Clear-SPMetadataWebServicePartitionData
Example
[image]

Removes all data for a site subscription on a metadata Web service application.

Clear-SPMetadataWebServicePartitionData -Identity <SPSiteSubscriptionPipeBind> -ServiceProxy <SPMetadataServiceProxyCmdletPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Specifies the site subscription configuration to remove.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a site subscription (for example, SiteSubscriptionConfig1); or an instance of a valid SiteSubscription object.

ServiceProxy

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceProxyCmdletPipeBind

Specifies the service proxy for the service application that contains the site subscription.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPMetadataServiceProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Clear-SPMetadataWebServicePartitionData cmdlet to clear all data for a site subscription on a metadata Web service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example
Copy Code

            Click here to

      submit feedback
             on this topic.


Export-SPMetadataWebServicePartitionData
See Also Example
[image]

Exports the data from a metadata Web service for a site subscription.

Export-SPMetadataWebServicePartitionData -Identity <SPSiteSubscriptionPipeBind> -ServiceProxy <SPMetadataServiceProxyCmdletPipeBind> -Path <String> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Specifies the site subscription to export.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a site subscription (for example, SiteSubscriptionConfig1); or an instance of a valid SiteSubscription object.

ServiceProxy

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceProxyCmdletPipeBind

Specifies the service proxy for the service application that contains the site subscription.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPMetadataServiceProxy object.

Path

Required

System.String

Specifies the path and file name for the file to create from the exported data.

The type must be a valid path in either of the following forms:

  • C:\folder_name\subscription_export

  • \\server_name\folder_name\formtemplate_name

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Export-SPMetadataWebServicePartitionData cmdlet to export the data from a metadata Web service that is associated with the specified site subscription.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example
Copy Code

  See Also
Reference
Clear-SPMetadataWebServicePartitionData
Import-SPMetadataWebServicePartitionData


Get-SPSiteSubscriptionMetadataConfig
[image]

Returns the site subscription configuration settings for a metadata service application.

Get-SPSiteSubscriptionMetadataConfig -Identity <SPSiteSubscriptionPipeBind> -ServiceProxy <SPMetadataServiceProxyCmdletPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Specifies the site subscription to read.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a site subscription (for example, SiteSubscriptionConfig1); or an instance of a valid SiteSubscription object.

ServiceProxy

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceProxyCmdletPipeBind

Specifies the proxy of the metadata service application for the site subscription.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPMetadataServiceProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPSiteSubscriptionMetadataConfig cmdlet to read the site subscription configuration settings for a specified metadata shared service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example
Copy Code

  See Also
Reference
Remove-SPSiteSubscriptionMetadataConfig
Set-SPSiteSubscriptionMetadataConfig


Get-SPTaxonomySession
Example
[image]

Returns a TaxonomySession object.

Get-SPTaxonomySession -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Site

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the SharePoint site mapped to the set of metadata term stores for the taxonomy session.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPTaxonomySession cmdlet to get a TaxonomySession object. A TaxonomySession object contains the set of metadata term stores for a taxonomy session.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example
Copy Code


Import-SPMetadataWebServicePartitionData
[image]

Restores the data for a site subscription.

Import-SPMetadataWebServicePartitionData -Identity <SPSiteSubscriptionPipeBind> -ServiceProxy <SPMetadataServiceProxyCmdletPipeBind> -Path <String> [-AssignmentCollection <SPAssignmentCollection>] [-OverwriteExisting <SwitchParameter>]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Specifies the site subscription to import.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a site subscription (for example, SiteSubscriptionConfig1); or an instance of a valid SiteSubscription object.

ServiceProxy

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceProxyCmdletPipeBind

Specifies the proxy for the service application that contains the site subscription.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPMetadataServiceProxy object.

Path

Required

System.String

Specifies the path and name of the subscription data file to import.

The type must be a valid path in either of the following forms:

  • C:\folder_name\formtemplate_name

  • \\server_name\folder_name\formtemplate_name

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

OverwriteExisting

Optional

System.Management.Automation.SwitchParameter

Determines whether to overwrite the existing site subscription data if it exists.

Detailed Description

Use the Import-SPMetadataWebServicePartitionData cmdlet to restore data for a site subscription to a metadata shared service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example
Copy Code

  See Also
Reference
Clear-SPMetadataWebServicePartitionData
Export-SPMetadataWebServicePartitionData


Remove-SPSiteSubscriptionMetadataConfig
[image]

Removes site subscription configuration settings.

Remove-SPSiteSubscriptionMetadataConfig -Identity <SPSiteSubscriptionPipeBind> -ServiceProxy <SPMetadataServiceProxyCmdletPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Specifies the site subscription for which to remove the metadata service application settings.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a site subscription (for example, SiteSubscriptionConfig1); or an instance of a valid SiteSubscription object.

ServiceProxy

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceProxyCmdletPipeBind

Specifies the local metadata service proxy for the service application containing the site subscription- specific settings.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPMetadataServiceProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Remove-SPSiteSubscriptionMetadataConfig cmdlet to remove the site subscription specific settings configuration settings for a specified metadata service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example
Copy Code

  See Also
Reference
Set-SPSiteSubscriptionMetadataConfig
Get-SPSiteSubscriptionMetadataConfig


Set-SPSiteSubscriptionMetadataConfig
[image]

Sets the site subscription configuration settings for a specified metadata service application.

Set-SPSiteSubscriptionMetadataConfig -Identity <SPSiteSubscriptionPipeBind> -ServiceProxy <SPMetadataServiceProxyCmdletPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-HubUri <String>] [-SyndicationErrorReportEnabled <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Specifies the site subscription for which to set the metadata service application settings.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a site subscription (for example, SiteSubscriptionConfig1); or an instance of a valid SiteSubscription object.

ServiceProxy

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceProxyCmdletPipeBind

Specifies the local metadata service proxy for the service application containing the site subscription-specific settings.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPMetadataServiceProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

HubUri

Optional

System.String

Specifies the URI of the syndication hub.

The type must be a valid URI, in the form file:\\server_name\sitedocs.

SyndicationErrorReportEnabled

Optional

System.Management.Automation.SwitchParameter

Enables error reporting for content type syndication.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPSiteSubscriptionMetadataConfig cmdlet to set the site subscription specific settings for a specified metadata shared service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example
Copy Code

  See Also
Reference
Remove-SPSiteSubscriptionMetadataConfig
Get-SPSiteSubscriptionMetadataConfig


Get-SPMetadataServiceApplication
Example
[image]

Returns the properties of a service application or a collection of service applications.

Get-SPMetadataServiceApplication -Identity <SPMetadataServiceCmdletPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceCmdletPipeBind

Specifies the service application to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application (for example, MetadataServiceApp1); or an instance of a valid WebServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPMetadataWebServiceApplication cmdlet to read the properties of a specified service application or the collection of service applications for the Metadata Service. If the Identity parameter is not specified, the cmdlet returns the collection of service applications in the Metadata Service.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code


Get-SPMetadataServiceApplicationProxy
Example
[image]

Returns the properties of a service application proxy or a collection of service application proxys.

Get-SPMetadataServiceApplicationProxy -Identity <SPMetadataServiceProxyCmdletPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceProxyCmdletPipeBind

Specifies he service application proxy to read.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPMetadataServiceProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPMetadataWebServiceProxy cmdlet to read the properties of a specified service application proxy or the collection of service application proxys for the Metadata Service. If the Identity parameter is not specified, the cmdlet returns the collection of service application proxys in the Metadata Service.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code


New-SPMetadataServiceApplication
[image]

Creates a new metadata service application.

New-SPMetadataServiceApplication -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> -Name <String> [-AdministratorAccount <String>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabasePassword <String>] [-DatabaseServer <String>] [-DatabaseUserName <String>] [-FailoverDatabaseServer <String>] [-FullAccessAccount <String>] [-HubUri <String>] [-PartitionMode <SwitchParameter>] [-RestrictedAccount <String>] [-SyndicationErrorReportEnabled <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the name of the service application to create. The name can contain a maximum of 128 characters.

The type must be a valid name of a service application; for example, MetadataServiceApp1.

AdministratorAccount

Optional

System.String

Specifies a set of user accounts or service accounts to use for creating and running the service application.

The type must be a valid name of an administrator account; for example, MyAdminAcct1.

ApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool to run the Web service in for the new metadata service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabaseCredentials

Optional

System.Management.Automation.PSCredential

Specifies the PSCredential object that contains the user name and password to be used to be used for database SQL authentication.

If SQL authentication is to be used then either the DatabaseCredentials must be specified OR both the DatabaseUserName and DatabasePassword must be set.

A valid PSCredential object.

DatabaseName

Optional

System.String

Specifies the name of the database to create for the new metadata service application.

The type must be a valid name of a SQL Server database; for example MeatadataDB1.

DatabasePassword

Optional

System.String

Specifies the password for the user specified in DatabaseUserName to be used for SQL authentication when accessing the metadata service application database.

A valid SQL password.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the database specified in DatabaseName.

The type must be a valid name of a SQL Server database; for example UsageLogDB1.

DatabaseUserName

Optional

System.String

Specifies the user name to use for connecting to the database for the metadata service application. Use this parameter only if SQL authentication is used to access the service application database.

The type must be a valid user name; for example, UserName1.

FailoverDatabaseServer

Optional

System.String

Specifies the name of the host server for the failover database server.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

FullAccessAccount

Optional

System.String

Specifies a set of application pool accounts, with full "read/write" permission, that can connect to this service application.

The type must be a list of valid application pool accounts.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

HubUri

Optional

System.String

Specifies the URI of the syndication hub.

The type must be a valid URI, in the form file:\\server_name\sitedocs.

PartitionMode

Optional

System.Management.Automation.SwitchParameter

Specifies that the Service Application restrict data by subscription.

Note This property cannot be changed after the SSA has been created.

RestrictedAccount

Optional

System.String

Specifies a set of application pool accounts with restricted access (that is, "read" permission to everything, but "write" permission only to open termsets) that can connect to this service application with restricted access (read all, but write only to open termsets).

The type must be a list of valid application pool service accounts.

SyndicationErrorReportEnabled

Optional

System.Management.Automation.SwitchParameter

Enables error reporting for content type syndication.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPMetadataWebServiceApplication cmdlet to create a new service application for the Metadata Service.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Set-SPMetadataWebServiceApplicationGet-SPMetadataWebServiceApplication


New-SPMetadataServiceApplicationProxy
[image]

Creates a new metadata service application proxy.

New-SPMetadataServiceApplicationProxy -Name <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ContentTypePushdownEnabled <SwitchParameter>] [-ContentTypeSyndicationEnabled <SwitchParameter>] [-DefaultKeywordTaxonomy <SwitchParameter>] [-DefaultProxyGroup <SwitchParameter>] [-DefaultSiteCollectionTaxonomy <SwitchParameter>] [-PartitionMode <SwitchParameter>] [-ServiceApplication <SPMetadataServiceCmdletPipeBind>] [-Uri <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the display name of the service application proxy to create. The name can contain a maximum of 128 characters.

The type must be a valid name of a service application proxy; for example, MetadataServiceProxy1.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

ContentTypePushdownEnabled

Optional

System.Management.Automation.SwitchParameter

Specifies that content type changes will be pushed down for syndication.

Default

Optional

System.Management.Automation.SwitchParameter

Specifies that the service application proxy is added to the farm's default proxy group.

DefaultKeywordTaxonomy

Optional

System.Management.Automation.SwitchParameter

Specifies that this service application's term store hold keywords for the Web application.

DefaultSiteCollectionTaxonomy

Optional

System.Management.Automation.SwitchParameter

Specifies that this term store hold all site collection term sets for the Web application.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

PartitionMode

Optional

System.Management.Automation.SwitchParameter

Specifies that the Service Application restrict data by subscription.

Note This property cannot be changed after the service application proxy has been created.

ServiceApplication

Optional

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceCmdletPipeBind

Specifies the local metadata service application to connect to. The service application must exist on the local farm and must be a type supported by the proxy.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application (for example, MetadataServiceApp1); or an instance of a valid WebServiceApplication object.

Uri

Optional

System.String

Specifies the URI of a remote metadata service application to connect to.

Note:
To specify the metadata service application that this proxy is connecting to, you must set only the URI parameter or only the ServiceApplication parameter.

The type must be a valid URL, in the form http://server_name.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Get-SPMetadataWebServiceProxy cmdlet to create a new metadata service application proxy.

Input Types

Return Types

SPMetadataServiceApplicationProxy

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Set-SPMetadataWebServiceProxyGet-SPMetadataWebServiceProxy


Set-SPMetadataServiceApplication
[image]

Sets the properties for a metadata service application.

Set-SPMetadataServiceApplication -Identity <SPMetadataServiceCmdletPipeBind> [-AdministratorAccount <String>] [-ApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabasePassword <String>] [-DatabaseServer <String>] [-DatabaseUserName <String>] [-FailoverDatabaseServer <String>] [-FullAccessAccount <String>] [-HubUri <String>] [-Name <String>] [-RestrictedAccount <String>] [-SyndicationErrorReportEnabled <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceCmdletPipeBind

Specifies the shared metadata service application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application (for example, MetadataServiceApp1); or an instance of a valid WebServiceApplication object.

AdministratorAccount

Optional

System.String

Specifies a set of user accounts or service accounts to use for creating and running the service application.

The type must be a valid name of an administrator account; for example, MyAdminAcct1.

ApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool to run the Web service in for the new metadata service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabaseCredentials

Optional

System.Management.Automation.PSCredential

Specifies the PSCredential object that contains the user name and password to be used to be used for database SQL authentication.

If SQL authentication is to be used then either the DatabaseCredentials must be specified OR both the DatabaseUserName and DatabasePassword must be set.

The type must be a valid PSCredential object.

DatabaseName

Optional

System.String

Specifies the name of the database to create for the new metadata service application.

The type must be a valid name of a SQL Server database; for example MeatadataDB1.

DatabasePassword

Optional

System.String

Specifies the password for the user specified in DatabaseUserName. Use this parameter only if SQL authentication is used to access the metadata service application database.

The type must be a valid SQL Server password.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the database specified in DatabaseName.

The type must be a valid name of a SQL Server database; for example UsageLogDB1.

DatabaseUserName

Optional

System.String

Specifies the user name to use for connecting to the database for the metadata service application. Use this parameter only if SQL authentication is used to access the service application database.

The type must be a valid user name; for example, UserName1.

FailoverDatabaseServer

Optional

System.String

Specifies the name of the host server for the failover database server.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

FullAccessAccount

Optional

System.String

Specifies a set of application pool accounts that can connect to this shared application with full read/write permission.

The type must be a list of valid application pool accounts.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Name

Optional

System.String

Specifies the name of the service application. The name can contain a maximum of 128 characters.

The type must be a valid name of a service application; for example, MetadataServiceApp1.

RestrictedAccount

Optional

System.String

Specifies a set of application pool accounts that can connect to this shared application with restricted access (read all, but write only to open termsets).

The type must be a list of valid application pool service accounts.

SyndicationErrorReportEnabled

Optional

System.Management.Automation.SwitchParameter

Enables error reporting for content type syndication.

HubUri

Optional

System.String

Specifies the URI of the syndication hub. Note that this parameter can be set only once.

The type must be a valid URI, in the form file:\\server_name\sitedocs.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use Set-SPMetadataWebServiceApplication to set the properties for a metadata service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Get-SPMetadataWebServiceApplicationNew-SPMetadataWebServiceApplication


Set-SPMetadataServiceApplicationProxy
[image]

Sets the properties for a metadata service application proxy.

Set-SPMetadataServiceApplicationProxy -Identity <SPMetadataServiceProxyCmdletPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ContentTypePushdownEnabled <SwitchParameter>] [-ContentTypeSyndicationEnabled <SwitchParameter>] [-DefaultKeywordTaxonomy <SwitchParameter>] [-DefaultProxyGroup <SwitchParameter>] [-DefaultSiteCollectionTaxonomy <SwitchParameter>] [-Name <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Taxonomy.Cmdlet.SPMetadataServiceProxyCmdletPipeBind

Specifies the service application proxy to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPMetadataServiceProxy object.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

ContentTypePushdownEnabled

Optional

System.Management.Automation.SwitchParameter

Specifies that the content type changes will be pushed down for syndication.

ContentTypeSyndicationEnabled

Optional

System.Management.Automation.SwitchParameter

Specifies that content type syndication is enabled for this proxy.

DefaultKeywordTaxonomy

Optional

System.Management.Automation.SwitchParameter

Specifies that this service application's term store hold keywords for the Web application.

DefaultSiteCollectionTaxonomy

Optional

System.Management.Automation.SwitchParameter

Specifies that this term store hold all site collection term sets for the Web application.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Name

Optional

System.String

Specifies the display name of the service application proxy. The name can contain a maximum of 128 characters.

The type must be a valid name of a service application proxy; for example, MetadataServiceProxy1.

DefaultProxyGroup

Optional

System.Management.Automation.SwitchParameter

Specifies that the service application proxy is added to the farm's default proxy group.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPMetadataWebServiceProxy cmdlet to set the properties for a metadata service application proxy.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Get-SPMetadataWebServiceProxyNew-SPMetadataWebServiceProxy