Get-SPContentDeploymentJob
See Also Example
[image]

Returns a content deployment job or a collection of content deployment jobs.

Get-SPContentDeploymentJob [-Identity <SPContentDeploymentJobPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Path <SPContentDeploymentPathPipeBind>]

Parameters

Parameter | Required | Type | Description
Identity | Optional | Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentJobPipeBind | Specifies the content deployment job to get. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example, DeployJob1); or an instance of a valid SPContentDeploymentJob object.
GarbageMan | Optional | Microsoft.SharePoint.PowerShell.SPGarbageMan |
Path | Optional | Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentPathPipeBind | Specifies that content deployment jobs for only the specified content deployment path are returned. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example; DeployPath1); or an instance of a valid SPContentDeploymentPath object.

Detailed Description

Use the Get-SPContentDeploymentJob cmdlet to read the specified content deployment job. If the Identity parameter is not specified, this cmdlet returns the collection of content deployment jobs on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

---------------EXAMPLE--------------
Copy Code
Get-SPContentDeploymentJob "Job 1"

This example returns the content deployment job called "Job 1".

See Also

Reference

New-SPContentDeploymentJob
Set-SPContentDeploymentJob

Click here to submit feedback on this topic.


Get-SPContentDeploymentPath
[image]

Returns a content deployment path or a collection of content deployment paths.

Get-SPContentDeploymentPath [-Identity <SPContentDeploymentPathPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentPathPipeBind

Specifies the content deployment path to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example, DeployJob1); or an instance of a valid SPContentDeploymentJob object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPContentDeploymentJob cmdlet to read the specified content deployment path. If the Identity parameter is not specified, this cmdlet returns the collection of content deployment paths on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------EXAMPLE--------------
Copy Code
Get-SPContentDeploymentPath "Path 1"

This example returns the content deployment path named, "Path1".

See Also

Reference

New-SPContentDeploymentPath
Set-SPContentDeploymentPath

Click here to submit feedback on this topic.


New-SPContentDeploymentJob
[image]

Creates a content deployment job.

New-SPContentDeploymentJob -Name <String> -SPContentDeploymentPath <SPContentDeploymentPathPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-EmailAddresses <String[]>] [-EmailNotifications <None | SendEmailOnFailure | SendEmailOnSuccess | SendEmailOnAlways>] [-HostingSupportEnabled <SwitchParameter>] [-IncrementalEnabled <SwitchParameter>] [-Schedule <String>] [-ScheduleEnabled <SwitchParameter>] [-Scope <SPWebPipeBind[]>] [-SqlSnapshotSetting <None | CreateNew>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the name of the new content deployment job.

The type must be a valid name of a content deployment job; for example, DeployJob1.

SPContentDeploymentPath

Required

Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentPathPipeBind

Specifies the deployment path to associate with the new deployment job.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example; DeployPath1); or an instance of a valid SPContentDeploymentPath object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Description

Optional

System.String

Specifies the description for the content deployment job. The name can be a maximum of 4096 alphanumeric characters.

The type must be a valid string.

EmailAddresses

Optional

System.String[]

Specifies the e-mail addresses of individuals who receive notification e-mails about this ContentDeploymentJob object.

The type must be a list of valid e-mail addresses.

EmailNotifications

Optional

Microsoft.SharePoint.Publishing.Administration.ContentDeploymentNotificationSettings

Specifies how e-mail notifications are sent about this ContentDeploymentJob object.

  • Never specifies that e-mail notifications will not be sent when a job succeeds or fails.

  • Success specifies that e-mail notifications will be sent if a content deployment job succeeds.

  • Failure specifies that e-mail notifications will be sent if a content deployment job fails.

  • Always specifies that e-mail notifications will be sent when a job succeeds or fails.

The type must be one of the following: Never, Success, Failure, or Always.

HostingSupportEnabled

Optional

System.Management.Automation.SwitchParameter

Enables special hosting- behavior. The default value is false.

Normally, a content deployment job is enabled or disabled using the Central Administration Web site. However, in the hosting case, the tenant administrator does not have permissions to access the Central Administration Webs site to configure their jobs. So when the HostingSupportEnabled parameter is set to true, the hoster creates the job, so that the tenants can enable/disable their deployment jobs from their tenant administration site.

IncrementalEnabled

Optional

System.Management.Automation.SwitchParameter

Specifies that only incremental changes are deployed to the destination site collection.

Schedule

Optional

System.String

Sets the schedule for the deployment job.

The type must be a valid SPSchedule object.

ScheduleEnabled

Optional

System.Management.Automation.SwitchParameter

Specify to enable the schedule for the deployment job. If the schedule is not enabled the job can be run only manually.

Scope

Optional

Microsoft.SharePoint.PowerShell.SPWebPipeBind[]

Sets the scope of the deployment job. SPSites passed in must exist in the current path of the source site collection. The default scope is the entire site collection. Valid values include a SPWeb object or an array of SPWeb objects.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Windows SharePoint Services Web site (for example, MySPSite1); or an instance of a valid SPWeb object.

SqlSnapshotSetting

Optional

Microsoft.SharePoint.Publishing.Administration.ContentDeploymentSqlSnapshotSetting

Backs up the SharePoint Services content database by using SQL Server.

The type must be one of the following:

  • None

  • CreateNew

    Note:
    The CreateNew value requires the Microsoft SQL Server Enterprise Edition to be installed.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Detailed Description

Use the New-SPContentDeploymentJob cmdlet to add a new content deployment job to a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
Get-SPContentDeploymentPath "Path 1" | New-SPContentDeploymentJob -Name "Deployment Job" -SPContentDeploymentPath $_ -IncrementalEnabled:$true -ScheduleEnabled:$false

This example creates a new content deployment job called "Deployment Job" using the deployment path "Path 1." The job is configured to be an incremental job with no schedule.

See Also

Reference

Set-SPContentDeploymentJob
Start-SPContentDeploymentJob

Click here to submit feedback on this topic.


New-SPContentDeploymentPath
[image]

Creates a new content deployment path.

New-SPContentDeploymentPath -DestinationCentralAdministrationURL <Uri> -DestinationSPSite <String> -DestinationSPWebApplication <Uri> -Name <String> -SourceSPSite <SPSitePipeBind> -SourceSPWebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Authentication <AppPool | Basic | Windows>] [-CompressionEnabled <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-DeploySecurityInformation <None | WssOnly | All>] [-DeployUserNamesEnabled <SwitchParameter>] [-Description <String>] [-EventReceiversEnabled <SwitchParameter>] [-KeepTemporaryFilesOptions <Never | Always | Failure>] [-PathAccount <PSCredential>] [-PathEnabled <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

DestinationCentralAdministrationURL

Required

System.Uri

Specifies the central administration URL for the destination farm.

The type must be a valid URL, in the form http://server_name.

DestinationSPSite

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the destination site collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

DestinationSPWebApplication

Required

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Specifies the destination Web application.

The type must be a valid URL, in the form http://server_name; a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of SharePoint Web application (for example, MyOfficeApp1); or an instance of a valid SPWebApplication object.

Name

Required

System.String

Specifies the name of the new content deployment path.

The type must be a valid name of a content deployment path; for example, DeployPath1.

SourceSPSite

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the source site collection for the deployment path. Must be a site collection in the source specified in the SourceSPWebApplication parameter.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

SourceSPWebApplication

Required

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Specifies the source Web application for the deployment path.

The type must be a valid URL, in the form http://server_name; a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of SharePoint Web application (for example, MyOfficeApp1); or an instance of a valid SPWebApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Authentication

Optional

Microsoft.SharePoint.Publishing.Administration.PathAuthenticationOption

Sets the Windows-based authentication type that the source front-end Web server uses to communicate with the destination Web application.

The type must be one of the following: AppPoolAccount, WindowsAuth, or BasicAuth.

CompressionEnabled

Optional

System.Management.Automation.SwitchParameter

Turns on compression during the export.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DeploySecurityInformation

Optional

Microsoft.SharePoint.Deployment.SPIncludeSecurity

Specifies the user and group information to include during the export operation for this content deployment path. The default value is All.

The type must be one of the following: None, All, or RoleDefinitionsOnly.

DeployUserNamesEnabled

Optional

System.Management.Automation.SwitchParameter

Description

Optional

System.String

Sets the description for the content deployment path. The description can contain a maximum of 4096 alphanumeric characters.

The type must be a valid string.

EventReceiversEnabled

Optional

System.Management.Automation.SwitchParameter

Turns on event receivers during import.

KeepTemporaryFilesOptions

Optional

Microsoft.SharePoint.Publishing.Administration.TemporaryFilesOption

Specifies that temporary files are kept after content deployment is finished.

The type must be one of the following: Never, Always, or OnFailure.

PathAccount

Optional

System.Management.Automation.PSCredential

Specifies the user ID that is an administrator on the Central Administration Web site on the destination farm.

The type must be a valid SharePoint user.

PathEnabled

Optional

System.Management.Automation.SwitchParameter

Enables the new content deployment path.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPContentDeploymentPath cmdlet to add a new content deployment path for a content deployment job.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-----------------EXAMPLE----------------------
Copy Code
$source = Get-SPSite http://source/
Copy Code
New-SPContentDeploymentPath -Name "Deployment Path" -SourceSPWebApplication $source.WebApplication -SourceSPSite $source DestinationCentralAdministrationURL http://destination:8080 -DestinationSPWebApplication http://destination -DestinationSPSite http://destination -KeepTemporaryFilesOptions "Failure" -PathEnabled:$true

This example creates a new deployment path called "Deployment Path" connecting a source at http://source to a destination at http://destination. The path is enabled and configured to keep temporary files on job failure.

See Also

Reference

Set-SPContentDeploymentPath
Get-SPContentDeploymentPath

Click here to submit feedback on this topic.


Set-SPContentDeploymentJob
[image]

Sets properties of a content deployment job.

Set-SPContentDeploymentJob -Identity <SPContentDeploymentJobPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-EmailAddresses <String[]>] [-EmailNotifications <None | SendEmailOnFailure | SendEmailOnSuccess | SendEmailOnAlways>] [-HostingSupportEnabled <SwitchParameter>] [-IncrementalEnabled <SwitchParameter>] [-Name <String>] [-Schedule <String>] [-ScheduleEnabled <SwitchParameter>] [-Scope <SPWebPipeBind[]>] [-SqlSnapshotSetting <None | CreateNew>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentJobPipeBind

Specifies the content deployment job to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example, DeployJob1); or an instance of a valid SPContentDeploymentJob object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Description

Optional

System.String

Specifies the description for the content deployment job. The name can be a maximum of 4096 alphanumeric characters.

The type must be a valid string.

EmailAddresses

Optional

System.String[]

Specifies the e-mail addresses of individuals who receive notification e-mails about this ContentDeploymentJob object.

The type must be a list of valid e-mail addresses.

EmailNotifications

Optional

Microsoft.SharePoint.Publishing.Administration.ContentDeploymentNotificationSettings

Specifies how e-mail notifications are sent about this ContentDeploymentJob object.

  • Never specifies that e-mail notifications will not be sent when a job succeeds or fails.

  • Success specifies that e-mail notifications will be sent if a content deployment job succeeds.

  • Failure specifies that e-mail notifications will be sent if a content deployment job fails.

  • Always specifies that e-mail notifications will be sent when a job succeeds or fails.

The type must be one of the following: Never, Success, Failure, or Always.

HostingSupportEnabled

Optional

System.Management.Automation.SwitchParameter

Enables special hosting- behavior. The default value is false.

Normally, a content deployment job is enabled or disabled using the Central Administration Web site. However, in the hosting case, the tenant administrator does not have permissions to access the Central Administration Webs site to configure their jobs. So when the HostingSupportEnabled parameter is set to true, the hoster creates the job, so that the tenants can enable/disable their deployment jobs from their tenant administration site.

IncrementalEnabled

Optional

System.Management.Automation.SwitchParameter

Specifies that only incremental changes are deployed to the destination site collection.

Name

Optional

System.String

Specifies the name of the new content deployment job.

The type must be a valid name of a content deployment job; for example, DeployJob1.

Schedule

Optional

System.String

Sets the schedule for the deployment job.

The type must be a valid SPSchedule object.

ScheduleEnabled

Optional

System.Management.Automation.SwitchParameter

Enables the schedule for the deployment job. If the schedule is not enabled the job can be run only manually.

Scope

Optional

Microsoft.SharePoint.PowerShell.SPWebPipeBind[]

Sets the scope of the deployment job. SPSite objects passed in must exist in the current path of the source site collection. The default scope is the entire site collection. Valid values include a SPWeb object or an array of SPWeb objects.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Windows SharePoint Services Web site (for example, MySPSite1); or an instance of a valid SPWeb object.

SqlSnapshotSetting

Optional

Microsoft.SharePoint.Publishing.Administration.ContentDeploymentSqlSnapshotSetting

Backs up the SharePoint Services content database by using SQL Server.

The type must be one of the following: None or CreateNew.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPContentDeploymentJob cmdlet to set the properties of content deployment job.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-----------------EXAMPLE------------------
Copy Code
Get-SPContentDeploymentJob "Job 1" | Set-SPContentDeploymentJob -Schedule "hourly between 0 and 59" -ScheduleEnabled:$true

This example sets the deployment job called "Job 1" to run hourly.

See Also

Reference

New-SPContentDeploymentJob
Start-SPContentDeploymentJob

Click here to submit feedback on this topic.


Set-SPContentDeploymentPath
[image]

Sets properties of a content deployment path.

Set-SPContentDeploymentPath -Identity <SPContentDeploymentPathPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Authentication <AppPool | Basic | Windows>] [-CompressionEnabled <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-DeploySecurityInformation <None | WssOnly | All>] [-DeployUserNamesEnabled <SwitchParameter>] [-Description <String>] [-DestinationCentralAdministrationURL <Uri>] [-EventReceiversEnabled <SwitchParameter>] [-KeepTemporaryFilesOptions <Never | Always | Failure>] [-Name <String>] [-PathAccount <PSCredential>] [-PathEnabled <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentPathPipeBind

Specifies the content deployment path to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example; DeployPath1); or an instance of a valid SPContentDeploymentPath object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Authentication

Optional

Microsoft.SharePoint.Publishing.Administration.PathAuthenticationOption

Sets the Windows-based authentication type that the source front-end Web server uses to communicate with the destination Web application.

The type must be one of the following: AppPoolAccount, WindowsAuth, or BasicAuth.

CompressionEnabled

Optional

System.Management.Automation.SwitchParameter

Turns on compression during the export.

DeploySecurityInformation

Optional

Microsoft.SharePoint.Deployment.SPIncludeSecurity

Specifies the user and group information to include during the export operation for this content deployment path. The default value is All.

The type must be one of the following: None, All, or RoleDefinitionsOnly.

DeployUserNamesEnabled

Optional

System.Management.Automation.SwitchParameter

Specify to enable event receivers during import.

Description

Optional

System.String

Sets the description for the content deployment path. The description can contain a maximum of 4096 alphanumeric characters.

The type must be a valid string.

DestinationCentralAdministrationURL

Optional

System.Uri

Specifies the central administration URL for the destination farm.

The type must be a valid URL, in the form http://server_name.

EventReceiversEnabled

Optional

System.Management.Automation.SwitchParameter

Turns on event receivers during import.

KeepTemporaryFilesOptions

Optional

Microsoft.SharePoint.Publishing.Administration.TemporaryFilesOption

Specifies that temporary files are kept after content deployment is finished.

The type must be one of the following: Never, Always, or OnFailure.

Name

Optional

System.String

Specifies the name of the content deployment path.

The type must be a valid name of a content deployment path; for example, DeploymentPath1.

PathAccount

Optional

System.Management.Automation.PSCredential

Specifies the user Id that is an administrator on the Central Administration Web site on the destination farm.

The type must be a valid SharePoint user.

PathEnabled

Optional

System.Management.Automation.SwitchParameter

Enables the content deployment path.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPContentDeploymentPath cmdlet to set the properties of content deployment path for a content deployment job.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------EXAMPLE-------------
Copy Code
Get-SPContentDeploymentPath "Path 1" | Set-SPContentDeploymentPath -PathEnabled:$false

This example sets the deployment path "Path 1" to be disabled.

See Also

Reference

Get-SPContentDeploymentPath
New-SPContentDeploymentPath

Click here to submit feedback on this topic.


Start-SPContentDeploymentJob
[image]

Starts a content deployment job.

Start-SPContentDeploymentJob -Identity <SPContentDeploymentJobPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DeploySinceTime <String>] [-TestEnabled <SwitchParameter>] [-WaitEnabled <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentJobPipeBind

Specifies the content deployment job to run.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example, DeployJob1); or an instance of a valid SPContentDeploymentJob object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DeploySinceTime

Optional

System.String

Specifies the date to use to determine what changes to export incrementally. This parameter is ignored if the deployment job type is full.

The type must be a valid DateTime type, in the form 2010,12,05.

TestEnabled

Optional

System.Management.Automation.SwitchParameter

Runs the content deployment job in test mode only.

WaitEnabled

Optional

System.Management.Automation.SwitchParameter

Specifies that the command is not returned until the operation is complete.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Start-SPContentDeploymentJob cmdlet to start a content deployment job.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------EXAMPLE-----------------
Copy Code
Get-SPContentDeploymentPath "Path 1" | New-SPContentDeploymentJob -Name "Job 1" -SPContentDeploymentPath $_ -IncrementalEnabled:$true -ScheduleEnabled:$false | Start-SPContentDeploymentJob

This example creates content deployment job "Job 1" and runs it immediately.

See Also

Reference

New-SPContentDeploymentJob
Set-SPContentDeploymentJob
Get-SPContentDeploymentJob

Click here to submit feedback on this topic.


Remove-SPContentDeploymentJob
Example
[image]

Removes a content deployment job.

Remove-SPContentDeploymentJob -Identity <SPContentDeploymentJobPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentPathPipeBind

Specifies the content deployment job to remove. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example; DeployJob1); or an instance of a valid SPContentDeploymentJob object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Remove-SPContentDeploymentJob cmdlet to remove a content deployment job.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.


Remove-SPContentDeploymentPath
Example
[image]

Removes a content deployment path.

Remove-SPContentDeploymentPath -Identity <SPContentDeploymentPathPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.Publishing.Cmdlet.SPContentDeploymentPathPipeBind

Specifies the content deployment path to remove. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a content deployment job (for example; DeployPath1); or an instance of a valid SPContentDeploymentPath object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Remove-SPContentDeploymentPath cmdlet to remove a content deployment path

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.