Get-SPAccessServiceApplication
See Also Example
[image]

Returns an Access Services application or a collection of Access Services applications.

Get-SPAccessServiceApplication [-Identity <SPAccessServiceApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Access.Server.PowerShell.SPAccessServiceApplicationPipeBind

Specifies the Access Services application to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of the service application proxy (for example, ServiceAppProxy1); or an instance of a valid SPAccessServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPAccessServiceApplication cmdlet to retrieve an Access Services application. If an identity is not specified, the cmdlet returns the collection of Access Services applications that are in the farm. If the properties returned from this cmdlet are changed, these changes affect all computers in the farm that are running this Access Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------EXAMPLE 1----------------
Copy Code
Get-SPAccessServiceApplication -identity "MyAccessService"

This example displays an Access Services application named "MyAccessService"

------------EXAMPLE 2----------------
Copy Code
Get-SPAccessServiceApplication | where {$_.macrostackdepthmax -gt 10000}

This example displays every Access Services application that is running in the farm, which allows more than 10,000 calls that a macro can make to other macros.

------------EXAMPLE 3----------------
Copy Code
Get-SPAccessServiceApplication

This example displays every Access Services application in the farm.

See Also

Reference

Set-SPAccessServiceApplication

Click here to submit feedback on this topic.


New-SPAccessServiceApplication
See Also Example
[image]

Creates a new instance of an Access Services application.

New-SPAccessServiceApplication -Name <String> -SPIisWebServiceApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-CacheTimeout <Int32>] [-ColumnsMax <Int32>] [-Confirm [<SwitchParameter>]] [-Default <SwitchParameter>] [-FormsMax <Int32>] [-ListsMax <Int32>] [-MacroIterationsInLoopMax <Int32>] [-MacrosMax <Int32>] [-MacroStackDepthMax <Int32>] [-NonRemotableQueriesAllowed <SwitchParameter>] [-OrderByMax <Int32>] [-OuterJoinsAllowed <SwitchParameter>] [-OutputCalculatedColumnsMax <Int32>] [-Partition <SwitchParameter>] [-QueriesMax <Int32>] [-RecordsInTableMax <Int32>] [-ReportsMax <Int32>] [-RequestDurationMax <Int32>] [-RowsMax <Int32>] [-SessionMemoryMax <Int32>] [-SessionsPerAnonymousUserMax <Int32>] [-SessionsPerUserMax <Int32>] [-SourcesMax <Int32>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the display name of the Access Service application to create. The name can contain a maximum of 128 characters and cannot contain the comma (,), equals (=) , and colon (:) characters.

The type must be a valid name of an Access Services application; for example, AccessSrvApp1.

SPIisWebServiceApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool to run the Web service in for the new Access Services application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL of a search application, in the form http://server_name; or an instance of a valid SPIisWebServiceApplicationPool object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

CacheTimeout

Optional

System.Int32

Specifies the number of seconds that a data cache will remain active on Access Services with no user activity. Valid values include: -1, cache never times out; 0, the cache expires at the end of a single request; 1 to 2073600, cache remains active from 1 second to 24 days.

The type must be the integers -1, 0, or an integer in the range of 1 to 2073600 (24 days). The default value is 300.

ColumnsMax

Optional

System.Int32

Specifies the maximum number of columns that a list involved in a query can contain, or that the output of the query can contain. The default value is 30.

An integer in the range of 1 to 255

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Default

Optional

System.Management.Automation.SwitchParameter

Specifies that the service application is associated with Web applications by default.

FormsMax

Optional

System.Int32

Specifies the maximum number of forms allowed per Access Service application. Valid values include: -1, no limit, and 1 to any positive integer.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

ListsMax

Optional

System.Int32

Specifies the maximum number of SharePoint lists that can be used as part of an Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

MacroIterationsInLoopMax

Optional

System.Int32

The maximum number of iterations allowed in a loop for macros in an Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 5000.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

MacrosMax

Optional

System.Int32

Specifies the maximum number of macros allowed in an Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

MacroStackDepthMax

Optional

System.Int32

Specifies the maximum number of calls that can be placed on the stack at one time by macros in an Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 50000.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

NonRemotableQueriesAllowed

Optional

System.Management.Automation.SwitchParameter

Specifies that queries that cannot be remoted to the database tier can run.

OrderByMax

Optional

System.Int32

Specifies the maximum number of Order By clauses in the query. The default value is 4.

The type must be an integer in the range of 1 to 8.

OuterJoinsAllowed

Optional

System.Management.Automation.SwitchParameter

Specifies that left and right outer joins are supported. Inner joins are always supported.

OutputCalculatedColumnsMax

Optional

System.Int32

Specifies the maximum number of calculated columns that can be included in the output as a part of the query. Calculated columns in the underlying SharePoint list are not included. The default value is 10.

The type must be an integer in the range of 1 to 32.

Partition

Optional

System.Management.Automation.SwitchParameter

Restricts this service to behave uniquely on a partitioned set of site collections. This property cannot be changed after the Access Service application is provisioned.

QueriesMax

Optional

System.Int32

Specifies the maximum number of data queries that are allowed for Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

RecordsInTableMax

Optional

System.Int32

Specifies the maximum number of records allowed for a table in the Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500000.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

ReportsMax

Optional

System.Int32

Specifies the maximum number of reports allowed for the Access Services application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

RequestDurationMax

Optional

System.Int32

Specifies the maximum number of seconds that a request to perform an operation can use before the request times out. Valid values include: -1, no limit, 1 to 2073600, cache remains active 1 second to 24 days. The default value is 30.

The type must be the integer -1, or an integer in the range of 1 to 2073600 (24 days)

RowsMax

Optional

System.Int32

Specifies the maximum number of rows that a list involved in a query can have, or that the output of the query can have. The default value is 50000.

The type must be an integer in the range of 1 to 200000.

SessionMemoryMax

Optional

System.Int32

Specifies the maximum allowable size, in megabytes (MB), of an individual session. Valid values include: 0, disable property, 1 to 4095. The default value is 64.

The type must be the integer 0, or an integer in the range of 1 to 4095.

SessionsPerAnonymousUserMax

Optional

System.Int32

Specifies the maximum number of sessions allowed per user. If this maximum is reached, the oldest session will be deleted when a new session is started. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 10.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

SessionsPerUserMax

Optional

System.Int32

Specifies the maximum number of sessions allowed per user. If this maximum is reached, the oldest session will be deleted when a new session is started. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 10.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

SourcesMax

Optional

System.Int32

Specifies the maximum number of lists that may be used as input to a query at one time. The default value is 8.

The type must be an integer in the range of 1 to 20.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

TemplateMax

System.Int32

The maximum allowable size in megabytes (MB) allowed for Access Templates (ACCDT) uploaded into the Solution Gallery. Valid values: -1(no limit), from 1 to any positive integer.

ApplicationLogMaxSize

System.Int32

The maximum number of records for an Access Services Application Log list. Valid valies: -1 to maxint. 0 means none are allowed. The default value is 3000.

Detailed Description

Use the New-SPAccessServiceApplication cmdlet to create and provision a new instance of an Access Services application. Also use the New-SPAccessServiceApplication cmdlet to provision a new instance of an Access Services application by using settings that were created from a previous backup operation. After creating a new Access Services application, use the Set-SPAccessServiceApplication cmdlet to modify its global settings.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------EXAMPLE 1----------------
Copy Code
New-SPAccessServiceApplication -Name "MyAccessService" " -SPIisWebServiceApplicationPool MyAppPool

This example provisions a new instance of Access Services with the name "MyAccessService" that runs under the application pool name, "MyAppPool

------------EXAMPLE 2----------------
Copy Code
New-SPAccessServiceApplication -Name "MyAccessService" -SPIisWebServiceApplicationPool MyAppPool -SessionsPerUserMax 25

This example provisions a new instance of Access Services with the name "MyAccessService" that runs under the application pool named "MyAppPool" that allows up to 25 sessions per user on each back end application server machine that runs Access Services.

See Also

Reference

Set-SPAccessServiceApplication
Get-SPAccessServiceApplication

Click here to submit feedback on this topic.


Set-SPAccessServiceApplication
See Also Example
[image]

Sets global properties of an existing Access Services application.

Set-SPAccessServiceApplication [-Identity <SPAccessServiceApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-CacheTimeout <Int32>] [-ColumnsMax <Int32>] [-Confirm [<SwitchParameter>]] [-FormsMax <Int32>] [-ListsMax <Int32>] [-MacroIterationsInLoopMax <Int32>] [-MacrosMax <Int32>] [-MacroStackDepthMax <Int32>] [-NonRemotableQueriesAllowed <SwitchParameter>] [-OrderByMax <Int32>] [-OuterJoinsAllowed <SwitchParameter>] [-OutputCalculatedColumnsMax <Int32>] [-QueriesMax <Int32>] [-RecordsInTableMax <Int32>] [-ReportsMax <Int32>] [-RequestDurationMax <Int32>] [-RowsMax <Int32>] [-SessionMemoryMax <Int32>] [-SessionsPerAnonymousUserMax <Int32>] [-SessionsPerUserMax <Int32>] [-SourcesMax <Int32>] [-SPIisWebServiceApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Access.Server.PowerShell.SPAccessServiceApplicationPipeBind

Specifies the Access Services application to update.

The type must be a valid name of an Access Services application; for example, AccessSrvApp1.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

CacheTimeout

Optional

System.Int32

Specifies the number of seconds that a data cache will remain active on Access Services with no user activity. Valid values include: -1, cache never times out; 0, the cache expires at the end of a single request; 1 to 2073600, cache remains active from 1 second to 24 days.

The type must be the integers -1, 0, or an integer in the range of 1 to 2073600 (24 days). The default value is 300.

ColumnsMax

Optional

System.Int32

Specifies the maximum number of columns that a list involved in a query can contain, or that the output of the query can contain. The default value is 30.

An integer in the range of 1 to 255.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

FormsMax

Optional

System.Int32

Specifies the maximum number of forms allowed per Access Service application. Valid values include: -1, no limit, and 1 to any positive integer.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

ListsMax

Optional

System.Int32

Specifies the maximum number of SharePoint lists that can be used as part of an Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

MacroIterationsInLoopMax

Optional

System.Int32

The maximum number of iterations allowed in a loop for macros in an Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 5000.

The integer -1, or an integer in the range of 1 to MaxInt

MacrosMax

Optional

System.Int32

The maximum number of iterations allowed in a loop for macros in an Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 5000.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

MacroStackDepthMax

Optional

System.Int32

Specifies the maximum number of calls that can be placed on the stack at one time by macros in an Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 50000.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

NonRemotableQueriesAllowed

Optional

System.Management.Automation.SwitchParameter

Specifies that queries that cannot be remoted to the database tier can run.

OrderByMax

Optional

System.Int32

Specifies the maximum number of Order By clauses in the query. The default value is 4.

The type must be an integer in the range of 1 to 8.

OuterJoinsAllowed

Optional

System.Management.Automation.SwitchParameter

Specifies that left and right outer joins are supported. Inner joins are always supported.

OutputCalculatedColumnsMax

Optional

System.Int32

Specifies the maximum number of calculated columns that can be included in the output as a part of the query. Calculated columns in the underlying SharePoint list are not included. The default value is 10.

The type must be an integer in the range of 1 to 32.

QueriesMax

Optional

System.Int32

Specifies the maximum number of data queries that are allowed for Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

RecordsInTableMax

Optional

System.Int32

Specifies the maximum number of records allowed for a table in the Access Service application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500000.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

ReportsMax

Optional

System.Int32

Specifies the maximum number of reports allowed for the Access Services application. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 500.

The type must be the integer -1, or an integer in the range of 1 to MaxInt.

RequestDurationMax

Optional

System.Int32

Specifies the maximum number of seconds that a request to perform an operation can use before the request times out. Valid values include: -1, no limit, 1 to 2073600, cache remains active 1 second to 24 days. The default value is 30.

The type must be the integer -1, or an integer in the range of 1 to 2073600 (24 days)

RowsMax

Optional

System.Int32

Specifies the maximum number of rows that a list involved in a query can have, or that the output of the query can have. The default value is 50000.

The type must be an integer in the range of 1 to 200000.

SessionMemoryMax

Optional

System.Int32

Specifies the maximum allowable size, in megabytes (MB), of an individual session. Valid values include: 0, disable property, 1 to 4095. The default value is 64.

The type must be the integer 0, or an integer in the range of 1 to 4095.

SessionsPerAnonymousUserMax

Optional

System.Int32

The maximum number of sessions allowed per user. If this maximum is reached, the oldest session will be deleted when a new session is started. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 10.

The integer -1, or an integer in the range of 1 to MaxInt

SessionsPerUserMax

Optional

System.Int32

Specifies the maximum number of sessions allowed per user. If this maximum is reached, the oldest session will be deleted when a new session is started. Valid values include: -1, no limit, and 1 to any positive integer. The default value is 10.

The integer -1, or an integer in the range of 1 to MaxInt.

SourcesMax

Optional

System.Int32

Specifies the maximum number of lists that may be used as input to a query at one time. The default value is 8.

The type must be an integer in the range of 1 to 20.

SPIisWebServiceApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the name of the IIS application pool of the Access Service application.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPAccessServiceApplication cmdlet to set the global runtime properties of an existing Access Services application. The changes made to the properties by using this cmdlet affect all machines in the farm that are running this Access Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------EXAMPLE 1------------------
Copy Code
Set-SPAccessServiceApplication -identity "MyAccessService" -requestDurationMax 100

This example sets the Access Services application named 'MyAccessService" to let requests take up to 100 seconds before they timeout

------------EXAMPLE 2------------------
Copy Code
Get-SPAccessServiceApplication | Set-SPAccessServiceApplication -sessionsPerUserMax 5

This example sets every Access Service application in the farm to allow up to 5 sessions per user on each back end application server computer that is running Access Services.

First, every Access Service application is retrieved, and then a new value is set using the Set-SPAccessServiceApplication cmdlet.

------------EXAMPLE 3------------------
Copy Code
Get-SPAccessServiceApplication | where {$_.rowsMax -gt 50000 } | Set-SPAccessServiceApplication -rowsMax 50000

This example sets every Access Service application in the farm that allows more than 50,000 rows to be returned from, or used in, a query, and then set the service application to only allow up to 50,000 rows.

First, every Access Service application that has rows greater than 50,000 is retrieved, and then a new value is set using the Set-SPAccessServiceApplication cmdlet.

See Also

Reference

Get-SPAccessServiceApplication

Click here to submit feedback on this topic.