Team Foundation Server install guide

[image]

Team Foundation Server install guide
Send Feedback

Team Foundation Server 2013, Update 4

This is the install guide for the latest release of Team Foundation Server 2013 - Update 4 (TFS 2013.4). For details on changes in Update 4, see the release notes.

To apply TFS 2013.4 to an existing installation of TFS, you upgrade. (This is different from applying Visual Studio's updates, which work more like traditional patches.) You can also install TFS 2013.4 the same as you would any other TFS 2013 release. To get started quickly with TFS, see the next section.

Get started quickly with Team Foundation Server

Team Foundation Server with SQL Server Express

If you want to install Team Foundation Server with the least amount of preliminary work, use the basic configuration, which comes with SQL Server Express and requires the least amount of set up. The TFS installation wizard can configure everything for you in about 10 minutes, and you can ignore most of the instruction in this guide. You won't get a report server or SharePoint, which means no HTML reports for your software projects, and no website to trade Office documents and collaborate, but you will have basic bug tracking, version control, and a website on the TFS server with team productivity features.

Tip Tip

If you do use the basic configuration, consider installing it on a server operating system. If you install it on a server, you can always add a report server and SharePoint later, if you find your team needs them. If you install TFS on a client OS, adding these features is blocked, and you would have to first migrate TFS to a server OS.

Step 1 Verify that your operating system and hardware meet the requirements for Team Foundation Server. For client operating systems, you can use 32-bit or 64-bit. For servers, you must use 64-bit.

For more information: System requirements for Team Foundation Server.

Step 2 Run the Team Foundation Sever install (tfs_server.exe) from the product DVD, and then use the basic configuration wizard to configure your installation.

Choose the basic install

For more information: Run Team Foundation Server installation and Configure Team Foundation Server using the basic configuration.

Tip Tip

After you set up TFS, the next thing to do is use Visual Studio to create a team project.

Install or upgrade Team Foundation Server

Install Team Foundation Server

You can install Team Foundation Server and all its prerequisites on one or more servers. This is scenario is for teams that want the full experience of TFS with options for SharePoint and an HTML report server, or teams that want to customize their installation.

Upgrade Team Foundation Server

You can upgrade from an earlier release of Team Foundation Server.

Customize your ALM environment

Add a build server or proxy to your ALM environment. Integrate Project Server or add an installation of SharePoint Products to your Team Foundation Server deployment.

Set up Team Foundation Build Service

Team Foundation Build Service can help you automatically build and share code.

Use an answer file and a command-line tool to configure TFS

Not everyone will need this tool. Use it to configure TFS on different machines. For example, you might want to configure multiple build servers using the same answer file, which would help ensure the same configuration across multiple servers.

This tool does not perform the initial installation of TFS but configures it (according to your specifications) after the TFS bits are present on the computer.

How to: Set up remote SharePoint Products for Team Foundation Server

If you don't want to run SharePoint Products on the same computer as Team Foundation Server, you can use Team Foundation Server Extensions for SharePoint Products to integrate SharePoint with Team Foundation Server. You can also use the TFS installation wizard to install SharePoint Foundation 2013.

How to: Create a Team Foundation server farm (high availability)

You can add an application-tier server to an existing deployment of Team Foundation Server to build redundancy into your deployment or to restore a failed application-tier server.

How to: Install Team Foundation Proxy and set up a remote site

You might save bandwidth by installing Team Foundation Server Proxy, which caches version control files so that developers working at remote locations don't have to repeatedly download the same files.

How to: Add Project Server to Team Foundation Server

If you have team members that use Project Server, you can use Team Foundation Server Extensions for Project Server to integrate Project Server with Team Foundation Server.

Install Release Management

Release Management provides a continuous deployment solution that makes release cycles repeatable, visible, and more efficient by automating deployments through every environment from Team Foundation Server (TFS) to production.


Install Team Foundation Server

[image]

Install Team Foundation Server
See Also Send Feedback
Installing on more than one server

If you intend to have SQL Server and TFS on the same server, then you might be able to use the TFS standard installation wizard, which is designed to streamline the number of decisions you have to make during TFS installation. To use the standard wizard, you have to have SQL Server set up on the default instance (as we did in the SQL Server installation topic) and the reporting features must be installed. We recommend that you have 24 GB of RAM to run SharePoint on the same server as SQL Server. If you're okay with all these requirements and with the default TFS options¹ (SharePoint Foundation is installed), then use the standard wizard.

If you want more control over installation options, use the advanced configuration.

Tip Tip

¹If you want to see the default options for TFS, use the advanced wizard and don't change any of the default settings. You'll get the same TFS installation as if you had used the standard wizard.

What will I need?

Whether you use standard or advanced TFS install wizards, you'll need at least one domain account for the report reader account. TFS uses this account to generate reports. If you let us install SharePoint, we use this same account for the Farm Admin account in SharePoint.

Tip Tip

The report reader account only needs the Allow log on locally permission, which all domain accounts have by default.

Why use the advanced wizard?

If you want to change the default installation options for Team Foundation Server, use the advanced wizard, which lets you configure Team Foundation Server on multiple servers and change many other options.

Why use advanced? The standard installation might not fit your needs. You might want to customize a single server installation or install Team Foundation Server and its configuration database on different servers. Perhaps you already have SQL Server or SharePoint Products running in your organization and you'd like to use one of these installations to host team projects or the data for Team Foundation Server. If you use the optional features that require prerequisite server software, these installations can also be hosted on different servers. If you use multiple servers, you can distribute the load between Team Foundation Server and the configuration database, or you can ensure that prerequisite server software for features such as reporting or the portal site is running on capable hardware.

Don't confuse the multiple server installation with the robust scale-out features that Team Foundation Server offers. These scale-out features include the ability to create a Team Foundation Server farm and add a team project collection to an instance of SQL Server that was not part of the original deployment of Team Foundation Server. However, these scale-out features are not part of this scenario. This scenario offers you guidance for an initial deployment of Team Foundation Server that takes advantage of configurable installation options, such as installing TFS on more than one server. For more information about how to add an application-tier server to your deployment of Team Foundation Server, see How to: Create a Team Foundation server farm (high availability).

Tip Tip

A multiple-server installation requires an Active Directory domain and domain accounts or the Network Service account. You cannot use local accounts for service accounts.

To install Team Foundation Server

Step 1 Verify that the operating system and hardware meet the requirements for Team Foundation Server and all its prerequisites. You must use a 64-bit server if you install TFS on a server operating system. Determine the report reader account you will use for Team Foundation Server.

For more information, see System requirements for Team Foundation Server, Accounts required for installation of Team Foundation Server.

Step 2 Install a supported version of SQL Server. You must install these SQL Server features: Database Engine, Full-Text and Semantic Extractions for Search. To get HTML reports from your TFS team projects, add these features: Analysis Services, and Reporting Services - Native

SQL R2 installation

For more information, see: SQL Server requirements for Team Foundation Server, Manually install SQL Server for Team Foundation Server

Step 3 You have a lot of options for SharePoint. If you have SQL Server and TFS on running on the same server, your best alternative might be to install SharePoint on a different server to minimize competition for resources. If you know you want SharePoint Server, you should install and configure it before you install TFS. Remember that you can always skip SharePoint integration altogether by using the TFS advanced wizard. TFS doesn't require SharePoint.

Configure SharePoint Server

For more information, see SharePoint Products requirements for Team Foundation Server, Manually Install SharePoint products for Team Foundation Server

Tip Tip

You can also verify and use an existing SharePoint deployment that meets the TFS requirements for SharePoint. If your existing SharePoint is not on the same server as where you'll install TFS, you'll want to first install the TFS SharePoint extensions on the SharePoint site. See How to: Install Remote SharePoint Products for Team Foundation Server.

Step 4 Run the Team Foundation Server install from the product DVD and then use one of the configuration wizards to configure your installation. Use the standard wizard if you have SQL Server on the default instance, and TFS will install SharePoint Foundation 2013 for you. For everything else, use the advanced wizard. See, "Why use the advanced wizard?" earlier.

Select TFS standard configuration

For more information, see Run Team Foundation Server installation, Configure Team Foundation Server using the advanced configuration, Configure Team Foundation Server using the standard configuration

See Also

Concepts

Set up Team Foundation Build Service


System requirements for Team Foundation Server

[image]

System requirements for Team Foundation Server
See Also Send Feedback

Before you install Team Foundation Server, make sure your system meets the software requirements described in this topic. You must use a 64-bit server operating system to install Team Foundation Server. We support 32-bit client operating systems, but 32-bit server operating systems are no longer supported. Team Foundation Server offers an option to install SharePoint 2013 as a companion program for managing team documents, but doing so will substantially increase your hardware requirements. See SharePoint Hardware Requirements below.

You can also find information about hardware in this topic, but these are just recommendations, not requirements. In general, the bigger your team, the greater your need for robust hardware. Eventually you will require more than one server to distribute the load.

Required software

TFS requires a supported operating system and SQL Server product. The following tables offer compatibility for TFS 2013 and earlier TFS products to help you plan upgrades. For a comprehensive breakdown of major and minor TFS dependencies, including client compatibility and support options, see the TFS 2013 Compatibility and Dependencies white paper. For more information about TFS upgrade requirements, see TFS upgrade requirements.

Supported operating systems

You can install Team Foundation Server on the following operating systems:

Server Operating System | TFS 2013 | TFS 2012 | TFS 2010
64-bit versions of Windows Server 2012 R2 (Essentials, Standard, Datacenter) | Supported | Supported | Not supported
64-bit versions of Windows Server 2012 | Supported | Supported | Not supported
64-bit versions of Windows Server 2008 R2 (Standard, Enterprise, Datacenter) ¹ | Supported (minimum SP1) | Supported | Supported
Windows Server 2008 | Not supported | Supported (minimum SP2) | Supported
Windows Server 2003 R2 | Not supported | Not supported | Supported
Windows Server 2003 | Not supported | Not supported | Supported (minimum SP2)
Windows Small Business Server 2011 (Standard, Essentials, Premium Add-On) ¹ | Supported (minimum SP1) | Supported | Not supported
Windows Home Server 2011 | Not supported | Supported | Not supported

¹ If you are installing Team Foundation Server or SQL Server on Windows Server 2008 R2, you must have the .NET Framework 3.5 installed. On Windows Server 2008 R2, you can install the .NET Framework 3.5 by using the Add Features Wizard from Server Manager. For more information, see the following page on the Microsoft website: Adding Server Roles and Features.

Team Foundation Server does not support the Server Core installation option. (What is Server Core?)

Client Operating System | TFS 2013 | TFS 2012 | TFS 2010
Windows 8.1 (Basic, Professional, Enterprise) | Supported | Supported | Not supported
Windows 8 | Supported | Supported | Not supported
Windows 7 (Home Premium, Professional, Enterprise, Ultimate) | Supported (minimum SP1) | Supported | Supported
Windows Vista | Not supported | Not supported | Supported (minimum SP2)

You can install Team Foundation Server on a client computer that is running one of the operating systems in the table. However, client operating systems do not support integration with SharePoint Products, reporting, or the ability to run TFS proxy. This means no website to trade Office documents and collaborate, no HTML reports for your software projects, and no capability to proxy version control files. If you want to use any of these features, you must install Team Foundation Server on a server operating system.

The TFS standard installation wizard is not supported on client operating systems because that wizard configures SharePoint.

Supported SQL Server products

You can use one of the following SQL Server products:

SQL Server | TFS 2013 | TFS 2012 | TFS 2010
SQL Server 2014 ¹ (Express, Standard, Enterprise) | Supported | Not supported | Not supported
SQL Server 2012 | Supported (minimum SP1²) | Supported | Not supported
SQL Server 2008 R2 | Not supported | Supported | Supported
SQL Server 2008 | Not supported | Not supported | Supported

¹ TFS 2013 with update 2 (TFS 2013.2) adds support for SQL Server 2014.

² We strongly recommend installing CU2 or higher on top of SQL Server 2012 SP1.

For more information about SQL Server requirements for TFS, see SQL Server requirements for Team Foundation Server.

Optional software requirements

You can use the following supported products with TFS:

SharePoint | TFS 2013 | TFS 2012 | TFS 2010
SharePoint 2013 (Foundation, Standard, Enterprise) | Supported | Supported | Not supported
SharePoint 2010 (Foundation, Standard, Enterprise) | Supported | Supported | Not supported
Office SharePoint Server 2007 (Standard, Enterprise) | Not supported | Supported | Supported
Windows SharePoint Services 3.0 ¹ | Not supported | Supported | Supported

¹ Windows SharePoint Services is the equivalent of the Foundation editions in current SharePoint products. In 2010, Microsoft began using a different product naming strategy.

For more information about SharePoint requirements for TFS, see SharePoint Products requirements for Team Foundation Server.

Project Server | TFS 2013 | TFS 2012 | TFS 2010
Project Server 2013 | Supported | Supported | Not supported
Project Server 2010 | Supported (minimum SP1) | Supported (minimum SP1) | Not supported
Project Server 2007 | Not supported | Supported (minimum SP2) | Supported (minimum SP2)

For more information about Project Server requirements for TFS, see Project Server requirements for Team Foundation Server.

Hardware Recommendations

The following table includes hardware guidelines for teams installing Team Foundation Server without SharePoint Products. Small shops can run Team Foundation Server with the basic configuration, which requires only 1GB RAM and 8 GB of hard disk space.

Number of users | Configuration | CPU | Memory | Hard disk
Fewer than 250 users | Single-server (Team Foundation Server and the Database Engine on the same server). | 1 single core processor at 2.13 GHz | 2 GB | 1 disk at 7.2k rpm (125 GB)
250 to 500 users | Single-server. | 1 dual core processor at 2.13 GHz | 4 GB | 1 disk at 10k rpm (300 GB)
500 to 2,200 users | Dual-server (Team Foundation Server and the Database Engine on different servers). This row is for Team Foundation Server. | 1 dual core Intel Xeon processor at 2.13 GHz | 4 GB | 1 disk at 7.2k rpm (500 GB)
 | This row is for the Database Engine with 500 to 2,200 users. | 1 quad core Intel Xeon processor at 2.33 GHz | 8 GB | SAS disk array at 10k rpm (2 TB)
2,200 to 3,600 users | Dual-server. This row is for Team Foundation Server. | 1 quad core Intel Xeon processor at 2.13 GHz | 8 GB | 1 disk at 7.2k rpm (500 GB)
 | This row is for the Database Engine with 2,200 to 3,600 users. | 2 quad core Intel Xeon processors at 2.33 GHz | 16 GB | SAS disk array at 10k rpm (3 TB)

Build service hardware requirements

The build service has the same operating system requirements as TFS. Sometimes it makes sense to run the build service on a machine separate from the TFS application tier. Hardware requirements for the build service are the same as the operating system on which it is running. However, you can optimize build service performance by tailoring the hardware specs of your build machine to the types of builds your team will use. For more information, see System requirements for Team Foundation Build Service

SharePoint Hardware Requirements

If you install SharePoint Products, you will need more robust hardware than what is listed in the previous table. For example, SharePoint Foundation 2013, which Team Foundation Server can install for you, requires a 64-bit 4 core CPU and a base minimum of 8 GB of system memory. If you install SharePoint 2013 on a server that is also running SQL Server (as required by the TFS standard configuration), SharePoint recommends that you have 24 GB of system memory, If you have only 8 GB, the Team Foundation installer will warn that you should have 10 GB, but you will be able to finish the install.

Go here for complete SharePoint hardware requirements:

  • Hardware and software requirements for SharePoint 2013 (SharePoint Foundation 2013/SharePoint Server 2013

  • Hardware and software requirements (SharePoint Foundation 2010)

  • Hardware and software requirements (SharePoint Server 2010)

For a complete list of supported versions of SharePoint, go here: SharePoint Products Requirements for Team Foundation Server

Virtualization

Microsoft supports the virtualization of Team Foundation Server in supported virtualization environments. For more information, see the following pages on the Microsoft website:

  • Microsoft server software and supported virtualization environments

  • Support policy for Microsoft software running in non-Microsoft hardware virtualization software

  • Support partners for non-Microsoft hardware virtualization software

  • Server Virtualization (officially supported products)

Compatibility and Team Foundation Server 2013

The links below provide guidance about browser compatibility, the numerous clients available for working with this version of TFS (and which can perform a set of given tasks), and backwards compatibility with previous TFS clients, especially with regard to new features in this version of TFS.

  • Comprehensive breakdown of major and minor TFS dependencies, including client compatibility and support options TFS 2013 Compatibility and Dependencies white paper

  • Browser support, including compatibility between Team Foundation Clients and Team Foundation Server

  • Supported TFS clients sorted by various tasks

More information about Team Foundation Server requirements for companion products: SQL Server, SharePoint Products, and Project Server

SQL Server requirements for Team Foundation Server

Team Foundation Server requires SQL Server, but you have many options, including an option to let Team Foundation Server install SQL Server Express for you.

SharePoint Products requirements for Team Foundation Server

Team Foundation Server doesn't require SharePoint Products. If you want to use SharePoint Products, you have many options, including the option to let Team Foundation Server install SharePoint Foundation 2010 for you.

Project Server requirements for Team Foundation Server

Team Foundation Server doesn't require Project Server, but if you want to use it, you must use a supported version.

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements


Run Team Foundation Server installation

[image]

Run Team Foundation Server installation
See Also Send Feedback

Follow these steps to run the Team Foundation Server installer. With this process, you copy Team Foundation Server to your file system and configure the features appropriate for your operating system and deployment.

For remote SharePoint Products deployments, you can use a special version of the installation program that installs only the Team Foundation Server extensions on the SharePoint Products server. This keeps the server running SharePoint Products tidy. You don't need to run this special installer on the server running Team Foundation Server, where the extensions are installed by default with most installations of Team Foundation Server.

Tip Tip

If you have a remote portal for your SharePoint Products, you must install Team Foundation Server Extensions for SharePoint Products on the remote portal. If multiple servers are running SharePoint Products in a web farm, you must install and configure these extensions on every server in that farm.

Required Permissions

To perform this procedure, you must be a member of the Administrators security group.

To run the Team Foundation Server installer

  1. Insert the Team Foundation Server DVD in the drive and launch the tfs_server.exe file to begin the installation.

    Tip Tip

    If you don't want to install all of Team Foundation Server on the server that is running SharePoint Products, launch the tfs_sharePointExtensions.exe file from the SharePoint Extensions folder to install only the Team Foundation Server Extensions for SharePoint Products.

  2. On the license terms dialog box, accept the license terms and then choose Install Now. If you want to install Team Foundation Server to a specific location in the file system, choose the browse button (...) next to the default install location.

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements
How to: Set up remote SharePoint Products for Team Foundation Server


Configure Team Foundation Server using the advanced configuration

[image]

Configure Team Foundation Server using the advanced configuration
See Also Send Feedback

The advanced configuration for Team Foundation Server lets you customize most settings. Although you can run the advanced configuration on either a client or a server operating system, if you use a client, you won't be able to add a portal or reporting to your deployment.

Installing on more than one server

If you use advanced on a client operating system, you don't need any domain accounts. On a server, you must have at least one domain account, which you can use for all of the following identities:

  • The service account for Team Foundation Server.

  • The report reader account for creating HTML reports.

  • The service account for new installations of SharePoint Foundation.

For more information about accounts, see Accounts required for installation of Team Foundation Server.

Tip Tip

Access the Team Foundation Server Configuration tool by launching Team Foundation Server Administration Console, choosing Application Tier, and then choosing Configure Installed Features.

Required permissions

You must be a member of the Administrators security group on the server on which you will install TFS. If you plan to configure reporting, you must also be a member of the Administrators security group on the server that is running SQL Server Reporting Services. If you plan to configure SharePoint, you must be a member of the Farm Administrators group on the SharePoint administration site. If you did not install the Database Engine that will host the configuration database or a database administrator manages the instance of SQL Server that you are using, you must be a member of sysadmin Server role in SQL Server.

Tip Tip

If you or your database administrator want a better understanding of the required SQL Server permissions, see the following page on the Microsoft website: Database Permissions Required to Configure TFS.

To configure Team Foundation Server using the advanced configuration

  1. In the Team Foundation Server Configuration tool, start the advanced wizard and read the Welcome screen.

  2. In SQL Server Instance, type the name of the server that is running SQL Server or the named instance that will host the configuration databases.

    Specify a database server

    You also have these options:

    • Select This instance is a SQL AlwaysOn Availability Group to specify that the SQL Server instance is an Availability Group Listener (AGL) and its availability group will host the TFS databases created during set up. See Use SQL Server Always On Availability Groups with Team Foundation Server.

    • In Server Database Label, type a label string, which is then embedded into all three of the default database names.

      This technique enables you to use a single instance of SQL Server to host multiple configuration databases.

    • Select the Use pre-existing empty database(s) check box, and then specify databases that are hosted on the server that is named in SQL Server Instance.

      You must create names for these databases by using the default naming structure, with or without a label. You can find the default naming structure under Team Foundation Server Databases.

    • Test the connectivity to SQL Server.

    Specify any optional database server details

  3. Choose Use a system account. To use a domain or local account, choose Use a user account. User accounts require a password. To test the user account and password combination, choose Test.

    Specify a system account

    Network Service is the default value for the TFS service account.

    Tip Tip

    If your report server and SharePoint servers are not installed on the same server as TFS, you should add the account you use here to the Farm Administrators group (for SharePoint) and the content manager group on the report server. If you're installing TFS on the same server as the report server and SharePoint, this account is added to these groups automatically.

  4. Choose NTLM as an Authentication Method. If you choose Negotiate (Kerberos), Kerberos authentication is attempted first. If that attempt fails, NTLM authentication is used.

    NTLM is the default setting.

  5. Accept the default Port number. Otherwise, enter a different one. This is the port number clients will use to connect to TFS.

    Specify listener port

    The default value for Port is 8080.

  6. Set up your file cache location. Make sure you have at least 50 Gb of free space. If you use a drive other than your Windows drive, TFS will perform better.

    File cache folder

  7. Accept the default virtual directory or specify something else.

    Specify virtual directory

    The default value for Virtual Directory is tfs.

  8. Under Web Site, note the TFS Site URL, which is dynamically assembled based on your input in Port and IIS Virtual Directory. Developers will use this URL to connect to TFS.

    Take note of the site URL.

    On a client operating system, you must skip to step 10. You can't add a portal or reporting (steps 8 and 9) on a client operating system.

  9. Choose Configure Reporting for use with Team Foundation Server to use reporting. Otherwise, clear the check box to skip it.

    Choose to configure reporting

    1. Type the name of the server that is running SQL Server Reporting Services in Reporting Services Instance and choose Populate URLs.

      The URLs for the report server and its management site appear in the drop-down lists for Report Server URL and Report Manager URL.

      Choose Populate URLs

    2. Make sure that the values displayed are the URLs that you want to use for TFS.

      Double check you have the right URLs

    3. Type the name of the server that is running SQL Server Analysis Services in SQL Analysis Services Instance.

      To test the connectivity to SQL Server, choose Test.

      Specify the instance of Analysis servies

    4. Type the name and password of the report reader account. To test the user account and password combination, choose Test.

      Specify the report reader
      Tip Tip

      If you specified a user account for the service account of TFS in step 3, you must select the Use a different account than the Team Foundation Server service account for the report reader account check box to use a different account.

    Note Note

    After installation is complete, add your administrators to the Team Foundation Content Managers group on the server that hosts SQL Server Reporting Services. Otherwise they might have problems, such as being blocked by a TF218027 error when trying to create a team project.

  10. Choose Configure SharePoint Products for use with Team Foundation Server to use SharePoint. Otherwise, clear the check box to skip it.

    Choose to configure SharePoint

    If you chose to configure SharePoint, then you have two choices-either install and configure SharePoint on this machine or specify a SharePoint location. Here are the details:

    • Install and configure SharePoint on this machine

      1. Choose Install and configure SharePoint on this machine.

        Choose to install SharePoint

      2. Choose the big Install SharePoint Foundation 2013 button. When the install finishes, choose Next.

        Choose the big button

        Note Note

        If the SharePoint installation requires a reboot, you might need to reenter some of the information you previously entered in this wizard.

      3. Type a user account and password for the service account for SharePoint Foundation. If you specified a user account for the service account of TFS in step 3, you must select the Use a different account than the Team Foundation Server service account for the SharePoint farm check box to use a different account.

        Use the report reader account

    • Specify a SharePoint location

      1. Choose Specify a SharePoint location and then choose Next.

      2. In Site URL, type the URL for the SharePoint web app.

      3. In Administration URL, type the URL for the SharePoint Central Administration site. To test connectivity to each of these URLs, choose Test.

  11. Select the Create a new team project collection check box to create a collection, or clear that check box to skip that step.

    If you create a collection, accept the default values, or type a new name and description.

    Create a new team project collection

  12. On the Review page, review the settings, and choose Next to let the wizard validate your configuration.

    Readiness checks validate your system

    If you run into a problem, you can use the detailed results to identify the issue. If you can, fix the issue, and then choose the link to run the ready checks over again. If you resolved the problem, you'll be able to configure TFS in the next step.

    Use detailed results to troublshoot any problems

  13. Choose Configure.

    The wizard applies configuration settings. This process might take several minutes.

    The wizard applies your configurations

  14. At the success screen, choose Next. Review the results of the next success screen, including the connection URL for TFS and any details about the installation.

    Take note of your connection URL

  15. Choose Close. In the TFS Configuration Center, note that TFS extensions for SharePoint have already been installed, if you installed TFS and SharePoint on the same server.

    After you close the TFS Configuration Center, the Team Foundation Server Administration Console appears.

See Also

Concepts

How to: Set up remote SharePoint Products for Team Foundation Server
Set up Team Foundation Build Service


Configure Team Foundation Server using the standard configuration

[image]

Configure Team Foundation Server using the standard configuration
See Also Send Feedback
Installing on a single-server

You can configure Team Foundation Server to use the standard configuration. To complete this procedure, you must have a domain account.

For more information about accounts, see Accounts required for installation of Team Foundation Server

Tip Tip

You can access the Team Foundation Server Configuration tool by launching Team Foundation Server Administration Console, choosing Application Tier, and then choosing Configure Installed Features.

Required Permissions

You must be a member of the Administrators security group on the server that is running TFS.

To configure Team Foundation Server by using the standard configuration

  1. Choose Standard Single Server, and then choose Start Wizard.

    The Team Foundation Server Standard Configuration wizard appears.

  2. Read the Welcome screen, and then choose Next.

  3. In User Account, enter the name of the service account that you want to use for SharePoint Foundation.

    This account is also used as the report reader account to create reports.

  4. In Password, enter the password for this service account, and then choose Next.

  5. Choose Install SharePoint Foundation 2013.

    Note Note

    If the SharePoint installation requires a reboot, you might need to reenter some of the information you previously entered in this wizard.

  6. After Team Foundation Server installs SharePoint Foundation, choose Next.

  7. Review the information, and then choose Next.

    The wizard validates your configuration.

    If you run into a problem, you can use the detailed results to identify the issue. If you can, fix the issue, and then choose the link to run the ready checks over again. If you resolved the problem, you'll be able to configure TFS in the next step.

  8. Choose Configure.

    The wizard applies configuration settings.

  9. Choose Next, Close, Close.

    The Team Foundation Server Administration Console appears.

See Also

Concepts

Install Team Foundation Server


Configure Team Foundation Server using the basic configuration

[image]

Configure Team Foundation Server using the basic configuration
See Also Send Feedback
Team Foundation Server with SQL Server Express

You can configure Team Foundation Server to use the basic configuration, which enables you to use SQL Server Express.

Tip Tip

You can access the Team Foundation Server Configuration tool by launching Team Foundation Server Administration Console, choosing Application Tier, and then choosing Configure Installed Features.

Required Permissions

To perform this procedure, you must be a member of the Administrators security group on the server that is running Team Foundation Server.

To configure Team Foundation Server by using the basic configuration

  1. In the Team Foundation Server Configuration tool, choose Basic, Start Wizard.

  2. Read the Welcome screen and decide whether to participate in the program.

  3. Choose Install SQL Server Express to host the configuration database on an instance of SQL Server Express.

    Tip Tip

    You don't have to use SQL Server Express. You can also choose Use an existing SQL Server Instance and then type the name of the server that is running a supported version of SQL Server or the named instance that will host the configuration database in SQL Server Instance. Choose Test to test the connectivity to SQL Server.

  4. Review your configurations settings and then choose Next.

    The wizard validates your configuration. If you run into a problem, you can use the detailed results to identify the issue. If you can, fix the issue, and then choose the link to run the ready checks over again. If you resolved the problem, you'll be able to configure TFS in the next step.

  5. Choose Configure.

    The wizard applies configuration settings. After the wizard completes, close it.

    Tip Tip

    Did you get error TF255356 you tried install TFS Basic or Express? It's a misleading error message. Read this blog post to recover: TF255356: Known Issue with Configuring TFS 2013 RTM Express and Basic

  6. In the TFS Configuration tool, choose Configure Team Foundation Build Service, Start Wizard.

  7. Read the Welcome screen, and then choose Next. The build service will automatically connect to TFS.

    If you connect to a collection that previously hosted resources for the build service on this server, you're prompted to restore your settings. If you want the same number of controllers and agents, choose Yes and then skip to step 9. (If you're upgrading from TFS 2012 or later, we'll save any other build service customizations you made, too.) If you want to configure this build server with different resources, choose No.

  8. Choose Use the default setting and specify one build agent.

  9. Choose Use a system account to run the build service as Network Service or Local Service.

    Tip Tip

    You can also run the build service as a domain or local account. Enter the account name and password and choose Test.

  10. Review your settings and then choose Next. If you run into a problem, use the detailed results to fix the issue, and then run the checks again.

  11. Choose Configure.

    The wizard applies configuration settings. After the wizard completes, close it.

    The Team Foundation Server Administration Console appears.

Tip Tip

After you set up TFS and the build service, the next thing to do is create a team project.

See Also

Concepts

Team Foundation Server install guide


SQL Server requirements for Team Foundation Server

[image]

SQL Server requirements for Team Foundation Server
See Also Send Feedback

Team Foundation Server 2013 requires SQL Server 2012 with Service Pack 1 or SQL Server 2014.

You have multiple options:

  • You can use the basic configuration of Team Foundation Server, which comes with the required version of SQL Server Express.

    Limitations of SQL Server Express (stackoverflow post)

  • You can install one of the supported editions.

  • You can verify and use an existing installation.

Regardless of which option you choose, your instance of SQL Server must meet the following requirements:

Supported editions

  • SQL Server 2014¹ (Express,² Standard,² and Enterprise editions)

  • SQL Server 2012 with SP1³ or newer service pack (Express,² Standard,² and Enterprise Editions)

Tip: TFS Express only supports SQL Server Express instances that use the default instance name (SQLExpress).

Required for Team Foundation Server

  • Database Engine Services

  • Full-Text and Semantic Extractions for Search

Required for reporting

  • Reporting Services - Native

  • Analysis Services

Collation settings

  • Must be accent sensitive

  • Must not be case sensitive

  • Must not be Binary

  • Must not be Binary - code point

For more information, see SQL Server Collation Requirements for Team Foundation Server.

Authentication

Windows authentication

Service account

You can use a domain account or a built-in account.

Tip Tip

For TFS installations that require running SQL Server on dedicated hardware, hardware recommendations are available. For more information, see System requirements for Team Foundation Server

Your limits on database read operations

Microsoft does not support any read operations against the TFS databases that originate from queries, scripts, .dll files, and so on, not provided by Microsoft or its support teams. If Microsoft Support determines that those read operations prevent them from solving your problem, the entire database will be unsupported. To return the database to a supported state, all unsupported read operations must stop.

¹ SQL Server 2014 has increased hardware requirements compared with previous versions. Certain configurations might hurt TFS performance. For more information, read TFS 2013 Update 2: performance considerations using SQL Server 2014.

² Limited or no SQL Server High Availability support.

³ If you're using SQL Server 2012 with SP1, we recommend you also apply cumulative update 2 on top of SP1 to address a critical SQL Server bug around resource consumption. This isn't a requirement because the bug only affects a small number of instances, but we wanted you to be aware of it. If you don't apply CU2, you should apply a SQL Server hotfix (KB2793634) to addresses another (different) issue where SQL Server 2012 with SP1 might request an excessive amount of restarts.

SQL Server High Availability features Supported by Team Foundation Server

SQL Server 2012 offers a new high availability (HA) feature that requires a Team Foundation Server-specific configuration. For more information, see: Use SQL Server Always On Availability Groups with Team Foundation Server

SQL Server HA feature | TFS support | Requires TFS Configuration
Always On Failover Cluster Instances | Yes | No
Always On Availability Groups | Yes | Yes
SQL Mirroring | Yes | No
SQL Replication | No | No
SQL Log Shipping | No | No

How to install SQL Server for Team Foundation Server

Manually install SQL Server for Team Foundation Server

Provides steps for how to install SQL Server for Team Foundation Server. Use these steps whether you are installing on a single server, across multiple servers, or for any combination of the two.

Verify SQL Server for Team Foundation Server

Provides steps to verify that a SQL Server instance is ready to work with Team Foundation Server.

More SQL Server Tasks for Team Foundation Server

Provisioning SQL Server Databases for Team Foundation Server

Describes how to create empty databases where Team Foundation Server can host its data on SQL Server.

Work with SQL Server Named Instances

What is a SQL Server named instance and how would I use it?

Conceptual Information about SQL Server and Team Foundation Server

Understanding SQL Server and SQL Server Reporting Services

Pulling it all together: Interactions between Team Foundation Server and SQL Server.

Team Foundation Server Databases

A comprehensive list of the databases used to store Team Foundation Server data.

SQL Server Reporting Services Roles

A brief explanation of how roles work in SQL Server Reporting Services.

SQL Server Collation Requirements for Team Foundation Server

Explains the Team Foundation Server requirements for SQL Server collation settings.

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements


Manually install SQL Server for Team Foundation Server

[image]

Manually install SQL Server for Team Foundation Server
See Also Send Feedback

The steps in this topic are for installing SQL Server 2012 enterprise edition, but you can use the same steps for installing the standard edition. The steps for SQL 2014 are also very similar to these. We'll install all the SQL Server 2012 features that TFS requires on the same server as TFS, but this isn't a requirement. TFS is very flexible with regard to SQL Server topologies. See One Server or Two?

Tip Tip

You can also use an existing installation of SQL Server for TFS, but to do this you'll need the SQL Server administrator to grant you a lot of administrative credentials. You must be a member of the sysadmin Server role in SQL Server to install and configure TFS. Why does TFS need so much privilege on the SQL Server? (blog post)

One server or two?

If you're going to use only one server for TFS, you can safely ignore this section.

If you plan to have more than 500 users accessing your TFS server, the recommendation is to put SQL Server on a second server. This splits the load between TFS and its configuration database. You could install all the SQL Server features that TFS requires on the second server, or you could split the features up. Some teams like to put the report server on the TFS server, and the Database engine, Full text search, and Analysis services on the second server, splitting HTTP traffic from SQL Server traffic.

There are many different topology choices you could make. In general, TFS allows you to install SQL Server instance features (Database engine, Reporting Services, Analysis Services) on different servers. Here are some caveats for various SQL Server topologies to keep in mind:

  • TFS requires the Database Engine and Full text search features on the same instance.

  • TFS reporting is optional, but if you want reporting you must install Reporting Services and Analysis Services (each can go on its own server, if you want that topology). If you skip reporting, you don't have to set up Reporting Services or Analysis Services.

  • If you don't install any SQL Server instances on the TFS server, you must at least install the SQL Server feature Client Tools Connectivity on TFS. If you have a SQL Server instance on the TFS server (either the Database Engine, Reporting Services or Analysis Services) you don't have to install Client Tools Connectivity.

If you want to install SQL Server features on different servers, run the SQL Server installation on each server where you want to install a feature. Use the same instructions below for each installation, but at step 9, only install the features that you require.

Tip Tip

A multiple-server installation of TFS requires an Active Directory domain and domain accounts or the Network Service account. You cannot use local accounts for service accounts.

To install SQL Server

Required Permissions

You must be a member of the Windows Administrators security group on the server on which you are installing SQL Server. To manually configure a report server, you must also be a member of the Windows Administrators security group on the SQL Server that hosts the report server database, if this instance of SQL Server is not on your report server.

Tip: If you are installing SQL Server 2014 on Windows Server 2012 or Windows Server 2012 R2, you must have the .NET Framework 3.5 installed. You can install the .NET Framework 3.5 by using the Add Features Wizard from Server Manager. For more information, see the following page on the Microsoft website: Adding Server Roles and Features (Windows 2012/Windows 2012 R2), Adding Server Roles and Features (Windows Server 2008 R2)

  1. Insert the installation DVD for a supported version of SQL Server and launch setup.exe.

    More information: SQL Server requirements for Team Foundation Server.

  2. On the SQL Server Installation Center page, choose Installation, and then choose New installation or add features to an existing installation.

    New installation of SQL Server

  3. On the Setup Support Rules page, choose OK.

  4. On the Product Key page, type your product key or specify a free edition.

  5. On the License Terms page, accept the license agreement.

  6. On the Setup Support Rules page, choose Next.

    Windows Firewall warning
    Tip Tip

    A Windows Firewall warning might appear, but you can safely ignore this warning if you're planning to also install TFS on this server. TFS automatically adds an exception to Windows Firewall for SQL Server, if both servers (TFS and SQL Server) are installed on the same machine. If you're installing TFS on some other server, you'll want to open a port for SQL Server in Windows Firewall on this server (blog post).

    For more information about SQL Server ports required for Team Foundation Server, see Ports required for installation of Team Foundation Server.

  7. On the Setup Role page, choose SQL Server Feature Installation.

  8. On the Feature Selection page, select the check boxes for one or more of the following components, depending on the topology you intend to use:

    • Database Engine Services (required)

    • Full-Text and Semantic Extractions for Search (required)

    • Analysis Services (required for reporting)

    • Reporting Services - Native (required for reporting)

    • Client Tools Connectivity (required only if no other SQL Server components are installed on the server that is running Team Foundation Server - not pictured)

    • Management Tools - Basic ¹ (not pictured)

  9. On the Installation Rules page, choose Next.

  10. On the Instance Configuration page, choose Default instance. If you choose Named instance, type the name of the instance..

  11. On the Disk Space Requirements page, choose Next.

  12. On the Server Configuration page, accept the defaults or enter the name of a domain account or NT AUTHORITY\NETWORK SERVICE in Account Name for every service. If you specify a domain account, type its password in Password. If you use NT AUTHORITY\NETWORK SERVICE, leave Password blank.

  13. In the Startup Type column, verify that Automatic appears for all services that you can edit, and then click Next.

    Server Configuration (details)
    Note Note

    Are you using a non-English version of SQL Server? The default collation settings for U.S. English meet the requirements for Team Foundation Server. If you're not using English, you can set collation settings for the Database Engine on this page. For more information, see SQL Server Collation Requirements for Team Foundation Server.

  14. If you selected the Database Engine Services check box in step 8, on the Database Engine Configuration page, choose Windows authentication mode, choose Add Current User. Otherwise skip to the next step.

    Database Engine Configuration

  15. If you selected the Analysis Services check box in step 8, on the Analysis Services Configuration page, choose Add Current User. Otherwise skip to the next step.

    Analysis Services Configuration

  16. If you selected the Reporting Services check box in step 8, on the Reporting Services Configuration page, choose Install and configure. If that option is unavailable, choose Install only.

    Reporting Services Configuration

    If you had to choose Install only, you might be planning to have the report server and Team Foundation Server on different servers. This is a supported topology, but you will have to manually configure the report server after you finish installing SQL Server. Use these instructions: Configure Report Server Manually

    Note Note

    You should not choose Reporting Service SharePoint Integrated Mode. TFS does not support this configuration mode.

  17. (Optional) On the Error and Usage Reporting page, specify whether to send information about errors.

  18. On the Installation Rules page, choose Next.

  19. On the Ready to Install page, review the list of components to be installed, and then choose Install.

¹ To install Team Foundation Server, you do not need to install Management Tools (Basic or Complete) on the same computer as SQL Server. However, you must use the SQL Server Management Studio management tool to verify your installation of SQL Server.

Configure Report Server Manually

No automatic configuration of Reporting Services

SQL Server 2008 R2 no SSRS auto configure

If you don't install the Database Engine on the same server as Reporting Services, you must manually configure your report server using the steps below after you finish SQL Server installation.

In the unlikely case that Reporting Services is on the same server as Team Foundation Server and you have not configured the report server, you are prompted during Team Foundation Server installation to complete the report server configuration, starting on step 3.

To manually configure a report server

  1. Launch Reporting Services Configuration Manager.

    The Reporting Services Configuration Connection dialog box appears.

  2. In Server Name, enter the name of the report server. If you are using an instance name, enter the name of the instance in Report Server Instance. Choose Connect.

  3. On the Reporting Services Configuration Manager page, choose Start if the Report Service status reads Stopped.

  4. In the navigation bar, choose Web Service URL.

  5. On the Web Service URL page, choose Apply to accept the default values in the Virtual Directory, IP Address, and TCP Port boxes.

  6. In the navigation bar, choose Database.

  7. On the Report Server Database page, choose Change Database.

    The Report Server Database Configuration Wizard appears.

  8. On the Action page of the wizard, choose Create a new report server database.

  9. On the Database Server page of the wizard, enter the name of a local or remote instance of SQL Server to host the database for the report server in Server Name.

  10. On the Database page of the wizard, accept the default values in the Database Name, Language, and Native Mode boxes.

  11. In Credentials, accept the default values in the Authentication Type, User name, and Password boxes.

  12. On the Summary page of the wizard, verify your information.

  13. On the Progress and Finish page of the wizard, choose Finish.

  14. In the navigation bar for Reporting Services Configuration Manager, choose Report Manager URL.

  15. On the Report Manager URL page, choose Apply to accept the default value in the Virtual Directory box.

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements
SQL Server Collation Requirements for Team Foundation Server


Understanding SQL Server and SQL Server Reporting Services

[image]

Visual Studio Application Lifecycle Management
Understanding SQL Server and SQL Server Reporting Services
See Also Send Feedback

You can manage Visual Studio Team Foundation Server more easily if you understand SQL Server, SQL Server Reporting Services, and how they both interact with Team Foundation Server. This topic focuses specifically on the interactions between SQL Server, SQL Server Reporting Services, and Team Foundation Server.

Interactions between Team Foundation Server and SQL Server

The logical data tier for Team Foundation depends on SQL Server and consists of several SQL Server databases. By default, these databases have the following names:

  • TFS_Configuration, which contains all the configuration information for the resources for Team Foundation Server

  • TFS_Warehouse, which is the database for all reports in Team Foundation Server

  • TFS_Analysis, which is a multi-dimensional database that stores the aggregated data from team project collections

  • TFS_CollectionName, the individual databases for team project collections (each collection has its own database).

This logical tier can be located on one or more physical servers, and it can be distributed across a SQL Server cluster of servers.

The following diagram illustrates the logical architecture of a deployment of Team Foundation Server that is integrated with both SQL Server Reporting Services and SharePoint Products:

Database relationships with SharePoint Products

One advantage of storing all your data in a database is that it simplifies data management because you don't have to back up individual client computers. If you are familiar with backing up SQL Server databases, you will find backing up and restoring Team Foundation Server databases equally familiar.

Tip Tip

Team Foundation Server requires that collation settings are case insensitive, are accent sensitive, and are not binary. If you want to use an existing installation of SQL Server with Team Foundation Server, you must verify that the collation settings meet these requirements. If they do not, installation of Team Foundation Server will fail. For more information, see SQL Server Collation Requirements for Team Foundation Server

SQL Server must be installed on a server (or servers) that has the appropriate trust levels configured between it and the server (or servers) that hosts the logical Team Foundation application-tier.

Interactions between Team Foundation Server and SQL Server Reporting Services

SQL Server Reporting Services is considered part of the logical application tier for Team Foundation Server. However, Reporting Services does not have to be installed on the same physical server as other logical aspects of that application tier, such as SharePoint Products.

When you configure user and group permissions and group membership in Team Foundation Server, you must also manually configure role membership and permissions appropriately for those users and groups in Reporting Services. For more information, see SQL Server Reporting Services Roles.

In addition to configuring role membership and permissions in Reporting Services, you must also manage the report reader account that Team Foundation Server uses to communicate with the report server. This account is frequently referred to as the data sources account for Reporting Services, or TFSREPORTS. Like the service account for Team Foundation Server, the report reader account must be a member of a workgroup or domain that is trusted by every computer that will connect to Team Foundation Server. For more information, see Accounts required for installation of Team Foundation Server.

Tip Tip

Even if you are logged on with administrative credentials, you might have trouble accessing Report Manager or the http://localhost/Reports sites unless you add these sites as Trusted Sites in Internet Explorer or start Internet Explorer as an administrator. To start Internet Explorer as an administrator, choose Start, All Programs, open the shortcut menu Internet Explorer, and then choose Run as administrator. For more information, see the Microsoft Web site.

See Also

Concepts

SQL Server Reporting Services Roles


Team Foundation Server Databases

[image]

Visual Studio Application Lifecycle Management
Team Foundation Server Databases
Send Feedback

Team Foundation Server stores data in SQL Server and, if you have reporting configured, SQL Server Analysis Services and Reporting Services. You can better manage and administer your deployment if you understand what databases Team Foundation Server uses.

The following table describes the databases that might be present in your deployment of Team Foundation Server:

Database | Used If | Description
Tfs_Configuration | Always | Stores data that describes your deployment of Team Foundation Server, including the name and location of the other databases.
Tfs_Collection | Always | One database for each team project collection. Each database stores the data for the team projects (version control, builds, and work items) in that collection.
Tfs_Warehouse | Reporting is configured | Data from all project collections is collected and stored in tables that are optimized for reporting.
Tfs_Analysis | Reporting is configured | Analysis Services database that organizes the data from the warehouse database into a cube structure..
ReportServer | Reporting is configured | Stores reports and report configuration data for Reporting Services.
ReportServer_TempDB | Reporting is configured | Stores temporary reporting data for Reporting Services.
WSS_Config | Integration with SharePoint Products is configured | Stores configuration data about SharePoint Products.
WSS_Content | Integration with SharePoint Products is configured | Stores the content for the SharePoint Products sites.
WSS_AdminContent | Integration with SharePoint Products is configured | Stores the administration information for SharePoint Products.


SQL Server Reporting Services Roles

[image]

Visual Studio Application Lifecycle Management
SQL Server Reporting Services Roles
See Also Send Feedback

You can use the roles in SQL Server Reporting Services to assign particular permissions to users in Visual Studio Team Foundation Server. Every user and group in Team Foundation Server must be assigned appropriate permissions in Reporting Services. Reporting Services provides default security through role assignments. You can use management tools for SQL Server, such as Management Studio and Report Manager, to assign users and groups to predefined roles.

You can use group membership in Team Foundation Server to determine the appropriate membership in one of the predefined roles in Reporting Services. No additional configuration of the role will be required. However, you can modify predefined roles and add custom roles to better meet your business needs. If you add custom roles or modify predefined roles, you must be sure that the roles have the permissions required for the appropriate level of access to reports and reporting features. For more information, see the following topic on the Microsoft Web site: Granting Permissions on a Native Mode Report Server.

The following predefined roles are suggested for use with Team Foundation Server:

  • System Administrator

  • Team Foundation Content Manager

  • Browser

For detailed information about pre-defined roles in Reporting Services, see the following topic on the Microsoft Web site: Using Predefined Roles.

Important note Important

You should restrict membership in Reporting Services to only those users who need the specific level of access and permissions granted by membership in that predefined role. Add a user or group to the predefined role that has the minimum permissions required to complete the user's or group's role within a team project. For example, if a user only needs to view the project schedule, you should add the user to the Browser role but not to the Content Manager role.

System Administrator

The System Administrator role includes permissions that are useful for a report server administrator who has overall responsibility for a report server, but not necessarily for the content within it. The System Administrator role does not convey the full range of permissions that a local administrator might have on a computer. You must add Team Foundation Administrators to both the System Administrator role and the Content Manager role. Together, the two role definitions provide a complete set of permissions required by members of the Team Foundation Administrators group.

Team Foundation Content Manager

Make sure to add your administrators to the Team Foundation Content Managers group on the server that hosts SQL Server Reporting Services. Otherwise they might have problems, such as being blocked by a TF218027 error when trying to create a team project.

Unlike the other roles described in this topic, the Team Foundation Content Manager role is not a default role in SQL Server. The role is created specifically for integration between Team Foundation Server and SQL Server Reporting Services when Team Foundation Server is installed. Its structure and permissions are similar to the Content Manager role that is native to SQL Server. The Team Foundation Content Manager role includes permissions that are useful for users who manage reports and Web content but that do not necessarily write reports or manage a Web server or instance of SQL Server. A content manager deploys reports, manages report models and data source connections, and decides how to use reports. The Team Foundation Content Manager role provides the typical range of permissions required by users who belong to the Project Administrators group in a team project, in addition to users who belong to the Project Collection Administrators group. You should also add members of the Team Foundation Administrators group to this role.

Browser

The Browser role includes permissions that are useful for users who view reports, but do not necessarily write or manage them. This role provides basic capabilities for users who belong to either the Contributor or Reader group in a team project.

See Also

Concepts

Understanding SQL Server and SQL Server Reporting Services


SQL Server Collation Requirements for Team Foundation Server

[image]

SQL Server Collation Requirements for Team Foundation Server
See Also Send Feedback

When you install SQL Server, you must consider two factors regarding collation settings that could affect your Team Foundation Server deployment:

  • Requirements for Team Foundation Server

  • All instances of SQL Server in your Team Foundation Server deployment must use the same settings

You can set collation settings for the Database Engine and SQL Server Analysis Services. Collation settings include character set, sort order, and other locale-specific settings, that are fundamental to the structure and function of SQL Server databases. You cannot change these settings after installation.

Requirements for Team Foundation Server

To work with Team Foundation Server, the collation settings for SQL Server must be case insensitive, accent sensitive, and not binary. If multiple SQL Server are running an instance of Database Engine or SQL Server Analysis Services for Team Foundation Server, the collation settings that you use must be the same across all these servers.

SQL Server bases your default collation settings on the locale of your operating system. The default setting for U.S. English and most other locales often meets the requirements for Team Foundation Server. However, those settings might not support all of the data that your organization must store in Team Foundation Server. In that case, you must find a setting that supports your data and is accent sensitive, not case sensitive, and not binary.

If you install Database Engine Services or Analysis Services, you can change collation settings on the Server Configuration page, by clicking the Collation tab and then clicking Customize. You may want to specify an option under Windows collation designator and sort order. For example, you can specify Latin1_General, and select the AS checkbox, if you require support for additional characters.

For most other locales, the default setting is an option under Windows collation designator and sort order. Make sure that the settings match the requirements for Team Foundation Server. If you must change this setting, you should specify the option that is named for your locale with "_100" after it, where possible. For example, you can use Japanese_100 collation if you use Unicode CJK Extension A characters or Unicode surrogates in the following ways:

  • Names of objects, such as queries or projects, in Team Foundation Server.

  • Files or paths that are checked into the version control system.

  • Any work item field that is used for searches.

To avoid problems with double-width or hiragana/katakana-equivalent characters, you should select the check boxes to enable Kana and width sensitivity when you install SQL Server.

For more information, see the Microsoft website: Collation Settings in Setup.

Full-Text search queries and collation settings

To support full-text search queries, the collation settings of the SQL Server database should correspond to a language that has a word breaker registered with SQL Server. If you use an unsupported language, you could receive unexpected results when you run a work item query that specifies the Contains or Contains Words operators with text strings.

To learn more, see one of the following topics:

  • Full-Text Search (SQL Server)

  • sys.fulltext_languages (Transact-SQL)

  • ALTER FULLTEXT INDEX (Transact-SQL)

  • SQL Server 2008 Full-Text Search: Internals and Enhancements

  • Query Fields, Operators, Values, and Variables

See Also

Concepts

Manually install SQL Server for Team Foundation Server
Install Team Foundation Server
TFS upgrade requirements


Verify SQL Server for Team Foundation Server

[image]

Verify SQL Server for Team Foundation Server
See Also Send Feedback

To ensure that your installation of SQL Server will work with Team Foundation Server, you should verify that the required SQL Server features are available, the underlying Windows services that are associated with SQL Server are running, the connection settings are configured, and the network ports are open.

If SQL Server Reporting Services is not on the server that is running Team Foundation Server and you are using reporting, you must install Client Tools Connectivity on Team Foundation Server.

If the Database Engine, Analysis Services, and Reporting Services are running on different instances of SQL Server, you must log on to each server to verify each instance.

Required Permissions

To run SQL Server Configuration Manager, you must be a member of the Users security group on the server that hosts SQL Server. To use SQL Server Configuration Manager to modify services, you must be a member of the Administrators security group.

To run SQL Server Reporting Services Configuration Manager or SQL Server Management Studio, you must be a member of the Administrators security group on the operating system of the server that is running the instance of SQL Server that you want to verify. For SQL Server Management Studio, you must also be a member of the Public server role on the instance of SQL Server that you want to verify.

Verify Reporting Services

If you are not using Team Foundation Server reporting, you do not need to verify SQL Server Reporting Services or Analysis Services.

To verify that the Windows service is running using SQL Server Configuration Manager

  1. On the server that is running SQL ServerSQL Server Reporting Services, launch SQL Server Configuration Manager.

  2. Choose SQL Server Services, and verify that Running appears in the State column for SQL Server Reporting Services.

To verify the report server URLs are running using SQL Server Reporting Services Configuration Manger

  1. On the server that is running SQL Server Reporting Services, launch Reporting Services Configuration Manager.

    Note Note

    On Windows Server, you must open the context menu for Reporting Services Configuration Manager and choose Run as administrator.

    The Reporting Services Configuration Connection dialog box appears.

  2. In Server Name, type the name of the report server. If you are using an instance name, type the name of the instance in Report Server Instance. Choose Connect.

  3. Choose Report Manager URL, and choose the link to the report manager website.

    The report manager website for the report server opens in an Internet browser window.

  4. Choose Web Service URL, and choose the link to the report server website.

    The report server website opens in an Internet browser window.

Verify the Database Engine and Analysis Services

On the instance of SQL Server that is running the Database Engine, you must ensure that you have the Full-Text Search feature installed. To verify this functionality, you open the SQL Server Installation Center, and then click the New SQL Server stand-alone installation or add features to an existing installation. If Full-Text Search is not available on the instance of SQL Server that is running the Database Engine, you must install Full-Text Search. For more information about how to work with SQL Server Installation Center, see Manually install SQL Server for Team Foundation Server.

To verify that Windows services are running by using SQL Server Configuration Manager

  1. On the instance of SQL Server on which the Database Engine, SQL Server Analysis Services, or both are running, launch SQL Server Configuration Manager.

  2. Choose SQL Server Services, and verify that Running appears in the State column and the Start Mode is set to automatic for all services.

    • To change the start mode of a service to start automatically, you must open the context menu for the service, choose Properties, choose the Service tab, click the drop-down list to the right of Start Mode, and then choose Automatic.

    • To change a stopped service state to running, you must open the context menu for the stopped service and choose Start.

  3. Choose SQL Server Network Configuration, double-click Protocols for MyInstanceName, and verify that Enabled appears in the Status column for TCP/IP.

    If you specified the default instance during installation, MyInstanceName will be MSSQLSERVER.

To perform the following procedure, you must have SQL Server Management Studio installed. However, it does not have to be installed on the server that is running the instance of SQL Server that you are verifying. If you must install SQL Server Management Studio, see Manually install SQL Server for Team Foundation Server.

To verify a connection to an instance of SQL Server by using SQL Server Management Studio

  1. Launch SQL Server Management Studio.

    The Connect to Server dialog box opens.

  2. In the Server type list, choose Database Engine or Analysis Services, depending on the type of installation that you are verifying.

  3. Type the name of the server to which you want to connect, and then choose Connect.

    If SQL Server is installed on a cluster, you must specify the server name, not the computer name. If you are using a named instance of SQL Server, you must specify the name of the server and the name of the instance. If you cannot connect to the server, verify the firewall settings, and then try to connect again.

  4. In Object Explorer, verify that a green arrow appears next to the server name.

See Also

Concepts

Manually install SQL Server for Team Foundation Server
Install Team Foundation Server


Provisioning SQL Server Databases for Team Foundation Server

[image]

Provisioning SQL Server Databases for Team Foundation Server
See Also Send Feedback

You might want to create empty databases for Team Foundation Server, because doing so can be useful for managing the databases of multiple instances of Team Foundation Server on a single instance of SQL Server or hosting Team Foundation Server databases on a managed instance of SQL Server. Whatever the reason, this topic provides guidance for how to provision empty SQL Server databases for use with Team Foundation Server.

Conceptually, this procedure contains two steps:

  1. You create the databases and name them based on established guidelines.

  2. You identify these databases when you install Team Foundation Server.

Configuration Database

Team Foundation Server has two databases that you can configure to use empty databases during installation.

  • Tfs_DatabaseLabelWarehouse

  • Tfs_DatabaseLabelApplication

These databases must use the naming structure as shown, but you can either omit the string DatabaseLabel or use any custom string that uniquely describes both databases.

When you install Team Foundation Server, you must select the Use pre-existing empty database(s) check box. If you added a label, you must also type it in Server Databases Label. The installation wizard will then use the empty databases that you created to set up the configuration database.

Note Note

Each project collection requires its own database, but you cannot configure Team Foundation Server to use an empty project collection database during installation. You must add an empty project collection database after installation, using Team Foundation Server Administration Console.

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements


Work with SQL Server Named Instances

[image]

Visual Studio Application Lifecycle Management
Work with SQL Server Named Instances
See Also Send Feedback

You can choose to install Team Foundation Server using the default instance of SQL Server or a named instance of SQL Server. Depending on your business infrastructure and deployment needs, you might prefer to use a named instance. If you want to use a named instance in your deployment of Team Foundation Server, you must create that named instance in SQL Server before you install Team Foundation Server or create a team project collection that uses that instance. You cannot create a named instance during installation of Team Foundation Server.

To use a named instance of SQL Server in a deployment of Team Foundation Server

  • To use a named instance with Team Foundation Server, you must install SQL Server by using a named instance, or move or restore Team Foundation Server data to a named instance, or create a team project collection on a named instance. For information about how to install SQL Server as a named instance, see Manually install SQL Server for Team Foundation Server.

See Also

Concepts

Understanding SQL Server and SQL Server Reporting Services


Use SQL Server Always On Availability Groups with Team Foundation Server

[image]

Use SQL Server Always On Availability Groups with Team Foundation Server
Send Feedback

This topic provides general guidelines for enabling AlwaysOn Availability Groups with Team Foundation Server. AlwaysOn Availability Groups requires a small amount of TFS-specific configuration, which can help you provide high availability (HA) to TFS relational databases like TFS_Configuration and TFS_Collection database. The TFS-specific configuration sets the MultisubnetFailover option to true in the connection string that TFS uses for the data tier and is not necessary for providing HA support for reporting or SharePoint. To provide high availability to the TFS report server or SharePoint deployment, use the documentation for those products.

TFS support for AlwaysOn Availability Groups is an on or off proposition: if you use it, you must include your TFS_Configuration database as well as all of your TFS_Collection databases in the availability group. If you add a team project collection in the future, the database for that collection must be added to the availability group in SQL Server.

New for this release, TFS 2013 allows you to use more than one SQL Server availability group.

Use SQL Server documentation for guidance about configuring AlwaysOn Availability Groups. TFS does not require any specific AlwaysOn Availability Group configuration. Use the configuration that best meets your team's needs and the recommendations found in SQL Server guidance. See Getting Started with AlwaysOn Availability Groups (SQL Server).

Setting up a new TFS installation with AlwaysOn Availability Groups

This a high level walkthrough of the steps required to implement AlwaysOn Availability Groups during TFS installation.

Tip Tip

To set the MultisubnetFailover option to true in the connection string for an already running deployment of TFS, use the RegisterDB command of TFSConfig with the /usesqlalwayson argument. You will need to use the TFSService Control Command to stop and start TFS before you can set the MultisubnetFailover option. See RegisterDB Command and TFSServiceControl Command.

One: set up AlwaysOn Availability Groups

The SQL Server AlwaysOn Availability Group must be ready before you install TFS. See Getting Started with AlwaysOn Availability Groups (SQL Server)

Two: install TFS using the advanced wizard

Select AlwaysOn checkbox

If you're installing TFS for the first time, use the Advanced configuration wizard, which gives you access to the SQL AlwaysOn Availability Group check box (pictured above). On this screen, enter the Availability Group Listener in the SQL Server Instance text box. TFS will create TFS_Configuration and the DefaultCollection databases on the Primary replica of your AlwaysOn Availability Group. The databases for SharePoint will also be created, if you allow TFS to install SharePoint Foundation.

Tip Tip

You can also access the SQL AlwaysOn Availability Group check box by using the Application-Tier Only or Upgrade wizards. See How to: Create a Team Foundation server farm (high availability) or TFS upgrade requirements.

Three: add the new TFS databases to the AlwaysOn Availability Group

Add TFS databases to AlwaysOn Availibility Group

You'll need to back up any databases that you want to add to the AlwaysOn Availability Group to bring them into compliance for data stored in an AlwaysOn Availability Group. Next, use the Availability Group Wizard to add the databases to the group. See Creation and Configuration of Availability Groups (SQL Server), and Use the New Availability Group Wizard (SQL Server Management Studio).

Tip Tip

If you add a new team project collection to TFS, remember to add the database for the collection to your availability group in SQL Server. You cannot have some databases for team project collections in and some outside the availability group.

AlwaysOn Availability Groups Support for Reporting and SharePoint

The TFS-specific configurations described in this topic are not necessary to provide HA support for reporting or SharePoint. To provide AlwaysOn support for those features, use the guidance available for those products, or implement some other TFS-supported HA feature.

Reporting and AlwaysOn Availability Groups

  • Reporting Services with AlwaysOn Availability Groups (SQL Server)

  • Analysis Services with AlwaysOn Availability Groups

SharePoint and HA

  • Configure and manage SQL Server availability groups for SharePoint Server

  • Plan for availability (SharePoint Server 2010)

  • SQL Server 2008 R2 and SharePoint 2010 Products: Better Together (white paper) (SharePoint Server 2010)


SharePoint Products requirements for Team Foundation Server

[image]

SharePoint Products requirements for Team Foundation Server
Send Feedback

SharePoint is a collaboration product that offers deep integration with Office products like Word, Outlook, and Excel. Although not a TFS requirement, some teams do find SharePoint integration useful. If you want to use SharePoint Products, you must use a supported version and it has to have the Team Foundation Server extension for SharePoint Products installed.

Tip Tip

If you plan to install SharePoint, make sure that the version of SharePoint you want to use is compatible with the server operating system you're using. Support for server operating systems in TFS is more amenable than in SharePoint.

Here are your main options:

  • You can use Team Foundation Server standard or advanced configuration wizards to install SharePoint Foundation 2013 on the same server as Team Foundation Server. The Team Foundation Server extensions for SharePoint Products are installed automatically during Team Foundation Server installation.

  • You can use Team Foundation Server extensions for SharePoint Products configuration wizard to install SharePoint Foundation 2013 on a different server from the one running Team Foundation Server.

  • You can use SharePoint Server. If you use the enterprise version of SharePoint Server, you must configure it for dashboard compatibility (more on dashboard requirements later).

  • You can use a different version of SharePoint Foundation than the one that ships with TFS.

Regardless of which option you choose, your SharePoint Products must meet the following requirements:

Supported versions, editions

  • SharePoint Foundation 2013¹

  • SharePoint Server 2013,¹ (Enterprise or Standard edition)

  • SharePoint Foundation 2010²

  • SharePoint Server 2010,² (Enterprise or Standard edition)

Authentication

NTLM is the recommended authentication provider.

Team Foundation Server Extensions for SharePoint Products does not support Basic authentication or anonymous authentication.

Tip Tip

In SharePoint Server 2013, Microsoft deprecated Windows classic-authentication in favor of claims-based authentication. TFS supports both, but for claims-based authentication, the authentication provider must be NTLM. TFS will only support NTLM-based claims.

¹ Not supported on Windows Server 2012 R2. SharePoint 2013 with SP1 (get it now) adds support for Windows Server 2012 R2.

² Not supported on Windows Server 2012 or Windows Server 2012 R2.

Tip Tip

Do you need to upgrade SharePoint to a supported version? See Upgrade from Office SharePoint Server 2007 or Windows SharePoint Services 3.0 to SharePoint Server 2013 or SharePoint Foundation 2013

Dashboard requirements

Team Foundation Server contains dashboards that use SharePoint Products features to display team data. The dashboards that are available to you depend on the version of SharePoint Products that you use.

  • If you use any supported enterprise edition of SharePoint Server, you get five dashboards that are based on Microsoft Excel.

  • If you use any other SharePoint Product (including the standard editions of SharePoint Server), you get two dashboards that are based on SQL Server Reporting Services.

Deployment references for SharePoint Products

SharePoint Products has its own guidance for deployment.

  • For more information about how to deploy and configure SharePoint 2013 Products, see the following page on the Microsoft website: Install and configure SharePoint 2013

  • For more information about how to deploy and configure SharePoint 2010 products, see the following pages on the Microsoft website: Deployment for SharePoint Server 2010 or Deployment for SharePoint Foundation 2010

How to install SharePoint Products for Team Foundation Server

How to: Set up remote SharePoint Products for Team Foundation Server

You can use Team Foundation Server extensions for SharePoint Products configuration wizard to install SharePoint Foundation 2013 on a different server from Team Foundation Server.

Install Team Foundation Server

You can use Team Foundation Server standard and advanced configuration wizards to install SharePoint Foundation 2013 on the same server as Team Foundation Server. The Team Foundation Server extensions for SharePoint Products are installed automatically during Team Foundation Server installation.

More SharePoint Products tasks for Team Foundation Server

Manually Install SharePoint products for Team Foundation Server

Install and configure SharePoint Server 2013 for use with Team Foundation Server. Although the procedures in this topic are tailored to SharePoint Server 2013, you could use them to install any of the supported SharePoint products. It's all very similar.

Add the service account for Team Foundation Server to the Farm Administrators group

You must add the service account for Team Foundation Server to the Farm Administrators group on the SharePoint products site. Team Foundation Server configures this for you automatically if you install SharePoint Products on the same server as Team Foundation Server.

Configure the enterprise application definition for Team Foundation Server

Final configuration is required in the Team Foundation Server extensions for SharePoint Products only if you're using an enterprise edition of SharePoint Server.

Verify SharePoint products for Team Foundation Server

Steps you can use to verify that an existing installation of SharePoint Products is ready to work with Team Foundation Server.


Manually Install SharePoint products for Team Foundation Server

[image]

Manually Install SharePoint products for Team Foundation Server
See Also Send Feedback

This procedure is for installing and configuring SharePoint Server 2013 on the same server as TFS and SQL Server.

We're going to install SharePoint after we install SQL Server, so that we can use the same Database Engine instance we installed for TFS for our SharePoint deployment, although using the same SQL Server instance for both SharePoint and TFS is not a requirement.

Tip Tip

Installing SharePoint on the same server as TFS isn't a requirement either. TFS is very flexible with regard to the topology of your SharePoint installation. See "What If I Already Have SharePoint?" later.

Do I even need SharePoint?

Maybe. SharePoint is a collaboration website product that offers deep integration with Office products like Word, Outlook, and Excel. Although it's not a TFS requirement, some teams do find its features useful. SharePoint is different from the Team Web Access site that comes with TFS. Team Web Access is a website that mirrors Visual Studio features and offers functionality for certain specialized team collaborations that relate to creating software projects. You get Team Web Access by default when you install TFS.

You don't need to add SharePoint to your initial TFS installation. You can always install TFS first, add SharePoint later, and then manually hook up each of your TFS team projects to SharePoint.

What will I need?

Assuming you still want SharePoint in your TFS deployment, you'll need a single domain account to act as the TFS Report Reader account. TFS uses this account to generate reports. (Even if you don't set up SharePoint, you'll need a report reader account to generate reports). We're going to use the report reader account for reports, but we'll also use it as the Farm Administrator account for our SharePoint installation, just as TFS would during a standard install.

Tip Tip

Don't put the report reader account in the Windows Administrators security group. It just needs the Allow log on locally permission, which all domain accounts have by default.

Free SharePoint vs. paid-for SharePoint

For each version of SharePoint, Microsoft delivers a free version and a paid-for version with additional functionality. TFS always comes with one of the free versions. However, TFS supports both versions and the instructions for installing either are very similar.

If you use the enterprise edition of SharePoint Server, as we are going to in this topic, you must make a few additional SharePoint configurations after you install SharePoint (and before you install TFS) to enable TFS dashboard functionality on the SharePoint site. If you install any other version of SharePoint, you can skip the extra dashboard configurations in this topic. You'll still get some dashboard functionality, but not as much as if you had the enterprise edition of SharePoint Server.

Dashboard differences between SharePoint products

Team Foundation Server contains dashboards that use SharePoint Products features to display team data. The dashboards that are available to you depend on the version of SharePoint that you use.

  • If you use any supported enterprise edition of SharePoint Server, you get five dashboards that are based on Microsoft Excel.

  • If you use any other SharePoint Product (including the standard editions of SharePoint Server), you get two dashboards that are based on SQL Server Reporting Services.

What if I already have SharePoint?

If your existing SharePoint installation meets the TFS requirements for SharePoint, you can verify your existing SharePoint deployment and then integrate it with TFS. Before you verify, review the SharePoint requirements for TFS.

Tip Tip

You can use a remote SharePoint installation-an instance of SharePoint that is not installed on the TFS server-but to do this you'll need to install the TFS extensions for SharePoint on the SharePoint server. See How to: Install Remote SharePoint Products for Team Foundation Server.

To install SharePoint 2013 products for TFS

Required Permissions

You must be a member of the Windows Administrators security group on the computer where you install SharePoint Products and where you host its databases.

Before you install any SharePoint 2013 product, run the SharePoint 2013 Products preparation tool. After preparing the server, you'll install SharePoint, and then do whatever post installation configuration tasks are appropriate for the product you just installed.

Remember that you'll need a single domain account to act as the TFS Report Reader account to install SharePoint Server 2013. See, "What will I need?"

Run the preparation tool

  1. Insert the SharePoint Server 2013 DVD and launch default.hta, or download SharePoint Foundation 2013 and run sharepoint.exe.

    You can find detailed information about SharePoint Products requirements for Team Foundation Server on MSDN, but this instruction will guide you through typical installations.

  2. Choose Install software prerequisites.

    Install software prerequisites

  3. On the Welcome page, choose Next.

  4. On the license agreement page, accept the terms of the license and choose Next.

    Depending on the state of your computer, the installer might prompt you to restart the machine. Follow any instructions.

    Restart the machine

    After a restart, you might have to run the SharePoint Products prep tool again, if it doesn't start automatically. Repeat the previous four steps for manual restarts until you get a success message.

  5. At completion, choose Finish.

    Prep tool success message

Run the SharePoint installation

Once the SharePoint Products Perpetration tool finishes, you might have to launch the SharePoint installer again, especially if you had to restart your computer.

Remember that you'll need a single domain account to act as the TFS Report Reader account to complete this section. See "What will I need?" earlier in this topic.

  1. Insert the SharePoint Server 2013 DVD and launch default.hta, or run sharepoint.exe (for SharePoint Foundation installations).

  2. Choose Install SharePoint Server this time (or Install SharePoint Foundation).

    Install SharePoint Server

    If you are installing SharePoint Server, type your product key, and choose Continue.

  3. Read and accept the agreement. Choose Continue.

  4. On the Server Type tab, choose Complete.

  5. Choose Install Now.

    When the installation wizard finishes, a dialog box appears that prompts you to complete the configuration of your server.

  6. In that dialog box, verify that the Run the SharePoint Products and Technologies Configuration Wizard now check box is selected.

    Run the wizard check box

  7. Choose Close to start the configuration wizard.

  8. On the Welcome page, choose Next.

    Note Note

    A warning about restarting certain services will appear. Choose Yes. Some services might need to be restarted during the configuration phase.

  9. On the Connect to a server farm page, choose Create a new server farm.

    Create a new server farm

  10. On the Specify Configuration Database Settings page, perform the following steps and then choose Next:

    1. In Database server, type the name of the server that is running SQL Server. Accept the default value for database name.

      Name of the SQL Server?
      Tip Tip

      If you used a named instance in step 10 of your SQL Server install, type the named instance here. For example, severname\InstanceName.

    2. Type the name of the report reader account and its password.

      Add report reader account
      Tip Tip

      You can use the same account here that you will use for the report reader account. Even if you use the report reader account here, the account you use to run the wizard will also be added to the SharePoint Farm administrators group.

  11. Type a password in Passphrase and confirm it.

  12. On the Configure SharePoint Central Administration Web Application page, select the Specify port number check box, and type 17012.

    Port number 17012

    You can use the randomly generated port number, but Team Foundation Server has always used 17012 as the port for the SharePoint Products administration site.

  13. Choose NTLM, and then choose Next.

  14. Review the information, and then choose Next.

    Configuration begins.

  15. Choose Finish.

    Once the installation routine finishes, it launches the SharePoint administration site, open to the initial configuration wizard.

Run the SharePoint Configuration wizards

No matter which version of SharePoint you install, you must run the SharePoint Configuration wizard. Special instructions appear in step 3 if you're installing the enterprise edition of SharePoint Server 2013.

  1. Choose Start the Wizard.

    Start the wizard

  2. Select Use existing managed account and choose the report reader account.

    Use existing managed account

  3. If you're installing SharePoint Server Enterprise edition, as we are, then you'll need to select Excel Services and Secure Store Service.

    If you're installing the Standard edition of SharePoint Server 2013 or SharePoint Foundation, none of the listed services are required, but you must run the wizard to succeed with your TFS installation. Even if you select no services, SharePoint will configure a site collection and some other services.

    Select any services you want to set up. Clear any you don't want set up.

    SharePoint selects all of them by default.

    Tip Tip

    Remember that you can always come back later to run the configuration wizards, but to succeed with your TFS installation, you have to run it one time after the SharePoint installation.

  4. Choose Next.

    The SharePoint configuration begins and takes a few minutes, depending on the number of services you're configuring. At some point during the configuration, SharePoint will prompt you to create a site collection.

  5. Type a Title and choose Next.

    Type a title

  6. Choose Finish.

    If you're installing SharePoint Foundation or the standard edition of SharePoint Server, you can skip forward to TFS installation. If you're installing SharePoint Server 2013, as we are, then configure Excel Services and Secure Store Service in the following sections.

Configure Excel Services (SharePoint Server only)

For TFS reports to operate correctly on a supported enterprise edition of SharePoint Server, you must also configure a trusted file location for Excel Services.

  1. In SharePoint Central Administration, under Application Management, choose Manage service applications.

    Choose Manage service applications

  2. On the Manage Service Applications page, choose Excel Services Application.

    Choose Excel Services Application

  3. On the Manage Excel Services Application page, choose Trusted File Locations.

    Choose Trusted File Locations

  4. Choose Add Trusted File Location.

    Choose Add Trusted File Location

  5. In Address, enter the URL of the root of the SharePoint site. This is the web application that the SharePoint configuration wizards created on port 80.

    Configure Trusted File Location

  6. In Location Type, choose Microsoft SharePoint Foundation.

  7. In Trust Children, select the Children trusted check box.

  8. In the External Data section, under Allow External Data, choose Trusted data connection libraries and embedded.

  9. (Optional) Clear the Refresh warning enabled check box.

  10. In Maximum Concurrent Queries Per Session, change the number to 20 and choose OK.

    The trusted file location you just created appears in the Excel Services trusted file location list.

    Trusted File Location added

Configure Secure Store Service (SharePoint Server only)

To configure the secure store service, you must create a target application for the secure store.

  1. In SharePoint Central Administration, under Application Management, choose Manage service applications.

    Choose Manage service applications

  2. On the Manage Service Applications page, choose Secure Store Service.

    Choose Secure Store Service

  3. Choose New to create a secure store target application for Team Foundation Server.

    Create a secure store target application
    Tip Tip

    If you have not created a key, SharePoint Products prompts you to create one by choosing Generate New Key. Without a key, you cannot create a target application for the secure store.

    The fields configured in the next four steps are pictured in the next screenshot.

  4. In Target Application ID and Display Name, enter TFS

    Tip Tip

    You do not have to use TFS for Target Application ID or Display Name, but take note of whatever you use here, because you will need it to configure Team Foundation Server later.

  5. In Contact E-mail, type the e-mail address of the person or group you want email messages about this application to be sent to

  6. In the Target Application Type list, choose Group

  7. In Target Application Page URL, choose None.

    Configure a secure store target application

  8. In Specify the credential fields for your Secure Store Target Application, accept the default settings for the credential fields.

    Specify the credential fields

  9. In Target Application Administrators, type the administrative account for the application.

  10. In Members, enter the global security group from the domain that contains all the users to whom you want to grant access to dashboards and reports in Team Foundation Server.

    Add global security group

  11. On the Secure Store Service Application page, select the check box for the target application that you just created (named TFS if you used the naming guidance that was provided earlier in this topic), and then choose Set Credentials in the ribbon.

  12. In the Set Credentials for Secure Store Target Application (Group) dialog box, enter the name and password of the report reader account for Team Foundation Server and confirm the password.

    Add report reader account

Next steps

With SharePoint Server 2013 installed, you're ready to move to the topic on TFS installation.

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements
How to: Set up remote SharePoint Products for Team Foundation Server


Verify SharePoint products for Team Foundation Server

[image]

Verify SharePoint products for Team Foundation Server
See Also Send Feedback

If you choose to use an installation of SharePoint Products other than the one that was installed during Team Foundation Server installation, you should verify that your installation of SharePoint Products meets the following guidelines:

  • The administration site and default website are running, and other computers on the network can access them.

  • SharePoint uses NTLM, the recommended authentication. (Basic authentication is not supported by Team Foundation Server extensions for SharePoint Products.)

  • If you are using a supported enterprise edition of SharePoint Server, you must configure settings for dashboard compatibility.

Required Permissions

To perform this procedure, you must be a member of the Administrators security group on the server that is running SharePoint.

To verify that the administration site and default website are running and that other computers on the network can access them

  1. On the server that is running SharePoint, choose Start, Run, enter inetmgr, and then choose OK.

    Internet Information Services (IIS) Manager appears.

  2. In Internet Information Services (IIS) Manager, open ServerName (local computer).

    ServerName is the name of the web server.

  3. Choose Sites, and then choose the default website.

  4. On the Actions pane, choose Browse :80 (http).

    The default website appears in the default browser.

  5. Choose the SharePoint Central Administration site.

    On the Actions pane, choose Browse :Port (http).

    Port is the number of the port that is bound to the SharePoint Central Administration site.

    The SharePoint Central Administration site appears in the default browser.

To verify that the default website uses recommended authentication

  1. In a web browser, open the SharePoint Central Administration site, and choose the Security.

  2. Under General Security, choose Specify authentication providers.

  3. In the Zone column, choose Default.

  4. In Claims Authentication Types, make sure that check boxes for Enable Windows Authentication, Integrated Windows authentication, and NTLM are selected.

    Note Note

    You should check that the authentication setting that appears in the SharePoint Central Administration site matches the authentication setting that appears in IIS.

To verify that a supported enterprise edition of SharePoint Server is configured for dashboard compatibility

  • If you are using a supported enterprise edition of SharePoint Server, perform the required configurations for dashboard compatibility. If you are using any other version of SharePoint, you can disregard this procedure. For more information, see Manually Install SharePoint products for Team Foundation Server.

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements
How to: Set up remote SharePoint Products for Team Foundation Server


Configure the enterprise application definition for Team Foundation Server

[image]

Configure the enterprise application definition for Team Foundation Server
See Also Send Feedback

If you're using a supported enterprise edition of SharePoint Server, you must add the enterprise application definition to your deployment of Team Foundation Server. You created the enterprise application definition when you configured SharePoint for dashboard compatibility. You must perform this configuration before reports and dashboards will appear correctly in Team Foundation Server.

To configure the enterprise application definition

  1. On the server that is running Team Foundation Server Extensions for SharePoint Products, open the administration console for Team Foundation Server.

  2. Choose Extensions for SharePoint Products, and then choose the SharePoint web application for which you want to configure the enterprise application definition.

  3. Choose Modify access, enter the name of the enterprise application definition in Enterprise Application Definition (optional), and then choose OK.

See Also

Concepts

Install Team Foundation Server
How to: Set up remote SharePoint Products for Team Foundation Server


Accounts required for installation of Team Foundation Server

[image]

Accounts required for installation of Team Foundation Server
See Also Send Feedback

You must use service accounts to install Team Foundation Server, Team Foundation Build, and Team Foundation Server Proxy. If you use reporting, you also need a report reader account when you install Team Foundation Server. This topic describes the requirements for service accounts and the report reader account for installation. For more information, see Service Accounts and Dependencies in Team Foundation Server.

Team Foundation Server requires multiple identities for installation, but you can use a single account for all the identities, as long as that account meets the requirements for all the identities for which you use it.

Tip Tip

Confused about accounts? New for this release is a tutorial available for Team Foundation Server installation that covers how to create accounts and groups for a single server installation. For more information, see Set up groups for use in TFS deployments.

Best practices for accounts

  • If you use domain accounts for your service accounts, you should use a different identity for the report reader account.

  • If you are installing a component in a workgroup, you must use local accounts for user accounts.

Report reader account

The report reader account is the identity that is used to gather information for reports. If you use reporting, you must specify a report reader account when you install Team Foundation Server.

If you install Team Foundation Server with the default options, the report reader account is also used as the identity of the service account for SharePoint Foundation.

Feature | Sample user logon name ¹ | Requirements
Reporting | TFSREPORTS | You must specify a user account that has the Allow log on locally permission. Default: You are prompted for this account. You cannot use a built-in account for the report reader account.

Service accounts

Team Foundation Server, Team Foundation Build and Team Foundation Server Proxy all require a service account. These service accounts become the identity for the installed component. By default, every component uses a built-in account (such as Network Service) as its service account. You can change this account to a user account when you install the component, but you must ensure that any user accounts that you use have the Log on as a service permission.

Tip Tip

Built-in accounts do not use passwords and already have the Log on as a service permission, making them easier to manage, especially in a domain environment.

Service accounts for Team Foundation Server

The service accounts in the following table are the identities for Team Foundation Server and its components.

The service account for Team Foundation Server is also used in Internet Information Services (IIS) as the identity of the application pool for Team Foundation Server.

Component

Sample user logon name ¹

Requirements

Team Foundation Server

TFSSERVICE

You can specify a built-in account or a user account. If you specify a user account, it must have the Log on as a service permission.

You must not use the account that you use to install Team Foundation Server as the account for TFSSERVICE. For example, if you are logged in as domain\user1 when you install Team Foundation Server, do not use domain\user1 as the account for TFSSERVICE.

If your SharePoint site was not installed at the same time as Team Foundation Server, you must add TFSSERVICE to the Farm Administrators group for the SharePoint Central Administration site. For more information, see Add the service account for Team Foundation Server to the Farm Administrators group.

Default: Network Service

Team Foundation Build

TFSBUILD

You can specify a built-in account or a user account. If you use a user account, it must have the Log on as a service permission.

Team Foundation Server Proxy

TFSPROXY

You can specify a built-in account or a user account. If you use a user account, it must have the Log on as a service permission.

Service accounts for Release Management for Visual Studio 2013

The service accounts in the following table are the identities for Release Management Server and the Microsoft Deployment agent.

Component | Sample user logon name ¹ | Requirements
Release Management Server | RMSERVER | This is the identity used in Internet Information Service (IIS) for the application pool and the Release Management Monitor Windows service. Default: Network Service
Microsoft Deployment Agent | DEPLOY | This identity is used to configure the machines in your environment for release. Make sure the identity you use here has enough permission to do whatever tasks are required. For example, if you need to install your application on this machine as part of your release, add this identity to the local Windows Administrators security group. If this identity will need to access builds on the network, make sure it has access to the network drop location. For step-by-step procedure, go here: Install deployment agent and set up machines for an environment Default: you are prompted for an account.

Connect Release Management to TFS account

If you connect Release Management to TFS, you need an account in TFS to act as an intermediary account. For a step-by-step procedure, go here: Connect Release Management to TFS

Component | Sample user logon name ¹ | Requirements
Release Management Server (connected to TFS) | RMTFS | A TFS user that is a member of the Project Collection Administrators¹ group and has the Make requests on behalf of others permission set to allow in TFS.

¹ What are the necessary minimal permissions that this account must have? (blog post)

Service accounts for additional software

The following table lists the service accounts that are the identities that are used to run Windows services for SharePoint Products and SQL Server.

The service account for SharePoint Products is also the identity of the application pool for the SharePoint Central Administration site.

Software | Sample user logon name ¹ | Requirements
SharePoint Products | WSSSERVICE | You must specify a user account. Default: If you install Team Foundation Server with the default options, the account that you specified as the report reader account is also used for this account.
SQL Server | SQLSERVICE | You can use a built-in system account or set up an account before you install SQL Server. Team Foundation Server has no requirements for this account.

¹ To make it easier to discuss the different accounts that Team Foundation Server requires, this guide uses the placeholder names that are specified in the preceding tables. You do not have to use these placeholder names for any accounts that you might create.

See Also

Concepts

Install Team Foundation Server
Install Release Management
How to: Create a Team Foundation server farm (high availability)
TFS upgrade requirements
Set up Team Foundation Build Service
How to: Install Team Foundation Proxy and set up a remote site


Ports required for installation of Team Foundation Server

[image]

Ports required for installation of Team Foundation Server
See Also Send Feedback

Your firewall controls network ports, but Team Foundation Server requires port access. You must ensure that your firewall does not block Team Foundation Server from the ports it requires. The tables in this topic show the default settings for TCP ports that Team Foundation Server, SQL Server, and SharePoint Products require.

Firewalls

If you are using Windows Firewall and it is configured to allow exceptions, the installation wizard for Team Foundation Server opens the ports that TFS requires. If Windows Firewall is configured not to allow exceptions, you should configure it to allow exceptions during the installation of Team Foundation Server. Otherwise, you will have to manually open the ports that TFS requires. For more information, see this page on the Microsoft website: How to Configure Windows Firewall on a Single Computer.

If you are using some other firewall product, you should check its documentation to determine how to open the ports that TFS requires.

Required Ports for SQL Server

The following table specifies the TCP ports that SQL Server requires.

Server or Application Context | TCP Port
SQL Service (Database Engine) | 14331
SQL Browser Service (Database Engine) | 1434
SQL Server Analysis Services Redirector | 2382
SQL Server Analysis Services | 2383
SQL Server Reporting Services | 80

1SQL Server uses port 1433 for the default instance. For named instances, SQL Server uses a dynamic port that the operating system assigns. Use SQL Server Configuration Manger to determine the SQL Server port number for any named instances. For more information, see this page on the Microsoft website: Configuring the Windows Firewall to Allow SQL Server Access.

Report Server Port Requirements

You must ensure that the report server contains an exception in Windows Firewall for Windows Management Instrumentation (WMI) if the report server is not on the server that is running Team Foundation Server. The instructions for completing this task differ based on the operating system that you are using. If you are using Windows Server 2003 or Windows Server 2003 R2, see the following page on the Microsoft website: Connecting Through Windows Firewall. If you are using Windows Server 2008, Windows Server 2008 R2, Windows Vista or Windows 7, see the following page on the Microsoft website: Connecting to WMI Remotely Starting with Windows Vista.

Required Ports for SharePoint Products

The table in this section specifies the TCP ports that SharePoint Foundation uses if it is installed by the installation wizard for TFS.

These port numbers might be different for existing deployments of SharePoint Products. You can determine which port numbers SharePoint Products uses by opening Internet Information Services (IIS) Manager and looking at the properties of the websites. For more information, see Verify SharePoint products for Team Foundation Server.

Server or Application Context | TCP Port
Default website | 80
SharePoint Central Administration | 17012

Required Ports for Team Foundation Server

By default, Team Foundation Server uses the following TCP ports:

Server or Application Context | TCP Port
Team Foundation Server | 8080
Team Foundation Server Proxy | 8081

Required Ports for Release Management for Visual Studio 2013

By default, Release Management Server uses the following TCP port:

Server or Application Context | TCP Port
Release Management Server | 1000

See Also

Concepts

Install Team Foundation Server
How to: Create a Team Foundation server farm (high availability)
TFS upgrade requirements
How to: Install Team Foundation Proxy and set up a remote site
Install Release Management


Active Directory requirements for Team Foundation Server

[image]

Active Directory requirements for Team Foundation Server
See Also Send Feedback

You can install Team Foundation Server on more than one server if they are all joined to an Active Directory domain that is based on a functional level that TFS supports. You can install TFS on a single server that is joined to an Active Directory domain or that is a member of a workgroup.

You cannot install TFS on servers that are joined to domains whose domain controllers are running Windows NT Server 4.0. The following table shows which functional levels for Active Directory domains TFS does not support.

Functional levels for Active Directory domains | Supported
Windows 2000 mixed mode Domain controllers that are running Windows NT Server 4.0, Windows 2000, Windows Server 2003, and Windows Server 2003 R2. | No
Windows Server 2003 interim mode Domain controllers that are running Windows NT Server 4.0, Windows Server 2003, and Windows Server 2003 R2. | No

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements
Set up Team Foundation Build Service
How to: Create a Team Foundation server farm (high availability)
How to: Install Team Foundation Proxy and set up a remote site
How to: Set up remote SharePoint Products for Team Foundation Server
How to: Add Project Server to Team Foundation Server


Language requirements for Team Foundation Server

[image]

Language requirements for Team Foundation Server
See Also Send Feedback

You can install TFS in various languages on supported operating systems in various languages. However, you cannot use every combination of localized operating system with TFS and you can't install multiple languages on a single TFS server. The language of the installation of SharePoint Products can also complicate your deployment. However, you can add an appropriate language pack to the server that is running SharePoint Products to meet requirements for Team Foundation Server.

The following table outlines the various language combinations that are supported:

Operating system | Team Foundation Server | SharePoint Products
English | English | English
English | Language other than English | Language (or language pack) must match Team Foundation Server
Language other than English | English | English (or English language pack added)
Language other than English | Language must match the operating system | Language (or language pack added) to match Team Foundation Server

The following rules clarify the language requirements for installations of Team Foundation Server.

  • If you are running an English language operating system, you can install any language version of Team Foundation Server. If you are not running an English language operating system, you must install the English version of Team Foundation Server or the version of Team Foundation Server that has been localized for the same language as the operating system.

  • If you want to use SharePoint Products, it must match the language of the installation of Team Foundation Server, or you must install the language pack that matches the language of your installation of Team Foundation Server.

For example, you can install a Japanese version of Team Foundation Server on an English or Japanese operating system but not on a German operating system. If you install a Japanese version of Team Foundation Server, you must also have either a Japanese version of SharePoint Products or the Japanese language pack for SharePoint Products on the server that is running SharePoint Products.

The following components do not have additional language requirements that are specific to working with Team Foundation Server:

  • Team Foundation Build Service

  • Team Foundation Server Proxy

  • Team Explorer

  • Visual Studio Lab Management

Test controllers and agents have their own language requirements. For more information, see the following page on the Microsoft website: Test Controller and Test Agent Requirements

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements


Upgrade Team Foundation Server

[image]

Upgrade Team Foundation Server
Send Feedback

Use this guide to upgrade to the latest release of Team Foundation Server 2013.

You'll find step-by-step guidance here that covers the most popular upgrade tasks, including in-place upgrades and upgrades that involve moving to new hardware and direction on what to do with SharePoint, whether it's running on the same server as TFS or somewhere else. We'll also walk through upgrade of a build machine, as well as adding new features to your upgraded team projects.

  1. Review upgrade requirements

  2. Upgrade TFS application-tier server

  3. Setup a new build server

  4. Add new features to your team projects

  • Q: What should we do with our files with pending changes? Do we have to check them in before we upgrade?

1. Review upgrade requirements

First, read the TFS upgrade requirements. New for this release, SQL Server and SharePoint requirements have changed. Some versions of SharePoint that were previously supported are no longer supported, so you might have to upgrade your SharePoint Farm to continuing using it with TFS.

2. Upgrade TFS application-tier server

Next, choose a server upgrade path.

The steps are different based on whether you're using a basic TFS installation (or Express), or if you're planning to use the same hardware (standard upgrade) or moving to a new machine (advanced upgrade). Select from one of the paths below:

  • Upgrade TFS Basic or Express (basic upgrade)

  • TFS application tier will use the same hardware it's using right now (standard upgrade)

  • TFS Application Tier will use different hardware than it's using right now (advanced upgrade)

TFS server upgrade choices

3. Setup a new build server

After you upgrade the application tier, you might want to install the new build service. At the bottom of the build service installation topic, you'll find some tips on dealing with the build service and upgrade.

Set up Team Foundation Build Service

install build machine for upgrade

4. Add new features to your team projects

You can also use a wizard to add new features to your team projects.

Configure features after a TFS upgrade

Add new features to your team projects

Q & A

Q: What should we do with changes on our dev machines? Do we have to push or check them in before we upgrade?

A: You don't have to check in changes to TFVC files or push changes to Git files. After you've completed the upgrade, your team members can connect to the upgraded server and continue working.

If you're concerned about backing up changes on a local dev machine during the upgrade process, you can:

  • TFVC icon TFVC: Shelve your changes.

  • Git icon Git: Copy or push your repo to a backup location on an alternate machine or storage device.


TFS upgrade requirements

[image]

TFS upgrade requirements
Send Feedback

Review the requirements listed here and then choose a server upgrade path. You can upgrade from any of the following earlier releases:

  • Team Foundation Server 2013 RTM ¹

  • Team Foundation Server 2012 with Update 4 (TFS 2012.4), TFS 2012.3, TFS 2012.2, TFS 2012.1, or TFS 2012 releases

  • Team Foundation Server 2010 with or without Service Pack 1

¹ Unlike Visual Studio 2013, there was no Update 1 for TFS 2013. The first update for TFS 2013 is Update 2.

Tip Tip

Do you need to upgrade from TFS 2008? You must upgrade to TFS 2012 first: There is an ISO of TFS 2012 available for you to prepare your TFS 2008 installation for an upgrade to TFS 2013.

New prerequisite requirements

SQL Server: Before you start your upgrade, you might have to upgrade SQL Server to meet new Team Foundation Server requirements. SQL Server 2008 R2 is no longer supported. SQL Server 2012 with SP1 is supported. For more information, see SQL Server requirements for Team Foundation Server.

Tip Tip

If you're using SQL Server 2012 with SP1, we recommend you also apply cumulative update 2 on top of SP1 to address a critical SQL Server bug around resource consumption. This isn't a hard requirement because the bug only affects a small number of instances, but we wanted you to be aware of it. If you don't apply CU2, you should apply a SQL Server hotfix (KB2793634) to addresses another (different) issue where SQL Server 2012 with SP1 might request an excessive amount of restarts.

SharePoint Products: If you have a portal server, you might have to upgrade it to continue using SharePoint integration. We no longer support Windows SharePoint Services 3.0 or Microsoft Office SharePoint Server 2007. See SharePoint Products requirements for Team Foundation Server.

Tip Tip

Do you need to upgrade SharePoint to a supported version? See Upgrade from Office SharePoint Server 2007 or Windows SharePoint Services 3.0 to SharePoint Server 2013 or SharePoint Foundation 2013

What about skipping reporting or SharePoint during upgrade?

If you don't install reporting or SharePoint, your deployment is simpler, but we don't recommend it. Keep these two features during upgrade because the upgrade configuration will automatically link upgraded projects to the portal and reporting features. If you add a portal or reporting after you upgrade, you cannot easily create these links between all your upgraded projects and the portal.

Tip Tip

Team Foundation Server doesn't support changing languages during an upgrade. You should maintain the locale of your operating system and Team Foundation Server during the upgrade. For more information, see: Language requirements for Team Foundation Server

Next step: choose a server upgrade path

The steps are different based on whether you're using a basic installation, or if you're planning to use the same hardware (standard upgrade) or moving to a new machine (advanced upgrade). Select from one of the paths below:

  • Upgrade TFS Basic or Express (basic upgrade)

  • TFS application tier will use the same hardware it's using right now (standard upgrade)

  • TFS Application Tier will use different hardware than it's using right now (advanced upgrade)

TFS server upgrade choices

Less common upgrade tasks

You can probably skip this section, if you are not using the trial edition of Team Foundation Server, a Team Foundation Server farm, or no one on your team uses Project Server.

Upgrade from the trial edition of Team Foundation Server

If you are using the trial edition of Team Foundation Server and your evaluation period expires or you are ready to upgrade to the full edition, you need to change the product key information to upgrade from the trial to the full edition. For more information, see this topic: Locate or Change the Product Key for Team Foundation Server.

Upgrade from trial edition of Release Management for Visual Studio 2013

Release Management for Visual Studio 2013 has three components (server, client and deployment agent) and you should use the same version of all components throughout your deployment. If you have the trial version of Release Management Server for Team Foundation Server 2013 installed and you upgrade to the full version, you should upgrade all three components before you start to manage any releases. You have to uninstall the trial version of Release Management to install the full version.

For more information, see this topic: Install Release Management

Upgrading a Team Foundation Server application-tier farm

If you have a scaled-out deployment of TFS application tiers that you want to upgrade, you should do one of the following processes, based on the version of the product you're upgrading from.

  • Your TFS farm is TFS 2010: Uninstall Team Foundation Server 2010 from each application tier. After all previous versions have been uninstalled, install TFS 2012 on one of the application tiers and run the upgrade as you would for a standalone deployment. Select any application tier in the farm that you like; it doesn't matter. After the upgrade completes, use the Add an Application Tier wizard to install Team Foundation Server 2012 on the remaining application tiers. This reassembles the farm and completes the farm upgrade.

  • Your TFS farm is TFS 2012 or TFS 2013: Quiesce every application tier in the farm. After all previous versions have been quiesced, install TFS 2013 on one of the application tiers (without uninstalling the previous version of TFS) and run the upgrade as you would for a standalone deployment. Select any application tier in the farm that you like; it doesn't matter. After the upgrade completes, use the Add an Application Tier wizard to install Team Foundation Server 2013 (without uninstalling the previous version of TFS) on the remaining application tiers. This reassembles the farm and completes the farm upgrade.

For more information, see this topic: How to: Create a Team Foundation server farm (high availability)

Upgrading the TFS Extensions for Project Server

If you have integrated Project Server with your TFS deployment and you upgrade TFS, your team projects should continue to work as before, but you won't have access to any new features until you install the new TFS Extensions for Project Server. You should uninstall the old extensions from Project Server and then install the latest version of the extensions on all the servers where it was previously installed. The version of the extensions you use for Project Server should always match the version of Team Foundation Server you're running. For more information, see this topic: How to: Add Project Server to Team Foundation Server


Locate or Change the Product Key for Team Foundation Server

[image]

Locate or Change the Product Key for Team Foundation Server
See Also Send Feedback

To move from the trial edition to the full edition of Team Foundation Server, you must have a valid product key for Team Foundation Server.

You can review the license type, license expiration date, and product key number of your deployment of Team Foundation Server. Problems with an expired or non-valid product key can disrupt your deployment. If you installed a trial edition of Team Foundation Server, you should be careful not to let the license expire. After the license expires, your users will be unable to use Team Foundation Server until you take steps to correct the situation. You might also need to locate the product key of Team Foundation Server for support or record-keeping purposes.

Note Note

If you have any issues during the licensing upgrade process, you can contact support for Visual Studio. For more information, see the following page on the Microsoft Web site: Help and Support and the Team Foundation Server Licensing Whitepaper.

Required Permissions

To perform these procedures, you must be a member of the Administrators security group on the application-tier server for Team Foundation Server and a member of the Team Foundation Administrators group.

To locate or change your product key

  1. Open the administration console of Team Foundation Server.

  2. Expand the name of the server, and review the information in Product ID, License Type, and License Expires.

    The number that appears in Product ID is your product key.

  3. (Optional) If you must change or update your product key, choose Update License.

    The Team Foundation Server License window opens.

  4. Type the product key, and then choose Activate.

Where to find your product key if it does not appear in the administration console

  • On the sleeve of the setup DVD.

  • On the Microsoft Subscriber Downloads web site.

See Also

Other Resources

How to: Locate the Visual Studio Product Key


Upgrade TFS Basic or Express

[image]

Upgrade TFS Basic or Express
Send Feedback
Basic TFS upgrade

To upgrade Team Foundation Server Basic or Express

Tip Tip

This topic is for upgrading a basic installation of TFS (no SharePoint, no reporting). If you have an installation with SharePoint or reporting, consider using the standard TFS upgrade (an in-place upgrade) or the advanced TFS upgrade (move TFS to a new machine) instead.

For more information, see: TFS application tier will use the same hardware it's using right now or TFS Application Tier will use different hardware than it's using right now

Step 1 Double Check. Verify that the operating system and hardware meet the requirements for the new version of Team Foundation Server. You must use a 64-bit server if you use a server operating system.

Determine the service account you will use for Team Foundation Server. By default, TFS uses Network Service. In most cases, you should use the same account you used for the previous installation or consider using Network Service.

For more information, see: System requirements for Team Foundation Server, or Accounts required for installation of Team Foundation Server.

Step 2 Visit Microsoft Update. If you're using SQL Server Express for TFS, use Microsoft Update to make sure that SQL Server Express has the latest service pack (SP). Similar to Windows Update, Microsoft Update is for Microsoft software other than operating systems. Use the Windows Update Control Panel to opt into Microsoft Update and check for updates.

Tip Tip

If you don't know if you're using SQL Express, look at the Application Tier node in the TFS administration console. Scroll down to Data Tier Summary and look for SQLServerExpress to confirm.

Step 3 Uninstall TFS 2010. Use Control Panel to completely uninstall Team Foundation Server 2010. If you're upgrading TFS 2012, you don't have to uninstall the old version of TFS. You can skip this step and we'll even preserve some of your settings.

Uninstall previous version

Step 4 Upgrade TFS. Run the Team Foundation Server install from the product DVD and then use the Upgrade Configuration wizard to upgrade your installation.

For more information, see: Run the TFS Upgrade Wizard

Next Step: Set up a new build machine

After you upgrade the application tier, you might want to install the new build service.

For more information, see Set up Team Foundation Build Service

install build machine for upgrade


TFS application tier will use the same hardware it's using right now

[image]

TFS application tier will use the same hardware it's using right now
Send Feedback

Illustration of an In-place Upgrade

In place upgrade

To do an in-place upgrade of Team Foundation Server

Step 1 Double check. Verify that the operating system and hardware meet the requirements for the new version of Team Foundation Server.

Determine the service account you will use for Team Foundation Server. By default, TFS uses Network Service, but you can also use a domain account. In most cases, you should use the same account you used for the previous installation or consider using Network Service.

For more information, see: System requirements for Team Foundation Server, or Accounts required for installation of Team Foundation Server.

Step 2 Uninstall TFS 2010. Use Control Panel to completely uninstall Team Foundation Server 2010. If you're upgrading TFS 2012, you don't have to uninstall the old version of TFS. You can skip this step and we'll preserve some of your application tier settings.

Tip Tip

If SharePoint is running on a computer other than Team Foundation Server, you have to uninstall the TFS extensions for SharePoint from the SharePoint server, too. If SharePoint Products is on the TFS application-tier, don't worry. We uninstall the TFS extensions for SharePoint at the same time as we remove the old version of TFS.

Uninstall previous version

Step 3 Upgrade TFS. Run the Team Foundation Server install from the product DVD and then use the Upgrade Configuration wizard to upgrade your installation. But wait-if SharePoint Products is running on a computer other than Team Foundation Server, you'll first want to install the new TFS Extensions for SharePoint on the SharePoint server. Similar to the previous step, if SharePoint Products is on the TFS application-tier, we'll install the Extensions for SharePoint at the same time that we set up the new version of TFS.

For more information, see: Run the TFS Upgrade Wizard.

Tip Tip

If you have Project Server added to TFS, this is when you should upgrade the TFS Extensions for Project Server. See the heading "Less-common upgrade tasks" for more information in TFS upgrade requirements.

Next Step: Set up a new build machine

After you upgrade the application tier, you might want to install the new build service.

For more information, see Set up Team Foundation Build Service.

install build machine for upgrade


TFS Application Tier will use different hardware than it's using right now

[image]

TFS Application Tier will use different hardware than it's using right now
Send Feedback

Illustration of migration upgrade

Migration upgrade

To do a hardware swap (migration) upgrade of Team Foundation Server

Step 1 Double Check. Verify that the operating system and hardware meet the requirements for Team Foundation Server. You must use a 64-bit server if you use a server operating system.

Determine the service account you will use for Team Foundation Server. By default, TFS uses Network Service, but you can also use a domain account. In most cases, you should use the same account you used for the previous installation or consider using Network Service.

For more information, see System requirements for Team Foundation Server, or Accounts required for installation of Team Foundation Server.

Step 2 Set up SQL Server. You're going to install all the SQL Server features that TFS requires on the same server where you'll eventually run TFS.

For more information, see Set up SQL Server for TFS

SQL R2 installation

Step 3 Set up SharePoint Products. If you don't skip the portal setup, you have two options for how to deal with SharePoint:

Option one: Use the same SharePoint site for TFS that you have right now

If your old SharePoint server is still running, you can continue to use it. Go to the SharePoint server and uninstall the old extensions, and then install the new extensions before you upgrade TFS. If SharePoint and the previous version of TFS were on the same computer, you have to uninstall the entire TFS 2010 application tier. In the new upgraded configuration, the only TFS component on the SharePoint server will be the TFS extensions for SharePoint.

For more information, see Use the same SharePoint site for TFS that you have right now

Use the same SharePoint site for TFS that you have

Option two: Move SharePoint to New Hardware for TFS

You can install SharePoint Foundation using the TFS extensions for SharePoint wizard. The TFS wizard will install a fresh copy of SharePoint using the installation of SQL Server you just set up, and then configure the TFS extensions for the new installation of TFS. After you install SharePoint, you'll detach its content database to prepare for the migration of the data from your previous SharePoint installation in step 4, Restore Data.

For more information, see Move SharePoint to new hardware for TFS

Move SharePoint to New Hardware for TFS

Step 4 Restore data. You can use the TFS custom backup and restore tools to manage your data. First you're going to back up your data, including the encryption key on the report server. Next, you're going to restore your data to the SQL Server instance you set up in step 2. With the restore complete, you'll use the SQL Server Reporting tool to restart the report server database, restore its encryption key, and then verify access. If you installed SharePoint, you'll use a SharePoint command line tool to attach and upgrade your content database.

For more information, see Back up and restore data for TFS

back up and restore data

Step 5 Upgrade TFS. Run the Team Foundation Server install from the product DVD and then use the Upgrade Configuration wizard to upgrade your installation.

For more information, see Run the TFS Upgrade Wizard

Tip Tip

If you have Project Server added to TFS, this is the point where you should upgrade the TFS Extensions for Project Server. See the heading "Less-common upgrade tasks" for more information in TFS upgrade requirements

Next Step: Set up a new build machine

After you upgrade the application tier, you might want to install the new build service. For more information, see Set up Team Foundation Build Service.

install build machine for upgrade


Set up SQL Server for TFS

[image]

Set up SQL Server for TFS
Send Feedback
SQL R2 installation

How to set up SQL Server

Install SQL Server 2012 SP1 for Team Foundation Server with reporting.

If you're using SQL Server 2012 with SP1, we recommend you also apply cumulative update 2 on top of SP1 to address a critical SQL Server bug around resource consumption. This isn't a requirement because the bug only affects a small number of instances, but we wanted you to be aware of it.

Upgrade tips for SQL Server

  • Make sure the default collation settings in SQL Server match the existing settings from the SQL Server instance that you're migrating from. For more information, see: SQL Server Collation Requirements for Team Foundation Server

  • Make sure your data compression settings in the new SQL Server instance are the same as they were in the previous instance, especially if you're changing from Enterprise edition to a different SQL Server edition.

Required Permissions

You must be a member of the Administrators security group on Windows Server.

  1. Insert the installation DVD for a supported version of SQL Server and launch setup.exe.

    More information: SQL Server requirements for Team Foundation Server.

  2. On the SQL Server Installation Center page, choose Installation, and then choose New installation or add features to an existing installation.

    New installation of SQL Server

  3. On the Setup Support Rules page, choose OK.

  4. On the Product Key page, type your product key or specify a free edition.

  5. On the License Terms page, accept the license agreement.

  6. On the Setup Support Rules page, choose Next.

    Windows Firewall warning
    Tip Tip

    A Windows Firewall warning might appear, but you can safely ignore this warning. TFS automatically adds an exception for Windows Firewall during upgrade in this topology.

  7. On the Setup Role page, choose SQL Server Feature Installation.

  8. On the Feature Selection page, select the following check boxes:

    • Database Engine Services (required)

    • Full-Text and Semantic Extractions for Search (required)

    • Analysis Services (required for reporting)

    • Reporting Services - Native (required for reporting)

    • Management Tools - Basic (not pictured)

  9. On the Installation Rules page, choose Next.

  10. On the Instance Configuration page, choose Default instance. If you choose Named instance, type the name of the instance..

  11. On the Disk Space Requirements page, choose Next.

  12. On the Server Configuration page, accept the defaults.

  13. In the Startup Type column, verify that Automatic appears for all services that you can edit, and then choose Next.

    Server Configuration (details)
    Note Note

    Are you using a non-English version of SQL Server? The default collation settings for U.S. English meet the requirements for Team Foundation Server. If you're not using English, you can set collation settings for the Database Engine on this page. For more information, see SQL Server Collation Requirements for Team Foundation Server.

  14. On the Database Engine Configuration page, choose Windows authentication mode, choose Add Current User.

    Database Engine Configuration

  15. On the Analysis Services Configuration page, choose Add Current User.

    Analysis Services Configuration

  16. On the Reporting Services Configuration page, choose Install and configure.

    Reporting Services Configuration

  17. (Optional) On the Error and Usage Reporting page, specify whether to send information about errors.

  18. On the Installation Rules page, choose Next.

  19. On the Ready to Install page, review the list of components to be installed, and then choose Install.

Next Step: Set up SharePoint

If you don't skip the portal setup, you have two options for how to deal with SharePoint (if you don't want to deal with SharePoint, you can move on to step 4, Back up and restore data for TFS):

Use the same SharePoint site for TFS that you have right now

If your old SharePoint server is still up and running, you can continue to use it. Go to the SharePoint server and uninstall old extensions, and then install the new extensions before you upgrade TFS. If SharePoint and the previous version of TFS were on the same computer, you have to uninstall the entire TFS 2010 application tier. In the new upgraded configuration, the only TFS component on the SharePoint server will be the TFS extensions for SharePoint.

For more information, see: Use the same SharePoint site for TFS that you have right now

install new TFS extensions

Move SharePoint to New Hardware for TFS

You can install SharePoint Foundation using the TFS extensions for SharePoint wizard. The TFS wizard will install a fresh copy of SharePoint using the installation of SQL Server you just set up, and then configure the TFS extensions for the new installation of TFS. After you install SharePoint, you'll detach its content database to prepare for the migration of the data from your previous SharePoint installation in step 4, Back up and Restore Data.

For more information: Move SharePoint to new hardware for TFS

install new SharePoint 2010


Move SharePoint to new hardware for TFS

[image]

Move SharePoint to new hardware for TFS
Send Feedback
install new SharePoint 2010

How to set up a new SharePoint site

You can install SharePoint Foundation using the TFS extensions for SharePoint wizard. The TFS wizard will install a fresh copy of SharePoint using the installation of SQL Server you just set up, and then configure the TFS extensions for the new installation of TFS. After you install SharePoint, you'll detach its content database to prepare for the migration of the data from your previous SharePoint installation in step 4, Back up and Restore Data.

Required Permissions

You must be a member of the administrators security group on Windows Server.

Install SharePoint and the TFS extensions

Run the TFS installation program from the product DVD and then use the Configure Extensions for SharePoint Products wizard.

To run the Team Foundation Server installer

  1. Insert the Team Foundation Server DVD in the drive and launch the tfs_server.exe file to begin the installation.

  2. On the license terms dialog box, accept the license terms and then choose Install Now.

    If you want to install Team Foundation Server to a specific location in the file system, choose the browse button (...) next to the default install location.

To install SharePoint

  1. In the Team Foundation Server Configuration tool, choose Configure Extensions for SharePoint Products and then choose Start Wizard.

    The Team Foundation Server SharePoint Extensions Configuration wizard appears.

  2. Read the Welcome screen, and choose Next.

  3. Take these steps to install SharePoint:

    1. Choose the big Install SharePoint Foundation 2013 button. Once the install completes, choose Next.

    2. Type the name of the SQL Server or named instance that will host the configuration databases for SharePoint and choose Next.

    3. Type a user account and password for the service account for SharePoint and then choose Next.

      For more information, see Accounts required for installation of Team Foundation Server

  4. On the Review page, review the settings and choose Next.

    The wizard validates your configuration.

  5. Choose Configure.

    The wizard applies configuration settings. This process might take several minutes.

  6. Choose Next, Close, Close.

    The Team Foundation Server Administration Console appears.

Add the TFS service account to the Farm Administrator group

If you're using the same SharePoint site from your previous deployment, you may already have the TFS service account in the Farm Administrators group. If so, you can skip this step. Otherwise, you should follow the steps below to ensure the service account that you will use for TFS is added to the Farm Administrators group on SharePoint.

How do you know if this step is necessary? Here are two potential scenarios that would require you to perform this step.

  • If you're planning to change the account you're using for the TFS service account during TFS upgrade, you should add the new account to the Farm Administrators group.

  • If you are using Network Service and you're planning to migrate the TFS application tier to new hardware, you should add the name of the new hardware followed by a $ symbol (Domain\ServerName$) to the Farm Administrators group.

To add the service account to the Farm Administrators group

  1. In a web browser, open the SharePoint 2013 Central Administration site.

  2. Under Security, choose Manage the farm administrators group.

  3. Choose New.

  4. In the Users/Groups box, enter the name of the service account for Team Foundation Server.

    If you're using Network Service, add the server name followed by a $ symbol. For example, domain\servername$. SharePoint might not find the name but will allow you to enter it into the list.

  5. Choose Share.

Detach the SharePoint content database

When you installed SharePoint, a brand new content database was created for SharePoint. You need to detach this database to prepare for the migration of data from your previous SharePoint installation in step 4, Back up and Restore Data.

To detach the content database

  1. In a web browser, open the SharePoint 2013 Central Administration site.

  2. Under Application Management, choose Manage Content Databases.

  3. Choose WSS_Content.

    Note Note

    WSS_Content is the default name. Your installation might use a custom name for this database.

    The Manage Content Database Settings page opens.

  4. Select the Remove content database check box, and then choose OK.

    Note Note

    This step detaches the database but does not delete any content.

  5. In the warning dialog box that appears, choose OK.

  6. In Manage Content Database Settings, choose OK to confirm your changes.

Next Step: Back up and restore data

You can use TFS custom backup and restore tools to manage your data. First you're going to back up your data, including the encryption key on the report server. Next, you're going to restore your data to the SQL Server instance you set up in step 2. With the restore complete, you'll use the SQL Server Reporting tool to restart the database, restore the encryption key, and then verify access to the report server. If you installed SharePoint, you'll use a SharePoint command line tool to attach and upgrade your content database

For more information, see Back up and restore data for TFS

back up and restore data


Back up and restore data for TFS

[image]

Back up and restore data for TFS
Send Feedback
back up and restore data

How to back up and restore TFS data to new hardware

If you haven't installed TFS on the new hardware yet, you'll want to do that now. You can use TFS custom backup and restore tools to manage your data.

Tip Tip

If you're upgrading from TFS 2012 with update 2 (TFS 2012.2) or higher, you can use the TFS built-in functionality to create your back up and restore it.

First you're going to back up your data, including the encryption key on the report server that you used with the previous version of TFS. Next, you're going to restore your data to the SQL Server instance you set up in step 2. With the restore complete, you'll use the SQL Server Reporting tool to restart the report server database, restore its encryption key, and then verify access to the report server. If you installed SharePoint, you'll use a SharePoint command line tool to attach and upgrade your content database.

Required Permissions

You must be a member of the administrators security group on Windows server of the new hardware and the old.

If you plan to configure reporting, you must also be a member of the administrators security group on the server that is running SQL Server Reporting Services. If you plan to configure SharePoint Products, you must be a member of the farm administrators group on the SharePoint Products administration site. If you did not install the Database Engine that will host the configuration database or a database administrator manages the instance of SQL Server that you are using, you must be a member of sysadmin Server role in SQL Server.

Back up your data

If you haven't installed TFS on the new hardware yet, you'll want to do that now to access the TFS custom backup and restore tools. You're going to back up all of your TFS data, including the encryption key for the report server.

Tip Tip

All your data needs to be backed up to the same point in time in order for the restore and upgrade to work correctly. The only reason to not back up a database would be, for example, if you have reporting in the old TFS instance, but you're not going to use reporting in the new TFS instance.

To run the Team Foundation Server installer

  1. Insert the Team Foundation Server DVD in the drive and launch the tfs_server.exe file to begin the installation.

  2. On the license terms dialog box, accept the license terms and then choose Install Now.

    If you want to install Team Foundation Server to a specific location in the file system, choose the browse button (...) next to the default install location.

To back up the encryption key for reporting services

  1. Launch Reporting Services Configuration Manager.

    The Reporting Services Configuration Connection dialog box opens.

  2. Specify the name of the report server you used with the previous version of TFS and then choose Connect.

  3. In the navigation bar on the left side, choose Encryption Keys, and then choose Backup.

    The Encryption Key Information dialog box opens.

  4. In File Location, specify the location where you want to store a copy of this key.

    Consider storing this key on the new hardware, so that it's easily accessible when you restore the Reporting Services databases.

  5. In Password, specify a password for the file.

    Don't forget the password! You'll need it later on to restore the Reporting Services databases.

  6. In Confirm Password, specify the password for the file again.

  7. Choose OK.

To back up your databases

  1. Launch TFSBackup.exe.

    The TFSBackup.exe tool is in the Tools folder where you installed Team Foundation Server. The default location is C:\Program Files\Microsoft Team Foundation Server 12.0\Tools.

  2. In Source SQL Server Instance, enter the name of the SQL Server instance that hosts the TFS databases you want to back up and choose Connect.

  3. In Select databases to backup, choose the databases to back up.

    Need help? List of TFS 2010 databases on MSDN; List of TFS 2012 databases on MSDN.

  4. In Backup Databases to, enter the name of a network share that is configured with read/write access for Everyone, or accept the default location in the file system of the SQL Server you connected to in step 2.

    Note Note

    If you want to overwrite backups stored in this network location, you can choose Overwrite existing database backups at this location.

  5. Choose Backup Now.

    The Backup tool reports progress on each database being backed up.

  6. Choose Close.

Restore your data

To restore your TFS data

  1. Launch TFSRestore.exe.

    The TFSRestore.exe tool is in the Tools folder where you installed Team Foundation Server. The default location is C:\Program Files\Microsoft Team Foundation Server 12.0\Tools.

  2. In Target SQL Server Instance, enter the SQL Server instance you will use as the data tier and choose Connect.

  3. Choose Add Share and enter the UNC path to the network share that is configured with read/write access to Everyone where you stored the backups of your TFS data. For example, \\servername\sharename\.

    If the backup files are located on the file system of the server that is running TFSRestore.exe, you can use the drop down box to select a local drive.

    Note Note

    The service account for the instance of SQL Server you identified at the start of this procedure must have read access to this share.

  4. In the left hand navigation pane, choose the network share or local disk you identified in the previous step.

    The TFS Restore Tool displays the database backups stored on the file share.

  5. Select the check boxes for the databases you want to restore to the SQL Server you identified at the start of this procedure.

    Important note Important

    For SharePoint, you must only restore the WSS_Content database. Do not restore the WSS_AdminContent or WSS_Config databases. You want the new SharePoint Foundation versions of these databases, not the ones from the previous version of SharePoint or from a SharePoint installation running on any other server.

  6. Choose Overwrite the existing database(s) and then choose Restore.

    The Database Restore Tool restores your data and displays progress reports.

  7. Choose Close.

Fix up the report server

To restart the Reporting Services database and restore its encryption key

  1. Launch the Report Server Configuration tool and restore the original reporting database and its encryption key to your new instance of SQL Server Reporting Services.

  2. In Reporting Services Configuration Connection, specify the name of the server where you installed Reporting Services for TFS 2013 and choose Connect.

  3. On the Database page, choose Change Database.

    The Report Server Database Configuration Wizard appears.

  4. Choose Choose an existing report server database and then choose Next.

  5. In Server Name, type the name of the SQL server you used in the TFS Database Restore Tool to restore your report server databases and choose Next.

  6. Choose the report server database you restored with the TFS Database Restore Tool and then choose Next.

    If you haven't changed the name, the default database name is ReportServer.

  7. On the Credentials page, choose Next.

  8. On the Summary page, review the information and then choose Next.

    The wizard configures the database and displays progress reports.

  9. On Encryption Keys page, choose Restore.

    The Restore Encryption Key window opens.

  10. In File Location, specify the location of the backup file for the encryption key. In Password, specify the password you used when you backed up the encryption key, and then choose OK.

    The status of the restoration appears in Results.

  11. On the Scale-out Deployment page, choose the previous report server from the scale-out deployment status page and choose Remove Server.

  12. On the Report Manager URL page, use the hyperlink in URL to launch the Report Manager site.

    The report manager site appears. Your report server has been restored.

  13. Choose Exit to close Reporting Services Configuration Manager.

Fix up SharePoint server

To run the STSADM command line tool for SharePoint

  1. Open a Command Prompt as an administrator on the new hardware that is running SharePoint Foundation.

  2. Change directories to this location:

    Drive:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\bin\

    Where Drive is the drive letter.

  3. In the command prompt, type the following command:

    stsadm.exe -o addcontentdb -url http://WSSServerName/sites -databasename contentdatabase -databaseserver SQLServerName

    Where:

    • WSSServerName is the name of the SharePoint server;

    • contentdatabase is the name of the content database;

    • SQLServerName is the name of the SQL Server that hosts the content database.

  4. In the command prompt, type the following command:

    stsadm.exe -o addpermissionpolicy -url http://WSSServerName -userlogin Domain\UserName -permissionlevel "full control"

    Where:

    1. WSSServerName is the name of the SharePoint server;

    2. Domain\UserName is the user name and domain of the account used to run the TFS SharePoint configuration wizard and install SharePoint.

Next Step: Run the TFS Upgrade Wizard

Run the Team Foundation Server install from the product DVD and then use the Upgrade Configuration wizard to upgrade your installation.

For more information, see: Run the TFS Upgrade Wizard


Use the same SharePoint site for TFS that you have right now

[image]

Use the same SharePoint site for TFS that you have right now
Send Feedback

install new TFS extensions

How to set up your current SharePoint site

If your current SharePoint site meets the new requirements for TFS 2013, you can continue to use it, if you perform a few procedures. First you have to uninstall the old TFS extensions for SharePoint¹, and then install the new version of the extensions. You also want to make sure the service account that you will use on the upgraded Team Foundation Server is a member of the Farm administrators group. If you're currently using Windows SharePoint Services 3.0 or SharePoint Server 2007, you'll have to upgrade to supported version of SharePoint. For more information, see Upgrade from Office SharePoint Server 2007 or Windows SharePoint Services 3.0 to SharePoint Server 2013 or SharePoint Foundation 2013

Tip Tip

¹ If you're upgrading TFS 2012, you don't have to uninstall the old version of TFS extensions.

Required Permissions

To perform these procedures, you must be a member of the Administrators security group on Windows Server and a member of the Farm Administrators group in Windows SharePoint Services 3.0.

Uninstall the old TFS extensions

Uninstall previous version

On the SharePoint site you were using with TFS 2010, uninstall the TFS Extensions for SharePoint.

If SharePoint and the previous version of TFS were on the same computer, you have to uninstall the entire TFS application tier. In the new upgraded TFS deployment, your SharePoint server will be on a different server than the TFS application tier, and the only TFS component on the SharePoint server will be the TFS extensions for SharePoint.

Tip Tip

If you're upgrading TFS 2012, you don't have to uninstall the old version of TFS. You can skip this step and install the new TFS extensions without uninstalling the old.

Install the new TFS extensions

Run the TFS installation program from the product DVD and then use the Configure Extensions for SharePoint Products wizard.

To run the Team Foundation Server installer

  1. Insert the Team Foundation Server DVD in the drive and launch the tfs_server.exe file to begin the installation.

  2. On the license terms dialog box, accept the license terms and then choose Install Now.

    If you want to install Team Foundation Server to a specific location in the file system, choose the browse button (...) next to the default install location.

To configure Team Foundation Server Extensions for SharePoint Products

  1. In the Team Foundation Server Configuration tool, choose Configure Extensions for SharePoint Products and then choose Start Wizard.

    The Team Foundation Server SharePoint Extensions Configuration wizard appears.

  2. Read the Welcome screen, and choose Next.

  3. Since SharePoint Products is already installed, skip to the next step. If SharePoint weren't installed, you'd take these steps:

    1. Choose the big Install SharePoint Foundation 2013 button. Once the install completes, choose Next.

    2. Type the name of the SQL Server or named instance that will host the configuration databases for SharePoint and choose Next.

    3. Type a user account and password for the service account for SharePoint and then choose Next.

      For more information, see Accounts required for installation of Team Foundation Server

  4. On the Review page, review the settings and choose Next.

    The wizard validates your configuration.

  5. Choose Configure.

    The wizard applies configuration settings. This process might take several minutes.

  6. Choose Next, Close, Close.

    The Team Foundation Server Administration Console appears.

Add the TFS service account to the Farm Administrator group

If you're using the same SharePoint site from your previous deployment, you may already have the TFS service account in the Farm Administrators group. If so, you can skip this step. Otherwise, you should follow the steps below to ensure the service account that you will use for TFS is added to the Farm Administrators group on SharePoint.

How do you know if this step is necessary? Here are two potential scenarios that would require you to perform this step.

  • If you're planning to change the account you're using for the TFS service account during TFS upgrade, you should add the new account to the Farm Administrators group.

  • If you are using Network Service and you're planning to migrate the TFS application tier to new hardware, you should add the name of the new hardware followed by a $ symbol (Domain\ServerName$) to the Farm Administrators group.

To add the service account to the Farm Administrators group

  1. In a web browser, open the SharePoint Central Administration site.

  2. Under Security Configuration, choose Manage the farm administrator's group.

  3. Choose New.

  4. In the Users/Groups box, enter the name of the service account for Team Foundation Server.

    If you're using Network Service, add the server name followed by a $ symbol. For example, domain\servername$. SharePoint might not find the name but will allow you to enter it into the list.

  5. Choose Share.

Next Step: Which server upgrade path are you on?

  • If you're doing an in-place upgrade, go to Step 3, Run the TFS Upgrade Wizard.

  • If you're doing a migration upgrade, go to Step 4, Back up and restore data for TFS.

Install TFS on same hardware

install TFS on different hardware


Run the TFS Upgrade Wizard

[image]

Run the TFS Upgrade Wizard
See Also Send Feedback

How to run the TFS upgrade wizard

First, install TFS, then run the upgrade configuration wizard. If you move the TFS application tier to new hardware, you must update the URL for the application tier after you finish running the TFS upgrade wizard.

Tip Tip

After you install TFS, its configuration tool appears automatically. If for some reason you don't see it, you can access it from the TFS administration console. Launch TFS administration console from the Start menu. In the admin console, choose Application Tier, and then choose Configure Installed Features.

Required Permissions

You must be a member of the Windows Administrators security group. If you're upgrading a basic TFS installation, these are the only permissions you need. If you plan to configure reporting, you must also be a member of the Windows Administrators security group on the server that is running SQL Server Reporting Services. If you plan to configure SharePoint Products, you must be a member of the Farm Administrators group on the SharePoint Products administration site. If you did not install the Database Engine that will host the configuration database or a database administrator manages the instance of SQL Server that you are using, you must be a member of sysadmin Server role in SQL Server.

To run the Team Foundation Server installer

  1. Insert the Team Foundation Server DVD in the drive and launch the tfs_server.exe file to begin the installation.

  2. On the license terms dialog box, accept the license terms and then choose Install Now.

    If you want to install Team Foundation Server to a specific location in the file system, choose the browse button (...) next to the default install location.

To run the Team Foundation Server upgrade wizard

  1. In the Team Foundation Server Configuration tool, choose Upgrade, and then choose Start Wizard. If you have TFS 2012 or TFS 2013 installed, the wizard opens automatically and you can skip this step.

  2. Read the Welcome screen and choose Next.

  3. Type the name of the SQL Server instance that hosts the data from an earlier version of Team Foundation Server, and choose List Available Databases. If your configuration database is part of an AlwaysOn Availability Group, you will be prompted to confirm that you want to upgrade in full recovery mode.

    The wizard lists deployments of Team Foundation Server that you can upgrade. If multiple deployments are listed, choose the one that you want to upgrade.

  4. Select the By checking this box, I confirm that I have a current backup check box, and then choose Next.

    If you need to do a backup, you can choose Click here to launch the Database Backup Tool, follow the steps below, then continue with the TFS upgrade wizard.

    The TFS Database Backup Tool displays the databases it finds on the SQL Server instance specified in SQL Server Instance.

    1. In Select databases to back up, choose the databases to back up.

      Need help? List of TFS 2010 databases on MSDN; List of TFS 2012 databases on MSDN

    2. In Backup Databases to, accept the default location or enter another location.

      Note Note

      If you want to overwrite backups stored in this network location, you can choose Overwrite existing database backups at this location.

    3. Choose Backup Now.

      The Backup tool reports progress on each database being backed up.

    4. Choose Close.

  5. Choose Use a system account to use a built-in account, or choose Use a user account to use a domain or local account. If you are using a user account, you must type its password. To test the user account and password combination, choose Test.

    Network Service is the default value for this service account.

  6. Under Authentication Method, choose NTLM or Negotiate (Kerberos), and then choose Next.

    • If you choose NTLM, NTLM authentication is used. This option is the default setting.

    • If you choose Negotiate (Kerberos), Kerberos authentication is attempted first. If that authentication fails, NTLM authentication is used.

  7. Set up your file cache location. Make sure you have at least 50 Gb of free space. If you use a drive other than your Windows drive, TFS will perform better.

    On client operating systems, you must skip to step 10. You cannot configure SharePoint Products or the reporting feature of Team Foundation Server (steps 8 and 9) on a client operating system.

  8. Select the Configure Reporting for use with Team Foundation Server check box to use reporting, or clear the check box to skip reporting, and then choose Next.

    Tip Tip

    If you skip reporting and add it later during an upgrade, you may need to use different database names for the reporting warehouse databases (TFS_Warehouse and TFS_Analysis). As an alternative, you can delete the old reporting databases and new databases will be created using the default names.

    1. Enter the name of the server that is running SQL Server Reporting Services in Reporting Services Instance and choose Populate URLs.

      The URLs for the report server and its management site appear in the drop-down lists for Report Server URL and Report Manager URL.

    2. Choose the URLs that you want to use for Team Foundation Server and then choose Next.

    3. Type the name of the server that is running the Database Engine and Full-Text Search to host the warehouse database, and then choose List Available Databases.

      The wizard lists available warehouse databases that you can upgrade. Choose the database that you want to upgrade, and then choose Next.

      You can choose Test to test the connection to SQL Server.

    4. Enter the name of the server that is running SQL Server Analysis Services in SQL Analysis Services Instance and choose Next.

      To test the connection to SQL Server, choose Test.

    5. Enter the name and the password of the report reader account and choose Next. If you specified a user account for the service account of Team Foundation Server in step 5 and you want to use a different account in this step, you must select the Use a different account than the Team Foundation Server service account for the Reporting Services report reader account check box.

      Choose Test to test the user account and password combination.

  9. Select the Configure SharePoint for use with Team Foundation Server check box to configure SharePoint Products or clear the check box to skip the step, and choose Next.

    If you selected SharePoint Products configuration perform one of the following steps:

    • Choose Use current SharePoint settings to retain your settings for SharePoint Products, and then choose Next.

      You typically use this option to continue to use the existing portal, which must have the new Team Foundation Server Extensions for Windows SharePoint Services installed and configured. If your portal is on the server you are upgrading, the new extensions are configured automatically.

    • Choose Change current settings to point to a different SharePoint farm, enter the URL for the SharePoint web application and the SharePoint Administration site, and then choose Next. To test the connection to each of these URLs, you can choose Test.

      You typically use this option to migrate to a new portal, which must contain your migrated data for SharePoint Products.

  10. On the Review page, review your settings, and choose Next.

    The wizard validates your configuration.

  11. Choose Configure.

    The wizard applies configuration settings.

    Tip Tip

    Did you get error TF255356 when you tried to upgrade from TFS 2012 (or TF400744 with TFS 2010)? These are misleading error messages. Read this blog post to recover: TF255356: Known Issue with Configuring TFS 2013 RTM Express and Basic

  12. Choose Next.

    Your data is upgraded, and progress reports appear and detail the steps that are being performed.

  13. Choose Next.

  14. Read the final summary screen, and then choose Close twice-once in the wizard and then again in the configuration tool.

Tip Tip

If you have Project Server added to TFS, this is when you should upgrade the TFS Extensions for Project Server. See the heading "Less-common upgrade tasks" for more information in TFS upgrade requirements

Update the URL for TFS

If you did an in-place upgrade, you can ignore both these procedures.

If you migrated the TFS application tier to new hardware, you have to update the URL for TFS on the application tier and in the TFS SharePoint Extensions.

Update the URL for TFS on the application tier

  1. On the TFS application-tier, open the administration console for Team Foundation Server.

  2. In the navigation bar, choose Application Tier, and then click Change URLs.

    The Change URLs window opens.

  3. In Notification URL, type the URL for the new application-tier server, and then choose OK.

Update the URL for the TFS application tier in the TFS Extensions for SharePoint

  1. On server running SharePoint, open the administration console for Team Foundation Server.

  2. In the navigation bar, choose Extensions for SharePoint Products, select the SharePoint Web Application and then choose Modify access.

    The Access for Team Foundation Server window opens.

  3. In URL for Team Foundation Server, type the URL for the new application-tier server, and then choose OK.

See Also

Concepts

TFS upgrade requirements
How to: Set up remote SharePoint Products for Team Foundation Server


Configure features after a TFS upgrade

[image]

Configure features after a TFS upgrade
Send Feedback

After a Team Foundation Server (TFS) upgrade, you'll want to use the new features that were installed. Some of these features might require updates to your team project. The Configure Features wizard is the easiest way to make this happen.

If you need to upgrade TFS, go to the downloads page.

Do you have a lot of team projects that need to be updated? If so, you can apply updates programmatically.

Run the Configure Features wizard

  1. If you're not a team project administrator, get added as one. Only project administrators or TFS administrators can run the wizard.

  2. Open the administration page for your team project from a supported browser (http://ServerName:8080/tfs/CollectionName/ProjectName/_admin).

  3. If you see a Configure Features link, run the wizard.

    Configure features for TFS 2013.2

    The options in the list depend on the TFS versions that have been installed on your application-tier server and the features that have been previously configured. To get the latest process templates, upgrade your server to the latest version.

    If Test Plan and Test Suite are not configured, go to Manual updates to support test management. You will need to manually import the WIT definitions and migrate data after you have upgraded your application-tier server to TFS 2013.3.

    If you don't see the Configure Features link, your features have been enabled. You can start using the new features.

  4. If you receive a message similar to the one shown below, you can configure your team project. If more than one process template is available, accept the recommended version.

    Updated team project with unconfigured features

    If the dialog box doesn't contain a Configure option, then you'll need to apply the updates manually.

  5. In most cases, the wizard will configure all the new features and you'll receive a success message.

    Success message upon configuring features

    Occasionally, the wizard will partially update your team project and return error messages that require resolution. Make a note of the errors that you receive and perform manual updates to resolve each error.

Post configuration steps

  • If you have updated a team project based on v5.0 of MSF for Agile, do the manual updates described in Update the Workflow for Agile Team Projects.

  • If you have team members that will use one or more of the following TWA features, you'll need to provide them Full access to TWA.

    • Portfolio Backlogs

    • Feedback

    • Team Rooms

    • Test case management, Test Plan and Test Suite

  • If your team will use the feedback request and code review features, make sure that you have configured an SMTP server for TFS.

  • If you are the server administrator for TFS and don't actually contribute to a team, then you may want to remove yourself as a member, and add a project lead as the team administrator. (Your user account was automatically added as a team administrator for the team project when you ran the Configure Features wizard.)

Apply updates manually

When the wizard is unable to update a team project, it will return a message indicating that there are no process templates available to support the update.

Configure features wizard returns error messages

When this occurs, you'll need to perform some manual updates according to one of the following options:

  • If your team project is based on a process template other than those that TFS provides, update the customized process template used to create the team project, and then run the Configure Features wizard.

    TFS process templates correspond to Visual Studio Scrum, MSF for Agile Software Development, and MSF for CMMI Process Development as described here.

  • If your team project has been heavily customized, but not the process template, add the new features manually.

  • If your team project was based on a v4.2 or earlier version of an MSF process template, first apply the updates to comply with TFS 2012 manually. Then run the Configure Features wizard.

Additional customizations to make after enabling new features

After you update your team project with the Configure Features wizard, you have access to the latest features and process templates. However, you still might want to make some additional customizations based on the TFS update you've installed.

Update a team project to TFS 2013.4

You might need to make some additional customizations for teams to choose whether to track bugs on the backlog.

Update a team project to TFS 2013.3

If you have Visual Studio 2013.3 Microsoft Test Manager installed in your environment, you're done with your updates. To learn about the changes introduced with the updated version of Test Manager or Team Web Access, see Plan Manual Tests using Team Web Access.

If you want to customize your test plan or test suite, you can now do that. If you add or change the workflow states for the test plan or test suite type definitions, and you work from a Test Manager client provided with Visual Studio 2013.2 or earlier versions, you must also update the process configuration for the team project as well. Otherwise, you'll encounter an Application detected an unexpected fault error when you connect to your team project. To resolve this error, see Import and export process configuration [witadmin].

Application fault error message after TFS upgrade

Update a team project from TFS 2012 to TFS 2013

There are no additional required customizations to make after updating from TFS 2012 to TFS 2013. However, there are some recommended updates to make to the workflow of specific WITs.

The updates bring your team project up to date with the workflow settings that are defined in the latest versions of the default process templates.

You might want to update the workflow of specific WITs to support missing transitions, additional reasons, and field assignments. Making this update revises the workflow for the following WITs to the latest version of their process template workflow:

  • Scrum 2.0 to Scrum 2013: Product Backlog Item and Bug.

  • Agile 6.0 to Agile 2013: User Story.

  • CMMI 6.0 to CMMI 2013: Requirement.

For details, see Upgrade your 2012 team project from RTM to Update 2.

If you haven't customized your work item types or process configuration, you can update the items quickly by using witadmin. Just download the latest version of the process template that is compatible with the one used to create your team project and then import the updated WITs.

Update a team project from TFS 2010 to TFS 2013

If you've updated a team project that was created with an MSF v 5.0 Agile process template, then you'll also want to manually update the user story and task workflow assignments.

If you don't update the workflow, then the task board provides only two states, Active and Closed. This prevents you and your team from distinguishing between tasks that are in progress from those that haven't been started.

Also, you might want to apply the workflow updates to the User Story as described in Upgrade your 2012 team project from RTM to Update 2.

Q & A

Q: How can I programmatically update many team projects?

A: If the team projects were created from the same process template, you should be able to modify the source process template, upload it, and then batch update all team projects defined for a team project collection. Review the following resources: Update a customized process template to access new features, How to Configure Features for dozens of team projects, and Features4tfs CodePlex solution.

Q: Where can I learn more about how to customize the test experience?

A: See one of the following topics:

  • Field customizations: Add a custom field, modify a pick list, or add a field rule.

  • Work item form customizations : Modify the form layout for the bug, test case, test plan, or test suite.

  • Workflow customizations : Modify the workflow definitions for the bug, test case, test plan, or test suite.

  • Test failure types: Specifies the reasons why a test run failed. The default configuration includes: Regression, New Issue, Known Issue, and Unknown.

  • Test resolution states: Specifies the action to take after a test run failure. The default configuration includes: Needs investigation, Test issue, Product issue, and Configuration issue.

Q: How do I resolve warning or error messages related to the update of test management artifacts with TFS 2013.3?

A: See Manual updates to support test plans and test suites.

Q: How does the Configure Features wizard work?

A: The Configure Features wizard adds new objects to your team project and might update a few existing objects, but does not change your data or the workflow. It adds the new objects based on the best match of settings defined within the installed process templates and your team project. The wizard references both updated customized process templates and the latest version of Microsoft process templates installed to your team project collection and added during the upgrade process. If the wizard determines that there is more than one process template that could be used to configure features, it selects the one that best matches your existing team project and that is the latest version.

Here's what the Configure Features wizard does:

  1. Scans the definitions in the team project to determine which features are and aren't configured.

  2. Determines which process template stored in the team project collection contains the best match of definitions to configure missing features.

  3. For each feature that can be configured, uploads the definitions for new objects or modifies existing definitions. To learn how the wizard configures each specific feature, see Configuration actions made to add each feature.

Q: To run successfully, which elements does the Configure Features wizard depend on?

A: The Configure Features wizard depends on the following elements.

  • The ProcessTemplate file must include the version statement. If the version statement is not present, the Configure Features wizard cannot select the process template for updating a team project. Also, the highest version number must be unique for each template ID. If more than one process template that specifies the same highest version number for the same template ID has been uploaded to TFS, then none of the process templates can be selected for updating a team project.

  • For each field defined for a team project collection, the following attributes must match:

    • Friendly name

    • Data type

    • Assignment to synchronize personal names with Active Directory (syncnamechanges).

    • Reporting attributes: reporting reference name, reporting name, reporting type, and reporting format

  • Reference names assigned to fields and link types must be unique within a team project collection.

  • Friendly names of the categories must be unique within a team project.

  • Certain work item types (WITs) and categories are required for the wizard to configure a feature. If you have renamed or deleted any of these WITs or categories, the wizard will return the following messages:

    There are no process templates available with valid configuration settings for this team project.

    Your team project cannot be configured automatically.

    You will have to rename or reinstate the missing WITs or categories to your team project, and then rerun the wizard. Or, you can modify the process templates to add the features and then rerun the wizard.

If any conflicts occur, you will receive an error message. See Resolve Errors Received When Configuring Features.

Q: I've added portfolio backlogs to my team project. Why can't all team members view them?

A: To view and work with portfolio backlogs requires that each team member has Full access.

Q: Where can I go if I have more questions?

A: You can post a question or search for answers in one of these forums: Team Foundation Server - Work Item Tracking or Team Web Access.


New features enabled for Team Web Access

[image]

New features enabled for Team Web Access
Send Feedback

By installing the latest version of Visual Studio Team Foundation Server (TFS), you can access new features in Team Web Access (TWA).

Some features show up automatically, but others only show up after they've been enabled using the Configure Features wizard. The wizard automatically tries to configure all available features that haven't yet been enabled.

To start using the features that the wizard enables, see the following topics.

Update

New features

TFS 2013.4

See Visual Studio 2013 Update 4 (2013.4) RC.

TFS 2013.3

Test Plan and Test Suite: New work item types (WITs) are added to support customization of test plans and test suites. These additions occur when you run the TFS Upgrade Wizard for TFS 2013.3. They do not require you to run the Configure Feature wizard.

The enhancements support:

  • Test plans and test suites are now work item types (WITs). You can add fields, change the workflow, and customize them like any other work item type.

  • The area path security model now contains permissions to Manage test suites. The Manage test plans permissions has been re-scoped to manage only test plans. Previously it covered permission management of both test plans and test suites.

  • The History field for test-related artifacts now provides a consolidated view of changes made to work item fields as well as changes to related artifacts such as test points and test configurations. A new field, the Test Suite Audit field, available in the test suite work item form, captures and displays these related artifact changes in the work item history.

The server upgrade automatically converts existing test plans and test suites to WITs and migrates test data and links. If it encounters a problem, a warning message appears in the server log. To learn more, see Update a team project manually to support test management.

To learn about changes introduced to Test Manager and Team Web Access, see Plan manual tests

TFS 2013.2

  • Shared Parameter: Use shared parameters to run tests with different data.

TFS 2013

  • Portfolio Backlogs: Work with portfolio backlogs.

Q & A

Q: Where can I get the latest released version of TFS 2013?

A: Go to the Visual Studio downloads.

Q: What other features were added with the upgrade of TFS 2013?

A: See What's New in Planning and Tracking.

Q: What other features were added with the upgrade of TFS 2012?

  • Planning Tools: Create and organize a backlog and Work in sprints.

  • Code Review: Initiate and track code review requests and responses.

  • Feedback: Request and manage feedback.

  • My Work: Organize upcoming, ongoing, and suspended work.

  • Storyboard linking: Access the latest version of storyboards by linking them to work items.

  • Hidden Types Category: Work items added to this category do not appear in New Work Item menus. This category includes Code Review Request and Code Review Response, Feedback Request and Feedback Response, and Shared Steps. Users should create these work item types through a form or a tool.

To use some of these tools, you'll need to be added to the Advanced access group in TWA.

See also What's New in Planning and Tracking (2012 version).


Configuration changes made to add new features

[image]

Configuration changes made to add new features
Send Feedback

When you run the Configure Features wizard, it assesses your existing team project, determines which features are missing, and adds them. Before you can use this wizard, you must upgrade your Team Foundation Server to a later version that contains new features.

Features added with the update to TFS 2013.4

The TFS 2013.4 update doesn't include any updates made with the Configure Features wizard. However, teams can now choose to show bugs on backlogs and boards. If the feature is disabled, the process configuration definition must be updated as described in Add bugs or other work item types to backlogs or boards.

To learn about additional features and enhancements made to Agile planning tools and work item tracking, see What's new in planning and tracking.

Features added with the update to TFS 2013.3

To enable the Test Plan and Test Suite feature, the TFS Upgrade Wizard (not the Configure Feature Wizard) performs the following actions:

  • Adds the Test Plan and Test Suite work item types (WITs)

  • Adds the Test Plan Category and Test Suite Category

  • Adds the Test Plan and Test Suite WITs to the Hidden Types Category

  • Updates the area path security model to include Manage test suites and re-scopes the Manage test plans permissions. For details, see Q: What test functions are controlled by area path permissions?.

  • Creates work items for existing test plan and test suites

  • Migrates existing test management data and creates links to test artifacts-such as test points, test runs, test results-to point to the work item based test plans and test suites

    Note that there are no parent-child links created between test plans and test suites or between test suites and test cases. Therefore, you can't create a query to see a hierarchy of these objects. However, the Test Manager and Team Web Access clients present these objects in relationship to one another.

You can start working with your test plans and test suites in Test Manager.

If one or more of the steps fail, the Test Management subsystem will log a warning or an error. To view these messages, open the Team Foundation Server Administration Console and view the Logs page. To resolve these messages, see Manual updates to support test management.

Important note Important

If, after an upgrade, the Test Plan and Test Suite feature is not configured, you must manually update your team project. The Configure Features wizard doesn't support the end-to-end activities required to migrate existing test plans and test suites.

Features added with the update from TFS 2013 to TFS 2013.2

To enable the Shared Parameter feature, the Configure Features wizard performs the following actions:

  • Adds the Shared Parameter WIT

  • Adds the Shared Parameter Category

  • Adds the Shared Parameter WIT to the Hidden Types Category

The Shared Parameter WIT supports repeating tests with different data.

Features added with the update from TFS 2012 to TFS 2013

To enable the Portfolio Backlog feature, the Configure Features wizard performs the following actions:

  • Adds the Feature WIT

  • Adds the Feature Category

  • Adds ProcessConfiguration, which supports portfolio backlog definition and assignment of colors to WITs

    ProcessConfiguration replaces the AgileConfiguration and CommonConfiguration files introduced in TFS 2012.0

This configuration adds one level of Agile portfolio management support.

Q & A

Q: What permissions do I need to run the Configure Features wizard?

A: To see the Configure Features link to access the wizard, you must be a member of one of the following groups: Team Foundation Administrators, Project Collection Administrators, or Project Administrators for the team project. Or, you must have the Edit project-level permissions set to Allow.

To get added as a Project Collection Administrator, go here.

Q: How do I customize the test management artifacts?

A: After you've upgraded to TFS 2013.3, you can customize the test plan and test suite in the same way you've customized other WITs.

  • Field customizations: Add a custom field, modify a pick list, or add a field rule.

  • Work item form customizations : Modify the form layout for the bug, test case, test plan, or test suite.

  • Workflow customizations : Modify the workflow definitions for the bug, test case, test plan, or test suite.

Q: Why are some WITs added to the Hidden Types Category?

A: WITs that you want users to create using a tool such as Microsoft Test Manager, Code Review, and Request Feedback are added to the Hidden Types Category. WITs belonging to the Hidden Types Category don't appear in menus used to create new work items.

In the TFS 2013.3 Preview version, the following WITs belong to the Hidden Types Category:

  • Code Review Request and Code Review Response

  • Feedback Request and Feedback Response

  • Shared Steps and Shared Parameter

  • Test Plan and Test Suite


Changes made to team projects and default process templates during upgrade of Team Foundation Server

[image]

Changes made to team projects and default process templates during upgrade of Team Foundation Server
Send Feedback

When you upgrade your server to Visual Studio Team Foundation Server (TFS), several changes are made for all team projects defined on the server. A few features have been deprecated.

This topic describes changed and deprecated features. To learn more about new features added since TFS 2012 to support planning and tracking, see What's New in Planning and Tracking.

Changes introduced with the upgrade to TFS 2013

  • Access level: The access level feature sets for Standard and Full Access have changed. See Change access levels for details.

  • TWA navigation and links: The navigation within TWA has changed to support the addition of portfolio backlogs and persistent sprint backlogs.

  • Team administrator permissions: Many features that were previously changeable by anyone on the team now require them to have permissions assigned to team administrators. These include adding team members, adding team favorites, customizing the Kanban board, and adding members and events in a team room. To add a team administrator, go here.

  • Process template names: The names of the default TFS process templates have changed. They are now associated with the version of TFS that they are released with. The new names correspond to:

    • Microsoft Visual Studio Scrum 2013

    • MSF for Agile Software Development 2013

    • MSF for CMMI Process Improvement 2013

  • witadmin: Using the witadmin command for process configuration has changed. The following witadmin commands have been deprecated along with their corresponding configuration files (AgileConfiguration and CommonConfiguration):

    • exportagileprocessconfig

    • exportcommonprocessconfig

    • importagileprocessconfig

    • importcommonprocessconfig

    Now, one process configuration file (ProcessConfiguration) is managed with witadmin exportprocessconfig and importprocessconfig commands. See Import and export process configuration

Changes made to the default process templates

The following summary describes the changes made to the default process templates that are provided with TFS from their previous versions:

Changes introduced with TFS 2013.4

The following changes were made to the work item type (WIT) definitions of the default process templates that TFS provides:

  • Scrum: Removed the Backlog Priority field from the bug and product backlog item definitions.

  • Agile: Added the Story Points field to the bug definition. Removed the Stack Rank field from the user story definition.

  • CMMI process template: Added the Size field to the bug definition. Removed the Stack Rank field from the requirement definition.

Changes introduced with TFS 2013.3

The following changes were made to all the default process templates that TFS provides:

  • Added the Test Plan and Test Suite work item types (WITs)

  • Added the Test Plan Category and Test Suite Category

  • Added the Test Plan and Test Suite WITs to the Hidden Types Category

Changes introduced with TFS 2013.2

The following changes were made to all the default process templates that TFS provides:

  • Added the Shared Parameter work item type (WIT).

  • Added the Shared Parameter Category.

  • Added the Shared Parameter WIT to the Hidden Types Category.

  • Updated the minor version numbers for each process template:

    • Scrum: <version type="6B724908-EF14-45CF-84F8-768B5384DA45" major="3" minor="9" />.

    • Agile: <version type="ADCC42AB-9882-485E-A3ED-7678F01F66BC" major="7" minor="19" />.

    • CMMI: <version type="27450541-8E31-4150-9947-DC59F998FC01" major="7" minor="9" />.

Changes introduced with TFS 2013

The following changes were made to all the default process templates that TFS provides:

  • Added the Feature work item type (WIT).

  • Added the Feature Category.

  • Replaced AgileConfiguration and CommonConfiguration with a single file, ProcessConfiguration.

    ProcessConfiguration supports these additional features: portfolio backlogs, color assignment to WITs, tags added to the default columns on all backlog pages.

  • Removed the build templates from the build plug-in. You now access build templates through the user interface Use the Default Template for your build process.

  • Updated the following Reporting Services reports: Backlog Overview (Scrum), Stories Overview and Stories Progress (Agile), and Requirements Overview and Requirements Progress (CMMI). These updates reflect changes required with the introduction of the Feature portfolio backlog work item type as described in this blog post: Update your Overview and Progress reports to support the Portfolio backlogs.

    To update your team project with the latest reports, see Upload reports to a team project.

  • Updated the major and minor version numbers for each process template to 9 (for Scrum) and 19 (for Agile and CMMI).

    • Scrum: <version type="6B724908-EF14-45CF-84F8-768B5384DA45" major="3" minor="7" />.

    • Agile: <version type="ADCC42AB-9882-485E-A3ED-7678F01F66BC" major="7" minor="17" />.

    • CMMI: <version type="27450541-8E31-4150-9947-DC59F998FC01" major="7" minor="7" />.

To access the new WITs and other new tools, see Configure Features wizard.

Changes introduced with TFS 2012.1 and 2012.2

Each of the default process templates that TFS provides has been updated to support additional regressive transitions. These transitions, shown in red in the following illustration, support moving items back to the backlog when they were incorrectly set to done or resolved. Now when you inadvertently drag a work item on the Kanban board or the task board to a resolved or closed state, you can drag it back to an earlier workflow state. The following work item types now support any-to-any workflow transitions:

  • Visual Studio Scrum 2.1: Bug, Product Backlog Item, Task

  • MSF Agile 6.1: Bug, Task, User Story

  • MSF Scrum 6.1: Bug, Task, Requirement

Typical forward transitions

Scrum workflow states - forward states and reasons

Atypical regressive transitions

Scrum workflow states - atypical backward flow

To apply the changes to your existing team projects, you need to replace the WORKFLOW sections defined for each of the updated work item types with the new definitions. You can do this by modifying the work item type definition. See Upgrade your 2012 team project from RTM to Update 2.

To obtain the latest versions of the default process templates, you must upgrade your application tier server with Quarterly Update 1. You can obtain the upgrade from the Microsoft download site: Quarterly Update for Microsoft Visual Studio Team Foundation Server 2012.

To learn more about the update, see the Microsoft blog post: Visual Studio and Team Foundation Server 2012 Update 1 now available.


Download the latest version of the process templates

[image]

Download the latest version of the process templates
Send Feedback

To manually add features and functionality to a team project that has been upgraded to Visual Studio Team Foundation Server (TFS) 2013, you download one of the default process templates TFS provides.

To download a process template from TFS

  1. If you aren't a member of the Project Collection Administrators group, get added. You need the Manage process template permission set to Allow to download and manage process templates.

  2. From Visual Studio or Team Explorer, open the process template manager, download the latest process template that is compatible with the one used to create your team project.

    Open Process Template Manager
    Tip Tip

    To download or upload process templates, you must connect to TFS 2013 from either Visual Studio 2013 or Team Explorer 2013.

  3. Download the process template that you need. You'll see all the process templates that have been uploaded to TFS for your team project collection.

    Select process template to work with

    The Upload, Download, Make Default, and Delete buttons are disabled when you don't have the necessary permissions to manage process templates.

    For example, if you are updating a team project based on the Scrum process template, then select Microsoft Visual Studio for Scrum 2013 or later version. If you don't see Scrum 2013 or Agile/CMMI 2013 or later versions, then you need to update TFS.

    To determine the type of process template that was used to create your team project, review the work item types that appear in the New Work Item menu for Team Explorer and then compare them with the work item types in the following chart. If your work item types differ from those shown listed, then a custom process template might have been used.

    Visual Studio Scrum

    MSF for Agile

    MSF for CMMI

    Scrum work items Agile work items CMMI work items

  4. Save the process template to a folder of your choice.

Q & A

Q: Where can I learn about customizing process templates?

A: You can learn more about the contents of each file and folder you just downloaded, and how to customize the template from the following topics: Customize a Process Template.


Update a customized process template to access new features

[image]

Update a customized process template to access new features
Send Feedback

When the Configure Features wizard can't update your team project, it's because your team project was created from a process template other than those TFS provides, or you've customized your team project in ways that conflict with its ability to apply the updates. In these situations, you have these options to update your existing team projects:

  • Option A: Add features to your customized process template, and then run the Configure Features wizard

    Do steps: Step 1, Step 2, Step 4, and Step 5

    Choose this option when you have made extensive customizations to your process template.

  • Option B: Apply your customizations to the latest process template, and then run the Configure Features wizard

    Do steps: Step 1, Step 3, Step 4, and Step 5.

    Choose this option when you have made very few customizations to your process template.

  • Option C: Manually update your team project to add features

    Choose this option when you've made customizations to your team project that aren't present in any of your process templates.

  • Option D: Programmatically update many team projects. First, choose Option A or Option B to update your customized process template. Then, batch update all team projects defined for a team project collection using the following information and resources: How to Configure Features for dozens of team projects and Features4tfs CodePlex solution.

    Choose this option when you have dozens of team projects that were created from the same process template.

To learn more about additions made to the latest default process templates, see Configuration changes made to add new features.

1. Download the latest process template

Step 1 You will copy or add files from the folder of the latest version of process template that you download to the corresponding folder containing your customized process template definitions.

  1. If you're updating a process template based on a version earlier than MSF 6.0 or Visual Studio Scrum 2.0, first apply the updates provided in the 2012 version of this topic.

    You can check the ProcessTemplate.xml file for version information.

  2. If you haven't upgraded your application-tier server to the TFS version that contains the features you want, do that now. Get the download and Upgrade Team Foundation Server.

  3. If you aren't a member of the Project Collection Administrators group, get added. You need the Manage process template permission set to Allow to download and manage process templates.

  4. After TFS has been upgraded, download the latest process template from TFS and choose the process template that most closely matches the one used to create your team project.

    See Download the latest version of the process templates.

    To download or upload process templates, you must connect to TFS 2013 from either Visual Studio 2013 or Team Explorer 2013.

  5. Copy the process template to a new folder where you'll apply your customizations (Option B), or copy XML definitions to add new features to your existing process template (Option C).

2. Add features to your customized process template (Option A)

Step 2 Update your customized process template by adding the following work item types (WITs):

  • Feature supports managing portfolio backlogs.

  • Shared Parameter supports repeating tests with different data.

  • Test Plan and Test Suite support customization of these artifacts and the ability to query against these WITs. Additional changes were introduced, as described in the following two topics: New features enabled for Team Web Access and Plan manual tests.

Copy or add files from the folder of the latest version of process template that you download to the corresponding folder containing your customized process template definitions.

Add Feature and portfolio backlog support (required TFS 2013)

  1. Copy the Feature.xml file from the WorkItem Tracking/TypeDefinitions folder to the corresponding folder of your customized process template.

  2. Add the Feature Category to the Categories file located in the WorkItem Tracking folder.

    Copy image Copy Code
    <CATEGORY name="Feature Category" refname="Microsoft.FeatureCategory">
    <DEFAULTWORKITEMTYPE name="Feature" />
  </CATEGORY>

  3. Open the WorkItems plug-in file located in the WorkItem Tracking folder.

    1. Add a task for uploading the Feature work item type to the <WORKITEMTYPES> section.

      Copy image Copy Code
      <WORKITEMTYPE fileName="WorkItem Tracking\TypeDefinitions\Feature.xml" />

    2. Replace the two process configuration tasks within the PROCESSCONFIGURATION element...

      Copy image Copy Code
      <PROCESSCONFIGURATION>
   <CommonConfiguration fileName="WorkItem Tracking\Process\CommonConfiguration.xml"/>
   <AgileConfiguration fileName="WorkItem Tracking\Process\AgileConfiguration.xml"/>
</PROCESSCONFIGURATION>

      .. with the single element statement that references the ProcessConfiguration file.

      Copy image Copy Code
      <PROCESSCONFIGURATION>
   <ProjectConfiguration fileName="WorkItem Tracking\Process\ProcessConfiguration.xml"/>
</PROCESSCONFIGURATION>

  4. Copy the ProcessConfiguration file from the WorkItem Tracking/Process folder of the downloaded process template to your customized template folder in the same location.

    Incorporate any customizations that you made to the AgileConfiguration or CommonConfiguration files to ProcessConfiguration. For more information, see Process Configuration XML Reference.

  5. Delete the AgileConfiguration and CommonConfiguration files from the WorkItem Tracking/Process folder.

    Process configuration is now supported by the single file ProcessConfiguration.

  6. Replace the Backlog/Stories/Requirement Overview.rdl and Stories/Requirements Progress.rdl files in the Reports folder of your customized template folder with the files of the downloaded process template in the same location.

    These updates reflect changes required with the introduction of the Feature portfolio backlog work item type as described in this blog post: Update your Overview and Progress reports to support the Portfolio backlogs.

  7. Replace the Process Guidance folder, located under Windows SharePoint Services folder, with the contents of the latest folder.

    These files provide forward links to the latest process guidance content.

Add Shared Parameters support (required TFS 2013.2)

  1. Copy the SharedParameter.xml file from the WorkItem Tracking/TypeDefinitions folder to the corresponding folder of your customized process template.

  2. Add the Shared Parameter Category to the Categories file located in the WorkItem Tracking folder.

    Copy image Copy Code
    <CATEGORY name="Shared Parameter Category" refname="Microsoft.SharedParameterCategory">
    <DEFAULTWORKITEMTYPE name="Shared Parameter" />
  </CATEGORY>

  3. Add Shared Parameter to Hidden Types Categories.

    Copy image Copy Code
    <CATEGORY name="Hidden Types Category" refname="Microsoft.HiddenCategory">
    <DEFAULTWORKITEMTYPE name="Code Review Request" />
    <WORKITEMTYPE name="Code Review Response" />
    <WORKITEMTYPE name="Feedback Request" />
    <WORKITEMTYPE name="Feedback Response" />
    <WORKITEMTYPE name="Shared Steps" />
    <WORKITEMTYPE name="Shared Parameter" />  </CATEGORY>

  4. Open the WorkItems plug-in file located in the WorkItem Tracking folder.

  5. Add a task for uploading the Shared Parameter WIT to the <WORKITEMTYPES> section.

    Copy image Copy Code
    <WORKITEMTYPE fileName="WorkItem Tracking\TypeDefinitions\SharedParameter.xml" />

Add test plan and test suite WITs (required TFS 2013.3)

When you upgrade your application-tier server to TFS 2013.3, the TFS Upgrade Wizard automatically updates your existing team projects to support the new work item tracking objects for test plans and test suites.

Changes are made to your team project but no changes are made to any existing customized process templates. You can manually update your customized process templates, however. Reasons you'd do this include supporting future TFS upgrades that require using the Configure Features Wizard, or if you plan to create team projects with your customized process template on your upgraded server. You need to manually add these objects to your customized process templates.

  1. Copy the TestPlan.xml and TestSuite.xml files from the WorkItem Tracking/TypeDefinitions folder to the corresponding folder of your customized process template.

  2. Add the Test Plan Category and Test Suite Category to the Categories file located in the WorkItem Tracking folder.

    Copy image Copy Code
    <CATEGORY name="Test Plan Category" refname="Microsoft.TestPlanCategory">
    <DEFAULTWORKITEMTYPE name="Test Plan" />
  </CATEGORY>
  <CATEGORY name="Test Suite Category" refname="Microsoft.TestSuiteCategory">
    <DEFAULTWORKITEMTYPE name="Test Suite" />
  </CATEGORY>

  3. Add the Test Plan Category and Test Suite Categoryto Hidden Types Categories.

    Copy image Copy Code
    <CATEGORY name="Hidden Types Category" refname="Microsoft.HiddenCategory">
    <DEFAULTWORKITEMTYPE name="Code Review Request" />
    <WORKITEMTYPE name="Code Review Response" />
    <WORKITEMTYPE name="Feedback Request" />
    <WORKITEMTYPE name="Feedback Response" />
    <WORKITEMTYPE name="Shared Steps" />
    <WORKITEMTYPE name="Shared Parameter" />
    <WORKITEMTYPE name="Test Plan" />
    <WORKITEMTYPE name="Test Suite" />
  </CATEGORY>

  4. Open the WorkItems plug-in file located in the WorkItem Tracking folder.

  5. Add a task for uploading the Test Plan and Test Suite WITs to the <WORKITEMTYPES> section.

    Copy image Copy Code
    <WORKITEMTYPE fileName="WorkItem Tracking\TypeDefinitions\TestPlan.xml" />
<WORKITEMTYPE fileName="WorkItem Tracking\TypeDefinitions\TestSuite.xml" />

3. Apply your customizations to the process template (Option B)

Step 3 With this option, you apply customizations you've made to your team project or process template to the latest process template that most closely matches the template used to create your team project.

  1. Apply the customizations that you've made to the new process template folder:

    • Apply customizations you've made to the default work item type (WIT) definitions. This could include additions of fields or modifications to the workflow or form.

    • Add custom WITs to the work item tracking folder, and update the WorkItems definition file as needed. See Add type definitions for work items to a process template.

      If you want to use a customized WIT that contains the same name as those in the default process template, then make sure that you swap out the WIT definition files. If you want to use a customized WIT with a different name that that provided in the default process template, then you'll need to modify the categories and process configuration definition files prior to import to reflect the different naming.

    • Apply customizations to the Categories definition file.

    • Apply customizations to the ProcessConfiguration definition file. Check that the WITs that you want are represented in the correct categories and that all workflow states are mapped to metastates.

    • Copy any additional process template files that you've customized to the appropriate process template folder. For a complete list of process template files and information about customizing them, see Overview of process template files.

  2. Review your changes against this checklist to make sure that you have applied all the required customizations:

    Customization

    Update or verify the WIT definition

    Update or verify the process configuration definition

    Add a WIT to the Requirement Category

    (A WIT can belong to the Requirement Category or the Task Category, but not both.)

    To include the following fields:

    • The field value assigned to type=Order in the process configuration file (Backlog Priority in Scrum, Stack Rank in Agile or CMMI)

    • The field value assigned to type=Effort in the process configuration file (Effort (Scrum), Story Points (Agile), or Size (CMMI))

    • The Area path or the field value assigned to type=Team in the process configuration file.

    • All fields that are included in the AddPanel section of the process configuration file (fields must be defined within the FIELDS section but don't have to be included within the FORM section.

    To contain the necessary metastate mappings under the RequirementBacklog section:

    • Map the initial states of each WIT in the Requirement Category to type="Proposed"

    • Map each intermediate workflow state you want to have show up on the Kanban board to type="InProgress"

    • Map the end of each workflow state to type="Complete"

      You can have more than one State mapped to type="Complete"

    To contain an entry to define the color codes associated with the WIT. For example:

    <WorkItemColor primary="FF009CCC" secondary="FFD6ECF2" name="Product Backlog Item" />

    Change the workflow of a WIT in the Requirement Category

    N/A

    To contain the necessary metastate mappings as described above for adding a WIT to the Requirement Category.

    Add a WIT to the Task Category

    To include the following fields:

    • The field value assigned to type=Order in the process configuration file (Backlog Priority in Scrum, Stack Rank in Agile or CMMI)

    • The field value assigned to type=Activity in the process configuration file (Activity (Scrum or Agile) or Discipline (CMMI) )

    • Area path or the field value assigned to type=Team in the process configuration file

    • The field value assigned to type=RemainingWork in the process configuration file (Remaining Work)

    • (Optional) Original Work and Completed Work (Agile and CMMI only)

    To contain the necessary metastate mappings under the TaskBacklog section:

    • Map the initial states of each WIT in the Task Category to type="Proposed"

    • Map each intermediate workflow state that you want to have show up on the task board to type="InProgress"

    • Map the end of each workflow state to type="Complete"

      You can have more than one State mapped to type="Complete"

    To contain an entry to define the color codes associated with the WIT. For example:

    <WorkItemColor primary="FFF2CB1D" secondary="FFF6F5D2" name="Task" />

    Change the workflow of a WIT in the Task Category

    N/A

    To contain the necessary metastate mappings as described above for adding a WIT to the Task Category.

    Add a WIT to the Bug Category or change the workflow of a WIT in the Bug Category (Agile and CMMI only) (See Note a)

    To support the team configurable setting to add bugs to the backlog, include the following fields:

    • The field value assigned to type=Order in the process configuration file (Backlog Priority in Scrum, Stack Rank in Agile or CMMI)

    • The field value assigned to type=Effort in the process configuration file (Effort (Scrum), Story Points (Agile), or Size (CMMI))

    To contain the necessary metastate mappings under the BugWorkItems section:

    • Map the initial state of each WIT in the Bug Category to type="Proposed"

    • Map each intermediate workflow state you want to have show up on the Kanban Board or for My Work to type="InProgress"

    • Map the end of each workflow state type="Complete"

      You can have more than one State mapped to type="Complete"

    To learn more, see Support bug update status using My Work.

    Remove a WIT from the Requirement Category or Task Category

    N/A

    To remove any metastate mappings that are only associated with that WIT

    Remove a WIT

    Remove the WIT from the categories file

    To remove any metastate mappings that are only associated with the WIT that you removed and the WorkItemColor element that defines the color codes for the WIT you removed.

    Rename a WIT

    Update the categories file with the new names

    Update the process configuration file with the new names

    Notes:

    1. If you've updated to TFS 2013.4, see Add bugs to the backlog or task board. TFS 2013.4 introduces a setting which enables each team to view bugs on their backlog and Kanban board. This feature references the metastate mappings made under BugWorkItems.

4. Rename and upload the process template to TFS

Step 4 For the Configure Features wizard to select the latest version of a process template, you must update the version statement to differentiate your updated process template version from previous versions.

  1. Open the ProcessTemplate plug-in file located in the top folder.

    1. Update the name to reflect the version changes you've made. For example:

      Copy image Copy Code
      <name>MyCompany Custom Scrum 2013.3  </name>

    2. Update the code snippet after the description element. Increase the minor version to reflect that you've made updates to the existing process template and distinguish it from the default TFS process template.

      Your choice of code snippet is based on the template category that you are updating:

      Category

      Version statement

      Agile

      Copy image Copy Code
      <version type="ADCC42AB-9882-485E-A3ED-7678F01F66BC" major="7" minor="20"/>

      CMMI

      Copy image Copy Code
      <version type="27450541-8E31-4150-9947-DC59F998FC01" major="7" minor="10"/>

      Scrum

      Copy image Copy Code
      <version type="6B724908-EF14-45CF-84F8-768B5384DA45" major="3" minor="10"/>

  2. Upload the process template.

    To verify your changes, create a test project. See create a team project.

5. Run the Configure Features wizard

Step 5 When you've verified that the process template supports your customizations, run the Configure Features wizard as to update your existing team projects. See Configure features after a TFS upgrade.

Q & A

Q: What types of customizations stop the Configure Features wizard from being able to update a team project?

A: The following changes made to a process template can interfere with the Configure Features wizard's ability to run:

  • Renamed or removed WITs that belong to the Requirement Category or Task Category.

  • Renamed states or customized workflow states defined for WITs that belong to the Requirement Category or Task Category. Metastates define how planning tools treat each workflow state. At least one workflow state must map to the InProgress and to the Completed metastates

  • Removal of fields defined for WITs that belong to the Requirement Category or Task Category. These fields are defined in the ProcessConfiguration definition file and include the fields used to manage backlog priority, effort, task activity or discipline, and remaining work.

To learn more, see Process configuration XML element reference.

Q: How is the version statement in process templates used?

A: The Configure Features wizard uses the version statement to determine which process template within a category is the latest version and automatically selects that version.

If the version statement is not present, the Configure Features wizard cannot select the process template for updating a team project. Also, if more than one process template has been uploaded to TFS that specifies the same highest version number, then none of these process templates can be selected for updating a team project.

Q: I'm new to working with process templates. What should I know about making manual updates?

A: Keep these tips in mind when modifying process template files:

  • For an overview of what process templates are and their files and folders, see Customize a process template Overview of process template files.

  • Do not remove a file or a task in order to upload a file unless you know what the file is and that you will have no use for it.

  • To locate the customizations that you have made, you can perform a diff operation on comparable files that exist in the two templates. However, you could receive some false positives because the sequence of element definitions might have changed between two versions.

  • You can search for the dependency element across all plug-in files to learn what tasks depend on other tasks that are being completed. For example, Microsoft Test Manager and Lab Management require the SharedSteps and TestCase work item types, the SharedSteps and TestedBy links types, and categories. See Define dependencies for task groups and tasks in plug-in files.

Q: How do I rename a work item type?

A: Use witadmin renamewitd command to change the name, and then update the Categories definition file. To learn more, see Modify or add a custom work item type (WIT).

Q: What if I want to use more than one level of portfolio backlog?

A: You can add up to five portfolio backlogs. This includes the default backlog of Feature. You can add this to a custom process template or after your team project is updated. To get started, see Add a Portfolio Backlog.

Q: Where can I learn more about the definition files to modify?

A: See these topics for more information:

  • Customize a process template

  • All WITD XML Elements Reference

  • Categories XML Element Reference

  • Process Configuration XML Element Reference

Q: Where can I go if I have more questions?

A: You can post a question or search for answers in one of these forums: Team Foundation Server - Work Item Tracking or Team Web Access.


Add features using a manual update process

[image]

Add features using a manual update process
Send Feedback

You can update team projects that were created in earlier versions of Team Foundation Server (TFS) to use new features added with the upgrade to TFS 2013. You should update team projects by using the Configure Features wizard, see Configure features after a TFS upgrade. However, if the wizard is unable to add a feature, you can add it manually.

You can add the following work item types (WITs):

  • Feature, available with upgrade to TFS 2013. The Feature WIT supports managing portfolio backlogs.

  • Shared Parameter, available when you upgrade to TFS 2013.2. The Shared Parameter WIT supports repeating tests with different data.

If you're updating from TFS 2010, first apply the updates provided in the 2012 version of this topic.

Updates required to use portfolio backlogs

Import files from the folder of the latest version of process template that you download and update the categories definition files.

  1. If you haven't upgraded TFS to TFS 2013, do that now. See Upgrade Team Foundation Server.

  2. If you aren't a member of the Project Collection Administrators group, get added. You'll need these permissions to run the wizard and download process templates.

  3. Run the Configure Features wizard to determine which features need to be configured. See Configure features after a TFS upgrade.

    Verify features can be configured

    If the wizard lists additional features to configure besides Portfolio Backlogs, then first apply the updates provided in the 2012 version of this topic.

  4. Download the latest version of the process templates that is compatible with the one used to create your team project.

    To download or upload process templates, you must connect to TFS 2013 from either Visual Studio 2013 or Team Explorer 2013.

  5. Open a Command Prompt window where either Visual Studio 2013 or Team Explorer 2013 is installed and enter:

    Copy image Copy Code
    cd %programfiles(x86)%\Microsoft Visual Studio 12.0\Common7\IDE

    On a 32-bit edition of Windows, replace %programfiles(x86)% with %programfiles%.

  6. Add the Feature WIT. Specify the DirectoryPath to the WorkItem Tracking/TypeDefinitions folder that contains the process template that you downloaded.

    Copy image Copy Code
    witadmin importwitd /collection:CollectionURL /p:"ProjectName" /f:"DirectoryPath\Feature.xml"

    The directory path must follow this structure: Drive:\TemplateFolder\WorkItem Tracking\TypeDefinitions.

    An example of CollectionURL is http://MyServer:8080/tfs/DefaultCollection.

  7. Update the categories to support using the Feature portfolio backlog.

    1. First, export the categories file.

      Copy image Copy Code
      witadmin exportcategories /collection:CollectionURL /p:ProjectName /f:"DirectoryPath\categories.xml"

    2. Add the Feature Category.

      Copy image Copy Code
      <CATEGORY name="Feature Category" refname="Microsoft.FeatureCategory">
    <DEFAULTWORKITEMTYPE name="Feature" />
  </CATEGORY>

    3. Then, import the categories file.

      Copy image Copy Code
      witadmin importcategories /collection:CollectionURL /p:ProjectName /f:"DirectoryPath\categories.xml"

  8. Import the new process configuration file from the WorkItem Tracking/Process folder of the downloaded process template. Process configuration is now supported by the single file ProcessConfiguration.

    Copy image Copy Code
    witadmin importprocessconfig /collection:CollectionURL /p:ProjectName /f:"DirectoryPath\ProcessConfiguration.xml"

    Incorporate any customizations that you made to the AgileConfiguration or CommonConfiguration files to ProcessConfiguration. For more information, see Process Configuration XML Reference.

  9. You can start using the portfolio backlog as described here.

Updates required to use Shared Parameters, requires TFS 2013.2 (Update 2)

Import one file from the folder of the latest version of process template that you download, and modify the categories definition file.

  1. If you haven't upgraded TFS to TFS 2013.2, get the download. Upgrade Team Foundation Server.

  2. If you aren't a member of the Project Collection Administrators group, get added. You'll need these permissions to run the wizard and download process templates.

  3. Run the Configure Features wizard to determine which features need to be configured. See Configure features after a TFS upgrade.

    Configure features for TFS 2013.2

  4. Download the latest version of the process templates that is compatible with the version used to create your team project.

    To download or upload process templates, you must connect to TFS 2013 from either Visual Studio 2013 or Team Explorer 2013.

  5. Open a Command Prompt window where either Visual Studio 2013 or Team Explorer 2013 is installed and enter:

    Copy image Copy Code
    cd %programfiles(x86)%\Microsoft Visual Studio 12.0\Common7\IDE

    On a 32-bit edition of Windows, replace %programfiles(x86)% with %programfiles%.

  6. Add the Shared Parameter WIT. Specify the DirectoryPath to the WorkItem Tracking/TypeDefinitions folder that contains the process template that you downloaded.

    Copy image Copy Code
    witadmin importwitd /collection:CollectionURL /p:"ProjectName" /f:"DirectoryPath\SharedParameter.xml"

    The directory path will follow this structure: Drive:\TemplateFolder\WorkItem Tracking\TypeDefinitions.

    An example of CollectionURL is http://MyServer:8080/tfs/DefaultCollection.

  7. Add the Shared Parameter Category to the categories definition.

    1. Export the categories file.

      Copy image Copy Code
      witadmin exportcategories /collection:CollectionURL /p:ProjectName /f:"DirectoryPath\categories.xml"

    2. Add the Shared Parameter Category.

      Copy image Copy Code
      <CATEGORY name="Shared Parameter Category" refname="Microsoft. SharedParameterCategory">
    <DEFAULTWORKITEMTYPE name="Shared Parameter" />
  </CATEGORY>

    3. Add Shared Parameter to Hidden Types Categories.

      Copy image Copy Code
      <CATEGORY name="Hidden Types Category" refname="Microsoft.HiddenCategory">
    <DEFAULTWORKITEMTYPE name="Code Review Request" />
    <WORKITEMTYPE name="Code Review Response" />
    <WORKITEMTYPE name="Feedback Request" />
    <WORKITEMTYPE name="Feedback Response" />
    <WORKITEMTYPE name="Shared Steps" />
    <WORKITEMTYPE name="Shared Parameter" />
  </CATEGORY>

    4. Import the categories file.

      Copy image Copy Code
      witadmin importcategories /collection:CollectionURL /p:ProjectName /f:"DirectoryPath\categories.xml"

  8. Verify that you can add a shared parameter set or convert to shared parameters. See Repeat a test with different data.

Q & A

Q: What if I already have a WIT named Feature defined in my team project?

A: If you want to use your existing WIT Feature to support a portfolio backlog, then you can skip step 5 and complete the remaining steps. However, if you want to add a different named WIT for your portfolio backlog, then you'll need to modify the categories and process configuration definition files prior to importing these files to reflect the different naming. See Add a Portfolio Backlog.

Q: What if I want to use more than one level of portfolio backlog?

A: You can add up to five portfolio backlogs. This includes the default backlog of Feature. To get started, see Add a Portfolio Backlog.

Q: I've added portfolio backlogs to my team project. Why can't all team members view them?

A: To view and work with portfolio backlogs requires that each team member has Full access.

Q: Where can I learn more about the definition files to modify?

A: See these topics for more information:

  • All WITD XML Elements Reference

  • Categories XML Element Reference

  • Process Configuration XML Element Reference

Q: Where can I go if I have more questions?

A: You can post a question or search for answers in the Team Foundation Server forum.


Update a team project manually to support test management

[image]

Update a team project manually to support test management
Send Feedback

When you upgrade your existing on-premises deployment to Team Foundation Server (TFS) 2013.3, you have the ability to customize test plans and test suites because these objects are now remodeled as work item types (WITs).

To accomplish this transformation, the TFS Upgrade Wizard automatically updates the team projects defined for all collections on the application tier and migrates existing test data and objects. Behind the scenes, it performs two activities:

  1. Imports the WIT definitions for test plan and test suite, and updates the categories definition for team projects to include test plan and test suite categories.

  2. Migrates existing test management data. Work items are created from existing test plan and test suites, and links between the other existing test artifacts-such as test points, test runs, and test results-are fixed to point to the work item-based test plans and test suites.

Data migration depends on a successful import of WIT definitions and updates. If the first activity fails, the second one will not occur. In the event that either activity is unsuccessful, the wizard logs one or more warnings or errors.

TFS Upgrade Wizard showing Test Management error

When this occurs, you'll need to manually update your team project. You won't be able to access existing test plans and test suites until you perform the manual updates.

Errors might occur if your team project already contains WITs labeled Test Plan or Test Suite, or you've upgraded from TFS 2005 and 2008 and you haven't added the necessary work tracking objects to support test management. See Update a Team Project Based on an MSF v4.2 Process Template.

Manually update your team project to support the TFS 2013.3 test experience

  1. Import the test plan and test suite WIT definitions.

    1. If you don't have administrative permissions, get them. To perform all the update steps, you need to be a member of the Team Foundation Administrators security group, and an administrator on the application-tier server.

    2. Download the latest version of the process templates.

    3. Open a Command Prompt window where either Visual Studio or Team Explorer is installed and enter:

      Copy image Copy Code
      cd %programfiles(x86)%\Microsoft Visual Studio 12.0\Common7\IDE

      On a 32-bit edition of Windows, replace %programfiles(x86)% with %programfiles%. You can download Team Explorer for free.

    4. Import the test plan and test suite WIT definitions. Specify the DirectoryPath to the WorkItem Tracking/TypeDefinitions folder that contains the process template that you downloaded.

      Copy image Copy Code
      witadmin importwitd /collection:"CollectionURL" /p:"ProjectName" /f:"DirectoryPath\TestPlan.xml"
witadmin importwitd /collection:"CollectionURL" /p:"ProjectName" /f:"DirectoryPath\TestSuite.xml"

      An example of CollectionURL is http://MyServer:8080/tfs/DefaultCollection.

      The DirectoryPath must follow this structure: Drive:\TemplateFolder\WorkItem Tracking\TypeDefinitions. For example:

      C:\Process Template\Microsoft Visual Studio Scrum 2013.3\WorkItem Tracking\TypeDefinitions

  2. Update your category definitions.

    1. Export your categories definition file.

      Copy image Copy Code
      witadmin exportcategories /collection:CollectionURL /p:ProjectName /f:"DirectoryPath\Categories.xml"

    2. Add the following categories.

      Copy image Copy Code
      <CATEGORY name="Test Plan Category" refname="Microsoft.TestPlanCategory">
    <DEFAULTWORKITEMTYPE name="Test Plan" />
  </CATEGORY>
  <CATEGORY name="Test Suite Category" refname="Microsoft.TestSuiteCategory">
    <DEFAULTWORKITEMTYPE name="Test Suite" />
  </CATEGORY>

    3. Add the new WITs to the hidden categories.

      Copy image Copy Code
      <CATEGORY name="Hidden Types Category" refname="Microsoft.HiddenCategory">
    <DEFAULTWORKITEMTYPE name="Code Review Request" />
    <WORKITEMTYPE name="Code Review Response" />
    <WORKITEMTYPE name="Feedback Request" />
    <WORKITEMTYPE name="Feedback Response" />
    <WORKITEMTYPE name="Shared Steps" />
    <WORKITEMTYPE name="Shared Parameter" />
    <WORKITEMTYPE name="Test Plan" />
    <WORKITEMTYPE name="Test Suite" />
  </CATEGORY>

    4. Import the updated file.

      Copy image Copy Code
      witadmin importcategories /collection:CollectionURL /p:ProjectName /f:"DirectoryPath\Categories.xml"

  3. Migrate existing test plans and suites to work item based test plans and suites.

    1. Open a Command Prompt window on the TFS application-tier server:

      Copy image Copy Code
      cd %programfiles%\Microsoft Team Foundation Server 12.0\Tools

    2. Run the TfsConfig TCM command.

      Copy image Copy Code
      TFSConfig TCM /upgradeTestPlans /CollectionName:CollectionName /TeamProject:TeamProjectName

      For example:

      TFSConfig TCM /upgradeTestPlans /CollectionName:"Fabrikam Fiber Collection" /TeamProject:"Fabrikam Fiber"

      Respond to the questions that appear.

      Copy image Copy Code
      Logging sent to file C:\ProgramData\Microsoft\Team Foundation\Server Configuration\Logs\TPC_UPG_AT_0515_143821.log
Microsoft (R) TfsConfig - Team Foundation Server Configuration Tool
Copyright (c) Microsoft Corporation. All rights reserved.

Command: tcm
Microsoft (R) TfsConfig - Team Foundation Server Configuration Tool
Copyright (c) Microsoft Corporation. All rights reserved.

In order to upgrade the test plans, you have to complete the following steps:
1. Import the test plan work item definition into the project. Have you complete
d this step? (Yes/No) Yes
2. Import the test plan category into the project. Have you completed this step?
(Yes/No) Yes

Test plan migration job successfully scheduled.

    3. If you're migrating a large quantity of test plans and test suites, you can run the following command to monitor the progress of data migration.

      Copy image Copy Code
      TFSConfig TCM /upgradeStatus /collectionName:CollectionName /TeamProject:TeamProjectName

After a successful data migration, all test management data should be available for use. For more information about this utility, go here.

For information about how to access the new WIT-based test plans and test suites in Test Manager or Team Web Access, see Plan manual tests.


Set up Team Foundation Build Service

[image]

Set up Team Foundation Build Service
See Also Send Feedback

If you want to automate builds of your software projects, you can install Team Foundation Build Service from the Team Foundation Server product DVD and create a build machine. Once you have the build machine set up, you'll want to create a build definition in Visual Studio with instructions about which code projects to compile and many other configurations. But first, you must set up the build machine.

Installing Team Foundation Build Service

The most important thing to concern yourself with during installation is selecting the right hardware to get the best performance (recommendations are linked below). If your team is building Windows apps, you'll need to install the build service on Windows 8. For more information, see this topic on the Microsoft website: Build and Test a Windows Store App Using Team Foundation Build. All of the settings you choose during the initial configuration of Team Foundation Build Service can be changed after installation, so don't worry too much about making a wrong choice. For a comprehensive explanation of Team Foundation Build Service architecture and all possible topologies, see this topic on the Microsoft website: Understanding a Team Foundation Build System.

Although you can install Team Foundation Build Service on the same computer as Team Foundation Server, you probably shouldn't. You don't want to hurt the performance of Team Foundation Server or increase its attack surface when builds are running.

To install Team Foundation Build Service

Step 1 Verify that the operating system and hardware meet the requirements for Team Foundation Build Service. By default, Team Foundation Build Service uses Network Service for its service account. If you're going to connect to Visual Studio Online, you'll also need the Microsoft account you used to set up the hosted service.

For more information: System requirements for Team Foundation Build Service, Accounts required for installation of Team Foundation Server.

Step 2 Run the Team Foundation Server install from the product DVD and then use the build service configuration wizard to configure your installation. This wizard installs and configures Team Foundation Build Service.

Install Team Foundation Server Build

For more information: Run Team Foundation Server installation, Configure Team Foundation Build Service using the Team Foundation Server configuration tool

Build machine upgrade tips

Here are some tips on dealing with TFS upgrades and the build service:

  • You will be prompted to restore your previous build settings if you connect to a collection from a server that had previously been set up with build resources. Ignore this prompt to discard your previous settings and create new settings.

  • If you're upgrading a TFS installation that's secured with SSL, remember to configure the new build server to use SSL ports before you try to connect to an application tier secured with SSL. See: To change a build configuration to use HTTPS.

  • You can connect a TFS 2010 build server to your on-premises TFS 2013 application-tier server, but you cannot run both the TFS 2010 and TFS 2013 build service on the same computer.

  • You can connect a TFS 2012 build server to your on-premises TFS 2013 application-tier server, but you cannot run both the TFS 2012 and TFS 2013 build service on the same computer.

For more information, see Resolve issues that can occur when you upgrade

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements


System requirements for Team Foundation Build Service

[image]

System requirements for Team Foundation Build Service
See Also Send Feedback

Team Foundation Build Service has the same operating system requirements as TFS. Hardware requirements for the build service are the same as the operating system on which it is running. However, you can optimize build service performance by tailoring the hardware specs of your build machine to the types of builds your team will use.

Hardware recommendations

To understand hardware optimization, you should understand the basics of the build service architecture. When you install Team Foundation Build Service with the default settings, you create a build machine with a build controller and a single build agent. Build controllers connect the build machine to Team Foundation Server. If you run many builds at the same time, build controllers can require a significant amount of memory. Build agents, on the other hand, perform processor-intensive and disk-intensive work, so you should make sure that the CPU on the build machine is sufficiently powerful to enable the build agent to perform its tasks in an acceptable period of time.

To determine the minimum amount of disk space that is required, you should determine the size of your overall source configuration, and then add the size of all intermediate outputs and binaries from the build process. After you have this number, multiply it by the number of build definitions likely to be built on a particular server, and then double that number for the minimum recommended amount of available disk space for that server.

Tip Tip

Use a server that has fast hard disks as an inexpensive way to improve build performance. Another way to maximize Team Foundation Build Service performance is to use hardware with multi-core CPUs.

Should you use one server or more?

You can use build frequency as a metric for determining how much of a hardware investment you want to make for Team Foundation Build Service. If your team performs weekly or nightly builds, installing Team Foundation Build Service on the server that is running Team Foundation Server may not have an adverse effect on productivity. If your team performs parallel builds or continuous integration builds, or if you plan to create a build lab for more than one team, you should most likely install Team Foundation Build Service on its own server, or possibly even multiple servers.

Additional considerations

You can set up a network share as a drop folder to store builds. You should create this folder on a computer that is running a supported server operating system, because of the concurrent file access limitations of non-server operating systems. This folder does not have to be on the same server as Team Foundation Build Service. See Set Up Drop Folders

See Also

Concepts

Set up Team Foundation Build Service


Configure Team Foundation Build Service using the Team Foundation Server configuration tool

[image]

Configure Team Foundation Build Service using the Team Foundation Server configuration tool
Send Feedback
Installing Team Foundation Build Service

You can use this procedure to configure Team Foundation Build Service with the default options.

Tip Tip

You can access the Team Foundation Server Configuration tool by launching Team Foundation Server Administration Console, choosing Build Configuration, and then choosing Configure Installed Features.

Required permissions

You must be a member of both the Windows Administrators security group on the server on which you are configuring Team Foundation Build Service and the Project Collection Administrators group on TFS. If you want to connect to a collection on Visual Studio Online, you also need the Microsoft account you used to set up the hosted service.

To configure Team Foundation Build Service

  1. Choose Configure Team Foundation Build Service, and then choose Start Wizard.

    The Build Service Configuration wizard appears.

  2. Read the Welcome screen, and then choose Next.

  3. Choose Browse, and then choose the team project collection to which you want this build controller to connect. If your team project collection is on the hosted service, you're prompted to authenticate. Enter the Microsoft account you used to set up the service. Choose Next.

    If you connect to a collection that previously hosted resources for the build service on this server, you're prompted to restore your settings. If you want the same number of controllers and agents, choose Yes and then skip to step 5. (If you're upgrading from TFS 2012 or later, we'll save any other build service customizations you made, too.) If you want to configure this build server with different resources, choose No.

  4. Perform one of the following steps, and then choose Next:

    • Choose Use the default setting, and specify the number of build agents.

      If you installed Team Foundation Build Service on the same server as Team Foundation Server or are using the hosted service, the default setting for Number of build agents to run on this build machine is 1 (recommended).

    • Choose Scale out build services to run concurrent builds across multiple machines. If you choose this option, you have to specify the number of build agents for this machine and then add them to a new or existing build controller.

      If you installed Team Foundation Build Service on its own server, the default setting for Number of build agents to run on this build machine is equal to the number of processor cores on this server.

    • Choose Replace an existing build machine, and then specify the build machine to replace. This option copies the existing configuration to the new build server.

    • Choose Configure later to skip setting up any build controllers or agents on this instance of Team Foundation Build Service.

      If you choose this option, you must manually connect the build controller to Team Foundation Server before you can use this build machine.

  5. Under Run Team Foundation Build Service as, perform one of the following steps, and then choose Next:

    • Choose Use a system account, and then choose a system account.

      For example, choose NT Authority\Network Service to use Network Service.

    • Choose Use a user account to use a domain or local account, and then enter the account name and password. To test the user account and password, choose Test.

    If you've connected this build machine to the hosted service, under Advanced Configuration, you can see Account Name.

    When you created the instance of Team Foundation Server on the hosted service, Account Name was automatically created for you. This account will be added to the Project Collection Build Service Accounts group on the hosted service.

  6. Review the information and then choose Next.

    The wizard validates your configuration.

  7. Choose Configure.

    The wizard applies configuration settings.

  8. Choose Next, Close, Close.

    The Team Foundation Server Administration Console appears.


How to: Create a Team Foundation server farm (high availability)

[image]

How to: Create a Team Foundation server farm (high availability)
Send Feedback
Add a Team Foundation Server

You might add an application-tier server to an existing deployment of Team Foundation Server for any of the following reasons:

  • You want to build redundancy into your deployment of Team Foundation Server.

  • You want your deployment of Team Foundation Server to run faster.

  • You want to restore an application-tier server that has failed.

  • You want to move an application tier to a different server.

Redundancy and performance

By using the Application-tier Only Configuration wizard, you can enhance the availability, scalability, and performance of your application tier.

To benefit from multiple application-tier servers, you should ensure that your initial deployment of Team Foundation Server includes the following characteristics:

  • The application tier and the configuration database are installed on separate servers.

  • You used a domain account for the Team Foundation Server service account (TFSSERVICE).

  • Network Load Balancing (NLB) is deployed.

You use NLB to create a cluster of Web servers that appear as a single logical Web service. This procedure is separate from the Application-tier Only Configuration wizard. For more information about how to set up NLB, see the following page on the Microsoft website: Network Load Balancing.

If you create an NLB cluster, you do not need to use a SQL Server cluster for your configuration database or any team project collection. For the purposes of performance, scalability, and availability, any SQL Server cluster that you might deploy is independent of the NLB cluster.

Disaster recovery and hardware upgrade

If you have a backup of your configuration database and your application tier has a hardware failure, you can use the Application-tier Only Configuration wizard to restore the application tier.

You can also move your application tier with the Application-tier Only Configuration wizard. Although no particular architecture is required to move an application tier, you must have access to the configuration database for the deployment.

To create a Team Foundation Server Farm

Use the steps in this checklist to add an application tier to an existing deployment of Team Foundation Server.

Task

Detailed instructions

Step 1

Check for supported hardware and software. Verify that the operating system and hardware meet requirements for Team Foundation Server.

  • System requirements for Team Foundation Server

Step 2

Set up Team Foundation Server. Install Team Foundation Server and run the Application-Tier Only Configuration wizard.

  • Run Team Foundation Server installation

  • Configure Team Foundation Server using the Application-Tier Only Configuration Wizard


Configure Team Foundation Server using the Application-Tier Only Configuration Wizard

[image]

Configure Team Foundation Server using the Application-Tier Only Configuration Wizard
Send Feedback
Add a Team Foundation Server

You can use a wizard to add an application tier to an existing Team Foundation Server deployment.

Your Team Foundation Server deployment must use a domain account for its service account. If you originally used a built-in account for the TFS service account, you must change it to a domain account. For more information, see the section "Assigning a Different Account as the Service Account" on this page on the Microsoft website: Change the Service Account or Password for Team Foundation Server.

Tip Tip

You can access the Team Foundation Server Configuration tool by launching Team Foundation Server Administration Console, choosing Application Tier, and then choosing Configure Installed Features.

Required permissions

To perform this procedure, you must be a member of the Administrators security group on the server.

To configure Team Foundation Server by using the application-tier only option

  1. Choose Application-Tier Only Configuration, and then choose Start Wizard.

    The Team Foundation Server Application-Tier Only wizard appears.

  2. Read the Welcome screen, and then choose Next.

  3. In SQL Server Instance, type the instance of SQL Server that hosts the configuration database for the installation of TFS for which you want to add an application-tier server, and then choose List Available Databases.

    The wizard lists all the databases on that instance of SQL Server.

  4. Choose a database, and then choose Next.

    The wizard displays the application-tier settings for this server.

  5. In the list, choose the account you want to use. Enter the password for the service account. To test the user account and password combination, you can optionally choose Test.

    Note Note

    Make sure that the service account you specify has been added to the Farm Administrators group for the SharePoint Central Administration site. For more information, see Add the service account for Team Foundation Server to the Farm Administrators group.

  6. Under Authentication Method, choose NTLM to use NTLM authentication or Negotiate (Kerberos) to first attempt Kerberos authentication, the more secure option. If that fails, fall back to NTLM. Choose Next.

    NTLM is the default value.

  7. On the Review page, review the settings, and then choose Next.

  8. Choose Configure to apply the configuration settings.

    The wizard applies configuration settings.

  9. Choose Next, Close, Close.

    The Team Foundation Server Administration Console appears.

Tip Tip

If you want to connect to an NLB cluster from a client that is running on one of the application-tier servers in the cluster, you should connect using localhost as the name of the server, instead of the Domain Name System (DNS) name for the load balancer. By default, Internet Information Services (IIS) prevents you from connecting to an NLB cluster from any server in the cluster, unless you use localhost as the name of the cluster.


How to: Set up remote SharePoint Products for Team Foundation Server

[image]

How to: Set up remote SharePoint Products for Team Foundation Server
See Also Send Feedback

If you have SQL Server and TFS running on the same server, your best alternative might be to install SharePoint on a different server to minimize competition for resources. The remote SharePoint scenario addresses such an installation.

Install Team Foundation Server Extensions for SharePoint Products on a remote server

install extensions on remote portal

If you want to run SharePoint Products on a server other than Team Foundation Server, you must install Team Foundation Server on the SharePoint server and then configure the TFS Extensions for SharePoint. This installs all of TFS on the SharePoint server, including the TFS SharePoint Extensions. The application tier, the build server, and the proxy server appear in the TFS administration console, but you do not have to configure any of these additional features.

As an alternative, you can use a special installer (tfs_sharePointExtensions.exe) to install just the TFS Extensions on the SharePoint server. Only the TFS Extensions for SharePoint will appear in the TFS administration console. This helps to keep your SharePoint installation nice and tidy. (It's also helpful if you have to convince SharePoint administrators outside of your organization to install the extensions on a SharePoint Server farm). No matter which installation you choose-full TFS install or the special installer-the TFS SharePoint Extensions work exactly the same. The only difference is whether you install all of TFS on the SharePoint server-or just the TFS Extensions for SharePoint.

You can install and configure SharePoint Foundation 2013 during the extensions configuration. If you install SharePoint by using the TFS Extensions configuration, it automatically provisions a new SharePoint web application for you during the SharePoint installation.

To install Team Foundation Server Extensions for SharePoint Products

Step 1 Verify that the operating system and hardware or the existing SharePoint Products installation meets the requirements for Team Foundation Server Extensions for SharePoint Products. If you don't want to use SharePoint Foundation 2013, you can install any supported version of SharePoint Products. If you install the Enterprise version of SharePoint Server, you must configure it for dashboards. For more information: SharePoint Products requirements for Team Foundation Server, Verify SharePoint products for Team Foundation Server, Manually Install SharePoint products for Team Foundation Server.

Step 2 Run the Team Foundation Server install from the product DVD and then use the Team Foundation Server Extensions for SharePoint Products configuration wizard to configure your installation. This wizard installs and configures the extensions and, if you want, SharePoint Foundation 2013. After you configure the TFS Extensions, add the service account that you will use for Team Foundation Server to the Farm Administrators group. For more information: Run Team Foundation Server installation, Configure Team Foundation Server Extensions for SharePoint Products, Add the service account for Team Foundation Server to the Farm Administrators group.

Tip Tip

If you don't want to install all of Team Foundation Server on the server that is running SharePoint Products, launch the tfs_sharePointExtensions.exe file from the SharePoint Extensions folder to install only the Team Foundation Server Extensions for SharePoint Products.

Step 3 If you installed Enterprise version of SharePoint Server, you must make some final configurations in the extensions, but you must do this step after you install Team Foundation Server. For more information: Configure the enterprise application definition for Team Foundation Server.

See Also

Concepts

TFS upgrade requirements


Configure Team Foundation Server Extensions for SharePoint Products

[image]

Configure Team Foundation Server Extensions for SharePoint Products
See Also Send Feedback

If SharePoint Products is not installed on the server that is running Team Foundation Server, you have a remote portal. If you have a remote portal, you must install and configure the Team Foundation Server Extensions for SharePoint Products on the remote portal.

If you have multiple servers in a web farm, you must install and configure the extensions on every application-tier and web-tier server in the farm. An error message might appear during configuration asking you to verify that the extensions have been installed on every server in the farm. You can safely ignore this error. After the extensions have been installed and configured on every server, this error stops.

Required permissions

To follow this procedure, you must be a member of the Farm administrators group on the SharePoint administration site.

To configure Team Foundation Server Extensions for SharePoint Products

  1. From Windows Start, run Team Foundation Server Administration Console.

  2. In the left pane choose Extensions for SharePoint Products, and then in the right pane choose Configure Installed Features.

  3. In the Team Foundation Server Configuration Center window, choose Configure Extensions for SharePoint Products in the left pane. In the right pane, choose Start Wizard.

  4. In the SharePoint Extensions Configuration window, read the Welcome screen, choose if you want to help improve Team Foundation Server, and then choose Next.

  5. If SharePoint Products is installed, skip to the next step. If SharePoint is not installed, take these steps:

    1. Choose the big Install SharePoint Foundation 2013 button. When the install finishes, choose Next.

    2. Type the name of the SQL Server or named instance that will host the configuration databases for SharePoint Foundation 2013.

    3. Type a user account and password for the service account for SharePoint.

      For more information, see Accounts required for installation of Team Foundation Server

  6. On the Review page, review the settings and choose Next to let the wizard validate your configuration.

  7. Choose Configure.

    The wizard applies configuration settings. This process might take several minutes.

  8. Choose Next, Close, Close.

The Team Foundation Server Administration Console appears.

See Also

Concepts

How to: Set up remote SharePoint Products for Team Foundation Server
TFS upgrade requirements


Add the service account for Team Foundation Server to the Farm Administrators group

[image]

Add the service account for Team Foundation Server to the Farm Administrators group
See Also Send Feedback

You must add the service account for Team Foundation Server to the Farm Administrators group on the SharePoint administration site. If you are using Network Service for the TFS service account and SharePoint is not running on the same server as TFS, you must add the machine name of the server that is running TFS instead of Network Service. The machine name is the server name followed by the $ symbol. For example, Domain\ServerName$.

For more information about service accounts, see Accounts required for installation of Team Foundation Server.

Required permissions

To follow this procedure, you must be a member of the Windows Administrators security group on the server that is running SharePoint.

To add the service account for Team Foundation Server to the Farm Administrators group

  1. In a web browser, open the SharePoint Central Administration site.

  2. Under Security, choose Manage the farm administrators group.

  3. Choose New.

  4. In the Users/Groups box, enter the name of the service account for TFS and choose Share.

    Tip Tip

    If you have to manually add a server name followed by the $ symbol, the search utility might not find it, but you will still be able to choose Share.

See Also

Concepts

TFS upgrade requirements
How to: Set up remote SharePoint Products for Team Foundation Server


How to: Install Team Foundation Proxy and set up a remote site

[image]

How to: Install Team Foundation Proxy and set up a remote site
Send Feedback
Team Foundation Proxy

If you have developers at a remote site who are sharing code with developers at the main site, you might save bandwidth by caching version control files at the remote location. Team Foundation Server Proxy distributes popular version control files from its cache at the remote site, rather than having multiple developers from the remote site each download the same file from the main site. Your team at the remote site works like they always have, without managing which version control files get loaded into the cache.

To set this up, you install and configure the proxy server at the remote site, connect the proxy server to the application tier, and then connect the version control feature of Team Explorer to the proxy. Before you can start to cache files at the remote site, you must add the service account for the proxy server to Team Foundation Server at the main site.

To cache version control files at a remote site

Task

Detailed instructions

Step 1

Check for supported hardware and software. Verify that the operating system meets requirements for Team Foundation Server Proxy and that the hardware can run it.

  • System requirements for Team Foundation Server Proxy

Step 2

Set up Team Foundation Server Proxy. Install Team Foundation Server Proxy. After the installation is finished, use the Team Foundation Server Configuration Tool to configure your proxy server.

  • Run Team Foundation Server installation

  • How to: Configure Team Foundation Server Proxy Using the Team Foundation Server Configuration Tool

Step 3

Connect Team Explorer to Team Foundation Server Proxy. After you configure the proxy server to connect to Team Foundation Server, you must configure Team Explorer to access version control files through the proxy server.

  • How to: Configure Team Foundation version control to use Proxy server

Q&A

Q: Is TFS 2013 Proxy backward compatible with previous versions of TFS?

A: Yes. TFS 2013 Proxy is fully compatible with TFS 2010 and TFS 2012. In fact, TFS Proxy 2010, TFS Proxy 2012, and TFS Proxy 2013 are fully compatible with one another in any combination. For example, you can use TFS Proxy 2010 with TFS Server 2013 or vice versa.

Q: Does any version of TFS Proxy have cache cleanup improvements to support disks larger than 1 TB?

A: Yes. TFS Proxy 2012 and TFS Proxy 2013 have cache cleanup improvements to support large disks.

Q: Does TFS Proxy 2013 have corruption detection logic?

A: Yes. If a cached file becomes corrupted on a disk after it was stored, TFS Proxy 2013 has logic to detect the corruption.

Q: Does TFS Proxy 2013 fully support caching against VisualStudio.com?

A: Yes.

Q: What happens to the proxy cache when I upgrade from one version of TFS to another?

A: If you upgrade from TFS Proxy 2010, TFS Proxy 2012, or TFS Proxy 2013, the cache is preserved during upgrade. You will be able to continue accessing TFS from remote locations right away, without any performance impact, because TFS will not need to recreate or repopulate the cache.


System requirements for Team Foundation Server Proxy

[image]

System requirements for Team Foundation Server Proxy
See Also Send Feedback

The proxy feature is available only if you installed Team Foundation Server on a server operating system. For a list of supported server operating systems, see System requirements for Team Foundation Server.

Review these hardware recommendations to determine the optimal hardware to use for Team Foundation Server Proxy. Unlike operating system requirements, hardware recommendations for proxy are different than those for setting up the application tier of Team Foundation Server. The application tier of TFS requires more robust hardware than the proxy feature does.

Tip Tip

These recommendations apply only to the proxy feature of Team Foundation Server.

Hardware recommendations

These recommendations are guidelines for Team Foundation Server Proxy. Recommended hardware is based on the size of the team that will use the proxy server. Usually this is the team in your remote office. The larger the team, the more robust your hardware must be.

Remote team size | Hardware recommendations (CPU/RAM) for Team Foundation Server Proxy
450 or fewer users | 1 processor, 2.2 GHz CPU, 2 GB RAM
Between 450 and 2,200 users | 2 processors, 2.0 GHz CPU, 2 GB RAM
Between 2,200 and 3,600 users | 4 processors, 2.0 GHz CPU, 2 GB RAM

See Also

Concepts

System requirements for Team Foundation Server


How to: Configure Team Foundation Server Proxy Using the Team Foundation Server Configuration Tool

[image]

How to: Configure Team Foundation Server Proxy Using the Team Foundation Server Configuration Tool
Send Feedback
Team Foundation Proxy

You can use the procedures in this topic to configure Team Foundation Server Proxy.

Note Note

You can access the Team Foundation Server Configuration tool from the Start menu by launching Team Foundation Server Administration Console, choosing Proxy Server, and then choosing Configure Installed Features.

Required permissions

To follow this procedure, you must be a member of the Administrators security group on the server on which you are configuring Team Foundation Server Proxy. You must be a member of the Project Collection Administrators group on TFS. If you connect the proxy to a collection on Visual Studio Online, you need the Microsoft account you used to set up the service.

To configure Proxy Server, you must have TFS installed on a server operating system. For more information, see System requirements for Team Foundation Server.

To configure Team Foundation Server Proxy by using Team Foundation Server Configuration tool

  1. Choose Configure Team Foundation Server Proxy, and then choose Start Wizard.

    The Team Foundation Server Proxy Configuration wizard appears.

  2. Read the Welcome screen, and then choose Next. If you had a version of TFS 2013 proxy (this feature only works with TFS 2013 proxy and forward) set up on this server, you're prompted to restore your settings. If you want to configure this proxy server with different resources, choose No and move on to the next step. If you want to connect proxy to the same TFS servers, choose Yes. TFS will attempt to authenticate. If TFS successfully authenticates all endpoints, skip to step 4.

    If there is a problem with one or more endpoints, you have the following troubleshooting options for each failed connection:

    • Connect: Use this option to manually authenticate endpoints. Manual authentication is a good place to start with any failed connection.

    • Skip: Use this option to skip authentication. Skip is useful if you don't have the password to authenticate this endpoint, but you want to save the connection information for another try, sometime in the future, perhaps when you have someone available who knows the password and can authenticate the endpoint.

    • Remove: Use this option to completely remove the endpoint.

    Tip Tip

    Would you like more details about what happens with any of these options? See this blog post.

  3. Choose Browse, and then choose the team project collection to which you want this proxy server to connect. Choose Next.

    Note Note

    If your team project collection is on Visual Studio Online, you're prompted to authenticate. Enter the Microsoft account you used to set up the service.

  4. Under Service Account, choose Use a system account to use Network Service or Use a user account to use a domain or local account. If you are using a user account, you must type the password. To test the user account and password combination, choose Test.

    Network Service is the default value for the proxy server service account.

  5. The following optional configurations appear under Advanced Configuration:

    • If you're connected to the hosted service, Account Name appears here.

      When you created the instance of Team Foundation Server on the hosted service, Account Name was automatically created for you. This account will be added to the Project Collection Proxy Service Accounts group on the hosted service. To use a different account, enter the account name and choose Test. To reset to the default service account automatically created for you, choose Reset to default service account.

    • You can change authentication settings. Under Authentication Method, choose NTLM to use NTLM authentication or Negotiate (Kerberos) to first attempt Kerberos authentication, the more secure option, and if that fails, fall back to NTLM.

      NTLM is the default value.

  6. Choose Next.

  7. In Port, accept the default value of 8081 or type a different listener port number for incoming connections to Team Foundation Server Proxy.

    8081 is the default value.

  8. In Cache Root Directory, accept the default value, or type the path of a different location in which to store cache files.

    The default value is Drive:\Program Files\Microsoft Team Foundation Server 12.0\Version Control Proxy\ _tfs_data

    Drive is the letter of the drive on which you want to store cache files. You can specify a mapped network drive.

  9. Choose Next.

  10. On the Review page, review the settings, and then choose Next.

    The wizard validates your configuration.

  11. Choose Configure for the wizard to apply configuration settings.

  12. Choose Next on the success screen to read the detailed results on the next success screen. You will also find a link to a log on this screen that contains the results of the configuration.

  13. Choose Close twice and the TFS administration console will appear.


How to: Configure Team Foundation version control to use Proxy server

[image]

How to: Configure Team Foundation version control to use Proxy server
Send Feedback

You can configure Team Foundation version control to use a proxy server, which caches copies of version control files in the location of a distributed team. You may reduce bandwidth requirements for remote developers by using a proxy server.

Required permissions

To follow this procedure, you must be a member of the Users security group on the computer on which you are configuring Team Explorer.

To configure Team Explorer to use Team Foundation Server Proxy

  1. Launch Visual Studio.

  2. On the Tools menu, choose Options.

  3. In the Options dialog box, expand Source Control, and then choose Visual Studio Team Foundation Server.

  4. Select the Use proxy server for file downloads check box.

  5. In the Proxy server name box, type the name of the server running Team Foundation Server Proxy.

  6. In the Port box, type the listener port for Team Foundation Server Proxy. By default, Team Foundation Server Proxy listens for client requests on port 8081.


How to: Add Project Server to Team Foundation Server

[image]

How to: Add Project Server to Team Foundation Server
See Also Send Feedback

Installing Team Foundation Server Extensions for Project Server

Project Server integration with TFS

If you want to add Project Server to your Team Foundation Server deployment, you must first install onto Project Server the Team Foundation Server Extensions for Project Server. With the extensions in place, you can assign permissions and configure the integration using the steps below.

Tip Tip

If you upgrade Team Foundation Server, you should uninstall the extensions from Project Server and then install the latest version of the Team Foundation Server Extensions for Project Server on all the servers where it was previously installed. The version of the extensions you use should always match the version of Team Foundation Server you're running.

To install Team Foundation Server Extensions for Project Server

Step 1 Verify that your Project Server installation meets the requirements for Team Foundation Server extensions for Project Server. See Project Server requirements for Team Foundation Server. Team Foundation Server supports integration with Project Server 2013 and Project Server 2010 with Service Pack 1 (SP1). Project Server 2007 is no longer supported.

Tip Tip

Is your team using SharePoint and Project Server to collaborate? You'll also find some topology recommendations for TFS deployments that contain both SharePoint and Project Server in the requirements topic. See Project Server requirements for Team Foundation Server.

Step 2 On Project Server, run the install from the Team Foundation Server product DVD. See, Install Team Foundation Server Extensions for Project Server, With the extensions installed, grant permissions in Team Foundation Server, Project Server, and the SharePoint Products farm that hosts the Project Server. This might be the same SharePoint Products farm that you use to host the Team Foundation Server team portal sites, but not necessarily.

Step 3 Run the TFSAdmin command-line tool to configure integration. After you finish configuration, verify that it works. The steps for verification are the six steps at the bottom of Configuration Quick Reference in the section, Verify Data Synchronization.

See Also

Concepts

Install Team Foundation Server
TFS upgrade requirements


Install Team Foundation Server Extensions for Project Server

[image]

Install Team Foundation Server Extensions for Project Server
See Also Send Feedback

Follow these steps to install Team Foundation Server Extensions for Project Server on the Project Server. This process will not install Team Foundation Server, but only its extensions for Project Server.

Tip Tip

If multiple servers are running Project Server in a web farm, you must install and configure these extensions on every application-tier and web-tier server in that farm.

Required permissions

You must be a member of the Administrators security group.

To install Team Foundation Server extensions for Project Server

  1. From the Team Foundation Server DVD, go to the Project Server Extensions folder and launch the tfs_projectServerExtensions.exe file.

  2. Accept the license terms, select whether to help Microsoft improve its setup experience, and then choose Continue. If you want to install extensions for Project Server to a specific location in the file system, choose Customize.

  3. Choose Install Now. You can also specify whether you want to update Team Foundation Server during setup by enabling Microsoft Updates.

    After the installation completes, choose close.

See Also

Concepts

How to: Add Project Server to Team Foundation Server


Project Server requirements for Team Foundation Server

[image]

Project Server requirements for Team Foundation Server
See Also Send Feedback

Team Foundation Server doesn't require Project Server, but if you want to use it, you must use a supported version.

Tip Tip

You must install the TFS Project Server extensions onto Project Server. If multiple servers are running Project Server in a web farm, you must install these extensions on every application-tier and web-tier server in that farm.

Supported versions, editions

  • Project Server 2013 ¹

  • Project Server 2010 with SP1

Authentication

NTLM is the recommended authentication.

In SharePoint Server 2013, Microsoft deprecated Windows classic-authentication in favor of claims-based authentication. TFS 2012 supports both, but for claims-based authentication, the authentication provider must be NTLM. TFS 2012 supports only NTLM-based claims.

¹ If you upgrade to Project Server 2013 from a Project Server 2010 installation that has been added to TFS, you have to perform a few extra steps to maintain the connection between TFS and Project Server. For more information, see this topic: Upgrade Microsoft Project Server 2010 to Microsoft Project Server 2013

Should you add Project Server to your current team project portal site?

Project Server is an extension of SharePoint Products. You can easily run Project Server on the same SharePoint Products farm you use for Team Foundation Server. If you run Project Server this way, you need to install both the Team Foundation Server extensions for SharePoint Products and the extensions for Project Server on the same server. Team Foundation Server recommends you use a web application running on port 80 for integration with SharePoint Products and you can use this same web application to host the Project Server projects. For example, the URL for team portal sites and Microsoft Project Web App (PWA) sites both hosted on a web application on port 80 might look something like these:

  • http://MOSS2013Server/sites/DefaultCollection/TFSProject

  • http://MOSS2013Server/pwa/EnterpriseProject

You can also run Project Server on its own SharePoint farm, separate from any farm where you might host team project portal sites. This would give you two SharePoint Products farm integrations in a single Team Foundation Server deployment.

Tip Tip

Team Foundation Server has no topology requirements for Project Server. For performance reasons, we recommend you run Project Server on a server other than Team Foundation Server. If you want to set up a sandbox integration of Project Server and Team Foundation Server, you could install all the products on a single server for demonstrations or test purposes.

See Also

Concepts

How to: Add Project Server to Team Foundation Server
SharePoint Products requirements for Team Foundation Server


Additional configurations to make after enabling new features [redirected]

[image]

Additional configurations to make after enabling new features [redirected]
Send Feedback

This topic has been merged into its parent topic, Configure features after a TFS upgrade.


Add an SMTP server to release management

[image]

Add an SMTP server to release management
Send Feedback

Insert introduction here.

Section Heading

Insert section body here.

Subsection Heading

Insert subsection body here.


How to: Add the Service Account for Team Foundation Server to the TFSEXECROLE SQL Server Database Role

[image]

How to: Add the Service Account for Team Foundation Server to the TFSEXECROLE SQL Server Database Role
Send Feedback

This error message might indicate that the service account for Team Foundation Server (TFSSERVICE) is no longer a member of TFSEXECROLE, a SQL Server database role created during Team Foundation Server installation.

To resolve this issue, you must manually add the service account (TFSSERVICE) for the primary application tier to TFSEXECROLE on the instance of SQL Server that hosts the configuration database.

For more information about service accounts, see Accounts required for installation of Team Foundation Server.

Required Permissions

To perform these procedures, you must be a member of the Administrators security group on the instance of SQL Server, which hosts the configuration database for the primary application tier.

To add the service account for Team Foundation Server to the TFSEXECROLE SQL Server database role

  1. Click Start, point to All Programs, point to Microsoft SQL Server 2008, and then click SQL Server Management Studio.

    The Connect to Server dialog box opens.

  2. In the Server type list, click Database Engine.

  3. Type the name of the server which hosts the configuration database for the primary application tier, and then click Connect.

  4. In Object Explorer, expand Databases, expand Tfs_DatabaseLabelApplication, expand Security, expand Roles, expand Database Roles, right-click TFSEXECROLE, and click Properties.

    Tfs_DatabaseLabelApplication might have a label substituted for DatabaseLabel, or it might appear as Tfs_Application.

    The Database Role Properties dialog box for TFSEXECROLE appears.

  5. Under Role Members, click Add.

    The Select Database User or Role dialog box appears.

  6. Type the service account (TFSSERVICE) for the primary application tier, and click OK.

  7. Click OK.