 TechNet Magazine January 2007
TechNet Magazine January 2007
JANUARY 2007
SharePoint

Ce mois-ci, TechNet Magazine est consacré à SharePoint et aux nouveautés de la dernière version. Nous allons vous présenter SharePoint Server 2007 et vous décrire les nouvelles fonctionnalités qui permettent de créer un site de collaboration de façon plus efficace et plus aisée. Un article général traite de la recherche à l'échelle de l'entreprise, de la gestion des documents et d'autres détails. D'autres articles parlent de la sécurité dans SharePoint, des tâches d'administration rapides par ligne de commande et de l'élaboration d'un site Wiki pour votre organisation. Et comme d'habitude, vous retrouverez notre série de célèbres colonnes, notamment Raymond Chen (Sortir de l'enfer DLL) et Les Scripteurs (tri dans VBScript à l'aide de la méthode DataList.Sort de .NET Framework).

FONCTIONNALITÉS
SharePoint Présentation de Microsoft Office SharePoint Server 2007

La nouvelle version de SharePoint est à même de répondre à tous vos besoins en matière de collaboration et de gestion de l'information grâce à une plate-forme intégrée et unique. Voici un descriptif des nouveaux outils et fonctionnalités de MOSS qui vont modifier la façon de travailler de votre organisation.

Thomas Rizzo 7 nouvelles fonctionnalités qui améliorent la sécurité dans SharePoint

L'utilisation de SharePoint implique l'exploitation de davantage de données d'entreprise et une intégration plus étroite avec le workflow métier ; par conséquent, la sécurité devient beaucoup plus critique. Découvrez comment ces 7 nouvelles fonctionnalités de MOSS peuvent rapidement améliorer la sécurité au sein de votre organisation.

Adam Robert Buenz Tout trouver avec SharePoint Enterprise Search

Votre entreprise perd du temps et de l'argent lorsque vos employés tentent d'assurer le suivi des informations ? La recherche de contenu au sein de l'entreprise peut vous aider. MOSS offre un outil de recherche de contenu au sein de l'entreprise. Il permet de trouver rapidement des informations, qu'elles se situent sur un site intranet, au sein d'une application métier ou qu'elles soient en possession d'un seul employé.

Matt Hester Puissante administration de SharePoint par ligne de commande

Laissez de côté l'interface graphique. Il existe un moyen beaucoup plus puissant et plus rapide de gérer SharePoint ; en effet, vous avez la possibilité d'exécuter des tâches d'administration à partir d'une invite de commandes et même à partir de procédures de script communes.

Todd Klindt Un site Wiki pour l'organisation

Les sites Wiki offrent un nouveau moyen, plus souple, de collaborer ; ils proposent une approche non structurée à la réflexion et à l'échange d'idées. Grâce à MOSS 2007, vous pouvez implémenter très facilement des sites Wiki dans votre organisation. Voici ce que vous devez savoir pour élaborer et utiliser des sites Wiki dans l'entreprise.

Mauro Cardarelli
COLONNES
De la part de l'éditeur

Joshua Trupin Boîte à outils

Nouveaux produits pour les professionnels de l'informatique

Greg Steen Lumière sur l'utilitaire

Kit d'administration Internet Explorer

Lance Whitney Forum aux questions sur SQL

Archivage de données, serveurs liés, mesure de la bande passante et plus encore

Par Nancy Michell The Cable Guy

Réglage automatique de la fenêtre de réception TCP

Joseph Davies Windows PowerShell

Structures Windows PowerShell

Don Jones 		Salut Scripteur !

Faites attention à ce que vous dites

Les Scripteurs de Microsoft File d'attente Exchange & A

Nous avons toutes les réponses (car nous avons créé les questions)

KC Lemson et Paul Bowden Surveillance de la sécurité

Sécurisation renforcée des services dans Windows Vista

Wole Moses Les fichiers du bureau

Kit WAIK (Windows Automated Installation Kit)

Wes Miller Notes de terrain

Support technique dédié à la belle-famille

James Snell Windows Confidential

Sortir de l'enfer DLL

Raymond Chen


 SharePoint: Pr&#233;sentation de Microsoft Office SharePoint Server 2007
SharePoint Thomas Rizzo

Présentation de Microsoft Office SharePoint Server 2007
Vue d'ensemble:
  • Intégration Web de SharePoint
  • Gestion du contenu
  • Analyse décisionnelle

Le mode de fonctionnement des entreprises au sein de ce que Microsoft appelle le « nouveau monde du travail » évolue en raison de deux phénomènes. Premièrement, les membres d'une équipe sont souvent dispersés à des endroits différents et
même dans des fuseaux horaires différents. Aussi, les logiciels collaboratifs ont pris toujours plus d'importance afin de s'adapter au caractère mondial du travail en mode connecté. Deuxièmement, l'utilisation d'informations numériques prend des proportions gigantesques tandis que les règles de conformité entourant ces données métier se compliquent. Les entreprises connaissent des difficultés pour mettre en œuvre la collaboration et le partage, ainsi que pour assurer la sécurité et la confidentialité des informations. Une solution répondant à toutes ces exigences : communication à travers les continents et les fuseaux horaires, outils de collaboration efficaces et gestion sécurisée des données, est absolument nécessaire pour tirer pleinement profit des informations et des ressources humaines.
L'arrivée de Microsoft® Office SharePoint® Server (MOSS) 2007 rassemble diverses technologies au sein d'une plate-forme et d'un ensemble de services d'entreprise uniques et intégrés. Ces technologies vont de la collaboration et des portails, aux recherches globales, workflows et processus métier. MOSS représente la nouvelle génération de SharePoint Portal Server (SPS) qui repose sur Windows® SharePoint Services (WSS). Pour mieux comprendre l'intégration de MOSS et de WSS, reportez-vous au graphique de la figure 1. Les secteurs ombrés verts composent WSS, et étant donné que MOSS s'appuie sur WSS, MOSS fournit la totalité des secteurs. Plus précisément, MOSS fournit le portail, la recherche, la gestion du contenu d'entreprise, les processus et les formulaires métier, ainsi que les éléments d'analyse décisionnelle.
Figure 1 Service reposant sur MOSS et WSS
Figure 1 Service reposant sur MOSS et WSS (Cliquer sur l'image pour la réduire)
Figure 1 Service reposant sur MOSS et WSS
Figure 1 Service reposant sur MOSS et WSS (Cliquer sur l'image pour l'agrandir)
La suite de cet article mettra en lumière la technologie offerte par MOSS et expliquera comment utiliser ces améliorations pour accroître la productivité de vos utilisateurs.

SharePoint et Web 2.0
Web 2.0, Enterprise 2.0, applications composites, contenu communautaire, quels que soient les termes utilisés, les technologies Internet, telles qu'AJAX, RSS, blogues et sites Wiki, permettent aux utilisateurs de mieux maîtriser leur contenu, leur collaboration et le flux des données qu'ils reçoivent. Ils souhaitent de plus voir allier l'interactivité de Windows à la facilité de déploiement et la convivialité que procure le Web. Mais l'introduction de concepts Internet dans un environnement d'entreprise pose de nouveaux problèmes. La source du service, par exemple, est-elle vérifiable et fiable ? Ce service s'intègre-t-il correctement à votre infrastructure ?
MOSS 2007 offre de nouvelles fonctionnalités tout en améliorant la plate-forme collaborative existante par l'intégration d'options de gestion et d'alerte des documents, l'ajout de capacités, telles que les blogues (voir figure 2), sites Wiki et WebPart pour la publication et la réception de flux RSS. Si vous utilisez Microsoft Office Outlook® 2007, vous pouvez exécuter une synchronisation bidirectionnelle de vos données de collaboration, comme le calendrier, les tâches et les contacts entre Outlook et Microsoft SharePoint. Pour modifier un contact ou déplacer un rendez-vous, vous pouvez effectuer le changement dans Outlook ou SharePoint et il apparaîtra dans l'autre programme.
Figure 2 MOSS 2007 prend en charge blogues et sites Wiki
Figure 2 MOSS 2007 prend en charge blogues et sites Wiki (Cliquer sur l'image pour la réduire)
Figure 2 MOSS 2007 prend en charge blogues et sites Wiki
Figure 2 MOSS 2007 prend en charge blogues et sites Wiki (Cliquer sur l'image pour l'agrandir)
Outlook prend également en charge le traitement hors ligne des bibliothèques de documents. Vous pouvez apporter des modifications à vos documents hors ligne, puis synchroniser ces changements lorsque vous vous reconnectez au réseau.
En outre, MOSS est en mesure d'auditer et d'appliquer les règles de conformité entourant le contenu communautaire ; les clients n'ont ainsi pas à sacrifier la capacité de gestion ou la sécurité.
L'une des améliorations majeures de MOSS 2007 réside dans la personnalisation renforcée de l'utilisation du portail. Dans la nouvelle version de MOSS, Mon Site a été totalement repensé et utilise pleinement les fonctionnalités des sites SharePoint. Les utilisateurs peuvent créer des listes, des bibliothèques de documents ou des sous-sites sous Mon Site et personnaliser l'affichage de ces sites pour eux-mêmes et pour leurs groupes de travail. Mon Site offre également de nouveaux composants WebPart pour les organigrammes et le suivi des collègues, notamment des alertes en cas de modification des métadonnées de ces derniers : numéro de téléphone, titre, bureau, etc. La figure 3 présente un exemple de Mon Site personnalisé dans MOSS.
Figure 3 Prise en charge par Mon Site de fonctionnalités orientées SharePoint supplémentaires
Figure 3 Prise en charge par Mon Site de fonctionnalités orientées SharePoint supplémentaires (Cliquer sur l'image pour la réduire)
Figure 3 Prise en charge par Mon Site de fonctionnalités orientées SharePoint supplémentaires
Figure 3 Prise en charge par Mon Site de fonctionnalités orientées SharePoint supplémentaires (Cliquer sur l'image pour l'agrandir)

Recherche globale
Lorsque la taille des disques durs était limitée, l'emplacement de stockage des informations était facilement mémorisable. Toutefois, avec l'explosion du stockage et la capacité sans limite des utilisateurs à le remplir, la fonction de recherche est devenue un composant essentiel de toute architecture de l'information. MOSS propose des fonctionnalités améliorées de recherche dans les référentiels d'entreprise, reposant sur la plate-forme d'origine de SPS 2003. MOSS 2007 permet toujours l'analyse des partages de fichiers, des sites Web, d'Exchange Server et des référentiels Lotus Notes, tous considérés comme des dépôts non structurés de données.
En revanche, SPS n'offrait pas de méthode simple de recherche dans les référentiels structurés, tels que les applications métier ou les bases de données relationnelles. En outre, les référentiels structurés ou non sont complétés par les métadonnées et l'expertise que les employés apportent à l'entreprise. MOSS permet les recherches dans les référentiels structurés via une nouvelle technologie nommée Business Data Catalog (BDC), et l'analyse des employés et de leur expertise via le nouveau réseau des connaissances (Knowledge Network).
La technologie BDC permet de se connecter à des systèmes dont les données sont exposées via des fournisseurs ADO.NET et des services Web, afin d'y effectuer des analyses et des recherches. Vous créez un fichier de configuration XML contenant les informations nécessaires sur le système auquel vous souhaitez vous connecter. Celles-ci comportent notamment le nom du serveur ou du point de terminaison, la méthode d'énumération et d'extraction des objets du système, le type de filtrage pris en charge par le système dorsal de traitement (back-end), et le schéma de correspondance des données back-end aux données SharePoint. Vous pouvez ensuite utiliser les fonctionnalités de recherche globale de SharePoint pour trouver les données BDC comme vous explorez les autres référentiels d'entreprise.
Par défaut, SharePoint crée une page de profil pour chaque entité commerciale de votre système back-end. Vous pouvez personnaliser ces pages de profil comme les autres pages dans SharePoint. La figure 4 montre une page de profil personnalisée renvoyant des données métier et autres informations. En outre, SharePoint est doté de composants WebPart Business Data vous permettant d'afficher sur vos pages des données BDC et de les filtrer à l'aide des métadonnées disponibles. Ces données métier étant mises en correspondance avec SharePoint, vous pouvez y accéder depuis les listes SharePoint à l'aide du nouveau type de colonne Données métier. Les erreurs de saisie sont évitées et le nettoyage des données est inutile puisque les données de la liste proviennent du système back-end faisant autorité.
Figure 4 Insertion de données métier dans les pages SharePoint depuis les services back-end
Figure 4 Insertion de données métier dans les pages SharePoint depuis les services back-end (Cliquer sur l'image pour la réduire)
Figure 4 Insertion de données métier dans les pages SharePoint depuis les services back-end
Figure 4 Insertion de données métier dans les pages SharePoint depuis les services back-end (Cliquer sur l'image pour l'agrandir)
Knowledge Network présente une méthode efficace de recherche de personnes et d'expertise. Les réseaux sociaux au sein de l'entreprise permettent de mener à bien les activités. Dans de nombreux cas, les employés pourraient se montrer plus productifs s'ils parvenaient à localiser des experts pouvant les assister sur les problèmes métier qu'ils traitent. Toutefois, si votre cercle direct de collègues ne dispose pas des connaissances qu'il vous faut, vous abandonnez la recherche de cette expertise. Grâce à Knowledge Network, au lieu de vous en remettre au réseau social physique, le logiciel vous aide à constituer une carte sociale de votre entreprise et vous permet de sonder ce réseau social. Vous pouvez trier les résultats par distance sociale et les filtrer par propriétés de métadonnées, telles que titre ou service.
Comme toute solution impliquant des personnes et leurs informations identifiables, Knowledge Network offre un modèle de sécurité et de confidentialité strict ; les utilisateurs doivent ainsi s'inscrire pour intégrer le réseau et peuvent contrôler les informations affichées en fonction des destinataires sur le réseau. Knowledge Network analyse vos informations côté serveur, telles que Mon Site SharePoint. Il est également doté d'un composant côté client qui se connecte à Outlook et Instant Messaging pour analyser vos courriels et contacts. Côté client, vous pouvez vérifier la programmation de l'analyse et le contenu publié dans votre profil serveur. L'une des complications des systèmes d'expertise réside dans la tenue à jour des données personnelles. Avec Knowledge Network, le logiciel prend totalement en charge la mise à jour des informations tout en autorisant les utilisateurs à contrôler la visibilité et l'accessibilité de ces données.

Gestion du contenu d'entreprise
Au-delà de la simple administration des documents, MOSS 2007 offre une solution puissante de gestion du contenu par l'ajout de fonctionnalités de gestion des enregistrements, du contenu Web et des formulaires électroniques. Les capacités de gestion des enregistrements de SharePoint comprennent notamment la possibilité de créer un référentiel géré répondant à vos besoins en matière de conformité, notamment la rétention de contenu, l'audit, la codification à barres et l'étiquetage. Grâce à une intégration étroite avec Exchange Server, les messages électroniques peuvent figurer dans le référentiel des enregistrements admis, en plus des informations créées et stockées dans SharePoint. Les capacités de gestion des enregistrements permettent la communication de documents grâce à des rétentions légales et à des recherches dans vos enregistrements. Vous pouvez ainsi enfreindre les politiques de conservation (en cas de procédures légales vous obligeant à prolonger la conservation de contenu au-delà de la durée prescrite).
Dans le domaine de la gestion du contenu Web, MOSS 2007 remplace maintenant Microsoft Content Management Server 2002. SharePoint couvre ainsi vos besoins Web, de l'intranet à l'extranet en passant par les sites Internet. Grâce au regroupement de toutes ces fonctionnalités au sein de SharePoint, vous n'avez qu'une seule technologie à prendre en charge à travers toute votre infrastructure. SharePoint autorise le déploiement de contenu ; vous pouvez donc disposer de serveurs de tests et de serveurs de déploiement. En outre, SharePoint facilite la personnalisation de site grâce à la prise en charge des pages maître ASP.NET 2.0. De plus, pour les sites en plusieurs langues, SharePoint autorise la coexistence de plusieurs variations d'un même site et redirige automatiquement le navigateur en fonction des paramètres linguistiques du client.
Pour les formulaires électroniques, SharePoint introduit une nouvelle capacité appelée InfoPath® Forms Services, qui vous permet de convertir vos formulaires InfoPath en formulaires électroniques. L'opération consiste à créer vos formulaires InfoPath, à cocher une case dans le concepteur pour être averti si vous tentez d'utiliser des fonctions non adaptées au Web, et à enregistrer votre formulaire à un emplacement approuvé au sein d'une liste SharePoint. Vos utilisateurs peuvent ensuite afficher, modifier et soumettre vos formulaires dans un simple navigateur Web.
L'une des fonctions importantes demandées par les utilisateurs de SPS 2003 consistait à améliorer les capacités de workflow, car de nombreux clients souhaitaient intégrer des workflows au contenu stocké dans SharePoint. MOSS va bien au-delà de la simple amélioration du workflow, en ajoutant les nouvelles fonctions Windows Workflow Foundation de .NET Framework 3.0. Vous pouvez créer des workflows à l'aide de Windows Workflow Foundation et les faire fonctionner au sein de SharePoint. Outre l'intégration de Windows Workflow Foundation, SharePoint comprend également des workflows prêts à l'emploi, notamment pour l'approbation et la signature de documents. La figure 5 montre comment configurer un workflow prêt à l'emploi dans MOSS.
Figure 5 Paramétrage de workflows dans MOSS
Figure 5 Paramétrage de workflows dans MOSS (Cliquer sur l'image pour la réduire)
Figure 5 Paramétrage de workflows dans MOSS
Figure 5 Paramétrage de workflows dans MOSS (Cliquer sur l'image pour l'agrandir)
MOSS vous permettant de surveiller vos workflows, vous disposez du statut de la tâche en cours et de l'historique. En outre, SharePoint s'intègre avec les clients Office, ce qui autorise les utilisateurs finaux à démarrer leurs workflows depuis leurs applications Office. Ils peuvent également voir rapidement si des tâches leur ont été affectées et les exécuter directement au sein des applications Office.
MOSS englobe maintenant les portails d'analyse décisionnelle. Ceux-ci contiennent normalement des rapports, des courbes et des tableaux de données que vous pouvez trier et filtrer, et offrant des graphiques représentant de manière visuelle le statut des données. Avec MOSS, l'élaboration de portails d'analyse décisionnelle consiste simplement à créer une page à l'aide du modèle de tableau de bord Analyse décisionnelle. Le tableau de bord par défaut inclut une liste d'indicateurs KPI (key performance indicator) et le composant WebPart Excel® Web Access.
La liste d'indicateurs KPI représente un nouveau type de listes dans MOSS qui permet la connexion à des sources d'informations, telles qu'Excel, SQL Server™ Analysis Services, listes SharePoint, ou à des informations saisies manuellement, et vous autorise à effectuer le suivi de vos indicateurs KPI à partir de ces sources de données. Avec la liste d'indicateurs KPI, vous pouvez visualiser les valeurs courantes, les valeurs cible, les tendances et le statut grâce à des indicateurs visuels.
Dans MOSS, Excel Web Access fait partie des services Excel, version côté serveur d'Excel vous permettant de calculer et d'afficher des informations Excel par l'intermédiaire d'un navigateur Web. Pour utiliser les services Excel, vous pouvez directement publier votre feuille de calcul personnelle à un emplacement autorisé de SharePoint. Les utilisateurs peuvent alors visualiser la feuille de calcul ou les graphiques Excel à l'aide d'un navigateur Web. Puis, les utilisateurs peuvent employer les capacités de paramétrage ou de filtrage éventuelles pour modifier le rendu des informations Excel par le navigateur Web.

Pour en savoir plus
Je n'ai ici fait qu'effleurer une partie infime des nouvelles capacités MOSS, mais il existe une abondance de ressources en ligne pour enrichir vos connaissances. Je vous recommande de commencer par le blogue SharePoint Team et par SharePoint Server TechCenter.

Thomas Rizzo dirige le groupe SharePoint chez Microsoft. Auparavant, Tom travaillait dans les groupes SQL Server et Exchange Server. Il est également l'auteur de quatre livres. Vous pouvez le joindre à l'adresse suivante : thomriz@microsoft.com.
© 2007 Microsoft Corporation et CMP Media, LLC. Tous droits réservés. Toute reproduction, totale ou partielle, est interdite sans autorisation préalable.


 Sharepoint: 7 nouvelles fonctionnalit&#233;s qui am&#233;liorent la s&#233;curit&#233; dans Sharepoint
Sharepoint Adam Robert Buenz

7 nouvelles fonctionnalités qui améliorent la sécurité dans Sharepoint
Vue d'ensemble:
  • Fournisseurs d'authentification
  • Les fonctionnalités de cryptage natives
  • Mappage des accès de substitution et zones
  • Gestion des droits relatifs à l'information

L'implémentation de mesures de sécurité efficaces pour votre environnement Microsoft Office SharePoint Server (MOSS) 2007 peut réduire de manière significative les tâches de gestion tout en permettant aux équipes de
collaborer et de partager les données de l'entreprise dans un environnement sécurisé. Les fonctionnalités d'authentification innovatrices intégrées dans MOSS 2007 vous permettent d'employer les normes de sécurité Web via des fournisseurs d'authentification personnalisés, l'authentification basée sur les formulaires Internet et l'authentification Web unique (SSO). En outre, MOSS offre une gestion précise des droits des informations d'entreprise tels que les fichiers système Microsoft® Office 2007, les fonctionnalités de cryptage natives et les obligations d'authentification client réduits.
Voici les sept composants de sécurité fournis par MOSS 2007 et qui peuvent être mis en œuvre rapidement.
1. Fournisseur d'authentification enfichable Un fournisseur d'authentification est un composant qui vous permet de vérifier les informations d'identification de l'utilisateur. La configuration de ce fournisseur d'authentification pour votre environnement MOSS est une décision de sécurité importante lors de la configuration de l'authentification Sharepoint® sur Internet. MOSS continue à prendre en charge les méthodes d'authentification basées sur Windows® disponibles dans les versions précédentes de Sharepoint y compris l'authentification intégrée et de base (tout en ajoutant l'authentification Digest) pour résoudre les utilisateurs vers des identités Windows tangibles. Cependant, la résolution d'une identité de Windows n'est plus la seule option. Vous pouvez même employer plusieurs fournisseurs d'authentification afin que, par exemple, les utilisateurs internes se connectent à l'aide de l'authentification Windows alors que les utilisateurs externes se connectent avec un autre fournisseur enfichable.
MOSS s'appuie sur ASP.NET 2.0, qui permet l'utilisation de fournisseurs d'authentification enfichables. Cela vous permet d'utiliser des répertoires configurables pour stocker des informations utilisateur s'il y a un fournisseur d'appartenance ASP.NET 2.0 (et un fournisseur de rôles facultatif) qui correspond au magasin de données des membres. Les informations d'authentification enfichables de fournisseur peuvent être hachées, chiffrées ou enregistrées en texte brut en fonction des valeurs de nœud enregistrées dans le fichier machine.config qui correspond au fournisseur d'appartenance. Plusieurs fournisseurs d'appartenance peuvent être utilisés avec MOSS, dont un fournisseur LDAP V3 (livré avec MOSS), un fournisseur SQL Server™ et un fournisseur Active Directory® disponible avec ASP.NET 2.0.
Les fournisseurs d'appartenance et de rôles qui peuvent être implémentés ne sont pas limités aux fournisseurs envoyés. À l'aide de l'architecture d'appartenance ASP.NET 2.0, il est possible de créer des fournisseurs personnalisés qui utilisent les magasins d'appartenance comme Microsoft Access™ ou les bases de données Oracle, les fichiers XML ou même les fichiers texte plats. Un fournisseur d'authentification personnalisé hérite de l'interface MembershipProvider d'ASP.NET, qui à son tour hérite de la classe ProviderBase (voir Figure 1).
Figure 1 Hiérarchie de la classe Membership de .NET
Figure 1 Hiérarchie de la classe Membership de .NET
Certaines implications de l'utilisation de l'authentification ASP.NET 2.0 (par opposition à l'authentification Windows) avec MOSS doivent être prises en considération. L'impact le plus significatif pour de nombreux utilisateurs est une interaction moins importante entre les clients Microsoft Office dans la mesure où la communication des services Web entre MOSS et les clients Office a été conçue à l'origine pour une utilisation avec les identités Windows.
En outre, certains services MOSS, notamment ceux qui sont liés à l'analyse et à l'indexation du contenu, doivent utiliser un compte Windows même s'ils disposent d'un fournisseur enfichable. L'utilisation d'un type d'authentification qui ne résout pas une identité Windows implique la création d'une zone MOSS supplémentaire qui mettra en œuvre l'authentification Windows. (J'aborderai les zones plus tard dans cet article).
Si vous disposez d'une infrastructure de clé publique (PKI) mandatée basée sur des mécanismes de sécurité tels que les cartes à puce pour lesquelles les clés publiques ou les certificats sont transportés par les clients, cela nécessite généralement la résolution d'une identité Windows pour une acceptation et une autorisation appropriées de certificat client, selon l'implémentation. Cela peut aussi nécessiter la création d'une zone MOSS supplémentaire ou d'autres configurations d'authentification.
2. Authentification basée sur les formulaires et authentification Web unique Un autre mécanisme d'authentification intéressant disponible dans MOSS 2007, c'est l'authentification basée sur les formulaires d'ASP.NET 2.0. Dans les versions précédentes de Sharepoint, cela pouvait être effectué uniquement via une extension ISAPI (Internet Server Application Programming Interface) personnalisée ou en utilisant l'extension ISAPI CustomAuth à partir du toolkit IIS 6.0. Et même avec ces solutions, Sharepoint a encore besoin du compte pour résoudre une identité utilisateur Windows, ce qui entraîne des déploiements basés sur le périmètre.
L'authentification MOSS basée sur les formulaires utilise les fournisseurs d'authentification enfichable et de rôles pour activer des mécanismes de sécurité Internet qui ne limitent pas les clients à l'ancienne invite de connexion NT. Vous pouvez aussi générer un processus de connexion personnalisé adapté aux besoins de vos utilisateurs. Pour mieux protéger le processus d'authentification, les cookies d'authentification de formulaires et les tickets d'authentification sont cryptés et infalsifiables.
Le fournisseur d'identité de formulaires ne doit pas nécessairement résider localement et peut, en effet, se connecter à un système de gestion d'identité externe, qui à son tour fournit la validation des informations d'identification de l'utilisateur. Cette fonctionnalité est appelée authentification Web unique et utilise un module HTTP pour l'authentification externe. Dans un tel scénario, vous pouvez fédérer des identités entre votre organisation et vos partenaires commerciaux qui leur permettent d'utiliser les connexions de l'organisation pour s'authentifier sur votre implémentation MOSS.
3. Cryptage des chaînes de connexion d'applications MOSS Pour des raisons de sécurité, il est déconseillé de placer les informations de chaînes de connexion importantes en texte brut dans un fichier web.config. Les informations exposées peuvent permettre à un utilisateur de créer une instance d'objet sur le serveur de base de données SQL et de manipuler des données sensibles. Cependant, à l'aide des fonctionnalités inhérentes à ASP.NET 2.0, vous pouvez crypter les données en utilisant l'une des deux technologies disponibles : Le cryptage Windows DPAPI (Data Protection API) ou RSA. DPAPI exploite les fonctionnalités cryptographiques intégrées de Windows pour crypter et décrypter à l'aide de la clé machine du serveur MOSS. Le cryptage RSA vous permet d'utiliser les algorithmes de clé publique, mais est confronté à la nécessité de disposer de conteneurs appropriés pour les clés de cryptage.
Pour MOSS 2007, et plus précisément pour le fournisseur d'authentification enfichable SQL Server d'ASP.NET 2.0, vous devez crypter le nœud <connectionStrings> dans le texte de chiffrement puisque c'est là que la faille de sécurité la plus significative peut se produire :
<connectionStrings>
<add name="MembershipConnectionString"
     connectionString="connectionString"/>
</connectionStrings>
Le cryptage DPAPI est relativement simple et très facile à implémenter puisqu'il utilise le cryptage natif de la clé machine pour un répertoire virtuel ou un répertoire physique. Il existe d'autres façons d'implémenter le cryptage par programmation mais il est plus facile d'utiliser les commandes suivantes dans une invite de commande :
aspnet_regiis.exe -pe section -app MOSS_virtual_directory -prov provider

aspnet_regiis.exe -pef section MOSS_physical_directory -prov provider
Puisque vous êtes concerné uniquement par l'implémentation du cryptage pour le nœud de chaînes de connexion, il vous suffit de crypter cette section spécifique en indiquant le paramètre de section :
aspnet_regiis.exe -pef "connectionStrings" "C:\Inetpub\wwwroot\WssVirtual " -prov "Provider"

aspnet_regiis.exe -pe "connectionStrings" -app "/MOSSAppinstance" -prov "Provider"
Après l'implémentation, les nœuds d'informations sensibles seront remplacés par les valeurs de chiffrement XML formatés correctement :
<connectionStrings confiProtectionProvider=
"EncryptionProvider">
<EncryptedData>
<CipherData>
<CipherValue>XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
</CipherValue>
<CipherData>
</EncryptedData>
</connectionStrings>
De même que l'architecture générale de MOSS, c'est un modèle enfichable dans lequel vous pouvez créer vos propres fournisseurs de cryptage pour gérer le texte de chiffrement pour les fichiers de configuration MOSS pertinents, tels que web.config ou machine.config, et, de plus, vous n'êtes pas limité au cryptage RSA ou DPAPI.
L'utilisation du cryptage a certaines conséquences. Comme vous utilisez la clé machine locale pour le cryptage, vous ne pouvez utiliser ce nœud de configuration que sur le serveur MOSS sur lequel il a été créé, sinon, le processus de chiffrement échouera. Si un intrus accède au serveur, il peut récupérer la clé machine et décrypter la chaîne de connexion. Le processus de décryptage entraînera également un impact mineur sur les performances des applications.
4. Mappage des accès de substitution et zones Le mappage des accès de substitution (AAM) est crucial, surtout lors de la configuration de plusieurs emplacements d'entrée pour votre environnement Sharepoint. L'AAM vous permet simplement de spécifier plusieurs URL par lesquelles les utilisateurs peuvent accéder à un seul site physique (voir le diagramme de la Figure 2). L'AAM peut diriger les utilisateurs vers le même chemin physique pour votre site MOSS, mais avec différents fournisseurs d'authentification et différentes stratégies de sécurité des applications Web. L'AAM compense également l'utilisation de différents domaines, proxys inversés et d'autres mécanismes de redirection des URL. L'URL que MOSS utilisera est déjà mappée pour vous par défaut, mais cela peut être étendu aux URL supplémentaires qu'un architecte Sharepoint crée explicitement pour gérer différentes méthodes d'entrée. L'AAM est requis pour s'assurer que le mappage des URL internes et publiques appropriées fonctionne correctement.Fournisseur d'authentification SQL Server
Parcourons l'implémentation du fournisseur d'authentification SQL Server enfichable ASP.NET 2.0. Ce fournisseur utilise l'authentification basée sur les formulaires avec des chaînes de connexion cryptées web.config, une implémentation classique pour les déploiements de périmètre MOSS (extranet).
Pour activer le fournisseur enfichable SQL Server, vous devez vérifier que la base de données pour le stockage d'informations d'authentification utilisateur est créée dans l'instance SQL Server appropriée de sorte que le fournisseur de services puisse disposer d'un magasin de données d'appartenance. Pour ce faire, exécutez la commande suivante à partir de la boîte de dialogue Exécuter ou d'une invite de commande :
%WINDIR%\Microsoft.NET\Framework\v2.0.50727\aspnet_regsql
Cela permet d'ouvrir un Assistant SQL Server qui vous aide à configurer la base de données pour l'enregistrement de vos données de membre.
Puisque vous n'avez probablement pas encore installé le fournisseur d'appartenance pour le stockage de base de données, configurez SQL Server pour les services d'application de sorte qu'il crée une nouvelle base de données. Si vous disposez d'une base de données existante, vous pouvez ajouter les informations pertinentes (si la consolidation de la base de données est un objectif de l'organisation).
La chaîne de connexion SQL se connectera à cette instance SQL, afin que vous installiez cette base de données pour utiliser l'authentification SQL Server (voir Figure A). A ce stade, j'utiliserai un nom d'utilisateur et un mot de passe en texte brut puisque, plus tard dans le processus d'installation, je vous expliquerai comment utiliser les fonctionnalités de cryptage ASP.NET 2.0 pour masquer ces informations de connexion privée dans le texte de chiffrement afin d'empêcher toute exploitation possible.

Création d'un formulaire de connexion
L'authentification basée sur les formulaires est souvent utilisée pour les sites exposés extérieurement qui résident sur un réseau de périmètre et sont exposés publiquement à tous les utilisateurs d'Internet. N'oubliez pas que lors de la création d'une collection de sites extranet, il est préférable de choisir le modèle de présence MOSS sur Internet. Avec ce modèle, vous n'aurez pas à créer manuellement un formulaire de connexion. Si vous étendez un site actuel ou que vous souhaitez implémenter un formulaire de connexion personnalisé, il est facile d'en créer un vous-même à l'aide de Microsoft Visual Studio® 2005. Cela nécessite relativement peu de codage.
Démarrez en ouvrant le répertoire physique de la collection de sites comme un site Web via Visual Studio, généralement stocké dans un emplacement comme suit :
C:\Inetpub\wwwroot\wss\VirtualDirectories\<GUID>
La première étape consiste à ajouter une page default.aspx puisque c'est le document par défaut dans les paramètres IIS du serveur virtuel. Utilisez la commande Ajouter un élément dans l'Explorateur de solutions, puis ajoutez un contrôle de connexion à la surface du formulaire Web récemment créé par la Boîte à outils Visual Studio.
Figure a Configuration de l'authentification SQL Server
Figure a Configuration de l'authentification SQL Server (Cliquer sur l'image pour la réduire)
Figure a Configuration de l'authentification SQL Server
Figure a Configuration de l'authentification SQL Server (Cliquer sur l'image pour l'agrandir)

Figure b Sélection du fournisseur d'authentification via l'écran de gestion des applications (Cliquer sur l'image pour la réduire)
Figure b Sélection du fournisseur d'authentification via l'écran de gestion des applications
Figure b Sélection du fournisseur d'authentification via l'écran de gestion des applications (Cliquer sur l'image pour l'agrandir)
Sur la même page, assurez-vous que le fournisseur utilisé pour l'authentification dans la section de fournisseur d'appartenance est spécifié comme AspNetSqlMembershipProvider et que le nom du gestionnaire de rôles est AspNetSqlRoleProvider. Spécifiez l'emplacement où vous souhaitez que les utilisateurs finaux aient un accès anonyme en accédant à /_layouts/setanon.aspx et en sélectionnant le site entier ou le paramètre de sécurité le plus approprié à vos besoins.
Vous effectuerez les changements majeurs en modifiant web.config. Vérifiez que l'élément <authentification> est défini pour utiliser l'élément <formulaires>. En général, cette configuration s'effectue automatiquement lorsque vous basculez de l'authentification Windows à l'authentification des formulaires, et c'est une partie importante du processus de connexion puisqu'il transporte les données concernant le ticket d'authentification des utilisateurs, qui à son tour vérifie les informations d'identification utilisateur lors de l'envoi de la page via les méthodes d'authentification ASP.NET 2.0. Mais web.config ignore encore la connexion SQL à votre banque d'utilisateurs, donc vous devez ajouter l'entrée de chaîne de connexion pour vous connecter à la base de données d'appartenance :
<connectionStrings>
<remove name="LocalSqlServer" />
<add name="LocalSqlServer" connectionString="Server=SQLserver;
Database=aspnetdb;uid=username;
pwd=password;" providerName="System.Data.SqlClient" />
</connectionStrings>
Apportez les mêmes modifications au fichier web.config du site d'administration centrale pour promouvoir la conformité des types d'authentification et vous assurer que le PeoplePickerWildCard résout vers AspNetSqlMembershipProvider afin que les contrôles de recherche permettant d'ajouter des utilisateurs connaissent le chemin d'accès correct à la recherche.
Puisque vous modifiez des fichiers XML principaux, MOSS requiert la réinitialisation de IIS. Une fois que vous êtes connecté à la base de données SQL Server, vous pouvez parcourir le site Web facilement, sauf que vous n'avez pas de propriétaires de collections de sites pour administrer le contenu. Dans le WAT, accédez à l'onglet Sécurité et ajoutez un utilisateur, puis définissez celui-ci comme administrateur de collections de sites en accédant à la Gestion des sites Sharepoint et en ajoutant les utilisateurs appropriés sous les Administrateurs de collections de sites. Le nom doit être correct à cause des modifications apportées précédemment au nœud peoplepicker dans web.config.
Enfin, cryptez les chaînes de connexion avec DPAPI en ouvrant la boîte de dialogue Exécuter et en exécutant :
aspnet_regiis.exe -pef "connectionStrings"
"C:\Inetpub\wwwroot\WssVirtual\<GUID> "
£prov "DataProtectionConfigurationProvider"
Lorsque l'opération est correctement exécutée, une boîte de dialogue de confirmation s'affiche.

Figure 2 Mappage des URL et zones
Figure 2 Mappage des URL et zones (Cliquer sur l'image pour la réduire)
Figure 2 Mappage des URL et zones
Figure 2 Mappage des URL et zones (Cliquer sur l'image pour l'agrandir)
Dans MOSS, les zones sont une nouvelle fonctionnalité qui permet de mieux contrôler le mappage du site fourni par l'AAM. Les zones vous permettent de mapper différents fournisseurs d'authentification vers le même chemin physique et contenu MOSS en fonction des mappages AAM des URL par lesquels les utilisateurs se connectent au contenu. Lors de la spécification des mappages AAM des URL, même s'il n'est pas nécessaire que la zone soit liée à un mécanisme d'authentification, c'est recommandé. Un mappage AAM des URL vers une zone qui n'est pas définie dans la page des fournisseurs d'authentification utilisera le paramètre de sécurité pour la zone par défaut.
Les zones nécessitent une planification puisqu'elles auront un impact important sur la manière dont les utilisateurs sont authentifiés et routés via votre portail à partir de plusieurs points d'entrée des URL. Lors de l'extension d'une nouvelle application Web, vous pouvez spécifier la zone que vous souhaitez utiliser sous la section relative à l'URL d'équilibrage de charge des paramètres (voir Figure 3). Il est recommandé de placer l'URL la plus accessible publiquement (par exemple, l'URL que vous souhaitez exposer sur Internet) dans la zone par défaut, puisque c'est l'URL que Sharepoint utilisera s'il ne peut pas déterminer la zone dans laquelle vous vous trouvez.
Figure 3 Configuration des zones MOSS
Figure 3 Configuration des zones MOSS (Cliquer sur l'image pour la réduire)
Figure 3 Configuration des zones MOSS
Figure 3 Configuration des zones MOSS (Cliquer sur l'image pour l'agrandir)
Dans chaque zone vous pouvez lier une stratégie de sécurité globale des applications Web qui définit des paramètres d'autorisations pour les utilisateurs de la zone. Cela vous permet de gérer de façon centralisée les modifications d'autorisations à grande échelle. Les applications Web incluent généralement plusieurs sites sur différentes collections de sites, et la gestion des autorisations de ces sites peut devenir problématique lorsque les applications sont importantes et complexes. MOSS 2007 permet des stratégies de sécurité globales qui lient les paramètres de stratégie tels que l'accès complet, l'accès en lecture complet, le refus d'accès en écriture, ou le refus total d'accès à un utilisateur ou à un groupe spécifique dans l'application. Ces stratégies peuvent remplacer les paramètres d'autorisation précis fournis par MOSS et gérés à partir de l'interface Administration centrale de SharePoint, donc vous pourrez planifier votre configuration soigneusement.
Votre site exposé extérieurement peut avoir deux URL comme défini dans vos paramètres AAM : une pour l'accès des utilisateurs de votre entreprise et une deuxième pour les utilisateurs externes. Chaque utilisateur dispose d'une URL unique, peut-être contoso pour les utilisateurs internes et extranet.contoso.com pour les partenaires externes fiables. Alors que les deux URL mappent vers le même contenu, chacune peut accéder au site via sa propre zone, avec son propre fournisseur d'authentification et sa propre stratégie de sécurité des applications. La configuration de la zone intranet sur l'URL interne permet aux utilisateurs internes de résoudre leurs identités Windows authentifiées par le domaine tandis que les partenaires externes se connectent via l'authentification Web unique dans la zone extranet, ce qui leur permet d'utiliser les informations d'identification utilisateur propres à l'organisation. Le pouvoir de lier les stratégies de sécurité des applications Web aux zones permet de donner à tous les utilisateurs externes fiables un accès complet en lecture, au lieu d'effectuer une configuration manuelle objet par objet.
5. Contenu ciblé pour une collaboration sécurisée Le verrouillage de vos collections de sites SharePoint signifie que les utilisateurs ne géreront que les informations auxquelles vous les autorisez à accéder. Les nouveaux mécanismes d'autorisations souples permettent un meilleur contrôle sur les différents types d'informations d'entreprise enregistrées dans votre environnement MOSS.
MOSS 2007 vous propose l'option de lier une identité à un objet spécifique, que ce soit une collection de sites, un site individuel, une bibliothèque de documents, un sous-dossier, une liste, un document individuel ou un élément de liste. Cela permet d'appliquer des contrôles d'accès précis et une appartenance explicite à cet élément, en refusant l'accès et en adaptant l'interface utilisateur de sorte que les utilisateurs ignorent les éléments auxquels ils n'ont pas accès. Cette fonctionnalité de MOSS est appelée sécurité au niveau de l'élément (Item Level Security, ILS) ou objets sécurisés (Secured Objects, SO). Les autorisations d'objets MOSS sont hiérarchiques par nature, ce qui leur permet de d'évoluer des objets individuels tels que des éléments de liste vers des éléments plus importants tels qu'une liste ou une bibliothèque de documents. L'héritage des autorisations peut être implémenté, ce qui permet aux objets enfants de niveau inférieur d'hériter de manière facultative des autorisations des objets parents de niveau supérieur. Il existe 33 autorisations uniques par défaut qui peuvent être données à un utilisateur ou à un groupe Sharepoint, chacune d'entre elles peut être liée à un objet. Vous pouvez aussi créer de nouveaux niveaux d'autorisation.
Par exemple, dans un site de gestion de projets, vous pouvez autoriser uniquement les développeurs et les gestionnaires de projets à accéder aux documents de développement sensibles, tels que les spécifications de conception et les techniques de codage intégrées dans les documents Microsoft Word stockés dans une bibliothèque de documents. Les autorisations par défaut de la bibliothèque hériteront des autorisations de site, mais celles-ci peuvent être modifiées pour donner l'accès uniquement aux développeurs et aux gestionnaires de projets ou même pour que chaque document Word puisse être vu et être accessible par le gestionnaire de projet et l'équipe de développement appropriés. À l'inverse, les documents non sensibles peuvent être rendus complètement publics, au niveau de l'élément, du dossier, ou de la bibliothèque de documents.
Les autorisations peuvent même être spécifiées sur les éléments d'événements, tels que les dates d'échéance des projets dans une liste d'événements, afin de vous assurer que seuls certains membres verront les événements spécifiques. De plus, les fonctionnalités ILS s'étendent aux résultats de recherche qui renvoient uniquement les objets mappant vers le contexte de sécurité de l'utilisateur qui effectue la recherche. Ainsi, tous ces contrôles limitent l'interface utilisateur au contexte utilisateur exclusif.
L'architecture de gestion des autorisations a été considérablement améliorée dans MOSS 2007. Les autorisations peuvent être définies pour les groupes Sharepoint et les groupes de domaines, ainsi qu'au niveau individuel. Plusieurs groupes sont déployés par défaut, notamment les Propriétaires (qui obtiennent le contrôle total), les Visiteurs (qui obtiennent des droits de collaborateur) et les Membres (qui obtiennent des droits de lecture). Des individus ou des groupes de domaines peuvent être attribués à ces groupes par défaut ou à des groupes personnalisés que vous pouvez créer et gérer au niveau des collections de sites, qui peuvent avoir différents niveaux d'autorisations uniques.
Lors de la création des groupes basés sur des rôles, vous pouvez créer des groupes « développeurs » et « gestionnaires de projets ». Il est possible ensuite d'attribuer des autorisations précises qui permettent, par exemple, aux développeurs de télécharger la documentation de codage pertinente et d'accorder des autorisations de lecture et d'approbation aux gestionnaires de projets afin qu'ils puissent évaluer et approuver ces documents. L'appartenance aux groupes reste cohérente dans la collection de sites afin que les groupes créés puissent être réutilisables à travers différents sites de projets.
6. Intégration de l'authentification unique enfichable Dans un environnement informatique classique un utilisateur peut accéder à toutes les applications tierces, chacune avec ses propres critères d'authentification, ce qui entraîne divers problèmes de sécurité et la fragilisation des mots de passe. Le service d'authentification unique MOSS permet d'éviter ce problème en fournissant un cache principal crypté d'informations d'authentification des utilisateurs pour mapper vers les systèmes métier connectés. Cela peut permettre de récupérer des informations essentielles de l'entreprise à afficher via les mécanismes MOSS tels que le catalogue des données de l'entreprise (BDC) ou les composants WebPart DataView de Sharepoint (DVWP).
Le fournisseur d'authentification unique (SSO) MOSS, comme plusieurs autres fonctionnalités architecturales d'applications abordées, est enfichable ; vous pouvez spécifier un fournisseur SSO extérieur à celui qui a été livré avec MOSS (SpsSsoProvider), bien qu'un seul fournisseur SSO par système métier puisse être enregistré à la fois dans l'environnement.
7. Gestion des droits relatifs à l'information (IRM) La protection des informations au niveau client même lorsque les informations d'entreprise sont mises hors ligne constitue une préoccupation majeure pour les entreprises qui ont tendance à traiter des données sensibles, surtout celles qui relèvent de législations telles que le Projet de loi N° 1386 du Sénat de Californie, Sarbanes-Oxley (conformité SOX), et l'Acte de responsabilité et de transférabilité de l'assurance santé (Health Insurance Portability and Accountability Act (HIPAA)). La Gestion des droits relatifs à l'information (IRM) côté serveur intègre des référentiels MOSS pour fournir une solution commune basée sur l'environnement de Gestion des Droits Windows (WRM). L'IRM permet de contrôler étroitement les données de l'entreprise en imposant des restrictions d'accès au niveau des documents, quel que soient l'emplacement de stockage du document ou l'utilisateur qui essaie de l'ouvrir. Une implémentation commune de la gestion IRM permet d'autoriser l'affichage ou l'impression, mais cela peut s'étendre à d'autres scénarios tels que la vérification d'informations d'authentification d'utilisateur après une période donnée, l'interdiction de télécharger des ressources qui ne bénéficient pas de la gestion IRM, une balise d'expiration planifiée qui supprimera la stratégie de restriction et la liaison à une stratégie globale d'autorisation de la gestion IRM de l'organisation.
Les fonctionnalités IRM sont fournies par un protecteur et plusieurs sont installés avec MOSS 2007. Un protecteur est une application qui gère le processus de cryptage pour un type de fichier, généralement tous les fichiers que vous enregistrez dans MOSS disposent déjà de protecteurs intégrés. (Les fichiers système Microsoft Office sont pris en charge en mode natif, avec les formats de fichier OpenXML). Cependant, comme les autres fournisseurs au sein de MOSS, l'architecture des applications est enfichable de sorte que vous pouvez implémenter des protecteurs personnalisés pour les autres types de fichier.
La première étape de l'implémentation IRM est de s'assurer que vous répondez à toutes les exigences de votre environnement MOSS. Le client des services WRM doit être installé sur chaque serveur Web MOSS frontal et les services de Gestion des droits Microsoft (RMS) doivent être connectés à vos serveurs Web MOSS frontaux. Vous devez ensuite spécifier le serveur RMS que MOSS doit assimiler via l'Administration centrale de SharePoint, en utilisant la valeur par défaut d'Active Directory ou en spécifiant l'emplacement.
IRM fonctionne directement avec les structures de magasin de données de Sharepoint telles que les bibliothèques de documents pour maintenir les autorisations. Lorsqu'un utilisateur accède à une bibliothèque de documents IRM et essaie de télécharger un document, MOSS lie les autorisations configurées pour la bibliothèque au document (voir Figure 4). Par conséquent, il existe un mappage 1:1 entre MOSS et les autorisations de documents, convertissant les rôles de Sharepoint liés au document en niveaux d'autorisation IRM dans le document lui-même.
Figure 4 Transition des autorisations IRM à partir d'une Bibliothèque de documents
Figure 4 Transition des autorisations IRM à partir d'une Bibliothèque de documents (Cliquer sur l'image pour la réduire)
Figure 4 Transition des autorisations IRM à partir d'une Bibliothèque de documents
Figure 4 Transition des autorisations IRM à partir d'une Bibliothèque de documents (Cliquer sur l'image pour l'agrandir)
Le document est crypté localement pour une protection hors ligne et maintenu dans cet état jusqu'à son téléchargement dans la bibliothèque de documents. Lorsque le document est téléchargé, il est maintenu dans un formulaire non crypté afin que le rassembleur Sharepoint indexe son contenu pour une recherche de texte intégral (bien qu'aucun compte utilisateur ne puisse accéder au contenu dans le formulaire non crypté).
MOSS 2007 fournit un certain nombre de nouvelles fonctionnalités qui permettent d'implémenter une sécurité efficace dans votre organisation sans ajouter de nombreuses tâches de gestion. En outre, les fonctionnalités très flexibles offrent de nombreuses possibilités de personnalisation pour assurer aux utilisateurs un accès direct aux informations dont ils ont besoin. Voir l'encadré « Fournisseur d'authentification SQL Server » qui donne un exemple simple.

Adam Robert Buenz est architecte Sharepoint et développeur pour ARB Security Solutions LLC (sharepointsecurity com). Il se concentre sur les environnements de collaboration centrés sur la sécurité. Contactez-le à l'adresse adam@sharepointsecurity.com.


 SharePoint: Tout trouver avec SharePoint Enterprise Search
SharePoint Matt Hester

Tout trouver avec SharePoint Enterprise Search
Vue d'ensemble:
  • Architecture d'une solution de recherche de contenu d'entreprise
  • Indexation et interrogation des données de l'entreprise
  • Données métier et connaissance des utilisateurs

Vous vous passez probablement beaucoup de temps à vous inquiéter à propos de facteurs tels que la durée d'exécution et la disponibilité des serveurs, les mises à jour de logiciel et la sécurité. Mais même si votre infrastructure fonctionne parfaitement, c'est à dire chaque application et
fichier sur l'ensemble du réseau, vos utilisateurs n'en perdent peut-être pas moins de la productivité. Bien sûr, toutes les données dont ils ont besoin sont disponibles, mais combien de temps leur faut-il pour y accéder ?
Il a beaucoup été fait pour aider les utilisateurs souffrant d'un excès d'informations. Les outils de recherche de bureau facilitent la recherche d'informations dissimulées parmi toutes les autres données stockées sur votre système. (Voir mon article d'août 2006 « Find Anything with Windows Desktop Search » (Tout trouver grâce à Windows Desktop Search. Mais qu'en est-il de toutes les données contenues sur les portails, stockées dans les partages, emprisonnées dans les applications professionnelles, ou tout simplement présentes dans la tête des employés et nulle part ailleurs ? Ces informations sont vitales à vos utilisateurs. Ils en ont besoin pour effectuer leur travail, et vite, pour prendre des décisions rapides en tout connaissance de cause. Mais songez au temps qu'il faut à ces utilisateurs pour rechercher et assembler des données disséminées à travers le réseau. Songez maintenant à l'impact potentiel de ce temps de recherche sur les performances de votre entreprise.
Vous devez réduire le temps que consacrent vos utilisateurs à traquer les informations stockées à travers l'entreprise. Comment ? Tout simplement, en utilisant un moteur disposant de fonctionnalités de recherche de contenu à l'échelle de l'entreprise.
Ce système est capable de rechercher des informations stockées presque n'importe où dans votre organisation. Qu'il s'agisse de rechercher une information stockée sur le bureau, logée sur un site intranet, enfermée dans une application métier ou dans la tête d'un employé, un outil de recherche de contenu d'entreprise peut aider. (Pas d'inquiétude, il ne sera pas question ici d'implantation de puce électronique dans la tête de vos employés !)
Une solution de recherche de contenu d'entreprise combine recherche de bureau et fonctionnalités de recherche rapide dans l'intranet. Enfin, un outil de recherche de contenu d'entreprise doit pouvoir effectuer des recherches fédérées, c'est-à-dire capables d'accéder à plusieurs sources de données à partir d'une seule requête. L'utilisateur dispose d'une interface unique pour entrer sa requête. Toutefois, derrière cette interface, la requête est envoyée à différents moteurs de recherche, puis les résultats sont affichés dans une vue agrégée.
Dans cet article, je vais montrer en quoi Microsoft® Office SharePoint® Server 2007 (MOSS 2007), la nouvelle génération de solutions Microsoft SharePoint, offre un moteur de recherche puissant qui vous aidera à vous frayer un chemin parmi les silos d'information de votre organisation. MOSS 2007 offre de nombreuses améliorations par rapport aux versions précédentes, des composants entièrement redéveloppés, ainsi que des fonctionnalités inédites. Je vais présenter ici certains de ces composants clés, tels que l'indexation, la propagation, la pertinence et les sources de contenu, en précisant comment ils vous permettront de fournir des fonctions de recherche plus efficaces à vos utilisateurs.

Rechercher des contenus d'entreprise avec SharePoint
La recherche de contenu d'entreprise sera proposée sous quatre versions qui se distinguent pas les différences clés suivantes : Microsoft Office SharePoint Server 2007 for Search (Standard Edition), Microsoft Office SharePoint Server 2007 for Search (Enterprise Edition), Microsoft Office SharePoint Server 2007 Standard et Microsoft Office SharePoint Server 2007 Enterprise.
La différence principale entre les deux éditions Search et les éditions complètes SharePoint Server réside dans le fait que les deux éditions Search n'incluent pas la fonctionnalité de recherche de personnes (qui comprend également l'intégration à Knowledge Network for MOSS 2007), le catalogue de données métier ou le centre de recherche amélioré, avec ses onglets personnalisables. La figure 1 illustre les différences clés.
Figure 1 Différences clés entre les quatre offres de recherche (Close Figure 1)

 | Microsoft Office SharePoint Server 2007 for Search Standard Edition | Microsoft Office SharePoint Server 2007 for Search Enterprise Edition | Microsoft Office SharePoint Server 2007 Standard Edition | Microsoft Office SharePoint Server 2007 Enterprise Edition
Index | 40 types de fichier disponibles dès l'installation (extensible) | 40 types de fichier disponibles dès l'installation (extensible) | 40 types de fichier disponibles dès l'installation (extensible) | 40 types de fichier disponibles dès l'installation (extensible)
Prend en charge (dès l'installation) les recherches sur les partages de fichiers, les sites Web, les sites SharePoint, les dossiers publics Exchange et les fichiers de base de données Notes |  |  |  |
Prend en charge les recherches sur les référentiels de document d'éditeurs tiers |  |  |  |
Prend en charge les recherches de personnes et de compétences |  |  |  |
Prend en charge les recherches sur les sources de données structurées |  |  |  |
Assure un contrôle d'accès au contenu sécurisé |  |  |  |
Fournit une interface graphique de Centre de recherche améliorée |  |  |  |
Limite du document | 400,000 | Illimité | Illimité | Illimité
L'interface graphique offre plusieurs nouvelles fonctionnalités, notamment « Voulez-vous dire ? ». Cette fonctionnalité très utile sur les moteurs de recherche Internet vous permet de confirmer l'objet de votre recherche en cas d'ambiguïté orthographique (voir figure 2). L'interface dispose également de fonctionnalités de mise en surbrillance des résultats et de prise en charge des « meilleures probabilités ». Mais nous n'en sommes encore qu'à gratter la surface des nouvelles capacités de recherche.
Figure 2 Nouvelle fonctionnalité « Voulez-vous dire... » Fonctionnalité dans les recherches SharePoint
Figure 2 Nouvelle fonctionnalité « Voulez-vous dire... » Fonctionnalité dans les recherches SharePoint (Cliquer sur l'image pour la réduire)
Figure 2 Nouvelle fonctionnalité « Voulez-vous dire... » Fonctionnalité dans les recherches SharePoint
Figure 2 Nouvelle fonctionnalité « Voulez-vous dire... » Fonctionnalité dans les recherches SharePoint (Cliquer sur l'image pour l'agrandir)

Accéder aux connaissances des personnes
L'une des nouvelles options les plus intéressantes réside dans la possibilité de rechercher des personnes possédant des connaissances ou des compétences particulières. Cela permet aux utilisateurs de puiser dans la somme de connaissances accumulées par les employés de l'entreprise - une étape importante dans le débroussaillage des silos.
Pour ce faire, l'indexation et la recherche peuvent être effectuées sur n'importe quel répertoire LDAP (Lightweight Directory Access Protocol), y compris les listes de distribution Active Directory® et les groupes d'utilisateurs SharePoint. En réalité, MOSS ne recherche pas directement dans les annuaires LDAP ; pour permettre la recherche des personnes, les informations LDAP doivent être importées dans MOSS. (Les recherches peuvent également être menées sur l'ensemble de l'infrastructure de l'entreprise).
Les résultats des recherches peuvent être groupés par « distance sociale » des individus, c'est-à-dire la distance entre le poste d'un utilisateur (un assistant commercial n'appellera probablement pas directement le directeur financier de l'entreprise) et les intérêts communs. La figure 3 illustre les résultats d'une recherche de personnes.
Figure 3 Recherche de collègues possédant des connaissances pertinentes
Figure 3 Recherche de collègues possédant des connaissances pertinentes (Cliquer sur l'image pour la réduire)
Figure 3 Recherche de collègues possédant des connaissances pertinentes
Figure 3 Recherche de collègues possédant des connaissances pertinentes (Cliquer sur l'image pour l'agrandir)

Recherche de données d'entreprise
SharePoint peut également indexer différents types de données d'entreprise, notamment les applications métier (telles que les applications RH, CRM, de notes de frais, etc.). Ces types de données sont traditionnellement difficiles d'accès en dehors de l'interface normale de l'application métier, ce qui ne facilite pas leur consultation ou leur utilisation par la majorité des employés.
Désormais, MOSS est capable d'extraire des données de n'importe quelle application métier, telle qu'une base de données relationnelle ou Lotus Notes, accessible par l'intermédiaire de services Web ou ADO.NET. La particularité de ce système est qu'il ne nécessite pas de code personnalisé. Grâce à la fonction Business Data Catalog (Catalogue des données métier), Il est aussi facile d'obtenir les données d'entreprise que d'accéder à n'importe quel document ou site Web. L'option (Business Data Catalog) peut être simplement intégrée à la gestion de propriété et aux zones de recherche personnalisées du Centre de recherche.

Indice de pertinence
Bien sûr, quel que soit le nombre de nouvelles fonctionnalités, celles-ci n'auraient pas beaucoup d'intérêt si elles ne produisaient pas des résultats précis. Heureusement, MOSS a fait l'objet d'améliorations spectaculaires en termes de pertinence. Toutefois, avant d'aborder ces améliorations, il est important de souligner que la pertinence des recherches en entreprise n'est pas comparable à celle des recherches sur Internet.
Peut-être vous demandez-vous pourquoi les recherches en intranet ne reposent pas sur les mêmes outils (et la même précision) que les recherches Internet. En deux mots, il s'agit d'environnements très différents, présentant des besoins et des spécifications très différentes. Ces différences peuvent être groupées en trois catégories principales : sécurité, structure et hiérarchie.
L'aspect sécurité concerne la nature d'Internet par opposition à celle de l'entreprise. Sur Internet, les données sont communément accessibles de manière anonyme, l'indexation et les recherches ne nécessitant aucune authentification ou limitation de sécurité. L'environnement de l'entreprise, en revanche, doit se conformer à un modèle de sécurité strict, notamment en matière de filtrage des résultats par rapport aux droits de l'utilisateur qui effectue la recherche.
L'impact de la structure est lié à la densité. Le réseau Internet est extrêmement riche et profond, chaque site étant lié à d'autres pour augmenter son contenu. Dans l'entreprise, les liens sont généralement utilisés pour la navigation, et la structure beaucoup moins dense.
Le facteur hiérarchie du site n'est que vaguement lié à la structure des liens. Sur Internet, il n'existe généralement aucune hiérarchie entre les sites, et très peu de sites de haut niveau. En revanche, les intranets d'entreprise suivent normalement d'un plan précis et sont hiérarchiques par nature. Même lorsqu'une entreprise possède plusieurs niveaux racines, il n'existe généralement qu'un seul portail pour l'organisation.
Ces différences fondamentales modifient la façon dont une solution de recherche de contenu d'entreprise indexe les données et renvoie les résultats. MOSS 2007 vise à mieux répondre aux différents besoins de l'entreprise. Il contient un nouveau moteur de classement, développé à l'aide d'une technologie existante combinée à des travaux réalisés par Microsoft Research et l'équipe MSN®. La pertinence des résultats a été améliorée par la création d'une série d'algorithmes de pertinence, qui rassemblent des informations internes et externes sur les documents et les données métier analysés. Lorsque des données d'entreprise sont indexées, plus de 200 types de document sont analysés et les algorithmes sont appliqués pour détecter la langue, extraire les métadonnées et procéder à une analyse du texte. Ces nouveaux algorithmes, qui sont spécifiquement ajustés en fonction des particularités des données d'entreprise et des applications métier, améliorent grandement la précision des résultats.
Les calculs de pertinence incluent plusieurs balises de métadonnées. Vous trouverez ci-dessous certains des éléments pris en compte :
  • Distance de clic – Distance de navigation depuis les sites autorisés (les distances les plus courtes sont souvent plus pertinentes).
  • Texte d'ancrage – Les liens hypertexte servent d'annotations concernant leur cible. De plus, ils ont tendance à être extrêmement descriptifs.
  • Profondeur d'URL – Les URL les plus élevées dans la hiérarchie sont souvent plus pertinentes.
  • Correspondance d'URL – Correspondances exactes du texte des URL.
  • Extraction des métadonnées – Extraction automatique du titre et de l'auteur du texte des documents s'ils sont manquants.
  • Détection automatique de la langue – Permet de créer une préférence pour les résultats dans votre langue.
  • Préférence de type de fichier – Certains types de fichier ont tendance à être plus pertinents (par exemple, les fichiers PPT sont souvent plus pertinents que les fichiers XLS).
  • Analyse de texte – Classement de texte traditionnel basé sur des facteurs tels que la correspondance des termes, la fréquence des termes et les variantes des mots.

Comment fonctionne l'indexation ?
MOSS 2007 a réalisé d'importants progrès en matière d'indexation et de gestion des contenus. Tout d'abord, vous pouvez spécifier si les sources de contenu sont des serveurs SharePoint, des sites Web, des partages de fichiers, des dossiers publics Exchange, des bases de données Lotus Notes ou des applications métier. L'approche globale de l'administration de l'indexation a été simplifiée, vous permettant de choisir librement ce que vous souhaitez indexer, comment et à quel moment, parmi plusieurs sources de contenu. Cette fonctionnalité est gérée par l'intermédiaire de règles de navigation, qui vous permettent de spécifier les chemins à inclure ou exclure. Vous pouvez même configurer la façon dont le robot suit les liens de l'URL. Un journal intégré vous permet de connaître le nombre de sites analysés et la manière dont laquelle ils ont été indexés.
L'index utilise la même technologie d'index que celle utilisée dans Windows® Desktop Search. Deux composants principaux forment l'index : un index de contenu et une banque de propriétés. Cette méthode de traitement des données est extrêmement efficace. L'index de contenu comprend le texte contenu dans les fichiers, ainsi qu'un index inversé associé des mots qui figurent dans votre index d'entreprise. La base de données qui stocke les propriétés est essentielle au traitement des résultats. Cette base de données contient toutes les propriétés de métadonnées supplémentaires (auteur, date de création, type de document, etc.) de tous les documents présents dans la mémoire. Structurellement, la mémoire des propriétés se compose d'un tableau de propriétés et de leurs valeurs. Chaque ligne du tableau correspond à un document séparé dans l'index de texte intégral. La mémoire des propriétés assure et applique la sécurité au niveau du document collectée lors de l'indexation d'un document.
Le processus d'indexation et de stockage démarre au niveau du moteur d'indexation, qui est chargé d'analyser la source de contenu. Le moteur commence son analyse après avoir vérifié qu'il dispose d'un gestionnaire de protocole approprié pour lire les sources de contenu. Une fois le gestionnaire de protocole approprié pour la source de contenu chargé, le gestionnaire de protocole et les IFilters nécessaires extraient et filtrent les éléments de la source de contenu. Un IFilter est un complément qui permet au moteur d'index d'ouvrir, de lire et d'indexer le contenu de nouveaux types de fichiers qu'il ne pourrait pas entièrement indexer sans cela. Les IFilters extraient le texte et les métadonnées de chaque document et retransmettent ensuite le flux au moteur d'index.
Les propriétés du document sont ensuite enregistrées dans la mémoire des propriétés, et le texte du document à proprement parler est placé dans l'index de contenu. Mais juste avant cela, le moteur d'index supprime les mots « parasites ». Le moteur traite également les informations à l'aide de séparateurs de mots et d'outils de conjugaison afin de simplifier les données, et de permettre une meilleure exécution des requêtes. (Les séparateurs de mots décomposent le texte en mots et en phrases. Les outils de conjugaison génèrent les formes désinentielles d'un mot donné).
Le moteur d'index utilise la méthode de propagation continue, qui permet la génération quasi immédiate de l'index. Avec la propagation continue, l'index est généré à mesure que le processus d'analyse traite les sources de contenu. Cette amélioration permet l'obtention de résultats quasi immédiats, un progrès de taille par rapport à SharePoint Portal Server 2003, où l'analyse de contenus volumineux pouvait prendre plusieurs jours et où l'index n'était propagé qu'à l'issue de l'analyse.

Comment fonctionne l'interrogation par requêtes ?
Lorsqu'un utilisateur entre une requête ou qu'une application personnalisée appelle l'index, le moteur de requête commence à traiter la requête. Il passe d'abord la requête dans un séparateur de mots spécifique à la langue. Si la langue n'est pas identifiée, un séparateur de mots neutre peut être employé. Une fois la requête décomposée, le moteur transfère l'information à un outil de conjugaison (si la conjugaison est activée) pour un traitement supplémentaire. Ce processus en deux étapes améliore la pertinence et l'efficacité des résultats renvoyés par la requête.
Si la requête spécifie des informations de propriété, le système vérifie si l'index contient des correspondances avec des documents de la mémoire des propriétés, puis vérifie à nouveau les propriétés de la requête afin de garantir la correspondance. Le moteur de requête assure un niveau de filtrage supplémentaire afin de supprimer les résultats auquel l'utilisateur n'a pas l'autorisation d'accéder. Les résultats correspondants sont retournés sous forme de liste, triée par pertinence. La figure 4 illustre le fonctionnement conjoint de tous les composants d'indexation et d'interrogation.
Figure 4 Architecture de l'environnement de recherche de contenu d'entreprise MOSS 2007
Figure 4 Architecture de l'environnement de recherche de contenu d'entreprise MOSS 2007 (Cliquer sur l'image pour la réduire)
Figure 4 Architecture de l'environnement de recherche de contenu d'entreprise MOSS 2007
Figure 4 Architecture de l'environnement de recherche de contenu d'entreprise MOSS 2007 (Cliquer sur l'image pour l'agrandir)

Gestion améliorée
Les administrateurs découvriront un environnement de recherche plus facile à gérer. Un ensemble amélioré d'outils communs pour les utilisateurs finaux et les administrateurs permet de réduire la complexité introduite par les différents points de connexion à la plate-forme. Et le moteur de recherche bénéficie pleinement du nouveau modèle de gestion de MOSS 2007. (La figure 5 présente la page de modification des paramètres de recherche principale).
Figure 5 Configuration des paramètres de recherche
Figure 5 Configuration des paramètres de recherche (Cliquer sur l'image pour la réduire)
Figure 5 Configuration des paramètres de recherche
Figure 5 Configuration des paramètres de recherche (Cliquer sur l'image pour l'agrandir)
Les zones de recherche, qui vous permettent de contrôler les différentes fonctionnalités de recherche, ont également été améliorées. Les zones de recherche facilitent vos recherches au sein d'une source de contenu, en vous permettant essentiellement de travailler sur des tronçons plus petits de l'index. Dans SharePoint Portal Server 2003, les zones de recherche sont connectées aux sources de contenu, ce qui les rend moins flexibles et moins faciles à gérer. Dans MOSS 2007, les zones de recherche sont distinctes des sources de contenu, et vous offrent plus de flexibilité. Vous pouvez définir des zones de recherche en fonction de propriétés de contenu arbitraires telles que l'URL, le type ou l'auteur. Vous pouvez même combiner des zones de recherche de façon à jouer avec plusieurs règles, par exemple, tous les documents techniques d'un auteur spécifique.
Bien sûr, si un administrateur veut améliorer la performance du moteur de recherche, l'une des choses les plus importantes à faire est de comprendre l'usage actuel de l'index. L'une des additions les plus remarquables au jeu d'outils d'administration est le rapport de requête. La fonctionnalité de rapport de requête disponible dès l'installation vous permet de trouver rapidement des informations sur les tendances en matière de volumes de requêtes, les requêtes les plus fréquentes, les taux de clic publicitaire, les requêtes ne produisant aucun résultat, et ainsi de suite. Le rapport de requête peut fournir des détails aux niveaux du site et du fournisseur de services principal. La figure 6 présente un exemple de rapport. Vous pouvez exporter les informations vers Microsoft Excel® pour approfondir l'analyse.
Figure 6 Rapport de requête de MOSS 2007
Figure 6 Rapport de requête de MOSS 2007 (Cliquer sur l'image pour la réduire)
Figure 6 Rapport de requête de MOSS 2007
Figure 6 Rapport de requête de MOSS 2007 (Cliquer sur l'image pour l'agrandir)

Sécurité et privilèges
Comme mentionné précédemment, le moteur de requête filtre les résultats de sorte que la liste présentée à l'utilisateur ne contienne que les documents qu'il est autorisé à consulter. (Dans SharePoint Portal Server 2003, l'utilisateur se voit proposer des liens vers des informations auxquelles il peut ne pas avoir le droit d'accéder). Attention : MOSS 2007 n'assure pas la limitation de sécurité sur les analyses Web. Vous ne pouvez pas limiter pour sécurité les sites Web car le protocole HTTP n'a pas la possibilité de lire en retour les informations de contrôle d'accès. De plus, MOSS 2007 ne vous permet pas de limiter les recherches dans le catalogue de données métier ou les recherches de personnes pour des raisons de sécurité.
MOSS 2007 respecte les listes de contrôle d'accès (ACL) existantes, garantissant la sécurité des documents dans l'index. Il s'agit d'un facteur de distinction important par rapport aux autres outils de recherche. Contrairement à d'autres moteurs de recherche qui exigent l'utilisation d'un fichier de configuration pour définir manuellement les autorisations sur les fichiers, MOSS 2007 vous permet de rester synchro avec les autorisations actuelles.
L'index peut refléter rapidement les modifications apportées à l'ACL d'un document unique. Disons par exemple qu'une feuille de calcul Excel est actuellement enregistrée dans l'index et que l'ACL du document est modifié en restrictif. Un administrateur peut réindexer et analyser ce seul document et le découpage de sécurité se produire immédiatement (et, si nécessaire, le document être entièrement supprimé de l'index).
De plus, chaque document peut se voir attribuer des autorisations uniques ou être défini de manière à hériter des paramètres de sécurité d'une bibliothèque de documents ou d'une bibliothèque parente. Cela simplifie considérablement le processus de sélection des groupes ou des individus autorisés à afficher, modifier ou enregistrer les documents.
Des améliorations ont également été apportées à la gestion de l'authentification et de l'ouverture de session. Le cache sécurisé des informations d'identification est désormais extensible, ce qui permet à MOSS d'accepter les systèmes de mise en cache d'informations d'identification à authentification unique provenant de tiers et les modules complémentaires à codage personnalisé. Par ailleurs, l'authentification centrale peut désormais accepter les systèmes tiers. Ces deux améliorations reposent sur le nouveau modèle de fournisseur ASP.NET, qui autorise l'utilisation d'autres services d'annuaire.

Personnalisation
Dans MOSS 2007, vous disposez de plusieurs options de modification de l'interface utilisateur. L'interface graphique peut être personnalisée avec nombre des outils que vous utilisez déjà pour modifier les sites Web. Il existe également de nouveaux outils, comme Office SharePoint Designer qui aide à la création de pages maîtres (et offre une manière simple de construire un site personnalisé). La figure 7 illustre une page de résultats de recherche en cours de modification.
Figure 7 Personnalisation de l'apparence d'une page de résultats de recherche
Figure 7 Personnalisation de l'apparence d'une page de résultats de recherche (Cliquer sur l'image pour la réduire)
Figure 7 Personnalisation de l'apparence d'une page de résultats de recherche
Figure 7 Personnalisation de l'apparence d'une page de résultats de recherche (Cliquer sur l'image pour l'agrandir)
MOSS 2007 propose deux onglets disponibles dès l'installation pour l'interface du Centre de recherche : Tous les sites et Personnes. Il vous suffit ensuite d'ajouter des onglets en fonction des différents types d'informations les plus fréquemment recherchées par vos utilisateurs. Vous pouvez par exemple fournir une entrée directe dans n'importe laquelle de vos applications d'entreprise, bases de données ou même services d'annuaire. Vous pouvez même mettre ces onglets en corrélation avec des zones de recherche. C'est un moyen pratique pour créer des onglets de recherche contextualisés sur des contenus spécifiques. Notez que les éditions MOSS 2007 for Search ne permettent pas cette personnalisation des onglets de recherche.

Conclusion
Comme vous l'avez vu, MOSS 2007 propose des améliorations tout à fait intéressantes en matière de recherche de contenu d'entreprise, qui permettent à vos utilisateurs de gagner en efficacité et en productivité. Pour plus d'information, consultez Microsoft Office SharePoint Server TechCenter.

Matt Hester est présentateur TechNet au sein de l'équipe Microsoft Across America. Pour suivre une de ses présentations en direct, rendez-vous sur www.technetevents.com/mhester. Consultez son blog à l'adresse blogs.technet.com/matthewms.


 SharePoint: Administration de ligne de commande ultraperformante pour Sharepoint
SharePoint Todd Klindt

Administration de ligne de commande ultraperformante pour Sharepoint
Vue d'ensemble:
  • Configuration de Sharepoint avec STSADM
  • Ecriture de scripts pour les tâches administratives quotidiennes
  • Opérations STSADM avancées

Pensez à la façon dont les gens interagissent avec Windows ou Microsoft Office. Les utilisateurs qui sont fans de la souris manipulent le pointeur pour naviguer entre les menus et les barres d'outils afin d'exécuter les tâches courantes. D'autres préfèrent
le clavier, exécutant rapidement des frappes et des raccourcis familiers. Il existe presque toujours plusieurs façons d'effectuer une tâche donnée.
En effet, une interface graphique peut être facile à utiliser, mais elle peut aussi se révéler peu pratique pour les tâches qui nécessitent des actions répétitives. Certaines opérations sont plus faciles à effectuer avec le clavier. Si vous vous occupez de l'administration de Sharepoint®, vous savez sans doute ce que c'est qu'être embourbé dans une interface graphique. Mais Sharepoint offre en fait une façon plus performante d'exécuter les tâches.
L'interface principale utilisée pour la gestion de Windows® Sharepoint Services (WSS) et de Microsoft® Office SharePoint Server 2007 (MOSS) est l'interface graphique d'administration centrale de SharePoint. Mais Sharepoint inclut également un outil de ligne de commande pour une administration plus performante. Cet outil, STSADM.exe, fournit toutes les fonctionnalités de l'Administration centrale de SharePoint, tout en offrant la souplesse de ligne de commande convoitée par de nombreux administrateurs. Dans cet article, je vous propose un cours accéléré pour apprendre à gérer WSS et MOSS à l'aide de STSADM. Je vous donnerai également quelques conseils de configuration de votre environnement et j'aborderai certaines commandes STSADM courantes. Je vous expliquerai même certaines commandes STSADM avancées qui vous feront de vous un héros, en cas de difficultés.

Démarrage
Si vous n'êtes pas encore tombé sur STSADM, c'est peut-être parce qu'il est bien caché. Dans Windows SharePoint Services 2.0, il se trouve par défaut dans c:\program files\common files\microsoft shared\web server extensions\60\bin. Dans la version 3.0, l'emplacement par défaut est c:\program files\common files\microsoft shared\web server extensions\12\bin.
Pour simplifier l'accès à cet outil, j'utilise deux approches différentes. D'abord, j'ajoute simplement ce répertoire à ma variable d'environnement PATH. De cette façon, je peux utiliser STSADM depuis n'importe quel emplacement du système de fichiers. Cependant, ce n'est pas toujours la solution idéale. Ma deuxième approche consiste à créer un raccourci vers CMD.EXE et à définir l'emplacement de STSADM comme répertoire initial. Pourquoi ne pas tout simplement pointer un raccourci directement vers STSADM ? Cela ne marche pas puisque STSADM n'est pas interactif. Par conséquent, si vous pointez un raccourci directement vers STSADM, vous obtiendrez un affichage rapide de son utilisation, puis il disparaîtra.
Lors de l'exécution de STSADM, vous devez être membre du groupe Administrateurs sur le serveur Web et vous devez exécuter l'application localement. Cela signifie qu'il n'est pas possible d'utiliser STSADM pour administrer à distance un serveur Sharepoint.
Pour afficher les opérations que vous pouvez effectuer avec STSADM, tapez stsadm.exe -help dans une invite de commande. Vérifiez cette liste après avoir appliqué les mises à jour et les correctifs à Sharepoint puisque de nouvelles opérations peuvent être ajoutées. Vous trouverez également un guide pratique des opérations stsadm.exe à l'adresse go.microsoft.com/fwlink/?LinkId=77516.

Notions fondamentales sur STSADM
Commençons par examiner certaines commandes permettant de modifier votre installation Sharepoint existante. Vous pouvez utiliser STSADM pour ajouter des fonctionnalités à Sharepoint et modifier les paramètres de configuration.
STSADM utilise le paramètre -o suivi de l'opération que vous souhaitez exécuter. Si vous tapez simplement STSADM -operationname, cela ne fonctionnera pas. Si, par exemple, vous souhaitez ajouter des modèles de site à votre installation, utilisez la commande suivante :
Stsadm -o addtemplate -filename <filename of the template>
-title <title of template> -description <description of template>
Ou, pour ajouter un package de composants WebPart utilisez cette commande :
Stsadm -o addwppack -filename <filename of the Web Part Package>
Pour obtenir des informations sur l'utilisation pour une opération, passez simplement l'opération sans aucun paramètre et STSADM vous indiquera l'entrée qu'il attend. STSADM -help operationname vous donnera également des informations sur l'utilisation.
Lors de la gestion des modèles, l'opération enumtemplates permet de voir les modèles ajoutés et deletetemplate de supprimer ceux qui sont installés. De même, il existe des commandes qui fonctionnent avec les packages de composants WebPart. L'opération enumwppacks permet de lister les packages de composants WebPart installés sur chaque serveur virtuel ou application Web, et deletewppack permet de supprimer ceux qui ont été ajoutés.
STSADM comporte également deux opérations qui gèrent les paramètres Sharepoint : setproperty et getproperty. L'exécution de ces opérations sans aucun paramètre vous donnera une liste des propriétés que vous pouvez afficher ou manipuler. À l'instar de STSADM lui-même, cette liste change avec les mises à jour et les correctifs. Cependant, certaines propriétés sont plus utiles que d'autres. La figure 1 répertorie certaines propriétés qui peuvent être définies après l'installation de Sharepoint, notamment les propriétés les plus courantes sur lesquelles les administrateurs Sharepoint demandent des informations.
Figure 1 Définition des propriétés utiles de Sharepoint (Close Figure 1)

Propriété | Fonction
Alerts-enabled | Active ou désactive les alertes pour votre serveur virtuel ou votre application Web.
Alerts-limited | Spécifie si le nombre d'alertes que les utilisateurs peuvent définir sur le serveur virtuel ou l'application Web est limité.
Alerts-maximum | Si des limites d'alertes sont définies, nombre maximal d'alertes qu'un utilisateur peut définir.
Days-to-show-new-icon | Cette propriété définit la durée pendant laquelle l'icône « Nouveau » apparaît en regard des éléments ajoutés au site Web, comme les messages d'annonce, par exemple.
Job-immediate-alerts | Spécifie la fréquence à laquelle Sharepoint recherche des alertes immédiates à envoyer. La valeur par défaut pour Sharepoint 2.0 est de cinq minutes. Vous pouvez ajuster cet intervalle ici. La diminution de la durée augmentera la charge de votre Web et de vos serveurs de base de données. Vous devez dont être vigilant si vous modifiez cette propriété.
Job-daily-alerts | Spécifie l'heure à laquelle les alertes quotidiennes sont envoyées. Les valeurs par défaut pour Sharepoint 2.0 sont comprises « entre 22:00 et 06:00 ». Si certains utilisateurs ne sont pas dans le même fuseau horaire que le serveur, vous pouvez ajuster cette propriété.
Job-weekly-alerts | Vous voyez probablement le modèle qui se profile. Définit la planification des alertes hebdomadaires.
Examinons rapidement l'utilisation d'une de ces propriétés. La commande suivante permettra à Sharepoint d'envoyer des alertes immédiates toutes les 10 minutes :
Stsadm -o setproperty -pn job-immediate-alerts -pv "Every 10 minutes"
Notez que j'ai utilisé -pn et -pv au lieu de -propertyname et -propertyvalue. Ce sont des raccourcis acceptables lorsque vous ne souhaitez pas taper le mot entier. Notez également que tous les exemples et commandes que j'ai présentés dans cette section fonctionneront pour les deux versions 2.0 et 3.0 de Windows SharePoint Services.

Administration quotidienne
L'administration quotidienne de Sharepoint est assez facile. Pour la plupart des administrateurs Sharepoint, l'essentiel des tâches quotidiennes consiste à travailler avec les utilisateurs et les sites. STSADM dispose de plusieurs opérations permettant d'optimiser ces tâches.
Je commencerai par les sites et les Webs. Par souci de cohérence, j'utiliserai « site » pour faire référence aux collections de site et « Web » pour faire référence aux sous-sites (également appelés sous-Webs). La terminologie est parfois compliquée, mais si vous restez cohérent par rapport à celle que STSADM utilise, vous trouverez plus facilement la commande souhaitée.
Si vous exécutez une installation Sharepoint de grande taille, vous passez probablement beaucoup de temps à créer de nouveaux sites pour les utilisateurs. Moi-même, j'effectue souvent ce type de tâche. La création de nouveaux sites est assez facile dans l'Administration centrale de SharePoint. Mais comme j'exécute cette tâche très souvent, je trouve plus rapide d'utiliser STSADM pour faire le travail.
J'utilise l'opération createsite. Elle est relativement simple et a recours aux paramètres suivants :
  • url <url>
  • ownerlogin <DOMAINE\nom>
  • owneremail <personne@exemple.com>
  • ownername <nom d'affichage>
  • lcid <langage>
  • sitetemplate <modèle de site>
  • title <titre du site>
  • description <description du site>
  • quota <modèle de quota>
Vous pouvez afficher ces paramètres à l'invite de commande en tapant stsadm -help createsite (voir Figure 2). De ces neuf paramètres, les seuls champs obligatoires sont URL, ownerlogin et owneremail.
Figure 2 Paramètres Createsite
Figure 2 Paramètres Createsite (Cliquer sur l'image pour la réduire)
Figure 2 Paramètres Createsite
Figure 2 Paramètres Createsite (Cliquer sur l'image pour l'agrandir)
Si vous créez souvent des sites, vous pouvez optimiser le processus en écrivant un script wrapper lié à STSADM pour automatiser la tâche. Par exemple, pour automatiser la création de sites personnels, enregistrez les éléments suivants dans un fichier texte nommé createpersonalsite.cmd :
stsadm -o createsite -url http://localhost/users/%1 -ownerlogin contoso\%1
-owneremail %1@contoso.com -sitetemplate usersite.stp
-title "Personal site for %1" -description "Personal site for %1" -quota "500 MB"
Pour ensuite créer un site pour l'utilisateur jsmith, vous pouvez simplement exécuter le script suivant :
createpersonalsite.cmd jsmith
L'écriture du script de création de site permet de gagner beaucoup de temps de frappe et de vous assurer de la cohérence de tous vos nouveaux sites. L'opération createweb fournit les mêmes fonctionnalités au niveau du Web.
Dans Windows SharePoint Services 2.0, le moyen le plus facile d'obtenir une liste exhaustive des collections de sites sur un serveur virtuel particulier est d'utiliser STSADM. Enumsites répertorie au format XML toutes les collections de sites sur un serveur virtuel ou une application Web spécifiques. Cela peut être associé à un composant WebPart d'affichage des données pour afficher facilement une liste des collections de sites. (Voir l'encadré « Utilisation d'un composant WebPart d'affichage des données » pour plus d'informations).
L'opération deletesite permet, comme vous pouvez le deviner, de supprimer des sites. Il vous suffit de fournir l'URL. Facultativement, vous pouvez passer -deleteadaccounts pour supprimer des comptes dans Active Directory®. Si vous travaillez avec des Webs, vous utiliserez l'opération deleteweb.
Vous pouvez également ajouter, supprimer et énumérer les utilisateurs d'un site ou du Web. Les opérations associées sont adduser, deleteuser et enumusers. Ces opérations sont pratiques si des utilisateurs doivent être ajoutés en masse à un site, ou si vous devez maintenir une liste d'utilisateurs qui ont accès à un site pour des audits.
Si vous travaillez avec des Webs, vous aurez accès à une opération supplémentaire, renameweb, qui permet de modifier le nom et l'URL d'un Web. Par exemple, pour renommer un Web et remplacer « ancien_nom » par « nouveau_nom_cool », utilisez les éléments suivants :
Stsadm -o renameweb -url http://localhost/oldname -newname coolnewname
Cela peut être d'un grand secours lorsque les noms de projet changent ou que les unités sont réorganisées. Dans Windows SharePoint Services 2.0, c'est un problème majeur, dans la mesure où le seul moyen de migrer des Webs, c'est à l'aide de SMIGRATE.exe, qui ne gère aucun paramètre utilisateur, comme l'appartenance ou les alertes. Avec Windows SharePoint Services 3.0, le problème est moindre, puisque STSADM peut sauvegarder et restaurer des Webs et des sites.

Sauvegarde et Restauration
L'une des meilleures utilisations de STSADM, réside dans la sauvegarde et la restauration des sites et des Webs. Des petites aux moyennes installations, ces fonctionnalités peuvent constituer la base d'un plan de récupération après incident. L'opération de sauvegarde est explicite et très facile à utiliser. Il suffit d'indiquer à STSADM le site à sauvegarder et l'emplacement dans lequel enregistrer le fichier de sauvegarde, comme suit :
Stsadm -o backup -url http://localhost -filename site.bak
Cette opération vide toute la collection de sites dans le fichier site.bak. Cela inclut tout le contenu des sites, tels que les Webs, les versions de document, les listes et les utilisateurs. Elle ne sauvegarde pas de définitions de site ou les modifications effectuées au niveau du système de fichiers de vos serveurs.
L'opération de sauvegarde étant importante, il faut être vigilant, car des problèmes peuvent survenir. Si le site est assez grand, la base de données de contenu peut être verrouillée pendant le processus de sauvegarde. Cela peut empêcher les utilisateurs d'accéder aux sites de cette base de données jusqu'à ce que l'opération de sauvegarde soit terminée. Ce problème a été atténué grâce aux service packs, mais il convient néanmoins de rester vigilant lorsque vos sites grandissent. STSADM utilise également le répertoire temp du serveur lors des sauvegardes et des restaurations, donc surveillez votre espace disque.
Utilisation d'un composant WebPart d'affichage des données
Vous pouvez associer la commande enumsites à un composant WebPart d'affichage des données pour afficher facilement une liste de collections de sites. Voyons comment procéder.
Tout d'abord, créez une tâche planifiée qui exécute :
stsadm –o enumsites –url http://localhost
>c:\inetpub\wwwroot\excludedsite\sites.xml
Assurez-vous que le fichier XML est enregistré dans un répertoire publié avec IIS, mais non géré par Sharepoint. Utilisez ensuite Microsoft FrontPage® (ou le successeur de Frontpage, Microsoft Office SharePoint Designer 2007) pour ajouter un composant WebPart d'affichage des données à une page de composants WebPart, que vous pointerez-le vers l'URL du fichier XML.
Le composant WebPart d'affichage des données fournit des fonctionnalités comme le tri, le filtrage et le regroupement. Vous pouvez aussi faire du champ de l'URL un lien direct vers le site. Si vous préférez une liste de Webs, l'opération enumsubwebs fournit une sortie XML des sous-Webs dans une collection de sites ou un Web.

Enfin, n'oubliez pas que si les sauvegardes STSADM fonctionnent bien pour les petits et moyens sites, les fonctionnalités ne sont pas particulièrement évolutives. Pour les sites de très grande taille (plusieurs gigaoctets ou plus), les processus de sauvegarde et de restauration peuvent ralentir de façon considérable.
La restauration d'un site est tout aussi simple. STSADM -o restore récupère un fichier créé par STSADM -o backup et l'enregistre sur un site dans Sharepoint. Cette commande est très souple : vous pouvez restaurer un site à son emplacement original (si, par exemple, le site a été supprimé à tort), le restaurer comme un site différent sur le même serveur virtuel (peut-être si vous souhaitez tester un processus sur un site sans courir le risque de détruire des données) ou le restaurer sur un tout autre serveur ou sur un serveur virtuel.
La restauration sur un autre site ou serveur facilite la récupération de documents individuels. Si un utilisateur veut restaurer un document sur un site sauvegardé, il n'est pas nécessaire de restaurer tout le site. Une restauration complète sacrifierait toutes les modifications apportées à ce site puisque la sauvegarde a été stockée. Au lieu de cela, il suffit de restaurer le site vers une URL différente, de récupérer les documents et de les enregistrer sur le site original.
Dans Windows SharePoint Services 2.0, STSADM comporte une limitation assez sérieuse. Lors de la sauvegarde, il ne peut traiter que des sites, pas des Webs. Les administrateurs ont manifesté leur mécontentement et Microsoft a réagi. Dans Windows SharePoint Services 3.0, les opérations de sauvegarde et de restauration peuvent désormais gérer les Webs. Deux nouvelles commandes sont également ajoutées : importer et exporter.
Pour exporter un Web, utilisez la commande simple suivante :
Stsadm -o export -url http://localhost/web -filename backup.dat
La fonctionnalité d'exportation propose des options pratiques, notamment -versions switch. Cette option permet de déterminer la taille de vos fichiers de sauvegarde en limitant les versions de fichier qui seront sauvegardées.
Pour importer un Web sur un serveur, utilisez la commande suivante :
Stsadm -o import -url http://localhost/web2 -filename backup.dat
Si votre site est suffisamment grand, le fichier de sauvegarde peut être décomposé en plusieurs fichiers.. Dans ce cas, pointez STSADM -o import vers le premier fichier et il récupérera automatiquement les fichiers suivants.

Opérations spécialisées
Maintenant que vous êtes à l'aise avec STSADM, je vais vous présenter quelques opérations que vous pouvez utiliser pour résoudre un problème. La première opération est toute nouvelle et s'appelle migrateuser. La version 2.0 ne se synchronise pas avec Active Directory. Si un compte est renommé, il ne peut plus se connecter à Sharepoint. Par le passé, il était impossible de migrer l'accès utilisateur d'un utilisateur de domaine à un autre. Avant Windows SharePoint Services 2.0 Service Pack 2 (SP2), il fallait supprimer l'utilisateur de chaque Web et ajouter manuellement le nouveau compte.
SP2 a introduit une nouvelle API et STSADM en tire parti. Si le compte jsmith est renommé jjones, utilisez la commande suivante :
Stsadm -o migrateuser -oldlogin domain\jsmith -newlogin domain\jjones -ignoresidhistory
Puisqu'en réalité vous ne migrez pas de comptes, vous pouvez ignorer l'historique de l'identificateur de sécurité Windows (SID). Notez que cette commande ne nécessite pas d'URL. Elle effectue la modification dans toutes les bases de données de contenu indépendamment des sites ou des Webs.
unextendvs est une autre opération susceptible de vous sortir d'une ornière. Si vous ne souhaitez pas que Sharepoint affiche un serveur virtuel ou une application Web, vous devez annuler leur extension. Normalement, cette action s'effectue à partir de l'Analyseur de configuration Sharepoint. Cependant, dans un groupe de serveurs Web, l'Analyseur de configuration Sharepoint nécessite que vos serveurs soient tous au même niveau de correctif. Il est possible qu'un serveur soit désynchronisé du reste du groupe, par conséquent, l'option unextend n'apparaîtra pas dans l'Analyseur. Toutefois, si vous utilisez STSADM, la commande suivante annulera l'extension de votre serveur virtuel :
Stsadm -o unextendvs -url http://localhost
Une fois le serveur sorti du groupe de serveurs Web, vous pouvez effectuer la maintenance nécessaire.
Pour faciliter l'administration du groupe de serveurs Web, l'Analyseur de Configuration Sharepoint peut être installé sur le même port pour tous vos serveurs. Le port est généré de façon aléatoire lors de l'installation de Sharepoint, mais STSADM inclut une opération pour remplacer le port par un autre que vous spécifiez :
Stsadm -o setadminport -port 1026
Cette opération effectue toutes les modifications de la base de données nécessaires, effectue les modifications IIS et ajuste le raccourci vers l'Analyseur de Configuration Sharepoint dans les Outils d'administration.

Conclusion
Windows SharePoint Services est une solution extrêmement puissante qui nécessite par conséquent une administration ultraperformante. STSADM permet d'effectuer l'administration de Sharepoint, notamment l'automatisation de la configuration et les tâches quotidiennes courantes. En effet, c'est parfois le seul moyen de faire le travail.

Todd Klindt est analyste systèmes chez UGS, où il passe ses journées à s'amuser avec Sharepoint, et est payé pour cela. Il est également MVP sur Windows SharePoint Services et est natif du signe du Verseau


 SharePoint: Travailler en Wiki
SharePoint Mauro Cardarelli

Travailler en Wiki
Vue d'ensemble:
  • Qu'est-ce qu'un wiki ?
  • Création d'un wiki dans SharePoint
  • Modification et suivi des modifications

Le concept de wiki existe depuis plus de 10 ans. Dans sa forme la plus simple, un wiki (terme hawaïen signifiant « rapide ») est un site en ligne où les utilisateurs peuvent créer ou modifier librement le contenu des pages Web
en utilisant uniquement un navigateur. Il s'agit d'offrir un espace où les membres d'une communauté virtuelle peuvent modifier n'importe quelle page en toute liberté pour introduire, modifier ou supprimer des contenus, y compris ceux créés par d'autres auteurs. Contrairement aux blogs, qui sont conçus pour un échange de connaissances plus structuré et une communication unilatérale, les wikis favorisent la collaboration.
La nouvelle génération d'outils en ligne, surnommée le Web 2.0, a récemment fait l'objet d'une grande attention. Le principe consiste à abaisser les barrières entourant la création de contenus, ce qui permet aux utilisateurs d'être à la fois producteurs et consommateurs d'informations en ligne. Ce phénomène ne se produit pas uniquement dans l'univers d'Internet mais également derrière les pare-feu d'entreprise. Voyez ça comme l'Entreprise 2.0 : des outils qui facilitent la création de contenus pour tous les employés. Les technologies telles que les blogs et les wikis modifieront fortement la façon dont les entreprises considèrent, stockent et recyclent leurs connaissances.
Microsoft facilite cette capacité de nouvelle génération en introduisant Microsoft® Office SharePoint® Server (MOSS) 2007, la troisième version de la célèbre technologie SharePoint. MOSS 2007 propose des fonctionnalités de collaboration et de communication étendues, notamment la prise en charge de la création de blogs et de wikis. Cet article explique comment créer des wikis grâce à MOSS 2007.

Mise en route
Si vous avez déjà utilisé SharePoint Portal Server 2003, vous devriez savoir vous servir des modèles de sites. Les modèles de sites fournissent un environnement pour la présentation d'un type de page particulier (une équipe, une rencontre ou un événement social, par exemple) qui prédéfinit des emplacements réservés à des contenus spécifiques. MOSS 2007 étend l'utilisation des modèles de sites en introduisant un nouvel ensemble de types de modèles. L'un de ces types permet de créer un wiki.
La figure 1 illustre la page du nouveau site SharePoint utilisée pour créer un site SharePoint. Notez que la liste des modèles comporte un élément destiné au site wiki. En sélectionnant ce modèle, vous pouvez créer votre premier wiki rapidement et facilement. Examinez la Figure 2, qui reproduit l'affichage par défaut du wiki qui vient d'être créé. La structure d'un wiki est telle que cette page par défaut constitue la page d'accueil de votre wiki. Tous les éléments de cette page peuvent être modifiés. Les utilisateurs dûment autorisés (votre communauté virtuelle) peuvent modifier cette page ou créer de nouvelles pages.
Figure 1 Sélection du modèle de wiki pour un nouveau site
Figure 1 Sélection du modèle de wiki pour un nouveau site
Figure 2 Votre nouveau wiki SharePoint, en attente de modification
Figure 2 Votre nouveau wiki SharePoint, en attente de modification (Cliquer sur l'image pour la réduire)
Figure 2 Votre nouveau wiki SharePoint, en attente de modification
Figure 2 Votre nouveau wiki SharePoint, en attente de modification (Cliquer sur l'image pour l'agrandir)
Avant de poursuivre, revenons en arrière pour aborder l'introduction des wikis à vos utilisateurs. Comme indiqué précédemment, les wikis sont depuis longtemps présents sur Internet ou disponibles via des outils tiers. Toutefois, pour l'essentiel, l'usage des wikis est resté extrêmement spécialisé et s'est développé lentement, par le bouche à oreille. MOSS 2007 est sur le point de révolutionner cet usage en proposant la fonctionnalité wiki à tous les utilisateurs d'intranet. Voilà une proposition très puissante (et potentiellement effrayante) ! Comment expliquer la valeur d'un wiki à des collègues n'ayant aucune compétence technique et n'ayant qu'une connaissance limitée d'Internet ? Vous devez leur dire que les wikis servent à encourager des échanges d'opinions et d'idées créatifs dans un environnement suffisamment libre pour offrir une voix à tous les utilisateurs. Ils favorisent la rédaction collaborative des contenus, mais ils ne s'arrêtent pas là. Le résultat final d'un wiki n'est pas un document ou un chapitre, mais plutôt un livre, un livre qui peut ne jamais se terminer et que vous pouvez modifier en fonction des besoins.
OK, reprenons le travail. Si vous utilisez des wikis pour la première fois, une aide en ligne est disponible à partir de l'hyperlien Comment utiliser ce site wiki. Le modèle de wiki par défaut est fourni avec une documentation suffisante pour mettre les nouveaux utilisateurs à l'aise et leur permettre de contribuer rapidement.

Fonctionnement des wikis
Sur chaque page wiki, vous remarquerez des boutons d'action dans le coin supérieur droit. Si vous cliquez sur le bouton intitulé Modifier, vous serez redirigé vers la page associée à la modification de contenu. La figure 3 en offre un exemple. Toutes les modifications sont apportées via le navigateur ; aucun outil externe tel que Microsoft Word n'est nécessaire. Les modifications se font en ligne et en temps réel (une fois enregistrées). Par ailleurs, aucune compétence en matière de conception ou développement Web n'est requise. L'interface de modification permet la création de documents au format RTF intégral (gras, couleurs, puces ou images), le tout avec des boutons standard. Il suffit à l'utilisateur d'ouvrir une page existante dans le mode de modification et d'ajouter ou de modifier le contenu. C'est aussi simple que cela.
Figure 3 Modification intégrale de contenu wiki dans le navigateur
Figure 3 Modification intégrale de contenu wiki dans le navigateur (Cliquer sur l'image pour la réduire)
Figure 3 Modification intégrale de contenu wiki dans le navigateur
Figure 3 Modification intégrale de contenu wiki dans le navigateur (Cliquer sur l'image pour l'agrandir)
Dans un environnement où les contenus ne cessent d'évoluer, comment gérez-vous les modifications ? Vous ne souhaitez pas forcément surveiller toutes les contributions, mais vous voulez probablement disposer de moyens de suivre les modifications et de gérer l'historique des versions. MOSS 2007 vous le permet. La figure 4 reproduit l'apparence d'une page standard lorsque vous cliquez sur le bouton Historique. Au centre, vous remarquerez que toutes les modifications apportées au texte ont été suivies. Sur la gauche, vous pouvez voir l'historique des modifications, avec un suivi de chaque modification. La communauté peut librement consulter, suivre, voire annuler les modifications. Il s'agit là d'un concept puissant. Lorsque vous créez et modifiez votre wiki, MOSS 2007 enregistre tous vos mouvements.
Figure 4 Suivi progressif des modifications d'une entrée wiki
Figure 4 Suivi progressif des modifications d'une entrée wiki (Cliquer sur l'image pour la réduire)
Figure 4 Suivi progressif des modifications d'une entrée wiki
Figure 4 Suivi progressif des modifications d'une entrée wiki (Cliquer sur l'image pour l'agrandir)
Comme indiqué, un wiki n'est pas une page Web. C'est un ensemble de pages illimité. En tant que membre d'une communauté wiki, vous pouvez décider d'introduire une nouvelle idée ou un nouveau sujet de discussion. Plutôt que d'ajouter du texte à une page existante, vous pouvez bifurquer sur une nouvelle page. MOSS 2007 prend cette option en charge en permettant un ajout aisé de pages wiki. Il vous suffit de cliquer sur Nouvelle pour tourner une nouvelle page wiki. Commencez à ajouter du contenu et c'est parti !

Conclusion
MOSS 2007 n'a pas introduit le concept de wiki mais, étant donné sa large disponibilité, il les rend beaucoup plus attrayants. Les wikis peuvent transformer la façon dont les employés collaborent : ils ne sont plus restreints par les limites d'un document. Les wikis favorisent une pensée déstructurée et une collaboration élargie, ce qui s'intègre bien dans les concepts plus vastes associés à la philosophie de l'Entreprise 2.0. Les wikis sont des outils ; ils permettent à tous les utilisateurs de participer, pas seulement pour suivre mais aussi pour orienter les débats vers de nouvelles directions.

Mauro Cardarelli est associé directeur chez Jornata, une société de services de conseils en informatique établie à Boston. Il est notamment responsable de la promotion des technologies, de la conception d'architecture et du développement de logiciel. Vous pouvez le contacter à l'adresse suivante : mauro.cardarelli@jornata.com.


 De la part de l'&#233;diteur: Il arrive que certains secteurs industriels
De la part de l'éditeur

Il arrive que certains secteurs industriels doivent faire face à des changements radicaux, qu'il s'agisse des technologies, mais aussi des stratégies, des tendances ou de tout autre domaine. C'est ce qui a occupé mes pensées il y a quelques semaines lors de mon discours à la conférence Windows Connection à Las Vegas. Il y a cinq ans, en novembre, je me serais rendu au Comdex, cette énorme manifestation destinée à tous les segments possibles de l'achat et de l'apprentissage des technologies dans le monde. Mais alors qu'elle n'avait cessé de prendre de l'ampleur pendant près de deux décennies, elle a presque disparu du jour au lendemain. De ce fait, plutôt que d'aller assister à une énorme manifestation destinée à une audience tous azimuts, je me suis exprimé lors d'un salon réussi et ciblé, axé sur un nombre restreint de produits informatiques et de développement. Je me suis adressé aux mêmes personnes et au même endroit, mais à une échelle beaucoup plus gratifiante pour l'ensemble des participants.
Le sujet abordé avait trait à la rédaction technique ; la méthode, les applications et les raisons. Les changements survenus dans notre secteur industriel se reflètent non seulement dans l'historique de Comdex, mais également dans le monde des communications techniques. Il y a cinq ans, j'ai dirigé une séance identique, mais il s'agissait alors essentiellement de magazines. A cette époque, peu de gens avaient déjà entendu parler des blogues. Les sites des communautés étaient alors l'ombre de ce qu'ils sont aujourd'hui. Ces cinq dernières années, nous avons observé une évolution permanente dans la manière dont l'écrit est transmis, à une échelle jamais vue auparavant.
Cela comporte foule d'avantages, mais aussi d'inconvénients, bien évidemment. Différentes formes de communication répondent à des objectifs différents. Sur un blogue, les personnes peuvent mettrent leurs pensées en ligne de manière spontanée, alors que dans un magazine, une édition et un examen technique du contenu sont généralement effectués. Vous pouvez gérer le contenu d'un billet diffusé sur un blogue, mais il vous est impossible de vous rendre dans chaque maison pour déchirer un paragraphe dans une page de magazine.
Quoiqu'il en soit, si j'aborde tous ces changements, c'est pour une bonne raison. Pour répondre aux nombreux commentaires des lecteurs sur le magazine, nous avons décidé d'étendre nos rubriques. Dans ce numéro, nous vous présentons la première version imprimée de The Cable Guy, une célèbre rubrique de TechNet auparavant diffusée uniquement en ligne. Nous sommes également à l'écoute de tous les postmasters et sommes conscients que Exchange Server 2007 sera un sujet épineux ; c'est la raison pour laquelle nous lançons Exchange Queue & A en tant que rubrique à part entière.
Si vous souhaitez qu'une technologie Microsoft figure dans le magazine, adressez-nous un commentaire en ce sens. La meilleure façon de vous servir est de vous offrir ce que vous demandez. £Joshua Trupin

Remerciements aux experts techniques Microsoft suivants : Puneet Arora, Jeff Bienvenu, Nino Bilic, Eric Broberg, Ramesh Chinta, Matt Cohen, Michael Dalton, George Irimescu, Bryan Jeffries, Dave Kong, Vijay Krishna, Rob Lefferts, Lawrence Liu, Bob Ma, Manu Namboodiri, Joel Oleson, Arpan Shah, Troy Starr, James Sturms, Jim Truher et Blaine Young.


 Toolbox: De nouveaux produits pour les professionnels de l'informatique
Toolbox
De nouveaux produits pour les professionnels de l'informatique
Greg Steen

Administration de serveurs
Windows Server 2003 Resource Kit Tools
go.microsoft.com/fwlink/?LinkId=77796
Les Windows Server 2003 Resource Kit Tools forment un ensemble de plus de 100 utilitaires extrêmement utiles vous permettant de rationnaliser et d'automatiser vos tâches administratives. Le kit comprend tout ce dont vous pouvez avoir besoin, des outils Active Directory® aux utilitaires de dépannage réseau en passant par les graveurs d'image de CD/DVD.
L'outil Custom Reason Editor (custreasonedit.exe) est un outil formidable vous permettant d'organiser votre Moniteur d'événements de mise hors tension. Composant de Windows Server® 2003, il consigne les causes des arrêts système dans le journal d'événements. En outre, l'outil Custom Reason Editor vous permet de créer une liste personnalisée de paramètres configurables qui remplaceront les causes incorporées et activées par défaut. Cet outil peut faciliter le regroupement et l'identification de processus, d'applications ou d'états posant problème et qui entraînent un arrêt du système, en assurant la logique et l'organisation des événements individuels.
L'outil DNS Resolver Tool, un utilitaire de ligne de commande qui simule l'exécution du service SMTP de résolution de DNS, affiche des messages relatifs à l'état de la requête DNS spécifiée comme paramètre de commande. Cet utilitaire s'exécute sur n'importe quel hôte Windows Server 2003 doté du service SMTP et renvoie des codes d'erreur que vous pouvez utiliser dans les fichiers batch. CDBurn.exe et DVDburn.exe sont des utilitaires de ligne de commande qui vous permettent de créer des CD et des DVD à partir d'images ISO et offrent une prise en charge limitée de supports réinscriptibles grâce au commutateur /Erase, qui nettoie le support avant d'appliquer la nouvelle image disque. Ils peuvent être utilisés, par exemple, pour automatiser des processus d'archivage dans votre infrastructure.
Windows Server 2003 Resource Kit
Windows Server 2003 Resource Kit (Cliquer sur l'image pour la réduire)
Windows Server 2003 Resource Kit
Windows Server 2003 Resource Kit (Cliquer sur l'image pour l'agrandir)
Si vous devez vérifier si un compte a été verrouillé avec succès, l'outil Account Lockout Status rend cette tâche à la fois simple et rapide grâce à une option de ligne de commande et de l'interface graphique. L'outil interroge chaque contrôleur de domaine accessible et vérifie l'état du compte utilisateur cible. Peut-être l'un des meilleurs outils d'automatisation, Robust File Copy Utility (Robocopy.exe) vous offre différentes options pour déplacer ou copier des fichiers. Cet outil vous permet d'utiliser des caractères génériques, et même des attributs de fichiers, pour spécifier les candidats à la copie, qui elle-même peut être définie de manière à être récursive. Vous pouvez utiliser cet outil pour la synchronisation et le configurer pour supprimer les fichiers ou répertoires de destination qui ont été supprimés du répertoire source.
Un autre de mes utilitaires préférés est l'outil Tail (tail.exe) qui, comme l'utilitaire de Linux/Unix, vous permet d'afficher le dernier nombre N de lignes d'un fichier, ce qui actualise l'affichage lors de l'ajout de nouvelles lignes. Cette option est très utile pour déboguer ou contrôler n'importe quelle tâche qui écrit dans un fichier journal.
Time It (timeit.exe) vous permet de chronométrer des commandes et enregistre les données dans son propre fichier de base de données, ce qui vous permet de tester la durée réelle de vos tâches administratives.
Notez que ces outils n'ont pas été localisés, car ils ont été écrits et testés en anglais uniquement et peuvent « produire des résultats imprévisibles » quand vous les exécutez. N'oubliez pas de les tester sur vos systèmes dont la langue est autre que l'anglais avant de les utiliser dans un environnement de production.
Prix : Téléchargement gratuit.

Suivi des problèmes
ASP.NET Issue Tracker
www.ASP.NET/StarterKits/WhitePapers/Issue%20Tracker%20Whitepaper.htm
Il y a deux choses qui, à mon avis, donnent toujours plus de valeur à une application : la gratuité et la personnalisabilité. L'outil ASP.NET Issue Tracker, fourni par la communauté de développeurs en ligne ASP.NET, remplit ces deux critères. Conçu comme un Kit de démarrage permettant d'apprendre à programmer des applications Web sous l'infrastructure ASP.NET 1.1 , ASP.NET Issue Tracker est un outil simple mais utile pour suivre les problèmes liés aux projets.
L'interface sans fioritures vous permet de créer facilement des projets, des utilisateurs et des problèmes. L'application prend en charge plusieurs utilisateurs avec des autorisations basées sur des rôles, protégeant ainsi les données des regards indiscrets. Vous pouvez également créer des catégories de problèmes personnalisées pour chaque projet et des champ de données personnalisés de différents types. Vous pouvez attribuer aux tâches un état, une priorité et des étapes intermédiaires, ce qui vous permet d'organiser vos projets.
Une autre fonctionnalité appréciable réside dans le fait que, lors de la création des projets, vous pouvez spécifier vos propres codes d'état, priorités et étapes intermédiaires pour chaque projet, et définir une image pour le représenter. Tout le code est disponible dans le fichier de téléchargement, donc, si vous connaissez un développeur .NET ou si vous pouvez vous débrouiller avec le code existant, vous pouvez utiliser le kit de démarrage comme base pour les fonctionnalités personnalisées dont vous avez besoin.
Prix : gratuit.

Surveillance des systèmes
NetHealth Sentinel Professional
www.nethealthsys.com
La surveillance du réseau et des systèmes est essentielle, et je suis toujours en quête d'applications qui me permettront d'observer l'état de mes machines à distance. C'est ce que fait NetHealth Sentinel Professional, de NetHealth Systems.
Une solution basée sur des agents, Sentinel Professional fournit des informations détaillées sur les ordinateurs hôtes contrôlés. L'application est divisée en quatre composants : Admin Server, Admin Console, Connection Manager et Remote Agent. Admin Server exécute des tâches planifiées, enregistre les informations de configuration et collecte les alertes à l'aide de Connection Manager.
Admin Console est l'interface graphique d'Admin Server et vous permet d'afficher et de configurer vos systèmes contrôlés, ainsi que de configurer des tâches ou des événements planifiés. Connection Manager rassemble toutes les données des agents distants (les agents d'hôte qui résident sur votre système contrôlé). Remote Agent fonctionne comme un service Windows et communique avec Connection Manager via une connexion sécurisée. Chaque agent distant peut être configuré pour envoyer des alertes à un ou des gestionnaires de connexion.
NetHealth Sentinel Professional
NetHealth Sentinel Professional (Cliquer sur l'image pour la réduire)
NetHealth Sentinel Professional
NetHealth Sentinel Professional (Cliquer sur l'image pour l'agrandir)
Une fonctionnalité intéressante réside dans le regroupement des événements de tous les ordinateurs dans un groupe de surveillance spécifié. L'interface utilisateur simple vous permet également de faire glisser et de déplacer des colonnes de données de la vue Événements pour les grouper par élément.
L'application propose également le volet Vital Signs, un aperçu général rapide des statistiques que vous souhaitez contrôler. Par défaut, vous pouvez consulter l'utilisation du processeur, du disque et de la mémoire, mais vous pouvez ajouter les compteurs de votre choix à l'aide de l'onglet Monitor.
NetHealth Sentinel Professional inclut également une fonctionnalité de configuration de base qui vous permet de déterminer des niveaux pour un fonctionnement « normal » de l'ordinateur, puis déclenche des alertes si le fonctionnement dépasse l'une des valeurs de base établies.
Prix : 495 £ pour un pack de 10 licences d'accès client.

Chiffement de données
TrueCrypt
www.truecrypt.org
TrueCrypt, de TrueCrypt Foundation, est un outil de chiffrement gratuit Open Source fonctionnant « à la volée » qui, avec le mot de passe ou la clé de chiffrement correct, déchiffre l'information que vous essayez de lire ou chiffre les données que vous essayez d'inscrire en mémoire, depuis et vers vos volumes chiffrés. Mais ne vous inquiétez pas : votre volume est en permanence protégé par le chiffrement. Ce n'est que si la mémoire se vide pendant que l'application déchiffre des données en mémoire qu'un agresseur peut trouver les informations que vous essayez de protéger. Ce problème peut facilement être évité en désactivant les vidages de mémoire sur votre système, sans compter que seule une petite portion de vos données est déchiffrée dans la mémoire à tout moment donné.
L'application prend en charge des volumes virtuels et des partitions ou des périphériques physiques. Les volumes virtuels, nommés « conteneurs de fichiers » par les auteurs, peuvent être créés avec n'importe quelle extension de fichier ou ne pas avoir d'extension du tout, de sorte que pour des espions, vos données sensibles sembleront composées de données aléatoires. En effet, il n'existe pas de « signature de fichier » TrueCrypt.
TrueCrypt
TrueCrypt (Cliquer sur l'image pour la réduire)
TrueCrypt
TrueCrypt (Cliquer sur l'image pour l'agrandir)
De plus, vous pouvez exécuter TrueCrypt en « mode mobile », ce qui signifie essentiellement que vous pouvez créer un conteneur de fichiers sur une clé USB avec les fichiers d'application correspondants et transporter vos données chiffrées avec vous sans devoir installer TrueCrypt sur le système hôte. Mais, de par la nature de la lecture/l'écriture via la mémoire, vous aurez besoin de privilèges d'administrateur sur le système où vous voulez utiliser votre disque amovible.
TrueCrypt possède un assistant très simple vous permettant également de configurer votre disque amovible. Il s'agit d'un formidable moyen de transporter vos informations d'administration système sans (trop) vous inquiéter de voir vos données d'entreprise sensibles espionnées.
Pour un niveau de sécurité supplémentaire, TrueCrypt vous permet également de créer un volume masqué dans un conteneur de fichiers, donc même si un intrus accède au volume extérieur, il ne pourra pas découvrir que le disque comporte un volume intérieur masqué. Chaque volume est initialisé avec des données aléatoires, ce qui fait du volume masqué résidant dans le volume extérieur un « espace libre » très difficile à détecter.
TrueCrypt peut utiliser AES, Blowfish, CAST5, Serpent, Triple DES, Twofish et plusieurs combinaisons de ces algorithmes pour chiffrer vos données. L'application utilise le mode LRW pour le chiffrement, qui va devenir une norme IEEE pour le chiffrement de volumes de stockage basé sur des secteurs. Pour l'algorithme de hachage d'en-tête, vous pouvez choisir d'utiliser Whirlpool, SHA-1 ou RIPEME-160, et l'application n'enregistrera pas de hachage, offrant ainsi une couche de protection supplémentaire pour votre système. L'application prend en charge les systèmes de fichiers FAT12, FAT16, FAT32 et NTFS, mais comme pour les autres utilitaires de chiffrement basé sur des secteurs Windows déjà publiés, il ne vous permet pas de chiffrer une partition de démarrage de Windows.
Prix : gratuit.

Critique
Hacking Web Services
www.charlesriver.com
Le livre Hacking Web Services (Piratage de services Web) de Shreeraj shah (Charles River Media, 2006) est une ressource intéressante pour les personnes en charge du développement, du déploiement ou du support de services Web. Ce livre est une référence générale de sécurité claire sur les services Web et la technologie de leurs composants. Il détaille bien les implications de leur protection au sein de votre infrastructure et de vos pratiques de développement.
Le livre commence sur une présentation assez détaillée des services Web. Une étude de cas intitulée « The Consequences of Procrastination » (Conséquences des atermoiements) vous enseigne les avantages des procédures de sécurité préventives et les problèmes des systèmes réactifs. Le chapitre intitulé « Web Services Scanning and Enumeration » (Énumération et analyse des services Web) indique comment utiliser wsChess, un ensemble d'outils de sécurité de services Web de base .NET édité par Net-Square (net-square.com/wschess/index.shtml) pour définir le profil et l'encombrement des services Web.
Le livre inclut un CD d'utilitaires, contenant une application .NET de démonstration appelée SOAPWall. Celle-ci décrit comment bloquer les caractères d'injection et les saturations de la mémoire tampon dans vos services Web .NET. De plus, ce CD propose des démonstrations de différents types d'attaques de services Web.
Prix : $49.95.
Le livre Hacking Web Services (Piratage de services Web) de Shreeraj shah (Charles River Media, 2006) est une ressource intéressante pour les personnes en charge du développement, du déploiement ou du support de services Web. Ce livre est une référence générale de sécurité claire sur les services Web et la technologie de leurs composants. Il détaille bien les implications de leur protection au sein de votre infrastructure et de vos pratiques de développement.
Le livre commence sur une présentation assez détaillée des services Web. Une étude de cas intitulée « The Consequences of Procrastination » (Conséquences des atermoiements) vous enseigne les avantages des procédures de sécurité préventives et les problèmes des systèmes réactifs. Le chapitre intitulé « Web Services Scanning and Enumeration » (Énumération et analyse des services Web) indique comment utiliser wsChess, un ensemble d'outils de sécurité de services Web de base .NET édité par Net-Square (net-square.com/wschess/index.shtml) pour définir le profil et l'encombrement des services Web.
Le livre inclut un CD d'utilitaires, contenant une application .NET de démonstration appelée SOAPWall. Celle-ci décrit comment bloquer les caractères d'injection et les saturations de la mémoire tampon dans vos services Web .NET. De plus, ce CD propose des démonstrations de différents types d'attaques de services Web.
Prix : $49.95.

Écrire à Toolbox
Si vous souhaitez voir votre outil ou utilitaire préféré figurer dans l'un de nos articles, veuillez écrire à l'auteur à l'adresse tntools@microsoft.com.

Les opinions exprimées dans cet article ne sont que celles de l'auteur et ne reflètent pas nécessairement les opinions de Microsoft. Tous les prix ont été vérifiés au moment de la publication et sont suspectibles de modifications.

Greg Steen est un professionnel de l'informatique, dynamique et enthousiaste. Il est constamment à la recherche de méthodes et d'outils innovants destinés à faciliter les opérations et le développement pour les professionnels de l'informatique.


 Pr&#233;sentation d'utilitaire: Kit d'administration d'Internet Explorer
Présentation d'utilitaire
Kit d'administration d'Internet Explorer
Lance Whitney
Télécharger le code de cet article: Présentation d'utilitaire : Kit d'administration d'Internet Explorer 7 (KB)

Votre directeur informatique vous a demandé d'installer la dernière version d'Internet Explorer 7 dans l'ensemble de votre organisation. Le délai est serré, le budget aussi et les exigences sont nombreuses. Vous avez besoin d'un module personnalisé qui appliquera les mêmes fonctionnalités et paramètres à tous vos utilisateurs. Vous devez également pouvoir modifier ces paramètres au besoin.
De plus, vous devez verrouiller Internet Explorer® afin que les utilisateurs ne puissent pas modifier les paramètres. Comment pouvez-vous créer et offrir ce type d'installation d'Internet Explorer rapidement et facilement ?
Microsoft vient à votre secours avec le kit d'administration d'Internet Explorer, surnommé IEAK. Cet outil de configuration gratuit a été créé pour aider les administrateurs et développeurs informatiques, les fournisseurs de services Internet et autres à créer des modules d'installation personnalisés pour Internet Explorer. En fait, Yahoo! a employé la version bêta d'IEAK 7 pour créer un module Internet Explorer 7 personnalisé à télécharger depuis le site Web Yahoo!
La version d'Internet Explorer 7 que vous créez avec IEAK doit inclure uniquement les fonctionnalités et les options que vous spécifiez. Vous pouvez activer des paramètres de sécurité spécifiques et verrouiller les contrôles auxquels vous ne souhaitez pas que vos utilisateurs aient accès.
Une fois Internet Explorer déployé, ceux qui parmi vous disposent d'Active Directory® peuvent, bien sûr, utiliser la stratégie de groupe pour contrôler et mettre à jour les paramètres du navigateur. Si vous le souhaitez, vous pouvez utiliser IEAK pour gérer les divers groupes de paramètres d'Internet Explorer.
IEAK 7 est convivial, plus encore que les versions précédentes, et offre une interface graphique simple pour créer votre module Internet Explorer. Des écrans détaillés vous guident lorsque vous sélectionnez les fonctionnalités et les options à intégrer dans votre version.
La nouvelle version d'IEAK présente quelques modifications par rapport aux versions préalables, avec quelques options supplémentaires et quelques-unes supprimées. Vous pouvez maintenant ajouter des flux Web RSS par défaut à votre version d'Internet Explorer, pointer vers plus d'une page d'accueil et page de recherche et ajouter la prise en charge d'un filtre anti-hameçonnage. Vous pouvez également configurer l'exécution et la mise à jour de l'outil de suppression des logiciels malveillants de Microsoft® Windows®. Cependant, vous ne pouvez plus personnaliser Outlook® Express et Windows Media® Player avec IEAK car ces applications ne sont pas incluses avec Internet Explorer 7.
Vous pouvez créer un module Internet Explorer pour des plates-formes de 32 bits ou 64 bits (Windows XP avec Service Pack 2 (SP2), Windows Server® 2003 avec SP1 ou Windows Vista™ x86, x64 ou Itanium). Avant d'exécuter IEAK 7, vous devez vous assurer qu'Internet Explorer 7 est installé sur le PC que vous utilisez pour créer votre module. Pour assurer la compatibilité, vous devez exécuter IEAK sur un ordinateur équipé du même système d'exploitation que les ordinateurs sur lesquels vous appliquerez la version d'Internet Explorer.
Je vais expliquer dans cette rubrique comment utiliser IEAK pour créer votre version d'installation d'Internet Explorer 7 et gérer ou mettre à jour les paramètres de votre navigateur.

Comment obtenir IEAK 7
Vous pouvez télécharger gratuitement la dernière version d'IEAK 7 sur le site microsoft.com/technet/prodtechnol/ie/ieak7. De plus, cette page fournit de la documentation et des notes de mise à jour sur IEAK, qui peuvent être utiles.
Lorsque vous installez IEAK 7 par le biais du fichier ieak.msi téléchargé, vous devez choisir le type de licence à utiliser en fonction de votre rôle (fournisseur de services Internet, fournisseur ou développeur de contenu) ou vous servir d'un Intranet d'entreprise. Les écrans qui s'affichent et le type de module créé varient en fonction du rôle choisi. Ainsi, si vous créez la version pour un environnement d'entreprise, prenez soin de sélectionner le rôle et la licence pour un Intranet d'entreprise. Une fois IEAK installé, un nouveau groupe de programmes appelé Microsoft IEAK 7 est créé dans votre menu Démarrer. Celui-ci contient trois articles : Aide IEAK, Gestionnaire de Profils IEAK et Assistant de personnalisation Internet Explorer.
Vous utiliserez l'Assistant de personnalisation d'Internet Explorer pour créer votre module d'installation. L'utilisation de cet assistant est assez simple car chaque écran vous guide tout au long du processus de conception de votre module. Alors, où est la difficulté ? Eh bien pour savoir comment configurer chaque option, il est nécessaire de bien comprendre les fonctionnalités et les contrôles dans Internet Explorer. Heureusement, IEAK 7 peut vous aider ici aussi. L'aide incorporée dans l'outil est plus détaillée et descriptive que dans les versions précédentes. Un bouton d'aide apparaît sur chaque écran de l'Assistant de personnalisation pour expliquer les paramètres et options de l'écran en question. Vous pouvez accéder à l'ensemble du fichier d'aide IEAK à partir du raccourci de l'Aide IEAK ou par le fichier IEAKHelp.chm dans C:\Program Files\Microsoft IEAK 7. Je vous recommande de lire la documentation avant de créer votre version pour comprendre chaque composant et prévoir les options nécessaires.
L'Assistant de personnalisation divise la création du module en cinq étapes distinctes :
  1. Collecte des informations
  2. Spécification des paramètres d'installation
  3. Personnalisation de l'expérience d'installation
  4. Personnalisation du navigateur
  5. Personnalisation supplémentaire
Microsoft a rationalisé le nombre d'écrans auxquels vous devez faire face dans IEAK 7, donc le processus est plus clair et plus net que dans les versions préalables. Cependant, l'Assistant de personnalisation continue de faire apparaître des dizaines d'écrans où vous choisissez les options pour votre module. En conséquence, je ne vais pas décrire chaque écran dans cette rubrique car un grand nombre d'entre eux sont explicites et j'ai expliqué comment accéder à l'Aide pour les plus compliqués. Je préfère vous fournir une brève description de l'objet de chaque étape et détailler quelques-uns des écrans les plus importants.
Étape 1 Collecte des informations Vous décidez ici où enregistrer votre module d'installation, sur quels système d'exploitation et plate-forme il s'exécutera, comment vous souhaitez distribuer Internet Explorer et quelles options personnaliser. Dans cette étape, vous pouvez spécifier une des trois méthodes de distribution pour Internet Explorer 7, comme illustré par la Figure 1 : une installation de Fichier, qui crée une structure de répertoire plate avec les fichiers qui constituent votre version, le CD-ROM, qui crée un disque d'installation (pratique si vous prenez en charge des utilisateurs distants) et un module de configuration seulement ou homologation seulement, qui applique vos paramètres personnalisés à une installation existante d'Internet Explorer 7. Vous pouvez utiliser la dernière option pour Windows Vista si Internet Explorer 7 est déjà installé et que vous souhaitez le personnaliser.
Figure 1 Spécification d'une méthode de distribution
Figure 1 Spécification d'une méthode de distribution (Cliquer sur l'image pour la réduire)
Figure 1 Spécification d'une méthode de distribution
Figure 1 Spécification d'une méthode de distribution (Cliquer sur l'image pour l'agrandir)
Dans cette étape, vous spécifiez également quelle langue utiliser pour votre version. Vous pouvez créer des versions localisées d'Internet Explorer 7 pour chacune des langues que vous avez besoin de prendre en charge.
Étape 2 Spécification des paramètres d'installation Ici, vous téléchargez les derniers composants et mises à jour pour Internet Explorer pour créer votre module.
Étape 3 Personnalisation de l'expérience d'installation Dans cette étape, vous choisissez l'installation que vos utilisateurs recevront : Interactive (l'utilisateur doit faire des choix pendant l'installation), Mains libres (l'utilisateur voit l'installation se dérouler, sans pouvoir intervenir) ou Entièrement automatisée (l'installation s'exécute complètement en arrière-plan sans interaction de l'utilisateur). Si vous créez un CD-ROM, cette étape vous invitera à créer une page de démarrage et d'autres éléments pour le CD.
Étape 4 Personnalisation du navigateur Ici, vous personnalisez l'apparence d'Internet Explorer, déterminez les URL pour la Page d'accueil, la Page de support et les Favoris, configurez vos paramètres de proxy et établissez les paramètres de confidentialité et de sécurité pour le navigateur. Dans cette étape, vous pouvez également spécifier le nom et l'emplacement d'un fichier d'auto-configuration ou un fichier de paramètres Internet (INS), avec lequel vous pouvez gérer vos paramètres de navigateur si vous n'avez pas l'intention d'utiliser la Stratégie de groupe.
Le fichier INS est un fichier texte simple qui contient tous les paramètres de navigateur principaux, de la page d'accueil aux Favoris, en passant par les options de sécurité et la configuration de proxy. Vous enregistrez ce fichier INS sur un serveur Web interne. Chaque PC pointe alors vers ce fichier pour obtenir ses paramètres de navigateur. Si vous avez besoin de modifier n'importe quel paramètre à l'avenir, il vous suffit de modifier le fichier INS et vos utilisateurs recevront automatiquement cette modification. Vous pouvez spécifier la fréquence de mise à jour et d'application des paramètres.
Dans cette étape, vous avez également la possibilité d'établir vos serveurs proxy, soit en entrant manuellement leurs adresses IP et numéros de port, soit en créant et spécifiant le nom d'un fichier JScript® ( JS), Javascript (JVS) ou d'autoconfiguration de proxy (PAC) avec vos informations de proxy. L'Aide d'IEAK fournit des exemples de codes que vous pouvez utiliser pour créer ces fichiers.
Vous pouvez également activer le Mode protégé si vous concevez un module Internet Explorer 7 dans et pour Windows Vista. Il vous suffit d'activer le mode protégé dans Internet Explorer 7 sur votre PC de référence, puis d'importer ensuite ce paramètre dans IEAK.
Étape 5 Personnalisation supplémentaire Pour finir, dans cette étape, vous déterminez des stratégies d'utilisateur et des restrictions de sécurité pour votre version. Vous pouvez verrouiller de manière sélective des paramètres individuels si vous ne souhaitez pas que vos utilisateurs les voient ou modifient. La figure 2 affiche l'écran Paramètres supplémentaires avec cinq catégories de contrôles que vous pouvez activer ou désactiver. Les paramètres de ces écrans sont tirés de cinq modèles d'ADM pour Internet Explorer 7, qui sont installés une fois que vous avez téléchargé les derniers composants de navigateur dans l'étape 2 de l'assistant. Si vous utilisez la Stratégie de groupe, vous pouvez ignorer cette étape. Sinon, vous pouvez ensuite configurer les options dans les cinq catégories. Comme ces catégories viennent directement des modèles d'ADM, vous pouvez même les modifier en modifiant chaque fichier ADM dans un éditeur de texte pour ajouter vos propres contrôles personnalisés. Les fichiers ADM sont situés dans C:\Program Files\Microsoft IEAK 7\pol-icies, sous des sous-répertoires différents pour chaque système d'exploitation et plate-forme Windows. La figure 3 affiche les cinq catégories avec une brève description de chacune.
Figure 3 Catégories de l'écran Paramètres supplémentaires (Close Figure 3)

Catégorie | Description
Gestion des contrôles | Cette catégorie vous permet d'activer ou de désactiver certains contrôles ActiveX. Les paramètres de cette catégorie ne s'appliquent pas à Windows Vista, seulement à Windows XP et Windows Server 2003.
Paramètres personnalisés | Cette catégorie affiche les paramètres de sécurité. Vous pouvez activer ou désactiver certains contrôles et actions par zone (Internet, Intranet, Sites de confiance ou Sites limités).
Paramètres d'entreprise | Dans cette catégorie, vous pouvez déterminer la taille et les paramètres du cache du navigateur.
Restrictions d'entreprise | Ici, vous pouvez verrouiller des contrôles et écrans spécifiques dans Internet Explorer pour que vos utilisateurs ne puissent pas les voir. Ces paramètres ne s'appliquent pas à Windows Vista, seulement à Windows XP et Windows Server 2003.
Paramètres Internet | Cette catégorie offre des options de saisie semi-automatique, de taille d'affichage et les paramètres avancés affichés dans le menu Options Internet d'Internet Explorer.
Figure 2 Personnalisation des fonctionnalités d'Internet Explorer
Figure 2 Personnalisation des fonctionnalités d'Internet Explorer (Cliquer sur l'image pour la réduire)
Figure 2 Personnalisation des fonctionnalités d'Internet Explorer
Figure 2 Personnalisation des fonctionnalités d'Internet Explorer (Cliquer sur l'image pour l'agrandir)

Vérification de la version
Une fois les écrans complétés dans l'Assistant de personnalisation, votre module est créé dans l'emplacement que vous avez spécifié à l'Étape 1 ou par défaut dans c:\builds. Vous verrez à cet endroit le répertoire de destination : IEAK utilise la date actuelle pour ce nom de répertoire, par exemple, 01012007 pour le 1er janvier, 2007. En-dessous se trouveront deux chemins de sous-répertoires, un nommé INS et l'autre portant le nom de la méthode de distribution choisie : FLAT, CD ou BrndOnly.
Le répertoire INS sert d'espace de travail ou de référentiel effectuant le suivi de vos personnalisations au cours de la création de votre module. Un fichier texte se trouvant dans ce répertoire, appelé install.ins, stocke tous les paramètres que vous créez. Si vous redémarrez l'Assistant de personnalisation, vos sélections précédentes sont automatiquement reprises dans ce fichier.
Les répertoires FLAT, CD ou BrndOnly enregistrent les fichiers d'installation réels. Vous trouverez sous n'importe lequel de ces trois emplacements un sous-répertoire tirant son nom du système d'exploitation et de la plate-forme, tel que WIN32 pour Windows XP ou Windows Vista de 32 bits. Le sous-répertoire final est nommé en fonction de la langue utilisée pour votre module (par exemple, EN pour English). À titre d'exemple, si vous avez créé une version le 1er janvier 2007, avec une distribution plate pour Windows 32 bits en anglais, le chemin de répertoire de votre version sera c:\builds\01012007\FLAT\WIN32\EN.
Pour rechercher l'installation créée avec une méthode de distribution plate, explorez la structure du répertoire FLAT jusqu'à ce qu'apparaisse le fichier IE7Setup.exe dans le sous-répertoire de langue. Il s'agit d'un exécutable auto-extractible contenant tous les fichiers binaires et de configuration constituant votre version. Ce fichier est tout ce dont vous avez besoin pour déployer votre module Internet Explorer 7 (les fichiers du répertoire INS ne sont pas nécessaires pour l'installation). Vous pouvez copier ce fichier seul sur votre serveur de distribution pour tester votre module et ensuite, une fois prêt, le déployer pour vos utilisateurs.
Si vous avez choisi une distribution par CD-ROM, vous devez copier tout ce qui se trouve dans le répertoire CD sur votre CD. Ceci inclut un fichier autorun.inf, qui est créé automatiquement, et un répertoire comprenant le fichier exécutable qui installe Internet Explorer à partir du CD.
Si vous avez créé un module Configuration seulement ou Homologation seulement, explorez la structure du répertoire BrndOnly jusqu'à atteindre le fichier Setup.exe dans le sous-répertoire de langue. Il s'agit d'un exécutable auto-extractible, que vous pouvez copier sur votre serveur de distribution pour le déploiement.

Gestion de vos paramètres
Votre module Internet Explorer 7 contient l'ensemble des fonctionnalités et paramètres dont vous avez besoin au début. Mais que faire lorsque vous avez besoin de modifier une option ? Deux choix s'offrent à vous. Si vous avez Active Directory, vous pouvez mettre à jour vos paramètres de navigateur en utilisant la Stratégie de groupe. Sinon, IEAK fournit un outil appelé Gestionnaire de profils qui permet de modifier les paramètres. Commençons par jeter un bref coup d'œil à la Stratégie de groupe.
Utilisation des stratégies de groupe La Stratégie de groupe représente la meilleure méthode pour gérer Internet Explorer car elle prend en charge tous les paramètres du navigateur. Avec les versions antérieures d'IEAK et d'Internet Explorer, il fallait ajouter les fichiers ADM et les fichiers de Maintenance Internet Explorer (IEM) à votre console de stratégie de groupe pour intégrer tous les paramètres pour Internet Explorer. Mais pour Internet Explorer 7, Windows XP SP2 et Windows Vista incluent tous les paramètres de stratégie de groupe nécessaires pour la gestion et la mise à jour du navigateur.
Si vous ouvrez l'Éditeur de stratégie de groupe (gpedit.msc), vous trouverez tous les paramètres nécessaires pour Internet Explorer 7 sous Modèles administratifs | Composants Windows | Internet Explorer.
Utilisation du Gestionnaire de profils IEAK Avec le Gestionnaire de profils IEAK, vous concevez et créez la configuration automatique, ou fichier INS, pour enregistrer les paramètres d'Internet Explorer 7. Au départ, le Gestionnaire de profils requiert que vous téléchargiez ou créiez un nouveau fichier INS. Vous pourriez partir de zéro et créer un nouveau fichier INS avec les paramètres que vous avez configurés dans l'Assistant de personnalisation. Mais pourquoi faire deux fois la même chose ? Lorsque vous avez conçu votre module, IEAK a créé le fichier install.ins par défaut pour enregistrer les paramètres du navigateur. Au lieu de créer un nouveau fichier INS dans le Gestionnaire de profils, utilisez install.ins. Pour charger ce fichier, accédez au chemin INS dans le répertoire de votre version, disons c:\builds\01012007\INS. Explorez les sous-répertoires restants jusqu'à atteindre le fichier.
Le Gestionnaire de profils divise ses paramètres en deux sections, comme vous pouvez le voir dans la Figure 4. Les Paramètres de l'Assistant englobent les options du navigateur telles que la page d'accueil, les paramètres de proxy, et les zones de sécurité. Ceux-ci correspondent aux paramètres des étapes 3 à 5 de l'Assistant de personnalisation. La section Stratégies et Restrictions contrôle les restrictions des utilisateurs et correspond aux paramètres des cinq catégories des Stratégies et Restrictions de l'étape 5 de l'Assistant de personnalisation.
Figure 4 Configuration d'Internet Explorer à l'aide du Gestionnaire de profils
Figure 4 Configuration d'Internet Explorer à l'aide du Gestionnaire de profils (Cliquer sur l'image pour la réduire)
Figure 4 Configuration d'Internet Explorer à l'aide du Gestionnaire de profils
Figure 4 Configuration d'Internet Explorer à l'aide du Gestionnaire de profils (Cliquer sur l'image pour l'agrandir)
Puisque vous avez déjà défini ces paramètres lors de la création de votre module, vous ne devez rien avoir à modifier. Cependant, il s'agit là d'une bonne opportunité pour passer en revue tous les paramètres que vous avez choisis pour votre module afin de vous assurer qu'ils sont corrects.
Après avoir vérifié les paramètres dans le Gestionnaire de profils, enregistrez le fichier install.ins ailleurs, puis copiez-le sur un serveur Web interne. Pour ce faire, vous devrez entrer le chemin d'accès UNC (Universal Naming Convention) du serveur, le même que celui spécifié dans l'écran de Configuration automatique à l'étape 4 de l'Assistant de personnalisation. Vous êtes également invité à enregistrer un fichier CAB avec le fichier INS, illustré par la Figure 5. Pourquoi ? Lorsque vous modifiez vos paramètres Internet Explorer 7 avec le Gestionnaire de profils, IEAK a souvent besoin de télécharger des entrées de registre pour vos clients Windows. Ces entrées sont enregistrées dans des fichiers INF, qui sont ensuite enregistrés dans un fichier CAB. Si le numéro de version du fichier INS change en raison de nouvelles modifications, un nouveau fichier CAB devient disponible pour le téléchargement. Enregistrez le fichier CAB au même endroit sur votre serveur Web que votre fichier INS.
Figure 5 Enregistrement de vos fichiers de configuration automatique
Figure 5 Enregistrement de vos fichiers de configuration automatique (Cliquer sur l'image pour la réduire)
Figure 5 Enregistrement de vos fichiers de configuration automatique
Figure 5 Enregistrement de vos fichiers de configuration automatique (Cliquer sur l'image pour l'agrandir)
Vous pouvez ensuite faire des copies du fichier INS et du fichier CAB et les enregistrer à des endroits différents sur votre serveur Web. Considérez-les comme des copies de sauvegarde et des copies de test. Lorsque vous modifiez vos paramètres Internet Explorer avec le Gestionnaire de profils à l'avenir, vous pouvez charger et modifier votre fichier INS de test pour tester vos modifications avant de modifier le fichier INS actif.
Il est facile de modifier un paramètre ou contrôle du navigateur par le biais du Gestionnaire de profils. Il suffit de sélectionner la catégorie appropriée et vous pouvez ensuite activer ou désactiver n'importe quelle option. Une fois vos changements effectués, réenregistrez le fichier INS, puis recopiez-le sur votre serveur.
Dernière recommandation : le fichier INS est un fichier texte simple. Vous pouvez l'ouvrir dans le Bloc-notes pour afficher ses paramètres. Peut-on également modifier le fichier INS dans le Bloc-notes ? Vous pouvez, et les paramètres prendront effet. Cependant, il y a certains avantages à utiliser le Gestionnaire de profils pour modifier le fichier INS. Le Gestionnaire de profils produit automatiquement un fichier CAB si nécessaire et il marque le fichier INS avec un nouveau numéro de version à chaque fois qu'il est modifié. Par conséquent, vous devez toujours utiliser le Gestionnaire de profils pour modifier votre fichier INS.

Conclusion
IEAK est un outil efficace pour créer et personnaliser rapidement et efficacement votre version d'Internet Explorer 7. La dernière version, IEAK 7, comporte plusieurs améliorations par rapport aux versions précédentes (des écrans plus clairs, une aide plus utile) qui vous aideront à concevoir votre propre module d'installation. En comprenant et en utilisant IEAK, vous devriez pouvoir fournir une installation fiable d'Internet Explorer 7 à vos utilisateurs, tout en satisfaisant votre directeur informatique.
Distribution automatique d'Internet Explorer 7
Microsoft a l'intention de distribuer Internet Explorer 7 sous la forme d'une mise à jour prioritaire grâce à des mises à jour automatiques et par le biais des sites Windows Update et Microsoft Update peu de temps après la publication de la version finale d'Internet Explorer 7. Ceci risque de vous poser un problème dans votre rôle d'administrateur, en fonction de votre environnement. Si vos utilisateurs n'ont pas de droits d'administrateur local, ils ne recevront pas cette mise à jour. De plus, si vous gérez votre environnement avec Microsoft Systems Management Server (SMS) ou Windows Server Update Services (WSUS), vous contrôlez déjà les mises à jour que vos utilisateurs reçoivent. Cependant, si certains ou tous vos utilisateurs ont des droits d'administrateur local et que vous n'avez pas de système pour gérer les mises à jour, vous devrez peut-être bloquer la mise à jour d'Internet Explorer 7. Microsoft a créé un Blocker Toolkit pour Internet Explorer 7. Ce toolkit (disponible dans le Centre de téléchargement Microsoft) comprend un modèle de Stratégie de groupe et un script définissant une clé de registre pour empêcher l'exécution de la mise à jour d'Internet Explorer 7.

Lance Whitney est consultant en informatique, formateur et rédacteur technique. Il a créé et pris en charge plusieurs modules d'installation pour Internet Explorer depuis la version 4.0. Journaliste à l'origine, il s'est reconverti dans le monde de l'informatique il y a 15 ans.


 Forum aux questions sur SQL: Archivage des donn&#233;es, serveurs li&#233;s, mesure de la bande passante et plus encore
Forum aux questions sur SQL
Archivage des données, serveurs liés, mesure de la bande passante et plus encore
Par Nancy Michell

Archivage des données
Q J'ai besoin d'une stratégie d'archivage de données complète pour mon groupe. Mon approche actuelle est basée sur le modèle standard consistant à sauvegarder les données, puis à exécuter des utilitaires qui purgeront les données historiques. Si les données purgées doivent être récupérées, l'environnement et la base de données sont restaurés.
Je recherche une solution d'archivage pouvant s'exécuter par étapes. Pour l'étape une, les données sont purgées de la base de données mais restent accessibles en temps réel. En d'autres termes les données sont supprimées, de sorte que la taille de la base de données de production reste gérable, mais les utilisateurs finaux sont toujours en mesure d'y accéder. Dans l'étape deux, les données sont complètement supprimées et une restauration est nécessaire pour y accéder. Comment puis-je réaliser cela ?
R Le plus simple serait de restaurer la copie archivée de la base de données, puis de modifier l'application de manière à accéder à la nouvelle base de données épurée ou à l'ancienne non nettoyée si l'utilisateur le demande. Par conséquent, vous aurez une copie de la base de données pour chaque période de purge.
Si les modifications de données sont lentes et que la plupart des données restent inchangées entre les purges, vous pouvez vous retrouver avec de nombreux chevauchements et une grande quantité d'espace monopolisé inutilement. D'autre part, puisque l'accès aux données archivées est peu fréquent, vous pouvez probablement vous en sortir en plaçant ces données archivées sur quelques lecteurs de grande capacité, plus lents et peu onéreux (au lieu de nombreux lecteurs petits, rapides et coûteux). Si les données sont entièrement actualisées à chaque période, cette solution vous conviendra bien. Ce processus devrait être relativement facile à gérer et presque infaillible.
En outre, envisagez d'utiliser des instantanés de base de données, qui permettent de créer un réplica reflétant un état précis de la base de données avant de nettoyer l'ancienne base de données. Bien que les instantanés soient une bonne solution dans certains scénarios, ils ont également de nombreuses implications. Les instantanés de base de données sont des « copies sur écriture » et conservent en permanence les modifications opérées entre la base de données originale et le moment où l'instantané est pris. Si de nombreuses modifications sont apportées à l'original, l'instantané peut devenir assez volumineux.
Dans un certain sens, l'instantané de base de données est l'opposé de la sauvegarde et de la restauration. L'instantané est intéressant lorsque vous prévoyez d'effectuer seulement quelques modifications, puisqu'il n'enregistre que des deltas, alors que la sauvegarde et la restauration sont mieux adaptées si vous prévoyez beaucoup de modifications. Dans ce cas, les avantages offerts par le gain de place de la « copie sur écriture » disparaissent alors que la difficulté de gérer de instantanés persiste.
Une autre option consiste à utiliser le partitionnement de table. Il vous permet de prendre des tables particulières, de désigner certaines plages de valeur comme appartenant à différentes partitions, puis de placer ces partitions sur différents groupes de fichiers. Une fois que vous maîtrisez l'emplacement des données dans les différents groupes de fichiers d'une table, vous pouvez mieux contrôler les coûts associés. Vous pouvez déterminer quels groupes de fichiers placer sur quels lecteurs physiques (voir la remarque précédente sur les lecteurs bon marché et les lecteurs onéreux) et quels groupes de fichiers doivent être sauvegardés, et à quelle fréquence. Si vous définissez ces groupes de fichiers en lecture seule, vous pouvez également utiliser des sauvegardes partielles.

Quantité de bases de données
Q Mon entreprise cherche à implémenter et à héberger une application devant desservir approximativement 5 000 de nos clients. Nous aimerions implémenter une base de données par client pour garantir la confidentialité des données. Pour une taille de données et d'index, un nombre de connexions d'utilisateur et une charge de travail donnés, les ressources du serveur seront-elles utilisées moins efficacement s'il s'agit d'une seule base de données ou s'il s'agit de 5 000 ?
R Quelle que soit l'importance de votre personnel, il serait difficile de maintenir la même base de code entre les bases de données. Si vous réparez un bogue dans le code de base de données, vous devrez déployer la réparation 5 000 fois. De plus, les temps de récupération de base de données seraient épouvantables, tout comme le serait le temps consacré aux tâches telles que les sauvegardes et le contrôle de cohérence des bases de données. Envisagez la question comme suit : une banque possède-t-elle une base de données distincte sur son hôte pour chaque client possédant un compte en banque ?
SQL Server™ est capable de créer un très grand nombre de bases de données, mais ne constitue pas toujours la meilleure approche. Imaginez le travail nécessaire pour exécuter une transaction dans chaque base de données au cours de la même période dans la mesure où chaque base de données a son propre journal des transactions. Comme nous le savons tous, l'une des clés des performances du traitement des transactions en ligne (OLTP) consiste à maintenir un environnement où le journal des transactions bénéficie d'écritures séquentielles sur son disque. Si vous souhaitez exécuter des transactions dans ces bases de données et non vous contenter de les lire, n'utilisez pas cette approche.

Interroger un serveur lié
Q Je suis en train de développer un data warehouse sur SQL Server 2005 Service Pack 1 (SP1). Notre serveur source se trouve sur le domaine d'un partenaire et le serveur de destination est sur notre propre domaine. Nous extrayons les enregistrements de la source via un serveur lié. Lorsque nous exécutons une requête depuis la source avec des jointures entre les tables sources, la requête est exécutée très rapidement. Cependant, dès que nous avons ne serait-ce qu'une jointure simple avec nos tables de destination, la requête devient très lente. Pourquoi ?
R Il est préférable d'éviter les jointures inter-serveur, en particulier si elles traversent une limite de domaine. Cela dit, selon les résultats de la requête, ce problème peut être dû au fait que vos partenaires approuvent votre domaine, mais que vous n'approuvez pas le leur. Essayez de revoir votre requête pour qu'elle s'exécute depuis la source, puis copiez les résultats vers la destination. Cela peut donner de meilleurs résultats.

Mesure de la bande passante
Q Existe-t-il des pratiques recommandées pour mesurer la bande passante utilisée pour la mise en miroir de base de données ? Je sais qu'il faut qu'elle soit environ trois fois supérieure à la vitesse de génération du journal, mais si la charge n'est pas lourde, est-il possible de mettre en miroir la base de données en passant par une connexion large bande sur le Web ?
R Outre le débit à proprement parler, vous devez tenir compte de la latence de message en boucle (plus critique si sécurité=totale) et de la fiabilité de la liaison. La mise en miroir de base de données est optimisée pour une connexion réseau fiable. La surcharge peut donc être importante à la reconnexion. Si la connexion large bande est instable (connexions rejetées ou longs délais) vous ne pourrez peut-être pas maintenir une connexion. Pour plus d'informations, consultez le livre blanc sur les questions de performance de la mise en miroir.
Sécurisation de l'accès à SQL Server
Vous cherchez des conseils sur la sécurisation de l'accès à SQL Server dans un environnement de production ? Consultez la page Centre de développement de modèles & conseils de Microsoft. Trois modèles peuvent vous intéresser :
  • Index d'ingénierie de sécurité
  • Index des conseils de sécurité pour les applications
  • Applications Web de modélisation des menaces

Vous souhaitez obtenir des détails sur la configuration d'un environnement opérationnel complet ? Voici deux bonnes références :
  • Windows Server System Reference Architecture
  • Guide de mise en œuvre des services de données

Merci aux informaticiens Microsoft ci-dessous pour l'apport de leur expertise technique : Denis Altudov, Jayashree Anand, Gus Apostol, Bhavana Bartholf, Mike Blaszczak, Dibyendu Chakraverty, Shaun Cox, Laurentiu Cristofor, Ernie DeVore, Michael Epprecht, Nakul Garg, Phil Hummel, Steve Lindell, Kaloian Manassiev, Al Noel, Ward Pond, Paul Randal, Remus Rusanu, Mike Shelton, Christy Sutton, Kevin Tsai, Peter Ty, Val Wittenberg, Steven Wort, Kalyan Yella, et Frankie Yuen.


 The Cable Guy: R&#233;glage automatique de la fen&#234;tre de r&#233;ception TCP
The Cable Guy
Réglage automatique de la fenêtre de réception TCP
Joseph Davies

Bienvenue dans le premier article du Cable Guy de TechNet Magazine. Les habitués des articles parus sur le site Web TechNet savent déjà que nous abordons tous les types de problèmes réseau et nous poursuivrons cette tradition ici chaque mois. Si vous êtes nouveau et que vous cherchez une archive des articles précédents, visitez le site du Cable Guy.
Commençons par notre premier sujet : la fenêtre de réception TCP.
Le débit par des connexions TCP peut être limité par l'envoi et la réception d'applications, l'envoi et la réception d'implémentations de TCP et le chemin de transmission entre les homologues de TCP. Dans cet article, je vais décrire la fenêtre de réception TCP et son impact sur le débit TCP, l'utilisation de l'évolutivité de la fenêtre TCP et la nouvelle fonctionnalité de Réglage automatique de la fenêtre de réception dans Windows Vista™ qui optimise le débit TCP pour les données reçues.

La fenêtre de réception TCP
Les connexions TCP ont un certain nombre de caractéristiques importantes. Premièrement, elles représentent un circuit point-à-point logique entre deux protocoles de la couche application. TCP ne fournit pas un service de livraison un-à-plusieurs, il offre uniquement une livraison un-à-un.
Deuxièmement, les connexions TCP sont orientées connexion. Avant le transfert des données, deux processus de couche d'application doivent négocier formellement une connexion TCP à partir du processus d'établissement de connexion TCP. De même, les connexions TCP sont officiellement fermées après la négociation avec le processus d'arrêt de connexion TCP.
Troisièmement, les données fiables envoyées sur une connexion TCP sont ordonnées et un accusé de réception du destinataire est attendu. En l'absence d'un accusé de réception, le segment est retransmis. Au niveau du destinataire, les segments dupliqués sont supprimés et les segments arrivant dans le mauvais ordre sont remis dans le bon ordre.
Quatrièmement, les connexions TCP sont en duplex intégral. Pour chaque homologue TCP, la connexion TCP consiste en deux canaux logiques : un canal sortant et un canal entrant. L'en-tête TCP contient le numéro de séquence des données sortantes et un accusé de réception (ACK) des données entrantes.
De plus, TCP affiche les données passant par les canaux entrants et sortants logiques comme un flux continu d'octets. Le numéro de séquence et le numéro d'accusé de réception de chaque en-tête TCP sont définis dans les limites d'octets. TCP n'est pas conscient de limites d'enregistrement ou message dans le flux d'octets. Le protocole de la couche application doit fournir l'analyse correcte du flux d'octets entrants.
Pour limiter la quantité de données pouvant être envoyées simultanément et fournir un contrôle du flux côté réception, les homologues TCP utilisent une fenêtre. La fenêtre est la portée des données du flux d'octets que le destinataire autorise l'émetteur à envoyer. L'émetteur peut envoyer uniquement les octets du flux d'octets compris à l'intérieur de la fenêtre. La fenêtre suit le flux d'octets sortants de l'émetteur et le flux d'octets entrants du destinataire.
Pour un canal logique donné (une direction de la connexion TCP en duplex intégral) l'émetteur gère une fenêtre d'envoi et le destinataire gère une fenêtre de réception. Lorsqu'il n'y a pas de données ou de segments ACK en transit, les fenêtres d'envoi et de réception d'un canal logique correspondent. En d'autres termes, la portée des données dans le flux d'octets sortants que l'émetteur est autorisé à envoyer correspond à la portée des données dans le flux d'octets entrants que le destinataire peut recevoir. La figure 1 illustre cette relation d'envoi et réception.
Figure 1 Correspondance des fenêtres d'envoi et de réception
Figure 1 Correspondance des fenêtres d'envoi et de réception (Cliquer sur l'image pour la réduire)
Figure 1 Correspondance des fenêtres d'envoi et de réception
Figure 1 Correspondance des fenêtres d'envoi et de réception (Cliquer sur l'image pour l'agrandir)
Pour indiquer la taille de la fenêtre de réception, l'en-tête TCP contient un champ de fenêtre 16 bits. Lorsque le destinataire obtient des données, il renvoie des accusés de réception (ACK) à l'émetteur en indiquant les octets reçus. Dans chaque ACK, le champ Fenêtre indique le numéro d'octets restant dans la fenêtre de réception. Lorsque les données sont envoyées, qu'elles font l'objet d'un accusé de réception et qu'elles sont récupérées par l'application, les fenêtres d'envoi et de réception glissent vers la droite. La fenêtre de réception est la fenêtre qui contrôle la quantité de données non reconnues transmises par l'émetteur au destinataire.
Comme il peut y avoir des données de la fenêtre de réception qui n'ont pas encore été récupérées par l'application et des données qui ont été reçues mais pas reconnues, la fenêtre de réception TCP a une structure supplémentaire, comme illustré par la figure 2.
Figure 2 Types de données de la fenêtre de réception TCP
Figure 2 Types de données de la fenêtre de réception TCP (Cliquer sur l'image pour la réduire)
Figure 2 Types de données de la fenêtre de réception TCP
Figure 2 Types de données de la fenêtre de réception TCP (Cliquer sur l'image pour l'agrandir)
Notez la différence entre les fenêtres de réception maximale et actuelle. La fenêtre de réception maximale a une taille fixe. La fenêtre de réception actuelle a une taille variable et correspond à la quantité restante de données que le destinataire autorise l'émetteur à envoyer. La taille de la fenêtre de réception actuelle est la valeur du champ Fenêtre indiquée dans les ACK renvoyés à l'émetteur et elle correspond à la différence entre la taille de la fenêtre de réception maximale et la quantité des données reçues et reconnues mais non récupérées par l'application.

Fenêtre de réception TCP et débit TCP
Pour optimiser le débit TCP (en supposant que le chemin de transmission est dépourvu d'erreurs), l'émetteur doit envoyer suffisamment de paquets pour remplir le canal logique situé entre l'émetteur et le destinataire. La capacité du canal logique peut être calculée par la formule suivante :
Capacity in bits = path bandwidth in bits per second * round-trip time (RTT) in seconds
La capacité est connue comme le produit bande passante/délai (BDP). Le canal peut être gros (bande passante élevée), fin (bande passante basse), court (RTT bas) ou long (élevé RTT) Les canaux qui sont gros et longs ont le BDP le plus élevé. Les chemins situés sur des satellites ou des réseaux étendus (WAN) d'entreprise qui comprennent des liaisons en fibre optique intercontinentaux sont des exemples de chemins de transmission à BDP élevé.
Augmentation des performances côté émetteur pour transmission à BDP élevé
La nouvelle fonctionnalité de réglage automatique de la fenêtre de réception offre des performances améliorées pour la réception de données sur des liaisons à BDP élevé, mais qu'en est-il des performances de l'émetteur ?
Les algorithmes existants qui empêchent un homologue TCP émetteur de submerger le réseau ralentissent le début et évitent la congestion. Ces algorithmes augmentent la fenêtre d'envoi (le nombre de segments que l'émetteur peut envoyer) lors du début de l'envoi de données à la connexion et au moment de la récupération après une perte de segment.
La lenteur du démarrage augmente la fenêtre d'envoi d'un segment TCP complet pour chaque segment d'accusé de réception (pour TCP dans Windows XP et Windows Server 2003) ou pour chaque segment reconnu (pour TCP dans Windows Vista et Windows Server « Longhorn »). L'élimination de la congestion augmente la fenêtre d'envoi d'un segment TCP complet pour chaque fenêtre de données complète reconnue.
Ces algorithmes conviennent pour les petits BDP et les petites tailles de fenêtre de réception. Cependant, lorsque vous avez une connexion TCP avec une fenêtre de réception de grande taille et un BDP élevé (par exemple avec une réplication des données entre deux serveurs situés sur une liaison WAN rapide et un temps d'aller-retour de 100 millisecondes), ces algorithmes n'augmentent pas la fenêtre de réception suffisamment vite pour utiliser pleinement la bande passante de la connexion.
Pour mieux utiliser la bande passante de connexions TCP dans ces situations, la pile TCP/IP nouvelle génération inclut Compound TCP (CTCP). CTCP augmente la fenêtre d'envoi d'une manière plus agressive pour les connexions avec de grandes tailles de fenêtres et des BDP élevés. CTCP tente d'optimiser le débit sur ces types de connexions en contrôlant les variations de délai et les pertes. Par ailleurs, CTCP s'assure que son comportement n'a pas d'impact négatif sur d'autres connexions TCP.
Les tests effectués en interne chez Microsoft ont révélé une forte réduction des temps de sauvegarde de fichiers (environ moitié moins) pour une connexion de 1 Gigabit par seconde avec un temps d'aller-retour de 50 millisecondes. Ces performances peuvent être encore meilleures avec des connexions ayant un BDP plus élevé. CTCP et le réglage automatique de la fenêtre de réception contribuent ensemble à une meilleure utilisation de la liaison et peuvent générer des gains de performance substantiels pour les connexions dotés de BDP élevés.
CTCP est activé par défaut sur les ordinateurs exécutant Windows Server « Longhorn » et désactivé par défaut sur les ordinateurs exécutant Windows Vista. Vous pouvez activer CTCP avec la commande « netsh interface tcp set global congestionprovider=ctcp ». Vous pouvez désactiver CTCP avec la commande « netsh interface tcp set global congestionprovider=none ».

La taille du champ Fenêtre dans l'en-tête TCP est de 16 bits, ce qui permet à un homologue TCP d'annoncer une taille de fenêtre de réception maximale de 65 535 octets. Vous pouvez calculer le débit approximatif pour une taille de fenêtre TCP donnée avec la formule suivante :
Throughput = TCP maximum receive windowsize / RTT
Par exemple, avec une fenêtre de réception de 65 535 octets, vous pouvez uniquement atteindre un débit approximatif de 5,24 mégabits par seconde (Mbits/s) sur un chemin ayant un RTT de 100 millisecondes, sans tenir compte de la bande passante réelle du chemin de transmission. Avec les chemins de transmission à BDP élevés d'aujourd'hui, la taille de fenêtre TCP conçue à l'origine devient un goulet d'étranglement du débit, même à sa valeur maximale.

Évolutivité de la fenêtre TCP
Pour que les tailles de fenêtres supérieures puissent prendre en charge les chemins de transmission haut débit, RFC 1323 (ietf.org/rfc/rfc1323.txt) définit une évolutivité de fenêtre qui permet à un destinataire d'avoir une taille de fenêtre supérieure à 65 535 octets. L'option Évolutivité de la fenêtre TCP comprend un facteur d'évolutivité de fenêtre qui, associé au champ Fenêtre de 16 bits dans l'en-tête TCP, peut augmenter la taille de la fenêtre de réception à un maximum d'1 Go environ. L'option Évolution de la fenêtre est envoyée uniquement dans les segments SYN (Synchronise) au cours du processus d'établissement de connexion. Les deux homologues TCP peuvent indiquer des facteurs d'évolutivité de fenêtre différents à utiliser pour leurs tailles de fenêtres de réception. En permettant à un émetteur d'envoyer plus de données sur une connexion, l'évolutivité de la fenêtre TCP permet aux noeuds TCP de mieux utiliser certains types de chemins de transmission dotés de BDP élevés.
Bien que la taille de la fenêtre de réception soit importante pour le débit TCP, la vitesse à laquelle l'application récupère les données accumulées dans la fenêtre de réception (le taux de récupération de l'application) constitue un autre facteur important pour déterminer le débit TCP optimal. Si l'application ne récupère pas les données, la fenêtre de réception commence à se remplir, ce qui force le destinataire à indiquer une taille de fenêtre actuelle inférieure. Dans les cas extrêmes, l'ensemble de la fenêtre de réception maximale est rempli, ce qui force le destinataire à indiquer une taille de fenêtre de 0 octet. Dans ce cas, l'émetteur doit arrêter d'envoyer des données jusqu'à ce que la fenêtre de réception se vide. Par conséquent, pour optimiser le débit TCP, la fenêtre de réception TCP pour une connexion doit être réglée sur une valeur reflétant à la fois le BDP du chemin de transmission de la connexion et le taux de récupération de l'application.
Même si vous pouviez déterminer correctement le BDP et le taux de récupération de l'application, ceux-ci peuvent changer. Le taux de BDP peut varier en fonction de la congestion sur le chemin de transmission et le taux de récupération de l'application peut varier en fonction du nombre de connexions sur lesquelles l'application reçoit des données.

La Fenêtre de réception dans Windows XP
Pour la pile TCP/IP dans Windows XP (et Windows Server® 2003), la taille de la fenêtre de réception maximale a un certain nombre d'attributs significatifs. Premièrement, la valeur par défaut se base sur la vitesse de liaison de l'interface d'envoi. La véritable valeur s'ajuste automatiquement sur les incréments de la taille de segment maximale (MSS) négociée pendant l'établissement de connexion TCP.
Deuxièmement, la taille de la fenêtre de réception maximale peut être configurée manuellement. Les valeurs de registre HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\TCPWindowSize et HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interface\InterfaceGUID\TCPWindowSize peuvent être réglées sur un maximum de 65 535 octets (sans évolutivité de fenêtre) ou 1 073 741 823 (avec évolutivité de fenêtre).
Troisièmement, la taille de la fenêtre de réception maximale peut l'évolutivité de fenêtre. Vous pouvez activer l'évolutivité de fenêtre en réglant la valeur de registre HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Tcp1323Opts sur 1 ou 3. Par défaut, l'évolutivité de fenêtre est utilisée sur une connexion uniquement si le segment SYN reçu contient l'option d'évolutivité de fenêtre.
Pour finir, la taille de fenêtre de réception maximale peut être spécifiée par une application en utilisant l'option SO_RCVBUF de Windows Sockets lorsqu'une connexion est établie. Pour l'évolutivité de fenêtre, l'application doit spécifier une taille de fenêtre supérieure à 65 535 octets.
Malgré la prise en charge des fenêtres évolutives, la taille de la fenêtre de réception maximale dans Windows XP peut quand même limiter le débit parce qu'il y a une taille maximale fixe pour toutes les connexions TCP (sauf mention contraire dans l'application), ce qui peut augmenter le débit pour certaines connexions et le diminuer pour d'autres. De plus, la taille de la fenêtre de réception maximale fixe pour une connexion TCP ne varie pas en fonction des modifications du taux de récupération de l'application ou de la congestion sur le chemin de transmission.

Réglage automatique de la fenêtre de réception dans Windows Vista
Pour optimiser le débit TCP, en particulier pour les chemins de transmission dotés d'un BDP élevé, la pile TCP/IP nouvelle génération de Windows Vista (et la prochaine version de Windows Server, nom de code « Longhorn ») prend en charge le réglage automatique de la fenêtre de réception. Cette fonctionnalité détermine la taille de la fenêtre de réception optimale en mesurant le BDP et le taux de récupération de l'application et en adaptant la taille de la fenêtre au chemin de transmission en cours et aux conditions d'application.
Le réglage automatique de la fenêtre de réception active l'évolutivité de la fenêtre TCP par défaut, ce qui permet une taille de fenêtre de réception maximale de 16 Mo. Lorsque les données circulent sur la connexion, la pile TCP/IP nouvelle génération surveille la connexion, mesure son BDP et son taux de récupération de l'application actuels et ajuste la taille de la fenêtre de réception pour optimiser le débit. La pile TCP/IP nouvelle génération n'utilise plus la valeur de registre TCPWindowSize.
Le réglage automatique de la fenêtre de réception a plusieurs avantages. Il détermine automatiquement la taille de la fenêtre de réception optimale en fonction de la connexion. Dans Windows XP, la valeur de registre TCPWindowSize s'applique à toutes les connexions. Les applications n'ont plus besoin de spécifier des tailles de fenêtres TCP par le biais d'options Windows Sockets. Et les administrateurs informatiques n'ont plus besoin de configurer manuellement une taille de fenêtre de réception TCP pour des ordinateurs spécifiques.
Avec le réglage automatique de la fenêtre de réception, un homologue TCP Windows Vista indique généralement des tailles de fenêtre de réception bien supérieures à celles d'un homologue TCP Windows XP. Ceci permet à l'autre homologue TCP de remplir le canal de l'homologue TCP Windows Vista en envoyant plus de segments de données TCP sans avoir à attendre un ACK (en fonction du contrôle de congestion TCP). Pour un trafic réseau client typique, tel que des pages Web ou le courrier électronique, le serveur Web ou le serveur de messagerie pourra envoyer plus de données TCP plus rapidement à l'ordinateur client, ce qui entraîne une augmentation globale des performances réseau. Plus le BDP et le taux de récupération de l'application sont élevés, plus les performances augmentent.
L'impact sur le réseau est le suivant : un flux de paquets de données TCP, qui serait normalement expédié à un rythme plus bas et mesuré, est envoyé beaucoup plus vite, ce qui entraîne un plus grand pic d'utilisation du réseau pendant le transfert des données. Pour les ordinateurs équipés de Windows XP et Windows Vista exécutant le même transfert de données sur un canal gros et long, la même quantité de données est transférée. Cependant, le transfert de données de l'ordinateur équipé de Windows Vista est plus rapide en raison de la taille supérieure de la fenêtre de réception et de la capacité du serveur à remplir le canal reliant le serveur au client.
Étant donné que le réglage automatique de la fenêtre de réception augmentera l'utilisation par le réseau de chemins de transmission à BDP élevés, l'utilisation de la Qualité de Service (QoS) ou de limitation du taux d'envoi de l'application risque de devenir importante pour les chemins de transmission utilisant toutes les capacités ou presque. Pour répondre à cet éventuel besoin, Windows Vista prend en charge des paramètres de QoS basé sur les stratégies qui vous permettent de définir des taux de limitation pour le trafic envoyé selon l'adresse IP ou le port TCP. Pour plus d'informations, voir les ressources sur le QoS basé sur les stratégies.
Augmentation du débit TCP pour les réseaux à forte perte
Les réseaux à forte perte peuvent réduire considérablement le débit TCP à cause des pauses et retransmissions fréquentes. Les réseaux sans fil sont un exemple de réseaux à forte perte, notamment ceux basés sur IEEE 802.11, General Packet Radio Service (GPRS), ou Universal Mobile Telecommunications System (UMTS), qui peuvent avoir des pertes de paquets élevées en fonction des conditions du réseau, de l'atténuation des signaux, d'interférences électromagnétiques et du changement d'emplacement de l'ordinateur.
La pile TCP/IP nouvelle génération prend en charge les quatre RFC suivantes pour optimiser le débit dans les environnements à forte perte :

RFC 2582 : Modification NewReno de l'algorithme de récupération rapide de TCP
L'algorithme de récupération rapide, défini dans RFC 2001, est basé sur l'algorithme Reno, qui augmente la quantité de données qu'un émetteur peut envoyer lorsqu'un segment est retransmis en raison d'un événement de retransmission rapide. Bien que l'algorithme Reno fonctionne bien pour les segments perdus individuels, il ne marche pas aussi bien lorsqu'il y a plusieurs segments perdus. L'algorithme NewReno offre un débit plus rapide en modifiant la façon dont un émetteur peut augmenter sa vitesse d'envoi lors de la récupération rapide si plusieurs segments d'une fenêtre de données sont perdus et l'émetteur reçoit un accusé de réception partiel (un accusé de réception pour une partie uniquement des données effectivement reçues).

RFC 2883 : Extension de l'option d'accusé de réception sélectif (SACK, Selective Acknowledgement) pour TCP
SACK, défini dans RFC 2018, permet à un destinataire d'indiquer jusqu'à quatre blocs de non-contigus de données reçues en utilisant une option SACK TCP. La RFC 2883 définit une utilisation supplémentaire des champs dans l'option SACK TCP pour accuser réception des paquets dupliqués. Ainsi, l'émetteur peut déterminer lorsqu'il a retransmis un segment de façon inutile et ajuster son comportement pour empêcher de futures retransmissions inutiles. La diminution du nombre de retransmissions améliore le débit global.

RFC 3517 : Algorithme conservatif de récupération de perte basé sur SACK pour TCP
L'implémentation actuelle de TCP/IP dans Windows Server 2003 et Windows XP utilise les informations SACK uniquement dans le but de déterminer les segments TCP qui ne sont pas arrivés à destination. La RFC 3517 définit une méthode d'utilisation des informations SACK pour effectuer la récupération de perte lors de la réception d'accusés de réception dupliqués, remplaçant l'algorithme de récupération rapide le plus ancien lorsque l'option SACK est activée sur une connexion. La pile TCP/IP nouvelle génération conserve une trace des informations SACK en fonction de la connexion et contrôle les accusés de réception entrants et dupliqués pour effectuer une récupération plus rapide lorsque plusieurs segments ne sont pas reçus à destination.

RFC 4138 : Récupération F-RTO (Forward RTO-Recovery) : Algorithme pour la détection des fausses expirations de retransmission avec TCP et le protocole SCTP (Stream Control Transmission Protocol)
Des fausses retransmissions de segments TCP peuvent survenir avec une augmentation soudaine dans RTT, entraînant le début des expirations de retransmission (RTO) de segments précédemment envoyés et forçant TCP à commencer à les retransmettre. Si l'augmentation survient juste avant l'envoi d'une fenêtre complète de données, un émetteur peut retransmettre la fenêtre de données entière. L'algorithme F-RTO empêche la fausse retransmission de segments TCP avec le comportement suivant.
Lorsque le RTO expire pour plusieurs segments, TCP retransmet juste le premier segment. Lorsque le premier accusé de réception arrive, TCP commence à envoyer de nouveaux segments (si la taille de fenêtre indiquée le permet). Si l'accusé de réception suivant confirme les autres segments ayant expiré mais n'ayant pas été retransmis, TCP détermine que l'expiration était fausse et ne retransmet pas les autres segments expirés.
Lorsque des environnements présentent des augmentations soudaines et temporaires du temps RTT (lorsqu'un client sans fil passe d'un point d'accès à un autre, par exemple), l'algorithme F-RTO empêche toute retransmission inutile de segments et revient plus rapidement à sa fréquence d'envoi normale. L'utilisation des algorithmes de récupération de perte basés sur SACK et F-RTO convient mieux aux connexions utilisant des liaisons GPRS.

Joseph Daviesest rédacteur technique chez Microsoft et il enseigne et écrit sur le réseau Windows depuis 1992. Il a écrit cinq livres pour Microsoft Press et on lui doit les articles mensuels du Cable Guy de Technet.


 Windows PowerShell: Constructions de Windows PowerShell
Windows PowerShell
Constructions de Windows PowerShell
Don Jones

Le mois dernier, je vous ai montré de quelle manière utiliser immédiatement Windows PowerShell afin d'effectuer certaines tâches d'administration sans pour autant devoir effectivement écrire des scripts. Toutefois, même si Windows PowerShell est un excellent shell interactif, vous tirerez réellement parti de ses fonctions et pourrez automatiser des tâches plus complexes en commençant à utiliser son langage de script puissant et simple à la fois.
Néanmoins, vous pouvez vous poser une question : Microsoft a réellement besoin d'un autre langage de script ? Après tout, Microsoft nous a déjà fourni KiXtart (un processeur de scripts de connexion) et VBScript (Visual Basic® Scripting Edition). La réponse est quand même oui. Microsoft avait réellement besoin d'un autre langage de script. Je vais vous en exposer la raison.
Le langage Windows PowerShell™ se devait d'être simple et intuitif afin que les administrateurs puissent le maîtriser sans suivre de trop longues formations. Il se devait également d'être relativement souple afin de s'adapter à l'ensemble des fonctionnalités puissantes que Windows PowerShell lui-même propose aux utilisateurs.
Windows PowerShell étant basé sur Microsoft® .NET Framework, sa syntaxe de script devait être aisément adaptable à .NET. Lors de la création d'un langage de script pour Windows PowerShell, les concepteurs ont choisi une syntaxe qui correspond essentiellement à un langage C# très simplifié (prononcé C-Sharp, l'un des langages fournis avec .NET Framework) . Pourquoi ne pas s'inspirer d'une syntaxe de type VBScript ? Le langage de script Windows PowerShell n'est en fait pas tellement différent de VBScript, mais en s'approchant davantage de la syntaxe C#, PowerShell propose une sorte de base initiale pour l'apprentissage de la programmation .NET Framework. Si vous décidez un jour de passer à Visual Studio® et de commencer à écrire des applications C#, la majeure partie de votre syntaxe de script Windows PowerShell pourra vous servir en ce sens.
Dans ce contexte, les constructions sont l'une des choses les plus importantes dans le langage de script Windows PowerShell (ou dans tout autre langage de script). Il s'agit d'éléments de langage spéciaux permettant à Windows PowerShell d'effectuer des comparaisons logiques pour entreprendre diverses actions en fonctions des résultats ou pour permettre de répéter indéfiniment une ou plusieurs instructions.

Penser logique
Les comparaisons logiques sont au cœur de bon nombre de constructions de langage de script ; Windows PowerShell n'y fait pas exception. Globalement, une comparaison analyse deux valeurs ou deux objets et détermine si le résultat est True (vrai) ou False (faux). Par exemple, vous pouvez vous demander si la date d'expiration du mot de passe utilisateur est identique à la date du jour. Le résultat sera True (vrai) si ces dates correspondent ou False (faux) si elles diffèrent. Remarquez que j'utilise les termes avec majuscules pour True (vrai) et False (faux) ; en effet, ils ont une signification spéciale dans Windows PowerShell.
Voici un exemple d'une comparaison logique réelle dans Windows PowerShell :
PS C:\> $a = 1
PS C:\> $b = 2
PS C:\> $a -eq $b
False
J'ai créé une variable nommée $a et l'ai définie pour qu'elle contienne la valeur 1. Dans Windows PowerShell, les noms de variable commencent toujours par un signe dollar afin de les reconnaître plus facilement. Techniquement, le signe = fait référence à l'opérateur d'attribution ; en effet, il sert à attribuer une valeur. Ensuite, j'ai créé une deuxième variable nommée $b à laquelle j'ai attribué la valeur 2. Vient ensuite la comparaison logique : je demande à Windows PowerShell de comparer les contenus de $a et $b à l'aide de l'opérateur -eq (égalité). PowerShell effectue la comparaison, détermine que ces deux variables ne sont pas égales, puis affiche le résultat : False.
Les opérateurs Windows PowerShell sont légèrement différents de ceux des autres langage de script, ainsi que de ceux de C#. La plupart des langages utilisent l'opérateur = aussi bien pour effectuer des vérifications d'égalité que des attributions de valeurs ; Windows PowerShell évite toute confusion en dédiant un opérateur à chaque fonction. La figure 1 illustre les opérateurs de comparaison Windows PowerShell avec leurs équivalents dans d'autres langages (tels que VBScript) qui vous sont peut-être déjà familiers.
Figure 1 Opérateurs de comparaison PowerShell (Close Figure 1)

Opérateur | Nom | Description
-eq | Egalité | Teste les valeurs pour déterminer si elles sont égales. D'autres langages peuvent utiliser = ou == pour tester l'égalité.
-ne | Non égal | Teste les valeurs pour déterminer si elles sont inégales. D'autres langages peuvent utiliser <> ou != pour tester l'inégalité.
*-gt | Supérieur à | Teste une valeur pour déterminer si elle est supérieure à une autre. D'autres langages peuvent utiliser le caractère >.
-lt | Inférieur à | Teste une valeur pour déterminer si elle est inférieure à une autre. D'autres langages peuvent utiliser le caractère <.
-ge | Supérieur ou égal à | Teste une valeur pour déterminer si elle est supérieure ou égale à une autre. Identique à >= dans VBScript et les autres langages.
-le | Inférieur ou égal à | Teste une valeur pour déterminer si elle est inférieure ou égale à une autre. Identique à <= dans VBScript et les autres langages.
Ces opérateurs de comparaison comportent une autre fonction intéressante. Voyez plutôt la comparaison suivante :
PS C:\> $a = "TechNet"
PS C:\> $b = "technet"
PS C:\> $a -eq $b
True
Par défaut, les opérateurs de comparaison ne sont pas sensibles à la casse ; ainsi la version avec majuscules de TechNet est considérée comme équivalente à « technet ». Cette caractéristique s'avère pratique du fait que vous ne vous souciez généralement pas de la casse des lettres dans la plupart des tâches d'administration. Toutefois, il arrive que la casse vous soit utile ; vous pouvez alors demander à Windows PowerShell d'effectuer une comparaison sensible à la casse en ajoutant la lettre c à l'opérateur de comparaison :
PS C:\> $a -ceq $b
False
De la même manière, si vous êtes soucieux de savoir si Windows PowerShell effectue une comparaison sensible à la casse ou non, vous pouvez l'y forcer en ajoutant la lettre i :
PS C:\> $a -ieq $b
True
Gardez à l'esprit que les comparaisons logiques ont toujours l'une de ces deux valeurs pour résultat : True (vrai) ou False (faux).

Prendre des décisions
A présent que vous savez comment écrire des comparaisons logiques, vous pouvez les utiliser dans les constructions. La première construction que je vais vous présenter permet à Windows PowerShell de prendre des décisions fondées sur une comparaison. Il s'agit d'une construction en If (si), laquelle comporte quelques variantes. Voici la plus simple d'entre elles :
PS C:\> if ($a -eq $b) {
>> Write-Host "They are equal"
>> }
>>
They are equal
Cette section comporte des éléments intéressants à retenir. Tout d'abord, les variables $a et $b contiennent encore les valeurs « TechNet » et « technet », respectivement. J'ai commencé la construction en utilisant le mot-clé If (si). A sa suite, entre parenthèses, j'ai saisi la comparaison logique à effectuer. Vient ensuite une accolade, laquelle indique le début de ce que j'appelle le code conditionnel, c'est-à-dire le code que Windows PowerShell exécute si le résultat de la comparaison est True (vrai). Le premier exemple vous a démontré que le résultat de cette comparaison True (vrai) ; je m'attends donc à ce que le code conditionnel s'exécute. Je saisis mon code conditionnel, Write-Host "Elles sont égales", puis j'appuie sur la touche Entrée. Enfin, je termine la section du code conditionnel en entrant une accolade fermante et en appuyant sur la touche Entrée à deux reprises. (La deuxième frappe sur la touche Entrée sur une ligne vierge permet à l'analyseur de savoir que j'en ai terminé avec l'écriture et suis prêt à ce qu'il exécute le code.)
Notez que cette construction ne s'exécute pas depuis un fichier de script. Je l'ai simplement saisie dans la ligne de commandes Windows PowerShell. C'est ce qui rend Windows PowerShell unique dans le monde du script Windows : les scripts peuvent aussi bien être créés de manière interactive qu'intégrés dans un fichier pour un stockage permanent.
Dès que j'ai saisi l'accolade ouvrante et appuyé sur la touche Entrée, Windows PowerShell a affiché une invite >>. Cette invite revient à dire « Je reconnais que vous êtes dans une construction et je suis prêt à vous laisser saisir ce que bon vous semble au sein de cette dernière ». Dès que j'ai entré l'accolade fermante et frappé sur la touche Entrée à deux reprises, Windows PowerShell a immédiatement exécuté la construction, déterminé que le résultat de la comparaison logique était True (vrai) et exécuté le code conditionnel. Vous pouvez vous en rendre compte grâce à l'affichage de « Elles sont égales » avant que PowerShell ne retourne à son invite normale. L'utilisation de Windows PowerShell pour écrire des scripts de manière interactive vous permet de tester rapidement des morceaux de code avant de les assembler dans un script permanent, afin d'en simplifier l'apprentissage et le débogage.
Je dois signaler que Windows PowerShell n'est pas particulièrement pointilleux sur les actions telles que les pressions sur la touche Entrée. Ainsi, ce qui suit aura la même fonctionnalité que l'exemple précédent :
PS C:\> if ($a -eq $b) { Write-Host "They are equal" }
They are equal
Etant donné que j'ai tout saisi sur une même ligne, Windows PowerShell n'a pas eu besoin d'afficher l'invite spéciale >> ; il a simplement exécuté la construction jusqu'à ce que j'appuie sur Entrée à la fin de la ligne. Comment Windows PowerShell a-t-il su qu'il pouvait exécuter la construction ? Parce qu'à ce stade, elle était terminée, l'accolade fermante ayant été saisie.
Précédemment, j'ai fait allusion à d'autres variantes de la construction If (si). En voici un exemple complet, présenté tel qu'il pourrait apparaître dans un fichier de script PS1, plutôt que dans le shell :
if ($a -eq $b) {
  Write-Host "They are equal"
} elseif ($a -lt $b) {
  Write Host "One is less than the other"
} else {
  Write Host "One is greater than the other"
}
Cette construction commence de la même manière, à l'aide du mot-clé If (si). Néanmoins, dans l'éventualité d'un résultat False (faux) pour la comparaison, j'ai ajouté une autre comparaison à l'aide du mot-clé Elseif (autrement, si). Si cette deuxième comparaison est également False (faux), mon dernier mot-clé, Else (autrement), fournit un ensemble de code final à exécuter.

Se répéter
Windows PowerShell contient plusieurs constructions permettant de répéter indéfiniment l'exécution d'un code jusqu'à ce qu'une comparaison donne un résultat True (vrai) ou False (faux). Les programmeurs appellent cela des constructions en boucle. Mieux encore, l'une des constructions en boucle les plus utiles est capable d'énumérer les objets d'une collection et d'exécuter une ou plusieurs lignes de code pour chaque objet. Cette construction est fort justement appelée construction « Foreach » (littéralement, « pour chaque ») et se présente comme suit :
PS C:\> $names = get-content "c:\computers.txt"
PS C:\> foreach ($name in $names) {
>> Write-Host $name
>> }
>>
don-pc
testbed
J'ai commencé par demander à l'applet de commande Get-Content de Windows PowerShell d'extraire le contenu du fichier c:\computers.txt que j'ai créé moi-même et qui contient un nom d'ordinateur par ligne. Windows PowerShell traite chaque ligne en tant qu'objet ; ce fichier est donc essentiellement une collection contenant ces objets. Cette collection se termine par la variable $names. A l'aide du mot-clé Foreach, je demande à Windows PowerShell d'énumérer la collection $names, en utilisant la variable $name pour représenter l'objet actuel à chaque exécution de la boucle. Le code en boucle se trouve entre les accolades. Ainsi, je vais extraire chaque nom présent dans le fichier vers la ligne de commande. Et, comme vous pouvez le constater dans le résultat suivant la construction, c'est exactement ce que fait Windows PowerShell. L'avantage en termes de scripts d'administration est évident : vous pouvez facilement construire une liste de noms de serveurs, par exemple, et demander à Windows PowerShell d'en extraire les informations, chacun à son tour.

Constructions Real-World
A présent, utilisons les comparaisons logiques, la construction If et la construction Foreach pour créer un outil utile. Je souhaite vérifier rapidement l'état du service Messenger sur un ensemble de serveurs. Comme je m'attends à ce que ce service soit arrêté sur la plupart d'entre eux, je ne veux pas que Windows PowerShell répertorie tous les serveurs dont l'état est celui auquel je m'attends ; je souhaite uniquement une liste des serveurs où le service Messenger est effectivement démarré car ce sont ces derniers qui m'intéressent.
Je sais que l'applet de commande Get-Service de Windows PowerShell peut m'aider à extraire les informations dont j'ai besoin pour l'ordinateur local. Toutefois, je ne peux malheureusement pas atteindre un ordinateur distant, ce qui est en fait mon objectif réel. Fort heureusement, je peux également accéder aux mêmes informations via WMI (Windows Management Instrumentation) à l'aide de l'applet de commande Get-WMIObject, lequel me permet de travailler avec un ordinateur distant. Voici donc le script :
$names = get-content c:\computers.txt
foreach ($name in $names) {
  $svc = get-wmiobject win32_service '
   -computer $name -filter "name='messenger'"
  if ($svc.started -eq $True ) {
    write-host "$name has Messenger running"
  }
}
Notez la présence du caractère ' sur la troisième ligne. Ce dernier indique à Windows PowerShell que la ligne suivante en est la suite. Ce caractère s'avère utile lorsque la ligne entière ne peut pas tenir dans le magazine et nécessite un renvoi à la ligne suivante. Notez également que ma construction If compare $svc.started à $True. La variable $True est une variable spéciale de Windows PowerShell qui représente la valeur booléenne True (vrai). (La variable associée, $False, représente la valeur booléenne False (faux).) En fait, j'aurais pu prendre un petit raccourci :
$names = get-content c:\computers.txt
foreach ($name in $names) {
  $svc = get-wmiobject win32_service '
   -computer $name -filter "name='messenger'"
  if ($svc.started) {
    write-host "$name has Messenger running"
  }
}
N'oubliez pas que la condition de la construction If (si) doit simplement être True (vrai) ou False (faux). Normalement, en comparant deux valeurs, vous obtenez un résultat True (vrai) ou False (faux), comme je l'ai fait dans la première version de ce script. Toutefois, la propriété Started étant soit True (vrai) soit False (faux), il n'est pas nécessaire de la comparer effectivement à ces résultats.

Un outil utile
En conclusion, voici un outil d'administration simple qui se sert de constructions pour effectuer sa tâche. Qu'il soit écrit de manière interactive dans Windows PowerShell ou enregistré dans un fichier PS1 afin de pouvoir le réutiliser aisément, cet outil facile à gérer vous permet de vérifier l'état d'un service sur divers ordinateurs et vous démontre à quel point les constructions s'avèrent utiles dans l'automatisation des tâches d'administration.

Don Jones est le directeur des projets et services de SAPIEN Technologies et le co-auteur de Windows PowerShell : TFM (SAPIEN Press, 2006). Pour contacter Don, rendez-vous sur son site Web à l'adresse suivante : ScriptingAnswers.com.


 H&#233;, le scripteur&#160;!: Attention &#224; ce que tu dis
Hé, le scripteur !
Attention à ce que tu dis
Les scripteurs Microsoft

Pendant la Guerre de Sécession (au cours de la bataille de Spotsylvania, pour être précis), le général nordiste John Sedgwick fut consterné par le spectacle de ses hommes se jetant à terre au moindre coup de feu tiré dans leur direction par les tireurs confédérés embusqués. Selon la légende, Sedgwick dit à ses hommes : « Vous me faites honte, à vous coucher ainsi. Ils n'atteindraient même pas un éléphant à cette distance ». Quelques instants plus tard, Sedgwick devenait l'officier nordiste mort au combat le plus gradé. Peut-être les tireurs confédérés ne pouvaient-ils pas atteindre un éléphant à cette distance, mais, pour le malheur de Sedgwick, ils pouvaient atteindre un général.
Bien sûr, il va sans dire que la morale de cette histoire est... en fait, maintenant qu'on en parle, « Couchez-vous si on vous tire dessus » ferait une assez bonne morale, vous ne pensez pas ? Dommage qu'on n'y ait pas pensé plus tôt ! À la place, on a conclu ceci : « Faites attention à ce que vous dites, ça peut se retourner contre vous ». Le général Sedgwick a pu le vérifier, comme d'autres après lui. Par exemple, personne ne se souvient de Thomas Watson, dirigeant de longue date d'IBM, comme d'un des grands entrepreneurs de l'histoire américaine. Quand on pense à Watson, on pense plutôt à celui qui a dit un jour « Je pense qu'il existe un marché mondial pour environ cinq ordinateurs ».
Pour être honnête, il n'existe aucune preuve que Watson ait jamais fait cette déclaration. Peut-être d'ailleurs s'est-il contenté de reprendre les propos d'un autre à ce sujet ? Mais qui s'en soucie ? L'idée que le PDG d'IBM ait pu dire une chose pareille est trop belle pour que l'on s'embarrasse de la vérité, n'est-ce pas ?
En revanche, Watson a bel et bien dit « Si vous voulez réussir, doublez votre taux d'échec ». Voici un conseil que les scripteurs ont adopté sans réserve.
Au moins, la partie qui concerne le taux d'échec.
Il y a aussi cette citation : « Si vous écrivez des scripts VBScript, vous n'avez pas accès à .NET Framework ». Affirmer que le Microsoft® .NET Framework est inaccessible aux scripteurs n'est pas aussi mémorable que « Ils n'atteindraient pas un éléphant à cette distance » ou « Je pense qu'il existe un marché mondial pour environ cinq ordinateurs ». Mais il est tout aussi farfelu. Il est vrai que .NET Framework a d'abord été conçu en pensant aux développeurs C# et Visual Basic®, et il est vrai que VBScript ne peut pas instancier les classes .NET Framework natives. Mais cela ne veut dire que .NET Framework est inaccessible aux scripteurs, au moins pas entièrement.
Mais bon, on vous l'accorde : on ne peut nier que la majorité des classes .NET Framework restent hors des limites de VBScript. Toutefois, il existe un nombre raisonnablement important de classes .NET dotées de wrappers CCW (COM Callable Wrapper), ce qui signifie simplement que ces classes comprennent une interface COM qui les rend accessibles à un langage de script comme VBScript. Vous avez du mal à le croire ? Jetez donc un coup d'œil à la section HKEY_CLASSES_ROOT de votre registre, illustrée à la figure 1. Vous devriez y voir toutes sortes de classes commençant par System.
Figure 1 Classes système dans le Registre
Figure 1 Classes système dans le Registre (Cliquer sur l'image pour la réduire)
Figure 1 Classes système dans le Registre
Figure 1 Classes système dans le Registre (Cliquer sur l'image pour l'agrandir)
La plupart de ces classes sont des classes .NET Framework, et la plupart peuvent être instanciées par VBScript.
On vous l'avait bien dit !
Bien sûr, comme tous ceux qui ont acheté un produit sur une chaîne de télé-achat vous le diront, ce n'est pas parce que vous pouvez faire quelque chose que vous devez le faire (il y a souvent une raison pour laquelle ces produits ne sont pas vendus dans le commerce). Bien sûr, vous pouvez créer une instance de la classe System.ContextMarshalException dans un script. En ce qui nous concerne, nous n'avons aucune idée de ce qui pourrait vous inciter à le faire ou de ce que vous pouvez en faire.
Mais cela n'est pas le cas de toutes les classes .NET Framework. Par exemple, l'un des grands croque-mitaines du monde des scripteurs est le fait qu'il n'existe aucun moyen de trier facilement une liste d'éléments. Pour mettre une liste dans l'ordre alphabétique, vous devez soit utiliser un jeu d'enregistrements déconnecté, soit créer une fonction de tri complexe, de votre cru, dans le style de la suivante (les petites natures sont priées d'ignorer le paragraphe ci-dessous) :
For i = (UBound(arrNames) - 1) to 0 Step -1
    For j= 0 to i
        If UCase(arrNames(j)) >
          UCase(arrNames(j+1)) Then
            strHolder = arrNames(j+1)
            arrNames(j+1) = arrNames(j)
            arrNames(j) = strHolder
        End If
    Next
Next
Ne vous inquiétez pas : c'est nous qui avons écrit le code et nous ne sommes pas sûrs de savoir ce qu'il fait, non plus.
Alors en quoi .NET Framework peut-il nous aider dans une situation comme celle-ci ? Pour répondre à cette question, intéressons-nous à ce petit script tout simple :
Set DataList = CreateObject _
      ("System.Collections.ArrayList")

DataList.Add "B"
DataList.Add "C"
DataList.Add "E"
DataList.Add "D"
DataList.Add "A"

DataList.Sort()

For Each strItem in DataList
    Wscript.Echo strItem
Next
Comme vous le voyez, nous sommes en train de créer une instance de la classe .NET Framework System.Collections.ArrayList. Nous utilisons ensuite la méthode Add pour ajouter cinq éléments à la liste. Tout cela est bien joli, à cette exception près : nous avons ajouté ces éléments d'une manière un peu aléatoire (B, C, E, D, A), mais nous devons afficher les éléments dans l'ordre alphabétique (A, B, C, D, E). C'est le moment de pondre un petit code maison, non ?
Non. (Désolé d'être aussi catégorique, mais non, c'est non). En fait, nous n'avons pas à pondre le moindre code, il nous suffit d'appeler la méthode Sort de la liste de tableau :
DataList.Sort()
C'est tout. Avec une seule ligne de code, nous pouvons trier tous les éléments de notre liste.
Une preuve ? Vous êtes bien exigeants ! Pas de problème. Nous nous attendions à en avoir un ou deux coriaces dans le public. C'est pour cette raison que le script comprend une boucle For Each qui s'exécute en boucle sur tous les éléments de la liste, faisant écho à la valeur de chaque élément à l'écran :
For Each strItem in DataList
    Wscript.Echo strItem
Next
Une question pour vous à présent : qu'obtenons-nous en exécutant ce script ?
Bien vu !
A
B
C
D
E
Pas mal, hein ?
Hmmm, apparemment certains d'entre-vous ne sont pas entièrement convaincus. Vous vous dites que tout cela est très bien, mais que tout ce que vous vouliez, c'était renvoyer ces valeurs en écho dans l'ordre décroissant afin d'obtenir une liste de Z à A plutôt que de A à Z. Et si vous n'obtenez pas cela, et bien... . .
Aucun problème. Il suffisait de le demander :
Set DataList = CreateObject _
      ("System.Collections.ArrayList")

DataList.Add "B"
DataList.Add "C"
DataList.Add "E"
DataList.Add "D"
DataList.Add "A"

DataList.Sort()
DataList.Reverse()

For Each strItem in DataList
    Wscript.Echo strItem
Next
Vous avez raison : cela ressemble beaucoup au script qu'on vous a montré, pas vrai ? Il contient toutefois un ajout important. Jetez donc un coup d'œil à la ligne de code que nous avons ajoutée, une ligne qui suit directement la méthode Sort :
DataList.Reverse()
Vous la voyez ? Après avoir trié la liste en ordre croissant, nous avons appelé la méthode Reverse qui, comme vous vous en doutez, inverse l'ordre de tous les éléments dans la liste de tableau. Et qu'obtenons-nous ? Un résultat comme celui-ci :
E
D
C
B
A
C'est fort, non ?
Mais attendez ! Ce n'est pas fini ! Avez-vous déjà essayé de supprimer un élément dans un tableau VBScript ? Allons, ne pleurez pas, on ne va pas vous demander de le faire. À la place, nous allons vous montrer comme il est facile de supprimer un élément de notre liste .NET Framework. Vous n'aimez pas la lettre D ? Débarrassez-vous-en. Voici un script qui crée une liste de tableau, la trie, puis supprime ensuite l'entrée de la lettre D :
Set DataList = CreateObject _
  ("System.Collections.ArrayList")

DataList.Add "B"
DataList.Add "C"
DataList.Add "E"
DataList.Add "D"
DataList.Add "A"

DataList.Sort()
DataList.Remove("D")

For Each strItem in DataList
    Wscript.Echo strItem
Next
Une fois encore, notez bien la petite ligne de code qui suit immédiatement la méthode Sort :
DataList.Remove("D")
Ici, nous avons utilisé la méthode Remove pour supprimer l'élément égal à D. Et voici ce que nous avons obtenu en exécutant le script :
A
B
C
E
Hasta la vista, D !
Et ne ratez pas le meilleur : il est possible de supprimer un élément sans avoir à redimensionner le tableau. Ça c'est sympa. Bien sûr, nous aurions également pu ajouter des éléments dans le tableau sans avoir à redimensionner quoi que ce soit. Et ne nous dites pas que ça ne vous facilitera pas la vie.
Croyez-le si vous voulez, nous n'en sommes qu'au début des possibilités de la liste de tableau .NET Framework (pour plus d'informations, consultez l'entrée liste de tableau dans le SDK .Net Framework).
La liste de tableau est-elle utile pour les scripteurs ? Disons cela comme ça : après avoir vu la liste de tableau .NET Framework à l'œuvre, nous ne voyons pas pourquoi vous voudriez utiliser le tableau VBScript intégré, en tous cas pas pour les simples listes d'éléments telles que celles que nous avons utilisées ici.
Force est de reconnaître que nous autres, scripteurs, n'avons pas exactement fait une étude exhaustive de .NET Framework afin de déterminer quelles classes pourraient être utiles aux scripteurs (ni les classes totalement inutiles, d'ailleurs). Nous y travaillons. D'ici-là, n'hésitez pas à piocher dans le SDK .Net Framework. Il semble que chaque fois que nous parcourons le SDK, nous y trouvons quelque chose de nouveau et d'intéressant pour les scripteurs.
Comme quoi ? Par exemple, générer des nombres aléatoires. Vous voulez générer un nombre aléatoire entre 1 et 100 à l'aide du générateur de nombre aléatoire VBScript ? Aucun problème. Il vous suffit d'utiliser un code comme celui-ci :
Randomize
Wscript.Echo Int((100 - 1 + 1) * Rnd + 1)
Vous avez retenu cette formule ? Ne vous inquiétez pas si ce n'est pas le cas. Il est beaucoup plus facile et intuitif d'utiliser la classe System.Random de .NET Framework :
Set objRandom = CreateObject("System.Random")
Wscript.Echo objRandom.Next_2(1,100)
Il est probable que vous vous en rendiez compte par vous-même. Quoi qu'il en soit, nous allons tout de même vous donner une petite explication, ne serait-ce que parce que TechNet Magazine considère que les chroniqueurs sont censés écrire quelque chose tous les mois. (Ne nous demandez pas pourquoi, c'est leur idée, pas la nôtre...).
Comme vous le voyez, nous créons une instance de la classe System.Random, puis appelons la méthode Next_2, en lui transmettant deux paramètres :
  • 1, le premier nombre de notre plage (comprise, si vous vous en souvenez, entre 1 et 100).
  • 100, le nombre le plus élevé de notre plage.
C'est tout ce que nous avons à faire.
Il nous reste un peu de temps pour une dernière question. Oui, vous avec la chemise verte. Qui disait que les scripteurs ne pouvaient pas accéder à .NET Framework ? Pour être tout à fait honnête, quand on a commencé, on... heu, l'oreillette me dit que nous n'avons plus le temps ! Au mois prochain !
De bons moments en perspective !
Février n'est plus très loin, vous voyez à quoi je fais allusion ? Non, pas la Saint-Valentin. Non, pas mon anniversaire. Mais quoi ? Mardi gras ? Mais non, plus février approche, plus on s'approche des Jeux de script d'hiver 2007, la compétition internationale de script la plus prestigieuse du monde (et probablement la seule !). Les Jeux de cette année promettent d'être plus grandioses et plus réussis que jamais. Pour la première fois, nous aurons quatre divisions :
  • Débutants VBScript
  • VBScript avancé
  • Débutants Windows PowerShell™
  • Windows PowerShell avancé
Consultez la page d'accueil des Jeux de script d'hiver 2007 pour en savoir plus.
Qu'est-ce que c'est ? Oh, merci. Et, euh, joyeux Mardi Gras à vous aussi.

Téléchargez Windows PowerShell dès aujourd'hui.
Windows PowerShell 1.0 est maintenant disponible au téléchargement. Il est même gratuit ! Comment pouvez-vous résister à cette offre ? Téléchargez le logiciel et commencez à l'utiliser dès aujourd'hui.

Les scripteurs Microsoft travaillent pour - enfin, sont employés par - Microsoft. Lorsqu'ils ne sont pas en train de jouer au base-ball, d'entraîner une équipe ou de regarder un match (ou de se livrer à de multiples autres activités), ils dirigent le Script Center TechNet. Vous pouvez le vérifier vous-même sur www.scriptingguys.com.


 Exchange Queue &amp; A: Nous avons toutes les r&#233;ponses (car c'est nous qui avons imagin&#233; les questions que vous pourriez poser)
Exchange Queue & A
Nous avons toutes les réponses (car c'est nous qui avons imaginé les questions que vous pourriez poser)
KC Lemson and KC Lemson

Bonjour et bienvenue dans le premier article de Exchange Queue and A ! Nous donnons le coup d'envoi avec une série de questions que nous avons élaborées nous-mêmes. Par conséquent, cela paraît probablement illogique de considérer ce numéro comme une vraie chronique de questions-réponses
car les authentiques Q&R constituent une chambre d'écho. Cependant, nous sommes persuadés que ces questions sont représentatives des préoccupations des clients Microsoft® Exchange Server et nous les revendiquons haut et fort. À l'avenir, vos questions seront les bienvenues, donc n'hésitez pas à les envoyer à l'adresse queuea@microsoft.com.
Nous envisageons une chronique écrite par une équipe tournante de rédacteurs (les plus persévérants resteront !) qui ont tous été impliqués dans le développement Exchange depuis de nombreuses années. Ce mois-ci les réponses (et les questions !) ont été coécrites par KC Lemson et Paul Bowden, responsables en chef de programme de l'équipe Exchange Server à Microsoft. Nous sommes tous les deux participants de la première heure au développement d'Exchange. Bien que nous ayons souvent bougé, nous n'avons jamais pu nous séparer de notre messagerie.
KC a travaillé dans le groupe Exchange pendant les six dernières années au cours desquelles elle a occupé plusieurs fonctions notamment celles de responsable de programme pour Microsoft Outlook® Web Access (OWA) et de responsable en chef de programme, chargée du programme client des versions préliminaires d'Exchange. Elle est actuellement responsable de l'environnement utilisateur pour Exchange, chargée de la conception des produits et des études de clientèle. Avant de rejoindre Exchange, elle a été testeur d'Outlook pendant trois ans et responsable des tests de pièces jointes à un moment où l'on considérait que ce n'était recommandé de bloquer des pièces jointes exécutables dans les messages électroniques. Consultez le blog de KC à l'adresse blogs.technet.com/kclemson.
Paul a passé les trois dernières années à travailler sur le merveilleux petit outil Exchange Best Practices Analyzer (ExBPA). En effet, il y a deux mois, il a gagné une récompense pour ses travaux et a été photographié avec Bill Gates. Cependant, avec la fin du projet Exchange Server 2007, il est temps de tourner la page. Paul doit arrêter de rêver de XML et revenir parmi nous. Il deviendra responsable de version pour la prochaine version d'Exchange (celle sur laquelle nous commencerons à travailler dès la sortie d'Exchange Server 2007).
À propos, avez-vous apprécié notre humour débordant pour nommer cette chronique ? Mais, évidemment, nous ne pouvons même pas nous attribuer le mérite de ce nom, il a été suggéré par un lecteur du blog de KC. (Nous espérons que vous appréciez le T-shirt, Tim !) Les autres suggestions étaient « Pushing the Envelope » et « When I'm X64", que KC a tellement apprécié qu'elle a enregistré www.whenimx64.com et l'a redirigé vers son blog parce qu'elle pouvait tout simplement le faire. Si seulement nous disposions d'autant de pouvoir sur tous les événements de notre vie !
Note rapide : KC a d'abord proposé de nommer cette colonne « The Monthly Queue and A » jusqu'à ce que notre éditeur fasse remarquer avec pertinence que le nombre de rédacteurs est inconnu et que notre capacité à faire des publications régulières n'est pas fiable (sa réponse était plus polie et moins directe, mais nous devinions sa pensée). De même, nous n'avons aucune idée des commentaires que feront les lecteurs sur cette chronique. Nous nous sommes donc mis d'accord sur le nom de la chronique et vous êtes invités à nous donner votre opinion à l'adresse queuea@microsoft.com.
Voyons sans plus attendre les questions...

Q : Pourquoi devrais-je être intéressé par Exchange Server 2007 ?
R : Nous nous rendons compte qu'il est risqué de lancer la première rubrique avec une question essentiellement marketing mais nous sommes tellement passionnés par Exchange Server 2007 que nous tenons vraiment à le partager avec vous. Donc nous essaierons de limiter « l'architecture marketing » dans cette réponse et expliquerons plutôt les nombreuses raisons techniques qui peuvent inciter un administrateur ou un utilisateur Exchange à se passionner pour Exchange 2007, d'un fan à un autre.

Améliorations de l'évolutivité et des performances
La première raison évidente : 64 bits. Quel est l'intérêt, me demanderez-vous ? Windows® 32 bits ne peut prendre en charge qu'un total de 4 Go (232 octets) de mémoire et 2 Go sont utilisés par défaut par le noyau, laissant seulement 2 Go pour les applications. La version actuelle de Windows prend en charge un commutateur /3GB dans boot.ini qui donne aux applications jusqu'à 3 Go d'espace mémoire, mais une fois qu'ils sont utilisés, le noyau Windows devient vulnérable et il faut redémarrer rapidement ce serveur pour récupérer des ressources.
Heureusement, une prise en charge 64 bits, ainsi que des modifications significatives au moteur de base de données sous-jacent (JET) dans Exchange, résout ce problème. Puisque les serveurs Exchange sont traditionnellement beaucoup plus liés par les E/S de disque que par toutes les autres ressources système (tel que l'UC), ajouter de la mémoire au système signifie que vous pouvez réduire de manière significative les E/S de disque en gardant plus d'informations en mémoire au lieu d'avoir à lire le disque. Par conséquent, avec Exchange 2007 vous pouvez prendre en charge de plus grandes boîtes aux lettres pour vos utilisateurs avec un matériel physique équipé de la même façon qu'avec Exchange 2003. Le serveur de messagerie dont je dispose à Microsoft, par exemple, prend en charge 4 000 utilisateurs avec un quota de boîte aux lettres de 2 Go, ce qui permet 6 téraoctets (To) de données. Il faut souligner que le fait qu'Exchange 2007 dispose de plus de mémoire ne signifie pas qu'il en ait besoin. Nous avons testé une boîte exécutant Windows Server® 2003 à 32 bits et Exchange 2003 avec une mémoire à 4 Go ou inférieur, installé Windows Server 2003 à 64 bits et Exchange 2007, et avons constaté des performances similaires.
Exchange 2007 inclut également deux nouvelles façons d'améliorer la disponibilité : Réplication continue en cluster (Clustered Continuous Replication, CCR) et réplication continue locale (Local Continuous Replication, LCR). Ces technologies réduisent le risque d'une défaillance de stockage entraînant des problèmes sérieux. La LCR garde une copie locale de vos bases de données sur le même ordinateur, mais vous pouvez les placer sur différents supports de stockage. La CCR peut faire de même entre deux ordinateurs sur un réseau. La CCR, combinée avec les améliorations d'E/S de disque dont nous avons parlé auparavant dans cette rubrique, ouvre de nouvelles options pour le matériel de stockage. Si vous souhaitez utiliser des supports de stockage à connexion directe tels que les disques SATA ou SCSI, c'est désormais une option beaucoup plus rentable et qui améliore les performances.

Administration
Microsoft a investi lourdement dans une nouvelle expérience d'administration avec Exchange 2007, qui inclut l'interface de ligne de commande illustrée dans la figure 1. Elle est appelée Exchange Management Shell (EMS) et est basé sur Windows PowerShell™. Si vous n'êtes pas fan de la ligne de commande, c'est parfait, l'interface graphique est toujours présente, mais désormais elle s'appelle console de gestion Exchange (EMC) et est beaucoup plus intuitive que l'ancien Gestionnaire système (voir la figure 2). Si vous êtes déjà un fervent défenseur des interfaces de ligne de commande ou souhaitez le devenir, consultez l'EMS dans Exchange 2007.
Figure 1 État des groupes de stockage dans Exchange Management Shell
Figure 1 État des groupes de stockage dans Exchange Management Shell (Cliquer sur l'image pour la réduire)
Figure 1 État des groupes de stockage dans Exchange Management Shell
Figure 1 État des groupes de stockage dans Exchange Management Shell (Cliquer sur l'image pour l'agrandir)
Figure 2 Le même état dans la console de gestion Exchange
Figure 2 Le même état dans la console de gestion Exchange (Cliquer sur l'image pour la réduire)
Figure 2 Le même état dans la console de gestion Exchange
Figure 2 Le même état dans la console de gestion Exchange (Cliquer sur l'image pour l'agrandir)
Dans Exchange 2003, vous deviez parfois utiliser les scripts Windows Management Instrumentation (WMI) pour exécuter certaines tâches administratives plus complexes, mais avec EMS ces tâches peuvent être exécutées par toute personne qui voyant « CD C:\TEMP » ne pense pas que c'est l'album d'un nouveau groupe (ta pa toum). Puisque l'un d'entre nous est un ancien sysadmin UNIX et que notre objectivité peut être mise en doute, nous pouvons vous indiquer des tiers impartiaux qui vous assureront que le noyau est très intuitif même si vous n'avez jamais utilisé une ligne de commande avant (vous aurez plus d'informations à ce sujet dans la prochaine chronique Exchange Queue and A).
L'un des bienfaits de Windows PowerShell, c'est qu'il est orienté objet. Lorsque vous récupérez des informations du serveur, telles qu'une liste de boîtes aux lettres ou des connecteurs SMTP, les informations sont automatiquement stockées dans un objet ou une variable et transmises à stdout en tant que texte pour une lecture facile. Cet objet peut être ensuite transmis directement à une autre commande et utilisé dans le pipeline (dans ce cas, il transmet l'objet au lieu du texte, facilitant ainsi la modification des données ou l'utilisation de parties de celles-ci). Voici un exemple simple :
Get-Mailbox | Set-Mailbox -ProhibitSendQuota 250MB
La commande Get-Mailbox récupère une liste de boîtes aux lettres dans le système. Le | (appelé symbole de pipeline) indique que la sortie de la commande de gauche doit être transmise à la commande de droite. La partie suivante, « Set-Mailbox-ProhibitSendQuota 250MB » signifie que toutes ces boîtes aux lettres ont maintenant un quota tel qu'elles ne peuvent plus envoyer de message électronique après avoir atteint la taille de 250 Mo. Vous auriez pu également le définir à 250 000 000 ou à 250 000 Ko ou à .25 Go. Le noyau traite les données avec une grande souplesse.
Une autre amélioration administrative utile d'Exchange 2007 est la capacité de créer des règles de transport, à l'aide d'un assistant de règles comme celui d'Outlook pour appliquer la logique métier aux messages circulant à travers votre système. Vous souhaitez bloquer tous les messages électroniques qui semblent contenir des numéros de sécurité sociale dans le corps, sur la base d'une expression régulière ? Coché. Vous souhaitez installer un mur éthique pour que deux divisions de votre organisation ne puissent pas s'envoyer de messages électroniques ? Coché. Vous souhaitez ajouter une exclusion à tous les messages électroniques qui partent de votre organisation ? Coché.
Une dernière fonctionnalité administrative que nous apprécions beaucoup, ce sont les messages système personnalisables : Désormais, vous pouvez immédiatement ajouter votre propre texte personnalisé aux rapports de non remise et (enfin !) les utilisateurs de message sont informés lorsqu'ils ont dépassé leurs quotas de stockage.

Aide du service d'assistance
L'une des dépenses les plus importantes pour de nombreux clients, c'est le coût du support technique lié à la configuration de nouveaux profils dans Outlook. Avec Autodiscover dans Outlook 2007, il suffit de lancer Outlook et il cherchera automatiquement votre adresse de messagerie et récupérera vos informations sur Exchange Server à partir d'Active Directory® à l'aide du point de connexion de service. Si vous n'êtes pas connecté à Active Directory, il suffit d'entrer votre adresse de messagerie ainsi que votre mot de passe et la recherche Autodiscover peut télécharger un fichier XML d'un serveur Web spécifié (tel que http://autodiscover.contoso.com) qui contient des informations de configuration de base telles que le serveur à utiliser pour RPC sur HTTP (maintenant appelé Outlook).
Un autre coût de support technique est la gestion des faux positifs apparemment inévitables de votre filtre anti-spam. Les utilisateurs peuvent conserver dans Outlook des listes fiables d'expéditeurs dont les messages ne doivent pas être soumis au filtre de contenu, mais jusqu'à Exchange 2007 seules ces listes permettaient aux messages de contourner le filtre Outlook. Cependant, du fait que le filtre Exchange agit sur les messages avant même qu'Outlook ne les voit, les utilisateurs pouvaient encore manquer le message électronique des utilisateurs fiables.
Exchange 2007 constitue une aide précieuse : Si vous utilisez le filtre de contenu anti-spam avec le rôle serveur Edge ou Hub dans Exchange 2007, vous pouvez le configurer pour propager des listes utilisateur d'expéditeurs fiables sur ce serveur, pour que les messages de ces expéditeurs contournent le filtre de contenu anti-spam. Bien sûr, ce qui constitue du spam pour un utilisateur est une newsletter pour un autre, donc l'agrégation d'expéditeurs fiables s'effectue pour chaque utilisateur.

Satisfaction de l'utilisateur final
Avec la messagerie unifiée (MU) dans Exchange 2007, vous pouvez recevoir la messagerie vocale entrante et des télécopies dans votre Boîte de réception. (Si vous n'en avez jamais bénéficié avant, vous ne savez pas ce que vous manquez). Vous pouvez appeler également votre serveur Exchange et lui dire de notifier chaque participant de votre réunion de 8:00 heures du matin que vous êtes en retard. Même la plus petite organisation peut disposer facilement d'un standard automatique personnalisé et de qualité afin que votre système oriente les clients qui vous appellent. Pour utiliser la MU, vous aurez besoin d'un PBX basé sur IP (IP/PBX) ou vous pouvez connecter votre PBX commuté traditionnel à une passerelle VoIP (voix sur IP).
Link Access (accès aux liens) est une nouvelle fonctionnalité d'OWA 2007. Que se passe-t-il si vous êtes en déplacement sans client VPN installé et que vous devez afficher un document Microsoft Word sur un partage de fichiers ou un site Sharepoint® du réseau de l'entreprise ? Aucun problème, il suffit de charger OWA 2007, d'accéder au lien Documents et de saisir le nom du site Sharepoint ou du partage (http://mysharepointsite ou \\server\share) pour parcourir et ouvrir les fichiers. Bien sûr, il y a de nombreux contrôles de sécurité afin que les administrateurs verrouillent les éléments souhaités : tous les serveurs autorisés sauf une certaine liste, tous les serveurs refusés sauf une certaine liste, autorisation d'accès aux documents uniquement si les utilisateurs se connectent à OWA à partir d'ordinateurs privés, etc.
OWA inclut également l'affichage de document WebReady (ou « transcodage » en langage de fan) dans lequel vous pouvez demander à Exchange d'afficher certains types de fichier en HTML si l'application appropriée n'est pas installée localement. Exchange 2007 sera livré avec la prise en charge pour le transcodage des types de fichier suivants par défaut : DOC, DOT, RTF, WBK, WIZ, XLS, XLK, PPT, PPS, POT, PWS et PDF. L'architecture enfichable du moteur de transcodage permet d'ajouter une prise en charge des nouveaux types de fichier d'un Service Pack. Il comporte également des options administratives afin de déterminer quels types de fichier les utilisateurs sont autorisés à transcoder ou de rejeter totalement le transcodage.
Si vos périphériques mobiles sont synchronisés avec Exchange ActiveSync®, vous serez ravis d'apprendre que lorsque vous transférez un thread de message électronique ou que vous y répondez, ce message ne sera plus converti en texte brut. Votre texte est ajouté en haut, mais le corps HTML du reste du message reste tel quel. Cela est valable pour tous les périphériques qui prennent en charge ActiveSync et ne nécessite aucune fonctionnalité dans le client.

Q : J'ai entendu dire qu'Exchange 2007 est « en 64 bits uniquement pour la production ». Qu'est-ce que cela signifie ?
R : Exchange 2007 est disponible en 32 bits et en 64 bits. La version 64 bits est destinée à une utilisation « live » pour la production de rôles serveur de base (boîte aux lettres, transport Hub, transport Edge, accès client, messagerie unifiée). La version 32 bits est destinée à l'évaluation des nouvelles fonctionnalités Exchange 2007. Les outils d'administration peuvent également être utilisés en 32 bits en production, afin que vous puissiez gérer vos serveurs de production Exchange 2007 en 64 bits à partir de votre ordinateur de bureau Windows XP 32 bits. Notez également que le schéma Exchange 2007 doit être installé sur un ordinateur du domaine. Exchange lui-même n'a pas besoin d'être installé dans le domaine racine, mais il est nécessaire que l'extension de schéma ait lieu dans le domaine racine comme moyen d'assurer une bonne connectivité réseau au contrôleur de schéma. Si vous ne disposez pas d'un serveur 64 bits dans ce domaine, vous pouvez utiliser le setup.exe de la version 32 bits pour étendre le schéma.
Quel est le problème avec les serveurs 32 bits, me demandez-vous ? Si vous avez eu le plaisir d'exécuter des milliers d'utilisateurs sur un seul serveur, vous savez que cela peut être un acte d'équilibrage entre les performances et la stabilité avec les limitations de mémoire que nous avons décrites précédemment. Si vous avez acheté un nouvel ordinateur au cours des deux dernières années, il est probable qu'il prenne déjà en charge les extensions x64. Actuellement, il est assez difficile d'acheter un nouvel ordinateur qui ne prend pas en charge le mode 64 bits. Ainsi, il se peut que l'ordinateur exécutant déjà Exchange dans votre environnement soit compatible 64 bits, mais qu'il exécute un système d'exploitation 32 bits. Cela nous amène à un point important : une fois en possession de votre nouvel ordinateur compatible 64 bits, n'oubliez pas d'installer la version 64 bits de Windows Server 2003 SP1.
Alors pourquoi tous ces avertissements lors de la configuration pour ne pas utiliser les installations 32 bits en production ? Bien qu'il soit assez facile de compiler Exchange de différentes façons, chaque composant est optimisé à 100 % et paramétré pour 64 bits (certains chemins de code que nous avons choisis pour optimiser les E/S de disque sur des systèmes 64 bits entraînent une dégradation des performances dans les environnements 32 bits). En fait, lorsque vous testez le produit avec 32 bits, il ne faut même pas envisager qu'il s'exécutera sous la charge (simulée ou autre). Vous aurez une image erronée de la manière dont il s'exécutera dans un système 64 bits ou du nombre d'utilisateurs que vous pouvez accueillir sur le serveur.
Alors tout est clair ? Vous pouvez utiliser la version 32 bits d'Exchange 2007 pour :
  • Évaluer les nouvelles fonctionnalités sur un serveur de test sans boîtes aux lettres d'utilisateur live.
  • Saliver devant la nouvelle console d'administration, le noyau ou l'interface OWA (mais faites attention au clavier, quand même).
  • Administrer vos serveurs Exchange 2007.
  • Étendre le schéma dans votre forêt Active Directory.
Lorsque vous êtes prêt à déplacer des boîtes aux lettres, il est nécessaire que les serveurs exécutent un système d'exploitation 64 bits avec Exchange 2007 à 64 bits. Sinon, l'installation et ExBPA vous avertiront par bip (voir la figure 3). Paul le sait car c'est lui qui a écrit le code !
Figure 3 Installation de 32 bits lorsque vous ne pouvez installer que 64 bits
Figure 3 Installation de 32 bits lorsque vous ne pouvez installer que 64 bits (Cliquer sur l'image pour la réduire)
Figure 3 Installation de 32 bits lorsque vous ne pouvez installer que 64 bits
Figure 3 Installation de 32 bits lorsque vous ne pouvez installer que 64 bits (Cliquer sur l'image pour l'agrandir)

Q : De combien de mémoire ai-je besoin pour exécuter Exchange 2007 ?
R : Votre installation de base requiert au moins 1 Go de RAM physique. Comme je l'ai expliqué précédemment, certains rôles de serveur sont assez lourds à gérer. Si vous envisagez d'installer un serveur tout-en-un (avec boîte aux lettres, accès client, transport Hub et messagerie unifiée), vous pouvez démarrer avec 2 Go de RAM et évoluer en fonction du nombre de boîtes aux lettres et de leur utilisation. Si vous envisagez d'installer le rôle Edge ou un cluster, ceux-ci doivent être installés sur des ordinateurs séparés. Seul le rôle de boîte aux lettres peut être installé sur un cluster, rien d'autre.
Vous serez ravis de savoir que vous pouvez enfin installer plus de 4 Go de RAM dans votre serveur Exchange. De nombreux ordinateurs actuels sont livrés avec 6 ou 8 Go. Il est toujours insupportable de supprimer ces modules de données à double fréquence (DDR) ou d'utiliser /BurnMemory pour diminuer la RAM à 4 Go (malheureusement, Exchange 2003 s'exécutera moins bien et sera moins stable si vous avez plus de 4 Go, consultez le site go.microsoft.com/fwlink/?LinkId=76537 pour plus d'informations).
Pour vos serveurs d'infrastructure (hubs, accès client, etc.) 4 Go de RAM seront suffisants, même avec la charge la plus lourde. Vous souhaitez investir surtout dans vos serveurs de boîtes aux lettres. Ce cache JET 64 bits récemment optimisé utilisera autant de mémoire que vous souhaitez. Bien entendu, contrairement à Exchange 2003, Exchange 2007 prend en charge jusqu'à 50 groupes de stockage.
Même si chaque groupe de stockage peut prendre en charge plusieurs bases de données, cela ne servira à rien, surtout que la LCR et la CCR (les deux types de réplication de base de données que nous avons abordés précédemment) ne peuvent fonctionner qu'avec des groupes de stockage ayant une seule base de données. Vous devrez certainement ajouter une RAM supplémentaire si vous souhaitez créer des groupes de stockage ou que vous rêvez de disposer de boîtes aux lettres de plus de 2 Go pour chaque utilisateur. Vous trouverez des informations importantes et détaillées concernant la taille de la RAM sur le blog de l'équipe Exchange, mais les figures 4 et 5 fournissent des cartes de référence pour vous initier.
Figure 5 RAM et groupes de stockage (Close Figure 5)

RAM physique | Nombre maximum de groupes de stockage recommandé
2 Go | 2
4 Go | 8
8 Go | 24
12 Go | 40
16 Go+ | 50
Figure 4 RAM par type d'utilisateur (Close Figure 4)

Type d'utilisateur | Mémoire de rôle de boîte aux lettres recommandée
Faible | Base 2 Go + 2 Mo par boîte aux lettres
Moyen | Base 2 Go + 3,5 Mo par boîte aux lettres
Élevé | Base 2 Go + 5 Mo par boîte aux lettres
À propos, Microsoft IT utilise un certain nombre de groupes de stockage, multiple de sept, parce qu'ils ont une planification de sauvegarde tournante qui prévoit qu'un jour donné, seuls quelques groupes de stockage sont sauvegardés. Nous appelons cette planification « sauvegardes canne à sucre » car sur la feuille de calcul Excel qui décrit la planification de sauvegarde, les groupes de stockage sauvegardés un jour donné sont représentés en rouge et en cascade. Nous espérons que ces informations étaient utiles. Envoyez de « vraies » questions pour le prochain numéro.

KC Lemson est responsable en chef de programme de l'équipe Exchange Server. Elle consacre son temps libre à assurer la protection des fonds du fameux prince du Nigeria.
KC Lemson est responsable en chef de programme de l'équipe Exchange Server. Elle consacre son temps libre à assurer la protection des fonds du fameux prince du Nigeria. Paul Bowden est également responsable en chef de programme de l'équipe Exchange Server. Il consacre le plus clair de son temps libre à reconfirmer ses informations de compte PayPal sur demande.


 Surveillance de la s&#233;curit&#233;: Renforcement des services dans Windows Vista
Surveillance de la sécurité
Renforcement des services dans Windows Vista
Wole Moses

Microsoft a annoncé son initiative Trustworthy Computing Initiative au début de l'année 2002, à la suite de l'apparition de plusieurs virus et vers de haut niveau, ayant ravagé les systèmes Windows et paralysé des services informatiques, et dont la résolution a coûté des sommes énormes aux entreprises et aux consommateurs. Dans le cadre de cette initiative, Microsoft a publié un
mea culpa en ce qui concerne ses résultats en matière de sécurité et a opéré un changement de cap rapide et un changement de paradigme en passant du développement de logiciels mettant l'accent sur la richesse des fonctionnalités et la convivialité à de nouvelles priorités : la sécurité et l'intégrité des logiciels. Le ver Blaster a frappé en août 2003, ce qui a donné un coup de fouet à l'initiative de sécurité. (Pour connaître l'histoire de Blaster, consultez l'encadré « L'attaque des clones ».)
Les principes de cette initiative informatique sont « Sécurisation par conception », qui concerne les philosophies de codage sécurisé, « Sécurisation par défaut », qui consiste à garantir que les composants Windows® se configurent par défaut sur le paramètre le plus sûr possible, et « Sécurisation dans le déploiement », qui concerne la création d'outils et de conseils préventifs destinés à aider les entreprises et les consommateurs à sécuriser leur infrastructure Windows.
Dans l'ensemble, l'initiative Trustworthy Computing Initiative s'est traduite par améliorations majeures de la sécurité. Malheureusement, Windows XP n'a jamais pu en bénéficier entièrement car il a été publié deux années avant le début de l'initiative. (Bien que le Service Pack 2, SP2, ait fait d'énormes progrès pour incorporer ces philosophies, Windows XP ne pouvait pas être complètement intégré dans cette initiative).
Ainsi, Windows Vista™ est le premier système d'exploitation de bureau Microsoft répondant entièrement aux objectifs d'une informatique fiable. Le Renforcement des services Windows Vista, une mise en œuvre spécifique du principe Sécurisation par défaut (voir Figure 1), représente une nouvelle fonctionnalité essentielle conçue pour contrecarrer les comportements de service déviants d'une bonne partie des logiciels malveillants actuels. Le renforcement des services permet à Microsoft de prendre des mesures importantes pour modifier le comportement par défaut et le profil de sécurité des services Windows.
Figure 1 Sécurisation par défaut : Services Windows (Close Figure 1)

Fonctionnalité | Description | Résultat
Privilège minimal | Les services de Windows Vista sont configurés pour utiliser le minimum de privilèges nécessaires pour s'exécuter. | Windows Vista réduit les privilèges de sécurité par défaut accessibles aux services Windows, ce qui diminue l'impact potentiel des logiciels malveillants.
Isolation de services | Les SID de service permettent d'autoriser des services à s'exécuter dans les comptes à faibles privilèges. | Windows Vista peut contrecarrer les logiciels malveillants en limitant l'accès à ses ressources en fonction des SID des services.
Accès réseau limité | Des restrictions de réseau sont mises en œuvre par défaut sur tous les services Windows Vista. | Windows Vista empêche les logiciels malveillants d'utiliser des services pour effectuer des activités réseau illégitimes.
Isolation de la session 0 | La session 0 est réservée aux services. | Windows Vista empêche les applications malveillantes de détourner des services à privilèges élevés en utilisant des attaques par messages puisqu'ils ne sont plus exécutés dans la même session.

Services à haut risque
Les services Windows, anciennement appelés services NT, sont des applications exécutables de longue durée qui s'exécutent au sein de leurs propres sessions Windows. Ils peuvent être lancés automatiquement au démarrage de l'ordinateur, arrêtés et redémarrés. Ils n'affichent généralement pas d'interface utilisateur et peuvent s'exécuter dans le contexte de la sécurité d'un compte différent de celui de l'utilisateur connecté ou du compte d'ordinateur par défaut. Les services Windows sont ainsi très utiles pour certains types de développement d'applications et pour les utilisateurs finaux qui ont besoin de ces applications. Cependant, du fait de leur puissance et de leur flexibilité, les services Windows ont toujours été vulnérables à une exploitation malveillante, et ce pour plusieurs raisons.
Premièrement, dans le passé, les services Windows s'exécutaient généralement dans des comptes Windows à privilèges élevés, tel que le compte LocalSystem. Si un service s'exécutant dans le compte LocalSystem est compromis par un logiciel malveillant, ce dernier a une forte chance de pouvoir faire tout ce qu'il désire sur ce système. Considérons, par exemple, le service d'appel de procédure distante (RPC) dans Windows XP. Avant Windows XP SP2, le service RPC fonctionnait sous le compte LocalSystem, ce qui permettait à Blaster, Welchia et à d'autres vers d'exécuter des tâches administratives une fois qu'ils avaient exploité la vulnérabilité de RPC.
Deuxièmement, de nombreux services sont orientés vers le réseau, ce qui fournit au logiciel malveillant la possibilité de les exploiter en créant des connexions entrantes vers eux via le réseau, et à un service infecté la possibilité de créer une connexion sortante pour infecter d'autres systèmes ou exécuter une autre activité illicite telle que transférer des séquences de frappe contrôlées. La plupart des infections de vers et de logiciels malveillants actuelles surviennent par le biais une méthode de connexion réseau.
En fait, les services sont généralement exécutés sur une longue période, ce qui signifie qu'ils s'exécutent depuis le moment où un système démarre et jusqu'à son arrêt. Ceci est intéressant pour les auteurs de logiciels malveillants parce que cela signifie qu'ils peuvent sonder les failles de ce service aussi longtemps que le système est activé, ce qui laisse finalement au logiciel malveillant tout le temps nécessaire pour mettre en œuvre ses activités de nuisance.

L'attaque des clones
Ce pourrait être son plus grand triomphe. Si tout marchait selon ses plans, il pourrait bientôt contrôler des centaines de milliers de systèmes Windows dans le monde, leur donner pratiquement n'importe quelle instruction, puis se retirer et les regarder exécuter sagement chacune de ses commandes.
Tenace et néanmoins insaisissable dans ses méthodes, il commença par sonder subrepticement plusieurs systèmes informatiques pour chercher un point d'entrée vulnérable. Il ne lui fallut pas longtemps pour trouver exactement ce qu'il cherchait :un système non protégé souffrant d'une vulnérabilité connue qu'il savait parfaitement comment exploiter.
Ce qui rendait cette vulnérabilité si dangereuse, c'est qu'en l'exploitant correctement, il pouvait obtenir un accès administrateur total au système. Il ne prenait pas le contrôle d'un seul compte : il manipulait le compte administrateur le plus puissant dans Windows. Ses actions n'étaient plus limitées que par son imagination.
Après un moment de réflexion, il entreprit de tester son code voyou sur l'ordinateur non protégé et vulnérable, et découvrit que cela fonctionnait ! Aussi simple que cela, il possédait maintenant des privilèges illimités sur l'ordinateur. Il utilisa son accès administratif pour forcer la machine à télécharger et installer un code de cheval de Troie, à modifier le Registre et à redémarrer, transformant ainsi ce système infecté en un pantin tout disposer à exécuter ses commandes. Grâce à la modification du Registre, le logiciel malveillant s'exécutait à chaque redémarrage de l'ordinateur.
Maintenant ses intentions étaient évidentes. En cas d'infection, l'ordinateur contaminé sonderait des ports de réseau spécifiques sur tous les autres ordinateurs du réseau. Si un port de réseau était ouvert et que l'ordinateur était vulnérable, le code de cheval de Troie serait téléchargé et installé sur cette nouvelle machine. Les mêmes modifications du Registre se produiraient. Ce cycle se répéterait en permanence et produirait une immense armée de clones d'attaque. À la fin de la journée, des milliers de systèmes Windows dans le monde faisaient partie de sa sinistre armée, ne répondant plus à aucune commande émise par quiconque.
Comme si cela ne suffisait pas, il se tourna ensuite vers le site Microsoft Windows Update et ordonna à tous ses clones d'exécuter une attaque de déni de service le 15 août 2003 pour tenter d'empêcher tout ordinateur dans le monde de télécharger le correctif de vulnérabilité qui, détail intéressant, était disponible depuis des mois.
Vous aurez probablement compris que je viens de décrire la pandémie du ver MS Blaster qui, en août 2003, a frappé les ordinateurs Windows auw quatre coins du globe. Blaster est sans doute l'une des plus attaques les plus graves jamais subies par Windows et a provoqué des milliards de dollars de dommages. L'ironie est que bien que MS Blaster eût un pouvoir énorme sur les machines qu'il avait infectées, il était remarquablement simple dans sa mise en œuvre.

Fonctionnement de Blaster
Blaster et ses dérivés utilisent une vulnérabilité du service RPC de Windows pour saturer la mémoire tampon. Un attaquant qui parvient à exploiter cette vulnérabilité peut exécuter un code avec les privilèges LocalSystem sur un système infecté, ce qui lui permet d'entreprendre n'importe quelle action sur le système : installer des programmes, afficher, modifier ou supprimer des données, et créer de nouveaux comptes avec des privilèges complets.
Dans le cas de Blaster, le ver analyse automatiquement les réseaux à la recherche d'ordinateurs dont le port TCP 135 est ouvert. Dès qu'il trouve une victime, Blaster tente d'exploiter la vulnérabilité de RPC. S'il réussit, il se connecte ensuite au port 4444 de la cible et ordonne à l'ordinateur infecté de lancer le protocole tfpt (Trivial File Transfer Protocol) et de télécharger une copie du ver, appelé MSBLAST.EXE, à partir du système infecté. (tftp est intégré dans Windows 2000, Windows XP et Windows Server 2003 en tant qu'élément à part entière du système d'exploitation.) Le système attaquant ordonne ensuite à l'ordinateur récemment infecté de lancer MSBLAST.EXE, l'ordinateur victime devenant alors un nouvel attaquant. Blaster écrivait également du code dans la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft \Windows\CurrentVersion\Run, ce qui lui permettait de s'exécuter à chaque démarrage de l'ordinateur.

Renforcement des services
Les services ont été renforcés et sécurisés de quatre façons dans Windows Vista : exécution de services avec le Privilège minimal, isolation de services, accès réseau limité et isolation de la session 0. Je les aborderai chacun en détail.
Utilisation du Privilège minimal De nombreux services Windows s'exécutaient auparavant dans le contexte du compte LocalSystem, le compte le plus puissant dans Windows. Le compte LocalSystem possède des droits d'utilisateur et des privilèges tels que la capacité d'accéder à presque n'importe quel objet du système ou à un autre profil d'utilisateur, d'emprunter l'identité des utilisateurs, d'ouvrir des clés de Registre sensibles comme HKLM\SECURITY et de présenter les informations d'authentification de l'ordinateur aux serveurs distants. Dans la mesure où les auteurs de code malveillant adoreraient bénéficier de ce niveau d'accès et contrôler Windows, tout service s'exécutant dans le contexte de la sécurité du compte LocalSystem est susceptible de devenir une cible juteuse.
Il s'avère que, bien que plusieurs services Windows aient été configurés pour s'exécuter sous le compte LocalSystem, nombre d'entre eux n'ont besoin que d'un petit sous-ensemble des privilèges propres au compte LocalSystem. Malheureusement, Windows XP et les versions précédentes de Windows fonctionnent en mode « tout ou rien », ce qui veut dire qu'ils ne fournissent pas de mécanisme permettant de sélectionner les privilèges nécessaires. Ainsi, beaucoup de services Windows finissent inévitablement par s'exécuter avec des privilèges de sécurité excessifs.
Le renforcement des services Windows Vista traite ce problème en introduisant le concept de privilège minimal à la configuration des services. Celui-ci permet aux services de s'exécuter avec le minimum de privilèges nécessaires pour fonctionner, au lieu de les forcer à s'exécuter avec tous les privilèges par défaut attribués au compte qu'ils utilisent pour ouvrir une session.
Par exemple, un service peut avoir besoin de pouvoir agir en tant que partie du système d'exploitation mais n'a pas besoin de pouvoir créer un jeton de sécurité. Avec le privilège minimal, vous pouvez supprimer le privilège de création de jeton. Par conséquent, vous diminuez les dommages susceptibles d'être causés par un attaquant si ce service devient par la suite vulnérable à une faille. Les développeurs peuvent utiliser les outils de ligne de commande tels que SC.exe (voir Figure 2) ou des méthodes de programmation pour définir et spécifier les privilèges dont leur service a besoin. Par défaut, Microsoft a appliqué le privilège minimal pour réduire les privilèges par défaut sur tous les services Windows Vista pré-installés.
Figure 2 Les options de commande SC définissent les privilèges des services Windows Vista
Figure 2 Les options de commande SC définissent les privilèges des services Windows Vista (Cliquer sur l'image pour la réduire)
Figure 2 Les options de commande SC définissent les privilèges des services Windows Vista
Figure 2 Les options de commande SC définissent les privilèges des services Windows Vista (Cliquer sur l'image pour l'agrandir)
Isolation de services Dans les versions de Windows antérieures à Windows Vista, lorsque un service doit accéder à un objet avec privilèges (tel qu'une clé de Registre ou un fichier sensible), les services y accèdent par le biais de l'une de ces trois méthodes : utilisation du compte LocalSystem pour accéder à l'objet, diminution de la sécurité sur la clé de Registre ou le fichier pour autoriser l'accès par un compte de service à privilèges moindres, ou création d'un compte spécialement pour le service et autorisation d'accéder aux objets seulement pour ce compte.
Même si ces approches fonctionnent toutes, elles posent chacune des problèmes fondamentaux. Les deux premières sont en soi risquées et la dernière impose une gestion manuelle lourde des mots de passe sur les nouveaux comptes.
Supposons, par exemple, qu'un antivirus installe un service qui a besoin d'accéder à plusieurs objets système sensibles, tels que le fichier de signatures de virus et les entrées de Registre se rapportant à l'antivirus. Si le service antivirus a été configuré pour utiliser le compte LocalSystem ou, d'ailleurs, n'importe lequel des autres comptes de sécurité incorporés, pour accéder à ses objets, cela signifierait que si un autre service Windows ayant utilisé ce compte est infecté par un logiciel malveillant, ce logiciel malveillant pourrait atteindre et modifier les fichiers de signatures d'antivirus, changer les paramètres du Registre relatifs au fonctionnement de l'antivirus, ou simplement arrêter le complètement le service antivirus. En fait, les logiciels malveillants d'aujourd'hui utilisent précisément certaines de ces techniques pour rester masqués et opérationnels.
Windows Vista traite ces problèmes de sécurité et de gestion grâce à l'isolation de services, qui permet à un service de réserver un objet pour son usage exclusif en sécurisant la ressource, telle qu'un accès à un fichier ou une clé de Registre, avec une entrée de contrôle d'accès contenant un ID de sécurité (SID) de service. De la sorte, le service antivirus décrit dans notre exemple pourrait s'exécuter dans un compte à faibles privilèges tout en conservant l'accès aux fichiers de signatures ou aux clés de Registre sensibles. Pour autoriser cet accès, Windows Vista affecterait un SID au service antivirus (s'exécutant dans ce compte à faibles privilèges). Une fois le SID attribué, le programme antivirus pourrait ensuite modifier les listes de contrôle d'accès (ACL) de ses objets de système de fichiers et de Registre pour accorder l'accès au service antivirus exclusivement.
Voici un autre exemple. En 2003 le ver Welchia a commença à profiter d'une vulnérabilité de RPC pour s'écrire lui-même dans %System%\Wins\Dllhost.exe. Il ajoutait également des clés à HKLM\SYSTEM\CurrentControlSet\Services afin d'installer ses propres services sur le système Windows infecté. Aujourd'hui, cependant, Windows Vista pourrait contrecarrer Welchia en limitant l'accès à ces deux emplacements aux seuls services appropriés et en utilisant les comptes à faibles privilèges pour accorder l'accès à ces services.
Accès réseau limité Windows Vista inclut un nouveau pare-feu qui exploite les fonctionnalités fournies dans le pare-feu Windows XP SP2. Les nouvelles fonctionnalités clés incluent le filtrage sortant et l'intégration d'IPSec. Le nouveau pare-feu s'intègre également au Renforcement des services Windows Vista pour que le logiciel malveillant puisse moins facilement s'exécuter dans un service Windows afin d'effectuer certaines activités réseau illégitimes.
Dans le pare-feu de Windows Vista, les services Windows sont affectés de stratégies de pare-feu de réseau qui fournissent des limitations et des restrictions sur le comportement du service. Par exemple, un service comme Plug-and-play, qui peut ne jamais avoir besoin de communiquer via un port réseau, peut se voir affecter la restriction « aucun accès réseau ». Avec cette restriction, une faille conçue pour viser ce service particulier ne pourrait jamais atteindre le service par le biais d'une approche basée sur réseau. N'importe quelle tentative de communiquer, entrante ou sortante, par ce service limité serait bloquée par le pare-feu. Les autres services qui ont des besoins légitimes d'accéder à un réseau peuvent être configurés pour utiliser uniquement des ports spécifiques. Les développeurs peuvent profiter de cette fonctionnalité pour limiter l'accès réseau de leur service.
Les restrictions réseau peuvent s'associer au Renforcement des services pour fournir une bonne défense contre les attaques basées sur les services potentielles, ce qui constitue une amélioration notable par rapport aux versions précédentes de Windows. Auparavant, Windows ne pouvait pas décider comment, où, et quels services étaient autorisés à communiquer via le réseau. Toutefois, en utilisant les restrictions réseau du pare-feu de Windows Vista contre le service RPC, nous pourrions empêcher des virus tels que Blaster, Sasser ou Welchia d'utiliser des services infectés pour communiquer avec d'autres machines.
Isolation de la session 0 La fonction Changement rapide d'utilisateur de Windows XP prend en charge des utilisateurs connectés simultanément en plaçant chaque utilisateur dans une session de Windows différente. La session 0 est créée lors du démarrage et d'autres sessions sont ajoutées si nécessaire. Les services se sont toujours exécutés dans la Session 0 et, avant Windows Vista, des applications utilisateur pouvaient également s'exécuter dans la Session 0. Cependant, l'exécution des applications utilisateur et des services Windows dans la même session pose des problèmes de sécurité, parce que les services s'exécutent avec des privilèges élevés et sont donc des cibles pour les logiciels malveillants qui cherchent un moyen d'élever leur propre niveau de privilège.
Windows Vista élimine ces risques de sécurité en réservant exclusivement la Session 0 aux services exécutant des applications dans les autres sessions, et en rendant la Session 0 non interactive (ce qui signifie qu'un service ne peut pas créer d'interface utilisateur, telle qu'une boîte de dialogue ou une invite, accessible à un utilisateur final). En raison de ces modifications, l'Isolation de la session 0 influe sur la compatibilité des applications pour toute personne développant des services ou des pilotes Windows.

Résumé
Windows Vista est la première version complète de système d'exploitation informatique de bureau fiable de Microsoft et introduit des avancées significatives et durables vers la protection des utilisateurs de Windows. La sécurité informatique est, bien sûr, une discipline en évolution et il ne fait aucun doute que les auteurs de logiciels malveillants recherchent, testent et développent constamment de nouvelles façons d'exploiter Windows. Cependant, les nouvelles fonctionnalités de renforcement des services de Windows Vista élèvent la barre de façon significative en améliorant les paramètres de sécurité par défaut et en réduisant les espaces potentiels pour une attaque. Voir microsoft.com/whdc/system/vista/Vista_Services.mspx pour plus d'informations sur ces améliorations substantielles.

Wole Moses est responsable régional Microsoft Windows et travaille chez Microsoft depuis huit ans. Actuellement basé à Istanbul, Turquie, Wole travaille avec les principaux clients des nouveaux marchés au Moyen-orient et en Afrique pour les aider à visualiser et à concevoir des solutions de base Microsoft destinées à optimiser leur infrastructure informatique tout en optimisant la sécurité.


 Fichiers du bureau: Kit d'installation automatique de Windows (WAIK)
Fichiers du bureau
Kit d'installation automatique de Windows (WAIK)
Wes Miller

Traditionnellement, Microsoft a proposé deux versions des outils de déploiement produits par l'équipe de déploiement Windows. La première version est apparue sous la forme du fichier de déploiement .cab, compris sur le CD Windows pendant des années. Elle comprenait de la documentation et des outils, tels que Setup Manager (gestionnaire d'installation) pour la création de fichiers d'installation sans assistance, ainsi que
l'outil Sysprep, utilisé pour préparer le déploiement des ordinateurs de bureau. L'autre version des outils de déploiement était le kit de préinstallation OEM (OPK), spécialement conçu pour satisfaire les besoins des fabricants de systèmes OEM et uniquement disponible pour eux. C'est de cette manière que Windows® PE était distribué à l'origine. Il existe une nouvelle version de l'OPK pour Windows Vista™, mais elle sera toujours disponible uniquement pour les OEM.
Heureusement pour les autres clients Microsoft, dont certains ne pouvaient obtenir Windows PE avec Windows XP, un produit pratiquement analogue à l'OPK sera disponible, il s'appelle WAIK (Kit d'installation automatique de Windows). Le kit WAIK sera disponible gratuitement et pourra être téléchargé à partir de microsoft.com/downloads, après l'envoi de Windows Vista, et comprendra les composants suivants : Windows PE 2.0, Windows Deployment Services, ImageX et Windows System Image Manager - un outil que je n'ai pas abordé avant et qui permet la création de fichiers unattend.xml visant à automatiser l'installation. Une documentation complète de tous ces outils est également incluse.
Veuillez noter que pour obtenir le WAIK, il est recommandé de télécharger l'intégralité de l'accélérateur de solution pour le déploiement d'ordinateurs de bureau (BDD) à partir de microsoft.com/desktopdeployment, ce qui fournit non seulement le WAIK, mais aussi l'outil de migration de l'état des utilisateurs (USMT) et le kit de compatibilité des applications(ACT). Le BDD comprend également des outils supplémentaires et des conseils pour réussir le déploiement de Windows Vista.

Windows PE 2.0
J'ai expliqué en profondeur la question de Windows PE 2.0 dans l'édition de novembre 2006 de TechNet Magazine, je ne vais donc pas m'attarder sur trop de détails ; il suffit de dire que le WAIK livrera la version officielle du nouveau Windows PE conçu pour Windows Vista. Il est important de comprendre Windows PE, car tous les autres outils de WAIK utilisent ce système, ou fonctionnent avec, d'une façon ou d'une autre. Vous pouvez lire mon article sur Windows PE 2.0 ici. .

ImageX
Dans ma dernière rubrique, j'ai passé un certain temps à expliquer le format de fichier Windows Imaging (WIM). (Voir microsoft.com/technet/technetmag/issues/2006/12/desktopfiles.) J'aborderai maintenant ImageX, un outil de ligne de commande, petit mais puissant, qui active la fonction de création intégrée d'images de Windows Vista. Lors de la planification d'ImageX, nous avions envisagé de créer un outil basé sur une interface graphique, mais nous avons finalement décidé de nous concentrer sur la ligne de commande, car l'automatisation du processus de création d'images était le point important. Pour voir les options de ligne de commande d'ImageX, consultez l'Illustration 1.
Illustration 1 Outil de ligne de commande ImageX en action
Illustration 1 Outil de ligne de commande ImageX en action (Cliquer sur l'image pour la réduire)
Illustration 1 Outil de ligne de commande ImageX en action
Illustration 1 Outil de ligne de commande ImageX en action (Cliquer sur l'image pour l'agrandir)
Windows Deployment Services (WDS), que nous décrirons plus tard, offre un outil d'interface graphique léger permettant de capturer facilement des images, mais ne propose pas la fonctionnalité complète d'ImageX. Il est également important de noter qu'ImageX est conçu et testé pour capturer des images destinées au déploiement sous Windows PE. Il n'a pas été mis au point pour effectuer des captures « en direct » de systèmes Windows en cours de fonctionnement.
Si vous connaissez des outils de création d'images d'autres systèmes, ImageX ne vous sera pas totalement étranger. Il a été conçu pour être simple d'utilisation, vous permettant de capturer et d'appliquer facilement des images, mais il fournit également une fonctionnalité vitale qui est souvent manquante ou incomplète dans les outils de déploiement couramment utilisés et plus anciens. Voici un exemple, que j'expliquerai brièvement : la capacité à monter une image facilement et de façon transparente en tant que partie d'un système local de fichiers vous permettant de visualiser, modifier ou supprimer des fichiers à partir d'une image existante.
ImageX fournit les boutons de manipulation d'images figurant à l'Illustration 2. Je vais appeler deux commandes spécifiques pour les décrire plus à fond.
Figure 2 Boutons de manipulation des images (Close Figure 2)

Bouton | Description
IMAGEX /APPEND | Ajoute une nouvelle Image de volume à un fichier WIM contenant déjà une Image de volume existante.
IMAGEX /APPLY | Applique une Image de volume à un volume qui a été partitionné et formaté.
IMAGEX /CAPTURE | Capture une Image de volume initiale en un fichier WIM.
IMAGEX /DELETE | Supprime de façon permanente les références à une Image de volume provenant d'un fichier WIM. Veuillez noter que cette action supprime les métadonnées. Elle n'élimine pas les données des fichiers compressés - ceci peut se faire à l'aide du bouton /export pour créer un WIM entièrement nouveau.
IMAGEX /DIR | Affiche l'arborescence des répertoires d'une Image de volume spécifique d'un fichier WIM.
IMAGEX /EXPORT | Exporte une Image de volume à partir d'un fichier WIM ou de plusieurs fichiers WIM fractionnés (SWM).
IMAGEX /INFO | Affiche les détails d'une Image de volume donnée ou d'un fichier WIM particulier - vous pouvez également paramétrer l'option /boot d'une Image de volume spécifiée contenant Windows PE. Seul Windows PE peut être amorcé à partir d'un fichier WIM.
IMAGEX /SPLIT | Fractionne un fichier WIM en un ou plusieurs fichiers SWM plus petits, de façon à ce qu'il puisse être stocké sur de multiples CD ou DVD.
La commande Capture devrait être suffisamment claire - ce dont il faut se souvenir est de n'utiliser qu'une seule capture par WIM. Étant donné qu'un fichier WIM est juste une capture de fichiers, vous pouvez capturer un volume entier (C:) ou même seulement un répertoire (C:\Test). La commande Application fonctionne de la même façon - vous pouvez appliquer une image à un répertoire (même si vous avez capturé un volume entier) ou, comme dans la plupart des cas, la racine d'un volume. Quand une image de volume unique existe déjà dans un WIM, vous utiliserez la commande ajouter. La fonction Appliquer est également relativement explicite et ne se complique que lorsque vous appliquez de multiples fichiers WIM. La commande Supprimer est utile si vous souhaitez retirer la référence à une image de volume spécifique - mais si vous voulez retirer complètement les données de cette image, vous devez utiliser Exporter pour créer un nouveau WIM entièrement dégagé de ces données (c'est-à-dire que si vous souhaitez réduire la taille de l'image en retirant les données restantes, vous devez utiliser Exporter). Considérez qu'Exporter est un outil qui peut servir de défragmenteur ou d'éditeur-lieur, vous permettant de constituer une image de volume en un ou plusieurs fichiers WIM ou de l'exporter vers son propre fichier WIM autonome. ImageX fournit également les boutons d'édition d'image suivants : IMAGEX /MOUNT, IMAGEX /MOUNTRW et IMAGEX /UNMOUNT.
Comme nous l'avons mentionné, l'équipe Produits a incorporé des fonctionnalités d'édition dans les outils et le format de création d'images dès le tout début. En activant l'édition, le format et les outils permettront aux clients de copier des fichiers à l'intérieur ou à l'extérieur, d'appliquer des service packs, d'ajouter/de supprimer des fichiers ou des applications autonomes ou d'ajouter/de supprimer d'autres données de l'image, selon les besoins (même en montant et en modifiant le registre). La maintenance de l'image a toujours été un point central.
Vous pouvez considérer que le montage de l'image équivaut au chargement d'un fichier WIM en tant que répertoire virtuel. Si vous vous y connaissez, l'analogie qui convient le mieux est probablement celle du point de montage du volume, qui vous permet de monter un volume entier dans un répertoire existant sur un autre volume (rendant F: visible sous la forme de C:\DriveF, par exemple). De la même façon, vous avez peut-être utilisé l'outil Microsoft® Virtual CD ou d'autres outils de montage ISO vous permettant de monter des images ISO (CD) en tant que lecteurs locaux. De la même façon, ImageX vous permet de monter un fichier WIM qui chevauchera un répertoire. Vous créez le répertoire, puis vous utilisez la commande Monter pour faire chevaucher l'image de volume spécifiée sur le répertoire, presque comme si vous l'aviez appliquée ici.
Cependant, contrairement à l'outil Virtual CD, vous pouvez monter une image WIM même si elle se trouve au niveau d'un partage réseau ou sur un support amovible. Bien entendu, cette opération peut limiter la fonctionnalité d'édition - un WIM sur un support optique (CD ou DVD) pourra généralement être édité uniquement en mode lecture seule. Vous pouvez également n'éditer qu'une image de volume dans un WIM à la fois si vous êtes en mode lecture/écriture - ceci afin de permettre un verrouillage adéquat et une mise à jour sûre du fichier lors de son démontage.
Vous pouvez monter l'image en lecture seule (/mount) ou en lecture/écriture (/mountrw). Lorsque vous utilisez lecture/écriture, toutes les modifications que vous apportez à l'image sont temporairement cachées (elles ne prennent pas immédiatement effet). Lorsque vous exécutez la commande /unmount avec l'option /commit, ces changements persistent en permanence dans le WIM. Si vous avez effectué des changements et que vous décidez ensuite que vous ne vouliez vraiment pas qu'ils persistent, vous pouvez également les écarter, au lieu de les valider, lorsque vous démontez l'image. C'est tout ou rien - toutes les écritures que vous avez faites au cours de la période de montage du fichier WIM sont soit validées, soit écartées.
Veuillez noter qu'il y a à ce moment un problème important. Tout comme avec la commande Supprimer, lorsque vous utilisez la fonction lecture/écriture pour éditer le WIM, les données des fichiers du fichier WIM ne sont pas complètement effacées ou nettoyées - les fichiers sont ajoutés à la fin du fichier WIM et la référence précédente dans l'image de volume est remplacée par les données mises à jour. Cela signifie que si vous avez ajouté un nouveau fichier de 5 Mo, remplaçant un fichier existant de la même taille, votre image s'agrandira de la taille du fichier de 5 Mo, une fois ce dernier compressé (c'est-à-dire, de 5 Mo ou moins, en fonction du type de compression utilisé). Pour retirer les anciennes données du WIM (si vous souhaitez réduire l'image), vous devrez utiliser/exporter l'image de volume vers un fichier WIM entièrement nouveau.
Si vous lisez mon article sur Windows PE 2.0, publié dans l'édition de novembre 2006 de TechNet Magazine, vous vous souviendrez que ce système prend en charge l'amorçage à partir d'un WIM. Pour y parvenir, le fichier WIM est lu à l'aide d'un lecteur, semblable au mode opératoire d'ImageX. Cependant, la prise en charge ImageX a été conçue pour être utilisée lors de la conception, alors que la fonction amorçage du WIM l'a été spécifiquement pour être en lecture seule et pour fonctionner uniquement avec Windows PE. Donc, même s'ils sont semblables, ces lecteurs et leur implémentation sont différents.
Outre l'outil ImageX, Microsoft fournit une API documentée de façon formelle, WIMGAPI, qui apporte une prise en charge complète de tous les outils de création d'images destinés à capturer, appliquer ou modifier des fichiers WIM. Ainsi, tout tiers souhaitant ajouter une prise en charge de la création d'images ou remplacer une infrastructure de création d'images existante peut le faire, grâce à WIMGAPI. Cette API fait partie du kit WAIK, elle est donc distribuée avec lui.

Installation de Windows basée sur l'image
Le format de création d'images a permis la conception du nouveau moteur d'installation. Fondamentalement, il ressemble beaucoup à l'ancienne Mini-installation ou à l'ancien Windows Welcome ; il vous pose les questions de base nécessaires à l'installation et à la configuration uniques du système, tout en gérant la configuration des disques avant d'installer l'image à partir d'install.wim, sur le DVD d'installation de Windows. L'objectif principal du nouveau moteur d'installation était de permettre des installations manuelles de Windows. Nous avons en effet considéré qu'un grand nombre d'OEM et d'entreprises clientes utiliseraient ImageX pour effectuer leurs déploiements.

Services d'installation à distance (RIS)
À ce stade de l'exposé, vous vous demanderez peut-être pourquoi je n'ai pas abordé les Services d'installation à distance (RIS). Les RIS sont une composante dont j'ai également hérité lorsque j'ai commencé dans l'équipe de déploiement de Windows. Le service RIS, qui était inclus avec Windows 2000, puis avec Windows Server® 2003, faitt appel à un démarrage PXE (Pre-boot Execution Environment) pour amorcer un ordinateur à partir du réseau, de façon à ce qu'un assistant rudimentaire puisse être achevé et qu'une installation Windows puisse se produire, le tout sur le réseau.
Le seul problème de taille du service RIS était sa très grande fragilité. La version du service RIS de Windows Server 2003, à l'origine uniquement prise en charge par Windows 2000 Professional, a élargi son support aux versions serveurs de Windows. Avec l'arrivée en force des contrôleurs de stockage Serial ATA (SATA) et des cartes réseau à 1Go ou plus rapides, le maintien à jour des pilotes du service RIS présentait toujours des risques importants. De plus, le service RIS ne prend pas en charge plusieurs des paramètres de lieu reconnus par Windows, ce qui signifie que l'installation de versions locales de Windows à l'aide de claviers localisés peut s'avérer difficile, voire impossible. Windows Deployment Services a été conçu pour être l'amalgame de l'installation de Windows et du service RIS, un amorçage PXE de Windows PE, qui vous permet de déployer un fichier WIM sur le réseau.
Le service WDS a été conçu non seulement pour être disponible dans la version à venir de Windows Server, dont le nom de code est « Longhorn », mais aussi en tant que mise à jour pouvant être installée sur Windows Server 2003. Cela signifie que le service WDS sera capable de déployer Windows Vista à partir de versions plus anciennes de Windows Server, ainsi que les anciennes versions de Windows. En fait, le service WDS fonctionne non seulement avec le service RIS, mais ils nécessite aussi une installation de celui-ci pour fonctionner correctement. Ceci est dû au fait que le service WDS fonctionne via la mise à jour de l'infrastructure du service RIS pour que ce dernier soit compatible, tout en fournissant la nouvelle infrastructure WDS.
Le service WDS fonctionne d'abord comme une mise à jour de RIS, procurant ainsi une bonne voie d'évolution pour les clients utilisant toujours des versions antérieures de Windows et qui commencent le déploiement de Windows Vista. Le service WDS fournit également des outils de gestion bien meilleurs que le service RIS, ce qui facilite l'ajout de nouvelles images au serveur. Ils fournit également un environnement PXE enfichable, ce qui veut dire qu'un serveur PXE tiers peut s'intégrer et préciser qu'il s'agit d'une réponse à une demande spécifique d'un client, au lieu de WDS. Voilà une demande que nous recevions souvent avec le service RIS et à laquelle nous n'avions à l'époque pas de réponse.
Disponible à l'origine en tant que composant pouvant s'installer sur Windows Server 2003 afin de mettre à jour le service RIS, WDS sera également intégré comme composant des produits Windows Server « Longhorn ». Microsoft envisage également d'inclure la fonction WDS dans les versions futures de SMS (qui sera connu sous le nom de System Center Configuration Manager).
Le service WDS fonctionne en fournissant une version amorcée par PXE de Windows PE 2.0. Cette image est contenue dans un WIM (ce qui veut dire que les données transmises sur le réseau sont réduites), elle est amorcée sur le réseau sous forme de disque virtuel (RAMDisk). L'installation se déroule alors sous Windows PE, à l'aide d'une nouvelle application client procurant la fonctionnalité délivrée par l'application rudimentaire OSChooser de RIS par le passé.
Bien que le service WDS ne prenne pas en charge les images RIS de Windows XP, Windows 2000 ou Windows Server 2003 en l'état, il peut tout à fait en déployer des images Sysprep. WDS s'intègre également dans Active Directory®, comme le faisait traditionnellement le service RIS, mais au besoin, le serveur PXE peut également fonctionner sans Active Directory. WDS peut même démarrer à partir de Windows PE, amorcé à partir d'un élément connexe au PXE, tel qu'un CD, un DVD ou une clé USB à mémoire flash (UFD). Il s'agit d'une fonction utile que le service RIS n'était pas en mesure de fournir.
Dans les faits, il existe trois modes permettant de faire fonctionner le service WDS, selon l'utilisation que vous faites de RIS :
WDS avec héritage des fichiers binaires sont installés, mais c'est OSChooser qui est le mécanisme d'amorce. RISetup et RIPrep, les outils d'installation sous forme de scripts et basés sur l'image de RIS, fonctionnent encore.
Mode mixte Les deux mécanismes d'amorce sont disponibles, les deux ensembles d'outils de création d'images fonctionnent et les deux ensembles d'outils de gestion s'exécutent.
Mode natif Il n'y a aucune fonction RIS, seulement une fonction WIM ; l'amorce Windows PE et les nouveaux outils de gestion sont disponibles. Veuillez noter qu'il s'agit de l'unique mode planifié pour être disponible pour Windows Server « Longhorn ». Il ne comportera aucune fonctionnalité RIS.
Le service WDS implémente également un protocole de communication personnalisé client-serveur, ce qui permettrait en théorie à un OEM ou à une entreprise cliente de créer aussi sa propre application de déploiement.
Le processus de capture d'une image WIM dans un serveur WDS est presque identique à celui du scénario Sysprep que j'ai détaillé. La différence réside dans le fait que la dernière étape impliquera l'amorçage dans WDS Capture Image, une image Windows PE qui existe pour vous aider à capturer un système client, puis de la capturer dans le serveur WDS.
Les composants centraux de WDS sont les suivants : le service WDS Server, le serveur PXE, le stockage d'images, le protocole de communication, le partage de fichiers avec les images Windows PE (à amorcer), les images WIM (à installer) et des fichiers supplémentaires de gestion associés.
Le service WDS a été conçu pour être relativement léger et pour fournir une expérience presque identique (bien que souvent plus rapide) qu'une installation de Windows optique traditionnelle basée sur les supports. L'implémentation de WDS en tant que mise à jour de RIS vous permet de remplacer progressivement le service RIS de façon appropriée, tout en facilitant le déploiement de Windows Vista dans votre entreprise. Et cela d'une manière plus simple d'utilisation et plus rapide que ce que le service RIS n'a jamais été capable de délivrer avec les versions précédentes de Windows.

Windows System Image Manager
Le composant final du WAIK est Windows System Image Manager (SIM). Si vous connaissez Setup Manager des versions précédents de Windows, alors le concept de Windows SIM ne vous sera pas étranger. Cet outil vous permet d'accomplir plusieurs tâches avec des fichiers d'installation sans assistance. Vous pouvez facilement créer un nouveau fichier d'installation sans assistance, en éditer un existant ou vérifier les paramètres d'un fichier existant par rapport à une image spécifique de Windows Vista. Cet outil peut également vous montrer toutes les options de configuration possibles relatives à un WIM spécifique intégrant Windows Vista - pensez aux options traditionnelles d'installation sans assistance, décrites dans les fichiers d'aide accompagnant le deploy.cab. Pour finir, Windows SIM peut aider à créer des partages de distribution et des ensembles de configuration, utilisés pour ajouter des lecteurs, applications et mises à jour à vos installations Windows Vista, via un fichier d'installation sans assistance.
Windows SIM exige que vous soyez un administrateur local du système sur lequel vous l'exécutez. Lorsque vous ouvrez Windows SIM, vous verrez cinq volets, tel que le montre l'illustration 3.
Illustration 3 Windows System Image Manager
Illustration 3 Windows System Image Manager (Cliquer sur l'image pour la réduire)
Illustration 3 Windows System Image Manager
Illustration 3 Windows System Image Manager (Cliquer sur l'image pour l'agrandir)
Partage de distribution, en haut à gauche, est un volet affichant les lecteurs et autres packages que vous avez ajoutés via SIM. Par défaut, Partage de distribution n'est pas monté, mais vous pouvez facilement en ouvrir ou en créer un.
Le volet Image Windows, sous Partage de distribution, affiche les options de configuration (composants et packages) dans une Image de volume Windows donnée d'un WIM. Veuillez noter que vous montez à la fois une seule Image de volume de Windows (une UGS sur le DVD Windows Vista) .
Fichier de réponses, le volet du centre, affiche les options de configuration dans un fichier d'installation sans assistance de Windows Vista, nouveau ou existant, ainsi que les paramètres par défaut, tels qu'ils sont définis par les catalogues (paramètres et configuration potentiels) à partir de l'Image de volume WIM que vous avez montée.
Propriétés, en haut à droite de la fenêtre, est un volet qui vous permet d'éditer les propriétés individuelles d'un composant à partir du volet Fichier de réponses.
Le dernier volet est Messages, qui se trouve au bas et qui affiche des commentaires plus détaillés, y compris une visualisation du code XML brut d'un fichier d'installation sans assistance de Windows Vista (toujours au format XML), ainsi que la sortie de validation et tous les messages liés aux Ensembles de configuration que vous utilisez (l'onglet Ensembles de configuration ne contient des données que si un Ensemble de configuration est ouvert).
Comme vous le voyez, le WAIK fournit un ensemble d'outils très puissants pour vous aider à déployer Windows Vista. L'équipe de déploiement de Windows a été très efficace dans la création d'une collection d'outils qui, vous le verrez, rendent le déploiement de Windows Vista plus facile que celui des versions précédentes de Windows.

Wes Miller est responsable du développement chez Pluck (pluck.com) à Austin, au Texas. Auparavant, il a travaillé chez Winternals Software et chez Microsoft comme responsable de programmes et comme responsable de produit Windows. Wes souhaiterait remercier Scott Dickens et John Macintyre, de Microsoft, pour leur contribution à cette rubrique. Vous pouvez le contacter à l'adresse suivante : technet@getwired.com.


 Notes de terrain: Support technique d&#233;di&#233; &#224; la belle-famille
Notes de terrain
Support technique dédié à la belle-famille
James Snell

JE ME SUIS MARIÉ l'année dernière. Il semble, parallèlement au contrat de mariage, que j'ai signé un contrat de support technique avec ma belle-famille... Récemment, je reçois de ma belle-mère le redoutable coup de fil « Vous vous y connaissez en ordinateur, n'est-ce pas ? ». Je me rends donc chez elle et je découvre un PC Windows® XP totalement asphyxié par une multitude de logiciels espions, logiciels de publicité, barres d'outils, etc.
Je suis informaticien, j'ai l'habitude de réparer les ordinateurs. Mais réparer un ordinateur pour un parent n'est pas chose aisée. La manière la plus rapide de traiter un ordinateur infecté est de formater le disque dur et de réinstaller Windows. Malheureusement, la plupart des utilisateurs rejettent cette option car ils ne souhaitent pas perdre l'ensemble de leurs données. En d'autres termes, préparez-vous à un très long nettoyage... Mais que faire lorsque vous ne pouvez même pas manipuler l'ordinateur ou vous connecter à Internet ?
Préparez une boîte à outils sur une clé USB 512 Mo, comprenant un antivirus, un logiciel anti-espion et un pare-feu personnel. Maintenez cette boîte à outils à jour et à portée de main.
Vous pouvez également placer Windows XP Service Pack 2 (SP2) sur le périphérique USB. Bien que Windows XP soit aujourd'hui fourni avec SP2, la version de ma belle-mère est antérieure à cette édition. Vous pouvez télécharger l'installation Windows XP SP2 à l'adresse microsoft.com/technet/prodtechnol/winxppro/maintain/winxpsp2.mspx. (Vous voulez la version pour plusieurs ordinateurs ; celle dédiée à l'installation sur un ordinateur unique utilise Windows Update.) À 266 Mo, le téléchargement n'est pas des plus rapides, mais vous ne devez l'exécuter qu'une seule fois.
Donc, récapitulons : vous avez passé l'après-midi à formater le disque dur/installer le système d'exploitation ou à supprimer laborieusement virus et logiciels espions. Ensuite, dans un cas comme dans l'autre, vous avez installé les mises à jour logicielles requises pour Windows, ainsi que le pare-feu, vous avez mis à jour les définitions de l'antivirus, etc. Et maintenant ? Une chose est sûre, vous ne passerez pas tous vos week-ends à refaire les mêmes opérations. Pour éviter ce scénario, suivez ces quelques étapes.

Bannir les logiciels-rebuts
Le système de ma belle-mère était rempli de logiciels (installés principalement par des amis), allant du logiciel accessoirement utile au logiciel sans aucune valeur. Pour empêcher cette situation de se reproduire, j'ai verrouillé le compte d'administrateur avec un mot de passe complexe, puis j'ai défini pour ma belle-mère un compte d'utilisateur standard (elle n'a pas besoin d'utiliser le compte d'administrateur très souvent). Dès lors, si quelqu'un tente d'installer un élément pour elle, le système lance une invitation à se connecter en tant qu'administrateur pour continuer ; ceci exerce généralement un effet de dissuasion. Grâce à cette mesure et à une petite séance d'éducation (ou « De l'art de bien utiliser son PC »), les logiciels-rebuts devraient rester à l'écart. (Le site Get Safe Online, getsafeonline.org, fournit de judicieux conseils aux utilisateurs dans le domaine de la sécurisation du PC.)
Ses besoins de sécurité sont différents en ce qui concerne les mots de passe. J'ai volontairement dissocié le mot de passe du compte utilisateur afin d'encourager belle-maman à l'utiliser. Du reste, je suppose qu'une personne mal intentionnée et disposant d'un accès physique à l'ordinateur emportera plutôt l'ordinateur que les données.
Il peut alors sembler stupide de ma part d'avoir placé un pense-bête à proximité de l'ordinateur. Mais le fait qu'elle accède au mot de passe administrateur sans que je le sache ne m'inquiète pas outre mesure. Après tout, il s'agit de son ordinateur. Tandis que ces pratiques ne seraient pas acceptables dans une entreprise, ma belle-mère ne stocke pas de données sensibles et elle laisse volontiers d'autres personnes utiliser son ordinateur. L'objectif, ici, est de faciliter son expérience utilisateur et – plus important encore – ma vie en tant qu'ingénieur support attitré !

Repousser les intrus
L'étape suivante consiste à fournir une protection supplémentaire. J'apprécie le fait qu'un pare-feu soit intégré à Windows et qu'il existe des pare-feu tiers. Toutefois, je n'accorde pas ma confiance à un seul et unique pare-feu. En vue d'une sécurité accrue, ma belle-mère dispose désormais d'un routeur ADSL avec un pare-feu intégré. Oui, il s'agit d'une dépense supplémentaire. Oui, il s'agit d'un autre élément à configurer et à exécuter. Mais la sécurité s'en trouve réellement améliorée. Et puis, un boîtier avec des voyants qui clignotent, impressionnant non ?
Mais ne pensez pas que la configuration initiale du routeur soit sécurisée. Je suis tombé sur des routeurs qui, par défaut, présentaient une activation des interfaces Web et Telnet côté public. Prenez quelques minutes et vérifiez les options avancées.
Le chargement des pare-feu logiciels est impossible tant que les composants réseau ne sont pas entrés en service. Le pare-feu Windows intégré est la seule protection dont vous disposez durant les premiers stades du démarrage (une autre raison de posséder Windows SP2 avant de connecter l'ordinateur à Internet). Lorsque vous désactivez le pare-feu Windows, vous restez protégé par ce dernier jusqu'à ce que le pare-feu sélectionné démarre. De plus, en ce qui concerne le pare-feu du routeur, je ne dois plus m'inquiéter d'une éventuelle désactivation car il s'agit d'un dispositif distinct ; s'il n'est pas activé, ma belle-mère n'est pas connectée. Je considère cette installation de la même manière qu'un double codage des données. Pour qu'une attaque aboutisse, le pare-feu du routeur et le pare-feu logiciel doivent tomber en panne simultanément. Cette situation n'est pas impossible mais elle est peu probable.

Inciter et protéger
Imaginez quelle aurait été la facilité de l'ensemble du processus avec une bonne sauvegarde. Je ne conçois pas que des personnes affirment ne pas pouvoir sauvegarder, au moins, leurs informations critiques. Les graveurs de DVD et les supports ne sont pas spécialement onéreux ; de plus, Windows inclut un logiciel de sauvegarde. Le problème est que la plupart des gens ne l'utilisent pas. Pour ma belle-mère, la solution consiste à exécuter la sauvegarde habituelle et planifiée du dossier Mes Documents et à enregistrer le fichier directement dans le dossier de gravure de CD (%userprofile%\Local Settings\Application Data\Microsoft\CD Burning). Pour que cette solution fonctionne, vous devez définir la tâche planifiée de façon à ce qu'elle s'exécute uniquement lorsque l'utilisateur est connecté. Ainsi, l'assistant de gravure de CD lance des invites régulières (et irritantes...) jusqu'à ce que l'utilisateur insère un disque vierge. J'ai obtenu le résultat souhaité.

Garder le contact
En paramétrant Windows Live™ Messenger, vous pouvez configurer le partage de bureau. En d'autres termes, une fois revenu chez vous et si un autre paramétrage est nécessaire, vous pouvez visualiser la situation sans vous déplacer (ce qui est toujours une bonne chose). À propos, je peux également confirmer que le fait de prendre le contrôle d'un ordinateur distant (ce qui nécessite une autorisation, bien sûr) et d'être observé en train de manipuler la souris est beaucoup plus impressionnant que les voyants lumineux du routeur !

James Snell est un ancien spécialiste du support Microsoft. Il vit au Royaume-Uni. Il a travaillé avec des utilisateurs à domicile et avec certains des plus grands comptes internationaux chez Microsoft. James développe actuellement un nouveau talent : la paternité. Vous pouvez le contacter à l'adresse James.Snell@lineone.net.


 Windows Confidential: Sortir de l'enfer des DLL
Windows Confidential
Sortir de l'enfer des DLL
Raymond Chen

L'ENFER DES DLL. Un problème si insidieux qu'il possède son propre surnom péjoratif ! Vous installez un programme et constatez ensuite qu'un programme apparemment sans lien avec le premier cesse de fonctionner. La raison en est simple. Sans que vous le sachiez, ces deux programmes sont connectés via une DLL partagée. Les deux programmes peuvent avoir un avis différent sur la version du fichier MSVCRT.DLL qui doit se trouver dans le répertoire système. Autre explication possible : le premier programme met à niveau un contrôle ActiveX® que le deuxième programme utilise, mise à niveau avec laquelle le deuxième programme n'est pas entièrement compatible.
Si les deux programmes sont essentiels aux opérations quotidiennes de votre entreprise, le problème n'est pas de savoir quel programme est en tort. La seule chose qui compte est de pouvoir les utiliser tous les deux. Il n'y a pas beaucoup de différence entre « Nous perdons de l'argent » et « Nous perdons de l'argent à cause de Jacques ». Dans les deux cas, votre société perd de l'argent et il vous revient de régler le problème au plus vite.
Il y a peu, la solution consistait à décider quel programme l'emportait sur l'autre. Depuis Windows® 2000, des correctifs logiciels sont proposés pour résoudre ces conflits. Toutefois, ces correctifs n'offrent que des remèdes temporaires permettant de remettre votre système en état de marche, le temps de trouver une solution plus définitive au conflit.
Windows 2000 a implémenté une version rudimentaire de ce qu'on appelle aujourd'hui la Redirection de bibliothèque de liens dynamiques. Pour activer la redirection de DLL, créez un fichier du même nom que le programme dont vous souhaitez rediriger les DLL, mais en ajoutant le suffixe .local à son nom. Par exemple, pour appliquer la redirection à C:\Program Files\Litware Inc\Invoice.exe, créez le fichier C:\Program Files\Litware Inc\Invoice.exe.local. Le contenu du fichier est sans importance. Ce qui importe, c'est que le fichier existe.
Une fois la redirection activée pour un programme, chaque fois que celui-ci essaie de charger une DLL, il commence par regarder dans son répertoire d'installation, avant les emplacements de recherche habituels. Par conséquent, dans le cas du fichier MSVCRT.DLL en conflit, vous pouvez activer la redirection pour chaque programme et mettre une copie privée de MSVCRT.DLL dans le répertoire d'installation de chaque programme. Chaque programme reçoit ensuite sa propre version de MSVCRT.DLL, c'est à dire la version de la DLL avec laquelle le programme a été testé.
La magie de cette technique est qu'elle fonctionne même si le programme utilise un chemin d'accès complet pour charger la DLL. Supposons par exemple, que le programme essaie de charger C:\Program Files\Common Files\Proseware Inc\taxplugin.dll. Après avoir mis à niveau le programme vers Proseware 2.0, vous découvrez que son plug-in d'imposition est incompatible avec votre programme de facture. Vous pouvez alors copier une version ancienne du plug-in d'imposition dans C:\Program Files\Litware Inc\taxplugin.dll. Même si le programme utilise un chemin complet pour charger le plug-in, la redirection de DLL continuera à chercher dans le répertoire actuel et utilisera le fichier local plutôt que celui du répertoire Proseware Inc.
Dans Windows XP et Windows Vista™, les règles de redirection de DLL sont légèrement différentes, mais fonctionnent sur le même principe. En plus de créer un fichier .local, vous pouvez également créer un répertoire .local. Dans ce cas, le système effectue sa recherche dans le répertoire .local plutôt que dans le répertoire d'installation du programme. Cela vous permet d'appliquer la redirection à plusieurs programmes dans le même répertoire, sans engendrer de conflit.
Notez que vous ne pouvez pas appliquer la redirection à des programmes qui contiennent un manifeste d'application, et que les DLL dites connues sont également exemptes de redirection. (Pour plus d'informations, consultez l'article « Redirection de bibliothèque de liens dynamiques ».)
La redirection de DLL ne vous sort pas totalement de l'enfer des DLL, mais vous prodigue au moins les premiers secours, le temps de vous remettre d'aplomb pour résoudre le problème.
Figure 1
Figure 1

Raymond Chenécrit tant sur l'histoire de Windows que sur la programmation Win32 sur son site Web (The Old New Thing), ainsi que dans son nouveau livre, également intitulé The Old New Thing (Addison-Wesley, 2007). Il n'a pas, en revanche, de chat prénommé The Old New Thing.