 TechNet Magazine January 2007
TechNet Magazine January 2007
JANUARY 2007
SharePoint

Este mes, TechNet Magazine dedica un artículo a SharePoint y a todas las novedades de la última versión. En él, presentamos SharePoint Server 2007 y le guiamos a través de las nuevas características que hacen que la creación de un sitio colaborativo sea más fácil y mejor que nunca. Un artículo de información general trata la búsqueda empresarial y la administración de documentos, entre otros temas. Asimismo, ofrecemos artículos sobre seguridad en SharePoint, tareas rápidas de administración de línea de comandos y creación de un wiki para la organización con SharePoint. Y, como es habitual, contamos con nuestra lista de populares columnas, que incluye a Raymond Chen en Huida del infierno de DLL y a los chicos del scripting, que tratan la ordenación en VBScript con el método DataList.Sort de .NET Framework.

CARACTERÍSTICAS
SharePoint Información general sobre Microsoft Office SharePoint Server 2007

La nueva versión de SharePoint está preparada para satisfacer todas las necesidades de administración de colaboración e información en una única plataforma integrada. En este documento se analizan las nuevas características y herramientas de MOSS que cambiarán el modo de funcionamiento de su empresa.

Thomas Rizzo Siete nuevas características que mejoran la seguridad en SharePoint

Si se aprovecha SharePoint para más datos empresariales y se llega a incorporar en mayor medida en el flujo de trabajo de la empresa, la seguridad adquiere mucha más importancia. Descubra el modo en el que estas nuevas características de MOSS pueden aumentar rápidamente la seguridad en su organización.

Adam Robert Buenz Encuéntrelo todo con la búsqueda empresarial de SharePoint

Su compañía pierde tiempo y dinero mientras los empleados intentan encontrar información. La búsqueda empresarial puede resultar de ayuda. MOSS ofrece una herramienta de búsqueda empresarial que puede encontrar información de forma rápida, tanto si está guardada en un sitio de la intranet, como en una aplicación de línea de negocio, o bien junto a un único empleado.

Matt Hester Administración eficaz de la línea de comandos para SharePoint

No se enrede con GUI. Existe una manera más eficaz y rápida de administrar SharePoint, que permite realizar tareas administrativas a partir de un símbolo del sistema e incluso crear scripts de procedimientos habituales.

Todd Klindt Edición de wikis mientras trabaja

Los wikis ofrecen una forma novedosa y más flexible de colaborar, promoviendo un enfoque no estructurado de pensar e intercambiar ideas. Por otro lado, MOSS 2007 hace que la implementación de wikis en la organización sea bastante fácil. En este artículo se incluye la información necesaria para comenzar a crear y utilizar wikis en el lugar de trabajo.

Mauro Cardarelli
COLUMNAS
From The Editor

Joshua Trupin Caja de herramientas

Nuevos productos para profesionales de TI

Greg Steen Utility Spotlight

Kit de administración de Internet Explorer

Lance Whitney Preguntas y respuestas de SQL

Archivado de datos, servidores vinculados, medición de ancho de banda y otras cuestiones

Editado por Nancy Michell The Cable Guy

Optimización automática de la ventana de recepción TCP

Joseph Davies Windows PowerShell

Construcciones de Windows PowerShell

Don Jones 		¡Hola, chicos del scripting!

Ten cuidado con lo que dices

Los chicos del scripting de Microsoft Exchange Queue & A

Tenemos todas las respuestas (porque nosotros hicimos las preguntas)

KC Lemson y Paul Bowden Vigilancia de seguridad

Services Hardening en Windows Vista

Wole Moses Archivos del escritorio

Kit de instalación automatizada de Windows

Wes Miller Notas de campo

Soporte técnico para la familia política

James Snell Confidencial de Windows

Huida del infierno de DLL

Raymond Chen


 SharePoint: Informaci&#243;n general sobre Microsoft&#160;Office&#160;SharePoint&#160;Server&#160;2007
SharePoint Thomas Rizzo

Información general sobre Microsoft Office SharePoint Server 2007
Resumen:
  • Integración web de SharePoint
  • Administración de contenido
  • Inteligencia empresarial

Actualmente existen dos fenómenos que cambian la forma en la que funcionan las empresas en lo que Microsoft denomina "el nuevo mundo del trabajo". En primer lugar, es cada vez más frecuente que equipos que trabajan conjuntamente estén situados en ubicaciones distintas y
que incluso lo hagan en diferentes horas del día. Como resultado, el software de colaboración ha llegado a cobrar aún más importancia para abarcar la naturaleza de trabajo de conexión global. En segundo lugar, el uso de información digital crece en gran medida, mientras las reglas de cumplimiento que rodean estos datos profesionales se vuelven más complejas. Las compañías se esfuerzan en permitir la colaboración y el uso compartido, así como en garantizar la seguridad y privacidad de la información. Para aprovechar la información y los activos de personal es fundamental la implementación de una solución que salve estos requisitos de comunicación a través de todos los continentes y zonas horarias, las herramientas eficaces de colaboración y el tratamiento seguro de datos.
La presentación de Microsoft® Office SharePoint® Server (MOSS) 2007 reúne una serie de tecnologías en una única plataforma integrada y en un conjunto de servicios empresariales. Estas tecnologías abarcan desde colaboraciones en portales a búsquedas empresariales de flujo de trabajo y procesos de negocio. MOSS representa la siguiente generación de SharePoint Portal Server (SPS) creada a partir de Windows® SharePoint Services (WSS). Consulte el gráfico circular de la figura 1 para comprender de forma sencilla el trabajo en conjunto de MOSS y WSS. Las áreas en verde pertenecen a WSS y debido a que MOSS se basa en WSS, todo el gráfico refleja el trabajo de MOSS. MOSS proporciona concretamente el portal, la búsqueda, la administración del contenido empresarial, el proceso de negocio y formularios, y ejemplos de inteligencia empresarial.
Figura 1 Servicio creado a partir de MOSS y WSS
Figura 1 Servicio creado a partir de MOSS y WSS (Hacer clic en la imagen para reducirla)
Figura 1 Servicio creado a partir de MOSS y WSS
Figura 1 Servicio creado a partir de MOSS y WSS (Hacer clic en la imagen para ampliarla)
En el resto de este artículo se analizan paso a paso las novedades tecnológicas de MOSS y cómo utilizar estos avances para aumentar la productividad de los usuarios.

SharePoint y Web 2.0
Web 2.0, Enterprise 2.0, aplicaciones compuestas, cualquier contenido dirigido a la comunidad, tecnologías de Internet como AJAX, RSS, blogs y wikis proporcionan a los usuarios un mayor control del contenido, de su colaboración y de la forma en la que los datos fluyen hasta ellos. Asimismo, los usuarios desean la interactividad de Windows con la facilidad de uso e implementación que ofrece la web. Sin embargo, la aplicación de conceptos de Internet en el entorno empresarial da lugar a nuevos problemas. Por ejemplo, ¿es posible comprobar y confiar en el origen del servicio? ¿Se integra sin problemas con la infraestructura existente?
MOSS 2007 ofrece una serie de características nuevas a la vez que mejora la plataforma de colaboración existente mediante capacidades integradas para la alerta y administración de documentos, agregando nuevas capacidades como blogs (consulte la figura 2), wikis y un elemento web para publicar y recibir fuentes RSS. Si utiliza Microsoft Office Outlook® 2007, puede realizar sincronizaciones bidireccionales de los datos de colaboración como calendario, tareas y contactos entre Outlook y Microsoft SharePoint. Si desea modificar un contacto o cambiar una cita, puede realizarlo en Outlook o en SharePoint y los cambios aparecerán en el otro programa.
Figura 2 MOSS 2007 admite blogs y wikis
Figura 2 MOSS 2007 admite blogs y wikis (Hacer clic en la imagen para reducirla)
Figura 2 MOSS 2007 admite blogs y wikis
Figura 2 MOSS 2007 admite blogs y wikis (Hacer clic en la imagen para ampliarla)
Outlook también admite que las bibliotecas de documentos dejen de estar conectadas. Puede realizar cambios en los documentos desconectados desde la red y volver a sincronizar los cambios la próxima vez que esté en línea.
Además, MOSS tiene la capacidad de auditar y aplicar reglas de cumplimiento en el contenido dirigido a la comunidad, de manera que el ofrecimiento de estas nuevas capacidades no exija a los clientes que sacrifiquen la facilidad ni la seguridad.
Un avance importante en MOSS 2007 es la mejora de la personalización del portal. MOSS introduce una actualización de Mi sitio que utiliza por completo la funcionalidad de los sitios SharePoint. Los usuarios pueden crear listas, bibliotecas de documentos o subsitios en Mi sitio y personalizar la visualización de estos sitios para sus vistas personales y de grupo de trabajo. Mi sitio también ofrece nuevos elementos web para la organización de jerarquías y seguimiento de compañeros de trabajo, incluidas alertas cuando cambien los metadatos de los compañeros, como el número de teléfono, tratamiento, ubicación de la oficina u otro tipo de información. En la figura 3 se muestra un ejemplo de Mi sitio personalizado en MOSS.
Figura 3 Mi sitio admite más características de SharePoint
Figura 3 Mi sitio admite más características de SharePoint (Hacer clic en la imagen para reducirla)
Figura 3 Mi sitio admite más características de SharePoint
Figura 3 Mi sitio admite más características de SharePoint (Hacer clic en la imagen para ampliarla)

Búsqueda empresarial
Cuando los discos duros tenían poca capacidad, no solía ser un problema recordar la ubicación donde estaba todo almacenado. Sin embargo, con el aumento vertiginoso de almacenamiento y lo que parece la capacidad sin límite de los usuarios para llenarlo, la búsqueda ha pasado a ser un componente fundamental de toda arquitectura de información. MOSS ofrece características mejoradas para buscar repositorios empresariales, a partir de la plataforma de búsqueda proporcionada originalmente en SPS 2003. MOSS 2007 sigue rastreando repositorios de recursos compartidos de archivos, sitios web, Exchange Server y Lotus Notes, que se consideran repositorios de datos sin estructurar.
Lo que SPS no ofreció de forma sencilla fue la capacidad de buscar repositorios estructurados como aplicaciones de línea de negocio o bases de datos relacionales. Además, los repositorios estructurados y no estructurados que complementan los metadatos y los empleados con experiencia contribuyen a la organización. MOSS puede buscar repositorios estructurados a través de una nueva tecnología denominada Catálogo de datos profesionales (BDC), así como buscar usuarios y expertos mediante la nueva red de conocimiento.
El BDC proporciona la capacidad de conectarse, rastrear y buscar sistemas que expongan los datos a través de proveedores de ADO.NET o servicios web. Puede crear un archivo de configuración XML que contenga la información necesaria acerca del sistema al que desee conectarse. En este archivo se puede incluir el nombre del servidor o del extremo, información sobre el modo de enumerar y recuperar objetos del sistema, sobre todo filtrado compatible con el sistema del servidor, así como sobre el modo en el que se deben asignar los datos del servidor a SharePoint. A continuación, se pueden utilizar las características de búsqueda empresarial en SharePoint para buscar datos del BDC a medida que se rastrean otros repositorios empresariales.
De forma predeterminada, SharePoint crea una página de perfil para cada entidad de negocio del sistema del servidor. Estas páginas de perfil se pueden personalizar de la misma forma que otras páginas en SharePoint. En la figura 4 se muestra una página de perfil personalizada que devuelve datos profesionales, así como otro tipo de información. SharePoint también incluye una serie de elementos web de datos profesionales que permiten mostrar datos del BDC en las páginas y, opcionalmente, filtran los datos de dichas páginas según los metadatos disponibles. Puesto que los datos profesionales se asignan a SharePoint, puede tener acceso a los datos en las listas de SharePoint mediante el nuevo tipo de columna de datos profesionales. Ya no se producen errores de entrada de datos ni limpieza de datos, ya que los datos de la lista proceden del sistema del servidor autorizado.
Figura 4 Organización de los datos profesionales en páginas de SharePoint desde servicios del servidor
Figura 4 Organización de los datos profesionales en páginas de SharePoint desde servicios del servidor (Hacer clic en la imagen para reducirla)
Figura 4 Organización de los datos profesionales en páginas de SharePoint desde servicios del servidor
Figura 4 Organización de los datos profesionales en páginas de SharePoint desde servicios del servidor (Hacer clic en la imagen para ampliarla)
La red de conocimiento ofrece un método completo de búsqueda de usuarios y expertos. Las redes sociales dentro de la empresa constituyen la forma en la que se llevan a cabo los negocios. En muchos casos, los empleados podrían llegar a ser más productivos si pudieran realizar consultas a expertos que les ayudaran con los problemas empresariales que estén tratando. Sin embargo, si su círculo de compañeros desconoce lo que necesita, probablemente no seguirá buscando un experto. Con la red de conocimiento, en lugar de confiar en las redes sociales y físicas, el software ayuda a crear el mapa social de la organización y permite buscar esa red social. Es posible ordenar los resultados por distancia social y filtrar por propiedades de metadatos como tratamiento o departamento.
Como cualquier solución relacionada con personas y su información de identificación personal, la red de conocimiento ofrece una amplia seguridad y un modelo de privacidad de manera que los usuarios tengan que optar por la red y puedan controlar lo que se muestra a determinadas partes de la misma. La red de conocimiento rastrea la información del servidor como Mi sitio de SharePoint. También tiene un componente del cliente que se conecta a Outlook y a la mensajería instantánea para rastrear correos electrónicos y contactos. En el cliente, es posible controlar si se lleva a cabo el rastreo programado y lo que se publica desde el rastreo del cliente al perfil del servidor. Uno de los problemas de los sistemas de expertos es el mantenimiento de los datos de personas actualizados. Con la red de conocimiento, el software mantiene todas las actualizaciones de la información a la vez que permite a los usuarios controlar la visibilidad y accesibilidad a dichos datos.

Administración del contenido empresarial
Más allá de la administración de documentos, MOSS 2007 ofrece una sólida solución de administración de contenido empresarial al aumentar la compatibilidad de administración de registros, contenido web y formularios electrónicos. La capacidad de administración de registros de SharePoint incluye la capacidad de crear un depósito administrado que cumpla con las necesidades de cumplimiento como retención de contenido, auditoría, códigos de barras y etiquetado. A través de la integración completa con Exchange Server, los repositorios de registros pueden incluir mensajes de correo electrónico como registros oficiales, además de la información creada y almacenada en SharePoint. Las capacidades de administración de registros permiten realizar detecciones legales a través de registros de búsqueda como contenciones legales de manera que se puedan separar las directivas de retención (según los procedimientos legales que requieren mantener el contenido más tiempo del que especifican las directivas de retención).
En el ámbito de la administración del contenido web, MOSS 2007 ocupa el lugar de Microsoft Content Management Server 2002. Mediante este cambio, SharePoint puede abastecer las necesidades de la web abarcando desde intranet a extranet para los sitios orientados a Internet. Con todas estas capacidades en SharePoint, tan sólo tiene que admitir una tecnología en toda la infraestructura. SharePoint admite la distribución de contenido de manera que puede tener servidores de prueba y de implementación independientes. Además, SharePoint hace que la personalización de los sitios sea más sencilla mediante la compatibilidad con páginas principales de ASP.NET 2.0. En cuanto a escenarios de varios idiomas, SharePoint admite variaciones de sitios para que un único sitio pueda tener distintas variaciones y realizar automáticamente redirecciones según la configuración del idioma del explorador cliente que muestra la página.
Con respecto a los formularios electrónicos, SharePoint agrega una nueva capacidad denominada InfoPath® Forms Services, que permite convertir los formularios de InfoPath en electrónicos. El proceso consiste en la creación de formularios de InfoPath, mediante la activación de una casilla en el diseñador para advertirle en caso de intentar utilizar características que no se van a convertir en la web y mediante el almacenamiento del formulario en una ubicación segura en una lista de SharePoint. A continuación, los usuarios pueden ver, editar y enviar los formularios tan sólo mediante el explorador web.
Una solicitud de características importante de los usuarios de SPS 2003 fue la mejora de las capacidades del flujo de trabajo, ya que muchos clientes deseaban incrustar flujos de trabajo en el contenido almacenado en SharePoint. MOSS va mucho más allá de la mejora del flujo de trabajo, mediante la incorporación de las nuevas características de Windows Workflow Foundation de .NET Framework 3.0. Esto permite crear flujos de trabajo en Windows Workflow Foundation e incluirlos en SharePoint. Además de alojar Windows Workflow Foundation, SharePoint también incluye una serie de flujos de trabajo listos para usar, entre los que se incluyen los flujos de trabajo de aprobación de documentos y de firma de documentos. En la figura 5 se muestra el modo de configuración de un flujo de trabajo listo para usar en MOSS.
Figura 5 Configuración de flujos de trabajo en MOSS
Figura 5 Configuración de flujos de trabajo en MOSS (Hacer clic en la imagen para reducirla)
Figura 5 Configuración de flujos de trabajo en MOSS
Figura 5 Configuración de flujos de trabajo en MOSS (Hacer clic en la imagen para ampliarla)
MOSS permite controlar los flujos de trabajo para disponer del estado y del historial de la tarea actual. Además, SharePoint se integra con los clientes de Office, de forma que los usuarios finales puedan iniciar los flujos de trabajo desde las aplicaciones de Office. También pueden consultar rápidamente si tienen tareas de flujo de trabajo asignadas y realizar dichas tareas en las aplicaciones de Office.
Asimismo, MOSS amplía su alcance a los portales de inteligencia empresarial. Estos portales constan normalmente de informes, listas y tablas de datos que se pueden ordenar y filtrar, incluidos gráficos que pueden ayudar a representar visualmente el estado de los datos. Con MOSS, la creación de los portales de inteligencia empresarial es simplemente cuestión de crear una nueva página mediante la plantilla de paneles de inteligencia empresarial (BI). El panel de BI incluye de forma predeterminada una lista de indicadores clave de rendimiento (KPI) y el elemento web de Excel® Web Access.
La lista de KPI es un nuevo tipo de lista de MOSS que le permite conectarse a fuentes de información como listas de Excel, SQL Server™ Analysis Services, SharePoint, o introducir información de forma manual, así como realizar un seguimiento de los KPI desde estos orígenes de datos. Con la lista de KPI, puede ver valores actuales, valores del objetivo, tendencias y estados mediante indicadores visuales.
Excel Web Access forma parte de los servicios de Excel en MOSS, una versión del servidor de Excel que permite calcular y mostrar la información de Excel mediante un explorador web. Para hacer uso de los servicios de Excel, puede publicar una hoja de cálculo directamente desde la aplicación Excel a una ubicación segura en SharePoint. Los usuarios pueden ver, a continuación, la hoja de cálculo o las listas desde Excel mediante los exploradores web. Tras esto, y si hay parámetros o filtro, los usuarios pueden utilizar estas capacidades para modificar el explorador web que representa la información de Excel.

Más información
Sólo he podido analizar un pequeño subconjunto de las nuevas capacidades de MOSS, aunque hay una amplia gama de recursos en línea a través de los cuales puede continuar su aprendizaje. Mi recomendación comenzar por el blog del equipo de SharePoint y el SharePoint Server TechCenter.

Thomas Rizzo es director del grupo SharePoint en Microsoft. Anteriormente, Tom trabajó en los grupos SQL Server y Exchange Server. También ha escrito cuatro libros. Puede ponerse en contacto con él en thomriz@microsoft.com.
© 2007 Microsoft Corporation and CMP Media, LLC. Reservados todos los derechos; queda prohibida la reproducción parcial o total sin previa autorización.


 SharePoint: Siete nuevas caracter&#237;sticas que mejoran la seguridad en SharePoint
SharePoint Adam Robert Buenz

Siete nuevas características que mejoran la seguridad en SharePoint
Resumen:
  • Proveedores de autenticación
  • Características de cifrado nativo
  • Asignación de acceso y zonas alternativas
  • Information Rights Management

Si se implementan medidas de seguridad eficaces para el entorno Microsoft Office SharePoint Server (MOSS) 2007, los gastos de administración pueden reducirse de forma considerable, a la vez que se permite a los equipos que
colaboren y compartan datos profesionales en un entorno seguro. Las innovadoras características de autenticación integradas en MOSS 2007 permiten utilizar niveles de seguridad basados en la web a través de proveedores de autenticación personalizados, autenticaciones basadas en formularios de Internet y el inicio de sesión único (SSO) en la web. Asimismo, MOSS ofrece la administración de derechos granulares de activos empresariales como archivos del sistema Microsoft® Office 2007, características de cifrado nativo y reducción de obligaciones de autenticación de clientes.
A continuación se muestran siete características de seguridad de MOSS 2007 que se pueden aplicar rápidamente.
1. Proveedores de autenticación conectables Los proveedores de autenticación son componentes que permiten comprobar las credenciales de usuario. La configuración del proveedor de autenticación del entorno de MOSS es una decisión importante de seguridad a la hora de instalar la autenticación de Internet de SharePoint®. MOSS sigue admitiendo los métodos de autenticación basados en Windows® disponibles en versiones anteriores de SharePoint, incluida la autenticación integrada y la básica (al agregar la autenticación implícita) para resolver a los usuarios en las identidades tangibles de Windows. Sin embargo, la resolución de una identidad de Windows no es la única opción. Puede incluso utilizar varios proveedores de autenticación para que, por ejemplo, los usuarios internos inicien sesión a través de la autenticación de Windows mientras los usuarios externos lo hagan mediante un proveedor conectable e independiente.
MOSS se crea a partir de ASP.NET 2.0, que permite el uso de proveedores de autenticación conectables. Esto permite usar directorios configurables para almacenar información de usuarios siempre que haya un proveedor de suscripciones de ASP.NET 2.0 (y un proveedor de funciones opcional) que se corresponda con el almacén de datos de miembros. Las credenciales de los proveedores conectables pueden tener un algoritmo hash y se pueden cifrar o almacenar en forma de texto sin formato según los valores de nodo almacenados en el archivo machine.config correspondientes al proveedor de suscripciones. Hay varios proveedores de suscripciones disponibles para utilizarlos con MOSS, entre los que se incluyen un proveedor de suscripciones de LDAP V3 (que se distribuye con MOSS), un proveedor de suscripciones de SQL Server™ y otro de Active Directory® disponible con ASP.NET 2.0.
Los proveedores de suscripciones y de funciones que se pueden ejecutar no son únicamente los que se distribuyen. Mediante la arquitectura de suscripciones de ASP.NET 2.0, es posible crear proveedores personalizados que utilicen almacenes de miembros como las bases de datos Microsoft Access™ u Oracle, archivos XML o incluso archivos de texto sin formato. Los proveedores de autenticación personalizados se heredan de la interfaz MembershipProvider de ASP.NET, la cual se hereda a su vez de la clase ProviderBase (consulte la figura 1).
Figura 1 Jerarquía de clases de suscripciones de .NET
Figura 1 Jerarquía de clases de suscripciones de .NET
El uso de la autenticación de ASP.NET 2.0 con MOSS tiene algunas repercusiones (a diferencia de la autenticación de Windows) que deben tenerse en cuenta. La más importante para muchos usuarios es la reducción de la interoperación del cliente de Microsoft Office debido a que la comunicación del servicio web entre los clientes de MOSS y de Office se diseñó en un principio para su uso con identidades de Windows.
Además, algunos servicios de MOSS, en concreto los relacionados con el rastreo y la indización del contenido, deben utilizar una cuenta de Windows incluso cuando utilizan también un proveedor conectable. Para realizar esto mediante un tipo de autenticación que no se resuelve en una identidad de Windows, es necesario crear una zona de MOSS adicional que utilice la autenticación de Windows. Analizaré las zonas más adelante.
Si posee una infraestructura de PKI autorizada basada en mecanismos de seguridad como tarjetas inteligentes en la que los clientes aprueban las claves públicas o los certificados, es necesario normalmente que se resuelva una identidad de Windows para la aceptación y la autorización del certificado de cliente adecuado, según la implementación. Esto, a su vez, puede requerir la creación de una zona de MOSS adicional u otras configuraciones de autenticación.
2. Autenticaciones basadas en formularios e inicio de sesión único en la web Otro fascinante mecanismo de autenticación disponible en MOSS 2007 es la autenticación basada en formularios basada a su vez en ASP.NET 2.0. En versiones anteriores de SharePoint, esto podía realizarse únicamente mediante una extensión personalizada de la interfaz de programación de aplicaciones para servidores de Internet (ISAPI) o utilizando la extensión ISAPI CustomAuth ISAPI desde el conjunto de herramientas de IIS 6.0. Incluso con estas soluciones, SharePoint sigue necesitando la cuenta para volver a resolver en una identidad de usuario de Windows, restringiendo la implementación basada en perímetros.
La autenticación de MOSS basada en formularios utiliza la autenticación conectable y los proveedores de funciones para permitir que los mecanismos de seguridad de Internet no limiten a los usuarios a una solicitud de inicio de sesión de NT pasada de moda. En lugar de eso, puede crear un proceso de inicio de sesión personalizado dirigido a las necesidades del usuario. Para proteger aún más el proceso de autenticación, las cookies de autenticación de los formularios y los vales de autenticación están cifrados y a prueba de modificaciones.
No es necesario que el proveedor de la identidad del formulario resida en el equipo local y puede, de hecho, conectarse a un sistema de administración de identidades externo, que proporciona la validación de las credenciales de usuario. Esta funcionalidad se conoce como inicio de sesión único en la web y utiliza un módulo HTTP para la autenticación externa. En un escenario de tales características, puede federar las identidades entre la organización y los socios comerciales por las cuales pueden utilizar sus propios inicios de sesión de empresa para autenticar la implementación de MOSS.
3. Cifrado de cadenas de conexión de la aplicación MOSS Guardar la información importante de cadenas de conexión como texto sin formato en un archivo web.config, no es una práctica muy segura. La información expuesta puede permitir a un usuario crear una instancia de objeto en el servidor de base de datos SQL y manipular datos importantes. Sin embargo, mediante la funcionalidad heredada de ASP.NET 2.0 puede cifrar los datos con cualquiera de las dos tecnologías disponibles: cifrado API de protección de datos (DPAPI) de Windows o RSA. DPAPI aprovecha de la funcionalidad criptográfica integrada de Windows para cifrar y descifrar mediante la clave del servidor MOSS. El cifrado RSA permite utilizar algoritmos de claves públicas, pero supone el gasto agregado de contenedores adecuados y necesarios para las claves cifradas.
En MOSS 2007, y más concretamente en el proveedor de autenticación SQL Server de ASP.NET 2.0, es posible que desee cifrar el nodo <connectionStrings> en texto de cifrado, puesto que es muy probable que haya riesgo de seguridad:
<connectionStrings>
<add name="MembershipConnectionString"
     connectionString="connectionString"/>
</connectionStrings>
El uso del cifrado DPAPI es relativamente directo y el más fácil de implementar, puesto que utiliza el cifrado de claves del equipo nativo para un directorio virtual o físico. Hay otras formas de implementarlo mediante programación, pero el uso de los siguientes comandos en un símbolo del sistema resulta menos difícil:
aspnet_regiis.exe -pe section -app MOSS_virtual_directory -prov provider

aspnet_regiis.exe -pef section MOSS_physical_directory -prov provider
Puesto que sólo le interesa principalmente la implementación de cifrado del nodo de las cadenas de conexión, puede cifrar sólo esa sección especificando el parámetro de sección:
aspnet_regiis.exe -pef "connectionStrings" "C:\Inetpub\wwwroot\WssVirtual " -prov "Provider"

aspnet_regiis.exe -pe "connectionStrings" -app "/MOSSAppinstance" -prov "Provider"
Tras la implementación, los nodos de información confidencial se sustituirán por valores de cifrado XML correctos.
<connectionStrings confiProtectionProvider=
"EncryptionProvider">
<EncryptedData>
<CipherData>
<CipherValue>XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
</CipherValue>
<CipherData>
</EncryptedData>
</connectionStrings>
Al igual que la arquitectura general de MOSS, este modelo es conectable, ya que puede crear sus propios proveedores de cifrado con el fin de administrar texto cifrado para archivos importantes de configuración de MOSS, como web.config o machine.con, y, además, no está limitado al cifrado RSA ni al DPAPI.
El uso del cifrado tiene algunas consecuencias. Debido a que utiliza la clave del equipo local para el cifrado, sólo puede utilizar este nodo de configuración en el servidor MOSS en el que se creó, de lo contrario el proceso de cifrado no se realizará correctamente. Si un intruso obtiene acceso al servidor, puede recuperar la clave del equipo y descifrar la cadena de conexión. El proceso de descifrado también causará un pequeño impacto en el rendimiento de la aplicación.
4. Asignación de acceso alternativo y de acceso a zonas alternativas AAM es crucial, especialmente a la hora de instalar varias ubicaciones de entrada para el entorno de SharePoint. AAM permite simplemente especificar distintas URL a través de las que los usuarios pueden tener acceso a un solo sitio físico (consulte el diagrama de la figura 2). Puede enviar a los usuarios a la misma ruta física del sitio MOSS, pero con diferentes proveedores de autenticación y directivas de seguridad de la aplicación web. La AAM también compensa a la hora de utilizar distintos dominios, proxy inversos y otros mecanismos de redirección de URL. La URL que va a utilizar MOSS ya está asignada de forma predeterminada, pero esto se puede extender a URL adicionales que crea explícitamente un arquitecto de SharePoint para encargarse de los distintos métodos de entrada. La AAM es necesaria para garantizar que la asignación adecuada de las URL internas y públicas funciona correctamente.Un proveedor de autenticación de SQL Server
Veamos paso a paso la implementación del proveedor de autenticación conectable SQL Server de ASP.NET 2.0. Este proveedor utiliza la autenticación basada en formularios con cadenas de conexión web.config cifradas, una implementación muy típica para las distribuciones de MOSS perimetrales (de extranet).
El primer paso para la habilitación del proveedor SQL Server conectable es garantizar que la base de datos para el almacenamiento de las credenciales de usuario se crea en la instancia de SQL Server adecuada, de forma que el proveedor de servicios tenga algo que utilizar como almacén de datos de miembros. Para realizar esto, ejecute el siguiente comando desde el cuadro de diálogo Ejecutar o desde el símbolo del sistema:
%WINDIR%\Microsoft.NET\Framework\v2.0.50727\aspnet_regsql
Aparecerá el asistente de SQL Server que permite configurar la base datos para almacenar los datos de miembros.
Puesto que lo más probable es que no haya configurado aún el proveedor de suscripciones para el almacenaje de base de datos, configure SQL Server para los servicios de la aplicación, de forma que se cree una nueva base de datos. Si ya cuenta con una base de datos existente, puede agregar la información relevante (si la consolidación de la base de datos es uno de los objetivos de la empresa).
La cadena de conexión de SQL se conectará a esta instancia de SQL, por lo que debe configurar la base de datos para que utilice la autenticación de SQL Server (consulte la figura A). En este punto, utilizaré un nombre de usuario y contraseña sin formato, puesto que más adelante explicaré cómo utilizar la funcionalidad nativa de cifrado de ASP.NET 2.0 para ocultar la información de conexión privada en texto cifrado y así evitar la posible vulneración de la seguridad.

Creación del formulario de inicio de sesión
La autenticación basada en formularios se utiliza con frecuencia para la orientación externa de sitios que van a residir en una red perimetral y se van a exponer públicamente a todos los usuarios de Internet. Teniendo esto en cuenta, es mejor elegir la plantilla de MOSS en Internet a la hora de crear una colección de sitios de extranet. Con esta plantilla, no será necesario crear un formulario de inicio de sesión manualmente. Si va a ampliar un sitio actual o desea implementar un formulario de inicio de sesión personalizado, es fácil crear uno mediante Microsoft Studio® 2005. Apenas es necesaria la codificación.
Comience abriendo el directorio físico de la colección de sitios como sitio web en Visual Studio, almacenado normalmente en una ubicación como la siguiente:
C:\Inetpub\wwwroot\wss\VirtualDirectories\<GUID>
El primer paso es agregar una página default.aspx, ya que es el documento predeterminado en la configuración del servidor virtual IIS. Utilice el comando Add Item en el Explorador de soluciones y, a continuación, agregue un control de inicio de sesión a la superficie de formulario web recién creada mediante el cuadro de herramientas de Visual Studio.
Figura a Configuración de la autenticación de SQL Server
Figura a Configuración de la autenticación de SQL Server (Hacer clic en la imagen para reducirla)
Figura a Configuración de la autenticación de SQL Server
Figura a Configuración de la autenticación de SQL Server (Hacer clic en la imagen para ampliarla)

Figura b Selección del proveedor de autenticación mediante la pantalla Administración de aplicaciones (Hacer clic en la imagen para reducirla)
Figura b Selección del proveedor de autenticación mediante la pantalla Administración de aplicaciones
Figura b Selección del proveedor de autenticación mediante la pantalla Administración de aplicaciones (Hacer clic en la imagen para ampliarla)
En la misma página, asegúrese de que el proveedor que se está utilizando para la autenticación en la sección del proveedor de suscripciones se haya especificado como AspNetSqlMembershipProvider y que el nombre del administrador de funciones sea AspNetSqlRoleProvider. Especifique si desea que los usuarios finales tengan acceso anónimo desplazándose hasta /_layouts/setanon.aspx y seleccionando el sitio completo o la configuración de seguridad que se ajusta más a sus necesidades.
Los cambios principales se realizan mediante la modificación de web.config. Asegúrese de que el elemento <autenticación> se haya establecido para utilizar el elemento <formularios>. Esto se configura normalmente de forma automática al cambiar de la autenticación Windows a la autenticación Formularios y es una fase importante del proceso de inicio de sesión, ya que se encarga de los datos acerca de los vales de autenticación de los usuarios, que a su vez comprobarán las credenciales de los usuarios en la devolución de la página mediante los métodos de autenticación de ASP.NET 2.0. Pero web.config no detecta aún la conexión SQL al almacén del usuario, por lo que debe agregar la entrada de la cadena de conexión para conectarse a la base de datos de miembros:
<connectionStrings>
<remove name="LocalSqlServer" />
<add name="LocalSqlServer" connectionString="Server=SQLserver;
Database=aspnetdb;uid=username;
pwd=password;" providerName="System.Data.SqlClient" />
</connectionStrings>
Realice las mismas modificaciones en el sitio de la administración central del archivo web.config para promover la conformidad de los tipos de autenticación y garantizar que PeoplePickerWildCard se resuelve en AspNetSqlMembershipProvider para que los controles de búsqueda para agregar usuarios conozcan la ruta correcta que se desea buscar.
Puesto que está realizando cambios en archivos XML del servidor, MOSS requiere que se reestablezca IIS. Una vez conectado a la base de datos de SQL Server, puede explorar el sitio web con facilidad, excepto si no cuenta con propietarios de la colección de sitios para administrar el contenido. En WAT, haga clic en la ficha Seguridad y agregue un usuario, a continuación convierta a este usuario en administrador de una colección de sitios en Administración de sitios de SharePoint agregando los usuarios apropiados en Administradores de colección de sitios. El nombre debe ser correcto debido a las modificaciones realizadas anteriormente en el nodo peoplepicker en web.config.
Por último, cifre las cadenas de conexión con DPAPI; para ello, abra el cuadro de diálogo de ejecución y ejecute:
aspnet_regiis.exe -pef "connectionStrings"
"C:\Inetpub\wwwroot\WssVirtual\<GUID> "
£prov "DataProtectionConfigurationProvider"
Una vez la operación haya finalizado correctamente, aparecerá un cuadro de diálogo de confirmación.

Figura 2 Zonas y asignación de URL
Figura 2 Zonas y asignación de URL (Hacer clic en la imagen para reducirla)
Figura 2 Zonas y asignación de URL
Figura 2 Zonas y asignación de URL (Hacer clic en la imagen para ampliarla)
En MOSS, las zonas son una nueva característica que permite un mayor control sobre la asignación del sitio que proporciona la AAM. Estas zonas permiten asignar diferentes proveedores de autenticación a la misma ruta física y al contenido de MOSS según las asignaciones de URL de la AAM, mediante las cuales los usuarios se conectan al contenido. Aunque no es necesario que la zona esté enlazada a un mecanismo de autenticación, se recomienda a la hora de especificar asignaciones de URL de la AAM. Si se asigna una URL de la AAM a una zona no definida en la página de los proveedores de autenticación, se utilizará la configuración de seguridad para la zona predeterminada.
Es necesario algún tipo de planeación para las zonas, ya que éstas afectarán en gran medida al modo en el que los usuarios se autentican y enrutan a través del portal a partir de varios puntos de entrada de URL. A la hora de ampliar una nueva aplicación web, puede especificar la zona que desea utilizar en la sección Dirección URL de carga equilibrada de la configuración (consulte la figura 3). Se recomienda colocar la URL de acceso más público (por ejemplo, la URL que va a exponer en Internet) en la zona Predeterminado, ya que esta es la URL que utilizará SharePoint si no puede determinar por completo la zona en la que se encuentra.
Figura 3 Configuración de las zonas de MOSS
Figura 3 Configuración de las zonas de MOSS (Hacer clic en la imagen para reducirla)
Figura 3 Configuración de las zonas de MOSS
Figura 3 Configuración de las zonas de MOSS (Hacer clic en la imagen para ampliarla)
En cada zona puede enlazar una directiva global de seguridad de la aplicación web que defina la configuración de los permisos de los usuarios de la zona. Esto le permite administrar de manera centralizada las modificaciones de permisos a gran escala. Las aplicaciones web incluyen normalmente varios sitos en varias colecciones de sitios y la administración de permisos de estos sitios puede llegar a ser problemática cuando las aplicaciones sean más extensas y complejas. MOSS 2007 permite las directivas globales de seguridad que enlazan la configuración de la directiva, como el acceso total, el acceso de lectura total, el acceso de escritura denegada o el acceso total denegado a un usuario determinado o un grupo dentro de la aplicación. Estas directivas pueden omitir la configuración de permisos granulares que proporciona MOSS administrados desde la interfaz de la administración central de SharePoint, por lo que deberá realizar la configuración con cuidado.
En otras palabras, el sitio orientado externamente puede tener dos URL como se define en la configuración de la AAM: una para que tengan acceso los usuarios de la empresa y otra para los usuarios externos. Cada uno de ellos tiene una URL exclusiva, puede que contoso para los usuarios internos, y extranet.contoso.com para los asociados externos de confianza. Mientras estas URL se asignen al mismo contenido, todos los usuarios pueden tener acceso al sitio a través de su propia zona, con su propio proveedor de autenticación y su propia directiva de seguridad de la aplicación. La configuración de la zona de intranet en la URL interna permite a los usuarios internos resolver en las identidades de Windows autenticadas por el dominio mientras que los asociados externos inician sesión mediante la autenticación de inicio de sesión único en la web a través de la zona de extranet, que les permite utilizar las credenciales de usuario propias de la organización. Si se aprovecha el enlace de las directivas de seguridad de la aplicación web a zonas, es posible proporcionar acceso de lectura total a todos los usuarios externos de confianza, en oposición a su configuración de forma manual objeto por objeto.
5. Contenido dirigido a la colaboración segura El bloqueo de las colecciones de sitios de SharePoint permitirá a los usuarios manipular sólo la información a la que se les haya otorgado acceso. Los nuevos mecanismos de permisos flexibles permiten un mayor control sobre los diversos tipos de información empresarial almacenada en el entorno de MOSS.
MOSS 2007 ofrece la opción de enlazar una identidad a un objeto determinado, ya sea una colección de sitios, un sitio individual, una biblioteca de documentos, una subcarpeta, una lista o bien, un documento o un elemento de lista individual. Esto refuerza los controles de acceso granulares y las solicitudes explícitas a dicho elemento, denegando el acceso y ajustando la interfaz del usuario de manera que los usuarios sean conscientes de los elementos a los que no tienen acceso. Esta funcionalidad de MOSS se conoce como seguridad a nivel de elementos (ILS) u objetos seguros (SO). Los permisos de objeto de MOSS poseen una naturaleza jerárquica, permitiéndoles escalar de objetos individuales como elementos de lista a elementos más grandes como una lista o una biblioteca de documentos. Es posible implementar la herencia de permisos, permitiendo a los objetos secundarios de nivel más bajo heredar permisos de forma opcional a partir de objetos principales de nivel más alto. Hay 33 permisos exclusivos predeterminados que se pueden otorgar a un usuario o a un grupo de SharePoint, cada uno de los cuales se puede enlazar a un objeto. También se pueden crear nuevos niveles de permiso.
Por ejemplo, en un sitio de administración de proyectos puede permitir sólo a los desarrolladores y a los administradores del proyecto tener acceso al material de desarrollo confidencial, como especificaciones de diseño y técnicas de codificación integradas en documentos de Microsoft Word almacenados en una biblioteca de documentos. Los permisos de la biblioteca se heredarán de forma predeterminada de los permisos del sitio pero se pueden modificar para otorgar acceso sólo a los desarrolladores y a los administradores del proyecto, o incluso para que el administrador del proyecto y el equipo de desarrollo sean los únicos que puedan ver los documentos de Word y tener acceso a ellos. Por el contrario, el material que no sea confidencial se puede hacer completamente público, ya sea un elemento, una carpeta o un nivel de biblioteca o documento.
Los permisos se pueden especificar incluso en elementos de eventos, como fechas de vencimiento ubicadas en una lista Eventos, para poder garantizar que sólo algunos miembros van a ver eventos específicos. Además, la funcionalidad ILS se amplía para devolver resultados de búsqueda en los que sólo se devolverán objetos que vuelvan a asignar el contexto de seguridad de la persona que realiza la búsqueda. Todos estos controles aplicados restringirán la interfaz de usuario al contexto de usuario exclusivo.
La arquitectura de administración de permisos se ha mejorado en gran medida en MOSS 2007. Los permisos se pueden establecer para los grupos SharePoint y los grupos de dominio, así como a nivel individual. Se aplican varios grupos de forma predeterminada, en concreto Propietarios (que tienen el control total), Visitantes (con derechos de colaborador) y Miembros (con derechos de lectura). Los grupos individuales o de dominio se pueden asignar a los grupos predeterminados o personalizados que puede crear y administrar en el nivel de colección de sitios, los cuales pueden tener varios niveles de permiso exclusivos.
Al crear grupos basados en funciones, puede crear grupos de "desarrolladores" y de "administradores de proyectos". A continuación, puede asignar permisos granulares que permiten, por ejemplo, a los desarrolladores cargar documentación relevante de codificación y otorgar permisos de lectura y aprobación a los administradores de proyectos para que puedan evaluar y aprobar dichos documentos. La pertenencia a grupos sigue siendo coherente en toda la colección de sitios, de forma que los grupos creados se pueden volver a utilizar en diversos sitios de proyectos distintos.
6. Integración de inicio de sesión único conectable En un entorno informático típico, los usuarios pueden tener acceso a las aplicaciones de terceros que desee, cada una con sus criterios de autenticación propios, lo que lleva a varios problemas de seguridad y a la fatiga de la contraseña. El servicio SSO de MOSS ayuda a aliviar este problema mediante la asignación de la caché de servidor cifrada de las credenciales de los usuarios a sistemas de línea de negocio conectados. Esto puede ayudar a la recuperación de la información esencial de las empresas que se va a mostrar en mecanismos de MOSS como el catálogo de datos profesionales (BDC) o los elementos web Vista de datos de SharePoint (DVWP).
El proveedor de SSO de MOSS es conectable, al igual que algunas de las características de la arquitectura de la aplicación restantes analizadas anteriormente; puede especificar un proveedor de SSO exclusivo aparte del que se incluye con MOSS (SpsSsoProvider), aunque sólo se puede registrar un proveedor de SSO por sistema de línea de negocio a la vez dentro del mismo entorno.
7. Information Rights Management (IRM) La protección de información en el nivel de cliente, incluso cuando la información empresarial se utiliza sin conexión, es un problema considerable para las empresas que tienden a trabajar con datos de naturaleza confidencial, especialmente los relacionados con la legislación, como el proyecto de ley 1386 del Senado de California, la ley Sarbanes-Oxley (Cumplimiento de SOX) y la ley de transferencia y responsabilidad de seguros de salud (HIPAA). Information Rights Management (IRM) del servidor se integra con los repositorios de MOSS para proporcionar una solución habitual integrada en el marco de Windows Rights Management (WRM). IRM le ofrece un control estricto sobre los datos profesionales, imponiendo restricciones de acceso en el nivel de documentos, independientemente de la ubicación en la que se almacene el documento o de la persona que intente abrirlo. Mediante la implementación habitual de IRM puede permitir únicamente presentaciones o impresiones autorizadas, pero esto se puede aplicar a otros escenarios como la solicitud de la comprobación de las credenciales de usuarios después de un cierto periodo de tiempo; la no permisión de los usuarios para cargar activos que no se aprovechen de IRM; una etiqueta de caducidad programada que descarta la directiva de restricción y el enlace a una directiva de permisos de IRM de organización global.
Con MOSS 2007 se instalan protectores que proporcionan la funcionalidad IRM. Un protector es una aplicación que administra el proceso de cifrado de un tipo de archivo; normalmente todos los archivos almacenados en MOSS ya cuentan con protectores integrados. Los archivos del sistema de Microsoft Office son compatibles de forma nativa, junto con los formatos de archivo OpenXML. Sin embargo, al igual que otros proveedores de MOSS, la arquitectura de la aplicación es conectable de manera que puede implementar protectores personalizados para otros tipos de archivo.
El primer paso en la implementación de IRM es garantizar que se reúnen todos los requisitos en el entorno de MOSS. Será necesario tener instalado el cliente de servicios de WRM en todos los servidores web de cliente y Microsoft Rights Management Services (RMS) debe tener conectividad a los servidores web de cliente de MOSS. A continuación, debe especificar el servidor RMS para que MOSS se asimile en la administración central de SharePoint, mediante el uso del servidor predeterminado en Active Directory o la especificación de la ubicación.
IRM trabaja directamente con estructuras de almacenes de datos de SharePoint como bibliotecas de documentos para mantener los permisos. Cuando un usuario llega hasta una biblioteca de documentos habilitada para IRM para descargar un documento, MOSS enlaza los permisos configurados para la biblioteca de documentos al documento (consulte la figura 4). Como resultado, hay una asignación 1:1 entre MOSS y los permisos de documentos, traduciendo las funciones de SharePoint relacionadas con el documento a niveles de permiso de IRM en el mismo documento.
Figura 4 Transición de permisos de IRM a partir de una biblioteca de documentos
Figura 4 Transición de permisos de IRM a partir de una biblioteca de documentos (Hacer clic en la imagen para reducirla)
Figura 4 Transición de permisos de IRM a partir de una biblioteca de documentos
Figura 4 Transición de permisos de IRM a partir de una biblioteca de documentos (Hacer clic en la imagen para ampliarla)
El documento se cifra localmente para la protección fuera de línea y se mantiene en este estado hasta que se vuelve a cargar en la biblioteca de documentos. Cuando el documento está cargado, mantiene su forma no cifrada para que el recopilador de SharePoint pueda indizar su contenido para la búsqueda de texto completo (aunque no haya disponible ninguna cuenta de usuario para tener acceso al contenido en su forma no cifrada).
MOSS 2007 proporciona una serie de nuevas características que pueden ayudarle a implementar una seguridad eficaz en su organización sin un mayor gasto en la administración. Y lo que es mejor, las características son muy flexibles y permiten un gran nivel de personalización que garantiza a los usuarios el acceso a la información que necesitan. Para obtener un ejemplo sencillo, consulte en la barra lateral "Un proveedor de autenticación de SQL Server".

Adam Robert Buenz es arquitecto de SharePoint y desarrollador de ARB Security Solutions LLC (sharepointsecurity.com). Adam está especializado en los entornos de colaboración centrados en la seguridad. Póngase en contacto con él en adam@sharepointsecurity.com.


 SharePoint: Encu&#233;ntrelo todo con la b&#250;squeda empresarial de SharePoint
SharePoint Matt Hester

Encuéntrelo todo con la búsqueda empresarial de SharePoint
Resumen:
  • Arquitectura de una solución de búsqueda empresarial
  • Indización y consulta de datos profesionales
  • Datos de LOB y conocimientos del personal

Probablemente pierde una gran cantidad de tiempo preocupándose por cuestiones como el tiempo de actividad y la disponibilidad del servidor, las actualizaciones de software y la seguridad. Pero aunque su infraestructura funcione perfectamente (todas las aplicaciones y
todos los archivos están disponibles en la red), es posible que los usuarios sigan perdiendo productividad. No hay duda de que todos los datos que necesitan están disponibles, pero ¿cuánto tiempo tardan en encontrarlos?
Se ha hecho mucho por ayudar al personal a enfrentarse a la sobrecarga de información. Las herramientas de búsqueda en el escritorio han facilitado la búsqueda de información oculta entre el resto de datos almacenados en el sistema. Consulte mi artículo de agosto de 2006 "Encuéntrelo todo con la Búsqueda en el escritorio de Windows" (en inglés). Y qué decir de toda la información disponible en portales, almacenada en recursos compartidos y contenida en aplicaciones empresariales, sin olvidar la valiosa información que guardan en sus mentes los empleados. Esta información es vital para los usuarios: la necesitan para realizar sus trabajos y la necesitan con rapidez para tomar decisiones empresariales oportunas y precisas. Sin embargo, piense en el tiempo que necesita uno de los usuarios para encontrar y recopilar datos dispersos por la red. Ahora piense en las consecuencias posibles que esto tiene en los resultados de la empresa.
Es necesario que reduzca la cantidad de tiempo que los usuarios tardan en encontrar información almacenada en la empresa. ¿Cómo puede hacerlo? La respuesta es bastante sencilla: mediante un motor de búsqueda que ofrezca capacidades de búsqueda empresarial.
La búsqueda empresarial permite buscar información almacenada prácticamente en cualquier lugar de la organización. Ya se trate de buscar datos almacenados en el escritorio, guardados en un sitio de la intranet, en una aplicación de línea de negocio (LOB) o en la mente de un empleado, una herramienta de búsqueda empresarial puede resultar de ayuda. No se preocupe: no tendrá que implantar ningún chip en el cerebro de los usuarios.
Una solución de búsqueda empresarial combina la búsqueda en el escritorio con capacidades de búsqueda rápida en la intranet. En última instancia, una herramienta de búsqueda empresarial debe ser capaz de realizar búsquedas agrupadas, esto es, aquéllas que pueden tener acceso a varios orígenes de datos mediante una sola consulta. El usuario cuenta con una única interfaz en la que introduce la consulta. Sin embargo, de manera subyacente, la consulta se envía a varios motores de búsqueda distintos y luego los resultados se muestran en una vista agregada.
En este artículo, trataré cómo Microsoft® Office SharePoint® Server 2007 (MOSS 2007), la próxima generación de soluciones de Microsoft SharePoint, ofrece un eficaz motor de búsqueda que le ayudará a terminar con los depósitos de información de la organización. MOSS 2007 ofrece numerosas mejoras frente a versiones anteriores, componentes desarrollados de nuevo por completo y algunas características totalmente nuevas. Analizaré algunos de estos componentes clave, como la indización, la propagación, la relevancia y los orígenes de contenido, así como el modo en que permitirán ofrecer mejores capacidades de búsqueda empresarial a los usuarios.

Búsquedas en la empresa con SharePoint
La búsqueda empresarial estará disponible en cuatro versiones con diferencias notables: Microsoft Office SharePoint Server 2007 for Search Standard Edition, Microsoft Office SharePoint Server 2007 for Search Enterprise Edition, Microsoft Office SharePoint Server 2007 Standard y Microsoft Office SharePoint Server 2007 Enterprise.
La principal diferencia entre las dos ediciones Search Edition y las ediciones completas de SharePoint Server es que las dos ediciones Search Edition no incluyen la funcionalidad de búsqueda de personas (que también incluye la integración con la red de conocimiento para MOSS 2007), el catálogo de datos profesionales ni el centro de búsqueda mejorado con fichas personalizables. En la figura 1 se muestran las diferencias principales.
Figure 1 Diferencias principales de las cuatro opciones de búsqueda (Close Figure 1)

 | Microsoft Office SharePoint Server 2007 for Search Standard Edition | Microsoft Office SharePoint Server 2007 for Search Enterprise Edition | Microsoft Office SharePoint Server 2007 Standard Edition | Microsoft Office SharePoint Server 2007 Enterprise Edition
Índices | 40 tipos de archivo incluidos (extensible) | 40 tipos de archivo incluidos (extensible) | 40 tipos de archivo incluidos (extensible) | 40 tipos de archivo incluidos (extensible)
Compatibilidad (incluida) con búsqueda en recursos compartidos de archivos, sitios web, sitios de SharePoint, carpetas públicas de Exchange, archivos de bases de datos de Notes |  |  |  |
Compatibilidad con búsqueda en repositorios de documentos de terceros |  |  |  |
Compatibilidad con búsqueda de personas y experiencia |  |  |  |
Compatibilidad con búsqueda en orígenes de datos estructurados |  |  |  |
Ofrece control de acceso a contenido seguro |  |  |  |
Ofrece interfaz de usuario de Centro de búsqueda mejorada |  |  |  |
Límite de documentos | 400,000 | Sin límite | Sin límite | Sin límite
La interfaz de usuario ofrece una serie de características nuevas, entre las que se incluyen las capacidades del tipo "¿Quiso decir?". Estas funciones, fundamentales en los motores de búsqueda de Internet, le aconsejan cuando escribe mal un término de búsqueda habitual (consulte la figura 2). La interfaz también incluye el resaltado de coincidencias y una compatibilidad completa con "opciones más probables". Aunque esto es sólo un resumen de las nuevas capacidades de búsqueda.
Figura 2 Nueva funcionalidad 'Quiso decir...' en las búsquedas de SharePoint
Figura 2 Nueva funcionalidad 'Quiso decir...' en las búsquedas de SharePoint (Hacer clic en la imagen para reducirla)
Figura 2 Nueva funcionalidad 'Quiso decir...' en las búsquedas de SharePoint
Figura 2 Nueva funcionalidad 'Quiso decir...' en las búsquedas de SharePoint (Hacer clic en la imagen para ampliarla)

Búsqueda de conocimientos del personal
Una de las nuevas características más interesantes es la capacidad de buscar entre el personal con unos conocimientos y una experiencia determinados. Esto permite a los usuarios aprovechar los conocimientos de los empleados de la organización, lo que supone un paso importante para terminar con los depósitos de información.
Para ello, se pueden llevar a cabo indizaciones y búsquedas en cualquier directorio de protocolo ligero de acceso a directorios (LDAP), que incluye las listas de distribución de Active Directory® y los grupos de usuarios de SharePoint. En realidad, MOSS no busca en los directorios LDAP directamente; para habilitar la búsqueda de personas, es necesario importar la información de LDAP en MOSS. Las búsquedas también se pueden realizar en toda la infraestructura de la empresa.
Los resultados de búsqueda se pueden agrupar de acuerdo con la "diferencia social" del individuo (esto hace referencia a la diferencia con respecto al puesto de un usuario (probablemente un vendedor deseará no tener que llamar al director financiero) y los intereses comunes. En la figura 3 se muestran los resultados de una búsqueda de personas.
Figura 3 Búsqueda de compañeros con conocimientos relevantes
Figura 3 Búsqueda de compañeros con conocimientos relevantes (Hacer clic en la imagen para reducirla)
Figura 3 Búsqueda de compañeros con conocimientos relevantes
Figura 3 Búsqueda de compañeros con conocimientos relevantes (Hacer clic en la imagen para ampliarla)

Búsqueda de datos profesionales
SharePoint también puede indizar varios tipos de datos profesionales. Esto incluye aplicaciones de línea de negocio (como aplicaciones de RR.HH., CRM, informes de gastos, etc.). Habitualmente, es difícil obtener acceso a este tipo de datos fuera de la interfaz normal de la aplicación de LOB, lo que dificulta a la mayoría de los empleados el descubrimiento y uso de estos datos.
Sin embargo, ahora la búsqueda de MOSS puede recuperar datos de cualquier aplicación de LOB, como una base de datos relacional o una base de datos de Lotus Notes, a la que se pueda obtener acceso a través de ADO.NET o servicios web. Lo especial de esta característica es que no es necesario escribir ningún código personalizado. Con la característica Catálogo de datos profesionales, la obtención de datos profesionales resulta tan sencilla como obtener acceso a un documento o sitio web. Esta característica se puede integrar fácilmente con la administración de propiedades y los ámbitos personalizados que ofrece el centro de búsqueda.

Obtención de relevancia
Naturalmente, cualquier característica nueva tendría poco valor si no ofreciera resultados precisos. Por suerte, MOSS ofrece algunas mejoras impresionantes con respecto a la relevancia. No obstante, antes de tratar estas mejoras, es importante que comprenda las diferencias entre la relevancia en la empresa y la relevancia en Internet.
Es posible que se pregunte por qué las búsquedas de intranet no se pueden basar en las mismas herramientas (ni tampoco en la misma precisión) que las búsquedas de Internet. Simplemente tenga en cuenta que se trata de dos entornos muy distintos, con necesidades y requisitos muy diferentes. Estas diferencias se pueden agrupar en tres categorías principales: seguridad, estructura y jerarquía.
La seguridad hace referencia a la naturaleza de Internet en contraposición a la empresa. A los datos de Internet se suele tener acceso de forma anónima; la indización y la búsqueda no requieren autenticación ni restricciones de seguridad. Los entornos empresariales, por otro lado, suelen seguir un modelo de seguridad rígido, que incluye el filtrado de los resultados para adecuarse a los permisos de la persona que realiza la búsqueda.
El impacto de la estructura está relacionado con la densidad. Internet es un entorno rico y profundo, con sitios vinculados a otros sitios con el fin de aumentar el contenido. Sin embargo, en el entorno empresarial, los vínculos suelen usarse para la exploración y la estructura es mucho menos densa.
Ligeramente relacionado con la estructura de vínculos está el factor de la jerarquía del sitio. En Internet, no suele haber ninguna jerarquía en los sitios y hay muy pocos sitios de nivel superior. Las intranets de las empresas, sin embargo, suelen estar planeadas y tener una estructura jerárquica. Incluso cuando una empresa tiene varios niveles raíz principales, suele haber un único portal principal para la organización.
Estas diferencias fundamentales hacen que la forma en que una solución de búsqueda empresarial indiza datos y devuelve resultados sea diferente. MOSS 2007 se centra en responder mejor a las necesidades de la empresa. Cuenta con un nuevo motor de clasificación, desarrollado gracias a la tecnología existente y al trabajo de Microsoft Research y el equipo de MSN®. La relevancia se ha incrementado mediante la creación de una serie de algoritmos de relevancia, que recopilan información interna y externa de los documentos y de los datos de línea de negocio que se rastrean. Al indizar los datos de una empresa, se exploran más de 200 tipos de documentos y se aplican algoritmos para detectar el idioma, extraer metadatos y realizar análisis de textos. Estos nuevos algoritmos, que están optimizados expresamente para responder a las necesidades de los datos empresariales y las aplicaciones de LOB, mejoran de manera espectacular la precisión de los resultados.
En los cálculos de relevancia, se incluyen varias etiquetas de metadatos. A continuación se muestran algunos de los aspectos que se han tenido en cuenta:
  • Distancia de clics Distancia de exploración desde los sitios autoritativos (las distancias más cortas suelen tener más importancia).
  • Texto de hipervínculo Los hipervínculos actúan como anotaciones sobre sus destinos. Además, suelen ser muy descriptivos.
  • Profundidad de URL Las direcciones URL superiores de la jerarquía suelen tener más importancia.
  • Concordancia de URL Concordancias directas de texto que está en las direcciones URL.
  • Extracción de metadatos Si faltan, se extraen automáticamente títulos y autores del texto del documento.
  • Detección automática de idioma Permite establecer la preferencia de resultados en el idioma del usuario.
  • Influencia de tipo de archivo Ciertos tipos de archivo suelen tener más importancia (por ejemplo, los archivos PPT suelen ser más relevantes que los archivos XLS).
  • Análisis de textos Clasificación tradicional de textos basada en factores como términos coincidentes, frecuencia de términos y variantes de palabras.

¿Cómo funciona la indización?
MOSS 2007 cuenta con importantes mejoras relativas al funcionamiento del servicio de indización y a la administración de contenido. Los principiantes pueden especificar si el origen del contenido son servidores de SharePoint, sitios web, recursos compartidos de archivos, carpetas públicas de Exchange, bases de datos de Lotus Notes o aplicaciones de LOB. La experiencia administrativa de indización general se ha simplificado y ahora puede elegir libremente qué, cómo y cuándo indizar entre varios orígenes de contenido. Estos procedimientos se controlan con reglas de rastreo, que permiten especificar rutas de acceso para incluirlas o excluirlas. Puede configurar incluso el modo en que el rastreador (crawler) seguirá los vínculos de una dirección URL. Un registro integrado ofrece una visión general del número de sitios rastreados y de cómo se han indizado.
Este índice es similar a la tecnología de índice usada en la Búsqueda en el escritorio de Windows®. Dos componentes principales forman el índice: un índice de contenido y un almacén de propiedades. Se trata de un modo sumamente eficaz de procesar los datos. El índice de contenido incluye el texto real de los archivos así como un índice invertido de palabras asociadas que están en el índice empresarial. La base de datos de almacén de propiedades es fundamental para procesar los resultados. Esta base de datos contiene todas las propiedades de metadatos adicionales (autor, fecha de creación, tipo de documento, etc.) de todos los documentos del almacén. Desde un punto de vista estructural, el almacén de propiedades se compone de una tabla de propiedades y sus valores. Cada fila de la tabla se corresponde con un documento independiente del índice del texto completo. El almacén de propiedades también mantiene y aplica la seguridad del nivel de documento que se obtiene al indizar un documento.
El proceso de indización y almacenamiento comienza con el motor de índice, que es responsable de rastrear el origen de contenido. El motor comienza a rastrear después de comprobar que cuenta con un controlador de protocolo adecuado para leer los orígenes de contenido. Una vez cargado el controlador correcto para el origen de contenido, el controlador de protocolo y los IFilters necesarios extraen y filtran los elementos del origen de contenido. Un IFilter es un complemento que permite al motor de índice abrir, leer e indizar el contenido de nuevos tipos de archivo que en otras circunstancias no podría indizar por completo. Los IFilters extraen el texto y los metadatos de cada documento y luego devuelven la secuencia al motor de índice.
A continuación, las propiedades del documento se guardan en el almacén de propiedades y el texto real del documento se coloca en el índice de contenido. Justo antes de que esto ocurra, el motor de índice elimina las palabras "irrelevantes". El motor también procesa la información mediante separadores de palabras y lematizadores para simplificar los datos, lo que permite una mejor ejecución de las consultas. Los separadores dividen el texto en palabras y frases. Los lematizadores generan variantes de un término determinado.
El motor de índice usa la propagación continua, que permite crear el índice casi de inmediato. Con este tipo de propagación, el índice sigue generándose aun cuando el proceso de rastreo se desplace por los orígenes de contenido. Esta mejora permite obtener resultados inmediatos, lo que supone un avance espectacular frente a SharePoint Portal Server 2003, donde un rastreo de contenido considerable podía tardar días y el índice sólo se propagaba una vez terminado el rastreo.

¿Cómo funcionan las consultas?
Cuando un usuario introduce una consulta o una aplicación personalizada llama al índice, el motor de consulta comienza a procesar la solicitud. Primero transfiere la consulta a un separador de palabras específico del idioma. Si no se puede identificar el idioma, se invoca un separador de palabras neutro. Una vez descompuesta la consulta, el motor transfiere la información al lematizador (si la lematización está activada) para llevar a cabo un procesamiento adicional. Este proceso de dos pasos mejora la relevancia y la efectividad de los resultados devueltos por la consulta.
Si la consulta especifica información de propiedades, primero se comprueba el índice de contenido en busca de concordancias con los documentos del almacén de propiedades y luego se comprueban de nuevo las propiedades de la consulta para garantizar la concordancia. El motor de consulta proporciona un nivel adicional de filtrado con el fin de eliminar resultados para los que el usuario no tiene permiso de acceso. Los resultados coincidentes se devuelven en una lista, ordenada según la relevancia. En la figura 4 se muestra la correspondencia de todos los elementos de indización y consulta.
Figura 4 Arquitectura del entorno de búsqueda empresarial de MOSS 2007
Figura 4 Arquitectura del entorno de búsqueda empresarial de MOSS 2007 (Hacer clic en la imagen para reducirla)
Figura 4 Arquitectura del entorno de búsqueda empresarial de MOSS 2007
Figura 4 Arquitectura del entorno de búsqueda empresarial de MOSS 2007 (Hacer clic en la imagen para ampliarla)

Administración mejorada
La administración del entorno de búsqueda resultará más sencilla para los administradores. El conjunto mejorado de herramientas comunes para los usuarios finales y los administradores ayuda a reducir la complejidad que agregan los distintos puntos de conexión de la plataforma. Asimismo, el motor de búsqueda se beneficia considerablemente del nuevo modelo de administración de MOSS 2007. En la figura 5 se muestra la página principal usada para modificar la configuración de búsqueda.
Figura 5 Configuración de parámetros de búsqueda
Figura 5 Configuración de parámetros de búsqueda (Hacer clic en la imagen para reducirla)
Figura 5 Configuración de parámetros de búsqueda
Figura 5 Configuración de parámetros de búsqueda (Hacer clic en la imagen para ampliarla)
Los ámbitos, que permiten controlar las distintas capacidades de búsqueda, también se han mejorado. Los ámbitos permiten realizar búsquedas de forma sencilla en un origen de contenido, lo que permite básicamente administrar el índice en grupos más pequeños. En SharePoint Portal Server 2003, los ámbitos están conectados con los orígenes de contenido, lo que los hace menos flexibles y un tanto difíciles de administrar. En MOSS 2007, los ámbitos son independientes de los orígenes de contenido, lo que ofrece un mayor grado de flexibilidad. Puede definir ámbitos según propiedades de contenido arbitrarias, como URL, tipo o autor. Incluso puede combinar ámbitos para disponer de varias reglas, por ejemplo, todos los documentos técnicos de un autor específico.
Naturalmente, si un administrador desea mejorar el rendimiento del motor de búsqueda, uno de los procedimientos más recomendables es conocer el uso actual del índice. Entre las novedades del conjunto de herramientas administrativas, destacan los informes de consulta. La funcionalidad incluida de informes de consulta permite buscar de forma rápida información sobre tendencias de volúmenes de consulta, consultas más frecuentes, índices de click-through, consultas sin resultados, etc. Los informes de consulta pueden ofrecer detalles del nivel de sitio y de los niveles de proveedores de servicios centrales. En la figura 6 se ofrece un informe de muestra. Puede exportar la información a Microsoft Excel® para realizar un análisis más detallado y cambiar la distribución de los datos.
Figura 6 Informe de consulta en MOSS 2007
Figura 6 Informe de consulta en MOSS 2007 (Hacer clic en la imagen para reducirla)
Figura 6 Informe de consulta en MOSS 2007
Figura 6 Informe de consulta en MOSS 2007 (Hacer clic en la imagen para ampliarla)

Seguridad y privilegios
Como mencioné anteriormente, el motor de consulta filtra los resultados, de forma que la lista que ve el usuario sólo incluye los documentos a los que el usuario tiene permiso de acceso. En SharePoint Portal Server 2003, se presentan vínculos al usuario para los que puede que no tenga los permisos adecuados para continuar. Una excepción relacionada con las restricciones de seguridad es que MOSS 2007 no restringe los rastreos web. No se pueden restringir los sitios web debido a que el protocolo HTTP no puede volver a leer la información de control de acceso. Asimismo, MOSS 2007 no permite restringir por seguridad el catálogo de datos profesionales ni las búsquedas de personas.
MOSS 2007 respeta las listas de control de acceso (ACL) existentes, lo que garantiza la seguridad de los documentos del índice. Ésta es una diferencia destacable con respecto a otras herramientas de búsqueda. A diferencia de algunos motores de búsqueda, que necesitan usar un archivo de configuración para establecer permisos de archivos de forma manual, MOSS 2007 permite mantener la sincronización con los permisos actuales.
El índice puede reflejar los cambios de ACL con rapidez para un solo documento. Supongamos, por ejemplo, que hay una hoja de cálculo de Excel almacenada en el índice y se cambia la ACL del documento para que sea restrictiva. Un administrador puede volver a indizar y rastrear solamente ese documento y la restricción de seguridad se producirá de inmediato (y, en caso necesario, el documento se puede eliminar por completo del índice).
Igualmente, se pueden asignar permisos exclusivos a documentos individuales o se puede establecer que hereden la configuración de permisos de una biblioteca de documentos o directorio principal. Esto simplifica en gran medida el proceso de selección de grupos o individuos a los que se permitirá ver, editar y guardar documentos.
También se han realizado mejoras con respecto a la autenticación y la administración de inicio de sesión. La caché de credencial segura ahora es extensible, lo que permite que MOSS acepte sistemas de almacenamiento en caché de credencial de inicio de sesión único de orígenes de terceros y complementos de código personalizado. Asimismo, la autenticación principal puede aceptar ahora sistemas de terceros. Estas dos mejoras se basan en el nuevo modelo de proveedor de ASP.NET, que permite el uso de otros servicios de directorio.

Personalización
En MOSS 2007, cuenta con una serie de opciones para modificar la interfaz de usuario. Puede personalizarla con muchas de las herramientas que ya usa para modificar los sitios web. También hay nuevas herramientas, como Office SharePoint Designer, que permite crear páginas principales (y ofrece una forma sencilla de crear sitios con un distintivo específico). En la figura 7 se muestra una página de resultados de búsqueda en proceso de edición.
Figura 7 Personalización del aspecto de una página de resultados de búsqueda
Figura 7 Personalización del aspecto de una página de resultados de búsqueda (Hacer clic en la imagen para reducirla)
Figura 7 Personalización del aspecto de una página de resultados de búsqueda
Figura 7 Personalización del aspecto de una página de resultados de búsqueda (Hacer clic en la imagen para ampliarla)
MOSS 2007 incluye dos fichas para la interfaz del Centro de búsqueda: Todos los sitios y Personas. Sólo tiene que agregar fichas adicionales que reflejen los distintos tipos de información que los usuarios buscan con mayor frecuencia. Por ejemplo, puede proporcionar una entrada directa a cualquiera de las aplicaciones o bases de datos empresariales, o incluso a los servicios de directorio. Puede incluso correlacionar estas fichas con ámbitos. Esto resulta útil a la hora de crear fichas de búsqueda contextualizada sobre contenido específico. Tenga en cuenta que las ediciones de sólo búsqueda no admiten esta personalización de las fichas de búsqueda.

Conclusión
Como ha podido observar, MOSS 2007 ofrece algunas mejoras nuevas muy atractivas a la funcionalidad de búsqueda empresarial y permite a los usuarios ser más eficientes y productivos. Para obtener más información, consulte Microsoft Office SharePoint Server TechCenter (en inglés).

Matt Hester es moderador de TechNet en el equipo Microsoft Across America. Para ver en directo sus moderaciones, visite www.technetevents.com/mhester (en inglés). Visite su blog en blogs.technet.com/matthewms (en inglés).


 SharePoint: Administraci&#243;n eficaz de la l&#237;nea de comandos para SharePoint
SharePoint Todd Klindt

Administración eficaz de la línea de comandos para SharePoint
Resumen:
  • Configuración de SharePoint con STSADM
  • Tareas administrativas diarias de scripts
  • Operaciones avanzadas de STSADM

Piense en la forma en la que los usuarios interactúan con Windows o Microsoft Office. Algunos usuarios son muy hábiles a la hora de utilizar el puntero para navegar por los menús y barras de herramientas con el fin de realizar tareas habituales. Otros se sienten más cómodos
con el teclado si tienen que ejecutar rápidamente pulsaciones de teclas y accesos directos. Casi siempre hay varias formas de realizar una tarea determinada.
El hecho es que puede que sea sencillo usar una interfaz gráfica, pero puede ser al mismo tiempo engorroso a la hora de realizar tareas que requieren la repetición de la misma acción una y otra vez. Es más sencillo realizar determinados tipos de acciones mediante el teclado. Si realiza una administración de SharePoint®, es probable que detecte las acciones que pueden llegar a enredar a los usuarios en la interfaz gráfica. Sin embargo, SharePoint ofrece una forma mucho más eficaz de realizar acciones.
La principal interfaz para administrar Windows® SharePoint Services (WSS) y Microsoft® Office SharePoint Server 2007 (MOSS) es la de la administración central de SharePoint basada en GUI. SharePoint también incluye una herramienta de línea de comandos para una administración más eficaz. Esta herramienta, STSADM.exe, proporciona toda la funcionalidad de la administración central de SharePoint, aunque con la flexibilidad de la línea de comandos que muchos administradores desearían. Este artículo es un curso intensivo sobre el uso de STSADM para administrar WSS y MOSS. También incluyo en el mismo algunos consejos acerca de la configuración del entorno y analizo algunos comandos habituales en STSADM. Incluso les mostraré algunos comandos de STSADM avanzados que pueden hacerles sentirse como héroes en caso de que sea necesario utilizarlos.

Introducción
Si no encuentra STSADM, puede ser porque se encuentra de algún modo escondido. En Windows SharePoint Services 2.0, está de forma predeterminada en c:\Archivos de programa\Archivos comunes\Microsoft Shared\web server extensions\60\BIN. La ubicación predeterminada en la versión 3.0 es c:\Archivos de programa\Archivos comunes\Microsoft Shared\web server extensions\12\BIN.
Para hacer más sencillo el acceso a esta herramienta, se pueden utilizar dos métodos distintos. En primer lugar, la adición de este directorio a la variable de entorno PATH. De esta forma se puede utilizar STSADM siempre que esté en el sistema de archivos. Sin embargo, esto no es siempre una opción. El segundo método es la creación de un acceso directo a CMD.EXE y establecer la ubicación de STSADM como directorio inicial. ¿Y por qué no designar directamente un acceso directo a STSADM? Esto no funcionaría puesto que STSADM no es interactivo. Como resultado, si no se designa directamente un acceso directo a STSADM, se mostrará una visualización rápida del uso y desaparecerá a continuación.
Al ejecutar STSADM, es necesario ser miembro del grupo de administradores locales en el servidor web, así como ejecutar la aplicación localmente. Esto quiere decir que no es posible utilizar STSADM para administrar un servidor de SharePoint de forma remota.
Para ver las operaciones que se pueden realizar con STSADM, escriba stsadm.exe -help en un símbolo del sistema. Asegúrese de comprobar esta lista después de aplicar actualizaciones y revisiones en SharePoint ya que se pueden haber agregado nuevas operaciones. Hay también disponible una guía útil para las operaciones de stsadm.exe en go.microsoft.com/fwlink/?LinkId=77516 (en inglés).

Conceptos básicos relativos a STSADM
Comencemos examinando algunos de los comandos que pueden utilizarse para ajustar la instalación de SharePoint existente. Puede utilizar STSADM para agregar funcionalidad a SharePoint y modificar los valores de configuración.
STSADM utiliza la estructura -o parámetro seguida de la operación que se desea realizar. Si se escribe únicamente STSADM -operationname no servirá de nada. Si, por ejemplo, desea agregar plantillas de sitio web a la instalación, puede hacerlo mediante el siguiente comando:
Stsadm -o addtemplate -filename <filename of the template>
-title <title of template> -description <description of template>
O bien, si desea agregar un paquete de elementos web, puede utilizar este comando:
Stsadm -o addwppack -filename <filename of the Web Part Package>
Para obtener más información acerca del uso de cualquier operación, escriba la operación sin parámetros y STSADM le indicará lo que debe introducir. STSADM -help operationname también proporciona información sobre el uso.
A la hora de administrar plantillas, puede utilizar la operación enumtemplates para ver las plantillas que se han agregado y deletetemplate para eliminar las que estén instaladas. Asimismo, existen comandos para trabajar con los paquetes de elementos web. La operación enumwppacks permite mostrar los paquetes de elementos web instalados en cada servidor virtual o aplicación web y deletewppack permite eliminar los que se hayan agregado.
STSADM también cuenta con dos operaciones relacionadas con la configuración de SharePoint: setproperty y getproperty. Si se ejecuta cualquiera de las dos sin parámetros, se mostrará una lista de las propiedades que se pueden ver o manipular. Al igual que STSADM, esta lista cambia con las actualizaciones y las revisiones. No obstante, algunas propiedades son más útiles que otras. En la figura 1 se muestran algunas de las propiedades que se pueden establecer una vez instalado SharePoint, incluida la mayoría de las propiedades habituales por las que los administradores de SharePoint suelen preguntar.
Figure 1 Configuración de las propiedades útiles de SharePoint (Close Figure 1)

Propiedad | Función
Alertas habilitadas | Activa y desactiva las alertas del servidor virtual o la aplicación web.
Alertas restringidas | Especifica si los usuarios tienen restricciones para configurar un determinado número de alertas en el servidor virtual o en la aplicación web.
Alertas máximas | Si se han determinado los límites de alerta, esta propiedad es el número máximo de alertas que el usuario puede establecer.
Días que mostrar nuevo icono | Esta propiedad establece el tiempo durante el que se muestra el icono "Nuevo" junto a los elementos agregados al sitio web, como anuncios, por ejemplo.
Alertas de trabajo inmediatas | Especifica la frecuencia con la que SharePoint busca alertas inmediatas que enviar. El valor determinado en SharePoint 2.0 es cinco minutos. El intervalo se puede ajustar aquí mismo. La disminución del tiempo aumentará la carga en los servidores web y de base de datos, por lo que debe estar pendiente si cambia esta propiedad.
Alertas diarias de trabajo | Especifica la hora a la que se envían las alertas. El valor predeterminado en SharePoint 2.0 es "entre las 22:00 y las 06:00". Si hay usuarios que no se encuentran en la misma zona horaria que el servidor, puede que sea necesario ajustar esta propiedad.
Alertas semanales de trabajo | Es probable que vea aquí el patrón. Esta propiedad determina la programación de las alertas semanales.
Veamos rápidamente el uso de una de estas propiedades. El siguiente comando hará que SharePoint envíe alertas inmediatas cada 10 minutos:
Stsadm -o setproperty -pn job-immediate-alerts -pv "Every 10 minutes"
Tenga en cuenta que he utilizado -pn y -pv en lugar de -propertyname y -propertyvalue. Estos accesos directos son válidos para las ocasiones en las que no le apetezca escribir la palabra completa. Tenga en cuenta también que todos los ejemplos y comandos analizados en esta sección funcionarán en las versiones 2.0 y 3.0 de Windows SharePoint Services.

Administración diaria
La administración diaria de SharePoint es muy sencilla. Para la mayoría de administradores de SharePoint, la inmensa parte de las tareas diarias consiste en trabajar con usuarios y sitios. STSADM cuenta con varias operaciones para agilizar estas tareas.
Comenzaremos por los sitios y las webs. Por motivos de coherencia, utilizaré la palabra "sitio" para referirme a una colección de sitios y "web" para los subsitios (también conocidos como subwebs). Parte de la terminología es algo peliaguda, pero si se es coherente con la que utiliza STSADM, será sencillo encontrar el comando necesario.
Si ejecuta una instalación de gran tamaño de SharePoint, es probable que invierta demasiado tiempo en crear nuevos sitios para los usuarios. Yo me he visto varias veces en esta situación. La creación de sitios nuevos se puede llevar a cabo fácilmente en la administración central de SharePoint. Pero, como realizo esta tarea muy a menudo, he encontrado una forma más rápida de utilizar STSADM para hacer el trabajo.
Utilizo la operación createsite. Es muy sencillo y se realiza mediante los siguientes parámetros:
  • url <url>
  • ownerlogin <DOMINIO\nombre>
  • owneremail <alguien@ejemplo.com>
  • ownername <nombre para mostrar>
  • lcid <idioma>
  • sitetemplate <plantilla de sitio>
  • title <título de sitio>
  • description <descripción de sitio>
  • quota <plantilla de cuota>
Puede introducir estos parámetros en el símbolo del sistema si escribe stsadm -help createsite (consulte la figura 2). De los nueve parámetros, los únicos campos obligatorios son URL, ownerlogin y owneremail.
Figura 2 Parámetros de createsite
Figura 2 Parámetros de createsite (Hacer clic en la imagen para reducirla)
Figura 2 Parámetros de createsite
Figura 2 Parámetros de createsite (Hacer clic en la imagen para ampliarla)
Si hay sitios que crea de forma rutinaria, puede avanzar en la simplificación del proceso si escribe un contenedor de scripts en STSADM para automatizar la tarea. Por ejemplo, para automatizar la creación de sitios personales, puede guardar lo siguiente en un archivo de texto con el nombre de createpersonalsite.cmd:
stsadm -o createsite -url http://localhost/users/%1 -ownerlogin contoso\%1
-owneremail %1@contoso.com -sitetemplate usersite.stp
-title "Personal site for %1" -description "Personal site for %1" -quota "500 MB"
Para crear a continuación un sitio para el usuario jsmith, tan sólo tiene que ejecutar lo siguiente:
createpersonalsite.cmd jsmith
La creación de un sitio de scripts ahorra escritura y garantiza que todos los sitios recién creados son coherentes. La operación createweb proporciona la misma funcionalidad en el nivel de la web.
En Windows SharePoint Services 2.0, la única forma sencilla de obtener una lista exhaustiva de las colecciones de sitios en un servidor virtual determinado es a través de STSADM. Enumsites muestra en formato XML todas las colecciones de sitios en un servidor virtual determinado o en una aplicación web. Esto, junto con el elemento web Vista de datos, permite ver fácilmente una lista de colecciones de sitios. Para obtener más información, consulte en la barra lateral "Trabajo con el elemento web Vista de datos" (en inglés).
STSADM ofrece una operación deletesite, como puede imaginar, para eliminar sitios. Lo único que debe proporcionar es la URL. También puede introducir -deleteadaccounts para que se eliminen las cuentas de Active Directory®. A la hora de trabajar con webs se debe utilizar la operación deleteweb.
También puede agregar, eliminar y enumerar los usuarios de un sitio o una web. Las operaciones asociadas son adduser, deleteuser y enumusers. Estas operaciones son útiles si es necesario agregar usuarios a un sitio de forma masiva o mantener una lista de los usuarios que tienen acceso a un sitio con fines de auditoría.
Si trabaja con webs tiene acceso a una operación adicional, renameweb, que le permite cambiar el nombre y la URL de una web. Por ejemplo, para cambiar el nombre de una web de "oldname" a "coolnewname", utilice lo siguiente:
Stsadm -o renameweb -url http://localhost/oldname -newname coolnewname
Esto puede ser una salvación cuando los nombres de proyecto cambian o se realinean unidades de negocio. En Windows SharePoint Services 2.0, esto supone un gran problema, ya que la única forma de migrar webs es mediante SMIGRATE.exe, que no mantiene ninguna configuración relacionada con el usuario como suscripciones o alertas. En Windows SharePoint Services 3.0, no supone tanto problema, ya que STSADM puede hacer copias de seguridad y restaurar webs y sitios.

Copia de seguridad y restauración
Uno de los mejores usos de STSADM es realizar copias de seguridad y restaurar sitios y webs. En instalaciones de tamaño pequeño a medio, esta funcionalidad puede ser la clave de un plan de recuperación de desastres. La operación de copia de seguridad no necesita explicación y es muy fácil de usar. Sólo tiene que indicar a STSADM el sitio del que desea realizar la copia de seguridad y el lugar donde desea almacenar dicha copia, por ejemplo de la siguiente manera:
Stsadm -o backup -url http://localhost -filename site.bak
Esta operación vuelca toda la colección de sitios en el archivo site.bak. En él se incluye todo el contenido del sitio, como webs, versiones de documentos, listas y usuarios. No se realizan copias de seguridad de definiciones del sitio ni de cambios realizados en el nivel del sistema de archivos de los servidores.
A pesar de que la operación de copia de seguridad es importante, tiene algunos inconvenientes de los que hay que estar pendientes. Si el sitio es lo suficientemente grande, puede que la base de datos de contenido se bloquee durante el proceso de copia de seguridad. Esto puede evitar que los usuarios tengan acceso a cualquier sitio de la base de datos hasta que finalice la operación de copia de seguridad. Este problema se ha mitigado con los service pack, pero hay que seguir controlándolo a medida que el sitio se amplía. STSADM también utiliza el directorio temporal del servidor al realizar copias de seguridad y restauraciones, por lo que debe supervisar el espacio en disco.
Trabajar con un elemento web Vista de datos
Puede acoplar el comando enumsites con un elemento web Vista de datos para crear una forma sencilla de ver una lista de colecciones de sitios. Veamos cómo.
En primer lugar, cree una tarea programada que ejecute:
stsadm –o enumsites –url http://localhost
>c:\inetpub\wwwroot\excludedsite\sites.xml
Asegúrese de que el archivo XML se está pasando a un directorio que se publica mediante IIS, pero que no lo administra SharePoint. Utilice a continuación Microsoft FrontPage® (o su sucesor, Microsoft Office SharePoint Designer 2007) para agregar un elemento web Vista de datos a una página del elemento web e indicarlo en la URL del archivo XML.
El elemento web Vista de datos proporciona funcionalidad como la ordenación, el filtrado y la agrupación. También puede convertir el campo URL en un vínculo que le lleve directamente al sitio. Si en su lugar desea obtener una lista de webs, la operación enumsubwebs proporciona un resultado XML de los subsitios en la colección de sitios o una web.

Por último, recuerde que aunque las copias de seguridad de STSADM funcionen correctamente en sitios pequeños y medianos, la funcionalidad no se escala particularmente bien. En sitios de gran tamaño (varios gigabytes o más), los procesos de copia se seguridad y restauración se pueden ralentizar bastante.
La restauración de un sitio es igualmente sencilla. El parámetro -o restore de STSADM toma un archivo creado mediante el parámetro -o backup y lo pasa a un sitio de SharePoint. Este comando permite mucha flexibilidad: puede volver a restaurar un sitio en su ubicación original (si, por ejemplo, el sitio se ha eliminado por error), restaurarlo como un sitio diferente del mismo servidor virtual (si desea probar un proceso en un sitio sin riesgo de destruir datos), o bien restaurar el sitio en un servidor completamente distinto o en un servidor virtual.
La restauración en un sitio o servidor diferente facilita un poco la recuperación del documento individual. Si ha realizado la copia de seguridad de un sitio y un usuario necesita un documento restaurado, no es necesario restaurar todo el sitio. Esto sacrificaría todos los cambios realizados en el sitio desde que se almacenó la copia de seguridad. En su lugar, puede restaurar el sitio en una URL distinta, tomar los documentos y volverlos a guardar en el sitio original.
En Windows SharePoint Services 2.0, STSADM cuenta con una limitación bastante exigente. Sólo se pueden realizar copias de seguridad de sitios y no de webs. Los administradores comunicaron su disconformidad y Microsoft respondió. En Windows SharePoint Services 3.0, es posible actualmente realizar copias de seguridad y restauraciones de webs. También agrega dos nuevos comandos: import y export.
Para exportar una web, utilice el siguiente comando simple:
Stsadm -o export -url http://localhost/web -filename backup.dat
La exportación cuenta con opciones útiles, incluido el modificador -versions. Este modificador le permite decidir el tamaño de los archivos de copia de seguridad mediante la restricción de las versiones de archivos de las que se va a realizar la copia de seguridad.
Para volver a importar una web en el servidor, utilice el siguiente comando:
Stsadm -o import -url http://localhost/web2 -filename backup.dat
Si el sitio es lo suficientemente grande, el archivo de copia de seguridad puede estar en varias partes. En este caso, introduzca STSADM -o import en el primer archivo y los siguientes archivos se tomarán automáticamente.

Operaciones de experto
Ahora que se ha familiarizado con STSADM, quiero mostrarle un par de operaciones que puede utilizar para evitar un enlace. La primera, es una operación recién agregada denominada migrateuser. La versión 2.0 no se sincroniza con Active Directory. Si cambia el nombre de una cuenta, no podrá iniciar sesión en SharePoint desde la misma. Anteriormente, no había forma de migrar el acceso de un usuario del dominio a otro. Antes de la publicación de Windows SharePoint Services 2.0 Service Pack 2 (SP2), era necesario eliminar el usuario de todas las webs y agregar la nueva cuenta manualmente.
SP2 presentó una nueva API y STSADM lo aprovecha. Si se cambia el nombre de la cuenta jsmith por jjones, puede utilizar el siguiente comando:
Stsadm -o migrateuser -oldlogin domain\jsmith -newlogin domain\jjones -ignoresidhistory
Puesto que no está migrando cuentas realmente, puede omitir el historial del Id. de seguridad (SID) de Windows. Tenga en cuenta que no es necesaria una URL para este comando. El cambio se realiza en las bases de datos de contenido, independientemente de los sitios o webs.
Otra operación que puede evitar un enlace es unextendvs. Si no desea que SharePoint represente un servidor virtual o aplicación web, deshaga la extensión del mismo. Normalmente, esto se realiza desde SharePoint Configuration Analyzer. Sin embargo en un conjunto de servidores web, SharePoint Configuration Analyzer requiere que los servidores estén al mismo nivel de revisión. Es posible que alguno de los servidores no esté sincronizado con el resto y, por lo tanto, no pueda aplicar la opción para deshacer la extensión en SharePoint Configuration Analyzer. Sin embargo, si utiliza el siguiente comando en STSADM, se deshará la extensión del servidor virtual:
Stsadm -o unextendvs -url http://localhost
Una vez que el servidor no se encuentre dentro del conjunto de servidores, puede realizar el mantenimiento necesario.
En cuanto a los conjuntos de servidores web, para facilitar la administración, es posible que desee que todos los servidores tengan SharePoint Configuration Analyzer en el mismo puerto. El puerto se genera de forma aleatoria al instalar SharePoint, pero STSADM incluye una operación para cambiar el puerto a uno especificado:
Stsadm -o setadminport -port 1026
Mediante esta operación es posible realizar los cambios necesarios en la base de datos, los cambios en los servicios ISS y ajustar el acceso directo a Sharepoint Configuration Analyzer en Herramientas administrativas.

Conclusión
Windows SharePoint Services es una solución eficaz y requiere una buena administración. STSADM proporciona una forma de llevar a cabo la administración de SharePoint, incluida la automatización de la configuración y de las tareas diarias habituales. De hecho, a veces ésta es la única forma de realizar el trabajo.

Todd Klindt es analista de sistemas en UGS, donde le pagan por jugar con SharePoint todo el día. También trabaja como MVP para Windows SharePoint Services y es Acuario.


 SharePoint: Edici&#243;n de wikis mientras trabaja
SharePoint Mauro Cardarelli

Edición de wikis mientras trabaja
Resumen:
  • ¿Qué es un wiki?
  • Creación de un wiki en SharePoint
  • Edición y seguimiento de cambios

El concepto wiki surgió hace unos 10 años. En otras palabras, un wiki, término hawaiano cuyo significado es "rápido", es un destino en línea en el que los usuarios pueden crear o editar contenido de una página web con total libertad
mediante sólo un explorador. El objetivo es proporcionar un espacio en el que los miembros de una comunidad virtual puedan editar cualquier página con plena libertad de introducir, modificar o eliminar contenido, incluida cualquier cosa creada anteriormente por otros autores. A diferencia de los blogs, que están diseñados para el intercambio más estructurado de conocimientos y comunicación de uno a varios, los wikis permiten una experiencia de más colaboración.
Recientemente, se le ha prestado más atención a la futura generación de herramientas en línea, apodada Web 2.0. El motivo es que se van a bajar las barreras que rodean a la creación de contenido y se va a permitir que los usuarios sean a la vez productores y consumidores de información en línea. Este fenómeno no sólo se produce en el mundo de Internet, sino también dentro de los firewalls corporativos. Imagínelas como herramientas de Enterprise 2.0 que facilitan a todos los empleados la creación de contenido. Las tecnologías como los blogs y los wikis harán que las empresas cambien su forma de pensar, almacenar y reciclar la experiencia corporativa.
Microsoft facilita la capacidad de futuras generaciones con la introducción de Microsoft® Office SharePoint® Server (MOSS) 2007, la tercera versión de la conocida tecnología SharePoint. MOSS 2007 ofrece una ampliación de la funcionalidad de colaboración y comunicación, incluida la admisión de la creación de blogs y wikis. En este artículo se analiza cómo comenzar a crear wikis con MOSS 2007.

Introducción
Si ya ha trabajado con SharePoint Portal Server 2003, el uso de plantillas de sitio le será muy familiar. Las plantillas de sitio proporcionan un marco para el diseño de un tipo determinado de página (un equipo, reunión o evento social, por ejemplo) que preestablece marcadores de posición para contenido específico. MOSS 2007 amplía el uso de plantillas de sitio mediante la introducción de una nueva colección de tipos de plantilla. Uno de estos tipos de plantilla está creado para los wikis.
En la figura 1 se muestra la página Nuevo sitio Sharepoint que se utiliza para crear un sitio SharePoint. Observe que en la lista de plantillas hay un elemento para sitios Wiki. Si selecciona esta plantilla, puede crear rápida y fácilmente su primer wiki. Observe la figura 2, en la que se representa el formato predeterminado del wiki recién creado. La estructura de un wiki es tal que esta página predeterminada es la página principal. Aquí puede editar cualquier cosa. Los usuarios autorizados de forma adecuada, dentro de la comunidad virtual, pueden modificar esta página o crear páginas nuevas.
Figura 1 Selección de la plantilla de wikis para un nuevo sitio
Figura 1 Selección de la plantilla de wikis para un nuevo sitio
Figura 2 El nuevo wiki de SharePoint, listo para editarse
Figura 2 El nuevo wiki de SharePoint, listo para editarse (Hacer clic en la imagen para reducirla)
Figura 2 El nuevo wiki de SharePoint, listo para editarse
Figura 2 El nuevo wiki de SharePoint, listo para editarse (Hacer clic en la imagen para ampliarla)
Antes de continuar, volvamos a atrás y analicemos el modo de presentar los wikis a los usuarios. Como he mencionado anteriormente, los wikis llevan algún tiempo presentes en Internet y en herramientas de terceros. En la mayoría de los casos, el uso de los wikis era, sin embargo, muy especializado y creció a un ritmo lento, a través del boca en boca. MOSS 2007 está preparado para cambiar esto ofreciendo la funcionalidad wiki a todos los usuarios de intranet. Esta proposición es muy útil (y horripilante). ¿Cómo explica el valor de un wiki a un compañero que no sea técnico ni tenga conocimientos de Internet? Lo que debe decirle es que los wikis están indicados para fomentar intercambios creativos de opiniones e ideas en un entorno lo suficientemente libre como para dar la oportunidad de expresarse a todos los usuarios. Los wikis permiten la colaboración de contenido, pero son en realidad mucho más que eso. El resultado final de un wiki no es un documento ni un capítulo, sino un libro que no es necesario terminar y que puede modificar siempre que sea necesario.
Y ahora, volvamos al trabajo. Para los usuarios que utilizan wikis por primera vez, hay disponible una guía en línea a través del hipervínculo de modo de uso del sitio wiki. La plantilla wiki predeterminada incluye documentación suficiente para que los nuevos usuarios se sientan cómodos y puedan colaborar rápidamente.

Funcionamiento de los wikis
En todas las páginas wiki, se aprecian botones de acción en la parte superior derecha. Si hace clic en el botón con la etiqueta Editar, aparecerá la página asociada a la edición del contenido. En la figura 3 se muestra un ejemplo. La edición se lleva a cabo en el explorador, no es necesario utilizar herramientas externas como Microsoft Word. Las modificaciones se realizan en línea y en tiempo real (una vez guardadas). Además, no son necesarios conocimientos de diseño ni de desarrollo. La interfaz de edición permite la creación de texto enriquecido completo (negrita, colores, viñetas o imágenes), mediante los botones estándar. El usuario sólo tiene que abrir una página existente en modo de edición y agregar o modificar el contenido. Eso es todo.
Figura 3 Edición de todo el contenido de un wiki en el explorador
Figura 3 Edición de todo el contenido de un wiki en el explorador (Hacer clic en la imagen para reducirla)
Figura 3 Edición de todo el contenido de un wiki en el explorador
Figura 3 Edición de todo el contenido de un wiki en el explorador (Hacer clic en la imagen para ampliarla)
¿Cómo realizaría cambios en un entorno en el que el contenido está aún en creación? Puede que no sea necesario supervisar cada una de las contribuciones, pero puede que desee realizar un seguimiento de los cambios y mantener el historial de versiones. MOSS 2007 permite realizar esto. En la figura 4 se muestra el aspecto de una página estándar tras hacer clic en el botón Historial. En el centro, verá que se han seguido todas las modificaciones del texto. A la izquierda, puede ver el historial de cambios, de los que se ha realizado un seguimiento después de su introducción. La comunidad puede revisar, seguir y deshacer los cambios. Este concepto es bastante útil. Al mismo tiempo que crea y cambia el wiki, MOSS 2007 realiza un seguimiento de dichas acciones.
Figura 4 Seguimiento de los cambios en una entrada wiki a lo largo del tiempo
Figura 4 Seguimiento de los cambios en una entrada wiki a lo largo del tiempo (Hacer clic en la imagen para reducirla)
Figura 4 Seguimiento de los cambios en una entrada wiki a lo largo del tiempo
Figura 4 Seguimiento de los cambios en una entrada wiki a lo largo del tiempo (Hacer clic en la imagen para ampliarla)
Como habrá podido observar, un wiki no es una página web. Es una colección de páginas sin límite. Como miembro de una comunidad wiki, puede decidir si desea introducir una nueva idea o un punto de discusión. En lugar de agregar texto en una página existente, puede hacerlo en una página nueva. MOSS 2007 admite esta función permitiendo una adición sencilla de páginas wiki. Sólo tiene que hacer clic en Nuevo y aparecerá una nueva página wiki. Comience a agregar contenido y siga haciendo todo lo que desee.

Conclusión
Puede que MOSS 2007 no introduzca el concepto de wiki pero, debido a su gran disponibilidad, lo hace mucho más atractivo. Los wikis pueden cambiar por completo el modo de colaboración de los trabajadores de empresa, ya que no están obligados a ceñirse a los límites de un documento. Éstos fomentan un pensamiento estructurado y una colaboración más amplia, lo que se integra muy bien con conceptos más extensos asociados a la filosofía de Enterprise 2.0. Los wikis son habilitadores, ya que permiten a los usuarios participar y no sólo seguir, sino también salir hacia nuevas direcciones.

Mauro Cardarelli es socio comercial de Jornata, empresa de servicios de consultoría de TI con sede en Boston. Entre sus responsabilidades se incluyen el evangelismo tecnológico, el diseño de arquitectura y el desarrollo de software. Puede ponerse en contacto con él en mauro.cardarelli@jornata.com.


 From&#160;The&#160;Editor: A veces, las industrias
From The Editor

A veces, las industrias sufren cambios sísmicos. Esto se aplica no sólo a la tecnología, sino también a la política, la moda y todo lo demás. Estaba pensando en esto hace unas semanas cuando hablaba en la conferencia Windows Connection en Las Vegas. Hacía cinco años, en noviembre, estaba en Comdex: una enorme feria que abarcaba cualquier segmento posible de los compradores y estudiantes de tecnología de todo el mundo. Pero la feria, que había crecido a un ritmo constante durante casi dos décadas, desapareció de la noche a la mañana. Así que, en lugar de asistir a una feria gigante y con una amplia selección de puntos principales, estaba hablando en una feria con mucho éxito que se había reducido y que se centrada en unos cuantos productos de TI y de desarrollador. Estaba hablando a las mismas personas en el mismo sitio, pero la escala era más gratificante para aquellos que prestaban atención.
Mi charla iba sobre redacción técnica: cómo se hace, dónde y por qué. Los cambios en nuestra industria se ven reflejados no sólo en la historia de Comdex, sino también en el mundo de las comunicaciones técnicas. Hace cinco años, ofrecí una sesión similar y era sobre revistas. En aquella época, pocas personas habían oído hablar de los blogs. Los sitios de comunidades eran sólo la sombra de lo que son ahora. En los últimos cinco años, hemos visto un cambio permanente en las formas de transmitir la palabra escrita a una escala que nunca antes se había experimentado.
Esto tiene sus pros y sus contras, por supuesto. Diferentes formas de comunicación están al servicio de diferentes fines. Las personas pueden exponer sus pensamientos en línea de forma espontánea, pero escribir tales pensamientos en una revista, normalmente significa que esas palabras se han editado y se han sometido técnicamente a una revisión. Puede criticar un artículo de un blog, pero no puede ir a casa de alguien a decirle que retire una sección de la página 28.
De todos modos, existe una razón que justifica por qué estoy hablando de todo este cambio. En respuesta a los numerosos lectores que nos han enviado sus impresiones acerca de la revista, estamos ampliando nuestro reparto de columnas. En este número, le estamos ofreciendo la primera entrega de The Cable Guy, una conocida columna en línea de TechNet que ahora está dando el salto al papel impreso. También hemos tenido noticias de los administradores de correo y sabemos que Exchange Server 2007 está a punto de convertirse en algo grande, así que estamos lanzando Exchange Queue & A como una columna de publicación regular. ¡Basta! ¡Es un nombre bonito!
Si desea que aparezca una tecnología de Microsoft en la revista, escríbanos unas líneas. La mejor forma en que podemos ayudarle es ofrecerle lo que necesita. £Joshua Trupin

Mi agradecimiento a los siguientes expertos técnicos de Microsoft: Puneet Arora, Jeff Bienvenu, Nino Bilic, Eric Broberg, Ramesh Chinta, Matt Cohen, Michael Dalton, George Irimescu, Bryan Jeffries, Dave Kong, Vijay Krishna, Rob Lefferts, Lawrence Liu, Bob Ma, Manu Namboodiri, Joel Oleson, Arpan Shah, Troy Starr, James Sturms, Jim Truher y Blaine Young.


 Caja de herramientas: Nuevos productos para profesionales de TI
Caja de herramientas
Nuevos productos para profesionales de TI
Greg Steen

Administración de servidor
Herramientas del kit de recursos de Windows Server 2003
go.microsoft.com/fwlink/?LinkId=77796
Las herramientas del kit de recursos de Microsoft Windows Server 2003 son un valioso conjunto de más de 100 utilidades que pueden ayudarle a simplificar y automatizar las tareas administrativas. Incluye todo el material de las herramientas de Active Directory® hasta utilidades de solución de problemas de red pasando por grabadores de imágenes de CD/DVD.
Custom Reason Editor (custreasonedit.exe) es una herramienta ideal para organizar el Rastreador de sucesos de apagado. El componente de Windows Server® 2003, Rastreador de sucesos de apagado, registra los motivos de los apagados del sistema en el registro de eventos. A su vez, Custom Reason Editor permite crear una lista personalizada con parámetros configurables que invalidará los motivos integrados habilitados de forma predeterminada. Esta herramienta puede facilitar la agregación e identificación de procesos, aplicaciones o estados de sistema problemáticos que llevan al apagado, a través del mantenimiento de la lógica y la organización de los elementos de evento.
DNS Resolver Tool, una utilidad de línea de comandos que simula la ejecución de la resolución de DNS del servicio SMTP, muestra mensajes relativos al estado de la consulta DNS especificada como parámetro de comando. Esta utilidad se ejecuta en cualquier host de Windows Server 2003 con el servicio SMTP instalado y devuelve códigos de error que puede usar en los archivos por lotes. CDBurn.exe y DVDburn.exe son utilidades de línea de comandos que permiten crear CD y DVD a partir de imágenes ISO y ofrecen compatibilidad limitada con medios RW mediante el conmutador /Erase que limpiará los medios antes de aplicar la nueva imagen de disco. Se pueden usar, por ejemplo, para automatizar los procesos de archivado de la infraestructura.
Kit de recursos de Windows Server 2003
Kit de recursos de Windows Server 2003 (Hacer clic en la imagen para reducirla)
Kit de recursos de Windows Server 2003
Kit de recursos de Windows Server 2003 (Hacer clic en la imagen para ampliarla)
Si necesita comprobar si una cuenta se ha bloqueado correctamente, la herramienta Account Lockout Status hace que este procedimiento sea fácil y rápido con una línea de comandos y una opción de GUI. La herramienta consulta cada controlador de dominio accesible y comprueba el estado de la cuenta de usuario de destino. Probablemente una de las mejores herramientas de automatización, Robust File Copy Utility, Robocopy.exe, ofrece una serie de opciones para mover y copiar archivos. Esta herramienta permite usar caracteres comodín e incluso atributos de archivo para especificar candidatos de copia; la copia se puede establecer como recursiva. Puede usar la herramienta para la sincronización y establecerla para que elimine archivos o directorios de destino que se hayan quitado del directorio de origen.
Otra de mis utilidades favoritas es la sencilla herramienta Tail (tail.exe) que, al igual que las utilidades de Linux/UNIX, permite mostrar las últimas N líneas de un archivo y actualiza la visualización cuando se agregan nuevas líneas. Se trata de una forma ideal de depurar o supervisar cualquier tarea que se escriba en un archivo de registro.
Time It (timeit.exe) permite controlar el tiempo de los datos y almacenarlos en su propio archivo de base de datos, lo que permite comprobar cuánto duran en realidad las tareas administrativas.
Debe tener en cuenta que las herramientas no se han localizado, se han escrito y probado sólo en inglés, y pueden "producir resultados imprevisibles" al ejecutarse. Asegúrese de comprobarlas en los sistemas que no estén en inglés antes de usar cualquiera de estas utilidades en un entorno de producción.
Precio: descarga gratuita.

Seguimiento de problemas
ASP.NET Issue Tracker
www.ASP.NET/StarterKits/WhitePapers/Issue%20Tracker%20Whitepaper.htm
Hay dos características que, a mi parecer, siempre hacen que una aplicación sea mejor: que sea gratis y que sea personalizable. ASP.NET Issue Tracker, que se proporciona a través de la comunidad de desarrolladores en línea de ASP.NET, posee ambas características. Diseñada como Starter Kit para aprender a programar aplicaciones web en el marco de ASP.NET 1.1, Issue Tracker es una herramienta sencilla pero útil para realizar el seguimiento de problemas relacionados con proyectos.
La interfaz es sencilla y permite crear proyectos, usuarios y problemas de forma fácil. La aplicación admite varios usuarios con permisos basados en funciones, con lo que se protegen los problemas frente a usuarios no deseados. También puede crear categorías de problema personalizadas para cada proyecto y campos de datos personalizados de distintos tipos. Se puede asignar un estado, una prioridad y un hito a las tareas, lo que ayuda a organizar los proyectos.
Otra característica destacada es que, en la creación de un proyecto, se pueden especificar códigos de estado, prioridades e hitos propios para cada proyecto y asignar una imagen para representarlo. Todo el código está disponible en la descarga, por lo que, si tiene a mano a un desarrollador de .NET o puede trabajar por su cuenta con el código existente, podrá usar el starter kit como base para cualquier funcionalidad necesaria.
Precio: gratuito.

Supervisión de sistemas
NetHealth Sentinel Professional
www.nethealthsys.com
La supervisión de red y sistemas es esencial, y siempre ando a la caza de aplicaciones que me ofrezcan una idea del estado de los equipos en un período de tiempo. NetHealth Sentinel Professional, de NetHealth Systems, realiza justo esta tarea.
Sentinel Professional, una solución basada en agente, ofrece una visión detallada de los equipos host supervisados. La aplicación se divide en cuatro componentes: Admin Server, Admin Console, Connection Manager y Remote Agent. Admin Server ejecuta tareas programadas, almacena información de configuración y recopila alertas a través de Connection Manager.
Admin Console es la interfaz gráfica de Admin Server que permite ver y configurar los sistemas supervisados, así como cualquier tarea o evento programado. Connection Manager recopila todos los datos de los agentes Remote Agent (agentes host que residen en el equipo supervisado). Remove Agent se ejecuta como un servicio de Windows y se comunica de forma segura con Connection Manager. Cada agente Remote Agent se puede configurar para enviar alertas a uno o varios Connection Manager.
NetHealth Sentinel Professional
NetHealth Sentinel Professional (Hacer clic en la imagen para reducirla)
NetHealth Sentinel Professional
NetHealth Sentinel Professional (Hacer clic en la imagen para ampliarla)
Una característica útil es la agregación de eventos de todos los equipos a un grupo de supervisión especificado. La sencilla GUI también permite arrastrar y colocar columnas de datos de la vista Event para agruparlas por elemento.
La aplicación también incluye el panel Vital Signs que ofrece una imagen general rápida de cualquier estadística que desee supervisar. De forma predeterminada, puede ver el uso de CPU, disco y memoria, aunque también puede agregar, a través de la ficha Monitor, los contadores que elija.
NetHealth Sentinel Professional también incluye una característica de línea de base que permite establecer niveles para el funcionamiento "normal" de un equipo y posteriormente activa alertas si el funcionamiento sobrepasa uno de los valores de línea de base establecidos.
Precio: 495 dólares para un paquete de licencia de acceso de 10 clientes.

Cifrado de datos
TrueCrypt
www.truecrypt.org
TrueCrypt, de TrueCrypt Foundation, es una herramienta de cifrado "al instante" gratuita y de código abierto que, con la contraseña o la clave de cifrado correcta, descifrará la información que intente leer o cifrará datos que intente escribir en memoria de los volúmenes cifrados. Pero no se preocupe: en ningún momento el volumen existe cuando está descifrado. Sólo si cuenta con un volcado de memoria mientras la aplicación descifra los datos en la memoria, puede un atacante encontrar la información que intenta proteger. Esto se puede evitar fácilmente desactivando los volcados de memoria del sistema, sin mencionar que sólo una pequeña parte de los datos existe descifrada en la memoria en algún momento.
La aplicación admite tanto volúmenes virtuales como particiones o dispositivos físicos. Los volúmenes virtuales, llamados "contenedores de archivos" por sus autores, se pueden crear con cualquier extensión de archivo o no tener ninguna extensión de archivo, por lo que, ante los ojos escrutadores, la información confidencial parecerá estar compuesta de datos aleatorios; no existe ninguna "firma de archivo" de TrueCrypt.
TrueCrypt
TrueCrypt (Hacer clic en la imagen para reducirla)
TrueCrypt
TrueCrypt (Hacer clic en la imagen para ampliarla)
Además, puede ejecutar TrueCrypt en "modo de viajero", lo que significa básicamente que puede crear un contenedor de archivos en una llave USB junto con los archivos de aplicación y llevarse los datos cifrados allí donde vaya, sin necesidad de instalar la aplicación TrueCrypt en el sistema host. No obstante, debido a la naturaleza de la memoria de lectura/escritura, necesitará privilegios administrativos en el sistema en el que desee usar el disco de viaje.
TrueCrypt cuenta también con un sencillo asistente para configurar el disco de viaje. Ésta es una forma ideal de transportar la información de administración del sistema y no tener que preocuparse (demasiado) por quienes puedan ver la información corporativa confidencial.
Para conseguir otro nivel adicional de seguridad, TrueCrypt también permite crear un volumen oculto dentro de un contenedor de archivos, de manera que, si un intruso llega al volumen exterior, no podrá descubrir que hay un volumen interior oculto en el disco. Cada volumen se inicializa con datos aleatorios, lo que hace que el volumen oculto que reside en el "espacio libre" del volumen exterior sea muy difícil de detectar.
TrueCrypt puede usar AES, Blowfish, CAST5, Serpent, Triple DES, Twofish y unas cuantas combinaciones de estos algoritmos para cifrar los datos. Las aplicaciones usan el modo de funcionamiento LRW para el cifrado, que va camino de convertirse en un estándar IEEE para el cifrado de almacenamiento basado en sectores. Para el algoritmo hash de encabezado, puede elegir usar Whirlpool, SHA-1 o RIPEME-160, y la aplicación no almacenará ningún hash en el sistema como capa adicional de protección. La aplicación admite los sistemas de archivos FAT12, FAT16, FAT32 y NTFS, aunque, al igual que otras utilidades de cifrado de sectores basadas en Windows del mercado, no permite cifrar una partición de arranque de Windows.
Precio: gratuito.

Reseña de libro
Hacking Web Services
www.charlesriver.com
Hacking Web Services (Charles River Media, 2006) de Shreeraj Shah es un valioso recurso para quienes estén implicados en el desarrollo, la implementación o el soporte técnico de servicios web. El libro es una referencia general de seguridad bien organizada para servicios web y sus tecnologías de componentes. Asimismo, contiene una descripción detallada de la defensa de estos elementos en la infraestructura y a través de las prácticas de desarrollo.
El libro comienza con una introducción relativamente detallada a los servicios web. El caso práctico sobre las consecuencias de la falta de decisión (The Consequences of Procrastination) le enseña la utilidad de los procedimientos de seguridad preventiva así como las desventajas de los sistemas reactivos. El capítulo sobre exploración y enumeración de servicios web (Web Services Scanning and Enumeration) trata cómo usar wsChess, un kit de herramientas de seguridad de servicios web basado en .NET de Net-Square (net-square.com/wschess/index.shtml) para servicios web de perfil y superficie.
El libro incluye un CD de utilidades, que contiene una aplicación de muestra basada en .NET llamada SOAPWall. Muestra cómo bloquear los caracteres de inserción y los desbordamientos de búfer en los servicios web de .NET. Asimismo, el CD ofrece demostraciones de distintos tipos de ataques de servicios web.
Precio: $49.95.
Hacking Web Services (Charles River Media, 2006) de Shreeraj Shah es un valioso recurso para quienes estén implicados en el desarrollo, la implementación o el soporte técnico de servicios web. El libro es una referencia general de seguridad bien organizada para servicios web y sus tecnologías de componentes. Asimismo, contiene una descripción detallada de la defensa de estos elementos en la infraestructura y a través de las prácticas de desarrollo.
El libro comienza con una introducción relativamente detallada a los servicios web. El caso práctico sobre las consecuencias de la falta de decisión (The Consequences of Procrastination) le enseña la utilidad de los procedimientos de seguridad preventiva así como las desventajas de los sistemas reactivos. El capítulo sobre exploración y enumeración de servicios web (Web Services Scanning and Enumeration) trata cómo usar wsChess, un kit de herramientas de seguridad de servicios web basado en .NET de Net-Square (net-square.com/wschess/index.shtml) para servicios web de perfil y superficie.
El libro incluye un CD de utilidades, que contiene una aplicación de muestra basada en .NET llamada SOAPWall. Muestra cómo bloquear los caracteres de inserción y los desbordamientos de búfer en los servicios web de .NET. Asimismo, el CD ofrece demostraciones de distintos tipos de ataques de servicios web.
Precio: $49.95.

Escriba a Toolbox.
Si tiene una herramienta o utilidad favorita que desearía ver comentada aquí, póngase en contacto con el autor en tntools@microsoft.com.

Las opiniones expresadas en esta columna pertenecen sólo al autor y no reflejan necesariamente las opiniones de Microsoft. Los precios se confirmaron en el momento de publicación y están sujetos a cambio.

Greg Steen es un profesional emprendedor y entusiasta de la tecnología. Siempre está buscando nuevas herramientas y métodos para ayudar a simplificar las operaciones y el desarrollo para los profesionales de TI.


 Utility Spotlight: Kit de administraci&#243;n de Internet&#160;Explorer
Utility Spotlight
Kit de administración de Internet Explorer
Lance Whitney
Descargar el código de este artículo: Utility Spotlight: Kit de administración de Internet Explorer 7 (KB)

El director de tecnologías de información le pide que instale la última versión de Internet Explorer 7 en toda la organización. La fecha límite es ajustada, el presupuesto es reducido y los requisitos son muchos. Necesita un paquete personalizado que aplicará las mismas características y configuración a todos los usuarios. También necesita poder cambiar esta configuración siempre que sea necesario.
Asimismo, es preciso que bloquee Internet Explorer® de modo que los usuarios no puedan modificar la configuración. ¿Cómo puede crear y proporcionar este tipo de instalación de Internet Explorer de forma rápida y sencilla?
Microsoft sale al rescate con el Kit de administración de Internet Explorer, conocido afectuosamente como IEAK. Esta herramienta de configuración gratuita se ha creado para ayudar a los administradores de TI, desarrolladores, ISP, etc. a crear paquetes de instalación personalizados para Internet Explorer. De hecho, Yahoo! usó la versión beta de IEAK 7 con el fin de crear un paquete de Internet Explorer 7 personalizado para descargarlo del sitio web de Yahoo!
La compilación de Internet Explorer 7 que se crea con IEAK debe incluir sólo las características y las opciones que especifique. Puede habilitar parámetros de seguridad específicos y bloquear cualquier control al que no desee que los usuarios tengan acceso.
Después de implementar Internet Explorer, quienes dispongan de Active Directory® pueden, por supuesto, usar la directiva de grupo para controlar y actualizar la configuración del explorador. O bien, si lo desea, puede usar IEAK para administrar la variada matriz de parámetros de Internet Explorer.
IEAK 7 es fácil de usar, mucho más que las versiones anteriores, y ofrece una sencilla interfaz gráfica para crear el paquete de Internet Explorer. Las pantallas paso a paso le guían a medida que selecciona características y opciones que desea incorporar a su compilación.
La nueva versión de IEAK ofrece unos cuantos cambios frente a versiones anteriores, con algunas opciones nuevas y otras que han desaparecido. Ahora puede agregar fuentes web RSS predeterminadas a la compilación de Internet Explorer, elegir más de una página principal y de búsqueda, y agregar compatibilidad para un filtro contra la suplantación de identidad. También puede configurar la Herramienta de eliminación de software malintencionado de Microsoft® Windows® para que se ejecute y actualice. Sin embargo, ya no podrá personalizar Outlook® Express ni Reproductor de Windows Media® con IEAK, ya que estas aplicaciones no se incluyen con Internet Explorer 7.
Puede crear un paquete de Internet Explorer para plataformas de 32 bits o 64 bits (Windows XP con Service Pack 2 (SP2), Windows Server® 2003 con SP1 o Windows Vista™ basado en x86, x64 o Itanium). Antes de ejecutar IEAK 7, se debe instalar Internet Explorer 7 en el equipo que use para crear el paquete. Por cuestiones de compatibilidad, debe ejecutar IEAK en un equipo con el mismo sistema operativo que los equipos en los que aplicará la compilación.
En esta columna, trataré cómo usar IEAK para crear la compilación de instalación de Internet Explorer 7 y mantener o actualizar la configuración del explorador.

Cómo obtener IEAK 7
Puede descargar la última versión de IEAK 7 de forma gratuita en microsoft.com/technet/prodtechnol/ie/ieak7 (en inglés). Además, esta página ofrece documentación y notas de la versión de IEAK, que merece la pena leer.
Al instalar IEAK 7 mediante el archivo ieak.msi descargado, se le pregunta que tipo de licencia se usará según su función (ISP, proveedor de contenido o desarrollador, o bien a través de una intranet corporativa). Las pantallas que se muestran y el tipo de paquete que se crea varían en función de la función seleccionada. De este modo, si va a crear la compilación para un entorno empresarial, asegúrese de seleccionar la función y la licencia para una intranet corporativa. Después de instalar IEAK, se crea un nuevo grupo de programas llamado Microsoft IEAK 7 en el menú Inicio y contiene tres elementos: Ayuda de IEAK, Administrador de perfiles de IEAK y Asistente para personalizar Internet Explorer.
Este último asistente lo usará para crear el paquete de instalación. Con el asistente resulta realmente sencillo, ya que cada pantalla le guía por el proceso de diseño del paquete. Entonces, ¿dónde está el truco? Para saber cómo configurar cada opción, es necesario comprender con claridad las características y controles de Internet Explorer. Afortunadamente, IEAK 7 también puede ser de ayuda en este caso. La ayuda integrada de la herramienta es más detallada y descriptiva que en versiones anteriores. Aparece un botón de ayuda en cada ventana del Asistente para personalizar, con el fin de explicar la configuración y las opciones de la pantalla en cuestión. Puede obtener acceso al archivo de ayuda completo de IEAK mediante el acceso directo de Ayuda de IEAK o a través del archivo IEAKHelp.chm en C:\Archivos de programa\Microsoft IEAK 7. Le recomiendo que lea la documentación antes de crear la compilación, con el fin de comprender cada componente y planear las opciones necesarias.
El Asistente para personalizar divide la creación del paquete en estas cinco fases distintas:
  1. Recopilar información
  2. Especificar parámetros de instalación
  3. Personalizar la experiencia de instalación
  4. Personalizar el explorador
  5. Personalizaciones adicionales
Microsoft ha simplificado el número de pantallas de IEAK 7, de modo que el proceso es más sencillo y claro que en versiones anteriores. No obstante, el Asistente para personalizar reúne decenas de pantallas en las que se seleccionan las opciones del paquete. Por ello, no repasaré cada pantalla en esta columna (muchas de ellas no necesitan explicación y ya he explicado cómo tener acceso a la ayuda para las más complicadas). En su lugar, ofreceré una breve descripción de cada fase y trataré algunas de las pantallas más importantes.
Fase 1 Recopilar información Aquí se decide dónde almacenar el paquete de instalación, en qué sistema operativo y plataforma se ejecutará, cómo se desea distribuir Internet Explorer y qué opciones se personalizarán. En esta fase, puede especificar uno de los tres métodos de distribución de Internet Explorer 7, tal y como se muestra en la figura 1: una instalación de archivo, que crea una estructura de directorios plana con los archivos que componen la compilación; CD-ROM, que crea un disco de instalación (resulta útil si cuenta con usuarios remotos); y un paquete de sólo configuración o sólo personalización de marca, que aplica la configuración personalizada a una instalación existente de Internet Explorer 7. Puede usar la última opción para Windows Vista si Internet Explorer 7 ya está instalado y desea aplicar sus propias personalizaciones al mismo.
Figura 1 Especificación de un método de distribución
Figura 1 Especificación de un método de distribución (Hacer clic en la imagen para reducirla)
Figura 1 Especificación de un método de distribución
Figura 1 Especificación de un método de distribución (Hacer clic en la imagen para ampliarla)
En esta fase, también se especifica el idioma que se desea usar para la compilación. Puede crear versiones localizadas de Internet Explorer 7 para todos los idiomas que necesite admitir.
Fase 2 Especificar parámetros de instalación Aquí se descargan los últimos componentes y actualizaciones de Internet Explorer para generar el paquete.
Fase 3 Personalizar la experiencia de instalación En esta fase, se elige la instalación que recibirán los usuarios: Instalación interactiva (en la que se presentan al usuario opciones durante la instalación), Instalación no interactiva (en la que el usuario puede ver la instalación que está teniendo lugar, pero no puede intervenir) o Instalación totalmente silenciosa (en la que la instalación se ejecuta por completo en segundo plano sin intervención del usuario). Si va a crear un CD-ROM, en esta fase se le pedirá que cree una página de inicio y otros elementos para el CD.
Fase 4 Personalizar el explorador Aquí se personaliza la apariencia de Internet Explorer; se establecen las direcciones URL de la página de inicio, la página de soporte técnico y favoritos; se configuran los parámetros de proxy y se establece la configuración de privacidad y seguridad del explorador. En esta fase, también puede especificar el nombre y la ubicación de un archivo de configuración automática o un archivo de configuración de Internet (INS), con el que puede administrar la configuración del explorador si no piensa usar la directiva de grupo.
El archivo INS es un archivo de texto simple que contiene toda la configuración principal del explorador, desde la página de inicio a favoritos, pasando por las opciones de seguridad o la configuración de proxy. El archivo INS se almacena en un servidor web interno. Cada equipo apunta a este archivo para obtener la configuración de explorador. Si necesita modificar cualquier parámetro en el futuro, sólo tiene que editar el archivo INS y los usuarios recibirán automáticamente el cambio. Puede especificar la frecuencia con la que se actualiza y aplica la configuración.
Asimismo, en esta fase, tiene la oportunidad de establecer los servidores proxy, ya sea introduciendo manualmente las direcciones IP y los números de puerto, o bien creando y especificando el nombre de un archivo JScript® (JS), JavaScript (JVS) o de configuración automática de proxy (PAC) con la información de proxy. La Ayuda de IEAK ofrece ejemplos de código que puede usar para crear estos archivos.
También puede habilitar el modo protegido si va a diseñar el paquete de Internet Explorer 7 en Windows Vista y para dicho sistema operativo. Sólo tiene que activar el modo protegido en Internet Explorer 7 en el equipo de referencia y, a continuación, importar dicho valor en IEAK.
Fase 5 Personalizaciones adicionales Finalmente, en esta fase, se establecen las directivas de usuario y las restricciones de seguridad para la compilación. Puede bloquear de forma selectiva parámetros individuales que no desee que los usuarios vean ni modifiquen. En la figura 2 aparece la pantalla Configuración adicional con cinco categorías de controles que puede activar o desactivar. Los parámetros de estas pantallas proceden de cinco plantillas ADM para Internet Explorer 7, que se instalan después de descargar los últimos componentes del explorador en la fase 2 del asistente. Si usa la directiva de grupo, puede omitir esta fase. En caso contrario, puede configurar las opciones de las cinco categorías. Puesto que estas categorías provienen directamente de las plantillas ADM, puede incluso modificarlas editando cada archivo ADM en un editor de textos, con el fin de agregar sus propios controles personalizados. Los archivos ADM se encuentran en C:\Archivos de programa\Microsoft IEAK 7\pol-icies en distintos subdirectorios para cada sistema operativo y plataforma de Windows. En la figura 3 se muestran las cinco categorías con una breve descripción de cada una de ellas.
Figure 3 Categorías de la pantalla Configuración adicional (Close Figure 3)

Categoría | Descripción
Administración de controles | Esta categoría permite activar o desactivar ciertos controles ActiveX. La configuración de esta categoría no se aplica a Windows Vista, sólo a Windows XP y Windows Server 2003.
Configuración personalizada | Esta categoría muestra la configuración de seguridad. Puede activar o desactivar ciertos controles y acciones por zona (Internet, intranet, sitios de confianza o sitios restringidos).
Configuración corporativa | En esta categoría, puede establecer el tamaño y los parámetros de la caché del explorador.
Restricciones corporativas | Aquí puede bloquear controles y pantallas específicos de Internet Explorer, de modo que los usuarios no puedan verlos. Esta configuración no se aplica a Windows Vista, sólo a Windows XP y Windows Server 2003.
Configuración de Internet | Esta categoría ofrece opciones para Autocompletar, tamaño de presentación y la configuración avanzada que se muestra en el menú Opciones de Internet de Internet Explorer.
Figura 2 Personalización de las características de Internet Explorer
Figura 2 Personalización de las características de Internet Explorer (Hacer clic en la imagen para reducirla)
Figura 2 Personalización de las características de Internet Explorer
Figura 2 Personalización de las características de Internet Explorer (Hacer clic en la imagen para ampliarla)

Comprobación de la compilación
Una vez que finalicen las pantallas del Asistente para personalizar, se crea el paquete en la ubicación especificada en la fase 1 o en c:\builds de forma predeterminada. En esta ubicación se encontrará el directorio de destino (IEAK usa la fecha actual para el nombre del directorio, por ejemplo, 01012007 para 1 de enero de 2007). En esta ubicación, habrá dos rutas de subdirectorio, uno llamado INS y el otro con el nombre del método de distribución elegido (FLAT, CD o BrndOnly).
El directorio INS actúa como área de trabajo o repositorio que mantiene el seguimiento de las personalizaciones a medida que crea el paquete. El archivo de texto de este directorio, llamado install.ins, almacena toda la configuración creada. Si reinicia el Asistente para personalizar, las selecciones anteriores se toman automáticamente de este archivo.
Los directorios FLAT, CD o BrndOnly almacenan los archivos de instalación reales. En cualquiera de estas tres ubicaciones habrá un subdirectorio con un nombre referente al sistema operativo y la plataforma, como WIN32 para Windows XP de 32 bits o Windows Vista. El subdirectorio final tiene el nombre del idioma que se usa en el paquete, por ejemplo, EN para inglés. A modo de ejemplo, si ha creado una compilación el 1 de enero de 2007, con una distribución plana para Windows de 32 bits en inglés, la ruta del directorio de la compilación será c:\builds\01012007\FLAT\WIN32\EN.
Para buscar la instalación creada con un método de distribución plana, explore en profundidad la estructura del directorio FLAT hasta que vea el archivo IE7Setup.exe en el subdirectorio de idioma. Se trata de un ejecutable autoextraíble que contiene todos los archivos binarios y de configuración que componen la compilación. Este archivo contiene todo lo necesario para implementar el paquete de Internet Explorer 7 (los archivos del directorio INS no son necesarios para la instalación). Puede copiar este único archivo en el servidor de distribución para probar el paquete y, después, cuando esté listo, distribuirlo entre los usuarios.
Si elige la distribución de CD-ROM, debe copiar todo el contenido del directorio CD en el CD correspondiente. Esto incluye un archivo autorun.inf, que se genera automáticamente, y un directorio con el archivo ejecutable que instala Internet Explorer desde el CD.
Si ha creado un paquete de sólo configuración o sólo personalización de marca, explore en profundidad la estructura del directorio BrndOnly hasta que vea el archivo Setup.exe en el subdirectorio de idioma. Se trata de un ejecutable autoextraíble, que puede copiar en el servidor de distribución para su implementación.

Administración de la configuración
El paquete de Internet Explorer 7 contiene todas las características y la configuración que necesita en principio. Sin embargo, ¿qué puede hacer cuando necesite cambiar una opción? Tiene dos posibilidades. Si cuenta con Active Directory, puede actualizar la configuración del explorador con la directiva de grupo. En caso contrario, IEAK ofrece una herramienta llamada Administrador de perfiles para modificar la configuración. Veamos primero brevemente la directiva de grupo.
Uso de directivas de grupo La directiva de grupo es el mejor método de administración de Internet Explorer ya que admite toda la configuración del explorador. En las versiones anteriores de IEAK e Internet Explorer, tenía que agregar los archivos ADM y los archivos de mantenimiento de Internet Explorer (IEM) a la consola de directiva de grupo para incorporar toda la configuración de Internet Explorer. Sin embargo, en Internet Explorer 7, Windows XP SP2 y Windows Vista incluyen toda la configuración de directiva de grupo necesaria para mantener y actualizar el explorador.
Si abre el Editor de directivas de grupo (gpedit.msc), encontrará toda la configuración necesaria para Internet Explorer 7 en Plantillas administrativas | Componentes de Windows | Internet Explorer.
Uso de Administrador de perfiles de IEAK Con el Administrador de perfiles de IEAK, puede generar y crear el archivo de configuración automática o INS para almacenar la configuración de Internet Explorer 7. El Administrador de perfiles necesita en principio que cargue o cree un nuevo archivo INS. Puede empezar desde cero y crear un nuevo archivo INS con la misma configuración del Asistente para personalizar. Pero ¿por qué duplicar el trabajo? Al generar el paquete, IEAK creó el archivo install.ins predeterminado para almacenar la configuración del explorador. En lugar de crear un nuevo archivo INS en el Administrador de perfiles, use install.ins. Para cargar este archivo, busque la ruta INS del directorio builds, es decir, c:\builds\01012007\INS. Explore en profundidad a través de los subdirectorios restantes hasta que vea el archivo.
El Administrador de perfiles divide su configuración en dos secciones, tal y como puede observar en la figura 4. La configuración del asistente contiene las opciones del explorador, como página de inicio, configuración de proxy y zonas de seguridad. Estos valores se corresponden con la configuración de las fases 3 a 5 del Asistente para personalizar. La sección de directivas y restricciones controla las restricciones de usuario y se corresponde con la configuración de las cinco categorías de directivas y restricciones de la fase 5 del Asistente para personalizar.
Figura 4 Configuración de Internet Explorer con el Administrador de perfiles
Figura 4 Configuración de Internet Explorer con el Administrador de perfiles (Hacer clic en la imagen para reducirla)
Figura 4 Configuración de Internet Explorer con el Administrador de perfiles
Figura 4 Configuración de Internet Explorer con el Administrador de perfiles (Hacer clic en la imagen para ampliarla)
Puesto que ya ha definido esta configuración al crear el paquete, no es necesario modificar nada. No obstante, ésta es una buena oportunidad para revisar toda la configuración seleccionada para el paquete con el fin de asegurarse de que es precisa.
Después de comprobar la configuración en el Administrador de perfiles, guarde el archivo install.ins en otro lugar y cópielo en un servidor web interno. Para ello, deberá introducir la ruta de convención de nomenclatura universal (UNC) del servidor, la misma ruta de acceso que especificara en la pantalla Configuración automática de la fase 4 del Asistente para configurar. También se le pide que guarde un archivo CAB junto con el archivo INS, tal y como se muestra en la figura 5. ¿Por qué? Al modificar la configuración de Internet Explorer 7 con el Administrador de perfiles, IEAK necesita a menudo descargar entradas del Registro para los clientes de Windows. Estas entradas se guardan en archivos INF, que posteriormente se almacenan en un archivo CAB. Si cambia el número de versión del archivo INS debido a nuevas modificaciones, se genera un nuevo archivo CAB para la descarga. Almacene el archivo CAB en la misma ubicación del servidor web que el archivo INS.
Figura 5 Cómo guardar los archivos de configuración automática
Figura 5 Cómo guardar los archivos de configuración automática (Hacer clic en la imagen para reducirla)
Figura 5 Cómo guardar los archivos de configuración automática
Figura 5 Cómo guardar los archivos de configuración automática (Hacer clic en la imagen para ampliarla)
Es recomendable realizar copias del archivo INS y el archivo CAB, y guardarlas en distintas ubicaciones del servidor web. Considere estas copias como copias de seguridad y de prueba. Cuando modifique la configuración de Internet Explorer con el Administrador de perfiles en el futuro, puede descargar y modificar el archivo INS de prueba con el fin de probar los cambios antes de modificar el archivo INS real.
La modificación de un parámetro o control del explorador mediante el Administrador de perfiles es sencilla. Sólo tiene que seleccionar la categoría adecuada y podrá activar o desactivar cualquiera de las opciones. Después de realizar los cambios, vuelva a guardar el archivo INS y, a continuación, cópielo de nuevo en el servidor.
Una recomendación más: el archivo INS es un archivo de texto simple. Puede abrirlo en el Bloc de notas para ver su configuración. ¿Se puede también editar el archivo INS en el Bloc de notas? Sí, se puede y la configuración tendrá efecto. No obstante, el uso del Administrador de perfiles para modificar el archivo INS ofrece una serie de ventajas. El Administrador de perfiles genera automáticamente un archivo CAB en caso de que sea necesario y también marca el archivo INS con un número de versión nuevo cada vez que se modifique. Por ello, siempre debe usar el Administrador de perfiles para modificar el archivo INS.

Conclusión
IEAK es una herramienta eficaz para crear y personalizar la compilación de Internet Explorer 7 de forma rápida y eficaz. La última versión, IEAK 7, cuenta con varias mejoras en relación con versiones anteriores (pantallas más claras, ayuda más útil) para facilitarle el diseño del paquete de instalación. Mediante el conocimiento y el uso de IEAK, debe poder ofrecer una instalación confiable de Internet Explorer 7 a los usuarios y de satisfacer al director de tecnologías de información al mismo tiempo.
Distribución automática de Internet Explorer 7
Microsoft tiene intención de distribuir Internet Explorer 7 como actualización de alta prioridad a través de Actualizaciones automáticas y los sitios de Windows Update y Microsoft Update poco después del lanzamiento de la versión final de Internet Explorer 7. Esto puede suponer un problema como administrador según el entorno. Si los usuarios no tienen derechos de administrador local, no recibirán esta actualización. Asimismo, si administra el entorno con Microsoft Systems Management Server (SMS) o Windows Server Update Services (WSUS), ya controla las actualizaciones que reciben los usuarios. Si, por el contrario, algunos o todos los usuarios tienen derechos de administrador local y no dispone de ningún sistema para administrar las actualizaciones, es posible que deba bloquear la actualización de Internet Explorer 7. Microsoft ha creado un kit de herramientas de bloqueo de Internet Explorer 7. Este kit de herramientas (disponible en el Centro de descarga Microsoft, en inglés) incluye tanto una plantilla de directiva de grupo como un script que establece una clave de registro para impedir que se ejecute la actualización de Internet Explorer 7.

Lance Whitney es consultor, instructor y escritor técnico de TI. Ha creado y ofrecido soporte a paquetes de instalación de Internet Explorer desde la versión 4.0. Periodista en sus inicios, dio un giro hacia el mundo de TI hace unos 15 años.


 Preguntas y respuestas de SQL: Archivado de datos, servidores vinculados, medici&#243;n de ancho de banda y otras cuestiones
Preguntas y respuestas de SQL
Archivado de datos, servidores vinculados, medición de ancho de banda y otras cuestiones
Editado por Nancy Michell

Archivado de datos
P Necesito una estrategia completa de archivado de datos para mi grupo. Mi método actual se basa en el modelo estándar de realizar copias de seguridad de los datos y luego ejecutar utilidades que purgarán los datos históricos. Si es necesario recuperar los datos purgados, se restauran el entorno y la base de datos.
Busco una solución de archivado que funcione por fases. En la primera fase, se purgarían los datos de la base de datos, aunque se seguiría teniendo acceso en tiempo real. En otras palabras, los datos se eliminan de modo que el tamaño de la base de datos de producción resulta manejable, aunque los usuarios finales siguen teniendo acceso a los datos. En la fase dos, los datos se eliminarían por completo y sería necesaria una restauración para poder tener acceso a ellos. ¿Cómo puedo hacerlo?
R La forma más fácil consiste en restaurar la copia de archivo de la base de datos y luego modificar la aplicación para tener acceso a una nueva base de datos reducida o a la antigua completa si así lo solicita el usuario. Como resultado, contará con una copia de la base de datos en cada período de purga.
Si los cambios de datos son lentos y la mayoría de los datos no cambian entre las purgas, puede que termine teniendo muchas superposiciones y espacio desperdiciado. Por otro lado, como no se tiene acceso con frecuencia, probablemente puede que le sea suficiente con colocar los datos archivados en unas cuantas unidades grandes, más lentas y económicas (en lugar de en pequeñas unidades rápidas y caras). Si los datos se actualizan por completo en cada período, este sistema se ajustará a sus necesidades. Este proceso debe resultar bastante sencillo de administrar y prácticamente infalible.
También puede estudiar la posibilidad de usar instantáneas de base de datos; ofrecen una forma de crear una réplica de un momento dado antes de recortar la base de datos antigua. Aunque las instantáneas pueden funcionar bien en algunos escenarios, tienen muchas implicaciones. Las instantáneas de base de datos son operaciones de "copia por escritura" y mantienen de forma continua los cambios entre la base de datos original y el momento en que se toma la instantánea. Si hay muchos cambios con respecto al original, el tamaño de la instantánea puede hacerse un poco grande.
En cierto sentido, la instantánea de base de datos es el proceso opuesto a la copia de seguridad y la restauración. El primer método tiene sentido si prevé sólo unos pocos cambios, ya que sólo se almacenan las diferencias, mientras que este último es más adecuado si se esperan muchos cambios. En este caso, la ventaja de ahorro de espacio de la "copia por escritura" se desvanece mientras que se mantiene la dificultad de administrar instantáneas.
Otra opción es usar la partición de tablas. Permite tomar tablas concretas, designar intervalos de valores clave que pertenezcan a particiones distintas y colocar luego dichas particiones en grupos de archivos diferentes. Una vez que controle los datos que se incluyen en cada grupo de archivos de una tabla, podrá ejercer un mejor control de los costos asociados. Puede elegir qué grupos de archivos colocar en cada unidad física (consulte la nota anterior sobre unidades económicas y caras) así como de qué grupos de archivos se debe realizar una copia de seguridad y con qué frecuencia. Si hace que los grupos de archivos sean de sólo lectura, también puede usar copias de seguridad parciales.

Cantidad de bases de datos
P Mi compañía desea implementar y alojar una aplicación que se espera que ofrezca servicio a aproximadamente 5.000 de nuestros clientes. Nos gustaría implementar una base de datos por cliente para garantizar la confidencialidad. ¿Disminuiría la eficacia de los recursos del servidor si se usan para un tamaño de índice y datos determinado, un número de conexiones de usuario y una carga de 1 base de datos o de 5.000?
R Con independencia de la cantidad de personal, sería difícil mantener la misma base de código entre las bases de datos. Imagine corregir un error del código de la base de datos y tener que aplicarlo 5.000 veces. Igualmente, los tiempos de recuperación de base de datos serían tremendos, al igual que el tiempo que tardarían tareas como las copias de seguridad y la comprobación de la coherencia de base de datos. Piénselo de esta forma: ¿acaso un banco cuenta con una base de datos independiente en su host para cada cliente que disponga de una cuenta corriente?
SQL Server™ puede crear muchísimas bases de datos, pero este enfoque no es siempre el más adecuado. Sólo tiene que imaginar la cantidad de trabajo necesario para realizar una transacción en cada base de datos en el mismo período de tiempo; cada base de datos cuenta con su propio registro de transacciones. Como es bien sabido, una de las claves del rendimiento del procesamiento de transacciones en línea (OLTP) es mantener un entorno en el cual el registro de transacciones aproveche las escrituras secuenciales en su disco subyacente. Si desea realizar transacciones en estas bases de datos en lugar de leer sólo información de ellas, no siga este enfoque.

Consultas en un servidor vinculado
P Estoy desarrollando un almacenamiento de datos en SQL Server 2005 Service Pack 1 (SP1). Nuestro servidor de origen se encuentra en el dominio de un asociado y el servidor de destino está en nuestro propio dominio. Estamos obteniendo los registros del servidor de origen a través de un servidor vinculado. Cuando ejecutamos una consulta en el servidor de origen con combinaciones entre las tablas de origen, la consulta se realiza muy rápida. Sin embargo, si se da el caso de que hay una sola combinación con las tablas de destino, la consulta tarda una eternidad. ¿Por qué?
R Es recomendable evitar el uso de combinaciones entre servidores, especialmente dentro de un mismo dominio. Dicho esto, según los resultados concretos, este problema puede deberse a que sus asociados confían en su dominio, pero usted no confía en el dominio de sus asociados. Pruebe a refactorizar la consulta para ejecutarla desde el servidor de origen y, a continuación, copie los resultados en el servidor de destino. Es probable que obtenga mejores resultados.

Medición de ancho de banda
P ¿Existen recomendaciones para medir el ancho de banda usado en la creación de reflejo de la base de datos? Sé que hay un requisito que dice que debe ser unas tres veces el índice de generación de registros, pero si la demanda no es demasiado grande, ¿es posible crear el reflejo de base de datos a través de una conexión de banda ancha de Internet?
R Además del rendimiento, debe considerar la latencia de mensajes de ida y vuelta (que es mayor si la seguridad es total) e igualmente la confiabilidad vinculada. La creación de reflejo de la base de datos está optimizada para una conexión de red confiable, por lo que puede haber una cantidad considerable de sobrecarga en las reconexiones. Si la conexión de banda ancha es inestable (se interrumpen las conexiones o hay largos retrasos), es posible que no pueda mantener la conexión. Para obtener más ayuda, consulte estas notas del producto (en inglés) con consideraciones sobre el rendimiento de creación de reflejo de la base de datos.
Protección de acceso a SQL Server
¿Busca recomendaciones de protección de acceso a SQL Server en un entorno de producción? Busque en el Centro de desarrollo de modelos y prácticas de Microsoft (en inglés). Hay tres modelos que pueden ser de especial interés:
  • Índice de ingeniería de seguridad (en inglés)
  • Guía de seguridad para índice de aplicaciones (en inglés)
  • Creación de modelos de amenaza para aplicaciones web (en inglés)

¿Desea obtener información sobre cómo configurar un entorno operativo completo? Aquí tiene dos buenas referencias:
  • Windows Server System Reference Architecture (en inglés)
  • Guía de implementación de servicios de datos (en inglés)

Mis agradecimientos a los siguientes profesionales de TI de Microsoft por la aportación de sus conocimientos técnicos: Denis Altudov, Jayashree Anand, Gus Apostol, Bhavana Bartholf, Mike Blaszczak, Dibyendu Chakraverty, Shaun Cox, Laurentiu Cristofor, Ernie DeVore, Michael Epprecht, Nakul Garg, Phil Hummel, Steve Lindell, Kaloian Manassiev, Al Noel, Ward Pond, Paul Randal, Remus Rusanu, Mike Shelton, Christy Sutton, Kevin Tsai, Peter Ty, Val Wittenberg, Steven Wort, Kalyan Yella y Frankie Yuen.


 The Cable Guy: Optimizaci&#243;n autom&#225;tica de la ventana de recepci&#243;n TCP
The Cable Guy
Optimización automática de la ventana de recepción TCP
Joseph Davies

Bienvenido a la primera entrega de The Cable Guy de TechNet Magazine. Los admiradores de la columna del sitio web de TechNet ya saben que abarcamos todos los temas relacionados con la red, tradición que continuaremos aquí todos los meses. Si es nuevo y desea encontrar un archivo de columnas anteriores, diríjase al sitio de Cable Guy (en inglés).
Comencemos con el primer tema de esta nueva etapa: la ventana de recepción TCP.
El rendimiento a través de las conexiones TCP se puede limitar mediante el envío y recepción de aplicaciones, de implementaciones de TCP y la ruta de transmisión entre los puntos TCP. En esta columna voy a describir la ventana de recepción TCP y su efecto en el rendimiento TCP, el uso del ajuste de escala de la ventana TCP y la característica nueva Optimización automática de la ventana de recepción de Windows Vista™ que optimiza el rendimiento TCP para los datos recibidos.

Ventana de recepción TCP
Las conexiones TCP presentan un número importante de características. En primer lugar, se trata de circuitos lógicos punto a punto entre dos protocolos de nivel de aplicación. TCP no ofrece un servicio de entrega de uno a varios, sólo proporciona entrega de uno a uno.
En segundo lugar, las conexiones TCP están orientadas a la conexión. Antes de poder transferir los datos, dos procesos de nivel de aplicación deben negociar formalmente una conexión TCP mediante el proceso de establecimiento de conexión TCP. De igual forma, las conexiones TCP se cierran formalmente tras la negociación mediante el proceso de terminación de la conexión TCP.
En tercer lugar, los datos confiables enviados a través de una conexión TCP están secuenciados y se espera que el receptor dé una confirmación positiva. Si no se recibe dicha confirmación, se retransmitirá el segmento. En el receptor, los segmentos duplicados se han descartado y los que proceden de una secuencia se vuelven a colocar en el orden correcto.
En cuarto lugar, las conexiones TCP son de dúplex completo. Para cada punto TCP, la conexión TCP está compuesta por dos canalizaciones lógicas: una saliente y otra entrante. El encabezado TCP contiene el número de secuencia de los datos entrantes y una confirmación (ACK) para los datos salientes.
Asimismo, TCP ve los datos enviados a través de las canalizaciones lógicas de entrada y salida como una secuencia continua de bytes. El número de secuencia y el de confirmación para cada encabezado TCP se definen mediante límites de bytes. TCP no tiene conocimiento de los límites de registro o mensaje de la secuencia de bytes. El protocolo de nivel de aplicación debe ofrecer el análisis correcto de la secuencia entrante de bytes.
Para limitar el número de datos que se puede enviar simultáneamente y para proporcionar el control de flujo del lado del receptor, los puntos TCP usan una ventana. La ventana son todos los datos de la secuencia de bytes que el receptor permite que el remitente envíe. El remitente sólo puede enviar los bytes de la secuencia de bytes incluidos en la ventana. La ventana recorre la secuencia saliente de bytes del remitente y la secuencia entrante de bytes del receptor.
Para una canalización lógica determinada (una dirección de la conexión TCP de dúplex completo) el remitente mantiene una ventana de envío y el receptor una ventana de recepción. Cuando no existen datos o los segmentos ACK están en tránsito, se establece una coincidencia entre ventanas de envío y de recepción de canalización lógica. Dicho de otro modo, se establece la concordancia entre todos los datos de la secuencia saliente de bytes que puede enviar el remitente y todos los datos de la secuencia entrante de bytes que el receptor puede recibir. En la figura 1 se muestra dicha relación entre envío y recepción.
Figura 1 Establecimiento de coincidencia entre las ventanas de envío y recepción
Figura 1 Establecimiento de coincidencia entre las ventanas de envío y recepción (Hacer clic en la imagen para reducirla)
Figura 1 Establecimiento de coincidencia entre las ventanas de envío y recepción
Figura 1 Establecimiento de coincidencia entre las ventanas de envío y recepción (Hacer clic en la imagen para ampliarla)
Para indicar el tamaño de la ventana de recepción, el encabezado TCP contiene un campo de ventana de 16 bits. Cuando el receptor obtiene datos, envía segmentos de ACK al remitente para indicar la recepción correcta de bytes. En cada ACK, el campo de ventana toma nota del número de bytes que permanecen en la ventana de recepción. Cuando la aplicación envía, confirma y recupera datos, las ventanas de recepción y envío se desplazan hacia la derecha. La ventana de recepción es la que controla la cantidad de datos sin confirmar que pueden estar en tránsito desde el remitente hasta el receptor.
Puesto que pueden existir datos en la ventana de recepción que la aplicación no ha recuperado y datos que se han recibido pero no reconocido, la ventana de recepción TCP presenta una estructura adicional, como se muestra en la figura 2.
Figura 2 Tipos de datos de la ventana de recepción TCP
Figura 2 Tipos de datos de la ventana de recepción TCP (Hacer clic en la imagen para reducirla)
Figura 2 Tipos de datos de la ventana de recepción TCP
Figura 2 Tipos de datos de la ventana de recepción TCP (Hacer clic en la imagen para ampliarla)
Observe la diferencia entre las ventanas de recepción máxima y actual. La ventana de recepción máxima presenta un tamaño fijo. La ventana de recepción actual tiene un tamaño variable que se corresponde con el número de datos restantes que el receptor permite que el remitente le envíe. El tamaño de la ventana de recepción actual corresponde al valor del campo de ventana anunciado en los segmentos ACK que se han enviado de vuelta hacia el remitente y es la diferencia que existe entre el tamaño de la ventana de recepción máxima y el número de datos recibidos y reconocidos pero no recuperados por la aplicación.

Ventana de recepción TCP y rendimiento TCP
Para optimizar el rendimiento TCP (en función de una ruta de transmisión prácticamente sin errores), el remitente debe enviar suficientes paquetes para completar la canalización lógica entre remitente y receptor. Se puede calcular la capacidad de la canalización lógica mediante la fórmula siguiente:
Capacity in bits = path bandwidth in bits per second * round-trip time (RTT) in seconds
La capacidad se conoce como el producto del retraso de ancho de banda (BDP). La canalización puede ser ancha (ancho de banda alto) o estrecha (ancho de banda bajo); corta (RTT bajo) o larga (RTT alto). Las canalizaciones anchas y largas presentan el BDP más elevado. Ejemplos de rutas de transmisión de BDP elevado son las existentes entre redes de área extensa (WAN) de satélites o empresas que incluyan vínculos de fibra óptica intercontinental.
Aumento de rendimiento por parte del remitente para transmisiones de BDP elevado
La característica nueva Optimización automática de la ventana de recepción presenta una mejora en el rendimiento para los datos recibidos a través de vínculo de BDP elevado, pero qué ocurre con el rendimiento del remitente.
Los algoritmos existentes que evitan que un envío de punto TCP congestione la red se denominan algoritmos de inicio lento y control de congestión. Dichos algoritmos aumentan la ventana de envío (número de segmentos que el remitente puede enviar) durante el envío de datos inicial a través de la conexión y durante la recuperación de un segmento perdido.
El inicio lento aumenta la ventana de envío mediante un segmento TCP completo por cada segmento de confirmación recibido (para TCP en Windows XP y Windows Server 2003) o por cada segmento confirmado (para TCP en Windows Vista y Windows Server "Longhorn"). El control de congestión aumenta la ventana de envío mediante un segmento TCP completo por cada ventana de datos completa que se confirme.
Estos algoritmos funcionan bien con BDP bajos y tamaños de ventana de recepción pequeños. Sin embargo, cuando tiene una conexión TCP con un tamaño grande de ventana de recepción y un BDP elevado, como en la duplicación de datos entre dos servidores ubicados en un vínculo WAN de alta velocidad con un tiempo de ida y vuelta de 100 ms, estos algoritmos no aumentan la ventana de recepción con la velocidad suficiente para usar todo el ancho de banda de la conexión.
Para aprovechar el ancho de banda de las conexiones TCP en estas situaciones, la pila Next Generation TCP/IP incluye TCP compuesto (CTCP). CTCP aumenta más radicalmente la ventana de envío para las conexiones con tamaños de ventana de recepción grandes y productos BDP. CTCP intenta maximizar el rendimiento de estos tipos de conexión mediante la supervisión de las variaciones y pérdidas de retraso. CTCP también garantiza que su comportamiento no cause un efecto negativo en otras conexiones TCP.
En pruebas realizadas internamente en Microsoft, los tiempos de copias de seguridad de archivos de gran tamaño se redujeron en casi la mitad para una conexión de 1 Gbps con un tiempo de ida y vuelta de 50 ms. Las conexiones con un BDP de gran tamaño pueden incluso tener mejor rendimiento. CTCP y Optimización automática de la ventana de recepción colaboran para aumentar el uso del vínculo y pueden obtener mejoras del rendimiento para conexiones con productos BDP de gran tamaño.
CTCP está habilitado de forma predeterminada en los equipos que ejecutan Windows Server "Longhorn" y deshabilitado en los que ejecutan Windows Vista. Puede habilitar CTCP mediante el comando "netsh interface tcp set global congestionprovider=ctcp". Puede deshabilitar CTCP mediante el comando "netsh interface tcp set global congestionprovider=none".

El tamaño del campo de ventana en el encabezado TCP es 16 bits, lo que permite que un punto TCP anuncie un tamaño máximo de la ventana de recepción de 65.535 bytes. Puede calcular el rendimiento aproximado para un tamaño de ventana TCP determinado mediante la fórmula siguiente:
Throughput = TCP maximum receive windowsize / RTT
Por ejemplo, para una ventana de recepción de 65.535 bytes sólo podrá obtener un rendimiento aproximado de 5,24 Megabits por segundo (Mbps) en una ruta con 100 ms de RTT, independientemente del ancho de banda real de la ruta de transmisión. Con las actuales rutas de transmisión de BDP elevado, el tamaño de ventana TCP diseñado originalmente, incluso con el valor máximo, se convierte en un cuello de botella para el rendimiento.

Ajuste de escala de la ventana TCP
Para que los tamaños de ventana más grandes alojen rutas de transmisión de alta velocidad, la especificación RFC 1323 (ietf.org/rfc/rfc1323.txt) (en inglés) define un ajuste de escala de ventana que permite a un remitente anunciar un tamaño de ventana superior a 65.535 bytes. Una opción de ajuste de escala de la ventana TCP incluye un factor de ajuste de escala de ventana que, cuando se combina con un campo de ventana de 16 bits en el encabezado TCP, puede aumentar el tamaño de ventana de recepción hasta un máximo de 1 GB aproximadamente. La opción de ajuste de escala de ventana sólo se envía en segmentos sincronizados (SYN) durante el proceso de establecimiento de conexión. Ambos puntos TCP pueden indicar factores de ajuste de escala de ventana diferentes para los tamaños de ventana de recepción. Al permitir a un remitente enviar más datos a través de una conexión, el ajuste de escala de ventana TCP permite los nodos TCP para un mejor uso de algunos tipos de rutas de transmisión con productos BDP elevados.
Aunque el tamaño de ventana de recepción es importante para el rendimiento TCP, otro factor importante para determinar el rendimiento TCP óptimo es la velocidad de la aplicación en recuperar los datos acumulados en la ventana de recepción (velocidad de recuperación de la aplicación). Si la aplicación no recupera los datos, la ventana de recepción se empieza a llenar, lo que provoca que el receptor anuncie un tamaño actual de ventana menor. En el peor caso, la ventana de recepción máxima se llena completamente, lo que provoca que el receptor anuncie un tamaño de ventana de 0 bytes. En tal caso, el remitente debe detener el envío de datos hasta que la ventana de recepción se haya borrado. Por lo tanto, para optimizar el rendimiento TCP, la ventana de recepción TCP para una conexión debe tener configurado un valor que refleje tanto el BDP de la ruta de transmisión de la conexión como la velocidad de recuperación de la aplicación.
Incluso si puede determinar correctamente el BDP y la velocidad de recuperación de la aplicación, pueden cambiar con el transcurso del tiempo. La velocidad BDP varía en función de la congestión de la ruta de transmisión y la velocidad de recuperación de la aplicación según el número de conexiones a través de las que la aplicación recibe datos.

Ventana de recepción en Windows XP
Para la pila TCP/IP de Windows XP (y Windows Server® 2003), el tamaño máximo de la ventana de recepción presenta un número importante de atributos. En primer lugar, el valor predeterminado se obtiene a partir de la velocidad de vínculo de la interfaz emisora. El valor real se ajusta automáticamente a los incrementos uniformes del tamaño máximo de segmento (MSS) negociados durante el establecimiento de la conexión TCP.
En segundo lugar, el tamaño máximo de la ventana de recepción se puede configurar manualmente. Los valores del Registro HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\TCPWindowSize y HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Interface\InterfaceGUID\TCPWindowSize se pueden establecer en un máximo de 65.535 bytes (sin ajuste de escala de la ventana) o 1.073.741.823 (con ajuste de escala de la ventana).
En tercer lugar, el tamaño máximo de la ventana de recepción puede usar ajuste de escala de ventana. Se puede habilitar el ajuste de escala de ventana mediante el establecimiento del valor del Registro HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\Tcp1323Opts en 1 o 3. De forma predeterminada, el ajuste de escala de la ventana sólo se utiliza en una conexión si el segmento SYN recibido contiene casualmente la opción de ajuste de escala de ventana.
Por último, se puede especificar el tamaño máximo de la ventana de recepción mediante la opción SO_RCVBUF de Windows Sockets de una aplicación cuando se inicia una conexión. Para el ajuste de escala de la ventana, la aplicación debe especificar un tamaño superior a 65.535 bytes.
A pesar de la compatibilidad con las ventanas escalables, el tamaño máximo de la ventana de recepción en Windows XP puede limitar el rendimiento, ya que es un tamaño máximo fijo para todas las conexiones TCP (salvo que lo especifique la aplicación), que se puede mejorar para algunas conexiones y reducirse para otras. Además, el tamaño máximo fijo de la ventana de recepción para una conexión TCP no varía por cambios en la velocidad de recuperación de la aplicación o por congestión en la ruta de transmisión.

Optimización automática de la ventana de recepción en Windows Vista
Para optimizar el rendimiento TCP, especialmente para rutas de transmisión con un BDP elevado, la pila Next Generation TCP/IP de Windows Vista (y la próxima versión de Windows Server denominada con el código "Longhorn") es compatible con la optimización automática de la ventana de recepción. Esta característica determina el tamaño óptimo de la ventana de recepción mediante la medición del BDP y de la velocidad de recuperación de la aplicación y la adaptación del tamaño de la ventana para las rutas de transmisión y las condiciones de aplicación próximas.
La optimización automática de la ventana de recepción permite el ajuste de escala de la ventana de TCP de forma predeterminada hasta un tamaño máximo de la ventana de recepción de 16 MB. Mientras los datos fluyen en la conexión, la pila Next Generation TCP/IP supervisa la conexión, mide el BDP actual y la velocidad de recuperación de la aplicación, y ajusta el tamaño de la ventana de recepción para optimizar el rendimiento. La pila Next Generation TCP/IP ha dejado de usar los valores del Registro TCPWindowSize.
la optimización automática de la ventana de recepción presenta una serie de ventajas. Determina automáticamente el tamaño óptimo de la ventana de recepción en función de cada conexión. En Windows XP, el valor del Registro TCPWindowSize se aplica a todas las conexiones. Las aplicaciones ya no deben especificar los tamaños de ventana TCP mediante opciones de Windows Sockets. Además, los administradores de TI no volverán a configurar manualmente un tamaño de ventana de recepción TCP para determinados equipos.
Gracias a la optimización automática de la ventana de recepción, un punto TCP basado en Windows Vista anunciará normalmente tamaños de ventana de recepción mayores que un punto TCP basado en Windows XP. Esto permite que el otro punto TCP llene la canalización hacia el punto TCP basado en Windows Vista mediante el envío de más segmentos de datos TCP sin necesidad de esperar a una ACK (dependiente del control de congestión TCP). Para un tráfico de red de cliente normal, como páginas web o correo electrónico, el servidor web o el servidor de correo electrónico podrán enviar más datos TCP al equipo cliente con una velocidad mayor, lo que aumenta el rendimiento general de la red. Cuanto mayores son los valores de BDP y velocidad de recuperación de datos de la conexión, mayor será el rendimiento.
Su influencia se nota en la red en que una secuencia de paquetes de datos TCP que se envía normalmente a un ritmo más lento y medido, se envía más rápido, lo que provoca un mayor aumento en el uso de red durante la transferencia de datos. Para equipos basados en Windows XP y Windows Vista que realizan la misma transferencia de datos en una canalización larga y ancha, se transfiere el mismo número de datos. Sin embargo, la transferencia de datos para el equipo cliente de Windows Vista es más rápida gracias al mayor tamaño de la ventana de recepción y a la habilidad del servidor para llenar la canalización desde el servidor hasta el cliente.
Puesto que la optimización automática de la ventana de recepción aumentará el uso de red de rutas de transmisión con BDP elevados, el uso de Calidad de servicio (QoS) o del límite de la velocidad de envío de la aplicación puede llegar a ser importante para las rutas de transmisión que funcionan al borde de sus posibilidades. Para satisfacer esta futura demanda, Windows Vista es compatible con la configuración de QoS basada en directivas de grupo que le permite limitar la velocidad del tráfico saliente para una dirección IP o puerto TCP. Para obtener más información, consulte estos recursos de QoS basados en directivas (en inglés).
Aumento del rendimiento TCP para redes con pérdidas elevadas
El rendimiento TCP de redes con pérdidas altas puede disminuir drásticamente por tiempos de espera y retransmisiones frecuentes. Ejemplos de redes con pérdidas altas son las redes inalámbricas (como las redes basabas en la directiva IEEE 802.11, el Servicio GPRS o el Sistema Universal de Telecomunicaciones Móviles (UMTS)), que pueden registrar grandes pérdidas de paquetes en función de las condiciones de red, la atenuación de la señal, las interferencias electromagnéticas y el cambio de ubicación del equipo.
La pila Next Generation TCP/IP es compatible con las cuatro especificaciones RFC siguientes para optimizar el rendimiento de entornos con grandes pérdidas:

RFC 2582: la modificación NewReno al algoritmo de recuperación rápida de TCP
El algoritmo de recuperación rápida, definido en la RFC 2001, se basa en el algoritmo Reno, que incrementa la cantidad de datos que un emisor puede enviar cuando se retransmite un segmento debido a un evento de retransmisión rápido. Aunque el algoritmo Reno funciona correctamente con segmentos perdidos únicos, no lo hace igual de bien con múltiples segmentos perdidos. El algoritmo NewReno proporciona un rendimiento más rápido gracias a que cambia la forma en la que un remitente puede incrementar la velocidad de envío durante la recuperación rápida cuando se pierden varios segmentos en una ventana de datos y el emisor recibe una confirmación parcial (sólo de una parte de los datos que se han recibido correctamente).

RFC 2883: una extensión a la opción de confirmación selectiva (SACK) para TCP
SACK, definida en RFC 2018, permite a un receptor indicar hasta cuatro bloques no contiguos de datos recibidos mediante el uso de la opción SACK TCP. RFC 2883 define un uso adicional de los campos de la opción TCP de SACK para confirmar paquetes duplicados. De este modo, el remitente puede determinar cuándo se ha retransmitido innecesariamente un segmento y ajustar su comportamiento para evitar futuras retransmisiones innecesarias. Mientras menos retransmisiones se envíen, mejor será el rendimiento general.

RFC 3517: algoritmo de recuperación de pérdidas conservador basado en la confirmación selectiva para TCP
La implementación actual de TCP/IP en Windows Server 2003 y Windows XP sólo usa la información de SACK para determinar los segmentos TCP que no han llegado a su destino. RFC 3517 define un método de uso de la información de SACK para llevar a cabo la recuperación de pérdidas cuando se han recibido confirmaciones duplicadas mediante la sustitución del algoritmo de recuperación rápida anterior cuando SACK está habilitada en una conexión. La pila Next Generation TCP/IP realiza un seguimiento de la información de SACK en cada conexión y supervisa las confirmaciones entrantes y duplicadas para permitir una recuperación más rápida cuando no se reciben varios segmentos en el destino.

RFC 4138: reenvío de recuperación de tiempo de espera de retransmisión (F-RTO, Forward RTO-Recovery): algoritmo para detectar falsos tiempos de espera de retransmisión con TCP y el protocolo de transporte de control de secuencias (SCTP, Stream Control Transmission Protocol)
Las retransmisiones de segmentos TCP falsos pueden producir un aumento repentino del RTT, lo que provoca que los tiempos de espera de retransmisión (RTO) de los segmentos enviados anteriormente empiecen a caducar y TCP empiece a retransmitirlos. Si el incremento ocurre justo antes de enviar una ventana completa de datos, un emisor puede retransmitir toda la ventana. El algoritmo F-RTO impide la retransmisión de segmentos TCP falsos mediante el siguiente comportamiento.
Cuando se agota el tiempo de espera de retransmisión para varios segmentos, TCP retransmite sólo el primero de ellos. Cuando se recibe la primera confirmación, TCP comienza a enviar segmentos nuevos (si el tamaño de ventana anunciado lo permite). Si en la siguiente confirmación se reconocen los demás segmentos que han agotado el tiempo de espera pero que no se han retransmitido, TCP determina que el tiempo de espera era falso y no retransmite dichos segmentos.
El resultado es que para los entornos en los que se producen incrementos repentinos y temporales del tiempo de ida y vuelta como, por ejemplo, cuando un cliente inalámbrico se desplaza de un punto de acceso a otro, F-RTO impide la retransmisión innecesaria de segmentos y vuelve más rápidamente a su velocidad de envío normal. El uso de la recuperación de pérdidas basada en SACK y F-RTO resulta idóneo para conexiones que usan vínculos GPRS.

Joseph Davieses escritor técnico en Microsoft y ha enseñado y escrito sobre temas de red de Windows desde 1992. Ha escrito cinco libros para Microsoft Press y es el autor de la columna mensual TechNet Cable Guy (en inglés).


 Windows PowerShell: Construcciones de Windows&#160;PowerShell
Windows PowerShell
Construcciones de Windows PowerShell
Don Jones

El mes pasado les mostré algunas formas en que Windows PowerShell se podía poner en funcionamiento inmediato mediante la resolución de tareas administrativas, sin escribir realmente ningún script. Sin embargo, aunque Windows PowerShell es un shell interactivo excelente, puede aprovechar de verdad sus capacidades y automatizar más tareas complejas cuando empiece a utilizar su lenguaje de scripting eficaz y a la vez simple.
Aun así, es posible que se esté preguntando: ¿De verdad necesita Microsoft otro lenguaje de scripting? Después de todo, Microsoft nos ha traído KiXtart, un procesador de script de inicio de sesión, así como Visual Basic® Scripting Edition (VBScript). La respuesta, sin embargo, es sí. Microsoft necesita otro lenguaje de scripting. Explicaré por qué.
Era necesario que el lenguaje de Windows PowerShell™ fuera simple e intuitivo, de forma que los administradores pudieran entenderlo sin someterse a un largo periodo de aprendizaje. También era necesario que fuera muy flexible, para que pudiera acomodar toda la funcionalidad que Windows PowerShell puede proporcionar a los usuarios.
Debido a que Windows PowerShell se basa en Microsoft® .NET Framework, era necesario que su sintaxis de scripting fuera compatible con .NET. Al ensamblar un lenguaje de scripting para Windows PowerShell, los diseñadores seleccionaron una sintaxis que esencialmente es un C# simplificado (un C-Sharp destacado, uno de los lenguajes que se distribuyen con .NET Framework). ¿Por qué no seguir con una sintaxis como VBScript? En realidad, el lenguaje de scripting de Windows PowerShell no es tan distinto a VBScript, pero al ceñirse más a la sintaxis de C#, PowerShell proporciona una especie de peldaño inicial para aprender programación de .NET Framework. Si alguna vez decide cambiar a Visual Studio® y comenzar a escribir aplicaciones C#, gran parte de la sintaxis de scripting de Windows PowerShell también cambiará.
Una de las cosas más importantes en el lenguaje de scripting de Windows PowerShell, o en cualquier lenguaje de scripting, es su construcción. Existen elementos de lenguaje especiales que permiten a Windows PowerShell realizar comparaciones lógicas y llevar a cabo diferentes acciones basadas en los resultados de dichas comparaciones o que le permiten repetir una o más instrucciones.

Pensamiento lógico
Las comparaciones lógicas están en el centro de muchas construcciones de lenguaje de scripting y Windows PowerShell no es una excepción. Una comparación se centra esencialmente en dos valores u objetos y evalúa si el resultado de la comparación es True o False. Por ejemplo, podría preguntarse, "¿Es la fecha de caducidad de esta contraseña de usuario la fecha de hoy?" El resultado sería True si las fechas coinciden y False si las fechas son diferentes. Observe que estoy escribiendo en mayúsculas True y False, porque son términos que tienen un significado especial en Windows PowerShell.
A continuación, verá un ejemplo de una comparación real que podría realizar en Windows PowerShell:
PS C:\> $a = 1
PS C:\> $b = 2
PS C:\> $a -eq $b
False
he creado una variable llamada $a y la he configurado para que contenga el valor 1. En Windows PowerShell, los nombres de variables siempre comienzan con el signo de dólar, así que son fáciles de identificar. El signo = se conoce técnicamente como operador de asignación, porque se utiliza para asignar un valor. A continuación, creo una segunda variable, $b, y le asigno el valor 2. Luego viene la comparación lógica real: solicito a Windows PowerShell que compare el contenido de $a y $b mediante el operador -eq (igualdad). PowerShell realiza la comparación, determina que los dos valores no son iguales y muestra el resultado: False.
Los operadores de Windows PowerShell son algo diferentes de otros lenguajes de scripting que quizá haya visto antes y son distintos incluso de C#. La mayoría de los lenguajes utilizará el operador = para realizar comprobaciones de igualdad así como para asignar valores; Windows PowerShell evita la confusión al tener un operador dedicado para cada función. En la figura 1 se muestran los operadores de comparación de Windows PowerShell, junto con operadores equivalentes en otros lenguajes (como VBScript) que quizá ya conozca.
Figure 1 Operadores de comparación de PowerShell (Close Figure 1)

Operador | Nombre | Descripción
-eq | Igualdad | Comprueba si los valores son los mismos. Otros lenguajes pueden utilizar = o == para comprobar la igualdad.
-ne | No igual | Comprueba la desigualdad. Otros lenguajes pueden utilizar <> o != para comprobar la desigualdad.
-gt | Mayor que | Comprueba si un valor es mayor que otro. Otros lenguajes pueden utilizar el carácter >.
-lt | Menor que | Comprueba si un valor es menor que otro. Otros lenguajes pueden utilizar el carácter <.
-ge | Mayor que o igual a | Comprueba si un valor es mayor que o igual a otro valor. Similar a>= en VBScript y otros idiomas.
-le | Menor que o igual a | Comprueba si un valor es menor que o igual a otro valor. Similar a<= en VBScript y otros idiomas.
Estos operadores de comparación tienen otra función de interés. Examine esta comparación:
PS C:\> $a = "TechNet"
PS C:\> $b = "technet"
PS C:\> $a -eq $b
True
de forma predeterminada, los operadores de comparación no distinguen entre mayúsculas y minúsculas, lo que significa que la versión escrita en mayúsculas de TechNet se toma como equivalente de "technet". Esto es conveniente porque en la mayoría de las tareas administrativas no se tiene en cuenta si las letras se escriben en mayúsculas o no. Sin embargo, a veces es posible que solicite a Windows PowerShell que realice una comparación distinguiendo entre mayúsculas y minúsculas mediante la anteposición de c en el operador de comparación:
PS C:\> $a -ceq $b
False
Del mismo modo, si alguna vez le preocupa o le desconcierta si Windows PowerShell va a realizar o no una comparación en la que no tenga en cuenta mayúsculas y minúsculas, puede forzarlo a hacerlo mediante la anteposición de la letra i:
PS C:\> $a -ieq $b
True
Simplemente recuerde que las comparaciones lógicas siempre dan como resultado uno de los dos siguientes valores: True o False.

Toma de decisiones
Ahora que sabe cómo escribir comparaciones lógicas, puede comenzar a utilizarlas en construcciones. La primera construcción que le mostraré permite a Windows PowerShell tomar decisiones basadas en una comparación. Se denomina construcción If y existen algunas variaciones de la misma. La más simple es la siguiente:
PS C:\> if ($a -eq $b) {
>> Write-Host "They are equal"
>> }
>>
They are equal
Existen algunos aspectos interesantes que comentar aquí. En primer lugar, las variables $a y $b todavía contienen los valores "TechNet" y "technet", respectivamente. Comencé la construcción con la palabra clave If. A continuación, entre paréntesis, especifiqué la comparación lógica que quería realizar. Después nos encontramos con una llave, que indica el comienzo de lo que llamaré código condicional, el código que Windows PowerShell ejecutará si la comparación devuelve un resultado True. Como sabrá por el ejemplo anterior, esta comparación devuelve el resultado True, por lo que espero que el código condicional se ejecute. Escribo el código condicional, Write-Host "They are equal" y presiono Entrar. Por último, finalizo la sección del código condicional escribiendo una llave de cierre y presionando Entrar dos veces. La segunda vez que presiono Entrar, lo hago sobre una línea en blanco que permite al analizador saber que he terminado de escribir y que estoy listo para que se ejecute el código.
Observe que esta construcción no se está ejecutando desde un archivo de script. Simplemente la escribí en la línea de comandos de Windows PowerShell. Lo que hace que Windows PowerShell sea exclusivo en el mundo del scripting de Windows es que los scripts se pueden crear de forma interactiva, así como almacenarse en un archivo permanentemente.
En cuanto escribí la llave de apertura y presioné Entrar, Windows PowerShell mostró un símbolo de >>. Esa es su forma de decir, "reconozco que se encuentra en una construcción, estoy listo para que empiece a escribir lo que vaya en la construcción". Tras escribir la llave de cierre y presionar Entrar dos veces, Windows PowerShell ejecutó la construcción de forma inmediata, determinó que la comparación lógica era True y ejecutó el código condicional. Esto puede comprobarse porque "They are equal" se mostró antes de que PowerShell volviera a su símbolo normal. El uso de Windows PowerShell para crear scripts de forma interactiva permite probar pequeños fragmentos de código antes de ensamblarlos en un script de carácter más permanente, lo que hace que el aprendizaje y la depuración sean más sencillos.
Debo señalar que Windows PowerShell no es muy quisquilloso con cosas como presionar Entrar. Por ejemplo, esto es prácticamente lo mismo que el ejemplo anterior:
PS C:\> if ($a -eq $b) { Write-Host "They are equal" }
They are equal
Debido a que escribí todo esto en una sola línea, Windows PowerShell no necesitó mostrar el símbolo especial de >>; simplemente ejecutó la construcción cuando presioné Entrar al final de la línea. ¿Cómo supo Windows PowerShell que podía ejecutar la construcción? Porque estaba completa en el momento que escribí la llave de cierre.
Aludí a otras variaciones de la construcción If. A continuación se muestra un ejemplo completo, presentado como puede aparecer en un archivo de scripts PS1, en lugar de en shell:
if ($a -eq $b) {
  Write-Host "They are equal"
} elseif ($a -lt $b) {
  Write Host "One is less than the other"
} else {
  Write Host "One is greater than the other"
}
La construcción comienza del mismo modo, con la palabra clave If. Sin embargo, en el supuesto caso de que la comparación sea False, he proporcionado otra comparación con la palabra clave Elseif. Si esta última comparación también es False, mi última palabra clave, Else, proporciona un conjunto final de código que se ejecutará.

Repetición
Windows PowerShell incluye un par de construcciones para ejecutar código una y otra vez, hasta que la comparación sea True o False. Los programadores denominan a este fenómeno construcciones de bucle. Y lo que es mejor, una de las construcciones de bucle más útiles es capaz de enumerar los objetos de una colección y ejecutar una o varias líneas de código para cada objeto. De manera apropiada, la construcción recibe el nombre de construcción foreach y se presenta del siguiente modo:
PS C:\> $names = get-content "c:\computers.txt"
PS C:\> foreach ($name in $names) {
>> Write-Host $name
>> }
>>
don-pc
testbed
Comencé a pedirle al cmdlet Get-Content de Windows PowerShell que recuperara el contenido del archivo c:\computers.txt, un archivo que creé y que contenía un nombre de equipo por línea. Windows PowerShell trata cada línea como un objeto, por lo que el archivo es fundamentalmente una colección que contiene dichos objetos. La colección concluye en la variable $names. Mediante la palabra clave Foreach, le indico a Windows PowerShell que enumere la colección $names, haciendo uso de la variable $name para representar el objeto actual cada vez que se ejecute el bucle. El código de bucle debe ir entre llaves. Así que, para cada nombre del archivo, introduciré el nombre en la línea de comandos. Y, como se puede ver en el resultado que sigue a la construcción, esto es exactamente lo que hace Windows PowerShell. A continuación, puede comprobar el modo en el que esto proporcionaría una ventaja obvia en los scripts administrativos: por ejemplo, puede construir fácilmente una lista de nombres de servidores y pedir a Windows PowerShell que recupere, a su vez, información de cada uno de ellos.

Construcciones reales
Tomemos las comparaciones lógicas, la construcción If y la construcción foreach y hagamos algo útil. Me gustaría comprobar rápidamente el estado del servicio Messenger de un conjunto de servidores. Espero que el servicio se detenga en la mayoría de los servidores, por lo que no deseo que Windows PowerShell muestre todos los servidores en los que el servicio se encuentra en el estado que espero; sólo quiero que muestre los servidores en los que ya se ha iniciado el servicio Messenger porque éstos son los servidores con los que necesito trabajar.
El cmdlet Get-Service de Windows PowerShell puede ayudarme a recuperar la información que necesito para el equipo local. Sin embargo, desafortunadamente, no puede extenderse hasta un equipo remoto, que es en realidad mi objetivo. Por suerte, también puedo tener acceso a la misma información a través de Instrumental de administración de Windows (WMI), haciendo uso del cmdlet Get-WMIObject, que me permite trabajar con un equipo remoto. El script es el siguiente:
$names = get-content c:\computers.txt
foreach ($name in $names) {
  $svc = get-wmiobject win32_service '
   -computer $name -filter "name='messenger'"
  if ($svc.started -eq $True ) {
    write-host "$name has Messenger running"
  }
}
¿Ha observado el carácter ' de la tercera línea? Indica a Windows PowerShell que la siguiente línea es una continuación. Es útil en casos como éste, en los que no encajaría toda la línea en la revista sin ajustarlo. Observe también que la construcción If compara $svc.started con $True. La variable $True es una variable especial de Windows PowerShell que representa el valor booleano True. La variable complementaria, $False, representa el valor booleano False. En realidad, podría haber hecho un pequeño acceso directo:
$names = get-content c:\computers.txt
foreach ($name in $names) {
  $svc = get-wmiobject win32_service '
   -computer $name -filter "name='messenger'"
  if ($svc.started) {
    write-host "$name has Messenger running"
  }
}
Recuerde que la condición de la construcción If sólo necesita ser True o False. Normalmente, se obtiene True o False al comparar dos valores, como hice en la primera versión de este script. Sin embargo, debido a que la propiedad Started es True o False, no es necesario compararla con True o False.

Una herramienta útil
Aquí tiene una herramienta administrativa sencilla y útil que utilizan las construcciones para realizar su trabajo. Independientemente de si la escribe en Windows PowerShell de forma interactiva o la guarda en un archivo PS1 para volverla a utilizar de forma sencilla, se trata de una herramienta práctica para comprobar el estado de un servicio en varios equipos, así como de una gran demostración de cómo las construcciones pueden ayudar a automatizar tareas administrativas.

Don Jones es el director de proyectos y servicios de SAPIEN Technologies y coautor de Windows PowerShell: TFM (SAPIEN Press, 2006). Póngase en contacto con Don a través de su sitio Web en ScriptingAnswers.com (en inglés)


 &#161;Hola, chicos del scripting!: Ten cuidado con lo que dices
¡Hola, chicos del scripting!
Ten cuidado con lo que dices
Los chicos del scripting de Microsoft

DURANTE LA GUERRA CIVIL AMERICANA (concretamente, en la batalla de Spotsylvania), el general de la Unión John Sedgwick quedó consternado al ver a sus hombres retorcerse de miedo ante los disparos aleatorios de los francotiradores de los confederados. Según cuenta la leyenda, Sedgwick les dijo: "Me avergüenzo de vosotros, ¿cómo podéis esconderos así? Nunca darán en el blanco a esa distancia". Minutos después, Sedgwick se convirtió en el oficial de la Unión de mayor rango muerto durante la guerra. Puede que los Confederados no pudieran acertar a esa distancia, pero desafortunadamente para Sedgwick, el general resultó ser un blanco fácil.
Por supuesto, sobra decir que la moraleja de esta historia puede ser... (-Bueno, ahora que lo dices, "Si oyes disparos, agacha la cabeza", no queda mal, ¿no?). Increíble, pero no habíamos pensado en eso. En lugar de eso, habíamos llegado a la moraleja siguiente: "Cuidado con lo que dices, que un día esas palabras se pueden volver en tu contra". Así fue para el general John Sedgwick, y así puede ser para muchas otras personas. Por ejemplo, nadie recuerda a Thomas Watson, director de IBM durante bastante tiempo, como uno de los mayores emprendedores de la historia americana. En vez de eso, Watson ha pasado a la historia como el hombre que dijo, "Creo que el mercado mundial está preparado para cinco ordenadores tal vez".
Curiosamente, no existen pruebas de que Watson pronunciara realmente esas palabras; como mucho, puede que expresara a alguien su opinión sobre el tema. Sin embargo, eso no le interesa a nadie. Después de todo, la idea de que el director de IBM dijera que no existía mercado para los ordenadores es una historia tan jugosa, que deja a un lado el insignificante hecho de que puede no ser cierto, ¿verdad?
A propósito, Watson también dijo: "Si quieres tener éxito, multiplica la frecuencia de errores por dos". Este es precisamente el consejo que los chicos del scripting han adoptado como filosofía.
Bueno, por lo menos la parte de duplicar la frecuencia de errores.
Por otro lado, existe una cita que dice: "Si estás escribiendo scripts VBScript, no tendrás acceso a .NET Framework". Hay que reconocer que afirmar que los generadores de scripts no pueden tener acceso a Microsoft® .NET Framework es tan memorable como "Nunca darán en el blanco a esa distancia" o "Creo que el mercado mundial está preparado para cinco ordenadores tal vez". Sin embargo, dicha afirmación carece de fundamentos. Es cierto que .NET Framework ha sido diseñado con desarrolladores de C# y Visual Basic® como modelo; es igualmente cierto que VBScript no puede crear instancias de clases de .NET Framework nativas. Sin embargo, eso no significa que los generadores de scripts no tengan acceso a .NET Framework, por lo menos, no en todos los casos.
De acuerdo, tiene razón: no podemos negar que la mayoría de las clases de.NET Framework están fuera del alcance de VBScript. No obstante, existe un mayor número de clases de .NET que tienen contenedores tipo COM, lo que significa sencillamente que dichas clases incluyen una interfaz COM que ofrece posibilidades de acceso mediante un lenguaje de scripting como VBScript. Parece difícil de crear, ¿verdad? Échele un vistazo a la parte de HKEY_CLASSES_ROOT en el registro que se muestra en la figura 1; debe prestar atención a todos los tipos de clases que comiencen por System.
Figura 1 Clases System del registro
Figura 1 Clases System del registro (Hacer clic en la imagen para reducirla)
Figura 1 Clases System del registro
Figura 1 Clases System del registro (Hacer clic en la imagen para ampliarla)
La mayoría son clases de .NET Framework y para la mayoría se puede crear una instancia mediante VBScript.
¡Se lo dije!
Por supuesto, como puede confirmar cualquier persona que haya comprado alguna vez un producto anunciado en televisión de madrugada, que se pueda hacer algo no significa que se deba hacer (suele existir un motivo para que dichos productos no se estén disponibles en comercios). Obviamente, puede crear una instancia de la clase System.ContextMarshalException en un script; simplemente no sabemos por qué o para qué la podría crear.
Sin embargo, este no es el caso de todas las clases de .NET Framework. Por ejemplo, uno de los mayores problemas en el campo del scripting es la dificultad para crear una lista de clasificación de los elementos. Para realizar una lista en orden alfabético, es necesario que use su propio conjunto de registros sin conexión o cree una función de clasificación, como los códigos de clasificación de burbuja siguientes (el párrafo siguiente puede herir la sensibilidad de los más débiles):
For i = (UBound(arrNames) - 1) to 0 Step -1
    For j= 0 to i
        If UCase(arrNames(j)) >
          UCase(arrNames(j+1)) Then
            strHolder = arrNames(j+1)
            arrNames(j+1) = arrNames(j)
            arrNames(j) = strHolder
        End If
    Next
Next
No se asuste: hemos escrito el código y no estamos completamente seguros de lo que significa.
¿Cómo puede ayudarnos .NET Framework en una situación semejante? Para responder a esta pregunta, observemos un pequeño script sencillo y directo:
Set DataList = CreateObject _
      ("System.Collections.ArrayList")

DataList.Add "B"
DataList.Add "C"
DataList.Add "E"
DataList.Add "D"
DataList.Add "A"

DataList.Sort()

For Each strItem in DataList
    Wscript.Echo strItem
Next
Como puede comprobar, lo que hemos hecho aquí es crear una instancia de la clase de .NET Framework System.Collections.ArrayList. A continuación, hemos usado el método Add para agregar cinco elementos a la lista. Todo está bien y es correcto, salvo en un punto: agregamos estos elementos de una forma un tanto aleatoria (B, C, E, D, A), aunque necesitamos verlos por orden alfabético (A, B, C, D, E). Ha llegado el momento de usar el código de clasificación de burbuja, ¿no cree?
Error. Sentimos ser tan categóricos, pero es un error. Como se ha demostrado, no necesitamos usar el código de clasificación de burbuja; todo lo que necesitamos es llamar al método Sort de la lista de matrices:
DataList.Sort()
Eso es todo. Gracias a esa única línea de código podemos ordenar todos los elementos de nuestra lista de matrices.
¿Lo demostramos? ¡Que público más exigente! Está bien, espero que haya algún incrédulo. Esta es la razón por la que el script incluye un bucle For Each que se repite en todos los elementos de la lista, haciendo eco del valor de cada uno en la pantalla:
For Each strItem in DataList
    Wscript.Echo strItem
Next
Ahora le planteo una cuestión: ¿qué obtenemos cuando ejecutamos este script?
Exacto:
A
B
C
D
E
Está bien, ¿no?
Veamos, parece que el resultado no es del todo satisfactorio. Es correcto, pero lo que quería era devolver esos valores en orden descendente; es decir, desea obtener una lista de Z a A en lugar de una lista de A a Z. Si es posible. . .
Bueno, ningún problema. Sólo tenía que preguntar:
Set DataList = CreateObject _
      ("System.Collections.ArrayList")

DataList.Add "B"
DataList.Add "C"
DataList.Add "E"
DataList.Add "D"
DataList.Add "A"

DataList.Sort()
DataList.Reverse()

For Each strItem in DataList
    Wscript.Echo strItem
Next
Tiene razón: esto tiene el mismo mal aspecto que lo anterior, ¿verdad? Sin embargo, hemos realizado una adición importante. Observe la línea de código agregada, la línea posterior al método Sort:
DataList.Reverse()
¿Lo ve? Después de ordenar la lista en orden ascendente, llamamos al método Reverse que... sorpresa, sorpresa... invierte el orden de todos los elementos de la matriz. ¿Qué obtenemos? Un resultado con el aspecto siguiente:
E
D
C
B
A
Impresiona, ¿eh?
¡Pero espera! Puede ser todavía mejor. ¿Ha intentado alguna vez quitar un elemento de una matriz VBScript? No llore; no se lo voy a pedir. En lugar de eso, le vamos a demostrar lo fácil que es quitar un elemento de nuestra lista de matrices de .NET Framework. ¿No le gusta la letra D? Deshágase de ella. Aquí se muestra un script que crea una lista de matrices, la ordena y, a continuación, quita la entrada para la D:
Set DataList = CreateObject _
  ("System.Collections.ArrayList")

DataList.Add "B"
DataList.Add "C"
DataList.Add "E"
DataList.Add "D"
DataList.Add "A"

DataList.Sort()
DataList.Remove("D")

For Each strItem in DataList
    Wscript.Echo strItem
Next
Debe volver a mirar la pequeña línea de código posterior al método Sort:
DataList.Remove("D")
Hemos usado el método Remove para quitar el elemento igual a D. Este el resultado de ejecutar este script:
A
B
C
E
Hasta la vista, D!
No se olvide de la mejor parte: podemos quitar un elemento sin tener que cambiar el tamaño o dimensiones de la matriz. Ahora sí tiene buena pinta. No cabe duda de que también podemos agregar elementos a la matriz sin tener que cambiar el tamaño o dimensiones de sus componentes. Atrévase a decir que el scripting no es más fácil así.
Se lo crea o no se lo crea, sólo hemos descrito superficialmente lo que puede hacer con arraylist de .NET Framework (para obtener más información, consulte la entrada arraylist en .NET Framework SDK (en inglés)).
¿Es útil arraylist para los generadores de scripts? Digámoslo así: después de ver la utilidad de arraylist en .NET Framework, no estamos seguros de por qué quería usar una matriz VBScript integrada, al menos no para listas simples de elementos como las empleadas aquí.
Hay que reconocer que los chicos del Scripting no hemos analizado .NET Framework en profundidad para descubrir las clases que pueden servir a los generadores de scripts (y las que no). Estamos trabajando en ello. Mientras tanto, indague todo lo que desee en .NET Framework SDK (en inglés). Parece que siempre que examinamos SDK, encontramos algo nuevo e interesante que los generadores de scripts pueden aprovechar.
¿Cómo qué? Qué le parece la generación de números aleatorios. ¿Desea generar un número aleatorio entre 1 y 100 mediante el generador de números aleatorios de VBScript? No hay problema; sólo debe usar un código parecido a éste:
Randomize
Wscript.Echo Int((100 - 1 + 1) * Rnd + 1)
¿Se ha aprendido la fórmula? No se preocupe; resulta mucho más fácil e intuitivo usar la clase System.Random de .NET Framework:
Set objRandom = CreateObject("System.Random")
Wscript.Echo objRandom.Next_2(1,100)
Seguro que lo puede descifrar sin necesidad de explicaciones. En cualquier caso, se lo explicaremos brevemente, aunque sólo sea porque TechNet Magazine quiere que los columnistas escriban algo cada mes. No nos pregunté el motivo, es su política, no la nuestra.
Como puede ver, creamos una instancia de la clase System.Random y, a continuación, llamamos al método Next_2 e introducimos dos parámetros en el método:
  • 1, primer número del intervalo (recuerde que vamos a generar un número aleatorio entre 1 y 100).
  • 100, el valor superior del intervalo.
Eso es todo lo que debemos hacer.
Parece que tenemos tiempo para una última cuestión. Sí, el de la camiseta verde. ¿Quién dijo exactamente que los que escriben scripts no pueden obtener acceso a .NET Framework? Bueno, para ser totalmente sincero, al empezar, nosotros... -Vaya, parece que se ha acabado el tiempo. ¡Nos vemos el mes que viene!
¡Que disfruten!
Febrero está cerca, lo que sólo puede significar una cosa. No, el día de San Valentín, no. No, el Día del Presidente tampoco. Por amor de Dios, ¿el Día de la Marmota? No, cuanto más nos acercamos a febrero más cerca estamos de la edición de 2007 de Winter Scripting Games, la competición de scripting más importante del ámbito internacional (probablemente la única). La competición de este año promete ser más grande y mejor que nunca; esta vez habrá cuatro categorías:
  • Principiantes en VBScript
  • Expertos de VBScript
  • Principiantes en Windows PowerShell™
  • Expertos en Windows PowerShell
Visite la página principal de 2007 Winter Scripting Games (en inglés) para obtener más información.
¿Cómo que qué es eso? Está bien, gracias. Ah, que pase también un feliz Día de la Marmota.

Descargar Windows PowerShell hoy
Windows PowerShell 1.0 ya se puede descargar. ¡Y es gratuito! No deje pasar esta oportunidad, descargue el software y empiece a usarlo hoy.

Los chicos del scripting de Microsoft trabajan para (bueno, son empleados de) Microsoft. Cuando no juegan al béisbol, ni entrenan ni lo ven (u otras actividades varias), dirigen el TechNet Script Center. Visite la página web www.scriptingguys.com.


 Exchange Queue &amp; A: Tenemos todas las respuestas (porque nosotros hicimos las preguntas)
Exchange Queue & A
Tenemos todas las respuestas (porque nosotros hicimos las preguntas)
KC Lemson and Paul Bowden

¡Hola, bienvenido a la primera entrega de Exchange Queue & A! Empezaremos con una serie de preguntas que, para ser honestos, nos hicimos nosotros mismos. Así que quizá no sea justo colocar esta columna como una columna verdadera de preguntas y respuestas,
ya que es una columna de Q&A sólo porque las preguntas y las respuestas se suceden en una habitación con eco. Creemos, sin embargo, que estas preguntas pueden representar las mismas cuestiones existentes en las mentes de los clientes de Microsoft® Exchange Server y es por eso que reivindicamos la fundamentación moral de la misma. En el futuro, sus respuestas son bienvenidas, así que puede enviarlas a queuea@microsoft.com.
Nuestra idea actual de esta columna es que sea un desfile rotativo de autores (como una especie de "tire a los escritores contra la pared y vea cuál se pega"), pero todos nosotros hemos trabajado con Exchange durante muchos años. Este mes, las respuestas (y preguntas) han sido escritas conjuntamente por KC Lemson y Paul Bowden, Directores de administración de programas en el equipo de productos de Exchange en Microsoft. Los dos somos veteranos en el desarrollo de Exchange. Nos hemos movido un poquito, pero nunca hemos podido alejarnos de la mensajería.
KC ha trabajado en el grupo de Exchange durante los últimos seis años, donde desempeñó varios puestos, incluyendo el de directora de programas en Microsoft Outlook® Web Access (OWA) y el de directora de administración de programas a cargo del programa de clientes preliminar de Exchange. Actualmente, es la administradora de experiencias del usuario de Exchange, a cargo del diseño de productos y la investigación sobre clientes. Antes de trabajar en Exchange, fue responsable de pruebas en Outlook durante tres años y estuvo a cargo de la realización de pruebas de datos adjuntos durante la época en que la gente pensaba que bloquear datos adjuntos ejecutables en el correo electrónico era algo malísimo. Consulte el blog de KC en blogs.technet.com/kclemson.
Paul ha pasado los últimos tres años trabajando en la pequeña pero ingeniosa herramienta Exchange Best Practices Analyzer (ExBPA). De hecho, ganó un premio por esta herramienta hace un par de meses y se hizo una foto con Bill Gates. Sin embargo, con la aparición del proyecto Exchange Server 2007, es hora de cambiar de puesto. Paul necesita dejar de soñar con XML y volver al mundo real. Será el administrador de la versión de la siguiente versión de Exchange (la versión en la que comenzaremos a trabajar en cuanto se distribuya Exchange Server 2007).
Por cierto, ¿le gustó la increíble cantidad de ingenio demostrado en la denominación de esta columna? Nosotros, por supuesto, ni siquiera podemos atribuirnos el nombre; nos lo sugirió un lector del blog de KC. (Disfruta de la camiseta, Tim) Las propuestas de otros participantes fueron "Sobrepasando límites" y "Cuando soy un X64". Éste último le gustó tanto a KC, que registró www.whenimx64.com (en inglés) y lo enlazó a su blog. Si estuviéramos tan motivados para todo en nuestras vidas.
Nota complementaria: Al principio, KC sugirió llamar a esta columna "The Monthly Queue and A" hasta que nuestro editor, acertadamente, señaló que todavía somos una cantidad desconocida y se puede confiar en nuestra capacidad organizativa (él fue más educado y menos directo en su respuesta, pero nosotros sabíamos lo que estaba pensando). Siguiendo en la misma línea, no tenemos ni idea de la reacción que provocaremos en los lectores de esta columna ni si merecerá la pena repetirla. Por lo tanto, decidimos quedarnos en un punto intermedio con el nombre y usted sólo tendrá que decirnos qué piensa en queuea@microsoft.com.
Y ahora, sin más preámbulos, pasemos a las preguntas...

Q ¿Por qué debería estar entusiasmado con respecto a Exchange Server 2007?
A Sabemos que es arriesgado comenzar la primera columna con lo que es esencialmente una pregunta de marketing, pero estamos tan entusiasmados con Exchange Server 2007, que queremos compartirlo con usted. Así que intentaremos limitar la "marqui-tectura" en esta respuesta y hablar de algunas de las muchas razones técnicas por las que un administrador o usuario de Exchange debería estar entusiasmado ante la idea de utilizar Exchange 2007, de geek a geek.

Mejoras en la escalabilidad y el rendimiento
Lo obvio es lo primero: 64 bits. ¿Cuál es el problema?, se preguntará Veamos, Windows® de 32 bits sólo puede admitir un total de 4 GB (232 bytes) de memoria y el núcleo ocupa 2 GB, dejando sólo 2 GB para aplicaciones. La versión actual de Windows admite un conmutador de /3GB en boot.ini que da a las aplicaciones hasta 3 GB de espacio en cabeza, pero una vez que lo ha utilizado, el núcleo de Windows se incomoda un poco y no pasará mucho tiempo antes de que tenga que reiniciar el servidor para reclamar los recursos.
Afortunadamente, la compatibilidad con 64 bits, junto con cambios significativos realizados en el motor de base de datos (JET) en Exchange, soluciona este problema. Debido a que los servidores Exchange están mucho más enlazadas por la E/S del disco que por otros recursos del sistema (como CPU), agregar memoria al sistema significa que puede reducir notablemente la E/S del disco manteniendo más información en la memoria en lugar de tener que leer el disco. Como resultado, con Exchange 2007 puede admitir muchos más buzones para sus usuarios en hardware físico equipado de forma similar que con Exchange 2003. El servidor de correo en el que estoy en Microsoft, por ejemplo, admite 4.000 usuarios con 2 GB de cuotas de buzón, lo que se traduce en 6 terabytes (TB) de datos. Para no andar con rodeos, el que Exchange 2007 pueda aprovechar más memoria no significa que necesite esa cantidad de memoria: hemos probado un buzón que ejecute Windows Server® 2003 de 32 bits y Exchange 2003 con 4 GB o menos de memoria, hemos instalado Windows Server 2003 y Exchange 2007 y hemos observado un rendimiento similar.
Exchange 2007 también incluye dos formas nuevas de mejorar la disponibilidad: Duplicación continua de clúster (CCR) y duplicación continua regional (LCR). Estas tecnologías reducen el riesgo de error en el almacenamiento, que puede causar problemas graves. La LCR conserva una copia local de sus bases de datos en el mismo equipo, pero puede colocarlas en otros medios de almacenamiento. La CCR puede hacer lo mismo entre dos equipos a través de una red. La CCR, combinada con las mejoras de la E/S de disco a las que hicimos alusión anteriormente en esta columna, abre nuevas opciones de hardware de almacenamiento; si le gustaría utilizar medios de almacenamiento conectados directos, como unidades SATA o SCSI, ahora es una opción mucho más rentable y mejor para el rendimiento.

Administración
Microsoft invirtió un gran esfuerzo en una experiencia administrativa en Exchange 2007, lo que incluye la interfaz de la línea de comandos que se muestra en la figura 1. Se llama Shell de administración de Exchange (EMS) y se basa en Windows PowerShell™. Si no le gusta demasiado la línea de comandos, no pasa nada: todavía le queda la GUI, sólo que ahora se llama Consola de administración de Exchange (EMC) y es una interfaz mucho más intuitiva que el antiguo Administrador del sistema (consulte la figura 2). Si ya es un defensor de las interfaces de línea de comandos o desea serlo, consulte el EMS en Exchange 2007.
Figura 1 Estado del grupo de almacenamiento en Shell de administración de Exchange.
Figura 1 Estado del grupo de almacenamiento en Shell de administración de Exchange. (Hacer clic en la imagen para reducirla)
Figura 1 Estado del grupo de almacenamiento en Shell de administración de Exchange.
Figura 1 Estado del grupo de almacenamiento en Shell de administración de Exchange. (Hacer clic en la imagen para ampliarla)
Figura 2 El mismo estado en la Consola de administración de Exchange
Figura 2 El mismo estado en la Consola de administración de Exchange (Hacer clic en la imagen para reducirla)
Figura 2 El mismo estado en la Consola de administración de Exchange
Figura 2 El mismo estado en la Consola de administración de Exchange (Hacer clic en la imagen para ampliarla)
Es posible que haya tenido que utilizar scripts del Instrumental de administración de Windows (WMI) en Exchange 2003 para realizar algunas de las tareas administrativas más complejas, pero con EMS cualquiera que vea "CD C:\TEMP" y no piense que es el disco de una nueva banda puede realizar estas tareas. Aunque uno de nosotros es un antiguo administrador del sistema de UNIX y, por lo tanto, nuestra objetividad puede verse cuestionada, podemos indicarle terceras personas que no están influenciadas y que darán fe de que el shell es increíblemente intuitivo incluso si no ha utilizado nunca antes una línea de comandos (más información en la siguiente columna Exchange Queue & A).
Uno de los atractivos de Windows PowerShell es que está orientado al objeto. Cuando recupera información del servidor, como una lista de buzones o de conectores SMTP, la información se almacena automáticamente en un objeto o una variable y se transfiere a stdout como texto para una lectura fácil. A continuación, dicho objeto se puede pasar directamente a otro comando y se puede utilizar en la canalización (en cuyo caso, ésta pasa por el objeto en vez de por el texto, facilitando así la modificación de datos o la utilización de las partes del mismo). He aquí un ejemplo simple:
Get-Mailbox | Set-Mailbox -ProhibitSendQuota 250MB
El comando Get-Mailbox recupera una lista de buzones en el sistema. El | (denominado el símbolo de la canalización) indica que la salida del comando situado a la izquierda se debería pasar al comando situado a la derecha. La siguiente parte, "Set-Mailbox-ProhibitSendQuota 250MB", significa que todos esos buzones tienen ahora tal cuota que ya no pueden enviar correos electrónicos tras alcanzar los 250 MB de tamaño. También podría haberlo establecido en 250000000, 250000 KB o .25 GB: el shell es muy flexible en cuanto al procesamiento de datos.
Otra mejora administrativa útil en Exchange 2007 es la capacidad de crear reglas de transporte mediante un asistente para reglas muy parecido al de Outlook para aplicar lógica empresarial a los mensajes que fluyen en el sistema. ¿Desea bloquear cualquier correo electrónico que parezca contener números de la seguridad social en el cuerpo basado en una expresión regular? Activar. ¿Desea configurar una limitación ética para que dos divisiones de su organización no puedan enviarse correos electrónicos entre sí? Activar. ¿Desea agregar una renuncia a todos los correos electrónicos que salgan de su organización? Activar.
Una de las últimas características administrativas que nos encanta es la de mensajes de sistema personalizables: fuera del buzón, ahora puede agregar su propio texto personalizado a informes de no entrega y, además, los usuarios de mensajes ven (por fin) cuándo han sobrepasado sus cuotas de almacenamiento.

Ayuda al servicio de asistencia
Uno de los mayores gastos para muchos clientes son los derivados del servicio de asistencia en relación a la configuración de nuevos perfiles en Outlook. Con la detección automática en Outlook 2007, inicie Outlook y éste buscará automáticamente su dirección de correo electrónico y recuperará la información del servidor Exchange desde Active Directory® mediante el punto de conexión de servicio. Si está conectado a Active Directory, introduzca su dirección de correo electrónico y contraseña y la búsqueda de la detección automática podrá descargar un archivo XML de un servidor web especializado (como http://autodiscover.contoso.com (en inglés)) que tenga información de configuración básica, como el servidor que se debe utilizar para RPC a través de HTTP (llamado ahora Outlook Anywhere).
Otros costos derivados del servicio de asistencia son los aparentemente inevitables falsos positivos procedentes del filtro de correo electrónico no deseado. Los usuarios pueden mantener listas seguras en Outlook de remitentes cuyos mensajes no deberían estar sujetos al filtrado de contenido, pero hasta Exchange 2007 estas listas sólo permitían a los mensajes omitir el filtro de Outlook. Sin embargo, debido a que el filtro de Exchange actúa en los mensajes antes incluso de que Outlook los vea, los usuarios podrían seguir perdiendo correo de personas en las que confían.
Exchange 2007 también es útil en este caso: si utiliza el filtro de contenido de correo electrónico no deseado con la función del servidor Transporte de concentradores o Transporte perimetral en Exchange 2007, puede también configurarlo para propagar listas de remitente seguro de los usuarios al servidor, de manera que los mensajes de tales remitentes omitan el filtro de contenido de correo electrónico no deseado. Por supuesto, lo que para un usuario es correo no deseado, para otro es un boletín o similares, por lo que la agregación de remitentes seguros tiene lugar usuario por usuario.

La alegría de los usuarios finales
Con Mensajería unificada (MU) en Exchange 2007, puede recuperar faxes y correo de voz en su bandeja de entrada. Si nunca ha tenido esta opción antes, no sabe lo que se pierde. También puede llamar a su servidor Exchange y decirle que notifique a todos los participantes de su reunión de las 8 a.m. que llegará tarde. Incluso la más pequeña de las organizaciones puede tener fácilmente un operador automático de marca y personalizado para que cuando sus clientes le llamen, el sistema los pueda enrutar en la dirección correcta. Para utilizar MU, necesitará un PBX basado en IP (IP/PBX) o puede enlazar el PBX basado en el interruptor de circuito a una puerta de enlace voz sobre IP (VoIP).
Link Access es una nueva característica en OWA 2007. ¿Qué pasa si está viajando sin tener un cliente de VPN instalado y necesita ver un documento de Microsoft Word en un recurso compartido de archivos o en un sitio SharePoint® en la red corporativa? No hay problema: cargue OWA 2007, vaya al vínculo Documentos y escriba el nombre del recurso compartido o del sitio SharePoint (http://mysharepointsite o \\server\share) para examinar y abrir los archivos. Por supuesto, existen muchos controles de seguridad para que los administradores bloqueen esto a su gusto: todos los servidores permitidos excepto una lista concreta, todos los servidores denegados excepto una lista concreta, permitir acceso a los documentos sólo si los usuarios inician sesión en OWA desde equipos privados, etc.
OWA también incluye Presentación de documentos WebReady (lo que entre geeks llamamos "transformación"), donde puede decir a Exchange que represente ciertos tipos de archivos en HTML si no tiene la aplicación adecuada instalada de forma local. Exchange 2007 tendrá compatibilidad para transformar los siguientes tipos de archivos de forma predeterminada: DOC, DOT, RTF, WBK, WIZ, XLS, XLK, PPT, PPS, POT, PWS y PDF. El motor de transformación posee una arquitectura conectable para que podamos agregar compatibilidad con nuevos tipos de archivos en un service pack. También existen opciones administrativas para que pueda determinar qué tipos de archivos se permite transformar a los usuarios o para no autorizar en absoluto la transformación.
Si tiene dispositivos móviles que se sincronizan con Exchange mediante Exchange ActiveSync®, se alegrará al saber que cuando conteste o reenvíe una conversación de correo electrónico, el mensaje ya no se convertirá a texto sin formato. Su texto se agrega al principio pero el cuerpo del HTML del resto del mensaje se mantiene igual. Esto funciona en cualquier dispositivo que sea compatible con ActiveSync, no requiere función en el cliente.

Q He oído que Exchange 2007 es "de 64 bits sólo para fines productivos". ¿Qué significa eso?
A Exchange 2007 está disponible tanto en la opción de 32 bits como en la de 64 bits. La versión de 64 bits está destinada al uso "activo" de producción de las funciones de servidor principales (Buzón de correo, Transporte de concentradores, Transporte perimetral, Acceso de cliente y Mensajería unificada). La versión de 32 bits está destinada a la evaluación de las nuevas características de Exchange 2007. Las herramientas de administración también se pueden utilizar en 32 bits en producción, para que pueda administrar los servidores de producción de Exchange 2007 de 64 bits desde el equipo de escritorio de Windows XP de 32 bits. Observe también que el esquema de Exchange 2007 se debe instalar en el dominio raíz: no es necesario que Exchange esté instalado en el dominio raíz, pero necesitamos que la ampliación del esquema tenga lugar en el dominio raíz como forma de asegurar una buena conectividad de la red al maestro de esquema. Si no tiene un servidor de 64 bits en dicho dominio, puede utilizar setup.exe en la versión de 32 bits para ampliar el esquema.
¿Cuál es el problema de los servidores de 32 bits?, le oigo preguntar. Si ha tenido el placer de contar con miles de usuarios en un solo servidor, sabrá que esto se puede convertir en un acto de equilibrio continuo entre rendimiento y estabilidad con las limitaciones de memoria que describimos anteriormente. Si ha comprado un equipo nuevo en los últimos dos años, lo más probable es que ya sea compatible con ampliaciones de x64. De hecho, es muy difícil comprar un equipo nuevo que no admita el modo de 64 bits hoy en día. Por lo tanto, es posible que el equipo que ya ejecuta Exchange en su entorno esté preparado para 64 bits; lo que pasa es que está ejecutando un sistema operativo de 32 bits. Lo cual nos lleva a lo siguiente: una vez que tiene su nuevo equipo preparado para 64 bits, recuerde instalar la versión de 64 bits de Windows Server 2003 SP1.
Entonces ¿por qué ve todos esos avisos en la instalación acerca de la no utilización de instalaciones de 32 bits en producción? Aunque es muy fácil compilar Exchange en varias opciones, cada componente está 100 por cien optimizado y ajustado para 64 bits. En realidad, algunas rutas de código que hemos elegido para conseguir mejoras en E/S del disco en sistemas de 64 bits repercuten negativamente en el rendimiento en entornos de 32 bits. De hecho, cuando esté haciendo comprobaciones con 32 bits, no crea que va a conseguir que funcione bajo carga (simulada o no); no conseguirá tener una idea real de cuál será su rendimiento en un sistema de 64 bits o cuántos usuarios puede ajustar en el servidor.
¿Está todo claro? Puede utilizar la versión de 32 bits de Exchange 2007 para:
  • Evaluar las nuevas características en un servidor de prueba sin ningún buzón de usuario activo en el mismo.
  • Babear con la nueva consola administrativa, el shell o la interfaz de OWA (cuidado con babear encima del teclado).
  • Administrar sus servidores Exchange 2007.
  • Ampliar el esquema en su bosque de Active Directory.
Una vez que esté preparado para mover buzones, necesitará que los servidores esté ejecutando un sistema operativo de 64 bits con Exchange 2007 de 64 bits. Si no es así, verá mensajes de ExBPA y de instalación quejándose sin parar (consulte la figura 3). Paul sabe esto por el hecho de que ¡él escribió el código!
Figura 3 Instalación de 32 bits donde sólo se debería instalar 64 bits
Figura 3 Instalación de 32 bits donde sólo se debería instalar 64 bits (Hacer clic en la imagen para reducirla)
Figura 3 Instalación de 32 bits donde sólo se debería instalar 64 bits
Figura 3 Instalación de 32 bits donde sólo se debería instalar 64 bits (Hacer clic en la imagen para ampliarla)

Q ¿Cuánta memoria necesito para ejecutar Exchange 2007?
A Su instalación base necesita al menos 1 GB de memoria RAM física. Como mencioné anteriormente, algunas funciones de servidor están en la parte pesada. Si intenta instalar un servidor integral (como Buzón de correo, Acceso de cliente, Transporte de concentradores, Transporte perimetral y Mensajería unificada), probablemente deseará comenzar con 2 GB de memoria RAM y escalarlo basado en el número y uso de buzones. Si intenta instalar la función del servidor de Transporte perimetral o un clúster, éstos se deben instalar en equipos diferentes. Un clúster sólo puede tener la función del servidor Buzón de correo instalada y nada más.
Le alegrará oír que por fin puede instalar más de 4 GB de memoria RAM en su servidor Exchange. Muchos equipos actuales son estándar con 6 o 8 GB y siempre es una pena extraer esos módulos DDR o utilizar /BurnMemory para disminuir la memoria RAM a 4 GB. Desafortunadamente, Exchange 2003 tendrá un peor rendimiento y será menos estable si tiene más de 4 GB: visite go.microsoft.com/fwlink/?LinkId=76537 (en inglés) para obtener detalles.
En cuanto a sus servidores de infraestructura, (concentradores, acceso a clientes, etc) le irá bien con menos de 4 GB de memoria RAM, incluso con las cargas más intensas. Donde desea gastar su dinero es en los servidores de buzón de correo. Esa caché JET de 64 bits optimizada querrá hacer uso de toda la memoria que pueda proporcionarle. Por supuesto, a diferencia de Exchange 2003, Exchange 2007 admite hasta 50 grupos de almacenamiento.
Aunque cada grupo de almacenamiento admite varias bases de datos, esto no le ahorrará nada, sobre todo porque LCR y CCR (las dos formas de réplica de base de datos que mencionamos anteriormente) sólo pueden funcionar con grupos de almacenamiento que tienen una sola base de datos. Seguramente tendrá que potenciar la memoria RAM adicional si tiene la intención de crear un conjunto de grupos de almacenamiento o hacer realidad el sueño de buzones de 2 GB+ para cada usuario. Encontrará información adicional sobre el tamaño de la memoria RAM en el blog del equipo Exchange (en inglés), pero en las figuras 4 y 5 se proporciona algunas notas para que pueda comenzar.
Figure 5 Memoria RAM y grupos de almacenamiento (Close Figure 5)

Memoria RAM física | Máximo recomendado de grupos de almacenamiento
2 GB | 2
4 GB | 8
8 GB | 24
12 GB | 40
16 GB+ | 50
Figure 4 Memoria RAM por tipo de usuario (Close Figure 4)

Tipo de usuario | Recomendaciones de memoria de función Buzón de correo
Ligero | 2 GB de base + 2 MB por buzón
Promedio | 2 GB de base + 3,5 MB por buzón
Intenso | 2 GB de base + 5 MB por buzón
De todas formas, los usuarios de Microsoft IT utiliza un número de grupos de almacenamiento que es un múltiple de siete, porque poseen una programación de copia de seguridad rotativa mediante cualquier día dado, sólo algunos grupos de almacenamiento obtienen copia de seguridad. Llamamos a esta programación "copias de bastón de caramelo" por la hoja de cálculo de Excel que describe la programación de seguridad, donde los grupos de almacenamiento que obtienen copia de seguridad en cualquier día dado se muestran destacados en rojo en forma de cascada. Esperamos que todo esto le haya sido útil. Envíe preguntas "reales" para el siguiente problema.

KC Lemsones directora de administración de programas en el equipo de Exchange Server. Emplea su tiempo libre en ayudar a salvaguardar el dinero de la realeza nigeriana.
Paul Bowdenes director de administración de programas en el equipo de Exchange Server. Emplea su tiempo libre en ayudar a salvaguardar el dinero de la realeza nigeriana. Paul Bowden también es director de administración de programas en el equipo de Exchange Server. Emplea mucho de su tiempo libre confirmando la información de su cuenta PayPal mediante solicitud previa.


 Vigilancia de seguridad: Services Hardening en Windows&#160;Vista
Vigilancia de seguridad
Services Hardening en Windows Vista
Wole Moses

Microsoft anunció la iniciativa de Trustworthy Computing a principios de 2002, tras la aparición de varios virus y gusanos con perfil alto que causaron estragos en los sistemas de Windows, paralizaron departamentos de TI y los empresarios y consumidores debieron invertir grandes cantidades en la solución del problema. En esta iniciativa, Microsoft entonó un
mea culpa con respecto al registro del control de seguridad y realizó un cambio de rumbo instantáneo y un cambio de paradigma del software en desarrollo con especial énfasis en las características integrales y en la facilidad de uso para dar prioridad a la seguridad e integridad del software. En agosto de 2003 apareció el gusano Blaster, lo que reforzó el entusiasmo de esta iniciativa de seguridad. Si desea conocer la historia de Blaster, consulte en la barra lateral "El ataque de los clones".
Los principios de la iniciativa de informática confiable son seguridad en el diseño, que trata de las filosofías de codificación segura; seguridad predeterminada, que pretende garantizar que los componentes de Windows® presenten unos valores predeterminados que ofrezcan la mayor seguridad posible; y seguridad en la implementación, que se relaciona con la creación de herramientas y orientación prescriptiva para ayudar a empresarios y consumidores en asegurar la infraestructura de Windows.
En términos generales, la iniciativa de Trustworthy Computing implementó mejoras en la seguridad; desafortunadamente, Windows XP no pudo aprovechar todas las ventajas porque se comercializó dos años antes de que se emprendiera la iniciativa. Aunque Service Pack 2, SP2, hizo grandes esfuerzos para incorporar dichas filosofías, no se pudieron hacer todos los ajustes de dicha iniciativa en Windows XP.
Por lo tanto, Windows Vista™ es el primer sistema operativo de escritorio de Microsoft que cumple con todos los objetivos de Trustworthy Computing. Services Hardening de Windows Vista, una implementación específica del principio de seguridad predeterminada de Trustworthy Computing (consulte la figura 1), es una importante capacidad nueva diseñada para frustrar comportamientos de servicio inadecuados que puede provocar gran parte del malware actual. Service Hardening ayuda a que Microsoft realice grandes avances en el cambio del comportamiento predeterminado y el perfil de seguridad de los servicios de Windows.
Figure 1 Seguridad predeterminada: Servicios de Windows (Close Figure 1)

Característica | Descripción | Resultado
Privilegio mínimo | Los servicios de Windows Vista están configurados para usar el número mínimo de privilegios necesarios para funcionar. | Windows Vista reduce los privilegios de seguridad predeterminados disponibles para los servicios de Windows, lo que reduce las consecuencias posibles del malware.
Aislamiento del servicio | Los SID de servicio se utilizan para permitir que los servicios se ejecuten en cuentas con pocos privilegios. | Windows Vista puede derrotar al malware mediante la restricción de acceso a sus recursos a partir de los SID de servicio.
Acceso restringido de red | Las restricciones de red se implementan de forma individual para todos los servicios de Windows Vista. | Windows Vista impide que el malware use servicios para realizar actividades de red malintencionadas.
Aislamiento de la sesión 0 | La sesión 0 se reserva para los servicios. | Windows Vista evita que las aplicaciones malintencionadas invadan los servicios con privilegios elevados mediante ataques basados en mensajes porque éstos no se ejecutan en la misma sesión.

Servicios de riesgo
Los servicios de Windows, anteriormente conocidos como servicios NT, son aplicaciones de larga ejecución que se ejecutan en sesiones propias de Windows. Los servicios se pueden iniciar automáticamente al iniciar el equipo, se pueden pausar y reiniciar, no muestran normalmente ninguna interfaz y se pueden ejecutar en el contexto de seguridad de cuentas distintas de la cuenta de inicio de sesión del usuario o de la predeterminada del equipo. Por lo tanto, los servicios de Windows presentan una gran ventaja para determinados tipos de desarrollo de aplicaciones y para los usuarios finales que necesiten usar dichas aplicaciones. Sin embargo, dada su eficacia y flexibilidad, los servicios de Windows han sido tradicionalmente vulnerables a los ataques por diversas razones.
En primer lugar, anteriormente los servicios de Windows se solían ejecutar en cuentas de Windows con muchos privilegios, como la cuenta del sistema local. Si un malware determinado pone en peligro un servicio que se ejecuta en la cuenta del sistema local, dicho malware tiene una excelente oportunidad para realizar todo lo que desee en ese sistema. Imagine, por ejemplo, el servicio de llamada a procedimiento remoto (RPC) en Windows XP. Antes de Windows XP SP2, el servicio de RPC se ejecutaba en la cuenta del sistema local, que es lo que permitía que Blaster, Welchia y otros gusanos realizaran tareas administrativas una vez que se aprovechaba la vulnerabilidad de RPC.
En segundo lugar, muchos servicios se realizan orientados a Internet, lo que ofrece al malware la posibilidad de atacar mediante la creación de conexiones entrantes con dichos servicios a través de la red y permite que un servicio infectado realice una conexión de salida para infectar a otros sistemas o realizar alguna otra actividad ilícita, como el reenvío de supervisión de pulsación de teclas. La mayoría de los gusanos e infecciones de malware actuales se producen mediante algún método basado en conexiones de red.
Por último, los servicios son normalmente de larga ejecución, lo que significa que se ejecutan desde que arranca un sistema hasta que se cierra. Esto les encanta a los autores de malware porque significa que pueden buscar los defectos de un servicio durante todo el tiempo que el sistema está activado, de modo que el malware dispone de todo el tiempo necesario para realizar sus actividades malintencionadas.

El ataque de los clones
Fue su gran victoria. Si todo se dispusiera conforme a un plan, podría controlar en poco tiempo miles de sistemas de Windows en todo el mundo, enviarles virtualmente cualquier instrucción y, a continuación, relajarse y ver cómo cumplen obedientemente sus órdenes.
Mediante métodos insistentes y esquivos, empezó investigando clandestinamente varios sistemas en busca de un punto débil para introducirse. No tardó mucho en encontrar lo que buscaba, un sistema sin parches con una vulnerabilidad conocida que supiera exactamente cómo atacar.
Esta vulnerabilidad era especialmente funesta porque al atacarla mediante los métodos adecuados se podía obtener acceso total como administrador del sistema. El objetivo no era controlar cualquier cuenta: estaba manipulando la cuenta administrativa más robusta de Windows. Sólo la imaginación podía poner límites a las acciones posteriores.
Tras un momento de reflexión, probó la eficacia de su código malintencionado en el equipo vulnerable y sin parches: ¡funcionó! Así de sencillo, ya tenía privilegios ilimitados en el equipo. Se valió de este acceso administrativo para obligar al equipo a descargar e instalar el código del troyano, a realizar modificaciones en el Registro y, a continuación, a realizar el reinicio, lo que convirtió el sistema infectado en un subordinado preparado y dispuesto a ejecutar todos los comandos. La modificación del Registro provocó que el software malintencionado se ejecutara siempre que el equipo se reiniciaba.
Ahora sus intenciones se veían claramente. Después de la infección, todos los equipos contaminados sondearon puertos de red concretos del resto de equipos de la red. Si un puerto de red concreto estaba abierto y el equipo era vulnerable, se descargaba e instalaba el código del troyano en este equipo nuevo. Se implementaban las mismas modificaciones en el Registro. El ciclo se repetía por recursividad y, de este modo, se había creado un ejército creciente de clones de ataque. Al final del día, miles de sistemas de Windows de todo el mundo formaban parte de este siniestro ejército de clones, indiferentes a los comandos ejecutados por cualquier otra persona de la Tierra.
Por si eso fuera poco, a continuación, puso su punto de mira en el sitio de Microsoft Windows Update y ordenó a todos los clones realizar un ataque por denegación de servicio el 15 de agosto de 2003 en un intento por evitar que algún equipo de alguna parte del mundo se descargara la corrección para la vulnerabilidad que, curiosamente, había estado disponible durante meses.
Probablemente, se haya dado ya cuenta de que acabo de describir la pandemia del gusano MS Blaster que, en agosto de 2003, atacó los equipos de Windows desde todos los rincones del mundo. Blaster fue posiblemente uno de los ataques más graves lanzados sobre Windows y provocó daños valorados en miles de millones de dólares. La ironía es que, aunque MS Blaster tenía una gran influencia sobre los equipos infectados, presentaba una implementación sorprendentemente sencilla.

Funcionamiento de Blaster
Blaster y sus derivados se valen de una vulnerabilidad del servicio de RPC de Windows para ejecutar un desbordamiento del búfer. Un atacante que aproveche esta vulnerabilidad con éxito podrá ejecutar código con privilegios del sistema local en un sistema afectado, lo que le permite realizar cualquier acción en este sistema: instalar programas, ver, cambiar o eliminar datos y crear cuentas nuevas con todos los privilegios.
En el caso de Blaster, el gusano explora automáticamente redes en busca de equipos con el puerto TCP 135 abierto. Cuando encuentra una víctima, Blaster intenta aprovechar la vulnerabilidad de RPC. Si tiene éxito, se conecta al puerto 4444 del equipo de destino y ordena a la víctima iniciar el protocolo trivial de transferencia de archivos (tfpt) y descargar una copia del gusano, denominado MSBLAST.EXE, desde el sistema infectado. Windows 2000, Windows XP y Windows Server 2003 incluyen tftp en el sistema operativo. A continuación, el sistema atacante ordena al equipo recién infectado que inicie MSBLAST.EXE y la víctima se convierte en un nuevo atacante. Blaster también escribe código en la clave de ejecución del Registro ubicada en HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft \Windows\CurrentVersion\Run Registry, lo que le permite ejecutarse siempre que el equipo se inicie.

Services Hardening
Son servicios que se han reforzado y asegurado mediante sistemas de protección en Windows Vista de cuatro formas: ejecución de servicios con privilegio mínimo, aislamiento del servicio, acceso restringido de red y aislamiento de la sesión 0. Analizaremos detalladamente cada punto.
Ejecución con privilegios mínimos Muchos servicios de Windows se han ejecutado anteriormente en el contexto de la cuenta del sistema local (la cuenta más importante en Windows). La cuenta del sistema local tiene privilegios y derechos de usuario como poder tener acceso a cualquier objeto del sistema o al perfil de otro usuario, suplantar a usuarios, abrir claves de registro confidenciales como HKLM\SECURITY y presentar las credenciales del equipo a los servidores remotos. Puesto que los autores de malware estarían encantados de tener este nivel de acceso y control en Windows, cualquier servicio que se ejecute en el contexto de seguridad del sistema local se convertirá en un objetivo jugoso.
Resulta que aunque se hayan configurado varios servicios de Windows para su ejecución en la cuenta del sistema local, muchos de ellos sólo necesitan un subconjunto pequeño de los privilegios de pertenencia exclusiva a la cuenta del sistema local. Desafortunadamente, Windows XP y las versiones anteriores de Windows funcionan según el sistema "todo o nada", es decir, no ofrecen mecanismos para seleccionar los privilegios necesarios. Por lo tanto, es inevitable que muchos servicios de Windows se acaben ejecutando innecesariamente con un exceso de privilegios de seguridad.
Service Hardening de Windows Vista soluciona este problema mediante el concepto de privilegios mínimos en la configuración de servicios. Este concepto permite que los servicios se ejecuten con el menor número de privilegios necesarios para su funcionamiento, en lugar de forzar la ejecución con todos los privilegios predeterminados asignados a la cuenta usada para iniciar sesión.
Por ejemplo, puede que un servicio deba actuar como parte de un sistema operativo, pero no deba crear un token de seguridad. Con privilegios mínimos, puede quitar el privilegio de crear tokens. Por consiguiente, se reducen los daños que un atacante puede ocasionar en caso de que dicho servicio se hiciera vulnerable a un ataque. Los desarrolladores pueden usar herramientas de línea de comandos como SC.exe (consulte la figura 2) o usar métodos de programación para definir y especificar los privilegios que necesita un servicio determinado. Microsoft ha aplicado de serie el concepto de privilegios mínimos para reducir los privilegios predeterminados en todos los servicios preinstalados de Windows Vista.
Figura 2 Definición de privilegios de servicios de Windows Vista mediante opciones de comando SC
Figura 2 Definición de privilegios de servicios de Windows Vista mediante opciones de comando SC (Hacer clic en la imagen para reducirla)
Figura 2 Definición de privilegios de servicios de Windows Vista mediante opciones de comando SC
Figura 2 Definición de privilegios de servicios de Windows Vista mediante opciones de comando SC (Hacer clic en la imagen para ampliarla)
Aislamiento del servicio En las versiones de Windows anteriores a Windows Vista, cuando un servicio necesita tener acceso a un objeto con privilegios (como un archivo o una clave de registro confidencial), los servicios obtienen el acceso mediante uno de estos tres métodos: usar la cuenta del sistema local para tener acceso al objeto; reducir el nivel de seguridad en la clave o archivo del Registro para habilitar una cuenta de servicio con menos privilegios para obtener acceso; o bien crear una cuenta específica para el servicio y permitir que sólo esa cuenta tenga acceso a los objetos.
Aunque todos estos planteamientos funcionan, existe un problema elemental en cada uno. Los dos primeros implican riesgos inherentes y el tercero introduce la complicación de administrar manualmente las contraseñas en las cuentas nuevas.
Imagine, por ejemplo, que un programa antivirus instala un servicio que necesita acceso a varios objetos confidenciales del sistema, como el archivo con la firma del virus y las entradas de registro pertenecientes al software antivirus. Si el servicio de antivirus se ha configurado para usar la cuenta del sistema local o, con dicho propósito, cualquiera de las otras cuentas de seguridad integradas para obtener acceso a los objetos, esto significaría que si un malware infecta otro servicio de Windows que use esa cuenta, dicho malware podría tener acceso y modificar los archivos de firmas de antivirus, alterar la configuración del registro relacionado con el modo de funcionamiento del software de antivirus o simplemente desactivar el servicio de antivirus por completo. De hecho, el malware actual usa exactamente algunas de dichas técnicas para mantenerse oculto y activo.
Windows Vista resuelve estos asuntos de seguridad y facilidad de uso mediante el aislamiento del servicio, que permite a un servicio reservar un objeto para su uso exclusivo protegiendo el recurso (como el acceso a un archivo o clave de registro) mediante una entrada de control de acceso que contenga un Id. de seguridad (SID) de servicio. De este modo, el servicio de antivirus descrito en el ejemplo se puede ejecutar en una cuenta con pocos privilegios, aunque sigue teniendo acceso a archivos de firmas o claves de registro confidenciales. Para habilitar este acceso, el servicio de antivirus (que se ejecuta en esta cuenta con pocos privilegios) debe tener un SID asignado por Windows Vista. Después de la asignación del SID, el programa antivirus podrá modificar las listas de control de acceso (ACL) del sistema de archivos de los objetos de registro para proporcionar acceso exclusivo al servicio de antivirus.
Veamos otro ejemplo. De vuelta a 2003, el gusano Welchia apareció aprovechándose de una vulnerabilidad de RPC para escribirse en %System%\Wins\Dllhost.exe. También agregó claves a HKLM\SYSTEM\CurrentControlSet\Services para instalar sus servicios en el sistema de Windows infectado. Sin embargo, hoy en día Windows Vista puede combatir a Welchia mediante la restricción de acceso de ambas ubicaciones a determinados servicios y mediante el uso de cuentas con pocos privilegios para garantizar el acceso de esos servicios.
Acceso restringido de red Windows Vista incluye un firewall nuevo creado a partir de las capacidades incluidas en el firewall de Windows XP SP2. Entre las nuevas capacidades importantes se incluyen el filtrado de salida y la integración de IPsec. El firewall nuevo también se integra con Services Hardening de Windows Vista para dificultar la ejecución de malware en un servicio vulnerable de Windows para realizar determinadas actividades de red malintencionadas.
En el firewall de Windows Vista, los servicios de Windows son directivas asignadas de firewall de red que imponen limitaciones y restricciones en el comportamiento del servicio. Por ejemplo, se puede asignar a un servicio tipo Plug and Play que posiblemente no necesitará establecer comunicación a través de un puerto de red una restricción "no hay acceso a la red". Con esta restricción asignada, un ataque diseñado para un servicio concreto nunca tendrá acceso al servicio mediante métodos que usen la red. El firewall bloqueará cualquier intento de comunicación del servicio con restricciones, ya sea de entrada o de salida. Se puede restringir el acceso a puertos específicos en la configuración de otros servicios con necesidades justificadas de acceso a una red. Los desarrolladores pueden usar esta capacidad para restringir el acceso a red de los servicios.
Las restricciones de red se combinan con Service Hardening para ofrecer un sistema sólido de defensa contra ataques futuros a través de los servicios, lo que supone una mejora importante con respecto a versiones anteriores de Windows. Anteriormente, Windows no podía decidir cómo y dónde establecer comunicaciones a través de Internet y qué servicios podían hacerlo. Sin embargo, aplicando las restricciones de la red de firewall de Windows Vista al servicio de RPC, podemos impedir que virus como Blaster, Sasser o Welchia infecten servicios para comunicarse con otros equipos.
Aislamiento de la sesión 0 La función Cambio rápido de usuario de Windows XP aloja simultáneamente a los usuarios conectados iniciando una sesión para cada usuario de Windows. La sesión 0 se crea durante el inicio y las sesiones adicionales se crean a medida que sea necesario. Los servicios siempre se han ejecutado en la sesión 0 y, antes de Windows Vista, también se podían ejecutar las aplicaciones de usuario en la sesión 0. Sin embargo, existen riesgos para la seguridad al ejecutar las aplicaciones del usuario en la misma sesión porque los servicios se ejecutan con privilegios elevados y, por lo tanto, son el objetivo del software malintencionado que busca la forma de elevar su nivel de privilegios.
Windows Vista evita estos riesgos de seguridad mediante la reserva de la sesión 0 exclusivamente para los servicios, la ejecución de las aplicaciones en otras sesiones y la eliminación de la interactividad de la sesión 0, lo que significa que un servicio no puede crear una interfaz de usuario, como un cuadro de diálogo o una solicitud a los que el usuario final tenga acceso. Estos cambios provocan que el aislamiento de la sesión 0 afecte a la compatibilidad de la aplicación para quien desarrolle servicios o controladores de Windows.

Resumen
Windows Vista es la primera versión del sistema operativo de escritorio de Trustworthy Computing de Microsoft e incluye avances importantes destinados a la protección de los usuarios de Windows. La seguridad en informática es, evidentemente, una disciplina en evolución y no hay duda de que los autores de malware no cesan de buscar, sondear e investigar nuevas formas de atacar a Windows. Sin embargo, las características nuevas de Service Hardening de Windows Vista sube considerablemente el listón al mejorar la configuración predeterminada de seguridad y reducir el área potencial para un ataque. Consulte microsoft.com/whdc/system/vista/Vista_Services.mspx para obtener más información sobre estas mejoras importantes.

Wole Moses es director regional de Microsoft Windows y experto con ocho años de antigüedad en Microsoft. Establecido actualmente en Estambul (Turquía), Wole trabaja con los clientes del mayor mercado emergente de Oriente Medio y África, les ayuda a prever y diseñar soluciones basadas en Microsoft que optimizan las infraestructuras de TI y aumentan simultáneamente la seguridad.


 Archivos del escritorio: Kit de instalaci&#243;n automatizada de Windows
Archivos del escritorio
Kit de instalación automatizada de Windows
Wes Miller

Microsoft ha ofrecido de forma histórica dos versiones de herramientas de implementación producidas por el equipo de implementación de Windows. La primera versión llegó en la forma del archivo .cab de implementación, que se distribuyó en el CD de Windows durante años. Incluía documentación y herramientas como Administración de instalación para crear archivos de instalación desatendida, así como
la herramienta Sysprep, utilizada para preparar escritorios para la implementación. La otra versión de las herramientas de implementación era el Kit de preinstalación de OEM (OPK), que fue diseñado especialmente para satisfacer las necesidades de los fabricantes del sistema OEM y sólo estaba disponible para los mismos. Este fue el modo original en que se distribuyó Windows® PE. Existe una nueva versión del OPK para Windows Vista™, pero seguirá estando disponible sólo para los OEM.
Afortunadamente para muchos otros clientes de Microsoft, algunos de los cuales no pudieron conseguir Windows PE durante el período de Windows XP, habrá un análogo del OPK disponible para su uso llamado Kit de instalación automatizada de Windows (WAIK). El WAIK se podrá descargar de forma gratuita desde microsoft.com/downloads (en inglés) tras la distribución de Windows Vista e incluirá los siguientes componentes: Windows PE 2.0, Servicios de implementación de Windows, ImageX y Windows System Image Manager: una herramienta que mencioné antes y que permite la creación de archivos unattend.xml para automatizar la instalación. También incluirá documentación completa para todas las herramientas.
Observe que el método recomendado para obtener el WAIK es descargar por completo Business Desktop Deployment Solution Accelerator (BDD) desde microsoft.com/desktopdeployment (en inglés), que no sólo proporciona el WAIK, sino también la Herramienta de migración del estado de usuario (USMT) y el Kit de herramientas de compatibilidad de aplicaciones (ACT). El BDD también incluye herramientas adicionales y ayuda para conseguir una implementación correcta de Windows Vista.

Windows PE 2.0
Profundicé en gran medida en Windows PE 2.0 en el número de noviembre de 2006 de TechNet Magazine (en inglés), así que no entraré en detalles en este número; basta con decir que el WAIK incluirá la versión oficial de la nueva compilación de Windows PE para Windows Vista. Es importante comprender Windows PE, ya que todas las demás herramientas del WAIK utilizan o funcionan con Windows PE de un modo u otro. Puede encontrar mi artículo sobre Windows PE 2.0 aquí (en inglés). .

ImageX
En mi última columna, dediqué bastante tiempo al formato de archivos de imágenes de Windows (WIM). Visite microsoft.com/technet/technetmag/issues/2006/12/desktopfiles. Ahora me centraré en ImageX, que es una pequeña pero eficaz herramienta de línea de comandos que hace posible imágenes integradas de Windows Vista. Al planear ImageX, pensamos crear una herramienta basada en GUI, pero luego decidimos centrarnos en la línea de comandos ya que la automatización del proceso de imágenes era el componente fundamental. Para ver las opciones de la línea de comandos para ImageX, consulte la figura 1.
Figura 1 Herramienta de línea de comandos de ImageX en funcionamiento
Figura 1 Herramienta de línea de comandos de ImageX en funcionamiento (Hacer clic en la imagen para reducirla)
Figura 1 Herramienta de línea de comandos de ImageX en funcionamiento
Figura 1 Herramienta de línea de comandos de ImageX en funcionamiento (Hacer clic en la imagen para ampliarla)
Los servicios de implementación de Windows (WDS), que describiré más adelante, incluyen una herramienta de GUI ligera que permite una sencilla captura de imágenes, pero no incluye la función completa de ImageX. También es importante observar que ImageX ha sido diseñado y probado para capturar imágenes para implementación en Windows PE. No se diseñó para realizar capturas "reales" de los sistemas de Windows que se ejecutan de forma activa.
Si conoce cualquier otra herramienta de imágenes del sistema, ya conoce algo de ImageX. Fue diseñado para que fuera fácil de usar, permitiéndole capturar y aplicar imágenes sin dificultades y aun así proporcionar funciones fundamentales que normalmente faltan o están incompletas en las herramientas de implementación normales que se incluían antes. Un ejemplo de esto, que abordaremos momentáneamente, es la capacidad para montar de forma fácil y transparente una imagen como parte de su sistema de archivos local para poder ver, modificar o eliminar archivos del interior de una imagen existente.
ImageX proporciona los conmutadores de manipulación de imágenes que se muestran en la figura 2. Voy a mencionar un par de comandos específicos para describirlos en profundidad.
Figure 2 Conmutadores de manipulación de imágenes (Close Figure 2)

Conmutador | Descripción
IMAGEX /APPEND | Agrega una imagen de volumen nueva a un archivo WIM que ya contiene una imagen de volumen existente.
IMAGEX /APPLY | Aplica una imagen de volumen a un volumen que se ha dividido y formateado.
IMAGEX /CAPTURE | Captura una imagen de volumen inicial en un archivo WIM.
IMAGEX /DELETE | Elimina de forma permanente las referencias a una imagen de volumen de un archivo WIM. Observe que se eliminan también los metadatos. No elimina los datos de archivos comprimidos, lo cual se puede hacer mediante el conmutador /export para crear un WIM completamente nuevo.
IMAGEX /DIR | Muestra el árbol de directorio de una imagen de volumen especificada en un archivo WIM.
IMAGEX /EXPORT | Exporta una imagen de volumen procedente de un archivo WIM o de varios archivos WIM divididos (SWM).
IMAGEX /INFO | Muestra los detalles de una imagen de volumen o archivo WIM dados: también puede establecer la opción /boot para una imagen de volumen dada que contenga Windows PE. Sólo Windows PE se puede iniciar desde un archivo WIM.
IMAGEX /SPLIT | Divide un archivo WIM en uno o más archivos SWM más pequeños para que pueda estar contenido en varios CD o DVD.
El comando de captura debería ser relativamente claro: lo más importante que debe recordar es que sólo lo utiliza una vez por WIM. Debido a que el archivo WIM sólo es una captura de archivo, puede capturar un volumen completo (C:) o incluso sólo un directorio (C:\Test). Con la aplicación pasa lo mismo: puede aplicar una imagen a un directorio (incluso si capturó un volumen completo) o, lo que es más frecuente, la raíz de un volumen. Una vez que ya existe una imagen de volumen en un WIM, se utilizaría el comando de agregación para agregarlo al mismo. El comando de aplicación tampoco requiere mucha explicación y sólo se complica cuando está aplicando varios archivos WIM. El comando de eliminación es útil si desea eliminar la referencia a una imagen de volumen específica: pero para eliminar por completo los datos de la imagen, debe utilizar el comando de exportación para crear un WIM nuevo completamente libre de datos, lo que significa que si desea reducir el tamaño de la imagen eliminando los datos restantes, debe utilizar el comando de exportación. Piense en el comando de exportación como una herramienta que puede actuar como desfragmentador o consolidador, permitiéndole intercalar una imagen de volumen en uno o más archivos WIM o exportarla a su propio archivo WIM completamente independiente. ImageX también proporciona los siguientes conmutadores de edición: IMAGEX /MOUNT, IMAGEX /MOUNTRW y IMAGEX /UNMOUNT.
Como se ha mencionado anteriormente, el equipo de producto incorporaba capacidades de edición en las herramientas y formato de imágenes desde el principio. Al habilitar la edición, el formato y herramientas permiten a los clientes copiar archivos dentro y fuera, aplicar service packs, agregar/eliminar archivos o aplicaciones independientes o agregar/eliminar otros datos de la imagen según sea necesario, incluso al montar y modificar el registro. El servicio de imagen siempre ha sido un punto importante.
Puede pensar en montar la imagen a medida que carga el archivo WIM como directorio virtual. Si está familiarizado con los mismos, probablemente el propio analógico es más parecido a un punto de montaje del volumen, que le permite montar un volumen entero en un directorio que existe en otro volumen, haciendo que F: sea visible como C:\DriveF, por ejemplo. De forma similar, es posible que haya utilizado la herramienta Microsoft® Virtual CD u otras herramientas de montaje de ISO que le permiten montar imágenes ISO (CD) como unidades locales. Del mismo modo, ImageX le permite montar un archivo WIM como superposición sobre un directorio. Cree un directorio y utilice el comando de montaje para superponer la imagen de volumen especificada sobre el directorio, como si lo hubiera aplicado ahí.
A diferencia de la herramienta Virtual CD, sin embargo, puede montar una imagen WIM incluso si está ubicada en un recurso compartido de red o si está en un medio extraíble. Por supuesto, hacer esto puede limitar su capacidad de edición: un WIM en un medio óptico (CD o DVD) será editable generalmente en modo de sólo lectura. También puede editar sólo una imagen de volumen en un WIM cada vez si está editando en modo de escritura y lectura: esto se hace para permitir un bloqueo correcto y una actualización segura del archivo cuando está desmontado.
Puede montar la imagen en sólo lectura (/mount) o en lectura y escritura (/mountrw). Cuando utilice lectura y escritura, cualquier modificación que realice en la imagen se almacenará temporalmente en la memoria caché (no tienen efecto de forma inmediata) y cuando ejecute el comando /unmount con la opción /commit, estos cambios se guardarán de forma permanente en el WIM. Si hizo cambios y decidió que en realidad no quería guardarlos, también podría descartarlos en lugar de confirmarlos cuando desmonte la imagen. Esto es todo o nada: todas las escrituras realizadas durante el tiempo en que se monta el archivo WIM se confirman o se descartan.
Es importante tener en cuenta la siguiente observación. Al igual que con el comando de eliminación, cuando utiliza la función lectura y escritura para editar el WIM, los datos de archivos del archivo WIM no se han borrado o limpiado completamente: los archivos se han agregado al final del archivo WIM y la referencia anterior en la imagen de volumen es suplantada por los datos actualizados. Esto significa que si agregó un nuevo archivo de 5 MB, que reemplazaba otro archivo del mismo tamaño, su imagen crecerá en el tamaño del archivo de 5 MB después de que se haya comprimido, es decir, 5 MB o menos en función del tipo de compresión utilizada. Para eliminar los datos antiguos del WIM, si deseara reducir la imagen, debería utilizar /export para exportar la imagen de volumen en un archivo WIM completamente nuevo.
Si leyó mi artículo de Windows PE 2.0 en el número de noviembre de 2006 de TechNet Magazine (en inglés), recordará que es compatible con el inicio desde un WIM. Para esto, el archivo WIM se lee utilizando un controlador, similar a la forma en lo hace ImageX. Pero la compatibilidad de ImageX se diseñó para utilizarse en tiempo de diseño y la característica de inicio del WIM se diseñó específicamente para sólo lectura y para funcionar solamente con Windows PE. Por lo tanto, aunque son parecidos, los controladores y la implementación son diferentes.
Además de la herramienta ImageX, Microsoft proporciona una API documentada formalmente, WIMGAPI, que permite compatibilidad total para cualquier herramienta de imágenes que desea poder capturar, aplicar o modificar archivos WIM. Cualquier tercera parte que desee agregar compatibilidad con imágenes o reemplazar una infraestructura de imágenes existente, puede hacerlo con WIMGAPI. Esta API es parte del WAIK y, por lo tanto, se distribuye con el mismo.

Instalación basada en imágenes de Windows
Una vez que se tuvo el formato de imágenes, se diseñó el nuevo motor de instalación. En su núcleo, es más parecido a la antigua instalación mínima o bienvenida de Windows, que realizaba las preguntas básicas necesarias para obtener la instalación y configuración única del sistema mientras controlaba también la configuración del disco antes de instalar la imagen desde install.wim en el DVD de instalación de Windows. El primer objetivo del nuevo motor de instalación era tener en cuenta las instalaciones manuales de Windows. Previmos que muchos OEM y clientes empresariales utilizarían ImageX para realizar sus implementaciones reales.

Servicios de instalación remota
Llegados a este punto, es posible que se esté preguntando por qué no he hablado de los servicios de instalación remota (RIS). RIS fue algo que heredé también cuando comencé en el equipo de Windows Deployment. RIS, que al principio se incluyó con Windows 2000 y luego otra vez en Windows Server® 2003, utiliza un entorno de ejecución previo al inicio (PXE) para iniciar desde la red un equipo hasta el punto en que se pueda finalizar un asistente básico y la instalación de Windows pueda tener lugar a través de la red.
El principal problema con RIS fue que era terriblemente frágil. La versión de Windows Server 2003 de RIS, que al principio sólo era compatible con Windows 2000 Professional, amplió su compatibilidad para versiones de servidores de Windows. Con la carga entrante de los controladores de almacenamiento Serial ATA (SATA) y GB o NIC más rápidos, mantener los controladores actualizados en RIS siempre fue muy peligroso. Además de esto, RIS no es compatible con muchas configuraciones regionales con las que Windows sí lo es, lo que significa que la instalación de las versiones regionales de Windows con teclados con configuración regional puede ser difícil, si no imposible. Los servicios de implementación de Windows se diseñaron para ser la amalgama de la instalación de Windows y RIS: un inicio de Windows PE iniciado en PXE que le permite implementar un archivo WIM a través de la red.
WDS se diseñó para estar disponible en la próxima versión del código de Windows Server, llamado "Longhorn," y también como una actualización que sería instalable en Windows Server 2003. Esto significó que WDS sería capaz de implementar Windows Vista desde versiones anteriores de Windows Server y también podría implementar versiones anteriores de Windows. De hecho, WDS no sólo funciona con RIS, sino que requiere una instalación de RIS para poder funcionar. Esto se debe a que funciona mediante la actualización de la infraestructura de RIS para que sea compatible con WDS, a la vez que proporciona la nueva infraestructura de WDS.
Además de funcionar como una actualización de RIS, proporcionando así una ruta de migración correcta para clientes que siguen utilizando versiones anteriores de Windows mientras inician las implementaciones de Windows Vista, WDS también proporciona herramientas de administración mucho mejores que las que RIS tenía, lo que permite una agregación de imágenes al servidor mucho más sencilla. También proporciona un marco de PXE conectable. Esto quiere decir que un tercer servidor PXE puede integrar y especificar que va a contestar una solicitud PXE de cliente específico en lugar de WDS. Ésta era una solicitud que recibíamos a menudo con RIS y que no podíamos proporcionar en ese momento.
WDS, disponible inicialmente como componente instalable en Windows Server 2003 para actualizar RIS, también se incluirá como componente integrado de los productos Windows Server "Longhorn". Actualmente, Microsoft también está planeando incluir la función WDS en futuras versiones de SMS (que se denominará System Center Configuration Manager).
WDS funciona proporcionando una versión de inicio PXE de Windows PE 2.0. Esta imagen se encuentra en un WIM, lo cual significa que se transmiten datos reducidos a través de la red, y se inicia a través de la red en un disco RAM. La instalación tiene lugar en Windows PE, mediante una aplicación de cliente nueva que proporciona la función distribuida por la aplicación OSChooser básica de RIS en el pasado.
Aunque WDS no es compatible con imágenes de RIS de Windows XP, Windows 2000 o Windows Server 2003 tal como están, tiene la capacidad de implementar imágenes Sysprep de los mismos. WDS también se integra en Active Directory®, como siempre hacía RIS, pero el servidor PXE también se puede ejecutar sin Active Directory si es necesario. WDS se puede iniciar incluso desde Windows PE, habiéndose iniciado éste a su vez desde algo distinto de PXE, como un CD, DVD o una unidad flash USB (UFD). Ésta es una función útil que RIS no podía proporcionar.
Existen tres modos eficaces en los que WDS puede funcionar, en función del uso que se haga de RIS:
WDS heredado Los binarios están instalados, pero OSChooser es el mecanismo de inicio. RISetup y RIPrep, las herramientas de instalación basada en imágenes y de secuencia de comandos, aún están en funcionamiento.
Modo mixto Ambos mecanismos de inicio están disponibles, los dos conjuntos de herramientas de imágenes funcionan y los dos conjuntos de herramientas de administración también.
Nativo No hay función de RIS, sólo están disponibles la función de WIM, el inicio de Windows PE y las nuevas herramientas de administración. Observe que este es el único modo programado para que esté disponible en Windows Server "Longhorn". No incluirá ninguna función de RIS.
WDS también implementa un protocolo de comunicación cliente-servidor y, como resultado, un OEM o cliente empresarial podría, en teoría, crear también su propia aplicación de implementación.
El proceso de capturar una imagen WIM en un servidor WDS es casi idéntico al escenario Sysprep que ya he explicado. La diferencia es que el último paso implicará el inicio en la imagen de captura WDS, una imagen de Windows PE que existe para ayudarle a capturar un sistema de cliente y capturarlo en el servidor WDS.
Los componentes principales de WDS son los siguientes: servicio de servidor WDS, servidor PXE, almacenamiento de imágenes, protocolo de comunicación, recurso compartido de archivos con imágenes de Windows PE (para iniciar), imágenes WIM (para instalar) y archivos de administración adicionales relacionados.
WDS fue diseñado para ser relativamente ligero y proporcionar una experiencia casi idéntica (pero a menudo más rápida) que una instalación tradicional basada en medios ópticos de Windows. La implementación de WDS como actualización de RIS le permite reemplazar RIS de forma gradual a la vez que se facilita la implementación de Windows Vista en su organización. También hace que sea más sencillo de utilizar y más rápido de lo que RIS era cuando se incluía en versiones anteriores de Windows.

Administrador de imágenes de sistema de Windows
El último componente del WAIK es el administrador de imágenes de sistema (WSIM). Si está familiarizado con el administrador de instalación de otras versiones anteriores de Windows, el concepto del SIM de Windows también le debería ser familiar. Esta herramienta le permite completar varias tareas con archivos de instalación desatendidos. Puede crear fácilmente un archivo de instalación desatendido nuevo, editar uno existente o comprobar la configuración en un archivo existente respecto a una imagen específica de Windows Vista. La herramienta también muestra todas las opciones de configuración potenciales dado un WIM específico con Windows Vista en el mismo: piense en las opciones de instalación desatendidas tradicionales, documentadas históricamente en los archivos de ayuda que acompañan deploy.cab. Por último, SIM de Windows puede ayudar a crear recursos compartidos de distribución y conjuntos de configuración, que se utilizan para agregar controladores, aplicaciones y actualizaciones a las instalaciones de Windows Vista mediante un archivo de instalación desatendido.
El SIM de Windows requiere que usted sea el administrador local del sistema en que lo ejecuta. Cuando abra el SIM de Windows, verá cinco paneles, como se muestra en la figura 3.
Figura 3 Administrador de imágenes de sistema de Windows
Figura 3 Administrador de imágenes de sistema de Windows (Hacer clic en la imagen para reducirla)
Figura 3 Administrador de imágenes de sistema de Windows
Figura 3 Administrador de imágenes de sistema de Windows (Hacer clic en la imagen para ampliarla)
En el panel Recurso compartido de distribución, en la parte superior izquierda, se muestran controladores y otros paquetes agregados a través del SIM. No tiene un recurso compartido de distribución montado de forma predeterminada, pero puede abrir y crear uno fácilmente.
En el panel Windows Image, bajo el panel Recurso compartido de distribución, se muestran opciones de configuración (componentes y paquetes) en una imagen de volumen de Windows dada en un WIM. Observe que monta una sola imagen de volumen de Windows (un SKU en el DVD de Windows Vista) cada vez.
En el panel Answer File, en el centro, se muestran las opciones de configuración en un archivo de instalación desatendida de Windows Vista, así como la configuración predeterminada como se define en los catálogos (los parámetros y configuración potenciales) de la imagen de volumen WIM que ha montado.
El panel Propiedades, en la parte superior derecha, es un panel que le permite editar las propiedades individuales de un componente del panel Answer File.
El último panel es Mensajes, que se encuentra en la parte inferior y en el que se muestran comentarios más detallados, incluyendo una vista del XML sin procesar en un archivo de configuración desatendido de Windows Vista (siempre en formato XML), así como salida de validación y cualquier mensaje relacionado con cualquier conjunto de configuración que esté utilizando actualmente (la ficha Configuration Set sólo contiene datos si tiene abierto un conjunto de configuración).
Como ya ha visto, el WAIK proporciona un conjunto de herramientas muy eficaz para ayudarle a implementar Windows Vista. El equipo de Windows Deployment ha realizado un gran trabajo al crear una recopilación de herramientas que hacen que Windows Vista sea más fácil de implementar en comparación con cualquier otra versión de Windows en el pasado.

Wes Miller es Director de desarrollo de Pluck (pluck.com, en inglés) en Austin, Texas. Anteriormente, trabajó en Winternals Software y en Microsoft como administrador de programas y administrador de producto para Windows. Wes desea agradecer a Scott Dickens y John Macintyre, de Microsoft, su ayuda con esta columna. Si lo desea, puede ponerse en contacto con Wes en la dirección technet@getwired.com.


 Notas de campo: Soporte t&#233;cnico para la familia pol&#237;tica
Notas de campo
Soporte técnico para la familia política
James Snell

ME CASÉ el año pasado y, a cambio de mi bella esposa, parece que he firmado un contrato de soporte técnico con toda su familia. Recientemente, mi suegra me llamó y me hizo el temido comentario "Tú sabes de informática, ¿verdad?" y me marché en busca de su equipo con Windows® XP que estaba afectado por un sinfín de spyware, adware, barras de herramientas, etc.
Si es un profesional de TI, lo más probable es que esté acostumbrado a arreglar equipos. Aunque hacerlo para un familiar no resulta tan sencillo. La forma más rápida de enfrentarse a un equipo infectado es formatear el disco duro y volver a instalar Windows. Por desgracia, la mayoría de la gente rechaza esta opción ya que no quiere perder todos sus datos. Esto significa normalmente que tiene por delante una larga tarea de limpieza. Pero ¿qué ocurre si ni siquiera puede tener acceso al equipo o a Internet?
Lo que necesita es reunir un kit de herramientas en una llave USB de 512 MB, que incluya software antivirus, anti spyware y de firewall personal. Mantenga el kit de herramientas actualizado y a mano.
También se recomienda contar con Windows XP Service Pack 2 (SP2) en la llave USB. Aunque Windows XP ahora incluye SP2, la versión de mi suegra era anterior a esta edición. Puede descargar la instalación de Windows XP SP2 en microsoft.com/technet/prodtechnol/winxppro/maintain/winxpsp2.mspx (en inglés). La versión que buscamos es para varios equipos; la de un solo equipo usa Windows Update.) Con 266 MB, difícilmente será una descarga rápida, pero sólo hay que hacerla una vez.
De modo que, supongamos que ha pasado la tarde formateando e instalando el sistema operativo, o bien eliminando a conciencia virus y spyware, y, a continuación en ambos casos, ha instalado las actualizaciones de software necesarias de Windows, además del firewall, ha actualizado las definiciones del antivirus, etc. ¿Y ahora qué? Seguro que no quiere pasar cada fin de semana haciendo esto. Hay varios pasos que puede seguir para que esta situación resulte menos probable.

Eliminar el software basura
El sistema de mi suegra estaba lleno de software, instalado principalmente por amigos, que abarcaba desde aplicaciones que podrían resultar útiles hasta auténtica basura. Para evitar que esto volviera a ocurrir, bloqueé la cuenta de administrador con una contraseña segura y la establecí como usuario estándar (no necesita usar la cuenta de administrador con mucha frecuencia). La próxima vez que alguien intente instalar algo, necesitará iniciar sesión como administrador para continuar y esto suele ser un elemento disuasorio suficiente. Este procedimiento, junto con algunas nociones de usuario, debe contener el software basura. Get Safe Online, getsafeonline.org (en inglés) cuenta con estupendos consejos para que los usuarios mantengan protegido su PC.
La seguridad de mi suegra precisaba algo diferente con respecto a las contraseñas. Dejé la contraseña fuera de la cuenta de usuario para animarla a que la usara. Además, supongo que alguien con malas intenciones y que tenga acceso físicamente al equipo sacará antes el equipo de la casa que los datos del equipo.
Puede parecer tonto, pero coloqué una nota adhesiva en el interior de la puerta frente al equipo. No obstante, no me preocupa que consiga la contraseña de administrador sin que yo lo sepa, al fin y al cabo, es su equipo. Aunque éstas no son recomendaciones aceptables para una empresa, mi suegra no almacena información confidencial y no se preocupa de que otros puedan usar su equipo. El objetivo en este caso es hacer su vida más fácil y, lo que es más importante, mi vida como su ingeniero de soporte técnico.

Fronteras de rechazo
El siguiente paso consistía en ofrecer un poco de protección adicional. Me gusta la idea de que haya un firewall integrado en Windows y de que existan firewalls de terceros. Sin embargo, desconfío de un solo firewall aislado. Para conseguir una seguridad adicional, mi suegra tiene ahora un enrutador ADSL con un firewall integrado. La verdad es que se trata de un gasto adicional y un elemento más del equipo que hay que configurar y ejecutar, pero ofrece un cierto nivel más de protección. Además, es una carcasa con luces parpadeantes, ¿acaso no resulta llamativo?
No obstante, no debemos suponer que la configuración inicial del enrutador sea segura. He elegido dos que, de forma predeterminada, tienen activadas las interfaces web y telnet en el lado público. Dediquemos un minuto a comprobar sus opciones avanzadas.
Los firewalls de software no se pueden cargar hasta que los componentes de red no estén conectados. El firewall integrado de Windows es la única protección con la que cuenta en las primeras fases de inicio del sistema (otro motivo para tener Windows SP2 instalado antes de conectar el equipo a Internet). Al desactivar el firewall de Windows, seguirá protegiéndole hasta que pueda iniciarse el firewall elegido. Asimismo, con el firewall del enrutador, no tengo que preocuparme porque algo lo desactive ya que se trata de un dispositivo independiente; si no está encendido, no se conectará. Además, lo considero como los datos con doble contraseña. Para que un ataque se lleve a cabo con éxito, tanto el enrutador como el firewall de software deben sufrir un error al mismo tiempo. No es que sea imposible, pero es menos probable.

Molestar y proteger
Piense en lo sencillo que habría sido todo el proceso si hubiéramos contado con una buena copia de seguridad. Yo no tengo paciencia con los que dicen que no pueden hacer copias de seguridad, al menos, de la información más importante. Los grabadores y los soportes de DVD no son tan caros y Windows incluye software de copia de seguridad. El problema es que mucha gente simplemente no los usa. En el caso de mi suegra, la solución fue realizar la copia habitual de la carpeta Mis documentos de manera periódica y guardar el archivo directamente en la carpeta de grabación del CD (%userprofile%\Configuración local\Datos de programa\Microsoft\CD Burning). Para ello, debe modificar la tarea programada con objeto de que sólo se ejecute cuando el usuario haya iniciado sesión. Así que ahora el asistente para grabación de CD muestra confirmaciones regulares (e irritantes) hasta que mi suegra introduce un disco en blanco, que es todo lo que yo quiero.

Mantener el contacto
Si se instala Windows Live™ Messenger, se puede configurar el escritorio compartido. Esto significa que, si una vez que llegue a casa, hay algo más que necesita configuración, puede ver qué ocurre sin tener que realizar otra visita (algo que es siempre de agradecer). Por cierto, puedo asegurar que tomar el control de un equipo remoto (lo que requiere permiso, claro está) y ser observados mientras controlamos el mouse es aún más impresionante que las luces parpadeantes del enrutador.

James Snell es un antiguo especialista de soporte técnico de Microsoft que reside en el Reino Unido. Ha trabajado con usuarios particulares y con algunas de las cuentas mundiales más grandes de Microsoft. James está trabajando actualmente en una nueva habilidad: la paternidad. Puede ponerse en contacto con él en James.Snell@lineone.net.


 Confidencial de Windows: Huida del infierno de DLL
Confidencial de Windows
Huida del infierno de DLL
Raymond Chen

EL INFIERNO DE DLL. Se trata de un problema tan perjudicial que tiene su propio apodo despectivo. Al instalar un programa, otro programa aparentemente sin relación deja de funcionar. La razón, desconocida para el usuario corriente, es que dichos programas están conectados mediante un archivo DLL. Ambos programas pueden tener ideas diferentes de la versión del archivo MSVCRT.DLL que debe estar instalado en el directorio de sistema. O bien el primer programa puede actualizar un control ActiveX® que el segundo programa usa (una actualización con la que el segundo programa no es totalmente compatible).
Si los dos programas son vitales en las operaciones diarias de la compañía, no es importante saber qué programa es responsable del error. Lo importante es que necesita que ambos estén actualizados y en funcionamiento. La diferencia entre "Estamos perdiendo dinero" y "Estamos perdiendo dinero por culpa de Bob" no es muy grande. En cualquier caso, se producen pérdidas en la compañía y debe solucionar el problema inmediatamente.
Anteriormente se decidía entre el programa mejor y el peor. Comencemos con Windows® 2000, se ponen las vendas a disposición del usuario para ayudarle a solucionar los conflictos. Sin embargo, estas vendas son sólo soluciones temporales que permiten volver a activar el sistema mientras busca una solución definitiva al conflicto.
Windows 2000 implementó una versión básica de lo que ahora se conoce con el nombre de redirección de biblioteca de vínculos dinámicos. Para habilitar la redirección de DLL, cree un archivo con el mismo nombre del programa cuyos archivos DLL desee redireccionar, pero con .local agregado al nombre. Por ejemplo, para aplicar la redirección a C:\Archivos de programa\Litware Inc\Invoice.exe, cree el archivo C:\Archivos de programa\Litware Inc\Invoice .exe.local. El contenido del archivo no es relevante; lo que importa es que el archivo exista.
Una vez que ha habilitado la redirección para un programa, cada vez que ese programa intente cargar una DLL buscará primero en el directorio que contiene el programa antes que en las ubicaciones de búsqueda habituales. Por lo tanto, en el caso del archivo MSVCRT.DLL conflictivo, puede habilitar la redirección en cada programa y poner una copia privada del archivo MSVCRT.DLL en el directorio de instalación de cada uno de los programas. A continuación, cada programa recibirá una versión propia de MSVCRT.DLL (la versión de la DLL con la que se probó el programa).
La ventaja de esta técnica es que funciona aunque el programa utilice una ruta completa para cargar la DLL. Por ejemplo, imagine que el programa intenta cargar C:\Archivos de programa\Archivos comunes\Proseware Inc\taxplugin.dll. Después de realizar la actualización a Proseware 2.0, descubre que el complemento sobre impuestos no es compatible con el programa de facturas. Puede copiar una versión anterior del complemento sobre impuestos en C:\Archivos de programa\Litware Inc\taxplugin.dll. Aunque el programa use una ruta completa para cargar dicho complemento, la redirección de DLL seguirá buscando en el directorio actual y usará la invalidación local en lugar de la ubicada en el directorio de Proseware Inc.
En Windows XP y Windows Vista™, las reglas para la redirección de DLL son ligeramente diferentes, pero el principio general se mantiene. Además de crear un archivo .local, puede crear también un directorio .local. En tal caso, se realizará la búsqueda en el directorio .local en lugar de en el directorio de instalación del programa. Esto le permite aplicar la redirección a varios programas en el mismo directorio sin problemas.
Tenga en cuenta que no puede aplicar la redirección a programas que contengan un manifiesto de aplicación, ni a las denominadas DLL. Para obtener más detalles, consulte "Redirección de biblioteca de vínculos dinámicos" (en inglés).
La redirección de DLL no le librará completamente del infierno de DLL, pero le proporcionará técnicas de primeros auxilios para desinfectar la herida mientras soluciona definitivamente el problema.
Figura 1
Figura 1

Raymond Chen escribe acerca de la historia de Windows y la programación de Win32 en su sitio web, The Old New Thing (en inglés), así como en su libro nuevo titulado The Old New Thing (Addison-Wesley, 2007). Sin embargo, no tiene ningún gato que se llame The Old New Thing.