 TechNet Magazine August 2007

TechNet Magazine August 2007

System Center: SMS の進化 : システムを管理するための強力な新しいソリューション

システムの管理が、今までよりもはるかに容易になろうとしています。この記事では、System Center Configuration Manager 2007 を紹介し、このテクノロジによって、ソフトウェアの更新プログラムの展開、モバイル デバイスの管理、システム構成のメンテナンスなどの重要な作業をどのように簡略化できるかについて説明します。

John Orefice System Center: アプリケーションと更新プログラムをブランチ オフィスに展開する

Configuration Manager 2007 の新機能の 1 つであるブランチ配布ポイントは、最初はあまり重要でない追加機能のように思えるかもしれません。しかし、詳しく見ていくと、ブランチ オフィスへのソフトウェアの配布を管理するために欠かせない新機能であることがわかります。

Steve Rachui System Center: System Center Essentials 2007 の概要

中規模の企業に特化して設計された System Center Essentials は、システムの監視、管理、およびトラブルシューティングを行うための統合されたソリューションを提供します。この記事では、使用しているネットワークに Essentials 2007 をインストールして構成する方法について説明します。

David Mills System Center: Operations Manager 2007 を使用してサーバーを監視する

MOM の最新バージョンである Operations Manager 2007 には、新しい管理インターフェイスや優れたレポート機能、基幹業務 (LOB) アプリケーションへのサポート、新しいセキュリティ オプションなど、いくつか主要な機能強化が導入されています。

Pete Zerger System Center: MOM から Operations Manager 2007 に移行する

Operations Manager 2007 に移行する準備はできていますか。このバージョンではアーキテクチャが変更されたため、MOM の前のバージョンからの単純なインプレース アップグレードは実行できません。このため、この記事で紹介するいずれかの移行計画に従って移行作業を行う必要があります。

Andy Dominey System Center: Microsoft SoftGrid を使用してアプリケーションを仮想化する

仮想化されたアプリケーションには、ユーザー エクスペリエンスの向上からシステム管理の簡略化まで、多数の利点があります。Microsoft SoftGrid が、仮想アプリケーションをどのようにして配布するか、インフラストラクチャにどのように適合するか、および企業で時間とコストをどのように節約できるかについての詳しい概要を紹介します。

Ahmer Sabri and Kedar Shah 編集長から: 動的化と最適化

Joshua Trupin ツールボックス: IT プロのための新製品

Greg Steen SQL に関する Q&A: ロックの検出、大きなクエリ、入出力統計など

Edited by Nancy Michell ユーティリティ スポットライト: BGInfo

名前、IP アドレス、ゲートウェイ、空きディスク領域など、PC に関して必要な情報を 1 か所で確認できたらすばらしいと思いませんか。Sysinternals から提供される無償のツールを使用すればこれを実現できます。

Lance Whitney The Cable Guy: Windows Vista での IPv6 自動構成

IPv6 は、アドレス空間を 32 ビットから 128 ビットに広げるだけのものではありません。この記事では、アドレス構成プロトコルを使用せずに IPv6 ホスト自体を自動構成する方法について説明します。

Joseph Davies Windows PowerShell: フィルタ処理の力

パイプラインは、コマンドレットのためだけのものではありません。今月のコラムでは、Windows PowerShell パイプラインを使用して、便利なフィルタ処理機能をスクリプトに追加する方法を紹介します。

Don Jones Hey, Scripting Guy!: あなたはだれ

ユーザーは、Active Directory に givenName、displayName、userPrincipalName、distinguishedName など、さまざまな ID を持つことができます。システム管理者は、ユーザーに関するこうした情報をどのようにして入手しているのでしょう。もちろん、スクリプトを使用しています。

The Microsoft Scripting Guys セキュリティ ウォッチ: Windows での PKI の機能強化

Windows Vista および Windows Server 2008 では、Windows PKI プラットフォームによって、高度なアルゴリズム、リアルタイムの有効性チェックがサポートされ、管理の容易さが提供されます。新しい PKI 機能をチェックして、それらの機能をどのように使用すれば、セキュリティを向上しつつ、コストを削減できるのかを見てみましょう。

John Morello デスクトップ ファイル: RDP について理解する

リモート デスクトップ プロトコルを使用すると、リモートでコンピュータにアクセスできるようになります。この便利なテクノロジは、Windows のバージョンごとに強化されています。この記事では、リモート デスクトップの概要と、その利点および欠点について説明します。

Wes Miller フィールド ノート: インスタント メッセージを使用した面接

1 つの役職の求人募集に対して、世界中から大量の履歴書が送られてきた場合、採用候補者をすばやく絞るにはどうすればよいでしょうか。答えは、インスタント メッセージ (IM) で面接を行うことです。ここでは、ある開発者の成功例を紹介します。

Nathan G. Jensen Windows 秘話: エクスプローラでテキスト形式を使用できない

エクスプローラでファイルの一覧をコピーしてテキストとして貼り付けて、ファイル名を取得できないのはなぜでしょうか。Windows チームはこの機能を組み込もうとしましたが、計画どおりに動作しませんでした。

Raymond Chen


 System Center: SMS の進化 : システムを管理するための強力な新しいソリューション
System Center John Orefice

SMS の進化 : システムを管理するための強力な新しいソリューション
概要:
  • オペレーティング システムを展開する
  • ソフトウェアの更新を管理する
  • 望ましい構成の管理

Systems Management Server (SMS) 2003 は、世界中の管理者にとって重要な構成管理ツールおよびソフトウェア配布ツールとなりました。現在マイクロソフトは、
企業管理ソリューションの新しいバージョンを発表する準備を進めています。この新しいバージョンでは新機能が追加され、製品名も System Center Configuration Manager 2007 に変更されます。
System Center は、複雑な IT インフラストラクチャの日々の管理を容易にし、コスト効率を高めるために、連携して動作するよう設計されたマイクロソフト製品のファミリです。System Center ソリューションは、Microsoft® Operations Framework (MOF) と情報技術インフラストラクチャ ライブラリ (ITIL) から派生した自動化方法とベスト プラクティスに基づいており、組織のあらゆるレベルで使用できます。
System Center ファミリには、Configuration Manager 2007 以外にも多くの製品があります。System Center Data Protection Manager は、企業システムのバックアップと回復を提供します。System Center Operations Manager は、積極的なシステムの監視と自動化を提供します。System Center Capacity Planner は、インフラストラクチャを展開する際のキャパシティの計画と what-if 分析を行うために使用することができます。これらの他にも新しい製品が続々と登場しています (詳細については、www.microsoft.com/systemcenter を参照してください)。
この記事では、Configuration Manager 2007 で提供される予定のいくつかの新機能と機能拡張について、最新のベータ リリースを基にして説明します。また、この魅力的なリリースで何が実現できるかについて概説し、Configuration Manager を使用してどのように組織の時間と経費を節約できるかについて説明します。

新しい管理用ユーザー インターフェイス
SMS 1.0 のリリース以来、SMS の新機能として最も要望が多いのは、強化された新しい UI です。マイクロソフトは、System Center Configuration Manager 2007 で管理用 UI をいくつか強化することによって、この要望に応えようとしています。これらの新機能を実現するために、Configuration Manager 2007 の新しいコンソールは C# と Microsoft .NET Framework を使用して構築されており、Microsoft 管理コンソール (MMC) 3.0 テクノロジ上で実行されます。また、SMS 2003 と同様、この UI は SDK を使用して拡張できるため、コンソールのユーザーが個々のニーズに合わせて独自のアドオンを作成することができます。
図 1 は、[Computer Management] (コンピュータの管理) ノードが展開され、使用できるすべての新しい管理機能が表示された新しいコンソールを示しています。[SMS Site Configuration] (SMS サイトの構成) セクションの新しい外観にも注目してください。このセクションには、インストール後、Configuration Manager を運用する前に完了する必要がある一般的な作業の概要が記載されています。[Links and Resources] (リンクとリソース) セクションには関連作業が記載されているため、一般的な機能を短時間でコンソール内から見つけることができます。
図 1 Configuration Manager の管理用インターフェイス
図 1 Configuration Manager の管理用インターフェイス
この新しいコンソールの利点と機能として挙げられるのは、複数のアイテムの選択とドラッグ アンド ドロップ (コレクションの管理に役立ちます)、コンソール内のアイテムを物理的にではなく仮想的に整理するための検索フォルダ、現在のセクションに適した作業を行うための [Actions] (操作) ペイン、特定のアイテム (オペレーティング システム イメージなど) の概要が表示される [Preview] (プレビュー) ペイン、ソフトウェアの展開などの特定のトピックの概要が表示されるホームページ、ナビゲーションが大幅に簡略化された組織構造などです。
前述の [Actions] (操作) ペインは、新しいコンソールの中で最も強化された機能の 1 つです。このペインには、現在使用しているコンソールのセクションに適した操作 (前後関係から判断されます) が表示されます。たとえば、[All Systems] (すべてのシステム) コレクションを表示している場合は、[Update Collection Membership] (コレクションのメンバシップを更新) や [Install Agent] (エージェントのインストール) などの操作が表示されます (図 2 を参照)。
図 2 現在のセクションに応じて表示される実行可能な操作
図 2 現在のセクションに応じて表示される実行可能な操作
さらに、Configuration Manager 2007 ではホームページという新しい概念が導入されます。この機能により、Software Updates (ソフトウェアの更新)、Software Distribution (ソフトウェアの配布)、Desired Configuration Management (望ましい構成の管理) などの特定の機能の状態をすばやく確認できるようになります。この操作はコンソール内で行うことができるため、レポートを実行したり、データを他の場所から探したりする必要はありません。この記事では、この製品のさまざまな機能について説明しながら、ホームページの例も紹介していきます。

サーバーの役割と配布ポイント
Configuration Manager 2007 では、ここで説明する一部の新機能を有効にするために、いくつかの新しいサーバーの役割が導入されます。これらの役割は、Fallback Status Point (フォールバック状態ポイント、FSP)、PXE Service Point (PXE サービス ポイント、PSP)、Branch Office Distribution Point (ブランチ オフィス配布ポイント、Branch Office DP)、State Migration Point (状態移行ポイント、SMP)、Software Update Point (ソフトウェア更新ポイント、SUP)、System Health Validator (システム状態の確認、SHV) です。SMS と Configuration Manager のすべてのサーバーの役割と同様、これらの役割は、適切なキャパシティの計画が行われている限り、同一のサーバー上でホストできます。
Branch Office DP は重要な役割であり、従来の DP と異なる点が 2 つあります。1 つ目は、サーバー オペレーティング システムにインストールする必要がないことです。この役割は Windows Vista® や Windows® XP にインストールできます。この役割は、クライアント オペレーティング システムにインストールできる唯一の Configuration Manager の役割です。この機能は、ブランチ オフィスにローカル サーバーがない場合や、IT 部門が小規模のブランチ オフィスからサーバーを撤去して、資金の節約と管理オーバーヘッドの削減を図る必要がある場合に役立ちます。このように Windows XP と Windows Vista 以外のオペレーティング システムを実行しているコンピュータが存在しない環境で Branch Office DP を使用すると、ローカル ネットワーク内で取得できるパッケージをクライアントが WAN 経由で取得しなくなるため、WAN トラフィックを減少させることができます。
Branch Office DP が標準の DP と異なる 2 つ目の点は、他の DP に接続することです。従来の配布ポイントのレプリケーション データは、プライマリ サイトからセカンダリ サイトに転送されない限り、調整もスケジュールもされません。このため、多くの組織は夜間にブランチ オフィスへのパッケージのレプリケーションを行い、それらのパッケージがローカルにすべてレプリケートされるまで、ソフトウェアを配布することはできません。
Branch Office DP は、バックグラウンド インテリジェント転送サービス (BITS) を使用して、情報を他の DP からダウンロードします。これにより、ブランチ オフィスに Configuration Manager セカンダリ サイトがない場合でも、ブランチ オフィスと中央のデータセンターにある DP との間の WAN リンクの帯域幅を調整できるため、非常に便利です。図 3 は、標準の DP を Branch Office DP に変更できる、新しい配布ポイントのプロパティ ダイアログ ボックスを示しています。
図 3 Branch Office DP の構成
図 3 Branch Office DP の構成
SMS 2003 で導入されたレプリケーション テクノロジにより、サイト サーバーから配布ポイントへの、パッケージのファイル デルタ レプリケーションを実行できるようになりました。このテクノロジは、複数の小さいファイルから構成されている SMS パッケージには効果がありました。たとえば、SMS 管理者が、大きい SMS パッケージ内の 1 つのファイル、または複数の小さいファイルを変更する必要がある場合、パッケージ全体ではなく、パッケージ内の変更されたファイルのみをレプリケートすることができました。
Configuration Manager 2007 では、オペレーティング システムの展開がより中心的な機能となるため、オペレーティング システム イメージ パッケージやその他の大きいパッケージを、可能な限り効率的に、WAN リンクを経由してインフラストラクチャ全体にレプリケートできることを皆さんも望んでいるでしょう。この目標を実現するために、Configuration Manager 2007 では、サイト サーバーからサイト サーバー、サイト サーバーから DP、および DP から Branch Office DP へのバイナリ デルタ レプリケーションが導入されます。
例として、いくつかのアプリケーションがあらかじめインストールされた新しい Windows Vista の展開イメージの場合について説明しましょう。このパッケージのサイズは、おそらく 6 GB になります。また、このパッケージは Windows Imaging (WIM) 形式のイメージであるため、1 つの 6 GB のファイルでもあります。既に説明したとおり、SMS 2003 では、新しい WIM イメージを開いて、設定を変更したりリリースされている 2 MB の修正プログラムを追加したりした場合、このイメージは 1 つの WIM ファイルであるため、6 GB の SMS パッケージ全体を DP にレプリケートする必要がありました。これとは対照的に、Configuration Manager 2007 のバイナリ デルタ レプリケーションでは、WIM イメージ パッケージの設定が変更されたり修正プログラムが適用されたりした場合、6 GB のパッケージ全体ではなく、2 MB の修正プログラムや変更された設定のみがインフラストラクチャ全体にレプリケートされます。

モバイル デバイスの一般的な処理
SMS 2003 がリリースされてから間もなく、マイクロソフトは Windows CE および Pocket PC モバイル デバイスの管理に使用できる Device Management Feature Pack (DMFP) をリリースしました。モバイル デバイスが企業組織内に普及するにつれて、それらのデバイスを管理することの必要性は増してきています。この傾向を踏まえて、Configuration Manager 2007 は、SMS 2003 DMFP を強化することにより、Windows Mobile® を実行している Smartphone や Pocket PC Phone をサーバー、ラップトップ、およびデスクトップ コンピュータと同じように管理できる、優れた新しい統合ソリューションを提供します。
モバイル デバイスの基本的な管理作業の対象には、ハードウェア インベントリとソフトウェア インベントリ、ファイル コレクション機能、ソフトウェアの配布、パスワードとセキュリティ ポリシーの管理に関する設定などがあります。Configuration Manager 2007 のインターネット ベースのクライアント管理機能を使用することにより、イントラネット上だけでなくインターネット上のデバイスもすべて管理できるようになります。この機能は、ほとんど企業 LAN に接続しない Smartphone やその他のデバイスにとって非常に役立ちます。
また、エージェントを展開する処理も強化されています。モバイル クライアントのアップグレードがサポートされるようになったため、クライアントの配布を Configuration Manager のコンソールから自動化できるようになりました。

メンテナンス時間帯
私が一緒に仕事をするほとんどの企業顧客では、サーバーと特定のミッション クリティカルなデスクトップのメンテナンス時間帯があらかじめ決められています。また、それらの顧客から、2007 Microsoft Office system などの大きいアプリケーションを、通常の業務時間中にエンド ユーザーの作業を中断することなく展開する方法をよく尋ねられます。
Configuration Manager 2007 では、メンテナンス時間帯と呼ばれる新機能が導入されます。この機能を使用すると、特定のコレクションに対してインストールを実行できる期間を定義できるようになります。これにより、パッケージを通常の業務時間中やユーザーにとって不都合な時間にインストールすることによって生じる悪影響を気にせず、任意の期間に提供情報の実行を必須にすることができます。
例として、2007 Office system パッケージの展開について考えてみましょう。このアプリケーションをエンド ユーザーにできるだけ早く展開する一方で、日中の業務も妨げないようにする必要があるとします。このような場合、メンテナンス時間帯を設定することにより、システムでインストールを実行する時間帯 (午後 8 時から午前 6 時までなど) を指定することができます。特定の日のこのメンテナンス時間帯の間に (理由を問わず) システムが使用できなくなった場合、Configuration Manager は、メンテナンス時間帯の中で次に定義されている時間まで待機するため、業務が突然中断することはありません。また、提供情報レベルでメンテナンス時間帯を無視して、制限を受けることなく重要な更新プログラムをできるだけ早く展開することもできます。

オペレーティング システムを展開する
オペレーティング システムの展開機能は、Configuration Manager 2007 の中で最も重視されている領域です。マイクロソフトは、サーバー プラットフォームとワークステーション プラットフォームのどちらでオペレーティング システムを展開する際にも主要な方法として使用できるように、Configuration Manager を設計しました。OS の展開の管理方法を根本的に変えるために、Configuration Manager 2007 には、SMS 2003 Operating System Deployment (OSD) Feature Pack の最も優れた機能が統合されました。
既にご存知かもしれませんが、Windows Vista では、オペレーティング システムの展開用の新しい Windows Imaging (WIM) 形式が導入されました。この形式を使用することによって、いくつかの利点が得られます。たとえば、Configuration Manager 2007 はネイティブで WIM イメージ形式をインポートするため、管理者はコンソールから直接イメージを操作して展開できます。
展開に関する Configuration Manager の新機能としてもう 1 つ重要なのは、統合された Task Sequencer (タスク シーケンサ) です。Microsoft Solution Accelerator for Business Desktop Deployment (BDD) に詳しい場合は、Configuration Manager で提供される多くの機能とオプションが BDD と類似していることがわかると思いますが、1 つ大きな違いがあります。それは、オペレーティング システム イメージを展開またはキャプチャするためのスクリプトを記述する必要がなくなったことです。さらに、Task Sequencer を活用することにより、オペレーティング システムの展開処理は完全に自動化されます。
Task Sequencer を使用すると、OS の展開中に実行する必要があるすべての手順の詳細を事前に決定できます。これらの手順には、展開前に古い OS で実行する手順 (ユーザー状態の移行とアプリケーションの設定の転送)、新しいオペレーティング システムを展開する手順 (フォーマット、ディスクのパーティション分割、プロダクト キー、ユーザー名、会社名、およびライセンスに関する設定、ドライバのインストール)、新しいシステムの展開後に実行する手順 (追加のアプリケーションのインストール、更新プログラムのインストール、ユーザー状態の移行) などがあります。この機能の例として、Task Sequence Editor (タスク シーケンス エディタ) を図 4 に示します。この図は、Windows Vista の展開で使用できる機能の一部を示しています。
図 4 オペレーティング システムの展開手順の編集
図 4 オペレーティング システムの展開手順の編集
Configuration Manager 2007 のオペレーティング システムの展開では、Task Sequencer の他にも、図 5 に示されているようないくつかの機能拡張が提供されます。たとえば、x86 および x64 プラットフォームでは、Pre-Boot Execution Environment (PXE) を使用したベアメタル展開と共に、デバイス ドライバの管理がサポートされています。デバイス ドライバの管理がサポートされることにより、組織はハードウェアの種類に合わせてメンテナンスする必要があるイメージの数を大幅に減らすことができるようになります。この機能を Windows Vista の WIM イメージ形式で導入された単一イメージのサポートと組み合わせれば、オペレーティング システムの展開にかかる時間と費用を削減できることはほぼ間違いありません。
Figure 5 オペレーティング システムの展開機能 (Close Figure 5)

シナリオ | SMS 2003 | Configuration Manager 2007
エンド ツー エンドの展開 | ○ | ○
完全な自動化 | ○ | ○
ワイプ アンド ロード アップグレード | ○ | ○
PXE を使用したベアメタル展開 | リモート インストール サービス (RIS) との密接でない統合 | Windows 展開サービス (WDS) に組み込まれた機能
サイド バイ サイド | BDD スクリプトが必要 | ○ (組み込みの State Migration Point (状態移行ポイント) を使用)
完全なオフライン展開 | × | ○
Windows Vista へのアップグレード計画 | × | ○
完全なサーバーの展開 | × | ○
デバイス ドライバの管理 | × | ○

ソフトウェアの更新を管理する
Configuration Manager 2007 の他の多くの機能と同様に、ソフトウェアの更新の管理も大幅に強化されました。Configuration Manager では、更新プログラムと通常のパッケージが、管理しているエージェントにそれぞれ異なる方法で展開されます。この動作は、すべてのソフトウェアの更新と、望ましい構成の管理に関する情報用に、状態ベースの優先順位が高いチャネルを新しく作成することによって実現されました。これにより、別のソフトウェア パッケージを展開しても、ソフトウェアの更新プログラムを展開したり、管理しているワークステーション、ラップトップ、またはサーバーから修正プログラムの状態を受信したりする操作が妨げられなくなります。
また、状態ベースの方法でソフトウェアの更新を管理することにより、修正プログラムと更新プログラムの状態がハードウェア インベントリのスキャンと関連付けられなくなるため、現在の Microsoft 更新プログラム用インベントリ ツール (ITMU) とスキャン カタログは不要になります。代わりに、Configuration Manager は、ソフトウェア更新エンジンおよびデータベースとしてバックエンドで Windows Server Update Services (WSUS) を実行する、Software Update Point (ソフトウェア更新ポイント、SUP) という新しいサーバーの役割を使用します。
WSUS を使用すると、すべての更新を 1 つの場所で集中管理できるようになります。これにより、マイクロソフト プラットフォーム用の重要でない更新プログラム、ドライバ、その他のソフトウェア パッケージなど、Microsoft Update で提供されるすべてのコンテンツをダウンロードできます。また、マイクロソフトはパートナーにもこの方法でソフトウェアの更新プログラムをリリースするよう働きかけています。現在は、Adobe と Citrix の 2 社のみが、SMS 2003 R2 のカスタム更新プログラム用インベントリ ツール (ITCU) 用のマニフェストを公開しており、Configuration Manager 用のマニフェストについても前向きに検討しています。
新しいソフトウェア更新エンジンは、更新の状態をほぼリアルタイムで提供するため、レポートとホームページ ビューが強化されます。これらのカスタマイズされたビューを使用することにより、IT インフラストラクチャ全体、またはコンピュータの特定のコレクションの修正プログラムの状態を表す簡単なグラフを表示できます。図 6 を見ると、ソフトウェアの更新の管理用にカスタマイズされた新しいホームページ ビューの 1 つを使用して、特定のセキュリティ情報に対応した修正プログラムの適用に関するデータを容易に表示できることがわかります。
図 6 ソフトウェアの更新の状態の表示
図 6 ソフトウェアの更新の状態の表示
最後に、ソフトウェアの更新プログラムの展開用テンプレートを使用すると、新しい更新プログラムをシステムやコレクションに展開するために必要な手順の数を大幅に削減できます。Configuration Manager 2007 では、ソフトウェアの更新プログラムの展開用テンプレートを使用して、再起動を強制するかどうか、クライアントがローカルの DP から修正プログラムをダウンロードする必要があるかどうかなど、一般的な構成情報をインストールの実行前に保存しておくことにより、必要な手順の数が SMS 2003 の ITMU の 18 個からわずか 6 個まで減少しました。

望ましい構成の管理
構成の管理は、Configuration Manager 2007 で大幅に強化された、もう 1 つのすばらしい機能です。Configuration Manager 2007 の Desired Configuration Management (望ましい構成の管理) では、2006 年の秋にリリースされた SMS 2003 Desired Configuration Monitoring の主要な機能が提供されます。Desired Configuration Monitoring の背景については、microsoft.com/technet/technetmag/issues/ 2006/09/HighStandards にある TechNet Magazine の記事を参照してください。図 7 は、2 つの特定の構成ベースラインを満たしているかどうかに関する情報が表示された Desired Configuration Management のホームページを示しています。
図 7 望ましい構成ベースラインを満たしているかどうかに関するレポート
図 7 望ましい構成ベースラインを満たしているかどうかに関するレポート
Configuration Manager の Desired Configuration Management の重要な機能は、マイクロソフトの顧客に対する膨大な調査に基づいています。この調査により、サービスが停止する原因のほとんどが、ミッション クリティカルなサーバーやデスクトップのオペレーティング システムまたはアプリケーションの構成の誤りであることがわかりました。管理者は、Configuration Manager の Desired Configuration Management 機能を使用し、定期的なベースライン スキャンをシステムに対して実行することにより、構成の傾向をすばやく把握することができます。これらのベースラインは構成アイテム (CI) を使用して作成され、組織のコンピュータのコレクションがベースラインを満たしているかどうかに関する情報を提供します。
Desired Configuration Management は、構成の傾向を把握するだけでなく、規制遵守に関するレポートの作成や変更の確認にも役立ちます。ほとんどの組織では、サーベンス オクスリー法 (SOX)、支払いカード業界データ セキュリティ基準 (PCIDSS)、医療保険の携行性と責任に関する法律 (HIPAA) などの法規制の遵守に関するレポートを作成する必要があります。Configuration Manager 2007 の Desired Configuration Management は、これらの必要なレポートを作成するのに役立ちます。
ここで Desired Configuration Management のしくみについて説明します。まず管理者が、コンピュータに対して検出、適用、および削除できる構成単位である CI を定義します。これらの CI を定義したら、1 つまたは複数の CI から構成される構成ベースラインを作成できます。その後、これらのベースラインを Configuration Manager のコレクションに割り当てて、ベースラインを満たしているかどうかを監視したり、法規制の遵守に関するレポートを作成したりします。
CI では、コンピュータのさまざまな側面を確認して情報を収集することができます。これらの側面には、Active Directory®、ファイルのメタデータ、スクリプトの結果、SQL Server™ に格納されているデータ、ソフトウェアの更新に関するデータ、WMI、XML、レジストリ値、IIS メタデータ、Microsoft インストーラの存在と構成などがあります。これらのさまざまな場所から収集された情報は、Configuration Manager データベースに格納され、システムがベースラインを満たしているかどうかや、法規制を遵守しているかどうかを確認するために使用されます。
興味深いことに、Configuration Manager 2007 の Desired Configuration Management の処理と新しい更新プログラムの展開処理は、完全に統合されます。Desired Configuration Management のすべてのデータは、新しいソフトウェア更新エンジンと同様に、状態ベースの優先順位が高いチャネルを使用します。これらの 2 つのミッション クリティカルな機能が統合されることにより、管理者は、更新プログラムの展開処理の一環として、Desired Configuration Management の新しいベースラインを定義したり、新しい更新プログラムで既存のベースラインを更新したりできるようになります。

インターネット ベースのクライアント管理
コンピュータがネットワークに長い間接続しなかったことが原因で、SMS 内のそのコンピュータ オブジェクトが使用できなくなった経験はあるでしょうか。顧客の話を聞いていると、このようなことは頻繁に起こっているようです。さいわい、Configuration Manager 2007 では、インターネット ベースのクライアント管理が新しく導入されます。この機能の動作は、Microsoft Office Outlook® が、仮想プライベート ネットワーク (VPN) を使用せずに、HTTPS を経由して Exchange Server と通信する動作と非常によく似ています。このシナリオに詳しくない場合は、単に、複雑な VPN 接続を使用せず、より安全にクライアント コンピュータと通信できる機能と考えてかまいません。
インターネット ベースのクライアント管理を使用すると、イントラネット上のコンピュータと同じレベルで、インターネット上のコンピュータを管理できるようになります。実際、この記事で説明している機能は、すべてインターネット ベースのクライアント管理と連携して動作します。ただし、オペレーティング システムの展開、Wake-On-LAN、およびリモート ツールは例外です。これらの機能は通信に異なるポートを使用するため、SSL や TLS を経由してトンネリングできないことがその理由です。インターネット ベースのクライアント管理は、レストラン、小売店、およびガソリンスタンドの POS 装置、従業員の自宅にあるコンピュータ、移動が多い分散型の営業チームやコンサルタント チームなどで役立ちます。
Configuration Manager 2007 インフラストラクチャでインターネット ベースのクライアント管理を有効にするには、いくつかの要件があります。まず、Configuration Manager によって管理されるすべてのエージェントにデジタル証明書を割り当てるための公開キー基盤 (PKI) が必要です。これにより、Configuration Manager サーバーと、管理しているすべてのエージェントとの間で相互認証を実行できるため、受信するデータが暗号化され、信頼できるソースから送信されていることを保証できます。また、Configuration Manager サーバーとすべてのインターネット ベースのクライアントとの間の接続ポイントとして動作する SSL 終端装置も必要です。Microsoft Internet Security and Acceleration (ISA) Server 2006 は、これらの要件を満たすソフトウェア ベースのソリューションです。
インターネット ベースのクライアント管理では、新しいサーバーの役割である Fallback Status Point (フォールバック状態ポイント、FSP) が使用されます。いずれかのインターネット ベースのエージェントが正しく通信できなくなった場合や証明書の有効期限が切れた場合、そのエージェントは、組織の境界ネットワーク内の使用可能なフォールバック状態ポイントに問題を報告します。これにより、インターネットで管理されているシステムへのアクセスを常に維持することができます。また、クライアントは管理をインターネット ベースの管理とイントラネット ベースの管理との間で自動的に切り替えることにより、適切なタイミングで適切なリソースを最大限に活用できます。

その他の新機能
ミッション クリティカルな機能とは考えられていませんが、Wake-On-LAN は非常に役立つ機能です。管理者は、この機能を使用することにより、ソフトウェアの配布、ソフトウェアの更新、OS の展開などをすばやく自動的に実行することができます。Configuration Manager 2007 では、互換性のあるネットワーク カードが搭載された、イントラネット ベースで管理されているすべてのエージェントに Wake-On-LAN 機能を使用できます。図 8 は、新しく設計された New Advertisement Wizard (新しい提供情報ウィザード) で、提供情報に Wake-On-LAN を使用する例を示しています。この場合は、新しいパッケージをコンピュータのグループに展開しています。Wake-On-LAN に対応しているデバイスの電源がオフになっていて、このウィザードで Wake-On-LAN の設定を有効にした場合、Configuration Manager は、そのデバイスのシステムを起動し、提供情報によって定義されたパッケージを展開します。
図 8 ソフトウェアを配布するための提供情報に対して Wake-On-LAN を有効にするページ
図 8 ソフトウェアを配布するための提供情報に対して Wake-On-LAN を有効にするページ
リモート コントロールは、より安全で信頼性が高いソリューションと、大幅に強化されたパフォーマンスを提供するために、Configuration Manager で全面的に書き換えられました。Configuration Manager では、SMS 1.0 から使用されてきた古いツールではなく、Windows Vista にネイティブで組み込まれている、リモート デスクトップ プロトコル (RDP) に基づいて構築されたコラボレーション テクノロジが使用されます。エンド ユーザーが新しいセッションを承諾する必要がないことなど、このテクノロジの基本的な機能は SMS 2003 の機能と同じですが、full control (フル コントロール)、view only (表示のみ)、および none (なし) という 3 つの新しいアクセス レベルが導入されます。この新しいテクノロジに加えて、Configuration Manager 2007 には、必要なときのために、リモート アシスタンスも引き続き統合されています。

まとめ
この記事では、System Center Configuration Manager 2007 のいくつかの新機能と機能拡張について説明しました。これらの機能は、IT 環境の管理作業を軽減し、新しい作業を行うことを可能にして、コストを削減することを目的として設計されました。Configuration Manager 2007 や System Center ファミリの他の製品を使用することにより、要求の多い IT インフラストラクチャに対応できるだけでなく、ビジネスの競争力を高めることもできます。
この製品では、この記事で説明した機能だけでなく、他にも多くの機能拡張が提供されます。たとえば、Windows Server® 2008 のネットワーク アクセス保護 (NAP) の統合や、SMS 2003 SP3 に含まれているものと同じ資産インテリジェンス テクノロジに基づいて強化されたソフトウェア資産管理 (SAM) 機能などがあります。Configuration Manager 2007 の製品候補版 (試用版) をダウンロードし、皆さんが使用しているインフラストラクチャでこれらの機能の動作を確認することをお勧めします。
System Center ファミリの他のすべての製品の概要については、microsoft.com/systemcenter を参照してください。このページから、Configuration Manager を含む、System Center ファミリのすべてのソリューションに関する情報を参照することができます。

John Orefice は、マイクロソフトの米国中部大西洋岸地区のテクノロジ ソリューション プロフェッショナルです。彼は Microsoft Consulting Services (MCS) でコンサルタントを務めた後、ここ数年はマイクロソフトの管理ソリューション関連の業務に携わっています。彼の連絡先は john.orefice@microsoft.com (英語のみ) です。
© 2007 Microsoft Corporation and CMP Media, LLC. All rights reserved; 許可なしに一部または全体を複製することは禁止されています.


 System Center: アプリケーションと更新プログラムをブランチ オフィスに展開する
System Center Steve Rachui

アプリケーションと更新プログラムをブランチ オフィスに展開する
概要:
  • ブランチ配布ポイントを構成する
  • 境界について
  • データを準備する 3 つの方法

マイクロソフトは、システム管理用の次世代ソリューションをリリースします。以前は Systems Management Server (SMS) として知られていた、新しい System Center Configuration Manager 2007 では、
魅力的な新機能が数多く提供されます。これらの役立つ機能の 1 つにブランチ配布ポイント (BDP) があります。これは、小規模のオフィスや分散したオフィスのニーズに応えることを目的として設計された新しい配布ポイントの種類です。一見したとき、および他の新機能と比較したとき、BDP はあまり重要でない追加機能のように思えるかもしれませんが、この機能の重要性は一見しただけではわかりません。
SMS の以前のバージョンでは、サーバー システムが配布ポイントをホストできる唯一のプラットフォームでした。このため、管理者は、ローカル サーバーが存在せず、低速の WAN リンクを経由して通信を行うことが多いブランチ オフィスにサービスを提供する必要がある場合、タイムリーかつ効率的にソフトウェアを配布できるインフラストラクチャを苦心して設計および構築していました。BDP は、まさにこのようなシナリオに対処することを目的として設計されました。
BDP は、ワークステーション システムとサーバー クラスのシステムの両方で動作するように設計されたコンポーネントであり、すべての Configuration Manager 2007 クライアントで使用できますが、既定では有効になっていません。すべての Configuration Manager 2007 クライアントには、BDP として動作するために必要なコードが実装されていますが、すべてのクライアントを BDP として構成する必要はありません。

BDP をセットアップする
クライアントで BDP 機能を有効にする作業は、基本的にはサーバー ベースの配布ポイントを構成する作業と同じです。まず、クライアントを新しいサイト システムとして構成 (図 1 を参照) した後、そのシステムをブランチ配布ポイントとして有効にすることを指定します (図 2 を参照)。この構成を行うことにより、BDP が、パッケージ、ソフトウェア更新プログラム、Operating System Deployment (OSD) イメージなどに使用できる配布ポイントとして一覧に表示されます。また、サイト サーバーによって、選択したクライアントで BDP 機能を有効にするポリシーが準備されます。このポリシーがダウンロードされたら、クライアントは BDP としての動作を開始します。
図 1 新しいサイト システムとしてのクライアントの構成
図 1 新しいサイト システムとしてのクライアントの構成
図 2 ブランチ配布ポイントとしてのサイト システムの構成
図 2 ブランチ配布ポイントとしてのサイト システムの構成
BDP やその他のサイト システムは、特定の境界 (SMS 2003 ではサイト境界と呼ばれていました) や境界のグループにサービスを提供したり、特定の境界に限定せずに動作したりするように構成できます。通常、Configuration Manager 2007 の境界は、IP サブネットまたは Active Directory® サイトによって定義されます。
特定の境界のグループにサービスを提供するように BDP を構成するには、サイト システム構成ウィンドウの [Enable this site system as a protected site system] (このサイト システムを保護されたサイト システムとして構成する) チェック ボックスをオンにし、サービスを提供する境界を指定します (図 1 を参照)。BDP を使用してオンデマンドでコンテンツを準備する (この後説明します) ことを計画している場合、これは必須の手順です。この手順を行わなかった場合、BDP は基本的に標準の配布ポイントと同じように動作します。

境界について
BDP 上の保護された境界の役割は、どのクライアントが BDP 上のコンテンツにアクセスできるかを定義することのみであり、BDP がどの標準の配布ポイントにアクセスして必要なコンテンツをダウンロードできるかは、これらの境界によって決定されません。たとえば、境界 A に BDP がインストールされている環境があるとします。また、この環境の境界 B には、バックグラウンド インテリジェント転送サービス (BITS) を使用する標準の配布ポイントのみが含まれており、この配布ポイントは、境界 B のクライアントのみにサービスを提供するように構成されているとします。BDP がコンテンツをダウンロードしようとした場合、ダウンロードは成功するでしょうか。保護された境界の規則に従うと、ダウンロードは失敗することが予想されます。しかし、このシナリオではダウンロードは成功します。これは、BDP のダウンロードが、標準の配布ポイントで構成されている保護された境界を認識しないためです。
BDP では、優れた柔軟性も提供されます。ブランチ オフィスの場所ごとに 1 つの BDP を有効にしたり、必要な場合は 1 つのブランチ オフィス (境界) 内で複数の BDP を有効にしたりできます。複数の BDP が同じ境界にサービスを提供するように構成されている場合、それらの BDP は、連携して負荷分散に近い機能を実現し、その境界内のクライアントにコンテンツを提供します。

データを準備する
BDP は、一度有効になると、3 つの異なる方法で必要なコンテンツを取得できます。これらの方法は、管理者による準備、オンデマンドでの準備、および手動による準備です。どの方法を使用してコンテンツを取得する場合でも、BITS に対応した 1 つ以上の標準の配布ポイントが使用可能になっていて、その配布ポイントに BDP が受信するコンテンツが準備されている必要があります。では、コンテンツの取得に使用できる 3 つの方法について見ていきましょう。
管理者による準備 これは、配布ポイントにコンテンツを準備する方法としてよく知られています。この方法を使用した場合、管理者は、手動で BDP を配布ポイントとして選択する必要があります。この操作を行うと、次のポリシー更新サイクルの間、同じサイト内にある BITS に対応した標準の配布ポイントに準備されているコンテンツをダウンロードするよう BDP に通知するポリシーが準備されます。
オンデマンドでの準備 これは、コンテンツの新しい準備方法であり、BDP に固有の方法です。この方法を使用すると、クライアントからコンテンツが要求されたときに、そのコンテンツをオンデマンドで BDP にダウンロードすることができます。BDP にコンテンツを準備するために管理者が特別な操作を行う必要はありません。つまり、BDP はパッケージ ノード内の配布ポイントとして選択されないということです。実質的には、オンデマンドでの準備機能は、コンテンツが要求されたときに BDP を配布ポイントとして選択します。この操作はバックグラウンドで自動的に実行されます。
オンデマンドでの準備を実行するには、このオプションをサポートするようにパッケージを構成する (図 3 を参照) 必要があります。また、BDP を保護することにより、コンテンツを要求するクライアントが BDP のみにアクセスでき、コンテンツが格納されている標準の配布ポイントにはアクセスできないようにする必要があります。複数の BDP が同じ境界内で構成されている場合、オンデマンドでの準備機能がいずれかの BDP にコンテンツを要求すると、すべての BDP でコンテンツが準備されることに注意してください。
図 3 パッケージのオンデマンド配布の有効化
図 3 パッケージのオンデマンド配布の有効化
手動による準備 このコンテンツの準備方法を使用する場合、その名前のとおり、管理者が手動で操作を行う必要があります。まず、コンテンツを手動で転送するようにパッケージを構成します (図 3 を参照)。その後、コンテンツを BDP に手動でコピーし、パッケージの一般的なディレクトリ構造を使用してパッケージ フォルダに格納します。
BDP はその新しいパッケージを認識し、要求側のクライアントに提供できるようにします。この方法では、リムーバブル メディアを使用してコンテンツを BDP に転送できるため、標準の配布ポイントと BDP との間の帯域幅が制限されている環境に適した方法と言えます。
ダウンロードしたコンテンツを特定のパーティションに格納するように BDP を構成できます。パーティションを指定しなかった場合は、使用するパーティションが BDP によって自動的に選択されます。コンテンツを BDP に準備するように構成したり、オンデマンド要求を処理したりしても、すぐに対象のコンテンツが BDP に準備されるわけではありません。まず、コンテンツをダウンロードできることを BDP に通知するポリシーが準備されます。BDP は、次回のポリシー サイクルでそのポリシーを受信した後、BITS によるコンテンツのダウンロードを開始します。グループ ポリシーを使用すると、使用される帯域幅と BITS によるダウンロードのスケジュールを、非常に正確に制御できます。BDP 上の配布ポイント共有と、標準の配布ポイント上の共有の外観に違いはありません。つまり、コンテンツは暗号化されないということです。

組織に適したセットアップ
既に説明したとおり、BDP の役割はブランチ オフィス用に作成されたため、ワークステーション システムでも完全に機能します。また、BDP をサーバー クラスのシステムで動作させることもできます。基になる OS は、BDP との間で確立できる接続の数に影響を与えます。ワークステーションでは最大同時接続数が 10 に制限されますが、サーバーではこのような制限がありません。このため、サポートする必要がある同時接続数によっては、サーバー システムを使用するか、ブランチ オフィス内に複数のワークステーション システムを配置したほうがよいかもしれません。また、どのプラットフォームを使用する場合でも、BITS に対応した 1 つ以上の標準の配布ポイントが使用可能になっていて、要求されるコンテンツがその配布ポイントに格納されている必要があります。
インフラストラクチャの構成にかかわらず、BDP を使用すると、組織全体へのソフトウェアの配布フローをよりきめ細かく制御できるようになります。ダウンロードの調整やスケジュール設定を行うことができる BITS が組み込みでサポートされることにより、さらにきめ細かい制御と予測可能性を必要とする管理者に大きなメリットが提供されます。

Steve Rachui は、マイクロソフトのプロダクト サポート サービス グループに所属する マネジャビリティ サポート エスカレーション エンジニアです。バージョン 1.2 のころから SMS のサポートを担当しています。Steve の連絡先は steverac@microsoft.com (英語のみ) です。
© 2007 Microsoft Corporation and CMP Media, LLC. All rights reserved; 許可なしに一部または全体を複製することは禁止されています.