 TechNet Magazine August 2007

TechNet Magazine August 2007

System Center: Évolution de SMS : une nouvelle solution puissante pour gérer vos systèmes

La gestion des systèmes est en passe de devenir beaucoup plus simple. Suivez la visite guidée de System Center Configuration Manager 2007 et découvrez comment il peut simplifier les tâches clés, telles que le déploiement de mises à jour logicielles, la gestion d'appareils mobiles et la maintenance des configurations système.

John Orefice System Center: Déploiement d'applications et de mises à jour dans les succursales

Les points de distribution de succursale, l'une des nouvelles fonctionnalités de Configuration Manager 2007, peuvent au premier abord apparaître comme un ajout plutôt mineur. Mais si vous regardez plus en détail, vous verrez qu'elle offre de nouvelles possibilités indispensables pour gérer la distribution de logiciels aux succursales.

Steve Rachui System Center: Mise en route de System Center Essentials 2007

Conçu spécifiquement pour les entreprises de taille moyenne, System Center Essentials offre une solution unifiée pour la surveillance, l'administration et le dépannage des systèmes. Voici un guide détaillé pour l'installation et la configuration d'Essentials 2007 pour votre réseau.

David Mills System Center: Surveillez vos serveurs grâce à Operations Manager 2007

Operations Manager 2007, l'incarnation la plus récente de MOM, introduit des améliorations importantes, notamment de nouvelles interfaces d'administration, des rapports améliorés, une prise en charge pour les solutions métier, de nouvelles options de sécurité, et bien plus encore.

Pete Zerger System Center: Migration de MOM vers Operations Manager 2007

Prêt à migrer sur Operations Manager 2007 ? En raison de modifications architecturales, il n'existe pas de chemin de mise à niveau simple et direct à partir d'une ancienne version de MOM. C'est pourquoi nous vous conseillons de suivre l'un des plans de migration présentés ici.

Andy Dominey System Center: Virtualisez vos applications avec Microsoft SoftGrid

Les applications virtualisées offrent de nombreux avantages, notamment en améliorant l'expérience utilisateur et en simplifiant l'administration des systèmes. Découvrez comment Microsoft SoftGrid fournit des applications virtuelles, s'adapte à votre infrastructure et permettre à votre entreprise de gagner du temps et de l'argent.

Ahmer Sabri and Kedar Shah Le mot du rédacteur en chef: Dynamique et optimal

Joshua Trupin Boîte à outils: Nouveaux produits pour les professionnels de l’informatique

Greg Steen Forum aux questions sur SQL: Recherche de verrous, requêtes de grande ampleur, statistiques d'E/S et bien plus encore

Edited by Nancy Michell Coup de projecteur sur les utilitaires: BGInfo

Ne serait-ce pas formidable si vous pouviez voir toutes les informations que vous avez besoin de connaître sur un ordinateur (son nom, son adresse IP, sa passerelle, son espace disque libre, etc.) dans un seul emplacement ? Vous le pouvez, grâce à cet outil gratuit de Sysinternals.

Lance Whitney Le petit câbleur: Configuration automatique IPv6 dans Windows Vista

IPv6 ne se limite pas à étendre l'espace d'adressage de 32 bits à 128 bits. Examinons comment les hôtes IPv6 peuvent se configurer automatiquement, même sans avoir recours à un protocole de configuration des adresses.

Joseph Davies Windows PowerShell: La puissance de filtrage

Le pipeline n'est pas destiné uniquement aux cmdlets. Découvrez comment vous pouvez utiliser le pipeline Windows PowerShell pour ajouter à vos scripts des fonctionnalités de filtrage très pratiques.

Don Jones Hé, vous le scripteur !: Qui êtes-vous ?

Avec Active Directory, les utilisateurs peuvent avoir toute une série d'identités, par exemple givenName, displayName, userPrincipalName ou distinguishedName. En tant qu'administrateur système, comment obtenez-vous toutes ces informations sur un utilisateur ? Avec un script, bien sûr.

The Microsoft Scripting Guys Vigilance sécurité: Améliorations de l'infrastructure de clé publique (PKI) dans Windows

Dans Windows Vista et Windows Server 2008, la plate-forme Windows PKI permet la prise en charge d'algorithmes avancés, de la vérification de validité en temps réel et d'une plus grande facilité de gestion. Découvrez les nouvelles fonctionnalités de PKI et voyez comment elles peuvent être utilisées pour réduire les coûts tout en améliorant la sécurité.

John Morello Histoires de Bureau: Familiarisation avec le protocole RDP

Le protocole RDP (Remote Desktop Protocol), qui vous permet d'accéder à des ordinateurs à distance, est un outil utile qui s'améliore avec chaque version de Windows. Découvrez le Bureau à distance, et apprenez-en plus sur les nombreux avantages offerts, mais également ses restrictions.

Wes Miller Sur le terrain: Entretiens sur messagerie instantanée

Vous avez un poste à pourvoir et une importante pile de curriculum vitae provenant du monde entier. Comment restreindre rapidement votre recherche ? La réponse pourrait être de faire passer des entretiens par le biais de la messagerie instantanée. Voici le témoignage d'un développeur.

Nathan G. Jensen La vie secrète de Windows: L'Explorateur Windows ne fait pas de la littérature

Pourquoi est-il impossible de copier une liste de fichiers dans l'Explorateur Windows et de les coller ensuite en tant que texte pour obtenir les noms de fichier ? L'équipe de Windows a essayé d'inclure cette fonctionnalité, mais cela n'a pas fonctionné comme prévu.

Raymond Chen


 System Center: &#201;volution de SMS&#160;: une nouvelle solution puissante pour g&#233;rer vos syst&#232;mes
System Center John Orefice

Évolution de SMS : une nouvelle solution puissante pour gérer vos systèmes
Vue d'ensemble:
  • Déploiement de système d'exploitation
  • Gestion des mises à jour logicielles
  • Gestion de la configuration souhaitée

Systems Management Server (SMS) 2003 est devenu un outil de gestion de la configuration et de livraison de logiciel essentiel pour les administrateurs du monde entier. Microsoft se prépare à présent
à introduire une nouvelle version de sa solution de gestion d'entreprise. Cette nouvelle version offrant de nouvelles fonctionnalités a été rebaptisée : System Center Configuration Manager 2007.
System Center est une famille de produits Microsoft conçus pour simplifier la gestion quotidienne de votre infrastructure informatique complexe tout en optimisant sa rentabilité. Les solutions System Center reposent sur l'automation et les méthodes recommandées dérivées de Microsoft® Operations Framework (MOF) et d'Information Technology Infrastructure Library (ITIL), et peuvent être utilisées à tous les niveaux d'une organisation.
Configuration Manager 2007 n'est qu'un élément de la famille System Center. System Center Data Protection Manager assure la sauvegarde et la récupération des systèmes d'entreprise. System Center Operations Manager vous offre une surveillance et une automation proactives des systèmes. System Center Capacity Planner peut être utilisé pour la planification des capacités et les analyses de simulation des déploiements d'infrastructure. Et la liste ne cesse de s'allonger (pour plus d'informations visitez www.microsoft. com/systemcenter).
Dans cet article, je vous présenterai plusieurs fonctionnalités nouvelles et améliorées prévues pour Configuration Manager 2007, d'après la version bêta la plus récente. Je vous donnerai un aperçu de ce que vous pouvez attendre de cette version très prometteuse et j'espère vous faire découvrir comment Configuration Manager pourra aider votre organisation à gagner du temps et de l'argent.

Nouvelle interface utilisateur Administrateur
Depuis SMS 1.0, l'une des nouvelles fonctionnalités les plus fréquemment demandées pour SMS est une nouvelle interface utilisateur améliorée. Microsoft répond à cette requête en apportant plusieurs améliorations à l'interface utilisateur Administrateur System Center Configuration Manager 2007. Pour activer ces nouvelles fonctionnalités, la nouvelle console de Configuration Manager 2007 est basée sur C# et Microsoft .NET Framework et s'exécute par-dessus la technologie Microsoft Management Console (MMC) 3.0. De plus, comme dans SMS 2003, l'interface utilisateur est extensible à l'aide d'un kit de développement logiciel pour permettre aux utilisateurs de la console de créer leurs propres modules complémentaires en fonction de leurs besoins individuels.
La figure 1 reproduit la nouvelle console avec le nœud Gestion de l'ordinateur développé, illustrant ainsi toutes les nouvelles fonctions de gestion disponibles. Vous remarquerez également le nouvel habillage de la section Configuration du site SMS, qui décrit les tâches courantes à réaliser pour que Configuration Manager soit opérationnel après l'installation. La section Liens et ressources contient les tâches permettant de réduire le temps de navigation dans la console pour la recherche des fonctions courantes.
Figure 1 Interface d'administration de Configuration Manager
Figure 1 Interface d'administration de Configuration Manager
Cette nouvelle console offre de nombreux avantages et fonctionnalités, notamment la possibilité de sélectionner et de glisser-déplacer plusieurs éléments (particulièrement utile pour la gestion des regroupements), des dossiers de recherche permettant d'organiser les éléments dans la console virtuellement plutôt que physiquement, un volet Actions permettant d'exécuter les tâches disponibles pour la section en cours, un volet Aperçu permettant d'afficher les informations récapitulatives sur un élément spécifique (par exemple, une image du système d'exploitation), des pages d'accueil récapitulant les informations concernant un sujet particulier tel que le déploiement de logiciels et une structure organisationnelle améliorée offrant une navigation extrêmement simplifiée.
Comme mentionné ci-dessus, le volet Actions constitue l'une des améliorations majeures du nouvel habillage de la console. Il offre la possibilité de voir les actions appropriées en fonction du contexte de la section de la console que vous êtes en train d'utiliser. Par exemple, si vous consultez le regroupement Tous les systèmes, le volet Actions proposera des actions telles que Mise à jour de l'adhésion à un regroupement et Installer l'agent (voir la figure 2).
Figure 2 Les actions disponibles sont spécifiques à l'affichage en cours
Figure 2 Les actions disponibles sont spécifiques à l'affichage en cours
De plus, Configuration Manager 2007 introduit un nouveau concept appelé pages d'accueil, qui vous permet d'examiner très rapidement l'état d'une fonction spécifique telle que Mises à jour de logiciels, Distribution de logiciels ou Gestion de la configuration souhaitée. Vous pouvez utiliser cette fonctionnalité au sein de la console sans exécuter de rapports ou rechercher les données depuis un autre emplacement. Vous trouverez d'autres exemples de pages d'accueil dans cet article lorsque je présenterai les différentes fonctionnalités du produit.

Rôles de serveur et points de distribution
Configuration Manager 2007 introduit plusieurs nouveaux rôles de serveur pour permettre certaines des nouvelles fonctionnalités que je vais aborder ici. Ceux-ci incluent le Point d'état de secours, le Point de service PXE, le Point de distribution de succursale, le Point de migration de l'état, le Point de mise à jour logicielle et le Validateur d'intégrité du système. Comme tous les rôles de serveur SMS et Configuration Manager, ces rôles peuvent être hébergés sur le même serveur dans la mesure où des exercices de planification de capacité appropriés sont effectués.
Le point de distribution de succursale est important et diffère du point de distribution traditionnel pour deux raisons. Pour commencer, il ne doit pas forcément être installé sur un système d'exploitation serveur ; il peut être installé sur Windows Vista® ou Windows® XP. Il s'agit du seul rôle Configuration Manager qui peut être installé sur un système d'exploitation client. Il est très utile pour les succursales sans serveur local ou dans les cas où un service informatique souhaite supprimer des serveurs de succursales plus petites par souci d'économies et pour réduire les frais administratifs. Dans les cas où seuls des ordinateurs exécutant Windows XP ou Windows Vista sont disponibles, le Point de distribution de succursale peut être utilisé pour réduire le trafic WAN en faisant en sorte que les clients n'extraient pas de packages du WAN lorsqu'ils sont disponibles localement.
La seconde différence entre le point de distribution de succursale et un point de distribution standard concerne son mode de connexion aux autres points de distribution. Les données de réplication des points de distribution traditionnels ne sont pas restreintes ou planifiées à moins qu'elles ne soient transférées d'un site primaire vers un site secondaire. C'est pour cette raison qu'un grand nombre d'organisations copient uniquement des packages vers les succursales pendant la nuit, retardant ainsi la distribution de logiciels jusqu'à ce que ces packages soient disponibles localement.
Le Point de distribution de succursale utilise le service BITS (Background Intelligent Transfer Services) pour télécharger les informations depuis d'autres points de distribution. Ce service est incomparable en termes de limitation de la bande passante sur une connexion WAN entre une succursale et un point de distribution situé dans le centre de données central, surtout lorsqu'il n'y a pas de site Configuration Manager secondaire situé dans la succursale. La figure 3 illustre la nouvelle boîte de dialogue Propriétés du point de distribution, utilisée pour transformer un point de distribution standard en point de distribution de succursale.
Figure 3 Configuration d'un point de distribution de succursale
Figure 3 Configuration d'un point de distribution de succursale
SMS 2003 avait introduit une technologie de réplication qui permettait la réplication delta par fichier de packages à partir d'un serveur de site vers un point de distribution. Cette technologie fonctionnait bien pour les packages SMS qui étaient composés de plusieurs petits fichiers. Si, par exemple, un administrateur SMS devait modifier un seul fichier, ou plusieurs petits fichiers dans un gros package SMS, seuls ces fichiers modifiés dans le package étaient répliqués plutôt que l'ensemble du package.
Dans la mesure où le déploiement de système d'exploitation devient plus courant dans Configuration Manager 2007, vous souhaiterez vous assurer que la réplication de packages d'image de système d'exploitation et d'autres packages volumineux sur votre infrastructure et sur des connexions WAN se passe le plus efficacement possible. Dans cette optique, Configuration Manager 2007 introduit la réplication delta binaire de serveur de site à serveur de site, de serveurs de site à points de distribution et de points de distribution à points de distribution de succursale.
Commencez par exemple avec une nouvelle image de déploiement de Windows Vista contenant plusieurs applications préinstallées. Ce package peut atteindre 6 Go et, comme il s'agit d'une image au format Windows Imaging (WIM), ce package contient un fichier unique de 6 Go. Comme décrit plus haut, dans SMS 2003, si la nouvelle image WIM a été ouverte pour permettre la modification d'un paramètre ou l'ajout d'un nouveau correctif de 2 Mo récemment publié, étant donné que l'image consiste en un seul fichier WIM, l'ensemble du package SMS de 6 Go devra être répliqué vers les points de distribution. En revanche, avec la réplication delta binaire de Configuration Manager 2007, si un paramètre est modifié ou si un correctif est ajouté au package d'image WIM, seul ce correctif ou paramètre de 2 Mo sera répliqué sur l'infrastructure au lieu de l'ensemble des 6 Go.

Processus courants pour les appareils mobiles
Peu après la sortie de SMS 2003, Microsoft a publié le Pack de gestion des appareils pour la gestion des appareils mobiles Windows CE et Pocket PC. Comme les appareils mobiles deviennent de plus en plus répandus dans les entreprises, leur gestion devient une priorité plus importante. Étant donné cette tendance, Configuration Manager 2007 représente une amélioration par rapport au Pack de gestion des appareils SMS 2003 et offre une nouvelle solution intégrée pour la gestion des appareils mobiles tels que les Smartphones Windows Mobile® et les téléphones Pocket PC, qui vous permet de les gérer comme des serveurs, des ordinateurs portables et des ordinateurs de bureau.
La gestion de base des appareils mobiles inclut l'inventaire matériel et logiciel, des fonctionnalités de regroupement des fichiers, la distribution logicielle et des paramètres pour la gestion des mots de passe et de la stratégie de sécurité. Grâce à la gestion client sur Internet de Configuration Manager 2007, tous les appareils peuvent maintenant être gérés sur votre intranet et sur Internet. Cette fonctionnalité est formidable pour les Smartphones ou autres appareils qui sont très rarement, voire jamais, sur le réseau local de l'entreprise.
Le processus de déploiement de l'agent a également été amélioré. Les mises à niveau client par voie hertzienne sont dorénavant prises en charge et la distribution client peut être automatisée à l'aide de la console Configuration Manager.

Fenêtres de maintenance
Un grand nombre des clients d'entreprise avec lesquels je travaille ont des fenêtres de maintenance prédéfinies pour les serveurs et pour certains bureaux stratégiques. De plus, ils demandent régulièrement des conseils sur la façon de déployer des applications volumineuses, telles que Microsoft Office System 2007, sans interruption de l'utilisateur final pendant les heures de bureau normales.
Configuration Manager 2007 introduit une nouvelle fonctionnalité appelée fenêtres de maintenance. Celle-ci vous permet de définir des intervalles pendant lesquels les installations peuvent survenir pour un regroupement particulier. Ceci vous donne la liberté de rendre une publication obligatoire sans vous soucier des répercussions qu'entraînerait l'installation du package pendant les heures de bureau normales ou à des moments inopportuns pour les utilisateurs.
Envisagez, à titre d'exemple, un déploiement de package Office System 2007. Vous souhaitez pouvoir faire parvenir cette application à vos utilisateurs finaux le plus vite possible, mais vous ne souhaitez pas que cela interfère avec le travail en journée. Vous pouvez définir la fenêtre de maintenance de façon à préciser l'intervalle pendant lequel vous souhaitez que le système réalise l'installation (par exemple entre 20 heures et 6 heures). Si un jour, le système n'est pas disponible pendant cette fenêtre de maintenance pour une raison ou une autre, Configuration Manager attendra le prochain intervalle défini dans la fenêtre de maintenance afin de garantir que les activités de l'entreprise ne sont pas interrompues de manière inattendue. Vous avez également la possibilité d'ignorer les fenêtres de maintenance au niveau de la publication, ce qui vous permet de déployer une mise à jour critique dès que possible malgré les éventuelles restrictions en place.

Déploiement de système d'exploitation
La fonctionnalité de déploiement de système d'exploitation représente le domaine spécifique le plus important pour Configuration Manager 2007. Microsoft a conçu Configuration Manager comme le moyen principal de déployer des systèmes d'exploitation pour les plates-formes de serveur et de poste de travail. Les meilleures fonctionnalités du Pack de déploiement de système d'exploitation SMS 2003 ont été intégrées dans Configuration Manager 2007 pour modifier radicalement le mode de gestion des déploiements de systèmes d'exploitation.
Comme vous le savez peut-être, Windows Vista a introduit un nouveau format Windows Imaging pour le déploiement de système d'exploitation. Ce format offre plusieurs avantages, notamment le fait que Configuration Manager 2007 importe le format d'image WIM en mode natif pour que les administrateurs puissent travailler sur les images et les déployer directement depuis la console.
Autre nouvelle fonctionnalité de déploiement importante dans Configuration Manager : le séquenceur de tâches intégré. Si vous connaissez Microsoft Solution Accelerator for Business Desktop Deployment (BDD), vous trouverez de nombreuses similarités dans les fonctionnalités et options disponibles dans Configuration Manager, mais constaterez une différence majeure : vous ne devrez plus écrire de scripts pour déployer ou capturer des images de système d'exploitation. De plus, grâce au Séquenceur de tâches, le processus de déploiement de système d'exploitation se fait entièrement sans intervention.
Le Séquenceur de tâches permet d'afficher toutes les étapes que vous devez exécuter au cours de votre déploiement de système d'exploitation, y compris les étapes exécutées dans l'ancien système d'exploitation avant le déploiement (migration de l'état des utilisateurs et transfert des paramètres d'application), les étapes permettant de déployer le nouveau système d'exploitation (formatage, partitions de disques, clé de produit, nom d'utilisateur, entreprise, paramètres de licence, installation des pilotes) et les étapes requises une fois le nouveau système déployé (installation d'applications supplémentaires, installation des mises à jour, migration de l'état des utilisateurs). Pour illustrer cette fonctionnalité, la figure 4 reproduit l'Éditeur de séquence de tâches en mettant en évidence certaines des fonctionnalités que vous pouvez utiliser dans un déploiement Windows Vista.
Figure 4 Étapes de modification pour un déploiement de système d'exploitation
Figure 4 Étapes de modification pour un déploiement de système d'exploitation
Outre le Séquenceur de tâches, Configuration Manager 2007 offre plusieurs autres améliorations du déploiement de système d'exploitation, comme illustré à la figure 5. Par exemple, Configuration Manager prend en charge le déploiement sans système d'exploitation grâce à l'environnement PXE pour les plates-formes x86 et x64 avec gestion des pilotes de périphériques. L'option de gestion des pilotes de périphériques permet à votre organisation de réduire considérablement le nombre d'images à gérer pour différents types de matériel. En associant celle-ci à la prise en charge d'image unique introduite avec le format d'image WIM de Windows Vista, vous êtes presque assuré de gagner du temps et de l'argent lors des déploiements de système d'exploitation.
Figure 5 Fonctionnalités de déploiement du système d'exploitation (Close Figure 5)

Scénario | SMS 2003 | Configuration Manager 2007
Déploiement de bout en bout | Oui | Oui
Entièrement automatisé | Oui | Oui
Mise à niveau « Wipe-and-load » | Oui | Oui
Déploiement sans système d'exploitation avec PXE | Intégration souple avec les services d'installation à distance | Intégration native avec les services de déploiement Windows
Côte à côte | Scripts BDD | Oui, via le point de migration d'état intégré
Déploiement hors ligne complet | Non | Oui
Planification de mise à niveau Windows Vista | Non | Oui
Déploiement complet de serveur | Non | Oui
Gestion des pilotes de périphériques | Non | Oui

Gestion des mises à jour logicielles
À l'instar de nombreuses autres fonctionnalités de Configuration Manager 2007, la gestion des mises à jour logicielles a été totalement repensée. Configuration Manager sépare la façon dont les mises à jour et les packages réguliers sont transmis à un agent géré en créant un nouveau canal prioritaire basé sur l'état pour toutes les mises à jour logicielles et les informations liées à la gestion de la configuration souhaitée. Le transfert d'un autre package logiciel n'interfèrera plus avec la transmission des mises à jour logicielles ou la réception de l'état des correctifs à partir de postes de travail, de portables ou de serveurs gérés.
La méthode basée sur l'état pour la gestion des mises à jour logicielles signifie également que l'état des correctifs et mises à jour n'est plus lié aux analyses d'inventaire matériel et, par conséquent, que l'Outil d'inventaire pour les mises à jour Microsoft et le catalogue des analyses ne seront plus nécessaires. À présent, Configuration Manager utilise le nouveau rôle de serveur Point de mise à jour logicielle qui exécute Windows Server Update Services (WSUS) en tant que moteur et base de données des mises à jour logicielles principaux.
WSUS vous permet d'avoir un emplacement central pour toute la gestion des mises à jour dans Configuration Manager. Ceci vous donne la possibilité de télécharger tout le contenu disponible sur Microsoft Update, y compris les mises à jour non-critiques, les pilotes et d'autres packages logiciels pour la plate-forme Microsoft. Par ailleurs, Microsoft encourage également ses partenaires à publier des mises à jour logicielles à l'aide de cette méthode. Adobe et Citrix sont deux des nombreuses entreprises qui publient actuellement des manifestes pour l'Outil d'inventaire pour les mises à jour personnalisées dans SMS 2003 R2 et prévoient de le faire pour Configuration Manager.
Ce nouveau moteur de mise à jour logicielle fournit également un état de mise à jour en quasi temps réel pour permettre des rapports et des affichages de pages d'accueil améliorés. Ces affichages personnalisés peuvent vous montrer des graphiques rapides de l'état des correctifs dans une infrastructure informatique ou pour un regroupement spécifique d'ordinateurs. La figure 6 illustre l'affichage des données de conformité à un correctif pour un bulletin spécifique à l'aide de l'un des nouveaux affichages de page d'accueil personnalisés pour la gestion des mises à jour logicielles.
Figure 6 Affichage de l'état des mises à jour logicielles
Figure 6 Affichage de l'état des mises à jour logicielles
Enfin, les modèles de déploiement de mise à jour logicielle réduisent de façon spectaculaire le nombre d'étapes requises pour transmettre de nouvelles mises à jour à un système ou regroupement. En utilisant les modèles de déploiement de mise à jour logicielle pour stocker les informations de configuration courante (notamment les paramètres permettant de choisir de forcer un redémarrage ou de déterminer si le client doit télécharger localement les correctifs depuis le point de distribution avant d'exécuter l'installation), cette fonctionnalité fait passer le nombre d'étapes requises de 18 avec l'outil d'inventaire pour les mises à jour logicielles dans SMS 2003 à 6 dans Configuration Manager 2007.

Gestion de la configuration souhaitée
La gestion de la configuration est une autre fonctionnalité très utile qui a été considérablement améliorée dans Configuration Manager 2007. Le contrôle de la configuration souhaitée de SMS 2003, publié à l'automne 2006, a fourni un grand nombre des fonctionnalités clés qui sont incluses dans la gestion de la configuration souhaitée de Configuration Manager 2007. Pour des informations complémentaires sur le contrôle de la configuration définie, consultez l'article de TechNet Magazine à l'adresse microsoft.com/technet/technetmag/issues/ 2006/09/HighStandards. La figure 7 illustre la page d'accueil Gestion de la configuration souhaitée montrant la conformité pour deux configurations de référence spécifiques.
Figure 7 Rapports sur la conformité aux configurations de référence souhaitées
Figure 7 Rapports sur la conformité aux configurations de référence souhaitées
L'élément déterminant pour la gestion de la configuration souhaitée dans Configuration Manager provient de recherches auprès de clients de Microsoft montrant que la plupart des interruptions de service sont provoquées par de mauvaises configurations du système d'exploitation ou d'une application sur des serveurs et des postes de travail stratégiques. En utilisant la fonctionnalité de gestion de la configuration souhaitée dans Configuration Manager, les administrateurs peuvent rattraper rapidement les dérives de configuration en exécutant régulièrement des analyses des configurations de référence sur les systèmes. Ces configurations de référence sont créées à partir des éléments de configuration et fournissent des informations de conformité pour un regroupement d'ordinateurs spécifique dans votre organisation.
En plus de rattraper les dérives de configuration, la gestion de la configuration souhaitée peut aider à la création de rapports de conformité à la réglementation ainsi qu'à la vérification des modifications. Dans la plupart des organisations, il y a de grandes chances que vous ayez besoin de rapports de conformité aux réglementations telles que la loi Sarbanes-Oxley (SOX), la norme PCI DSS et la loi HIPAA (Health Insurance Portability and Accountability Act). Configuration Manager 2007 peut vous fournir les rapports dont vous avez besoin grâce à la gestion de la configuration souhaitée.
Voici comment fonctionne la gestion de la configuration souhaitée. Un administrateur définit des éléments de configuration (des unités de configuration qui peuvent être détectées, appliquées et supprimées des ordinateurs). Une fois ces éléments de configuration définis, vous pouvez créer une configuration de référence qui se compose d'un ou de plusieurs de ces éléments. Ces configurations de référence sont ensuite attribuées aux regroupements de Configuration Manager pour la surveillance de la conformité et création de rapports.
Les éléments de configuration peuvent vérifier plusieurs aspects différents d'un ordinateur pour rassembler les informations, y compris la présence et la configuration d'Active Directory®, de métadonnées de fichiers, de résultats de script, de données stockées dans SQL Server™, de données de mises à jour logicielles, de WMI, de XML, de valeurs de registre, de métadonnées IIS et de Microsoft Installer. Les informations rassemblées à partir de ces différents emplacements sont stockées dans la base de données de Configuration Manager et utilisées pour vérifier si un système est conforme.
Notez que le processus de Gestion de la configuration souhaitée et le processus de transmission de nouvelles mises à jour par le biais de Configuration Manager 2007 sont dorénavant entièrement intégrés. Comme pour le nouveau moteur de mises à jour logicielles, toutes les données de gestion de la configuration souhaitée utilisent le canal prioritaire basé sur l'état. L'intégration de ces deux fonctionnalités stratégiques permet à un administrateur de définir une nouvelle base de gestion de la configuration souhaitée ou de mettre à jour une configuration existante avec de nouvelles mises à jour dans le cadre du processus de déploiement des mises à jour.

Gestion client Internet
Vous est-il déjà arrivé qu'un ordinateur se déconnecte du réseau pendant assez longtemps pour que l'objet Ordinateur se trouvant dans SMS devienne obsolète ? Si j'en crois les conversations que j'ai eues avec mes clients, ceci semble assez fréquent. Heureusement, Configuration Manager 2007 introduit une nouvelle gestion de client sur Internet. Cette fonctionnalité fonctionne de la même façon que Microsoft Office Outlook® communique avec Exchange Server via HTTPS sans réseau privé virtuel (VPN). Si vous ne connaissez pas ce scénario, cela signifie simplement que vous obtenez une communication plus sécurisée avec les ordinateurs clients, sans les complications que représente une connexion VPN.
La gestion client sur Internet vous permet de gérer des ordinateurs sur Internet avec le même niveau de contrôle que les ordinateurs de l'intranet. En fait, toutes les fonctionnalités abordées dans cet article fonctionneront avec la gestion client sur Internet, sauf le déploiement de système d'exploitation, wake-on-LAN et les outils à distance puisqu'ils utilisent des ports différents pour la communication et ne peuvent pas être transférés par tunnel SSL ou TLS. Voici quelques bons exemples de situations où la gestion client sur Internet entre en jeu : périphériques de vente pour les restaurants, les magasins, et les stations-services ; ordinateurs aux domiciles des employés et les personnes mobiles telles qu'une force de vente distribuée ou une équipe de consultants.
Il vous faudra satisfaire certaines exigences avant d'activer la gestion client sur Internet dans votre infrastructure Configuration Manager 2007. Pour commencer, vous aurez besoin d'une infrastructure de clé publique (PKI) pour attribuer des certificats numériques à tous les agents gérés par Configuration Manager. Ceci vous permet d'utiliser l'authentification mutuelle entre les serveurs Configuration Manager et tous les agents de gestion afin de garantir que les données que vous recevez sont chiffrées et proviennent d'une source de confiance. Il vous faudra également un terminateur SSL pour servir de point de connexion entre les serveurs Configuration Manager et tous les clients basés sur Internet. Microsoft Internet Security and Acceleration (ISA) Server 2006 est une solution logicielle répondant à ces exigences.
C'est dans la gestion des clients sur Internet qu'est utilisé le nouveau rôle de serveur Point d'état de secours. Si l'un de vos agents basés sur Internet ne communique pas correctement ou si un certificat expire, l'agent signalera le problème au point d'état de secours disponible dans le réseau de périmètre de votre organisation. Ceci garantit que vous ne perdrez jamais le contact avec vos systèmes gérés sur Internet. De plus, les clients peuvent passer de la gestion Internet à la gestion intranet automatiquement pour mieux exploiter les ressources appropriées aux moments appropriés.

Autres nouvelles fonctionnalités
Bien qu'elle ne soit pas considérée comme stratégique, la fonctionnalité Wake-on-LAN s'avère extrêmement utile pour les administrateurs qui souhaitent effectuer rapidement et discrètement une distribution logicielle, une mise à jour logicielle ou un déploiement de système d'exploitation. Configuration Manager 2007 active la fonctionnalité Wake-on-LAN pour tous les agents gérés par l'intranet dotés d'une carte réseau compatible. La figure 8 illustre un exemple d'utilisation de la fonction Wake-on-LAN pour une publication dans le tout nouvel Assistant Nouvelle publication. Dans le cas présent, je suis en train de déployer un nouveau package sur un groupe d'ordinateurs. Lorsqu'un appareil compatible Wake-on-LAN est éteint, si ce paramètre est activé dans l'Assistant, Configuration Manager démarre le système pour déployer le package qui a été défini par la publication.
Figure 8 Wake-on-LAN dans une publication de distribution logicielle
Figure 8 Wake-on-LAN dans une publication de distribution logicielle
Le Contrôle à distance a été complètement remodelé dans Configuration Manager pour proposer une solution plus sécurisée et fiable avec des performances beaucoup plus rapides. Les anciens outils qui étaient en place depuis SMS 1.0 ont été remplacés dans Configuration Manager par la technologie de collaboration native de Windows Vista, qui repose sur le protocole RDP. Les fonctionnalités de base sont les mêmes que dans SMS 2003 en ce sens qu'il n'est pas nécessaire que les utilisateurs finaux acceptent les nouvelles sessions. Cependant, trois nouveaux niveaux d'accès ont été introduits : Contrôle total, Affichage uniquement et Aucun. Outre cette nouvelle technologie, Configuration Manager 2007 est toujours intégré à l'Assistance à distance pour les cas où cette fonctionnalité est nécessaire.

Conclusion
Je vous ai présenté plusieurs des nouvelles fonctionnalités et améliorations de System Center Configuration Manager 2007. Ces fonctionnalités ont été conçues pour aider à atténuer l'effort administratif, permettre de nouvelles charges de travail et réduire les coûts au sein de votre environnement informatique. Avec Configuration Manager 2007, comme avec les autres produits de la famille System Center, vous serez équipé pour contrôler les infrastructures informatiques les plus exigeantes tout en donnant à votre entreprise un avantage compétitif.
Outre les fonctionnalités présentées dans cet article, le produit a bénéficié de nombreuses autres améliorations, telles que l'intégration de la protection de l'accès réseau Windows Server® 2008 et des fonctionnalités de gestion du parc logiciel améliorées basées sur la même technologie Asset Intelligence que dans SMS 2003 SP3. Je vous encourage à télécharger la version d'évaluation ou la version RTM de Configuration Manager 2007 pour voir par vous-même ces fonctionnalités en action dans votre infrastructure.
Pour plus d'informations et une présentation de tous les produits de la famille System Center, visitez le site microsoft.com/systemcenter. D'ici, vous pouvez accéder à n'importe quelle solution dans la famille System Center, y compris Configuration Manager.

John Orefice est TSP (Technology Solution Professional) dans la zone des États mid-atlantiques de Microsoft. Il travaille sur les solutions de gestion Microsoft depuis plusieurs années, dans un premier temps en tant que consultant auprès de Microsoft Consulting Services (MCS), avant de rejoindre son poste actuel. Vous pouvez le contacter à l'adresse suivante : john.orefice@microsoft.com.
© 2007 Microsoft Corporation et CMP Media, LLC. Tous droits réservés. Toute reproduction, totale ou partielle, est interdite sans autorisation préalable.


 System Center: D&#233;ploiement d'applications et de mises &#224; jour dans les succursales
System Center Steve Rachui

Déploiement d'applications et de mises à jour dans les succursales
Vue d'ensemble:
  • Configuration d'un point de distribution de succursale
  • Tout sur les limites
  • Trois approches de la mise en service des données

Microsoft est sur le point de mettre sur le marché sa solution de nouvelle génération pour l'administration de systèmes. Anciennement appelé Systems Management Server (SMS), le nouveau System Center Configuration Manager 2007
dispose de nouvelles fonctionnalités qui ne manqueront pas de vous impressionner. Le point de distribution de succursale, un nouveau type de point de distribution spécialement conçu pour répondre aux besoins des sites de petite taille ou distribués. À première vue, et par rapport aux autres nouvelles fonctionnalités, le point de distribution de succursale peut apparaître comme un ajout mineur, mais ne négligez trop vite cette fonctionnalité.
Avec les versions précédentes de SMS, les systèmes serveurs étaient les seules plates-formes prises en charge pour l'hébergement des points de distribution. Par conséquent, les administrateurs qui devaient fournir des services aux succursales, lesquelles manquaient souvent de serveurs locaux et communiquaient à l'aide de connexions WAN plus lentes, rencontraient toujours des difficultés pour concevoir et assembler une infrastructure permettant la distribution opportune et efficace des logiciels. Ce scénario correspond exactement au problème que le point de distribution de succursale a été conçu pour résoudre.
Le point de distribution de succursale, conçu pour fonctionner sur des postes de travail et des systèmes de type serveur, est un composant disponible, bien qu'il ne soit pas activé par défaut, sur chaque client Configuration Manager 2007. Bien que chaque client Configuration Manager 2007 dispose du code nécessaire pour fonctionner en tant que point de distribution de succursale, tous les clients ne doivent pas être configurés de la sorte.

Configuration d'un point de distribution de succursale
L'activation de la fonction de point de distribution de succursale revient à configurer un point de distribution serveur quelconque. Démarrez en configurant un client en tant que nouveau système de site (comme illustré à la figure 1), puis indiquez qu'il s'agit d'un point de distribution de succursale (comme indiqué à la figure 2). Avec cette configuration, le point de distribution de succursale est répertorié en tant que point de distribution disponible pour les packages, les mises à jour logicielles, les images de déploiement de système d'exploitation, et ainsi de suite. La stratégie sera préparée par le serveur de site et ciblée vers le client sélectionné qui activera la fonction de point de distribution de succursale. Une fois cette stratégie téléchargée, le client commencera à agir en tant que point de distribution de succursale.
Figure 1 Configuration du client en tant que nouveau système de site
Figure 1 Configuration du client en tant que nouveau système de site
Figure 2 Configuration du système de site en tant que point de distribution de succursale
Figure 2 Configuration du système de site en tant que point de distribution de succursale
Un point de distribution de succursale, ou tout système de site, peut être configuré pour traiter une limite particulière (anciennement appelé limites de site dans SMS 2003) ou un groupe de limites. Il peut également être configuré pour fonctionner sans limite spécifique. Les limites dans Configuration Manager 2007 sont généralement définies par le sous-réseau IP ou le site Active Directory®.
Pour configurer un point de distribution de succursale de façon à servir une série de limites particulière, sélectionnez l'option « Activer ce système de site en tant que système de site protégé » dans la fenêtre de configuration du système de site, puis spécifiez les limites qui doivent être servies, comme illustré à la figure 1. Notez que cette étape est obligatoire si vous souhaitez utiliser le point de distribution de succursale pour configurer la mise en service de contenu à la demande (que je décrirai ultérieurement). Si cette étape est omise, le point de distribution de succursale fonctionnera essentiellement en tant que point de distribution standard.

À propos des limites
Les limites protégées sur un point de distribution de succursale ne sont là que pour définir les clients qui pourront accéder au contenu sur le point de distribution de succursale. Elles ne jouent aucun rôle dans la façon de déterminer le point de distribution standard auquel un point de distribution de succursale peut accéder pour télécharger le contenu dont il a besoin. Supposons, par exemple, un environnement avec un point de distribution de succursale installé sur la Limite A. Supposons maintenant que la Limite B contient le seul point de distribution standard utilisant le service BITS (Background Intelligent Transfer Service) et que ce point de distribution est configuré pour servir uniquement les clients de la Limite B. Lorsque le point de distribution de succursale tentera de télécharger du contenu, y parviendra-t-il ? Selon les règles normales des limites protégées, on peut penser qu'il échouerait. Cependant, dans ce scénario, le téléchargement réussirait, parce que les téléchargements de point de distribution de succursale n'honorent aucune limite protégée configurée sur des points de distribution standard.
Les points de distribution de succursale offre également une grande flexibilité. Il est possible d'activer un point de distribution de succursale unique par succursale ou, si nécessaire, d'activer plusieurs points de distribution de succursale dans une seule succursale (limite). Lorsque plusieurs points de distribution de succursale sont configurés pour servir les mêmes limites, ils travaillent ensemble un peu comme l'équilibrage des charges pour fournir le contenu aux clients au sein de ces limites.

Mise en service de données
Une fois activé, un point de distribution de succursale peut obtenir le contenu dont il a besoin de trois façons différentes : mise en service par l'administrateur, mise en service à la demande et mise en service manuelle. Quelle que soit la méthode utilisée pour obtenir le contenu, au moins un point de distribution compatible BITS standard doit être disponible et contenir le contenu que le point de distribution de succursale recevra. Examinons les trois méthodes utilisables pour obtenir le contenu.
Mise en service par l'administrateur Il s'agit de la méthode de fourniture de contenu sur un point de distribution courante. Avec cette approche, un administrateur doit sélectionner manuellement le point de distribution de succursale en tant que point de distribution. Cette opération entraîne la préparation d'une stratégie indiquant au point de distribution de succursale de télécharger le contenu mis en service à partir d'un point de distribution BITS standard au sein du même site pendant le cycle de mise à jour de la stratégie suivante.
Mise en service à la demande Il s'agit d'une nouvelle méthode de fourniture de contenu spécifique au point de distribution de succursale. Cette approche permet au contenu d'être téléchargé à la demande vers le point de distribution de succursale lorsqu'il est demandé par un client. L'administrateur ne décide pas de mettre en service le contenu sur le point de distribution de succursale, ce qui signifie que le point de distribution de succursale n'est pas sélectionné en tant que point de distribution dans le nœud de packages. La mise en service à la demande entraîne la sélection effective du point de distribution de succursale en tant que point de distribution lorsque la requête de contenu est effectuée. Ceci se produit en coulisses et est automatique.
La mise en service à la demande ne peut avoir lieu que si le package est configuré pour la prise en charge de cette option (voir la figure 3) et si le point de distribution de succursale est protégé pour s'assurer que les clients qui demandent le contenu sont uniquement capables d'accéder au point de distribution de succursale et ne peuvent pas accéder aux points de distribution standard disposant du contenu. Notez que si plusieurs points de distribution de succursale sont configurés dans les mêmes limites protégées, une requête de mise en service à la demande à une limite entraînera la mise en service du contenu sur toutes les limites.
Figure 3 Activation de la distribution à la demande d'un package
Figure 3 Activation de la distribution à la demande d'un package
Mise en service manuelle Comme son nom l'indique, cette méthode de fourniture du contenu nécessite l'action manuelle de l'administrateur. Le package doit être configuré pour indiquer que le contenu sera transféré manuellement, comme illustré à la figure 3. Le contenu doit ensuite être copié manuellement sur le point de distribution de succursale dans le dossier Packages à l'aide d'une structure de répertoires courante pour un package normal.
Le point de distribution de succursale reconnaîtra le nouveau package et le mettra à la disposition des clients le demandant. Dans la mesure où cette méthode permet le transfert du contenu au point de distribution de succursale à l'aide de supports amovibles, elle est idéale pour les environnements dont la bande passante est limitée entre le point de distribution standard et le point de distribution de succursale.
Vous pouvez configurer un point de distribution de succursale de sorte à enregistrer le contenu téléchargé sur une partition particulière. Si aucune partition n'est spécifiée, le point de distribution de succursale choisira automatiquement une partition à utiliser. Lorsque le contenu est configuré pour être fourni sur un point de distribution de succursale ou lorsqu'une requête à la demande est traitée, le contenu cible n'est pas immédiatement disponible sur le point de distribution de succursale. Au lieu de cela, la stratégie est préparée pour alerter le point de distribution de succursale que ce contenu est disponible en téléchargement. Au cycle de stratégie suivant, le point de distribution de succursale recevra la stratégie et lancera un téléchargement BITS du contenu. Vous pouvez utiliser la stratégie de groupe pour contrôler avec précision la bande passante utilisée et la planification des téléchargements BITS. Notez sur le partage de point de distribution sur le point de distribution de succursale est identique au partage sur un point de distribution standard, ce qui signifie que le contenu n'est pas chiffré.

La configuration appropriée pour votre organisation
Comme mentionné précédemment, le rôle de point de distribution de succursale a été créé pour la succursale et est entièrement fonctionnel sur les systèmes postes de travail. Cependant, il est également possible de faire fonctionner un point de distribution de succursale sur un système serveur. Le système d'exploitation sous-jacent aura un impact sur le nombre de connexions pouvant être établies sur le point de distribution de succursale. Les postes de travail sont limités à 10 connexions simultanées, tandis que les serveurs ne font l'objet d'aucune restriction. Par conséquent, en fonction du nombre de connexions simultanées à prendre en charge, vous souhaiterez peut-être utiliser un système serveur, ou peut-être plusieurs systèmes postes de travail au sein de la succursale. Quelle que soit la plate-forme utilisée, vous devez toujours disposer d'au moins un point de distribution BITS standard avec le contenu demandé.
Quelle que soit la configuration de votre infrastructure, le point de distribution de succursale vous offrira un plus grand contrôle du flux de distribution de logiciels à l'échelle de votre organisation. La prise en charge incorporée de BITS, qui permet de limiter et planifier les téléchargements, offre un avantage clé pour les administrateurs qui ne requièrent pas un contrôle et une prévisibilité plus granulaire.

Steve Rachui est technicien de support de gestion au sein du groupe Product Support Services chez Microsoft. Il assure le support de SMS depuis la version 1.2. Vous pouvez contacter Steve à l'adresse suivante : steverac@microsoft.com.


 System Center: Mise en route de System&#160;Center&#160;Essentials&#160;2007
System Center David Mills

Mise en route de System Center Essentials 2007
Vue d'ensemble:
  • Installation et mise à niveau
  • Configuration d'Essentials 2007
  • Procédures de dépannage

System Center Essentials 2007 est une nouvelle solution de gestion informatique destinée en particulier aux entreprises de taille moyenne comptant de 50 à 500 ordinateurs et de 5 à 30 serveurs. Essentials 2007 a été développé en réponse aux nombreux commentaires de professionnels de l'informatique signalant leur besoin spécifique d'une
solution de gestion unifiée. Essentials 2007 répond à ce besoin et vous permet d'être rapidement opérationnel grâce à une installation unique et une configuration aisée.
Plus spécialement, Essentials 2007 fournit des fonctionnalités de surveillance, de dépannage et de suivi des actifs pour vous aider à assurer la sécurité et les mises à jour de votre environnement informatique. Essentials 2007 fournit également une console d'administration unifiée, où vous gérez vos serveurs, vos clients, votre matériel, vos logiciels et vos services informatiques (voir la figure 1). Par ailleurs, Essentials 2007 peut simplifier et améliorer les tâches de gestion complexes telles que le dépannage de problèmes des utilisateurs finaux, la surveillance et le déploiement de logiciels serveur et client.
Figure 1 Console d'administration Essentials 2007
Figure 1 Console d'administration Essentials 2007

Configuration requise pour Essentials 2007
Avant de commencer l'installation et la configuration d'Essentials 2007, vérifiez que vos systèmes répondent aux exigences minimales en termes de logiciels et de matériel. Votre système d'exploitation de serveur doit être Windows Server® 2003 SP1 ou R2, ou Windows® Small Business Server 2003 SP1 ou versions ultérieures. Vous aurez également besoin d'Active Directory®, d'IIS 6.0, de Microsoft® .NET Framework 2.0 et 3.0 ou version ultérieure et de SQL Server™ 2005 SP1. Le serveur lui-même nécessite au moins 1 Go de RAM, 12 Go d'espace disque libre et un processeur de 1,8 GHz. Un ordinateur disposant de 2 Go de RAM, de 20 Go d'espace disque libre et d'un processeur de 2,8 GHz ou davantage est recommandé.
Les ordinateurs clients gérés doivent exécuter Windows 2000 Professionnel SP4, Windows XP SP2 ou Windows Vista®. Les systèmes d'exploitation x86 et x64 sont pris en charge.
Les ordinateurs serveurs gérés doivent exécuter Windows 2000 Professionnel SP4 ou un système d'exploitation plus récent. Les systèmes d'exploitation x86 et x64 sont pris en charge. Dans la mesure où bon nombre d'entre vous souhaiteront probablement contrôler et administrer leur environnement informatique depuis leur propre ordinateur de bureau ou portable, vous aurez besoin d'exécuter une installation console uniquement d'Essentials 2007 sur votre ordinateur. Avant de commencer, assurez-vous qu'il exécute Windows XP SP2, Windows Vista ou Windows Server 2003 SP1.
De plus, lorsque vous planifiez votre configuration de serveur Essentials 2007, conservez suffisamment d'espace disque pour accueillir les téléchargements de mises à jour et votre base de données de rapports. Pour les mises à jour, votre base de données peut atteindre plus de 2 Go et votre contenu de mise à jour dépasser 6 Go. Les bases de données de fonctionnement et de rapports Essentials 2007 peuvent atteindre 4 Go. Prévoyez suffisamment d'espace de stockage afin de ne pas en manquer.

Installation d'Essentials 2007
L'installation d'Essentials 2007 est simple grâce à son utilisation efficace d'Assistants qui vous guident rapidement tout au long des tâches critiques telles que l'installation et la configuration, la détection des ordinateurs et la configuration des mises à jour. Lorsque vous exécutez l'assistant d'installation, Essentials 2007 vérifie automatiquement ces conditions préalables et vous indique s'il vous manque quoi que ce soit (voir la figure 2).
Figure 2 Vérification des conditions préalables à l'installation
Figure 2 Vérification des conditions préalables à l'installation
Si un élément requis n'est pas présent sur le disque Essentials 2007, un lien vers le logiciel manquant figure dans l'écran d'installation pour vous permettre de l'installer. Lorsque que vous parcourez l'Assistant d'installation, vous devez entrer un chemin pour l'emplacement d'installation d'Essentials 2007 et les informations du compte possédant les privilèges d'administrateur. L'administration des ordinateurs à l'aide d'Essentials 2007 peut devenir beaucoup plus simple si ce compte dispose des droits d'administrateur sur le serveur d'administration et tous les ordinateurs gérés. Essentials 2007 prend en charge l'utilisation d'un compte unique pour l'exécution de tâches telles que l'installation d'agents sur les ordinateurs gérés.
Si SQL Server 2005 n'est actuellement pas installé et disponible pour une utilisation avec Essentials 2007, que ce soit localement ou à distance, vous pouvez choisir de demander à Essentials 2007 d'installer localement SQL Server 2005 Express with Advanced Services pendant l'installation. Cette version de SQL Server est incluse sur le disque d'Essentials 2007. Vous pouvez également acheter une version d'Essentials 2007 avec une version de SQL Server 2005 Standard dotée d'une licence particulière pour une utilisation avec Essentials 2007.
La seule autre décision majeure que vous devez prendre pendant l'installation consiste à déterminer l'emplacement où vous souhaitez qu'Essentials 2007 enregistre vos mises à jour. Vous pouvez enregistrer les mises à jour localement et elles seront alors transmises aux ordinateurs gérés par le biais du réseau de votre serveur Essentials 2007. C'est probablement le meilleur choix, surtout si l'accès Internet a tendance à constituer un goulot d'étranglement pour votre réseau. Les mises à jour peuvent également être téléchargées directement depuis Microsoft Update chaque fois qu'un ordinateur à besoin d'être mis à jour. Si vous sélectionnez cette option, cela signifie qu'une mise à jour pour 50 ordinateurs est téléchargée 50 fois, une fois pour chaque ordinateur. Cela peut être encombrant, mais l'avantage est que vous utilisez moins d'espace disque sur votre serveur d'administration.
La topologie de déploiement de base prise en charge par Essentials 2007 consiste à installer tous les composants d'administration sur un seul serveur (voir la figure 3). Cependant, vous pouvez également choisir d'installer la console d'administration Essentials 2007 sur un poste de travail ou un ordinateur portable dans votre bureau et de contrôler à distance le serveur d'administration. Avant d'installer la console à distance, vous devez exécuter l'Assistant de configuration des fonctionnalités sur le serveur Essentials 2007. Ce processus détermine si la stratégie de groupe de domaine ou la stratégie de groupe locale est utilisée pour configurer la console à distance. Si vous sélectionnez la stratégie de groupe de domaine, assurez-vous qu'il s'est écoulé suffisamment de temps pour la mise à jour de l'ordinateur sur lequel vous installez la console à distance. Vous pouvez installer plusieurs consoles à distance si nécessaire.
Figure 3 Configuration de base d'Essentials 2007
Figure 3 Configuration de base d'Essentials 2007
Si vous gérez un environnement informatique comprenant plus de 200 ordinateurs, vous devrez installer SQL Server 2005 sur un serveur distant (pas sur le serveur d'administration Essentials 2007) et utiliser cette instance distante comme base de données Essentials 2007 (voir la figure 4). Ceci vous offrira de meilleures performances en cas d'ajout d'ordinateurs. Souvenez-vous juste que ce serveur distant doit se trouver dans le même domaine que le serveur d'administration Essentials 2007.
Figure 4 Utilisation d'une base de données SQL Server distante
Figure 4 Utilisation d'une base de données SQL Server distante
Si vous choisissez d'utiliser une instance de base de données SQL existante pendant l'installation d'Essentials 2007, vous devez vous assurer que SQL Server 2005 SP1 Reporting Services est installé et configuré sur le serveur d'administration Essentials 2007.

Mise à niveau vers Essentials 2007
Il est probable que vous exécutiez déjà Windows Server Update Services (WSUS) 2.0 ou 3.0 pour contrôler vos mises à jour Microsoft. Si oui, et si vous voulez effectuer la mise à niveau vers Essentials 2007 pour bénéficier d'une solution de gestion plus complète, Essentials 2007 vous permet d'effectuer la mise à niveau pendant le processus d'installation. Cette mise à niveau conserve les informations de mise à jour existantes, y compris les fichiers binaires, les groupes et les approbations.
Si vous utilisez Microsoft Operations Manager 2005 ou MOM 2005 Workgroup Edition pour contrôler les serveurs critiques, mais que vous souhaitez bénéficier des fonctionnalités supplémentaires d'Essentials 2007 pour effectuer l'inventaire des actifs, la distribution de logiciels et la mise à jour, vous pouvez migrer facilement vos packs d'administration en les exportant, en les convertissant et en les important ensuite directement dans Essentials 2007. Tout comme MOM 2005, Essentials 2007 utilise des packs d'administration pour contrôler les ordinateurs et les périphériques. Les packs d'administration contiennent également les informations dont vous avez besoin pour diagnostiquer et résoudre les problèmes informatiques avec succès. Si vous ne souhaitez pas migrer complètement vers Essentials 2007, vous pouvez maintenir un fonctionnement côté à côte pour conserver la surveillance stratégique et migrer quand cela vous conviendra.
Vous devez savoir que certains paramètres de WSUS ne sont pas conservés pendant la mise à niveau vers Essentials 2007. Vous perdrez les informations sur les ordinateurs, les approbations automatiques et les paramètres, ainsi que les approbations existantes pour les groupes nommés Tous les clients ou Tous les serveurs. Par conséquent, il est recommandé de supprimer les groupes nommés Tous les clients ou Tous les serveurs de WSUS avant la mise à niveau. Ensuite, vous devrez recréer ces approbations une fois l'installation d'Essentials 2007 terminée.
Notez que vous ne pouvez pas exécuter cette mise à niveau de WSUS si le serveur existant a des serveurs actifs en aval. Essentials 2007 ne prend pas en charge le mode Serveur en amont de WSUS. Comme ils ne peuvent pas être détectés de manière fiable, vous serez averti si le serveur WSUS a des serveurs en aval. Par ailleurs, il est déconseillé d'effectuer une mise à niveau si vous utilisez WSUS 2.0 ou 2.0 SP1 avec un serveur de base de données distant qui n'exécute pas SQL Server 2005 SP1 pour stocker les données de WSUS.
Une copie de sauvegarde de la base de données actuelle est automatiquement créée pendant le processus de mise à niveau. Si la mise à niveau ne réussit pas, vous pouvez restaurer l'environnement précédent en utilisant cette copie de sauvegarde. Assurez-vous que vous disposez de suffisamment d'espace pour sauvegarder la base de données WSUS actuelle en vérifiant la taille du fichier de base de données actuel et en contrôlant que l'espace libre est suffisant pour en faire une copie.

Configuration d'Essentials 2007
Essentials 2007 fournit de nombreux Assistants qui vous aident à effectuer les tâches de configuration et d'administration. L'Assistant de configuration des fonctionnalités vous permet de parcourir rapidement certaines étapes de configuration qui seraient difficiles si vous deviez les exécuter manuellement, comme la configuration de la stratégie de groupe. La figure 5 présente la première page de l'Assistant.
Figure 5 Démarrage de l'Assistant de configuration des fonctionnalités
Figure 5 Démarrage de l'Assistant de configuration des fonctionnalités
Si vous voulez utiliser un serveur proxy lors de la connexion à Internet, l'une des premières étapes consiste à entrer le nom du serveur et le numéro de port. Ensuite, vous pouvez choisir un type de stratégie de groupe pour configurer les ordinateurs gérés : stratégie de groupe locale ou de domaine. Vous pouvez également créer une exception de Pare-feu Windows si vous avez choisi d'utiliser la stratégie de groupe de domaine pour configurer les ordinateurs gérés.
Puis vient l'étape facultative de l'activation de l'assistance à distance d'ordinateurs. Celle-ci s'applique si vous avez choisi d'utiliser la stratégie de groupe de domaine pour configurer les clients. Notez que cela crée une exception de pare-feu sur tous les ordinateurs gérés pour autoriser DCOM sur le port TCP 135.
Vous pouvez choisir si vous souhaitez recueillir les résultats de la surveillance des erreurs sans agent à partir des ordinateurs gérés. Si vous sélectionnez Oui et que vous choisissez un emplacement pour enregistrer les erreurs, les ordinateurs gérés enverront les rapports d'erreur au serveur Essentials 2007. Vous pourrez alors les consulter pour voir quelles applications rencontrent des problèmes.
Vous pouvez également spécifier s'il faut transférer votre rapport d'erreur à Microsoft, et s'il faut configurer et envoyer un bilan de santé quotidien, contenant des informations sur les alertes, les mises à jour, les logiciels et l'inventaire. Si vous spécifiez que le bilan de santé quotidien doit vous être envoyé par message électronique, vous pouvez voir rapidement ce qui se passe dans votre environnement informatique lorsque vous commencez votre journée de travail.
Enfin, vous pouvez choisir de planifier une découverte quotidienne des nouveaux ordinateurs. Je recommanderais de sélectionner cette option car elle indique à Essentials 2007 d'exécuter une analyse quotidienne d'Active Directory pour rechercher les nouveaux ordinateurs et les configurer pour être administrés automatiquement.
L'exécution de l'Assistant de gestion des ordinateurs et des périphériques configuré pour la découverte automatique des ordinateurs invite le serveur Essentials 2007 à interroger Active Directory et à découvrir tous les ordinateurs répertoriés dans le domaine à administrer (voir la figure 6). Si vous sélectionnez l'option de découverte avancée, vous pouvez filtrer les périphériques découverts par type, par exemple clients uniquement ou périphériques réseau, limiter la recherche à une plage d'adresses IP donnée ou créer des requêtes avancées. Je conseille de sélectionner la découverte automatique des ordinateurs et de l'exécuter en premier lieu afin de découvrir tous les clients et tous les serveurs. Puisque Essentials 2007 contrôle également les périphériques réseau compatibles SNMP, vous pouvez ensuite réexécuter l'Assistant en mode avancé et découvrir les périphériques réseau.
Figure 6 Démarrage de l'Assistant de gestion des ordinateurs et des périphériques
Figure 6 Démarrage de l'Assistant de gestion des ordinateurs et des périphériques
Si votre réseau compte plus d'environ 300 ordinateurs, vous devrez probablement choisir la découverte avancée et fournir des critères plus spécifiques pour localiser vos ordinateurs. Lorsque vous spécifiez un compte administrateur, assurez-vous que le compte possède des privilèges d'administrateur sur les ordinateurs que vous voulez découvrir et sur lesquels vous voulez installer des agents. Une fois la découverte achevée, choisissez les ordinateurs que vous voulez gérer et cliquez sur Terminer.
Si vous avez utilisé WSUS, certains des paramètres de l'Assistant de configuration de la gestion des mises à jour vous seront familiers. Si un serveur proxy est nécessaire pour la connexion de votre serveur à Internet, entrez ses paramètres. Sélectionnez les produits pour lesquels vous voulez télécharger et déployer des mises à jour, et sélectionnez ensuite les langues dont vous avez besoin pour les mises à jour (la langue du serveur est celle utilisée par défaut). Sélectionnez les catégories de mises à jour que vous souhaitez télécharger et déployer (mises à jour critiques, mises à jour de sécurité et Services Packs par défaut). Sélectionnez, le cas échéant, quelles catégories de mises à jour vous voulez approuver automatiquement pour quels groupes. (Par défaut, les mises à jour critiques et de sécurité pour le groupe Tous les ordinateurs.) Enfin, définissez la planification pour la synchronisation des mises à jour (quotidiennement est la fréquence par défaut).
Si vous pouvez ouvrir une session avec les informations d'authentification d'Administrateur de domaine ou d'Administrateur de stratégie de groupe lors de la configuration d'Essentials 2007, nous vous conseillons de sélectionner la stratégie de groupe de domaine pour configurer les ordinateurs gérés : cela facilitera considérablement la configuration. Si vous sélectionnez la stratégie de groupe de domaine, vous pouvez automatiser la configuration des paramètres du Pare-feu Windows et de l'Assistance à distance sur tous les ordinateurs gérés. Cette option indique à Essentials 2007 de créer les configurations de stratégie pour vous. Si vous sélectionnez la stratégie locale, vous devrez effectuer manuellement une grande partie de la configuration.

Dépannage d'Essentials
Plusieurs éléments sont à prendre en compte pour la résolution des problèmes liés à la découverte des ordinateurs, au déploiement d'agent et aux communications. Pour commencer, voici un rapide aperçu de la façon dont fonctionne le processus de découverte des ordinateurs. Essentials 2007 prend vos paramètres d'entrée de recherche et crée une requête LDAP (le protocole LDAP est le langage de requête utilisé pour rechercher des objets dans Active Directory). La requête LDAP est ensuite transmise au contrôleur de domaine local et soumet une tâche de recherche, puis Active Directory renvoie les résultats au serveur d'administration. Le serveur d'administration essaie ensuite de se connecter à chaque ordinateur répertorié dans la liste pour s'assurer qu'il peut communiquer avec ces ordinateurs découverts et ainsi pouvoir installer les agents de gestion. Une fois qu'un ordinateur a été vérifié, il est ajouté à la liste d'ordinateurs découverts que vous devez gérer.
N'oubliez toutefois pas que le serveur Essentials 2007 peut ne pas être capable de découvrir des ordinateurs en cas de problèmes avec Active Directory, le réseau et le DNS ou la vérification.
Ouvrez la console d'administration Utilisateurs et ordinateurs d'Active Directory pour voir si l'ordinateur est répertorié. Cet outil est installé par défaut sur Windows Server 2003 et peut être installé sur Windows XP Professionnel à partir du Pack d'administration Windows Server 2003. Sélectionnez le dossier Requêtes sauvegardées, cliquez dessus avec le bouton droit, pointez sur Nouveau, puis cliquez sur Requête. Entrez un nom pour la requête et cliquez sur le bouton Définir la requête. Cliquez sur la liste déroulante intitulée Rechercher et sélectionnez Ordinateurs. Entrez le nom ou le préfixe de recherche et cliquez sur OK plusieurs fois pour générer la requête.
Maintenant, vérifiez que l'ordinateur apparaît dans la liste de résultats. Dans le cas contraire, ajoutez l'ordinateur à Active Directory. Assurez-vous que la propriété DNSHostname est définie correctement pour l'ordinateur ; cette propriété se trouve sur l'onglet Général de la boîte de dialogue des propriétés de l'ordinateur dans la console d'administration Utilisateurs et ordinateurs d'Active Directory.
Si vous devez contacter un ordinateur par le biais du réseau, utilisez la commande ping pour essayer d'atteindre l'ordinateur en utilisant le même nom que celui fourni à l'Assistant de découverte. Si la machine répond à une commande ping, exécutez ping avec le commutateur -a et l'adresse IP :
ping -a <IP address>
La commande suivante affichera le DNS de l'ordinateur ; il doit être identique à celui utilisé dans la commande ping originale. Utilisez cette commande pour voir le nom Netbios et le domaine enregistrés pour l'ordinateur :
nbtstat -a <computer name>
Elle exécutera la même tâche avec l'adresse IP de l'ordinateur.
nbtstat -A <IP address>
Le commutateur de commande –a est sensible à la casse. Notez que vous devez utiliser –A avec l'adresse IP. Si l'ordinateur ne répond pas à une requête ping ou que l'installation d'un agent à distance échoue avec le message « Service RPC indisponible », cela signifie que le Pare-feu Windows est activé. Dans le cas où un pare-feu est activé dans l'environnement de déploiement d'Essentials 2007, des exceptions doivent être créées pour que le serveur d'administration Essentials 2007 puisse installer correctement les agents sur les ordinateurs gérés et pour que les ordinateurs gérés puissent communiquer avec le serveur d'administration. (Quand vous utilisez un ordinateur géré, vous n'avez pas besoin de créer des exceptions de pare-feu manuellement si vous utilisez la stratégie de groupe de domaine au lieu de la stratégie de groupe locale).
Si l'installation de l'agent échoue, accédez à l'espace d'administration (la figure dorée dans l'angle inférieur gauche de la console d'administration Essentials 2007 principale, à côté du bouton de navigation Rapports), puis cliquez sur Administration en attente. Cet affichage fournit les étapes de dépannage et vous offre la possibilité de redéployer l'agent sur les ordinateurs où la première tentative d'installation a échoué.
Veillez à laisser s'écouler plusieurs heures pour que la stratégie de pare-feu s'applique à tous les ordinateurs à administrer. Si vous essayez d'exécuter l'Assistant de configuration des fonctionnalités et que vous sélectionnez l'Assistant de gestion des ordinateurs et des périphériques, tout cela rapidement, la stratégie de pare-feu peut ne pas avoir eu la possibilité de s'appliquer aux ordinateurs que vous découvrez et, par conséquent, la découverte peut échouer si le pare-feu est toujours activé.
Une méthode permettant de voir si un agent peut être envoyé avec succès sur un ordinateur consiste à essayer d'exécuter telnet sur cet ordinateur à partir du serveur d'administration. Si vous pouvez exécuter telnet via le port 135 à partir du serveur d'administration vers l'ordinateur, vous êtes prêt pour la suite. Dans le cas contraire, le pare-feu sur cet ordinateur peut bloquer le port TCP 135. Pour exécuter telnet, lancez une fenêtre de commande et tapez :
telnet <computer_name> 135
Vous serez ainsi connecté au nom d'ordinateur que vous spécifiez avec telnet via le port 135. Le port 135 est important parce qu'il s'agit du port que vous utilisez pour l'installation à distance de l'agent.
Si ceci ne fonctionne pas, vérifiez que les exceptions de Pare-feu Windows appropriées ont été créées de sorte à autoriser le déploiement d'agent et les communications avec le serveur d'administration. Dans la négative, vous devez créer les exceptions de port illustrées à la figure 7. Pour toutes ces exceptions, limitez l'étendue à l'adresse IP du serveur d'administration Essentials 2007 en utilisant l'option Liste personnalisée.
Figure 7 Exceptions de port (Close Figure 7)

Protocole | Nom | Port
TCP | Port 6270 | 6270
TCP | Port 135 | 135
TCP | Port 445 | 445
Si vos ordinateurs utilisent le logiciel de pare-feu d'un fabricant tiers, vous devez vous référer à la documentation de ce produit pour apprendre comment créer des exceptions. Cependant, les exceptions de port indiquées dans la figure 7 s'appliquent toujours.
Si le nom Netbios et le nom de domaine complet (FQDN) ne correspondent pas, vous devez corriger les enregistrements DNS pour l'ordinateur. Si l'agent s'installe mais ne contacte pas le serveur d'administration, connectez-vous à l'aide des services Terminal Server ou du Bureau à distance à l'ordinateur agent et utilisez les commandes ping et nbtstat pour vérifier que l'agent peut résoudre les noms Netbios et FQDN du serveur d'administration.
Si l'adresse IP du serveur d'administration Essentials 2007 est attribuée de façon dynamique, vous devez mettre à jour les stratégies de pare-feu sur les ordinateurs gérés lorsque l'adresse IP change. Pour mettre à jour les exceptions de pare-feu pour une nouvelle adresse IP du serveur d'administration, activez les deux paramètres de stratégie suivants dans l'Éditeur d'objets de stratégie de groupe et configurez-les comme je l'explique ici. Pour « Pare-feu Windows : autoriser l'exception d'administration à distance », définissez « Autoriser les messages entrants non sollicités provenant de : » sur la nouvelle adresse IP du serveur d'administration. Pour « Pare-feu Windows : autoriser l'exception de partage de fichiers et d'imprimantes », définissez « Autoriser les messages entrants non sollicités provenant de : » sur la nouvelle adresse IP du serveur d'administration.

Résumé
J'espère que les informations de cet article vous seront utiles dans vos débuts avec System Center Essentials 2007. Pour plus d'informations sur ce nouveau produit System Center, consultez le site Web microsoft.com/sce.
N'oubliez pas que rien ne vaut une planification soignée avant le déploiement. Dans le cas présent, vous allez déployer une solution toute nouvelle pour gérer votre environnement informatique, donc vous devez prendre le temps de réfléchir à votre configuration réseau actuelle, à la façon dont travaillent vos utilisateurs et à la façon dont vous voulez gérer vos ressources informatiques. Une réflexion préliminaire approfondie sur ces facteurs vous aidera à configurer Essentials 2007 de façon adaptée à vos besoins.

David Mills travaille chez Microsoft depuis sept ans et est aujourd'hui Responsable technique de produit pour System Center Essentials 2007. Avant de rejoindre l'équipe Marketing de System Center, David dirigeait les équipes d'assistance aux utilisateurs dans la division Windows Server, qui envoie des documentations techniques aux professionnels de l'informatique pour les technologies réseau de base et de gestion.


 System Center: Surveillez vos serveurs gr&#226;ce &#224; Operations&#160;Manager&#160;2007
System Center Pete Zerger

Surveillez vos serveurs grâce à Operations Manager 2007
Vue d'ensemble:
  • Nouvelles fonctionnalités d'Operations Manager 2007
  • Utilisation de la console d'opérations
  • Le rôle des rôles
  • Nouvelle fonction de création de rapports puissante

System Center Operations Manager 2007 offre une grande avancée dans la plate-forme d'administration des opérations Microsoft. Operations Manager 2007 représente un changement de paradigme en termes de stratégie, passant d'une surveillance centrée sur l'ordinateur à une véritable
plate-forme de surveillance orientée services. Bien que le nouveau modèle présente certaines ressemblances avec son prédécesseur en tant que solution de surveillance basée sur des agents, exploitant des concepts familiers à tout administrateur Microsoft® Operations Manager (MOM) 2005, de nombreuses modifications ont été apportées. Comme vous pourrez le constater, il y a de nouvelles fonctionnalités, de nouvelles interfaces d'administration et de nombreuses ressources supplémentaires pour en savoir plus sur ce dernier-né de la famille Microsoft System Center.

Interfaces d'administration
Les modifications les plus évidentes apparaissent dans les nouvelles interfaces de gestion. Les consoles Opérateur et Administrateur laissé place à une console Opérateur consolidée qui offre des fonctions d'administration, de création, d'exploitation et de création de rapports (voir la figure 1). De même, l'arborescence unique et souvent confuse de la console Administrateur MOM 2005 a disparu. Une interface très proche de celle d'Outlook® la remplace, exposant cinq espaces de travail spécifiques aux fonctions suivantes : surveillance, création, rapports, administration et mon espace de travail.
Figure 1 Console Opérateur
Figure 1 Console Opérateur
L'espace de travail Surveillance expose les affichages d'alerte, d'état, de performances et de diagramme de l'infrastructure réseau dans une interface propre, semblable à celle de la console Opérateur de MOM 2005.
L'espace de travail Création vous permet de configurer de nouvelles règles et de créer des groupes sur lesquels les règles et les moniteurs agiront. Une interface de rapports réellement améliorée a été intégrée à la console Opérateur, éliminant la nécessité de consulter un site Web de rapports séparé. Une interface permettant d'exécuter des tâches administratives, telles que la découverte des périphériques réseau et des ordinateurs et la configuration des paramètres de sécurité et de notification, est également disponible. Enfin, Mon Espace de travail permet aux utilisateurs de créer des affichages personnalisés, d'enregistrer des affichages et des recherches fréquemment utilisés et de configurer des abonnements à des notifications d'alerte personnalisées.
La console Opérateur contient une aide contextuelle, notamment des liens vers la documentation du produit, des webcasts en ligne et le guide des concepts. La console Opérateur comprend également une fonctionnalité de recherche riche permettant aux utilisateurs de définir des critères de recherche avancés pour tout type d'objet, et de consulter les résultats en fonction du type d'objet et des caractéristiques de valeur définies dans la recherche.
Le volet Actions de la console Opérateur offre toute une série de tâches contextuelles qui fournissent des informations sur la configuration et l'état des objets, et vous permet de lancer le nouvel Explorateur d'intégrité pour l'objet ciblé (voir la figure 2). Dans l'Explorateur d'intégrité, la structure de l'arborescence représentant l'intégrité des objets surveillés pour une entité donnée (objet surveillé) est hiérarchique. Chaque entité est surveillée sur au moins quatre paramètres : Disponibilité, configuration, performances et sécurité. Ces valeurs sont dépendantes les unes des autres. L'état de chacun de ces paramètres est calculé en fonction de l'état des moniteurs qui résident en dessous dans la hiérarchie.
Figure 2 Explorateur d'intégrité
Figure 2 Explorateur d'intégrité
L'Explorateur d'intégrité diagnostique les défaillances des objets surveillés et vous permet d'agir sur les conditions d'erreur en cliquant sur les liens hypertexte contenus dans le détail de l'événement. Vous pouvez également exécuter la tâche de diagnostic ou de récupération dans le volet de détails de l'Explorateur d'intégrité à la demande (comme à la figure 3) ou configurer la tâche pour s'exécuter automatiquement lorsqu'une alerte est générée. Le résultat de toute tâche de diagnostic (telle que la récupération d'une liste des processus en cours d'exécution) est automatiquement affiché dans le volet de détails lorsque l'événement de modification de l'état est souligné.
Figure 3 Diagnostics et récupérations
Figure 3 Diagnostics et récupérations

Console Web
Les fonctionnalités d'administration Web d'Operations Manager ont été largement développées dans cette version. La console Web expose les fonctionnalités des zones Surveillance et Mon Espace de travail de la console Opérateur via Internet Explorer®, offrant les mêmes affichages que ceux disponibles dans la console Opérateur, y compris un volet Actions entièrement fonctionnel pour l'exécution de tâches basées sur le contexte, et la possibilité de mettre les objets surveillés en mode de maintenance (voir la figure 4).
Figure 4 Console Web
Figure 4 Console Web
Une console Web mobile offrant un accès à partir de tout périphérique mobile Web est également incluse. La console Web propose un flux RSS qui fournit des alertes à la boîte de réception d'Outlook 2007 ou à l'agrégation RSS de votre choix.

Interface de commande
L''interface de commande d'Operations Manager est une puissante interface qui permet un contrôle administratif complet à partir de la ligne de commande. De nombreuses tâches complexes peuvent être lancées à l'aide d'une seule ligne de code (uniligne). L'interface de commande est une instance spécialement configurée de Windows PowerShell™, l'environnement d'interface de commande orienté objet basé sur Microsoft .NET Framework. Celle-ci vous permet d'accéder à un grand nombre de fonctions, appelées cmdlet, qui peuvent exécuter n'importe quelle tâche disponible dans l'interface utilisateur de la console Opérations, et bien d'autres choses encore. Ces cmdlet vous permettent d'exécuter facilement et rapidement une tâche sur plusieurs objets cibles (la mise en mode de maintenance de plusieurs agents par exemple), qui prendrait beaucoup plus longtemps si elle était exécutée par la console Opérateur. Par exemple, pour exporter une liste de toutes les alertes critiques ouvertes vers une page Web, exécutez ce qui suit dans la fenêtre de l'interface de commande d'Operations Manager :
get-alert | where {$_.Severity -gt "Warning" -and $_.ResolutionState -eq 0 } | format-table
monitoringobjectdisplayname,name,severity,
description
C'est la nature orientée objet de Windows PowerShell qui rend l'interface de commande si puissante. Vous obtenez la puissance des bibliothèques de classes Operations Manager .NET sans avoir à connaître C# ou Visual Basic® .NET.

Découverte des périphériques et des ordinateurs
La découverte des ordinateurs et le déploiement d'agents ont également évolué dans Operations Manager. Vous pouvez découvrir les agents en utilisant l'Assistant de gestion des ordinateurs et des périphériques depuis la console Opérateur, lequel permet aux administrateurs d'effectuer des recherches dans Active Directory® ou d'entrer manuellement un ordinateur cible ou une liste d'ordinateurs (voir la figure 5). Des requêtes LDAP (Lightweight Directory Access Protocol) détaillées permettent un ciblage plus granulaire des ordinateurs pour le déploiement d'agent.
Figure 5 Découverte avancée via la requête Active Directory
Figure 5 Découverte avancée via la requête Active Directory
L'Assistant vous permet de découvrir les périphériques SNMP (Simple Network Management Protocol), qui peuvent ensuite être ciblés pour la surveillance dans les règles du pack d'administration.
L'intégration à Active Directory représente une autre amélioration significative. Elle permet aux administrateurs d'enregistrer les informations des groupes d'administration dans Active Directory (via un utilitaire simple) pour que les agents d'Operations Manager puissent repérer le serveur d'administration approprié en interrogeant Active Directory au démarrage. La nouvelle intégration permet également aux administrateurs d'automatiser et de simplifier le déploiement d'agents en incluant un agent Operations Manager sur l'image d'un ordinateur, de déployer des agents via les plates-formes d'administration de systèmes courants (tels que Systems Management Server 2003 ou System Center Configuration Manager) ou via la Stratégie de groupe.

Sécurité
Operations Manager 2007 peut être utilisé pour surveiller de nombreux types d'applications, dont certains devront peut-être être limités à certains membres du service de support. Heureusement, le nouveau modèle de sécurité basé sur les rôles comporte cinq profils utilisateur par défaut qui regroupent l'accès selon les fonctions courantes, de l'opérateur en lecture seule à l'administrateur. Chacun des rôles d'utilisateur par défaut est basé sur un de ces profils par défaut. Les rôles d'utilisateur définissent les types d'opérations qui peuvent être exécutés par un utilisateur et la portée de ces droits. Vous pouvez également créer des rôles personnalisés en sélectionnant un de ces profils par défaut, puis définir la portée du rôle pour limiter la visibilité des données de surveillance au sous-ensemble souhaité d'objets, de tâches et d'affichages surveillés. Les rôles d'utilisateur standard et personnalisés basés sur ces profils utilisateur peuvent être attribués aux groupes de sécurité Active Directory, remettant les tâches d'attribution des privilèges d'accès utilisateur entre les mains du personnel d'administration de la sécurité.
L'option Exécuter en tant qu'exécution, également nouvelle dans Operations Manager 2007, offre une infrastructure sécurisée pour gérer les informations d'authentification requises pour exécuter les actions spécifiques. Par exemple, certaines tâches de surveillance peuvent nécessiter des informations d'authentification extrêmement privilégiées, voire des informations d'authentification non Windows.
L'option Exécuter en tant que comptes doit être associée à l'option Exécuter en tant que profil, qui peut à son tour être associé à une règle ou une tâche nécessitant des privilèges spéciaux. L'option Exécuter en tant que profil permet aux créateurs de pack d'administration de soustraire les exigences de compte pendant le processus de création pour que l'administrateur puisse associer une option Exécuter en tant que comptes appropriée une fois le pack d'administration installé dans Operations Manager.
En ce qui concerne les communications entre les agents et les serveurs d'administration, Operations Manager 2007 offre une sécurité accrue par rapport à son prédécesseur en nécessitant l'authentification mutuelle. Dans les environnements de confiance, l'authentification mutuelle peut être effectuée par Kerberos. Pour les environnements de réseau de périmètre non fiables, la situation peut devenir plus compliquée. L'authentification mutuelle nécessite une autorisation basée sur des certificats qui utilise des certificats x.509, ce qui obligera les organisations à envisager leurs options d'infrastructure de clé publique (PKI) si elles n'en possèdent pas encore.

Rôles de serveur
Tandis que les rôles de serveur d'administration, de base de données des opérations et de serveur de rapports de MOM 2005 restent dans Operations Manager, de nouveaux rôles de serveur d'administration ont été introduits. Le rôle de serveur d'administration racine isole les fonctions critiques, telles que l'autorisation utilisateur, la notification et l'administration des connexions de console à un rôle dédié dans l'infrastructure. Pour des performances optimales, le serveur d'administration racine doit être dédié à ce rôle et aucun agent ne doit être configuré pour envoyer des rapports vers ce serveur.
Le nouveau rôle de serveur de passerelle permet une utilisation des ordinateurs d'administration plus efficace dans les domaines et les environnements de périmètre non fiables en offrant une communication unique avec le serveur d'administration. Dans de nombreux cas, les agents du domaine cible peuvent être authentifiés auprès du serveur de passerelle via le protocole Kerberos, ce qui limite la nécessité d'une authentification basée sur les certificats et réduit les efforts administratifs et le coût total de possession.

Rapports
Les utilisateurs verront qu'Operations Manager 2007 offre des améliorations notables au niveau de la création de rapports, avec un espace Rapports intégré à la console Opérateur. De même, la sécurité pour les rapports est intégrée à la sécurité globale d'Operations Manager.
La fonction de création de rapport a subi plusieurs modifications architecturales majeures, notamment au niveau du moment et de la manière dont les données sont transmises à la base de données de rapports. La tâche nocturne DTS (Data Transformation Services) qui permettait de transférer les données de rapports de la veille à partir de la base de données des opérations a disparu. À la place, les données sont directement insérées dans la base de données de rapports en même temps qu'elles sont insérées dans la base de données des opérations, entraînant une latence quasi nulle.
Les rapports d'Operations Manager contiennent de nouveaux en-têtes de paramètre intelligents, offrant la flexibilité nécessaire pour définir et créer un rapport à des plages de date et d'heure spécifiques et relatives, y compris pour limiter la sortie des rapports à une plage d'heures de bureau définie par l'utilisateur. Le sélecteur d'objet situé dans l'en-tête de paramètre intelligent fournit une fonction de recherche, afin de simplifier la tâche de ciblage des objets pour les rapports. Lors de la planification des rapports, le sélecteur de date flexible élimine la nécessité de modifier les fichiers de définition de rapports pour atteindre une plage de date relative spécifique dans les rapports récurrents (voir la figure 6).
Figure 6 Configuration des heures de bureau
Figure 6 Configuration des heures de bureau
Une autre amélioration des rapports vise à s'assurer que les rapports s'affichent rapidement, même lorsqu'ils sont exécutés dans des plages de date étendues. Pour ce faire, les données de rapports d'Operations Manager sont automatiquement pré-indexées et agrégées dans les points de données de résumé quotidien et hebdomadaire, qui sont utilisés dans tous les rapports d'Operations Manager. En plus d'avoir les données déjà compilées, ceci améliore l'évolutivité des entrepôts de données étant donné que les points de données brutes peuvent être compressés dans la base de données de manière beaucoup plus agressive sans impact sur la fonctionnalité de rapport historique.
Les améliorations les plus impressionnantes concernent le contenu et les fonctionnalités des rapports affichés, qui présentent les données historiques de performances et de disponibilité au format adéquat aux ingénieurs réseau et responsables informatiques.
La figure 7 affiche un rapport de performances standard, qui consiste en un graphique avec un tableau. Les lignes du graphique et les descriptions du tableau permettent d'accéder d'un seul clic à un rapport détaillé, comme illustré à la figure 8.
Figure 7 Rapport de performances standard
Figure 7 Rapport de performances standard
Figure 8 Rapport de performances détaillé (Plongée dans la hiérarchie)
Figure 8 Rapport de performances détaillé (Plongée dans la hiérarchie)
Les rapports de disponibilité d'Operations Manager sont basés sur l'état des objets. Tout objet pouvant avoir un état peut être ciblé dans un rapport de disponibilité dès l'installation. Vous pouvez passer du rapport de détail au rapport de disponibilité en un seul clic (voir la figure 9).
Figure 9 Rapport de disponibilité
Figure 9 Rapport de disponibilité
Pour les packs d'administration sans rapport, il existe des rapports génériques qui prendront en charge les rapports de disponibilité et de performances de la quasi-totalité des objets gérés, réduisant considérablement la nécessité de créer des rapports personnalisés.
Les administrateurs seront ravis de voir que dès l'installation, Operations Manager 2007 prend en charge plusieurs groupes d'administration liés un entrepôt de données de rapports unique. La sécurité des rapports est intégrée à la sécurité basée sur les rôles du produit, ce qui permet aux administrateurs de contrôler l'accès aux rapports via les groupes de sécurité d'Active Directory.

Notification
Le jeu d'outils du moteur Notification d'Operations Manager 2007a été entièrement repensé, et offre désormais de nouvelles fonctionnalités ardemment réclamées par les administrateurs, notamment des options de notification supplémentaires (appelées canaux de notification) telles que la messagerie instantanée et le SMS (qui requiert un fournisseur SMS tiers installé sur le serveur d'administration). Les abonnements aux notifications incluent désormais une option de définition de la portée pour que les administrateurs puissent limiter la visibilité des types et groupes d'objets disponibles aux rôles d'opérateur et cibler plus précisément les abonnements aux notifications.
Le vieillissement des alertes (escalade) permet d'envoyer une notification lorsqu'une alerte qui satisfait les critères définis dans l'abonnement reste dans une état de résolution donné pendant une période définie par l'utilisateur.
Les formats de message peuvent désormais être personnalisés par abonnement, ce qui permet la personnalisation du format des messages au niveau des utilisateurs individuels. De plus, la notification libre-service du volet Mon Espace de travail de la console Operateur permet aux utilisateurs de définir leurs périphériques de notification et paramètres d'abonnement. Ces fonctionnalités ne sont que quelques-unes des fonctionnalités de notification que vous trouverez extrêmement pratiques.

Packs d'administration
Les packs d'administration représentent toujours l'infrastructure de base de surveillance des services et des applications dans Operations Manager 2007 et offrent une connaissance des applications issue directement des équipes de produit Microsoft. Cependant, ils passent de la surveillance de serveur à une surveillance orientée service, en se concentrant sur l'intégrité du service offert.
Des contraintes d'espace ne me permettent pas de dire davantage, mais il est à noter que le simple modèle de type d'objet de MOM 2005 (groupes d'ordinateurs et ordinateurs) ont été transformé en modèle extensible permettant de cibler des dizaines de types d'objet surveillés. Le résultat final consiste en un environnement de développement riche permettant aux FIL tiers de proposer des solutions métier, réseau et inter-plates-formes exceptionnelles.
Des règles de surveillance simples, semblables à celles disponibles dans MOM 2005, sont utilisées pour toute une série de tâches de surveillance courantes, telles que la surveillance des journaux d'événement et de texte, les requêtes d'événement WMI, les scripts exécutés sur calendrier et un fournisseur d'interruption SNMP considérablement amélioré qui élimine la nécessité de compiler les bases d'informations d'administration SNMP.
Cependant, dans Operations Manager, les moniteurs détectent les modifications de l'état des objets gérés. Les moniteurs comprennent de nombreuses fonctionnalités inconnues chez les fournisseurs MOM 2005, telles que la vérification du port TCP, les transactions synthétiques pour la connectivité de base de données et de site Web, la surveillance des applications ASP.NET et des services Web, et peut-être le plus important, la surveillance orientée service pour les applications métier distribuées. J'aborderai ces fonctionnalités plus en détail ultérieurement.

Seuils à réglage automatique
Parfois, le comportement n'est pas connu pour un compteur donné. Pour de telles situations, Operations Manager fournit des moniteurs de seuil à réglage automatique. Un moniteur de seuil à réglage automatique utilise un processus d'apprentissage sur le cycle d'entreprise défini (en général, une semaine, mais parfois aussi court qu'une journée) pour déterminer les valeurs normales d'un objet compteur de performances spécifié, puis pour définir les seuils en fonction des normes de fonctionnement enregistrées pendant la période d'apprentissage. Ces seuils représentent l'activité prévue, y compris les chutes ou les pics nets dans l'utilisation des ressources, comme c'est le cas lors de la maintenance nocturne des applications et des systèmes.

Transactions synthétiques
Pour une image plus dynamique de l'intégrité des applications, Operations Manager propose des transactions synthétiques, qui sont des actions s'exécutant en temps réel sur les objets surveillés. Les transactions synthétiques peuvent être créées pour les séquences de navigation de site Web, la connectivité de base de données et la surveillance de port TCP. Vous pouvez spécifier les nœuds de serveur à partir desquels les transactions s'exécuteront (appelés nœuds d'observation) ainsi que l'intervalle de surveillance souhaité. Si plusieurs nœuds d'observation sont choisis, les résultats peuvent alors être comparés pour déterminer si l'expérience à partir de chaque nœud est identique.
L'Editeur d'applications Web, utilisé pour capturer les séquences de navigation Web, permet également aux administrateurs de définir les seuils de délai de réponse pour les avertissements et les erreurs et de spécifier le groupement de compteurs de performances pour les opérations individuelles au sein du chargement de pages et de la récupération de liens. Les séquences de navigation sécurisées (SSL) qui nécessitent tout un éventail de méthodes d'authentification (telles que Basic ou NTLM) sont prises en charge.
Les remplacements, concept MOM 2005 bien connu, sont utilisés pour ajuster la configuration des paramètres Operations Manager des moniteurs, des attributs et des règles pour un objet ou un groupe d'objets gérés (voir la figure 10). L'utilisation des remplacements est essentielle pour le contrôle de la quantité de données recueillies par Operations Manager. Vous pouvez utiliser des groupes et des remplacements simultanément pour limiter l'activité du moniteur, de la règle, de l'attribut ou de la découverte d'objet à un groupe cible d'objets non seulement dans vos propres packs d'administration, mais également dans ceux des FIL tiers et de Microsoft.
Figure 10 Paramètres de remplacement pour un moniteur de service
Figure 10 Paramètres de remplacement pour un moniteur de service

Surveillance des applications métier
Le nouveau concepteur Distributed Application Designer vous permet de créer une image au niveau du service des applications critiques, et fournit ensuite un indicateur d'intégrité sommaire des composants d'applications distribuées. Celui-ci inclut tout type d'objet découvert, tel qu'un service Web, une base de données SQL Server™, et même les périphériques non Windows, tels que les routeurs et les commutateurs réseau. Les relations aux objets et l'état d'intégrité actuel peuvent ensuite être affichés dans un diagramme.
Pour rendre cette puissante fonctionnalité plus accessible, Microsoft propose plusieurs modèles d'applications distribuées afin de donner aux administrateurs un point de départ pour la définition de leurs propres applications métier. Des modèles sont disponibles pour de nombreux scénarios courants, notamment Application ASP.NET et service Web ASP.NET, Application métier Web, Messagerie, Batterie de portails SharePoint® et Batterie de serveurs de services Terminal Server.
De nouveaux modèles peuvent être ajoutés au groupe d'administration via les packs d'administration Microsoft ou tiers, qui apparaissent ensuite dans l'Assistant d'ajout de surveillance. Les moniteurs d'applications distribuées pour Active Directory, Exchange et Operations Manager sont pré-déployés et ne peuvent pas être modifiés.

Disponibilité des packs d'administration
Les packs d'administration écrits spécialement pour Operations Manager 2007 (appelés packs d'administration optimisés) sont conçus pour tirer pleinement parti des nouvelles fonctionnalités d'Operations Manager 2007 et seront disponibles avec les nouvelles versions logicielles prévues en 2008. Cependant, les packs d'administration MOM 2005 existants peuvent être convertis au format convivial d'Operations Manager 2007 à l'aide de l'utilitaire MPConvert. Ils peuvent également être transférés depuis une installation MOM 2005 existante à l'aide de l'outil de migration MOM 2005 vers Operations Manager 2007. Vous trouverez ces deux outils sur le CD d'Operations Manager 2007. En fait, Microsoft est en train de convertir les packs d'administration MOM 2005 au format Operations Manager 2007 compatible. Par conséquent, ceci devrait en général être nécessaire uniquement pour les packs d'administration maison.

Collecte d'audit
La collection d'audit offre la solution permettant d'automatiser la collecte et l'archivage centralisé des journaux d'événements de sécurité Windows distribués. Elle est conçue pour les moyennes et grandes entreprises nécessitant la collecte et la surveillance d'un volume élevé de données du journal d'événements de sécurité pour un audit de conformité interne et externe. La collecte d'audit consiste en quatre rôles : le collecteur, les redirecteurs, le rôle de base de données et le rôle de rapports. Le collecteur est le serveur qui « attrape » les événements et les insère dans la base de données de la collection d'audit. Le redirecteur est un service qui envoie les événements des journaux d'événements de sécurité quasiment en temps réel, ce qui réduit le risque d'interférence des administrateurs locaux avec les journaux d'événements de sécurité. Le service redirecteur est inclus dans l'agent Operations Manager 2007 mais est désactivé jusqu'à l'activation de la collection d'audit pour un agent donné.
La collecte d'audit utilise la maintenance de base de données nocturne automatique, garantissant des performances de rendu de rapports systématiquement excellentes sur de larges datasets. La collecte d'audit maintient un dataset constant (stocké pendant 14 jours par défaut) qui peut être ajusté par les administrateurs pour satisfaire leurs exigences organisationnelles. Pour surveiller les événements collectés, la collecte d'audit inclut un rôle de rapports comprenant un groupe de base d'environ 20 rapports d'audit ainsi qu'un abonné WMI hautes performances, fournissant une interface facile pour les requêtes ad hoc sans avoir à autoriser directement les administrateurs à accéder à la base de données.

Surveillance client
Les nouvelles fonctionnalités de surveillance client d'Operations Manager 2007 permettent aux administrateurs de surveiller les systèmes d'exploitation et les applications des postes de travail afin de déterminer les erreurs qui surviennent fréquemment pour que les efforts puissent se centrer sur les interventions les plus bénéfiques à l'organisation. Les données d'erreur collectées sont utilisées pour produire des affichages et des rapports détaillés, offrant ainsi à l'administrateur une source d'informations prête à l'emploi pour faciliter les décisions de support.
La surveillance client d'Operations Manager 2007 se divise en fait en trois niveaux qui peuvent être activés individuellement :
Le Contrôle des exceptions sans agent (AEM) permet à l'administrateur de contrôler les incidents et les erreurs survenant sur les systèmes d'exploitation et les applications. L'administrateur peut diriger ces rapports, qui auraient auparavant été directement envoyés à Microsoft, vers un serveur d'administration à partir duquel ils peuvent ensuite être transférés à Microsoft s'il le souhaite.
Programme d'amélioration des services (CEIP) Lorsque vous participez au Programme d'amélioration des services, vous configurez les clients à l'aide de la stratégie de groupe de façon rediriger les rapports vers un serveur d'administration Operations Manager 2007, au lieu d'envoyer les rapports directement à Microsoft. Les serveurs d'administration sont ensuite configurés pour transmettre ces rapports à Microsoft.
Il est important de noter que les composants AEM et CEIP peuvent être exécutés sans agent.
La surveillance client pour les postes de travail stratégiques concerne le déploiement effectif d'un agent Operations Manager sur les postes de travail stratégiques. Les packs d'administration incluent ceux pour Windows 2000, Windows XP et Windows Vista et Microsoft Information Worker qui surveille Microsoft Office, Internet Explorer et les autres applications de bureau Microsoft.

Essayez vous-même !
Comme vous pouvez le constater, System Center Operations Manager 2007 offre une multitude de fonctionnalités conçues pour assurer une surveillance orientée service avec une intégration parfaitement pensée, ce qui vous permet de tirer pleinement parti des investissements Active Directory existants, de rationaliser l'administration et de réduire le coût total de possession. Je vous encourage à essayer cette superbe nouvelle version et à explorer ses possibilités.
Vous pouvez télécharger une version d'essai d'Operations Manager 2007, valable 180 jours, à l'adresse suivante : microsoft.com/technet/opsmgr/2007/downloads/trials/privacy.mspx. Pour plus d'informations sur les technologies Microsoft System Center, consultez la page d'accueil de System Center Operations Manager à l'adresse suivante : microsoft.com/systemcenter/opsmgr. Consultez les témoignages concernant System Center (vidéos et études de cas) sur le nouveau site Web « Conçu pour les grandes choses » à l'adresse suivante designedforbig.com.

Pete Zerger est un partenaire de conseil chez AKOS Technology Services. Pete a neuf ans d'expérience dans le secteur informatique. Sa spécialité : la conception et le déploiement de solutions d'administration des opérations d'entreprise, de services d'annuaire et de solutions de messagerie. Pete possède une certification MCSE pour la messagerie, une certification MCTS pour SQL Server 2005 et est Microsoft MVP pour Microsoft Operations Manager.


 System Center: Migration de MOM vers Operations&#160;Manager&#160;2007
System Center Andy Dominey

Migration de MOM vers Operations Manager 2007
Vue d'ensemble:
  • Planification d'un déploiement d'Operations Manager
  • Évaluation des besoins matériels
  • Conservation des données historiques
  • Planification des tests

La surveillance et l'administration des serveurs représentent un aspect crucial de toute infrastructure informatique moderne. Il est essentiel que vous vous assuriez que votre infrastructure informatique fonctionne non seulement correctement mais qu'elle est suffisante pour supporter la charge exercée par les utilisateurs. Toutefois, la collecte de ces informations n'est pas
une sinécure. Quant à savoir ce que vous devez faire de ces informations après les avoir collectées, c'est encore une autre histoire. Heureusement, l'aide n'est pas loin. Microsoft® Operations Manager (MOM) permet la collecte de ces informations depuis sept ans. Et sa dernière incarnation, System Center Operations Manager 2007, développe ce principe.

Pourquoi migrer ?
System Center Operations Manager 2007 offre de multiples améliorations significatives depuis sa dernière version, MOM 2005. L'architecture de base a été remaniée et considérablement améliorée pour permettre au produit d'être informé au mieux des applications réparties sur plusieurs périphériques et d'être également informé non seulement des serveurs mais également de tous les composants qui constituent un serveur.
De plus, Operations Manager contient un moteur de classement puissant capable d'agréger les données d'alertes, tout en réduisant considérablement le nombre de fausses alertes, ainsi qu'un explorateur d'intégrité qui permet de rationaliser le processus de localisation et de résolution des problèmes.
Il contient également des seuils à réglage automatique et un moteur de configuration de base qui vous permettent de suivre facilement l'utilisation des ressources sur l'ensemble de votre environnement. Le moteur de rapports, quant à lui, a été considérablement amélioré, offrant de superbes graphiques et des rapports permettant de plonger dans la hiérarchie. Examinez la Figure 1 pour un aperçu de la présentation visuelle des données de rapport.
Figure 1 Rapport de disponibilité dans Operations Manager 2007
Figure 1 Rapport de disponibilité dans Operations Manager 2007
Operations Manager peut même être utilisé pour contrôler les ordinateurs de bureau, ainsi que les serveurs. Voici quelques fonctionnalités supplémentaires offertes par Operations Manager 2007 :
  • Excellente surveillance de la plate-forme Windows Server System™
  • Fonctionnalités de surveillance des applications puissantes
  • Automatisation des tâches courantes
  • Le moteur de base de données nouvelle génération facilite l'évolutivité et le contrôle à l'échelle de l'entreprise
  • Améliorations de sécurité et intégration avec Active Directory®
Pour encore plus d'informations sur les nouvelles fonctionnalités disponibles dans System Center Operations Manager 2007, consultez l'article « Surveillez vos serveurs grâce à Operations Manager 2007 » de Pete Zerger dans ce numéro de TechNet Magazine.

Migration vers Operations Manager
Avant de planifier votre migration vers Operations Manager 2007, vous devez savoir qu'il n'existe pas de chemin de mise à niveau direct pour le produit. Avec des modifications architecturales aussi importantes que celles apportées à Operations Manager, le produit ne pourrait pas rester suffisamment compatible avec les versions précédentes pour permettre une mise à niveau directe. Par conséquent, si vous exécutez actuellement MOM 2000 ou MOM 2005, vous devrez envisager l'une des stratégies de migration décrites ultérieurement dans cet article.
Si vous n'exécutez pas de version précédente de MOM, il vous suffit d'installer la nouvelle version du produit. Gardez à l'esprit que vous devrez décider très tôt dans le projet si vous disposez de compétences internes suffisantes pour exécuter l'installation ou la migration, ou si vous devez obtenir l'assistance d'un tiers. Ceci aura évidemment un impact sur le coût général du projet. Vous devez donc examiner la question au début de ce processus.

Scénarios de migration
Pour ceux qui n'exécutent pas actuellement MOM, le déploiement est simple : planifiez et concevez l'architecture puis déployez le logiciel. En revanche, si vous utilisez MOM, Microsoft prend en charge deux scénarios de migration : côte à côte sur un même matériel et côte à côte sur un matériel différent. Explorons les deux scénarios.
Côte à côte sur un même matériel Dans ce scénario, vous installez Operations Manager sur le même matériel physique que votre architecture MOM 2000 ou MOM 2005 existante. Cette approche est utile pour les sites où l'infrastructure MOM est peu utilisée et où le matériel serveur est suffisamment puissant pour héberger côte à côte l'ancienne et la nouvelle version. N'envisagez cette option que si l'installation d'Operations Manager ne risque pas d'avoir un impact sérieux sur les performances des serveurs MOM actuels.
Côte à côte sur un matériel différent Dans ce cas-ci, la nouvelle installation est exécutée sur le nouveau matériel ou un matériel différent. Il s'agit de l'approche préférée étant donné qu'elle garantit un impact minimum sur l'infrastructure d'administration actuelle pendant la migration. Notez qu'un matériel supplémentaire n'est pas requis. Les nouveaux serveurs Operations Manager 2007 peuvent être montés sur des ordinateurs virtuels jusqu'à ce que l'ancien matériel serveur puisse être réattribué.

Considérations
Avant de choisir une stratégie de migration particulière, quelques points importants sont à prendre en considération.
Vous devez d'abord penser aux exigences matérielles et logicielles et aux coûts associés. Même si vous décidez d'installer ou de configurer une partie ou la totalité de l'infrastructure Operations Manager sur les ordinateurs virtuels, vous devrez malgré tout autoriser le système d'exploitation et les licences d'application, ainsi que les OML (Operations Management License) pour chaque agent à être contrôlés par Operations Manager.
Ensuite, vous devez planifier les ressources qui exécuteront le travail. Dans une petite entreprise, ceci peut ne pas se révéler très complexe ou difficile, mais dans les entreprises plus importantes, cela peut s'avérer un élément clé de la stratégie de migration générale.
Vous devez également considérer l'impact potentiel que cette migration pourrait avoir sur l'infrastructure de surveillance actuelle ou sur l'ensemble des serveurs. Vous devez planifier toute éventualité, y compris la possibilité de redémarrage des serveurs, voire de défaillances de serveurs de production critiques.
Notez que si vous utilisez la base de données Microsoft Access™ dans MOM 2000 ou le magasin de données SQL Server™ dans MOM 2005 pour le stockage et les rapports de données d'archive, la migration de ces données vers Operations Manager 2007 n'est actuellement pas prise en charge.

Planification pour une migration réussie
En tant que consultant, l'un des plus gros problèmes que je rencontre est la planification inadéquate des déploiements. Après avoir décidé d'effectuer l'installation sur un nouveau matériel ou un matériel existant, l'étape suivante consiste à créer un plan de projet.
Votre plan de projet doit répertorier les étapes du projet suggérées dans cet article, bien que cette liste ne soit pas exhaustive. Veillez à prévoir suffisamment de temps pour chaque étape du projet et à prendre en compte toutes les ressources nécessaires.
Comme je l'ai indiqué, System Center Operations Manager 2007 possède une architecture passablement différente de MOM 2000 et 2005. Pour commencer, il existe un rôle de serveur supplémentaire dans Operations Manager : le serveur d'administration racine (RMS). RMS gère la configuration du groupe d'administration, traite toutes les connexions aux autres groupes d'administration et produits tiers. Il gère également la sécurité au sein du groupe d'administration. Ce rôle peut être tenu sur un serveur d'administration System Center Operations Manager existant, mais dans les environnements plus grands et complexes, il doit disposer de son propre serveur physique. De même, le concept de groupes d'administration nivelés qui existait dans MOM 2005 a été remplacé par les groupes d'administration connectés. Dans cette nouvelle architecture, aucune donnée d'alerte n'est transmise entre les groupes d'administration. Au lieu de cela, les alertes des groupes d'administration connectés sont simplement présentées dans l'interface utilisateur du groupe d'administration demandeur. De plus, si vous pensez installer les agents sur les ordinateurs dans des domaines ou groupes de travail non fiables, vous devrez utiliser des certificats pour permettre à l'agent et au serveur d'administration de s'authentifier mutuellement (fonctionnalité forcée dans Operations Manager).
Afin de concevoir l'architecture pour System Center Operations Manager, vous devrez considérer le nombre de serveurs et de clients que vous souhaitez surveiller, s'ils sont situés dans un domaine de confiance, quelles applications et plates-formes vous devez surveiller et si vous souhaitez surveiller votre infrastructure réseau. Vous devez également identifier toute application qui nécessite des règles ou des packs d'administration personnalisés.
Il s'agit là de l'étape où vous devez identifier vos exigences de pack d'administration. Après avoir déterminé les applications à surveiller, vous pouvez décider des packs d'administration à installer. Les packs d'administration contiennent des règles, des moniteurs, des tâches et des classes qui s'appliquent à une application ou un système d'exploitation spécifique et doivent être importés si leur application ou système d'exploitation associé est utilisé dans votre environnement. Le choix des packs d'administration à cette étape aura une influence sur la configuration matérielle et logicielle requise et le temps qui devra être alloué à l'installation et à la configuration du logiciel.
Une fois que vous aurez une idée de l'architecture de votre infrastructure Operations Manager, vous devrez recourir à l'outil System Center Capacity Planner 2007 (encore à la version bêta à la rédaction de cet article). Utilisez l'outil pour dresser le plan de votre infrastructure réseau et de serveurs et simuler son exécution par rapport au déploiement planifié d'Operations Manager pour vous assurer qu'il est suffisant pour contrôler et gérer votre infrastructure.
À ce stade, vous devez faire également très attention à la conception architecturale si vous comptez procéder à une migration. Vous devez considérer le fait que MOM 200x s'exécutera à côté d'Operations Manager, entraînant une augmentation du trafic réseau.

Déploiement
Le déploiement est l'étape suivante. Assurez-vous que le matériel adéquat configuré avant d'installer le logiciel. Si vous effectuez l'installation sur un nouvel environnement, un matériel physique est plus approprié, surtout pour le serveur de base de données. Cependant, les serveurs d'administration peuvent être virtualisés si le matériel physique ne peut pas être envisagé. Dans un scénario de migration, l'utilisation de serveurs virtualisés constitue une bonne alternative à l'achat de matériel pour l'installation de la nouvelle infrastructure. Dans cette situation, vous pouvez utiliser des ordinateurs virtuels pour installer Operations Manager pendant que les anciens serveurs MOM sont désactivés et reconstruits.
Une fois les serveurs configurés, vous pouvez commencer à installer le logiciel. Tout d'abord, assurez-vous que les serveurs qui exécuteront Operations Manager disposent de la configuration logicielle préalablement requise pour sa prise en charge. Par exemple, si vous exécutez SQL Server 2000 et que vous comptez installer Operations Manager sur le même serveur, vous devrez tout d'abord mettre à niveau vers SQL Server 2005 avec SP1. Pour effectuer cette vérification, exécutez le module de vérification des conditions requises d'Operations Manager à partir du support d'installation de System Center Operations Manager.
Une fois toutes ces conditions requises satisfaites et après avoir configuré SQL Server et Reporting Services, commencez l'installation du logiciel Operations Manager. Dans un environnement de serveur unique, c'est facile : il vous suffit d'exécuter le fichier d'installation Operations Manager sur le serveur, puis d'exécuter l'installation d'Operations Manager Reporting si vous souhaitez utiliser cette fonctionnalité. Cependant, dans un environnement distribué, les composants d'Operations Manager doivent être installés sur les serveurs individuels dans le bon ordre. Installez en premier la base de données, puis le premier serveur d'administration, auquel sera automatiquement attribué le rôle de serveur d'administration racine. Ensuite, tout serveur d'administration supplémentaire peut être installé. L'étape finale consiste à installer la console Web et les composants de rapport.

Migration
À cette étape, vous devez vous assurer que votre nouvelle infrastructure reflète votre surveillance existante avant de tenter d'exploiter toute nouvelle fonctionnalité. Tout pack d'administration utilisé dans l'ancien environnement doit être dupliqué dans le nouveau déploiement d'Operations Manager. S'il existe un pack d'administration d'Operations Manager, vous souhaiterez peut-être l'importer, mais tout pack d'administration qui ne dispose pas de nouvelles versions devra être exporté du groupe d'administration actuel, converti à l'aide de l'outil MPConvert depuis le CD d'installation, puis importé dans Operations Manager, à moins que votre pack d'administration personnalisé soit simple ou peu volumineux, auquel cas il est préférable de simplement le recréer. Il existe également un outil très utile pour la duplication de la configuration. L'outil de migration de MOM 2005 vers Operations Manager aide à dupliquer la configuration d'un groupe d'administration MOM existant vers Operations Manager. Vous le trouverez également sur le CD d'installation d'Operations Manager. La figure 2 illustre une configuration typique lors d'une migration.
Figure 2 Configuration typique lors d'une migration
Figure 2 Configuration typique lors d'une migration
Une fois votre configuration dupliquée, assurez-vous que vous obtenez les mêmes alertes et recueillez les mêmes données avec Operations Manager qu'avec MOM. Heureusement, l'agent Operations Manager peut coexister avec les agents hérités de MOM pour une exécution simultanée des agents des deux versions. Vous pouvez recueillir des données des agents des deux versions et les comparer côte à côte par souci d'exactitude avant de désactiver le système hérité.
Vous devez ensuite formuler un plan de tests. Les tests peuvent consister en une simple comparaison des alertes du système hérité avec celles du système Operations Manager, mais peuvent également aller jusqu'à nécessiter la génération délibérée d'alertes pour une évaluation complète de la nouvelle infrastructure. Une fois satisfait des résultats de tests, vous pouvez commencer à désinstaller les agents MOM hérités à l'aide de la console MOM ou avec l'option Ajout/Suppression de programmes sur les ordinateurs agents.
La création de rapports représente un aspect important d'un déploiement MOM et System Center Operations Manager et doit également être abordée. La base de données SystemCenterReporting existante ne peut pas être actuellement migrée vers Operations Manager 2007. Par conséquent, vous pouvez créer une nouvelle instance de Reporting Services pour Operations Manager et conserver la base de données MOM 2005 existante (SystemCenterReporting) dans une instance de SQL Reporting Services dédiée pour afficher les rapports hérités. La nouvelle console de rapports de System Center Operations Manager 2007 est intégrée au produit. Il n'est donc pas recommandé d'utiliser la console Reporting Services pour tout ce qui n'est pas Operations Manager. La migration des données de rapports sera peut-être possible à l'avenir au moyen d'un script de migration de données, mais pour le moment, vous devrez peut-être dire au revoir à vos données de rapports archivées et vous consoler en pensant que lorsque vous commencerez à générer vos tout nouveaux rapports, la direction sera si enthousiaste qu'elle ne remarquera même pas que vos anciennes données ont disparu.

Conclusion
System Center Operations Manager offre des améliorations significatives par rapport à MOM 2000 et 2005, mais ces avancées peuvent avoir un coût. Une modification majeure de l'architecture sous-jacente (et par conséquent, l'absence d'un chemin de mise à niveau direct) signifie que les coûts de déploiement sont potentiellement plus élevés. Pour réduire ces coûts, vous devez effectuer une planification détaillée et vous assurer que vous disposez des bonnes personnes pour effectuer cette migration. Faites tout cela et vous récolterez les avantages du dur labeur de Microsoft grâce à System Center Operations Manager.

Andy Dominey est dans le secteur informatique depuis huit ans et est actuellement employé chez 1E, Royaume-Uni, en tant que spécialiste de l'administration Windows. Il travaille sur MOM depuis MOM 2000. Andy a reçu la récompense Microsoft MVP ces deux dernières années pour MOM.


 System Center: Virtualisez vos applications avec Microsoft SoftGrid
System Center Ahmer Sabri and Kedar Shah

Virtualisez vos applications avec Microsoft SoftGrid
Vue d'ensemble:
  • Avantages de la virtualisation des applications
  • Présentation de l'architecture SoftGrid
  • Rationalisation des packages logiciels

Le concept de virtualisation logicielle existe, sous une forme ou sous une autre, depuis les années 60. Cependant, le secteur informatique a mis des dizaines d'années à commencer à se rendre compte du potentiel de la
virtualisation des applications. Le retard est en train d'être rattrapé et des développements majeurs sont en cours.
L'acquisition de Softricity par Microsoft en juillet 2006 n'a fait qu'accentuer cette tendance. De cette acquisition est né Microsoft® SoftGrid, une solution de virtualisation d'application. Avec SoftGrid, les applications sont servies à partir d'un centre de données ou d'un autre emplacement réseau et s'exécutent localement sur les clients distants dans un environnement virtuel. Les applications virtualisées s'exécutent en silos et fonctionnent indépendamment du système d'exploitation et des autres applications installés sur le bureau local.
L'implémentation de la virtualisation d'applications avec SoftGrid offre de nombreux avantages, trop pour tous les aborder ici. Voici cependant certains des avantages les plus notables et immédiatement reconnus :
Régression et tests de compatibilité simplifiés En exécutant plusieurs versions de la même application parallèlement et sans conflits sur un seul ordinateur, vous pouvez réduire de façon spectaculaire la complexité, le temps et les coûts associés au test et au déploiement de nouvelles applications (voir la figure 1).
Figure 1 Rationalisation du déploiement d'applications avec SoftGrid
Figure 1 Rationalisation du déploiement d'applications avec SoftGrid
Simplification de la gestion des systèmes Le département 'informatique dispose d'un grand contrôle sur l'environnement dans lequel ces applications s'exécutent, ce qui facilite la maintenance de l'environnement de postes de travail idéal.
Réduction des appels passés au support technique Avec des environnements de postes de travail mieux gérés et un nombre de conflits réduit (grâce aux applications virtualisées s'exécutant dans un silo contrôlé), les utilisateurs sollicitent moins fréquemment le support technique.
Amélioration de la sécurité des postes de travail Les applications ne sont jamais installées sur le système d'exploitation, ce qui améliore sa sécurité globale. Les applications sont uniquement mises à disposition des utilisateurs autorisés, empêchant ainsi tout accès non autorisé. Et la plupart des applications sont affichées dans le contexte de sécurité standard.
Placement libre Les préférences de l'utilisateur (profil et autres paramètres) sont enregistrées sur le réseau, ce qui permet aux utilisateurs d'accéder à leurs applications, leurs préférences et leurs contrôles à partir de n'importe quel PC.
Amélioration de la tolérance de panne et de la récupération après incident Les applications sont transformées en fichiers de données qui peuvent être enregistrés et copiés comme n'importe quelles données d'entreprise. Les applications et leurs mises à jour peuvent être automatiquement synchronisées entre les sites en temps réel et le BCP (Bulk Copy Program) à l'aide d'outils tiers, ce qui offre un accès immédiat aux applications en cas de sinistre.
Au final, ces caractéristiques allègent la charge d'administration des systèmes, réduisent les coûts et permettent à votre organisation d'adopter de nouvelles technologies de façon plus rapide et fiable. Observons maintenant de plus près le fonctionnement de SoftGrid.

Livraison des applications virtualisées
L'architecture de SoftGrid est composée de différents composants fonctionnant de concert. Elle comprend des composants SoftGrid tels que le magasin de données, le serveur d'applications virtuelles, le séquenceur, les consoles de gestion, le service Web de gestion et l'application cliente, qui fonctionnent conjointement avec les composants d'infrastructure standard, tels qu'Active Directory® (voir la figure 2). Nous allons vous donner un aperçu général de l'architecture de SoftGrid et vous expliquer comment les divers composants collaborent.
Figure 2 Architecture globale de SoftGrid
Figure 2 Architecture globale de SoftGrid
Le magasin de données de SoftGrid sert de référentiel central pour l'ensemble de l'environnement de virtualisation. Installé sur SQL Server™ (version 2000 ou 2005) ou Microsoft SQL Server Desktop Engine (MSDE), le magasin de données contient les applications, la configuration, les données de licence, les informations de rapport et les informations de journalisation.
Les applications virtualisées sont servies à la machine de l'utilisateur et affichées dans un client. SoftGrid offre deux approches : Microsoft SoftGrid Application Virtualization for Desktops et Microsoft SoftGrid Application Virtualization for Terminal Services. Chaque approche présente des avantages mais suppose également certains compromis au niveau des performances, ce que nous traiterons dans la section Configuration du client.
L'un des composants les plus critiques dans l'environnement SoftGrid est le serveur d'applications virtuelles SoftGrid (SVAS). Il est utilisé pour contrôler les demandes d'applications des utilisateurs et transmettre les données d'application aux utilisateurs sur demande.
SVAS s'exécute sous la forme d'un service Windows® appelé Microsoft System Center Virtual Application Server et a des exigences de configuration matérielle très modestes. Par défaut, toutes les données d'application elles-mêmes (que nous aborderons dans un moment) sont situées dans le répertoire \Program Files\Softricity\SoftGrid Server\content.
L'environnement SoftGrid type est lancé lorsqu'un utilisateur ouvre une session sur un poste de travail. Le client SoftGrid capture le jeton de sécurité de l'utilisateur et l'appartenance au groupe de domaine et transmet ces informations à SVAS via un canal sécurisé. SVAS attribue l'accès utilisateur aux applications, à condition que le SID de l'utilisateur (Security Identifier) soit présent dans l'annuaire d'appartenance au groupe de l'application, et un raccourci pour chaque application est placé sur le bureau de l'utilisateur (ou dans tout autre emplacement que l'administrateur peut définir, par exemple le menu Démarrer, la barre d'outils de lancement rapide, etc.).
La livraison même d'une application commence généralement quand un utilisateur clique sur l'icône de raccourci associée à un fichier .osd (Open Software Description). Il s'agit d'un fichier de base XML qui contient les informations du package d'applications. Le client récupère le nom du serveur d'applications virtuelles à partir du fichier .osd et établit une connexion. À ce moment, SVAS authentifie le client et contacte le magasin de données pour déterminer la validité de la licence. Une fois l'utilisateur authentifié, SVAS transmet les données d'application au client par blocs de données (par défaut, les blocs de données font 32 Ko mais leur taille peut être configurée lors du séquençage).
Notez que toute l'application n'est pas transmise au client. Au lieu de cela, SoftGrid transmet uniquement la portion de l'application nécessaire dans l'immédiat pour lancer l'application sur le client. Il s'agit généralement d'environ 20 à 40 % du code total, bien que ceci puisse certainement varier selon l'application. Par exemple, Microsoft Word 2003 nécessite la transmission de seulement 15 Mo de données au client pour pouvoir être lancé, sur une taille totale de package de 800 Mo. Si l'utilisateur accède à une portion de l'application qui n'est pas déjà contenue dans le cache du client, le code nécessaire est alors transmis au client. Pour éviter l'effet d'embouteillage, où trop de requêtes simultanées obstruent le réseau, les organisations peuvent choisir de mettre au préalable en cache les applications courantes sur les postes de travail des utilisateurs.

Active Directory
SoftGrid s'appuie sur les utilisateurs et les groupes du domaine Active Directory (ou Windows NT® 4.0) pour fournir les applications aux utilisateurs autorisés. Dans un environnement de plusieurs domaines, les utilisateurs peuvent être mis en service à l'aide des appartenances de groupe appropriées (SoftGrid prend en charge les appartenances de groupe locales, globales et universelles) et des relations d'approbation avec le domaine où SVAS est installé.
Quand vous installez SVAS, vous êtes invité à indiquer différents comptes et groupes de service, qui favorisent l'intégration avec Active Directory et sont utilisés par la suite à des fins d'administration. Ainsi, vous devez créer trois groupes et comptes avant l'installation : Un compte d'explorateur SoftGrid, un groupe d'administrateurs SoftGrid et un groupe d'utilisateurs SoftGrid.
Le compte d'explorateur SoftGrid a pour rôle de parcourir Active Directory et nécessite par conséquent des droits en lecture seule sur tous les domaines Active Directory d'un environnement multi-domaine. Les groupes d'administrateurs SoftGrid sont utilisés pour accorder un accès administratif à la console de gestion SoftGrid et au service Web de gestion SoftGrid. Enfin, les groupes d'utilisateurs SoftGrid sont utilisés pour attribuer la stratégie de fournisseur par défaut, qui est utilisée pour fournir à tous les utilisateurs du domaine l'accès aux applications publiées via la console de gestion.

L'environnement virtuel
SystemGuard est l'élément central du client SoftGrid, qui s'exécute sur le poste de travail local. SystemGuard a pour tâche de fournir un environnement virtuel entièrement fonctionnel pour que les applications puissent s'exécuter de manière autonome. Cet environnement en silos contient les composants de système d'exploitation virtualisés (le registre, les fichiers, les polices, INI, COM, les services intégrés et les variables d'environnement) qui sont nécessaires pour le bon fonctionnement de l'application (voir la figure 3).
Figure 3 Environnement virtualisé une application s'exécutant de façon autonome
Figure 3 Environnement virtualisé une application s'exécutant de façon autonome
SystemGuard crée des clés de registre virtualisées pour chaque application qu'il exécute. Ces clés ne sont pas accessibles aux autres applications s'exécutant sur le système d'exploitation local. Elles ne sont pas non plus visibles aux outils de modification de registre tels que regedit. Les écritures et les lectures du registre sont redirigées vers les clés virtuelles le cas échéant. Notez, cependant, que les applications sont autorisées à passer par le registre local pour fournir des informations non contenues dans les clés de registre virtualisées.
De même, SystemGuard crée un système de fichiers virtualisé et redirige la majorité des lectures et des écritures de l'application vers ce système de fichiers. Ce système de fichiers virtualisé est isolé et fournit l'environnement dont vous avez besoin si vous souhaitez exécuter plusieurs versions d'une même application sur un client unique.
Nous devons toutefois signaler que, bien que les applications soient isolées du système d'exploitation local, l'utilisateur a toujours accès à tous les services locaux, tels que l'impression, le couper-coller et les lecteurs réseau.

Empaquetage d'applications
Maintenant vous vous demandez peut-être comment créer un environnement indépendant entièrement fonctionnel où exécuter votre application virtualisée. Pour cela, vous devez utiliser le séquenceur de SoftGrid. Cet Assistant vous permet d'empaqueter des applications dans un environnement virtuel qui peut être livré et exécuté sur le client.
Le processus de séquençage comprend trois étapes : installation, configuration et test, et exécution. Dans la première étape, l'installation, le séquenceur de SoftGrid utilise un processus d'observation active pour contrôler l'installation de l'application et évaluer les dépendances des applications. Cela fait, la phase de configuration et de test permet d'apporter les modifications nécessaires à la configuration par défaut afin d'assurer l'expérience de première exécution souhaitée. Enfin, dans la phase d'exécution, le séquenceur de SoftGrid compile et organise le bloc de code nécessaire pour lancer l'application. Feature Block 1 (FB1) est le code essentiel nécessaire pour lancer l'application, permettant à l'utilisateur d'exécuter l'application sans télécharger le package entier.
Une fois qu'une application a été séquencée, quatre fichiers sont créés : un fichier d'application virtualisable (.sft), un fichier de description de logiciel ouvert (.osd), un fichier d'icônes (.ico) et un fichier de projet (.sprj). Ils sont ensuite copiés dans le répertoire de contenu de SVAS. L'administrateur a également la possibilité de publier les fichiers .ico et .osd sur les clients à l'aide d'un serveur HTTP.
Tandis que SoftGrid configure généralement des applications de sorte qu'elles s'exécutent indépendamment les unes des autres dans des environnements isolés, SystemGuard autorise une certaine interaction entre les applications. Vous devez examiner soigneusement toutes les dépendances que les applications peuvent avoir entre elles et séquencer les applications ensemble si elles demandent une interaction entre elles. Ce processus est habituellement appelé « suiting ». Notez que les applications nécessitant une interaction ne peuvent pas toutes être séquencées ensemble. Le suiting est un processus très compliqué et qui ne doit être effectué qu'après un examen soigneux des dépendances, car il arrive que le séquençage de deux applications ou plus annule les effets de la virtualisation.

Simplification de l'administration
La console de gestion SoftGrid offre un outil unique pour l'exécution de toutes les tâches administratives. La console de gestion est installée sur SVAS par défaut et peut être installée sur tout autre serveur ou poste de travail. Il s'agit d'un composant logiciel enfichable MMC 3.0 qui utilise le service Web de gestion SoftGrid pour se connecter au magasin de données SoftGrid (voir la figure 4), ce qui confère aux administrateurs autorisés l'accès total aux données enregistrées dans la base de données pour les opérations d'administration. La connexion entre la console de gestion et le service Web de gestion SoftGrid utilise la communication à distance de Microsoft .NET Framework, ce qui permet d'installer la console de gestion et le service Web sur le même serveur ou sur des serveurs différents. La figure 2 décrit comment ces divers éléments s'ajustent ensemble et fournissent un accès à l'ensemble de l'implémentation de SoftGrid. Notez que les grandes organisations doivent exécuter plus d'une instance du service Web de gestion SoftGrid.
Figure 4 Le service Web de gestion SoftGrid fournit la connexion au magasin de données
Figure 4 Le service Web de gestion SoftGrid fournit la connexion au magasin de données
Le service Web de gestion SoftGrid s'exécute sous Windows 2000 ou ultérieur avec IIS 5.0 ou ultérieur. .NET Framework 2.0 ou version ultérieure est nécessaire, de même que Microsoft Data Access Components (MDAC) 2.7 ou version ultérieure pour la connectivité de magasin de données.
La console de gestion fournit un outil d'administration unique à partir duquel les applications peuvent être publiées, fermées, etc. Les tâches sont organisées en neuf catégories ou conteneurs principaux, comme indiqué dans le menu dans la figure 5.
Figure 5 Administration de SoftGrid à partir d'une console de gestion unique
Figure 5 Administration de SoftGrid à partir d'une console de gestion unique
Voici un récapitulatif rapide des types de tâches de gestion de chaque conteneur. Le conteneur Applications est celui où l'administrateur peut effectuer des tâches telles qu'importer des fichiers .sprj pour publier de nouvelles applications, spécifier l'emplacement .osd, supprimer des applications, etc. Par défaut, ce conteneur inclut un package publié que vous pouvez utiliser pour tester la connectivité client au serveur d'applications.
Une association de types de fichier est créée lors du séquençage des applications. Une fois le package importé, les associations de types de fichier deviennent disponibles dans la console de gestion. Le conteneur File Type Associations fournit aux administrateurs un emplacement unique pour modifier toutes les associations de types de fichier.
Le conteneur Packages contrôle les versions des packages pour les mises à niveau actives ; il s'agit de mises à niveau d'application qui peuvent être effectuées sans déconnexion de l'utilisateur et sans arrêt du serveur. L'administrateur peut également supprimer un package à partir de la console de gestion en utilisant ce conteneur. Notez que la suppression d'un package du conteneur Packages supprimera le fichier .sft de la console de gestion et du magasin de données mais ne le supprimera pas du répertoire de contenu sur le serveur d'applications.
Comme nous l'avons mentionné précédemment, lorsqu'un utilisateur lance une application, un client SoftGrid vérifie la disponibilité des licences et ne lance l'application que si une licence est disponible dans un magasin de données. Le conteneur Application Licenses est celui où les administrateurs peuvent associer des licences avec les applications ; les licences illimitées, les licences simultanées et les licences nommées sont toutes prises en charge.
Le conteneur Server Groups contient un groupement logique de serveurs de virtualisation d'applications et d'informations de journalisation. Les administrateurs peuvent ajouter de nouveaux groupes de serveurs ou modifier les propriétés (telles que les ports utilisés pour la communication ou la mémoire et les processus alloués) d'un groupe existant.
Dans le conteneur Provider Policies, l'administrateur peut créer une série de règles appelée stratégies. Les stratégies de fournisseur personnalisées sont utilisées pour permettre aux utilisateurs d'accéder à de nombreuses applications dans différentes séries de conditions. Vous pouvez utiliser le conteneur Account Authorities pour spécifier un domaine et des informations d'authentification qui seront utilisés lorsque SoftGrid aura besoin d'un accès pour lire les informations d'annuaire du domaine. SoftGrid Administrators contient les groupes d'utilisateurs chargés de l'administration de l'environnement SoftGrid. Dans ce conteneur, les administrateurs peuvent ajouter ou supprimer des groupes pour contrôler les autorisations d'accès.
Enfin, le conteneur Reports, comme son nom l'indique, permet aux administrateurs de générer des rapports pour vérifier l'intégrité générale de l'environnement SoftGrid. Les rapports suivants sont disponibles : Application Utilization (utilisation des applications), Software Audit (audit des logiciels), System Utilization (utilisation du système), User/Group Activity (activité des utilisateurs/groupes) et System Error (erreur système).

Configuration du client
Le client SoftGrid est installé sur le système d'exploitation de l'ordinateur que l'utilisateur utilisera pour accéder à l'application virtualisée. Comme nous l'avons dit auparavant, deux types de client sont pris en charge : Microsoft SoftGrid for Desktops ou Microsoft SoftGrid for Terminal Services. Chaque approche a des avantages mais présente également certains inconvénients en termes de performances, de latence du réseau, de consolidation des batteries de serveurs et de facilité de gestion.
Dans une implantation de postes de travail, les applications sont disponibles localement et dépendent peu de la disponibilité et de la vitesse du réseau. Cette approche est recommandée, par exemple, pour les organisations qui possèdent des succursales avec une infrastructure informatique limitée. Les services Terminal Server constituent une bonne solution pour les organisation qui ont déjà déployé des serveurs des services Terminal Server. Ce scénario exploite efficacement le matériel et les logiciels, réduisant ainsi fortement le nombre de serveurs nécessaires. Et, bien sûr, il offre un véritable environnement libre placement. Les grandes organisations utiliseront généralement une combinaison d'infrastructures de bureau et Terminal Server. L'installation et la configuration des divers composants sont similaires pour les deux approches lorsque vous montez un déploiement SoftGrid.
Le client peut être déployé en utilisant une méthode standard comme l'installation manuelle ou le déploiement automatisé à l'aide d'un outil tel que Systems Management Server 2003. La figure 6 répertorie la configuration matérielle et logicielle minimale nécessaire pour installer ces clients.
Figure 6 Configuration requise pour les clients SoftGrid (Close Figure 6)

Client | Processeur | Mémoire | Espace disque | Système d'exploitation
Microsoft SoftGrid for Terminal Services | PIII 850 MHz | 1 Go de RAM (au minimum 256 Mo, la quantité nécessaire en réalité dépend du nombre d'utilisateurs et d'applications) | 12 Mo pour l'installation et 4096 Mo pour le cache | • Windows 2000 Server ou Advanced Server avec services Terminal Server activés • Windows Server 2003 avec services Terminal Server activés
Microsoft SoftGrid for Desktops | PIII 600 MHz | 128 Mo | 12 Mo pour l'installation et 2048 Mo pour le cache | • Windows 2000 Professionnel ou Windows XP • Windows 2000 Server ou Windows Server 2003
Bien que l'installation du client soit simple, vous devez fournir certaines propriétés lors de l'installation, notamment l'emplacement de l'installation, la taille de la mémoire cache, la lettre de lecteur à utiliser pour le lecteur virtuel, l'emplacement des fichiers de données d'application, etc. Une fois le client installé, certains paramètres supplémentaires peuvent être spécifiés ou modifiés à l'aide de la console de gestion de client.
Pour la lancer, ouvrez le panneau de configuration et démarrez SoftGrid Client Management à partir des outils d'administration. Vous pouvez choisir de vous connecter à l'ordinateur local ou à un ordinateur distant.
La figure 7 illustre la console de gestion de client comportant un conteneur racine et trois conteneurs enfants. L'onglet racine SoftGrid on localhost vous permet de spécifier la plupart des paramètres fonctionnels, y compris le répertoire des journaux, le répertoire des données d'application, le client exécuté et les paramètres d'affichage, la fréquence d'affichage des messages d'informations et des erreurs, la taille de cache maximale, le lecteur virtualisé, les options de réseau et de connectivité en cas de déconnexion du serveur SoftGrid et les autorisations.
Figure 7 Console de gestion de client
Figure 7 Console de gestion de client
Vous pouvez afficher et modifier les applications dans le conteneur Applications. Il fournit des informations d'état sur l'application locale, par exemple si l'application est en cours d'exécution, si l'application est verrouillée en cache et quel pourcentage de l'application (fichier .sft) a été transmis dans le cache local.
Le conteneur File Type Associations vous permet d'afficher, de modifier et de supprimer une association de types de fichier. Pour plus de détails, reportez-vous à notre discussion sur l'association de types de fichier dans la section précédente.
Le conteneur Desktop Configuration vous permet de spécifier, de modifier et d'actualiser manuellement les paramètres de serveur d'applications que vous avez spécifiés pendant l'installation. Ici, vous pouvez également indiquer si l'actualisation de client doit se produire lors de l'ouverture de session de l'utilisateur (sélection par défaut) et la durée de l'intervalle d'actualisation automatique.

Conclusion
La virtualisation d'applications avec Microsoft SoftGrid offre un moyen attrayant d'améliorer la fiabilité des systèmes et de simplifier la gestion. Bien qu'elle implique un certain nombre d'éléments fonctionnant ensemble, l'architecture s'ajuste en fait en douceur dans l'infrastructure informatique.
Microsoft SoftGrid for Desktops est disponible pour les clients Software Assurance dans le cadre de Microsoft Desktop Optimization Pack. Pour plus d'informations, consultez la page windowsvista.com/optimizeddesktop. Microsoft SoftGrid for Terminal Services est disponible sous forme de licence d'accès client autonome aux clients d'entreprise dans le cadre des accords de licence en volume de Microsoft. Pour télécharger une version d'évaluation, connectez-vous à votre compte de licence en volume à l'adresse https://licensing.microsoft.com et sélectionnez Desktop Optimization Pack for SA sous Téléchargements.

Ahmer Sabri est spécialiste technique au sein du groupe Financial Services de Microsoft. Vous pouvez le contacter à l'adresse suivante : ahmers@microsoft.com.
Kedar Shah est spécialiste technique au sein du groupe Financial Services de Microsoft. Vous pouvez le contacter à l'adresse suivante : kedars@microsoft.com.


 Le mot du r&#233;dacteur en chef: Dynamique et optimal
Le mot du rédacteur en chef
Dynamique et optimal
Joshua Trupin

Dans les mois à venir, vous entendrez probablement parler de deux stratégies informatiques de Microsoft : les systèmes dynamiques et l'optimisation d'infrastructure. Ces deux initiatives vous aideront à améliorer le taux de réussite de vos tâches informatiques actuelles, et vous aideront à faire face aux défis à venir.
L'initiative DSI (Dynamic Systems Initiative) définit une infrastructure pour les outils et les applications qui combine quatre domaines clés d'innovation technique pour orienter les approches informatiques de demain. Pour obtenir un environnement dynamique, votre infrastructure et vos logiciels doivent être unifiés et virtualisés, gérés par processus et basés sur des modèles, optimisés pour les services et orientés vers l'utilisateur.
La création d'un environnement informatique dynamique ne se limite toutefois pas aux produits de Microsoft. Votre entreprise peut consacrer une plus grande partie de ses investissements à la création d'avantages métier grâce à l'informatique, au lieu de simplement s'efforcer de gérer sa complexité grandissante. En utilisant les modèles d'Optimisation d'infrastructure pour déterminer les perspectives de votre entreprise sur les deux prochaines années, vous pouvez à la fois optimiser vos systèmes actuels et vous préparer pour un avenir plus dynamique.
En règle générale, le cycle de vie informatique d'une entreprise a atteint un niveau parmi ces quatre. Infrastructure de base : « Nous combattons les feux. » Infrastructure standardisée : « Nous prenons le contrôle. » Infrastructure rationalisée : « Nous facilitons l'activité. » Infrastructure dynamique : « Nous sommes un atout stratégique. » Ces niveaux sont chacun abordés en détail à l'adresse microsoft.com/io. Vous pouvez utiliser les aides qui s'y trouvent pour analyser votre infrastructure et planifier son avenir. En appliquant les concepts de Systèmes dynamiques, vous pouvez transformer votre organisation informatique en un élément clé de votre entreprise.
Une fois que votre organisation aura atteint le niveau Dynamique, vos systèmes informatiques seront des actifs stratégiques autogérés. Aaaaah, le Nirvana informatique. La meilleure façon de passer d'une étape à l'autre dans votre quête d'une informatique dynamique est d'utiliser la gamme System Center de solutions de gestion informatique. System Center fournit des outils de configuration, des applications de déploiement, un gestionnaire d'opérations, et bien plus encore; il englobe le cycle de vie informatique complet (planification, déploiement et maintenance).
Et bien sûr, TechNet Magazine peut vous aider à mettre le pied à l'étrier. Ce numéro porte sur la suite de solutions System Center. Commençons par des présentations générales de deux composants clés : System Center Configuration Manager 2007 et System Center Operations Manager 2007. Nous examinons également le déploiement et les opérations, ainsi que la gestion des succursales.
Votre infrastructure est-elle à la hauteur ? Venez visiter notre blog sur blogs.technet.com/tnmag et dites-nous où l'informatique dynamique vous mènera selon vous. —Joshua Trupin


 Bo&#238;te &#224; outils: Nouveaux produits pour les professionnels de l’informatique
Boîte à outils
Nouveaux produits pour les professionnels de l’informatique
Greg Steen

Gestion des données de configuration de démarrage
VistaBootPRO
www.vistabootpro.org
Tous les professionnels de l'informatique que je connais possèdent au moins une ou deux machines à démarrage multiple. Aujourd'hui, ces systèmes incluent généralement une instance de Windows Vista® ou Windows Server® 2008, ancien nom de code « Longhorn ». Si vous exécutez un système à démarrage multiple doté d'un de ces systèmes d'exploitation, vous devriez jeter un œil sur VistaBootPRO de PROnetworks.
Comme vous le savez probablement, depuis Windows Vista, Microsoft a modifié le mode de gestion de la configuration de démarrage. Au lieu d'utiliser un fichier texte lisible comme Boot.ini, vous avez maintenant le magasin des données de configuration de démarrage (BCD). Celui-ci offre une approche plus sécurisée et indépendante des microprogrammes pour la gestion des informations de l'environnement de démarrage. Il existe trois méthodes de base permettant d'examiner et de modifier votre BCD. La première consiste à utiliser MSConfig, qui vous donne un accès de base pour lire, modifier et réorganiser les entrées dans le BCD. Les administrateurs système sont probablement plus familiers avec la deuxième option, qui consiste à utiliser l'outil de ligne de commande BCDEdit. Avec cet outil, vous pouvez créer un nouveau magasin BCD, modifier les magasins existants et importer ou exporter des magasins pour l'archivage et la réutilisation. La troisième option consiste à gérer le BCD par programmation en utilisant son API Windows® Management Instrumentation (WMI).
Ces trois méthodes permettent d'exécuter la tâche, mais aucune d'elles n'est particulièrement conviviale. C'est là que VistaBootPRO entre en jeu, avec une interface graphique plus conviviale pour modifier la configuration de démarrage sur votre machine exécutant Windows Vista. Cet outil vous permet de renommer facilement les entrées de système d'exploitation, d'ajouter de nouvelles entrées, de modifier le lecteur de démarrage et de configurer des options d'expiration en quelques clics. De plus, VistaBootPRO vous permet de sélectionner une entrée de système d'exploitation et de définir les paramètres de démarrage, par exemple pour limiter les processeurs accessibles par le système d'exploitation, activer ou désactiver la prévention d'exécution des données pour les entrées Windows Vista ou Windows Server 2008, réduire la mémoire physique accessible par le système d'exploitation et exécuter le processus de démarrage en mode de débogage.
Avant d'effectuer toute modification de votre BCD à l'aide de cet outil, vous devez sauvegarder votre magasin actuel, en cas de problème. L'application vous avertira si vous n'avez pas effectué de sauvegarde et vous propose un moyen simple d'exporter la configuration actuelle. Et, bien sûr, VistaBootPRO vous permet de restaurer les configurations sauvegardées.
En résumé, VistaBootPRO est une application fonctionnelle facile à utiliser pour gérer votre BCD. Pour ne rien gâcher, il est gratuit

Prix : Gratuit.
Figure vistabootpro

Surveillez les services et périphériques
NetGong
netgong.tsarfin.com
Ahhh, les outils de surveillance... entre nous, je les adore. Si vous recherchez un nouveau moniteur de services et périphériques réseau ou si vous aimez bien jouer avec les utilitaires de surveillance, NetGong vous ravira.
Cette application s'exécute dans votre barre d'état système et se lance au démarrage de Windows. Un simple clic avec le bouton droit sur l'icône fournit une option permettant de démarrer ou d'arrêter rapidement la surveillance. Un double-clic sur l'icône permet d'afficher la principale interface utilisateur de configuration où vous pouvez configurer, consulter et afficher les événements pour vos hôtes sous surveillance.
La configuration d'un moniteur d'hôte est simple. Il suffit d'entrer l'hôte, le port TCP que vous souhaitez surveiller, l'intervalle d'exécution des tests et le type d'alerte que vous souhaitez recevoir. Vous pouvez également ajouter une description significative et modifier les paramètres par défaut du protocole ICMP (Internet Control Message Protocol), tels que le délai d'expiration, la taille de paquet et le nombre de tentatives. Par défaut, NetGong nécessite que l'hôte sous surveillance réponde aux requêtes ICMP, mais vous pouvez également désactiver cette option au moyen d'une case à cocher pour les hôtes silencieux qui n'acceptent pas les requêtes ICMP sur votre réseau.
L'application vous propose quatre catégories d'alertes : son, messages électroniques, messages et fichier. Pour le son, vous pouvez spécifier le fichier WAV que vous souhaitez utiliser. Pour les messages, vous pouvez définir un message de texte, le forcer à devenir la fenêtre supérieure et choisir de fermer la fenêtre automatiquement ou manuellement. Les alertes par message électronique vous permettent de spécifier un serveur SMTP et les détails du message à envoyer. L'option d'alerte par fichier vous permet d'exécuter un fichier exécutable (ou un fichier de commandes) avec des paramètres configurables, le mode de fenêtre et le répertoire de démarrage. Pour chacun des types d'alerte, vous pouvez configurer une planification qui définit le moment où envoyer la première alerte, le nombre maximal d'alertes à envoyer et l'intervalle d'échec (nombre d'échecs) entre les alertes. Vous pouvez également choisir d'être notifié lors de la récupération du service.
NetGong conserve aussi des fichiers journaux des résultats. Vous pouvez choisir de consigner les événements dans un journal d'événements, un fichier texte ou sur une page HTML créée de manière dynamique. Cette application vous permet d'afficher les résultats de la surveillance sur des pages servies via son serveur Web intégré en écoutant un port spécifié par l'utilisateur. Vous pouvez aussi envoyer un paramètre de chaîne de requête avec un intervalle d'actualisation pour obtenir une actualisation de la page Web avec les dernières informations des événements de surveillance.

Prix : 79,95 USD direct par machine (licence d'entreprise), 59,95 USD direct par machine (la licence académique), 39,95 USD direct par machine (licence personnelle).
Figure steen.toolbox.netgong

Critique
Windows PowerShell: TFM
www.sapienpress.com
Bien sûr, vous avez déjà entendu parler de Windows PowerShell™. Il semble que tout le monde en parle. TechNet Magazine lui a même consacré un article (écrit par un des auteurs de ce livre). Mais vous êtes vous vraiment penché sur cet outil ?
Windows PowerShell peut être un outil d'automatisation et de productivité extrêmement efficace une fois que vous maîtrisez son utilisation. Que vous soyez un novice des scripts ou un ninja de VBScript résolu à développer votre utilisation de ce nouveau langage de script et outil de ligne de commande centré sur l'administration, Windows PowerShell: TFM, par Don Jones et Jeffery Hicks, représente le point de départ idéal. Ce livre très abordable est orienté vers l'administrateur système et se concentre sur les informations utiles à la plupart des administrateurs.
La première section du livre présente l'environnement Windows PowerShell, couvrant les paramètres communs à tous les cmdlets et les principes fondamentaux de la syntaxe et de la sémantique du langage de script. Les concepts de redirection, traitement en pipeline de l'exécution, fonctions, variables et exécution de shells multiples sont également présentés. Puisque Windows PowerShell est basé sur Microsoft® .NET Framework, il hérite des avantages du code géré. (Notez que Windows PowerShell nécessite .NET Framework 2.0 ou version ultérieure.) Par conséquent, ce livre fournit également une vue d'ensemble des éléments essentiels de l'infrastructure, du contexte de sécurité dans lequel les scripts s'exécutent aux concepts de réflexion, d'assemblys et de classes.
Après avoir expliqué comment lier Windows PowerShell à Windows Management Instrumentation (WMI), les auteurs abordent en détail la structure du langage script Windows PowerShell, en fournissant des exemples qui vous aideront à comprendre la fonction des objets ainsi que leurs propriétés et méthodes associées. Vous verrez également comment utiliser les différents types d'opérateurs, des opérateurs arithmétiques de base aux opérateurs de comparaison au niveau du bit, ainsi que les expressions régulières puissantes permettant d'analyser les chaînes pour les éléments tels que les adresses IP et les noms de contrôleur de domaine. Cette section offre une base particulièrement utile pour toute personne résolue à maîtriser Windows PowerShell.
Les chapitres sur la gestion de Windows et l'écriture de script de base de données illustrent certaines fonctionnalités puissantes offertes par Windows PowerShell. Vous apprendrez à travailler avec les journaux d'événements, les processus, le registre, le système de fichiers et les services d'annuaire, et comment vous connecter aux requêtes de bases de données et exécuter celles-ci.
Les autres sections couvrent l'affichage et le formatage des données, la modularisation des scripts, la gestion des erreurs et le débogage. Les auteurs proposent même un jeu de méthodes recommandées pour l'écriture de scripts Windows PowerShell qui inclut les conventions d'attribution de nom, les commentaires de code et l'utilisation du retrait pour améliorer la lisibilité du code.
Vous voudrez certainement conserver le manuel à portée de main pour accéder facilement aux ressources des annexes, dont l'une est une référence pour les 133 cmdlets Windows PowerShell, tandis que l'autre est une référence pour les types le plus couramment utilisés (ainsi que les méthodes et les propriétés associées à ces types). En plus de fournir un guide rapide pour l'utilisation d'un cmdlet spécifique, ces références vous donnent un aperçu immédiat de l'étendue des fonctionnalités offertes par Windows PowerShell.

Prix : 49,99 USD catalogue.

Testez vos câbles
SMARTest Compact Network Cable Tester
www.hobbes-usa.com
Des câbles, des câbles partout ! En tant que professionnels de l'informatique, la plupart d'entre nous sommes entourés de câbles CAT5. Une multitude de câbles CAT5 : des centaines de fils, représentant des milliers de mètres. Et si vous êtes responsable de ces câbles, un bon testeur de câble facile à transporter n'est pas seulement pratique mais essentiel. C'est pour cela que vous devriez jeter un coup d'œil sur le SMARTest Compact Network Cable Tester de Hobbes.
Le SMARTest est un testeur de câble de type stylet. Il est compatible avec les câbles réseau CAT 3, 4, 5, 5e et 6 et peut vous aider à détecter les problèmes courants de fils de câble. En particulier, vous pouvez tester les paires ouvertes, court-circuitées, inversées, séparées, les erreurs de câblage et les problèmes de mise à la terre des câbles.
Cet appareil fonctionne sur quatre petites piles de style montre, il n'est donc pas nécessaire de connecter les câbles pour le test. Vous n'avez pas besoin non plus de relier SMARTest à une connexion réseau active. Pour tester un câble, il suffit de brancher une extrémité du fil dans l'unité principale et l'autre dans l'unité distante détachable. L'unité SMARTest possède une interface avec des connecteurs RJ45 femelle et mâle, de sorte que vous pouvez tester tout type d'installation de câble. Vous pouvez même utiliser le périphérique SMARTest pour tester les fils de vos tableaux de connexion et les prises murales.
Une autre fonctionnalité intéressante réside dans le générateur de tonalité intégré de l'appareil, qui permet d'envoyer un signal audio via le câble testé. Vous pouvez ensuite capter le signal avec une sonde de signal compatible, telle que l'outil Cable Tracer Probe, également disponible chez Hobbes.
SMARTest avec générateur de tonalité coûte de 80 à 90 USD, en fonction du détaillant. Il existe également un adaptateur de connecteur F en option pour tester les câbles coaxiaux.

Prix : 99,99 USD catalogue.
Figure steen.toolbox.smartest

Greg Steen est un professionnel de l’informatique, dynamique et enthousiaste. Il est constamment à la recherche de méthodes et d’outils innovants destinés à faciliter les opérations et le développement pour les professionnels de l’informatique.


 Forum aux questions sur SQL: Recherche de verrous, requ&#234;tes de grande ampleur, statistiques d'E/S et bien plus encore
Forum aux questions sur SQL
Recherche de verrous, requêtes de grande ampleur, statistiques d'E/S et bien plus encore
Par Nancy Michell
Télécharger le code de cet article: SQLQandA2007_08.exe (151KB)

Q Je dois afficher le nom des objets de toutes les bases de données qui sont verrouillées. Comment faire ?

R Dans SQL Server™ 2000, vous pouvez interroger la table système syslocks dans la base de données master ou exécuter sp_lock pour obtenir les informations de verrouillage actuelles, comme suit :
SELECT * FROM master..syslocks
EXEC sp_lock
Cependant, imaginons que vous vouliez traduire des NOMS d'objets réels de ObjID à partir du RÉSULTAT de la procédure stockée sp_lock (ou à partir de la colonne id dans master..syslocks).
Dans SQL Server 2005 SP1 et versions antérieures, la fonction OBJECT_NAME vous permettait uniquement de transmettre un paramètre : object_id. Ainsi, pour obtenir le nom d'objet correctement, vous deviez travailler dans la base de données ACTUELLE avant d'exécuter OBJECT_NAME. Cela rendait la surveillance des verrous en cours difficile, puisque vous deviez écrire un code personnalisé qui créait une boucle dans chaque base de données pour obtenir l'OBJECT_NAME correct.
USE DBNAME
SELECT OBJECT_NAME(object_id)
SQL Server 2005 SP2 améliore cette procédure en ajoutant un deuxième paramètre, database_id. Ce nouveau paramètre vous permet d'interroger des noms d'objet quelle que soit la base de données ACTUELLE à laquelle vous êtes connecté.
OBJECT_NAME ( object_id [, database_id ] )
Désormais, vous pouvez interroger sys.dm_tran_locks et récupérer le nom d'objet pour chaque base de données, comme ceci :
SELECT
DB_NAME(resource_database_id),
OBJECT_NAME(resource_associated_entity_id, resource_database_id)
FROM sys.dm_tran_locks
WHERE resource_type='OBJECT'
Notez, cependant, que cela fonctionne uniquement dans SQL Server 2005 SP2 et versions ultérieures. Si vous exécutez cette procédure dans une version antérieure de SQL Server 2005, vous obtiendrez l'erreur suivante :
Msg 174, Level 15, State 1, Line 1
The object_name function requires 1 argument(s).
Un autre exemple, illustré à la figure 1, s'ajoute à sys.dm_exec_sessions pour obtenir des informations sur les ID de processus de service (SPIDS) impliqués dans les verrous. Pour plus d'informations, consultez la documentation SQL Server en ligne à l'adresse technet.microsoft.com/library/ms130214(sql.90).aspx.
Figure 1 Recherche d'ID de processus de serveur (Close Figure 1)
SELECT
DB_NAME(resource_database_id) as DBName,
OBJECT_NAME(resource_associated_entity_id, resource_database_id) AS ObjectName,
request_mode,
request_type,
request_session_id,
es.host_name,
es.login_name,
es.login_time
FROM
sys.dm_tran_locks tl
INNER JOIN sys.dm_exec_sessions es
ON tl.request_session_id=es.session_id
WHERE resource_type='OBJECT'

Q J'ai une large requête SQL dynamique qui semble parfois dépasser la durée de NVARCHAR(max). Existe-t-il une façon de contourner ce problème me permettant de continuer à exécuter une chaîne de grande taille ?

R Si vous dépassez la longueur de NVARCHAR(max), vous obtenez une requête de 2 Go ! Vous devez aussi probablement convertir toutes les chaînes que vous concaténez vers NVARCHAR(max). Cependant, une solution plus commode, qui a également l'avantage d'être efficace dans les versions de SQL Server antérieures à SQL Server 2005, consiste à concaténer plusieurs petites chaînes ensemble. Voici un exemple :
DECLARE @q1 NVARCHAR(4000), @q2 NVARCHAR(4000), @q3 NVARCHAR(4000)
SET @q1 = 'SELECT...'
SET @q2 = 'FROM...'
SET @q3 = 'WHERE...'
EXEC (@q1 + @q2 + @q3)
CONSEIL : Utilisation de la clause OUTPUT
Vous pouvez désormais auditer les modifications que vous effectuez en utilisant des instructions DML (Data Manipulation Language) sans même utiliser des déclencheurs. SQL Server 2005 a introduit une clause OUTPUT intégrée aux instructions DML qui peut vous aider à suivre les modifications effectuées pendant une opération DML. La clause OUTPUT peut enregistrer le jeu de résultats dans une table ou une variable de table.
Sa fonctionnalité est semblable à celle des déclencheurs dans les tables INSERTED et DELETED, accédaient aux lignes modifiées pendant l'opération DML. Pour voir comment cela fonctionne, modifions l'adresse de la table d'adresses en l'inverse de l'adresse originale, comme illustré à la figure ci-dessous. Vous pouvez également utiliser la logique affichée dans ce code pour suivre les modifications apportées aux données et les enregistrer dans une table.
Le résultat de la requête aura la forme suivante :
Original Value:'1234 One Microsoft Way, Redmond, Wa.' has been changed to: '.aW,dnomdeR
,yaW tfosorciM enO 4321'

Modification d'une adresse
--Create the address table
Create Table Address (ProductID Int, SupplierID Int, Address Varchar(255))

--Insert data
Insert into Address Values (234,567,'1234 One Microsoft Way, Redmond, Wa.')

--Declare a table variable
Declare @Recordchanges table (change Varchar(255))

--Update the address
Update Supplier.Address
Set Address=reverse(address)

--Record the updates into the table variable
OUTPUT 'Original Value:' + DELETED.Address+' has been changed to: '+ INSERTED.Address+''
into @RecordChanges

--Query the changes from table variable
Select * from @RecordChanges

Q J'ai une installation SQL Server 2005 en tant que cluster stratégique sur Windows Server® 2003. Le service MS DTC (Microsoft® Distributed Transaction Coordinator) a été « clusterisé » sur le même groupe que le cluster Quorum, mais utilise une ressource disque dédiée (MS DTC partage le même nom de réseau et la même adresse IP que le groupe de clusters Quorum). Je veux aligner cette configuration sur les meilleures pratiques Microsoft. Par conséquent, j'ai besoin de conseils pour déplacer MS DTC vers un groupe de clusters dédiés. Est-il suffisant de supprimer les services MS DTC à l'aide de l'outil d'administration de cluster et de les recréer sur un groupe dédié ?

R Puisque vous disposez déjà d'une ressource disque dédiée pour MS DTC, vous pouvez simplement supprimer la ressource et la créer dans un nouveau groupe. Vous devez aussi créer un nouveau nom de réseau et une adresse IP virtuelle dans le nouveau groupe.
Vous pouvez également créer le nouveau nom de réseau et l'adresse IP dans le groupe de clusters et modifier les dépendances aux nouvelles ressources. Vous pouvez ensuite faire glisser MS DTC vers un nouveau groupe qui prendra le disque dédié ainsi que les nouvelles ressources.

Q Je voudrais afficher les statistiques d'E/S dans les fichiers de base de données physiques d'une base de données. Que dois-je utiliser ?

R La fonction système fn_virtualfilestats, disponible dans SQL Server 2000 et SQL Server 2005, ou sys.dm_io_virtual_file_stats (dans SQL Server 2005 uniquement) vous permet de faire exactement ce que vous souhaitez. Cette fonction renvoie les informations statistiques recueillies depuis le dernier démarrage de l'instance de SQL Server. Un exemple des résultats est illustré à la figure 2.
Figure 2 Affichage des statistiques d'E/S dans une base de données (Close Figure 2)

DbId | FileId | TimeStamp | NumberReads | NumberWrites | BytesRead | BytesWritten | IoStallMS
20 | 1 | 250765718 | 381 | 0 | 3350528 | 0 | 951
20 | 2 | 250765718 | 12 | 8 | 409600 | 491520 | 0
20 | 3 | 250765718 | 5 | 0 | 40960 | 0 | 16
La compréhension de l'impact d'E/S sur les fichiers de données sous-jacents peut vous aider à mieux planifier des éléments tels que l'emplacement physique des fichiers et des groupes de fichiers sur les volumes de données, en détectant les goulots d'étranglement d'E/S possibles, en effectuant la maintenance de base de données au niveau fichier et d'autres tâches semblables. Cette fonction est particulièrement utile pour examiner l'impact d'E/S pour les bases de données volumineuses comportant plusieurs fichiers et groupes de fichiers.
La requête permettant d'afficher les informations d'E/S des fichiers pour SQL Server 2000 ressemble à ceci :
SELECT *
FROM ::fn_virtualfilestats(default,default)
GO
Pour afficher un databaseID spécifique, transmettez l'ID de la base de données, comme suit :
SELECT *
FROM ::fn_virtualfilestats(7,default)
GO
Voici le code SQL Server 2005 qui affiche les statistiques de fichier pour toutes les bases de données du serveur :
SELECT *
FROM ::fn_virtualfilestats(NULL,NULL)
GO
La requête suivante renvoie les statistiques de fichier pour la base de données actuelle uniquement :
SELECT *
FROM ::fn_virtualfilestats(NULL,NULL)
WHERE DBID=db_id()
GO
Pour SQL Server 2005, il existe également une nouvelle fonction système appelée sys.dm_io_virtual_file_stats, qui est destinée à remplacer par la suite la fonction héritée fn_virtualfilestats :
sys.dm_io_virtual_file_stats(
{ database_id | NULL },
{ file_id | NULL }
)
Voici comment l'utiliser :
SELECT * FROM sys.dm_io_virtual_file_stats(NULL,NULL)
Si vous souhaitez générer un rapport plus lisible qui présente les noms de base de données et de fichier réels à partir du résultat, vous pouvez utiliser le code fourni dans le téléchargement associé sur SQL Server 2000 ou SQL Server 2005. Le code est disponible sur le site Web TechNet Magazine.

Q J'ai besoin d'un moyen rapide de voir si une transaction de suppression a activé un déclencheur. Savez-vous comment je peux obtenir cette information ?

R Lors de l'utilisation d'un déclencheur qui gère les opérations de suppression, d'insertion et de mise à jour, différentes techniques permettent de déterminer si celui-ci a été activé par une transaction de suppression. Une méthode très prisée consiste à comparer le nombre de tables virtuelles insérées et supprimées pour voir s'ils correspondent. Cependant, il existe une méthode plus simple : Vous pouvez utiliser la fonction Columns_Updated à la place.
En effet, lorsqu'un déclencheur est activé par une transaction de suppression, Columns_Updated renvoie toujours la valeur varbinary 0x. Le contrôle suivant vérifiera que le déclencheur a été activé par une suppression :
IF Columns_Updated() = 0x
CONSEIL : Initialisation des fichiers de données et des fichiers journaux
Saviez-vous que les fichiers de données et les fichiers journaux sont initialisés pour remplacer les données se trouvant toujours sur le disque qui proviennent de fichiers précédemment supprimés ? Les fichiers de données et les fichiers journaux sont d'abord initialisés avec des zéros lorsque vous créez une base de données, ajoutez des fichiers, un journal ou des données à une base de données existante, augmentez la taille d'un fichier existant (opérations de croissance automatique y compris) ou restaurez une base de données ou un groupe de fichiers. L'initialisation des fichiers augmente le temps d'exécution de ces opérations. Toutefois, lorsque les données sont écrites dans le fichier pour la première fois, le système d'exploitation n'a pas besoin de remplir les fichiers de zéros.
Dans SQL Server 2005, les fichiers de données peuvent être initialisés instantanément. Cela permet une exécution rapide des opérations de fichier mentionnées précédemment. L'initialisation instantanée des fichiers récupère l'espace disque utilisé sans remplir cet espace de zéros. Au lieu de cela, le contenu de disque est remplacé à mesure que les nouvelles données sont écrites dans les fichiers. Les fichiers journaux ne peuvent pas être initialisés instantanément. L'initialisation instantanée de fichiers n'est disponible que sur Windows XP Professionnel et Windows Server 2003 ou versions ultérieures.
Comme le contenu du disque supprimé n'est remplacé que lorsque de nouvelles données sont écrites dans les fichiers, une entité de sécurité non autorisée peut accéder au contenu supprimé. Même si le fichier de base de données est attaché à l'instance SQL Server, le risque de divulgation de ces informations est limité par la liste DACL (Discretionary Access Control List) du fichier. Cette liste DACL n'autorise l'accès au fichier qu'à l'administrateur local et au compte de service SQL Server. Cependant, quand le fichier est détaché, un utilisateur ou un service ne bénéficiant pas de l'autorisation SE_MANAGE_VOLUME_NAME peut y accéder. Une menace similaire existe quand la base de données est sauvegardée Un service ou un utilisateur non autorisé peut accéder au contenu supprimé si le fichier de sauvegarde n'est pas protégé par une liste DACL appropriée.
Si le risque de divulgation du contenu supprimé constitue un problème, assurez-vous toujours que les fichiers de sauvegarde et les fichiers de données détachés possèdent des listes DACL restrictives. Désactivez l'initialisation instantanée des fichiers pour l'instance SQL Server en retirant l'autorisation SE_MANAGE_VOLUME_NAME au compte de service SQL Server.

Thanks to the following Microsoft IT pros for their technical expertise: Christian Bolton, Dan Carollo, Robert Davis, Jorge Guzman, Saleem Hakani, Ward Pond, Kalyan Yella, and Paolo Zavatarelli.


 Coup de projecteur sur les utilitaires: BGInfo
Coup de projecteur sur les utilitaires
BGInfo
Lance Whitney
Télécharger le code de cet article: BgInfo v4.10 (274KB)

Vous essayez de résoudre un problème sur l'ordinateur d'un utilisateur et vous avez besoin d'informations sur cet ordinateur (nom, adresse IP, passerelle, mémoire, espace disque libre, etc.). Rassembler toutes ces données vous oblige d'habitude à fouiller dans différentes sources ou à poser une foule de questions à l'utilisateur. Ne serait-ce pas pratique si tout ce que vous avez besoin de savoir sur un ordinateur était au même endroit ? C'est possible, grâce à un outil gratuit de Sysinternals appelé BGInfo.
Écrit par Bryce Cogswell, BGInfo (abréviation de Background Information) demande les données clés à un poste de travail ou un serveur Windows®, tout des statistiques réseau (adresse IP, routeur, nom de domaine, adresse MAC) aux informations de matériel et de logiciel (nom d'ordinateur, mémoire, version du système d'exploitation et niveau de Service Pack). Le programme affiche ensuite toutes ces données sur le bureau sous forme de papier peint, rendant les informations clairement visibles sans être envahissantes (voir la figure 1).
Figure 1 BGInfo affiche les informations système sur le bureau
Figure 1 BGInfo affiche les informations système sur le bureau
Pour exécuter BGInfo, double-cliquez simplement sur le fichier bginfo.exe, aucune installation n'est nécessaire. L'écran de configuration apparaît pour vous permettre de consulter et de sélectionner les champs de données à afficher. Par défaut, BGInfo fournit 24 informations distinctes. Vous pouvez supprimer n'importe quel champ que vous ne voulez pas voir, puis le rajouter plus tard si vous changez d'avis. Vous pouvez également faire apparaître facilement des champs supplémentaires. BGInfo affichera n'importe quelle variable environnementale, la plupart des valeurs de registre et le résultat des requêtes provenant de VBScript et Windows Management Instrumentation (WMI). L'interface WMI offre un moyen simple de générer des requêtes en sélectionnant des valeurs dans un menu déroulant. BGInfo peut également creuser dans certains fichiers pour afficher leurs informations de version, d'horodatage et de contenu.
L'affichage est hautement personnalisable. Vous pouvez modifier divers attributs du texte : l'alignement, la police, la taille et la couleur. De plus, vous pouvez déplacer les données dans différentes parties du bureau et spécifier la largeur maximale de leur zone d'affichage en pouces. Enfin, BGInfo vous permet d'ajouter des graphiques à côté des données de texte, vous pouvez donc afficher une image, telle que le logo de votre entreprise. À l'inverse, si vous préférez ne pas afficher toutes ces informations sur le bureau, configurez plutôt BGInfo en tant qu'icône dans la barre d'état système. Cliquez dessus pour l'afficher complètement.
Après avoir effectué vos choix de mise en forme, vous pouvez cliquer sur le bouton d'aperçu pour vérifier l'affichage avant de valider, puis l'appliquer s'il vous convient. Vous pouvez exécuter BGInfo manuellement sur n'importe quel ordinateur quand vous en avez besoin ou le maintenir à jour automatiquement. Pour actualiser les données régulièrement, ajoutez le fichier BGInfo.exe au dossier de démarrage ou configurez-le en tant que Tâche planifiée. Après avoir personnalisé BGInfo sur un ordinateur, vous souhaiterez probablement utiliser les mêmes paramètres sur d'autres PC. Pour cela, enregistrez vos paramètres dans un fichier BGI, puis chargez-les sur les autres ordinateurs exécutant le programme.
Bien que vous puissiez exécuter BGInfo sur un ordinateur à la fois, vous pourriez vouloir le lancer sur plusieurs clients réseau. Vous pouvez insérer le fichier bginfo.exe dans un script d'ouverture de session ; le programme fournit plusieurs options de ligne de commande pour contrôler son comportement. Les données recueillies par BGInfo peuvent également être exportées vers un fichier externe (fichier texte, classeur Excel®, base de données Access™ ou SQL), de façon à disposer d'une ressource pratique contenant toutes les statistiques des ordinateurs du réseau.
Les informations d'aide incluses avec BGInfo sont exhaustives et faciles à suivre. Elles offrent même des conseils sur la façon d'écrire des requêtes VBScript et WMI simples dont le résultat peut être capturé par BGInfo. Le programme s'exécute sur toutes les versions de Windows, de Windows 95 à Windows Vista®. Pour en savoir plus sur BGInfo et télécharger l'outil, rendez-vous sur microsoft.com/technet/sysinternals/Miscellaneous/BgInfo.mspx.

Lance Whitney est consultant en informatique, formateur et rédacteur technique. Il a passé un nombre d'heures incalculable à affiner des postes de travail et serveurs Windows. Journaliste de formation, il s'est reconverti à l'informatique il y a 15 ans.


 Le petit c&#226;bleur: Configuration automatique&#160;IPv6 dans Windows&#160;Vista
Le petit câbleur
Configuration automatique IPv6 dans Windows Vista
Joseph Davies

IPv6 ne se limite pas à étendre l'espace d'adressage de 32 bits dans IPv4 à 128 bits. Les hôtes IPv6 peuvent aussi se configurer automatiquement, même sans avoir recours à un protocole de configuration des adresses tel que DHCP for IPv6 (DHCPv6).
Conformément à RFC 2462, tous les nœuds IPv6 configurent automatiquement une adresse lien-local pour chaque interface. Un hôte IPv6 utilise également la découverte de routeur (un échange de messages de sollicitation de routeur et d'annonce de routeur), pour déterminer les adresses supplémentaires et les paramètres de configuration. Les indicateurs Managed Address Configuration (M) et Other Stateful Configuration (O), qui indiquent si l'hôte doit utiliser DHCPv6 pour les adresses supplémentaires ou les paramètres de configuration, sont inclus dans le message d'annonce de routeur envoyé par le routeur.

Types de configuration automatique IPv6
Outre l'adresse lien-local, les hôtes peuvent également utiliser la configuration automatique sans état pour configurer des adresses et d'autres paramètres en fonction de la réception des messages d'annonce de routeur. Ces messages peuvent inclure une ou plusieurs options d'information de préfixe, que l'hôte de réception peut utiliser pour dériver des adresses sans état.
De même, la configuration automatique avec état est la configuration d'adresses et d'autres paramètres en fonction de l'utilisation de DHCPv6 pour obtenir des adresses. Un hôte utilise la configuration automatique avec état lorsqu'il reçoit un message d'annonce de routeur avec l'indicateur M configuré sur 1.
Enfin, un hôte peut aussi utiliser la configuration automatique sans et avec état, qui est une combinaison d'adresses incluses dans l'annonce de routeur et obtenues à partir d'un serveur DHCPv6.

États des adresses configurées automatiquement
Lorsqu'une adresse configurée automatiquement est dans l'état provisoire, cela signifie que son unicité est en cours de vérification via la détection d'adresse en double (DAD). Pour plus d'informations sur l'exécution de DAD, reportez-vous à l'encadré « Processus de configuration automatique IPv6 selon RFC 2462 ».. Une adresse est dans l'état valide lorsque son unicité a été vérifiée. Elle peut alors être utilisée pour envoyer et recevoir un trafic monodiffusion. L'état valide inclut les états préférés et les états désapprouvés. Dans l'état préféré, l'adresse peut être utilisée pour une communication illimitée. Dans l'état désapprouvé, l'adresse ne doit pas être utilisée pour une nouvelle communication, mais les communications existantes peuvent continuer.
Processus de configuration automatique IPv6 selon RFC 2462
Les étapes suivantes décrivent le processus de configuration automatique pour un hôte IPv6 comme défini par RFC 2462 :
  • Dérivation d'une adresse lien-local provisoire avec un ID d'interface basé sur EUI-64.
  • Exécution de DAD sur l'adresse lien-local provisoire par l'envoi d'un message de sollicitation de voisin avec l'adresse cible du message définie sur l'adresse lien-local provisoire.
  • Si un message d'annonce de voisin envoyé en réponse au message de sollicitation de voisin est reçu, l'adresse lien-local provisoire est une adresse en double. Arrêt de la configuration automatique des adresses. À ce stade, une configuration manuelle doit être exécutée sur l'hôte.
  • Si aucun message d'annonce de voisin (envoyé en réponse au message de sollicitation de voisin) n'est reçu, l'adresse lien-local provisoire est unique. Définissez l'état de l'adresse dans l'interface sur préféré.
  • Envoyez un message de sollicitation de routeur.
  • Si aucun message d'annonce de routeur n'est reçu, utilisez DHCPv6 pour obtenir les adresses et autres paramètres de configuration.
  • Si un message d'annonce de routeur est reçu, configurez les adresses provisoires pour les préfixes inclus et exécutez la détection d'adresses en double pour chaque adresse provisoire. Si les adresses sont uniques, définissez l'état des adresses dans l'interface sur préféré.
  • Si l'indicateur M du message d'annonce de routeur est défini sur 1, utilisez DHCPv6 pour obtenir des adresses supplémentaires avec état.
  • Si l'indicateur M du message d'annonce de routeur est défini sur 0 et que l'indicateur O est défini sur 1, utilisez DHCPv6 pour obtenir les paramètres de configuration supplémentaires.

Un routeur d'annonce ou un serveur DHCPv6 spécifie les durées de vie valides et préférées pour un préfixe d'adresse. Une adresse entre dans l'état désapprouvé lorsque la durée de vie préférée de l'adresse a été dépassée. La durée de vie préférée d'une adresse configurée automatiquement est actualisée par la réception d'annonces de routeur ou par le renouvellement de la configuration des adresses DHCPv6. La figure 1 illustre les états d'une adresse configurée automatiquement et leur relation avec les durées de vie préférées et valides.
Figure 1 États d'une adresse configurée automatiquement
Figure 1 États d'une adresse configurée automatiquement
Á l'exception de la configuration automatique pour les adresses lien-local, la configuration automatique des adresses est spécifiée uniquement pour les hôtes IPv6. Les routeurs IPv6 doivent obtenir les paramètres d'adresse et de configuration par un autre moyen, tel que la configuration manuelle.
L'encadré « Processus de configuration automatique IPv6 selon RFC 2462 » décrit le processus détaillé de la configuration automatique des adresses IPv6 pour les hôtes défini par RFC 2462.

Comportement de la configuration automatique IPv6 pour Windows Vista
Les ordinateurs exécutant Windows Vista® ou Windows Server® 2008, ancien nom de code « Longhorn », génèrent par défaut des ID d'interface aléatoires pour les adresses IPv6 non temporaires configurées automatiquement, y compris les adresses publiques et lien-local, au lieu des ID d'interface basés sur EUI-64. Une adresse IPv6 publique est une adresse globale enregistrée dans DNS qui est généralement utilisée par les applications serveur pour les connexions entrantes, telles qu'un serveur Web. Vous pouvez désactiver ce comportement par défaut avec la commande :
netsh interface ipv6 set global randomizeidentifiers=disabled
Lorsque celui-ci est désactivé, IPv6 utilise les ID d'interface basés sur EUI-64.
Avec un ID d'interface dérivé de façon aléatoire, le risque de dupliquer l'adresse lien-local est très faible. Par conséquent, les ordinateurs exécutant Windows Vista ou Windows Server 2008 n'attendent pas que DAD se termine pour envoyer des messages de sollicitation de routeur utilisant leurs adresses lien-local dérivées. Ce processus est appelé optimistic DAD. La découverte de routeur et DAD sont exécutés en parallèle pour gagner du temps pendant le processus d'initialisation de l'interface.
Les ordinateurs exécutant Windows Vista ou Windows Server 2008 ne tentent pas la configuration automatique des adresses avec état avec DHCPv6 si aucune annonce de routeur n'est reçue.
Processus de configuration automatique IPv6 dans Windows Vista
Les étapes suivantes décrivent le processus de configuration automatique pour un hôte IPv6 exécutant Windows Vista :
  • Dérivez une adresse lien-local provisoire pour l'interface LAN avec un ID d'interface dérivé de façon aléatoire (paramètre par défaut).
  • Exécutez DAD pour l'adresse lien-local dérivée de l'interface LAN (envoyez un message de sollicitation de voisin avec le champ Adresse cible défini sur l'adresse lien-local provisoire).
  • Exécutez la découverte de routeur dans l'interface LAN (envoyez un message de sollicitation de routeur à partir de l'adresse lien-local provisoire).
  • Si un message d'annonce de voisin envoyé en réponse au message de sollicitation de voisin envoyé à l'étape 2 est reçu, marquez l'adresse lien-local comme doublon.
  • Si aucun message d'annonce de voisin en réponse au message de sollicitation de voisin n'est reçu, définissez l'état de l'adresse lien-local dans l'interface LAN sur préféré.
  • Si aucune annonce de routeur n'est reçue, arrêtez la configuration automatique des adresses IPv6 dans l'interface LAN. Passez à l'étape 13.
  • Si une annonce de routeur est reçue, créez des adresses publiques provisoires correspondant aux préfixes d'adresse locale globaux ou uniques dans le message basé sur l'ID d'interface aléatoire dérivé à l'étape 1 et exécutez DAD.
  • Créez des adresses temporaires provisoires correspondant aux préfixes d'adresse locale globaux ou uniques dans le message à l'aide de nouveaux ID d'interface aléatoires dérivés de façon aléatoire et exécutez DAD.
  • Pour chaque nouvelle adresse, si aucun message d'annonce de voisin en réponse au message de sollicitation de voisin n'est reçu, définissez l'état de l'adresse sur l'interface LAN sur préféré.
  • Si les indicateurs M et O de l'annonce de routeur sont définis sur 0, arrêtez la configuration automatique IPv6 sur l'interface LAN. Passez à l'étape 13.
  • Si l'indicateur M de l'annonce de routeur est défini sur 1, utilisez DHCPv6 pour obtenir les adresses IPv6 avec état et les paramètres de configuration supplémentaires.
  • Si l'indicateur M de l'annonce de routeur est défini sur 0 et que l'indicateur O est défini sur 1, utilisez DHCPv6 pour obtenir les paramètres de configuration supplémentaires.
  • Dérivez les adresses lien-local ISATAP en fonction des adresses IPv4 de l'interface LAN et attribuez-les à l'interface de tunnel ISATAP.
  • Tentez de résoudre le nom d'hôte « ISATAP » vers une adresse IPv4.
  • Si le nom d'hôte « ISATAP » ne peut pas être résolu, arrêtez la configuration IPv6.
  • Si le nom d'hôte « ISATAP » est résolu vers une adresse IPv4, envoyez une sollicitation de routeur encapsulée IPv4 au routeur ISATAP.
  • Si une annonce du routeur ISATAP est reçue, créez les adresses ISATAP supplémentaires correspondant aux préfixes d'adresse locale globaux ou uniques publiés et attribuez-les à l'interface de tunnel ISATAP.

Adresses configurées automatiquement pour Windows Vista
Comme décrit précédemment, le protocole IPv6 pour Windows Vista et Windows Server 2008 configure automatiquement les adresses lien-local à l'aide d'identificateurs d'interface dérivés de façon aléatoire pour toutes les interfaces LAN.
Si une annonce de routeur reçue inclut un préfixe local global ou unique, IPv6 configure des adresses locales globales ou uniques à l'aide du même ID d'interface dérivé de façon aléatoire et les attribue à l'interface LAN qui a reçu l'annonce de routeur. Ces adresses sont appelées adresses publiques.
Par défaut, IPv6 dans Windows Vista configure aussi des adresses locales globales ou uniques temporaires à l'aide de différents ID d'interface dérivés de façon aléatoire et les attribue à l'interface LAN qui a reçu l'annonce de routeur. Les adresses temporaires sont définies par RFC 3041 et sont utilisées pour fournir un niveau d'anonymat pour les communications initiées par le client. En revanche, IPv6 dans Windows Server 2008 ne crée pas d'adresses temporaires par défaut. Vous pouvez activer les adresses temporaires en utilisant la commande :
netsh interface ipv6 set privacy-enabled
Si l'indicateur M est défini sur 1 dans les messages d'annonce de routeur reçus, IPv6 utilise DHCPv6 pour configurer des adresses locales globales ou uniques supplémentaires pour l'interface LAN.
IPv6 crée également une interface de tunnel ISATAP (IntraSite Automatic Tunnel Addressing Protocol) pour chaque interface LAN de l'hôte. RFC 4214 décrit la technologie de transition IPv6 ISATAP. Avec ISATAP, les hôtes IPv6 peuvent communiquer sur un intranet compatible IPv4 uniquement en encapsulant un paquet IPv6 avec un en-tête IPv4. Pour plus d'informations sur ISATAP, consultez le document « Technologies de transition IPv6 ».
Pour chaque interface de tunnel ISATAP, IPv6 configure des adresses lien-local ISATAP pour les adresses IPv4 qui sont attribuées à son interface LAN correspondante. Par exemple, pour l'interface de tunnel ISATAP qui correspond à une interface LAN à laquelle est attribuée l'adresse IPv4 192.168.91.211, IPv6 attribue l'adresse lien-local ISATAP FE80::0:5EFE:192.168.91.211.
Les hôtes ISATAP exécutent également la découverte de routeur ISATAP. Pour recevoir une annonce d'un routeur ISATAP, IPv6 doit pouvoir résoudre par défaut le nom d'hôte « ISATAP » vers une adresse IPv4. Pour ce faire, les méthodes Windows de résolution de noms d'hôte telles que DNS sont utilisées. Une fois que le nom est résolu, l'hôte envoie un sollicitation de routeur encapsulée IPv4 au routeur ISATAP. Le routeur ISATAP envoie ensuite une annonce de routeur encapsulée IPv4 à l'hôte. En fonction du contenu de l'annonce de routeur reçue, IPv6 configure également les adresses ISATAP locales globales ou uniques sur les interfaces de tunnel ISATAP.
Windows Vista prend également en charge les technologies de transition IPv6 6to4 et Teredo. Cependant, pour simplifier les choses, je n'aborderai pas ici la configuration automatique des interfaces de tunnel 6to4 et Teredo d'un hôte IPv6 Windows Vista.
L'encadré « Processus de configuration automatique IPv6 dans Windows Vista » décrit le processus de configuration automatique d'adresse pour un hôte IPv6 Windows Vista avec une seule interface LAN configurée avec des préfixes d'adresse locale globaux ou uniques sur son réseau local ou sur les interfaces de tunnel ISATAP.
Par exemple, un hôte exécutant Windows Vista possède une seule interface LAN. L'hôte reçoit une annonce de routeur sur son interface LAN avec les indicateurs M et O définis sur 0 et contient les préfixes 2001:DB8:D005:F282::/64 et FD4A:3A9:27A1:F282::/64. Il ne reçoit pas de message d'annonce de routeur provenant d'un routeur ISATAP. La figure 2 illustre le résultat de la commande
Figure 2 Le résultat de netsh interface IPv6 affiche l'adresse (Close Figure 2)
Interface 1: Loopback Pseudo-Interface 1

Addr Type DAD State Valid Life Pref. Life Address
--------- ----------- ---------- ---------- ------------------------
Other   Preferred  infinite infinite ::1

Interface 8: Local Area Connection

Addr Type DAD State Valid Life Pref. Life Address
--------- ----------- ---------- ---------- ------------------------
Temporary Preferred 6d19h37m21s 6d19h37m21s 2001:db8:d005:f282:ed46:5dd4:5439:2e1c
Public  Preferred  infinite infinite 2001:db8:d005:f282:3521:12fa:2c44:87d1
Temporary Preferred 6d19h37m21s 6d19h37m21s fd4a:3a9:27a1:f282:ed46:5dd4:5439:2e1c
Public   Preferred  infinite infinite fd4a:3a9:27a1:f282:3521:12fa:2c44:87d1
Other   Preferred  infinite infinite fe80::3521:12fa:2c44:87d1%8

Interface 17: Local Area Connection* 9

Addr Type DAD State Valid Life Pref. Life Address
--------- ----------- ---------- ---------- ------------------------
Other   Preferred  infinite infinite fe80::5efe:10.47.181.92%17

netsh interface ipv6 show address
pour cet exemple d'hôte. Dans cette figure, l'interface de tunnel ISATAP correspondant à l'interface LAN nommée Connexion locale se nomme Connexion Locale* 9.
Outre les adresses configurées automatiquement, le protocole IPv6 pour Windows Server 2008 et Windows Vista prend également en charge la configuration manuelle d'adresses IPv6 statiques à l'aide de la commande suivante
netsh interface ipv6 add address
ou via le composant Internet Protocol version 6 (TCP/IPv6) à partir des propriétés d'une connexion dans le dossier Connexions réseau.
Dans la chronique de ce mois, j'ai pris comme hypothèse que vous possédiez déjà des notions de l'adressage et du fonctionnement du protocole IPv6. Si vous souhaitez plus d'informations sur ce sujet, je vous suggère de commencer par le livre blanc « Introduction à IPv6 » qui se trouve sur le site microsoft.com/technet/ network/IPv6/introIPv6.mspx.

Joseph Davies est rédacteur technique chez Microsoft. Il enseigne et rédige des articles sur les questions relatives aux réseaux Windows depuis 1992. Il a écrit cinq livres pour Microsoft Press et est l'auteur de la chronique en ligne mensuelle Le petit câbleur de TechNet.


 Windows&#160;PowerShell: La puissance de filtrage
Windows PowerShell
La puissance de filtrage
Don Jones

Dans l'article du mois dernier, j'ai abordé la puissance et la flexibilité du pipeline Windows PowerShell, qui vous permet de faire passer un ensemble de données ou, plus précisément, un flux d'objets, d'une cmdlet à une autre, en affinant ces données jusqu'à ce que vous obteniez exactement ce que vous voulez. Dans mon article, j'ai fait allusion au fait que vos propres scripts,
pas seulement les cmdlets, peuvent également bénéficier du pipeline. Ce mois-ci, je souhaite aborder ce sujet en détail.
L'une des opérations les plus fréquentes que j'effectue dans Windows PowerShell™ consiste à écrire des scripts qui agissent sur plusieurs ordinateurs distants, généralement via Windows® Management Instrumentation (WMI). Comme pour toutes les tâches impliquant des ordinateurs distants, il existe toujours l'éventualité qu'un ou plusieurs ordinateurs ne soient pas disponibles lors de l'exécution du script. Mes scripts doivent être conçus en conséquence.
Bien sûr, il existe plusieurs méthodes qui permettent à un script de gérer un délai d'expiration de connexion WMI, mais je n'aime pas trop cette approche car le délai d'expiration est très long, environ 30 secondes, par défaut. L'exécution de mon script serait très ralentie s'il devait attendre des délais d'expiration fréquents. Au lieu de cela, je souhaite que mon script vérifie rapidement si un ordinateur donné est réellement en ligne avant d'essayer de s'y connecter.

Le paradigme de Windows PowerShell
Dans d'autres langages de script, tels que VBScript, je traiterais normalement un ordinateur à la fois. C'est-à-dire que je récupèrerais un nom d'ordinateur, peut-être à partir d'une liste de noms enregistrés dans un fichier texte, et enverrais une requête ping au système pour voir s'il est disponible. S'il était disponible, je lancerais la connexion WMI et exécuterais toutes les autres tâches que je dois effectuer. C'est une approche de type script courante. En fait, j'écrirais probablement tout mon code dans une boucle, puis répèterais cette boucle une fois pour chaque ordinateur auquel je dois me connecter.
Cependant, Windows PowerShell, est mieux adapté aux opérations par lots grâce à sa base dans les objets et sa capacité de travailler directement avec les groupes ou collections d'objets. Le paradigme de Windows PowerShell est de ne pas travailler avec des objets ou éléments de données uniques, mais plutôt de travailler avec des groupes entiers, en affinant le groupe petit à petit jusqu'à ce qu'à atteindre le résultat souhaité. Par exemple, au lieu de récupérer les noms d'ordinateur un par un dans ma liste, je lirais toute la collection de noms immédiatement. Au lieu d'envoyer une requête un ping à chaque ordinateur en boucle, j'écrirais une seule routine qui accepte une collection de noms, j'enverrais une requête ping à ceux-ci, puis j'afficherais ceux qui ont pu être contactés. L'étape suivant de mon processus consisterait à lancer ma connexion WMI aux noms restants, c'est-à-dire ceux qui ont répondu à la requête ping.
Windows PowerShell utilise cette approche pour un certain nombre de tâches. Par exemple, pour obtenir une liste des services en cours, je peux utiliser une commande comme celle-ci :
Get-Service | Where-Object { $_.Status –eq "Running" }
La figure 1 illustre le résultat apparaissant sur mon ordinateur. Au lieu de vérifier chaque service un par un, j'ai récupéré tous les services à l'aide de Get-Service, j'ai dirigé ceux-ci vers Where-Object, puis j'ai éliminé tous ceux qui ne s'exécutaient pas. C'est plus ou moins ce que je veux faire avec mon script : obtenir une liste de noms d'ordinateur, éliminer tous ceux qui ne répondent pas aux requêtes ping et faire passer la liste d'ordinateurs qui ont répondu à l'étape suivante.
Figure 1 Obtention d'une liste d'ordinateurs répondant aux requêtes ping
Figure 1 Obtention d'une liste d'ordinateurs répondant aux requêtes ping

Fonctions de filtrage
Bien que je puisse écrire ma propre cmdlet pour réaliser cette opération, je ne le souhaite pas. La création de cmdlets nécessite Visual Basic® ou C# et une bonne connaissance du développement Microsoft® .NET Framework. Plus important encore, elle nécessite plus d'implication que je ne souhaite en investir pour cette tâche. Heureusement, Windows PowerShell me permet d'écrire un type spécial de fonction, nommé filtre, parfaitement capable d'agir dans le pipeline. La forme de base d'une fonction de filtrage ressemble à ceci :
function <name> {
  BEGIN {
    #<code>
  }
  PROCESS {
    #<code>
  }
  END {
    #<code>
  }
}
Comme vous pouvez le constater, cette fonction contient trois blocs de script indépendants, nommés BEGIN, PROCESS et END. Une fonction de filtrage, c'est à dire une fonction conçue pour agir dans le pipeline afin de filtrer les objets, peut être constituée de toutes les combinaisons de ces trois blocs de script possibles, en fonction de ce que vous souhaitez faire. Ils fonctionnent comme suit :
  • Le bloc BEGIN s'exécute une fois lorsque votre fonction est appelée pour la première fois. Vous pouvez utiliser ce bloc pour effectuer la tâche d'installation, si nécessaire.
  • Le bloc PROCESS s'exécute une fois pour chaque objet pipeline traité par la fonction. La variable $_ représente l'objet d'entrée pipeline actuel. Le bloc PROCESS est requis dans une fonction de filtrage.
  • Le bloc END s'exécute une fois après le traitement de tous les objets pipeline. Il peut être utilisé pour toutes les tâches de finalisation, si nécessaire.
Dans mon exemple, je souhaite créer une fonction de filtrage qui acceptera une collection de noms en tant qu'objets d'entrées, puis essayer d'exécuter la commande ping sur chacun d'eux. Ceux qui répondent à la requête ping seront dirigés vers le pipeline. Les systèmes qui ne répondent pas à la requête ping seront simplement éliminés. Comme la fonctionnalité ping ne nécessite pas d'installation ou de finalisation spéciale, j'utiliserai simplement le bloc de script PROCESS. Le code de la figure 2 fournit le script complet.
Figure 2 Ping-Address et Restart-Computer. (Close Figure 2)
1  function Ping-Address {
2    PROCESS {
3      $ping = $false
4      $results = Get-WmiObject -query `
5      "SELECT * FROM Win32_PingStatus WHERE Address = '$_'"
6      foreach ($result in $results) {
7        if ($results.StatusCode -eq 0) {
8          $ping = $true
9        }
10      }
11      if ($ping -eq $true) {
12        Write-Output $_
13      }
14    }
15  }
16
17  function Restart-Computer {
18    PROCESS {
19      $computer = Get-WmiObject Win32_OperatingSystem -computer $_
20      $computer.Reboot()
21    }
22  }
23
24  Get-Content c:\computers.txt | Ping-Address | Restart-Computer
Notez que j'ai défini deux fonctions : Ping-Address et Restart-Computer. Dans Windows PowerShell, les fonctions doivent être définies avant de pouvoir être appelées. Par conséquent, la première ligne exécutable de mon script est la ligne 24, qui utilise la cmdlet Get-Content pour obtenir une liste de noms d'ordinateur à partir d'un fichier (un nom d'ordinateur par ligne). Cette liste, techniquement une collection d'objets String, est dirigée vers la fonction Ping-Address, qui filtre tous les ordinateurs qui ne répondent pas à la requête ping. Les résultats sont dirigés vers Restart-Computer, qui utilise WMI pour redémarrer à distance chaque ordinateur répondant à la requête ping.
La fonction Ping-Address implémente un bloc de script PROCESS, ce qui signifie que la fonction attend une collection d'entrée d'objets. Le bloc de script PROCESS traite cette entrée automatiquement. Je n'ai pas eu besoin de définir des arguments d'entrée pour contenir l'entrée. Je démarre le processus à la ligne 3 en définissant la variable $ping sur $false, qui est une variable Windows PowerShell intégrée représentant la valeur Booléenne False.
J'utilise ensuite la classe WMI locale Win32_PingStatus pour envoyer une requête ping à l'ordinateur spécifié. Notez à la ligne 5 que la variable $_, qui représente l'objet pipeline actuel, est intégrée dans la chaîne de requête WMI. Lorsqu'une chaîne est contenue dans des guillemets doubles, Windows PowerShell essaiera toujours de remplacer les variables telles que $_ par leur contenu, pour que vous n'ayez pas à vous soucier de la concaténation de chaîne. J'utilise cette fonctionnalité à la ligne 5.
La ligne 6 est une boucle qui vérifie le résultat de mes requêtes ping. Si l'un de ces résultats est positif (c'est à dire, avec un StatusCode de zéro), je définis $ping égal à $true pour indiquer le succès. À la ligne 11, je vérifie si $ping a été défini sur $true. Si c'est le cas, j'ajoute l'objet d'entrée original au flux de sortie par défaut. Windows Powershell gère le flux de sortie par défaut automatiquement. Si cette fonction se trouve à la fin du pipeline, le flux de sortie est transformé en représentation texte. S'il y a plus de commandes dans le pipeline, les objets du flux de sortie, en l'occurrence les objets de chaîne contenant des noms d'ordinateur, sont transmis à la commande pipeline suivante.
La fonction Restart-Computer est un peu plus simple, mais elle utilise également un bloc PROCESS pour pouvoir participer facilement au pipeline. À la ligne 19, la fonction se connecte à l'ordinateur nommé et récupère sa classe WMI Win32_OperatingSystem. La ligne 20 exécute la méthode Reboot de la classe pour redémarrer l'ordinateur distant.
Encore une fois, c'est à la ligne 24 que l'exécution s'effectue réellement. Bien sûr, vous devez être très prudent lorsque vous exécutez ce script. Il est conçu pour redémarrer chaque ordinateur nommé dans c:\computers.txt, ce qui pourrait certainement avoir des résultats désastreux si vous ne faites pas attention aux noms de ce fichier texte !

Étapes suivantes
Ce script n'est pas complètement infaillible. Je dois reconnaître également l'éventualité d'une erreur WMI non liée à la connectivité de base, par exemple un pare-feu bloquant les ports nécessaires sur l'ordinateur distant ou une erreur de sécurité WMI. Je peux contrôler ces problèmes en implémentant un gestionnaire d'interruption, lequel qui pourrait constituer un sujet parfait pour un futur article.
Ce script exécute aussi une opération assez importante : le redémarrage d'un ordinateur distant. Tous les scripts qui tentent cette action potentiellement dangereuse doivent implémenter deux paramètres Windows PowerShell courants, –Confirm et –WhatIf. L'explication de la procédure à suivre dépasse le cadre de cet article, mais constituerait elle aussi un bon sujet pour un futur article. En attendant, consultez le blog de l'équipe Windows PowerShell. L'architecte Jeffrey Snover traite ce sujet.
Même sans approfondir ces fonctionnalités, vous aurez une idée de ce que les fonctions de filtrage peuvent réaliser. J'affinerai cette technique dans de futurs articles, en montrant comment les fonctions peuvent permettent de modulariser le code réutilisable et d'améliorer la fonctionnalité de vos scripts en général.

Don Jones est le gourou des scripts chez SAPIEN Technologies et co-auteur de Windows PowerShell: TFM (SAPIEN Press, 2007). Vous pouvez le contacter sur le site www.ScriptingAnswers.com.


 H&#233;, vous le scripteur&#160;!: Qui &#234;tes-vous&#160;?
Hé, vous le scripteur !
Qui êtes-vous ?
Les scripteurs Microsoft
Télécharger le code de cet article: HeyScriptingGuy2007-082007_08.exe (152KB)

Il y n'a pas si longtemps, le scripteur qui écrit cet article regardait un match de base-ball à la télé. Une fois le match terminé, il décida de lire un magasine mais laissa la télévision allumée. Alors qu'il terminait son magasine, il leva les yeux vers la télé et se rendit compte qu'il était en train de regarder un vieux film sur la deuxième guerre mondiale. En fait, il leva les yeux juste au moment où les acteurs entamaient un scénario 1000 fois éprouvé : un jeune GI américain effectue son tour de garde de nuit lorsqu'il entend un bruit.
« Qui va là ? » aboie la sentinelle.
« Ce n'est que moi, le sergent Smith », répond une voix.
« Sergent Smith ? Il n'y a pas Sergent Smith dans ce bataillon ».
« Je suis nouveau ici ; je viens d'être transféré de la compagnie A ».
« Ah, vraiment ? La compagnie A ? OK, Smith : Qui a gagné les World Series de 1934 ? »
« Les Yankees de New York ».
Mauvaise réponse, « Smith » ! (Qui, comme vous pouvez le deviner, est immédiatement arrêté et jeté en prison.) Tout bon Américain, tout Américain qui se respecte, sait que les St. Louis Cardinals, vous savez, Dizzy Dean et le Gas House Gang, ont gagné les World Series de 1934. Quiconque ne sait pas ça ne peut être qu'une chose : un espion.
Si une personne lisant cet article ne savait pas que les St. Louis Cardinals ont gagné les World Series de 1934, hé bien, une chose est sûre : votre compte est bon ; nous savons que vous êtes un espion. Nous espérons que vous aurez la décence de vous rendre au bureau du FBI le plus proche, ou au moins de les appeler. Quand il s'agit d'espions, le FBI assure le service ramassage et de livraison.
Alors que le Scripteur qui écrit cet article regardait le film, il se rendit compte qu'il aurait d'assez bonnes chances de répondre à la deuxième question de la sentinelle : Qui a gagné les World Series de 1966 ? Les Baltimore Orioles. World Series de 1960 ? Pittsburgh Pirates. World Series 1994 ? Ha ! Une question piège : il n'y a pas eu de World Series en 1994.
Cependant, à l'heure actuelle, il aurait eu beaucoup de problèmes à répondre à la toute première question : Qui êtes-vous ? Ce n'est pas une question aussi facile aujourd'hui qu'elle pourrait l'avoir été dans les années 40. Après tout, rien qu'avec Active Directory®, les utilisateurs peuvent avoir un nombre incalculable d'identités différentes, notamment :
  • leur prénom (givenName).
  • leur nom (sn).
  • leur nom d'affichage (displayName).
  • leur nom principal utilisateur (userPrincipalName).
  • leur nom d'ouverture de session (samAccountName).
  • leur nom unique (distinguishedName).
Tous ces noms identifient la même personne, et tous sont des noms qui, selon les circonstances, sont importants à connaître. Et c'est un gros problème. La plupart des utilisateurs connaissent leur prénom et leur nom. Mais si vous demandez à un utilisateur, « Quel est votre nom unique ? », peu d'entre eux pourront répondre, « Ben, c'est facile ! Je suis CN=Ken.Myer, UO=Finance, DC=fabrikam, DC=com. Mais mes amis m'appellent CN=Ken.Myer. »
En tant qu'administrateur système ou membre du support technique, vous devez vous aussi connaître ces noms. Mais comment êtes-vous censé obtenir ces informations ? Hé bien, une approche serait de pendre vos utilisateurs à des crochets de boucher jusqu'à ce qu'ils vous révèlent leur nom unique. Cela fonctionnerait probablement, mais la plupart des départements des ressources humains déconseillent ces pratiques de nos jours. Il vous faudra donc avoir recours au plan B : un script. Quel genre de script ? Hé bien, pour les débutants, pourquoi pas le script de la figure 1 ?
Figure 1 Récupération des attributs de l'utilisateur avec ADSystemInfo (Close Figure 1)
On Error Resume Next

Set objSysInfo = CreateObject("ADSystemInfo")
strUser = objSysInfo.UserName

Set objUser = GetObject("LDAP://" & strUser)
WScript.Echo "First Name: " & objUser.givenName
WScript.Echo "Last Name: " & objUser.sn
WScript.Echo "Display Name: " & objUser.displayName
WScript.Echo "User Principal Name: " & objUser.userPrincipalName
WScript.Echo "SAM Account Name: " & objUser.sAMAccountName
WScript.Echo "Distinguished Name: " & objUser.distinguishedName
Ohlala, si seulement le sergent Smith avait étudié VBScript, hein ? Ce script exploite un objet ADSI peu connu (mais extrêmement utile) nommé ADSystemInfo. Il s'agit d'un petit objet bien pratique qui peut renvoyer toutes sortes d'informations sur l'utilisateur actuellement connecté à l'ordinateur local, de même que sur l'ordinateur local lui-même et le domaine auquel il appartient. Par exemple, examinez la figure 2.
Figure 2 Afficher toutes sortes d'informations de domaine (Close Figure 2)
On Error Resume Next

Set objSysInfo = CreateObject("ADSystemInfo")

Wscript.Echo "User name: " & objSysInfo.UserName
Wscript.Echo "Computer name: " & objSysInfo.ComputerName
Wscript.Echo "Site name: " & objSysInfo.SiteName
Wscript.Echo "Domain short name: " & objSysInfo.DomainShortName
Wscript.Echo "Domain DNS name: " & objSysInfo.DomainDNSName
Wscript.Echo "Forest DNS name: " & objSysInfo.ForestDNSName
Wscript.Echo "PDC role owner: " & objSysInfo.PDCRoleOwner
Wscript.Echo "Schema role owner: " & objSysInfo.SchemaRoleOwner
Wscript.Echo "Domain is in native mode: " & objSysInfo.IsNativeMode
Pour le moment, cependant, la seule propriété qui nous intéresse est la propriété UserName. Qu'est-ce que UserName a de si spécial ? Et bien, il se trouve qu'elle correspond à la propriété distinguishedName. Et qu'y a distinguishedName de spécial ? Hmm, distinguishedName s'apparente à un chemin d'accès UNC : tout comme un chemin UNC nous permet d'identifier de manière univoque un fichier quelque part sur notre réseau, distinguishedName (par exemple, CN=Ken.Myer, UO=Finance, DC=fabrikam, DC=com) nous permet d'identifier de façon unique un compte utilisateur dans Active Directory. Ensuite, cela nous permet de nous connecter à ce compte utilisateur. Et une fois cette connexion établie, nous pouvons récupérer n'importe quelle information sur un utilisateur, y compris son identité.
Et c'est exactement ce que nous faisons dans le premier script que nous vous avons présenté. Pour commencer, nous créons une instance de l'objet ADSystemInfo et attribuons ensuite la valeur de la propriété UserName à une variable nommée strUser :
Set objSysInfo = CreateObject("ADSystemInfo")
strUser = objSysInfo.UserName
Notez que nous n'avons pas à faire grand chose. Par exemple, nous n'avons pas besoin de spécifier le nom d'utilisateur, le domaine de l'utilisateur ou l'UO où réside le compte utilisateur ; ADSystemInfo fait tout cela pour nous. Une fois que nous avons le distinguishedName de l'utilisateur, nous pouvons ensuite nous connecter à son compte utilisateur en utilisant cette ligne de code :
Set objUser = GetObject("LDAP://" & strUser)
Une fois encore, après avoir établi la connexion, nous pouvons renvoyer les valeurs de n'importe quel attribut Active Directory de ce compte. Dans notre exemple de script, nous avons simplement renvoyé certaines des propriétés du nom de l'utilisateur, mais nous aurions pu tout aussi facilement récupérer le numéro de téléphone, l'emplacement du bureau, l'adresse de messagerie etc.
C'est génial. Il vous suffit donc de transmettre ce script à tous vos utilisateurs et ils n'auront plus jamais à se demander, « Qui suis-je ? » (ou, s'ils sont indécis, ils disposeront d'un moyen rapide et facile de le déterminer). Mais qu'en est-il de la question apparentée : Qui êtes-vous ? C'est une chose de pouvoir identifier l'utilisateur connecté à l'ordinateur local. Mais comment diable peut-on déterminer qui a ouvert une session sur un ordinateur distant ? Comme on pouvait s'y attendre, il s'agit là d'un problème plus épineux.
Et, désolé, nous y avons pensé nous aussi, mais malheureusement, on ne peut pas simplement diriger notre petit script ADSystemInfo vers un ordinateur distant. La raison en est que l'objet ADSystemInfo peut uniquement être créé localement. Cela nous laisse trois possibilités :
  • Créer un script d'ouverture de session qui enregistre le nom de l'utilisateur connecté dans un certain emplacement facile d'accès.
  • Utiliser la classe WMI Win32_ComputerSystem et la propriété UserName.
  • Faire autre chose.
La première option semble plutôt séduisante. Comme vous l'avez peut-être remarqué, l'objet ADSystemInfo peut renvoyer le nom unique de l'ordinateur (la propriété ComputerName) ainsi que celui de l'utilisateur. Observez, si vous le voulez bien, l'exemple de script proposé à la figure 3.
Figure 3 Script d'ouverture de session (Close Figure 3)
On Error Resume Next

Set objSysInfo = CreateObject("ADSystemInfo")

strUser = objSysInfo.UserName
strComputer = objSysInfo.ComputerName

Set objUser = GetObject("LDAP://" & _
    strUser)
strUserName = objUser.displayName

Set objComputer = GetObject("LDAP://" & _
    strComputer)
objComputer.Description = strUserName
objComputer.SetInfo
Que faisons-nous ici ? Pour commencer, nous prenons les valeurs des propriétés UserName et ComputerName et les enregistrons dans une paire de variables (strUser et strComputer). Nous nous connectons ensuite au compte utilisateur dans Active Directory (tout comme nous le faisions avant), nous récupérons la valeur de l'attribut displayName (comme avant) et nous enregistrons cette valeur dans une variable nommée strUserName. C'est plutôt simple, non ?
Nous sommes ensuite en mesure d'utiliser cette ligne de code pour nous connecter au compte ordinateur Active Directory :
Set objComputer = GetObject("LDAP://" & _
    strComputer)
après avoir établi cette connexion, nous attribuons le displayName de l'utilisateur à la propriété Description de l'ordinateur et appelons ensuite la méthode SetInfo pour intégrer cette modification à Active Directory :
objComputer.Description = strUserName
objComputer.SetInfo
Pourquoi faisons-nous cela ? C’est simple : supposons que Ken Myer ouvre une session sur l'ordinateur atl-ws-01. Devinez ce que sera la propriété Description de la valeur atl-ws-01 ? Vous l'avez deviné : Ken Myer, la personne actuellement connectée à l'ordinateur. Vous voulez savoir qui a ouvert une session sur atl-ws-01 ? Il vous suffit de vérifier la propriété Description.
Bon, ce scénario fonctionne plutôt bien en général, et même mieux si vous avez un script de déconnexion qui efface la propriété Description chaque fois que l'utilisateur ferme la session. Ce n'est toutefois pas une solution infaillible. Pourquoi ? Hé bien, les scripts d'ouverture de session ne fonctionnent pas toujours. Par exemple, ils ne s'exécutent généralement pas lorsque les gens ouvrent une session en utilisant RAS. De la même manière, le script d'ouverture de session ne s'exécutera pas si un utilisateur débranche sa connexion réseau, ouvre une session à l'aide d'informations d'authentification mises en cache et rebranche ensuite son ordinateur au réseau. Et supposons qu'un utilisateur éteigne son ordinateur sans fermer la session. Cela signifie que son script de fermeture de session ne s'exécutera jamais. Dans ce cas, Ken Myer apparaît toujours connecté à atl-ws-01 bien que la machine ne soit même pas allumée. Par conséquent, cette technique est très utile, mais...
Donc qu'en est-il de l'option 2, c'est-à-dire utiliser la classe Win32_ComputerSystem ? Encore une fois, cela fonctionnera souvent, mais le problème avec la classe Win32_ComputerSystem, c'est qu'elle ne renvoie pas toujours le nom de l'utilisateur connecté, surtout pour les utilisateurs qui n'ont pas de droits d'administrateur (et, surtout, pour les ordinateurs exécutant Windows® 2000). Le script de la figure 4 vous dira probablement qui a ouvert une session sur un ordinateur mais, une fois encore, cela n'est pas garanti.
Figure 4 Savoir qui est connecté avec WMI (Close Figure 4)
strComputer = "."

Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")
Set colItems = objWMIService.ExecQuery("Select * From Win32_ComputerSystem")

For Each objItem in colItems
  Wscript.Echo objItem.UserName
Next
En outre, dans ce cas-ci, la propriété UserName est renvoyée au format domaine\nom_d'utilisateur. En d'autres termes : FABRIKAM\kenmyer.
Oh, nous allions oublier : même si un nom est renvoyé, cela ne signifie pas qu'un utilisateur est effectivement connecté à l'ordinateur. Lorsque Ken Myer se déconnecte de atl-ws-01, son nom est conservé comme valeur de la propriété UserName et n'est pas remplacé tant qu'une autre personne n'ouvre pas une session.
Mouais.
Attendez ; cela ne fait pas de nous des espions. Voici une autre approche possible. Si quelqu'un est connecté à un ordinateur, il est probable que le processus Explorer.exe soit en cours d'exécution. En général, si Explorer.exe n'est pas en cours d'exécution, personne n'est connecté à la machine. Et comme Explorer.exe s'exécute à l'aide des informations d'authentification de l'utilisateur connecté, nous pouvons presque toujours déterminer qui a ouvert une session sur un ordinateur en utilisant un script semblable à celui de la figure 5.
Figure 5 Déterminer le propriétaire d'Explorer.exe (Close Figure 5)
strComputer = "atl-ws-01"

Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")

Set colItems = objWMIService.ExecQuery _
  ("Select * from Win32_Process Where Name = 'explorer.exe'")

If colItems.Count = 0 Then
  Wscript.Echo "No one is logged on to the computer."
Else
  For Each objProcess in colItems
    objProcess.GetOwner strUser, strDomain
    Wscript.Echo strDomain & "\" & strUser
  Next
End If
Comme vous pouvez le voir, dans le cas présent, nous nous connectons au service WMI sur un ordinateur distant (atl-ws-01, pour être exact). Nous utilisons ensuite la ligne de code suivante pour récupérer une collection de toutes les instances de la classe Win32_Process portant le nom Explorer.exe:
Set colItems = objWMIService.ExecQuery _
  ("Select * from Win32_Process Where " & _
  "Name = 'explorer.exe'")
Et maintenant ? Hé bien, comme nous l'avons vu précédemment, si Explorer.exe ne s'exécute pas, il y a d'assez bonnes chances pour que personne ne soit connecté à l'ordinateur. Comment savoir si Explorer.exe est en cours d'exécution ? Une méthode très simple consiste à vérifier la valeur de la propriété Count de la collection. Si Count est égal à 0, nous avons une collection vide, et la seule explication pour que nous ayons une collection vide, c'est qu'il n'y ait pas d'instance Explorer.exe en cours d'exécution sur atl-ws-01. Si c'est le cas, nous renvoyons un message indiquant que personne n'est connecté à l'ordinateur :
Wscript.Echo "No one is logged on " & _
"to the computer."
Si Count est différent de 0, nous configurons une boucle For Each de sorte à parcourir la collection de processus ayant pour nom Explorer.exe (et oui, nous supposons que notre collection contiendra invariablement un seul élément). Pour chaque instance d'Explorer.exe, nous appelons ensuite la méthode GetOwner pour déterminer sous le compte de qui Explorer.exe s'exécute :
objProcess.GetOwner strUser, strDomain
Notez que nous transmettons des paramètres out à GetOwner : StrUser et strDomain. Les paramètres out sont simplement des variables que nous nommons et fournissons à une méthode ; la méthode leur attribuera ensuite des valeurs. Dans le cas présent, strUser recevra le nom d'ouverture de session de l'utilisateur connecté (kenmyer) et strDomain le nom de domaine de l'utilisateur connecté (FABRIKAM). Il nous suffit ensuite de renvoyer les valeurs de ces deux paramètres out :
Wscript.Echo strDomain & "\" & strUser
Vous savez quoi ? Cela marche plutôt bien. Mais nous pouvons aller un peu plus loin. Lorsque nous utilisons la méthode GetOwner, nous recevons en retour le nom d'ouverture de session (samAccountName) pour l'utilisateur connecté à l'ordinateur. C'est bien, mais, comme nous l'avons vu, les utilisateurs ont toutes sortes de noms en plus de leur samAccountName. Pour véritablement répondre à la question « Qui êtes-vous ? », il serait bon de connaître, disons, le nom d'affichage de l'utilisateur. Mais nous ne pouvons pas connaître les autres noms en utilisant GetOwner, n'est-ce pas ?
Non, nous ne le pouvons pas. Toutefois, nous pouvons utiliser le samAccountName, le placer dans un script de recherche Active Directory, puis localiser et nous connecter au compte utilisateur avec ce nom d'ouverture de session (une tâche facilitée par le fait que samAccountNames doit être unique dans un domaine). Et une fois connectés au compte utilisateur, nous pouvons retrouver les valeurs de n'importe quelle propriété Active Directory, y compris displayName.
Nous n'avons pas le temps de détailler le script de la figure 6. Pour en savoir plus sur les recherches dans Active Directory, consultez l'article « Hé mec, où est mon imprimante ? ». Qu'il me suffise de dire que ce script détermine le nom d'ouverture de session de l'utilisateur connecté, recherche dans Active Directory l'utilisateur possédant ce nom d'ouverture de session (samAccountName), se connecte au compte utilisateur en question et ensuite renvoie le nom d'affichage de l'utilisateur. Et tout ça avec une main attachée derrière le dos !
Figure 6 Connexion à l'utilisateur connecté (Close Figure 6)
strComputer = "atl-ws-01"

Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")

Set colItems = objWMIService.ExecQuery _
  ("Select * from Win32_Process Where Name = 'explorer.exe'")

If colItems.Count = 0 Then
  Wscript.Echo "No one is logged on to the computer."
Else
  For Each objProcess in colItems
    objProcess.GetOwner strUser,strDomain
  Next
End If

Const ADS_SCOPE_SUBTREE = 2

Set objConnection = CreateObject("ADODB.Connection")
Set objCommand = CreateObject("ADODB.Command")
objConnection.Provider = "ADsDSOObject"
objConnection.Open "Active Directory Provider"
Set objCommand.ActiveConnection = objConnection

objCommand.Properties("Page Size") = 1000
objCommand.Properties("Searchscope") = ADS_SCOPE_SUBTREE

objCommand.CommandText = "SELECT displayName FROM " & _
  "'LDAP://DC=wingroup,DC=fabrikam,DC=com' WHERE " & _
    "objectCategory='user' " & _
    "AND samAccountName = '" & strUser & "'"
Set objRecordSet = objCommand.Execute

objRecordSet.MoveFirst

Do Until objRecordSet.EOF
  Wscript.Echo objRecordSet.Fields("displayName").Value
  objRecordSet.MoveNext
Loop
Donc quels sont les key takeaways pour aujourd'hui ? (À propos, c'est ainsi les gens de Microsoft parlent. Si vous voulez rendre un Scripteur complètement dingue, allez vers lui et dites quelque chose comme, « Nous avons besoin de trier les key takeaways, les action items et les non-goals pour tous les stakeholders ».) Bien, nous savons maintenant d'une part comment obtenir les informations concernant l'utilisateur connecté à un ordinateur (local ou distant). Plus important, nous savons que faire si nous sommes pris dans une spirale spatio-temporelle et que nous nous retrouvons à l'époque de la deuxième guerre mondiale : veillez à avoir une copie de cet article (pour pouvoir répondre à la question « Qui êtes-vous ? ») et, quoi que vous fassiez, ayez toujours avec vous une liste des vainqueurs des World Series. Après tout, on ne peut jamais savoir quand quelqu'un demandera, « Qui a gagné les World Series de 1903 ? »
N'oubliez pas : Les Boston Red Sox. C'étaient d'ailleurs les tous premiers World Series. Maintenant, selon vous qui a gagné les World Series de 1904 ? Comment ça, vous ne savez pas ? Excusez-nous une seconde ; nous avons un coup de fil à passer....

Les scripteurs Microsoft travaillent pour (enfin, sont employés par) Microsoft. Lorsqu’ils ne sont pas en train de jouer au base-ball, d’entraîner une équipe ou de regarder un match (ou de se livrer à de multiples autres activités), ils dirigent le Script Center TechNet. Vous pouvez le vérifier vous-même sur www.scriptingguys.com.


 Vigilance s&#233;curit&#233;: Am&#233;liorations de l'infrastructure de cl&#233; publique (PKI) dans Windows
Vigilance sécurité
Améliorations de l'infrastructure de clé publique (PKI) dans Windows
John Morello
Cette chronique est basée sur une version bêta de Windows Server 2008. Toutes les informations contenues dans cet article sont susceptibles d’être modifiées.

Windows a inclus une puissante prise en charge de l'infrastructure de clé publique (PKI) sur l'ensemble de la plate-forme depuis Windows 2000. Cette version comprenait la première fonctionnalité d'autorité de certification native, introduisait l'inscription automatique et fournissait une prise en charge de l'authentification par carte à puce. Dans Windows XP et Windows Server 2003, ces
fonctionnalités ont été étendues pour fournir des options d'inscription plus flexibles grâce aux modèles de certificat de version 2, et pour prendre en charge l'inscription automatique des certificats utilisateur. Dans Windows Vista® et Windows Server ® 2008 (ancien nom de code « Longhorn »), la plate-forme Windows® PKI va encore plus loin en prenant en charge des algorithmes avancés, la vérification de validité en temps réel et une plus grande facilité de gestion. Cette chronique aborde les nouvelles fonctionnalités de l'infrastructure PKI dans Windows Vista et Windows Server 2008 et la façon dont elles peuvent être utilisées par les entreprises pour réduire leurs coûts et accroître leur sécurité.
Les améliorations de l'infrastructure PKI dans Windows Vista et Windows Server 2008 sont concentrées sur quatre axes principaux : la cryptographie, l'inscription, la facilité de gestion et la révocation. Outre ces améliorations spécifiques aux fonctionnalités, la plate-forme Windows PKI offre également d'autres améliorations système, telles que le Gestionnaire de rôles, qui facilitent la création et le déploiement de nouvelles autorités de certification. De plus, de nombreux autres composants de Windows peuvent bénéficier des améliorations de l'infrastructure PKI, telles que la prise en charge dans Windows Vista de l'utilisation de cartes à puce pour le stockage de clés du système de fichiers EFS.

Cryptographie
Les améliorations apportées à l'axe cryptographie sont doubles. Tout d'abord, avec l'introduction de la cryptographie nouvelle génération (CNG), Windows offre désormais une possibilité de chiffrement enfichable indépendant du protocole facilitant le développement et l'accès aux algorithmes individuels par programmation. Ensuite, la nouvelle architecture de chiffrement permet la prise en charge des algorithmes de la Suite B introduits par la NSA (National Security Agency) en 2005.
CNG est une nouvelle interface de cryptographie de base pour Microsoft. Elle est l'API recommandée pour les futures applications Windows qui utilisent la cryptographie. CNG offre une toute une série de nouvelles fonctionnalités pour les développeurs, notamment une détectabilité et un remplacement des algorithmes simplifiés, des générateurs des nombres aléatoires remplaçables et une API cryptographique en mode noyau. Tout en offrant ces nouvelles fonctionnalités, CNG est également rétrocompatible avec la série d'algorithmes fournis dans sa version précédente, CryptoAPI 1.0. CNG est actuellement en cours d'évaluation pour la certification de niveau 2 de la norme FIPS (Federal Information Processing Standards) 140-2, ainsi que pour les critères communs sur certaines plates-formes sélectionnées.
La prise en charge de la Suite B de CNG comprend tous les algorithmes requis : AES (toutes les tailles de clés), la famille d'algorithmes de hachage SHA-2 (SHA-256, SHA-384 et SHA-512), ECDH (Elliptic Curve Diffie-Hellman) et ECDSA (Elliptic Curve Digital Signature Algorithm) sur les courbes standard du National Institute of Standards and Technology (NIST) P-256, P-384 et P-521. La NSA a déclaré que les implémentations de la Suite B certifiées seront utilisées pour protéger les informations classées top secrètes, secrètes, et les informations privées qui, par le passé, avaient été décrites comme sensibles mais non classées. Tous les algorithmes de la Suite B ont été développés ouvertement et certains gouvernements envisagent également de les adopter en tant que normes nationales.
Ces améliorations de bas niveau à la plate-forme Windows PKI offrent aux développeurs des méthodes plus sécurisées pour protéger les données, tout en créant un sous-système plus facile à maintenir et améliorer dans le temps. Étant donné que CNG est une architecture enfichable, de nouveaux algorithmes peuvent être ajoutés si nécessaire et CNG soustrait ces fournisseurs de la couche d'application. Résultat net : Windows Vista et Windows Server 2008 sont conçus pour offrir une plate-forme évolutive avancée pour le développement des applications et des services compatibles avec PKI.

Inscription
L'inscription de certificats dans Windows a été considérablement améliorée grâce à un nouvel outil d'inscription basé sur un Assistant, une meilleure gestion des notifications d'expiration, une nouvelle API, la fonctionnalité « Inscrire au nom de » et l’itinérance avec authentification par informations d’identification. Ces fonctionnalités améliorées réduisent le coût total de possession d'une infrastructure PKI en facilitant le déploiement de certificats dans votre entreprise avec une gestion centralisée et un impact utilisateur minimal.
La modification la plus perceptible du point de vue de l'inscription est la nouvelle interface utilisateur Inscription de certificats illustrée aux figures 1 et 2. Cette interface utilisateur remplace l'ancienne interface limitée qui n'était pas capable d'accepter des données provenant des utilisateurs lors du processus d'inscription. La nouvelle interface permet aux utilisateurs d'entrer des données pendant l'inscription (si l'administrateur configure le modèle de certificat pour le demander). L'interface fournit également des explications claires sur les raisons pour lesquelles un utilisateur pourrait ne pas pouvoir s'inscrire à un modèle donné.
Figure 1 Sélection des certificats disponibles
Figure 1 Sélection des certificats disponibles
Figure 2 État des certificats indisponibles
Figure 2 État des certificats indisponibles
Une autre amélioration clé de l'interface d'inscription réside dans la gestion de l'expiration des certificats. La nouvelle interface fournit aux utilisateurs finaux des informations claires sur l'expiration des certificats et permet aux utilisateurs de renouveler facilement les certificats ou d'ignorer les avertissements à partir de la même interface. Bien que les administrateurs puissent actualiser automatiquement les certificats grâce à l'inscription automatique, cette fonctionnalité d'avertissement est importante pour les utilisateurs déconnectés ou mobiles qui se connectent rarement au réseau de l'entreprise et disposent de certificats ayant presque atteint leur date d'expiration.
Pour les développeurs qui travaillent sur l'inscription de certificats, une nouvelle API est disponible offrant des améliorations significatives des anciennes commandes ActiveX® (xenroll.dll et scrdernl.dll). La nouvelle API d'inscription de certificats offre une hiérarchie de classe bien définie, beaucoup plus simple à comprendre et à coder. Cette nouvelle API remplace xenroll dans Windows Vista et Windows Server 2008.
Cette modification dans l'API a un impact sur les développeurs et les professionnels de l'informatique dans la mesure où les clients Windows Vista ne peuvent pas utiliser les fonctionnalités d'inscription Web fournies dans Windows Server 2003. Ceci est dû au fait que les pages d'inscription (stockées dans le répertoire virtuel /certsrv par défaut) qui utilisent la commande xenroll ne se trouve plus dans Windows Vista. L'article « Comment utiliser les pages d'inscription Web des services de certification avec Windows Vista » de la base de connaissances (support.microsoft.com/kb/922706) fournit des informations sur une solution de contournement. L'inscription automatique de Windows Server 2003 vers Windows Vista n'est pas concernée.
Dans les précédentes versions de Windows Server, les agents d'inscription n'étaient pas limités au niveau de l'individu au nom duquel ils pouvaient procéder à l'inscription. En d'autres termes, une fois qu'un utilisateur recevait des fonctionnalités d'agent d'inscription, il pouvait s'inscrire au nom de tout autre utilisateur de la forêt. Bien sûr, ceci signifiait que l'utilisateur pouvait facilement promouvoir ses privilèges en s'inscrivant au nom d'un utilisateur existant et en imitant l'utilisateur avec le certificat créé récemment. Afin de contrecarrer cette menace, les fonctionnalités d'agent d'inscription étaient fournies à des individus d'extrême confiance uniquement. Bien qu'une telle approche ait amélioré la sécurité, elle a également rendu les modèles de déploiement moins flexibles, vu que seul un nombre réduit d'individus disposent de la fonctionnalité d'inscription au nom d'autres utilisateurs. Par conséquent, les organisations de grande taille géographiquement dispersées, étaient confrontées à une complexité accrue lors du déploiement de certificats aux utilisateurs finaux (pour les cartes à puce par exemple).
Dans Windows Server 2008, les agents d'inscription peuvent être limités à un niveau beaucoup plus granulaire. Les restrictions peuvent être basées sur les utilisateurs qui peuvent être inscrits au nom de ou sur les modèles qui peuvent être inscrits, comme indiqué à la figure 3. Par exemple, une organisation peut désormais conférer à un informaticien local la possibilité d'effectuer les inscriptions au nom de tous les utilisateurs de sa succursale, mais pas des utilisateurs du groupe Ressources humaines. Cette approche granulaire des agents d'inscription permet aux entreprises de déléguer de manière sécurisée et efficace les fonctionnalités d'inscription au sein de leur organisation.
Figure 3 Restrictions d'agent d'inscription
Figure 3 Restrictions d'agent d'inscription
L'un des plus grands défis posés par la gestion de l'infrastructure PKI consiste à gérer toutes les paires de clés dispersées sur les périphériques de l'organisation. Même dans un environnement PKI modérément complexe, tout utilisateur donné peut disposer de plusieurs paires de clés différentes (par exemple pour l'EFS, l'authentification à un réseau sans fil et S/MIME) qui doivent être disponibles quel que soit le lieu de connexion. Du fait de l'utilisation croissante de l'informatique mobile et des services Terminal Server, vous devez, aujourd'hui plus que jamais, répliquer ces paires de clés sur l'ensemble du réseau pour qu'elles soient à la disposition des utilisateurs quel que soit leur lieu de connexion. Bien que les jetons utilisateur, tels que les cartes à puce, puissent résoudre certains aspects de ce problème, certains utilisateurs peuvent ne pas disposer de carte et certains certificats peuvent ne pas être enregistrés sur les cartes. L’itinérance avec authentification par informations d’identification résout ces problèmes en stockant les paires de clés et les certificats dans Active Directory® de façon sécurisée, les mettant ainsi à la disposition des utilisateurs quel que soit leur lieu de connexion.
L’itinérance avec authentification par informations d’identification a été implémentée pour la première fois dans Windows Server 2003 SP1. Elle permet aux certificats et aux clés de basculer de manière sécurisée entre les ordinateurs sans utiliser les profils utilisateur itinérants. Dans Windows Vista et Windows Server 2008, cette fonctionnalité est incluse par défaut et est implémentée dans le service du client des services de certification (CSC). Les options de configuration, telles que le choix des certificats pouvant utiliser des profils itinérants et la façon dont les conflits sont arbitrés, sont gérées à l'aide de la stratégie de groupe. Sur Windows Vista et Windows Server 2008, le service CSC peut utiliser des noms et mots de passe utilisateur enregistrés itinérants. Bien que cette fonctionnalité soit incluse par défaut dans Windows Vista, il est à noter que l’itinérance avec authentification par informations d’identification est entièrement prise en charge sur Windows XP lorsqu'un utilisateur se connecte à un contrôleur de domaine Windows Server 2003 (avec le déploiement d'une mise à jour ; voir support.microsoft.com/kb/907247). Cela signifie que vous ne devez pas attendre d'avoir terminé le déploiement de Windows Vista pour pouvoir profiter de cette technologie.

Facilité de gestion
Plusieurs mises à niveau ont été effectuées dans Windows Server 2008 pour améliorer la facilité de gestion du service de l'autorité de certification en facilitant l'installation, la surveillance et l'exécution en mode haute disponibilité. L'installation de l'autorité de certification est intégrée à l'outil Gestionnaire de rôles et offre une méthode simple d'installation du service de l'autorité de certification. Les paramètres par défaut sont définis pour chaque étape du processus et l'installation peut désormais être exécutée en mode sans assistance. Enfin, l'installation dispose de fonctionnalités de diagnostic améliorées facilitant la résolution de tout problème ou défaillance pouvant survenir.
La surveillance du service de l'autorité de certification a été considérablement améliorée dans Windows Server 2008 (comme l'a été le diagnostic des certificats global dans Windows Vista). En plus de l'infrastructure d'événements beaucoup plus flexible qui porte tout le produit, le service de l'autorité de certification dispose désormais d'une console de surveillance intégrée et s'intègre à Systems Center Operations Manager 2007 (anciennement connu en tant que MOM) pour fournir une alerte au niveau entreprise. La console de surveillance PKI Enterprise représente une amélioration majeure par rapport à sa version précédente qui a été introduite dans le pack d'administration de Windows Server 2003. La nouvelle console est incluse dans le produit lui-même et peut désormais surveiller les URI de protocole OCSP (Online Certificate Status Protocol) en plus de toutes les autorités de certification dans une forêt donnée.
Le pack d'administration d'Operations Manager fournit une fonctionnalité de surveillance passive pour l'infrastructure PKI d'une organisation, notamment les alertes basées sur un seuil intégrées. Par exemple, le pack d'administration peut être utilisé pour surveiller l'actualisation d'une Liste de révocation des certificats (CRL) et avertir les administrateurs de l'infrastructure PKI lorsqu'une CRL atteint un certain nombre de jours ou heures avant son expiration. Enfin, un grand nombre de nouveaux compteurs de performances permettant le dépannage et la surveillance des performances globales du service de l'autorité de certification lui-même sont disponibles. Ces compteurs peuvent être utilisés pour capturer des données, telles que le nombre de certificats émis par seconde.
Une nouvelle fonctionnalité fait ses débuts dans Windows Server 2008 : la prise en charge de la mise en clustersau niveau matériel du service de l'autorité de certification. Cette prise en charge des clusters utilise la technologie Microsoft Clustering Services (MSCS) standard et prend en charge les configurations active/passive sur deux nœuds. La prise en charge des clusters vous permet d'exécuter une infrastructure d'émission en mode haute disponibilité et peut être utilisée dans des déploiements de clusters géographiquement dispersés. Si vous choisissez d'utiliser la prise en charge des clusters, notez que la simple mise en clusters d'une autorité de certification n'entraîne pas une disponibilité pour l'ensemble de l'infrastructure PKI. Bien que les clusters permettent de garantir que les autorités de certification sont elles-mêmes disponibles, une infrastructure PKI fonctionnelle comprend généralement d'autres composants qui ne s'exécutent pas directement sur les autorités de certification. Par exemple, les points de distribution CRL et les répondeurs OCSP doivent également être exécutés en mode haute disponibilité pour garantir que cette révocation puisse être exécutée. De plus, lorsque des modules de sécurité physiques (HSM), en particulier les HSM réseau, sont utilisés, ils représentent également un point de défaillance potentiel dans une infrastructure PKI. Le mise en clusters est une nouvelle fonctionnalité puissante pour assurer une haute disponibilité de l'autorité de certification elle-même, mais elle ne constitue pas la panacée pour la disponibilité de l'intégralité d'un déploiement PKI.

Révocation
Les CRL ont longtemps été utilisées pour permettre la vérification de validité des certificats. Ces CRL comprennent des numéros de série de tous les certificats dont la période de validité n'a pas encore expiré mais qui ne sont plus fiables. Par exemple, si un employé dispose d'un certificat avec une date d'expiration au 12/31/2008 mais qu'il quitte l'organisation le 9/1/2007, les numéros de série de ses certificats doivent être ajoutés à la CRL. Ensuite, la CRL sera mis à disposition sur plusieurs points de distribution CRL (CDP), tel que les chemins HTTP et LDAP (Lightweight Directory Access Protocol).
Bien que l'utilisation en soit très répandue, les CRL présentent certains inconvénients clés. Tout d'abord, les CRL sont publiées par les autorités de certification de façon périodique (en général, une ou deux fois par jour). Les clients téléchargent ensuite ces CRL et les mettent en cache jusqu'à l'intervalle de publication suivant. Pendant cette période de mise en cache, les certificats peuvent être révoqués, laissant le client dans l'ignorance de l'état le plus actuel. Ensuite, dans les très grandes organisations, les CRL peuvent atteindre des tailles très importantes (parfois supérieure à 100 Mo). La distribution de ces fichiers sur un réseau de grande taille dispersé peut s'avérer difficile voire impossible, surtout pour les succursales ou les autres environnements avec une bande passante limitée.
Pour remédier à ces problèmes, le protocole OCSP a été créé et a été défini dans RFC 2560. Le protocole OCSP fournit une méthode de validation de l'état des certificats en temps réel. Un client OCSP s'exécute sur l'ordinateur qui doit vérifier la validité d'un certificat feuille. Le logiciel client référence ensuite un répondeur OCSP et envoie un message demandant l'état de validité du certificat feuille. Le répondeur vérifie la validité du certificat et répond au client en temps réel. Cette approche évite la mise en cache et les problèmes de distribution.
Pour la première fois, la fonctionnalité de client OCSP est incluse dans Windows Vista (précédemment, un logiciel tiers était nécessaire) et est configurable à l'aide de la stratégie de groupe. Par défaut, Windows tentera d'utiliser le protocole OCSP mais reviendra aux recherches CRL standard si le répondeur n'est pas disponible.
Dans Windows Server 2008, un répondeur OCSP est fourni pour répondre à ces requêtes. Le répondeur est installé via le Gestionnaire de rôles et peut être surveillé par le pack d'administration d'Operations Manager 2007. Comme le client et le répondeur sont conformes à la norme OCSP, ils peuvent être facilement intégrés aux environnements OCSP existants qui utilisent des composants tiers standard. Par exemple, il est parfaitement possible de configurer le système de sorte qu'un client Windows Vista vérifie l'état d'un certificat auprès d'un répondeur tiers et qu'un répondeur Windows Server 2008 réponde aux requêtes d'une application client tierce. De plus, le répondeur Windows OCSP peut répondre aux requêtes pour des certificats émis par n'importe quelle autorité de certification conforme. Les autorités de certification Windows Server 2008 (et les autorités de certification Windows en général) ne sont pas nécessaires.

Conclusion
L'infrastructure PKI de Windows Vista et Windows Server 2008 comprend de nombreuses améliorations et plusieurs nouvelles fonctionnalités qui rendent le déploiement et le fonctionnement d'une infrastructure PKI plus sûrs et moins onéreux. La nouvelle API CNG offre aux développeurs un environnement de programmation plus simple et prend en charge les nouvelles normes cryptographiques. Les améliorations de l'inscription permettent aux organisations de fournir plus facilement des certificats et de sécuriser les clés itinérantes à travers l'entreprise. De même, le nouveau pack d'administration et la fonctionnalité de mise en clusters de l'autorité de certification facilitent la surveillance de l'état des d'autorités de certification et assurent la haute disponibilité. Enfin, les améliorations de vérification de révocation utilisent une approche standard pour offrir une validation des certificats en temps réel sans les coûts de bande passante liés à la distribution CRL. Par conséquent, Windows Vista et Windows Server 2008 portent l'infrastructure PKI Windows à un tout nouveau niveau.
Ressources d'améliorations de l'infrastructure PKI
  • Page d'accueil de Windows PKI
  • Dépannage des problèmes de l'infrastructure PKI sur Windows Vista
  • API de cryptographie : nouvelle génération
  • API d'inscription de certificats Comment utiliser les pages d'inscription Web des services de certification avec Windows Vista
  • Configuration et dépannage du client des services de certification - Itinérance avec authentification par informations d’identification

John Morello est chez Microsoft depuis 2000. En tant que consultant senior, il a conçu des solutions de sécurité pour des entreprises classées dans Fortune 100 ainsi que des clients civils et militaires de l'administration fédérale. Il est actuellement responsable de programme senior dans la division Windows Server qui se consacre aux technologies de sécurité et d'accès à distance. Vous pouvez lire le blog de son équipe à l'adresse blogs.technet.com/WinCAT.


 Histoires de Bureau: Familiarisation avec le protocole RDP
Histoires de Bureau
Familiarisation avec le protocole RDP
Wes Miller

Le protocole RDP, Remote Desktop Protocol, vous permet d'accéder à des ordinateurs à distance. Il s'agit d'un outil très utile qui a sans aucun doute rendu de grands services à de nombreux administrateurs système au fil des années. Le protocole RDP fournit depuis longtemps une prise en charge de l'accès à distance qui ne cesse de s'améliorer. Il a été introduit en 1998 pour Windows NT 4.0 Terminal Server Edition
(TSE) et a évolué depuis avec quasiment chaque version de Windows®.
Sous Windows 2000, pratiquement tout le monde pouvait accéder facilement à un système serveur distant parce que les services Terminal Server avaient été introduits en tant que composant Windows facultatif et pouvaient être configurés pour vous permettre d'utiliser le système soit en tant que serveur Terminal Server soit pour ce que nous appelons aujourd'hui un Bureau à distance. Windows Server® 2003 et Windows XP offraient une fonctionnalité de Bureau à distance native, vous permettant de contrôler le système comme si vous y étiez. Aujourd'hui, j'utilise le Bureau à distance tous les jours pour accéder à distance au PC et au serveur de mon domicile, et pour utiliser mon unité Media Center Extender.
Windows XP et les versions ultérieures de Windows ont ajouté l'Assistance à distance, qui fournit une expérience similaire au Bureau à distance mais conçue pour permettre à un utilisateur local de demander l'assistance d'un utilisateur distant. Poursuivant l'évolution de la prise en charge de l'accès distant, Windows Vista® permet désormais aux utilisateurs distants d'offrir une Assistance à distance, si la Stratégie de groupe l'autorise.
Comme vous le verrez, le Bureau à distance améliore encore cette fonctionnalité puissante et vous apprécierez tout ce qu'elle a à offrir. Bien sûr, le Bureau à distance fait l'objet de certaines restrictions, mais il offre également de nombreux avantages. Examinons-les.

Le bon, le mauvais et le formidable
Sous Windows XP (à l'exception de l'Édition Media Center), la principale restriction réside dans le fait qu'un seul utilisateur interactif peut être connecté à la fois. Bien que la fonctionnalité de Changement rapide d'utilisateur de Windows XP permette la connexion simultanée de plusieurs utilisateurs, seul un utilisateur peut agir de façon interactive avec la souris ou le clavier, qu'il soit local à l'ordinateur ou distant. Avec les versions Windows Server (non exécutées en tant que serveurs Terminal Server), deux sessions de Bureau à distance peuvent se connecter simultanément. Pour vous connecter via le Bureau à distance à la session de console dans Windows Server 2003, vous devez lancer l'application de client des Services Terminal Server (MSTSC.exe) avec le paramètre /console en option. La session de console est très importante parce que certaines applications plus anciennes, qui n'ont pas été conçues pour prendre en compte les sessions des services Terminal Server, font souvent apparaître les boîtes de dialogue uniquement sur la session de console (Session 0). La figure 1 illustre un utilisateur connecté à la session de console sur Windows Server 2003. Windows XP et le Bureau à distance Windows Server 2003 appliqueront l'attribution de licences de façon à garantir que seul le nombre d'utilisateurs autorisés est connecté de façon interactive.
Figure 1 Connecté à la session 0
Figure 1 Connecté à la session 0
Par ailleurs, la bande passante du réseau et la Stratégie de groupe peuvent affecter l'expérience de Bureau à distance. Windows XP est capable de fournir une résolution atteignant 24 bits, ainsi qu'une redirection du son, des imprimantes locales, des disques et du presse-papiers pour couper et coller. Du fait du mode de fonctionnement du Bureau à distance pour la création de l'écran, la suppression des éléments graphiques de la session à distance (thèmes, arrière-plans et ainsi de suite) améliore considérablement la bande passante réseau disponible et par conséquent, la session répond beaucoup mieux à l'utilisateur. Windows Vista optimise cette capacité de Windows XP en ajoutant une résolution de 32 bits et une redirection de périphériques supplémentaires.
Notez que certains éléments, tels que les opérations impliquant un grand nombre de graphismes, peuvent présenter des difficultés même pour les meilleures sessions de Bureau à distance s'il n'y a pas suffisamment de bande passante.Prévoyez donc en conséquence.

Nouvelles fonctionnalités dans Windows Vista
Windows Vista propose des modifications significatives du Bureau à distance. Comme mentionné précédemment, la résolution d'affichage 32 bits et le lissage des polices sont deux des modifications les plus visibles. Autre amélioration apparentée : la possibilité d'exécuter des sessions Windows Vista sur plusieurs moniteurs, en lançant le client des services Terminal Server avec la commande /span. Notez que la commande /span fonctionne uniquement avec les systèmes d'hôte distant Windows Vista, qu'elle requiert une résolution sur le client identique sur tous les moniteurs et qu'elle nécessite que les moniteurs soient alignés. La répartition de l'affichage sur plusieurs moniteurs fonctionne en traitant le système distant (le client) comme un seul affichage de grande taille. Cela signifie que l'agrandissement d'une application peut entraîner des effets inattendus, notamment le positionnement inapproprié de boîtes de dialogue, qui doivent être déplacées par l'utilisateur.
Par ailleurs, si le client à partir duquel vous vous connectez est un client Windows Vista et que le système distant est un système Windows Vista, vous pouvez exécuter l'interface utilisateur de la session distante dans le mode Windows Aero™ Glass (dans la mesure où le système local prend en charge Aero Glass, même si ce n'est pas le cas pour le système distant). Ceci est dû au remaniement de l'architecture du Bureau à distance Windows visant à exécuter la plupart des opérations de gestion de fenêtre sur le système client si le client est Windows Vista, ce qui permet d'améliorer l'expérience utilisateur tout en réduisant l'utilisation de la bande passante.
Windows Vista offre également une amélioration clé de la sécurité, l'authentification NLA. L'authentification NLA peut vous aider à empêcher les attaques par un intermédiaire où un utilisateur non autorisé usurpe le serveur auquel vous croyez être connecté. L'authentification NLA améliore également l'expérience d'authentification en ne lançant pas l'interface utilisateur Windows complète pour l'authentification : ceci minimise l'impact sur le système distant et réduit la sensibilité aux attaques par déni de service. L'authentification NLA requiert Windows Vista sur le client et sur le système distant. La figure 2 indique comment spécifier à l'aide du client RDP 6.0 si vous souhaitez mettre en place l'authentification, avertir ou si vous n'en avez pas besoin du tout. Notez que si vous vous connectez à un système distant qui exécute une version de Windows antérieure à Windows Vista, vous devez vous assurer qu'il est configuré pour vous avertir au moins pour cette connexion, sans quoi, la connexion échouera.
Figure 2 Préférences de connexion avancées
Figure 2 Préférences de connexion avancées
La redirection améliorée des ressources (non limitée aux lecteurs et imprimantes) est une autre amélioration clé du protocole RDP dans Windows Vista. Dans la mesure où les pilotes sont présents sur le système distant et où le périphérique prend en charge la redirection, vous pouvez rediriger plusieurs nouveaux types de périphériques, y compris les cartes à puce. D'autres types de périphériques peuvent être pris en charge par leurs fournisseurs.
Windows Vista prend également en charge les serveurs de passerelle via le client RDP 6.0. Ceci permet aux utilisateurs de se connecter de façon transparente à des systèmes distants via Internet sans avoir besoin d'une connexion VPN ou de logiciel tiers. La figure 3 illustre les paramètres de serveur de passerelle des services Terminal Server. Le serveur de passerelle peut être comparé au VPN, sinon qu'il ne nécessite aucun logiciel client spécifique autre que le logiciel client RDP 6.0 (pas besoin de paramètres VPN ou de logiciel propriétaire).
Figure 3 Paramètres de serveur de passerelle des services Terminal Server
Figure 3 Paramètres de serveur de passerelle des services Terminal Server
Windows Vista inclut également l'infrastructure nécessaire à une nouvelle fonctionnalité appelée RemoteApp™. Voici à quoi RemoteApp peut vous servir. Le Bureau à distance vous permet généralement de vous connecter à une session Windows entière. Mais supposez que vous ayez besoin d'exécuter uniquement Microsoft® Word ou Microsoft PowerPoint®. RemoteApp vous permet de le faire. Des scénarios destinés à permettre un partage d'applications robuste seront également disponibles dans Windows Server 2008.
De plus, une nouvelle prise en charge a été ajoutée dans Windows Vista pour l'API de partage de bureau Windows, qui permet la publication d'applications de collaboration partagées. Un exemple d'application mis à votre disposition par l'équipe des services Terminal Server de Microsoft à l'adresse blogs.msdn.com/ts/ archive/2007/03/23/writing-a-desktop-sharing-application.aspx illustre le fonctionnement de l'API de partage de bureau Windows.
Modification importante à noter dans Windows Vista et versions ultérieures : la session 0 (traditionnellement la session de console, où les applications héritées font apparaître des messages de boîte de dialogue) n'est généralement pas accessible à l'utilisateur. Ceci réduit l'interactivité entre les services système (exécutés dans la session 0, bien que d'une façon non interactive) et les utilisateurs interactifs. Ceci permet également de réduire la surface d'attaque posée par les services dotés de privilèges trop nombreux et les utilisateurs interactifs dans Windows Vista, où l'accent est mis sur la réduction des privilèges (avec le contrôle des comptes utilisateur et d'autres améliorations de la sécurité). Vous ne devez normalement pas vous en soucier, à moins que vous n'exécutiez un logiciel hérité sur Windows Vista et qu'il ne fonctionne pas correctement lors de son installation ou de son exécution.
Où trouver le Bureau à distance
Il est essentiel de savoir où le Bureau à distance peut être utilisé. Windows XP Professionnel, l'Édition Media Center et l'édition Tablet PC incluent tous la fonctionnalité de Bureau à distance, de même que toutes les versions de Windows Server 2003. Windows Vista inclut la fonctionnalité de Bureau à distance dans les éditions Professionnel, Entreprise et Intégrale. Les éditions familiales de Windows, notamment Windows XP Édition familiale, et toutes les éditions familiales de Windows Vista, n'incluent pas la fonctionnalité de Bureau à distance.

Client des services Terminal Server
Vous pouvez trouver le nouveau client RDP 6.0 à l'adresse go.microsoft.com/fwlink/?LinkId=91612. Comme mentionné plus haut, le client inclut toutes les fonctionnalités nécessaires pour la connexion à un système RDP 6.0 (Windows Vista ou Windows Server 2008).
La figure 4 illustre le client RDP 6.0. La possibilité de mettre en cache les informations d'authentification représente une amélioration significative dans MSTSC et, si vous vous connectez depuis Windows Vista vers Windows Vista ou Windows Server 2008, même l'authentification unique est prise en charge par la Stratégie de groupe.
Figure 4 Client RDP 6.0
Figure 4 Client RDP 6.0
La version 6.0 de MSTSC.exe compte de nombreux paramètres de ligne de commande, répertoriés ci-dessous. Examinons-les un par un.
mstsc [<connection file>] [/v:<server[:port]>]
[/console] [/f[ullscreen]] [/w:<width>] [/h:<height>]
[/public] | [/span] [/edit "connection file"] [/migrate] [/?]
/v:<serveur[:port]> spécifie l'ordinateur distant auquel vous souhaitez vous connecter, ainsi qu'une valeur de port facultative (le port 3389, port par défaut, peut être modifié sur toutes les versions de Windows).
/console vous permet de vous connecter à la session de console de versions antérieures de Windows. Ce paramètre ne fonctionne pas avec Windows Vista ou Windows Server 2008.
/f démarre la connexion Bureau à distance en mode plein écran.
/w:<largeur> spécifie la largeur de la fenêtre de connexion Bureau à distance.
/h:<hauteur> spécifie la hauteur de la fenêtre du Bureau à distance.
/public exécute la connexion Bureau à distance en mode public. Dans le mode public, le client RDP ne met pas de données en cache sur le système local. Utilisez le mode public, par exemple, lorsque vous vous connectez à un serveur d'entreprise depuis un système situé dans un centre de conférences.
Autres merveilles des services Terminal Server
Vous ignorez peut-être que deux autres technologies Microsoft utilisent des composants des services Terminal Server pour exécuter leurs prouesses. Le Changement rapide d'utilisateur dans Windows XP et Windows Vista permet à plusieurs utilisateurs de se connecter sur le même système, mais passe rapidement d'un contexte utilisateur à un autre sans forcer les utilisateurs à se déconnecter. Windows Media Center (et Windows Vista) exploite cette infrastructure pour permettre aux unités Media Center Extender, qui correspondent en fait à un terminal client léger disposant d'une technologie de rendu et de codecs audio/vidéo, de se connecter et d'afficher l'environnement Media Center à distance sur un téléviseur par le biais d'une connexion câblée ou sans fil. Dans Windows XP, il s'agit généralement de scénarios non métier, puisque ces deux technologies nécessitent un système qui n'est pas joint à un domaine et dans lequel le changement rapide d'utilisateur est activé. N'oubliez pas que toutes deux sont disponibles dans les éditions Windows Vista professionnelles, bien que les scénarios d'utilisation ne soient pas vraiment appropriés au contexte de l'entreprise, raison pour laquelle je ne suis pas vraiment rentré dans les détails.

/span conserve la largeur et la hauteur du bureau virtuel local sur le bureau à distance, en répartissant l'affichage sur plusieurs moniteurs au besoin. Notez que les moniteurs doivent tous avoir la même hauteur et être alignés côte à côte.
/edit ouvre le fichier de connexion rdp spécifié pour le modifier. Les fichiers RDP servent à stocker les informations de connexion pour un système distant spécifique.
/migrate déplace les anciens fichiers de connexion créés avec le Gestionnaire de connexion client vers de nouveaux fichiers de connexion .rdp.
Un grand nombre des améliorations apportées au client MSTSC sont également disponibles lors de l'utilisation du contrôle ActiveX® des services Terminal Server, de même que lors de l'utilisation de TSMMC.msc, décrit plus bas, pour se connecter à plusieurs systèmes depuis la même console.

Nouvelles fonctionnalités dans Windows Server 2008
Outre les fonctionnalités et modifications déjà mentionnées pour Windows Vista, Windows Server 2008 inclut ses propres fonctions de Bureau à distance : Terminal Services Web Access et Terminal Services Easy Print.
TS Web Access permet d'utiliser un navigateur Web pour consulter une liste des programmes qui ont été activés sur le serveur distant en tant qu'applications à distance et de les lancer d'un simple clic grâce au contrôle ActiveX du Bureau à distance. D'une certaine façon, l'expérience est semblable à celle de la virtualisation d'applications SoftGrid dont j'ai parlé dans mon article du mois dernier consacré à Microsoft Desktop Optimization Pack, où un utilisateur distant lance une application en toute facilité sans qu'un logiciel installé localement soit nécessaire. Il sera intéressant, au cours des prochaines années, de comparer les scénarios d'utilisation des technologies SoftGrid à ceux des technologies des services Terminal Server.
TS Easy Print permet de rediriger vers le système local (client) toutes les tâches d'impression lancées sur le système distant (hôte). Vous pensez peut-être que la redirection d'imprimante offre déjà cette fonctionnalité, mais ce n'est pas le cas. Easy Print fonctionne sans que des pilotes d'imprimante supplémentaires ne soient nécessaires sur le système hôte ou sans aucune interactivité de la part de l'utilisateur pour installer le périphérique. S'il y a une imprimante locale, elle fonctionne de la même façon sur le système distant et localement. Pour qu'Easy Print fonctionne, le système distant doit exécuter Windows Server 2008, et les systèmes clients et serveurs doivent exécuter le client des services Terminal Server 6.1 et avoir installé Microsoft .NET Framework 3.0 SP1. Tous deux devraient être disponibles en même temps que Windows Server 2008.

Conseils pour l'utilisation du Bureau à distance
Comme je l'ai mentionné précédemment, j'utilise le Bureau à distance, ou plutôt le composant MMC (Microsoft Management Console) du Bureau à distance, tous les jours. En ajoutant ici des systèmes distants sous la forme de nœuds, vous pouvez basculer rapidement et facilement entre plusieurs systèmes depuis la même interface utilisateur. La figure 5 illustre l'environnement utilisateur MMC. Le composant logiciel enfichable MMC fait partie du pack des outils d'administration Windows Server 2003, dont la dernière version est disponible à l'adresse go.microsoft.com/fwlink/?LinkId=91685.
Figure 5 Page MMC
Figure 5 Page MMC
Une autre astuce que j'ai remarquée concerne les opérations couper-coller. Les opérations couper-coller sur le client et le serveur sont apparues avec Windows XP. Pour qu'elles fonctionnent, le client et le serveur doivent tous les deux exécuter Windows XP et le presse-papiers doit être redirigé (voir la figure 6). Les clients Windows Vista prennent également en charge les opérations couper-coller lorsque la redirection du presse-papiers est activée pour la connexion.
Figure 6 Paramètres des ressources locales
Figure 6 Paramètres des ressources locales
Il est également important de noter que les raccourcis clavier dont vous risquez d'avoir besoin, tels que Ctrl + Alt + Suppr, ne sont pas transmis via le réseau au système distant : ils agissent toujours sur le système local. Pour envoyer Ctrl + Alt + Suppr vers le système distant, appuyez sur Ctrl + Alt + Fin sur le client.
Pour finir, je vous recommande de consulter régulièrement le blog de l'équipe des services Terminal Server de Microsoft à l'adresse blogs.msdn.com/ts. C'est en tout cas ce que je fais.
Personnellement, je trouve que le Bureau à distance et les services Terminal Server me facilitent énormément la vie, à tel point que j'ai du mal à l'imaginer sans eux. J'espère que cet article vous aura fourni un bon aperçu des nouvelles fonctionnalités du client RDP 6.0 et de Windows Vista et Windows Server 2008.

J'aimerais remercier Nelly Porter, responsable de programme principale au sein de l'équipe des services Terminal Server, pour son aide à la préparation de cet article.

Wes Miller est responsable du développement chez Pluck (www.pluck.com) à Austin, au Texas. Auparavant, il a travaillé chez Winternals Software à Austin et chez Microsoft en tant que responsable de programme et responsable de produit pour Windows. Vous pouvez contacter Wes à l’adresse suivante : technet@getwired.com.


 Sur le terrain: Entretiens sur messagerie instantan&#233;e
Sur le terrain
Entretiens sur messagerie instantanée
Nathan G. Jensen

Récemment, mon entreprise a publié une annonce en ligne pour rechercher un ingénieur logiciel expérimenté (poste en télétravail) et nous avons immédiatement été inondés de candidatures du monde entier. En tant que développeur responsable, j'ai été chargé de mener les entretiens techniques pour cette masse de candidats. Je regardais épuisé la liste interminable et lisais les C.V. surgonflés l'un après l'autre. Je savais par expérience que la plupart de ces candidats n'auraient pas les compétences requises, c'est pourquoi les entretiens techniques sont si importants.
Alors que j'envisageais de faire passer d'innombrables entretiens par téléphone, j'ai pensé, « ça va prendre un mois ! » Puis ça m'est venu. J'ai eu une révélation, une vision. Une idée est tombée du Super Département Informatique du ciel : faire passer les entretiens par messagerie instantanée ! C'était génial ! Et ça a fonctionné.
J'ai commencé par envoyer un message électronique en masse à tous les candidats par CCI, expliquant qu'un entretien technique détaillé serait nécessaire et que Windows Live™ Messenger (pas le téléphone) serait le moyen de communication. Ce message électronique a permis d'écrémer environ la moitié les candidats, vraisemblablement parce qu'ils savaient qu'ils ne pourraient pas donner le change lors d'un entretien technique. Pour les autres, j'ai senti qu'une discussion par messagerie instantanée fonctionnerait parce que je voulais uniquement des réponses directes à des questions strictement techniques, bam bam bam. À ce stade du processus d'entretien, le contact et les qualités oratoires n'avaient pas beaucoup d'importance.
Figure J'avais plusieurs fenêtres de messagerie ouvertes et je les mitraillais tous de questions techniques
Figure J'avais plusieurs fenêtres de messagerie ouvertes et je les mitraillais tous de questions techniques
Ma première observation a été que cette formule haute technologie d'entretien permettait de gagner du temps et de l'argent. Pas de facture de téléphone. Et quand les candidats ont commencé à me contacter pour un entretien, je me suis rendu compte que je pouvais m'occuper de plusieurs d'entre eux simultanément et efficacement. Ca a été un sacré choc. J'avais plusieurs fenêtres de messagerie ouvertes et je les bombardais tous de questions techniques. Et parce que j'avais pré-tapé les questions, il s'est principalement agit d'un exercice de copier-coller.
J'avais passé mes questions au tamis du Web afin d'éviter les jolies réponses prélevées sur Internet. Si quelqu'un envoyait une réponse qui avait l'air de venir d'un article bien léché ou d'une documentation officielle, ce serait évident. De plus, Windows Live Messager peut suivre l'horodateur de chaque réponse si bien que vous pouvez vous absenter, revenir et déterminer quels candidats prennent trop de longtemps pour répondre.
J'ai eu une autre révélation lorsque, au milieu de ces discussions simultanées, mon téléphone a sonné et que je me suis rendu compte que je pouvais continuer les entretiens et parler au téléphone en même temps. C'était le sommet de l'efficacité multithread !
Et juste au moment où je pensais que les choses ne pouvaient aller mieux, un autre avantage m'est apparu. Ce qui m'agace le plus dans les entretiens techniques par téléphone, c'est quand je pose une question courte et attends une réponse aussi courte mais que je dois écouter un discours de cinq minutes. Avec la messagerie instantanée, cela n'arrive plus parce que les gens ont tendance à faire court dans leurs réponses.
À la fin de chaque entretien j'ai enregistré les journaux de la discussion pour en garder un enregistrement que je pourrais revoir et évaluer ultérieurement. Et j'ai envoyé ces journaux à mon patron pour qu'il en établisse une comparaison objective. Enfin, l'ensemble du processus n'a pris que quelques heures au lieu d'une semaine (le temps nécessaire pour prendre des rendez-vous et interviewer les 25 candidats par téléphone).
Je n'aurais pas pu être plus heureux de ma découverte. Nous avons engagé la personne qui a fourni le plus rapidement les réponses correctes et a eu ensuite un bon entretien « personnel » avec mon patron par téléphone. Ca a été rapide, efficace, productif et nous a permis de trouver le meilleur candidat pour la tâche seulement quelques jours après la publication de l'appel aux candidatures.

Nathan G. Jensen est responsable de développement Web et auteur indépendant habitant à Salt Lake City. Vous pouvez le contacter en visitant builderdash.com.


 La vie secr&#232;te de Windows: L'Explorateur Windows ne fait pas de la litt&#233;rature
La vie secrète de Windows
L'Explorateur Windows ne fait pas de la littérature
Raymond Chen

Il était une fois le PowerToy Send To X. Il vous permettait de faire trucs géniaux comme sélectionner un ensemble de fichiers, cliquer avec le bouton droit, et ensuite sélectionner Envoyer au presse-papiers en tant que noms. Comme prévu, cette opération copiait les noms des fichiers sélectionnés dans le presse-papiers.
C'était certes un PowerToy bien utile, mais pourquoi avait-il même dû être créé ? Pourquoi ne puis-je pas juste copier les fichiers dans l'Explorateur Windows® et les coller ensuite en tant que texte pour obtenir les noms de fichier ? Ou mieux encore, pourquoi ne puis-je pas simplement faire glisser des fichiers de l'Explorateur Windows et les déposer dans le Bloc-notes pour en obtenir les noms ?
Nous avons essayé, mais ça ne marche pas.
Le transfert de données, que ce soit à l'aide du presse-papiers ou du glisser-déplacer, est régi par les objets de données OLE, représentés par l'interface IDataObject. Un objet de données offre toute une série de formats. Certains formats de presse-papiers, y compris le texte et les images bitmaps, existent à peu près depuis les débuts de Windows. Les autres ont été progressivement ajoutés. Lorsque la fonctionnalité de glisser-déplacer de fichiers a été introduite pour la première fois dans Windows, elle avait la forme d'un HDROP. Vous pouviez la transmettre à des fonctions telles que DragQueryFile, par exemple, pour extraire les noms de fichier. Lorsque vous copiez un élément dans le presse-papiers de l'Explorateur Windows, l'objet de données résultant offre, entre autres, le HDROP mentionné ci-dessus, le contenu du fichier et un descripteur du groupe de fichiers. Mais l'un des formats que vous ne verrez pas proposé par l'objet de données est le format texte.
Lorsque une cible de déplacement (un élément vers lequel vous pouvez déplacer les objets) est informée qu'un objet de données est glissé ou déplacé vers lui, elle demande à l'objet de données « Qu'est-ce que tu as ? » L'objet de données répond en listant tous les formats qu'il prend en charge, dans un ordre de préférence décroissant. En d'autres termes, le premier format renvoyé par l'objet de données est le format qui décrit le mieux l'objet. Vient ensuite le meilleur format suivant, et ainsi de suite, jusqu'à ce que vous arriviez au dernier format, qui est juste une pâle ombre de l'objet original. Par exemple, l'objet de données qui représente certains objets issus d'une fenêtre de l'Explorateur Windows fournirait probablement d'abord une liste d'ID de noyau, puisque c'est une représentation presque parfaite du contenu d'une fenêtre de l'Explorateur Windows. Ensuite viendrait dans la liste un descripteur de groupe de fichier, suivi du contenu des fichiers, puis un HDROP.
En 1998, l'équipe du shell a essayé d'ajouter le texte brut à la liste de formats offerts, en le mettant tout à la fin de la liste. Pour l'essentiel, ce format disait, « si vous êtes vraiment désespéré, au moins vous pouvez obtenir un peu de texte (à savoir, la liste de fichiers). » Malheureusement, dans la réalité plusieurs programmes étaient distraits par le joli format texte et disaient, « Ooooh, j'aime le texte ». Ces programmes allaient directement au format texte qui ne contenait rien d'autre qu'une liste de fichiers. Par conséquent, lorsque vous faisiez glisser un fichier de l'Explorateur Windows et que vous le déposiez déposé dans un document, le programme insérait juste le nom du fichier au lieu d'insérer le fichier lui-même dans le document.
Oups.
En raison des commentaires très négatifs sur la compatibilité des applications, cette modification a été annulée. Par conséquent, lorsque vous glissez-déplacez ou collez des fichiers copiés à partir de l'Explorateur Windows, l'objet de données de noyau n'offre pas les noms de fichier au format texte.
Windows Vista®, toutefois, corrige ce très vieux défaut en vous offrant un moyen de copier le chemin au format texte : appuyez sur la touche MAJ lorsque vous cliquez avec le bouton droit afin d'afficher le menu contextuel étendu. Vous obtiendrez ainsi la nouvelle option Copier en tant que chemin d’accès. Pas besoin d'un PowerToy.

Raymond Chen, The Old New Thing, et son livre du même titre (Addison-Wesley, 2007) traitent de l’historique de Windows et de la programmation Win32. Il laisse l'amélioration des mécanismes aux autres.