August 2007
System Center: SMS ha evolucionado: Una nueva y eficaz solución para la administración de sus sistemas
La administración de sistemas está a punto de ser mucha más sencilla. Obtenga una visita guiada de System Center Configuration Manager 2007 y compruebe cómo puede simplificar tareas clave, tales como la implementación de actualizaciones de software, la administración de dispositivos móviles y el mantenimiento de configuraciones de sistema. John Orefice
System Center: Implemente aplicaciones y actualizaciones en sus sucursales
Los puntos de distribución de sucursales, una de las nuevas características de Configuration Manager 2007, podrían parecer en un principio una adición bastante irrelevante. Pero si nos fijamos un poco más, veremos que presenta capacidades nuevas e indispensables para la administración de la distribución de software en las sucursales. Steve Rachui
System Center: Introducción a System Center Essentials 2007
Diseñado específicamente para empresas medianas, System Center Essentials ofrece una solución unificada para la supervisión, administración y solución de problemas de sistemas. Esta es una guía detallada para la instalación y configuración de Essentials 2007 en su red. David Mills
System Center: Cuide sus servidores con Operations Manager 2007
Operations Manager 2007, la encarnación más nueva de MOM, incorpora algunas mejoras importantes, entre las que se incluyen nuevas interfaces de administración, mejor generación de informes y compatibilidad para aplicaciones de línea de negocios, nuevas opciones de seguridad y mucho más. Pete Zerger
System Center: Migración de MOM a Operations Manager 2007
¿Está listo para cambiar a Operations Manager 2007? Debido a cambios de arquitectura, no hay una ruta de actualización local sencilla desde una versión anterior de MOM. En cambio, siga alguno de los planes de migración que se presentan aquí. Andy Dominey
System Center: Virtualice sus aplicaciones con Microsoft SoftGrid
Las aplicaciones virtualizadas ofrecen numerosas ventajas, desde las mejoras de la experiencia de usuario hasta la simplificación en la administración de sistema. Obtenga una introducción detallada de cómo Microsoft SoftGrid proporciona aplicaciones virtuales, cómo pueden adaptarse en su infraestructura y cómo puede ahorrar tiempo y dinero a la empresa. Ahmer Sabri and Kedar Shah
Columns
Nota del editor: Dinámico y optimizado: | Cuadro de herramientas: Nuevos productos para profesionales de TI: | Preguntas y respuestas acerca de SQL: Búsqueda de bloqueos, consultas de gran tamaño, estadísticas de E/S y mucho más.:
Utility Spotlight: BGInfo: No sería estupendo si pudiese consultar todo lo que necesita acerca de un equipo PC: nombre, dirección IP, puerta de enlace, espacio libre en disco, etcétera, y en un solo lugar. Pues ahora puede, con esta herramienta gratis de Sysinternals.Lance Whitney | The Cable Guy: Configuración automática de IPv6 en Windows Vista: Hay mucho más en IPv6 que sólo la extensión del espacio de direcciones de 32 bits a 128 bits. Esta es una vista de cómo los hosts IPv6 se pueden configurar de forma automática, incluso sin usar un protocolo de configuración de direcciones.Joseph Davies | Windows PowerShell: El poder del filtrado: La canalización no es sólo para los cmdlets. Echemos un vistazo a cómo puede usar la canalización de Windows PowerShell para poder agregar capacidades de filtrado útiles a sus scripts.Don Jones
¡Hola, encargados del scripting!: ¿Quién es usted?: Con Active Directory, los usuarios pueden tener varias identidades, tales como givenName, displayName, userPrincipalName o distinguishedName. Como administrador del sistema: ¿cómo obtiene toda esta información acerca de un usuario? Con un script, por supuesto.The Microsoft Scripting Guys | Vigilancia de seguridad: Mejoras de PKI en Windows: En Windows Vista y Windows Server 2008, la plataforma PKI de Windows es compatible con los algoritmos avanzados, las comprobaciones de validez en tiempo real y las mejoras de la capacidad de administración. Consulte las características nuevas de PKI y cómo éstas pueden usarse para reducir costos y, al mismo tiempo, mejorar la seguridad.John Morello | Archivos del escritorio: Introducción a RDP: El protocolo de escritorio remoto, que permite obtener acceso a equipos de forma remota, es una tecnología muy útil que va mejorando con cada versión de Windows. Obtenga una introducción acerca del uso de Escritorio remoto y conozca las muchas prestaciones y limitaciones que ofrece.Wes Miller
Notas de campo: Entrevistas a través de mensajería instantánea: Tiene una vacante que cubrir en su empresa y una pila enorme de currículos procedentes de todo el planeta. ¿Cómo estrechar rápidamente su búsqueda? La respuesta puede encontrarse en la realización de entrevistas a través de mensajería instantánea. Ésta es la historia de éxito de un desarrollador.Nathan G. Jensen | Confidencial de Windows: Explorador de Windows no crea texto: ¿Por qué no se puede copiar una lista de archivos en Explorador de Windows y pegarlos como texto para obtener sus nombres de archivo? El equipo de Windows intentó incluir esta funcionalidad, pero no funcionó como estaba planeado.Raymond Chen


System Center
SMS ha evolucionado: Una nueva y eficaz solución para la administración de sus sistemas
John Orefice
Resumen:
  • Implementación del sistema operativo
  • Administración de actualizaciones de software
  • Administración de la configuración deseada

Systems Management Server (SMS) 2003 se ha transformado en una importante herramienta de administración de configuración y entrega de software para los administradores de todo el mundo. Ahora Microsoft se prepara
para presentar una nueva versión de su solución de administración de la empresa, y la nueva versión tiene nuevas capacidades y un nombre nuevo: System Center Configuration Manager 2007.
System Center es una familia de productos de Microsoft diseñados para funcionar en conjunto con el fin de hacer más fácil y rentable la administración diaria de la compleja infraestructura de TI. Las soluciones System Center se basan en la automatización y las recomendaciones derivadas de Microsoft® Operations Framework (MOF) y la Biblioteca de infraestructuras de tecnologías de la información (ITIL), y se pueden usar en todos los niveles de una organización.
Configuration Manager 2007 es sólo un elemento de la familia System Center. System Center Data Protection Manager ofrece características de copia de seguridad y recuperación de sistemas empresariales. System Center Operations Manager proporciona supervisión y automatización proactivas de sistema. System Center Capacity Planner se puede usar en la planeación de capacidad y el análisis de tipo "qué ocurre si" (what-if) de implementaciones de infraestructura. Y la lista sigue creciendo (para obtener más información, consulte www.microsoft.com/systemcenter).
En este artículo, le guiaré por varias características nuevas y mejoradas planeadas para Configuration Manager 2007, que se basan en la versión beta más reciente. Le ofreceré una amplia visión de lo que puede esperar en esta emocionante versión y espero conseguir que piense en cómo podrá ahorrar tiempo y dinero en su organización con Configuration Manager.

Nueva interfaz administrativa de usuario
A partir de SMS 1.0, una de las nuevas características de SMS más solicitadas ha sido una interfaz de usuario nueva y mejorada. Microsoft responde a esa solicitud con varias mejoras a la interfaz administrativa de usuario de System Center Configuration Manager 2007. Para permitir estas nuevas características, la nueva consola de Configuration Manager 2007 se crea con C# y Microsoft .NET Framework, y se ejecuta sobre la base de la tecnología de Microsoft Management Console (MMC) 3.0. Además, como en SMS 2003, la interfaz de usuario es ampliable mediante SDK, de modo que los usuarios de la consola pueden crear sus propios complementos para satisfacer sus necesidades individuales.
La figura 1 muestra la nueva consola con el nodo Computer Management expandido y representa todas las nuevas funciones de administración que están disponibles. Además, observe el nuevo aspecto de la sección SMS Site Configuration, que resume las tareas comunes que se necesitan completar de forma previa para que Configuration Manager esté operativo después de la instalación. La sección Links and Resources contiene tareas pertinentes que reducen el tiempo de navegación a través de la consola en funciones comunes.
Figura 1 Interfaz de administración de Configuration Manager
Figura 1 Interfaz de administración de Configuration Manager (Hacer clic en la imagen para ampliarla)
Algunas ventajas y características que esta nueva consola permite son la capacidad de seleccionar, arrastrar y soltar elementos múltiples (útil en la administración de colecciones), las carpetas de búsqueda para organizar elementos en la consola de modo práctico en lugar de físico, el panel Actions para realizar tareas apropiadas en la sección actual, el panel Preview para ver información resumida de un elemento específico (por ejemplo, la imagen de un sistema operativo), páginas principales para resumir información sobre un tema en particular tal como la implementación de software y mejoras en la estructura organizativa para simplificar apreciablemente la navegación.
Tal como se indicó, el panel Actions es una de las mayores mejoras dentro de la consola recientemente actualizada. Ofrece un modo de ver las acciones apropiadas para el contexto de la sección de la consola en uso. Por ejemplo, si observa la colección All Systems, el panel Actions contendrá acciones tales como la Update Collection Membership e Install Agent (consulte la figura 2).
Figura 2 Las acciones disponibles son específicas de la vista actual
Figura 2 Las acciones disponibles son específicas de la vista actual (Hacer clic en la imagen para ampliarla)
Además, Configuration Manager 2007 incorpora un nuevo concepto denominado páginas principales, que le ofrece la capacidad de revisar con mucha rapidez el estado de funciones específicas tales como actualizaciones de software, distribución de software o administración de la configuración deseada. Puede realizar estas tareas dentro de la consola sin necesidad de ejecutar los informes o buscar datos en cualquier otra parte. A medida que resumo las diferentes características del producto, observe más ejemplos sobre páginas principales en este artículo.

Funciones de servidor y puntos de distribución
Configuration Manager 2007 incorpora nuevas funciones de servidor para habilitar algunas de las nuevas características que abordaré aquí. Entre ellas se incluyen Fallback Status Point (FSP), PXE Service Point (PSP), Branch Office Distribution Point (DP), State Migration Point (SMP), Software Update Point (SUP) y System Health Validator (SHV). Al igual que con el resto de las funciones de servidor de SMS y Configuration Manager, estas funciones se pueden hospedar en el mismo servidor mientras se realizan los ejercicios de planeamiento de capacidad adecuados.
Branch Office DP es importante y difiere del DP tradicional por dos motivos. Primero, no se debe instalar en un sistema operativo de servidor; se puede instalar en Windows Vista® o Windows® XP. Es la única función de Configuration Manager que se puede instalar en un sistema operativo cliente. Esto es de gran utilidad para las sucursales sin servidor local o en los casos en que el departamento de TI desea eliminar servidores en sucursales más pequeñas para ahorrar dinero y reducir la carga administrativa. En estos casos donde sólo existen equipos que ejecutan Windows XP o Windows Vista, Branch Office DP se puede usar para reducir el tráfico de WAN al garantizar que los clientes no extraen paquetes de la WAN cuando se ponen a disposición de forma local.
La segunda manera en que un Branch Office DP difiere de un DP estándar es a través de su conectividad con otros DP. Los datos de réplica de los puntos de distribución tradicionales no se aceleran ni se programan a menos que vayan desde un sitio principal a uno secundario. Por este motivo, muchas organizaciones sólo realiza réplicas de los paquetes a las sucursales durante la noche, con lo cual la distribución de software se demora hasta que esos paquetes están disponibles de forma local.
Branch Office DP usa servicios de transferencia inteligente en segundo plano (BITS) para descargar la información de otros DP. Esto es excepcional para acelerar el ancho de banda sobre un vínculo WAN entre una sucursal y un DP presente en el centro de datos central, especialmente cuando no existe un sitio secundario de Configuration Manager ubicado en la sucursal. La figura 3 muestra el nuevo cuadro de diálogo DP Properties que se usa para convertir un DP estándar en un Branch Office DP.
Figura 3 Configuración de Branch Office DP
Figura 3 Configuración de Branch Office DP (Hacer clic en la imagen para ampliarla)
SMS 2003 incorporó una tecnología de réplica que permitió la réplica delta de archivos de paquetes desde un servidor de sitio a un punto de distribución. Esta tecnología funcionó bien con paquetes SMS compuestos por varios archivos más pequeños. Por ejemplo, si un administrador de SMS necesitaba realizar un cambio sólo en un archivo, o en varios archivos más pequeños en un paquete SMS mayor, sólo se realizaba la réplica de aquellos archivos modificados en el paquete en lugar del paquete completo.
A medida que la implementación del sistema operativo se vuelva más habitual en Configuration Manager 2007, se querrá asegurar que la réplica de imágenes del sistema operativo y otros paquetes mayores en su infraestructura y sobre vínculos WAN sea lo más eficaz posible. Con ese objetivo en mente, Configuration Manager 2007 incorpora la réplica delta binaria de servidores de sitio entre sí, de servidores de sitio a DP y de DP a Branch Office DP.
Por ejemplo, comience con una nueva imagen de implementación de Windows Vista que tiene varias aplicaciones preinstaladas. Este paquete puede tener un tamaño de 6 GB y debido a que es una imagen con formato de imagen de Windows (WIM), es además un único archivo de 6 GB. Como se describió anteriormente, en SMS 2003, cuando se abre la nueva imagen WIM para cambiar una configuración o agregar una nueva revisión de 2 MB recién lanzada, debido a que la imagen es un único archivo WIM, es necesario replicar el paquete SMS completo de 6 GB a los DP. En contraste con esto, con la réplica delta binaria en Configuration Manager 2007, si se cambia una configuración o se agrega una única revisión al paquete de la imagen WIM, se realizará la réplica exactamente de esa única revisión o configuración de 2 MB en la infraestructura en lugar de los 6 GB completos.

Procesos comunes para dispositivos móviles
Poco después del lanzamiento de SMS 2003, Microsoft lanzó al mercado Device Management Feature Pack (DMFP) para administración de dispositivos móviles Windows CE y Pocket PC. A medida que los dispositivos móviles se hacen más generalizados en las organizaciones empresariales, la necesidad de administrarlos se vuelve más prioritaria. Reconocida esta tendencia, Configuration Manager 2007 mejora SMS 2003 DMFP y ofrece una nueva y fantástica solución integrada para administrar dispositivos móviles incluidos los Smartphone de Windows Mobile® y teléfonos de Pocket PC, de manera similar a como administraría servidores, equipos portátiles y equipos de escritorio.
La administración básica de dispositivos móviles incluye inventario de hardware y software, capacidades de recopilación de archivos, distribución de software y configuración de contraseñas y administración de directivas de seguridad. Mediante la administración de clientes basada en Internet de Configuration Manager 2007, ahora todos los dispositivos se pueden administrar en su Intranet así como a través de Internet. Esto es útil para los Smartphone y otros dispositivos que muy rara vez o casi nunca se encuentran en la LAN corporativa.
También ha mejorado el proceso de implementación del agente. Ahora se admiten actualizaciones de cliente por aire y la distribución de clientes se puede automatizar mediante la consola de Configuration Manager.

Ventanas de mantenimiento
Muchos de los clientes empresariales con que trabajo tienen ventanas de mantenimiento predefinidas tanto para los servidores como para ciertos escritorios fundamentales. Además, regularmente piden consejos sobre cómo implementar aplicaciones mayores como 2007 Microsoft Office system, sin interrumpir al usuario final durante el horario comercial habitual.
Configuration Manager 2007 incorpora una nueva característica denominada ventanas de mantenimiento. Le permite definir ventanas de tiempo durante las cuales se pueden producir instalaciones de una colección concreta. Esta característica le ofrece la libertad de realizar un anuncio obligatorio sin necesidad de preocuparse por las repercusiones del paquete que se instala durante el horario comercial normal o en tiempos inoportunos para los usuarios.
Considere, por ejemplo, la implementación de un paquete de 2007 Office system. Desea poder enviar lo más rápidamente posible esta aplicación a los usuarios finales, pero no quiere que la inserción de la aplicación interfiera durante el día con el trabajo. Puede establecer la ventana de mantenimiento para indicar la agenda durante la cual desea que el sistema realice la instalación (quizás de las 20h00 a las 06h00). Si, por cualquier motivo, el sistema no está disponible durante esta ventana de mantenimiento en un día concreto, Configuration Manager esperará hasta la próxima vez definida en la ventana de mantenimiento para garantizar que el negocio no se interrumpe de modo inesperado. También tiene la opción de omitir las ventanas de mantenimiento en un nivel de anuncio, lo que le permite implementar una actualización crítica tan pronto como sea posible, pese a cualquier restricción que pueda estar aplicada.

Implementación del sistema operativo
La función de implementación del sistema operativo es la mayor área individual de especialización de Configuration Manager 2007. Microsoft ha diseñado Configuration Manager como el principal medio de implementación del sistema operativo tanto para plataformas de servidores como para estaciones de trabajo. Las mejores características de SMS 2003 Operating System Deployment (OSD) Feature Pack se integran en Configuration Manager 2007 para cambiar de modo fundamental la manera de administrar las implementaciones del sistema operativo.
Como quizá sepa, Windows Vista incorporó un nuevo formato de imagen de Windows (WIM) para la implementación del sistema operativo. Existen varias ventajas en usar este formato, comenzando con el hecho que Configuration Manager 2007 importa el formato de imagen WIM de modo nativo para que los administradores puedan trabajar en las imágenes e implementarlas directamente desde la consola.
Otra nueva característica de implementación importante en Configuration Manager es el secuenciador de tareas integrado. Si conoce Microsoft Solution Accelerator for Business Desktop Deployment (BDD), encontrará muchas similitudes con las características y opciones disponibles en Configuration Manager, aunque con una diferencia importante: ya no necesitará escribir scripts para implementar o capturar imágenes del sistema operativo. Y al aprovechar el secuenciador de tareas, se delega completamente el proceso de implementación del sistema operativo.
El secuenciador de tareas ayuda a ordenar todos los pasos que necesita ejecutar en la implementación de su sistema operativo, incluidos los pasos previos a la implementación que se ejecutan en el antiguo sistema operativo (migración del estado de usuario y transferencia de configuraciones de aplicación), los pasos para implementar el nuevo sistema operativo (formato, particiones de disco, clave de producto, nombre de usuario, compañía, configuración de licencia, instalación de controladores) y los pasos necesarios después de la implementación del nuevo sistema (instalación de aplicaciones adicionales, instalación de actualizaciones, migración del estado de usuario). Como ejemplo de esta funcionalidad, la figura 4 muestra el editor de secuencias de tareas que resalta algunas de las características que puede aprovechar en una implementación de Windows Vista.
Figura 4 Edición de pasos en una implementación del sistema operativo
Figura 4 Edición de pasos en una implementación del sistema operativo (Hacer clic en la imagen para ampliarla)
Además del secuenciador de tareas, existen varias mejoras adicionales en la implementación del sistema operativo en Configuration Manager 2007, tal como se describe en la figura 5. Por ejemplo, Configuration Manager admite la implementación completa con entorno de ejecución previo al arranque (PXE) para plataformas x86 y x64 con administración de controladores de dispositivo. La opción de administración de controladores de dispositivo permite a su organización reducir apreciablemente el número de imágenes que se necesitan mantener para diferentes clases de hardware. Combinada con la compatibilidad de imagen única incorporada con el formato de imagen WIM de Windows Vista, tiene prácticamente garantizado el ahorro de tiempo y dinero cuando realiza la implementación del sistema operativo.
Figure 5 Características de la implementación del sistema operativo

Escenario | SMS 2003 | Configuration Manager 2007
Implementación de extremo a extremo | Sí | Sí
Totalmente automatizado | Sí | Sí
Actualización de barrido y carga | Sí | Sí
Implementación completa con PXE | Integración no estricta con Servicios de instalación remota (RIS) | Complemento integrado con Servicios de implementación de Windows (WDS)
En paralelo | Scripts de BDD | Sí, mediante State Migration Point integrado
Implementación completa sin conexión | No | Sí
Planeamiento de actualización de Windows Vista | No | Sí
Implementación de servidor completa | No | Sí
Administración de controladores de dispositivo | No | Sí

Administración de actualizaciones de software
Como muchas otras características en Configuration Manager 2007, la administración de actualizaciones de software ha sido totalmente mejorada. Configuration Manager separa la manera en que los paquetes de actualización y normales se insertan en un agente administrado con la creación de un canal de alta prioridad basado en estado para la información de todas las actualizaciones de software y administración de la configuración deseada. La inserción de otros paquetes de software ya no interferirá con la inserción de actualizaciones de software o la recepción del estado de revisiones de estaciones de trabajo administradas, equipos portátiles o servidores.
El método basado en estado para la administración de actualizaciones de software también significa que el estado de revisión y actualización ya no está asociado con las examinaciones de inventario de hardware y, por lo tanto, la herramienta actual Inventory Tool for Microsoft Updates (ITMU) y el catálogo de examinación ya no son necesarios. En cambio, Configuration Manager usa la nueva función de servidor Software Update Point (SUP) que ejecuta Windows Server Update Services (WSUS) en el back-end como motor y base de datos de actualización de software.
WSUS le permite tener toda la administración de actualizaciones en Configuration Manager en una ubicación central. Esto le ofrece la capacidad de descargar todo el contenido disponible en Microsoft Update incluidas las actualizaciones no críticas, controladores y otros paquetes de software de la plataforma Microsoft. Además, Microsoft también anima a sus asociados a publicar actualizaciones de software a través de este método. Adobe y Citrix son sólo dos de las empresas que actualmente publican manifiestos para Inventory Tool for Custom Updates (ITCU) en SMS 2003 R2 y planean hacer lo mismo, avanzando con Configuration Manager.
Este nuevo motor de actualización de software ofrece también estado de actualización en tiempo cercano al real para permitir una mejor generación de informes y vistas de página principal mejoradas. Estas vistas personalizadas pueden mostrar gráficos rápidos del estado de revisión en una infraestructura de TI o una colección de equipos específica. La figura 6 muestra lo sencillo que es visualizar datos de cumplimiento de revisiones de un boletín específico mediante una de las nuevas vistas personalizadas de la página principal para la administración de actualizaciones de software.
Figura 6 Visualización del estado de actualizaciones de software
Figura 6 Visualización del estado de actualizaciones de software (Hacer clic en la imagen para ampliarla)
Por último, las plantillas de implementación de actualizaciones de software reducen considerablemente el número de pasos necesarios para insertar nuevas actualizaciones en un sistema o una colección. Mediante las plantillas de implementación de actualizaciones de software para almacenar información común de configuración, como por ejemplo, si se debe forzar un reinicio o si el cliente debe descargar revisiones del DP de forma local antes de ejecutar la instalación, esta característica reduce el número de pasos, de 18 que se requerían con ITMU en SMS 2003 a sólo 6 en Configuration Manager 2007.

Administración de la configuración deseada
La administración de la configuración es otra magnífica característica muy mejorada en Configuration Manager 2007. SMS 2003 Desired Configuration Monitoring se lanzó al mercado en el otoño de 2006 y ofreció muchas características clave incluidas en Configuration Manager 2007 Desired Configuration Management. Para obtener más información acerca de la supervisión de configuración deseada, consulte el artículo de TechNet Magazine en microsoft.com/technet/technetmag/issues/ 2006/09/HighStandards. La figura 7 representa la página principal de Desired Configuration Management que muestra el cumplimiento para dos líneas de base de configuraciones específicas.
Figura 7 Generación de informes de cumplimiento de línea de base de la configuración deseada
Figura 7 Generación de informes de cumplimiento de línea de base de la configuración deseada (Hacer clic en la imagen para ampliarla)
El impulso clave para la administración de la configuración deseada en Configuration Manager proviene de una importante cantidad de investigaciones con clientes de Microsoft que muestra que la mayoría de las fallas de servicio son ocasionadas por errores de configuración de sistema operativo o aplicación en servidores y escritorios fundamentales. Mediante la funcionalidad de administración de la configuración deseada en Configuration Manager, los administradores pueden rápidamente captar el desplazamiento de configuración mediante la ejecución de análisis periódicos de línea de base en los sistemas. Estas líneas de base se crean mediante elementos de configuración (CI) y ofrecen información de cumplimiento para una colección de equipos en su organización.
Además de captar el desplazamiento de configuración, la administración de la configuración deseada puede ayudar con la generación de informes de cumplimiento de disposiciones legales y la comprobación de cambios. En la mayoría de las organizaciones, existen buenas posibilidades de que se necesite la generación de informes de cumplimiento de disposiciones legales tales como Sarbanes-Oxley (SOX), Payment Card Industry Data Security Standard (PCI DSS) y Health Insurance Portability and Accountability Act (HIPAA). Configuration Manager 2007 le puede ayudar ofreciéndole los informes que necesita mediante la administración de la configuración deseada.
Explicamos aquí cómo funciona la administración de la configuración deseada. Un administrador define los CI; unidades de configuración que se pueden detectar, aplicar y quitar en los equipos. Una vez que se definen estos CI, puede crear una línea de base de configuración que está compuesta de uno o más de estos CI. A continuación, estas líneas de base se asignan a colecciones de Configuration Manager para la generación de informes de supervisión de cumplimiento y disposiciones legales.
Los CI pueden analizar diferentes aspectos de un equipo para reunir información, incluidos Active Directory®, metadatos de archivo, resultados de script, datos almacenados en SQL Server™, datos de actualización de software, WMI, XML, valores de registro, metadatos IIS y presencia y configuración de Microsoft Installer. La información reunida a partir de estas ubicaciones diferentes se almacena en la base de datos de Configuration Manager y se usa para comprobar si un sistema se encuentra en conformidad.
Como un aspecto interesante, el proceso de administración de la configuración deseada y el proceso para insertar nuevas actualizaciones a través de Configuration Manager 2007 ahora están totalmente integrados. Al igual que con el nuevo motor de actualización de software, todos los datos de la administración de la configuración deseada usan el canal de alta prioridad basado en estado. La integración de estas dos características fundamentales permite que un administrador defina una nueva línea de administración de la configuración deseada o actualice una existente con nuevas actualizaciones como parte del proceso de implementación de actualizaciones.

Administración de clientes basada en Internet
¿Alguna vez tuvo un equipo desconectado de la red durante tanto tiempo que el objeto de equipo dentro de SMS quedó obsoleto? Según las conversaciones que he mantenido con mis clientes, parece que esto sucede con demasiada frecuencia. Afortunadamente, Configuration Manager 2007 incorpora la nueva administración de clientes basada en Internet. Esta característica funciona muy parecido al modo en que Microsoft Office Outlook® se comunica con Exchange Server a través de HTTPS sin una red privada virtual (VPN). Si no está familiarizado con este escenario, simplemente significa que obtiene una comunicación más segura con los equipos cliente sin la complicación de una conexión VPN.
La administración de clientes basada en Internet le permite administrar equipos en Internet con el mismo nivel de control que con equipos en la Intranet. De hecho, todas las características tratadas en este artículo funcionarán con la administración de clientes basada en Internet excepto la implementación del sistema operativo, Wake-on-LAN y herramientas remotas porque usan puertos diferentes para la comunicación y no se pueden incluir en un túnel sobre SSL ni TLS. Algunos ejemplos magníficos de situaciones donde entra en juego la administración de clientes basada en Internet son los dispositivos de punto de ventas para restaurantes, tiendas minoristas, estaciones de servicio; equipos domésticos de los empleados y viajeros de negocios, como por ejemplo, una fuerza de ventas distribuida o un equipo de consultores.
Se deben establecer algunos requisitos antes de habilitar la administración de clientes basada en Internet en la infraestructura de Configuration Manager 2007. En primer lugar, necesitará una infraestructura de claves públicas (PKI) para asignar certificados digitales a todos los agentes administrados con Configuration Manager. Esto le permite usar autenticación mutua entre los servidores de Configuration Manager y todos los agentes de administración para asegurar que los datos que recibe son cifrados y provienen de un origen de confianza. También necesitará un terminador SSL que funcione como punto de conexión entre los servidores de Configuration Manager y todos los clientes basados en Internet. Microsoft Internet Security and Acceleration (ISA) Server 2006 es una solución basada en software que cumple estos requisitos.
En la administración de clientes basada en Internet se usa la nueva función de servidor Fallback Status Point (FSP). Si cualquiera de los agentes basados en Internet dejan de comunicarse correctamente o si expira un certificado, el agente notificará el problema al punto de estado de reserva disponible en la red de perímetro de su organización. Esto garantiza que nunca se pierda el contacto con sus sistemas administrados por Internet. Además, los clientes pueden viajar automáticamente dentro y fuera de la administración basada en Internet a la basada en Intranet para usar mejor los recursos apropiados en los tiempos apropiados.

Otras nuevas características
Aunque no se considera una característica fundamental, Wake-on-LAN es muy valiosa en el arsenal de herramientas del administrador para realizar de forma rápida y silenciosa distribuciones y actualizaciones de software o implementación del sistema operativo. Configuration Manager 2007 habilita la funcionalidad Wake-on-LAN en todos los agentes administrados basados en Intranet que tienen una tarjeta de red compatible. La figura 8 muestra un ejemplo de cómo puede usar Wake-on-LAN en un anuncio en el Asistente para nuevo anuncio recién diseñado. En este caso, implemento un nuevo paquete en un grupo de equipos. Si el dispositivo compatible con Wake-on-LAN está desactivado y este valor está habilitado en el asistente, Configuration Manager iniciará el sistema para implementar el paquete que fue definido por el anuncio.
Figura 8 Wake-on-LAN en un anuncio de distribución de software
Figura 8 Wake-on-LAN en un anuncio de distribución de software (Hacer clic en la imagen para ampliarla)
El control remoto ha sido reescrito completamente en Configuration Manager para proporcionar una solución más segura y confiable con rendimiento apreciablemente más rápido. En lugar de las viejas herramientas que existen desde SMS 1.0, Configuration Manager usa ahora tecnología de colaboración nativa de Windows Vista que se basa en el Protocolo de escritorio remoto (RDP). La funcionalidad básica es la misma que en SMS 2003 en el sentido de que no hay necesidad que el usuario final acepte nuevas sesiones. Sin embargo, se incorporan tres nuevos niveles de acceso: Control total, sólo visualizar y ninguno. Además de esta nueva tecnología, Configuration Manager 2007 todavía está integrado con Asistencia Remota para las ocasiones en que se necesita esa funcionalidad.

Conclusión
Lo he guiado por varias de las nuevas características y mejoras en System Center Configuration Manager 2007. Estas características se diseñaron para ayudar a disminuir el esfuerzo administrativo, permitir nuevas cargas de trabajo y disminuir costos en su entorno de TI. Con Configuration Manager 2007, así como con los demás productos de la familia System Center, estará equipado para administrar las infraestructuras de TI más exigentes mientras ofrece a su negocio una posición de ventaja con respecto a la competencia.
Además de las características resumidas en este artículo, existen muchas más mejoras en el producto, tales como la integración con Protección de acceso a redes (NAP) de Windows Server® 2008 y mejoras en la capacidad de administración de activos de software (SAM) basadas en la misma tecnología de Inteligencia de activos incluida en SMS 2003 SP3. Lo animo a descargar la versión candidata al lanzamiento de Configuration Manager 2007 o la versión de prueba de RTM para ver estas características en funcionamiento en su infraestructura.
Para obtener más información y una introducción de todos los productos en la familia System Center visite microsoft.com/systemcenter. Desde aquí puede navegar hacia cualquier solución de la familia System Center, incluido Configuration Manager.

John Orefice es un profesional especializado en soluciones tecnológicas que trabaja para Microsoft en la zona del Atlántico central. Lleva varios años trabajando con soluciones de administración de Microsoft, primero como consultor de Servicios de consultoría de Microsoft (Microsoft Consulting Services, MCS) y ahora en su función actual. Puede ponerse en contacto con él en la dirección john.orefice@microsoft.com.
© 2008 Microsoft Corporation and CMP Media, LLC. Reservados todos los derechos; queda prohibida la reproducción parcial o total sin previa autorización.


System Center
Implemente aplicaciones y actualizaciones en sus sucursales
Steve Rachui
Resumen:
  • Configuración de un punto de distribución de una sucursal
  • Todo acerca de los límites
  • Tres métodos de aprovisionamiento de datos

Microsoft está a punto de lanzar al mercado su solución de próxima generación para la administración de sistemas. Anteriormente conocido como Systems Management Server (SMS), el nuevo System Center Configuration Manager 2007
posee un buen número de características nuevas que seguro le impresionarán. Una de estas características tan prácticas es el punto de distribución de sucursales (BDP), un nuevo tipo de punto de distribución diseñado especialmente para satisfacer las necesidades de configuración de la pequeña oficina o de la oficina distribuida. A primera vista, y en comparación con otras características nuevas, BDP puede parecer una adición bastante irrelevante, pero no subestime esta característica.
Con versiones anteriores de SMS, los servidores de sistemas eran las únicas plataformas compatibles para hospedar puntos de distribución. A raíz de esto, los administradores que necesitaban proporcionar servicios a sucursales, las cuales a menudo carecen de servidores locales y se comunican a través de conexiones WAN más lentas, se esforzaron en diseñar y crear una infraestructura que permitiese una distribución de software oportuna y eficiente. Este escenario es exactamente la necesidad para la que BDP se diseñó.
BDP, que se diseñó para funcionar tanto en estaciones de trabajo como en sistemas de servidor, es un componente que está disponible, aunque no habilitado de forma predeterminada, en cada cliente de Configuration Manager 2007. Aunque cada cliente de Configuration Manager 2007 dispone del código necesario para funcionar como un BDP, no todos los clientes deberán configurarse como tales.

Configuración de un BDP
Activar la función BDP en un cliente es básicamente lo mismo que configurar algún punto de distribución basado en servidor. Se empieza por configurar un cliente como un sistema de sitio nuevo (tal como se muestra en la figura 1) y, a continuación, se indica que es un punto de distribución de sucursal (tal como se muestra en la figura 2). Esta configuración hace que BDP se incluya en una lista como un punto de distribución disponible para paquetes, actualizaciones de software, imágenes Operating System Deployment (OSD), etcétera. El servidor del sitio preparará la directiva y ésta se dirigirá al cliente seleccionado, el cual activará la función BDP. Una vez que se haya descargado la directiva, el cliente empezará a actuar como un BDP.
Figura 1 Configuración del cliente como un sistema de sitio nuevo
Figura 1 Configuración del cliente como un sistema de sitio nuevo
Figura 2 Configuración del sistema de sitio como un punto de distribución de sucursal
Figura 2 Configuración del sistema de sitio como un punto de distribución de sucursal
Un BDP, o cualquier sistema de sitio, puede configurarse para atender un límite específico (originariamente conocidos como límites del sitio en SMS 2003) o un grupo de límites, o bien puede configurarse para funcionar sin tratarse de un límite específico. Los límites en Configuración Manager 2007 se definen generalmente mediante una subred IP o un sitio de Active Directory ®.
Para configurar un BDP que atienda a un conjunto de límites específico, seleccione la opción "Enable this site system as a protected site system" en la ventana de configuración del sistema del sitio y, a continuación, especifique los límites que deben atenderse, tal como se muestra en la figura 1. Tenga en cuenta que se trata de un paso obligatorio si planea usar el BDP para el aprovisionamiento de contenido a petición (lo cual describiré dentro de un momento). Si se omite este paso, el BDP funcionará esencialmente como cualquier punto de distribución estándar.

Acerca de los límites
Los límites protegidos en un BDP sólo sirven para definir qué clientes pueden tener acceso a su contenido; no desempeñan ningún papel fundamental a la hora de determinar a qué punto de distribución estándar puede tener acceso un BDP para descargar el contenido que necesita. Suponga, por ejemplo, que hay un entorno con un BDP instalado en el Límite A. Ahora suponga que el Límite B contiene el único punto de distribución estándar que usa el Servicio de transferencia inteligente en segundo plano (BITS) y este punto de distribución se configura para servir sólo a los clientes en el Límite B. Cuando el BDP intente descargar contenido, ¿se realizará correctamente? Según las reglas previstas de los límites protegidos, podría creerse que no. Sin embargo, en este escenario, la descarga se realizaría correctamente, ya que las descargas de BDP no respetan ningún límite protegido que se haya configurado en puntos de distribución estándar.
Los BDP ofrecen también mucha flexibilidad. Se puede activar un único BDP por ubicación de sucursal o, si fuera necesario, se pueden activar varios BDP en una única sucursal (límite). Cuando se configuran varios BDP para atender los mismos límites, funcionan en conjunto como una especie de equilibrio de carga para ofrecer el contenido a los clientes dentro de esos límites.

Datos de aprovisionamiento
Una vez habilitado, un BDP puede obtener el contenido que necesita de tres maneras diferentes: aprovisionado por el administrador, aprovisionado a petición y aprovisionado manualmente. Independientemente del método que se use para obtener el contenido, por lo menos debe de haber un punto de distribución estándar con BITS habilitado disponible y aprovisionado con el contenido que recibirá el BDP. Echemos una ojeada a los tres métodos que pueden usarse para obtener el contenido.
Aprovisionado por el administrador Se trata del método conocido de almacenamiento de contenido en un punto de distribución. Con este método se requiere que un administrador seleccione manualmente el BDP como punto de distribución. Al hacerlo, se originará una directiva que alertará al BDP para que descargue el contenido que se está aprovisionando desde un punto de distribución estándar habilitado con BITS dentro del mismo sitio durante el ciclo siguiente de actualización de directivas.
Aprovisionado a petición Se trata de un método nuevo para almacenar contenido y es específico del BDP. Este método permite que el contenido se descargue a petición en el BDP cuando un cliente lo solicite. El administrador no emprende ninguna acción para aprovisionar el contenido en el BDP, lo que significa que el BDP no se ha seleccionado como punto de distribución dentro del nodo de paquetes. El aprovisionamiento a petición hará que el BDP se seleccione como punto de distribución cuando se realice la solicitud del contenido. Esto sucede en segundo plano y es automático.
El aprovisionamiento a petición sólo puede tener lugar si el paquete está configurado para ser compatible con esta opción (consulte la figura 3) y el BDP está protegido con el fin de garantizar que los clientes que soliciten el contenido sólo puedan tener acceso al BDP y no puedan tener acceso a ningún punto de distribución estándar que tenga ese contenido. Tenga en cuenta que si se configuran varios BDP dentro de los mismos límites protegidos, una solicitud de aprovisionamiento a petición a uno de ellos tendrá como resultado que el se aprovisione a todos.
Figura 3 Habilitación de la distribución a petición de un paquete
Figura 3 Habilitación de la distribución a petición de un paquete
Aprovisionamiento manual Como su nombre implica, este método de almacenar el contenido requiere la acción manual del administrador. El paquete debe configurarse de tal manera que indique que el contenido se transferirá manualmente, tal como se muestra en la figura 3. El contenido entonces debe copiarse manualmente al BDP en la carpeta de paquetes mediante una estructura de directorios que es la que se esperaría en un paquete normal.
El BDP reconocerá el paquete nuevo y lo pondrá a disposición de los clientes que lo soliciten. Dado que este método permite que el contenido se transfiera al BDP mediante medios extraíbles, es ideal para entornos con un ancho de banda limitado entre el punto de distribución estándar y el BDP.
Puede configurar un BDP para que almacene el contenido descargado en una partición en particular; si no se especifica ninguna partición, el BDP elegirá automáticamente la partición que usará. Cuando se configura el contenido para que se almacene en un BDP, o cuando se procesa una solicitud a petición, el contenido de destino no estará inmediatamente disponible en el BDP. Más bien, se prepara una directiva para que genere una alerta con el fin de avisar al BDP de que el contenido está listo para la descarga. En el ciclo de directivas siguiente, el BDP recibirá la directiva e iniciará una descarga BITS del contenido. Se puede usar una directiva de grupo para controlar con mayor precisión el ancho de banda que se usa, así como la programación para descargas por BITS. Tenga en cuenta que el recurso compartido del punto de distribución en el BDP aparece sólo como el recurso compartido de un punto de distribución estándar, lo que significa que el contenido no está cifrado.

Configuración correcta para su organización
Como ya se comentó, la función BDP se creó para las sucursales y su funcionalidad es completa en sistemas de estaciones de trabajo. Sin embargo, un BDP también puede funcionar en un sistema de servidores. El sistema operativo subyacente influirá en el número de conexiones que puedan establecerse para el BDP. Las estaciones de trabajo tienen un límite de 10 conexiones simultáneas, mientras que los servidores no tienen ese límite. Así pues, según el número de conexiones simultáneas que se debe admitir, es posible que desee usar un sistema de servidores o quizás varias estaciones de trabajo dentro de la sucursal. Independientemente de la plataforma que use, aún así debe de existir al menos un punto de distribución estándar habilitado con BITS con el contenido que se solicita.
Aunque su infraestructura esté configurada, el BDP proporcionará mucho más control sobre el flujo de la distribución de software a través de cualquier organización. La compatibilidad integrada para BITS, que permite limitar y programar las descargas, ofrece una ventaja clave para aquellos administradores que necesitan más control y capacidad de previsión granulares.

Steve Rachui es ingeniero de escala de soporte técnico para la capacidad de administración del grupo de servicios de soporte técnico de productos de Microsoft. Ha proporcionado soporte técnico para SMS desde la versión 1.2. Puede ponerse en contacto con Steve en la dirección steverac@microsoft.com.


System Center
Introducción a System Center Essentials 2007
David Mills
Resumen:
  • Instalación y actualización
  • Configuración de Essentials 2007
  • Pasos para la solución de problemas

System Center Essentials 2007 es una nueva solución de administración de TI diseñada específicamente para empresas medianas con 50 a 500 PCs y 5 a 30 servidores. Essentials 2007 surgió en respuesta a extensas sugerencias y comentarios de profesionales de TI respecto de sus necesidades específicas de una solución
de administración unificada. Essentials 2007 resuelve esas necesidades y le permite rápidamente conseguir el funcionamiento con una única instalación y configuración sencilla.
Más específicamente, Essentials 2007 proporciona funciones de supervisión, solución de problemas y seguimiento de activos para ayudar a mantener su entorno de TI seguro y actualizado. Essentials 2007 ofrece también una consola de administración unificada, donde administra servidores, clientes, hardware, software y servicios de TI (consulte la figura 1). Además, Essentials puede hacer que las tareas complejas de administración, tal como la solución de problemas de usuarios finales, la supervisión y la implementación de software de servidores y clientes, sean más sencillas y eficientes.
Figura 1 Consola de administración de Essentials 2007
Figura 1 Consola de administración de Essentials 2007 (Hacer clic en la imagen para ampliarla)

Requisitos de Essentials 2007
Antes de iniciar la instalación y configuración de Essentials 2007, compruebe que sus sistemas cumplen los requisitos mínimos de software y hardware. Su sistema operativo de servidor debe ser Windows Server® 2003 SP1 o R2 o Windows® Small Business Server 2003 SP1 o una versión posterior. También necesitará Active Directory®, IIS 6.0, Microsoft® .NET Framework 2.0 y 3.0 o posterior y SQL Server™ 2005 SP1. El propio servidor requiere por lo menos 1 GB de RAM, 12 GB de espacio en disco libre y un procesador de 1.8 GHz. Se recomienda un equipo con 2 GB de RAM, 20 GB de espacio en disco libre y un procesador de 2.8 GHz o más rápido.
Los equipos cliente administrados deben estar ejecutando Windows 2000 Professional SP4, Windows XP SP2 o Windows Vista®. Tanto los sistemas operativos x86 como x64 son compatibles.
Los equipos para servidor administrados deben estar ejecutando Windows 2000 Professional SP4 o un sistema operativo más reciente. Tanto los sistemas operativos x86 como x64 son compatibles. Dado que muchos probablemente desearán supervisar y administrar su entorno de TI desde su propio escritorio o equipo portátil, será necesario ejecutar en su equipo la instalación de Essentials 2007 sólo para consola. Antes de iniciar, asegúrese de que se encuentra en ejecución Windows XP SP2, Windows Vista o Windows Server 2003 SP1.
Además, cuando planee la configuración del servidor Essentials 2007, permita suficiente espacio en disco para controlar las descargas de las actualizaciones y la base de datos de generación de informes. Para actualizaciones, la base de datos de actualizaciones puede crecer más allá de 2 GB y su contenido de actualizaciones puede crecer más allá de 6 GB. Las bases de datos operativas y de generación de informes de Essentials pueden crecer hasta 4 GB. Realice el planeamiento en consecuencia para que no se quede sin espacio de almacenamiento.

Instalación de Essentials 2007
La configuración de Essentials 2007 es sencilla debido al uso eficaz de asistentes que rápidamente lo guían a través de las tareas críticas, tales como la instalación y configuración, la detección de equipos y la configuración de actualización. Cuando se ejecuta el asistente para la instalación, Essentials 2007 automáticamente comprueba estos requisitos previos y comunica si algo falta (consulte la figura 2).
Figura 2 Comprobación de los requisitos previos de instalación
Figura 2 Comprobación de los requisitos previos de instalación (Hacer clic en la imagen para ampliarla)
Si un elemento requerido no se encuentra en el disco de Essentials 2007, hay un vínculo de la pantalla de instalación al software faltante para que pueda realizar la instalación. Cuando se desplaza por el asistente para la instalación, deberá escribir una ruta para la ubicación de instalación de Essentials 2007 y la información de una cuenta con privilegios administrativos. La administración de equipos con Essentials 2007 puede ser una tarea mucho más sencilla si esta cuenta tiene derechos de administrador en el servidor de administración y todos los equipos administrados. Essentials admite el uso de una única cuenta para realizar tareas tales como la instalación de agentes en equipos administrados.
Si SQL Server 2005 no se encuentra actualmente instalado y disponible para usar con Essentials 2007, ya sea de forma local o remota, tiene la opción de hacer que Essentials 2007 instale SQL Server 2005 Express with Advanced Services de forma local durante la instalación. Esta versión de SQL Server se incluye en el disco de Essentials 2007. También puede comprar una versión de Essentials 2007 con SQL Server 2005 Standard que se licencia específicamente para su uso con Essentials 2007.
La única decisión importante que debe realizar durante la instalación es dónde desea que Essentials 2007 almacene sus actualizaciones. Puede almacenar las actualizaciones de forma local y se entregarán a los equipos administrados a través de la red desde su servidor Essentials 2007. Probablemente ésta es la mejor elección, especialmente si el acceso a Internet tiende a ser un cuello de botella en su red. Las actualizaciones también se pueden descargar directamente de Microsoft Update cada vez que un equipo necesite actualizarse. Seleccionar esta opción significa que una actualización para 50 equipos se descarga 50 veces, una vez para cada equipo. Esto puede ser voluminoso, pero la ventaja es que usa menos espacio en disco en su servidor de administración.
La topología de implementación de línea de base compatible con Essentials 2007 es instalar todos los componentes de administración en un único servidor (consulte la figura 3). Sin embargo, también tiene la opción de instalar la consola de administración de Essentials 2007 en el equipo de escritorio o portátil en su oficina y controlar de forma remota el servidor de administración. Antes de instalar la consola remota, debe ejecutar el asistente para configuración de características en el servidor Essentials 2007. Este proceso establece si se usa la directiva de grupo de dominio o la directiva de grupo local para configurar la consola remota. Si selecciona la directiva de grupo de dominio, asegúrese de que transcurra el tiempo suficiente para actualizar el equipo en que instala la consola remota. Puede instalar múltiples consolas remotas si fuera necesario.
Figura 3 Configuración de línea de base de Essentials 2007
Figura 3 Configuración de línea de base de Essentials 2007
Si administra un entorno de TI con más de 200 equipos, deberá instalar SQL Server 2005 en un servidor remoto (no en Essentials 2007 Management Server) y usar esta copia remota como su base de datos de Essentials 2007 (consulte la figura 4). Obtendrá un aumento de rendimiento a medida que trabaje a mayor escala. Sólo recuerde que este servidor remoto debe estar en el mismo dominio que Essentials 2007 Management Server.
Figura 4 Uso de una base de datos SQL Server remota
Figura 4 Uso de una base de datos SQL Server remota
Si elige usar una copia de la base de datos SQL existente durante la instalación de Essentials 2007, se debe asegurar que SQL Server 2005 SP1 Reporting Services se encuentra instalado y configurado en Essentials 2007 Management Server.

Actualización a Essentials 2007
Es probable que ya ejecute Windows Server Update Services (WSUS) 2.0 ó 3.0 para administrar sus actualizaciones de Microsoft. Si ese es el caso y desea actualizar a Essentials 2007 para obtener una solución de administración más completa, Essentials le permite actualizar durante el proceso de configuración. Esta actualización local conserva la información de actualización existente incluidos los archivos binarios, grupos y aprobaciones.
Si usa Microsoft Operations Manager (MOM) 2005 o MOM 2005 Workgroup Edition para supervisar servidores críticos, pero desea las características agregadas de Essentials 2007 para inventario de activos, distribución de software y actualizaciones, puede migrar fácilmente sus paquetes de administración si los exporta, convierte y, a continuación, los importa directamente en Essentials 2007. Al igual que MOM 2005, Essentials 2007 usa paquetes de administración para supervisar equipos y dispositivos. Los paquetes de administración también contienen la información que necesita para diagnosticar y resolver problemas de TI correctamente. Si no desea migrar completamente a Essentials 2007, puede mantener la operación en paralelo para conservar la supervisión fundamental y migrar cuando le resulte más cómodo.
Esté prevenido de que alguna configuración de WSUS no se conserva durante la actualización a Essentials 2007. Perderá información acerca de equipos, aprobaciones y configuración automáticas y cualquier aprobación existente para los grupos denominados Todos los clientes o Todos los servidores. Por lo tanto, elimine de WSUS los grupos Todos los clientes y Todos los servidores antes de realizar la actualización. A continuación, deberá volver a crear estas aprobaciones después de completar la instalación de Essentials 2007.
Tenga en cuenta que no puede realizar esta actualización de WSUS si el servidor existente tiene servidores activos que siguen en la cadena. Essentials 2007 no es compatible con el modo de servidor que precede en la cadena (USS) de WSUS. Debido a que no se puede detectar con seguridad, si el servidor WSUS tiene servidores que siguen en la cadena recibirá una advertencia. Además, no continúe con una actualización si usa WSUS 2.0 ó 2.0 SP1 con un servidor de base de datos remoto que no ejecute SQL Server 2005 SP1 para almacenar los datos de WSUS.
Durante el proceso de actualización se crea automáticamente una copia de seguridad de la base de datos. Si la actualización no se realiza correctamente, puede restaurar el entorno anterior mediante la copia de seguridad. Asegúrese de disponer de espacio suficiente para realizar copias de seguridad de la base de datos actual de WSUS. Para ello, compruebe el tamaño del archivo de base de datos automáticamente y confirme que existe espacio suficiente para realizar una copia.

Configuración de Essentials 2007
Essentials 2007 ofrece muchos asistentes que ayudan con las tareas de configuración y administración. El asistente para configuración de características lo conduce para recorrer rápidamente algunos pasos de configuración que serían difíciles si tuviera que realizarlos manualmente, tales como la configuración de la directiva de grupo. La figura 5 muestra la primera página del asistente.
Figura 5 Inicio del asistente para configuración de características
Figura 5 Inicio del asistente para configuración de características (Hacer clic en la imagen para ampliarla)
Si desea usar un servidor proxy al conectarse a Internet, uno de los primeros pasos es escribir el nombre de servidor y número de puerto. A continuación, puede elegir un tipo de directiva de grupo para configurar equipos administrados; sea una directiva de grupo local o de dominio. También puede crear una excepción de Firewall de Windows si elige usar la directiva de grupo de dominio para configurar equipos administrados.
Lo que sigue es el paso opcional de la habilitación de asistencia remota de equipos. Se aplica si ha elegido usar la directiva de grupo de dominio para configurar los clientes. Tenga en cuenta que se crea una excepción de firewall en todos los equipos administrados para permitir DCOM sobre el puerto TCP 135.
Tiene la opción de recopilar una supervisión de errores sin agente de los equipos administrados. Si selecciona Sí y elige una ubicación para almacenar los errores, entonces los equipos administrados enviarán informes de errores al servidor Essentials 2007 y podrá consultar los informes para ver cuáles aplicaciones tienen problemas.
Hay opciones que especifican si el informe de errores se debe enviar a Microsoft, y si se debe configurar y enviar un informe de estado diario, que contiene información acerca de alertas, actualizaciones, software e inventario. Si configura el informe de estado diario para que se envíe por correo electrónico, puede determinar rápidamente lo que sucede en su entorno de TI cuando comienza su día laborable.
Por último, puede elegir establecer la detección diaria programada de nuevos equipos. Recomiendo seleccionar esta opción porque le indica a Essentials 2007 que ejecute una detección diaria de Active Directory en búsqueda de nuevos equipos y los configura para que se administren automáticamente.
La ejecución del asistente para administración de equipos y dispositivos configurado para detección automática de equipos solicita al servidor Essentials 2007 que consulte a Active Directory y detecte todos los equipos enumerados en el dominio que se administra (consulte la figura 6). Si selecciona la opción de detección avanzada, puede filtrar dispositivos detectados por tipos, tales como sólo clientes o dispositivos de red, realizar una búsqueda dentro de un intervalo de direcciones IP o crear consultas avanzadas. Recomiendo seleccionar y ejecutar primero la detección automática de equipos antes que detectar todos los clientes y servidores. Dado que Essentials 2007 también supervisa dispositivos de red con SNMP habilitado (Protocolo simple de administración de red), puede ejecutar nuevamente el asistente en modo avanzado y detectar dispositivos de red.
Figura 6 Inicio del asistente para administración de equipos y dispositivos
Figura 6 Inicio del asistente para administración de equipos y dispositivos (Hacer clic en la imagen para ampliarla)
Si su red está compuesta de más de aproximadamente 300 equipos, probablemente deba elegir Detección avanzada y ofrecer criterios más específicos para localizar sus equipos. Al especificar una cuenta de administrador, asegúrese de que la cuenta tiene privilegios administrativos en los equipos que desea detectar y en los que desea instalar agentes. Una vez que se completa la detección, puede elegir los equipos que desea administrar y hacer clic en Finalizar.
Si usó WSUS, algunas de las configuraciones en el asistente para configuración de administración de actualizaciones le resultarán familiares. Si se necesita un servidor proxy cuando su servidor se conecta a Internet, escriba la configuración de servidor proxy. Seleccione los productos para los que desea descargar e implementar actualizaciones, seleccione los idiomas en que necesita actualizaciones (el idioma del servidor es el predeterminado). Seleccione las categorías de actualizaciones que desea descargar e implementar (las actualizaciones críticas, las actualizaciones de seguridad y los Service Pack son los valores predeterminados). Seleccione cuáles, si existen, categorías de actualizaciones desea aprobar automáticamente y en qué grupos. (La opción de actualizaciones críticas y de seguridad para el grupo Todos los equipos es el valor predeterminado.) Por último, establezca la programación para sincronizar actualizaciones (diaria es el valor predeterminado).
Si puede iniciar sesión con credenciales de administrador de dominio o administrador de directiva de grupo cuando configura Essentials 2007, debe seleccionar la directiva de grupo de dominio para configurar los equipos administrados; esto facilita mucho la configuración. Si selecciona la directiva de grupo de dominio, puede automatizar la configuración de Firewall de Windows y de la asistencia remota en todos los equipos administrados. Esta opción le indica a Essentials 2007 que debe crear la configuración de directiva en nombre del usuario. Si selecciona la directiva local, deberá establecer bastantes valores de configuración manuales.

Solución de problemas de Essentials
Hay varios aspectos que se deben tener en cuenta a la hora de realizar tareas de solución problemas con la detección de equipos, la implementación de agentes y las comunicaciones. En primer lugar, se presenta aquí una vista rápida de cómo funciona el proceso de detección de equipos. Essentials 2007 toma los parámetros de entrada de la búsqueda y crea una consulta LDAP (Protocolo ligero de acceso a directorios; LDAP es el lenguaje de consulta que se usa para buscar objetos en Active Directory). La consulta LDAP se pasa al controlador de dominio local y se envía una tarea de búsqueda, y Active Directory devuelve los resultados al servidor de administración. A continuación, el servidor de administración intenta conectarse a cada equipo devuelto en la lista para garantizar que se puede comunicar con estos equipos detectados a fin de que se puedan instalar los agentes de administración. Una vez que se comprueba un equipo, éste se agrega a la lista de equipos detectados para administrar.
Sin embargo, tenga en cuenta que es posible que el servidor Essentials 2007 no pueda detectar equipos si hay problemas con Active Directory, la red y DNS o la comprobación.
Abra la consola de administración de usuarios y equipos de Active Directory para ver si el equipo se incluye en la lista. Esta herramienta se instala de forma predeterminada en Windows Server 2003 y se puede instalar en Windows XP Professional a partir del paquete de administración de Windows Server 2003. Seleccione la carpeta Consultas guardadas, haga clic con el botón secundario en ella, seleccione Nueva y haga clic en Consulta. Escriba un nombre para la consulta y haga clic en el botón Definir consulta. Haga clic en la lista desplegable marcada Buscar y seleccione Equipos. Escriba el nombre o prefijo de la búsqueda y haga clic en Aceptar unas pocas veces para generar la consulta.
Ahora compruebe que el equipo aparece en la lista de resultados. En caso contrario, agregue el equipo a Active Directory. Asegúrese que la propiedad DNSHostname se estableció correctamente para el equipo; esta propiedad se encuentra en la ficha General del cuadro diálogo de propiedades del equipo en la consola de administración de usuarios y equipos de Active Directory.
Si necesita consultar un equipo a través de la red, use el comando ping para intentar alcanzar el equipo usando el mismo nombre ofrecido por el asistente para detección. Si el equipo responde a un comando ping, ejecute ping con el modificador -a y la dirección IP:
ping -a <IP address>
El siguiente comando mostrará el DNS del equipo; debe coincidir con el que se usa en el comando ping original. Use este comando para ver el nombre NetBIOS y el dominio registrados para el equipo:
nbtstat -a <computer name>
Esto realizará la misma tarea con la dirección IP del equipo.
nbtstat -A <IP address>
El modificador del comando, –a, distingue mayúsculas de minúsculas. Tenga en cuenta que usa –A al usar la dirección IP. Si el equipo no responde a una solicitud de ping o se produce un error en una instalación remota de agente con el mensaje "Servicio RPC no disponible", significa que Firewall de Windows está activado. En caso de que haya un firewall habilitado en el entorno de implementación de Essentials 2007, se deben crear excepciones para que Essentials 2007 Management Server pueda instalar correctamente los agentes en los equipos administrados y para que éstos se puedan comunicar con el servidor de administración. (Cuando se usa un equipo administrado, no es necesario crear ninguna excepción de firewall de forma manual si se usa una directiva de grupo de dominio en lugar de una directiva de grupo local).
Si se producen errores en la instalación del agente, navegue al espacio de administración (la pieza dorada en la esquina inferior izquierda de la consola de administración de Essentials 2007 junto al botón de navegación Generación de informes) y haga clic en Administración pendiente. Esta vista ofrecerá pasos de solución de problemas, así como la capacidad de reenviar el agente a equipos en que se produjeron errores en el primer intento de instalación.
Asegúrese de permitir varias horas para que la directiva de firewall se aplique a todos los equipos que se deben administrar. Si intenta ejecutar el asistente para configuración de características y selecciona la directiva de grupo de dominio y el asistente para administración de equipos y dispositivos, todo en una sucesión rápida, es posible que la directiva de firewall no haya tenido oportunidad de aplicarse en los equipos detectados y esto provocará errores en la detección si el firewall todavía está habilitado.
Una manera de ver si un agente se puede insertar correctamente en un equipo es intentar ejecutar un comando Telnet a ese equipo desde el servidor de administración. Si puede realizar un comando Telnet mediante el puerto 135 del servidor de administración al equipo, estará listo para continuar. De lo contrario, es posible que el firewall en ese equipo está bloqueando el puerto TCP 135. Para ejecutar Telnet, abra una ventana de comandos y escriba:
telnet <computer_name> 135
Esto lo conectará al nombre de equipo que especifica con Telnet mediante el puerto 135. El puerto 135 es importante porque es el puerto que usa cuando instala el agente de forma remota.
Si esto no funciona, asegúrese de que se han creado las excepciones apropiadas en Firewall de Windows para permitir la implementación del agente y la comunicación con el servidor de administración. Si no, necesita crear las excepciones de puerto que se muestran en la figura 7. En todas estas excepciones, limite el ámbito a la dirección IP de Essentials 2007 Management Server por medio de la opción Lista personalizada.
Figure 7 Excepciones de puertos

Protocolo | Nombre | Puerto
TCP | Puerto 6270 | 6270
TCP | Puerto 135 | 135
TCP | Puerto 445 | 445
Si sus equipos usan software de firewall de terceros, debe consultar la documentación de ese producto para crear las excepciones. Sin embargo, todavía se aplican las excepciones de puerto que se enumeran en la figura 7.
Si el nombre NetBIOS y el nombre de dominio completo no coinciden, entonces se deben corregir los registros DNS para el equipo. Si el agente se instala pero no logra comunicarse con el servidor de administración, conéctese al equipo del agente mediante Terminal Services o Escritorio remoto y use los comandos ping y nbtstat para comprobar que el agente puede resolver los nombres NetBIOS y FQDN del servidor de administración.
Si la dirección IP de Essentials 2007 Management Server se asigna dinámicamente, debe actualizar las directivas de firewall en los equipos administrados cuando cambie la dirección IP. Para actualizar las excepciones de firewall para una nueva dirección IP del servidor de administración, habilite los dos valores de configuración de directiva siguientes en el Editor de objetos de directiva de grupo, y configúrelos tal como se describe aquí. Para "Firewall de Windows permitir excepción de administración remota" establezca la opción "Permitir mensajes entrantes no solicitados de:" a la nueva dirección IP del servidor de administración. Para "Firewall de Windows permitir la excepción compartir impresoras y archivos", establezca la opción "Permitir mensajes entrantes no solicitados de:" a la nueva dirección IP del servidor de administración.

Resumen
Espero que encuentre útil la información en este artículo para comenzar a usar System Center Essentials 2007. Para obtener más información acerca de este nuevo producto de System Center, vaya a la dirección microsoft.com/sce.
Sólo recuerde que no hay sustituto para un planeamiento cuidadoso antes de la implementación. En este caso, implementará una solución completamente nueva para administrar su entorno de TI, así que necesita tomarse algún tiempo para pensar la configuración actual de su red, la manera en que trabajan sus usuarios y cómo desea administrar sus recursos de TI. Tener primero en cuenta estos factores le ayudará a configurar correctamente Essentials 2007 para satisfacer sus necesidades.

David Mills ha trabajado con Microsoft durante siete años y es director técnico sénior de producto de System Center Essentials 2007. Antes de unirse al equipo de marketing de System Center, David condujo equipos de asistencia al usuario en la división de Windows Server suministrando documentación técnica profesional de TI para las principales tecnologías de redes y administración.


System Center
Cuide sus servidores con Operations Manager 2007
Pete Zerger
Resumen:
  • Nuevas características en Operations Manager 2007
  • Uso de la consola de operaciones
  • La función de las funciones
  • Eficaz generación de informes

System Center Operations Manager 2007 ofrece un gran paso en la plataforma de administración de operaciones de Microsoft. Operations Manager 2007 representa un cambio de paradigma estratégico, al pasar de una supervisión centrada en equipos a una plataforma de supervisión
orientada a servicios. Aunque el nuevo modelo tiene cierta semejanza con su antecesor como solución de supervisión basada en agentes y traspasa conceptos familiares para cualquier administrador de Microsoft® Operations Manager (MOM) 2005, incluye muchos cambios. Como verá, existen nuevas e interesantes características, nuevas interfaces de administración y muchos recursos adicionales para aprender más acerca de esta última adición a la Familia Microsoft System Center.

Interfaces de administración
En ningún lugar los cambios son más aparentes que en las nuevas interfaces de administración. Desaparecieron las consolas separadas de operaciones y administrador, y en su lugar se encuentra una consola de operaciones consolidada que proporciona funciones administrativas, de creación, operativas y de generación de informes (consulte la figura 1). También desapareció el único y con frecuencia confuso árbol de carpetas de la consola de administrador de MOM 2005. Ocupa su lugar una interfaz que se parece mucho más a Outlook® y que expone cinco áreas de trabajo específicas por función: supervisión, creación, generación de informes, administración y mi área de trabajo.
Figura 1 Consola de operaciones
Figura 1 Consola de operaciones (Hacer clic en la imagen para ampliarla)
El área de trabajo de supervisión expone vistas de alertas, estados, rendimiento y diagramas de la infraestructura de la red en una interfaz limpia, similar a la que vería en la consola de operador en MOM 2005.
El área de trabajo de creación es donde configura nuevas reglas y crea los grupos en que funcionarán las reglas y los monitores. Una interfaz de generación de informes totalmente mejorada se integra en la consola de operaciones y elimina la necesidad de visitar un sitio web independiente para la generación de informes. Se incluye también una interfaz para la ejecución de tareas administrativas, tales como la detección de equipos y dispositivos de red y la configuración de valores de seguridad y notificación. Por último, la sección Mi área de trabajo permite a los usuarios crear vistas personalizadas, guardar las vistas y búsquedas más usadas y configurar suscripciones de notificación de alertas personalizadas.
La consola de operaciones se carga con ayuda contextual, que incluye vínculos a documentación del producto, webcasts en línea y orientación conceptual. La consola de operaciones también incluye funciones enriquecidas de búsqueda, que permiten a los usuarios definir criterios avanzados de búsqueda para cualquier tipo de objeto y devuelven resultados según las características del tipo y valor del objeto definidas en la búsqueda.
El panel de acciones en la consola de operaciones ofrece un sinfín de tareas contextuales que proporcionan información sobre la configuración y el estado de objetos, y permite iniciar el nuevo explorador de mantenimiento para el objeto de destino (consulte la figura 2). En el explorador de estado, la estructura de árbol que representa el mantenimiento de los objetos supervisados de una entidad determinada (objeto supervisado) es jerárquica. En cada entidad se supervisa por lo menos cuatro parámetros: Disponibilidad, configuración, rendimiento y seguridad. Estos valores se organizan hacia arriba en cascada; el estado de cada uno de estos parámetros se calcula en función del estado de los monitores que residen debajo de éstos en la jerarquía.
Figura 2 Explorador de estado
Figura 2 Explorador de estado (Hacer clic en la imagen para ampliarla)
El explorador de estado diagnostica errores en los objetos supervisados y le ofrece la capacidad de actuar sobre las condiciones de error haciendo clic en hipervínculos dentro del detalle de evento. También permite ejecutar a petición cualquier tarea de diagnóstico o recuperación que aparece en el panel de detalles del explorador de estado (tal como se muestra en la figura 3) o configurar la tarea para que se ejecute automáticamente cuando se genera una alerta. Los resultados de cualquier tarea de diagnóstico (tal como la recuperación de una lista de procesos en ejecución) se mostrarán automáticamente en el panel de detalles cuando el evento de cambio de estado se muestra resaltado.
Figura 3 Diagnósticos y recuperaciones
Figura 3 Diagnósticos y recuperaciones (Hacer clic en la imagen para ampliarla)

Consola web
Las capacidades de administración web de Operations Manager se amplían apreciablemente en esta versión. La consola web expone la funcionalidad de las áreas de supervisión y Mi área de trabajo de la consola de operaciones mediante Internet Explorer®, ofreciendo las mismas vistas disponibles en la consola de operaciones, incluido un panel de acciones completamente funcional para la ejecución de tareas contextuales, junto con la capacidad de poner en modo de mantenimiento los objetos supervisados (consulte la figura 4).
Figura 4 Consola web
Figura 4 Consola web (Hacer clic en la imagen para ampliarla)
Se incluye también una consola web móvil que permite el acceso desde cualquier dispositivo móvil con capacidad web. La consola web también ofrece un suministro RSS que proporciona alertas a la bandeja de entrada de Outlook 2007 o al agregador RSS de su elección.

Shell de comandos
El shell de comandos de Operations Manager es una interfaz eficaz que permite un control administrativo completo desde la línea de comandos. Muchas tareas complejas se pueden iniciar con una sola línea de código (conocida como frase de una línea). El shell de comandos es una instancia especialmente configurada de Windows PowerShell™, el entorno de línea de comandos orientado a objetos basado en Microsoft .NET Framework. Le ofrece acceso a una gran variedad de funciones, denominadas cmdlets, que pueden ejecutar cualquier tarea disponible en la GUI de la consola de operaciones, y muchas otras más. Estos cmdlets permiten ejecutar una tarea de forma rápida y sencilla con múltiples objetos de destino (como por ejemplo poner un gran número de agentes en modo de mantenimiento) lo que demandaría mucho más tiempo si se realizara mediante la consola de operaciones. Por ejemplo, para exportar a una página web una lista de todas las alertas críticas abiertas, en la ventana del shell de comandos de Operations Manager, ejecute:
get-alert | where {$_.Severity -gt "Warning" -and $_.ResolutionState -eq 0 } | format-table
monitoringobjectdisplayname,name,severity,
description
La naturaleza orientada a objetos de Windows PowerShell es lo que hace que el shell de comandos sea tan eficaz. El poder de las bibliotecas de clases .NET de Operations Manager se obtiene sin necesidad de conocer C# o Visual Basic® .NET.

Detección de equipos y dispositivos
La detección de equipos e implementación de agentes también ha evolucionado en Operations Manager. Puede detectar los agentes por medio del asistente para administración de equipos y dispositivos desde la consola de operaciones, lo que permite a los administradores buscar en Active Directory® o especificar manualmente un equipo o lista de equipos de destino (consulte la figura 5). Las consultas LDAP (Protocolo ligero de acceso a directorios) permiten elegir de modo más específico equipos determinados para la implementación de agentes.
Figura 5 Detección avanzada mediante consultas de Active Directory
Figura 5 Detección avanzada mediante consultas de Active Directory (Hacer clic en la imagen para ampliarla)
El asistente permite detectar dispositivos con Protocolo simple de administración de red (SNMP) habilitado, que pueden ser destinatarios de supervisión en las reglas del módulo de administración.
La integración con Active Directory es otra mejora considerable. Permite que los administradores registren información de grupos de administración en Active Directory (mediante una utilidad sencilla) para que los agentes de Operations Manager puedan localizar el servidor de administración apropiado realizando una consulta de Active Directory durante el inicio. La nueva integración también permite a los administradores automatizar y simplificar la implementación de agentes al incluir un agente de Operations Manager en una imagen de equipo, implementar agentes mediante plataformas populares de administración de sistemas (tales como Systems Management Server 2003 o System Center Configuration Manager) o a través de una directiva de grupo.

Seguridad
Operations Manager 2007 se puede usar para supervisar muchos tipos de aplicaciones y quizá algunas se deban restringir a cierto personal de soporte técnico. Afortunadamente, el nuevo modelo de seguridad basado en funciones tiene cinco perfiles de usuario predeterminados que se basan en funciones de trabajo comunes para agrupar el acceso, desde operadores de sólo lectura a administradores. Cada una de las funciones de usuario predeterminadas se basa en alguno de estos perfiles predeterminados. Las funciones de usuario definen qué tipos de operaciones puede realizar un usuario y el ámbito de estos derechos. También puede crear funciones personalizadas si selecciona uno de éstos perfiles predeterminados y establece el ámbito de la función para restringir la visibilidad de datos de supervisión al subconjunto deseado de objetos, tareas y vistas supervisados. Tanto las funciones de usuario estándar como personalizadas basadas en estos perfiles de usuario se pueden asignar a grupos de seguridad de Active Directory, para volver a colocar las tareas de aprovisionamiento de usuarios en manos del personal de administración de seguridad.
La ejecución "Ejecutar como", también nueva en Operations Manager 2007, ofrece una infraestructura segura para administrar las credenciales necesarias para realizar acciones específicas. Por ejemplo, algunas tareas de supervisión pueden requerir credenciales con privilegios altos o incluso credenciales no basadas en Windows.
Las cuentas "Ejecutar como" deben estar asociadas con un perfil "Ejecutar como", que a su vez puede estar asociado con una regla o tarea que requiera privilegios especiales. El perfil "Ejecutar como" permite a los autores del módulo de administración resumir el requisito de cuentas durante el proceso de creación para que el administrador pueda asociar una cuenta "Ejecutar como" apropiada después que el paquete de administración se instale en Operations Manager.
Operations Manager 2007 proporciona mayor seguridad que su antecesor en las comunicaciones entre agentes y servidores de administración al requerir autenticación mutua. En entornos de confianza, la autenticación mutua se puede lograr mediante Kerberos. Para entornos que no son de confianza y de red de perímetro, la situación puede ser más complicada. La autenticación mutua requiere autorización basada en certificados que usa certificados X.509, que requerirá que las organizaciones consideren sus opciones de infraestructura de claves públicas (PKI) si aún no fue establecida.

Funciones de servidor
Mientras las funciones de servidor de administración, base de datos de operaciones y generación de informes de MOM 2005 permanecen en Operations Manager, se han incorporado nuevas funciones de administración. La función de servidor de administración de raíz aísla funciones críticas tales como la autorización de usuario, la notificación y la administración de conexiones de consola en una función dedicada en la infraestructura. Para obtener un mejor rendimiento, el servidor de administración de raíz debe estar dedicado a esta función y no se deben configurar agentes que notifiquen a este servidor.
La nueva función de servidor de puerta de enlace admite el uso más eficiente de los equipos de administración en dominios y entornos de perímetro que no son de confianza al ofrecer una única comunicación de retorno al servidor de administración. En muchos casos, los agentes en el dominio de destino pueden autenticarse con el servidor de puerta de enlace mediante el protocolo Kerberos, lo que minimiza la necesidad de autenticación basada en certificados y reduce el esfuerzo y costo total de la propiedad.

Generación de informes
Los usuarios encontrarán que Operations Manager 2007 proporciona mejoras notables en la generación de informes, con un espacio de generación de informes integrado en la consola de operaciones. De forma similar, la seguridad de la generación de informes se integra con la seguridad general de Operations Manager.
Hay varios cambios de arquitectura importantes, que incluyen cuando y cómo se proporcionan los datos a la base de datos de generación de informes. Ha desaparecido la tarea nocturna Servicios de transformación de datos (DTS) que transfería los datos de generación de informes del día anterior de la base de datos de operaciones. En lugar de eso, los datos se insertan directamente en la base de datos de generación de informes al mismo tiempo que en la base de datos de operaciones, y como resultado prácticamente no existe latencia.
Los informes de Operations Manager contienen nuevos encabezados de parámetro inteligentes que ofrecen flexibilidad para definir y notificar intervalos de fecha y hora específicos y relativos, incluida la salida de informes restringida a un intervalo del horario comercial definido por el usuario. El selector de objetos en el encabezado de parámetro inteligente proporciona la búsqueda para simplificar la tarea de elegir objetos para los informes. En la programación de informes, el flexible selector de fechas elimina la necesidad de modificar archivos de definición de informes para lograr un intervalo de fechas relativo específico en informes periódicos (consulte la figura 6).
Figura 6 Configuración del horario comercial
Figura 6 Configuración del horario comercial (Hacer clic en la imagen para ampliarla)
Otra mejora de la generación de informes se propone asegurar que los informes se representen rápidamente, incluso cuando se ejecutan en intervalos de fechas prolongados. Con esa finalidad, los datos de la generación de informes de Operations Manager se preindexan automáticamente y se agregan en puntos de datos de resumen diario y por hora, que se usan en todos los informes de Operations Manager. Además de disponer de datos ya compilados, esto mejora la escalabilidad de almacenamiento de datos porque los puntos de datos sin formato se pueden comprimir más intensamente en la base de datos sin repercusión en la capacidad de generación de informes históricos.
De lejos, las mejoras más impresionantes implican el contenido y las características de los informes representados en sí mismos, que presentan datos históricos de rendimiento y disponibilidad en un formato pertinente para los ingenieros de redes y administradores de TI.
La figura 7 muestra un informe estándar de rendimiento, que consta de un gráfico con una tabla. Tanto las líneas en el gráfico como las descripciones en la tabla ofrecen por medio de un clic un informe detallado, tal como se muestra en la figura 8.
Figura 7 Informe de rendimiento estándar
Figura 7 Informe de rendimiento estándar (Hacer clic en la imagen para ampliarla)
Figura 8 Informe detallado de rendimiento (en profundidad)
Figura 8 Informe detallado de rendimiento (en profundidad) (Hacer clic en la imagen para ampliarla)
La generación de informes de disponibilidad en Operations Manager se basan en el estado de objeto. En un informe de disponibilidad listo para usar se puede elegir cualquier objeto que pueda tener estado. Se puede cambiar entre un informe detallado y uno de disponibilidad con un solo clic (consulte la figura 9).
Figura 9 Informe de disponibilidad
Figura 9 Informe de disponibilidad (Hacer clic en la imagen para ampliarla)
Para paquetes de administración sin informes, hay informes genéricos que acomodarán la generación de informes de disponibilidad y rendimiento de casi cualquier objeto administrado, lo que reduce claramente la necesidad de crear informes personalizados.
Los administradores estarán satisfechos de encontrar que de fábrica, Operations Manager 2007 admite la generación de informes de varios grupos de administración en un único almacén de datos de generación de informes. La seguridad de la generación de informes se integra con la seguridad del producto basada en funciones, lo que permite a los administradores controlar el acceso a los informes mediante grupos de seguridad de Active Directory.

Notificación
El motor de notificación ha experimentado un completo reequipamiento en Operations Manager 2007 y surge con nuevas características solicitadas por los administradores. Entre ellas se incluyen opciones de notificación adicionales (denominadas canales de notificación), tales como mensajes instantáneos y SMS (esta característica requiere instalar un proveedor SMS de terceros en el servidor de administración). Las suscripciones de notificación ahora incluyen una opción de ámbito para que los administradores puedan limitar la visibilidad de tipos y grupos de objetos disponibles para las funciones de operador y suscripciones de notificación de destino con más precisión.
La antigüedad de alerta (escalada) permite el envío de la notificación cuando una alerta que cumple criterios definidos en la suscripción permanece en un estado de resolución determinado durante cierto tiempo definido por el usuario.
Los formatos de mensajes ahora se pueden personalizar por suscripción y permiten la personalización del formato de mensaje hasta el nivel de usuario individual. Además, la notificación de autoservicio en el panel de Mi área de trabajo de la consola de operaciones permite a los usuarios definir sus configuraciones de dispositivos y suscripciones de notificación. Estas son sólo algunas de las características de notificación que encontrará totalmente útiles.

Paquetes de administración
Los paquetes de administración todavía representan el marco de base de la supervisión de servicios y aplicaciones en Operations Manager 2007, y proporcionan conocimiento de aplicaciones directo de los equipos de producto de Microsoft. Sin embargo, cambian de supervisión de servidor a supervisión orientada a servicios, y se centran en el mantenimiento del servicio que se está suministrando.
Las restricciones de espacio impiden entrar aquí en mayores detalles, pero se debe tener en cuenta que el modelo de tipo de objetos sencillo de MOM 2005 (equipos y grupos de equipos) se ha renovado como un modelo extensible con docenas de tipos de objetos supervisados que se pueden elegir. El resultado es un entorno de desarrollo completo para ISV de terceros con el fin de proporcionar excepcionales ofertas para línea de negocios, red y entre plataformas.
Reglas de supervisión sencillas, semejantes a las que se disponen en MOM 2005, se usan en una variedad de tareas de supervisión comunes, tales como la supervisión de texto y registro de eventos, consultas de eventos WMI, scripts ejecutados en una programación y un proveedor de capturas SNMP inmensamente mejorado que elimina la necesidad de compilar bases de información de administración SNMP.
Sin embargo, en Operations Manager los monitores detectan el cambio en el estado de objetos administrados. Los monitores incluyen muchas funciones no vistas en proveedores de MOM 2005, tales como comprobación de puerto TCP, transacciones sintéticas para conectividad de bases de datos y sitios web, supervisión de aplicaciones ASP.NET y servicios web, y quizá lo más importante, supervisión orientada a servicios para aplicaciones de línea de negocios distribuidas. Abordaré dentro de un momento estos temas con mayor detalle.

Autoajuste de umbrales
A veces el comportamiento de un contador dado no es conocido. En dichas situaciones, Operations Manager ofrece monitores de autoajuste de umbral. Un monitor de autoajuste de umbral usa un proceso de aprendizaje sobre el ciclo de negocio definido (generalmente una semana, aunque quizás tan breve como un día) para determinar los valores normales de un objeto contador de rendimiento especificado y para definir umbrales basados en normas operativas registradas durante el período de aprendizaje. Estos umbrales representan la actividad esperada, incluidas caídas o picos sostenidos en el uso del recurso, como quizás se experimentan durante el mantenimiento de la aplicación y del sistema por la noche.

Transacciones sintéticas
Para una imagen más dinámica del mantenimiento de la aplicación, Operations Manager ofrece transacciones sintéticas, que son acciones que se ejecutan en tiempo real con objetos supervisados. Las transacciones sintéticas se pueden crear para supervisión de secuencias de exploración de sitios web, conectividad de base de datos y puertos TCP. Puede especificar los nodos de servidor desde los que se ejecutarán las transacciones (llamados nodos de observador) así como el intervalo de supervisión deseado. Si se eligen múltiples nodos de observador, los resultados se pueden comparar para determinar si la experiencia de cada nodo es la misma.
El editor de aplicación web que se usa para capturar las secuencias de explorador web permite también a los administradores definir umbrales de tiempo de respuesta de advertencias y niveles de error, así como especificar recopilación de contadores de rendimiento para operaciones individuales en la carga de páginas y recuperación de vínculos. Las secuencias de explorador seguras (SSL) requieren que una variedad de métodos de autenticación (tales como básico o NTLM) sean compatibles.
Las invalidaciones, un concepto familiar de MOM 2005, se usan para ajustar la configuración de valores de Operations Manager para monitores, atributos y reglas para un objeto o grupo de objetos administrados (consulte la figura 10). El uso de invalidaciones es clave para controlar la cantidad de datos que recopila Operations Manager. Puede usar grupos e invalidaciones para reducir el enfoque del monitor, regla, atributo o detección de objeto a un grupo de destino de objetos no sólo en sus propios paquetes de administración, sino también en ISV de Microsoft y de terceros.
Figura 10 Parámetros de invalidaciones para un monitor de servicio
Figura 10 Parámetros de invalidaciones para un monitor de servicio (Hacer clic en la imagen para ampliarla)

Supervisión de aplicaciones de línea de negocios
El nuevo diseñador de aplicaciones distribuidas permite crear una imagen del nivel de servicio de aplicaciones críticas y ofrece un indicador de mantenimiento de resumen de los componentes de aplicaciones distribuidas. Incluye todos los tipos de objetos detectados, tales como un servicio web, base de datos SQL Server™ e incluso dispositivos que no son de Windows tales como enrutadores de red y conmutadores. Se pueden observar en un diagrama las relaciones de los objetos y el estado actual.
Para hacer que esta eficaz característica sea más accesible, Microsoft ofrece varias plantillas de aplicación distribuida con el fin de ofrecer a los administradores un punto de partida para definir sus propias aplicaciones de línea de negocios. Hay plantillas para muchas situaciones comunes disponibles que incluyen aplicación ASP.NET y servicio web ASP.NET, aplicación web de línea de negocios, mensajería, granja de SharePoint® Portal y granja de Terminal Services.
Las nuevas plantillas se pueden agregar al grupo de administración mediante paquetes de administración de Microsoft o de terceros y que, a su vez, aparecen en el asistente para agregar supervisión. La aplicación distribuida supervisa que Active Directory, Exchange y Operations Manager están previamente implementados y no se pueden editar.

Disponibilidad de paquetes de administración
Los paquetes de administración escritos específicamente para Operations Manager 2007 (denominados paquetes de administración optimizados) se diseñan para aprovechar las nuevas características en Operations Manager 2007 y su disponibilidad está programada para los nuevos lanzamientos de software que comenzarán a partir de 2008. Sin embargo, los paquetes de administración de MOM 2005 existentes se pueden convertir en el formato sencillo de Operations Manager 2007 mediante la utilidad MPConvert, o bien se pueden transferir desde una instalación MOM 2005 existente mediante la herramienta de migración de MOM 2005 a Operations Manager 2007; ambas herramientas se encuentran en el CD de Operations Manager 2007. En realidad, Microsoft convierte paquetes de administración de MOM 2005 al formato compatible con Operations Manager 2007, así que generalmente esto sólo será necesario para los paquetes de administración de cosecha propia.

Recopilación de auditoría
La recopilación de auditoría ofrece la solución para automatizar la recopilación y archivado centralizado de los registros de eventos de seguridad de Windows distribuidos. Está diseñada para empresas medianas y de gran tamaño que requieren recopilación y análisis de grandes volúmenes de datos de registro de eventos de seguridad para auditorías de cumplimiento internas y externas. La recopilación de auditoría consta de cuatro funciones: el recopilador, los reenviadores, la función de base de datos y la función de generación de informes. El recopilador es el servidor que "captura" eventos y los inserta en la base de datos de recopilación de auditoría. El reenviador es un servicio que envía eventos del registro de eventos de seguridad en tiempo cercano al real, minimizando la probabilidad que los administradores locales puedan interferir con los eventos de registros de seguridad. El servicio de reenviador se incluye en el agente de Operations Manager 2007, pero está deshabilitado hasta que se habilite la recopilación de auditoría para un agente determinado.
La recopilación de auditoría emplea mantenimiento automático de la base de datos por la noche, lo que asegura una buena coherencia en el rendimiento del procesamiento de informes a través de conjuntos de datos de gran tamaño. La recopilación de auditoría mantiene un conjunto de datos circulares (almacenados de forma predeterminada por 14 días) que los administradores pueden ajustar para cumplir los requisitos de su organización. Para analizar los eventos recopilados, la recopilación de auditoría incluye una función de generación de informes con un conjunto de base de cerca de 20 informes de auditoría así como un suscriptor WMI de gran rendimiento, que ofrece una interfaz sencilla para consultas ad hoc sin necesidad de conceder a los administradores acceso directo a la base de datos.

Supervisión de clientes
Las nuevas características de supervisión de clientes en Operations Manager 2007 permiten a los administradores supervisar sistemas operativos y aplicaciones de escritorio, para ayudar a determinar qué errores ocurren con más frecuencia de manera que los esfuerzos se puedan orientar a lograr las mayores prestaciones para la organización. Los datos de errores recopilados se usan para producir vistas detalladas y generación de informes, que ofrecen al administrador un origen de información fácilmente disponible que facilita las decisiones de soporte técnico.
La supervisión de clientes en Operations Manager 2007 consta en realidad de tres niveles que se pueden habilitar individualmente:
Agentless Exception Monitoring (AEM) permite al administrador supervisar bloqueos y errores en sistemas operativos y aplicaciones. El administrador puede dirigir estos informes que anteriormente se enviaban directamente a Microsoft a un servidor de administración, desde el que se pueden reenviar a Microsoft si así se desea.
Programa para la mejora de la experiencia del usuario (CEIP) Cuando participa en el CEIP, puede configurar los clientes con directiva de grupo para redireccionar los informes a un servidor de administración de Operations Manager 2007, en lugar de enviar los informes directamente a Microsoft. Los servidores de administración son, a su vez, configurados para reenviar estos informes a Microsoft.
Es importante tener en cuenta que los componentes de supervisión de clientes AEM y CEIP se pueden ejecutar sin agentes.
La supervisión de clientes para estaciones de trabajo críticas del negocio implica en realidad la implementación de un agente de Operations Manager en escritorios críticos del negocio. Los paquetes de administración se incluyen para Windows 2000, Windows XP, Windows Vista y Microsoft Information Worker que supervisa Microsoft Office, Internet Explorer y otras aplicaciones de escritorio de Microsoft.

Pruébelo
Como puede ver, System Center Operations Manager 2007 trae un sinfín de características diseñadas para proporcionar supervisión orientada a servicios con integración en todos los lugares adecuados, que le permiten aprovechar las inversiones existentes en Active Directory, agilizar la administración y reducir el costo total de la propiedad. Lo animo a probar esta fantástica nueva versión y explorar sus posibilidades.
Puede descargar una copia de prueba de 180 días de Operations Manager 2007 en la dirección microsoft.com/technet/opsmgr/2007/downloads/trials/privacy.mspx. Para obtener más información acerca de las tecnologías de Microsoft System Center, visite la página principal de System Center Operations Manager en microsoft.com/systemcenter/opsmgr. Consulte historias de éxito de System Center (vídeos y casos prácticos) en el nuevo sitio web "Designed for BIG" en designedforbig.com.

Pete Zerger es socio de consultoría en AKOS Technology Services. Pete tiene nueve años de experiencia en el sector de TI; se dedica al diseño y la implementación de administración de operaciones, servicios de directorio y soluciones de mensajería empresariales. Pete tiene un MSCE en Mensajería, un MCTS en SQL Server 2005 y es Microsoft MVP en Microsoft Operations Manager.


System Center
Migración de MOM a Operations Manager 2007
Andy Dominey
Resumen:
  • Planeamiento de una implementación de Operations Manager
  • Valoración de necesidades de hardware
  • Conservación de datos históricos
  • Pruebas de los planes

La supervisión y administración del servidor es un área crítica de cualquier infraestructura moderna de TI. Es de vital importancia garantizar no sólo que la infraestructura de TI funciona correctamente, sino además que es adecuada para sostener la carga que los usuarios ejercen sobre ella. Sin embargo, reunir esta información es más fácil
de decir que de hacer, y saber qué hacer con la información una vez que la obtuvo es otra historia totalmente distinta. Afortunadamente, hay ayuda. Microsoft® Operations Manager (MOM) lo ha estado haciendo posible durante siete años, y en su última encarnación, System Center Operations Manager 2007, amplía esa base.

¿Por qué migrar?
System Center Operations Manager 2007 ofrece numerosas y considerables mejoras sobre la versión anterior, MOM 2005. La arquitectura principal se ha rediseñado y tiene muchas mejoras para permitir que el producto tenga más en cuenta las aplicaciones extendidas a través de múltiples dispositivos y para que tenga también en cuenta no sólo servidores sino todos los componentes que constituyen un servidor.
Además, Operations Manager cuenta con un eficaz motor de intercalación que puede agregar datos de alerta, lo que reducirá significativamente el número de alertas falsas. También incluye un explorador de estado que ayuda a agilizar el proceso de localización y solución de problemas.
Existen umbrales de autoajuste y un motor de línea de base que le permite realizar un seguimiento sencillo del rendimiento en su entorno, y el motor de generación de informes tiene muchas mejoras, ofreciendo informes con gráficos y detalles superiores. Eche una mirada a la figura 1 para obtener una muestra de la presentación visual de los datos de informes.
Figura 1 Informe de disponibilidad en Operations Manager 2007
Figura 1 Informe de disponibilidad en Operations Manager 2007 (Hacer clic en la imagen para ampliarla)
Operations Manager incluso se puede usar para supervisar equipos de escritorio así como servidores. Estas son algunas características adicionales que ofrece Operations Manager 2007:
  • Excelente supervisión para la plataforma Windows Server System™
  • Eficaces capacidades de supervisión de aplicaciones y funcionalidad
  • Automatización de tareas comunes
  • Motor de base de datos de próxima generación que facilita la escalabilidad y el control en el nivel empresarial
  • Mejoras de seguridad e integración con Active Directory®
Para obtener más información acerca de las nuevas características disponibles en System Center Operations Manager 2007, consulte el artículo "Cuide sus servidores con Operations Manager 2007" de Pete Zerger en este número de TechNet Magazine.

Migración a Operations Manager
Antes de planear su migración a Operations Manager 2007, debe tener en cuenta que no hay una ruta de actualización directa para el producto. Con estos cambios considerables de arquitectura en Operations Manager, el producto no conservó suficiente compatibilidad con versiones anteriores como para permitir una actualización local. Por lo tanto, si actualmente ejecuta MOM 2000 o MOM 2005, deberá considerar alguna de las estrategias de migración descritas más adelante en este artículo.
Sin embargo, si no ejecuta una versión anterior de MOM, puede simplemente instalar la nueva versión del producto. Tenga presente que deberá decidir en la primera parte del proyecto si cuenta con suficientes habilidades en la empresa para llevar a cabo la instalación o migración, o si necesitará obtener ayuda de terceros. Obviamente, esto tendrá repercusión en el costo general del proyecto, así que se debe tener en cuenta al comienzo de este proceso.

Escenarios de migración
Para los que actualmente no ejecutan MOM, la implementación es sencilla: planear y diseñar la arquitectura y, a continuación, implementar el software. Sin embargo, si usa MOM, Microsoft admite dos escenarios de migración; en paralelo con el mismo hardware y en paralelo con hardware diferente. Exploremos ambos.
En paralelo con el mismo hardware En este escenario, Operations Manager se instala en el mismo hardware físico que el de la arquitectura MOM 2000 o MOM 2005 existente. Este método es de utilidad para emplazamientos en los que la infraestructura MOM no se usa mucho y en los que el hardware de servidor tiene la eficacia suficiente como para alojar conjuntamente tanto la versión antigua como la nueva. Sólo debe considerar este camino si la instalación de Operations Manager no tiene una repercusión seria en el rendimiento de los servidores MOM actuales.
En paralelo con hardware diferente En este caso, la nueva instalación se realiza en hardware nuevo o diferente. Este es el método preferido porque asegura una pequeña repercusión en la infraestructura de administración actual mientras se produce la migración. Cabe destacar que no necesariamente se requiere hardware adicional. Los nuevos servidores de Operations Manager 2007 se pueden incluir en equipos virtuales hasta que se pueda reasignar el antiguo hardware de servidor.

Consideraciones
Antes de confirmar una estrategia de migración en particular, hay algunos puntos importantes que se deben considerar.
En primer lugar, necesita pensar en los requisitos de hardware y software y en los costos asociados. Incluso si decide incluir o aprovisionar toda o una parte de la infraestructura de Operations Manager en equipos virtuales, aún necesita permitir las licencias de sistema operativo y aplicación así como las licencias OML (Operations Management License) para cada agente que Operations Manager supervisa.
En segundo lugar, debe planear los recursos que llevarán a cabo el trabajo. En una pequeña empresa, es posible que no se trate de un plan especialmente complejo ni difícil, pero en compañías más grandes será una parte clave en la estrategia general de migración.
También necesita considerar la repercusión potencial que esta migración podría tener en la infraestructura de supervisión actual o en el estado del servidor en conjunto. Debe planear cada eventualidad, incluida la posibilidad de rearranques del servidor o incluso de errores en servidores de producción críticos.
Tenga en cuenta que si usa la base de datos Microsoft Access™ en MOM 2000 o el almacén de datos SQL Server™ en MOM 2005 para el almacenamiento de datos de archivo y la generación de informes, actualmente la migración de estos datos a Operations Manager 2007 no es compatible.

Planeamiento para una migración correcta
Como consultor, uno de los problemas más grandes que veo es el planeamiento inadecuado de la implementación. Por lo tanto, una vez que decide si la instalación se realizará en hardware nuevo o existente, el paso siguiente es crear un plan de proyecto.
Su plan de proyecto debe enumerar las etapas del proyecto sugeridas en este artículo; aunque no se trata de una lista exhaustiva. Asegúrese de asignar tiempo suficiente a cada etapa del proyecto y de tener en cuenta todos los recursos que se necesiten.
Como mencioné, System Center Operations Manager 2007 tiene una arquitectura apreciablemente diferente de MOM 2000 y 2005. Para comenzar, hay una función de servidor adicional en Operations Manager, el servidor de administración de raíz (RMS). RMS administra la configuración del grupo de administración, controla todas las conexiones a los otros grupos de administración y productos de terceros y también es responsable de la seguridad en el grupo de administración. Esta función se puede mantener en un servidor de administración de System Center Operations Manager, pero en entornos grandes y complejos se le debe asignar su propio servidor físico. Además, el concepto de grupos de administración con niveles que existía en MOM 2005 se reemplazaron por grupos de administración conectados. En esta nueva arquitectura, los datos de alerta no pasan entre los grupos de administración; en lugar de eso, las alertas de los grupos de administración conectados simplemente se presentan en la IU del grupo de administración que las solicitan. Además, si piensa instalar agentes en equipos en dominios o grupos de trabajo que no son de confianza, deberá usar certificados para permitir que el servidor de administración y los agentes realicen la autenticación mutua (una característica obligatoria en Operations Manager).
Para diseñar la arquitectura de System Center Operations Manager, deberá considerar el número de servidores y clientes que planea supervisar, si están ubicados en un dominio de confianza, cuáles aplicaciones y plataformas necesita supervisar y si desea supervisar su infraestructura de red. También deberá identificar todas las aplicaciones que necesitan reglas o paquetes de administración personalizados.
Esta es la etapa en que debe identificar sus requisitos de paquetes de administración. Una vez que haya determinado las aplicaciones que supervisará, puede decidir cuáles paquetes de administración instalará. Los paquetes de administración contienen reglas, monitores, tareas y clases que se aplican a una aplicación o sistema operativo concretos y se deben importar si su aplicación o sistema operativo asociados se encuentran en uso en su entorno. La elección de los paquetes de administración en esta etapa tendrá un impacto en los requisitos de hardware y software y en la cantidad de tiempo que se debe asignar para instalar y configurar el software.
Una vez que tenga una idea de la arquitectura de su infraestructura de Operations Manager, debe abrir la herramienta System Center Capacity Planner 2007 (en versión beta en el momento en que se escribe este artículo). Use la herramienta para elaborar la infraestructura de red y servidores y simular la ejecución con su implementación de Operations Manager planeada para asegurar que es suficiente para supervisar y administrar su infraestructura.
En este momento, debe prestar especial atención al diseño de arquitectura si planea migrar. Debe considerar el hecho que MOM 200x se ejecuta junto con Operations Manager, lo que resulta en tráfico de red adicional.

Implementación
La implementación es la siguiente etapa que se debe analizar. Debe estar seguro de que se suministra el hardware adecuado antes de instalar el software. Si instala en un entorno nuevo, el hardware físico es mejor, especialmente para el servidor de base de datos. Sin embargo, los servidores de administración se pueden virtualizar si el hardware físico no es una opción. En un escenario de migración, el uso de servidores virtualizados es una buena alternativa a la compra de hardware para incluir la nueva infraestructura. En esta situación, puede usar equipos virtuales para incluir Operations Manager mientras los antiguos servidores MOM se retiran de servicio activo y se vuelven a montar.
Una vez que los servidores se hayan aprovisionado, puede comenzar a instalar el software. En primer lugar, asegúrese de que los servidores que ejecutarán Operations Manager cumplan los requisitos previos necesarios de software para ser compatibles él. Por ejemplo, si ejecuta SQL Server 2000 y planea instalar Operations Manager en el mismo servidor, primero deberá actualizar a SQL Server 2005 con SP1. Para realizar esta comprobación, puede ejecutar el programa de comprobación de requisitos previos de Operations Manager desde el medio de instalación de System Center Operations Manager.
Una vez establecidos todos los requisitos previos de software y configurado SQL Server y Reporting Services, puede comenzar a instalar el software de Operations Manager. En un entorno de servidor único, esta tarea es sencilla; simplemente ejecute el archivo de instalación de Operations Manager en el servidor y, a continuación, ejecute la instalación de informes de Operations Manager si desea usar esa característica. Sin embargo, en un entorno distribuido, los componentes de Operations Manager se deben instalar en los servidores individuales en el orden correcto. En primer lugar, instale la base de datos, a continuación, el primer servidor de administración, al que automáticamente le será asignada la función servidor de administración de raíz. A continuación, se puede instalar cualquiera de los servidores de administración adicionales. Como último paso, instale los componentes de consola web y de generación de informes.

Migración
En esta etapa, debe asegurarse de que la nueva infraestructura refleje la supervisión existente antes de intentar aprovechar cualquiera de las nuevas características. Todos los paquetes de administración que se usan en el entorno heredado se deben duplicar en la nueva implementación de Operations Manager. Si existe un paquete de administración de Operations Manager disponible, quizás desee importarlo, pero todos los paquetes de administración que no tengan versiones más nuevas deberán exportarse desde el grupo de administración actual, convertirse mediante la herramienta MPConvert desde el CD de instalación e importarse en Operations Manager (a menos que disponga de un paquete de administración personalizado sencillo o pequeño, en cuyo caso será preferible simplemente volverlo a crearlo). También existe una herramienta de gran utilidad a la hora de duplicar una configuración. La herramienta de migración de MOM 2005 a Operations Manager ayuda a duplicar la configuración de un grupo de administración de MOM existente en Operations Manager. Ésta se encuentra también en el CD de instalación de Operations Manager. La figura 2 muestra una configuración típica durante una migración.
Figura 2 Configuración típica durante la migración
Figura 2 Configuración típica durante la migración (Hacer clic en la imagen para ampliarla)
Una vez duplicada la configuración, debe asegurarse que se obtienen las mismas alertas y se recopilan los mismos datos con Operations Manager que con MOM. Afortunadamente, el agente de Operations Manager puede coexistir con los agentes heredados de MOM de manera que ambos agentes se pueden ejecutar simultáneamente. Puede recopilar los datos de ambos y compararlos en paralelo para comprobar su exactitud antes del retiro de servicio del sistema heredado.
A continuación deber formular un plan de prueba. La prueba puede consistir simplemente en la comparación de las alertas del sistema heredado con las del sistema Operations Manager, pero también puede llegar a requerir la generación de alertas con sentido para valorar exhaustivamente la nueva infraestructura. Una vez que está satisfecho con los resultados de prueba, puede comenzar a desinstalar los agentes de MOM heredados, por medio de los programas de consola de MOM o con la opción Agregar o quitar programas en los equipos en que están instalados los agentes.
La generación de informes es una parte importante en la implementación de MOM y System Center Operations Manager, y también merece un análisis. La base de datos existente de SystemCenterReporting actualmente no se puede migrar a Operations Manager 2007, por lo que puede crear una nueva sesión de Reporting Services for Operations Manager y mantener la base de datos existente de MOM 2005 (SystemCenterReporting) en una sesión dedicada de SQL Reporting Services para mostrar los informes heredados. La nueva consola de generación de informes en System Center Operations Manager 2007 está integrada en el producto. Por lo tanto, no se recomienda usar la consola Reporting Services para nada que no sea Operations Manager. La migración de datos para la generación de informes es algo que se puede solucionar en el futuro por medio de un script de migración de datos. Pero mientras tanto, quizás tenga que despedirse de sus datos para la generación de informes archivados y simplemente consolarse con el hecho de que cuando comience a generar sus nuevos informes llamativos, los directivos estarán tan emocionados que ni siquiera advertirán que han desaparecido sus antiguos datos.

Conclusión
System Center Operations Manager ofrece mejoras considerables sobre MOM 2000 y 2005, pero estos avances vienen con cierto costo. Un cambio importante en la arquitectura subyacente (y como resultado, la ausencia de una ruta de actualización local directa) significa que esos costos de implementación son potencialmente mayores. La clave para minimizar estos costos es realizar adecuadamente el plan y asegurarse de contar con las personas adecuadas para el trabajo. De este modo, podrá disfrutar de los beneficios del esfuerzo de Microsoft con System Center Operations Manager.

Andy Dominey ha trabajado durante ocho años en el sector de TI y actualmente es empleado de 1E como especialista en administración de Windows en el Reino Unido. Trabaja con MOM desde la versión MOM 2000. Andy recibió el premio Microsoft MVP para MOM los últimos dos años.


System Center
Virtualice sus aplicaciones con Microsoft SoftGrid
Ahmer Sabri and Kedar Shah
Resumen:
  • Ventajas de la virtualización de aplicaciones
  • Introducción a la arquitectura de SoftGrid
  • Transmisión de paquetes de software

El concepto de virtualización de software, en alguna forma u otra, existe desde los años sesenta. Sin embargo, le ha llevado décadas al sector de TI comenzar a tomar conciencia del potencial de la virtualización de
aplicaciones. Las personas ahora lo comprenden y se han realizado desarrollos importantes.
Microsoft apostó a la virtualización de aplicaciones cuando adquirió Softricity allá en julio de 2006. De esta adquisición proviene Microsoft® SoftGrid, una solución para virtualización de aplicaciones. Con SoftGrid, las aplicaciones se sirven desde un centro de datos u otra ubicación de red y se ejecutan de forma local en un entorno virtual en clientes remotos. Las aplicaciones virtualizadas se ejecutan en silos y funcionan independiente del sistema operativo y otras aplicaciones en el escritorio local.
Hay muchas ventajas en implementar virtualización de aplicaciones con SoftGrid; demasiadas para tratar aquí. Sin embargo, alguno de los beneficios más notables y que se reconocen de inmediato son:
Pruebas de regresión y compatibilidad simplificadas Si se ejecutan múltiples versiones en paralelo de la misma aplicación en un solo equipo sin conflictos, es posible reducir dramáticamente la complejidad, los tiempos y los costos asociados con la prueba e implementación de nuevas aplicaciones (consulte la figura 1).
Figura 1 Simplificación de la implementación de aplicaciones con SoftGrid
Figura 1 Simplificación de la implementación de aplicaciones con SoftGrid (Hacer clic en la imagen para ampliarla)
Administración de sistemas más sencilla TI tiene gran control sobre el entorno en que se ejecutan estas aplicaciones, lo que facilita mantener el entorno de escritorio ideal.
Menos llamadas al servicio de soporte técnico Con entornos de escritorio mejor administrados y menos conflictos (gracias a la ejecución de aplicaciones virtualizadas en un silo controlado), los usuarios necesitan llamar menos al servicio de soporte técnico.
Seguridad de escritorio mejorada Las aplicaciones nunca se instalan en el sistema operativo, lo cuál mejora la seguridad general del sistema operativo. Las aplicaciones sólo se aprovisionan a usuarios autorizados, impidiendo así el acceso no autorizado. Y la mayoría de las aplicaciones se representan con el contexto de seguridad estándar.
Experiencia de libertad de puesto Las preferencias de usuario (perfil y otras configuraciones) se almacenan en la red, lo que permite a los usuarios tener acceso a sus aplicaciones, preferencias y controles desde cualquier PC.
Tolerancia a errores y recuperación ante desastres mejoradas Las aplicaciones se convierten en archivos de datos que se pueden almacenar y replicar como todos los datos empresariales. Las aplicaciones y sus actualizaciones se pueden sincronizar automáticamente entre sitios activos y sitios de programa de copia masiva (BCP) por medio de herramientas de terceros, que permiten el acceso instantáneo a aplicaciones en casos de desastre.
Por último, estas características aligeran la carga de administración de sistema, reducen los costos y permiten que su organización adopte las nuevas tecnologías de forma más rápida y confiable. Ahora examinemos con mayor profundidad cómo funciona SoftGrid.

Cómo se sirven las aplicaciones virtualizadas
La arquitectura de SoftGrid está compuesta por varios componentes que trabajan en conjunto en una sinfonía. Implica componentes de SoftGrid tales como el almacén de datos, servidor de aplicaciones virtual, secuenciador, consolas de administración, servicio web de administración y aplicaciones de clientes, que trabajan junto con componentes de infraestructura estándar, tales como Active Directory® (consulte la figura 2). A continuación se ofrece una introducción a la arquitectura de SoftGrid y se explica cómo los diferentes componentes funcionan en conjunto.
Figura 2 Arquitectura general de SoftGrid
Figura 2 Arquitectura general de SoftGrid (Hacer clic en la imagen para ampliarla)
El componente SoftGrid Data Store actúa como un repositorio central para el entorno de virtualización completo. Instalado en SQL Server™ (versión 2000 o 2005) o en Microsoft SQL Server Desktop Engine (MSDE), el almacén de datos conserva los registros, las aplicaciones, la configuración, los datos de licencia, la información para informes y la información de registro.
Las aplicaciones virtualizadas se sirven al equipo del usuario y se representan en un cliente. SoftGrid ofrece dos tipos; Microsoft SoftGrid Application Virtualization for Desktops y Microsoft SoftGrid Application Virtualization for Terminal Services. Cada enfoque tiene ventajas pero también ciertos inconvenientes de rendimiento, que abordaremos en la sección de configuración del cliente.
Uno de los componentes más críticos en el entorno de SoftGrid es SoftGrid Virtual Application Server (SVAS). Se usa para controlar las solicitudes de usuario para las aplicaciones y transmitir a petición los datos de aplicación a los usuarios.
SVAS se ejecuta como un servicio de Windows® denominado Microsoft System Center Virtual Application Server y tiene requisitos de hardware muy modestos. De forma predeterminada, todos los datos de la propia aplicación (que explicaremos en un momento) se encuentran en el directorio \Archivos de programa\Softricity\SoftGrid Server\content.
La experiencia de SoftGrid típica se inicia cuando un usuario inicia sesión en una estación de trabajo. El cliente de SoftGrid captura el símbolo (token) de seguridad y pertenencia a grupos de dominio del usuario y pasa esta información mediante un canal seguro a SVAS. SVAS asigna el acceso de usuario a las aplicaciones, siempre y cuando exista el identificador de seguridad (SID) del usuario en el directorio de pertenencia a grupos de la aplicación, y se coloca un acceso directo para cada aplicación en el escritorio del usuario (o en cualquier otra ubicación que el administrador puede definir, tal como el menú Inicio, la barra de herramientas de inicio rápido, etc.).
La entrega real de una aplicación generalmente se inicia cuando un usuario hace clic en el icono de acceso directo, que está asociado con un archivo de distribución abierta de software (.osd). Este es un archivo basado en XML que contiene información sobre el paquete de la aplicación. El cliente recupera el nombre virtual del servidor de aplicaciones del archivo .osd e inicia una conexión. En este momento, SVAS autentica al cliente y se pone en contacto con el almacén de datos para determinar el cumplimiento de licencia. Una vez que el usuario se autentica, SVAS transmite los datos de aplicación al cliente en bloques de datos. De forma predeterminada, los bloques de datos son de 32 KB pero se pueden configurar con el tiempo de secuencia.
Tenga en cuenta que no se transmite la aplicación completa al cliente. En cambio, SoftGrid transmite sólo la parte de la aplicación que se necesita iniciar de inmediato en el cliente. Esto típicamente representa cerca del 20 al 40 por ciento del código total, aunque desde luego puede variar según la aplicación. Por ejemplo, Microsoft Word 2003 sólo necesita que se transmitan al cliente 15 MB de datos antes que se pueda iniciar, en comparación con los 800 MB de tamaño total del paquete. Si el usuario tiene acceso a una parte de la aplicación que aún no se encuentra en la memoria caché del cliente, entonces se transmite al cliente el código necesario. Para evitar el efecto de lunes por la mañana, en que demasiadas solicitudes simultáneas atascan la red, las organizaciones pueden elegir colocar previamente en la memoria caché las aplicaciones comunes en los escritorios de usuario.

Active Directory
SoftGrid depende de usuarios y grupos de dominio de Active Directory (o Windows NT® 4.0) para realizar el aprovisionamiento de aplicaciones a usuarios autorizados. En un entorno de varios dominios, los usuarios se pueden aprovisionar por medio de las pertenencias a grupos apropiadas (SoftGrid es compatible con pertenencias a grupos locales, globales y universales) y las relaciones de confianza con el dominio donde se instala SVAS.
Al instalar SVAS, se solicitan distintas cuentas y grupos de servicio, que ayudan a la integración con Active Directory y posteriormente se usan con fines administrativos. Por lo tanto, antes de la instalación se deben crear tres grupos y cuentas: Una cuenta de explorador de SoftGrid, un grupo de administradores de SoftGrid y un grupo de usuarios de SoftGrid.
La cuenta de explorador de SoftGrid es responsable de examinar Active Directory y, por lo tanto, requiere derechos de sólo lectura en todos los dominios de Active Directory en un entorno de varios dominios. El grupo de administradores de SoftGrid se usa para conceder acceso administrativo a la consola de administración de SoftGrid y al servicio web de administración de SoftGrid (SoftGrid Management Web Service). Y el grupo de usuarios de SoftGrid se usa para asignar la directiva de proveedor predeterminada, que se usa para otorgar a todos los usuarios en el dominio el acceso a las aplicaciones publicadas mediante la consola de administración.

El entorno virtual
SystemGuard se encuentra en el núcleo del cliente de SoftGrid, que se ejecuta en el escritorio local. SystemGuard es responsable de ofrecer un entorno virtual completamente funcional para que las aplicaciones se ejecuten aisladas. En este entorno de silo se alojan los componentes virtualizados del sistema operativo (el Registro, archivos, fuentes, INI, COM, servicios incrustados y variables de entorno) que son necesarios para que la aplicación se ejecute apropiadamente (consulte la figura 3).
Figura 3 Entorno virtualizado para que la aplicación se ejecute de manera aislada
Figura 3 Entorno virtualizado para que la aplicación se ejecute de manera aislada
SystemGuard crea claves del Registro virtualizadas en cada aplicación que ejecuta. Otras aplicaciones que se ejecutan en el sistema operativo local no pueden tener acceso a estas claves, ni son visibles para herramientas de edición del Registro tales como regedit. Las lecturas y escrituras del Registro se redireccionan a las claves virtuales según sea necesario. No obstante, considere que se permite que esas aplicaciones virtualizadas pasen por el Registro local para buscar información no contenida en las claves de Registro virtualizadas.
De forma análoga, SystemGuard crea un sistema de archivos virtualizado y redirecciona a éste la mayoría de las lecturas y escrituras de la aplicación. Este sistema de archivos virtualizado se encuentra aislado y ofrece el entorno que se necesita cuando se desea ejecutar múltiples versiones de la misma aplicación en un solo cliente.
No obstante, debemos indicar que si bien las aplicaciones están aisladas del sistema operativo local, el usuario todavía tiene acceso a todos los servicios locales, como por ejemplo impresión, cortar y pegar y unidades de red.

Empaquetado de aplicaciones
Quizá ahora se pregunte cómo crear un entorno independiente completamente funcional en el que se pueda ejecutar su aplicación virtualizada. Para esta tarea, se usa SoftGrid Sequencer. Esta herramienta basada en asistente le permite incluir aplicaciones en un entorno virtual que se puede ofrecer y ejecutar en el cliente.
El proceso de la secuencia implica tres pasos: la instalación, la configuración y prueba y la ejecución. En el primer paso, la instalación, SoftGrid Sequencer usa un proceso de supervisión activo para supervisar la instalación de la aplicación y evaluar las dependencias de aplicación. Una vez completada, la fase de configuración y prueba se usa para realizar todos los cambios que sean necesarios en la configuración predeterminada para garantizar la experiencia de primera ejecución deseada. Por último, en la fase de ejecución, SoftGrid Sequencer compila y ordena los bloques de código necesarios para iniciar la aplicación. El bloque de característica 1 (FB1) es el código esencial que se necesita para iniciar la aplicación y permite que el usuario ejecute la aplicación sin descargar el paquete completo.
Una vez que se realiza la secuencia de la aplicación, se crean cuatro archivos: un archivo de aplicación con virtualización habilitada (.sft), un archivo de distribución abierta de software (.osd), un archivo de icono (.ico) y un archivo de proyecto (.sprj). A continuación, éstos se copian al directorio de contenido de SVAS. Como alternativa, un administrador puede publicar los archivos .ico y .osd en los clientes mediante un servidor HTTP.
Si bien SoftGrid típicamente aprovisiona las aplicaciones para que se ejecuten independientemente una de otra en entornos aislados, SystemGuard permite cierta interacción de la aplicación. Debe examinar con cuidado cualquier dependencia que las aplicaciones puedan tener entre sí y realizar la secuencia de las aplicaciones en conjunto si dependen de la interacción mutua. Este proceso frecuentemente se le denomina proceso conjunto. Tenga en cuenta que no es posible realizar la secuencia en conjunto en todas las aplicaciones que necesitan interacción mutua. El proceso conjunto es un proceso muy complejo y se debe realizar sólo después de un examen cuidadoso de dependencias, porque a veces realizar la secuencia de dos o más aplicaciones hace fracasar el propósito de la virtualización.

Administración simplificada
La consola de administración de SoftGrid ofrece una herramienta única para realizar todas las tareas administrativas. La consola de administración se instala en SVAS de forma predeterminada y se puede instalar en cualquier otro servidor o estación de trabajo. Es un complemento de MMC 3.0 y usa el servicio web de administración de SoftGrid para conectarse al almacén de datos de SoftGrid (consulte la figura 4), ofreciendo a los administradores autorizados acceso completo a datos almacenados en la base de datos para fines de administración. La conexión entre la consola de administración y el servicio web de administración de SoftGrid usa de forma remota Microsoft .NET Framework, lo que hace posible instalar la consola de administración y el servicio web en el mismo servidor o en servidores diferentes. La figura 2 muestra cómo encajan estas diferentes piezas y cómo ofrecen acceso a la implementación de SoftGrid completa. Tenga en cuenta que las organizaciones más grandes deberían ejecutar más de una instancia del servicio web de administración de SoftGrid.
Figura 4 El servicio web de administración de SoftGrid ofrece la conexión al almacén de datos
Figura 4 El servicio web de administración de SoftGrid ofrece la conexión al almacén de datos (Hacer clic en la imagen para ampliarla)
El servicio web de administración de SoftGrid se ejecuta en Windows 2000 o posterior con IIS 5.0 o posterior. Se necesita .NET Framework 2.0 o posterior, así como Microsoft Data Access Components (MDAC) 2.7 o posterior para la conectividad con el almacén de datos.
La consola de administración ofrece una única herramienta administrativa desde la cuál las aplicaciones se pueden publicar, detener, etc. Las tareas se organizan en nueve categorías o contenedores principales, tal como se muestra en el menú en la figura 5.
Figura 5 Administración de SoftGrid desde una única consola de administración
Figura 5 Administración de SoftGrid desde una única consola de administración (Hacer clic en la imagen para ampliarla)
Este es un resumen de los tipos de tareas de administración que se encuentran en cada contenedor. El contenedor de aplicaciones es donde el administrador puede realizar acciones tales como importar archivos .sprj para publicar las aplicaciones más nuevas, especificar la ubicación de .osd, quitar aplicaciones, etc. De forma predeterminada, este contenedor incluye un paquete publicado que se puede usar para probar conectividad del cliente al servidor de aplicaciones.
Cuando se realiza la secuencia de las aplicaciones se crean asociaciones de tipo de archivo. Una vez que se importa el paquete, las asociaciones de tipos de archivo quedan disponibles en la consola de administración. El contenedor de asociaciones de tipo de archivo ofrece un lugar único para que los administradores modifiquen todas las asociaciones de tipo de archivo.
El contenedor de paquetes controla las versiones de los paquetes para las actualizaciones activas; se trata de actualizaciones de aplicación que se pueden realizar sin que se desconecte el usuario o se apague el servidor. El administrador también puede eliminar un paquete de la consola de administración mediante este contenedor. Tenga en cuenta que si se elimina un paquete del contenedor de paquetes, se eliminará el archivo .sft de la consola de administración y del almacén de datos, pero no lo eliminará del directorio de contenido en el servidor de aplicaciones.
Como mencionamos anteriormente, cuando un usuario inicia una aplicación, el cliente de SoftGrid comprueba la disponibilidad de la licencia e inicia la aplicación sólo cuando en el almacén de datos hay una licencia disponible. El contenedor de licencias de aplicación es donde los administradores pueden asociar licencias con aplicaciones; se admiten licencias ilimitadas, licencias simultáneas y licencias con nombre.
Los grupos de servidor contienen una agrupación lógica de servidores de virtualización de aplicaciones e información de registro. Los administradores pueden agregar nuevos grupos de servidor o modificar las propiedades (tales como los puertos que se usan para las comunicaciones o la memoria y los procesos asignados) de un grupo existente.
En el contenedor de directivas de proveedor, el administrador puede crear un conjunto de reglas denominadas directivas. Las directivas de proveedor personalizadas se usan para proporcionar a los usuarios acceso a numerosas aplicaciones bajo diferentes conjuntos de condiciones. Puede usar el contenedor de autoridades de cuenta para especificar un dominio y las credenciales que se usarán cuando SoftGrid necesite tener acceso para leer la información de directorio del dominio. El contenedor de administradores de SoftGrid contiene los grupos de usuarios responsables de la administración del entorno de SoftGrid. En este contenedor, los administradores pueden agregar o quitar grupos para controlar permisos de acceso.
Por último, el contenedor de informes, como su nombre lo indica, permite que los administradores generen informes para comprobar el mantenimiento general del entorno de SoftGrid. Los siguientes informes están disponibles: Uso de aplicación, auditoría de software, uso de sistema, actividad de usuario/grupo y errores de sistema.

Configuración del cliente
El cliente de SoftGrid se instala en el sistema operativo del equipo que el usuario usará para tener acceso a la aplicación virtualizada. Como mencionamos anteriormente, se admiten dos tipos de cliente: Microsoft SoftGrid for Desktops o Microsoft SoftGrid for Terminal Services. Cada método tiene ventajas pero también ciertas desventajas de rendimiento, desde el punto de vista de latencia de red, consolidación de granja de servidores y facilidad de administración.
En una implementación de escritorio, las aplicaciones están disponibles de forma local y existe poca dependencia de la disponibilidad y rendimiento de la red. Este enfoque se recomienda, por ejemplo, para organizaciones que tienen sucursales con infraestructura de TI limitada. Terminal Services es una buena opción para una organización que ya ha implementado servidores Terminal Server. Este escenario hace un uso eficiente del hardware y software, y reduce significativamente el número de servidores necesarios. Y, por supuesto, permite un entorno con libertad de puesto real. Normalmente, las grandes organizaciones tendrán una combinación de infraestructura de escritorios y servidores Terminal Server. Cuando establece una implementación de SoftGrid, la instalación y configuración de los diferentes componentes es similar en ambos métodos.
El cliente se puede implementar mediante algún método estándar, tal como la instalación manual o implementación automatizada por medio de una herramienta como Systems Management Server 2003. La figura 6 enumera los requisitos mínimos de hardware y software que se necesitan para instalar estos clientes.
Figure 6 Requisitos de sistema para los clientes de SoftGrid

Cliente | Procesador | Memoria | Espacio en disco | Sistema operativo
Microsoft SoftGrid for Terminal Services | PIII 850 MHZ | 1 GB de RAM (mínimo de 256 MB, depende realmente del número de usuarios y aplicaciones) | 12 MB para la instalación y 4.096 MB para memoria caché | • Windows 2000 Server o Advanced Server con Terminal Services habilitados • Windows Server 2003 con Terminal Services habilitados
Microsoft SoftGrid for Desktops | PIII 600 MHZ | 128 MB | 12 MB para la instalación y 2.048 MB para memoria caché | • Windows 2000 Professional o Windows XP • Windows 2000 Server o Windows Server 2003
Aunque la instalación del cliente es sencilla, se deben proporcionar algunas propiedades en el momento de instalación, tales como la ubicación de instalación, el tamaño de la memoria caché, la letra que se usará para la unidad de disco virtual, la ubicación de archivos de datos de la aplicación, etc. Una vez instalado el cliente, se puede especificar o cambiar alguna configuración adicional mediante la consola de administración de clientes.
Para iniciar la consola de administración de clientes, vaya al panel de control e inicie SoftGrid Client Management desde la opción Administrative Tools. Tiene la opción de conectarse al equipo local o a un equipo remoto.
La figura 7 muestra cómo la consola de administración de clientes se compone de un contenedor raíz y tres contenedores secundarios. La ficha SoftGrid on localhost root es donde puede especificar la mayor parte de los parámetros funcionales, que incluyen el directorio de registro, le directorio de datos de aplicación, la configuración de ejecución y visualización del cliente, la frecuencia de mensajes emergentes de errores e información, el tamaño máximo de la memoria caché, la unidad de disco virtualizada, las opciones de red y conectividad cuando se encuentra desconectado del servidor de SoftGrid y los permisos.
Figura 7 Consola de administración de clientes
Figura 7 Consola de administración de clientes
Puede ver y cambiar aplicaciones en el contenedor aplicaciones. El contenedor de aplicaciones ofrece información de estado acerca de la aplicación local, tal como si la aplicación está en ejecución, si está bloqueada en la memoria caché y qué porcentaje de la aplicación (archivo .sft) ha sido transmitido en caché local.
El contenedor de asociaciones de tipo de archivo le permite ver, cambiar y quitar una asociación de tipo de archivo. Para obtener información más detallada, consulte nuestro análisis acerca de la asociación de tipos de archivo en la sección anterior.
El contenedor de configuración de escritorio le permite especificar, cambiar y actualizar de forma manual la configuración de servidor de aplicaciones que se especificó durante la instalación. Aquí, también se puede seleccionar si la actualización de cliente debe suceder en el momento de inicio de sesión de usuario (esta es la selección predeterminada) y la duración del intervalo automático de actualización.

Conclusión
La virtualización de aplicaciones con Microsoft SoftGrid ofrece una manera atractiva de mejorar la confiabilidad del sistema y simplificar la administración. Si bien implica varios elementos que funcionan en conjunto, la arquitectura se adapta sin problemas en la infraestructura de TI.
Microsoft SoftGrid for Desktops está disponible para clientes de Software Assurance como parte del Paquete de optimización de escritorio de Microsoft. Para obtener más información, consulte windowsvista.com/optimizeddesktop. Microsoft SoftGrid for Terminal Services está disponible como licencia de acceso de cliente independiente para clientes empresariales con contratos de licencias por volumen de Microsoft. Para descargar una versión de prueba, inicie sesión con su cuenta de licencias por volumen en https://licensing.microsoft.com y seleccione Desktop Optimization Pack for SA en Product Downloads.

Ahmer Sabri es técnico especialista en el grupo de servicios financieros de Microsoft. Si lo desea, puede ponerse en contacto con Ahmer en la dirección ahmers@microsoft.com.
Kedar Shah es técnico especialista en el grupo de servicios financieros de Microsoft. Si lo desea, puede ponerse en contacto con Kedar en la dirección kedars@microsoft.com.


Nota del editor Dinámico y optimizado
Joshua Trupin

En los próximos meses, probablemente escuchará algo acerca de dos estrategias de TI de Microsoft: sistemas dinámicos y optimización de la infraestructura. Estas dos iniciativas le ayudarán a realizar correctamente y ahora mismo su trabajo relacionado con la TI, y le ayudarán a prepararse para enfrentar los desafíos del futuro.
La Iniciativa de sistemas dinámicos define un marco para herramientas y aplicaciones que combina cuatro áreas clave de innovación técnica para ayudar a guiar los enfoques de TI del mañana. Para lograr un entorno dinámico, su infraestructura y software deben estar unificados y virtualizados, conducidos por procesos e impulsados por modelos, con servicios habilitados y enfocados en el usuario.
Sin embargo, la creación de un entorno dinámico de TI no se limita a productos de Microsoft. Su compañía puede realizar más inversiones para crear ventajas competitivas de negocios con TI, en lugar de sólo intentar administrar la complejidad creciente. Al emplear modelos de optimización de infraestructuras para ver hacia dónde se dirige su negocio en los próximos dos años, puede aprovechar al máximo sus sistemas actuales y planear un futuro más dinámico.
En general, el ciclo de vida de TI de una compañía existe en una de cuatro etapas. Básica: "Combatimos imprevistos" Estandarizada: "Ganamos el control" Racionalizada: "Facilitamos el negocio" Dinámica: "Somos un activo estratégico". Estas etapas se analizan con todo detalle en microsoft.com/io. Puede usar la información en ese sitio para analizar su infraestructura y planear para su futuro. Mediante la aplicación de conceptos de sistemas dinámicos, puede convertir su organización de TI en un activo clave de negocio.
Una vez que su organización alcanza la etapa dinámica, sus sistemas de TI serán activos de negocio autoadministrados y estratégicos. Ah, la Nirvana de TI. La mejor manera de progresar de etapa en etapa en su búsqueda de una TI dinámica es a través de la familia System Center de soluciones de administración de TI. System Center ofrece herramientas de configuración, aplicaciones de implementación, un administrador de operaciones y mucho más; abarca el ciclo de vida completo de TI en cuanto al planeamiento, la implementación y el mantenimiento.
Y, por supuesto, TechNet Magazine lo puede ayudar. Este número se centra en el conjunto de soluciones System Center. Comienza con amplias introducciones a dos componentes clave: System Center Configuration Manager 2007 y System Center Operations Manager 2007, también se analiza la implementación y las operaciones, e incluso cómo administrar correctamente sucursales.
¿Su infraestructura está a la altura? Venga y visite nuestro blog en la dirección blogs.technet.com/tnmag y cuéntenos hasta dónde cree que TI dinámica lo llevará. —Joshua Trupin

Joshua Trupin


Cuadro de herramientas Nuevos productos para profesionales de TI
Greg Steen

Administre los datos de configuración de arranque
VistaBootPRO
www.vistabootpro.org
Todos los profesionales de TI tienen por lo menos uno o dos equipos con arranque múltiple. Hoy en día, esos sistemas incluyen generalmente una sesión de Windows Vista® o Windows Server® 2008, anteriormente designado con el nombre en código "Longhorn". Si ejecuta un sistema con arranque múltiple con alguno de estos sistemas operativos, quizás desee echar un vistazo a VistaBootPRO de PROnetworks.
Como seguramente sabe, a partir de Windows Vista y en adelante, Microsoft ha cambiado la manera en que se administra la configuración de arranque. En vez de usar un archivo de texto legible como Boot.ini, ahora obtiene el almacén de datos de configuración de arranque (BCD). Esto ofrece un enfoque más seguro e independiente del firmware para administrar los detalles del entorno de arranque. Existen tres maneras básicas de ver y modificar su BCD. La primera es usar MSConfig, que le ofrece acceso básico para leer, modificar y reordenar entradas en el BCD. Es probable que los administradores del sistema estén más familiarizados con la segunda opción, que es usar la herramienta de línea de comandos BCDEdit. Con esta herramienta, se puede crear un nuevo almacén BCD, modificar almacenes existentes e importar y exportar almacenes para archivar y volver a usar. La tercera opción es administrar el BCD mediante programación mediante la API del Instrumental de administración de Windows® (WMI).
Los tres métodos realizan el trabajo, pero ninguno de ellos es especialmente fácil de usar. Aquí es donde VistaBootPRO entra en acción, con una GUI más descriptiva para modificar la configuración de arranque en su equipo que ejecuta Windows Vista. La herramienta le permite cambiar el nombre de las entradas de sistema operativo fácilmente, agregar nuevas entradas, cambiar la unidad de disco de arranque y configurar las opciones de tiempo de espera sólo con uno o dos clics. Además, VistaBootPRO le permite seleccionar una entrada de sistema operativo y establecer parámetros de inicio, tales como limitar las CPU disponibles para el sistema operativo, habilitar o deshabilitar prevención de ejecución de datos en entradas de Windows Vista o Windows Server 2008, reducir la memoria física disponible para el sistema operativo y ejecutar el proceso de arranque en modo de depuración.
Antes de realizar cualquier cambio en su BCD por medio de esta herramienta, debe realizar copias de seguridad de su almacén actual en caso de que algo salga mal. La aplicación le advertirá si no ha hecho una copia de seguridad, y le ofrecerá una manera fácil de exportar la configuración actual. Y, por supuesto, VistaBootPRO le permite restaurar las configuraciones de copia de seguridad.
Con todo ello, VistaBootPRO es una aplicación sencilla de usar y bien equipada para administrar su BCD. Y lo mejor de todo, es gratis.

Precio: Gratis.
Figura de vistabootpro
Figura de vistabootpro (Hacer clic en la imagen para ampliarla)

Supervisión de servicios y dispositivos
NetGong
netgong.tsarfin.com
¡Ah!, herramientas de supervisión; me parece imposible obtener suficiente de ellas. Si está dispuesto a comprar un nuevo supervisor de servicios de red y dispositivos, o simplemente le gustan las utilidades de supervisión como pasatiempo, consulte NetGong.
La aplicación se ejecuta en la bandeja del sistema y se inicia cuando inicia Windows. Un simple clic con el botón secundario en el icono ofrece una opción para iniciar o detener rápidamente la supervisión. Con doble clic en el icono aparece la interfaz de usuario de la configuración principal, desde donde puede configurar, revisar y consultar eventos en hosts supervisados.
Configurar la supervisión de un host es sencillo. Simplemente escriba el host, el puerto TCP que desea supervisar, el intervalo en que se deben realizar las pruebas y el tipo de alerta que desea recibir. También puede agregar una descripción significativa y modificar la configuración predeterminada de ICMP (Protocolo de mensajes de control de Internet), tal como tiempo de espera, tamaño de paquete y número de reintentos. De forma predeterminada, NetGong necesita que el host supervisado responda a solicitudes ICMP, pero también puede invalidar esa opción con una casilla para hosts silenciosos que no aceptan solicitudes ICMP en su red.
La aplicación le ofrece cuatro categorías de alerta: sonidos, correo electrónico, mensajes y archivo. Para sonidos, puede especificar el archivo WAV que desea usar. Para mensajes, puede definir un mensaje de texto, forzarlo para que sea la ventana de nivel superior y elegir si la ventana se debe cerrar de forma automática o manual. Las alertas de correo electrónico le permiten especificar un servidor SMTP y los detalles del mensaje que envía. Y la opción de alerta de archivo le permite ejecutar un archivo ejecutable (o archivo por lotes) con parámetros configurables, modo de ventana y directorio de inicio. En cualquiera de los tipos de alerta, puede configurar una programación que define cuándo enviar la primera alerta, el número máximo de alertas a enviar y el intervalo de error (número de errores) entre alertas. También tiene la opción de recibir notificaciones durante la recuperación del servicio.
NetGong también mantiene archivos de registro de los resultados. Tiene la opción de registrar los eventos en un registro de eventos, un archivo de texto o una página HTML creada dinámicamente. La aplicación permite ver los resultados de la supervisión en páginas que se visualizan a través de su servidor web integrado que escucha en un puerto especificado por el usuario. Además, puede enviar un parámetro de cadena de consulta con un intervalo de actualización para que la página web se actualice con los últimos detalles de los eventos supervisados.

Precio: 79,95 dólares directos por equipo (licencia corporativa), 59,95 dólares directos por equipo (licencia académica), 39,95 dólares directos por equipo (licencia doméstica).
Figura de steen.toolbox.netgong
Figura de steen.toolbox.netgong (Hacer clic en la imagen para ampliarla)

Reseña de libro
Windows PowerShell: TFM
www.sapienpress.com
Seguramente, ya ha oído hablar de Windows PowerShell™. Parece que todos están hablando de él. TechNet Magazine le dedica incluso un artículo (que casualmente está escrito por uno de los autores de este libro). ¿Pero realmente ha profundizado en él?
Windows PowerShell puede ser una herramienta de automatización y productividad muy eficaz una vez que el usuario llega a dominar su uso. Tanto si recién comienza con scripting como si ya es un ninja de VBScript que busca ampliarse hacia este nuevo lenguaje de scripting centrado en administración y conjunto de herramientas de línea de comandos, Windows PowerShell: TFM, por Don Jones y Jeffery Hicks, es un excelente sitio para comenzar. Este libro muy accesible está dirigido al administrador del sistema y hace un buen trabajo en centrarse en aquello que será de utilidad para la mayoría de los administradores.
La primera sección del libro presenta el entorno de Windows PowerShell y abarca los parámetros que la totalidad de los cmdlets tienen en común y los principios de la sintaxis y la semántica del lenguaje de scripting. También se presentan los conceptos de redirección, canalización de ejecución, funciones, variables y ejecución de shells múltiples. Dado que Windows PowerShell se basa en Microsoft® .NET Framework, hereda las ventajas del código administrado. (Tenga en cuenta que Windows PowerShell necesita .NET Framework 2.0 o posterior). Así que el libro también ofrece alguna perspectiva sobre aspectos fundamentales de Framework, desde el contexto de seguridad en que se ejecutan los scripts hasta conceptos de reflexión, ensamblados y clases.
Después de explicar cómo relacionar Windows PowerShell con Instrumental de administración de Windows (WMI), los autores analizan la estructura del lenguaje de scripting de Windows PowerShell con todo detalle, ofreciendo ejemplos que ayudan a comprender la función de los objetos y sus propiedades y métodos asociados. También podrá ver cómo usar los diferentes tipos de operadores, desde operadores aritméticos básicos hasta operadores de comparación de bit a bit, así como expresiones regulares eficaces para analizar cadenas de elementos tales como direcciones IP y nombres de controlador de dominio. Esta es una base especialmente útil para todos aquellos que tomen en serio el dominio de Windows PowerShell.
Los capítulos sobre administración de Windows y scripting de base de datos demuestran algunas de las grandes capacidades que ofrece Windows PowerShell. Verá cómo trabajar con registros de eventos, procesos, el Registro, el sistema de archivos y los servicios de directorio y también cómo conectar y ejecutar consultas en bases de datos.
Otras secciones abarcan generación y formato de datos, cómo generar scripts modulares, control de errores y depuración. Los autores ofrecen incluso un conjunto sugerido de recomendaciones para scripting de Windows PowerShell que incluyen convenciones de nombres, marcar comentarios en su código y uso de sangría para facilitar la lectura del código.
Ciertamente deseará tener el libro a mano para tener fácil acceso al material en los apéndices, uno de los cuales es una referencia para los 133 cmdlets de Windows PowerShell, mientras que el otro es una referencia para los tipos comúnmente más usados (y los métodos y propiedades asociados con estos tipos). Además de proporcionar una consulta rápida sobre cómo usar un cmdlet específico, estas referencias ofrecen una vista preliminar instantánea de la amplitud de las capacidades que ofrece Windows PowerShell.

Precio: 49,99 dólares de lista.

Pruebe sus cables
Dispositivo de comprobación de cables de red compacto SMARTest
www.hobbes-usa.com
¡Cables, cables por todas partes! Como profesionales de TI, la mayoría de nosotros está rodeado por cables CAT5. Montones de cables CAT5: cientos de cables trenzados, que se extienden por miles de metros. Y si es responsable de estos cables, un buen dispositivo de comprobación de cables, fácil de llevar, no sólo es útil, es esencial. Por ese motivo, quizás desee echar un vistazo al dispositivo de comprobación de cables de red compacto SMARTest de Hobbes.
El dispositivo SMARTest es un dispositivo de comprobación de cables de estilo lápiz. Es compatible con cables de red CAT 3, 4, 5, 5e y 6 y le puede ayudar a detectar los problemas comunes de conexionado del cable. Específicamente, puede comprobar pares abiertos, cortocircuitados, invertidos, con hilos faltantes, pares divididos y problemas de conexión a tierra en un cable trenzado.
El dispositivo funciona con cuatro baterías pequeñas de estilo reloj, así que sus cables no deben estar conectados para realizar la prueba; ni debe conectar SMARTest a una conexión de red activa. Para realizar la prueba de un cable, simplemente conecte un extremo del cable trenzado en la unidad principal y el otro en la unidad remota separable. La unidad SMARTest tiene una interfaz con ambos tipos de conectores RJ45, enchufe y clavija (hembra y macho), así que puede probar cualquier clase de instalación de cables. Incluso puede usar el dispositivo SMARTest para comprobar el cableado de sus paneles de conexiones y enchufes de pared.
Otra característica atractiva es que el dispositivo tiene una generación de tono incorporada que puede enviar una señal de audio a través del cable que prueba. A continuación, puede obtener la señal con una sonda de señal compatible, tal como la Cable Tracer Probe, también disponible en Hobbes.
SMARTest con generación de tono cuesta aproximadamente entre 80,00 a 90,00 dólares, según el minorista. También hay un adaptador F opcional para realizar pruebas de cables coaxiales.

Precio: 99,99 dólares de lista.
Figura steen.toolbox.smartest (Hacer clic en la imagen para ampliarla)

Greg Steen es un profesional emprendedor y entusiasta de la tecnología. Siempre está buscando nuevas herramientas y métodos para ayudar a simplificar las operaciones y el desarrollo para los profesionales de TI.


Preguntas y respuestas acerca de SQL Búsqueda de bloqueos, consultas de gran tamaño, estadísticas de E/S y mucho más.
Editado por Nancy Michell

Descargar el código de este artículo: SQLQandA2007_08.exe (151KB)

P Necesito ver los nombres de los objetos en todas las bases de datos que los tienen bloqueados. ¿Cómo puedo hacerlo?

R En SQL Server™ 2000, puede consultar la tabla de sistema syslocks en Masters o ejecutar sp_lock para obtener la información actual de bloqueo, tal como se indica a continuación:
SELECT * FROM master..syslocks
EXEC sp_lock
Sin embargo, digamos que quiere traducir los nombres de objeto reales del ObjID de la salida OUTPUT del procedimiento almacenado sp_lock (o de la columna id en master..syslocks).
En SQL Server 2005 SP1 y versiones anteriores, la función OBJECT_NAME sólo permitía pasar un parámetro: object_id. De modo que, para obtener correctamente el nombre de objeto, se requería trabajar en la base de datos CURRENT antes de ejecutar OBJECT_NAME. Esto hacía difícil la supervisión de bloqueos actuales, porque requería el esfuerzo de escribir código personalizado para recorrer cada base de datos y obtener el OBJECT_NAME correcto.
USE DBNAME
SELECT OBJECT_NAME(object_id)
SQL Server 2005 SP2 mejora al agregar un segundo parámetro, database_id. Este nuevo parámetro le permite consultar nombres de objeto independientemente de la base de datos CURRENT a la que está conectado.
OBJECT_NAME ( object_id [, database_id ] )
Ahora puede consultar sys.dm_tran_locks y recuperar el nombre de objeto de cada base de datos, de esta forma:
SELECT
DB_NAME(resource_database_id),
OBJECT_NAME(resource_associated_entity_id, resource_database_id)
FROM sys.dm_tran_locks
WHERE resource_type='OBJECT'
Observe, no obstante, que sólo funciona en SQL Server 2005 SP2 y versiones posteriores. Si lo ejecuta en una versión anterior de SQL Server 2005, obtendrá el siguiente error:
Msg 174, Level 15, State 1, Line 1
The object_name function requires 1 argument(s).
Otro ejemplo, que se muestra en la figura 1, une sys.dm_exec_sessions para obtener información acerca de los identificadores de proceso de servicios (SPIDS) implicados en los bloqueos. Para obtener más información, consulte los Libros en pantalla de SQL Server en la dirección technet.microsoft.com/library/ms130214(sql.90).aspx.
Figure 1 Búsqueda de identificadores de proceso de servidor
SELECT
DB_NAME(resource_database_id) as DBName,
OBJECT_NAME(resource_associated_entity_id, resource_database_id) AS ObjectName,
request_mode,
request_type,
request_session_id,
es.host_name,
es.login_name,
es.login_time
FROM
sys.dm_tran_locks tl
INNER JOIN sys.dm_exec_sessions es
ON tl.request_session_id=es.session_id
WHERE resource_type='OBJECT'

P Tengo una consulta SQL dinámica y de gran tamaño que a veces parece que supera la longitud de NVARCHAR(max). ¿Existe alguna forma de evitar esto y que todavía me permita ejecutar una cadena de gran tamaño?

R Si supera la longitud de NVARCHAR(max), obtendrá una consulta de 2 GB. Probablemente necesita convertir también todas las cadenas que concatena a NVARCHAR(max). Sin embargo, una solución alternativa más útil, que también tiene la ventaja de funcionar en versiones de SQL Server anteriores a SQL Server 2005, es concatenar varias cadenas más pequeñas entre sí. Por ejemplo:
DECLARE @q1 NVARCHAR(4000), @q2 NVARCHAR(4000), @q3 NVARCHAR(4000)
SET @q1 = 'SELECT...'
SET @q2 = 'FROM...'
SET @q3 = 'WHERE...'
EXEC (@q1 + @q2 + @q3)
Sugerencia: Uso de la cláusula OUTPUT
Ahora puede auditar los cambios que realiza mediante instrucciones DML (lenguaje de manipulación de datos) incluso sin usar desencadenadores. SQL Server 2005 incorpora una cláusula OUTPUT como parte de las instrucciones DML que permiten realizar el seguimiento de los cambios realizados durante cualquier operación de DML. La cláusula OUTPUT puede guardar resultset en una tabla o en una variable de tabla.
La funcionalidad es similar a la que tenían los desencadenadores con tablas INSERTED y DELETED, que se usaban para obtener acceso a las filas modificadas durante la operación de DML. Para ver el funcionamiento, cambiemos la dirección de la tabla de direcciones al orden inverso del valor original, tal como se muestra en la figura siguiente. También puede usar la lógica mostrada en este código para realizar el seguimiento de todos los cambios realizados en los datos y almacenarlos en una tabla.
El resultado de la consulta tendrá el siguiente aspecto:
Original Value:'1234 One Microsoft Way, Redmond, Wa.' has been changed to: '.aW,dnomdeR
,yaW tfosorciM enO 4321'

Cambio de una dirección
--Create the address table
Create Table Address (ProductID Int, SupplierID Int, Address Varchar(255))

--Insert data
Insert into Address Values (234,567,'1234 One Microsoft Way, Redmond, Wa.')

--Declare a table variable
Declare @Recordchanges table (change Varchar(255))

--Update the address
Update Supplier.Address
Set Address=reverse(address)

--Record the updates into the table variable
OUTPUT 'Original Value:' + DELETED.Address+' has been changed to: '+ INSERTED.Address+''
into @RecordChanges

--Query the changes from table variable
Select * from @RecordChanges

P Tengo una instalación en clúster de misión crítica de SQL 2005 en Windows Server ®2003. El coordinador de transacciones distribuidas de Microsoft® (MS DTC) se configuró en clúster en el mismo grupo de Cluster Quorum, pero usa un recurso de disco dedicado (MS DTC comparte el mismo nombre de red y dirección IP del grupo Cluster Quorum). Deseo que esta configuración cumpla con las recomendaciones de Microsoft. Por lo tanto, necesito consejo para mover MS DTC a un grupo de clúster dedicado. ¿Es suficiente con quitar los servicios de MS DTC mediante la herramienta Cluster Admin y volverlo a crear en un grupo dedicado?

R Dado que ya cuenta con un recurso de disco dedicado para MS DTC, debería poder simplemente eliminar el recurso y volver a crearlo en un grupo nuevo. También debe crear un nuevo nombre de red y dirección IP virtual en el nuevo grupo.
Como alternativa, podría crear el nuevo nombre de red y dirección IP en el grupo de clúster y cambiar las dependencias a los nuevos recursos. A continuación, puede arrastrar MS DTC a un nuevo grupo y de esta manera tomará consigo el disco dedicado y los nuevos recursos.

P Necesito ver estadísticas de E/S en los archivos de base de datos físicos en una base de datos. ¿Qué debería usar?

R La función del sistema fn_virtualfilestats, disponible en SQL Server 2000 y SQL Server 2005, o sys.dm_io_virtual_file_stats (sólo en SQL Server 2005) le permite hacer exactamente lo que busca. La función devuelve información estadística recopilada desde la última vez que se inició la instancia de SQL Server. Los resultados de ejemplo se muestran en la figura 2.
Figure 2 Visualización de estadísticas de E/S en una base de datos

DBId | FileId | TimeStamp | NumberReads | NumberWrites | BytesRead | BytesWritten | IoStallMS
20 | 1 | 250765718 | 381 | 0 | 3350528 | 0 | 951
20 | 2 | 250765718 | 12 | 8 | 409600 | 491520 | 0
20 | 3 | 250765718 | 5 | 0 | 40960 | 0 | 16
Comprender el impacto de E/S en los archivos de datos subyacentes le puede ayudar a planear mejor cosas como, por ejemplo, la ubicación física de archivos y grupos de archivos en los volúmenes de datos, detectar posibles cuellos de botella de E/S, realizar el mantenimiento de base de datos en el nivel de archivos, entre otras tareas. Esta función es especialmente útil a la hora de examinar el impacto de E/S en bases de datos de gran tamaño, donde puede haber múltiples archivos y grupos de archivos.
La consulta para mostrar la información de E/S de archivos para SQL Server 2000 tiene el aspecto siguiente:
SELECT *
FROM ::fn_virtualfilestats(default,default)
GO
Para ver un databaseID específico, pase el identificador de la base de datos, tal como se indica a continuación:
SELECT *
FROM ::fn_virtualfilestats(7,default)
GO
Este es el código de SQL Server 2005 que muestra las estadísticas de archivos de todas las bases de datos en el servidor:
SELECT *
FROM ::fn_virtualfilestats(NULL,NULL)
GO
La siguiente consulta devuelve las estadísticas de archivos sólo para la base de datos actual:
SELECT *
FROM ::fn_virtualfilestats(NULL,NULL)
WHERE DBID=db_id()
GO
En SQL Server 2005, existe también una nueva función de sistema denominada sys.dm_io_virtual_file_stats, que está pensada para reemplazar en algún momento a la función heredada fn_virtualfilestats:
sys.dm_io_virtual_file_stats(
{ database_id | NULL },
{ file_id | NULL }
)
A continuación se muestra cómo se usa:
SELECT * FROM sys.dm_io_virtual_file_stats(NULL,NULL)
Si desea generar un informe más legible que muestre los nombres de base de datos y nombres de archivo reales de la salida, puede usar el código de la descarga que acompaña en SQL Server 2000 o SQL Server 2005. El código está disponible en el sitio web de TechNet Magazine.

P Necesito una manera fácil de ver si una transacción de eliminación ha activado un desencadenador. ¿Sabe cómo puedo obtener esta información?

R Cuando se trabaja con desencadenadores que controlan acciones de eliminación, inserción y actualización, las personas comúnmente usan varias técnicas diferentes para determinar si un desencadenador fue activado por una transacción de eliminación. Un método popular es comparar los contadores de las tablas virtuales insertadas y eliminadas para ver si coinciden. Sin embargo, hay un método más sencillo: Puede usar la función Columns_Updated.
Eso se debe a que cuando un desencadenador se activa mediante una transacción de eliminación, Columns_Updated siempre devuelve el valor varbinary 0x. Con la acción siguiente se comprobará que el desencadenador fue activado por una eliminación:
IF Columns_Updated() = 0x
Sugerencia: Inicialización de los archivos de datos y de registro
¿Sabía que los archivos de datos y registro se inicializan para sobrescribir todos los datos existentes de archivos anteriormente eliminados que quedan en el disco? Los archivos de datos y registro se inicializan por primera vez completando los archivos con ceros cuando se crea una base de datos; se agregan archivos, de registro o datos, a una base de datos existente; se aumenta el tamaño de un archivo existente (incluidas las operaciones autogrow) o se restaura un grupo de base de datos o archivos. La inicialización de archivos hace que estas operaciones lleven más tiempo. Sin embargo, cuando los datos se escriben por primera vez a los archivos, el sistema operativo no tiene que completar los archivos con ceros.
En SQL Server 2005, los archivos de datos se pueden inicializar instantáneamente. Esta capacidad permite la ejecución rápida de las operaciones de archivo mencionadas. La inicialización instantánea de archivos recupera espacio en disco usado sin completar ese espacio con ceros. En lugar de eso, el contenido del disco se sobrescribe a medida que los nuevos datos se escriben en los archivos. Los archivos de registro no se pueden inicializar instantáneamente. La inicialización instantánea de archivos sólo está disponible en Windows XP Professional y Windows Server 2003 o en versiones posteriores.
Debido a que el contenido eliminado del disco se sobrescribe sólo cuando los nuevos datos se escriben en los archivos, personal no autorizado podría tener acceso al contenido eliminado. Aunque el archivo de base de datos se adjunta con la sesión de SQL Server, esta amenaza de divulgación de información se reduce mediante la lista de control de acceso discrecional (DACL) en el archivo. Esta DACL permite que sólo la cuenta de servicio de SQL Server y el administrador local tengan acceso a los archivos. Sin embargo, cuando el archivo se separa, un usuario o servicio que no tenga se_manage_volume_name puede tener acceso a él. Una amenaza similar existe cuando se realiza la copia de seguridad de la base de datos. El contenido eliminado puede pasar a estar a disposición de un usuario o servicio no autorizado si el archivo de copia de seguridad no está protegido con una DACL apropiada.
Si la posibilidad de divulgación de contenido eliminado representa un problema, siempre debe asegurase que todos los archivos de datos y de copia de seguridad separados tengan DACL restrictivas. Además, deshabilite la inicialización instantánea de archivos para la sesión de SQL Server mediante revocación de se_manage_volume_name de la cuenta de servicio de SQL Server.

Thanks to the following Microsoft IT pros for their technical expertise: Christian Bolton, Dan Carollo, Robert Davis, Jorge Guzman, Saleem Hakani, Ward Pond, Kalyan Yella, and Paolo Zavatarelli.


Utility Spotlight BGInfo
Lance Whitney

Descargar el código de este artículo: BgInfo v4.10 (274KB)

Está intentado resolver un problema con el equipo PC de un usuario y necesita información acerca del equipo: nombre, dirección IP, puerta de enlace, memoria, espacio libre en disco, etcétera. La recopilación de todos estos datos generalmente requieren realizar una búsqueda en las diversas fuentes de información o agobiar al usuario con una lluvia de preguntas. ¿No sería más práctico si todo lo que necesitase saber acerca de un equipo estuviese en un único lugar? Ahora esto es posible gracias a una herramienta gratis de Sysinternals llamada BGInfo.
Escrito por Bryce Cogswell, BGInfo (abreviación del inglés Background Information) hace consultas a una estación de trabajo o servidor de Windows® en búsqueda de datos clave: desde estadísticas relacionadas con la red (dirección IP, enrutador, nombre de dominio, dirección MAC) hasta información acerca del hardware y software (nombre del equipo, memoria, versión del sistema operativo y nivel de Service Pack). El programa luego muestra todos esos datos en el escritorio como parte del papel tapiz, donde la información estará claramente visible sin ser moleta (consulte la figura 1).
Figura 1 BGInfo muestra información de sistema en el escritorio
Figura 1 BGInfo muestra información de sistema en el escritorio (Hacer clic en la imagen para ampliarla)
Para ejecutar BGInfo, haga doble clic en el archivo bginfo.exe (no se necesita instalación previa). La pantalla de configuración aparece para que se puedan revisar y seleccionar los campos de datos que se deben mostrar. De forma predeterminada, BGInfo revela 24 elementos de datos diferentes. Se puede quitar cualquier campo que no se debe mostrar y, a continuación, agregarlo más tarde si cambia de opinión. También puede especificar fácilmente campos adicionales. BGInfo mostrará cualquier variable de entorno, la mayoría de los valores del Registro y el resultado de las consultas de VBScript e Instrumental de administración de Windows (WMI). La interfaz WMI proporciona una manera sencilla de crear consultas mediante la selección de valores desde un menú desplegable. BGInfo también puede usar determinados archivos para mostrar información acerca de la versión, la marca de tiempo y contenido.
La pantalla se puede personalizar mucho. Es posible modificar los distintos atributos de texto como, por ejemplo, la alineación, la fuente, el tamaño y el color. Además, puede jugar con la posición de los datos en secciones diferentes del escritorio y especificar el ancho máximo de su área de visualización en pulgadas. Por último, BGInfo permite agregar gráficos junto con los datos de texto, por lo que se puede insertar una imagen tal como el logotipo de su empresa. Como alternativa, si decide que no desea mostrar toda esta información en el escritorio, simplemente configure BGInfo como un icono en la bandeja del sistema. Haga clic en él y aparecerá la pantalla completa.
Después de definir las opciones de formato, puede hacer clic en el botón Preview para comprobar la pantalla antes de confirmarla y, a continuación, aplicarla si le parece correcta. BGInfo se puede ejecutar manualmente en cualquier equipo cuando lo necesite, o bien se puede mantener actualizado automáticamente. Para actualizar los datos con regularidad, agregue el archivo BGInfo.exe a la carpeta de inicio o establézcalo como una tarea programada. Después que haber personalizado BGInfo en un equipo, probablemente querrá usar la misma configuración en otros equipos. Para ello, guarde la configuración como un archivo BGI y luego puede cargue dicho archivo en los demás equipos que ejecutan el programa.
Aunque BGInfo se puede ejecutar en un único equipo PC a la vez, quizás desee activarlo en múltiples clientes de red. Para ello, puede insertar el archivo bginfo.exe en un script de inicio de sesión. El programa ofrece varias opciones de línea de comandos para controlar su comportamiento. Los datos que BGInfo recopila también se pueden exportar a un archivo externo: un archivo de texto, una hoja de cálculo Excel®, una base de datos Acces™ o una base de datos SQL. De este modo, podrá disponer de un recurso práctico de todas las estadísticas de sus equipos en red.
La información de la ayuda que se incluye con BGInfo es completa y fácil de seguir. Incluso ofrece sugerencias de cómo escribir consultas sencillas de VBScript y WMI cuyo resultado puede ser capturado por BGInfo. El programa se ejecuta en todas las versiones de Windows, desde Windows 95 a Windows Vista®. Obtenga más información acerca de BGInfo y descargue esta herramienta desde la dirección microsoft.com/technet/sysinternals/Miscellaneous/BgInfo.mspx.

Lance Whitney es consultor, instructor y escritor técnico de TI. Ha pasado cientos y cientos de horas trabajando con estaciones de trabajo y servidores de Windows. Periodista en sus inicios, dio un giro hacia el mundo de TI hace unos 15 años.


The Cable Guy Configuración automática de IPv6 en Windows Vista
Joseph Davies

IPv6 se centra en más que en la extensión del espacio de direcciones de 32 bits en IPv4 a 128 bits. Los hosts IPv6 también se pueden configurar de forma automática, incluso sin usar un protocolo de configuración de direcciones tal como DHCP para IPv6 (DHCPv6).
Basados en RFC 2462, todos los nodos IPv6 configuran de forma automática una dirección local de vínculo en cada interfaz. Un host IPv6 usa también detección de enrutador (un intercambio de mensajes de solicitud de enrutador y anuncio de enrutador) para determinar direcciones adicionales y opciones de configuración. En el mensaje de anuncio de enrutador enviado por el enrutador se incluyen los marcadores de configuración de dirección administrada (M) y otra configuración con estado (O), que indican si el host debe usar DHCPv6 para direcciones adicionales u opciones de configuración.

Tipos de configuración automática de IPv6
Más allá de las direcciones locales de vínculo, los hosts también pueden usar la configuración automática sin estado para configurar direcciones y otras opciones en función de la recepción de mensajes de anuncio de enrutador. Estos mensajes pueden incluir una o más opciones de información de prefijo, que el host receptor puede usar para derivar direcciones sin estado.
De forma similar, la configuración automática con estado es la configuración de direcciones y otras opciones basada en el uso de DHCPv6 para la obtención de direcciones. Un host usa la configuración automática con estado cuando recibe un mensaje de anuncio de enrutador con el marcador M establecido en 1.
Por último, un host también puede usar ambos tipos de configuración automática con estado y sin estado, que es una combinación de direcciones incluidas en el anuncio de enrutador y obtenida de un servidor DHCPv6.

Estados de direcciones configuradas de forma automática
Cuando una dirección configurada de forma automática está en estado provisional, se está comprobando si es una dirección exclusiva mediante la detección de dirección duplicada (DAD). Consulte la barra lateral "Proceso de configuración automática de IPv6 - RFC 2462" para obtener más información acerca de cómo se realiza DAD. Una dirección en estado válido se ha comprobado como exclusiva y se puede usar para enviar y recibir tráfico de unidifusión. El estado válido incluye los estados preferido y obsoleto. En el estado preferido, la dirección se puede usar para comunicaciones sin límites. En el estado obsoleto, la dirección no se debe usar en nuevas comunicaciones; sin embargo, las comunicaciones existentes que usan la dirección pueden continuar.
Proceso de configuración automática de IPv6 - RFC 2462
Los pasos siguientes describen el proceso de configuración automática de un host IPv6 según se define en RFC 2462:
  • Derivar una dirección local de vínculo provisional con un identificador de interfaz (id.) de identificador exclusivo extendido de 64 bits (EUI-64).
  • Realizar DAD en la dirección local de vínculo provisional enviando un mensaje de solicitud de vecino con dirección de destino en el mensaje establecida en la dirección local de vínculo provisional.
  • Si se recibe un mensaje de anuncio de vecino en respuesta al mensaje de solicitud de vecino, la dirección local de vínculo provisional es una dirección duplicada. Detener la configuración automática de dirección. En este momento, se debe realizar la configuración manual en el host.
  • Si no se recibe un mensaje de anuncio de vecino (en respuesta al mensaje de solicitud de vecino), la dirección local de vínculo provisional es exclusiva. Cambiar el estado de la dirección en la interfaz a preferido.
  • Enviar un mensaje de solicitud de enrutador.
  • Si no se reciben mensajes de anuncio de enrutador, usar DHCPv6 para obtener las direcciones y otros parámetros de configuración.
  • Si se recibe un mensaje de anuncio de enrutador, configurar direcciones provisionales para los prefijos incluidos y realizar detección de dirección duplicada en cada dirección provisional. Si las direcciones son exclusivas, cambiar el estado de las direcciones en la interfaz a preferido.
  • Si el marcador M en el mensaje de anuncio de enrutador está establecido en 1, usar DHCPv6 para obtener direcciones activas adicionales.
  • Si el marcador M en el mensaje de anuncio de enrutador está establecido en 0 y el marcador O está establecido en 1, usar DHCPv6 para obtener parámetros adicionales de configuración.

Un anuncio de enrutador o servidor DHCPv6 especifica la vigencia válida y preferida para un prefijo de dirección. Una dirección ingresa en el estado obsoleto después que se supera la vigencia preferida de la dirección. La vigencia preferida de una dirección configurada de forma automática se actualiza cuando se reciben anuncios de enrutador o se renueva la configuración de la dirección DHCPv6. La figura 1 muestra los estados de una dirección configurada de forma automática y su relación con las vigencias preferida y válida.
Figura 1 Estados de una dirección configurada de forma automática
Figura 1 Estados de una dirección configurada de forma automática (Hacer clic en la imagen para ampliarla)
Con la excepción de la configuración automática para direcciones locales de vínculo, la configuración automática de dirección sólo se especifica para hosts IPv6. Los enrutadores IPv6 deben obtener los parámetros de dirección y configuración a través de otros medios, tales como la configuración manual.
La barra lateral "Proceso de configuración automática de IPv6 - RFC 2462" describe el proceso detallado de configuración automática de dirección IPv6 para hosts que se definen en RFC 2462.

Comportamiento de la configuración automática de IPv6 en Windows Vista
Los equipos que ejecutan Windows Vista® o Windows Server® 2008, anteriormente designado con el nombre en código "Longhorn", de forma predeterminada, generan identificadores de interfaz aleatorios para direcciones IPv6 permanentes configuradas de forma automática, que incluyen direcciones públicas y locales de vínculo, en lugar de los identificadores de interfaz basados en EUI-64. Una dirección IPv6 pública es una dirección global que se registra en DNS y típicamente se usa en aplicaciones de servidor para conexiones entrantes, tal como un servidor web. Puede deshabilitar este comportamiento predeterminado con el comando siguiente:
netsh interface ipv6 set global randomizeidentifiers=disabled
Cuando está deshabilitado, IPv6 usa los identificadores de interfaz basados en EUI-64.
Con un identificador de interfaz derivado de forma aleatoria, la posibilidad de que duplique la dirección local de vínculo es muy pequeña. Por lo tanto, los equipos que ejecutan Windows Vista o Windows Server 2008 no esperan que DAD se complete antes de enviar mensajes de solicitud de enrutador mediante sus direcciones locales de vínculo derivadas. Esto se conoce como DAD optimista; la detección de enrutador y DAD se realiza en paralelo para ahorrar tiempo durante el proceso de inicialización de la interfaz.
Los equipos que ejecutan Windows Vista o Windows Server 2008 no intentan realizar la configuración automática de dirección con estado mediante DHCPv6 si no se reciben anuncios de enrutador.
Proceso de configuración automática de IPv6 en Windows Vista
Los pasos siguientes describen el proceso de configuración automática de un host IPv6 que ejecuta Windows Vista:
  • Derivar una dirección local de vínculo provisional para la interfaz LAN con un identificador de interfaz derivada de forma aleatoria (configuración predeterminada).
  • Realizar DAD para la dirección local de vínculo derivada de la interfaz LAN (enviar un mensaje de solicitud de vecino con el campo de dirección de destino establecido en la dirección local de vínculo provisional).
  • Realizar la detección de enrutador en la interfaz LAN (enviar un mensaje de solicitud de enrutador desde la dirección local de vínculo provisional).
  • Si se recibe un mensaje de anuncio de vecino en respuesta al mensaje de solicitud de vecino enviado en el paso 2, marcar la dirección local de vínculo como un duplicado.
  • Si no se reciben mensajes de anuncio de vecino en respuesta al mensaje de solicitud de vecino, cambiar el estado de la dirección local de vínculo en la interfaz LAN a preferido.
  • Si no se reciben anuncios de enrutador, detener la configuración automática de dirección IPv6 en la interfaz LAN. Ir al paso 13.
  • Si se recibe un anuncio de enrutador, crear direcciones públicas provisionales correspondientes a los prefijos de dirección local global o exclusiva en el mensaje según el identificador de interfaz derivado de forma aleatoria en el paso 1, y realizar DAD.
  • Crear direcciones temporales provisionales correspondientes a los prefijos de dirección local global o exclusiva en el mensaje mediante los nuevos identificadores de interfaz derivados de forma aleatoria, y realizar DAD.
  • Para cada nueva dirección, si no se reciben mensajes de anuncio de vecino en respuesta a mensajes de solicitud de vecino, cambiar el estado de la dirección en la interfaz LAN a preferido.
  • Si el anuncio de enrutador tiene los marcadores M y O establecidos en 0, detener la configuración automática de IPv6 en la interfaz LAN. Ir al paso 13.
  • Si el anuncio de enrutador tiene el marcador M establecido en 1, usar DHCPv6 para obtener ambas direcciones IPv6 con estado y opciones de configuración adicionales.
  • Si el anuncio de enrutador tiene el marcador M establecido en 0 y el marcador O establecido en 1, usar DHCPv6 para obtener opciones de configuración adicionales.
  • Derivar direcciones ISATAP locales de vínculo según las direcciones IPv4 de la interfaz LAN y asignarlas a la interfaz de túnel ISATAP.
  • Intentar resolver el nombre de host "ISATAP" con una dirección IPv4.
  • Si el nombre de host "ISATAP" no se puede resolver, detener la configuración IPv6.
  • Si el nombre de host "ISATAP" se resuelve con una dirección IPv4, enviar una solicitud de enrutador con encapsulado IPv4 al enrutador ISATAP.
  • Si se recibe un anuncio de enrutador del enrutador ISATAP, crear las direcciones ISATAP adicionales correspondientes a los prefijos de dirección local global o exclusiva anunciados y asignarlas a la interfaz de túnel ISATAP.

Direcciones configuradas de forma automática para Windows Vista
Como se describió anteriormente, el protocolo IPv6 para Windows Vista y Windows Server 2008 configura de forma automática las direcciones locales de vínculo mediante identificadores de interfaz derivados de forma aleatoria para todas las interfaces LAN.
Si un anuncio de enrutador recibido incluye un prefijo local global o exclusivo, IPv6 configura direcciones locales globales o exclusivas que usan el mismo identificador de interfaz derivado de forma aleatoria y los asigna a la interfaz LAN que recibió el anuncio de enrutador. Estas direcciones se conocen como direcciones públicas.
IPv6 en Windows Vista también configura de forma predeterminada direcciones locales globales o exclusivas temporales mediante diferentes identificadores de interfaz derivados de forma aleatoria y los asigna a la interfaz LAN que recibió el anuncio de enrutador. Las direcciones temporales se definen en RFC 3041 y se usan para ofrecer un nivel de anonimato en comunicaciones iniciadas por clientes. En cambio, IPv6 en Windows Server 2008 no crea de forma predeterminada direcciones temporales. Puede habilitar direcciones temporales mediante el comando siguiente:
netsh interface ipv6 set privacy-enabled
Si el marcador M se establece en 1 en los mensajes de anuncio de enrutador recibidos, IPv6 usa DHCPv6 para configurar direcciones locales globales o exclusivas adicionales para la interfaz LAN.
IPv6 crea también una interfaz de túnel ISATAP para cada interfaz LAN en el host. RFC 4214 describe la tecnología de transición IPv6 de ISATAP. Con ISATAP, los hosts IPv6 se pueden comunicar a través de una Intranet de sólo IPv4 mediante encapsulado de paquetes IPv6 con encabezados IPv4. Para obtener más información acerca de ISATAP, consulte "Tecnologías de transición de IPv6".
Para cada interfaz de túnel ISATAP, IPv6 configura direcciones ISATAP locales de vínculo para las direcciones IPv4 que están asignadas a su interfaz LAN correspondiente. Por ejemplo, para la interfaz de túnel ISATAP correspondiente a una interfaz de LAN que tiene asignada la dirección IPv4 192.168.91.211, IPv6 asigna la dirección ISATAP local de vínculo FE80::0:5EFE:192.168.91.211.
Los host ISATAP también llevan a cabo la detección de enrutador ISATAP. Para recibir un anuncio de enrutador de un enrutador ISATAP, de forma predeterminada IPv6 debe poder resolver el nombre de host "ISATAP" con una dirección IPv4. Esto se realiza a través de métodos de resolución de nombres de host basados en Windows tales como DNS. Después que se resuelve el nombre, el host envía una solicitud de enrutador con encapsulado IPv4 al enrutador ISATAP. A continuación, el enrutador ISATAP envía un anuncio de enrutador con encapsulado IPv4 al host. Según el contenido del anuncio de enrutador recibido, IPv6 configura también las direcciones ISATAP locales globales o exclusivas en las interfaces de túnel ISATAP.
Windows Vista también es compatible con las tecnologías de transición 6to4 y Teredo IPv6. Sin embargo, para no complicar las cosas, no abordaré la configuración automática de interfaces de túnel 6to4 y Teredo de un host IPv6 basado en Windows Vista en este artículo.
La barra lateral "Proceso de configuración automática de IPv6 en Windows Vista" describe el proceso de configuración automática de direcciones para un host IPv6 basado en Windows Vista con una única interfaz LAN que se configura con prefijos de dirección local global o exclusiva en sus interfaces LAN o de túnel ISATAP.
Por ejemplo, un host que ejecuta Windows Vista tiene una única interfaz LAN. El host recibe un anuncio de enrutador en su interfaz LAN con ambos marcadores M y O establecidos en 0 y contiene los prefijos 2001:DB8:D005:F282::/64 y FD4A:3A9:27A1:F282::/64. No recibe un mensaje de anuncio de enrutador de un enrutador ISATAP. La figura 2 es un ejemplo de la salida que resulta del comando
Figure 2 Resultado de netsh interface ipv6 show address
Interface 1: Loopback Pseudo-Interface 1

Addr Type DAD State Valid Life Pref. Life Address
--------- ----------- ---------- ---------- ------------------------
Other   Preferred  infinite infinite ::1

Interface 8: Local Area Connection

Addr Type DAD State Valid Life Pref. Life Address
--------- ----------- ---------- ---------- ------------------------
Temporary Preferred 6d19h37m21s 6d19h37m21s 2001:db8:d005:f282:ed46:5dd4:5439:2e1c
Public  Preferred  infinite infinite 2001:db8:d005:f282:3521:12fa:2c44:87d1
Temporary Preferred 6d19h37m21s 6d19h37m21s fd4a:3a9:27a1:f282:ed46:5dd4:5439:2e1c
Public   Preferred  infinite infinite fd4a:3a9:27a1:f282:3521:12fa:2c44:87d1
Other   Preferred  infinite infinite fe80::3521:12fa:2c44:87d1%8

Interface 17: Local Area Connection* 9

Addr Type DAD State Valid Life Pref. Life Address
--------- ----------- ---------- ---------- ------------------------
Other   Preferred  infinite infinite fe80::5efe:10.47.181.92%17

netsh interface ipv6 show address
en este host de ejemplo. En la figura, la interfaz de túnel ISATAP correspondiente a la interfaz LAN denominada Local Area Connection se denomina Local Area Connection* 9.
Además de direcciones configuradas de forma automática, el protocolo IPv6 para Windows Server 2008 y Windows Vista admite configuración manual de direcciones IPv6 estáticas mediante el uso del siguiente comando
netsh interface ipv6 add address
o mediante el componente Protocolo de Internet versión 6 (TCP/IPv6) de las propiedades de una conexión en la carpeta de conexiones de red.
A lo largo del artículo de este mes, hice la suposición que el lector cuenta con conocimientos generales en el direccionamiento y el funcionamiento del protocolo IPv6. Si necesita obtener más información acerca de este tema, le sugiero comenzar con el artículo "Introducción a IPv6," que se encuentra en la dirección microsoft.com/technet/ network/ipv6/introipv6.mspx.

Joseph Davies es escritor técnico de Microsoft y enseña y escribe sobre temas de red de Windows desde 1992. Ha escrito cinco libros para Microsoft Press y es autor del artículo mensual Cable Guy de TechNet.


Windows PowerShell El poder del filtrado
Don Jones

En la columna del mes pasado, hablé sobre la efectividad y flexibilidad de la canalización de Windows PowerShell, que permite pasar un conjunto de datos (o, más exactamente, una secuencia de objetos) de un cmdlet a otro, y posteriormente perfeccionarlo hasta obtener exactamente el que se necesita. En mi análisis, hice referencia al hecho de que los propios scripts del usuario,
no sólo los cmdlets, también pueden sacar provecho de la canalización. Este mes quiero tratar ese tema con todo detalle.
Una de las cosas más frecuentes que hago en Windows PowerShell™ es escribir scripts que actúan en varios equipos remotos, generalmente a través de Instrumental de administración de Windows® (WMI). Como con cualquier tarea relacionada con equipos remotos, siempre existe la posibilidad de que ése u otros equipos no estén disponibles cuando se ejecute el script. Por lo tanto, necesito que mis scripts puedan tratar esta situación.
Por supuesto, hay varias maneras a través de las cuales puedo otorgar a un script la capacidad de controlar el tiempo de espera de una conexión WMI, pero, personalmente, no me gusta ese método, ya que el período de tiempo de espera es muy largo, casi 30 segundos de forma predeterminada. Si tuviese que esperar a que se dieran muchos tiempos de espera, esto haría que mi script se ejecutase mucho más lentamente. En cambio, quiero que mi script realice una comprobación rápida para consultar si un equipo concreto está realmente conectado antes de intentar conectarme a él.

Paradigma de Windows PowerShell
En otros lenguajes de scripting, tal como VBScript, normalmente trataría con un equipo a la vez. Es decir, recuperaría un nombre de equipo, quizás de una lista de nombres almacenada en un archivo de texto, y enviaría un ping al sistema para comprobar si éste está disponible. Si lo está, procedería con la conexión WMI y realizaría cualquier otra labor que necesitase. Esto es un método de uso común de scripting. De hecho, yo escribiría probablemente todo mi código en un bucle y entonces repetiría ese bucle una vez para cada equipo al que necesitase conectarme.
Windows PowerShell, sin embargo, es más idóneo para realizar operaciones por lotes gracias a su base en objetos y su capacidad para trabajar directamente con grupos o colecciones de objetos. El paradigma en Windows PowerShell es que no funciona con objetos únicos ni partes de datos, sino que funciona más bien con grupos enteros, perfeccionando el grupo poco a poco hasta haber alcanzado cualquier objetivo. Por ejemplo, en vez de recuperar un nombre de equipo de mi lista uno a la vez, leería en una acción la recopilación entera de nombres. Y en vez de enviar un ping a cada equipo en un bucle, escribiría una sola rutina que aceptase una recopilación de nombres, les enviaría un ping y, entonces, obtendría aquellos con los que me habría podido poner en contacto. El paso siguiente de mi proceso sería efectuar mi conexión WMI a los nombres restantes, aquellos que se pudieron alcanzar a través de un ping.
Windows PowerShell usa este mismo método exacto en varias tareas. Por ejemplo, para obtener una lista de servicios ejecutados, puedo usar algo como lo siguiente:
Get-Service | Where-Object { $_.Status –eq "Running" }
La figura 1 muestra cómo se ve el resultado en mi equipo. En vez de comprobar cada servicio de uno en uno, usé Get-Service para recuperar todos los servicios, a éstos los canalicé a Where-Object y, a continuación, filtré todos los que no se estaban ejecutando. Esto es más o menos lo que quiero hacer con mi script: obtener una lista de nombres de equipos, filtrar todos a los que no se puede enviar un ping y pasar esta lista de equipos a los que se puede enviar un ping al paso siguiente.
Figura 1 Obtener una lista de equipos a los que se puede enviar un ping
Figura 1 Obtener una lista de equipos a los que se puede enviar un ping (Hacer clic en la imagen para ampliarla)

Funciones de filtrado
Aunque puedo escribir mi propio cmdlet para hacer esto mismo, no quiero. La creación de un cmdlet requiere el uso de Visual Basic® o C# y bastante experiencia de desarrollo con Microsoft® .NET Framework. Y lo que es más importante, requiere una mayor inversión de la que yo quiero poner en esta tarea. Afortunadamente, Windows PowerShell me permite escribir un tipo especial de función, llamada filtro, que es perfectamente capaz de actuar dentro de la canalización. El diseño básico de una función de filtrado tiene el aspecto siguiente:
function <name> {
  BEGIN {
    #<code>
  }
  PROCESS {
    #<code>
  }
  END {
    #<code>
  }
}
Como puede ver, esta función contiene tres bloques independientes de scripts, denominados BEGIN, PROCESS y END. Una función de filtrado, es decir, una función diseñada para funcionar dentro de la canalización para filtrar objetos, puede disponer de cualquier combinación de estos tres bloques de scripts, en función de lo que se desee hacer. Estos funcionan de la siguiente manera:
  • El bloque BEGIN se ejecuta una vez cuando se llama a la función por primera vez. Puede usarse para hacer el trabajo de instalación, si es necesario.
  • El bloque PROCESS se ejecuta una vez para cada objeto de canalización que se pasa a la función. La variable $_ representa el objeto de entrada de la canalización actual. El bloque PROCESS es obligatorio en una función de filtrado.
  • El bloque END se ejecuta una vez, después de que se hayan procesado todos los objetos de la canalización. Este bloque puede usarse para cualquier trabajo de ultimación, si fuera necesario.
En mi ejemplo, pretendo producir una función de filtrado que acepte una recopilación de nombres como objetos de entrada y que, entonces, intente enviar un ping a cada uno. Los que reciban el ping correctamente pasarán a la canalización, mientras que los sistemas que no puedan recibir el ping simplemente se descartarán. Dado que la funcionalidad de ping no requiere ninguna instalación ni ultimación especiales, simplemente usaré el bloque de script PROCESS. El código en la figura 2 proporciona el script completo.
Figure 2 Ping-Address y Restart-Computer
1  function Ping-Address {
2    PROCESS {
3      $ping = $false
4      $results = Get-WmiObject -query `
5      "SELECT * FROM Win32_PingStatus WHERE Address = '$_'"
6      foreach ($result in $results) {
7        if ($results.StatusCode -eq 0) {
8          $ping = $true
9        }
10      }
11      if ($ping -eq $true) {
12        Write-Output $_
13      }
14    }
15  }
16
17  function Restart-Computer {
18    PROCESS {
19      $computer = Get-WmiObject Win32_OperatingSystem -computer $_
20      $computer.Reboot()
21    }
22  }
23
24  Get-Content c:\computers.txt | Ping-Address | Restart-Computer
Observe que definí dos funciones: Ping-Address y Restart-Computer. En Windows PowerShell, las funciones deben definirse antes de ser invocadas. Como resultado, la primera línea ejecutable de mi script es la línea 24, que usa el cmdlet Get-Content para obtener una lista de nombres de equipo de un archivo (un nombre de equipo por línea). Esa lista, que técnicamente es una colección de objetos de cadena, se canaliza a la función que dirige el ping, la cual filtra los equipos que no pueden recibir un ping. Los resultados se canalizan a la función Restart-Computer, que usa la conexión para reiniciar de forma remota los equipos que sí pueden recibir un ping.
La función Ping-Address implementa un bloque de script PROCESS, los que significa que la función espera una recopilación de entrada de objetos. El bloque de script PROCESS trata con esa entrada automáticamente; no tuve que definir ningún argumento de entrada para incluirla. Inicio el proceso en la línea 3 al establecer la variable $ping en $false, que es una variable integrada de Windows PowerShell que representa el valor booleano False.
A continuación, uso la clase local WMI Win32_PingStatus para enviar el ping al equipo especificado. Observe en la línea 5 que la variable $_, que representa el objeto de canalización actual, está incrustada dentro de la cadena de consulta WMI. Cuando una cadena se incluye entre comillas dobles, Windows PowerShell siempre intentará reemplazar las variables tal como $_ con su contenido, de modo que no es necesario preocuparse por la concatenación de la cadena. Uso esa capacidad en la línea 5.
La línea 6 es un bucle que comprueba los resultados de mi ping. Si cualquiera de los resultados es correcto (es decir, el StatusCode es cero), establezco el valor $ping igual a $true para indicar ese resultado correcto. En la línea 11, compruebo si $ping se estableció en $true. En caso afirmativo, envío el objeto de entrada original a la secuencia de salida predeterminada. Windows PowerShell administra la secuencia de salida predeterminada de manera automática. Si esta función se da al final de la canalización, entonces la secuencia de salida se convierte en una representación de texto. Si hay más comandos en la canalización, entonces los objetos de secuencia de salida (en este caso, los objetos de cadena que contienen los nombres de equipo) pasan al comando siguiente de la canalización.
La función Restart-Computer es algo más sencilla, pero también usa un bloque PROCESS para que pueda participar fácilmente en la canalización. En la línea 19, la función se conecta al equipo denominado y recupera su clase WMI Win32_OperatingSystem. La línea 20 ejecuta el método de la clase Reboot para reiniciar el equipo remoto.
De nuevo, la línea 24 es donde de hecho se ejecuta todo. Por supuesto, se debe ser muy cauteloso al ejecutar este script, ya que está diseñado para rearrancar todos los equipos denominados en c:\computers.txt, lo cual podría tener definitivamente unos resultados desastrosos si no se presta atención a los nombres de ese archivo de texto.

Pasos siguientes
Este script no está totalmente a prueba de balas. Debo reconocer también de que existe la posibilidad de que se dé un error WMI no relacionado con la conectividad básica, como por ejemplo, que el firewall bloquee los puertos necesarios en el equipo remoto o que se produzca un error de seguridad de WMI. Estos problemas se pueden controlar si se implementa un controlador de capturas, cosa que suena a tema perfecto para una próxima columna.
Asimismo, este script realiza una acción bastante importante: reiniciar un equipo remoto. Cualquier script que intenta dicha acción potencialmente peligrosa debe implementar dos parámetros comunes de Windows PowerShell: –Confirm y –WhatIf. Explicar cómo se realiza esta operación requiere más espacio del que dispongo aquí, pero también sería otro gran tema para una columna en el futuro. Mientras tanto, puede visitar el blog del equipo de Windows PowerShell: el arquitecto Jeffrey Snover cubre este tema.
Incluso sin entrar en detalle con estas características, puede obtener una buena idea de lo que pueden hacer las funciones de filtrado. Voy a perfeccionar esta técnica en columnas venideras, para así mostrar que estas funciones pueden proporcionar una buena manera de modularizar código que se puede volver a usar, así como mejorar la funcionalidad de sus scripts en general.

Don Jones es el principal gurú de scripting de SAPIEN Technologies y coautor de Windows PowerShell: TFM (SAPIEN Press, 2007). Póngase en contacto con Don en la dirección www.ScriptingAnswers.com.


¡Hola, encargados del scripting! ¿Quién es usted?
Los encargados del scripting

Descargar el código de este artículo: HeyScriptingGuy2007-082007_08.exe (152KB)

Hace poco, el encargado del scripting que escribe este artículo miraba un juego del béisbol en televisión. Cuando el juego terminó, decidió leer una revista pero dejó la televisión encendida. Cuando terminó de leer la revista, levantó la vista hacia la televisión y descubrió que estaba mirando una vieja película de la segunda guerra mundial. De hecho, levantó la vista justo en el momento que los actores estaban en medio de una de esas situaciones comprobadas y ciertas: un joven soldado norteamericano está de guardia a última hora de la noche cuando oye un ruido.
"¿Quién es usted?" ladró el centinela.
"Soy yo, el sargento Smith", contestó una voz.
"¿Sargento Smith? No hay ningún sargento Smith en esta unidad."
"Soy nuevo aquí; acabo de ser transferido desde la Compañía A."
"¿Ah, sí? De la Compañía A? Está bien, Smith: ¿Quién ganó la serie mundial de 1934?"
"The New York Yankees."
"¡Respuesta equivocada, Smith!" (Como se puede imaginar, fue detenido de inmediato y arrojado al bergantín). Cualquier buen estadounidense, uno de verdad, sabe que The St. Louis Cardinals, el equipo de Dizzy Dean y Gas House Gang, ganaron la serie mundial de 1934. Quien no lo sepa sólo puede ser una cosa: un espía.
Si quien lee el artículo de este mes no sabía que The St. Louis Cardinals ganaron la serie mundial de 1934, bueno, todo lo que podemos decir es lo siguiente: no hay esperanzas; sabemos que es un espía. Esperamos que tenga la amabilidad de dirigirse a la oficina del FBI más cercana. O que por lo menos nos llame; cuando se trata de espías, el FBI recoge y entrega.
Cuando el encargado del scripting que escribe esta columna miró, se dio cuenta que tenía buenas posibilidades de contestar la segunda pregunta del centinela: ¿Quién ganó la serie mundial de 1966? The Baltimore Orioles. ¿La serie mundial de 1960? Pittsburgh Pirates. ¿La serie mundial de 1994? ¡Ah! Una pregunta con trampa: no hubo serie mundial en 1994.
Sin embargo, hoy en día y en esta época, tendría dificultades para contestar la primera pregunta: ¿quién es usted? Esa no es hoy una pregunta tan fácil como quizás lo era allá en los años cuarenta. Después de todo, sólo en Active Directory® los usuarios pueden tener una gran cantidad de identidades diferentes, que incluyen:
  • Su nombre (givenName).
  • Su apellido (sn).
  • Su nombre para mostrar (displayName).
  • Su nombre principal de usuario (userPrincipalName).
  • Su nombre de inicio de sesión (samAccountName).
  • Su nombre distintivo (distinguishedName).
Todos estos nombres identifican a la misma persona, y todos son nombres que, según las circunstancias, es importante conocer. Y eso es un problema. La mayoría de los usuarios conocen su nombre y apellido. Pero, si le pregunta a un usuario: "¿Cuál es su nombre distintivo?" sólo algunos pocos podrán contestar, "Bueno, ¡eso es sencillo! Soy CN=Ken.Myer, OU=Finance, DC=fabrikam, DC=com. Pero todos mis amigos me llaman CN=Ken.Myer".
Como administrador del sistema o como persona de soporte técnico, también necesita conocer estos nombres. Pero, ¿cómo se supone que obtiene esta información? Bueno, un método sería torturar a sus usuarios hasta que finalmente le digan su nombre distintivo. Probablemente esto funcionaría, pero la mayoría de los departamentos de recursos humanos desalientan hoy día ese tipo de cosas. Así que quizás tenga que recurrir al plan B: un script. ¿Qué clase de script? Bueno, para comenzar, ¿qué tal el script de la figura 1?
Figure 1 Recuperación de atributos de usuario con ADSystemInfo
On Error Resume Next

Set objSysInfo = CreateObject("ADSystemInfo")
strUser = objSysInfo.UserName

Set objUser = GetObject("LDAP://" & strUser)
WScript.Echo "First Name: " & objUser.givenName
WScript.Echo "Last Name: " & objUser.sn
WScript.Echo "Display Name: " & objUser.displayName
WScript.Echo "User Principal Name: " & objUser.userPrincipalName
WScript.Echo "SAM Account Name: " & objUser.sAMAccountName
WScript.Echo "Distinguished Name: " & objUser.distinguishedName
Vaya, ¿y si sólo el sargento Smith habría estudiado VBScript, eh? Este script aprovecha un objeto ADSI poco conocido (pero muy útil) denominado ADSystemInfo. Se trata de un pequeño objeto ingenioso que puede devolver todo tipo de información sobre el usuario que tiene una sesión iniciada en el equipo local, así como sobre el propio equipo local y el dominio al que pertenece. Por ejemplo, eche un vistazo a la figura 2.
Figure 2 Muestre todo tipo de información de dominio
On Error Resume Next

Set objSysInfo = CreateObject("ADSystemInfo")

Wscript.Echo "User name: " & objSysInfo.UserName
Wscript.Echo "Computer name: " & objSysInfo.ComputerName
Wscript.Echo "Site name: " & objSysInfo.SiteName
Wscript.Echo "Domain short name: " & objSysInfo.DomainShortName
Wscript.Echo "Domain DNS name: " & objSysInfo.DomainDNSName
Wscript.Echo "Forest DNS name: " & objSysInfo.ForestDNSName
Wscript.Echo "PDC role owner: " & objSysInfo.PDCRoleOwner
Wscript.Echo "Schema role owner: " & objSysInfo.SchemaRoleOwner
Wscript.Echo "Domain is in native mode: " & objSysInfo.IsNativeMode
No obstante, por hoy, la única propiedad que nos interesa es la propiedad UserName. ¿Qué tiene de especial UserName? Bueno, resulta que corresponde a la propiedad distinguishedName. ¿Y qué tiene de especial distinguishedName? Bueno, distinguishedName es similar a una ruta de acceso de archivo UNC: Al igual que una ruta de acceso UNC nos permite identificar exclusivamente un archivo en alguna parte de nuestra red, distinguishedName (por ejemplo, CN=Ken.Myer, OU=Finance, DC=fabrikam, DC=com) nos permite identificar exclusivamente una cuenta de usuario en Active Directory. A su vez, nos permite enlazar esa cuenta de usuario. Y una vez que hemos hecho esa conexión, podemos recuperar cualquier información que deseamos acerca de un usuario, incluso quién es.
Y es exactamente eso lo que hacemos en el primer script que le mostramos. Para empezar, creamos una instancia del objeto ADSystemInfo y le asignamos el valor de la propiedad UserName a una variable denominada strUser:
Set objSysInfo = CreateObject("ADSystemInfo")
strUser = objSysInfo.UserName
Observe que aquí no tenemos mucho para hacer. Por ejemplo, no tenemos que especificar el nombre de usuario, dominio de usuario, ni la unidad organizativa en la que reside la cuenta de usuario; ADSystemInfo hace todo eso por nosotros. Una vez que tenemos el distinguishedName del usuario, lo podemos enlazar a su cuenta de usuario por medio de esta línea de código:
Set objUser = GetObject("LDAP://" & strUser)
Y, nuevamente, una vez que realizamos la conexión podemos devolver los valores de cualquiera de los atributos de Active Directory de esa cuenta. En nuestro script de ejemplo, simplemente hemos devuelto algunas propiedades del nombre del usuario, pero también podríamos haber recuperado el número de teléfono, la ubicación de la oficina, la dirección de correo electrónico, etc.
Eso es fantástico. Todo lo que tiene que hacer es repartir este script a todos sus usuarios y nunca más tendrán que preguntarse: "¿Quién soy"? (O, si lo hacen, tendrán una manera rápida y fácil de resolverlo). Pero qué sucede con una pregunta relacionada: ¿quién es usted? Una cosa es poder identificar el usuario que ha iniciado sesión en equipo local. ¿Pero cómo puede determinar quién ha iniciado sesión en un equipo remoto? Como se puede imaginar, ese es el hueso más duro de roer.
Y, disculpe, también lo pensamos. Lamentablemente no puede apuntar nuestro script de ADSystemInfo a un equipo remoto. La razón por la que no puede es porque el objeto ADSystemInfo sólo se puede crear de forma local. Eso nos deja tres posibilidades:
  • Crear un script de inicio de sesión que registre el nombre del usuario que ha iniciado sesión en alguna ubicación de fácil acceso.
  • Usar la clase Win32_ComputerSystem de WMI y la propiedad UserName.
  • Hacer otra cosa.
La primera opción suena muy atrayente. Como se habrá dado cuenta, el objeto ADSystemInfo puede devolver el nombre distintivo del equipo (la propiedad ComputerName) así como el nombre distintivo del usuario. Considere, si le parece, el script de ejemplo que se muestra en la figura 3.
Figure 3 Script de inicio de sesión
On Error Resume Next

Set objSysInfo = CreateObject("ADSystemInfo")

strUser = objSysInfo.UserName
strComputer = objSysInfo.ComputerName

Set objUser = GetObject("LDAP://" & _
    strUser)
strUserName = objUser.displayName

Set objComputer = GetObject("LDAP://" & _
    strComputer)
objComputer.Description = strUserName
objComputer.SetInfo
¿Qué hacemos aquí? Para comenzar, tomamos los valores de las propiedades UserName y ComputerName y los almacenamos en un par de variables (strUser y strComputer). A continuación, los enlazamos a la cuenta de usuario en Active Directory (igual que antes), recuperamos el valor del atributo displayName (igual que antes) y almacenamos ese valor en una variable denominada strUserName. ¿Bastante sencillo, no?
A continuación, podemos usar esta línea de código para realizar la conexión a la cuenta de equipo de Active Directory:
Set objComputer = GetObject("LDAP://" & _
    strComputer)
Una vez establecida esa conexión, asignamos el displayName del usuario a la propiedad Description del equipo y, a continuación, llamamos al método SetInfo para escribir ese cambio en Active Directory:
objComputer.Description = strUserName
objComputer.SetInfo
¿Por qué hacemos esto? Muy fácil. Suponga que Ken Myer se conecta al equipo atl-ws-01. ¿Adivina cuál será el valor de la propiedad Description del equipo atl-ws-01? Exacto: Ken Myer, la misma persona que tiene una sesión iniciada en el equipo. ¿Desea saber quién tiene una sesión iniciada en atl-ws-01? Sólo compruebe la propiedad Description.
Ahora, en general, este escenario funciona bastante bien y funciona aún mejor si dispone de un script de cierre de sesión que desactiva la propiedad Description cada vez que el usuario cierre sesión. Sin embargo, no es una solución infalible. ¿Por qué? Bueno, los scripts de inicio de sesión no siempre se ejecutan. Por ejemplo, normalmente no se ejecutan cuando los usuarios inician sesión mediante RAS. De forma similar, un script de inicio de sesión no se ejecuta si un usuario desconecta su conexión de red, inicia sesión con credenciales almacenadas en la memoria caché y luego vuelve a conectar el equipo a la red. Y suponga que un usuario apaga su equipo sin cerrar sesión. Eso significa que su script de cierre de sesión nunca se ejecutará. En ese caso, Ken Myer supuestamente todavía tendrá una sesión iniciada en atl-ws-01 aunque el equipo ni siquiera está en funcionamiento. Es decir, es una técnica de gran utilidad, pero...
Entonces, ¿qué le parece la opción 2, usar la clase Win32_ComputerSystem? Nuevamente, a menudo funcionará, pero el problema con la clase Win32_ComputerSystem es que no siempre devuelve el nombre del usuario que tiene una sesión iniciada, especialmente para los usuarios que no tienen derechos de administrador (y especialmente, para equipos con Windows® 2000). El script en la figura 4 probablemente le dirá quién tiene una sesión iniciada en un equipo pero, nuevamente, sin ninguna garantía.
Figure 4 Averigüe con WMI quién tiene una sesión iniciada
strComputer = "."

Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")
Set colItems = objWMIService.ExecQuery("Select * From Win32_ComputerSystem")

For Each objItem in colItems
  Wscript.Echo objItem.UserName
Next
A propósito, en este caso la propiedad UserName se obtiene con el formato dominio\nombre de usuario. En otras palabras: FABRIKAM\kenmyer.
Ah, casi nos olvidamos: incluso si se obtiene un nombre, eso no significa que un usuario tenga realmente una sesión iniciada en el equipo. Cuando Ken Myer sale del sistema atl-ws-01, su nombre se retiene como valor de la propiedad UserName y no se reemplaza hasta que alguien inicia nuevamente una sesión.
Vaya.
Pero espere; eso no nos convierte en espías. Este es otro método que podemos aplicar. Si alguien tiene una sesión iniciada en el equipo, es muy probable que el proceso Explorer.exe se esté ejecutando. En general, si Explorer.exe no se ejecuta, significa que nadie tiene una sesión iniciada en el equipo. Y dado que Explorer.exe se ejecuta bajo las credenciales del usuario que tiene una sesión iniciada, casi siempre podemos determinar quién ha iniciado sesión en un equipo por medio de un script similar al que se muestra en la figura 5.
Figure 5 Determinación del propietario de Explorer.exe
strComputer = "atl-ws-01"

Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")

Set colItems = objWMIService.ExecQuery _
  ("Select * from Win32_Process Where Name = 'explorer.exe'")

If colItems.Count = 0 Then
  Wscript.Echo "No one is logged on to the computer."
Else
  For Each objProcess in colItems
    objProcess.GetOwner strUser, strDomain
    Wscript.Echo strDomain & "\" & strUser
  Next
End If
Como puede ver, en este caso realizamos una conexión al servicio WMI en un equipo remoto (atl-ws-01, para ser precisos). A continuación, usamos esta línea de código para recuperar una colección de todas las instancias de la clase Win32_Process con el nombre Explorer.exe:
Set colItems = objWMIService.ExecQuery _
  ("Select * from Win32_Process Where " & _
  "Name = 'explorer.exe'")
Y ahora, ¿qué? Bien, como mencionamos hace un instante, si Explorer.exe no se ejecuta, es muy probable de que nadie tenga una sesión iniciada en el equipo. ¿Cómo sabemos si Explorer.exe se encuentra en ejecución? Una manera muy sencilla es comprobar el valor de la propiedad Count de la colección. Si Count es igual a 0, tenemos una colección vacía y la única manera que podemos tener una colección vacía es si no hay sesiones de Explorer.exe en ejecución en atl-ws-01. En este caso, devolvemos un mensaje que dice que nadie ha iniciado sesión en el equipo:
Wscript.Echo "No one is logged on " & _
"to the computer."
Si Count no es igual a 0, establecemos un bucle For Each para avanzar por pasos por la colección de procesos con el nombre Explorer.exe (y sí, suponemos que nuestra colección tendrá invariablemente sólo un elemento). En cada sesión de Explorer.exe llamamos al método GetOwner para determinar de quién es la cuenta con la que se ejecuta Explorer.exe:
objProcess.GetOwner strUser, strDomain
Observe que pasamos a GetOwner un par de parámetros de salida: strUser y strDomain. Los parámetros de salida simplemente son variables a las que asignamos un nombre y suministramos a un método; el método asignará valores a esos parámetros de salida. En este caso, a strUser se asignará el nombre de inicio de sesión del usuario conectado (kenmyer) y a strDomain se asignará el nombre de dominio del usuario conectado (FABRIKAM). Todo lo que debemos hacer es devolver los valores de estos dos parámetros de salida:
Wscript.Echo strDomain & "\" & strUser
¿Sabe qué? Eso es bastante bueno. Pero podemos dar un paso más. Cuando usamos el método GetOwner, obtenemos el nombre de inicio de sesión (samAccountName) para el usuario que tiene una sesión iniciada en el equipo. Eso es bueno, pero como mencionamos antes, los usuarios tienen todo tipo de nombres además de samAccountName. Para responder sinceramente a la pregunta "¿Quién es usted?" sería útil conocer, digamos, el displayName del usuario. Pero ¿podemos determinar estos otros nombres usando GetOwner?
No, no podemos. Sin embargo, podemos tomar samAccountName, insertarlo en un script de búsqueda de Active Directory y, a continuación, ubicar la cuenta de usuario con ese nombre de inicio de sesión y enlazarla (una tarea que resulta más fácil por el hecho que samAccountName debe ser exclusivo en un dominio). Y una vez que enlazamos la cuenta de usuario, podemos devolver los valores de cualquier propiedad de Active Directory, incluido displayName.
No tenemos tiempo para explicar el script de la figura 6 con todo detalle. Si desea obtener más información acerca de cómo realizar búsquedas en Active Directory, eche un vistazo a "Amigo, ¿dónde está mi impresora?". Es suficiente decir que este script determina el nombre de inicio de sesión del usuario conectado, busca en Active Directory el usuario con ese nombre de inicio de sesión (samAccountName), enlaza la cuenta de usuario en cuestión y, a continuación, devuelve el displayName del usuario. ¡Y todo con una mano atada detrás de su espalda!
Figure 6 Enlace al usuario que ha iniciado la sesión
strComputer = "atl-ws-01"

Set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")

Set colItems = objWMIService.ExecQuery _
  ("Select * from Win32_Process Where Name = 'explorer.exe'")

If colItems.Count = 0 Then
  Wscript.Echo "No one is logged on to the computer."
Else
  For Each objProcess in colItems
    objProcess.GetOwner strUser,strDomain
  Next
End If

Const ADS_SCOPE_SUBTREE = 2

Set objConnection = CreateObject("ADODB.Connection")
Set objCommand = CreateObject("ADODB.Command")
objConnection.Provider = "ADsDSOObject"
objConnection.Open "Active Directory Provider"
Set objCommand.ActiveConnection = objConnection

objCommand.Properties("Page Size") = 1000
objCommand.Properties("Searchscope") = ADS_SCOPE_SUBTREE

objCommand.CommandText = "SELECT displayName FROM " & _
  "'LDAP://DC=wingroup,DC=fabrikam,DC=com' WHERE " & _
    "objectCategory='user' " & _
    "AND samAccountName = '" & strUser & "'"
Set objRecordSet = objCommand.Execute

objRecordSet.MoveFirst

Do Until objRecordSet.EOF
  Wscript.Echo objRecordSet.Fields("displayName").Value
  objRecordSet.MoveNext
Loop
¿Así que cuáles son los elementos clave que debemos retener del artículo de hoy? (A propósito, ese es el modo en que habla la gente de Microsoft. Si quiere volver totalmente loco al encargado del scripting, simplemente dígale algo como: "Necesitamos seleccionar los elementos clave y de acción, así como los objetivos obsoletos para todos los interesados"). Bueno, en primer lugar, ahora sabemos cómo obtener información acerca del usuario que ha iniciado sesión en un equipo (tanto en el equipo local o como en uno remoto). Más importante, sabemos que si alguna vez nos damos un salto en el tiempo y nos encontramos en la segunda guerra mundial: hay que tener una copia de este artículo (para que pueda contestar la pregunta "¿Quién es usted?"), y haga lo que haga, siempre lleve una lista de los ganadores de la serie mundial de béisbol. Después de todo, nunca sabe cuándo alguien le va a preguntar, "¿Quién ganó la serie mundial de 1903?".
Nota: The Boston Red Sox. A propósito, esta fue la primera de todas las series mundiales. Ahora, ¿quién se supone que ganó la serie mundial de 1904? Qué quiere decir, ¿no lo sabe? Discúlpenos un segundo; necesitamos realizar una llamada telefónica...

Los encargados del scripting trabajan para Microsoft, mejor dicho, están contratados por Microsoft. Cuando no juegan al béisbol, ni entrenan ni lo ven (u otras actividades varias), dirigen el TechNet Script Center. Visite la página web www.scriptingguys.com.


Vigilancia de seguridad Mejoras de PKI en Windows
John Morello

Este artículo se basa en una versión preliminar de Windows Server 2008. Por tanto, toda la información de este documento está sujeta a cambios.

Windows ha ido incluyendo una sólida compatibilidad con una amplia variedad de plataformas para la infraestructura de claves públicas (PKI) desde el lanzamiento de Windows 2000. Ese lanzamiento incluía la primera capacidad nativa de entidad de certificación, incorporó la inscripción automática y ofreció compatibilidad con la autenticación basada en tarjetas inteligentes. En Windows XP y Windows Server 2003, esas
capacidades se ampliaron con el objetivo de ofrecer opciones de inscripción más flexibles con las plantillas de certificados de la versión 2, además de más compatibilidad con la inscripción automática de certificados de usuario. En Windows Vista® y Windows Server® 2008 (originariamente, bajo el nombre en código "Longhorn"), la plataforma PKI de Windows® da otro paso en su avance hacia una mayor compatibilidad con los algoritmos avanzados, comprobaciones de validez en tiempo real y mejoras de la capacidad de administración. Esta columna analiza las nuevas características de PKI que hay en Windows Vista y Windows Server 2008, y cómo pueden las empresas hacer uso de ellas de forma que se reduzcan los costos y aumente la seguridad.
Las mejoras de PKI en Windows Vista y Windows Server 2008 se centran en cuatro pilares principales: la criptografía, la inscripción, la capacidad de administración y la revocación. Además de estas mejoras específicas de sus características, la plataforma PKI de Windows también se beneficia de otros avances del sistema operativo, tal como el administrador de funciones, que facilita la creación e implementación de las nuevas autoridades de certificación (CA). Asimismo, muchas otras partes de Windows pueden sacar provecho de las mejoras conseguidas en la plataforma PKI, tal como la compatibilidad en Windows Vista para usar tarjetas inteligentes para el almacenamiento de las claves de sistema del cifrado de archivos (EFS).

Criptografía
Las mejoras en el pilar de la criptografía son doble. En primer lugar, con la introducción de la criptografía de próxima generación (CNG), Windows ofrece ahora una capacidad acoplable de cifrado que no distingue protocolos y que hace que cada algoritmo individualmente sea más fácil de desarrollar y de tener acceso mediante programación. En segundo lugar, CNG aporta una nueva compatibilidad con los algoritmos de la Suite B que introdujo la Agencia de Seguridad Nacional (NSA) de Estados Unidos en 2005.
CNG es una interfaz de criptografía nueva y fundamental para Microsoft, además de ser la API recomendada para aplicaciones futuras de Windows, compatibles con el sistema criptográfico. CNG proporciona un host con una funcionalidad nueva centrada en el desarrollador, que incluye un sistema de detección y de sustitución de los algoritmos más fácil, generadores reemplazables de números aleatorios y una API cifrada en modo kernel. Gracias a estas capacidades nuevas, CNG se vuelve compatible con versiones anteriores mediante el conjunto de algoritmos que se incluían en la versión anterior, CryptoAPI 1.0. Actualmente, CNG está siendo evaluado para la certificación FIPS 140-2 nivel 2 así como para criterios comunes en plataformas seleccionadas.
La compatibilidad de la Suite B de CNG incluye todos los algoritmos necesarios: AES (todos los tamaños de clave), la familia SHA-2 (SHA-256, SHA-384 y SHA-512) de algoritmos hash, la curva elíptica Diffie-Hellman (ECDH) y la curva elíptica del algoritmo de firma digital (ECDSA) por encima de las curvas estándar principales P-256, P-384 y P-521 del Instituto Nacional de Estándares y Tecnología (NIST) de Estados Unidos. La NSA ha determinado que las implementaciones certificadas de la Suite B se usarán para proteger información clasificada como altamente secreta, secreta e información privada que, en un pasado, se describió como confidencial pero no clasificada. Todos los algoritmos de la Suite B se desarrollaron abiertamente y ahora algunos otros gobiernos están estudiando también adoptarlos como estándares nacionales.
Estas mejoras de nivel inferior en la plataforma PKI de Windows ofrecen a los desarrolladores métodos más seguros para la protección de datos, y al mismo tiempo se crea un subsistema que es más fácil de mantener y de mejorar con el tiempo. Dado que CNG es una arquitectura acoplable, los algoritmos nuevos pueden agregarse a medida que son necesarios y CNG abstrae estos proveedores del nivel de la aplicación. El resultado claro es que Windows Vista y Windows Server 2008 están diseñados para ofrecer una plataforma avanzada y con capacidad de evolución para desarrollar las aplicaciones y servicios activados con PKI.

Inscripción
La experiencia de la inscripción de certificados en Windows ha mejorado increíblemente gracias a una herramienta nueva de inscripción basada en asistentes, un control mejorado de la expiración de los certificados, una API nueva, una capacidad de "inscribirse en nombre de" y credenciales móviles. Estas capacidades mejoradas permiten reducir el costo total de propiedad de una PKI, lo que hace que sea más fácil implementar certificados en las empresas mediante una administración centralizada y con un impacto mínimo sobre el usuario.
El cambio más notable desde un punto de vista de la inscripción es la nueva interfaz de usuario de inscripción de certificados, la cual se muestra en las figuras 1 y 2. Esta interfaz de usuario reemplaza la versión anterior, que era más limitada y que carecía de la capacidad para aceptar datos de los usuarios durante el proceso de la inscripción. La nueva interfaz permite a los usuarios especificar datos durante la inscripción (si el administrador configura la plantilla de certificado para que los requiera). La interfaz también proporciona explicaciones claras de por qué un usuario quizás no puede inscribirse a una plantilla concreta.
Figura 1 Selección de los certificados disponibles
Figura 1 Selección de los certificados disponibles (Hacer clic en la imagen para ampliarla)
Figura 2 Estado de los certificados no disponibles
Figura 2 Estado de los certificados no disponibles (Hacer clic en la imagen para ampliarla)
Otra mejora clave de la interfaz de inscripción se encuentra en el control de los certificados que expiran. La nueva interfaz ofrece a los usuarios finales información clara acerca de cuáles son los certificados que expiran y permite a los usuarios renovar fácilmente certificados o desestimar las advertencias de la propia interfaz. Aunque los administradores pueden actualizar automáticamente los certificados a través de la inscripción, esta capacidad de advertencias es importante para los usuarios móviles o desconectados que quizás inician sesión en la red corporativa pocas veces y que tienen certificados a punto de expirar.
Para los desarrolladores que trabajan con la inscripción de certificados, hay una nueva API disponible que ofrece importantes mejoras sobre los controles anteriores basados en ActiveX® (xenroll.dll y scrdernl.dll). La nueva API para la inscripción de certificados proporciona una jerarquía de clases bien definida y que es mucho más sencilla de entender y de codificar. Esta nueva API reemplaza xenroll tanto en Windows Vista como en Windows Server 2008.
Este cambio en la API repercuta sobre los desarrolladores y profesionales de TI, ya que los clientes Windows Vista no pueden usar las capacidades de inscripción basadas en web que se proporciona en Windows Server 2003. Esto se debe a que las páginas de inscripción (almacenadas en el directorio virtual de /certsrv de forma predeterminada) usan el control xenroll que ya no está presente en Windows Vista. El artículo de Knowledge Base "Cómo usar páginas de servicios web de inscripción de certificados con Windows Vista" (support.microsoft.com/kb/922706) ofrece información acerca de una solución alternativa. La inscripción automática desde Windows Server 2003 a Windows Vista no se ve afectada.
En versiones anteriores de Windows Server, los agentes de inscripción no quedaban limitados a aquellos en nombre de los cuales podían inscribirse. Es decir, una vez que un usuario recibía habilidades de agente de inscripción, podía inscribirse en nombre de cualquier otro usuario en el bosque. Por supuesto, esto significaba que ese usuario podía traspasar sus privilegios, ya que se inscribía en nombre de un usuario existente y suplantaba a ese usuario con el certificado recién creado. En un intento para derrotar esta amenaza, las habilidades de agente de inscripción se otorgaban sólo a usuarios de gran confianza. Aunque este método mejoraba la seguridad, hacía también que los modelos de implementación fueran menos flexibles, ya que sólo un número pequeño de usuarios podían inscribirse en nombre de otros usuarios. Como resultado de todo esto, una organización geográficamente dispersa se enfrentaba a una mayor complejidad a la hora de implementar certificados a los usuarios finales (como, por ejemplo, las tarjetas inteligentes).
En Windows Server 2008, los agentes de inscripción se pueden restringir a un nivel mucho más granular. Las restricciones pueden basarse en los elementos en nombre de los cuales se puede inscribir un usuario o las plantillas sobre las que se puede realizar una inscripción, tal como se muestra en la figura 3. Por ejemplo, ahora una organización podrá proporcionar a los profesionales de TI locales la capacidad de inscribirse en nombre de todos los usuarios de su sucursal, pero no de los usuarios del grupo de Recursos humanos. Este método granular para agentes de inscripción permite a las empresas delegar de forma más eficaz y segura capacidades de inscripción en toda la organización.
Figura 3 Restricciones del agente de inscripción
Figura 3 Restricciones del agente de inscripción (Hacer clic en la imagen para ampliarla)
Uno de los desafíos más importantes de la administración de una PKI es la administración de todos los pares de claves dispersos entre todos los dispositivos de una organización. Incluso en un entorno de PKI moderadamente complejo, cualquier usuario puede poseer varios pares de claves (como, por ejemplo, para EFS, la autenticación a una red inalámbrica y S/MIME) que deben estar disponibles independientemente del lugar en el que haya iniciado sesión. Con la creciente presencia de equipamiento móvil y Terminal Services, es más importante que nunca replicar esos pares de claves en la red de modo que estén disponibles para los usuarios desde dondequiera que inicien sesión. Mientras los símbolos (token) de usuario, tales como las tarjetas inteligentes, pueden ayudar a resolver ciertos aspectos de este problema, las organizaciones pueden aún tener usuarios que no reciben tarjetas o certificados que no se almacenan en las tarjetas. Las credenciales móviles resuelven estos problemas al almacenar de forma segura los pares de claves y certificados en Active Directory®. De esta forma, éstos quedan a disposición de los usuarios independientemente del punto desde donde inicien sesión.
Las credenciales móviles se ofrecieron por primera vez en Windows Server 2003 SP1 y permitían que los certificados y las claves tenga movilidad segura entre equipos sin necesidad de usar perfiles de usuario móviles. En Windows Vista y Windows Server 2008, esta capacidad va incluida de forma predeterminada y se implementa en el servicio Cliente de Servicios de Certificate Server (CSC). Las opciones de configuración, como por ejemplo los certificados que tienen movilidad y cómo arbitrar conflictos, se administran a través de una directiva de grupo. En Windows Vista y Windows Server 2008, el servicio CSC también permite la movilidad de nombres de usuario y contraseñas almacenados. Aunque esta capacidad se incluye de forma predeterminada en Windows Vista, debe tenerse en cuenta que las credenciales móviles son totalmente compatibles con Windows XP y cuando se inicia sesión en un controlador de dominio de Windows Server 2003 (mediante la implementación de una actualización; consulte support.microsoft.com/kb/907247). Esto significa que no es necesario esperar hasta completar una implementación de Windows Vista antes de poder sacar partido de esta tecnología.

Capacidad de administración
Se realizaron varias actualizaciones en Windows Server 2008 para mejorar la capacidad de administración del servicio Entidad de certificación (CA) al facilitar la configuración, supervisión y ejecución de una manera altamente disponible. La instalación de CA está integrada con la herramienta del administrador de funciones que proporciona un método simplificado para instalar este servicio. Los valores predeterminados se definen para cada paso del proceso y, por lo tanto, la instalación ahora puede realizarse en modo desatendido. Por último, la instalación tiene mejores capacidades de diagnóstico que facilitan la solución de problemas o errores que puedan surgir.
La supervisión del servicio de CA ha mejorado mucho en Windows Server 2008 (al igual que los diagnósticos de certificados en general de Windows Vista). Además de una infraestructura de eventos mucho más flexible que se extiende por todo el producto, el servicio de CA ahora incluye una consola de supervisión integrada y que se conecta con Systems Center Operations Manager 2007 (antes conocido como MOM) para proporcionar un servicio de alertas de nivel empresarial. La consola de supervisión de PKI empresarial representa una mejora con respecto a su predecesor, que se incorporó en el paquete de administración de Windows Server 2003. Esta consola nueva se incluye en el producto mismo y ahora puede supervisar los URI de Protocolo de estado de certificados en línea (OCSP) además de todos las CA de un bosque en particular.
El paquete de administración de Operations Manager ofrece una capacidad pasiva de supervisión de la PKI de una organización, incluido el servicio de alertas integrado basado en umbrales. Por ejemplo, el paquete de administración puede usarse para supervisar las actualizaciones de una lista de revocación de certificados (CRL) y notificar a los administradores de PKI cuando una CRL alcance número de días u horas determinados antes de su expiración. Por último, hay disponible una variedad de nuevos contadores de rendimiento que ayudan en la solución de problemas y la supervisión del rendimiento global del propio servicio de CA. Estos contadores pueden usarse para capturar datos como, por ejemplo, el número de certificados que se emiten por segundo.
Windows Server 2008 estrena una nueva capacidad: compatibilidad con los clúster de nivel de hardware del servicio de CA. Este compatibilidad con clúster usa la tecnología estándar de Servicio de Cluster Server de Microsoft (MSCS) y es compatible con las configuraciones activa/pasiva de dos nodos. La compatibilidad con clúster permite ejecutar una infraestructura de emisiones de manera altamente disponible y se puede usar en implementaciones de clúster geográficamente dispersas. Si decide usar la compatibilidad con clúster, tenga en cuenta que un clúster de CA no resulta en una disponibilidad para toda la PKI. Si bien los clúster contribuyen a garantizar la disponibilidad de las CA mismas, una PKI que funciona correctamente probablemente dispondrá de otros componentes que no se ejecutan directamente en las CA. Por ejemplo, los puntos de distribución CRL (CDP) y contestadores OCSP también deben ejecutarse de una manera altamente disponible para asegurar que la revocación pueda llevarse a cabo. Además, cuando se usan módulos de seguridad de hardware (HSM), especialmente los HSM basados en red, representan también un punto de error posible en una PKI. Los clúster representan una sólida capacidad nueva para proporcionar alta disponibilidad de la entidad de certificación en sí, pero no son la panacea de la disponibilidad de una implementación completa de PKI.

Revocación
Las CRL se han usado durante mucho tiempo para proporcionar comprobaciones de validez de los certificados. Estas CRL incluyen los números de serie de todos los certificados cuyo período de validez todavía no ha expirado pero que ya no deben ser de confianza. Por ejemplo, si un empleado tiene un certificado con una fecha de expiración del 31/12/2008 pero el empleado deja la organización el 1 de septiembre de 2007, los números de serie de su certificado se colocarían en la CRL. A continuación, la CRL estaría disponible en varios puntos de distribución de CRL (CDP), tales como las rutas de acceso HTTP y de Protocolo ligero de acceso a directorios (LDAP).
Aunque su uso todavía es muy generalizada, las CRL tienen algunas desventajas clave. En primer lugar, las CRL se publican mediante las CA de forma periódica (generalmente, una o dos veces al día). Los clientes entonces descargan estas CRL y las copian en la memoria caché hasta el intervalo de publicación siguiente. Durante este período en la memoria caché, los certificados pueden ser revocados, lo cual hace que el cliente no sea consciente del estado más actual. En segundo lugar, en organizaciones muy grandes, las CRL pueden tener un tamaño considerable (a veces hasta más de 100 MB). Distribuir estos archivos a través de una red de gran tamaño y extensamente dispersa puede ser difícil o imposible, especialmente en escenarios de sucursales o de otros entornos con ancho de banda limitado.
Para remediar estos problemas, se creó OCSP y se definió en RFC 2560. OCSP proporciona un método de validación en tiempo real del estado de los certificados. Un cliente OCSP se ejecuta en el equipo en el que se debe comprobar la validez de un certificado de hoja. El software del cliente entonces se dirige a un contestador OCSP y envía un mensaje en el que se requiere el estado de validez del certificado de hoja. El contestador comprueba la validez del certificado y envía una respuesta al cliente en tiempo real. Este método evita los problemas de almacenamiento en la memoria caché y de distribución.
Por primera vez, la funcionalidad del cliente OCSP se incluye en Windows Vista (antes se requería software de terceros) y se puede configurar a través de una directiva de grupo. Windows intentará usar OCSP de forma predeterminada, pero recurrirá a las búsquedas de CRL estándar si el contestador no está disponible.
En Windows Server 2008 se proporciona un contestador OCSP para responder a estas solicitudes. El contestador se instala través de un administrador de funciones y puede supervisarse mediante el paquete de administración de Operations Manager 2007. Dado que el cliente y el contestador se adaptan a los estándares de OCSP, pueden integrarse fácilmente en los entornos de OCSP existentes que usan componentes de terceros basados en estándares similares. Por ejemplo, es totalmente admisible que un cliente Windows Vista realice la comprobación del estado de un certificado contra el contestador de terceros y que un contestador de Windows Server 2008 responda las consultas de la aplicación cliente de terceros. Además, el contestador OCSP de Windows puede responder a las solicitudes de certificados emitidos por cualquier CA que cumpla los estándares normativos. Las CA de Windows Server 2008 (y CA basadas en Windows en general) no son obligatorias.

Conclusión
La plataforma PKI en Windows Vista y Windows Server 2008 contiene muchas mejoras y varias características nuevas que aumentan la seguridad y reducen los costos de su implementación y funcionamiento. La nueva API de CNG proporciona a los desarrolladores un entorno de programación más fácil y compatibilidad con los nuevos estándares de cifrado. Las mejoras de las inscripciones permiten a las organizaciones aprovisionarse con mayor facilidad de muchos certificados y permitir una movilidad segura de las claves en toda la empresa. De igual forma, el nuevo paquete de administración y la capacidad de clúster de CA facilita la supervisión del estado de las CA y asegura una alta disponibilidad. Por último, las mejoras en la comprobación de la revocación usan un método basado en estándares que proporciona una validación de certificados en tiempo real sin los costos de ancho de banda derivados de la distribución CRL. Como resultado de todo ello, Windows Vista y Windows Server 2008 elevan la plataforma PKI de Windows a un nuevo nivel.
Recursos para las mejoras en PKI
  • Página principal de PKI de Windows
  • Solución de problemas de PKI en Windows Vista
  • API de criptografía: la próxima generación
  • API de inscripción de certificados Cómo usar las páginas de servicios web de inscripción de certificados con Windows Vista
  • Configuración y solución de problemas del servicio Cliente de Servicios de Certificate Server y de las credenciales móviles

John Morelloha trabajado con Microsoft desde el año 2000. Bajo el cargo de Consultor jefe, ha diseñado soluciones de seguridad para empresas miembro del Fortune 100 y para clientes de la administración pública y de defensa. Actualmente, es Administrador jefe de programas del grupo de Windows Server que trabaja con tecnologías de acceso remoto. Puede leer al blog de su equipo en la dirección blogs.technet.com/WinCAT.


Archivos del escritorio Introducción a RDP
Wes Miller

El protocolo de escritorio remoto, o RDP, permite tener acceso a equipos de forma remota. Se trata de una tecnología muy útil que indudablemente ha salvado a más de unos cuantos administradores de sistema a lo largo de los años. RDP tiene un historial largo de ofrecer una compatibilidad cada vez mejor de acceso remoto. Se presentó en 1998 para Windows NT 4.0 Terminal Server
Edition (TSE) y ha evolucionado en casi cada nueva versión de Windows® desde entonces.
Empezando con Windows 2000, casi cualquiera podía tener acceso remoto fácilmente a un sistema de servidor ya que Terminal Services se incorporó como un componente opcional de Windows y podía configurarse de forma que permitía usar el sistema como un servidor Terminal Server real o como lo que hoy se denomina Escritorio remoto. Windows Server® 2003 y Windows XP proporcionaron una funcionalidad nativa de Escritorio remoto que permite controlar el sistema como si se estuviera físicamente presente. Hoy día, yo uso Escritorio remoto todos los días para tener acceso a mi equipo y servidor en casa de forma remota, y para usar mi Media Center Extender.
Windows XP y versiones posteriores de Windows agregaron la asistencia remota, que proporciona una experiencia similar a la de Escritorio remoto pero diseñada para que un usuario local pueda solicitar asistencia de un usuario remoto. Continuando con la evolución de la compatibilidad de acceso remoto, Windows Vista® ahora permite a los usuarios remotos ofrecer asistencia remota, si la directiva de grupo lo permite.
Como veremos, Escritorio remoto lleva esta funcionalidad tan eficaz a un nivel totalmente nuevo, y podremos apreciar todo lo que nos ofrece. Por supuesto, Escritorio remoto tiene algunas limitaciones, pero también tiene muchas ventajas. Echemos un vistazo a ambas.

Lo bueno, lo malo y lo fantástico
En Windows XP (a excepción de Media Center Edition), la limitación clave es que sólo un usuario interactivo puede iniciar sesión a la vez. Aunque la opción Cambio rápido de usuario de Windows XP permite que haya más de un usuario con una sesión iniciada, sólo un usuario puede estar interactivo usando el mouse o el teclado, independientemente de si lo hace localmente o de forma remota. Con las versiones de Windows Server (que no se ejecuta como servidores de Terminal Server), pueden conectarse dos sesiones de Escritorio remoto a la vez. Para conectarse a través de Escritorio remoto a la sesión de la consola real de Windows Server 2003, debe iniciar la aplicación de cliente Terminal Services (MSTSC.exe) con el parámetro opcional /console. La sesión de la consola es muy importante porque algunas aplicaciones anteriores, las cuales no se diseñaron apropiadamente para tener en cuenta las sesiones Terminal Services, con frecuencia mostrarán cuadros de diálogo emergentes sólo en la sesión de consola (Sesión 0). La figura 1 muestra un usuario que inició sesión en la consola en Windows Server 2003. Windows XP y Windows Server 2003 Remote Desktop aplicarán las licencias para asegurar que únicamente el número permitido de usuarios inicia sesión de manera interactiva.
Figura 1 Sesión 0 iniciada
Figura 1 Sesión 0 iniciada (Hacer clic en la imagen para ampliarla)
Asimismo, tanto el ancho de banda de la red como la directiva de grupo pueden afectar a la experiencia de Escritorio remoto. Windows XP puede proporcionar una resolución de hasta 24 bits así como redirección del sonido, de las impresoras locales, de las unidades de disco y del Portapapeles para cortar y pegar. Debido a la manera en que Escritorio remoto funciona para generar la pantalla, la eliminación de elementos gráficos de la sesión remota (temas, fondos, etcétera) mejora significativamente el ancho de banda disponible y, como resultado, la sesión tiene mucha más capacidad de respuesta para el usuario. Sobre esto, Windows Vista agrega una resolución de 32 bits y un redireccionamiento de dispositivos adicional.
Tenga en cuenta que algunas cosas, como las operaciones con muchos gráficos, pueden desafiar incluso a las mejores sesiones de Escritorio remoto si el ancho de banda es insuficiente, así que se deberá planear según corresponda.

Funcionalidades nuevas en Windows Vista
Windows Vista incorpora importantes cambios en Escritorio remoto. Como mencioné, la resolución de pantalla de 32 bits así como el suavizado de fuentes son los cambios más visibles. Una mejora relacionada es la capacidad de ejecutar sesiones de Windows Vista entre varios monitores si se inicia el cliente Terminal Services mediante el comando /span. Tenga en cuenta que /span sólo funciona con sistemas host remotos de Windows Vista, requiere la misma resolución en el cliente en todos los monitores y requiere que los monitores estén alineados. La expansión funciona al tratar el sistema remoto (el cliente) como una única pantalla grande. Esto significa que maximizar una aplicación puede tener consecuencias no esperadas, entre ellas cuadros de diálogo colocados en lugares inoportunos que el usuario deberá mover.
Asimismo, si el cliente al que se está conectando es un cliente de Windows Vista y el sistema remoto es un sistema de Windows Vista, puede ejecutar la interfaz de usuario de la sesión remota en el modo Windows Aero™ Glass (siempre y cuando el sistema local sea compatible con Aero Glass, incluso si el sistema remoto no lo es). Éste es el resultado de la nueva arquitectura de Escritorio remoto de Windows para realizar muchas de las operaciones de administración de ventanas en el sistema cliente si éste es Windows Vista, los que mejora la experiencia del usuario al reducir el uso del ancho de banda.
Windows Vista también aporta una mejora clave de seguridad, la autenticación a nivel de red (NLA). La NLA ayuda a impedir ataques de tipo "hombre intermedio" (MITM) en los que un usuario deshonesto suplanta la identidad del servidor al que se cree que se está conectando. NLA también mejora la experiencia de la autenticación al no iniciar toda la interfaz de usuario de Windows para la autenticación, lo cual minimiza el impacto sobre el sistema remoto y reduce la vulnerabilidad a ataques de denegación de servicio. NLA requiere que Windows Vista esté instalado tanto en el cliente como en el sistema remoto. La figura 2 muestra cómo especificar a través del cliente RDP 6.0 si se debe aplicar la autenticación, enviar advertencias o si se requiere o no. Tenga en cuenta que si se conecta a un sistema remoto que ejecuta una versión de Windows anterior a Windows Vista, es recomendable establecer esta opción para que al menos advierta de esa conexión; de lo contrario, se producirá un error en la conexión.
Figura 2 Preferencias avanzadas de conexión
Figura 2 Preferencias avanzadas de conexión (Hacer clic en la imagen para ampliarla)
Un mejor redireccionamiento de recursos (más que sólo unidades de disco e impresoras) es otra mejora clave de RDP en Windows Vista. Se podrán redireccionar muchos tipos nuevos de dispositivos, incluidas las tarjetas inteligentes, siempre y cuando los controladores estén presentes en el sistema remoto y el dispositivo sea compatible con el redireccionamiento. Tipos adicionales de dispositivos pueden obtener compatibilidad a través de sus proveedores.
Windows Vista también admite servidores de puerta de enlace a través del cliente RDP 6.0. Esto permite a los usuarios conectarse sin inconvenientes a sistemas en el trabajo a través de Internet sin necesidad de establecer una conexión VPN o disponer de software de terceros. La figura 3 muestra la configuración del servidor de puerta de enlace de Terminal Services. Puede considerar un servidor de puerta de enlace como una conexión VPN, sin necesidad de ningún software específico de cliente más que el software RDP 6.0 (no se requiere configuración de VPN ni software de propiedad).
Figura 3 Configuración del servidor de puerta de enlace de Terminal Services
Figura 3 Configuración del servidor de puerta de enlace de Terminal Services (Hacer clic en la imagen para ampliarla)
Windows Vista también incluye la infraestructura para una característica nueva llamada RemoteApp™. Esto es lo que RemoteApp puede hacer por usted. Escritorio remoto generalmente permite conectarse a una sesión completa de Windows. Pero supongamos que sólo desea ejecutar Microsoft® Word o Microsoft PowerPoint®. RemoteApp ofrece la capacidad de hacer eso. Los escenarios para permitir un sólido uso compartido de aplicaciones también se habilitarán en Windows Server 2008.
Asimismo, se han agregado nuevas compatibilidades en Windows Vista para la API de Windows Desktop Sharing, que permite la publicación de aplicaciones compartidas y de colaboración. El equipo de Microsoft Terminal Server tiene disponible una aplicación de ejemplo en la dirección blogs.msdn.com/ts/ archive/2007/03/23/writing-a-desktop-sharing-application.aspx que muestra cómo funciona la API de Windows Desktop Sharing.
Un cambio clave para tener en cuenta en Windows Vista y versiones posteriores es que generalmente el usuario no puede tener acceso a la Sesión 0 (tradicionalmente la sesión de la consola, donde aplicaciones heredadas mostrarán mensajes de cuadro de diálogo emergentes). Esto reduce la interactividad entre los servicios del sistema (que se ejecutan en la Sesión 0, si bien es cierto que no de manera interactiva) y los usuarios interactivos. También permite una reducción de la superficie de ataque que supone el tener servicios con demasiados privilegios y usuarios interactivos en Windows Vista donde se ha intentado fundamentalmente reducir los privilegios (mediante el sistema de control de cuentas de usuario y de otras mejoras de seguridad). Esto no es una cuestión que generalmente deba ser motivo de preocupación, a menos que ejecute un software heredado en Windows Vista y no actúe correctamente durante su instalación o ejecución.
Dónde se encuentra Escritorio remoto
Un punto clave que hay que tener en cuenta con respecto a Escritorio remoto es en todo momento dónde se puede usar. Windows XP Professional, Media Center Edition y Tablet PC Edition incluyen la funcionalidad Escritorio remoto, como así lo hacen todas las versiones de Windows Server 2003. Windows Vista incluye la funcionalidad Escritorio remoto en las versiones Business, Enterprise y Ultimate. Ninguna de las versiones Windows Home Edition, incluida Windows XP Home Edition y todas las versiones de Windows Vista Home, incluye la funcionalidad de Escritorio remoto.

Cliente de Terminal Services
El nuevo cliente RDP 6.0 se encuentra en la dirección go.microsoft.com/fwlink/?LinkId=91612. Como mencioné más arriba, el cliente incluye todas la funcionalidades necesarias para conectarse a un sistema RDP 6.0 (Windows Vista o Windows Server 2008).
La figura 4 muestra el cliente RDP 6.0. Una mejora notable en MSTSC es la capacidad de copiar las credenciales en la memoria caché; y si la conexión se realiza desde Windows Vista a Windows Vista o Windows Server 2008, incluso el inicio de sesión único (SSO) es compatible mediante una directiva de grupo.
Figura 4 Cliente RDP 6.0
Figura 4 Cliente RDP 6.0 (Hacer clic en la imagen para ampliarla)
La versión 6.0 de MSTSC.exe tiene numerosos parámetros de línea de comandos, incluidos los que se muestran a continuación. Echemos una ojeada a cada uno de ellos.
mstsc [<connection file>] [/v:<server[:port]>]
[/console] [/f[ullscreen]] [/w:<width>] [/h:<height>]
[/public] | [/span] [/edit "connection file"] [/migrate] [/?]
/v:<server[:port]> especifica el equipo remoto al que desea conectarse, así como un valor de puerto opcional (el puerto 3389 es el predeterminado y se puede cambiar en todas las versiones de Windows).
/console permite conectarse a la sesión de consola de versiones anteriores de Windows. Esta configuración no funciona con Windows Vista ni Windows Server 2008.
/f inicia Conexión a Escritorio remoto en el modo de pantalla completa.
/w:<width> especifica el ancho de la ventana Conexión a Escritorio remoto.
/h:<height> especifica la altura de la ventana Escritorio remoto.
/public ejecuta Conexión a Escritorio remoto en el modo público. En el modo público, el cliente RDP no copia datos en la memoria caché del sistema local. Por ejemplo, use el modo público al conectarse a un servidor empresarial desde un sistema en un centro de congresos.
Más magia de Terminal Services
Es posible que no esté familiarizado con otras dos tecnologías de Microsoft que usan los componentes Terminal Services para hacer magia. La opción Cambio rápido de usuario de Windows XP y Windows Vista funciona al permitir a varios usuarios iniciar sesión en el mismo sistema y cambiar rápidamente entre los contextos de usuario sin obligarles a cerrar sesión. Windows Media Center Edition y Windows Vista amplían esta infraestructura para permitir que Media Center Extenders (en efecto una terminal de cliente ligero con tecnología de representación de audio y vídeo y códecs) inicien sesión y representen la experiencia de Medios Center de forma remota en una televisión a través de una conexión por cable o inalámbrica. En Windows XP, estas dos tecnologías suelen ser escenarios no relacionados con el mundo empresarial, ya que ambas requieren un sistema que no está unido a un dominio y que tiene activada la opción Cambio rápido de usuario. Tenga en cuenta que ambas tecnologías están disponibles en ediciones de productos de Windows Vista para empresas. Sin embargo, los escenarios de uso no son realmente escenarios empresariales corrientes, por lo que no los describo en demasiado detalle aquí.

/span hace coincidir el ancho y la altura del escritorio remoto con los del escritorio virtual local, expandiéndose entre varios monitores si fuera necesario. Tenga en cuenta que los monitores deben tener todos la misma altura y estar alineados.
/edit abre el archivo de conexión .rdp especificado para su edición. Los archivos RDP se usan para almacenar información de conexión para un sistema remoto específico.
/migrate mueve los archivos de conexión más antiguos que se crearon con Connection Manager de cliente a nuevos archivos de conexión .rdp.
Muchas de las mejoras en el cliente MSTSC también están disponibles cuando se usa el control ActiveX® de Terminal Services y TSMMC.msc, el cual se describe a continuación, para conectarse a varios sistemas desde la misma consola.

Funcionalidades nuevas en Windows Server 2008
Además de todas las funcionalidades y los cambios ya mencionados con respecto a Windows Vista, Windows Server 2008 incluye funciones de escritorio remoto propias: Acceso web de Terminal Services y Easy Print de Terminal Services.
Acceso web de Terminal Services permite al usuario que usa un explorador web ver una lista de los programas habilitados en el servidor remoto como RemoteApps e iniciarlos fácilmente con un único clic a través del control ActiveX de Escritorio remoto. En algunos sentidos, puede considerar esto como experiencia similar a la de SoftGrid Application Virtualization que comenté en la columna del mes pasado acerca del paquete de optimización de escritorio de Microsoft, donde un usuario remoto inicia fácilmente una aplicación sin necesidad de tener software instalado de manera local. Será interesante comprobar durante los años siguientes cómo se comparan los escenarios que usan SoftGrid con las tecnologías de Terminal Services.
Easy Print de Terminal Services permite redireccionar al sistema local (cliente) todas las tareas de impresoras que tengan lugar en el sistema remoto (host). Quizás esté pensando que el redireccionamiento de impresoras ya hace esto, pero no es así. Easy Print funciona sin requerir controladores de impresora adicionales en el sistema host ni interactividad de usuario para instalar el dispositivo. Si hay una impresora local, funciona igual en el sistema remoto que como lo hace de forma local. Para que Easy Print funcione, el sistema remoto debe estar ejecutando Windows Server 2008 y los sistemas de cliente y de servidor deben estar ejecutando el cliente Terminal Services 6.1 y tener instalado Microsoft .NET Framework 3.0 SP1. Ambos están programados para enviarse cuando se acerque el lanzamiento al mercado de Windows Server 2008.

Sugerencias para usar Escritorio remoto
Como mencioné anteriormente, uso Escritorio remoto todos los días; para ser preciso, uso Microsoft Management Console (MMC) de Escritorio remoto. Al agregar sistemas remotos como nodos aquí, puede intercambiar fácil y rápidamente entre varios sistemas de la misma interfaz de usuario. La figura 5 muestra a qué se parece la experiencia de MMC. El complemento de MMC forma parte del paquete de herramientas de administración de Windows Server 2003, la versión más reciente que está disponible en la dirección go.microsoft.com/fwlink/?LinkId=91685.
Figura 5 Página de MMC
Figura 5 Página de MMC (Hacer clic en la imagen para ampliarla)
Otra sugerencia divertida con la que me tropecé tiene que ver con la función cortar y pegar. Hacer operaciones de cortar y pegar a través del cliente y del servidor era algo nuevo de Windows XP. Para que funcione, tanto el cliente y como el servidor deben ejecutar Windows XP y se debe redireccionar el Portapapeles (consulte la figura 6). Los clientes de Windows Vista también admiten la función de cortar y pegar cuando está habilitado el redireccionamiento del Portapapeles para la conexión.
Figura 6 Configuración de recursos locales
Figura 6 Configuración de recursos locales (Hacer clic en la imagen para ampliarla)
También es importante tener en cuenta que los accesos directos de teclado, tal como Ctrl+Alt+Supr, no se transmiten a través del cable al sistema remoto; es decir, siempre actúan sobre el sistema local. Para enviar Ctrl+Alt+Supr al sistema remoto, presione Ctrl+Alt+Fin en el cliente.
Por último, me gustaría recomendarle que visite regularmente el blog del equipo de Terminal Services de Microsoft en blogs.msdn.com/ts. Yo lo hago.
Personalmente, creo que Escritorio remoto y Terminal Services hacen que mi vida sea más fácil y me es difícil imaginármela sin ellos. Espero que este artículo le haya proporcionado alguna idea de la funcionalidad nueva del cliente RDP 6.0 y Windows Vista y Windows Server 2008.

Querría dar las gracias a Nelly Mozo, administrador jefe de programas del equipo de Terminal Services, por su ayuda en la investigación realizada para escribir esta columna.

Wes Miller es director de desarrollo de Pluck (www.pluck.com) en Austin, Texas. Anteriormente, trabajó en Winternals Software, en Austin, y en Microsoft como director de programas y director de productos para Windows. Si lo desea, puede ponerse en contacto con Wes en la dirección technet@getwired.com.


Notas de campo Entrevistas a través de mensajería instantánea
Nathan G. Jensen

Recientemente, mi compañía publicó un anuncio en Internet para cubrir el puesto de un ingeniero de software con experiencia (un puesto para trabajar de manera remota) e inmediatamente nos inundó una ola de solicitudes de todo el mundo. Como desarrollador jefe, mi tarea era conducir las entrevistas técnicas de toda esa oleada de candidatos. Me quedé mirando esa larga lista con fastidio y me dispuse a examinar todos aquellos currículos inflados. Sabía por experiencia que la mayor parte de los solicitantes no estarían cualificados para el puesto, razón por la cual las entrevistas técnicas son tan esenciales.
A medida que consideraba la idea de llevar esa larga lista de entrevistas telefónicamente, vi que eso iba a llevarme un mes por lo menos. Y entonces se me ocurrió. Tuve una iluminación, una visión, una idea caída del propio cielo del genial departamento de TI: hacer las entrevistas a través de mensajería instantánea. ¡Era una idea fantástica! Y funcionó.
Empecé por enviar un mensaje de correo electrónico en masa a todos los candidatos mediante copia de destinatario oculto, explicando que se les requeriría una entrevista técnica y que el medio para llevarla a cabo sería Windows Live™ Messenger, y no el teléfono. El correo electrónico filtró cerca de la mitad de los solicitantes, presumiblemente porque sabían que no podrían echarse un farol a través de la entrevista técnica. En cuanto a lo demás, creía que un chat a través de mensajería instantánea sería fácil de manejar porque sólo buscaba respuestas directas a preguntas técnicas directas, pam, pam, pam. En esta etapa del proceso de entrevistas, las aptitudes técnicas en software y la oratoria no era de gran importancia.
Figura Tenía abiertas varias ventanas de mensajería instantánea, y como en una bolera lanzaba a diestro y siniestro todo tipo de preguntas técnicas
Figura Tenía abiertas varias ventanas de mensajería instantánea, y como en una bolera lanzaba a diestro y siniestro todo tipo de preguntas técnicas (Hacer clic en la imagen para ampliarla)
Lo primero que noté fue que esta forma de alta tecnología de realizar entrevistas ahorraría tiempo y dinero. Sin facturas de teléfono. Y cuando los solicitantes empezaron a responder para solicitar la entrevista, me di cuenta de que así podría atender a varios de ellos de forma simultánea y eficaz. De hecho, fue una risa. Tenía abiertas diversas ventanas de mensajería instantánea, y como en una bolera lanzaba a diestro y siniestro todo tipo de preguntas técnicas. Y dado que había escrito las preguntas previamente, básicamente me limité a copiarlas y pegarlas.
Con cuidado, realicé un filtro web de mis preguntas con el fin de minimizar todas las respuestas que podrían obtenerse directamente de Internet. Si alguien enviaba una respuesta que parecía obtenida de algún artículo bien elaborado o de documentación oficial, se haría evidente. Además, Windows Live Messenger puede hacer el seguimiento de la marca de hora de cada respuesta de forma que podía revisarlo más tarde y determinar qué candidatos habían tardado demasiado en contestar.
Tuve otro momento de iluminación cuando, en medio de estos chats de mensajería instantánea en columna, me di cuenta de que podía continuar haciendo las entrevistas y hablar por teléfono al mismo tiempo. Esto ya era lo máximo en eficiencia de llevar varios subprocesos a la vez.
Y sólo cuando creía que el invento no podía ser mejor, surgió algo más. Lo que más me irrita de las entrevistas por teléfono es cuando hago una pregunta corta a la espera de una respuesta corta, pero en lugar de ello recibo una disertación de cinco minutos. Con la mensajería instantánea esto desaparece porque las personas tienden a ser breves con sus respuestas.
Al final de cada entrevista guardé los registros de chats para tener un registro que pueda revisar y analizar más tarde. Además, podría enviar aquellos registros a mi jefe y así obtener una comparación objetiva. Al final, el proceso completo me llevó unas pocas horas en vez de una semana, que es lo que me habría llevado establecer citas y entrevistar a los 25 candidatos por teléfono.
No podía estar más satisfecho de mi descubrimiento. Contratamos a la persona que más rápido devolvió las respuestas correctas y que luego tuvo una buena entrevista con mi jefe por teléfono. Fue rápido, eficiente, productivo y nos proporcionó rápidamente al candidato ideal para el trabajo apenas unos pocos días después de haberse convocado la vacante.

Nathan G. Jensen es director de desarrollo web y autor independiente. Vive en Salt Lake City. Puede ponerse en contacto con él en la dirección builderdash.com.


Confidencial de Windows Explorador de Windows no crea texto
Raymond Chen

Había una vez la herramienta Send To X PowerToy. Ésta le permitía hacer cosas ingeniosas, tales como seleccionar un conjunto de archivos, hacer clic con el botón secundario y seleccionar Send To Clipboard as Names. Como se esperaba, copiaba los nombres de los archivos seleccionados al Portapapeles.
Desde luego era un Powertoy útil, pero en primer lugar: ¿por qué tenía que existir? ¿Por qué no se puede simplemente copiar los archivos en Explorador de Windows® y pegarlos como texto para obtener sus nombres de archivo? O mejor aún: ¿por qué no se puede simplemente arrastrar los archivos fuera de Explorador de Windows y colocarlos en el Bloc de notas para obtener los nombres?
Lo intentamos, pero no funcionó.
La transferencia de datos, mediante el Portapapeles o mediante arrastrar y soltar, se realiza mediante objetos de datos OLE, representados por la interfaz IDataObject. Un objeto de datos ofrece una variedad de formatos. Algunos formatos del Portapapeles, incluidos texto y mapas de bits, se han usado desde los inicios de Windows. Los otros se han agregado con el tiempo. Cuando las capacidades de arrastrar y soltar archivos llegaron por primera vez a Windows, consistían en un HDROP. Podía pasarle funciones tales como DragQueryFile, por ejemplo, para extraer los nombres de archivo. Cuando copia algo al Portapapeles desde Explorador de Windows, el objeto de datos resultante ofrece, entre otras cosas, el HDROP mencionado, el contenido del archivo y un descriptor del grupo del archivo. Pero uno de los formatos que el objeto de datos no ofrece es texto.
Cuando a un destino de colocación (una ubicación en la que puede soltar objetos) se le indica que un objeto de datos se está arrastrando sobre él o se está soltando en él, el destino de colocación pregunta al objeto de datos "¿Qué tienes?". El objeto de datos responde con una lista de todos los formatos que admite, en orden descendente de preferencia. Es decir, el primer formato que el objeto de datos devuelve es el formato que mejor describe el objeto. A continuación, sigue el formato de segunda categoría, etc., hasta llegar al último formato, que es sólo una pálida sombra del objeto original. Por ejemplo, el objeto de datos que representa algunos objetos que se arrastran fuera de una ventana de Explorador de Windows probablemente ofrecerían primero una lista de identificadores de shell, debido a que eso es una representación casi perfecta del contenido de una ventana de Explorador de Windows. Lo siguiente en la lista quizás sea un descriptor del grupo del archivo, seguido por el contenido del archivo y, a continuación, un HDROP.
En 1998, el equipo de shell intentó agregar texto sin formato a la lista de formatos ofrecidos, y lo puso al final de la lista. Esencialmente, es como decir "si realmente está desesperado, por lo menos puede obtener algún texto mío (concretamente, la lista de archivos)". Desafortunadamente, sucede que muchos programas se distraen con el formato brillante de texto y dicen "Ooooh, yo quiero texto". Estos programas fueron directamente al formato de texto que no contenía más que una lista de archivos. Como resultado, cuando arrastraba un archivo de Explorador de Windows y lo soltaba en un documento, el programa sólo insertaba el nombre de archivo en vez de insertar el archivo en el documento.
Uy.
Debido al resultado altamente negativo en la compatibilidad de la aplicación, se dio marcha atrás en este cambio. Como resultado, cuando arrastra y suelta o pega archivos que se copian de Explorador de Windows, el objeto de datos de shell no ofrece los nombres de archivo como texto.
Sin embargo, Windows Vista® corrige este antiguo error y le ofrece un modo de copiar la ruta de acceso como texto: mantenga presionada la tecla Mayús cuando hace clic con el botón secundario para obtener el menú contextual ampliado. Esto presentará la nueva opción Copiar como ruta de acceso. No se necesita ningún Powertoy.

Raymond Chen The Old New Thing, y en su libro del mismo nombre (Addison-Wesley, 2007) se trata la historia de Windows y la programación de Win32. Deja a otros el trabajo de hacer mecanismos operativos.