Microsoft Dynamics GP 2013 Web Service Reference

This documentation contains detailed information about the operations, classes, enumerations, and policies available in the Dynamics GP service. Information is divided into the following sections:

  • Summary
  • Method reference
  • Class reference
  • Enumeration reference
  • Policy reference
  • Interface reference

Last updated: November 15, 2012

Documentation Feedback


What’s new?

The following methods and classes were added or revised for Microsoft Dynamics GP 2013. The classes and enumerations that previously existed but were changed for the release are marked with an asterisk (*).

Methods

  • GetTenantList
  • MultitenantEnabled

Classes

  • ArrayOfTenant
  • Context*
  • Tenant


Summary

The following lists summarize the methods, classes, enumerations, and policies that are available in the web service for Microsoft Dynamics GP.

  • Methods listing
  • Classes listing
  • Enumerations listing
  • Policies listing
  • Interfaces listing


Methods listing

The following methods are defined for the Dynamics GP service.

  • CreateApplicant
  • CreateApplicantEducation
  • CreateApplicantInterview
  • CreateApplicantReference
  • CreateApplicantSkill
  • CreateApplicantTest
  • CreateApplicantWorkHistory
  • CreateBackOfficeRoleAssignment
  • CreateBusinessObjectUserAssignment
  • CreateCashReceipt
  • CreateCorporateAccount
  • CreateCustomer
  • CreateCustomerAddress
  • CreateEmployee
  • CreateEmployeeAddress
  • CreateEmployeePayCode
  • CreateFee
  • CreateGLFixedAllocationAccount
  • CreateGLPostingAccount
  • CreateGLTransaction
  • CreateGLUnitAccount
  • CreateGLVariableAllocationAccount
  • CreateHRRequisition
  • CreateInventoryAdjustment
  • CreateInventoryTransfer
  • CreateInventoryVariance
  • CreateItemCurrency
  • CreateItemVendor
  • CreateItemWarehouse
  • CreateKit
  • CreatePayablesCreditMemo
  • CreatePayablesFinanceCharge
  • CreatePayablesInvoice
  • CreatePayablesMiscellaneousCharge
  • CreatePayablesReturn
  • CreatePolicy
  • CreatePricing
  • CreatePurchaseInvoice
  • CreatePurchaseOrder
  • CreatePurchaseReceipt
  • CreateReceivablesCreditMemo
  • CreateReceivablesDebitMemo
  • CreateReceivablesFinanceCharge
  • CreateReceivablesInvoice
  • CreateReceivablesReturn
  • CreateReceivablesServiceRepair
  • CreateReceivablesWarranty
  • CreateReturnMaterialAuthorization
  • CreateSalesBackorder
  • CreateSalesFulfillmentOrder
  • CreateSalesInvoice
  • CreateSalesItem
  • CreateSalesOrder
  • CreateSalesProcessHoldSetup
  • CreateSalesQuote
  • CreateSalesReturn
  • CreateService
  • CreateServiceCall
  • CreateServiceEquipment
  • CreateServiceQuote
  • CreateSkill
  • CreateSkillSet
  • CreateVendor
  • CreateVendorAddress
  • CreateWarehouse
  • DeleteAllLoggedExceptionData
  • DeleteApplicant
  • DeleteApplicantApplication
  • DeleteApplicantEducation
  • DeleteApplicantInterview
  • DeleteApplicantReference
  • DeleteApplicantSkill
  • DeleteApplicantTest
  • DeleteApplicantWorkHistory
  • DeleteBusinessObjectUserAssignment
  • DeleteCustomer
  • DeleteCustomerAddress
  • DeleteEmployeeAddress
  • DeleteLoggedExceptionDataByKey
  • DeletePolicy
  • DeletePurchaseOrder
  • DeleteSalesBackorder
  • DeleteSalesFulfillmentOrder
  • DeleteSalesInvoice
  • DeleteSalesOrder
  • DeleteSalesQuote
  • DeleteSalesReturn
  • DeleteSkill
  • DeleteSkillSet
  • DeleteVendorAddress
  • DiscontinueSalesItem
  • GetApplicantApplicationByKey
  • GetApplicantApplicationList
  • GetApplicantByKey
  • GetApplicantEducationByKey
  • GetApplicantEducationList
  • GetApplicantInterviewByKey
  • GetApplicantInterviewList
  • GetApplicantList
  • GetApplicantReferenceByKey
  • GetApplicantReferenceList
  • GetApplicantSkillByKey
  • GetApplicantSkillList
  • GetApplicantTestByKey
  • GetApplicantTestList
  • GetApplicantWorkHistoryByKey
  • GetApplicantWorkHistoryList
  • GetBackOfficeRoleAssignmentList
  • GetBackOfficeRoleByKey
  • GetBackOfficeRoleList
  • GetBankByKey
  • GetBankList
  • GetBatchByKey
  • GetBatchList
  • GetBusinessObjectSummaryList
  • GetBusinessObjectUserAssignmentList
  • GetCashReceiptByKey
  • GetCashReceiptList
  • GetChangedCurrencyKeyList
  • GetChangedCustomerAddressKeyList
  • GetChangedCustomerKeyList
  • GetChangedInternetAddressKeyList
  • GetChangedItemKeyList
  • GetChangedPriceLevelKeyList
  • GetChangedPricingKeyList
  • GetChangedSalesInvoiceKeyList
  • GetChangedSalesOrderKeyList
  • GetChangedSalespersonKeyList
  • GetChangedShippingMethodKeyList
  • GetChangedTaxDetailKeyList
  • GetChangedTaxScheduleDetailKeyList
  • GetChangedUofMScheduleKeyList
  • GetCompanyAddressByKey
  • GetCompanyAddressList
  • GetCompanyByKey
  • GetCompanyList
  • GetCompletePolicyByKey
  • GetCorporateAccountByKey
  • GetCountryRegionCodeByKey
  • GetCountryRegionCodeList
  • GetCurrencyAccessByKey
  • GetCurrencyAccessList
  • GetCurrencyByKey
  • GetCurrencyList
  • GetCurrencyPostingAccountByKey
  • GetCurrencyPostingAccountList
  • GetCustomerAddressByKey
  • GetCustomerAddressList
  • GetCustomerByKey
  • GetCustomerList
  • GetCustomerReceivablesSummaryByKey
  • GetCustomerReceivablesSummaryList
  • GetDynamicsOnlineConfigurationByKey
  • GetDynamicsOnlineConfigurationList
  • GetEmployeeAddressByKey
  • GetEmployeeAddressList
  • GetEmployeeByKey
  • GetEmployeeList
  • GetEmployeePayCodeByKey
  • GetEmployeePayCodeList
  • GetFeeByKey
  • GetFeeList
  • GetGLAccountByKey
  • GetGLAccountCategoryList
  • GetGLAccountFormatList
  • GetGLAccountList
  • GetGLFixedAllocationAccountByKey
  • GetGLFixedAllocationAccountList
  • GetGLPostedTransactionByKey
  • GetGLPostingAccountByKey
  • GetGLPostingAccountList
  • GetGLTransactionByKey
  • GetGLTransactionList
  • GetGLUnitAccountByKey
  • GetGLUnitAccountList
  • GetGLVariableAllocationAccountByKey
  • GetGLVariableAllocationAccountList
  • GetHRRequisitionByKey
  • GetHRRequisitionList
  • GetInventoriedItemByKey
  • GetInventoriedItemList
  • GetInventoryAdjustmentByKey
  • GetInventoryAdjustmentList
  • GetInventoryTransferByKey
  • GetInventoryTransferList
  • GetInventoryVarianceByKey
  • GetInventoryVarianceList
  • GetItemByKey
  • GetItemClassList
  • GetItemCurrencyByKey
  • GetItemCurrencyList
  • GetItemList
  • GetItemVendorByKey
  • GetItemVendorList
  • GetItemWarehouseByKey
  • GetItemWarehouseList
  • GetLoggedExceptionDataByKey
  • GetLoggedExceptionDataList
  • GetLoggedValidationResultByKey
  • GetManufacturingOrderByKey
  • GetManufacturingOrderList
  • GetMulticurrencySetupByKey
  • GetMulticurrencySetupList
  • GetPayablesCreditMemoByKey
  • GetPayablesCreditMemoList
  • GetPayablesDocumentList
  • GetPayablesFinanceChargeByKey
  • GetPayablesFinanceChargeList
  • GetPayablesInvoiceByKey
  • GetPayablesInvoiceList
  • GetPayablesMiscellaneousChargeByKey
  • GetPayablesMiscellaneousChargeList
  • GetPayablesReturnByKey
  • GetPayablesReturnList
  • GetPaymentCardTypeByKey
  • GetPaymentCardTypeList
  • GetPaymentTermsByKey
  • GetPaymentTermsList
  • GetPlannedOrderByKey
  • GetPlannedOrderList
  • GetPolicyByKey
  • GetPolicyByOperation
  • GetPolicyList
  • GetPolicyListByRoleKey
  • GetPolicyRoles
  • GetPostedPayablesVendorPaymentsByKey
  • GetPostedPayablesVendorPaymentsList
  • GetPriceLevelByKey
  • GetPriceLevelList
  • GetPricingByKey
  • GetPricingList
  • GetProjectBudgetByKey
  • GetProjectBudgetList
  • GetProjectByKey
  • GetProjectChangeOrderByKey
  • GetProjectChangeOrderList
  • GetProjectContractByKey
  • GetProjectContractList
  • GetProjectEmployeeExpenseByKey
  • GetProjectEmployeeExpenseList
  • GetProjectList
  • GetProjectMiscellaneousLogByKey
  • GetProjectMiscellaneousLogList
  • GetProjectTimesheetByKey
  • GetProjectTimesheetList
  • GetPurchaseInvoiceByKey
  • GetPurchaseInvoiceList
  • GetPurchaseOrderByKey
  • GetPurchaseOrderList
  • GetPurchaseReceiptByKey
  • GetPurchaseReceiptList
  • GetReceivablesCreditMemoByKey
  • GetReceivablesCreditMemoList
  • GetReceivablesDebitMemoByKey
  • GetReceivablesDebitMemoList
  • GetReceivablesDocumentList
  • GetReceivablesFinanceChargeByKey
  • GetReceivablesFinanceChargeList
  • GetReceivablesInvoiceByKey
  • GetReceivablesInvoiceList
  • GetReceivablesReturnByKey
  • GetReceivablesReturnList
  • GetReceivablesServiceRepairByKey
  • GetReceivablesServiceRepairList
  • GetReceivablesWarrantyByKey
  • GetReceivablesWarrantyList
  • GetReturnMaterialAuthorizationByKey
  • GetReturnMaterialAuthorizationList
  • GetSalesBackorderByKey
  • GetSalesBackorderList
  • GetSalesDocumentList
  • GetSalesFulfillmentOrderByKey
  • GetSalesFulfillmentOrderList
  • GetSalesInvoiceByKey
  • GetSalesInvoiceList
  • GetSalesOrderByKey
  • GetSalesOrderList
  • GetSalesProcessHoldSetupByKey
  • GetSalesProcessHoldSetupList
  • GetSalesQuoteByKey
  • GetSalesQuoteList
  • GetSalesReturnByKey
  • GetSalesReturnList
  • GetSalesTerritoryByKey
  • GetSalesTerritoryList
  • GetSalespersonByKey
  • GetSalespersonCommissionsByKey
  • GetSalespersonCommissionsList
  • GetSalespersonList
  • GetServiceByKey
  • GetServiceCallByKey
  • GetServiceCallList
  • GetServiceEquipmentByKey
  • GetServiceEquipmentList
  • GetServiceList
  • GetServiceQuoteByKey
  • GetServiceQuoteList
  • GetShippingMethodByKey
  • GetShippingMethodList
  • GetSkillByKey
  • GetSkillList
  • GetSkillSetByKey
  • GetSkillSetList
  • GetTaxDetailByKey
  • GetTaxDetailList
  • GetTaxScheduleByKey
  • GetTaxScheduleDetailByKey
  • GetTaxScheduleDetailList
  • GetTaxScheduleList
  • GetTenantList
  • GetUofMScheduleByKey
  • GetUofMScheduleList
  • GetUserAssignableBusinessObjectList
  • GetVendorAddressByKey
  • GetVendorAddressList
  • GetVendorByKey
  • GetVendorList
  • GetVendorManufacturingOrderByKey
  • GetVendorManufacturingOrderList
  • GetVendorPlannedOrderByKey
  • GetVendorPlannedOrderList
  • GetWarehouseByKey
  • GetWarehouseList
  • GetWSEnabledCompanyForUserList
  • GetWSEnabledCompanyList
  • MultitenantEnabled
  • UpdateApplicant
  • UpdateApplicantEducation
  • UpdateApplicantInterview
  • UpdateApplicantReference
  • UpdateApplicantSkill
  • UpdateApplicantTest
  • UpdateApplicantWorkHistory
  • UpdateCorporateAccount
  • UpdateCustomer
  • UpdateCustomerAddress
  • UpdateEmployee
  • UpdateEmployeeAddress
  • UpdateEmployeePayCode
  • UpdateHRRequisition
  • UpdateItemVendor
  • UpdatePolicy
  • UpdatePurchaseOrder
  • UpdateReturnMaterialAuthorization
  • UpdateSalesBackorder
  • UpdateSalesFulfillmentOrder
  • UpdateSalesInvoice
  • UpdateSalesOrder
  • UpdateSalesProcessHoldSetup
  • UpdateSalesQuote
  • UpdateSalesReturn
  • UpdateServiceCall
  • UpdateServiceEquipment
  • UpdateServiceQuote
  • UpdateSkill
  • UpdateSkillSet
  • UpdateVendor
  • UpdateVendorAddress
  • VoidCashReceipt
  • VoidPurchaseOrder
  • VoidReceivablesCreditMemo
  • VoidReceivablesReturn
  • VoidSalesBackorder
  • VoidSalesInvoice
  • VoidSalesOrder
  • VoidSalesQuote
  • VoidSalesReturn


Classes listing

The following classes are defined for the Dynamics GP service.

  • Address
  • AddressBase
  • AddressKey
  • AgingAmounts
  • Amount
  • Applicant
  • ApplicantAddress
  • ApplicantApplication
  • ApplicantApplicationCriteria
  • ApplicantApplicationSummary
  • ApplicantCriteria
  • ApplicantEducation
  • ApplicantEducationCriteria
  • ApplicantInterview
  • ApplicantInterviewCriteria
  • ApplicantInterviewItem
  • ApplicantInterviewSummary
  • ApplicantInterviewTypeKey
  • ApplicantKey
  • ApplicantReference
  • ApplicantReferenceCriteria
  • ApplicantReferenceKey
  • ApplicantReferenceSummary
  • ApplicantSequenceKey
  • ApplicantSkill
  • ApplicantSkillCriteria
  • ApplicantSkillKey
  • ApplicantSummary
  • ApplicantTest
  • ApplicantTestCriteria
  • ApplicantTestKey
  • ApplicantWorkHistory
  • ApplicantWorkHistoryCriteria
  • ApplicantWorkHistoryKey
  • ApplicationColor
  • ApplicationReferenceInformation
  • ApplicationRejectionInformation
  • ApplyDateKey
  • ApprovalWorkflow
  • ArrayOfApplicantApplication
  • ArrayOfApplicantApplicationSummary
  • ArrayOfApplicantEducation
  • ArrayOfApplicantInterview
  • ArrayOfApplicantInterviewItem
  • ArrayOfApplicantInterviewSummary
  • ArrayOfApplicantReference
  • ArrayOfApplicantReferenceSummary
  • ArrayOfApplicantSkill
  • ArrayOfApplicantSummary
  • ArrayOfApplicantTest
  • ArrayOfApplicantWorkHistory
  • ArrayOfApplicationStatus
  • ArrayOfBackOfficeRole
  • ArrayOfBackOfficeRoleAssignment
  • ArrayOfBank
  • ArrayOfBatch
  • ArrayOfBehavior
  • ArrayOfBehaviorOption
  • ArrayOfBusinessObjectSummary
  • ArrayOfBusinessObjectUserAssignment
  • ArrayOfCashReceiptDistribution
  • ArrayOfCashReceiptSummary
  • ArrayOfChangedCurrencyKey
  • ArrayOfChangedCustomerAddressKey
  • ArrayOfChangedCustomerKey
  • ArrayOfChangedInternetAddressKey
  • ArrayOfChangedItemKey
  • ArrayOfChangedPriceLevelKey
  • ArrayOfChangedPricingKey
  • ArrayOfChangedSalesInvoiceKey
  • ArrayOfChangedSalesOrderKey
  • ArrayOfChangedSalespersonKey
  • ArrayOfChangedShippingMethodKey
  • ArrayOfChangedTaxDetailKey
  • ArrayOfChangedTaxScheduleDetailKey
  • ArrayOfChangedUofMScheduleKey
  • ArrayOfCompany
  • ArrayOfCompanyAddress
  • ArrayOfCompensationPeriod
  • ArrayOfCorporateAccountMember
  • ArrayOfCountryRegionCode
  • ArrayOfCurrency
  • ArrayOfCurrencyAccess
  • ArrayOfCurrencyPostingAccount
  • ArrayOfCustomerAddress
  • ArrayOfCustomerAddressSummary
  • ArrayOfCustomerReceivablesSummary
  • ArrayOfCustomerSummary
  • ArrayOfDateTime
  • ArrayOfDecimal
  • ArrayOfDynamicsOnlineConfiguration
  • ArrayOfEmployeeAddress
  • ArrayOfEmployeeAddressSummary
  • ArrayOfEmployeePayCodeSummary
  • ArrayOfEmployeePayTypes
  • ArrayOfEmployeeSummary
  • ArrayOfFeeSummary
  • ArrayOfFeeType
  • ArrayOfGLAccountCategory
  • ArrayOfGLAccountCurrency
  • ArrayOfGLAccountFormat
  • ArrayOfGLAccountSummary
  • ArrayOfGLAccountSummaryType
  • ArrayOfGLFixedAllocationAccountSummary
  • ArrayOfGLFixedAllocationDistributionAccount
  • ArrayOfGLLedgerType
  • ArrayOfGLPostingAccountSummary
  • ArrayOfGLTransactionLine
  • ArrayOfGLTransactionState
  • ArrayOfGLTransactionSummary
  • ArrayOfGLUnitAccountSummary
  • ArrayOfGLVariableAllocationAccountSummary
  • ArrayOfGLVariableAllocationBreakdownAccount
  • ArrayOfGLVariableAllocationDistributionAccount
  • ArrayOfHRRequisitionStatus
  • ArrayOfHRRequisitionSummary
  • ArrayOfInt
  • ArrayOfInventoriedItemSummary
  • ArrayOfInventoriedItemType
  • ArrayOfInventoryAdjustmentLine
  • ArrayOfInventoryAdjustmentSummary
  • ArrayOfInventoryBin
  • ArrayOfInventoryLot
  • ArrayOfInventorySerial
  • ArrayOfInventoryTransactionState
  • ArrayOfInventoryTransferBin
  • ArrayOfInventoryTransferLine
  • ArrayOfInventoryTransferLot
  • ArrayOfInventoryTransferSerial
  • ArrayOfInventoryTransferSummary
  • ArrayOfInventoryVarianceLine
  • ArrayOfInventoryVarianceSummary
  • ArrayOfItemClass
  • ArrayOfItemCurrency
  • ArrayOfItemSummary
  • ArrayOfItemType
  • ArrayOfItemVendorSummary
  • ArrayOfItemWarehouseSummary
  • ArrayOfKitComponent
  • ArrayOfLoggedExceptionDataSummary
  • ArrayOfManufacturingOrderOutSourced
  • ArrayOfManufacturingOrderPickListItem
  • ArrayOfManufacturingOrderPriority
  • ArrayOfManufacturingOrderRouteStep
  • ArrayOfManufacturingOrderStatus
  • ArrayOfManufacturingOrderSummary
  • ArrayOfMulticurrencySetup
  • ArrayOfParameter
  • ArrayOfPayablesCreditMemoSummary
  • ArrayOfPayablesDistribution
  • ArrayOfPayablesDocumentSummary
  • ArrayOfPayablesDocumentType
  • ArrayOfPayablesFinanceChargeSummary
  • ArrayOfPayablesInvoiceSummary
  • ArrayOfPayablesMiscellaneousChargeSummary
  • ArrayOfPayablesReturnSummary
  • ArrayOfPayablesTax
  • ArrayOfPayablesTransactionState
  • ArrayOfPaymentCardType
  • ArrayOfPaymentTerms
  • ArrayOfPhoneNumber
  • ArrayOfPlannedOrderItem
  • ArrayOfPlannedOrderReplenishment
  • ArrayOfPlannedOrderSummary
  • ArrayOfPolicySummary
  • ArrayOfPostedPayablesVendorPaymentSummary
  • ArrayOfPriceLevel
  • ArrayOfPricingDetail
  • ArrayOfPricingSummary
  • ArrayOfProjectAccountType
  • ArrayOfProjectBillingCycle
  • ArrayOfProjectBudget
  • ArrayOfProjectBudgetSummary
  • ArrayOfProjectChangeOrderBudget
  • ArrayOfProjectChangeOrderFee
  • ArrayOfProjectChangeOrderFeeLine
  • ArrayOfProjectChangeOrderFeeLineSchedule
  • ArrayOfProjectChangeOrderSummary
  • ArrayOfProjectContractAccountType
  • ArrayOfProjectContractBillingCycle
  • ArrayOfProjectContractSummary
  • ArrayOfProjectEmployeeExpenseDistribution
  • ArrayOfProjectEmployeeExpenseLine
  • ArrayOfProjectEmployeeExpenseLineTax
  • ArrayOfProjectEmployeeExpenseSummary
  • ArrayOfProjectEquipmentItem
  • ArrayOfProjectFee
  • ArrayOfProjectFeeSchedule
  • ArrayOfProjectMiscellaneousLogDistribution
  • ArrayOfProjectMiscellaneousLogLine
  • ArrayOfProjectMiscellaneousLogSummary
  • ArrayOfProjectSummary
  • ArrayOfProjectTimesheetDistribution
  • ArrayOfProjectTimesheetLine
  • ArrayOfProjectTimesheetSummary
  • ArrayOfProjectTransactionState
  • ArrayOfPurchaseBinDetail
  • ArrayOfPurchaseDistribution
  • ArrayOfPurchaseInvoiceApplyReceipt
  • ArrayOfPurchaseInvoiceLine
  • ArrayOfPurchaseInvoiceSummary
  • ArrayOfPurchaseInvoiceTax
  • ArrayOfPurchaseLotDetail
  • ArrayOfPurchaseOrderLine
  • ArrayOfPurchaseOrderStatus
  • ArrayOfPurchaseOrderSummary
  • ArrayOfPurchaseOrderTransactionState
  • ArrayOfPurchaseReceiptLine
  • ArrayOfPurchaseReceiptSummary
  • ArrayOfPurchaseSerialDetail
  • ArrayOfPurchaseTax
  • ArrayOfPurchaseTransactionState
  • ArrayOfPurchaseUserDefined
  • ArrayOfReceivablesCommission
  • ArrayOfReceivablesCreditMemoSummary
  • ArrayOfReceivablesDebitMemoSummary
  • ArrayOfReceivablesDistribution
  • ArrayOfReceivablesDocumentSummary
  • ArrayOfReceivablesDocumentType
  • ArrayOfReceivablesFinanceChargeSummary
  • ArrayOfReceivablesInvoiceSummary
  • ArrayOfReceivablesReturnSummary
  • ArrayOfReceivablesServiceRepairSummary
  • ArrayOfReceivablesTax
  • ArrayOfReceivablesTransactionState
  • ArrayOfReceivablesWarrantySummary
  • ArrayOfReturnMaterialAuthorizationAudit
  • ArrayOfReturnMaterialAuthorizationDistribution
  • ArrayOfReturnMaterialAuthorizationLine
  • ArrayOfReturnMaterialAuthorizationLineLot
  • ArrayOfReturnMaterialAuthorizationLineSerial
  • ArrayOfReturnMaterialAuthorizationSummary
  • ArrayOfReturnMaterialAuthorizationType
  • ArrayOfRoleKey
  • ArrayOfSalesBackorderComponent
  • ArrayOfSalesBackorderLine
  • ArrayOfSalesBackorderSummary
  • ArrayOfSalesCommission
  • ArrayOfSalesCommissionTransactionState
  • ArrayOfSalesComponentBin
  • ArrayOfSalesComponentLot
  • ArrayOfSalesComponentSerial
  • ArrayOfSalesDistribution
  • ArrayOfSalesDocumentSummary
  • ArrayOfSalesDocumentTax
  • ArrayOfSalesDocumentType
  • ArrayOfSalesFulfillmentOrderComponent
  • ArrayOfSalesFulfillmentOrderLine
  • ArrayOfSalesFulfillmentOrderSummary
  • ArrayOfSalesInvoiceComponent
  • ArrayOfSalesInvoiceLine
  • ArrayOfSalesInvoiceSummary
  • ArrayOfSalesItemWarehouse
  • ArrayOfSalesItemWarehouseBin
  • ArrayOfSalesLineBin
  • ArrayOfSalesLineLot
  • ArrayOfSalesLineSerial
  • ArrayOfSalesLineTax
  • ArrayOfSalesOrderComponent
  • ArrayOfSalesOrderLine
  • ArrayOfSalesOrderSummary
  • ArrayOfSalesPayment
  • ArrayOfSalespersonCommissionsDocumentType
  • ArrayOfSalespersonCommissionsSummary
  • ArrayOfSalespersonHistory
  • ArrayOfSalespersonSummary
  • ArrayOfSalesProcessHold
  • ArrayOfSalesProcessHoldSetup
  • ArrayOfSalesQuoteComponent
  • ArrayOfSalesQuoteLine
  • ArrayOfSalesQuoteSummary
  • ArrayOfSalesReturnComponent
  • ArrayOfSalesReturnLine
  • ArrayOfSalesReturnSummary
  • ArrayOfSalesTerritoryHistory
  • ArrayOfSalesTerritorySummary
  • ArrayOfSalesTrackingNumber
  • ArrayOfSalesTransactionState
  • ArrayOfServiceCallAdditionalChargeLine
  • ArrayOfServiceCallDocumentAudit
  • ArrayOfServiceCallEquipmentCode
  • ArrayOfServiceCallExpenseLine
  • ArrayOfServiceCallLaborLine
  • ArrayOfServiceCallPartLine
  • ArrayOfServiceCallSummary
  • ArrayOfServiceCallType
  • ArrayOfServiceDistribution
  • ArrayOfServiceEquipmentCode
  • ArrayOfServiceEquipmentReading
  • ArrayOfServiceEquipmentSummary
  • ArrayOfServiceLot
  • ArrayOfServiceQuoteAdditionalChargeLine
  • ArrayOfServiceQuoteExpenseLine
  • ArrayOfServiceQuoteLaborLine
  • ArrayOfServiceQuotePartLine
  • ArrayOfServiceQuoteSummary
  • ArrayOfServiceSerial
  • ArrayOfServiceSummary
  • ArrayOfServiceTransactionState
  • ArrayOfShippingMethod
  • ArrayOfSkill
  • ArrayOfSkillSetSummary
  • ArrayOfString
  • ArrayOfTaxDetail
  • ArrayOfTaxDetailBase
  • ArrayOfTaxDetailType
  • ArrayOfTaxSchedule
  • ArrayOfTaxScheduleDetail
  • ArrayOfTenant
  • ArrayOfUofMScheduleDetail
  • ArrayOfUofMScheduleSummary
  • ArrayOfUserAssignableBusinessObject
  • ArrayOfValidationError
  • ArrayOfValidationWarning
  • ArrayOfVendorAddress
  • ArrayOfVendorAddressSummary
  • ArrayOfVendorManufacturingOrderSummary
  • ArrayOfVendorPlannedOrderSummary
  • ArrayOfVendorSummary
  • ArrayOfWarehouseBin
  • ArrayOfWarehouseSummary
  • ArrayOfWorkflow
  • AXCompanyKey
  • BackOfficeRole
  • BackOfficeRoleAssignment
  • BackOfficeRoleAssignmentKey
  • BackOfficeRoleKey
  • Bank
  • BankAccountKey
  • BankCriteria
  • BankKey
  • BaseChangedKeyCriteria
  • BaseChangedSalesDocument
  • BaseChangedSalesDocumentKeyCriteria
  • Batch
  • BatchCriteria
  • BatchKey
  • Behavior
  • BehaviorKey
  • BehaviorOption
  • BehaviorOptionKey
  • BetweenRestrictionOfNullableOfDateTime
  • BetweenRestrictionOfNullableOfDecimal
  • BetweenRestrictionOfNullableOfInt32
  • BetweenRestrictionOfNullableOfServiceCallType
  • BetweenRestrictionOfString
  • BillingRate
  • BusinessAddress
  • BusinessObject
  • BusinessObjectSummary
  • BusinessObjectSummaryCriteria
  • BusinessObjectUserAssignment
  • BuyerKey
  • CashDetail
  • CashReceipt
  • CashReceiptCriteria
  • CashReceiptDistribution
  • CashReceiptSummary
  • ChangedBusinessObjectGreatPlainsKey
  • ChangedBusinessObjectKey
  • ChangedCurrencyKey
  • ChangedCustomerAddressKey
  • ChangedCustomerKey
  • ChangedInternetAddressKey
  • ChangedItemKey
  • ChangedPriceLevelKey
  • ChangedPricingKey
  • ChangedSalesInvoiceKey
  • ChangedSalesOrderKey
  • ChangedSalespersonKey
  • ChangedShippingMethodKey
  • ChangedTaxDetailKey
  • ChangedTaxScheduleDetailKey
  • ChangedUofMScheduleKey
  • CheckDetail
  • CommentKey
  • CommissionSummary
  • Company
  • CompanyAddress
  • CompanyAddressCriteria
  • CompanyAddressKey
  • CompanyCriteria
  • CompanyKey
  • Compensation
  • ConstituentAddress
  • Context
  • CorporateAccount
  • CorporateAccountMember
  • CorporateAccountMemberKey
  • CostCategoryKey
  • CostPlus
  • CountryRegionCode
  • CountryRegionCodeCriteria
  • CountryRegionCodeKey
  • CreditLimit
  • Criteria
  • Currency
  • CurrencyAccess
  • CurrencyAccessCriteria
  • CurrencyAccessKey
  • CurrencyChangedKeyCriteria
  • CurrencyCriteria
  • CurrencyKey
  • CurrencyPostingAccount
  • CurrencyPostingAccountCriteria
  • CurrencyPostingAccountKey
  • Customer
  • CustomerAddress
  • CustomerAddressChangedKeyCriteria
  • CustomerAddressCriteria
  • CustomerAddressKey
  • CustomerAddressSummary
  • CustomerChangedKeyCriteria
  • CustomerClassKey
  • CustomerCreditLimit
  • CustomerCriteria
  • CustomerKey
  • CustomerReceivablesSummary
  • CustomerReceivablesSummaryCriteria
  • CustomerSummary
  • DepartmentKey
  • Distribution
  • DistributionTypeKey
  • DivisionKey
  • DynamicsOnlineConfiguration
  • DynamicsOnlineConfigurationCriteria
  • EmailRecipients
  • Employee
  • EmployeeAddress
  • EmployeeAddressCriteria
  • EmployeeAddressKey
  • EmployeeAddressSummary
  • EmployeeApplicableTaxes
  • EmployeeClassKey
  • EmployeeCriteria
  • EmployeeFlatTaxRates
  • EmployeeKey
  • EmployeePayCode
  • EmployeePayCodeCriteria
  • EmployeePayCodeKey
  • EmployeePayCodeSummary
  • EmployeePayStep
  • EmployeeSummary
  • EmployeeW2Boxes
  • ExceptionInformation
  • ExtendedBusinessAddress
  • Extension
  • ExtensionList
  • Fee
  • FeeCriteria
  • FeeSummary
  • FixedPrice
  • GLAccount
  • GLAccountCategory
  • GLAccountCategoryKey
  • GLAccountCriteria
  • GLAccountCriteriaBase
  • GLAccountCurrency
  • GLAccountCurrencyKey
  • GLAccountFormat
  • GLAccountFormatCriteria
  • GLAccountFormatKey
  • GLAccountNumberKey
  • GLAccountSummary
  • GLAccountSummaryBase
  • GLAllocationDistributionAccountKey
  • GLFinancialAccount
  • GLFixedAllocationAccount
  • GLFixedAllocationAccountCriteria
  • GLFixedAllocationAccountSummary
  • GLFixedAllocationDistributionAccount
  • GLIntercompany
  • GLOriginatingDocument
  • GLOriginatingDocumentLine
  • GLPostingAccount
  • GLPostingAccountCriteria
  • GLPostingAccountSummary
  • GLTax
  • GLTransaction
  • GLTransactionCriteria
  • GLTransactionKey
  • GLTransactionLine
  • GLTransactionLineKey
  • GLTransactionPostedKey
  • GLTransactionSummary
  • GLUnitAccount
  • GLUnitAccountCriteria
  • GLUnitAccountSummary
  • GLVariableAllocationAccount
  • GLVariableAllocationAccountCriteria
  • GLVariableAllocationAccountSummary
  • GLVariableAllocationBreakdownAccount
  • GLVariableAllocationBreakdownAccountKey
  • GLVariableAllocationDistributionAccount
  • GreatPlainsKey
  • HistoryOptions
  • HRRequisition
  • HRRequisitionAdvertisingList
  • HRRequisitionCosts
  • HRRequisitionCriteria
  • HRRequisitionNumberKey
  • HRRequisitionSummary
  • InternationalAddress
  • InternetAddresses
  • InternetAddressKeyChangedCriteria
  • InterviewTypeKey
  • InventoriedItem
  • InventoriedItemCriteria
  • InventoriedItemSummary
  • InventoryAdjustment
  • InventoryAdjustmentCriteria
  • InventoryAdjustmentLine
  • InventoryAdjustmentSummary
  • InventoryBase
  • InventoryBin
  • InventoryBinBase
  • InventoryBinKey
  • InventoryCriteria
  • InventoryKey
  • InventoryLine
  • InventoryLineBase
  • InventoryLineKey
  • InventoryLot
  • InventoryLotBase
  • InventoryLotKey
  • InventorySerial
  • InventorySerialBase
  • InventorySerialKey
  • InventorySummary
  • InventoryTransfer
  • InventoryTransferBin
  • InventoryTransferCriteria
  • InventoryTransferLine
  • InventoryTransferLot
  • InventoryTransferSerial
  • InventoryTransferSummary
  • InventoryVariance
  • InventoryVarianceCriteria
  • InventoryVarianceLine
  • InventoryVarianceSummary
  • Item
  • ItemChangedKeyCriteria
  • ItemClass
  • ItemClassCriteria
  • ItemClassKey
  • ItemCriteria
  • ItemCriteriaBase
  • ItemCurrency
  • ItemCurrencyCriteria
  • ItemCurrencyKey
  • ItemKey
  • ItemSummary
  • ItemSummaryBase
  • ItemTaxScheduleKey
  • ItemVendor
  • ItemVendorCriteria
  • ItemVendorKey
  • ItemVendorSummary
  • ItemWarehouse
  • ItemWarehouseBinKey
  • ItemWarehouseCriteria
  • ItemWarehouseKey
  • ItemWarehouseSummary
  • JobTitleKey
  • Key
  • Kit
  • KitComponent
  • KitComponentKey
  • LandedCostGroupKey
  • LanguageKey
  • LikeRestrictionOfNullableOfInt32
  • LikeRestrictionOfNullableOfServiceCallType
  • LikeRestrictionOfString
  • ListRestrictionOfNullableOfApplicationStatus
  • ListRestrictionOfNullableOfCompensationPeriod
  • ListRestrictionOfNullableOfDateTime
  • ListRestrictionOfNullableOfDecimal
  • ListRestrictionOfNullableOfEmployeePayTypes
  • ListRestrictionOfNullableOfFeeType
  • ListRestrictionOfNullableOfGLAccountSummaryType
  • ListRestrictionOfNullableOfGLLedgerType
  • ListRestrictionOfNullableOfGLTransactionState
  • ListRestrictionOfNullableOfHRRequisitionStatus
  • ListRestrictionOfNullableOfInt32
  • ListRestrictionOfNullableOfInventoriedItemType
  • ListRestrictionOfNullableOfInventoryTransactionState
  • ListRestrictionOfNullableOfItemType
  • ListRestrictionOfNullableOfManufacturingOrderOutSourced
  • ListRestrictionOfNullableOfManufacturingOrderPriority
  • ListRestrictionOfNullableOfManufacturingOrderStatus
  • ListRestrictionOfNullableOfPayablesDocumentType
  • ListRestrictionOfNullableOfPayablesTransactionState
  • ListRestrictionOfNullableOfPlannedOrderReplenishment
  • ListRestrictionOfNullableOfProjectTransactionState
  • ListRestrictionOfNullableOfPurchaseOrderStatus
  • ListRestrictionOfNullableOfPurchaseOrderTransactionState
  • ListRestrictionOfNullableOfPurchaseTransactionState
  • ListRestrictionOfNullableOfReceivablesDocumentType
  • ListRestrictionOfNullableOfReceivablesTransactionState
  • ListRestrictionOfNullableOfReturnMaterialAuthorizationType
  • ListRestrictionOfNullableOfSalesCommissionTransactionState
  • ListRestrictionOfNullableOfSalesDocumentType
  • ListRestrictionOfNullableOfSalesTransactionState
  • ListRestrictionOfNullableOfSalespersonCommissionsDocumentType
  • ListRestrictionOfNullableOfServiceCallType
  • ListRestrictionOfNullableOfServiceTransactionState
  • ListRestrictionOfNullableOfTaxDetailBase
  • ListRestrictionOfNullableOfTaxDetailType
  • ListRestrictionOfString
  • LoggedExceptionData
  • LoggedExceptionDataSummary
  • LotCategoryKey
  • ManagerKey
  • ManufacturingOrder
  • ManufacturingOrderCriteria
  • ManufacturingOrderDocument
  • ManufacturingOrderDocumentCriteria
  • ManufacturingOrderDocumentKey
  • ManufacturingOrderDocumentSummary
  • ManufacturingOrderPickListItem
  • ManufacturingOrderRouteStep
  • ManufacturingOrderServiceItem
  • ManufacturingOrderSummary
  • MarkupPercentage
  • MaximumInvoice
  • MaximumWriteoff
  • MiscellaneousKey
  • MoneyAmount
  • MoneyPercentChoice
  • MoneyProfitCalculation
  • MulticurrencySetup
  • MulticurrencySetupCriteria
  • MulticurrencySetupKey
  • Name
  • NAVCompanyKey
  • NoProfit
  • OfficeKey
  • OrganizationKey
  • Parameter
  • ParameterKey
  • PayablesVendorPayment
  • PayablesVendorPaymentCriteria
  • PayablesVendorPaymentSummary
  • PayCodeKey
  • PayablesCashDetail
  • PayablesCreditDocument
  • PayablesCreditMemo
  • PayablesCreditMemoCriteria
  • PayablesCreditMemoSummary
  • PayablesDebitDocument
  • PayablesDistribution
  • PayablesDistributionKey
  • PayablesDocument
  • PayablesDocumentCriteria
  • PayablesDocumentCriteriaBase
  • PayablesDocumentKey
  • PayablesDocumentSummary
  • PayablesDocumentSummaryBase
  • PayablesFinanceCharge
  • PayablesFinanceChargeCriteria
  • PayablesFinanceChargeSummary
  • PayablesInvoice
  • PayablesInvoiceCriteria
  • PayablesInvoiceSummary
  • PayablesMiscellaneousCharge
  • PayablesMiscellaneousChargeCriteria
  • PayablesMiscellaneousChargeSummary
  • PayablesPayment
  • PayablesReturn
  • PayablesReturnCriteria
  • PayablesReturnSummary
  • PayablesTax
  • PayablesTaxKey
  • PayablesTerms
  • PaymentCardAccount
  • PaymentCardAccountKey
  • PaymentCardDetail
  • PaymentCardType
  • PaymentCardTypeCriteria
  • PaymentCardTypeKey
  • PaymentTerms
  • PaymentTermsCriteria
  • PaymentTermsKey
  • PayrollDepartmentKey
  • PayStepKey
  • Percent
  • PercentOfActual
  • PercentOfBaseline
  • PercentProfitCalculation
  • PhoneNumber
  • PlannedOrder
  • PlannedOrderCriteria
  • PlannedOrderCriteriaBase
  • PlannedOrderItem
  • PlannedOrderItemExceptions
  • PlannedOrderKey
  • PlannedOrderSummary
  • PlannerKey
  • Planning
  • Policy
  • PolicyKey
  • PolicySummary
  • PositionKey
  • PostedPayablesVendorPayment
  • PostedPayablesVendorPaymentCriteria
  • PostedPayablesVendorPaymentSummary
  • PriceLevel
  • PriceLevelChangedKeyCriteria
  • PriceLevelCriteria
  • PriceLevelKey
  • Pricing
  • PricingChangedKeyCriteria
  • PricingCriteria
  • PricingDetail
  • PricingDetailKey
  • PricingDetailPrice
  • PricingKey
  • PricingSummary
  • PrimaryPayCodeKey
  • Profit
  • ProfitCalculation
  • ProfitFixed
  • ProfitVariable
  • Project
  • ProjectAccountType
  • ProjectAccountTypeKey
  • ProjectAccountingOptions
  • ProjectActual
  • ProjectAmount
  • ProjectBaseline
  • ProjectBilled
  • ProjectBilledBase
  • ProjectBilling
  • ProjectBillingCycle
  • ProjectBillingCycleKey
  • ProjectBillingFull
  • ProjectBudget
  • ProjectBudgetActual
  • ProjectBudgetBase
  • ProjectBudgetBaseline
  • ProjectBudgetBilled
  • ProjectBudgetCriteria
  • ProjectBudgetForecast
  • ProjectBudgetKey
  • ProjectBudgetPosted
  • ProjectBudgetSummary
  • ProjectBudgetUncommitted
  • ProjectBudgetUnposted
  • ProjectCashDetail
  • ProjectChangeOrder
  • ProjectChangeOrderBudget
  • ProjectChangeOrderBudgetKey
  • ProjectChangeOrderCriteria
  • ProjectChangeOrderFee
  • ProjectChangeOrderFeeKey
  • ProjectChangeOrderFeeLine
  • ProjectChangeOrderFeeLineKey
  • ProjectChangeOrderFeeLineSchedule
  • ProjectChangeOrderFeeLineScheduleKey
  • ProjectChangeOrderKey
  • ProjectChangeOrderPayCodeHourlyKey
  • ProjectChangeOrderPayCodeSalaryKey
  • ProjectChangeOrderSummary
  • ProjectClassKey
  • ProjectContract
  • ProjectContractAccountType
  • ProjectContractAccountTypeKey
  • ProjectContractActual
  • ProjectContractBaseline
  • ProjectContractBilled
  • ProjectContractBillingCycle
  • ProjectContractBillingCycleKey
  • ProjectContractCriteria
  • ProjectContractForecast
  • ProjectContractKey
  • ProjectContractSummary
  • ProjectContractUnposted
  • ProjectCriteria
  • ProjectDepartmentKey
  • ProjectDistributionBase
  • ProjectEmployeeExpense
  • ProjectEmployeeExpenseCriteria
  • ProjectEmployeeExpenseDistribution
  • ProjectEmployeeExpenseDistributionKey
  • ProjectEmployeeExpenseKey
  • ProjectEmployeeExpenseLine
  • ProjectEmployeeExpenseLineKey
  • ProjectEmployeeExpenseLineTax
  • ProjectEmployeeExpenseLineTaxKey
  • ProjectEmployeeExpenseSummary
  • ProjectEquipmentItem
  • ProjectEquipmentItemKey
  • ProjectEquipmentKey
  • ProjectEquipmentRateTableKey
  • ProjectFee
  • ProjectFeeItemKey
  • ProjectFeeKey
  • ProjectFeeSchedule
  • ProjectFeeScheduleKey
  • ProjectForecast
  • ProjectHeaderBase
  • ProjectKey
  • ProjectLaborRateTableKey
  • ProjectLineBase
  • ProjectMiscellaneousLog
  • ProjectMiscellaneousLogCriteria
  • ProjectMiscellaneousLogDistribution
  • ProjectMiscellaneousLogDistributionKey
  • ProjectMiscellaneousLogKey
  • ProjectMiscellaneousLogLine
  • ProjectMiscellaneousLogLineKey
  • ProjectMiscellaneousLogSummary
  • ProjectPayment
  • ProjectPosted
  • ProjectPostedAmount
  • ProjectPostedBase
  • ProjectSummary
  • ProjectTimesheet
  • ProjectTimesheetCriteria
  • ProjectTimesheetDistribution
  • ProjectTimesheetDistributionKey
  • ProjectTimesheetKey
  • ProjectTimesheetLine
  • ProjectTimesheetLineKey
  • ProjectTimesheetSummary
  • ProjectUnposted
  • ProjectUnpostedBase
  • PurchaseBinDetail
  • PurchaseBinDetailKey
  • PurchaseDistribution
  • PurchaseDistributionKey
  • PurchaseInvoice
  • PurchaseInvoiceApplyReceipt
  • PurchaseInvoiceApplyReceiptKey
  • PurchaseInvoiceCriteria
  • PurchaseInvoiceLine
  • PurchaseInvoiceSummary
  • PurchaseInvoiceTax
  • PurchaseLotDetail
  • PurchaseLotDetailKey
  • PurchaseOrder
  • PurchaseOrderCriteria
  • PurchaseOrderLine
  • PurchaseOrderSummary
  • PurchaseReceipt
  • PurchaseReceiptCriteria
  • PurchaseReceiptLine
  • PurchaseReceiptSummary
  • PurchaseSerialDetail
  • PurchaseSerialDetailKey
  • PurchaseTax
  • PurchaseTaxKey
  • PurchaseTransactionKey
  • PurchaseTransactionLineKey
  • PurchaseUserDefined
  • PurchaseUserDefinedKey
  • Quantity
  • RateTypeKey
  • ReceivablesCommission
  • ReceivablesCommissionKey
  • ReceivablesCreditDocument
  • ReceivablesCreditMemo
  • ReceivablesCreditMemoCriteria
  • ReceivablesCreditMemoSummary
  • ReceivablesDebitDocument
  • ReceivablesDebitMemo
  • ReceivablesDebitMemoCriteria
  • ReceivablesDebitMemoSummary
  • ReceivablesDistribution
  • ReceivablesDistributionKey
  • ReceivablesDocument
  • ReceivablesDocumentCriteria
  • ReceivablesDocumentCriteriaBase
  • ReceivablesDocumentKey
  • ReceivablesDocumentSummary
  • ReceivablesDocumentSummaryBase
  • ReceivablesFinanceCharge
  • ReceivablesFinanceChargeCriteria
  • ReceivablesFinanceChargeSummary
  • ReceivablesInvoice
  • ReceivablesInvoiceCriteria
  • ReceivablesInvoiceSummary
  • ReceivablesPayment
  • ReceivablesPaymentCardDetail
  • ReceivablesReturn
  • ReceivablesReturnCriteria
  • ReceivablesReturnSummary
  • ReceivablesServiceRepair
  • ReceivablesServiceRepairCriteria
  • ReceivablesServiceRepairSummary
  • ReceivablesTax
  • ReceivablesTaxKey
  • ReceivablesTerms
  • ReceivablesWarranty
  • ReceivablesWarrantyCriteria
  • ReceivablesWarrantySummary
  • ReferenceKey
  • Restriction
  • RestrictionOfNullableOfApplicationStatus
  • RestrictionOfNullableOfBoolean
  • RestrictionOfNullableOfCompensationPeriod
  • RestrictionOfNullableOfDataModificationAction
  • RestrictionOfNullableOfDateTime
  • RestrictionOfNullableOfDecimal
  • RestrictionOfNullableOfEmployeePayTypes
  • RestrictionOfNullableOfFeeType
  • RestrictionOfNullableOfGLAccountSummaryType
  • RestrictionOfNullableOfGLLedgerType
  • RestrictionOfNullableOfGLTransactionState
  • RestrictionOfNullableOfHRRequisitionStatus
  • RestrictionOfNullableOfInt32
  • RestrictionOfNullableOfInventoriedItemType
  • RestrictionOfNullableOfInventoryTransactionState
  • RestrictionOfNullableOfItemType
  • RestrictionOfNullableOfManufacturingOrderOutSourced
  • RestrictionOfNullableOfManufacturingOrderPriority
  • RestrictionOfNullableOfManufacturingOrderStatus
  • RestrictionOfNullableOfPayablesDocumentType
  • RestrictionOfNullableOfPayablesTransactionState
  • RestrictionOfNullableOfPlannedOrderReplenishment
  • RestrictionOfNullableOfProjectTransactionState
  • RestrictionOfNullableOfPurchaseOrderStatus
  • RestrictionOfNullableOfPurchaseTransactionState
  • RestrictionOfNullableOfReceivablesDocumentType
  • RestrictionOfNullableOfReceivablesTransactionState
  • RestrictionOfNullableOfReturnMaterialAuthorizationType
  • RestrictionOfNullableOfSalesCommissionTransactionState
  • RestrictionOfNullableOfSalesDocumentType
  • RestrictionOfNullableOfSalesTransactionState
  • RestrictionOfNullableOfSalespersonCommissionsDocumentType
  • RestrictionOfNullableOfServiceCallType
  • RestrictionOfNullableOfServiceTransactionState
  • RestrictionOfNullableOfTaxDetailBase
  • RestrictionOfNullableOfTaxDetailType
  • RestrictionOfString
  • ReturnMaterialAuthorization
  • ReturnMaterialAuthorizationAudit
  • ReturnMaterialAuthorizationCriteria
  • ReturnMaterialAuthorizationDistribution
  • ReturnMaterialAuthorizationLine
  • ReturnMaterialAuthorizationLineLot
  • ReturnMaterialAuthorizationLineRepair
  • ReturnMaterialAuthorizationLineReplacement
  • ReturnMaterialAuthorizationLineSerial
  • ReturnMaterialAuthorizationReasonCodeKey
  • ReturnMaterialAuthorizationReturnToAddress
  • ReturnMaterialAuthorizationShipToAddress
  • ReturnMaterialAuthorizationStatusCodeKey
  • ReturnMaterialAuthorizationSummary
  • ReturnMaterialAuthorizationTypeKey
  • Review
  • RoleKey
  • RoundingType
  • SalesAmounts
  • SalesBackorder
  • SalesBackorderComponent
  • SalesBackorderCriteria
  • SalesBackorderLine
  • SalesBackorderSummary
  • SalesBin
  • SalesCommission
  • SalesCommissionKey
  • SalesComponent
  • SalesComponentBin
  • SalesComponentBinKey
  • SalesComponentKey
  • SalesComponentLot
  • SalesComponentLotKey
  • SalesComponentSerial
  • SalesComponentSerialKey
  • SalesDistribution
  • SalesDistributionKey
  • SalesDocument
  • SalesDocumentCriteria
  • SalesDocumentCriteriaBase
  • SalesDocumentKey
  • SalesDocumentSummary
  • SalesDocumentSummaryBase
  • SalesDocumentTax
  • SalesDocumentTaxKey
  • SalesDocumentTypeKey
  • SalesFulfillmentOrder
  • SalesFulfillmentOrderComponent
  • SalesFulfillmentOrderCriteria
  • SalesFulfillmentOrderLine
  • SalesFulfillmentOrderSummary
  • SalesHistoryOptions
  • SalesInvoice
  • SalesInvoiceChangedKeyCriteria
  • SalesInvoiceComponent
  • SalesInvoiceCriteria
  • SalesInvoiceLine
  • SalesInvoiceSummary
  • SalesItem
  • SalesItemWarehouse
  • SalesItemWarehouseBin
  • SalesLine
  • SalesLineBin
  • SalesLineBinKey
  • SalesLineKey
  • SalesLineLot
  • SalesLineLotKey
  • SalesLineSerial
  • SalesLineSerialKey
  • SalesLineTax
  • SalesLineTaxKey
  • SalesLot
  • SalesOrder
  • SalesOrderChangedKeyCriteria
  • SalesOrderComponent
  • SalesOrderCriteria
  • SalesOrderLine
  • SalesOrderSummary
  • SalesPayment
  • SalesPaymentKey
  • Salesperson
  • SalespersonChangedKeyCriteria
  • SalespersonCommissions
  • SalespersonCommissionsCriteria
  • SalespersonCommissionsKey
  • SalespersonCommissionsSummary
  • SalespersonCriteria
  • SalespersonHistory
  • SalespersonHistoryKey
  • SalespersonKey
  • SalespersonSummary
  • SalesProcessHold
  • SalesProcessHoldKey
  • SalesProcessHoldSetup
  • SalesProcessHoldSetupCriteria
  • SalesProcessHoldSetupKey
  • SalesQuote
  • SalesQuoteComponent
  • SalesQuoteCriteria
  • SalesQuoteLine
  • SalesQuoteSummary
  • SalesReturn
  • SalesReturnComponent
  • SalesReturnCriteria
  • SalesReturnLine
  • SalesReturnQuantities
  • SalesReturnSummary
  • SalesSerial
  • SalesSerialLot
  • SalesSerialLotBase
  • SalesSummary
  • SalesTax
  • SalesTerms
  • SalesTerritory
  • SalesTerritoryCriteria
  • SalesTerritoryHistory
  • SalesTerritoryHistoryKey
  • SalesTerritoryKey
  • SalesTerritorySummary
  • SalesTrackingNumber
  • SalesTrackingNumberKey
  • SalesUserDefined
  • SecurityKey
  • SequenceKey
  • Service
  • ServiceAddress
  • ServiceAreaKey
  • ServiceAudit
  • ServiceBillTo
  • ServiceCall
  • ServiceCallAdditionalChargeLine
  • ServiceCallCriteria
  • ServiceCallDocument
  • ServiceCallDocumentAudit
  • ServiceCallDocumentCriteria
  • ServiceCallEquipmentCode
  • ServiceCallEquipmentMeter
  • ServiceCallExpenseLine
  • ServiceCallLaborLine
  • ServiceCallLineCauseCodeKey
  • ServiceCallLineProblemCodeKey
  • ServiceCallLineRepairCodeKey
  • ServiceCallPartLine
  • ServiceCallShipToAddress
  • ServiceCallStatusCodeKey
  • ServiceCallSummary
  • ServiceCharge
  • ServiceChargeLine
  • ServiceCriteria
  • ServiceDistanceTraveled
  • ServiceDistribution
  • ServiceDocument
  • ServiceDocumentCriteria
  • ServiceDocumentKey
  • ServiceDocumentSummary
  • ServiceEquipment
  • ServiceEquipmentAddress
  • ServiceEquipmentCode
  • ServiceEquipmentCriteria
  • ServiceEquipmentKey
  • ServiceEquipmentMeter
  • ServiceEquipmentReading
  • ServiceEquipmentReadingKey
  • ServiceEquipmentSummary
  • ServiceLaborLine
  • ServiceLine
  • ServiceLineDetailKey
  • ServiceLineKey
  • ServiceLinePurchaseOrderCreation
  • ServiceLot
  • ServicePartLine
  • ServiceQuote
  • ServiceQuoteAdditionalChargeLine
  • ServiceQuoteCriteria
  • ServiceQuoteExpenseLine
  • ServiceQuoteLaborLine
  • ServiceQuotePartLine
  • ServiceQuoteSummary
  • ServiceSerial
  • ServiceSerialLot
  • ServiceSerialLotKey
  • ServiceStatusKey
  • ServiceSummary
  • ServiceTechnicianKey
  • ServiceTimeZoneKey
  • ServiceTypeKey
  • ServiceWarrantyCode
  • ServiceWarrantyCodeKey
  • ServiceWorkTypeKey
  • ShippingMethod
  • ShippingMethodChangedKeyCriteria
  • ShippingMethodCriteria
  • ShippingMethodKey
  • ShipToAddressKey
  • SickTime
  • Skill
  • SkillCriteria
  • SkillKey
  • SkillSet
  • SkillSetCriteria
  • SkillSetKey
  • SkillSetSummary
  • SourceDocumentKey
  • Spouse
  • SupervisorKey
  • SUTAStateKey
  • Tax
  • TaxDetail
  • TaxDetailChangedKeyCriteria
  • TaxDetailCriteria
  • TaxDetailKey
  • TaxSchedule
  • TaxScheduleCriteria
  • TaxScheduleDetail
  • TaxScheduleDetailChangedKeyCriteria
  • TaxScheduleDetailCriteria
  • TaxScheduleDetailKey
  • TaxScheduleKey
  • Tenant
  • Terms
  • TestKey
  • TimeAndMaterial
  • TimeAwayFromWork
  • TotalProfit
  • TransactionKey
  • UnionKey
  • UofMSchedule
  • UofMScheduleChangedKeyCriteria
  • UofMScheduleCriteria
  • UofMScheduleDetail
  • UofMScheduleDetailKey
  • UofMScheduleKey
  • UofMScheduleSummary
  • UserAssignableBusinessObject
  • UserKey
  • Vacation
  • ValidationError
  • ValidationItem
  • ValidationResult
  • ValidationWarning
  • Vendor
  • VendorAddress
  • VendorAddressCriteria
  • VendorAddressKey
  • VendorAddressSummary
  • VendorClassKey
  • VendorCreditLimit
  • VendorCriteria
  • VendorKey
  • VendorManufacturingOrder
  • VendorManufacturingOrderCriteria
  • VendorManufacturingOrderSummary
  • VendorPlannedOrder
  • VendorPlannedOrderCriteria
  • VendorPlannedOrderSummary
  • VendorSummary
  • Warehouse
  • WarehouseBin
  • WarehouseBinKey
  • WarehouseCriteria
  • WarehouseKey
  • WarehouseSummary
  • WorkersCompensationKey
  • Workflow


Enumerations listing

The following enumerations are defined for the Dynamics GP service.

  • ABCCode
  • AgeCode
  • ApplicationColorCode
  • ApplicationReferenceSource
  • ApplicationRejectionReason
  • ApplicationStatus
  • ApprovalWorkflowStatus
  • BalanceType
  • BillingStatus
  • BillingType
  • BOMCategory
  • BusinessExceptionType
  • CashAccountFromType
  • CashReceiptScope
  • CashReceiptType
  • CommissionBasedOn
  • CompanyOptions
  • CompensationPeriod
  • CostOfGoodsSoldAccountSource
  • CreditLimitSpecialAmount
  • CurrencyDecimalPlaces
  • CurrencyType
  • CustomerScope
  • DataModificationAction
  • DecimalPlaces
  • DecimalSymbol
  • DiscountDateBasedOn
  • DueDateBasedOn
  • EmployeeBaseStepIncreasedOn
  • EmployeePayTypes
  • EmployeeScope
  • EmployeeTipType
  • EmploymentType
  • Ethnicity
  • ExpenseType
  • FeeType
  • FreeOnBoard
  • Frequency
  • Gender
  • GLAccountSummaryType
  • GLAccountType
  • GLLedgerType
  • GLTransactionState
  • GLUnitAccountDecimalPlaces
  • GLVariableAllocationAccountBalanceCalculationType
  • HRRequisitionPostingType
  • HRRequisitionStatus
  • HRStatus
  • InventoriedItemType
  • InventoryTransactionState
  • ISO8061Month
  • ItemType
  • ManufacturingOrderComponentCalculation
  • ManufacturingOrderOutSourced
  • ManufacturingOrderPriority
  • ManufacturingOrderRouteSequenceType
  • ManufacturingOrderStatus
  • MaritalStatus
  • MaximumInvoiceSpecialAmount
  • MaximumWriteoffSpecialAmount
  • NegativeSymbol
  • NegativeSymbolCurrencySymbolLocation
  • OrderFullfillmentShortage
  • OrderPolicy
  • PayableCardType
  • PayablesCashAccountType
  • PayablesDocumentType
  • PayablesPostResultsTo
  • PayablesTransactionState
  • PayablesVendorPaymentScope
  • PaymentMethod
  • PlannedOrderItemStatus
  • PlannedOrderMRPType
  • PlannedOrderParentMRPType
  • PlannedOrderReplenishment
  • PostingFrequency
  • PostingLevel
  • PostingType
  • PostRevaluationResultsTo
  • PriceMethod
  • ProfitType
  • ProjectAccountingMethod
  • ProjectChangeOrderDocumentStatus
  • ProjectChangeOrderStatus
  • ProjectChangeOrderTrackChangesToType
  • ProjectChangeOrderType
  • ProjectCloseToBillings
  • ProjectCloseToProjectCosts
  • ProjectFeeType
  • ProjectFrequency
  • ProjectLaborRateTableType
  • ProjectOverheadRateMethod
  • ProjectSourceFile
  • ProjectStatus
  • ProjectTaxBasis
  • ProjectTransactionState
  • ProjectTransactionType
  • ProjectType
  • PurchaseOrderFormat
  • PurchaseOrderLineOrigin
  • PurchaseOrderStatus
  • PurchaseOrderTransactionState
  • PurchaseOrderType
  • PurchaseTransactionState
  • PurchasingTaxBasis
  • QuantityDecimalPlaces
  • QuantityType
  • RateCalculation
  • ReceivableCardType
  • ReceivablesCashAccountType
  • ReceivablesDocumentScope
  • ReceivablesDocumentType
  • ReceivablesPostResultsTo
  • ReceivablesTransactionState
  • RelativeLocation
  • ReplenishmentMethod
  • ReturnMaterialAuthorizationOriginatingDocumentType
  • ReturnMaterialAuthorizationReturnStatus
  • ReturnMaterialAuthorizationTransferDocumentStatus
  • ReturnMaterialAuthorizationType
  • ReturnScope
  • RevaluationMethod
  • RoundHow
  • RoundTo
  • SalaryPostingType
  • SalesCommissionTransactionState
  • SalesDocumentScope
  • SalesDocumentType
  • SalesPaymentType
  • SalespersonCommissionsDocumentType
  • SalespersonScope
  • SalesSummaryType
  • SalesTaxBasis
  • SalesTransactionState
  • SchedulingMethod
  • SeriesType
  • ServiceAddressOptionTypes
  • ServiceCallDocumentScope
  • ServiceCallType
  • ServiceEquipmentScope
  • ServiceLaborUseType
  • ServicePartUseType
  • ServiceTransactionState
  • ShippingMethodType
  • ShippingProcessStatus
  • StatementCycle
  • StatusGroup
  • SupportedContainment
  • Tax1099Type
  • TaxDetailBase
  • TaxDetailBaseQualfiers
  • TaxDetailRangeType
  • TaxDetailRounding
  • TaxDetailType
  • ThousandsSymbol
  • TimeAwayFromWorkAccrualMethod
  • TrackingOption
  • TypicalBalance
  • UofMSalesAvailable
  • ValuationMethod
  • VendorManufacturingOrderScope
  • VendorPlannedOrderScope
  • VendorScope
  • WorkflowPriority


Policies listing

The following default policies are defined for the Dynamics GP service.

  • Create Applicant Policy
  • Create Applicant Education Policy
  • Create Applicant Interview Policy
  • Create Applicant Reference Policy
  • Create Applicant Skill Policy
  • Create Applicant Test Policy
  • Create Applicant Work History Policy
  • Create Back Office Role Assignment Policy
  • Create Cash Receipt Policy
  • Create Corporate Account Policy
  • Create Customer Address Policy
  • Create Customer Policy
  • Create Employee Policy
  • Create Employee Address Policy
  • Create Employee Pay Code Policy
  • Create Fee Policy
  • Create GL Fixed Allocation Account Policy
  • Create GL Posting Account Policy
  • Create GL Transaction Policy
  • Create GL Unit Account Policy
  • Create GL Variable Allocation Account Policy
  • Create HRRequisition Policy
  • Create Inventory Adjustment Policy
  • Create Inventory Transfer Policy
  • Create Inventory Variance Policy
  • Create Item Currency Policy
  • Create Item Vendor Policy
  • Create Item Warehouse Policy
  • Create Kit Policy
  • Create Payables Credit Memo Policy
  • Create Payables Finance Charge Policy
  • Create Payables Invoice Policy
  • Create Payables Miscellaneous Charge Policy
  • Create Payables Return Policy
  • Create Pricing Policy
  • Create Purchase Invoice Policy
  • Create Purchase Order Policy
  • Create Purchase Receipt Policy
  • Create Receivables Credit Memo Policy
  • Create Receivables Debit Memo Policy
  • Create Receivables Finance Charge Policy
  • Create Receivables Invoice Policy
  • Create Receivables Return Policy
  • Create Receivables Service Repair Policy
  • Create Receivables Warranty Policy
  • Create Return Material Authorization Policy
  • Create Sales Backorder Policy
  • Create Sales Fulfillment Order Policy
  • Create Sales Invoice Policy
  • Create Sales Item Policy
  • Create Sales Order Policy
  • Create Sales Process Hold Setup Policy
  • Create Sales Quote Policy
  • Create Sales Return Policy
  • Create Service Call Policy
  • Create Service Equipment Policy
  • Create Service Policy
  • Create Service Quote Policy
  • Create Skill Policy
  • Create Skillset Policy
  • Create Vendor Address Policy
  • Create Vendor Policy
  • Create Warehouse Policy
  • Delete Applicant Policy
  • Delete Applicant Education Policy
  • Delete Applicant Interview Policy
  • Delete Applicant Reference Policy
  • Delete Applicant Skill Policy
  • Delete Applicant Test Policy
  • Delete Applicant Work History Policy
  • Delete Customer Address Policy
  • Delete Customer Policy
  • Delete Employee Address Policy
  • Delete Purchase Order Policy
  • Delete Sales Backorder Policy
  • Delete Sales Fulfillment Order Policy
  • Delete Sales Invoice Policy
  • Delete Sales Order Policy
  • Delete Sales Quote Policy
  • Delete Sales Return Policy
  • Delete Skill Policy
  • Delete Skillset Policy
  • Delete Vendor Address Policy
  • Discontinue Sales Item Policy
  • Update Applicant Policy
  • Update Applicant Education Policy
  • Update Applicant Interview Policy
  • Update Applicant Reference Policy
  • Update Applicant Skill Policy
  • Update Applicant Test Policy
  • Update Applicant Work History Policy
  • Update Corporate Account Policy
  • Update Customer Address Policy
  • Update Customer Policy
  • Update Employee Policy
  • Update Employee Address Policy
  • Update Employee Pay Code Policy
  • Update HRRequisition Policy
  • Update Item Vendor Policy
  • Update Purchase Order Policy
  • Update Return Material Authorization Policy
  • Update Sales Backorder Policy
  • Update Sales Fulfillment Order Policy
  • Update Sales Invoice Policy
  • Update Sales Order Policy
  • Update Sales Process Hold Setup Policy
  • Update Sales Quote Policy
  • Update Sales Return Policy
  • Update Service Call Policy
  • Update Service Equipment Policy
  • Update Service Quote Policy
  • Update Skill Policy
  • Update Skillset Policy
  • Update Vendor Address Policy
  • Update Vendor Policy
  • Void Cash Receipt Policy
  • Void Purchase Order Policy
  • Void Receivables Credit Memo Policy
  • Void Receivables Return Policy
  • Void Sales Backorder Policy
  • Void Sales Invoice Policy
  • Void Sales Order Policy
  • Void Sales Quote Policy
  • Void Sales Return Policy


Interfaces listing

The following interfaces are available for the Dynamics GP service.

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales


Method reference

The method reference provides details of each method in the Microsoft Dynamics GP service. The following is a list of the conventions used in this documentation.

Each method has the following:

  • The name of the method
  • The parameters for the method
  • The return value of the method (if applicable)
  • The interfaces in which the method is available
  • Examples of how to use the method, including both the legacy endpoint and native endpoint


CreateApplicant

Description

This method creates a new job applicant.

Parameters

Parameter | Type | Description
businessObject | Applicant | The applicant object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new applicant. The FirstName, LastName, DateApplied, and Applications properties are set. All other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Applicant applicant;
            ApplicantApplication applicantApplication;
            Policy applicantCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant object
            applicant = new Applicant();

            // Populate the required fields of the applicant object
            applicant.FirstName = "Test";
            applicant.LastName = "Applicant";
            applicant.DateApplied = DateTime.Today;

            // Create an applicant application object
            applicantApplication = new ApplicantApplication();

            // Populate the required fields of the applicant application object
            applicantApplication.DateApplied = DateTime.Today;

            // Add the application object to the applicant object
            ApplicantApplication[] applications = {applicantApplication};
            applicant.Applications = applications;

            // Get the create policy for applicants
            applicantCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateApplicant", context);

            // Create the applicant
            wsDynamicsGP.CreateApplicant(applicant, context, applicantCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Applicant applicant;
            ApplicantApplication applicantApplication;
            Policy applicantCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant object
            applicant = new Applicant();

            // Populate the required fields of the applicant object
            applicant.FirstName = "Test";
            applicant.LastName = "Applicant";
            applicant.DateApplied = DateTime.Today;

            // Create an applicant application object
            applicantApplication = new ApplicantApplication();

            // Populate the required fields of the applicant application object
            applicantApplication.DateApplied = DateTime.Today;

            // Add the application object to the applicant object
            ApplicantApplication[] applications = {applicantApplication};
            applicant.Applications = applications;

            // Get the create policy for applicants
            applicantCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateApplicant", context);

            // Create the applicant
            wsDynamicsGP.CreateApplicant(applicant, context, applicantCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateApplicantEducation

Description

This method creates a new applicant education entry for a specified applicant.

Parameters

Parameter | Type | Description
businessObject | ApplicantEducation | The applicant education object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new applicant education entry for an applicant. The ApplicantKey property of the ApplicantSequenceKey object specifies the applicant. The SequenceKey property of the ApplicantSequenceKey should not be populated for the create operation.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantEducation applicantEducation;
            ApplicantKey applicantKey;
            ApplicantSequenceKey applicantSequenceKey;
            Policy applicantEducationCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant education object
            applicantEducation = new ApplicantEducation();

            // Use the applicant key to specify an applicant object
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an applicant sequence key object
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;

            // Populate the fields of the applicant education object
            applicantEducation.ApplicantEducationKey = applicantSequenceKey;
            applicantEducation.School = "Local University";

            // Get the create policy for application education objects
            applicantEducationCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantEducation", context);

            // Create the applicant education record
            wsDynamicsGP.CreateApplicantEducation(applicantEducation,
                context, applicantEducationCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantEducation applicantEducation;
            ApplicantKey applicantKey;
            ApplicantSequenceKey applicantSequenceKey;
            Policy applicantEducationCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant education object
            applicantEducation = new ApplicantEducation();

            // Use the applicant key to specify an applicant object
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an applicant sequence key object
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;

            // Populate the fields of the applicant education object
            applicantEducation.ApplicantEducationKey = applicantSequenceKey;
            applicantEducation.School = "Local University";

            // Get the create policy for application education objects
            applicantEducationCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantEducation", context);

            // Create the applicant education record
            wsDynamicsGP.CreateApplicantEducation(applicantEducation,
                context, applicantEducationCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateApplicantInterview

Description

This method creates a new applicant interview entry for a specified applicant.

Parameters

Parameter | Type | Description
businessObject | ApplicantInterview | The applicant interview object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new applicant interview entry for an applicant. The ApplicantKey property of the ApplicantInterviewTypeKey object specifies the applicant. The InterviewTypeKey property of the ApplicantInterviewTypeKey specifies the type of interview.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterview applicantInterview;
            ApplicantKey applicantKey;
            ApplyDateKey applyDateKey;
            InterviewTypeKey interviewTypeKey;
            ApplicantInterviewTypeKey applicantInterviewTypeKey;
            Policy applicantInterviewCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant interview object
            applicantInterview = new ApplicantInterview();

            // Use the applicant key to specify an applicant
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an apply date key
            applyDateKey = new ApplyDateKey();
            applyDateKey.Id = DateTime.Today;

            // Create an interview type key
            interviewTypeKey = new InterviewTypeKey();
            interviewTypeKey.Id = "test";

            // Create an applicant interview type key object
            applicantInterviewTypeKey = new ApplicantInterviewTypeKey();
            applicantInterviewTypeKey.ApplicantKey = applicantKey;
            applicantInterviewTypeKey.ApplyDateKey = applyDateKey;
            applicantInterviewTypeKey.InterviewTypeKey = interviewTypeKey;

            // Populate the fields of the applicant interview object
            applicantInterview.ApplicantInterviewKey = applicantInterviewTypeKey;
            applicantInterview.Notes = "Test interview information";

            // Get the create policy for application interview objects
            applicantInterviewCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantInterview", context);

            // Create the applicant interview record
            wsDynamicsGP.CreateApplicantInterview(applicantInterview,
                context, applicantInterviewCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterview applicantInterview;
            ApplicantKey applicantKey;
            ApplyDateKey applyDateKey;
            InterviewTypeKey interviewTypeKey;
            ApplicantInterviewTypeKey applicantInterviewTypeKey;
            Policy applicantInterviewCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant interview object
            applicantInterview = new ApplicantInterview();

            // Use the applicant key to specify an applicant
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an apply date key
            applyDateKey = new ApplyDateKey();
            applyDateKey.Id = DateTime.Today;

            // Create an interview type key
            interviewTypeKey = new InterviewTypeKey();
            interviewTypeKey.Id = "test";

            // Create an applicant interview type key object
            applicantInterviewTypeKey = new ApplicantInterviewTypeKey();
            applicantInterviewTypeKey.ApplicantKey = applicantKey;
            applicantInterviewTypeKey.ApplyDateKey = applyDateKey;
            applicantInterviewTypeKey.InterviewTypeKey = interviewTypeKey;

            // Populate the fields of the applicant interview object
            applicantInterview.ApplicantInterviewKey = applicantInterviewTypeKey;
            applicantInterview.Notes = "Test interview information";

            // Get the create policy for application interview objects
            applicantInterviewCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantInterview", context);

            // Create the applicant interview record
            wsDynamicsGP.CreateApplicantInterview(applicantInterview,
                context, applicantInterviewCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateApplicantReference

Description

This method creates a new applicant reference entry for a specified applicant.

Parameters

Parameter | Type | Description
businessObject | ApplicantReference | The applicant reference object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new applicant reference entry for an applicant. The ApplicantKey property of the ApplicantReferenceKey object specifies the applicant. Use the Id property of the ApplicantReferenceKey to uniquely identify the reference object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantReference applicantReference;
            ApplicantKey applicantKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantReferenceKey applicantReferenceKey;
            Policy applicantReferenceCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create and applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an applicant sequence key object
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;

            // Use the applicant reference key to specify an applicant reference object
            applicantReferenceKey = new ApplicantReferenceKey();
            applicantReferenceKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantReferenceKey.Id = "Test reference";

            // Create an applicant reference object
            applicantReference = new ApplicantReference();

            // Populate the fields of the applicant reference object
            applicantReference.ApplicantReferenceKey = applicantReferenceKey;
            applicantReference.Relationship = "Coworker";

            // Get the create policy for application reference objects
            applicantReferenceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantReference", context);

            // Create the applicant reference record
            wsDynamicsGP.CreateApplicantReference(applicantReference,
                context, applicantReferenceCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantReference applicantReference;
            ApplicantKey applicantKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantReferenceKey applicantReferenceKey;
            Policy applicantReferenceCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create and applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an applicant sequence key object
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;

            // Use the applicant reference key to specify an applicant reference object
            applicantReferenceKey = new ApplicantReferenceKey();
            applicantReferenceKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantReferenceKey.Id = "Test reference";

            // Create an applicant reference object
            applicantReference = new ApplicantReference();

            // Populate the fields of the applicant reference object
            applicantReference.ApplicantReferenceKey = applicantReferenceKey;
            applicantReference.Relationship = "Coworker";

            // Get the create policy for application reference objects
            applicantReferenceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantReference", context);

            // Create the applicant reference record
            wsDynamicsGP.CreateApplicantReference(applicantReference,
                context, applicantReferenceCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateApplicantSkill

Description

This method creates a new applicant skill entry for a specified applicant.

Parameters

Parameter | Type | Description
businessObject | ApplicantSkill | The applicant skill object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new applicant skill entry for an applicant. The ApplicantKey property of the ApplicantSkillKey object specifies the applicant. Use the Id property of the SkillKey to identify the skill object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSkill applicantSkill;
            ApplicantSkillKey applicantSkillKey;
            ApplicantKey applicantKey;
            SkillKey skillKey;
            Policy applicantSkillCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key object
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create an applicant skill key
            applicantSkillKey = new ApplicantSkillKey();
            applicantSkillKey.ApplicantKey = applicantKey;
            applicantSkillKey.SkillKey = skillKey;

            // Create an applicant skill object
            applicantSkill = new ApplicantSkill();

            // Populate the fields of the applicant skill object
            applicantSkill.ApplicantSkillKey = applicantSkillKey;
            applicantSkill.SkillNumber = 1;
            applicantSkill.Comments = "Created applicant skill";

            // Get the create policy for applicant skill objects
            applicantSkillCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantSkill", context);

            // Create the applicant skill record
            wsDynamicsGP.CreateApplicantSkill(applicantSkill,
                context, applicantSkillCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSkill applicantSkill;
            ApplicantSkillKey applicantSkillKey;
            ApplicantKey applicantKey;
            SkillKey skillKey;
            Policy applicantSkillCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key object
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create an applicant skill key
            applicantSkillKey = new ApplicantSkillKey();
            applicantSkillKey.ApplicantKey = applicantKey;
            applicantSkillKey.SkillKey = skillKey;

            // Create an applicant skill object
            applicantSkill = new ApplicantSkill();

            // Populate the fields of the applicant skill object
            applicantSkill.ApplicantSkillKey = applicantSkillKey;
            applicantSkill.SkillNumber = 1;
            applicantSkill.Comments = "Created applicant skill";

            // Get the create policy for applicant skill objects
            applicantSkillCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantSkill", context);

            // Create the applicant skill record
            wsDynamicsGP.CreateApplicantSkill(applicantSkill,
                context, applicantSkillCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateApplicantTest

Description

This method creates test information for a specified applicant.

Parameters

Parameter | Type | Description
businessObject | ApplicantTest | The applicant test object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new applicant test entry for an applicant. The ApplicantSequenceKey property of the ApplicantTestKey object specifies the applicant. The Id property of the TestKey specifies “TEST1” to specify the test object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantTest applicantTest;
            ApplicantKey applicantKey;
            ApplicantTestKey applicantTestlKey;
            ApplicantSequenceKey applicantSequenceKey;
            TestKey testKey;
            Policy applicantTestCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an applicant sequence key object
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;

            // Create a test key
            testKey = new TestKey();
            testKey.Id = "TEST1";

            // Create an applicant test key
            applicantTestlKey = new ApplicantTestKey();
            applicantTestlKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantTestlKey.TestKey = testKey;

            // Create an applicant test object
            applicantTest = new ApplicantTest();

            // Populate the fields of the applicant test object
            applicantTest.ApplicantTestKey = applicantTestlKey;
            applicantTest.Notes = "Created applicant test object";

            // Get the create policy for application test objects
            applicantTestCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantTest", context);

            // Create the applicant test record
            wsDynamicsGP.CreateApplicantTest(applicantTest,
                context, applicantTestCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantTest applicantTest;
            ApplicantKey applicantKey;
            ApplicantTestKey applicantTestlKey;
            ApplicantSequenceKey applicantSequenceKey;
            TestKey testKey;
            Policy applicantTestCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an applicant sequence key object
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;

            // Create a test key
            testKey = new TestKey();
            testKey.Id = "TEST1";

            // Create an applicant test key
            applicantTestlKey = new ApplicantTestKey();
            applicantTestlKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantTestlKey.TestKey = testKey;

            // Create an applicant test object
            applicantTest = new ApplicantTest();

            // Populate the fields of the applicant test object
            applicantTest.ApplicantTestKey = applicantTestlKey;
            applicantTest.Notes = "Created applicant test object";

            // Get the create policy for application test objects
            applicantTestCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantTest", context);

            // Create the applicant test record
            wsDynamicsGP.CreateApplicantTest(applicantTest,
                context, applicantTestCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateApplicantWorkHistory

Description

This method creates work history information for a specified applicant.

Parameters

Parameter | Type | Description
businessObject | ApplicantWorkHistory | The applicant work history object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates work history information for an applicant. The ApplicantSequenceKey property of the ApplicantWorkHistoryKey object specifies the applicant. The Id property of the ApplicantWorkHistoryKey identifies the name a the prior employer of the applicant.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantWorkHistory applicantWorkHistory;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantWorkHistoryKey applicantWorkHistoryKey;
            Policy applicantWorkHistoryCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key object
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;

            // Create an applicant work history key
            applicantWorkHistoryKey = new ApplicantWorkHistoryKey();
            applicantWorkHistoryKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantWorkHistoryKey.Id = "Previous employer";

            // Create an applicant work history object
            applicantWorkHistory = new ApplicantWorkHistory();

            // Populate the fields of the applicant work history object
            applicantWorkHistory.ApplicantWorkHistoryKey = applicantWorkHistoryKey;
            applicantWorkHistory.YearsOfExperience = 2;

            // Get the create policy for applicant work history objects
            applicantWorkHistoryCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantWorkHistory", context);

            // Create the applicant work history record
            wsDynamicsGP.CreateApplicantWorkHistory(applicantWorkHistory,
                context, applicantWorkHistoryCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantWorkHistory applicantWorkHistory;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantWorkHistoryKey applicantWorkHistoryKey;
            Policy applicantWorkHistoryCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key object
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;

            // Create an applicant work history key
            applicantWorkHistoryKey = new ApplicantWorkHistoryKey();
            applicantWorkHistoryKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantWorkHistoryKey.Id = "Previous employer";

            // Create an applicant work history object
            applicantWorkHistory = new ApplicantWorkHistory();

            // Populate the fields of the applicant work history object
            applicantWorkHistory.ApplicantWorkHistoryKey = applicantWorkHistoryKey;
            applicantWorkHistory.YearsOfExperience = 2;

            // Get the create policy for applicant work history objects
            applicantWorkHistoryCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateApplicantWorkHistory", context);

            // Create the applicant work history record
            wsDynamicsGP.CreateApplicantWorkHistory(applicantWorkHistory,
                context, applicantWorkHistoryCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateBackOfficeRoleAssignment

Description

This method creates a new back office role assignment, assigning a Microsoft Dynamics GP user to a security role.

Parameters

Parameter | Type | Description
backOfficeRoleAssignment | BackOfficeRoleAssignment | The back office role assignment object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example adds the user “STEVEK” to the “PAYROLL CLERK*” back office security role for the sample company in Microsoft Dynamics GP.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CompanyKey companyKey;
            BackOfficeRoleKey roleKey;
            UserKey userKey;
            BackOfficeRoleAssignment backOfficeRoleAssignment;
            BackOfficeRoleAssignmentKey backOfficeRoleAssignmentKey;
            Policy roleAssignmentCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Specify the assignment will be created in the sample company
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the role
            roleKey = new BackOfficeRoleKey();
            roleKey.Id = "PAYROLL CLERK*";

            // Specify the user
            userKey = new UserKey();
            userKey.Id = "STEVEK";

            // Create the backOfficeRoleAssignment and key
            backOfficeRoleAssignment = new BackOfficeRoleAssignment();
            backOfficeRoleAssignmentKey = new BackOfficeRoleAssignmentKey();

            // Define back office role assignment
            backOfficeRoleAssignmentKey.CompanyKey = companyKey;
            backOfficeRoleAssignmentKey.RoleKey = roleKey;
            backOfficeRoleAssignmentKey.UserKey = userKey;
            backOfficeRoleAssignment.Key = backOfficeRoleAssignmentKey;

            // Get the create policy for back office role assignment objects
            roleAssignmentCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateBackOfficeRoleAssignment",
            context);

            // Create the back office role assignment
            wsDynamicsGP.CreateBackOfficeRoleAssignment(backOfficeRoleAssignment, context,
            roleAssignmentCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CompanyKey companyKey;
            BackOfficeRoleKey roleKey;
            UserKey userKey;
            BackOfficeRoleAssignment backOfficeRoleAssignment;
            BackOfficeRoleAssignmentKey backOfficeRoleAssignmentKey;
            Policy roleAssignmentCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Specify the assignment will be created in the sample company
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the role
            roleKey = new BackOfficeRoleKey();
            roleKey.Id = "PAYROLL CLERK*";

            // Specify the user
            userKey = new UserKey();
            userKey.Id = "STEVEK";

            // Create the backOfficeRoleAssignment and key
            backOfficeRoleAssignment = new BackOfficeRoleAssignment();
            backOfficeRoleAssignmentKey = new BackOfficeRoleAssignmentKey();

            // Define back office role assignment
            backOfficeRoleAssignmentKey.CompanyKey = companyKey;
            backOfficeRoleAssignmentKey.RoleKey = roleKey;
            backOfficeRoleAssignmentKey.UserKey = userKey;
            backOfficeRoleAssignment.Key = backOfficeRoleAssignmentKey;

            // Get the create policy for back office role assignment objects
            roleAssignmentCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateBackOfficeRoleAssignment",
            context);

            // Create the back office role assignment
            wsDynamicsGP.CreateBackOfficeRoleAssignment(backOfficeRoleAssignment, context,
            roleAssignmentCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateBusinessObjectUserAssignment

Description

This method creates a new business object user assignment, assigning a Windows User ID to an ID in Microsoft Dynamics GP.

Parameters

Parameter | Type | Description
businessObjectUserAssignment | BusinessObjectUserAssignment | The business object user assignment object being created.
context | Context | Specifies information about how the method will be called.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example assigns the Windows User “CORPORATE\stevek” to the Back Office User “STEVEK” in Microsoft Dynamics GP.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Guid BusinessObjectType = new Guid();
            UserAssignableBusinessObject[] userAssignableBusinessObjects;
            BusinessObjectUserAssignment businessObjectUserAssignment;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the list of user-assignable business objects
            userAssignableBusinessObjects = wsDynamicsGP.GetUserAssignableBusinessObjectList(context);

            // Find the type for Back Office User
            foreach (UserAssignableBusinessObject u in userAssignableBusinessObjects)
            {
                if (u.BusinessObjectTypeDisplayName == "Back Office User")
                {
                    BusinessObjectType = u.BusinessObjectTypeId;
                    break;
                }
            }

            // Define the business object user assignment
            businessObjectUserAssignment = new BusinessObjectUserAssignment();
            businessObjectUserAssignment.BusinessObjectKey = "STEVEK";
            businessObjectUserAssignment.BusinessObjectTypeId = BusinessObjectType;
            businessObjectUserAssignment.OrganizationKey = null;  //Enterprise-level
            businessObjectUserAssignment.User = "CORPORATE\\stevek";

            // Create the business object user assignment
            wsDynamicsGP.CreateBusinessObjectUserAssignment(businessObjectUserAssignment, context);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Guid BusinessObjectType = new Guid();
            UserAssignableBusinessObject[] userAssignableBusinessObjects;
            BusinessObjectUserAssignment businessObjectUserAssignment;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the list of user-assignable business objects
            userAssignableBusinessObjects = wsDynamicsGP.GetUserAssignableBusinessObjectList(context);

            // Find the type for Back Office User
            foreach (UserAssignableBusinessObject u in userAssignableBusinessObjects)
            {
                if (u.BusinessObjectTypeDisplayName == "Back Office User")
                {
                    BusinessObjectType = u.BusinessObjectTypeId;
                    break;
                }
            }

            // Define the business object user assignment
            businessObjectUserAssignment = new BusinessObjectUserAssignment();
            businessObjectUserAssignment.BusinessObjectKey = "STEVEK";
            businessObjectUserAssignment.BusinessObjectTypeId = BusinessObjectType;
            businessObjectUserAssignment.OrganizationKey = null;  //Enterprise-level
            businessObjectUserAssignment.User = "CORPORATE\\stevek";

            // Create the business object user assignment
            wsDynamicsGP.CreateBusinessObjectUserAssignment(businessObjectUserAssignment, context);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateCashReceipt

Description

This method creates a new cash receipt.

Parameters

Parameter | Type | Description
cashReceipt | CashReceipt | The cash receipt object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a new cash receipt with a key value “WSPYMNT0000000010”. The cash receipt key, customer key, and cash amount properties are set. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            MoneyAmount cashAmount;
            ReceivablesDocumentKey cashReceiptKey;
            CashReceipt cashReceipt;
            Policy cashReceiptCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key to identify the cash receipt
            cashReceiptKey = new ReceivablesDocumentKey();
            cashReceiptKey.Id = "WSPYMNT0000000010";

            // Create a customer key object to specify the customer for the cash receipt
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the amount of the cash receipt
            cashAmount = new MoneyAmount();
            cashAmount.Currency = "USD";
            cashAmount.Value = 10m;

            // Create the cash receipt object and populate the required properties
            cashReceipt = new CashReceipt();
            cashReceipt.Key = cashReceiptKey;
            cashReceipt.CustomerKey = customerKey;
            cashReceipt.Amount = cashAmount;

            // Get the create policy for cash receipts
            cashReceiptCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateCashReceipt", context);

            // Create the cash receipt
            wsDynamicsGP.CreateCashReceipt(cashReceipt, context, cashReceiptCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            MoneyAmount cashAmount;
            ReceivablesDocumentKey cashReceiptKey;
            CashReceipt cashReceipt;
            Policy cashReceiptCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key to identify the cash receipt
            cashReceiptKey = new ReceivablesDocumentKey();
            cashReceiptKey.Id = "WSPYMNT0000000010";

            // Create a customer key object to specify the customer for the cash receipt
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the amount of the cash receipt
            cashAmount = new MoneyAmount();
            cashAmount.Currency = "USD";
            cashAmount.Value = 10m;

            // Create the cash receipt object and populate the required properties
            cashReceipt = new CashReceipt();
            cashReceipt.Key = cashReceiptKey;
            cashReceipt.CustomerKey = customerKey;
            cashReceipt.Amount = cashAmount;

            // Get the create policy for cash receipts
            cashReceiptCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateCashReceipt", context);

            // Create the cash receipt
            wsDynamicsGP.CreateCashReceipt(cashReceipt, context, cashReceiptCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateCorporateAccount

Description

This method creates a new corporate account.

Parameters

Parameter | Type | Description
corporateAccount | CorporateAccount | The corporate account object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a new corporate account. The customer object with the key value “COMMUNIC0001” becomes the parent corporate account. The customer object with the key value of “COMMUNIC0002“ is added as a member of the corporate account. All other properties of the corporate account are left as default values. A corporate account may also be created without specifying any members.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey parentCustomerKey;
            CustomerKey memberCustomerKey;
            CorporateAccount corporateAccount;
            CorporateAccountMemberKey memberKey;
            CorporateAccountMember member;
            Policy createCorpAccountPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the parent corporate account
            parentCustomerKey = new CustomerKey();
            parentCustomerKey.Id = "COMMUNIC0001";

            // Create a customer key to specify the member
            memberCustomerKey = new CustomerKey();
            memberCustomerKey.Id = "COMMUNIC0002";

            // Create a corporate account member key
            // Use the customer keys to specify the parent and the member
            memberKey = new CorporateAccountMemberKey();
            memberKey.CorporateAccountKey = parentCustomerKey;
            memberKey.CustomerKey = memberCustomerKey;

            // Create a corporate account member object
            // Populate the Key property with the member key object
            member = new CorporateAccountMember();
            member.Key = memberKey;

            // Add the corporate account member to an array
            CorporateAccountMember[] corpAccountMembers = {member};

            // Create a corporate account object
            corporateAccount = new CorporateAccount();
            corporateAccount.Key = parentCustomerKey;
            corporateAccount.Members = corpAccountMembers;

            // Get the create policy for corporate accounts
            createCorpAccountPolicy = wsDynamicsGP.GetPolicyByOperation("CreateCorporateAccount", context);

            // Create the corporate account
            wsDynamicsGP.CreateCorporateAccount(corporateAccount, context, createCorpAccountPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey parentCustomerKey;
            CustomerKey memberCustomerKey;
            CorporateAccount corporateAccount;
            CorporateAccountMemberKey memberKey;
            CorporateAccountMember member;
            Policy createCorpAccountPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the parent corporate account
            parentCustomerKey = new CustomerKey();
            parentCustomerKey.Id = "COMMUNIC0001";

            // Create a customer key to specify the member
            memberCustomerKey = new CustomerKey();
            memberCustomerKey.Id = "COMMUNIC0002";

            // Create a corporate account member key
            // Use the customer keys to specify the parent and the member
            memberKey = new CorporateAccountMemberKey();
            memberKey.CorporateAccountKey = parentCustomerKey;
            memberKey.CustomerKey = memberCustomerKey;

            // Create a corporate account member object
            // Populate the Key property with the member key object
            member = new CorporateAccountMember();
            member.Key = memberKey;

            // Add the corporate account member to an array
            CorporateAccountMember[] corpAccountMembers = {member};

            // Create a corporate account object
            corporateAccount = new CorporateAccount();
            corporateAccount.Key = parentCustomerKey;
            corporateAccount.Members = corpAccountMembers;

            // Get the create policy for corporate accounts
            createCorpAccountPolicy = wsDynamicsGP.GetPolicyByOperation("CreateCorporateAccount", context);

            // Create the corporate account
            wsDynamicsGP.CreateCorporateAccount(corporateAccount, context, createCorpAccountPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateCustomer

Description

This method creates a new customer.

Parameters

Parameter | Type | Description
customer | Customer | The customer object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a new customer with the key value “CONTOSO”. The Name property is set, and all other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            Policy customerPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a new customer object
            customer = new Customer();

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "CONTOSO";
            customer.Key = customerKey;

            // Set properties for the new customer
            customer.Name = "Contoso, Ltd";

            // Get the create policy for the customer
            customerPolicy = wsDynamicsGP.GetPolicyByOperation("CreateCustomer", context);

            // Create the customer
            wsDynamicsGP.CreateCustomer(customer, context, customerPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            Policy customerPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a new customer object
            customer = new Customer();

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "CONTOSO";
            customer.Key = customerKey;

            // Set properties for the new customer
            customer.Name = "Contoso, Ltd";

            // Get the create policy for the customer
            customerPolicy = wsDynamicsGP.GetPolicyByOperation("CreateCustomer", context);

            // Create the customer
            wsDynamicsGP.CreateCustomer(customer, context, customerPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateCustomerAddress

Description

This method creates a new customer address.

Parameters

Parameter | Type | Description
address | CustomerAddress | The customer address object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a customer address with the key value “BILLING” for the customer with a customer key of “AARONFIT0001”. The Line1, Line2, City, State, and CountryRegion properties are set. All other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerAddressKey customerAddressKey;
            CustomerAddress customerAddress;
            Policy customerAddressCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a customer address key
            customerAddressKey = new CustomerAddressKey();
            customerAddressKey.CustomerKey = customerKey;
            customerAddressKey.Id = "BILLING";

            // Create a customer address object
            customerAddress = new CustomerAddress();
            customerAddress.Key = customerAddressKey;

            // Populate properties with address information
            customerAddress.Line1 = "11403 45 St. South";
            customerAddress.Line2 = "Billing Dept.";
            customerAddress.City = "Chicago";
            customerAddress.State = "IL";
            customerAddress.CountryRegion = "USA";

            // Get the create policy for the customer address
            customerAddressCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateCustomerAddress",
            context);

            // Create the customer address
            wsDynamicsGP.CreateCustomerAddress(customerAddress, context, customerAddressCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerAddressKey customerAddressKey;
            CustomerAddress customerAddress;
            Policy customerAddressCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a customer address key
            customerAddressKey = new CustomerAddressKey();
            customerAddressKey.CustomerKey = customerKey;
            customerAddressKey.Id = "BILLING";

            // Create a customer address object
            customerAddress = new CustomerAddress();
            customerAddress.Key = customerAddressKey;

            // Populate properties with address information
            customerAddress.Line1 = "11403 45 St. South";
            customerAddress.Line2 = "Billing Dept.";
            customerAddress.City = "Chicago";
            customerAddress.State = "IL";
            customerAddress.CountryRegion = "USA";

            // Get the create policy for the customer address
            customerAddressCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateCustomerAddress",
            context);

            // Create the customer address
            wsDynamicsGP.CreateCustomerAddress(customerAddress, context, customerAddressCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateEmployee

Description

This method creates a new employee.

Parameters

Parameter | Type | Description
employee | Employee | The employee object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new employee with the key value “ABARR”. The example populates the required Name, TaxIdentifier, DepartmentKey, and PositionKey properties. The remaining properties use default values. The CreateEmployee operation saves the new employee.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Employee employee;
            EmployeeKey employeeKey;
            Name employeeName;
            DepartmentKey departmentKey;
            PositionKey positionKey;
            Policy employeePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a new employee object
            employee = new Employee();

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ABARR";
            employee.Key = employeeKey;

            // Set properties for the new employee

            // Specify the employee name
            employeeName = new Name();
            employeeName.Given = "Adam";
            employeeName.Family = "Barr";
            employee.Name = employeeName;

            // Specify the tax identifier
            employee.TaxIdentifier = "917238675";

            // Specify the department -- Sales
            departmentKey = new DepartmentKey();
            departmentKey.Id = "SALE";
            employee.DepartmentKey = departmentKey;

            // Specify the employee position -- Field Sales Representitive
            positionKey = new PositionKey();
            positionKey.Id = "FSR";
            employee.PositionKey = positionKey;

            // Get the create policy for the employee
            employeePolicy = wsDynamicsGP.GetPolicyByOperation("CreateEmployee", context);

            // Create the employee
            wsDynamicsGP.CreateEmployee(employee, context, employeePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Employee employee;
            EmployeeKey employeeKey;
            Name employeeName;
            DepartmentKey departmentKey;
            PositionKey positionKey;
            Policy employeePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a new employee object
            employee = new Employee();

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ABARR";
            employee.Key = employeeKey;

            // Set properties for the new employee

            // Specify the employee name
            employeeName = new Name();
            employeeName.Given = "Adam";
            employeeName.Family = "Barr";
            employee.Name = employeeName;

            // Specify the tax identifier
            employee.TaxIdentifier = "917238675";

            // Specify the department -- Sales
            departmentKey = new DepartmentKey();
            departmentKey.Id = "SALE";
            employee.DepartmentKey = departmentKey;

            // Specify the employee position -- Field Sales Representitive
            positionKey = new PositionKey();
            positionKey.Id = "FSR";
            employee.PositionKey = positionKey;

            // Get the create policy for the employee
            employeePolicy = wsDynamicsGP.GetPolicyByOperation("CreateEmployee", context);

            // Create the employee
            wsDynamicsGP.CreateEmployee(employee, context, employeePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateEmployeeAddress

Description

This method creates a new address and associates it with a specified employee.

Parameters

Parameter | Type | Description
employee | EmployeeAddress | The employee address object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new address for an employee with the ID of “ACKE0001”. The example populates the State property. The remaining properties use default values. The CreateEmployeeAddress operation saves the address for the employee.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeAddress employeeAddress;
            EmployeeKey employeeKey;
            EmployeeAddressKey employeeAddressKey;
            Policy employeeAddressCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create an employee address key
            employeeAddressKey = new EmployeeAddressKey();
            employeeAddressKey.EmployeeKey = employeeKey;
            employeeAddressKey.Id = "Test address";

            // Create an employee address object
            employeeAddress = new EmployeeAddress();
            employeeAddress.Key = employeeAddressKey;
            employeeAddress.State = "CA";

            // Get the create policy for employee address objects
            employeeAddressCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateEmployeeAddress", context);

            // Create the employee address
            wsDynamicsGP.CreateEmployeeAddress(employeeAddress, context, employeeAddressCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeAddress employeeAddress;
            EmployeeKey employeeKey;
            EmployeeAddressKey employeeAddressKey;
            Policy employeeAddressCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create an employee address key
            employeeAddressKey = new EmployeeAddressKey();
            employeeAddressKey.EmployeeKey = employeeKey;
            employeeAddressKey.Id = "Test address";

            // Create an employee address object
            employeeAddress = new EmployeeAddress();
            employeeAddress.Key = employeeAddressKey;
            employeeAddress.State = "CA";

            // Get the create policy for employee address objects
            employeeAddressCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateEmployeeAddress", context);

            // Create the employee address
            wsDynamicsGP.CreateEmployeeAddress(employeeAddress, context, employeeAddressCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateEmployeePayCode

Description

This method associates a specified pay code with a specified employee.

Parameters

Parameter | Type | Description
employeePayCode | EmployeePayCode | The employee pay code object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example associates the pay code “COMM” with the employee that has the the ID “ACKE0001”. The remaining properties use default values. The CreateEmployeePayCode operation associates the pay code with the employee.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeePayCode employeePayCode;
            EmployeePayCodeKey employeePayCodeKey;
            EmployeeKey employeeKey;
            PayCodeKey payCodeKey;
            Policy employeePayCodeCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create a pay code key
            payCodeKey = new PayCodeKey();
            payCodeKey.Id = "COMM";

            // Create an employee pay code key
            employeePayCodeKey = new EmployeePayCodeKey();
            employeePayCodeKey.EmployeeKey = employeeKey;
            employeePayCodeKey.PayCodeKey = payCodeKey;

            // Create an employee pay code object
            employeePayCode = new EmployeePayCode();
            employeePayCode.EmployeePayCodeKey = employeePayCodeKey;

            // Get the create policy for employee pay code objects
            employeePayCodeCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateEmployeePayCode", context);

            // Create the employee pay code object
            wsDynamicsGP.CreateEmployeePayCode(employeePayCode, context, employeePayCodeCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeePayCode employeePayCode;
            EmployeePayCodeKey employeePayCodeKey;
            EmployeeKey employeeKey;
            PayCodeKey payCodeKey;
            Policy employeePayCodeCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create a pay code key
            payCodeKey = new PayCodeKey();
            payCodeKey.Id = "COMM";

            // Create an employee pay code key
            employeePayCodeKey = new EmployeePayCodeKey();
            employeePayCodeKey.EmployeeKey = employeeKey;
            employeePayCodeKey.PayCodeKey = payCodeKey;

            // Create an employee pay code object
            employeePayCode = new EmployeePayCode();
            employeePayCode.EmployeePayCodeKey = employeePayCodeKey;

            // Get the create policy for employee pay code objects
            employeePayCodeCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "CreateEmployeePayCode", context);

            // Create the employee pay code object
            wsDynamicsGP.CreateEmployeePayCode(employeePayCode, context, employeePayCodeCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateFee

Description

This method creates a new fee item.

Parameters

Parameter | Type | Description
fee | Fee | The fee object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a fee item. The example populates the required Key, Description, and UofMScheduleKey properties. The fee type property uses the default value of “Flat Fee”. The remaining fee properties also use default values. The CreateFee operation saves the new fee.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            UofMScheduleKey unitOfMeasureKey;
            Fee fee;
            Policy feeCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a fee object
            fee = new Fee();

            // Create an item key to identify the fee
            itemKey = new ItemKey();
            itemKey.Id = "TESTFEE0001";

            // Populate the fee object's key with the item key
            fee.Key = itemKey;

            // Create a unit of measure schedule key
            unitOfMeasureKey = new UofMScheduleKey();
            unitOfMeasureKey.Id = "EACH";

            // Populate the fee object's unit of measure schedule key property
            fee.UofMScheduleKey = unitOfMeasureKey;

            // Populate the description property
            fee.Description = "Test Fee Creation";

            // Get the create policy for fee
            feeCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateFee", context);

            // Create the fee
            wsDynamicsGP.CreateFee(fee, context, feeCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            UofMScheduleKey unitOfMeasureKey;
            Fee fee;
            Policy feeCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a fee object
            fee = new Fee();

            // Create an item key to identify the fee
            itemKey = new ItemKey();
            itemKey.Id = "TESTFEE0001";

            // Populate the fee object's key with the item key
            fee.Key = itemKey;

            // Create a unit of measure schedule key
            unitOfMeasureKey = new UofMScheduleKey();
            unitOfMeasureKey.Id = "EACH";

            // Populate the fee object's unit of measure schedule key property
            fee.UofMScheduleKey = unitOfMeasureKey;

            // Populate the description property
            fee.Description = "Test Fee Creation";

            // Get the create policy for fee
            feeCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateFee", context);

            // Create the fee
            wsDynamicsGP.CreateFee(fee, context, feeCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateGLFixedAllocationAccount

Description

This method creates a new GL fixed allocation account.

Parameters

Parameter | Type | Description
fixedAllocationAccount | GLFixedAllocationAccount | The GL fixed allocation account being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example creates a GL fixed allocation account with the key value “000-6170-00”. The fixed allocation account identifies the posting accounts “000-6170-04” and “000-6170-05” as distribution accounts. Each distribution account receives a 50% allocation. The Description property is set and all other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLAccountNumberKey staffAccount;
            GLAccountNumberKey lineAccount;
            GLFixedAllocationAccount glFixedAllocationAccount;
            GLAllocationDistributionAccountKey staffDistributionAccountKey;
            GLAllocationDistributionAccountKey lineDistributionAccountKey;
            GLFixedAllocationDistributionAccount staffDistributionAccount;
            GLFixedAllocationDistributionAccount lineDistributionAccount;
            Percent allocationPercentage;
            Policy fixedAllocationAccountCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL number key object to identify the new GL fixed allocation account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-6170-00";

            // Create the allocation percentage object
            allocationPercentage = new Percent();
            allocationPercentage.Value = .50m;

            // Create a distribution account object:
            // Create an account number key to specify the staff distribution account
            staffAccount = new GLAccountNumberKey();
            staffAccount.Id = "000-6170-04";

            // Create a distribution account key
            staffDistributionAccountKey = new GLAllocationDistributionAccountKey();
            staffDistributionAccountKey.AccountKey = accountNumberKey;
            staffDistributionAccountKey.DistributionAccountKey = staffAccount;

            // Create the distribution account object
            staffDistributionAccount = new GLFixedAllocationDistributionAccount();
            staffDistributionAccount.Key = staffDistributionAccountKey;
            staffDistributionAccount.Percentage = allocationPercentage;

            // Create a second distribution account object:
            // Create an account number key to specify the line distribution account
            lineAccount = new GLAccountNumberKey();
            lineAccount.Id = "000-6170-05";

            // Create a distribution account key
            lineDistributionAccountKey = new GLAllocationDistributionAccountKey();
            lineDistributionAccountKey.AccountKey = accountNumberKey;
            lineDistributionAccountKey.DistributionAccountKey = lineAccount;

            // Create the distribution account object
            lineDistributionAccount = new GLFixedAllocationDistributionAccount();
            lineDistributionAccount.Key = lineDistributionAccountKey;
            lineDistributionAccount.Percentage = allocationPercentage;

            // Add both distribution account objects to an array of GL fixed
            // allocation distribution account objects
            GLFixedAllocationDistributionAccount[] distributionAccounts =
            { staffDistributionAccount, lineDistributionAccount };

            // Create a fixed allocation account object
            glFixedAllocationAccount = new GLFixedAllocationAccount();
            glFixedAllocationAccount.Key = accountNumberKey;
            glFixedAllocationAccount.Description = "Janitorial Services";
            glFixedAllocationAccount.Distributions = distributionAccounts;

            // Get the create policy for a GL fixed allocation account
            fixedAllocationAccountCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateGLFixedAllocationAccount", context);

            // Create the GL fixed allocation account
            wsDynamicsGP.CreateGLFixedAllocationAccount(glFixedAllocationAccount,
            context, fixedAllocationAccountCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLAccountNumberKey staffAccount;
            GLAccountNumberKey lineAccount;
            GLFixedAllocationAccount glFixedAllocationAccount;
            GLAllocationDistributionAccountKey staffDistributionAccountKey;
            GLAllocationDistributionAccountKey lineDistributionAccountKey;
            GLFixedAllocationDistributionAccount staffDistributionAccount;
            GLFixedAllocationDistributionAccount lineDistributionAccount;
            Percent allocationPercentage;
            Policy fixedAllocationAccountCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL number key object to identify the new GL fixed allocation account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-6170-00";

            // Create the allocation percentage object
            allocationPercentage = new Percent();
            allocationPercentage.Value = .50m;

            // Create a distribution account object:
            // Create an account number key to specify the staff distribution account
            staffAccount = new GLAccountNumberKey();
            staffAccount.Id = "000-6170-04";

            // Create a distribution account key
            staffDistributionAccountKey = new GLAllocationDistributionAccountKey();
            staffDistributionAccountKey.AccountKey = accountNumberKey;
            staffDistributionAccountKey.DistributionAccountKey = staffAccount;

            // Create the distribution account object
            staffDistributionAccount = new GLFixedAllocationDistributionAccount();
            staffDistributionAccount.Key = staffDistributionAccountKey;
            staffDistributionAccount.Percentage = allocationPercentage;

            // Create a second distribution account object:
            // Create an account number key to specify the line distribution account
            lineAccount = new GLAccountNumberKey();
            lineAccount.Id = "000-6170-05";

            // Create a distribution account key
            lineDistributionAccountKey = new GLAllocationDistributionAccountKey();
            lineDistributionAccountKey.AccountKey = accountNumberKey;
            lineDistributionAccountKey.DistributionAccountKey = lineAccount;

            // Create the distribution account object
            lineDistributionAccount = new GLFixedAllocationDistributionAccount();
            lineDistributionAccount.Key = lineDistributionAccountKey;
            lineDistributionAccount.Percentage = allocationPercentage;

            // Add both distribution account objects to an array of GL fixed
            // allocation distribution account objects
            GLFixedAllocationDistributionAccount[] distributionAccounts =
            { staffDistributionAccount, lineDistributionAccount };

            // Create a fixed allocation account object
            glFixedAllocationAccount = new GLFixedAllocationAccount();
            glFixedAllocationAccount.Key = accountNumberKey;
            glFixedAllocationAccount.Description = "Janitorial Services";
            glFixedAllocationAccount.Distributions = distributionAccounts;

            // Get the create policy for a GL fixed allocation account
            fixedAllocationAccountCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateGLFixedAllocationAccount", context);

            // Create the GL fixed allocation account
            wsDynamicsGP.CreateGLFixedAllocationAccount(glFixedAllocationAccount,
            context, fixedAllocationAccountCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateGLPostingAccount

Description

This method creates a new GL posting account.

Parameters

Parameter | Type | Description
postingAccount | GLPostingAccount | The GL posting account being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example creates a GL posting account with the key value “000-1135-00”. The Key, AccountCategoryKey, and Description properties are set. All other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLAccountCategoryKey accountCategoryKey;
            GLPostingAccount postingAccount;
            Policy postingAccountCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key object to identify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-1135-00";

            // Create a GL account category key
            accountCategoryKey = new GLAccountCategoryKey();
            accountCategoryKey.Id = "Cash";

            // Create a posting account object
            postingAccount = new GLPostingAccount();
            postingAccount.Key = accountNumberKey;
            postingAccount.AccountCategoryKey = accountCategoryKey;
            postingAccount.Description = "Cash - Contributions";

            // Get the create policy for GL posting accounts
            postingAccountCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateGLPostingAccount",
            context);

            // Create the posting account
            wsDynamicsGP.CreateGLPostingAccount(postingAccount, context, postingAccountCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLAccountCategoryKey accountCategoryKey;
            GLPostingAccount postingAccount;
            Policy postingAccountCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key object to identify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-1135-00";

            // Create a GL account category key
            accountCategoryKey = new GLAccountCategoryKey();
            accountCategoryKey.Id = "Cash";

            // Create a posting account object
            postingAccount = new GLPostingAccount();
            postingAccount.Key = accountNumberKey;
            postingAccount.AccountCategoryKey = accountCategoryKey;
            postingAccount.Description = "Cash - Contributions";

            // Get the create policy for GL posting accounts
            postingAccountCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateGLPostingAccount",
            context);

            // Create the posting account
            wsDynamicsGP.CreateGLPostingAccount(postingAccount, context, postingAccountCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateGLTransaction

Description

This method creates a new GL transaction.

Parameters

Parameter | Type | Description
glTransaction | GLTransaction | The GL transaction being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example creates a GL transaction. The example uses a GL transaction key to identify the new transaction. The batch key and reference property are also populated and two GL transaction line objects are created to specify the GL accounts and the transaction amount. All other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BatchKey batchKey;
            GLTransactionKey transactionKey;
            GLTransaction transaction;
            GLTransactionLineKey glTransactionLineKey;
            GLTransactionLine transactionDebitLine;
            GLTransactionLine transactionCreditLine;
            GLAccountNumberKey debitAccountKey;
            GLAccountNumberKey creditAccountKey;
            MoneyAmount debitAmount;
            MoneyAmount creditAmount;
            MoneyAmount zeroAmount;
            Policy transactionCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a batch key object to specify the batch
            batchKey = new BatchKey();
            batchKey.Id = "RMCSH00000011";

            // Create a GL transaction key object to identify the transaction
            transactionKey = new GLTransactionKey();
            transactionKey.JournalId = 3365;
            transactionKey.Date = new DateTime(2007, 4, 12);

            // Create the transaction object
            transaction = new GLTransaction();

            // Populate the GL transaction object's key property
            transaction.Key = transactionKey;

            // Populate the batch key and reference properties
            transaction.BatchKey = batchKey;
            transaction.Reference = "Receivables Cash Receipts";

            // Create a GL transaction line key
            glTransactionLineKey = new GLTransactionLineKey();

            // Create two GL transaction lines:
            // Create the debit transaction line
            transactionDebitLine = new GLTransactionLine();

            // Populate the transaction line key
            transactionDebitLine.Key = glTransactionLineKey;

            // Create a GL account number key object to specify the account
            debitAccountKey = new GLAccountNumberKey();
            debitAccountKey.Id = "000-1100-00";

            // Populate the debit line GL account key property
            transactionDebitLine.GLAccountKey = debitAccountKey;

            // Create a money object
            zeroAmount = new MoneyAmount();
            zeroAmount.Value = 0m;
            zeroAmount.Currency = "USD";

            // Create a money object for the debit amount
            debitAmount = new MoneyAmount();
            debitAmount.Value = 50m;
            debitAmount.Currency = "USD";

            // Populate the transaction line debit and credit amount properties
            transactionDebitLine.DebitAmount = debitAmount;
            transactionDebitLine.CreditAmount = zeroAmount;

            // Create the credit transaction line
            transactionCreditLine = new GLTransactionLine();

            // Populate the transaction line key
            transactionCreditLine.Key = glTransactionLineKey;

            // Create a GL account number key object to specify the account
            creditAccountKey = new GLAccountNumberKey();
            creditAccountKey.Id = "000-1200-00";

            // Populate the credit line GL account key property
            transactionCreditLine.GLAccountKey = creditAccountKey;

            // Create a money amount object for the credit
            creditAmount = new MoneyAmount();
            creditAmount.Value = 50m;
            creditAmount.Currency = "USD";

            // Populate the transaction line debit and credit amount properties
            transactionCreditLine.DebitAmount = zeroAmount;
            transactionCreditLine.CreditAmount = creditAmount;

            // Create an array to hold the two GL transaction line objects
            GLTransactionLine[] lines = { transactionDebitLine, transactionCreditLine };

            // Add the array of GL transaction line objects to the transaction object
            transaction.Lines = lines;

            // Get the create policy for GL transactions
            transactionCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateGLTransaction", context);

            // Create the GL transaction
            wsDynamicsGP.CreateGLTransaction(transaction, context, transactionCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BatchKey batchKey;
            GLTransactionKey transactionKey;
            GLTransaction transaction;
            GLTransactionLineKey glTransactionLineKey;
            GLTransactionLine transactionDebitLine;
            GLTransactionLine transactionCreditLine;
            GLAccountNumberKey debitAccountKey;
            GLAccountNumberKey creditAccountKey;
            MoneyAmount debitAmount;
            MoneyAmount creditAmount;
            MoneyAmount zeroAmount;
            Policy transactionCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a batch key object to specify the batch
            batchKey = new BatchKey();
            batchKey.Id = "RMCSH00000011";

            // Create a GL transaction key object to identify the transaction
            transactionKey = new GLTransactionKey();
            transactionKey.JournalId = 3365;
            transactionKey.Date = new DateTime(2007, 4, 12);

            // Create the transaction object
            transaction = new GLTransaction();

            // Populate the GL transaction object's key property
            transaction.Key = transactionKey;

            // Populate the batch key and reference properties
            transaction.BatchKey = batchKey;
            transaction.Reference = "Receivables Cash Receipts";

            // Create a GL transaction line key
            glTransactionLineKey = new GLTransactionLineKey();

            // Create two GL transaction lines:
            // Create the debit transaction line
            transactionDebitLine = new GLTransactionLine();

            // Populate the transaction line key
            transactionDebitLine.Key = glTransactionLineKey;

            // Create a GL account number key object to specify the account
            debitAccountKey = new GLAccountNumberKey();
            debitAccountKey.Id = "000-1100-00";

            // Populate the debit line GL account key property
            transactionDebitLine.GLAccountKey = debitAccountKey;

            // Create a money object
            zeroAmount = new MoneyAmount();
            zeroAmount.Value = 0m;
            zeroAmount.Currency = "USD";

            // Create a money object for the debit amount
            debitAmount = new MoneyAmount();
            debitAmount.Value = 50m;
            debitAmount.Currency = "USD";

            // Populate the transaction line debit and credit amount properties
            transactionDebitLine.DebitAmount = debitAmount;
            transactionDebitLine.CreditAmount = zeroAmount;

            // Create the credit transaction line
            transactionCreditLine = new GLTransactionLine();

            // Populate the transaction line key
            transactionCreditLine.Key = glTransactionLineKey;

            // Create a GL account number key object to specify the account
            creditAccountKey = new GLAccountNumberKey();
            creditAccountKey.Id = "000-1200-00";

            // Populate the credit line GL account key property
            transactionCreditLine.GLAccountKey = creditAccountKey;

            // Create a money amount object for the credit
            creditAmount = new MoneyAmount();
            creditAmount.Value = 50m;
            creditAmount.Currency = "USD";

            // Populate the transaction line debit and credit amount properties
            transactionCreditLine.DebitAmount = zeroAmount;
            transactionCreditLine.CreditAmount = creditAmount;

            // Create an array to hold the two GL transaction line objects
            GLTransactionLine[] lines = { transactionDebitLine, transactionCreditLine };

            // Add the array of GL transaction line objects to the transaction object
            transaction.Lines = lines;

            // Get the create policy for GL transactions
            transactionCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateGLTransaction", context);

            // Create the GL transaction
            wsDynamicsGP.CreateGLTransaction(transaction, context, transactionCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateGLUnitAccount

Description

This method creates a new GL unit account.

Parameters

Parameter | Type | Description
unitAccount | GLUnitAccount | The GL unit account being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example creates a GL unit account with the key value “000-9045-00”. The Key and Description properties are set. All other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLUnitAccount unitAccount;
            Policy unitAccountCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key object to identify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-9045-00";

            // Create a GL unit account object
            unitAccount = new GLUnitAccount();
            unitAccount.Key = accountNumberKey;
            unitAccount.Description = "Number of Workstations";

            // Get the create policy for unit accounts
            unitAccountCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateGLUnitAccount", context);

            // Create the unit account
            wsDynamicsGP.CreateGLUnitAccount(unitAccount, context, unitAccountCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLUnitAccount unitAccount;
            Policy unitAccountCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key object to identify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-9045-00";

            // Create a GL unit account object
            unitAccount = new GLUnitAccount();
            unitAccount.Key = accountNumberKey;
            unitAccount.Description = "Number of Workstations";

            // Get the create policy for unit accounts
            unitAccountCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateGLUnitAccount", context);

            // Create the unit account
            wsDynamicsGP.CreateGLUnitAccount(unitAccount, context, unitAccountCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateGLVariableAllocationAccount

Description

This method creates a new GL variable allocation account.

Parameters

Parameter | Type | Description
variableAllocationAccount | GLVariableAllocationAccount | The GL variable allocation account being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example creates a GL variable allocation account with the key value “000-6510-00”. The variable allocation account identifies the posting accounts “300-6510-00” and “400-6510-00” as distribution accounts. Each distribution account specifies the breakdown account used to determine the variable allocation amount. The Description property is set and all other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLVariableAllocationAccount variableAllocationAccount;
            GLVariableAllocationDistributionAccount salesDistributionAccount;
            GLVariableAllocationDistributionAccount serviceDistributionAccount;
            GLAccountNumberKey salesTelephoneExpenseAccount;
            GLAccountNumberKey serviceTelephoneExpenseAccount;
            GLAllocationDistributionAccountKey salesDistributionAccountKey;
            GLAllocationDistributionAccountKey serviceDistributionAccountKey;
            Policy variableAllocationAccountCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL number key object to identify the new GL variable allocation account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-6510-00";

            // Create the sales distribution account object:
            // Create a GL number key object to specify the distribution account
            salesTelephoneExpenseAccount = new GLAccountNumberKey();
            salesTelephoneExpenseAccount.Id = "300-6510-00";

            // Create a GL allocation distribution account key
            salesDistributionAccountKey = new GLAllocationDistributionAccountKey();
            salesDistributionAccountKey.AccountKey = accountNumberKey;
            salesDistributionAccountKey.DistributionAccountKey = salesTelephoneExpenseAccount;

            // Create the breakdown account for the sales distribution account
            GLAllocationDistributionAccountKey salesAllocationDistributionAccountKey =
            new GLAllocationDistributionAccountKey();
            salesAllocationDistributionAccountKey.AccountKey = salesDistributionAccountKey.AccountKey;
            salesAllocationDistributionAccountKey.DistributionAccountKey =
            salesDistributionAccountKey.DistributionAccountKey;

            // Create a GL account number key to specify the breakdown account
            GLAccountNumberKey salesAllocationAccountKey = new GLAccountNumberKey();
            salesAllocationAccountKey.Id = "300-9020-00";

            // Create a breakdown account key and specify the distribution account
            GLVariableAllocationBreakdownAccountKey salesBreakdownAccountKey =
            new GLVariableAllocationBreakdownAccountKey();
            salesBreakdownAccountKey.BreakdownAccountKey = salesAllocationAccountKey;
            salesBreakdownAccountKey.AllocationDistributionAccountKey =
            salesAllocationDistributionAccountKey;

            // Create a GL variable allocation breakdown account object
            GLVariableAllocationBreakdownAccount salesBreakdownAccount =
            new GLVariableAllocationBreakdownAccount();
            salesBreakdownAccount.Key = salesBreakdownAccountKey;

            // Add the breakdown account to the array
            GLVariableAllocationBreakdownAccount[] salesBreakdownAccounts = { salesBreakdownAccount };

            // Create the sales distribution account
            salesDistributionAccount = new GLVariableAllocationDistributionAccount();
            salesDistributionAccount.Key = salesDistributionAccountKey;
            salesDistributionAccount.Breakdowns = salesBreakdownAccounts;

            // Create a service distribution account object:
            // Create a GL account number key to specify the distribution account
            serviceTelephoneExpenseAccount = new GLAccountNumberKey();
            serviceTelephoneExpenseAccount.Id = "400-6510-00";

            // Create a GL allocation distribution account key
            serviceDistributionAccountKey = new GLAllocationDistributionAccountKey();
            serviceDistributionAccountKey.AccountKey = accountNumberKey;
            serviceDistributionAccountKey.DistributionAccountKey = serviceTelephoneExpenseAccount;

            // Create the breakdown account for the service distribution account
            GLAllocationDistributionAccountKey serviceAllocationDistributionAccountKey =
            new GLAllocationDistributionAccountKey();
            serviceAllocationDistributionAccountKey.AccountKey = serviceDistributionAccountKey.AccountKey;
            serviceAllocationDistributionAccountKey.DistributionAccountKey =
            serviceDistributionAccountKey.DistributionAccountKey;

            // Create a GL account number key to specify the breakdown account
            GLAccountNumberKey serviceAllocationAccountKey = new GLAccountNumberKey();
            serviceAllocationAccountKey.Id = "400-9020-00";

            // Create a breakdown account key and specify the distribution account
            GLVariableAllocationBreakdownAccountKey serviceBreakdownAccountKey =
            new GLVariableAllocationBreakdownAccountKey();
            serviceBreakdownAccountKey.BreakdownAccountKey = serviceAllocationAccountKey;
            serviceBreakdownAccountKey.AllocationDistributionAccountKey =
            serviceAllocationDistributionAccountKey;

            // Create a GL variable allocation breakdown account object
            GLVariableAllocationBreakdownAccount serviceBreakdownAccount =
            new GLVariableAllocationBreakdownAccount();
            serviceBreakdownAccount.Key = serviceBreakdownAccountKey;

            // Add the breakdown account to the array
            GLVariableAllocationBreakdownAccount[] serviceBreakdownAccounts = { serviceBreakdownAccount };

            // Create the service distribution account object
            serviceDistributionAccount = new GLVariableAllocationDistributionAccount();
            serviceDistributionAccount.Key = serviceDistributionAccountKey;
            serviceDistributionAccount.Breakdowns = serviceBreakdownAccounts;

            // Add the sales and service distribution account objects to an array
            // the array will be assigned to the Distributions property of the GL
            // variable allocation account object
            GLVariableAllocationDistributionAccount[] distributionAccounts =
            { salesDistributionAccount, serviceDistributionAccount };

            // Create the GL variable allocation account object
            variableAllocationAccount = new GLVariableAllocationAccount();
            variableAllocationAccount.Key = accountNumberKey;
            variableAllocationAccount.Description = "Telephone Expense";
            variableAllocationAccount.Distributions = distributionAccounts;

            // Get the create policy for GL variable allocation accounts
            variableAllocationAccountCreatePolicy = wsDynamicsGP.GetPolicyByOperation
            ("CreateGLVariableAllocationAccount", context);

            // Create the GL variable allocation account
            wsDynamicsGP.CreateGLVariableAllocationAccount(variableAllocationAccount,
            context, variableAllocationAccountCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLVariableAllocationAccount variableAllocationAccount;
            GLVariableAllocationDistributionAccount salesDistributionAccount;
            GLVariableAllocationDistributionAccount serviceDistributionAccount;
            GLAccountNumberKey salesTelephoneExpenseAccount;
            GLAccountNumberKey serviceTelephoneExpenseAccount;
            GLAllocationDistributionAccountKey salesDistributionAccountKey;
            GLAllocationDistributionAccountKey serviceDistributionAccountKey;
            Policy variableAllocationAccountCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL number key object to identify the new GL variable allocation account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-6510-00";

            // Create the sales distribution account object:
            // Create a GL number key object to specify the distribution account
            salesTelephoneExpenseAccount = new GLAccountNumberKey();
            salesTelephoneExpenseAccount.Id = "300-6510-00";

            // Create a GL allocation distribution account key
            salesDistributionAccountKey = new GLAllocationDistributionAccountKey();
            salesDistributionAccountKey.AccountKey = accountNumberKey;
            salesDistributionAccountKey.DistributionAccountKey = salesTelephoneExpenseAccount;

            // Create the breakdown account for the sales distribution account
            GLAllocationDistributionAccountKey salesAllocationDistributionAccountKey =
            new GLAllocationDistributionAccountKey();
            salesAllocationDistributionAccountKey.AccountKey = salesDistributionAccountKey.AccountKey;
            salesAllocationDistributionAccountKey.DistributionAccountKey =
            salesDistributionAccountKey.DistributionAccountKey;

            // Create a GL account number key to specify the breakdown account
            GLAccountNumberKey salesAllocationAccountKey = new GLAccountNumberKey();
            salesAllocationAccountKey.Id = "300-9020-00";

            // Create a breakdown account key and specify the distribution account
            GLVariableAllocationBreakdownAccountKey salesBreakdownAccountKey =
            new GLVariableAllocationBreakdownAccountKey();
            salesBreakdownAccountKey.BreakdownAccountKey = salesAllocationAccountKey;
            salesBreakdownAccountKey.AllocationDistributionAccountKey =
            salesAllocationDistributionAccountKey;

            // Create a GL variable allocation breakdown account object
            GLVariableAllocationBreakdownAccount salesBreakdownAccount =
            new GLVariableAllocationBreakdownAccount();
            salesBreakdownAccount.Key = salesBreakdownAccountKey;

            // Add the breakdown account to the array
            GLVariableAllocationBreakdownAccount[] salesBreakdownAccounts = { salesBreakdownAccount };

            // Create the sales distribution account
            salesDistributionAccount = new GLVariableAllocationDistributionAccount();
            salesDistributionAccount.Key = salesDistributionAccountKey;
            salesDistributionAccount.Breakdowns = salesBreakdownAccounts;

            // Create a service distribution account object:
            // Create a GL account number key to specify the distribution account
            serviceTelephoneExpenseAccount = new GLAccountNumberKey();
            serviceTelephoneExpenseAccount.Id = "400-6510-00";

            // Create a GL allocation distribution account key
            serviceDistributionAccountKey = new GLAllocationDistributionAccountKey();
            serviceDistributionAccountKey.AccountKey = accountNumberKey;
            serviceDistributionAccountKey.DistributionAccountKey = serviceTelephoneExpenseAccount;

            // Create the breakdown account for the service distribution account
            GLAllocationDistributionAccountKey serviceAllocationDistributionAccountKey =
            new GLAllocationDistributionAccountKey();
            serviceAllocationDistributionAccountKey.AccountKey = serviceDistributionAccountKey.AccountKey;
            serviceAllocationDistributionAccountKey.DistributionAccountKey =
            serviceDistributionAccountKey.DistributionAccountKey;

            // Create a GL account number key to specify the breakdown account
            GLAccountNumberKey serviceAllocationAccountKey = new GLAccountNumberKey();
            serviceAllocationAccountKey.Id = "400-9020-00";

            // Create a breakdown account key and specify the distribution account
            GLVariableAllocationBreakdownAccountKey serviceBreakdownAccountKey =
            new GLVariableAllocationBreakdownAccountKey();
            serviceBreakdownAccountKey.BreakdownAccountKey = serviceAllocationAccountKey;
            serviceBreakdownAccountKey.AllocationDistributionAccountKey =
            serviceAllocationDistributionAccountKey;

            // Create a GL variable allocation breakdown account object
            GLVariableAllocationBreakdownAccount serviceBreakdownAccount =
            new GLVariableAllocationBreakdownAccount();
            serviceBreakdownAccount.Key = serviceBreakdownAccountKey;

            // Add the breakdown account to the array
            GLVariableAllocationBreakdownAccount[] serviceBreakdownAccounts = { serviceBreakdownAccount };

            // Create the service distribution account object
            serviceDistributionAccount = new GLVariableAllocationDistributionAccount();
            serviceDistributionAccount.Key = serviceDistributionAccountKey;
            serviceDistributionAccount.Breakdowns = serviceBreakdownAccounts;

            // Add the sales and service distribution account objects to an array
            // the array will be assigned to the Distributions property of the GL
            // variable allocation account object
            GLVariableAllocationDistributionAccount[] distributionAccounts =
            { salesDistributionAccount, serviceDistributionAccount };

            // Create the GL variable allocation account object
            variableAllocationAccount = new GLVariableAllocationAccount();
            variableAllocationAccount.Key = accountNumberKey;
            variableAllocationAccount.Description = "Telephone Expense";
            variableAllocationAccount.Distributions = distributionAccounts;

            // Get the create policy for GL variable allocation accounts
            variableAllocationAccountCreatePolicy = wsDynamicsGP.GetPolicyByOperation
            ("CreateGLVariableAllocationAccount", context);

            // Create the GL variable allocation account
            wsDynamicsGP.CreateGLVariableAllocationAccount(variableAllocationAccount,
            context, variableAllocationAccountCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateHRRequisition

Description

This method creates a new job requisition document.

Parameters

Parameter | Type | Description
businessObject | HRRequisition | The job requisition object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a new job requisition with a requisition key Id of “1”. The sample code also populates the required status, department key, and position key properties. All other properties use their default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PositionKey positionKey;
            HRRequisitionNumberKey requisitionNumberKey;
            DepartmentKey departmentKey;
            HRRequisition requisition;
            Policy requisitionCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a position key
            positionKey = new PositionKey();
            positionKey.Id = "TEC";

            // Create a requisition number key
            requisitionNumberKey = new HRRequisitionNumberKey();
            requisitionNumberKey.Id = "1";

            // Create a department key
            departmentKey = new DepartmentKey();
            departmentKey.Id = "SPTS";

            // Create the requisition object
            requisition = new HRRequisition();
            requisition.DepartmentKey = departmentKey;
            requisition.PositionKey = positionKey;
            requisition.RequisitionNumber = requisitionNumberKey;
            requisition.Status = HRRequisitionStatus.Open;

            // Get the create policy for requisitions
            requisitionCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateHRRequisition", context);

            // Create the requisition
            wsDynamicsGP.CreateHRRequisition(requisition, context, requisitionCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PositionKey positionKey;
            HRRequisitionNumberKey requisitionNumberKey;
            DepartmentKey departmentKey;
            HRRequisition requisition;
            Policy requisitionCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a position key
            positionKey = new PositionKey();
            positionKey.Id = "TEC";

            // Create a requisition number key
            requisitionNumberKey = new HRRequisitionNumberKey();
            requisitionNumberKey.Id = "1";

            // Create a department key
            departmentKey = new DepartmentKey();
            departmentKey.Id = "SPTS";

            // Create the requisition object
            requisition = new HRRequisition();
            requisition.DepartmentKey = departmentKey;
            requisition.PositionKey = positionKey;
            requisition.RequisitionNumber = requisitionNumberKey;
            requisition.Status = HRRequisitionStatus.Open;

            // Get the create policy for requisitions
            requisitionCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateHRRequisition", context);

            // Create the requisition
            wsDynamicsGP.CreateHRRequisition(requisition, context, requisitionCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateInventoryAdjustment

Description

This method creates a new inventory adjustment document.

Parameters

Parameter | Type | Description
inventoryAdjustment | InventoryAdjustment | The inventory adjustment object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a new inventory adjustment document with the key “WSINVADJ000000015”. The example demonstrates setting the inventory adjustment document’s key, batch key, and date properties. The example also uses a single inventory adjustment line to specify the details of the adjustment. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BatchKey batchKey;
            ItemKey itemKey;
            Quantity itemQuantity;
            WarehouseKey warehouseKey;
            InventoryKey inventoryKey;
            InventoryAdjustment inventoryAdjustment;
            InventoryLineKey inventoryLineKey;
            InventoryAdjustmentLine inventoryAdjustmentLine;
            Policy inventoryAdjustmentCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an inventory key to identify the inventory adjustment object
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "WSINVADJ000000015";

            // Create a batch key object to specify a batch for the inventory adjustment
            batchKey = new BatchKey();
            batchKey.Id = "INVENTORY BATCH";

            // Create the inventory adjustment object
            inventoryAdjustment = new InventoryAdjustment();

            // Populate the inventory adjustment object's required properties
            inventoryAdjustment.Key = inventoryKey;
            inventoryAdjustment.BatchKey = batchKey;
            inventoryAdjustment.Date = DateTime.Today;

            // Create an inventory adjustment line object to detail the inventory adjustment
            inventoryAdjustmentLine = new InventoryAdjustmentLine();

            // Create an inventory line key to identify the inventory line adjustment object
            inventoryLineKey = new InventoryLineKey();
            inventoryLineKey.InventoryKey = inventoryKey;

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "PEN";

            // Create a quantity object to specify the amount of the adjustment
            itemQuantity = new Quantity();
            itemQuantity.Value = 1m;

            // Create a warehouse key to specify the location of the adjustment
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "WAREHOUSE";

            // Populate the required properties of the inventory line adjustment object
            inventoryAdjustmentLine.Key = inventoryLineKey;
            inventoryAdjustmentLine.ItemKey = itemKey;
            inventoryAdjustmentLine.Quantity = itemQuantity;
            inventoryAdjustmentLine.WarehouseKey = warehouseKey;

            // Create an array to hold the inventory line adjustment object
            InventoryAdjustmentLine[] lines = { inventoryAdjustmentLine };

            // Add the array of inventory adjustment lines to the inventory adjustment object
            inventoryAdjustment.Lines = lines;

            // Get the create policy for an inventory adjustment
            inventoryAdjustmentCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateInventoryAdjustment", context);

            // Create the inventory adjustment
            wsDynamicsGP.CreateInventoryAdjustment(inventoryAdjustment,
            context, inventoryAdjustmentCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BatchKey batchKey;
            ItemKey itemKey;
            Quantity itemQuantity;
            WarehouseKey warehouseKey;
            InventoryKey inventoryKey;
            InventoryAdjustment inventoryAdjustment;
            InventoryLineKey inventoryLineKey;
            InventoryAdjustmentLine inventoryAdjustmentLine;
            Policy inventoryAdjustmentCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an inventory key to identify the inventory adjustment object
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "WSINVADJ000000015";

            // Create a batch key object to specify a batch for the inventory adjustment
            batchKey = new BatchKey();
            batchKey.Id = "INVENTORY BATCH";

            // Create the inventory adjustment object
            inventoryAdjustment = new InventoryAdjustment();

            // Populate the inventory adjustment object's required properties
            inventoryAdjustment.Key = inventoryKey;
            inventoryAdjustment.BatchKey = batchKey;
            inventoryAdjustment.Date = DateTime.Today;

            // Create an inventory adjustment line object to detail the inventory adjustment
            inventoryAdjustmentLine = new InventoryAdjustmentLine();

            // Create an inventory line key to identify the inventory line adjustment object
            inventoryLineKey = new InventoryLineKey();
            inventoryLineKey.InventoryKey = inventoryKey;

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "PEN";

            // Create a quantity object to specify the amount of the adjustment
            itemQuantity = new Quantity();
            itemQuantity.Value = 1m;

            // Create a warehouse key to specify the location of the adjustment
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "WAREHOUSE";

            // Populate the required properties of the inventory line adjustment object
            inventoryAdjustmentLine.Key = inventoryLineKey;
            inventoryAdjustmentLine.ItemKey = itemKey;
            inventoryAdjustmentLine.Quantity = itemQuantity;
            inventoryAdjustmentLine.WarehouseKey = warehouseKey;

            // Create an array to hold the inventory line adjustment object
            InventoryAdjustmentLine[] lines = { inventoryAdjustmentLine };

            // Add the array of inventory adjustment lines to the inventory adjustment object
            inventoryAdjustment.Lines = lines;

            // Get the create policy for an inventory adjustment
            inventoryAdjustmentCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateInventoryAdjustment", context);

            // Create the inventory adjustment
            wsDynamicsGP.CreateInventoryAdjustment(inventoryAdjustment,
            context, inventoryAdjustmentCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateInventoryTransfer

Description

This method creates a new inventory transfer document.

Parameters

Parameter | Type | Description
inventoryTransfer | InventoryTransfer | The inventory transfer object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a new inventory transfer document with the key “WSINVTRFR00000010”. The example demonstrates setting the inventory transfer document’s key, batch key, and date properties. The example uses a single inventory transfer line to specify the details of the transfer. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BatchKey batchKey;
            ItemKey itemKey;
            Quantity itemQuantity;
            WarehouseKey fromWarehouseKey;
            WarehouseKey toWarehouseKey;
            InventoryKey inventoryKey;
            InventoryLineKey inventoryLineKey;
            InventoryTransfer inventoryTransfer;
            InventoryTransferLine inventoryTransferLine;
            Policy inventoryTransferCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an inventory key to identify the inventory transfer object
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "WSINVTRFR00000010";

            // Create a batch key object to specify a batch for the inventory transfer
            batchKey = new BatchKey();
            batchKey.Id = "TRANSFER 1";

            // Create an inventory transfer object
            inventoryTransfer = new InventoryTransfer();

            // Populate the inventory transfer object's required properties
            inventoryTransfer.Key = inventoryKey;
            inventoryTransfer.BatchKey = batchKey;
            inventoryTransfer.Date = DateTime.Today;

            // Create an inventory transfer line object to detail the inventory transfer
            inventoryTransferLine = new InventoryTransferLine();

            // Create an inventory line key to identify the inventory transfer line object
            inventoryLineKey = new InventoryLineKey();
            inventoryLineKey.InventoryKey = inventoryKey;

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a quantity object to specify the amount of the transfer
            itemQuantity = new Quantity();
            itemQuantity.Value = 5m;

            // Create a warehouse key to specify the location originating the transfer
            fromWarehouseKey = new WarehouseKey();
            fromWarehouseKey.Id = "NORTH";

            // Create a warehouse key to specify the location receiving the transfer
            toWarehouseKey = new WarehouseKey();
            toWarehouseKey.Id = "WAREHOUSE";

            // Populate the required properties of the inventory transfer line object
            inventoryTransferLine.Key = inventoryLineKey;
            inventoryTransferLine.ItemKey = itemKey;
            inventoryTransferLine.Quantity = itemQuantity;
            inventoryTransferLine.WarehouseFromKey = fromWarehouseKey;
            inventoryTransferLine.WarehouseToKey = toWarehouseKey;

            // Create an array to hold the inventory transfer line object
            InventoryTransferLine[] lines = { inventoryTransferLine };

            // Add the array of inventory transfer lines to the inventory transfer object
            inventoryTransfer.Lines = lines;

            // Get the create policy for an inventory transfer
            inventoryTransferCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateInventoryTransfer", context);

            // Create the inventory transfer
            wsDynamicsGP.CreateInventoryTransfer(inventoryTransfer,
            context, inventoryTransferCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BatchKey batchKey;
            ItemKey itemKey;
            Quantity itemQuantity;
            WarehouseKey fromWarehouseKey;
            WarehouseKey toWarehouseKey;
            InventoryKey inventoryKey;
            InventoryLineKey inventoryLineKey;
            InventoryTransfer inventoryTransfer;
            InventoryTransferLine inventoryTransferLine;
            Policy inventoryTransferCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an inventory key to identify the inventory transfer object
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "WSINVTRFR00000010";

            // Create a batch key object to specify a batch for the inventory transfer
            batchKey = new BatchKey();
            batchKey.Id = "TRANSFER 1";

            // Create an inventory transfer object
            inventoryTransfer = new InventoryTransfer();

            // Populate the inventory transfer object's required properties
            inventoryTransfer.Key = inventoryKey;
            inventoryTransfer.BatchKey = batchKey;
            inventoryTransfer.Date = DateTime.Today;

            // Create an inventory transfer line object to detail the inventory transfer
            inventoryTransferLine = new InventoryTransferLine();

            // Create an inventory line key to identify the inventory transfer line object
            inventoryLineKey = new InventoryLineKey();
            inventoryLineKey.InventoryKey = inventoryKey;

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a quantity object to specify the amount of the transfer
            itemQuantity = new Quantity();
            itemQuantity.Value = 5m;

            // Create a warehouse key to specify the location originating the transfer
            fromWarehouseKey = new WarehouseKey();
            fromWarehouseKey.Id = "NORTH";

            // Create a warehouse key to specify the location receiving the transfer
            toWarehouseKey = new WarehouseKey();
            toWarehouseKey.Id = "WAREHOUSE";

            // Populate the required properties of the inventory transfer line object
            inventoryTransferLine.Key = inventoryLineKey;
            inventoryTransferLine.ItemKey = itemKey;
            inventoryTransferLine.Quantity = itemQuantity;
            inventoryTransferLine.WarehouseFromKey = fromWarehouseKey;
            inventoryTransferLine.WarehouseToKey = toWarehouseKey;

            // Create an array to hold the inventory transfer line object
            InventoryTransferLine[] lines = { inventoryTransferLine };

            // Add the array of inventory transfer lines to the inventory transfer object
            inventoryTransfer.Lines = lines;

            // Get the create policy for an inventory transfer
            inventoryTransferCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateInventoryTransfer", context);

            // Create the inventory transfer
            wsDynamicsGP.CreateInventoryTransfer(inventoryTransfer,
            context, inventoryTransferCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateInventoryVariance

Description

This method creates a new inventory variance document.

Parameters

Parameter | Type | Description
inventoryVariance | InventoryVariance | The inventory variance object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a new inventory variance document with the key “WSINVVAR000000016”. The example demonstrates setting the inventory variance document’s key, batch key, and date properties. The example uses a single inventory variance line to specify the details of the variance. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BatchKey batchKey;
            ItemKey itemKey;
            Quantity itemQuantity;
            WarehouseKey warehouseKey;
            InventoryKey inventoryKey;
            InventoryLineKey inventoryLineKey;
            InventoryVariance inventoryVariance;
            InventoryVarianceLine inventoryVarianceLine;
            Policy inventoryVarianceCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an inventory key to identify the inventory variance object
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "WSINVVAR000000016";

            // Create a batch key object to specify a batch for the inventory variance
            batchKey = new BatchKey();
            batchKey.Id = "INVENTORY BATCH";

            // Create an inventory variance object
            inventoryVariance = new InventoryVariance();

            // Populate the inventory variance object's required properties
            inventoryVariance.Key = inventoryKey;
            inventoryVariance.BatchKey = batchKey;
            inventoryVariance.Date = DateTime.Today;

            // Create an inventory variance line object to detail the inventory variance
            inventoryVarianceLine = new InventoryVarianceLine();

            // Create an inventory line key to identify the inventory variance line object
            inventoryLineKey = new InventoryLineKey();
            inventoryLineKey.InventoryKey = inventoryKey;

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a quantity object to specify the amount of the variance
            itemQuantity = new Quantity();
            itemQuantity.Value = 2m;

            // Create a warehouse key to specify the location of the variance
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "NORTH";

            // Populate the required properties of the inventory variance line object
            inventoryVarianceLine.Key = inventoryLineKey;
            inventoryVarianceLine.ItemKey = itemKey;
            inventoryVarianceLine.Quantity = itemQuantity;
            inventoryVarianceLine.WarehouseKey = warehouseKey;

            // Create an array to hold the inventory variance line object
            InventoryVarianceLine[] lines = { inventoryVarianceLine };

            // Add the array of inventory variance lines to the inventory variance object
            inventoryVariance.Lines = lines;

            // Get the create policy for an inventory variance
            inventoryVarianceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateInventoryVariance", context);

            // Create the inventory variance
            wsDynamicsGP.CreateInventoryVariance(inventoryVariance,
            context, inventoryVarianceCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BatchKey batchKey;
            ItemKey itemKey;
            Quantity itemQuantity;
            WarehouseKey warehouseKey;
            InventoryKey inventoryKey;
            InventoryLineKey inventoryLineKey;
            InventoryVariance inventoryVariance;
            InventoryVarianceLine inventoryVarianceLine;
            Policy inventoryVarianceCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an inventory key to identify the inventory variance object
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "WSINVVAR000000016";

            // Create a batch key object to specify a batch for the inventory variance
            batchKey = new BatchKey();
            batchKey.Id = "INVENTORY BATCH";

            // Create an inventory variance object
            inventoryVariance = new InventoryVariance();

            // Populate the inventory variance object's required properties
            inventoryVariance.Key = inventoryKey;
            inventoryVariance.BatchKey = batchKey;
            inventoryVariance.Date = DateTime.Today;

            // Create an inventory variance line object to detail the inventory variance
            inventoryVarianceLine = new InventoryVarianceLine();

            // Create an inventory line key to identify the inventory variance line object
            inventoryLineKey = new InventoryLineKey();
            inventoryLineKey.InventoryKey = inventoryKey;

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a quantity object to specify the amount of the variance
            itemQuantity = new Quantity();
            itemQuantity.Value = 2m;

            // Create a warehouse key to specify the location of the variance
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "NORTH";

            // Populate the required properties of the inventory variance line object
            inventoryVarianceLine.Key = inventoryLineKey;
            inventoryVarianceLine.ItemKey = itemKey;
            inventoryVarianceLine.Quantity = itemQuantity;
            inventoryVarianceLine.WarehouseKey = warehouseKey;

            // Create an array to hold the inventory variance line object
            InventoryVarianceLine[] lines = { inventoryVarianceLine };

            // Add the array of inventory variance lines to the inventory variance object
            inventoryVariance.Lines = lines;

            // Get the create policy for an inventory variance
            inventoryVarianceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateInventoryVariance", context);

            // Create the inventory variance
            wsDynamicsGP.CreateInventoryVariance(inventoryVariance,
            context, inventoryVarianceCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateItemCurrency

Description

This method creates a new relationship between an item and a currency.

Parameters

Parameter | Type | Description
itemCurrency | ItemCurrency | The item currency object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates an item currency relationship between an item with the key value “1-A3261A” and the currency with the ISO code “SPD“. The example uses a currency key to specify the currency and an item key to specify the item. The item currency key combines the two keys to define the relationship. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CurrencyKey currencyKey;
            ItemKey itemKey;
            ItemCurrencyKey itemCurrencyKey;
            ItemCurrency itemCurrency;
            Policy itemCurrencyCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item currency object
            itemCurrency = new ItemCurrency();

            // Create a currency key object
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "SPD";

            // Create an item key object
            itemKey = new ItemKey();
            itemKey.Id = "1-A3261A";

            // Create an item currency key
            itemCurrencyKey = new ItemCurrencyKey();
            itemCurrencyKey.CurrencyKey = currencyKey;
            itemCurrencyKey.ItemKey = itemKey;

            // Populate the item currency key property with the itemCurrencyKey object
            itemCurrency.Key = itemCurrencyKey;

            // Get the create policy for item currency
            itemCurrencyCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateItemCurrency", context);

            // Create the item currency
            wsDynamicsGP.CreateItemCurrency(itemCurrency, context, itemCurrencyCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CurrencyKey currencyKey;
            ItemKey itemKey;
            ItemCurrencyKey itemCurrencyKey;
            ItemCurrency itemCurrency;
            Policy itemCurrencyCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item currency object
            itemCurrency = new ItemCurrency();

            // Create a currency key object
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "SPD";

            // Create an item key object
            itemKey = new ItemKey();
            itemKey.Id = "1-A3261A";

            // Create an item currency key
            itemCurrencyKey = new ItemCurrencyKey();
            itemCurrencyKey.CurrencyKey = currencyKey;
            itemCurrencyKey.ItemKey = itemKey;

            // Populate the item currency key property with the itemCurrencyKey object
            itemCurrency.Key = itemCurrencyKey;

            // Get the create policy for item currency
            itemCurrencyCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateItemCurrency", context);

            // Create the item currency
            wsDynamicsGP.CreateItemCurrency(itemCurrency, context, itemCurrencyCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateItemVendor

Description

This method creates a new relationship between an item and a vendor.

Parameters

Parameter | Type | Description
itemVendor | ItemVendor | The item vendor object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates an item vendor relationship between an item with the key “128 SDRAM” and a vendor with the key “ACETRAVE0001“. The example uses an item key to specify the item and a vendor key to specify the vendor. The item vendor key combines the two keys to define the relationship. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemVendor itemVendor;
            ItemKey itemKey;
            VendorKey vendorKey;
            ItemVendorKey itemVendorKey;
            Policy itemVendorCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item vendor object
            itemVendor = new ItemVendor();

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a vendor key to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create an item vendor key
            itemVendorKey = new ItemVendorKey();
            itemVendorKey.ItemKey = itemKey;
            itemVendorKey.VendorKey = vendorKey;

            // Populate the item vendor objects key property
            itemVendor.Key = itemVendorKey;

            // Get the create policy for item vendor
            itemVendorCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateItemVendor", context);

            // Create the item vendor
            wsDynamicsGP.CreateItemVendor(itemVendor, context, itemVendorCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemVendor itemVendor;
            ItemKey itemKey;
            VendorKey vendorKey;
            ItemVendorKey itemVendorKey;
            Policy itemVendorCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item vendor object
            itemVendor = new ItemVendor();

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a vendor key to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create an item vendor key
            itemVendorKey = new ItemVendorKey();
            itemVendorKey.ItemKey = itemKey;
            itemVendorKey.VendorKey = vendorKey;

            // Populate the item vendor objects key property
            itemVendor.Key = itemVendorKey;

            // Get the create policy for item vendor
            itemVendorCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateItemVendor", context);

            // Create the item vendor
            wsDynamicsGP.CreateItemVendor(itemVendor, context, itemVendorCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateItemWarehouse

Description

This method creates a new relationship between an item and a warehouse.

Parameters

Parameter | Type | Description
itemWarehouse | ItemWarehouse | The item warehouse object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates an item warehouse relationship between an item with the key “OM02865” and a warehouse with the key “NORTH“. The example uses an item key to specify the item and a warehouse key to specify the warehouse. The item warehouse key combines the two keys to define the relationship. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            WarehouseKey warehouseKey;
            ItemWarehouseKey itemWarehouseKey;
            ItemWarehouse itemWarehouse;
            Policy itemWarehouseCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item warehouse object
            itemWarehouse = new ItemWarehouse();

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "OM02865";

            // Create a warehouse key to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "NORTH";

            // Create an item warehouse key
            itemWarehouseKey = new ItemWarehouseKey();
            itemWarehouseKey.ItemKey = itemKey;
            itemWarehouseKey.WarehouseKey = warehouseKey;

            // Populate the item warehouse key property
            itemWarehouse.Key = itemWarehouseKey;

            // Get the create policy for item warehouse
            itemWarehouseCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateItemWarehouse", context);

            // Create the item warehouse
            wsDynamicsGP.CreateItemWarehouse(itemWarehouse, context, itemWarehouseCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            WarehouseKey warehouseKey;
            ItemWarehouseKey itemWarehouseKey;
            ItemWarehouse itemWarehouse;
            Policy itemWarehouseCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item warehouse object
            itemWarehouse = new ItemWarehouse();

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "OM02865";

            // Create a warehouse key to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "NORTH";

            // Create an item warehouse key
            itemWarehouseKey = new ItemWarehouseKey();
            itemWarehouseKey.ItemKey = itemKey;
            itemWarehouseKey.WarehouseKey = warehouseKey;

            // Populate the item warehouse key property
            itemWarehouse.Key = itemWarehouseKey;

            // Get the create policy for item warehouse
            itemWarehouseCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateItemWarehouse", context);

            // Create the item warehouse
            wsDynamicsGP.CreateItemWarehouse(itemWarehouse, context, itemWarehouseCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateKit

Description

This method creates a new kit inventory item.

Parameters

Parameter | Type | Description
kit | Kit | The kit inventory item object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a new kit inventory item with the key “TESTKIT001”. The example creates a kit consisting of two kit components. The kit components include a phone that has an inventory item key of “100XLG“ and a headset with an inventory item key of “ACCS-HDS-1EAR“. The example also populates the description, unit of measure, component key and quantity properties. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Quantity quantity;
            KitComponentKey phoneKitComponentKey;
            KitComponentKey headsetKitComponentKey;
            KitComponent phoneKitComponent;
            KitComponent headsetKitComponent;
            ItemKey kitItemKey;
            ItemKey phoneComponentItemKey;
            ItemKey headsetComponentItemKey;
            UofMScheduleKey unitOfMeasureScheduleKey;
            Kit kit;
            Policy kitCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object to identify the kit object
            kitItemKey = new ItemKey();
            kitItemKey.Id = "TESTKIT001";

            // Create a unit of measure schedule object for the kit object
            unitOfMeasureScheduleKey = new UofMScheduleKey();
            unitOfMeasureScheduleKey.Id = "Each";

            // Create a quantity object to specify the quantity for the kit components
            quantity = new Quantity();
            quantity.Value = 1;

            // Create the kit object
            kit = new Kit();

            // Add the key object to the kit object
            kit.Key = kitItemKey;
            kit.Description = "A test kit for web services";
            kit.UofMScheduleKey = unitOfMeasureScheduleKey;

            // Create a kit component object for a phone item:
            // Create a item key to specify the item for the kit component object
            phoneComponentItemKey = new ItemKey();
            phoneComponentItemKey.Id = "100XLG";

            // Create a kit component key to identify the kit component object
            phoneKitComponentKey = new KitComponentKey();
            phoneKitComponentKey.KitKey = kitItemKey;
            phoneKitComponentKey.ItemKey = phoneComponentItemKey;
            phoneKitComponentKey.UofM = "Each";

            // Create the kit Component object
            phoneKitComponent = new KitComponent();
            phoneKitComponent.Key = phoneKitComponentKey;
            phoneKitComponent.Quantity = quantity;

            // Create a kit component object for a headset item:
            // Create a item key to specify the item for the kit component object
            headsetComponentItemKey = new ItemKey();
            headsetComponentItemKey.Id = "ACCS-HDS-1EAR";

            // Create a kit component key to identify the kit component object
            headsetKitComponentKey = new KitComponentKey();
            headsetKitComponentKey.KitKey = kitItemKey;
            headsetKitComponentKey.ItemKey = headsetComponentItemKey;
            headsetKitComponentKey.UofM = "Each";

            // Create the kit Component object
            headsetKitComponent = new KitComponent();
            headsetKitComponent.Key = headsetKitComponentKey;
            headsetKitComponent.Quantity = quantity;

            // Create an array of the kit component objects
            KitComponent[] components = { phoneKitComponent, headsetKitComponent };

            // Add the array to the kit object
            kit.Components = components;

            // Get the create policy for kit objects
            kitCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateKit", context);

            // Create the kit
            wsDynamicsGP.CreateKit(kit, context, kitCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Quantity quantity;
            KitComponentKey phoneKitComponentKey;
            KitComponentKey headsetKitComponentKey;
            KitComponent phoneKitComponent;
            KitComponent headsetKitComponent;
            ItemKey kitItemKey;
            ItemKey phoneComponentItemKey;
            ItemKey headsetComponentItemKey;
            UofMScheduleKey unitOfMeasureScheduleKey;
            Kit kit;
            Policy kitCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object to identify the kit object
            kitItemKey = new ItemKey();
            kitItemKey.Id = "TESTKIT001";

            // Create a unit of measure schedule object for the kit object
            unitOfMeasureScheduleKey = new UofMScheduleKey();
            unitOfMeasureScheduleKey.Id = "Each";

            // Create a quantity object to specify the quantity for the kit components
            quantity = new Quantity();
            quantity.Value = 1;

            // Create the kit object
            kit = new Kit();

            // Add the key object to the kit object
            kit.Key = kitItemKey;
            kit.Description = "A test kit for web services";
            kit.UofMScheduleKey = unitOfMeasureScheduleKey;

            // Create a kit component object for a phone item:
            // Create a item key to specify the item for the kit component object
            phoneComponentItemKey = new ItemKey();
            phoneComponentItemKey.Id = "100XLG";

            // Create a kit component key to identify the kit component object
            phoneKitComponentKey = new KitComponentKey();
            phoneKitComponentKey.KitKey = kitItemKey;
            phoneKitComponentKey.ItemKey = phoneComponentItemKey;
            phoneKitComponentKey.UofM = "Each";

            // Create the kit Component object
            phoneKitComponent = new KitComponent();
            phoneKitComponent.Key = phoneKitComponentKey;
            phoneKitComponent.Quantity = quantity;

            // Create a kit component object for a headset item:
            // Create a item key to specify the item for the kit component object
            headsetComponentItemKey = new ItemKey();
            headsetComponentItemKey.Id = "ACCS-HDS-1EAR";

            // Create a kit component key to identify the kit component object
            headsetKitComponentKey = new KitComponentKey();
            headsetKitComponentKey.KitKey = kitItemKey;
            headsetKitComponentKey.ItemKey = headsetComponentItemKey;
            headsetKitComponentKey.UofM = "Each";

            // Create the kit Component object
            headsetKitComponent = new KitComponent();
            headsetKitComponent.Key = headsetKitComponentKey;
            headsetKitComponent.Quantity = quantity;

            // Create an array of the kit component objects
            KitComponent[] components = { phoneKitComponent, headsetKitComponent };

            // Add the array to the kit object
            kit.Components = components;

            // Get the create policy for kit objects
            kitCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateKit", context);

            // Create the kit
            wsDynamicsGP.CreateKit(kit, context, kitCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePayablesCreditMemo

Description

This method creates a new payables credit memo document.

Parameters

Parameter | Type | Description
payablesCreditMemo | PayablesCreditMemo | The payables credit memo document being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a new payables credit memo document with the key “00000000000001950”. The example demonstrates setting the document’s batch key, vendor key, vendor document number, and purchases amount properties. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey creditMemoKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            PayablesCreditMemo payablesCreditMemo;
            Policy payablesCreditMemoCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables credit memo
            creditMemoKey = new PayablesDocumentKey();
            creditMemoKey.Id = "00000000000001950";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            MoneyAmount creditAmount = new MoneyAmount();
            creditAmount.Currency = "USD";
            creditAmount.Value = 560m;

            // Create a payables credit memo object
            payablesCreditMemo = new PayablesCreditMemo();

            // Populate the payables credit memo properties
            payablesCreditMemo.Key = creditMemoKey;
            payablesCreditMemo.BatchKey = batchKey;
            payablesCreditMemo.VendorKey = vendorKey;
            payablesCreditMemo.VendorDocumentNumber = "DOCUMENT 40";
            payablesCreditMemo.PurchasesAmount = creditAmount;

            // Get the create policy for payables credit memos
            payablesCreditMemoCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesCreditMemo", context);

            // Create the payables credit memo
            wsDynamicsGP.CreatePayablesCreditMemo(payablesCreditMemo,
            context, payablesCreditMemoCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey creditMemoKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            PayablesCreditMemo payablesCreditMemo;
            Policy payablesCreditMemoCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables credit memo
            creditMemoKey = new PayablesDocumentKey();
            creditMemoKey.Id = "00000000000001950";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            MoneyAmount creditAmount = new MoneyAmount();
            creditAmount.Currency = "USD";
            creditAmount.Value = 560m;

            // Create a payables credit memo object
            payablesCreditMemo = new PayablesCreditMemo();

            // Populate the payables credit memo properties
            payablesCreditMemo.Key = creditMemoKey;
            payablesCreditMemo.BatchKey = batchKey;
            payablesCreditMemo.VendorKey = vendorKey;
            payablesCreditMemo.VendorDocumentNumber = "DOCUMENT 40";
            payablesCreditMemo.PurchasesAmount = creditAmount;

            // Get the create policy for payables credit memos
            payablesCreditMemoCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesCreditMemo", context);

            // Create the payables credit memo
            wsDynamicsGP.CreatePayablesCreditMemo(payablesCreditMemo,
            context, payablesCreditMemoCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePayablesFinanceCharge

Description

This method creates a new payables finance charge document.

Parameters

Parameter | Type | Description
payablesFinanceCharge | PayablesFinanceCharge | The payables finance charge document being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a new payables finance charge document with the key “00000000000001850”. The example demonstrates setting the document’s batch key, vendor key, vendor document number, and purchases amount properties. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey financeChargeKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            PayablesFinanceCharge payablesFinanceCharge;
            Policy payablesFinanceChargeCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables finance charge
            financeChargeKey = new PayablesDocumentKey();
            financeChargeKey.Id = "00000000000001850";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            MoneyAmount chargeAmount = new MoneyAmount();
            chargeAmount.Currency = "USD";
            chargeAmount.Value = 85m;

            // Create a payables finance charge object
            payablesFinanceCharge = new PayablesFinanceCharge();

            // Populate the finance charge properties
            payablesFinanceCharge.Key = financeChargeKey;
            payablesFinanceCharge.BatchKey = batchKey;
            payablesFinanceCharge.VendorKey = vendorKey;
            payablesFinanceCharge.VendorDocumentNumber = "DOCUMENT 20";
            payablesFinanceCharge.PurchasesAmount = chargeAmount;

            // Get the create policy for payables finance charge
            payablesFinanceChargeCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesFinanceCharge", context);

            // Create the payables finance charge
            wsDynamicsGP.CreatePayablesFinanceCharge(payablesFinanceCharge,
            context, payablesFinanceChargeCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey financeChargeKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            PayablesFinanceCharge payablesFinanceCharge;
            Policy payablesFinanceChargeCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables finance charge
            financeChargeKey = new PayablesDocumentKey();
            financeChargeKey.Id = "00000000000001850";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            MoneyAmount chargeAmount = new MoneyAmount();
            chargeAmount.Currency = "USD";
            chargeAmount.Value = 85m;

            // Create a payables finance charge object
            payablesFinanceCharge = new PayablesFinanceCharge();

            // Populate the finance charge properties
            payablesFinanceCharge.Key = financeChargeKey;
            payablesFinanceCharge.BatchKey = batchKey;
            payablesFinanceCharge.VendorKey = vendorKey;
            payablesFinanceCharge.VendorDocumentNumber = "DOCUMENT 20";
            payablesFinanceCharge.PurchasesAmount = chargeAmount;

            // Get the create policy for payables finance charge
            payablesFinanceChargeCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesFinanceCharge", context);

            // Create the payables finance charge
            wsDynamicsGP.CreatePayablesFinanceCharge(payablesFinanceCharge,
            context, payablesFinanceChargeCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePayablesInvoice

Description

This method creates a new payables invoice document.

Parameters

Parameter | Type | Description
payablesInvoice | PayablesInvoice | The payables invoice document being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a new payables invoice document with the key “00000000000001550”. The example demonstrates setting the document’s batch key, vendor key, vendor document number, and purchases amount properties. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey invoiceKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            PayablesInvoice payablesInvoice;
            Policy payablesInvoiceCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables invoice
            invoiceKey = new PayablesDocumentKey();
            invoiceKey.Id = "00000000000001550";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            MoneyAmount purchaseAmount = new MoneyAmount();
            purchaseAmount.Currency = "USD";
            purchaseAmount.Value = 250m;

            // Create a payables invoice object
            payablesInvoice = new PayablesInvoice();

            // Populate the invoice properties
            payablesInvoice.Key = invoiceKey;
            payablesInvoice.BatchKey = batchKey;
            payablesInvoice.VendorKey = vendorKey;
            payablesInvoice.VendorDocumentNumber = "DOCUMENT 10";
            payablesInvoice.PurchasesAmount = purchaseAmount;

            // Get the create policy for payables invoices
            payablesInvoiceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesInvoice", context);

            // Create the payables invoice
            wsDynamicsGP.CreatePayablesInvoice(payablesInvoice, context, payablesInvoiceCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey invoiceKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            PayablesInvoice payablesInvoice;
            Policy payablesInvoiceCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables invoice
            invoiceKey = new PayablesDocumentKey();
            invoiceKey.Id = "00000000000001550";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            MoneyAmount purchaseAmount = new MoneyAmount();
            purchaseAmount.Currency = "USD";
            purchaseAmount.Value = 250m;

            // Create a payables invoice object
            payablesInvoice = new PayablesInvoice();

            // Populate the invoice properties
            payablesInvoice.Key = invoiceKey;
            payablesInvoice.BatchKey = batchKey;
            payablesInvoice.VendorKey = vendorKey;
            payablesInvoice.VendorDocumentNumber = "DOCUMENT 10";
            payablesInvoice.PurchasesAmount = purchaseAmount;

            // Get the create policy for payables invoices
            payablesInvoiceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesInvoice", context);

            // Create the payables invoice
            wsDynamicsGP.CreatePayablesInvoice(payablesInvoice, context, payablesInvoiceCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePayablesMiscellaneousCharge

Description

This method creates a new payables miscellaneous charge document.

Parameters

Parameter | Type | Description
payablesMiscellaneousCharge | PayablesMiscellaneousCharge | The payables miscellaneous charge document being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a new payables miscellaneous charge document with the key “00000000000001750”. The example demonstrates setting the document’s batch key, vendor key, vendor document number, and purchases amount properties. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey miscChargeKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            PayablesMiscellaneousCharge payablesMiscellaneousCharge;
            Policy payablesMiscellaneousChargeCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables miscellaneous charges
            miscChargeKey = new PayablesDocumentKey();
            miscChargeKey.Id = "00000000000001750";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            MoneyAmount chargeAmount = new MoneyAmount();
            chargeAmount.Currency = "USD";
            chargeAmount.Value = 25m;

            // Create a payables miscellaneous charges object
            payablesMiscellaneousCharge = new PayablesMiscellaneousCharge();

            // Populate the miscellaneous charges properties
            payablesMiscellaneousCharge.Key = miscChargeKey;
            payablesMiscellaneousCharge.BatchKey = batchKey;
            payablesMiscellaneousCharge.VendorKey = vendorKey;
            payablesMiscellaneousCharge.VendorDocumentNumber = "DOCUMENT 15";
            payablesMiscellaneousCharge.PurchasesAmount = chargeAmount;

            // Get the create policy for payables miscellaneous charges
            payablesMiscellaneousChargeCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesMiscellaneousCharge", context);

            // Create the payables miscellaneous charges
            wsDynamicsGP.CreatePayablesMiscellaneousCharge(payablesMiscellaneousCharge,
            context, payablesMiscellaneousChargeCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey miscChargeKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            PayablesMiscellaneousCharge payablesMiscellaneousCharge;
            Policy payablesMiscellaneousChargeCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables miscellaneous charges
            miscChargeKey = new PayablesDocumentKey();
            miscChargeKey.Id = "00000000000001750";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            MoneyAmount chargeAmount = new MoneyAmount();
            chargeAmount.Currency = "USD";
            chargeAmount.Value = 25m;

            // Create a payables miscellaneous charges object
            payablesMiscellaneousCharge = new PayablesMiscellaneousCharge();

            // Populate the miscellaneous charges properties
            payablesMiscellaneousCharge.Key = miscChargeKey;
            payablesMiscellaneousCharge.BatchKey = batchKey;
            payablesMiscellaneousCharge.VendorKey = vendorKey;
            payablesMiscellaneousCharge.VendorDocumentNumber = "DOCUMENT 15";
            payablesMiscellaneousCharge.PurchasesAmount = chargeAmount;

            // Get the create policy for payables miscellaneous charges
            payablesMiscellaneousChargeCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesMiscellaneousCharge", context);

            // Create the payables miscellaneous charges
            wsDynamicsGP.CreatePayablesMiscellaneousCharge(payablesMiscellaneousCharge,
            context, payablesMiscellaneousChargeCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePayablesReturn

Description

This method creates a new payables return document.

Parameters

Parameter | Type | Description
payablesReturn | PayablesReturn | The payables return document being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a new payables return document with the key “00000000000001600”. The example demonstrates setting the document’s batch key, vendor key, vendor document number, and purchases amount properties. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey returnKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            MoneyAmount returnAmount;
            PayablesReturn payablesReturn;
            Policy payablesReturnCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables return
            returnKey = new PayablesDocumentKey();
            returnKey.Id = "00000000000001600";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            returnAmount = new MoneyAmount();
            returnAmount.Currency = "USD";
            returnAmount.Value = 70m;

            // Create a payables return object
            payablesReturn = new PayablesReturn();

            // Populate the return properties
            payablesReturn.Key = returnKey;
            payablesReturn.BatchKey = batchKey;
            payablesReturn.VendorKey = vendorKey;
            payablesReturn.VendorDocumentNumber = "DOCUMENT 10";
            payablesReturn.PurchasesAmount = returnAmount;

            // Get the create policy for payables returns
            payablesReturnCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesReturn", context);

            // Create the payables return
            wsDynamicsGP.CreatePayablesReturn(payablesReturn, context, payablesReturnCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey returnKey;
            BatchKey batchKey;
            VendorKey vendorKey;
            MoneyAmount returnAmount;
            PayablesReturn payablesReturn;
            Policy payablesReturnCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key object to identify the payables return
            returnKey = new PayablesDocumentKey();
            returnKey.Id = "00000000000001600";

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "PAYABLES BATCH";

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create a money amount object for the transaction
            returnAmount = new MoneyAmount();
            returnAmount.Currency = "USD";
            returnAmount.Value = 70m;

            // Create a payables return object
            payablesReturn = new PayablesReturn();

            // Populate the return properties
            payablesReturn.Key = returnKey;
            payablesReturn.BatchKey = batchKey;
            payablesReturn.VendorKey = vendorKey;
            payablesReturn.VendorDocumentNumber = "DOCUMENT 10";
            payablesReturn.PurchasesAmount = returnAmount;

            // Get the create policy for payables returns
            payablesReturnCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePayablesReturn", context);

            // Create the payables return
            wsDynamicsGP.CreatePayablesReturn(payablesReturn, context, payablesReturnCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePolicy

Description

Creates a policy instance for the specified role. The new policy instance can have different behavior settings from the default policy for the service operation.

Parameters

Parameter | Type | Description
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.
roleKey | RoleKey | The role key object that specifies the role for which the policy instance is being created.
context | Context | Specifies information about how the method will be called.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example creates a policy instance of the Update Sales Return policy for the Sales Representitive role in the sample company Fabrikam.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicyKey policyKey;
            Policy salesReturnPolicy;
            RoleKey roleKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Get the update policy for sales returns
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("a08b0c69-13bd-4a7b-bda9-d7902803364b");
            salesReturnPolicy = wsDynamicsGP.GetPolicyByKey(policyKey, context);

            // Create the role key for the new role
            roleKey = new RoleKey();
            roleKey.Id = "aaeb72e0-77f9-4925-ab9a-73012417fb37";

            // Create the new policy instance for sales returns
            wsDynamicsGP.CreatePolicy(salesReturnPolicy, roleKey, context);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicyKey policyKey;
            Policy salesReturnPolicy;
            RoleKey roleKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Get the update policy for sales returns
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("a08b0c69-13bd-4a7b-bda9-d7902803364b");
            salesReturnPolicy = wsDynamicsGP.GetPolicyByKey(policyKey, context);

            // Create the role key for the new role
            roleKey = new RoleKey();
            roleKey.Id = "aaeb72e0-77f9-4925-ab9a-73012417fb37";

            // Create the new policy instance for sales returns
            wsDynamicsGP.CreatePolicy(salesReturnPolicy, roleKey, context);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePricing

Description

This method creates a new pricing option for an item.

Parameters

Parameter | Type | Description
pricing | Pricing | The pricing object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a new pricing option for the item with the key “TESTINVENTORYITEM0005”. The item was created by the CreateSalesItem example. The pricing and pricing detail object specify the item and the required pricing information. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            PriceLevelKey priceLevelKey;
            CurrencyKey currencyKey;
            PricingKey pricingKey;
            Pricing pricing;
            PricingDetail pricingDetail;
            PricingDetailKey pricingDetailKey;
            Quantity toQuantity;
            PricingDetailPrice detailPrice;
            MoneyAmount priceAmount;
            Policy pricingCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to identify the item
            itemKey = new ItemKey();
            itemKey.Id = "TESTINVENTORYITEM0005";

            // Create a price level key
            priceLevelKey = new PriceLevelKey();
            priceLevelKey.Id = "RETAIL";

            // Create a currency key
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "USD";

            // Create a pricing key object and populate its key properties
            pricingKey = new PricingKey();
            pricingKey.ItemKey = itemKey;
            pricingKey.PriceLevelKey = priceLevelKey;
            pricingKey.CurrencyKey = currencyKey;
            pricingKey.UofM = "EACH";

            // Create a price level object
            pricing = new Pricing();

            // Populate the pricing object key
            pricing.Key = pricingKey;

            // Create a pricing detail object
            pricingDetail = new PricingDetail();

            // Create a pricing detail key
            pricingDetailKey = new PricingDetailKey();

            // Populate the pricing detail key with the pricing key
            pricingDetailKey.PricingKey = pricingKey;

            // Create a quantity object
            toQuantity = new Quantity();

            // Populate the quantity objects value property with the maximum value
            toQuantity.Value = 999999999999M;

            // Populate the pricing detail key ToQuantity property
            pricingDetailKey.ToQuantity = toQuantity;

            // Populate the pricing detail key
            pricingDetail.Key = pricingDetailKey;

            // Create a pricing detail price object
            detailPrice = new PricingDetailPrice();

            // Create a money amount object to specify the price and currency
            priceAmount = new MoneyAmount();
            priceAmount.Value = 5m;
            priceAmount.Currency = "USD";

            // Populate the pricing detail price item with the amount object
            detailPrice.Item = priceAmount;

            // Populate the pricing detail object's UofMPrice with the pricing detail price object
            pricingDetail.UofMPrice = detailPrice;

            // Create an array for the pricing detail objects
            PricingDetail[] pricingDetails = { pricingDetail };

            // Add the array of pricing details to the pricing object
            pricing.Details = pricingDetails;

            // Get the create policy for price level
            pricingCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreatePricing", context);

            // Create the pricing object
            wsDynamicsGP.CreatePricing(pricing, context, pricingCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            PriceLevelKey priceLevelKey;
            CurrencyKey currencyKey;
            PricingKey pricingKey;
            Pricing pricing;
            PricingDetail pricingDetail;
            PricingDetailKey pricingDetailKey;
            Quantity toQuantity;
            PricingDetailPrice detailPrice;
            MoneyAmount priceAmount;
            Policy pricingCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to identify the item
            itemKey = new ItemKey();
            itemKey.Id = "TESTINVENTORYITEM0005";

            // Create a price level key
            priceLevelKey = new PriceLevelKey();
            priceLevelKey.Id = "RETAIL";

            // Create a currency key
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "USD";

            // Create a pricing key object and populate its key properties
            pricingKey = new PricingKey();
            pricingKey.ItemKey = itemKey;
            pricingKey.PriceLevelKey = priceLevelKey;
            pricingKey.CurrencyKey = currencyKey;
            pricingKey.UofM = "EACH";

            // Create a price level object
            pricing = new Pricing();

            // Populate the pricing object key
            pricing.Key = pricingKey;

            // Create a pricing detail object
            pricingDetail = new PricingDetail();

            // Create a pricing detail key
            pricingDetailKey = new PricingDetailKey();

            // Populate the pricing detail key with the pricing key
            pricingDetailKey.PricingKey = pricingKey;

            // Create a quantity object
            toQuantity = new Quantity();

            // Populate the quantity objects value property with the maximum value
            toQuantity.Value = 999999999999M;

            // Populate the pricing detail key ToQuantity property
            pricingDetailKey.ToQuantity = toQuantity;

            // Populate the pricing detail key
            pricingDetail.Key = pricingDetailKey;

            // Create a pricing detail price object
            detailPrice = new PricingDetailPrice();

            // Create a money amount object to specify the price and currency
            priceAmount = new MoneyAmount();
            priceAmount.Value = 5m;
            priceAmount.Currency = "USD";

            // Populate the pricing detail price item with the amount object
            detailPrice.Item = priceAmount;

            // Populate the pricing detail object's UofMPrice with the pricing detail price object
            pricingDetail.UofMPrice = detailPrice;

            // Create an array for the pricing detail objects
            PricingDetail[] pricingDetails = { pricingDetail };

            // Add the array of pricing details to the pricing object
            pricing.Details = pricingDetails;

            // Get the create policy for price level
            pricingCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreatePricing", context);

            // Create the pricing object
            wsDynamicsGP.CreatePricing(pricing, context, pricingCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePurchaseInvoice

Description

This method creates a new purchase invoice document.

Parameters

Parameter | Type | Description
purchaseInvoice | PurchaseInvoice | The purchase invoice object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a new purchase invoice document with the key “RCT4065”. The example demonstrates setting the purchase invoice document’s required key, vendor key, and vendor document number properties. The example uses a single purchase invoice line to specify purchase order, quantity, and item information. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseInvoiceKey;
            VendorKey vendorKey;
            PurchaseInvoice purchaseInvoice;
            PurchaseInvoiceLine purchaseInvoiceLine;
            PurchaseTransactionKey purchaseOrderKey;
            Quantity purchaseInvoiceQuantity;
            Policy purchaseInvoiceCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to identify the purchase invoice
            purchaseInvoiceKey = new PurchaseTransactionKey();
            purchaseInvoiceKey.Id = "RCT4065";

            // Create a vendor key to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create the purchase invoice object
            purchaseInvoice = new PurchaseInvoice();

            // Populate the required properties
            purchaseInvoice.Key = purchaseInvoiceKey;
            purchaseInvoice.VendorKey = vendorKey;
            purchaseInvoice.VendorDocumentNumber = "AD2223454";

            // Create a purchase invoice line object for the purchase invoice object
            purchaseInvoiceLine = new PurchaseInvoiceLine();

            // Create a purchase order key to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO0997";

            // Add the purchase order key to the purchase invoice line
            purchaseInvoiceLine.PurchaseOrderKey = purchaseOrderKey;

            // Set the vendor item number property for the purchase invoice line
            purchaseInvoiceLine.VendorItemNumber = "ATT-53BK";

            // Create a quantity object to specify the quantity of an item
            purchaseInvoiceQuantity = new Quantity();
            purchaseInvoiceQuantity.Value = 1;

            // Populate the quantity property of the purchase invoice line object
            purchaseInvoiceLine.QuantityInvoiced = purchaseInvoiceQuantity;

            // Create an array to hold the purchase line object
            PurchaseInvoiceLine[] lines = { purchaseInvoiceLine };

            // Add the array of purchase invoice lines to the purchase invoice object
            purchaseInvoice.Lines = lines;

            // Get the create policy for purchase invoices
            purchaseInvoiceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePurchaseInvoice", context);

            // Create the purchase invoice
            wsDynamicsGP.CreatePurchaseInvoice(purchaseInvoice, context, purchaseInvoiceCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseInvoiceKey;
            VendorKey vendorKey;
            PurchaseInvoice purchaseInvoice;
            PurchaseInvoiceLine purchaseInvoiceLine;
            PurchaseTransactionKey purchaseOrderKey;
            Quantity purchaseInvoiceQuantity;
            Policy purchaseInvoiceCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to identify the purchase invoice
            purchaseInvoiceKey = new PurchaseTransactionKey();
            purchaseInvoiceKey.Id = "RCT4065";

            // Create a vendor key to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ADVANCED0001";

            // Create the purchase invoice object
            purchaseInvoice = new PurchaseInvoice();

            // Populate the required properties
            purchaseInvoice.Key = purchaseInvoiceKey;
            purchaseInvoice.VendorKey = vendorKey;
            purchaseInvoice.VendorDocumentNumber = "AD2223454";

            // Create a purchase invoice line object for the purchase invoice object
            purchaseInvoiceLine = new PurchaseInvoiceLine();

            // Create a purchase order key to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO0997";

            // Add the purchase order key to the purchase invoice line
            purchaseInvoiceLine.PurchaseOrderKey = purchaseOrderKey;

            // Set the vendor item number property for the purchase invoice line
            purchaseInvoiceLine.VendorItemNumber = "ATT-53BK";

            // Create a quantity object to specify the quantity of an item
            purchaseInvoiceQuantity = new Quantity();
            purchaseInvoiceQuantity.Value = 1;

            // Populate the quantity property of the purchase invoice line object
            purchaseInvoiceLine.QuantityInvoiced = purchaseInvoiceQuantity;

            // Create an array to hold the purchase line object
            PurchaseInvoiceLine[] lines = { purchaseInvoiceLine };

            // Add the array of purchase invoice lines to the purchase invoice object
            purchaseInvoice.Lines = lines;

            // Get the create policy for purchase invoices
            purchaseInvoiceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePurchaseInvoice", context);

            // Create the purchase invoice
            wsDynamicsGP.CreatePurchaseInvoice(purchaseInvoice, context, purchaseInvoiceCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePurchaseOrder

Description

This method creates a new purchase order document.

Parameters

Parameter | Type | Description
purchaseOrder | PurchaseOrder | The purchase order object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a new purchase order document with the key “PO4055”. The example demonstrates setting the purchase order document’s required key and vendor key properties. The example uses a single purchase order line to specify warehouse, quantity, and item information. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            VendorKey vendorKey;
            PurchaseOrder purchaseOrder;
            PurchaseOrderLine purchaseOrderLine;
            WarehouseKey warehouseKey;
            Quantity quantityOrdered;
            Policy purchaseOrderCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to identify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO4055";

            // Create a vendor key object to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create a purchase order object
            purchaseOrder = new PurchaseOrder();

            // Populate the required properties
            purchaseOrder.Key = purchaseOrderKey;
            purchaseOrder.VendorKey = vendorKey;

            // Create a purchase order line object for the purchase order object
            purchaseOrderLine = new PurchaseOrderLine();

            // Create a warehouse key to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "WAREHOUSE";

            // Add the warehouse key to the purchase order line object
            purchaseOrderLine.WarehouseKey = warehouseKey;

            // Create a quantity object to specify the quantity ordered
            quantityOrdered = new Quantity();
            quantityOrdered.Value = 10;

            // Add the quantity to the purchase order line object
            purchaseOrderLine.QuantityOrdered = quantityOrdered;

            // Specify the inventory item being purchased
            purchaseOrderLine.VendorItemNumber = "100XLG";

            // Create an array to hold the purchase order line object
            PurchaseOrderLine[] lines = { purchaseOrderLine };

            // Add the array of purchase order lines to the purchase order object
            purchaseOrder.Lines = lines;

            // Get the create policy for purchase order objects
            purchaseOrderCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreatePurchaseOrder", context);

            // Create the purchase order
            wsDynamicsGP.CreatePurchaseOrder(purchaseOrder, context, purchaseOrderCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            VendorKey vendorKey;
            PurchaseOrder purchaseOrder;
            PurchaseOrderLine purchaseOrderLine;
            WarehouseKey warehouseKey;
            Quantity quantityOrdered;
            Policy purchaseOrderCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to identify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO4055";

            // Create a vendor key object to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create a purchase order object
            purchaseOrder = new PurchaseOrder();

            // Populate the required properties
            purchaseOrder.Key = purchaseOrderKey;
            purchaseOrder.VendorKey = vendorKey;

            // Create a purchase order line object for the purchase order object
            purchaseOrderLine = new PurchaseOrderLine();

            // Create a warehouse key to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "WAREHOUSE";

            // Add the warehouse key to the purchase order line object
            purchaseOrderLine.WarehouseKey = warehouseKey;

            // Create a quantity object to specify the quantity ordered
            quantityOrdered = new Quantity();
            quantityOrdered.Value = 10;

            // Add the quantity to the purchase order line object
            purchaseOrderLine.QuantityOrdered = quantityOrdered;

            // Specify the inventory item being purchased
            purchaseOrderLine.VendorItemNumber = "100XLG";

            // Create an array to hold the purchase order line object
            PurchaseOrderLine[] lines = { purchaseOrderLine };

            // Add the array of purchase order lines to the purchase order object
            purchaseOrder.Lines = lines;

            // Get the create policy for purchase order objects
            purchaseOrderCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreatePurchaseOrder", context);

            // Create the purchase order
            wsDynamicsGP.CreatePurchaseOrder(purchaseOrder, context, purchaseOrderCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreatePurchaseReceipt

Description

This method creates a new purchase receipt document.

Parameters

Parameter | Type | Description
purchaseReceipt | PurchaseReceipt | The purchase receipt object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a new purchase receipt document with the key “RCT4075”. The example demonstrates setting the purchase receipt document’s required key and vendor key properties. The example uses a single purchase receipt line to specify warehouse, quantity, and item information. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseReceiptKey;
            VendorKey vendorKey;
            PurchaseReceipt purchaseReceipt;
            PurchaseReceiptLine purchaseReceiptLine;
            ItemKey itemKey;
            WarehouseKey warehouseKey;
            Quantity purchaseReceiptQuantity;
            Policy purchaseReceiptCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to identify the purchase receipt
            purchaseReceiptKey = new PurchaseTransactionKey();
            purchaseReceiptKey.Id = "RCT4075";

            // Create a vendor key object to specify the vendor for the purchase receipt
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create a purchase receipt object
            purchaseReceipt = new PurchaseReceipt();

            // Populate the required properties for the purchase receipt object
            purchaseReceipt.Key = purchaseReceiptKey;
            purchaseReceipt.VendorKey = vendorKey;

            // Create a purchase receipt line object for the purchase receipt object
            purchaseReceiptLine = new PurchaseReceiptLine();

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "ACCS-CRD-12WH";

            // Populate the item key property of the purchase receipt line object
            purchaseReceiptLine.ItemKey = itemKey;

            // Populate the vendor item number property of the purchase receipt line
            purchaseReceiptLine.VendorItemNumber = "ACCS-CRD-12WH";

            // Create a warehouse key object to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "WAREHOUSE";

            // Populate the purchase receipt line's warehouse key property
            purchaseReceiptLine.WarehouseKey = warehouseKey;

            // Create a quantity object to specify the quantity
            purchaseReceiptQuantity = new Quantity();
            purchaseReceiptQuantity.Value = 1;

            // Populate the shipped quantity property of the purchase receipt line
            purchaseReceiptLine.QuantityShipped = purchaseReceiptQuantity;

            // Create an array to hold the purchase receipt line
            PurchaseReceiptLine[] lines = { purchaseReceiptLine };

            // Add the array of purchase receipt lines to the purchase receipt object
            purchaseReceipt.Lines = lines;

            // Get the create policy for purchase receipt objects
            purchaseReceiptCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePurchaseReceipt", context);

            // Create the purchase receipt
            wsDynamicsGP.CreatePurchaseReceipt(purchaseReceipt, context, purchaseReceiptCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseReceiptKey;
            VendorKey vendorKey;
            PurchaseReceipt purchaseReceipt;
            PurchaseReceiptLine purchaseReceiptLine;
            ItemKey itemKey;
            WarehouseKey warehouseKey;
            Quantity purchaseReceiptQuantity;
            Policy purchaseReceiptCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to identify the purchase receipt
            purchaseReceiptKey = new PurchaseTransactionKey();
            purchaseReceiptKey.Id = "RCT4075";

            // Create a vendor key object to specify the vendor for the purchase receipt
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create a purchase receipt object
            purchaseReceipt = new PurchaseReceipt();

            // Populate the required properties for the purchase receipt object
            purchaseReceipt.Key = purchaseReceiptKey;
            purchaseReceipt.VendorKey = vendorKey;

            // Create a purchase receipt line object for the purchase receipt object
            purchaseReceiptLine = new PurchaseReceiptLine();

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "ACCS-CRD-12WH";

            // Populate the item key property of the purchase receipt line object
            purchaseReceiptLine.ItemKey = itemKey;

            // Populate the vendor item number property of the purchase receipt line
            purchaseReceiptLine.VendorItemNumber = "ACCS-CRD-12WH";

            // Create a warehouse key object to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "WAREHOUSE";

            // Populate the purchase receipt line's warehouse key property
            purchaseReceiptLine.WarehouseKey = warehouseKey;

            // Create a quantity object to specify the quantity
            purchaseReceiptQuantity = new Quantity();
            purchaseReceiptQuantity.Value = 1;

            // Populate the shipped quantity property of the purchase receipt line
            purchaseReceiptLine.QuantityShipped = purchaseReceiptQuantity;

            // Create an array to hold the purchase receipt line
            PurchaseReceiptLine[] lines = { purchaseReceiptLine };

            // Add the array of purchase receipt lines to the purchase receipt object
            purchaseReceipt.Lines = lines;

            // Get the create policy for purchase receipt objects
            purchaseReceiptCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreatePurchaseReceipt", context);

            // Create the purchase receipt
            wsDynamicsGP.CreatePurchaseReceipt(purchaseReceipt, context, purchaseReceiptCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateReceivablesCreditMemo

Description

This method creates a new receivables credit memo document.

Parameters

Parameter | Type | Description
receivablesCreditMemo | ReceivablesCreditMemo | The receivables credit memo object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a receivables credit memo document. The example populates the required Key, CustomerKey, and SalesAmount properties. All other receivables credit memo properties are set to default values. The CreateReceivablesCreditMemo operation saves the new receivables credit memo document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey creditMemoKey;
            CustomerKey customerKey;
            MoneyAmount creditMemoAmount;
            ReceivablesCreditMemo receivablesCreditMemo;
            Policy receivablesCreditMemoCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables credit memo
            creditMemoKey = new ReceivablesDocumentKey();
            creditMemoKey.Id = "CM6500";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the credit memo amount
            creditMemoAmount = new MoneyAmount();
            creditMemoAmount.Currency = "USD";
            creditMemoAmount.Value = 158m;

            // Create the receivables credit memo object
            receivablesCreditMemo = new ReceivablesCreditMemo();

            // Populate the receivables credit memo object's required properties
            receivablesCreditMemo.Key = creditMemoKey;
            receivablesCreditMemo.CustomerKey = customerKey;
            receivablesCreditMemo.SalesAmount = creditMemoAmount;

            // Get the create policy for receivables credit memo objects
            receivablesCreditMemoCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesCreditMemo", context);

            // Create the receivables credit memo
            wsDynamicsGP.CreateReceivablesCreditMemo(receivablesCreditMemo,
            context, receivablesCreditMemoCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey creditMemoKey;
            CustomerKey customerKey;
            MoneyAmount creditMemoAmount;
            ReceivablesCreditMemo receivablesCreditMemo;
            Policy receivablesCreditMemoCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables credit memo
            creditMemoKey = new ReceivablesDocumentKey();
            creditMemoKey.Id = "CM6500";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the credit memo amount
            creditMemoAmount = new MoneyAmount();
            creditMemoAmount.Currency = "USD";
            creditMemoAmount.Value = 158m;

            // Create the receivables credit memo object
            receivablesCreditMemo = new ReceivablesCreditMemo();

            // Populate the receivables credit memo object's required properties
            receivablesCreditMemo.Key = creditMemoKey;
            receivablesCreditMemo.CustomerKey = customerKey;
            receivablesCreditMemo.SalesAmount = creditMemoAmount;

            // Get the create policy for receivables credit memo objects
            receivablesCreditMemoCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesCreditMemo", context);

            // Create the receivables credit memo
            wsDynamicsGP.CreateReceivablesCreditMemo(receivablesCreditMemo,
            context, receivablesCreditMemoCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateReceivablesDebitMemo

Description

This method creates a new receivables debit memo document.

Parameters

Parameter | Type | Description
receivablesDebitMemo | ReceivablesDebitMemo | The receivables debit memo object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a receivables debit memo document. The example populates the required Key, CustomerKey, and SalesAmount properties. All other receivables debit memo properties are set to default values. The CreateReceivablesDebitMemo operation saves the new receivables debit memo document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey debitMemoKey;
            CustomerKey customerKey;
            MoneyAmount debitMemoAmount;
            ReceivablesDebitMemo receivablesDebitMemo;
            Policy receivablesDebitMemoCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables debit memo
            debitMemoKey = new ReceivablesDocumentKey();
            debitMemoKey.Id = "DM6500";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the debit memo amount
            debitMemoAmount = new MoneyAmount();
            debitMemoAmount.Currency = "USD";
            debitMemoAmount.Value = 741m;

            // Create the receivables debit memo object
            receivablesDebitMemo = new ReceivablesDebitMemo();

            // Populate the receivables debit memo object's required properties
            receivablesDebitMemo.Key = debitMemoKey;
            receivablesDebitMemo.CustomerKey = customerKey;
            receivablesDebitMemo.SalesAmount = debitMemoAmount;

            // Get the create policy for receivables debit memos
            receivablesDebitMemoCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesDebitMemo", context);

            // Create the receivables debit memo
            wsDynamicsGP.CreateReceivablesDebitMemo(receivablesDebitMemo,
            context, receivablesDebitMemoCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey debitMemoKey;
            CustomerKey customerKey;
            MoneyAmount debitMemoAmount;
            ReceivablesDebitMemo receivablesDebitMemo;
            Policy receivablesDebitMemoCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables debit memo
            debitMemoKey = new ReceivablesDocumentKey();
            debitMemoKey.Id = "DM6500";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the debit memo amount
            debitMemoAmount = new MoneyAmount();
            debitMemoAmount.Currency = "USD";
            debitMemoAmount.Value = 741m;

            // Create the receivables debit memo object
            receivablesDebitMemo = new ReceivablesDebitMemo();

            // Populate the receivables debit memo object's required properties
            receivablesDebitMemo.Key = debitMemoKey;
            receivablesDebitMemo.CustomerKey = customerKey;
            receivablesDebitMemo.SalesAmount = debitMemoAmount;

            // Get the create policy for receivables debit memos
            receivablesDebitMemoCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesDebitMemo", context);

            // Create the receivables debit memo
            wsDynamicsGP.CreateReceivablesDebitMemo(receivablesDebitMemo,
            context, receivablesDebitMemoCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateReceivablesFinanceCharge

Description

This method creates a new receivables finance charge document.

Parameters

Parameter | Type | Description
receivablesFinanceCharge | ReceivablesFinanceCharge | The receivables finance charge object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a receivables finance charge document. The example populates the required Key, CustomerKey, and SalesAmount properties. All other receivables finance charge properties are set to default values. The CreateReceivablesFinanceCharge operation saves the new receivables finance charge document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey financeChargeKey;
            CustomerKey customerKey;
            MoneyAmount financeChargeAmount;
            ReceivablesFinanceCharge receivablesFinanceCharge;
            Policy receivablesFinanceChargeCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables finance charge
            financeChargeKey = new ReceivablesDocumentKey();
            financeChargeKey.Id = "FC6500";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the finance charge amount
            financeChargeAmount = new MoneyAmount();
            financeChargeAmount.Currency = "USD";
            financeChargeAmount.Value = 381m;

            // Create the receivables finance charge object
            receivablesFinanceCharge = new ReceivablesFinanceCharge();

            // Populate the receivables finance charge object's required properties
            receivablesFinanceCharge.Key = financeChargeKey;
            receivablesFinanceCharge.CustomerKey = customerKey;
            receivablesFinanceCharge.SalesAmount = financeChargeAmount;

            // Get the create policy for receivables finance charge objects
            receivablesFinanceChargeCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesFinanceCharge", context);

            // Create the receivables finance charge
            wsDynamicsGP.CreateReceivablesFinanceCharge(receivablesFinanceCharge,
            context, receivablesFinanceChargeCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey financeChargeKey;
            CustomerKey customerKey;
            MoneyAmount financeChargeAmount;
            ReceivablesFinanceCharge receivablesFinanceCharge;
            Policy receivablesFinanceChargeCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables finance charge
            financeChargeKey = new ReceivablesDocumentKey();
            financeChargeKey.Id = "FC6500";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the finance charge amount
            financeChargeAmount = new MoneyAmount();
            financeChargeAmount.Currency = "USD";
            financeChargeAmount.Value = 381m;

            // Create the receivables finance charge object
            receivablesFinanceCharge = new ReceivablesFinanceCharge();

            // Populate the receivables finance charge object's required properties
            receivablesFinanceCharge.Key = financeChargeKey;
            receivablesFinanceCharge.CustomerKey = customerKey;
            receivablesFinanceCharge.SalesAmount = financeChargeAmount;

            // Get the create policy for receivables finance charge objects
            receivablesFinanceChargeCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesFinanceCharge", context);

            // Create the receivables finance charge
            wsDynamicsGP.CreateReceivablesFinanceCharge(receivablesFinanceCharge,
            context, receivablesFinanceChargeCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateReceivablesInvoice

Description

This method creates a new receivables invoice document.

Parameters

Parameter | Type | Description
receivablesInvoice | ReceivablesInvoice | The receivables invoice object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a receivables invoice document. The example populates the required Key, CustomerKey, and SalesAmount properties. All other receivables invoice properties are set to default values. The CreateReceivablesInvoice operation saves the new receivables invoice document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey invoiceKey;
            CustomerKey customerKey;
            MoneyAmount invoiceAmount;
            ReceivablesInvoice receivablesInvoice;
            Policy receivablesInvoiceCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables invoice
            invoiceKey = new ReceivablesDocumentKey();
            invoiceKey.Id = "INV6520";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the invoice amount
            invoiceAmount = new MoneyAmount();
            invoiceAmount.Currency = "USD";
            invoiceAmount.Value = 451m;

            // Create the receivables invoice object
            receivablesInvoice = new ReceivablesInvoice();

            // Populate the receivables invoice object's required properties
            receivablesInvoice.Key = invoiceKey;
            receivablesInvoice.CustomerKey = customerKey;
            receivablesInvoice.SalesAmount = invoiceAmount;

            // Get the create policy for receivables invoices
            receivablesInvoiceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesInvoice", context);

            // Create the receivables invoice
            wsDynamicsGP.CreateReceivablesInvoice(receivablesInvoice,
            context, receivablesInvoiceCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey invoiceKey;
            CustomerKey customerKey;
            MoneyAmount invoiceAmount;
            ReceivablesInvoice receivablesInvoice;
            Policy receivablesInvoiceCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables invoice
            invoiceKey = new ReceivablesDocumentKey();
            invoiceKey.Id = "INV6520";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the invoice amount
            invoiceAmount = new MoneyAmount();
            invoiceAmount.Currency = "USD";
            invoiceAmount.Value = 451m;

            // Create the receivables invoice object
            receivablesInvoice = new ReceivablesInvoice();

            // Populate the receivables invoice object's required properties
            receivablesInvoice.Key = invoiceKey;
            receivablesInvoice.CustomerKey = customerKey;
            receivablesInvoice.SalesAmount = invoiceAmount;

            // Get the create policy for receivables invoices
            receivablesInvoiceCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesInvoice", context);

            // Create the receivables invoice
            wsDynamicsGP.CreateReceivablesInvoice(receivablesInvoice,
            context, receivablesInvoiceCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateReceivablesReturn

Description

This method creates a new receivables return document.

Parameters

Parameter | Type | Description
receivablesReturn | ReceivablesReturn | The receivables return object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a receivables return document. The example populates the required Key, CustomerKey, and SalesAmount properties. All other receivables return properties are set to default values. The CreateReceivablesReturn operation saves the new receivables return document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey returnKey;
            CustomerKey customerKey;
            MoneyAmount returnAmount;
            ReceivablesReturn receivablesReturn;
            Policy receivablesReturnCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables return
            returnKey = new ReceivablesDocumentKey();
            returnKey.Id = "TRN2550";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the return amount
            returnAmount = new MoneyAmount();
            returnAmount.Currency = "USD";
            returnAmount.Value = 68m;

            // Create the receivables return object
            receivablesReturn = new ReceivablesReturn();

            // Populate the receivables return object's required properties
            receivablesReturn.Key = returnKey;
            receivablesReturn.CustomerKey = customerKey;
            receivablesReturn.SalesAmount = returnAmount;

            // Get the create policy for receivables returns
            receivablesReturnCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesReturn", context);

            // Create the receivables return
            wsDynamicsGP.CreateReceivablesReturn(receivablesReturn,
            context, receivablesReturnCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey returnKey;
            CustomerKey customerKey;
            MoneyAmount returnAmount;
            ReceivablesReturn receivablesReturn;
            Policy receivablesReturnCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables return
            returnKey = new ReceivablesDocumentKey();
            returnKey.Id = "TRN2550";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the return amount
            returnAmount = new MoneyAmount();
            returnAmount.Currency = "USD";
            returnAmount.Value = 68m;

            // Create the receivables return object
            receivablesReturn = new ReceivablesReturn();

            // Populate the receivables return object's required properties
            receivablesReturn.Key = returnKey;
            receivablesReturn.CustomerKey = customerKey;
            receivablesReturn.SalesAmount = returnAmount;

            // Get the create policy for receivables returns
            receivablesReturnCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesReturn", context);

            // Create the receivables return
            wsDynamicsGP.CreateReceivablesReturn(receivablesReturn,
            context, receivablesReturnCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateReceivablesServiceRepair

Description

This method creates a new receivables service repair document.

Parameters

Parameter | Type | Description
receivablesServiceRepair | ReceivablesServiceRepair | The receivables service repair object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a receivables service repair. The example populates the required Key, CustomerKey, and SalesAmount properties. All other receivables service repair properties are set to default values. The CreateReceivablesServiceRepair operation saves the new service repair document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey serviceRepairKey;
            CustomerKey customerKey;
            MoneyAmount repairAmount;
            ReceivablesServiceRepair receivablesServiceRepairs;
            Policy receivablesServiceRepairsCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables service repair
            serviceRepairKey = new ReceivablesDocumentKey();
            serviceRepairKey.Id = "SVC5551";

            // Create a customer key object for the receivables service repair
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the repair amount
            repairAmount = new MoneyAmount();
            repairAmount.Currency = "USD";
            repairAmount.Value = 345m;

            // Create the receivables service repair object
            receivablesServiceRepairs = new ReceivablesServiceRepair();

            // Populate the receivables service repair object's required properties
            receivablesServiceRepairs.Key = serviceRepairKey;
            receivablesServiceRepairs.CustomerKey = customerKey;
            receivablesServiceRepairs.SalesAmount = repairAmount;

            // Get the create policy for receivables service repairs
            receivablesServiceRepairsCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesServiceRepair", context);

            // Create the receivables service repair
            wsDynamicsGP.CreateReceivablesServiceRepair(receivablesServiceRepairs,
            context, receivablesServiceRepairsCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey serviceRepairKey;
            CustomerKey customerKey;
            MoneyAmount repairAmount;
            ReceivablesServiceRepair receivablesServiceRepairs;
            Policy receivablesServiceRepairsCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables service repair
            serviceRepairKey = new ReceivablesDocumentKey();
            serviceRepairKey.Id = "SVC5551";

            // Create a customer key object for the receivables service repair
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the repair amount
            repairAmount = new MoneyAmount();
            repairAmount.Currency = "USD";
            repairAmount.Value = 345m;

            // Create the receivables service repair object
            receivablesServiceRepairs = new ReceivablesServiceRepair();

            // Populate the receivables service repair object's required properties
            receivablesServiceRepairs.Key = serviceRepairKey;
            receivablesServiceRepairs.CustomerKey = customerKey;
            receivablesServiceRepairs.SalesAmount = repairAmount;

            // Get the create policy for receivables service repairs
            receivablesServiceRepairsCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesServiceRepair", context);

            // Create the receivables service repair
            wsDynamicsGP.CreateReceivablesServiceRepair(receivablesServiceRepairs,
            context, receivablesServiceRepairsCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateReceivablesWarranty

Description

This method creates a new receivables warranty document.

Parameters

Parameter | Type | Description
receivablesWarranty | ReceivablesWarranty | The receivables warranty object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a receivables warranty document. The example populates the required Key, CustomerKey, and SalesAmount properties. All other receivables warranty properties are set to default values. The CreateReceivablesWarranty operation saves the new receivables warranty document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey warrantyKey;
            CustomerKey customerKey;
            MoneyAmount warrantyAmount;
            ReceivablesWarranty receivablesWarranty;
            Policy receivablesWarrantyCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables warranty
            warrantyKey = new ReceivablesDocumentKey();
            warrantyKey.Id = "WRN6500";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the warranty amount
            warrantyAmount = new MoneyAmount();
            warrantyAmount.Currency = "USD";
            warrantyAmount.Value = 205m;

            // Create the receivables warranty object
            receivablesWarranty = new ReceivablesWarranty();

            // Populate the receivables warranty object's required properties
            receivablesWarranty.Key = warrantyKey;
            receivablesWarranty.CustomerKey = customerKey;
            receivablesWarranty.SalesAmount = warrantyAmount;

            // Get the create policy for receivables warranty
            receivablesWarrantyCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesWarranty", context);

            // Create the receivables warranty
            wsDynamicsGP.CreateReceivablesWarranty(receivablesWarranty,
            context, receivablesWarrantyCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey warrantyKey;
            CustomerKey customerKey;
            MoneyAmount warrantyAmount;
            ReceivablesWarranty receivablesWarranty;
            Policy receivablesWarrantyCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the document key to uniquely identify the receivables warranty
            warrantyKey = new ReceivablesDocumentKey();
            warrantyKey.Id = "WRN6500";

            // Create a customer key object to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a money amount object to specify the warranty amount
            warrantyAmount = new MoneyAmount();
            warrantyAmount.Currency = "USD";
            warrantyAmount.Value = 205m;

            // Create the receivables warranty object
            receivablesWarranty = new ReceivablesWarranty();

            // Populate the receivables warranty object's required properties
            receivablesWarranty.Key = warrantyKey;
            receivablesWarranty.CustomerKey = customerKey;
            receivablesWarranty.SalesAmount = warrantyAmount;

            // Get the create policy for receivables warranty
            receivablesWarrantyCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateReceivablesWarranty", context);

            // Create the receivables warranty
            wsDynamicsGP.CreateReceivablesWarranty(receivablesWarranty,
            context, receivablesWarrantyCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateReturnMaterialAuthorization

Description

This method creates a new return material authorization.

Parameters

Parameter | Type | Description
returnMaterialAuthorization | ReturnMaterialAuthorization | The return material authorization object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example creates a return material authorization document. The example populates the required Key, ReturnWarehouseKey, ReturnTypeKey, CustomerKey, and ShipToAddressKey properties. All other return material authorization properties are set to default values. The CreateReturnMaterialAuthorization operation saves the new return material authorization document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReturnMaterialAuthorization returnMaterialAuthorization;
            ServiceDocumentKey serviceDocKey;
            WarehouseKey warehouseKey;
            ReturnMaterialAuthorizationTypeKey rmaTypeKey;
            CustomerKey customerKey;
            ShipToAddressKey shipToKey;
            Policy rmaCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a return material authorization object
            returnMaterialAuthorization = new ReturnMaterialAuthorization();

            // Create a service document key object
            // Populate the Id with a value to uniquely identify the RMA document
            serviceDocKey = new ServiceDocumentKey();
            serviceDocKey.Id = "RMATEST000200";

            // Populate the return material authorization object's key property
            // with the service document key
            returnMaterialAuthorization.Key = serviceDocKey;

            // Create a warehouse key object
            // Populate the Id property to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "WAREHOUSE";

            // Populate the return material authorization object's return warehouse
            // key property
            returnMaterialAuthorization.ReturnWarehouseKey = warehouseKey;

            // Create a return material authorization type key object
            // Populate the Id property to specify the return type
            rmaTypeKey = new ReturnMaterialAuthorizationTypeKey();
            rmaTypeKey.Id = "SVC";

            // Populate the return material authorization object's return type key property
            returnMaterialAuthorization.ReturnTypeKey = rmaTypeKey;

            // Create a customer key object
            // Populate the Id to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the return material authorization object's customer key property
            returnMaterialAuthorization.CustomerKey = customerKey;

            // Create a ship to key object
            // Populate the Id property to specify the customer address
            shipToKey = new ShipToAddressKey();
            shipToKey.Id = "PRIMARY";

            // Populate the return material authorization object's ship to address key
            returnMaterialAuthorization.ShipToAddressKey = shipToKey;

            // Retrieve the create policy for the return material authorization object
            rmaCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateReturnMaterialAuthorization",
                context);

             // Create the new return material authorization document
            wsDynamicsGP.CreateReturnMaterialAuthorization(returnMaterialAuthorization,
                context, rmaCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReturnMaterialAuthorization returnMaterialAuthorization;
            ServiceDocumentKey serviceDocKey;
            WarehouseKey warehouseKey;
            ReturnMaterialAuthorizationTypeKey rmaTypeKey;
            CustomerKey customerKey;
            ShipToAddressKey shipToKey;
            Policy rmaCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a return material authorization object
            returnMaterialAuthorization = new ReturnMaterialAuthorization();

            // Create a service document key object
            // Populate the Id with a value to uniquely identify the RMA document
            serviceDocKey = new ServiceDocumentKey();
            serviceDocKey.Id = "RMATEST000200";

            // Populate the return material authorization object's key property
            // with the service document key
            returnMaterialAuthorization.Key = serviceDocKey;

            // Create a warehouse key object
            // Populate the Id property to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "WAREHOUSE";

            // Populate the return material authorization object's return warehouse
            // key property
            returnMaterialAuthorization.ReturnWarehouseKey = warehouseKey;

            // Create a return material authorization type key object
            // Populate the Id property to specify the return type
            rmaTypeKey = new ReturnMaterialAuthorizationTypeKey();
            rmaTypeKey.Id = "SVC";

            // Populate the return material authorization object's return type key property
            returnMaterialAuthorization.ReturnTypeKey = rmaTypeKey;

            // Create a customer key object
            // Populate the Id to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the return material authorization object's customer key property
            returnMaterialAuthorization.CustomerKey = customerKey;

            // Create a ship to key object
            // Populate the Id property to specify the customer address
            shipToKey = new ShipToAddressKey();
            shipToKey.Id = "PRIMARY";

            // Populate the return material authorization object's ship to address key
            returnMaterialAuthorization.ShipToAddressKey = shipToKey;

            // Retrieve the create policy for the return material authorization object
            rmaCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateReturnMaterialAuthorization",
                context);

             // Create the new return material authorization document
            wsDynamicsGP.CreateReturnMaterialAuthorization(returnMaterialAuthorization,
                context, rmaCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSalesBackorder

Description

This method creates a new sales backorder.

Parameters

Parameter | Type | Description
salesBackorder | SalesBackorder | The sales backorder object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a sales backorder. The example first populates the required Type, CustomerKey, and BatchKey properties. The sales backorder uses a sales backorder line to specify the item and quantity backordered. The sales backorder line requires the ItemKey, and Quantity properties to be populated. The sales backorder key and sales invoice line key are not populated. The CreateSalesBackorder operation automatically populates the empty sales backorder key and sales backorder line key with the next available backorder number. All other sales backorder properties are set to default values. The CreateSalesBackorder operation saves the new sales backorder.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesBackorder salesBackorder;
            Policy salesBackorderCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales backorder object
            salesBackorder = new SalesBackorder();

            // Create a document type key for the sales backorder
            SalesDocumentTypeKey salesBackorderType = new SalesDocumentTypeKey();
            salesBackorderType.Type = SalesDocumentType.Backorder;

            // Populate the document type key of the sales backorder object
            salesBackorder.DocumentTypeKey = salesBackorderType;

            // Create a customer key
            CustomerKey customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the customer key of the sales backorder
            salesBackorder.CustomerKey = customerKey;

            // Create a batch key
            BatchKey batchKey = new BatchKey();
            batchKey.Id = "SALES BACKORDER";

            // Populate the batch key of the sales backorder
            salesBackorder.BatchKey = batchKey;

            // Create a sales backorder line to specify the backordered item
            SalesBackorderLine salesBackorderLine = new SalesBackorderLine();

            // Create an item key
            ItemKey itemKey = new ItemKey();
            itemKey.Id = "32X IDE";

            // Populate the item key property of the sales invoice line object
            salesBackorderLine.ItemKey = itemKey;

            // Create a sales backorder quantity object
            Quantity backorderCount = new Quantity();
            backorderCount.Value = 1;

            // Populate the quantity of the sales backorder line object
            salesBackorderLine.Quantity = backorderCount;

            // Create an array of sales backorder objects
            // Initialize the array with the sales backorder line object
            SalesBackorderLine[] backorderLines = { salesBackorderLine };

            // Add the sales backorder line array to the sales backorder object
            salesBackorder.Lines = backorderLines;

            // Get the create policy for sales backorder objects
            salesBackorderCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesBackorder", context);

            // Create the sales backorder
            wsDynamicsGP.CreateSalesBackorder(salesBackorder, context, salesBackorderCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesBackorder salesBackorder;
            Policy salesBackorderCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales backorder object
            salesBackorder = new SalesBackorder();

            // Create a document type key for the sales backorder
            SalesDocumentTypeKey salesBackorderType = new SalesDocumentTypeKey();
            salesBackorderType.Type = SalesDocumentType.Backorder;

            // Populate the document type key of the sales backorder object
            salesBackorder.DocumentTypeKey = salesBackorderType;

            // Create a customer key
            CustomerKey customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the customer key of the sales backorder
            salesBackorder.CustomerKey = customerKey;

            // Create a batch key
            BatchKey batchKey = new BatchKey();
            batchKey.Id = "SALES BACKORDER";

            // Populate the batch key of the sales backorder
            salesBackorder.BatchKey = batchKey;

            // Create a sales backorder line to specify the backordered item
            SalesBackorderLine salesBackorderLine = new SalesBackorderLine();

            // Create an item key
            ItemKey itemKey = new ItemKey();
            itemKey.Id = "32X IDE";

            // Populate the item key property of the sales invoice line object
            salesBackorderLine.ItemKey = itemKey;

            // Create a sales backorder quantity object
            Quantity backorderCount = new Quantity();
            backorderCount.Value = 1;

            // Populate the quantity of the sales backorder line object
            salesBackorderLine.Quantity = backorderCount;

            // Create an array of sales backorder objects
            // Initialize the array with the sales backorder line object
            SalesBackorderLine[] backorderLines = { salesBackorderLine };

            // Add the sales backorder line array to the sales backorder object
            salesBackorder.Lines = backorderLines;

            // Get the create policy for sales backorder objects
            salesBackorderCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesBackorder", context);

            // Create the sales backorder
            wsDynamicsGP.CreateSalesBackorder(salesBackorder, context, salesBackorderCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSalesFulfillmentOrder

Description

This method creates a new sales fulfillment order.

Parameters

Parameter | Type | Description
salesFulfillmentOrder | SalesFulfillmentOrder | The sales fulfillment order object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a sales fulfillment order. The example first populates the required DocumentTypeKey, CustomerKey, and BatchKey properties. The sales fulfillment order uses a sales fulfillment order line to specify the item and quantity sold. The sales fulfillment line requires the ItemKey, and Quantity properties to be populated. The sales fulfillment order key and sales fulfillment order line key are not populated. The CreateSalesInvoice operation automatically populates the empty sales fulfillment order key and sales fulfillment order line key with the next available number. All other sales fulfillment order properties are set to default values. The CreateSalesFulfillmentOrder operation saves the new sales fulfillment order.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentTypeKey salesDocumentType;
            SalesFulfillmentOrder salesFulfillmentOrder;
            CustomerKey customerKey;
            BatchKey batchKey;
            SalesFulfillmentOrderLine fulfillmentOrderLine;
            ItemKey orderItemKey;
            Quantity orderQuantity;
            Policy salesFulfillmentOrderCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales fulfillment order object
            salesFulfillmentOrder = new SalesFulfillmentOrder();

            // Create a sales document type key for the sales fulfillment order
            salesDocumentType = new SalesDocumentTypeKey();
            salesDocumentType.Type = SalesDocumentType.FulfillmentOrder;
            salesDocumentType.Id = "FULORD";

            // Populate the document type of the sales fulfillment order object
            salesFulfillmentOrder.DocumentTypeKey = salesDocumentType;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales fulfillment order object
            salesFulfillmentOrder.CustomerKey = customerKey;

            // Create a batch key object
            batchKey = new BatchKey();
            batchKey.Id = "FULORD";

            // Set the batch key property of the sales fulfillment order object
            salesFulfillmentOrder.BatchKey = batchKey;

            // Create a sales fulfillment order line object
            fulfillmentOrderLine = new SalesFulfillmentOrderLine();

            // Create an item key
            orderItemKey = new ItemKey();
            orderItemKey.Id = "128 SDRAM";

            // Set the item key property of the sales fulfillment order line object
            fulfillmentOrderLine.ItemKey = orderItemKey;

            //Create a quantity object
            orderQuantity = new Quantity();
            orderQuantity.Value = 1;

            // Set the quantity property of the sales fulfillment order line object
            fulfillmentOrderLine.Quantity = orderQuantity;

            // Create a array of sales fulfillment order lines
            // Initialize the array with the sales fulfillment order line object
            SalesFulfillmentOrderLine[] fulfillmentOrderLines = { fulfillmentOrderLine };

            // Add the sales fulfillment order array to the sales fulfillment order object
            salesFulfillmentOrder.Lines = fulfillmentOrderLines;

            // Get the create policy for sales fulfillment orders
            salesFulfillmentOrderCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateSalesFulfillmentOrder", context);

            // Create the sales fulfillment order
            wsDynamicsGP.CreateSalesFulfillmentOrder(salesFulfillmentOrder,
            context, salesFulfillmentOrderCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentTypeKey salesDocumentType;
            SalesFulfillmentOrder salesFulfillmentOrder;
            CustomerKey customerKey;
            BatchKey batchKey;
            SalesFulfillmentOrderLine fulfillmentOrderLine;
            ItemKey orderItemKey;
            Quantity orderQuantity;
            Policy salesFulfillmentOrderCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales fulfillment order object
            salesFulfillmentOrder = new SalesFulfillmentOrder();

            // Create a sales document type key for the sales fulfillment order
            salesDocumentType = new SalesDocumentTypeKey();
            salesDocumentType.Type = SalesDocumentType.FulfillmentOrder;
            salesDocumentType.Id = "FULORD";

            // Populate the document type of the sales fulfillment order object
            salesFulfillmentOrder.DocumentTypeKey = salesDocumentType;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales fulfillment order object
            salesFulfillmentOrder.CustomerKey = customerKey;

            // Create a batch key object
            batchKey = new BatchKey();
            batchKey.Id = "FULORD";

            // Set the batch key property of the sales fulfillment order object
            salesFulfillmentOrder.BatchKey = batchKey;

            // Create a sales fulfillment order line object
            fulfillmentOrderLine = new SalesFulfillmentOrderLine();

            // Create an item key
            orderItemKey = new ItemKey();
            orderItemKey.Id = "128 SDRAM";

            // Set the item key property of the sales fulfillment order line object
            fulfillmentOrderLine.ItemKey = orderItemKey;

            //Create a quantity object
            orderQuantity = new Quantity();
            orderQuantity.Value = 1;

            // Set the quantity property of the sales fulfillment order line object
            fulfillmentOrderLine.Quantity = orderQuantity;

            // Create a array of sales fulfillment order lines
            // Initialize the array with the sales fulfillment order line object
            SalesFulfillmentOrderLine[] fulfillmentOrderLines = { fulfillmentOrderLine };

            // Add the sales fulfillment order array to the sales fulfillment order object
            salesFulfillmentOrder.Lines = fulfillmentOrderLines;

            // Get the create policy for sales fulfillment orders
            salesFulfillmentOrderCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateSalesFulfillmentOrder", context);

            // Create the sales fulfillment order
            wsDynamicsGP.CreateSalesFulfillmentOrder(salesFulfillmentOrder,
            context, salesFulfillmentOrderCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSalesInvoice

Description

This method creates a new sales invoice.

Parameters

Parameter | Type | Description
salesInvoice | SalesInvoice | The sales invoice object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a sales invoice. The example first populates the required DocumentTypeKey, CustomerKey, and BatchKey properties. The sales invoice uses a sales invoice line to specify the item and quantity sold. The sales invoice line requires the ItemKey, and Quantity properties to be populated. The sales invoice key and sales invoice line key are not populated. The CreateSalesInvoice operation automatically populates the empty sales invoice key and sales invoice line key with the next available invoice number. All other sales invoice properties are set to default values. The CreateSalesInvoice operation saves the new sales invoice.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesInvoice salesInvoice;
            SalesDocumentTypeKey salesInvoiceType;
            CustomerKey customerKey;
            BatchKey batchKey;
            SalesInvoiceLine salesInvoiceLine;
            ItemKey invoiceItem;
            Quantity invoiceCount;
            Policy salesInvoiceCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales invoice object
            salesInvoice = new SalesInvoice();

            // Create a sales document type key for the sales invoice
            salesInvoiceType = new SalesDocumentTypeKey();
            salesInvoiceType.Type = SalesDocumentType.Invoice;

            // Populate the document type key for the sales invoice
            salesInvoice.DocumentTypeKey = salesInvoiceType;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales invoice
            salesInvoice.CustomerKey = customerKey;

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "SALES INVOICES";

            // Set the batch key property of the sales invoice object
            salesInvoice.BatchKey = batchKey;

            // Create a sales invoice line to specify the invoiced item
            salesInvoiceLine = new SalesInvoiceLine();

            // Create an item key
            invoiceItem = new ItemKey();
            invoiceItem.Id = "32X IDE";

            // Set the item key property of the sales invoice line object
            salesInvoiceLine.ItemKey = invoiceItem;

            // Create a sales invoice quatity object
            invoiceCount = new Quantity();
            invoiceCount.Value = 2;

            // Set the quantity of the sales invoice line object
            salesInvoiceLine.Quantity = invoiceCount;

            // Create an array of sales invoice lines
            // Initialize the array with the sales invoice line object
            SalesInvoiceLine[] invoiceLines = { salesInvoiceLine };

            // Add the sales invoice line array to the sales line object
            salesInvoice.Lines = invoiceLines;

            // Get the create policy for the sales invoice object
            salesInvoiceCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesInvoice", context);

            // Create the sales invoice
            wsDynamicsGP.CreateSalesInvoice(salesInvoice, context, salesInvoiceCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesInvoice salesInvoice;
            SalesDocumentTypeKey salesInvoiceType;
            CustomerKey customerKey;
            BatchKey batchKey;
            SalesInvoiceLine salesInvoiceLine;
            ItemKey invoiceItem;
            Quantity invoiceCount;
            Policy salesInvoiceCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales invoice object
            salesInvoice = new SalesInvoice();

            // Create a sales document type key for the sales invoice
            salesInvoiceType = new SalesDocumentTypeKey();
            salesInvoiceType.Type = SalesDocumentType.Invoice;

            // Populate the document type key for the sales invoice
            salesInvoice.DocumentTypeKey = salesInvoiceType;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales invoice
            salesInvoice.CustomerKey = customerKey;

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "SALES INVOICES";

            // Set the batch key property of the sales invoice object
            salesInvoice.BatchKey = batchKey;

            // Create a sales invoice line to specify the invoiced item
            salesInvoiceLine = new SalesInvoiceLine();

            // Create an item key
            invoiceItem = new ItemKey();
            invoiceItem.Id = "32X IDE";

            // Set the item key property of the sales invoice line object
            salesInvoiceLine.ItemKey = invoiceItem;

            // Create a sales invoice quatity object
            invoiceCount = new Quantity();
            invoiceCount.Value = 2;

            // Set the quantity of the sales invoice line object
            salesInvoiceLine.Quantity = invoiceCount;

            // Create an array of sales invoice lines
            // Initialize the array with the sales invoice line object
            SalesInvoiceLine[] invoiceLines = { salesInvoiceLine };

            // Add the sales invoice line array to the sales line object
            salesInvoice.Lines = invoiceLines;

            // Get the create policy for the sales invoice object
            salesInvoiceCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesInvoice", context);

            // Create the sales invoice
            wsDynamicsGP.CreateSalesInvoice(salesInvoice, context, salesInvoiceCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSalesItem

Description

This method creates a new sales item.

Parameters

Parameter | Type | Description
salesItem | SalesItem | The sales item object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a sales item. The example populates the required Key, Description, and UofMScheduleKey properties. All other sales item properties are set to default values. The CreateSalesItem operation saves the new sales item.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            UofMScheduleKey unitOfMeasureKey;
            SalesItem salesItem;
            Policy salesItemCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales item object
            salesItem = new SalesItem();

            // Create a sales item key object to identify the sales item
            itemKey = new ItemKey();
            itemKey.Id = "TESTINVENTORYITEM0005";

            // Populate the sales item key property
            salesItem.Key = itemKey;

            // Populate the description property
            salesItem.Description = "Test inventory item 05";

            // Create a unit of measure schedule key
            unitOfMeasureKey = new UofMScheduleKey();
            unitOfMeasureKey.Id = "EACH";

            // Populate the unit of measure property
            salesItem.UofMScheduleKey = unitOfMeasureKey;

            // Get the create policy for sales item
            salesItemCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesItem", context);

            // Create the sales item
            wsDynamicsGP.CreateSalesItem(salesItem, context, salesItemCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            UofMScheduleKey unitOfMeasureKey;
            SalesItem salesItem;
            Policy salesItemCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales item object
            salesItem = new SalesItem();

            // Create a sales item key object to identify the sales item
            itemKey = new ItemKey();
            itemKey.Id = "TESTINVENTORYITEM0005";

            // Populate the sales item key property
            salesItem.Key = itemKey;

            // Populate the description property
            salesItem.Description = "Test inventory item 05";

            // Create a unit of measure schedule key
            unitOfMeasureKey = new UofMScheduleKey();
            unitOfMeasureKey.Id = "EACH";

            // Populate the unit of measure property
            salesItem.UofMScheduleKey = unitOfMeasureKey;

            // Get the create policy for sales item
            salesItemCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesItem", context);

            // Create the sales item
            wsDynamicsGP.CreateSalesItem(salesItem, context, salesItemCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSalesOrder

Description

This method creates a new sales order.

Parameters

Parameter | Type | Description
salesOrder | SalesOrder | The sales order object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a sales order. The example first populates the required DocumentTypeKey, CustomerKey, and BatchKey properties. The sales order uses a sales order line to specify the item and quantity ordered. The sales order line requires the ItemKey, and Quantity properties to be populated. The sales order key and sales order line key are not populated. The CreateSalesOrder operation automatically populates the empty sales order key and sales order line key with the next available order number. All other sales order properties are set to default values. The CreateSalesOrder operation saves the new sales order.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesOrder salesOrder;
            SalesDocumentTypeKey salesOrderType;
            CustomerKey customerKey;
            BatchKey batchKey;
            SalesOrderLine salesOrderLine;
            ItemKey orderedItem;
            Quantity orderedAmount;
            Policy salesOrderCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales order object
            salesOrder = new SalesOrder();

            // Create a sales document type key for the sales order
            salesOrderType = new SalesDocumentTypeKey();
            salesOrderType.Type = SalesDocumentType.Order;

            // Populate the document type key of the sales order object
            salesOrder.DocumentTypeKey = salesOrderType;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales order object
            salesOrder.CustomerKey = customerKey;

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "SALES ORDERS";

            // Set the batch key property of the sales order object
            salesOrder.BatchKey = batchKey;

            // Create a sales order line to specify the ordered item
            salesOrderLine = new SalesOrderLine();

            // Create an item key
            orderedItem = new ItemKey();
            orderedItem.Id = "32X IDE";

            // Set the item key property of the sales order line object
            salesOrderLine.ItemKey = orderedItem;

            // Create a sales order quantity object
            orderedAmount = new Quantity();
            orderedAmount.Value = 4;

            // Set the quantity of the sales order line object
            salesOrderLine.Quantity = orderedAmount;

            // Create an array of sales order lines
            // Initialize the array with sales order line object
            SalesOrderLine[] orders = { salesOrderLine };

            // Add the sales order line array to the sales order
            salesOrder.Lines = orders;

            // Get the create policy for the sales order object
            salesOrderCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesOrder", context);

            // Create the sales order
            wsDynamicsGP.CreateSalesOrder(salesOrder, context, salesOrderCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesOrder salesOrder;
            SalesDocumentTypeKey salesOrderType;
            CustomerKey customerKey;
            BatchKey batchKey;
            SalesOrderLine salesOrderLine;
            ItemKey orderedItem;
            Quantity orderedAmount;
            Policy salesOrderCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales order object
            salesOrder = new SalesOrder();

            // Create a sales document type key for the sales order
            salesOrderType = new SalesDocumentTypeKey();
            salesOrderType.Type = SalesDocumentType.Order;

            // Populate the document type key of the sales order object
            salesOrder.DocumentTypeKey = salesOrderType;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales order object
            salesOrder.CustomerKey = customerKey;

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "SALES ORDERS";

            // Set the batch key property of the sales order object
            salesOrder.BatchKey = batchKey;

            // Create a sales order line to specify the ordered item
            salesOrderLine = new SalesOrderLine();

            // Create an item key
            orderedItem = new ItemKey();
            orderedItem.Id = "32X IDE";

            // Set the item key property of the sales order line object
            salesOrderLine.ItemKey = orderedItem;

            // Create a sales order quantity object
            orderedAmount = new Quantity();
            orderedAmount.Value = 4;

            // Set the quantity of the sales order line object
            salesOrderLine.Quantity = orderedAmount;

            // Create an array of sales order lines
            // Initialize the array with sales order line object
            SalesOrderLine[] orders = { salesOrderLine };

            // Add the sales order line array to the sales order
            salesOrder.Lines = orders;

            // Get the create policy for the sales order object
            salesOrderCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesOrder", context);

            // Create the sales order
            wsDynamicsGP.CreateSalesOrder(salesOrder, context, salesOrderCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSalesProcessHoldSetup

Description

This method creates a new sales process hold setup.

Parameters

Parameter | Type | Description
salesProcessHoldSetup | SalesProcessHoldSetup | The sales process hold setup object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a sales process hold setup. The example populates the required Key, sets the IsFulfillHold property to “true” and the IsPrintHold, IsPostHold, and IsTransferHold properties to “false”. All other properties are set to default values. The CreateSalesProcessHoldSetup operation saves the new sales process hold setup.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesProcessHoldSetupKey salesProcessHoldSetupKey;
            SalesProcessHoldSetup salesProcessHoldSetup;
            Policy salesProcessHoldSetupCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales process hold setup key object
            salesProcessHoldSetupKey = new SalesProcessHoldSetupKey();
            salesProcessHoldSetupKey.Id = "Confirm";

            // Create a sales process hold setup object
            // Populate the Key and the 'Hold' properties
            salesProcessHoldSetup = new SalesProcessHoldSetup();
            salesProcessHoldSetup.Key = salesProcessHoldSetupKey;
            salesProcessHoldSetup.IsPrintHold = false;
            salesProcessHoldSetup.IsFulfillHold = true;
            salesProcessHoldSetup.IsPostHold = false;
            salesProcessHoldSetup.IsTransferHold = false;

            // Get the create policy for sales process hold setup objects
            salesProcessHoldSetupCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateSalesProcessHoldSetup", context);

            // Create the sales process hold setup
            wsDynamicsGP.CreateSalesProcessHoldSetup(salesProcessHoldSetup,
            context, salesProcessHoldSetupCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesProcessHoldSetupKey salesProcessHoldSetupKey;
            SalesProcessHoldSetup salesProcessHoldSetup;
            Policy salesProcessHoldSetupCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales process hold setup key object
            salesProcessHoldSetupKey = new SalesProcessHoldSetupKey();
            salesProcessHoldSetupKey.Id = "Confirm";

            // Create a sales process hold setup object
            // Populate the Key and the 'Hold' properties
            salesProcessHoldSetup = new SalesProcessHoldSetup();
            salesProcessHoldSetup.Key = salesProcessHoldSetupKey;
            salesProcessHoldSetup.IsPrintHold = false;
            salesProcessHoldSetup.IsFulfillHold = true;
            salesProcessHoldSetup.IsPostHold = false;
            salesProcessHoldSetup.IsTransferHold = false;

            // Get the create policy for sales process hold setup objects
            salesProcessHoldSetupCreatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "CreateSalesProcessHoldSetup", context);

            // Create the sales process hold setup
            wsDynamicsGP.CreateSalesProcessHoldSetup(salesProcessHoldSetup,
            context, salesProcessHoldSetupCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSalesQuote

Description

This method creates a new sales quote.

Parameters

Parameter | Type | Description
salesQuote | SalesQuote | The sales quote object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a sales quote. The example first populates the required DocumentTypeKey, CustomerKey, and BatchKey properties. The sales quote uses a sales quote line to specify an item and quantity. The sales quote line requires the ItemKey, Quantity, QuantityToInvoice, and QuantityToOrder properties to be populated. The sales quote key and sales quote line key are not populated. The CreateSalesQuote operation automatically populates the empty sales quote key and sales quote line key with the next available quote number. All other sales quote properties are set to default values. The CreateSalesQuote operation saves the new sales quote.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentTypeKey documentTypeKey;
            CustomerKey customerKey;
            BatchKey batchKey;
            ItemKey quoteItem;
            Quantity itemQuantity;
            Quantity quoteItemQuantity;
            SalesQuote salesQuote;
            SalesQuoteLine salesQuoteLine;
            Policy salesQuoteCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales quote object
            salesQuote = new SalesQuote();

            // Create a sales document type key
            documentTypeKey = new SalesDocumentTypeKey();
            documentTypeKey.Type = SalesDocumentType.Quote;
            documentTypeKey.Id = "STDQTE";

            // Set the document type key of the sales quote object
            salesQuote.DocumentTypeKey = documentTypeKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales quote object
            salesQuote.CustomerKey = customerKey;

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "SALES QUOTES";

            // Set the batch key property of the sales quote object
            salesQuote.BatchKey = batchKey;

            // Create a sales quote line to specify the quote items
            salesQuoteLine = new SalesQuoteLine();

            // Create an item key
            quoteItem = new ItemKey();
            quoteItem.Id = "128 SDRAM";

            // Set the item key property of the sales quote line object
            salesQuoteLine.ItemKey = quoteItem;

            // Create a quantity object
            itemQuantity = new Quantity();
            itemQuantity.Value = 0;

            // Initialize the quantity to invoice and quantity to order properties
            salesQuoteLine.QuantityToInvoice = itemQuantity;
            salesQuoteLine.QuantityToOrder = itemQuantity;

            // Create a quantity object
            quoteItemQuantity = new Quantity();
            quoteItemQuantity.Value = 2;

            // Set the quantity property of the sales quote line object
            salesQuoteLine.Quantity = quoteItemQuantity;

            // Create an array of sales quote lines
            // Initialize the array with the sales quote line object
            SalesQuoteLine[] quotes = { salesQuoteLine };

            // Add the sales quote line to the sales quote object
            salesQuote.Lines = quotes;

            // Get the create policy for sales quotes
            salesQuoteCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesQuote", context);

            // Create the sales quote
            wsDynamicsGP.CreateSalesQuote(salesQuote, context, salesQuoteCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentTypeKey documentTypeKey;
            CustomerKey customerKey;
            BatchKey batchKey;
            ItemKey quoteItem;
            Quantity itemQuantity;
            Quantity quoteItemQuantity;
            SalesQuote salesQuote;
            SalesQuoteLine salesQuoteLine;
            Policy salesQuoteCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales quote object
            salesQuote = new SalesQuote();

            // Create a sales document type key
            documentTypeKey = new SalesDocumentTypeKey();
            documentTypeKey.Type = SalesDocumentType.Quote;
            documentTypeKey.Id = "STDQTE";

            // Set the document type key of the sales quote object
            salesQuote.DocumentTypeKey = documentTypeKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales quote object
            salesQuote.CustomerKey = customerKey;

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "SALES QUOTES";

            // Set the batch key property of the sales quote object
            salesQuote.BatchKey = batchKey;

            // Create a sales quote line to specify the quote items
            salesQuoteLine = new SalesQuoteLine();

            // Create an item key
            quoteItem = new ItemKey();
            quoteItem.Id = "128 SDRAM";

            // Set the item key property of the sales quote line object
            salesQuoteLine.ItemKey = quoteItem;

            // Create a quantity object
            itemQuantity = new Quantity();
            itemQuantity.Value = 0;

            // Initialize the quantity to invoice and quantity to order properties
            salesQuoteLine.QuantityToInvoice = itemQuantity;
            salesQuoteLine.QuantityToOrder = itemQuantity;

            // Create a quantity object
            quoteItemQuantity = new Quantity();
            quoteItemQuantity.Value = 2;

            // Set the quantity property of the sales quote line object
            salesQuoteLine.Quantity = quoteItemQuantity;

            // Create an array of sales quote lines
            // Initialize the array with the sales quote line object
            SalesQuoteLine[] quotes = { salesQuoteLine };

            // Add the sales quote line to the sales quote object
            salesQuote.Lines = quotes;

            // Get the create policy for sales quotes
            salesQuoteCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesQuote", context);

            // Create the sales quote
            wsDynamicsGP.CreateSalesQuote(salesQuote, context, salesQuoteCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSalesReturn

Description

This method creates a new sales return.

Parameters

Parameter | Type | Description
salesReturn | SalesReturn | The sales return object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example creates a sales return. The example first populates the required DocuemntTypeKey, CustomerKey, and BatchKey properties. The sales return uses a sales return line to specify the item and quantity returned. The sales return line requires the ItemKey, and Quantity properties to be populated. The sales return key and sales return line key are not populated. The CreateSalesReturn operation automatically populates the empty sales return key and sales return line key with the next available return number. All other sales return properties are set to default values. The CreateSalesReturn operation saves the new sales return.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Policy salesReturnCreatePolicy;
            SalesReturn salesReturn;
            SalesDocumentTypeKey docTypeKey;
            CustomerKey customerKey;
            BatchKey batchKey;
            SalesReturnLine salesReturnLine;
            ItemKey returnedItem;
            SalesReturnQuantities salesReturnQuantity;
            Quantity returnedAmount;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales return object
            salesReturn = new SalesReturn();

            // Create a sales document type key
            docTypeKey = new SalesDocumentTypeKey();
            docTypeKey.Type = SalesDocumentType.Return;

            // Set the document type key of the sales return object
            salesReturn.DocumentTypeKey = docTypeKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales return object
            salesReturn.CustomerKey = customerKey;

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "SALES RETURNS";

            // Set the batch key property of the sales return object
            salesReturn.BatchKey = batchKey;

            // Create a sales return line to specify the returned item
            salesReturnLine = new SalesReturnLine();

            // Create an item key
            returnedItem = new ItemKey();
            returnedItem.Id = "32X IDE";

            // Set the item key property of the sales return line object
            salesReturnLine.ItemKey = returnedItem;

            // Create a sales return quantity object
            salesReturnQuantity = new SalesReturnQuantities();

            // Create a quantity object
            returnedAmount = new Quantity();
            returnedAmount.Value = 1;

            // Set the returned quantity property of the sales return quantities object
            salesReturnQuantity.ReturnedQuantity = returnedAmount;

            // Set the returned quantity property of the sales return line object
            salesReturnLine.ReturnQuantity = salesReturnQuantity;

            // Set the quantity property of the sales return line object
            salesReturnLine.Quantity = returnedAmount;

            // Create an array of sales return lines
            // Initialize the array with the sales return line object
            SalesReturnLine[] returns = { salesReturnLine };

            // Add the sales return line array to the sales return object
            salesReturn.Lines = returns;

            // Get the create policy for sales returns
            salesReturnCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesReturn", context);

            // Create the sales return
            wsDynamicsGP.CreateSalesReturn(salesReturn, context, salesReturnCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Policy salesReturnCreatePolicy;
            SalesReturn salesReturn;
            SalesDocumentTypeKey docTypeKey;
            CustomerKey customerKey;
            BatchKey batchKey;
            SalesReturnLine salesReturnLine;
            ItemKey returnedItem;
            SalesReturnQuantities salesReturnQuantity;
            Quantity returnedAmount;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales return object
            salesReturn = new SalesReturn();

            // Create a sales document type key
            docTypeKey = new SalesDocumentTypeKey();
            docTypeKey.Type = SalesDocumentType.Return;

            // Set the document type key of the sales return object
            salesReturn.DocumentTypeKey = docTypeKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Set the customer key property of the sales return object
            salesReturn.CustomerKey = customerKey;

            // Create a batch key
            batchKey = new BatchKey();
            batchKey.Id = "SALES RETURNS";

            // Set the batch key property of the sales return object
            salesReturn.BatchKey = batchKey;

            // Create a sales return line to specify the returned item
            salesReturnLine = new SalesReturnLine();

            // Create an item key
            returnedItem = new ItemKey();
            returnedItem.Id = "32X IDE";

            // Set the item key property of the sales return line object
            salesReturnLine.ItemKey = returnedItem;

            // Create a sales return quantity object
            salesReturnQuantity = new SalesReturnQuantities();

            // Create a quantity object
            returnedAmount = new Quantity();
            returnedAmount.Value = 1;

            // Set the returned quantity property of the sales return quantities object
            salesReturnQuantity.ReturnedQuantity = returnedAmount;

            // Set the returned quantity property of the sales return line object
            salesReturnLine.ReturnQuantity = salesReturnQuantity;

            // Set the quantity property of the sales return line object
            salesReturnLine.Quantity = returnedAmount;

            // Create an array of sales return lines
            // Initialize the array with the sales return line object
            SalesReturnLine[] returns = { salesReturnLine };

            // Add the sales return line array to the sales return object
            salesReturn.Lines = returns;

            // Get the create policy for sales returns
            salesReturnCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateSalesReturn", context);

            // Create the sales return
            wsDynamicsGP.CreateSalesReturn(salesReturn, context, salesReturnCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateService

Description

This method creates a new service.

Parameters

Parameter | Type | Description
service | Service | The service object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a service with the key value “NEW-SUPRT-SRVC0010”. The Key, Type, Description, and UofMScheduleKey properties are populated, and all other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            UofMScheduleKey unitKey;
            Service service;
            Policy serviceCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an Item Key object to identify the service
            itemKey = new ItemKey();
            itemKey.Id = "NEW-SUPRT-SRVC0010";

            // Create a unit of measure schedule key
            unitKey = new UofMScheduleKey();
            unitKey.Id = "HR";

            // Create a service object
            service = new Service();

            // Populate the service's key, type, description and UofMScheduleKey properties
            service.Key = itemKey;
            service.Type = ItemType.Service;
            service.Description = "New Support plan";
            service.UofMScheduleKey = unitKey;

            // Get the create policy for services
            serviceCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateService", context);

            // Create the service
            wsDynamicsGP.CreateService(service, context, serviceCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            UofMScheduleKey unitKey;
            Service service;
            Policy serviceCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an Item Key object to identify the service
            itemKey = new ItemKey();
            itemKey.Id = "NEW-SUPRT-SRVC0010";

            // Create a unit of measure schedule key
            unitKey = new UofMScheduleKey();
            unitKey.Id = "HR";

            // Create a service object
            service = new Service();

            // Populate the service's key, type, description and UofMScheduleKey properties
            service.Key = itemKey;
            service.Type = ItemType.Service;
            service.Description = "New Support plan";
            service.UofMScheduleKey = unitKey;

            // Get the create policy for services
            serviceCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateService", context);

            // Create the service
            wsDynamicsGP.CreateService(service, context, serviceCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateServiceCall

Description

This method creates a new service call document.

Parameters

Parameter | Type | Description
serviceCall | ServiceCall | The service call object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example creates a service call document with the key value “SCTEST00100”. The required Key, CustomerKey, and ShipToAddressKey properties are populated. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceCall serviceCall;
            ServiceDocumentKey serviceDocKey;
            CustomerKey customerKey;
            ShipToAddressKey shipToAddressKey;
            Policy serviceCallCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service call object
            serviceCall = new ServiceCall();

            // Create a service document key object
            // Populate the Id property with a value that uniquely identifies the document
            serviceDocKey = new ServiceDocumentKey();
            serviceDocKey.Id = "SCTEST00100";

            // Populate the service call object's Key propety with the service document key
            serviceCall.Key = serviceDocKey;

            // Create a customer key
            // Populate the Id property to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the service call object's CustomerKey property with the customer key object
            serviceCall.CustomerKey = customerKey;

            // Create a ship to address key object
            // Populate the Id property to specify the customer address information
            shipToAddressKey = new ShipToAddressKey();
            shipToAddressKey.Id = "PRIMARY";

            // Populate the service call object's ShipToAddressKey property with the ship to address
            // key object
            serviceCall.ShipToAddressKey = shipToAddressKey;

            // Get the create policy for service calls
            serviceCallCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateServiceCall", context);

            // Create the service equipment document
            wsDynamicsGP.CreateServiceCall(serviceCall, context, serviceCallCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceCall serviceCall;
            ServiceDocumentKey serviceDocKey;
            CustomerKey customerKey;
            ShipToAddressKey shipToAddressKey;
            Policy serviceCallCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service call object
            serviceCall = new ServiceCall();

            // Create a service document key object
            // Populate the Id property with a value that uniquely identifies the document
            serviceDocKey = new ServiceDocumentKey();
            serviceDocKey.Id = "SCTEST00100";

            // Populate the service call object's Key propety with the service document key
            serviceCall.Key = serviceDocKey;

            // Create a customer key
            // Populate the Id property to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the service call object's CustomerKey property with the customer key object
            serviceCall.CustomerKey = customerKey;

            // Create a ship to address key object
            // Populate the Id property to specify the customer address information
            shipToAddressKey = new ShipToAddressKey();
            shipToAddressKey.Id = "PRIMARY";

            // Populate the service call object's ShipToAddressKey property with the ship to address
            // key object
            serviceCall.ShipToAddressKey = shipToAddressKey;

            // Get the create policy for service calls
            serviceCallCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateServiceCall", context);

            // Create the service equipment document
            wsDynamicsGP.CreateServiceCall(serviceCall, context, serviceCallCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateServiceEquipment

Description

This method creates a new service equipment document.

Parameters

Parameter | Type | Description
serviceEquipment | ServiceEquipment | The service equipment object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example creates a service equipment document with the key value “SETEST000100”. The required Key, CustomerKey, and AddressKey properties are populated. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceEquipment serviceEquipment;
            ItemKey itemKey;
            ServiceEquipmentKey servEquipKey;
            CustomerKey customerKey;
            AddressKey addressKey;
            Policy serviceEquipmentCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a new service equipment object
            serviceEquipment = new ServiceEquipment();

            // Create an item key object and specify the item
            itemKey = new ItemKey();
            itemKey.Id = "1-A3261A";

            // Create a service equipment key object
            // Populate the Id property with a value that uniquely identifies the document
            // Populate the ItemKey property with the item key object
            servEquipKey = new ServiceEquipmentKey();
            servEquipKey.Id = "SETEST000100";
            servEquipKey.ItemKey = itemKey;

            // Populate the service equipment object's Key property with the service equipment key object
            serviceEquipment.Key = servEquipKey;

            // Create a customer key object
            // Populate the Id property to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the service equipment object's CustomerKey property with the customer key object
            serviceEquipment.CustomerKey = customerKey;

            // Create an address key object
            // Populate teh address key object's Id to specify the customer address information
            addressKey = new AddressKey();
            addressKey.Id = "PRIMARY";

            // Populate the service equipment object's AddressKey property with the address key object
            serviceEquipment.AddressKey = addressKey;

            // Get the create policy for service equipment
            serviceEquipmentCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateServiceEquipment",
                context);

            // Create the service equipment document
            wsDynamicsGP.CreateServiceEquipment(serviceEquipment, context, serviceEquipmentCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceEquipment serviceEquipment;
            ItemKey itemKey;
            ServiceEquipmentKey servEquipKey;
            CustomerKey customerKey;
            AddressKey addressKey;
            Policy serviceEquipmentCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a new service equipment object
            serviceEquipment = new ServiceEquipment();

            // Create an item key object and specify the item
            itemKey = new ItemKey();
            itemKey.Id = "1-A3261A";

            // Create a service equipment key object
            // Populate the Id property with a value that uniquely identifies the document
            // Populate the ItemKey property with the item key object
            servEquipKey = new ServiceEquipmentKey();
            servEquipKey.Id = "SETEST000100";
            servEquipKey.ItemKey = itemKey;

            // Populate the service equipment object's Key property with the service equipment key object
            serviceEquipment.Key = servEquipKey;

            // Create a customer key object
            // Populate the Id property to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the service equipment object's CustomerKey property with the customer key object
            serviceEquipment.CustomerKey = customerKey;

            // Create an address key object
            // Populate teh address key object's Id to specify the customer address information
            addressKey = new AddressKey();
            addressKey.Id = "PRIMARY";

            // Populate the service equipment object's AddressKey property with the address key object
            serviceEquipment.AddressKey = addressKey;

            // Get the create policy for service equipment
            serviceEquipmentCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateServiceEquipment",
                context);

            // Create the service equipment document
            wsDynamicsGP.CreateServiceEquipment(serviceEquipment, context, serviceEquipmentCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateServiceQuote

Description

This method creates a new service quote document.

Parameters

Parameter | Type | Description
serviceQuote | ServiceQuote | The service quote object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example creates a service quote document with the key value “SQTEST0100”. The required Key, CustomerKey, and ShipToAddressKey properties are populated. All other properties use default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceQuote serviceQuote;
            ServiceDocumentKey serviceDocKey;
            CustomerKey customerKey;
            ShipToAddressKey shipToAddressKey;
            Policy serviceQuoteCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service quote object
            serviceQuote = new ServiceQuote();

            // Create a service document key object
            // Populate the Id property with a value that uniquely identifies the service quote
            serviceDocKey = new ServiceDocumentKey();
            serviceDocKey.Id = "SQTEST0100";

            // Populate the service quote object's Key property with the service document key object
            serviceQuote.Key = serviceDocKey;

            // Create a customer key object
            // Populate the Id property to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the service quote object's CustomerKey property with the customer
            // key object
            serviceQuote.CustomerKey = customerKey;

            // Create a ship to address key object
            // Populate the Id to specify the customer address for the service quote
            shipToAddressKey = new ShipToAddressKey();
            shipToAddressKey.Id = "PRIMARY";

            // Populate the service quote object's ship to address key property
            serviceQuote.ShipToAddressKey = shipToAddressKey;

            // Get the create policy for service quotes
            serviceQuoteCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateServiceQuote", context);

            // Create the service quote
            wsDynamicsGP.CreateServiceQuote(serviceQuote, context, serviceQuoteCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceQuote serviceQuote;
            ServiceDocumentKey serviceDocKey;
            CustomerKey customerKey;
            ShipToAddressKey shipToAddressKey;
            Policy serviceQuoteCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service quote object
            serviceQuote = new ServiceQuote();

            // Create a service document key object
            // Populate the Id property with a value that uniquely identifies the service quote
            serviceDocKey = new ServiceDocumentKey();
            serviceDocKey.Id = "SQTEST0100";

            // Populate the service quote object's Key property with the service document key object
            serviceQuote.Key = serviceDocKey;

            // Create a customer key object
            // Populate the Id property to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Populate the service quote object's CustomerKey property with the customer
            // key object
            serviceQuote.CustomerKey = customerKey;

            // Create a ship to address key object
            // Populate the Id to specify the customer address for the service quote
            shipToAddressKey = new ShipToAddressKey();
            shipToAddressKey.Id = "PRIMARY";

            // Populate the service quote object's ship to address key property
            serviceQuote.ShipToAddressKey = shipToAddressKey;

            // Get the create policy for service quotes
            serviceQuoteCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateServiceQuote", context);

            // Create the service quote
            wsDynamicsGP.CreateServiceQuote(serviceQuote, context, serviceQuoteCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSkill

Description

This method creates a new job skill document.

Parameters

Parameter | Type | Description
businessObject | Skill | The skill object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a skill object with the key value “New test skill”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Skill skill;
            SkillKey skillKey;
            Policy policy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create a skill object
            skill = new Skill();
            skill.SkillKey = skillKey;

            // Get the create policy for skill objects
            policy = wsDynamicsGP.GetPolicyByOperation("CreateSkill", context);

            // Create the skill entry
            wsDynamicsGP.CreateSkill(skill, context, policy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Skill skill;
            SkillKey skillKey;
            Policy policy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create a skill object
            skill = new Skill();
            skill.SkillKey = skillKey;

            // Get the create policy for skill objects
            policy = wsDynamicsGP.GetPolicyByOperation("CreateSkill", context);

            // Create the skill entry
            wsDynamicsGP.CreateSkill(skill, context, policy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateSkillSet

Description

This method creates a new skill set.

Parameters

Parameter | Type | Description
businessObject | SkillSet | The skill set object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example creates a skill set object with the key value “New test skillset”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillKey skillKey;
            SkillSet skillSet;
            SkillSetKey skillSetKey;
            Policy policy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill set key
            skillSetKey = new SkillSetKey();
            skillSetKey.Id = "New test skillset";

            // Specify the skills for the skill set
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";
            Skill[] skills = {wsDynamicsGP.GetSkillByKey(skillKey, context)};

            // Create a skill set object
            skillSet = new SkillSet();
            skillSet.SkillSetKey = skillSetKey;
            skillSet.Skills = skills;

            // Get the create policy for skill set objects
            policy = wsDynamicsGP.GetPolicyByOperation("CreateSkillset", context);

            // Create the skill set entry
            wsDynamicsGP.CreateSkillSet(skillSet, context, policy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillKey skillKey;
            SkillSet skillSet;
            SkillSetKey skillSetKey;
            Policy policy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill set key
            skillSetKey = new SkillSetKey();
            skillSetKey.Id = "New test skillset";

            // Specify the skills for the skill set
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";
            Skill[] skills = {wsDynamicsGP.GetSkillByKey(skillKey, context)};

            // Create a skill set object
            skillSet = new SkillSet();
            skillSet.SkillSetKey = skillSetKey;
            skillSet.Skills = skills;

            // Get the create policy for skill set objects
            policy = wsDynamicsGP.GetPolicyByOperation("CreateSkillset", context);

            // Create the skill set entry
            wsDynamicsGP.CreateSkillSet(skillSet, context, policy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateVendor

Description

This method creates a new vendor.

Parameters

Parameter | Type | Description
vendor | Vendor | The vendor object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a vendor with the key value “NewVendor001”. The Name property is set, and all other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Vendor vendor;
            VendorKey vendorKey;
            Policy vendorPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credential are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which comany to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a new vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "NewVndr001";

            // Populate the vendor object
            vendor = new Vendor();
            vendor.Key = vendorKey;
            vendor.Name = "New Vendor 001";

            // Get the create policy for vendor
            vendorPolicy = wsDynamicsGP.GetPolicyByOperation("CreateVendor", context);

            // Create the vendor
            wsDynamicsGP.CreateVendor(vendor, context, vendorPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Vendor vendor;
            VendorKey vendorKey;
            Policy vendorPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Be sure the default credential are being used
            // Create a context object with which to call the service
            context = new Context();

            // Specify which comany to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a new vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "NewVndr001";

            // Populate the vendor object
            vendor = new Vendor();
            vendor.Key = vendorKey;
            vendor.Name = "New Vendor 001";

            // Get the create policy for vendor
            vendorPolicy = wsDynamicsGP.GetPolicyByOperation("CreateVendor", context);

            // Create the vendor
            wsDynamicsGP.CreateVendor(vendor, context, vendorPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateVendorAddress

Description

This method creates a new vendor address.

Parameters

Parameter | Type | Description
address | VendorAddress | The vendor address object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example creates a vendor address with the key value “PRIMARY” for the vendor with a vendor key of “NEWVNDR001”. “NEWVNDR001” is the vendor created by the CreateVendor example. The Line1, City and State properties are set, and all other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Policy vendorPolicy;
            VendorAddressKey vendorAddressKey;
            VendorAddress vendorAddress;
            VendorKey vendorKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key object and populate the Id property
            vendorKey = new VendorKey();
            vendorKey.Id = "NEWVNDR001";

            // Create a vendor address key
            vendorAddressKey = new VendorAddressKey();
            vendorAddressKey.Id = "PRIMARY";
            vendorAddressKey.VendorKey = vendorKey;

            // Create a vendor address object
            vendorAddress = new VendorAddress();
            vendorAddress.Key = vendorAddressKey;
            vendorAddress.Line1 = "100 Main St.";
            vendorAddress.City = "Orinoco";
            vendorAddress.State = "MN";

            // Create a policy object
            vendorPolicy = wsDynamicsGP.GetPolicyByOperation("CreateVendorAddress", context);

            // Create the vendor address
            wsDynamicsGP.CreateVendorAddress(vendorAddress, context, vendorPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Policy vendorPolicy;
            VendorAddressKey vendorAddressKey;
            VendorAddress vendorAddress;
            VendorKey vendorKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key object and populate the Id property
            vendorKey = new VendorKey();
            vendorKey.Id = "NEWVNDR001";

            // Create a vendor address key
            vendorAddressKey = new VendorAddressKey();
            vendorAddressKey.Id = "PRIMARY";
            vendorAddressKey.VendorKey = vendorKey;

            // Create a vendor address object
            vendorAddress = new VendorAddress();
            vendorAddress.Key = vendorAddressKey;
            vendorAddress.Line1 = "100 Main St.";
            vendorAddress.City = "Orinoco";
            vendorAddress.State = "MN";

            // Create a policy object
            vendorPolicy = wsDynamicsGP.GetPolicyByOperation("CreateVendorAddress", context);

            // Create the vendor address
            wsDynamicsGP.CreateVendorAddress(vendorAddress, context, vendorPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


CreateWarehouse

Description

This method creates a new warehouse (site) in Microsoft Dynamics GP.

Parameters

Parameter | Type | Description
warehouse | Warehouse | The warehouse object being created.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example creates a warehouse with the key value “TstWhse001”. The example populates the required Description property. All other properties are left as default values.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            WarehouseKey warehouseKey;
            Warehouse warehouse;
            Policy warehouseCreatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a warehouse key object to identify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "TstWhse001";

            // Create the warehouse object
            warehouse = new Warehouse();

            // Populate the required key and description properties
            warehouse.Key = warehouseKey;
            warehouse.Description = "Test warehouse for web services";

            // Get the create policy for warehouse objects
            warehouseCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateWarehouse", context);

            // Create the warehouse
            wsDynamicsGP.CreateWarehouse(warehouse, context, warehouseCreatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            WarehouseKey warehouseKey;
            Warehouse warehouse;
            Policy warehouseCreatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a warehouse key object to identify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "TstWhse001";

            // Create the warehouse object
            warehouse = new Warehouse();

            // Populate the required key and description properties
            warehouse.Key = warehouseKey;
            warehouse.Description = "Test warehouse for web services";

            // Get the create policy for warehouse objects
            warehouseCreatePolicy = wsDynamicsGP.GetPolicyByOperation("CreateWarehouse", context);

            // Create the warehouse
            wsDynamicsGP.CreateWarehouse(warehouse, context, warehouseCreatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteAllLoggedExceptionData

Description

Deletes all exceptions from the log.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example deletes all exceptions from the log.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Delete all the exception in the exception log
            wsDynamicsGP.DeleteAllLoggedExceptionData(context);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Delete all the exception in the exception log
            wsDynamicsGP.DeleteAllLoggedExceptionData(context);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteApplicant

Description

Deletes an applicant based on the key value supplied.

Parameters

Parameter | Type | Description
businessObjectKey | ApplicantKey | The applicant key object that specifies the applicant to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the applicant with the key value “1”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            Policy applicantDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Get the delete policy for the applicant
            applicantDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteApplicant", context);

            // Delete the applicant
            wsDynamicsGP.DeleteApplicant(applicantKey, context, applicantDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            Policy applicantDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Get the delete policy for the applicant
            applicantDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteApplicant", context);

            // Delete the applicant
            wsDynamicsGP.DeleteApplicant(applicantKey, context, applicantDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteApplicantApplication

Description

Deletes an applicant application object based on the key value supplied.

Parameters

Parameter | Type | Description
businessObjectKey | ApplicantSequenceKey | The applicant sequence key object that specifies the applicant application to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the applicant application where the applicant key Id value is “1” and the application sequence Id is “1”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            Policy applicantApplicationDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Get the delete policy for the applicant application objects
            applicantApplicationDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantApplication", context);

            // Delete the applicant application object
            wsDynamicsGP.DeleteApplicantApplication(applicantSequenceKey,
                context, applicantApplicationDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            Policy applicantApplicationDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Get the delete policy for the applicant application objects
            applicantApplicationDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantApplication", context);

            // Delete the applicant application object
            wsDynamicsGP.DeleteApplicantApplication(applicantSequenceKey,
                context, applicantApplicationDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteApplicantEducation

Description

Deletes applicant education information based on the key value supplied.

Parameters

Parameter | Type | Description
businessObjectKey | ApplicantSequenceKey | The applicant sequence key object that specifies the applicant education object to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the applicant education object with a key that has an applicant key value of “1” and a sequence key value of “1”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            Policy applicantEducationDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Get the delete policy for the applicant education objects
            applicantEducationDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantEducation", context);

            // Delete the applicant education object
            wsDynamicsGP.DeleteApplicantEducation(applicantSequenceKey,
                context, applicantEducationDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            Policy applicantEducationDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Get the delete policy for the applicant education objects
            applicantEducationDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantEducation", context);

            // Delete the applicant education object
            wsDynamicsGP.DeleteApplicantEducation(applicantSequenceKey,
                context, applicantEducationDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteApplicantInterview

Description

Deletes applicant interview information based on the key value supplied.

Parameters

Parameter | Type | Description
businessObjectKey | ApplicantInterviewTypeKey | The applicant interview type key object that specifies the applicant interview object to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the applicant interview object with a key that has an applicant key value of “1”, an interview type key value of “test”, and a apply date key with a value equel to the current date.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterviewTypeKey applicantInterviewTypeKey;
            ApplicantKey applicantKey;
            InterviewTypeKey interviewTypeKey;
            ApplyDateKey applyDateKey;
            Policy applicantInterviewDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an apply date key
            applyDateKey = new ApplyDateKey();
            applyDateKey.Id = DateTime.Today;

            // Create an interview type key
            interviewTypeKey = new InterviewTypeKey();
            interviewTypeKey.Id = "test";

            // Create an applicant interview type key object
            applicantInterviewTypeKey = new ApplicantInterviewTypeKey();
            applicantInterviewTypeKey.ApplicantKey = applicantKey;
            applicantInterviewTypeKey.ApplyDateKey = applyDateKey;
            applicantInterviewTypeKey.InterviewTypeKey = interviewTypeKey;

            // Get the delete policy for the applicant interview objects
            applicantInterviewDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantInterview", context);

            // Delete the applicant interview object
            wsDynamicsGP.DeleteApplicantInterview(applicantInterviewTypeKey,
                context, applicantInterviewDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterviewTypeKey applicantInterviewTypeKey;
            ApplicantKey applicantKey;
            InterviewTypeKey interviewTypeKey;
            ApplyDateKey applyDateKey;
            Policy applicantInterviewDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an apply date key
            applyDateKey = new ApplyDateKey();
            applyDateKey.Id = DateTime.Today;

            // Create an interview type key
            interviewTypeKey = new InterviewTypeKey();
            interviewTypeKey.Id = "test";

            // Create an applicant interview type key object
            applicantInterviewTypeKey = new ApplicantInterviewTypeKey();
            applicantInterviewTypeKey.ApplicantKey = applicantKey;
            applicantInterviewTypeKey.ApplyDateKey = applyDateKey;
            applicantInterviewTypeKey.InterviewTypeKey = interviewTypeKey;

            // Get the delete policy for the applicant interview objects
            applicantInterviewDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantInterview", context);

            // Delete the applicant interview object
            wsDynamicsGP.DeleteApplicantInterview(applicantInterviewTypeKey,
                context, applicantInterviewDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteApplicantReference

Description

Deletes applicant reference information based on the key value supplied.

Parameters

Parameter | Type | Description
businessObjectKey | ApplicantReferenceKey | The applicant reference key object that specifies the applicant reference object to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the applicant reference object with a key that has an applicant key value of “1”, a sequence key value of “2”, and an applicant reference key Id of “Test reference”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantReferenceKey applicantReferenceKey;
            Policy applicantReferenceDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 2;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant reference key
            applicantReferenceKey = new ApplicantReferenceKey();
            applicantReferenceKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantReferenceKey.Id = "Test reference";

            // Get the delete policy for the applicant reference objects
            applicantReferenceDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantReference", context);

            // Delete the applicant reference object
            wsDynamicsGP.DeleteApplicantReference(applicantReferenceKey,
            context, applicantReferenceDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantReferenceKey applicantReferenceKey;
            Policy applicantReferenceDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 2;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant reference key
            applicantReferenceKey = new ApplicantReferenceKey();
            applicantReferenceKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantReferenceKey.Id = "Test reference";

            // Get the delete policy for the applicant reference objects
            applicantReferenceDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantReference", context);

            // Delete the applicant reference object
            wsDynamicsGP.DeleteApplicantReference(applicantReferenceKey,
            context, applicantReferenceDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteApplicantSkill

Description

Deletes applicant skill information based on the key value supplied.

Parameters

Parameter | Type | Description
businessObjectKey | ApplicantSkillKey | The applicant skill key object that specifies the applicant skill object to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the applicant skill object with a key that has an applicant skill key value of “New test skill”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SkillKey skillKey;
            ApplicantSkillKey applicantSkillKey;
            Policy applicantSkillDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create an applicant skill key
            applicantSkillKey = new ApplicantSkillKey();
            applicantSkillKey.ApplicantKey = applicantKey;
            applicantSkillKey.SkillKey = skillKey;

            // Get the delete policy for applicant skill objects
            applicantSkillDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteApplicantSkill", context);

            // Delete the applicant skill object
            wsDynamicsGP.DeleteApplicantSkill(applicantSkillKey, context, applicantSkillDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SkillKey skillKey;
            ApplicantSkillKey applicantSkillKey;
            Policy applicantSkillDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create an applicant skill key
            applicantSkillKey = new ApplicantSkillKey();
            applicantSkillKey.ApplicantKey = applicantKey;
            applicantSkillKey.SkillKey = skillKey;

            // Get the delete policy for applicant skill objects
            applicantSkillDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteApplicantSkill", context);

            // Delete the applicant skill object
            wsDynamicsGP.DeleteApplicantSkill(applicantSkillKey, context, applicantSkillDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteApplicantTest

Description

Deletes applicant test information based on the key value supplied.

Parameters

Parameter | Type | Description
businessObjectKey | ApplicantTestKey | The applicant test key object that specifies the applicant test object to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the specified applicant test object. To identify the test object, the applicant test key specifies the applicant, a sequence number, and a test key value of “TEST1”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            TestKey testKey;
            ApplicantTestKey applicantTestKey;
            Policy applicantTestDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create a test key
            testKey = new TestKey();
            testKey.Id = "NEWTES";

            // Create an applicant test key
            applicantTestKey = new ApplicantTestKey();
            applicantTestKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantTestKey.TestKey = testKey;

            // Get the update policy for applicant test objects
            applicantTestDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteApplicantTest", context);

            // Update the applicant test information
            wsDynamicsGP.DeleteApplicantTest(applicantTestKey, context, applicantTestDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            TestKey testKey;
            ApplicantTestKey applicantTestKey;
            Policy applicantTestDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create a test key
            testKey = new TestKey();
            testKey.Id = "NEWTES";

            // Create an applicant test key
            applicantTestKey = new ApplicantTestKey();
            applicantTestKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantTestKey.TestKey = testKey;

            // Get the update policy for applicant test objects
            applicantTestDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteApplicantTest", context);

            // Update the applicant test information
            wsDynamicsGP.DeleteApplicantTest(applicantTestKey, context, applicantTestDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteApplicantWorkHistory

Description

Deletes applicant work history information based on a specified key value.

Parameters

Parameter | Type | Description
businessObjectKey | ApplicantWorkHistoryKey | The applicant work history key object that specifies the applicant work history object to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the specified applicant work history object. To identify the work history object, the applicant work history key specifies the applicant, the sequence number, and the Id value of “Previous employer”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantWorkHistoryKey applicantWorkHistoryKey;
            Policy applicantWorkHistoryDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant work history key
            applicantWorkHistoryKey = new ApplicantWorkHistoryKey();
            applicantWorkHistoryKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantWorkHistoryKey.Id = "Previous employer";

            // Get the update policy for applicant work history objects
            applicantWorkHistoryDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantWorkHistory", context);

            // Delete the work history object for the specified applicant
            wsDynamicsGP.DeleteApplicantWorkHistory(applicantWorkHistoryKey,
                context, applicantWorkHistoryDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantWorkHistoryKey applicantWorkHistoryKey;
            Policy applicantWorkHistoryDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant work history key
            applicantWorkHistoryKey = new ApplicantWorkHistoryKey();
            applicantWorkHistoryKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantWorkHistoryKey.Id = "Previous employer";

            // Get the update policy for applicant work history objects
            applicantWorkHistoryDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteApplicantWorkHistory", context);

            // Delete the work history object for the specified applicant
            wsDynamicsGP.DeleteApplicantWorkHistory(applicantWorkHistoryKey,
                context, applicantWorkHistoryDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteBusinessObjectUserAssignment

Description

Deletes a business object user assignment.

Parameters

Parameter | Type | Description
businessObjectUserAssignment | BusinessObjectUserAssignment | The business object user assignment to be deleted.
context | Context | Specifies information about how the method will be called.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following example deletes all of the business object user assignments for the Windows User ID “CORPORATE\stevek”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            BusinessObjectUserAssignment[] businessObjectUserAssignments;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the business object user assignment objects
            businessObjectUserAssignments = wsDynamicsGP.GetBusinessObjectUserAssignmentList(context);

            // Delete the assignments for the specific Windows user
            foreach (BusinessObjectUserAssignment a in businessObjectUserAssignments)
            {
                if (a.User == "CORPORATE\\stevek")
                {
                    // Delete this object
                    wsDynamicsGP.DeleteBusinessObjectUserAssignment(a, context);
                }
            }
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            BusinessObjectUserAssignment[] businessObjectUserAssignments;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the business object user assignment objects
            businessObjectUserAssignments = wsDynamicsGP.GetBusinessObjectUserAssignmentList(context);

            // Delete the assignments for the specific Windows user
            foreach (BusinessObjectUserAssignment a in businessObjectUserAssignments)
            {
                if (a.User == "CORPORATE\\stevek")
                {
                    // Delete this object
                    wsDynamicsGP.DeleteBusinessObjectUserAssignment(a, context);
                }
            }

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteCustomer

Description

Deletes a customer based on the key value supplied.

Parameters

Parameter | Type | Description
key | CustomerKey | The customer key object that specifies the customer to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example deletes the customer with the key value “CONTOSO”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            Policy customerPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "CONTOSO";

            // Get the delete policy for the customer
            customerPolicy = wsDynamicsGP.GetPolicyByOperation("DeleteCustomer", context);

            // Delete the customer
            wsDynamicsGP.DeleteCustomer(customerKey, context, customerPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            Policy customerPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "CONTOSO";

            // Get the delete policy for the customer
            customerPolicy = wsDynamicsGP.GetPolicyByOperation("DeleteCustomer", context);

            // Delete the customer
            wsDynamicsGP.DeleteCustomer(customerKey, context, customerPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteCustomerAddress

Description

Deletes a customer address based on the key value supplied.

Parameters

Parameter | Type | Description
key | CustomerAddressKey | The customer address key object that specifies the customer address to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example deletes the customer address with the key value “BILLING” for the customer with a key value of “AARONFIT0001”. The “BILLING” customer address used in this example was created by the CreateCustomerAddress example.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerAddressKey customerAddressKey;
            Policy customerAddressDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a customer address key
            customerAddressKey = new CustomerAddressKey();
            customerAddressKey.CustomerKey = customerKey;
            customerAddressKey.Id = "BILLING";

            // Get the delete policy for customer address
            customerAddressDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteCustomerAddress",
            context);

            // Delete the customer address
            wsDynamicsGP.DeleteCustomerAddress(customerAddressKey, context, customerAddressDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerAddressKey customerAddressKey;
            Policy customerAddressDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a customer address key
            customerAddressKey = new CustomerAddressKey();
            customerAddressKey.CustomerKey = customerKey;
            customerAddressKey.Id = "BILLING";

            // Get the delete policy for customer address
            customerAddressDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteCustomerAddress",
            context);

            // Delete the customer address
            wsDynamicsGP.DeleteCustomerAddress(customerAddressKey, context, customerAddressDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteEmployeeAddress

Description

Deletes an employee address based on the key value supplied.

Parameters

Parameter | Type | Description
key | EmployeeAddressKey | The employee address key object that specifies the employee address to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the address information for the employee “ACKE0001” where the employee address key Id value is “Test address”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeKey employeeKey;
            EmployeeAddressKey employeeAddressKey;
            Policy employeeAddressDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create an employee address key
            employeeAddressKey = new EmployeeAddressKey();
            employeeAddressKey.EmployeeKey = employeeKey;
            employeeAddressKey.Id = "Test address";

            // Get the delete policy for employee address objects
            employeeAddressDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteEmployeeAddress", context);

            // Delete the specified employee address object
            wsDynamicsGP.DeleteEmployeeAddress(employeeAddressKey, context, employeeAddressDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeKey employeeKey;
            EmployeeAddressKey employeeAddressKey;
            Policy employeeAddressDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create an employee address key
            employeeAddressKey = new EmployeeAddressKey();
            employeeAddressKey.EmployeeKey = employeeKey;
            employeeAddressKey.Id = "Test address";

            // Get the delete policy for employee address objects
            employeeAddressDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
                "DeleteEmployeeAddress", context);

            // Delete the specified employee address object
            wsDynamicsGP.DeleteEmployeeAddress(employeeAddressKey, context, employeeAddressDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteLoggedExceptionDataByKey

Description

Deletes a single exception from the log based on the logId value supplied.

Parameters

Parameter | Type | Description
logId | guid | A key that uniquely identifies the logged exception.
context | Context | Specifies information about how the method will be called.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example deletes a logged exception. To use this example, the logid GUID in the example should be replaced with a valid logid from the exception log.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Guid logId;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the logid to be deleted
            logId = new Guid("cc9170cf-17c0-4d2e-acb7-9457f1425aa7");

            // Delete the exception from the exception log
            wsDynamicsGP.DeleteLoggedExceptionDataByKey(logId, context);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Guid logId;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the logid to be deleted
            logId = new Guid("cc9170cf-17c0-4d2e-acb7-9457f1425aa7");

            // Delete the exception from the exception log
            wsDynamicsGP.DeleteLoggedExceptionDataByKey(logId, context);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeletePolicy

Description

Deletes a policy instance for the specified role.

Parameters

Parameter | Type | Description
policyKey | PolicyKey | The policy key object that specifies the policy for which a policy instance will be deleted.
roleKey | RoleKey | The role key object that specifies the role for the policy instance that is being deleted.
context | Context | Specifies information about how the method will be called.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example deletes the policy intance of the Update Sales Return policy for the Sales Representitive role.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicyKey policyKey;
            RoleKey roleKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Get the update policy for sales returns
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("a08b0c69-13bd-4a7b-bda9-d7902803364b");

            // Create the role key for the role
            roleKey = new RoleKey();
            roleKey.Id = "aaeb72e0-77f9-4925-ab9a-73012417fb37";

            // Delete the policy instance for sales returns
            wsDynamicsGP.DeletePolicy(policyKey, roleKey, context);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicyKey policyKey;
            RoleKey roleKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Get the update policy for sales returns
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("a08b0c69-13bd-4a7b-bda9-d7902803364b");

            // Create the role key for the role
            roleKey = new RoleKey();
            roleKey.Id = "aaeb72e0-77f9-4925-ab9a-73012417fb37";

            // Delete the policy instance for sales returns
            wsDynamicsGP.DeletePolicy(policyKey, roleKey, context);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeletePurchaseOrder

Description

Deletes a purchase order based on the purchase transaction key value supplied.

Parameters

Parameter | Type | Description
key | PurchaseTransactionKey | The purchase transaction key that specifies the purchase order to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example deletes the purchase order with the purchase transaction key value of “PO2072”. DeletePurchaseOrder can be used with only purchase orders that have a status of “New”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            Policy purchaseOrderDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key object to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO2072";

            // Get the delete policy for purchase order objects
            purchaseOrderDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeletePurchaseOrder", context);

            // Delete the purchase order
            wsDynamicsGP.DeletePurchaseOrder(purchaseOrderKey, context, purchaseOrderDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            Policy purchaseOrderDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key object to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO2072";

            // Get the delete policy for purchase order objects
            purchaseOrderDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeletePurchaseOrder", context);

            // Delete the purchase order
            wsDynamicsGP.DeletePurchaseOrder(purchaseOrderKey, context, purchaseOrderDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteSalesBackorder

Description

Deletes a sales backorder based on the key value supplied.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key that specifies the sales backorder to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example deletes the sales backorder with the key value “BKO1005”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesBackorderKey;
            Policy salesBackorderDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesBackorderKey = new SalesDocumentKey();
            salesBackorderKey.Id = "BKO1005";

            // Get the delete policy for sales backorders
            salesBackorderDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesBackorder", context);

            // Delete the sales backorder
            wsDynamicsGP.DeleteSalesBackorder(salesBackorderKey, context, salesBackorderDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesBackorderKey;
            Policy salesBackorderDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesBackorderKey = new SalesDocumentKey();
            salesBackorderKey.Id = "BKO1005";

            // Get the delete policy for sales backorders
            salesBackorderDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesBackorder", context);

            // Delete the sales backorder
            wsDynamicsGP.DeleteSalesBackorder(salesBackorderKey, context, salesBackorderDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteSalesFulfillmentOrder

Description

Deletes a sales fulfillment order based on the key value supplied.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key that specifies the sales fulfillment order to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example deletes the sales fulfillment order with the key value “FULORD1001”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            Policy salesFulfillmentOrderDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales fulfillment order
            documentKey = new SalesDocumentKey();
            documentKey.Id = "FULORD1001";

            // Get the delete policy for sales fulfillment orders
            salesFulfillmentOrderDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
            "DeleteSalesFulfillmentOrder", context);

            // Delete the sales fulfillment order
            wsDynamicsGP.DeleteSalesFulfillmentOrder(documentKey,
            context, salesFulfillmentOrderDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            Policy salesFulfillmentOrderDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales fulfillment order
            documentKey = new SalesDocumentKey();
            documentKey.Id = "FULORD1001";

            // Get the delete policy for sales fulfillment orders
            salesFulfillmentOrderDeletePolicy = wsDynamicsGP.GetPolicyByOperation(
            "DeleteSalesFulfillmentOrder", context);

            // Delete the sales fulfillment order
            wsDynamicsGP.DeleteSalesFulfillmentOrder(documentKey,
            context, salesFulfillmentOrderDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteSalesInvoice

Description

Deletes a sales invoice based on the key value supplied.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key that specifies the sales invoice to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example deletes the sales invoice with the key value “STDINV2260”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesInvoiceKey;
            Policy salesInvoiceDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesInvoiceKey = new SalesDocumentKey();
            salesInvoiceKey.Id = "STDINV2260";

            // Get the delete policy for sales invoices
            salesInvoiceDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesInvoice", context);

            // Delete the sales invoice
            wsDynamicsGP.DeleteSalesInvoice(salesInvoiceKey, context, salesInvoiceDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesInvoiceKey;
            Policy salesInvoiceDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesInvoiceKey = new SalesDocumentKey();
            salesInvoiceKey.Id = "STDINV2260";

            // Get the delete policy for sales invoices
            salesInvoiceDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesInvoice", context);

            // Delete the sales invoice
            wsDynamicsGP.DeleteSalesInvoice(salesInvoiceKey, context, salesInvoiceDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteSalesOrder

Description

Deletes a sales order based on the key value supplied.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key that specifies the sales order to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example deletes the sales order with the key value “ORDST2226”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesOrderKey;
            Policy salesOrderDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesOrderKey = new SalesDocumentKey();
            salesOrderKey.Id = "ORDST2226";

            // Get the sales order delete policy
            salesOrderDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesOrder", context);

            // Delete the specified sales order
            wsDynamicsGP.DeleteSalesOrder(salesOrderKey, context, salesOrderDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesOrderKey;
            Policy salesOrderDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesOrderKey = new SalesDocumentKey();
            salesOrderKey.Id = "ORDST2226";

            // Get the sales order delete policy
            salesOrderDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesOrder", context);

            // Delete the specified sales order
            wsDynamicsGP.DeleteSalesOrder(salesOrderKey, context, salesOrderDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteSalesQuote

Description

Deletes a sales quote based on the key value supplied.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key that specifies the sales quote to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example deletes the sales quote with the key value “QTEST1022”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            Policy salesQuoteDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales quote
            documentKey = new SalesDocumentKey();
            documentKey.Id = "QTEST1022";

            // Get the delete policy for sales quotes
            salesQuoteDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesQuote", context);

            // Delete the sales quote
            wsDynamicsGP.DeleteSalesQuote(documentKey, context, salesQuoteDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            Policy salesQuoteDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales quote
            documentKey = new SalesDocumentKey();
            documentKey.Id = "QTEST1022";

            // Get the delete policy for sales quotes
            salesQuoteDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesQuote", context);

            // Delete the sales quote
            wsDynamicsGP.DeleteSalesQuote(documentKey, context, salesQuoteDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteSalesReturn

Description

Deletes a sales return based on the key value supplied.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key that specifies the sales return to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example deletes the sales return with the key value “STDINV2258”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            Policy salesReturnDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key and specify a sales return object
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2258";

            // Retrieve the delete policy for sales returns
            salesReturnDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesReturn", context);

            // Delete the sales return
            wsDynamicsGP.DeleteSalesReturn(salesReturnKey, context, salesReturnDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            Policy salesReturnDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key and specify a sales return object
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2258";

            // Retrieve the delete policy for sales returns
            salesReturnDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSalesReturn", context);

            // Delete the sales return
            wsDynamicsGP.DeleteSalesReturn(salesReturnKey, context, salesReturnDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteSkill

Description

Deletes a skill based on the key value supplied.

Parameters

Parameter | Type | Description
key | SkillKey | The skill key that specifies the skill to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the skill with the skill key value “New test skill”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillKey skillKey;
            Policy skillDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Get the delete policy for skill objects
            skillDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSkill", context);

            // Delete the specified skill object
            wsDynamicsGP.DeleteSkill(skillKey, context, skillDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillKey skillKey;
            Policy skillDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Get the delete policy for skill objects
            skillDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSkill", context);

            // Delete the specified skill object
            wsDynamicsGP.DeleteSkill(skillKey, context, skillDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteSkillSet

Description

Deletes a skill set based on the key value supplied.

Parameters

Parameter | Type | Description
key | SkillSetKey | The skill set key that specifies the skill set to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example deletes the skill set with the skill set key value “New test skill set”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillSetKey skillSetKey;
            Policy skillSetDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill set key
            skillSetKey = new SkillSetKey();
            skillSetKey.Id = "New test skill set";

            // Get the delete policy for skill set objects
            skillSetDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSkillset", context);

            // Delete the specified skill set object
            wsDynamicsGP.DeleteSkillSet(skillSetKey, context, skillSetDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillSetKey skillSetKey;
            Policy skillSetDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill set key
            skillSetKey = new SkillSetKey();
            skillSetKey.Id = "New test skill set";

            // Get the delete policy for skill set objects
            skillSetDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteSkillset", context);

            // Delete the specified skill set object
            wsDynamicsGP.DeleteSkillSet(skillSetKey, context, skillSetDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DeleteVendorAddress

Description

Deletes a vendor address based on the key value supplied.

Parameters

Parameter | Type | Description
key | VendorAddressKey | The vendor address key that specifies the vendor address to delete.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example deletes the vendor address for the vendor "ACETRAVE0001"and the vendor address Id of “TEST ADDRESS”.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorKey vendorKey;
            VendorAddressKey vendorAddressKey;
            Policy vendorAddressDeletePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key and specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create the vendor address key object
            vendorAddressKey = new VendorAddressKey();
            vendorAddressKey.VendorKey = vendorKey;
            vendorAddressKey.Id = "TEST ADDRESS";

            // Get the delete policy for vendor address objects
            vendorAddressDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteVendorAddress", context);

            // Delete the vendor address object
            wsDynamicsGP.DeleteVendorAddress(vendorAddressKey, context, vendorAddressDeletePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorKey vendorKey;
            VendorAddressKey vendorAddressKey;
            Policy vendorAddressDeletePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key and specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create the vendor address key object
            vendorAddressKey = new VendorAddressKey();
            vendorAddressKey.VendorKey = vendorKey;
            vendorAddressKey.Id = "TEST ADDRESS";

            // Get the delete policy for vendor address objects
            vendorAddressDeletePolicy = wsDynamicsGP.GetPolicyByOperation("DeleteVendorAddress", context);

            // Delete the vendor address object
            wsDynamicsGP.DeleteVendorAddress(vendorAddressKey, context, vendorAddressDeletePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


DiscontinueSalesItem

Description

Discontinues a sales item based on the item key value supplied.

Parameters

Parameter | Type | Description
key | ItemKey | The item key that specifies the sales item to discontinue.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example discontinues the sales item with the item key value “TESTINVENTORYITEM0005”. The “TESTINVENTORYITEM0005” sales item used in this example was created by the CreateSalesItem example.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            Policy salesItemDiscontinuePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object to specify the sales item
            itemKey = new ItemKey();
            itemKey.Id = "TESTINVENTORYITEM0005";

            // Get the discontinue policy for sales items
            salesItemDiscontinuePolicy = wsDynamicsGP.GetPolicyByOperation("DiscontinueSalesItem", context);

            // Discontinue the sales item
            wsDynamicsGP.DiscontinueSalesItem(itemKey, context, salesItemDiscontinuePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            Policy salesItemDiscontinuePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object to specify the sales item
            itemKey = new ItemKey();
            itemKey.Id = "TESTINVENTORYITEM0005";

            // Get the discontinue policy for sales items
            salesItemDiscontinuePolicy = wsDynamicsGP.GetPolicyByOperation("DiscontinueSalesItem", context);

            // Discontinue the sales item
            wsDynamicsGP.DiscontinueSalesItem(itemKey, context, salesItemDiscontinuePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantApplicationByKey

Description

Retrieves a single job application object for a specified applicant.

Parameters

Parameter | Type | Description
key | ApplicantSequenceKey | The applicant sequence key object that specifies the applicant application to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantApplicationByKeyResult | ApplicantApplication | An applicant application object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant application for the applicant with the key Id value “1” and the application sequence Id value of “1”. The value of the IsReplyLetterSent property of the applicant application is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantApplication applicantApplication;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Retrieve the applicant application object
            applicantApplication = wsDynamicsGP.GetApplicantApplicationByKey(applicantSequenceKey, context);

            // Display whether a reply letter was sent for the specified applicant application object
            MessageBox.Show("Reply letter sent: " + applicantApplication.IsReplyLetterSent.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantApplication applicantApplication;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Retrieve the applicant application object
            applicantApplication = wsDynamicsGP.GetApplicantApplicationByKey(applicantSequenceKey, context);

            // Display whether a reply letter was sent for the specified applicant application object
            MessageBox.Show("Reply letter sent: " + applicantApplication.IsReplyLetterSent.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantApplicationList

Description

Retrieves a list of applicant application summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ApplicantApplicationCriteria | The applicant application criteria object that specifies which applicant application summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantApplicationListResult | ArrayOfApplicantApplicationSummary | The list of applicant application summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of applicant application summary objects for the applicant with an applicant Id value of “1”. The total number of applications for the specified applicant is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantApplicationSummary[] applicantApplicationList;
            ApplicantApplicationCriteria applicantApplicationCriteria;
            LikeRestrictionOfNullableOfInt32 applicantIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant application objects to retrieve
            applicantIdRestriction = new LikeRestrictionOfNullableOfInt32();
            applicantIdRestriction.EqualValue = 1;
            applicantApplicationCriteria = new ApplicantApplicationCriteria();
            applicantApplicationCriteria.ApplicantKeyId = applicantIdRestriction;

            // Retrieve the list of applications for the specified applicant
            applicantApplicationList = wsDynamicsGP.GetApplicantApplicationList(
                applicantApplicationCriteria, context);

            // Display the number of applications for the applicant
            MessageBox.Show("Total number of applications: " + applicantApplicationList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantApplicationSummary[] applicantApplicationList;
            ApplicantApplicationCriteria applicantApplicationCriteria;
            LikeRestrictionOfNullableOfint applicantIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant application objects to retrieve
            applicantIdRestriction = new LikeRestrictionOfNullableOfint();
            applicantIdRestriction.EqualValue = 1;
            applicantApplicationCriteria = new ApplicantApplicationCriteria();
            applicantApplicationCriteria.ApplicantKeyId = applicantIdRestriction;

            // Retrieve the list of applications for the specified applicant
            applicantApplicationList = wsDynamicsGP.GetApplicantApplicationList(
                applicantApplicationCriteria, context);

            // Display the number of applications for the applicant
            MessageBox.Show("Total number of applications: " + applicantApplicationList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantByKey

Description

Retrieves a single applicant object based on the key value supplied.

Parameters

Parameter | Type | Description
key | ApplicantKey | The applicant key object that specifies the applicant to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantByKeyResult | Applicant | An applicant object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant with the key value “1”. The name of the applicant is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Applicant applicant;
            ApplicantKey applicantKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Retrieve the specified applicant
            applicant = wsDynamicsGP.GetApplicantByKey(applicantKey, context);

            // Display the applicant name
            MessageBox.Show("The name of the specified applicant: " +
                applicant.FirstName + " " + applicant.LastName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Applicant applicant;
            ApplicantKey applicantKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Retrieve the specified applicant
            applicant = wsDynamicsGP.GetApplicantByKey(applicantKey, context);

            // Display the applicant name
            MessageBox.Show("The name of the specified applicant: " +
                applicant.FirstName + " " + applicant.LastName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantEducationByKey

Description

Retrieves a single applicant education object based on the key value supplied.

Parameters

Parameter | Type | Description
key | ApplicantSequenceKey | The applicant sequence key object that specifies the applicant education object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantEducationByKeyResult | ApplicantEducation | An applicant education object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant education object with an application key and sequence key value of “1”. The school property of the specified applicant education object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantEducation applicantEducation;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Retrieve the applicant education object
            applicantEducation = wsDynamicsGP.GetApplicantEducationByKey(applicantSequenceKey, context);

            // Display the school property of the specified applicant education object
            MessageBox.Show(applicantEducation.School);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantEducation applicantEducation;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Retrieve the applicant education object
            applicantEducation = wsDynamicsGP.GetApplicantEducationByKey(applicantSequenceKey, context);

            // Display the school property of the specified applicant education object
            MessageBox.Show(applicantEducation.School);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantEducationList

Description

Retrieves a list of applicant education objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ApplicantEducationCriteria | The applicant eduction criteria object that specifies which applicant eduction objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantEducationListResult | ArrayOfApplicantEducation | The list of applicant education objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of applicant education objects with a School property of “Local University”. The total number of applicant education objects is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantEducation[] applicantEducation;
            ApplicantEducationCriteria applicantCriteria;
            LikeRestrictionOfString schoolRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant education objects to retrieve
            schoolRestriction = new LikeRestrictionOfString();
            schoolRestriction.Like = "Local University";
            applicantCriteria = new ApplicantEducationCriteria();
            applicantCriteria.School = schoolRestriction;

            // Retrieve the list of applicant education objects
            applicantEducation = wsDynamicsGP.GetApplicantEducationList(applicantCriteria, context);

            // Display the number of applicant education objects matching the criteria
            MessageBox.Show("Total applicants educated at a local university:" +
                applicantEducation.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantEducation[] applicantEducation;
            ApplicantEducationCriteria applicantCriteria;
            LikeRestrictionOfstring schoolRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant education objects to retrieve
            schoolRestriction = new LikeRestrictionOfstring();
            schoolRestriction.Like = "Local University";
            applicantCriteria = new ApplicantEducationCriteria();
            applicantCriteria.School = schoolRestriction;

            // Retrieve the list of applicant education objects
            applicantEducation = wsDynamicsGP.GetApplicantEducationList(applicantCriteria, context);

            // Display the number of applicant education objects matching the criteria
            MessageBox.Show("Total applicants educated at a local university:" +
                applicantEducation.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantInterviewByKey

Description

Retrieves a single applicant interview object based on the key value supplied.

Parameters

Parameter | Type | Description
key | ApplicantInterviewTypeKey | The applicant interview type key object that specifies the applicant interview object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantInterviewByKeyResult | ApplicantInterview | An applicant interview object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant interview object with an application key value of “1”, an interviewType key of “test”, and an apply date key equal to the current date. The interview notes from the specified applicant interview object are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterview applicantInterview;
            ApplicantKey applicantKey;
            InterviewTypeKey interviewTypeKey;
            ApplyDateKey applyDateKey;
            ApplicantInterviewTypeKey applicantInterviewTypeKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an interview type key
            interviewTypeKey = new InterviewTypeKey();
            interviewTypeKey.Id = "test";

            // Create an apply date key
            applyDateKey = new ApplyDateKey();
            applyDateKey.Id = DateTime.Today;

            // Create an applicant interview type key
            applicantInterviewTypeKey = new ApplicantInterviewTypeKey();
            applicantInterviewTypeKey.ApplicantKey = applicantKey;
            applicantInterviewTypeKey.InterviewTypeKey = interviewTypeKey;
            applicantInterviewTypeKey.ApplyDateKey = applyDateKey;

            // Retrieve the applicant interview object
            applicantInterview = wsDynamicsGP.GetApplicantInterviewByKey(applicantInterviewTypeKey, context);

            // Display the notes property of the specified applicant interview object
            MessageBox.Show("Interview notes: " + applicantInterview.Notes);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterview applicantInterview;
            ApplicantKey applicantKey;
            InterviewTypeKey interviewTypeKey;
            ApplyDateKey applyDateKey;
            ApplicantInterviewTypeKey applicantInterviewTypeKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an interview type key
            interviewTypeKey = new InterviewTypeKey();
            interviewTypeKey.Id = "test";

            // Create an apply date key
            applyDateKey = new ApplyDateKey();
            applyDateKey.Id = DateTime.Today;

            // Create an applicant interview type key
            applicantInterviewTypeKey = new ApplicantInterviewTypeKey();
            applicantInterviewTypeKey.ApplicantKey = applicantKey;
            applicantInterviewTypeKey.InterviewTypeKey = interviewTypeKey;
            applicantInterviewTypeKey.ApplyDateKey = applyDateKey;

            // Retrieve the applicant interview object
            applicantInterview = wsDynamicsGP.GetApplicantInterviewByKey(applicantInterviewTypeKey, context);

            // Display the notes property of the specified applicant interview object
            MessageBox.Show("Interview notes: " + applicantInterview.Notes);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantInterviewList

Description

Retrieves a list of applicant interview summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ApplicantInterviewCriteria | The applicant interview criteria object that specifies which applicant interview summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantInterviewListResult | ArrayOfApplicantInterviewSummary | The list of applicant interview summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of applicant interview summary objects where the interview type is “test”. The total number of applicant interviews is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterviewSummary[] applicantInterviews;
            ApplicantInterviewCriteria applicantInterviewCriteria;
            LikeRestrictionOfString interviewTypeRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant summaries to retrieve
            interviewTypeRestriction = new LikeRestrictionOfString();
            interviewTypeRestriction.Like = "test";
            applicantInterviewCriteria = new ApplicantInterviewCriteria();
            applicantInterviewCriteria.InterviewTypeKeyId = interviewTypeRestriction;

            // Retrieve the list of applicant interview summaries
            applicantInterviews = wsDynamicsGP.GetApplicantInterviewList(applicantInterviewCriteria, context);

            // Display the number of applicant interviews matching the criteria
            MessageBox.Show("Total applicant interviews of type Test:"
                + applicantInterviews.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterviewSummary[] applicantInterviews;
            ApplicantInterviewCriteria applicantInterviewCriteria;
            LikeRestrictionOfstring interviewTypeRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant summaries to retrieve
            interviewTypeRestriction = new LikeRestrictionOfstring();
            interviewTypeRestriction.Like = "test";
            applicantInterviewCriteria = new ApplicantInterviewCriteria();
            applicantInterviewCriteria.InterviewTypeKeyId = interviewTypeRestriction;

            // Retrieve the list of applicant interview summaries
            applicantInterviews = wsDynamicsGP.GetApplicantInterviewList(applicantInterviewCriteria, context);

            // Display the number of applicant interviews matching the criteria
            MessageBox.Show("Total applicant interviews of type Test:"
                + applicantInterviews.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantList

Description

Retrieves a list of applicant summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ApplicantCriteria | The applicant criteria object that specifies which applicant summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantListResult | ArrayOfApplicantSummary | The list of applicant summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of applicant summary objects for the applicants whose FirstName property is “Test”. The total number of applicants is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSummary[] applicants;
            ApplicantCriteria applicantCriteria;
            LikeRestrictionOfString nameRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant summaries to retrieve
            nameRestriction = new LikeRestrictionOfString();
            nameRestriction.Like = "Test";
            applicantCriteria = new ApplicantCriteria();
            applicantCriteria.FirstName = nameRestriction;

            // Retrieve the list of applicant summaries
            applicants = wsDynamicsGP.GetApplicantList(applicantCriteria, context);

            // Display the number of applicants matching the criteria
            MessageBox.Show("Total applicants with First Name equal to Test:" + applicants.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSummary[] applicants;
            ApplicantCriteria applicantCriteria;
            LikeRestrictionOfstring nameRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant summaries to retrieve
            nameRestriction = new LikeRestrictionOfstring();
            nameRestriction.Like = "Test";
            applicantCriteria = new ApplicantCriteria();
            applicantCriteria.FirstName = nameRestriction;

            // Retrieve the list of applicant summaries
            applicants = wsDynamicsGP.GetApplicantList(applicantCriteria, context);

            // Display the number of applicants matching the criteria
            MessageBox.Show("Total applicants with First Name equal to Test:" + applicants.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantReferenceByKey

Description

Retrieves a single applicant reference object based on the key value supplied.

Parameters

Parameter | Type | Description
key | ApplicantReferenceKey | The applicant reference key object that specifies the applicant reference object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantReferenceByKeyResult | ApplicantReference | An applicant reference object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant reference object with the specifed application reference key. The relationship of the applicant reference object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantReference applicantReference;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantReferenceKey applicantReferenceKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 2;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant reference key
            applicantReferenceKey = new ApplicantReferenceKey();
            applicantReferenceKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantReferenceKey.Id = "Test reference";

            // Retrieve the applicant reference object
            applicantReference = wsDynamicsGP.GetApplicantReferenceByKey(applicantReferenceKey, context);

            // Display the relationship property of the specified applicant reference object
            MessageBox.Show(applicantReference.Relationship);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantReference applicantReference;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantReferenceKey applicantReferenceKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 2;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant reference key
            applicantReferenceKey = new ApplicantReferenceKey();
            applicantReferenceKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantReferenceKey.Id = "Test reference";

            // Retrieve the applicant reference object
            applicantReference = wsDynamicsGP.GetApplicantReferenceByKey(applicantReferenceKey, context);

            // Display the relationship property of the specified applicant reference object
            MessageBox.Show(applicantReference.Relationship);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantReferenceList

Description

Retrieves a list of applicant reference summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ApplicantReferenceCriteria | The applicant reference criteria object that specifies which applicant reference summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantReferenceListResult | ArrayOfApplicantReferenceSummary | The list of applicant reference summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of applicant reference objects with a Relationship property of “Coworker”. The total number of applicant reference objects is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantReferenceSummary[] applicantReferences;
            ApplicantReferenceCriteria applicantReferenceCriteria;
            LikeRestrictionOfString relationshipRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant reference objects to retrieve
            relationshipRestriction = new LikeRestrictionOfString();
            relationshipRestriction.Like = "Coworker";
            applicantReferenceCriteria = new ApplicantReferenceCriteria();
            applicantReferenceCriteria.Relationship = relationshipRestriction;

            // Retrieve the list of applicant reference objects
            applicantReferences = wsDynamicsGP.GetApplicantReferenceList(applicantReferenceCriteria, context);

            // Display the number of applicant reference objects matching the criteria
            MessageBox.Show("Total applicants references:" +
                applicantReferences.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantReferenceSummary[] applicantReferences;
            ApplicantReferenceCriteria applicantReferenceCriteria;
            LikeRestrictionOfstring relationshipRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant reference objects to retrieve
            relationshipRestriction = new LikeRestrictionOfstring();
            relationshipRestriction.Like = "Coworker";
            applicantReferenceCriteria = new ApplicantReferenceCriteria();
            applicantReferenceCriteria.Relationship = relationshipRestriction;

            // Retrieve the list of applicant reference objects
            applicantReferences = wsDynamicsGP.GetApplicantReferenceList(applicantReferenceCriteria, context);

            // Display the number of applicant reference objects matching the criteria
            MessageBox.Show("Total applicants references:" +
                applicantReferences.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantSkillByKey

Description

Retrieves a single applicant skill object based on the key value supplied.

Parameters

Parameter | Type | Description
key | ApplicantSkillKey | The applicant skill key object that specifies the applicant skill object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantSkillByKeyResult | ApplicantSkill | An applicant skill object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant skill object with the specifed applicant skill key. The comment for the applicant skill object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSkill applicantSkill;
            ApplicantKey applicantKey;
            SkillKey skillKey;
            ApplicantSkillKey applicantSkillKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create an applicant skill key
            applicantSkillKey = new ApplicantSkillKey();
            applicantSkillKey.ApplicantKey = applicantKey;
            applicantSkillKey.SkillKey = skillKey;

            // Retrieve the applicant skill object
            applicantSkill = wsDynamicsGP.GetApplicantSkillByKey(applicantSkillKey, context);

            // Display the comments for the specified applicant skill object
            MessageBox.Show(applicantSkill.Comments);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSkill applicantSkill;
            ApplicantKey applicantKey;
            SkillKey skillKey;
            ApplicantSkillKey applicantSkillKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create an applicant skill key
            applicantSkillKey = new ApplicantSkillKey();
            applicantSkillKey.ApplicantKey = applicantKey;
            applicantSkillKey.SkillKey = skillKey;

            // Retrieve the applicant skill object
            applicantSkill = wsDynamicsGP.GetApplicantSkillByKey(applicantSkillKey, context);

            // Display the comments for the specified applicant skill object
            MessageBox.Show(applicantSkill.Comments);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantSkillList

Description

Retrieves a list of applicant skill objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ApplicantSkillCriteria | The applicant skill criteria object that specifies which applicant skill objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantSkillListResult | ArrayOfApplicantSkill | The list of applicant skill objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of applicant skill objects for the applicant with the Id of “1”. The total number of applicant skills is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSkill[] applicantSkills;
            ApplicantSkillCriteria applicantSkillCriteria;
            LikeRestrictionOfNullableOfInt32 applicantIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant skill objects to retrieve
            applicantIdRestriction = new LikeRestrictionOfNullableOfInt32();
            applicantIdRestriction.EqualValue = 1;
            applicantSkillCriteria = new ApplicantSkillCriteria();
            applicantSkillCriteria.ApplicantKeyId = applicantIdRestriction;

            // Retrieve the list of applicant skill objects
            applicantSkills = wsDynamicsGP.GetApplicantSkillList(applicantSkillCriteria, context);

            // Display the number of applicant skill objects matching the criteria
            MessageBox.Show("The number of job skills for the applicant: " +
                applicantSkills.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSkill[] applicantSkills;
            ApplicantSkillCriteria applicantSkillCriteria;
            LikeRestrictionOfNullableOfint applicantIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant skill objects to retrieve
            applicantIdRestriction = new LikeRestrictionOfNullableOfint();
            applicantIdRestriction.EqualValue = 1;
            applicantSkillCriteria = new ApplicantSkillCriteria();
            applicantSkillCriteria.ApplicantKeyId = applicantIdRestriction;

            // Retrieve the list of applicant skill objects
            applicantSkills = wsDynamicsGP.GetApplicantSkillList(applicantSkillCriteria, context);

            // Display the number of applicant skill objects matching the criteria
            MessageBox.Show("The number of job skills for the applicant: " +
                applicantSkills.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantTestByKey

Description

Retrieves a single applicant test object based on the key value supplied.

Parameters

Parameter | Type | Description
key | ApplicantTestKey | The applicant test key object that specifies the applicant test object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantTestByKeyResult | ApplicantTest | An applicant test object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant test object with the specified applicant test key. The notes for the specified applicant test object are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            TestKey testKey;
            ApplicantTest applicantTest;
            ApplicantTestKey applicantTestKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create a test key
            testKey = new TestKey();
            testKey.Id = "TEST1";

            // Create an applicant test key
            applicantTestKey = new ApplicantTestKey();
            applicantTestKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantTestKey.TestKey = testKey;

            // Retrieve the applicant test object
            applicantTest = wsDynamicsGP.GetApplicantTestByKey(applicantTestKey, context);

            // Display the notes property of the specified applicant test object
            MessageBox.Show(applicantTest.Notes);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            TestKey testKey;
            ApplicantTest applicantTest;
            ApplicantTestKey applicantTestKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create a test key
            testKey = new TestKey();
            testKey.Id = "TEST1";

            // Create an applicant test key
            applicantTestKey = new ApplicantTestKey();
            applicantTestKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantTestKey.TestKey = testKey;

            // Retrieve the applicant test object
            applicantTest = wsDynamicsGP.GetApplicantTestByKey(applicantTestKey, context);

            // Display the notes property of the specified applicant test object
            MessageBox.Show(applicantTest.Notes);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantTestList

Description

Retrieves a list of applicant test objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ApplicantTestCriteria | The applicant test criteria object that specifies which applicant test objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantTestListResult | ArrayOfApplicantTest | The list of applicant test objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of applicant test objects for the applicant with the Id of “1”. The total number of applicant tests is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantTest[] applicantTests;
            ApplicantTestCriteria applicantTestCriteria;
            LikeRestrictionOfNullableOfInt32 applicantIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant test objects to retrieve
            applicantIdRestriction = new LikeRestrictionOfNullableOfInt32();
            applicantIdRestriction.EqualValue = 1;
            applicantTestCriteria = new ApplicantTestCriteria();
            applicantTestCriteria.ApplicantKeyId = applicantIdRestriction;

            // Retrieve the list of applicant test objects
            applicantTests = wsDynamicsGP.GetApplicantTestList(applicantTestCriteria, context);

            // Display the number of applicant test objects matching the criteria
            MessageBox.Show("The number of job tests associated with the applicant: " +
                applicantTests.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantTest[] applicantTests;
            ApplicantTestCriteria applicantTestCriteria;
            LikeRestrictionOfNullableOfint applicantIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the applicant test objects to retrieve
            applicantIdRestriction = new LikeRestrictionOfNullableOfint();
            applicantIdRestriction.EqualValue = 1;
            applicantTestCriteria = new ApplicantTestCriteria();
            applicantTestCriteria.ApplicantKeyId = applicantIdRestriction;

            // Retrieve the list of applicant test objects
            applicantTests = wsDynamicsGP.GetApplicantTestList(applicantTestCriteria, context);

            // Display the number of applicant test objects matching the criteria
            MessageBox.Show("The number of job tests associated with the applicant: " +
                applicantTests.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantWorkHistoryByKey

Description

Retrieves a single applicant work history object based on the key value supplied.

Parameters

Parameter | Type | Description
key | ApplicantWorkHistoryKey | The applicant work history key object that specifies the applicant work history object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantWorkHistoryByKeyResult | ApplicantWorkHistory | An applicant work history object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant work history object with the specified applicant work history key. The years of experience for the specified applicant work history object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantWorkHistoryKey applicantWorkHistoryKey;
            ApplicantWorkHistory applicantWorkHistory;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant work history key
            applicantWorkHistoryKey = new ApplicantWorkHistoryKey();
            applicantWorkHistoryKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantWorkHistoryKey.Id  = "Previous employer";

            // Retrieve the applicant work history object
            applicantWorkHistory = wsDynamicsGP.GetApplicantWorkHistoryByKey(applicantWorkHistoryKey, context);

            // Display the notes property of the specified applicant work history object
            MessageBox.Show("Years of experience for the specified applicant: " +
                applicantWorkHistory.YearsOfExperience.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantWorkHistoryKey applicantWorkHistoryKey;
            ApplicantWorkHistory applicantWorkHistory;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant work history key
            applicantWorkHistoryKey = new ApplicantWorkHistoryKey();
            applicantWorkHistoryKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantWorkHistoryKey.Id  = "Previous employer";

            // Retrieve the applicant work history object
            applicantWorkHistory = wsDynamicsGP.GetApplicantWorkHistoryByKey(applicantWorkHistoryKey, context);

            // Display the notes property of the specified applicant work history object
            MessageBox.Show("Years of experience for the specified applicant: " +
                applicantWorkHistory.YearsOfExperience.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetApplicantWorkHistoryList

Description

Retrieves a list of applicant work history objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ApplicantWorkHistoryCriteria | The applicant work history criteria object that specifies which applicant work history objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetApplicantWorkHistoryListResult | ArrayOfApplicantWorkHistory | The list of applicant test objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of applicant work history objects where the employer value is “Previous employer”. The number of applicant work history objects that match the criteria is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantWorkHistory[] applicantWorkHistory;
            ApplicantWorkHistoryCriteria applicantWorkHistoryCriteria;
            LikeRestrictionOfString employerRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria of the applicant work history objects to retrieve
            employerRestriction = new LikeRestrictionOfString();
            employerRestriction.EqualValue = "Previous employer";
            applicantWorkHistoryCriteria = new ApplicantWorkHistoryCriteria();
            applicantWorkHistoryCriteria.Employer = employerRestriction;

            // Retrieve the list of applicant work history objects
            applicantWorkHistory = wsDynamicsGP.GetApplicantWorkHistoryList(applicantWorkHistoryCriteria, context);

            // Display the number of applicant work history objects that match the criteria
            MessageBox.Show("The number of applicants from the specified employer: " +
                applicantWorkHistory.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantWorkHistory[] applicantWorkHistory;
            ApplicantWorkHistoryCriteria applicantWorkHistoryCriteria;
            LikeRestrictionOfstring employerRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria of the applicant work history objects to retrieve
            employerRestriction = new LikeRestrictionOfstring();
            employerRestriction.EqualValue = "Previous employer";
            applicantWorkHistoryCriteria = new ApplicantWorkHistoryCriteria();
            applicantWorkHistoryCriteria.Employer = employerRestriction;

            // Retrieve the list of applicant work history objects
            applicantWorkHistory = wsDynamicsGP.GetApplicantWorkHistoryList(applicantWorkHistoryCriteria, context);

            // Display the number of applicant work history objects that match the criteria
            MessageBox.Show("The number of applicants from the specified employer: " +
                applicantWorkHistory.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBackOfficeRoleAssignmentList

Description

Retrieves a list of all of the back office role assignment objects. Each back office role assignment object represents a back office security role that a user in Microsoft Dynamics GP is assigned to.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBackOfficeRoleAssignmentListResult | ArrayOfBackOfficeRoleAssignment | A collection of back office role assignment objects.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example lists all of the users in Microsoft Dynamics GP and the back office security roles they are assigned to.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            BackOfficeRoleAssignment[] backOfficeRoleAssignments;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the back office role assignments
            backOfficeRoleAssignments = wsDynamicsGP.GetBackOfficeRoleAssignmentList(context);

            // Display the back office role assignments in the list
            StringBuilder roleList = new StringBuilder();
            foreach (BackOfficeRoleAssignment a in backOfficeRoleAssignments)
            {
                // Look up the role
                BackOfficeRoleKey roleKey = new BackOfficeRoleKey();
                roleKey.Id = a.Key.RoleKey.Id;
                BackOfficeRole backOfficeRole;
                backOfficeRole = wsDynamicsGP.GetBackOfficeRoleByKey(roleKey, context);

                // Add the user and role
                roleList.AppendLine(a.Key.UserKey.Id + "   " + backOfficeRole.Name);
            }
            MessageBox.Show(roleList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            BackOfficeRoleAssignment[] backOfficeRoleAssignments;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the back office role assignments
            backOfficeRoleAssignments = wsDynamicsGP.GetBackOfficeRoleAssignmentList(context);

            // Display the back office role assignments in the list
            StringBuilder roleList = new StringBuilder();
            foreach (BackOfficeRoleAssignment a in backOfficeRoleAssignments)
            {
                // Look up the role
                BackOfficeRoleKey roleKey = new BackOfficeRoleKey();
                roleKey.Id = a.Key.RoleKey.Id;
                BackOfficeRole backOfficeRole;
                backOfficeRole = wsDynamicsGP.GetBackOfficeRoleByKey(roleKey, context);

                // Add the user and role
                roleList.AppendLine(a.Key.UserKey.Id + "   " + backOfficeRole.Name);
            }
            MessageBox.Show(roleList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBackOfficeRoleByKey

Description

Retrieves a single back office security role based on the key value supplied.

Parameters

Parameter | Type | Description
backOfficeRoleKey | BackOfficeRoleKey | A back office role key object that specifies the back office security role to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBackOfficeRoleByKeyResult | BackOfficeRole | A back office role object representing a security role defined in Microsoft Dynamics GP.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the back office security role with the key value “BOOKKEEPER*”. The description of the security role is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            OrganizationKey organizationKey;
            Context context;
            BackOfficeRole backOfficeRole;
            BackOfficeRoleKey backOfficeRoleKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify the system database
            organizationKey = null;

            // Set up the context object
            context.OrganizationKey = organizationKey;

            // Create the back office role key
            backOfficeRoleKey = new BackOfficeRoleKey();
            backOfficeRoleKey.Id = "BOOKKEEPER*";

            // Retrieve the back office role
            backOfficeRole = wsDynamicsGP.GetBackOfficeRoleByKey(backOfficeRoleKey, context);

            // Display the description of the back office security role
            MessageBox.Show(backOfficeRole.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            OrganizationKey organizationKey;
            Context context;
            BackOfficeRole backOfficeRole;
            BackOfficeRoleKey backOfficeRoleKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify the system database
            organizationKey = null;

            // Set up the context object
            context.OrganizationKey = organizationKey;

            // Create the back office role key
            backOfficeRoleKey = new BackOfficeRoleKey();
            backOfficeRoleKey.Id = "BOOKKEEPER*";

            // Retrieve the back office role
            backOfficeRole = wsDynamicsGP.GetBackOfficeRoleByKey(backOfficeRoleKey, context);

            // Display the description of the back office security role
            MessageBox.Show(backOfficeRole.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBackOfficeRoleList

Description

Retrieves a list of all of the back office role objects representing each security role defined in Microsoft Dynamics GP.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBackOfficeRoleListResult | ArrayOfBackOfficeRole | A list of back office role objects representing each security role defined in Microsoft Dynamics GP.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of all security roles defined in Microsoft Dynamics GP and displays their names in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            OrganizationKey organizationKey;
            Context context;
            BackOfficeRole[] backOfficeRoles;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify the system database
            organizationKey = null;

            // Set up the context object
            context.OrganizationKey = organizationKey;

            // Retrieve the list of back office roles
            backOfficeRoles = wsDynamicsGP.GetBackOfficeRoleList(context);

            // Display the name of each security role in the list
            StringBuilder roleList = new StringBuilder();
            foreach (BackOfficeRole a in backOfficeRoles)
            {
                roleList.AppendLine(a.Name);
            }
            MessageBox.Show(roleList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            OrganizationKey organizationKey;
            Context context;
            BackOfficeRole[] backOfficeRoles;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify the system database
            organizationKey = null;

            // Set up the context object
            context.OrganizationKey = organizationKey;

            // Retrieve the list of back office roles
            backOfficeRoles = wsDynamicsGP.GetBackOfficeRoleList(context);

            // Display the name of each security role in the list
            StringBuilder roleList = new StringBuilder();
            foreach (BackOfficeRole a in backOfficeRoles)
            {
                roleList.AppendLine(a.Name);
            }
            MessageBox.Show(roleList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBankByKey

Description

Retrieves a single bank object based on the bank key value supplied.

Parameters

Parameter | Type | Description
key | BankKey | The bank key object that specifies the bank to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBankByKeyResult | Bank | A bank object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the bank object with the key value “TEST BANK”. This example requires a bank named “TEST BANK” to be manually created. A message box displays the bank name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BankKey bankKey;
            Bank bank;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a bank key object to specify the bank
            bankKey = new BankKey();
            bankKey.Id = "TEST BANK";

            // Retrieve the bank object
            bank = wsDynamicsGP.GetBankByKey(bankKey, context);

            // Display the name property from the bank object
            MessageBox.Show("Bank name: " + bank.Name);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BankKey bankKey;
            Bank bank;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a bank key object to specify the bank
            bankKey = new BankKey();
            bankKey.Id = "TEST BANK";

            // Retrieve the bank object
            bank = wsDynamicsGP.GetBankByKey(bankKey, context);

            // Display the name property from the bank object
            MessageBox.Show("Bank name: " + bank.Name);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBankList

Description

Retrieves a list of bank objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | BankCriteria | The bank criteria object that specifies which bank objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBankListResult | ArrayOfBank | The list of bank objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of all bank objects. A message box displays the name and the transit number of each bank in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString bankNameRestriction;
            BankCriteria bankCriteria;
            Bank[] bankList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all available bank objects
            bankNameRestriction = new LikeRestrictionOfString();
            bankNameRestriction.Like = "%";

            // Create the bank criteria object
            bankCriteria = new BankCriteria();
            bankCriteria.Name = bankNameRestriction;

            // Retrieve the list of bank objects
            bankList = wsDynamicsGP.GetBankList(bankCriteria, context);

            // Display the ID and amount of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (Bank a in bankList)
            {
                summaryList.AppendLine("Bank name: " + a.Name + "  Transit number: " +
                a.TransitNumber);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring bankNameRestriction;
            BankCriteria bankCriteria;
            Bank[] bankList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all available bank objects
            bankNameRestriction = new LikeRestrictionOfstring();
            bankNameRestriction.Like = "%";

            // Create the bank criteria object
            bankCriteria = new BankCriteria();
            bankCriteria.Name = bankNameRestriction;

            // Retrieve the list of bank objects
            bankList = wsDynamicsGP.GetBankList(bankCriteria, context);

            // Display the ID and amount of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (Bank a in bankList)
            {
                summaryList.AppendLine("Bank name: " + a.Name + "  Transit number: " +
                a.TransitNumber);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBatchByKey

Description

Retrieves a single batch object based on the batch key value supplied.

Parameters

Parameter | Type | Description
key | BatchKey | The batch key object that specifies the batch to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBatchByKeyResult | Batch | A batch object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a batch object with the batch key ID of “GL BATCH”, a batch key source of “GL_Normal” and a batch key created date of “5/9/2007”. A message box displays the batch name and it total.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DateTime createDate;
            BatchKey batchKey;
            Batch batch;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a date time object to specify the batch create date
            createDate = new DateTime(2007,5, 9);

            // Create the batch key object
            batchKey = new BatchKey();
            batchKey.Id = "GL BATCH";
            batchKey.Source = "GL_Normal";
            batchKey.CreatedDateTime = createDate;

            // Retrieve the specified batch
            batch = wsDynamicsGP.GetBatchByKey(batchKey, context);

            // Display the batch name and its total
            MessageBox.Show("Batch name: " + batch.Key.Id + "  Total: " + batch.Total.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DateTime createDate;
            BatchKey batchKey;
            Batch batch;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a date time object to specify the batch create date
            createDate = new DateTime(2007,5, 9);

            // Create the batch key object
            batchKey = new BatchKey();
            batchKey.Id = "GL BATCH";
            batchKey.Source = "GL_Normal";
            batchKey.CreatedDateTime = createDate;

            // Retrieve the specified batch
            batch = wsDynamicsGP.GetBatchByKey(batchKey, context);

            // Display the batch name and its total
            MessageBox.Show("Batch name: " + batch.Key.Id + "  Total: " + batch.Total.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBatchList

Description

Retrieves a list of batch objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | BatchCriteria | The batch criteria object that specifies which batch objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBatchListResult | ArrayOfBatch | The list of batch objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of batch objects with an ID property that begins with “P”. A message box displays the batch name and frequency for each batch in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString batchIdRestriction;
            BatchCriteria batchCriteria;
            Batch[] batchList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Specify batch objects where the ID property begins with 'P'
            batchIdRestriction = new LikeRestrictionOfString();
            batchIdRestriction.Like = "P%";

            // Create the batch criteria object
            batchCriteria = new BatchCriteria();
            batchCriteria.Id = batchIdRestriction;

            // Retrieve the list of batch objects
            batchList = wsDynamicsGP.GetBatchList(batchCriteria, context); ;

            // Display the batch name and frequency for each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (Batch a in batchList)
            {
                summaryList.AppendLine("Batch: " + a.Key.Id + "  Frequency: " + a.Frequency.ToString());
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring batchIdRestriction;
            BatchCriteria batchCriteria;
            Batch[] batchList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Specify batch objects where the ID property begins with 'P'
            batchIdRestriction = new LikeRestrictionOfstring();
            batchIdRestriction.Like = "P%";

            // Create the batch criteria object
            batchCriteria = new BatchCriteria();
            batchCriteria.Id = batchIdRestriction;

            // Retrieve the list of batch objects
            batchList = wsDynamicsGP.GetBatchList(batchCriteria, context); ;

            // Display the batch name and frequency for each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (Batch a in batchList)
            {
                summaryList.AppendLine("Batch: " + a.Key.Id + "  Frequency: " + a.Frequency.ToString());
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBusinessObjectSummaryList

Description

Retrieves a list of business object summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
businessObjectTypeId | guid | Specifies the type of business object to be retrieved. Use the method GetUserAssignableBusinessObjectList to retrieve the list of available objects.
organizationKey | OrganizationKey | Specifies where the business object information should be retrieved from, such as a specific company.
criteria | BusinessObjectSummaryCriteria | The business object summary criteria object that specifies which business object summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBusinessObjectSummaryListResult | ArrayOfBusinessObjectSummary | The list of business object summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a list of business object summary objects for each customer defined in the sample company. Notice how the GetUserAssignableBusinessObjectList method is used to retrieve the list of available business objects so the businessObjectTypeId can be set.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CompanyKey companyKey;
            Guid BusinessObjectType = new Guid();
            UserAssignableBusinessObject[] userAssignableBusinessObjects;
            BusinessObjectSummary[] businessObjectSummaryList;
            BusinessObjectSummaryCriteria businessObjectSummaryCriteria;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the list of user-assignable business objects
            userAssignableBusinessObjects = wsDynamicsGP.GetUserAssignableBusinessObjectList(context);

            // Find the type for Customer
            foreach (UserAssignableBusinessObject u in userAssignableBusinessObjects)
            {
                if (u.BusinessObjectTypeDisplayName == "Customer")
                {
                    BusinessObjectType = u.BusinessObjectTypeId;
                    break;
                }
            }

            // Search for customers in the sample company
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Update the context object for the call
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the criteria to search -- No restrictions
            businessObjectSummaryCriteria = new BusinessObjectSummaryCriteria();

            // Get the list of business object summaries of the specified type
            businessObjectSummaryList = wsDynamicsGP.GetBusinessObjectSummaryList(BusinessObjectType,
            companyKey, businessObjectSummaryCriteria, context);

            // Display the details of the business object summaries in the list
            StringBuilder businessObjectList = new StringBuilder();
            foreach (BusinessObjectSummary b in businessObjectSummaryList)
            {
                // Build the string to display
                businessObjectList.AppendLine(b.DisplayName + "  " + b.DisplayId);
            }
            MessageBox.Show(businessObjectList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CompanyKey companyKey;
            Guid BusinessObjectType = new Guid();
            UserAssignableBusinessObject[] userAssignableBusinessObjects;
            BusinessObjectSummary[] businessObjectSummaryList;
            BusinessObjectSummaryCriteria businessObjectSummaryCriteria;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the list of user-assignable business objects
            userAssignableBusinessObjects = wsDynamicsGP.GetUserAssignableBusinessObjectList(context);

            // Find the type for Customer
            foreach (UserAssignableBusinessObject u in userAssignableBusinessObjects)
            {
                if (u.BusinessObjectTypeDisplayName == "Customer")
                {
                    BusinessObjectType = u.BusinessObjectTypeId;
                    break;
                }
            }

            // Search for customers in the sample company
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Update the context object for the call
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the criteria to search -- No restrictions
            businessObjectSummaryCriteria = new BusinessObjectSummaryCriteria();

            // Get the list of business object summaries of the specified type
            businessObjectSummaryList = wsDynamicsGP.GetBusinessObjectSummaryList(BusinessObjectType,
            companyKey, businessObjectSummaryCriteria, context);

            // Display the details of the business object summaries in the list
            StringBuilder businessObjectList = new StringBuilder();
            foreach (BusinessObjectSummary b in businessObjectSummaryList)
            {
                // Build the string to display
                businessObjectList.AppendLine(b.DisplayName + "  " + b.DisplayId);
            }
            MessageBox.Show(businessObjectList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetBusinessObjectUserAssignmentList

Description

Retrieves a list of all the business object user assignment objects. Each business object user assignment represents a Windows User ID that is mapped to an ID in Microsoft Dynamics GP.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetBusinessObjectUserAssignmentListResult | ArrayOfBusinessObjectUserAssignment | A list of business object user assignment objects.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves all of the business object user assignments and displays the details of each in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            string objectTypeName;
            Company company;
            UserAssignableBusinessObject[] userAssignableBusinessObjects;
            BusinessObjectUserAssignment[] businessObjectUserAssignments;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the list of user-assignable business objects
            userAssignableBusinessObjects = wsDynamicsGP.GetUserAssignableBusinessObjectList(context);

            // Retrieve the business object user assignment objects
            businessObjectUserAssignments = wsDynamicsGP.GetBusinessObjectUserAssignmentList(context);

            // Display the business object user assignments in the list
            StringBuilder assignmentList = new StringBuilder();
            foreach (BusinessObjectUserAssignment a in businessObjectUserAssignments)
            {
                // Look up the object type
                objectTypeName = "";
                foreach (UserAssignableBusinessObject u in userAssignableBusinessObjects)
                {
                    if (a.BusinessObjectTypeId == u.BusinessObjectTypeId)
                    {
                        objectTypeName = u.BusinessObjectTypeDisplayName;
                    }
                }

                // Look up the company
                company = wsDynamicsGP.GetCompanyByKey((CompanyKey)a.OrganizationKey, context);

                // Build the string to display
                assignmentList.AppendLine("Windows user: " + a.User + "  Object type:" + objectTypeName +
                "  ID:" + a.BusinessObjectKey + "  Company:" + company.Name);
            }
            MessageBox.Show(assignmentList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            string objectTypeName;
            Company company;
            UserAssignableBusinessObject[] userAssignableBusinessObjects;
            BusinessObjectUserAssignment[] businessObjectUserAssignments;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the list of user-assignable business objects
            userAssignableBusinessObjects = wsDynamicsGP.GetUserAssignableBusinessObjectList(context);

            // Retrieve the business object user assignment objects
            businessObjectUserAssignments = wsDynamicsGP.GetBusinessObjectUserAssignmentList(context);

            // Display the business object user assignments in the list
            StringBuilder assignmentList = new StringBuilder();
            foreach (BusinessObjectUserAssignment a in businessObjectUserAssignments)
            {
                // Look up the object type
                objectTypeName = "";
                foreach (UserAssignableBusinessObject u in userAssignableBusinessObjects)
                {
                    if (a.BusinessObjectTypeId == u.BusinessObjectTypeId)
                    {
                        objectTypeName = u.BusinessObjectTypeDisplayName;
                    }
                }

                // Look up the company
                company = wsDynamicsGP.GetCompanyByKey((CompanyKey)a.OrganizationKey, context);

                // Build the string to display
                assignmentList.AppendLine("Windows user: " + a.User + "  Object type:" + objectTypeName +
                "  ID:" + a.BusinessObjectKey + "  Company:" + company.Name);
            }
            MessageBox.Show(assignmentList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCashReceiptByKey

Description

Retrieves a single cash receipt object based on the receivables document key value supplied.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | The receivables document key object that specifies the cash receipt to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCashReceiptByKeyResult | CashReceipt | A cash receipt object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the cash receipt object with the key value “PYMNT000000000265”. A message box displays the customer ID and the amount of the cash receipt.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey cashReceiptKey;
            CashReceipt cashReceipt;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key to specify the cash receipt
            cashReceiptKey = new ReceivablesDocumentKey();
            cashReceiptKey.Id = "PYMNT000000000265";

            // Retrieve the cash receipt object
            cashReceipt = wsDynamicsGP.GetCashReceiptByKey(cashReceiptKey, context);

            // Display the customer and cash amount
            MessageBox.Show("Customer: " + cashReceipt.CustomerKey.Id + "  Amount: "
            + cashReceipt.Amount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey cashReceiptKey;
            CashReceipt cashReceipt;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key to specify the cash receipt
            cashReceiptKey = new ReceivablesDocumentKey();
            cashReceiptKey.Id = "PYMNT000000000265";

            // Retrieve the cash receipt object
            cashReceipt = wsDynamicsGP.GetCashReceiptByKey(cashReceiptKey, context);

            // Display the customer and cash amount
            MessageBox.Show("Customer: " + cashReceipt.CustomerKey.Id + "  Amount: "
            + cashReceipt.Amount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCashReceiptList

Description

Retrieves a list of cash receipt summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CashReceiptCriteria | The cash receipt criteria object that specifies which cash receipt summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCashReceiptListResult | ArrayOfCashReceiptSummary | The list of cash receipt summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of cash receipt summary objects for the customer with the ID “AARONFIT0001”. A second restriction is used to only retrieve the customer’s cash receipt documents with a transaction state of “Work”. A message box displays the Date and Amount from each cash receipt summary that was returned.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString customerIdRestriction;
            ListRestrictionOfNullableOfReceivablesTransactionState transactionStateRestriction;
            CashReceiptCriteria cashReceiptCriteria;
            CashReceiptSummary[] cashReceiptSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction objects
            // Retrieve cash receipts for customer with customer ID of 'AARONFIT0001'
            customerIdRestriction = new LikeRestrictionOfString();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Only retrieve cash receipts with a transaction state of 'Work'
            transactionStateRestriction = new ListRestrictionOfNullableOfReceivablesTransactionState();
            transactionStateRestriction.EqualValue = ReceivablesTransactionState.Work;

            // Create the cash receipt criteria object
            cashReceiptCriteria = new CashReceiptCriteria();
            cashReceiptCriteria.CustomerId = customerIdRestriction;
            cashReceiptCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of cash receipt summary objects
            cashReceiptSummaries = wsDynamicsGP.GetCashReceiptList(cashReceiptCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (CashReceiptSummary a in cashReceiptSummaries)
            {
                summaryList.AppendLine("Date: " + a.Date.Value.ToShortDateString()
                + "  Cash amount: " + a.Amount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring customerIdRestriction;
            ListRestrictionOfNullableOfReceivablesTransactionState transactionStateRestriction;
            CashReceiptCriteria cashReceiptCriteria;
            CashReceiptSummary[] cashReceiptSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction objects
            // Retrieve cash receipts for customer with customer ID of 'AARONFIT0001'
            customerIdRestriction = new LikeRestrictionOfstring();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Only retrieve cash receipts with a transaction state of 'Work'
            transactionStateRestriction = new ListRestrictionOfNullableOfReceivablesTransactionState();
            transactionStateRestriction.EqualValue = ReceivablesTransactionState.Work;

            // Create the cash receipt criteria object
            cashReceiptCriteria = new CashReceiptCriteria();
            cashReceiptCriteria.CustomerId = customerIdRestriction;
            cashReceiptCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of cash receipt summary objects
            cashReceiptSummaries = wsDynamicsGP.GetCashReceiptList(cashReceiptCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (CashReceiptSummary a in cashReceiptSummaries)
            {
                summaryList.AppendLine("Date: " + a.Date.Value.ToShortDateString()
                + "  Cash amount: " + a.Amount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedCurrencyKeyList

Description

Retrieves a list of changed currency key objects for the currencies that have been acted on during the specified interval. A currency has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | CurrencyChangedKeyCriteria | The currency changed key criteria object that specifies which changed currency key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedCurrencyKeyListResult | ArrayOfChangedCurrencyKey | The list of changed currency key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed currency key objects that have been acted on during the last week. A message box displays the number of each type of action that was performed.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CurrencyChangedKeyCriteria currencyCriteria;
            ChangedCurrencyKey[] changedCurrencyKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return currency objects that changed
            currencyCriteria = new CurrencyChangedKeyCriteria();
            currencyCriteria.LastModifiedDate = restriction;

            // Retrieve the changed currency key objects
            changedCurrencyKeyObjects = wsDynamicsGP.GetChangedCurrencyKeyList(currencyCriteria, context);

            // Display the numbers for currencies that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedCurrencyKey key in changedCurrencyKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Currency changes: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CurrencyChangedKeyCriteria currencyCriteria;
            ChangedCurrencyKey[] changedCurrencyKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return currency objects that changed
            currencyCriteria = new CurrencyChangedKeyCriteria();
            currencyCriteria.LastModifiedDate = restriction;

            // Retrieve the changed currency key objects
            changedCurrencyKeyObjects = wsDynamicsGP.GetChangedCurrencyKeyList(currencyCriteria, context);

            // Display the numbers for currencies that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedCurrencyKey key in changedCurrencyKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Currency changes: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedCustomerAddressKeyList

Description

Retrieves a list of changed customer address key objects for the customer addresses that have been acted on during the specified interval. A customer address has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | CustomerAddressChangedKeyCriteria | The customer address changed key criteria object that specifies which changed customer address key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedCustomerAddressKeyListResult | ArrayOfChangedCustomerAddressKey | The list of changed customer address key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed customer address key objects that have been acted on during the last week. The list is restricted to customer AARONFIT0001. A message box displays the number of each type of address action that was performed.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerAddressChangedKeyCriteria customerAddressCriteria;
            ChangedCustomerAddressKey[] changedCustomerAddressKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;
            BetweenRestrictionOfString customerRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Restrict to just the customer AARONFIT0001
            customerRestriction = new BetweenRestrictionOfString();
            customerRestriction.EqualValue = "AARONFIT0001";

            // Create the criteria to return customer address objects that changed
            customerAddressCriteria = new CustomerAddressChangedKeyCriteria();
            customerAddressCriteria.LastModifiedDate = restriction;
            customerAddressCriteria.CustomerKeyId = customerRestriction;

            // Retrieve the changed customer address key objects
            changedCustomerAddressKeyObjects = wsDynamicsGP.GetChangedCustomerAddressKeyList(customerAddressCriteria, context);

            // Display the numbers of customer addresses that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedCustomerAddressKey key in changedCustomerAddressKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Customer address changes: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerAddressChangedKeyCriteria customerAddressCriteria;
            ChangedCustomerAddressKey[] changedCustomerAddressKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;
            BetweenRestrictionOfstring customerRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Restrict to just the customer AARONFIT0001
            customerRestriction = new BetweenRestrictionOfstring();
            customerRestriction.EqualValue = "AARONFIT0001";

            // Create the criteria to return customer address objects that changed
            customerAddressCriteria = new CustomerAddressChangedKeyCriteria();
            customerAddressCriteria.LastModifiedDate = restriction;
            customerAddressCriteria.CustomerKeyId = customerRestriction;

            // Retrieve the changed customer address key objects
            changedCustomerAddressKeyObjects = wsDynamicsGP.GetChangedCustomerAddressKeyList(customerAddressCriteria, context);

            // Display the numbers of customer addresses that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedCustomerAddressKey key in changedCustomerAddressKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Customer address changes: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedCustomerKeyList

Description

Retrieves a list of changed customer key objects for the customers that have been acted on during the specified interval. A customer has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | CustomerChangedKeyCriteria | The customer changed key criteria object that specifies which changed customer key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedCustomerKeyListResult | ArrayOfChangedCustomerKey | The list of changed customer key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed customer key objects for all of the customers that have been acted on during the current day. Because no additional restriction was added, all of the create, update, and delete actions are included. A message box displays the number of customers that were acted on.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerChangedKeyCriteria customerCriteria;
            ChangedCustomerKey[] changedCustomerKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes all of today
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date;
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return changed customer objects
            customerCriteria = new CustomerChangedKeyCriteria();
            customerCriteria.LastModifiedDate = restriction;

            // Retrieve the changed customer key objects
            changedCustomerKeyObjects = wsDynamicsGP.GetChangedCustomerKeyList(customerCriteria, context);

            // Display the number of customer objects that changed
            MessageBox.Show("Changed customer objects: " + changedCustomerKeyObjects.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerChangedKeyCriteria customerCriteria;
            ChangedCustomerKey[] changedCustomerKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes all of today
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date;
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return changed customer objects
            customerCriteria = new CustomerChangedKeyCriteria();
            customerCriteria.LastModifiedDate = restriction;

            // Retrieve the changed customer key objects
            changedCustomerKeyObjects = wsDynamicsGP.GetChangedCustomerKeyList(customerCriteria, context);

            // Display the number of customer objects that changed
            MessageBox.Show("Changed customer objects: " + changedCustomerKeyObjects.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedInternetAddressKeyList

Description

Retrieves a list of changed Internet address key objects for the Internet addresses that have been acted on during the specified interval. An Internet address has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | InternetAddressKeyChangedCriteria | The Internet address key changed criteria object that specifies which changed Internet address key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedInternetAddressKeyListResult | ArrayOfChangedInternetAddressKey | The list of changed Internet address key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed Internet address key objects that have been acted on during the last week. The list is restricted to Internet addresses for customers. A message box displays the number of each type of Internet address action that was performed.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            InternetAddressKeyChangedCriteria internetAddressCriteria;
            ChangedInternetAddressKey[] changedInternetAddressKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;
            BetweenRestrictionOfString addressTypeRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Restrict to just the customers that had Internet address actions
            addressTypeRestriction = new BetweenRestrictionOfString();
            addressTypeRestriction.EqualValue = "CUS";

            // Create the criteria to return Internet address objects that changed
            internetAddressCriteria = new InternetAddressKeyChangedCriteria();
            internetAddressCriteria.LastModifiedDate = restriction;
            internetAddressCriteria.InternetAddressType = addressTypeRestriction;

            // Retrieve the changed Internet Address key objects
            changedInternetAddressKeyObjects = wsDynamicsGP.GetChangedInternetAddressKeyList(internetAddressCriteria, context);

            // Display the numbers of Internet addresses that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedInternetAddressKey key in changedInternetAddressKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Internet address changes: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            InternetAddressKeyChangedCriteria internetAddressCriteria;
            ChangedInternetAddressKey[] changedInternetAddressKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;
            BetweenRestrictionOfstring addressTypeRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Restrict to just the customers that had Internet address actions
            addressTypeRestriction = new BetweenRestrictionOfstring();
            addressTypeRestriction.EqualValue = "CUS";

            // Create the criteria to return Internet address objects that changed
            internetAddressCriteria = new InternetAddressKeyChangedCriteria();
            internetAddressCriteria.LastModifiedDate = restriction;
            internetAddressCriteria.InternetAddressType = addressTypeRestriction;

            // Retrieve the changed Internet Address key objects
            changedInternetAddressKeyObjects = wsDynamicsGP.GetChangedInternetAddressKeyList(internetAddressCriteria, context);

            // Display the numbers of Internet addresses that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedInternetAddressKey key in changedInternetAddressKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Internet address changes: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedItemKeyList

Description

Retrieves a list of changed item key objects for the items that have been acted on during the specified interval. An item has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | ItemChangedKeyCriteria | The item changed key criteria object that specifies which changed item key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedItemKeyListResult | ArrayOfChangedItemKey | The list of changed item key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed item key objects for all of the items that have been acted on during the previous week. The ID value of the item is used to retrieve the item object. Details about each item are displayed in the console window.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemChangedKeyCriteria itemCriteria;
            ChangedItemKey[] changedItemKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;
            ItemKey itemKey;
            Item item;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return item objects that changed
            itemCriteria = new ItemChangedKeyCriteria();
            itemCriteria.LastModifiedDate = restriction;

            // Retrieve the changed item key objects
            changedItemKeyObjects = wsDynamicsGP.GetChangedItemKeyList(itemCriteria, context);

            // Display the details about each item that acted on this week
            foreach (ChangedItemKey key in changedItemKeyObjects)
            {
                // Display the key
                Console.WriteLine("Item key: " + key.Id);

                // Display what the object knows about its changes
                Console.WriteLine("Last Modified Date: " + key.LastModifiedDate.ToString());

                // Get the item
                itemKey = new ItemKey();
                itemKey.Id = key.Id;
                item = wsDynamicsGP.GetItemByKey(itemKey, context);

                // Display the item description
                Console.WriteLine("Description: " + item.Description);

                // Display the operation performed
                if (key.Action == DataModificationAction.Created)
                    Console.WriteLine("Action: Created");
                if (key.Action == DataModificationAction.Updated)
                    Console.WriteLine("Action: Updated");
                if (key.Action == DataModificationAction.Deleted)
                    Console.WriteLine("Action: Deleted");

                Console.WriteLine();
            }
            Console.WriteLine("Press 'Enter' to continue...");
            Console.ReadLine();
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemChangedKeyCriteria itemCriteria;
            ChangedItemKey[] changedItemKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;
            ItemKey itemKey;
            Item item;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return item objects that changed
            itemCriteria = new ItemChangedKeyCriteria();
            itemCriteria.LastModifiedDate = restriction;

            // Retrieve the changed item key objects
            changedItemKeyObjects = wsDynamicsGP.GetChangedItemKeyList(itemCriteria, context);

            // Display the details about each item that acted on this week
            foreach (ChangedItemKey key in changedItemKeyObjects)
            {
                // Display the key
                Console.WriteLine("Item key: " + key.Id);

                // Display what the object knows about its changes
                Console.WriteLine("Last Modified Date: " + key.LastModifiedDate.ToString());

                // Get the item
                itemKey = new ItemKey();
                itemKey.Id = key.Id;
                item = wsDynamicsGP.GetItemByKey(itemKey, context);

                // Display the item description
                Console.WriteLine("Description: " + item.Description);

                // Display the operation performed
                if (key.Action == DataModificationAction.Created)
                    Console.WriteLine("Action: Created");
                if (key.Action == DataModificationAction.Updated)
                    Console.WriteLine("Action: Updated");
                if (key.Action == DataModificationAction.Deleted)
                    Console.WriteLine("Action: Deleted");

                Console.WriteLine();
            }
            Console.WriteLine("Press 'Enter' to continue...");
            Console.ReadLine();

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedPriceLevelKeyList

Description

Retrieves a list of changed price level key objects for the price levels that have been acted on during the specified interval. A price level has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | PriceLevelChangedKeyCriteria | The price level changed key criteria object that specifies which changed price level key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedPriceLevelKeyListResult | ArrayOfChangedPriceLevelKey | The list of changed price level key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed price level key objects for all of the price levels that have been acted on during the current day. The data modification action restriction is used so that only update actions are included in the list returned. A message box displays the number of price levels that were updated.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PriceLevelChangedKeyCriteria priceLevelCriteria;
            ChangedPriceLevelKey[] changedPriceLevelKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;
            RestrictionOfDataModificationAction dataModificationRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes all of today
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date;
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the restriction so only updated price levels are returned
            dataModificationRestriction = new RestrictionOfDataModificationAction();
            dataModificationRestriction.EqualValue = DataModificationAction.Updated;

            // Create the criteria to return price level objects that were updated
            priceLevelCriteria = new PriceLevelChangedKeyCriteria();
            priceLevelCriteria.LastModifiedDate = restriction;
            priceLevelCriteria.Action = dataModificationRestriction;

            // Retrieve the changed price level key objects
            changedPriceLevelKeyObjects = wsDynamicsGP.GetChangedPriceLevelKeyList(priceLevelCriteria, context);

            // Display the number of price level objects that were updated today
            MessageBox.Show("Updated price level objects: " + changedPriceLevelKeyObjects.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PriceLevelChangedKeyCriteria priceLevelCriteria;
            ChangedPriceLevelKey[] changedPriceLevelKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;
            RestrictionOfDataModificationAction dataModificationRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes all of today
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date;
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the restriction so only updated price levels are returned
            dataModificationRestriction = new RestrictionOfDataModificationAction();
            dataModificationRestriction.EqualValue = DataModificationAction.Updated;

            // Create the criteria to return price level objects that were updated
            priceLevelCriteria = new PriceLevelChangedKeyCriteria();
            priceLevelCriteria.LastModifiedDate = restriction;
            priceLevelCriteria.Action = dataModificationRestriction;

            // Retrieve the changed price level key objects
            changedPriceLevelKeyObjects = wsDynamicsGP.GetChangedPriceLevelKeyList(priceLevelCriteria, context);

            // Display the number of price level objects that were updated today
            MessageBox.Show("Updated price level objects: " + changedPriceLevelKeyObjects.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedPricingKeyList

Description

Retrieves a list of changed pricing key objects for the pricing objects that have been acted on during the specified interval. A pricing object has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | PricingChangedKeyCriteria | The pricing changed key criteria object that specifies which changed pricing key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedPricingKeyListResult | ArrayOfChangedPricingKey | The list of changed pricing key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed pricing key objects for all of the pricing actions that have occurred over the last week for the inventory item 1-A3261A. A message box displays the number of actions of each type that were performed.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PricingChangedKeyCriteria pricingCriteria;
            ChangedPricingKey[] changedPricingKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;
            BetweenRestrictionOfString itemRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Restrict the pricing to a single item
            itemRestriction = new BetweenRestrictionOfString();
            itemRestriction.EqualValue = "1-A3261A";

            // Create the criteria to return pricing objects that changed
            pricingCriteria = new PricingChangedKeyCriteria();
            pricingCriteria.LastModifiedDate = restriction;
            pricingCriteria.ItemKeyId = itemRestriction;

            // Retrieve the changed pricing key objects
            changedPricingKeyObjects = wsDynamicsGP.GetChangedPricingKeyList(pricingCriteria, context);

            // Display the numbers of sales orders that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedPricingKey key in changedPricingKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Pricing changes for 1-A3261A: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PricingChangedKeyCriteria pricingCriteria;
            ChangedPricingKey[] changedPricingKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;
            BetweenRestrictionOfstring itemRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Restrict the pricing to a single item
            itemRestriction = new BetweenRestrictionOfstring();
            itemRestriction.EqualValue = "1-A3261A";

            // Create the criteria to return pricing objects that changed
            pricingCriteria = new PricingChangedKeyCriteria();
            pricingCriteria.LastModifiedDate = restriction;
            pricingCriteria.ItemKeyId = itemRestriction;

            // Retrieve the changed pricing key objects
            changedPricingKeyObjects = wsDynamicsGP.GetChangedPricingKeyList(pricingCriteria, context);

            // Display the numbers of sales orders that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedPricingKey key in changedPricingKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Pricing changes for 1-A3261A: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedSalesInvoiceKeyList

Description

Retrieves a list of changed sales invoice key objects for the sales invoices that have been acted on during the specified interval. A sales invoice has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | SalesInvoiceChangedKeyCriteria | The sales invoice changed key criteria object that specifies which changed sales invoice key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedSalesInvoiceKeyListResult | ArrayOfChangedSalesInvoiceKey | The list of changed sales invoice key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed sales invoice key objects for all of the sales invoices that were created, updated, or deleted over the last week. A message box displays the number of sales invoices that had each action type performed on them.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesInvoiceChangedKeyCriteria salesInvoiceCriteria;
            ChangedSalesInvoiceKey[] changedSalesInvoiceKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return sales invoice objects that changed
            salesInvoiceCriteria = new SalesInvoiceChangedKeyCriteria();
            salesInvoiceCriteria.LastModifiedDate = restriction;

            // Retrieve the changed sales invoice key objects
            changedSalesInvoiceKeyObjects = wsDynamicsGP.GetChangedSalesInvoiceKeyList(salesInvoiceCriteria, context);

            // Display the numbers of sales invoices that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedSalesInvoiceKey key in changedSalesInvoiceKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Sales invoices: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesInvoiceChangedKeyCriteria salesInvoiceCriteria;
            ChangedSalesInvoiceKey[] changedSalesInvoiceKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return sales invoice objects that changed
            salesInvoiceCriteria = new SalesInvoiceChangedKeyCriteria();
            salesInvoiceCriteria.LastModifiedDate = restriction;

            // Retrieve the changed sales invoice key objects
            changedSalesInvoiceKeyObjects = wsDynamicsGP.GetChangedSalesInvoiceKeyList(salesInvoiceCriteria, context);

            // Display the numbers of sales invoices that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedSalesInvoiceKey key in changedSalesInvoiceKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Sales invoices: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedSalesOrderKeyList

Description

Retrieves a list of changed sales order key objects for the sales orders that have been acted on during the specified interval. A sales order has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | SalesOrderChangedKeyCriteria | The sales order changed key criteria object that specifies which changed sales order key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedSalesOrderKeyListResult | ArrayOfChangedSalesOrderKey | The list of changed sales order key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed sales order key objects for all of the sales orders that were created, updated, or deleted over the last week. A message box displays the number of sales orders that had each action type performed on them.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesOrderChangedKeyCriteria salesOrderCriteria;
            ChangedSalesOrderKey[] changedSalesOrderKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return sales order objects that changed
            salesOrderCriteria = new SalesOrderChangedKeyCriteria();
            salesOrderCriteria.LastModifiedDate = restriction;

            // Retrieve the changed sales order key objects
            changedSalesOrderKeyObjects = wsDynamicsGP.GetChangedSalesOrderKeyList(salesOrderCriteria, context);

            // Display the numbers of sales orders that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedSalesOrderKey key in changedSalesOrderKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Sales orders: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesOrderChangedKeyCriteria salesOrderCriteria;
            ChangedSalesOrderKey[] changedSalesOrderKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return sales order objects that changed
            salesOrderCriteria = new SalesOrderChangedKeyCriteria();
            salesOrderCriteria.LastModifiedDate = restriction;

            // Retrieve the changed sales order key objects
            changedSalesOrderKeyObjects = wsDynamicsGP.GetChangedSalesOrderKeyList(salesOrderCriteria, context);

            // Display the numbers of sales orders that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedSalesOrderKey key in changedSalesOrderKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Sales orders: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedSalespersonKeyList

Description

Retrieves a list of changed salesperson key objects for the salespersons that have been acted on during the specified interval. A salesperson has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | SalespersonChangedKeyCriteria | The salesperson changed key criteria object that specifies which changed salesperson key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedSalespersonKeyListResult | ArrayOfChangedSalespersonKey | The list of changed salesperson key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed salesperson key objects for all of the salespersons that were created during the current day. The data modification action restriction is used so that only create actions are included in the list returned. A message box displays the number of salespersons that were created.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalespersonChangedKeyCriteria salespersonCriteria;
            ChangedSalespersonKey[] changedSalespersonKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;
            RestrictionOfDataModificationAction dataModificationRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes all of today
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date;
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the restriction so only created salespeople are returned
            dataModificationRestriction = new RestrictionOfDataModificationAction();
            dataModificationRestriction.EqualValue = DataModificationAction.Created;

            // Create the criteria to return salesperson objects that were created
            salespersonCriteria = new SalespersonChangedKeyCriteria();
            salespersonCriteria.LastModifiedDate = restriction;
            salespersonCriteria.Action = dataModificationRestriction;

            // Retrieve the created salesperson key objects
            changedSalespersonKeyObjects = wsDynamicsGP.GetChangedSalespersonKeyList(salespersonCriteria, context);

            // Display the number of salesperson objects that were created today
            MessageBox.Show("Created salesperson objects: " + changedSalespersonKeyObjects.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalespersonChangedKeyCriteria salespersonCriteria;
            ChangedSalespersonKey[] changedSalespersonKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;
            RestrictionOfDataModificationAction dataModificationRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes all of today
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date;
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the restriction so only created salespeople are returned
            dataModificationRestriction = new RestrictionOfDataModificationAction();
            dataModificationRestriction.EqualValue = DataModificationAction.Created;

            // Create the criteria to return salesperson objects that were created
            salespersonCriteria = new SalespersonChangedKeyCriteria();
            salespersonCriteria.LastModifiedDate = restriction;
            salespersonCriteria.Action = dataModificationRestriction;

            // Retrieve the created salesperson key objects
            changedSalespersonKeyObjects = wsDynamicsGP.GetChangedSalespersonKeyList(salespersonCriteria, context);

            // Display the number of salesperson objects that were created today
            MessageBox.Show("Created salesperson objects: " + changedSalespersonKeyObjects.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedShippingMethodKeyList

Description

Retrieves a list of changed shipping method key objects for the shipping methods that have been acted on during the specified interval. A shipping method has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | ShippingMethodChangedKeyCriteria | The shipping method changed key criteria object that specifies which changed shipping method key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedShippingMethodKeyListResult | ArrayOfChangedShippingMethodKey | The list of changed shipping method key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed shipping method key objects for all of the shipping methods that were created, updated, or deleted over the last week. A message box displays the number of shipping methods that had each action type performed on them.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ShippingMethodChangedKeyCriteria shippingMethodCriteria;
            ChangedShippingMethodKey[] changedShippingMethodKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return shipping method objects that changed
            shippingMethodCriteria = new ShippingMethodChangedKeyCriteria();
            shippingMethodCriteria.LastModifiedDate = restriction;

            // Retrieve the changed shipping method key objects
            changedShippingMethodKeyObjects = wsDynamicsGP.GetChangedShippingMethodKeyList(shippingMethodCriteria, context);

            // Display the numbers of shipping methods that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedShippingMethodKey key in changedShippingMethodKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Shipping methods: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ShippingMethodChangedKeyCriteria shippingMethodCriteria;
            ChangedShippingMethodKey[] changedShippingMethodKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return shipping method objects that changed
            shippingMethodCriteria = new ShippingMethodChangedKeyCriteria();
            shippingMethodCriteria.LastModifiedDate = restriction;

            // Retrieve the changed shipping method key objects
            changedShippingMethodKeyObjects = wsDynamicsGP.GetChangedShippingMethodKeyList(shippingMethodCriteria, context);

            // Display the numbers of sales orders that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedShippingMethodKey key in changedShippingMethodKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                deleted++;
            }

            string message;
            message = "Shipping methods: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if (wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedTaxDetailKeyList

Description

Retrieves a list of changed tax detail key objects for the tax details that have been acted on during the specified interval. A tax detail has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | TaxDetailChangedKeyCriteria | The tax detail changed key criteria object that specifies which changed tax detail key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedTaxDetailKeyListResult | ArrayOfChangedTaxDetailKey | The list of changed tax detail key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed tax detail key objects for all of the tax details that were created, updated, or deleted over the last week. A message box displays the number of tax details that had each action type performed on them.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ShippingMethodChangedKeyCriteria shippingMethodCriteria;
            ChangedShippingMethodKey[] changedShippingMethodKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return shipping method objects that changed
            shippingMethodCriteria = new ShippingMethodChangedKeyCriteria();
            shippingMethodCriteria.LastModifiedDate = restriction;

            // Retrieve the changed shipping method key objects
            changedShippingMethodKeyObjects = wsDynamicsGP.GetChangedShippingMethodKeyList(shippingMethodCriteria, context);

            // Display the numbers of shipping methods that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedShippingMethodKey key in changedShippingMethodKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Shipping methods: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxDetailChangedKeyCriteria taxDetailCriteria;
            ChangedTaxDetailKey[] changedTaxDetailKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return tax detail objects that changed
            taxDetailCriteria = new TaxDetailChangedKeyCriteria();
            taxDetailCriteria.LastModifiedDate = restriction;

            // Retrieve the changed tax detail key objects
            changedTaxDetailKeyObjects = wsDynamicsGP.GetChangedTaxDetailKeyList(taxDetailCriteria, context);

            // Display the numbers of tax details that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedTaxDetailKey key in changedTaxDetailKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Tax Details: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if (wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedTaxScheduleDetailKeyList

Description

Retrieves a list of changed tax schedule detail key objects for the tax schedule details that have been acted on during the specified interval. A tax schedule detail has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | TaxScheduleDetailChangedKeyCriteria | The tax schedule detail changed key criteria object that specifies which changed tax schedule detail key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedTaxScheduleDetailKeyListResult | ArrayOfChangedTaxScheduleDetailKey | The list of changed tax schedule detail key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed tax schedule detail key objects for all of the tax schedule details that were created, updated, or deleted over the last week. A message box displays the number of tax schedule details that had each action type performed on them.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxScheduleDetailChangedKeyCriteria taxScheduleDetailCriteria;
            ChangedTaxScheduleDetailKey[] changedTaxScheduleDetailKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return tax schedule detail objects that changed
            taxScheduleDetailCriteria = new TaxScheduleDetailChangedKeyCriteria();
            taxScheduleDetailCriteria.LastModifiedDate = restriction;

            // Retrieve the changed tax schedule detail key objects
            changedTaxScheduleDetailKeyObjects = wsDynamicsGP.GetChangedTaxScheduleDetailKeyList(taxScheduleDetailCriteria, context);

            // Display the numbers of tax schedule details that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedTaxScheduleDetailKey key in changedTaxScheduleDetailKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Tax schedule details: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxScheduleDetailChangedKeyCriteria taxScheduleDetailCriteria;
            ChangedTaxScheduleDetailKey[] changedTaxScheduleDetailKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return tax schedule detail objects that changed
            taxScheduleDetailCriteria = new TaxScheduleDetailChangedKeyCriteria();
            taxScheduleDetailCriteria.LastModifiedDate = restriction;

            // Retrieve the changed tax schedule detail key objects
            changedTaxScheduleDetailKeyObjects = wsDynamicsGP.GetChangedTaxScheduleDetailKeyList(taxScheduleDetailCriteria, context);

            // Display the numbers of tax schedule details that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedTaxScheduleDetailKey key in changedTaxScheduleDetailKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "Tax Schedule Details: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if (wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetChangedUofMScheduleKeyList

Description

Retrieves a list of changed unit of measure schedule key objects for the unit of measure schedules that have been acted on during the specified interval. A unit of measure schedule has been acted on if it has been created, updated, or deleted. Entity change tracking must be enabled for this method to return valid results.

Parameters

Parameter | Type | Description
criteria | UofMScheduleChangedKeyCriteria | The unit of measure schedule changed key criteria object that specifies which changed unit of measure schedule key objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetChangedUofMScheduleKeyListResult | ArrayOfChangedUofMScheduleKey | The list of changed unit of measure schedule key objects that match the specified criteria.

Interfaces

  • Dynamics GP

Examples

The following C# example retrieves the list of the changed unit of measure schedule key objects for all of the unit of measure schedules that were created, updated, or deleted over the last week. A message box displays the number of unit of measure schedules that had each action type performed on them.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            UofMScheduleChangedKeyCriteria UofMCriteria;
            ChangedUofMScheduleKey[] changedUofMScheduleKeyObjects;
            BetweenRestrictionOfNullableOfDateTime restriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfDateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return unit of measure objects that changed
            UofMCriteria = new UofMScheduleChangedKeyCriteria();
            UofMCriteria.LastModifiedDate = restriction;

            // Retrieve the changed unit of measure key objects
            changedUofMScheduleKeyObjects = wsDynamicsGP.GetChangedUofMScheduleKeyList(UofMCriteria, context);

            // Display the numbers of unit of measure schedules that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedUofMScheduleKey key in changedUofMScheduleKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "U of M objects: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            UofMScheduleChangedKeyCriteria UofMCriteria;
            ChangedUofMScheduleKey[] changedUofMScheduleKeyObjects;
            BetweenRestrictionOfNullableOfdateTime restriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction that defines the interval examined for changes
            // The following restriction includes the last week
            restriction = new BetweenRestrictionOfNullableOfdateTime();
            restriction.From = DateTime.Today.Date.AddDays(-7);
            restriction.To = DateTime.Today.Date.AddDays(1);

            // Create the criteria to return unit of measure objects that changed
            UofMCriteria = new UofMScheduleChangedKeyCriteria();
            UofMCriteria.LastModifiedDate = restriction;

            // Retrieve the changed unit of measure key objects
            changedUofMScheduleKeyObjects = wsDynamicsGP.GetChangedUofMScheduleKeyList(UofMCriteria, context);

            // Display the numbers of unit of measure schedules that were acted on this week
            int created = 0;
            int updated = 0;
            int deleted = 0;

            foreach (ChangedUofMScheduleKey key in changedUofMScheduleKeyObjects)
            {
                if (key.Action == DataModificationAction.Created)
                    created++;

                if (key.Action == DataModificationAction.Updated)
                    updated++;

                if (key.Action == DataModificationAction.Deleted)
                    deleted++;
            }

            string message;
            message = "U of M objects: \n";
            message = message + "Created: " + created.ToString() + "\n";
            message = message + "Updated: " + updated.ToString() + "\n";
            message = message + "Deleted: " + deleted.ToString() + "\n";

            MessageBox.Show(message);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCompanyAddressByKey

Description

Retrieves a single company address object based on the key value supplied.

Parameters

Parameter | Type | Description
key | CompanyAddressKey | The company address key object that specifies the company address to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCompanyAddressByKeyResult | CompanyAddress | A company address object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a the company address object with the key value “PRIMARY”. The organization key property of the context object specifies the company key. The street address is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CompanyAddress companyAddress;
            CompanyAddressKey addressKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a company address key object to retrieve the primary address
            addressKey = new CompanyAddressKey();
            addressKey.Id = "PRIMARY";

            // Retrieve the company address object
            companyAddress = wsDynamicsGP.GetCompanyAddressByKey(addressKey, context);

            // Display the primary street address
            MessageBox.Show("Primary street address: " + companyAddress.Line1);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CompanyAddress companyAddress;
            CompanyAddressKey addressKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a company address key object to retrieve the primary address
            addressKey = new CompanyAddressKey();
            addressKey.Id = "PRIMARY";

            // Retrieve the company address object
            companyAddress = wsDynamicsGP.GetCompanyAddressByKey(addressKey, context);

            // Display the primary street address
            MessageBox.Show("Primary street address: " + companyAddress.Line1);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCompanyAddressList

Description

Retrieves a list of company address objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CompanyAddressCriteria | The company address criteria object that specifies which company address objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCompanyAddressListResult | ArrayOfCompanyAddress | The list of company address objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of company address objects for the company specified by the company key object. The restriction object’s Like property is “%” to return all company addresses. The total number of company addresses is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CompanyAddress[] companyAddress;
            CompanyAddressCriteria addressCriteria;
            LikeRestrictionOfString addressRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Use the % wildcard to return all existing addresses
            addressRestriction = new LikeRestrictionOfString();
            addressRestriction.Like = "%";

            // Create a criteria object to specify the records to be retrieved
            addressCriteria = new CompanyAddressCriteria();
            addressCriteria.Id = addressRestriction;

            // Retrieve the list of company address objects
            companyAddress = wsDynamicsGP.GetCompanyAddressList(addressCriteria, context);

            // Display the number of addresses returned
            MessageBox.Show("Number of addresses: " + companyAddress.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CompanyAddress[] companyAddress;
            CompanyAddressCriteria addressCriteria;
            LikeRestrictionOfstring addressRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Use the % wildcard to return all existing addresses
            addressRestriction = new LikeRestrictionOfstring();
            addressRestriction.Like = "%";

            // Create a criteria object to specify the records to be retrieved
            addressCriteria = new CompanyAddressCriteria();
            addressCriteria.Id = addressRestriction;

            // Retrieve the list of company address objects
            companyAddress = wsDynamicsGP.GetCompanyAddressList(addressCriteria, context);

            // Display the number of addresses returned
            MessageBox.Show("Number of addresses: " + companyAddress.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCompanyByKey

Description

Retrieves a single company object based on the key value supplied.

Parameters

Parameter | Type | Description
key | CompanyKey | The company key object that specifies the company to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCompanyByKeyResult | Company | A company object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the company with the key value “-1”. The name of the company is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Company company;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            // To retrieve from the system database, set the organization key to null
            context.OrganizationKey = null;

            // Specify a company to retrieve (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Retrieve the company object for the sample company
            company = wsDynamicsGP.GetCompanyByKey(companyKey, context);

            // Display the company name
            MessageBox.Show("Company name: " + company.Name);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Company company;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            // To retrieve from the system database, set the organization key to null
            context.OrganizationKey = null;

            // Specify a company to retrieve (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Retrieve the company object for the sample company
            company = wsDynamicsGP.GetCompanyByKey(companyKey, context);

            // Display the company name
            MessageBox.Show("Company name: " + company.Name);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCompanyList

Description

Retrieves a list of company objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CompanyCriteria | The company criteria object that specifies which company objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCompanyListResult | ArrayOfCompany | The list of company objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of all company objects. The criteria object specifies a range that includes all possible company ID values. The total number of companies is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            BetweenRestrictionOfNullableOfInt32 companyRestriction;
            CompanyCriteria companyCriteria;
            Company[] companyList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object
            context = new Context();

            // Set up the context object
            // To retrieve from the system database set the organization key to null
            context.OrganizationKey = null;

            // Create a restriction object to query by company ID
            // Query for all possible company ID values
            companyRestriction = new BetweenRestrictionOfNullableOfInt32();
            companyRestriction.From = -32768;
            companyRestriction.To = 32767;

            // Create a company criteria object and add the restriction object
            companyCriteria = new CompanyCriteria();
            companyCriteria.Id = companyRestriction;

            // Retrieve the list of companies
            companyList = wsDynamicsGP.GetCompanyList(companyCriteria, context);

            // Display the number of companies in a message box
            MessageBox.Show("Number of companies: " + companyList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            BetweenRestrictionOfNullableOfint companyRestriction;
            CompanyCriteria companyCriteria;
            Company[] companyList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object
            context = new Context();

            // Set up the context object
            // To retrieve from the system database set the organization key to null
            context.OrganizationKey = null;

            // Create a restriction object to query by company ID
            // Query for all possible company ID values
            companyRestriction = new BetweenRestrictionOfNullableOfint();
            companyRestriction.From = -32768;
            companyRestriction.To = 32767;

            // Create a company criteria object and add the restriction object
            companyCriteria = new CompanyCriteria();
            companyCriteria.Id = companyRestriction;

            // Retrieve the list of companies
            companyList = wsDynamicsGP.GetCompanyList(companyCriteria, context);

            // Display the number of companies in a message box
            MessageBox.Show("Number of companies: " + companyList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCompletePolicyByKey

Description

Retrieves the policy instance based on the key value (GUID) for the policy and the role key supplied. The returned policy object will contain both the internal and the external behaviors.

Parameters

Parameter | Type | Description
key | PolicyKey | The policy key object ths specifies the policy to retrieve.
roleKey | RoleKey | The role key object that specifies the role for the policy instance.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCompletePolicyByKeyResult | Policy | The policy instance object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the default instance of the Update Sales Return policy. The GUID for the Update Sales Return policy was found in the Policy Reference for the Dynamics GP service. The role key object specifies the default policy instance. The total number of behaviors for the policy is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicyKey policyKey;
            Policy salesReturnPolicy;
            RoleKey roleKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the role key for the default role
            roleKey = new RoleKey();
            roleKey.Id = "00000000-0000-0000-0000-000000000000";

            // Get the complete update policy for sales returns
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("a08b0c69-13bd-4a7b-bda9-d7902803364b");
            salesReturnPolicy = wsDynamicsGP.GetCompletePolicyByKey(policyKey, roleKey, context);

            MessageBox.Show(salesReturnPolicy.Behaviors.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicyKey policyKey;
            Policy salesReturnPolicy;
            RoleKey roleKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the role key for the default role
            roleKey = new RoleKey();
            roleKey.Id = "00000000-0000-0000-0000-000000000000";

            // Get the complete update policy for sales returns
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("a08b0c69-13bd-4a7b-bda9-d7902803364b");
            salesReturnPolicy = wsDynamicsGP.GetCompletePolicyByKey(policyKey, roleKey, context);

            MessageBox.Show(salesReturnPolicy.Behaviors.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCorporateAccountByKey

Description

Retrieves a single corporate account object based on the key value supplied.

Parameters

Parameter | Type | Description
key | CustomerKey | A customer key object that specifies the corporate account object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCorporateAccountByKeyResult | CorporateAccount | A corporate account object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the corporate account with the key value “COMMUNIC0001”. The corporate account’s total number of members is displayed in a message box. The “COMMUNIC0001” corporate account used in this example was created by the CreateCorporateAccount example.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CorporateAccount corporateAccount;
            CustomerKey customerKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key specifying the corporate account
            customerKey = new CustomerKey();
            customerKey.Id = "COMMUNIC0001";

            // Retrieve the corporate account object
            corporateAccount = wsDynamicsGP.GetCorporateAccountByKey(customerKey, context);

            // Display the number of members for the corporate account
            MessageBox.Show("Total number of members: " + corporateAccount.Members.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CorporateAccount corporateAccount;
            CustomerKey customerKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key specifying the corporate account
            customerKey = new CustomerKey();
            customerKey.Id = "COMMUNIC0001";

            // Retrieve the corporate account object
            corporateAccount = wsDynamicsGP.GetCorporateAccountByKey(customerKey, context);

            // Display the number of members for the corporate account
            MessageBox.Show("Total number of members: " + corporateAccount.Members.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCountryRegionCodeByKey

Description

Retrieves the country region code object based on the key values supplied.

Parameters

Parameter | Type | Description
key | CountryRegionCodeKey | The country region code key object that specifies the country region code to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCountryRegionCodeByKeyResult | CountryRegionCode | The country region code object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the country region code with the country code “BE”. This example requires Intrastat tracking to be enabled. If the country code “BE” cannot be found, an existing country region code should be used. A message box displays the description property of the country region code object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CountryRegionCodeKey countryRegionCodeKey;
            CountryRegionCode countryRegionCode;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a country region code key object to specify the country region code
            countryRegionCodeKey = new CountryRegionCodeKey();
            countryRegionCodeKey.Id = "BE";

            // Retrieve the country region code object
            countryRegionCode = wsDynamicsGP.GetCountryRegionCodeByKey(countryRegionCodeKey, context);

            // Display the description property from the country region code object
            MessageBox.Show("Country region code description: " + countryRegionCode.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CountryRegionCodeKey countryRegionCodeKey;
            CountryRegionCode countryRegionCode;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a country region code key object to specify the country region code
            countryRegionCodeKey = new CountryRegionCodeKey();
            countryRegionCodeKey.Id = "BE";

            // Retrieve the country region code object
            countryRegionCode = wsDynamicsGP.GetCountryRegionCodeByKey(countryRegionCodeKey, context);

            // Display the description property from the country region code object
            MessageBox.Show("Country region code description: " + countryRegionCode.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCountryRegionCodeList

Description

Retrieves a list of country region code objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CountryRegionCodeCriteria | The country region code criteria object that specifies which country region code objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCountryRegionCodeListResult | ArrayOfCountryRegionCode | The list of country region code objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of all country region code objects. The example needs Intrastat tracking enabled and one or more country region codes to be entered. A message box displays the country region code and the description for each object in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString idRestriction;
            CountryRegionCodeCriteria countryRegionCodeCriteria;
            CountryRegionCode[] countryRegionCodeList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all the country codes
            idRestriction = new LikeRestrictionOfString();
            idRestriction.Like = "%";

            // Create the country region code criteria object
            countryRegionCodeCriteria = new CountryRegionCodeCriteria();
            countryRegionCodeCriteria.Id = idRestriction;

            // Retrieve the list of country region code objects that match the criteria
            countryRegionCodeList = wsDynamicsGP.GetCountryRegionCodeList(
            countryRegionCodeCriteria, context);

            // Display the country region code and description for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (CountryRegionCode a in countryRegionCodeList)
            {
                summaryList.AppendLine("Country region code: " + a.Key.Id + "  Description: " +
                a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring idRestriction;
            CountryRegionCodeCriteria countryRegionCodeCriteria;
            CountryRegionCode[] countryRegionCodeList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all the country codes
            idRestriction = new LikeRestrictionOfstring();
            idRestriction.Like = "%";

            // Create the country region code criteria object
            countryRegionCodeCriteria = new CountryRegionCodeCriteria();
            countryRegionCodeCriteria.Id = idRestriction;

            // Retrieve the list of country region code objects that match the criteria
            countryRegionCodeList = wsDynamicsGP.GetCountryRegionCodeList(
            countryRegionCodeCriteria, context);

            // Display the country region code and description for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (CountryRegionCode a in countryRegionCodeList)
            {
                summaryList.AppendLine("Country region code: " + a.Key.Id + "  Description: " +
                a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCurrencyAccessByKey

Description

Retrieves the currency access object based on the key values supplied. Information in this object indicates whether a company has access to a currency defined in Microsoft Dynamics GP.

Parameters

Parameter | Type | Description
key | CurrencyAccessKey | The currency access key object that specifies the company and currency.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCurrencyAccessByKeyResult | CurrencyAccess | The currency access object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the currency access object for the sample company and the New Zealand Dollar (NZD) currency. A message box is displayed, indicating whether the sample company has access to the currency.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CurrencyKey currencyKey;
            CompanyKey companyKey;
            CurrencyAccessKey currencyAccessKey;
            CurrencyAccess currencyAccess;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Create the currency access key object, specifying the
            // company and currency for which access will be examined
            companyKey = new CompanyKey();
            companyKey.Id = (-1);
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "NZD";
            currencyAccessKey = new CurrencyAccessKey();
            currencyAccessKey.CompanyKey = companyKey;
            currencyAccessKey.CurrencyKey = currencyKey;

            // Retrieve the currency access object
            currencyAccess = wsDynamicsGP.GetCurrencyAccessByKey(currencyAccessKey, context);

            // Indicate whether the company has access to the currency
            if (currencyAccess.IsActive == true)
            {
                MessageBox.Show("Company has access");
            }
            else
            {
                MessageBox.Show("Company does not have access");
            }
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CurrencyKey currencyKey;
            CompanyKey companyKey;
            CurrencyAccessKey currencyAccessKey;
            CurrencyAccess currencyAccess;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Create the currency access key object, specifying the
            // company and currency for which access will be examined
            companyKey = new CompanyKey();
            companyKey.Id = (-1);
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "NZD";
            currencyAccessKey = new CurrencyAccessKey();
            currencyAccessKey.CompanyKey = companyKey;
            currencyAccessKey.CurrencyKey = currencyKey;

            // Retrieve the currency access object
            currencyAccess = wsDynamicsGP.GetCurrencyAccessByKey(currencyAccessKey, context);

            // Indicate whether the company has access to the currency
            if (currencyAccess.IsActive == true)
            {
                MessageBox.Show("Company has access");
            }
            else
            {
                MessageBox.Show("Company does not have access");
            }

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCurrencyAccessList

Description

Retrieves a list of currency access objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CurrencyAccessCriteria | The currency access criteria object that specifies which currency access objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCurrencyAccessListResult | ArrayOfCurrencyAccess | The list of currency access objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a list of the currency access objects for the sample company (with -1 as the ID value). The total number of objects returned is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CurrencyAccessCriteria currencyAccessCriteria;
            CurrencyAccess[] currencyAccessList;
            BetweenRestrictionOfNullableOfInt32 companyRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Create the currency access criteria object, specifying
            // which company will be examined
            currencyAccessCriteria = new CurrencyAccessCriteria();
            companyRestriction = new BetweenRestrictionOfNullableOfInt32();
            companyRestriction.EqualValue = (-1);
            currencyAccessCriteria.CompanyId = companyRestriction;

            // Retrieve the currency access objects for the company
            currencyAccessList = wsDynamicsGP.GetCurrencyAccessList(currencyAccessCriteria, context);

            // Display the number of objects returned
            MessageBox.Show(currencyAccessList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CurrencyAccessCriteria currencyAccessCriteria;
            CurrencyAccess[] currencyAccessList;
            BetweenRestrictionOfNullableOfint companyRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Create the currency access criteria object, specifying
            // which company will be examined
            currencyAccessCriteria = new CurrencyAccessCriteria();
            companyRestriction = new BetweenRestrictionOfNullableOfint();
            companyRestriction.EqualValue = (-1);
            currencyAccessCriteria.CompanyId = companyRestriction;

            // Retrieve the currency access objects for the company
            currencyAccessList = wsDynamicsGP.GetCurrencyAccessList(currencyAccessCriteria, context);

            // Display the number of objects returned
            MessageBox.Show(currencyAccessList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCurrencyByKey

Description

Retrieves a single currency object based on the key value supplied.

Parameters

Parameter | Type | Description
key | CurrencyKey | The currency key object that specifies the currency to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCurrencyByKeyResult | Currency | A currency object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the currency with the key value “NZD”, representing New Zealand dollars. The description of the currency is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Currency currency;
            CurrencyKey currencyKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Create the key for the currency to retrieve
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "NZD";

            // Retrieve the currency object
            currency = wsDynamicsGP.GetCurrencyByKey(currencyKey, context);

            // Display the currency description
            MessageBox.Show(currency.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Currency currency;
            CurrencyKey currencyKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Create the key for the currency to retrieve
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "NZD";

            // Retrieve the currency object
            currency = wsDynamicsGP.GetCurrencyByKey(currencyKey, context);

            // Display the currency description
            MessageBox.Show(currency.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCurrencyList

Description

Retrieves a list of currency objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CurrencyCriteria | The currency criteria object that specifies which currency objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCurrencyListResult | ArrayOfCurrency | The list of currency objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of currency objects that have the word “Dollar” in their description. The total number of currency objects returned is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Currency[] currencyList;
            CurrencyCriteria currencyCriteria;
            LikeRestrictionOfString currencyDescription;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Create the criteria specifying which currencies to retrieve
            currencyCriteria = new CurrencyCriteria();
            currencyDescription = new LikeRestrictionOfString();
            currencyDescription.Like = "%Dollar%";
            currencyCriteria.Description = currencyDescription;

            // Retrieve the list of currency objects
            currencyList = wsDynamicsGP.GetCurrencyList(currencyCriteria, context);

            // Display the number of currencies returned
            MessageBox.Show(currencyList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Currency[] currencyList;
            CurrencyCriteria currencyCriteria;
            LikeRestrictionOfstring currencyDescription;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Create the criteria specifying which currencies to retrieve
            currencyCriteria = new CurrencyCriteria();
            currencyDescription = new LikeRestrictionOfstring();
            currencyDescription.Like = "%Dollar%";
            currencyCriteria.Description = currencyDescription;

            // Retrieve the list of currency objects
            currencyList = wsDynamicsGP.GetCurrencyList(currencyCriteria, context);

            // Display the number of currencies returned
            MessageBox.Show(currencyList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCurrencyPostingAccountByKey

Description

Retrieves a single currency posting account object based on the key value supplied.

Parameters

Parameter | Type | Description
key | CurrencyPostingAccountKey | The currency posting account key object that specifies the currency posting account object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCurrencyPostingAccountByKeyResult | CurrencyPostingAccount | A currency posting account object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the currency posting account object with the key value “NZD”, containing the posting accounts configured to work with New Zealand dollars. The account number for the Realized Gain account is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CurrencyPostingAccount currencyPostingAccount;
            CurrencyPostingAccountKey currencyPostingAccountKey;
            CurrencyKey currencyKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = companyKey;

            // Create the key for the item to retrieve
            currencyPostingAccountKey = new CurrencyPostingAccountKey();
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "NZD";
            currencyPostingAccountKey.CurrencyKey = currencyKey;

            // Retrieve the currency posting account object
            currencyPostingAccount = wsDynamicsGP.GetCurrencyPostingAccountByKey
            (currencyPostingAccountKey, context);

            // Display the Realized Gain account
            MessageBox.Show(currencyPostingAccount.RealizedGainGLAccountKey.Id);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CurrencyPostingAccount currencyPostingAccount;
            CurrencyPostingAccountKey currencyPostingAccountKey;
            CurrencyKey currencyKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = companyKey;

            // Create the key for the item to retrieve
            currencyPostingAccountKey = new CurrencyPostingAccountKey();
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "NZD";
            currencyPostingAccountKey.CurrencyKey = currencyKey;

            // Retrieve the currency posting account object
            currencyPostingAccount = wsDynamicsGP.GetCurrencyPostingAccountByKey
            (currencyPostingAccountKey, context);

            // Display the Realized Gain account
            MessageBox.Show(currencyPostingAccount.RealizedGainGLAccountKey.Id);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCurrencyPostingAccountList

Description

Retrieves a list of currency posting account objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CurrencyPostingAccountCriteria | The currency posting account criteria object that specifies which currency posting account objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCurrencyPostingAccountListResult | ArrayOfCurrencyPostingAccount | The list of currency posting account objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of currency posting account objects for the currencies with the ISO code “NZD”, representing New Zealand dollars. The total number of objects is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CurrencyPostingAccountCriteria currencyPostingAccountCriteria;
            CurrencyPostingAccount[] currencyPostingAccountList;
            LikeRestrictionOfString currencyRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = companyKey;

            // Specify the criteria for the currency posting account objects to retrieve
            currencyRestriction = new LikeRestrictionOfString();
            currencyRestriction.Like = "ZAR";
            currencyPostingAccountCriteria = new CurrencyPostingAccountCriteria();
            currencyPostingAccountCriteria.Id = currencyRestriction;

            // Retrieve the list of currency posting account objects
            currencyPostingAccountList = wsDynamicsGP.GetCurrencyPostingAccountList
            (currencyPostingAccountCriteria, context);

            // Display how many objects were returned
            MessageBox.Show(currencyPostingAccountList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CurrencyPostingAccountCriteria currencyPostingAccountCriteria;
            CurrencyPostingAccount[] currencyPostingAccountList;
            LikeRestrictionOfstring currencyRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = companyKey;

            // Specify the criteria for the currency posting account objects to retrieve
            currencyRestriction = new LikeRestrictionOfstring();
            currencyRestriction.Like = "ZAR";
            currencyPostingAccountCriteria = new CurrencyPostingAccountCriteria();
            currencyPostingAccountCriteria.Id = currencyRestriction;

            // Retrieve the list of currency posting account objects
            currencyPostingAccountList = wsDynamicsGP.GetCurrencyPostingAccountList
            (currencyPostingAccountCriteria, context);

            // Display how many objects were returned
            MessageBox.Show(currencyPostingAccountList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCustomerAddressByKey

Description

Retrieves a single customer address object based on the specified customer address key.

Parameters

Parameter | Type | Description
key | CustomerAddressKey | The customer address key object that specifies the customer address to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCustomerAddressByKeyResult | CustomerAddress | A customer address object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the primary address for the customer with the key value “AARONFIT0001”. The city from the customer’s address is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerAddressKey customerAddressKey;
            CustomerAddress customerAddress;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key and specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a customer address key object
            customerAddressKey = new CustomerAddressKey();
            customerAddressKey.CustomerKey = customerKey;
            customerAddressKey.Id = "PRIMARY";

            // Retrieve the customer address object
            customerAddress = wsDynamicsGP.GetCustomerAddressByKey(customerAddressKey, context);

            // Display the location information for the customer
            MessageBox.Show("City: " + customerAddress.City);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerAddressKey customerAddressKey;
            CustomerAddress customerAddress;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key and specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a customer address key object
            customerAddressKey = new CustomerAddressKey();
            customerAddressKey.CustomerKey = customerKey;
            customerAddressKey.Id = "PRIMARY";

            // Retrieve the customer address object
            customerAddress = wsDynamicsGP.GetCustomerAddressByKey(customerAddressKey, context);

            // Display the location information for the customer
            MessageBox.Show("City: " + customerAddress.City);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCustomerAddressList

Description

Retrieves a list of customer address summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CustomerAddressCriteria | The customer address criteria object that specifies which customer address summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCustomerAddressListResult | ArrayOfCustomerAddressSummary | The list of customer address summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of customer address summary objects where the customer has a primary address in the state “IL”. The total number of customer addresses is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerAddressSummary[] customerAddressList;
            CustomerAddressCriteria customerAddressCriteria;
            LikeRestrictionOfString addressRestriction;
            LikeRestrictionOfString stateRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer address criteria object
            addressRestriction = new LikeRestrictionOfString();
            addressRestriction.Like = "PRIMARY";
            stateRestriction = new LikeRestrictionOfString();
            stateRestriction.EqualValue = "IL";
            customerAddressCriteria = new CustomerAddressCriteria();
            customerAddressCriteria.CustomerAddressKeyId = addressRestriction;
            customerAddressCriteria.State = stateRestriction;

            // Retrieve the customer address summary objects
            customerAddressList = wsDynamicsGP.GetCustomerAddressList(customerAddressCriteria, context);

            // Display the number of customers that have a primary address in the specified state
            MessageBox.Show("Total number of customers with a primary address in IL: "
                + customerAddressList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerAddressSummary[] customerAddressList;
            CustomerAddressCriteria customerAddressCriteria;
            LikeRestrictionOfstring addressRestriction;
            LikeRestrictionOfstring stateRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer address criteria object
            addressRestriction = new LikeRestrictionOfstring();
            addressRestriction.Like = "PRIMARY";
            stateRestriction = new LikeRestrictionOfstring();
            stateRestriction.EqualValue = "IL";
            customerAddressCriteria = new CustomerAddressCriteria();
            customerAddressCriteria.CustomerAddressKeyId = addressRestriction;
            customerAddressCriteria.State = stateRestriction;

            // Retrieve the customer address summary objects
            customerAddressList = wsDynamicsGP.GetCustomerAddressList(customerAddressCriteria, context);

            // Display the number of customers that have a primary address in the specified state
            MessageBox.Show("Total number of customers with a primary address in IL: "
                + customerAddressList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCustomerByKey

Description

Retrieves a single customer object based on the key value supplied. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | CustomerKey | The customer key object that specifies the customer to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCustomerByKeyResult | Customer | A customer object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the customer with the key value “AARONFIT0001”. The name of the customer is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Retrieve the customer object
            customer = wsDynamicsGP.GetCustomerByKey(customerKey, context);

            MessageBox.Show(customer.Name);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Retrieve the customer object
            customer = wsDynamicsGP.GetCustomerByKey(customerKey, context);

            MessageBox.Show(customer.Name);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCustomerList

Description

Retrieves a list of customer summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CustomerCriteria | The customer criteria object that specifies which customer summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCustomerListResult | ArrayOfCustomerSummary | The list of customer summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of customer summary objects for the customers whose State property is “ND”. The total number of customers is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerCriteria customerCriteria;
            CustomerSummary[] customerSummaryList;
            LikeRestrictionOfString stateRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria for the customer summaries to retrieve
            stateRestriction = new LikeRestrictionOfString();
            stateRestriction.Like = "%ND%";
            customerCriteria = new CustomerCriteria();
            customerCriteria.State = stateRestriction;

            // Retrieve the list of customer summaries
            customerSummaryList = wsDynamicsGP.GetCustomerList(customerCriteria, context);

            // Display the number of customers matching the criteria
            MessageBox.Show("North Dakota customers: " + customerSummaryList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerCriteria customerCriteria;
            CustomerSummary[] customerSummaryList;
            LikeRestrictionOfstring stateRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria for the customer summaries to retrieve
            stateRestriction = new LikeRestrictionOfstring();
            stateRestriction.Like = "%ND%";
            customerCriteria = new CustomerCriteria();
            customerCriteria.State = stateRestriction;

            // Retrieve the list of customer summaries
            customerSummaryList = wsDynamicsGP.GetCustomerList(customerCriteria, context);

            // Display the number of customers matching the criteria
            MessageBox.Show("North Dakota customers: " + customerSummaryList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCustomerReceivablesSummaryByKey

Description

Retrieves receivables summary information for a specified customer. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | CustomerKey | The customer key object that specifies the customer to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCustomerReceivablesSummaryByKeyResult | CustomerReceivablesSummary | A customer receivables summary object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the receivables summary object for the customer with the key value “AARONFIT0001”. A message box displays the customer’s last receivables payment date.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerReceivablesSummary customerReceivablesSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Retrieve the customer receivables summary object
            customerReceivablesSummary = wsDynamicsGP.GetCustomerReceivablesSummaryByKey(customerKey,
            context);

            // Display the last payment date from the customer receivables summary object
            MessageBox.Show("Last Payment Date: " + customerReceivablesSummary.LastPaymentDate.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerReceivablesSummary customerReceivablesSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Retrieve the customer receivables summary object
            customerReceivablesSummary = wsDynamicsGP.GetCustomerReceivablesSummaryByKey(customerKey,
            context);

            // Display the last payment date from the customer receivables summary object
            MessageBox.Show("Last Payment Date: " + customerReceivablesSummary.LastPaymentDate.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetCustomerReceivablesSummaryList

Description

Retrieves a list of customer receivables summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | CustomerReceivablesSummaryCriteria | The customer receivables summary criteria object that specifies which customer receivables summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetCustomerReceivablesSummaryList Result | ArrayOfCustomerReceivablesSummary | The list of customer receivables summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of customer receivables summary objects where the salesperson ID is equal to “Paul W.”. A message box displays the customer number and on order amount of each customer that has an on order balance.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString salespersonIdRestriction;
            CustomerReceivablesSummaryCriteria customerReceivablesSummaryCriteria;
            CustomerReceivablesSummary[] customerReceivablesSummaryList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all customer receivables summary objects where 'Paul W.' is the specified salesperson
            salespersonIdRestriction = new LikeRestrictionOfString();
            salespersonIdRestriction.EqualValue = "PAUL W.";

            // Create the criteria object and specify the criteria restriction
            customerReceivablesSummaryCriteria = new CustomerReceivablesSummaryCriteria();
            customerReceivablesSummaryCriteria.SalespersonId = salespersonIdRestriction;

            // Retrieve the list of customer receivables summary objects
            customerReceivablesSummaryList = wsDynamicsGP.GetCustomerReceivablesSummaryList
                (customerReceivablesSummaryCriteria, context);

            // Display the customer number and on order amount for members of the
            // customer receivables summary list that have an on order balance
            StringBuilder summaryList = new StringBuilder();
            foreach (CustomerReceivablesSummary a in customerReceivablesSummaryList)
            {
                if (a.OnOrderAmount.Value > 0)
                {
                    summaryList.AppendLine("Customer: " + a.Key.Id
                        + "   On order amount: " + a.OnOrderAmount.Value.ToString("C"));
                }
            }
            MessageBox.Show(summaryList.ToString());

    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring salespersonIdRestriction;
            CustomerReceivablesSummaryCriteria customerReceivablesSummaryCriteria;
            CustomerReceivablesSummary[] customerReceivablesSummaryList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all customer receivables summary objects where 'Paul W.' is the specified salesperson
            salespersonIdRestriction = new LikeRestrictionOfstring();
            salespersonIdRestriction.EqualValue = "PAUL W.";

            // Create the criteria object and specify the criteria restriction
            customerReceivablesSummaryCriteria = new CustomerReceivablesSummaryCriteria();
            customerReceivablesSummaryCriteria.SalespersonId = salespersonIdRestriction;

            // Retrieve the list of customer receivables summary objects
            customerReceivablesSummaryList = wsDynamicsGP.GetCustomerReceivablesSummaryList
                (customerReceivablesSummaryCriteria, context);

            // Display the customer number and on order amount for members of the
            // customer receivables summary list that have an on order balance
            StringBuilder summaryList = new StringBuilder();
            foreach (CustomerReceivablesSummary a in customerReceivablesSummaryList)
            {
                if (a.OnOrderAmount.Value > 0)
                {
                    summaryList.AppendLine("Customer: " + a.Key.Id
                        + "   On order amount: " + a.OnOrderAmount.Value.ToString("C"));
                }
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }

    }
}


GetDynamicsOnlineConfigurationByKey

Description

Retrieves the Dynamics Online Configuration for a specific company.

Parameters

Parameter | Type | Description
key | CompanyKey | The company key object that specifies the company for which the Dynamics Online Configuration will be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetDynamicsOnlineConfigurationByKeyResult | DynamicsOnlineConfiguration | A customer object.

Interfaces

  • Dynamics GP
  • Common

Examples

The following C# example retrieves the Dynamics Online Configuration object for the Fabrikam sample company. A message box displays the company name from the Dynamics Online Configuration data.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DynamicsOnlineConfiguration doConfiguration;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = null;

            // Retrieve the Dynamics Online Configuration for the company
            doConfiguration = wsDynamicsGP.GetDynamicsOnlineConfigurationByKey(companyKey, context);

            // Display the company name from the configuration data
            MessageBox.Show("Configuration for: " + doConfiguration.CompanyName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DynamicsOnlineConfiguration doConfiguration;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the Dynamics Online Configuration for the company
            doConfiguration = wsDynamicsGP.GetDynamicsOnlineConfigurationByKey(companyKey, context);

            // Display the company name from the configuration data
            MessageBox.Show("Configuration for: " + doConfiguration.CompanyName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetDynamicsOnlineConfigurationList

Description

Retrieves a list of Dynamics Online Configuration objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | DynamicsOnlineConfigurationCriteria | The Dynamics Online Configuration criteria object that specifies which objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetDynamicsOnlineConfigurationListResult | ArrayOfDynamicsOnlineConfiguration | A list of the Dynamics Online Configuration objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common

Examples

The following C# example retrieves the collection of Dynamics Online Configuration objects which Commerce Services are active. A message box displays the number of companies.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DynamicsOnlineConfiguration[] doConfigurations;
            DynamicsOnlineConfigurationCriteria doCriteria;
            RestrictionOfNullableOfBoolean activeRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context
            context.OrganizationKey = null;

            // Specify the criteria for the configurations to retrieve
            activeRestriction = new RestrictionOfNullableOfBoolean();
            activeRestriction.EqualValue = true;
            doCriteria = new DynamicsOnlineConfigurationCriteria();
            doCriteria.IsCommerceServicesActive = activeRestriction;

            // Retrieve the Dynamics Online Configurations
            doConfigurations = wsDynamicsGP.GetDynamicsOnlineConfigurationList(doCriteria, context);

            // Display the number of configuration sets found
            MessageBox.Show("Configurations found: " + doConfigurations.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DynamicsOnlineConfiguration[] doConfigurations;
            DynamicsOnlineConfigurationCriteria doCriteria;
            RestrictionOfNullableOfboolean activeRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = null;

            // Specify the criteria for the configurations to retrieve
            activeRestriction = new RestrictionOfNullableOfboolean();
            activeRestriction.EqualValue = true;
            doCriteria = new DynamicsOnlineConfigurationCriteria();
            doCriteria.IsCommerceServicesActive = activeRestriction;

            // Retrieve the Dynamics Online Configurations
            doConfigurations = wsDynamicsGP.GetDynamicsOnlineConfigurationList(doCriteria, context);

            // Display the number of configuration sets found
            MessageBox.Show("Configurations found: " + doConfigurations.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetEmployeeAddressByKey

Description

Retrieves a single employee address object based on the specified employee address key.

Parameters

Parameter | Type | Description
key | EmployeeAddressKey | The employee address key object that specifies the employee address to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetEmployeeAddressByKeyResult | EmployeeAddress | An employee address object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the employee address for the employee“ACKE0001” where the address Id is “Test address”. The address information is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeKey employeeKey;
            EmployeeAddressKey employeeAddressKey;
            EmployeeAddress employeeAddress;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create an employee address key
            employeeAddressKey = new EmployeeAddressKey();
            employeeAddressKey.EmployeeKey = employeeKey;
            employeeAddressKey.Id = "Test address";

            // Get the specified employee address object
            employeeAddress = wsDynamicsGP.GetEmployeeAddressByKey(employeeAddressKey, context);

            // Display data from the employee address
            MessageBox.Show("Address type: " + employeeAddress.Key.Id + "   Location: " + employeeAddress.State);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeKey employeeKey;
            EmployeeAddressKey employeeAddressKey;
            EmployeeAddress employeeAddress;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create an employee address key
            employeeAddressKey = new EmployeeAddressKey();
            employeeAddressKey.EmployeeKey = employeeKey;
            employeeAddressKey.Id = "Test address";

            // Get the specified employee address object
            employeeAddress = wsDynamicsGP.GetEmployeeAddressByKey(employeeAddressKey, context);

            // Display data from the employee address
            MessageBox.Show("Address type: " + employeeAddress.Key.Id + "   Location: " + employeeAddress.State);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetEmployeeAddressList

Description

Retrieves a list of employee address summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | EmployeeAddressCriteria | The employee address criteria object that specifies which employee address summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetEmployeeAddressListResult | ArrayOfEmployeeAddressSummary | The list of employee address summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of employee address summary objects for employees whose Id property begins with “A”. Information from each address summary is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString employeeIdRestriction;
            EmployeeAddressCriteria employeeAddressCriteria;
            EmployeeAddressSummary[] employeeAddressList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve address summary objects for employees that begin with 'A'
            employeeIdRestriction = new LikeRestrictionOfString();
            employeeIdRestriction.Like = "A%";

            // Create the criteria object and specify the criteria restriction
            employeeAddressCriteria = new EmployeeAddressCriteria();
            employeeAddressCriteria.EmployeeKeyId = employeeIdRestriction;

            // Retrieve the list of employee address summary objects
            employeeAddressList = wsDynamicsGP.GetEmployeeAddressList(employeeAddressCriteria, context);

            // Display the employee address and on order amount for members of the
            // customer receivables summary list that have an on order balance
            StringBuilder summaryList = new StringBuilder();
            foreach (EmployeeAddressSummary a in employeeAddressList)
            {
                if (a.State.Length > 0)
                {
                    summaryList.AppendLine("Employee: " + a.Key.EmployeeKey.Id
                        + "   Address title: " + a.Key.Id
                        + "   State: " + a.State);
                }
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring employeeIdRestriction;
            EmployeeAddressCriteria employeeAddressCriteria;
            EmployeeAddressSummary[] employeeAddressList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve address summary objects for employees that begin with 'A'
            employeeIdRestriction = new LikeRestrictionOfstring();
            employeeIdRestriction.Like = "A%";

            // Create the criteria object and specify the criteria restriction
            employeeAddressCriteria = new EmployeeAddressCriteria();
            employeeAddressCriteria.EmployeeKeyId = employeeIdRestriction;

            // Retrieve the list of employee address summary objects
            employeeAddressList = wsDynamicsGP.GetEmployeeAddressList(employeeAddressCriteria, context);

            // Display the employee address and on order amount for members of the
            // customer receivables summary list that have an on order balance
            StringBuilder summaryList = new StringBuilder();
            foreach (EmployeeAddressSummary a in employeeAddressList)
            {
                if (a.State.Length > 0)
                {
                    summaryList.AppendLine("Employee: " + a.Key.EmployeeKey.Id
                        + "   Address title: " + a.Key.Id
                        + "   State: " + a.State);
                }
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetEmployeeByKey

Description

Retrieves a single employee object based on the key value supplied. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | EmployeeKey | The employee key object that specifies the employee to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetEmployeeByKeyResult | Employee | An employee object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the employee with the key value “ACKE0001”. The name information for the employee is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Employee employee;
            EmployeeKey employeeKey;
            Name name;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Retrieve the employee object
            employee = wsDynamicsGP.GetEmployeeByKey(employeeKey, context);

            // Retrieve the employee name information
            name = new Name();
            name = employee.Name;

            // Display the name information
            MessageBox.Show(name.Given + " " + name.Middle + " " + name.Family);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Employee employee;
            EmployeeKey employeeKey;
            Name name;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Retrieve the employee object
            employee = wsDynamicsGP.GetEmployeeByKey(employeeKey, context);

            // Retrieve the employee name information
            name = new Name();
            name = employee.Name;

            // Display the name information
            MessageBox.Show(name.Given + " " + name.Middle + " " + name.Family);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetEmployeeList

Description

Retrieves a list of employee summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | EmployeeCriteria | The employee criteria object that specifies which employee summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetEmployeeListResult | ArrayOfEmployeeSummary | The list of employee summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of employee summary objects for the employees whose SupervisorID property is “SUPMGR”. The total number of employees is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeCriteria employeeCriteria;
            EmployeeSummary[] employeeSummaryList;
            LikeRestrictionOfString supervisorRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria for the employee summaries to retrieve
            supervisorRestriction = new LikeRestrictionOfString();
            supervisorRestriction.Like = "%SUPMGR%";
            employeeCriteria = new EmployeeCriteria();
            employeeCriteria.SupervisorId = supervisorRestriction;

            // Retrieve the list of employee summaries
            employeeSummaryList = wsDynamicsGP.GetEmployeeList(employeeCriteria, context);

            // Display the number of employees matching the criteria
            MessageBox.Show("SUPMGR employees: " + employeeSummaryList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeCriteria employeeCriteria;
            EmployeeSummary[] employeeSummaryList;
            LikeRestrictionOfstring supervisorRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria for the employee summaries to retrieve
            supervisorRestriction = new LikeRestrictionOfstring();
            supervisorRestriction.Like = "%SUPMGR%";
            employeeCriteria = new EmployeeCriteria();
            employeeCriteria.SupervisorId = supervisorRestriction;

            // Retrieve the list of employee summaries
            employeeSummaryList = wsDynamicsGP.GetEmployeeList(employeeCriteria, context);

            // Display the number of employees matching the criteria
            MessageBox.Show("SUPMGR employees: " + employeeSummaryList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetEmployeePayCodeByKey

Description

Retrieves an employee pay code object based on the key value supplied.

Parameters

Parameter | Type | Description
key | EmployeePayCodeKey | The employee pay code key object that specifies the employee pay code to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetEmployeePayCodeByKeyResult | EmployeePayCode | An employee pay code object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the employee pay code object with the employee Id value “ACKE0001” and the pay code value “COMM”. The employee pay code information is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeePayCode employeePayCode;
            EmployeePayCodeKey employeePayCodeKey;
            EmployeeKey employeeKey;
            PayCodeKey payCodeKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create a pay code key
            payCodeKey = new PayCodeKey();
            payCodeKey.Id = "COMM";

            // Create an employee pay code key
            employeePayCodeKey = new EmployeePayCodeKey();
            employeePayCodeKey.EmployeeKey = employeeKey;
            employeePayCodeKey.PayCodeKey = payCodeKey;

            // Get the employee pay code object
            employeePayCode = wsDynamicsGP.GetEmployeePayCodeByKey(employeePayCodeKey, context);

            // Display the pay code for the employee
            MessageBox.Show("Employee: " + employeePayCode.EmployeePayCodeKey.EmployeeKey.Id
                + "   Pay code: " + employeePayCode.EmployeePayCodeKey.PayCodeKey.Id);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeePayCode employeePayCode;
            EmployeePayCodeKey employeePayCodeKey;
            EmployeeKey employeeKey;
            PayCodeKey payCodeKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create a pay code key
            payCodeKey = new PayCodeKey();
            payCodeKey.Id = "COMM";

            // Create an employee pay code key
            employeePayCodeKey = new EmployeePayCodeKey();
            employeePayCodeKey.EmployeeKey = employeeKey;
            employeePayCodeKey.PayCodeKey = payCodeKey;

            // Get the employee pay code object
            employeePayCode = wsDynamicsGP.GetEmployeePayCodeByKey(employeePayCodeKey, context);

            // Display the pay code for the employee
            MessageBox.Show("Employee: " + employeePayCode.EmployeePayCodeKey.EmployeeKey.Id
                + "   Pay code: " + employeePayCode.EmployeePayCodeKey.PayCodeKey.Id);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetEmployeePayCodeList

Description

Retrieves a list of employee pay code summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | EmployeePayCodeCriteria | The employee pay code criteria object that specifies which employee pay code summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetEmployeePayCodeListResult | ArrayOfEmployeePayCodeSummary | The list of employee pay code summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of employee pay code summary objects where the employee Id begins with “A”. A message box displays the pay codes for each employee.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeePayCodeSummary[] employeePayCodeList;
            EmployeePayCodeCriteria employeePayCodeCriteria;
            LikeRestrictionOfString employeeIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee pay code criteria object
            employeeIdRestriction = new LikeRestrictionOfString();
            employeeIdRestriction.Like = "A%";
            employeePayCodeCriteria = new EmployeePayCodeCriteria();
            employeePayCodeCriteria.EmployeeKeyId = employeeIdRestriction;

            // Get the list of employee pay codes
            employeePayCodeList = wsDynamicsGP.GetEmployeePayCodeList(employeePayCodeCriteria, context);

            // Display each member of the pay code summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (EmployeePayCodeSummary a in employeePayCodeList)
            {
                summaryList.AppendLine("Employee: " + a.EmployeePayCodeKey.EmployeeKey.Id + "  Pay Code: " +
                a.EmployeePayCodeKey.PayCodeKey.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeePayCodeSummary[] employeePayCodeList;
            EmployeePayCodeCriteria employeePayCodeCriteria;
            LikeRestrictionOfstring employeeIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee pay code criteria object
            employeeIdRestriction = new LikeRestrictionOfstring();
            employeeIdRestriction.Like = "A%";
            employeePayCodeCriteria = new EmployeePayCodeCriteria();
            employeePayCodeCriteria.EmployeeKeyId = employeeIdRestriction;

            // Get the list of employee pay codes
            employeePayCodeList = wsDynamicsGP.GetEmployeePayCodeList(employeePayCodeCriteria, context);

            // Display each member of the pay code summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (EmployeePayCodeSummary a in employeePayCodeList)
            {
                summaryList.AppendLine("Employee: " + a.EmployeePayCodeKey.EmployeeKey.Id + "  Pay Code: " +
                a.EmployeePayCodeKey.PayCodeKey.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetFeeByKey

Description

Retrieves a single fee object based on the item key value supplied.

Parameters

Parameter | Type | Description
key | ItemKey | The item key object that specifies the fee to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetFeeByKeyResult | Fee | A fee object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the fee with the key value “5-CONTRACTS”. The description of the fee is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            Fee fee;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object to specify the fee
            itemKey = new ItemKey();
            itemKey.Id = "5-CONTRACTS";

            // Retrieve the fee object
            fee = wsDynamicsGP.GetFeeByKey(itemKey, context);

            // Display the description property of the fee object
            MessageBox.Show("Fee description: " + fee.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            Fee fee;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object to specify the fee
            itemKey = new ItemKey();
            itemKey.Id = "5-CONTRACTS";

            // Retrieve the fee object
            fee = wsDynamicsGP.GetFeeByKey(itemKey, context);

            // Display the description property of the fee object
            MessageBox.Show("Fee description: " + fee.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetFeeList

Description

Retrieves a list of fee summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | FeeCriteria | The fee criteria object that specifies which fee summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetFeeListResult | ArrayOfFeeSummary | The list of fee summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of fee summary objects where the fee type is equal to “Flat Fee”. A message box displays the description and type property of each fee in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfFeeType feeTypeRestriction;
            FeeCriteria feeCriteria;
            FeeSummary[] feeSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all fee with a type of 'Flat Fee'
            feeTypeRestriction = new ListRestrictionOfNullableOfFeeType();
            feeTypeRestriction.EqualValue = FeeType.FlatFee;

            // Create the criteria object and specify the criteria restriction
            feeCriteria = new FeeCriteria();
            feeCriteria.Type = feeTypeRestriction;

            // Retrieve the list of fee summary objects
            feeSummaries = wsDynamicsGP.GetFeeList(feeCriteria, context);

            // Display the description and type of each member of the fee summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (FeeSummary a in feeSummaries)
            {
                summaryList.AppendLine("Fee name: " + a.Description + "  Fee type: " +
                a.Type.ToString());
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfFeeType feeTypeRestriction;
            FeeCriteria feeCriteria;
            FeeSummary[] feeSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all fee with a type of 'Flat Fee'
            feeTypeRestriction = new ListRestrictionOfNullableOfFeeType();
            feeTypeRestriction.EqualValue = FeeType.FlatFee;

            // Create the criteria object and specify the criteria restriction
            feeCriteria = new FeeCriteria();
            feeCriteria.Type = feeTypeRestriction;

            // Retrieve the list of fee summary objects
            feeSummaries = wsDynamicsGP.GetFeeList(feeCriteria, context);

            // Display the description and type of each member of the fee summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (FeeSummary a in feeSummaries)
            {
                summaryList.AppendLine("Fee name: " + a.Description + "  Fee type: " +
                a.Type.ToString());
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLAccountByKey

Description

Retrieves a single general ledger account object based on the key value supplied.

Parameters

Parameter | Type | Description
key | GLAccountNumberKey | A general ledger account number key object that specifies the account to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLAccountByKeyResult | GLAccount | A general ledger account object.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the general ledger account with the key value “000-1100-00”. The description of the account is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountKey;
            GLAccount account;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key object
            accountKey = new GLAccountNumberKey();
            accountKey.Id = "000-1100-00";

            // Retrieve the GL account object
            account = wsDynamicsGP.GetGLAccountByKey(accountKey, context);

            // Display the account description in a message box
            MessageBox.Show("Account: " + account.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountKey;
            GLAccount account;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key object
            accountKey = new GLAccountNumberKey();
            accountKey.Id = "000-1100-00";

            // Retrieve the GL account object
            account = wsDynamicsGP.GetGLAccountByKey(accountKey, context);

            // Display the account description in a message box
            MessageBox.Show("Account: " + account.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLAccountCategoryList

Description

Retrieves a list of all general ledger account category objects.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLAccountCategoryListResult | ArrayOfGLAccountCategory | A list containing all general ledger account category objects.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the list of all existing general ledger account category objects. The total number of account categories is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountCategory[] accountCategories;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Retrieve all the general ledger account category objects
            accountCategories = wsDynamicsGP.GetGLAccountCategoryList(context);

            // Display the number of account categories
            MessageBox.Show("Total number of GL account categories: " + accountCategories.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountCategory[] accountCategories;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Retrieve all the general ledger account category objects
            accountCategories = wsDynamicsGP.GetGLAccountCategoryList(context);

            // Display the number of account categories
            MessageBox.Show("Total number of GL account categories: " + accountCategories.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLAccountFormatList

Description

Retrieves a list of general ledger account format objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | GLAccountFormatCriteria | The GL account format criteria object that specifies which account format objects are to be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLAccountFormatListResult | ArrayOfGLAccountFormat | A list of the GL account format objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves all GL account formats and displays each format object’s segment name and segment length property in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountFormatCriteria accountFormatCriteria;
            GLAccountFormat[] accountFormats;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an account format criteria object
            accountFormatCriteria = new GLAccountFormatCriteria();

            // Retrieve the account format list
            accountFormats = wsDynamicsGP.GetGLAccountFormatList(accountFormatCriteria, context);

            // Display the name and length of each member of the GL account format object list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLAccountFormat a in accountFormats)
            {
                summaryList.AppendLine("Name: " + a.SegmentName + "  Length " +
                a.SegmentLength.ToString());
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountFormatCriteria accountFormatCriteria;
            GLAccountFormat[] accountFormats;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an account format criteria object
            accountFormatCriteria = new GLAccountFormatCriteria();

            // Retrieve the account format list
            accountFormats = wsDynamicsGP.GetGLAccountFormatList(accountFormatCriteria, context);

            // Display the name and length of each member of the GL account format object list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLAccountFormat a in accountFormats)
            {
                summaryList.AppendLine("Name: " + a.SegmentName + "  Length " +
                a.SegmentLength.ToString());
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLAccountList

Description

Retrieves a list of GL account summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | GLAccountCriteria | The GL account criteria object that specifies which account summaries are to be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLAccountListResult | ArrayOfGLAccountSummary | A list of the GL account summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the list of all active GL accounts and displays the total in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountSummary[] GLAccountSummaryList;
            GLAccountCriteria GLAccountCriteria;
            RestrictionOfNullableOfBoolean accountActiveRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Set the criteria specifying wich accounts to retrieve
            GLAccountCriteria = new GLAccountCriteria();
            accountActiveRestriction = new RestrictionOfNullableOfBoolean();
            accountActiveRestriction.EqualValue = true;
            GLAccountCriteria.IsActive = accountActiveRestriction;

            // Retrieve the list of active accounts
            GLAccountSummaryList = wsDynamicsGP.GetGLAccountList(GLAccountCriteria, context);

            // Display the total number of active accounts
            MessageBox.Show("Total active accounts:" + GLAccountSummaryList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountSummary[] GLAccountSummaryList;
            GLAccountCriteria GLAccountCriteria;
            RestrictionOfNullableOfboolean accountActiveRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Set the criteria specifying wich accounts to retrieve
            GLAccountCriteria = new GLAccountCriteria();
            accountActiveRestriction = new RestrictionOfNullableOfboolean();
            accountActiveRestriction.EqualValue = true;
            GLAccountCriteria.IsActive = accountActiveRestriction;

            // Retrieve the list of active accounts
            GLAccountSummaryList = wsDynamicsGP.GetGLAccountList(GLAccountCriteria, context);

            // Display the total number of active accounts
            MessageBox.Show("Total active accounts:" + GLAccountSummaryList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLFixedAllocationAccountByKey

Description

Retrieves a single general ledger fixed allocation account object based on the key value supplied.

Parameters

Parameter | Type | Description
key | GLAccountNumberKey | A general ledger account number key object that specifies the GL fixed allocation account to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLFixedAllocationAccountByKeyResult | GLFixedAllocationAccount | A GL fixed allocation account object.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the general ledger fixed allocation account with the key value “000-6190-00”. The description of the account is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLFixedAllocationAccount fixedAllocationAccount;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account key to specify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-6190-00";

            // Retrieve the specified fixed allocation account object
            fixedAllocationAccount = wsDynamicsGP.GetGLFixedAllocationAccountByKey(
            accountNumberKey, context);

            // Display the account object's description property
            MessageBox.Show("Account description: " + fixedAllocationAccount.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLFixedAllocationAccount fixedAllocationAccount;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account key to specify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-6190-00";

            // Retrieve the specified fixed allocation account object
            fixedAllocationAccount = wsDynamicsGP.GetGLFixedAllocationAccountByKey(
            accountNumberKey, context);

            // Display the account object's description property
            MessageBox.Show("Account description: " + fixedAllocationAccount.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLFixedAllocationAccountList

Description

Retrieves a list of general ledger fixed allocation account summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | GLFixedAllocationAccountCriteria | The GL fixed allocation account criteria object that specifies which fixed allocation account summaries are to be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLFixedAllocationAccountListResult | ArrayOfGLFixedAllocationAccountSummary | A list of the GL fixed allocation account summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the list of all active GL fixed allocation accounts and displays each account’s description in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            RestrictionOfNullableOfBoolean activeRestriction;
            GLFixedAllocationAccountCriteria fixedAllocationAccountCriteria;
            GLFixedAllocationAccountSummary[] fixedAllocationAccountSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all active GL fixed allocation account
            activeRestriction = new RestrictionOfNullableOfBoolean();
            activeRestriction.EqualValue = true;

            // Create a GL fixed allocation account criteria object
            fixedAllocationAccountCriteria = new GLFixedAllocationAccountCriteria();
            fixedAllocationAccountCriteria.IsActive = activeRestriction;

            // Retrieve the GL fixed allocation account summaries
            fixedAllocationAccountSummary = wsDynamicsGP.GetGLFixedAllocationAccountList(
            fixedAllocationAccountCriteria, context);

            // Display the description of each member of the summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLFixedAllocationAccountSummary a in fixedAllocationAccountSummary)
            {
                summaryList.AppendLine("Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            RestrictionOfNullableOfboolean activeRestriction;
            GLFixedAllocationAccountCriteria fixedAllocationAccountCriteria;
            GLFixedAllocationAccountSummary[] fixedAllocationAccountSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all active GL fixed allocation account
            activeRestriction = new RestrictionOfNullableOfboolean();
            activeRestriction.EqualValue = true;

            // Create a GL fixed allocation account criteria object
            fixedAllocationAccountCriteria = new GLFixedAllocationAccountCriteria();
            fixedAllocationAccountCriteria.IsActive = activeRestriction;

            // Retrieve the GL fixed allocation account summaries
            fixedAllocationAccountSummary = wsDynamicsGP.GetGLFixedAllocationAccountList(
            fixedAllocationAccountCriteria, context);

            // Display the description of each member of the summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLFixedAllocationAccountSummary a in fixedAllocationAccountSummary)
            {
                summaryList.AppendLine("Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLPostedTransactionByKey

Description

Retrieves a single general ledger transaction object based on the key value supplied.

Parameters

Parameter | Type | Description
key | GLTransactionPostedKey | A GL transaction posted key object that specifies the GL transaction to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLPostedTransactionByKeyResult | GLTransaction | A GL transaction object.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves a single posted GL transaction. The example uses a GL posted transaction key object to retrieve the company’s first GL transaction. A message box displays the GL transaction’s reference and posted by properties.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLTransactionPostedKey transactionPostedKey;
            GLTransaction transaction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL transaction posted key to specify the transaction
            transactionPostedKey = new GLTransactionPostedKey();
            transactionPostedKey.JournalId = 1;
            transactionPostedKey.Date = new DateTime(2003, 12, 31);
            transactionPostedKey.FiscalYear = 2004;
            transactionPostedKey.RecurringTransactionSequence = 1;

            // Retrieve the GL transaction object
            transaction = wsDynamicsGP.GetGLPostedTransactionByKey(transactionPostedKey, context);

            // Display the reference and posted by properties of the transaction object
            MessageBox.Show("Reference: " + transaction.Reference + "  Posted by: " + transaction.PostedBy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLTransactionPostedKey transactionPostedKey;
            GLTransaction transaction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL transaction posted key to specify the transaction
            transactionPostedKey = new GLTransactionPostedKey();
            transactionPostedKey.JournalId = 1;
            transactionPostedKey.Date = new DateTime(2003, 12, 31);
            transactionPostedKey.FiscalYear = 2004;
            transactionPostedKey.RecurringTransactionSequence = 1;

            // Retrieve the GL transaction object
            transaction = wsDynamicsGP.GetGLPostedTransactionByKey(transactionPostedKey, context);

            // Display the reference and posted by properties of the transaction object
            MessageBox.Show("Reference: " + transaction.Reference + "  Posted by: " + transaction.PostedBy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLPostingAccountByKey

Description

Retrieves a single general ledger posting account object based on the key value supplied.

Parameters

Parameter | Type | Description
key | GLAccountNumberKey | A GL account number key object that specifies the GL posting account to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLPostingAccountByKeyResult | GLPostingAccount | A GL posting account object.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the GL posting account with the key value “000-1100-00”. The description of the account is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLPostingAccount postingAccount;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key to specify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-1100-00";

            // Retrieve the posting account object
            postingAccount = wsDynamicsGP.GetGLPostingAccountByKey(accountNumberKey, context);

            // Display the posting account description in a message box
            MessageBox.Show("Description: " + postingAccount.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLPostingAccount postingAccount;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key to specify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-1100-00";

            // Retrieve the posting account object
            postingAccount = wsDynamicsGP.GetGLPostingAccountByKey(accountNumberKey, context);

            // Display the posting account description in a message box
            MessageBox.Show("Description: " + postingAccount.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLPostingAccountList

Description

Retrieves a list of general ledger posting account summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | GLPostingAccountCriteria | The GL posting account criteria object that specifies which posting account summaries are to be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLPostingAccountListResult | ArrayOfGLPostingAccountSummary | A list of the GL posting account summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the list of GL posting accounts with an account category of “Cash”. A message box displays the description property for each account.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString accountCategoryRestriction;
            GLPostingAccountCriteria postingAccountCriteria;
            GLPostingAccountSummary[] postingAccountSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all the posting accounts in the Cash category
            accountCategoryRestriction = new LikeRestrictionOfString();
            accountCategoryRestriction.EqualValue = "Cash";

            // Create a GL posting account criteria object
            postingAccountCriteria = new GLPostingAccountCriteria();
            postingAccountCriteria.GLAccountCategoryId = accountCategoryRestriction;

            // Retrieve the list of GL posting summary objects
            postingAccountSummaries = wsDynamicsGP.GetGLPostingAccountList(postingAccountCriteria, context);

            // Display the description of each member of the summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLPostingAccountSummary a in postingAccountSummaries)
            {
                summaryList.AppendLine("Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring accountCategoryRestriction;
            GLPostingAccountCriteria postingAccountCriteria;
            GLPostingAccountSummary[] postingAccountSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all the posting accounts in the Cash category
            accountCategoryRestriction = new LikeRestrictionOfstring();
            accountCategoryRestriction.EqualValue = "Cash";

            // Create a GL posting account criteria object
            postingAccountCriteria = new GLPostingAccountCriteria();
            postingAccountCriteria.GLAccountCategoryId = accountCategoryRestriction;

            // Retrieve the list of GL posting summary objects
            postingAccountSummaries = wsDynamicsGP.GetGLPostingAccountList(postingAccountCriteria, context);

            // Display the description of each member of the summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLPostingAccountSummary a in postingAccountSummaries)
            {
                summaryList.AppendLine("Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLTransactionByKey

Description

Retrieves a single general ledger transaction object based on the key value supplied.

Parameters

Parameter | Type | Description
key | GLTransactionKey | A GL transaction key object that specifies the GL transaction to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLTransactionByKeyResult | GLTransaction | A GL transaction object.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the GL transaction.with the journal Id value of “3327” and a transaction date of “4/21/2007”. The transaction’s source document value is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DateTime transactionDate;
            GLTransactionKey transactionKey;
            GLTransaction transaction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a data object
            // Specify the date of the transaction
            transactionDate = new DateTime(2007, 4, 21);

            // Create a GL transaction key to specify the transaction
            transactionKey = new GLTransactionKey();
            transactionKey.JournalId = 3327;
            transactionKey.Date = transactionDate;

            // Retrieve the GL transaction object
            transaction = wsDynamicsGP.GetGLTransactionByKey(transactionKey, context);

            // Display the source document of the transaction
            MessageBox.Show("Source document: " + transaction.SourceDocumentKey.Id);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DateTime transactionDate;
            GLTransactionKey transactionKey;
            GLTransaction transaction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a data object
            // Specify the date of the transaction
            transactionDate = new DateTime(2007, 4, 21);

            // Create a GL transaction key to specify the transaction
            transactionKey = new GLTransactionKey();
            transactionKey.JournalId = 3327;
            transactionKey.Date = transactionDate;

            // Retrieve the GL transaction object
            transaction = wsDynamicsGP.GetGLTransactionByKey(transactionKey, context);

            // Display the source document of the transaction
            MessageBox.Show("Source document: " + transaction.SourceDocumentKey.Id);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLTransactionList

Description

Retrieves a list of general ledger transaction summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | GLTransactionCriteria | The GL transaction criteria object that specifies which GL transaction summaries are to be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLTransactionListResult | ArrayOfGLTransactionSummary | A list of the GL transaction summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the list of GL transaction with a transaction state of “Work” and a batch Id of “PMCHK”. A message box displays the journal Id and reference properties for each transaction.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfGLTransactionState transactionStateRestriction;
            LikeRestrictionOfString batchRestriction;
            GLTransactionCriteria transactionCriteria;
            GLTransactionSummary[] transactionSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create two restriction object
            // Retrieve GL transactions with a transaction state of 'Work'
            transactionStateRestriction = new ListRestrictionOfNullableOfGLTransactionState();
            transactionStateRestriction.EqualValue = GLTransactionState.Work;

            // Retrieve GL transactions with the batch Id of 'PMCHK'
            batchRestriction = new LikeRestrictionOfString();
            batchRestriction.EqualValue = "PMCHK";

            // Create the criteria object
            transactionCriteria = new GLTransactionCriteria();
            transactionCriteria.TransactionState = transactionStateRestriction;
            transactionCriteria.BatchId = batchRestriction;

            // Retrieve the list of GL transaction summary objects
            transactionSummaries = wsDynamicsGP.GetGLTransactionList(transactionCriteria, context);

            // Display the journal ID and reference property for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLTransactionSummary a in transactionSummaries)
            {
                summaryList.AppendLine("Journal Id: " + a.Key.JournalId + "  Reference: " +
                a.Reference);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfGLTransactionState transactionStateRestriction;
            LikeRestrictionOfstring batchRestriction;
            GLTransactionCriteria transactionCriteria;
            GLTransactionSummary[] transactionSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create two restriction object
            // Retrieve GL transactions with a transaction state of 'Work'
            transactionStateRestriction = new ListRestrictionOfNullableOfGLTransactionState();
            transactionStateRestriction.EqualValue = GLTransactionState.Work;

            // Retrieve GL transactions with the batch Id of 'PMCHK'
            batchRestriction = new LikeRestrictionOfstring();
            batchRestriction.EqualValue = "PMCHK";

            // Create the criteria object
            transactionCriteria = new GLTransactionCriteria();
            transactionCriteria.TransactionState = transactionStateRestriction;
            transactionCriteria.BatchId = batchRestriction;

            // Retrieve the list of GL transaction summary objects
            transactionSummaries = wsDynamicsGP.GetGLTransactionList(transactionCriteria, context);

            // Display the journal ID and reference property for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLTransactionSummary a in transactionSummaries)
            {
                summaryList.AppendLine("Journal Id: " + a.Key.JournalId + "  Reference: " +
                a.Reference);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLUnitAccountByKey

Description

Retrieves a single general ledger unit account object based on the key value supplied.

Parameters

Parameter | Type | Description
key | GLAccountNumberKey | A GL account number key object that specifies the GL unit account to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLUnitAccountByKeyResult | GLUnitAccount | A GL unit account object.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the GL unit account with the key value “000-9010-00”. The description of the account is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLUnitAccount unitAccount;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key to specify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "100-9010-00";

            // Retrieve the GL unit account object
            unitAccount = wsDynamicsGP.GetGLUnitAccountByKey(accountNumberKey, context);

            // Display the description property from the unit account
            MessageBox.Show("Description: " + unitAccount.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLUnitAccount unitAccount;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key to specify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "100-9010-00";

            // Retrieve the GL unit account object
            unitAccount = wsDynamicsGP.GetGLUnitAccountByKey(accountNumberKey, context);

            // Display the description property from the unit account
            MessageBox.Show("Description: " + unitAccount.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLUnitAccountList

Description

Retrieves a list of general ledger unit account summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | GLUnitAccountCriteria | The GL unit account criteria object that specifies which unit account summaries are to be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLUnitAccountListResult | ArrayOfGLUnitAccountSummary | A list of the GL unit account summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the list of GL unit accounts with an account number containing “9010”. A message box displays the account number and description from each member of the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString accountIdRestriction;
            GLUnitAccountCriteria unitAccountCriteria;
            GLUnitAccountSummary[] unitAccountSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            accountIdRestriction = new LikeRestrictionOfString();
            accountIdRestriction.Like = "%9010%";

            // Create a GL unit account criteria object
            unitAccountCriteria = new GLUnitAccountCriteria();
            unitAccountCriteria.GLAccountId = accountIdRestriction;

            // Retrieve the list of GL unit account summary objects
            unitAccountSummaries = wsDynamicsGP.GetGLUnitAccountList(unitAccountCriteria, context);

            // Display the account number and description of each member of the summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLUnitAccountSummary a in unitAccountSummaries)
            {
                summaryList.AppendLine("Account: " + a.Key.Id + "  Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring accountIdRestriction;
            GLUnitAccountCriteria unitAccountCriteria;
            GLUnitAccountSummary[] unitAccountSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            accountIdRestriction = new LikeRestrictionOfstring();
            accountIdRestriction.Like = "%9010%";

            // Create a GL unit account criteria object
            unitAccountCriteria = new GLUnitAccountCriteria();
            unitAccountCriteria.GLAccountId = accountIdRestriction;

            // Retrieve the list of GL unit account summary objects
            unitAccountSummaries = wsDynamicsGP.GetGLUnitAccountList(unitAccountCriteria, context);

            // Display the account number and description of each member of the summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLUnitAccountSummary a in unitAccountSummaries)
            {
                summaryList.AppendLine("Account: " + a.Key.Id + "  Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLVariableAllocationAccountByKey

Description

Retrieves a single general ledger variable allocation account object based on the key value supplied.

Parameters

Parameter | Type | Description
key | GLAccountNumberKey | A GL account number key object that specifies the GL variable allocation account to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLVariableAllocationAccountByKeyResult | GLVariableAllocationAccount | A GL variable allocation account object.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the GL variable allocation account with the key value “000-6180-00”. The description of the account is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLVariableAllocationAccount variableAllocationAccount;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key to specify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-6180-00";

            // Retrieve the GL variable allocation account object
            variableAllocationAccount = wsDynamicsGP.GetGLVariableAllocationAccountByKey(
            accountNumberKey, context);

            // Display the description property from the variable allocation account
            MessageBox.Show("Account: " + variableAllocationAccount.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            GLAccountNumberKey accountNumberKey;
            GLVariableAllocationAccount variableAllocationAccount;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a GL account number key to specify the account
            accountNumberKey = new GLAccountNumberKey();
            accountNumberKey.Id = "000-6180-00";

            // Retrieve the GL variable allocation account object
            variableAllocationAccount = wsDynamicsGP.GetGLVariableAllocationAccountByKey(
            accountNumberKey, context);

            // Display the description property from the variable allocation account
            MessageBox.Show("Account: " + variableAllocationAccount.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetGLVariableAllocationAccountList

Description

Retrieves a list of general ledger variable allocation account summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | GLVariableAllocationAccountCriteria | The GL variable allocation account criteria object that specifies which variable allocation account summaries are to be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetGLVariableAllocationAccountListResult | ArrayOfGLVariableAllocationAccountSummary | A list of the GL variable allocation account summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Financials

Examples

The following C# example retrieves the list of GL variable allocation accounts created prior to 2006. A message box displays the account number and description of each member of the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DateTime date;
            BetweenRestrictionOfNullableOfDateTime dateRestriction;
            GLVariableAllocationAccountCriteria variableAllocationAccountCriteria;
            GLVariableAllocationAccountSummary[] variableAllocationAccountSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a datetime object
            date = new DateTime(2006, 1, 1);

            // Create a restriction object
            // Retrieve GL variable allocation accounts created before 2006
            dateRestriction = new BetweenRestrictionOfNullableOfDateTime();
            dateRestriction.LessThan = date;

            // Create a GL variable allocation account criteria object
            variableAllocationAccountCriteria = new GLVariableAllocationAccountCriteria();
            variableAllocationAccountCriteria.CreatedDate = dateRestriction;

            // Retrieve the list of GL variable allocation account summary objects
            variableAllocationAccountSummaries = wsDynamicsGP.GetGLVariableAllocationAccountList(
            variableAllocationAccountCriteria, context);

            // Display the account number and description of each member of the summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLVariableAllocationAccountSummary a in variableAllocationAccountSummaries)
            {
                summaryList.AppendLine("Account: " + a.Key.Id + "  Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DateTime date;
            BetweenRestrictionOfNullableOfdateTime dateRestriction;
            GLVariableAllocationAccountCriteria variableAllocationAccountCriteria;
            GLVariableAllocationAccountSummary[] variableAllocationAccountSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a datetime object
            date = new DateTime(2006, 1, 1);

            // Create a restriction object
            // Retrieve GL variable allocation accounts created before 2006
            dateRestriction = new BetweenRestrictionOfNullableOfdateTime();
            dateRestriction.LessThan = date;

            // Create a GL variable allocation account criteria object
            variableAllocationAccountCriteria = new GLVariableAllocationAccountCriteria();
            variableAllocationAccountCriteria.CreatedDate = dateRestriction;

            // Retrieve the list of GL variable allocation account summary objects
            variableAllocationAccountSummaries = wsDynamicsGP.GetGLVariableAllocationAccountList(
            variableAllocationAccountCriteria, context);

            // Display the account number and description of each member of the summary list
            StringBuilder summaryList = new StringBuilder();
            foreach (GLVariableAllocationAccountSummary a in variableAllocationAccountSummaries)
            {
                summaryList.AppendLine("Account: " + a.Key.Id + "  Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetHRRequisitionByKey

Description

Retrieves a single HR requisition object based on the key value supplied.

Parameters

Parameter | Type | Description
key | HRRequisitionNumberKey | A HR requisition number key object that specifies the requisition object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetHRRequisitionByKeyResult | HRRequisition | An HR requisition object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the HR requisition with the key value “1”. The department and status for the requisition are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            HRRequisitionNumberKey requisitionNumberKey;
            HRRequisition requisition;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a requisition number key
            requisitionNumberKey = new HRRequisitionNumberKey();
            requisitionNumberKey.Id = "1";

            // Get the specified requisition object
            requisition = wsDynamicsGP.GetHRRequisitionByKey(requisitionNumberKey, context);

            // Display the status of the requisition
            MessageBox.Show("Department: " + requisition.DepartmentKey.Id + "   Status: " + requisition.Status);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            HRRequisitionNumberKey requisitionNumberKey;
            HRRequisition requisition;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a requisition number key
            requisitionNumberKey = new HRRequisitionNumberKey();
            requisitionNumberKey.Id = "1";

            // Get the specified requisition object
            requisition = wsDynamicsGP.GetHRRequisitionByKey(requisitionNumberKey, context);

            // Display the status of the requisition
            MessageBox.Show("Department: " + requisition.DepartmentKey.Id + "   Status: " + requisition.Status);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetHRRequisitionList

Description

Retrieves a list of HR requisition summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | HRRequisitionCriteria | The HR requisition criteria object that specifies which HR requisition summaries are to be retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetHRRequisitionListResult | ArrayOfHRRequisitionSummary | A list of the HR requisition summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of HR requsitions with status other than “Closed”. A message box displays the number of requisition summary objects in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfHRRequisitionStatus statusRestriction;
            HRRequisitionCriteria requisitionCriteria;
            HRRequisitionSummary[] requisitionList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a requisition criteria object
            statusRestriction = new ListRestrictionOfNullableOfHRRequisitionStatus();
            statusRestriction.NotEqualValue = HRRequisitionStatus.Closed;
            requisitionCriteria = new HRRequisitionCriteria();
            requisitionCriteria.Status = statusRestriction;

            // Get the list of requisition summary objects
            requisitionList = wsDynamicsGP.GetHRRequisitionList(requisitionCriteria, context);

            // Display the number of requisitions that are not closed
            MessageBox.Show("Number of requisiton with status other than Closed: " +
                requisitionList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfHRRequisitionStatus statusRestriction;
            HRRequisitionCriteria requisitionCriteria;
            HRRequisitionSummary[] requisitionList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a requisition criteria object
            statusRestriction = new ListRestrictionOfNullableOfHRRequisitionStatus();
            statusRestriction.NotEqualValue = HRRequisitionStatus.Closed;
            requisitionCriteria = new HRRequisitionCriteria();
            requisitionCriteria.Status = statusRestriction;

            // Get the list of requisition summary objects
            requisitionList = wsDynamicsGP.GetHRRequisitionList(requisitionCriteria, context);

            // Display the number of requisitions that are not closed
            MessageBox.Show("Number of requisiton with status other than Closed: " +
                requisitionList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetInventoriedItemByKey

Description

Retrieves a single inventoried item object based on the item key value supplied. Kit objects and SalesItem objects can also be retrieved using this method. For Kit and SalesItem objects, you must cast the object returned from the method to the appropriate object type.

Parameters

Parameter | Type | Description
key | ItemKey | An item key object that specifies the inventoried item to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetInventoriedItemByKeyResult | InventoriedItem | An inventoried item object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the inventoried item with the item key “40X IDE”. A message box displays the inventoried item’s description property.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            InventoriedItem inventoriedItem;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the inventory item
            itemKey = new ItemKey();
            itemKey.Id = "40X IDE";

            // Retrieve the inventoried item object
            inventoriedItem = wsDynamicsGP.GetInventoriedItemByKey(itemKey, context);

            // Display the description from the inventoried item object
            MessageBox.Show("Inventory item description: " + inventoriedItem.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            InventoriedItem inventoriedItem;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the inventory item
            itemKey = new ItemKey();
            itemKey.Id = "40X IDE";

            // Retrieve the inventoried item object
            inventoriedItem = wsDynamicsGP.GetInventoriedItemByKey(itemKey, context);

            // Display the description from the inventoried item object
            MessageBox.Show("Inventory item description: " + inventoriedItem.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}

The following C# example retrieves the inventoried items in the “RETAIL” class. It then examines the type of each inventoried item to find out whether it is a sales item or a kit. The GetInventoriedItemByKey() method is used to retrieve the item. Note how the return value of the method is cast to be either a SalesItem object or a Kit object. For SalesItem objects, the tracking option is displayed. For Kit objects, the number of components in the kit is displayed.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString classIdRestriction;
            InventoriedItemCriteria inventoryItemCriteria;
            InventoriedItemSummary[] inventoryItemSummaries;
            Kit kit;
            SalesItem salesItem;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Get items in the RETAIL class
            classIdRestriction = new LikeRestrictionOfString();
            classIdRestriction.EqualValue = "RETAIL";

            // Create the inventoried item criteria object
            inventoryItemCriteria = new InventoriedItemCriteria();
            inventoryItemCriteria.ItemClassId = classIdRestriction;

            // Retrieve the list of inventoried item summary objects
            inventoryItemSummaries = wsDynamicsGP.GetInventoriedItemList(inventoryItemCriteria, context);

            // Display a description of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoriedItemSummary a in inventoryItemSummaries)
            {
                // Include the description of the item
                Console.WriteLine("Inventory item description: " + a.Description);

                // Is the item a sales item?
                if (a.Type == InventoriedItemType.SalesItem)
                {
                    // Retrieve the inventoried item and cast it to SalesItem so the sales item
                    // properties can be retrieved
                    salesItem = (SalesItem)wsDynamicsGP.GetInventoriedItemByKey(a.Key, context);

                    // Include the RevalueInventory property, which is a SalesItem property
                    Console.WriteLine("   Tracking: " + salesItem.TrackingOption.ToString());
                }

                // Is the item a kit?
                if (a.Type == InventoriedItemType.Kit)
                {
                    // Retrieve the inventoried item and cast it to Kit so the kit properties
                    // can be retrieved
                    kit = (Kit)wsDynamicsGP.GetInventoriedItemByKey(a.Key, context);

                    // Include the quantity of kit components
                    Console.WriteLine("    Number of components: " + kit.Components.Length.ToString());
                }
            }

            Console.ReadLine();
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring classIdRestriction;
            InventoriedItemCriteria inventoryItemCriteria;
            InventoriedItemSummary[] inventoryItemSummaries;
            Kit kit;
            SalesItem salesItem;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Get items in the RETAIL class
            classIdRestriction = new LikeRestrictionOfstring();
            classIdRestriction.EqualValue = "RETAIL";

            // Create the inventoried item criteria object
            inventoryItemCriteria = new InventoriedItemCriteria();
            inventoryItemCriteria.ItemClassId = classIdRestriction;

            // Retrieve the list of inventoried item summary objects
            inventoryItemSummaries = wsDynamicsGP.GetInventoriedItemList(inventoryItemCriteria, context);

            // Display a description of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoriedItemSummary a in inventoryItemSummaries)
            {
                // Include the description of the item
                Console.WriteLine("Inventory item description: " + a.Description);

                // Is the item a sales item?
                if (a.Type == InventoriedItemType.SalesItem)
                {
                    // Retrieve the inventoried item and cast it to SalesItem so the sales item
                    // properties can be retrieved
                    salesItem = (SalesItem)wsDynamicsGP.GetInventoriedItemByKey(a.Key, context);

                    // Include the RevalueInventory property, which is a SalesItem property
                    Console.WriteLine("   Tracking: " + salesItem.TrackingOption.ToString());
                }

                // Is the item a kit?
                if (a.Type == InventoriedItemType.Kit)
                {
                    // Retrieve the inventoried item and cast it to Kit so the kit properties
                    // can be retrieved
                    kit = (Kit)wsDynamicsGP.GetInventoriedItemByKey(a.Key, context);

                    // Include the quantity of kit components
                    Console.WriteLine("    Number of components: " + kit.Components.Length.ToString());
                }
            }

            Console.ReadLine();

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetInventoriedItemList

Description

Retrieves a list of inventoried item summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | InventoriedItemCriteria | The inventoried item criteria object that specifies which inventoried item summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetInventoriedItemListResult | ArrayOfInventoriedItemSummary | A list of the inventoried item summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of inventoried item summary objects with a item class Id of “ATT CORD”. A message box displays the description of each member of the inventoried item summary objects list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString classIdRestriction;
            InventoriedItemCriteria inventoryItemCriteria;
            InventoriedItemSummary[] inventoryItemSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Get items with an item class Id of 'ATT CORD'
            classIdRestriction = new LikeRestrictionOfString();
            classIdRestriction.EqualValue = "ATT CORD";

            // Create the inventoried item criteria object
            inventoryItemCriteria = new InventoriedItemCriteria();
            inventoryItemCriteria.ItemClassId = classIdRestriction;

            // Retrieve the list of inventoried item summary objects
            inventoryItemSummaries = wsDynamicsGP.GetInventoriedItemList(inventoryItemCriteria, context);

            // Display a description of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoriedItemSummary a in inventoryItemSummaries)
            {
                summaryList.AppendLine("Inventory item description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring classIdRestriction;
            InventoriedItemCriteria inventoryItemCriteria;
            InventoriedItemSummary[] inventoryItemSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Get items with an item class Id of 'ATT CORD'
            classIdRestriction = new LikeRestrictionOfstring();
            classIdRestriction.EqualValue = "ATT CORD";

            // Create the inventoried item criteria object
            inventoryItemCriteria = new InventoriedItemCriteria();
            inventoryItemCriteria.ItemClassId = classIdRestriction;

            // Retrieve the list of inventoried item summary objects
            inventoryItemSummaries = wsDynamicsGP.GetInventoriedItemList(inventoryItemCriteria, context);

            // Display a description of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoriedItemSummary a in inventoryItemSummaries)
            {
                summaryList.AppendLine("Inventory item description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetInventoryAdjustmentByKey

Description

Retrieves a single inventory adjustment object based on the inventory key value supplied.

Parameters

Parameter | Type | Description
key | InventoryKey | An inventory key object that specifies the inventory adjustment object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetInventoryAdjustmentByKeyResult | InventoryAdjustment | An inventory adjustment object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the inventory adjustment with an inventory key equal to “ADJ00059000000000001”. A message box displays the inventory adjustment’s audit trail code property.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            InventoryKey inventoryKey;
            InventoryAdjustment inventoryAdjustment;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an inventory key to specify the inventory adjustment
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "ADJ00059000000000001";

            // Retrieve the inventory adjustment object
            inventoryAdjustment = wsDynamicsGP.GetInventoryAdjustmentByKey(inventoryKey, context);

            // Display the audit trail code property from the inventory adjustment object
            MessageBox.Show("Inventory adjustment audit trail code: " + inventoryAdjustment.AuditTrailCode);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            InventoryKey inventoryKey;
            InventoryAdjustment inventoryAdjustment;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an inventory key to specify the inventory adjustment
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "ADJ00059000000000001";

            // Retrieve the inventory adjustment object
            inventoryAdjustment = wsDynamicsGP.GetInventoryAdjustmentByKey(inventoryKey, context);

            // Display the audit trail code property from the inventory adjustment object
            MessageBox.Show("Inventory adjustment audit trail code: " + inventoryAdjustment.AuditTrailCode);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetInventoryAdjustmentList

Description

Retrieves a list of inventory adjustment summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | InventoryAdjustmentCriteria | The inventory adjustment criteria object that specifies which inventory adjustment summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetInventoryAdjustmentListResult | ArrayOfInventoryAdjustmentSummary | A list of the inventory adjustment summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of inventory adjustment summary objects where the inventory transaction state is equal to “Work”. A message box displays the batch assigned to each member of the inventory adjustment summary object list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfInventoryTransactionState inventoryTransactionStateRestriction;
            InventoryAdjustmentCriteria inventoryAdjustmentCriteria;
            InventoryAdjustmentSummary[] inventoryAdjustmentSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve only inventory adjustment with a transaction state of 'Work'
            inventoryTransactionStateRestriction = new
            ListRestrictionOfNullableOfInventoryTransactionState();
            inventoryTransactionStateRestriction.EqualValue = InventoryTransactionState.Work;

            // Create the inventory adjustment criteria object
            inventoryAdjustmentCriteria = new InventoryAdjustmentCriteria();
            inventoryAdjustmentCriteria.TransactionState = inventoryTransactionStateRestriction;

            // Retrieve the list of inventory adjustment summary objects
            inventoryAdjustmentSummaries = wsDynamicsGP.GetInventoryAdjustmentList(
            inventoryAdjustmentCriteria, context);

            // Display the batch ID for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoryAdjustmentSummary a in inventoryAdjustmentSummaries)
            {
                summaryList.AppendLine("Batch Id: " + a.BatchKey.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfInventoryTransactionState inventoryTransactionStateRestriction;
            InventoryAdjustmentCriteria inventoryAdjustmentCriteria;
            InventoryAdjustmentSummary[] inventoryAdjustmentSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve only inventory adjustment with a transaction state of 'Work'
            inventoryTransactionStateRestriction = new
            ListRestrictionOfNullableOfInventoryTransactionState();
            inventoryTransactionStateRestriction.EqualValue = InventoryTransactionState.Work;

            // Create the inventory adjustment criteria object
            inventoryAdjustmentCriteria = new InventoryAdjustmentCriteria();
            inventoryAdjustmentCriteria.TransactionState = inventoryTransactionStateRestriction;

            // Retrieve the list of inventory adjustment summary objects
            inventoryAdjustmentSummaries = wsDynamicsGP.GetInventoryAdjustmentList(
            inventoryAdjustmentCriteria, context);

            // Display the batch ID for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoryAdjustmentSummary a in inventoryAdjustmentSummaries)
            {
                summaryList.AppendLine("Batch Id: " + a.BatchKey.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetInventoryTransferByKey

Description

Retrieves a single inventory transfer object based on the inventory key value supplied.

Parameters

Parameter | Type | Description
key | InventoryKey | An inventory key object that specifies the inventory transfer object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetInventoryTransferByKeyResult | InventoryTransfer | An inventory transfer object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the inventory transfer object with an inventory key equal to “00000000000000002”. A message box displays the number of inventory transfer lines associated with the specified inventory transfer object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            InventoryKey inventoryKey;
            InventoryTransfer inventoryTransfer;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the inventory key object to specify the inventory transfer
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "00000000000000002";

            // Retrieve the inventory transfer object
            inventoryTransfer = wsDynamicsGP.GetInventoryTransferByKey(inventoryKey, context);

            // Display the number of line items for the inventory transfer object
            MessageBox.Show("Number of inventory transfer lines: " +
            inventoryTransfer.Lines.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            InventoryKey inventoryKey;
            InventoryTransfer inventoryTransfer;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the inventory key object to specify the inventory transfer
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "00000000000000002";

            // Retrieve the inventory transfer object
            inventoryTransfer = wsDynamicsGP.GetInventoryTransferByKey(inventoryKey, context);

            // Display the number of line items for the inventory transfer object
            MessageBox.Show("Number of inventory transfer lines: " +
            inventoryTransfer.Lines.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetInventoryTransferList

Description

Retrieves a list of inventory transfer summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | InventoryTransferCriteria | The inventory transfer criteria object that specifies which inventory transfer summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetInventoryTransferListResult | ArrayOfInventoryTransferSummary | A list of the inventory transfer summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of inventory transfer summary objects where the batch assigned to the inventory transfer begins with “TRANSFER”. A message box displays the document number for each inventory transfer in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString batchIdRestriction;
            InventoryTransferCriteria inventoryTransferCriteria;
            InventoryTransferSummary[] inventoryTransferSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all inventory transfers with a batch key that begins with 'TRANSFER'
            batchIdRestriction = new LikeRestrictionOfString();
            batchIdRestriction.Like = "TRANSFER%";

            // Create the inventory transfer criteria object
            inventoryTransferCriteria = new InventoryTransferCriteria();
            inventoryTransferCriteria.BatchId = batchIdRestriction;

            // Retrieve the list of inventory transfer summary objects
            inventoryTransferSummaries = wsDynamicsGP.GetInventoryTransferList(
            inventoryTransferCriteria, context);

            // Display the key Id property for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoryTransferSummary a in inventoryTransferSummaries)
            {
                summaryList.AppendLine("Inventory transfer document number: " + a.Key.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring batchIdRestriction;
            InventoryTransferCriteria inventoryTransferCriteria;
            InventoryTransferSummary[] inventoryTransferSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all inventory transfers with a batch key that begins with 'TRANSFER'
            batchIdRestriction = new LikeRestrictionOfstring();
            batchIdRestriction.Like = "TRANSFER%";

            // Create the inventory transfer criteria object
            inventoryTransferCriteria = new InventoryTransferCriteria();
            inventoryTransferCriteria.BatchId = batchIdRestriction;

            // Retrieve the list of inventory transfer summary objects
            inventoryTransferSummaries = wsDynamicsGP.GetInventoryTransferList(
            inventoryTransferCriteria, context);

            // Display the key Id property for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoryTransferSummary a in inventoryTransferSummaries)
            {
                summaryList.AppendLine("Inventory transfer document number: " + a.Key.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetInventoryVarianceByKey

Description

Retrieves a single inventory variance object based on the inventory key value supplied.

Parameters

Parameter | Type | Description
key | InventoryKey | An inventory key object that specifies the inventory variance object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetInventoryVarianceByKeyResult | InventoryVariance | An inventory variance object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the inventory variance object with a key of “ADJ00045”. A message box displays the site ID for the first inventory variance line associated with the specified inventory variance object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            InventoryKey inventoryKey;
            InventoryVariance inventoryVariance;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the inventory key object to specify the inventory variance
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "ADJ00045";

            // Retrieve the inventory variance object
            inventoryVariance = wsDynamicsGP.GetInventoryVarianceByKey(inventoryKey, context);

            // Display the location associated with the first line of the variance object
            MessageBox.Show("Location of the variance: " + inventoryVariance.Lines[0].WarehouseKey.Id);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            InventoryKey inventoryKey;
            InventoryVariance inventoryVariance;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the inventory key object to specify the inventory variance
            inventoryKey = new InventoryKey();
            inventoryKey.Id = "ADJ00045";

            // Retrieve the inventory variance object
            inventoryVariance = wsDynamicsGP.GetInventoryVarianceByKey(inventoryKey, context);

            // Display the location associated with the first line of the variance object
            MessageBox.Show("Location of the variance: " + inventoryVariance.Lines[0].WarehouseKey.Id);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetInventoryVarianceList

Description

Retrieves a list of inventory variance summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | InventoryVarianceCriteria | The inventory variance criteria object that specifies which inventory variance summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetInventoryVarianceListResult | ArrayOfInventoryVarianceSummary | A list of the inventory variance summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of inventory variance summary objects with a transaction state of “History”. A message box displays the variance document number and date for each inventory variance in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfInventoryTransactionState transactionStateRestriction;
            InventoryVarianceCriteria inventoryVarianceCriteria;
            InventoryVarianceSummary[] inventoryVarianceSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all inventory variance summary objects with a transaction state of 'History'
            transactionStateRestriction = new ListRestrictionOfNullableOfInventoryTransactionState();
            transactionStateRestriction.EqualValue = InventoryTransactionState.History;

            // Create an inventory variance criteria object
            inventoryVarianceCriteria = new InventoryVarianceCriteria();
            inventoryVarianceCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of inventory variance summary objects
            inventoryVarianceSummaries = wsDynamicsGP.GetInventoryVarianceList(
            inventoryVarianceCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoryVarianceSummary a in inventoryVarianceSummaries)
            {
                summaryList.AppendLine("Variance number: " + a.Key.Id + " Date: " +
                a.Date.Value.ToShortDateString());
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfInventoryTransactionState transactionStateRestriction;
            InventoryVarianceCriteria inventoryVarianceCriteria;
            InventoryVarianceSummary[] inventoryVarianceSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all inventory variance summary objects with a transaction state of 'History'
            transactionStateRestriction = new ListRestrictionOfNullableOfInventoryTransactionState();
            transactionStateRestriction.EqualValue = InventoryTransactionState.History;

            // Create an inventory variance criteria object
            inventoryVarianceCriteria = new InventoryVarianceCriteria();
            inventoryVarianceCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of inventory variance summary objects
            inventoryVarianceSummaries = wsDynamicsGP.GetInventoryVarianceList(
            inventoryVarianceCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (InventoryVarianceSummary a in inventoryVarianceSummaries)
            {
                summaryList.AppendLine("Variance number: " + a.Key.Id + " Date: " +
                a.Date.Value.ToShortDateString());
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemByKey

Description

Retrieves a single inventory item object based on the item key value supplied.

Parameters

Parameter | Type | Description
key | ItemKey | An item key object that specifies the item to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemByKeyResult | Item | An item object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the inventory item with the key value “128 SDRAM”. The item description is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            Item item;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Retrieve the item object
            item = wsDynamicsGP.GetItemByKey(itemKey, context);

            // Display the description property from the item object
            MessageBox.Show("Item description: " + item.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            Item item;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Retrieve the item object
            item = wsDynamicsGP.GetItemByKey(itemKey, context);

            // Display the description property from the item object
            MessageBox.Show("Item description: " + item.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemClassList

Description

Retrieves a list of inventory item class objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | ItemClassCriteria | The item class criteria object that specifies which item class objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemClassListResult | ArrayOfItemClass | A list of the item class objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of item classes with an item type equal to “SalesItem”. A message box displays the item class description of each member of the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfItemType itemTypeRestriction;
            ItemClassCriteria itemClassCriteria;
            ItemClass[] itemClasses;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve item classes with an item type of 'SalesItem'
            itemTypeRestriction = new ListRestrictionOfNullableOfItemType();
            itemTypeRestriction.EqualValue = ItemType.SalesItem;

            // Create a item class criteria object
            itemClassCriteria = new ItemClassCriteria();
            itemClassCriteria.Type = itemTypeRestriction;

            // Retrieve the list of item class objects
            itemClasses = wsDynamicsGP.GetItemClassList(itemClassCriteria, context);

            // Display the item class description of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ItemClass a in itemClasses)
            {
                summaryList.AppendLine("Item class: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfItemType itemTypeRestriction;
            ItemClassCriteria itemClassCriteria;
            ItemClass[] itemClasses;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve item classes with an item type of 'SalesItem'
            itemTypeRestriction = new ListRestrictionOfNullableOfItemType();
            itemTypeRestriction.EqualValue = ItemType.SalesItem;

            // Create a item class criteria object
            itemClassCriteria = new ItemClassCriteria();
            itemClassCriteria.Type = itemTypeRestriction;

            // Retrieve the list of item class objects
            itemClasses = wsDynamicsGP.GetItemClassList(itemClassCriteria, context);

            // Display the item class description of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ItemClass a in itemClasses)
            {
                summaryList.AppendLine("Item class: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemCurrencyByKey

Description

Retrieves a single item currency object based on the item currency key value supplied.

Parameters

Parameter | Type | Description
key | ItemCurrencyKey | An item currency key object that specifies the item currency object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemCurrencyByKeyResult | ItemCurrency | An item currency object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the item currency with the item key value of “128 SDRAM”. The item currency ISO code is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            ItemCurrencyKey itemCurrencyKey;
            ItemCurrency itemCurrency;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a Currency object
            CurrencyKey currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "USD";

            // Create a item currency key object to specify the item currency
            itemCurrencyKey = new ItemCurrencyKey();
            itemCurrencyKey.ItemKey = itemKey;
            itemCurrencyKey.CurrencyKey = currencyKey;

            // Retrieve the item currency object
            itemCurrency = wsDynamicsGP.GetItemCurrencyByKey(itemCurrencyKey, context);

            // Display the Currency ISO Code property for the item currency object
            MessageBox.Show("Currency ISO code: " + itemCurrency.Key.CurrencyKey.ISOCode.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            ItemCurrencyKey itemCurrencyKey;
            ItemCurrency itemCurrency;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a Currency object
            CurrencyKey currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "USD";

            // Create a item currency key object to specify the item currency
            itemCurrencyKey = new ItemCurrencyKey();
            itemCurrencyKey.ItemKey = itemKey;
            itemCurrencyKey.CurrencyKey = currencyKey;

            // Retrieve the item currency object
            itemCurrency = wsDynamicsGP.GetItemCurrencyByKey(itemCurrencyKey, context);

            // Display the Currency ISO Code property for the item currency object
            MessageBox.Show("Currency ISO code: " + itemCurrency.Key.CurrencyKey.ISOCode.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemCurrencyList

Description

Retrieves a list of item currency objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | ItemCurrencyCriteria | The item currency criteria object that specifies which item currency objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemCurrencyListResult | ArrayOfItemCurrency | A list of the item curency objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of item currency objects with an ItemId containing “SDRam”. A message box displays the item ID and the currency ISO code for each member of the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString itemRestriction;
            ItemCurrencyCriteria itemCurrencyCriteria;
            ItemCurrency[] itemCurrencies;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve items containing string 'SDRam'
            itemRestriction = new LikeRestrictionOfString();
            itemRestriction.Like = "%SDRam%";

            // Create an item currency criteria object
            itemCurrencyCriteria = new ItemCurrencyCriteria();
            itemCurrencyCriteria.ItemId = itemRestriction;

            // Retrieve the list of item currency objects
            itemCurrencies = wsDynamicsGP.GetItemCurrencyList(itemCurrencyCriteria, context);

            // Display the item ID and currency ISO code for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ItemCurrency a in itemCurrencies)
            {
                summaryList.AppendLine("Item: " + a.Key.ItemKey.Id +
                "  Currency ISO code: " + a.Key.CurrencyKey.ISOCode.ToString());
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring itemRestriction;
            ItemCurrencyCriteria itemCurrencyCriteria;
            ItemCurrency[] itemCurrencies;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve items containing string 'SDRam'
            itemRestriction = new LikeRestrictionOfstring();
            itemRestriction.Like = "%SDRam%";

            // Create an item currency criteria object
            itemCurrencyCriteria = new ItemCurrencyCriteria();
            itemCurrencyCriteria.ItemId = itemRestriction;

            // Retrieve the list of item currency objects
            itemCurrencies = wsDynamicsGP.GetItemCurrencyList(itemCurrencyCriteria, context);

            // Display the item ID and currency ISO code for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ItemCurrency a in itemCurrencies)
            {
                summaryList.AppendLine("Item: " + a.Key.ItemKey.Id +
                "  Currency ISO code: " + a.Key.CurrencyKey.ISOCode.ToString());
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemList

Description

Retrieves a list of inventory items that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | ItemCriteria | The item criteria object that specifies which item objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemListResult | ArrayOfItemSummary | A list of the item summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of item summary objects with an item class ID equal to “CATALOG”. A message box displays the item ID and the description of each member of the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString itemClassIdRestriction;
            ItemCriteria itemCriteria;
            ItemSummary[] itemSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all items in the CATALOG class
            itemClassIdRestriction = new LikeRestrictionOfString();
            itemClassIdRestriction.EqualValue = "CATALOG";

            // Create a item criteria object
            itemCriteria = new ItemCriteria();
            itemCriteria.ItemClassId = itemClassIdRestriction;

            // Retrieve the list of item summary objects
            itemSummaries = wsDynamicsGP.GetItemList(itemCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ItemSummary a in itemSummaries)
            {
                summaryList.AppendLine("Item: " + a.Key.Id + "  Description: " +
                a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring itemClassIdRestriction;
            ItemCriteria itemCriteria;
            ItemSummary[] itemSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all items in the CATALOG class
            itemClassIdRestriction = new LikeRestrictionOfstring();
            itemClassIdRestriction.EqualValue = "CATALOG";

            // Create a item criteria object
            itemCriteria = new ItemCriteria();
            itemCriteria.ItemClassId = itemClassIdRestriction;

            // Retrieve the list of item summary objects
            itemSummaries = wsDynamicsGP.GetItemList(itemCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ItemSummary a in itemSummaries)
            {
                summaryList.AppendLine("Item: " + a.Key.Id + "  Description: " +
                a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemVendorByKey

Description

Retrieves a single item vendor object based on the item vendor key value supplied.

Parameters

Parameter | Type | Description
key | ItemVendorKey | An item vendor key object that specifies the item vendor object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemVendorByKeyResult | ItemVendor | An item vendor object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the item vendor with an item key value of “100XLG” and a vendor key value of “ACETRAVE0001”. The item description is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            VendorKey vendorKey;
            ItemVendorKey itemVendorKey;
            ItemVendor itemVendor;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "100XLG";

            // Create a vendor key to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create an item vendor key object
            itemVendorKey = new ItemVendorKey();
            itemVendorKey.ItemKey = itemKey;
            itemVendorKey.VendorKey = vendorKey;

            // Retrieve the item vendor object
            itemVendor = wsDynamicsGP.GetItemVendorByKey(itemVendorKey, context);

            // Display the item description
            MessageBox.Show("Item description: " + itemVendor.VendorItemDescription);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            VendorKey vendorKey;
            ItemVendorKey itemVendorKey;
            ItemVendor itemVendor;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "100XLG";

            // Create a vendor key to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create an item vendor key object
            itemVendorKey = new ItemVendorKey();
            itemVendorKey.ItemKey = itemKey;
            itemVendorKey.VendorKey = vendorKey;

            // Retrieve the item vendor object
            itemVendor = wsDynamicsGP.GetItemVendorByKey(itemVendorKey, context);

            // Display the item description
            MessageBox.Show("Item description: " + itemVendor.VendorItemDescription);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemVendorList

Description

Retrieves a list of item vendor summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | ItemVendorCriteria | The item vendor criteria object that specifies which item vendor summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemVendorListResult | ArrayOfItemVendorSummary | A list of the item vendor summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of item vendor summary objects for the vendor with a key of “ACETRAVE0001”. The example lists all items supplied by the specified vendor. A message box displays the vendor’s item description for each member of the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString vendorRestriction;
            LikeRestrictionOfString itemRestriction;
            ItemVendorCriteria itemVendorCriteria;
            ItemVendorSummary[] itemVendorSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object for vendor
            // Specify a single vendor
            vendorRestriction = new LikeRestrictionOfString();
            vendorRestriction.EqualValue = "ACETRAVE0001";

            // Create a restriction object for items
            // Get all available items
            itemRestriction = new LikeRestrictionOfString();
            itemRestriction.Like = "%";

            // Create an item vendor criteria object
            itemVendorCriteria = new ItemVendorCriteria();
            itemVendorCriteria.VendorId = vendorRestriction;
            itemVendorCriteria.ItemId = itemRestriction;

            // Retrieve the list of item vendor summary objects
            itemVendorSummaries = wsDynamicsGP.GetItemVendorList(itemVendorCriteria, context);

            // Display the item description property of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach(ItemVendorSummary a in itemVendorSummaries)
            {
                summaryList.AppendLine("Item description: " + a.VendorItemDescription);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring vendorRestriction;
            LikeRestrictionOfstring itemRestriction;
            ItemVendorCriteria itemVendorCriteria;
            ItemVendorSummary[] itemVendorSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object for vendor
            // Specify a single vendor
            vendorRestriction = new LikeRestrictionOfstring();
            vendorRestriction.EqualValue = "ACETRAVE0001";

            // Create a restriction object for items
            // Get all available items
            itemRestriction = new LikeRestrictionOfstring();
            itemRestriction.Like = "%";

            // Create an item vendor criteria object
            itemVendorCriteria = new ItemVendorCriteria();
            itemVendorCriteria.VendorId = vendorRestriction;
            itemVendorCriteria.ItemId = itemRestriction;

            // Retrieve the list of item vendor summary objects
            itemVendorSummaries = wsDynamicsGP.GetItemVendorList(itemVendorCriteria, context);

            // Display the item description property of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach(ItemVendorSummary a in itemVendorSummaries)
            {
                summaryList.AppendLine("Item description: " + a.VendorItemDescription);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemWarehouseByKey

Description

Retrieves a single item warehouse object based on the item warehouse key value supplied.

Parameters

Parameter | Type | Description
key | ItemWarehouseKey | An item warehouse key object that specifies the item warehouse object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemWarehouseByKeyResult | ItemWarehouse | An item warehouse object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the item warehouse with an item key value of “128 SDRAM” and a warehouse key value of “North”. The requisitioned quantity value is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            WarehouseKey warehouseKey;
            ItemWarehouseKey itemWarehouseKey;
            ItemWarehouse itemWarehouse;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a warehouse key to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "North";

            // Create an item warehouse key
            itemWarehouseKey = new ItemWarehouseKey();
            itemWarehouseKey.ItemKey = itemKey;
            itemWarehouseKey.WarehouseKey = warehouseKey;

            // Retrieve the item warehouse object
            itemWarehouse = wsDynamicsGP.GetItemWarehouseByKey(itemWarehouseKey, context);

            // Display the requisitioned amount
            MessageBox.Show("Requisitioned quantity: " +
            itemWarehouse.RequisitionedQuantity.Value.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            WarehouseKey warehouseKey;
            ItemWarehouseKey itemWarehouseKey;
            ItemWarehouse itemWarehouse;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "128 SDRAM";

            // Create a warehouse key to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "North";

            // Create an item warehouse key
            itemWarehouseKey = new ItemWarehouseKey();
            itemWarehouseKey.ItemKey = itemKey;
            itemWarehouseKey.WarehouseKey = warehouseKey;

            // Retrieve the item warehouse object
            itemWarehouse = wsDynamicsGP.GetItemWarehouseByKey(itemWarehouseKey, context);

            // Display the requisitioned amount
            MessageBox.Show("Requisitioned quantity: " +
            itemWarehouse.RequisitionedQuantity.Value.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetItemWarehouseList

Description

Retrieves a list of item warehouse summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | ItemWarehouseCriteria | The item warehouse criteria object that specifies which item warehouse summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetItemWarehouseListResult | ArrayOfItemWarehouseSummary | A list of the item warehouse summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of item warehouse summary objects with a warehouse key of “North” and an item key containing “SDRAM”. A message box displays the item ID for each member of the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString itemCriteria;
            LikeRestrictionOfString warehouseCriteria;
            ItemWarehouseCriteria itemWarehouseCriteria;
            ItemWarehouseSummary[] itemWarehouseSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve items with a key which contains 'SDRAM'
            itemCriteria = new LikeRestrictionOfString();
            itemCriteria.Like = "%SDRAM%";

            // Create a restriction object
            // Retrieve only items from the warehouse with a key of 'North'
            warehouseCriteria = new LikeRestrictionOfString();
            warehouseCriteria.EqualValue = "North";

            // Create an item warehouse criteria object
            itemWarehouseCriteria = new ItemWarehouseCriteria();
            itemWarehouseCriteria.ItemId = itemCriteria;
            itemWarehouseCriteria.WarehouseId = warehouseCriteria;

            // Retrieve the list if item warehouse summary objects
            itemWarehouseSummaries = wsDynamicsGP.GetItemWarehouseList(itemWarehouseCriteria, context);

            // Display the item ID of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ItemWarehouseSummary a in itemWarehouseSummaries)
            {
                summaryList.AppendLine("Item: " + a.Key.ItemKey.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring itemCriteria;
            LikeRestrictionOfstring warehouseCriteria;
            ItemWarehouseCriteria itemWarehouseCriteria;
            ItemWarehouseSummary[] itemWarehouseSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve items with a key which contains 'SDRAM'
            itemCriteria = new LikeRestrictionOfstring();
            itemCriteria.Like = "%SDRAM%";

            // Create a restriction object
            // Retrieve only items from the warehouse with a key of 'North'
            warehouseCriteria = new LikeRestrictionOfstring();
            warehouseCriteria.EqualValue = "North";

            // Create an item warehouse criteria object
            itemWarehouseCriteria = new ItemWarehouseCriteria();
            itemWarehouseCriteria.ItemId = itemCriteria;
            itemWarehouseCriteria.WarehouseId = warehouseCriteria;

            // Retrieve the list if item warehouse summary objects
            itemWarehouseSummaries = wsDynamicsGP.GetItemWarehouseList(itemWarehouseCriteria, context);

            // Display the item ID of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ItemWarehouseSummary a in itemWarehouseSummaries)
            {
                summaryList.AppendLine("Item: " + a.Key.ItemKey.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetLoggedExceptionDataByKey

Description

Retrieves a single exception object from the log based on the logId value supplied.

Parameters

Parameter | Type | Description
logId | guid | A key that uniquely identifies the logged exception.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetLoggedExceptionDataByKeyResult | LoggedExceptionData | A LoggedExceptionData object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a logged exception. The error message from the exception is displayed in a message box. To use this example, the logid GUID in the example should be replaced with a valid logid from the exception log.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Guid guid;
            LoggedExceptionData loggedSystemException;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Guid with the id value of the logged exception to retrieve
            guid = new Guid("511db25b-962d-4d10-ba3f-b929a82ae434");

            // Retrieve the exception
            loggedSystemException = wsDynamicsGP.GetLoggedExceptionDataByKey(guid, context);

            // Display the exception message from the ExceptionDetail property
            MessageBox.Show("Error message: " + loggedSystemException.ExceptionDetail.Message);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Guid guid;
            LoggedExceptionData loggedSystemException;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Guid with the id value of the logged exception to retrieve
            guid = new Guid("511db25b-962d-4d10-ba3f-b929a82ae434");

            // Retrieve the exception
            loggedSystemException = wsDynamicsGP.GetLoggedExceptionDataByKey(guid, context);

            // Display the exception message from the ExceptionDetail property
            MessageBox.Show("Error message: " + loggedSystemException.ExceptionDetail.Message);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetLoggedExceptionDataList

Description

Retrieves a list of exception summary objects that were logged between the specified dates.

Parameters

Parameter | Type | Description
beginDate | dateTime | A date/time object that specifies which exception summaries are to be retrieved. The LoggedDate property of all retrieved exception summary objects will be equal to or later than the specified date and time value.
endDate | dateTime | A date/time object that specifies which exception summaries are to be retrieved. The LoggedDate property of all retrieved exception summary objects will be earlier than the specified date and time value.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetLoggedExceptionDataListResult | ArrayOfLoggedExceptionDataSummary | A list of logged exception summary objects between the specified begin and end dates.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of exception summaries logged between two dates, and displays the number in a message box. To use this example, the begin and end date values should be changed to reflect exception log activity.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DateTime beginDate;
            DateTime endDate;
            LoggedExceptionDataSummary[] exceptionSummaryList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample comany)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the start and end dates
            beginDate = new DateTime(2006, 1, 18);
            endDate = new DateTime(2006, 1, 20);

            // Retrieve the list of exception summaries
            exceptionSummaryList = wsDynamicsGP.GetLoggedExceptionDataList(beginDate, endDate, context);

            // Display the number of exception summaries matching the criteria
            MessageBox.Show("Number of exceptions logged = " + exceptionSummaryList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            DateTime beginDate;
            DateTime endDate;
            LoggedExceptionDataSummary[] exceptionSummaryList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample comany)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the start and end dates
            beginDate = new DateTime(2006, 1, 18);
            endDate = new DateTime(2006, 1, 20);

            // Retrieve the list of exception summaries
            exceptionSummaryList = wsDynamicsGP.GetLoggedExceptionDataList(beginDate, endDate, context);

            // Display the number of exception summaries matching the criteria
            MessageBox.Show("Number of exceptions logged = " + exceptionSummaryList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetLoggedValidationResultByKey

Description

Retrieves a single validation result object from the log based on the logId value supplied.

Parameters

Parameter | Type | Description
logId | guid | A key that uniquely identifies the logged validation result.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetLoggedValidationResultByKeyResult | ValidationResult | A logged validation result object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example creates two validation errors. The validation errors cause a soap exception that contains the logid of the logged validation exception. The logid is used to to retrieve the validation result object. The number of validation errors in the validation result object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using System.Web.Services.Protocols;
using System.Xml;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorKey vendorKey;
            Vendor vendor;
            Policy policy;
            ValidationResult validationResult;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key of the vendor to be udpated
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create a vendor object
            vendor = new Vendor();
            vendor.Key = vendorKey;

            // Set a pair of properties to create two validation errors
            vendor.DiscountGracePeriod = 100;
            vendor.DueDateGracePeriod = 100;

            try
            {
                // Create a policy object
                policy = wsDynamicsGP.GetPolicyByOperation("UpdateVendor", context);

                // Attempt to update the vendor
                wsDynamicsGP.UpdateVendor(vendor, context, policy);
            }
            catch(SoapException soapErr)
            {
                // Try retrieving the Message node
                XmlDocument doc = new XmlDocument();
                XmlNamespaceManager nsManager = new
                    XmlNamespaceManager(doc.NameTable);
                nsManager.AddNamespace("sm",
            "http://schemas.datacontract.org/2004/07/System.ServiceModel");
                doc.LoadXml(soapErr.Detail.InnerXml);
                XmlNode node = doc.SelectSingleNode(
                    "//sm:InnerException//sm:Message", nsManager);
                if (node != null)
                {
                    // Use the GUID retrieved to load the validation details
                    Guid LogId = new Guid(node.InnerText.Trim());

                    // Get the validation result object
                    validationResult = wsDynamicsGP.GetLoggedValidationResultByKey(guid, context);

                    // Display the number of validation exceptions
                    MessageBox.Show("Number of validation exceptions: " +
                    validationResult.Errors.Length.ToString());
                }
            }
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using System.Web.Services.Protocols;
using DynamicsGPWebServiceSample.DynamicsGPService;
using System.ServiceModel;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorKey vendorKey;
            Vendor vendor;
            Policy policy;
            ValidationResult validationResult;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key of the vendor to be udpated
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create a vendor object
            vendor = new Vendor();
            vendor.Key = vendorKey;

            // Set a pair of properties to create two validation errors
            vendor.DiscountGracePeriod = 100;
            vendor.DueDateGracePeriod = 100;

            try
            {
                // Create a policy object
                policy = wsDynamicsGP.GetPolicyByOperation("UpdateVendor", context);

                // Attempt to update the vendor
                wsDynamicsGP.UpdateVendor(vendor, context, policy);
            }
            catch (FaultException<System.ServiceModel.ExceptionDetail> ex)
            {
                // If this is a validation exception, retrieve the details
                if (ex.Detail.InnerException != null)
                {
                    // Create a guid for the logid value in the exception
                    Guid guid = new Guid(ex.Detail.InnerException.Message.Trim());

                    // Get the validation result object
                    validationResult = wsDynamicsGP.GetLoggedValidationResultByKey(guid, context);

                    // Display the number of validation exceptions
                    MessageBox.Show("Number of validation exceptions: " +
                    validationResult.Errors.Length.ToString());
                }
            }

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetManufacturingOrderByKey

Description

Retrieves a single manufacturing order object based on the specified manufacturing order document key.

Parameters

Parameter | Type | Description
key | ManufacturingOrderDocumentKey | The manufacturing order document key object that specifies the manufacturing order object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetManufacturingOrderByKeyResult | ManufacturingOrder | A manufacturing order object.

Interfaces

  • Dynamics GP
  • Manufacturing

Examples

The following C# example retrieves a manufacturing order object with the manufacturing order document Id value “MO0001”. A message box displays the manufacturing order Id and the description for that order.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ManufacturingOrder manufacturingOrder;
            ManufacturingOrderDocumentKey manufacturingOrderDocumentKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a manufacturing order document key
            manufacturingOrderDocumentKey = new ManufacturingOrderDocumentKey();
            manufacturingOrderDocumentKey.Id = "MO0001";

            // Get the specified manufacturing order object
            manufacturingOrder = wsDynamicsGP.GetManufacturingOrderByKey(manufacturingOrderDocumentKey, context);

            // Display the manufacturing order ID and the description of the order
            MessageBox.Show("Manufacturing Order: " + manufacturingOrder.ManufacturingOrderDocumentKey.Id
                + "   Description: " + manufacturingOrder.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ManufacturingOrder manufacturingOrder;
            ManufacturingOrderDocumentKey manufacturingOrderDocumentKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a manufacturing order document key
            manufacturingOrderDocumentKey = new ManufacturingOrderDocumentKey();
            manufacturingOrderDocumentKey.Id = "MO0001";

            // Get the specified manufacturing order object
            manufacturingOrder = wsDynamicsGP.GetManufacturingOrderByKey(manufacturingOrderDocumentKey, context);

            // Display the manufacturing order ID and the description of the order
            MessageBox.Show("Manufacturing Order: " + manufacturingOrder.ManufacturingOrderDocumentKey.Id
                + "   Description: " + manufacturingOrder.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetManufacturingOrderList

Description

Retrieves a list of manufacturing order summary objects that meet the specified criteria.

Parameters

Parameter | Type | Description
criteria | ManufacturingOrderCriteria | The manufacturing order criteria object that specifies which manufacturing order summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetManufacturingOrderListResult | ArrayOfManufacturingOrderSummary | A list of the manufacturing order summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Manufacturing

Examples

The following C# example retrieves the list of manufacturing order summary objects where the archived property indicates the order is not archived. A message box displays the number of manufacturing orders in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ManufacturingOrderSummary[] manufacturingOrderList;
            ManufacturingOrderCriteria manufacturingOrderCriteria;
            RestrictionOfNullableOfBoolean archivedRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a manufacturing order criteria object
            archivedRestriction = new RestrictionOfNullableOfBoolean();
            archivedRestriction.EqualValue = false;
            manufacturingOrderCriteria = new ManufacturingOrderCriteria();
            manufacturingOrderCriteria.Archived = archivedRestriction;

            // Get the collection of manufacturing order summary objects
            manufacturingOrderList = wsDynamicsGP.GetManufacturingOrderList(manufacturingOrderCriteria, context);

            // Display the number of manufacturing orders
            MessageBox.Show("Total non-archived manufacturing oders: "
                + manufacturingOrderList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ManufacturingOrderSummary[] manufacturingOrderList;
            ManufacturingOrderCriteria manufacturingOrderCriteria;
            RestrictionOfNullableOfboolean archivedRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a manufacturing order criteria object
            archivedRestriction = new RestrictionOfNullableOfboolean();
            archivedRestriction.EqualValue = false;
            manufacturingOrderCriteria = new ManufacturingOrderCriteria();
            manufacturingOrderCriteria.Archived = archivedRestriction;

            // Get the collection of manufacturing order summary objects
            manufacturingOrderList = wsDynamicsGP.GetManufacturingOrderList(manufacturingOrderCriteria, context);

            // Display the number of manufacturing orders
            MessageBox.Show("Total non-archived manufacturing oders: "
                + manufacturingOrderList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetMulticurrencySetupByKey

Description

Retrieves the multicurrency setup object for the current company, based on the key value supplied.

Parameters

Parameter | Type | Description
key | MulticurrencySetupKey | The multicurrency setup key object that specifies the multicurrency setup object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetMulticurrencySetupByKeyResult | MulticurrencySetup | A multicurrency setup object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the multicurrency setup object for the sample company (Fabrikam). The ISO code for the sample company is a known-value so the multicurrency setup key can be created. The reporting currency for the sample company is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CompanyKey companyKey;
            MulticurrencySetup multicurrencySetup;
            MulticurrencySetupKey multicurrencySetupKey;
            CurrencyKey currencyKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Create a company key (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = companyKey;

            // Create the multicurrency setup key
            // The key for the sample company is "USD"
            multicurrencySetupKey = new MulticurrencySetupKey();
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "USD";
            multicurrencySetupKey.CurrencyKey = currencyKey;

            // Get the multicurrency setup object
            multicurrencySetup = wsDynamicsGP.GetMulticurrencySetupByKey(multicurrencySetupKey, context);

            // Display the reporting currency
            MessageBox.Show(multicurrencySetup.ReportingCurrencyKey.ISOCode);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CompanyKey companyKey;
            MulticurrencySetup multicurrencySetup;
            MulticurrencySetupKey multicurrencySetupKey;
            CurrencyKey currencyKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Create a company key (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = companyKey;

            // Create the multicurrency setup key
            // The key for the sample company is "USD"
            multicurrencySetupKey = new MulticurrencySetupKey();
            currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "USD";
            multicurrencySetupKey.CurrencyKey = currencyKey;

            // Get the multicurrency setup object
            multicurrencySetup = wsDynamicsGP.GetMulticurrencySetupByKey(multicurrencySetupKey, context);

            // Display the reporting currency
            MessageBox.Show(multicurrencySetup.ReportingCurrencyKey.ISOCode);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetMulticurrencySetupList

Description

Retrieves a list of multicurrency setup objects for the specified company.

Parameters

Parameter | Type | Description
criteria | MulticurrencySetupCriteria | The multicurrency setup criteria object. This object will be empty.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetMulticurrencySetupListResult | ArrayOfMulticurrencySetup | The list of multicurrency setup objects. This will contain one item for the current company.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the multicurrency setup list for the sample company. The functional currency for the sample company is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CompanyKey companyKey;
            MulticurrencySetupCriteria multicurrencySetupCriteria;
            MulticurrencySetup[] multicurrencySetupList;
            MulticurrencySetup multicurrencySetup;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Create a company key (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = companyKey;

            // Create the criteria, which in this case are empty
            multicurrencySetupCriteria = new MulticurrencySetupCriteria();

            // Get the list of Multicurrency Setup objects
            multicurrencySetupList = wsDynamicsGP.GetMulticurrencySetupList
            (multicurrencySetupCriteria, context);

            // Retrieve the one item from the list
            if (multicurrencySetupList.Length > 0)
            {
                multicurrencySetup = multicurrencySetupList[0];
                MessageBox.Show(multicurrencySetup.Key.CurrencyKey.ISOCode);
            }
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            CompanyKey companyKey;
            MulticurrencySetupCriteria multicurrencySetupCriteria;
            MulticurrencySetup[] multicurrencySetupList;
            MulticurrencySetup multicurrencySetup;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Create a company key (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = companyKey;

            // Create the criteria, which in this case are empty
            multicurrencySetupCriteria = new MulticurrencySetupCriteria();

            // Get the list of Multicurrency Setup objects
            multicurrencySetupList = wsDynamicsGP.GetMulticurrencySetupList
            (multicurrencySetupCriteria, context);

            // Retrieve the one item from the list
            if (multicurrencySetupList.Length > 0)
            {
                multicurrencySetup = multicurrencySetupList[0];
                MessageBox.Show(multicurrencySetup.Key.CurrencyKey.ISOCode);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
            }
        }
    }
}


GetPayablesCreditMemoByKey

Description

Retrieves a single payables credit memo object based on the specified payables document key.

Parameters

Parameter | Type | Description
key | PayablesDocumentKey | The payables document key object that specifies the payables credit memo to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesCreditMemoByKeyResult | PayablesCreditMemo | A payables credit memo object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a payables credit memo object with the key value “00000000000000459”. A message box displays the vendor name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesCreditMemo payablesCreditMemo;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the payables document key object
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000459";

            // Retrieve the payable credit memo object
            payablesCreditMemo = wsDynamicsGP.GetPayablesCreditMemoByKey(documentKey, context);

            // Display the vendor name property from the payables credit memo object
            MessageBox.Show("Vendor name: " + payablesCreditMemo.VendorName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesCreditMemo payablesCreditMemo;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the payables document key object
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000459";

            // Retrieve the payable credit memo object
            payablesCreditMemo = wsDynamicsGP.GetPayablesCreditMemoByKey(documentKey, context);

            // Display the vendor name property from the payables credit memo object
            MessageBox.Show("Vendor name: " + payablesCreditMemo.VendorName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesCreditMemoList

Description

Retrieves a list of payables credit memo summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PayablesCreditMemoCriteria | A payables credit memo criteria object that specifies which payables credit memo summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesCreditMemoListResult | ArrayOfPayablesCreditMemoSummary | The list of payables credit memo summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of payables credit memo summary objects whose TransactionState property equals “Open”. The document number and vendor name from each payables credit memo summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPayablesTransactionState transactionStateRestriction;
            PayablesCreditMemoCriteria creditMemoCriteria;
            PayablesCreditMemoSummary[] payablesCreditMemoSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all payables credit memo objects with a status of 'Open'
            transactionStateRestriction = new ListRestrictionOfNullableOfPayablesTransactionState();
            transactionStateRestriction.EqualValue = PayablesTransactionState.Open;

            // Create the payables credit memo criteria object
            creditMemoCriteria = new PayablesCreditMemoCriteria();
            creditMemoCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the payables credit memo summary objects
            payablesCreditMemoSummaries = wsDynamicsGP.GetPayablesCreditMemoList(
            creditMemoCriteria, context);

            // Display the document number and vendor name of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesCreditMemoSummary a in payablesCreditMemoSummaries)
            {
                summaryList.AppendLine("Document number: " + a.Key.Id + "  Vendor name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPayablesTransactionState transactionStateRestriction;
            PayablesCreditMemoCriteria creditMemoCriteria;
            PayablesCreditMemoSummary[] payablesCreditMemoSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all payables credit memo objects with a status of 'Open'
            transactionStateRestriction = new ListRestrictionOfNullableOfPayablesTransactionState();
            transactionStateRestriction.EqualValue = PayablesTransactionState.Open;

            // Create the payables credit memo criteria object
            creditMemoCriteria = new PayablesCreditMemoCriteria();
            creditMemoCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the payables credit memo summary objects
            payablesCreditMemoSummaries = wsDynamicsGP.GetPayablesCreditMemoList(
            creditMemoCriteria, context);

            // Display the document number and vendor name of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesCreditMemoSummary a in payablesCreditMemoSummaries)
            {
                summaryList.AppendLine("Document number: " + a.Key.Id + "  Vendor name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesDocumentList

Description

Retrieves a list of payables document summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PayablesDocumentCriteria | A payables document criteria object that specifies which payables document summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesDocumentListResult | ArrayOfPayablesDocumentSummary | The list of payables document summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of payables document summary objects with a vendor Id of “ADVANCED0001“ and a Type of “Invoice”. The invoice date and invoice amount from each payables document summary object are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString vendorRestriction;
            ListRestrictionOfNullableOfPayablesDocumentType typeRestriction;
            PayablesDocumentCriteria documentCriteria;
            PayablesDocumentSummary[] documentSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction objects
            // Retrieve payables documents for a specified vendor
            vendorRestriction = new LikeRestrictionOfString();
            vendorRestriction.EqualValue = "ADVANCED0001";

            // Retrieve only invoice documents
            typeRestriction = new ListRestrictionOfNullableOfPayablesDocumentType();
            typeRestriction.EqualValue = PayablesDocumentType.Invoice;

            // Create a payables document criteria object
            documentCriteria = new PayablesDocumentCriteria();
            documentCriteria.Type = typeRestriction;
            documentCriteria.VendorId = vendorRestriction;

            // Retrieve the payables document summary objects
            documentSummaries = wsDynamicsGP.GetPayablesDocumentList(documentCriteria, context);

            // Display the invoice date and amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesDocumentSummary a in documentSummaries)
            {
                summaryList.AppendLine("Invoice date: " + a.Date.Value.ToShortDateString()
                + "  Invoice Amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring vendorRestriction;
            ListRestrictionOfNullableOfPayablesDocumentType typeRestriction;
            PayablesDocumentCriteria documentCriteria;
            PayablesDocumentSummary[] documentSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction objects
            // Retrieve payables documents for a specified vendor
            vendorRestriction = new LikeRestrictionOfstring();
            vendorRestriction.EqualValue = "ADVANCED0001";

            // Retrieve only invoice documents
            typeRestriction = new ListRestrictionOfNullableOfPayablesDocumentType();
            typeRestriction.EqualValue = PayablesDocumentType.Invoice;

            // Create a payables document criteria object
            documentCriteria = new PayablesDocumentCriteria();
            documentCriteria.Type = typeRestriction;
            documentCriteria.VendorId = vendorRestriction;

            // Retrieve the payables document summary objects
            documentSummaries = wsDynamicsGP.GetPayablesDocumentList(documentCriteria, context);

            // Display the invoice date and amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesDocumentSummary a in documentSummaries)
            {
                summaryList.AppendLine("Invoice date: " + a.Date.Value.ToShortDateString()
                + "  Invoice Amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesFinanceChargeByKey

Description

Retrieves a single payables finance charge object based on the specified payables document key.

Parameters

Parameter | Type | Description
key | PayablesDocumentKey | The payables document key object that specifies the payables finance charge object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesFinanceChargeByKeyResult | PayablesFinanceCharge | A payables finance charge object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a payables finance charge object with the key value “00000000000000460”. A message box displays the vendor name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesFinanceCharge payablesFinanceCharge;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key to specify the finance charge object
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000460";

            // Retrieve the payables finance charge object
            payablesFinanceCharge = wsDynamicsGP.GetPayablesFinanceChargeByKey(documentKey, context);

            // Display the vendor name property from the payables finance charge object
            MessageBox.Show("Vendor name: " + payablesFinanceCharge.VendorName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesFinanceCharge payablesFinanceCharge;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key to specify the finance charge object
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000460";

            // Retrieve the payables finance charge object
            payablesFinanceCharge = wsDynamicsGP.GetPayablesFinanceChargeByKey(documentKey, context);

            // Display the vendor name property from the payables finance charge object
            MessageBox.Show("Vendor name: " + payablesFinanceCharge.VendorName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesFinanceChargeList

Description

Retrieves a list of payables finance charge summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PayablesFinanceChargeCriteria | A payables finance charge criteria object that specifies which payables finance charge summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesFinanceChargeListResult | ArrayOfPayablesFinanceChargeSummary | The list of payables finance charge summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of payables finance charge summary objects whose TransactionState property equals “Work”. The document number and vendor name from each payables finance charge summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPayablesTransactionState transactionStateRestriction;
            PayablesFinanceChargeCriteria financeChargeCriteria;
            PayablesFinanceChargeSummary[] financeChargeSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            transactionStateRestriction = new ListRestrictionOfNullableOfPayablesTransactionState();
            transactionStateRestriction.EqualValue = PayablesTransactionState.Work;

            // Create a payables finance charge criteria object
            financeChargeCriteria = new PayablesFinanceChargeCriteria();
            financeChargeCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the payables finance charge summary objects
            financeChargeSummaries = wsDynamicsGP.GetPayablesFinanceChargeList(
            financeChargeCriteria, context);

            // Display the document number and vendor name of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesFinanceChargeSummary a in financeChargeSummaries)
            {
                summaryList.AppendLine("Document number: " + a.Key.Id + "  Vendor Name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPayablesTransactionState transactionStateRestriction;
            PayablesFinanceChargeCriteria financeChargeCriteria;
            PayablesFinanceChargeSummary[] financeChargeSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            transactionStateRestriction = new ListRestrictionOfNullableOfPayablesTransactionState();
            transactionStateRestriction.EqualValue = PayablesTransactionState.Work;

            // Create a payables finance charge criteria object
            financeChargeCriteria = new PayablesFinanceChargeCriteria();
            financeChargeCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the payables finance charge summary objects
            financeChargeSummaries = wsDynamicsGP.GetPayablesFinanceChargeList(
            financeChargeCriteria, context);

            // Display the document number and vendor name of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesFinanceChargeSummary a in financeChargeSummaries)
            {
                summaryList.AppendLine("Document number: " + a.Key.Id + "  Vendor Name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesInvoiceByKey

Description

Retrieves a single payables invoice object based on the specified payables document key.

Parameters

Parameter | Type | Description
key | PayablesDocumentKey | The payables document key object that specifies the payables invoice to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesInvoiceByKeyResult | PayablesInvoice | A payables invoice object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a payables invoice object with the key value “00000000000000457”. A message box displays the vendor name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesInvoice payablesInvoice;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000457";

            // Retrieve the payables invoice object
            payablesInvoice = wsDynamicsGP.GetPayablesInvoiceByKey(documentKey, context);

            // Display the vendor name property from the payables invoice object
            MessageBox.Show("Vendor: " + payablesInvoice.VendorName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesInvoice payablesInvoice;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000457";

            // Retrieve the payables invoice object
            payablesInvoice = wsDynamicsGP.GetPayablesInvoiceByKey(documentKey, context);

            // Display the vendor name property from the payables invoice object
            MessageBox.Show("Vendor: " + payablesInvoice.VendorName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesInvoiceList

Description

Retrieves a list of payables invoice summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PayablesInvoiceCriteria | A payables invoice criteria object that specifies which payables invoice summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesInvoiceListResult | ArrayOfPayablesInvoiceSummary | The list of payables invoice summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of payables invoice summary objects whose TransactionState property equals “Work”. The document number and vendor name from each payables invoice summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPayablesTransactionState transactionStateRestriction;
            PayablesInvoiceCriteria payablesInvoiceCriteria;
            PayablesInvoiceSummary[] payablesInvoiceSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve payables invoice objects with a transaction state of work
            transactionStateRestriction = new ListRestrictionOfNullableOfPayablesTransactionState();
            transactionStateRestriction.EqualValue = PayablesTransactionState.Work;

            // Create a criteria object
            payablesInvoiceCriteria = new PayablesInvoiceCriteria();
            payablesInvoiceCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the payables invoice summary objects
            payablesInvoiceSummaries = wsDynamicsGP.GetPayablesInvoiceList(payablesInvoiceCriteria, context);

            // Display the document number and vendor name of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesInvoiceSummary a in payablesInvoiceSummaries)
            {
                summaryList.AppendLine("Payable invoice: " + a.Key.Id + "  Vendor name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPayablesTransactionState transactionStateRestriction;
            PayablesInvoiceCriteria payablesInvoiceCriteria;
            PayablesInvoiceSummary[] payablesInvoiceSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve payables invoice objects with a transaction state of work
            transactionStateRestriction = new ListRestrictionOfNullableOfPayablesTransactionState();
            transactionStateRestriction.EqualValue = PayablesTransactionState.Work;

            // Create a criteria object
            payablesInvoiceCriteria = new PayablesInvoiceCriteria();
            payablesInvoiceCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the payables invoice summary objects
            payablesInvoiceSummaries = wsDynamicsGP.GetPayablesInvoiceList(payablesInvoiceCriteria, context);

            // Display the document number and vendor name of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesInvoiceSummary a in payablesInvoiceSummaries)
            {
                summaryList.AppendLine("Payable invoice: " + a.Key.Id + "  Vendor name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesMiscellaneousChargeByKey

Description

Retrieves a single payables miscellaneous charge object based on the specified payables document key.

Parameters

Parameter | Type | Description
key | PayablesDocumentKey | The payables document key object that specifies the payables miscellaneous charge object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesMiscellaneousChargeByKeyResult | PayablesMiscellaneousCharge | A payables miscellaneous charge object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a payables miscellaneous charge object with the key value “00000000000000461”. A message box displays the vendor name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesMiscellaneousCharge payablesMiscellaneousCharge;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000461";

            // Retrieve the payables miscellaneous charge object
            payablesMiscellaneousCharge = wsDynamicsGP.GetPayablesMiscellaneousChargeByKey(
            documentKey, context);

            // Display the vendor name property from the payables miscellaneous charge object
            MessageBox.Show("Vendor name: " + payablesMiscellaneousCharge.VendorName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesMiscellaneousCharge payablesMiscellaneousCharge;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000461";

            // Retrieve the payables miscellaneous charge object
            payablesMiscellaneousCharge = wsDynamicsGP.GetPayablesMiscellaneousChargeByKey(
            documentKey, context);

            // Display the vendor name property from the payables miscellaneous charge object
            MessageBox.Show("Vendor name: " + payablesMiscellaneousCharge.VendorName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesMiscellaneousChargeList

Description

Retrieves a list of payables miscellaneous charge summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PayablesMiscellaneousChargeCriteria | A payables miscellaneous charge criteria object that specifies which payables miscellaneous charge summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesMiscellaneousChargeListResult | ArrayOfPayablesMiscellaneousChargeSummary | The list of payables miscellaneous charge summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of payables miscellaneous charge summary objects whose BatchId property equals “PAYABLES BATCH”. The document number and vendor name from each payables miscellaneous charge summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString batchRestriction;
            PayablesMiscellaneousChargeCriteria miscellaneousChargeCriteria;
            PayablesMiscellaneousChargeSummary[] payablesMiscellaneousChargeSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve records where the batch ID is 'PAYABLES BATCH'
            batchRestriction = new LikeRestrictionOfString();
            batchRestriction.EqualValue = "PAYABLES BATCH";

            // Create a payables miscellaneous credit criteria object
            miscellaneousChargeCriteria = new PayablesMiscellaneousChargeCriteria();
            miscellaneousChargeCriteria.BatchId = batchRestriction;

            // Retrieve the list of payables miscellaneous charge summary objects
            payablesMiscellaneousChargeSummaries = wsDynamicsGP.GetPayablesMiscellaneousChargeList(
            miscellaneousChargeCriteria, context);

            // Display the document number and vendor name property of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesMiscellaneousChargeSummary a in payablesMiscellaneousChargeSummaries)
            {
                summaryList.AppendLine("Document number: " + a.Key.Id + "  Vendor name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring batchRestriction;
            PayablesMiscellaneousChargeCriteria miscellaneousChargeCriteria;
            PayablesMiscellaneousChargeSummary[] payablesMiscellaneousChargeSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve records where the batch ID is 'PAYABLES BATCH'
            batchRestriction = new LikeRestrictionOfstring();
            batchRestriction.EqualValue = "PAYABLES BATCH";

            // Create a payables miscellaneous credit criteria object
            miscellaneousChargeCriteria = new PayablesMiscellaneousChargeCriteria();
            miscellaneousChargeCriteria.BatchId = batchRestriction;

            // Retrieve the list of payables miscellaneous charge summary objects
            payablesMiscellaneousChargeSummaries = wsDynamicsGP.GetPayablesMiscellaneousChargeList(
            miscellaneousChargeCriteria, context);

            // Display the document number and vendor name property of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesMiscellaneousChargeSummary a in payablesMiscellaneousChargeSummaries)
            {
                summaryList.AppendLine("Document number: " + a.Key.Id + "  Vendor name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesReturnByKey

Description

Retrieves a single payables return object based on the specified payables document key.

Parameters

Parameter | Type | Description
key | PayablesDocumentKey | The payables document key object that specifies the payables return object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesReturnByKeyResult | PayablesReturn | A payables return object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a payables return object with the key value “00000000000000462”. A message box displays the vendor name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesReturn payablesReturn;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000462";

            // Retrieve the payables return object
            payablesReturn = wsDynamicsGP.GetPayablesReturnByKey(documentKey, context);

            // Display the vendor name property from the payables return object
            MessageBox.Show("Vendor name: " + payablesReturn.VendorName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PayablesDocumentKey documentKey;
            PayablesReturn payablesReturn;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key
            documentKey = new PayablesDocumentKey();
            documentKey.Id = "00000000000000462";

            // Retrieve the payables return object
            payablesReturn = wsDynamicsGP.GetPayablesReturnByKey(documentKey, context);

            // Display the vendor name property from the payables return object
            MessageBox.Show("Vendor name: " + payablesReturn.VendorName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPayablesReturnList

Description

Retrieves a list of payables return summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PayablesReturnCriteria | A payables return criteria object that specifies which payables return summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPayablesReturnListResult | ArrayOfPayablesReturnSummary | The list of payables return summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of payables return summary objects whose TransactionState property equals “Work”. The document number and vendor name from each payables return summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPayablesTransactionState transactionStateRestriction;
            PayablesReturnCriteria payablesReturnCriteria;
            PayablesReturnSummary[] payablesReturnSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create restriction object
            transactionStateRestriction = new ListRestrictionOfNullableOfPayablesTransactionState();
            transactionStateRestriction.EqualValue = PayablesTransactionState.Work;

            // Create the payables return criteria object
            payablesReturnCriteria = new PayablesReturnCriteria();
            payablesReturnCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of payables returns summary objects
            payablesReturnSummaries = wsDynamicsGP.GetPayablesReturnList(payablesReturnCriteria, context);

            // Display the document number and vendor name property of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesReturnSummary a in payablesReturnSummaries)
            {
                summaryList.AppendLine("Document number: " + a.Key.Id + "  Vendor name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPayablesTransactionState transactionStateRestriction;
            PayablesReturnCriteria payablesReturnCriteria;
            PayablesReturnSummary[] payablesReturnSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create restriction object
            transactionStateRestriction = new ListRestrictionOfNullableOfPayablesTransactionState();
            transactionStateRestriction.EqualValue = PayablesTransactionState.Work;

            // Create the payables return criteria object
            payablesReturnCriteria = new PayablesReturnCriteria();
            payablesReturnCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of payables returns summary objects
            payablesReturnSummaries = wsDynamicsGP.GetPayablesReturnList(payablesReturnCriteria, context);

            // Display the document number and vendor name property of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PayablesReturnSummary a in payablesReturnSummaries)
            {
                summaryList.AppendLine("Document number: " + a.Key.Id + "  Vendor name: " +
                a.VendorName);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPaymentCardTypeByKey

Description

Retrieves a single payment card type object based on the specified payment card type key.

Parameters

Parameter | Type | Description
key | PaymentCardTypeKey | The payment card type key object that specifies the payment card type object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPaymentCardTypeByKeyResult | PaymentCardType | A payment card type object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a payment card type object with the key value “AmericaCharge”. A message box displays the payable card type classification.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PaymentCardTypeKey cardTypeKey;
            PaymentCardType cardType;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payment card type key and specify the Id
            cardTypeKey = new PaymentCardTypeKey();
            cardTypeKey.Id = "AmericaCharge";

            // Retrieve the payment card type object
            cardType = wsDynamicsGP.GetPaymentCardTypeByKey(cardTypeKey, context);

            // Display the payable card type property from the payment card type object
            MessageBox.Show("Card Type: " + cardType.PayableCardType.Value.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PaymentCardTypeKey cardTypeKey;
            PaymentCardType cardType;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payment card type key and specify the Id
            cardTypeKey = new PaymentCardTypeKey();
            cardTypeKey.Id = "AmericaCharge";

            // Retrieve the payment card type object
            cardType = wsDynamicsGP.GetPaymentCardTypeByKey(cardTypeKey, context);

            // Display the payable card type property from the payment card type object
            MessageBox.Show("Card Type: " + cardType.PayableCardType.Value.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPaymentCardTypeList

Description

Retrieves a list of payment card type objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PaymentCardTypeCriteria | A payment type card criteria object that specifies which payment card type objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPaymentCardTypeListResult | ArrayOfPaymentCardType | The list of payment card type objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of payment card type objects whose Id property ends with “Credit”. The Id property from each payment card type object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString idRestriction;
            PaymentCardTypeCriteria cardCriteria;
            PaymentCardType[] paymentCardTypes;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create restriction object
            // Retrieve all types that end in 'Credit'
            idRestriction = new LikeRestrictionOfString();
            idRestriction.Like = "%Credit";

            // Create a payment card type criteria object
            cardCriteria = new PaymentCardTypeCriteria();
            cardCriteria.Id = idRestriction;

            // Retrieve the list of payment card types
            paymentCardTypes = wsDynamicsGP.GetPaymentCardTypeList(cardCriteria, context);

            // Display the ID of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PaymentCardType a in paymentCardTypes)
            {
                summaryList.AppendLine("Card type: " + a.Key.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring idRestriction;
            PaymentCardTypeCriteria cardCriteria;
            PaymentCardType[] paymentCardTypes;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create restriction object
            // Retrieve all types that end in 'Credit'
            idRestriction = new LikeRestrictionOfstring();
            idRestriction.Like = "%Credit";

            // Create a payment card type criteria object
            cardCriteria = new PaymentCardTypeCriteria();
            cardCriteria.Id = idRestriction;

            // Retrieve the list of payment card types
            paymentCardTypes = wsDynamicsGP.GetPaymentCardTypeList(cardCriteria, context);

            // Display the ID of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PaymentCardType a in paymentCardTypes)
            {
                summaryList.AppendLine("Card type: " + a.Key.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPaymentTermsByKey

Description

Retrieves a single payment terms object based on the specified payment terms key.

Parameters

Parameter | Type | Description
key | PaymentTermsKey | The payment terms key object that specifies the payment terms object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPaymentTermsByKeyResult | PaymentTerms | A payment terms object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a payment terms object with the key value “EOM”. A message box displays the payment terms days until due property.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PaymentTermsKey paymentTermsKey;
            PaymentTerms paymentTerms;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payment terms key to specify the payment terms object
            paymentTermsKey = new PaymentTermsKey();
            paymentTermsKey.Id = "EOM";

            // Retrieve the payment terms object
            paymentTerms = wsDynamicsGP.GetPaymentTermsByKey(paymentTermsKey, context);

            // Display the days until due property
            MessageBox.Show("Days until due: " + paymentTerms.DaysUntilDue.Value.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PaymentTermsKey paymentTermsKey;
            PaymentTerms paymentTerms;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payment terms key to specify the payment terms object
            paymentTermsKey = new PaymentTermsKey();
            paymentTermsKey.Id = "EOM";

            // Retrieve the payment terms object
            paymentTerms = wsDynamicsGP.GetPaymentTermsByKey(paymentTermsKey, context);

            // Display the days until due property
            MessageBox.Show("Days until due: " + paymentTerms.DaysUntilDue.Value.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPaymentTermsList

Description

Retrieves a list of payment terms objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PaymentTermsCriteria | A payment terms criteria object that specifies which payment terms objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPaymentTermsListResult | ArrayOfPaymentTerms | The list of payment terms objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of payment terms objects whose Id property contains “Net”. The Id property from each payment terms object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString paymentTermsIdRestriction;
            PaymentTermsCriteria paymentTermsCriteria;
            PaymentTerms[] paymentTerms;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all payment terms containing 'Net'
            paymentTermsIdRestriction = new LikeRestrictionOfString();
            paymentTermsIdRestriction.Like = "%Net%";

            // Create a payment terms criteria object
            paymentTermsCriteria = new PaymentTermsCriteria();
            paymentTermsCriteria.Id = paymentTermsIdRestriction;

            // Retrieve the list of payment term objects
            paymentTerms = wsDynamicsGP.GetPaymentTermsList(paymentTermsCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PaymentTerms a in paymentTerms)
            {
                summaryList.AppendLine("Payment terms: " + a.Key.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring paymentTermsIdRestriction;
            PaymentTermsCriteria paymentTermsCriteria;
            PaymentTerms[] paymentTerms;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all payment terms containing 'Net'
            paymentTermsIdRestriction = new LikeRestrictionOfstring();
            paymentTermsIdRestriction.Like = "%Net%";

            // Create a payment terms criteria object
            paymentTermsCriteria = new PaymentTermsCriteria();
            paymentTermsCriteria.Id = paymentTermsIdRestriction;

            // Retrieve the list of payment term objects
            paymentTerms = wsDynamicsGP.GetPaymentTermsList(paymentTermsCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PaymentTerms a in paymentTerms)
            {
                summaryList.AppendLine("Payment terms: " + a.Key.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPlannedOrderByKey

Description

Retrieves a single planned order object based on the specified planned order key.

Parameters

Parameter | Type | Description
key | PlannedOrderKey | The planned order key object that specifies the planned order object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPlannedOrderByKeyResult | PlannedOrder | A planned order object.

Interfaces

  • Dynamics GP
  • Manufacturing

Examples

The following C# example retrieves a planned order object with the planned order key value “PO0001”. A message box displays the quantity to order information for the specified planned order.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PlannedOrder plannedOrder;
            PlannedOrderKey plannedOrderKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a planned order key object
            plannedOrderKey = new PlannedOrderKey();
            plannedOrderKey.Id = "PO0001";

            // Get the list of planned order summary objects
            plannedOrder = wsDynamicsGP.GetPlannedOrderByKey(plannedOrderKey, context);

            // Display the list of planned orders
            MessageBox.Show("Quantity to order: " + plannedOrder.QuantityToOrder.Value.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PlannedOrder plannedOrder;
            PlannedOrderKey plannedOrderKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a planned order key object
            plannedOrderKey = new PlannedOrderKey();
            plannedOrderKey.Id = "PO0001";

            // Get the list of planned order summary objects
            plannedOrder = wsDynamicsGP.GetPlannedOrderByKey(plannedOrderKey, context);

            // Display the list of planned orders
            MessageBox.Show("Quantity to order: " + plannedOrder.QuantityToOrder.Value.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPlannedOrderList

Description

Retrieves a list of planned order summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PlannedOrderCriteria | A planned order criteria object that specifies which planned order summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPlannedOrderListResult | ArrayOfPlannedOrderSummary | The list of planned order summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Manufacturing

Examples

The following C# example retrieves the list of all planned order summary objects. The total number of planned order summary objects is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPWebService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString idRestriction;
            PlannedOrderSummary[] plannedOrderList;
            PlannedOrderCriteria plannedOrderCriteria;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a planned order criteria object
            idRestriction = new LikeRestrictionOfString();
            idRestriction.Like = "%";
            plannedOrderCriteria = new PlannedOrderCriteria();
            plannedOrderCriteria.PlannedOrderKey = idRestriction;

            // Get the list of planned order summary objects
            plannedOrderList = wsDynamicsGP.GetPlannedOrderList(plannedOrderCriteria, context);

            // Display the list of planned orders
            MessageBox.Show("Total planned orders: " + plannedOrderList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPWebService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring idRestriction;
            PlannedOrderSummary[] plannedOrderList;
            PlannedOrderCriteria plannedOrderCriteria;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a planned order criteria object
            idRestriction = new LikeRestrictionOfstring();
            idRestriction.Like = "%";
            plannedOrderCriteria = new PlannedOrderCriteria();
            plannedOrderCriteria.PlannedOrderKey = idRestriction;

            // Get the list of planned order summary objects
            plannedOrderList = wsDynamicsGP.GetPlannedOrderList(plannedOrderCriteria, context);

            // Display the list of planned orders
            MessageBox.Show("Total planned orders: " + plannedOrderList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPolicyByKey

Description

Retrieves the policy instance based on the key value (GUID) for the policy. The appropriate policy instance will be retrieved for the user, company, and role specified by the context object. The returned policy object will contain only the external behaviors.

Parameters

Parameter | Type | Description
key | PolicyKey | The policy key object ths specifies the policy to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPolicyByKeyResult | Policy | The policy instance object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example updates a sales return document. The GetPolicyByKey method is used to retrieve the policy instance to use for the method call. The GUID for the Update Sales Return policy was found in the Policy Reference for the Dynamics GP service.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            SalesReturn salesReturn;
            PolicyKey policyKey;
            Policy salesReturnPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Sales Return key and specify the sales return
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Retrieve the sales return object
            salesReturn = wsDynamicsGP.GetSalesReturnByKey(salesReturnKey, context);

            // Set the comment property
            salesReturn.Comment = "Return was approved";

            // Get the update policy for sales returns
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("a08b0c69-13bd-4a7b-bda9-d7902803364b");
            salesReturnPolicy = wsDynamicsGP.GetPolicyByKey(policyKey, context);

            // Update the sales return object
            wsDynamicsGP.UpdateSalesReturn(salesReturn, context, salesReturnPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            SalesReturn salesReturn;
            PolicyKey policyKey;
            Policy salesReturnPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Sales Return key and specify the sales return
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Retrieve the sales return object
            salesReturn = wsDynamicsGP.GetSalesReturnByKey(salesReturnKey, context);

            // Set the comment property
            salesReturn.Comment = "Return was approved";

            // Get the update policy for sales returns
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("a08b0c69-13bd-4a7b-bda9-d7902803364b");
            salesReturnPolicy = wsDynamicsGP.GetPolicyByKey(policyKey, context);

            // Update the sales return object
            wsDynamicsGP.UpdateSalesReturn(salesReturn, context, salesReturnPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPolicyByOperation

Description

Retrieves the policy instance based on the name of the service operation to be performed. The appropriate policy instance will be retrieved for the user, company, and role specified by the context object. The returned policy object will contain only the external behaviors.

Parameters

Parameter | Type | Description
operation | string | The name of the service operation to be performed.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPolicyByOperationResult | Policy | The policy instance object for the operation.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example updates a sales return document. The GetPolicyByOperation method is used to retrieve the policy instance to use for the method call.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            SalesReturn salesReturn;
            Policy salesReturnPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Sales Return key and specify the sales return
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Retrieve the sales return object
            salesReturn = wsDynamicsGP.GetSalesReturnByKey(salesReturnKey, context);

            // Set the comment property
            salesReturn.Comment = "Return was approved";

            // Get the update policy for sales returns
            salesReturnPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesReturn", context);

            // Update the sales return object
            wsDynamicsGP.UpdateSalesReturn(salesReturn, context, salesReturnPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            SalesReturn salesReturn;
            Policy salesReturnPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Sales Return key and specify the sales return
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Retrieve the sales return object
            salesReturn = wsDynamicsGP.GetSalesReturnByKey(salesReturnKey, context);

            // Set the comment property
            salesReturn.Comment = "Return was approved";

            // Get the update policy for sales returns
            salesReturnPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesReturn", context);

            // Update the sales return object
            wsDynamicsGP.UpdateSalesReturn(salesReturn, context, salesReturnPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPolicyList

Description

Retrieves a list of the policy summary objects for the current company.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPolicyListResult | ArrayOfPolicySummary | The list of policy summary objects returned.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of policy summary objects for the policies defined in the sample company Fabrikam. The total number of policy summary objects is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicySummary[] policySummaryList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Retrieve the list of policies
            policySummaryList = wsDynamicsGP.GetPolicyList(context);

            // Display the number of policy summary objects
            MessageBox.Show("Total Policies: " + policySummaryList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicySummary[] policySummaryList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Retrieve the list of policies
            policySummaryList = wsDynamicsGP.GetPolicyList(context);

            // Display the number of policy summary objects
            MessageBox.Show("Total Policies: " + policySummaryList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPolicyListByRoleKey

Description

Retrieves the list of policy summary objects for policies that have a policy instance for the specified role.

Parameters

Parameter | Type | Description
roleKey | RoleKey | The role key object that specifies which policy instances will be included in the list.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPolicyListByRoleKeyResult | ArrayOfPolicySummary | The list of policy summary objects for the policy instances defined for the specified role.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of policy summary object for the policy instances defined for the “Sales Representitive” role defined in the Dynamics Security Service. The GUID that corresponds to this role is used to create the role key object used for this method. The total number of policy instances is displayed in a message box. The names of the policies are also displayed.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicySummary[] policySummaryList;
            RoleKey roleKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the role key (for Sales Representitive role)
            roleKey = new RoleKey();
            roleKey.Id = "aaeb72e0-77f9-4925-ab9a-73012417fb37";

            // Retrieve the list of policy instances for this role
            policySummaryList = wsDynamicsGP.GetPolicyListByRoleKey(roleKey, context);

            // Display the number of policy summary objects
            MessageBox.Show("Total policies for this role: " + policySummaryList.Length.ToString());

            foreach (PolicySummary p in policySummaryList)
            {
                MessageBox.Show(p.Name);
            }
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PolicySummary[] policySummaryList;
            RoleKey roleKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the role key (for Sales Representitive role)
            roleKey = new RoleKey();
            roleKey.Id = "aaeb72e0-77f9-4925-ab9a-73012417fb37";

            // Retrieve the list of policy instances for this role
            policySummaryList = wsDynamicsGP.GetPolicyListByRoleKey(roleKey, context);

            // Display the number of policy summary objects
            MessageBox.Show("Total policies for this role: " + policySummaryList.Length.ToString());

            foreach (PolicySummary p in policySummaryList)
            {
                MessageBox.Show(p.Name);
            }

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPolicyRoles

Description

Retrieves the list of roles that have policy instances for the specified policy. The roles are returned as role keys (GUID values) that correspond to roles defined in the Dynamics Security Service.

Parameters

Parameter | Type | Description
policyKey | PolicyKey | The policy key object that specifies which policy will have roles returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPolicyRolesResult | ArrayOfRoleKey | The list of role keys (GUID values) for which policy instances exist. The values correspond to roles defined in the Dynamics Security Service.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the policy roles that are available for the Create Customer policy in the sample company Fabrikam. The Create Customer policy is identified using the GUID value from the Policy Reference. The Context object specifies that the sample company is to be examined. A series of message boxes display the total number of roles, and the ID of each role.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            RoleKey[] roleKeyList;
            PolicyKey policyKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the policy key for the Create Customer policy
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("94880780-186c-43c8-b484-efcdd03cbdbe");

            // Retrieve the list of roles for this policy in the current company
            roleKeyList = wsDynamicsGP.GetPolicyRoles(policyKey, context);

            // Display the number of roles
            MessageBox.Show("Total roles for this policy: " + roleKeyList.Length.ToString());

            foreach (RoleKey r in roleKeyList)
            {
                MessageBox.Show(r.Id.ToString());
            }
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            RoleKey[] roleKeyList;
            PolicyKey policyKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the policy key for the Create Customer policy
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("94880780-186c-43c8-b484-efcdd03cbdbe");

            // Retrieve the list of roles for this policy in the current company
            roleKeyList = wsDynamicsGP.GetPolicyRoles(policyKey, context);

            // Display the number of roles
            MessageBox.Show("Total roles for this policy: " + roleKeyList.Length.ToString());

            foreach (RoleKey r in roleKeyList)
            {
                MessageBox.Show(r.Id.ToString());
            }

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPostedPayablesVendorPaymentsByKey

Description

Retrieves a single posted payables vendor payment object based on the specified payables document key.

Parameters

Parameter | Type | Description
key | PayablesDocumentKey | The payables document key object that specifies the posted payables vendor payment object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPostedPayablesVendorPaymentsByKeyResult | PostedPayablesVendorPayment | A posted payables vendor payment object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a posted payables vendor payment object with the payables document Id “00000000000000114“. A message box displays the vendor name property of the posted payables vendor payment object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PostedPayablesVendorPayment postedPayablesVendorPayment;
            PayablesDocumentKey payablesDocumentKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key
            payablesDocumentKey = new PayablesDocumentKey();
            payablesDocumentKey.Id = "00000000000000114";

            //Get the posted payables vendor payment object
            postedPayablesVendorPayment = wsDynamicsGP.GetPostedPayablesVendorPaymentsByKey(payablesDocumentKey, context);

            // Display the vendor name property of the specified posted payables vendor payment object
            MessageBox.Show("Vendor name: " + postedPayablesVendorPayment.VendorName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PostedPayablesVendorPayment postedPayablesVendorPayment;
            PayablesDocumentKey payablesDocumentKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a payables document key
            payablesDocumentKey = new PayablesDocumentKey();
            payablesDocumentKey.Id = "00000000000000114";

            //Get the posted payables vendor payment object
            postedPayablesVendorPayment = wsDynamicsGP.GetPostedPayablesVendorPaymentsByKey(payablesDocumentKey, context);

            // Display the vendor name property of the specified posted payables vendor payment object
            MessageBox.Show("Vendor name: " + postedPayablesVendorPayment.VendorName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPostedPayablesVendorPaymentsList

Description

Retrieves a list of posted payables vendor payment summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PostedPayablesVendorPaymentCriteria | A posted payables vendor payment criteria object that specifies which posted payables vendor payment summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPostedPayablesVendorPaymentsListResult | ArrayOfPostedPayablesVendorPaymentSummary | The list of posted payables vendor payment summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of posted payables vendor payment summary objects with a vendor Id of “ASSOCIAT0001”. A message box displays the number of posted payables vendor payment summary objects assocated with the vendor.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PostedPayablesVendorPaymentSummary[] postedPayablesVendorPaymentList;
            PostedPayablesVendorPaymentCriteria postedPayablesVendorPaymentCriteria;
            LikeRestrictionOfString vendorIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the posted payables vendor payment criteria object
            vendorIdRestriction = new LikeRestrictionOfString();
            vendorIdRestriction.Like = "ASSOCIAT0001";
            postedPayablesVendorPaymentCriteria = new PostedPayablesVendorPaymentCriteria();
            postedPayablesVendorPaymentCriteria.VendorId  = vendorIdRestriction;

            // Get the list of posted payables vendor payment summary objects
            postedPayablesVendorPaymentList = wsDynamicsGP.GetPostedPayablesVendorPaymentsList(
                postedPayablesVendorPaymentCriteria, context);

            // Display the number of posted payables vendor payment summary objects for the specified vendor
            MessageBox.Show("Total number of posted payables vendor payments: "
                + postedPayablesVendorPaymentList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PostedPayablesVendorPaymentSummary[] postedPayablesVendorPaymentList;
            PostedPayablesVendorPaymentCriteria postedPayablesVendorPaymentCriteria;
            LikeRestrictionOfstring vendorIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the posted payables vendor payment criteria object
            vendorIdRestriction = new LikeRestrictionOfstring();
            vendorIdRestriction.Like = "ASSOCIAT0001";
            postedPayablesVendorPaymentCriteria = new PostedPayablesVendorPaymentCriteria();
            postedPayablesVendorPaymentCriteria.VendorId  = vendorIdRestriction;

            // Get the list of posted payables vendor payment summary objects
            postedPayablesVendorPaymentList = wsDynamicsGP.GetPostedPayablesVendorPaymentsList(
                postedPayablesVendorPaymentCriteria, context);

            // Display the number of posted payables vendor payment summary objects for the specified vendor
            MessageBox.Show("Total number of posted payables vendor payments: "
                + postedPayablesVendorPaymentList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPriceLevelByKey

Description

Retrieves a single price level object based on the specified price level key.

Parameters

Parameter | Type | Description
key | PriceLevelKey | The price level key object that specifies the price level object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPriceLevelByKeyResult | PriceLevel | A price level object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves a price level object with the Id “SERVICE“. A message box displays the price level object’s description.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PriceLevelKey priceLevelKey;
            PriceLevel priceLevel;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a price level key
            priceLevelKey = new PriceLevelKey();
            priceLevelKey.Id = "SERVICE";

            // Retrieve the price level object
            priceLevel = wsDynamicsGP.GetPriceLevelByKey(priceLevelKey, context);

            // Display the description property from the price level object
            MessageBox.Show("Description: " + priceLevel.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PriceLevelKey priceLevelKey;
            PriceLevel priceLevel;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a price level key
            priceLevelKey = new PriceLevelKey();
            priceLevelKey.Id = "SERVICE";

            // Retrieve the price level object
            priceLevel = wsDynamicsGP.GetPriceLevelByKey(priceLevelKey, context);

            // Display the description property from the price level object
            MessageBox.Show("Description: " + priceLevel.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPriceLevelList

Description

Retrieves a list of price level objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PriceLevelCriteria | A price level criteria object that specifies which price level objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPriceLevelListResult | ArrayOfPriceLevel | The list of price level objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of price level objects with a created date value between “1/1/2003” and the current date. A message box displays the description from each price level object in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BetweenRestrictionOfNullableOfDateTime createdDateRestriction;
            PriceLevelCriteria priceLevelCriteria;
            PriceLevel[] priceLevels;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve pricing level objects created since 1/1/2003
            createdDateRestriction = new BetweenRestrictionOfNullableOfDateTime();
            createdDateRestriction.From = new DateTime(2003, 1, 1);
            createdDateRestriction.To = DateTime.Today;

            // Create the criteria object and specify the restriction
            priceLevelCriteria = new PriceLevelCriteria();
            priceLevelCriteria.CreatedDate = createdDateRestriction;

            // Retrieve the list of price level objects
            priceLevels = wsDynamicsGP.GetPriceLevelList(priceLevelCriteria, context);

            // Display the description property of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PriceLevel a in priceLevels)
            {
                summaryList.AppendLine("Price level description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BetweenRestrictionOfNullableOfdateTime createdDateRestriction;
            PriceLevelCriteria priceLevelCriteria;
            PriceLevel[] priceLevels;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve pricing level objects created since 1/1/2003
            createdDateRestriction = new BetweenRestrictionOfNullableOfdateTime();
            createdDateRestriction.From = new DateTime(2003, 1, 1);
            createdDateRestriction.To = DateTime.Today;

            // Create the criteria object and specify the restriction
            priceLevelCriteria = new PriceLevelCriteria();
            priceLevelCriteria.CreatedDate = createdDateRestriction;

            // Retrieve the list of price level objects
            priceLevels = wsDynamicsGP.GetPriceLevelList(priceLevelCriteria, context);

            // Display the description property of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PriceLevel a in priceLevels)
            {
                summaryList.AppendLine("Price level description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPricingByKey

Description

Retrieves a single pricing object based on the specified pricing key.

Parameters

Parameter | Type | Description
key | PricingKey | The pricing key object that specifies the pricing object to retrieve
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPricingByKeyResult | Pricing | A pricing object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves a pricing object with a price level of “RETAIL“ and an item key of “1-A3261A”. A message box displays the pricing object’s currency ISO code.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            PriceLevelKey priceLevelKey;
            PricingKey pricingKey;
            Pricing pricing;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "1-A3261A";

            // Create a price level key to specify the price level
            priceLevelKey = new PriceLevelKey();
            priceLevelKey.Id = "RETAIL";

            // Create a currency key to specify the price level
            CurrencyKey currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "USD";

            // Create a pricing key to specify the pricing object
            pricingKey = new PricingKey();
            pricingKey.ItemKey = itemKey;
            pricingKey.PriceLevelKey = priceLevelKey;
            pricingKey.CurrencyKey = currencyKey;
            pricingKey.UofM = "Each";

            // Get the specified pricing object
            pricing = wsDynamicsGP.GetPricingByKey(pricingKey, context);

            // Display the pricing object's currency ISO code
            MessageBox.Show("Pricing currency code: " + pricing.Key.CurrencyKey.ISOCode);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            PriceLevelKey priceLevelKey;
            PricingKey pricingKey;
            Pricing pricing;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "1-A3261A";

            // Create a price level key to specify the price level
            priceLevelKey = new PriceLevelKey();
            priceLevelKey.Id = "RETAIL";

            // Create a currency key to specify the price level
            CurrencyKey currencyKey = new CurrencyKey();
            currencyKey.ISOCode = "USD";

            // Create a pricing key to specify the pricing object
            pricingKey = new PricingKey();
            pricingKey.ItemKey = itemKey;
            pricingKey.PriceLevelKey = priceLevelKey;
            pricingKey.CurrencyKey = currencyKey;
            pricingKey.UofM = "Each";

            // Get the specified pricing object
            pricing = wsDynamicsGP.GetPricingByKey(pricingKey, context);

            // Display the pricing object's currency ISO code
            MessageBox.Show("Pricing currency code: " + pricing.Key.CurrencyKey.ISOCode);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPricingList

Description

Retrieves a list of pricing summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PricingCriteria | A pricing criteria object that specifies which pricing summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPricingListResult | ArrayOfPricingSummary | The list of pricing summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of pricing summary objects where the PriceLevelId property equals “Retail”. A message box displays the total number of pricing summary objects with the specified PriceLevelId.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString priceLevelIdRestriction;
            PricingCriteria pricingCriteria;
            PricingSummary[] pricingSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Get the items with a price level Id of 'Retail'
            priceLevelIdRestriction = new LikeRestrictionOfString();
            priceLevelIdRestriction.EqualValue = "Retail";

            // Create a pricing criteria object
            pricingCriteria = new PricingCriteria();
            pricingCriteria.PriceLevelId = priceLevelIdRestriction;

            // Retrieve the list of pricing summary objects
            pricingSummaries = wsDynamicsGP.GetPricingList(pricingCriteria, context);

            // Display the total number of items with a price level Id of 'Retail'
            MessageBox.Show("Total number of retail priced items: " + pricingSummaries.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring priceLevelIdRestriction;
            PricingCriteria pricingCriteria;
            PricingSummary[] pricingSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Get the items with a price level Id of 'Retail'
            priceLevelIdRestriction = new LikeRestrictionOfstring();
            priceLevelIdRestriction.EqualValue = "Retail";

            // Create a pricing criteria object
            pricingCriteria = new PricingCriteria();
            pricingCriteria.PriceLevelId = priceLevelIdRestriction;

            // Retrieve the list of pricing summary objects
            pricingSummaries = wsDynamicsGP.GetPricingList(pricingCriteria, context);

            // Display the total number of items with a price level Id of 'Retail'
            MessageBox.Show("Total number of retail priced items: " + pricingSummaries.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetProjectBudgetByKey

Description

Retrieves a single project budget object based on the specified project budget key.

Parameters

Parameter | Type | Description
key | ProjectBudgetKey | The project budget key object that specifies the project budget to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectBudgetByKeyResult | ProjectBudget | The project budget object.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectBudgetList

Description

Retrieves a list of project budget summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ProjectBudgetCriteria | A project budget criteria object that specifies which project budget summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectBudgetListResult | ArrayOfProjectBudgetSummary | The list of project budget summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectByKey

Description

Retrieves a single project object based on the specified project key.

Parameters

Parameter | Type | Description
key | ProjectKey | The project key object that specifies the project to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectByKeyResult | Project | The project object.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectChangeOrderByKey

Description

Retrieves a single project change order object based on the specified project change order key.

Parameters

Parameter | Type | Description
key | ProjectChangeOrderKey | The project change order key object that specifies the project change order to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectChangeOrderByKeyResult | ProjectChangeOrder | The project change order object.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectChangeOrderList

Description

Retrieves a list of project change order summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ProjectChangeOrderCriteria | A project change order criteria object that specifies which project change order summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectChangeOrderListResult | ArrayOfProjectChangeOrderSummary | The list of project change order summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectContractByKey

Description

Retrieves a single project contract object based on the specified project contract key.

Parameters

Parameter | Type | Description
key | ProjectContractKey | The project contract key object that specifies the project budget to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectContractByKeyResult | ProjectContract | The project contract.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectContractList

Description

Retrieves a list of project contract summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ProjectContractCriteria | A project contract criteria object that specifies which project contract summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectContractListResult | ArrayOfProjectContractSummary | The list of project contract summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectEmployeeExpenseByKey

Description

Retrieves a single project employee expense object based on the specified project employee expense key.

Parameters

Parameter | Type | Description
key | ProjectEmployeeExpenseKey | The project employee expense key object that specifies the project employee expense to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectEmployeeExpenseByKeyResult | ProjectEmployeeExpense | The project employee expense object.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectEmployeeExpenseList

Description

Retrieves a list of project employee expense summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ProjectEmployeeExpenseCriteria | A project employee expense criteria object that specifies which project employee expense summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectEmployeeExpenseListResult | ArrayOfProjectEmployeeExpenseSummary | The list of project employee expense summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectList

Description

Retrieves a list of project summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ProjectCriteria | A project criteria object that specifies which project summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectListResult | ArrayOfProjectSummary | The list of project summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectMiscellaneousLogByKey

Description

Retrieves a single project miscellaneous log object based on the specified project miscellaneous log key.

Parameters

Parameter | Type | Description
key | ProjectMiscellaneousLogKey | The project miscellaneous log key object that specifies the project miscellaneous log to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectMiscellaneousLogByKeyResult | ProjectMiscellaneousLog | The project miscellaneous log object.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectMiscellaneousLogList

Description

Retrieves a list of project miscellaneous log summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ProjectMiscellaneousLogCriteria | A project miscellaneous log criteria object that specifies which project miscellaneous log summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectMiscellaneousLogListResult | ArrayOfProjectMiscellaneousLogSummary | The list of project miscellaneous log summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectTimesheetByKey

Description

Retrieves a single project timesheet object based on the specified project timesheet key.

Parameters

Parameter | Type | Description
key | ProjectTimesheetKey | The project timesheet key object that specifies the project timesheet to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectTimesheetByKeyResult | ProjectTimesheet | The project timesheet object.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetProjectTimesheetList

Description

Retrieves a list of project timesheet summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ProjectTimesheetCriteria | A project timesheet criteria object that specifies which project timesheet summary objects to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetProjectTimesheetListResult | ArrayOfProjectTimesheetSummary | The list of project budget timesheet objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Project Accounting

Examples

A detailed example is not available for this method.


GetPurchaseInvoiceByKey

Description

Retrieves a single purchase invoice object based on the specified purchase transaction key.

Parameters

Parameter | Type | Description
key | PurchaseTransactionKey | The purchase transaction key object that specifies the purchase invoice to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPurchaseInvoiceByKeyResult | PurchaseInvoice | A purchase invoice object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a purchase invoice object with the key value “RCT1160”. A message box displays the Vendor Name property from the purchase invoice object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseInvoiceKey;
            PurchaseInvoice purchaseInvoice;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to specify the purchase invoice
            purchaseInvoiceKey = new PurchaseTransactionKey();
            purchaseInvoiceKey.Id = "RCT1160";

            // Retrieve the purchase invoice object
            purchaseInvoice = wsDynamicsGP.GetPurchaseInvoiceByKey(purchaseInvoiceKey, context);

            // Display the vendor name property from the purchase invoice object
            MessageBox.Show("Vendor name: " + purchaseInvoice.VendorName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseInvoiceKey;
            PurchaseInvoice purchaseInvoice;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to specify the purchase invoice
            purchaseInvoiceKey = new PurchaseTransactionKey();
            purchaseInvoiceKey.Id = "RCT1160";

            // Retrieve the purchase invoice object
            purchaseInvoice = wsDynamicsGP.GetPurchaseInvoiceByKey(purchaseInvoiceKey, context);

            // Display the vendor name property from the purchase invoice object
            MessageBox.Show("Vendor name: " + purchaseInvoice.VendorName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPurchaseInvoiceList

Description

Retrieves a list of purchase invoice summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PurchaseInvoiceCriteria | A purchase invoice criteria object that specifies which purchase invoice summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPurchaseInvoiceListResult | ArrayOfPurchaseInvoiceSummary | The list of purchase invoice summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of purchase invoice summary objects with a batch key of “ENTER/MATCH“. The Vendor Id and Subtotal property from each purchase invoice summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString batchIdRestriction;
            PurchaseInvoiceCriteria purchaseInvoiceCriteria;
            PurchaseInvoiceSummary[] purchaseInvoiceSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all purchase invoice summary object with a batch key of 'ENTER/MATCH'
            batchIdRestriction = new LikeRestrictionOfString();
            batchIdRestriction.EqualValue = "ENTER/MATCH";

            // Create a purchase invoice criteria object
            purchaseInvoiceCriteria = new PurchaseInvoiceCriteria();
            purchaseInvoiceCriteria.BatchId = batchIdRestriction;

            // Retrieve the list of purchase invoice summary objects
            purchaseInvoiceSummaries = wsDynamicsGP.GetPurchaseInvoiceList(purchaseInvoiceCriteria, context);

            // Display the vendor ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PurchaseInvoiceSummary a in purchaseInvoiceSummaries)
            {
                summaryList.AppendLine("Vendor Id: " + a.VendorKey.Id + "  Purchase invoice amount: " +
                a.Subtotal.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring batchIdRestriction;
            PurchaseInvoiceCriteria purchaseInvoiceCriteria;
            PurchaseInvoiceSummary[] purchaseInvoiceSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all purchase invoice summary object with a batch key of 'ENTER/MATCH'
            batchIdRestriction = new LikeRestrictionOfstring();
            batchIdRestriction.EqualValue = "ENTER/MATCH";

            // Create a purchase invoice criteria object
            purchaseInvoiceCriteria = new PurchaseInvoiceCriteria();
            purchaseInvoiceCriteria.BatchId = batchIdRestriction;

            // Retrieve the list of purchase invoice summary objects
            purchaseInvoiceSummaries = wsDynamicsGP.GetPurchaseInvoiceList(purchaseInvoiceCriteria, context);

            // Display the vendor ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PurchaseInvoiceSummary a in purchaseInvoiceSummaries)
            {
                summaryList.AppendLine("Vendor Id: " + a.VendorKey.Id + "  Purchase invoice amount: " +
                a.Subtotal.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPurchaseOrderByKey

Description

Retrieves a single purchase order object based on the specified purchase transaction key.

Parameters

Parameter | Type | Description
key | PurchaseTransactionKey | The purchase transaction key object that specifies the purchase order to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPurchaseOrderByKeyResult | PurchaseOrder | A purchase order object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a purchase order object with the key value “PO1007”. A message box displays the Remaining Subtotal property from the purchase order object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            PurchaseOrder purchaseOrder;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO1007";

            // Retrieve the purchase order object
            purchaseOrder = wsDynamicsGP.GetPurchaseOrderByKey(purchaseOrderKey, context);

            // Display the purchase order object's remaining subtotal property
            MessageBox.Show("Purchase order amount: " + purchaseOrder.RemainingSubtotal.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            PurchaseOrder purchaseOrder;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO1007";

            // Retrieve the purchase order object
            purchaseOrder = wsDynamicsGP.GetPurchaseOrderByKey(purchaseOrderKey, context);

            // Display the purchase order object's remaining subtotal property
            MessageBox.Show("Purchase order amount: " + purchaseOrder.RemainingSubtotal.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPurchaseOrderList

Description

Retrieves a list of purchase order summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PurchaseOrderCriteria | A purchase order criteria object that specifies which purchase order summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPurchaseOrderListResult | ArrayOfPurchaseOrderSummary | The list of purchase order summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of purchase order summary objects with a transaction state of “Work“. The Purchase Order Id and Vendor Id property from each purchase order summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPurchaseTransactionState transactionStateRestriction;
            PurchaseOrderCriteria purchaseOrderCriteria;
            PurchaseOrderSummary[] purchaseOrderSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve purchase orders with transaction state of 'Work'
            transactionStateRestriction = new ListRestrictionOfNullableOfPurchaseTransactionState();
            transactionStateRestriction.EqualValue = PurchaseTransactionState.Work;

            // Create the purchase order criteria object
            purchaseOrderCriteria = new PurchaseOrderCriteria();
            purchaseOrderCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of purchase order summary objects
            purchaseOrderSummaries = wsDynamicsGP.GetPurchaseOrderList(purchaseOrderCriteria, context);

            // Display the purchase order ID and vendor ID of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PurchaseOrderSummary a in purchaseOrderSummaries)
            {
                summaryList.AppendLine("Purchase order: " + a.Key.Id + "  Vendor ID: " +
                a.VendorKey.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfPurchaseTransactionState transactionStateRestriction;
            PurchaseOrderCriteria purchaseOrderCriteria;
            PurchaseOrderSummary[] purchaseOrderSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve purchase orders with transaction state of 'Work'
            transactionStateRestriction = new ListRestrictionOfNullableOfPurchaseTransactionState();
            transactionStateRestriction.EqualValue = PurchaseTransactionState.Work;

            // Create the purchase order criteria object
            purchaseOrderCriteria = new PurchaseOrderCriteria();
            purchaseOrderCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of purchase order summary objects
            purchaseOrderSummaries = wsDynamicsGP.GetPurchaseOrderList(purchaseOrderCriteria, context);

            // Display the purchase order ID and vendor ID of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PurchaseOrderSummary a in purchaseOrderSummaries)
            {
                summaryList.AppendLine("Purchase order: " + a.Key.Id + "  Vendor ID: " +
                a.VendorKey.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPurchaseReceiptByKey

Description

Retrieves a single purchase receipt object based on the specified purchase transaction key.

Parameters

Parameter | Type | Description
key | PurchaseTransactionKey | The purchase transaction key object that specifies the purchase receipt to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPurchaseReceiptByKeyResult | PurchaseReceipt | A purchase receipt object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a purchase receipt object with the key value “RCT1161”. A message box displays the vendor name property from the purchase receipt object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseReceiptKey;
            PurchaseReceipt purchaseReceipt;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to specify the purchase receipt
            purchaseReceiptKey = new PurchaseTransactionKey();
            purchaseReceiptKey.Id = "RCT1161";

            // Retrieve the purchase receipt object
            purchaseReceipt = wsDynamicsGP.GetPurchaseReceiptByKey(purchaseReceiptKey, context);

            // Display the vendor name property from the purchase receipt object
            MessageBox.Show("Vendor name: " + purchaseReceipt.VendorName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseReceiptKey;
            PurchaseReceipt purchaseReceipt;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to specify the purchase receipt
            purchaseReceiptKey = new PurchaseTransactionKey();
            purchaseReceiptKey.Id = "RCT1161";

            // Retrieve the purchase receipt object
            purchaseReceipt = wsDynamicsGP.GetPurchaseReceiptByKey(purchaseReceiptKey, context);

            // Display the vendor name property from the purchase receipt object
            MessageBox.Show("Vendor name: " + purchaseReceipt.VendorName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetPurchaseReceiptList

Description

Retrieves a list of purchase receipt summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | PurchaseReceiptCriteria | A purchase receipt criteria object that specifies which purchase receipt summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetPurchaseReceiptListResult | ArrayOfPurchaseReceiptSummary | The list of purchase receipt summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of purchase receipt summary objects where the vendor ID is equal to “ADVANCED0001“. The Purchase Receipt Id and Transaction State property from each purchase receipt summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString vendorIdRestriction;
            PurchaseReceiptCriteria purchaseReceiptCriteria;
            PurchaseReceiptSummary[] purchaseReceiptSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all purchase receipt summary object with a vendor Id of 'ADVANCED0001'
            vendorIdRestriction = new LikeRestrictionOfString();
            vendorIdRestriction.EqualValue = "ADVANCED0001";

            // Create the purchase receipt criteria object
            purchaseReceiptCriteria = new PurchaseReceiptCriteria();
            purchaseReceiptCriteria.VendorId = vendorIdRestriction;

            // Retrieve the list of purchase receipt summary objects
            purchaseReceiptSummaries = wsDynamicsGP.GetPurchaseReceiptList(purchaseReceiptCriteria, context);

            // Display the ID and transaction state of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PurchaseReceiptSummary a in purchaseReceiptSummaries)
            {
                summaryList.AppendLine("Purchase receipt: " + a.Key.Id + "  Transaction state: " +
                a.TransactionState.Value.ToString());
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring vendorIdRestriction;
            PurchaseReceiptCriteria purchaseReceiptCriteria;
            PurchaseReceiptSummary[] purchaseReceiptSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Retrieve all purchase receipt summary object with a vendor Id of 'ADVANCED0001'
            vendorIdRestriction = new LikeRestrictionOfstring();
            vendorIdRestriction.EqualValue = "ADVANCED0001";

            // Create the purchase receipt criteria object
            purchaseReceiptCriteria = new PurchaseReceiptCriteria();
            purchaseReceiptCriteria.VendorId = vendorIdRestriction;

            // Retrieve the list of purchase receipt summary objects
            purchaseReceiptSummaries = wsDynamicsGP.GetPurchaseReceiptList(purchaseReceiptCriteria, context);

            // Display the ID and transaction state of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (PurchaseReceiptSummary a in purchaseReceiptSummaries)
            {
                summaryList.AppendLine("Purchase receipt: " + a.Key.Id + "  Transaction state: " +
                a.TransactionState.Value.ToString());
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesCreditMemoByKey

Description

Retrieves a single receivables credit memo object based on the specified receivables document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | The receivables document key object that specifies the receivables credit memo to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesCreditMemoByKeyResult | ReceivablesCreditMemo | A receivables credit memo object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a receivables credit memo object with the key value “CM3000.1”. A message box displays the customer ID and the amount from the receivables credit memo object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey creditMemoKey;
            ReceivablesCreditMemo creditMemo;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivable document key to specify the receivables credit memo
            creditMemoKey = new ReceivablesDocumentKey();
            creditMemoKey.Id = "CM3000.1";

            // Retrieve the receivables credit memo object
            creditMemo = wsDynamicsGP.GetReceivablesCreditMemoByKey(creditMemoKey, context);

            // Display the credit memo’s customer ID and credit memo amount
            MessageBox.Show("Customer Id: " + creditMemo.CustomerKey.Id +
            "  Credit memo amount: " + creditMemo.SalesAmount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey creditMemoKey;
            ReceivablesCreditMemo creditMemo;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivable document key to specify the receivables credit memo
            creditMemoKey = new ReceivablesDocumentKey();
            creditMemoKey.Id = "CM3000.1";

            // Retrieve the receivables credit memo object
            creditMemo = wsDynamicsGP.GetReceivablesCreditMemoByKey(creditMemoKey, context);

            // Display the credit memo’s customer ID and credit memo amount
            MessageBox.Show("Customer Id: " + creditMemo.CustomerKey.Id +
            "  Credit memo amount: " + creditMemo.SalesAmount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesCreditMemoList

Description

Retrieves a list of receivables credit memo summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReceivablesCreditMemoCriteria | A receivables credit memo criteria object that specifies which receivables credit memo summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesCreditMemoListResult | ArrayOfReceivablesCreditMemoSummary | The list of receivables credit memo summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of receivables credit memo summary objects where the date property is between two specified dates. A message box displays the customer ID and the credit memo amount for the receivables credit memo summary objects that match the date criteria.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BetweenRestrictionOfNullableOfDateTime dateRestriction;
            ReceivablesCreditMemoCriteria creditMemoCriteria;
            ReceivablesCreditMemoSummary[] creditMemoSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all the credit memo objects from August 2003
            dateRestriction = new BetweenRestrictionOfNullableOfDateTime();
            dateRestriction.From = new DateTime(2003, 8, 1);
            dateRestriction.To = new DateTime(2003, 8, 30);

            // Create the credit memo criteria object
            creditMemoCriteria = new ReceivablesCreditMemoCriteria();
            creditMemoCriteria.Date = dateRestriction;

            // Retrieve the list of credit memo summary objects
            creditMemoSummaries = wsDynamicsGP.GetReceivablesCreditMemoList(creditMemoCriteria, context);

            // Display the customer ID and the amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesCreditMemoSummary a in creditMemoSummaries)
            {
                summaryList.AppendLine("Customer ID: " + a.CustomerKey.Id + "  Credit memo amount: " +
                a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            BetweenRestrictionOfNullableOfdateTime dateRestriction;
            ReceivablesCreditMemoCriteria creditMemoCriteria;
            ReceivablesCreditMemoSummary[] creditMemoSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all the credit memo objects from August 2003
            dateRestriction = new BetweenRestrictionOfNullableOfdateTime();
            dateRestriction.From = new DateTime(2003, 8, 1);
            dateRestriction.To = new DateTime(2003, 8, 30);

            // Create the credit memo criteria object
            creditMemoCriteria = new ReceivablesCreditMemoCriteria();
            creditMemoCriteria.Date = dateRestriction;

            // Retrieve the list of credit memo summary objects
            creditMemoSummaries = wsDynamicsGP.GetReceivablesCreditMemoList(creditMemoCriteria, context);

            // Display the customer ID and the amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesCreditMemoSummary a in creditMemoSummaries)
            {
                summaryList.AppendLine("Customer ID: " + a.CustomerKey.Id + "  Credit memo amount: " +
                a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesDebitMemoByKey

Description

Retrieves a single receivables debit memo object based on the specified receivables document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | The receivables document key object that specifies the receivables debit memo to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesDebitMemoByKeyResult | ReceivablesDebitMemo | A receivables debit memo object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a receivables debit memo object with the key value “DM18000”. A message box displays the customer ID and the amount from the receivables debit memo object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey debitMemoKey;
            ReceivablesDebitMemo debitMemo;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivable document key to specify the receivables debit memo
            debitMemoKey = new ReceivablesDocumentKey();
            debitMemoKey.Id = "DM18000";

            // Retrieve the receivables debit memo object
            debitMemo = wsDynamicsGP.GetReceivablesDebitMemoByKey(debitMemoKey, context);

            // Display the debit memo’s customer ID and debit memo amount
            MessageBox.Show("Customer Id: " + debitMemo.CustomerKey.Id +
            "  Debit memo amount: " + debitMemo.SalesAmount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey debitMemoKey;
            ReceivablesDebitMemo debitMemo;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivable document key to specify the receivables debit memo
            debitMemoKey = new ReceivablesDocumentKey();
            debitMemoKey.Id = "DM18000";

            // Retrieve the receivables debit memo object
            debitMemo = wsDynamicsGP.GetReceivablesDebitMemoByKey(debitMemoKey, context);

            // Display the debit memo’s customer ID and debit memo amount
            MessageBox.Show("Customer Id: " + debitMemo.CustomerKey.Id +
            "  Debit memo amount: " + debitMemo.SalesAmount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesDebitMemoList

Description

Retrieves a list of receivables debit memo summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReceivablesDebitMemoCriteria | A receivables debit memo criteria object that specifies which receivables debit memo summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesDebitMemoListResult | ArrayOfReceivablesDebitMemoSummary | The list of receivables debit memo summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a list of receivables debit memo summary objects. The example retrieves debit memo objects whose Key Id starts with “DM” and whose third Key Id character is less than or equal to a “2”. A message box displays the customer ID and the debit memo amount for the receivables debit memo summary objects that matched the criteria.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString documentIdRestriction;
            ReceivablesDebitMemoCriteria debitMemoCriteria;
            ReceivablesDebitMemoSummary[] debitMemoSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve the range of debit memo objects starting with 'DM' but less than 'DM2'
            documentIdRestriction = new LikeRestrictionOfString();
            documentIdRestriction.From = "DM";
            documentIdRestriction.To = "DM2";

            // Create the debit memo criteria object
            debitMemoCriteria = new ReceivablesDebitMemoCriteria();
            debitMemoCriteria.DocumentId = documentIdRestriction;

            // Retrieve the list of debit memo summary objects
            debitMemoSummaries = wsDynamicsGP.GetReceivablesDebitMemoList(debitMemoCriteria, context);

            // Display the customer ID and the amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesDebitMemoSummary a in debitMemoSummaries)
            {
                summaryList.AppendLine("Customer ID: " + a.CustomerKey.Id + "  Debit memo amount: " +
                a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring documentIdRestriction;
            ReceivablesDebitMemoCriteria debitMemoCriteria;
            ReceivablesDebitMemoSummary[] debitMemoSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve the range of debit memo objects starting with 'DM' but less than 'DM2'
            documentIdRestriction = new LikeRestrictionOfstring();
            documentIdRestriction.From = "DM";
            documentIdRestriction.To = "DM2";

            // Create the debit memo criteria object
            debitMemoCriteria = new ReceivablesDebitMemoCriteria();
            debitMemoCriteria.DocumentId = documentIdRestriction;

            // Retrieve the list of debit memo summary objects
            debitMemoSummaries = wsDynamicsGP.GetReceivablesDebitMemoList(debitMemoCriteria, context);

            // Display the customer ID and the amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesDebitMemoSummary a in debitMemoSummaries)
            {
                summaryList.AppendLine("Customer ID: " + a.CustomerKey.Id + "  Debit memo amount: " +
                a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesDocumentList

Description

Retrieves a list of receivables document summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReceivablesDocumentCriteria | A receivables document criteria object that specifies which receivables document summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesDocumentListResult | ArrayOfReceivablesDocumentSummary | The list of receivables document summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of receivables document summary objects where the customer Id is “AARONFIT0001“ and the document type is a service repair. The Date and DocumentAmount property from each receivables document summary object are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString customerIdRestriction;
            ListRestrictionOfNullableOfReceivablesDocumentType documentTypeRestriction;
            ReceivablesDocumentCriteria receivablesCriteria;
            ReceivablesDocumentSummary[] documentSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction objects
            // Retrieve all receivables documents with customer Id of 'AARONFIT0001'
            customerIdRestriction = new LikeRestrictionOfString();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Retrieve only receivables documents with a type of service repair
            documentTypeRestriction = new ListRestrictionOfNullableOfReceivablesDocumentType();
            documentTypeRestriction.EqualValue = ReceivablesDocumentType.ServiceRepair;

            // Create the receivables document criteria object
            receivablesCriteria = new ReceivablesDocumentCriteria();
            receivablesCriteria.CustomerId = customerIdRestriction;
            receivablesCriteria.Type = documentTypeRestriction;

            // Retrieve the list of receivables document summary objects
            documentSummaries = wsDynamicsGP.GetReceivablesDocumentList(receivablesCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesDocumentSummary a in documentSummaries)
            {
                summaryList.AppendLine("Service repair date: " + a.Date.Value.ToShortDateString()
                + "  Amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring customerIdRestriction;
            ListRestrictionOfNullableOfReceivablesDocumentType documentTypeRestriction;
            ReceivablesDocumentCriteria receivablesCriteria;
            ReceivablesDocumentSummary[] documentSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction objects
            // Retrieve all receivables documents with customer Id of 'AARONFIT0001'
            customerIdRestriction = new LikeRestrictionOfstring();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Retrieve only receivables documents with a type of service repair
            documentTypeRestriction = new ListRestrictionOfNullableOfReceivablesDocumentType();
            documentTypeRestriction.EqualValue = ReceivablesDocumentType.ServiceRepair;

            // Create the receivables document criteria object
            receivablesCriteria = new ReceivablesDocumentCriteria();
            receivablesCriteria.CustomerId = customerIdRestriction;
            receivablesCriteria.Type = documentTypeRestriction;

            // Retrieve the list of receivables document summary objects
            documentSummaries = wsDynamicsGP.GetReceivablesDocumentList(receivablesCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesDocumentSummary a in documentSummaries)
            {
                summaryList.AppendLine("Service repair date: " + a.Date.Value.ToShortDateString()
                + "  Amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesFinanceChargeByKey

Description

Retrieves a single receivables finance charge object based on the specified receivables document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | The receivables document key object that specifies the receivables finance charge to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesFinanceChargeByKeyResult | ReceivablesFinanceCharge | A receivables finance charge object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a receivables finance charge object with the key value “FC20010”. A message box displays the amount from the receivables finance charge object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey financeChargeKey;
            ReceivablesFinanceCharge financeCharge;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key object to specify the receivables finance charge
            financeChargeKey = new ReceivablesDocumentKey();
            financeChargeKey.Id = "FC20010";

            // Retrieve the receivables finance charge object
            financeCharge = wsDynamicsGP.GetReceivablesFinanceChargeByKey(financeChargeKey, context);

            // Display the finance charge amount
            MessageBox.Show("Total finance charge: " + financeCharge.DocumentAmount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey financeChargeKey;
            ReceivablesFinanceCharge financeCharge;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key object to specify the receivables finance charge
            financeChargeKey = new ReceivablesDocumentKey();
            financeChargeKey.Id = "FC20010";

            // Retrieve the receivables finance charge object
            financeCharge = wsDynamicsGP.GetReceivablesFinanceChargeByKey(financeChargeKey, context);

            // Display the finance charge amount
            MessageBox.Show("Total finance charge: " + financeCharge.DocumentAmount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesFinanceChargeList

Description

Retrieves a list of receivables finance charge summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReceivablesFinanceChargeCriteria | A receivables finance charge criteria object that specifies which receivables finance charge summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesFinanceChargeListResult | ArrayOfReceivablesFinanceChargeSummary | The list of receivables finance charge summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of receivables finance charge summary objects with a CustomerId of “AARONFIT0001“. The Date and DocumentAmount property from each receivables finance charge summary object are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString customerIdRestriction;
            ReceivablesFinanceChargeCriteria financeChargeCriteria;
            ReceivablesFinanceChargeSummary[] financeChargeSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve the finance charge objects for customer 'AARONFIT0001'
            customerIdRestriction = new LikeRestrictionOfString();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Create the receivables finance charge criteria object
            financeChargeCriteria = new ReceivablesFinanceChargeCriteria();
            financeChargeCriteria.CustomerId = customerIdRestriction;

            // Retrieve the list of receivables finance charge summary objects
            financeChargeSummaries = wsDynamicsGP.GetReceivablesFinanceChargeList(
            financeChargeCriteria, context);

            // Display the customer ID and the amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesFinanceChargeSummary a in financeChargeSummaries)
            {
                summaryList.AppendLine("Date: " + a.Date.Value.ToShortDateString() +
                "  Finance Charge amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring customerIdRestriction;
            ReceivablesFinanceChargeCriteria financeChargeCriteria;
            ReceivablesFinanceChargeSummary[] financeChargeSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve the finance charge objects for customer 'AARONFIT0001'
            customerIdRestriction = new LikeRestrictionOfstring();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Create the receivables finance charge criteria object
            financeChargeCriteria = new ReceivablesFinanceChargeCriteria();
            financeChargeCriteria.CustomerId = customerIdRestriction;

            // Retrieve the list of receivables finance charge summary objects
            financeChargeSummaries = wsDynamicsGP.GetReceivablesFinanceChargeList(
            financeChargeCriteria, context);

            // Display the customer ID and the amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesFinanceChargeSummary a in financeChargeSummaries)
            {
                summaryList.AppendLine("Date: " + a.Date.Value.ToShortDateString() +
                "  Finance Charge amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesInvoiceByKey

Description

Retrieves a single receivables invoice object based on the specified receivables document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | The receivables document key object that specifies the receivables invoice to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesInvoiceByKeyResult | ReceivablesInvoice | A receivables invoice object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a receivables invoice object with the key value “STDINV2185”. A message box displays the invoice amount.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey invoiceKey;
            ReceivablesInvoice receivablesInvoice;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables invoice key object to specify the receivables invoice
            invoiceKey = new ReceivablesDocumentKey();
            invoiceKey.Id = "STDINV2185";

            // Retrieve the receivables invoice object
            receivablesInvoice = wsDynamicsGP.GetReceivablesInvoiceByKey(invoiceKey, context);

            // Display the invoice amount
            MessageBox.Show("Invoice amount: " + receivablesInvoice.DocumentAmount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey invoiceKey;
            ReceivablesInvoice receivablesInvoice;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables invoice key object to specify the receivables invoice
            invoiceKey = new ReceivablesDocumentKey();
            invoiceKey.Id = "STDINV2185";

            // Retrieve the receivables invoice object
            receivablesInvoice = wsDynamicsGP.GetReceivablesInvoiceByKey(invoiceKey, context);

            // Display the invoice amount
            MessageBox.Show("Invoice amount: " + receivablesInvoice.DocumentAmount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesInvoiceList

Description

Retrieves a list of receivables invoice summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReceivablesInvoiceCriteria | A receivables invoice criteria object that specifies which receivables invoice summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesInvoiceListResult | ArrayOfReceivablesInvoiceSummary | The list of receivables invoice summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of receivables invoice summary objects with a SalespersonId of “Nancy B.“. A message box displays the number of receivables invoice summary objects that were retrieved.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString salespersonRestriction;
            ReceivablesInvoiceCriteria invoiceCriteria;
            ReceivablesInvoiceSummary[] invoiceSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all receivables invoice objects for salesperson 'Nancy B.'
            salespersonRestriction = new LikeRestrictionOfString();
            salespersonRestriction.EqualValue = "Nancy B.";

            // Create the receivables invoice criteria object
            invoiceCriteria = new ReceivablesInvoiceCriteria();
            invoiceCriteria.SalespersonId = salespersonRestriction;

            // Retrieve the list of receivables invoice summary objects
            invoiceSummaries = wsDynamicsGP.GetReceivablesInvoiceList(invoiceCriteria, context);

            // Display the number of receivables invoice objects in the list
            MessageBox.Show("Total invoices for Nancy B.:  " + invoiceSummaries.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring salespersonRestriction;
            ReceivablesInvoiceCriteria invoiceCriteria;
            ReceivablesInvoiceSummary[] invoiceSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all receivables invoice objects for salesperson 'Nancy B.'
            salespersonRestriction = new LikeRestrictionOfstring();
            salespersonRestriction.EqualValue = "Nancy B.";

            // Create the receivables invoice criteria object
            invoiceCriteria = new ReceivablesInvoiceCriteria();
            invoiceCriteria.SalespersonId = salespersonRestriction;

            // Retrieve the list of receivables invoice summary objects
            invoiceSummaries = wsDynamicsGP.GetReceivablesInvoiceList(invoiceCriteria, context);

            // Display the number of receivables invoice objects in the list
            MessageBox.Show("Total invoices for Nancy B.:  " + invoiceSummaries.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesReturnByKey

Description

Retrieves a single receivables return object based on the specified receivables document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | The receivables document key object that specifies the receivables return to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesReturnByKeyResult | ReceivablesReturn | A receivables return object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a receivables return object with the key value “RTN18022”. A message box displays the customer ID and the return amount.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey receivablesReturnKey;
            ReceivablesReturn receivablesReturn;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivable return key to specify the receivables return object
            receivablesReturnKey = new ReceivablesDocumentKey();
            receivablesReturnKey.Id = "RTN18022";

            // Retrieve the receivables return object
            receivablesReturn = wsDynamicsGP.GetReceivablesReturnByKey(receivablesReturnKey, context);

            // Display the customer ID and return amount from the receivables return object
            MessageBox.Show("Customer Id: " + receivablesReturn.CustomerKey.Id + "  Returned amount: "
            + receivablesReturn.DocumentAmount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey receivablesReturnKey;
            ReceivablesReturn receivablesReturn;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivable return key to specify the receivables return object
            receivablesReturnKey = new ReceivablesDocumentKey();
            receivablesReturnKey.Id = "RTN18022";

            // Retrieve the receivables return object
            receivablesReturn = wsDynamicsGP.GetReceivablesReturnByKey(receivablesReturnKey, context);

            // Display the customer ID and return amount from the receivables return object
            MessageBox.Show("Customer Id: " + receivablesReturn.CustomerKey.Id + "  Returned amount: "
            + receivablesReturn.DocumentAmount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesReturnList

Description

Retrieves a list of receivables return summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReceivablesReturnCriteria | A receivables return criteria object that specifies which receivables return summary objects are retrieved.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesReturnListResult | ArrayOfReceivablesReturnSummary | The list of receivables return summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of receivables return summary objects with a SalespersonId of “Nancy B.“. A message box displays the date and amount from each receivables return summary object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program

        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString salespersonRestriction;
            ReceivablesReturnCriteria receivablesReturnCriteria;
            ReceivablesReturnSummary[] receivablesReturnSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all receivables return summary objects for salesperson 'Nancy B.'
            salespersonRestriction = new LikeRestrictionOfString();
            salespersonRestriction.EqualValue = "Nancy B.";

            // Create the receivables return criteria object
            receivablesReturnCriteria = new ReceivablesReturnCriteria();
            receivablesReturnCriteria.SalespersonId = salespersonRestriction;

            // Retrieve the list of receivables return summary objects
            receivablesReturnSummaries = wsDynamicsGP.GetReceivablesReturnList(
            receivablesReturnCriteria, context);

            // Display the date and amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesReturnSummary a in receivablesReturnSummaries)
            {
                summaryList.AppendLine("Return date: " + a.Date.Value.ToShortDateString()
                + "  Returned amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program

        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring salespersonRestriction;
            ReceivablesReturnCriteria receivablesReturnCriteria;
            ReceivablesReturnSummary[] receivablesReturnSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all receivables return summary objects for salesperson 'Nancy B.'
            salespersonRestriction = new LikeRestrictionOfstring();
            salespersonRestriction.EqualValue = "Nancy B.";

            // Create the receivables return criteria object
            receivablesReturnCriteria = new ReceivablesReturnCriteria();
            receivablesReturnCriteria.SalespersonId = salespersonRestriction;

            // Retrieve the list of receivables return summary objects
            receivablesReturnSummaries = wsDynamicsGP.GetReceivablesReturnList(
            receivablesReturnCriteria, context);

            // Display the date and amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesReturnSummary a in receivablesReturnSummaries)
            {
                summaryList.AppendLine("Return date: " + a.Date.Value.ToShortDateString()
                + "  Returned amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesServiceRepairByKey

Description

Retrieves a single receivables service repair object based on the specified receivables document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | The receivables document key object that specifies the receivables service repair to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesServiceRepairByKeyResult | ReceivablesServiceRepair | A receivables service repair object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a receivables service repair object with the key value “SVC11020”. A message box displays the service repair amount.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey serviceRepairKey;
            ReceivablesServiceRepair receivablesServiceRepair;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the receivables service repair key object to specify the service repair
            serviceRepairKey = new ReceivablesDocumentKey();
            serviceRepairKey.Id = "SVC11020";

            // Retrieve the receivables service repair object
            receivablesServiceRepair = wsDynamicsGP.GetReceivablesServiceRepairByKey(
            serviceRepairKey, context);

            // Display the service repair amount
            MessageBox.Show("Service repair amount: " +
            receivablesServiceRepair.DocumentAmount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey serviceRepairKey;
            ReceivablesServiceRepair receivablesServiceRepair;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the receivables service repair key object to specify the service repair
            serviceRepairKey = new ReceivablesDocumentKey();
            serviceRepairKey.Id = "SVC11020";

            // Retrieve the receivables service repair object
            receivablesServiceRepair = wsDynamicsGP.GetReceivablesServiceRepairByKey(
            serviceRepairKey, context);

            // Display the service repair amount
            MessageBox.Show("Service repair amount: " +
            receivablesServiceRepair.DocumentAmount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesServiceRepairList

Description

Retrieves a list of receivables service repair summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReceivablesServiceRepairCriteria | A receivables service repair criteria object that specifies which receivables service repair summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesServiceRepairListResult | ArrayOfReceivablesServiceRepairSummary | The list of receivables service repair summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of receivables service repair summary objects where the salesperson Id is “Nancy B.“ and the transaction state is a “Open”. The Date and DocumentAmount property from each receivables service repair summary object are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString salespersonRestriction;
            ListRestrictionOfNullableOfReceivablesTransactionState transactionStateRestriction;
            ReceivablesServiceRepairCriteria serviceRepairCriteria;
            ReceivablesServiceRepairSummary[] repairSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction objects
            // Retrieve receivables repair documents with a transaction state of 'Open'
            transactionStateRestriction = new ListRestrictionOfNullableOfReceivablesTransactionState();
            transactionStateRestriction.EqualValue = ReceivablesTransactionState.Open;

            // Retrieve only receivables service repair document with a sales person Id like 'Nancy B.'
            salespersonRestriction = new LikeRestrictionOfString();
            salespersonRestriction.Like = "Nancy B.";

            // Create the receivables service repair criteria object and add the restriction objects
            serviceRepairCriteria = new ReceivablesServiceRepairCriteria();
            serviceRepairCriteria.SalespersonId = salespersonRestriction;
            serviceRepairCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of receivables service repair summary objects
            repairSummaries = wsDynamicsGP.GetReceivablesServiceRepairList(serviceRepairCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesServiceRepairSummary a in repairSummaries)
            {
                summaryList.AppendLine("Service date: " + a.Date.Value.ToShortDateString()
                + "  Amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring salespersonRestriction;
            ListRestrictionOfNullableOfReceivablesTransactionState transactionStateRestriction;
            ReceivablesServiceRepairCriteria serviceRepairCriteria;
            ReceivablesServiceRepairSummary[] repairSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction objects
            // Retrieve receivables repair documents with a transaction state of 'Open'
            transactionStateRestriction = new ListRestrictionOfNullableOfReceivablesTransactionState();
            transactionStateRestriction.EqualValue = ReceivablesTransactionState.Open;

            // Retrieve only receivables service repair document with a sales person Id like 'Nancy B.'
            salespersonRestriction = new LikeRestrictionOfstring();
            salespersonRestriction.Like = "Nancy B.";

            // Create the receivables service repair criteria object and add the restriction objects
            serviceRepairCriteria = new ReceivablesServiceRepairCriteria();
            serviceRepairCriteria.SalespersonId = salespersonRestriction;
            serviceRepairCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of receivables service repair summary objects
            repairSummaries = wsDynamicsGP.GetReceivablesServiceRepairList(serviceRepairCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesServiceRepairSummary a in repairSummaries)
            {
                summaryList.AppendLine("Service date: " + a.Date.Value.ToShortDateString()
                + "  Amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesWarrantyByKey

Description

Retrieves a single receivables warranty object based on the specified receivables document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | The receivables document key object that specifies the receivables warranty to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesWarrantyByKeyResult | ReceivablesWarranty | A receivables warranty object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a receivables warranty object with the Key value “WRN4003”. A message box displays the customer ID and the warranty amount.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey receivablesWarrantyKey;
            ReceivablesWarranty receivablesWarranty;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key to specify the receivables warranty object
            receivablesWarrantyKey = new ReceivablesDocumentKey();
            receivablesWarrantyKey.Id = "WRN4003";

            // Retrieve the receivables warranty object
            receivablesWarranty = wsDynamicsGP.GetReceivablesWarrantyByKey(receivablesWarrantyKey, context);

            // Display the Customer ID and the warranty amount
            MessageBox.Show("Customer Id: " + receivablesWarranty.CustomerKey.Id + "  Warranty Amount: "
            + receivablesWarranty.DocumentAmount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey receivablesWarrantyKey;
            ReceivablesWarranty receivablesWarranty;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key to specify the receivables warranty object
            receivablesWarrantyKey = new ReceivablesDocumentKey();
            receivablesWarrantyKey.Id = "WRN4003";

            // Retrieve the receivables warranty object
            receivablesWarranty = wsDynamicsGP.GetReceivablesWarrantyByKey(receivablesWarrantyKey, context);

            // Display the Customer ID and the warranty amount
            MessageBox.Show("Customer Id: " + receivablesWarranty.CustomerKey.Id + "  Warranty Amount: "
            + receivablesWarranty.DocumentAmount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReceivablesWarrantyList

Description

Retrieves a list of receivables warranty summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReceivablesWarrantyCriteria | A receivables warranty criteria object that specifies which receivables warranty summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReceivablesWarrantyListResult | ArrayOfReceivablesWarrantySummary | The list of receivables warranty summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of receivables warranty summary objects where the customer Id is “ADAMPARK0001“. The Date and DocumentAmount property from each receivables warranty summary object are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString customerIdRestriction;
            ReceivablesWarrantyCriteria receivablesWarrantyCriteria;
            ReceivablesWarrantySummary[] receivablesWarrantySummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all receivables warranty objects for the customer 'ADAMPARK0001'
            customerIdRestriction = new LikeRestrictionOfString();
            customerIdRestriction.EqualValue = "ADAMPARK0001";

            // Create the receivables warranty criteria object
            receivablesWarrantyCriteria = new ReceivablesWarrantyCriteria();
            receivablesWarrantyCriteria.CustomerId = customerIdRestriction;

            // Retrieve the list of receivables warranty summary objects
            receivablesWarrantySummaries = wsDynamicsGP.GetReceivablesWarrantyList(
            receivablesWarrantyCriteria, context);

            // Display the date and amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesWarrantySummary a in receivablesWarrantySummaries)
            {
                summaryList.AppendLine("Warranty date: " + a.Date.Value.ToShortDateString()
                + "  Warranty amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring customerIdRestriction;
            ReceivablesWarrantyCriteria receivablesWarrantyCriteria;
            ReceivablesWarrantySummary[] receivablesWarrantySummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all receivables warranty objects for the customer 'ADAMPARK0001'
            customerIdRestriction = new LikeRestrictionOfstring();
            customerIdRestriction.EqualValue = "ADAMPARK0001";

            // Create the receivables warranty criteria object
            receivablesWarrantyCriteria = new ReceivablesWarrantyCriteria();
            receivablesWarrantyCriteria.CustomerId = customerIdRestriction;

            // Retrieve the list of receivables warranty summary objects
            receivablesWarrantySummaries = wsDynamicsGP.GetReceivablesWarrantyList(
            receivablesWarrantyCriteria, context);

            // Display the date and amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReceivablesWarrantySummary a in receivablesWarrantySummaries)
            {
                summaryList.AppendLine("Warranty date: " + a.Date.Value.ToShortDateString()
                + "  Warranty amount: " + a.DocumentAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReturnMaterialAuthorizationByKey

Description

Retrieves a single return material authorization object based on the specified service document key.

Parameters

Parameter | Type | Description
key | ServiceDocumentKey | The service document key object that specifies the return materiall authorization to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReturnMaterialAuthorizationByKeyResult | ReturnMaterialAuthorization | A return material authorization object.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves a return material authorization object with the key ID value of “RMA000000003001”. A message box displays the customer name

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ReturnMaterialAuthorization returnMaterialsAuthorization;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key
            // Specify the RMA document number
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "RMA000000003001";

            // Retrieve the return materials authorization object
            returnMaterialsAuthorization = wsDynamicsGP.GetReturnMaterialAuthorizationByKey
                (serviceDocumentKey, context);

            // Display the customer name
            MessageBox.Show("Customer name: " + returnMaterialsAuthorization.CustomerName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ReturnMaterialAuthorization returnMaterialsAuthorization;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key
            // Specify the RMA document number
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "RMA000000003001";

            // Retrieve the return materials authorization object
            returnMaterialsAuthorization = wsDynamicsGP.GetReturnMaterialAuthorizationByKey
                (serviceDocumentKey, context);

            // Display the customer name
            MessageBox.Show("Customer name: " + returnMaterialsAuthorization.CustomerName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetReturnMaterialAuthorizationList

Description

Retrieves a list of return material authorization summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ReturnMaterialAuthorizationCriteria | A return material authorization criteria object that specifies which return material authorization summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetReturnMaterialAuthorizationListResult | ArrayOfReturnMaterialAuthorizationSummary | The list of return material authorization summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves the list of return material authorization summary objects where the ReturnTpeId property is equal to “Svc”. The customer name and return type of each return material authorization summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReturnMaterialAuthorizationCriteria returnMaterialAuthorizationCriteria;
            LikeRestrictionOfString returnTypeRestriction;
            ReturnMaterialAuthorizationSummary[] returnMaterialAuthorizationSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the like restriction of string object
            returnTypeRestriction = new LikeRestrictionOfString();
            returnTypeRestriction.EqualValue = "SVC";

            // Create the return material authorization criteria object
            returnMaterialAuthorizationCriteria = new ReturnMaterialAuthorizationCriteria();
            returnMaterialAuthorizationCriteria.ReturnTypeId = returnTypeRestriction;

            // Retrieve the list of return material authorization summary objects
            returnMaterialAuthorizationSummary = wsDynamicsGP.GetReturnMaterialAuthorizationList
                (returnMaterialAuthorizationCriteria, context);

            // Display the customer name and return type for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReturnMaterialAuthorizationSummary a in returnMaterialAuthorizationSummary)
            {
                summaryList.AppendLine("Customer name: " + a.CustomerName + "   Return Type: "
                    + a.ReturnTypeKey.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReturnMaterialAuthorizationCriteria returnMaterialAuthorizationCriteria;
            LikeRestrictionOfstring returnTypeRestriction;
            ReturnMaterialAuthorizationSummary[] returnMaterialAuthorizationSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the like restriction of string object
            returnTypeRestriction = new LikeRestrictionOfstring();
            returnTypeRestriction.EqualValue = "SVC";

            // Create the return material authorization criteria object
            returnMaterialAuthorizationCriteria = new ReturnMaterialAuthorizationCriteria();
            returnMaterialAuthorizationCriteria.ReturnTypeId = returnTypeRestriction;

            // Retrieve the list of return material authorization summary objects
            returnMaterialAuthorizationSummary = wsDynamicsGP.GetReturnMaterialAuthorizationList
                (returnMaterialAuthorizationCriteria, context);

            // Display the customer name and return type for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ReturnMaterialAuthorizationSummary a in returnMaterialAuthorizationSummary)
            {
                summaryList.AppendLine("Customer name: " + a.CustomerName + "   Return Type: "
                    + a.ReturnTypeKey.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesBackorderByKey

Description

Retrieves a single sales backorder object based on the specified sales document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key object that specifies the sales backorder to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesBackorderByKeyResult | SalesBackorder | A sales backorder object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a sales backorder object with the key value “BKO1005”. A message box displays the customer name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesBackorderKey;
            SalesBackorder salesBackorder;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesBackorderKey = new SalesDocumentKey();
            salesBackorderKey.Id = "BKO1005";

            // Retrieve the sales backorder object
            salesBackorder = wsDynamicsGP.GetSalesBackorderByKey(salesBackorderKey, context);

            // Display the customer name
            MessageBox.Show("Customer name: " + salesBackorder.CustomerName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesBackorderKey;
            SalesBackorder salesBackorder;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesBackorderKey = new SalesDocumentKey();
            salesBackorderKey.Id = "BKO1005";

            // Retrieve the sales backorder object
            salesBackorder = wsDynamicsGP.GetSalesBackorderByKey(salesBackorderKey, context);

            // Display the customer name
            MessageBox.Show("Customer name: " + salesBackorder.CustomerName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesBackorderList

Description

Retrieves a list of sales backorder summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalesBackorderCriteria | A sales backorder criteria object that specifies which sales backorder summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesBackorderListResult | ArrayOfSalesBackorderSummary | The list of sales backorder summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of sales backorder summary objects where the TransactionState property is equal to “Work”. The Id and TotalAmount property from each sales backorder summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesBackorderCriteria salesBackorderCriteria;
            SalesBackorderSummary[] salesBackorderSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a transaction state restriction object
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales backorder criteria object
            salesBackorderCriteria = new SalesBackorderCriteria();
            salesBackorderCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the sales backorder summary objects specified by the criteria object
            salesBackorderSummary = wsDynamicsGP.GetSalesBackorderList(salesBackorderCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesBackorderSummary a in salesBackorderSummary)
            {
                summaryList.AppendLine("Backorder number: " + a.Key.Id + "  Backordered amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesBackorderCriteria salesBackorderCriteria;
            SalesBackorderSummary[] salesBackorderSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a transaction state restriction object
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales backorder criteria object
            salesBackorderCriteria = new SalesBackorderCriteria();
            salesBackorderCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the sales backorder summary objects specified by the criteria object
            salesBackorderSummary = wsDynamicsGP.GetSalesBackorderList(salesBackorderCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesBackorderSummary a in salesBackorderSummary)
            {
                summaryList.AppendLine("Backorder number: " + a.Key.Id + "  Backordered amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesDocumentList

Description

Retrieves a list of sales document summary objects that match the specified criteria. The list may contain different types of sales documents.

Parameters

Parameter | Type | Description
criteria | SalesDocumentCriteria | A sales document criteria object that specifies which sales document summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesDocumentListResult | ArrayOfSalesDocumentSummary | The list of sales document summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of sales document summary objects where the CustomerId property equals “AARONFIT0001“ and the TransactionState property is equal to “Work”. The list includes sales orders, sales invoices, sales returns, and sales backorders for the specified customer. The Type and TotalAmount property from each sales document summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString customerIdRestriction;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesDocumentCriteria salesDocumentCriteria;
            SalesDocumentSummary[] salesDocumentSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer ID restriction object
            customerIdRestriction = new LikeRestrictionOfString();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Create a transaction state restriction object
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales document criteria object
            salesDocumentCriteria = new SalesDocumentCriteria();
            salesDocumentCriteria.CustomerId = customerIdRestriction;
            salesDocumentCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the sales document summary objects specified by the criteria object
            salesDocumentSummary = wsDynamicsGP.GetSalesDocumentList(salesDocumentCriteria, context);

            // Display the type and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            summaryList.AppendLine("Customer Summary for:  " + salesDocumentSummary[0].CustomerName);
            foreach (SalesDocumentSummary a in salesDocumentSummary)
            {
                summaryList.AppendLine("Document Type: " + a.Type.ToString() + "  Total amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring customerIdRestriction;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesDocumentCriteria salesDocumentCriteria;
            SalesDocumentSummary[] salesDocumentSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer ID restriction object
            customerIdRestriction = new LikeRestrictionOfstring();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Create a transaction state restriction object
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales document criteria object
            salesDocumentCriteria = new SalesDocumentCriteria();
            salesDocumentCriteria.CustomerId = customerIdRestriction;
            salesDocumentCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the sales document summary objects specified by the criteria object
            salesDocumentSummary = wsDynamicsGP.GetSalesDocumentList(salesDocumentCriteria, context);

            // Display the type and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            summaryList.AppendLine("Customer Summary for:  " + salesDocumentSummary[0].CustomerName);
            foreach (SalesDocumentSummary a in salesDocumentSummary)
            {
                summaryList.AppendLine("Document Type: " + a.Type.ToString() + "  Total amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesFulfillmentOrderByKey

Description

Retrieves a single sales fulfillment order object based on the specified sales document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key object that specifies the sales fulfillment order to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesFulfillmentOrderByKeyResult | SalesFulfillmentOrder | A sales fulfillment order object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a sales fulfillment order object with the key value “FULORD1000”. A message box displays the customer name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            SalesFulfillmentOrder salesFulfillmentOrder;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales fulfillment order
            documentKey = new SalesDocumentKey();
            documentKey.Id = "FULORD1000";

            // Retrieve the sales fulfillment order object
            salesFulfillmentOrder = wsDynamicsGP.GetSalesFulfillmentOrderByKey(documentKey, context);

            // Display the customer name property from the sales fulfillment order object
            MessageBox.Show("Customer name: " + salesFulfillmentOrder.CustomerName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            SalesFulfillmentOrder salesFulfillmentOrder;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales fulfillment order
            documentKey = new SalesDocumentKey();
            documentKey.Id = "FULORD1000";

            // Retrieve the sales fulfillment order object
            salesFulfillmentOrder = wsDynamicsGP.GetSalesFulfillmentOrderByKey(documentKey, context);

            // Display the customer name property from the sales fulfillment order object
            MessageBox.Show("Customer name: " + salesFulfillmentOrder.CustomerName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesFulfillmentOrderList

Description

Retrieves a list of sales fulfillment order summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalesFulfillmentOrderCriteria | A sales fulfillment order criteria object that specifies which sales fulfillment order summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesFulfillmentOrderListResult | ArrayOfSalesFulfillmentOrderSummary | The list of sales fulfillment order summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of sales fulfillment order summary objects where the CustomerId begins with “A”. The customer name and total amount from each sales invoice summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString customerIdRestriction;
            SalesFulfillmentOrderCriteria fulfillmentOrderCriteria;
            SalesFulfillmentOrderSummary[] salesFulfillmentOrderSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all sales fulfillment orders with a customer Id that begin with 'A'
            customerIdRestriction = new LikeRestrictionOfString();
            customerIdRestriction.Like = "A%";

            // Create a criteria object
            fulfillmentOrderCriteria = new SalesFulfillmentOrderCriteria();
            fulfillmentOrderCriteria.CustomerId = customerIdRestriction;

            // Retrieve the list of sales fulfillment order summary objects
            salesFulfillmentOrderSummaries = wsDynamicsGP.GetSalesFulfillmentOrderList(
            fulfillmentOrderCriteria, context);

            // Display the customer name and total order amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesFulfillmentOrderSummary a in salesFulfillmentOrderSummaries)
            {
                summaryList.AppendLine("Customer name: " + a.CustomerName + "  Fulfillment order amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring customerIdRestriction;
            SalesFulfillmentOrderCriteria fulfillmentOrderCriteria;
            SalesFulfillmentOrderSummary[] salesFulfillmentOrderSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all sales fulfillment orders with a customer Id that begin with 'A'
            customerIdRestriction = new LikeRestrictionOfstring();
            customerIdRestriction.Like = "A%";

            // Create a criteria object
            fulfillmentOrderCriteria = new SalesFulfillmentOrderCriteria();
            fulfillmentOrderCriteria.CustomerId = customerIdRestriction;

            // Retrieve the list of sales fulfillment order summary objects
            salesFulfillmentOrderSummaries = wsDynamicsGP.GetSalesFulfillmentOrderList(
            fulfillmentOrderCriteria, context);

            // Display the customer name and total order amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesFulfillmentOrderSummary a in salesFulfillmentOrderSummaries)
            {
                summaryList.AppendLine("Customer name: " + a.CustomerName + "  Fulfillment order amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesInvoiceByKey

Description

Retrieves a single sales invoice object based on the specified sales document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key object that specifies the sales invoice to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesInvoiceByKeyResult | SalesInvoice | A sales invoice object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a sales invoice object with the key value “STDINV2255”. A message box displays the customer name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesInvoiceKey;
            SalesInvoice salesInvoice;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesInvoiceKey = new SalesDocumentKey();
            salesInvoiceKey.Id = "STDINV2255";

            // Retrieve the sales invoice
            salesInvoice = wsDynamicsGP.GetSalesInvoiceByKey(salesInvoiceKey, context);

            // Display the sales invoice customer name
            MessageBox.Show("Customer name: " + salesInvoice.CustomerName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesInvoiceKey;
            SalesInvoice salesInvoice;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesInvoiceKey = new SalesDocumentKey();
            salesInvoiceKey.Id = "STDINV2255";

            // Retrieve the sales invoice
            salesInvoice = wsDynamicsGP.GetSalesInvoiceByKey(salesInvoiceKey, context);

            // Display the sales invoice customer name
            MessageBox.Show("Customer name: " + salesInvoice.CustomerName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesInvoiceList

Description

Retrieves a list of sales invoice summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalesInvoiceCriteria | A sales invoice criteria object that specifies which sales invoice summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesInvoiceListResult | ArrayOfSalesInvoiceSummary | The list of sales invoice summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of sales invoice summary objects where the SalespersonId value is equal to “PAUL W.” and the TransactionState property is equal to “Work”. The Id and TotalAmount property from each sales invoice summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString salespersonIdRestriction;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesInvoiceCriteria salesInvoiceCriteria;
            SalesInvoiceSummary[] salesInvoiceSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a salesperson restriction object
            salespersonIdRestriction = new LikeRestrictionOfString();
            salespersonIdRestriction.EqualValue = "PAUL W.";

            // Create a transaction state restriction object
            // The SaleTransactionState enumeration specifies the transaction state
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales invoice criteria object
            // Retrieve summary objects of unposted sales invoices for the specified salesperson
            salesInvoiceCriteria = new SalesInvoiceCriteria();
            salesInvoiceCriteria.TransactionState = transactionStateRestriction;
            salesInvoiceCriteria.SalespersonId = salespersonIdRestriction;

            // Retrieve the sales invoice summaries specified by the criteria object
            salesInvoiceSummary = wsDynamicsGP.GetSalesInvoiceList(salesInvoiceCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesInvoiceSummary a in salesInvoiceSummary)
            {
                summaryList.AppendLine("Invoice number: " + a.Key.Id + "  Invoice amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring salespersonIdRestriction;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesInvoiceCriteria salesInvoiceCriteria;
            SalesInvoiceSummary[] salesInvoiceSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a salesperson restriction object
            salespersonIdRestriction = new LikeRestrictionOfstring();
            salespersonIdRestriction.EqualValue = "PAUL W.";

            // Create a transaction state restriction object
            // The SaleTransactionState enumeration specifies the transaction state
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales invoice criteria object
            // Retrieve summary objects of unposted sales invoices for the specified salesperson
            salesInvoiceCriteria = new SalesInvoiceCriteria();
            salesInvoiceCriteria.TransactionState = transactionStateRestriction;
            salesInvoiceCriteria.SalespersonId = salespersonIdRestriction;

            // Retrieve the sales invoice summaries specified by the criteria object
            salesInvoiceSummary = wsDynamicsGP.GetSalesInvoiceList(salesInvoiceCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesInvoiceSummary a in salesInvoiceSummary)
            {
                summaryList.AppendLine("Invoice number: " + a.Key.Id + "  Invoice amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesOrderByKey

Description

Retrieves a single sales order object based on the specified sales document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key object that specifies the sales order to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesOrderByKeyResult | SalesOrder | A sales order object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a sales order object with the key value “ORDST2229”. A message box displays the customer name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesOrderKey;
            SalesOrder salesOrder;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesOrderKey = new SalesDocumentKey();
            salesOrderKey.Id = "ORDST2229";

            // Retrieve the sales order
            salesOrder = wsDynamicsGP.GetSalesOrderByKey(salesOrderKey, context);

            // Display the sales order customer name
            MessageBox.Show("Customer: " + salesOrder.CustomerName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesOrderKey;
            SalesOrder salesOrder;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesOrderKey = new SalesDocumentKey();
            salesOrderKey.Id = "ORDST2229";

            // Retrieve the sales order
            salesOrder = wsDynamicsGP.GetSalesOrderByKey(salesOrderKey, context);

            // Display the sales order customer name
            MessageBox.Show("Customer: " + salesOrder.CustomerName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesOrderList

Description

Retrieves a list of sales order summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalesOrderCriteria | A sales order criteria object that specifies which sales order summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesOrderListResult | ArrayOfSalesOrderSummary | The list of sales order summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of sales order summary objects where the CustomerKey value is equal to “AARONFIT0001” and the TransactionState property is equal to “Work”. The Id and TotalAmount property from each sales order summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString customerIdRestriction;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesOrderCriteria salesOrderCriteria;
            SalesOrderSummary[] salesOrderSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer restriction object
            // Specify the customer ID
            customerIdRestriction = new LikeRestrictionOfString();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Create a transaction state restriction object
            // The SaleTransactionState enumeration specifies the transaction state
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales order criteria object
            // Retrieve summary objects of active sales orders for the specified customer
            salesOrderCriteria = new SalesOrderCriteria();
            salesOrderCriteria.TransactionState = transactionStateRestriction;
            salesOrderCriteria.CustomerId = customerIdRestriction;

            // Retrieve the sales order summaries specified by the criteria object
            salesOrderSummary = wsDynamicsGP.GetSalesOrderList(salesOrderCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesOrderSummary a in salesOrderSummary)
            {
                summaryList.AppendLine("Order number: " + a.Key.Id + "  Order amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring customerIdRestriction;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesOrderCriteria salesOrderCriteria;
            SalesOrderSummary[] salesOrderSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer restriction object
            // Specify the customer ID
            customerIdRestriction = new LikeRestrictionOfstring();
            customerIdRestriction.EqualValue = "AARONFIT0001";

            // Create a transaction state restriction object
            // The SaleTransactionState enumeration specifies the transaction state
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales order criteria object
            // Retrieve summary objects of active sales orders for the specified customer
            salesOrderCriteria = new SalesOrderCriteria();
            salesOrderCriteria.TransactionState = transactionStateRestriction;
            salesOrderCriteria.CustomerId = customerIdRestriction;

            // Retrieve the sales order summaries specified by the criteria object
            salesOrderSummary = wsDynamicsGP.GetSalesOrderList(salesOrderCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesOrderSummary a in salesOrderSummary)
            {
                summaryList.AppendLine("Order number: " + a.Key.Id + "  Order amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesProcessHoldSetupByKey

Description

Retrieves a single sales process hold setup object based on the specified sales process hold setup key.

Parameters

Parameter | Type | Description
key | SalesProcessHoldSetupKey | The sales process hold setup key object that specifies the sales process hold setup to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesProcessHoldSetupByKeyResult | SalesProcessHoldSetup | A sales process hold setup object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a sales process hold setup object with the key value “ADDRESS”. A message box displays the sales process hold setup description property.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesProcessHoldSetupKey salesProcessHoldSetupKey;
            SalesProcessHoldSetup salesProcessHoldSetup;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales process hold setup key object
            salesProcessHoldSetupKey = new SalesProcessHoldSetupKey();
            salesProcessHoldSetupKey.Id = "ADDRESS";

            // Retrieve the sales process setup hold object
            salesProcessHoldSetup = wsDynamicsGP.GetSalesProcessHoldSetupByKey(
            salesProcessHoldSetupKey, context);

            // Display the sales process hold setup description
            MessageBox.Show("Description: " + salesProcessHoldSetup.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesProcessHoldSetupKey salesProcessHoldSetupKey;
            SalesProcessHoldSetup salesProcessHoldSetup;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales process hold setup key object
            salesProcessHoldSetupKey = new SalesProcessHoldSetupKey();
            salesProcessHoldSetupKey.Id = "ADDRESS";

            // Retrieve the sales process setup hold object
            salesProcessHoldSetup = wsDynamicsGP.GetSalesProcessHoldSetupByKey(
            salesProcessHoldSetupKey, context);

            // Display the sales process hold setup description
            MessageBox.Show("Description: " + salesProcessHoldSetup.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesProcessHoldSetupList

Description

Retrieves a list of sales process hold setup objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalesProcessHoldSetupCriteria | A sales process hold setup criteria object that specifies which sales process hold setup objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesProcessHoldSetupListResult | ArrayOfSalesProcessHoldSetup | The list of sales process hold setup objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of sales process hold setup objects where the Id value begins with “A”. The Description property from each sales process hold setup object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString idRestriction;
            SalesProcessHoldSetupCriteria salesProcessHoldSetupCriteria;
            SalesProcessHoldSetup[] salesProcessHoldSetupList;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a string restriction object
            // Retrieve all sales process setup holds with a name beginning with 'A'
            idRestriction = new LikeRestrictionOfString();
            idRestriction.Like = "A%";

            // Create a criteria object
            salesProcessHoldSetupCriteria = new SalesProcessHoldSetupCriteria();
            salesProcessHoldSetupCriteria.Id = idRestriction;

            // Retrieve the sales process hold setup objects specified by the criteria object
            salesProcessHoldSetupList = wsDynamicsGP.GetSalesProcessHoldSetupList(
            salesProcessHoldSetupCriteria, context);

            // Display the description of each member of the sales process hold setup object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesProcessHoldSetup a in salesProcessHoldSetupList)
            {
                summaryList.AppendLine("Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring idRestriction;
            SalesProcessHoldSetupCriteria salesProcessHoldSetupCriteria;
            SalesProcessHoldSetup[] salesProcessHoldSetupList;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a string restriction object
            // Retrieve all sales process setup holds with a name beginning with 'A'
            idRestriction = new LikeRestrictionOfstring();
            idRestriction.Like = "A%";

            // Create a criteria object
            salesProcessHoldSetupCriteria = new SalesProcessHoldSetupCriteria();
            salesProcessHoldSetupCriteria.Id = idRestriction;

            // Retrieve the sales process hold setup objects specified by the criteria object
            salesProcessHoldSetupList = wsDynamicsGP.GetSalesProcessHoldSetupList(
            salesProcessHoldSetupCriteria, context);

            // Display the description of each member of the sales process hold setup object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesProcessHoldSetup a in salesProcessHoldSetupList)
            {
                summaryList.AppendLine("Description: " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesQuoteByKey

Description

Retrieves a single sales quote object based on the specified sales document key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales document key object that specifies the sales quote to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesQuoteByKeyResult | SalesQuote | A sales quote object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a sales quote object with the key value “QTEST1022”. A message box displays the customer name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            SalesQuote salesQuote;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales quote
            documentKey = new SalesDocumentKey();
            documentKey.Id = "QTEST1022";

            // Retrieve the sales quote object
            salesQuote = wsDynamicsGP.GetSalesQuoteByKey(documentKey, context);

            // Display the customer name property of the sales quote object
            MessageBox.Show("Customer name: " + salesQuote.CustomerName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            SalesQuote salesQuote;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales quote
            documentKey = new SalesDocumentKey();
            documentKey.Id = "QTEST1022";

            // Retrieve the sales quote object
            salesQuote = wsDynamicsGP.GetSalesQuoteByKey(documentKey, context);

            // Display the customer name property of the sales quote object
            MessageBox.Show("Customer name: " + salesQuote.CustomerName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesQuoteList

Description

Retrieves a list of sales quote summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalesQuoteCriteria | A sales quote criteria object that specifies which sales quote summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesQuoteListResult | ArrayOfSalesQuoteSummary | The list of sales quote summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of sales quote summary objects where the Batch ID equals “SALES QUOTES”. The Id and amount property from each sales quote summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString batchIdRestriction;
            SalesQuoteCriteria salesQuoteCriteria;
            SalesQuoteSummary[] salesQuoteSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all sales quotes for a specified batch ID
            batchIdRestriction = new LikeRestrictionOfString();
            batchIdRestriction.EqualValue = "SALES QUOTES";

            // Create a sales quote criteria object
            salesQuoteCriteria = new SalesQuoteCriteria();
            salesQuoteCriteria.BatchId = batchIdRestriction;

            // Retrieve the list of sales quote summary objects
            salesQuoteSummaries = wsDynamicsGP.GetSalesQuoteList(salesQuoteCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesQuoteSummary a in salesQuoteSummaries)
            {
                summaryList.AppendLine("Sales quote: " + a.Key.Id + "  Quote amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring batchIdRestriction;
            SalesQuoteCriteria salesQuoteCriteria;
            SalesQuoteSummary[] salesQuoteSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve all sales quotes for a specified batch ID
            batchIdRestriction = new LikeRestrictionOfstring();
            batchIdRestriction.EqualValue = "SALES QUOTES";

            // Create a sales quote criteria object
            salesQuoteCriteria = new SalesQuoteCriteria();
            salesQuoteCriteria.BatchId = batchIdRestriction;

            // Retrieve the list of sales quote summary objects
            salesQuoteSummaries = wsDynamicsGP.GetSalesQuoteList(salesQuoteCriteria, context);

            // Display the ID and amount of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesQuoteSummary a in salesQuoteSummaries)
            {
                summaryList.AppendLine("Sales quote: " + a.Key.Id + "  Quote amount: " +
                a.TotalAmount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesReturnByKey

Description

Retrieves a single sales return object based on the specified sales return key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | The sales return key object that specifies the sales return to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesReturnByKeyResult | SalesReturn | A sales return object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a sales return object with the key value “STDINV2257”. A message box displays the customer name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            SalesReturn salesReturn;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Sales Return key and specify the sales return
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Retrieve the sales return object
            salesReturn = wsDynamicsGP.GetSalesReturnByKey(salesReturnKey, context);

            // Display the customer name
            MessageBox.Show("Customer name: " + salesReturn.CustomerName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            SalesReturn salesReturn;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Sales Return key and specify the sales return
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Retrieve the sales return object
            salesReturn = wsDynamicsGP.GetSalesReturnByKey(salesReturnKey, context);

            // Display the customer name
            MessageBox.Show("Customer name: " + salesReturn.CustomerName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesReturnList

Description

Retrieves a list of sales return summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalesReturnCriteria | A sales return criteria object that specifies which sales return summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesReturnListResult | ArrayOfSalesReturnSummary | The list of sales return summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the list of sales return summary objects for sales returns whose Sales Transaction State property equals “Work”. The Id and Customer Name property from each sales return summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesReturnCriteria salesReturnCriteria;
            SalesReturnSummary[] salesReturnSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // The SalesTransactionState enumeration specifies the transaction state
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales return criteria object
            // Retrieve summary objects of sales returns that have not been posted
            salesReturnCriteria = new SalesReturnCriteria();
            salesReturnCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the sales return summaries specified by the criteria object
            salesReturnSummary = wsDynamicsGP.GetSalesReturnList(salesReturnCriteria, context);

            // Display the ID and Name of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesReturnSummary a in salesReturnSummary)
            {
                summaryList.AppendLine("ID:" + a.Key.Id + "  Customer:" + a.CustomerName);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ListRestrictionOfNullableOfSalesTransactionState transactionStateRestriction;
            SalesReturnCriteria salesReturnCriteria;
            SalesReturnSummary[] salesReturnSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // The SalesTransactionState enumeration specifies the transaction state
            transactionStateRestriction = new ListRestrictionOfNullableOfSalesTransactionState();
            transactionStateRestriction.EqualValue = SalesTransactionState.Work;

            // Create a sales return criteria object
            // Retrieve summary objects of sales returns that have not been posted
            salesReturnCriteria = new SalesReturnCriteria();
            salesReturnCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the sales return summaries specified by the criteria object
            salesReturnSummary = wsDynamicsGP.GetSalesReturnList(salesReturnCriteria, context);

            // Display the ID and Name of each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesReturnSummary a in salesReturnSummary)
            {
                summaryList.AppendLine("ID:" + a.Key.Id + "  Customer:" + a.CustomerName);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesTerritoryByKey

Description

Retrieves a single sales territory object based on the specified sales territory key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalesTerritoryKey | The sales territory key object that specifies the sales territory to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesTerritoryByKeyResult | SalesTerritory | A sales territory object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a sales territory object with the key value “TERRITORY 1”. A message box displays the territory description and country.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesTerritoryKey territoryKey;
            SalesTerritory territory;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales territory key object to specify the sales territory
            territoryKey = new SalesTerritoryKey();
            territoryKey.Id = "TERRITORY 1";

            // Retrieve the sales territory object
            territory = wsDynamicsGP.GetSalesTerritoryByKey(territoryKey, context);

            // Display a description of the sales territory
            MessageBox.Show("Territory: " + territory.Description +
            "  Country: " + territory.Country);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesTerritoryKey territoryKey;
            SalesTerritory territory;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales territory key object to specify the sales territory
            territoryKey = new SalesTerritoryKey();
            territoryKey.Id = "TERRITORY 1";

            // Retrieve the sales territory object
            territory = wsDynamicsGP.GetSalesTerritoryByKey(territoryKey, context);

            // Display a description of the sales territory
            MessageBox.Show("Territory: " + territory.Description +
            "  Country: " + territory.Country);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalesTerritoryList

Description

Retrieves a list of sales territory summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalesTerritoryCriteria | A sales territory criteria object that specifies which sales territory summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalesTerritoryListResult | ArrayOfSalesTerritorySummary | The list of sales territory summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of all sales territory summary objects. A message box displays the description and the sales manager for each sales territory.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesTerritoryCriteria territoryCriteria;
            SalesTerritorySummary[] territorySummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            LikeRestrictionOfString idRestriction = new LikeRestrictionOfString();
            idRestriction.Like = "%";

            // Create the sales territory criteria object
            territoryCriteria = new SalesTerritoryCriteria();
            territoryCriteria.Id = idRestriction;

            // Retrieve the list of sales territory objects
            territorySummaries = wsDynamicsGP.GetSalesTerritoryList(territoryCriteria, context);

            // Display the territory and sales manager for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesTerritorySummary a in territorySummaries)
            {
                summaryList.AppendLine("Territory: " + a.Description + "   Sales manager: " +
                a.SalesManagerFirstName + " " + a.SalesManagerLastName);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesTerritoryCriteria territoryCriteria;
            SalesTerritorySummary[] territorySummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            LikeRestrictionOfstring idRestriction = new LikeRestrictionOfstring();
            idRestriction.Like = "%";

            // Create the sales territory criteria object
            territoryCriteria = new SalesTerritoryCriteria();
            territoryCriteria.Id = idRestriction;

            // Retrieve the list of sales territory objects
            territorySummaries = wsDynamicsGP.GetSalesTerritoryList(territoryCriteria, context);

            // Display the territory and sales manager for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalesTerritorySummary a in territorySummaries)
            {
                summaryList.AppendLine("Territory: " + a.Description + "   Sales manager: " +
                a.SalesManagerFirstName + " " + a.SalesManagerLastName);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalespersonByKey

Description

Retrieves a single salesperson object based on the specified salesperson key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalespersonKey | The salesperson key object that specifies the salesperson to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalespersonByKeyResult | Salesperson | A salesperson object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a salesperson object with the key value “SANDRA M.”. A message box displays the salesperson name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalespersonKey salesPersonKey;
            Salesperson salesPerson;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales person key object to specify the sales person
            salesPersonKey = new SalespersonKey();
            salesPersonKey.Id = "SANDRA M.";

            // Retrieve the sales person object
            salesPerson = wsDynamicsGP.GetSalespersonByKey(salesPersonKey, context);

            // Display the name of the sales person
            MessageBox.Show("Sales person: " + salesPerson.FirstName + " " + salesPerson.LastName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalespersonKey salesPersonKey;
            Salesperson salesPerson;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales person key object to specify the sales person
            salesPersonKey = new SalespersonKey();
            salesPersonKey.Id = "SANDRA M.";

            // Retrieve the sales person object
            salesPerson = wsDynamicsGP.GetSalespersonByKey(salesPersonKey, context);

            // Display the name of the sales person
            MessageBox.Show("Sales person: " + salesPerson.FirstName + " " + salesPerson.LastName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalespersonCommissionsByKey

Description

Retrieves a single salesperson commissions object based on the specified salesperson commissions key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | SalespersonCommissionsKey | The salesperson commissions key object that specifies the salesperson commissions object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalespersonCommissionsByKeyResult | SalespersonCommissions | A salesperson commissions object.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a salesperson commissions object with the document number “INV1016” and a sequence number of “16384“. A message box displays the sales invoice commission amount.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalespersonCommissionsKey commissionsKey;
            SalespersonCommissions salespersonCommissions;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a salesperson commission key object to specify the sales commissions
            commissionsKey = new SalespersonCommissionsKey();
            commissionsKey.DocumentNumber = "INV1016";
            commissionsKey.SequenceNumber = 16384;

            // Retrieve the salesperson commission object
            salespersonCommissions = wsDynamicsGP.GetSalespersonCommissionsByKey(commissionsKey, context);

            // Display the commission amount for the sales invoice
            MessageBox.Show("Commission amount: " + salespersonCommissions.Amount.Value.ToString("C"));
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalespersonCommissionsKey commissionsKey;
            SalespersonCommissions salespersonCommissions;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a salesperson commission key object to specify the sales commissions
            commissionsKey = new SalespersonCommissionsKey();
            commissionsKey.DocumentNumber = "INV1016";
            commissionsKey.SequenceNumber = 16384;

            // Retrieve the salesperson commission object
            salespersonCommissions = wsDynamicsGP.GetSalespersonCommissionsByKey(commissionsKey, context);

            // Display the commission amount for the sales invoice
            MessageBox.Show("Commission amount: " + salespersonCommissions.Amount.Value.ToString("C"));

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalespersonCommissionsList

Description

Retrieves a list of salesperson commission objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalespersonCommissionsCriteria | A salesperson commissions criteria object that specifies which salesperson commissions summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalespersonCommissionsListResult | ArrayOfSalespersonCommissionsSummary | The list of salesperson commissions summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves a list of salesperson commissions summary objects. The example retrieves a salesperson's commissions on open sales invoices for the customer with a key of “METROPOL0001“. The sales amount and commission amount from each salesperson commissions summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString salespersonIdRestriction;
            LikeRestrictionOfString customerIdRestriction;
            ListRestrictionOfNullableOfSalespersonCommissionsDocumentType salesDocumentTypeRestriction;
            ListRestrictionOfNullableOfSalesCommissionTransactionState transactionStateRestriction;
            SalespersonCommissionsCriteria commissionsCriteria;
            SalespersonCommissionsSummary[] commissionsSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create four restriction objects
            // Retrieve a sales person's commissions on open sales invoices for one customer
            salespersonIdRestriction = new LikeRestrictionOfString();
            salespersonIdRestriction.Like = "SANDRA M.";

            customerIdRestriction = new LikeRestrictionOfString();
            customerIdRestriction.EqualValue = "METROPOL0001";

            salesDocumentTypeRestriction = new
            ListRestrictionOfNullableOfSalespersonCommissionsDocumentType();
            salesDocumentTypeRestriction.EqualValue = SalespersonCommissionsDocumentType.SalesInvoice;

            transactionStateRestriction = new ListRestrictionOfNullableOfSalesCommissionTransactionState();
            transactionStateRestriction.EqualValue = SalesCommissionTransactionState.Open;

            // Create the criteria object
            commissionsCriteria = new SalespersonCommissionsCriteria();
            commissionsCriteria.SalespersonId = salespersonIdRestriction;
            commissionsCriteria.CustomerId = customerIdRestriction;
            commissionsCriteria.DocumentType = salesDocumentTypeRestriction;
            commissionsCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of salespersons commissions summary objects
            commissionsSummaries = wsDynamicsGP.GetSalespersonCommissionsList(commissionsCriteria, context);

            // Display the sales amount and commission amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalespersonCommissionsSummary a in commissionsSummaries)
            {
                summaryList.AppendLine("Sales amount: " + a.SalesAmount.Value.ToString("C")
                + "  Commission amount: " + a.Amount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring salespersonIdRestriction;
            LikeRestrictionOfstring customerIdRestriction;
            ListRestrictionOfNullableOfSalespersonCommissionsDocumentType salesDocumentTypeRestriction;
            ListRestrictionOfNullableOfSalesCommissionTransactionState transactionStateRestriction;
            SalespersonCommissionsCriteria commissionsCriteria;
            SalespersonCommissionsSummary[] commissionsSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create four restriction objects
            // Retrieve a sales person's commissions on open sales invoices for one customer
            salespersonIdRestriction = new LikeRestrictionOfstring();
            salespersonIdRestriction.Like = "SANDRA M.";

            customerIdRestriction = new LikeRestrictionOfstring();
            customerIdRestriction.EqualValue = "METROPOL0001";

            salesDocumentTypeRestriction = new
            ListRestrictionOfNullableOfSalespersonCommissionsDocumentType();
            salesDocumentTypeRestriction.EqualValue = SalespersonCommissionsDocumentType.SalesInvoice;

            transactionStateRestriction = new ListRestrictionOfNullableOfSalesCommissionTransactionState();
            transactionStateRestriction.EqualValue = SalesCommissionTransactionState.Open;

            // Create the criteria object
            commissionsCriteria = new SalespersonCommissionsCriteria();
            commissionsCriteria.SalespersonId = salespersonIdRestriction;
            commissionsCriteria.CustomerId = customerIdRestriction;
            commissionsCriteria.DocumentType = salesDocumentTypeRestriction;
            commissionsCriteria.TransactionState = transactionStateRestriction;

            // Retrieve the list of salespersons commissions summary objects
            commissionsSummaries = wsDynamicsGP.GetSalespersonCommissionsList(commissionsCriteria, context);

            // Display the sales amount and commission amount for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalespersonCommissionsSummary a in commissionsSummaries)
            {
                summaryList.AppendLine("Sales amount: " + a.SalesAmount.Value.ToString("C")
                + "  Commission amount: " + a.Amount.Value.ToString("C"));
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSalespersonList

Description

Retrieves a list of salesperson objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SalespersonCriteria | A salesperson criteria object that specifies which salesperson summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSalespersonListResult | ArrayOfSalespersonSummary | The list of salesperson summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of salesperson summary objects that have a last name property that begins with “M”. The salesperson name and sales territory properties from each salesperson summary object are displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalespersonCriteria salesPersonCriteria;
            SalespersonSummary[] salesPersonSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve sales person objects with last name that begins with 'M'
            LikeRestrictionOfString nameRestriction = new LikeRestrictionOfString();
            nameRestriction.Like = "M%";

            // Create the criteria object
            salesPersonCriteria = new SalespersonCriteria();
            salesPersonCriteria.LastName = nameRestriction;

            // Retrieve the list of sales person objects
            salesPersonSummaries = wsDynamicsGP.GetSalespersonList(salesPersonCriteria, context);

            // Display the sales person name and territory for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalespersonSummary a in salesPersonSummaries)
            {
                summaryList.AppendLine("Sales Person: " + a.FirstName + " " + a.LastName
                + "  Sales Territory: " + a.SalesTerritoryKey.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalespersonCriteria salesPersonCriteria;
            SalespersonSummary[] salesPersonSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve sales person objects with last name that begins with 'M'
            LikeRestrictionOfstring nameRestriction = new LikeRestrictionOfstring();
            nameRestriction.Like = "M%";

            // Create the criteria object
            salesPersonCriteria = new SalespersonCriteria();
            salesPersonCriteria.LastName = nameRestriction;

            // Retrieve the list of sales person objects
            salesPersonSummaries = wsDynamicsGP.GetSalespersonList(salesPersonCriteria, context);

            // Display the sales person name and territory for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (SalespersonSummary a in salesPersonSummaries)
            {
                summaryList.AppendLine("Sales Person: " + a.FirstName + " " + a.LastName
                + "  Sales Territory: " + a.SalesTerritoryKey.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetServiceByKey

Description

Retrieves a single service object based on the specified item key.

Parameters

Parameter | Type | Description
key | ItemKey | The item key object that specifies the service to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetServiceByKeyResult | Service | A service object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves a service object with the key value “SPLN-TWO-0001”. A message box displays the service description.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey serviceKey;
            Service service;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the service
            serviceKey = new ItemKey();
            serviceKey.Id = "SPLN-TWO-0001";

            // Retrieve the service
            service = wsDynamicsGP.GetServiceByKey(serviceKey, context);

            // Display the service description
            MessageBox.Show("Service description: " + service.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey serviceKey;
            Service service;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the service
            serviceKey = new ItemKey();
            serviceKey.Id = "SPLN-TWO-0001";

            // Retrieve the service
            service = wsDynamicsGP.GetServiceByKey(serviceKey, context);

            // Display the service description
            MessageBox.Show("Service description: " + service.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetServiceCallByKey

Description

Retrieves a single service call object based on the specified service document key.

Parameters

Parameter | Type | Description
key | ServiceDocumentKey | The service document key object that specifies the service call to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetServiceCallByKeyResult | ServiceCall | A service call object.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves a service call object with the service document key value “0000002022”. A message box displays the service call customer name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ServiceCall serviceCall;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key object
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "0000002022";

            // Retrieve the specified service call object
            serviceCall = wsDynamicsGP.GetServiceCallByKey(serviceDocumentKey, context);

            // Display the service call customer name
            MessageBox.Show("Customer: " + serviceCall.CustomerName);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ServiceCall serviceCall;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key object
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "0000002022";

            // Retrieve the specified service call object
            serviceCall = wsDynamicsGP.GetServiceCallByKey(serviceDocumentKey, context);

            // Display the service call customer name
            MessageBox.Show("Customer: " + serviceCall.CustomerName);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetServiceCallList

Description

Retrieves a list of service call summmary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ServiceCallCriteria | A service call criteria object that specifies which service call summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetServiceCallListResult | ArrayOfServiceCallSummary | The list of service call summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves the list of service call summary objects with a technician Id property of “T0102”. The technician Id and customer name properties from each service call summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString technicianId;
            ServiceCallCriteria serviceCallCriteria;
            ServiceCallSummary[] serviceCallSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve service call summaries with the technician Id 'T0102'
            technicianId = new LikeRestrictionOfString();
            technicianId.EqualValue = "T0102";

            // Create a service call criteria object
            // Retrieve service call summaries for the specified technician Id
            serviceCallCriteria = new ServiceCallCriteria();
            serviceCallCriteria.TechnicianId = technicianId;

            // Retrieve the service call summaries specified by the criteria object
            serviceCallSummary = wsDynamicsGP.GetServiceCallList(serviceCallCriteria, context);

            // Display the technician Id and customer name of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ServiceCallSummary a in serviceCallSummary)
            {
                summaryList.AppendLine("Technician: " + a.TechnicianKey.Id
                    + "    Customer: " + a.CustomerName);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring technicianId;
            ServiceCallCriteria serviceCallCriteria;
            ServiceCallSummary[] serviceCallSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve service call summaries with the technician Id 'T0102'
            technicianId = new LikeRestrictionOfstring();
            technicianId.EqualValue = "T0102";

            // Create a service call criteria object
            // Retrieve service call summaries for the specified technician Id
            serviceCallCriteria = new ServiceCallCriteria();
            serviceCallCriteria.TechnicianId = technicianId;

            // Retrieve the service call summaries specified by the criteria object
            serviceCallSummary = wsDynamicsGP.GetServiceCallList(serviceCallCriteria, context);

            // Display the technician Id and customer name of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ServiceCallSummary a in serviceCallSummary)
            {
                summaryList.AppendLine("Technician: " + a.TechnicianKey.Id
                    + "    Customer: " + a.CustomerName);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetServiceEquipmentByKey

Description

Retrieves a single service equipment object based on the specified service equipment key.

Parameters

Parameter | Type | Description
key | ServiceEquipmentKey | The service equipment key object that specifies the service equipment to retrieve. The service equipment key requires an item key and service equipment Id.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetServiceEquipmentByKeyResult | ServiceEquipment | A service call object.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves a service equipment object with the service equipment key value “00045478” and an item key with an Id of “2-A3284A“. A message box displays the service equipment customer Id and status.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            ServiceEquipmentKey serviceEquipmentKey;
            ServiceEquipment serviceEquipment;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object
            itemKey = new ItemKey();
            itemKey.Id = "2-A3284A";

            // Create a service equipment key object
            serviceEquipmentKey = new ServiceEquipmentKey();
            serviceEquipmentKey.Id = "00045478";
            serviceEquipmentKey.ItemKey = itemKey;

            // Retrieve the specified service equipment object
            serviceEquipment = wsDynamicsGP.GetServiceEquipmentByKey(serviceEquipmentKey, context);

            // Display the service equipment description
            MessageBox.Show("Customer: " + serviceEquipment.CustomerKey.Id +
                "  Status: " + serviceEquipment.StatusKey.Id);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            ServiceEquipmentKey serviceEquipmentKey;
            ServiceEquipment serviceEquipment;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object
            itemKey = new ItemKey();
            itemKey.Id = "2-A3284A";

            // Create a service equipment key object
            serviceEquipmentKey = new ServiceEquipmentKey();
            serviceEquipmentKey.Id = "00045478";
            serviceEquipmentKey.ItemKey = itemKey;

            // Retrieve the specified service equipment object
            serviceEquipment = wsDynamicsGP.GetServiceEquipmentByKey(serviceEquipmentKey, context);

            // Display the service equipment description
            MessageBox.Show("Customer: " + serviceEquipment.CustomerKey.Id +
                "  Status: " + serviceEquipment.StatusKey.Id);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetServiceEquipmentList

Description

Retrieves a list of service equipment summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ServiceEquipmentCriteria | A service equipment criteria object that specifies which service equipment summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetServiceEquipmentListResult | ArrayOfServiceEquipmentSummary | The list of service equipment summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves the list of service equipment summary objects with a status of “RETURN”. The customer Id and status properties from each service equipment summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString statusRestriction;
            ServiceEquipmentCriteria serviceEquipmentCriteria;
            ServiceEquipmentSummary[] serviceEquipmentSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve service equipment summaries with status of 'RETURN'
            statusRestriction = new LikeRestrictionOfString();
            statusRestriction.EqualValue = "RETURN";

            // Create a service equipment criteria object
            // Retrieve service call summaries with the specified status
            serviceEquipmentCriteria = new ServiceEquipmentCriteria();
            serviceEquipmentCriteria.StatusId = statusRestriction;

            // Retrieve the service equipment summaries specified by the criteria object
            serviceEquipmentSummary = wsDynamicsGP.GetServiceEquipmentList
                (serviceEquipmentCriteria, context);

            // Display the customer Id and status of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ServiceEquipmentSummary a in serviceEquipmentSummary)
            {
                summaryList.AppendLine("Customer Id: " + a.CustomerKey.Id + "    Status: " + a.StatusKey.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring statusRestriction;
            ServiceEquipmentCriteria serviceEquipmentCriteria;
            ServiceEquipmentSummary[] serviceEquipmentSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve service equipment summaries with status of 'RETURN'
            statusRestriction = new LikeRestrictionOfstring();
            statusRestriction.EqualValue = "RETURN";

            // Create a service equipment criteria object
            // Retrieve service call summaries with the specified status
            serviceEquipmentCriteria = new ServiceEquipmentCriteria();
            serviceEquipmentCriteria.StatusId = statusRestriction;

            // Retrieve the service equipment summaries specified by the criteria object
            serviceEquipmentSummary = wsDynamicsGP.GetServiceEquipmentList
                (serviceEquipmentCriteria, context);

            // Display the customer Id and status of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ServiceEquipmentSummary a in serviceEquipmentSummary)
            {
                summaryList.AppendLine("Customer Id: " + a.CustomerKey.Id + "    Status: " + a.StatusKey.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetServiceList

Description

Retrieves a list of service objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ServiceCriteria | A service criteria object that specifies which service summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetServiceListResult | ArrayOfServiceSummary | The list of service summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of service summary objects with a generic description property of “Labor”. The Id and Description properties from each service summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString serviceRestriction;
            ServiceCriteria serviceCriteria;
            ServiceSummary[] serviceSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            serviceRestriction = new LikeRestrictionOfString();
            serviceRestriction.Like = "Labor";

            // Create a service criteria object
            // Retrieve service summaries with a generic description property of Labor
            serviceCriteria = new ServiceCriteria();
            serviceCriteria.GenericDescription = serviceRestriction;

            // Retrieve the service summaries specified by the criteria object
            serviceSummary = wsDynamicsGP.GetServiceList(serviceCriteria, context);

            // Display the ID and Description properties of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ServiceSummary a in serviceSummary)
            {
                summaryList.AppendLine("Service: " + a.Key.Id + " - " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring serviceRestriction;
            ServiceCriteria serviceCriteria;
            ServiceSummary[] serviceSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            serviceRestriction = new LikeRestrictionOfstring();
            serviceRestriction.Like = "Labor";

            // Create a service criteria object
            // Retrieve service summaries with a generic description property of Labor
            serviceCriteria = new ServiceCriteria();
            serviceCriteria.GenericDescription = serviceRestriction;

            // Retrieve the service summaries specified by the criteria object
            serviceSummary = wsDynamicsGP.GetServiceList(serviceCriteria, context);

            // Display the ID and Description properties of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ServiceSummary a in serviceSummary)
            {
                summaryList.AppendLine("Service: " + a.Key.Id + " - " + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetServiceQuoteByKey

Description

Retrieves a single service quote object based on the specified service document key.

Parameters

Parameter | Type | Description
key | ServiceDocumentKey | The service document key object that specifies the service quote to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetServiceQuoteByKeyResult | ServiceQuote | A service quote object.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves a service quote object with the service document key value “0000002025”. A message box displays the service quote customer name and description properties.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ServiceQuote serviceQuote;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key object
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "0000002025";

            // Retrieve the specified service quote object
            serviceQuote = wsDynamicsGP.GetServiceQuoteByKey(serviceDocumentKey, context);

            // Display the service quote customer name and description properties
            MessageBox.Show("Customer: " + serviceQuote.CustomerName + "  Description: "
                + serviceQuote.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ServiceQuote serviceQuote;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key object
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "0000002025";

            // Retrieve the specified service quote object
            serviceQuote = wsDynamicsGP.GetServiceQuoteByKey(serviceDocumentKey, context);

            // Display the service quote customer name and description properties
            MessageBox.Show("Customer: " + serviceQuote.CustomerName + "  Description: "
                + serviceQuote.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetServiceQuoteList

Description

Retrieves a list of service quote summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ServiceQuoteCriteria | A service quote criteria object that specifies which service quote summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetServiceQuoteListResult | ArrayOfServiceQuoteSummary | The list of service quote summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves the list of service quote summary objects with an office Id that begins with “N”. The customer name and service type code properties from each service quote summary object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString officeIdRestriction;
            ServiceQuoteCriteria serviceQuoteCriteria;
            ServiceQuoteSummary[] serviceQuoteSummary;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            officeIdRestriction = new LikeRestrictionOfString();
            officeIdRestriction.Like = "N%";

            // Create a service quote criteria object
            // Retrieve service quote summaries with an office Id that begins with 'N'
            serviceQuoteCriteria = new ServiceQuoteCriteria();
            serviceQuoteCriteria.OfficeId = officeIdRestriction;

            // Retrieve the service quote summaries specified by the criteria object
            serviceQuoteSummary = wsDynamicsGP.GetServiceQuoteList(serviceQuoteCriteria, context);

            // Display the CustomerName and ServiceTypeKey properties of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ServiceQuoteSummary a in serviceQuoteSummary)
            {
                summaryList.AppendLine("Customer: " + a.CustomerName + "  Service type: " +
                    a.ServiceTypeKey.Id);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring officeIdRestriction;
            ServiceQuoteCriteria serviceQuoteCriteria;
            ServiceQuoteSummary[] serviceQuoteSummary;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            officeIdRestriction = new LikeRestrictionOfstring();
            officeIdRestriction.Like = "N%";

            // Create a service quote criteria object
            // Retrieve service quote summaries with an office Id that begins with 'N'
            serviceQuoteCriteria = new ServiceQuoteCriteria();
            serviceQuoteCriteria.OfficeId = officeIdRestriction;

            // Retrieve the service quote summaries specified by the criteria object
            serviceQuoteSummary = wsDynamicsGP.GetServiceQuoteList(serviceQuoteCriteria, context);

            // Display the CustomerName and ServiceTypeKey properties of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ServiceQuoteSummary a in serviceQuoteSummary)
            {
                summaryList.AppendLine("Customer: " + a.CustomerName + "  Service type: " +
                    a.ServiceTypeKey.Id);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetShippingMethodByKey

Description

Retrieves a single shipping method object based on the specified shipping method key.

Parameters

Parameter | Type | Description
key | ShippingMethodKey | The shipping method key object that specifies the shipping method to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetShippingMethodByKeyResult | ShippingMethod | A shipping method object.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves a shipping method object with the key value “OVERNIGHT”. A message box displays the description.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ShippingMethodKey shippingMethodKey;
            ShippingMethod shippingMethod;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a shipping method key
            shippingMethodKey = new ShippingMethodKey();
            shippingMethodKey.Id = "OVERNIGHT";

            // Retrieve the shipping method object
            shippingMethod = wsDynamicsGP.GetShippingMethodByKey(shippingMethodKey, context);

            // Display the description property
            MessageBox.Show("Shipping method description: " + shippingMethod.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ShippingMethodKey shippingMethodKey;
            ShippingMethod shippingMethod;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a shipping method key
            shippingMethodKey = new ShippingMethodKey();
            shippingMethodKey.Id = "OVERNIGHT";

            // Retrieve the shipping method object
            shippingMethod = wsDynamicsGP.GetShippingMethodByKey(shippingMethodKey, context);

            // Display the description property
            MessageBox.Show("Shipping method description: " + shippingMethod.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetShippingMethodList

Description

Retrieves a list of shipping method objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | ShippingMethodCriteria | A shipping method criteria object that specifies which shipping method objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetShippingMethodListResult | ArrayOfShippingMethod | The list of shipping method objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of shipping method objects whose Id property ends with “DAY”. The Description and Carrier properties from each shipping method object is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString shippingMethodRestriction;
            ShippingMethodCriteria shippingMethodCriteria;
            ShippingMethod[] shippingMethods;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve shipping methods ending with DAY
            shippingMethodRestriction = new LikeRestrictionOfString();
            shippingMethodRestriction.Like = "%DAY";

            // Create a shipping method criteria object
            shippingMethodCriteria = new ShippingMethodCriteria();
            shippingMethodCriteria.Id = shippingMethodRestriction;

            // Retrieve the shipping method objects
            shippingMethods = wsDynamicsGP.GetShippingMethodList(shippingMethodCriteria, context);

            // Display the description and carrier of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ShippingMethod a in shippingMethods)
            {
                summaryList.AppendLine("Shipping method: " + a.Description + "  Carrier: " + a.Carrier);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring shippingMethodRestriction;
            ShippingMethodCriteria shippingMethodCriteria;
            ShippingMethod[] shippingMethods;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // Retrieve shipping methods ending with DAY
            shippingMethodRestriction = new LikeRestrictionOfstring();
            shippingMethodRestriction.Like = "%DAY";

            // Create a shipping method criteria object
            shippingMethodCriteria = new ShippingMethodCriteria();
            shippingMethodCriteria.Id = shippingMethodRestriction;

            // Retrieve the shipping method objects
            shippingMethods = wsDynamicsGP.GetShippingMethodList(shippingMethodCriteria, context);

            // Display the description and carrier of each member of the object list
            StringBuilder summaryList = new StringBuilder();
            foreach (ShippingMethod a in shippingMethods)
            {
                summaryList.AppendLine("Shipping method: " + a.Description + "  Carrier: " + a.Carrier);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSkillByKey

Description

Retrieves a skill object based on the specified skill key.

Parameters

Parameter | Type | Description
key | SkillKey | The skill key object that specifies the skill object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSkillByKeyResult | Skill | A skill object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves a skill object with the key value “New test skill”. A message box displays the compensation values associated with the specified skill.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Skill skill;
            SkillKey skillKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Retrieve the list of skill objects
            skill = wsDynamicsGP.GetSkillByKey(skillKey, context);

            // Display the number of skill objects matching the criteria
            MessageBox.Show("The compensation value for the specified job skill: " +
                skill.Compensation.CompensationAmount.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Skill skill;
            SkillKey skillKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Retrieve the list of skill objects
            skill = wsDynamicsGP.GetSkillByKey(skillKey, context);

            // Display the number of skill objects matching the criteria
            MessageBox.Show("The compensation value for the specified job skill: " +
                skill.Compensation.CompensationAmount.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSkillList

Description

Retrieves a list of skill objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SkillCriteria | A skill criteria object that specifies which skill objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSkillListResult | ArrayOfSkill | The list of skill objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of skill objects with an Id that includes the term “test”. A message box displays the number of skill objects that include the specified term.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Skill[] skills;
            SkillCriteria skillCriteria;
            LikeRestrictionOfString skillIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the skill objects to retrieve
            skillIdRestriction = new LikeRestrictionOfString();
            skillIdRestriction.Like = "%test%";
            skillCriteria = new SkillCriteria();
            skillCriteria.SkillKeyId = skillIdRestriction;

            // Retrieve the list of skill objects
            skills = wsDynamicsGP.GetSkillList(
            skillCriteria, context);

            // Display the number of skill objects matching the criteria
            MessageBox.Show("The number of skills with an ID that includes the word test: " +
                skills.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Skill[] skills;
            SkillCriteria skillCriteria;
            LikeRestrictionOfstring skillIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the skill objects to retrieve
            skillIdRestriction = new LikeRestrictionOfstring();
            skillIdRestriction.Like = "%test%";
            skillCriteria = new SkillCriteria();
            skillCriteria.SkillKeyId = skillIdRestriction;

            // Retrieve the list of skill objects
            skills = wsDynamicsGP.GetSkillList(
            skillCriteria, context);

            // Display the number of skill objects matching the criteria
            MessageBox.Show("The number of skills with an ID that includes the word test: " +
                skills.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSkillSetByKey

Description

Retrieves a skill set object based on the specified skill set key.

Parameters

Parameter | Type | Description
key | SkillSetKey | The skill set key object that specifies the skill set object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSkillSetByKeyResult | SkillSet | A skill set object.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves a skill set object with the key value “New test skill set”. A message box displays the number of skills associated with the specified skill set.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillSet skillSet;
            SkillSetKey skillSetKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Create a skill set key
            skillSetKey = new SkillSetKey();
            skillSetKey.Id = "New test skill set";

            // Retrieve the skill set object
            skillSet = wsDynamicsGP.GetSkillSetByKey(skillSetKey, context);

            // Display the number of skills associated with the skill set
            MessageBox.Show("The skill set includes the following number of skills : " +
                skillSet.AvailableSkills.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillSet skillSet;
            SkillSetKey skillSetKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Create a skill set key
            skillSetKey = new SkillSetKey();
            skillSetKey.Id = "New test skill set";

            // Retrieve the skill set object
            skillSet = wsDynamicsGP.GetSkillSetByKey(skillSetKey, context);

            // Display the number of skills associated with the skill set
            MessageBox.Show("The skill set includes the following number of skills : " +
                skillSet.AvailableSkills.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetSkillSetList

Description

Retrieves a list of skill set summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | SkillSetCriteria | A skill set criteria object that specifies which skill set summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetSkillSetListResult | ArrayOfSkillSetSummary | The list of skill set summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the list of skill set summary objects with an Id that includes the term “test”. A message box displays the number of skill set summary objects that include the specified word.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillSetSummary[] skillSets;
            SkillSetCriteria skillSetCriteria;
            LikeRestrictionOfString skillSetIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the skill set summary objects to retrieve
            skillSetIdRestriction = new LikeRestrictionOfString();
            skillSetIdRestriction.Like = "%test%";
            skillSetCriteria = new SkillSetCriteria();
            skillSetCriteria.SkillSetKeyId = skillSetIdRestriction;

            // Retrieve the list of skill set summary objects
            skillSets = wsDynamicsGP.GetSkillSetList(
            skillSetCriteria, context);

            // Display the number of skill set summary objects matching the criteria
            MessageBox.Show("The number of skill sets with an ID that includes the word test: " +
                skillSets.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillSetSummary[] skillSets;
            SkillSetCriteria skillSetCriteria;
            LikeRestrictionOfstring skillSetIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Specify the criteria of the skill set summary objects to retrieve
            skillSetIdRestriction = new LikeRestrictionOfstring();
            skillSetIdRestriction.Like = "%test%";
            skillSetCriteria = new SkillSetCriteria();
            skillSetCriteria.SkillSetKeyId = skillSetIdRestriction;

            // Retrieve the list of skill set summary objects
            skillSets = wsDynamicsGP.GetSkillSetList(
            skillSetCriteria, context);

            // Display the number of skill set summary objects matching the criteria
            MessageBox.Show("The number of skill sets with an ID that includes the word test: " +
                skillSets.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetTaxDetailByKey

Description

Retrieves a single tax detail object based on the key value supplied.

Parameters

Parameter | Type | Description
key | TaxDetailKey | The tax detail key object that specifies the tax detail to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetTaxDetailByKeyResult | TaxDetail | A tax detail object.

Interfaces

  • Dynamics GP
  • Common

Examples

The following C# example retrieves the tax detail object with the tax detail Id value “CANGST+PS7N0”. The description is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxDetail taxDetail;
            TaxDetailKey taxDetailKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a tax detail key
            taxDetailKey = new TaxDetailKey();
            taxDetailKey.Id = "CANGST+PS7N0";

            // Get the tax detail object
            taxDetail = wsDynamicsGP.GetTaxDetailByKey(taxDetailKey, context);

            // Display the description for the tax detail
            MessageBox.Show("Description: " + taxDetail.TaxDetailDescription);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxDetail taxDetail;
            TaxDetailKey taxDetailKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a tax detail key
            taxDetailKey = new TaxDetailKey();
            taxDetailKey.Id = "CANGST+PS7N0";

            // Get the tax detauk object
            taxDetail = wsDynamicsGP.GetTaxDetailByKey(taxDetailKey, context);

            // Display the description for the tax detail
            MessageBox.Show("Description: " + taxDetail.TaxDetailDescription);

            // Close the service
            if (wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetTaxDetailList

Description

Retrieves a list of tax detail objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | TaxDetailCriteria | The tax detail criteria object that specifies which tax detail objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetTaxDetailListResult | ArrayOfTaxDetail | The list of tax detail objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common

Examples

The following C# example retrieves the list of tax detail objects with a tax detail Id that begins with “CAN”, indicating they apply to Canadian taxes. A message box displays the number of tax detail objects found.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxDetail[] taxDetails;
            TaxDetailCriteria taxDetailCriteria;
            LikeRestrictionOfString taxDetailIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria of the tax detail objects to retrieve
            taxDetailIdRestriction = new LikeRestrictionOfString();
            taxDetailIdRestriction.Like = "CAN%";
            taxDetailCriteria = new TaxDetailCriteria();
            taxDetailCriteria.TaxDetailKeyId = taxDetailIdRestriction;

            // Retrieve the list of tax detail objects
            taxDetails = wsDynamicsGP.GetTaxDetailList(taxDetailCriteria, context);

            // Display the number of tax details found
            MessageBox.Show("Tax details for Canada: " + taxDetails.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxDetail[] taxDetails;
            TaxDetailCriteria taxDetailCriteria;
            LikeRestrictionOfstring taxDetailIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria of the tax detail objects to retrieve
            taxDetailIdRestriction = new LikeRestrictionOfstring();
            taxDetailIdRestriction.Like = "CAN%";
            taxDetailCriteria = new TaxDetailCriteria();
            taxDetailCriteria.TaxDetailKeyId = taxDetailIdRestriction;

            // Retrieve the list of tax detail objects
            taxDetails = wsDynamicsGP.GetTaxDetailList(taxDetailCriteria, context);

            // Display the number of tax details found
            MessageBox.Show("Tax details for Canada: " + taxDetails.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetTaxScheduleByKey

Description

Retrieves a single tax schedule object based on the key value supplied.

Parameters

Parameter | Type | Description
key | TaxScheduleKey | The tax schedule key object that specifies the tax schedule to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetTaxScheduleByKeyResult | TaxSchedule | A tax detail object.

Interfaces

  • Dynamics GP
  • Common

Examples

The following C# example retrieves the tax schedule object with the tax schedule Id value “UKVAT-175”. The description is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxSchedule taxSchedule;
            TaxScheduleKey taxScheduleKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a tax schedule key
            taxScheduleKey = new TaxScheduleKey();
            taxScheduleKey.Id = "UKVAT-175";

            // Get the tax schedule object
            taxSchedule = wsDynamicsGP.GetTaxScheduleByKey(taxScheduleKey, context);

            // Display the description for the tax detail
            MessageBox.Show("Description: " + taxSchedule.TaxScheduleDescription);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxSchedule taxSchedule;
            TaxScheduleKey taxSchedulelKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a tax schedule key
            taxSchedulelKey = new TaxScheduleKey();
            taxSchedulelKey.Id = "UKVAT-175";

            // Get the tax schedule object
            taxSchedule = wsDynamicsGP.GetTaxScheduleByKey(taxSchedulelKey, context);

            // Display the description for the tax schedule
            MessageBox.Show("Description: " + taxSchedule.TaxScheduleDescription);

            // Close the service
            if (wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetTaxScheduleDetailByKey

Description

Retrieves a tax detail object that is part of a tax schedule, based on the key values supplied.

Parameters

Parameter | Type | Description
key | TaxScheduleDetailKey | The tax schedule detail key object that specifies the tax schedule detail to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetTaxScheduleDetailByKeyResult | TaxScheduleDetail | A tax schedule detail object.

Interfaces

  • Dynamics GP
  • Common

Examples

The following C# example retrieves the tax schedule detail object for the tax detail “ILLINOIS” that is part of the tax schedule “USEXMT+PSONO”. The calculation base is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxScheduleDetail taxScheduleDetail;
            TaxScheduleDetailKey taxScheduleDetailKey;
            TaxScheduleKey taxScheduleKey;
            TaxDetailKey taxDetailKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a tax schedule detail key
            taxScheduleKey = new TaxScheduleKey();
            taxScheduleKey.Id = "ILLINOIS";

            taxDetailKey = new TaxDetailKey();
            taxDetailKey.Id = "USEXMT+PSONO";

            taxScheduleDetailKey = new TaxScheduleDetailKey();
            taxScheduleDetailKey.TaxScheduleKey = taxScheduleKey;
            taxScheduleDetailKey.TaxDetailKey = taxDetailKey;

            // Get the tax schedule detail object
            taxScheduleDetail = wsDynamicsGP.GetTaxScheduleDetailByKey(taxScheduleDetailKey, context);

            // Display the calculation base for the tax schedule detail
            MessageBox.Show("Calculation base: " + taxScheduleDetail.TaxDetailBase.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxScheduleDetail taxScheduleDetail;
            TaxScheduleDetailKey taxScheduleDetailKey;
            TaxScheduleKey taxScheduleKey;
            TaxDetailKey taxDetailKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a tax schedule detail key
            taxScheduleKey = new TaxScheduleKey();
            taxScheduleKey.Id = "ILLINOIS";

            taxDetailKey = new TaxDetailKey();
            taxDetailKey.Id = "USEXMT+PSONO";

            taxScheduleDetailKey = new TaxScheduleDetailKey();
            taxScheduleDetailKey.TaxScheduleKey = taxScheduleKey;
            taxScheduleDetailKey.TaxDetailKey = taxDetailKey;

            // Get the tax schedule detail object
            taxScheduleDetail = wsDynamicsGP.GetTaxScheduleDetailByKey(taxScheduleDetailKey, context);

            // Display the calculation base for the tax schedule detail
            MessageBox.Show("Calculation base: " + taxScheduleDetail.TaxDetailBase.ToString());

            // Close the service
            if (wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetTaxScheduleDetailList

Description

Retrieves a list of tax schedule detail objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | TaxScheduleDetailCriteria | The tax schedule detail criteria object that specifies which tax schedule detail objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetTaxScheduleDetailListResult | ArrayOfTaxScheduleDetail | The list of tax schedule detail objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common

Examples

The following C# example retrieves the list of tax schedule detail objects with for the tax schedule Id “UKVAT-175”. A message box displays the number of tax schedule detail objects found.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxScheduleDetail[] taxScheduleDetails;
            TaxScheduleDetailCriteria taxScheduleDetailCriteria;
            LikeRestrictionOfString taxScheduleIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria of the tax schedule detail objects to retrieve
            taxScheduleIdRestriction = new LikeRestrictionOfString();
            taxScheduleIdRestriction.EqualValue = "UKVAT-175";
            taxScheduleDetailCriteria = new TaxScheduleDetailCriteria();
            taxScheduleDetailCriteria.TaxScheduleKeyId = taxScheduleIdRestriction;

            // Retrieve the list of tax schedule detail objects
            taxScheduleDetails = wsDynamicsGP.GetTaxScheduleDetailList(taxScheduleDetailCriteria, context);

            // Display the number of tax schedule details found
            MessageBox.Show("Tax schedules for UKVAT-175: " + taxScheduleDetails.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxScheduleDetail[] taxScheduleDetails;
            TaxScheduleDetailCriteria taxScheduleDetailCriteria;
            LikeRestrictionOfstring taxScheduleIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria of the tax schedule detail objects to retrieve
            taxScheduleIdRestriction = new LikeRestrictionOfstring();
            taxScheduleIdRestriction.EqualValue = "UKVAT-175";
            taxScheduleDetailCriteria = new TaxScheduleDetailCriteria();
            taxScheduleDetailCriteria.TaxScheduleKeyId = taxScheduleIdRestriction;

            // Retrieve the list of tax schedule detail objects
            taxScheduleDetails = wsDynamicsGP.GetTaxScheduleDetailList(taxScheduleDetailCriteria, context);

            // Display the number of tax schedules found
            MessageBox.Show("Tax schedules for UKVAT-175: " + taxScheduleDetails.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetTaxScheduleList

Description

Retrieves a list of tax schedule objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | TaxScheduleCriteria | The tax schedule criteria object that specifies which tax schedule objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetTaxScheduleListResult | ArrayOfTaxSchedule | The list of tax schedule objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Common

Examples

The following C# example retrieves the list of tax schedule detail objects that are part of the tax schedule with the Id “CAN”, indicating they apply to Canadian taxes. A message box displays the number of tax schedule objects found.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxSchedule[] taxSchedules;
            TaxScheduleCriteria taxScheduleCriteria;
            LikeRestrictionOfString taxScheduleIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria of the tax schedule objects to retrieve
            taxScheduleIdRestriction = new LikeRestrictionOfString();
            taxScheduleIdRestriction.Like = "CAN%";
            taxScheduleCriteria = new TaxScheduleCriteria();
            taxScheduleCriteria.TaxScheduleKeyId = taxScheduleIdRestriction;

            // Retrieve the list of tax schedule objects
            taxSchedules = wsDynamicsGP.GetTaxScheduleList(taxScheduleCriteria, context);

            // Display the number of tax schedules found
            MessageBox.Show("Tax schedules for Canada: " + taxSchedules.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            TaxSchedule[] taxSchedules;
            TaxScheduleCriteria taxScheduleCriteria;
            LikeRestrictionOfstring taxScheduleIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria of the tax schedule objects to retrieve
            taxScheduleIdRestriction = new LikeRestrictionOfstring();
            taxScheduleIdRestriction.Like = "CAN%";
            taxScheduleCriteria = new TaxScheduleCriteria();
            taxScheduleCriteria.TaxScheduleKeyId = taxScheduleIdRestriction;

            // Retrieve the list of tax schedule objects
            taxSchedules = wsDynamicsGP.GetTaxScheduleList(taxScheduleCriteria, context);

            // Display the number of tax schedules found
            MessageBox.Show("Tax schedules for Canada: " + taxSchedules.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetTenantList

Description

Retrieves a list of tenants that the specified user has access to.

Parameters

Parameter | Type | Description
identity | string | Specifies the user for which the list of tenants is being returned.
activeTenantsOnly | boolean | The value true specifies that only active tenants are returned. The value false specifies that all tenants are returned.

Return Value:

Value | Type | Description
GetTenantListResult | ArrayOfTenant | The list of tenant objects.

Examples

An example will be provided when tenants are supported by the Dynamics GP web service.


GetUofMScheduleByKey

Description

Retrieves a single unit of measure schedule object based on the specified unit of measure schedule key.

Parameters

Parameter | Type | Description
key | UofMScheduleKey | The unit of measure schedule key object that specifies the unit of measure schedule to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetUofMScheduleByKeyResult | UofMSchedule | A unit of measure schedule object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves a unit of measure schedule with the key value “ASSEMBLY”. A message box displays the unit of measure schedule description.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            UofMSchedule unitSchedule;
            UofMScheduleKey unitScheduleKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the unit of measure schedule key object
            unitScheduleKey = new UofMScheduleKey();
            unitScheduleKey.Id = "ASSEMBLY";

            // Retrieve the specified unit of measure schedule object
            unitSchedule = wsDynamicsGP.GetUofMScheduleByKey(unitScheduleKey, context);

            // Display the description of the unit of measure schedule
            MessageBox.Show("Unit of Measure Schedule description: " + unitSchedule.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            UofMSchedule unitSchedule;
            UofMScheduleKey unitScheduleKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the unit of measure schedule key object
            unitScheduleKey = new UofMScheduleKey();
            unitScheduleKey.Id = "ASSEMBLY";

            // Retrieve the specified unit of measure schedule object
            unitSchedule = wsDynamicsGP.GetUofMScheduleByKey(unitScheduleKey, context);

            // Display the description of the unit of measure schedule
            MessageBox.Show("Unit of Measure Schedule description: " + unitSchedule.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetUofMScheduleList

Description

Retrieves a list of unit of measure schedule summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | UofMScheduleCriteria | A unit of measure schedule criteria object that specifies which unit of measure schedule summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetUofMScheduleListResult | ArrayOfUofMScheduleSummary | The list of unit of measure schedule summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of unit of measure schedule summary objects whose Unit of Measure Schedule Id begins with “A”. A message box displays a list containing the ID and description of each unit of measure schedule.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            UofMScheduleSummary[] unitSummary;
            UofMScheduleCriteria unitCriteria;
            LikeRestrictionOfString unitRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // The "A%" matches all strings beginning with A
            unitRestriction = new LikeRestrictionOfString();
            unitRestriction.Like = "A%";

            // Create a criteria object
            // Retrieve summary objects that have a key beginning with "A"
            unitCriteria = new UofMScheduleCriteria();
            unitCriteria.UnitofMeasureScheduleId = unitRestriction;

            // Retrieve the records specified by the criteria object
            unitSummary = wsDynamicsGP.GetUofMScheduleList(unitCriteria, context);

            // Display a list of summary objects
            StringBuilder summaryList = new StringBuilder();
            foreach(UofMScheduleSummary a in unitSummary)
            {
                summaryList.AppendLine("ID:" + a.Key.Id + "  Description:" + a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            UofMScheduleSummary[] unitSummary;
            UofMScheduleCriteria unitCriteria;
            LikeRestrictionOfstring unitRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a restriction object
            // The "A%" matches all strings beginning with A
            unitRestriction = new LikeRestrictionOfstring();
            unitRestriction.Like = "A%";

            // Create a criteria object
            // Retrieve summary objects that have a key beginning with "A"
            unitCriteria = new UofMScheduleCriteria();
            unitCriteria.UnitofMeasureScheduleId = unitRestriction;

            // Retrieve the records specified by the criteria object
            unitSummary = wsDynamicsGP.GetUofMScheduleList(unitCriteria, context);

            // Display a list of summary objects
            StringBuilder summaryList = new StringBuilder();
            foreach(UofMScheduleSummary a in unitSummary)
            {
                summaryList.AppendLine("ID:" + a.Key.Id + "  Description:" + a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetUserAssignableBusinessObjectList

Description

Retrieves the list of business objects in Microsoft Dynamics GP that can have a user ID associated with them.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetUserAssignableBusinessObjectListResult | ArrayOfUserAssignableBusinessObject | A list of the user assignable business objects

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example displays a list of all the available business objects that can have a user ID associated with them.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            UserAssignableBusinessObject[] userAssignableBusinessObjects;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the list of user-assignable business objects
            userAssignableBusinessObjects = wsDynamicsGP.GetUserAssignableBusinessObjectList(context);

            // Display the available object types
            StringBuilder objectList = new StringBuilder();
            foreach (UserAssignableBusinessObject a in userAssignableBusinessObjects)
            {
                // Build the string to display
                objectList.AppendLine(a.BusinessObjectTypeDisplayName);
            }
            MessageBox.Show(objectList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            UserAssignableBusinessObject[] userAssignableBusinessObjects;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retrieve the list of user-assignable business objects
            userAssignableBusinessObjects = wsDynamicsGP.GetUserAssignableBusinessObjectList(context);

            // Display the available object types
            StringBuilder objectList = new StringBuilder();
            foreach (UserAssignableBusinessObject a in userAssignableBusinessObjects)
            {
                // Build the string to display
                objectList.AppendLine(a.BusinessObjectTypeDisplayName);
            }
            MessageBox.Show(objectList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetVendorAddressByKey

Description

Retrieves a single vendor address object based on the specified vendor address key.

Parameters

Parameter | Type | Description
key | VendorAddressKey | The vendor address key object that specifiest the vendor address to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetVendorAddressByKeyResult | VendorAddress | The vendor address.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the primary address for the vendor with the key value “ACETRAVE0001”. The city from the vendor’s address is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorKey vendorKey;
            VendorAddress vendorAddress;
            VendorAddressKey vendorAddressKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key and specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create the vendor key object
            vendorAddressKey = new VendorAddressKey();
            vendorAddressKey.VendorKey = vendorKey;
            vendorAddressKey.Id = "PRIMARY";

            // Retrieve the vendor address object
            vendorAddress = wsDynamicsGP.GetVendorAddressByKey(vendorAddressKey, context);

            // Display location information for the vendor
            MessageBox.Show("City: " + vendorAddress.City);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorKey vendorKey;
            VendorAddress vendorAddress;
            VendorAddressKey vendorAddressKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key and specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create the vendor key object
            vendorAddressKey = new VendorAddressKey();
            vendorAddressKey.VendorKey = vendorKey;
            vendorAddressKey.Id = "PRIMARY";

            // Retrieve the vendor address object
            vendorAddress = wsDynamicsGP.GetVendorAddressByKey(vendorAddressKey, context);

            // Display location information for the vendor
            MessageBox.Show("City: " + vendorAddress.City);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetVendorAddressList

Description

Retrieves a list of vendor address summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | VendorAddressCriteria | The vendor address criteria object that specifies which vendor address summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetVendorAddressListResult | ArrayOfVendorAddressSummary | The list of vendor address summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of vendor address summary objects where the vendor is located in a state that begins with “N”. The list of vendors and states is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorAddressSummary[] vendorAddressList;
            VendorAddressCriteria vendorAddressCriteria;
            LikeRestrictionOfString stateRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor address criteria object
            stateRestriction = new LikeRestrictionOfString();
            stateRestriction.Like = "N%";
            vendorAddressCriteria = new VendorAddressCriteria();
            vendorAddressCriteria.State = stateRestriction;

            // Get the list of vendor address objects
            vendorAddressList = wsDynamicsGP.GetVendorAddressList(vendorAddressCriteria, context);

            // Display the vendors located in the specified state
            StringBuilder objectList = new StringBuilder();
            foreach (VendorAddressSummary a in vendorAddressList)
            {
                // Build the string to display
                objectList.AppendLine(a.State + "  " + a.Key.VendorKey.Id);
            }

            MessageBox.Show(objectList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorAddressSummary[] vendorAddressList;
            VendorAddressCriteria vendorAddressCriteria;
            LikeRestrictionOfstring stateRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor address criteria object
            stateRestriction = new LikeRestrictionOfstring();
            stateRestriction.Like = "N%";
            vendorAddressCriteria = new VendorAddressCriteria();
            vendorAddressCriteria.State = stateRestriction;

            // Get the list of vendor address objects
            vendorAddressList = wsDynamicsGP.GetVendorAddressList(vendorAddressCriteria, context);

            // Display the vendors located in the specified state
            StringBuilder objectList = new StringBuilder();
            foreach (VendorAddressSummary a in vendorAddressList)
            {
                // Build the string to display
                objectList.AppendLine(a.State + "  " + a.Key.VendorKey.Id);
            }

            MessageBox.Show(objectList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetVendorByKey

Description

Retrieves a single vendor object based on the specified vendor key. The value returned by this method can be affected by entity ID filtering.

Parameters

Parameter | Type | Description
key | VendorKey | The vendor key object that specifies the vendor to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetVendorByKeyResult | Vendor | A vendor object.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves a vendor with the key value “ACETRAVE0001”. A message box displays the vendor’s name.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Vendor vendor;
            VendorKey vendorKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Retrieve the vendor object
            vendor = wsDynamicsGP.GetVendorByKey(vendorKey, context);

            // Display vendor name
            MessageBox.Show("Vendor: " + vendor.Name);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Vendor vendor;
            VendorKey vendorKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Retrieve the vendor object
            vendor = wsDynamicsGP.GetVendorByKey(vendorKey, context);

            // Display vendor name
            MessageBox.Show("Vendor: " + vendor.Name);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetVendorList

Description

Retrieves a list of vendor summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | VendorCriteria | The vendor criteria object that specifies which vendor summary objects are returned.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetVendorListResult | ArrayOfVendorSummary | The list of vendor summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves the list of vendor summary objects for the vendors whose Vendor Class Id property equals “USA-US-I”. The total number of vendors in the vendor class is displayed in a message box.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorCriteria vendorCriteria;
            VendorSummary[] vendorSummaryList;
            LikeRestrictionOfString classIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria for the vendor summaries to retrieve
            classIdRestriction = new LikeRestrictionOfString();
            classIdRestriction.EqualValue = "USA-US-I";

            vendorCriteria = new VendorCriteria();
            vendorCriteria.ClassId = classIdRestriction;

            // Retrieve the list of vendor summaries
            vendorSummaryList = wsDynamicsGP.GetVendorList(vendorCriteria, context);

            MessageBox.Show("Total vendors in class: " + vendorSummaryList.Length);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorCriteria vendorCriteria;
            VendorSummary[] vendorSummaryList;
            LikeRestrictionOfstring classIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the criteria for the vendor summaries to retrieve
            classIdRestriction = new LikeRestrictionOfstring();
            classIdRestriction.EqualValue = "USA-US-I";

            vendorCriteria = new VendorCriteria();
            vendorCriteria.ClassId = classIdRestriction;

            // Retrieve the list of vendor summaries
            vendorSummaryList = wsDynamicsGP.GetVendorList(vendorCriteria, context);

            MessageBox.Show("Total vendors in class: " + vendorSummaryList.Length);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetVendorManufacturingOrderByKey

Description

Retrieves a single vendor manufacturing order object based on the specified manufacturing order document key.

Parameters

Parameter | Type | Description
key | ManufacturingOrderDocumentKey | The manufacturing order document key object that specifies the vendor manufacturing order object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetVendorManufacturingOrderByKeyResult | VendorManufacturingOrder | A vendor manufacturing order object.

Interfaces

  • Dynamics GP
  • Manufacturing

Examples

The following C# example retrieves a vendor manufacturing order object with the key value “MO0001”. A message box displays the Description property of the vendor manufacturing order object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorManufacturingOrder vendorManufacturingOrder;
            ManufacturingOrderDocumentKey manufacturingOrderKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a manufacturing order document key
            manufacturingOrderKey = new ManufacturingOrderDocumentKey();
            manufacturingOrderKey.Id = "MO0001";

            // Get the vendor manufacturing order object
            vendorManufacturingOrder = wsDynamicsGP.GetVendorManufacturingOrderByKey(manufacturingOrderKey, context);

            // Display the description from the vendor manufacturing order
            MessageBox.Show("Order description: " + vendorManufacturingOrder.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorManufacturingOrder vendorManufacturingOrder;
            ManufacturingOrderDocumentKey manufacturingOrderKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a manufacturing order document key
            manufacturingOrderKey = new ManufacturingOrderDocumentKey();
            manufacturingOrderKey.Id = "MO0001";

            // Get the vendor manufacturing order object
            vendorManufacturingOrder = wsDynamicsGP.GetVendorManufacturingOrderByKey(manufacturingOrderKey, context);

            // Display the description from the vendor manufacturing order
            MessageBox.Show("Order description: " + vendorManufacturingOrder.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetVendorManufacturingOrderList

Description

Retrieves a list of vendor manufacturing order summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | VendorManufacturingOrderCriteria | The vendor manufacturing order criteria object that specifies which vendor manufacturing order summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetVendorManufacturingOrderListResult | ArrayOfVendorManufacturingOrderSummary | The list of vendor manufacturing order summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Manufacturing

Examples

The following C# example retrieves the list of vendor manufacturing order summary objects with a status of open. A message box displays the order Id and the description for each vendor manufacturing order in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorManufacturingOrderSummary[] vendorManufacturingOrderList;
            VendorManufacturingOrderCriteria vendorManufacturingOrderCriteria;
            ListRestrictionOfNullableOfManufacturingOrderStatus statusRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor manufacturing order criteria object
            // Use the restriction object to return all open vendor manufacturing orders
            statusRestriction = new ListRestrictionOfNullableOfManufacturingOrderStatus();
            statusRestriction.EqualValue = ManufacturingOrderStatus.Open;
            vendorManufacturingOrderCriteria = new VendorManufacturingOrderCriteria();
            vendorManufacturingOrderCriteria.OrderStatus = statusRestriction;

            // Get the list of vendor manufacturing order objects
            vendorManufacturingOrderList = wsDynamicsGP.GetVendorManufacturingOrderList(
                vendorManufacturingOrderCriteria, context);

            // Display the list of vendor manufacturing orders
            // Display the vendor manufacturing orders with a status of Open
            StringBuilder objectList = new StringBuilder();
            foreach (VendorManufacturingOrderSummary a in vendorManufacturingOrderList)
            {
                // Build the string to display
                objectList.AppendLine(a.ManufacturingOrderDocumentKey.Id + "  " + a.Description);
            }

            MessageBox.Show(objectList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorManufacturingOrderSummary[] vendorManufacturingOrderList;
            VendorManufacturingOrderCriteria vendorManufacturingOrderCriteria;
            ListRestrictionOfNullableOfManufacturingOrderStatus statusRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor manufacturing order criteria object
            // Use the restriction object to return all open vendor manufacturing orders
            statusRestriction = new ListRestrictionOfNullableOfManufacturingOrderStatus();
            statusRestriction.EqualValue = ManufacturingOrderStatus.Open;
            vendorManufacturingOrderCriteria = new VendorManufacturingOrderCriteria();
            vendorManufacturingOrderCriteria.OrderStatus = statusRestriction;

            // Get the list of vendor manufacturing order objects
            vendorManufacturingOrderList = wsDynamicsGP.GetVendorManufacturingOrderList(
                vendorManufacturingOrderCriteria, context);

            // Display the list of vendor manufacturing orders
            // Display the vendor manufacturing orders with a status of Open
            StringBuilder objectList = new StringBuilder();
            foreach (VendorManufacturingOrderSummary a in vendorManufacturingOrderList)
            {
                // Build the string to display
                objectList.AppendLine(a.ManufacturingOrderDocumentKey.Id + "  " + a.Description);
            }

            MessageBox.Show(objectList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetVendorPlannedOrderByKey

Description

Retrieves a single vendor planned order object based on the specified planned order key.

Parameters

Parameter | Type | Description
key | PlannedOrderKey | The planned order key object that specifies the vendor planned order object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetVendorPlannedOrderByKeyResult | VendorPlannedOrder | A vendor planned order object.

Interfaces

  • Dynamics GP
  • Manufacturing

Examples

The following C# example retrieves a vendor planned order object with the key value “PO0001”. A message box displays the quantity to order information for the specified vendor planned order object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PlannedOrder vendorPlannedOrder;
            PlannedOrderKey plannedOrderKey;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vemdor planned order key
            plannedOrderKey = new PlannedOrderKey();
            plannedOrderKey.Id = "PO0001";

            // Get the vendor planned order object
            vendorPlannedOrder = wsDynamicsGP.GetVendorPlannedOrderByKey(plannedOrderKey, context);

            // Display the quantity to order from the vendor planned order
            MessageBox.Show("Quantity to order: " + vendorPlannedOrder.QuantityToOrder.Value.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PlannedOrder vendorPlannedOrder;
            PlannedOrderKey plannedOrderKey;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vemdor planned order key
            plannedOrderKey = new PlannedOrderKey();
            plannedOrderKey.Id = "PO0001";

            // Get the vendor planned order object
            vendorPlannedOrder = wsDynamicsGP.GetVendorPlannedOrderByKey(plannedOrderKey, context);

            // Display the quantity to order from the vendor planned order
            MessageBox.Show("Quantity to order: " + vendorPlannedOrder.QuantityToOrder.Value.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetVendorPlannedOrderList

Description

Retrieves a list of vendor planned order summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | VendorPlannedOrderCriteria | The vendor planned order criteria object that specifies which vendor planned order summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetVendorPlannedOrderListResult | ArrayOfVendorPlannedOrderSummary | The list of vendor planned order summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Manufacturing

Examples

The following C# example retrieves the list of all vendor planned order summary objects. A message box displays the number of vendor planned order summary objects in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorPlannedOrderSummary[] vendorPlannedOrderList;
            VendorPlannedOrderCriteria vendorPlannedOrderCriteria;
            LikeRestrictionOfString plannedOrderIdRestriction;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor planned order criteria object
            plannedOrderIdRestriction = new LikeRestrictionOfString();
            plannedOrderIdRestriction.Like = "%";
            vendorPlannedOrderCriteria = new VendorPlannedOrderCriteria();
            vendorPlannedOrderCriteria.PlannedOrderKey = plannedOrderIdRestriction;

            // Get the list of vendor planned order summary objects
            vendorPlannedOrderList = wsDynamicsGP.GetVendorPlannedOrderList(vendorPlannedOrderCriteria, context);

            // Displays the list of vendor planned order summary objects
            MessageBox.Show("Total number of vendor planned orders: " +
                vendorPlannedOrderList.Length.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorPlannedOrderSummary[] vendorPlannedOrderList;
            VendorPlannedOrderCriteria vendorPlannedOrderCriteria;
            LikeRestrictionOfstring plannedOrderIdRestriction;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor planned order criteria object
            plannedOrderIdRestriction = new LikeRestrictionOfstring();
            plannedOrderIdRestriction.Like = "%";
            vendorPlannedOrderCriteria = new VendorPlannedOrderCriteria();
            vendorPlannedOrderCriteria.PlannedOrderKey = plannedOrderIdRestriction;

            // Get the list of vendor planned order summary objects
            vendorPlannedOrderList = wsDynamicsGP.GetVendorPlannedOrderList(vendorPlannedOrderCriteria, context);

            // Displays the list of vendor planned order summary objects
            MessageBox.Show("Total number of vendor planned orders: " +
                vendorPlannedOrderList.Length.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetWarehouseByKey

Description

Retrieves a single warehouse (site) object based on the specified warehouse key.

Parameters

Parameter | Type | Description
key | WarehouseKey | The warehouse key object that specifies the warehouse object to retrieve.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetWarehouseByKeyResult | Warehouse | A warehouse object.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves a warehouse object with the key value “NORTH”. A message box displays the warehouse object’s Description property.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            WarehouseKey warehouseKey;
            Warehouse warehouse;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a warehouse key object to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "NORTH";

            // Retrieve the warehouse object
            warehouse = wsDynamicsGP.GetWarehouseByKey(warehouseKey, context);

            // Display the description of the warehouse
            MessageBox.Show("Warehouse description: " + warehouse.Description);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            WarehouseKey warehouseKey;
            Warehouse warehouse;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a warehouse key object to specify the warehouse
            warehouseKey = new WarehouseKey();
            warehouseKey.Id = "NORTH";

            // Retrieve the warehouse object
            warehouse = wsDynamicsGP.GetWarehouseByKey(warehouseKey, context);

            // Display the description of the warehouse
            MessageBox.Show("Warehouse description: " + warehouse.Description);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetWarehouseList

Description

Retrieves a list of warehouse (site) summary objects that match the specified criteria.

Parameters

Parameter | Type | Description
criteria | WarehouseCriteria | The warehouse criteria object that specifies which warehouse summary objects to return.
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetWarehouseListResult | ArrayOfWarehouseSummary | The list of warehouse summary objects that match the specified criteria.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves the list of warehouse summary objects with a State property of “IL”. A message box displays the State and Description for each warehouse in the list.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfString stateRestriction;
            WarehouseCriteria warehouseCriteria;
            WarehouseSummary[] warehouseSummaries;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Return all warehouses with a state property of 'IL'
            stateRestriction = new LikeRestrictionOfString();
            stateRestriction.EqualValue = "IL";

            // Create the criteria object
            warehouseCriteria = new WarehouseCriteria();
            warehouseCriteria.State = stateRestriction;

            // Retrieve the list of warehouse summary objects
            warehouseSummaries = wsDynamicsGP.GetWarehouseList(warehouseCriteria, context);

            // Display the state and description for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (WarehouseSummary a in warehouseSummaries)
            {
                summaryList.AppendLine("State: " + a.State + "  Description: " +
                a.Description);
            }
            MessageBox.Show(summaryList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            LikeRestrictionOfstring stateRestriction;
            WarehouseCriteria warehouseCriteria;
            WarehouseSummary[] warehouseSummaries;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the restriction object
            // Return all warehouses with a state property of 'IL'
            stateRestriction = new LikeRestrictionOfstring();
            stateRestriction.EqualValue = "IL";

            // Create the criteria object
            warehouseCriteria = new WarehouseCriteria();
            warehouseCriteria.State = stateRestriction;

            // Retrieve the list of warehouse summary objects
            warehouseSummaries = wsDynamicsGP.GetWarehouseList(warehouseCriteria, context);

            // Display the state and description for each member of the summary object list
            StringBuilder summaryList = new StringBuilder();
            foreach (WarehouseSummary a in warehouseSummaries)
            {
                summaryList.AppendLine("State: " + a.State + "  Description: " +
                a.Description);
            }
            MessageBox.Show(summaryList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetWSEnabledCompanyForUserList

Description

Retrieves a list of company objects for which the current user is assigned to at least one security role, allowing them to run service methods.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetWSEnabledCompanyForUserListResult | ArrayOfCompany | The collection of company objects for which the user is able to run methods.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example displays a list of all companies the current user can run web methods in.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Company[] companies;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retieve the list of companies enabled for the current user
            companies = wsDynamicsGP.GetWSEnabledCompanyForUserList(context);

            // Display the list of companies
            StringBuilder companyList = new StringBuilder();
            foreach (Company c in companies)
            {
                companyList.AppendLine(c.Name);
            }
            MessageBox.Show(companyList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Company[] companies;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retieve the list of companies enabled for the current user
            companies = wsDynamicsGP.GetWSEnabledCompanyForUserList(context);

            // Display the list of companies
            StringBuilder companyList = new StringBuilder();
            foreach (Company c in companies)
            {
                companyList.AppendLine(c.Name);
            }
            MessageBox.Show(companyList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


GetWSEnabledCompanyList

Description

Retrieves the list of company objects for companies in Microsoft Dynamics GP that have had web services installed.

Parameters

Parameter | Type | Description
context | Context | Specifies information about how the method will be called.

Return Value:

Value | Type | Description
GetWSEnabledCompanyListResult | ArrayOfCompany | The collection of company objects for which web services have been installed.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the list of all companies in Microsoft Dynamics GP that have had web services installed.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Company[] companies;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retieve the list of companies enabled for web services
            companies = wsDynamicsGP.GetWSEnabledCompanyList(context);

            // Display the list of companies
            StringBuilder companyList = new StringBuilder();
            foreach (Company c in companies)
            {
                companyList.AppendLine(c.Name);
            }
            MessageBox.Show(companyList.ToString());
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Context context;
            Company[] companies;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Set up the context object
            context.OrganizationKey = null;

            // Retieve the list of companies enabled for web services
            companies = wsDynamicsGP.GetWSEnabledCompanyList(context);

            // Display the list of companies
            StringBuilder companyList = new StringBuilder();
            foreach (Company c in companies)
            {
                companyList.AppendLine(c.Name);
            }
            MessageBox.Show(companyList.ToString());

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


MultitenantEnabled

Description

Indicates whether the Dynamics GP service is installed in a multitenant configuration.

Parameters

None

Return Value:

Value | Type | Description
MultitenantEnabledResult | boolean | The value true indicates that a multitenant configuration is being used. The value false indicates that the Tenant Service is not being used.

Examples

An example will be provided when tenants are supported by the Dynamics GP web service.


UpdateApplicant

Description

Updates the specified applicant object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | Applicant | The applicant object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant with the key value “1” and sets the AgeCode property. The UpdateApplicant operation saves the change.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Applicant applicant;
            ApplicantKey applicantKey;
            Policy applicantUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Retrieve the specified applicant
            applicant = wsDynamicsGP.GetApplicantByKey(applicantKey, context);

            // Change the value of the AgeCode property
            applicant.AgeCode = AgeCode.EighteenTwentyfive;

            // Get the update policy for the applicant
            applicantUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicant", context);

            // Update the applicant
            wsDynamicsGP.UpdateApplicant(applicant, context, applicantUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Applicant applicant;
            ApplicantKey applicantKey;
            Policy applicantUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Retrieve the specified applicant
            applicant = wsDynamicsGP.GetApplicantByKey(applicantKey, context);

            // Change the value of the AgeCode property
            applicant.AgeCode = AgeCode.EighteenTwentyfive;

            // Get the update policy for the applicant
            applicantUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicant", context);

            // Update the applicant
            wsDynamicsGP.UpdateApplicant(applicant, context, applicantUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateApplicantEducation

Description

Updates the specified applicant education object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | ApplicantEducation | The applicant education object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant education object with an applicant key value of “1” and a sequence key value of “1”. The example updates the value of the school property. The UpdateApplicantEducation operation saves the change.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantEducation applicantEducation;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            Policy applicantEducationUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Retrieve the specified applicant education object
            applicantEducation = wsDynamicsGP.GetApplicantEducationByKey(applicantSequenceKey, context);

            // Change the value of the School property
            applicantEducation.School = "Local college";

            // Get the update policy for applicant education
            applicantEducationUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantEducation", context);

            // Update the applicant education information
            wsDynamicsGP.UpdateApplicantEducation(applicantEducation, context, applicantEducationUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantEducation applicantEducation;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            Policy applicantEducationUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Retrieve the specified applicant education object
            applicantEducation = wsDynamicsGP.GetApplicantEducationByKey(applicantSequenceKey, context);

            // Change the value of the School property
            applicantEducation.School = "Local college";

            // Get the update policy for applicant education
            applicantEducationUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantEducation", context);

            // Update the applicant education information
            wsDynamicsGP.UpdateApplicantEducation(applicantEducation, context, applicantEducationUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateApplicantInterview

Description

Updates the specified applicant interview object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | ApplicantInterview | The applicant interview object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant interview object with an applicant key value of “1” an iinterview type key of “test”, and an apply date key equal to the current date. The example updates the value of the notes property. The UpdateApplicantInterview operation saves the change.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterview applicantInterview;
            ApplicantKey applicantKey;
            InterviewTypeKey interviewTypeKey;
            ApplyDateKey applyDateKey;
            ApplicantInterviewTypeKey applicantInterviewTypeKey;
            Policy applicantInterviewUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an interview type key
            interviewTypeKey = new InterviewTypeKey();
            interviewTypeKey.Id = "test";

            // Create an apply date key
            applyDateKey = new ApplyDateKey();
            applyDateKey.Id = DateTime.Today;

            // Create an applicant interview type key
            applicantInterviewTypeKey = new ApplicantInterviewTypeKey();
            applicantInterviewTypeKey.ApplicantKey = applicantKey;
            applicantInterviewTypeKey.InterviewTypeKey = interviewTypeKey;
            applicantInterviewTypeKey.ApplyDateKey = applyDateKey;

            // Retrieve the applicant interview object
            applicantInterview = wsDynamicsGP.GetApplicantInterviewByKey(applicantInterviewTypeKey, context);

            // Update the applicant interview notes
            applicantInterview.Notes = "Update applicant interview";

            // Get the update policy for applicant interview objects
            applicantInterviewUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantInterview", context);

            // Update the applicant interview object
            wsDynamicsGP.UpdateApplicantInterview(applicantInterview, context, applicantInterviewUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantInterview applicantInterview;
            ApplicantKey applicantKey;
            InterviewTypeKey interviewTypeKey;
            ApplyDateKey applyDateKey;
            ApplicantInterviewTypeKey applicantInterviewTypeKey;
            Policy applicantInterviewUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create an interview type key
            interviewTypeKey = new InterviewTypeKey();
            interviewTypeKey.Id = "test";

            // Create an apply date key
            applyDateKey = new ApplyDateKey();
            applyDateKey.Id = DateTime.Today;

            // Create an applicant interview type key
            applicantInterviewTypeKey = new ApplicantInterviewTypeKey();
            applicantInterviewTypeKey.ApplicantKey = applicantKey;
            applicantInterviewTypeKey.InterviewTypeKey = interviewTypeKey;
            applicantInterviewTypeKey.ApplyDateKey = applyDateKey;

            // Retrieve the applicant interview object
            applicantInterview = wsDynamicsGP.GetApplicantInterviewByKey(applicantInterviewTypeKey, context);

            // Update the applicant interview notes
            applicantInterview.Notes = "Update applicant interview";

            // Get the update policy for applicant interview objects
            applicantInterviewUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantInterview", context);

            // Update the applicant interview object
            wsDynamicsGP.UpdateApplicantInterview(applicantInterview, context, applicantInterviewUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateApplicantReference

Description

Updates the specified applicant reference object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | ApplicantReference | The applicant reference object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant reference object with the specified applicant refernece key. The example updates the value of the company name property. The UpdateApplicantReference operation saves the change.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantReference applicantReference;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantReferenceKey applicantReferenceKey;
            Policy applicantReferenceUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 2;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            //Create an applicant reference key
            applicantReferenceKey = new ApplicantReferenceKey();
            applicantReferenceKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantReferenceKey.Id = "Test reference";

            // Retrieve the specified applicant reference object
            applicantReference = wsDynamicsGP.GetApplicantReferenceByKey(applicantReferenceKey, context);

            // Change the value of the cmpany name property
            applicantReference.CompanyName = "Company Name";

            // Get the update policy for applicant references
            applicantReferenceUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantReference", context);

            // Update the applicant reference information
            wsDynamicsGP.UpdateApplicantReference(applicantReference, context, applicantReferenceUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantReference applicantReference;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantReferenceKey applicantReferenceKey;
            Policy applicantReferenceUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 2;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            //Create an applicant reference key
            applicantReferenceKey = new ApplicantReferenceKey();
            applicantReferenceKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantReferenceKey.Id = "Test reference";

            // Retrieve the specified applicant reference object
            applicantReference = wsDynamicsGP.GetApplicantReferenceByKey(applicantReferenceKey, context);

            // Change the value of the cmpany name property
            applicantReference.CompanyName = "Company Name";

            // Get the update policy for applicant references
            applicantReferenceUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantReference", context);

            // Update the applicant reference information
            wsDynamicsGP.UpdateApplicantReference(applicantReference, context, applicantReferenceUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateApplicantSkill

Description

Updates the specified applicant skill object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | ApplicantSkill | The applicant skill object that is being updated.
context | Context | Specifies information about how the methodSpecifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant skill object with the specified applicant skill key. The example updates the value of the comments property. The UpdateApplicantSkill operation saves the change.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSkill applicantSkill;
            ApplicantKey applicantKey;
            SkillKey skillKey;
            ApplicantSkillKey applicantSkillKey;
            Policy applicantSkillUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create an applicant skill key
            applicantSkillKey = new ApplicantSkillKey();
            applicantSkillKey.ApplicantKey = applicantKey;
            applicantSkillKey.SkillKey = skillKey;

            // Retrieve the specified applicant skill object
            applicantSkill = wsDynamicsGP.GetApplicantSkillByKey(applicantSkillKey, context);

            // Change the value of the comments property
            applicantSkill.Comments = "Updated applicant skill";

            // Get the update policy for applicant skill objects
            applicantSkillUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantskill", context);

            // Update the applicant skill information
            wsDynamicsGP.UpdateApplicantSkill(applicantSkill, context, applicantSkillUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantSkill applicantSkill;
            ApplicantKey applicantKey;
            SkillKey skillKey;
            ApplicantSkillKey applicantSkillKey;
            Policy applicantSkillUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Create an applicant skill key
            applicantSkillKey = new ApplicantSkillKey();
            applicantSkillKey.ApplicantKey = applicantKey;
            applicantSkillKey.SkillKey = skillKey;

            // Retrieve the specified applicant skill object
            applicantSkill = wsDynamicsGP.GetApplicantSkillByKey(applicantSkillKey, context);

            // Change the value of the comments property
            applicantSkill.Comments = "Updated applicant skill";

            // Get the update policy for applicant skill objects
            applicantSkillUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantskill", context);

            // Update the applicant skill information
            wsDynamicsGP.UpdateApplicantSkill(applicantSkill, context, applicantSkillUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateApplicantTest

Description

Updates the specified applicant test object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | ApplicantTest | The applicant test object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant test object with the specified applicant test key. The example updates the value of the notes property. The UpdateApplicantTest operation saves the change.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            TestKey testKey;
            ApplicantTest applicantTest;
            ApplicantTestKey applicantTestKey;
            Policy applicantTestUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create a test key
            testKey = new TestKey();
            testKey.Id = "TEST1";

            // Create an applicant test key
            applicantTestKey = new ApplicantTestKey();
            applicantTestKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantTestKey.TestKey = testKey;

            // Retrieve the applicant test object
            applicantTest = wsDynamicsGP.GetApplicantTestByKey(applicantTestKey, context);

            // Update the Notes property of the applicant test object
            applicantTest.Notes = "Updated applicant test";

            // Get the update policy for applicant test objects
            applicantTestUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantTest", context);

            // Update the applicant test information
            wsDynamicsGP.UpdateApplicantTest(applicantTest, context, applicantTestUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            TestKey testKey;
            ApplicantTest applicantTest;
            ApplicantTestKey applicantTestKey;
            Policy applicantTestUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create a test key
            testKey = new TestKey();
            testKey.Id = "TEST1";

            // Create an applicant test key
            applicantTestKey = new ApplicantTestKey();
            applicantTestKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantTestKey.TestKey = testKey;

            // Retrieve the applicant test object
            applicantTest = wsDynamicsGP.GetApplicantTestByKey(applicantTestKey, context);

            // Update the Notes property of the applicant test object
            applicantTest.Notes = "Updated applicant test";

            // Get the update policy for applicant test objects
            applicantTestUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateApplicantTest", context);

            // Update the applicant test information
            wsDynamicsGP.UpdateApplicantTest(applicantTest, context, applicantTestUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateApplicantWorkHistory

Description

Updates the specified applicant work history object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | ApplicantWorkHistory | The applicant work history object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves the applicant work history object with the specified applicant work history key. The value of the years of experience property is updated. The UpdateApplicantWorkHistory operation saves the change.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantWorkHistoryKey applicantWorkHistoryKey;
            ApplicantWorkHistory applicantWorkHistory;
            Policy applicantWorkHistoryUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant work history key
            applicantWorkHistoryKey = new ApplicantWorkHistoryKey();
            applicantWorkHistoryKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantWorkHistoryKey.Id = "Previous employer";

            // Retrieve the applicant work history object
            applicantWorkHistory = wsDynamicsGP.GetApplicantWorkHistoryByKey(
                applicantWorkHistoryKey, context);

            // Update the years of experience property of the work history object
            applicantWorkHistory.YearsOfExperience = 4;

            // Get the update policy for applicant work history objects
            applicantWorkHistoryUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "UpdateApplicantWorkHistory", context);

            // Update the applicant work history
            wsDynamicsGP.UpdateApplicantWorkHistory(applicantWorkHistory, context, applicantWorkHistoryUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ApplicantKey applicantKey;
            SequenceKey sequenceKey;
            ApplicantSequenceKey applicantSequenceKey;
            ApplicantWorkHistoryKey applicantWorkHistoryKey;
            ApplicantWorkHistory applicantWorkHistory;
            Policy applicantWorkHistoryUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an applicant key
            applicantKey = new ApplicantKey();
            applicantKey.Id = 1;

            // Create a sequence key
            sequenceKey = new SequenceKey();
            sequenceKey.Id = 1;

            // Create an applicant sequence key
            applicantSequenceKey = new ApplicantSequenceKey();
            applicantSequenceKey.ApplicantKey = applicantKey;
            applicantSequenceKey.SequenceKey = sequenceKey;

            // Create an applicant work history key
            applicantWorkHistoryKey = new ApplicantWorkHistoryKey();
            applicantWorkHistoryKey.ApplicantSequenceKey = applicantSequenceKey;
            applicantWorkHistoryKey.Id = "Previous employer";

            // Retrieve the applicant work history object
            applicantWorkHistory = wsDynamicsGP.GetApplicantWorkHistoryByKey(
                applicantWorkHistoryKey, context);

            // Update the years of experience property of the work history object
            applicantWorkHistory.YearsOfExperience = 4;

            // Get the update policy for applicant work history objects
            applicantWorkHistoryUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "UpdateApplicantWorkHistory", context);

            // Update the applicant work history
            wsDynamicsGP.UpdateApplicantWorkHistory(applicantWorkHistory, context, applicantWorkHistoryUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateCorporateAccount

Description

Updates the specified corporate account object, storing the current values in the database.

Parameters

Parameter | Type | Description
corporateAccount | CorporateAccount | The corporate account object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the corporate account with the key value “COMMUNIC0001” and sets the ApplyHoldActiveStatusOfParentAcrossCorporateAccount property. The UpdateCorporateAccount operation saves the change. The “COMMUNIC0001” corporate account used in this example was created by the CreateCorporateAccount example.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CorporateAccount corporateAccount;
            Policy updateCorpAccountPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the corporate account
            customerKey = new CustomerKey();
            customerKey.Id = "COMMUNIC0001";

            // Retrieve the corporate account object
            corporateAccount = wsDynamicsGP.GetCorporateAccountByKey(customerKey, context);

            // Set the ApplyHoldActiveStatusOfParentAcrossCorporateAccount property
            corporateAccount.ApplyHoldActiveStatusOfParentAcrossCorporateAccount = true;

            // Get the update policy for corporate accounts
            updateCorpAccountPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCorporateAccount", context);

            // Update the corporate account
            wsDynamicsGP.UpdateCorporateAccount(corporateAccount, context, updateCorpAccountPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CorporateAccount corporateAccount;
            Policy updateCorpAccountPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the corporate account
            customerKey = new CustomerKey();
            customerKey.Id = "COMMUNIC0001";

            // Retrieve the corporate account object
            corporateAccount = wsDynamicsGP.GetCorporateAccountByKey(customerKey, context);

            // Set the ApplyHoldActiveStatusOfParentAcrossCorporateAccount property
            corporateAccount.ApplyHoldActiveStatusOfParentAcrossCorporateAccount = true;

            // Get the update policy for corporate accounts
            updateCorpAccountPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCorporateAccount", context);

            // Update the corporate account
            wsDynamicsGP.UpdateCorporateAccount(corporateAccount, context, updateCorpAccountPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateCustomer

Description

Updates the specified customer object, storing the current values in the database.

Parameters

Parameter | Type | Description
customer | Customer | The customer object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the customer with the key value “AARONFIT0001” and sets the Comment1 property. The UpdateCustomer operation saves the change.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            Policy customerPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Retrieve the customer object
            customer = wsDynamicsGP.GetCustomerByKey(customerKey, context);

            // Add a comment
            customer.Comment1 = "Customer is moving";

            // Get the update policy for the customer
            customerPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCustomer", context);

            // Update the customer
            wsDynamicsGP.UpdateCustomer(customer, context, customerPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            Policy customerPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Retrieve the customer object
            customer = wsDynamicsGP.GetCustomerByKey(customerKey, context);

            // Add a comment
            customer.Comment1 = "Customer is moving";

            // Get the update policy for the customer
            customerPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCustomer", context);

            // Update the customer
            wsDynamicsGP.UpdateCustomer(customer, context, customerPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateCustomerAddress

Description

Updates the specified customer address object, storing the current values in the database.

Parameters

Parameter | Type | Description
address | CustomerAddress | The customer address object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves and updates the customer address with the customer address key value of “WAREHOUSE” and a vendor key value of “AARONFIT0001”. The update sets the Line2 property to a value of “Receiving Dept.”. The UpdateCustomerAddress operation saves the new address value to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerAddressKey customerAddressKey;
            CustomerAddress customerAddress;
            Policy customerAddressUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a customer address key object
            customerAddressKey = new CustomerAddressKey();
            customerAddressKey.CustomerKey = customerKey;
            customerAddressKey.Id = "WAREHOUSE";

            // Retrieve the customer address object
            customerAddress = wsDynamicsGP.GetCustomerAddressByKey(customerAddressKey, context);

            // Populate the Line2 property with a new value
            customerAddress.Line2 = "Receiving Dept.";

            // Get the update policy for customer address
            customerAddressUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCustomerAddress",
            context);

            // Update the customer address
            wsDynamicsGP.UpdateCustomerAddress(customerAddress, context, customerAddressUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            CustomerKey customerKey;
            CustomerAddressKey customerAddressKey;
            CustomerAddress customerAddress;
            Policy customerAddressUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key to specify the customer
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Create a customer address key object
            customerAddressKey = new CustomerAddressKey();
            customerAddressKey.CustomerKey = customerKey;
            customerAddressKey.Id = "WAREHOUSE";

            // Retrieve the customer address object
            customerAddress = wsDynamicsGP.GetCustomerAddressByKey(customerAddressKey, context);

            // Populate the Line2 property with a new value
            customerAddress.Line2 = "Receiving Dept.";

            // Get the update policy for customer address
            customerAddressUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCustomerAddress",
            context);

            // Update the customer address
            wsDynamicsGP.UpdateCustomerAddress(customerAddress, context, customerAddressUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateEmployee

Description

Updates the specified employee object, storing the current values in the database.

Parameters

Parameter | Type | Description
employee | Employee | The employee object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves and updates the status property of the employee with an Id of “ACKE0001”. The update sets the Status property to “Other. The UpdateEmployee operation saves the changes to the employee object to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Employee employee;
            EmployeeKey employeeKey;
            Policy employeeUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Retrieve the employee object
            employee = wsDynamicsGP.GetEmployeeByKey(employeeKey, context);

            // Change the status property of the employee object
            employee.HRStatus = HRStatus.Other;

            // Get the update policy for employee objects
            employeeUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateEmployee", context);

            // Update the employee
            wsDynamicsGP.UpdateEmployee(employee, context, employeeUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Employee employee;
            EmployeeKey employeeKey;
            Policy employeeUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Retrieve the employee object
            employee = wsDynamicsGP.GetEmployeeByKey(employeeKey, context);

            // Change the status property of the employee object
            employee.HRStatus = HRStatus.Other;

            // Get the update policy for employee objects
            employeeUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateEmployee", context);

            // Update the employee
            wsDynamicsGP.UpdateEmployee(employee, context, employeeUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateEmployeeAddress

Description

Updates the specified employee address object, storing the current values in the database.

Parameters

Parameter | Type | Description
employee | EmployeeAddress | The employee address object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves and updates the employee address with the employee with an Id of “ACKE0001” and a employee address Id of “Test address”. The update sets the State property to “WA”. The UpdateEmployeeAddress operation saves the updated address value to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeKey employeeKey;
            EmployeeAddressKey employeeAddressKey;
            EmployeeAddress employeeAddress;
            Policy employeeAddressUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create an employee address key
            employeeAddressKey = new EmployeeAddressKey();
            employeeAddressKey.EmployeeKey = employeeKey;
            employeeAddressKey.Id = "Test address";

            // Get the specified employee address object
            employeeAddress = wsDynamicsGP.GetEmployeeAddressByKey(employeeAddressKey, context);

            // Change the value of the State property of the employee address object
            employeeAddress.State = "WA";

            // Get the update policy for employee address objects
            employeeAddressUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateEmployeeAddress", context);

            // Update the employee address object
            wsDynamicsGP.UpdateEmployeeAddress(employeeAddress, context, employeeAddressUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeeKey employeeKey;
            EmployeeAddressKey employeeAddressKey;
            EmployeeAddress employeeAddress;
            Policy employeeAddressUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create an employee address key
            employeeAddressKey = new EmployeeAddressKey();
            employeeAddressKey.EmployeeKey = employeeKey;
            employeeAddressKey.Id = "Test address";

            // Get the specified employee address object
            employeeAddress = wsDynamicsGP.GetEmployeeAddressByKey(employeeAddressKey, context);

            // Change the value of the State property of the employee address object
            employeeAddress.State = "WA";

            // Get the update policy for employee address objects
            employeeAddressUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateEmployeeAddress", context);

            // Update the employee address object
            wsDynamicsGP.UpdateEmployeeAddress(employeeAddress, context, employeeAddressUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateEmployeePayCode

Description

Updates the specified employee pay code object, storing the current values in the database.

Parameters

Parameter | Type | Description
employeePayCode | EmployeePayCode | The employee pay code object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves and updates the employee pay code for the employee with an Id of “ACKE0001” and a pay code Id of “COMM”. The update sets the PayPeriod property to quarterly. The UpdateEmployeePayCode operation saves the updated employee pay code value to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeePayCode employeePayCode;
            EmployeePayCodeKey employeePayCodeKey;
            EmployeeKey employeeKey;
            PayCodeKey payCodeKey;
            Policy employeePayCodeUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create a pay code key
            payCodeKey = new PayCodeKey();
            payCodeKey.Id = "COMM";

            // Create an employee pay code key
            employeePayCodeKey = new EmployeePayCodeKey();
            employeePayCodeKey.EmployeeKey = employeeKey;
            employeePayCodeKey.PayCodeKey = payCodeKey;

            // Get the employee pay code object
            employeePayCode = wsDynamicsGP.GetEmployeePayCodeByKey(employeePayCodeKey, context);

            // Update the compensation period
            employeePayCode.PayPeriod = CompensationPeriod.Quarterly;

            // Get the update policy for employee pay code objects
            employeePayCodeUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "UpdateEmployeePayCode", context);

            // Update the employee pay code object
            wsDynamicsGP.UpdateEmployeePayCode(employeePayCode, context, employeePayCodeUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            EmployeePayCode employeePayCode;
            EmployeePayCodeKey employeePayCodeKey;
            EmployeeKey employeeKey;
            PayCodeKey payCodeKey;
            Policy employeePayCodeUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an employee key
            employeeKey = new EmployeeKey();
            employeeKey.Id = "ACKE0001";

            // Create a pay code key
            payCodeKey = new PayCodeKey();
            payCodeKey.Id = "COMM";

            // Create an employee pay code key
            employeePayCodeKey = new EmployeePayCodeKey();
            employeePayCodeKey.EmployeeKey = employeeKey;
            employeePayCodeKey.PayCodeKey = payCodeKey;

            // Get the employee pay code object
            employeePayCode = wsDynamicsGP.GetEmployeePayCodeByKey(employeePayCodeKey, context);

            // Update the compensation period
            employeePayCode.PayPeriod = CompensationPeriod.Quarterly;

            // Get the update policy for employee pay code objects
            employeePayCodeUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "UpdateEmployeePayCode", context);

            // Update the employee pay code object
            wsDynamicsGP.UpdateEmployeePayCode(employeePayCode, context, employeePayCodeUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateHRRequisition

Description

Updates the specified HR requisition object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | HRRequisition | The HR requisition object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example retrieves and updates the HR requisition with an Id of “1”. The UpdateHRRequisition operation saves the changes made to the requisition to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            HRRequisitionNumberKey requisitionNumberKey;
            HRRequisition requisition;
            Policy requisitionUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a requisition number key
            requisitionNumberKey = new HRRequisitionNumberKey();
            requisitionNumberKey.Id = "1";

            // Get the specified requisition object
            requisition = wsDynamicsGP.GetHRRequisitionByKey(requisitionNumberKey, context);

            // Update the requisition object
            requisition.PositionsAvailable = 2;

            // Get the update policy for requisition objects
            requisitionUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateHRRequisition", context);

            // Update the requisition
            wsDynamicsGP.UpdateHRRequisition(requisition, context, requisitionUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            HRRequisitionNumberKey requisitionNumberKey;
            HRRequisition requisition;
            Policy requisitionUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a requisition number key
            requisitionNumberKey = new HRRequisitionNumberKey();
            requisitionNumberKey.Id = "1";

            // Get the specified requisition object
            requisition = wsDynamicsGP.GetHRRequisitionByKey(requisitionNumberKey, context);

            // Update the requisition object
            requisition.PositionsAvailable = 2;

            // Get the update policy for requisition objects
            requisitionUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateHRRequisition", context);

            // Update the requisition
            wsDynamicsGP.UpdateHRRequisition(requisition, context, requisitionUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateItemVendor

Description

Updates the specified item vendor object, storing the current values in the database.

Parameters

Parameter | Type | Description
itemVendor | ItemVendor | Theitem vendor object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Inventory

Examples

The following C# example retrieves and updates the item vendor with an item Id of “100XLG” and vendor ID of “ACETRAVE0001“. The UpdateItemVendor operation saves the changes to the minimum order quantity property of the item vendor to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            VendorKey vendorKey;
            ItemVendorKey itemVendorKey;
            ItemVendor itemVendor;
            Quantity orderQuantity;
            Policy itemVendorUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "100XLG";

            // Create a vendor key to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create an item vendor key object
            itemVendorKey = new ItemVendorKey();
            itemVendorKey.ItemKey = itemKey;
            itemVendorKey.VendorKey = vendorKey;

            // Retrieve the item vendor object
            itemVendor = wsDynamicsGP.GetItemVendorByKey(itemVendorKey, context);

            // Change the minimum order quantity value for the item vendor
            orderQuantity = new Quantity();
            orderQuantity.Value = 5;
            itemVendor.MinimumOrderQuantity = orderQuantity;

            // Get the update policy for item vendor objects
            itemVendorUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateItemVendor", context);

            // Update the item vendor
            wsDynamicsGP.UpdateItemVendor(itemVendor, context, itemVendorUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            VendorKey vendorKey;
            ItemVendorKey itemVendorKey;
            ItemVendor itemVendor;
            Quantity orderQuantity;
            Policy itemVendorUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key to specify the item
            itemKey = new ItemKey();
            itemKey.Id = "100XLG";

            // Create a vendor key to specify the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create an item vendor key object
            itemVendorKey = new ItemVendorKey();
            itemVendorKey.ItemKey = itemKey;
            itemVendorKey.VendorKey = vendorKey;

            // Retrieve the item vendor object
            itemVendor = wsDynamicsGP.GetItemVendorByKey(itemVendorKey, context);

            // Change the minimum order quantity value for the item vendor
            orderQuantity = new Quantity();
            orderQuantity.Value = 5;
            itemVendor.MinimumOrderQuantity = orderQuantity;

            // Get the update policy for item vendor objects
            itemVendorUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateItemVendor", context);

            // Update the item vendor
            wsDynamicsGP.UpdateItemVendor(itemVendor, context, itemVendorUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdatePolicy

Description

Updates a policy instance for the specified role. Changes made to the behaviors for the policy instance will be saved.

Parameters

Parameter | Type | Description
policy | Policy | The policy for the policy instance that is being updated.
roleKey | RoleKey | The role key object that specifies the role for the policy instance being updated.
context | Context | Specifies information about how the method will be called.

Interfaces

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales

Examples

The following C# example retrieves the Update Customer policy for the default role. It modifies the selected behavior option for the Create Active behavior, and then updates the default instance of the policy.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Policy createCustomerPolicy;
            PolicyKey policyKey;
            RoleKey roleKey;
            Behavior createActiveBehavior;
            BehaviorOption setToInactiveBehaviorOption;
            Guid behaviorGUID;
            int behaviorOptionID;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the role key for the role (default role)
            roleKey = new RoleKey();
            roleKey.Id = "00000000-0000-0000-0000-000000000000";

            // Get the complete policy for Create Customer
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("94880780-186c-43c8-b484-efcdd03cbdbe");
            createCustomerPolicy = wsDynamicsGP.GetCompletePolicyByKey(policyKey, roleKey, context);

            // Set the behavior for the 'Create Active' behavior
            // Find the behavior in the list (from Web Service Reference)
            behaviorGUID = new Guid("5c098de9-952c-478c-ad4b-cf992b55ea46");
            createActiveBehavior = new Behavior();
            foreach (Behavior b in createCustomerPolicy.Behaviors)
            {
                if (b.Key.Id == behaviorGUID)
                {
                    // Behavior was found
                    createActiveBehavior = b;
                    break;
                }
            }

            // Find the behavior option (from Web Service Reference)
            behaviorOptionID = 2;
            setToInactiveBehaviorOption = new BehaviorOption();
            foreach (BehaviorOption bo in createActiveBehavior.Options)
            {
                if (bo.Key.Id == behaviorOptionID)
                {
                    // Behavior option was found
                    setToInactiveBehaviorOption = bo;
                    break;
                }
            }

            // Set selected behavior option to create inactive customers
            createActiveBehavior.SelectedOption = setToInactiveBehaviorOption;

            // Update the policy instance for the default role
            wsDynamicsGP.UpdatePolicy(createCustomerPolicy, roleKey, context);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Policy createCustomerPolicy;
            PolicyKey policyKey;
            RoleKey roleKey;
            Behavior createActiveBehavior;
            BehaviorOption setToInactiveBehaviorOption;
            Guid behaviorGUID;
            int behaviorOptionID;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the role key for the role (default role)
            roleKey = new RoleKey();
            roleKey.Id = "00000000-0000-0000-0000-000000000000";

            // Get the complete policy for Create Customer
            policyKey = new PolicyKey();
            policyKey.Id = new Guid("94880780-186c-43c8-b484-efcdd03cbdbe");
            createCustomerPolicy = wsDynamicsGP.GetCompletePolicyByKey(policyKey, roleKey, context);

            // Set the behavior for the 'Create Active' behavior
            // Find the behavior in the list (from Web Service Reference)
            behaviorGUID = new Guid("5c098de9-952c-478c-ad4b-cf992b55ea46");
            createActiveBehavior = new Behavior();
            foreach (Behavior b in createCustomerPolicy.Behaviors)
            {
                if (b.Key.Id == behaviorGUID)
                {
                    // Behavior was found
                    createActiveBehavior = b;
                    break;
                }
            }

            // Find the behavior option (from Web Service Reference)
            behaviorOptionID = 2;
            setToInactiveBehaviorOption = new BehaviorOption();
            foreach (BehaviorOption bo in createActiveBehavior.Options)
            {
                if (bo.Key.Id == behaviorOptionID)
                {
                    // Behavior option was found
                    setToInactiveBehaviorOption = bo;
                    break;
                }
            }

            // Set selected behavior option to create inactive customers
            createActiveBehavior.SelectedOption = setToInactiveBehaviorOption;

            // Update the policy instance for the default role
            wsDynamicsGP.UpdatePolicy(createCustomerPolicy, roleKey, context);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdatePurchaseOrder

Description

Updates the specified purchase order object, storing the current values in the database.

Parameters

Parameter | Type | Description
purchaseOrder | PurchaseOrder | The purchase order object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example retrieves and updates the purchase order with the Id “PO4055”. The UpdatePurchaseOrder operation saves the changes to the purchase order object to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            PurchaseOrder purchaseOrder;
            Policy purchaseOrderUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO4055";

            // Retrieve the purchase order object
            purchaseOrder = wsDynamicsGP.GetPurchaseOrderByKey(purchaseOrderKey, context);

            // Change the status of the purchase order
            purchaseOrder.Status = PurchaseOrderStatus.Canceled;

            // Get the update policy for purchase orders
            purchaseOrderUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdatePurchaseOrder", context);

            // Update the purchase oder
            wsDynamicsGP.UpdatePurchaseOrder(purchaseOrder, context, purchaseOrderUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            PurchaseOrder purchaseOrder;
            Policy purchaseOrderUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO4055";

            // Retrieve the purchase order object
            purchaseOrder = wsDynamicsGP.GetPurchaseOrderByKey(purchaseOrderKey, context);

            // Change the status of the purchase order
            purchaseOrder.Status = PurchaseOrderStatus.Canceled;

            // Get the update policy for purchase orders
            purchaseOrderUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdatePurchaseOrder", context);

            // Update the purchase oder
            wsDynamicsGP.UpdatePurchaseOrder(purchaseOrder, context, purchaseOrderUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateReturnMaterialAuthorization

Description

Updates the specified return material authorization object, storing the current values in the database.

Parameters

Parameter | Type | Description
returnMaterialAuthorization | ReturnMaterialAuthorization | The return material authorization object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves the return material authorizaton document with the service document key value “RMATEST000200” and sets the customer purchase order property to “100”. This example uses the return material authorization document created by the CreateReturnMaterialAuthorization example. The UpdateReturnMaterialAuthorization operation saves the new customer purchase order value and the return material authorization object’s existing properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ReturnMaterialAuthorization returnMaterialsAuthorization;
            ReturnMaterialAuthorizationReasonCodeKey rmaReasonCode;
            Policy returnMaterialAuthorizationUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key
            // Specify the return material authorization document number
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "RMATEST000200";

            // Retrieve the specified return materials authorization object
            returnMaterialsAuthorization = wsDynamicsGP.GetReturnMaterialAuthorizationByKey(
                serviceDocumentKey, context);

            // Set the customer purchase order number property to '100'
            returnMaterialsAuthorization.CustomerPONumber = "100";

            // Get the update policy for a return material authorizations
            returnMaterialAuthorizationUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "UpdateReturnMaterialAuthorization", context);

            // Update the specified return material authorization document
            wsDynamicsGP.UpdateReturnMaterialAuthorization(returnMaterialsAuthorization,
                context, returnMaterialAuthorizationUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ReturnMaterialAuthorization returnMaterialsAuthorization;
            ReturnMaterialAuthorizationReasonCodeKey rmaReasonCode;
            Policy returnMaterialAuthorizationUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key
            // Specify the return material authorization document number
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "RMATEST000200";

            // Retrieve the specified return materials authorization object
            returnMaterialsAuthorization = wsDynamicsGP.GetReturnMaterialAuthorizationByKey(
                serviceDocumentKey, context);

            // Set the customer purchase order number property to '100'
            returnMaterialsAuthorization.CustomerPONumber = "100";

            // Get the update policy for a return material authorizations
            returnMaterialAuthorizationUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "UpdateReturnMaterialAuthorization", context);

            // Update the specified return material authorization document
            wsDynamicsGP.UpdateReturnMaterialAuthorization(returnMaterialsAuthorization,
                context, returnMaterialAuthorizationUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSalesBackorder

Description

Updates the specified sales backorder object, storing the current values in the database.

Parameters

Parameter | Type | Description
salesBackorder | SalesBackorder | The sales backorder object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the sales backorder with the sales document key value “BKO1005” and sets the comment property to “Transferred from an order”. The UpdateSalesBackorder operation saves the new comment and all the sales backorder object’s existing properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesBackorder salesBackorder;
            SalesDocumentKey salesBackorderKey;
            Policy salesBackorderUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesBackorderKey = new SalesDocumentKey();
            salesBackorderKey.Id = "BKO1005";

            // Retrieve the sales backorder object
            salesBackorder = wsDynamicsGP.GetSalesBackorderByKey(salesBackorderKey, context);

            // Populate the comment property
            salesBackorder.Comment = "Transferred from an order";

            // Retrieve the update policy for sales backorders
            salesBackorderUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesBackorder", context);

            // Update the sales backorder object
            wsDynamicsGP.UpdateSalesBackorder(salesBackorder, context, salesBackorderUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesBackorder salesBackorder;
            SalesDocumentKey salesBackorderKey;
            Policy salesBackorderUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesBackorderKey = new SalesDocumentKey();
            salesBackorderKey.Id = "BKO1005";

            // Retrieve the sales backorder object
            salesBackorder = wsDynamicsGP.GetSalesBackorderByKey(salesBackorderKey, context);

            // Populate the comment property
            salesBackorder.Comment = "Transferred from an order";

            // Retrieve the update policy for sales backorders
            salesBackorderUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesBackorder", context);

            // Update the sales backorder object
            wsDynamicsGP.UpdateSalesBackorder(salesBackorder, context, salesBackorderUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSalesFulfillmentOrder

Description

Updates the specified sales fulfillment order object, storing the current values in the database.

Parameters

Parameter | Type | Description
salesFulfillmentOrder | SalesFulfillmentOrder | The sales fulfillment order object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the sales fulfillment order with the sales document key value “FULORD1000” and sets the comment property to “Confirmation completed.”. The UpdateSalesFulfillmentOrder operation saves the new comment and all the sales fulfillment order object’s existing properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            SalesFulfillmentOrder salesFulfillmentOrder;
            Policy salesFulfillmentOrderUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key and specify the sales fulfillment order
            documentKey = new SalesDocumentKey();
            documentKey.Id = "FULORD1000";

            // Retrieve the sales fulfillment order object
            salesFulfillmentOrder = wsDynamicsGP.GetSalesFulfillmentOrderByKey(documentKey, context);

            // Update the comment property
            salesFulfillmentOrder.Comment = "Confirmation completed.";

            // Get the update policy for sales fulfillment orders
            salesFulfillmentOrderUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "UpdateSalesFulfillmentOrder", context);

            // Update the sales order fulfillment
            wsDynamicsGP.UpdateSalesFulfillmentOrder(salesFulfillmentOrder,
            context, salesFulfillmentOrderUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            SalesFulfillmentOrder salesFulfillmentOrder;
            Policy salesFulfillmentOrderUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key and specify the sales fulfillment order
            documentKey = new SalesDocumentKey();
            documentKey.Id = "FULORD1000";

            // Retrieve the sales fulfillment order object
            salesFulfillmentOrder = wsDynamicsGP.GetSalesFulfillmentOrderByKey(documentKey, context);

            // Update the comment property
            salesFulfillmentOrder.Comment = "Confirmation completed.";

            // Get the update policy for sales fulfillment orders
            salesFulfillmentOrderUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "UpdateSalesFulfillmentOrder", context);

            // Update the sales order fulfillment
            wsDynamicsGP.UpdateSalesFulfillmentOrder(salesFulfillmentOrder,
            context, salesFulfillmentOrderUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSalesInvoice

Description

Updates the specified sales invoice object, storing the current values in the database.

Parameters

Parameter | Type | Description
salesInvoice | SalesInvoice | The sales invoice object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the sales invoice with the sales document key value “STDINV2255” and sets the comment property to “Requested ship date confirmed”. The UpdateSalesInvoice operation saves the new comment and all the sales invoice object’s existing properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesInvoiceKey;
            SalesInvoice salesInvoice;
            Policy salesInvoiceUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesInvoiceKey = new SalesDocumentKey();
            salesInvoiceKey.Id = "STDINV2255";

            // Retrieve the sales invoice
            salesInvoice = wsDynamicsGP.GetSalesInvoiceByKey(salesInvoiceKey, context);

            // Set the comment property
            salesInvoice.Comment = "Requested ship date confirmed";

            // Get the update policy for sales invoices
            salesInvoiceUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesInvoice", context);

            // Update the sales invoice object
            wsDynamicsGP.UpdateSalesInvoice(salesInvoice, context, salesInvoiceUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesInvoiceKey;
            SalesInvoice salesInvoice;
            Policy salesInvoiceUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesInvoiceKey = new SalesDocumentKey();
            salesInvoiceKey.Id = "STDINV2255";

            // Retrieve the sales invoice
            salesInvoice = wsDynamicsGP.GetSalesInvoiceByKey(salesInvoiceKey, context);

            // Set the comment property
            salesInvoice.Comment = "Requested ship date confirmed";

            // Get the update policy for sales invoices
            salesInvoiceUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesInvoice", context);

            // Update the sales invoice object
            wsDynamicsGP.UpdateSalesInvoice(salesInvoice, context, salesInvoiceUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSalesOrder

Description

Updates the specified sales order object, storing the current values in the database.

Parameters

Parameter | Type | Description
salesOrder | SalesOrder | The sales order object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the sales order with the sales document key value “ORDST2228” and sets the comment property to “Customer called about order status”. The UpdateSalesOrder operation saves the new comment and all the sales order object’s existing properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesOrderKey;
            SalesOrder salesOrder;
            Policy salesOrderUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesOrderKey = new SalesDocumentKey();
            salesOrderKey.Id = "ORDST2228";

            // Retrieve the sales order
            salesOrder = wsDynamicsGP.GetSalesOrderByKey(salesOrderKey, context);

            // Set the comment property
            salesOrder.Comment = "Customer called about order status";

            // Retrieve the update policy for sales orders
            salesOrderUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesOrder", context);

            // Update the sales order object
            wsDynamicsGP.UpdateSalesOrder(salesOrder, context, salesOrderUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesOrderKey;
            SalesOrder salesOrder;
            Policy salesOrderUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesOrderKey = new SalesDocumentKey();
            salesOrderKey.Id = "ORDST2228";

            // Retrieve the sales order
            salesOrder = wsDynamicsGP.GetSalesOrderByKey(salesOrderKey, context);

            // Set the comment property
            salesOrder.Comment = "Customer called about order status";

            // Retrieve the update policy for sales orders
            salesOrderUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesOrder", context);

            // Update the sales order object
            wsDynamicsGP.UpdateSalesOrder(salesOrder, context, salesOrderUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSalesProcessHoldSetup

Description

Updates the specified sales process hold setup object, storing the current values in the database.

Parameters

Parameter | Type | Description
salesProcessHoldSetup | SalesProcessHoldSetup | The sales process hold setup object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the sales process hold setup with the sales process hold setup key value “ADDRESS” and sets the Description property to “Address Verification Hold”. The UpdateSalesProcessHoldSetup operation saves the new description and all the sales process hold setup object’s existing properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesProcessHoldSetupKey salesProcessHoldSetupKey;
            SalesProcessHoldSetup salesProcessHoldSetup;
            Policy salesProcessHoldSetupUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales process hold setup key object
            salesProcessHoldSetupKey = new SalesProcessHoldSetupKey();
            salesProcessHoldSetupKey.Id = "ADDRESS";

            // Retrieve the specified sales process setup hold object
            salesProcessHoldSetup = wsDynamicsGP.GetSalesProcessHoldSetupByKey(
            salesProcessHoldSetupKey, context);

            // Update the description property of the sales process hold setup object
            salesProcessHoldSetup.Description = "Address Verification Hold";

            // Get the update policy for sales process hold setup objects
            salesProcessHoldSetupUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "UpdateSalesProcessHoldSetup", context);

            // Update the sales process hold object
            wsDynamicsGP.UpdateSalesProcessHoldSetup(salesProcessHoldSetup,
            context, salesProcessHoldSetupUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesProcessHoldSetupKey salesProcessHoldSetupKey;
            SalesProcessHoldSetup salesProcessHoldSetup;
            Policy salesProcessHoldSetupUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales process hold setup key object
            salesProcessHoldSetupKey = new SalesProcessHoldSetupKey();
            salesProcessHoldSetupKey.Id = "ADDRESS";

            // Retrieve the specified sales process setup hold object
            salesProcessHoldSetup = wsDynamicsGP.GetSalesProcessHoldSetupByKey(
            salesProcessHoldSetupKey, context);

            // Update the description property of the sales process hold setup object
            salesProcessHoldSetup.Description = "Address Verification Hold";

            // Get the update policy for sales process hold setup objects
            salesProcessHoldSetupUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
            "UpdateSalesProcessHoldSetup", context);

            // Update the sales process hold object
            wsDynamicsGP.UpdateSalesProcessHoldSetup(salesProcessHoldSetup,
            context, salesProcessHoldSetupUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSalesQuote

Description

Updates the specified sales quote object, storing the current values in the database.

Parameters

Parameter | Type | Description
salesQuote | SalesQuote | The sales quote object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the sales quote with the sales document key value “QTEST1022” and sets the comment property to “Confirmed line items with customer”. The UpdateSalesQuote operation saves the new comment and all the sales quote object’s properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            SalesQuote salesQuote;
            Policy salesQuoteUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales quote
            documentKey = new SalesDocumentKey();
            documentKey.Id = "QTEST1022";

            // Retrieve the sales quote object
            salesQuote = wsDynamicsGP.GetSalesQuoteByKey(documentKey, context);

            // Update the comment property
            salesQuote.Comment = "Confirmed line items with customer";

            // Get the update policy for sales quotes
            salesQuoteUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesQuote", context);

            // Update the sales quote object
            wsDynamicsGP.UpdateSalesQuote(salesQuote, context, salesQuoteUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            SalesQuote salesQuote;
            Policy salesQuoteUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales quote
            documentKey = new SalesDocumentKey();
            documentKey.Id = "QTEST1022";

            // Retrieve the sales quote object
            salesQuote = wsDynamicsGP.GetSalesQuoteByKey(documentKey, context);

            // Update the comment property
            salesQuote.Comment = "Confirmed line items with customer";

            // Get the update policy for sales quotes
            salesQuoteUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesQuote", context);

            // Update the sales quote object
            wsDynamicsGP.UpdateSalesQuote(salesQuote, context, salesQuoteUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSalesReturn

Description

Updates the specified sales return object, storing the current values in the database.

Parameters

Parameter | Type | Description
salesReturn | SalesReturn | The sales return object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example retrieves the sales return with the sales return key value “STDINV2257” and sets the comment property to “Return was approved”. The UpdateSalesReturn operation saves the new comment and all the sales return object’s properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            SalesReturn salesReturn;
            Policy salesReturnPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Sales Return key and specify the sales return
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Retrieve the sales return object
            salesReturn = wsDynamicsGP.GetSalesReturnByKey(salesReturnKey, context);

            // Set the comment property
            salesReturn.Comment = "Return was approved";

            // Get the update policy for sales returns
            salesReturnPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesReturn", context);

            // Update the sales return object
            wsDynamicsGP.UpdateSalesReturn(salesReturn, context, salesReturnPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            SalesReturn salesReturn;
            Policy salesReturnPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a Sales Return key and specify the sales return
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Retrieve the sales return object
            salesReturn = wsDynamicsGP.GetSalesReturnByKey(salesReturnKey, context);

            // Set the comment property
            salesReturn.Comment = "Return was approved";

            // Get the update policy for sales returns
            salesReturnPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSalesReturn", context);

            // Update the sales return object
            wsDynamicsGP.UpdateSalesReturn(salesReturn, context, salesReturnPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateServiceCall

Description

Updates the specified service call object, storing the current values in the database.

Parameters

Parameter | Type | Description
serviceCall | ServiceCall | The service call object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves the service call document with the service document Id of “SCTEST00100”. This example uses the service call document created by the CreateServiceCall example. The service call priority is updated to “90”. The UpdateServiceCall operation saves the newly assigned priority and the service call object’s other properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ServiceCall serviceCall;
            Policy serviceCallUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key object
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "SCTEST00100";

            // Retrieve the specified service call object
            serviceCall = wsDynamicsGP.GetServiceCallByKey(serviceDocumentKey, context);

            // Update the service call priority property
            serviceCall.Priority = 90;

            // Retrieve the update policy for service call
            serviceCallUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateServiceCall", context);

            // Update the service call document
            wsDynamicsGP.UpdateServiceCall(serviceCall, context, serviceCallUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ServiceCall serviceCall;
            Policy serviceCallUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key object
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "SCTEST00100";

            // Retrieve the specified service call object
            serviceCall = wsDynamicsGP.GetServiceCallByKey(serviceDocumentKey, context);

            // Update the service call priority property
            serviceCall.Priority = 90;

            // Retrieve the update policy for service call
            serviceCallUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateServiceCall", context);

            // Update the service call document
            wsDynamicsGP.UpdateServiceCall(serviceCall, context, serviceCallUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateServiceEquipment

Description

Updates the specified service equipment object, storing the current values in the database.

Parameters

Parameter | Type | Description
serviceEquipment | ServiceEquipment | The service equipment object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves the service equipment document with the service document Id of “00045478” and item key of “2-A3284A“. The example updates the service equipment document’s TechnicianKey property to “T0117”. The UpdateServiceEquipment operation saves the newly assigned technician Id and the service equipment object’s other properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            ServiceEquipmentKey serviceEquipmentKey;
            ServiceEquipment serviceEquipment;
            Policy serviceEquipUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object
            itemKey = new ItemKey();
            itemKey.Id = "2-A3284A";

            // Create a service equipment key object
            serviceEquipmentKey = new ServiceEquipmentKey();
            serviceEquipmentKey.Id = "00045478";
            serviceEquipmentKey.ItemKey = itemKey;

            // Retrieve the specified service equipment object
            serviceEquipment = wsDynamicsGP.GetServiceEquipmentByKey(serviceEquipmentKey, context);

            // Create a technician key and specify the technician for the service equipment object
            ServiceTechnicianKey technicianKey = new ServiceTechnicianKey();
            technicianKey.Id = "T0117";

            // Add the technician key to the service equipment object
            serviceEquipment.TechnicianKey = technicianKey;

            // Get the update policy for service equipment
            serviceEquipUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateServiceEquipment", context);

            // Update the service equipment information
            wsDynamicsGP.UpdateServiceEquipment(serviceEquipment, context, serviceEquipUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ItemKey itemKey;
            ServiceEquipmentKey serviceEquipmentKey;
            ServiceEquipment serviceEquipment;
            Policy serviceEquipUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create an item key object
            itemKey = new ItemKey();
            itemKey.Id = "2-A3284A";

            // Create a service equipment key object
            serviceEquipmentKey = new ServiceEquipmentKey();
            serviceEquipmentKey.Id = "00045478";
            serviceEquipmentKey.ItemKey = itemKey;

            // Retrieve the specified service equipment object
            serviceEquipment = wsDynamicsGP.GetServiceEquipmentByKey(serviceEquipmentKey, context);

            // Create a technician key and specify the technician for the service equipment object
            ServiceTechnicianKey technicianKey = new ServiceTechnicianKey();
            technicianKey.Id = "T0117";

            // Add the technician key to the service equipment object
            serviceEquipment.TechnicianKey = technicianKey;

            // Get the update policy for service equipment
            serviceEquipUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateServiceEquipment", context);

            // Update the service equipment information
            wsDynamicsGP.UpdateServiceEquipment(serviceEquipment, context, serviceEquipUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateServiceQuote

Description

Updates the specified service quote object, storing the current values in the database.

Parameters

Parameter | Type | Description
serviceQuote | ServiceQuote | The service quote object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Field Service

Examples

The following C# example retrieves the service quote document with the service document Id of “SQTEST0100”. This example uses the service quote document created by the CreateServiceQuote example. The service quote description property is updated with “This is a test quote”. The UpdateServiceQuote operation saves the newly assigned description and the service quote object’s other properties to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ServiceQuote serviceQuote;
            Policy serviceQuoteUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key object
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "SQTEST0100";

            // Retrieve the specified service quote object
            serviceQuote = wsDynamicsGP.GetServiceQuoteByKey(serviceDocumentKey, context);

            // Update the Description property
            serviceQuote.Description = "This is a test quote.";

            // Get the update policy for service quote
            serviceQuoteUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateServiceQuote", context);

            // Update the service quote information
            wsDynamicsGP.UpdateServiceQuote(serviceQuote, context, serviceQuoteUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ServiceDocumentKey serviceDocumentKey;
            ServiceQuote serviceQuote;
            Policy serviceQuoteUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a service document key object
            serviceDocumentKey = new ServiceDocumentKey();
            serviceDocumentKey.Id = "SQTEST0100";

            // Retrieve the specified service quote object
            serviceQuote = wsDynamicsGP.GetServiceQuoteByKey(serviceDocumentKey, context);

            // Update the Description property
            serviceQuote.Description = "This is a test quote.";

            // Get the update policy for service quote
            serviceQuoteUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateServiceQuote", context);

            // Update the service quote information
            wsDynamicsGP.UpdateServiceQuote(serviceQuote, context, serviceQuoteUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSkill

Description

Updates the specified skill object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | Skill | The skill object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example updates a skill object with the skill key ID value “New test skill”. The UpdateSkill operation adds compensation information to the specified skill object.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Skill skill;
            SkillKey skillKey;
            Compensation compensation;
            Policy skillUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Retrieve the specified skill object
            skill = wsDynamicsGP.GetSkillByKey(skillKey, context);

            // Create a compensation object
            compensation = new Compensation();
            compensation.CompensationAmount = 10;
            compensation.CompensationPeriod = CompensationPeriod.Hourly;

            // Add a compensation object to the skill
            skill.Compensation = compensation;

            // Get the update policy for  skill objects
            skillUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSkill", context);

            // Update the skill information
            wsDynamicsGP.UpdateSkill(skill, context, skillUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Skill skill;
            SkillKey skillKey;
            Compensation compensation;
            Policy skillUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill key
            skillKey = new SkillKey();
            skillKey.Id = "New test skill";

            // Retrieve the specified skill object
            skill = wsDynamicsGP.GetSkillByKey(skillKey, context);

            // Create a compensation object
            compensation = new Compensation();
            compensation.CompensationAmount = 10;
            compensation.CompensationPeriod = CompensationPeriod.Hourly;

            // Add a compensation object to the skill
            skill.Compensation = compensation;

            // Get the update policy for  skill objects
            skillUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateSkill", context);

            // Update the skill information
            wsDynamicsGP.UpdateSkill(skill, context, skillUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateSkillSet

Description

Updates the specified skill set object, storing the current values in the database.

Parameters

Parameter | Type | Description
businessObject | SkillSet | The skill set object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Human Resources/Payroll

Examples

The following C# example updates a skill set object with the skill set key ID value “New test skill set”. The UpdateSkillSet operation saves the change to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillSet skillSet;
            SkillSetKey skillSetKey;
            Policy skillSetUpdatePolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill set key
            skillSetKey = new SkillSetKey();
            skillSetKey.Id = "New test skill set";

            // Retrieve the specified skill set object
            skillSet = wsDynamicsGP.GetSkillSetByKey(skillSetKey, context);

            // Change one of the skills associated with the skill set
            SkillKey skillKey = new SkillKey();
            skillKey.Id = "test skills";
            Skill skill = wsDynamicsGP.GetSkillByKey(skillKey, context);
            skillSet.Skills[0] = skill;

            // Get the update policy for skill set objects
            skillSetUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "UpdateSkillset", context);

            // Update the skill set information
            wsDynamicsGP.UpdateSkillSet(skillSet, context, skillSetUpdatePolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SkillSet skillSet;
            SkillSetKey skillSetKey;
            Policy skillSetUpdatePolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a skill set key
            skillSetKey = new SkillSetKey();
            skillSetKey.Id = "New test skill set";

            // Retrieve the specified skill set object
            skillSet = wsDynamicsGP.GetSkillSetByKey(skillSetKey, context);

            // Change one of the skills associated with the skill set
            SkillKey skillKey = new SkillKey();
            skillKey.Id = "test skills";
            Skill skill = wsDynamicsGP.GetSkillByKey(skillKey, context);
            skillSet.Skills[0] = skill;

            // Get the update policy for skill set objects
            skillSetUpdatePolicy = wsDynamicsGP.GetPolicyByOperation(
                "UpdateSkillset", context);

            // Update the skill set information
            wsDynamicsGP.UpdateSkillSet(skillSet, context, skillSetUpdatePolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateVendor

Description

Updates the specified vendor object, storing the current values in the database.

Parameters

Parameter | Type | Description
vendor | Vendor | The vendor object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example updates the vendor name to “A Travel Company, Inc.” for the vendor with the key value “ACETRAVE0001”. The UpdateVendor operation saves the newly assigned name value to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorKey vendorKey;
            Vendor vendor;
            Policy vendorPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the vendor to be updated
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create the vendor object and set the value of the field to be updated
            vendor = new Vendor();
            vendor.Name = "A Travel Company, Inc.";
            vendor.Key = vendorKey;

            // Get the update policy for vendor
            vendorPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateVendor", context);

            // Update the vendor information
            wsDynamicsGP.UpdateVendor(vendor, context, vendorPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            VendorKey vendorKey;
            Vendor vendor;
            Policy vendorPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context object with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Specify the vendor to be updated
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create the vendor object and set the value of the field to be updated
            vendor = new Vendor();
            vendor.Name = "A Travel Company, Inc.";
            vendor.Key = vendorKey;

            // Get the update policy for vendor
            vendorPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateVendor", context);

            // Update the vendor information
            wsDynamicsGP.UpdateVendor(vendor, context, vendorPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


UpdateVendorAddress

Description

Updates the specified vendor address object, storing the current values in the database.

Parameters

Parameter | Type | Description
address | VendorAddress | The vendor address object that is being updated.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example updates the vendor address with the vendor address key value of “PRIMARY” and a vendor key value of “ACETRAVE0001”. The update sets the Line2 property to a value of “Suite 5A”. The UpdateVendorAddress operation saves the new address value to the database.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Policy vendorAddressPolicy;
            VendorKey vendorKey;
            VendorAddressKey vendorAddressKey;
            VendorAddress vendorAddress;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key object specifying the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create a vendor address key object specifying the vendor address to be updated
            vendorAddressKey = new VendorAddressKey();
            vendorAddressKey.VendorKey = vendorKey;
            vendorAddressKey.Id = "PRIMARY";

            // Create the vendor address object and set the Line2 property
            vendorAddress = new VendorAddress();
            vendorAddress.Key = vendorAddressKey;
            vendorAddress.Line2 = "Suite 5A";

            // Create the vendor address policy object
            vendorAddressPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateVendorAddress", context);

            // Update the vendor address
            wsDynamicsGP.UpdateVendorAddress(vendorAddress, context, vendorAddressPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Policy vendorAddressPolicy;
            VendorKey vendorKey;
            VendorAddressKey vendorAddressKey;
            VendorAddress vendorAddress;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key object specifying the vendor
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create a vendor address key object specifying the vendor address to be updated
            vendorAddressKey = new VendorAddressKey();
            vendorAddressKey.VendorKey = vendorKey;
            vendorAddressKey.Id = "PRIMARY";

            // Create the vendor address object and set the Line2 property
            vendorAddress = new VendorAddress();
            vendorAddress.Key = vendorAddressKey;
            vendorAddress.Line2 = "Suite 5A";

            // Create the vendor address policy object
            vendorAddressPolicy = wsDynamicsGP.GetPolicyByOperation("UpdateVendorAddress", context);

            // Update the vendor address
            wsDynamicsGP.UpdateVendorAddress(vendorAddress, context, vendorAddressPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidCashReceipt

Description

This method voids a cash receipt.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | A receivables document key object that specifies the cash receipt to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example voids the cash receipt with the receivables document key “PYMNT000000000167”. The VoidCashReceipt operation reverses the cash receipt but does not delete the document.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey cashReceiptKey;
            Policy cashReceiptVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the receivables document key to specify the cash receipt object
            cashReceiptKey = new ReceivablesDocumentKey();
            cashReceiptKey.Id = "PYMNT000000000167";

            // Get the void policy for cash receipts
            cashReceiptVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidCashReceipt", context);

            // Void the cash receipt
            wsDynamicsGP.VoidCashReceipt(cashReceiptKey, context, cashReceiptVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey cashReceiptKey;
            Policy cashReceiptVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the receivables document key to specify the cash receipt object
            cashReceiptKey = new ReceivablesDocumentKey();
            cashReceiptKey.Id = "PYMNT000000000167";

            // Get the void policy for cash receipts
            cashReceiptVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidCashReceipt", context);

            // Void the cash receipt
            wsDynamicsGP.VoidCashReceipt(cashReceiptKey, context, cashReceiptVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidPurchaseOrder

Description

This method voids a purchase order document.

Parameters

Parameter | Type | Description
key | PurchaseTransactionKey | A purchase transaction key object that specifies the purchase order to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Purchasing

Examples

The following C# example voids the purchase order with the purchase transaction key “PO2071”. VoidPurchaseOrder can be used with only purchase orders that have a status of “New”. The VoidPurchaseOrder operation either moves the purchase order to history or removes it from the system.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            Policy purchaseOrderVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key object to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO2071";

            // Get the void policy for purchase order objects
            purchaseOrderVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidPurchaseOrder", context);

            // Void the purchase order
            wsDynamicsGP.VoidPurchaseOrder(purchaseOrderKey, context, purchaseOrderVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            PurchaseTransactionKey purchaseOrderKey;
            Policy purchaseOrderVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a purchase transaction key object to specify the purchase order
            purchaseOrderKey = new PurchaseTransactionKey();
            purchaseOrderKey.Id = "PO2071";

            // Get the void policy for purchase order objects
            purchaseOrderVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidPurchaseOrder", context);

            // Void the purchase order
            wsDynamicsGP.VoidPurchaseOrder(purchaseOrderKey, context, purchaseOrderVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidReceivablesCreditMemo

Description

This method voids a receivables credit memo.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | A receivables document key object that specifies the receivables credit memo to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example voids the receivables credit memo with the receivables document key “CM6500”. This example uses the receivables credit memo created by the CreateReceivablesCreditMemo example. The VoidReceivableCreditMemo operation can only void the receivables credit memo after it has been posted. The VoidReceivablesCreditMemo removes the receivables credit memo but does not delete it.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey creditMemoKey;
            Policy receivablesCreditMemoVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the receivables document key to specify the receivables credit memo
            creditMemoKey = new ReceivablesDocumentKey();
            creditMemoKey.Id = "CM6500";

            // Get the void policy for receivables credit memo objects
            receivablesCreditMemoVoidPolicy = wsDynamicsGP.GetPolicyByOperation(
            "VoidReceivablesCreditMemo", context);

            // Void the receivables credit memo
            wsDynamicsGP.VoidReceivablesCreditMemo(creditMemoKey, context, receivablesCreditMemoVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey creditMemoKey;
            Policy receivablesCreditMemoVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create the receivables document key to specify the receivables credit memo
            creditMemoKey = new ReceivablesDocumentKey();
            creditMemoKey.Id = "CM6500";

            // Get the void policy for receivables credit memo objects
            receivablesCreditMemoVoidPolicy = wsDynamicsGP.GetPolicyByOperation(
            "VoidReceivablesCreditMemo", context);

            // Void the receivables credit memo
            wsDynamicsGP.VoidReceivablesCreditMemo(creditMemoKey, context, receivablesCreditMemoVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidReceivablesReturn

Description

This method voids a receivables return.

Parameters

Parameter | Type | Description
key | ReceivablesDocumentKey | A receivables document key object that specifies the receivables return to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example voids the receivables return with the receivables document key “TRN2550”. This example uses the receivables return created by the CreateReceivablesReturn example. The VoidReceivableReturn operation can only void the receivables return after it has been posted. The VoidReceivablesReturn removes the receivables return but does not delete it.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey receivablesReturnKey;
            Policy receivablesReturnVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key to specify the receivables return
            receivablesReturnKey = new ReceivablesDocumentKey();
            receivablesReturnKey.Id = "TRN2550";

            // Get the void policy for receivable return objects
            receivablesReturnVoidPolicy = wsDynamicsGP.GetPolicyByOperation(
            "VoidReceivablesReturn", context);

            // Void the specified receivables return
            wsDynamicsGP.VoidReceivablesReturn(receivablesReturnKey, context, receivablesReturnVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            ReceivablesDocumentKey receivablesReturnKey;
            Policy receivablesReturnVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a receivables document key to specify the receivables return
            receivablesReturnKey = new ReceivablesDocumentKey();
            receivablesReturnKey.Id = "TRN2550";

            // Get the void policy for receivable return objects
            receivablesReturnVoidPolicy = wsDynamicsGP.GetPolicyByOperation(
            "VoidReceivablesReturn", context);

            // Void the specified receivables return
            wsDynamicsGP.VoidReceivablesReturn(receivablesReturnKey, context, receivablesReturnVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidSalesBackorder

Description

This method voids a sales backorder.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | A sales document key object that specifies the sales backorder to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example voids the sales backorder with the sales document key “BKO1006”. The VoidSalesBackorder operation removes the sales backorder but does not delete it.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesBackorderKey;
            Policy salesBackorderVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesBackorderKey = new SalesDocumentKey();
            salesBackorderKey.Id = "BKO1006";

            // Get the void policy for sales backorder objects
            salesBackorderVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesBackorder", context);

            // Void the specified sales backorder
            wsDynamicsGP.VoidSalesBackorder(salesBackorderKey, context, salesBackorderVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesBackorderKey;
            Policy salesBackorderVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesBackorderKey = new SalesDocumentKey();
            salesBackorderKey.Id = "BKO1006";

            // Get the void policy for sales backorder objects
            salesBackorderVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesBackorder", context);

            // Void the specified sales backorder
            wsDynamicsGP.VoidSalesBackorder(salesBackorderKey, context, salesBackorderVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidSalesInvoice

Description

This method voids a sales invoice.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | A sales document key object that specifies the sales invoice to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example voids the sales invoice with the sales document key “STDINV2256”. The VoidSalesInvoice operation removes the unposted sales invoice but does not delete it.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesInvoiceKey;
            Policy salesInvoiceVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesInvoiceKey = new SalesDocumentKey();
            salesInvoiceKey.Id = "STDINV2256";

            // Get the void policy for sales invoices
            salesInvoiceVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesInvoice", context);

            // Void the specified sales invoice
            wsDynamicsGP.VoidSalesInvoice(salesInvoiceKey, context, salesInvoiceVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesInvoiceKey;
            Policy salesInvoiceVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesInvoiceKey = new SalesDocumentKey();
            salesInvoiceKey.Id = "STDINV2256";

            // Get the void policy for sales invoices
            salesInvoiceVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesInvoice", context);

            // Void the specified sales invoice
            wsDynamicsGP.VoidSalesInvoice(salesInvoiceKey, context, salesInvoiceVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidSalesOrder

Description

This method voids a sales order.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | A sales document key object that specifies the sales order to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example voids the sales order with the sales document key “ORDST2228”. The VoidSalesOrder operation removes the sales order but does not delete it.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesOrderKey;
            Policy salesOrderVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesOrderKey = new SalesDocumentKey();
            salesOrderKey.Id = "ORDST2228";

            // Get the void policy for sales orders
            salesOrderVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesOrder", context);

            // Void the specified sales order
            wsDynamicsGP.VoidSalesOrder(salesOrderKey, context, salesOrderVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesOrderKey;
            Policy salesOrderVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesOrderKey = new SalesDocumentKey();
            salesOrderKey.Id = "ORDST2228";

            // Get the void policy for sales orders
            salesOrderVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesOrder", context);

            // Void the specified sales order
            wsDynamicsGP.VoidSalesOrder(salesOrderKey, context, salesOrderVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidSalesQuote

Description

This method voids a sales quote.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | A sales document key object that specifies the sales quote to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example voids the sales quote with the key “QTEST1023”. The VoidSalesQuote operation removes the sales quote but does not delete it.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            Policy salesQuoteVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales quote
            documentKey = new SalesDocumentKey();
            documentKey.Id = "QTEST1023";

            // Get the void policy for sales quotes
            salesQuoteVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesQuote", context);

            // Void the specified sales quote
            wsDynamicsGP.VoidSalesQuote(documentKey, context, salesQuoteVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey documentKey;
            Policy salesQuoteVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key to specify the sales quote
            documentKey = new SalesDocumentKey();
            documentKey.Id = "QTEST1023";

            // Get the void policy for sales quotes
            salesQuoteVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesQuote", context);

            // Void the specified sales quote
            wsDynamicsGP.VoidSalesQuote(documentKey, context, salesQuoteVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


VoidSalesReturn

Description

This method voids a sales return.

Parameters

Parameter | Type | Description
key | SalesDocumentKey | A sales document key object that specifies the sales return to void.
context | Context | Specifies information about how the method will be called.
policy | Policy | Specifies the set of behaviors and behavior options to be applied during the operation.

Interfaces

  • Dynamics GP
  • Sales

Examples

The following C# example voids the sales return with the sales document key “STDINV2257”. The VoidSalesReturn operation removes the unposted sales return but does not delete it.

Legacy endpoint

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            Policy salesReturnVoidPolicy;

            // Create an instance of the service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Get the void policy for sales returns
            salesReturnVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesReturn", context);

            // Void the specified sales return
            wsDynamicsGP.VoidSalesReturn(salesReturnKey, context, salesReturnVoidPolicy);
        }
    }
}

Native endpoint

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            SalesDocumentKey salesReturnKey;
            Policy salesReturnVoidPolicy;

            // Create an instance of the service
            DynamicsGPClient wsDynamicsGP = new DynamicsGPClient();

            // Create a context with which to call the service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a sales document key
            salesReturnKey = new SalesDocumentKey();
            salesReturnKey.Id = "STDINV2257";

            // Get the void policy for sales returns
            salesReturnVoidPolicy = wsDynamicsGP.GetPolicyByOperation("VoidSalesReturn", context);

            // Void the specified sales return
            wsDynamicsGP.VoidSalesReturn(salesReturnKey, context, salesReturnVoidPolicy);

            // Close the service
            if(wsDynamicsGP.State != CommunicationState.Faulted)
            {
                wsDynamicsGP.Close();
            }
        }
    }
}


Class reference

The class reference provides details of each class in the Microsoft Dynamics GP service. The following is a list of the conventions are used in this documentation.

Each class has the following items:

  • The name of the class
  • A description of what the class represents in Microsoft Dynamics GP.
  • A list of the properties for the class. The properties are listed in the same order as in the SOAP message.
  • If applicable, the class directly inherited from.

Each property can have the following:

  • Name
  • Type
  • Maximum length (for string properties)
  • Default value
  • Description

All properties required for a create or update operation are listed in bold type.


Address

Description

A set of common address information in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CountryRegion | string | 60 | Empty | The country or region for the address.
Phone1 | PhoneNumber | N/A | Empty | Phone number 1 for the address.
Phone2 | PhoneNumber | N/A | Empty | Phone number 2 for the address.
Phone3 | PhoneNumber | N/A | Empty | Phone number 3 for the address.
Fax | PhoneNumber | N/A | Empty | Fax number for the address.

Inherits from

AddressBase


AddressBase

Description

The common properties for an address in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Line1 | string | 60 | Empty | Line 1 of the address.
Line2 | string | 60 | Empty | Line 2 of the address.
Line3 | string | 60 | Empty | Line 3 of the address.
City | string | 35 | Empty | The city for the address.
State | string | 29 | Empty | The state for the address.
PostalCode | string | 10 | Empty | The postal code for the address.

Inherits from

BusinessObject


AddressKey

Description

Uniquely identifies an address in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | Uniquely identifies the address.

Inherits from

ReferenceKey


AgingAmounts

Description

Provides receivables aging information for a customer.

Properties

Property | Type | Length | Default | Description
Period1Amount | MoneyAmount | N/A | 0 | The total value of recievables that are current.
Period2Amount | MoneyAmount | N/A | 0 | The total value of recievables in the first past due category.
Period3Amount | MoneyAmount | N/A | 0 | The total value of recievables in the second past due category.
Period4Amount | MoneyAmount | N/A | 0 | The total value of recievables in the third past due category.
Period5Amount | MoneyAmount | N/A | 0 | The total value of recievables in the fourth past due category.
Period6Amount | MoneyAmount | N/A | 0 | The total value of recievables in the fifth past due category.
Period7Amount | MoneyAmount | N/A | 0 | The total value of recievables in the last past due category.
LastAgedDate | dateTime | N/A | empty | Displays the date records were last aged for this customer.
BalanceAmount | MoneyAmount | N/A | 0 | Displays the total transaction amounts posted for all aging periods.


Amount

Description

Provides the underlying storage for instances of concrete “quantity” and “money amount” types that derive from it.

Properties

None


Applicant

Description

Defines a job applicant for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
IsDisabledVeteran | boolean | N/A | N/A | Specifies whether the applicant is a disabled verteran.
SequenceKey | SequenceKey | N/A | N/A | The SequenceKey object that uniquely identifies the line sequence number for the applicant.
Address | ApplicantAddress | N/A | N/A | An applicant address object the specifies the applicant address information.
TaxIdentifier | string | 15 | N/A | A string that specfies the tax identification number for the applicant.
FirstName | string | 15 | N/A | The first name of the applicant.
LastName | string | 20 | N/A | The last name of the applicant.
MiddleName | string | 15 | Empty | The middle name of the applicant.
DateApplied | dateTime | N/A | N/A | The date of the application.
HRRequisistionKey | HRRequisitionNumberKey | N/A | N/A | A key that uniquely specifies the requisition associated with the applicant.
CompanyCode | string | 5 | N/A | A string that specifies the company ID.
DivisionKey | DivisionKey | N/A | N/A | The DivisionKey object that uniquely identifies the division associated with the applicant.
DepartmentKey | DepartmentKey | N/A | N/A | The DepartmentKey object that uniquely identifies the department associated with the applicant.
PositionKey | PositionKey | N/A | N/A | The PositionKey object that uniquely identifies the position associated with the applicant.
Location | string | 15 | Empty | Specifies location information for the applicant.
ApplicationStatus | ApplicationStatus | N/A | 0 | An ApplicationStatus enumeration value that specifies the current status of the application.
RejectionInformation | ApplicationRejectionInformation | N/A | N/A | A RejectionInformation enumeration value that specifies the reason the applicant was rejected.
IsWillRelocate | boolean | N/A | N/A | Specifies whether the applicant requires relocation.
IsReplyLetterSent | boolean | N/A | N/A | Specifies whether a reply letter was sent to the applicant.
ApplicationColor | ApplicationColor | N/A | N/A | The ApplicationColor enumeration value that associates a color with the application.
ReferenceInformation | ApplicationReferenceInformation | N/A | N/A | An ApplicationReferenceInformation object that provides reference information for the applicant.
Gender | Gender | N/A | N/A | A Gender enumeration value that specifies the gender of the applicant.
Ethnicity | Ethnicity | N/A | N/A | An Ethnicity enumeration value that specifies the ethnic origin of the applicant.
IsDisabled | boolean | N/A | N/A | Specifies whether the applicant is disabled.
IsVeteran | boolean | N/A | N/A | Specifies whether the applicant is a military veteran.
IsVietnamEraVeteran | boolean | N/A | N/A | Specifies whether the applicant is a veteran of the the Vietnam war.
IsOtherVeteran | boolean | N/A | N/A | Specifies whether the applicant qualifies as a veteran.
AgeCode | AgeCode | N/A | N/A | An AgeCode enumeration value that specifies the age category of the applicant.
Applications | ArrayOfApplicantApplication | N/A | N/A | A collection of application information associated with the applicant.
Skills | ArrayOfApplicantSkill | N/A | N/A | A collection of job skill information associated with the applicant.
References | ArrayOfApplicantReference | N/A | N/A | A collection of job references for the applicant.
Schools | ArrayOfApplicantEducation | N/A | N/A | A collection of education information associated with the applicant.
Tests | ArrayOfApplicantTest | N/A | N/A | A collection of job test information associated with the applicant.
Interviews | ArrayOfApplicantInterview | N/A | N/A | A collection of interview information associated with the applicant.
PreviousEmployers | ArrayOfApplicantWorkHistory | N/A | N/A | A collection of work history information associated with the applicant.
ApplicantKey | ApplicantKey | N/A | N/A | A key that uniquely identifies the applicant.
LastModifiedBy | string | N/A | N/A | The user who last modified the transaction. This property is read-only.
LastModifiedDate | dateTime | N/A | N/A | The date the application was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.

Inherits from

BusinessObject


ApplicantAddress

Description

The address information for a job applicant.

Properties

Inherited from the base class

Inherits from

Address


ApplicantApplication

Description

Describes a job application for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CompanyCode | string | 5 | N/A | A string that specifies the company ID.
ApplicantApplicationKey | ApplicantSequenceKey | N/A | N/A | A key that uniquely identifies the applicant and sequence objects associated with the application.
RequisitionKey | HRRequisitionNumberKey | N/A | N/A | A key that uniquely identifies the job requisition associated with the application.
DivisionKey | DivisionKey | N/A | N/A | A key that uniquely identifies the division associated with the applciation.
DepartmentKey | DepartmentKey | N/A | N/A | A key that uniquely identifies the department associated with the application.
PositionKey | PositionKey | N/A | N/A | A key that specifies the position associated with the application.
DateApplied | dateTime | N/A | N/A | The date of the application.
Status | ApplicationStatus | N/A | N/A | An ApplicationStatus enumeration value that specifies the current status of the application.
Location | string | 15 | Empty | Location information associated with the application.
IsWillRelocate | boolean | N/A | N/A | Specifies whether relocation is needed.
IsReplyLetterSent | boolean | N/A | N/A | Specifies whether a reply letter was sent to the applicant.
LastModifiedBy | string | N/A | N/A | The user who last modified the transaction. This property is read-only.
LastModifiedDate | dateTime | N/A | N/A | The date the application was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
RejectionInfomation | ApplicationRejectionInformation | N/A | N/A | ApplicationRejectionInformation object that specifies the reason the application was rejected.
ReferenceInformation | ApplicationReferenceInformation | N/A | N/A | ApplicationReferenceInformation object that provides information about the origination of the application.
Color | ApplicationColor | N/A | N/A | An ApplicationColor object that associates an application color code with the application.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove the application.

Inherits from

BusinessObject


ApplicantApplicationCriteria

Description

Specifies the set of criteria to use when retrieving a list of applicant application summary objects. Only application sumamry objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
SequenceKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the sequence for the application.
ApplicantKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the applicant for the application.
RequisitionKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the requisition for the application.
DivisionKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the division for the application.
DepartmentKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the department for the application.
PositionKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the position for the application.
Status† | ListRestrictionOfNullableOfApplicationStatus | A list restriction specifying the status of the application.
DateApplied† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the application was created.

Inherits from

Criteria


ApplicantApplicationSummary

Description

A representation of the important details of a job application. The properties are read-only.

Properties

Property | Type | Length | Default | Description
CompanyCode | string | 5 | N/A | A string that specifies the company ID.
ApplicantApplicationKey | ApplicantSequenceKey | N/A | N/A | A key that uniquely identifies the applicant and sequence objects associated with the application.
RequisitionKey | HRRequisitionNumberKey | N/A | N/A | A key that uniquely identifies the job requisition associated with the application.
DivisionKey | DivisionKey | N/A | N/A | A key that uniquely identifies the division associated with the applciation.
DepartmentKey | DepartmentKey | N/A | N/A | A key that uniquely identifies the department associated with the application.
PositionKey | PositionKey | N/A | N/A | A key that specifies the position associated with the application.
DateApplied | dateTime | N/A | N/A | The date of the application.
Status | ApplicationStatus | N/A | N/A | An ApplicationStatus enumeration values that specifies the current status of the application.


ApplicantCriteria

Description

Specifies the set of criteria to use when retrieving a list of applicant summary objects. Only applicant sumary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
RequisitionKeyId | LikeRestrictionOfNullableOfInt32 | A key that uniquely identifies the job requisition associated with the application.
FirstName† | LikeRestrictionOfString | A string restriction specifying the first name of the applicant.
LastName† | LikeRestrictionOfString | A string restriction specifying the last name of the applicant.
PositionKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the position for the application.
DivisionKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the division for the application.
DepartmentKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the department for the application.
ApplicationStatus† | ListRestrictionOfNullableOfApplicationStatus | A list restriction specifying the status of the application for the applicant..
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date that applicant information was updated.
ApplicantKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the applicant for the application.

Inherits from

Criteria


ApplicantEducation

Description

Describes the educational background of a job applicant.

Properties

Property | Type | Length | Default | Description
ApplicantEducationKey | ApplicantSequenceKey | N/A | N/A | A key that uniquely identifies the applicant education object.
School | string | 15 | Empty | The university or school that the applicant graduated from.
Degree | string | 20 | Empty | The degree the applicant received from the specified school.
Major | string | 15 | Empty | The applicant’s major course of study while attending the specified school.
GradePointAverage | string | 5 | Empty | The grade point average for the applicant.
YearGraduated | string | 5 | Empty | The year the applicant graduated from school.
GPABase | string | 3 | Empty | The basis the school uses for calculating a grade point average.
Notes | string | 8000 | Empty | Notes about the applicant education information.
LastModifiedBy | string | N/A | N/A | The user who last modified the transaction. This property is read-only.
LastModifiedDate | dateTime | N/A | N/A | The date the application was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove applicant education information.

Inherits from

BusinessObject


ApplicantEducationCriteria

Description

Specifies the set of criteria to use when retrieving a list of applicant education objects. Only applicants with education information that matches the specified criteria will be returned. For the best performance, create criteria that use the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date that applicant information was updated.
SequenceKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the sequence for the application.
ApplicantKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the applicant for the application.
Degree† | LikeRestrictionOfString | A string restriction specifying the degree for an applicant.
School | LikeRestrictionOfString | A string restriction specifying the school for an applicant.
Major† | LikeRestrictionOfString | A string restriction specifying the major course of study for an applicant.
GradePointAverage† | LikeRestrictionOfString | A string restriction specifying the grade point average for an applicant.
YearGraduated | LikeRestrictionOfString | A string restriction specifying the year the applicant graduated from school.

Inherits from

Criteria


ApplicantInterview

Description

Provides interview information for a job applicant.

Properties

Property | Type | Length | Default | Description
CompanyCode | string | 5 | N/A | A string that specifies the company ID.
InterviewItems | ArrayOfApplicantInterviewItem | N/A | N/A | A collection of ApplicantInterviewItem objects that provide additional information about the interview.
ApplicantInterviewKey | ApplicantInterviewTypeKey | N/A | N/A | The key that uniquely identifies the applicant interview object.
EffectiveDate | dateTime | N/A | N/A | The date of the interview.
DepartmentKey | DepartmentKey | N/A | N/A | A key that uniquely identifies the department associated with the application.
DivisionKey | DivisionKey | N/A | N/A | A key that uniquely identifies the division associated with the applciation.
PositionKey | PositionKey | N/A | N/A | A key that specifies the position associated with the application.
ReviewRating | decimal | N/A | 0 | Specifies the score from the interview.
ReviewRange | int | N/A | N/A | Specifies the range associated with the rating.
WeightedScore | int | N/A | N/A | Specifies the weighted score from the interview.
TotalWeight | int | N/A | N/A | Specifies a weight value for the interview.
Notes | string | 8000 | Empty | Additional information associated with the interview.
InterviewTypeCode | int | N/A | N/A | Specifies the type of interview.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove applicant interview information.

Inherits from

BusinessObject


ApplicantInterviewCriteria

Description

Specifies the set of criteria to use when retrieving a list of applicant interview summary objects. Only applicant summary objects with interview information that matches the specified criteria will be returned. For the best performance, create criteria that use the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ApplicantKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the applicant for the application.
DepartmentKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the department for the application.
DivisionKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the division for the application.
PositionKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the position for the application.
DateApplied† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date that the applicant applied for a position.
InterviewDate† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date when the interview was completed.
InterviewTypeKeyId | LikeRestrictionOfString | A string restriction specifying the type of the interview that was completed.

Inherits from

Criteria


ApplicantInterviewItem

Description

Provides detailed information for an applicant interview.

Properties

Property | Type | Length | Default | Description
CategoryName | string | 15 | N/A | Specifies the category for the interview.
CategoryWeight | int | N/A | N/A | Specifies the weight associated with the interview.
Score | int | N/A | 0 | Specifies the interview score assigned to the applicant.
Notes | string | 8000 | Empty | Additional information associated with the interview.
SequenceKey | SequenceKey | N/A | N/A | The SequenceKey object that uniquely identifies the line sequence number for the applicant.
CategoryCode | int | N/A | N/A | A values that specifies the interview category.


ApplicantInterviewSummary

Description

A representation of the important details of a job interview. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ApplicantInterviewKey | ApplicantInterviewTypeKey | N/A | N/A | The key that uniquely identifies the applicant interview object.
EffectiveDate | dateTime | N/A | N/A | The date of the interview.
DepartmentKey | DepartmentKey | N/A | N/A | A key that uniquely identifies the department associated with the application.
DivisionKey | DivisionKey | N/A | N/A | A key that uniquely identifies the division associated with the applciation.
PositionKey | PositionKey | N/A | N/A | A key that specifies the position associated with the application.
ReviewRating | decimal | N/A | 0 | Specifies the score from the interview.
ReviewRange | int | N/A | N/A | Specifies the range associated with the rating.
WeightedScore | int | N/A | N/A | Specifies the weighted score from the interview.
TotalWeight | int | N/A | N/A | Specifies a weight value for the interview.


ApplicantInterviewTypeKey

Description

Uniquely identifies interview information associated with an applicant.

Properties

Property | Type | Length | Default | Description
ApplicantKey | ApplicantKey | N/A | N/A | The applicant key object that uniquely identifies the applicant.
InterviewTypeKey | InterviewTypeKey | N/A | N/A | The key that uniquely identifies the type of interview that was completed.
ApplyDateKey | ApplyDateKey | N/A | N/A | An ApplyDateKey object that identifies the date of the applicant interview.

Inherits from

ReferenceKey


ApplicantKey

Description

Uniquely identifies an applicant in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | int | N/A | N/A | A number that uniquely identifies the applicant.

Inherits from

ReferenceKey


ApplicantReference

Description

Provides job reference information for an applicant.

Properties

Property | Type | Length | Default | Description
ApplicantReferenceKey | ApplicantReferenceKey | N/A | N/A | The key that uniquely identifies the applicant reference object.
Relationship | string | 15 | Empty | A string that specifies the relationship between the reference and the applicant.
CompanyName | string | 64 | Empty | A string that specifies the name of the company for the reference.
Notes | string | 8000 | Empty | Additional information associated with the reference.
LastModifiedDate | dateTime | N/A | N/A | The date the application was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
LastModifiedBy | string | 15 | N/A | A string that specifies the namde of the user who last modified the transaction. This property is read-only.
Address | ApplicantAddress | N/A | N/A | Specifies address information for the reference.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove applicant interview information.

Inherits from

BusinessObject


ApplicantReferenceCriteria

Description

Specifies the set of criteria to use when retrieving a list of applicant reference summary objects. Only applicant reference summary objects with reference information that matches the specified criteria will be returned. For the best performance, create criteria that use the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ApplicantKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the applicant for the application.
ReferenceName | LikeRestrictionOfString | A string restriction specifying the name of the reference.
Relationship | LikeRestrictionOfString | A string restriction specifying the relationship between the reference and the applicant.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying when the reference information was last updated.
CompanyName | LikeRestrictionOfString | A string restriction specifying the name of the company for the reference.

Inherits from

Criteria


ApplicantReferenceKey

Description

Uniquely identifies a reference for a job applicant in Microsoft Dynamics GP

Properties

Property | Type | Length | Default | Description
ApplicantSequenceKey | ApplicantSequenceKey | NA | N/A | A key that uniquely identifies the applicant and sequence objects associated with the application.
Id | string | 21 | N/A | A string value that uniquely identifies the reference associated with the specified applicant.

Inherits from

ReferenceKey


ApplicantReferenceSummary

Description

A representation of the important details of a reference for a job applicant. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ApplicantReferenceKey | ApplicantReferenceKey | N/A | N/A | The key that uniquely identifies the applicant reference object.
Relationship | string | 15 | Empty | A string that specifies the relationship between the reference and the applicant.
CompanyName | string | 64 | Empty | A string that specifies the name of the company for the reference.
LastModifiedDate | dateTime | 15 | N/A | A string that specifies the name of the user who last modified the transaction. This property is read-only.


ApplicantSequenceKey

Description

Uniquely identifies the applicant and sequence information for a job application.

Properties

Property | Type | Length | Default | Description
ApplicantKey | ApplicantKey | N/A | N/A | The ApplicantKey object that uniquely identifies the applicant.
SequenceKey | SequenceKey | N/A | N/A | The SequenceKey object that uniquely identifies the line sequence number for the applicant.

Inherits from

ReferenceKey


ApplicantSkill

Description

Provides job skill information for an applicant.

Properties

Property | Type | Length | Default | Description
ApplicantSkillKey | ApplicantSkillKey | N/A | N/A | The key that uniquely identifies applicant skill information.
SkillNumber | int | N/A | N/A | A number that identifies the job skill.
Proficiency | int | N/A | 0 | Specifies the number of points. The points reflect the capabilities of the applicant for the specified job skill.
Comments | string | 20 | Empty | Additional information associated with the applicant and the specified skill.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove applicant skill information.

Inherits from

BusinessObject


ApplicantSkillCriteria

Description

Specifies the set of criteria to use when retrieving a list of applicant job skill objects. Only job skills object that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ApplicantKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the applicant for the application.
SkillKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the job skill for an applicant.
Proficiency† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the job skill proficiency for an applicant.

Inherits from

Criteria


ApplicantSkillKey

Description

Uniquely identifies job skill information for an applicant.

Properties

Property | Type | Length | Default | Description
ApplicantKey | ApplicantKey | N/A | N/A | The ApplicantKey object that uniquely identifies the applicant.
SkillKey | SkillKey | N/A | N/A | The SkillKey object that uniquely identifies a job skill.

Inherits from

ReferenceKey


ApplicantSummary

Description

A representation of the important details of a job applicant. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ApplicantKey | ApplicantKey | N/A | N/A | A key that uniquely identifies the applicant.
LastModifiedDate | dateTime | N/A | N/A | The date the application was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
FirstName | string | 15 | N/A | The first name of the applicant.
LastName | string | 20 | N/A | The last name of the applicant.
MiddleName | string | 15 | Empty | The middle name of the applicant.
TaxIdentifier | string | 15 | Empty | A string that specifies the tax identification number for the applicant.
DivisionKey | DivisionKey | N/A | N/A | The DivisionKey object that uniquely identifies the division associated with the applicant.
DepartmentKey | DepartmentKey | N/A | N/A | The DepartmentKey object that uniquely identifies the department associated with the applicant.
PositionKey | PositionKey | N/A | N/A | The PositionKey object that uniquely identifies the position associated with the applicant.
ApplicationStatus | ApplicationStatus | N/A | 0 | An ApplicationStatus enumeration value that specifies the current status of the application.
DateApplied | dateTime | N/A | N/A | The date of the application.
RequisitionKey | HRRequisitionNumberKey | N/A | N/A | A key that uniquely specifies the requisition associated with the applicant.


ApplicantTest

Description

Provides job test information for an applicant.

Properties

Property | Type | Length | Default | Description
LastModifiedDate | dateTime | N/A | N/A | The date the application was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
LastModifiedBy | string | 15 | N/A | A string that specifies the namde of the user who last modified the application. This property is read-only.
ApplicantTestKey | ApplicantTestKey | N/A | N/A | The ApplicantTestKey object that uniquely identifies the applicant test object.
TestDate | dateTime | N/A | Empty | Specifies the date the test was given to the applicant.
Score | string | 21 | Empty | Specifies the applicant score on the test.
Notes | string | 8000 | Empty | Specifies additional information associated with the test.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove applicant test information.

Inherits from

BusinessObject


ApplicantTestCriteria

Description

Specifies the set of criteria to use when retrieving a list of applicant job test objects. Only job test objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying when the test information was last updated.
TestCodeKeyId† | LikeRestrictionOfString | A string restriction that specifies the test code.
ApplicantKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the applicant for the application.
TestDate† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the test was completed.
Score† | LikeRestrictionOfString | A string restriction that specifies the test score.

Inherits from

Criteria


ApplicantTestKey

Description

Uniquely identifies job test information for an applicant.

Properties

Property | Type | Length | Default | Description
ApplicantSequenceKey | ApplicantSequenceKey | NA | N/A | A key that uniquely identifies the applicant and sequence objects associated with an application.
TestKey | TestKey | NA | N/A | A key that uniquely identifies a test object.

Inherits from

ReferenceKey


ApplicantWorkHistory

Description

Provides information about the prior work history of an applicant.

Properties

Property | Type | Length | Default | Description
ApplicantWorkHistoryKey | ApplicantWorkHistoryKey | N/A | N/A | A key that uniquely identifies a work history object for an applicant.
Wage | decimal | N/A | Empty | Specifies the applicant wage while working for the specified employer.
CompensationPeriod | CompensationPeriod | N/A | N/A | A CompensationPeriod enumeration value that specifies how the wage of the applicant was calculated.
PositionKey | PositionKey | N/A | N/A | The PositionKey object that identifies the position the applicant had with another employer.
StartDate | dateTime | N/A | N/A | Specifies the date the applicant started working for the specified employer.
EndDate | dateTime | N/A | N/A | Specifies the date the applicant stopped workfing for the specified employer.
YearsOfExperience | int | N/A | N/A | Specifies the number of years the applicant worked for the specified employer.
Notes | string | 8000 | Empty | Specifies additional information associated with the work history of the applicant.
LastModifiedBy | string | 15 | N/A | A string that specifies the namde of the user who last modified the application. This property is read-only.
LastModifiedDate | dateTime | N/A | N/A | The date the application was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove applicant work history information.

Inherits from

BusinessObject


ApplicantWorkHistoryCriteria

Description

Specifies the set of criteria to use when retrieving a list of applicant work history objects. Only work history objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying when the work history information was last updated.
ApplicantKeyId† | LikeRestrictionOfNullableOfInt32 | A restriction specifying the ID of the applicant for the application.
Employer | LikeRestrictionOfString | A string restriction specifying the name of a past employer.
Wage | BetweenRestrictionOfNullableOfDecimal | A restriciton that specifies a range of wages.
YearsOfExperience | BetweenRestrictionOfString | A restriction specifying a range of values to use for years of experience.

Inherits from

Criteria


ApplicantWorkHistoryKey

Description

Uniquely identifies work history information for an applicant.

Properties

Property | Type | Length | Default | Description
ApplicantSequenceKey | ApplicantSequenceKey | NA | N/A | A key that uniquely identifies the applicant and sequence objects associated with an application.
Id | string | 30 | N/A | A value that specifies the name of a previous employer.

Inherits from

ReferenceKey


ApplicationColor

Description

Provides a color category for an applicant. The color categories are used to flag and sort applicant records.

Properties

Property | Type | Length | Default | Description
ColorCode | ApplicationColorCode | N/A | N/A | An ApplicationColorCode enumeration value that specifies a color.
ColorName | string | 7 | Empty | Specifies the color name associated with the enumeration value.


ApplicationReferenceInformation

Description

Provides information that describes how the applicant learned about the job opening.

Properties

Property | Type | Length | Default | Description
Source | ApplicationReferenceSource | N/A | N/A | An ApplicationReferenceSource enumeration value specifying how the applicant learned of the job opportunity.
SourceDescription | string | 30 | Empty | Specifies additional information about how the applicant leard of the job opportunity.


ApplicationRejectionInformation

Description

Provides information that describes why the applicant was rejected.

Properties

Property | Type | Length | Default | Description
Comment | string | 30 | Empty | Specifies additional information about why the applicant was rejected.
Reason | ApplicationRejectionReason | N/A | N/A | An ApplicationRejectionReason enumeration value that specifies why the applicant was rejected.


ApplyDateKey

Description

Provides date and time information for specified events during the job application process.

Properties

Property | Type | Length | Default | Description
Id | dateTime | N/A | N/A | A date/time value specifying when an application event occurred.

Inherits from

ReferenceKey


ApprovalWorkflow

Description

An approval workflow in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
WorkflowName | string | N/A | N/A | Identifies the type of workflow. This property is read-only.
Status | ApprovalWorkflowStatus | N/A | N/A | The current status of an approval workflow. This property is read-only.

Inherits from

Workflow


ArrayOfApplicantApplication

Description

A collection of job application objects.

Properties

Property | Type | Length | Default | Description
ApplicantApplication | ApplicantApplication | N/A | N/A | A job application object in the collection.


ArrayOfApplicantApplicationSummary

Description

A collection of job application summary objects.

Properties

Property | Type | Length | Default | Description
ApplicantApplicationSummary | ApplicantApplicationSummary | N/A | N/A | A job application summary object in the collection.


ArrayOfApplicantEducation

Description

A collection of applicant education objects.

Properties

Property | Type | Length | Default | Description
ApplicantEducation | ApplicantEducation | N/A | N/A | An applicant education object in the collection.


ArrayOfApplicantInterview

Description

A collection of applicant interview objects.

Properties

Property | Type | Length | Default | Description
ApplicantInterview | ApplicantInterview | N/A | N/A | An applicant interview object in the collection.


ArrayOfApplicantInterviewItem

Description

A collection of applicant interview item objects

Properties

Property | Type | Length | Default | Description
ApplicantInterviewItem | ApplicantInterviewItem | N/A | N/A | An applicant interview item object in the collection.


ArrayOfApplicantInterviewSummary

Description

A collection of applicant interview summary objects.

Properties

Property | Type | Length | Default | Description
ApplicantInterviewSummary | ApplicantInterviewSummary | N/A | N/A | An application interview summary object in the collection.


ArrayOfApplicantReference

Description

A collection of applicant reference objects.

Properties

Property | Type | Length | Default | Description
ApplicantReference | ApplicantReference | N/A | N/A | An applicant reference object in the collection.


ArrayOfApplicantReferenceSummary

Description

A collection of applicant reference summary objects.

Properties

Property | Type | Length | Default | Description
ApplicantReferenceSummary | ApplicantReferenceSummary | N/A | N/A | An applicant reference summary object in the collection.


ArrayOfApplicantSkill

Description

A collection of applicant skill objects.

Properties

Property | Type | Length | Default | Description
ApplicantSkill | ApplicantSkill | N/A | N/A | An applicant skill object in the collection.


ArrayOfApplicantSummary

Description

A collection of applicant summary objects.

Properties

Property | Type | Length | Default | Description
ApplicantSummary | ApplicantSummary | N/A | N/A | An applicant summary object in the collection.


ArrayOfApplicantTest

Description

A collection of applicant test objects.

Properties

Property | Type | Length | Default | Description
ApplicantTest | ApplicantTest | N/A | N/A | An applicant test object in the collection.


ArrayOfApplicantWorkHistory

Description

A collection of applicant work history objects.

Properties

Property | Type | Length | Default | Description
ApplicantWorkHistory | ApplicantWorkHistory | N/A | N/A | An applicant work history object in the collection.


ArrayOfApplicationStatus

Description

An collection of application status objects.

Properties

Property | Type | Length | Default | Description
ApplicationStatus | ApplicationStatus | N/A | N/A | An application status object in the collection.


ArrayOfBackOfficeRole

Description

A collection of back office role objects.

Properties

Property | Type | Length | Default | Description
BackOfficeRole | BackOfficeRole | N/A | N/A | A back office role object in the collection.


ArrayOfBackOfficeRoleAssignment

Description

A collection of back office role assignment objects.

Properties

Property | Type | Length | Default | Description
BackOfficeRoleAssignment | BackOfficeRoleAssignment | N/A | N/A | A back office role assignment object in the collection.


ArrayOfBank

Description

A collection of bank objects.

Properties

Property | Type | Length | Default | Description
Bank | Bank | N/A | N/A | A bank object in the collection.


ArrayOfBatch

Description

A collection of batch objects.

Properties

Property | Type | Length | Default | Description
Batch | Batch | N/A | N/A | A batch object in the collection.


ArrayOfBehavior

Description

A collection of behavior objects for a policy.

Properties

Property | Type | Length | Default | Description
Behavior | Behavior | N/A | N/A | A behavior object in the collection.


ArrayOfBehaviorOption

Description

A collection of behavior option objects for a behavior.

Properties

Property | Type | Length | Default | Description
BehaviorOption | BehaviorOption | N/A | N/A | A behavior option object in the collection.


ArrayOfBusinessObjectSummary

Description

A collection of business object summary objects.

Properties

Property | Type | Length | Default | Description
BusinessObjectSummary | BusinessObjectSummary | N/A | N/A | A business object summary object in the collection.


ArrayOfBusinessObjectUserAssignment

Description

A collection of business object user assignment objects.

Properties

Property | Type | Length | Default | Description
BusinessObjectUserAssignment | BusinessObjectUserAssignment | N/A | N/A | A business object user assignment object in the collection.


ArrayOfCashReceiptDistribution

Description

A collection of cash receipt distribution objects.

Properties

Property | Type | Length | Default | Description
CashReceiptDistribution | CashReceiptDistribution | N/A | N/A | A cash receipt distribution object in the collection.


ArrayOfCashReceiptSummary

Description

A collection of cash receipt summary objects.

Properties

Property | Type | Length | Default | Description
CashReceiptSummary | CashReceiptSummary | N/A | N/A | A cash receipt summary object in the collection.


ArrayOfChangedCurrencyKey

Description

A collection of changed currency key objects.

Properties

Property | Type | Length | Default | Description
ChangedCurrencyKey | ChangedCurrencyKey | N/A | N/A | A changed currency key object in the collection.


ArrayOfChangedCustomerAddressKey

Description

A collection of changed customer address key objects.

Properties

Property | Type | Length | Default | Description
ChangedCustomerAddressKey | ChangedCustomerAddressKey | N/A | N/A | A changed customer address key object in the collection.


ArrayOfChangedCustomerKey

Description

A collection of changed customer key objects.

Properties

Property | Type | Length | Default | Description
ChangedCustomerKey | ChangedCustomerKey | N/A | N/A | A changed customer key object in the collection.


ArrayOfChangedInternetAddressKey

Description

A collection of changed Internet address key objects.

Properties

Property | Type | Length | Default | Description
ChangedInternetAddressKey | ChangedInternetAddressKey | N/A | N/A | A changed Internet address key object in the collection.


ArrayOfChangedItemKey

Description

A collection of changed item key objects.

Properties

Property | Type | Length | Default | Description
ChangedItemKey | ChangedItemKey | N/A | N/A | A changed item key object in the collection.


ArrayOfChangedPriceLevelKey

Description

A collection of changed price level key objects.

Properties

Property | Type | Length | Default | Description
ChangedPriceLevelKey | ChangedPriceLevelKey | N/A | N/A | A changed price level key object in the collection.


ArrayOfChangedPricingKey

Description

A collection of changed pricing key objects.

Properties

Property | Type | Length | Default | Description
ChangedPricingKey | ChangedPricingKey | N/A | N/A | A changed pricing key object in the collection.


ArrayOfChangedSalesInvoiceKey

Description

A collection of changed sales invoice key objects.

Properties

Property | Type | Length | Default | Description
ChangedSalesInvoiceKey | ChangedSalesInvoiceKey | N/A | N/A | A changed sales invoice key object in the collection.


ArrayOfChangedSalesOrderKey

Description

A collection of changed sales order key objects.

Properties

Property | Type | Length | Default | Description
ChangedSalesOrderKey | ChangedSalesOrderKey | N/A | N/A | A changed sales order key object in the collection.


ArrayOfChangedSalespersonKey

Description

A collection of changed salesperson key objects.

Properties

Property | Type | Length | Default | Description
ChangedSalespersonKey | ChangedSalespersonKey | N/A | N/A | A changed salesperson key object in the collection.


ArrayOfChangedShippingMethodKey

Description

A collection of changed shipping method key objects.

Properties

Property | Type | Length | Default | Description
ChangedShippingMethodKey | ChangedShippingMethodKey | N/A | N/A | A changed shipping method key object in the collection.


ArrayOfChangedTaxDetailKey

Description

A collection of changed tax detail key objects.

Properties

Property | Type | Length | Default | Description
ChangedTaxDetailKey | ChangedTaxDetailKey | N/A | N/A | A changed tax detail key object in the collection.


ArrayOfChangedTaxScheduleDetailKey

Description

A collection of changed tax schedule detail key objects.

Properties

Property | Type | Length | Default | Description
ChangedTaxScheduleDetailKey | ChangedTaxScheduleDetailKey | N/A | N/A | A changed tax schedule detail key object in the collection.


ArrayOfChangedUofMScheduleKey

Description

A collection of changed unit of measure schedule key objects.

Properties

Property | Type | Length | Default | Description
ChangedUofMScheduleKey | ChangedUofMScheduleKey | N/A | N/A | A changed unit of measure schedule key object in the collection.


ArrayOfCompany

Description

A collection of company objects.

Properties

Property | Type | Length | Default | Description
Company | Company | N/A | N/A | A company object in the collection.


ArrayOfCompanyAddress

Description

A collection of company address objects.

Properties

Property | Type | Length | Default | Description
CompanyAddress | CompanyAddress | N/A | N/A | A company address object in the collection.


ArrayOfCompensationPeriod

Description

A collection of compensation period objects.

Properties

Property | Type | Length | Default | Description
CompensationPeriod | CompensationPeriod | N/A | N/A | A compensation period object in the collection.


ArrayOfCorporateAccountMember

Description

A collection of corporate account member objects (customers) in a corporate (national) account.

Properties

Property | Type | Length | Default | Description
CorporateAccount Member | CorporateAccountMember | N/A | N/A | A corporate account member object in the collection.


ArrayOfCountryRegionCode

Description

A collection of country or region codes.

Properties

Property | Type | Length | Default | Description
CountryRegionCode | CountryRegionCode | N/A | N/A | A country or region code in the collection.


ArrayOfCurrency

Description

A collection of currency objects.

Properties

Property | Type | Length | Default | Description
Currency | Currency | N/A | N/A | A currency object in the collection.


ArrayOfCurrencyAccess

Description

A collection of currency access objects.

Properties

Property | Type | Length | Default | Description
CurrencyAccess | CurrencyAccess | N/A | N/A | A currency access object in the collection.


ArrayOfCurrencyPostingAccount

Description

A collection of currency posting account objects.

Properties

Property | Type | Length | Default | Description
CurrencyPostingAccount | CurrencyPostingAccount | N/A | N/A | A currency posting account object in the collection.


ArrayOfCustomerAddress

Description

A collection of customer address objects.

Properties

Property | Type | Length | Default | Description
CustomerAddress | CustomerAddress | N/A | N/A | A customer address object in the collection.


ArrayOfCustomerAddressSummary

Description

A collection of customer address summary objects.

Properties

Property | Type | Length | Default | Description
CustomerAddressSummary | CustomerAddressSummary | N/A | N/A | A customer address summary object in the collection.


ArrayOfCustomerReceivablesSummary

Description

A collection of customer receivables summary objects.

Properties

Property | Type | Length | Default | Description
CustomerReceivablesSummary | CustomerReceivablesSummary | N/A | N/A | A customer receivables summary object in the collection.


ArrayOfCustomerSummary

Description

A collection of customer summary objects.

Properties

Property | Type | Length | Default | Description
CustomerSummary | CustomerSummary | N/A | N/A | A customer summary object in the collection.


ArrayOfDateTime

Description

A collection of date/time values.

Properties

Property | Type | Length | Default | Description
dateTime | dateTime | N/A | N/A | A date/time value in the collection.


ArrayOfDecimal

Description

A collection of decimal values.

Properties

Property | Type | Length | Default | Description
decimal | decimal | N/A | N/A | A decimal value in the collection.


ArrayOfDynamicsOnlineConfiguration

Description

A collection of Dynamics Online Configuration objects.

Properties

Property | Type | Length | Default | Description
DynamicsOnlineConfiguration | DynamicsOnlineConfiguration | N/A | N/A | A Dynamics Online Configuration object in the collection.


ArrayOfEmployeeAddress

Description

A collection of employee addresses.

Properties

Property | Type | Length | Default | Description
EmployeeAddress | EmployeeAddress | N/A | N/A | An emloyee address in the collection.


ArrayOfEmployeeAddressSummary

Description

A collection of employee address summary objects.

Properties

Property | Type | Length | Default | Description
EmployeeAddressSummary | EmployeeAddressSummary | N/A | N/A | An employee address summary object in the collection.


ArrayOfEmployeePayCodeSummary

Description

A collection of employee pay code summary objects.

Properties

Property | Type | Length | Default | Description
EmployeePayCodeSummary | EmployeePayCodeSummary | N/A | N/A | An employee pay code summary object in the collection.


ArrayOfEmployeePayTypes

Description

A collection of employee pay type objects.

Properties

Property | Type | Length | Default | Description
EmployeePayTypes | EmployeePayTypes | N/A | N/A | An employee pay type object in the collection.


ArrayOfEmployeeSummary

Description

A collection of employee summary objects.

Properties

Property | Type | Length | Default | Description
EmployeeSummary | EmployeeSummary | N/A | N/A | An emloyee summary object in the collection.


ArrayOfFeeSummary

Description

A collection of fee summary objects.

Properties

Property | Type | Length | Default | Description
FeeSummary | FeeSummary | N/A | N/A | A fee summary object in the collection.


ArrayOfFeeType

Description

A collection of fee type objects.

Properties

Property | Type | Length | Default | Description
FeeType | FeeType | N/A | N/A | A fee type object in the collection.


ArrayOfGLAccountCategory

Description

A collection of GL account category objects.

Properties

Property | Type | Length | Default | Description
GLAccountCategory | GLAccountCategory | N/A | N/A | A GL account category object in the collection.


ArrayOfGLAccountCurrency

Description

A collection of GL account currency objects.

Properties

Property | Type | Length | Default | Description
GLAccountCurrency | GLAccountCurrency | N/A | N/A | A GL account currency object in the collection.


ArrayOfGLAccountFormat

Description

A collection of GL account format objects.

Properties

Property | Type | Length | Default | Description
GLAccountFormat | GLAccountFormat | N/A | N/A | A GL account format object in the collection.


ArrayOfGLAccountSummary

Description

A collection of GL account summary objects.

Properties

Property | Type | Length | Default | Description
GLAccountSummary | GLAccountSummary | N/A | N/A | A GL account summary object in the collection.


ArrayOfGLAccountSummaryType

Description

A collection of GL account summary type objects.

Properties

Property | Type | Length | Default | Description
GLAccountSummaryType | GLAccountSummaryType | N/A | N/A | A GL account summary type object in the collection.


ArrayOfGLFixedAllocationAccountSummary

Description

A collection of GL fixed allocation account summary objects.

Properties

Property | Type | Length | Default | Description
GLFixedAllocationAccountSummary | GLFixedAllocationAccountSummary | N/A | N/A | A GL fixed allocation account summary object in the collection.


ArrayOfGLFixedAllocationDistributionAccount

Description

A collection of GL fixed allocation distribution account objects.

Properties

Property | Type | Length | Default | Description
GLFixedAllocationDistributionAccount | GLFixedAllocationDistributionAccount | N/A | N/A | A GL fixed allocation distribution account object in the collection.


ArrayOfGLLedgerType

Description

A collection of GL ledger type objects.

Properties

Property | Type | Length | Default | Description
GLLedgerType | GLLedgerType | N/A | N/A | A GL ledger type object in the collection.


ArrayOfGLPostingAccountSummary

Description

A collection of GL posting account summary objects.

Properties

Property | Type | Length | Default | Description
GLPostingAccountSummary | GLPostingAccountSummary | N/A | N/A | A GL posting account summary object in the collection.


ArrayOfGLTransactionLine

Description

A collection of GL transaction line objects.

Properties

Property | Type | Length | Default | Description
GLTransactionLine | GLTransactionLine | N/A | N/A | A GL transaction line object in the collection.


ArrayOfGLTransactionState

Description

A collection of GL transaction state objects.

Properties

Property | Type | Length | Default | Description
GLTransactionState | GLTransactionState | N/A | N/A | A GL transaction state object in the collection.


ArrayOfGLTransactionSummary

Description

A collection of GL transaction summary objects.

Properties

Property | Type | Length | Default | Description
GLTransactionSummary | GLTransactionSummary | N/A | N/A | A GL transaction summary object in the collection.


ArrayOfGLUnitAccountSummary

Description

A collection of GL unit account summary objects.

Properties

Property | Type | Length | Default | Description
GLUnitAccountSummary | GLUnitAccountSummary | N/A | N/A | A GL unit account summary object in the collection.


ArrayOfGLVariableAllocationAccountSummary

Description

A collection of GL variable allocation account summary objects.

Properties

Property | Type | Length | Default | Description
GLVariableAllocationAccountSummary | GLVariableAllocationAccountSummary | N/A | N/A | A GL variable allocation account summary object in the collection.


ArrayOfGLVariableAllocationBreakdownAccount

Description

A collection of GL variable allocation breakdown account objects.

Properties

Property | Type | Length | Default | Description
GLVariableAllocationBreakdownAccount | GLVariableAllocationBreakdownAccount | N/A | N/A | A GL variable allocation breakdown account object in the collection.


ArrayOfGLVariableAllocationDistributionAccount

Description

A collection of GL variable allocation distribution account objects.

Properties

Property | Type | Length | Default | Description
GLVariableAllocationDistributionAccount | GLVariableAllocationDistributionAccount | N/A | N/A | A GL variable allocation distribution account object in the collection.


ArrayOfHRRequisitionStatus

Description

A collection of HR requisition status objects.

Properties

Property | Type | Length | Default | Description
HRRequisitionStatus | HRRequisitionStatus | N/A | N/A | An HR requisition status object in the collection.


ArrayOfHRRequisitionSummary

Description

A collection of HR requisition summary objects.

Properties

Property | Type | Length | Default | Description
HRRequisitionSummary | HRRequisitionSummary | N/A | N/A | An HR requisition summary object in the collection.


ArrayOfInt

Description

A collection of integer values.

Properties

Property | Type | Length | Default | Description
int | int | N/A | N/A | An integer value in the collection.


ArrayOfInventoriedItemSummary

Description

A collection of inventoried item summary objects.

Properties

Property | Type | Length | Default | Description
InventoriedItemSummary | InventoriedItemSummary | N/A | N/A | An inventoried item summary object in the collection.


ArrayOfInventoriedItemType

Description

A collection of inventoried item type objects.

Properties

Property | Type | Length | Default | Description
InventoriedItemType | InventoriedItemType | N/A | N/A | An inventoried item type object in the collection.


ArrayOfInventoryAdjustmentLine

Description

A collection of inventory adjustment line objects.

Properties

Property | Type | Length | Default | Description
InventoryAdjustmentLine | InventoryAdjustmentLine | N/A | N/A | An inventory adjustment line object in the collection.


ArrayOfInventoryAdjustmentSummary

Description

A collection of inventory adjustment summary objects.

Properties

Property | Type | Length | Default | Description
InventoryAdjustmentSummary | InventoryAdjustmentSummary | N/A | N/A | An inventory adjustment summary object in the collection.


ArrayOfInventoryBin

Description

A collection of inventory bin objects.

Properties

Property | Type | Length | Default | Description
InventoryBin | InventoryBin | N/A | N/A | An inventory bin object in the collection.


ArrayOfInventoryLot

Description

A collection of inventory lot objects.

Properties

Property | Type | Length | Default | Description
InventoryLot | InventoryLot | N/A | N/A | An inventory lot object in the collection.


ArrayOfInventorySerial

Description

A collection of inventory serial objects.

Properties

Property | Type | Length | Default | Description
InventorySerial | InventorySerial | N/A | N/A | An inventory serial object in the collection.


ArrayOfInventoryTransactionState

Description

A collection of inventory transaction state objects.

Properties

Property | Type | Length | Default | Description
InventoryTransactionState | InventoryTransactionState | N/A | N/A | An inventory transaction state object in the collection.


ArrayOfInventoryTransferBin

Description

A collection of inventory transfer bin objects.

Properties

Property | Type | Length | Default | Description
InventoryTransferBin | InventoryTransferBin | N/A | N/A | An inventory transfer bin object in the collection.


ArrayOfInventoryTransferLine

Description

A collection of inventory transfer line objects.

Properties

Property | Type | Length | Default | Description
InventoryTransferLine | InventoryTransferLine | N/A | N/A | An inventory transfer line object in the collection.


ArrayOfInventoryTransferLot

Description

A collection of inventory transfer lot objects.

Properties

Property | Type | Length | Default | Description
InventoryTransferLot | InventoryTransferLot | N/A | N/A | An inventory transfer lot object in the collection.


ArrayOfInventoryTransferSerial

Description

A collection of inventory transfer serial objects.

Properties

Property | Type | Length | Default | Description
InventoryTransferSerial | InventoryTransferSerial | N/A | N/A | An inventory transfer serial object in the collection.


ArrayOfInventoryTransferSummary

Description

A collection of inventory transfer summary objects.

Properties

Property | Type | Length | Default | Description
InventoryTransferSummary | InventoryTransferSummary | N/A | N/A | An inventory transfer summary object in the collection.


ArrayOfInventoryVarianceLine

Description

A collection of inventory variance line objects.

Properties

Property | Type | Length | Default | Description
InventoryVarianceLine | InventoryVarianceLine | N/A | N/A | An inventory variance line object in the collection.


ArrayOfInventoryVarianceSummary

Description

A collection of inventory variance summary objects.

Properties

Property | Type | Length | Default | Description
InventoryVariance Summary | InventoryVarianceSummary | N/A | N/A | An inventory variance summary object in the collection.


ArrayOfItemClass

Description

A collection of item class objects.

Properties

Property | Type | Length | Default | Description
ItemClass | ItemClass | N/A | N/A | An item class object in the collection.


ArrayOfItemCurrency

Description

A collection of item currency objects.

Properties

Property | Type | Length | Default | Description
ItemCurrency | ItemCurrency | N/A | N/A | An item currency object in the collection.


ArrayOfItemSummary

Description

A collection of item summary objects.

Properties

Property | Type | Length | Default | Description
ItemSummary | ItemSummary | N/A | N/A | An item summary object in the collection.


ArrayOfItemType

Description

A collection of item type objects.

Properties

Property | Type | Length | Default | Description
ItemType | ItemType | N/A | N/A | An item type object in the collection.


ArrayOfItemVendorSummary

Description

A collection of item vendor summary objects.

Properties

Property | Type | Length | Default | Description
ItemVendorSummary | ItemVendorSummary | N/A | N/A | An item vendor summary object in the collection.


ArrayOfItemWarehouseSummary

Description

A collection of item warehouse summary objects.

Properties

Property | Type | Length | Default | Description
ItemWarehouseSummary | ItemWarehouseSummary | N/A | N/A | An item warehouse summary object in the collection.


ArrayOfKitComponent

Description

A collection of kit component objects.

Properties

Property | Type | Length | Default | Description
KitComponent | KitComponent | N/A | N/A | A kit component object in the collection.


ArrayOfLoggedExceptionDataSummary

Description

A collection of logged exception data summary objects.

Properties

Property | Type | Length | Default | Description
LoggedExceptionDataSummary | LoggedExceptionDataSummary | N/A | N/A | A logged exception data summary object in the collection.


ArrayOfManufacturingOrderOutSourced

Description

A collection of manufacturing order outsourced objects.

Properties

Property | Type | Length | Default | Description
ManufacturingOrderOutSourced | ManufacturingOrderOutSourced | N/A | N/A | A manufacturing order outsourced object in the collection.


ArrayOfManufacturingOrderPickListItem

Description

A collection of manufacturing order pick list item obects.

Properties

Property | Type | Length | Default | Description
ManufacturingOrderPickListItem | ManufacturingOrderPickListItem | N/A | N/A | A manufacturing order pick list item object in the collection.


ArrayOfManufacturingOrderPriority

Description

A collection of manufacturing order priority objects.

Properties

Property | Type | Length | Default | Description
ManufacturingOrderPriority | ManufacturingOrderPriority | N/A | N/A | A manufacturing order priority object in the collection.


ArrayOfManufacturingOrderRouteStep

Description

A collection of manufacturing order route step objects.

Properties

Property | Type | Length | Default | Description
ManufacturingOrderRouteStep | ManufacturingOrderRouteStep | N/A | N/A | A manufacturing order route step object in the collection.


ArrayOfManufacturingOrderStatus

Description

A collection of manufacturing order status objects.

Properties

Property | Type | Length | Default | Description
ManufacturingOrderStatus | ManufacturingOrderStatus | N/A | N/A | A manufacturing order status object in the collection.


ArrayOfManufacturingOrderSummary

Description

A collection of manufacturing order summary objects.

Properties

Property | Type | Length | Default | Description
ManufacturingOrderSummary | ManufacturingOrderSummary | N/A | N/A | A manufacturing order summary object in the collection.


ArrayOfMulticurrencySetup

Description

A collection of multicurrency setup objects.

Properties

Property | Type | Length | Default | Description
MulticurrencySetup | MulticurrencySetup | N/A | N/A | A multicurrency setup object in the collection.


ArrayOfParameter

Description

A collection of parameter objects.

Properties

Property | Type | Length | Default | Description
Parameter | Parameter | N/A | N/A | A parameter object in the collection.


ArrayOfPayablesCreditMemoSummary

Description

A collection of payables credit memo summary objects.

Properties

Property | Type | Length | Default | Description
PayablesCreditMemoSummary | PayablesCreditMemoSummary | N/A | N/A | A payables credit memo summary object in the collection.


ArrayOfPayablesDistribution

Description

A collection of payables distribution objects.

Properties

Property | Type | Length | Default | Description
PayablesDistribution | PayablesDistribution | N/A | N/A | A payables distribution object in the collection.


ArrayOfPayablesDocumentSummary

Description

A collection of payables document summary objects.

Properties

Property | Type | Length | Default | Description
PayablesDocument Summary | PayablesDocumentSummary | N/A | N/A | A payables document summary object in the collection.


ArrayOfPayablesDocumentType

Description

A collection of payables document type objects.

Properties

Property | Type | Length | Default | Description
PayablesDocumentType | PayablesDocumentType | N/A | N/A | A payables document type object in the collection.


ArrayOfPayablesFinanceChargeSummary

Description

A collection of payables finance charge summary objects.

Properties

Property | Type | Length | Default | Description
PayablesFinanceCharge Summary | PayablesFinanceChargeSummary | N/A | N/A | A payables finance charge summary object in the collection.


ArrayOfPayablesInvoiceSummary

Description

A collection of payables invoice summary objects.

Properties

Property | Type | Length | Default | Description
PayablesInvoiceSummary | PayablesInvoiceSummary | N/A | N/A | A payables invoice summary object in the collection.


ArrayOfPayablesMiscellaneousChargeSummary

Description

A collection of payables miscellaneous charge summary objects.

Properties

Property | Type | Length | Default | Description
PayablesMiscellaneous ChargeSummary | PayablesMiscellaneousChargeSummary | N/A | N/A | A payables miscellaneous charge summary object in the collection.


ArrayOfPayablesReturnSummary

Description

A collection of payables return summary objects.

Properties

Property | Type | Length | Default | Description
PayablesReturnSummary | PayablesReturnSummary | N/A | N/A | A payables return summary object in the collection.


ArrayOfPayablesTax

Description

A collection of payables tax objects.

Properties

Property | Type | Length | Default | Description
PayablesTax | PayablesTax | N/A | N/A | A payables tax object in the collection.


ArrayOfPayablesTransactionState

Description

A collection of payables transaction state objects.

Properties

Property | Type | Length | Default | Description
PayablesTransactionState | PayablesTransactionState | N/A | N/A | A payables transaction state object in the collection.


ArrayOfPaymentCardType

Description

A collection of payment card type objects.

Properties

Property | Type | Length | Default | Description
PaymentCardType | PaymentCardType | N/A | N/A | A payment card type object in the collection.


ArrayOfPaymentTerms

Description

A collection of payment terms objects.

Properties

Property | Type | Length | Default | Description
PaymentTerms | PaymentTerms | N/A | N/A | A payment terms object in the collection.


ArrayOfPhoneNumber

Description

A collection of phone number objects.

Properties

Property | Type | Length | Default | Description
PhoneNumber | PhoneNumber | N/A | N/A | A phone number object in the collection.


ArrayOfPlannedOrderItem

Description

A collection of planned order item objects.

Properties

Property | Type | Length | Default | Description
PlannedOrderItem | PlannedOrderItem | N/A | N/A | A planned order item object in the collection.


ArrayOfPlannedOrderReplenishment

Description

A collection of planned order replenishment objects.

Properties

Property | Type | Length | Default | Description
PlannedOrderReplenishment | PlannedOrderReplenishment | N/A | N/A | A planned order replenishment object in the collection.


ArrayOfPlannedOrderSummary

Description

A collection of planned order summary objects.

Properties

Property | Type | Length | Default | Description
PlannedOrderSummary | PlannedOrderSummary | N/A | N/A | A planned order summary object in the collection.


ArrayOfPolicySummary

Description

A collection of policy summary objects.

Properties

Property | Type | Length | Default | Description
PolicySummary | PolicySummary | N/A | N/A | A policy summary object in the collection.


ArrayOfPostedPayablesVendorPaymentSummary

Description

A collection of posted payables vendor payment summary objects.

Properties

Property | Type | Length | Default | Description
PostedPayablesVendorPaymentSummary | PostedPayablesVendorPaymentSummary | N/A | N/A | A posted payables vendor payment summary object in the collection.


ArrayOfPriceLevel

Description

A collection of price level objects.

Properties

Property | Type | Length | Default | Description
PriceLevel | PriceLevel | N/A | N/A | A price level object in the collection.


ArrayOfPricingDetail

Description

A collection of pricing detail objects.

Properties

Property | Type | Length | Default | Description
PricingDetail | PricingDetail | N/A | N/A | A pricing detail object in the collection.


ArrayOfPricingSummary

Description

A collection of pricing summary objects.

Properties

Property | Type | Length | Default | Description
PricingSummary | PricingSummary | N/A | N/A | A pricing summary object in the collection.


ArrayOfProjectAccountType

Description

A collection of project account type objects.

Properties

Property | Type | Length | Default | Description
ProjectAccountType | ProjectAccountType | N/A | N/A | A project account type object in the collection.


ArrayOfProjectBillingCycle

Description

A collection of project billing cycle objects.

Properties

Property | Type | Length | Default | Description
ProjectBillingCycle | ProjectBillingCycle | N/A | N/A | A project billing cycle object in the collection.


ArrayOfProjectBudget

Description

A collection of project budget objects.

Properties

Property | Type | Length | Default | Description
ProjectBudget | ProjectBudget | N/A | N/A | A project budget object in the collection.


ArrayOfProjectBudgetSummary

Description

A collection of project budget summary objects.

Properties

Property | Type | Length | Default | Description
ProjectBudgetSummary | ProjectBudgetSummary | N/A | N/A | A project budget summary object in the collection.


ArrayOfProjectChangeOrderBudget

Description

A collection of project change order budget objects.

Properties

Property | Type | Length | Default | Description
ProjectChangeOrder Budget | ProjectChangeOrderBudget | N/A | N/A | A project change order budget object in the collection.


ArrayOfProjectChangeOrderFee

Description

A collection of project change order fee objects.

Properties

Property | Type | Length | Default | Description
ProjectChangeOrderFee | ProjectChangeOrderFee | N/A | N/A | A project change order fee object in the collection.


ArrayOfProjectChangeOrderFeeLine

Description

A collection of project change order fee line objects.

Properties

Property | Type | Length | Default | Description
ProjectChangeOrderFee Line | ProjectChangeOrderFeeLine | N/A | N/A | A project change order fee line object in the collection.


ArrayOfProjectChangeOrderFeeLineSchedule

Description

A collection of project change order fee line schedule objects.

Properties

Property | Type | Length | Default | Description
ProjectChangeOrderFee LineSchedule | ProjectChangeOrderFeeLineSchedule | N/A | N/A | A project change order fee line schedule object in the collection.


ArrayOfProjectChangeOrderSummary

Description

A collection of project change order summary objects.

Properties

Property | Type | Length | Default | Description
ProjectChangeOrder Summary | ProjectChangeOrderSummary | N/A | N/A | A project change order summary object in the collection.


ArrayOfProjectContractAccountType

Description

A collection of project contract account type objects.

Properties

Property | Type | Length | Default | Description
ProjectContractAccount Type | ProjectContractAccountType | N/A | N/A | A project contract account type object in the collection.


ArrayOfProjectContractBillingCycle

Description

A collection of project contract billing cycle objects.

Properties

Property | Type | Length | Default | Description
ProjectContractBilling Cycle | ProjectContractBillingCycle | N/A | N/A | A project contract billing cycle object in the collection.


ArrayOfProjectContractSummary

Description

A collection of project contract summary objects.

Properties

Property | Type | Length | Default | Description
ProjectContractSummary | ProjectContractSummary | N/A | N/A | A project contract summary object in the collection.


ArrayOfProjectEmployeeExpenseDistribution

Description

A collection of project employee expense distribution objects.

Properties

Property | Type | Length | Default | Description
ProjectEmployeeExpense Distribution | ProjectEmployeeExpenseDistribution | N/A | N/A | A project employee expense distribution object in the collection.


ArrayOfProjectEmployeeExpenseLine

Description

A collection of project employee expense line objects.

Properties

Property | Type | Length | Default | Description
ProjectEmployeeExpense Line | ProjectEmployeeExpenseLine | N/A | N/A | A project employee expense line object in the collection.


ArrayOfProjectEmployeeExpenseLineTax

Description

A collection of project employee expense line tax objects.

Properties

Property | Type | Length | Default | Description
ProjectEmployeeExpense LineTax | ProjectEmployeeExpenseLineTax | N/A | N/A | A project employee expense line tax object in the collection.


ArrayOfProjectEmployeeExpenseSummary

Description

A collection of project employee expense summary objects.

Properties

Property | Type | Length | Default | Description
ProjectEmployeeExpense Summary | ProjectEmployeeExpenseSummary | N/A | N/A | A project employee expense summary object in the collection.


ArrayOfProjectEquipmentItem

Description

A collection of project equipment item objects.

Properties

Property | Type | Length | Default | Description
ProjectEquipmentItem | ProjectEquipmentItem | N/A | N/A | A project equipment item object in the collection.


ArrayOfProjectFee

Description

A collection of project fee objects.

Properties

Property | Type | Length | Default | Description
ProjectFee | ProjectFee | N/A | N/A | A project fee object in the collection.


ArrayOfProjectFeeSchedule

Description

A collection of project fee schedule objects.

Properties

Property | Type | Length | Default | Description
ProjectFeeSchedule | ProjectFeeSchedule | N/A | N/A | A project fee schedule object in the collection.


ArrayOfProjectMiscellaneousLogDistribution

Description

A collection of project miscellaneous log distribution objects.

Properties

Property | Type | Length | Default | Description
ProjectMiscellaneousLog Distribution | ProjectMiscellaneousLogDistribution | N/A | N/A | A project miscellaneous log distribution object in the collection.


ArrayOfProjectMiscellaneousLogLine

Description

A collection of project miscellaneous log line objects.

Properties

Property | Type | Length | Default | Description
ProjectMiscellaneousLog Line | ProjectMiscellaneousLogLine | N/A | N/A | A project miscellaneous log line object in the collection.


ArrayOfProjectMiscellaneousLogSummary

Description

A collection of project miscellaneous log summary objects.

Properties

Property | Type | Length | Default | Description
ProjectMiscellaneousLog Summary | ProjectMiscellaneousLogSummary | N/A | N/A | A project miscellaneous log summary object in the collection.


ArrayOfProjectSummary

Description

A collection of project summary objects.

Properties

Property | Type | Length | Default | Description
ProjectSummary | ProjectSummary | N/A | N/A | A project summary object in the collection.


ArrayOfProjectTimesheetDistribution

Description

A collection of project timesheet distribution objects.

Properties

Property | Type | Length | Default | Description
ProjectTimesheet Distribution | ProjectTimesheetDistribution | N/A | N/A | A project timesheet distribution object in the collection.


ArrayOfProjectTimesheetLine

Description

A collection of project timesheet line objects.

Properties

Property | Type | Length | Default | Description
ProjectTimesheetLine | ProjectTimesheetLine | N/A | N/A | A project timesheet line object in the collection.


ArrayOfProjectTimesheetSummary

Description

A collection of project timesheet summary objects.

Properties

Property | Type | Length | Default | Description
ProjectTimesheet Summary | ProjectTimesheetSummary | N/A | N/A | A project timesheet summary object in the collection.


ArrayOfProjectTransactionState

Description

A collection of project transaction state objects.

Properties

Property | Type | Length | Default | Description
ProjectTransactionState | ProjectTransactionState | N/A | N/A | A project transaction state object in the collection.


ArrayOfPurchaseBinDetail

Description

A collection of purchase bin detail objects.

Properties

Property | Type | Length | Default | Description
PurchaseBinDetail | PurchaseBinDetail | N/A | N/A | A purchase bin detail object in the collection.


ArrayOfPurchaseDistribution

Description

A collection of purchase distribution objects.

Properties

Property | Type | Length | Default | Description
PurchaseDistribution | PurchaseDistribution | N/A | N/A | A purchase distribution object in the collection.


ArrayOfPurchaseInvoiceApplyReceipt

Description

A collection of purchase invoice apply receipt objects.

Properties

Property | Type | Length | Default | Description
PurchaseInvoiceApply Receipt | PurchaseInvoiceApplyReceipt | N/A | N/A | A purchase invoice apply receipt object in the collection.


ArrayOfPurchaseInvoiceLine

Description

A collection of purchase invoice line objects.

Properties

Property | Type | Length | Default | Description
PurchaseInvoiceLine | PurchaseInvoiceLine | N/A | N/A | A purchase invoice line object in the collection.


ArrayOfPurchaseInvoiceSummary

Description

A collection of purchase invoice summary objects.

Properties

Property | Type | Length | Default | Description
PurchaseInvoiceSummary | PurchaseInvoiceSummary | N/A | N/A | A purchase invoice summary object in the collection.


ArrayOfPurchaseInvoiceTax

Description

A collection of purchase invoice tax objects.

Properties

Property | Type | Length | Default | Description
PurchaseInvoiceTax | PurchaseInvoiceTax | N/A | N/A | A purchase invoice tax object in the collection.


ArrayOfPurchaseLotDetail

Description

A collection of purchase lot detail objects.

Properties

Property | Type | Length | Default | Description
PurchaseLotDetail | PurchaseLotDetail | N/A | N/A | A purchase lot detail object in the collection.


ArrayOfPurchaseOrderLine

Description

A collection of purchase order line objects.

Properties

Property | Type | Length | Default | Description
PurchaseOrderLine | PurchaseOrderLine | N/A | N/A | A purchase order line object in the collection.


ArrayOfPurchaseOrderStatus

Description

A collection of purchase order status objects.

Properties

Property | Type | Length | Default | Description
PurchaseOrderStatus | PurchaseOrderStatus | N/A | N/A | A purchase order status object in the collection.


ArrayOfPurchaseOrderSummary

Description

A collection of purchase order summary objects.

Properties

Property | Type | Length | Default | Description
PurchaseOrderSummary | PurchaseOrderSummary | N/A | N/A | A purchase order summary object in the collection.


ArrayOfPurchaseOrderTransactionState

Description

A collection of purchase order transaction state objects.

Properties

Property | Type | Length | Default | Description
PurchaseOrder TransactionState | PurchaseOrderTransactionState | N/A | N/A | A purchase order transaction state object in the collection.


ArrayOfPurchaseReceiptLine

Description

A collection of purchase receipt line objects.

Properties

Property | Type | Length | Default | Description
PurchaseReceiptLine | PurchaseReceiptLine | N/A | N/A | A purchase receipt line object in the collection.


ArrayOfPurchaseReceiptSummary

Description

A collection of purchase receipt summary objects.

Properties

Property | Type | Length | Default | Description
PurchaseReceipt Summary | PurchaseReceiptSummary | N/A | N/A | A purchase receipt summary object in the collection.


ArrayOfPurchaseSerialDetail

Description

A collection of purchase serial detail objects.

Properties

Property | Type | Length | Default | Description
PurchaseSerialDetail | PurchaseSerialDetail | N/A | N/A | A purchase serial detail object in the collection.


ArrayOfPurchaseTax

Description

A collection of purchase tax objects.

Properties

Property | Type | Length | Default | Description
PurchaseTax | PurchaseTax | N/A | N/A | A purchase tax object in the collection.


ArrayOfPurchaseTransactionState

Description

A collection of purchase transaction state objects.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionState | PurchaseTransactionState | N/A | N/A | A purchase transaction state object in the collection.


ArrayOfPurchaseUserDefined

Description

A collection of purchase user defined objects.

Properties

Property | Type | Length | Default | Description
PurchaseUserDefined | PurchaseUserDefined | N/A | N/A | A purchase user defined object in the collection.


ArrayOfReceivablesCommission

Description

A collection of receivables commission objects.

Properties

Property | Type | Length | Default | Description
ReceivablesCommission | ReceivablesCommission | N/A | N/A | A receivables commission object in the collection.


ArrayOfReceivablesCreditMemoSummary

Description

A collection of receivables credit memo summary objects.

Properties

Property | Type | Length | Default | Description
ReceivablesCreditMemo Summary | ReceivablesCreditMemoSummary | N/A | N/A | A receivables credit memo summary object in the collection.


ArrayOfReceivablesDebitMemoSummary

Description

A collection of receivables debit memo summary objects.

Properties

Property | Type | Length | Default | Description
ReceivablesDebitMemo Summary | ReceivablesDebitMemoSummary | N/A | N/A | A receivables debit memo sumary object in the collection.


ArrayOfReceivablesDistribution

Description

A collection of receivables distribution objects.

Properties

Property | Type | Length | Default | Description
ReceivablesDistribution | ReceivablesDistribution | N/A | N/A | A receivables distribution object in the collection.


ArrayOfReceivablesDocumentSummary

Description

A collection of receivables document summary objects.

Properties

Property | Type | Length | Default | Description
ReceivablesDocument Summary | ReceivablesDocumentSummary | N/A | N/A | A receivables document summary object in the collection.


ArrayOfReceivablesDocumentType

Description

A collection of receivables document type objects.

Properties

Property | Type | Length | Default | Description
ReceivablesDocument Type | ReceivablesDocumentType | N/A | N/A | A receivables document type object in the collection.


ArrayOfReceivablesFinanceChargeSummary

Description

A collection of receivables finance charge summary objects.

Properties

Property | Type | Length | Default | Description
ReceivablesFinance ChargeSummary | ReceivablesFinanceChargeSummary | N/A | N/A | A receivables finance charge summary object in the collection.


ArrayOfReceivablesInvoiceSummary

Description

A collection of receivables invoice summary objects.

Properties

Property | Type | Length | Default | Description
ReceivablesInvoice Summary | ReceivablesInvoiceSummary | N/A | N/A | A receivables invoice summary object in the collection.


ArrayOfReceivablesReturnSummary

Description

A collection of receivables return summary objects.

Properties

Property | Type | Length | Default | Description
ReceivablesReturn Summary | ReceivablesReturnSummary | N/A | N/A | A receivables return summary object in the collection.


ArrayOfReceivablesServiceRepairSummary

Description

A collection of receivables service repair summary objects.

Properties

Property | Type | Length | Default | Description
ReceivablesService RepairSummary | ReceivablesServiceRepairSummary | N/A | N/A | A receivables service repair summary object in the collection.


ArrayOfReceivablesTax

Description

A collection of receivables tax objects.

Properties

Property | Type | Length | Default | Description
ReceivablesTax | ReceivablesTax | N/A | N/A | A receivables tax object in the collection.


ArrayOfReceivablesTransactionState

Description

A collection of receivables transaction state objects.

Properties

Property | Type | Length | Default | Description
ReceivablesTransaction State | ReceivablesTransactionState | N/A | N/A | A receivables transaction state object in the collection.


ArrayOfReceivablesWarrantySummary

Description

A collection of receivables warranty summary objects.

Properties

Property | Type | Length | Default | Description
ReceivablesWarranty Summary | ReceivablesWarrantySummary | N/A | N/A | A receivables warranty summary object in the collection.


ArrayOfReturnMaterialAuthorizationAudit

Description

A collection of return material authorization audit objects.

Properties

Property | Type | Length | Default | Description
ReturnMaterialAuthorizationAudit | ReturnMaterialAuthorizationAudit | N/A | N/A | A return material authorization audit object in the collection.


ArrayOfReturnMaterialAuthorizationDistribution

Description

A collection of return material authorization distribution objects.

Properties

Property | Type | Length | Default | Description
ReturnMaterialAuthorizationDistribution | ReturnMaterialAuthorizationDistribution | N/A | N/A | A return material authorization distribution object in the collection.


ArrayOfReturnMaterialAuthorizationLine

Description

A collection of return material authorization line objects.

Properties

Property | Type | Length | Default | Description
ReturnMaterialAuthorizationLine | ReturnMaterialAuthorizationLine | N/A | N/A | A return material authorization line object in the collection.


ArrayOfReturnMaterialAuthorizationLineLot

Description

A collection of return material authorization line lot objects.

Properties

Property | Type | Length | Default | Description
ReturnMaterialAuthorizationLineLot | ReturnMaterialAuthorizationLineLot | N/A | N/A | A return material authorization line lot object in the collection.


ArrayOfReturnMaterialAuthorizationLineSerial

Description

A collection of return material authorization line serial objects.

Properties

Property | Type | Length | Default | Description
ReturnMaterialAuthorizationLineSerial | ReturnMaterialAuthorizationLineSerial | N/A | N/A | A return material authorization line serial object in the collection.


ArrayOfReturnMaterialAuthorizationSummary

Description

A collection of return material authorization summary objects.

Properties

Property | Type | Length | Default | Description
ReturnMaterialAuthorizationSummary | ReturnMaterialAuthorizationSummary | N/A | N/A | A return material authorization summary object in the collection.


ArrayOfReturnMaterialAuthorizationType

Description

A collection of return material authorization type objects.

Properties

Property | Type | Length | Default | Description
ReturnMaterialAuthorizationType | ReturnMaterialAuthorizationType | N/A | N/A | A return material authorization type object in the collection.


ArrayOfRoleKey

Description

A collection of role key objects.

Properties

Property | Type | Length | Default | Description
RoleKey | RoleKey | N/A | N/A | A role key object in the collection.


ArrayOfSalesBackorderComponent

Description

A collection of sales backorder component objects.

Properties

Property | Type | Length | Default | Description
SalesBackorder Component | SalesBackorderComponent | N/A | N/A | A sales backorder component object in the collection.


ArrayOfSalesBackorderLine

Description

A collection of sales backorder line objects.

Properties

Property | Type | Length | Default | Description
SalesBackorderLine | SalesBackorderLine | N/A | N/A | A sales backorder line object in the collection.


ArrayOfSalesBackorderSummary

Description

A collection of sales backorder summary objects.

Properties

Property | Type | Length | Default | Description
SalesBackorderSummary | SalesBackorderSummary | N/A | N/A | A sales backorder summary object in the collection.


ArrayOfSalesCommission

Description

A collection of sales commission objects.

Properties

Property | Type | Length | Default | Description
SalesCommission | SalesCommission | N/A | N/A | A sales commission object in the collection.


ArrayOfSalesCommissionTransactionState

Description

A collection of sales commission transaction state objects.

Properties

Property | Type | Length | Default | Description
SalesCommission TransactionState | SalesCommissionTransactionState | N/A | N/A | A sales commission transaction state object in the collection.


ArrayOfSalesComponentBin

Description

A collection of sales component bin objects.

Properties

Property | Type | Length | Default | Description
SalesComponentBin | SalesComponentBin | N/A | N/A | A sales component bin object in the collection.


ArrayOfSalesComponentLot

Description

A collection of sales component lot objects.

Properties

Property | Type | Length | Default | Description
SalesComponentLot | SalesComponentLot | N/A | N/A | A sales component lot object in the collection.


ArrayOfSalesComponentSerial

Description

A collection of sales component serial objects.

Properties

Property | Type | Length | Default | Description
SalesComponentSerial | SalesComponentSerial | N/A | N/A | A sales component serial object in the collection.


ArrayOfSalesDistribution

Description

A collection of sales distribution objects.

Properties

Property | Type | Length | Default | Description
SalesDistribution | SalesDistribution | N/A | N/A | A sales distribution object in the collection.


ArrayOfSalesDocumentSummary

Description

A collection of sales document summary objects.

Properties

Property | Type | Length | Default | Description
SalesDocumentSummary | SalesDocumentSummary | N/A | N/A | A sales document summary object in the collection.


ArrayOfSalesDocumentTax

Description

A collection of sales document tax objects.

Properties

Property | Type | Length | Default | Description
SalesDocumentTax | SalesDocumentTax | N/A | N/A | A sales document tax object in the collection.


ArrayOfSalesDocumentType

Description

A collection of sales document type objects.

Properties

Property | Type | Length | Default | Description
SalesDocumentType | SalesDocumentType | N/A | N/A | A sales document type object in the collection.


ArrayOfSalesFulfillmentOrderComponent

Description

A collection of sales fulfillment order component objects.

Properties

Property | Type | Length | Default | Description
SalesFulfillmentOrder Component | SalesFulfillmentOrderComponent | N/A | N/A | A sales fulfillment order component object in the collection.


ArrayOfSalesFulfillmentOrderLine

Description

A collection of sales fulfillment order line objects.

Properties

Property | Type | Length | Default | Description
SalesFulfillmentOrderLine | SalesFulfillmentOrderLine | N/A | N/A | A sales fulfillment order line object in the collection.


ArrayOfSalesFulfillmentOrderSummary

Description

A collection of sales fulfillment order summary objects.

Properties

Property | Type | Length | Default | Description
SalesFulfillmentOrder Summary | SalesFulfillmentOrderSummary | N/A | N/A | A sales fulfillment order summary object in the collection.


ArrayOfSalesInvoiceComponent

Description

A collection of sales invoice component objects.

Properties

Property | Type | Length | Default | Description
SalesInvoiceComponent | SalesInvoiceComponent | N/A | N/A | A sales invoice component object in the collection.


ArrayOfSalesInvoiceLine

Description

A collection of sales invoice line objects.

Properties

Property | Type | Length | Default | Description
SalesInvoiceLine | SalesInvoiceLine | N/A | N/A | A sales invoice line object in the collection.


ArrayOfSalesInvoiceSummary

Description

A collection of sales invoice summary objects.

Properties

Property | Type | Length | Default | Description
SalesInvoiceSummary | SalesInvoiceSummary | N/A | N/A | A sales invoice summary object in the collection.


ArrayOfSalesItemWarehouse

Description

A collection of sales item warehouse objects.

Properties

Property | Type | Length | Default | Description
SalesItemWarehouse | SalesItemWarehouse | N/A | N/A | A sales item warehouse object in the collection.


ArrayOfSalesItemWarehouseBin

Description

A collection of sales item warehouse bin objects.

Properties

Property | Type | Length | Default | Description
SalesItemWarehouseBin | SalesItemWarehouseBin | N/A | N/A | A sales item warehouse bin object in the collection.


ArrayOfSalesLineBin

Description

A collection of sales line bin objects.

Properties

Property | Type | Length | Default | Description
SalesLineBin | SalesLineBin | N/A | N/A | A sales line bin object in the collection.


ArrayOfSalesLineLot

Description

A collection of sales line lot objects.

Properties

Property | Type | Length | Default | Description
SalesLineLot | SalesLineLot | N/A | N/A | A sales line lot object in the collection.


ArrayOfSalesLineSerial

Description

A collection of sales line serial objects.

Properties

Property | Type | Length | Default | Description
SalesLineSerial | SalesLineSerial | N/A | N/A | A sales line serial object in the collection.


ArrayOfSalesLineTax

Description

A collection of sales line tax objects.

Properties

Property | Type | Length | Default | Description
SalesLineTax | SalesLineTax | N/A | N/A | A sales line tax object in the collection.


ArrayOfSalesOrderComponent

Description

A collection of sales order component objects.

Properties

Property | Type | Length | Default | Description
SalesOrderComponent | SalesOrderComponent | N/A | N/A | A sales order component object in the collection.


ArrayOfSalesOrderLine

Description

A collection of sales order line objects.

Properties

Property | Type | Length | Default | Description
SalesOrderLine | SalesOrderLine | N/A | N/A | A sales order line object in the collection.


ArrayOfSalesOrderSummary

Description

A collection of sales order summary objects.

Properties

Property | Type | Length | Default | Description
SalesOrderSummary | SalesOrderSummary | N/A | N/A | A sales order summary object in the collection.


ArrayOfSalesPayment

Description

A collection of sales payment objects.

Properties

Property | Type | Length | Default | Description
SalesPayment | SalesPayment | N/A | N/A | A sales payment object in the collection.


ArrayOfSalespersonCommissionsDocumentType

Description

A collection of salesperson commissions document type objects.

Properties

Property | Type | Length | Default | Description
SalespersonCommissions DocumentType | SalespersonCommissionsDocumentType | N/A | N/A | A salesperson commissions document type object in the collection.


ArrayOfSalespersonCommissionsSummary

Description

A collection of salesperson commissions summary objects.

Properties

Property | Type | Length | Default | Description
SalespersonCommissions Summary | SalespersonCommissionsSummary | N/A | N/A | A salesperson commissions summary object in the collection.


ArrayOfSalespersonHistory

Description

A collection of salesperson history objects.

Properties

Property | Type | Length | Default | Description
SalespersonHistory | SalespersonHistory | N/A | N/A | A salesperson history object in the collection.


ArrayOfSalespersonSummary

Description

A collection of salesperson summary objects.

Properties

Property | Type | Length | Default | Description
SalespersonSummary | SalespersonSummary | N/A | N/A | A salesperson summary object in the collection.


ArrayOfSalesProcessHold

Description

A collection of sales process hold objects.

Properties

Property | Type | Length | Default | Description
SalesProcessHold | SalesProcessHold | N/A | N/A | A sales process hold object in the collection.


ArrayOfSalesProcessHoldSetup

Description

A collection of sales process hold setup objects.

Properties

Property | Type | Length | Default | Description
SalesProcessHoldSetup | SalesProcessHoldSetup | N/A | N/A | A sales process hold setup object in the collection.


ArrayOfSalesQuoteComponent

Description

A collection of sales quote component objects.

Properties

Property | Type | Length | Default | Description
SalesQuoteComponent | SalesQuoteComponent | N/A | N/A | A sales quote component object in the collection.


ArrayOfSalesQuoteLine

Description

A collection of sales quote line objects.

Properties

Property | Type | Length | Default | Description
SalesQuoteLine | SalesQuoteLine | N/A | N/A | A sales quote line object in the collection.


ArrayOfSalesQuoteSummary

Description

A collection of sales quote summary objects.

Properties

Property | Type | Length | Default | Description
SalesQuoteSummary | SalesQuoteSummary | N/A | N/A | A sales quote summary object in the collection.


ArrayOfSalesReturnComponent

Description

A collection of sales return component objects.

Properties

Property | Type | Length | Default | Description
SalesReturnComponent | SalesReturnComponent | N/A | N/A | A sales return component object in the collection.


ArrayOfSalesReturnLine

Description

A collection of sales return line objects.

Properties

Property | Type | Length | Default | Description
SalesReturnLine | SalesReturnLine | N/A | N/A | A sales return line object in the collection.


ArrayOfSalesReturnSummary

Description

A collection of sales return summary objects.

Properties

Property | Type | Length | Default | Description
SalesReturnSummary | SalesReturnSummary | N/A | N/A | A sales return summary object in the collection.


ArrayOfSalesTerritoryHistory

Description

A collection of sales territory history objects.

Properties

Property | Type | Length | Default | Description
SalesTerritoryHistory | SalesTerritoryHistory | N/A | N/A | A sales territory history object in the collection.


ArrayOfSalesTerritorySummary

Description

A collection of sales territory summary objects.

Properties

Property | Type | Length | Default | Description
SalesTerritorySummary | SalesTerritorySummary | N/A | N/A | A sales territory summary object in the collection.


ArrayOfSalesTrackingNumber

Description

A collection of sales tracking number objects.

Properties

Property | Type | Length | Default | Description
SalesTrackingNumber | SalesTrackingNumber | N/A | N/A | A sales tracking number object in the collection.


ArrayOfSalesTransactionState

Description

A collection of sales transaction state objects.

Properties

Property | Type | Length | Default | Description
SalesTransactionState | SalesTransactionState | N/A | N/A | A sales transaction state object in the collection.


ArrayOfServiceCallAdditionalChargeLine

Description

A collection of service call additional charge line objects.

Properties

Property | Type | Length | Default | Description
ServiceCallAdditionalChargeLine | ServiceCallAdditionalChargeLine | N/A | N/A | A service call additional charge line object in the collection.


ArrayOfServiceCallDocumentAudit

Description

A collection of service call document audit objects.

Properties

Property | Type | Length | Default | Description
ServiceCallDocumentAudit | ServiceCallDocumentAudit | N/A | N/A | A service call document audit object in the collection.


ArrayOfServiceCallEquipmentCode

Description

A collection of service call equipment code objects.

Properties

Property | Type | Length | Default | Description
ServiceCallEquipmentCode | ServiceCallEquipmentCode | N/A | N/A | A service call equipment code object in the collection.


ArrayOfServiceCallExpenseLine

Description

A collection of service call expense line objects.

Properties

Property | Type | Length | Default | Description
ServiceCallExpenseLine | ServiceCallExpenseLine | N/A | N/A | A service call expense line object in the collection.


ArrayOfServiceCallLaborLine

Description

A collection of service call labor line objects.

Properties

Property | Type | Length | Default | Description
ServiceCallLaborLine | ServiceCallLaborLine | N/A | N/A | A service call labor line object in the collection.


ArrayOfServiceCallPartLine

Description

A collection of service call part line objects.

Properties

Property | Type | Length | Default | Description
ServiceCallPartLine | ServiceCallPartLine | N/A | N/A | A service call part line object in the collection.


ArrayOfServiceCallSummary

Description

A collection of service call summary objects.

Properties

Property | Type | Length | Default | Description
ServiceCallSummary | ServiceCallSummary | N/A | N/A | A service call summary object in the collection.


ArrayOfServiceCallType

Description

A collection of service call type objects.

Properties

Property | Type | Length | Default | Description
ServiceCallType | ServiceCallType | N/A | N/A | A service call type object in the collection.


ArrayOfServiceDistribution

Description

A collection of service distribution objects.

Properties

Property | Type | Length | Default | Description
ServiceDistribution | ServiceDistribution | N/A | N/A | A service distribution object in the collection.


ArrayOfServiceEquipmentCode

Description

A collection of service equipment code objects.

Properties

Property | Type | Length | Default | Description
ServiceEquipmentCode | ServiceEquipmentCode | N/A | N/A | A service equipment code object in the collection.


ArrayOfServiceEquipmentReading

Description

A collection of service equipment reading objects.

Properties

Property | Type | Length | Default | Description
ServiceEquipmentReading | ServiceEquipmentReading | N/A | N/A | A service equipment reading object in the collection.


ArrayOfServiceEquipmentSummary

Description

A collection of service equipment summary objects.

Properties

Property | Type | Length | Default | Description
ServiceEquipmentSummary | ServiceEquipmentSummary | N/A | N/A | A service equipment summary object in the collection.


ArrayOfServiceLot

Description

A collection of service lot objects.

Properties

Property | Type | Length | Default | Description
ServiceLot | ServiceLot | N/A | N/A | A service lot object in the collection.


ArrayOfServiceQuoteAdditionalChargeLine

Description

A collection of service quote additional charge line objects.

Properties

Property | Type | Length | Default | Description
ServiceQuoteAdditionalChargeLine | ServiceQuoteAdditionalChargeLine | N/A | N/A | A service quote additional charge line object in the collection.


ArrayOfServiceQuoteExpenseLine

Description

A collection of service quote expense line objects.

Properties

Property | Type | Length | Default | Description
ServiceQuoteExpenseLine | ServiceQuoteExpenseLine | N/A | N/A | A service quote expense line object in the collection.


ArrayOfServiceQuoteLaborLine

Description

A collection of service quote labor line objects.

Properties

Property | Type | Length | Default | Description
ServiceQuoteLaborLine | ServiceQuoteLaborLine | N/A | N/A | A service quote labor line object in the collection.


ArrayOfServiceQuotePartLine

Description

A collection of service quote part line objects.

Properties

Property | Type | Length | Default | Description
ServiceQuotePartLine | ServiceQuotePartLine | N/A | N/A | A service quote part line object in the collection.


ArrayOfServiceQuoteSummary

Description

A collection of service quote summary objects.

Properties

Property | Type | Length | Default | Description
ServiceQuoteSummary | ServiceQuoteSummary | N/A | N/A | A service quote summary object in the collection.


ArrayOfServiceSerial

Description

A collection of service serial objects.

Properties

Property | Type | Length | Default | Description
ServiceSerial | ServiceSerial | N/A | N/A | A service serial object in the collection.


ArrayOfServiceSummary

Description

A collection of service summary objects.

Properties

Property | Type | Length | Default | Description
ServiceSummary | ServiceSummary | N/A | N/A | A service summary object in the collection.


ArrayOfServiceTransactionState

Description

A collection of service transaction state objects.

Properties

Property | Type | Length | Default | Description
ServiceTransactionState | ServiceTransactionState | N/A | N/A | A service transaction state object in the collection.


ArrayOfShippingMethod

Description

A collection of shipping method objects.

Properties

Property | Type | Length | Default | Description
ShippingMethod | ShippingMethod | N/A | N/A | A shipping method object in the collection.


ArrayOfSkill

Description

A collection of job skill objects.

Properties

Property | Type | Length | Default | Description
Skill | Skill | N/A | N/A | A skill object in the collection.


ArrayOfSkillSetSummary

Description

A collection of job skillset summary objects.

Properties

Property | Type | Length | Default | Description
SkillSetSummary | SkillSetSummary | N/A | N/A | A skillset summary object in the collection.


ArrayOfString

Description

A collection of string values.

Properties

Property | Type | Length | Default | Description
string | string | N/A | N/A | A string value in the collection.


ArrayOfTaxDetail

Description

A collection of tax detail objects.

Properties

Property | Type | Length | Default | Description
TaxDetail | TaxDetail | N/A | N/A | A tax detail object in the collection.


ArrayOfTaxDetailBase

Description

A collection of tax detail base values.

Properties

Property | Type | Length | Default | Description
TaxDetailBase | TaxDetailBase | N/A | N/A | A tax detail base value in the collection.


ArrayOfTaxDetailType

Description

A collection of tax detail type values.

Properties

Property | Type | Length | Default | Description
TaxDetailType | TaxDetailType | N/A | N/A | A tax detail type value in the collection.


ArrayOfTaxSchedule

Description

A collection of tax schedule objects.

Properties

Property | Type | Length | Default | Description
TaxSchedule | TaxSchedule | N/A | N/A | A tax schedule object in the collection.


ArrayOfTaxScheduleDetail

Description

A collection of tax schedule detail objects.

Properties

Property | Type | Length | Default | Description
TaxScheduleDetail | TaxScheduleDetail | N/A | N/A | A tax schedule detail object in the collection.


ArrayOfTenant

Description

A collection of tenant objects.

Properties

Property | Type | Length | Default | Description
Tenant | Tenant | N/A | N/A | A tenant object in the collection.


ArrayOfUofMScheduleDetail

Description

A collection of U of M schedule detail objects.

Properties

Property | Type | Length | Default | Description
UofMScheduleDetail | UofMScheduleDetail | N/A | N/A | A U of M schedule detail object in the collection.


ArrayOfUofMScheduleSummary

Description

A collection of U of M schedule summary objects.

Properties

Property | Type | Length | Default | Description
UofMScheduleSummary | UofMScheduleSummary | N/A | N/A | A U of M schedule summary object in the collection.


ArrayOfUserAssignableBusinessObject

Description

A collection of user-assignable business object.

Properties

Property | Type | Length | Default | Description
UserAssignableBusinessObject | UserAssignableBusinessObject | N/A | N/A | A user-assignable business object in the collection.


ArrayOfValidationError

Description

A collection of validation error objects.

Properties

Property | Type | Length | Default | Description
ValidationError | ValidationError | N/A | N/A | A validation error object in the collection.


ArrayOfValidationWarning

Description

A collection of validation warning objects.

Properties

Property | Type | Length | Default | Description
ValidationWarning | ValidationWarning | N/A | N/A | A validation warning object in the collection.


ArrayOfVendorAddress

Description

A collection of vendor address objects.

Properties

Property | Type | Length | Default | Description
VendorAddress | VendorAddress | N/A | N/A | A vendor address object in the collection.


ArrayOfVendorAddressSummary

Description

A collection of vendor address summary objects.

Properties

Property | Type | Length | Default | Description
VendorAddressSummary | VendorAddressSummary | N/A | N/A | A vendor address summary object in the collection.


ArrayOfVendorManufacturingOrderSummary

Description

A collection of vendor manufacturing order summary objects.

Properties

Property | Type | Length | Default | Description
VendorManufacturingOrderSummary | VendorManufacturingOrderSummary | N/A | N/A | A vendor manufacturing order summary object in the collection.


ArrayOfVendorPlannedOrderSummary

Description

A collection of vendor planned order summary objects.

Properties

Property | Type | Length | Default | Description
VendorPlannedOrderSummary | VendorPlannedOrderSummary | N/A | N/A | A vendor planned order summary object in the collection.


ArrayOfVendorSummary

Description

A collection of vendor summary objects.

Properties

Property | Type | Length | Default | Description
VendorSummary | VendorSummary | N/A | N/A | A vendor summary object in the collection.


ArrayOfWarehouseBin

Description

A collection of warehouse bin objects.

Properties

Property | Type | Length | Default | Description
WarehouseBin | WarehouseBin | N/A | N/A | A warehouse bin object in the collection.


ArrayOfWarehouseSummary

Description

A collection of warehouse summary objects.

Properties

Property | Type | Length | Default | Description
WarehouseSummary | WarehouseSummary | N/A | N/A | A warehouse summary object in the collection.


ArrayOfWorkflow

Description

A collection of workflow objects.

Properties

Property | Type | Length | Default | Description
Workflow | Workflow | N/A | N/A | A workflow object in the collection.


AXCompanyKey

Description

Uniquely identifies a company in Microsoft Dynamics AX. Reserved for future use.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value that uniquely identifies the company.

Inherits from

OrganizationKey


BackOfficeRole

Description

Defines a security role in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | BackOfficeRoleKey | N/A | N/A | The back office role key object that uniquely identifies a security role in Microsoft Dynamics GP.
Name | string | 50 | N/A | The display name for the back office security role.
Description | string | 255 | Empty | The description of the back office security role.

Inherits from

BusinessObject


BackOfficeRoleAssignment

Description

An object that maps a user in Microsoft Dynamics GP to a specific back office security role.

Properties

Property | Type | Length | Default | Description
Key | BackOfficeRoleAssignmentKey | N/A | N/A | The back office role assignment key object that defines the characteristics of the back office role assignment.

Inherits from

BusinessObject


BackOfficeRoleAssignmentKey

Description

Uniquely identifies the properties of a back office role assignment.

Properties

Property | Type | Length | Default | Description
RoleKey | BackOfficeRoleKey | N/A | N/A | A back office role key object that uniquely identifies a back office security role in Microsoft Dynamics GP.
CompanyKey | CompanyKey | N/A | N/A | The company key object that specifies the company
UserKey | UserKey | N/A | N/A | A user key object that uniquely identifies a user in Microsoft Dynamics GP.


BackOfficeRoleKey

Description

Uniquely identifies a back office security role in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 25 | N/A | A string value that identifies the back office security role.


Bank

Description

A bank within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | BankKey | N/A | N/A | The bank key object that uniquely identifies the bank.
Name | string | 30 | Empty | The name of the bank.
Address | Address | N/A | Empty | A collection of address properties for the bank.
TransitNumber | string | 9 | Empty | The bank’s transit number.
Branch | string | 20 | Empty | Identifies the specific branch for the bank.
DirectDepositTransit Number | string | 9 | Empty | The bank’s direct deposit transit number.

Inherits from

BusinessObject


BankAccountKey

Description

Uniquely identifies a bank account object.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identified assigned to the bank account.

Inherits from

ReferenceKey


BankCriteria

Description

Specifies the criteria to use when retrieving a list of bank objects. Only bank objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying ID for the bank.
Name† | LikeRestrictionOfString | A string restriction specifying the name for the bank.
Branch† | LikeRestrictionOfString | A string restriction specifying the branch for the bank.

Inherits from

Criteria


BankKey

Description

Uniquely identifies a bank object.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier assigned to the bank.

Inherits from

ReferenceKey


BaseChangedKeyCriteria

Description

A set of the common properties for all changed key criteria objects in Microsoft Dynamics GP.

Properties

Property | Type | Description
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the object was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
Action | RestrictionOfNullableOfDataModificationAction | A restriction specifying the type of action that was performed that resulted in the the object being modified.

Inherits from

Criteria


BaseChangedSalesDocument

Description

A set of the common properties for all changed sales document object in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
SalesDocumentTypeKey | SalesDocumentTypeKey | N/A | Empty | The sales document type key object that uniquely identifies a sales document type.

Inherits from

ChangedBusinessObjectGreatPlainsKey


BaseChangedSalesDocumentKeyCriteria

Description

A set of the common properties for all changed sales document key criteria objects in Microsoft Dynamics GP.

Properties

Property | Type | Description
SalesDocumentKeyId | BetweenRestrictionOfString | A string restriction specifying the ID for the sales document.

Inherits from

BaseChangedKeyCriteria


Batch

Description

A batch within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch. This property is read-only.
NumberOfTransactions | int | N/A | N/A | The number of transactions in the batch. This property is read-only.
Frequency | PostingFrequency | N/A | From Microsoft Dynamics GP setup | The posting frequency of the batch.
RecurringLastPostedDate | dateTime | N/A | Empty | The last date a recurring batch was posted. Only applies if frequency is not Single. This property is read-only.
NumberOfPostings | int | N/A | N/A | The number of times the recurring batch has been posted. Only applies if the frequency is not Single. This property is read-only.
Comment | string | 60 | Empty | A description of the batch. This property is read-only.
Total | MoneyAmount | N/A | N/A | The absolute value of all debits and credits in the batch. This property is read-only.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the ISO code used for the cash receipt. This property is read-only.
ControlNumberOfTransactions | int | N/A | N/A | The number of transactions that should be in the batch. This property is read-only.
ControlTotal | MoneyAmount | N/A | N/A | The desired amount of transactions, debits and credits within the batch. This property is read-only.
GeneralLedgerPostedDate | dateTime | N/A | Empty | The general ledger posting date for the batch. This property is read-only.
BankAccountKey | BankAccountKey | N/A | N/A | The bank account key object that uniquely identifies the bank account for the batch. This property is read-only.
WorkflowPriority | WorkflowPriority | N/A | N/A | The priority of the batch in the workflow. This property is read-only.
Workflows | ArrayOfWorkflow | N/A | N/A | The collection of workflow objects for the batch.

Inherits from

BusinessObject


BatchCriteria

Description

Specifies the criteria to use when retrieving a list of batch objects. Only batch objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying ID for the batch.
Source† | LikeRestrictionOfString | A string restriction specifying the source of the transactions in the batch.

Inherits from

Criteria


BatchKey

Description

Uniquely identifies a batch within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Source | string | 15 | Empty | Identifies the type of transactions that are in the batch.
Id | string | 15 | Empty | The string value that identifies a batch.
CreatedDateTime | dateTime | N/A | Current system date | The date and time the batch was created. This property is read-only.

Inherits from

ReferenceKey


Behavior

Description

Defines a behavior for a policy. A behavior defines how a single characteristic of the underlying object is handled by a web method. For instance, a behavior for the Create GL Transaction Policy controls whether a reversing transaction is created when the CreateGLTransaction method creates a new transaction. A policy can have multiple behaviors defined for it.

Properties

Property | Type | Length | Default | Description
Key | BehaviorKey | N/A | N/A | The behavior key object that uniquely identifies the behavior. This property is read-only.
Name | string | N/A | N/A | The name of the behavior. This property is read-only.
Description | string | N/A | N/A | A description of the behavior. This property is read-only.
Internal | boolean | N/A | N/A | Indicates whether the behavior can be controlled by the application accessing the web method, or only by the web service administrator. True means the behavior can be controlled only by the web service administrator. False means the behavior can be controlled by the application accessing the web method. This property is read-only.
Options | ArrayOfBehaviorOption | N/A | N/A | The collection of possible behavior options for this behavior. This property is read-only.
SelectedOption | BehaviorOption | N/A | N/A | The behavior option that will be used from the list of available behavior options. This property is read-only.


BehaviorKey

Description

Uniquely identifies a behavior.

Properties

Property | Type | Length | Default | Description
PolicyKey | PolicyKey | N/A | N/A | The policy key object that specifies the policy that the behavior is part of. This property is read-only.
Id | GUID | N/A | N/A | A globally unique identifier (GUID) assigned to the behavior. This property is read-only.


BehaviorOption

Description

Defines one of the possible actions for a policy behavior. Each behavior has a set of behavior options, one of which will be selected and applied to the object being acted on.

Properties

Property | Type | Length | Default | Description
Key | BehaviorOptionKey | N/A | N/A | The behavior key object that uniquely identifies the behavior. This property is read-only.
Name | string | N/A | N/A | The name of the behavior option. This property is read-only.
Description | string | N/A | N/A | A description of the behavior option. This property is read-only.
Parameters | ArrayOfParameter | N/A | N/A | A collection of parameters for the behavior option. Not all behavior options have parameters.


BehaviorOptionKey

Description

Uniquely identifies a behavior option.

Properties

Property | Type | Length | Default | Description
BehaviorKey | BehaviorKey | N/A | N/A | The behavior key object that specifies the behavior the behavior option is part of. This property is read-only.
Id | int | N/A | N/A | The integer identifier assigned to the behavior option. This value is read-only.


BetweenRestrictionOfNullableOfDateTime

Description

A restriction specifying the allowable range of values for a date/time property of a criteria object.

Properties

Property | Type | Length | Default | Description
From | dateTime | N/A | N/A | The lowest value the dateTime property can be equal to.
To | dateTime | N/A | N/A | The highest value the dateTime property can be equal to.
GreaterThan | dateTime | N/A | N/A | The value the dateTime property must be greater than.
LessThan | dateTime | N/A | N/A | The value the dateTime property must be less than.

Inherits from

ListRestrictionOfNullableOfDateTime


BetweenRestrictionOfNullableOfDecimal

Description

A restriction specifying the allowable range of values for the decimal property of a criteria object.

Properties

Property | Type | Length | Default | Description
From | decimal | N/A | N/A | The lowest value the decimal property can be equal to.
To | decimal | N/A | N/A | The highest value the deicmal property can be equal to.
GreaterThan | decimal | N/A | N/A | The value the decimal property must be greater than.
LessThan | decimal | N/A | N/A | The value the decimal property must be less than.

Inherits from

ListRestrictionOfNullableOfDecimal


BetweenRestrictionOfNullableOfInt32

Description

A restriction specifying the allowable range of values for an Int32 property of a criteria object.

Properties

Property | Type | Length | Default | Description
From | int | N/A | N/A | The lowest value the Int32 property can be equal to.
To | int | N/A | N/A | The highest value the Int32 property can be equal to.
GreaterThan | int | N/A | N/A | The value the Int32 property must be greater than.
LessThan | int | N/A | N/A | The value the Int32 property must be less than.

Inherits from

ListRestrictionOfNullableOfInt32


BetweenRestrictionOfNullableOfServiceCallType

Description

A restriction specifying the allowable range of values for a service call type of a criteria object.

Properties

Property | Type | Length | Default | Description
From | ServiceCallType | N/A | N/A | The lowest value the service call type property can be equal to.
To | ServiceCallType | N/A | N/A | The highest value the service call type property can be equal to.
GreaterThan | ServiceCallType | N/A | N/A | The value the service call type property must be greater than.
LessThan | ServiceCallType | N/A | N/A | The value the service call type property must be less than.

Inherits from

ListRestrictionOfNullableOfServiceCallType


BetweenRestrictionOfString

Description

A restriction specifying the allowable range of values for a string property of a criteria object.

Properties

Property | Type | Length | Default | Description
From | string | N/A | N/A | The lowest value the string property can be equal to.
To | string | N/A | N/A | The highest value the string property can be equal to.
GreaterThan | string | N/A | N/A | The value the string property must be greater than.
LessThan | string | N/A | N/A | The value the string property must be less than.

Inherits from

ListRestrictionOfString


BillingRate

Description

A project type in which the total the customer is billed is based on the quantity and the billing rate for a single unit quantity of an item or time.

Properties

Inherited from the base class

Inherits from

MoneyProfitCalculation


BusinessAddress

Description

Extends the International Address class with properties that are specific to a business address.

Properties

Property | Type | Length | Default | Description
Name | string | 64 | Empty | The full name of the the business at the address.
ContactPerson | string | 60 | Empty | The contact person at the business address.

Inherits from

InternationalAddress


BusinessObject

Description

Provides the underlying storage and capabilities for each of the concrete object types that derive from it.

Properties

Property | Type | Length | Default | Description
Extensions | ExtensionList | N/A | Empty | The collection of additional data items that third-parties have added to the object.


BusinessObjectSummary

Description

A representation of the important details of a business object in Microsoft Dynamics GP. A list of business object summary objects is returned by the GetBusinessObjectSummaryList method.

Properties

Property | Type | Length | Default | Description
BusinessObjectKey | string | N/A | N/A | The key value for the business object.
DisplayId | string | N/A | N/A | The display ID for the business object.
DisplayName | string | N/A | N/A | The display name for the business object.


BusinessObjectSummaryCriteria

Description

Specifies the criteria to use when retrieving a list of business object summary objects. Only business object summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
BusinessObjectKey | RestrictionOfString | A string restriction specifying the key for the business object.
DisplayId | LikeRestrictionOfString | A string restriction specifying the display ID for the business object.

Inherits from

Criteria


BusinessObjectUserAssignment

Description

Represents a Windows User ID that is mapped to an ID in Microsoft Dynamics GP

Properties

Property | Type | Length | Default | Description
User | string | N/A | N/A | The Window User ID that is mapped to an ID in Microsoft Dynamics GP.
BusinessObjectTypeId | guid | N/A | N/A | Uniquely identifies the user assignable business object type. Use the GetUserAssignableBusinessObjectList method to retrieve available types.
OrganizationKey | OrganizationKey | N/A | N/A | Specifies the location of the business object to which the Windows User ID is mapped. It could be a specific company, or null to indicate the enterprise-level.
BusinessObjectKey | string | N/A | N/A | The ID of the business object in Microsoft Dynamics GP to which the Windows User is mapped.


BuyerKey

Description

Uniquely identifies a buyer.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The unique identifier assigned to the buyer.

Inherits from

ReferenceKey


CashDetail

Description

Defines a cash payment/receipt in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Amount | MoneyAmount | N/A | 0 | The cash amount.
BankAccountKey | BankAccountKey | N/A | Empty | The bank account key object that specifies the bank account (checkbook) used to record the cash payment/receipt.
Date | dateTime | N/A | N/A | The date the cash payment/receipt was received.
Number | string | 20 | N/A | The cash payment/receipt number.


CashReceipt

Description

Defines the receipt of money from a customer in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer for the cash receipt.
CorporateAccountKey | CustomerKey | N/A | Empty | If the customer is part of a corporate (national) account, the customer key that specifies the parent account.
Key | ReceivablesDocumentKey | N/A | N/A | The receivables document key object that uniquely identifies the receivables document for the cash receipt.
CheckCardNumber | string | 20 | Empty | The check or payment card number.
PaymentCardTypeKey | PaymentCardTypeKey | N/A | N/A | The payment card type key object that uniquely identifies the type of payment card for the transaction.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch to use for the cash receipt.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.
Type | CashReceiptType | N/A | N/A | Indicates whether the cash receipt type is check, cash or payment card.
BankAccountKey | BankAccountKey | N/A | N/A | The bank account key object that uniquely identifies the bank account for the transaction.
Date | dateTime | N/A | If not provided, defaults to the system date. | The date of the cash receipt.
PostedDate | dateTime | N/A | N/A | The date the cash receipt was posted.
PostedBy | string | N/A | N/A | The user who posted the cash receipt.
GeneralLedgerPosting Date | dateTime | N/A | If not provided, defaults to the system date. | The general ledger posting date of the cash receipt.
ModifiedDate | dateTime | N/A | N/A | The date the cash receipt document was last modified. This property is read-only.
ModifiedBy | string | N/A | N/A | The user who last modified the cash receipt document. This property is read-only.
Amount | MoneyAmount | N/A | N/A | The cash receipt transaction amount.
Description | string | 30 | Empty | The description of the cash receipt transaction.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the ISO code used for the cash receipt.
ExchangeRate | decimal | N/A | 0 | The exchange rate for the cash receipt transaction.
ExchangeDate | dateTime | N/A | N/A | The exchange date associated with the exchange rate provided.
IsVoided | boolean | N/A | N/A | Indicates whether the cash receipt has been voided.
VoidDate | dateTime | N/A | N/A | The date the cash receipt was voided.
Distributions | ArrayOfCashReceiptDistribution | N/A | N/A | A collection of cash receipt distributions for the cash receipt.

Inherits from

BusinessObject


CashReceiptCriteria

Description

Specifies the criteria to use when retrieving a list of cash receipt summary objects. Only cash receipt summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the cash receipt.
CustomerId† | LikeRestrictionOfString | A string restriction specifying the customer ID for the cash receipt.
BatchId† | LikeRestrictionOfString | A string restriction specifying the batch ID for the cash receipt.
CurrencyISOCode | ListRestrictionOfString | A list restriction specifying the currency ISO code for the cash receipt.
TransactionState | ListRestrictionOfNullableOfReceivablesTransactionState | A list restriction specifying the transaction state of the cash receipt.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the cash receipt.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the cash receipt was last modified.
Scope | CashReceiptScope | A property in criteria used to determine the level of filtering to be used when returning cash receipt data.

Inherits from

Criteria


CashReceiptDistribution

Description

Defines the properties specific to a general ledger distribution for a cash receipt.

Properties

Property | Type | Length | Default | Description
Key | ReceivablesDistributionKey | N/A | N/A | The receivables distribution key that uniquely identifies a receivables distribution instance.

Inherits from

Distribution


CashReceiptSummary

Description

A representation of the important details of a cash receipt within Microsoft Dynamics GP. A list of cash receipt summary objects is returned by the GetCashReceiptList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ReceivablesDocumentKey | N/A | N/A | The receivables document key object that uniquely identifies the receivables document for the cash receipt.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer for the cash receipt.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch used for the cash receipt.
Date | dateTime | N/A | N/A | The cash receipt document date.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the ISO code used for the cash receipt.
BankAccountKey | BankAccountKey | N/A | N/A | The bank account key object that uniquely identifies the bank account for the transaction.
Description | string | 30 | N/A | The description of the cash receipt transaction.
Amount | MoneyAmount | N/A | N/A | The cash receipt transaction amount.
TransactionState | ReceivablesTransactionState | N/A | N/A | Indicates whether the receivables document was retrieved from the work table, open table or the history table.
ModifiedDate | dateTime | N/A | N/A | The date the cash receipt document was last modified.


ChangedBusinessObjectGreatPlainsKey

Description

Uniquely identifies a changed business object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CompanyKey | CompanyKey | N/A | N/A | A key that uniquely identifies a company object.

Inherits from

ChangedBusinessObjectKey


ChangedBusinessObjectKey

Description

Uniquely identifies a changed business object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
LastModifiedDate | dateTime | N/A | The current system date. | The date the object was last modified. The value is in Coordinated Universal Time (UTC).
LastModifiedBy | string | N/A | N/A | Not implemented.
Action | DataModificationAction | N/A | N/A | Indicates what action caused the object to be modified.


ChangedCurrencyKey

Description

Uniquely identifies a changed currency object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ISOCode | string | 3 | N/A | The value used to identify the the currency that changed. For example, US dollars is USD.

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedCustomerAddressKey

Description

Uniquely identifies a changed customer address object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer for whom an address changed.
Id | string | 15 | N/A | Specifies the ID of the address that changed for the set of address information for the customer.

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedCustomerKey

Description

Uniquely identifies a changed customer object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier of the customer that changed.

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedInternetAddressKey

Description

Uniquely identifies a changed Internet address object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
InternetAddressType | string | 3 | N/A | Specifies the type of object that the Internet addresses are associated with. Use one of the following three-character values: CMP - Company CUS - Customers EMP - Employees ITM - Items SLP - Salespeople VEN - Vendors
InternetAddressKey | string | N/A | N/A | A string value that identifies the object that the Internet addresses are associated with.
AddressKey | AddressKey | N/A | N/A | Uniquely identifies the address that the changed Internet address is associated with.

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedItemKey

Description

Uniquely identifies a changed item object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | N/A | The unique identifier of the item that changed.
ItemType | ItemType | N/A | N/A | Describe the type of item or the status of the item.

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedPriceLevelKey

Description

Uniquely identifies a changed price level object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | N/A | The string value that identifies the price level that changed.

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedPricingKey

Description

Uniquely identifies the changed pricing for an item within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ItemKey | ItemKey | N/A | N/A | The item key object that uniquely identifies the item for which pricing has changed.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the ISO code of the currency.
PriceLevelKey | PriceLevelKey | N/A | N/A | The price level key object that uniquely identifies the price level.
UofM | string | 8 | N/A | The unit of measure.

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedSalesInvoiceKey

Description

Uniquely identifies a changed sales invoice object within Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedSalesOrderKey

Description

Uniquely identifies a changed sales order object within Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

BaseChangedSalesDocument


ChangedSalespersonKey

Description

Uniquely identifies a changed salesperson object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The string value that identifies the salesperson that changed.

Inherits from

ChangedBusinessObjectGreatPlainsKey


ChangedShippingMethodKey

Description

Uniquely identifies a changed shipping method object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The string value that identifies the shipping method that changed.

Inherits from

ChangedBusinessObjectKey


ChangedTaxDetailKey

Description

Uniquely identifies a changed tax detail object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
TaxDetailKey | TaxDetailKey | 15 | N/A | The string value that identifies the tax detail that changed.

Inherits from

ChangedBusinessObjectKey


ChangedTaxScheduleDetailKey

Description

Uniquely identifies a changed tax schedule detail object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
TaxScheduleDetailKey | TaxScheduleDetailKey | 15 | N/A | The string value that identifies the tax schedule detail that changed.

Inherits from

ChangedBusinessObjectKey


ChangedUofMScheduleKey

Description

Uniquely identifies a changed unit of measure schedule object within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | N/A | The string value that identifies the unit of measure schedule that changed.

Inherits from

ChangedBusinessObjectGreatPlainsKey


CheckDetail

Description

Defines a check payment/receipt in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Amount | MoneyAmount | N/A | 0 | The check amount.
BankAccountKey | BankAccountKey | N/A | Empty | The bank account key object that specifies the bank account (checkbook) used to record the check payment/receipt.
Date | dateTime | N/A | N/A | The date the check payment/receipt was received.
Number | string | 20 | Empty | The check payment/receipt number.
CheckNumber | string | 20 | Empty | The check number.


CommentKey

Description

Uniquely identifies a comment object.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The unique identifier assigned to the comment.

Inherits from

ReferenceKey


CommissionSummary

Description

A set of commission information.

Properties

Property | Type | Length | Default | Description
CostOfSales | MoneyAmount | N/A | 0 | The total cost of sales.
TotalCommissions Amount | MoneyAmount | N/A | 0 | The total commissions amount.
CommissionedSales | MoneyAmount | N/A | 0 | The total commissioned sales.
NoncommissionedSales | MoneyAmount | N/A | 0 | The total noncommissioned sales.

Inherits from

BusinessObject


Company

Description

A company in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CompanyKey | N/A | N/A | The company key object that uniquely identifies the customer.
Name | string | 30 | Empty | The name of the company that corresponds to the main address.
DefaultAddressKey | CompanyAddressKey | N/A | Empty | The company address key object that specifies the default address for the company.
DefaultAddress | ExtendedBusinessAddress | N/A | N/A | The default address information for the company.
UserDefined1 | string | 30 | Empty | A user-defined field for the company.
UserDefined2 | string | 30 | Empty | A user-defined field for the company.
TaxExempt1 | string | 25 | Empty | A tax exemption number for the company.
TaxExempt2 | string | 25 | Empty | A second tax exemption number for the company.
TaxRegistration | string | 25 | Empty | The tax registration number for the company, such as a VAT registration number.
ModifiedDate | dateTime | N/A | System date | The date and time the company object was last modified.
ModifiedBy | string | 15 | Current user | The last user to modify the company information.
CreatedDate | dateTime | N/A | System date | The date and time the company was created.
SalesTaxScheduleKey | TaxScheduleKey | N/A | Empty | The tax schedule key object that specifies the sales tax schedule to use for the company.
PurchasesTaxSchedule Key | TaxScheduleKey | N/A | Empty | The tax schedule key object that specifies the purchase tax schedule to use for the company.
WithholdingVendorKey | VendorKey | N/A | Empty | The vendor key object that specifies the vendor to whom tax withholding is submitted. Typically, this vendor is a taxing authority.
WitholdingFileOr ReconciliationNumber | string | 25 | Empty | The Withholding File or Reconciliation Number.
WitholdingTaxRate | int | N/A | 0 | The withholding tax rate.
ReceivablesProcessesTax DetailKey | TaxDetailKey | N/A | Empty | A tax detail key object that specifies the receivables processes tax detail.
PayablesProcessesTax DetailKey | TaxDetailKey | N/A | Empty | A tax detail key object that specifies the payables processes tax detail.
BusinessType | string | 30 | Empty | The business type for the company. Applies when the Human Resource module is used.
SICNumber | string | 4 | Empty | The Standard Industry Classification (SIC) number for the company. Available when the Human Resources module is used.
DUNSNumber | string | 9 | Empty | The Dun & Bradstreet Number for the company. Available when the Human Resources module is used.
Vets100Number | string | 20 | Empty | The VETS-100 number for the company. Available when the Human Resources module is used.
AccountSegment Separator | string | 1 | - | The character to use as the separator in the account number.
IsValueAddedTaxReturn Enabled | boolean | N/A | False | Specifies whether VAT is
Options | CompanyOptions | N/A | N/A | Specifies options for the company.
IsWorkflowEnabled | boolean | N/A | N/A | Indicates whether workflow capability is enabled for the company.

Inherits from

BusinessObject


CompanyAddress

Description

A set of address information for a company within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CompanyAddressKey | N/A | N/A | The company address key object that uniquely identifies the set of address information.
ModifiedBy | string | N/A | N/A | The user who last modified the company address. This property is read-only.
InternetAddresses | InternetAddresses | N/A | N/A | The date the company address was modified. This property is read-only.
InternetAddresses | InternetAddresses | N/A | Empty | The set of Internet address information for the company address.

Inherits from

ExtendedBusinessAddress


CompanyAddressCriteria

Description

Specifies the criteria to use when retrieving a list of company address objects. Only company address objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID for the company address.
Name† | LikeRestrictionOfString | A string restriction specifying the name of the company.
ContactPerson† | LikeRestrictionOfString | A string restriction specifying the contact person.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the company address was modified.

Inherits from

Criteria


CompanyAddressKey

Description

Uniquely identifies a set of address information for a company.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | Specifies the ID of a set of address information for a company.

Inherits from

ReferenceKey


CompanyCriteria

Description

Specifies the criteria to use when retrieving a list of company objects. Only company objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | BetweenRestrictionOfNullableOfInt32 | A string restriction specifying the ID for the company.
Name† | LikeRestrictionOfString | A string restriction specifying the name of the company.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the company was created.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the company was modified.

Inherits from

Criteria


CompanyKey

Description

Uniquely identifies a company object.

Properties

Property | Type | Length | Default | Description
Id | int | N/A | 0 | The unique integer identifier assigned to the company.

Inherits from

OrganizationKey


Compensation

Description

Provides information about the values used to calculate a compensation amount for a job skill.

Properties

Property | Type | Length | Default | Description
CompensationPeriod | CompensationPeriod | N/A | 0 | A compensation period enumeration value that specifies the number of periods you use to calculate compensation amounts.
CompensationAmount | decimal | N/A | 0 | The amount per period value to use when calculating compensation.

Inherits from

BusinessObject


ConstituentAddress

Description

Extends the BusinessAddress class with properties that are specific to a constituent entity, such as a customer or vendor.

Properties

Property | Type | Length | Default | Description
UPSZone | string | 3 | Empty | The United Parcel Service zone or courier ID for the address.
ShippingMethodKey | ShippingMethodKey | N/A | Empty | The shipping method key object that specifies the shipping method to use for this address.
TaxScheduleKey | TaxScheduleKey | N/A | Empty | The tax schedule key object that specifies the tax schedule to use for this address.
CreatedDate | dateTime | N/A | Current system date | The date the address was created.
ModifiedDate | dateTime | N/A | Current system date | The date the address was modified. The value is in Coordinated Universal Time (UTC).
LastModifiedDate | dateTime | N/A | Current system date | The date the address was last modified. The value is in Coordinated Universal Time (UTC).
UserDefined1 | string | 20 | Empty | A user-defined value for the address.
UserDefined2 | string | 20 | Empty | A user-defined value for the address.
InternetAddresses | InternetAddresses | N/A | Empty | The set of Internet address information for the constituent address.

Inherits from

BusinessAddress


Context

Description

Defines the properties that specify how to execute a web service request.

Properties

Property

Type

Length

Default

Description

WorkOnBehalfOf

string

N/A

Empty

Used when the web service call should be made using the security settings for a different user than the one executing the web method. The property should be set to the other user's logon name in the form: DOMAIN\USERNAME

or COMPUTERNAME\USERNAME

If the web service is not being called on behalf of another user, this property should be left empty.

OrganizationKey

OrganizationKey

N/A

Empty

Specifies the unique identifier of the company where the operation should be executed. The web service will determine the appropriate company database to use.

A null value for OrganizationKey will represent the system database. (In Microsoft Dynamics GP this is the DYNAMICS database.)

CultureName

string

N/A

Empty

The name of the culture. For a list of valid CultureNames, see the Web Services for Microsoft Dynamics GP Programmer’s Guide.

CurrencyType

CurrencyType

N/A

Transactional

This property can be specified when documents are retrieved from the Dynamics GP service. It determines whether the MoneyAmount values in the document are returned in the Local currency or in the Transactional currency. This property should be specified only for documents that support multicurrency. A CurrencyType of Local will be used for all documents that do not support multicurrency.

RoleKey

RoleKey

N/A

Empty

If supplied, the role specified will be used used to choose the policy and appropriate behavior option for the web service call.

If you don’t supply a role key, the Dynamics GP web service will attempt to find a role for the user and company specified in the context object. If only one role can be found, that role will be used. If more than one role is found, or no roles are found, the default role will be used.

TenantName

String

100

Empty

If supplied, specifies the tenant for which the Microsoft Dynamics GP web service will be accessed.

If you don’t supply a tenant name, and the Dynamics GP web service is deployed in a multitenant configuration, the web service will attempt to determine the correct tenant to use. If the web service cannot resolve to a single tenant, an exception will be thrown.


CorporateAccount

Description

A corporate (national) account within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CustomerKey | N/A | N/A | The customer key that represents the controlling customer of the corporate (national) account.
AllowReceiptsFor Members | boolean | N/A | False | Specifies whether to allow receipts to be created for child customers of the corporate account. True specifies new cash receipts are allowed. False specifies they are not.
BaseCreditCheckOn ConsolidatedCorporate Account | boolean | N/A | False | Specifies whether to base credit checks on the parent customer’s credit limits. True specifies the current balance (used to compare to the credit limit) is the sum of the parent customer balance and all the child customer balances. False specifies credit checks will be performed on either the parent or child, depending on the customer a transaction is being entered for.
BaseFinanceChargeOn ConsolidatedCorporate Account | boolean | N/A | False | Specifies how finance charges will be assessed against the corporate account. True specifies that consolidated balances from all customers associated with the corporate account will be used. False specifies that finance charges will be assessed against each customer individually.
ApplyHoldActiveStatusOf ParentAcrossCorporate Account | boolean | N/A | False | Specifies whether the parent’s customer’s hold and inactive rules apply for all the child customers. True indicates the parent’s rules apply. False indicates the rules apply individually.
DefaultNationalAccount VendorForMember Refunds | boolean | N/A | False | Specifies how refunds are paid. True indicates refunds are paid to the vendor assigned to the parent customer of a corporate account. False indicates refunds are paid to each customer’s vendor.
Members | ArrayOfCorporateAccountMember | N/A | Empty | An array containing the customers that are included in the corporate account.

Inherits from

BusinessObject


CorporateAccountMember

Description

A customer that is part of a corporate (national) account.

Properties

Property | Type | Length | Default | Description
Key | CorporateAccountMemberKey | N/A | Empty | The corporate account member key object that specifies a child customer of the corporate account
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove the customer from the corporate account member list.

Inherits from

BusinessObject


CorporateAccountMemberKey

Description

Uniquely identifies a customer that is a member of a corporate (national) account.

Properties

Property | Type | Length | Default | Description
CorporateAccountKey | CustomerKey | N/A | Empty | A customer key object that specifies the parent customer of the corporate account.
CustomerKey | CustomerKey | N/A | Empty | A customer key object that identifies the customer that is a member of the corporate account.

Inherits from

ReferenceKey


CostCategoryKey

Description

Uniquely identifies a cost category object in the Project Accounting module within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The unique identifier assigned to a cost category.

Inherits from

ReferenceKey


CostPlus

Description

A project type in which the customer pays the actual cost plus a fee.

Properties

Property | Type | Length | Default | Description
Item | Choice | N/A | N/A | A choice type that contains a NoProfit, PercentOfActual, PercentOfBaseline, ProfitFixed, ProfitVariable, or TotalProfit amount.

Inherits from

Profit


CountryRegionCode

Description

Represents a country or region. The properties are read only.

Properties

Property | Type | Length | Default | Description
Key | CountryRegionCodeKey | 6 | N/A | The country/region code key object that uniquely identifies the country/region.
Description | string | 30 | Empty | A description of the country/region.
IsEuropeanUnionMember | boolean | N/A | False | Specifies whether the country/region is part of the European Union. True specifies it is part of the European Union. False specifies that it is not.

Inherits from

BusinessObject


CountryRegionCodeCriteria

Description

Specifies the criteria to use when retrieving a list of country/region code objects. Only country/region code objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID for the country/region code.
Description† | LikeRestrictionOfString | A string restriction specifying the description for the country/region code.

Inherits from

Criteria


CountryRegionCodeKey

Description

Uniquely identifies a country/region code object.

Properties

Property | Type | Length | Default | Description
Id | string | 6 | Empty | The unique identifier assigned to the country/region code.

Inherits from

ReferenceKey


CreditLimit

Description

Provides the underlying storage for instances of concrete customer credit limit and vendor credit limit types that derive from it.

Properties

Property | Type | Length | Default | Description
Item | Choice | N/A | N/A | A choice type that contains either a MoneyAmount or a CreditLimitSpecialAmount.

Examples

The following C# example demonstrates how to retrieve the Item property of a credit limit object and determine whether it is a money amount or a credit limit special amount. Note how the GetType() function is used to retrieve the underlying type of the Item property, and how the typeof() function is used to retrieve the types for the comparison operation.

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            CustomerCreditLimit creditLimit;
            MoneyAmount creditLimitAmount;
            CreditLimitSpecialAmount creditLimitSpecialAmount;

            // Create an instance of the web service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the web service
            context = new Context();

            // Specify which company (lesson company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Retrieve the customer object
            customer = wsDynamicsGP.GetCustomerByKey(customerKey, context);

            // Examine the credit limit information
            creditLimit = new CustomerCreditLimit();
            creditLimit = customer.CreditLimit;

            if (creditLimit.Item.GetType() == typeof(MoneyAmount))
            {
                creditLimitAmount = (MoneyAmount)creditLimit.Item;
                MessageBox.Show("Credit limit is a money amount of: " + creditLimitAmount.Value.ToString());
            }

            if (creditLimit.Item.GetType() == typeof(CreditLimitSpecialAmount))
            {
                creditLimitSpecialAmount = (CreditLimitSpecialAmount)creditLimit.Item;
                MessageBox.Show("Credit limit is special amount: " + creditLimitSpecialAmount.ToString());
            }
        }
    }
}

The following C# example shows how the Item property for a customer credit limit can be set to one of the values in the CreditLimitSpecialAmount enumeration. Notice how the Item property is cast to be of the proper type.

using System;
using System.Collections.Generic;
using System.Text;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            CustomerCreditLimit creditLimit;
            Policy customerUpdatePolicy;

            // Create an instance of the web service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the web service
            context = new Context();

            // Specify which company (lesson company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Get the UpdateCustomer policy
            customerUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCustomer", context);

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "ADVANCED0001";

            // Create the customer object
            customer = new Customer();
            customer.Key = customerKey;

            // Set the credit limit information
            creditLimit = new CustomerCreditLimit();
            creditLimit.Item = (CreditLimitSpecialAmount)CreditLimitSpecialAmount.NoCredit;
            customer.CreditLimit = creditLimit;

            // Update the customer
            wsDynamicsGP.UpdateCustomer(customer, context, customerUpdatePolicy);
        }
    }
}


Criteria

Description

Provides the underlying storage and comparison of instances of concrete criteria types that derive from it.

Properties

None


Currency

Description

A currency type in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the currency.
Description | string | 30 | Empty | The description of the currency.
Index | int | N/A | N/A | The index assigned to the currency. This value is used internally by Microsoft Dynamics GP.
Id | string | 15 | Empty | The string identifier assigned to the currency.
Symbol | string | 3 | Empty | The symbol to use for the currency.
SymbolLocation | RelativeLocation | N/A | Before Amount | Specifies where the currency symbol will be located for each currency value.
IncludeSpace | boolean | N/A | False | Specifies whether a space will be included between the currency symbol and the currency amount.
NegativeSymbol | NegativeSymbol | N/A | Negative Sign | Specifies the symbol to display for negative currency values.
NegativeSymbolLocation | RelativeLocation | N/A | Before Amount | Specifies where the negative symbol will be displayed for the currency value.
NegativeSymbolCurrencySymbolLocation | NegativeSymbolCurrencySymbolLocation | N/A | Before Currency Symbol | Specifies whether the negative symbol will be displayed before or after the currency symbol.
DecimalSymbol | DecimalSymbol | N/A | Period | Specifies the symbol to display to designate the decimal portion of a currency value.
DecimalPlaces | DecimalPlaces | N/A | Two | Specifies the number of decimal places used for the currency value.
ThousandsSymbol | ThousandsSymbol | N/A | Comma | Specifies the symbol to use to designate the thousands separator for the currency value.
UnitText | string | 25 | Empty | The text representation of the unit of the currency, such as the word “Dollars”.
UnitSubunitConnector Text | string | 25 | Empty | The text used to connect the unit and subunit amounts for the currency.
SubunitText | string | 25 | Empty | The text representation of the subunit of the currency, such as the word “Cents”.
LastModifiedDate | dateTime | N/A | Set to the system date | The date the currency was last modified. The value is in Coordinated Universal Time (UTC).
LastModifiedBy | string | N/A | N/A | Not implemented.

Inherits from

BusinessObject


CurrencyAccess

Description

Specifies whether a company has access to a specific currency in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CurrencyAccessKey | N/A | N/A | The currency access key object that specifies the company and currency for which currency access is being specified.
IsActive | boolean | N/A | False | Specifies whether the company has access to the currency. The value true indicates the company has access, while false indicates it does not.

Inherits from

BusinessObject


CurrencyAccessCriteria

Description

Specifies the criteria to use when retrieving a list of currency access objects. Only currency access objects that match the specified criteria wil be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
CompanyId† | BetweenRestrictionOfNullableOfInt32 | An integer restriction specifying the ID of the company.
CurrencyISOCode | LikeRestrictionOfString | A string restrictioning specifying the ISO code for the currency.

Inherits from

Criteria


CurrencyAccessKey

Description

Uniquely identifies a company and currency in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that uniquely identifies a currency.

Inherits from

ReferenceKey


CurrencyChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of currency objects that have changed. Only changed currency key objects that match the specified criteria wil be returned.

Properties

Property | Type | Description
IsoCode | BetweenRestrictionOfString | A string restriction specifying the ISO Code on the currency. For example, US dollars is USD.

Inherits from

BaseChangedKeyCriteria


CurrencyCriteria

Description

Specifies the criteria to use when retrieving a list of currency access objects. Only currency access objects that match the specified criteria wil be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ISOCode | LikeRestrictionOfString | A string restriction specifying the ISO Code on the currency. For example, US dollars is USD.
Id | LikeRestrictionOfString | A string restriction specifying the string identifier assigned to the currency.
Description† | LikeRestrictionOfString | A string restriction specifying the description of the currency.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the currency was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.

Inherits from

Criteria


CurrencyKey

Description

Uniquely identifies a currency in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ISOCode | string | 3 | N/A | The value used to identify the ISO Code on the currency. For example, US dollars is USD.

Inherits from

ReferenceKey


CurrencyPostingAccount

Description

The set of posting accounts associated with a specific currency in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CurrencyPostingAccountKey | N/A | N/A | The currency posting account key object that uniquely identifies the set of posting accounts for a currency.
RealizedGainGLAccount Key | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the realized gain account.
RealizedLossGLAccount Key | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the realized loss account.
UnrealizedGainGL AccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the unrealized gain account.
UnrealizedLossGL AccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the unrealized loss account.
FinancialOffsetGLAccount Key | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the financial offset account.
PurchasingOffsetGL AccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the purchasing offset account.
SalesOffsetGLAccount Key | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the sales offset account.
RoundingWriteOffGL AccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the rounding writeoff account.
RoundingDifferenceGL AccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the rounding difference account.

Inherits from

BusinessObject


CurrencyPostingAccountCriteria

Description

Specifies the criteria to use when retrieving a list of currency posting account objects. Only currency posting account objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Id | LikeRestrictionOfString | A string restriction specifying the ISO code of the currency posting account.

Inherits from

Criteria


CurrencyPostingAccountKey

Description

Uniquely identifies the set of posting accounts for a currency in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that specifies the currency for which the posting accounts are used.

Inherits from

ReferenceKey


Customer

Description

A customer within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer.
IsOnHold | boolean | N/A | False | The customer’s hold status. True indicates on hold. False indicates not on hold.
IsActive | boolean | N/A | True | Indicates whether the customer is active. True indicates active. False indicates inactive.
ShipCompleteOnly | boolean | N/A | False | Indicates whether the customer accepts partial shipments of Sales Order Processing documents. True indicates they accept only complete shipments. False indicates they accept partial shipments.
Name | string | 64 | Empty | The customer name.
Shortname | string | 15 | A shortened version of the value supplied for the Name property | A shortened version of the customer’s name.
StatementName | string | 64 | The same value supplied for the Name property | The customer’s name, as it should appear on statements.
ClassKey | CustomerClassKey | N/A | Empty | The customer class key object that specifies the customer class.
Priority | int | N/A | 1 | The priority assigned to the customer, used when allocating items for sales order documents. The value 1 indicates no priority has been assigned. The values 2 through 100 correspond to values 1 (highest priority) to 99 (lowest priority) in Dynamics GP.
DefaultAddressKey | CustomerAddressKey | N/A | N/A | The customer address key that specifies the primary address for the customer.
ShipToAddressKey | CustomerAddressKey | N/A | N/A | The customer address key that specifies the address to ship items to the customer.
BillToAddressKey | CustomerAddressKey | N/A | N/A | The customer address key that specifies the address to bill the customer.
StatementToAddressKey | CustomerAddressKey | N/A | N/A | The address key that specifies the address to send statements to the customer.
Comment1 | string | 30 | Empty | Comment field 1.
Comment2 | string | 30 | Empty | Comment field 2.
TradeDiscountPercent | Percent | N/A | 0 | A percent object that specifies the discount percentage to extend to the customer.
PaymentTermsKey | PaymentTermsKey | N/A | Empty | The payment terms key object that specifies the set of payment terms to use for the customer.
DiscountGracePeriod | int | N/A | 0 | The grace period (in days) for payment terms that use discounts.
DueDateGracePeriod | int | N/A | 0 | The grace period (in days) for payment terms that use due dates
PriceLevelKey | PriceLevelKey | N/A | Empty | The price level key object that specifies the price level used most often when selling to this customer.
Notes | string | 8000 | Empty | Text for the record-level note for the customer.
BalanceType | BalanceType | N/A | Open Item | The type of account the customer has.
FinanceCharge | MoneyPercentChoice | N/A | No finance charge | The type and amount of the finance charge for the customer. The finance chanrge can be a money amount or a percent.
MinimumPayment | MoneyPercentChoice | N/A | No minimum payment | The type and amount of the minimum payment for the customer. The minimum payment amount can be a money amount or a percent.
CreditLimit | CustomerCreditLimit | N/A | No credit | The customer credit limit object that specifies the credit limit.
MaximumWriteoff | MaximumWriteoff | N/A | Not allowed | Specifies whether writeoffs are allowed for the customer, and what the maximum amount of the writeoff can be.
AllowRevaluation | boolean | N/A | True | Specifies whether the customer is included in a sales revaluation. True specifies the customer will be included. False specifies the customer will not be included.
PostResultsTo | ReceivablesPostResultsTo | N/A | Receivables/Discount Account | Specifies where to post the sales revaluation results.
OrderFullfillment ShortageDefault | OrderFullfillmentShortage | N/A | None - Shortages handled manually | Specifies how to handle a shortage when filling an order for the customer.
IncludeInDemand Planning | boolean | N/A | True | Specifies whether the customer will be included in demand planning. True specifies the customer will be included. False specifies the customer will not.
PaymentCardAccount | PaymentCardAccount | N/A | Empty | The payment card account object that specifies the credit card used by the customer.
BankName | string | 30 | Empty | The name of the customer’s bank.
BankBranch | string | 20 | Empty | The name of the branch for the customer’s bank.
UserLanguageKey | LanguageKey | N/A | Empty | The language to use for this customer. Applies only if languages were set up using Language Maintenance in Microsoft Dynamics GP.
TaxExemptNumbers | ArrayOfString | 25 | Empty | The customer’s tax exemption numbers. The array can contain two elements.
TaxRegistrationNumber | string | 25 | Empty | The customer’s tax registration number.
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that specifies the ISO code of the currency typically used for the customer.
RateTypeKey | RateTypeKey | N/A | Empty | The rate type key object that specifies the rate type typically used for the customer.
StatementCycle | StatementCycle | N/A | Monthly | Specifies the statement cycle frequency for the customer.
HistoryOptions | HistoryOptions | N/A | Maintain history for all types | The history options object that specifies which types of history are maintained for the customer.
SendEmailStatements | boolean | N/A | False | Specifies whether statements can be sent to the customer through e-mail. True specifies e-mail can be used. False specifies it cannot. The StatementRecipients property specifies the e-mail address for the customer.
BankAccountKey | BankAccountKey | N/A | Empty | The bank account key object that specifies the ID of the bank account (checkbook) to use for cash transactions.
DefaultCashAccountType | ReceivablesCashAccountType | N/A | Checkbook | Specifies which Cash GL account to use for the customer's transactions. Customer specifies that the GL account in the CashGLAccount field will be used. Checkbook specifies the Cash GL account assigned to the BankAccount (checkbook) associated with the customer will be used.
CashGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which cash amounts for the customer will be posted.
AccountsReceivableGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which receivable amounts for the customer will be posted.
SalesGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which sale amounts for the customer will be posted.
CostOfGoodsSoldGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which cost of sales amounts for this customer will be posted.
InventoryGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which inventory amounts for this customer will be posted.
PaymentTermsDiscount TakenGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which terms discounts taken amounts for this customer will be posted.
PaymentTermsDiscount AvailableGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which terms discounts available amounts for this customer will be posted.
FinanceChargesGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which finance charge amounts for this customer will be posted.
WriteoffGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which written-off amounts for underpayments for this customer will be posted.
SalesOrderReturnsGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which sales order returns amounts for this customer will be posted.
OverpaymentWriteoff GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which writeoffs for overpayments from this customer will be posted.
StatementRecipients | EmailRecipients | N/A | N/A | An e-mail recipients object that specifies the e-mail addresses to which to send statements for the customer.
CreatedDate | dateTime | N/A | Current system date | The date the customer was created. This property is read-only.
ModifiedDate | dateTime | N/A | Current system date | The date the customer was modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
LastModifiedDate | dateTime | N/A | Current system date | The date the customer was modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
CorporateAccountKey | CustomerKey | N/A | Empty | If the customer is part of a corporate (national) account, the customer key that specifies the parent account. This property is read-only.
UserDefined1 | string | 50 | Empty | A user-defined field.
UserDefined2 | string | 50 | Empty | A user-defined field.
Addresses | ArrayOfCustomerAddress | N/A | Empty | An array containing the customer’s various addresses.

Inherits from

BusinessObject


CustomerAddress

Description

A set of address information for a customer within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CustomerAddressKey | N/A | N/A | The customer address key object that uniquely identifies the set of address information.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that specifies the salesperson associated with the set of address information.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that specifies the sales territory associated with the set of address information.
WarehouseKey | WarehouseKey | N/A | N/A | The warehouse site key object that specifies the warehouse associated with the set of address information.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove the address from the customer.

Inherits from

ConstituentAddress


CustomerAddressChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of address changes for a customer. Only changed customer address key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
AddressKeyId | BetweenRestrictionOfString | A string restriction specifying the address.
CustomerKeyId | BetweenRestrictionOfString | A string restriction specifying the customer.

Inherits from

BaseChangedKeyCriteria


CustomerAddressCriteria

Description

Specifies the criteria to use when retrieving a list of customer address summary objects. Only customer address summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Scope | CustomerScope | A CustomerScope enumeration value that specifies the level of filtering to use when returning customer data.
SalesPersonKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of a salesperson.
SalesTerritoryKeyId† | LikeRestrictionOfString | A string restriction specifiying the ID of the sales territory.
CustomerAddressKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the customer address.
CustomerKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the customer.
PhoneNumber | LikeRestrictionOfString | A string restriction specifying a telephone number.
Address | LikeRestrictionOfString | A string restriction specifying an address value.
City† | LikeRestrictionOfString | A string restriction specifying a city name.
State† | LikeRestrictionOfString | A string restriction specifying the postal abbreviation of the state.
PostalCode† | LikeRestrictionOfString | A string restriction specifying a postal code.

Inherits from

Criteria


CustomerAddressKey

Description

Uniquely identifies a set of address information for a customer.

Properties

Property | Type | Length | Default | Description
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies a customer.
Id | string | 15 | Empty | Specifies the ID of a set of address information for a customer.

Inherits from

ReferenceKey


CustomerAddressSummary

Description

A representation of the important details of a customer address within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | CustomerAddressKey | N/A | N/A | The customer address key object that uniquely identifies the set of address information.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that specifies the salesperson associated with the set of address information.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that specifies the sales territory associated with the set of address information.
WarehouseKey | WarehouseKey | N/A | N/A | The warehouse site key object that specifies the warehouse associated with the set of address information.

Inherits from

BusinessAddress


CustomerChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of customers that have changed. Only changed customer key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Id | BetweenRestrictionOfString | A string restriction specifying the customer.

Inherits from

BaseChangedKeyCriteria


CustomerClassKey

Description

Uniquely identifies a customer class in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier assigned to the customer class.

Inherits from

ReferenceKey


CustomerCreditLimit

Description

Defines properties to provide additional credit limit information for a customer when a specific credit limit amount is specified.

Properties

Property | Type | Length | Default | Description
Period | int | N/A | Empty | A value from 1 to 7 specifying an aging period defined in the Microsoft Dynamics GP Recievables setup.
PeriodAmount | MoneyAmount | N/A | 0 | The credit limit amount for the aging period specified. A warning will be displayed if a transaction is created that extends credit to this customer beyond the limit entered here for the specified aging period, and for all previous aging periods.

Inherits from

CreditLimit


CustomerCriteria

Description

Specifies the criteria to use when retrieving a list of customer summary objects. Only customer summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | BetweenRestrictionOfString | A string restriction specifying the ID for the customer.
Name† | LikeRestrictionOfString | A string restriction specifying the name of the customer.
IsActive | RestrictionOfNullableOfBoolean | A boolean restriction specifying the active status of the customer.
IsOnHold | RestrictionOfNullableOfBoolean | A boolean restriction specifying the hold status of the customer.
SalespersonId† | LikeRestrictionOfString | A string restriction specifying the salesperson associated with the customer.
ClassId† | LikeRestrictionOfString | A string restriction specifying the class associated with the customer.
CorporateAccountId† | LikeRestrictionOfString | A string restriction specifying the corporate account for the customer.
State† | LikeRestrictionOfString | A string restriction specifying the state for the customer.
PhoneNumber | LikeRestrictionOfString | A string restriction specifying the phone number for the customer.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the customer was created.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the customer was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the customer was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
Scope | CustomerScope | A property in criteria used to determine the level of filtering to be used when returning customer data.

Inherits from

Criteria


CustomerKey

Description

Uniquely identifies a customer object.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier assigned to the customer.

Inherits from

ReferenceKey


CustomerReceivablesSummary

Description

A representation of the important details of a customer receivables document within Microsoft Dynamics GP. A list of customer receivables summary objects is returned by the GetCustomerReceivablesSummaryList method.

Properties

Property | Type | Length | Default | Description
Key | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer.
Aging | AgingAmounts | N/A | N/A | The aging amounts object for the specified customer.
LastYear | SalesAmounts | N/A | N/A | A sales amount object that contains sales information for the previous year.
LifeToDate | SalesAmounts | N/A | N/A | A sales amount object that contains sales total information for the customer.
YearToDate | SalesAmounts | N/A | N/A | A sales amount object that contains sales information for the current year.
OnOrderAmount | MoneyAmount | N/A | 0 | The on order amount for the specified customer.
LastPaymentAmount | MoneyAmount | N/A | 0 | The amount of the customer’s most recent payment.
LastPaymentDate | dateTime | N/A | empty | The date of the customer’s last payment.
LastStatementAmount | MoneyAmount | N/A | 0 | The amount owed on the most recent statement that was sent to this customer.
LastStatementDate | dateTime | N/A | empty | The date of the most recent statement that was sent to this customer.
LastTransactionAmount | MoneyAmount | N/A | 0 | The amount of the last customer transaction.
LastTransactionDate | dateTime | N/A | empty | The date of the last customer transaction.

Inherits from

BusinessObject


CustomerReceivablesSummaryCriteria

Description

Specifies the criteria to use when retrieving a list of customer receivables summary objects. Only customer receivables summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
CustomerId | LikeRestrictionOfString | A string restriction that specifies the ID of the customer.
LastAgedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the last receivables aging was completed.
LastPaymentDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the last payment.
LastTransactionDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the last transaction.
SalespersonId | LikeRestrictionOfString | A string restriction specifying the salesperson associated with the customer.
Scope | CustomerScope | A property in criteria used to determine the level of filtering to be used when returning customer receivables data.

Inherits from

Criteria


CustomerSummary

Description

A representation of the important details of a customer within Microsoft Dynamics GP. A list of customer summary objects is returned by the GetCustomerList method.

Properties

Property | Type | Length | Default | Description
Key | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer.
Name | string | 64 | Empty | The customer name.
IsActive | boolean | N/A | True | Indicates whether the customer is active. True indicates active. False indicates inactive.
IsOnHold | boolean | N/A | False | The customer’s hold status. True indicates on hold. False indicates not on hold.
CustomerClassKey | CustomerClassKey | N/A | Empty | The customer class key object that specifies the customer class.
CorporateAccountKey | CustomerKey | N/A | Empty | If the customer is part of a corporate (national) account, the customer key that specifies the parent account.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that specifies the salesperson associated with the customer.
State | string | 29 | Empty | The customer’s state.
PhoneNumbers | ArrayOfPhoneNumber | N/A | Empty | An array containing the customer’s various telephone numbers.
CreatedDate | dateTime | N/A | Current system date | The date the customer was created.
ModifiedDate | dateTime | N/A | Current system date | The date the customer was modified. The value is in Universal Coordinated Time (UTC).
LastModifiedDate | dateTime | N/A | Current system date | The date the customer was modified. The value is in Coordinated Universal Time (UTC).


DepartmentKey

Description

Uniquely identifies a department within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 6 | N/A | The string value that uniquely identifies the department.

Inherits from

ReferenceKey


Distribution

Description

Defines a general ledger distribution.

Properties

Property | Type | Length | Default | Description
DistributionTypeKey | DistributionTypeKey | N/A | Empty | The distribution type key that uniquely identiries the type of distribution.
Reference | string | 30 | Empty | The reference to post as the general ledger distribution reference for the account.
GLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the account to which the amount for this distribution line will be posted.
DebitAmount | Amount | N/A | 0 | The debit amount that will be distributed to the account for each distribution line.
CreditAmount | Amount | N/A | 0 | The credit amount that will be distributed to the account for each distribution line.

Inherits from

BusinessObject


DistributionTypeKey

Description

Uniquely identifies the type of distribution for a distribution line.

Properties

Property | Type | Length | Default | Description
Id | int | N/A | N/A | Identifies the distribution type for the GL accounts on the distribution line. The valid distribution types are: 1 = Sales 2 = Accounts Receivable 3 = Cash 4 = Discount Taken 5 = Discount Available 6 = Trade 7 = Freight 8 = Miscellaneous 9 = Tax 10 = Markdown 11 = Commission Expense 12 = Commissions Paid 13 = Other 14 = COGS 15 = Inventory 16 = Returned 17 = In Use 18 = In Service 19 = Damged 20 = Unit 21 = Deposits 22 = Round 23 = Rebate

Inherits from

ReferenceKey


DivisionKey

Description

Uniquely identifies a division within Microsoft Dynamics GP. Employees can be assigned to a specific division. This field is visible in Microsoft Dynamics GP when the Human Resources module is loaded.

Properties

Property | Type | Length | Default | Description
Id | string | 6 | Empty | The string that identifies the division.

Inherits from

ReferenceKey


DynamicsOnlineConfiguration

Description

Defines properties for the online services available in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CustomerNumber | CustomerKey | N/A | N/A | The customer number.
CompanyName | string | 64 | N/A | The name of the company for the Dynamics Online Configuration.
CompanyKey | CompanyKey | N/A | N/A | The company for the online configuration.
OnlineCommerceAccountNumber | string | 50 | N/A | The Online Commerce account number.
OnlineCommerceOrganizationID | string | 100 | N/A | The organization ID.
ECommOrderType | SalesDocumentKey | N/A | N/A | Specifies the order type.
ECommInvoiceType | SalesDocumentKey | N/A | N/A | Specifies the invoice type.
IsOnlineCommerceActive | boolean | N/A | N/A | Indicates whether online commerce is active for the company.
IsPaymentServicesActive | boolean | N/A | N/A | Indicates whether payment services is active for the company.
PaymentServicesId | string | 50 | N/A | The Payment Services ID.
DynamicsOnlineCardType | PaymentCardTypeKey | N/A | N/A | The credit card type.
OnlineCertificate | string | 500 | N/A | Stores the online certificate.

Inherits from

BusinessObject


DynamicsOnlineConfigurationCriteria

Description

Specifies the criteria to use when retrieving a list of Dynamics Online Configuration objects. Only Dynamics Online Configuration objects that match the specified criteria will be returned.

Properties

Property | Type | Description
IsCommerceServicesActive | RestrictionOfNullableOfBoolean | A boolean restriction specifying the active state of Commerce Services.
IsPaymentServicesActive | RestrictionOfNullableOfBoolean | A boolean restriction specifying the active state of Payment Services.

Inherits from

Criteria


EmailRecipients

Description

A set of e-mail addresses to which a document (such as a statement) will be sent.

Properties

Property | Type | Length | Default | Description
To | ArrayOfString | 80 | Empty | The list of e-mail addresses to which the message will be sent.
CC | ArrayOfString | 80 | Empty | The list of e-mail addresses to which the message will be sent as a carbon copy.
BCC | ArrayOfString | 80 | Empty | The list of e-mail addresses to which the message will be sent as a blind carbon copy.


Employee

Description

An employee within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
EmployeeKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the employee.
ClassKey | EmployeeClassKey | N/A | Empty | The employee class key object that specifies the employee class.
IsActive | boolean | N/A | True | Indicates whether the employee is active. True indicates active. False indicates inactive.
Name | Name | N/A | N/A | The name object that specifies the names for the employee.
DefaultAddressKey | EmployeeAddressKey | N/A | N/A | The employee address key that specifies the primary address for the employee.
TaxIdentifier | string | 15 | N/A | The government issued tax number for the employee. In the United States, this is the Social Security Number.
BirthDate | dateTime | N/A | Empty | The employee’s birth date.
GenderCode | Gender | N/A | Not applicable | The gender of the employee.
Ethnicity | Ethnicity | N/A | Not applicable | The ethnicity of the employee.
DoesCalculateMinimumWageBalance | boolean | N/A | False | Indicates whether the minimum wage balance should be calculated for the employee. True indicates it should. False indicates it should not.
DivisionKey | DivisionKey | N/A | N/A | The division key object that specifies the division the employee is assigned to.
DepartmentKey | DepartmentKey | N/A | N/A | The department key object that specifies the department the employee is assigned to.
PositionKey | PositionKey | N/A | N/A | The position key object that specifies the position the employee is assigned to.
SupervisorKey | SupervisorKey | N/A | N/A | The supervisor key object that specifies the supervisor for the employee.
CompanyAddressKey | CompanyAddressKey | N/A | Empty | The company address key object that specifies the address for the employee.
DefaultCashAccountFrom Type | CashAccountFromType | N/A | Checkbook | Specifies where to post the net pay for the employee.
GLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account key object that specifies the cash account to which net pay for the employee is posted.
WorkHoursPerYear | int | N/A | 0 | The number of hours the employee typically works in a year.
EmploymentStartDate | dateTime | N/A | N/A | The date the employee started working at the company.
EmployeeInactivatedDate | dateTime | N/A | N/A | The date the employee was inactivated.
ReasonEmployee Inactivated | string | 30 | Empty | The reason the employee was inactivated.
MinimumNetPay | MoneyAmount | N/A | 0 | The minimum amount that the employee must receive in each paycheck. If the paycheck amount is below the minimum net pay after tax sheltered annuities and taxes are deducted, Payroll deductions aren't taken.
SUTAStateKey | SUTAStateKey | N/A | Empty | The code for the state to which unemployment taxes will be paid for this employee.
WorkersCompensation Key | WorkersCompensationKey | N/A | Empty | The code for the workers' compensation classification that applies to the employee.
Vacation | Vacation | N/A | Empty | Specifies vacation information for the employee.
SickTime | SickTime | N/A | Empty | Specifies sick time information for the employee.
UserDefined1 | string | 20 | Empty | User-defined data for the employee.
UserDefined2 | string | 20 | Empty | User-defined data for the employee.
EmploymentType | EmploymentType | N/A | Full Time Regular | The type of employment for the employee.
MaritalStatus | MaritalStatus | N/A | Not applicable | The marital status for the employee.
BenefitStartDate | dateTime | N/A | Empty | The date benefits start for the employee.
LastWorkedDate | dateTime | N/A | Empty | The last day the employee worked at the company.
DayOfBirth | int | N/A | N/A | The day of the month of the employee’s birthday.
MonthOfBirth | ISO8061Month | N/A | N/A | The month of the employee’s birthday.
Spouse | Spouse | N/A | Empty | Information about the spouse of the employee.
HRStatus | HRStatus | N/A | N/A | The HR status of the employee.
Review | Review | N/A | Empty | Information about the review status of the employee.
IsDisabled | boolean | N/A | False | Indicates whether the employee is disabled. True indicates the employee is. False indicates the employee is not.
IsVeteran | boolean | N/A | False | Indicates whether the employee is a military veteran. True indicates the employee is. False indicates the employee is not.
IsVietnamEraVeteran | boolean | N/A | False | Indicates whether the employee is a military veteran from the Vietnam era. True indicates the employee is. False indicates the employee is not.
IsDisabledVeteran | boolean | N/A | False | Indicates whether the employee is a disabled veteran. True indicates the employee is. False indicates the employee is not.
IsUnionEmployee | boolean | N/A | False | Indicates whether the employee is in a union. True indicates the employee is. False indicates the employee is not.
IsSmoker | boolean | N/A | False | Indicates whether the employee is a smoker. True indicates the employee is. False indicates the employee is not.
IsUnitedStatesCitizen | boolean | N/A | False | Indicates whether the employee is a US citizen. True indicates the employee is. False indicates the employee is not.
IsI9Verified | boolean | N/A | False | Indicates whether the I9 form for the employee has been verified. True indicates it has been. False indicates it has not.
I9RenewDate | dateTime | N/A | Empty | The date the I9 for the employee is to be renewed.
PrimaryPayCodeKey | PrimaryPayCodeKey | N/A | Empty | The primary pay code for the employee.
ModifiedBy | string | 15 | Empty | Contains the login ID of the user who last modified the employee record.
ModifiedDate | dateTime | N/A | Empty | Contains the date the employee record was last modified.
UnionKey | UnionKey | N/A | Empty | The union key object that specfies the union the employee belongs to.
IsOtherVeteran | boolean | N/A | False | Indicates whether the employee is a veteran who served in a war other than the Vietnam War, or served in a campaign or expedition and was awarded a campaign badge, service medal, or an expeditionary medal. True indicates the employee is. False indicates the employee is not.
MilitaryDischargeDate | dateTime | N/A | Empty | The date the employee was discharged from the military.
BenefitExpiration | dateTime | N/A | Empty | Specifies the date that benefits expire.
RateClass | string | 15 | Empty | Specifies the rate class for the employee.
FederalClass | string | 15 | Empty | Specifies the federal class code for the employee.
Status | string | 15 | Empty | Specifies the status of the employee.
Addresses | ArrayOfEmployeeAddress | N/A | N/A | The collection of addresses for the employee.

Inherits from

BusinessObject


EmployeeAddress

Description

Extends the International Address class with properties that are specific to an employee address.

Properties

Property | Type | Length | Default | Description
Key | EmployeeAddressKey | N/A | N/A | The employee address key object that uniquely identifies the employee address.
County | string | 60 | Empty | The county for the address.
InternetAddresses | InternetAddresses | N/A | N/A | An InternetAddress object that specifies the set of Internet addresses for an employee.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove the address from the customer.

Inherits from

InternationalAddress


EmployeeAddressCriteria

Description

Specifies the criteria to use when retrieving a list of employee address summary objects. Only employee address summary objects that match the specified criteria will be returned. For the best performance, create criteria that use only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Scope | EmployeeScope | Specifies the EmployeeScope enumeration value that determines the level of filtering to use when retrieveing employee data.
EmployeeKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the employee
EmployeeAddressKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the employee address information.
PhoneNumber | LikeRestrictionOfString | A string restriction specifying a telephone number.
Address | LikeRestrictionOfString | A string restriction specifying address information.
City† | LikeRestrictionOfString | A string restriction specifying the name of a city.
State† | LikeRestrictionOfString | A string restriction specifying a state.
PostalCode† | LikeRestrictionOfString | A string restriction specifying a postal code value.

Inherits from

Criteria


EmployeeAddressKey

Description

Uniquely identifies an employee address for an employee.

Properties

Property | Type | Length | Default | Description
EmployeeKey | EmployeeKey | 15 | N/A | Specifies the employee that the employee address is associated with.
Id | string | 15 | Empty | Uniquely identifies the employee address.

Inherits from

ReferenceKey


EmployeeAddressSummary

Description

A representation of the important details of an employee address within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | EmployeeAddressKey | N/A | N/A | The employee address key object that uniquely identifies the employee address.
County | string | 60 | Empty | The county for the address.

Inherits from

InternationalAddress


EmployeeApplicableTaxes

Description

Provides additional tax information for an employee.

Properties

Property | Type | Length | Default | Description
IsFederalTaxApplied | boolean | N/A | False | Specifies whether wages are subject to federal tax.
IsSocialSecurityApplied | boolean | N/A | False | Specifies whether wages are subject to Social Security tax.
IsMedicareApplied | boolean | N/A | False | Specifies whether wages are subject to Medicare tax.
IsStateTaxApplied | boolean | N/A | False | Specifies whether wages are subject to state tax.
IsLocalTaxApplied | boolean | N/A | False | Specifies whether wages are subject to local tax.
IsFutaApplied | boolean | N/A | False | Specifies whether wages are subject to federal unemployment tax.
IsSutaApplied | boolean | N/A | False | Specifies whether wages are subject to state unemployment tax.
SutaState | string | 2 | Empty | Specifies the state for which unemployment taxes are collected.


EmployeeClassKey

Description

Uniquely identifies an employee class.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The string that uniquely identifies the employee class.

Inherits from

ReferenceKey


EmployeeCriteria

Description

Specifies the criteria to use when retrieving a list of employee summary objects. Only employee summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
EmployeeKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the employee.
FamilyName† | LikeRestrictionOfString | A string restriction specifying the family name (last name) of the employee.
GivenName† | LikeRestrictionOfString | A string restriction specifying the given name (first name) of the employee.
EmployeeClassId† | LikeRestrictionOfString | A string restriction specifying the class of the employee.
PositionId | LikeRestrictionOfString | A string restriction specifying the position of the employee.
DivisionId† | LikeRestrictionOfString | A string restriction specifying the division of the employee.
WorkersCompensationId | LikeRestrictionOfString | A string restriction specifying the workers compensation ID.
DepartmentId† | LikeRestrictionOfString | A string restriction specifying the department ID.
SupervisorId† | LikeRestrictionOfString | A string restriction specifying the supervisor ID.
CompanyAddressId | LikeRestrictionOfString | A string restriction specifying the company address ID.
IsActive† | RestrictionOfNullableOfBoolean | A boolean restriction specifying the active status of the employee.
Scope | EmployeeScope | A property in criteria used to determine the level of filtering to be used when returning employee data.

Inherits from

Criteria


EmployeeFlatTaxRates

Description

Provides flat tax rate information for employees.

Properties

Property | Type | Length | Default | Description
State | decimal | N/A | N/A | Specifies the state flat tax rate.
Federal | decimal | N/A | N/A | Specifies the federal flat tax rate.


EmployeeKey

Description

Uniquely identifies an employee in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier assigned to the employee.

Inherits from

ReferenceKey


EmployeePayCode

Description

Provide pay information for an employee.

Properties

Property | Type | Length | Default | Description
EmployeePayCodeKey | EmployeePayCodeKey | N/A | N/A | A key that uniquely identifies an employee pay code object.
IsInactive | boolean | N/A | False | Specifies whether the employee pay code is inactive.
PayType | EmployeePayTypes | N/A | N/A | An EmployeePayTypes enumeration value specifying a pay type.
PayPeriod | CompensationPeriod | N/A | N/A | A CompensationPeriod enumeration value specifying the length of the pay period.
IsTaxable | boolean | N/A | True | Specifies whether the employee wages are taxable.
PayRate | decimal | N/A | N/A | Specifies the amount of the employee pay rate.
PayUnit | string | 25 | N/A | Specifies the pay unit for the employee.
W2BoxesLabels | EmployeeW2Boxes | N/A | N/A | An object that provides additional W-2 information for the employee.
BasePayRecord | PayCodeKey | N/A | N/A | Uniquely identifies the pay code object.
PayUnitPeriod | CompensationPeriod | N/A | N/A | A CompensationPeriod enumeration value specifying the length of the pay unit.
PayPerPeriod | decimal | N/A | N/A | Specifies the amount of the employee pay per period.
MaxPayPerPeriod | decimal | N/A | N/A | Specifies the maximum payment amount for the employee in a period.
TipType | EmployeeTipType | N/A | N/A | An EmployeeTipType enumeration value specifying how the employee receives tips.
PayAdvance | decimal | N/A | N/A | The amount of a pay advance.
IsReportAsWages | boolean | N/A | N/A | Specifies whether the employee reports pay as wages.
ApplicableTaxes | EmployeeApplicableTaxes | N/A | N/A | An object that provides additional tax information for the employee.
Notes | string | 8000 | Empty | Specifies additional information for the employee pay code.
IsDataEntry | boolean | N/A | N/A | Specifies whether data entry is required.
PayStep | EmployeePayStep | N/A | N/A | An object that provides additional information about employee pay changes.
FlatTaxRates | EmployeeFlatTaxRates | N/A | N/A | An object that provides additional tax information about employee pay.
IsVacationAccrued | boolean | N/A | N/A | Specifies whether vacation time is accrued.
IsSickTimeAccrued | boolean | N/A | N/A | Specifies whether sick time is accrued.
ShiftCode | string | 6 | N/A | Specifies the employee shift code.
PayFactor | decimal | N/A | N/A | Specifies the amount of the pay factor for the employee.
WorkersComp | string | 6 | Empty | Specifies the worker compensation code.
PayAdvanceTaken | decimal | N/A | N/A | Specifies whether a pay advance has been taken.
BasedOnRate | decimal | N/A | False | Specifies the amount of the based-on rate.
IsPrimaryPayRecord | boolean | N/A | False | Specifies whether this is the primary pay record for an employee.

Inherits from

BusinessObject


EmployeePayCodeCriteria

Description

Specifies the criteria to use when retrieving a list of employee pay code summary objects. Only employee pay code summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
EmployeeKeyId† | LikeRestrictionOfString | A string restriction specifying an employee ID.
PayCodeKeyId† | LikeRestrictionOfString | A string restriction specifying a pay code ID.
IsInactive | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the employee pay code is active or inactive.
PayPeriod | ListRestrictionOfNullableOfCompensationPeriod | A restriction specifying the length of the pay period.
IsTaxable | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether employee pay is taxable.
PayRate | BetweenRestrictionOfNullableOfDecimal | A decimal restiction that specifies a pay range.
PayType† | ListRestrictionOfNullableOfEmployeePayTypes | A restriction specifying pay type.

Inherits from

Criteria


EmployeePayCodeKey

Description

Uniquely identifies an employee pay code.

Properties

Property | Type | Length | Default | Description
EmployeeKey | EmployeeKey | N/A | N/A | An EmployeeKey that uniquely identifies an employee.
PayCodeKey | PayCodeKey | N/A | N/A | A PayCodeKey that uniquely identifies a pay code.

Inherits from

ReferenceKey


EmployeePayCodeSummary

Description

A representation of the important details of an employee pay code within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
EmployeePayCodeKey | EmployeePayCodeKey | N/A | N/A | A key that uniquely identifies an employee pay code object.
IsInactive | boolean | N/A | False | Specifies whether the employee pay code is inactive.
PayType | EmployeePayTypes | N/A | N/A | An EmployeePayTypes enumeration value specifying a pay type.
PayPeriod | CompensationPeriod | N/A | N/A | A CompensationPeriod enumeration value specifying the length of the pay period.
IsTaxable | boolean | N/A | True | Specifies whether the employee wages are taxable.
PayRate | decimal | N/A | N/A | Specifies the amount of the employee pay rate.
PayUnit | string | 25 | N/A | Specifies the pay unit for the employee.


EmployeePayStep

Description

Provides pay step information for an employee pay code.

Properties

Property | Type | Length | Default | Description
PayStepKey | PayStepKey | N/A | N/A | A key that uniquely identifies the pay step.
Step | int | N/A | 0 | Specifies the pay step value for the employee.
EffectiveDate | dateTime | N/A | Empty | Specifies the effective date of the pay step.
StepFTE | decimal | N/A | 0 | Specifies the amount of the pay adjustment for full-time and non-full-time employees. The typical value for an FTE is 1.
BasedOn | EmployeeBaseStepIncreasedOn | N/A | N/A | EmployeeBaseStepIncreaseOn enumeration value that specifie when the step occurs.


EmployeeSummary

Description

A representation of the important details of an employee within Microsoft Dynamics GP. A list of employee summary objects is returned by the GetEmployeeList method.

Properties

Property | Type | Length | Default | Description
EmployeeKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the employee.
ClassKey | EmployeeClassKey | N/A | Empty | The employee class key object that specifies the employee class.
Name | Name | N/A | N/A | The name object that specifies the names for the employee.
DivisionKey | DivisionKey | N/A | N/A | The division key object that specifies the division the employee is assigned to.
DepartmentKey | DepartmentKey | N/A | N/A | The department key object that specifies the department the employee is assigned to.
PositionKey | PositionKey | N/A | N/A | The position key object that specifies the position the employee is assigned to.
SupervisorKey | SupervisorKey | N/A | N/A | The supervisor key object that specifies the supervisor for the employee.
WorkersCompensation Key | WorkersCompensationKey | N/A | Empty | The code for the workers' compensation classification that applies to the employee.
CompanyAddressKey | CompanyAddressKey | N/A | Empty | The company address key object that specifies the address for the employee.
IsActive | boolean | N/A | True | Indicates whether the employee is active. True indicates active. False indicates inactive.


EmployeeW2Boxes

Description

Provides additional tax information to use with an employee pay code.

Properties

Property | Type | Length | Default | Description
W2BoxNumber_1 | int | N/A | 0 | Specifies a special W-2 box for the employee pay code.
W2BoxNumber_2 | int | N/A | 0 | Specifies a special W-2 box for the employee pay code.
W2BoxNumber_3 | int | N/A | 0 | Specifies a special W-2 box for the employee pay code.
W2BoxNumber_4 | int | N/A | 0 | Specifies a special W-2 box for the employee pay code.
W2BoxLabel_1 | string | 6 | Empty | Specifies the label for the special W-2 box used for the employee pay code.
W2BoxLabel_2 | string | 6 | Empty | Specifies the label for the special W-2 box used for the employee pay code.
W2BoxLabel_3 | string | 6 | Empty | Specifies the label for the special W-2 box used for the employee pay code.
W2BoxLabel_4 | string | 6 | Empty | Specifies the label for the special W-2 box used for the employee pay code.


ExceptionInformation

Description

A set of information about an exception. An ExceptionInformation object contains the base exception details for the exception that created a logged exception. An ExceptionInformation object may also contain another ExceptionInformation object that specifies its parent exception.

Properties

Property | Type | Length | Default | Description
ExceptionType | string | N/A | N/A | Specifies the exception type.
HelpLink | string | N/A | Empty | Specifies the help file associated with the exception.
InnerException | ExceptionInformation | N/A | N/A | An exception information object that specifies the exception that caused this exception.
Message | string | N/A | N/A | A text message that describes the exception.
Source | string | N/A | N/A | Specifies the application or object that caused the exception.
StackTrace | string | N/A | N/A | Describes the frames on the call stack at the point where the exception occurred.
TargetSite | string | N/A | Empty | Specifies the web method.


ExtendedBusinessAddress

Description

Extends the BusinessAddress class with a property to store the county specific to the adress.

Properties

Property | Type | Length | Default | Description
County | string | 60 | Empty | The county for the address.

Inherits from

BusinessAddress


Extension

Description

Additional data that is being included with a business object. Third-party developers use Extension objects to add additional data for business objects.

Properties

Property | Type | Length | Default | Description
ExtensionId | string | N/A | Empty | The string value that uniquely identifies the extension object. Typically, it will describe the content in the extension.
DocExtension | XML element | N/A | Empty | An XML element that contains the additional data that is being included in the extension. When the application accessing the web service retrieves the business object, it must process this XML element to extract data from it. When the application accessing the web service creates or updates the business object, it must properly form this XML element so it can be saved in the database. The developer of the extension is responsible for documenting the XML element’s format.


ExtensionList

Description

The collection of extension objects available with each business object. Typically, the extension objects contain additional data for a specific business object.

Properties

Property | Type | Length | Default | Description
Extension | Extension | N/A | N/A | An extension object in the collection.


Fee

Description

Defines a fee item in the Inventory module in Microsoft Dynamic GP.

Properties

Inherited from base class

Inherits from

Item


FeeCriteria

Description

Specifies the criteria to use when retrieving a list of fee item summary objects. Only fee item summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Type | ListRestrictionOfNullableOfFeeType | A list restriction specifying the type of fee item.

Inherits from

ItemCriteriaBase


FeeSummary

Description

A representation of the important details of a fee item within Microsoft Dynamics GP. A list of fee item summary objects is returned by the GetFeeList method.

Properties

Property | Type | Length | Default | Description
Type | FeeType | N/A | Empty | Identifies the type of fee item.

Inherits from

ItemSummaryBase


FixedPrice

Description

A project type in which the customer pays a predetermined amount for the entire project.

Properties

Property | Type | Length | Default | Description
Item | Choice | N/A | N/A | A choice type that contains a NoProfit, PercentOfBaseline, ProfitFixed, or TotalProfit amount.

Inherits from

Profit


GLAccount

Description

Defines the common properties for all general ledger accounts within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the GL account number.
Alias | string | 20 | Empty | The short description used to identify a GL account.
Type | GLAccountType | N/A | N/A | Identifies the type of GL account.
IsActive | boolean | N/A | True | Indicates whether the GL account is active.
Description | string | 50 | Empty | The description of the GL account.
CreatedDate | dateTime | N/A | N/A | The date the GL account was created. This property is read-only.
ModifiedDate | dateTime | N/A | N/A | The date the GL account was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.

Inherits from

BusinessObject


GLAccountCategory

Description

A category used to group accounts together in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | GLAccountCategoryKey | N/A | N/A | The GL account category key object that uniquely identifies the GL account category.

Inherits from

ReferenceKey


GLAccountCategoryKey

Description

Uniquely identifies a GL account category in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 50 | Empty | A string that identifies the GL account category.


GLAccountCriteria

Description

Specifies the criteria to use when retrieving a list of GL account summary objects. Only GL account summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
AccountType | ListRestrictionOfNullableOfGLAccountSummaryType | A list restriction specifying the type of general ledger account.

Inherits from

GLAccountCriteriaBase


GLAccountCriteriaBase

Description

Specifies the base set of criteria to use when retrieving GL account summary objects. Only GL accounts that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the GL account was created.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the GL account was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
IsActive | RestrictionOfNullableOfBoolean | A boolean restriction specifying the active status of the GL account.
GLAccountId | LikeRestrictionOfString | A string restriction specifying the ID of the GL account.
Description† | LikeRestrictionOfString | A string restriction specifying the description of the GL account.
Alias† | LikeRestrictionOfString | A string restriction specifying the alias of the GL account.

Inherits from

Criteria


GLAccountCurrency

Description

Defines the relationship between an GL account and a currency in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | GLAccountCurrencyKey | N/A | Empty | The GL account currency key object that uniquely identifies the GL account currency.

Inherits from

BusinessObject


GLAccountCurrencyKey

Description

Uniquely identifies a GL account currency in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
AccountKey | GLAccountNumberKey | N/A | Empty | The GL account key object that uniquely identifies the GL account.
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that uniquely identifies the the currency.

Inherits from

ReferenceKey


GLAccountFormat

Description

Defines the structure of one segment of the general ledger account number for a particular company as it was setup when the company was created within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | GLAccountFormatKey | N/A | N/A | The GL account format key object that uniquely identifies the GL account format.
SegmentName | string | N/A | N/A | The name of the segment.
MaximumSegment Length | int | N/A | N/A | The maximum length for the segment.
SegmentLength | int | N/A | N/A | The length of the segment.
IsMainSegment | boolean | N/A | N/A | Identifies the segment that is the main segment.
UserDefinedSegment | int | N/A | N/A | Defines the additional sorting that can be set.

Inherits from

BusinessObject


GLAccountFormatCriteria

Description

Specifies the criteria to use when retrieving a list of GL account format objects.

Properties

None

Inherits from

Criteria


GLAccountFormatKey

Description

Uniquely identifies a GL account format object.

Properties

Property | Type | Length | Default | Description
Id | int | N/A | N/A | Identifies the segment number.

Inherits from

ReferenceKey


GLAccountNumberKey

Description

Uniquely identifies a GL account number object.

Properties

Property | Type | Length | Default | Description
Id | string | Determined by GLAccountFormat | N/A | A string value that identifies a GL account number.
IsEncrypted | boolean | N/A | N/A | Indicates when the GL account number is encrypted. This property is read-only.

Inherits from

ReferenceKey


GLAccountSummary

Description

A representation of the important details of a GL account within Microsoft Dynamics GP. A list of GL account summary objects is returned by the GetGLAccountList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
AccountType | GLAccountSummaryType | N/A | N/A | Identifies the type of GL account.

Inherits from

GLAccountSummaryBase


GLAccountSummaryBase

Description

Defines the common properties for the GL account summary objects returned by the Get List operation. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the GL account number.
Alias | string | 20 | N/A | The short description used to identify a GL account.
IsActive | boolean | N/A | True | Indicates whether the GL account is active.
Description | string | 50 | Empty | The description of the GL account.
CreatedDate | dateTime | N/A | N/A | The date the GL account was created.
ModifiedDate | dateTime | N/A | N/A | The date the GL account was last modified.


GLAllocationDistributionAccountKey

Description

Uniquely identifies the GL allocation distribution account object.

Properties

Property | Type | Length | Default | Description
AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the GL account number.
DistributionAccount Key | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the GL distribution account number.

Inherits from

ReferenceKey


GLFinancialAccount

Description

Defines the properties common to a GL financial account in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PostInventoryIn | PostingLevel | N/A | N/A | Specifies how much detail to post to General Ledger from Inventory.
PostPayrollIn | PostingLevel | N/A | N/A | Specifies how much detail to post to General Ledger from Payroll.
PostPurchasingIn | PostingLevel | N/A | N/A | Specifies how much detail to post to General Ledger from Purchasing.
PostSalesIn | PostingLevel | N/A | N/A | Specifies how much detail to post to General Ledger from Sales.

Inherits from

GLAccount


GLFixedAllocationAccount

Description

Defines a GL fixed allocation account in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Distributions | ArrayOfGLFixedAllocationDistributionAccount | N/A | N/A | A collection of fixed allocation distribution account instances.

Inherits from

GLFinancialAccount


GLFixedAllocationAccountCriteria

Description

Specifies the criteria to use when retrieving a list of GL fixed allocation account summary objects. Only GL fixed allocation account summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

GLAccountCriteriaBase


GLFixedAllocationAccountSummary

Description

A representation of the important details of a GL fixed allocation account within Microsoft Dynamics GP. A list of GL fixed allocation account summary objects is returned by the GetGLFixedAllocationAccountList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

GLAccountSummaryBase


GLFixedAllocationDistributionAccount

Description

Defines a GL fixed allocation distribution account in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | GLAllocationDistributionAccountKey | N/A | N/A | The GL allocation distribution account key object that uniquely identifies the GL allocation distribution account.
Percentage | Percent | N/A | N/A | The percentage of the total transaction amount to be allocated to each allocation distribution account. The percentages entered for all distribution accounts must total 100% to post transactions to the account.

Inherits from

BusinessObject


GLIntercompany

Description

Defines the company and journal ID that originated the intercompany transaction. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | CompanyKey | N/A | N/A | The company key object that uniquely identifies the company.
OriginalJournalId | int | N/A | N/A | The ID of the originating journal.


GLOriginatingDocument

Description

Defines the properties of the originating document of the GL transaction. The properties are read-only.

Properties

Property | Type | Length | Default | Description
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted.
PostedDate | dateTime | N/A | N/A | The date the original document was posted.
Series | SeriesType | N/A | N/A | Describes at a high level the originating document.


GLOriginatingDocumentLine

Description

Defines the properties of the originating document line of the GL transaction. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ControlId | string | N/A | N/A | The originating document control ID.
Description | string | N/A | N/A | The originating document description.
Id | string | N/A | N/A | The originating document ID.
MasterId | string | N/A | N/A | The originating document master ID.
MasterName | string | N/A | N/A | The originating document master name.
SequenceNumber | int | N/A | N/A | The originating document line sequence number.
Type | int | N/A | N/A | The originating document type.


GLPostingAccount

Description

Defines the properties specific to a GL posting account within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
GLAccountCategory Key | GLAccountCategoryKey | N/A | N/A | The GL account category key object that uniquely identifies the GL account category.
AllowAccountEntry | boolean | N/A | True | Indicates whether the GL posting account can be used in subsidiary modules.
Currencies | ArrayOfGLAccountCurrency | N/A | N/A | A collection of account currency instances.
IsRevalued | boolean | N/A | False | Indicates whether the GL posting account is to be included when the revaluation procedure is performed.
PostRevaluationResultsTo | PostRevaluationResultsTo | N/A | Account | Indicates if the results of a revaluation should be posted to the same account or a financial offset account.
PostingType | PostingType | N/A | Balance Sheet | Indicates whether the account should be closed to a retained earnings account at the end of the year, or have a balance brought forward to the next year.
RevaluationMethod | RevaluationMethod | N/A | Net Change | Indicates the amount the revaluation should be based on.
TypicalBalance | TypicalBalance | N/A | Debit | Indicates whether this account has a debit balance or a credit balance.
UserDefined1 | string | 30 | N/A | User defined text.
UserDefined2 | string | 30 | N/A | User defined text.
UserDefined3 | string | 30 | N/A | User defined text.
UserDefined4 | string | 30 | N/A | User defined text.

Inherits from

GLFinancialAccount


GLPostingAccountCriteria

Description

Specifies the criteria to use when retrieving a list of GL posting account summary objects. Only GL posting account summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
GLAccountCategoryId | LikeRestrictionOfString | A string restriction specifying the ID of the GL account category.

Inherits from

GLAccountCriteriaBase


GLPostingAccountSummary

Description

A representation of the important details of a GL posting account within Microsoft Dynamics GP. A list of GL posting account summary objects is returned by the GetGLPostingAccountList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
GLAccountCategoryKey | GLAccountCategoryKey | N/A | N/A | The GL account category key object that uniquely identifies the GL account category.
AllowAccountEntry | boolean | N/A | N/A | Indicates whether the GL posting account can be used in subsidiary modules.
PostingType | PostingType | N/A | N/A | Indicates whether the account should be closed to a retained earnings account at the end of the year, or have a balance brought forward to the next year.
TypicalBalance | TypicalBalance | N/A | N/A | Indicates whether this account has a debit balance or a credit balance.

Inherits from

GLAccountSummaryBase


GLTax

Description

Defines the properties of the tax detail for a GL transaction in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account.
Amount | MoneyAmount | N/A | 0 | The tax amount.
DetailKey | TaxDetailKey | N/A | N/A | The tax detail key object that uniquely identifies the tax detail.


GLTransaction

Description

A general ledger transaction in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | GLTransactionKey | N/A | N/A | The GL transaction key object that uniquely identifies the GL transaction.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the currency used for the transaction.
Lines | ArrayOfGLTransaction Line | N/A | N/A | A collection of GL transaction lines.
Reference | string | NA | Empty | A reference for the transaction. References are required and can be any combination of alphanumeric symbols to help identify the transaction.
SourceDocumentKey | SourceDocumentKey | N/A | N/A | The source document key object that uniquely identifies the source document.
ExchangeRate | decimal | N/A | 0 | The exchange rate of the general ledger. Set this value only for multi-currency transactions. If there is triangulation and both rates are fixed, this is the originating to Euro fixed rate. Otherwise this is the variable rate.
ExchangeDate | dateTime | N/A | If not provided, will be set to transaction date. | The exchange date associated with the exchange rate provided.
LedgerType | GLLedgerType | N/A | N/A | Specifies the ledger type for the transaction.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.
Intercompany | GLIntercompany | N/A | N/A | The company and journal ID that originated the GL transaction. This property is read-only.
IsVoided | boolean | N/A | N/A | Indicates whether the transaction is voided. This property is read-only.
ModifiedBy | string | N/A | N/A | The user who last modified the transaction. This property is read-only.
ModifiedDate | dateTime | N/A | N/A | The date the transaction was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
OriginatingDocument | GLOriginatingDocument | N/A | N/A | The originating document. This property is read-only.
PostedBy | string | N/A | N/A | Identifies the user who posted the transaction. This property is read-only.
TransactionState | GLTransactionState | N/A | N/A | Indicates whether the transaction was retrieved from the work table, open table or the history table. This property is read-only.

Inherits from

BusinessObject


GLTransactionCriteria

Description

Specifies the criteria to use when retrieving a list of GL transaction summary objects. Only GL transaction summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
CurrencyISOCode | LikeRestrictionOfString | A string restriction specifying the CurrencyISOCode of the GL transaction.
Date | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the GL transaction.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the GL transaction was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
JournalId† | LikeRestrictionOfString | A string restriction specifying the JournalId of the GL transaction.
BatchId† | LikeRestrictionOfString | A string restriction specifying the BatchId of the GL transaction.
FiscalYear | BetweenRestrictionOfNullableOfInt32 | An integer restriction specifying the FiscalYear of the GL transaction.
RecurringTransaction Sequence | BetweenRestrictionOfNullableOfInt32 | An integer restriction specifying the recurring sequence of the GL transaction.
SourceDocumentId | LikeRestrictionOfString | A string restriction specifying the SourceDocumentId of the GL transaction.
TransactionState | ListRestrictionOfNullableOfGLTransactionState | A list restriction specifying the transaction state of the payables document.
LedgerType | ListRestrictionOfNullableOfGLLedgerType | A list restriction specifying the ledger type.

Inherits from

Criteria


GLTransactionKey

Description

Uniquely identifies a GL transaction in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
JournalId | int | N/A | N/A | The journal entry number for the transaction.
Date | dateTime | N/A | N/A | The transaction date. This value must be supplied.

Inherits from

TransactionKey


GLTransactionLine

Description

A GL transaction line in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | GLTransactionLineKey | N/A | N/A | The GL transaction line key object that uniquely identifies the GL transaction line.
CreditAmount | Amount | N/A | 0 | The credit amount for the account on the same line. The right-hand side of the account. If a credit amount isn’t being specified for the line, this property must be set to 0.
DebitAmount | Amount | N/A | 0 | The debit amount for the account on the same line. The left-hand side of the account. If a debit amount isn’t being specified for the line, this property must be set to 0.
Description | string | N/A | Empty | The description which identifies the account in the chart of accounts.
GLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that uniquely identifies the GL account number.
ExchangeRate | decimal | N/A | N/A | The exchange rate between the transactional and local currency. This property is read-only.
ExchangeDate | dateTime | N/A | If not provided, will be set to transaction date. | The exchange date associated with the exchange rate provided.
IntercompanyKey | CompanyKey | N/A | N/A | The company key object that uniquely identifies the company that originated the GL transaction line. This property is read-only.
OriginatingDocument | GLOriginatingDocumentLine | N/A | N/A | The originating document for the line. This property is read-only.
Tax | GLTax | N/A | N/A | Defines the GL taxes for the transaction line.

Inherits from

BusinessObject


GLTransactionLineKey

Description

Uniquely identifies a GL transaction line in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
TransactionKey | GLTransactionKey | N/A | N/A | The GL transaction key object that uniquely identifies the GL transaction.
SequenceNumber | int | N/A | N/A | The sequence number of the transaction line.


GLTransactionPostedKey

Description

Uniquely identifies a posted GL transaction in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
RecurringTransaction Sequence | long | N/A | N/A | The sequence number of a recurring transaction.
FiscalYear | int | N/A | N/A | The fiscal year in which the transaction was posted.

Inherits from

GLTransactionKey


GLTransactionSummary

Description

A representation of the important details of a GL transaction within Microsoft Dynamics GP. A list of GL transaction summary objects is returned by the GetGLTransactionList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | GLTransactionKey | N/A | N/A | The GL transaction key object that uniquely identifies the GL transaction.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the currency used for the transaction.
ModifiedDate | dateTime | N/A | N/A | The date the transaction was last modified.
Reference | string | NA | Empty | A reference for the transaction. References are required and can be any combination of alphanumeric symbols to help identify the transaction.
SourceDocumentKey | SourceDocumentKey | N/A | N/A | The source document key object that uniquely identifies the source document.
TransactionState | GLTransactionState | N/A | N/A | Indicates whether the transaction was retrieved from the work table, open table or the history table.
LedgerType | GLLedgerType | N/A | N/A | Indicates the ledger type for the transaction.


GLUnitAccount

Description

Defines the properties common to a GL unit account in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DecimalPlaces | GLUnitAccountDecimalPlaces | N/A | 2 | The number of decimal places that will be used to format unit account amounts. You can select 0, 1, or 2.

Inherits from

GLAccount


GLUnitAccountCriteria

Description

Specifies the criteria to use when retrieving a list of GL unit account summary objects. Only GL unit account summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

GLAccountCriteriaBase


GLUnitAccountSummary

Description

A representation of the important details of a GL unit account within Microsoft Dynamics GP. A list of GL unit account summary objects is returned by the GetGLUnitAccountList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
DecimalPlaces | GLUnitAccountDecimalPlaces | N/A | N/A | The number of decimal places that will be used to format unit account amounts. Possible values are 0, 1, or 2.

Inherits from

GLAccountSummaryBase


GLVariableAllocationAccount

Description

Defines the properties common to a GL variable allocation account within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
BalanceForCalculation | GLVariableAllocation AccountBalance CalculationType | N/A | Year To Date | Identifies how to calculate percentages for distributions. Calculations can be based on the breakdown accounts' year-to-date balances or transaction period balances.
Distributions | ArrayOfGLVariable AllocationDistribution Account | N/A | N/A | A collection of distribution accounts to which transaction amounts will be distributed.

Inherits from

GLFinancialAccount


GLVariableAllocationAccountCriteria

Description

Specifies the criteria to use when retrieving a list of GL variable allocation account summary objects. Only GL variable allocation account summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

GLAccountCriteriaBase


GLVariableAllocationAccountSummary

Description

A representation of the important details of a GL variable allocation account within Microsoft Dynamics GP. A list of GL variable allocation account summary objects is returned by the GetGLVariableAllocationAccountList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

GLAccountSummaryBase


GLVariableAllocationBreakdownAccount

Description

Defines a GL variable allocation breakdown account within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | GLVariableAllocationBreakdownAccountKey | N/A | N/A | The GL variable allocation breakdown account key object that uniquely identifies a GL variable allocation breakdown account.

Inherits from

BusinessObject


GLVariableAllocationBreakdownAccountKey

Description

Uniquely identifies a GL variable allocation breakdown account within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
AllocationDistribution AccountKey | GLAllocationDistributionAccountKey | N/A | N/A | The GL allocation distribution account key object that uniquely identifies the GL allocation distribution account.
BreakdownAccount Key | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the GL account number.

Inherits from

ReferenceKey


GLVariableAllocationDistributionAccount

Description

Defines a GL variable allocation distribution account in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | GLAllocationDistributionAccountKey | N/A | N/A | The GL allocation distribution account key object that uniquely identifies the GL allocation distribution account.
Breakdowns | ArrayOfGLVariableAllocationBreakdownAccount | N/A | N/A | A collection of the GL breakdown accounts to be used to calculate the percentages that will be posted to the distribution accounts. The balance of each breakdown account determines the percentage of the transaction amount that will be posted to each distribution account.

Inherits from

BusinessObject


GreatPlainsKey

Description

The core key object on which other keys are based.

Properties

Property | Type | Length | Default | Description
CompanyKey | CompanyKey | N/A | N/A | The company key object that uniquely identifies the company.


HistoryOptions

Description

Specifies the options for keeping transaction history for customers and vendors.

Properties

Property | Type | Length | Default | Description
KeepCalendarHistory | boolean | N/A | True | When set to true, a summary of posted transactions is saved by calendar months which allows printing of monthly and yearly customer or vendor activity reports.
KeepFiscalHistory | boolean | N/A | True | When set to true, a summary of posted transactions is saved for individual fiscal months kept which allows printing of reports of activity in each fiscal period.
KeepTransactionHistory | boolean | N/A | True | When set to true, detailed information about transactions are kept which allows printing of reports from history and Historical Aged Trial Balance reports.
KeepDistributionHistory | boolean | N/A | True | When set to true, detailed information about the posting account distributions for each transaction which allows printing of the Distribution History report.


HRRequisition

Description

Defines the properties for a job requisition in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CompanyCode | string | 5 | N/A | A string that specifies the company ID.
PositionKey | PositionKey | N/A | N/A | A key that uniquely identifies a position.
ManagerKey | ManagerKey | N/A | N/A | A key that uniquely identifies a manager.
RequisitionNumber | HRRequisitionNumberKey | N/A | N/A | A key that uniquely identifies a requistion.
Status | HRRequisitionStatus | N/A | N/A | An HRRequisitionStatus enumeration value specifying the status of the requisition.
DepartmentKey | DepartmentKey | N/A | N/A | A key that uniquely identifies a department.
DivisionKey | DivisionKey | N/A | N/A | A key that uniquely identifies a division.
SupervisorKey | SupervisorKey | N/A | N/A | A key that uniquely identifies the supervisor.
InternalPostDate | dateTime | N/A | Empty | Specifies the date the job was opened to internal candidates.
InternalCloseDate | dateTime | N/A | Empty | Specifies the date the job was closed to internal candidates.
OpeningDate | dateTime | N/A | Empty | Specifies the date the requisition was opened.
Recruiter | string | N/A | Empty | Specifies the name of the recruiter associated with the requisition.
JobPostingType | HRRequisitionPostingType | N/A | N/A | An HRRequisitionPostingType enumeration value specifying whether the position is open to internal or external candidates.
AdvertisingList | HRRequisitionAdvertisingList | N/A | N/A | An HRRequisitionAdvertisingList object that provides information about where the job is advertised.
PositionsAvailable | int | N/A | 0 | Specifies the total number of positions for the requisition.
PositionsFilled | int | N/A | 0 | Specifies the number of filled positions.
ApplicantsApplied | int | N/A | 0 | Specifies the total number of applicants for the position.
ApplicantsInterviewed | int | N/A | 0 | Specifies the number of applicants interviewed.
RequisitionCosts | HRRequisitionCosts | N/A | N/A | An HRRequisitionCosts object that provides additional information about costs associated with the requisition.
LastModifiedBy | string | 15 | Empty | The user who last modified the requisition. This property is read-only.
LastModifiedDate | dateTime | N/A | N/A | The date the requisition was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.

Inherits from

BusinessObject


HRRequisitionAdvertisingList

Description

Provides a list of advertising resources for a requisition.

Properties

Property | Type | Length | Default | Description
Line1 | string | 15 | Empty | Specifies advertising information for a job requisition.
Line2 | string | 15 | Empty | Specifies advertising information for a job requisition.
Line3 | string | 15 | Empty | Specifies advertising information for a job requisition.
Line4 | string | 15 | Empty | Specifies advertising information for a job requisition.
Line5 | string | 15 | Empty | Specifies advertising information for a job requisition.


HRRequisitionCosts

Description

Provides detailed expense information for a requisition.

Properties

Property | Type | Length | Default | Description
Advertising | decimal | N/A | Empty | Specifies the advertising costs associated with a job requisition.
RecruiterFees | decimal | N/A | Empty | Specifies the recruiter costs associated with a job requisition.
Travel | decimal | N/A | Empty | Specifies the travel expenses associated with a job requisition.
Lodging | decimal | N/A | Empty | Specifies the lodging expenses associated with a job requisition.
MovingExpenses | decimal | N/A | Empty | Specifies the moving expenses associated with a job requisition.
Other | decimal | N/A | Empty | Specifies the miscellaneous expenses associated with a job requisition.


HRRequisitionCriteria

Description

Specifies the criteria to use when retrieving a list of requisition summary objects. Only requisition summary objects that match the specified criteria will be returned. For the best performance, create criteria that use only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
RequisitionNumber† | BetweenRestrictionOfNullableOfInt32 | A restriction specifying a range of requisition numbers.
Status† | ListRestrictionOfNullableOfHRRequisitionStatus | A list restriction specifying the status of requisition.
CompanyKey† | LikeRestrictionOfString | A string restriction specifying the company ID of a requisition.
OpeningDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying a range of dates to include when identifying when a requisition opened.
InternalPostDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying a range of dates to include when identifying when a requisition opened to internal candidates.
InternalCloseDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying a range of dates to include when identifying when a requisition closed to internal candidates.
ManagerKey | LikeRestrictionOfString | A string restriction specifying the ID of a manager.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the dates that requisition information was last updated.

Inherits from

Criteria


HRRequisitionNumberKey

Description

Uniquely identifies a job requisition in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 4 | N/A | A string that uniquely identifies a job requisition.

Inherits from

ReferenceKey


HRRequisitionSummary

Description

A representation of the important details of a job requisition. The properties are read-only

Properties

Property | Type | Length | Default | Description
RequisitionNumber | HRRequisitionNumberKey | N/A | N/A | A key that uniquely identifies a requistion.
Status | HRRequisitionStatus | N/A | N/A | An HRRequisitionStatus enumeration value specifying the status of the requisition.
OpeningDate | dateTime | N/A | Empty | Specifies the date the requisition was opened.
InternalPostDate | dateTime | N/A | Empty | Specifies the date the job was opened to internal candidates.
InternalCloseDate | dateTime | N/A | Empty | Specifies the date the job was closed to internal candidates.
ManagerKey | ManagerKey | N/A | N/A | A key that uniquely identifies a manager.
LastModifiedDate | dateTime | N/A | N/A | The date the requisition was last modified. The value is in Coordinated Universal Time (UTC).
PositionKey | PositionKey | N/A | N/A | A key that uniquely identifies a position.

Inherits from

BusinessObjectSummary


InternationalAddress

Description

Extends the Address class with properties that describe an international address.

Properties

Property | Type | Length | Default | Description
CountryRegionCodeKey | CountryRegionCodeKey | N/A | Empty | The ISO 4217 code that represents the country or region where the address is located.

Inherits from

Address


InternetAddresses

Description

Represents the various Internet addresses of an entity in Microsoft Dynamic GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
MessengerAddress | string | 200 | Empty | Specifies an instant messenger address.
EmailToAddress | string | 1000 | Empty | Specifies the address where an email document will be sent.
EmailCcAddress | string | 1000 | Empty | Specifies the address where a carbon copy of an email document will be sent.
EmailBccAddress | string | 1000 | Empty | Specifies the address where blind carbon copies of an email document will be sent.
InternetField1 | string | 200 | N/A | Internet address 1
InternetField2 | string | 200 | N/A | Internet address 2
InternetField3 | string | 200 | N/A | Internet address 3
InternetField4 | string | 200 | N/A | Internet address 4
InternetField5 | string | 200 | N/A | Internet address 5
InternetField6 | string | 200 | N/A | Internet address 6
InternetField7 | string | 200 | N/A | Internet address 7
InternetField8 | string | 200 | N/A | Internet address 8
AdditionalInformation | string | 32000 | N/A | A text property that holds additional information about the internet address.


InternetAddressKeyChangedCriteria

Description

Specifies the criteria to use when retrieving a list of Internet addresses that have changed. Only changed Internet address key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
InternetAddressType | BetweenRestrictionOfString | A string restriction specifying the type of object that the Internet addresses are associated with. Use one of the following three-character values: CMP - Company CUS - Customers EMP - Employees ITM - Items SLP - Salespeople VEN - Vendors
InternetAddressKeyId | BetweenRestrictionOfString | A string restriction specifying the object that the Internet addresses are associated with. Typically, the string value matches the primary key value of the object.
AddressKeyId | BetweenRestrictionOfString | A string restriction specifying that address that the changed Internet address is associated with.

Inherits from

BaseChangedKeyCriteria


InterviewTypeKey

Description

Uniquely identifies the type of interviews included in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 20 | N/A | A string value that uniquley identifies the interview type.

Inherits from

ReferenceKey


InventoriedItem

Description

Defines the common properties for inventoried items in the Inventory module in Microsoft Dynamic GP.

Properties

Inherited from the base class

Inherits from

Item


InventoriedItemCriteria

Description

Specifies the criteria to use when retrieving a list of inventory item summary objects. Only inventory item summary objects that match the specified criteria will be returned

Properties

Property | Type | Description
Type | ListRestrictionOfNullableOfInventoriedItemType | A list restriction specifying the type of item.
IsDiscontinued | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether discontinued items will be included.

Inherits from

ItemCriteriaBase


InventoriedItemSummary

Description

A representation of the important details of an inventory item within Microsoft Dynamics GP. A list of inventoried item summary objects is returned by the GetItemList method.

Properties

Property | Type | Length | Default | Description
Type | InventoriedItemType | N/A | Empty | The type of item.
IsDiscontinued | boolean | N/A | False | Identifies items that have been discontinued.

Inherits from

ItemSummaryBase


InventoryAdjustment

Description

An inventory adjustment document in Microsoft Dynamics GP. An inventory adjustment is used to account for changes in inventory due to the purchase or sale of inventoried items.

Properties

Property | Type | Length | Default | Description
Lines | ArrayOfInventoryAdjustmentLine | N/A | N/A | A collection of inventory adjustment lines for the inventory adjustment.

Inherits from

InventoryBase


InventoryAdjustmentCriteria

Description

Specifies the criteria to use when retrieving inventory adjustment summary objects. Only inventory adjustment summary documents that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

InventoryCriteria


InventoryAdjustmentLine

Description

An inventory adjustment line for an inventory adjustment document . An inventory adjustment can have a collection of inventory adjustment lines.

Properties

Inherited from the base class

Inherits from

InventoryLine


InventoryAdjustmentSummary

Description

A representation of the important details of an inventory adjustment document within Microsoft Dynamics GP. A list of inventory adjustment summary objects is returned by the GetInventoryAdjustmentList method.

Properties

Inherited from the base class

Inherits from

InventorySummary


InventoryBase

Description

An inventory document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | InventoryKey | N/A | N/A | The inventory key object that uniquely identifies the inventory document.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch used for the inventory document.
Date | dateTime | N/A | N/A | The date of the inventory document.
ModifiedDate | dateTime | N/A | Current system date. | The date the inventory document was last modified. The value is in Coordinated Universal Time (UTC).
CreatedDate | dateTime | N/A | Current system date. | The date the inventory document was created.
AuditTrailCode | string | N/A | N/A | The internally-assigned audit trail code that gets assigned when the transaction is posted. This property is read-only.
GLPostingDate | dateTime | N/A | If not provided, defaults to the system date. | The general ledger posting date of the document.
TransactionState | InventoryTransactionState | N/A | N/A | Indicates whether the transaction was retrieved from the work table or history table. This property is read-only.

Inherits from

BusinessObject


InventoryBin

Description

Defines an inventory bin in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Bin | string | 15 | N/A | Identifies the bin.

Inherits from

InventoryBinBase


InventoryBinBase

Description

Defines the common properties for all types of inventory bins in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | InventoryBinKey | N/A | N/A | The inventory bin key object that uniquely identifies the inventory bin.
Quantity | Quantity | N/A | 0 | The quantity that will either be placed into the bin or removed from the bin.

Inherits from

BusinessObject


InventoryBinKey

Description

Uniquely identifies an inventory bin associated with an inventory line.

Properties

Property | Type | Length | Default | Description
InventoryLineKey | InventoryLineKey | N/A | N/A | The inventory line key object that uniquely identifies the inventory line.
SequenceNumber | int | N/A | N/A | The sequence number which identifies the inventory line.

Inherits from

TransactionKey


InventoryCriteria

Description

Specifies the base set of criteria to use when retrieving a list of inventory summary objects. Only inventory summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the inventory document was created.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the inventory document was last modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
Date | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the inventory document.
BatchId† | LikeRestrictionOfString | A string restriction specifying the batch ID for the inventory document.
InventoryId† | LikeRestrictionOfString | A string restriction specifying the ID of the inventory document.
TransactionState | ListRestrictionOfNullableOfInventoryTransactionState | A list restriction specifying the transaction state of the inventory document.

Inherits from

Criteria


InventoryKey

Description

Uniquely identifies an inventory document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 17 | N/A | The string value that uniquely identifies an inventory document.

Inherits from

TransactionKey


InventoryLine

Description

Defines an inventory line document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
UofM | string | 8 | N/A | The unit of measure for the item’s quantity.
WarehouseKey | WarehouseKey | N/A | N/A | The warehouse key object that uniquely identifies the location where the transaction occurs.
InventoryGLAccount | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the account that the cost of an item, based on the valuation method, will be posted to when an inventory variance or adjustment transaction occurs.
InventoryOffsetGL Account | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the account that the cost of an item, based on the valuation method, will be posted to when an inventory decrease adjustment transaction occurs.
Bins | ArrayOfInventoryBin | N/A | N/A | A collection of inventory bins for the inventory line.
Lots | ArrayOfInventoryLot | N/A | N/A | A collection of inventory lots for the inventory line.
Serials | ArrayOfInventorySerial | N/A | N/A | A collection of inventory serial objects for the inventory line.

Inherits from

InventoryLineBase


InventoryLineBase

Description

Defines the common properties for all inventory lines in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | InventoryLineKey | N/A | N/A | The inventory line key object that uniquely identifies the inventory line.
ItemKey | ItemKey | N/A | N/A | The item key object that uniquely identifies the item for the inventory line.
Quantity | Quantity | N/A | 0 | The quantity by which the item inventory should be adjusted.
UnitCost | MoneyAmount | N/A | N/A | The current cost or the standard cost of the item, depending on the item’s inventory valuation method.

Inherits from

BusinessObject


InventoryLineKey

Description

Uniquely identifies an inventory line for an inventory document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
InventoryKey | InventoryKey | N/A | N/A | The inventory key object that uniquely identifies inventory document for the inventory line.
SequenceNumber | decimal | N/A | 0 | The inventory line sequence number.

Inherits from

TransactionKey


InventoryLot

Description

Defines an inventory lot document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Bin | string | 15 | Empty | The bin that holds the lot.

Inherits from

InventoryLotBase


InventoryLotBase

Description

Defines the common properties for all inventory lots in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | InventoryLotKey | N/A | N/A | The inventory lot key object that uniquely identifies the inventory lot document.
LotNumber | string | 20 | N/A | The lot number that is being added or removed from inventory.
Quantity | Quantity | N/A | N/A | The quantity of the lot that is being adjusted.
ManufacturedDate | dateTime | N/A | N/A | The date the lot item was made.
ExpirationDate | dateTime | N/A | N/A | The date the lot item will expire.
ReceivedDate | dateTime | N/A | N/A | The date the lot item was received.

Inherits from

BusinessObject


InventoryLotKey

Description

Uniquely identifies an inventory transaction for an inventory lot within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
InventoryLineKey | InventoryLineKey | N/A | N/A | The inventory line key object that uniquely identifies the inventory line for the inventory lot.
SequenceNumber | int | N/A | 0 | The sequence number of the inventory transfer lot. When adding new inventory transfer lots, use 16,384 for the first line, 32,768 for the next line, and so on.

Inherits from

TransactionKey


InventorySerial

Description

Defines an inventory document for serial-numbered inventory transactions in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Bin | string | 15 | Empty | The bin where the serial number exists.

Inherits from

InventorySerialBase


InventorySerialBase

Description

Defines the common properties for all serial-numbered inventory transactions within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | InventorySerialKey | N/A | N/A | The inventory serial key object that uniquely identifies the inventory serial document.
SerialNumber | string | 20 | Empty | The serial number that is being added or removed from inventory.

Inherits from

BusinessObject


InventorySerialKey

Description

Uniquely identifies an inventory transaction for serial-numbered inventory within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
InventoryLineKey | InventoryLineKey | N/A | N/A | The inventory line key that uniquely identifies the inventory line for the inventory serial instance.
SequenceNumber | int | N/A | 0 | The sequence number of the inventory transfer serial. When adding new inventory transfer serial values, use 16,384 for the first line, 32,768 for the next line, and so on.

Inherits from

TransactionKey


InventorySummary

Description

A representation of the important details of an inventory document within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | InventoryKey | N/A | N/A | The inventory key object that uniquely identifies the inventory document.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch used for the inventory document.
Date | dateTime | N/A | N/A | The date of the inventory document.
ModifiedDate | dateTime | N/A | N/A | The date the inventory document was last modified.
CreatedDate | dateTime | N/A | N/A | The date the inventory document was created.
TransactionState | InventoryTransactionState | N/A | N/A | Indicates whether the transaction was retrieved from the work table or history table.


InventoryTransfer

Description

An inventory transfer document within Microsoft Dynamics GP. An inventory transfer is used to account for moving items from one site to another, or changing items from one type to another.

Properties

Property | Type | Length | Default | Description
Lines | ArrayOfInventoryTransferLine | N/A | N/A | A collection of inventory transfer lines for the inventory transfer document.

Inherits from

InventoryBase


InventoryTransferBin

Description

Defines an inventory transfer between inventory bins within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
BinFrom | string | 15 | Empty | The bin the item is being transferred from.
BinTo | string | 15 | Empty | The bin the item is being transferred to.

Inherits from

InventoryBinBase


InventoryTransferCriteria

Description

Specifies the criteria to use when retrieving a list of inventory transfer summary objects. Only inventory transfer summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

InventoryCriteria


InventoryTransferLine

Description

Defines an inventory transfer line document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
WarehouseFromKey | WarehouseKey | N/A | N/A | The warehouse key object that uniquely identifies the warehouse location where the items will be transferred from.
WarehouseToKey | WarehouseKey | N/A | N/A | The warehouse key object that uniquely identifies the warehouse location where the items will be transferred to.
QuantityTypeFrom | QuantityType | N/A | N/A | The quantity type where the item will be transferred from. Quantity type can be: On Hand; Returned; In Use; In Service; and Damaged.
QuantityTypeTo | QuantityType | N/A | N/A | The quantity type where the item will be transferred to. Quantity type can be: On Hand; Returned; In Use; In Service; and Damaged.
InventoryFromGLAccount | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the GL account that will be decreased by the transfer.
InventoryToGLAccount | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies the GL account that will be increased by the transfer.
Bins | ArrayOfInventoryTransferBin | N/A | N/A | A collection of inventory transfer bin objects for the inventory transfer line.
Lots | ArrayOfInventoryTransferLot | N/A | N/A | A collection of inventory transfer lot objects for the inventory transfer line.
Serials | ArrayOfInventoryTransferSerial | N/A | N/A | A collection of inventory transfer serial objects for the inventory transfer line.

Inherits from

InventoryLineBase


InventoryTransferLot

Description

Defines the properties used to transfer inventory lots within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
BinFrom | string | 15 | Empty | The bin the item is being transferred from.
BinTo | string | 15 | Empty | The bin the item is being transferred to.

Inherits from

InventoryLotBase


InventoryTransferSerial

Description

Defines the properties used to transfer serial-numbered inventory within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
BinFrom | string | 15 | Empty | The bin the item is being transferred from.
BinTo | string | 15 | Empty | The bin the item is being transferred to.

Inherits from

InventorySerialBase


InventoryTransferSummary

Description

A representation of the important details of an inventory transfer document within Microsoft Dynamics GP. A list of inventory transfer summary objects is returned by the GetInventoryTransferList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

InventorySummary


InventoryVariance

Description

Defines an inventory variance document within Microsoft Dynamics GP. An inventory variance is used to account for the difference between quantities recorded in Inventory Control and the results of stock counts.

Properties

Property | Type | Length | Default | Description
Lines | ArrayOfInventoryVarianceLine | N/A | N/A | A collection of inventory variance line object for the inventory variance document.

Inherits from

InventoryBase


InventoryVarianceCriteria

Description

Specifies the criteria to use when retrieving a list of inventory variance summary objects. Only inventory variance summary objects that match the specified criteria will be returned

Properties

Inherited from the base class

Inherits from

InventoryCriteria


InventoryVarianceLine

Description

Defines an inventory variance line within Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

InventoryLine


InventoryVarianceSummary

Description

A representation of the important details of an inventory variance document within Microsoft Dynamics GP. A list of inventory transfer summary objects is returned by the GetInventoryVarianceList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

InventorySummary


Item

Description

Defines the common properties for all types of items in the Inventory module in Microsoft Dynamic GP.

Properties

Property | Type | Length | Default | Description
Key | ItemKey | N/A | Empty | The item key object that uniquely identifies the item.
Description | string | 100 | Empty | The description of the item.
ShortDescription | string | 15 | Empty | The short description of the item.
GenericDescription | string | 10 | Empty | The generic description of the item.
ClassKey | ItemClassKey | N/A | Empty | The item class key object that uniquely identifies the item class associated with the item.
Type | ItemType | N/A | Defaults from Item Class if provided. Otherwise will be set to Sales. | Describe the type of item or the status of the item. Also determines which posting accounts are updated when an item is used in transactions.
SalesTaxBasis | SalesTaxBasis | N/A | Defaults from Item Class if provided. Otherwise will be set to Taxable. | Determines whether the item will be taxed, and if so, on what basis.
SalesTaxScheduleKey | TaxScheduleKey | N/A | Defaults from Item Class if provided. Otherwise will be set to Empty. | The tax schedule key object that uniquely identifies the sales tax schedule associated with the item. Only used when the sales tax basis is taxable.
UofMScheduleKey | UofMScheduleKey | N/A | Defaults from Item Class if provided. Otherwise will be set to Empty. | The UofM schedule key object that uniquely identifies the unit of measure schedule associated with the item.
ShippingWeight | decimal | N/A | 0 | The shipping weight of the item.
QuantityDecimalPlaces | QuantityDecimalPlaces | N/A | Defaults from Item Class if provided. Otherwise will be set to 0. | The number of decimal places that will be used to track accurate quantities for the item.
CurrencyDecimalPlaces | CurrencyDecimalPlaces | N/A | 0 | The default number of decimal places to use for currency amounts for an item.
PurchaseTaxBasis | PurchasingTaxBasis | N/A | Defaults from Item Class if provided. Otherwise will be set to Taxable. | Determines whether taxes will need to be paid when the item is purchased, and if so, on what basis.
PurchaseTaxScheduleKey | TaxScheduleKey | N/A | Defaults from Item Class if provided. Otherwise will be set to Empty. | The tax schedule key object that uniquely identifies the purchase tax schedule associated with the item. Only used when the purchase tax basis is taxable.
StandardCost | MoneyAmount | N/A | 0 | The standard cost of the item.
CurrentCost | MoneyAmount | N/A | 0 | The current cost of the item.
SubstituteItem1Key | ItemKey | N/A | Empty | The item key object that uniquely identifies the item assigned as a substitute item number that will be suggested if the selected item number is out of stock at the time of sale.
SubstituteItem2Key | ItemKey | N/A | Empty | The item key object that uniquely identifies the item assigned as a second substitute item number that will be suggested if the selected item number is out of stock at the time of sale.
IncludeInDemand Planning | boolean | N/A | False | Specifies whether to include the item in demand planning. True indicates the item will be included. False indicates it will not.
AllowBackOrder | boolean | N/A | Defaults from Item Class if provided. Otherwise will be set to False. | Indicates whether back orders can be be entered for an item.
WarrantyDays | short | N/A | 0 | The number of days the item will be covered by a warranty after it's sold.
ABCCode | ABCCode | N/A | None | Identifies the ABC code to assign to an item.
UserCategoryList1 | string | 10 | Defaults from Item Class if provided. Otherwise will be set to Empty. | The value for the first user definable category used to group similar items on Inventory Control reports.
UserCategoryList2 | string | 10 | Defaults from Item Class if provided. Otherwise will be set to Empty. | The value for the second user definable category used to group similar items on Inventory Control reports.
UserCategoryList3 | string | 10 | Defaults from Item Class if provided. Otherwise will be set to Empty. | The value for the third user definable category used to group similar items on Inventory Control reports.
UserCategoryList4 | string | 10 | Defaults from Item Class if provided. Otherwise will be set to Empty. | The value for the fourth user definable category used to group similar items on Inventory Control reports.
UserCategoryList5 | string | 10 | Defaults from Item Class if provided. Otherwise will be set to Empty. | The value for the fifth user definable category used to group similar items on Inventory Control reports.
UserCategoryList6 | string | 10 | Defaults from Item Class if provided. Otherwise will be set to Empty. | The value for the sixth user definable category used to group similar items on Inventory Control reports.
KeepCalendarYearHistory | boolean | N/A | Defaults from Item Class if provided. Otherwise will be set to False. | Specifies whether to maintain calendar-year history for this item. Calendar-year history includes quantity sold, total amount in sales and total amount in costs for the item, by month.
KeepFiscalYearHistory | boolean | N/A | Defaults from Item Class if provided. Otherwise will be set to False. | Specifies whether to maintain fiscal-year history for this item. Fiscal-year history includes quantity sold, total amount in sales and total amount in costs for the item, by period.
KeepTransactionHistory | boolean | N/A | Defaults from Item Class if provided. Otherwise will be set to False. | Specifies whether to maintain transaction history for this item. Transaction history is the detailed line-by-line history of posted documents. Transaction history is required to print the Transaction History Report or the Historical Stock Status Report.
KeepDistributionHistory | boolean | N/A | Defaults from Item Class if provided. Otherwise will be set to False. | Specifies whether to maintain distribution history for this item. Distribution history is the General Ledger posting distribution history; if you use this type of history, distribution breakdown registers and transaction posting journals may be reprinted.
InventoryGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the cost of an item, based on the valuation method you've selected, will be posted to when you enter a variance or adjustment transaction. An increase adjustment will debit the Inventory account; a decrease adjustment will credit the Inventory account. This account also will be used in Sales Order Processing and Invoicing when you enter a return to the On Hand or Returned quantity types.
InventoryOffsetGL AccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the cost of an item, based on the valuation method you've selected, will be posted to when you enter a decrease adjustment. Typically, this will be a cost of goods sold account. This account will be used only when increase or decrease transactions are entered directly in Inventory Control. It is the offset amount for the Inventory account.
CostofGoodsSoldGL AccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the cost of this item, based on the valuation method you've selected, will be posted to when an invoice is entered in Microsoft Dynamics GP Invoicing or Sales Order Processing. This account also will be used as the default account that the cost of the item, based on the valuation method you've selected, will be posted to when a correction to a purchase receipt is entered for items that have already been sold.
SalesGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the extended price of an item, based on the valuation method and price method you've selected, will be posted to when an invoice is posted in Microsoft Dynamics GP Sales Order Processing or Invoicing. This account will be posted to if you've chosen to use posting accounts for the item rather than the customer.
MarkdownGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the discount (markdown) amount will be posted to when a transaction is entered in Microsoft Dynamics GP Invoicing or Sales Order Processing to reduce the price of an item. The discount amount is the difference between the unit cost of the item in Invoicing and the reduced price. For example, if the unit cost of an item is $100 and you mark it down 10%, $10 will be posted to the Discount account. This account will be posted to if you've chosen to use posting accounts for the item rather than the customer in the Invoicing or Sales Order Processing modules.
SalesReturnGLAccount Key | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the price of an item will be posted to when a transaction is entered to return an item in Microsoft Dynamics GP Invoicing or Sales Order Processing. This account will be posted to if you've chosen to use posting accounts for the item rather than the customer in Invoicing or Sales Order Processing.
InUseGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the cost of an item, based on the valuation method you've selected, will be posted to when a transaction is posted to transfer the quantity type of an item to In Use or for return documents entered in either Sales Order Processing or Invoicing.
InServiceGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the cost of an item, based on the valuation method you've selected, will be posted to when a transaction is posted to transfer the quantity type of an item to In Service or for return documents entered in either Sales Order Processing or Invoicing.
DamagedGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the cost of an item, based on the valuation method you've selected, will be posted to when a transaction is posted to transfer the quantity type of an item to Damaged or for return documents entered in either Sales Order Processing or Invoicing.
VarianceGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which cost amounts for the item will be posted.
DropShipGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the cost of an item will be posted when an invoice receipt for a drop-ship purchase order is posted. Since the goods on a drop-ship purchase order aren't received into your inventory, the drop-ship items account is a purchasing clearing account.
PurchasePriceVarianceGL AccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the variance when the shipment unit cost of an item and the invoice unit cost are different when posting an invoice receipt in the Purchasing Invoice Entry window.
UnrealizedPurchasePrice VarianceGLAccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the variance when the item's standard cost and the cost when the item is received are different when posting a shipment receipt in the Receivings Transaction Entry window.
InventoryReturnGL AccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which the cost of an item, based on the valuation method you've selected, will be posted to when a transaction is posted to transfer the quantity type of an item to Return. This account will be used for documents entered in Sales Order Processing and Invoicing if you've selected to use posting accounts from the item. This account also is used for return documents entered in either Sales Order Processing or Invoicing.
AssemblyVarianceGL AccountKey | GLAccountNumberKey | N/A | Defaults from Item Class if provided. Otherwise set to Empty. | The GL account number key object that specifies the account to which assembly variance of this item, based on the valuation method you've selected, will be posted to when the actual costs are different than the standard or average costs when building a subassembly.
PurchaseUofM | string | 10 | Empty | The unit of measure used most often when purchasing the item.
DefaultWarehouseKey | WarehouseKey | N/A | Empty | The warehouse key object that uniquely identifies the default warehouse associated with the item.
PriceMethod | PriceMethod | N/A | Defaults from Item Class if provided. Otherwise set to Currency Amount. | Used to calculate prices in the price list. The price method you select also will control which values-either percentages or amounts-can be provided to determine pricing for an item.
FunctionalCurrency DecimalPlaces | CurrencyDecimalPlaces | N/A | N/A | The default number of decimal places to use for local (functional) currency amounts for an item.
ModifiedDate | dateTime | N/A | System Date | The date the item was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
LastModifiedDate | dateTime | N/A | System Date | The date the item was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
CreatedDate | dateTime | N/A | Empty | The date the item was created. This property is read-only.
IsDiscontinued | boolean | N/A | Empty | Identifies items that have been discontinued. This property is read-only.
DefaultPriceLevelKey | PriceLevelKey | N/A | Empty | Specifies the default price level for the item.
DefaultSellingUofM | string | 10 | Empty | Specifies the default unit of measure for the item.
InternetAddresses | InternetAddresses | N/A | Empty | The set of Internet address information for the item.

Inherits from

BusinessObject


ItemChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of item objects that have changed. Only item changed key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
ItemType | ListRestrictionOfNullableOfItemType | A list restriction specifying the item type.
ItemKeyId | BetweenRestrictionOfString | A string restriction specifying the item key.

Inherits from

BaseChangedKeyCriteria


ItemClass

Description

Defines the properties for an item class in the Inventory module within Microsoft Dynamics GP. These properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ItemClassKey | N/A | Empty | The item class key object that uniquely identifies the item class.
Description | string | N/A | Empty | The description of the item class.
Type | ItemType | N/A | Empty | The type of item.

Inherits from

BusinessObject


ItemClassCriteria

Description

Specifies the criteria to use when retrieving a list of item class summary objects. Only item class summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
ItemClassId | LikeRestrictionOfString | A string restriction specifying the item class ID.
Description | LikeRestrictionOfString | A string restriction specifying the description.
Type | ListRestrictionOfNullableOfItemType | A list restriction specifying the item type.

Inherits from

Criteria


ItemClassKey

Description

Uniquely identifies an item class within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | The string value used to identify an item class.

Inherits from

ReferenceKey


ItemCriteria

Description

Specifies the criteria to use when retrieving a list of item summary objects. Only item summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Type | ListRestrictionOfNullableOfItemType | A list restriction specifying the item type.
IsDiscontinued | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether discontinued items will be included.

Inherits from

ItemCriteriaBase


ItemCriteriaBase

Description

Defines the common properties for restricting the list of item summary objects. Only item summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ItemId† | LikeRestrictionOfString | A string restriction specifying the item ID.
Description† | LikeRestrictionOfString | A string restriction specifying the item description.
ShortDescription† | LikeRestrictionOfString | A string restriction specifying the short description.
GenericDescription† | LikeRestrictionOfString | A string restriction specifying the generic description.
ItemClassId† | LikeRestrictionOfString | A string restriction specifying the item class ID.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the item was created.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the item was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the item was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.

Inherits from

Criteria


ItemCurrency

Description

Definess the relationship between an item and a currency within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ItemCurrencyKey | N/A | Empty | The item currency key object that uniquely identifies the item currency.
CurrencyDecimalPlaces | CurrencyDecimalPlaces | N/A | 0 | The default number of decimal places to use for currency amounts for the item and currency provided.
ListPrice | MoneyAmount | N/A | 0 | The list price for the item in the currency.

Inherits from

BusinessObject


ItemCurrencyCriteria

Description

Specifies the criteria to use when retrieving a list of item currency summary objects. Only item currency summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
ItemId | LikeRestrictionOfString | A string restriction specifying the item ID.
CurrencyISOCode | LikeRestrictionOfString | A string restriction specifying the currency ISO code.

Inherits from

Criteria


ItemCurrencyKey

Description

Uniquely identifies an item currency within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ItemKey | ItemKey | N/A | Empty | The item key object that uniquely identifies the item.
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that uniquely identifies the currency.

Inherits from

ReferenceKey


ItemKey

Description

Uniquely identifies an item within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | Empty | The string value used to identify an item.

Inherits from

ReferenceKey


ItemSummary

Description

A representation of the important details of an item within Microsoft Dynamics GP. A list of item summary objects is returned by the GetItemList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Type | ItemType | N/A | N/A | The type of item.
IsDiscontinued | boolean | N/A | N/A | Identifies items that have been discontinued.

Inherits from

ItemSummaryBase


ItemSummaryBase

Description

Defines the common properties to be used when returning information about items from the Get List operation. The properties are read only.

Properties

Property | Type | Length | Default | Description
Key | ItemKey | N/A | N/A | The item key object that uniquely identifies the item.
Description | string | 100 | Empty | The description of the item.
ShortDescription | string | 15 | Empty | The short description of the item.
GenericDescription | string | 10 | Empty | The generic description of the item.
ClassKey | ItemClassKey | N/A | Empty | The item class key object that uniquely identifies the item class associated with the item.
CreatedDate | dateTime | N/A | N/A | The date the item was created.
ModifiedDate | dateTime | N/A | System Date | The date the item was last modified. The value is in Coordinated Universal Time (UTC).
LastModifiedDate | dateTime | N/A | System Date | The date the item was last modified. The value is in Coordinated Universal Time (UTC).


ItemTaxScheduleKey

Description

Uniquely identify an item tax schedule within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The string value used to identify the item tax schedule.

Inherits from

ReferenceKey


ItemVendor

Description

Defines the relationship between an item and a vendor in the Inventory module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ItemVendorKey | N/A | Empty | The item vendor key object that uniquely identifies the item vendor.
VendorItemNumber | string | 30 | Empty | The item number that the vendor uses for this item.
RequisitionedQuantity | Quantity | 18 | 0 | The quantity of this item you have requisitioned but haven't yet ordered from this vendor.
AverageLeadTime | decimal | N/A | 0 | The average number of days that pass between the time you place an order with this vendor and the time you receive the order.
NumberOfReceipts | short | N/A | 0 | The number of receipts you have had from the vendor for the item.
MinimumOrderQuantity | Quantity | 18 | 0 | The smallest quantity in which you can order this item from this vendor.
MaximumOrderQuantity | Quantity | 18 | 0 | The largest quantity in which you can order this item from this vendor. The Maximum Order can't be less than the Order Multiple value.
EconomicOrderQuantity | Quantity | 18 | 0 | The quantity that will give you the lowest price per unit for the selected item when you order it from this vendor.
VendorItemDescription | string | 100 | Empty | The item description for the vendor's item number.
LastOriginatingCost | MoneyAmount | N/A | 0 | The last cost that was paid for the item from the supplier. The cost is displayed in terms of the currency used on the purchasing transaction.
LastCurrencyKey | CurrencyKey | N/A | Empty | The currency key object that uniquely identifies the last currency the item was purchased in from the vendor.
FreeOnBoard | FreeOnBoard | N/A | None | Indicate when ownership of this item passes from the vendor to your company.
PurchasingUofM | string | 8 | Empty | The normal unit of measure the item is typically purchased in when buying from the vendor.
PlanningLead | short | N/A | 0 | The number of days you use in planning between the day an order is placed with this vendor and the day you receive the order.
OrderMultipleQuantity | Quantity | 18 | 0 | The number you want order quantities of this item to be a multiple of when ordering from this vendor.

Inherits from

BusinessObject


ItemVendorCriteria

Description

Specifies the criteria to use when retrieving a list of item vendor summary objects. Only item vendor summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
ItemId | LikeRestrictionOfString | A string restriction specifying the item ID.
VendorId | LikeRestrictionOfString | A string restriction specifying the vendor ID.
Scope | VendorScope | A property in criteria used to determine the level of filtering to be used when returning item vendor data.

Inherits from

Criteria


ItemVendorKey

Description

Uniquely identifies an item vendor within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ItemKey | ItemKey | N/A | Empty | The item key object that uniquely identifies the item.
VendorKey | VendorKey | N/A | Empty | The vendor key object that uniquely identifies the vendor.

Inherits from

ReferenceKey


ItemVendorSummary

Description

A representation of the important details of an item vendor within Microsoft Dynamics GP. A list of item vendor summary objects is returned by the GetItemVendorList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ItemVendorKey | N/A | N/A | The item vendor key object that uniquely identifies the item vendor.
VendorItemNumber | string | 30 | N/A | The item number that the vendor uses for this item.
VendorItemDescription | string | 100 | N/A | The item description for the vendor's item number.
AverageLeadTime | decimal | N/A | N/A | The average number of days that pass between the time you place an order with this vendor and the time you receive the order.
MinimumOrderQuantity | Quantity | 18 | N/A | The smallest quantity in which you can order this item from this vendor.
MaximumOrderQuantity | Quantity | 18 | N/A | The largest quantity in which you can order this item from this vendor. The Maximum Order can't be less than the Order Multiple value.


ItemWarehouse

Description

Defines the relationship between an item and a warehouse in the Inventory module within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ItemWarehouseKey | N/A | Empty | The item warehouse key object that uniquely identifies the item warehouse.
Bin | string | 20 | Empty | The bin where the item is typically stored in the warehouse.
PrimaryVendorKey | VendorKey | N/A | Empty | The vendor key object that uniquely identifies the primary vendor for the item.
LandedCostGroupKey | LandedCostGroupKey | N/A | Empty | The landed cost group key object that uniquely identifies the landed cost group.
RequisitionedQuantity | Quantity | N/A | 0 | The quantity of the item that has been requisitioned at the warehouse but not yet ordered.
BuyerKey | BuyerKey | N/A | Empty | The buyer key object that uniquely identifies the buyer. This property is read-only.
PlannerKey | PlannerKey | N/A | Empty | The planner key object that uniquely identifies the planner. This property is read-only.
Planning | Planning | N/A | N/A | The resource planning information for an item warehouse combination. This is read-only.

Inherits from

BusinessObject


ItemWarehouseBinKey

Description

Uniquely identifies an item warehouse bin within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ItemWarehouseKey | ItemWarehouseKey | N/A | Empty | The item warehouse key object that uniquely identifies the item warehouse.
Bin | string | 20 | Empty | The bin where the item is typically stored in the warehouse.

Inherits from

ReferenceKey


ItemWarehouseCriteria

Description

Specifies the criteria to use when retrieving a list of item warehouse summary objects. Only item warehouse summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
ItemId | LikeRestrictionOfString | A string restriction specifying the item ID.
WarehouseId | LikeRestrictionOfString | A string restriction specifying the warehouse ID.
BuyerId | LikeRestrictionOfString | A string restriction specifying the buyer ID.
PlannerId | LikeRestrictionOfString | A string restriction specifying the planner ID.

Inherits from

Criteria


ItemWarehouseKey

Description

Uniquely identifies an item warehouse within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ItemKey | ItemKey | N/A | Empty | The item key object that uniquely identifies the item.
WarehouseKey | WarehouseKey | N/A | Empty | The warehouse key object that uniquely identifies the warehouse.

Inherits from

ReferenceKey


ItemWarehouseSummary

Description

A representation of the important details of an item warehouse within Microsoft Dynamics GP. A list of item warehouse summary objects is returned by the GetItemWarehouseList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ItemWarehouseKey | N/A | Empty | The item warehouse key object that uniquely identifies the item warehouse.
PrimaryVendorKey | VendorKey | N/A | Empty | The vendor key object that uniquely identifies the primary vendor for the item.
BuyerKey | BuyerKey | N/A | Empty | The buyer key object that uniquely identifies the buyer.
PlannerKey | PlannerKey | N/A | Empty | The planner key object that uniquely identifies the planner.


JobTitleKey

Description

Uniquely identifies a job title code for a project timesheet.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The job title code.

Inherits from

ReferenceKey


Key

Description

Provides the underlying storage for instances of concrete key types that derive from it.

Properties

None


Kit

Description

Defines properties that are specific to a kit inventory item within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CostOfGoodsSold AccountSource | CostOfGoodsSoldAccountSource | N/A | Defaults from Item Class if provided. Otherwise, it will be set to Empty. | Cost of Goods account when a Kit item is sold. This only pertains to items that are Kits.
Components | ArrayOfKitComponent | N/A | N/A | A collection of kit component items in the kit.

Inherits from

InventoriedItem


KitComponent

Description

A component of a kit item in the Inventory module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | KitComponentKey | N/A | Empty | The kit component key object that uniquely identifies the kit component for a kit item.
Quantity | Quantity | N/A | 0 | The quantity of the component used to build one kit item.
Description | string | 100 | N/A | The description of the component item. This property is read-only.
Type | ItemType | N/A | N/A | The type of the component item. This property is read-only.
UofMScheduleKey | UofMScheduleKey | N/A | N/A | The UofM schedule key object that uniquely identifies a unit of measure schedule.

Inherits from

BusinessObject


KitComponentKey

Description

Uniquely identifies a kit component in the Inventory module within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
KitKey | ItemKey | N/A | Empty | The kit key object that uniquely identifies the kit item.
ItemKey | ItemKey | N/A | Empty | The item key object that uniquely identifies the component item.
UofM | string | 8 | Empty | The unit of measure in which each component will be allocated when the kit item is sold.

Inherits from

ReferenceKey


LandedCostGroupKey

Description

Uniquely identifies a landed cost group within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The string value used to identify a landed cost group.

Inherits from

ReferenceKey


LanguageKey

Description

Specifies the language used for the object, such as a customer or vendor.

Properties

Property | Type | Length | Default | Description
Id | int | N/A | 0 | The language to use. The value corresponds to the languages set up in the Language Setup window in Microsoft Dynamics GP.

Inherits from

ReferenceKey


LikeRestrictionOfNullableOfInt32

Description

A restriction specifying a collection of Int32 values that a criteria object can have.

Properties

Property | Type | Length | Default | Description
Like | string | N/A | N/A | The “like” expression that specifies the Int32 value in the collection.

Inherits from

BetweenRestrictionOfNullableOfInt32


LikeRestrictionOfNullableOfServiceCallType

Description

A restriction specifying the collection of values a service call type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Like | string | N/A | N/A | The “like” expression that specifies which string values will be affected.

Inherits from

BetweenRestrictionOfNullableOfServiceCallType


LikeRestrictionOfString

Description

A restriction specifying the values for a string property of a criteria object that match the “Like” expression supplied. The syntax for the “Like” expression is the same as the LIKE statement for Transact-SQL.

Properties

Property | Type | Length | Default | Description
Like | string | N/A | N/A | The “like” expression that specifies which string values will be affected.

Inherits from

BetweenRestrictionOfString


ListRestrictionOfNullableOfApplicationStatus

Description

A restriction specifying the collection of values that the application status property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfApplicationStatus | N/A | N/A | The collection of application status values the property can have.

Inherits from

RestrictionOfNullableOfApplicationStatus


ListRestrictionOfNullableOfCompensationPeriod

Description

A restriction specifying the collection of values that the compensation period property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfCompensationPeriod | N/A | N/A | The collection of compensation period values the property can have.

Inherits from

RestrictionOfNullableOfCompensationPeriod


ListRestrictionOfNullableOfDateTime

Description

A restriction specifying the collection of values a date/time property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfDateTime | N/A | N/A | The collection of dateTime values the property can have.

Inherits from

RestrictionOfNullableOfDateTime


ListRestrictionOfNullableOfDecimal

Description

A restriction specifying the collection of decimal values that a property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfDecimal | N/A | N/A | The collection of decimal values the property can have.

Inherits from

RestrictionOfNullableOfDecimal


ListRestrictionOfNullableOfEmployeePayTypes

Description

A restriction specifying the collection of values an employee pay type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfEmployeePayTypes | N/A | N/A | The collection of employee pay type values the property can have.

Inherits from

RestrictionOfNullableOfEmployeePayTypes


ListRestrictionOfNullableOfFeeType

Description

A restriction specifying the collection of values a fee type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfFeeType | N/A | N/A | The collection of fee type values the property can have.

Inherits from

RestrictionOfNullableOfFeeType


ListRestrictionOfNullableOfGLAccountSummaryType

Description

A restriction specifying the collection of values a GL account summary type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfGLAccountSummaryType | N/A | N/A | The collection of GL account summary type values the property can have.

Inherits from

RestrictionOfNullableOfGLAccountSummaryType


ListRestrictionOfNullableOfGLLedgerType

Description

A restriction specifying the collection of values that the GL ledger type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfGLLedgerType | N/A | N/A | The collection of GL ledger type values the property can have.

Inherits from

RestrictionOfNullableOfGLLedgerType


ListRestrictionOfNullableOfGLTransactionState

Description

A restriction specifying the collection of values a GL transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfGLTransactionState | N/A | N/A | The collection of GL transaction state values the property can have.

Inherits from

RestrictionOfNullableOfGLTransactionState


ListRestrictionOfNullableOfHRRequisitionStatus

Description

A restriction specifying the collection of values that the HR requisition status property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfHRRequisitionStatus | N/A | N/A | The collection of HR requisition status values the property can have.

Inherits from

RestrictionOfNullableOfHRRequisitionStatus


ListRestrictionOfNullableOfInt32

Description

A restriction specifying the collection of values an Int32 property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfInt | N/A | N/A | The collection of Int32 values the property can have.

Inherits from

RestrictionOfNullableOfInt32


ListRestrictionOfNullableOfInventoriedItemType

Description

A restriction specifying the collection of values an inventoried item type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfInventoriedItemType | N/A | N/A | The collection of inventoried item type values the property can have.

Inherits from

RestrictionOfNullableOfInventoriedItemType


ListRestrictionOfNullableOfInventoryTransactionState

Description

A restriction specifying the collection of values an inventory transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfInventoryTransactionState | N/A | N/A | The collection of inventory transaction state values the property can have.

Inherits from

RestrictionOfNullableOfInventoryTransactionState


ListRestrictionOfNullableOfItemType

Description

A restriction specifying the collection of values an item type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfItemType | N/A | N/A | The collection of item type values the property can have.

Inherits from

RestrictionOfNullableOfItemType


ListRestrictionOfNullableOfManufacturingOrderOutSourced

Description

A restriction specifying the collection of values that a manufacturing order outsourced property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfManufacturingOrderOutSourced | N/A | N/A | The collection of manufacturing order outsourced values the property can have.

Inherits from

RestrictionOfNullableOfManufacturingOrderOutSourced


ListRestrictionOfNullableOfManufacturingOrderPriority

Description

A restriction specifying the collection of values that a manufacturing order priority property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfManufacturingOrderPriority | N/A | N/A | The collection of manufacturing order priority values the property can have.

Inherits from

RestrictionOfNullableOfManufacturingOrderPriority


ListRestrictionOfNullableOfManufacturingOrderStatus

Description

A restriction specifying the collection of values that a manufacturing order status property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfManufacturingOrderStatus | N/A | N/A | The collection of manufacturing order status values the property can have.

Inherits from

RestrictionOfNullableOfManufacturingOrderStatus


ListRestrictionOfNullableOfPayablesDocumentType

Description

A restriction specifying the collection of values a payables document type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfPayablesDocumentType | N/A | N/A | The collection of payables document type values the property can have.

Inherits from

RestrictionOfNullableOfPayablesDocumentType


ListRestrictionOfNullableOfPayablesTransactionState

Description

A restriction specifying the collection of values a payables transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfPayablesTransactionState | N/A | N/A | The collection of payables transaction state values the property can have.

Inherits from

RestrictionOfNullableOfPayablesTransactionState


ListRestrictionOfNullableOfPlannedOrderReplenishment

Description

A restriction specifying the collection of values that a planned order replenishment property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfPlannedOrderReplenishment | N/A | N/A | The collection of planned order replenishment values the property can have.

Inherits from

RestrictionOfNullableOfPlannedOrderReplenishment


ListRestrictionOfNullableOfProjectTransactionState

Description

A restriction specifying the collection of values a project transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfProjectTransactionState | N/A | N/A | The collection of project transaction state values the property can have.

Inherits from

RestrictionOfNullableOfProjectTransactionState


ListRestrictionOfNullableOfPurchaseOrderStatus

Description

A restriction specifying the collection of values a purchase order status property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfPurchaseOrderStatus | N/A | N/A | The collection of purchase order status values the property can have.

Inherits from

RestrictionOfNullableOfPurchaseOrderStatus


ListRestrictionOfNullableOfPurchaseOrderTransactionState

Description

A restriction specifying the collection of values a purchase order transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfPurchaseOrderTransactionState | N/A | N/A | The collection of purchase order transaction state values the property can have.


ListRestrictionOfNullableOfPurchaseTransactionState

Description

A restriction specifying the collection of values a purchase transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfPurchaseTransactionState | N/A | N/A | The collection of purchase transaction state values the property can have.

Inherits from

RestrictionOfNullableOfPurchaseTransactionState


ListRestrictionOfNullableOfReceivablesDocumentType

Description

A restriction specifying the collection of values a receivables document type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfReceivablesDocumentType | N/A | N/A | The collection of receivables document type values the property can have.

Inherits from

RestrictionOfNullableOfReceivablesDocumentType


ListRestrictionOfNullableOfReceivablesTransactionState

Description

A restriction specifying the collection of values a receivables transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfReceivablesTransactionState | N/A | N/A | The collection of receivables transaction state values the property can have.

Inherits from

RestrictionOfNullableOfReceivablesTransactionState


ListRestrictionOfNullableOfReturnMaterialAuthorizationType

Description

A restriction specifying the collection of values a return material authorization type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfReturnMaterialAuthorizationType | N/A | N/A | The collection of return material authorization type values the property can have.

Inherits from

RestrictionOfNullableOfReturnMaterialAuthorizationType


ListRestrictionOfNullableOfSalesCommissionTransactionState

Description

A restriction specifying the collection of values a sales commission transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfSalesCommissionTransactionState | N/A | N/A | The collection of sales commission transaction state values the property can have.

Inherits from

RestrictionOfNullableOfSalesCommissionTransactionState


ListRestrictionOfNullableOfSalesDocumentType

Description

A restriction specifying the collection of values a sales document type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfSalesDocumentType | N/A | N/A | The collection of sales document type values the property can have.

Inherits from

RestrictionOfNullableOfSalesDocumentType


ListRestrictionOfNullableOfSalesTransactionState

Description

A restriction specifying the collection of values a sales transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfSalesTransactionState | N/A | N/A | The collection of sales transaction state values the property can have.

Inherits from

RestrictionOfNullableOfSalesTransactionState


ListRestrictionOfNullableOfSalespersonCommissionsDocumentType

Description

A restriction specifying the collection of values a salesperson commissions document type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfSalespersonCommissionsDocumentType | N/A | N/A | The collection of salesperson commissions document type values the property can have.

Inherits from

RestrictionOfNullableOfSalespersonCommissionsDocumentType


ListRestrictionOfNullableOfServiceCallType

Description

A restriction specifying the collection of values a service call type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfServiceCallType | N/A | N/A | The collection of service call type values the property can have.

Inherits from

RestrictionOfNullableOfServiceCallType


ListRestrictionOfNullableOfServiceTransactionState

Description

A restriction specifying the collection of values a service transaction state property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfServiceTransactionState | N/A | N/A | The collection of service transaction state values the property can have.

Inherits from

RestrictionOfNullableOfServiceTransactionState


ListRestrictionOfNullableOfTaxDetailBase

Description

A restriction specifying the collection of values the tax detail base property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfTaxDetailBase | N/A | N/A | The collection of tax detail base values the property can have.

Inherits from

RestrictionOfNullableOfTaxDetailBase


ListRestrictionOfNullableOfTaxDetailType

Description

A restriction specifying the collection of values the tax detail type property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfTaxDetailType | N/A | N/A | The collection of tax detail type values the property can have.

Inherits from

RestrictionOfNullableOfTaxDetailType


ListRestrictionOfString

Description

A restriction specifying the collection of values a string property of a criteria object can have.

Properties

Property | Type | Length | Default | Description
Items | ArrayOfString | N/A | N/A | The collection of string values the property can have.

Inherits from

RestrictionOfString


LoggedExceptionData

Description

A set of information describing a validation error, validation warning, or system error.

Properties

Property | Type | Length | Default | Description
LogId | GUID | N/A | N/A | A key that uniquely identifies the exception.
ExceptionType | BusinessExceptionType | N/A | N/A | A business exception type object that specifies whether the exception is a Validation Exception or a System Exception.
ExceptionDetail | ExceptionInformation | N/A | N/A | An exception information object that details the exception that created the current exception.
ValidationResult | ValidationResult | N/A | Empty | A validation result object that contains each validation error or warning. If ExceptionType is System Exception, ValidationResult is null.
ServiceType | string | 100 | N/A | The type of operation. Operations include Create, Update, Delete, Void, GetByKey or GetList.
BusinessObjectType | string | 100 | N/A | Specifies the type of business object.
User | string | N/A | N/A | Specifies the user that made the web service call causing the exception.
Context | Context | N/A | N/A | Specifies the context object for the operation.
RequestXml | string | N/A | N/A | Serialized XML representing the input parameters.
LoggedDate | dateTime | N/A | Current system date | The date the exception was logged.


LoggedExceptionDataSummary

Description

A representation of the important details of a logged exception. A list of logged exception data summary objects is returned by the GetLoggedExceptionDataList method.

Properties

Property | Type | Length | Default | Description
LogId | guid | N/A | N/A | A key that uniquely identifies the exception.
Message | string | N/A | N/A | The message explaining the exception.
User | string | 100 | N/A | The login name of the user who caused the exception.
CompanyName | string | 64 | N/A | The name of the company.
BusinessExceptionType | BusinessExceptionType | N/A | N/A | A business exception type object that specifies whether the exception is a Validation Exception or a System Exception.
ServiceType | string | 100 | N/A | The type of operation. Operations include Create, Update, Delete, Void, GetByKey or GetList.
BusinessObjectType | string | 100 | N/A | Specifies the type of business object.
LoggedDate | dateTime | N/A | Current system date | The date the exception was logged.


LotCategoryKey

Description

Uniquely identifies a lot category within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | N/A | The string value that uniquely identifies a lot category (lot type).

Inherits from

ReferenceKey


ManagerKey

Description

Uniquely identifies a manager within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | N/A | The string value that uniquely identifies a manager.

Inherits from

ReferenceKey


ManufacturingOrder

Description

Defines the properties of a manufacturing order in Microsoft Dynamics GP. A manufacturing order adds order picklist and route step information to a manufacturing order document.

Properties

Property | Type | Length | Default | Description
PickList | ArrayOfManufacturingOrderPickListItem | N/A | N/A | A collection of manufacturing order picklist item objects.
Route | ArrayOfManufacturingOrderRouteStep | N/A | N/A | A collection of manufacturing order route step objects.

Inherits from

ManufacturingOrderDocument


ManufacturingOrderCriteria

Description

Specifies the set of criteria to use when retrieving a list of manufacturing order summary objects. Only manufacturing order summary that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Priority | ListRestrictionOfNullableOfManufacturingOrderPriority | A restriction specifying the manufacturing order priority of the manufacturing order.
RoutingName† | LikeRestrictionOfString | A string restriction specifying the routing name of the manufacturing order.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the range of dates to use to identify when the manufacturing order was last modified.
Archived | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the manufacturing order is archived.
QuickMo | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the manufacturing order requires less detailed tracking of manufacturing resources.
DateCompleted | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the range of dates to use to identify when the manufacturing order was completed.
OutSourced | ListRestrictionOfNullableOfManufacturingOrderOutSourced | A restriction specifying whether the manufacturing order was outsourced.
PostToSite† | LikeRestrictionOfString | A string restriction specifying the inventory site where the finished items for the manufacturing order are added.
EndDate† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the range of dates to use to identify when the manufacturing order ended.

Inherits from

ManufacturingOrderDocumentCriteria


ManufacturingOrderDocument

Description

Defines the properties of a manufacturing order document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ActualDemand | Quantity | N/A | N/A | Specifies the quantity of items.
ManufacturingOrderDocumentKey | ManufacturingOrderDocumentKey | N/A | N/A | The key that uniquely identifies the manufacturing order document.
Description | string | 30 | Empty | Specifies a description of the manufacturing order.
OrderStatus | ManufacturingOrderStatus | N/A | N/A | ManufacturingOrderStatus enumeration value specifying the status of the order.
ItemKey | ItemKey | N/A | N/A | A key specifying the item number of the item being manufactured.
IsArchivedMO | boolean | N/A | False | Specifies whether the manufacturing order has been archived.
BOMCategory | BOMCategory | N/A | N/A | BOMCategory enumeration value specifying the bill of materials category.
RoutingName | string | 30 | Empty | Specifies the name of the route.
EndingQty | Quantity | N/A | N/A | Specifies the quantity of the item after the order is complete.
StartingQty | Quantity | N/A | N/A | Specifies the quantity of the item when the order begins.
StartDate | dateTime | N/A | Empty | Specifies the date the manufacturing order started.
EndDate | dateTime | N/A | Empty | Specifies the date the manufacturing order ended.
DrawFromSite | string | 10 | Empty | Specifies the inventory site for the components used in the manufacturing order.
LastModifiedDate | dateTime | N/A | N/A | The date the manufacturing order was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
ScheduleMethod | SchedulingMethod | N/A | N/A | Scheduling method enumeration values specifying the schedule method.
PostToSite | string | 10 | Empty | Specifies the inventory site for finished items.
LotNumber | string | 20 | Empty | Specifies the number used to identify the items produced by the manufacturing order.
SchedulingPreference | string | 20 | Empty | Specifies the scheduling preference.
PlanName | string | 15 | Empty | Specifies the manufacturing plan.
Priority | ManufacturingOrderPriority | N/A | N/A | ManufacturingOrderPriority enumeration value specifying the priority of the manufacturing order.
Notes | string | 8000 | Empty | Specifies additional information associated with the manufacturing order.
OutSourced | ManufacturingOrderOutSourced | N/A | N/A | ManufacturingOrderOutSourced enumeration specifying whether the order was outsourced.
ComponentCalculation | ManufacturingOrderComponentCalculation | N/A | N/A | ManufacturingOrderComponentCalculation enumeration value specifying how components are calculated.
DateCompleted | dateTime | N/A | Empty | Specifies the date the manufacturing order was completed.
PickNumber | string | 17 | Empty | Specifies the number of the manufacturing pick document.
IsQuickMO | boolean | N/A | False | Specifies whether the manufacturing order is a a Quick MO.
RoutingRevisionLevel | string | 50 | Empty | Specifies the current routing revision level.
BOMRevisionLevel | string | 50 | Empty | Specifies the current bill of materials revision level.

Inherits from

BusinessObject


ManufacturingOrderDocumentCriteria

Description

Specifies the set of criteria to use when retrieving a list of manufacturing order document summary objects. Only manufacturing order document summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ManufacturingOrderDocumentKeyId | LikeRestrictionOfString | A string specifying the ID of the manufacturing order document.
ItemKeyId | LikeRestrictionOfString | A string restriction specifying the ID of the item being manufactured.
OrderStatus | ListRestrictionOfNullableOfManufacturingOrderStatus | A restriction specifying the status of the manufacturing order.
StartDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the range of dates to use to identify when the manufacturing order started.

Inherits from

Criteria


ManufacturingOrderDocumentKey

Description

Uniquely identifies a manufacturing order document.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | N/A | A value that uniquely identifies a manufacturing order document.

Inherits from

ReferenceKey


ManufacturingOrderDocumentSummary

Description

A representation of the important details of a manufacturing order document in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Description | string | 30 | Empty | Specifies a description of the manufacturing order.
ManufacturingOrderDocumentKey | ManufacturingOrderDocumentKey | N/A | N/A | The key that uniquely identifies the manufacturing order document.
OrderStatus | ManufacturingOrderStatus | N/A | N/A | ManufacturingOrderStatus enumeration value specifying the status of the order.
ItemKey | ItemKey | N/A | N/A | A key specifying the item number of the item being manufactured.
StartDate | dateTime | N/A | Empty | Specifies the date the manufacturing order started.

Inherits from

BusinessObjectSummary


ManufacturingOrderPickListItem

Description

Defines the properties of a manufacturing order picklist item in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CurrentReturnToStockQty | Quantity | N/A | N/A | Specifies quantity of material returned to stock.
ManufacturingOrderDocumentKey | ManufacturingOrderDocumentKey | N/A | N/A | A key that uniquely identifies a manufacturing order document.
Sequence | int | N/A | N/A | Specifies the sequence of the pick list in a manufacturing order.
OrderStatus | ManufacturingOrderStatus | N/A | N/A | ManufacturingOrderStatus enumeration value specifying the status of the order.
ParentPartNumber | ItemKey | N/A | N/A | Specifies the finished good item number.
ItemKey | ItemKey | N/A | N/A | A key that uniquely identifies the item being manufactured.
PositionNumber | int | N/A | Empty | Specifies the order in which components are used to build an item.
RoutingName | string | 30 | Empty | Specifies the route that this item belongs to.
RoutingSequence | string | 10 | Empty | Specifies the sequence in the route.
MRPAmount | MoneyAmount | N/A | N/A | Specifies the original issue amount.
MRPAmount2 | MoneyAmount | N/A | N/A | Specifies the net issue amount. The net amount is the original issue amount minus the reverse issue amount.
SuggestedQty | Quantity | N/A | N/A | Specifies the suggested quantity of the component.
DateResourcePlanIssued | dateTime | N/A | Empty | Specifies the date the resource plan was issued.
DateAllocated | dateTime | N/A | Empty | Specifies the allocation date.
WorkCenter | string | 10 | Empty | Specifies the work center where the item is manufactured.
VendorKey | VendorKey | N/A | N/A | A key that uniquely identifies a vendor.
VendorName | string | 64 | Empty | Specifies the name of a vendor.
IsBackFlushed | boolean | N/A | False | Specifies whether the item is back flushed.
IsBackOrdered | boolean | N/A | False | Specifies whether the item is back ordered.
IsAlternateItem | boolean | N/A | False | Specifies whether the item is an alternate item.
AlternateItemFor | ItemKey | N/A | N/A | Identifies the item that this item is an alternate for.
AlternateItemSequence | int | N/A | Empty | Specifies the alternate item sequence number.
IsSubAssemblyItem | boolean | N/A | False | Specifies whether the item is a subassembly for another item.
SubAssemblyItemFor | ItemKey | N/A | N/A | Identifies the item that this item is a subassembly for.
SubAssemblyItemSequence | int | N/A | Empty | Specifies the sequence number of a subassembly.
IsBOMApproved | boolean | N/A | False | Specifies whether the subassembly bill of materials is approved.
IsBOMSingleLot | boolean | N/A | False | Specifies whether the item is a single lot.
Location | string | 10 | Empty | Specifies where the item is located.
IsAllocated | boolean | N/A | False | Specifies whether the item is already allocated.
IsIssued | boolean | N/A | False | Specifies whether the item is already issued.
IsFloorStock | boolean | N/A | False | Specifies whether the item is floor stock.
IsResourcePlanCalculated | boolean | N/A | False | Specifies whether a resource plan is calculated.
IsPhantomItem | boolean | N/A | False | Specifies whether the item is classifed as a phantom item.
LastModifiedDate | dateTime | N/A | N/A | The date the picklist item was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
AllocatedBy | string | 15 | Empty | Specifies the person who allocated the item.
IssuedBy | string | 15 | Empty | Specifies the person who issued the item.
RefillCost | MoneyAmount | N/A | N/A | Specifies the cost to refill the item.
ReturnToStockQty | Quantity | N/A | N/A | Specifies the number of items returned to stock.
ScrappedQty | Quantity | N/A | N/A | Specifies the number of items scrapped.
ActualConsumedQty | Quantity | N/A | N/A | Specifies the number of items consumed.
POLine | PurchaseTransactionLineKey | N/A | N/A | Identifies a purchase order for the item.
AllowedQty | Quantity | N/A | N/A | Specifies the quantity allowed for the item.
CurrentConsumedQty | Quantity | N/A | N/A | Specifies the current quantity consumed for the item.
CurrentScrappedQty | Quantity | N/A | N/A | Specifies the current quantity scrapped for the item.
IsOptionedItem | boolean | N/A | False | Specifies whether the item is optioned.
MarkdownAmt | MoneyAmount | N/A | N/A | Specifies the amount of the markdown for the item.
BOMCategory | BOMCategory | N/A | N/A | Specifies the bill of materials category.
BOMName | string | 15 | Empty | Specifies the bill of materials name.
Promotion | string | 30 | Empty | Specifies whether a promotion exists.
IsActualConsumedChecked | boolean | N/A | False | Specifies whether the quantity consumed was verified.
DateRequired | dateTime | N/A | Empty | Specifies the date the item is required.
UofM | string | 8 | Empty | Specifies the unit of measure.
AllocatedQty | Quantity | N/A | N/A | Specifies the quantity that was allocated.
UnitCost | MoneyAmount | N/A | N/A | Specifies the unit cost of the item.
NonInventoryCreditIndex | int | N/A | Empty | If comp on pick list is non-inventory it is the credit index account used.
BaseUOMQty | Quantity | N/A | N/A | Specifies the base unit of measure quantity.
IssuedQty | Quantity | N/A | N/A | Specifies the quantity that was issued.
BackFlushedQty | Quantity | N/A | N/A | Specifies the quantity that was back flushed.
NonInventoryItemDescription | string | 100 | Empty | Specifies a description to include at the point of use.
LinkToSequence | int | N/A | N/A | Specifies a routing link.
FixedQty | Quantity | N/A | N/A | Specifies the item quantity required for each manufacturing order.
LeadTimeOffset | decimal | N/A | N/A | The number of days that lead times should be offset from the manufacturing order start date or due date. If the lead time is based on the manufacturing order due date, you can’t enter a negative value.
OffsetFrom | decimal | N/A | N/A | The date that the lead time is calculated from: manufacturing order start date or due date.
BOMUserDef1 | string | 30 | Empty | Specifies a user-defined value.
BOMUserDef2 | string | 30 | Empty | Specifies a user-defined value.
ExplodedQty | Quantity | N/A | N/A | Specifies the quantity used in an MRP quantity calculation.
ManufacturingNote | string | 8000 | Empty | Specifies additional information associated with the picklist.
BOMSequence | int | N/A | Empty | Specifies the sequence in the bill of materials.
PositionNumber2 | int | N/A | Empty | Specifies an alternate part on a picklist.


ManufacturingOrderRouteStep

Description

Defines the properties of a manufacturing order route step in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ManufacturingOrderDocumentKey | ManufacturingOrderDocumentKey | N/A | N/A | A key that uniquely identifies a manufacturing order document.
RouteSequenceNum | int | N/A | Empty | Specifies the sequence number of this step in the route.
RouteSequenceType | ManufacturingOrderRouteSequenceType | N/A | N/A | ManufacturingOrderRouteSequenceType enumeration value that specifies the route type.
ClosedBy | string | 30 | Empty | Specifes the person who closed the manufacturing order.
DateClosed | dateTime | N/A | Empty | Specifies the date the manufacturing order closed.
RouteSeqDescription | string | 100 | Empty | Specifies a description of the route.
ActualFinishDate | dateTime | N/A | Empty | Specifies the date the step completed.
ActualStartDate | dateTime | N/A | Empty | Specifies the date the step started.
ScheduledFinishDate | dateTime | N/A | Empty | Specifies the date the step is schedule to complete.
ScheduledStartDate | dateTime | N/A | Empty | Specifies the date the step is schedule to begin.
WorkCenter | string | 10 | Empty | Specifies the work center.
VendorKey | VendorKey | N/A | N/A | A key that uniquely identifies a vendor.
VendorName | string | 64 | Empty | Specifies the name of the vendor.
OperationCode | string | 6 | Empty | Specifies the operation code associated with the specified work center.
RouteWorkCenter | string | 12 | Empty | Specifies the ID of the routing work center.
RouteMachineID | string | 12 | Empty | Specifies the ID of the machine center.
MachineId | string | 10 | Empty | Specifies the ID of the machine.
SetupTime | decimal | N/A | 0 | Specifies the setup time for the step.
MachineTime | decimal | N/A | 0 | Specifies the machine time for the step.
RunTime | decimal | N/A | 0 | Specifies the run time for the step.
LaborTime | decimal | N/A | 0 | Specifies the labor time for the step.
QueueTime | decimal | N/A | 0 | Specifies the queue time for the step.
CycleTime | decimal | N/A | 0 | Specifies the cycle time for the step.
MoveTime | decimal | N/A | 0 | Specifies the move time for the step.
MRPAmount | MoneyAmount | N/A | N/A | Specifies the amount used as the origninal issue amount.
LaborCode_1 | string | 10 | Empty | Specifies the labor code for the step.
LaborCode_2 | string | 10 | Empty | Specifies an additional labor code for the step.
NextRouteNumber | string | 10 | Empty | Specifies the next step to process for the route.
RoutePartNumber | string | 10 | Empty | Specifies the part number used in parallel routing.
PercentageComplete | int | N/A | 0 | Specifies the completion percentage for the step.
Quantity | Quantity | N/A | N/A | Specifies the quantity amount.
DrawingNumber | string | 30 | Emptyh | Specifies the drawing number assocated with the step.
WaitHours | int | N/A | 0 | Specifies the number of hours spent waiting to process.
IsMultiEmployeeOperation | boolean | N/A | False | Specifies whether the step requires multiple employees.
NumberOfEmployees | int | N/A | 0 | Specifies the number of employees required.
NumberOfCrews | int | N/A | 0 | Specifies the number of crews required.
IsLastSequenceofTheDay | boolean | N/A | False | Specifies whether the sequence is the last scheduled for a specified day.
UserDef_1 | string | 20 | Empty | A user-defined field.
UserDef_2 | string | 20 | Empty | A user-defined field.
DateCreated | dateTime | N/A | Empty | Specifies the date the step was created.
LastModifiedDate | dateTime | N/A | N/A | The date the route step was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
IsCapacityRequirementsPlanned | boolean | N/A | False | Specifies whether capacity requirements planning applies.
Notes | string | 8000 | Empty | Specifies additional information associated with the step.
ManufacturingNote | string | 8000 | Empty | Specifies additional information associated with the maufacturing route.
Pieces | Quantity | N/A | N/A | Specifies the number of pieces created by this step.
Rejects | Quantity | N/A | N/A | Specifies the number of rejects created by this step.
IsAutoBackFlushLabor | boolean | N/A | False | Specifies whether labor costs for the step are backflushed.
IsAutoBackFlushMachine | boolean | N/A | False | Specifies whether machine costs for the step are backflushed.
NumberOfMachines | int | N/A | 0 | Specifies the number of machines required for the step.
IsQualityAssuranceNeeded | boolean | N/A | False | Specifies whether the step is inspected.
POOffsetDays | int | N/A | N/A | Specifies the number of days that the purchase order for the vendor’s services should be offset from the required date for the items. The default entry is the vendor’s planning lead time for the service item, which is entered in the Item Vendor Maintenance window.
WIPOutputPerMOStartQty | Quantity | N/A | N/A | Specifies the number of items per finished item that are expected from this sequence. This is used to calculate the default WIP values for shipping items to and receiving items from an outsourced vendor.
IsPhantomItem | boolean | N/A | False | Specifies whether the item is classifed as a phantom item.
ServiceItem | ManufacturingOrderServiceItem | N/A | N/A | Provides service item information for the step.
IsDone | boolean | N/A | False | Specifies whether the step is completed.


ManufacturingOrderServiceItem

Description

Defines the properties of a manufacturing order service item in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ManufacturingOrderDocumentKey | ManufacturingOrderDocumentKey | N/A | N/A | A key that uniquely identifies a manufacturing order document.
RouteSequenceNum | int | N/A | N/A | Specifies the sequence number of the step in a route.
ServiceItem | ItemKey | N/A | N/A | The item key object that uniquely identifies the item.
QtyToOrder | Quantity | N/A | N/A | Specifies the amount of the service required for the order.
SuggestedQty | Quantity | N/A | N/A | Specifies the suggested amount of the service required for the order.
RequiredDate | dateTime | N/A | Empty | Specifies the date the service item is required.
DateReleased | dateTime | N/A | Empty | Specifies the release date for the service item.


ManufacturingOrderSummary

Description

A representation of the important details of a manufacturing order. The properties are read-only.

Properties

Property | Type | Length | Default | Description
OutSourced | ManufacturingOrderOutSourced | N/A | N/A | ManufacturingOrderOutSourced enumeration specifying whether the order was outsourced.
PostToSite | string | 10 | Empty | Specifies the inventory site for finished items.
IsArchivedMO | boolean | N/A | False | Specifies whether the manufacturing order has been archived.
RoutingName | string | 30 | Empty | Specifies the name of the route.
EndDate | dateTime | N/A | Empty | Specifies the date the manufacturing order ended.
LastModifiedDate | dateTime | N/A | N/A | The date the application was last modified. The value is in Coordinated Universal Time (UTC).
Priority | ManufacturingOrderPriority | N/A | N/A | ManufacturingOrderPriority enumeration value specifying the priority of the manufacturing order.
DateCompleted | dateTime | N/A | Empty | Specifies the date the manufacturing order was completed.
PickNumber | string | 17 | Empty | Specifies the number of the manufacturing pick document.
IsQuickMO | boolean | N/A | False | Specifies whether the manufacturing order is a a Quick Manufacturing Order.

Inherits from

ManufacturingOrderDocumentSummary


MarkupPercentage

Description

A project type where the profit is a markup percentage amount.

Properties

Inherited from the base class

Inherits from

PercentProfitCalculation


MaximumInvoice

Description

Contains information about the maximum invoice for a vendor.

Properties

Property | Type | Length | Default | Description
Item | Choice | N/A | N/A | A choice type that contains either a MoneyAmount or a MaximumInvoiceSpecialAmount.

Examples

The following C# example demonstrates how to retrieve the Item property of a MaximumInvoice object and determine whether it is a money amount or a maximum invoice special amount. Note how the GetType() function is used to retrieve the underlying type of the Item property, and how the typeof() function is used to retrieve the types for the comparison operation.

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Vendor vendor;
            VendorKey vendorKey;
            MaximumInvoice maximumInvoice;
            MoneyAmount maximumInvoiceAmount;
            MaximumInvoiceSpecialAmount maximumInvoiceSpecialAmount;

            // Create an instance of the web service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the web service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Retrieve the vendor object
            vendor = wsDynamicsGP.GetVendorByKey(vendorKey, context);

            // Examine the maximum invoice information
            maximumInvoice = new MaximumInvoice();
            maximumInvoice = vendor.MaximumInvoice;

            if (maximumInvoice.Item.GetType() == typeof(MoneyAmount))
            {
                maximumInvoiceAmount = (MoneyAmount)maximumInvoice.Item;
                MessageBox.Show("Maximum invoice is an amount of " + maximumInvoiceAmount.Value.ToString());
            }

            if (maximumInvoice.Item.GetType() == typeof(MaximumInvoiceSpecialAmount))
            {
                maximumInvoiceSpecialAmount = (MaximumInvoiceSpecialAmount)maximumInvoice.Item;
                MessageBox.Show("Maximum invoice is a special amount: " +
                maximumInvoiceSpecialAmount.ToString());
            }
        }
    }
}

The following C# example shows how the Item property for a vendor maximum invoice can be set to the value in the MaximumInvoiceSpecialAmount enumeration. Notice how the Item property is cast to be of the proper type.

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Vendor vendor;
            VendorKey vendorKey;
            MaximumInvoice maximumInvoice;
            Policy vendorUpdatePolicy;

            // Create an instance of the web service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the web service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Get the UpdateVendor policy
            vendorUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateVendor", context);

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Create the vendor object
            vendor = new Vendor();
            vendor.Key = vendorKey;

            // Set the maximum invoice information
            maximumInvoice = new MaximumInvoice();
            maximumInvoice.Item = (MaximumInvoiceSpecialAmount)MaximumInvoiceSpecialAmount.NoMaximum;
            vendor.MaximumInvoice = maximumInvoice;

            // Update the vendor
            wsDynamicsGP.UpdateVendor(vendor, context, vendorUpdatePolicy);
        }
    }
}


MaximumWriteoff

Description

Contains information about the maximum writeoff amount for a customer or vendor.

Properties

Property | Type | Length | Default | Description
Item | Choice | N/A | N/A | A choice type that contains either a MoneyAmount or a MaximumWriteoffSpecialAmount.

Examples

The following C# example demonstrates how to retrieve the Item property of a MaximumWriteoff object and determine whether it is a money amount or a maximum writeoff special amount. Note how the GetType() function is used to retrieve the underlying type of the Item property, and how the typeof() function is used to retrieve the types for the comparison operation.

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Vendor vendor;
            VendorKey vendorKey;
            MaximumWriteoff maximumWriteoff;
            MoneyAmount maximumWriteoffAmount;
            MaximumWriteoffSpecialAmount maximumWriteoffSpecialAmount;

            // Create an instance of the web service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the web service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a vendor key
            vendorKey = new VendorKey();
            vendorKey.Id = "ACETRAVE0001";

            // Retrieve the vendor object
            vendor = wsDynamicsGP.GetVendorByKey(vendorKey, context);

            // Examine the maximum writeoff information
            maximumWriteoff = new MaximumWriteoff();
            maximumWriteoff = vendor.MaximumWriteoff;

            if (maximumWriteoff.Item.GetType() == typeof(MoneyAmount))
            {
                maximumWriteoffAmount = (MoneyAmount)maximumWriteoff.Item;
                MessageBox.Show("Maximum writeoff is an amount of " + maximumWriteoffAmount.Value.ToString());
            }

            if (maximumWriteoff.Item.GetType() == typeof(MaximumWriteoffSpecialAmount))
            {
                maximumWriteoffSpecialAmount = (MaximumWriteoffSpecialAmount)maximumWriteoff.Item;
                MessageBox.Show("Maximum writeoff is a special amount: " +
                maximumWriteoffSpecialAmount.ToString());
            }
        }
    }
}

The following C# example shows how the Item property for a customer maximum writeoff can be set to the value in the MaximumWriteoffSpecialAmount enumeration. Notice how the Item property is cast to be of the proper type.

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            MaximumWriteoff maximumWriteoff;
            Policy customerUpdatePolicy;

            // Create an instance of the web service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure the default credentials are used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context object with which to call the web service
            context = new Context();

            // Specify which company to use (sample company)
            companyKey = new CompanyKey();
            companyKey.Id = (-1);

            // Set up the context object
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Get the UpdateCustomer policy
            customerUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCustomer", context);

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "WORLDENT0001";

            // Create the customer object
            customer = new Customer();
            customer.Key = customerKey;

            // Set the maximum writeoff information
            maximumWriteoff = new MaximumWriteoff();
            maximumWriteoff.Item = (MaximumWriteoffSpecialAmount)MaximumWriteoffSpecialAmount.NotAllowed;
            customer.MaximumWriteoff = maximumWriteoff;

            // Update the customer
            wsDynamicsGP.UpdateCustomer(customer, context, customerUpdatePolicy);
        }
    }
}


MiscellaneousKey

Description

Uniquely identifies a miscellaneous ID in the Project Accounting module within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The string value used to uniquely identify a miscellaneous ID.

Inherits from

ReferenceKey


MoneyAmount

Description

A monetary value in Microsoft Dynamics GP. A money amount has both a currency and a numeric value.

Properties

Property | Type | Length | Default | Description
Currency | string | 3 | Empty | The ISO Code that identifies the currency for the money amount. For example, US dollars is USD.
Value | decimal | N/A | 0 | The decimal value of the money amount.
DecimalDigits | int | N/A | 0 | The number of decimal places to be applied to the money amount. The value can be from 0 to 5.

Inherits from

Amount


MoneyPercentChoice

Description

A value that is either a money amount or a percent amount.

Properties

Property | Type | Length | Default | Description
Item | Choice | N/A | N/A | A choice type that contains either a MoneyAmount or a Percent amount.

Examples

The following C# example demonstrates how to retrieve the Item property of a money percent choice object and determine whether it is a money amount or a percent amount. In this example, the value is the FinanceCharge property for a customer object. Note how the GetType() function is used to retrieve the underlying type of the Item property, and how the typeof() function is used to retrieve the types for the comparison operation.

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            MoneyPercentChoice financeCharge;
            MoneyAmount financeChargeAmount;
            Percent financeChargePercent;

            // Create an instance of the web service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the web service
            context = new Context();

            // Specify which company (lesson company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "AARONFIT0001";

            // Retrieve the customer object
            customer = wsDynamicsGP.GetCustomerByKey(customerKey, context);

            // Examine the finance charge information
            financeCharge = new MoneyPercentChoice();
            financeCharge = customer.FinanceCharge;

            if (financeCharge.Item.GetType() == typeof(MoneyAmount))
            {
                financeChargeAmount = (MoneyAmount)financeCharge.Item;
                MessageBox.Show("Finance charge is a money amount of: "
                + financeChargeAmount.Value.ToString());
            }

            if (financeCharge.Item.GetType() == typeof(Percent))
            {
                financeChargePercent = (Percent)financeCharge.Item;
                MessageBox.Show("Finance charge is a percentage: " + financeChargePercent.Value.ToString());
            }
        }
    }
}

The following C# example shows how the Item property for a customer finance charge can be set to a money amount, in this case $10 USD. Notice how the Item property is cast to be of the proper type.

using System;
using System.Collections.Generic;
using System.Text;
using System.Windows.Forms;
using DynamicsGPWebServiceSample.DynamicsGPService;

namespace DynamicsGPWebServiceSample
{
    class Program
    {
        static void Main(string[] args)
        {
            CompanyKey companyKey;
            Context context;
            Customer customer;
            CustomerKey customerKey;
            MoneyPercentChoice financeCharge;
            MoneyAmount financeChargeAmount;
            Policy customerUpdatePolicy;

            // Create an instance of the web service
            DynamicsGP wsDynamicsGP = new DynamicsGP();

            // Be sure that default credentials are being used
            wsDynamicsGP.UseDefaultCredentials = true;

            // Create a context with which to call the web service
            context = new Context();

            // Specify which company (lesson company)
            companyKey = new DynamicsGPService.CompanyKey();
            companyKey.Id = (-1);

            // Set up the context
            context.OrganizationKey = (OrganizationKey)companyKey;

            // Get the UpdateCustomer policy
            customerUpdatePolicy = wsDynamicsGP.GetPolicyByOperation("UpdateCustomer", context);

            // Create a customer key
            customerKey = new CustomerKey();
            customerKey.Id = "ADVANCED0001";

            // Create the customer object
            customer = new Customer();
            customer.Key = customerKey;

            // Set the finance charge information
            financeCharge = new MoneyPercentChoice();
            financeChargeAmount = new MoneyAmount();
            financeChargeAmount.Value = 10M;
            financeChargeAmount.DecimalDigits = 2;
            financeChargeAmount.Currency = "USD";
            financeCharge.Item = (MoneyAmount)financeChargeAmount;
            customer.FinanceCharge = financeCharge;

            // Update the customer
            wsDynamicsGP.UpdateCustomer(customer, context, customerUpdatePolicy);
        }
    }
}


MoneyProfitCalculation

Description

The amout of profit for a project calculated as a money amount.

Properties

Property | Type | Length | Default | Description
ProfitAmount | MoneyAmount | N/A | 0 | The amout of profit for a project.

Inherits from

ProfitCalculation


MulticurrencySetup

Description

Contains details about the multicurrency setup in Microsoft Dynamics GP. These properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | MulticurrencySetupKey | N/A | N/A | The multicurrency setup key that uniquely identifies the multicurrency setup.
ReportingCurrencyKey | CurrencyKey | N/A | N/A | The currency key object that specifies the ISO code of the currency used for reporting.
ReportingCurrency ExchangeRate | decimal | N/A | N/A | The exchange rate used when calculating reporting currency amounts.
ReportingCurrencyRate CalculationMethod | RateCalculation | N/A | N/A | The method used for calculating the reporting currency amount.
AllowNewRates | boolean | N/A | N/A | Indicates whether new exchange rates can be used for individual transactions or revaluations.
AllowModifyRates | boolean | N/A | N/A | Indicates whether exchange rates can be modified.
AllowOverrideExchange Rates | boolean | N/A | N/A | Indicates whether exchange rates can be overridden.
AllowOverrideRate Variance | boolean | N/A | N/A | Indicates whether the exchange rate variance can be overridden.
AllowOverrideReporting Rate | boolean | N/A | N/A | Indicates whether the exchange rate can be overridden for reporting and inquiries.
AverageExchangeRate CalculationMethod Display | RateCalculation | N/A | N/A | The method used for calculating the average exchange rate for currency values displayed in summary and inquiry windows.
DefaultFinancialRateType Key | RateTypeKey | N/A | N/A | The default currency rate type to use for financial transactions.
DefaultSalesRateTypeKey | RateTypeKey | N/A | N/A | The default currency rate type to use for sales transactions.
DefaultPurchasingRateTypeKey | RateTypeKey | N/A | N/A | The default currency rate type to use for purchasing transactions.
KeepGeneralLedger AccountHistory | boolean | N/A | N/A | Indicates whether a record of account summary balances for closed fiscal periods is being maintained by Microsoft Dynamics GP.
LastFinancialRevaluation Date | dateTime | N/A | N/A | The most recent date that multicurrency transactions for the Financial series were revalued.
LastPurchasing RevaluationDate | dateTime | N/A | N/A | The most recent date that multicurrency transactions for the Purchasing series were revalued.
LastSalesRevaluationDate | dateTime | N/A | N/A | The most recent date that multicurrency transactions for the Sales series were revalued.
LastTransactionRemoval Date | dateTime | N/A | N/A | The most recent date that transaction history was removed.
LastSummaryRemoval Date | dateTime | N/A | N/A | The most recent date that summary history was removed.

Inherits from

BusinessObject


MulticurrencySetupCriteria

Description

Specifies the criteria to use when retrieving the list of multicurrency setup objects. Typically, the one multicurrency setup object for the Microsoft Dynamics GP installation will be returned.

Properties

None

Inherits from

Criteria


MulticurrencySetupKey

Description

Uniquely identifies the multicurrency setup for the Microsoft Dynamics GP installation.

Properties

Property | Type | Length | Default | Description
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that specifies the ISO code of the functional currency for the Microsoft Dynamics GP installation.

Inherits from

ReferenceKey


Name

Description

Contains name information for an employee.

Properties

Property | Type | Length | Default | Description
Family | string | 20 | Empty | The family name (last name) for the employee.
Given | string | 15 | Empty | The given name (first name) for the employee.
Middle | string | 15 | Empty | The middle name for the employee.
Preferred | string | 20 | Empty | The preferred name (nick name) for the employee.
Alternate | string | 20 | Empty | The alternate name for the employee.
Suffix | string | 4 | Empty | Specifies the suffix to use with the employee name.


NAVCompanyKey

Description

Uniquely identifies a company in Microsoft Dynamics NAV. Reserved for future use.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value that uniquely identifies the company.

Inherits from

OrganizationKey


NoProfit

Description

A project type that has no profit realized.

Properties

Inherited from the base class

Inherits from

ProfitCalculation


OfficeKey

Description

Uniquely identifies the office within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | The unique identifier assigned to the office.

Inherits from

ReferenceKey


OrganizationKey

Description

Provides the underlying storage for the concrete key types that derive from it, such as CompanyKey.

Properties

Key


Parameter

Description

Defines additional information needed to apply a behavior option for a policy behavior.

Properties

Property | Type | Length | Default | Description
Key | ParameterKey | N/A | N/A | The parameter key object that uniquely identifies the parameter. This property is read-only.
Name | string | N/A | N/A | The name of the parameter. This property is read-only.
Value | string | N/A | N/A | The value assigned to the parameter.
Description | string | 256 | N/A | The description of the parameter.


ParameterKey

Description

Uniquely identifies a parameter for a behavior option.

Properties

Property | Type | Length | Default | Description
BehaviorOptionKey | BehaviorOptionKey | N/A | N/A | The behavior option key object that the parameter is part of. This property is read-only.
Id | int | N/A | N/A | The integer identifier assigned to the parameter. This value is read-only.


PayablesVendorPayment

Description

Vendor payment information for payables.

Properties

Inherited from the base class

Inherits from

PayablesDebitDocument


PayablesVendorPaymentCriteria

Description

Specifies the set of criteria to use when retrieving a list of payables vendor payment summary objects. Only payables vendor paymentt sumary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Scope | PayablesVendorPaymentScope | A PayablesVendorPaymentScope enumeration value that specifies the level of filtering to use when returning vendor payment data.

Inherits from

PayablesDocumentCriteriaBase


PayablesVendorPaymentSummary

Description

A representation of the important details common to all vendor payment documents. All of the properties are read-only.

Properties

Inherited from the base class

Inherits from

PayablesDocumentSummaryBase


PayCodeKey

Description

Uniquely identifies a specify type and rate of pay for a project.

Properties

Property | Type | Length | Default | Description
Id | string | 6 | Empty | The unique identifier assigned to the pay code.

Inherits from

ReferenceKey


PayablesCashDetail

Description

Details for a cash payment on a payables document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DocumentId | string | 20 | Empty | A string value used to identify the cash payment.

Inherits from

CashDetail


PayablesCreditDocument

Description

A payables credit document within Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

PayablesDocument


PayablesCreditMemo

Description

A payables credit memo document within Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

PayablesCreditDocument


PayablesCreditMemoCriteria

Description

Specifies the criteria to use when retrieving a list of payables credit memo summary objects. Only payables credit memo summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

PayablesDocumentCriteriaBase


PayablesCreditMemoSummary

Description

A representation of the important details of a payables credit memo within Microsoft Dynamics GP. A list of payables credit memo summary objects is returned by the GetPayablesCreditMemoList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

PayablesDocumentSummaryBase


PayablesDebitDocument

Description

Defines the properties common to a debit document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Terms | PayablesTerms | N/A | N/A | The terms of payment for the document.
WriteoffAmount | MoneyAmount | N/A | 0 | The writeoff amount for the document.
Payment | PayablesPayment | N/A | N/A | Payables specific payment details.
TotalPayments | MoneyAmount | N/A | 0 | The total of all payments on the document. This property is read-only.

Inherits from

PayablesDocument


PayablesDistribution

Description

Defines the properties specific to a general ledger distribution for a payables document.

Properties

Property | Type | Length | Default | Description
Key | PayablesDistributionKey | N/A | N/A | The payables distribution key object that uniquely identifies a distribution instance.
CompanyKey | CompanyKey | N/A | N/A | The company key object that specifies a company. This property is read-only
PostingDate | dateTime | N/A | N/A | The date the distribution was posted.
IsPosted | boolean | N/A | N/A | Indicates whether the distribution has been posted. True indicates it has. False indicates it has not. This property is read-only.

Inherits from

Distribution


PayablesDistributionKey

Description

Uniquely identifies a distribution instance for a payables document.

Properties

Property | Type | Length | Default | Description
PayablesDocumentKey | PayablesDocumentKey | N/A | N/A | The payables document key object that uniquely identifies a payables document the distribution applies to.
SequenceNumber | int | N/A | 0 | The sequence number of the distribution instance.

Inherits from

TransactionKey


PayablesDocument

Description

A set of the common properties for all payables documents in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | PayablesDocumentKey | N/A | Empty | The payables document key object that uniquely identifies a payables document.
VendorDocument Number | string | 20 | Empty | The document number of the vendor's document.
DocumentAmount | MoneyAmount | N/A | If value is not provided, it will be set to sum of (PurchasesAmount + FreightAmount + MiscellaneousAmount + TaxAmount - TradeDiscountAmount) | The sum of this document's amounts.
Date | dateTime | N/A | If not provided, defaults to the system date. | The date of the payables document.
GeneralLedgerPosting Date | dateTime | N/A | If not provided, defaults to the system date. | The general ledger posting date of the document.
PurchasesAmount | MoneyAmount | N/A | 0 | The total purchases amount for the payables document.
Description | string | 30 | Empty | A description of the payables document.
TradeDiscountAmount | MoneyAmount | N/A | 0 | The trade discount amount for the payables document.
TaxAmount | MoneyAmount | N/A | If value is not provided, it will be set to sum of tax detail lines. | The total tax amount for the payables document.
FreightAmount | MoneyAmount | N/A | 0 | The total freight amount for the payables document.
Amount1099 | MoneyAmount | N/A | 0 | The 1099 amount for the payables document.
MiscellaneousAmount | MoneyAmount | N/A | 0 | The total miscellaneous amount for the payables document.
PONumber | string | 20 | Empty | The purchase order number for the payables document.
ExchangeRate | decimal | N/A | 0 | The exchange rate of the payables document. Set this value only for multi-currency transactions. If there is triangulation and both rates are fixed, this is the originating to Euro fixed rate. Otherwise this is the variable rate.
ExchangeDate | dateTime | N/A | If not provided, it will be set to the payables document date. | The exchange date associated with the exchange rate provided.
Type | PayablesDocumentType | N/A | Automatically set, based on the type of payables document being created. | Identifies the type of payables document. This property is read-only.
TransactionState | PayablesTransactionState | N/A | N/A | Indicates whether the payables document was retrieved from the work table, open table or the history table. This property is read-only.
VendorName | string | 64 | N/A | The name of the vendor. This property is read-only.
ChargeAmount | MoneyAmount | N/A | N/A | The amount charged to the vendor's account for this document. This property is read-only.
ModifiedBy | string | N/A | N/A | The user who last modified the payables document. This property is read-only.
ModifiedDate | dateTime | N/A | N/A | The date the payables document was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
PostedBy | string | N/A | N/A | The user who posted the payables document. This property is read-only.
PostedDate | dateTime | N/A | N/A | The date the payables document was posted. This property is read-only.
TaxDate | dateTime | N/A | N/A | The tax date on the payables document. This property is read-only.
AuditTrailCode | string | N/A | N/A | The internally-assigned audit trail code that gets assigned when the transaction is posted. This property is read-only.
IsVoided | boolean | N/A | N/A | Indicates whether the payables document has been voided. This property is read-only.
IsIntercompany Transaction | boolean | N/A | N/A | Indicates whether the payables document is an intercompany transaction. This property is read-only.
HasIntercompany Distributions | boolean | N/A | N/A | Indicates whether there are intercompany distributions. This property is read-only.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch used for the payables document.
VendorKey | VendorKey | N/A | N/A | The vendor key object that uniquely identifies the vendor used for the payables document.
AddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies the address of the vendor used for the payables document. This property is read-only.
RemitToAddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies the remit to address of the vendor used for the payables document. This property is read-only.
TaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the tax schedule used for the payables document. This property is read-only.
ShippingMethodKey | ShippingMethodKey | N/A | N/A | The shipping method key object that uniquely identifies the shipping method used for the payables document. This property is read-only.
PurchaseTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the purchase tax schedule used for the payables document. This property is read-only.
FreightTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the freight tax schedule used for the payables document. This property is read-only.
MiscellaneousTax ScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the miscellaneous tax schedule used for the payables document. This property is read-only.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the ISO Code used for the payables document. This property is read-only.
Distributions | ArrayOfPayablesDistribution | N/A | N/A | A collection of distributions for a payables document. This property is read-only.
Taxes | ArrayOfPayablesTax | N/A | N/A | A collection of tax details for a payables document. This property is read-only.

Inherits from

BusinessObject


PayablesDocumentCriteria

Description

Specifies the criteria to use when retrieving a list of payables document summary objects. Only payables document summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Type | ListRestrictionOfNullableOfPayablesDocumentType | A list restriction specifying the payables document types.

Inherits from

PayablesDocumentCriteriaBase


PayablesDocumentCriteriaBase

Description

Specifies the base set of criteria to use when retrieving a payables document object. Only payables documents that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
DocumentId† | LikeRestrictionOfString | A string restriction specifying the ID of the payables document.
Date | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the payables document.
VendorId† | LikeRestrictionOfString | A string restriction specifying the vendor ID for the payables document.
BatchId† | LikeRestrictionOfString | A string restriction specifying the batch ID for the payables document.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date restriction specifying the date of the payables document. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
TransactionState | ListRestrictionOfNullableOfPayablesTransactionState | A list restriction specifying the transaction state of the payables document.

Inherits from

Criteria


PayablesDocumentKey

Description

Uniquely identifies a payables document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 17 | N/A | The string value that uniquely identifies a payables document.

Inherits from

TransactionKey


PayablesDocumentSummary

Description

A representation of the important details of a payables document within Microsoft Dynamics GP. A list of payables document summary objects is returned by the GetPayablesDocumentList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Type | PayablesDocumentType | N/A | N/A | Identifies the type of payables document.

Inherits from

PayablesDocumentSummaryBase


PayablesDocumentSummaryBase

Description

A representation of the important details common to all payables documents in the Purchasing module in Microsoft Dynamics GP. All of the properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | PayablesDocumentKey | N/A | Empty | The payables document key object that uniquely identifies a payables document.
VendorKey | VendorKey | N/A | N/A | The vendor key object that uniquely identifies the vendor used for the payables document.
VendorName | string | 64 | N/A | The name of the vendor.
Date | dateTime | N/A | N/A | The date of the payables document.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch used for the payables document.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the ISO Code used for the payables document.
TradeDiscountAmount | MoneyAmount | N/A | N/A | The trade discount amount for the payables document.
FreightAmount | MoneyAmount | N/A | N/A | The total freight amount for the payables document.
MiscellaneousAmount | MoneyAmount | N/A | N/A | The total miscellaneous amount for the payables document.
TaxAmount | MoneyAmount | N/A | N/A | The total tax amount for the payables document.
DocumentAmount | MoneyAmount | N/A | N/A | The sum of this document's amounts.
ModifiedDate | dateTime | N/A | N/A | The date the payables document was last modified.
TransactionState | PayablesTransactionState | N/A | N/A | Indicates whether the payables document was retrieved from the work table, open table or the history table.


PayablesFinanceCharge

Description

A payables finance charge document in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

PayablesDebitDocument


PayablesFinanceChargeCriteria

Description

Specifies the criteria to use when retrieving a list of payables finance charge summary objects. Only payables finance charge summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

PayablesDocumentCriteriaBase


PayablesFinanceChargeSummary

Description

A representation of the important details of a payables finance charge within Microsoft Dynamics GP. A list of payables finance charge summary objects is returned by the GetPayablesFinanceChargeList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

PayablesDocumentSummaryBase


PayablesInvoice

Description

A payables invoice document in the Purchasing module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PaymentTermsKey | PaymentTermsKey | N/A | N/A | The payment terms key object that uniquely identifies the terms of payment for the payables document.

Inherits from

PayablesDebitDocument


PayablesInvoiceCriteria

Description

Specifies the criteria to use when retrieving a list of payables invoice summary objects. Only payables invoice summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

PayablesDocumentCriteriaBase


PayablesInvoiceSummary

Description

A representation of the important details of a payables invoice within Microsoft Dynamics GP. A list of payables invoice summary objects is returned by the GetPayablesInvoiceList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

PayablesDocumentSummaryBase


PayablesMiscellaneousCharge

Description

A payables miscellaneous charge document in the Purchasing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PaymentTermsKey | PaymentTermsKey | N/A | N/A | The payment terms key object that uniquely identifies the terms of payment for the payables document.

Inherits from

PayablesDebitDocument


PayablesMiscellaneousChargeCriteria

Description

Specifies the criteria to use when retrieving a list of payables miscellaneous charge summary objects. Only payables miscellaneous charge summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

PayablesDocumentCriteriaBase


PayablesMiscellaneousChargeSummary

Description

A representation of the important details of a payables miscellaneous charge within Microsoft Dynamics GP. A list of payables miscellaneous charge summary objects is returned by the GetPayablesMiscellaneousChargeList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

PayablesDocumentSummaryBase


PayablesPayment

Description

Defines the properties specific to a payment on a payables document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Cash | PayablesCashDetail | N/A | N/A | The details of a cash payment on a payables document.
Check | CheckDetail | N/A | N/A | The details of a check payment on a payables document.
PaymentCard | PaymentCardDetail | N/A | N/A | The details of a payment card payment on a payables document.


PayablesReturn

Description

A payables return document in the Purchasing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DiscountReturned Amount | MoneyAmount | N/A | 0 | If a terms discount was applied, the amount of the discount. This amount will reduce the amount returned to the vendor.
WriteoffAmount | MoneyAmount | N/A | 0 | The writeoff amount for the document.
TotalPayments | MoneyAmount | N/A | 0 | The total of all payments on the document. This property is read-only.
Payment | PayablesPayment | N/A | N/A | The payment details for the payables document.

Inherits from

PayablesCreditDocument


PayablesReturnCriteria

Description

Specifies the criteria to use when retrieving a list of payables return summary objects. Only payables return summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

PayablesDocumentCriteriaBase


PayablesReturnSummary

Description

A representation of the important details of a payables return within Microsoft Dynamics GP. A list of payables return summary objects is returned by the GetPayablesReturnList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

PayablesDocumentSummaryBase


PayablesTax

Description

Defines the properties for purchase tax information for payables documents in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | PayablesTaxKey | N/A | N/A | The payables tax key object that uniquely identifies the payables tax instance.
PurchasesTaxAmount | MoneyAmount | N/A | 0 | The amount of tax on the purchases amount.
FreightTaxAmount | MoneyAmount | N/A | 0 | The amount of tax on the freight amount.
MiscellaneousTaxAmount | MoneyAmount | N/A | 0 | The amount of tax on the miscellaneous amount.
GLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the account to which tax amounts will be posted.
IsPosted | boolean | N/A | N/A | Indicates whether the tax details have been posted. This property is read-only.

Inherits from

Tax


PayablesTaxKey

Description

Uniquely identifies the payables tax within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PayablesDocumentKey | PayablesDocumentKey | N/A | N/A | The payables document key object that uniquely identifies the payables document.
TaxDetailKey | TaxDetailKey | N/A | N/A | The tax detail key object that uniquely identifies the tax detail.

Inherits from

TransactionKey


PayablesTerms

Description

Defines the payment terms specific to a payables document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DiscountTakenAmount | MoneyAmount | N/A | 0 | The payment terms discount amount taken by your company from the vendor.
DiscountAmountAppliedTaken | MoneyAmount | N/A | 0 | The payment terms discount amount taken which has been applied to the payables document.

Inherits from

Terms


PaymentCardAccount

Description

A payment card that is used by a customer.

Properties

Property | Type | Length | Default | Description
Key | PaymentCardAccountKey | N/A | Empty | The payment card account key object that uniquely identifies the payment card account.
ExpirationDate | dateTime | N/A | Empty | The expiration date for the payment card.


PaymentCardAccountKey

Description

Uniquely identifies a payment card account object.

Properties

Property | Type | Length | Default | Description
PaymentCardTypeKey | PaymentCardTypeKey | N/A | N/A | The payment card type key object that uniquely identifies the payment card type.
Number | string | 20 | Empty | The number for the payment card.

Inherits from

ReferenceKey


PaymentCardDetail

Description

Defines a payment card payment/receipt within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Amount | MoneyAmount | N/A | 0 | The payment card amount.
Date | dateTime | N/A | Empty | The date the payment card payment/receipt was received.
Number | string | 20 | N/A | The payment card payment/receipt number.
ReceiptNumber | string | 20 | Empty | The receipt number.
TypeKey | PaymentCardTypeKey | N/A | Empty | The payment card type key object that specifies the type of payment card used to record the payment/receipt.


PaymentCardType

Description

Defines a type of payment card (credit card) within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | PaymentCardTypeKey | N/A | N/A | The payment card type key object that uniquely identifies the payment card type.
ReceivableCardType | ReceivableCardType | N/A | N/A | Specifies the payment card type that is accepted by customers.
UsedByCompany | boolean | N/A | N/A | Specifies whether the payment card is used by the company. True indicates the payment card is used by the company. False indicates it is not.
AcceptedFromCustomers | boolean | N/A | N/A | Specifies whether the payment card is accepted from customers for payment. True indicates the card is accepted from customers. False indicates it is not.
CustomerCardBank AccountKey | BankAccountKey | N/A | N/A | The bank account key object that specifies the bank account (checkbook) if the payment card is accepted from customers and the ReceivableCardType is set to Bank Card.
GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the GL account to use if the payment card is accepted from customers and the receivable card type is set to Payment Card.
VendorKey | VendorKey | N/A | N/A | The vendor key object that specifies the vendor to use if the payment card is used by the company.
PayableCardType | PayableCardType | N/A | N/A | Specifies the payment card type that is used by the company.
CompanyCardBank AccountKey | BankAccountKey | N/A | N/A | The bank account key object that specifies the bank account (checkbook) if the payment card is used by the company and the PayableCardType is set to Check Card.
ModifiedBy | string | N/A | N/A | The user who last modified the payment card type data.
CreatedDate | dateTime | N/A | N/A | The date the payment card type was created.
ModifiedDate | dateTime | N/A | N/A | The date the payment card type data was last modified.

Inherits from

BusinessObject


PaymentCardTypeCriteria

Description

Specifies the criteria to use when retrieving a list of payment card type objects. Only payment card type objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Id | LikeRestrictionOfString | A string restriction specifying the ID.

Inherits from

Criteria


PaymentCardTypeKey

Description

Uniquely identifies a payment card type within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The string that uniquely identifies the type of payment card.

Inherits from

ReferenceKey


PaymentTerms

Description

A set of payment terms in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | PaymentTermsKey | N/A | N/A | The payment terms key object that uniquely identifies the payment terms.
DueDateBasedOn | DueDateBasedOn | N/A | Net Days | Specifies how to determine when the full payment is due.
DaysUntilDue | int | N/A | 0 | The number of days until payment is due.
DiscountDateBasedOn | DiscountDateBasedOn | N/A | Days | Specifies how to determine when payment must be made for a discount to be given.
DaysDiscountAvailable | int | N/A | 0 | The maximum number of days after the invoice date that the discount will be given.
Discount | MoneyPercentChoice | N/A | 0 | The amount of the discount.
UseGracePeriods | boolean | N/A | False | Indicates whether customer or vendor grace periods will be used.
IsDiscountCalculatedOn SalePurchase | boolean | N/A | False | Indicates whether the discount is applied to the sale price.
IsDiscountCalculatedOn TradeDiscount | boolean | N/A | False | Indicates whether the discount is applied to trade discounts.
IsDiscountCalculatedOn Freight | boolean | N/A | False | Indicates whether the discount is applied to freight.
IsDiscountCalculatedOn Miscellaneous | boolean | N/A | False | Indicates whether the discount is applied to miscellaneous expenses.
IsDiscountCalculatedOn Tax | boolean | N/A | False | Indicates whether the discount is applied to taxes.
UseValueAddedTax | boolean | N/A | False | Indicates whether value-added tax is used.
ModifiedBy | string | N/A | N/A | The user who last modified the payment terms data.
CreatedDate | dateTime | N/A | N/A | The date the payment terms were created.
ModifiedDate | dateTime | N/A | N/A | The date the payment terms were last modified.

Inherits from

BusinessObject


PaymentTermsCriteria

Description

Specifies the criteria to use when retrieving a list of payment terms objects. Only payment terms objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Id | LikeRestrictionOfString | A string restriction specifying the ID of the payment terms.

Inherits from

Criteria


PaymentTermsKey

Description

Uniquely identifies a set of payment terms.

Properties

Property | Type | Length | Default | Description
Id | string | 20 | N/A | The unique identifier assigned to the payment terms.

Inherits from

ReferenceKey


PayrollDepartmentKey

Description

Uniquely identifies a payment department code for a project timesheet.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The payroll department code.

Inherits from

ReferenceKey


PayStepKey

Description

Uniquely identifies an employee pay step.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | A value that uniquely identifies the pay step.

Inherits from

ReferenceKey


Percent

Description

A percent amount in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Value | decimal | N/A | 0 | The decimal value of the percent amount.
DecimalDigits | int | N/A | 0 | The number of decimal places to be applied to the percent amount. The value can be from 0 to 5.


PercentOfActual

Description

A project for which the profit is a percent of the actual cost.

Properties

Inherited from the base class

Inherits from

PercentProfitCalculation


PercentOfBaseline

Description

A project for which the profit is a percent of the baseline cost.

Properties

Inherited from the base class

Inherits from

PercentProfitCalculation


PercentProfitCalculation

Description

The amout of profit for a project calculated as a percent amount.

Properties

Property | Type | Length | Default | Description
ProfitPercent | Percent | N/A | 0 | The profit percentage amount.

Inherits from

ProfitCalculation


PhoneNumber

Description

Represents a telephone number in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Value | string | 11 | Empty | The telephone number without the country code or extension.
CountryCode | string | 3 | Empty | The country code for the telephone number.
Extension | string | 7 | Empty | The extension for the telephone number.


PlannedOrder

Description

Defines the properties of a planned order in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ReleaseDate | dateTime | N/A | Empty | Specifies the date that the MO/PO needs to be released to ensure that the item will be received into the location when it is needed.
PlannedOrderKey | PlannedOrderKey | N/A | N/A | A key that uniquely identifies the planned order.
ItemKey | ItemKey | N/A | N/A | A key that uniquely identifies an item.
LocationKey | WarehouseKey | N/A | N/A | A key that uniquely identifies the site where the item is needed.
DueDate | dateTime | N/A | Empty | Specifies the date the item is needed.
RunNumber | int | N/A | Empty | Specifies the MRP regeneration number.
LLC | int | N/A | Empty | Specifies the low-level codes used for MRP calcualations.
QuantityToOrder | Quantity | N/A | N/A | Specifies the quantity to order.
UnitOfMeasure | string | 8 | Empty | Specifies the unit of measure for the item.
VendorKey | VendorKey | N/A | N/A | A key that uniquely identifies the primary vendor for the item.
Replenishment | PlannedOrderReplenishment | N/A | N/A | PlannedOrderReplenishment enumeration value specifying how the item is obtained.
Transferred | boolean | N/A | False | Specifies whether the order has been transferred to a MO or PO.
IsCRPScheduled | boolean | N/A | False | Specifies whether capacity resource planning is scheduled.
Items | ArrayOfPlannedOrderItem | N/A | N/A | A collection of planned order item objects.

Inherits from

BusinessObject


PlannedOrderCriteria

Description

Specifies additional criteria to use when retrieving a list of planned order summary objects. To see the original criteria, see the base class. Only planned order summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ReplenishmentMethod | ListRestrictionOfNullableOfPlannedOrderReplenishment | A restriction specifying the planned order replenishment value.
Transferred | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the planned order has been transferred.
RunNumber | BetweenRestrictionOfNullableOfInt32 | An Int32 restriction specifying a range of run number values.

Inherits from

PlannedOrderCriteriaBase


PlannedOrderCriteriaBase

Description

Specifies the set of criteria to use when retrieving a list of planned order summary objects. Only planned order summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
PlannedOrderKey† | LikeRestrictionOfString | A string restriction specifying the ID of the planned order.
ItemKey | LikeRestrictionOfString | A string restriction specifying the ID of the item.
LocationKey† | LikeRestrictionOfString | A string restriction specifying the ID of the location.
DueDate† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the range of dates to use to identify when the planned order is due.
ReleaseDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the range of dates to use to identify when the planned order is released.
VendorKeyId | LikeRestrictionOfString | A string restriction specifying the ID of the vendor.

Inherits from

Criteria


PlannedOrderItem

Description

Defines the properties of a planned order item in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
RequiredByOpenMO | Quantity | N/A | N/A | Specifies the demand from unallocated components for quote and open manufacturing orders in the issue-from site, including MRP-Planned demand whose status is Planned.
DueDate | dateTime | N/A | N/A | Specifies the date the item is required.
ItemKey | ItemKey | N/A | N/A | A key that uniquely identifies an item.
LocationKey | WarehouseKey | N/A | N/A | A key that uniquely identifies a site.
PlannedOrderKey | PlannedOrderKey | N/A | N/A | The key that uniquely identifies the planned order item.
MRPType | PlannedOrderMRPType | N/A | N/A | PlannedOrderMRPType enumeration value specifying the type of order.
MRPParentType | PlannedOrderParentMRPType | N/A | N/A | PlannedOrderParentMRPType enumeration value specifying the type of the parent order.
SequenceNumber | int | N/A | N/A | A unique number value for each line in a manufacturing order picklist.
PhantomParent | string | 30 | Empty | Specifies the part number for the phantom subassembly for applicable items.
Status | PlannedOrderItemStatus | N/A | N/A | PlannedOrderItemStatus enumeration value specifying the status of the planned order item.
StatusDescription | string | 30 | Empty | Specifies additional status information.
AllocatedByOpenMO | Quantity | N/A | N/A | Specifies the demand from allocated components at the issue from site from picklist for manufacturing orders with Quote or Open status. The allocated quantity will be recongnized by MRP on the date when the item is required by the manufacturing order.
AllocatedByReleasedMO | Quantity | N/A | N/A | Specifies the demand from the unissued and allocated components at the issue-from site from picklists for manufacturig orders with Release or Partially Received (or possible Complete) status. The allocated quantity of an item will be recognized by MRP on the date when the item is required by the manufacturing order.
ConsumedByOpenMO | Quantity | N/A | N/A | Specifies the demand from all unissued components of quote and open manufacturing orders—regardless of allocation status—in the issue-from site, including MRP-planned demand with Planned status.
ConsumedByReleasedMO | Quantity | N/A | N/A | Specifies the demand from all unissued components for released or partially-received (or possibly complete manufacturing orders—regardless of allocation status—in the issue-from site.
RequiredByReleasedMO | Quantity | N/A | N/A | Specifies the demand from unissued, unallocated components for released, partially-received, complete manufacturing orders in the issue-from site.
MoveIn | boolean | N/A | False | Specifies whether MRP is suggesting to move the existing order in.
MoveOut | boolean | N/A | False | Specifies whether MRP is suggesting to move the existing order out.
OriginalDueDate | dateTime | N/A | N/A | Specifies the original due date when MRP suggests move in or move out.
Canceled | boolean | N/A | False | Specifies whether MRP is suggesting to cancel the existing order.
Exceptions | PlannedOrderItemExceptions | N/A | N/A | PlannedOrderItemException object that provides exception information for the order item.


PlannedOrderItemExceptions

Description

Provides exception information for a planned order item object.

Properties

Property | Type | Length | Default | Description
HasException1 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException2 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException3 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException4 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException5 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException6 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException7 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException8 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException9 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException10 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException11 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException12 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException13 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException14 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException15 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException16 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException17 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException18 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException19 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.
HasException20 | boolean | N/A | False | Specifies whether the order item includes the specifed type of exception.


PlannedOrderKey

Description

Uniquely identifies a planned order in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | N/A | The value that uniquely identifies a planned order.

Inherits from

ReferenceKey


PlannedOrderSummary

Description

A representation of the important details of a planned order. The properties are read-only.

Properties

Property | Type | Length | Default | Description
PlannedOrderKey | PlannedOrderKey | N/A | N/A | A key that uniquely identifies the planned order.
ItemKey | ItemKey | N/A | N/A | A key that uniquely identifies an item.
LocationKey | WarehouseKey | N/A | N/A | A key that uniquely identifies the site where the item is needed.
DueDate | dateTime | N/A | Empty | Specifies the date the item is needed.
RunNumber | int | N/A | Empty | Specifies the MRP regeneration number.
ReleaseDate | dateTime | N/A | Empty | Specifies the date that the MO/PO needs to be released to ensure that the item will be received into the location when it is needed
QuantityToOrder | Quantity | N/A | N/A | Specifies the quantity to order.
VendorKey | VendorKey | N/A | N/A | A key that uniquely identifies the primary vendor for the item.

Inherits from

BusinessObjectSummary


PlannerKey

Description

Uniquely identifies a planner within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The value that uniquely identifies a planner.

Inherits from

ReferenceKey


Planning

Description

Defines the resource planning information for an item warehouse combination within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
OrderPolicy | OrderPolicy | N/A | N/A | The order policy to be used for the item.
FixedOrderQuantity | Quantity | N/A | N/A | Planned orders will be generated for the fixed quantity whenever there is a net requirement.
OrderPointQuantity | Quantity | N/A | N/A | The quantity this item should be reordered at to maintain your desired stock. This quantity is used to calculate the quantity to reorder.
OrderUpToLevelQuantity | Quantity | N/A | N/A | The amount that is the sum of the Order Point Qty and an amount you choose. The Order-Up-To Level is known as the target inventory level in some systems.
ReplenishmentMethod | ReplenishmentMethod | N/A | N/A | Specifies how supply of the item should be obtained.
ShrinkageFactor | Percent | N/A | N/A | The percentage of the anticipated loss for this item.
PurchasingLeadTime | decimal | N/A | N/A | The number of days needed to obtain a purchased item.
ManufacturingLeadTime | decimal | N/A | N/A | The amount of time (in days) required to produce an item, and that is not dependent on the quantity of items being manufactured.
TimeFence | short | N/A | N/A | A period of time, usually a certain number of days, during which you don't want to adjust manufacturing order or purchase orders.
MinimumOrderQuantity | Quantity | N/A | N/A | The minimum allowable order size for the item.
MaximumOrderQuantity | Quantity | N/A | N/A | The maximum allowable order size for the item.
OrderMultipleQuantity | Quantity | N/A | N/A | The multiple to be used in calculating order sizes for the item.
ReorderVarianceQuantity | Quantity | N/A | N/A | The amount of allowable tolerance for the order point quantity.
SafetyStockQuantity | Quantity | N/A | N/A | The quantity of the item to have on hand for this item-site combination.


Policy

Description

Defines a policy for a web method in the Dynamics GP web service. Each policy has a set of behaviors that control specific characteristics of the business object being managed by the web method. For example, the Create Sales Order policy contains behaviors that control characteristics of the sales document being created by the CreateSalesOrder web method. The properties for a policy are read-only.

Properties

Property | Type | Length | Default | Description
Key | PolicyKey | N/A | N/A | The policy key object that uniquely identifies the policy.
Behaviors | ArrayOfBehavior | N/A | N/A | The collection of behaviors associated to the policy.
Name | string | N/A | N/A | The name of the policy.
RootBusinessObject Name | string | N/A | N/A | The business object that the policy applies to.


PolicyKey

Description

Uniquely identifies a policy.

Properties

Property | Type | Length | Default | Description
Id | GUID | N/A | N/A | A globally unique identifier (GUID) assigned to the policy. This property is read-only.


PolicySummary

Description

A representation of the important details of a policy in the Dynamics GP web service. A list of policy summary objects is returned by the GetPolicyList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | PolicyKey | N/A | N/A | The policy key object that uniquely identifies the policy.
Name | string | N/A | N/A | The name of the policy.
RootBusinessObject Name | string | N/A | N/A | The business object that the policy applies to.


PositionKey

Description

Uniquely identifies a position type within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 6 | N/A | The unique identifier assigned to the position type.

Inherits from

ReferenceKey


PostedPayablesVendorPayment

Description

Posted vendor payment information for payables.

Properties

Inherited from the base class

Inherits from

PayablesVendorPayment


PostedPayablesVendorPaymentCriteria

Description

Specifies the set of criteria to use when retrieving a list of posted payables vendor payment summary objects. Only posted payables vendor payment summary objects that match the specified criteria will be returned. For the best performance, create criteria that use only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Inherited from the base class

Inherits from

PayablesVendorPaymentCriteria


PostedPayablesVendorPaymentSummary

Description

A representation of the important details of a posted vendor payment document. All of the properties are read-only.

Properties

Inherited from the base class

Inherits from

PayablesVendorPayment


PriceLevel

Description

Defines a price level that is used to facilitate broad grouping of prices in the Inventory module for Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | PriceLevelKey | N/A | N/A | The price level key object that uniquely identifies the price level.
Description | string | N/A | N/A | The description of the price level.
CreatedDate | dateTime | N/A | N/A | The date the price level was created.
ModifiedDate | dateTime | N/A | Set to the system date | The last date the price level was modified. The time is in Coordinated Universal Time (UTC).
LastModifiedDate | dateTime | N/A | Set to the system date | The last date the price level was modified. The time is in Coordinated Universal Time (UTC).
LastModifiedBy | string | N/A | N/A | Not implemented.

Inherits from

BusinessObject


PriceLevelChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of price level objects that have changed. Only changed price level key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
PriceLevelKeyId | BetweenRestrictionOfString | A string restriction specifying the price level key.

Inherits from

BaseChangedKeyCriteria


PriceLevelCriteria

Description

Specifies the criteria to use when retrieving a list of price level summary objects. Only price level summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
PriceLevelKeyId | BetweenRestrictionOfString | A string restriction specifying the price level key.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the price level was created.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the price level was modified.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the price level was modified.

Inherits from

Criteria


PriceLevelKey

Description

Uniquely identifies a price level within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | N/A | The string value used to identify a price level.

Inherits from

ReferenceKey


Pricing

Description

Defines the pricing for an item in the Inventory module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | PricingKey | N/A | Empty | The pricing key object that uniquely identifies the pricing instance.
Round | RoundingType | N/A | None | The rounding to be applied to the calculated price.
UofMSalesOption | UofMSalesAvailable | N/A | Whole | The options that determine how the unit of measure is handled on a sale.
Details | ArrayOfPricingDetail | N/A | N/A | A collection of pricing details.
LastModifiedDate | dateTime | N/A | Set to the system date | The last date the pricing was modified. The time is in Coordinated Universal Time (UTC).
LastModifiedBy | string | N/A | N/A | Not implemented.

Inherits from

BusinessObject


PricingChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of pricing objects that have changed. Only changed pricing key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
ItemKeyId | BetweenRestrictionOfString | A string restriction specifying the item key.
CurrencyKeyId | BetweenRestrictionOfString | A string restriction specifying the currency key.
PriceLevelKeyId | BetweenRestrictionOfString | A string restriction specifying the price level key.
UofMKeyId | BetweenRestrictionOfString | A string restriction specifying the unit of measure key.

Inherits from

BaseChangedKeyCriteria


PricingCriteria

Description

Specifies the criteria to use when retrieving a list item pricing summary objects. Only item pricing summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
ItemId | LikeRestrictionOfString | A string restriction specifying the item ID.
CurrencyISOCode | LikeRestrictionOfString | A string restriction specifying the currency ISO code.
PriceLevelId | LikeRestrictionOfString | A string restriction specifying the price level ID.
UofM | LikeRestrictionOfString | A string restriction specifying the unit of measure.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the pricing was modified.

Inherits from

Criteria


PricingDetail

Description

Defines the pricing detail for an item in the Inventory module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | PricingDetailKey | N/A | Empty | The pricing detail key object that uniquely identifies the pricing detail.
UofMPrice | PricingDetailPrice | N/A | N/A | The price for a single unit of measure. The value may be a money amount or a percent.
LastModifiedDate | dateTime | N/A | Set to the system date | The last date the pricing was modified. The time is in Coordinated Universal Time (UTC).
LastModifiedyBy | string | N/A | N/A | Not implemented.

Inherits from

BusinessObject


PricingDetailKey

Description

Uniquely identifies a pricing detail within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PricingKey | PricingKey | N/A | Empty | The pricing key object that uniquely identifies the pricing instance.
ToQuantity | Quantity | N/A | 0 | The ending quantity for the quantity range for the pricing detail instance.

Inherits from

ReferenceKey


PricingDetailPrice

Description

The price for a single unit of measure of an inventory item.

Properties

Property | Type | Length | Default | Description
Item | Choice | N/A | Empty | A choice type that specifies either a MoneyAmount or a Percent.


PricingKey

Description

Uniquely identifies a pricing instance within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ItemKey | ItemKey | N/A | Empty | The item key object that uniquely identifies the item.
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that uniquely identifies the ISO code of the currency.
PriceLevelKey | PriceLevelKey | N/A | Empty | The price level key object that uniquely identifies the price level.
UofM | string | 8 | Empty | The unit of measure.

Inherits from

ReferenceKey


PricingSummary

Description

A representation of the important details of an item pricing within Microsoft Dynamics GP. A list of item pricing summary objects is returned by the GetItemList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | PricingKey | N/A | Empty | The pricing key object that uniquely identifies the pricing instance.
LastModifiedDate | dateTime | N/A | Set to the system date | The last date the pricing was modified. The time is in Coordinated Universal Time (UTC).
LastModifiedBy | string | N/A | N/A | Not implemented.


PrimaryPayCodeKey

Description

The primary pay code for an employee.

Properties

Property | Type | Length | Default | Description
Id | string | 6 | Empty | The unique identifier for the pay code.

Inherits from

ReferenceKey


Profit

Description

The base class on which profit types for projects are based.

Properties

None


ProfitCalculation

Description

The base class for project profit calculations.

Properties

None


ProfitFixed

Description

A project for which the profit amount is the actual cost plus a fixed amount for each unit quantity.

Properties

Inherited from the base class

Inherits from

MoneyProfitCalculation


ProfitVariable

Description

A project for which the profit amount is the actual cost plus an amount for each unit quantity.

Properties

Inherited from the base class

Inherits from

MoneyProfitCalculation


Project

Description

Defines the properties for a project in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies a customer.
ProjectContractKey | ProjectContractKey | N/A | N/A | The project contract key object that uniquely identifies a project contract.
ProjectContractId | string | N/A | N/A | The contract ID assigned to a project.
ProjectId | string | N/A | N/A | The project ID assigned to a project.
Name | string | N/A | N/A | A descriptive name for a project.
Key | ProjectKey | N/A | N/A | The project key object that uniquely identifies a project.
ProjectClassKey | ProjectClassKey | N/A | N/A | The project class key object that uniquely identifies a project class.
Type | ProjectType | N/A | N/A | Determines how a contractor is to compute project costs and charge customers for such costs. It also is a way to determine how much revenues can be generated in a project.
AccountingMethod | ProjectAccountingMethod | N/A | N/A | Determines the Percentage Completion of a certain project, budget or fee to determine the revenues to be recognized.
Status | ProjectStatus | N/A | N/A | Identifies the status of the project.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies a currency.
CustomerPONumber | string | N/A | N/A | The purchase order number issued by the customer for the project.
CloseToProjectCosts | boolean | N/A | N/A | Option to allow or disallow cost transaction entry and posting for the project. False means to Allow. True means to Disallow.
CloseToBillings | boolean | N/A | N/A | Option to allow or disallow billing transaction entry and posting for the project. False means to Allow. True means to Disallow.
DepartmentKey | ProjectDepartmentKey | N/A | N/A | The project department key object that uniquely identifies a department.
EstimatorKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the estimator.
ProjectManagerKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies a project manager.
BusinessManagerKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies a business manager.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that uniquely identifies a salesperson.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that uniquely identifies a sales territory.
CommissionPercent | Percent | N/A | N/A | The commission percent for the project.
CommissionBasedOn | CommissionBasedOn | N/A | N/A | An option which determines whether the salesperson's commissions will be calculated as a percentage of the sale amount or as a percentage of the total, including the sale amount, freight, taxes, and miscellaneous charges
ContactPerson | string | N/A | N/A | The name of the contact person at the ship to address
BillToAddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies a bill to address.
LaborRateTableKey | ProjectLaborRateTableKey | N/A | N/A | The project labor rate table key object that uniquely identifies a labor rate table.
LaborRateTableType | ProjectLaborRateTableType | N/A | N/A | The project labor rate table key object that uniquely identifies a labor rate table.
DoesAcceptLaborRate TableReplacement | boolean | N/A | N/A | An option to replace the labor rate table currently assigned to the project.
EquipmentRateTableKey | ProjectEquipmentRateTableKey | N/A | N/A | The project equipment rate table key object that uniquely identifies an equipment rate table.
DoesAcceptEquipment RateTableReplacement | boolean | N/A | N/A | An option to replace the equipment rate table currently assigned to the project.
BillingType | BillingType | N/A | N/A | Identifies the billing type to be used when transactions are created for the project. For Time and materials, fixed price, cost plus project types select Standard to bill customers for project costs based on a specific profit type; for Time and materials project types select No charge when you won’t charge customers for project costs; for Time and materials project types select No Billing when you won’t bill customers for project costs.
ServiceFeeAmount | MoneyAmount | N/A | N/A | An amount for services to be rendered over a specified period.
ProjectFeeAmount | MoneyAmount | N/A | N/A | Management fee, professional fee, incentive fee or any other similar fee amount that forms part of the total project or contract amount.
RetainerAmount | MoneyAmount | N/A | N/A | Prepaid amount to be included in project billings. Professionals require retainer to ensure cash flow and bill collection.
RetentionFeeAmount | MoneyAmount | N/A | N/A | An amount that is not included in progress billings for a fixed price or cost plus project until the project is completed or until specified project conditions and guarantees are met.
ProjectAmount | MoneyAmount | N/A | N/A | Project Amount is the sum of Forecast Project Revenue for each Cost Category + sum of Project Fees + sum of Service Fees.
AccountAmount | MoneyAmount | N/A | N/A | The retainer amount applied to the customer account. Retainer is a prepaid amount given by a customer. Professionals usually require retainer to ensure cash flow and payment of services later
DefaultBillingFormat | string | N/A | N/A | Identifies the default billing format to be used when printing billings during cycle billing.
DiscountPercent | Percent | N/A | N/A | The discount percent given to the customer for this project.
RetentionPercent | Percent | N/A | N/A | The percentage of billing amount that will be withheld in progress billings for a fixed price and cost plus project.
UserDefinedText1 | string | N/A | N/A | User defined data.
UserDefinedText2 | string | N/A | N/A | User defined data.
DoesCombineForRevenue Recognition | boolean | N/A | N/A | An option to combine earnings from various cost categories in the same project.
WriteUpDownAmount | MoneyAmount | N/A | N/A | The amount to be added or subtracted from the billing amount for the project. Contractors, and more often, professionals, usually use write up or write down to change the billing amount.
CostCompletedPercent | Percent | N/A | N/A | The percentage of cost expended, if you selected the accounting method When Performed, When Billed, Cost-to-Cost or Completed.
QuantityCompleted Percent | Percent | N/A | N/A | The percentage of effort expended, if you selected the accounting method Effort-Expended. The Effort-Expended option is usually used to track the number of hours used in a project.
POCommittedCosts | MoneyAmount | N/A | N/A | The costs that are committed on a purchase order.
POCommittedQuantity | Quantity | N/A | N/A | The quantities that are committed on a purchase order.
WorkersCompensation Key | WorkersCompensationKey | N/A | N/A | The workers compensation key object that uniquely identifies workers compensation classification that applies to the employee on a timesheet transaction.
SUTAState | string | N/A | N/A | Code assigned to the employee to which unemployment taxes are paid by the state.
BillingNotReceivable | MoneyAmount | N/A | N/A | Actual billing not receivables management.
RestrictToCustomerList | boolean | N/A | N/A | An option to restrict the Customer ID to customers included in the Third Party Customer List. When this option is marked, users can to choose only customers in the list when billing.
TransactionalCurrency CodeKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the transactional (originating) currency.
Forecast | ProjectForecast | N/A | N/A | The forecast amounts for a project.
Baseline | ProjectBaseline | N/A | N/A | The baseline amounts for a project.
Billed | ProjectBilled | N/A | N/A | The billed amounts for a project.
Posted | ProjectPosted | N/A | N/A | The posted amounts for a project.
Unposted | ProjectUnposted | N/A | N/A | The unposted amounts for a project.
Actual | ProjectActual | N/A | N/A | The actual amounts for a project.
BillingCycles | ArrayOfProjectBillingCycle | N/A | N/A | A collection of billing cycles for a project.
Accounts | ArrayOfProjectAccountType | N/A | N/A | A collection of GL accounts for a project.
EquipmentList | ArrayOfProjectEquipmentItem | N/A | N/A | A collection of equipment for a project.
Fees | ArrayOfProjectFee | N/A | N/A | A collection of fees for a project.
Budgets | ArrayOfProjectBudget | N/A | N/A | A collection of budgets for a project.

Inherits from

BusinessObject


ProjectAccountType

Description

Defines the properties for project account type in the Project Accounting module for Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectAccountTypeKey | N/A | N/A | The project account key object that uniquely identifies a project account.
GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that uniquely identifies a GL account.

Inherits from

BusinessObject


ProjectAccountTypeKey

Description

Uniquely identifies a project account type within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
SourceFile | ProjectSourceFile | N/A | N/A | Identifies the source file.
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies a project.
CostTransaction | string | N/A | N/A | Identifies a project cost transaction (leave blank for fee accounts): TS=Timesheet; EL=Equipment log; VI=Purchase materials; ML=Miscellaneous log; EE=employee expense.
DistributionTypeKey | DistributionTypeKey | N/A | N/A | The distribution type key object that uniquely identifies a distribution type.

Inherits from

ReferenceKey


ProjectAccountingOptions

Description

Defines the properties for the Project Accounting options for a vendor within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DefaultPurchaseOrder Format | PurchaseOrderFormat | N/A | PO Format A | Identifies the format to be used when printing a PO for the vendor.
UnitOfMeasure | string | 8 | Empty | Identifies the unit of measure used for work performed on a project by the vendor.
UnitCost | MoneyAmount | N/A | 0 | Holds the cost amount per unit of measure. For example 45 dollars for each hour of work.
TimeAndMaterial | TimeAndMaterial | N/A | Billing Rate | Identifies the profit type calculation and the value to be used for time and material projects for the vendor. The time and material amount can be a money amount or a percent.
FixedPrice | FixedPrice | N/A | Profit Fixed | Identifies the profit type calculation and the value to be used for fixed price projects for the vendor. The fixed price amount can be a money amount or a percent.
CostPlus | CostPlus | N/A | Profit Fixed | Identifies the profit type calculation and the value to be used for cost plus projects for the vendor. The cost plus amount can be a money amount or a percent.
UserDefined1 | string | N/A | Empty | User-defined text.
UserDefined2 | string | N/A | Empty | User-defined text.


ProjectActual

Description

Defines the common properties for the actual dates in the Project Accounting module within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
BeginDate | dateTime | N/A | N/A | Holds the actual begin date of the project. The beginning and ending date indicate the scheduled utilization of the project.
EndDate | dateTime | N/A | N/A | Holds the actual end date of the project. The beginning and ending date indicate the scheduled utilization of the project.

Inherits from

ProjectAmount


ProjectAmount

Description

Defines the amount properties for a project in the Project Accounting module within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Quantity | Quantity | N/A | N/A | The total number of units allocated.
TotalCost | MoneyAmount | N/A | N/A | The total cost. Total cost is set in cost and billing transactions as well as in revenue recognition.
OverheadAmount | MoneyAmount | N/A | N/A | The overhead amount.
ProfitAmount | MoneyAmount | N/A | N/A | The profit amount.
TaxAmount | MoneyAmount | N/A | N/A | The tax amount for a project.
AccruedRevenueAmount | MoneyAmount | N/A | N/A | The accrued revenue amount.
RecognizedRevenue Amount | MoneyAmount | N/A | N/A | The recognized revenue amount.
BillingsInExcessOf EarningsAmount | MoneyAmount | N/A | N/A | The billings in excess of earnings amount.
EarningsInExcessOf BillingsAmount | MoneyAmount | N/A | N/A | The earnings in excess of billings amount.
BillingAmount | MoneyAmount | N/A | N/A | The billing amount.
DiscountAmount | MoneyAmount | N/A | N/A | The discount amount.
SalesTaxAmount | MoneyAmount | N/A | N/A | The sales tax amount.
RetainageAmount | MoneyAmount | N/A | N/A | The retainage amount.


ProjectBaseline

Description

The baseline amounts in the Project Accounting module in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ProjectBudgetBase


ProjectBilled

Description

The billed amounts in the Project Accounting module in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ProjectBilledBase


ProjectBilledBase

Description

The common properties for billed amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Quantity | Quantity | N/A | N/A | The total billed quantity.
Cost | MoneyAmount | N/A | N/A | The total billed cost.
AccruedRevenue | MoneyAmount | N/A | N/A | The total billed accrued revenue.


ProjectBilling

Description

The properties for billing amounts for a transaction line in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProfitPercent | Percent | N/A | N/A | The percent of profit.
ProfitAmount | MoneyAmount | N/A | N/A | The profit amount.
Amount | MoneyAmount | N/A | N/A | The billing amount.
TaxAmount | MoneyAmount | N/A | N/A | The tax amount.
Quantity | Quantity | N/A | N/A | The billing quantity.
Status | BillingStatus | N/A | N/A | The billing status of a project transaction line.
Rate | MoneyAmount | N/A | N/A | The billing rate.
Type | BillingType | N/A | N/A | The billing type of a project transaction line.


ProjectBillingCycle

Description

The properties for billing cycle in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectBillingCycleKey | N/A | N/A | The project billing cycle key object that uniquely identifies a project billing cycle.
BillingFormat | string | N/A | N/A | The billing format to be used when printing billings during cycle billing.

Inherits from

BusinessObject


ProjectBillingCycleKey

Description

Uniquely identifies a project billing cycle within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies a project.
Id | string | N/A | N/A | The string value used to identify a project billing cycle.

Inherits from

ReferenceKey


ProjectBillingFull

Description

Extends the billing amounts in the Project Accounting module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DiscountAmount | MoneyAmount | N/A | N/A | The discount amount for the project.

Inherits from

ProjectBilling


ProjectBudget

Description

A project budget in the Project Accounting module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ProjectBudgetKey | N/A | N/A | The project budget key object that uniquely identifies a project budget.
LineSequenceNumber | int | N/A | N/A | The line sequence number.
IsInventoryItem | boolean | N/A | N/A | An option to indicate that the cost category key is for inventoried items.
Status | ProjectStatus | N/A | N/A | Identifies the status of the cost category.
ProfitType | ProfitType | N/A | N/A | Identifies the profit type to be used when transactions are created.
BillingType | BillingType | N/A | N/A | Identifies the billing type to be used when transactions are created. For Time and materials, fixed price, cost plus project types select Standard to bill customers for project costs based on a specific profit type; for Time and materials project types select No charge when you won’t charge customers for project costs; for Time and materials project types select No Billing when you won’t bill customers for project costs.
POCommittedCosts | MoneyAmount | N/A | N/A | The costs that are committed on a purchase order.
POCommittedQuantity | Quantity | N/A | N/A | The quantities that are committed on a purchase order.
CostCompletedPercent | Percent | N/A | N/A | The percentage of cost expended, if you selected the accounting method When Performed, When Billed, Cost-to-Cost or Completed.
CostOfEarningsAmount | MoneyAmount | N/A | N/A | The total cost of earnings for the project.
DoesAcceptEquipment RateTableReplacement | boolean | N/A | N/A | An option to replace the equipment rate table currently assigned to the project budget.
DoesAcceptLaborRate TableReplacement | boolean | N/A | N/A | An option to replace the labor rate table currently assigned to the project budget.
EarningsAmount | MoneyAmount | N/A | N/A | The total earnings amount for the project.
EquipmentRateTableKey | ProjectEquipmentRateTableKey | N/A | N/A | The project equipment rate table key object that uniquely identifies an equipment rate table.
LaborRateTableKey | ProjectLaborRateTableKey | N/A | N/A | The project labor rate table key object that uniquely identifies a labor rate table.
LaborRateTableType | ProjectLaborRateTableType | N/A | N/A | The project labor rate table key object that uniquely identifies a labor rate table.
OverheadRateMethod | ProjectOverheadRateMethod | N/A | N/A | Identifies the overhead calculation methods that can be used to include overhead in project costs.
PayCodeHourlyKey | PayCodeKey | N/A | N/A | The pay code key object that uniquely identifies an hourly pay code.
PayCodeSalaryKey | PayCodeKey | N/A | N/A | The pay code key object that uniquely identifies a salary pay code.
ProjectAmount | MoneyAmount | N/A | N/A | The total project amount. Project Amount = Sum of Forecast Project Revenue for Each Cost Category + Sum of Project Fees + Sum of Service Fees.
QuantityCompleted Percent | Percent | N/A | N/A | The percentage of effort expended, if you selected the accounting method Effort-Expended. The Effort-Expended option is usually used to track the number of hours used in a project.
ReceiptsAmount | MoneyAmount | N/A | N/A | The cash receipt amount received from the customer for the project.
TaxPaidAmount | MoneyAmount | N/A | N/A | The tax paid amount for the project.
UofM | string | N/A | N/A | The unit of measure for the cost category.
UofMScheduleKey | UofMScheduleKey | N/A | N/A | The UofM schedule key object that uniquely identifies a unit of measure schedule.
WriteoffAmount | MoneyAmount | N/A | N/A | The amount written off for the project.
WriteoffTaxAmount | MoneyAmount | N/A | N/A | The tax amount written off for the project.
WriteUpDownAmount | MoneyAmount | N/A | N/A | The positive or negative amount used to modify the amount billed.
TransactionalCurrency Code | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies a transaction currency code.
Forecast | ProjectBudgetForecast | N/A | N/A | The forecast amounts for a project budget.
Baseline | ProjectBudgetBaseline | N/A | N/A | The baseline amounts for a project budget.
Billed | ProjectBudgetBilled | N/A | N/A | The billed amounts for a project budget.
Posted | ProjectBudgetPosted | N/A | N/A | The posted amounts for a project budget.
Unposted | ProjectBudgetUnposted | N/A | N/A | The unposted amounts for a project budget.
Actual | ProjectBudgetActual | N/A | N/A | The actual amounts for a project budget.
Uncommitted | ProjectBudgetUncommitted | N/A | N/A | The uncommitted purchase order amounts for a project budget.

Inherits from

BusinessObject


ProjectBudgetActual

Description

The actual budget amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
BeginDate | dateTime | N/A | N/A | The begin date of the cost category. The beginning date and ending date indicate the scheduled utilization of the cost category in the project.
EndDate | dateTime | N/A | N/A | The end date of the cost category.
CostOfEarningsAmount | MoneyAmount | N/A | N/A | The total cost of earnings for the project.
LossAmount | MoneyAmount | N/A | N/A | The amount of loss for the project.
WriteoffAmount | MoneyAmount | N/A | N/A | The amount written off for the project budget.
ReceiptsAmount | MoneyAmount | N/A | N/A | The cash receipt amount received from the customer for the project.


ProjectBudgetBase

Description

The base budget amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
BeginDate | dateTime | N/A | N/A | The begin date of the cost category. The beginning date and ending date indicate the scheduled utilization of the cost category in the project.
EndDate | dateTime | N/A | N/A | The end date of the cost category.
Quantity | Quantity | N/A | N/A | The quantity for the cost category.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the cost category. Total cost = (( Quantity) x (UnitCost)) + OverheadCost
BillableAmount | MoneyAmount | N/A | N/A | The billable amount for the cost category.
ProfitAmount | MoneyAmount | N/A | N/A | The profit amount for the cost category.
TaxAmount | MoneyAmount | N/A | N/A | The tax amount for the cost category.
OverheadCost | MoneyAmount | N/A | N/A | The overhead cost amount for the cost category.


ProjectBudgetBaseline

Description

The baseline budget amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
UnitCost | MoneyAmount | N/A | N/A | The unit cost for the cost category.
NetProfitAmount | MoneyAmount | N/A | N/A | The net profit amount for the cost category.
OverheadPercent | Quantity | N/A | N/A | The overhead percent for the cost category.
ProfitPercent | Percent | N/A | N/A | The profit percent for the cost category.
PurchaseTaxBasis | ProjectTaxBasis | N/A | N/A | Identifies the tax basis to be used for the purchases of materials and equipment.
PurchaseTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a purchase tax schedule.
SalesTaxBasis | SalesTaxBasis | N/A | N/A | Identifies the tax basis to be used for the billing amount.
SalesTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a sales tax schedule.

Inherits from

ProjectBudgetBase


ProjectBudgetBilled

Description

The billed budget amounts in the Project Accounting module in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ProjectBilledBase


ProjectBudgetCriteria

Description

Specifies the base set of criteria to use when retrieving a list of project budget summary objects. Only project budget summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ProjectId† | LikeRestrictionOfString | A string restriction that specifies the ID of a project.
CostCategoryId† | LikeRestrictionOfString | A string restriction that specifies the cost category ID.

Inherits from

Criteria


ProjectBudgetForecast

Description

The forecast budget amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
UnitCost | MoneyAmount | N/A | N/A | The unit cost for the cost category.
NetProfitAmount | MoneyAmount | N/A | N/A | The net profit amount for the cost category.
OverheadPercent | Percent | N/A | N/A | The overhead percent for the cost category.
ProfitPercent | Percent | N/A | N/A | The profit percent for the cost category.
PurchaseTaxBasis | ProjectTaxBasis | N/A | N/A | Identifies the tax basis to be used for the purchases of materials and equipment.
PurchaseTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a purchase tax schedule.
SalesTaxBasis | SalesTaxBasis | N/A | N/A | Identifies the tax basis to be used for the billing amount.
SalesTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a sales tax schedule.

Inherits from

ProjectBudgetBase


ProjectBudgetKey

Description

Uniquely identifies a project budget instance in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies a project.
CostCategoryKey | CostCategoryKey | N/A | N/A | The cost category key object that uniquely identifies a cost category.
TransactionUsage | int | N/A | N/A | Identifies the transaction type the cost category is for.

Inherits from

ReferenceKey


ProjectBudgetPosted

Description

The posted budget amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
BillableAmount | MoneyAmount | N/A | N/A | The billable amount for the cost category.
CommittedCost | MoneyAmount | N/A | N/A | The committed costs of a purchase order for the project.
CommittedQuantity | Quantity | N/A | N/A | The committed quantity of a purchase order for the project.
CommittedTaxAmount | MoneyAmount | N/A | N/A | The committed tax amount of a purchase order for the project.
TaxPaidAmount | MoneyAmount | N/A | N/A | The amount of tax paid on the project.

Inherits from

ProjectPostedBase


ProjectBudgetSummary

Description

-A representation of the important details of a project budget within Microsoft Dynamics GP. A list of project budget summary objects is returned by the GetProjectBudgetList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectBudgetKey | N/A | N/A | The project budget key object that uniquely identifies a project budget.
ProjectAmount | MoneyAmount | N/A | N/A | The total project amount. Project Amount = Sum of Forecast Project Revenue for Each Cost Category + Sum of Project Fees + Sum of Service Fees.
Status | ProjectStatus | N/A | N/A | Identifies the status of the cost category.
ProfitType | ProfitType | N/A | N/A | Identifies the profit type to be used when transactions are created.
PostedQuantity | Quantity | N/A | N/A | The posted quantity for a cost category.
PostedTotalCost | MoneyAmount | N/A | N/A | The posted total cost for a cost category.
PostedBillableAmount | MoneyAmount | N/A | N/A | The posted billable amount for a cost category.
ForecastQuantity | Quantity | N/A | N/A | The forecast quantity for a cost category.
ForecastTotalCost | MoneyAmount | N/A | N/A | The forecast total cost for a cost category.
ForecastBillableAmount | MoneyAmount | N/A | N/A | The forecast billable amount for a cost category.


ProjectBudgetUncommitted

Description

The uncommitted budget amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
POCosts | MoneyAmount | N/A | N/A | The costs uncommitted on purchase orders for the project budget.
POQuantity | Quantity | N/A | N/A | The quantities uncommitted on purchase orders for the project budget.


ProjectBudgetUnposted

Description

The unposted budget amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
BeginDate | dateTime | N/A | N/A | The begin date of the cost category. The beginning date and ending date indicate the scheduled utilization of the cost category in the project.
EndDate | dateTime | N/A | N/A | The end date of the cost category.
BillableAmount | MoneyAmount | N/A | N/A | The billable amount for the cost category.
CommittedCost | MoneyAmount | N/A | N/A | The committed costs of a purchase order for the project.
CommittedQuantity | Quantity | N/A | N/A | The committed quantity of a purchase order for the project.
CommittedTaxAmount | MoneyAmount | N/A | N/A | The committed tax amount of a purchase order for the project.

Inherits from

ProjectUnpostedBase


ProjectCashDetail

Description

The properties for cash payment in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
DocumentNumber | string | N/A | N/A | The document number assigned to the cash payment.

Inherits from

CashDetail


ProjectChangeOrder

Description

Defines the properties for a change order in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectChangeOrderKey | N/A | N/A | The project change order key object that uniquely identifies a project change order.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies a customer.
Date | dateTime | N/A | N/A | The date of the change order.
Description | string | N/A | N/A | A description of the change order.
CustomerChangeOrder Number | string | N/A | N/A | The customer’s change order number.
Type | ProjectChangeOrderType | N/A | N/A | The type of change order.
Status | ProjectChangeOrderStatus | N/A | N/A | The status of the change order.
RequestedBy | string | N/A | N/A | The individual or customer requesting the change order
EstimatedBy | string | N/A | N/A | The individual who estimated the change order.
RevisedBy | string | N/A | N/A | The individual who revised the change order.
RevisersPosition | string | N/A | N/A | The position/role of the individual who revised the change order.
LastProcessedDate | dateTime | N/A | N/A | The date the change order was last processed.
ModifiedBy | string | N/A | N/A | The individual who last modified the change order.
PreviousContractBegin Date | dateTime | N/A | N/A | The previous contract begin date.
ContractBeginDate | dateTime | N/A | N/A | The contract begin date.
PreviousContractEndDate | dateTime | N/A | N/A | The previous contract end date.
ContractEndDate | dateTime | N/A | N/A | The contract end date.
ApprovedBy | string | N/A | N/A | The individual who approved the change order.
ApproverPosition | string | N/A | N/A | The position/role of the individual who approved the change order.
ApprovalDate | dateTime | N/A | N/A | The date the change order was approved.
TrackChangesToType | ProjectChangeOrderTrackChangesToType | N/A | N/A | An option indicating whether to apply the change order to baseline or forecast amounts for the projects in the contract.
RevisedBudgetTotal Amount | MoneyAmount | N/A | N/A | The revised budget total amount.
RevisedFeeTotalAmount | MoneyAmount | N/A | N/A | The revised fee total amount.
TotalChangeOrder Amount | MoneyAmount | N/A | N/A | The total change order amount.
PreviousProjectAmount | MoneyAmount | N/A | N/A | The previous project amount.
VarianceProjectAmount | MoneyAmount | N/A | N/A | The positive or negative variance amount used to update the project amount.
RevisedProjectAmount | MoneyAmount | N/A | N/A | The revised project amount.
ProjectAmount | MoneyAmount | N/A | N/A | The total project amount.
ReasonForRevision | string | N/A | N/A | The reason for the revision to the change order.
DocumentStatus | ProjectChangeOrderDocumentStatus | N/A | N/A | Identifies the status of the change order document.
SequenceNumber | int | N/A | N/A | The sequence number.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the change order.
TotalBilling | MoneyAmount | N/A | N/A | The total billing amount of the change order.
TotalQuantity | Quantity | N/A | N/A | The total quantity of the change order.
VarianceTotalBilling | MoneyAmount | N/A | N/A | The total billing variance amount.
VarianceTotalCost | MoneyAmount | N/A | N/A | The total cost variance amount.
VarianceTotalQuantity | Quantity | N/A | N/A | The total quantity variance value.
Budgets | ArrayOfProjectChangeOrderBudget | N/A | N/A | A collection of change order budgets.
Fees | ArrayOfProjectChangeOrderFee | N/A | N/A | A collection of change order fees.

Inherits from

BusinessObject


ProjectChangeOrderBudget

Description

Defines the properties of change order budget in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectChangeOrderBudgetKey | N/A | N/A | The project change order budget key object that uniquely identifies a project change order budget.
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies a project.
CostCategoryKey | CostCategoryKey | N/A | N/A | The cost category key object that uniquely identifies a cost category.
LineItemSequence Number | int | N/A | N/A | The line sequence number.
UofM | string | N/A | N/A | The unit of measure for the cost category.
UofMScheduleKey | UofMScheduleKey | N/A | N/A | The UofM schedule key object that uniquely identifies a unit of measure schedule.
PreviousContractBegin Date | dateTime | N/A | N/A | The previous begin date of the contract.
ContractBeginDate | dateTime | N/A | N/A | The begin date of the contract.
PreviousContractEndDate | dateTime | N/A | N/A | The previous end date of the contract.
ContractEndDate | dateTime | N/A | N/A | The end date of the contract.
PreviousPayCodeSalary Key | ProjectChangeOrderPayCodeSalaryKey | N/A | N/A | The project change order pay code salary key object that uniquely identifies a project change order salary pay code.
PayCodeSalaryKey | ProjectChangeOrderPayCodeSalaryKey | N/A | N/A | The project change order pay code salary key object that uniquely identifies a project change order salary pay code.
PreviousPayCodeHourly Key | ProjectChangeOrderPayCodeHourlyKey | N/A | N/A | The project change order pay code hourly key object that uniquely identifies a project change order hourly pay code.
PayCodeHourlyKey | ProjectChangeOrderPayCodeHourlyKey | N/A | N/A | The project change order pay code hourly key object that uniquely identifies a project change order hourly pay code.
ProfitType | ProfitType | N/A | N/A | Identifies the profit type to be used when transactions are created for the project.
BillingType | BillingType | N/A | N/A | Identifies the billing type to be used when transactions are created. For Time and materials, fixed price, cost plus project types select Standard to bill customers for project costs based on a specific profit type; for Time and materials project types select No charge when you won’t charge customers for project costs; for Time and materials project types select No Billing when you won’t bill customers for project costs.
PreviousPurchaseTax Basis | PurchasingTaxBasis | N/A | N/A | The previous purchase tax basis.
PurchaseTaxBasis | PurchasingTaxBasis | N/A | N/A | For cost transactions, the purchase tax basis indicates whether cost amounts for the cost category are taxable, non-taxable, or based on the tax settings for the vendor or customer. The tax schedule for cost transactions is for employee expense transactions, purchase orders, shipment receipts, shipment/invoice receipts, invoice receipts, and inventory transfers with non-inventoried items.
PreviousTaxScheduleKey | TaxScheduleKey | N/A | N/A | The previous tax schedule.
PurchaseTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a purchase tax schedule.
PreviousSalesTaxBasis | SalesTaxBasis | N/A | N/A | The previous sales tax basis.
SalesTaxBasis | SalesTaxBasis | N/A | N/A | For billing transactions, sales tax basis indicates whether billing amounts for the cost category are taxable, non-taxable, or based on the tax settings for the vendor or customer.
PreviousSalesTax ScheduleKey | TaxScheduleKey | N/A | N/A | The previous sales tax schedule.
SalesTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a sales tax schedule.
VarianceQuantity | Quantity | N/A | N/A | The positive or negative value used to update the cost category quantity.
Quantity | Quantity | N/A | N/A | The quantity for the cost category.
PreviousQuantity | Quantity | N/A | N/A | The previous quantity for the cost category.
VarianceUnitCost | MoneyAmount | N/A | N/A | The positive or negative amount used to update the unit cost of the cost category.
UnitCost | MoneyAmount | N/A | N/A | The unit cost of the cost category.
PreviousUnitCost | MoneyAmount | N/A | N/A | The previous unit cost of the cost category.
VarianceTotalCost | MoneyAmount | N/A | N/A | The total cost variance of the cost category.
VarianceOverhead Amount | MoneyAmount | N/A | N/A | The positive or negative amount used to update the overhead amount for the cost category.
TotalOverheadAmount | MoneyAmount | N/A | N/A | The total overhead amount for the cost category.
VarianceOverheadPercent | Percent | N/A | N/A | The positive or negative value used to update the overhead percent for the cost category.
OverheadPercent | Percent | N/A | N/A | The total overhead percent for the cost category.
PreviousOverheadPercent | Percent | N/A | N/A | The previous overhead percent for the cost category.
PreviousTotalOverhead Amount | MoneyAmount | N/A | N/A | The previous overhead amount for the cost category.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the cost category.
PreviousTotalCost | MoneyAmount | N/A | N/A | The previous total cost of the cost category.
VarianceMarkupPercent | Percent | N/A | N/A | The positive or negative value used to update the markup percent for the cost category.
ProfitPercent | Percent | N/A | N/A | The profit percent for the cost category.
PreviousProfitPercent | Percent | N/A | N/A | The previous profit percent for the cost category.
VarianceProfitAmount | MoneyAmount | N/A | N/A | The positive or negative amount used to update the profit amount for the cost category.
ProfitAmount | MoneyAmount | N/A | N/A | The profit amount for the cost category.
PreviousProfitAmount | MoneyAmount | N/A | N/A | The previous profit amount for the cost category.
VarianceTotalProfit Amount | MoneyAmount | N/A | N/A | The total profit amount variance for the cost category.
TotalProfitAmount | MoneyAmount | N/A | N/A | The total profit amount for the cost category.
PreviousTotalProfit Amount | MoneyAmount | N/A | N/A | The previous total profit amount for the cost category.
VarianceTotalBilling Amount | MoneyAmount | N/A | N/A | The total billing amount variance for the cost category.
TotalBillingAmount | MoneyAmount | N/A | N/A | The total billing amount for the cost category.
PreviousTotalBilling Amount | MoneyAmount | N/A | N/A | The previous total billing amount for the cost category.
OriginalBudgetAmount | MoneyAmount | N/A | N/A | The original budget amount.
OriginalProjectAmount | MoneyAmount | N/A | N/A | The original project amount.
ProjectAmount | MoneyAmount | N/A | N/A | The total project amount.
PreviousProjectAmount | MoneyAmount | N/A | N/A | The previous project amount.
VarianceProjectAmount | MoneyAmount | N/A | N/A | The positive or negative variance amount used to update the project amount.
PreviousBaselineQuantity | Quantity | N/A | N/A | The previous baseline quantity.
BaselineQuantity | Quantity | N/A | N/A | The baseline quantity.
PreviousBaselineUnitCost | MoneyAmount | N/A | N/A | The previous base line unit cost.
BaselineUnitCost | MoneyAmount | N/A | N/A | The baseline unit cost.
PreviousBaseline OverheadCost | MoneyAmount | N/A | N/A | The previous baseline overhead cost.
BaselineOverheadCost | MoneyAmount | N/A | N/A | The baseline overhead cost.
PreviousBaselineProfit Amount | MoneyAmount | N/A | N/A | The previous profit amount.
BaselineProfitAmount | MoneyAmount | N/A | N/A | The baseline profit amount.
InitialQuoteAmount | MoneyAmount | N/A | N/A | The initial quote amount.
FinalQuoteAmount | MoneyAmount | N/A | N/A | The final quote amount.
QuotePreparedBy | string | N/A | N/A | The individual who prepared the quote.
QuoteApprovedBy | string | N/A | N/A | The individual who approved the quote.
RevisedBudgetTotal Amount | MoneyAmount | N/A | N/A | The revised budget total amount.
RevisedProjectTotal Amount | MoneyAmount | N/A | N/A | The revised project total amount.
SequenceNumber | int | N/A | N/A | The sequence number.
ApprovalDate | dateTime | N/A | N/A | The approval date.
IsClosed | boolean | N/A | N/A | Indicates if the change order budget instance is closed.
ActualReceiptAmount | MoneyAmount | N/A | N/A | The actual cash receipt amount for the change order.
ActualWriteoffAmount | MoneyAmount | N/A | N/A | The actual written off amount for the change order.
ActualWriteoffTaxAmount | MoneyAmount | N/A | N/A | The actual written off tax amount for the change order.
Posted | ProjectPostedAmount | N/A | N/A | The posted amounts for a change order budget.

Inherits from

BusinessObject


ProjectChangeOrderBudgetKey

Description

Uniquely identifies a project change order budget in the Project Accounting module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ProjectChangeOrderKey | ProjectChangeOrderKey | N/A | N/A | The project change order key object that uniquely identifies a project change order.
LineSequenceNumber | int | N/A | N/A | The line sequence number.

Inherits from

Key


ProjectChangeOrderCriteria

Description

Specifies the criteria to use when retrieving a list of project change order summary objects. Only project change order summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the change order.
ProjectContractId† | LikeRestrictionOfString | A string restriction specifying the project contract ID.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the change order.

Inherits from

Criteria


ProjectChangeOrderFee

Description

Defines the properties of change order fee in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectChangeOrderFeeKey | N/A | N/A | The project change order fee key object that uniquely identifies a project change order fee.
ContractBeginDate | dateTime | N/A | N/A | The begin date of the project contract.
ContractEndDate | dateTime | N/A | N/A | The end date of the project contract.
TotalProjectFeeAmount | MoneyAmount | N/A | N/A | The total project fee amount.
TotalRetainerFeeAmount | MoneyAmount | N/A | N/A | The total retainer fee amount.
TotalRetentionFeeAmount | MoneyAmount | N/A | N/A | The total retention fee amount.
TotalServiceFeeAmount | MoneyAmount | N/A | N/A | The total amount for services to be rendered over a specified period.
VarianceFeeAmount | MoneyAmount | N/A | N/A | The positive or negative amount used to update the fee amount.
SequenceNumber | int | N/A | N/A | The sequence number.
VarianceProjectFee Amount | MoneyAmount | N/A | N/A | The positive or negative amount used to update the project fee amount.
VarianceRetainerFee Amount | MoneyAmount | N/A | N/A | The positive or negative amount used to update the retainer fee amount.
VarianceRetentionFee Amount | MoneyAmount | N/A | N/A | The positive or negative amount used to update the retention fee amount.
VarianceServiceFee Amount | MoneyAmount | N/A | N/A | The positive or negative amount used to update the service fee amount.
PostedProjectFeeAmount | MoneyAmount | N/A | N/A | The posted project fee amount.
PostedRetainerFee Amount | MoneyAmount | N/A | N/A | The posted retainer fee amount.
PostedRetentionFee Amount | MoneyAmount | N/A | N/A | The posted retention fee amount.
PostedServiceFeeAmount | MoneyAmount | N/A | N/A | The posted amount for services to be rendered over a specified period.
Lines | ArrayOfProjectChangeOrderFeeLine | N/A | N/A | A collection of project change order fee lines.

Inherits from

BusinessObject


ProjectChangeOrderFeeKey

Description

Uniquely identifies a change order fee in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectChangeOrderKey | ProjectChangeOrderKey | N/A | N/A | The project change order key object that uniquely identifies a project change order.
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies a project.

Inherits from

Key


ProjectChangeOrderFeeLine

Description

Defines the properties of change order fee line in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectChangeOrderFeeLineKey | N/A | N/A | The project change order fee line key object that uniquely identifies a project change order fee line.
LineSequenceNumber | int | N/A | N/A | The line sequence number.
FeeType | ProjectFeeType | N/A | N/A | Identifies the fee type.
PreviousFeeAmount | MoneyAmount | N/A | N/A | The previous fee amount.
VarianceFeeAmount | MoneyAmount | N/A | N/A | The positive or negative amount used to update the fee amount.
Amount | MoneyAmount | N/A | N/A | The fee amount.
PreviousFeePercent | Percent | N/A | N/A | The previous fee percent.
VarianceFeePercent | Percent | N/A | N/A | The positive or negative value used to update the fee percent.
Percent | Percent | N/A | N/A | The fee percent.
FeeToUseKey | ProjectFeeKey | N/A | N/A | The project fee key object that uniquely identifies a project fee.
SalesTaxBasis | SalesTaxBasis | N/A | N/A | For billing transactions, sales tax basis indicates whether billing amounts for the cost category are taxable, non-taxable, or based on the tax settings for the vendor or customer.
SalesTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a sales tax schedule.
PreviousSalesTax ScheduleKey | TaxScheduleKey | N/A | N/A | The previous sales tax schedule.
ContractBeginDate | dateTime | N/A | N/A | The begin date of the contract.
PreviousContractBegin Date | dateTime | N/A | N/A | The previous begin date of the contract.
ContractEndDate | dateTime | N/A | N/A | The end date of the contract.
PreviousContractEndDate | dateTime | N/A | N/A | The previous end date of the contract.
Frequency | ProjectFrequency | N/A | N/A | The frequency associated with the fee.
PreviousFrequency | ProjectFrequency | N/A | N/A | The previous fee frequency.
StartDate | dateTime | N/A | N/A | The date that a service fee begins.
EndDate | dateTime | N/A | N/A | The date that a service fee ends.
DoesRenew | boolean | N/A | N/A | Indicates if a service fee is recurring.
RenewDate | dateTime | N/A | N/A | The renew date of a service fee.
TotalAmount | MoneyAmount | N/A | N/A | The total amount of the change order fee line.
PreviousTotalAmount | MoneyAmount | N/A | N/A | The previous total amount of the change order fee line
RenewDay | int | N/A | N/A | The renew day for the service fee.
RenewMonth | int | N/A | N/A | The renew month for the service fee.
SequenceNumber | int | N/A | N/A | The sequence number.
PostedProjectFeeAmount | MoneyAmount | N/A | N/A | The posted project fee amount.
PostedRetainerFee Amount | MoneyAmount | N/A | N/A | The posted retainer fee amount.
PostedRetentionFee Amount | MoneyAmount | N/A | N/A | The posted retention fee amount.
PostedServiceFeeAmount | MoneyAmount | N/A | N/A | The posted amount for services to be rendered over a specified period.
Schedules | ArrayOfProjectChangeOrderFeeLineSchedule | N/A | N/A | A collection of change order fee line schedules.

Inherits from

BusinessObject


ProjectChangeOrderFeeLineKey

Description

Uniquely identifies a change order fee line in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectChangeOrderKey | ProjectChangeOrderKey | N/A | N/A | The project change order key object that uniquely identifies a project change order.
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies a project.
ProjectChangeOrderFee Key | ProjectFeeKey | N/A | N/A | The project change order fee key object that uniquely identifies a project change order fee.


ProjectChangeOrderFeeLineSchedule

Description

Defines the properties of change order fee line schedule in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectFeeKey | N/A | N/A | The project fee key object that uniquely identifies a project fee.
SequenceNumber | int | N/A | N/A | The sequence number.
Amount | MoneyAmount | N/A | N/A | The amount of the fee to bill on the specified date.
PreviousDate | dateTime | N/A | N/A | The previous date to bill a fee amount.
PreviousFeeAmount | MoneyAmount | N/A | N/A | The previous amount of the fee to bill.
AmountBilled | MoneyAmount | N/A | N/A | The amount of the fee billed.

Inherits from

BusinessObject


ProjectChangeOrderFeeLineScheduleKey

Description

Uniquely identifies a change order fee line schedule in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectFeeKey | ProjectFeeKey | N/A | N/A | The project fee key object that uniquely identifies a project fee.
ProjectChangeOrderKey | ProjectChangeOrderKey | N/A | N/A | The project change order key object that uniquely identifies a project change order.
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies a project.
LineSequenceNumber | int | N/A | N/A | The line sequence number.
Date | dateTime | N/A | N/A | The date to bill a fee amount.


ProjectChangeOrderKey

Description

Uniquely identifies a change order in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectContractKey | ProjectContractKey | N/A | N/A | The project contract key object that uniquely identifies a project contract.
Id | string | N/A | N/A | The string value used to identify a project change order.

Inherits from

ReferenceKey


ProjectChangeOrderPayCodeHourlyKey

Description

Uniquely identifies a change order hourly pay code in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a change order hourly pay code,


ProjectChangeOrderPayCodeSalaryKey

Description

Uniquely identifies a change order salary pay code in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a change order salary pay code.


ProjectChangeOrderSummary

Description

A representation of the important details of a project change order within Microsoft Dynamics GP. A list of project change order summary objects is returned by the GetProjectChangeOrderList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectChangeOrderKey | N/A | N/A | The project change order key object that uniquely identifies a project change order.
Date | dateTime | N/A | N/A | The date of the change order.
Status | ProjectChangeOrderStatus | N/A | N/A | The status of the change order.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies a customer.
ApprovedBy | string | N/A | N/A | The individual who approved the change order.
ApprovalDate | dateTime | N/A | N/A | The approval date of the change order.
RevisedProjectAmount | MoneyAmount | N/A | N/A | The revised project amount.
RevisedBudgetTotal Amount | MoneyAmount | N/A | N/A | The revised total budget amount.
RevisedFeeTotalAmount | MoneyAmount | N/A | N/A | The revised total fee amount.
TotalChangeOrder Amount | MoneyAmount | N/A | N/A | The total change order amount.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the change order.


ProjectClassKey

Description

Uniquely identifies a project class in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a project class.


ProjectContract

Description

Defines the properties of a contract in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectContractKey | N/A | N/A | The project contract key object that uniquely identifies a project contract.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies a customer.
ProjectContractId | string | N/A | N/A | The string value used to identify a project contract.
Name | string | N/A | N/A | A descriptive name of the contract.
ClassKey | ProjectClassKey | N/A | N/A | The project class key object that uniquely identifies a project class.
ProjectType | ProjectType | N/A | N/A | Determines how a contractor is to compute project costs and charge customers for such costs. It also is a way to determine how much revenues can be generated in a project.
AccountingMethod | ProjectAccountingMethod | N/A | N/A | Determines the Percentage Completion of a certain project, budget or fee to determine the revenues to be recognized.
Status | ProjectStatus | N/A | N/A | Identifies the status of the contract.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies a currency.
CustomerPONumber | string | N/A | N/A | The customer’s purchase order number.
CloseToProjectCosts | ProjectCloseToProjectCosts | N/A | N/A | Option to allow or disallow cost transaction entry and posting for the contract. The options are: 0 = Allow; 1 = Disallow.
CloseToBillings | ProjectCloseToBillings | N/A | N/A | Option to allow or disallow billing transaction entry and posting for the contract.
ContractManagerKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies a contract manager.
BusinessManagerKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies a business manager.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that uniquely identifies a salesperson.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that uniquely identifies a sales territory.
CommissionPercent | Percent | N/A | N/A | The commission percent for the project contract.
CommissionBasedOn | CommissionBasedOn | N/A | N/A | An option which determines whether the salesperson's commissions will be calculated as a percentage of the sale amount or as a percentage of the total, including the sale amount, freight, taxes, and miscellaneous charges.
DefaultBillingFormat | string | N/A | N/A | The default billing format to be used when printing billings during cycle billing.
AddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies a customer address.
ContactPerson | string | N/A | N/A | The contact person for the customer.
BillToAddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies a customer bill to address.
UserDefined1 | string | N/A | N/A | User defined data.
UserDefined2 | string | N/A | N/A | User defined data.
DoesCombineForRevenue Recognition | boolean | N/A | N/A | An option to combine earnings from various cost categories and projects in the same contract.
RestrictToCustomerList | boolean | N/A | N/A | An option to restrict the Customer ID to customers included in the Third Party Customer List. When this option is marked, users can to choose only customers in the list when billing.
DiscountPercent | Percent | N/A | N/A | The discount percent given to the customer for this contract.
ProjectAmount | MoneyAmount | N/A | N/A | The total project amount. Project Amount = Sum of Forecast Project Revenue for Each Cost Category + Sum of Project Fees + Sum of Service Fees.
WriteUpDownAmount | MoneyAmount | N/A | N/A | The amount to be added or subtracted from the billing amount for the contract. Contractors, and more often, professionals, usually use write up or write down to change the billing amount.
CostCompletedPercent | Percent | N/A | N/A | The percentage of cost expended, if you selected the accounting method When Performed, When Billed, Cost-to-Cost or Completed.
QuantityCompleted Percent | Percent | N/A | N/A | The percentage of effort expended, if you selected the accounting method Effort-Expended. The Effort-Expended option is usually used to track the number of hours used in a project.
ServiceFeeAmount | MoneyAmount | N/A | N/A | An amount services to be rendered over a specified period.
RetainerAmount | MoneyAmount | N/A | N/A | Prepaid amount to be included in project billings. Professionals require retainer to ensure cash flow and bill collection.
ProjectFeeAmount | MoneyAmount | N/A | N/A | Management fee, professional fee, incentive fee or any other similar fee amount that forms part of the total project or contract amount.
RetentionFeeAmount | MoneyAmount | N/A | N/A | An amount that is not included in progress billings for a fixed price or cost plus project until the project is completed or until specified project conditions and guarantees are met.
POCommittedCosts | MoneyAmount | N/A | N/A | The costs that are committed on a purchase order.
POCommittedQuantity | Quantity | N/A | N/A | The quantities that are committed on a purchase order.
TransactionalCurrency Key | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies a transactional (originating) currency.
Forecast | ProjectContractForecast | N/A | N/A | The project contract forecast amounts.
Baseline | ProjectContractBaseline | N/A | N/A | The project contract baseline amounts.
Billed | ProjectContractBilled | N/A | N/A | The project contract billed amounts.
Unposted | ProjectContractUnposted | N/A | N/A | The project contract unposted amounts.
Actual | ProjectContractActual | N/A | N/A | The project contract actual amounts.
BillingCycles | ArrayOfProjectContractBillingCycle | N/A | N/A | A collection of project contract billing cycles.
Accounts | ArrayOfProjectContractAccountType | N/A | N/A | A collection of project contract GL accounts.

Inherits from

BusinessObject


ProjectContractAccountType

Description

Defines the properties of contract account type in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectContractAccountTypeKey | N/A | N/A | The distribution type key that uniquely identifies the type of distribution.
GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account.

Inherits from

BusinessObject


ProjectContractAccountTypeKey

Description

Uniquely identifies a contract account type in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
SourceFile | ProjectSourceFile | N/A | N/A | Identifies the source file.
ProjectContractKey | ProjectContractKey | N/A | N/A | The project contract key object that uniquely identifies the project contract.
CostTransaction | string | N/A | N/A | Identifies cost transactions (leave blank for fee accounts). The options are:: TS=Timesheet; EL=Equipment log; VI=Purchase materials; ML=Miscellaneous log; EE=employee expense
DistributionTypeKey | DistributionTypeKey | N/A | N/A | The distribution type key that uniquely identifies the type of distribution.

Inherits from

ReferenceKey


ProjectContractActual

Description

The actual amounts for a contract in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
CommittedPOQuantity | Quantity | N/A | N/A | The quantities that are committed on purchase orders for the contract.
CommittedPOCost | MoneyAmount | N/A | N/A | The costs that are committed on purchase orders for the contract.
CommittedPOTaxAmount | MoneyAmount | N/A | N/A | The tax amount that is committed on purchase orders for the contract.
ProjectFeeAmount | MoneyAmount | N/A | N/A | The project fee amount for the contract. Management fee, professional fee, incentive fee or any other similar fee amount that forms part of the total project or contract amount.
RetainerFeeAmount | MoneyAmount | N/A | N/A | The retainer fee amount for the contract. Prepaid amount to be included in project billings.
ServiceFeeAmount | MoneyAmount | N/A | N/A | An amount for services to be rendered over a specified period.
RetentionAmount | MoneyAmount | N/A | N/A | An amount that is not included in progress billings for a fixed price or cost plus project until the project is completed or until specified project conditions and guarantees are met.
BilledRetentionAmount | MoneyAmount | N/A | N/A | The retention amount billed.
LossAmount | MoneyAmount | N/A | N/A | The loss amount of the contract.
BeginDate | dateTime | N/A | N/A | The begin date of the contract. The beginning date and ending date indicate the scheduled utilization of the contract.
EndDate | dateTime | N/A | N/A | The end date of the contract.
ReceiptsAmount | MoneyAmount | N/A | N/A | The cash receipts amount received from the customer for the projects under the contract.
POCosts | MoneyAmount | N/A | N/A | The costs uncommitted on purchase orders for the contract.
POQuantity | Quantity | N/A | N/A | The quantities uncommitted on purchase orders for the contract.
EarningsAmount | MoneyAmount | N/A | N/A | The total earnings amount for the contract.
CostOfEarningsAmount | MoneyAmount | N/A | N/A | The total cost of earnings for the contract.

Inherits from

ProjectAmount


ProjectContractBaseline

Description

The baseline amounts for a contract in the Project Accounting module in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ProjectBudgetBase


ProjectContractBilled

Description

The billed amounts for a contract in the Project Accounting module in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ProjectBilledBase


ProjectContractBillingCycle

Description

Defines the properties for contract billing cycle in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectContractBillingCycleKey | N/A | N/A | The contract billing cycle key that uniquely identifies a contract billing cycle.
BillingFormat | string | N/A | N/A | Identifies the billing format to be used when printing billings during cycle billing.

Inherits from

BusinessObject


ProjectContractBillingCycleKey

Description

Uniquely identifies a contract billing cycle in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectContractKey | ProjectContractKey | N/A | N/A | The project contract key that uniquely identifies a project contract.
Id | string | N/A | N/A | The string value used to identify a billing cycle.

Inherits from

ReferenceKey


ProjectContractCriteria

Description

Specifies the criteria to use when retrieving a list of project contract summary objects. Only project contract summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the project contract.
CustomerId† | LikeRestrictionOfString | A string restriction specifying the customer ID.
ProjectClassId† | LikeRestrictionOfString | A string restriction specifying the class of the project contract.
BusinessManagerId† | LikeRestrictionOfString | A string restriction specifying the business manager ID.

Inherits from

Criteria


ProjectContractForecast

Description

The forecast amounts for a contract in the Project Accounting module in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ProjectBudgetBase


ProjectContractKey

Description

Uniquely identifies a contract in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The project contract key that uniquely identifies a project contract.

Inherits from

ReferenceKey


ProjectContractSummary

Description

A representation of the important details of a project contract within Microsoft Dynamics GP. A list of project contract summary objects is returned by the GetProjectContractList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectContractKey | N/A | N/A | The project contract key that uniquely identifies a project contract.
Status | ProjectStatus | N/A | N/A | Identifies the status of the contract.
CustomerKey | CustomerKey | N/A | N/A | The customer key that uniquely identifies a customer.
ProjectClassKey | ProjectClassKey | N/A | N/A | The project class key that uniquely identifies a project class.
BusinessManagerKey | EmployeeKey | N/A | N/A | The employee key that uniquely identifies a business manager.
ForecastProfitAmount | MoneyAmount | N/A | N/A | The forecast profit amount for the contract.
ActualProfitAmount | MoneyAmount | N/A | N/A | The actual profit amount for the contract.
ActualEarningsAmount | MoneyAmount | N/A | N/A | The actual total earnings amount for the contract.
ActualCostOfEarnings Amount | MoneyAmount | N/A | N/A | The actual total cost of earnings for the contract.
ActualTotalCost | MoneyAmount | N/A | N/A | The actual total cost amount for the contract.


ProjectContractUnposted

Description

The unposted amounts for a contract in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectFeeAmount | MoneyAmount | N/A | N/A | The unposted project fee amount for the contract. Management fee, professional fee, incentive fee or any other similar fee amount that forms part of the total project or contract amount.
RetainerFeeAmount | MoneyAmount | N/A | N/A | The unposted retainer fee amount for the contract. Prepaid amount to be included in project billings.
ServiceFeeAmount | MoneyAmount | N/A | N/A | The unposted service fee amount for the contract. An amount for services to be rendered over a specified period.
RetentionAmount | MoneyAmount | N/A | N/A | The unposted retention amount for the contract. An amount that is not included in progress billings for a fixed price or cost plus project until the project is completed or until specified project conditions and guarantees are met.
BilledRetentionAmount | MoneyAmount | N/A | N/A | The unposted billed retention amount for the contract.
ReceiptsAmount | MoneyAmount | N/A | N/A | The unposted cash receipts amount received from the customer for the projects under the contract.
EarningsAmount | MoneyAmount | N/A | N/A | The unposted earnings amount for the contract.
CostOfEarningsAmount | MoneyAmount | N/A | N/A | The unposted cost of earnings for the contract.
POCosts | MoneyAmount | N/A | N/A | The costs uncommitted on purchase orders for the contract.
POQuantity | Quantity | N/A | N/A | The quantities uncommitted on purchase orders for the contract.

Inherits from

ProjectUnpostedBase


ProjectCriteria

Description

Specifies the criteria to use when retrieving a list of project summary objects. Only project summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the project.
ProjectId† | LikeRestrictionOfString | A string restriction specifying the project ID assigned to the project.
ProjectContractId† | LikeRestrictionOfString | A string restriction specifying the project contract.
CustomerId† | LikeRestrictionOfString | A string restriction specifying the customer ID.
ProjectClassId† | LikeRestrictionOfString | A string restriction specifying the project class.
ProjectManagerId† | LikeRestrictionOfString | A string restriction specifying the project manager.

Inherits from

Criteria


ProjectDepartmentKey

Description

Uniquely identifies a department in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a department.


ProjectDistributionBase

Description

Defines the common distribution properties in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted.
CreditAmount | MoneyAmount | N/A | N/A | The credit amount for the account on the same line. The right-hand side of the account.
DebitAmount | MoneyAmount | N/A | N/A | The debit amount for the account on the same line. The left-hand side of the account.
GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account.
DistributionTypeKey | DistributionTypeKey | N/A | N/A | The distribution type key that uniquely identifies the type of distribution.
Reference | string | N/A | N/A | The reference to post as the general ledger distribution reference for the account.

Inherits from

BusinessObject


ProjectEmployeeExpense

Description

Defines the properties for employee expense in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectEmployeeExpenseKey | N/A | N/A | The project employee expense key object that uniquely identifies the project employee expense.
EmployeeKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the employee.
PersonalDataKeeper EmployeeKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the personal data keeper employee.
AddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies the employee address.
StartDate | dateTime | N/A | N/A | The start date of the project employee expense.
EndDate | dateTime | N/A | N/A | The end date of the project employee expense.
PaymentTermsKey | PaymentTermsKey | N/A | N/A | The payment terms key object that uniquely identifies the payment terms.
ExtendedCost | MoneyAmount | N/A | N/A | The extended cost amount for the project employee expense instance.
ReimbursableTax | MoneyAmount | N/A | N/A | The reimbursable tax amount for the project employee expense instance.
TradeDiscountAmount | MoneyAmount | N/A | N/A | The trade discount amount for the project employee expense instance.
FreightTaxBasis | ProjectTaxBasis | N/A | N/A | Specifies how taxes are calculated on freight for the project employee expense.
FreightTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the freight tax schedule.
FreightAmount | MoneyAmount | N/A | N/A | The freight amount for the project employee expense instance.
FreightTaxAmount | MoneyAmount | N/A | N/A | The freight tax amount for the project employee expense instance.
MiscellaneousTaxBasis | ProjectTaxBasis | N/A | N/A | Specifies how taxes are calculated on the miscellaneous amount for the project employee expense.
MiscellaneousTax ScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the miscellaneous tax schedule.
MiscellaneousAmount | MoneyAmount | N/A | N/A | The miscellaneous amount for the project employee expense instance.
MiscellaneousTaxAmount | MoneyAmount | N/A | N/A | The miscellaneous tax amount for the project employee expense instance.
DocumentAmount | MoneyAmount | N/A | N/A | The total amount for the project employee expense instance.
Amount1099 | MoneyAmount | N/A | N/A | The 1099 amount for the project employee expense instance.
Unapplied1099Amount | MoneyAmount | N/A | N/A | The unapplied 1099 amount for the project employee expense instance.
ChargeAmount | MoneyAmount | N/A | N/A | The amount that will be charged to the payables account.
TaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the tax schedule.
TaxAmount | MoneyAmount | N/A | N/A | The tax amount for the project employee expense instance.
ReimbursableAmount | MoneyAmount | N/A | N/A | The reimbursable amount for the project employee expense instance.
DoesPostToPayables Management | boolean | N/A | N/A | Indicates if the project employee expense will post to Dynamics GP accounts payable module.
TaxDate | dateTime | N/A | N/A | The tax date for the project employee expense instance.
IsTaxInvoiceReceived | boolean | N/A | N/A | Indicates if the tax invoice is received.
IsTaxInvoiceRequired | boolean | N/A | N/A | Indicates if a tax invoice is required.
ShippingMethodKey | ShippingMethodKey | N/A | N/A | The shipping method key object that uniquely identifies the shipping method.
Payment | ProjectPayment | N/A | N/A | The payments for the project employee expense instance.
Lines | ArrayOfProjectEmployeeExpenseLine | N/A | N/A | A collection of project employee expense lines.
Distributions | ArrayOfProjectEmployeeExpenseDistribution | N/A | N/A | A collection of project employee expense distributions.

Inherits from

ProjectHeaderBase


ProjectEmployeeExpenseCriteria

Description

Specifies the criteria to use when retrieving a list of project employee expense summary objects. Only project employee expense summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the project employee expense.
TransactionState | ListRestrictionOfNullableOfProjectTransactionState | A list restriction specifying the transaction state.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date.
EmployeeId† | LikeRestrictionOfString | A string restriction specifying the employee ID.
BatchId† | LikeRestrictionOfString | A string restriction specifying the batch ID.

Inherits from

Criteria


ProjectEmployeeExpenseDistribution

Description

Defines the distribution properties specific to an employee expense distribution in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectEmployeeExpenseDistributionKey | N/A | N/A | The project employee expense distribution key object that uniquely identifies the project employee expense distribution.

Inherits from

ProjectDistributionBase


ProjectEmployeeExpenseDistributionKey

Description

Uniquely identifies an employee expense distribution in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectEmployee ExpenseKey | ProjectEmployeeExpenseKey | N/A | N/A | The project employee expense key object that uniquely identifies the project employee expense.
ControlType | int | N/A | N/A | The control type for the employee expense distribution. Always set to zero.
SequenceNumber | int | N/A | N/A | The sequence number.


ProjectEmployeeExpenseKey

Description

Uniquely identifies an employee expense in the Project Accounting module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify an employee expense.

Inherits from

TransactionKey


ProjectEmployeeExpenseLine

Description

Defines the properties of an employee expense line in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectEmployeeExpenseLineKey | N/A | N/A | The project employee expense line key object that uniquely identifies the project employee expense line.
TaxBasis | ProjectTaxBasis | N/A | N/A | Determines how the tax of the expense line item will be computed.
TaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the tax schedule.
TaxAmount | MoneyAmount | N/A | N/A | The tax amount for the employee expense line.
BackoutTaxAmount | MoneyAmount | N/A | N/A | The amount of the backout tax if there is a tax included with item price detail.
PaymentMethodType | PaymentMethod | N/A | N/A | Identifies the Payment Method to be used when paying this expense transaction.
ExpenseType | ExpenseType | N/A | N/A | Identifies whether the expense transaction is reimbursable or a personal expense.
ReimbursableAmount | MoneyAmount | N/A | N/A | Te reimbursable amount of the expense line.
Description | string | N/A | N/A | A description of the expense line.
Billing | ProjectBilling | N/A | N/A | The billing amounts for the project employee expense line.
Taxes | ArrayOfProjectEmployeeExpenseLineTax | N/A | N/A | A collection of project employee expense line taxes.

Inherits from

ProjectLineBase


ProjectEmployeeExpenseLineKey

Description

Uniquely identifies an employee expense line in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectEmployee ExpenseKey | ProjectEmployeeExpenseKey | N/A | N/A | The project employee expense key object that uniquely identifies the project employee expense.
SequenceNumber | int | N/A | N/A | The sequence number.


ProjectEmployeeExpenseLineTax

Description

Defines the properties for employee expense line tax in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectEmployeeExpenseLineTaxKey | N/A | N/A | The project employee expense tax key object that uniquely identifies the project employee expense tax.
TotalTaxAmount | MoneyAmount | N/A | N/A | The total tax amount for the project employee expense line.
ReimbursedTaxAmount | MoneyAmount | N/A | N/A | The reimbursed tax amount for the project employee expense line.
PurchaseTaxAmount | MoneyAmount | N/A | N/A | The purchase tax amount for the project employee expense line.
FreightTaxAmount | MoneyAmount | N/A | N/A | The freight tax amount for the project employee expense line.
MiscellaneousTaxAmount | MoneyAmount | N/A | N/A | The miscellaneous tax amount for the project employee expense line.
TotalAmount | MoneyAmount | N/A | N/A | The total amount of the project employee expense line.
TaxableAmount | MoneyAmount | N/A | N/A | The taxable amount of the project employee expense line.
GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account.

Inherits from

BusinessObject


ProjectEmployeeExpenseLineTaxKey

Description

Uniquely identifies an employee expense line tax in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectEmployee ExpenseKey | ProjectEmployeeExpenseKey | N/A | N/A | The project employee expense key object that uniquely identifies the project employee expense.
TransactionType | ProjectTransactionType | N/A | N/A | Identifies the type of transaction.
LineSequenceNumber | int | N/A | N/A | The line sequence number.
TaxDetailKey | TaxDetailKey | N/A | N/A | The tax detail key object that uniquely identifies the tax detail.


ProjectEmployeeExpenseSummary

Description

A representation of the important details of a project employee expense within Microsoft Dynamics GP. A list of project employee expense summary objects is returned by the GetProjectEmployeeExpenseList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectEmployeeExpenseKey | N/A | N/A | The project employee expense key object that uniquely identifies the project employee expense transaction.
TransactionState | ProjectTransactionState | N/A | N/A | Indicates whether the project employee expense was retrieved from the open table or the history table.
TransactionType | ProjectTransactionType | N/A | N/A | Identifies the type of transaction.
Date | dateTime | N/A | N/A | The date of the project employee expense transaction.
EmployeeKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the employee.
ReferenceDocument Number | string | N/A | N/A | When the employee expense transaction has a referenced transaction type, this property identifies the document number of the posted transaction to be corrected.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the project employee expense transaction.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch.


ProjectEquipmentItem

Description

Defines the properties for equipment item assigned to a project in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectEquipmentItemKey | N/A | N/A | The project equipment key object that uniquely identifies the project equipment.

Inherits from

BusinessObject


ProjectEquipmentItemKey

Description

Uniquely identifies an equipment item in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies the project.
ProjectEquipmentKey | ProjectEquipmentKey | N/A | N/A | The project equipment key object that uniquely identifies the project equipment.


ProjectEquipmentKey

Description

Uniquely identifies equipment in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify equipment.


ProjectEquipmentRateTableKey

Description

Uniquely identifies an equipment rate table in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify an equipment rate table.

Inherits from

TransactionKey


ProjectFee

Description

Defines the properties for project fee in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectFeeItemKey | N/A | N/A | The project fee line key object that uniquely identifies the project fee line.
Name | string | N/A | N/A | A descriptive name of the fee.
Type | ProjectFeeType | N/A | N/A | Identifies the fee type.
Amount | MoneyAmount | N/A | N/A | The fee amount to be billed.
CostPercent | Percent | N/A | N/A | The percentage to be used to calculate fee as a percentage of total budgeted cost for the project.
RevenuePercent | Percent | N/A | N/A | The percentage to be used to calculate fee as a percentage of total budgeted revenues.
RetentionPercent | Percent | N/A | N/A | The percentage of billing amount that will be withheld in progress billings for a fixed price and cost plus project.
SalesTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a sales tax schedule.
SalesTaxBasis | SalesTaxBasis | N/A | N/A | Identifies the tax basis to be used for the billing amount.
ContractBeginDate | dateTime | N/A | N/A | The begin date of the project contract.
ContractEndDate | dateTime | N/A | N/A | The end date of the project contract.
Frequency | ProjectFrequency | N/A | N/A | The frequency associated with the fee.
StartDate | dateTime | N/A | N/A | The date that a service fee begins.
EndDate | dateTime | N/A | N/A | The date that a service fee ends.
Renew | boolean | N/A | N/A | Indicates if a service fee is recurring.
RenewDate | dateTime | N/A | N/A | The renew date of a service fee.
TotalAmount | MoneyAmount | N/A | N/A | The total amount of the change order fee line.
RenewDay | int | N/A | N/A | The renew day for the service fee.
RenewMonth | int | N/A | N/A | The renew month for the service fee.
UserDefined1 | string | N/A | N/A | User defined data.
UserDefined2 | string | N/A | N/A | User defined data.
ServiceFeeAmount | MoneyAmount | N/A | N/A | An amount for services to be rendered over a specified period.
Schedules | ArrayOfProjectFeeSchedule | N/A | N/A | A collection of project fee schedules.

Inherits from

BusinessObject


ProjectFeeItemKey

Description

Uniquely identifies a project fee item in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies the project.
LineSequenceNumber | int | N/A | N/A | The line sequence number.
ProjectFeeKey | ProjectFeeKey | N/A | N/A | The project fee key object that uniquely identifies the project fee.


ProjectFeeKey

Description

Uniquely identifies a project fee in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a project fee.


ProjectFeeSchedule

Description

Defines the properties of a project fee schedule in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectFeeScheduleKey | N/A | N/A | The project fee schedule key object that uniquely identifies the project fee schedule.
Amount | MoneyAmount | N/A | N/A | The amount of the fee to be applied in the project.
BilledAmount | MoneyAmount | N/A | N/A | The amount of the fee that has been billed.

Inherits from

BusinessObject


ProjectFeeScheduleKey

Description

Uniquely identifies a project fee schedule in the Project Accounting module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies the project.
LineSequenceNumber | int | N/A | N/A | The line sequence number.
ProjectFeeKey | ProjectFeeKey | N/A | N/A | The project fee key object that uniquely identifies the project fee.
Date | dateTime | N/A | N/A | The date the fee is to be applied in the project.


ProjectForecast

Description

The forecast amounts for a project in the Project Accounting module in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ProjectBudgetBase


ProjectHeaderBase

Description

Defines the common properties for a project in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
TransactionState | ProjectTransactionState | N/A | N/A | Indicates whether the project instance was retrieved from the open table or the history table.
TransactionType | ProjectTransactionType | N/A | N/A | Identifies the type of transaction.
Date | dateTime | N/A | N/A | The date of the project transaction.
UserKey | UserKey | N/A | N/A | The user key object that uniquely identifies the user.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted.
ReferenceDocument Number | string | N/A | N/A | The document number of the posted transaction to correct when using the transaction type referenced.
Comment | string | N/A | N/A | The comment associated to the transaction header.
UserDefined1 | string | N/A | N/A | User defined data.
UserDefined2 | string | N/A | N/A | User defined data.
TotalQuantity | Quantity | N/A | N/A | Summation of all quantities expended for the transaction.
TotalCost | MoneyAmount | N/A | N/A | Summation of all costs expended for the transaction.
TotalAccruedRevenue | MoneyAmount | N/A | N/A | Summation of all revenues accrued from the transaction.
ReportSuffix | string | N/A | N/A | The sequential number assigned if more than one transaction is created for the same employee during the same reporting period.
GeneralLedgerPosting Date | dateTime | N/A | N/A | The general lodger posting date for the transaction.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the currency.
ExchangeRate | decimal | N/A | N/A | The exchange rate to be used for currency conversion for the transaction.
ExchangeDate | dateTime | N/A | N/A | The exchange date to be used for currency conversion for the transaction.
OriginalDocumentKey | ProjectMiscellaneousLogKey | N/A | N/A | The project miscellaneous log key object that uniquely identifies the original document.
CreatedBy | string | N/A | N/A | Identifies who created the project transaction.
CreatedDate | dateTime | N/A | N/A | The date the project transaction was created.
PostedDate | dateTime | N/A | N/A | The date the project transaction was posted.
PostedBy | string | N/A | N/A | Identifies who posted the project transaction.

Inherits from

BusinessObject


ProjectKey

Description

Uniquely identifies a project in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a project.

Inherits from

ReferenceKey


ProjectLaborRateTableKey

Description

Uniquely identifies a project labor rate table in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a labor rate table.

Inherits from

TransactionKey


ProjectLineBase

Description

Defines the common properties of a project line in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Date | dateTime | N/A | N/A | The date of the project line.
ProjectKey | ProjectKey | N/A | N/A | The project key object that uniquely identifies the project.
CostCategoryKey | CostCategoryKey | N/A | N/A | The cost category key object that uniquely identifies the cost category.
Quantity | Quantity | N/A | N/A | The number of units used in the project.
UofM | string | N/A | N/A | The unit of measure for the transaction line.
RoundAmount | MoneyAmount | N/A | N/A | The rounding difference when converting the total cost from transaction (originating) to local (functional) currency
UnitCost | MoneyAmount | N/A | N/A | The amount per unit expended.
ExtendedCost | MoneyAmount | N/A | N/A | The cost derived from multiplying the quantity times the unit cost.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the transaction line. The extended cost plus overhead amount.
OverheadAmount | MoneyAmount | N/A | N/A | The overhead amount for the cost category.
OverheadPercent | Percent | N/A | N/A | The overhead percent for the cost category.
TotalOverheadAmount | MoneyAmount | N/A | N/A | The total overhead amount for the cost category.
MarkupPercent | Percent | N/A | N/A | The percentage to be used in computing the accrued revenues if the profit type is markup percentage.
AccruedRevenue | MoneyAmount | N/A | N/A | The computed accrued revenue for the transaction line when the billing type is standard.
ReferenceDocument SequenceNumber | int | N/A | N/A | For a referenced transaction type, this property identifies the line sequence number of the project and cost category combination in the line history table of the posted project transaction being referenced on the project header.
ProjectContractKey | ProjectContractKey | N/A | N/A | The project contract key object that uniquely identifies the project contract.
ProfitType | ProfitType | N/A | N/A | Identifies the profit type to be used when transactions are created for the project.
ProfitAmount | MoneyAmount | N/A | N/A | The profit amount for the transaction line. Calculated as actual billing less actual cost.
TotalProfitAmount | MoneyAmount | N/A | N/A | The total profit amount for the transaction line. Calculated as accrued revenue less total cost.
WorkInProgressGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account to which work in progress amounts will be posted.
UnbilledAccount ReceivableGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account to which unbilled accounts receivable amounts will be posted.
CostOfGoodsSoldGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account to which cost of goods sold amounts will be posted.
ContraGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the contra GL account.
OverheadGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account to which overhead amounts will be posted.
UnbilledProjectRevenue GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account to which unbilled project revenue amounts will be posted.
RoundingGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account key object that uniquely identifies the GL account to which rounding amounts will be posted.
OriginalDocument SequenceNumber | int | N/A | N/A | For a transaction adjustment transaction this property identifies the line sequence number of the project and cost category combination in the line history table of the original project transaction line.

Inherits from

BusinessObject


ProjectMiscellaneousLog

Description

Defines the properties of a miscellaneous log transaction in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectMiscellaneousLogKey | N/A | N/A | The project miscellaneous log key object that uniquely identifies the project miscellaneous log transaction.
MiscellaneousKey | MiscellaneousKey | N/A | N/A | The miscellaneous key object that uniquely identifies the miscellaneous ID.
ReportingPeriod | int | N/A | N/A | The reporting period for which this transaction applies. Reporting periods are useful in tracking the miscellaneous expenses for a project within a given period.
ReportingDate | dateTime | N/A | N/A | The first day of the reporting period.
PeriodEndDate | dateTime | N/A | N/A | The last day of the reporting period.
Lines | ArrayOfProjectMiscellaneousLogLine | N/A | N/A | A collection of project miscellaneous log lines.
Distributions | ArrayOfProjectMiscellaneousLogDistribution | N/A | N/A | A collection of project miscellaneous log distributions.

Inherits from

ProjectHeaderBase


ProjectMiscellaneousLogCriteria

Description

Specifies the criteria to use when retrieving a list of project miscellaneous log summary objects. Only project miscellaneous log summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the project miscellaneous log.
TransactionState | ListRestrictionOfNullableOfProjectTransactionState | A list restriction specifying the transaction state.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date.
MiscellaneousId† | LikeRestrictionOfString | A string restriction specifying the miscellaneous ID.

Inherits from

Criteria


ProjectMiscellaneousLogDistribution

Description

Defines the properties specific to miscellaneous log distribution in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectMiscellaneousLogDistributionKey | N/A | N/A | The project miscellaneous log distribution key object that uniquely identifies the project miscellaneous log distribution.
UserKey | UserKey | N/A | N/A | The user key object that uniquely identifies the user.

Inherits from

ProjectDistributionBase


ProjectMiscellaneousLogDistributionKey

Description

Uniquely identifies a miscellaneous log distribution in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
MiscellaneousLogKey | ProjectMiscellaneousLogKey | N/A | N/A | The project miscellaneous log key object that uniquely identifies the project miscellaneous log.
ControlType | int | N/A | N/A | The control type for the miscellaneous log distribution. Always set to zero.
SequenceNumber | int | N/A | N/A | The sequence number.


ProjectMiscellaneousLogKey

Description

Uniquely identifies a miscellaneous log in the Project Accounting module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a project miscellaneous log transaction.

Inherits from

TransactionKey


ProjectMiscellaneousLogLine

Description

Defines the properties for a miscellaneous log line in the Project Accounting module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ProjectMiscellaneousLogLineKey | N/A | N/A | The project miscellaneous log line key object that uniquely identifies the project miscellaneous log line.
Billing | ProjectBillingFull | N/A | N/A | Billing amounts for the project.
ProjectChangeOrderKey | ProjectChangeOrderKey | N/A | N/A | The project change order key object that uniquely identifies the project change order.

Inherits from

ProjectLineBase


ProjectMiscellaneousLogLineKey

Description

Uniquely identifies a miscellaneous log line in the Project Accounting module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ProjectMiscellaneousLog Key | ProjectMiscellaneousLogKey | N/A | N/A | The project miscellaneous log key object that uniquely identifies the project miscellaneous log.
SequenceNumber | int | N/A | N/A | The sequence number.


ProjectMiscellaneousLogSummary

Description

A representation of the important details of a project miscellaneous log within Microsoft Dynamics GP. A list of project miscellaneous log summary objects is returned by the GetProjectMiscellaneousLogList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectMiscellaneousLogKey | N/A | N/A | The project miscellaneous log key object that uniquely identifies the project miscellaneous log.
TransactionState | ProjectTransactionState | N/A | N/A | Indicates whether the miscellaneous log instance was retrieved from the open table or the history table.
TransactionType | ProjectTransactionType | N/A | N/A | Identifies the type of transaction.
Date | dateTime | N/A | N/A | The date of the transaction.
MiscellaneousKey | MiscellaneousKey | N/A | N/A | The project miscellaneous key object that uniquely identifies the project miscellaneous.
ReportingPeriod | int | N/A | N/A | The reporting period for which this transaction applies. Reporting periods are useful in tracking the miscellaneous expenses for a project within a given period.
ReportingDate | dateTime | N/A | N/A | The first day of the reporting period.
ReferenceDocument Number | string | N/A | N/A | The document number of the posted transaction to correct when using the transaction type referenced.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the transaction.


ProjectPayment

Description

The types of payments in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Cash | ProjectCashDetail | N/A | N/A | The details of a cash payment.
Check | CheckDetail | N/A | N/A | The details of a check payment.
PaymentCard | PaymentCardDetail | N/A | N/A | The details of a payment card payment.


ProjectPosted

Description

The posted amounts in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectFeeAmount | MoneyAmount | N/A | N/A | The posted project fee amount. Management fee, professional fee, incentive fee or any other similar fee amount that forms part of the total project or contract amount.
RetainerFeeAmount | MoneyAmount | N/A | N/A | The posted retainer fee amount for the contract. Prepaid amount to be included in project billings.
ServiceFeeAmount | MoneyAmount | N/A | N/A | The posted amount for services to be rendered over a specified period.
RetentionAmount | MoneyAmount | N/A | N/A | The posted amount not included in progress billings for a fixed price or cost plus project until the project is completed or until specified project conditions and guarantees are met.
BilledRetentionAmount | MoneyAmount | N/A | N/A | The posted billed retention amount for the project.
ReceiptsAmount | MoneyAmount | N/A | N/A | The posted cash receipts amount received from the customer for the projects under the contract.
WriteoffAmount | MoneyAmount | N/A | N/A | The posted amount written off.
CostOfEarningsAmount | MoneyAmount | N/A | N/A | The total cost of earnings for the project.
LossAmount | MoneyAmount | N/A | N/A | The loss amount for the project.

Inherits from

ProjectPostedBase


ProjectPostedAmount

Description

The specific properties for posted amounts for a project in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
TaxPaidAmount | MoneyAmount | N/A | N/A | The tax paid amount for the project.

Inherits from

ProjectAmount


ProjectPostedBase

Description

The common posted amount properties in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
POCosts | MoneyAmount | N/A | N/A | The posted costs on purchase orders for the project.
POQuantity | Quantity | N/A | N/A | The quantities on purchase orders for the project.
EarningsAmount | MoneyAmount | N/A | N/A | The posted total earnings amount for the project.

Inherits from

ProjectAmount


ProjectSummary

Description

A representation of the important details of a project within Microsoft Dynamics GP. A list of project summary objects is returned by the GetProjectList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectKey | N/A | N/A | The project key object that uniquely identifies the project.
ProjectId | string | N/A | N/A | The string value used to identify a project ID assigned to a project.
Name | string | N/A | N/A | A descriptive name for the project.
ProjectContractKey | ProjectContractKey | N/A | N/A | The project contract key object that uniquely identifies the project contract.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer.
ProjectClassKey | ProjectClassKey | N/A | N/A | The project class key object that uniquely identifies the project class.
ProjectManagerKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the project manager.
Type | ProjectType | N/A | N/A | Determines how a contractor is to compute project costs and charge customers for such costs. It also is a way to determine how much revenues can be generated in a project.
Status | ProjectStatus | N/A | N/A | Identifies the status of the project.
AccountingMethod | ProjectAccountingMethod | N/A | N/A | Determines the Percentage Completion of a certain project, budget or fee to determine the revenues to be recognized.
ForecastTotalCost | MoneyAmount | N/A | N/A | The forecast total cost amount.
ForecastProfitAmount | MoneyAmount | N/A | N/A | The forecast profit amount.
PostedTotalCost | MoneyAmount | N/A | N/A | The posted total cost amount.
PostedProfitAmount | MoneyAmount | N/A | N/A | The posted profit amount.


ProjectTimesheet

Description

Defines the properties for a timesheet in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectTimesheetKey | N/A | N/A | The project timesheet key object that uniquely identifies the project timesheet.
ReportingPeriod | int | N/A | N/A | Identifies the Reporting Period for which this transaction applies. Reporting periods are useful in tracking the number of hours expended on a project within a given period.
ReportingDate | dateTime | N/A | N/A | The first day of the reporting period.
PeriodEndDate | dateTime | N/A | N/A | The last day of the reporting period.
PersonalDataKeeperProxy Key | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the personal data keeper proxy.
EmployeeKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the employee.
PersonalDataKeeper TimesheetNumber | string | N/A | N/A | The document number for a timesheet that is entered in PDK (personal data keeper).
Lines | ArrayOfProjectTimesheetLine | N/A | N/A | A collection of project timesheet lines.
Distributions | ArrayOfProjectTimesheetDistribution | N/A | N/A | A collection of project timesheet distributions.

Inherits from

ProjectHeaderBase


ProjectTimesheetCriteria

Description

Specifies the criteria to use when retrieving a list of project timesheet summary objects. Only project timesheet summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the timesheet.
TransactionState | ListRestrictionOfNullableOfProjectTransactionState | A list restriction specifying the transaction state.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date.
EmployeeId† | LikeRestrictionOfString | A string restriction specifying the employee ID.
BatchId† | LikeRestrictionOfString | A string restriction specifying the batch ID.

Inherits from

Criteria


ProjectTimesheetDistribution

Description

Defines the properties specific to timesheet distribution in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectTimesheetDistributionKey | N/A | N/A | The project timesheet distribution key object that uniquely identifies the project timesheet distribution.

Inherits from

ProjectDistributionBase


ProjectTimesheetDistributionKey

Description

Uniquely identifies the timesheet distribution in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectTimesheetKey | ProjectTimesheetKey | N/A | N/A | The project timesheet key object that uniquely identifies the project timesheet.
ControlType | int | N/A | N/A | The control type for the timesheet distribution. Always set to zero.
SequenceNumber | int | N/A | N/A | The sequence number.


ProjectTimesheetKey

Description

Uniquely identifies a timesheet in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string value used to identify a project timesheet.

Inherits from

TransactionKey


ProjectTimesheetLine

Description

Defines the properties for a timesheet line in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectTimesheetLineKey | N/A | N/A | The project timesheet line key object that uniquely identifies the project timesheet line.
BeginTime | dateTime | N/A | N/A | The time the employee began working for a particular cost category in the project. The value is displayed in time using a 24-hour clock. For example, enter 1300 for 1:00 p.m.
EndTime | dateTime | N/A | N/A | The time the employee finished working for a particular cost category in the project. The value is displayed in time using a 24-hour clock. For example, enter 1300 for 1:00 p.m.
Billing | ProjectBillingFull | N/A | N/A | The billing amounts for the timesheet line.
PayCodeKey | PayCodeKey | N/A | N/A | The pay code key object that uniquely identifies the pay code.
SalaryPostingType | SalaryPostingType | N/A | N/A | Identifies the procedure to be performed when posting a salary amount to US Payroll.
JobTitleCodeKey | JobTitleKey | N/A | N/A | The job title key object that uniquely identifies the job title.
DepartmentCodeKey | PayrollDepartmentKey | N/A | N/A | The payroll department key object that uniquely identifies the department.

Inherits from

ProjectLineBase


ProjectTimesheetLineKey

Description

Uniquely identifies a timesheet line in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectTimesheetKey | ProjectTimesheetKey | N/A | N/A | The project timesheet key object that uniquely identifies the project timesheet.
SequenceNumber | int | N/A | N/A | The sequence number.


ProjectTimesheetSummary

Description

A representation of the important details of a project timesheet within Microsoft Dynamics GP. A list of project timesheet summary objects is returned by the GetProjectTimesheetList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ProjectTimesheetKey | N/A | N/A | The project timesheet key object that uniquely identifies the project timesheet.
TransactionState | ProjectTransactionState | N/A | N/A | Indicates whether the project timesheet instance was retrieved from the open table or the history table.
TransactionType | ProjectTransactionType | N/A | N/A | Identifies the type of transaction.
Date | dateTime | N/A | N/A | The date of the transaction.
EmployeeKey | EmployeeKey | N/A | N/A | The employee key object that uniquely identifies the employee.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch.
ReportingPeriod | int | N/A | N/A | Identifies the Reporting Period for which this transaction applies. Reporting periods are useful in tracking the number of hours expended on a project within a given period.
ReportingDate | dateTime | N/A | N/A | The first day of the reporting period.
ReferenceDocument Number | string | N/A | N/A | The document number of the posted transaction to correct when using the transaction type referenced.
TotalCost | MoneyAmount | N/A | N/A | The total cost for the project timesheet.


ProjectUnposted

Description

The unposted amounts for a project in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ProjectFeeAmount | MoneyAmount | N/A | N/A | The unposted project fee amount. Management fee, professional fee, incentive fee or any other similar fee amount that forms part of the total project or contract amount.
RetainerFeeAmount | MoneyAmount | N/A | N/A | The unposted retainer fee amount for the contract. Prepaid amount to be included in project billings.
ServiceFeeAmount | MoneyAmount | N/A | N/A | The unposted amount for services to be rendered over a specified period.
RetentionAmount | MoneyAmount | N/A | N/A | The unposted amount not included in progress billings for a fixed price or cost plus project until the project is completed or until specified project conditions and guarantees are met.
BilledRetentionAmount | MoneyAmount | N/A | N/A | The unposted billed retention amount for the project.
ReceiptsAmount | MoneyAmount | N/A | N/A | The unposted cash receipts amount received from the customer for the projects under the contract.
EarningsAmount | MoneyAmount | N/A | N/A | The unposted total earnings amount for the project.
CostOfEarningsAmount | MoneyAmount | N/A | N/A | The unposted total cost of earnings for the project.
POCosts | MoneyAmount | N/A | N/A | The costs uncommitted on purchase orders for the project.
POQuantity | Quantity | N/A | N/A | The quantities uncommitted on purchase orders for the project.

Inherits from

ProjectUnpostedBase


ProjectUnpostedBase

Description

The properties specific to unposted amounts for a project in the Project Accounting module in Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
LossAmount | MoneyAmount | N/A | N/A | The unposted loss amount for a project.

Inherits from

ProjectAmount


PurchaseBinDetail

Description

Represents a bin for a purchase receipt line.

Properties

Property | Type | Length | Default | Description
Key | PurchaseBinDetailKey | N/A | N/A | The purchase bin detail key that identifies the bin to use for a purchase receipt line.
ItemKey | ItemKey | N/A | Empty | The item key that identifies the item for the bin.
Bin | string | 15 | Empty | The bin identifier.
Quantity | Quantity | N/A | 0 | The quantity for the bin instance.
UofM | string | 8 | Empty | The unit of measure for the bin item.

Inherits from

BusinessObject


PurchaseBinDetailKey

Description

Uniquely identifies a purchase bin for a purchase receipt line.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that identifies the purchase receipt document.
LineSequenceNumber | int | N/A | N/A | The line sequence number. This property is read-only.

Inherits from

TransactionKey


PurchaseDistribution

Description

Defines a general ledger distribution for a specific purchasing document.

Properties

Property | Type | Length | Default | Description
Key | PurchaseDistributionKey | N/A | N/A | The purchase distribution key object that identifies the purchase distribution.
GLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the account to which the amount for this distribution will be posted.
CreditAmount | MoneyAmount | N/A | 0 | The credit amount that will be distributed to the account for each distribution line.
DebitAmount | MoneyAmount | N/A | 0 | The debit amount that will be distributed to the account for each distribution line.
Reference | string | 30 | Empty | The reference to post as the general ledger distribution reference for the account.
DistributionType | DistributionTypeKey | N/A | Empty | The distribution type key that uniquely identifies the type of distribution.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.

Inherits from

BusinessObject


PurchaseDistributionKey

Description

Uniquely identifies a purchase distribution for a purchasing document.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that uniquely identifies a purchas document the distribution applies to.
SequenceNumber | int | N/A | N/A | The sequence number of the distribution instance. This property is read-only.

Inherits from

TransactionKey


PurchaseInvoice

Description

A purchase invoice document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that uniquely identifies the purchase invoice.
VendorDocument Number | string | 20 | N/A | The transaction number assigned by the vendor to this document.
Date | dateTime | N/A | If blank, set to the system date. | The date of the purchase invoice.
BatchKey | BatchKey | N/A | N/A | The batch key object that specifies the batch the purchase invoice is part of.
VendorKey | VendorKey | N/A | N/A | The vendor key object that specified the vendor for the transaction.
VendorName | string | 64 | If not provided, set based on the vendor key. | The name of the vendor.
Reference | string | 17 | N/A | The reference number for the purchase invoice.
Subtotal | MoneyAmount | N/A | N/A | The subtotal for the purchase invoice. This property is read-only.
TradeDiscountAmount | MoneyAmount | N/A | 0 | The amount of the trade discount for the purchase invoice.
FreightAmount | MoneyAmount | N/A | 0 | The freight amount for the purchase invoice.
MiscellaneousAmount | MoneyAmount | N/A | 0 | The amount of miscellaneous charges for the purchase invoice.
TaxAmount | MoneyAmount | N/A | 0 | The total tax amount for the purchase invoice. If a value is not provided it is calculated.
Amount1099 | MoneyAmount | N/A | 0 | The amount to include on the vendor's 1099 statement.
PaymentTermsKey | PaymentTermsKey | N/A | Empty | The payment terms key object that specifies the payment terms for the purchase.
Terms | Terms | N/A | N/A | Specifies the payment terms (such as the discount) for the purchase.
CreatedBy | string | N/A | N/A | The user who created the purchase invoice. This property is read-only.
TaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that identifies the tax schedule for the purchasing company specific to the items being purchased.
FreightTaxBasis | PurchasingTaxBasis | N/A | Nontaxable | Specifies how taxes are calculated on freight for the purchase.
MiscellaneousTaxBasis | PurchasingTaxBasis | N/A | Nontaxable | Specifies how taxes are calculated on miscellaneous costs for the purchase.
FreightTaxScheduleKey | TaxScheduleKey | N/A | Empty | The tax schedule key object that identifies the tax schedule to use when calculating tax for the freight amount.
MiscellaneousTax ScheduleKey | TaxScheduleKey | N/A | Empty | The tax schedule key object that identifies the tax schedule to use when calculating tax for the miscellaneous amount.
FreightTaxAmount | MoneyAmount | N/A | 0 | The freight tax amount.
MiscellaneousTaxAmount | MoneyAmount | N/A | 0 | The miscellaneous tax amount.
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that specifies the currency the purchase was transacted in.
ExchangeRate | decimal | N/A | N/A | The exchange rate of the purchase invoice. Set this value only for multi-currency transactions. If there is triangulation and both rates are fixed, this is the originating to Euro fixed rate. Otherwise this is the variable rate.
ExchangeDate | dateTime | N/A | N/A | The exchange date associated with the exchange rate provided.
VoucherNumber | string | 20 | Empty | The voucher number for the vendor.
RemitToAddressKey | AddressKey | N/A | Defaulted from the vendor | The address key object that specifies where to remit payment for the purchase.
GeneralLedgerPosting Date | dateTime | N/A | Empty | The date that will be used as the posting date in General Ledger.
PostedDate | dateTime | N/A | N/A | The date the transaction was posted.
PostedBy | string | N/A | Set to the user ID who posted the purchase invoice. | The user who posted the purchase invoice. This property is read-only.
CreatedDate | dateTime | N/A | System date | The date the purchase invoice was created. This property is read-only.
ModifiedDate | dateTime | N/A | System date | The date the purchase invoice was last modified. This property is read-only.
TransactionState | PurchaseTransactionState | N/A | N/A | The state of the purchase invoice. This property is read-only.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.
Distributions | ArrayOfPurchaseDistribution | N/A | N/A | The collection of distributions for the purchase invoice.
FreightTaxes | ArrayOfPurchaseInvoiceTax | N/A | N/A | The collection of freight taxes for the purchase invoice.
MiscellaneousTaxes | ArrayOfPurchaseInvoiceTax | N/A | N/A | The collection of miscellaneous taxes for the purchase invoice.
Taxes | ArrayOfPurchaseInvoiceTax | N/A | N/A | The collection of taxes for the purchase invoice.
Lines | ArrayOfPurchaseInvoiceLine | N/A | N/A | A collection of purchase invoice lines for the purchase invoice.

Inherits from

BusinessObject


PurchaseInvoiceApplyReceipt

Description

Matches items in a purchase invoice to purchase receipt.

Properties

Property | Type | Length | Default | Description
Key | PurchaseInvoiceApplyReceiptKey | N/A | N/A | Uniquely identifies a purchase invoice apply receipt.
QuantityInvoiced | Quantity | N/A | 0 | The quanity of items in the purchase invoice document line.
DoesRevalueInventory | boolean | N/A | False | Indicates whether purchase receipt document inventory values can be adjusted.
VarianceGLAccountKey | GLAccountNumberKey | N/A | Empty | A GL account number key object that specifies the purchase account to use when shipment unit cost for an item and the invoice unit cost is different.
UnitCost | MoneyAmount | N/A | 0 | The invoice unit cost as reported on the purchase invoice.
Cost | MoneyAmount | N/A | 0 | The shipment unit cost as reported on the invoice sent from the vendor.

Inherits from

BusinessObject


PurchaseInvoiceApplyReceiptKey

Description

Uniquely identifies a purchase invoice apply receipt document.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that specifies the purchase invoice document.
ReceiptKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that specifies the purchase receipt document.
ReceiptLineSequence Number | int | N/A | 0 | The line sequence number of the purchase receipt document.
LineSequenceNumber | int | N/A | 0 | The line number of purchase invoice apply receipt document.

Inherits from

TransactionKey


PurchaseInvoiceCriteria

Description

Specifies the criteria to use when retrieving a list of purchase invoice summary objects. Only purchase invoice summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
TransactionState | ListRestrictionOfNullableOfPurchaseTransactionState | A list restriction specifying the transaction state of the purchase invoice document.
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the purchase invoice document.
VendorId† | LikeRestrictionOfString | A string restriction specifying the ID of the vendor for the purchase invoice.
BatchId† | LikeRestrictionOfString | A string restriction specifying the batch the purchase invoice is included in.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the purchase invoice document.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the purchase invoice document was last modified.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the purchase invoice document was created.

Inherits from

Criteria


PurchaseInvoiceLine

Description

A purchase invoice line for a purchase invoice in Microsoft Dynamics GP. Each purchase invoice can have a set of purchase invoice lines.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionLineKey | N/A | N/A | The purchase transaction line key object that uniquely identifies the purchase invoice line.
PurchaseOrderKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key that indicates which purchase order the line applies to.
PurchaseOrderLineKey | PurchaseTransactionLineKey | N/A | N/A | The purchase transaction like key that specifies a purchase order line.
QuantityInvoiced | Quantity | N/A | 0 | The quanity of the item being invoiced.
VendorItemNumber | string | 30 | Empty | The item number the vendor uses to refer to the item.
ItemKey | ItemKey | N/A | Empty | The item key object that specifies the item being purchased.
IsNonInventory | boolean | N/A | False | Indicates whether the item is not an inventory item.
VarianceGLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the account to which variance amounts will be posted.
VendorItemDescription | string | 100 | Empty | The vendor’s description of the item being purchased.
UofM | string | 8 | Empty | The unit of measure for the purchase invoice line.
TaxBasis | PurchasingTaxBasis | N/A | Taxable | A tax option which will determine whether the item on the purchase invoice line is taxable. If it is taxable, it also specifies which tax schedule will be used.
ItemTaxScheduleKey | ItemTaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the item tax schedule for the item.
WarehouseTaxSchedule Key | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the warehouse (site) tax schedule to be used when the shipping method is Delivery.
ProjectKey | ProjectKey | N/A | N/A | The project key object that specifies the project this purchase invoice line will update.
CostCategoryKey | CostCategoryKey | N/A | N/A | The cost category key object that specifies the cost category that will be updated.
UnitCost | MoneyAmount | N/A | Default from the item | The cost for the item in the specified unit of measure.
ExtendedCost | MoneyAmount | N/A | Set to QuantityOrdered x UnitCost | The extended cost of the purchase invoice line. This property is read-only.
IsLandedCost | boolean | N/A | False | Indicates whether the item uses landed costs.
TaxAmount | MoneyAmount | N/A | Automatically calculated | The tax amount for the purchase invoice line.
BackoutTaxAmount | MoneyAmount | N/A | N/A | The backout tax amount for the purchase invoice line. This property is read-only.
Receipts | ArrayOfPurchaseInvoiceApplyReceipt | N/A | N/A | The collection of purchase invoice apply receipts for the purchase invoice line.
Taxes | ArrayOfPurchaseInvoiceTax | N/A | N/A | The collection of purchase invoice tax information for the purchase invoice line.

Inherits from

BusinessObject


PurchaseInvoiceSummary

Description

A representation of the important details of a purchase invoice document within Microsoft Dynamics GP. A list of purchase invoice summary objects is returned by the GetPurchaseInvoiceList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that uniquely identifies the purchase invoice.
VendorKey | VendorKey | N/A | N/A | The vendor key object that specified the vendor for the transaction.
Date | dateTime | N/A | N/A | The date of the purchase invoice.
VendorDocumentNumber | string | 20 | N/A | The transaction number assigned by the vendor to this document.
Subtotal | MoneyAmount | N/A | N/A | The subtotal for the purchase invoice.
TaxAmount | MoneyAmount | N/A | N/A | The total tax amount for the purchase invoice.
FreightAmount | MoneyAmount | N/A | N/A | The freight amount for the purchase invoice.
MiscellaneousAmount | MoneyAmount | N/A | N/A | The amount of miscellaneous charges for the purchase invoice.
BatchKey | BatchKey | N/A | N/A | The batch key object that specifies the batch the purchase invoice is part of.
ModifiedDate | dateTime | N/A | N/A | The date the purchase invoice was last modified. This property is read-only.
CreatedDate | dateTime | N/A | N/A | The date the purchase invoice was created. This property is read-only.
TransactionState | PurchaseTransactionState | N/A | N/A | The state of the purchase invoice.


PurchaseInvoiceTax

Description

Defines that tax information for a purchase invoice.

Properties

Property | Type | Length | Default | Description
GLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account key object that specifies the posting account to which the tax amount for this tax detail will be posted.

Inherits from

PurchaseTax


PurchaseLotDetail

Description

Lot details for a purchase receipt line.

Properties

Property | Type | Length | Default | Description
Key | PurchaseLotDetailKey | N/A | N/A | The purcase lot detail key object that identifies the purchase lot detail.
LotNumber | string | 20 | Empty | The lot number.
Quantity | Quantity | N/A | 0 | The quantity of items selected from the lot number specified.
Bin | string | 15 | Empty | The bin number. Only provide when using multiple bins.
ManufacturedDate | dateTime | N/A | N/A | The date the item was made. This property is read-only.
ExpirationDate | dateTime | N/A | N/A | The date the item will expire. This property is read-only.
DateReceived | dateTime | N/A | N/A | The date the item was received. This property is read-only.
DateSequenceNumber | decimal | N/A | N/A | The received sequence number. This property is read-only.
UnitCost | MoneyAmount | N/A | N/A | The cost per unit of measure. This property is read-only.

Inherits from

BusinessObject


PurchaseLotDetailKey

Description

Uniquely identifies a purchase lot for a purchase receipt line.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that specifies the purchase receipt.
LineSequenceNumber | int | N/A | 0 | The line sequence number of the purchase receipt associated with the purchase lot serial detail instance. This property is read only.
QuantityType | QuantityType | N/A | 0 | The quantity type of the item. For non-return item quantities the quantity type must be on hand.
SequenceNumber | int | N/A | 0 | The sequence number. This property is read-only.

Inherits from

TransactionKey


PurchaseOrder

Description

A purchase order document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that uniquely identifies the purchase order.
Type | PurchaseOrderType | N/A | Standard | Specifies the type of purchase order document.
VendorKey | VendorKey | N/A | N/A | The vendor key object that specifies the vendor who will be filling the purchase order.
VendorName | string | 64 | If not provided, the name is based on the vendor key. | The name of the vendor who will be filling the purchase order.
Date | dateTime | N/A | If blank, set to the system date. | The date of the purchase order.
BuyerKey | BuyerKey | N/A | Empty | The buyer key object that specifies the buyer responsible for the purchase order.
DoesAllowSalesOrder Commitments | boolean | N/A | False | Specifies whether the purchase order can be committed to outstanding sales orders.
CustomerKey | CustomerKey | N/A | Empty | The customer key object that specifies which customer the purchase order will be drop shipped to. This value is required for drop ship purchase orders.
ShipToAddressKey | AddressKey | N/A | Will default based on CompanyKey | The address key object that specifies where the purchase order will be shipped.
ShipToAddress | BusinessAddress | N/A | Will default based on ShipToAddressKey | The address where the purchase order will be shipped.
PurchaseAddressKey | AddressKey | N/A | Will default based on VendorKey | The address key object that specifies the vendor’s address.
PurchaseAddress | BusinessAddress | N/A | Will default based on PurchaseAddressKey | The address for the vendor.
BillToAddressKey | AddressKey | N/A | Empty | The address key object that specifies who should be billed for the purchase.
ShippingMethodKey | ShippingMethodKey | N/A | Empty | The shipping method key that specifies the shipping method for the purchase.
PaymentTermsKey | PaymentTermsKey | N/A | Empty | The payment terms key object that specifies the payment terms for the purchase.
Terms | Terms | N/A | N/A | Specifies the payment terms (such as the discount) for the purchase.
TaxRegistrationNumber | string | 25 | Empty | The vendor’s tax registration number.
ConfirmWith | string | 20 | Empty | The person at the purchasing company that must confirm the purchase can be initiated.
CommentKey | CommentKey | N/A | Empty | The identifier for the comment that will apprear on the purchase order.
IsOnHold | boolean | N/A | False | Indicates whether the purchase is on hold.
TaxScheduleKey | TaxScheduleKey | N/A | Empty | The tax schedule key object that identifies the tax schedule for the purchasing company specific to the items being purchased.
FreightTaxBasis | PurchasingTaxBasis | N/A | Nontaxable | Specifies how taxes are calculated on freight for the purchase.
MiscellaneousTaxBasis | PurchasingTaxBasis | N/A | Nontaxable | Specifies how taxes are calculated on miscellaneous costs for the purchase.
FreightTaxScheduleKey | TaxScheduleKey | N/A | Empty | The tax schedule key object that identifies the tax schedule to use when calculating tax for the freight amount.
MiscellaneousTax ScheduleKey | TaxScheduleKey | N/A | Empty | The tax schedule key object that identifies the tax schedule to use when calculating tax for the miscellaneous amount.
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that specifies the currency the purchase order was transacted in.
ExchangeRate | decimal | N/A | 0 | The exchange rate of the purchase order. Set this value only for multi-currency transactions. If there is triangulation and both rates are fixed, this is the originating to Euro fixed rate. Otherwise this is the variable rate.
ExchangeDate | dateTime | N/A | If not provided, will be set to the purchase order date. | The exchange date associated with the exchange rate provided.
CreatedBy | string | N/A | Set to the user ID who created the purchase order. | The user who created the purchase order. This property is read-only.
Status | PurchaseOrderStatus | N/A | New | The status of the purchase order. This property is read-only.
Comment | string | 500 | Empty | The comment associated with the purchase order.
PromisedDate | dateTime | N/A | Empty | The date the vendor promised the entire order would be received.
PromisedShipDate | dateTime | N/A | Empty | The date the vendor promised to ship the entire purchase order.
RequestedDate | dateTime | N/A | Empty | The date the entire purchase order must be received.
ContractEndDate | dateTime | N/A | Empty | The date the contract with the vendor expires.
StatusGroup | StatusGroup | N/A | Active | Indicates the status of a purchase order. This property is read-only.
RequisitionDate | dateTime | N/A | N/A | The requisition date (when the purchase order originated as a requisition). This property is read-only.
CompanyKey | CompanyKey | N/A | N/A | The company key object specifying the company. This property is read-only.
RemainingSubtotal | MoneyAmount | N/A | N/A | The cost of the items remaining to invoice for the purchase order. This property is read-only.
Subtotal | MoneyAmount | N/A | N/A | The total of the extended costs of all the line items for the purchase order before taxes, freight and miscellaneous charges are added to the costs and the trade discounts are subtracted from the costs. This property is read-only.
CanceledSubtotal | MoneyAmount | N/A | N/A | The total of the canceled line items for the purchase order. This property is read-only.
TradeDiscountAmount | MoneyAmount | N/A | 0 | The amount of the trade discount for the purchase order. If a trade discount percentage was specified for the customer the trade discount amount is calculated by the system.
FreightAmount | MoneyAmount | N/A | 0 | The freight amount for the purchase order.
MiscellaneousAmount | MoneyAmount | N/A | 0 | The amount of miscellaneous charges for the purchase order.
TaxAmount | MoneyAmount | N/A | N/A | The tax amount for the summed details for Tax, FreightTax and MiscelleaneousTax.
LastEditDate | dateTime | N/A | N/A | The date the purchase order was last edited. This property is read-only.
LastPrintedDate | dateTime | N/A | N/A | The date the purchase order was last printed. This property is read-only.
TimesPrinted | int | N/A | N/A | The number of time the purchase order has been printed. This property is read-only.
CreatedDate | dateTime | N/A | System date | The date the purchase order was created. This property is read-only.
ModifiedDate | dateTime | N/A | System date | The date the purchase order was last modified. The value is in Coordinated Universal Time (UTC). This property is read-only.
RevisionNumber | int | N/A | N/A | The purchase order’s revision number. This property is read-only.
TransactionState | PurchaseOrderTransactionState | N/A | Work | The state of the purchase order transaction. This property is read-only.
FreightTaxAmount | MoneyAmount | N/A | 0 | The freight tax amount.
MiscellaneousTaxAmount | MoneyAmount | N/A | 0 | The miscellaneous tax amount.
BackoutTaxAmount | MoneyAmount | N/A | N/A | The backout tax amount. This property is read-only.
BackoutFreightTax Amount | MoneyAmount | N/A | N/A | The backout freight tax amount. This property is read-only.
BackoutMiscellaneousTax Amount | MoneyAmount | N/A | N/A | The backout miscellaneous tax amount. This property is read-only.
FreightTaxes | ArrayOfPurchaseTax | N/A | N/A | The collection of freight taxes for the purchase order. Do not set this value if you are also setting taxes on the Purchase Order Line. Setting tax information on both the purchase order and purchase order line is not supported.
MiscellaneousTaxes | ArrayOfPurchaseTax | N/A | N/A | The collection of miscellaneous taxes for the purchase order. Do not set this value if you are also setting taxes on the Purchase Order Line. Setting tax information on both the purchase order and purchase order line is not supported.
Taxes | ArrayOfPurchaseTax | N/A | N/A | The collection of taxes for the purchase order. Do not set this value if you are also setting taxes on the Purchase Order Line. Setting tax information on both the purchase order and purchase order line is not supported.
Lines | ArrayOfPurchaseOrderLine | N/A | N/A | A collection of purchase order lines for the purchase order.
WorkflowPriority | WorkflowPriority | N/A | N/A | The priority of the purchase order in the workflow. This property is read-only.
Workflows | ArrayOfWorkflow | N/A | N/A | The collection of workflow objects for the purchase order. This property is read-only.
ContractNumber | string | 20 | Empty | The contract number for the purchase order. This property is read-only.
TotalAmount | MoneyAmount | N/A | N/A | The total amount of the purchase order.

Inherits from

BusinessObject


PurchaseOrderCriteria

Description

Specifies the criteria to use when retrieving a list of purchase order summary objects. Only purchase order summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
TransactionState | ListRestrictionOfNullableOfPurchaseOrderTransactionState | A list restriction specifying the transaction state of the purchase order document.
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the purchase order document.
VendorId† | LikeRestrictionOfString | A string restriction specifying the ID of the vendor that will be filling the purchase order.
BuyerId | LikeRestrictionOfString | A string restriction specifying the ID of the buyer associated with the purchase order.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the purchase order document.
Status | ListRestrictionOfNullableOfPurchaseOrderStatus | A list restriction specifying the status of the purchase order document.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the purchase order document was last modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the purchase order document was created.
Scope | VendorScope | A property in criteria that specifies the vendor information to be used when returning purchase order data.

Inherits from

Criteria


PurchaseOrderLine

Description

A purchase order line for a purchase order in Microsoft Dynamics GP. Each purchase order can have a set of purchase order lines.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionLineKey | N/A | N/A | The purchase transaction line key object that uniquely identifies the purchase order line.
WarehouseKey | WarehouseKey | N/A | N/A | The warehouse key object that specifies the warehouse (site) where item will be received.
VendorItemNumber | string | 30 | Empty | The item number the vendor uses to refer to the item.
ItemKey | ItemKey | N/A | Empty | The item key object that specifies the item being purchased.
QuantityOrdered | Quantity | N/A | 0 | The quantity of the item being purchased.
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled of the item being purchased.
FreeOnBoard | FreeOnBoard | N/A | None | Specifies when ownership of the items passes from the vendor to the buyer.
RequestedBy | string | 20 | Empty | The person or department that requested the item.
CommentKey | CommentKey | N/A | Empty | The identifier for the comment that will apprear on the purchase order line.
RequestedDate | dateTime | N/A | Empty | The date the item must be received by.
ReleaseByDate | dateTime | N/A | Empty | The date the purchase order line needs to be released to the vendor in order to receive the item by the required date.
PromisedDate | dateTime | N/A | Empty | The date the vendor promised you would receive merchandise or services.
PromisedShipDate | dateTime | N/A | Empty | The date the vendor promised the merchandise would be shipped.
IsNonInventory | boolean | N/A | False | Indicates whether the item on the purchase order is not an inventory item.
InventoryGLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the inventory account that will be used as the default posting account when you post invoices and shipment/invoices.
ItemDescription | string | 100 | Empty | The description of the item for the purchase order line.
VendorItemDescription | string | 100 | Empty | The vendor’s description of the item being purchased.
UofM | string | 8 | Empty | The unit of measure for the purchase order line.
TaxBasis | PurchasingTaxBasis | N/A | Taxable | A tax option which will determine whether the item on the purchase order line is taxable. If it is taxable, it also specifies which tax schedule will be used.
ItemTaxScheduleKey | ItemTaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the item tax schedule for the item. This property is read-only.
WarehouseTaxSchedule Key | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the warehouse (site) tax schedule to be used when the shipping method is Delivery.
LandedCostGroupKey | LandedCostGroupKey | N/A | N/A | The landed cost group key object that uniquely identifies the landed cost group that should be used for the item.
ShippingMethodKey | ShippingMethodKey | N/A | N/A | The shipping method key object that specifies the shipping method for the item.
Status | PurchaseOrderStatus | N/A | New | Specifies the status of the purchase order line item.
Comment | string | 500 | Empty | The comment for the purchase order line.
ShipToAddressKey | AddressKey | N/A | Empty | The address key object that specifies where the purchase order line item will be shipped.
ShipToAddress | BusinessAddress | N/A | Empty | The address where the purchase order line item will be shipped.
ProjectKey | ProjectKey | N/A | N/A | The project key object that specifies the project this purchase order line will update.
CostCategoryKey | CostCategoryKey | N/A | N/A | The cost category key object that specifies the cost category that will be updated.
UnitCost | MoneyAmount | N/A | Default from the item | The cost for the item in the specified unit of measure.
ExtendedCost | MoneyAmount | N/A | Set to QuantityOrdered x UnitCost | The extended cost of the purchase order line. This property is read-only.
SourceDocumentNumber | string | N/A | N/A | The source document number for the purchase order line. This property is read-only
SourceDocumentLine Number | string | N/A | N/A | The line number for the source document. This property is read-only.
ReleasedDate | dateTime | N/A | N/A | The date the purchase order line was released to the vendor. This property is read-only.
TaxAmount | MoneyAmount | N/A | 0 | The tax amount for the purchase order line.
BackoutTaxAmount | MoneyAmount | N/A | N/A | The backout tax amount for the purchase order line. This property is read-only.
Taxes | ArrayOfPurchaseTax | N/A | N/A | The collection of purchase tax information for the purchase order line.
JobNumber | string | N/A | N/A | The job number for the purchase order line. This property is read-only.
LineOrigin | PurchaseOrderLineOrigin | N/A | N/A | Identifies the origin of the purchase order line.
IsCapitalItem | boolean | N/A | N/A | The value True indicates that the item on the purchase order line is a capital item. This property is read-only.
DocumentDate | dateTime | N/A | N/A | Specifies the date of the purchase order.

Inherits from

BusinessObject


PurchaseOrderSummary

Description

A representation of the important details of a purchase order document within Microsoft Dynamics GP. A list of purchase order summary objects is returned by the GetPurchaseOrderList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that uniquely identifies the purchase order.
Type | PurchaseOrderType | N/A | N/A | Specifies the type of purchase order document.
VendorKey | VendorKey | N/A | N/A | The vendor key object that specifies the vendor who will be filling the purchase order.
TransactionState | PurchaseOrderTransactionState | N/A | N/A | The state of the purchase order transaction.
Date | dateTime | N/A | N/A | The date of the purchase order.
BuyerKey | BuyerKey | N/A | N/A | The buyer key object that specifies the buyer responsible for the purchase order.
Status | PurchaseOrderStatus | N/A | N/A | The status of the purchase order.
RequestedDate | dateTime | N/A | N/A | The date the entire purchase order must be received.
RemainingSubtotal | MoneyAmount | N/A | N/A | The cost of the items remaining to invoice for the purchase order.
ModifiedDate | dateTime | N/A | N/A | The date the purchase order was last modified.
CreatedDate | dateTime | N/A | N/A | The date the purchase order was created.


PurchaseReceipt

Description

A purchase receipt document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that uniquely identifies the purchase receipt.
VendorDocument Number | string | 20 | N/A | The document number given to you by the vendor. Typically this is the invoice number or packing slip number from the vendor's documents.
Date | dateTime | N/A | Set to the system date if not supplied. | The date of the receipt.
ActualShipDate | dateTime | N/A | Empty | The date the vendor actually shipped the order.
BatchKey | BatchKey | N/A | N/A | The batch key object that specifies the batch the purchase receipt is part of.
VendorKey | VendorKey | N/A | N/A | The vendor key object that specified the vendor that filled the purchase order.
VendorName | string | 64 | If not provided, set based on the vendor key. | The name of the vendor that filled the purchase order.
Reference | string | 30 | Empty | The transaction comments that will be posted in the general ledger for the purchase receipt.
Subtotal | MoneyAmount | N/A | N/A | The subtotal for the purchase receipt. This property is read-only.
CreatedBy | string | N/A | N/A | The user who created the purchase receipt. This property is read-only.
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that specifies the currency the purchase receipt was transacted in.
ExchangeRate | decimal | N/A | 0 | The exchange rate of the purchase receipt. Set this value only for multi-currency transactions. If there is triangulation and both rates are fixed, this is the originating to Euro fixed rate. Otherwise this is the variable rate.
ExchangeDate | dateTime | N/A | If not provided, will be set to the purchase receipt date | The exchange date associated with the exchange rate provided.
RemitToAddressKey | AddressKey | N/A | Defaulted from the vendor | The address key object that specifies where to remit payment for the purchase.
GeneralLedgerPosting Date | dateTime | N/A | N/A | The date that will be used as the posting date in General Ledger. This property is read-only.
PostedDate | dateTime | N/A | N/A | The date the transaction was posted. This property is read-only.
PostedBy | string | N/A | N/A | The user who posted the purchase receipt. This property is read-only.
CreatedDate | dateTime | N/A | N/A | The date the purchase receipt was created. This property is read-only.
ModifiedDate | dateTime | N/A | N/A | The date the purchase receipt was last modified. This property is read-only.
TransactionState | PurchaseTransactionState | N/A | N/A | The state of the purchase receipt. This property is read-only.
TotalLandedCostAmount | MoneyAmount | N/A | N/A | The sum of the landed costs contained on the purchase receipt line items.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.
UserDefined | ArrayOfPurchaseUserDefined | N/A | N/A | The user-defined values for the purchase receipt.
Distributions | ArrayOfPurchaseDistribution | N/A | N/A | The collection of distributions for the purchase receipt.
Lines | ArrayOfPurchaseReceiptLine | N/A | N/A | A collection of purchase receipt lines for the purchase receipt.

Inherits from

BusinessObject


PurchaseReceiptCriteria

Description

Specifies the criteria to use when retrieving a list of purchase receipt summary objects. Only purchase receipt summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
TransactionState | ListRestrictionOfNullableOfPurchaseTransactionState | A list restriction specifying the transaction state of the purchase receipt document.
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the purchase receipt document.
VendorId† | LikeRestrictionOfString | A string restriction specifying the ID of the vendor that will filled the purchase order.
BatchId† | LikeRestrictionOfString | A string restriction specifying the ID of the batch the purchase receipt is part of.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the purchase receipt document.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the purchase receipt document was last modified.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the purchase receipt document was created.

Inherits from

Criteria


PurchaseReceiptLine

Description

A purchase receipt line for a purchase receipt in Microsoft Dynamics GP. Each purchase receipt can have a set of purchase receipt lines.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionLineKey | N/A | N/A | The purchase transaction line key object that uniquely identifies the purchase receipt line.
PurchaseOrderKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key that indicates which purchase order the line applies to.
ItemKey | ItemKey | N/A | N/A | The item key object that specifies the item for the purchase receipt line.
ItemDescription | string | 100 | Defaulted from the item | The description of the item being purchased.
VendorItemNumber | string | 30 | Empty | The item number the vendor uses to refer to the item.
VendorItemDescription | string | 100 | Empty | The vendor’s description of the item being purchased.
ActualShipDate | dateTime | N/A | Empty | The date the vendor shipped the item.
InventoryGLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the account the purchased item will be distributed to.
UofM | string | 8 | Empty | The unit of measure for the purchase receipt line.
UnitCost | MoneyAmount | N/A | Default from the item | The cost for the item in the specified unit of measure.
ExtendedCost | MoneyAmount | N/A | Set to QuantityOrdered x UnitCost | The extended cost of the purchase receipt line. This property is read-only.
IsNonInventory | boolean | N/A | False | Indicates whether the item being purchased is an non-inventory item.
BillOfLadingNumber | string | 30 | Empty | The Bill of Lading or Progressive Number that was assigned to the purchase receipt by the carrier.
QuantityShipped | Quantity | N/A | 0 | The quantity of items received on the purchase receipt.
LandedCostGroupKey | LandedCostGroupKey | N/A | N/A | The landed cost group key that defines the landed cost group that should be used for the item.
WarehouseKey | WarehouseKey | N/A | N/A | The warehouse key object that specifies the warehouse (site) where item will be received.
ProjectKey | ProjectKey | N/A | N/A | The project key object that specifies the project this purchase receipt line will update.
CostCategoryKey | CostCategoryKey | N/A | N/A | The cost category key object that specifies the cost category that will be updated.
PurchaseOrderLineKey | PurchaseTransactionLineKey | N/A | N/A | The purchase transaction line key that specifies the purchase order line that corresponds to this purchase receipt line.
QuantityRejected | Quantity | N/A | N/A | The quantity of items that was rejected upon delivery. This property is read-only.
Lots | ArrayOfPurchaseLotDetail | N/A | Empty | A collection of lost details for a purchase receipt line witha lot-tracked item.
Serials | ArrayOfPurchaseSerialDetail | N/A | Empty | A collection of serial details for a purchase receipt line with a serial-tracked item.
Bins | ArrayOfPurchaseBinDetail | N/A | Empty | A collection of bin details for a purchase receipt line when using the multiple bin functionality.

Inherits from

BusinessObject


PurchaseReceiptSummary

Description

A representation of the important details of a purchase receipt document within Microsoft Dynamics GP. A list of purchase receipt summary objects is returned by the GetPurchaseReceiptList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that uniquely identifies the purchase receipt.
VendorKey | VendorKey | N/A | N/A | The vendor key object that specified the vendor that filled the purchase order.
Date | dateTime | N/A | N/A | The date of the receipt.
VendorDocumentNumber | string | 20 | N/A | The document number given to you by the vendor. Typically this is the invoice number or packing slip number from the vendor's documents.
Subtotal | MoneyAmount | N/A | N/A | The subtotal for the purchase receipt.
BatchKey | BatchKey | N/A | N/A | The batch key object that specifies the batch the purchase receipt is part of.
ModifiedDate | dateTime | N/A | N/A | The date the purchase receipt was last modified. This property is read-only.
CreatedDate | dateTime | N/A | N/A | The date the purchase receipt was created. This property is read-only.
TransactionState | PurchaseTransactionState | N/A | N/A | The state of the purchase receipt.


PurchaseSerialDetail

Description

Serial number details for a purchase receipt line.

Properties

Property | Type | Length | Default | Description
Key | PurchaseSerialDetailKey | N/A | N/A | The purchase serial detail key object that identifies the serial detail.
SerialNumber | string | 20 | Empty | The serial number.
Bin | string | 15 | Empty | The bin number. Only provide if using multiple bins.
UnitCost | MoneyAmount | N/A | N/A | The cost per unit of measure. This property is read-only.

Inherits from

BusinessObject


PurchaseSerialDetailKey

Description

Uniquely identifies the set of serial details for a purchase receipt line.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that specifies the purchase document.
LineSequenceNumber | int | N/A | 0 | The line sequence number.
QuantityType | QuantityType | N/A | N/A | The quantity type for the item.
SequenceNumber | int | N/A | 0 | The sequence number.

Inherits from

TransactionKey


PurchaseTax

Description

Defines the tax information for a specific purchasing document.

Properties

Property | Type | Length | Default | Description
Key | PurchaseTaxKey | N/A | Empty | The purchase tax key object that uniquely identifies the purchase tax information.
IsBackoutTax | boolean | N/A | False | Indicates whether the tax is a backout tax.
TaxAmount | MoneyAmount | N/A | 0 | The tax amount.
TaxableAmount | MoneyAmount | N/A | 0 | The total taxable purchase amount.
TotalAmount | MoneyAmount | N/A | 0 | The total purchase amount.
TotalTaxPotentialAmount | MoneyAmount | N/A | N/A | The total tax potential. This property is read-only.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.

Inherits from

BusinessObject


PurchaseTaxKey

Description

Uniquely identifies a purchase tax instance for a purchasing document.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that uniquely identifies a purchase document the tax information applies to.
TaxDetailKey | TaxDetailKey | N/A | N/A | The tax detail key object that identifies the tax detail.
SequenceNumber | int | N/A | N/A | The sequence number of the tax information instance. This property is read-only.

Inherits from

ReferenceKey


PurchaseTransactionKey

Description

Uniquely identifies a purchase document object in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 17 | N/A | The unique identifier for the purchase document.

Inherits from

TransactionKey


PurchaseTransactionLineKey

Description

Uniquely identifies a line instance for a purchasing document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionKey | PurchaseTransactionKey | N/A | N/A | The purchasing document key object that uniquely identifies the purchasing document.
LineSequenceNumber | int | N/A | 0 | The line item sequence number.

Inherits from

TransactionKey


PurchaseUserDefined

Description

Contains user-defined values that have been set up for purchase receipts (receivings transactions).

Properties

Property | Type | Length | Default | Description
Key | PurchaseUserDefinedKey | N/A | N/A | The purchase user defined key object that uniquely identifies the set of user-defined data for a purchase receipt.
List01 | string | 30 | Empty | List field 1
List02 | string | 30 | Empty | List field 2
List03 | string | 30 | Empty | List field 3
List04 | string | 30 | Empty | List field 4
List05 | string | 30 | Empty | List field 5
Text01 | string | 30 | Empty | Text field 1
Text02 | string | 30 | Empty | Text field 2
Text03 | string | 30 | Empty | Text field 3
Text04 | string | 30 | Empty | Text field 4
Text05 | string | 30 | Empty | Text field 5
Text06 | string | 30 | Empty | Text field 6
Text07 | string | 30 | Empty | Text field 7
Text08 | string | 30 | Empty | Text field 8
Text09 | string | 30 | Empty | Text field 9
Text10 | string | 30 | Empty | Text field 10
Date01 | dateTime | N/A | Empty | Date field 1
Date02 | dateTime | N/A | Empty | Date field 2
Date03 | dateTime | N/A | Empty | Date field 3
Date04 | dateTime | N/A | Empty | Date field 4
Date05 | dateTime | N/A | Empty | Date field 5
Date06 | dateTime | N/A | Empty | Date field 6
Date07 | dateTime | N/A | Empty | Date field 7
Date08 | dateTime | N/A | Empty | Date field 8
Date09 | dateTime | N/A | Empty | Date field 9
Date10 | dateTime | N/A | Empty | Date field 10
Date11 | dateTime | N/A | Empty | Date field 11
Date12 | dateTime | N/A | Empty | Date field 12
Date13 | dateTime | N/A | Empty | Date field 13
Date14 | dateTime | N/A | Empty | Date field 14
Date15 | dateTime | N/A | Empty | Date field 15
Date16 | dateTime | N/A | Empty | Date field 16
Date17 | dateTime | N/A | Empty | Date field 17
Date18 | dateTime | N/A | Empty | Date field 18
Date19 | dateTime | N/A | Empty | Date field 19
Date20 | dateTime | N/A | Empty | Date field 20

Inherits from

BusinessObject


PurchaseUserDefinedKey

Description

Uniquely identifies a set of user-defined values for a purchase receipt transaction.

Properties

Property | Type | Length | Default | Description
PurchaseTransactionKey | PurchaseTransactionKey | N/A | N/A | The purchase transaction key object that specifies which purchase transaction the user-defined values are associated with.

Inherits from

TransactionKey


Quantity

Description

A quantity amount in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Value | decimal | N/A | 0 | The decimal value of the quantity amount.
DecimalDigits | int | N/A | 0 | The number of decimal places to be applied to the quantity amount. The value can be from 0 to 5.

Inherits from

Amount


RateTypeKey

Description

Uniquely identifies a rate type within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | The string identifier assigned to a rate type. This property is read-only.

Inherits from

ReferenceKey


ReceivablesCommission

Description

Represents a commission instance for receivables documents in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ReceivablesCommissionKey | N/A | N/A | The receivables commission key object that uniquely identifies a receivables commission.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key that uniquely identifies the salesperson receiving the commission.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that uniquely identifies the sales territory.
CommissionPercent | Percent | N/A | 0 | The salesperson’s commission percentage or the percentage of each sale the salesperson receives.
CommissionAmount | MoneyAmount | N/A | 0 | The commission amount the salesperson will be paid. This amount may be a negative number if the extended price and unit price are negative amounts.
PercentOfSale | Percent | N/A | 0 | The percentage of the sales the salesperson’s commission are calculated on. To split a commission, provide the percentage of the sale that should be attributed to each salesperson on the transaction.
Noncommissioned‘ Amount | MoneyAmount | N/A | N/A | The amount on which no commissions were paid to the salesperson.
SalesAmount | MoneyAmount | N/A | N/A | The total sales amount.

Inherits from

BusinessObject


ReceivablesCommissionKey

Description

Uniquely identifies a receivables commission associated with a receivables document.

Properties

Property | Type | Length | Default | Description
ReceivablesDocumentKey | ReceivablesDocumentKey | N/A | N/A | The receivables document key object that uniquely identifies the receivables document the commission is associated with.
SequenceNumber | int | N/A | 0 | The sequence number of the commission instance.

Inherits from

TransactionKey


ReceivablesCreditDocument

Description

A receivables credit document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DiscountReturned | MoneyAmount | N/A | N/A | The amount of the discount returned for a receivables document.

Inherits from

ReceivablesDocument


ReceivablesCreditMemo

Description

A receivables credit memo document within Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ReceivablesCreditDocument


ReceivablesCreditMemoCriteria

Description

Specifies the criteria to use when retrieving a list of receivables credit memo summary objects. Only receivables credit memo summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentCriteriaBase


ReceivablesCreditMemoSummary

Description

A representation of the important details of a receivables credit memo within Microsoft Dynamics GP. A list of receivables credit memo summary objects is returned by the GetReceivablesCreditMemoList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentSummaryBase


ReceivablesDebitDocument

Description

Defines the properties common to a receivables debit document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Payment | ReceivablesPayment | N/A | N/A | The receivables payment object specifying payment information for the receivables debit document.
Terms | ReceivablesTerms | N/A | N/A | The receivables terms object specifying the terms discount information for the receivables debit document.
WriteoffAmount | MoneyAmount | N/A | 0 | The write-off amount for the receivables debit document.
GSTDiscountAmount | MoneyAmount | N/A | 0 | The GST discount amount for the receivables debit document. Only used when GST is enabled.
PaymentTermsKey | PaymentTermsKey | N/A | N/A | The payment terms key object that uniquely identifies the payment terms for the receivables debit document.

Inherits from

ReceivablesDocument


ReceivablesDebitMemo

Description

Defines the properties common to a receivables debit memo document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CommissionBasedOn | CommissionBasedOn | N/A | N/A | Indicates whether the commission amount is based on the document’s sales amount or the total document amount.
CommissionAmount | MoneyAmount | N/A | N/A | The commission amount for the receivables debit memo document.
Commissions | ArrayOfReceivablesCommission | N/A | N/A | A collection of receivables commission objects for the receivables debit memo document.

Inherits from

ReceivablesDebitDocument


ReceivablesDebitMemoCriteria

Description

Specifies the criteria to use when retrieving a list of receivables debit memo summary objects. Only receivables debit memo summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentCriteriaBase


ReceivablesDebitMemoSummary

Description

A representation of the important details of a receivables debit memo within Microsoft Dynamics GP. A list of receivables debit memo summary objects is returned by the GetReceivablesDebitMemoList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentSummaryBase


ReceivablesDistribution

Description

Defines the properties specific to a general ledger distribution for a receivables document.

Properties

Property | Type | Length | Default | Description
Key | ReceivablesDistributionKey | N/A | N/A | The receivables distribution key object that uniquely identifies a distribution instance.
IsPosted | boolean | N/A | False | Indicates whether the distribution has been posted.

Inherits from

Distribution


ReceivablesDistributionKey

Description

Uniquely identifies a distribution instance for a receivables document.

Properties

Property | Type | Length | Default | Description
ReceivablesDocumentKey | ReceivablesDocumentKey | N/A | N/A | The receivables document key that uniquely identifies the receivables document the distribution applies to.
SequenceNumber | int | N/A | 0 | The sequence number of the distribution instance.

Inherits from

TransactionKey


ReceivablesDocument

Description

A set of common properties for all receivables documents in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ReceivablesDocumentKey | N/A | N/A | The receivables document key that uniquely identifies a receivables document.
Type | ReceivablesDocument Type | N/A | N/A | The receivables document type.
Date | dateTime | N/A | If not provided, defaults to system date. | The date of the receivables document.
DocumentAmount | MoneyAmount | N/A | N/A | The total amount for the receivables document. If the value is not provided it is calculated.
SalesAmount | MoneyAmount | N/A | N/A | The sales amount for the receivables document.
Description | string | 30 | Empty | The description of the receivables document.
CustomerPONumber | string | 20 | Empty | The customer’s purchase order number for the document.
CostAmount | MoneyAmount | N/A | 0 | The cost amount for the receivables document.
TradeDiscountAmount | MoneyAmount | N/A | 0 | The amount of the trade discount for the receivables document.
FreightAmount | MoneyAmount | N/A | 0 | The freight amount for the receivables document.
MiscellaneousAmount | MoneyAmount | N/A | 0 | The amount for miscellaneous charges for the receivables document.
TaxAmount | MoneyAmount | N/A | 0 | The total tax amount for the receivables document. If a value is not provided it is calculated.
ExchangeRate | decimal | N/A | 0 | The exchange rate used for currency conversion.
ExchangeDate | dateTime | N/A | Empty | The exchange date for the exchange rate.
CustomerName | string | 64 | Empty | The name of the customer for the receivables document.
TransactionState | ReceivablesTransactionState | N/A | N/A | A receivables transaction state object that specifies the current state of the receivables document.
SalesTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the sales tax schedule used for the receivables document.
FreightTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the freight tax schedule used for the receivables document.
MiscellaneousTax ScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the miscellaneous tax schedule used for the receivables document
GeneralLedgerPosting Date | dateTime | N/A | If not provided, defaults to the system date. | The general ledger posting date of the document.
PostedDate | dateTime | N/A | N/A | The date the receivables document was posted.
PostedBy | string | N/A | N/A | The user who posted the receivables document.
IsElectronic | boolean | N/A | False | Indicates whether the receivable document supports electronic transfers.
IsIntrastatDocument | boolean | N/A | N/A | Identifies the intrastat state of the receivables document.
IsDirectDebitDocument | boolean | N/A | False | Specifies whether the transaction will be paid using direct debit.
CurrentDocumentAmount | MoneyAmount | N/A | N/A | The amount remaining on the receivables document.
CorporateAccountKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the corporate account associated with the receivables document.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.
InvoicePaidOffDate | dateTime | N/A | N/A | The date the receivables document was paid.
IsDeleted | boolean | N/A | False | Indicates whether the receivables document has been deleted.
IsVoided | boolean | N/A | False | Indicates whether the receivables document has been voided.
VoidDate | dateTime | N/A | N/A | The date the receivables document was voided.
ModifiedDate | dateTime | N/A | Set to the system date. | The date the sales document was last modified. The value is in Coordinated Universal Time (UTC).
ModifiedBy | string | N/A | Set to the user ID of the subscriber who last modified the document. | The user who last modified the receivables document. This property is read-only.
BatchKey | BatchKey | N/A | N/A | A batch key object that uniquely identifies the batch used for the receivables document.
CustomerKey | CustomerKey | N/A | N/A | The customer key that uniquely identifies the customer for the receivables document.
AddressKey | CustomerAddressKey | N/A | N/A | The customer address key object that uniquely identifies the address of the customer.
SalespersonKey | SalespersonKey | N/A | N/A | The sales person key object that uniquely identifies the sales person for the receivables document.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that uniquely identifies the sales territory for the receivables document.
ShippingMethodKey | ShippingMethodKey | N/A | N/A | The shipping method key object that uniquely identifies the shipping method for the receivables document.
TaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the tax schedule used for the receivables document.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the ISO Code used for the receivables document.
Taxes | ArrayOfReceivablesTax | N/A | N/A | A collection of tax details for a receivables document.
Distributions | ArrayOfReceivablesDistribution | N/A | N/A | A collection of distributions for a receivables document.

Inherits from

BusinessObject


ReceivablesDocumentCriteria

Description

Specifies the criteria to use when retrieving a list of receivables document summary objects. Only receivables document summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Type | ListRestrictionOfNullableOfReceivablesDocumentType | A list restriction specifying the receivables document types.

Inherits from

ReceivablesDocumentCriteriaBase


ReceivablesDocumentCriteriaBase

Description

Specifies the base set of criteria to use when retrieving a receivables document object. Only receivables documents that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
TransactionState | ListRestrictionOfNullableOfReceivablesTransactionState | A list restriction object specifying the transaction state of the receivables document.
DocumentId† | LikeRestrictionOfString | A string restriction specifying the ID of the receivables document.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the receivables document.
CustomerId† | LikeRestrictionOfString | A string restriction specifying the customer ID for the receivables document.
BatchId† | LikeRestrictionOfString | A string restriction specifying the batch ID for the receivables document.
SalespersonId | LikeRestrictionOfString | A string restriction specifying the salesperson ID for the receivables document.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the receivables document was last modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
Scope | ReceivablesDocumentScope | A property in criteria used to determine the level of filtering to be used when returning receivables data.

Inherits from

Criteria


ReceivablesDocumentKey

Description

Uniquely identifies a receivables document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The string value that uniquely identifies a receivables document.

Inherits from

TransactionKey


ReceivablesDocumentSummary

Description

A representation of the important details of a receivables document within Microsoft Dynamics GP. A list of receivables document summary objects is returned by the GetReceivablesDocumentList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Type | ReceivablesDocumentType | N/A | N/A | Identifies the type of receivable document.

Inherits from

ReceivablesDocumentSummaryBase


ReceivablesDocumentSummaryBase

Description

A representation of the important details common to all receivables documents in Microsoft Dynamics GP. All properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ReceivablesDocumentKey | N/A | N/A | The receivables document key object that uniquely identifies a receivables document.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer for the receivables document.
CustomerPONumber | string | 20 | Empty | The customer’s purchase order number for the document.
CustomerName | string | 64 | Empty | The name of the customer for the receivables document.
Date | dateTime | N/A | N/A | The date of the receivables document.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the ISO Code used for the receivables document.
BatchKey | BatchKey | N/A | N/A | The batch key object that uniquely identifies the batch used for the receivables document.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that uniquely identifies the salesperson for the receivables document.
TradeDiscountAmount | MoneyAmount | N/A | N/A | The trade discount amount for the receivables document.
FreightAmount | MoneyAmount | N/A | N/A | The total freight amount for the receivables document.
MiscellaneousAmount | MoneyAmount | N/A | N/A | The total miscellaneous amount for the receivables document.
TaxAmount | MoneyAmount | N/A | N/A | The total tax amount for the receivables document.
DocumentAmount | MoneyAmount | N/A | N/A | The sum of the document’s amounts.
ModifiedDate | dateTime | N/A | N/A | The date the receivables document was last modified.
TransactionState | ReceivablesTransactionState | N/A | N/A | Indicates whether the receivables document was retrieved from the work table, open table or the history table.


ReceivablesFinanceCharge

Description

A receivables finance charge document in Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ReceivablesDebitDocument


ReceivablesFinanceChargeCriteria

Description

Specifies the criteria to use when retrieving a list of receivables finance charge summary objects. Only receivables finance charge summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentCriteriaBase


ReceivablesFinanceChargeSummary

Description

A representation of the important details of a receivables finance charge within Microsoft Dynamics GP. A list of receivables finance charge summary objects is returned by the GetReceivablesFinanceChargeList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentSummaryBase


ReceivablesInvoice

Description

A receivables invoice document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CommissionBasedOn | CommissionBasedOn | N/A | N/A | Indicates whether the commission amount is based on the document’s sales amount or the total document amount.
CommissionAmount | MoneyAmount | N/A | 0 | The commission amount the salesperson will be paid.
Commissions | ArrayOfReceivablesCommission | N/A | N/A | A collection of receivables commission objects for the receivables invoice document.

Inherits from

ReceivablesDebitDocument


ReceivablesInvoiceCriteria

Description

Specifies the criteria to use when retrieving a list of receivables invoice summary objects. Only receivables invoice summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentCriteriaBase


ReceivablesInvoiceSummary

Description

A representation of the important details of a receivables invoice within Microsoft Dynamics GP. A list of receivables invoice summary objects is returned by the GetReceivablesInvoiceList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentSummaryBase


ReceivablesPayment

Description

Defines the properties specific to a payment on a receivables document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Cash | CashDetail | N/A | N/A | The details of a cash payment on a receivables document.
Check | CheckDetail | N/A | N/A | The details of a check payment on a receivables document.
PaymentCard | ReceivablesPaymentCardDetail | N/A | N/A | The details of a payment card payment on a receivables document.


ReceivablesPaymentCardDetail

Description

Defines the properties specific to a receivables payment card within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
BankAccountKey | BankAccountKey | N/A | N/A | The back account key object that uniquely identifies the bank account for the receivables payment card.

Inherits from

PaymentCardDetail


ReceivablesReturn

Description

A receivable return document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Payment | ReceivablesPayment | N/A | N/A | The payment details for the receivables return document.
CommissionBasedOn | CommissionBasedOn | N/A | N/A | Indicates whether the commission amount is based on the document’s sales amount or the total document amount.
CommissionAmount | MoneyAmount | N/A | 0 | The salesperson’s commission amount related to the receivables return document.
Commissions | ArrayOfReceivablesCommission | N/A | N/A | A collection of receivables commission objects for the receivables return document.

Inherits from

ReceivablesCreditDocument


ReceivablesReturnCriteria

Description

Specifies the criteria to use when retrieving a list of receivables return summary objects. Only receivables return summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentCriteriaBase


ReceivablesReturnSummary

Description

A representation of the important details of a receivables return within Microsoft Dynamics GP. A list of receivables return summary objects is returned by the GetReceivablesReturnList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentSummaryBase


ReceivablesServiceRepair

Description

A receivables service repair document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CommissionBasedOn | CommissionBasedOn | N/A | N/A | Indicates whether the commission amount is based on the document’s sales amount or the total document amount.
CommissionAmount | MoneyAmount | N/A | 0 | The salesperson’s commission amount related to the receivables service repair document.
Commissions | ArrayOfReceivablesCommission | N/A | N/A | A collection of receivables commission objects for the receivables return document.

Inherits from

ReceivablesDebitDocument


ReceivablesServiceRepairCriteria

Description

Specifies the criteria to use when retrieving a list of receivables service repair summary objects. Only receivables service repair summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentCriteriaBase


ReceivablesServiceRepairSummary

Description

A representation of the important details of a receivables service repair document within Microsoft Dynamics GP. A list of receivables service repair summary objects is returned by the GetReceivablesServiceRepairList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentSummaryBase


ReceivablesTax

Description

Defines the tax information properties for a receivables document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ReceivablesTaxKey | N/A | N/A | The receivables tax key object that uniquely identifies the receivables tax instance.
SalesTaxAmount | MoneyAmount | N/A | N/A | The sales tax amount for a tax detail line.
FreightTaxAmount | MoneyAmount | N/A | 0 | The freight tax amount for a tax detail line.
MiscellaneousTaxAmount | MoneyAmount | N/A | 0 | The miscellaneous tax amount for a tax detail line.
GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key that uniquely identifies the account for the tax detail line.

Inherits from

Tax


ReceivablesTaxKey

Description

Uniquely identifies a receivables tax document within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ReceivablesDocumentKey | ReceivablesDocumentKey | N/A | N/A | The receivables document key object that uniquely identifies the receivable document.
TaxDetailKey | TaxDetailKey | N/A | N/A | The tax detail key object that uniquely identifies the tax detail.

Inherits from

TransactionKey


ReceivablesTerms

Description

Defines the receivables terms specific to a receivables document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DiscountTakenAmount | MoneyAmount | N/A | 0 | The receivables terms discount taken by the customer.
DiscountAvailableTakenAmount | MoneyAmount | N/A | 0 | The payment terms discount amount taken which has been applied to the receivables document.

Inherits from

Terms


ReceivablesWarranty

Description

A receivables warranty document within Microsoft Dynamics GP.

Properties

Inherited from the base class

Inherits from

ReceivablesDocument


ReceivablesWarrantyCriteria

Description

Specifies the criteria to use when retrieving a list of receivables warranty summary objects. Only receivables warranty summary objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentCriteriaBase


ReceivablesWarrantySummary

Description

A representation of the important details of a receivables warranty within Microsoft Dynamics GP. A list of receivables warranty summary objects is returned by the GetReceivablesWarrantyList method. The properties are read-only.

Properties

Inherited from the base class

Inherits from

ReceivablesDocumentSummaryBase


ReferenceKey

Description

An abstract class used for key objects.

Properties

None

Inherits from

GreatPlainsKey


Restriction

Description

Provides the underlying storage for instances of concrete restriction types that derive from it. Restrictions are used when setting up criteria objects.

Properties

None


RestrictionOfNullableOfApplicationStatus

Description

A restriction specifying the allowable values for the application status property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ApplicationStatus | N/A | N/A | The value the application status property must be equal to.
NotEqualValue | ApplicationStatus | N/A | N/A | The value the application status property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfBoolean

Description

A restriction specifying the allowable values for a boolean property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | boolean | N/A | N/A | The value the boolean property must be equal to.
NotEqualValue | boolean | N/A | N/A | The value the boolean property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfCompensationPeriod

Description

A restriction specifying the allowable values for a compensation period property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | CompensationPeriod | N/A | N/A | The value the compensation period property must be equal to.
NotEqualValue | CompensationPeriod | N/A | N/A | The value the compensation period property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfDataModificationAction

Description

A restriction specifying the allowable values for a data modification action property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | DataModificationAction | N/A | N/A | The value the data modification action property must be equal to.
NotEqualValue | DataModificationAction | N/A | N/A | The value the data modification action property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfDateTime

Description

A restriction specifying the allowable values for a date/time property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | dateTime | N/A | N/A | The value the dateTime property must be equal to.
NotEqualValue | dateTime | N/A | N/A | The value the dateTime property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfDecimal

Description

A restriction specifying the allowable values for an Decimal property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | decimal | N/A | N/A | The value the Decimal property must be equal to.
NotEqualValue | decimal | N/A | N/A | The value the Decimal property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfEmployeePayTypes

Description

A restriction specifying the allowable values for an employee pay types property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | EmployeePayTypes | N/A | N/A | The value the employee pay types property must be equal to.
NotEqualValue | EmployeePayTypes | N/A | N/A | The value the employee pay types property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfFeeType

Description

A restriction specifying the allowable values for a fee type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | FeeType | N/A | N/A | The value the fee type property must be equal to.
NotEqualValue | FeeType | N/A | N/A | The value the fee type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfGLAccountSummaryType

Description

A restriction specifying the allowable values for a GL account summary type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | GLAccountSummaryType | N/A | N/A | The value the GL account summary type property must be equal to.
NotEqualValue | GLAccountSummaryType | N/A | N/A | The value the GL account summary type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfGLLedgerType

Description

A restriction specifying the allowable values for a GL Ledger type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | GLLedgerType | N/A | N/A | The value the GL ledger type property must be equal to.
NotEqualValue | GLLedgerType | N/A | N/A | The value the GL ledger type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfGLTransactionState

Description

A restriction specifying the allowable values for a GL transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | GLTransactionState | N/A | N/A | The value the GL transaction state property must be equal to.
NotEqualValue | GLTransactionState | N/A | N/A | The value the GL transaction state property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfHRRequisitionStatus

Description

A restriction specifying the allowable values for an HR requisition status property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | HRRequisitionStatus | N/A | N/A | The value the HR requisition status property must be equal to.
NotEqualValue | HRRequisitionStatus | N/A | N/A | The value the HR requisition status property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfInt32

Description

A restriction specifying the allowable values for an Int32 property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | int | N/A | N/A | The value the Int32 property must be equal to.
NotEqualValue | int | N/A | N/A | The value the Int32 property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfInventoriedItemType

Description

A restriction specifying the allowable values for an inventoried item type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | InventoriedItemType | N/A | N/A | The value the inventoried item type property must be equal to.
NotEqualValue | InventoriedItemType | N/A | N/A | The value the inventoried item type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfInventoryTransactionState

Description

A restriction specifying the allowable values for an inventory transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | InventoryTransactionState | N/A | N/A | The value the inventory transaction state property must be equal to.
NotEqualValue | InventoryTransactionState | N/A | N/A | The value the inventory transaction state property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfItemType

Description

A restriction specifying the allowable values for an item type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ItemType | N/A | N/A | The value the item type property must be equal to.
NotEqualValue | ItemType | N/A | N/A | The value the item type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfManufacturingOrderOutSourced

Description

A restriction specifying the allowable values for a manufacturing order outsourced property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ManufacturingOrderOutSourced | N/A | N/A | The value the manufacturing order outsourced property must be equal to.
NotEqualValue | ManufacturingOrderOutSourced | N/A | N/A | The value the manufacturing order outsourced property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfManufacturingOrderPriority

Description

A restriction specifying the allowable values for a manufacturing order priority property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ManufacturingOrderPriority | N/A | N/A | The value the manufacturing order priority property must be equal to.
NotEqualValue | ManufacturingOrderPriority | N/A | N/A | The value the manufacturing order priority property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfManufacturingOrderStatus

Description

A restriction specifying the allowable values for a manufacturing order status property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ManufacturingOrderStatus | N/A | N/A | The value the manufacturing order status property must be equal to.
NotEqualValue | ManufacturingOrderStatus | N/A | N/A | The value the manufacturing order status property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfPayablesDocumentType

Description

A restriction specifying the allowable values for a payables document type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | PayablesDocumentType | N/A | N/A | The value the payables document type property must be equal to.
NotEqualValue | PayablesDocumentType | N/A | N/A | The value the payables document type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfPayablesTransactionState

Description

A restriction specifying the allowable values for a payables transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | PayablesTransactionState | N/A | N/A | The value the payables transaction state property must be equal to.
NotEqualValue | PayablesTransactionState | N/A | N/A | The value the payables transaction state property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfPlannedOrderReplenishment

Description

A restriction specifying the allowable values for a planned order replenishment property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | PlannedOrderReplenishment | N/A | N/A | The value the planned order replenishment property must be equal to.
NotEqualValue | PlannedOrderReplenishment | N/A | N/A | The value the planned order replenishment property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfProjectTransactionState

Description

A restriction specifying the allowable values for a project transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ProjectTransactionState | N/A | N/A | The value the project transaction state property must be equal to.
NotEqualValue | ProjectTransactionState | N/A | N/A | The value the project transaction state property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfPurchaseOrderStatus

Description

A restriction specifying the allowable values for a purchase order status property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | PurchaseOrderStatus | N/A | N/A | The value the purchase order status property must be equal to.
NotEqualValue | PurchaseOrderStatus | N/A | N/A | The value the purchase order status property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfPurchaseTransactionState

Description

A restriction specifying the allowable values for a purchase transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | PurchaseTransactionState | N/A | N/A | The value the purchase transaction state property must be equal to.
NotEqualValue | PurchaseTransactionState | N/A | N/A | The value the purchase transaction state property must not be equal to.


RestrictionOfNullableOfReceivablesDocumentType

Description

A restriction specifying the allowable values for a receivables document type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ReceivablesDocumentType | N/A | N/A | The value the receivables document type property must be equal to.
NotEqualValue | ReceivablesDocumentType | N/A | N/A | The value the receivables document type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfReceivablesTransactionState

Description

A restriction specifying the allowable values for a receivables transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ReceivablesTransactionState | N/A | N/A | The value the receivables transaction state property must be equal to.
NotEqualValue | ReceivablesTransactionState | N/A | N/A | The value the receivables transaction state property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfReturnMaterialAuthorizationType

Description

A restriction specifying the allowable values for a return material authorization type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ReturnMaterialAuthorizationType | N/A | N/A | The value the return material authorization type property must be equal to.
NotEqualValue | ReturnMaterialAuthorizationType | N/A | N/A | The value the return material authorization type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfSalesCommissionTransactionState

Description

A restriction specifying the allowable values for a sales commission transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | SalesCommissionTransactionState | N/A | N/A | The value the sales commission transaction state property must be equal to.
NotEqualValue | SalesCommissionTransactionState | N/A | N/A | The value the sales commission transaction state property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfSalesDocumentType

Description

A restriction specifying the allowable values for a sales document type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | SalesDocumentType | N/A | N/A | The value the sales document type property must be equal to.
NotEqualValue | SalesDocumentType | N/A | N/A | The value the sales document type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfSalesTransactionState

Description

A restriction specifying the allowable values for a sales transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | SalesTransactionState | N/A | N/A | The value the sales transaction state property must be equal to.
NotEqualValue | SalesTransactionState | N/A | N/A | The value the sales transaction state property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfSalespersonCommissionsDocumentType

Description

A restriction specifying the allowable values for a salesperson commissions document type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | SalespersonCommissionsDocumentType | N/A | N/A | The value the salesperson commissions document type property must be equal to.
NotEqualValue | SalespersonCommissionsDocumentType | N/A | N/A | The value the salesperson commissions document type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfServiceCallType

Description

A restriction specifying the allowable values for a service call type property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ServiceCallType | N/A | N/A | The value the service call type property must be equal to.
NotEqualValue | ServiceCallType | N/A | N/A | The value the service call type property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfServiceTransactionState

Description

A restriction specifying the allowable values for a service transaction state property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | ServiceTransactionState | N/A | N/A | The value the service transaction state property must be equal to.
NotEqualValue | ServiceTransactionState | N/A | N/A | The value the service transaction state property must not be equal to.

Inherits from

Restriction


RestrictionOfNullableOfTaxDetailBase

Description

A restriction specifying the allowable values for the tax detail base property of a tax detail object.

Properties

Property | Type | Length | Default | Description
EqualValue | TaxDetailBase | N/A | N/A | The value the tax detail base property must be equal to.
NotEqualValue | TaxDetailBase | N/A | N/A | The value the tax detail base property must not be equal to.


RestrictionOfNullableOfTaxDetailType

Description

A restriction specifying the allowable values for the tax detail type property of a tax detail object.

Properties

Property | Type | Length | Default | Description
EqualValue | TaxDetailType | N/A | N/A | The value the tax detail type property must be equal to.
NotEqualValue | TaxDetailType | N/A | N/A | The value the tax detail type property must not be equal to.


RestrictionOfString

Description

A restriction specifying the allowable values for a string property of a criteria object.

Properties

Property | Type | Length | Default | Description
EqualValue | string | N/A | N/A | The value the string property must be equal to.
NotEqualValue | string | N/A | N/A | The value the string property must not be equal to.

Inherits from

Restriction


ReturnMaterialAuthorization

Description

Defines the properties for a return material authorization in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
BillOfLading | string | 30 | Empty | Bill of Lading for shipping out to customer.
ClosedDateTime | dateTime | N/A | Empty | The date and time the return material authorization was closed.
CommitDateTime | dateTime | N/A | Empty | The commit date and time for the return material authorization.
IsFromServiceCall | boolean | N/A | N/A | The value True indicates the return material authorization was created from Service Call.
OriginatingDocumentId | string | 30 | Empty | The return reference document number. This would be either the Sales Invoice Number or Service Call Number.
OriginatingDocumentType | ReturnMaterialAuthorizationOriginatingDocumentType | N/A | None | Identifies the return origin.
ReasonCodeKey | ReturnMaterialAuthorizationReasonCodeKey | N/A | Empty | The reason code key object that uniquely identifies a reason code for the return material authorization.
ReturnDateTime | dateTime | N/A | Empty | The date and time the return material authorization was received.
ReturnStatusCodeKey | ReturnMaterialAuthorizationStatusCodeKey | N/A | Default from setup. | The return status code key object that uniquely identifies a return status code for the return material authorization.
ReturnToAddress | ReturnMaterialAuthorizationReturnToAddress | N/A | Empty | The address details for the return to warehouse for the return material authorization.
ReturnTypeKey | ReturnMaterialAuthorizationTypeKey | N/A | N/A | The return type key object that uniquely identifies a return type for the return material authorization.
ReturnWarehouseKey | WarehouseKey | N/A | Default from setup. | The warehouse key object that uniquely identifies a return warehouse for the return material authorization.
ShippingMethodKey | ShippingMethodKey | N/A | Empty | The shipping method key object that uniquely identifies a shipping method for the return material authorization.
ShipToAddress | ReturnMaterialAuthorizationShipToAddress | N/A | N/A | The address details for the ship to address of the return material authorization.
CreatedBy | string | N/A | Set to the user ID who created the document. | The user who created the return material authorization document. This property is read-only.
IsReceived | boolean | N/A | N/A | Indicates whether the return material authorizatiton has been received. This property is read-only.
ReasonCodeDescription | string | 30 | Empty | The description of the reason code.
ReturnStatus | ReturnMaterialAuthorizationReturnStatus | N/A | N/A | Identifies the return status of the return material authorization. This property is read-only.
Type | ReturnMaterialAuthorizationType | N/A | Default from setup. | Identifies the record type of the return material authorization. This property is read-only.
Lines | ArrayOfReturnMaterialAuthorizationLine | N/A | N/A | A collection of return material authorization lines for the return material authorization.
Audits | ArrayOfReturnMaterialAuthorizationAudit | N/A | N/A | A collection of audits for the return material authorization.

Inherits from

ServiceDocument


ReturnMaterialAuthorizationAudit

Description

Defines the audit properties for a return material authorization in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ServiceLineDetailKey | N/A | N/A | The service line detail key object that uniquely identifies a service line detail for the return material authorization. This property is read-only.
LineSequenceNumber | decimal | N/A | N/A | The line sequence number of an return material authorization line when the audit is for an return material authorization line. This property is read-only.
FromReturnStatusCodeKey | ReturnMaterialAuthorizationStatusCodeKey | N/A | N/A | The return status code key object that uniquely identifies the previous return status code for the return material authorization. This property is read-only.
ToReturnStatusCodeKey | ReturnMaterialAuthorizationStatusCodeKey | N/A | N/A | The return status code key object that uniquely identifies the new return status code for the return material authorization. This property is read-only.

Inherits from

ServiceAudit


ReturnMaterialAuthorizationCriteria

Description

Specifies the criteria to use when retrieving return material authorization summary objects. Only return material authorization summary documents that match the specified criteria will be returned.

Properties

Property | Type | Description
Type | ListRestrictionOfNullableOfReturnMaterialAuthorizationType | A list restriction specifying the type of the return material authorization.
ReturnTypeId | LikeRestrictionOfString | A string restriction specifying the return type ID of the return material authorization.
ReturnStatusCodeId | LikeRestrictionOfString | A string restriction specifying the return status code ID of the return material authorization.
Scope | ReturnScope | A property in criteria used to determine the level of filtering to be used when returning return material authorization data.

Inherits from

ServiceDocumentCriteria


ReturnMaterialAuthorizationDistribution

Description

Defines a general ledger distribution for a return material authorization line.

Properties

Property | Type | Length | Default | Description
Key | ServiceLineDetailKey | N/A | N/A | The service line detail key object that uniquely identifies the return material distribution
IsPosted | boolean | N/A | N/A | Indicates whether the distribution has been posted. This property is read-only.
PostedDate | dateTime | N/A | N/A | The date the distribution was posted to general ledger. This property is read-only.

Inherits from

Distribution


ReturnMaterialAuthorizationLine

Description

A return material authorization line for a return material authorization in the Field Service module of Microsoft Dynamics GP. Each return material authorization can have a set of return material authorization lines.

Properties

Property | Type | Length | Default | Description
Key | ServiceLineKey | N/A | N/A | The service line key object that uniquely identifies a service line for the return material authorization.
BillOfLading | string | 30 | Empty | The Bill of Lading for shipping out to the customer.
ClosedDateTime | dateTime | N/A | N/A | The data and time the return material authorization line was closed.
CommitDateTime | dateTime | N/A | N/A | The commit date and time for the return material authorization line.
Replacement | ReturnMaterialAuthorizationLineReplacement | N/A | N/A | The replacement item for the return authorization line.
CustomerName | string | 64 | Empty | The customer’s name.
CustomerPONumber | string | 20 | Empty | The purchase order number of the customer.
EntryDateTime | dateTime | N/A | N/A | The entry date and time of the return material authorization line.
EstimatedArrivalDateTime | dateTime | N/A | N/A | The estimated arrival date and time of return material authorization line.
IsClosed | boolean | N/A | False | The value True indicates that the line is closed.
IsCustomerOwned | boolean | N/A | False | The value True indicates when the return item is owned by the customer.
IsFactorySealed | boolean | N/A | False | The value True indicates the return item is factory sealed.
IsReadyToClose | boolean | N/A | False | The value True indicates the return material authorization line is ready to close.
ItemDescription | string | 100 | Empty | A description of the item on the return material authorization line.
ItemKey | ItemKey | N/A | N/A | The item key object that uniquely identifies the item for the return material authorization line.
Note | string | 8000 | Empty | Note text on the return material authorization line.
OfficeKey | OfficeKey | N/A | N/A | The office key object that uniquely identifies the office that is responsible for the return material authorization line.
OriginatingDocumentId | string | 30 | Empty | The return reference document number. This would be either the Sales Invoice Number or Service Call Number.
PromiseDateTime | dateTime | N/A | N/A | The promise date and time for the return material authorization line.
Quantity | Quantity | N/A | N/A | The quantity of the item being returned on the return material authorization line.
ReasonCodeKey | ReturnMaterialAuthorizationReasonCodeKey | N/A | N/A | The reason code key object that uniquely identifies the reason code for the return material authorization line.
Repair | ReturnMaterialAuthorizationLineRepair | N/A | N/A | Information for the repair of the item for the return authorization line.
ReturnDateTime | dateTime | N/A | N/A | The return date and time of the return material authorization line.
ReturnedItemDescription | string | 100 | Empty | The description of the returned item on the return material authorization line.
ReturnedItemKey | ItemKey | N/A | N/A | The returned item key object that uniquely identifies the returned item for the return material authorization line.
ReturnedPriceLevelKey | PriceLevelKey | N/A | N/A | The returned price level key object that uniquely identifies the price level for the returned item for the return material authorization line.
ReturnedQuantity | Quantity | N/A | N/A | The quantity of the returned item on the return material authorization line.
ReturnedTotalAmount | MoneyAmount | N/A | Set to the value ReturnedQuantity x ReturnedUnitPrice | The extended price of the returned item.
ReturnedUnitCost | MoneyAmount | N/A | The default unit cost will be set based on the valuation method for the inventory item. If this cannot be calculated, the default will be 0. | The unit cost of the returned item.
ReturnedUnitPrice | MoneyAmount | N/A | 0 | The unit price of the returned item.
ReturnedUofM | string | 9 | Empty | The unit of measure of the returned item.
ReturnedWarehouseKey | WarehouseKey | N/A | N/A | The returned warehouse key object that uniquely identifies the warehouse where the returned item was received for the return material authorization line.
ReturnStatusCodeKey | ReturnMaterialAuthorizationStatusCodeKey | N/A | N/A | The return status code key object that uniquely identifies the return status of the return material authorization line.
ReturnToAddress | ReturnMaterialAuthorizationReturnToAddress | N/A | Empty | The address details for the return to warehouse for the return material authorization line.
ReturnTypeKey | ReturnMaterialAuthorizationTypeKey | N/A | N/A | The return type key object that uniquely identifies the return type for the return material authorization line.
ReturnWarehouseKey | WarehouseKey | N/A | N/A | The return warehouse key object that uniquely identifies the warehouse where the item on the return material authorization line will be returned to.
SalesInvoiceLineKey | SalesLineKey | N/A | N/A | The sales invoice line key object that uniquely identifies the sales invoice line for the return material authorization line.
SalesInvoiceComponentSequenceNumber | int | N/A | N/A | The component sequence number for the sales invoice line on which the item on the return material authorization line was originally sold.
EquipmentLineSequenceNumber | int | N/A | N/A | The equipment line sequence number for the service call line on which the item on the return material authorization line was originally sold.
ServiceLineKey | ServiceLineKey | N/A | N/A | The service line key object that uniquely identifies the service line for the return material authorization line.
ShippingMethodKey | ShippingMethodKey | N/A | N/A | The shipping method key object that uniquely identifies the shipping method for the return material authorization line.
ShipToAddress | ReturnMaterialAuthorizationShipToAddress | N/A | N/A | The address details for the ship to address of the return material authorization line.
ShipToAddressKey | AddressKey | N/A | N/A | The ship to address key object that uniquely identifies the ship to address for the return material authorization line.
TotalAmount | MoneyAmount | N/A | Set to the value Quantity x UnitPrice | The extended price of the item being returned.
UnitCost | MoneyAmount | N/A | The default unit cost will be set based on the valuation method for the inventory item. If this cannot be calculated, the default will be 0. | The unit cost of the item being returned.
UnitPrice | MoneyAmount | N/A | 0 | The unit price of the item being returned.
UofM | string | 9 | Empty | The unit of measure of the item being returned.
UserDefined01 | string | 20 | Empty | User defined text.
UserDefined02 | string | 20 | Empty | User defined text.
UserDefined03 | string | 20 | Empty | User defined text.
UserDefined04 | string | 20 | Empty | User defined text.
UserDefined05 | string | 20 | Empty | User defined text.
CreatedBy | string | N/A | Set to the user ID of the subscriber who created the document line. | The user who created the return material authorization document line. This property is read-only.
FrontOfficeIntegrationId | string | N/A | N/A | Front office integration ID. This property is read-only.
IsFromServiceCall | boolean | N/A | N/A | Identifies when the return material authorization line was created from a service call. This property is read-only.
IsReceived | boolean | N/A | N/A | Identifies when the return material authorization line has been received. This property is read-only.
IsTravelerPrinted | boolean | N/A | N/A | Identifies when a traveler has been printed for the return material authorization line.
ReasonCodeDescription | string | N/A | N/A | The description of the reason code. This property is read-only.
Reference | string | N/A | N/A | An additional reference for the return material authorization line. This property is read-only.
ReturnedTotalCost | MoneyAmount | N/A | N/A | The extended cost of the returned item. This property is read-only.
ReturnStatus | ReturnMaterialAuthorizationReturnStatus | N/A | N/A | The return status of the return material authorization line. This property is read-only.
SalesReturnLineKey | SalesLineKey | N/A | N/A | The sales return line key object that uniquely identifies the sales return line for the return material authorization line. This property is read-only.
SalesOrderLineKey | SalesLineKey | N/A | N/A | The sales order line key object that uniquely identifies the sales order line for the return material authorization line. This property is read-only.
TotalCost | MoneyAmount | N/A | N/A | The extended cost of the return material authorization line. This property is read-only.
TransferDocumentLineKey | ServiceLineKey | N/A | N/A | The transfer document line key object that uniquely identifies the transfer document line for the return material authorization line. This property is read-only.
TransferStatus | ReturnMaterialAuthorizationTransferDocumentStatus | N/A | N/A | The status of the transfer document line. This property is read-only.
Distributions | ArrayOfReturnMaterialAuthorizationDistribution | N/A | N/A | A collection of distributions for the return material authorization line.
Lots | ArrayOfReturnMaterialAuthorizationLineLot | N/A | N/A | A collection of lots for the return material authorization line.
Serials | ArrayOfReturnMaterialAuthorizationLineSerial | N/A | N/A | A collection of serial numbers for the return material authorization line.

Inherits from

BusinessObject


ReturnMaterialAuthorizationLineLot

Description

Represents the lot details for a return material authorization lot.

Properties

Property | Type | Length | Default | Description
IsForReplacement | boolean | N/A | N/A | Indicates that the item is for a replacement.
IsMarked | boolean | N/A | N/A | Flag that indicates the lot number is not available for use. This property is read-only.
IsOriginalLot | boolean |  |  | The value True indicates that it is the original IV lot. This property is read-only.

Inherits from

ServiceLot


ReturnMaterialAuthorizationLineRepair

Description

Represents the details for a return material authorization repair.

Properties

Property | Type | Length | Default | Description
Cost | MoneyAmount | N/A | 0 | The repair cost.
FlatRatePrice | MoneyAmount | N/A | 0 | The flat-rate repair price.
InvoiceItemKey | ItemKey | N/A | N/A | The invoice item key object that uniquely identifies the item used to invoice the repair for the return material authorization line.
NotToExceedPrice | MoneyAmount | N/A | 0 | The amount the repair is not to exceed.
Price | MoneyAmount | N/A | 0 | The repair price.
DocumentKey | SalesDocumentKey | N/A | N/A | The document key object that specifies the sales invoice document associated to the RMA line for repair charges. This property is read-only.


ReturnMaterialAuthorizationLineReplacement

Description

Represents the details for a return material authorization replacement.

Properties

Property | Type | Length | Default | Description
ItemKey | ItemKey | N/A | N/A | The item key object that specifies the cross ship or replacement item for the sales order document line associated to the RMA line.
PriceLevelKey | PriceLevelKey | N/A | N/A | The price level key object that specifies the price level for the cross ship or replacement sales order document line associated to the RMA line,
UofM | string | 8 | Empty | The unit of measure for the cross ship or replacement item the sales order document line associated to the RMA line.
WarehouseKey | WarehouseKey | N/A | N/A | The warehouse key object that specifies the cross ship or replacement warehouse for the sales order document line associated to the RMA line.
Quantity | Quantity | N/A | 0 | The quantity for the cross ship or replacement item for the sales order document line associated to the RMA line.
UnitCost | MoneyAmount | N/A | 0 | The unit cost of the cross ship or replacement item for the sales order document line associated to the RMA line.
UnitPrice | MoneyAmount | N/A | 0 | The unit price of the cross ship or replacement item for the sales order document line associated to the RMA line.


ReturnMaterialAuthorizationLineSerial

Description

Represents the lot details for a return material authorization serial.

Properties

Property | Type | Length | Default | Description
IsMarked | boolean | N/A | N/A | Flag that indicates the serial number is not available for use. This property is read-only.
IsOriginalSerial | boolean | N/A | N/A | The value True indicates that it is the original IV serial number. This property is read-only.

Inherits from

ServiceSerial


ReturnMaterialAuthorizationReasonCodeKey

Description

Uniquely identifies a reason code associated with a return material authorization document.

Properties

Property | Type | Length | Default | Description
Id | string | 3 | Empty | A string value that uniquely identifies the reason code.

Inherits from

ReferenceKey


ReturnMaterialAuthorizationReturnToAddress

Description

Represents the return to address details for a return material authorization.

Properties

Property | Type | Length | Default | Description
Name | string | 45 | Empty | The name of the return to address for the document.

Inherits from

ServiceAddress


ReturnMaterialAuthorizationShipToAddress

Description

Represents the ship to address details for a return material authorization.

Properties

Property | Type | Length | Default | Description
ContactPerson | string | 60 | Empty | The name of the contact associated with the ship to address of the return material authorization document.

Inherits from

ServiceAddress


ReturnMaterialAuthorizationStatusCodeKey

Description

Uniquely identifies a status code associated with a return material authorization document.

Properties

Property | Type | Length | Default | Description
Id | string | 3 | Defaulted from setup | A string value that uniquely identifies the return material authorization (RMA) status code.

Inherits from

ReferenceKey


ReturnMaterialAuthorizationSummary

Description

A representation of the important details of a return material authorization document in the Return module for Microsoft Dynamics GP. A list of return material authorization summary objects is returned by the GetReturnMaterialAuthorizationList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ReturnTypeKey | ReturnMaterialAuthorizationTypeKey | N/A | N/A | The return type key object that specifies the type of return material authorization document.
ReturnStatusCodeKey | ReturnMaterialAuthorizationStatusCodeKey | N/A | N/A | The return status code key object that specifies the return status for the return material authorization document.
Type | ReturnMaterialAuthorizationType | N/A | N/A | The type object that specifies the return material authorization (RMA) type for the return material authorization document.

Inherits from

ServiceDocumentSummary


ReturnMaterialAuthorizationTypeKey

Description

Uniquely identifies a type associated with a return material authorization document.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | A string value that uniquely identifies the return material authorization (RMA) type.

Inherits from

ReferenceKey


Review

Description

Information about the review status of the employee.

Properties

Property | Type | Length | Default | Description
LastDate | dateTime | N/A | Empty | The date the employee last received a review.
NextDate | dateTime | N/A | Empty | The date the employee should next receive a review.


RoleKey

Description

Uniquely identifies a security role for the Dynamics GP web service.

Properties

Property | Type | Length | Default | Description
Id | string | N/A | N/A | A string value that uniquely identifies the role.

Inherits from

SecurityKey


RoundingType

Description

Defines rounding for a calculated item price within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Option | RoundHow | N/A | None | Specifies how prices for an item should be rounded.
Policy | RoundTo | N/A | None | Specify the direction in which price calculations will be rounded.
Amount | MoneyAmount | N/A | 0 | The amount that will be used to determine the last number in the price.


SalesAmounts

Description

A sales amounts object in Microsoft Dynamics GP. The CustomerReceivablesSummary object uses sales amounts to provide sales total information for a customer.

Properties

Property | Type | Length | Default | Description
AverageDaysToPay | int | N/A | 0 | The average number of days this customer has taken to pay invoices in full for a specified timeframe.
HighBalance | MoneyAmount | N/A | 0 | The highest balance a customer has had during a specified timeframe.
NumberOfInvoices | int | N/A | 0 | The number of paid invoices for a customer during a specified timeframe.
TermsDiscountsTaken | MoneyAmount | N/A | 0 | The terms discount amount a customer took during a specified timeframe.
TotalCashReceived | MoneyAmount | N/A | 0 | The amount of cash received from a customer during a specified timeframe.
TotalCost | MoneyAmount | N/A | 0 | The cost of sales amount posted for a customer during a specified timeframe.
TotalFinanceCharge | MoneyAmount | N/A | 0 | The total finance charge amount posted for a customer during a specified timeframe.
TotalReturns | MoneyAmount | N/A | 0 | The returns amount posted for a customer during a specified timeframe.
TotalSales | MoneyAmount | N/A | 0 | The sales amount posted for a customer during a specified timeframe.
TotalWaivedFinanceCharge | MoneyAmount | N/A | 0 | The finance charge amount waived for a customer during a specified timeframe.
TotalWriteoffAmount | MoneyAmount | N/A | 0 | The amount written off for a customer during a specified timeframe.


SalesBackorder

Description

A sales backorder document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PaymentAmount | MoneyAmount | N/A | If not specified, set to the sum of the payments for the sales backorder. | The total payment amount for the sales backorder.
DepositAmount | MoneyAmount | N/A | If not specified, set to the sum of the deposit amounts for the sales backorder. | The total deposit amount for the sales backorder.
Lines | ArrayOfSalesBackorderLine | N/A | N/A | A collection of sales backorder lines for the sales backorder.
Payments | ArrayOfSalesPayment | N/A | N/A | A collection of payments for the sales backorder.

Inherits from

SalesDocument


SalesBackorderComponent

Description

A sales backorder component for a sales backorder line in the Sales Order Processing module of Microsoft Dynamics GP. Each sales backorder line can have a set of sales backorder components when the item on the sales backorder line is a kit item.

Properties

Property | Type | Length | Default | Description
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityToInvoice | Quantity | N/A | 0 | The quantity invoiced on the line item.
QuantityToOrder | Quantity | N/A | 0 | The quantity ordered on the line item.

Inherits from

SalesComponent


SalesBackorderCriteria

Description

Specifies the criteria to use when retrieving sales backorder summary objects. Only sales backorder summary documents that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

SalesDocumentCriteriaBase


SalesBackorderLine

Description

A sales backorder line for a sales backorder in the Sales Order Processing module of Microsoft Dynamics GP. Each sales backorder can have a set of sales backorder lines.

Properties

Property | Type | Length | Default | Description
QuantityToOrder | Quantity | N/A | 0 | The quantity ordered on the line item.
QuantityToInvoice | Quantity | N/A | 0 | The quantity invoiced on the line item.
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
Components | ArrayOfSalesBackorderComponent | N/A | N/A | A collection of components for a sales backorder line.

Inherits from

SalesLine


SalesBackorderSummary

Description

A representation of the important details of a sales backorder document in the Sales Order Processing module for Microsoft Dynamics GP. A list of sales backorder summary objects is returned by the GetSalesBackorderList method.

Properties

Inherited from the base class

Inherits from

SalesDocumentSummaryBase


SalesBin

Description

A set of the common properties for all sales bins.

Properties

Property | Type | Length | Default | Description
Bin | string | 15 | Empty | The bin identifier.
QuantityType | QuantityType | N/A | On Hand | The quantity type of the item. For non-return item quantities the quantity type must be on hand.
Quantity | Quantity | N/A | 0 | The quantity for the bin instance.

Inherits from

BusinessObject


SalesCommission

Description

Represents a commission instance in the Sales Order Processing module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | SalesCommissionKey | N/A | N/A | The sales commission key object that uniquely identifies a sales commission.
SalespersonKey | SalespersonKey | N/A | Empty | The salesperson key object that uniquely identifies a salesperson receiving a commission.
SalesTerritoryKey | SalesTerritoryKey | N/A | Empty | The sales territory key object that uniquely identifies a sales territory.
CommissionPercent | Percent | N/A | 0 | The salesperson's commission percentage or the percentage of each sale the salesperson will receive.
CommissionAmount | MoneyAmount | N/A | 0 | The commission amount that the salesperson will be paid. This amount may be a negative number if the extended price and unit price on a sales line are negative amounts.
PercentOfSale | Percent | N/A | 0 | The percentage of the sale that each salesperson's commissions are calculated on. To split a commission, provide the percentage of the sale that should be attributed to each salesperson on the sales document.
CommissionSaleAmount | MoneyAmount | N/A | N/A | The sales amount on which commissions were paid.
NoncommissionedAmount | MoneyAmount | N/A | N/A | The sales amount on which no commissions were paid for the salesperson.
SalesAmount | MoneyAmount | N/A | N/A | The total sales amount.

Inherits from

BusinessObject


SalesCommissionKey

Description

Uniquely identifies a sales commission associated with a sales document.

Properties

Property | Type | Length | Default | Description
SalesDocumentKey | SalesDocumentKey | N/A | N/A | The sales document key object that uniquely identifies a sales document that the commission is associated with.
SequenceNumber | int | N/A | 0 | The sequence number of the commission instance.

Inherits from

TransactionKey


SalesComponent

Description

A set of the common properties for a sales component. Each line of a sales document can have a set of sales components when the item on the sales line is a kit item.

Properties

Property | Type | Length | Default | Description
Key | SalesComponentKey | N/A | N/A | The sales component key object that uniquely identifies a sales component.
Quantity | Quantity | N/A | 0 | The quantity of the sales component.
UnitCost | MoneyAmount | N/A | The default unit cost will be set based on the valuation method for the inventory item. If this cannot be calculated, the default will be 0. | The unit cost of the sales component. For sales order and sales invoice documents, the property can be set only for non-inventory items. For sales return documents, the property can always be set.
ItemDescription | string | 100 | Empty | The description of the sales component.
IsNonInventory | boolean | N/A | False | Specifies whether the item on the sales component is an inventory item. True indicates it is not an inventory item. False indicates it is an inventory item.
UofM | string | 8 | Empty | The unit of measure for the sales component.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove the component line.
ExtendedCost | MoneyAmount | N/A | Set to the value Quantity x UnitCost | The extended cost of the sales component. This property is read only.
CostOfSalesGLAccount Key | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which cost of sales amounts for this sales component will be posted. This property is read-only.
DamagedGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which damaged goods costs for this sales component will be posted. This property is read-only.
InServiceGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account that will be updated when you enter a return document line and return some part of the total item quantity to the In Service quantity type. This property is read-only.
InUseGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account that will be updated when you enter a return document line and return some part of the total item quantity to the In Use quantity type. This property is read-only.
InventoryGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which inventory amounts for this sales component will be posted. This property is read-only.
DiscountGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which discount (markdown) amounts for this sales component will be posted. This property is read-only.
ReturnsGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which return amounts for this sales component will be posted. This property is read-only.
SalesGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which sales amounts for this sales component will be posted. This property is read-only.
WarehouseKey | WarehouseKey | N/A | If not provided, set based on the Default Warehouse Behavior option specified. | The warehouse key object that specifies identifies the warehouse (site) for a sales component.
ItemKey | ItemKey | N/A | N/A | The item key object that uniquely identifies the item on a sales component.

Inherits from

BusinessObject


SalesComponentBin

Description

Represents a bin for a sales component.

Properties

Property | Type | Length | Default | Description
Key | SalesComponentBinKey | N/A | Empty | The sales component bin key that identifies a bin to use for a sales component.

Inherits from

SalesBin


SalesComponentBinKey

Description

Uniquely identifies a sales component bin.

Properties

Property | Type | Length | Default | Description
SalesComponentKey | SalesComponentKey | N/A | Empty | The sales component key object that uniquely identifies a sales component a bin is associated with.
SequenceNumber | int | N/A | 0 | The sequence number of the bin instance. This property is read-only.

Inherits from

TransactionKey


SalesComponentKey

Description

Uniquely identifies a sales component associated with a sales document line.

Properties

Property | Type | Length | Default | Description
SalesLineKey | SalesLineKey | N/A | Empty | The sales line key object that identifies the sales line that the sales component is associated with.
ComponentSequence Number | int | N/A | 0 | The sequence number of the component instance.

Inherits from

TransactionKey


SalesComponentLot

Description

Represents the lot details for a sales component.

Properties

Property | Type | Length | Default | Description
Key | SalesComponentLotKey | N/A | Empty | The sales component lot key object that uniquely identifies the lot details for a sales component.

Inherits from

SalesLot


SalesComponentLotKey

Description

Indentifies a lot number for a sales component.

Properties

Property | Type | Length | Default | Description
SalesComponentKey | SalesComponentKey | N/A | Empty | The sales component key object that uniquely identifies a sales component.
QuantityType | QuantityType | N/A | On Hand | The quantity type of the item. For non-return item quantities the quantity type must be On Hand.
SequenceNumber | int | N/A | N/A | The sequence number of the serial number or lot instance. This property is read-only.

Inherits from

TransactionKey


SalesComponentSerial

Description

Represents the serial number for a sales component.

Properties

Property | Type | Length | Default | Description
Key | SalesComponentSerialKey | N/A | Empty | The sales component serial key object that uniquely identifies the serial number details for a sales component.

Inherits from

SalesSerial


SalesComponentSerialKey

Description

Indentifies a serial number for a sales component.

Properties

Property | Type | Length | Default | Description
SalesComponentKey | SalesComponentKey | N/A | Empty | The sales component key object that uniquely identifies a sales component.
QuantityType | QuantityType | N/A | On Hand | The quantity type of the item. For non-return item quantities the quantity type must be On Hand.
SequenceNumber | int | N/A | N/A | The sequence number of the serial number or lot instance. This property is read-only.

Inherits from

TransactionKey


SalesDistribution

Description

Defines a general ledger distribution for a specific sales document.

Properties

Property | Type | Length | Default | Description
Key | SalesDistributionKey | N/A | Empty | The sales distribution key object that uniquely identifies a distribution instance.
IsPosted | boolean | N/A | N/A | Indicates whether the distribution has been posted. This property is read-only.

Inherits from

Distribution


SalesDistributionKey

Description

Uniquely identifies a sales distribution for a sales document.

Properties

Property | Type | Length | Default | Description
SalesDocumentKey | SalesDocumentKey | N/A | N/A | The sales document key object that uniquely identifies a sales document the distribution applies to.
SequenceNumber | int | N/A | 0 | The sequence number of the distribution instance.

Inherits from

TransactionKey


SalesDocument

Description

A set of the common properties for all sales documents in Microsoft Dynamics GP.

Properties

Property

Type

Length

Default

Description

Key

SalesDocumentKey

N/A

N/A

The sales document key object that uniquely identifies a sales document.

Type

SalesDocumentType

N/A

Automatically set, based on the type of sales document being created.

Identifies the type of sales document. This property is read-only.

Date

dateTime

N/A

If not provided, defaults to system date.

The date of the sales document.

FreightAmount

MoneyAmount

N/A

0

The total freight amount for the sales document.

MiscellaneousAmount

MoneyAmount

N/A

0

The total miscellaneous amount for the sales document.

TaxAmount

MoneyAmount

N/A

If not provided, defaults to the sum of all the tax detail lines.

The total tax amount for the sales document.

TradeDiscount

MoneyPercentChoice

N/A

If not provided, defaults from customer.

The type and amount of the trade discount for the sales document. The trade discount amount can be a money amount or a percent.

DiscountAmount

MoneyAmount

N/A

0

The type and amount of the discount (markdown) for the sales document. The discount (markdown) amount can be a money amount or a percent.

CustomerName

string

64

If not provided, defaults from customer.

The full name of the customer on the sales document.

CustomerPONumber

string

20

Empty

The customer's purchase order number for the sales document.

UPSZone

string

3

Empty

The UPS zone for the ship to address on the sales document.

MasterNumber

int

N/A

0

The master number of the sales document. The value 0 indicates master numbers are not being tracked.

CommissionAmount

MoneyAmount

N/A

0

The total commission amount for the sales document.

ExchangeRate

decimal

N/A

N/A

The exchange rate of the sales document. Set this value only for multi-currency transactions. If there is triangulation and both rates are fixed, this is the originating to Euro fixed rate. Otherwise this is the variable rate.

ExchangeDate

dateTime

N/A

N/A

The exchange date associated with the exchange rate provided.

RequestedShipDate

dateTime

N/A

If not provided, defaults to the date of the sales document.

The date on which the items should be shipped.

Comment

string

500

Empty

The comment text associated with the sales document.

TaxExemptNumber1

string

25

If not provided, defaults from customer.

The tax exempt number for the customer.

TaxExemptNumber2

string

25

If not provided, defaults from customer.

The tax exempt number for the customer.

TaxRegistrationNumber

string

25

If not provided, defaults from customer.

The tax registration number for the customer.

FreightTaxBasis

SalesTaxBasis

N/A

If not provided, set based on the Freight Tax Basis Behavior option specified.

A tax option which will determine whether the freight amount on the sales document is taxable and where the tax schedule defaults from. Taxable will tax freight charges. Nontaxable will not tax freight charges. Based On Customers will use the tax schedule assigned to the customer's shipping address for calculating taxes on freight charges.

MiscellaneousTaxBasis

SalesTaxBasis

N/A

If not provided, set based on the Miscellaneous Tax Basis Behavior option specified.

A tax option which will determine whether the miscellaneous amount on the sales document is taxable and where the tax schedule defaults from. Taxable will tax miscellaneous charges. Nontaxable will not tax miscellaneous charges. Based On Customers will use the tax schedule assigned to the customer's shipping address for calculating taxes on miscellaneous charges.

FreightTaxAmount

MoneyAmount

N/A

The sum of the freight tax detail lines.

The tax amount for the FreightAmount property on the sales document. This property is read-only.

MiscellaneousTaxAmount

MoneyAmount

N/A

The sum of the miscellaneous tax detail lines.

The tax amount for the MiscellaneousAmount property on the sales document. This property is read-only.

Note

string

N/A

0

The note text on a sales document.

TransactionState

SalesTransactionState

N/A

N/A

Indicates whether the sales document was retrieved from the open table or the history table. This property is read-only.

TaxScheduleKey

TaxScheduleKey

N/A

Empty

The tax schedule key object that uniquely identifies the sales tax schedule used for the sales document. This property is read-only.

FreightTaxScheduleKey

TaxScheduleKey

N/A

Empty

The tax schedule key object that uniquely identifies the freight tax schedule used for the sales document.

MiscellaneousTax
ScheduleKey

TaxScheduleKey

N/A

Empty

The tax schedule key object that uniquely identifies the miscellaneous tax schedule used for the sales document.

LineTotalAmount

MoneyAmount

N/A

The sum of all sales document lines.

The subtotal amount of the sales document. This property is read-only.

TotalAmount

MoneyAmount

N/A

The sum of (LineTotalAmount + FreightAmount + MiscellaneousAmount + TaxAmount - TradeDiscountAmount).

The total document amount. This property is read-only.

CreatedBy

string

N/A

Set to the user ID of the subscriber who created the document.

The user who created the sales document. This property is read-only.

CreatedDate

dateTime

N/A

Set to the system date.

The date the sales document was created.

ModifiedDate

dateTime

N/A

Set to the system date.

The date the sales document was last modified. The value is in Coordinated Universal Time (UTC).

LastModifiedDate

dateTime

N/A

Set to the system date.

The date the sales document was last modified. The value is in Coordinated Universal Time (UTC).

CommissionBasedOn

CommissionBasedOn

N/A

Sales

Options which determine how to calculate sales amounts for commission' calculations. When set to Sales, commissions will be calculated as a percentage of the sale amount. When set to DocumentTotal commissions will be calculated as a percentage of the document total, including the sale amount, freight, taxes, and miscellaneous charges. This property is read-only.

CommissionSaleAmount

MoneyAmount

N/A

N/A

The sale amount used to calculate the commission. This property is read only.

ActualShipDate

dateTime

N/A

N/A

The last date a line item on the sales document was shipped. This property is read-only.

FulfillDate

dateTime

N/A

N/A

The last date that a line item quantity on the sales document was fulfilled. This property is read only.

QuoteDate

dateTime

N/A

N/A

The date of the quote. This property is read-only.

AuditTrailCode

string

N/A

N/A

The internally-assigned audit trail code that gets assigned when the transaction is posted. This property is read-only.

IsIntrastatDocument

boolean

N/A

N/A

Identifies the intrastat state of the sales document. This property is read-only.

IsVoided

boolean

N/A

N/A

Indicates whether the document has been voided. True indicates the document has not been voided. False indicates it has not been voided. This property is read-only.

Reference

string

30

Empty

The transaction comments that will be posted in the general ledger for the sales document.

ShipCompleteOnly

boolean

N/A

N/A

Indicates whether the customer is willing to accept partial shipments. True means they are unwilling to accept partial shipments. False means they are willing to accept partial shipments. This property is read-only.

FrontOfficeIntegrationId

string

50

Empty

The ID of the document in the front office application from which the sales document originated. This property is read-only.

IntegrationSource

int

N/A

0

The integration source from with the sales document originated. This property is read-only.

IntegrationId

string

50

Empty

The ID of the document from which the sales document originated. This property is read-only.

InvoiceDate

dateTime

N/A

N/A

The invoice date used when type is not invoice. This property is read-only.

BackorderDate

dateTime

N/A

N/A

The backorder date used when type is not backorder. This property is read-only.

ReturnDate

dateTime

N/A

N/A

The return date used when type is not return. This property is read-only.

OriginalSalesDocument
Key

SalesDocumentKey

OriginalSalesDocument
Type

string

DocumentTypeKey

SalesDocumentTypeKey

N/A

If not provided, is set based on the Default Document Type ID Behavior option specified.

The document type key object that uniquely identifies the document type of the sales document.

ShippingMethodKey

ShippingMethodKey

N/A

If not provided, defaults from customer.

The shipping method key object that uniquely identifies the shipping method to use for the sales document.

WarehouseKey

WarehouseKey

N/A

If not provided set based on the Default Warehouse Behavior option specified.

The warehouse key object that uniquely identifies the default warehouse from which items will be shipped.

CustomerKey

CustomerKey

N/A

N/A

The customer key object that uniquely identifies the customer for the sales document.

SalesTerritoryKey

SalesTerritoryKey

N/A

Empty

The sales territory key object that uniquely identifies the sales territory for the sales document.

SalespersonKey

SalespersonKey

N/A

Empty

The salesperson key object that uniquely identifies the salesperson for the sales document.

BatchKey

BatchKey

N/A

If not provided, will be set according to the Batch creation Behavior option selected.

The batch key object that uniquely identifies the batch to use for the sales document.

BillToAddressKey

CustomerAddressKey

N/A

Empty

The customer address key object that uniquely identifies the bill to address for the sales document.

ShipToAddressKey

CustomerAddressKey

N/A

Empty

The customer address key object that uniquely identifies the ship to address for the sales document.

PaymentTermsKey

PaymentTermsKey

N/A

If not provided, defaults from customer.

The payment terms key object that uniquely identifies the payment terms to use for the sales document.

CurrencyKey

CurrencyKey

N/A

Empty

The currency key object that uniquely identifies the currency for the sales document.

CommentKey

CommentKey

N/A

Empty

The comment key object that uniquely identifies a comment for the sales document.

PriceLevelKey

PriceLevelKey

N/A

Empty

The price level key object that uniquely identifies the default price level for the sales document.

ShipToAddress

BusinessAddress

N/A

If nothing is supplied, the default will be supplied from the customer address key. If any one of the following are supplied, the remaining that are not supplied will default to blank:

BusinessAddress.Name Address.Line1 Address.Line2 Address.Line3 Address.City Address.State Address.PostalCode Address.Country BusinessAddress.ContactPerson Address.Phone1 Address.Phone2 Address.Phone3 Address.Fax

The address details of the ship to address on the sales document.

UserDefined

SalesUserDefined

N/A

N/A

The user defined data on the sales document.

Commissions

ArrayOfSalesCommission

N/A

N/A

The collection of sales commissions associated with the sales document.

ProcessHolds

ArrayOfSalesProcessHold

N/A

N/A

The collection of process holds associated with the dales document.

Taxes

ArrayOfSalesDocument
Tax

N/A

N/A

The collection of sales tax details associated with the sales document.

FreightTaxes

ArrayOfSalesDocument
Tax

N/A

N/A

The collection of freight tax details associated with the sales document.

MiscellaneousTaxes

ArrayOfSalesDocument
Tax

N/A

N/A

The collection of miscellaneous tax details associated with the sales document.

TrackingNumbers

ArrayOfSalesTracking
Number

N/A

N/A

The collection of tracking numbers associated with the sales document.

Inherits from

BusinessObject


SalesDocumentCriteria

Description

Specifies the criteria to use when retrieving a sales document object. Only sales document summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Type† | ListRestrictionOfNullableOfSalesDocumentType | A list restriction specifying the sales document types.

Inherits from

SalesDocumentCriteriaBase


SalesDocumentCriteriaBase

Description

Specifies the base set of criteria to use when retrieving a sales document object. Only sales documents that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
TransactionState | ListRestrictionOfNullableOfSalesTransactionState | A list restriction specifying the transaction state of the sales document.
DocumentId† | LikeRestrictionOfString | A string restriction specifying the ID of the sales document.
Date† | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date of the sales document.
CustomerId† | LikeRestrictionOfString | A string restriction specifying the customer ID for the sales document.
CustomerName | LikeRestrictionOfString | A string restriction specifying the name of the customer for the sales document.
CustomerPONumber† | LikeRestrictionOfString | A string restriction specifying the customer’s purchase order number for the sales document.
BatchId† | LikeRestrictionOfString | A string restriction specifying the batch ID for the sales document.
DocumentTypeId† | LikeRestrictionOfString | A string restriction specifying the document type ID for the sales document.
SalespersonId | LikeRestrictionOfString | A string restriction specifying the salesperson ID for the sales document.
MasterNumber† | BetweenRestrictionOfNullableOfInt32 | An integer restriction specifying the master number for the sales document.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the sales document was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the sales document was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the sales document was created.
Scope | SalesDocumentScope | A property in criteria used to determine the level of filtering to be used when returning sales document data.

Inherits from

Criteria


SalesDocumentKey

Description

Uniquely identifies a sales document object in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 17 | N/A | The unique identifier for the sales document.

Inherits from

TransactionKey


SalesDocumentSummary

Description

A representation of the important details of a sales document in the Sales Order Processing module in Microsoft Dynamics GP. A list of sales document summary objects is returned by the GetSalesDocumentList method.

Properties

Property | Type | Length | Default | Description
Type | SalesDocumentType | N/A | Automatically set, based on the type of sales document. | Identifies the type of sales document. This property is read-only.

Inherits from

SalesDocumentSummaryBase


SalesDocumentSummaryBase

Description

A representation of the important details that are common to all sales documents in the Sales Order Processing module in Microsoft Dynamics GP. All of the properties are read-only.

Properties

Property | Type | Length | Default | Description
DocumentTypeKey | SalesDocumentTypeKey | N/A | N/A | The sales document type key object that uniquely identifies the document type ID of the sales document.
Key | SalesDocumentKey | N/A | N/A | The sales document key object that uniquely identifies a sales document.
MasterNumber | int | N/A | 0 | The master number of the sales document. The value 0 indicates master numbers are not being tracked.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer on the sales document
CustomerPONumber | string | 20 | N/A | The customer's purchase order number for the sales document.
CustomerName | string | 64 | N/A | The full name of the customer on the sales document.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that uniquely identifies the salesperson for the sales document.
Date | dateTime | N/A | N/A | The date of the sales document.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the currency for the sales document.
LineTotalAmount | MoneyAmount | N/A | N/A | The subtotal amount of the sales document.
TradeDiscountAmount | MoneyAmount | N/A | N/A | The trade discount amount on the sales document.
FreightAmount | MoneyAmount | N/A | N/A | The total freight amount for the sales document.
MiscellaneousAmount | MoneyAmount | N/A | N/A | The total miscellaneous amount for the sales document.
TaxAmount | MoneyAmount | N/A | N/A | The total tax amount for the sales document.
TotalAmount | MoneyAmount | N/A | N/A | The total document amount.
CreatedDate | dateTime | N/A | N/A | The date the sales document was created.
ModifiedDate | dateTime | N/A | Set to the system date. | The date the sales document was last modified. The value is in Coordinated Universal Time (UTC).
LastModifiedDate | dateTime | N/A | Set to the system date. | The date the sales document was last modified. The value is in Coordinated Universal Time (UTC).
TransactionState | SalesTransactionState | N/A | N/A | Indicates whether the sales document was retrieved from the open table or the history table.
BatchKey | BatchKey | N/A | N/A | The batch the sales document is included in.


SalesDocumentTax

Description

A set of properties specific to sales tax for sales documents in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | SalesDocumentTaxKey | N/A | Empty | The sales document tax key object that uniquely identifies a sales document tax instance.

Inherits from

SalesTax


SalesDocumentTaxKey

Description

Defines the properties that uniquely identify a sales tax instance for a specific sales document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
SalesDocumentKey | SalesDocumentKey | N/A | N/A | The sales document key object that uniquely identifies a sales document.
SequenceNumber | int | N/A | 0 | The sequence number of the tax detail.
TaxDetailKey | TaxDetailKey | N/A | Empty | The tax detail key object that uniquely identifies a tax detail.

Inherits from

TransactionKey


SalesDocumentTypeKey

Description

Defines the properties that uniquely identify a sales document type for a sales document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Type | SalesDocumentType | N/A | Empty | The sales document type identifies the type of sales document.
Id | string | 15 | Empty | Identifies a sales document type

Inherits from

ReferenceKey


SalesFulfillmentOrder

Description

A sales fulfillment order document in the Sales Order Processing module in Microsoft Dyamics GP.

Properties

Property | Type | Length | Default | Description
PaymentAmount | MoneyAmount | N/A | If not specified, set to the sum of the payments for the sales fulfillment order. | The total payment amount for the sales order.
DepositAmount | MoneyAmount | N/A | If not specified, set to the sum of the deposit amounts for the sales fulfillment order. | The total deposit amount for the sales order.
Terms | SalesTerms | N/A | N/A | The sales terms object that defines the properties for the payment terms of the sales fulfillment order.
GeneralLedgerPosting Date | dateTime | N/A | N/A | Date that will be assigned as the GL Post Date for all transactions in the batch if Posting Setup is set to post by batch date. This property is read-only.
PostedDate | dateTime | N/A | N/A | Used for recurring batches, this value records the last date this transaction was posted. This property is read-only.
PostedBy | string | N/A | N/A | Used for recurring batches, this value records the last user to post this transaction. This property is read-only.
IsDirectDebit | boolean | N/A | false | Specifies whether the transaction will be paid using direct debit.
ShippingProcessStatus | ShippingProcessStatus | N/A | N/A | The shipping status of the sales fulfillment order.
WorkflowPriority | WorkflowPriority | N/A | N/A | The priority of the sales fulfillment order in the workflow. This property is read-only.
Lines | ArrayOfSalesFulfillment OrderLine | N/A | N/A | A collection of sales fulfillment order lines for the sales fulfillment order.
Payments | ArrayOfSalesPayment | N/A | N/A | A collection of payments for the sales fulfillment order.
Distributions | ArrayOfSalesDistribution | N/A | N/A | A collection of sales distributions for the sales fulfillment order.
Workflows | ArrayOfWorkflow | N/A | N/A | The collection of workflow objects for the sales fulfillment order. This property is read-only.

Inherits from

SalesDocument


SalesFulfillmentOrderComponent

Description

A sales fulfillment order component for a sales fulfillment order line in the Sales Order Processing module of Microsoft Dynamics GP. Each sales fulfillment order line can have a set of a sales order components when the item on the sales fulfillment order line is a kit item.

Properties

Property | Type | Length | Default | Description
QuantityToBackorder | Quantity | N/A | 0 | The quantity to be transferred to a back order. This property cannot have a value if Quantity has a negative value.
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityFulfilled | Quantity | N/A | 0 | The quantity fulfilled in the line U of M. This property cannot have a value if Quantity has a negative value.
BillingQuantity | Quantity | N/A | 0 | Holds the total quantity of the component needed to fill the quantity of the kit item entered on the sales fulfillment order line.
QuantityAllocated | Quantity | N/A | N/A | The quantity allocated of the item. This property is read-only.
Serials | ArrayOfSalesComponentSerial | N/A | Empty | A collection of serial details for a sales component with a serial-tracked item.
Lots | ArrayOfSalesComponentLot | N/A | Empty | A collection of lot details for a sales component with a lot-tracked item.
Bins | ArrayOfSalesComponentBin | N/A | Empty | A collection of bin details for a sales component when using the multiple bin functionality.

Inherits from

SalesComponent


SalesFulfillmentOrderCriteria

Description

Specifies the criteria to use when retrieving sales fulfillment order summary objects. Only sales fulfillment order summary documents that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

SalesDocumentCriteriaBase


SalesFulfillmentOrderLine

Description

A sales fulfillment order line for a sales fulfillment order in the Sales Order Processing module of Microsoft Dynamics GP. Each sales fulfillment order can have a set of sales fulfillment order lines.

Properties

Property | Type | Length | Default | Description
QuantityToBackorder | Quantity | N/A | 0 | The quantity to be transferred to a back order. This property cannot have a value if Quantity has a negative value.
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityFulfilled | Quantity | N/A | 0 | The quantity fulfilled in the line U of M. This property cannot have a value if Quantity has a negative value.
BillingQuantity | Quantity | N/A | 0 | Holds the quantity ordered for the item number of the sales fulfillment order line.
ActualShipDate | dateTime | N/A | N/A | The date on which an item quantity was most recently shipped.
QuantityAllocated | Quantity | N/A | 0 | The quantity allocated of the item. This property is read-only.
FulfillDate | dateTime | N/A | N/A | The date the item quantities were fulfilled. If the item is partially fulfilled, the most recent date that fulfillment occurred for an item quantity will be displayed.
Components | ArrayOfSalesFulfillmentOrderComponent | N/A | Empty | A collection of components for a sales fulfillment order line.
Serials | ArrayOfSalesLineSerial | N/A | Empty | A collection of serial details for a sales order line with a serial-tracked item.
Lots | ArrayOfSalesLineLot | N/A | Empty | A collection of lot details for a sales order line with a lot-tracked item.
Bins | ArrayOfSalesLineBin | N/A | Empty | A collection of bin details for a sales order line when using the multiple bin functionality.

Inherits from

SalesLine


SalesFulfillmentOrderSummary

Description

A representation of the important details of a sales fulfillment order document in the Sales Order Processing module for Microsoft Dynamics GP. A list of sales fulfillment order summary objects is returned by the GetSalesFulfillmentOrderList method.

Properties

Inherited from the base class

Inherits from

SalesDocumentSummaryBase


SalesHistoryOptions

Description

Specifies how sales history information will be tracked for a salesperson or sales territory.

Properties

Property | Type | Length | Default | Description
KeepCalendar | boolean | N/A | True | The value true specifies history will be kept for the calendar year.
KeepPeriod | boolean | N/A | True | The value true specifies history will be kept for the fiscal year (the individual fiscal periods).

Inherits from

BusinessObject


SalesInvoice

Description

A sales invoice document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PaymentAmount | MoneyAmount | N/A | In not specified, set to the sum of the payments in the sales invoice. | The total payment amount for the sales invoice.
DepositAmount | MoneyAmount | N/A | 0 | The total deposit amount for the sales invoice.
Terms | SalesTerms | N/A | N/A | The sales terms object that defines the properties for the payment terms of the sales invoice.
GeneralLedgerPosting Date | dateTime | N/A | N/A | Date that will be assigned as the GL Post Date for all transactions in the batch if Posting Setup is set to post by batch date. This property is read-only.
PostedDate | dateTime | N/A | N/A | Used for recurring batches, this value records the last date this transaction was posted. This property is read-only.
PostedBy | string | N/A | N/A | Used for recurring batches, this value records the last user to post this transaction. This property is read-only.
IsDirectDebit | boolean | N/A | False | Specifies whether the transaction will be paid using direct debit.
WorkflowPriority | WorkflowPriority | N/A | N/A | The priority of the sales invoice in the workflow. This property is read-only.
Lines | ArrayOfSalesInvoiceLine | N/A | N/A | The collection of line items for the sales invoice.
Payments | ArrayOfSalesPayment | N/A | N/A | A collection of payments for the sales invoice.
Distributions | ArrayOfSalesDistribution | N/A | N/A | A collection of distributions for the sales invoice.
Workflows | ArrayOfWorkflow | N/A | N/A | The collection of workflow objects for the sales invoice. This property is read-only.

Inherits from

SalesDocument


SalesInvoiceChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of sales invoice objects that have changed. Only changed sales invoice key objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

BaseChangedSalesDocumentKeyCriteria


SalesInvoiceComponent

Description

A sales invoice component for a sales invoice line in the Sales Order Processing module of Microsoft Dynamics GP. Each sales invoice line can have a set of sales invoice components when the item on the sales invoice line is a kit item.

Properties

Property | Type | Length | Default | Description
QuantityToBackorder | Quantity | N/A | 0 | The quantity to be transferred to a back order. This property cannot have a value if Quantity has a negative value.
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityFulfilled | Quantity | N/A | 0 | The quantity fulfilled in the line U of M. This property cannot have a value if Quantity has a negative value.
BillingQuantity | Quantity | N/A | 0 | The quantity ordered for the item on the component line.
QuantityAllocated | Quantity | N/A | N/A | The quantity allocated for the item. This property is read-only.
Serials | ArrayOfSalesComponentSerial | N/A | Empty | A collection of serial details for a sales component with a serial-tracked item.
Lots | ArrayOfSalesComponentLot | N/A | Empty | A collection of lot details for a sales component with a lot-tracked item.
Bins | ArrayOfSalesComponentBin | N/A | Empty | A collection of bin details for a sales component when using the multiple bin functionality.

Inherits from

SalesComponent


SalesInvoiceCriteria

Description

Specifies the criteria to use when retrieving sales invoice summary objects. Only sales invoice summary documents that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

SalesDocumentCriteriaBase


SalesInvoiceLine

Description

A sales invoice line for a sales invoice in the Sales Order Processing module of Microsoft Dynamics GP. Each sales invoice can have a set of sales invoice lines.

Properties

Property | Type | Length | Default | Description
QuantityToBackorder | Quantity | N/A | 0 | The quantity to be transferred to a back order. This property cannot have a value if Quantity has a negative value.
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityFulfilled | Quantity | N/A | 0 | The quantity fulfilled in the line U of M. This property cannot have a value if Quantity has a negative value.
BillingQuantity | Quantity | N/A | 0 | The quantity ordered for the item on the component line.
ActualShipDate | dateTime | N/A | N/A | The date on which an item quantity was most recently shipped.
QuantityAllocated | Quantity | N/A | N/A | The quantity allocated of the item. This property is read-only.
FulfillDate | dateTime | N/A | N/A | The date the item quantities were fulfilled. If the item is partially fulfilled, the most recent date that fulfillment occurred for an item quantity will be displayed.
Components | ArrayOfSalesComponent | N/A | N/A | A collection of components for a sales invoice line.
Serials | ArrayOfSalesLineSerial | N/A | N/A | A collection of serial details for a sales invoice line with a serial-tracked item.
Lots | ArrayOfSalesLineLot | N/A | N/A | A collection of lot details for a sales invoice line with a lot-tracked item.
Bins | ArrayOfSalesLineBin | N/A | N/A | A collection of bin details for a sales invoice line when using the multiple bin functionality.

Inherits from

SalesLine


SalesInvoiceSummary

Description

A representation of the important details of a sales invoice document in the Sales Order Proccessing module for Microsoft Dynamics GP. A list of sales invoice summary objects is returned by the GetSalesInvoiceList method.

Properties

Inherited from the base class

Inherits from

SalesDocumentSummaryBase


SalesItem

Description

Defines a sales item in the Inventory module for Microsoft Dynamics GP. A sales item has inventory and may be sold as an individual item or as a component of a kit.

Properties

Property | Type | Length | Default | Description
ValuationMethod | ValuationMethod | N/A | FIFO Perpetual | Used to determine the cost of this item.
TrackingOption | TrackingOption | N/A | Defaults from Item Class if provided. Otherwise will be set to None. | Identifies whether the item should be tracked by serial numbers or lot numbers.
LotCategoryKey | LotCategoryKey | N/A | Defaults from Item Class if provided. Otherwise will be set to empty. | For lot tracked items, this identifies the Lot Category which is used to track additional information for the lot.
MinimumShelfLifeDays1 | short | N/A | 0 | For lot tracked items, the first of two properties that can be used to specify the number of days which should be used to determine if the item is still available for sale.
MinimumShelfLifeDays2 | short | N/A | 0 | For lot tracked items, the second of two properties that can be used to specify the number of days which should be used to determine if the item is still available for sale.
RevalueInventory | boolean | N/A | Defaults from Item Class if provided. Otherwise will be set to False. | Specifies whether the item should be revalued when cost variances exist in purchasing.
TolerancePercentage | Percent | N/A | Defaults from Item Class if provided. Otherwise will be set to 0. | Identifies the percentage difference between the purchase receipt and the matched invoice that must occur to have item revalued.
Quantities | ArrayOfSalesItemWarehouse | N/A | N/A | A collection of item warehouse quantities.

Inherits from

InventoriedItem


SalesItemWarehouse

Description

Defines the item quantity data for a warehouse within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ItemWarehouseKey | N/A | N/A | The sales item warehouse key object that uniquely identifies a sales item warehouse.
InUseQuantity | Quantity | N/A | N/A | The current quantity of this item with a quantity type of In Use.
InServiceQuantity | Quantity | N/A | N/A | The current quantity of this item with a quantity type of In Service.
ReturnedQuantity | Quantity | N/A | N/A | The quantity of the selected item with an item type of Returned.
DamagedQuantity | Quantity | N/A | N/A | The current quantity of this item with a quantity type of Damaged.
OnHandQuantity | Quantity | N/A | N/A | The quantity of the selected item with a quantity type of On Hand.
AllocatedQuantity | Quantity | N/A | N/A | The current quantity of this item with a quantity type of Allocated.
OnOrderQuantity | Quantity | N/A | N/A | The quantity of this item entered on standard purchase orders and blanket purchase orders.
BackOrderedQuantity | Quantity | N/A | N/A | The quantity of this item for which a back order has been placed.
Bins | ArrayOfSalesItemWarehouseBin | N/A | N/A | A collection of bins for the sales item warehouse.

Inherits from

BusinessObject


SalesItemWarehouseBin

Description

Defines the item quantity data for a warehouse within Microsoft Dynamics GP. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ItemWarehouseBinKey | N/A | N/A | The sales item warehouse key object that uniquely identifies a sales item warehouse.
OnHandQuantity | Quantity | N/A | N/A | The quantity of the selected item with a quantity type of On Hand.
AllocatedQuantity | Quantity | N/A | N/A | The current quantity of this item with a quantity type of Allocated.
ReturnedQuantity | Quantity | N/A | N/A | The quantity of the selected item with an item type of Returned.
InUseQuantity | Quantity | N/A | N/A | The current quantity of this item with a quantity type of In Use.
InServiceQuantity | Quantity | N/A | N/A | The current quantity of this item with a quantity type of In Service.
DamagedQuantity | Quantity | N/A | N/A | The current quantity of this item with a quantity type of Damaged.

Inherits from

BusinessObject


SalesLine

Description

Defines the common properties for all sales document lines in the Sales Order Processing module of Microsoft Dynamics GP.

Properties

Property

Type

Length

Default

Description

Key

SalesLineKey

N/A

N/A

The sales line key object that uniquely identifies a sales line.

UnitPrice

MoneyAmount

N/A

0

The unit price of the item.

TotalAmount

MoneyAmount

N/A

If not provided, set to UnitPrice x Quantity.

The extended price for the sales line.

Quantity

Quantity

N/A

0

The quantity for the sales line.

Discount

MoneyPercentChoice

N/A

Default from sales document, otherwise 0.

The type and amount of the markdown for the sales line. The markdown amount can be a money amount or a percent.

UnitCost

MoneyAmount

N/A

Default from item if a return document line, otherwise 0.

The unit cost of a non-inventory item or an item on a return document line.

ItemDescription

string

100

Empty

The description of the item on the sales line.

IsNonInventory

boolean

N/A

False

Indicates whether the item on the sales line is not an inventory item.True indicates it is non-inventory item. False indicates it is an inventory item.

IsDropShip

boolean

N/A

False

Indicates whether the item is a drop ship item. True indicates it is a drop ship item. False indicates it is not. The drop ship status must be set to False for a negative quantity invoice item.

RequestedShipDate

dateTime

N/A

If not provided, defaults to the document date.

The date on which the item should be shipped.

Comment

string

N/A

Empty

A comment on the sales line.

UofM

string

8

Empty

The unit of measure for the sales line.

DeleteOnUpdate

boolean

N/A

False

Set to True when calling the Update operation to remove the sales line.

ExtendedCost

MoneyAmount

N/A

Set to Quantity x UnitCost

The extended cost of the sales line. This property is read-only.

ItemTaxScheduleKey

TaxScheduleKey

N/A

N/A

The tax schedule key object that uniquely identifies the item tax schedule for a sales line. This property is read-only.

TaxBasis

SalesTaxBasis

N/A

N/A

A tax option which will determine whether the item on the sales line is taxable. If it is taxable, it also specifies which tax schedule will be used. If the tax option for the item is Taxable, the tax schedule for the line item is compared to the item tax schedule. Taxes will be calculated for tax details found in both schedules. If the tax option for the item is Nontaxable, no tax is calculated for that item. If the tax option for the item is Based on Customer, the line item's tax schedule is used for calculating taxes for item. This property is read-only.

TaxAmount

MoneyAmount

N/A

Sum of the tax details for the line.

The tax amount for the sales line. This property is read-only.

TaxScheduleKey

TaxScheduleKey

N/A

N/A

The tax schedule key object that uniquely identifies the sales tax schedule for a sales line. This property is read-only.

CostOfSalesGLAccount
Key

GLAccountNumberKey

N/A

N/A

The GL account number key object that specifies the account to which cost of sales amounts for this sales line will be posted. This property is read-only.

DamagedGLAccountKey

GLAccountNumberKey

N/A

N/A

The GL account number key object that specifies the account to which damaged goods costs for this sales line will be posted. This property is read-only.

InServiceGLAccountKey

GLAccountNumberKey

N/A

N/A

The GL account number key object that specifies the account that will be updated when you enter a return document line and return some part of the total item quantity to the In Service quantity type. This property is read-only.

InUseGLAccountKey

GLAccountNumberKey

N/A

N/A

The GL account number key object that specifies the account that will be updated when you enter a return document line and return some part of the total item quantity to the In Use quantity type. This property is read-only.

InventoryGLAccountKey

GLAccountNumberKey

N/A

N/A

The GL account number key object that specifies the account to which inventory amounts for this sales line will be posted. This property is read-only.

DiscountGLAccountKey

GLAccountNumberKey

N/A

N/A

The GL account number key object that specifies the account to which discount (markdown) amounts for this sales line will be posted. This property is read-only.

ReturnsGLAccountKey

GLAccountNumberKey

N/A

N/A

The GL account number key object that specifies the account to which return amounts for this sales line will be posted. This property is read-only.

SalesGLAccountKey

GLAccountNumberKey

N/A

N/A

The GL account number key object that specifies the account to which sales amounts for this sales line will be posted. This property is read-only.

FrontOfficeIntegrationId

string

IntegrationSource

int

IntegrationId

string

WarehouseKey

WarehouseKey

N/A

If not provided, set based on the Default Warehouse Behavior option specified.

The warehouse key object that uniquely identifies the warehouse for a sales line.

ItemKey

ItemKey

N/A

N/A

The item key object that uniquely identifies the item for a sales line.

ShippingMethodKey

ShippingMethodKey

N/A

If not provided, defaults from Sales Document.

The shipping method key object that uniquely identifies the shipping method for a sales line.

SalesTerritoryKey

SalesTerritoryKey

N/A

N/A

The sales territory key object that uniquely identifies the sales territory for a sales line.

SalespersonKey

SalespersonKey

N/A

If not provided, defaults from ship to address on the sales line.

The salesperson key object that uniquely identifies the salesperson for a sales line.

CommentKey

CommentKey

N/A

N/A

The comment key object that uniquely identifies the comment for a sales line.

PriceLevelKey

PriceLevelKey

N/A

N/A

The price level key object that uniquely identifies the price level for a sales line.

ShipToAddressKey

CustomerAddressKey

N/A

N/A

The customer address key object that uniquely identifies the ship to address for a sales line.

ShipToAddress

BusinessAddress

N/A

If nothing is supplied, the default will be supplied from the “ship to” address on the SalesDocument. If any one of the following are supplied, the remaining that are not supplied will default to blank:

BusinessAddress.Name Address.Line1 Address.Line2 Address.Line3 Address.City Address.State Address.PostalCode Address.Country BusinessAddress.ContactPerson Address.Phone1 Address.Phone2 Address.Phone3 Address.Fax

The address details of the ship to address for the sales line.

Taxes

ArrayOfSalesLineTax

N/A

N/A

A collection a tax details for a sales line.

Inherits from

BusinessObject


SalesLineBin

Description

Represents a bin for a sales line.

Properties

Property | Type | Length | Default | Description
Key | SalesLineBinKey | N/A | Empty | The sales line bin key that identifies a bin to use for a sales line.

Inherits from

SalesBin


SalesLineBinKey

Description

Uniquely identifies a sales line bin.

Properties

Property | Type | Length | Default | Description
SalesLineKey | SalesLineKey | N/A | Empty | The sales line key object that uniquely identifies a sales line.
SequenceNumber | int | N/A | 0 | The sequence number of the bin instance. This property is read-only.

Inherits from

TransactionKey


SalesLineKey

Description

Uniquely identifies a line instance for a sales document in the Sales Order Processing module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
SalesDocumentKey | SalesDocumentKey | N/A | N/A | The sales document key object that uniquely identifies a sales document.
LineSequenceNumber | int | N/A | 0 | The line item sequence number.

Inherits from

TransactionKey


SalesLineLot

Description

Represents the lot details for a sales line.

Properties

Property | Type | Length | Default | Description
Key | SalesLineLotKey | N/A | N/A | The sales line lot key object that uniquely identifies the lot details for a sales line.

Inherits from

SalesLot


SalesLineLotKey

Description

Indentifies a lot number for a sales line.

Properties

Property | Type | Length | Default | Description
SalesLineKey | SalesLineKey | N/A | N/A | The sales line key object that uniquely identifies a sales line.
QuantityType | QuantityType | N/A | On Hand | The quantity type of the item. The options are: On Hand, Returned, In Use, In Service, or Damaged. For non-return item quantities the quantity type must be On Hand.
SequenceNumber | int | N/A | N/A | The sequence number for the serial lot instance. This property is read-only.

Inherits from

TransactionKey


SalesLineSerial

Description

Represents the serial number for a sales line.

Properties

Property | Type | Length | Default | Description
Key | SalesLineSerialKey | N/A | N/A | The sales line serial key object that uniquely identifies the serial number details for a sales line.

Inherits from

SalesSerial


SalesLineSerialKey

Description

Indentifies a serial number for a sales line.

Properties

Property | Type | Length | Default | Description
SalesLineKey | SalesLineKey | N/A | N/A | The sales line key object that uniquely identifies a sales line.
QuantityType | QuantityType | N/A | On Hand | The quantity type of the item. The options are: On Hand, Returned, In Use, In Service, or Damaged. For non-return item quantities the quantity type must be On Hand.
SequenceNumber | int | N/A | N/A | The sequence number for the serial lot instance. This property is read-only.

Inherits from

TransactionKey


SalesLineTax

Description

Represents tax information for a sales line.

Properties

Property | Type | Length | Default | Description
Key | SalesLineTaxKey | N/A | N/A | The sales line tax key object that uniquely identifies a sales tax line.

Inherits from

SalesTax


SalesLineTaxKey

Description

Uniquely identifies a sales line tax item for a sales line.

Properties

Property | Type | Length | Default | Description
SalesLineKey | SalesLineKey | N/A | N/A | The sales line key object that uniquely identifies a sales line.
TaxDetailKey | TaxDetailKey | N/A | Empty | The tax detail key object that uniquely identifies a tax detail.

Inherits from

TransactionKey


SalesLot

Description

A set of common properties that are specific to lots for lot-tracked items.

Properties

Property | Type | Length | Default | Description
LotNumber | string | 20 | Empty | The lot number.
Quantity | Quantity | N/A | 0 | The quantity of items selected from the lot number specified.
ManufacturedDate | dateTime | N/A | Empty | The date the item was made.
ExpirationDate | dateTime | N/A | Empty | The date the item will expire.
UserDate | dateTime | N/A | Empty | The date for the item.

Inherits from

SalesSerialLot


SalesOrder

Description

A sales order document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PaymentAmount | MoneyAmount | N/A | In not specified, set to the sum of the payments for the sales order. | The total payment amount for the sales order.
DepositAmount | MoneyAmount | N/A | In not specified, set to the sum of the deposit amounts for the sales order. | The total deposit amount for the sales order.
ShippingProcessStatus | ShippingProcessStatus | N/A | N/A | The shipping status of the sales order.
IsRepeating | boolean | N/A | N/A | Identifies repeating quotes and orders. This property is read-only.
DocumentFrequency | Frequency | N/A | N/A | The length of time before the document repeats itself.
TimesToRepeat | int | N/A | N/A | Number of times the document will repeat. This property is read-only.
DaysToIncrement | int | N/A | N/A | When the document frequency is miscellaneous this is the number of days that the document date should be incremented by each time the document is repeated. This property is read-only.
WorkflowPriority | WorkflowPriority | N/A | N/A | The priority of the sales order in the workflow. This property is read-only.
Lines | ArrayOfSalesOrderLine | N/A | N/A | A collection of sales order lines for the sales order.
Payments | ArrayOfSalesPayment | N/A | N/A | A collection of payments for the sales order.
Workflows | ArrayOfWorkflow | N/A | N/A | The collection of workflow objects for the sales order. This property is read-only.

Inherits from

SalesDocument


SalesOrderChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of sales order objects that have changed. Only changed sales order key objects that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

BaseChangedSalesDocumentKeyCriteria


SalesOrderComponent

Description

A sales order component for a sales order line in the Sales Order Processing module of Microsoft Dynamics GP. Each sales order line can have a set of sales order components when the item on the sales order line is a kit item.

Properties

Property | Type | Length | Default | Description
QuantityToBackorder | Quantity | N/A | 0 | The quantity to be transferred to a back order. This property cannot have a value if Quantity has a negative value.
QuantityToInvoice | Quantity | N/A | 0 | The quantity ordered for the item on the component.
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityFulfilled | Quantity | N/A | 0 | The quantity fulfilled in the line U of M. This property cannot have a value if Quantity has a negative value.
QuantityAllocated | Quantity | N/A | N/A | The quantity allocated of the item. This property is read-only.
Serials | ArrayOfSalesComponentSerial | N/A | Empty | A collection of serial details for a sales component with a serial-tracked item.
Lots | ArrayOfSalesComponentLot | N/A | Empty | A collection of lot details for a sales component with a lot-tracked item.
Bins | ArrayOfSalesComponentBin | N/A | Empty | A collection of bin details for a sales component when using the multiple bin functionality.

Inherits from

SalesComponent


SalesOrderCriteria

Description

Specifies the criteria to use when retrieving sales order summary objects. Only sales order summary documents that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

SalesDocumentCriteriaBase


SalesOrderLine

Description

A sales order line for a sales order in the Sales Order Processing module of Microsoft Dynamics GP. Each sales order can have a set of sales order lines.

Properties

Property | Type | Length | Default | Description
QuantityToBackorder | Quantity | N/A | 0 | The quantity to be transferred to a back order. This property cannot have a value if Quantity has a negative value.
QuantityToInvoice | Quantity | N/A | 0 | The quantity ordered for the item on the document line.
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityFulfilled | Quantity | N/A | 0 | The quantity fulfilled in the line U of M. This property cannot have a value if Quantity has a negative value.
QuantityAllocated | Quantity | N/A | N/A | The quantity allocated of the item. This property is read only.
FulfillDate | dateTime | N/A | N/A | The date the item quantities were fulfilled. If the item is partially fulfilled, the most recent date that fulfillment occurred for an item quantity will be displayed.
ActualShipDate | dateTime | N/A | N/A | The date on which an item quantity was most recently shipped.
Components | ArrayOfSalesComponent | N/A | N/A | A collection of components for a sales order line.
Serials | ArrayOfSalesLineSerial | N/A | N/A | A collection of serial details for a sales order line with a serial-tracked item.
Lots | ArrayOfSalesLineLot | N/A | N/A | A collection of lot details for a sales order line with a lot-tracked item.
Bins | ArrayOfSalesLineBin | N/A | N/A | A collection of bin details for a sales order line when using the multiple bin functionality.

Inherits from

SalesLine


SalesOrderSummary

Description

A representation of the important details of a sales order document in the Sales Order Proccessing module for Microsoft Dynamics GP. A list of sales order summary objects is returned by the GetSalesOrderList method.

Properties

Inherited from the base class

Inherits from

SalesDocumentSummaryBase


SalesPayment

Description

Defines payment information for a specific sales document.

Properties

Property | Type | Length | Default | Description
Key | SalesPaymentKey | N/A | N/A | The sales payment key object that uniquely identifies a sales payment.
IsProcessElectronically | boolean | N/A | False | Indicates whether the payment should be processed using Payment Services available through Dynamics Online.
Date | dateTime | N/A | If not provided, set to the system date. | The date of the payment.
PaymentAmount | MoneyAmount | N/A | 0 | The amount of the payment.
BankAccountKey | BankAccountKey | N/A | Empty | The bank account key object that specifies the ID of the checkbook used for the payment.
PaymentCardTypeKey | PaymentCardTypeKey | N/A | Empty | The payment card type key object that uniquely identifies a payment card type.
CheckNumber | string | 20 | Empty | The number of the check. Required if payment type is Check Deposit or Check Payment.
PaymentCardNumber | string | 20 | Empty | The number of the payment card. Required if payment type is Payment Card Deposit or Payment Card payment.
AuthorizationCode | string | 15 | Empty | The authorization code provided by the issuer of the payment card. Only used if payment type is Payment Card Deposit or Payment Card Payment.
ExpirationDate | dateTime | N/A | Empty | The expiration date of the payment card. Required if payment type is Payment Card Deposit or Payment Card Payment.
Type | SalesPaymentType | N/A | Check Deposit | Indicates the type of payment.
Number | string | 20 | Empty | The payment or cash receipt number.
DeleteOnUpdate | boolean | N/A | N/A | Set to True when calling the Update operation to removed the payment instance.
AuditTrailCode | string | N/A | N/A | The internally-assigned audit trail code that is saved at the time the transaction is posted. This property is read-only.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that specifies the ID of the currency used for the payment. This property is read-only.

Inherits from

BusinessObject


SalesPaymentKey

Description

Uniquely identifies a sales payment for a sales document.

Properties

Property | Type | Length | Default | Description
SalesDocumentKey | SalesDocumentKey | N/A | N/A | The sales document key object that uniquely identifies a sales document the payment applies to.
SequenceNumber | int | N/A | 0 | The sequence number for the payment instance.

Inherits from

TransactionKey


Salesperson

Description

A salesperson in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | SalespersonKey | N/A | N/A | The customer key object that uniquely identifies the salesperson.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that specifies the territory for the salesperson.
EmployeeKey | EmployeeKey | N/A | Empty | The employee key object that specifies the employee corresponding to the salesperson.
VendorKey | VendorKey | N/A | Empty | The vendor key object that specifies the vendor the salesperson is associated with, such as when the salesperson is an independent contractor and not an employee.
FirstName | string | 15 | Empty | The salesperson’s first name.
MiddleName | string | 15 | Empty | The saleperson’s middle name.
LastName | string | 20 | Empty | The saleperson’s last name.
Address | Address | N/A | Empty | The set of address information for the salesperson.
IsActive | boolean | N/A | True | A boolean that specifies whether the salesperson is active. The value true indicates they are, while false indicates they are not.
CommissionPercent | Percent | N/A | 0 | The commission amount for the salesperson.
CommissionBasedOn | CommissionBasedOn | N/A | Sales | How the salesperson’s commissions will be calculated.
HistoryOptions | SalesHistoryOptions | N/A | N/A | Specifies how sales history information will be tracked for the salesperson.
SalesSummary | SalesSummary | N/A | N/A | Summarizes sales information for the salesperson.
SalesHistory | ArrayOfSalespersonHistory | N/A | N/A | The collection of historical sales information available for the salesperson.
CreatedDate | dateTime | N/A | The current system date | The date the salesperson was created.
ModifiedDate | dateTime | N/A | The current system date | The date the saleperson was last modified. The value is in Coordinated Universal Time (UTC).
InternetAddresses | InternetAddresses | N/A | Empty | The set of Internet address information for the salesperson.

Inherits from

BusinessObject


SalespersonChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of salesperson objects that have changed. Only changed salesperson key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
SalespersonKey | BetweenRestrictionOfString | A string restriction specifying the salesperson.

Inherits from

BaseChangedKeyCriteria


SalespersonCommissions

Description

A salesperson commissions object in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | SalespersonCommissionsKey | N/A | N/A | The salesperson commission key that uniquely identifies the sales person commission.
Noncommissioned Amount | MoneyAmount | N/A | N/A | The sales amount on which no commissions were paid to the salesperson.
CommissionPercent | Percent | N/A | N/A | The percentage of each sale the salesperson will receive.
AuditTrailCode | string | N/A | Empty | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.
CommissionAuditTrail Code | string | N/A | Empty | The internally assigned audit trail code that gets saved on the record at the time the commission is posted. This property is read-only.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer on the sales commission line.
SalespersonKey | SalespersonKey | N/A | N/A | Specifies the salesperson for the commission line.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | Specifies the sales territory for the commission line.
PercentOfSale | Percent | N/A | N/A | The percentage of the sale on which each salesperson’s commissions are calculated.
SalesAmount | MoneyAmount | N/A | N/A | The sales amount on which commissions were paid.
Amount | MoneyAmount | N/A | N/A | The commission amount.
IsPosted | boolean | N/A | false | Specifies whether the commission has been posted.
IsPaid | boolean | N/A | false | Specifies whether the commission has been paid.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that specifies the ID of the currency used for the commission line.
TransactionState | SalesCommission TransactionState | N/A | N/A | A sales commission transaction state object that specifies whether the transaction state is Open or History.

Inherits from

BusinessObject


SalespersonCommissionsCriteria

Description

Specifies the criteria to use when retrieving a list of salesperson commissions summary objects. Only salesperson commissions summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
TransactionState | ListRestrictionOfNullableOfSalesCommissionTransactionState | A transaction state restriction specifying the current state of the sales transaction.
DocumentType† | ListRestrictionOfNullableOfSalespersonCommissionsDocumentType | A document type restriction specifying the type of sales document.
DocumentNumber† | LikeRestrictionOfString | A string restriction specifying the ID of the sales document.
CustomerId | LikeRestrictionOfString | A string restriction specifying the ID of the customer.
SalespersonId† | LikeRestrictionOfString | A string restriction specifying the ID of the salesperson.
SalesTerritoryId† | LikeRestrictionOfString | A string restriction specifying the ID of the sales territory,
Scope | SalespersonScope | A property in criteria used to determine the level of filtering to be used when returning salesperson commission data.

Inherits from

Criteria


SalespersonCommissionsKey

Description

Uniquely identifies a salesperson commissions object.

Properties

Property | Type | Length | Default | Description
DocumentType | SalespersonCommissionsDocumentType | N/A | N/A | Specifies the salesperson commissions document type associated with the commission instance.
DocumentNumber | string | 17 | N/A | The document number associated with the commission instance.
SequenceNumber | int | N/A | N/A | The sequence number of the commission instance.

Inherits from

TransactionKey


SalespersonCommissionsSummary

Description

A representation of the important details of salesperson commissions within Microsoft Dynamics GP. A list of salesperson commissions summary objects is returned by the GetSalespersonCommissionsList method.

Properties

Property | Type | Length | Default | Description
Key | SalespersonCommissionsKey | N/A | N/A | The sales person commissions key object that uniquely identifies the salesperson commission instance.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer for the salesperson commission instance.
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that uniquely identifies the salesperson.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that uniquely identifies the sales territory.
SalesAmount | MoneyAmount | N/A | N/A | The sales amount on which commissions were paid.
Amount | MoneyAmount | N/A | N/A | The commission amount.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that specifies the ID of the currency used for the commission.
TransactionState | SalesCommissionTransactionState | N/A | N/A | A sales commission transaction state object that specifies whether the transaction state is Open or History.


SalespersonCriteria

Description

Specifies the criteria to use when retrieving a list of salesperson summary objects. Only salesperson summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID of the salesperson.
LastName† | LikeRestrictionOfString | A string restriction specifying the last name of the salesperson.
FirstName† | LikeRestrictionOfString | A string restriction specifying the first name of the salesperson.
IsActive | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the salesperson is active.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the salesperson was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the salesperson was created.
TerritoryId | LikeRestrictionOfString | A string restriction specifying the sales territory.
Scope | SalespersonScope | A property in criteria used to determine the level of filtering to be used when returning salesperson data.

Inherits from

Criteria


SalespersonHistory

Description

A salesperson history object in Microsoft Dynamics GP

Properties

Property | Type | Length | Default | Description
Key | SalespersonHistoryKey | N/A | N/A | The sales person history key that specifies the salesperson, summary type, and time period.
CommissionSummary | CommissionSummary | N/A | N/A | The commission summary object for the specified salesperson and time period.

Inherits from

BusinessObject


SalespersonHistoryKey

Description

Uniquely identify a salesperson history object.

Properties

Property | Type | Length | Default | Description
SalespersonKey | SalespersonKey | N/A | N/A | The salesperson key object that uniquely identifies the salesperson.
SummaryType | SalesSummaryType | N/A | N/A | Specifies whether the sales history is from the calendar year or the fiscal year.
Period | int | N/A | 0 | An integer representing the calendar month or the fiscal period.
Year | int | N/A | 0 | An integer representing the year of the calendar month or the fiscal period.

Inherits from

ReferenceKey


SalespersonKey

Description

Uniquely identify a salesperson object.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier assigned to the salesperson.

Inherits from

ReferenceKey


SalespersonSummary

Description

A representation of the important details of a salesperson within Microsoft Dynamics GP. A list of salesperson summary objects is returned by the GetSalespersonList method.

Properties

Property | Type | Length | Default | Description
Key | SalespersonKey | N/A | N/A | The customer key object that uniquely identifies the salesperson.
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that specifies the territory for the salesperson.
FirstName | string | 15 | Empty | The salesperson’s first name.
LastName | string | 20 | Empty | The saleperson’s last name.
IsActive | boolean | N/A | True | A boolean that specifies whether the salesperson is active. The value true indicates they are, while false indicates they are not.
CreatedDate | dateTime | N/A | The current system date | The date the salesperson was created.
ModifiedDate | dateTime | N/A | The current system date | The date the saleperson was last modified.


SalesProcessHold

Description

Defines a process hold for a sales document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | SalesProcessHoldKey | N/A | Empty | The sales process hold key object that uniquely identifies a process hold.
Description | string | 30 | Empty | A description of the process hold.
Password | string | 15 | Empty | The password for removing the hold from the sales document.
IsTransferHold | boolean | N/A | False | Restricts documents from being transferred until the hold is removed. True specifies the documents cannot be transferred. False specifies that documents can be transferred.
IsPostHold | boolean | N/A | False | Restricts documents from being posted until the hold is removed. True specifies the documents cannot be posted. False specifies that documents can be posted.
IsFulfillHold | boolean | N/A | False | Restricts an order or invoice document from being fulfilled until the hold is removed. True specifies the order or invoice cannot be fulfilled. False specifies that the order or invoice can be fulfilled.
IsPrintHold | boolean | N/A | False | Restricts documents from being printed until the hold is removed. True specifies the documents cannot be printed. False specifies that documents can be printed.
HoldDateTime | dateTime | N/A | If not provided, set to the system date and time | The date and time each hold was assigned to the sales document.
User | string | N/A | Empty | The user ID for the employee who assigned each sales document hold.
DeleteOnUpdate | boolean | N/A | 0 | Set to True when calling the Update operation to remove the process hold instance.

Inherits from

BusinessObject


SalesProcessHoldKey

Description

Uniquely identifies a process hold for a sales document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
SalesDocumentKey | SalesDocumentKey | N/A | N/A | The sales document key object that uniquely identifies a sales document.
SalesProcessHoldSetup Key | SalesProcessHoldSetupKey | N/A | N/A | The sales process hold setup key object that uniquely identifies a process hold.

Inherits from

TransactionKey


SalesProcessHoldSetup

Description

A sales process hold setup object in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | SalesProcessHoldSetup Key | N/A | N/A | The sales process hold setup key that uniquely identifies the sales process hold setup.
Description | string | 30 | Empty | A description of the sales process hold.
Password | string | 15 | Empty | The password for removing the hold from the sales document.
IsTransferHold | boolean | N/A | False | Restricts documents from being transferred until the hold is removed. True specifies the documents cannot be transferred. False specifies that documents can be transferred.
IsPostHold | boolean | N/A | False | Restricts documents from being posted until the hold is removed. True specifies the documents cannot be posted. False specifies that documents can be posted.
IsFulfillHold | boolean | N/A | False | Restricts an order or invoice document from being fulfilled until the hold is removed. True specifies the order or invoice cannot be fulfilled. False specifies that the order or invoice can be fulfilled.
IsPrintHold | boolean | N/A | False | Restricts documents from being printed until the hold is removed. True specifies the documents cannot be printed. False specifies that documents can be printed.
CreatedDate | dateTime | N/A | Current system date. | The date the sales process hold setup was created.
ModifiedDate | dateTime | N/A | Current system date. | The date the sales process hold setup was last modified.
CreatedBy | string | N/A | Set to the user ID of the subscriber who created the document. | The date the sales process hold setup was created. This property is read-only.

Inherits from

BusinessObject


SalesProcessHoldSetupCriteria

Description

Specifies the criteria to use when retrieving a list of sales process hold setup objects. Only sales process hold setup objects that match the specified criteria will be returned.

Properties

Property | Type | Length | Default | Description
Id | LikeRestrictionOfString | N/A | N/A | A string restriction specifying the ID of the sales process hold setup.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | N/A | N/A | A date/time restriction specifying the date the sales process hold setup was modified.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | N/A | N/A | A date/time restriction specifying the date the sales process hold setup was created.

Inherits from

Criteria


SalesProcessHoldSetupKey

Description

Uniquely identifies a process hold in the Sales Order Processing module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | Identifies a process hold.

Inherits from

ReferenceKey


SalesQuote

Description

A sales quote document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ExpirationDate | dateTime | N/A | N/A | Holds the date the quote expires.
IsRepeating | boolean | N/A | False | Specifies whether the sales quote’s document ID can repeat.
DocumentFrequency | Frequency | N/A | None | Specifies how often the sales quote will repeat.
TimesToRepeat | int | N/A | 0 | Specifies the number of times the sales quote can repeat.
DaysToIncrement | int | N/A | 0 | Specifies the number of days the sales quote will increment each time it is repeated.
WorkflowPriority | WorkflowPriority | N/A | N/A | The priority of the sales quote in the workflow. This property is read-only.
IsProspect | boolean | N/A | N/A | Indicates whether the customer is a prospect customer.
Lines | ArrayOfSalesQuoteLine | N/A | N/A | A collection of sales order lines for the sales order.
Workflows | ArrayOfWorkflow | N/A | N/A | The collection of workflow objects for the sales quote. This property is read-only.

Inherits from

SalesDocument


SalesQuoteComponent

Description

A sales quote component for a sales quote line in the Sales Order Processing module of Microsoft Dynamics GP. Each sales quote line can have a set of sales quote components when the item on the sales quote line is a kit item.

Properties

Property | Type | Length | Default | Description
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityToInvoice | Quantity | N/A | 0 | The quantity to use as the invoice quantity when the document is transferred to an invoice.
QuantityToOrder | Quantity | N/A | 0 | Holds the total quantity of the component needed to fill the quantity of the kit item entered on the sales quote.

Inherits from

SalesComponent


SalesQuoteCriteria

Description

Specifies the criteria to use when retrieving sales quote summary objects. Only sales quote summary documents that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

SalesDocumentCriteriaBase


SalesQuoteLine

Description

A sales quote line for a sales quote in the Sales Order Processing module of Microsoft Dynamics GP. Each sales quote can have a set of sales quote lines.

Properties

Property | Type | Length | Default | Description
QuantityCanceled | Quantity | N/A | 0 | The quantity canceled on the line item. This property cannot have a value if Quantity has a negative value.
QuantityToInvoice | Quantity | N/A | 0 | The quantity to use as the invoice quantity when the document is transferred to an invoice
QuantityToOrder | Quantity | N/A | 0 | Holds the quantity of the item on the sales quote line.
Components | ArrayOfSalesQuoteComponent | N/A | Empty | A collection of components for a sales quote line.

Inherits from

SalesLine


SalesQuoteSummary

Description

A representation of the important details of a sales quote document in the Sales Order Processing module for Microsoft Dynamics GP. A list of sales quote summary objects is returned by the GetSalesQuoteList method.

Properties

Inherited from the base class

Inherits from

SalesDocumentSummaryBase


SalesReturn

Description

A sales return document in the Sales Order Processing module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PaymentAmount | MoneyAmount | N/A | In not specified, set to the sum of the payments in the sales return. | The total payment amount for the sales return.
TermsDiscountReturned Amount | MoneyAmount | N/A | N/A | If a terms discount was applied, the amount of the discount. This amount will reduce the amount returned to the customer.
GeneralLedgerPosting Date | dateTime | N/A | N/A | Date that will be assigned as the GL Post Date for all transactions in the batch if Posting Setup is set to post by batch date. This property is read-only.
PostedDate | dateTime | N/A | N/A | Used for recurring batches, this value records the last user to post this transaction. This property is read-only.
PostedBy | string | N/A | N/A | Used for recurring batches, this value records the last user to post this transaction. This property is read-only.
Lines | ArrayOfSalesReturnLine | N/A | N/A | A collection of sales return lines for the sales return.
Payments | ArrayOfSalesPayment | N/A | N/A | A collection of payments for the sales return.
Distributions | ArrayOfSalesDistribution | N/A | N/A | A collection of distributions for the sales return.

Inherits from

SalesDocument


SalesReturnComponent

Description

A sales return component for a sales return line in the Sales Order Processing module of Microsoft Dynamics GP. Each sales return line can have a set of sales return components when the item on the sales return line is a kit item.

Properties

Property | Type | Length | Default | Description
ReturnQuantity | SalesReturnQuantities | N/A | 0 | An object that represents the set of quantities returned for the sales return component.
Serials | ArrayOfSalesComponentSerial | N/A | Empty | A collection of serial details for a sales component with a serial-tracked item.
Lots | ArrayOfSalesComponentLot | N/A | Empty | A collection of lot details for a sales component with a lot-tracked item.
Bins | ArrayOfSalesComponentBin | N/A | Empty | A collection of bin details for a sales component when using the multiple bin functionality.

Inherits from

SalesComponent


SalesReturnCriteria

Description

Specifies the criteria to use when retrieving a sales return summary objects. Only sales return summary documents that match the specified criteria will be returned.

Properties

Inherited from the base class

Inherits from

SalesDocumentCriteriaBase


SalesReturnLine

Description

A sales return line for a sales return in the Sales Order Processing module of Microsoft Dynamics GP. Each sales return can have a set of sales return lines.

Properties

Property | Type | Length | Default | Description
ReturnQuantity | SalesReturnQuantities | N/A | N/A | The set of quantities for a sales return line.
Components | ArrayOfSalesComponent | N/A | N/A | A collection of components for a sales return line.
Serials | ArrayOfSalesLineSerial | N/A | N/A | A collection of serial details for a sales return line with a serial-tracked item.
Lots | ArrayOfSalesLineLot | N/A | N/A | A collection of lot details for a sales return line with a lot-tracked item.
Bins | ArrayOfSalesLineBin | N/A | N/A | A collection of bin details for a sales return line when using the multiple bin functionality.

Inherits from

SalesLine


SalesReturnQuantities

Description

The set of quantities for a sales return line.

Properties

Property | Type | Length | Default | Description
OnHandQuantity | Quantity | N/A | 0 | The number of items being returned to the quantity on hand, or the quantity that is available to be sold.
ReturnedQuantity | Quantity | N/A | 0 | The number of items being returned to the returned quantity type.
InUseQuantity | Quantity | N/A | 0 | The number of items being returned that are in use.
InServiceQuantity | Quantity | N/A | 0 | The number of items being returned that are in service.
DamagedQuantity | Quantity | N/A | 0 | The number of items being returned that are damaged.


SalesReturnSummary

Description

A representation of the important details of a sales return document in the Sales Order Processing module for Microsoft Dynamics GP. A list of sales return summary objects is returned by the GetSalesReturnList method.

Properties

Inherited from the base class

Inherits from

SalesDocumentSummaryBase


SalesSerial

Description

A set of common properties that are specific to serial numbers for serial-tracked items.

Properties

Property | Type | Length | Default | Description
SerialNumber | string | 20 | Empty | The serial number.

Inherits from

SalesSerialLot


SalesSerialLot

Description

A set of properties that is common for both lot numbers and serial numbers.

Properties

Property | Type | Length | Default | Description
DeleteOnUpdate | boolean | N/A | False | Set to True when calling the Update operation to remove the serial/lot instance.

Inherits from

SalesSerialLotBase


SalesSerialLotBase

Description

The common properties of serial numbers and lot numbers in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Bin | string | 15 | Empty | The bin number. Only provide if using multiple bins.
DateReceived | dateTime | N/A | N/A | The date the serial number or lot number was received. This property is read-only.
DateSequenceNumber | decimal | N/A | N/A | The received sequence number. This property is read-only.
UnitCost | MoneyAmount | N/A | N/A | The cost per unit of measure. This property is read-only.
IsPosted | boolean | N/A | N/A | Indicates whether the serial/lot has been posted. This property is read-only.

Inherits from

BusinessObject


SalesSummary

Description

Contains sales summary information for a salesperson or sales territory in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
YearToDate | CommissionSummary | N/A | N/A | Commission summary information for the year to date.
LastYear | CommissionSummary | N/A | N/A | Commission summary information for the previous year.

Inherits from

BusinessObject


SalesTax

Description

Defines common properties for sales tax information in the Sales Order Processing module for Microsoft Dynamics GP

Properties

Property | Type | Length | Default | Description
GLAccountKey | GLAccountNumberKey | N/A | Empty | The GL account number key object that specifies the account to which the tax amount will be posted.
IsTaxableTax | boolean | N/A | N/A | This property is read only.
TotalTaxPotentialAmount | MoneyAmount | N/A | N/A | This property is read only.

Inherits from

Tax


SalesTerms

Description

Defines sales terms for a sales invoice document in the Sales Order Processing module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DiscountTakenAmount | MoneyAmount | N/A | 0 | The payment terms discount amount taken if the customer has taken advantage of available discounts.

Inherits from

Terms


SalesTerritory

Description

A sales territory in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | SalesTerritoryKey | N/A | N/A | The sales territory key object that uniquely identifies the sales territory.
Description | string | 30 | Empty | The description of the sales territory.
IsActive | boolean | N/A | False | Indicates whether the sales territory is active.
SalesManagerKey | SalespersonKey | N/A | N/A | The sales manager key object that specifies the sales manager.
SalesManagerFirstName | string | 15 | Empty | The sales manager’s first name.
SalesManagerMiddle Name | string | 15 | Empty | The sales manager’s middle name.
SalesManagerLastName | string | 20 | Empty | The sales manager’s last name.
Country | string | 60 | Empty | The country the sales territory is located in.
HistoryOptions | SalesHistoryOptions | N/A | N/A | The options for tracking sales history.
CreatedDate | dateTime | N/A | Current system date | The date the sales territory was created.
ModifiedDate | dateTime | N/A | Current system date | The date the sales territory was modified. The value is in Coordinated Universal Time (UTC).
SalesSummary | SalesSummary | N/A | N/A | Sales summary information for the sales territory.
SalesHistory | ArrayOfSalesTerritoryHistory | N/A | N/A | A collection of sales territory history items.

Inherits from

BusinessObject


SalesTerritoryCriteria

Description

Specifies the criteria to use when retrieving a list of sales territory summary objects. Only sales territory summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID for the sales territory.
SalesManagerId | LikeRestrictionOfString | A string restriction specifying the sales manager ID.
SalesManagerLastName | LikeRestrictionOfString | A string restriction specifying the sales manager last name.
IsActive | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the sales territory is active.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the sales territory was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the sales territory was created.
SalespersonId | LikeRestrictionOfString | A string restriction specifying the salesperson ID.
Scope | SalespersonScope | A property in criteria used to determine the level of filtering to be used when returning sales territory data.

Inherits from

Criteria


SalesTerritoryHistory

Description

Contains historical sales and commissions information for a sales territory.

Properties

Property | Type | Length | Default | Description
Key | SalesTerritoryHistoryKey | N/A | N/A | The sales territory history key that uniquely identifies the sales territory history.
CommissionSummary | CommissionSummary | N/A | N/A | A set of sales commission information for the sales territory.

Inherits from

BusinessObject


SalesTerritoryHistoryKey

Description

Uniquely identifies a sales territory history object.

Properties

Property | Type | Length | Default | Description
SalesTerritoryKey | SalesTerritoryKey | N/A | N/A | The sales territory key object that uniquely identifies the sales territory.
SummaryType | SalesSummaryType | N/A | Calendar Year | Specifies the type of summary.
Period | int | N/A | N/A | The period for which data is being retrieved.
Year | int | N/A | N/A | The year for which data is being retrieved.

Inherits from

ReferenceKey


SalesTerritoryKey

Description

Uniquely identifies a sales territory.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The unique identifier assigned to the sales territory.

Inherits from

ReferenceKey


SalesTerritorySummary

Description

A representation of the important details of a sales territory within Microsoft Dynamics GP. A list of sales territory summary objects is returned by the GetSalesTerritoryList method.

Properties

Property | Type | Length | Default | Description
Key | SalesTerritoryKey | N/A | N/A | The sales territory key object that uniquely identifies the sales territory.
Description | string | 30 | Empty | The description of the sales territory.
IsActive | boolean | N/A | False | Indicates whether the sales territory is active.
SalesManagerKey | SalespersonKey | N/A | N/A | The sales manager key object that specifies the sales manager.
SalesManagerFirstName | string | 15 | Empty | The sales manager’s first name.
SalesManagerLastName | string | 20 | Empty | The sales manager’s last name.
CreatedDate | dateTime | N/A | Current system date | The date the sales territory was created.
ModifiedDate | dateTime | N/A | Current system date | The date the sales territory was modified.


SalesTrackingNumber

Description

A tracking number for a sales document in the Sales Order Processing module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | SalesTrackingNumberKey | N/A | N/A | The sales tracking number key object that uniquely identifies a tracking number for a sales document.
DeleteOnUpdate | boolean | N/A | False | Set to True when calling the Update operation to remove the tracking number.

Inherits from

BusinessObject


SalesTrackingNumberKey

Description

Uniquely identifies a sales tracking number for a sales document in the Sales Order Processing module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
SalesDocumentKey | SalesDocumentKey | N/A | N/A | The sales document key object that uniquely identifies a sales document.
Id | string | 40 | Empty | The value of the tracking number.

Inherits from

TransactionKey


SalesUserDefined

Description

The user defined properties of a sales document in the Sales Order Processing module for Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Date01 | dateTime | N/A | Empty | User-defined date information for a sales document.
Date02 | dateTime | N/A | Empty | User-defined date information for a sales document.
List01 | string | 20 | Empty | User-defined list information for a sales document.
List02 | string | 20 | Empty | User-defined list information for a sales document.
List03 | string | 20 | Empty | User-defined list information for a sales document.
Text01 | string | 20 | Empty | User-defined text information for a sales document.
Text02 | string | 20 | Empty | User-defined text information for a sales document.
Text03 | string | 20 | Empty | User-defined text information for a sales document.
Text04 | string | 20 | Empty | User-defined text information for a sales document.
Text05 | string | 20 | Empty | User-defined text information for a sales document.


SecurityKey

Description

The base key object for security keys.

Properties

None


SequenceKey

Description

Uniquely identifies an application for a job applicant in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | int | N/A | N/A | An integer value that uniquely identifies an application for a job applicant.

Inherits from

ReferenceKey


Service

Description

Defines a service item in the Inventory module in Microsoft Dynamic GP.

Properties

Inherited from base class

Inherits from

Item


ServiceAddress

Description

Represents the service address details for a service or return document in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CountryRegion | string | 60 | Empty | The country or region for the address.

Inherits from

AddressBase


ServiceAreaKey

Description

Uniquely identifies a service area.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | The unique identifier assigned to the service area.

Inherits from

ReferenceKey


ServiceAudit

Description

Contains the common audit details for a service call or return document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Description | string | N/A | N/A | The description of the change being recorded within the audit records. This property is read-only.
CreatedBy | string | N/A | Set to the user ID of the subscriber who created the audit. | The user who created the audit. This property is read-only.
CreatedDateTime | dateTime | N/A | Set to the system date. | The date and time on which the current audit record was generated. This property is read-only

Inherits from

BusinessObject


ServiceBillTo

Description

Contains the bill to details for a service call or return material authorization document in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies a customer.
AddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies an address.


ServiceCall

Description

A service call in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
DispatchDateTime | dateTime | N/A | Empty | The date and time on which the technician was dispatched to the service call.
ArrivalDateTime | dateTime | N/A | Empty | The date and time on which the technician arrived at the service call location.
CompletionDateTime | dateTime | N/A | Empty | The date and time on which the technician has completed all technical work associated with the current service call.
Meter1 | ServiceCallEquipmentMeter | N/A | N/A | The current reading provided for Meter1 for the service call.
Meter2 | ServiceCallEquipmentMeter | N/A | N/A | The current reading provided for Meter2 for the service call.
Meter3 | ServiceCallEquipmentMeter | N/A | N/A | The current reading provided for Meter3 for the service call.
Meter4 | ServiceCallEquipmentMeter | N/A | N/A | The current reading provided for Meter4 for the service call.
Meter5 | ServiceCallEquipmentMeter | N/A | N/A | The current reading provided for Meter5 for the service call.
Type | ServiceCallType | N/A | Open | Identifies the type of service document.
EscalationDateTime | dateTime | N/A | N/A | The date and time on which the last escalation step was completed. This property is read-only.
EscalationLevel | int | N/A | N/A | The number of the last escalation step that was completed. This property is read-only.
InvoicedAmount | MoneyAmount | N/A | N/A | The amount actually invoiced for the service call. This property is read-only.
IsCallback | boolean | N/A | N/A | Identifies when the service call is a callback for a previously completed call. This property is read-only.
NotifyDateTime | dateTime | N/A | N/A | The date and time on which the technician was notified of the service call. This property is read-only.
WasNotified | boolean | N/A | N/A | Identifies that the technician was notified of the service call. This property is read-only.
Parts | ArrayOfServiceCallPartLine | N/A | N/A | A collection of service call part lines.
Labor | ArrayOfServiceCallLaborLine | N/A | N/A | A collection of service call labor lines.
AdditionalCharges | ArrayOfServiceCallAdditionalChargeLine | N/A | N/A | A collection of additional charge lines.
Expenses | ArrayOfServiceCallExpenseLine | N/A | N/A | A collection of service call expense lines.
EquipmentCodes | ArrayOfServiceCallEquipmentCode | N/A | N/A | A collection of service call equipment codes.

Inherits from

ServiceCallDocument


ServiceCallAdditionalChargeLine

Description

An additional charge line for a service call in the Field Service module of Microsoft Dynamics GP. Each service call can have a set of additional charge lines.

Properties

Inherited from the base class

Inherits from

ServiceChargeLine


ServiceCallCriteria

Description

Specifies the criteria to use when retrieving a list of service call summary objects. Only service call summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Type | LikeRestrictionOfNullableOfServiceCallType | A document type restriction specifying the type of service call document.

Inherits from

ServiceCallDocumentCriteria


ServiceCallDocument

Description

The common properties for a service call document in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CustomerReference | string | 22 | Empty | The customer's reference on the service call.
Description | string | 62 | Empty | A description of the service call.
IsOnHold | boolean | N/A | False | Indicates when the service call is on hold.
PaymentTermsKey | PaymentTermsKey | N/A | Empty | The payment terms key object that uniquely identifies the payment term for the service call.
PriceLevelKey | PriceLevelKey | N/A | Empty | The price level key object that uniquely identifies the price level for the service call.
Priority | int | N/A | 0 | The priority level of the service call.
ResponseDateTime | dateTime | N/A | Empty | The date and time by which a response should be initiated for the service call, based on any applicable contract terms.
ServiceAreaKey | ServiceAreaKey | N/A | Empty | The service area key object that uniquely identifies the service area for the service call.
ServiceContractKey | ServiceDocumentKey | N/A | Empty | The service contract key object that uniquely identifies the service contract for the service call.
ServiceTypeKey | ServiceTypeKey | N/A | Empty | The service type key object that uniquely identifies the service type for the service call.
ShipToAddress | ServiceCallShipToAddress | N/A | Empty | The address details for the ship to address.
StatusCodeKey | ServiceCallStatusCodeKey | N/A | Empty | The status code key object that uniquely identifies the status for the service call.
TechnicianKey | ServiceTechnicianKey | N/A | Empty | The service technician key object that uniquely identifies the technician for the service call.
TimeZoneKey | ServiceTimeZoneKey | N/A | Empty | The time zone key object that uniquely identifies the time zone for the service call.
DocumentTotal | MoneyAmount | N/A | N/A | The total price of the current service call, including all labor, parts, additional charge, expense and sales tax values. This property is read-only.
EstimatedTimeToRepair | decimal | N/A | 0.0 | The time it typically takes to perform a repair based on the item, techniaicn, and problem code. This property is read-only.
LaborCharges | ServiceCharge | N/A | N/A | The details of labor charges related to the service call. This property is read-only.
MiscellaneousCharges | ServiceCharge | N/A | N/A | The details of miscellaneous charges related to the service call. This property is read-only.
PartsCharges | ServiceCharge | N/A | N/A | The details of part charges related to the service call. This property is read-only.
PreTaxDocumentAmount | MoneyAmount | N/A | N/A | A summary of the pre-tax price of all labor, parts, additional charge and expense entries attached to the service call. This property is read-only.
SalesPersonKey | SalespersonKey | N/A | Empty | The salesperson key object that uniquely identifies the salesperson for the service call. This property is read-only.
ServiceContractLine SequenceNumber | decimal | N/A | N/A | The line sequence number of the contract associated to the service call. This property is read-only.
TaxAmount | MoneyAmount | N/A | N/A | The projected sales tax amount for the service call. This property is read-only.
TaxExemptNumber1 | string | N/A | N/A | The customer's tax exemption number. This property is read-only.
TaxExemptNumber2 | string | N/A | N/A | An additional customer's tax exemption number. This property is read-only.
TaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies the tax schedule for the service call. This property is read-only.
Distributions | ArrayOfServiceDistribution | N/A | N/A | A collection of service distributions.
Audits | ArrayOfServiceCallDocumentAudit | N/A | N/A | A collection of service call document audits.

Inherits from

ServiceDocument


ServiceCallDocumentAudit

Description

Contains the audit details for a service call document in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ServiceLineKey | N/A | N/A | The key object that uniquely identifies the service line for the service call document audit. This property is read-only.
TechnicianKey | ServiceTechnicianKey | N/A | N/A | The technician key object that uniquely identifies the technician for the service call document audit. This property is read-only.
FromStatusCodeKey | ServiceCallStatusCodeKey | N/A | N/A | The from status code key object that uniquely identifies the previous status code for the service call document audit. This property is read-only.
ToStatusCodeKey | ServiceCallStatusCodeKey | N/A | N/A | The to status code key object that uniquely identifies the new status code for the service call document audit. This property is read-only.

Inherits from

ServiceAudit


ServiceCallDocumentCriteria

Description

Specifies the set of criteria to use when retrieving a service call document object. Only service call documents that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
ServiceTypeId | LikeRestrictionOfString | A string restriction specifying the ID of the service type.
TechnicianId | LikeRestrictionOfString | A string restriction specifying the technician ID for the service call document.
StatusCodeId | LikeRestrictionOfString | A string restriction specifying the status code ID for the service call document.
Scope | ServiceCallDocumentScope | A property in criteria used to determine the level of filtering to be used when returning service call document data.

Inherits from

ServiceDocumentCriteria


ServiceCallEquipmentCode

Description

The code properties for the service equipment on a service call in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
PerformedPreventive Maintenance | boolean | N/A | N/A | The value true indicates that preventive maintenace was performed for the equipment.

Inherits from

ServiceEquipmentCode


ServiceCallEquipmentMeter

Description

Defines the properties specific to an equipment meter for a service call in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
InternalUsage | int | N/A | N/A | The number of meter clicks used on the service call in the repair process. This property is read-only.

Inherits from

ServiceEquipmentMeter


ServiceCallExpenseLine

Description

An expense line for a service call in the Field Service module of Microsoft Dynamics GP. Each service call can have a set of expense lines.

Properties

Inheritied from the base class

Inherits from

ServiceChargeLine


ServiceCallLaborLine

Description

A labor line for a service call in the Field Service module of Microsoft Dynamics GP. Each service call can have a set of labor lines.

Properties

Inherited from the base class

Inherits from

ServiceLaborLine


ServiceCallLineCauseCodeKey

Description

Uniquely identifies a service call line cause code in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 12 | Empty | The unique identifier assigned to the cause code.

Inherits from

ReferenceKey


ServiceCallLineProblemCodeKey

Description

Uniquely identifies a service call line problem code in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 12 | Empty | The unique identifier assigned to the problem code.

Inherits from

ReferenceKey


ServiceCallLineRepairCodeKey

Description

Uniquely identifies a service call line repair code in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 12 | Empty | The unique identifier assigned to the repair code.

Inherits from

ReferenceKey


ServiceCallPartLine

Description

A part line for a service call in the Field Service module of Microsoft Dynamics GP. Each service call can have a set of part lines.

Properties

Property | Type | Length | Default | Description
ConsolidateOnPO | boolean | N/A | False | The value true indicates that transfer or purchase order lines will be consolidated with other open transfers or purchase orders. The value false indicates they will not.
QuantityAllocated | Quantity | N/A | 0 | The quantity of the item on the part line that is allocated in Inventory.
QuantitySold | Quantity | N/A | 0 | The quantity of the item on the part line that was actually used.
IsOnReturnDocument | boolean | N/A | N/A | The value true indicates the service call line is on a customer return (RMA) document. This property is read-only.
IsOnTransfer | boolean | N/A | N/A | The value true indicates the service call line is on a transfer document. This property is read-only.
ReturnMaterialAuthorizationLineKey | ServiceLineKey | N/A | N/A | The service line key object that uniquely identifies the service line for the service call document. This property is read-only.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the line, which is the unit cost times the quantity sold. This property is read-only.
TransferFromWarehouseKey | WarehouseKey | N/A | N/A | The transfer from warehouse key object that uniquely identifies the warehouse for the transfer document. This property is read-only.
TransferLineKey | ServiceLineKey | N/A | N/A | The transfer line key object that uniquely identifies the transfer line for the service call part line. This property is read-only.
TransferQuantity | Quantity | N/A | N/A | The quantity of the current part that will be transferred to fulfill the line. This property is read-only.
PurchaseOrderLineKey | PurchaseTransactionLineKey | N/A | N/A | The purchase order line key object that uniquely identifies the purchase order line for the service call part line. This property is read-only.
LotDetails | ArrayOfServiceLot | N/A | N/A | A collection of service lot details.
SerialDetails | ArrayOfServiceSerial | N/A | N/A | A collection of service serial details.

Inherits from

ServicePartLine


ServiceCallShipToAddress

Description

Contains the details specific to the ship to address for a service call in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Phone1 | PhoneNumber | N/A | Empty | The telephone number assigned to the ship to address of the document.

Inherits from

ReturnMaterialAuthorizationShipToAddress


ServiceCallStatusCodeKey

Description

Uniquely identifies a service call status code in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 4 | Blank | The unique identifier assigned to the status code.

Inherits from

ReferenceKey


ServiceCallSummary

Description

A representation of the important details of a service call within Microsoft Dynamics GP. A list of service call summary objects is returned by the GetServiceCallList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Type | ServiceCallType | N/A | N/A | Identifies the type of service document.
ServiceTypeKey | ServiceTypeKey | N/A | N/A | The service type key object that uniquely identifies the service type for the service call.
TechnicianKey | ServiceTechnicianKey | N/A | N/A | The technician key object that uniquely identifies the technician for the service call.
StatusCodeKey | ServiceCallStatusCodeKey | N/A | N/A | The status code key object that uniquely identifies the status for the service call.
DispatchDateTime | dateTime | N/A | N/A | The date and time on which the technician was dispatched to the service call.
ArrivalDateTime | dateTime | N/A | N/A | The date and time on which the technician arrived at the service call location.
CompletionDateTime | dateTime | N/A | N/A | The date and time on which the technician has completed all technical work associated with the current service call.
DocumentTotal | MoneyAmount | N/A | N/A | The total price of the current service call, including all labor, parts, additional charge, expense and sales tax values.

Inherits from

ServiceDocumentSummary


ServiceCharge

Description

Contains the service charge properties for a service call document in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
TotalAmount | MoneyAmount | N/A | N/A | The total price of the service charge, which is the unit price multiplied by the quantity sold.
BillablePercent | Percent | N/A | N/A | The percent of the service charge that is billable to the customer.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the service charge, which is the unit cost multiplied by the quantity sold.

Inherits from

BusinessObject


ServiceChargeLine

Description

Defines the common properties for a service charge line for a service call line in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
BillableMiscellaneousPercent | Percent | N/A | The value will default from any contract or warranty attached to the current contract, otherwise it will default to 100. | The percent of the line that is billable to the customer.
QuantitySold | Quantity | N/A | N/A | The quantity of the item on the service charge line that was actually used.
PurchaseOrder | ServiceLinePurchaseOrderCreation | N/A | N/A | The details related to the creation of a purchase order for a service charge line.
PurchaseOrderLineKey | PurchaseTransactionLineKey | N/A | N/A | The purchase order line key object that uniquely identifies the purchase order line for the service charge line. This property is read-only.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the service charge line, which is the unit cost multiplied by the quantity sold.

Inherits from

ServiceLine


ServiceCriteria

Description

Specifies the criteria to use when retrieving a list of service item summary objects. Only service item summary objects that match the specified criteria will be returned.

Properties

Inherited from base class

Inherits from

ItemCriteriaBase


ServiceDistanceTraveled

Description

Defines the details related to distance traveled on a service call in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Ending | int | N/A | 0 | The ending mileage.
Starting | int | N/A | 0 | The starting mileage.
Used | int | N/A | 0 | The total mileage (Ending - Starting).

Inherits from

BusinessObject


ServiceDistribution

Description

Defines a general ledger distribution for a specific service document.

Properties

Property | Type | Length | Default | Description
Key | ServiceLineKey | N/A | N/A | The key object that uniquely identifies the line for the service distribution. This property is read-only.
IsPosted | boolean | N/A | N/A | Indicates whether the distribution has been posted. True indicates it has. False indicates it has not. This property is read-only.
PostedDate | dateTime | N/A | N/A | The date the distribution was posted. This property is read-only.

Inherits from

Distribution


ServiceDocument

Description

Defines the common properties for a service or return document in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ServiceDocumentKey | N/A | N/A | The key object that uniquely identifies the service document.
CurrencyKey | CurrencyKey | N/A | N/A | The currency key object that uniquely identifies the currency for the service document.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer for the service document.
CustomerName | string | 64 | Empty | The customer name.
CustomerPONumber | string | 22 | Empty | The customer's purchase order number provided as authorization for the service document.
EntryDateTime | dateTime | N/A | N/A | The date and time on which the service document was first saved.
EstimatedArrivalDateTime | dateTime | N/A | N/A | The estimated arrival (ETA) date and time for the service document. For a service call it is the ETA of the technician. For a return document is the ETA for the return item.
FrontOfficeIntegrationId | string | 50 | Empty | The from office integration ID.
Note | string | 8000 | Empty | The note text for the service document.
OfficeKey | OfficeKey | N/A | N/A | The office key object that uniquely identifies the office for the service document.
ShipToAddressKey | ShipToAddressKey | N/A | N/A | The ship to address key object that uniquely identifies the ship to address for the service document.
TransactionState | ServiceTransactionState | N/A | N/A | Indicates whether the sales document was retrieved from the open table or the history table. This property is read-only.
UserDefined01 | string | 22 | Emptry | User-defined text.
UserDefined02 | string | 22 | Emptry | User-defined text.
UserDefined03 | string | 22 | Emptry | User-defined text.
UserDefined04 | string | 22 | Emptry | User-defined text.
UserDefined05 | string | 22 | Emptry | User-defined text.
BillTo | ServiceBillTo | N/A | N/A | The bill to details for the service document. This information is read-only.
ExchangeDate | dateTime | N/A | N/A | The exchange date of the service document. This property is read-only.
ExchangeRate | decimal | N/A | N/A | The exchange rate of the service document. This property is read-only.
RateTypeKey | RateTypeKey | N/A | N/A | The rate type key object that specifies the rate type typically used for the customer on the service document. This property is read-only.

Inherits from

BusinessObject


ServiceDocumentCriteria

Description

Specifies the set of criteria to use when retrieving a service document object. Only service documents that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id | LikeRestrictionOfString | A string restriction specifying the ID of the service document.
CustomerId | LikeRestrictionOfString | A string restriction specifying the customer ID for the service document.
CustomerName | LikeRestrictionOfString | A string restriction specifying the name of the customer for the service document.
CustomerPONumber | LikeRestrictionOfString | A string restriction specifying the purchase order of the customer for the service document.
OfficeId | LikeRestrictionOfString | A string restriction specifying the office ID of the service document.
TransactionState | ListRestrictionOfNullableOfServiceTransactionState | A list restriction specifying the transaction state of the service document.

Inherits from

Criteria


ServiceDocumentKey

Description

Uniquely identifies a service document in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 12 | Empty | The unique identifier assigned to the service document.

Inherits from

TransactionKey


ServiceDocumentSummary

Description

A representation of the important details of a service document within Microsoft Dynamics GP. All of the properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ServiceDocumentKey | N/A | N/A | The key object that uniquely identifies the service document.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer for the service document.
CustomerName | string | N/A | N/A | The name of the customer on the service document.
CustomerPONumber | string | N/A | N/A | The customer's purchase order number provided as authorization for the service document.
OfficeKey | OfficeKey | N/A | N/A | The office key object that uniquely identifies the office for the service document.
TransactionState | ServiceTransactionState | N/A | N/A | Indicates whether the sales document was retrieved from the open table or the history table.


ServiceEquipment

Description

Defines the properties for service equipment in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ServiceEquipmentKey | N/A | N/A | The key object that uniquely identifies the service equipment.
Reference | string | 30 | Empty | A reference about the service equipment.
Version | string | 20 | Empty | The version of the service equipment.
StatusKey | ServiceStatusKey | N/A | N/A | The status key object that uniquely identifies the service status of the service equipment.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer of the service equipment.
AddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies the address of the service equipment.
Address | ServiceEquipmentAddress | N/A | N/A | The address details for the location of the service equipment.
InstallDate | dateTime | N/A | N/A | The date the equipment was installed.
ShippedDate | dateTime | N/A | N/A | The date the equipment was shipped.
RegisterDate | dateTime | N/A | N/A | The date the equipment was registered.
LastPreventive MaintenanceDate | dateTime | N/A | N/A | The last date that preventive maintenance was performed on the equipment.
LastServiceDate | dateTime | N/A | N/A | The last date of a service call for the equipment.
TechnicianKey | ServiceTechnicianKey | N/A | N/A | The technician key object that uniquely identifies the technician that normally services the service equipment.
OfficeKey | OfficeKey | N/A | N/A | The office key object that uniquely identifies the office that is responsible for the service equipment.
ServiceAreaKey | ServiceAreaKey | N/A | N/A | The service area key object that uniquely identifies the service area where the service equipment is located.
TimeZoneKey | ServiceTimeZoneKey | N/A | N/A | The time zone key object that uniquely identifies the time zone where the service equipment is located.
VendorKey | VendorKey | N/A | N/A | The vendor key object that uniquely identifies the vendor that has the vendor warranty for the service equipment.
VendorWarrantyCode | ServiceWarrantyCode | N/A | N/A | The details of the vendor warranty code for the service equipment.
SellerWarrantyCode | ServiceWarrantyCode | N/A | N/A | The details of the seller warranty code for the service equipment.
Note | string | 8000 | Empty | The note text for the service equipment.
PreventiveMaintenance Month | ISO8061Month | N/A | N/A | The month preferred by the customer for when annual preventive maintenance events are to be performed.
PreventiveMaintenance Day | int | N/A | 0 | The day of the month preferred by the customer for when annual preventive maintenance events are to be performed.
LastCalculatedDate | dateTime | N/A | N/A | The last date preventative maintenance month and day were calculated. This property is read-only.
UserDefined01 | string | 20 | Empty | User-defined text.
UserDefined02 | string | 20 | Empty | User-defined text.
UserDefined03 | string | 20 | Empty | User-defined text.
UserDefined04 | string | 20 | Empty | User-defined text.
UserDefined05 | string | 20 | Empty | User-defined text.
SerialNumber | string | 20 | Empty | The serial number of the service equipment.
Quantity | Quantity | N/A | N/A | The quantity for the service equipment. This property is read-only.
AssetTag | string | 20 | Empty | The asset tag for the service equipment.
Readings | ArrayOfServiceEquipmentReading | N/A | N/A | A collection of readings for the service equipment.

Inherits from

BusinessObject


ServiceEquipmentAddress

Description

The specific properties for a service equipment address in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Country | string | 60 | Empty | The country of the customer address where the equipment is installed.
ContactPerson | string | 60 | Empty | The contact person of the customer address where the is equipment is installed.

Inherits from

AddressBase


ServiceEquipmentCode

Description

The code properties for the service equipment in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
SerialNumber | string | 20 | Empty | Uniquely identifies the equipment on the service call to be repaired.
ItemKey | ItemKey | N/A | N/A | The item key object that uniquely identifies the item of the service equipment.
ProblemCodeKey | ServiceCallLineProblemCodeKey | N/A | N/A | The problem code key object that uniquely identifies the problem code for the service equipment on the service call.
CauseCodeKey | ServiceCallLineCauseCodeKey | N/A | N/A | The cause code key object that uniquely identifies the cause code for the service equipment on the service call.
RepairCodeKey | ServiceCallLineRepairCodeKey | N/A | N/A | The repair code key object that uniquely identifies the repair code for the service equipment on the service call.
Key | ServiceLineKey | N/A | N/A | The key object that uniquely identifies the service equipment on the service call.
EquipmentLineSequenceNumber | int | N/A | N/A | The line sequence number of the equipment. This property is read-only.

Inherits from

BusinessObject


ServiceEquipmentCriteria

Description

Specifies the set of criteria to use when retrieving a service equipment object. Only service equipment that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id | LikeRestrictionOfString | A string restriction specifying the ID of the service equipment.
CustomerId | LikeRestrictionOfString | A string restriction specifying the customer ID for the service equipment.
AddressId | LikeRestrictionOfString | A string restriction specifying the address ID for the service equipment.
ItemId | LikeRestrictionOfString | A string restriction specifying the item ID for the service equipment.
StatusId | LikeRestrictionOfString | A string restriction specifying the status ID for the service equipment.
InstallDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the service equipment was installed.
Scope | ServiceEquipmentScope | A property in criteria used to determine the level of filtering to be used when returning service equipment data.

Inherits from

Criteria


ServiceEquipmentKey

Description

Uniquely identifies service equipment in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 20 | Empty | The unique identifier assigned to the service equipment.
ItemKey | ItemKey | N/A | N/A | The item key object that uniquely identifies the item of the service equipment.

Inherits from

ReferenceKey


ServiceEquipmentMeter

Description

Defines the properties for the meter for service equipment in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
CurrentReading | int | N/A | 0 | The current meter reading.
Replaced | boolean | N/A | False | Indicates the meter has been replaced. True indicates it has, while false indicates it has not.

Inherits from

BusinessObject


ServiceEquipmentReading

Description

Defines the properties for the service equipment reading in the Field Service module of Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ServiceEquipmentReadingKey | N/A | N/A | The service equipment reading key object that uniquely identifies a reading for the service equipment.
Meter1 | ServiceEquipmentMeter | N/A | N/A | The meter reading for Meter 1.
Meter2 | ServiceEquipmentMeter | N/A | N/A | The meter reading for Meter 2.
Meter3 | ServiceEquipmentMeter | N/A | N/A | The meter reading for Meter 3.
Meter4 | ServiceEquipmentMeter | N/A | N/A | The meter reading for Meter 4.
Meter5 | ServiceEquipmentMeter | N/A | N/A | The meter reading for Meter 5.
ModifiedDate | dateTime | N/A | N/A | The date the equipment reading was last modified.
ModifiedBy | string | N/A | N/A | The user who last modified an equipment reading. This property is read-only.
ReadingEnteredFrom | string | N/A | N/A | Identifies where the meter reading was posted from. Values are: "Equipment" from Equipment Maintenance >> Meter reading Post; "Batch Post" from Contract Meter Posting; "Service Call" from Service call completion posting of Meter Item. This property is read-only.

Inherits from

BusinessObject


ServiceEquipmentReadingKey

Description

Uniquely identifies service equipment reading in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ServiceEquipmentKey | ServiceEquipmentKey | N/A | N/A | The service equipment key object that uniquely identifies a piece of service equipment.
SequenceNumber | int | N/A | N/A | The sequence number of the service equipment reading instance.

Inherits from

ReferenceKey


ServiceEquipmentSummary

Description

A representation of the important details of service equipment within Microsoft Dynamics GP. A list of service equipment summary objects is returned by the GetServiceEquipmentList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | ServiceEquipmentKey | N/A | N/A | The service equipment key object that uniquely identifies a piece of service equipment.
CustomerKey | CustomerKey | N/A | N/A | The customer key object that uniquely identifies the customer of the service equipment.
AddressKey | AddressKey | N/A | N/A | The address key object that uniquely identifies the address of the service equipment.
StatusKey | ServiceStatusKey | N/A | N/A | The status key object that uniquely identifies the status of the service equipment.
InstallDate | dateTime | N/A | N/A | The date the service equipment was installed.


ServiceLaborLine

Description

Defines the properties for a service labor line of a service call line in the Field Service module in Microsoft Dynamics GP. Each service call can have a set of labor lines.

Properties

Property | Type | Length | Default | Description
BillableLaborPercent | Percent | N/A | The value will default from any contract or warranty attached to the current contract, otherwise it will default to 100. | The percent of the line that is billable to the customer.
BillableTime | int | N/A | 0 | The amount of time that should be billed for a labor line This value may vary from the TransactionTime field based on rounding or minimum labor settings. Values should be in portions of an hour. For example, a half hour would be 00030, while one hour would be 00100.
DistanceTraveled | ServiceDistanceTraveled | N/A | N/A | Details about the distance traveled by the technician for the service call.
EndDateTime | dateTime | N/A | N/A | The date and time on which the labor line ended.
Quantity | Quantity | N/A | 0 | The amount of labor required for the service call labor line.
QuantitySold | Quantity | N/A | 0 | The quantity of the line that was actually used. This is the value that will be transferred to the invoice during the service call billing process.
StartDateTime | dateTime | N/A | N/A | The date and time on which the labor line started.
TransactionTime | int | N/A | 0 | The actual time for a labor line. Values should be in portions of an hour. For example, a half hour would be 00030, while one hour would be 00100.
WorkTypeKey | ServiceWorkTypeKey | N/A | N/A | The work type key object that uniquely identifies the work type for the labor line.
TotalCost | MoneyAmount | N/A | N/A | The total cost of the line, which is the unit cost times the quantity sold. This property is read-only.
UseType | ServiceLaborUseType | N/A | N/A | Identifies the type of labor line. This property is read-only.

Inherits from

ServiceLine


ServiceLine

Description

Defines the common properties for a service line of a service document in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ServiceLineKey | N/A | N/A | The service line key object that uniquely identifies the line of the service document.
ItemKey | ItemKey | N/A | N/A | The item key object that uniquely identifies the item of the service line.
PriceLevelKey | PriceLevelKey | N/A | N/A | The price level key object that uniquely identifies the price level of the service line.
TechnicianKey | ServiceTechnicianKey | N/A | N/A | The technician key object that uniquely identifies the technician of the service line.
ItemDescription | string | 100 | Empty | The description of the item on the service line.
Note | string | 8000 | Empty | Note text for the service line.
UofM | string | 8 | Empty | The unit of measure for the service line.
EntryDateTime | dateTime | N/A | Defaults to system date | The date and time used to determine the exchange rate for the service line.
EquipmentLineSequence Number | int | N/A | 1 | The equipment line sequence number.
FrontOfficeIntegrationId | string | 50 | Empty | The front office integration ID.
TaxAmount | MoneyAmount | N/A | N/A | The applicable sales tax amount for the line. This property is read-only.
TotalAmount | MoneyAmount | N/A | N/A | The total price of the line, which is the unit price multiplied by the quantity sold.
UnitCost | MoneyAmount | N/A | N/A | The cost per unit of measure for the service line.
UnitPrice | MoneyAmount | N/A | N/A | The price per unit of measure for the service line.

Inherits from

BusinessObject


ServiceLineDetailKey

Description

Uniquely identifies service line detail in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ServiceLineKey | ServiceLineKey | N/A | N/A | The service line detail key object that uniquely identifies the line detail of the service call.
SequenceNumber | int | N/A | N/A | The sequence number of the service line detail instance.

Inherits from

TransactionKey


ServiceLineKey

Description

Uniquely identifies service line in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ServiceDocumentKey | ServiceDocumentKey | N/A | N/A | The service line key object that uniquely identifies the line of the service call.
LineSequenceNumber | int | N/A | N/A | The line sequence number of the service line instance.

Inherits from

TransactionKey


ServiceLinePurchaseOrderCreation

Description

Defines the properties related to the creation of a purchase order for a service line in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ConsolidateOnPO | boolean | N/A | False | The value true indicates that purchase order lines will be consolidated with other open purchase orders.
CreatePO | boolean | N/A | False | The value true indicates the purchase order will be created. The value false indicates it will not.
PromiseDate | dateTime | N/A | N/A | The promise date for the purchase order.
VendorKey | VendorKey | N/A | N/A | The vendor key object that uniquely identifies the vendor of the service call.


ServiceLot

Description

The properties specific to a service lot in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Quantity | Quantity | N/A | 0 | The quantity of the lot number for each lot detail line. If Quantity > 0 indicates add/update, < 0 indicates delete if exists.
ExpirationDate | dateTime | N/A | N/A | The date the lot item will expire.
LotNumber | string | 22 | Empty | The lot number for each lot detail line.
ManufactureDate | dateTime | N/A | N/A | The date the lot item was made.

Inherits from

ServiceSerialLot


ServicePartLine

Description

Defines the properties for a service part line of a service call document in the Field Service module in Microsoft Dynamics GP. Each service call document can have a set of part lines.

Properties

Property | Type | Length | Default | Description
BillablePartsPercent | Percent | N/A | The value will default from any contract or warranty attached to the current contract, otherwise it will default to 100. | The percent of the line that is billable to the customer.
Quantity | Quantity | N/A | 0 | The quantity of parts required for the service line.
QuantityBackordered | Quantity | N/A | 0 | The quantity of the parts line that is backordered.
ShipToAddressOption Type | ServiceAddressOptionTypes | N/A | Technician Site | Identifies the type of ship to address for the part line.
StatusCodeKey | ServiceCallStatusCodeKey | N/A | N/A | The status code key object that uniquely identifies the status code of the service line.
WarehouseKey | WarehouseKey | N/A | N/A | The warehouse key object that uniquely identifies the warehouse of the service line.
PurchaseOrder | ServiceLinePurchaseOrderCreation | N/A | N/A | The details related to the creation of a purchase order for the part line.
DoNotCreateReturnLine | boolean | N/A | False | Indicates whether or not to create returnable line for items that are set as returnable.
UseType | ServicePartUseType | N/A | N/A | Identifies the type of part line. This property is read-only.
MiscellaneousAddress Key | AddressKey | N/A | N/A | The miscellaneous address key object that uniquely identifies the miscellaneous address for the service line.

Inherits from

ServiceLine


ServiceQuote

Description

A service quote document in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Parts | ArrayOfServiceQuotePartLine | N/A | N/A | A collection of part lines.
Labor | ArrayOfServiceQuoteLaborLine | N/A | N/A | A collection of labor lines.
AdditionalCharges | ArrayOfServiceQuoteAdditionalChargeLine | N/A | N/A | A collection of additional charge lines.
Expenses | ArrayOfServiceQuoteExpenseLine | N/A | N/A | A collection of expense lines.
EquipmentCodes | ArrayOfServiceEquipmentCode | N/A | N/A | A collection of service equipment codes.

Inherits from

ServiceCallDocument


ServiceQuoteAdditionalChargeLine

Description

Defines the properties for an additional charge line of a service quote in the Field Service module in Microsoft Dynamics GP. Each service quote can have a set of additional charge lines.

Properties

Inherited from the base class

Inherits from

ServiceChargeLine


ServiceQuoteCriteria

Description

Specifies the set of criteria to use when retrieving a service quote object. Only service quote that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Inherited from the base class

Inherits from

ServiceCallDocumentCriteria


ServiceQuoteExpenseLine

Description

Defines the properties for an expense line of a service quote in the Field Service module in Microsoft Dynamics GP. Each service quote can have a set of expense lines.

Properties

Inherited from the base class

Inherits from

ServiceChargeLine


ServiceQuoteLaborLine

Description

Defines the properties for a labor line of a service quote in the Field Service module in Microsoft Dynamics GP. Each service quote can have a set of labor lines.

Properties

Inherited from the base class

Inherits from

ServiceLaborLine


ServiceQuotePartLine

Description

Defines the properties for a part line of a service quote in the Field Service module in Microsoft Dynamics GP. Each service quote can have a set of part lines.

Properties

Inherited from the base class

Inherits from

ServicePartLine


ServiceQuoteSummary

Description

A representation of the important details of service quote within Microsoft Dynamics GP. A list of service quote summary objects is returned by the GetServiceQuoteList method. The properties are read-only.

Properties

Property | Type | Length | Default | Description
ServiceTypeKey | ServiceTypeKey | N/A | N/A | The service type key object that uniquely identifies the type of the service quote.
TechnicianKey | ServiceTechnicianKey | N/A | N/A | The technician key object that uniquely identifies the technician of the service quote.
StatusCodeKey | ServiceCallStatusCodeKey | N/A | N/A | The status code key object that uniquely identifies the status code of the service quote.
DocumentTotal | MoneyAmount | N/A | N/A | The total price of the service quote, including all labor, parts, additional charge, expense and sales tax.

Inherits from

ServiceDocumentSummary


ServiceSerial

Description

The properties specific to a service serial in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
SerialNumber | string | 22 | Empty | The serial number for each serial detail line.
ServiceEquipmentKey | ServiceEquipmentKey | N/A | N/A | The service equipment key object that uniquely identifies a service equipment instance.

Inherits from

ServiceSerialLot


ServiceSerialLot

Description

The common properties for a service serial or service lot in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ServiceSerialLotKey | N/A | N/A | The service serial lot key object that uniquely identifies a service serial lot instance.
AuditTrailCode | string | N/A | N/A | The internally assigned audit trail code that gets saved on the record at the time the transaction is posted. This property is read-only.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove the service serial or lot.

Inherits from

SalesSerialLotBase


ServiceSerialLotKey

Description

Uniquely identifies a service serial lot in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
ServiceLineKey | ServiceLineKey | N/A | N/A | The service serial lot key object that uniquely identifies a service serial lot instance.
QuantityType | QuantityType | N/A | On Hand | The type of inventory that the current serial or lot number represents. Service uses only On Hand quantity types. This property is read-only.
SequenceNumber | int | N/A | N/A | System assigned value that differentiates between multiple serial or lot numbers within the same parts line. This value begins at 1 for the first serial number and increments by 1 for each additional lot number tracked for a single parts line. This property is read-only.

Inherits from

TransactionKey


ServiceStatusKey

Description

Uniquely identifies a service status in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 3 | Empty | The unique identifier assigned to the service status.

Inherits from

ReferenceKey


ServiceSummary

Description

A representation of the important details of a service item within Microsoft Dynamics GP. A list of service item summary objects is returned by the GetServiceList method.

Properties

Inherited from base class

Inherits from

ItemSummaryBase


ServiceTechnicianKey

Description

Uniquely identifies a service technician in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | The unique identifier assigned to the service technician.

Inherits from

ReferenceKey


ServiceTimeZoneKey

Description

Uniquely identifies a time zone in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 3 | Empty | The unique identifier assigned to the service time zone.

Inherits from

ReferenceKey


ServiceTypeKey

Description

Uniquely identifies a service type in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | The unique identifier assigned to the service type.

Inherits from

ReferenceKey


ServiceWarrantyCode

Description

The properties for a warranty code in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | ServiceWarrantyCodeKey | N/A | N/A | The service warranty code key object that uniquely identifies a warranty code.
StartDate | dateTime | N/A | Empty | The date the warranty goes into effect.
EndDate | dateTime | N/A | Empty | The date the warranty ends.

Inherits from

BusinessObject


ServiceWarrantyCodeKey

Description

Uniquely identifies a warranty code in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | The unique identifier assigned to the service warranty code.

Inherits from

ReferenceKey


ServiceWorkTypeKey

Description

Uniquely identifies a work type in the Field Service module in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 12 | Empty | The unique identifier assigned to the service work type.

Inherits from

ReferenceKey


ShippingMethod

Description

A shipping method object in Microsoft Dynamics GP. The properties for this object are read-only.

Properties

Property | Type | Length | Default | Description
Key | ShippingMethodKey | N/A | N/A | The shipping method key object that uniquely identifies a shipping method.
Description | string | 30 | N/A | A description of the shipping method.
PhoneNumber | PhoneNumber | 14 | N/A | The phone number for the shipping method.
Contact | string | 60 | N/A | The contact for the shipping method.
CarrierAccount | string | 15 | N/A | The account number that has been assigned to your company by the carrier.
Carrier | string | 30 | N/A | The carrier for the shipping method.
Type | ShippingMethodType | N/A | N/A | The type for the shipping method.
ModifiedBy | string | N/A | N/A | The user who last modified the shipping method information.
CreatedDate | dateTime | N/A | N/A | The date the shipping method was created.
ModifiedDate | dateTime | N/A | N/A | The last date the shipping method was modified.

Inherits from

BusinessObject


ShippingMethodChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of shipping method objects that have changed. Only changed shipping method key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
Id | BetweenRestrictionOfString | A string restriction specifying the shipping method.

Inherits from

BaseChangedKeyCriteria


ShippingMethodCriteria

Description

Specifies the criteria to use when retrieving a list of shipping method objects. Only shipping method objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | LikeRestrictionOfString | A string restriction specifying the ID for the shipping method.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the shipping method was created.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the shipping method was modified.

Inherits from

Criteria


ShippingMethodKey

Description

Uniquely identifies a shipping method object.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier assigned to the shipping method.

Inherits from

ReferenceKey


ShipToAddressKey

Description

Uniquely identifies a ship to address in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier assigned to the ship to address.

Inherits from

ReferenceKey


SickTime

Description

Contains sick time information for the employee.

Properties

Inherited from the base class

Inherits from

TimeAwayFromWork


Skill

Description

The common properties for a job skill in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Compensation | Compensation | N/A | N/A | A compensation object that provides compensation information associated with the job skill.
SkillKey | SkillKey | N/A | N/A | A key that uniquely identifies the job skill.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove job skill information.

Inherits from

BusinessObject


SkillCriteria

Description

Specifies the set of criteria to use when retrieving a list of skill objects. Only skill objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
SkillKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of a job skill.
CompensationPeriod | ListRestrictionOfNullableOfCompensationPeriod | A list restriction specifying the compensation period of a job skill.

Inherits from

Criteria


SkillKey

Description

Uniquely identifies a job skill in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | N/A | A string value that uniquely identifies a job skill.

Inherits from

ReferenceKey


SkillSet

Description

A collection of related job skills.

Properties

Property | Type | Length | Default | Description
AvailableSkills | int | N/A | Automatically set | Specifies the number of skills included in the skill set. This property is read-only.
SkillSetKey | SkillSetKey | N/A | N/A | The key that uniquely identifies the skill set.
Skills | ArrayOfSkill | N/A | N/A | A collection of job skill objects.

Inherits from

BusinessObject


SkillSetCriteria

Description

Specifies the set of criteria to use when retrieving a list of skill set objects. Only skill set objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
SkillSetKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of a skill set.

Inherits from

Criteria


SkillSetKey

Description

Uniquely identifies a skill set in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | N/A | A string value that uniquely identifies a skill set.

Inherits from

ReferenceKey


SkillSetSummary

Description

A representation of the important details of a skill set. The properties are read-only.

Properties

Property | Type | Length | Default | Description
SkillSetKey | SkillSetKey | N/A | N/A | The key that uniquely identifies the skill set.
AvailableSkills | int | N/A | N/A | Specifies the number of skills included in the skill set. This property is read-only.

Inherits from

BusinessObjectSummary


SourceDocumentKey

Description

Uniquely identifies a source document for a transaction.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | The indentifier asigned to the source document.

Inherits from

ReferenceKey


Spouse

Description

Contains information about the spouse of an employee.

Properties

Property | Type | Length | Default | Description
Name | string | 15 | Empty | The name of the spouse.
TaxIdentifier | string | 15 | Empty | The government issued tax number for the spouse. In the United States, this is the Social Security Number.


SupervisorKey

Description

Uniquely identifies a supervisor type within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 6 | Empty | The unique identifier assigned to the supervisor type.

Inherits from

ReferenceKey


SUTAStateKey

Description

The code for the state to which unemployment taxes will be paid for this employee.

Properties

Property | Type | Length | Default | Description
Id | string | 2 | Empty | The two-character code for the state.

Inherits from

ReferenceKey


Tax

Description

Defines common properties for sales tax information.

Properties

Property | Type | Length | Default | Description
TaxAmount | MoneyAmount | N/A | 0 | The tax amount.
TotalAmount | MoneyAmount | N/A | 0 | The total sales amount.
TaxableAmount | MoneyAmount | N/A | 0 | The total taxable sales amount.
IsBackoutTax | boolean | N/A | N/A | This property is read-only.

Inherits from

BusinessObject


TaxDetail

Description

A tax detail object in Microsoft Dynamics GP. Tax schedules can contain one or more tax detail objects.

Properties

Property | Type | Length | Default | Description
TaxDetailKey | TaxDetailKey | N/A | N/A | The tax detail key object that uniquely identifies a tax detail.
TaxDetailType | TaxDetailType | N/A | N/A | Specifies how the tax detail will be used.
TaxDetailDescription | string | 50 | Empty | A description of the tax detail.
Account | GLAccountNumberKey | N/A | N/A | The account associated with the tax detail.
TaxIdNumber | string | 15 | Empty | The tax ID number.
TaxDetailBase | TaxDetailBase | N/A | N/A | Specifies the calculation base.
TaxDetailPercent | decimal | N/A | 0.0 | The percentage the tax detail is based on.
TaxDetailAmount | MoneyAmount | N/A | 0 | The amount the tax detail is based on.
TaxDetailRounding | TaxDetailRounding | N/A | N/A | Specifies how tax calculations will be rounded.
TaxDetailBasedOnDetailKey | TaxDetailKey | N/A | Empty | The key of the base tax detail. This applies when the tax detail is based on another tax detail.
TaxDetailTaxableMinimum | MoneyAmount | N/A | 0 | The minimum amount taxable.
TaxDetailTaxableMaximum | MoneyAmount | N/A | 0 | The maximum amount taxable.
TaxDetailTaxMinimum | MoneyAmount | N/A | 0 | The minimum tax amount.
TaxDetailTaxMaximum | MoneyAmount | N/A | 0 | The maximum tax amount.
TaxDetailRangeType | TaxDetailRangeType | N/A | N/A | Indicates whether tax will be calculated on the full amount or the amount within the minimum and maximum range.
TaxDetailBaseQualifiers | TaxDetailBaseQualifiers | N/A | N/A | Specifies what the taxable minimum and maximum will be compared to when taxes are calculated.
IsTaxDetailTaxable | boolean | N/A | False | True indicates that other taxes will be calculated on this tax. False indicates this tax is not taxable.
IsTaxDetailPrintOnDocuments | boolean | N/A | False | True indicates a one-character code for the tax detail will be printed on reports. The code will appear next to the items being taxed.
TaxDetailPrintCharacter | string | 1 | Empty | The character to include on reports for items being taxed.
TaxDetailTaxablePercent | decimal | N/A | 0.0 | The percentage of the item price that is taxable.

Inherits from

BusinessObject


TaxDetailChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of tax detail objects that have changed. Only changed tax detail key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
TaxDetailKeyId | BetweenRestrictionOfString | A string restriction specifying the tax detail.

Inherits from

BaseChangedKeyCriteria


TaxDetailCriteria

Description

Specifies the criteria to use when retrieving a list of tax detail objects. Only tax detail objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
TaxDetailKeyId† | LikeRestrictionOfString | A string restriction specifying the ID for the tax detail.
TaxDetailType† | ListRestrictionOfNullableOfTaxDetailType | A list restriction specifying the type of the tax detail.
TaxIdNumber | LikeRestrictionOfString | A string restriction specifying the tax ID number for the tax detail.
TaxDetailTaxable | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the amount for the tax detail is taxable.

Inherits from

Criteria


TaxDetailKey

Description

Uniquely identifies a tax detail object.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The unique identifier assigned to the tax detail.

Inherits from

ReferenceKey


TaxSchedule

Description

A tax schedule in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
TaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that uniquely identifies a tax schedule.
TaxScheduleDescription | string | 30 | Empty | The description of the tax schedule.
Notes | string | 8000 | Empty | Notes for the tax schedule.

Inherits from

BusinessObject


TaxScheduleCriteria

Description

Specifies the criteria to use when retrieving a list of tax schedule objects. Only tax schedule objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
TaxScheduleKeyId† | LikeRestrictionOfString | A string restriction specifying the tax schedule ID.
TaxScheduleDescription | LikeRestrictionOfString | A string restriction specifying the tax schedule description.

Inherits from

Criteria


TaxScheduleDetail

Description

Contains properties of a tax detail that is part of a tax schedule.

Properties

Property | Type | Length | Default | Description
TaxScheduleDetailKey | TaxScheduleDetailKey | N/A | N/A | Identifies a tax detail that is part of a tax schedule.
TaxDetailBase | TaxDetailBase | N/A | N/A | Specifies the calculation base.
IsTaxDetailTaxable | boolean | N/A | False | True indicates that other taxes will be calculated on this tax. False indicates this tax is not taxable.
IsAutoCalculate | boolean | N/A | False | Indicates whether the tax is auto-calculated.

Inherits from

BusinessObject


TaxScheduleDetailChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of tax schedule detail objects that have changed. Only changed tax schedule detail key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
TaxScheduleDetailKeyId | BetweenRestrictionOfString | A string restriction specifying the tax schedule detail.
TaxDetailKeyId | BetweenRestrictionOfString | A string restriction specifying the tax detail.

Inherits from

BaseChangedKeyCriteria


TaxScheduleDetailCriteria

Description

Specifies the criteria to use when retrieving a list of tax schedule detail objects. Only tax schedule detail objects that match the specified criteria will be returned.

Properties

Property | Type | Description
TaxScheduleKeyId | LikeRestrictionOfString | A string restriction specifying the tax schedule.
TaxDetailKeyId | LikeRestrictionOfString | A string restriction specifying the tax detail.
TaxDetailBase | ListRestrictionOfNullableOfTaxDetailBase | A list restriction specifying the calculation base used for calculating tax.
IsTaxDetailTaxable | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the amount for the tax detail is taxable.
IsAutoCalculate | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the tax schedule is auto-calculated.

Inherits from

Criteria


TaxScheduleDetailKey

Description

Identifies a tax detail that is part of a tax schedule.

Properties

Property | Type | Length | Default | Description
TaxScheduleKey | TaxScheduleKey | 15 | Empty | The unique identifier assigned to the tax schedule.
TaxDetailKey | TaxDetailKey | 15 | Empty | The unique identifier assigned to the tax detail.

Inherits from

ReferenceKey


TaxScheduleKey

Description

Uniquely identifies a tax schedule in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The unique identifier assigned to the tax schedule.

Inherits from

ReferenceKey


Tenant

Description

A tenant that the current user has access to. The tenant specifies which installation of Microsoft Dynamics GP will be accessed.

Properties

Property | Type | Length | Default | Description
Name | string | 100 | N/A | The name of the tenant.
Description | string | SQL VarChar Maximum | N/A | The description of the tenant.


Terms

Description

Payment terms for a transaction.

Properties

Property | Type | Length | Default | Description
Discount | MoneyPercentChoice | N/A | 0 | The type and amount of the discount for the transaction. The discount can be a money amount or a percent.
DiscountAvailable Amount | MoneyAmount | N/A | 0 | The amount of discount available to be taken by the discount date when making payment on the transaction.
DueDate | dateTime | N/A | N/A | The date when payment is due for the transaction.
DiscountDate | dateTime | N/A | N/A | The date by which the discount may be deducted from the payment for the transaction.


TestKey

Description

Uniquely identifies a job test in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | N/A | A string value that uniquely identifies a job test.

Inherits from

ReferenceKey


TimeAndMaterial

Description

A project type in which the customer is billed for project costs as they are incurred.

Properties

Property | Type | Length | Default | Description
Item | Choice | N/A | N/A | A choice type that contains either a BillingRate, MarkupPercentage, or NoProfit amount.

Inherits from

Profit


TimeAwayFromWork

Description

Contains information about time away from work for an employee. Time away could be vacation time or sick time.

Properties

Property | Type | Length | Default | Description
DoesAutomaticallyAccrue | boolean | N/A | False | True specifies that the type of time away accrues automatically. False indicates it does not.
AccrualAmount | Quantity | N/A | 0 | The number of hours accrued for each pay period.
AccrualMethod | TimeAwayFromWorkAccrualMethod | N/A | Hours Worked | The method used to calculate the time away from work.
HoursPerYear | int | N/A | 0 | The number of hours of the type of time away from work that the employee receives in a year.
HoursAvailable | Quantity | N/A | 0 | The number of hours available of the type of time away from work.
WarnWhenHours AvailableFallsBelowZero | boolean | N/A | True | True specifies that a warning will be displayed in Microsoft Dynamics GP when the hours available of the type of time away from work falls below zero.


TotalProfit

Description

A project for which the profit is a flat amount.

Properties

Inherited from the base class

Inherits from

MoneyProfitCalculation


TransactionKey

Description

The base key object for transaction keys.

Properties

Inherited from the base class

Inherits from

GreatPlainsKey


UnionKey

Description

Uniquely identifies a union that an employee can belong to.

Properties

Property | Type | Length | Default | Description
Id | string | 30 | Empty | The unique identifier for the union.

Inherits from

ReferenceKey


UofMSchedule

Description

Define a unit of measure schedule in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | UofMScheduleKey | N/A | N/A | The UofM schedule key object that uniquely identifies a unit of measure schedule. This property is read-only.
Description | string | 30 | N/A | Description of the unit of measure schedule. This property is read-only.
BaseUofM | string | 8 | N/A | The unit of measure on which all other units of measure are based for the UofM schedule. This property is read-only.
UofMDecimalPlaces Quantities | QuantityDecimalPlaces | N/A | N/A | The number of decimal places for the UofM schedule. This property is read-only.
Details | ArrayOfUofMScheduleDetail | N/A | N/A | A collection of units of measure. This property is read-only.
LastModifiedDate | dateTime | N/A | Set to the system date | The last date the unit of measure schedule was modified. The time is in Coordinated Universal Time (UTC).
LastModifiedBy | string | N/A | N/A | Not implemented.

Inherits from

BusinessObject


UofMScheduleChangedKeyCriteria

Description

Specifies the criteria to use when retrieving a list of unit of measure schedule objects that have changed. Only changed unit of measure schedule key objects that match the specified criteria will be returned.

Properties

Property | Type | Description
UofMScheduleKeyId | BetweenRestrictionOfString | A string restriction specifying the unit of measure schedule.

Inherits from

BaseChangedKeyCriteria


UofMScheduleCriteria

Description

Specifies the criteria to use when retrieving a list of U of M schedule summary objects. Only U of M schedule summary objects that match the specified criteria will be returned.

Properties

Property | Type | Description
UnitofMeasureScheduleId | LikeRestrictionOfString | A string restriction specifying the ID for the unit of measure schedule.
LastModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the unit of measure schedule was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.

Inherits from

Criteria


UofMScheduleDetail

Description

Defines a unit of measure associated with a UofM schedule.

Properties

Property | Type | Length | Default | Description
Key | UofMScheduleDetailKey | N/A | N/A | The UofM schedule detail key object that uniquely identifies a unit of measure detail. This property is read-only.
UofM | string | 8 | N/A | A unit of measure. This property is read-only.
EquivalentUofM | string | 8 | N/A | The equivalent unit of measure. This property is read-only.
EquivalentUofMQuantity | Quantity | N/A | N/A | The quantity of the equivalent unit of measure. This property is read-only.
QuantityInBaseUofM | Quantity | N/A | N/A | The quantity in the base unit of measure. This property is read-only.
LongDescription | string | N/A | N/A | A description of the unit of measure. This property is read-only.
LastModifiedDate | dateTime | N/A | Set to the system date | The last date the unit of measure schedule was modified. The time is in Coordinated Universal Time (UTC).
LastModifiedBy | string | N/A | N/A | Not implemented.

Inherits from

BusinessObject


UofMScheduleDetailKey

Description

Uniquely identifies a unit of measure schedule detail.

Properties

Property | Type | Length | Default | Description
UofMScheduleKey | UofMScheduleKey | N/A | N/A | The UofM schedule key object that uniquely identifies a unit of measure schedule. This property is read-only.
SequenceNumber | int | N/A | N/A | The sequence number of the detail for the unit of measure schedule.

Inherits from

ReferenceKey


UofMScheduleKey

Description

Uniquely identifies a unit of measure schedule.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | N/A | The unique identifier assigned to the unit of measure schedule.

Inherits from

ReferenceKey


UofMScheduleSummary

Description

A representation of the important details of a unit of measure schedule within Microsoft Dynamics GP. A list of unit of measure schedule summary objects is returned by the GetUofMScheduleList method.

Properties

Property | Type | Length | Default | Description
Key | UofMScheduleKey | N/A | N/A | The UofM schedule key object that uniquely identifies a unit of measure schedule. This property is read-only.
Description | string | 30 | N/A | Description of the unit of measure schedule. This property is read-only.
BaseUofM | string | 8 | N/A | The unit of measure on which all other units of measure are based for the UofM schedule. This property is read-only.
UofMDecimalPlaces Quantities | QuantityDecimalPlaces | N/A | N/A | The number of decimal places for the UofM schedule. This property is read-only.
LastModifiedDate | dateTime | N/A | Set to the system date | The last date the unit of measure schedule was modified. The time is in Coordinated Universal Time (UTC).
LastModifiedBy | string | N/A | N/A | Not implemented.


UserAssignableBusinessObject

Description

Represents an entity in Microsoft Dynamics GP that has a specific user ID. Examples include customers or salespeople.

Properties

Property | Type | Length | Default | Description
BusinessObjectTypeId | guid | N/A | N/A | Uniquely identifies the user assignable business object type. Use the GetUserAssignableBusinessObjectList method to retrieve available types.
BusinessObjectType DisplayName | string | N/A | N/A | The display name of the user assignable business object.
IsKeyEqualToDisplayId | boolean | N/A | N/A | The value true indicates the DisplayId property of the object BusinessObjectSummary has the same value as the key for the corresponding base object.
SupportedContainment | SupportedContainment | N/A | N/A | Indicates where data for a specific business object type is located.


UserKey

Description

Uniquely identifies a user within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | Empty | The user name in Microsoft Dynamics GP.

Inherits from

ReferenceKey


Vacation

Description

Contains vacation information for the employee.

Properties

Inheritied from the base class

Inherits from

TimeAwayFromWork


ValidationError

Description

A set of information that describes a validation error.

Properties

Inherited from the base class

Inherits from

ValidationItem


ValidationItem

Description

Defines the common properties for validation errors and validation warnings.

Properties

Property | Type | Length | Default | Description
ObjectType | string | 100 | N/A | Specifies the type of business object.
PropertyNames | ArrayOfString | N/A | N/A | A collection of strings that specify the name of the property or properties that caused the validation error or warning.
Message | string | N/A | N/A | A text message that describes the validation error or warning.
Id | string | N/A | N/A | Identifies the validation error or warning.


ValidationResult

Description

A collection of ValidationError and ValidationWarning objects. ValidationResult is a property of LoggedExceptionData. The ValidationResult collection can be used to obtain detailed information about individual warnings or exceptions when a LoggedDataException’s BusinessObjectType property is ValidationException.

Properties

Property | Type | Length | Default | Description
Errors | ArrayOfValidationError | N/A | N/A | A collection of validation errors.
Warnings | ArrayOfValidationWarning | N/A | N/A | A collection of validation warnings.

Inherits from

ValidationItem


ValidationWarning

Description

A set of information that describes a validation warning.

Properties

Inherited from the base class

Inherits from

ValidationItem


Vendor

Description

A vendor within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | VendorKey | N/A | N/A | The vendor key object that uniquely identifies the vendor.
Name | string | 64 | Empty | The vendor name.
ShortName | string | 15 | A shortened version of the value supplied for the Name property. | A shortened version of the vendor name.
CheckName | string | 64 | The value supplied for the Name property | The name printed on checks.
IsOnHold | boolean | N/A | False | The vendor’s hold status. True indicates on hold. False indicates not on hold.
IsActive | boolean | N/A | False | The vendor’s status. True indicates active. False indicates inactive.
IsOneTime | boolean | N/A | False | A status designation indicating the vendor is a one-time or temporary vendor. True indicates a temporary vendor. False indicates the vendors is not a temporary vendor.
ClassKey | VendorClassKey | N/A | Empty | The vendor class key that specifies the vendor class.
DefaultAddressKey | VendorAddressKey | N/A | N/A | The vendor address key that specifies the primary address for the vendor.
PurchaseAddressKey | VendorAddressKey | N/A | N/A | The vendor address key that specifies the vendor’s address for making purchases.
RemitToAddressKey | VendorAddressKey | N/A | N/A | The vendor address key that specifies the address used to remit payments to the vendor.
ShipFromAddressKey | VendorAddressKey | N/A | N/A | The vendor address key that specifies the address where vendor shipments originate.
VendorAccountNumber | string | 20 | Empty | The account number assigned to you by the vendor.
Comment1 | string | 30 | Empty | Commnet field 1.
Comment2 | string | 30 | Empty | Comment field 2.
Notes | string | 8000 | Empty | Text for the record-level note for the vendor.
CurrencyKey | CurrencyKey | N/A | Empty | The currency key object that specifies the ID of the currency typically used for the vendor.
RateTypeKey | RateTypeKey | N/A | Empty | The rate type key object that specifies the rate type the vendor typically uses.
PaymentTermsKey | PaymentTermsKey | N/A | Empty | The payment terms key that specifies the the payment terms provided by the vendor.
DiscountGracePeriod | int | N/A | 0 | The discount grace period (in days) allowed by the vendor. The maximum value is 99.
DueDateGracePeriod | int | N/A | 0 | The due date grace period (in days) allowed by the vendor. The maximum value is 99.
PaymentPriority | string | 3 | Empty | Indicates the priority assigned to the vendor’s vouchers.
MinimumOrderAmount | MoneyAmount | N/A | N/A | A money amount object that specifies the minimum amount required for an order.
TradeDiscountPercent | Percent | N/A | 0 | A percent object that specifies the discount offered by the vendor.
TaxSchedule | string | 15 | Empty | Specifies the tax schedule to use on sales transactions for the default address.
TaxIdentificationNumber | string | 11 | Empty | The tax identification number for the vendor.
TaxRegistrationNumber | string | 25 | Empty | The tax registration number for the vendor.
BankAccountKey | BankAccountKey | N/A | Empty | The bank account key object that specifies the ID of the checkbook used to pay the vendor.
UserDefined1 | string | 20 | Empty | A user-defined field.
UserDefined2 | string | 20 | Empty | A user-defined field.
Tax1099Type | Tax1099Type | N/A | None | Indicates the type of tax information to be reported to the US Internal Revenue Service.
Tax1099BoxNumber | int | N/A | N/A | Specifies the 1099 box number associated with 1099 tax type of the vendor.
FreeOnBoard | FreeOnBoard | N/A | None | Indicates the point at which ownership of goods passes to the buyer.
UserLanguageKey | LanguageKey | N/A | Empty | Indicates the language used by the vendor.
MinimumPayment | MoneyPercentChoice | N/A | No minimum payment | The type and amount of the minimum payment required by the vendor. The minimum payment amount can be a money amount or a percent.
MaximumInvoice | MaximumInvoice | N/A | No maximum invoice | The maximum invoice object that specifies the maximum invoice amount.
CreditLimit | VendorCreditLimit | N/A | Unlimited | The vendor credit limit object that specifies the available credit limit.
MaximumWriteoff | MaximumWriteoff | N/A | Unlimited | Specifies whether writeoffs are allowed by the vendor, and what the maximum amount of the writeoff can be.
AllowRevaluation | boolean | N/A | True | Specifies whether the vendor will be included when revaluing multicurrency documents. True specifies the vendor will be included. False specifies the vendor will not be included.
PostResultsTo | PayablesPostResultsTo | N/A | Payable/Discount account | Specifies where to post the revaluation results.
HistoryOptions | HistoryOptions | N/A | Maintain history for all types | The history options object that specifies which types of history are maintained for the vendor.
DefaultCashAccountType | PayablesCashAccountType | N/A | Checkbook | Specifies the cash account to be used for the vendor’s transactions.
CashGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which cash amounts for the vendor will be posted.
AccountsPayableGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which payable amounts for the vendor will be posted.
TermsDiscountAvailable GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which available terms discounts amounts for the vendor will be posted.
TermsDiscountTakenGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which terms discounts taken amounts for this vendor will be posted.
FinanceChargesGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which finance charges amounts for the vendor will be posted.
PurchasesGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which purchase amounts for the vendor will be posted.
TradeDiscountGLAccount Key | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which trade discounts amounts for the vendor will be posted.
MiscellaneousGLAccount Key | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which miscellaneous amounts for the vendor will be posted.
FreightGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which freight amounts for the vendor will be posted.
TaxGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which tax amounts for the vendor will be posted.
WriteoffGLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which writeoff amounts for the vendor will be posted.
AccruedPurchasesGL AccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which accrued purchase amounts for the vendor will be posted.
PurchasePriceVariance GLAccountKey | GLAccountNumberKey | N/A | N/A | The GL account number key object that specifies the account to which purchase price variance amounts for the vendor will be posted.
CreatedDate | dateTime | N/A | Current system date | The date the vendor was created.
ModifiedDate | dateTime | N/A | Current system date | The date the vendor was modified. The value is in Coordinated Universal Time (UTC).
ProjectAccounting Options | ProjectAccountingOptions | N/A | N/A | The project accounting options object that specifies the vendor’s default entries for purchase order format, profit, and unit cost.
Addresses | ArrayOfVendorAddress | N/A | Empty | An array containing the vendor’s various addresses.
WorkflowPriority | WorkflowPriority | N/A | N/A | WorkflowPriority enumeration value specifying the workflow priority associated with the vendor.
Workflows | ArrayOfWorkflow | N/A | N/A | A collection of workflow objects associated with the vendor.
Language | string | N/A | N/A | Specifies the language for the vendor.

Inherits from

BusinessObject


VendorAddress

Description

A set of address information for a vendor in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | VendorAddressKey | N/A | N/A | The vendor address key object that uniquely identifies the set of address information.
DeleteOnUpdate | boolean | N/A | False | Set this flag to True when calling the Update operation to remove vendor address information.

Inherits from

ConstituentAddress


VendorAddressCriteria

Description

Specifies the criteria to use when retrieving a list of vendor address summary objects. Only vendor address summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Scope | VendorScope | A property in criteria used to determine the level of filtering to be used when returning vendor address data.
VendorAddressKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the vendor address object.
VendorKeyId† | LikeRestrictionOfString | A string restriction specifying the ID of the vendor.
PhoneNumber | LikeRestrictionOfString | A string restriction specifying a telephone number.
Address | LikeRestrictionOfString | A string restriction specifying address information.
City† | LikeRestrictionOfString | A string restriction specifying a city.
State† | LikeRestrictionOfString | A string restriction specifying a state.
PostalCode† | LikeRestrictionOfString | A string restriction specifying a postal code.

Inherits from

Criteria


VendorAddressKey

Description

Uniquely identifies a set of address information for a vendor.

Properties

Property | Type | Length | Default | Description
VendorKey | VendorKey | N/A | N/A | The vendor key object that uniquely identifies a vendor.
Id | string | 15 | Empty | Specifies the ID of a set of address information for a vendor.

Inherits from

ReferenceKey


VendorAddressSummary

Description

A representation of the important details of a vendor address. The properties are read-only.

Properties

Property | Type | Length | Default | Description
Key | VendorAddressKey | N/A | N/A | The vendor address key object that uniquely identifies the set of address information.

Inherits from

BusinessAddress


VendorClassKey

Description

Uniquely identifies a vendor class in Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | Empty | The unique identifier assigned to the vendor class.

Inherits from

ReferenceKey


VendorCreditLimit

Description

Defines the credit limit information for a vendor.

Properties

Inherited from the base class

Inherits from

CreditLimit


VendorCriteria

Description

Specifies the criteria to use when retrieving a list of vendor summary objects. Only vendor summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Id† | BetweenRestrictionOfString | A string restriction specifying the ID of the vendor.
Name† | LikeRestrictionOfString | A string restriction specifying the name of the vendor.
ClassId† | LikeRestrictionOfString | A string restriction specifying the class associated with the vendor.
IsOnHold | RestrictionOfNullableOfBoolean | A boolean restriction specifying the hold status of the vendor.
IsActive | RestrictionOfNullableOfBoolean | A boolean restriction specifying the active status of the vendor.
IsOneTime | RestrictionOfNullableOfBoolean | A boolean restriction specifying whether the vendor is short-term.
State† | LikeRestrictionOfString | A string restriction specifying the state for the vendor.
PhoneNumber | LikeRestrictionOfString | A string restriction specifying the phone number of the vendor.
CreatedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the vendor was created.
ModifiedDate | BetweenRestrictionOfNullableOfDateTime | A date/time restriction specifying the date the vendor was modified. The value is in Coordinated Universal Time (UTC). Both the date and time portions of the value must be specified for the criteria.
Scope | VendorScope | A property in criteria used to determine the level of filtering to be used when returning vendor data.

Inherits from

Criteria


VendorKey

Description

Uniquely identifies a vendor object.

Properties

Property | Type | Length | Default | Description
Id | string | 15 | N/A | The unique identifier assigned to the vendor.

Inherits from

ReferenceKey


VendorManufacturingOrder

Description

The collection of manufacturing order route step objects associated with a vendor manufacturing order.

Properties

Property | Type | Length | Default | Description
Route | ArrayOfManufacturingOrderRouteStep | N/A | N/A | A collection of manufacturing order route step objects.

Inherits from

ManufacturingOrderDocument


VendorManufacturingOrderCriteria

Description

Specifies the criteria to use when retrieving a list of vendor manufacturing order summary objects. Only vendor manufacturing order summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
VendorKeyId | LikeRestrictionOfString | A string restriction specifying the ID of a vendor.
Scope | VendorManufacturingOrderScope | A property in criteria used to determine the level of filtering to be used when returning vendor manufacturing order data.

Inherits from

ManufacturingOrderDocumentCriteria


VendorManufacturingOrderSummary

Description

A representation of the important details of a vendor manufacturing order document in Microsoft Dynamics GP. The properties are read-only.

Properties

Inherited from the base class

Inherits from

ManufacturingOrderDocumentSummary


VendorPlannedOrder

Description

Defines the properties of a planned order associated with a vendor.

Properties

Inherited from the base class

Inherits from

PlannedOrder


VendorPlannedOrderCriteria

Description

Specifies the set of criteria to use when retrieving a list of vendor planned order summary objects. Only vendor planned order summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
Scope | VendorPlannedOrderScope | A property in criteria used to determine the level of filtering to be used when returning vendor planned order data.

Inherits from

PlannedOrderCriteriaBase


VendorPlannedOrderSummary

Description

A representation of the important details of a vendor planned order. The properties are read-only.

Properties

Inherited from the base class

Inherits from

PlannedOrderSummary


VendorSummary

Description

A representation of the important details of a vendor within Microsoft Dynamics GP. A list of vendor summary objects is returned by the GetVendorList method.

Properties

Property | Type | Length | Default | Description
Key | VendorKey | N/A | N/A | The vendor key object that uniquely identifies the vendor.
Name | string | 64 | Empty | The vendor name.
ClassKey | VendorClassKey | N/A | Empty | The vendor class key object that specifies the vendor class.
State | string | 29 | Empty | The vendor’s state.
PhoneNumbers | ArrayOfPhoneNumber | N/A | Empty | An array containing the vendor’s various telephone numbers.
CreatedDate | dateTime | N/A | Current system date | The date the vendor was created.
ModifiedDate | dateTime | N/A | Current system date | The date the vendor was modified.
IsOnHold | boolean | N/A | False | The vendor’s hold status. True indicates on hold. False indicates not on hold.
IsActive | boolean | N/A | False | The vendor’s status. True indicates active. False indicates inactive.
IsOneTime | boolean | N/A | False | A status designation indicating the vendor is a one-time or temporary vendor. True indicates a temporary vendor. False indicates the vendors is not a temporary vendor.


Warehouse

Description

A warehouse (site) within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | WarehouseKey | N/A | N/A | The warehouse key object that uniquely identifies the warehouse.
Description | string | 30 | Empty | The description of the warehouse.
Address | InternationalAddress | N/A | N/A | The address key object that specifies the address of the warehouse.
SalesTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that specifies the tax schedule used for sales.
PurchaseTaxScheduleKey | TaxScheduleKey | N/A | N/A | The tax schedule key object that specifies the tax schedule used for purchases.
IncludeInPlanning | boolean | N/A | True | Specifies whether goods and services at the warehouse should be included in planning decisions.
Bins | ArrayOfWarehouseBin | N/A | N/A | An array containing the warehouse bin objects for the warehouse.

Inherits from

BusinessObject


WarehouseBin

Description

A warehouse (site) bin within Microsoft Dynamics GP.

Properties

Property | Type | Length | Default | Description
Key | WarehouseBinKey | N/A | N/A | The warehouse bin key object that uniquely identifies a bin.

Inherits from

BusinessObject


WarehouseBinKey

Description

Uniquely identifies a bin for a warehouse (site).

Properties

Property | Type | Length | Default | Description
WarehouseKey | WarehouseKey | N/A | N/A | The warehouse key object that uniquely identifies a warehouse
Bin | string | 15 | N/A | The unique identifier assigned to a bin.

Inherits from

ReferenceKey


WarehouseCriteria

Description

Specifies the criteria to use when retrieving a list of warehouse (site) summary objects. Only warehouse summary objects that match the specified criteria will be returned. For the best performance, create criteria that uses only the properties marked with the dagger (†). These properties correspond to indexed columns in the database.

Properties

Property | Type | Description
WarehouseId† | LikeRestrictionOfString | A string restriction specifying the ID of the warehouse.
Description† | LikeRestrictionOfString | A string restriction specifying the description of the warehouse.
AddressLine1 | LikeRestrictionOfString | A string restriction specifying the address of the warehouse.
City | LikeRestrictionOfString | A string restriction specifying the city of the warehouse.
State | LikeRestrictionOfString | A string restriction specifying the state for the warehouse.
PostalCode | LikeRestrictionOfString | A string restriction specifying the postal code of the warehouse.
CountryRegion | LikeRestrictionOfString | A string restriction specifying the country for the warehouse.

Inherits from

Criteria


WarehouseKey

Description

Uniquely identifies a warehouse (site) object.

Properties

Property | Type | Length | Default | Description
Id | string | 10 | N/A | The unique identifier assigned to a warehouse.

Inherits from

ReferenceKey


WarehouseSummary

Description

A representation of the important details of a warehouse (site) within Microsoft Dynamics GP. A list of warehouse summary objects is returned by the GetWarehouseList method.

Properties

Property | Type | Length | Default | Description
Key | WarehouseKey | N/A | N/A | The warehouse key object that uniquely identifies the warehouse.
Description | string | 30 | Empty | The description of the warehouse.
AddressLine1 | string | 30 | Empty | The warehouse’s address.
City | string | 30 | Empty | The warehouse’s city.
State | string | 4 | Empty | The warehouse’s state.
PostalCode | string | 10 | Empty | The warehouse’s postal code.
CountryRegion | string | 20 | Empty | The warehouse’s country or region.


WorkersCompensationKey

Description

Uniquely identifies workers compensation information for a project or an employee.

Properties

Property | Type | Length | Default | Description
Id | string | 6 | Empty | The unique identifier for the workers compensation information.

Inherits from

Key


Workflow

Description

Provides the underlying storage and capabilities for workflow object types that derive from it.

Properties

Inherited from the base class

Inherits from

BusinessObject


Enumeration reference

The enumeration reference provides details of each enumeration in the Microsoft Dynamics GP web service. Each enumeration is described, along with the list of values included in it.


ABCCode

Description

Specifies analysis codes to assign to an item for inventory control purposes.

Constant | Description
None | None
A | "A" items are the most important items in your inventory. They should be tightly controlled, with accurate records.
B | "B" items might be less controlled, with good records.
C | "C" items might have minimal records with periodic review.


AgeCode

Description

Specifies the age category of a job applicant.

Constant | Description
Eighteen - Twenty-five | Applicant is between eighteen and twenty-five years old.
Twenty-six - Thirty-five | Applicant is between twenty-six and thirty-five years old.
Thirty-six - Forty-five | Applicant is between thirty-six and forty-five years old.
Forty-six - Fifty-five | Applicant is between forty-six and fifty-five years old.
Over Fiftyfive | Applicant is fifty-six years old or older.
Unknown | The applicant age is unknown.
Under Seventeen | The applicant is seventeen years old or younger.


ApplicationColorCode

Description

The color code used to categorize job applicants.

Constant | Description
Blue | Blue
Green | Green
Yellow | Yellow
Red | Red
N/A | Not applicable


ApplicationReferenceSource

Description

Specifies how an applicant learned of a job opportunity.

Constant | Description
Word of Mouth | The applicant was referred by word of mouth.
Referred to by an Employee | The applicant was referred by a current employee of this organization.
Referred to by an Agency | The applicant was referred by an agency.
Newspaper | The applicant saw a newspaper advertisement.
Other | The applicant was referred by another source.
Internet | The applicant saw an Internet advertisement.


ApplicationRejectionReason

Description

Specifies the reason an applicant was rejected.

Constant | Description
Testing | The applicant was rejected because of test results.
Interview | The applicant was rejected because of an interview.
References | The applicant was rejected because of references.
Experience | The applicant was rejected because of experience.
Education | The applicant was rejected because of education.
Other | The applicant was rejected because of some other reason.


ApplicationStatus

Description

Specifies the current status of a job application.

Constant | Description
Active | The application is active.
Open | The application is open.
Rejected | The application has been rejected for the position.
Hired | The application has been hired as an employee.
Other | The application has some other status.


ApprovalWorkflowStatus

Description

Specifies the status of a document in the workflow process within Microsoft Dynamics GP.

Constant | Description
Not Submitted | Not submitted to the workflow process.
Submitted | Submitted to the workflow process.
No Approval Needed | No approval needed.
Pending Approval | Pending approval.
Pending Changes | Pending changes.
Approved | Approved.
Rejected | Rejected.
Workflow Ended | Approval workflow is ended.
Not Enabled | Approval workflow is not enabled.
Disabled | Approval workflow is disabled.


BalanceType

Description

Specifies whether a customer has an open item or balance forward account with your company.

Constant | Description
Open Item | Individual transaction information is saved and detailed on customer statements until the transaction is removed through paid transaction removal.
Balance Forward | Transaction information is retained only for the current period, and is consolidated into an account total that is brought forward at the beginning of each subsequent period.


BillingStatus

Description

Specifies the billing status of a transaction line in the Project Accounting module within Microsoft Dynamics GP.

Constant | Description
Billable | The transaction is billable.
In Process | The transaction is in the process of being billed.
Closed | The billing for the transaction is closed.
No Billing | The transaction has no billing.
Fixed Fee Transaction | The transaction is a fixed fee transaction.


BillingType

Description

Specifies how the cost will be charged to customers of a transaction line in the Project Accounting module within Microsoft Dynamics GP.

Constant | Description
Standard | Details from cost transactions and the billing amounts can be printed on billing invoices.
No Charge | Details from cost transactions can be printed on billing invoices. The billing amounts will be zero.
No Billing | Neither details from cost transactions nor billing amounts will be printed on billing invoices.


BOMCategory

Description

Specifies how a bill of materials will be used.

Constant | Description
MFG BOM | Manufacturing bill of materials.
ENG BOM | Engineering bill of materials.
ARCH BOM | Archived bill of materials.
CONFIG BOM | Configured bill of materials.


BusinessExceptionType

Description

Specifies the source of an exception.

Constant | Description
ValidationException | The exception occurred while validating data in an object.
SystemException | The exception occurred while querying or updating Microsoft Dynamics GP.


CashAccountFromType

Description

Specifies where to post the net pay for an employee when a pay run is performed.

Constant | Description
Checkbook | Net pay is posted to an account for a checkbook.
Employee | Net pay is posted to an account for the employee.


CashReceiptScope

Description

Used to determine the level of filtering to be used when returning cash receipt data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on CustomerId | The value for the criteria property “Id” will be set to the back office customer ID mapped to the current user. The current user is specified by the Context object.


CashReceiptType

Description

Specifies the type of cash receipt.

Constant | Description
Check | The cash receipt is a check.
Cash | The cash receipt is cash.
Payment Card | The cash receipt is a payment card.


CommissionBasedOn

Description

Specifies how a salesperson's commissions will be calculated.

Constant | Description
Sales | Commissions will be calculated as a percentage of the sale amount.
Document Total | Commissions will be calculated as a percentage of the invoice total, including the sale amount, freight, taxes, and miscellaneous charges.


CompanyOptions

Description

Specifies the various options available for a company.

Constant | Description
UseShippingMethodWhenSelectingDefaultTaxSchedule | This option determines whether or not you want to use the shipping method when selecting the default tax schedule on a transaction. Microsoft Dynamics GP calculates taxes at the point of exchange, using the shipping method assigned to a transaction to determine the point of exchange. The shipping method will determine which tax schedule appears as a default schedule for the transaction. If you decided not to use the shipping method to determine the default tax schedule, the tax schedule assigned to the vendor's purchase address or the customer's ship to address will be the default tax schedule.
CalculateTermsDiscountBeforeTaxes | Will apply taxes to only the discounted amount, regardless of when the payment is actually made.
EnableIntrastatTracking | This option will allow the user to enable entering Intrastat information that is required for members of the European Union. The Intrastat Trade Report is used to report this information.
SeparatePaymentDistributions | This option allows the user to separate document and payment distributions entered on the same transaction as if the document and payment were entered as separate transactions. You will be able to enter multiple distributions with the same distribution type and account.
MergeTradeDiscountAndMarkdownDistributionsInSales | This option will merge the trade discount and markdown distributions with the sales distributions.
MergeTradeDiscountDistributionsInPurchasing | This option will merge the trade discount distributions with the purchase distributions.
CalculateTaxRebates | This option will allow correcting tax amounts for a transaction with a terms discount.
EnablePostingNumbersInGeneralLedger | This option will assign each transaction a unique sequence number during posting, in addition to the journal entry number. Use this option if you want solid numbering of transactions, without gaps. Solid numbering is a legal requirement in some countries, for auditing purposes.
AllowNegativeDebitsAndCreditsInGeneralLedger | This option will allow distributions as negative amounts to reverse or correct transactions. In some countries financial statements are used not only to keep account balances, but the totals for each account's debit and credit. By marking this option, the totals for each account's debit and credit won't be overstated. When voiding transactions in Receivables Management and Payables Management, negative debit and credit distributions are posted to General Ledger. This option is available only for the following countries: Czech Republic, Poland, Germany, Belgium, Luxembourg, Singapore/Hong Kong SAR, South Africa, UAE/Saudi Arabia, Colombia, and Portugal.
EnableGstForAustraliaAndNewZealand | This option will be marked by default if you chose Australia as your country when installing Microsoft Dynamics GP.
EnableTaxDate | This option will allows you to specify a tax date for documents.
EnableShippingDocumentInSalesOrderProcessing | This option supports shipping documents in the Sales Order Processing module.
EnableReversingChargeTaxes | The option will allow reverse charge tax detail IDs. You'll be able to assign reverse charge tax details to transactions in Receivings Management, Payables Management, Purchase Order Processing, Sales Order Processing and Invoicing. Reverse charge tax information also will be printed on tax reports.
CalculateTaxesInGeneralLedger | This option will calculate taxes in General Ledger. For example, a taxable reimbursement to an employee could be entered in General Ledger, rather than in Payables Management.
AllowSummaryLevelTaxEdits | This option will allow edits to tax information in the tax summary windows.
RequireTaxDetailTotalsToMatchThePretaxAmount | This option will require the pre-tax amount to be fully distributed among the tax details of the transaction. When tax details are required to match the pre-tax amount, you'll have to assign tax schedules so taxes are calculated or enter a tax detail during transaction entry so the goods value matches pre-tax amount. When this option is marked, you are required to enter a zero percent tax detail in the Tax Detail for System Processes field for receivables and payables documents that are automatically generated within the system. The pre-tax amount is the sale or purchase amount (less any trade discount) plus freight and miscellaneous charges. If the module you're working with is set up to calculate terms discounts before taxes, the discount available amount is deducted from the pre-tax amount.
SpecifyTaxDetailsForAutomaticTaxCalculation | Specify whether or not you want specific tax details to calculate tax.
EnableVatReturn | This option will generate summary and detailed Value-added Tax (VAT) information for a specified period, helping to meet governmental VAT reporting requirements.
EnableEuropeanUnionTransactionTracking | This option will allow a user to indicate whether a transaction is an EU transaction without using Intrastat Statistics. The vendor's or customer's tax registration number will be printed on documents.
EnableEuropeanElectronicFundsTransfer | This option will allow a user to enter electronic funds transfers for manual payments and computer checks in Payables Management. You'll be able to setup electronic funds transfer information for your checkbooks, vendors and customers. When bank transfers are entered, the cash-in-transit account from the checkbook is used instead of the cash account. When this option is marked, fields and windows used for Electronic Funds Transfers become available. You must be using the European Direct Debits solution for the electronic funds transfer information entered in Receivables Management. You can't mark the Enable European Electronic Funds Transfer option if you are using another electronic funds transfer solution.
EnablePayablesElectronicFundsTransfer | This option will allow a user to enter electronic funds transfers for manual payments and computer checks in Payables Management. You'll be able to setup electronic funds transfer information for your checkbooks, vendors and customers. When bank transfers are entered, the cash-in-transit account from the checkbook is used instead of the cash account.
EnableCanadianTaxDetail | This option will allow a user to select the tax detail posting account and to view the amounts inclusive of tax in the Receivables Management, Sales Order Processing, and Purchase Order Processing.


CompensationPeriod

Description

Specifies the periods you use to calculate compensation amounts for a job skill.

Constant | Description
Undefined | The compensation period is not defined.
Hourly | Paid per hour.
Weekly | Paid once a week.
Biweekly | Paid every two weeks.
Semimonthly | Paid twice a month.
Monthly | Paid once a month.
Quarterly | Paid four times a year.
Semiannually | Paid twice a year.
Annually | Paid once a year
Daily/Miscellaneous | Paid daily or another unspecified time period.


CostOfGoodsSoldAccountSource

Description

Specifies which cost of goods sold account to use for sales transactions for a kit item.

Constant | Description
From Component Item | Use the cost of goods sold account from each component.
From Kit Item | Use the cost of goods sold account from the kit item.


CreditLimitSpecialAmount

Description

Specifies the customer or vendor credit limit when not a specific amount.

Constant | Description
No Credit | The customer or vendor has no credit.
Unlimited Credit | The customer or vendor has unlimited credit.


CurrencyDecimalPlaces

Description

Specifies the number of decimal places for a currency.

Constant | Description
Zero | No decimals places.
One | One decimal place.
Two | Two decimal places.
Three | Three decimal places.
Four | Four decimal places.
Five | Five decimal places.


CurrencyType

Description

Specifies the currency type to be used when retrieving an amount property.

Constant | Description
Transactional | The transaction currency (originating) amount will be returned.
Local | The local currency (functional) amount will be returned.


CustomerScope

Description

Used to determine the level of filtering to be used when returning customer data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Customer Id | The value for the criteria property “Id” will be set to the back office customer ID mapped to the current user. The current user is specified by the Context object.
Return Based on Salesperson Id | The value for the criteria property “SalespersonId” will be set to the back office salesperson ID mapped to the current user. The current user is specified by the Context object.


DataModificationAction

Description

Used to indicate what modification was applied to an object in Microsoft Dynamics GP.

Constant | Description
Created | The object was created.
Updated | The object was updated.
Deleted | The object was deleted.


DecimalPlaces

Description

Specifies the number of decimal places.

Constant | Description
Zero | No decimals places.
One | One decimal place.
Two | Two decimal places.
Three | Three decimal places.
Four | Four decimal places.
Five | Five decimal places.


DecimalSymbol

Description

Specifies the symbol for separating decimal amounts for the currency.

Constant | Description
Space | A space will be used to separate decimal amounts.
Period | A period will be used to separate decimal amounts.
Comma | A comma will be used to separate decimal amounts.
Dollar Symbol | A dollar sign will be used to separate decimal amounts.


DiscountDateBasedOn

Description

Specifies how to determine when the payment must be made for a discount to be given.

Constant | Description
Days | The terms discount is applied when the payment is made within a certain number of days after the invoice date.
Date | The terms discount is applied when the payment is made by a specific date.
EOM | The terms discount is applied if the payment is made by the end of the month in which the invoice date occurs.
None | There is no terms discount option available.


DueDateBasedOn

Description

Specifies how to determine the date when the full payment is due.

Constant | Description
Net Days | The payment is due by a certain number of days after the invoice date.
Date | The payment is due by a certain date.
EOM | The payment is due in full by the end of the month in which the purchase occurs.
None | The payment isn't due on any specific date.
Next Month | The payment is due on the 20th of the month following the document date.


EmployeeBaseStepIncreasedOn

Description

Specifies when a pay step increase occurs.

Constant | Description
Hire Date | The date the employee was hired.
Adjusted Hire Date | A hire date that has been changed to account for time away from the job.
Seniority Date | The date of the employee entered into a union.
Manual | The date was manually selected.


EmployeePayTypes

Description

Specifies the pay type for an employee.

Constant | Description
Hourly | Paid by the hour.
Salary | Paid a specific amount each pay period.
Piecework | Paid per unit made or completed.
Commission | Paid according to what and how much an employee sells.
Business Expense | Used to track the records of employees who are reimbursed for mileage and travel expenses.
Overtime | The employee is paid for working more than the assigned number of hours and is paid at different pay rates for the additional hours.
Double Time | The employee qualifies for double-time pay.
Vacation | The employee receives pay while on vacation.
Sick | The employee receives pay while sick.
Holiday | The employee receives paid time off during holidays.
Pension | The employee is retired and receives pension pay from the company.
Other | Used to classify additional types of pay.
Earned Income Credit | The employee qualifies for the earned income credit and has filed a W-5 form.
Charged Tips | The employee receives tips from customers through a charge card or check.
Reported Tips | The employee receives cash tips from customers.
Minimum Wage Balance | The employee must earn a specified minimum hourly amount. Available only for Charged Tips and Reported Tip pay types.


EmployeeScope

Description

Used to determine the level of filtering to be used when returning employee data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Employee Id | The value for the criteria property “Id” will be set to the back office employee ID mapped to the current user. The current user is specified by the Context object.


EmployeeTipType

Description

Specifies how an employee receives tip pay.

Constant | Description
Directly | The employee receives tips directly from the customer.
Indirectly | The employee does not receive tips directly from the customer.


EmploymentType

Description

The type of employment for the employee.

Constant | Description
Full Time Regular | Full Time Regular
Full Time Temporary | Full Time Temporary
Part Time Regular | Part Time Regular
Part Time Temporary | Part Time Temporary
Intern | Intern


Ethnicity

Description

Specifies the ethnicity of a person, such as an employee.

Constant | Description
White | White
American Indian or Alaskan Native | American Indian or Alaskan Native
Black or African American | Black or African American
Asian | Asian
Hispanic or Latino | Hispanic or Latino
Two or more races | Two or more races
N/A | Not applicable
Native Hawaiian or Pacific Islander | Native Hawaiian or Pacific Islander


ExpenseType

Description

Specifies the type of project employee expense.

Constant | Description
Reimbursable | The employee expense is reimbursable.
Personal Expense | The employee expense is a personal expense and will not be reimbursed.


FeeType

Description

Specifies the type of fee the fee item represents in the Inventory module for Microsoft Dynamic GP.

Constant | Description
Miscellaneous Charges | Quantities and current costs aren't tracked in Inventory. Miscellaneous charges include costs such as freight expense. You can't change this item type once it's assigned. Posting updates the Sales and Cash accounts.
Flat Fee | Current costs, but not quantities, are tracked. You can sell these items individually or as part of a kit. Posting updates the Sales account.


FreeOnBoard

Description

Specifies the terms of sale that identify the point at which ownership of goods passes to the buyer.

Constant | Description
None | No FOB designation has been specified.
Origin | Ownership transfers to the buyer when the vendor delivers the goods to the carrier.
Destination | Ownership transfers to the buyer when the goods are received from the carrier.


Frequency

Description

Specifies the frequency options for a repeating sales quote or sales order in the Sales Order Processing module for Microsoft Dynamics GP.

Constant | Description
None | Does not repeat.
Weekly | Document will repeat weekly.
Biweekly | Document will repeat every 2 weeks.
Semimonthly | Document will repeat t twice a month.
Monthly | Document will repeat once a month.
Bimonthly | Document will repeat every 2 months.
Quarterly | Document will repeat every 3 months.
Miscellaneous | Document will repeat based on the days to increment value.


Gender

Description

Specifies the gender of a person, such as an employee.

Constant | Description
Male | Male
Female | Female
Unknown | Unknown


GLAccountSummaryType

Description

Specifies the type of GL account summary.

Constant | Description
Posting | Posting accounts are the financial accounts that track assets, liabilities, revenue, expenses, and equity. Transactions posted to these accounts appear on financial reports. Examples of posting accounts include Cash, Cost of Goods Sold, and Accounts Receivable.
Unit | Unit accounts are similar to posting accounts. Like posting accounts, unit accounts are used in transaction entry. Historical information and budgets can be maintained for both types of accounts. However, quantities-rather than amounts-are posted to unit accounts, and unit accounts don't appear on financial statements.
Fixed Allocation | Fixed allocation accounts are used to distribute fixed percentages of a single transaction among several accounts. For example, a fixed allocation account might be used to divide utility expenses among the departments within a company. When you post transactions to allocation accounts, the amounts are allocated to distribution accounts based on percentages you define.
Variable Allocation | Variable allocation accounts are used to distribute percentages of a single transaction to several different accounts, much like fixed allocation accounts. You might use variable allocation accounts instead of fixed allocation accounts when you need to break down expenses precisely. For example, you could set up an account, Insurance Expense, and distribute the expense among the distribution accounts set up for each department. The expense could be further broken down by the number of employees in each department, if you set up unit accounts that track each department's head count.


GLAccountType

Description

Specify the type of GL account.

Constant | Description
Posting | Posting accounts are the financial accounts that track assets, liabilities, revenue, expenses, and equity. Transactions posted to these accounts appear on financial reports. Examples of posting accounts include Cash, Cost of Goods Sold, and Accounts Receivable.
Unit | Unit accounts are similar to posting accounts. Like posting accounts, unit accounts are used in transaction entry. Historical information and budgets can be maintained for both types of accounts. However, quantities-rather than amounts-are posted to unit accounts, and unit accounts don't appear on financial statements.
Posting Allocation | Fixed allocation accounts are used to distribute fixed percentages of a single transaction among several accounts. For example, a fixed allocation account might be used to divide utility expenses among the departments within a company. When you post transactions to allocation accounts, the amounts are allocated to distribution accounts based on percentages you define.
Unit Allocation | Variable allocation accounts are used to distribute percentages of a single transaction to several different accounts, much like fixed allocation accounts. You might use variable allocation accounts instead of fixed allocation accounts when you need to break down expenses precisely. For example, you could set up an account, Insurance Expense, and distribute the expense among the distribution accounts set up for each department. The expense could be further broken down by the number of employees in each department, if you set up unit accounts that track each department's head count.


GLLedgerType

Description

Specifies the type of general ledger.

Constant | Description
Base | Base
IFRS | IFRS
Local | Local


GLTransactionState

Description

Specifies the state of a GL transaction Microsoft Dynamics GP.

Constant | Description
Work | The GL transaction is in the work file and may have changes made to it.
Open | The GL transaction is in the open file which means it has been posted and may not be edited.
History | The GL transaction has been moved to history and may not be edited.


GLUnitAccountDecimalPlaces

Description

Specifies the number of decimal places for a GL unit account.

Constant | Description
Zero | No decimal places.
One | One decimal place.
Two | Two decimal places.


GLVariableAllocationAccountBalanceCalculationType

Description

Specifies how percentages for distributions are to be calculated.

Constant | Description
Year To Date | Based on year to date balances.
Transaction Period | Based on transaction period balances.


HRRequisitionPostingType

Description

Specifies the job posting type for a requisition.

Constant | Description
Internal | The position is open to people within the company.
External | The position is open to people outside the company.


HRRequisitionStatus

Description

Specifies the status of the requisition.

Constant | Description
Open | The requisition is open.
Closed | The requisition is closed.
On Hold | The hiring for the position is on hold.
Immediate | The position needs to be filled immediately.


HRStatus

Description

The human resources status of an employee. This is available only when Human Resources is installed for Microsoft Dynamics GP.

Constant | Description
Active | Active
Family Leave | Family Leave
Leave of Absence | Leave of Absence
Maternity | Maternity
Retired | Retired
Separated | Separated
Suspended | Suspended
Terminated | Terminated
Other | Other


InventoriedItemType

Description

Specifies the type of inventory item in the Inventory module for Microsoft Dynamic GP.

Constant | Description
Sales Item | Quantities are tracked. You can enter both increase and decrease adjustments. Amounts posted to the Inventory and Inventory Offset accounts appear on the Distributions Breakdown Register. Posting from Purchase Order Processing affects the Cash or Accounts Payables accounts. Posting from Sales Order Processing affects the Sales, Cash, Cost of Good Sold, or Accounts Receivables accounts.
Kit | Quantities aren't tracked. Kits consist of one or more components, which can be services, sales inventory, miscellaneous charges, discontinued, or flat fee items. Posting updates the Inventory and Cost of Goods Sold accounts specified for each component. If you plan to create a phantom bill for use on a bill of materials, we recommend not assigning components to the Kit in Inventory. Posting from Sales Order Processing affects the Sales, Cash, Cost of Good Sold, or Accounts Receivables accounts.


InventoryTransactionState

Description

Specifies whether an inventory transaction came from the Work table or the History table in Microsoft Dynamics GP.

Constant | Description
Work | The inventory transaction is in the work file and may have changes made to it.
History | The inventory transaction has been moved to history and may not be edited.


ISO8061Month

Description

Specifies the month values of the International Standard for the representation of dates and times.

Constant | Description
January | January
February | February
March | March
April | April
May | May
June | June
July | July
August | August
September | September
October | October
November | November
December | December


ItemType

Description

Specifies the type of item in the Inventory module for Microsoft Dynamic GP.

Constant | Description
Sales Item | Quantities are tracked. You can enter both increase and decrease adjustments. Amounts posted to the Inventory and Inventory Offset accounts appear on the Distributions Breakdown Register. Posting from Purchase Order Processing affects the Cash or Accounts Payables accounts. Posting from Sales Order Processing affects the Sales, Cash, Cost of Good Sold, or Accounts Receivables accounts.
Kit | Quantities aren't tracked. Kits consist of one or more components, which can be services, sales inventory, miscellaneous charges, discontinued, or flat fee items. Posting updates the Inventory and Cost of Goods Sold accounts specified for each component. If you plan to create a phantom bill for use on a bill of materials, we recommend not assigning components to the Kit in Inventory. Posting from Sales Order Processing affects the Sales, Cash, Cost of Good Sold, or Accounts Receivables accounts.
Miscellaneous Charges | Quantities and current costs aren't tracked in Inventory. Miscellaneous charges include costs such as freight expense. You can't change this item type once it's assigned. Posting updates the Sales and Cash accounts.
Service | Current costs, but not quantities, are tracked. You can sell these items individually or as part of a kit. Posting updates the Sales and Cash accounts.
Flat Fee | Current costs, but not quantities, are tracked. You can sell these items individually or as part of a kit. Posting updates the Sales account.


ManufacturingOrderComponentCalculation

Description

Specifies how components are calculated for a manufacturing order.

Constant | Description
None | No component calculation method has been specified.
Start Quantity | Calculate component quantities based on manufacturing order start quantity.
Total Quantity Received | Calculate component quantities based on total quantity of finished goods received for a manufacturing order.


ManufacturingOrderOutSourced

Description

Specifies whether the manufacturing order has been outsourced.

Constant | Description
Yes | The manufacturing order has been outsourced.
No | The manufacturing order has not been outsourced.


ManufacturingOrderPriority

Description

Specifies a priority for a manufacturing order.

Constant | Description
High | High
Medium | Medium
Low | Low


ManufacturingOrderRouteSequenceType

Description

Specifies the route sequence type for a manufacturing order route step.

Constant | Description
Standard | Standard
Alternate | Alternate
Rework | Rework
Outside Proc. | Outside Proc.
Inspection | Inspection


ManufacturingOrderStatus

Description

Specifies the status of a manufacturing order.

Constant | Description
Quote/Estimate | The manufacturing order might not be produced.
Open | The manufacturing order will be produced.
Released | Specifies that work on a manufacturing order is ready to begin.
Hold | Specifies that work on the manufacturing order has been temporarily stopped.
Canceled | Work on the manufacturing order has been permanently suspended.
Complete | Specifies that all tasks for a manufacturing order are complete.
Partially Received | Specifies that a portion of the finished goods from a manufacturing order have been received.
Closed | All accounting tasks associated with tracking the costs of a manufacturing order have been completed.


MaritalStatus

Description

The marital status for an employee.

Constant | Description
Married | Married
Single | Single
Not applicable | Not applicable


MaximumInvoiceSpecialAmount

Description

Specifies whether there is a maximum invoice amount for purchases from the vendor.

Constant | Description
No Maximum | No maximum invoice amount.


MaximumWriteoffSpecialAmount

Description

Specifies the writeoff option the vendor uses when not a specific amount.

Constant | Description
Not Allowed | Writeoffs are not allowed.
Unlimited | There is no limit on the writeoff amount.


NegativeSymbol

Description

Specifies the symbol to use when displaying negative amounts.

Constant | Description
Negative Sign | Displayed with a hyphen (-).
Parenthesis | Displayed with parenthesis.
Credit | Displayed with Cr.
Uppercase Credit | Displayed with CR
Lowercase Credit | Displayed with cr.


NegativeSymbolCurrencySymbolLocation

Description

Specifies whether the negative symbol will be located before or after the currency symbol when displaying negative amounts.

Constant | Description
Before Currency Symbol | Displayed before the currency symbol.
After Currency Symbol | Displayed after the currency symbol.


OrderFullfillmentShortage

Description

Specifies how to handle a shortage when fulfilling an order for a customer.

Constant | Description
None | Shortages have to be handled manually.
Backorder Remaining | The unavailable items are backordered.
Cancel Remaining | The unavailable items are canceled.


OrderPolicy

Description

Specifies the method for calculating how quantities of an item should be calculated for replenishment.

Constant | Description
Not Planned | No suggested purchase orders or manufacturing orders will be created.
Lot For Lot | An order policy for ordering the exact quantity needed, provided that the order quantity is between the minimum and maximum order quantities.
Fixed Order Quantity | An order policy type that calculates order size for a day's requirements based on one or more of these variables: standard order quantity, order increment size, minimum order size, and maximum order size.
Period Order Quantity | An order policy type that calculates order size for requirements for a period you specify based on one or more of these variables: standard order quantity, order increment size, minimum order size and maximum order size.
Order Point | Suggested purchase orders will be automatically created based on the order point quantity on the item.
Manually Planned | Purchase orders will be manually created.


PayableCardType

Description

Specifies the type of card used by the company to make payments to a vendor.

Constant | Description
Credit Card | Using a credit card. The company will pay the credit card company for the goods and services your company purchases with the card.
Check Card | Using a check card. The amount of the purchase or payment is automatically withdrawn from your company's bank account.


PayablesCashAccountType

Description

Specifies from where the GL cash account will be defaulted for a transaction.

Constant | Description
Bank Account | The GL cash account on the bank will be used as the default.
Vendor | The GL cash account on the vendor will be used as the default.


PayablesDocumentType

Description

Specifies the type of payables document.

Constant | Description
Invoice | A bill for goods or services you received or ordered from a vendor.
Finance Charge | The cost of borrowing money or a late charge for not making payments on time.
Miscellaneous Charge | A service charge that isn't part of your normal purchasing process, such as a charge for installation or repair of merchandise.
Return | Records the return of merchandise to a vendor that offsets the amount of the original invoice.
Credit Memo | A record of a credit to the amount owed to a particular vendor.
Payment | A payment to a vendor.


PayablesPostResultsTo

Description

Specifies the GL account to be used when posting revaluation amounts for a vendor.

Constant | Description
Payables/Discount Account | The accounts payables account or discount account.
Payables Offset Account | The payables offset account.


PayablesTransactionState

Description

Specifies the state of a Payables Transaction within Microsoft Dynamics GP.

Constant | Description
Work | The payables transaction is in the work file and may have changes made to it.
Open | The payables transaction is in the open file which means it has been posted and may not be edited.
History | The payables transaction has been moved to history and may not be edited.


PayablesVendorPaymentScope

Description

Used to determine the level of filtering to be used when returning vendor paymentdata.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on VendorId | The value for the criteria property “VendorId” will be set to the back office vendor ID mapped to the current user. The current user is specified by the Context object.


PaymentMethod

Description

Specifies the payment method the employee used for expenses in an employee expense transaction in the Project Accounting module within Microsoft Dynamics GP.

Constant | Description
Cash | The amount that the employee paid for expenses using cash.
Company Payment Card | The amount that the employee paid for expenses using the company payment card.
Personal Payment Card | The amount that the employee paid for expenses using a personal payment card.


PlannedOrderItemStatus

Description

Specifies the status of the planned order item.

Constant | Description
Quote | The planned order might not be produced.
Open | The planned order will be produced.
Released | Specifies that work on a planned order is ready to begin.
Hold | Specifies that work on the planned order has been temporarily stopped.
Canceled | Work on the planned order has been permanently suspended.
Complete | Specifies that all tasks for a planned order are complete.
Partially Received | Specifies that a portion of the finished goods from a planned order have been received.
Closed | All accounting tasks associated with tracking the costs of a planned order have been completed.
MRP Planned | Specifies that the planned order was generated by MRP.


PlannedOrderMRPType

Description

Specifies the MRP type for a planned order.

Constant | Description
Real MO document | A real MO document.
Suggested MO document | A suggested MO document.


PlannedOrderParentMRPType

Description

Specifies the MRP type for the parent of the planned order.

Constant | Description
Suggested MO document | A suggested MO document.
Real MO document | A real MO document.


PlannedOrderReplenishment

Description

Specifies the replenishment method for a planned order.

Constant | Description
Make the item | The item is manufactured or produced by this organization.
Buy the item | The item is purchased.


PostingFrequency

Description

Specifies how often a batch can be posted in Microsoft Dynamics GP.

Constant | Description
Single Use | After posting the batch will be deleted.
Weekly | After posting the transaction dates will be increased by one week.
Biweekly | After posting the transaction dates will be increased by two weeks.
Semimonthly | After posting the transaction dates will be increased to the next 1st or 15th of the month.
Monthly | After posting the transaction dates will be increased by 1 month.
Bimonthly | After posting the transaction dates will be increased by 2 months.
Quarterly | After posting the transaction dates will be increased by 3 months.
Miscellaneous | After posting the transaction dates will be incremented by the number of days specified in Miscellaneous Batch Days To Increment.


PostingLevel

Description

Specifies how much detail to post to General Ledger from each series-Sales, Inventory Control, Purchasing, and Payroll-if the transaction origin is set up to use account settings.

Constant | Description
Detail | To post detailed information about each line item for a group of transactions.
Summary | To post a summarized total for a group of transactions for this account.


PostingType

Description

Specifies whether the GL posting account should be closed to a retained earnings account at the end of the year, or have a balance brought forward to the next year.

Constant | Description
BalanceSheet | Balance is brought forward to the next year.
ProfitLoss | Balance is closed to a retained earnings account.


PostRevaluationResultsTo

Description

Specifies where the revaluation results are posted for a GL posting account in Microsoft Dynamics GP.

Constant | Description
Account | Post to a realized or unrealized gain/loss account and the offset to the posting account being revalued.
Offset Account | Post the results to the financial offset account.


PriceMethod

Description

Specifies the price method to be used to calculate prices in the price book detail (price list) for an item in the Inventory module of Microsoft Dynamics GP.

Constant | Description
Currency Amount | A flat currency amount for each unit of measure in the price list.
Percent Of List Price | For each unit of measure, provide a percentage of the item's list price that is used to calculate prices. For example, the distributor's list price for a single can is $0.20, and you want to sell single cans at 250% of list. All single cans are sold at $0.50 (250% x $0.20). You can specify a different list price for each currency, if needed. List price x price percentage
Percent Markup Of Current Cost | Provide a percentage based on the current cost of each unit of measure. Each time you receive a shipment of an item, the price being charged for the item changes according to the item's current cost when it was received. For example, the current cost for single cans is routinely updated each time you receive a shipment. If you enter 150% as the price for Can, the price for single cans will always be 250% (100% + 150%) more than you paid for your last shipment. Current cost x (100% + price percentage)
Percent Markup Of Standard Cost | The prices you charge for each unit of measure are updated only when you update the standard cost. Because the standard cost is updated periodically, the standard cost doesn't always match the amount you most recently paid for an item. For example, if you enter 150% as the price for a single can, the price for single cans will always be 250% (100%+ 150%) more than the standard cost. Standard cost x (100% + price percentage)
Percent Margin Of Current Cost | Provide the profit percentage you want to achieve, based on the current cost of the item being sold. Each time you receive a shipment, the current cost for the item is updated and the price changes accordingly. For example, suppose you've entered a profit of 25%. The price for single cans will always be 25% more than the current cost. Current cost + [(current cost x price percentage)/(100% - price percentage)]
Percent Margin Of Standard Cost | The profit percentage you want to achieve is entered, based on the standard cost. Each time the standard cost is updated, the price changes, as well. For example, suppose you've entered a profit of 25%. The price for single cans will always be 25% more than the standard cost. Standard cost + [(standard cost x price percentage)/(100% -price percentage)]


ProfitType

Description

Specifies the method used to determine profit and calculate billing amounts in the Project Accounting module for Microsoft Dynamics GP.

Constant | Description
Not Applicable | Does not apply.
Billing Rate | Specify a flat amount for the billing rate. Billing amounts will be calculated using quantities and the billing rate. Applies to Time and Materials projects.
Markup Percentage | Specify a percentage for the markup. Billing amounts will be calculated using actual cost, plus a percentage markup of actual cost. Applies to Time and Materials projects.
Profit Fixed | Specify a flat amount. Billing amounts will be calculated using actual cost plus the flat amount for each unit quantity. Applies to Cost Plus and Fixed Price projects.
Profit Variable | Specify a flat amount for profit. Billing amounts will be calculated using actual cost, plus the profit for each unit quantity. Applies to Cost Plus projects.
Total Profit | Specify a flat amount. The billing amount will be the flat amount. Applies to Cost Plus projects.
Percent of Baseline | Specify a percentage. Billing amounts will be calculated using a percentage of the baseline budget amount. Applies to Cost Plus and Fixed Price projects.
Percent of Actual | Specify a percentage. Billing amounts will be calculated using a percentage of actual cost. Applies to Cost Plus and Fixed Price projects.
None | Billing amounts are always zero. Applies to Time and Materials, Cost Plus, and Fixed Price projects.
Price Level | Billing amounts are calculated using price levels for inventoried items included in cost categories. Applies to Time and Materials, Cost Plus, and Fixed Price projects.


ProjectAccountingMethod

Description

Determines the percentage completion of a certain project, budget, or fee to determine the revenues to be recognized.

Constant | Description
When Performed | Revenue is recognized for a Time and Materials project that uses the When Performed accounting method when a cost transaction is posted for the project.
When Billed | Revenue is recognized for a Time and Materials project that uses the When Billed accounting method when a billing invoice is posted for the project.
Cost To Cost | Revenue is recognized for a Cost Plus or Fixed Price project that uses the Cost-to-Cost accounting method when revenue recognition transactions are posted for the project.
Effort Expended | Revenue is recognized for a Cost Plus or Fixed Price project that uses the Effort-Expended accounting method when you post revenue recognition transactions for the project.
Completed | Revenue is recognized for a Cost Plus or Fixed Price project that uses the Completed accounting method when the project status has been changed to Completed for all projects in the contract that the project is for.
Labor Only | Revenue is recognized for a Cost Plus or Fixed Price project that uses the Labor Only accounting method when revenue recognition transactions are posted for the project.


ProjectChangeOrderDocumentStatus

Description

Specifies the status of a change order document in the Project Accounting module within Dynamics GP.

Constant | Description
Processed when pending | The change order document was processed with the status was pending.
Unprocessed when pending or unapproved | The change order document is unprocessed with a status of pending or unapproved.
Processed when unapproved | The change order document was processed with the status was unapproved.
Unprocessed when approved | The change order document is unprocessed with a status of approved.
Processed when approved | The change order document was processed with the status was approved.
Record saved again after it has already been approved and processed | The change order document was saved again after already having been approved and processed.


ProjectChangeOrderStatus

Description

Specifies the status of a change order in the Project Accounting module within Dynamics GP.

Constant | Description
Pending | The default status of a new change order. When the change order has a status of pending you cannot enter cost, billing, and revenue recognition transactions for cost categories and projects on the change order; cannot modify budget settings and fee assignments for the projects; cannot enter cost, billing, and revenue recognition transactions for cost categories and projects on the change order; cannot modify budget settings and fee assignments for the projects. Allows the change order to be deleted.
Unapproved | The change order has not been approved. When the change order has a status of unapproved a cost category cannot be entered on a billing transaction for a project if you've entered change order amounts for the cost category and project; fee assignments cannot be modified for the project using the Fee Entry window if you've entered a change order to modify fee assignments for the project.
Approved | The change order has been approved. When the change order status is approved cost, billing, and revenue recognition transactions can be entered for cost categories and projects on the change order; budget settings and fee assignments can be modified for the projects. The change order cannot be deleted.
Canceled | The change order has been canceled. When the change order status is canceled budget settings for the cost category cannot be modified.
Completed | The change order has been completed. When the status of a change order is completed the change order has been billed and not changes are allowed.


ProjectChangeOrderTrackChangesToType

Description

Specifies which amounts to apply change orders to for projects in the contract in the Project Accounting module within Dynamics GP.

Constant | Description
Baseline | Change orders will be applied to the baseline amounts.
Forecast | Change orders will be applied to the forecast amounts,


ProjectChangeOrderType

Description

Specifies the type of change order in the Project Accounting module within Dynamics GP.

Constant | Description
Internal | The change order is internal and must be approved by an employee in the company. The names Internal and Company are used for information only. There is no technical difference between Internal and Company change orders.
Company | The change order is for the company and must be approved by an employee in the company. The names Internal and Company are used for information only. There is no technical difference between Internal and Company change orders.
Customer | The change order is for a customer and must be approved by the customer.


ProjectCloseToBillings

Description

Specifies whether to allow or disallow billing transaction entry and posting for the contract in the Project Accounting module within Dynamics GP.

Constant | Description
Allow | Allow billing transactions to be entered and posted for a contract.
Disallow | Do not allow billing transactions to be entered and posted for a contract.


ProjectCloseToProjectCosts

Description

Specifies whether to allow or disallow cost transaction entry and posting for the contract in the Project Accounting module within Dynamics GP.

Constant | Description
Allow | Allow cost transactions to be entered and posted for a contract.
Disallow | Do not allow cost transactions to be entered and posted for a contract.


ProjectFeeType

Description

Specifies the fee types supported in the Project Accounting module within Dynamics GP.

Constant | Description
Project Fee | A flat amount billed using a fee schedule or a percentage of total baseline project costs or revenue that can be billed during each billing cycle using a fee schedule or after the project is complete.
Retainer | A flat amount billed using a fee schedule. Retainer fee amounts are held on account and can be applied to billing amounts.
Retentions | A percentage of total baseline project costs that isn't billed until the project status is Completed. This fee is for Cost Plus and Fixed Price projects only.
Service | A flat amount billed using a fee schedule. This fee is for Time and Materials projects only.


ProjectFrequency

Description

Specifies whether how bill the customer for the fee in the Project Accounting module within Dynamics GP.

Constant | Description
Scheduled | The fee is billed using a fee schedule.
Per Invoice | The fee is billed during each billing cycle.
At Project Completion | The fee is billed after the project is complete.


ProjectLaborRateTableType

Description

Specifies the type of labor rate table to use with the cost category in the project budget in the Project Accounting module within Dynamics GP.

Constant | Description
None | No labor rate table is used.
Employee | The employee rate table is used to calculate cost and profit for employees for the cost category in the project budget.
Position | The position rate table is used to calculate cost and profit for employees for the cost category in the project budget.


ProjectOverheadRateMethod

Description

Specifies the overhead calculation methods that can be used to include overhead in project costs in the Project Accounting module within Dynamics GP.

Constant | Description
Amount Per Unit | Overhead is a flat amount that is added to the unit cost for each single unit quantity of time or an item.
Percentage Of Actual Cost | Overhead is a percentage of the actual cost for each single unit quantity of time or an item.


ProjectSourceFile

Description

Specifies the object used to determine the default GL accounts used in the Project Accounting module within Dynamics GP.

Constant | Description
Contract | The default GL accounts from the contract are used.
Project | The default GL accounts from the project are used.
Project Fee | The default GL accounts from the contract fee are used.
Contract Fee | The default GL accounts from the project fee are used.


ProjectStatus

Description

Specifies the status of a cost category, project, or project contract in the Project Accounting module within Dynamics GP.

Constant | Description
Open | The cost category, project or project contract is open.
On Hold | The cost category, project or project contract is on hold.
Closed | The cost category, project or project contract is closed.
Estimate | The cost category, project or project contract has an estimate status.
Completed | The cost category, project or project contract is completed.


ProjectTaxBasis

Description

Specifies whether taxes will need to be paid on a transaction in the Project Accounting module of Microsoft Dynamics GP and if so, on what basis.

Constant | Description
Unspecified | No tax basis was specified.
Taxable | A tax schedule will be provided.
Nontaxable | The transaction will not be taxed.
Based On Vendor | All the details on the vendor tax schedule will be applied.


ProjectTransactionState

Description

Indicates whether a project transaction came from the Work table or the History table in Microsoft Dynamics GP.

Constant | Description
Work | The project transaction is in the work file which means it has not been posted and may have changes made to it.
Open | The project transaction is in the open file which means it has been posted and may not be edited.
History | Transaction has been paid and moved to history.


ProjectTransactionType

Description

Specifies the type of transaction in the Project Accounting module within Microsoft Dynamics GP.

Constant | Description
Standard | A regular or standard transaction.
Referenced | A transaction to modify amounts from a standard transaction.


ProjectType

Description

Specifies how a contractor is to compute project costs and charge customers for such costs in the Project Accounting module within Microsoft Dynamics GP. It also is a way to determine how much revenues can be generated in a project.

Constant | Description
Time And Materials | Time and Materials will use direct labor hours, cost of materials and overhead cost in computing project amount
Cost Plus | Cost Plus will use allowable costs incurred plus a fee for the contractor's services in computing project cost.
Fixed Price | Fixed Price will use a single price for the total amount of work to be performed in a project.


PurchaseOrderFormat

Description

Specifies the default format to use when printing a purchase order with project information. This is specified in the Project Accounting Options for a vendor.

Constant | Description
A | Format A.
B | Format B.
C | Format C.


PurchaseOrderLineOrigin

Description

Specifies the various origins of a purchase order line that is created within Microsoft Dynamics GP.

Constant | Description
Manual | The purchase order line was created manually in the Purchasing module.
eRequisition | The purchase order line was created from the eRequisition product.
Sales Order Processing | The purchase order line was created from a Sales Order Processing module.
Manufacturing | The purchase order line was created from the Manufacturing module.
Field Service Call | The purchase order line was created from a service call in the Field Service module.
Service Returns | The purchase order line was created from a return material authorization (RMA) in the Field Service module.
Depot Order | The purchase order line was created from a depot work order in the Field Service module.
Undefined | The origin of the purchase order line is undefined.
PO Generator | The purchase order line was generated from the Purchase Order Generator function.


PurchaseOrderStatus

Description

Specifies the status of the purchase order in Microsoft Dynamics GP.

Constant | Description
New | This status is assigned when a purchase order is created for the first time, before it has been released to the vendor. A New purchase order can exist without line items. If you make changes to a New purchase order, its status will remain New. Inventory quantities are not adjusted when the new purchase order is entered; they are adjusted when the purchase order line's status becomes Released.
Released | This status indicates that the purchase order has been sent to the vendor. A New purchase order is assigned a status of Released when at least one purchase order line changes from New to Released, or when a receipt is posted. A Change Order purchase order also changes to Released when printing it results in at least one Released purchase order line and no remaining Change Order purchase order lines.
Change Order | This status notifies people that the original order is no longer valid. When a purchase order with a Released status is edited in a way that affects the vendor, it is assigned a status of Change Order, and the revision number increases. Use the revision number to be sure you and the vendor are referring to the same order. The revision number will not increase when you make changes to a purchase order that already has a status of Change Order.
Received | This status is assigned when there are no quantities remaining to receive, but there are quantities remaining to invoice. A Received purchase order can have a combination of Received, Canceled, and Closed line items.
Closed | This status is assigned when all line items have been closed-there are no remaining quantities to receive or match to invoices. A Closed purchase order can also have Canceled lines.
Canceled | This status indicates that the purchase order will not be processed any further. A purchase order is assigned this status when all line items have been canceled and haven't been received against.


PurchaseOrderTransactionState

Description

Specifies the state of a purchase order in Microsoft Dynamics GP.

Constant | Description
Work | The purchase order is in the work file and may have changes made to it depending on the status of the purchase order.
History | The purchase order has been moved to history and may not be edited.


PurchaseOrderType

Description

Specifies the type of purchase order document in Microsoft Dynamics GP.

Constant | Description
Standard | Used when the document's items will be shipped to your business to be received into your inventory.
Drop Ship | Used when the document's items will be shipped directly to the customer. The vendor will invoice your business and you, in turn, will invoice the customer. The quantity on hand isn't updated in Inventory Control, but the current cost for the drop-ship items and the item vendor information will be updated when the invoice is posted.
Blanket | Used when the quantities of a single item on the document are to be delivered in a series of shipments, usually on specific dates. The line items you enter for a blanket purchase order must be the same item number. The item will be shipped to your business to be received into your inventory. If you are using Project Accounting, you can't enter blanket purchase orders for projects.
Drop Ship Blanket | Used when the quantities of a single item on the document are to be delivered to the customer in a series of shipments, usually on specific dates. The line items you enter for a drop-ship blanket purchase order must be the same item number. The vendor will invoice your business and you, in turn, will invoice the customer. The quantity on hand isn't updated in Inventory Control, but the current cost for the drop-ship items and the item vendor information will be updated when the invoice is posted. If you are using Project Accounting, you can't enter drop-ship blanket purchase orders for projects.


PurchaseTransactionState

Description

Specifies the state of a purchase document (purchase order, purchase invoice, or purchase receipt) in Microsoft Dynamics GP.

Constant | Description
Work | The purchase document is in the work file and may have changes made to it depending on the status of the purchase order.
History | The purchase document has been moved to history and may not be edited.


PurchasingTaxBasis

Description

Specifies whether taxes will need to be paid when an item, in the Inventory module of Microsoft Dynamics GP, is purchased, and if so, on what basis.

Constant | Description
Taxable | A tax schedule will be provided for the item.
Nontaxable | The item will not be taxed when purchased.
Based On Vendor | All the details on the vendor tax schedule will be applied, depending on whether the shipping method is delivery or pickup. The shipping method will determine where the exchange of goods takes place and therefore which tax schedule appears as a default value for the transaction. If the shipping method is delivery, the tax schedule designated for the shipping address for the customer will appear as the default value. If the shipping method is pickup, the tax schedule designated for the site you're selling from will appear as the default value.


QuantityDecimalPlaces

Description

Specifies the number of decimal places for a quantity value.

Constant | Description
Zero | Zero decimal places.
One | One decimal place.
Two | Two decimal places.
Three | Three decimal places.
Four | Four decimal places.
Five | Five decimal places.


QuantityType

Description

Specifies the quantity type for an item on a sales return line in the Sales Order Processing module or an inventory transfer line in the Inventory module of Microsoft Dynamics GP.

Constant | Description
On Hand | When the item quantity is available for sale.
Returned | When the item quantity should be returned to the vendor and is not available for sale.
In Use | When the item quantity is in use and not available for sale.
In Service | When the item quantity is in service and not available for sale.
Damaged | When the item quantity is damaged and not available for sale.


RateCalculation

Description

Specifies a method for calculating exchange rates assigned to a currency ID in the exchange rate table.

Constant | Description
Multiply | The originating currency amount will be multiplied by the exchange rate to determine a functional currency amount.
Divide | The originating currency amount will be divided by the exchange rate to determine a functional currency amount.


ReceivableCardType

Description

Specifies the type of card the company accepts as payment from customers.

Constant | Description
Bank Card | When payments made to your company with bank cards are treated as check or cash payments.
Payment Card | When payments made to your company with payment cards must be collected from the company issuing the card before they can be considered received.


ReceivablesCashAccountType

Description

Specifies from where the GL cash account will be defaulted for a transaction.

Constant | Description
Bank Account | The GL cash account from the bank will be used as the default.
Customer | The GL cash account from the customer will be used as the default.


ReceivablesDocumentScope

Description

Used to determine the level of filtering to be used when returning receivables document data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Customer Id | The value for the criteria property “CustomerId” will be set to the back office customer ID mapped to the current user. The current user is specified by the Context object.
Return Based on Salesperson Id | The value for the criteria property “SalespersonId” will be set to the back office salesperson ID mapped to the current user. The current user is specified by the Context object.


ReceivablesDocumentType

Description

Specifies the type of receivables document in the Sales module of Microsoft Dynamics GP.

Constant | Description
Balance Brought Forward | Use Balance Brought Forward to enter a customer's beginning balance.
Invoice | Use invoice to enter and record a sale.
Scheduled Payment | Use to enter payment schedules against existing receivables invoices.
Debit Memo | Use debit memos to record an increase to the customer's balance for charges other than a sale.
Finance Charge | Use finance charges to enter and record a finance charge for a specific customer. This finance charge is in addition to or instead of the finance charges assessed during month-end procedures using the Assess Finance Charges process.
Service Repair | Use service repair to record a transaction for a service your business provided for a customer.
Warranty | Use warranty to record a service or repair covered by a warranty.
Credit Memo | Use credit memos to record any decrease in a customer's balance that is not the result of a payment. The difference between a credit and a return is that a credit memo credits a customer's account. A return credits a customer's credit card balance or account with your company, and reverses tax and commission amounts that were previously created.
Return | Use returns to record the return of a product. You can use returns to decrease the customer's balance, if the customer hasn't received cash for the return. The difference between a credit and a return is that a credit memo credits a customer's account. A return credits a customer's credit card balance or account with your company, and reverses tax and commission amounts that were previously created.
Cash Receipt | Use cash receipt to record the receipt of money from your customers for transactions on account.


ReceivablesPostResultsTo

Description

Specifies the GL account to be used when posting revaluation amounts for a customer.

Constant | Description
Receivables/Discount Account | The accounts receivable account or discount account.
Sales Offset Account | The sales offset account.


ReceivablesTransactionState

Description

Specifies the state of a receivables transaction in the Sales module for Microsoft Dynamics GP.

Constant | Description
Work | The receivables transaction is in the work file and may have changes made to it.
Open | The receivables transaction is in the open file which means it has been posted and may not be edited.
History | The receivables transaction has been moved to history and may not be edited.


RelativeLocation

Description

Specifies whether the negative symbol will be located before or after the currency amount when displaying negative amounts.

Constant | Description
Before Amount | Displays the negative sign before the currency amount.
After Amount | Displays the negative symbol after the currency amount.


ReplenishmentMethod

Description

Specifies how the supply of a specific item should be obtained in the Inventory module for Microsoft Dynamics GP.

Constant | Description
Make | The item supply will be manufactured.
Buy | The item supply will be purchased.


ReturnMaterialAuthorizationOriginatingDocumentType

Description

Specifies the various types of documents from which a return material authorization (RMA) document can be originated in the Field Service module for Microsoft Dynamics GP.

Constant | Description
None | The return material authorization document has no originating document.
Service Call | The return material authorization document originates from a service call.
Sales Invoice | The return material authorization document originates from a sales invoice.


ReturnMaterialAuthorizationReturnStatus

Description

Specifies the various statuses that a return material authorization (RMA) document can have.

Constant | Description
New | Assigned to a new return material authorization document.
Repair | Assigned to a repair return material authorization document.
Credit | Assigned to a credit return material authorization document.
Replace | Assigned to a replace return material authorization document.
Cross-Ship | Assigned to a cross-ship return material authorization document.
None | Assigned to a return material authorization document where the return item is customer owned.
Open RTV or WO | The return material authorization document has an association to open return to vendor (RTV) document or depot work order.
Closed RTV or WO | The return material authorization document has an association to closed return to vendor (RTV) document or depot work order.
Ready To Close | The return material authorization document is ready to be closed.
Closed RMA | The return material authorization document has been closed.


ReturnMaterialAuthorizationTransferDocumentStatus

Description

Specifies the various statuses that a transfer document can have in the Field Service module for Microsoft Dynamics GP.

Constant | Description
Open | Assigned to a transfer that is open.
Picked | Assigned to a transfer that has been picked.
Packed | Assigned to a transfer that has been packed.
Partial Shipped | Assigned to a transfer where some lines have been shipped.
Shipped | Assigned to a transfer when all lines have been shipped.
Partial Received | Assigned to a transfer where some lines have been received.
Received | Assigned to a transfer when all lines have been received.
Void Through RTV | Assigned to a transfer that has been voided from a return to vendor function.
RMA Returned to Stock | Assigned to a transfer that returns the items to stock.


ReturnMaterialAuthorizationType

Description

Specifies whether a return material authorization document came from the Open table or the History table in Microsoft Dynamics GP.

Constant | Description
Open | The return material authorization document is in the open table.
History | The return material authorization document has been moved to history and may not be edited.


ReturnScope

Description

Used to determine the level of filtering to be used when returning return material authorization document data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Customer Id | The value for the criteria property “CustomerId” will be set to the back office customer ID mapped to the current user. The current user is specified by the Context object.


RevaluationMethod

Description

Specifies the account balance to use when revaluing a GL posting account in Microsoft Dynamics GP.

Constant | Description
Net Change | Revalues the selected account based on the net change, or the difference in the account's beginning and ending balances for the revaluation period.
Period Balances | Revalues the selected account based on the period balance, or the current balance of the account on the last day of the revaluation period.


RoundHow

Description

Specifies how prices for an item should be rounded in the Inventory module of Microsoft Dynamics GP.

Constant | Description
None | No rounding.
Multiple Of | Price will end with a number that is a multiple of a number you specify.
Ends In | Price will end with a certain number.


RoundTo

Description

Specifies the direction in which price calculations will be rounded for each price record for an item in the Inventory module of Microsoft Dynamics GP.

Constant | Description
None | No rounding.
Up | The calculated price will round up.
Down | The calculated price will round down.
To Nearest | Amounts an equal distance from the lower and higher amounts will be rounded to the higher amount.


SalaryPostingType

Description

Identifies the procedure to be performed when posting a salary amount to US Payroll.

Constant | Description
No Post | Select No Post is timesheet information should not be posted to payroll. This is the default option.
Reallocate Amount | Select Reallocate Amount if using U.S. Payroll to track the departments that employees are working in, pay employees using payroll accounts for the departments that the employees worked for, relative to time entered on timesheets.
Reallocate Hours | Select Reallocate Hours if using U.S. Payroll to track the number of hours that salaried employee's work, update the hours worked for employees based on time entered on timesheets.
Additional Amount | Select Additional Amount if you pay employees additional amounts based on the total cost entered on timesheets.


SalesCommissionTransactionState

Description

Specifies whether a sales commission transaction came from the Open table or the History table in Microsoft Dynamics GP.

Constant | Description
Open | The sales commission transaction is in the open file which means it has been posted and may not be edited.
History | The sales commission transaction has been moved to history and may not be edited.


SalesDocumentScope

Description

Used to determine the level of filtering to be used when returning sales document data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Customer Id | The value for the criteria property “CustomerId” will be set to the back office customer ID mapped to the current user. The current user is specified by the Context object.
Return Based on Salesperson Id | The value for the criteria property “SalespersonId” will be set to the back office salesperson ID mapped to the current user. The current user is specified by the Context object.


SalesDocumentType

Description

Identifies the type of sales document in Microsoft Dynamics GP.

Constant | Description
Quote | A quote. Sales quotes are saved but not posted, and distributions aren't calculated on quotes. If a customer decides to make a purchase based on the quoted price, you can transfer the quote to an order or invoice. When you transfer a quote to an invoice or order, information about the document, customer, and items will be transferred to the new document. To transfer a quote for a prospect customer to an order or to an invoice, you must add the prospect to your customer base or assign the prospect to an existing customer.
Order | An order. Sales orders are saved, but not posted; distributions aren't calculated on orders. When you ship the items to a customer, you can transfer the order to an invoice. If ordered items aren't available in inventory, you can transfer the order to a fulfillment order or a back order.
Invoice | An invoice. Sales invoices are saved and may be posted. A sale invoice will have distributions. When posted inventory quantities are decreased (increased if quantity is negative).
Return | A return. Sales returns are saved and may be posted. A sales return will have distributions. When posted inventory quantities are increased.
Backorder | A backorder. Back orders are saved but not posted and distributions aren't calculated on back orders. When an item that has been back ordered is in stock, you can transfer the back order to an order or an invoice. When you transfer a back order to an invoice, fulfillment order, or order, information about the document, customer, and items will be transferred to the new document.
Fulfillment Order | A fulfillment order. Sales fulfillment orders are a type of sales document that uses document statuses to provide additional structure and control over typical sales processes, such as printing the picking ticket, picking the goods, printing the packing slip, packing and shipping the goods, and invoicing the customer.


SalesPaymentType

Description

Specifies the type of payment on a sales document in the Sales Order Processing module for Microsoft Dynamics GP.

Constant | Description
Cash Deposit | A cash deposit. Only available for sales order or sales backorder.
Check Deposit | A check deposit. Only available for sales order or sales backorder.
Payment Card Deposit | A payment card deposit. Only available for sales order or sales backorder.
Cash Payment | A cash payment. Only available for sales invoice, sales fulfillment order, or sales return.
Check Payment | A check payment. Available for all sales documents except sales quote.
Payment Card Payment | A payment payment. Available for all sales documents except sales quote.


SalespersonCommissionsDocumentType

Description

The type of document for a salesperson commission.

Constant | Description
Sales/Invoice | A sales document or invoice.
DebitMemo | A debit memo.
Service/Repair | A service or repair.
Return | A return.


SalespersonScope

Description

Used to determine the level of filtering to be used when returning salesperson data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Salesperson Id | The value for the criteria property “SalespersonId” (“Id” if “SalespersonId” does not exist) will be set to the back office salesperson ID mapped to the current user. The current user is specified by the Context object.
Return Based on Territory Id | The value for the criteria property “TerritoryId”, “SalesTerritoryId”, or “Id” will be set to the territory for the salesperon ID mapped to the current user. The current user is specified by the Context object.


SalesSummaryType

Description

The type of summary.

Constant | Description
Calendar Year | Summary for the calendar year.
Fiscal Year | Summary for the fiscal year.


SalesTaxBasis

Description

Specifies whether an item will be taxed when sold, and if so, on what basis.

Constant | Description
Single Tax Schedule | Sales tax is based on single tax schedule.
Taxable | Sales tax will be applied based on the tax schedule for the item.
Nontaxable | Sales tax will not be applied.
Based On Customer | Sales tax will be applied, based on the customer’s tax schedule or the site tax schedule will be applied, depending on whether the shipping method is delivery or pickup. The shipping method will determine where the exchange of goods takes place and therefore which tax schedule appears as a default entry for the transaction. If the shipping method is delivery, the tax schedule designated for the shipping address for the customer will appear as the default value. If the shipping method is pickup, the tax schedule designated for the site you're selling from will appear as the default value.


SalesTransactionState

Description

Indicates whether a sales transaction came from the Work table or the History table in Microsoft Dynamics GP.

Constant | Description
Work | Transaction has not been posted.
History | Transaction has been paid.


SchedulingMethod

Description

Specifies the scheduling method for a manufacturing order.

Constant | Description
Forward Infinite | Scheduling uses the starting date to determine the flow of work needed for a manufacturing order.
Backward Infinite | Scheduling works back from the due date to determine the flow of work needed for a manufacturing order..


SeriesType

Description

Groups the solutions within Microsoft Dynamics GP similar in their purpose.

Constant | Description
Financial | Maintain and update general ledger records.
Sales | Maintain and update customer records.
Purchasing | Maintain and update vendor records.
Inventory | Maintain and update inventory records.
Payroll | Maintain and update payroll records.
Project | Maintain and update project accounting records.


ServiceAddressOptionTypes

Description

Specifies the various types of address options available to ship to for a line on a service document in the Field Service module for Microsoft Dynamics GP.

Constant | Description
Labor, Additional Charge or Expense | No ship to information is available.
Customer Address ID | The item on the part line will be shipped to the customer address assigned to the line.
Technician Site | The item on the part line will be shipped to the address of the technician site assigned to the line.
Miscellaneous Address Code | The item on the part line will be shipped to the miscellaneous address assigned to the line.
Transfer Header Modified | The item on the part line will be shipped to the modified ship to address on the transfer header associated with the part line.


ServiceCallDocumentScope

Description

Used to determine the level of filtering to be used when returning service call data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Customer Id | The value for the criteria property “CustomerId” will be set to the back office customer ID mapped to the current user. The current user is specified by the Context object.


ServiceCallType

Description

Specifies the types of service calls supported in the Field Service module for Microsoft Dynamics GP.

Constant | Description
Open | Assigned to a service call that is open and has not been invoiced.
Invoiced | Assigned to a service call that has been completed and invoiced.


ServiceEquipmentScope

Description

Used to determine the level of filtering to be used when returning service equipment data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Customer ID | The value for the criteria property “CustomerId” will be set to the back office customer ID mapped to the current user. The current user is specified by the Context object.


ServiceLaborUseType

Description

Specifies the various types of labor available for a service labor line.

Constant | Description
Hotline | Identifies a hotline labor line.
Standard | Identifies a standard labor line.
Travel | Identifies a travel labor line.


ServicePartUseType

Description

Specifies the various types available for a service part line.

Constant | Description
Consumable | Assigned when the item on the part line is not marked as a returnable item.
Insert | Assigned to the installed part line when the item on the part line is marked as returnable.
Return | Assigned to the return part line when an item is marked as returnable.


ServiceTransactionState

Description

Indicates whether a sales transaction came from the Work table or the History table in Microsoft Dynamics GP.

Constant | Description
Work | Transaction is in the open table. It may be open or invoiced.
History | Transaction has been moved to the history table.


ShippingMethodType

Description

Specifies whether a shipping method is a pickup or delivery.

Constant | Description
Pickup | The items on order will be picked up.
Delivery | The item on order will be delivered.


ShippingProcessStatus

Description

Identifies the status of a sales order or sales fulfillment order within the shipping process.

Constant | Description
None | No status.
New | A new sales document.
Ready To Pick | The sales document is ready to pick.
Unconfirmed Pick | The sales document has been picked but not confirmed.
Ready To Pack | The sales document is ready to pack.
Unconfirmed Pack | The sales document has been packed but not confirmed.
Shipped | The sales document has been shipped.
Ready To Post | The sales document is ready to post.
In Process | The posting of the sales document is in process.
Complete | The posting of the sales document is complete.


StatementCycle

Description

Specifies the frequency of statements for a customer.

Constant | Description
No Statement | No statements sent
Weekly | Statements sent weekly
Bi-Weekly | Statements sent once every two weeks
Semi-Monthly | Statements sent twice each month
Monthly | Statements sent once each month
Bi-Monthly | Statements sent once every two months
Quarterly | Statements sent once each quarter


StatusGroup

Description

Identifies the status of a purchase order.

Constant | Description
Active | The purchase order is active.
Closed | The purchase order is closed.


SupportedContainment

Description

Indicates where data for a specific business object type is located.

Constant | Description
Enterprise | Data for the business object is located in the system database (DYNAMICS).
CompanyKey | Data for the business object is located in the database for a company.
AXCompanyKey | Reserved for future use.
NAVCompanyKey | Reserved for future use.


Tax1099Type

Description

Identifies the type of 1099 information, required by the US Internal Revenue Service for independent contractors and others, to be reported at the end of the year.

Constant | Description
None | No 1099 required.
Dividend | Record and report dividends paid.
Interest | Record and report interest paid.
Miscellaneous | Record and report miscellaneous amount.


TaxDetailBase

Description

Specifies the calculation base to use for calculating tax.

Constant | Description
Tax Included with Item Price | Calculates the price of an item with the tax included in the total.
Flat Amount per Unit | Calculates the amount of tax per unit sold or purchased, for example, a gasoline tax of $0.17 per gallon.
Percent of Sales/Purchase | Calculates the tax as a percentage of all that was sold or purchased.
Percent of Cost | Calculates tax as a straight percentage of the cost of an item.
Percent of Another Tax Detail | Calculates a tax amount as a percentage of another tax detail.
Percent of Sales/Purchase plus Taxable Taxes | Calculates tax as a percentage of the sale or purchase amount including any taxable tax.


TaxDetailBaseQualfiers

Description

Specifies what the taxable minimum and maximum will be compared to when taxes are calculated.

Constant | Description
Not Applicable | Does not apply for this tax detail.
Unit Amount | The taxable minimum and maximum amount will be compared to the individual amount for one unit of an item.
Extended Amount | The taxable minimum and maximum amounts will be compared to the extended amount of an item.
Invoice Total | The taxable minimum and maximum amounts will be compared to the invoice total.
Unit Amount Plus Taxable Taxes | The taxable minimum and maximum amount will be compared to the individual amount for one unit of an item including the taxable tax for that item.
Extended Amount Plus Taxable Taxes | The taxable minimum and maximum amounts will be compared to the extended amount including any taxable taxes.
Invoice Total Plus Taxable Taxes | The taxable minimum and maximum amounts will be compared to the invoice total plus any taxable taxes.


TaxDetailRangeType

Description

Indicates whether tax will be calculated on the full amount or the amount within the minimum and maximum range.

Constant | Description
Full Amount | Tax will be calculated on the full amount of the sale or purchase up to the maximum taxable amount.
Amount within Range | Tax will be calculated only on the amount within the minimum and maximum taxable amount range.


TaxDetailRounding

Description

Specifies how tax calculations will be rounded.

Constant | Description
Up to the Next Currency Decimal Digit | Round numbers to the next currency decimal digit. For example, if the tax amount is calculated to be $1.563, the tax will be $1.57.
To the Nearest Currency Decimal Digit | Round numbers to the nearest currency decimal digit. For example, if the tax amount is calculated to be $1.563, the tax will be $1.56.
Down to the Previous Currency Decimal Digit | Round numbers down to the previous whole digit. For example, if the tax amount is calculated to be $1.3306, the tax will be $1.33.
Up to the Next Whole Digit | Round numbers up to the next whole digit. For example, if the tax amount is calculated to be $1.263, the tax will be $2.00.
To the Nearest Whole Digit | Round numbers to the nearest whole digit. For example, if the tax amount is calculated to be $1.26, the tax will be $1.00. If the tax amount is calculated to be $1.51, the tax will be $2.00.
Down to the Previous Whole Digit | Round numbers down to the previous whole digit. For example, if the tax amount is calculated to be $1.563, the tax will be $1.00.


TaxDetailType

Description

Specifies how the tax detail will be used.

Constant | Description
Sales | Tax detail will be used for sales transactions.
Purchases | Tax detail will be used for purchase transactions.


ThousandsSymbol

Description

Specifies the thousands separator for the currency amounts in Microsoft Dynamics GP.

Constant | Description
Space | Separate with a space.
Period | Separate with a period.
Comma | Separate with a comma.
Apostrophe | Separate with an apostrophe.


TimeAwayFromWorkAccrualMethod

Description

Specifies how the time away from work is accrued.

Constant | Description
Hours Worked | Time away from work is based on the total number of hours worked.
Set Hours | Time away from work is the same for each pay period.


TrackingOption

Description

Specifies whether the item should be tracked by serial numbers or lot numbers in the Inventory module in Microsoft Dynamics GP.

Constant | Description
None | No tracking.
Serial Numbers | Track using serial numbers.
Lot Numbers | Track using lot numbers.


TypicalBalance

Description

Specifies whether a GL account typically has a debit balance or a credit balance in Microsoft Dynamics GP.

Constant | Description
Debit | A debit balance.
Credit | A credit balance.


UofMSalesAvailable

Description

Specifies how the unit of measure is handled on a sale of an item.

Constant | Description
Unit Of Measure Not Available For Sales Purposes | The item is not available for sales for a particular combination of price level, currency and unit of measure.
Unit Of Measure Must Be Sold In Whole Quantities | The item is available for sales only in whole units of measure for a specific combination of price level, currency and unit of measure.
Unit Of Measure Must Be Sold In Whole And Fractional Quantities | The item is available for sales in whole or fractional units of measure for a specific combination of price level, currency and unit of measure.


ValuationMethod

Description

Specifies the valuation method that will be used to determine the cost of an item in the Inventory module in Microsoft Dynamics GP.

Constant | Description
FIFO Perpetual | Items purchased first are considered sold first (First In, First Out). Detailed information about the cost of all items is maintained, and the inventory is valued at its actual cost. The current cost for items is the cost of the item the first time it was received.
LIFO Perpetual | Items purchased last are considered sold first (Last In, First Out). Detailed information about the cost of all items is maintained, and the inventory is valued at its actual cost. The current cost for items is the cost of the item the last time it was received.
Average Perpetual | The cost of items with the same item number is totaled and an average cost is assigned to the items. The average cost of an item is revalued throughout the period as you enter increase transactions for items. The average cost also is used as the current cost.
FIFO Periodic | Items purchased first are considered sold first (First In, First Out), and are valued at their standard cost. To update the standard cost, you can use the Inventory Year-End Closing window. At the end of the year, the standard cost can be adjusted to the current cost.
LIFO Periodic | Items purchased last are considered sold first (Last In, First Out), and are valued at their standard cost. To update the standard cost, you can use the Inventory Year-End Closing window. At the end of the year, the fixed cost can be adjusted to the current cost, or the cost of the item the last time it was received.


VendorManufacturingOrderScope

Description

Used to determine the level of filtering to be used when returning vendor manufacturing order data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Vendor Id | The value for the criteria property “VendorKeyId” will be set to the back office vendor ID mapped to the current user. The current user is specified by the Context object.


VendorPlannedOrderScope

Description

Used to determine the level of filtering to be used when returning vendor planned order data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Vendor Id | The value for the criteria property “VendorKeyId” will be set to the back office vendor ID mapped to the current user. The current user is specified by the Context object.


VendorScope

Description

Used to determine the level of filtering to be used when returning vendor data.

Constant | Description
Return All | The values passed in for the properties of the criteria object will be used to filter the return data set.
Return Based on Vendor Id | The value for the criteria property “VendorId” will be set to the back office vendor ID mapped to the current user. The current user is specified by the Context object.


WorkflowPriority

Description

Specifies the priority level of a document that is in a workflow process.

Constant | Description
Low | Low priority.
Normal | Normal priority.
High | High priority.


Policy reference

The policy reference provides details of each policy included with the Microsoft Dynamics GP service. The following is a list of the conventions used in this documentation.

Each policy has the following:

  • The name of the policy and a description
  • The uique ID of the policy
  • The list of behaviors available for the policy
  • Details of each behavior, such as behavior options


Create Applicant Policy

Description

The policy for the CreateApplicant web method.

ID

6eefbde5-6f9b-4d2d-844e-a79bbc1c80de

Behaviors

None


Create Applicant Education Policy

Description

The policy for the CreateApplicantEducation web method.

ID

a306a6fb-6004-40f2-9292-dda6873d8f1d

Behaviors

None


Create Applicant Interview Policy

Description

The policy for the CreateApplicantInterview web method.

ID

0fc9cf22-d4a7-4971-8b30-bdf0af2374d6

Behaviors

None


Create Applicant Reference Policy

Description

The policy for the CreateApplicantReference web method.

ID

03ff520e-df42-42ff-82af-040c8fcd4f28

Behaviors

None


Create Applicant Skill Policy

Description

The policy for the CreateApplicantSkill web method.

ID

f9eb6bee-b1eb-4063-b8ea-97a6f05917bb

Behaviors

None


Create Applicant Test Policy

Description

The policy for the CreateApplicantTest web method.

ID

8e9c8412-5f87-430c-8b2f-f8bd923c6197

Behaviors

None


Create Applicant Work History Policy

Description

The policy for the CreateApplicantWorkHistory web method.

ID

4a72edfd-2a7d-49d6-9b21-996508719696

Behaviors

None


Create Back Office Role Assignment Policy

Description

The policy for the CreateBackOfficeRoleAssignment web method.

ID

3c9f7f9a-43c3-430f-b9e3-461e9d5b0dba

Behaviors

The following behaviors are defined for this policy:

  • Default Alternate/Modified Forms and Reports ID Behavior

Default Alternate/Modified Forms and Reports ID Behavior

Description: Will determine if a default Alternate/Modified Forms and Reports ID, to be used when creating a new back office role assignment, will be specified.

Type: External

ID: 638fd2d7-d412-4f35-a729-4ba0bcb764d5

Behavior Options:

Name | Description | Parameters | ID
No Default Alternate/Modified Forms and Reports ID | No default alternate/modified forms and reports ID specified. | None | 0
Specify Default Alternate/Modified Forms and Reports ID | Specify default alternate/modified forms and reports ID. | Default Alternate/Modified Forms and Reports ID Parameter | 1

Selected option: Specify Default Alternate/Modified Forms and Reports ID


Create Cash Receipt Policy

Description

The policy for the CreateCashReceipt web method.

ID

df5521bc-6896-405c-832e-180c061c05c0

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Corporate Account Policy

Description

The policy for the CreateCorporateAccount web method.

ID

94880780-186c-43c8-b484-efcdd03cbdbf

Behaviors

None


Create Customer Address Policy

Description

The policy for the CreateCustomerAddress web method.

ID

d46910a1-f123-403a-914a-d0051021520d

Behaviors

None


Create Customer Policy

Description

The policy for the CreateCustomer web method.

ID

94880780-186c-43c8-b484-efcdd03cbdbe

Behaviors

The following behaviors are defined for this policy:

  • Create With Default Class Behavior
  • Create Address Behavior
  • Create Active Behavior
  • Customer Class Defaulting Behavior

Create With Default Class Behavior

Description: Will determine if a default customer class, to be used when creating a new customer, will be specified

Type: Internal

ID: 6c203fc2-9460-4961-9f95-2d79119d626a

Behavior Options:

Name | Description | Parameters | ID
No Default Class | No default class Id specified | None | 0
Specify Default Class | Specify default class Id | Class Id Parameter | 1

Selected option: No Default Class

Create Address Behavior

Description: Will determine whether customer addresses can be created on-the-fly

Type: Internal

ID: 971dead2-e669-4541-9670-6ffa02c7193f

Behavior Options:

Name | Description | Parameters | ID
No | No | None | 0
Yes | Yes | None | 1

Selected option: Yes

Create Active Behavior

Description: Will determine how the active status of a customer will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: 5c098de9-952c-478c-ad4b-cf992b55ea46

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use the value supplied; If a value for IsActive is not provided the customer will be set to the default (Active). | None | 0
Set To Active | Each customer is created as active. The service recommends this option for those service owners that have a very high trust level with consumers. | None | 1
Set To Inactive | Each customer is created as inactive. | None | 2

Selected option: Use Supplied Value

Customer Class Defaulting Behavior

Description: Will determine whether the customer class will be used to default other values

Type: Internal

ID: 795dd0e2-3932-4872-9b37-e75e518218be

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Customer Class | Do not use customer class to default values; property values will be set to the value passed in. Properties that do not have a value passed in and are not part of customer class will be defaulted based on the Dynamics GP business logic. | None | 0
Use Customer Class | Use the customer class Id that is passed in to default any property that is part of customer class but was not passed in. For properties that do not have a value passed in and are not part of customer class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Customer Class


Create Employee Policy

Description

The policy for the CreateEmployee web method.

ID

7a0190d1-1104-400f-9eca-0854e0c086f1

Behaviors

The following behaviors are defined for this policy:

  • Create With Default Class Behavior
  • Employee Class Defaulting Behavior
  • Create Active Behavior

Create With Default Class Behavior

Description: Will determine if a default employee class, to be used when creating a new employee, will be specified

Type: Internal

ID: 2b768e3c-05c4-48fe-a300-1ed0fe1877f3

Behavior Options:

Name | Description | Parameters | ID
No Default Class | No default class Id specified | None | 0
Specify Default Class | Specify default class Id | Class Id Parameter | 1

Selected option: No Default Class

Employee Class Defaulting Behavior

Description: Will determine whether the employee class will be used to default other values

Type: Internal

ID: 7559855c-8276-4556-ba06-663e45f3b1f3

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Employee Class | No employee class will be set | None | 0
Use Employee Class | Use the employee class Id that is passed in to default any property that is part of employee class but was not passed in. For properties that do not have a value passed in and are not part of employee class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Employee Class

Create Active Behavior

Description: Will determine how the active status of a employee will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: cc111297-3f02-4587-9251-c5205f39687d

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use the value supplied; If a value for IsActive is not provided the employee will be set to the default (Active). | None | 0
Set To Active | Each employee is created as active. The service recommends this option for those service owners that have a very high trust level with employees. | None | 1
Set To Inactive | Each employee is created as inactive. | None | 2

Selected option: Use Supplied Value


Create Employee Address Policy

Description

The policy for the CreateEmployeeAddress web method.

ID

f37afd63-1c37-4d7e-8d5b-cb7047bffc98

Behaviors

None


Create Employee Pay Code Policy

Description

The policy for the CreateEmployeePayCode web method.

ID

5bff4e6e-a103-4995-9f6a-24e827fcd02b

Behaviors

The following behaviors are defined for this policy:

  • Create Primary Pay Record Behavior
  • Create Active Behavior
  • Create With Default Class Behavior
  • EmployeePayCode Class Defaulting Behavior

Create Primary Pay Record Behavior

Description: Will determine how the primary pay record of an employee will be set; the Create Primary Pay Record behavior will always be applied. Any value provided for the IsPrimaryPayRecord property may be overwritten based on the behavior option selected.

Type: Internal

ID: 9141875a-deb1-4d31-a752-60aee0d31116

Behavior Options:

Name | Description | Parameters | ID
Use supplied value | Use the value supplied | None | 0
Set to primary | Each employeepayrecord is created as the primary pay record for that employee. The service recommends this option for those service owners that have a very high trust level with employees. | None | 1
Dont set to primary | Each pay record that is created is not set to the primary pay record of the employee | None | 2

Selected option: Use supplied value

Create Active Behavior

Description: Will determine how the active status of an employeepaycode will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: 7e181c88-acad-49be-887c-ad374a6df4a1

Behavior Options:

Name | Description | Parameters | ID
Use supplied value | Use the value supplied; If a value for IsActive is not provided the employeepaycode will be set to the default (Active). | None | 0
Set To Active | Each account is created as active. The service recommends this option for those service owners that have a very high trust level with consumers. | None | 1
Set To Inactive | Each employeepaycode is created as inactive. | None | 2

Selected option: Use supplied value

Create With Default Class Behavior

Description: Will determine if a default employeepaycode class, to be used when creating a new employee, will be specified

Type: Internal

ID: 27c45d60-1f34-46c1-a89c-b07a425a6532

Behavior Options:

Name | Description | Parameters | ID
No Default Class | No default class Id specified | None | 0
Specify Default Class | Specify default class Id | Class Id Parameter | 1

Selected option: No Default Class

EmployeePayCode Class Defaulting Behavior

Description: Will determine whether the employeepaycode class will be used to default other values

Type: Internal

ID: 57bdf69e-4742-45be-a764-edf163ffdfaf

Behavior Options:

Name | Description | Parameters | ID
Don't use the employeepaycode class | Do not use employeepaycode class to default values; property values will be set to the value passed in. For properties that do not have a value passed in and are not part of employeepaycode class, the defaulting is based on the setup from the Dynamics GP Application. (Default) | None | 0
Use the employeepaycode class | Use the employeepaycode that is passed in to default any property that is part of employeepaycode class but was not passed in. For properties that do not have a value passed in and are not part of employeepaycode class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Don't use the employeepaycode class


Create Fee Policy

Description

The policy for the CreateFee web method.

ID

bd947d2f-40ec-4d68-81f1-534401723c6c

Behaviors

The following behaviors are defined for this policy:

  • Item Class Defaulting Behavior

Item Class Defaulting Behavior

Description: Will determine whether the item class will be used to default other values

Type: Internal

ID: e744465f-be0c-4924-9eb7-1380caa8a59c

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Item Class | Do not use item class to default values; property values will be set to the value passed in. Properties that do not have a value passed in and are not part of item class will be defaulted based on the Dynamics GP business logic. | None | 0
Use Item Class | Use the item class Id that is passed in to default any property that is part of item class but was not passed in. For properties that do not have a value passed in and are not part of item class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Item Class


Create GL Fixed Allocation Account Policy

Description

The policy for the CreateGLFixedAllocationAccount web method.

ID

c69e2f3a-a77c-43ea-9ea7-0d1037c087d7

Behaviors

The following behaviors are defined for this policy:

  • Create Active Behavior
  • Post Inventory In Behavior
  • Post Payroll In Behavior
  • Post Purchasing In Behavior
  • Post Sales In Behavior

Create Active Behavior

Description: Will determine how the active status of a GL account will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b0

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use the value supplied; If a value for IsActive is not provided the account will be set to the default (Active). | None | 1
Set to Active | Each account is created as active. The service recommends this option for those service owners that have a very high trust level with consumers. | None | 2
Set to Inactive | Each account is created as inactive. | None | 3

Selected option: Use Supplied Value

Post Inventory In Behavior

Description: Will determine how to set the posting level for inventory transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b1

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value

Post Payroll In Behavior

Description: Will determine how to set the posting level for payroll transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b2

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value

Post Purchasing In Behavior

Description: Will determine how to set the posting level for purchasing transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b3

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Detail | None | 3

Selected option: Use Supplied Value

Post Sales In Behavior

Description: Will determine how to set the posting level for sales transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b4

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value


Create GL Posting Account Policy

Description

The policy for the CreateGLPostingAccount web method.

ID

c69e2f3a-a77c-43ea-9ea7-0d1037c087d6

Behaviors

The following behaviors are defined for this policy:

  • Create Active Behavior
  • Post Inventory In Behavior
  • Post Payroll In Behavior
  • Post Purchasing In Behavior
  • Post Sales In Behavior

Create Active Behavior

Description: Will determine how the active status of a GL account will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b0

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use the value supplied; If a value for IsActive is not provided the account will be set to the default (Active). | None | 1
Set to Active | Each account is created as active. The service recommends this option for those service owners that have a very high trust level with consumers. | None | 2
Set to Inactive | Each account is created as inactive. | None | 3

Selected option: Use Supplied Value

Post Inventory In Behavior

Description: Will determine how to set the posting level for inventory transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b1

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value

Post Payroll In Behavior

Description: Will determine how to set the posting level for payroll transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b2

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value

Post Purchasing In Behavior

Description: Will determine how to set the posting level for purchasing transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b3

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Detail | None | 3

Selected option: Use Supplied Value

Post Sales In Behavior

Description: Will determine how to set the posting level for sales transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b4

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value


Create GL Transaction Policy

Description

The policy for the CreateGLTransaction web method.

ID

ffa3b9a6-fa25-47a2-8179-cb37c695455e

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create Reversing Transaction
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create Reversing Transaction

Description: Will indicate if a reversing transaction will be created when the original transaction is posted

Type: External

ID: b0c9fe57-c4f0-4d6a-b0aa-ab4d6d7596c8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create Reversing Transaction | Do not create reversing transaction | None | 1
Create Reversing Transaction | Create reversing transaction | Reversing Transaction Date | 2

Selected option: Do Not Create Reversing Transaction

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create GL Unit Account Policy

Description

The policy for the CreateGLUnitAccount web method.

ID

c69e2f3a-a77c-43ea-9ea7-0d1037c087d9

Behaviors

The following behaviors are defined for this policy:

  • Create Active Behavior

Create Active Behavior

Description: Will determine how the active status of a GL account will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b0

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use the value supplied; If a value for IsActive is not provided the account will be set to the default (Active). | None | 1
Set to Active | Each account is created as active. The service recommends this option for those service owners that have a very high trust level with consumers. | None | 2
Set to Inactive | Each account is created as inactive. | None | 3

Selected option: Use Supplied Value


Create GL Variable Allocation Account Policy

Description

The policy for the CreateGLVariableAllocationAccount web method.

ID

c69e2f3a-a77c-43ea-9ea7-0d1037c087d8

Behaviors

The following behaviors are defined for this policy:

  • Create Active Behavior
  • Post Inventory In Behavior
  • Post Payroll In Behavior
  • Post Purchasing In Behavior
  • Post Sales In Behavior

Create Active Behavior

Description: Will determine how the active status of a GL account will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b0

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use the value supplied; If a value for IsActive is not provided the account will be set to the default (Active). | None | 1
Set to Active | Each account is created as active. The service recommends this option for those service owners that have a very high trust level with consumers. | None | 2
Set to Inactive | Each account is created as inactive. | None | 3

Selected option: Use Supplied Value

Post Inventory In Behavior

Description: Will determine how to set the posting level for inventory transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b1

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value

Post Payroll In Behavior

Description: Will determine how to set the posting level for payroll transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b2

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value

Post Purchasing In Behavior

Description: Will determine how to set the posting level for purchasing transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b3

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Detail | None | 3

Selected option: Use Supplied Value

Post Sales In Behavior

Description: Will determine how to set the posting level for sales transactions for a GL account

Type: Internal

ID: f56b2aee-6a79-4918-9977-4109cc44f5b4

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use Supplied Value | None | 1
Set To Detail | Set To Detail | None | 2
Set To Summary | Set To Summary | None | 3

Selected option: Use Supplied Value


Create HRRequisition Policy

Description

The policy for the CreateHRRequisition web method.

ID

1acae4dd-a7e5-49d8-895c-2ed6f424207e

Behaviors

The following behaviors are defined for this policy:

  • Create Status Behavior

Create Status Behavior

Description: Provide a behavior mechanism that provides the following options: a. Use supplied value (Default) b. Set to open

Type: Internal

ID: 5d231ac7-78d4-45e1-a71a-5087669d5e27

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use the value supplied; If a value for Status is not provided the employee will be set to the default (Open). | None | 0
Set To Open | Each HRRequisition is created as open. | None | 1

Selected option: Use Supplied Value


Create Inventory Adjustment Policy

Description

The policy for the CreateInventoryAdjustment web method.

ID

0984fa28-3c71-4773-a9c2-fbfca9541d6a

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Post To General Ledger Behavior
  • Bin Quantity Shortage Behavior
  • Create Inventory Serial Behavior
  • Create Inventory Lot Behavior
  • Create Batch
  • Create Bins Behavior
  • Inventory Transaction Quantity Shortage Behavior
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Post To General Ledger Behavior

Description: Will determine if an inventory transaction can be posted to general ledger

Type: External

ID: fb16647f-a1c0-4681-af11-0e3155b1c7be

Behavior Options:

Name | Description | Parameters | ID
Do Not Post to General Ledger | Do not post to General Ledger | None | 0
Post to General Ledger | Post to General Ledger | None | 1

Selected option: Post to General Ledger

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Inventory Transaction Quantity Shortage Behavior

Description: Will determine the quantity to use when there is a quantity shortage on an inventory transaction

Type: External

ID: 65186885-8099-44d1-bdf4-e5753ff04954

Behavior Options:

Name | Description | Parameters | ID
Inventory Transaction Quantity Shortage Behavior | Will determine the quantity to use when there is a quantity shortage on an inventory transaction | None | 0
Inventory Transaction Quantity Shortage Behavior | Will determine the quantity to use when there is a quantity shortage on an inventory transaction | None | 1

Selected option: Inventory Transaction Quantity Shortage Behavior

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Inventory Transfer Policy

Description

The policy for the CreateInventoryTransfer web method.

ID

deb66f76-317a-48b3-9491-bfe234e1fee7

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Post To General Ledger Behavior
  • Bin Quantity Shortage Behavior
  • Create Inventory Serial Behavior
  • Create Inventory Lot Behavior
  • Create Batch
  • Create Bins Behavior
  • Inventory Transaction Quantity Shortage Behavior
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Post To General Ledger Behavior

Description: Will determine if an inventory transaction can be posted to general ledger

Type: External

ID: fb16647f-a1c0-4681-af11-0e3155b1c7be

Behavior Options:

Name | Description | Parameters | ID
Do Not Post to General Ledger | Do not post to General Ledger | None | 0
Post to General Ledger | Post to General Ledger | None | 1

Selected option: Post to General Ledger

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Inventory Transaction Quantity Shortage Behavior

Description: Will determine the quantity to use when there is a quantity shortage on an inventory transaction

Type: External

ID: 65186885-8099-44d1-bdf4-e5753ff04954

Behavior Options:

Name | Description | Parameters | ID
Inventory Transaction Quantity Shortage Behavior | Will determine the quantity to use when there is a quantity shortage on an inventory transaction | None | 0
Inventory Transaction Quantity Shortage Behavior | Will determine the quantity to use when there is a quantity shortage on an inventory transaction | None | 1

Selected option: Inventory Transaction Quantity Shortage Behavior

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Inventory Variance Policy

Description

The policy for the CreateInventoryVariance web method.

ID

bfe41b59-e4e7-44e2-b43f-d491b8b111b3

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Post To General Ledger Behavior
  • Bin Quantity Shortage Behavior
  • Create Inventory Serial Behavior
  • Create Inventory Lot Behavior
  • Create Batch
  • Create Bins Behavior
  • Inventory Transaction Quantity Shortage Behavior
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Post To General Ledger Behavior

Description: Will determine if an inventory transaction can be posted to general ledger

Type: External

ID: fb16647f-a1c0-4681-af11-0e3155b1c7be

Behavior Options:

Name | Description | Parameters | ID
Do Not Post to General Ledger | Do not post to General Ledger | None | 0
Post to General Ledger | Post to General Ledger | None | 1

Selected option: Post to General Ledger

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Inventory Transaction Quantity Shortage Behavior

Description: Will determine the quantity to use when there is a quantity shortage on an inventory transaction

Type: External

ID: 65186885-8099-44d1-bdf4-e5753ff04954

Behavior Options:

Name | Description | Parameters | ID
Inventory Transaction Quantity Shortage Behavior | Will determine the quantity to use when there is a quantity shortage on an inventory transaction | None | 0
Inventory Transaction Quantity Shortage Behavior | Will determine the quantity to use when there is a quantity shortage on an inventory transaction | None | 1

Selected option: Inventory Transaction Quantity Shortage Behavior

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Item Currency Policy

Description

The policy for the CreateItemCurrency web method.

ID

992b50a4-cfc8-45f4-b926-ae67e848f70f

Behaviors

None


Create Item Vendor Policy

Description

The policy for the CreateItemVendor web method.

ID

29a58753-a72e-46ee-80e2-688dca335732

Behaviors

None


Create Item Warehouse Policy

Description

The policy for the CreateItemWarehouse web method.

ID

95a05f2d-4a93-4426-b967-e602cc736dda

Behaviors

None


Create Kit Policy

Description

The policy for the CreateKit web method.

ID

3de0e913-c9f9-4962-8892-868eabf05950

Behaviors

The following behaviors are defined for this policy:

  • Item Class Defaulting Behavior

Item Class Defaulting Behavior

Description: Will determine whether the item class will be used to default other values

Type: Internal

ID: e744465f-be0c-4924-9eb7-1380caa8a59c

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Item Class | Do not use item class to default values; property values will be set to the value passed in. Properties that do not have a value passed in and are not part of item class will be defaulted based on the Dynamics GP business logic. | None | 0
Use Item Class | Use the item class Id that is passed in to default any property that is part of item class but was not passed in. For properties that do not have a value passed in and are not part of item class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Item Class


Create Payables Credit Memo Policy

Description

The policy for the CreatePayablesCreditMemo web method.

ID

e181b53c-2679-45c6-8101-78d0708b9c3f

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Payables Finance Charge Policy

Description

The policy for the CreatePayablesFinanceCharge web method.

ID

0a9f9814-cb08-4360-a57d-d31f147df5fa

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Payables Invoice Policy

Description

The policy for the CreatePayablesInvoice web method.

ID

f39624cb-97f1-4d5a-a67f-9b66e95d8930

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Payables Miscellaneous Charge Policy

Description

The policy for the CreatePayablesMiscellaneousCharge web method.

ID

1ff7b739-37d8-4962-b2f1-ac51540c0e5f

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Payables Return Policy

Description

The policy for the CreatePayablesReturn web method.

ID

36077df7-d30a-4266-8ef6-18ab55557e9a

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Pricing Policy

Description

The policy for the CreatePricing web method.

ID

23067418-06b0-40da-9e16-4746044745be

Behaviors

None


Create Purchase Invoice Policy

Description

The policy for the CreatePurchaseInvoice web method.

ID

bfae00ff-7681-491f-a203-101e4ff92332

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Auto Invoice Behavior
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Auto Invoice Behavior

Description: Will determine whether or not to automatically invoice the shipments that have been received against the purchase order number that is passed in for a purchase invoice transaction

Type: External

ID: 80e18e3b-76de-4473-aff8-dd4632b5901b

Behavior Options:

Name | Description | Parameters | ID
Do Not Auto Create Invoice | Do not automatically create invoice | None | 0
Auto Create Invoice | Automatically create invoice | None | 1

Selected option: Do Not Auto Create Invoice

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Purchase Order Policy

Description

The policy for the CreatePurchaseOrder web method.

ID

c3b14f1e-b7b9-49c3-bce4-d1717bb5a4ab

Behaviors

None


Create Purchase Receipt Policy

Description

The policy for the CreatePurchaseReceipt web method.

ID

b49ba9f1-a546-4478-868f-0b13d83fe9cc

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Create Bins Behavior
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Receivables Credit Memo Policy

Description

The policy for the CreateReceivablesCreditMemo web method.

ID

e852915e-bc65-4048-8aa8-b9c346bad320

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Receivables Debit Memo Policy

Description

The policy for the CreateReceivablesDebitMemo web method.

ID

dfafce69-1d94-4d34-ba92-2ef07ee63df8

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Receivables Finance Charge Policy

Description

The policy for the CreateReceivablesFinanceCharge web method.

ID

7a7b7a43-0e7f-4d4e-bf67-15a8b576ad49

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Receivables Invoice Policy

Description

The policy for the CreateReceivablesInvoice web method.

ID

b0845ab6-ecac-400a-bb06-dd177c48a1f2

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Receivables Return Policy

Description

The policy for the CreateReceivablesReturn web method.

ID

40eb2079-cb7e-413b-b7ab-7f1e8a52173c

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Receivables Service Repair Policy

Description

The policy for the CreateReceivablesServiceRepair web method.

ID

12a3a22e-ff96-4394-86a6-6ea34aa25a9a

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Receivables Warranty Policy

Description

The policy for the CreateReceivablesWarranty web method.

ID

2ec2d5da-a703-4630-9ee0-b22045675ecb

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Create GL Account Distributions Behavior
  • Create Batch
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Return Material Authorization Policy

Description

The policy for the CreateReturnMaterialAuthorization web method.

ID

d0b1b8e3-1e4f-4926-8e4f-6a5c2a1c874b

Behaviors

The following behaviors are defined for this policy:

  • Create Inventory Lot Behavior
  • Check Hold Behavior

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: e0205846-ddf1-4536-8220-d23e6a8cbf70

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Check Status | Check status | None | 1

Selected option: Check Status


Create Sales Backorder Policy

Description

The policy for the CreateSalesBackorder web method.

ID

87d55f8e-50d4-40b0-a447-b57b472f95e5

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Calculate Unit Price Behavior
  • Calculate Total Amount Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Miscellaneous Tax Behavior
  • Create Batch
  • Freight Tax Behavior
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Sales Fulfillment Order Policy

Description

The policy for the CreateSalesFulfillmentOrder web method.

ID

d08d5e3b-19a7-47b1-a5b4-e32cbc3178cb

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Calculate Unit Price Behavior
  • Bin Quantity Shortage Behavior
  • Calculate Total Amount Behavior
  • Create Inventory Serial Behavior
  • Allocate Lots Behavior
  • Create GL Account Distributions Behavior
  • Include Promotions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Allocate Quantities Behavior
  • Check Credit Limit Behavior
  • Assign Bin Behavior
  • Create Inventory Lot Behavior
  • Allocate Serials Behavior
  • Use Header Level Taxes Behavior
  • Miscellaneous Tax Behavior
  • Create Batch
  • Create Bins Behavior
  • Freight Tax Behavior
  • Day of Week
  • Create Taxes Behavior
  • Quantity Shortage Behavior

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Lots Behavior

Description: Used to determine how lot numbers are fulfilled on a sales document line.

Type: Internal

ID: 17fa7992-d96a-481c-b15f-29181ed3fd92

Behavior Options:

Name | Description | Parameters | ID
Automatic | Lot number fulfillment will be automatic | None | 0
Manual | Lot numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided lot numbers are fulfilled will be automatically fulfilled. | None | 2

Selected option: Automatic

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Include Promotions Behavior

Description: Will determine the application of promotions to the line (i.e. percentage off, value off, or quantity fee)

Type: External

ID: 2e58b57c-8fe1-4e98-bf04-371621f8e8b7

Behavior Options:

Name | Description | Parameters | ID
Do Not Include | Do not include promotions | None | 0
Include | Include promotions | None | 1

Selected option: Do Not Include

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Allocate Quantities Behavior

Description: Will determine how quantities on the sales document are allocated

Type: Internal

ID: 97bd3863-2f87-4079-aef4-8b35ee3a5c3c

Behavior Options:

Name | Description | Parameters | ID
Based on Type Id | Allocate quantities based on the document type Id of the sales document | None | 0
Allocate | Allocate quantities | None | 1

Selected option: Based on Type Id

Check Credit Limit Behavior

Description: Will determine whether the customer's credit limit will be checked when the document is created

Type: Internal

ID: 6cc8431e-7d60-4850-bb07-a66d4d4adb2c

Behavior Options:

Name | Description | Parameters | ID
Override Credit Limit | Override credit limit | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Assign Bin Behavior

Description: Will determine whether bins are automatically assigned

Type: Internal

ID: 80ad078e-5787-4e75-8cfb-a8d652d93eab

Behavior Options:

Name | Description | Parameters | ID
Do Not Assign | Do not assign bin | None | 0
Assign Bin | Automatically assign bin | None | 1

Selected option: Assign Bin

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Serials Behavior

Description: Will determine how serial numbers are allocated on a sales document line

Type: Internal

ID: 75d49cdf-0a3e-4b4e-9c39-c9d603d17973

Behavior Options:

Name | Description | Parameters | ID
Automatic | Serial number fulfillment will be automatic | None | 0
Manual | Serial numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided serial numbers are fulfilled will be automatically fulfilled | None | 2

Selected option: Automatic

Use Header Level Taxes Behavior

Description: Will determine whether detail taxes are being provided

Type: Internal

ID: 74fda1f6-b7b6-4cfe-a38b-d6ad5b39e57e

Behavior Options:

Name | Description | Parameters | ID
Detail Taxes Will Be Provided | Detail taxes will be provided | None | 0
Header Taxes Will Be Provided | Header level taxes will be provided | None | 1

Selected option: Detail Taxes Will Be Provided

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday

Create Taxes Behavior

Description: Will determine whether the tax engine will be used to calculate the taxes or if the tax details will be manually provided

Type: Internal

ID: 47105c7b-7a08-4c89-8204-f9e3538d1eb9

Behavior Options:

Name | Description | Parameters | ID
Taxes Will Be Provided | Taxes will be provided | None | 0
Automatically Create Taxes | Automatically create taxes | None | 1

Selected option: Automatically Create Taxes

Quantity Shortage Behavior

Description: Will determine how to proceed when there is a quantity shortage

Type: External

ID: 3ea346a7-69f5-403d-87cf-fc3d9e5a9c9d

Behavior Options:

Name | Description | Parameters | ID
Sell Balance | Sell Balance | None | 1
Override | Override | None | 2
Backorder All | Backorder All | None | 3
Backorder Balance | Backorder Balance | None | 4
Cancel All | Cancel All | None | 5
Cancel Balance | Cancel Balance | None | 6

Selected option: Override


Create Sales Invoice Policy

Description

The policy for the CreateSalesInvoice web method.

ID

f7d96bfa-487f-4958-9774-5de37e937045

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Calculate Unit Price Behavior
  • Bin Quantity Shortage Behavior
  • Calculate Total Amount Behavior
  • Create Inventory Serial Behavior
  • Allocate Lots Behavior
  • Create GL Account Distributions Behavior
  • Include Promotions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Allocate Quantities Behavior
  • Check Credit Limit Behavior
  • Assign Bin Behavior
  • Create Inventory Lot Behavior
  • Allocate Serials Behavior
  • Use Header Level Taxes Behavior
  • Miscellaneous Tax Behavior
  • Create Batch
  • Create Bins Behavior
  • Freight Tax Behavior
  • Day of Week
  • Create Taxes Behavior
  • Quantity Shortage Behavior

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Lots Behavior

Description: Used to determine how lot numbers are fulfilled on a sales document line.

Type: Internal

ID: 17fa7992-d96a-481c-b15f-29181ed3fd92

Behavior Options:

Name | Description | Parameters | ID
Automatic | Lot number fulfillment will be automatic | None | 0
Manual | Lot numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided lot numbers are fulfilled will be automatically fulfilled. | None | 2

Selected option: Automatic

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Include Promotions Behavior

Description: Will determine the application of promotions to the line (i.e. percentage off, value off, or quantity fee)

Type: External

ID: 2e58b57c-8fe1-4e98-bf04-371621f8e8b7

Behavior Options:

Name | Description | Parameters | ID
Do Not Include | Do not include promotions | None | 0
Include | Include promotions | None | 1

Selected option: Do Not Include

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Allocate Quantities Behavior

Description: Will determine how quantities on the sales document are allocated

Type: Internal

ID: 97bd3863-2f87-4079-aef4-8b35ee3a5c3c

Behavior Options:

Name | Description | Parameters | ID
Based on Type Id | Allocate quantities based on the document type Id of the sales document | None | 0
Allocate | Allocate quantities | None | 1

Selected option: Based on Type Id

Check Credit Limit Behavior

Description: Will determine whether the customer's credit limit will be checked when the document is created

Type: Internal

ID: 6cc8431e-7d60-4850-bb07-a66d4d4adb2c

Behavior Options:

Name | Description | Parameters | ID
Override Credit Limit | Override credit limit | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Assign Bin Behavior

Description: Will determine whether bins are automatically assigned

Type: Internal

ID: 80ad078e-5787-4e75-8cfb-a8d652d93eab

Behavior Options:

Name | Description | Parameters | ID
Do Not Assign | Do not assign bin | None | 0
Assign Bin | Automatically assign bin | None | 1

Selected option: Assign Bin

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Serials Behavior

Description: Will determine how serial numbers are allocated on a sales document line

Type: Internal

ID: 75d49cdf-0a3e-4b4e-9c39-c9d603d17973

Behavior Options:

Name | Description | Parameters | ID
Automatic | Serial number fulfillment will be automatic | None | 0
Manual | Serial numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided serial numbers are fulfilled will be automatically fulfilled | None | 2

Selected option: Automatic

Use Header Level Taxes Behavior

Description: Will determine whether detail taxes are being provided

Type: Internal

ID: 74fda1f6-b7b6-4cfe-a38b-d6ad5b39e57e

Behavior Options:

Name | Description | Parameters | ID
Detail Taxes Will Be Provided | Detail taxes will be provided | None | 0
Header Taxes Will Be Provided | Header level taxes will be provided | None | 1

Selected option: Detail Taxes Will Be Provided

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday

Create Taxes Behavior

Description: Will determine whether the tax engine will be used to calculate the taxes or if the tax details will be manually provided

Type: Internal

ID: 47105c7b-7a08-4c89-8204-f9e3538d1eb9

Behavior Options:

Name | Description | Parameters | ID
Taxes Will Be Provided | Taxes will be provided | None | 0
Automatically Create Taxes | Automatically create taxes | None | 1

Selected option: Automatically Create Taxes

Quantity Shortage Behavior

Description: Will determine how to proceed when there is a quantity shortage

Type: External

ID: 3ea346a7-69f5-403d-87cf-fc3d9e5a9c9d

Behavior Options:

Name | Description | Parameters | ID
Sell Balance | Sell Balance | None | 1
Override | Override | None | 2
Backorder All | Backorder All | None | 3
Backorder Balance | Backorder Balance | None | 4
Cancel All | Cancel All | None | 5
Cancel Balance | Cancel Balance | None | 6

Selected option: Override


Create Sales Item Policy

Description

The policy for the CreateSalesItem web method.

ID

60c582b3-84cc-400a-bc43-f5583c387ce0

Behaviors

The following behaviors are defined for this policy:

  • Item Class Defaulting Behavior

Item Class Defaulting Behavior

Description: Will determine whether the item class will be used to default other values

Type: Internal

ID: e744465f-be0c-4924-9eb7-1380caa8a59c

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Item Class | Do not use item class to default values; property values will be set to the value passed in. Properties that do not have a value passed in and are not part of item class will be defaulted based on the Dynamics GP business logic. | None | 0
Use Item Class | Use the item class Id that is passed in to default any property that is part of item class but was not passed in. For properties that do not have a value passed in and are not part of item class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Item Class


Create Sales Order Policy

Description

The policy for the CreateSalesOrder web method.

ID

4d060bdc-fa1e-4ea1-9e89-e1d19a5cb2ce

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Calculate Unit Price Behavior
  • Bin Quantity Shortage Behavior
  • Calculate Total Amount Behavior
  • Create Inventory Serial Behavior
  • Allocate Lots Behavior
  • Include Promotions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Allocate Quantities Behavior
  • Check Credit Limit Behavior
  • Assign Bin Behavior
  • Create Inventory Lot Behavior
  • Allocate Serials Behavior
  • Miscellaneous Tax Behavior
  • Create Batch
  • Create Bins Behavior
  • Freight Tax Behavior
  • Day of Week
  • Quantity Shortage Behavior

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Lots Behavior

Description: Used to determine how lot numbers are fulfilled on a sales document line.

Type: Internal

ID: 17fa7992-d96a-481c-b15f-29181ed3fd92

Behavior Options:

Name | Description | Parameters | ID
Automatic | Lot number fulfillment will be automatic | None | 0
Manual | Lot numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided lot numbers are fulfilled will be automatically fulfilled. | None | 2

Selected option: Automatic

Include Promotions Behavior

Description: Will determine the application of promotions to the line (i.e. percentage off, value off, or quantity fee)

Type: External

ID: 2e58b57c-8fe1-4e98-bf04-371621f8e8b7

Behavior Options:

Name | Description | Parameters | ID
Do Not Include | Do not include promotions | None | 0
Include | Include promotions | None | 1

Selected option: Do Not Include

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Allocate Quantities Behavior

Description: Will determine how quantities on the sales document are allocated

Type: Internal

ID: 97bd3863-2f87-4079-aef4-8b35ee3a5c3c

Behavior Options:

Name | Description | Parameters | ID
Based on Type Id | Allocate quantities based on the document type Id of the sales document | None | 0
Allocate | Allocate quantities | None | 1

Selected option: Based on Type Id

Check Credit Limit Behavior

Description: Will determine whether the customer's credit limit will be checked when the document is created

Type: Internal

ID: 6cc8431e-7d60-4850-bb07-a66d4d4adb2c

Behavior Options:

Name | Description | Parameters | ID
Override Credit Limit | Override credit limit | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Assign Bin Behavior

Description: Will determine whether bins are automatically assigned

Type: Internal

ID: 80ad078e-5787-4e75-8cfb-a8d652d93eab

Behavior Options:

Name | Description | Parameters | ID
Do Not Assign | Do not assign bin | None | 0
Assign Bin | Automatically assign bin | None | 1

Selected option: Assign Bin

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Serials Behavior

Description: Will determine how serial numbers are allocated on a sales document line

Type: Internal

ID: 75d49cdf-0a3e-4b4e-9c39-c9d603d17973

Behavior Options:

Name | Description | Parameters | ID
Automatic | Serial number fulfillment will be automatic | None | 0
Manual | Serial numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided serial numbers are fulfilled will be automatically fulfilled | None | 2

Selected option: Automatic

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday

Quantity Shortage Behavior

Description: Will determine how to proceed when there is a quantity shortage

Type: External

ID: 3ea346a7-69f5-403d-87cf-fc3d9e5a9c9d

Behavior Options:

Name | Description | Parameters | ID
Sell Balance | Sell Balance | None | 1
Override | Override | None | 2
Backorder All | Backorder All | None | 3
Backorder Balance | Backorder Balance | None | 4
Cancel All | Cancel All | None | 5
Cancel Balance | Cancel Balance | None | 6

Selected option: Override


Create Sales Process Hold Setup Policy

Description

The policy for the CreateSalesProcessHoldSetup web method.

ID

e0aaef51-f042-4f94-8be2-70e84892a4af

Behaviors

None


Create Sales Quote Policy

Description

The policy for the CreateSalesQuote web method.

ID

16106f07-2c64-41fe-b08d-f2386624dceb

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Calculate Unit Price Behavior
  • Calculate Total Amount Behavior
  • Include Promotions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Miscellaneous Tax Behavior
  • Create Batch
  • Freight Tax Behavior
  • Day of Week

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Include Promotions Behavior

Description: Will determine the application of promotions to the line (i.e. percentage off, value off, or quantity fee)

Type: External

ID: 2e58b57c-8fe1-4e98-bf04-371621f8e8b7

Behavior Options:

Name | Description | Parameters | ID
Do Not Include | Do not include promotions | None | 0
Include | Include promotions | None | 1

Selected option: Do Not Include

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday


Create Sales Return Policy

Description

The policy for the CreateSalesReturn web method.

ID

07f575f9-c6c3-424c-8162-19ab5b4af372

Behaviors

The following behaviors are defined for this policy:

  • Assign Batch Prefix
  • Calculate Unit Price Behavior
  • Calculate Total Amount Behavior
  • Create GL Account Distributions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Use Header Level Taxes Behavior
  • Miscellaneous Tax Behavior
  • Create Batch
  • Create Bins Behavior
  • Freight Tax Behavior
  • Day of Week
  • Create Taxes Behavior

Assign Batch Prefix

Description: Will determine if a prefix for the batch Id will be provided

Type: Internal

ID: dc788b46-e2ae-4b7a-80c2-00cb40dcf76f

Behavior Options:

Name | Description | Parameters | ID
No Prefix | No prefix will be specified for the Batch Id | None | 1
Specify Prefix | A prefix will be specified for the Batch Id | Prefix | 2

Selected option: No Prefix

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Use Header Level Taxes Behavior

Description: Will determine whether detail taxes are being provided

Type: Internal

ID: 74fda1f6-b7b6-4cfe-a38b-d6ad5b39e57e

Behavior Options:

Name | Description | Parameters | ID
Detail Taxes Will Be Provided | Detail taxes will be provided | None | 0
Header Taxes Will Be Provided | Header level taxes will be provided | None | 1

Selected option: Detail Taxes Will Be Provided

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Batch

Description: Specifies the naming method to use when a new batch is created by the web service, if the name of the batch was not supplied

Type: Internal

ID: 5855c79b-17a8-43b6-ab4f-db52e64fd0bd

Behavior Options:

Name | Description | Parameters | ID
Hourly | The batch name will use the following format: Numeric representation of year, month, and day, followed by the letter "H" and then the hour in 24-hour format. For example, 20060710H17 represents July 10, 2006 at 5 p.m | None | 1
Daily | The batch name will use the following format: Numeric representation of the year, month, and day. For example, 20060710 represents July 10, 2006 | None | 2
Weekly | The batch name will use the following format: Numeric representation of the year, followed by the letter "W", the numeric representation of the current week in the year, and finally the value specified by the Day of Week behavior. For example, 2006W2802 represents Tuesday of the 28th week of 2006 | None | 3

Selected option: Hourly

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Day of Week

Description: If the Create Batch behavior is set to Weekly, specifies the value to use in the day of the week portion of the batch name created by the web service

Type: Internal

ID: c4f96f80-69bd-4a67-ac0f-f019fa79bb1c

Behavior Options:

Name | Description | Parameters | ID
Monday | The value "01" representing Monday | None | 1
Tuesday | The value "02" representing Tuesday | None | 2
Wednesday | The value "03" representing Wednesday | None | 3
Thursday | The value "04" representing Thursday | None | 4
Friday | The value "05" representing Friday | None | 5
Saturday | The value "06" representing Saturday | None | 6
Sunday | The value "07" representing Sunday | None | 7

Selected option: Monday

Create Taxes Behavior

Description: Will determine whether the tax engine will be used to calculate the taxes or if the tax details will be manually provided

Type: Internal

ID: 47105c7b-7a08-4c89-8204-f9e3538d1eb9

Behavior Options:

Name | Description | Parameters | ID
Taxes Will Be Provided | Taxes will be provided | None | 0
Automatically Create Taxes | Automatically create taxes | None | 1

Selected option: Automatically Create Taxes


Create Service Call Policy

Description

The policy for the CreateServiceCall web method.

ID

7addaefe-4e5c-4d6f-97c1-6ee9ca58ee3c

Behaviors

The following behaviors are defined for this policy:

  • Create Labor Behavior
  • Create Inventory Lot Behavior
  • Check Hold Behavior

Create Labor Behavior

Description: Create Labor Behavior

Type: Internal

ID: 6554f82d-6de9-4d15-b853-b329917bc023

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: e0205846-ddf1-4536-8220-d23e6a8cbf70

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Check Status | Check status | None | 1

Selected option: Check Status


Create Service Equipment Policy

Description

The policy for the CreateServiceEquipment web method.

ID

e2ef3ca6-74de-473b-86fe-45798962b7ab

Behaviors

None


Create Service Policy

Description

The policy for the CreateService web method.

ID

e3502818-e50a-4997-87b9-3a81bc22f835

Behaviors

The following behaviors are defined for this policy:

  • Item Class Defaulting Behavior

Item Class Defaulting Behavior

Description: Will determine whether the item class will be used to default other values

Type: Internal

ID: e744465f-be0c-4924-9eb7-1380caa8a59c

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Item Class | Do not use item class to default values; property values will be set to the value passed in. Properties that do not have a value passed in and are not part of item class will be defaulted based on the Dynamics GP business logic. | None | 0
Use Item Class | Use the item class Id that is passed in to default any property that is part of item class but was not passed in. For properties that do not have a value passed in and are not part of item class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Item Class


Create Service Quote Policy

Description

The policy for the CreateServiceQuote web method.

ID

bbe0c06a-27a8-413d-b4cd-e8a96c6d80dc

Behaviors

The following behaviors are defined for this policy:

  • Check Hold Behavior

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: e0205846-ddf1-4536-8220-d23e6a8cbf70

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Check Status | Check status | None | 1

Selected option: Check Status


Create Skill Policy

Description

The policy for the CreateSkill web method.

ID

cd7e9757-b0be-424c-a3d0-e439fb2b5f25

Behaviors

None


Create Skillset Policy

Description

The policy for the CreateSkillset web method.

ID

f69f98e3-8416-4766-a975-570f80e5c28e

Behaviors

None


Create Vendor Address Policy

Description

The policy for the CreateVendorAddress web method.

ID

66e1feb2-68db-4fd5-a431-70f2fe128cd4

Behaviors

None


Create Vendor Policy

Description

The policy for the CreateVendor web method.

ID

66e1feb2-68db-4fd5-a431-70f2fe128cd1

Behaviors

The following behaviors are defined for this policy:

  • Create Active Behavior
  • Vendor Class Defaulting Behavior
  • Create With Default Class Behavior
  • Create Address Behavior

Create Active Behavior

Description: Will determine how the active status of a vendor will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: 7b5d30f0-e152-4818-a196-6ba3accd8d31

Behavior Options:

Name | Description | Parameters | ID
Use Supplied Value | Use the value supplied; If a value for IsActive is not provided the vendor will be set to the default (Active). | None | 0
Set To Active | Each vendor is created as active. The service recommends this option for those service owners that have a very high trust level with consumers. | None | 1
Set To Inactive | Each vendor is created as inactive. | None | 2

Selected option: Use Supplied Value

Vendor Class Defaulting Behavior

Description: Will determine whether the vendor class will be used to default other values

Type: Internal

ID: 7b5d30f0-e152-4818-a196-6ba3accd8d32

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Vendor Class | Do not use vendor class to default values; property values will be set to the value passed in. Properties that do not have a value passed in and are not part of vendor class will be defaulted based on the Dynamics GP business logic. | None | 0
Use Vendor Class | Use the vendor class Id that is passed in to default any property that is part of vendor class but was not passed in. For properties that do not have a value passed in and are not part of vendor class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Vendor Class

Create With Default Class Behavior

Description: Will determine if a default vendor class, to be used when creating a new vendor, will be specified

Type: Internal

ID: 7b5d30f0-e152-4818-a196-6ba3accd8d33

Behavior Options:

Name | Description | Parameters | ID
No Default Class | No default class Id specified | None | 0
Specify Default Class | Specify default class Id | Class Id Parameter | 1

Selected option: No Default Class

Create Address Behavior

Description: Will determine whether vendor addresses can be created on-the-fly

Type: Internal

ID: 7b5d30f0-e152-4818-a196-6ba3accd8d34

Behavior Options:

Name | Description | Parameters | ID
No | No | None | 0
Yes | Yes | None | 1

Selected option: Yes


Create Warehouse Policy

Description

The policy for the CreateWarehouse web method.

ID

7dfc19e9-5c8b-4f53-b455-1a605f3b2656

Behaviors

None


Delete Applicant Policy

Description

The policy for the DeleteApplicant web method.

ID

df0ce8ce-1602-4fb4-aa8e-9bb97bd301c6

Behaviors

None


Delete Applicant Education Policy

Description

The policy for the DeleteApplicantEducation web method.

ID

75438c34-9b5b-449d-852c-020f511b9a27

Behaviors

None


Delete Applicant Interview Policy

Description

The policy for the DeleteApplicantInterview web method.

ID

8ca23b29-2c2e-41dd-92d8-6390417c91fa

Behaviors

None


Delete Applicant Reference Policy

Description

The policy for the DeleteApplicantReference web method.

ID

45207f5f-a649-43a2-8b3a-313d7fc42634

Behaviors

None


Delete Applicant Skill Policy

Description

The policy for the DeleteApplicantSkill web method.

ID

336a0c80-447d-4c8d-a1d1-2ebc320b24d8

Behaviors

None


Delete Applicant Test Policy

Description

The policy for the DeleteApplicantTest web method.

ID

311d983e-f471-4d00-9f97-74cb64b79be4

Behaviors

None


Delete Applicant Work History Policy

Description

The policy for the DeleteApplicantWorkHistory web method.

ID

8c8dc586-cc54-421a-8f08-6f05912fdebd

Behaviors

None


Delete Customer Address Policy

Description

The policy for the DeleteCustomerAddress web method.

ID

7fc12ad2-33d4-48f7-8514-00baf43421f3

Behaviors

None


Delete Customer Policy

Description

The policy for the DeleteCustomer web method.

ID

5186e19e-c379-45a1-855f-c5c665b246b7

Behaviors

None


Delete Employee Address Policy

Description

The policy for the DeleteEmployeeAddress web method.

ID

146d6980-15e1-481a-89d7-18ed9849b76a

Behaviors

None


Delete Purchase Order Policy

Description

The policy for the DeletePurchaseOrder web method.

ID

2c9cfe9c-b29d-461b-aca1-547317133ded

Behaviors

None


Delete Sales Backorder Policy

Description

The policy for the DeleteSalesBackorder web method.

ID

b83410d0-bd4c-44af-9aea-e8fbff1338bd

Behaviors

The following behaviors are defined for this policy:

  • Remove Posted Deposits

Remove Posted Deposits

Description: Will determine whether the posted deposits on a voided or deleted document are to be removed

Type: External

ID: 0f2c414b-fd12-4d83-940b-2bc0d65c3b77

Behavior Options:

Name | Description | Parameters | ID
Do Not Remove | Do not remove posted deposits | None | 0
Remove | Remove posted deposits and post reversing entry to GL | None | 1

Selected option: Remove


Delete Sales Fulfillment Order Policy

Description

The policy for the DeleteSalesFulfillmentOrder web method.

ID

10c901c6-7cf7-4855-86ff-14295d5c3948

Behaviors

None


Delete Sales Invoice Policy

Description

The policy for the DeleteSalesInvoice web method.

ID

579aa132-c360-4161-9e8f-8df9feb1f568

Behaviors

None


Delete Sales Order Policy

Description

The policy for the DeleteSalesOrder web method.

ID

636d3d67-ec01-4819-9409-81cb38273acb

Behaviors

The following behaviors are defined for this policy:

  • Remove Posted Deposits

Remove Posted Deposits

Description: Will determine whether the posted deposits on a voided or deleted document are to be removed

Type: External

ID: 0f2c414b-fd12-4d83-940b-2bc0d65c3b77

Behavior Options:

Name | Description | Parameters | ID
Do Not Remove | Do not remove posted deposits | None | 0
Remove | Remove posted deposits and post reversing entry to GL | None | 1

Selected option: Remove


Delete Sales Quote Policy

Description

The policy for the DeleteSalesQuote web method.

ID

35a19cc2-857e-40f5-9054-61f48386b4e0

Behaviors

None


Delete Sales Return Policy

Description

The policy for the DeleteSalesReturn web method.

ID

54f877ef-5271-4d3d-889c-6a1feb1ec46f

Behaviors

None


Delete Skill Policy

Description

The policy for the DeleteSkill web method.

ID

5d771976-b421-404a-88a7-be0ecfb52958

Behaviors

None


Delete Skillset Policy

Description

The policy for the DeleteSkillset web method.

ID

36f3fbeb-4e9b-4575-92a1-67241b107de9

Behaviors

None


Delete Vendor Address Policy

Description

The policy for the DeleteVendorAddress web method.

ID

c713827a-386b-403c-b2d5-1d2f4039e7f0

Behaviors

None


Discontinue Sales Item Policy

Description

The policy for the DiscontinueSalesItem web method.

ID

67b7dc25-f4c0-4283-a82d-ee40754a3477

Behaviors

None


Update Applicant Policy

Description

The policy for the UpdateApplicant web method.

ID

c9396de7-4acf-4fc5-a9ef-88406a3c92d3

Behaviors

None


Update Applicant Education Policy

Description

The policy for the UpdateApplicantEducation web method.

ID

8ff766b5-d078-4b5e-9feb-605a20f3a992

Behaviors

None


Update Applicant Interview Policy

Description

The policy for the UpdateApplicantInterview web method.

ID

b2a08d11-b6a1-47e1-89e6-85c4570a0c5c

Behaviors

None


Update Applicant Reference Policy

Description

The policy for the UpdateApplicantReference web method.

ID

06a0ae24-d7c5-48be-a0fa-aad3e865cfa9

Behaviors

None


Update Applicant Skill Policy

Description

The policy for the UpdateApplicantSkill web method.

ID

f76b5fcd-87d6-4906-9f8d-4797967b54c1

Behaviors

None


Update Applicant Test Policy

Description

The policy for the UpdateApplicantTest web method.

ID

1da60f42-2a1e-4ce2-a351-d55eae059bbe

Behaviors

None


Update Applicant Work History Policy

Description

The policy for the UpdateApplicantWorkHistory web method.

ID

192fdb4d-201b-416b-99db-9331631cf146

Behaviors

None


Update Corporate Account Policy

Description

The policy for the UpdateCorporateAccount web method.

ID

3c3846db-12f0-4f5e-8f25-02b765d70cd7

Behaviors

None


Update Customer Address Policy

Description

The policy for the UpdateCustomerAddress web method.

ID

105c6835-499c-4223-bc3e-b0e5a82026b6

Behaviors

None


Update Customer Policy

Description

The policy for the UpdateCustomer web method.

ID

71d16621-2182-41fd-a672-7149af05a6d6

Behaviors

The following behaviors are defined for this policy:

  • Customer Class Defaulting Behavior

Customer Class Defaulting Behavior

Description: Will determine whether the customer class will be used to default other values

Type: Internal

ID: 795dd0e2-3932-4872-9b37-e75e518218be

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Customer Class | Do not use customer class to default values; property values will be set to the value passed in. Properties that do not have a value passed in and are not part of customer class will be defaulted based on the Dynamics GP business logic. | None | 0
Use Customer Class | Use the customer class Id that is passed in to default any property that is part of customer class but was not passed in. For properties that do not have a value passed in and are not part of customer class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Customer Class


Update Employee Policy

Description

The policy for the UpdateEmployee web method.

ID

cf733d86-d236-45ca-aaaf-0533c9a4fdeb

Behaviors

The following behaviors are defined for this policy:

  • Employee Class Defaulting Behavior

Employee Class Defaulting Behavior

Description: Will determine whether the employee class will be used to default other values

Type: Internal

ID: 7559855c-8276-4556-ba06-663e45f3b1f3

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Employee Class |  | None | 0
Use Employee Class | Use the employee class Id that is passed in to default any property that is part of employee class but was not passed in. For properties that do not have a value passed in and are not part of employee class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Employee Class


Update Employee Address Policy

Description

The policy for the UpdateEmployeeAddress web method.

ID

f575d786-e3a3-4fa5-8fcd-6c2d3440065f

Behaviors

None


Update Employee Pay Code Policy

Description

The policy for the UpdateEmployeePayCode web method.

ID

e377b327-4d84-4086-abc7-cfc20f5c3cdd

Behaviors

The following behaviors are defined for this policy:

  • Create Primary Pay Record Behavior
  • Create Active Behavior
  • Create With Default Class Behavior
  • EmployeePayCode Class Defaulting Behavior

Create Primary Pay Record Behavior

Description: Will determine how the primary pay record of an employee will be set; the Create Primary Pay Record behavior will always be applied. Any value provided for the IsPrimaryPayRecord property may be overwritten based on the behavior option selected.

Type: Internal

ID: 9141875a-deb1-4d31-a752-60aee0d31116

Behavior Options:

Name | Description | Parameters | ID
Use supplied value | Use the value supplied | None | 0
Set to primary | Each employeepayrecord is created as the primary pay record for that employee. The service recommends this option for those service owners that have a very high trust level with employees. | None | 1
Dont set to primary | Each pay record that is created is not set to the primary pay record of the employee | None | 2

Selected option: Use supplied value

Create Active Behavior

Description: Will determine how the active status of an employeepaycode will be set; the Create Active behavior will always be applied. Any value provided for the IsActive property may be overwritten based on the behavior option selected.

Type: Internal

ID: 7e181c88-acad-49be-887c-ad374a6df4a1

Behavior Options:

Name | Description | Parameters | ID
Use supplied value | Use the value supplied; If a value for IsActive is not provided the employeepaycode will be set to the default (Active). | None | 0
Set To Active | Each account is created as active. The service recommends this option for those service owners that have a very high trust level with consumers. | None | 1
Set To Inactive | Each employeepaycode is created as inactive. | None | 2

Selected option: Use supplied value

Create With Default Class Behavior

Description: Will determine if a default employeepaycode class, to be used when creating a new employee, will be specified

Type: Internal

ID: 27c45d60-1f34-46c1-a89c-b07a425a6532

Behavior Options:

Name | Description | Parameters | ID
No Default Class | No default class Id specified | None | 0
Specify Default Class | Specify default class Id | Class Id Parameter | 1

Selected option: No Default Class

EmployeePayCode Class Defaulting Behavior

Description: Will determine whether the employeepaycode class will be used to default other values

Type: Internal

ID: 57bdf69e-4742-45be-a764-edf163ffdfaf

Behavior Options:

Name | Description | Parameters | ID
Don't use the employeepaycode class | Do not use employeepaycode class to default values; property values will be set to the value passed in. For properties that do not have a value passed in and are not part of employeepaycode class, the defaulting is based on the setup from the Dynamics GP Application. (Default) | None | 0
Use the employeepaycode class | Use the employeepaycode that is passed in to default any property that is part of employeepaycode class but was not passed in. For properties that do not have a value passed in and are not part of employeepaycode class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Don't use the employeepaycode class


Update HRRequisition Policy

Description

The policy for the UpdateHRRequisition web method.

ID

174666ec-6aeb-4b65-9e50-b40a713d51de

Behaviors

None


Update Item Vendor Policy

Description

The policy for the UpdateItemVendor web method.

ID

719e7108-8db7-4334-80cb-efd1ded46a44

Behaviors

None


Update Purchase Order Policy

Description

The policy for the UpdatePurchaseOrder web method.

ID

c3b14f1e-b7a9-49c3-bae4-d1717bb5b4aa

Behaviors

None


Update Return Material Authorization Policy

Description

The policy for the UpdateReturnMaterialAuthorization web method.

ID

942f3558-0252-49df-b26b-a5e58c962c98

Behaviors

The following behaviors are defined for this policy:

  • Create Inventory Lot Behavior
  • Check Hold Behavior

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: e0205846-ddf1-4536-8220-d23e6a8cbf70

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Check Status | Check status | None | 1

Selected option: Check Status


Update Sales Backorder Policy

Description

The policy for the UpdateSalesBackorder web method.

ID

db7d9018-cb4a-4407-94ff-d278610e018c

Behaviors

The following behaviors are defined for this policy:

  • Calculate Unit Price Behavior
  • Calculate Total Amount Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Miscellaneous Tax Behavior
  • Freight Tax Behavior

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup


Update Sales Fulfillment Order Policy

Description

The policy for the UpdateSalesFulfillmentOrder web method.

ID

5c725f07-6b2f-44ea-84e2-cc50dcded5e0

Behaviors

The following behaviors are defined for this policy:

  • Calculate Unit Price Behavior
  • Bin Quantity Shortage Behavior
  • Calculate Total Amount Behavior
  • Create Inventory Serial Behavior
  • Allocate Lots Behavior
  • Create GL Account Distributions Behavior
  • Include Promotions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Allocate Quantities Behavior
  • Check Credit Limit Behavior
  • Assign Bin Behavior
  • Create Inventory Lot Behavior
  • Allocate Serials Behavior
  • Miscellaneous Tax Behavior
  • Create Bins Behavior
  • Freight Tax Behavior
  • Create Taxes Behavior
  • Quantity Shortage Behavior

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Lots Behavior

Description: Used to determine how lot numbers are fulfilled on a sales document line.

Type: Internal

ID: 17fa7992-d96a-481c-b15f-29181ed3fd92

Behavior Options:

Name | Description | Parameters | ID
Automatic | Lot number fulfillment will be automatic | None | 0
Manual | Lot numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided lot numbers are fulfilled will be automatically fulfilled. | None | 2

Selected option: Automatic

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Include Promotions Behavior

Description: Will determine the application of promotions to the line (i.e. percentage off, value off, or quantity fee)

Type: External

ID: 2e58b57c-8fe1-4e98-bf04-371621f8e8b7

Behavior Options:

Name | Description | Parameters | ID
Do Not Include | Do not include promotions | None | 0
Include | Include promotions | None | 1

Selected option: Do Not Include

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Allocate Quantities Behavior

Description: Will determine how quantities on the sales document are allocated

Type: Internal

ID: 97bd3863-2f87-4079-aef4-8b35ee3a5c3c

Behavior Options:

Name | Description | Parameters | ID
Based on Type Id | Allocate quantities based on the document type Id of the sales document | None | 0
Allocate | Allocate quantities | None | 1

Selected option: Based on Type Id

Check Credit Limit Behavior

Description: Will determine whether the customer's credit limit will be checked when the document is created

Type: Internal

ID: 6cc8431e-7d60-4850-bb07-a66d4d4adb2c

Behavior Options:

Name | Description | Parameters | ID
Override Credit Limit | Override credit limit | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Assign Bin Behavior

Description: Will determine whether bins are automatically assigned

Type: Internal

ID: 80ad078e-5787-4e75-8cfb-a8d652d93eab

Behavior Options:

Name | Description | Parameters | ID
Do Not Assign | Do not assign bin | None | 0
Assign Bin | Automatically assign bin | None | 1

Selected option: Assign Bin

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Serials Behavior

Description: Will determine how serial numbers are allocated on a sales document line

Type: Internal

ID: 75d49cdf-0a3e-4b4e-9c39-c9d603d17973

Behavior Options:

Name | Description | Parameters | ID
Automatic | Serial number fulfillment will be automatic | None | 0
Manual | Serial numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided serial numbers are fulfilled will be automatically fulfilled | None | 2

Selected option: Automatic

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Taxes Behavior

Description: Will determine whether the tax engine will be used to calculate the taxes or if the tax details will be manually provided

Type: Internal

ID: 47105c7b-7a08-4c89-8204-f9e3538d1eb9

Behavior Options:

Name | Description | Parameters | ID
Taxes Will Be Provided | Taxes will be provided | None | 0
Automatically Create Taxes | Automatically create taxes | None | 1

Selected option: Automatically Create Taxes

Quantity Shortage Behavior

Description: Will determine how to proceed when there is a quantity shortage

Type: External

ID: 3ea346a7-69f5-403d-87cf-fc3d9e5a9c9d

Behavior Options:

Name | Description | Parameters | ID
Sell Balance | Sell Balance | None | 1
Override | Override | None | 2
Backorder All | Backorder All | None | 3
Backorder Balance | Backorder Balance | None | 4
Cancel All | Cancel All | None | 5
Cancel Balance | Cancel Balance | None | 6

Selected option: Override


Update Sales Invoice Policy

Description

The policy for the UpdateSalesInvoice web method.

ID

38e46a1f-bc0f-45b4-afce-a88d3eedbcc4

Behaviors

The following behaviors are defined for this policy:

  • Calculate Unit Price Behavior
  • Bin Quantity Shortage Behavior
  • Calculate Total Amount Behavior
  • Create Inventory Serial Behavior
  • Allocate Lots Behavior
  • Create GL Account Distributions Behavior
  • Include Promotions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Allocate Quantities Behavior
  • Check Credit Limit Behavior
  • Assign Bin Behavior
  • Create Inventory Lot Behavior
  • Allocate Serials Behavior
  • Miscellaneous Tax Behavior
  • Create Bins Behavior
  • Freight Tax Behavior
  • Create Taxes Behavior
  • Quantity Shortage Behavior

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Lots Behavior

Description: Used to determine how lot numbers are fulfilled on a sales document line.

Type: Internal

ID: 17fa7992-d96a-481c-b15f-29181ed3fd92

Behavior Options:

Name | Description | Parameters | ID
Automatic | Lot number fulfillment will be automatic | None | 0
Manual | Lot numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided lot numbers are fulfilled will be automatically fulfilled. | None | 2

Selected option: Automatic

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Include Promotions Behavior

Description: Will determine the application of promotions to the line (i.e. percentage off, value off, or quantity fee)

Type: External

ID: 2e58b57c-8fe1-4e98-bf04-371621f8e8b7

Behavior Options:

Name | Description | Parameters | ID
Do Not Include | Do not include promotions | None | 0
Include | Include promotions | None | 1

Selected option: Do Not Include

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Allocate Quantities Behavior

Description: Will determine how quantities on the sales document are allocated

Type: Internal

ID: 97bd3863-2f87-4079-aef4-8b35ee3a5c3c

Behavior Options:

Name | Description | Parameters | ID
Based on Type Id | Allocate quantities based on the document type Id of the sales document | None | 0
Allocate | Allocate quantities | None | 1

Selected option: Based on Type Id

Check Credit Limit Behavior

Description: Will determine whether the customer's credit limit will be checked when the document is created

Type: Internal

ID: 6cc8431e-7d60-4850-bb07-a66d4d4adb2c

Behavior Options:

Name | Description | Parameters | ID
Override Credit Limit | Override credit limit | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Assign Bin Behavior

Description: Will determine whether bins are automatically assigned

Type: Internal

ID: 80ad078e-5787-4e75-8cfb-a8d652d93eab

Behavior Options:

Name | Description | Parameters | ID
Do Not Assign | Do not assign bin | None | 0
Assign Bin | Automatically assign bin | None | 1

Selected option: Assign Bin

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Serials Behavior

Description: Will determine how serial numbers are allocated on a sales document line

Type: Internal

ID: 75d49cdf-0a3e-4b4e-9c39-c9d603d17973

Behavior Options:

Name | Description | Parameters | ID
Automatic | Serial number fulfillment will be automatic | None | 0
Manual | Serial numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided serial numbers are fulfilled will be automatically fulfilled | None | 2

Selected option: Automatic

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Taxes Behavior

Description: Will determine whether the tax engine will be used to calculate the taxes or if the tax details will be manually provided

Type: Internal

ID: 47105c7b-7a08-4c89-8204-f9e3538d1eb9

Behavior Options:

Name | Description | Parameters | ID
Taxes Will Be Provided | Taxes will be provided | None | 0
Automatically Create Taxes | Automatically create taxes | None | 1

Selected option: Automatically Create Taxes

Quantity Shortage Behavior

Description: Will determine how to proceed when there is a quantity shortage

Type: External

ID: 3ea346a7-69f5-403d-87cf-fc3d9e5a9c9d

Behavior Options:

Name | Description | Parameters | ID
Sell Balance | Sell Balance | None | 1
Override | Override | None | 2
Backorder All | Backorder All | None | 3
Backorder Balance | Backorder Balance | None | 4
Cancel All | Cancel All | None | 5
Cancel Balance | Cancel Balance | None | 6

Selected option: Override


Update Sales Order Policy

Description

The policy for the UpdateSalesOrder web method.

ID

150401c6-7467-4853-9146-236fc5fa7bf8

Behaviors

The following behaviors are defined for this policy:

  • Calculate Unit Price Behavior
  • Bin Quantity Shortage Behavior
  • Calculate Total Amount Behavior
  • Create Inventory Serial Behavior
  • Allocate Lots Behavior
  • Include Promotions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Allocate Quantities Behavior
  • Check Credit Limit Behavior
  • Assign Bin Behavior
  • Create Inventory Lot Behavior
  • Allocate Serials Behavior
  • Miscellaneous Tax Behavior
  • Create Bins Behavior
  • Freight Tax Behavior
  • Quantity Shortage Behavior

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Bin Quantity Shortage Behavior

Description: Will determine whether the bin quantity shortage can be overridden

Type: External

ID: 67e5073d-b69e-4526-8079-1a691d475c48

Behavior Options:

Name | Description | Parameters | ID
Do Not Override | Do not override bin quantity shortage | None | 0
Override Bin | Override bin quantity shortage | None | 1

Selected option: Override Bin

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Create Inventory Serial Behavior

Description: Create Inventory Serial Behavior

Type: Internal

ID: 32dc3e06-7c7f-4625-aee9-24f5c4868be8

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Lots Behavior

Description: Used to determine how lot numbers are fulfilled on a sales document line.

Type: Internal

ID: 17fa7992-d96a-481c-b15f-29181ed3fd92

Behavior Options:

Name | Description | Parameters | ID
Automatic | Lot number fulfillment will be automatic | None | 0
Manual | Lot numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided lot numbers are fulfilled will be automatically fulfilled. | None | 2

Selected option: Automatic

Include Promotions Behavior

Description: Will determine the application of promotions to the line (i.e. percentage off, value off, or quantity fee)

Type: External

ID: 2e58b57c-8fe1-4e98-bf04-371621f8e8b7

Behavior Options:

Name | Description | Parameters | ID
Do Not Include | Do not include promotions | None | 0
Include | Include promotions | None | 1

Selected option: Do Not Include

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Allocate Quantities Behavior

Description: Will determine how quantities on the sales document are allocated

Type: Internal

ID: 97bd3863-2f87-4079-aef4-8b35ee3a5c3c

Behavior Options:

Name | Description | Parameters | ID
Based on Type Id | Allocate quantities based on the document type Id of the sales document | None | 0
Allocate | Allocate quantities | None | 1

Selected option: Based on Type Id

Check Credit Limit Behavior

Description: Will determine whether the customer's credit limit will be checked when the document is created

Type: Internal

ID: 6cc8431e-7d60-4850-bb07-a66d4d4adb2c

Behavior Options:

Name | Description | Parameters | ID
Override Credit Limit | Override credit limit | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Assign Bin Behavior

Description: Will determine whether bins are automatically assigned

Type: Internal

ID: 80ad078e-5787-4e75-8cfb-a8d652d93eab

Behavior Options:

Name | Description | Parameters | ID
Do Not Assign | Do not assign bin | None | 0
Assign Bin | Automatically assign bin | None | 1

Selected option: Assign Bin

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Allocate Serials Behavior

Description: Will determine how serial numbers are allocated on a sales document line

Type: Internal

ID: 75d49cdf-0a3e-4b4e-9c39-c9d603d17973

Behavior Options:

Name | Description | Parameters | ID
Automatic | Serial number fulfillment will be automatic | None | 0
Manual | Serial numbers will be provided | None | 1
Mixed | Any quantity remaining after the manually provided serial numbers are fulfilled will be automatically fulfilled | None | 2

Selected option: Automatic

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Quantity Shortage Behavior

Description: Will determine how to proceed when there is a quantity shortage

Type: External

ID: 3ea346a7-69f5-403d-87cf-fc3d9e5a9c9d

Behavior Options:

Name | Description | Parameters | ID
Sell Balance | Sell Balance | None | 1
Override | Override | None | 2
Backorder All | Backorder All | None | 3
Backorder Balance | Backorder Balance | None | 4
Cancel All | Cancel All | None | 5
Cancel Balance | Cancel Balance | None | 6

Selected option: Override


Update Sales Process Hold Setup Policy

Description

The policy for the UpdateSalesProcessHoldSetup web method.

ID

7dffd45c-a233-4346-9916-c4646944f143

Behaviors

None


Update Sales Quote Policy

Description

The policy for the UpdateSalesQuote web method.

ID

b654838b-dec7-4742-a8c8-fab1957a4985

Behaviors

The following behaviors are defined for this policy:

  • Calculate Unit Price Behavior
  • Calculate Total Amount Behavior
  • Include Promotions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Miscellaneous Tax Behavior
  • Freight Tax Behavior

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Include Promotions Behavior

Description: Will determine the application of promotions to the line (i.e. percentage off, value off, or quantity fee)

Type: External

ID: 2e58b57c-8fe1-4e98-bf04-371621f8e8b7

Behavior Options:

Name | Description | Parameters | ID
Do Not Include | Do not include promotions | None | 0
Include | Include promotions | None | 1

Selected option: Do Not Include

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup


Update Sales Return Policy

Description

The policy for the UpdateSalesReturn web method.

ID

a08b0c69-13bd-4a7b-bda9-d7902803364b

Behaviors

The following behaviors are defined for this policy:

  • Calculate Unit Price Behavior
  • Calculate Total Amount Behavior
  • Create GL Account Distributions Behavior
  • Default Warehouse Behavior
  • Default Document Type Id Behavior
  • Create Components Behavior
  • Check Hold Behavior
  • Create Commissions Behavior
  • Miscellaneous Tax Behavior
  • Create Bins Behavior
  • Freight Tax Behavior
  • Create Taxes Behavior

Calculate Unit Price Behavior

Description: Will determine whether the unit price and total amount will be automatically calculated

Type: Internal

ID: 2e873316-fee1-460e-8da1-12167013401b

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate unit price and line total amount | None | 0
Calculate | Calculate unit price and line total amount | None | 1

Selected option: Calculate

Calculate Total Amount Behavior

Description: Will determine whether the total amount on the sales line will be automatically calculated

Type: Internal

ID: 41233b06-db1a-4050-b4af-207eb2c908b3

Behavior Options:

Name | Description | Parameters | ID
Do Not Calculate | Do not calculate line total amount | None | 0
Calculate | Automatically calculate total amount | None | 1

Selected option: Calculate

Create GL Account Distributions Behavior

Description: Will determine whether the GL account distributions will provided or automatically calculated

Type: Internal

ID: e476a157-ecf0-4dae-8cef-317dd2cfbe41

Behavior Options:

Name | Description | Parameters | ID
Distributions Will Be Provided | Distributions will be provided | None | 0
Automatically Create Distributions | Automatically create distributions | None | 1

Selected option: Automatically Create Distributions

Default Warehouse Behavior

Description: Will determine the default warehouseId to be used when creating a sales document

Type: Internal

ID: 758c758e-13fc-42cc-a508-57a8abe04dcd

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | The warehouse Id will default from the customer ship-to address on the sales document header; if empty then the warehouse Id will default from Sales Order Processing Setup | None | 0
Specify Default | Specify the default warehouse Id | Default Warehouse Parameter | 1

Selected option: Use Setup Value

Default Document Type Id Behavior

Description: Will determine the default document type Id to be used when creating a sales document

Type: External

ID: 16fb38cc-d635-4b5e-8235-6235fa828062

Behavior Options:

Name | Description | Parameters | ID
Use Setup Value | Use default document type Id from Sales Setup | None | 0
Specify Default | Specify the default document type Id | Default Type Id Parameter | 1

Selected option: Use Setup Value

Create Components Behavior

Description: will determine whether kit components are being provided

Type: Internal

ID: f3903ab2-6964-451e-b9be-682c6ca6a89e

Behavior Options:

Name | Description | Parameters | ID
Automatically Create Components | Automatically create components | None | 0
Components Will Be Provided | Components will be provided | None | 1

Selected option: Automatically Create Components

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: 626a4d44-dd14-4a1c-a344-69a8dac9d3a3

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Cancel Document | Cancel document | None | 1

Selected option: Cancel Document

Create Commissions Behavior

Description: Will determine whether commissions will be automatically created or manually provided

Type: Internal

ID: ed4b65bd-554a-41bd-b870-86eb41670cd8

Behavior Options:

Name | Description | Parameters | ID
Commissions Will Be Provided | Commissions will be provided | None | 0
Automatically Create Commissions | Automatically create commissions | None | 1

Selected option: Automatically Create Commissions

Miscellaneous Tax Behavior

Description: Will determine whether the miscellaneous amount on the document is taxable and if taxable where the miscellaneous tax schedule Id defaults from

Type: Internal

ID: 799cbafa-207a-4e42-8141-d9f281fc2ba9

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Bins Behavior

Description: Create Bins Behavior

Type: Internal

ID: 1a994c4e-c0a9-4466-aba0-e01157f78646

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Freight Tax Behavior

Description: Will determine whether the freight amount on the document is taxable and if taxable where the freight tax schedule Id defaults from

Type: Internal

ID: 9a601da7-bf3a-4da2-b70f-e30f5798158f

Behavior Options:

Name | Description | Parameters | ID
Default From Setup | Default From Setup | None | 0
Taxable | Taxable | None | 1
Nontaxable | Nontaxable | None | 2
Base On Customer | Base On Customer | None | 3

Selected option: Default From Setup

Create Taxes Behavior

Description: Will determine whether the tax engine will be used to calculate the taxes or if the tax details will be manually provided

Type: Internal

ID: 47105c7b-7a08-4c89-8204-f9e3538d1eb9

Behavior Options:

Name | Description | Parameters | ID
Taxes Will Be Provided | Taxes will be provided | None | 0
Automatically Create Taxes | Automatically create taxes | None | 1

Selected option: Automatically Create Taxes


Update Service Call Policy

Description

The policy for the UpdateServiceCall web method.

ID

c5f781b3-4baa-4095-ba0a-3f639097c003

Behaviors

The following behaviors are defined for this policy:

  • Create Labor Behavior
  • Create Inventory Lot Behavior
  • Check Hold Behavior

Create Labor Behavior

Description: Create Labor Behavior

Type: Internal

ID: 6554f82d-6de9-4d15-b853-b329917bc023

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Create Inventory Lot Behavior

Description: Create Inventory Lot Behavior

Type: Internal

ID: 61d22257-3dce-4ae0-a458-b35791040bf6

Behavior Options:

Name | Description | Parameters | ID
Do Not Create | Do not create | None | 0
Create | Create | None | 1

Selected option: Create

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: e0205846-ddf1-4536-8220-d23e6a8cbf70

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Check Status | Check status | None | 1

Selected option: Check Status


Update Service Equipment Policy

Description

The policy for the UpdateServiceEquipment web method.

ID

b9f506ce-6dfc-4977-bdaf-244d51c7ebc8

Behaviors

None


Update Service Quote Policy

Description

The policy for the UpdateServiceQuote web method.

ID

07dd249a-746f-4501-af25-958fe174681a

Behaviors

The following behaviors are defined for this policy:

  • Check Hold Behavior

Check Hold Behavior

Description: Will determine whether the customer's hold status will be checked when the document is created

Type: Internal

ID: e0205846-ddf1-4536-8220-d23e6a8cbf70

Behavior Options:

Name | Description | Parameters | ID
Override Hold | Override hold | None | 0
Check Status | Check status | None | 1

Selected option: Check Status


Update Skill Policy

Description

The policy for the UpdateSkill web method.

ID

bcc1f16e-8411-4563-b43c-b8949970f5d7

Behaviors

None


Update Skillset Policy

Description

The policy for the UpdateSkillset web method.

ID

b66b2638-f805-4a30-a715-0389e9ba2ded

Behaviors

None


Update Vendor Address Policy

Description

The policy for the UpdateVendorAddress web method.

ID

66e1feb2-68db-4fd5-a431-70f2fe128cd5

Behaviors

None


Update Vendor Policy

Description

The policy for the UpdateVendor web method.

ID

66e1feb2-68db-4fd5-a431-70f2fe128cd2

Behaviors

The following behaviors are defined for this policy:

  • Vendor Class Defaulting Behavior

Vendor Class Defaulting Behavior

Description: Will determine whether the vendor class will be used to default other values

Type: Internal

ID: 7b5d30f0-e152-4818-a196-6ba3accd8d32

Behavior Options:

Name | Description | Parameters | ID
Do Not Use Vendor Class | Do not use vendor class to default values; property values will be set to the value passed in. Properties that do not have a value passed in and are not part of vendor class will be defaulted based on the Dynamics GP business logic. | None | 0
Use Vendor Class | Use the vendor class Id that is passed in to default any property that is part of vendor class but was not passed in. For properties that do not have a value passed in and are not part of vendor class will be defaulted based on the Dynamics GP business logic. | None | 1

Selected option: Do Not Use Vendor Class


Void Cash Receipt Policy

Description

The policy for the VoidCashReceipt web method.

ID

df5521bc-6896-405c-832e-180c061c05c1

Behaviors

The following behaviors are defined for this policy:

  • Default GL Posting Date Behavior
  • Default Void Date Behavior

Default GL Posting Date Behavior

Description: Will determine the date to use as the General Ledger Posting date to use when voiding a transaction

Type: External

ID: 92288614-b012-494d-a801-8e04021eacbd

Behavior Options:

Name | Description | Parameters | ID
Use Document Date | Use Document Date | None | 1
Use Current Date | Use Current Date | None | 2
Specify Default | Specify GL Posting Date | GL Posting Date Parameter | 3

Selected option: Use Document Date

Default Void Date Behavior

Description: Will determine the date to use as the void date on a transaction

Type: External

ID: 7983a090-e98d-45d0-b52b-cd21b3d8278b

Behavior Options:

Name | Description | Parameters | ID
Use Document Date | Use Document Date | None | 1
Use Current Date | Use Current Date | None | 2
Specify Default | Specify Void Date | Void Date Parameter | 3

Selected option: Use Document Date


Void Purchase Order Policy

Description

The policy for the VoidPurchaseOrder web method.

ID

b3eb766b-a1e0-4651-b700-f4a66f8a8703

Behaviors

None


Void Receivables Credit Memo Policy

Description

The policy for the VoidReceivablesCreditMemo web method.

ID

4c97279c-666e-4022-9b0a-7cdea6292b7c

Behaviors

The following behaviors are defined for this policy:

  • Default GL Posting Date Behavior
  • Default Void Date Behavior

Default GL Posting Date Behavior

Description: Will determine the date to use as the General Ledger Posting date to use when voiding a transaction

Type: External

ID: 92288614-b012-494d-a801-8e04021eacbd

Behavior Options:

Name | Description | Parameters | ID
Use Document Date | Use Document Date | None | 1
Use Current Date | Use Current Date | None | 2
Specify Default | Specify GL Posting Date | GL Posting Date Parameter | 3

Selected option: Use Document Date

Default Void Date Behavior

Description: Will determine the date to use as the void date on a transaction

Type: External

ID: 7983a090-e98d-45d0-b52b-cd21b3d8278b

Behavior Options:

Name | Description | Parameters | ID
Use Document Date | Use Document Date | None | 1
Use Current Date | Use Current Date | None | 2
Specify Default | Specify Void Date | Void Date Parameter | 3

Selected option: Use Document Date


Void Receivables Return Policy

Description

The policy for the VoidReceivablesReturn web method.

ID

2359c0f9-e54e-43a4-b9ca-094cf28bfb4d

Behaviors

The following behaviors are defined for this policy:

  • Default GL Posting Date Behavior
  • Default Void Date Behavior

Default GL Posting Date Behavior

Description: Will determine the date to use as the General Ledger Posting date to use when voiding a transaction

Type: External

ID: 92288614-b012-494d-a801-8e04021eacbd

Behavior Options:

Name | Description | Parameters | ID
Use Document Date | Use Document Date | None | 1
Use Current Date | Use Current Date | None | 2
Specify Default | Specify GL Posting Date | GL Posting Date Parameter | 3

Selected option: Use Document Date

Default Void Date Behavior

Description: Will determine the date to use as the void date on a transaction

Type: External

ID: 7983a090-e98d-45d0-b52b-cd21b3d8278b

Behavior Options:

Name | Description | Parameters | ID
Use Document Date | Use Document Date | None | 1
Use Current Date | Use Current Date | None | 2
Specify Default | Specify Void Date | Void Date Parameter | 3

Selected option: Use Document Date


Void Sales Backorder Policy

Description

The policy for the VoidSalesBackorder web method.

ID

0feb1a61-f167-4b17-9be5-47ed5305cdeb

Behaviors

The following behaviors are defined for this policy:

  • Remove Posted Deposits

Remove Posted Deposits

Description: Will determine whether the posted deposits on a voided or deleted document are to be removed

Type: External

ID: 0f2c414b-fd12-4d83-940b-2bc0d65c3b77

Behavior Options:

Name | Description | Parameters | ID
Do Not Remove | Do not remove posted deposits | None | 0
Remove | Remove posted deposits and post reversing entry to GL | None | 1

Selected option: Remove


Void Sales Invoice Policy

Description

The policy for the VoidSalesInvoice web method.

ID

9812a443-5f81-464c-baf8-78ce719922c9

Behaviors

None


Void Sales Order Policy

Description

The policy for the VoidSalesOrder web method.

ID

06a4941a-5793-4bd8-9ed1-471c68a4d981

Behaviors

The following behaviors are defined for this policy:

  • Remove Posted Deposits

Remove Posted Deposits

Description: Will determine whether the posted deposits on a voided or deleted document are to be removed

Type: External

ID: 0f2c414b-fd12-4d83-940b-2bc0d65c3b77

Behavior Options:

Name | Description | Parameters | ID
Do Not Remove | Do not remove posted deposits | None | 0
Remove | Remove posted deposits and post reversing entry to GL | None | 1

Selected option: Remove


Void Sales Quote Policy

Description

The policy for the VoidSalesQuote web method.

ID

f6442a47-e372-41d1-bda2-b3356df94959

Behaviors

None


Void Sales Return Policy

Description

The policy for the VoidSalesReturn web method.

ID

dc7b7235-9901-43c4-ab34-7cce936b3ea4

Behaviors

None


Interface reference

Both the native and legacy endpoints of the Dynamics GP service implement several interfaces that are used to group related methods. The interfaces divide the methods into functional areas, such as Financial, Inventory, or Sales. In the default configuration, the Dynamics GP service presents the interface that contains all of the available methods. You can configure the Dynamics GP service to present one of these area-specific interfaces instead.

When developing an application, you can target one of these area-specific interfaces. The proxy generated for the service reference or the web service reference will contain only the methods, classes, and enumerations defined in that interface. This makes the proxy mcuh smaller and more efficient.

The following lists summarize the available interfaces and the methods that are available in each.

  • Dynamics GP
  • Common
  • Field Service
  • Financials
  • Human Resources/Payroll
  • Inventory
  • Manufacturing
  • Project Accounting
  • Purchasing
  • Sales


Dynamics GP

Description

This interface contains all methods available in the Dynamics GP service. It is the default interface for both the native endpoint and the legacy endpoint.

Interface name

IGPServices (for the native endpoint)

IGPServicesLegacy (for the legacy endpoint)

Methods

  • All methods in the Dynamics GP service


Common

Description

This interface contains the methods that are commonly used in integrating applications. All of the area-specific interfaces also contain these methods.

Interface name

ICommon

Methods

  • CreateBackOfficeRoleAssignment
  • CreateBusinessObjectUserAssignment
  • CreatePolicy
  • DeleteAllLoggedExceptionData
  • DeleteBusinessObjectUserAssignment
  • DeleteLoggedExceptionDataByKey
  • DeletePolicy
  • GetBackOfficeRoleAssignmentList
  • GetBackOfficeRoleByKey
  • GetBackOfficeRoleList
  • GetBankByKey
  • GetBankList
  • GetBatchByKey
  • GetBatchList
  • GetBusinessObjectSummaryList
  • GetBusinessObjectUserAssignmentList
  • GetCompanyAddressByKey
  • GetCompanyAddressList
  • GetCompanyByKey
  • GetCompanyList
  • GetCompletePolicyByKey
  • GetCountryRegionCodeByKey
  • GetCountryRegionCodeList
  • GetCurrencyAccessByKey
  • GetCurrencyAccessList
  • GetCurrencyByKey
  • GetCurrencyList
  • GetCurrencyPostingAccountByKey
  • GetCurrencyPostingAccountList
  • GetDynamicsOnlineConfigurationByKey
  • GetDynamicsOnlineConfigurationList
  • GetGLAccountFormatList
  • GetLoggedExceptionDataByKey
  • GetLoggedExceptionDataList
  • GetLoggedValidationResultByKey
  • GetMulticurrencySetupByKey
  • GetMulticurrencySetupList
  • GetPaymentCardTypeByKey
  • GetPaymentCardTypeList
  • GetPaymentTermsByKey
  • GetPaymentTermsList
  • GetPolicyByKey
  • GetPolicyByOperation
  • GetPolicyList
  • GetPolicyListByRoleKey
  • GetPolicyRoles
  • GetSalespersonByKey
  • GetSalespersonList
  • GetSalesTerritoryByKey
  • GetSalesTerritoryList
  • GetShippingMethodByKey
  • GetShippingMethodList
  • GetTaxDetailByKey
  • GetTaxDetailList
  • GetTaxScheduleByKey
  • GetTaxScheduleDetailByKey
  • GetTaxScheduleDetailList
  • GetTaxScheduleList
  • GetUserAssignableBusinessObjectList
  • GetWSEnabledCompanyForUserList
  • GetWSEnabledCompanyList
  • UpdatePolicy


Field Service

Description

This interface contains the methods for field service.

Interface name

IFieldService

Methods

  • All methods in Common
  • CreateReturnMaterialAuthorization
  • CreateServiceCall
  • CreateServiceEquipment
  • CreateServiceQuote
  • GetReturnMaterialAuthorizationByKey
  • GetReturnMaterialAuthorizationList
  • GetServiceCallByKey
  • GetServiceCallList
  • GetServiceEquipmentByKey
  • GetServiceEquipmentList
  • GetServiceQuoteByKey
  • GetServiceQuoteList
  • UpdateReturnMaterialAuthorization
  • UpdateServiceCall
  • UpdateServiceEquipment
  • UpdateServiceQuote


Financials

Description

This interface contains the methods for financials.

Interface name

IFinancials

Methods

  • All methods in Common
  • CreateGLFixedAllocationAccount
  • CreateGLPostingAccount
  • CreateGLTransaction
  • CreateGLUnitAccount
  • CreateGLVariableAllocationAccount
  • GetGLAccountByKey
  • GetGLAccountCategoryList
  • GetGLAccountList
  • GetGLFixedAllocationAccountByKey
  • GetGLFixedAllocationAccountList
  • GetGLPostedTransactionByKey
  • GetGLPostingAccountByKey
  • GetGLPostingAccountList
  • GetGLTransactionByKey
  • GetGLTransactionList
  • GetGLUnitAccountByKey
  • GetGLUnitAccountList
  • GetGLVariableAllocationAccountByKey
  • GetGLVariableAllocationAccountList


Human Resources/Payroll

Description

This interface contains the methods for human resources and payroll.

Interface name

IHumanResourcesPayroll

Methods

  • All methods in Common
  • CreateApplicant
  • CreateApplicantEducation
  • CreateApplicantInterview
  • CreateApplicantReference
  • CreateApplicantSkill
  • CreateApplicantTest
  • CreateApplicantWorkHistory
  • CreateEmployee
  • CreateEmployeeAddress
  • CreateEmployeePayCode
  • CreateHRRequisition
  • CreateSkill
  • CreateSkillSet
  • DeleteApplicant
  • DeleteApplicantApplication
  • DeleteApplicantEducation
  • DeleteApplicantInterview
  • DeleteApplicantReference
  • DeleteApplicantSkill
  • DeleteApplicantTest
  • DeleteApplicantWorkHistory
  • DeleteEmployeeAddress
  • DeleteSkill
  • DeleteSkillSet
  • GetApplicantApplicationByKey
  • GetApplicantApplicationList
  • GetApplicantByKey
  • GetApplicantEducationByKey
  • GetApplicantEducationList
  • GetApplicantInterviewByKey
  • GetApplicantInterviewList
  • GetApplicantList
  • GetApplicantReferenceByKey
  • GetApplicantReferenceList
  • GetApplicantSkillByKey
  • GetApplicantSkillList
  • GetApplicantTestByKey
  • GetApplicantTestList
  • GetApplicantWorkHistoryByKey
  • GetApplicantWorkHistoryList
  • GetEmployeeAddressByKey
  • GetEmployeeAddressList
  • GetEmployeeByKey
  • GetEmployeeList
  • GetEmployeePayCodeByKey
  • GetEmployeePayCodeList
  • GetHRRequisitionByKey
  • GetHRRequisitionList
  • GetSkillByKey
  • GetSkillList
  • GetSkillSetByKey
  • GetSkillSetList
  • UpdateApplicant
  • UpdateApplicantEducation
  • UpdateApplicantInterview
  • UpdateApplicantReference
  • UpdateApplicantSkill
  • UpdateApplicantTest
  • UpdateApplicantWorkHistory
  • UpdateEmployee
  • UpdateEmployeeAddress
  • UpdateEmployeePayCode
  • UpdateHRRequisition
  • UpdateSkill
  • UpdateSkillSet


Inventory

Description

This interface contains the methods for inventory.

Interface name

IInventory

Methods

  • All methods in Common
  • CreateFee
  • CreateInventoryAdjustment
  • CreateInventoryTransfer
  • CreateInventoryVariance
  • CreateItemCurrency
  • CreateItemVendor
  • CreateItemWarehouse
  • CreateKit
  • CreatePricing
  • CreateSalesItem
  • CreateService
  • CreateWarehouse
  • DiscontinueSalesItem
  • GetFeeByKey
  • GetFeeList
  • GetInventoriedItemByKey
  • GetInventoriedItemList
  • GetInventoryAdjustmentByKey
  • GetInventoryAdjustmentList
  • GetInventoryTransferByKey
  • GetInventoryTransferList
  • GetInventoryVarianceByKey
  • GetInventoryVarianceList
  • GetItemByKey
  • GetItemClassList
  • GetItemCurrencyByKey
  • GetItemCurrencyList
  • GetItemList
  • GetItemVendorByKey
  • GetItemVendorList
  • GetItemWarehouseByKey
  • GetItemWarehouseList
  • GetPriceLevelByKey
  • GetPriceLevelList
  • GetPricingByKey
  • GetPricingList
  • GetServiceByKey
  • GetServiceList
  • GetUofMScheduleByKey
  • GetUofMScheduleList
  • GetWarehouseByKey
  • GetWarehouseList
  • UpdateItemVendor


Manufacturing

Description

This interface contains the methods for manufacturing.

Interface name

IManufacturing

Methods

  • All methods in Common
  • GetManufacturingOrderByKey
  • GetManufacturingOrderList
  • GetPlannedOrderByKey
  • GetPlannedOrderList
  • GetVendorManufacturingOrderByKey
  • GetVendorManufacturingOrderList
  • GetVendorPlannedOrderByKey
  • GetVendorPlannedOrderList


Project Accounting

Description

This interface contains the methods for project accounting.

Interface name

IProjectAccounting

Methods

  • All methods in Common
  • GetProjectBudgetByKey
  • GetProjectBudgetList
  • GetProjectByKey
  • GetProjectChangeOrderByKey
  • GetProjectChangeOrderList
  • GetProjectContractByKey
  • GetProjectContractList
  • GetProjectEmployeeExpenseByKey
  • GetProjectEmployeeExpenseList
  • GetProjectList
  • GetProjectMiscellaneousLogByKey
  • GetProjectMiscellaneousLogList
  • GetProjectTimesheetByKey
  • GetProjectTimesheetList


Purchasing

Description

This interface contains the methods for purchasing.

Interface name

IPurchasing

Methods

  • All methods in Common
  • CreatePayablesCreditMemo
  • CreatePayablesFinanceCharge
  • CreatePayablesInvoice
  • CreatePayablesMiscellaneousCharge
  • CreatePayablesReturn
  • CreatePurchaseInvoice
  • CreatePurchaseOrder
  • CreatePurchaseReceipt
  • CreateVendor
  • CreateVendorAddress
  • DeletePurchaseOrder
  • DeleteVendorAddress
  • GetPayablesCreditMemoByKey
  • GetPayablesCreditMemoList
  • GetPayablesDocumentList
  • GetPayablesFinanceChargeByKey
  • GetPayablesFinanceChargeList
  • GetPayablesInvoiceByKey
  • GetPayablesInvoiceList
  • GetPayablesMiscellaneousChargeByKey
  • GetPayablesMiscellaneousChargeList
  • GetPayablesReturnByKey
  • GetPayablesReturnList
  • GetPurchaseInvoiceByKey
  • GetPurchaseInvoiceList
  • GetPurchaseOrderByKey
  • GetPurchaseOrderList
  • GetPurchaseReceiptByKey
  • GetPurchaseReceiptList
  • GetVendorAddressByKey
  • GetVendorAddressList
  • GetVendorByKey
  • GetVendorList
  • UpdatePurchaseOrder
  • UpdateVendor
  • UpdateVendorAddress
  • VoidPurchaseOrder


Sales

Description

This interface contains the methods for sales.

Interface name

ISales

Methods

  • All methods in Common
  • CreateCashReceipt
  • CreateCorporateAccount
  • CreateCustomer
  • CreateCustomerAddress
  • CreateReceivablesCreditMemo
  • CreateReceivablesDebitMemo
  • CreateReceivablesFinanceCharge
  • CreateReceivablesInvoice
  • CreateReceivablesReturn
  • CreateReceivablesServiceRepair
  • CreateReceivablesWarranty
  • CreateSalesBackorder
  • CreateSalesFulfillmentOrder
  • CreateSalesInvoice
  • CreateSalesOrder
  • CreateSalesProcessHoldSetup
  • CreateSalesQuote
  • CreateSalesReturn
  • DeleteCustomer
  • DeleteCustomerAddress
  • DeleteSalesBackorder
  • DeleteSalesFulfillmentOrder
  • DeleteSalesInvoice
  • DeleteSalesOrder
  • DeleteSalesQuote
  • DeleteSalesReturn
  • GetCashReceiptByKey
  • GetCashReceiptList
  • GetCorporateAccountByKey
  • GetCustomerAddressByKey
  • GetCustomerAddressList
  • GetCustomerByKey
  • GetCustomerList
  • GetCustomerReceivablesSummaryByKey
  • GetCustomerReceivablesSummaryList
  • GetPostedPayablesVendorPaymentsByKey
  • GetPostedPayablesVendorPaymentsList
  • GetReceivablesCreditMemoByKey
  • GetReceivablesCreditMemoList
  • GetReceivablesDebitMemoByKey
  • GetReceivablesDebitMemoList
  • GetReceivablesDocumentList
  • GetReceivablesFinanceChargeByKey
  • GetReceivablesFinanceChargeList
  • GetReceivablesInvoiceByKey
  • GetReceivablesInvoiceList
  • GetReceivablesReturnByKey
  • GetReceivablesReturnList
  • GetReceivablesServiceRepairByKey
  • GetReceivablesServiceRepairList
  • GetReceivablesWarrantyByKey
  • GetReceivablesWarrantyList
  • GetSalesBackorderByKey
  • GetSalesBackorderList
  • GetSalesDocumentList
  • GetSalesFulfillmentOrderByKey
  • GetSalesFulfillmentOrderList
  • GetSalesInvoiceByKey
  • GetSalesInvoiceList
  • GetSalesOrderByKey
  • GetSalesOrderList
  • GetSalespersonCommissionsByKey
  • GetSalespersonCommissionsList
  • GetSalesProcessHoldSetupByKey
  • GetSalesProcessHoldSetupList
  • GetSalesQuoteByKey
  • GetSalesQuoteList
  • GetSalesReturnByKey
  • GetSalesReturnList
  • UpdateCorporateAccount
  • UpdateCustomer
  • UpdateCustomerAddress
  • UpdateSalesBackorder
  • UpdateSalesFulfillmentOrder
  • UpdateSalesInvoice
  • UpdateSalesOrder
  • UpdateSalesProcessHoldSetup
  • UpdateSalesQuote
  • UpdateSalesReturn
  • VoidCashReceipt
  • VoidReceivablesCreditMemo
  • VoidReceivablesReturn
  • VoidSalesBackorder
  • VoidSalesInvoice
  • VoidSalesOrder
  • VoidSalesQuote
  • VoidSalesReturn


Copyright notice

Copyright © 2012 Microsoft Corporation. All rights reserved.

Limitation of liability

This document is provided “as-is”. Information and views expressed in this document, including URL and other Internet Web site references, may change without notice. You bear the risk of using it.

Some examples depicted herein are provided for illustration only and are fictitious. No real association or connection is intended or should be inferred.

Intellectual property

This document does not provide you with any legal rights to any intellectual property in any Microsoft product.

You may copy and use this document for your internal, reference purposes.

Trademarks

Microsoft, Microsoft Dynamics, Visual Basic, Windows, and Windows Server are trademarks of the Microsoft group of companies.

All other trademarks are property of their respective owners.

Warranty disclaimer

Microsoft Corporation disclaims any warranty regarding the sample code contained in this documentation, including the warranties of merchantability and fitness for a particular purpose.

License agreement

Use of this product is covered by a license agreement provided by Microsoft Corporation with the software product. If you have any questions, please call the Microsoft Dynamics GP Support Department at 800-456-0025 (in the U.S. or Canada) or +1-701-281-6500.

Publication date

December 2012