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Introduction
The Executive Center in Business Portal for Microsoft Dynamics® GP 2010 displays 
key performance indicators (KPIs) and metrics created using Microsoft® SQL 
Server® Reporting Services 2008. Your data is displayed in these KPIs and metrics 
without having to set up and display them in web parts. Refer to the Key 
Performance Indicators documentation for information about the Executive Center.

If you have used KPIs in a previous release of Business Portal and have upgraded to 
Business Portal for Microsoft Dynamics GP 2010, you can create and display KPIs in 
a full page or web part. This manual shows you how to create some of the more 
common KPIs, such as the current ratio and gross profit margin.

Check for updated instructions
This information was current as of March 16, 2010. The documentation may be 
updated as new information becomes available. Check the Microsoft Dynamics GP 
documentation web site (http://go.microsoft.com/fwlink/?LinkId=185513) for the 
most current documentation. 

This introduction is divided into the following sections:

• What’s in this manual
• Symbols and conventions
• Additional resources
• Technical support
• Send us your documentation comments

What’s in this manual

Each chapter in this manual explains how to create a specific KPI. The following 
chapters are included:

• Chapter 1, “Current ratio,” describes how to create a KPI that indicates whether 
your company is able to meet its current obligations.

• Chapter 2, “Quick ratio,” describes how to create a KPI that measures your 
company’s liquidity.

• Chapter 3, “Debt to equity ratio,” describes how to create a KPI that indicates 
how much your company is leveraged (in debt).

• Chapter 4, “Debt ratio,” describes how to create a KPI that indicates the amount 
of debt your company has taken on relative to the total assets it owns.

• Chapter 5, “Gross profit margin,” describes how to create a KPI that indicates 
how efficiently your company is using its materials and labor in the production 
process.

• Chapter 6, “Return on sales,” describes how to create a KPI that helps you 
determine whether your company is making an appropriate return on its sales 
efforts.

http://go.microsoft.com/fwlink/?LinkId=161199
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• Chapter 7, “Customer service levels,” describes how to create a KPI that 
indicates the percentage of shipments that are overdue.

• Chapter 8, “Standard purchase orders overdue,” describes how to create a KPI 
that calculates the percentage of standard purchase orders that haven’t been 
received on time.

• Chapter 9, “Drop ship purchase orders overdue,” displays how to create a KPI 
that calculates the percentage of drop ship purchase orders that haven’t been 
received on time.

Symbols and conventions

This manual uses the following symbols to make specific types of information stand 
out.

This manual uses the following conventions to refer to sections, navigation, and 
other information.

Additional resources

In addition to this manual, the following documentation is included with this 
release of Business Portal.

Manuals
The following PDF manuals are included in the Documentation folder on the 
Business Portal installation media.

Business Portal Installation Guide The Installation Guide 
(BusinessPortalInstallation.pdf) provides step-by-step instructions for installing 
Business Portal.

Business Portal Administrator’s Guide The Administrator’s Guide 
(BusinessPortalAdminGuide.pdf) explains how to set up and configure Business 
Portal.

Symbol Description

The light bulb symbol indicates helpful tips, shortcuts, and suggestions.

The warning symbol indicates situations you should be especially aware 
of when completing tasks. Typically, this includes cautions about 
performing steps in their proper order, or important reminders about 
how other information in Business Portal or the back office might be 
affected.

Convention Description

Create a KPI Italic type indicates the name of a section or procedure.

File > Print The (>) symbol indicates a sequence of actions, such as clicking items on 
a menu or a toolbar or clicking buttons in a window. This example 
directs you to go to the File menu and click Print.

Bold Bold type indicates the names of fields, tabs, menus, commands, and 
buttons, and text you should type.

TAB or ENTER Small capital letters indicate a key or a key sequence.



C O M M O N  K P I S  G U I D E 3

I N T R O D U C T I O N

Business Portal User’s Guide The User’s Guide 
(BusinessPortalUsersGuide.pdf) helps users complete day-to-day tasks in Business 
Portal.

Application manuals User and administrator manuals for each application 
installed in Business Portal are available in the Documentation folder.

Key Performance Indicators manual The Key Performance Indicators 
manual (KeyPerformanceIndicators.pdf) explains how to install Key Performance 
Indicators, and create and administer KPIs so Business Portal users can view them.

Help
Help is available by clicking the Help icon button, located in the upper-right corner 
of any page. The help that is displayed depends on whether you open help from a 
Business Portal page, a Microsoft Windows® SharePoint® Services page, or a 
Microsoft Office SharePoint Server 2007 page or Microsoft SharePoint Server 2010 
page.

Business Portal help When you click the Help icon button on a Business Portal 
page, the relevant help topic for that page is displayed. You can use the search field 
on the help page to search for information. You also can click the Home icon button 
to browse the contents of the help.

SharePoint help  Many of the features included in Business Portal—such as 
document libraries, lists, announcements, links, and alerts—are provided by 
Windows SharePoint Services. General information about these features is provided 
in the Administering Business Portal help. For more detailed information, refer to 
the Windows SharePoint Services help, which can be accessed by clicking the Help 
icon button in the upper-right corner of any Windows SharePoint Services page. If 
you’re using Office SharePoint Server 2007 or Microsoft SharePoint Server 2010, 
additional help related to SharePoint Server features also will be available.

Technical support

You can contact Microsoft Dynamics technical support online or by telephone. Go to 
www.microsoft.com/dynamics and click the CustomerSource link or call 888-477-
7877 (in the U.S. and Canada) or 701-281-0555.

Send us your documentation comments

We welcome comments regarding the usefulness of the Microsoft Dynamics GP 
documentation. If you have specific suggestions or find any errors in this manual, 
send your comments by e-mail to the following address: bizdoc@microsoft.com.

Note: By offering any suggestions to Microsoft, you give Microsoft full permission to use 
them freely.

http://www.microsoft.com/dynamics
mailto:bizdoc@microsoft.com
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Chapter 1: Current ratio
The current ratio is a standard measure of any company’s financial health. It 
indicates whether your company is able to meet its current obligations by 
measuring whether the company has enough assets to cover its liabilities.

After you’ve created the Current Ratio KPI, refer to the Key Performance Indicators 
documentation for information about how to display KPIs to Business Portal users. 
You can only display KPIs in a full page or web part if you have used KPIs in a 
previous release of Business Portal and have upgraded to Business Portal for 
Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Current Assets query
• Create the Current Liabilities query
• Create the Total Current Assets KPI
• Create the Total Current Liabilities KPI
• Create the Current Ratio KPI

Overview

You’ll need to complete the following steps to create the Current Ratio KPI.

Create the Current Assets query

Use the following steps to create the Current Assets query, which displays 
information about current asset accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 

Step Description Described in

1. Create the Current 
Assets query

Displays information about 
current asset accounts

Create the Current Assets query on 
page 5

2. Create the Current 
Liabilities query

Displays information about 
current liability accounts

Create the Current Liabilities query 
on page 6

3. Create the Total 
Current Assets KPI

Calculates the sum of the account 
balances from the Current Assets 
query

Create the Total Current Assets KPI 
on page 7

4. Create the Total 
Current Liabilities KPI

Calculates the sum of the account 
balances from the Current 
Liabilities query

Create the Total Current Liabilities 
KPI on page 9

5. Create the Current 
Ratio KPI

Divides the Total Current Assets 
KPI by the Total Current Liabilities 
KPI

Create the Current Ratio KPI on 
page 10
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5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the current asset accounts. For example, if you’re using the 
sample company, Fabrikam, Inc., you would restrict the query where segment 2 
of the account number is between 1100 and 1399.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Current Assets. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Current Liabilities query

Use the following steps to create the Current Liabilities query, which displays 
information about current liability accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 
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5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the current liability accounts. For example, if you’re using 
the sample company, Fabrikam, Inc., you would restrict the query where 
segment 2 of the account number is between 2100 and 2899.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Current Liabilities. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Total Current Assets KPI

Use the following steps to create the Total Current Assets KPI, which displays the 
sum of the amounts in the current asset accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.
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4. In the Name and Description area, type the following information:

• In the Name field, type Total Current Assets.

• In the Description field, type Sum of Current Assets.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Current Assets query, which was created in Create the Current Assets 
query on page 5.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.

10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.

12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.
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15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Total Current Liabilities KPI

Use the following steps to create the Total Current Liabilities KPI, which displays 
the sum of the amounts in the current liability accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Total Current Liabilities.

• In the Description field, type Sum of Current Liabilities.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears.

6. Select the Current Liabilities query, which was created in Create the Current 
Liabilities query on page 6.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located list, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.
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10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.

12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Current Ratio KPI

Use the following procedure to create the Current Ratio KPI, which calculates and 
displays the value of the total current assets divided by the total current liabilities.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Current Ratio.

• In the Description field, type Current Ratio.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.
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6. Type the following equation:

“Total Current Assets”/(“Total Current Liabilities”*-1)

7. Click OK.

8. In the Data Calculation area, do the following:

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 2.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Chapter 2: Quick ratio
The quick ratio—sometimes referred to as the acid test ratio—measures your 
company’s liquidity by calculating the company’s liquid assets in relation to its 
liabilities.

After you’ve created the Quick Ratio KPI, refer to the Key Performance Indicators 
documentation for information about how to display KPIs to Business Portal users. 
You can only display KPIs in a full page or web part if you have used KPIs in a 
previous release of Business Portal and have upgraded to Business Portal for 
Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Cash query
• Create the Net Receivables query
• Create the Current Liabilities query
• Create the Total Cash KPI
• Create the Net Receivables KPI
• Create the Total Current Liabilities KPI
• Create the Quick Ratio KPI

Overview

You’ll need to complete the following steps to create the Quick Ratio KPI.

Create the Cash query

Use the following steps to create the Cash query, which displays information about 
cash accounts.

Step Description Described in

1. Create the Cash 
query

Displays information about cash 
accounts

Create the Cash query on page 13

2. Create the Net 
Receivables query

Displays information about 
receivables accounts

Create the Net Receivables query 
on page 14

3. Create the Current 
Liabilities query

Displays information about 
current liability accounts

Create the Current Liabilities query 
on page 15

4. Create the Total Cash 
KPI

Calculates the sum of the account 
balances from the Cash query

Create the Total Cash KPI on 
page 16

5. Create the Net 
Receivables KPI

Calculates the sum of the account 
balances from the Net Receivables 
query

Create the Net Receivables KPI on 
page 17

6. Create the Total 
Current Liabilities KPI

Calculates the sum of the account 
balances from the Current 
Liabilities query

Create the Total Current Liabilities 
KPI on page 18

7. Create the Quick 
Ratio KPI

Adds the Total Cash KPI to the Net 
Receivables KPI and then divides 
the resulting value by the Total 
Current Liabilities KPI

Create the Quick Ratio KPI on 
page 19
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1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 

5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the cash accounts. For example, if you’re using the sample 
company, Fabrikam, Inc., you would restrict the query where segment 2 of the 
account number is between 1100 and 1199.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Cash. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Net Receivables query

Use the following steps to create the Net Receivables query, which displays 
information about receivables accounts.
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1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 

5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the receivable accounts. For example, if you’re using the 
sample company, Fabrikam, Inc., you would restrict the query where segment 2 
of the account number is between 1200 and 1289.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Net Receivables. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Current Liabilities query

To create the Current Liabilities query, see the instructions in Create the Current 
Liabilities query on page 6.
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Create the Total Cash KPI

Use the following steps to create the Total Cash KPI, which displays the total of the 
cash accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Total Cash.

• In the Description field, type Sum of Cash.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Cash query, which was created in Create the Cash query on page 13.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.

10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.
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12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Net Receivables KPI

Use the following steps to create the Net Receivables KPI, which displays the total 
of the receivables accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Net Receivables.

• In the Description field, type Sum of Net Receivables.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Net Receivables query, which was created in Create the Net Receivables 
query on page 14.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.
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• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.

10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.

12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Total Current Liabilities KPI

To create the Total Current Liabilities query, see the instructions in Create the Total 
Current Liabilities KPI on page 9.
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Create the Quick Ratio KPI

Use the following steps to create the Quick Ratio KPI, which calculates and displays 
the value of the total cash and receivables accounts, divided by the total liabilities.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Quick Ratio.

• In the Description field, type Quick Ratio.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.

6. Type the following equation:

(“Total Cash”+“Net Receivables”)/(“Total Current Liabilities”*-1)

7. Click OK.

8. In the Data Calculation area, do the following:

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 2.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.
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14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Chapter 3: Debt to equity ratio
The debt to equity ratio indicates how much your company is leveraged (in debt) by 
comparing what is owed to what is owned.

After you’ve created the Debt to Equity Ratio KPI, refer to the Key Performance 
Indicators documentation for information about how to display KPIs to Business 
Portal users. You can only display KPIs in a full page or web part if you have used 
KPIs in a previous release of Business Portal and have upgraded to Business Portal 
for Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Total Liabilities query
• Create the Total Equity query
• Create the Total Liabilities KPI
• Create the Total Equity KPI
• Create the Debt to Equity Ratio KPI

Overview

You’ll need to complete the following steps to create the Debt to Equity Ratio KPI.

Create the Total Liabilities query

Use the following steps to create the Total Liabilities query, which displays 
information about liability accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 

Step Description Described in

1. Create the Total 
Liabilities query

Displays information about 
liability accounts

Create the Total Liabilities query 
on page 21

2. Create the Total 
Equity query

Displays information about equity 
accounts

Create the Total Equity query on 
page 22

3. Create the Total 
Liabilities KPI

Calculates the sum of the account 
balances from the Total Liabilities 
query

Create the Total Liabilities KPI on 
page 23

4. Create the Total 
Equity KPI

Calculates the sum of the account 
balances from the Total Equity 
query

Create the Total Equity KPI on 
page 25

5. Create the Debt to 
Equity Ratio KPI

Divides the Total Liabilities KPI by 
the Total Equity KPI

Create the Debt to Equity Ratio KPI 
on page 26
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5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the liability accounts. For example, if you’re using the 
sample company, Fabrikam, Inc., you would restrict the query where segment 2 
of the account number is between 2000 and 2999.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Total Liabilities.

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Total Equity query

Use the following steps to create the Total Equity query, which displays information 
about equity accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 
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5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the equity accounts. For example, if you’re using the 
sample company, Fabrikam, Inc., you would restrict the query where segment 2 
of the account number is between 3000 and 3999.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Total Equity. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Total Liabilities KPI

Use the following steps to create the Total Liabilities KPI, which displays the total of 
the liability accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.
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4. In the Name and Description area, type the following information:

• In the Name field, type Total Liabilities.

• In the Description field, type Sum of Total Liabilities.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Total Liabilities query, which was created in Create the Total Liabilities 
query on page 21.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.

10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.

12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.
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15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Total Equity KPI

Use the following steps to create the Total Equity KPI, which displays the total of 
the equity accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Total Equity.

• In the Description field, type Sum of Total Equity.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Total Equity query, which was created in Create the Total Equity query 
on page 22.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.
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10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.

12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Debt to Equity Ratio KPI

Use the following steps to create the Debt to Equity Ratio KPI, which calculates and 
displays the value of the total liabilities divided by the total equity.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Debt to Equity Ratio.

• In the Description field, type Debt to Equity Ratio.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.
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6. Type the following equation:

(“Total Liabilities”*-1)/“Total Equity”

7. Click OK.

8. In the Data Calculation area, do the following:

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 2.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Chapter 4: Debt ratio
The debt ratio indicates the amount of debt your company has taken on relative to 
the total assets it owns.

After you’ve created the Debt Ratio KPI, refer to the Key Performance Indicators 
documentation for information about how to display KPIs to Business Portal users. 
You can only display KPIs in a full page or web part if you have used KPIs in a 
previous release of Business Portal and have upgraded to Business Portal for 
Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Total Liabilities query
• Create the Total Assets query
• Create the Total Liabilities KPI
• Create the Total Assets KPI
• Create the Debt Ratio KPI

Overview

You’ll need to complete the following steps to create the Debt Ratio KPI.

Create the Total Liabilities query

To create the Total Liabilities query, see the instructions in Create the Total Liabilities 
query on page 21.

Create the Total Assets query

Use the following steps to create the Total Assets query, which displays information 
about asset accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

Step Description Described in

1. Create the Total 
Liabilities query

Displays information about 
liability accounts

Create the Total Liabilities query 
on page 29

2. Create the Total 
Assets query

Displays information about asset 
accounts

Create the Total Assets query on 
page 29

3. Create the Total 
Liabilities KPI

Calculates the sum of the account 
balances from the Total Liabilities 
query

Create the Total Liabilities KPI on 
page 30

4. Create the Total 
Assets KPI

Calculates the sum of the account 
balances from the Total Assets 
query

Create the Total Assets KPI on 
page 31

5. Create the Debt Ratio 
KPI

Divides the Total Liabilities KPI by 
the Total Assets KPI

Create the Debt Ratio KPI on 
page 32
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3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 

5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the asset accounts. For example, if you’re using the sample 
company, Fabrikam, Inc., you would restrict the query where segment 2 of the 
account number is between 1000 and 1999.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Total Assets. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Total Liabilities KPI

To create the Total Liabilities KPI, see the instructions in Create the Total Liabilities KPI 
on page 23.
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Create the Total Assets KPI

Use the following steps to create the Total Assets KPI, which displays the total of the 
asset accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Total Assets.

• In the Description field, type Sum of Total Assets.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Total Assets query, which was created in Create the Total Assets query 
on page 29.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.

10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.
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12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Debt Ratio KPI

Use the following steps to create the Debt Ratio KPI, which calculates and displays 
the value of the total liabilities divided by the total assets.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Debt Ratio.

• In the Description field, type Debt Ratio.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.

6. Type the following equation:

(“Total Liabilities”*-1)/“Total Assets”

7. Click OK.

8. In the Data Calculation area, do the following:

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 2.
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9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Chapter 5: Gross profit margin
The gross profit margin indicates how efficiently your business is using its materials 
and labor in the production process. It shows the percentage of net sales remaining 
after subtracting the cost of goods sold (COGS).

After you’ve created the Gross Profit Margin KPI, refer to the Key Performance 
Indicators documentation for information about how to display KPIs to Business 
Portal users. You can only display KPIs in a full page or web part if you have used 
KPIs in a previous release of Business Portal and have upgraded to Business Portal 
for Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Gross Profit query
• Create the Total Sales query
• Create the Gross Profit KPI
• Create the Total Sales KPI
• Create the Gross Profit Margin KPI

Overview

You’ll need to complete the following steps to create the Gross Profit Margin KPI.

Create the Gross Profit query

Use the following steps to create the Gross Profit query, which displays information 
about sales and COGS accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 

Step Description Described in

1. Create the Gross 
Profit query

Displays information about sales 
and COGS accounts

Create the Gross Profit query on 
page 35

2. Create the Total 
Sales query

Displays information about sales 
accounts

Create the Total Sales query on 
page 36

3. Create the Gross 
Profit KPI

Calculates the sum of the account 
balances from the Gross Profit 
query

Create the Gross Profit KPI on 
page 37

4. Create the Total 
Sales KPI

Calculates the sum of the account 
balances from the Total Sales 
query

Create the Total Sales KPI on 
page 39

5. Create the Gross 
Profit Margin KPI

Divides the Gross Profit KPI by the 
Total Sales KPI

Create the Gross Profit Margin KPI 
on page 40
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5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the sales and COGS accounts. For example, if you’re using 
the sample company, Fabrikam, Inc., you would restrict the query where 
segment 2 of the account number is between 4100 and 4599.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Gross Profit. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Total Sales query

Use the following steps to create the Total Sales query, which displays information 
about sales accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 
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5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the current liability accounts. For example, if you’re using 
the sample company, Fabrikam, Inc., you would restrict the query where 
segment 2 of the account number is between 4100 and 4150.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Total Sales. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Gross Profit KPI

Use the following steps to create the Gross Profit KPI, which displays the total of the 
sales and COGS accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.
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4. In the Name and Description area, type the following information:

• In the Name field, type Gross Profit.

• In the Description field, type Gross Profit.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Gross Profit query, which was created in Create the Gross Profit query 
on page 35.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.

10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.

12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.
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15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Total Sales KPI

Use the following steps to create the Total Sales KPI, which displays the total of the 
sales accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Total Sales.

• In the Description field, type Sum of Total Sales.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Total Sales query, which was created in Create the Total Sales query on 
page 36.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.
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10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.

12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Gross Profit Margin KPI

Use the following steps to create the Gross Profit Margin KPI, which calculates and 
displays the value of the total sales and cost of goods sold, divided by the total 
sales.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Gross Profit Margin.

• In the Description field, type Gross Profit Margin.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.
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6. Type the following equation:

(“Gross Profit”*-1)/(“Total Sales”*-1)*100

7. Click OK.

8. In the Data Calculation area, do the following:

• In the Format the results as list, select Percent.

• In the Number of decimal places field, type 2.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Chapter 6: Return on sales
The return on sales ratio compares after-tax profit to sales. It helps you determine 
whether your company is making an appropriate return on its sales efforts.

After you’ve created the Return on Sales KPI, refer to the Key Performance 
Indicators documentation for information about how to display KPIs to Business 
Portal users. You can only display KPIs in a full page or web part if you have used 
KPIs in a previous release of Business Portal and have upgraded to Business Portal 
for Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Net Profit query
• Create the Net Sales query
• Create the Net Profit KPI
• Create the Net Sales KPI
• Create the Return on Sales KPI

Overview

You’ll need to complete the following steps to create the Return on Sales KPI.

Create the Net Profit query

Use the following steps to create the Net Profit query, which displays information 
about sales and expense accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 

5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.

Step Description Described in

1. Create the Net Profit 
query

Displays information about sales 
and expense accounts

Create the Net Profit query on 
page 43

2. Create the Net Sales 
query

Displays information about sales 
accounts

Create the Net Sales query on 
page 44

3. Create the Net Profit 
KPI

Calculates the sum of the account 
balances from the Net Profit query

Create the Net Profit KPI on 
page 45

4. Create the Net Sales 
KPI

Calculates the sum of the account 
balances from the Net Sales query

Create the Net Sales KPI on 
page 47

5. Create the Return on 
Sales KPI

Divides the Net Profit KPI by the 
Net Sales KPI

Create the Return on Sales KPI on 
page 48
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6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the sales and expense accounts. For example, if you’re 
using the sample company, Fabrikam, Inc., you would restrict the query where 
segment 2 of the account number is between 4000 and 8999.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Net Profit. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Net Sales query

Use the following steps to create the Net Sales query, which displays information 
about sales accounts.

1. Go to the Financial Queries page.
Point to Business Portal on the top link bar > click Financial Center > click 
Queries on the Quick Launch
-or-
Click Financial on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Account.

3. Select the Financial Account query.

4. Click Modify Query. The Modify Query page appears. 

5. On the Select Columns tab, click the plus sign (+) next to Ledger Transaction 
Summary.
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6. Select the following columns:

• Year
• Period
• Debit Amount
• Credit Amount
• Net Change

7. Click the Restrict Rows tab.

8. Select the Advanced option.

9. Restrict the query to the sales accounts. For example, if you’re using the sample 
company, Fabrikam, Inc., you would restrict the query where segment 2 of the 
account number is between 4100 and 4199.

10. Click the Options tab.

11. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

12. Click OK to save your changes. The Financial Queries page reappears, 
displaying the modified query.

13. Click Save Query.

14. On the Modify Query page, name the query Net Sales. 

15. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Net Profit KPI

Use the following steps to create the Net Profit KPI, which displays the total of the 
sales and expense accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Net Profit.

• In the Description field, type Total Net Profit.
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5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Net Profit query, which was created in Create the Net Profit query on 
page 43.

7. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

8. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Create the Net Sales KPI

Use the following steps to create the Net Sales KPI, which displays the total of the 
sales accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Net Sales.

• In the Description field, type Sum of Net Sales.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Net Sales query, which was created in Create the Net Sales query on 
page 44.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Net Change.

• In the Type of calculation to perform list, select Sum.

• In the Format the results as list, select Currency.

• In the Number of decimal places field, type 2.

9. In the Time Periods area, select the My query has a column that contains fiscal 
time periods option and do the following:

• In the Fiscal year column list, select Year.

• In the Fiscal period column list, select Period.

10. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

11. Click Next to open the next Create KPI page.
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12. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

13. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

14. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

15. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

16. In the Save to Folder area, select the folder the KPI will be saved in.

17. Click OK to save the KPI and return to the KPI Management page.

Create the Return on Sales KPI

Use the following steps to create the Return on Sales KPI, which calculates and 
displays the value of the total sales and expense accounts, divided by the total sales 
accounts.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Return on Sales.

• In the Description field, type Return on Sales Ratio.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.

6. Type the following equation:

(“Net Profit”*-1)/(“Net Sales”*-1)

7. Click OK.
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8. In the Data Calculation area, do the following:

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 2.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Year folder, select Current Year and Previous Year.

• In the Fiscal Period folder, select Current Period, Previous Period, and 
One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Weekly in the Default Recalculation 
Rate list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Chapter 7: Customer service levels
The customer service levels indicate the percentage of shipments that are overdue.

After you’ve created the Customer Service Levels KPI, refer to the Key Performance 
Indicators documentation for information about how to display KPIs to Business 
Portal users. You can only display KPIs in a full page or web part if you have used 
KPIs in a previous release of Business Portal and have upgraded to Business Portal 
for Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Late Shipments query
• Create the All Invoices query
• Create the Late Shipments KPI
• Create the All Invoices KPI
• Create the Customer Service Levels KPI

Overview

You’ll need to complete the following steps to create the Customer Service Levels 
KPI.

Create the Late Shipments query

Use the following steps to create the Late Shipments query, which displays 
information about late shipments.

1. Go to the Sales Queries page.
Point to Business Portal on the top link bar > click Sales Center > click Queries 
on the Quick Launch
-or-
Click Sales on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, expand the Sales Document > Sales Invoice 
Document node.

3. Select the Sales Invoice query.

4. Click Modify Query. The Modify Query page appears. 

5. Click the Restrict Rows tab.

Step Description Described in

1. Create the Late 
Shipments query

Displays information about late 
shipments

Create the Late Shipments query 
on page 51

2. Create the All 
Invoices query

Displays information about 
invoices

Create the All Invoices query on 
page 52

3. Create the Late 
Shipments KPI

Calculates the number of records 
in the Late Shipments query

Create the Late Shipments KPI on 
page 53

4. Create the All 
Invoices KPI

Calculates the number of records 
in the All Invoices query

Create the All Invoices KPI on 
page 54

5. Create the Customer 
Service Levels KPI

Divides the Late Shipments KPI by 
the All Invoices KPI

Create the Customer Service 
Levels KPI on page 56
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6. Select the Advanced option and click the lookup button. The Column Lookup 
page appears.

7. Click the plus sign (+) next to Dates.

8. Select Actual Ship Date and click OK. The Modify Query page reappears. 

9. Select is greater than from the list and click the arrow button. The Advanced 
Restrictions page appears.

10. Select Compare to, and then select Requested Ship Date from the list that 
appears. 

11. Click OK. The Modify Query page reappears. Verify that the page looks like the 
following.

12. Click the Options tab.

13. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

14. Click OK to save your changes. The Sales Queries page reappears, displaying 
the modified query.

15. Click Save Query.

16. On the Modify Query page, name the query Late Shipments. 

17. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the All Invoices query

Use the following steps to create the All Invoices query, which displays information 
about invoices.

1. Go to the Sales Queries page.
Point to Business Portal on the top link bar > click Sales Center > click Queries 
on the Quick Launch
-or-
Click Sales on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, expand the Sales Document > Sales Invoice 
Document node.

3. Select the Sales Invoice query.

4. Click Modify Query. The Modify Query page appears. 

5. Click the Options tab.
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6. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

7. Click OK to save your changes. The Sales Queries page reappears, displaying 
the modified query.

8. Click Save Query.

9. On the Modify Query page, name the query All Invoices. 

10. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Late Shipments KPI

Use the following steps to create the Late Shipments KPI, which displays the 
number of late shipments for your company.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Late Shipments.

• In the Description field, type Late Shipments.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Late Shipments query, which was created in Create the Late Shipments 
query on page 51.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Document Amount.

• In the Type of calculation to perform list, select Count.

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 0.

9. In the Time Periods area, select the My query has a column that contains 
calendar dates option.

10. In the Calendar date column list, select Document Date.
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11. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.

12. Click Next to open the next Create KPI page.

13. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

14. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

15. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

16. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

17. In the Save to Folder area, select the folder the KPI will be saved in.

18. Click OK to save the KPI and return to the KPI Management page.

Create the All Invoices KPI

Use the following steps to create the All Invoices KPI, which displays the number of 
invoices for your company.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 
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3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type All Invoices.

• In the Description field, type Number of invoices.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the All Invoices query, which was created in Create the All Invoices query 
on page 52. 

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Document Amount.

• In the Type of calculation to perform list, select Count.

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 0.

9. In the Time Periods area, select the My query has a column that contains 
calendar dates option.

10. In the Calendar date column list, select Document Date.

11. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.

12. Click Next to open the next Create KPI page.
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13. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

14. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

15. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

16. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

17. In the Save to Folder area, select the folder the KPI will be saved in.

18. Click OK to save the KPI and return to the KPI Management page.

Create the Customer Service Levels KPI

Use the following steps to create the Customer Service Levels KPI, which calculates 
and displays the total number of late shipments divided by the total number of 
invoices.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Customer Service Levels.

• In the Description field, type Percentage of invoices that shipped late.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.

6. Type the following equation:

(“Late Shipments”/“All Invoices”)*100

7. Click OK.
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8. In the Data Calculation area, do the following:

• In the Format the results as list, select Percent.

• In the Number of decimal places field, type 2.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Chapter 8: Standard purchase orders overdue
You can create a KPI that calculates the percentage of standard purchase orders for 
your company that haven’t been received on time.

After you’ve created the Standard Purchase Orders Overdue KPI, refer to the Key 
Performance Indicators documentation for information about how to display KPIs 
to Business Portal users. You can only display KPIs in a full page or web part if you 
have used KPIs in a previous release of Business Portal and have upgraded to 
Business Portal for Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Standard Purchase Orders query
• Create the Overdue Standard Purchase Orders query
• Create the Standard Purchase Orders KPI
• Create the Overdue Standard Purchase Orders KPI
• Create the Standard Purchase Orders Overdue KPI

Overview

You’ll need to complete the following steps to create the Standard Purchase Orders 
Overdue KPI.

Create the Standard Purchase Orders query

Use the following steps to create the Standard Purchase Orders query, which 
displays information about standard purchase orders.

1. Go to the Purchasing Queries page.
Point to Business Portal on the top link bar > click Purchasing Center > click 
Queries on the Quick Launch
-or-
Click Purchasing on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Purchase Order.

3. Select the Standard Purchase Order query.

Step Description Described in

1. Create the Standard 
Purchase Orders query

Displays information about 
standard purchase orders

Create the Standard Purchase 
Orders query on page 59

2. Create the Overdue 
Standard Purchase 
Orders query

Displays information about 
overdue standard purchase orders

Create the Overdue Standard 
Purchase Orders query on page 61

3. Create the Standard 
Purchase Orders KPI

Calculates the number of records 
in the Standard Purchase Orders 
query

Create the Standard Purchase 
Orders KPI on page 62

4. Create the Overdue 
Standard Purchase 
Orders KPI

Calculates the number of records 
in the Overdue Standard Purchase 
Orders query

Create the Overdue Standard 
Purchase Orders KPI on page 64

5. Create the Standard 
Purchase Orders 
Overdue KPI

Divides the Overdue Standard 
Purchase Orders KPI by the 
Standard Purchase Orders KPI

Create the Standard Purchase 
Orders Overdue KPI on page 65
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4. Click Modify Query. The Modify Query page appears. 

5. Click the Restrict Rows tab.

6. In the Status field, restrict the query to purchase orders with the following 
statuses:

• New
• Released
• Change Order

7. Click the Options tab.

8. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

9. Click OK to save your changes. The Purchasing Queries page reappears, 
displaying the modified query.

10. Click Save Query.

11. On the Modify Query page, name the query Standard Purchase Orders. 

12. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.
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Create the Overdue Standard Purchase Orders query

Use the following steps to create the Overdue Standard Purchase Orders query, 
which displays information about overdue standard purchase orders.

1. Go to the Purchasing Queries page.
Point to Business Portal on the top link bar > click Purchasing Center > click 
Queries on the Quick Launch
-or-
Click Purchasing on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Purchase Order.

3. Select the Standard Purchase Order query.

4. Click Modify Query. The Modify Query page appears. 

5. Click the Restrict Rows tab.

6. Select the Advanced option and click the lookup button. The Column Lookup 
page appears.

7. Select Status and click OK. The Modify Query page reappears. 

8. Select is equal to from the list.

9. Restrict the query to purchase orders with the following statuses:

• New
• Released
• Change Order

10. Click the lookup button in the second row. The Column Lookup page appears.

11. Select Date Promised and click OK. The Modify Query page reappears. 

12. Select is less than from the list and click the arrow button. The Advanced 
Restrictions page appears.

13. Select Variables, and then select Today from the list that appears. 
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14. Click OK. The Modify Query page reappears. Verify that the page looks like the 
following.

15. Click the Options tab.

16. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

17. Click OK to save your changes. The Purchasing Queries page reappears, 
displaying the modified query.

18. Click Save Query.

19. On the Modify Query page, name the query Overdue Standard Purchase 
Orders. 

20. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Standard Purchase Orders KPI

Use the following steps to create the Standard Purchase Orders KPI, which displays 
the total number of standard purchase orders.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.
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4. In the Name and Description area, type the following information:

• In the Name field, type Standard Purchase Orders.

• In the Description field, type Number of standard purchase orders, 
excluding closed, canceled, and received purchase orders.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Standard Purchase Orders query, which was created in Create the 
Standard Purchase Orders query on page 59.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Subtotal.

• In the Type of calculation to perform list, select Count.

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 0.

9. In the Time Periods area, select the My query has a column that contains 
calendar dates option.

10. In the Calendar date column list, select Document Date.

11. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.

12. Click Next to open the next Create KPI page.

13. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.
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14. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

15. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

16. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

17. In the Save to Folder area, select the folder the KPI will be saved in.

18. Click OK to save the KPI and return to the KPI Management page.

Create the Overdue Standard Purchase Orders KPI

Use the following steps to create the Overdue Standard Purchase Orders KPI, which 
displays the total number of overdue standard purchase orders.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Overdue Standard Purchase Orders.

• In the Description field, type Number of standard purchase orders that 
are overdue.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Overdue Standard Purchase Orders query, which was created in 
Create the Overdue Standard Purchase Orders query on page 61.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Subtotal.

• In the Type of calculation to perform list, select Count.

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 0.
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9. In the Time Periods area, select the My query has a column that contains 
calendar dates option.

10. In the Calendar date column list, select Document Date.

11. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.

12. Click Next to open the next Create KPI page.

13. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

14. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

15. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

16. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

17. In the Save to Folder area, select the folder the KPI will be saved in.

18. Click OK to save the KPI and return to the KPI Management page.

Create the Standard Purchase Orders Overdue KPI

Use the following steps to create the Standard Purchase Orders Overdue KPI, which 
calculates and displays the value of the total number of overdue standard purchase 
orders divided by the total number of standard purchase orders.
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1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Standard Purchase Orders Overdue.

• In the Description field, type Percentage of standard purchase orders that 
are overdue.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.

6. Type the following equation:

(“Overdue Standard Purchase Orders”/“Standard Purchase Orders”)*100

7. Click OK.

8. In the Data Calculation area, do the following:

• In the Format the results as list, select Percent.

• In the Number of decimal places field, type 2.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.

10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.
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12. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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Chapter 9: Drop ship purchase orders overdue
You can create a KPI that calculates the percentage of drop ship purchase orders that 
haven’t been received on time.

After you’ve created the Drop Ship Purchase Orders Overdue KPI, refer to the Key 
Performance Indicators documentation for information about how to display KPIs 
to Business Portal users. You can only display KPIs in a full page or web part if you 
have used KPIs in a previous release of Business Portal and have upgraded to 
Business Portal for Microsoft Dynamics GP 2010.

This information is divided into the following sections:

• Overview
• Create the Drop Ship Purchase Orders query
• Create the Overdue Drop Ship Purchase Orders query
• Create the Drop Ship Purchase Orders KPI
• Create the Overdue Drop Ship Purchase Orders KPI
• Create the Drop Ship Purchase Orders Overdue KPI

Overview

You’ll need to complete the following steps to create the Drop Ship Purchase Orders 
Overdue KPI.

Create the Drop Ship Purchase Orders query

Use the following steps to create the Drop Ship Purchase Orders query, which 
displays information about drop ship purchase orders.

1. Go to the Purchasing Queries page.
Point to Business Portal on the top link bar > click Purchasing Center > click 
Queries on the Quick Launch
-or-
Click Purchasing on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Purchase Order.

3. Select the Drop Ship Purchase Order query.

Step Description Described in

1. Create the Drop Ship 
Purchase Orders query

Displays information about drop 
ship purchase orders

Create the Drop Ship Purchase 
Orders query on page 69

2. Create the Overdue 
Drop Ship Purchase 
Orders query

Displays information about 
overdue drop ship purchase 
orders

Create the Overdue Drop Ship 
Purchase Orders query on page 71

3. Create the Drop Ship 
Purchase Orders KPI

Calculates the number of records 
in the Drop Ship Purchase Orders 
query

Create the Drop Ship Purchase 
Orders KPI on page 72

4. Create the Overdue 
Drop Ship Purchase 
Orders KPI

Calculates the number of records 
in the Overdue Drop Ship 
Purchase Orders query

Create the Overdue Drop Ship 
Purchase Orders KPI on page 74

5. Create the Drop Ship 
Purchase Orders 
Overdue KPI

Divides the Overdue Drop Ship 
Purchase Orders KPI by the Drop 
Ship Purchase Orders KPI

Create the Drop Ship Purchase 
Orders Overdue KPI on page 76
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4. Click Modify Query. The Modify Query page appears. 

5. Click the Restrict Rows tab.

6. In the Status field, restrict the query to drop ship purchase orders with the 
following statuses:

• New
• Released
• Change Order

7. Click the Options tab.

8. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

9. Click OK to save your changes. The Purchasing Queries page reappears, 
displaying the modified query.

10. Click Save Query.

11. On the Modify Query page, name the query Drop Ship Purchase Orders. 

12. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.
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Create the Overdue Drop Ship Purchase Orders query

Use the following steps to create the Overdue Drop Ship Purchase Orders query, 
which displays information about overdue drop ship purchase orders.

1. Go to the Purchasing Queries page.
Point to Business Portal on the top link bar > click Purchasing Center > click 
Queries on the Quick Launch
-or-
Click Purchasing on the top link bar > click Queries on the Quick Launch 

2. In the Queries web part, click the plus sign (+) next to Purchase Order.

3. Select the Drop Ship Purchase Order query.

4. Click Modify Query. The Modify Query page appears. 

5. Click the Restrict Rows tab.

6. Select the Advanced option and click the lookup button. The Column Lookup 
page appears.

7. Select Status and click OK. The Modify Query page reappears. 

8. Select is equal to from the list.

9. Restrict the query to drop ship purchase orders with the following statuses:

• New
• Released
• Change Order

10. Click the lookup button in the second row. The Column Lookup page appears.

11. Select Date Promised and click OK. The Modify Query page reappears. 

12. Select is less than from the list and click the arrow button. The Advanced 
Restrictions page appears.

13. Select Variables, and then select Today from the list that appears. 
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14. Click OK. The Modify Query page reappears. Verify that the page looks like the 
following.

15. Click the Options tab.

16. Select a company from the list. You must select a specific company from the list; 
do not select the <Any> option.

17. Click OK to save your changes. The Purchasing Queries page reappears, 
displaying the modified query.

18. Click Save Query.

19. On the Modify Query page, name the query Overdue Drop Ship Purchase 
Orders. 

20. Click Save to save the query. You must store the query in a shared folder if it 
will be used to create a KPI. See the Key Performance Indicators documentation 
for more information.

Create the Drop Ship Purchase Orders KPI

Use the following steps to create the Drop Ship Purchase Orders KPI, which 
displays the total number of drop ship purchase orders.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.
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4. In the Name and Description area, type the following information:

• In the Name field, type Drop Ship Purchase Orders.

• In the Description field, type Number of drop ship purchase orders, 
excluding closed, canceled, and received purchase orders.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Drop Ship Purchase Orders query, which was created in Create the 
Drop Ship Purchase Orders query on page 69.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Subtotal.

• In the Type of calculation to perform list, select Count.

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 0.

9. In the Time Periods area, select the My query has a column that contains 
calendar dates option.

10. In the Calendar date column list, select Document Date.

11. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.

12. Click Next to open the next Create KPI page.

13. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.
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14. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

15. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

16. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

17. In the Save to Folder area, select the folder the KPI will be saved in.

18. Click OK to save the KPI and return to the KPI Management page.

Create the Overdue Drop Ship Purchase Orders KPI

Use the following steps to create the Overdue Drop Ship Purchase Orders KPI, 
which displays the total number of overdue drop ship purchase orders.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Overdue Drop Ship Purchase Orders.

• In the Description field, type Number of drop ship purchase orders that 
are overdue.

5. In the Creation Method area, select Use Query and click the Use Existing 
Query button. The Select Query page appears. 

6. Select the Overdue Drop Ship Purchase Orders query, which was created in 
Create the Drop Ship Purchase Orders KPI on page 72.

7. Click Select and Close.

8. In the Data Calculation area, do the following:

• In the Column where data is located field, select Subtotal.

• In the Type of calculation to perform list, select Count.

• In the Format the results as list, select Number.

• In the Number of decimal places field, type 0.
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9. In the Time Periods area, select the My query has a column that contains 
calendar dates option.

10. In the Calendar date column list, select Document Date.

11. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.

12. Click Next to open the next Create KPI page.

13. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

14. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

15. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

16. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

17. In the Save to Folder area, select the folder the KPI will be saved in.

18. Click OK to save the KPI and return to the KPI Management page.
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Create the Drop Ship Purchase Orders Overdue KPI

Use the following steps to create the Drop Ship Purchase Orders Overdue KPI, 
which calculates and displays the value of the total number of overdue drop ship 
purchase orders divided by the total number of drop ship purchase orders.

1. Go to the Site Settings page for the top-level Business Portal web site. 

2. Under Key Performance Indicators, click KPI management. The KPI 
Management page appears. 

3. In the Pick a Task area of the KPI List web part, click Create a new KPI to open 
the Create KPI page.

4. In the Name and Description area, type the following information:

• In the Name field, type Drop Ship Purchase Orders Overdue.

• In the Description field, type Percentage of drop ship purchase orders that 
are overdue.

5. In the Creation Method area, select Use KPI and click the Create KPI Equation 
button. The Create KPI Equation page appears.

6. Type the following equation:

(“Overdue Drop Ship Purchase Orders”/“Drop Ship Purchase Orders”)*100

7. Click OK.

8. In the Data Calculation area, do the following:

• In the Format the results as list, select Percent.

• In the Number of decimal places field, type 2.

9. In the Time periods to calculate and include in this KPI field, select the 
following check boxes:

• In the Calendar > Year folder, select Current Year and Previous Year.

• In the Calendar > Quarter folder, select Current Quarter, Previous Quarter, 
and One Year Ago.

• In the Calendar > Month folder, select Current Month, Previous Month, 
and One Year Ago.

• In the Calendar > Week folder, select Current Week and Previous Week.

• In the Calendar > Day folder, select Current Day and Previous Day.

• In the Fiscal > Year folder, select Current Year and Previous Year.

• In the Fiscal > Fiscal Period folder, select Current Period, Previous Period, 
and One Year Ago.
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10. Click Next to open the next Create KPI page.

11. You can use the fields in the Alert Ranges area to set up critical and warning 
alert ranges. These alert ranges indicate when calculated KPI values do not 
meet specified target values. For more information about defining alert ranges, 
see the Key Performance Indicators documentation.

12. In the Recalculation Rate area, select Daily in the Default Recalculation Rate 
list.

13. In the Related KPIs area, select which KPIs are related to the one you’re 
creating. For more information about related KPIs, see the Key Performance 
Indicators documentation.

14. In the Roles area, select which roles should be able to view this KPI. 

You also must give the selected roles access to the KPI Default Permission using the 
Roles page, so the users within those roles can view the KPIs within the specified web 
parts. See the Business Portal Administrator’s Guide for more information about 
assigning data permissions to roles.

15. In the Save to Folder area, select the folder the KPI will be saved in.

16. Click OK to save the KPI and return to the KPI Management page.
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