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1   Introduction 

Xaml is defined in the Xaml Object Mapping Specification (referred to as '[MS-XAML]' for short). The 
[MS-XAML] specification enables each application that uses Xaml to define its own vocabulary. 
Vocabularies are formally specified using the Xaml Schema Information Set, a data model defined 
by [MS-XAML]. 

This specification defines the Xaml Schema Information Set information items for the Windows 
Presentation Foundation (WPF) Xaml Vocabulary. The information items in the Xaml Schema 
Information Set presented in this specification can be used in conjunction with [MS-XAML] to 

determine whether any particular Xaml instance or XML document is valid WPF Xaml. 

  

http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
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2   Specification Conventions 

The [MS-XAML] specification only defines a data model for the Xaml Schema Information Set. It 
does not prescribe the representation of the information items that constitute a schema. While [MS-
XAML] does introduce a notation with which it defines its intrinsic information items, this 
specification does not use that notation. Instead, a more compact representation is used to 
minimize redundancy. 

The WPF Xaml Vocabulary contains several thousand information items, many of which share much 
in common. The following sections describe the conventions used in this specification, which exploit 

this commonality to reduce the volume of text required to describe each information item, and to 
make it easier to see each item's distinguishing features. 

2.1   Xaml Types 

The [MS-XAML] specification defines a XamlType Information Item. Throughout this specification, 
when a XamlType Information Item is presented, only those values that do not match the default 

value are listed. The following table defines the default values for a XamlType Information Item. 

Property Default Value 

[is default constructible] True 

[is nullable] True 

[text syntax] Null 

[dictionary key property] Null  

[name property] Null  

[xml lang property] Null  

[trim surrounding whitespace] False 

[whitespace significant collection] False 

[is list] False 

[is dictionary] False 

[members] Empty set 

[content property] Null  

[allowed types] Empty set 

[allowed key types] Empty set 

[is xdata] False 

[is name scope] False 

[constructors] Empty set 

[return value type] Null  

http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715


 

30 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

This specification denotes non-default values for the information set items with rows that begin with 
the relevant property name in square brackets. Each Xaml Type definition in this specification 

includes some non-normative information, in order to aid understanding of the type. In order to 
distinguish them, these rows begin with a name in parentheses. 

There is a (usage) row that illustrates the way in which the type is used in XML. If the type cannot 
contain content, a self-closing tag will be displayed, as the following example shows: 

(usage) <DependencyObject /> 

Some types offer a choice of content. The following example indicates that the three fixed string 
values shown are acceptable as content: 

(usage) OnLastWindowClose | OnMainWindowClose | OnExplicitShutdown 

Elements that may contain string content look like the following example. Note that there are 

typically constraints on which strings are valid. The purpose of the (usage) row is only to provide an 
approximate indication of content, rather than a formal description. 

(usage) <PropertyPath> string </PropertyPath> 

Types that can contain an instance of some other type show the name of the type in the usage, as 
shown in the following example: 

(usage) <BeginStoryboard> Storyboard </BeginStoryboard> 

Types that can contain multiple instances of some other type indicate this with an asterisk, as 
shown in the following example: 

(usage) <XmlNamespaceMappingCollection> XmlNamespaceMapping* 

</XmlNamespaceMappingCollection> 

Some types cannot be used directly in a Xaml document. For example, a type might be used as the 
[value type] of a member, but may be marked as [is default constructible] False, and have no [text 
syntax]. A Xaml document might contain types that list such a type in their [types assignable to] 
property, but the type itself cannot be used directly. (This corresponds to the idea of an abstract 
type in some object-oriented programming systems.) Such types have "None" in their Usage row. 

Type definitions also include (description) rows, both for the type and also for the members of that 

type. This is also non-normative. 

The (used by) row is also non-normative. Each (used by) row provides a list of types that use this 
type in some way. For example, it lists types that use this type as the [value type] of a member. 
The (used by) row is provided to make it easier to see how a type is used, and it does not translate 
into a property in the Xaml Schema Information Set. 

Some types that are used as the [value type] of a member, but which are not typically used directly 

as objects have a (types assignable from) row. This is non-normative, and is provided as a guide to 
the role of the type. Note that this list is necessarily not complete, because the set of types from 
which a type is assignable is not closed: anyone is free to define a new Xaml vocabulary which 
defines types that are assignable to types in this specification. 
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2.2   Xaml Type Order 

Xaml types in this specification are ordered in an alphabetical way. The WPF Xaml Vocabulary uses 
the [types assignable to] property in a way that corresponds to inheritance in object-oriented 

programming. On the row above each type name is a list of 'Base' types. On the row below each 
type name are types which directly 'inherit' from that type. 

The following example shows the XamlType Information Items for the Fruit, Apple, and Banana 
types.  

 Fruit 

Fruit 

 Apple Banana  

(usage) Value 

… … 

property N Value 

 

 Fruit> Apple 

Apple 

(usage) Value 

… … 

property N Value 

 

 Fruit> Banana 

Banana (4.5) 

(usage) Value 

… … 

property N Value 

Since this specification models typical object-oriented inheritance, a 'derived' type inherits all 
members from a 'base' type. This is not made explicit. For each type, only additional members are 
listed. The [MS-XAML] specification does not require this inheritance-like style. In the Xaml Schema 
Information Set data model, each type lists its members exhaustively. Therefore, the correct 

interpretation of a type definition in this specification is that the corresponding XamlType 
Information Item's [members] property should include not just the listed members, but also all of 

the [members] of each type listed in its [types assignable to] property. 

The "Banana" type, in the example above, has "(4.5)" listed after it to indicate that this type was 
introduced in this XAML Vocabulary's version 4.5 release. All types or members without a version 
number after it were released in versions previous to that. 

http://go.microsoft.com/fwlink/?LinkId=390715
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XamlMember Information Items have numerous properties, and in this specification, members are 
more similar than they are different. So a notation is used to minimize redundancy. Some 

XamlMember Information Item properties may be omitted. Unless specified otherwise, the default 
values described in the following table apply. 

Property Default Value 

[text syntax] Null 

[is read only] False 

[is static] False 

[is attachable] False 

[target type] Null  

[allowed location] Any 

[is event] False 

[is directive] False 

Members are not defined in distinct sections of this specification - they are listed inside their 
defining type following a row named (properties). This means that the [owner type] member defined 
by [MS-XAML] is never specified explicitly in this specification. The [owner type] is always the type 
in which the member definition appears. Likewise, the [members] property of the defining type is 
never explicitly defined - it always contains all of the members listed for that type. The [name] and 

[value type] are specified on the first line of the property description. This line may be followed by 
non-default values for other properties. The following example shows the XamlType Information 
Item for the Satsuma type, which defines a member named SegmentCount of type Int32. 

 Fruit > Satsuma 

Satsuma 

(usage) <Satsuma /> 

(description) Specifies a small, orange citrus fruit. 

(properties)  

SegmentCount Int32 

(description) The number of segments in this satsuma. 

If all of the XamlMember Information Item properties had been listed in full for this property, it 
would look like the following table. 

Property Value 

[name] SegmentCount 

[owner type] Satsuma 

[value type] Int32 

http://go.microsoft.com/fwlink/?LinkId=390715
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Property Value 

[text syntax] Null 

[is read only] False 

[is static] False 

[is attachable] False 

[target type] Null 

[allowed location] Any 

[is event] False 

As with the type-level (description), the per-member (description) entries in this specification are 

non-normative. 

XamlType Information Item descriptions in this document may contain up to three additional 
member categories: attachable members, event members, and static members. These three 
member categories have slightly different defaults, and are grouped separately in the type 
definitions for clarity. The conventions for these member categories are defined in the following 
sections. 

2.3   Xaml Members where [is attachable] is True 

A type that defines members whose [is attachable] property is True will list them in a section that 
begins with "(attachable properties)". The following FruitBowl type example defines a Children 
member for which the normal defaults apply. This FruitBowl type also defines an attachable member 
named ZIndex for which [is attachable] is True. (The other member defaults still apply for ZIndex.) 

Object > Bowl(T) > FruitBowl 

FruitBowl 

(usage) <FruitBowl>Fruit*</FruitBowl> 

(description) A container of fruit. 

[content property] Children 

(properties)  

Children FruitCollection 

(description) The items of fruit 

(attachable properties)  

FruitBowl.ZIndex Int32 

(description) Indicates how deeply buried within the fruit bowl a piece of fruit is. 

[target type] Fruit 

The name for an attachable member is specified as TypeName.MemberName. This is a syntactical 
convention to make it clear that this is an attachable property, and to illustrate how the property will 
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look in a Xaml document. The [name] property of the XamlMember Information Item will only 
contain the MemberName part (the part after the period). 

2.4   Xaml Types where [is generic] is True 

A type whose [is generic] property is Truue will be represented with a (T) notation following the 
[type name]. "Bowl(Fruit)" would be describing a generic Bowl type, with Fruit as the type 
argument. 

Object > Bowl(T) 

Bowl(T) 

FruitBowl  

(usage) <Bowl x:TypeArguments="T" > 

(description) A container for different types of objects. 

[is collection] True 

2.5   Xaml Members where [is event] is True 

A type that defines members whose [is event] property is True will list them in a section that begins 

with "(events)". For members in this section, the default value for [value type] is the x:XamlEvent 
type defined in Section 5 "Intrinsic Schema Information Items" of [MS-XAML]. (The other defaults 
still apply.) 

2.6   Xaml Members where [is static] is True 

A type that defines members whose [is static] property is True will list them in a section that begins 
with "(static properties)". 

2.7   Constructors 

Types with a non-empty [constructors] property use a convention similar to that for members. This 
example includes a constructor: 

4.97.4    BruleeToppingExtension 

(usage) {BruleeToppingExtension} 

(description) Defines the way in which the topping on a brulée-style dessert is 

prepared. 

[types assignable to] Brulee MarkupExtension Object 

(used by) FruitBrulee CremeBrulee 

[return value type] BruleeTopping 

[constructors]   

          (2 parameters)   

                         thickness Double 

%5bMS-XAML-2012%5d.pdf
http://go.microsoft.com/fwlink/?LinkId=390714
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4.97.4    BruleeToppingExtension 

                                   (description) The thickness of the topping in 1/96th of an inch. 

                         burnFactor Double 

                                   (description) The extent to which the sugar is burnt: 0 for raw sugar, 1 for 

carbon. 

Unlike members, which are identified by names, a constructor for a type is distinguished only by the 
number of parameters it has. This type has a single constructor that takes two parameters. This is 
interpreted as a Constructor Information Item, whose [arguments] contains one entry per 

parameter. The [arguments] list contains just XamlType Information Items - both the Double type in 
this case. Note that the type is the only formal part of the constructor argument - the name and 
description are only provided for informational purposes. 
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3   The WPF Xaml Schema Information Set 

The WPF Xaml Schema Information Item is a Xaml Schema Information Item (as defined in Section 
3 "Xaml Schema Information Set" of [MS-XAML]). Its properties are defined in the following table. 

Property Value 

[target 

namespace] 

"http://schemas.microsoft.com/winfx/2006/xaml/presentation" 

[types] All of the XamlType Information Items defined in the "WPF XamlType Information 

Items" section of this specification.  

[assignable 

types] 

All of the XamlType Information Items defined in the "WPF XamlType Information 

Items for Assignable Types" section of this specification. 

[directives] The XamlMember Information Items defined in this specification for which the [is 

directive] property is True. 

[compatible 

with schemas] 

Empty 

A WPF Xaml instance MUST be well-formed and valid with respect to this schema, using the rules for 
'well-formed' and 'valid' defined in [MS-XAML]. 

An XML document that is a WPF Xaml document MUST yield a WPF Xaml instance when the 
processing rules in Section 6 "Creating a Xaml Information Set from XML" are applied using this 
schema. 

%5bMS-XAML-2012%5d.pdf
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
%5bMS-XAML-2012%5d.pdf
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4   WPF XamlType Information Items 

4.1   AccessText 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > AccessText, 
IInputElement 

(usage) <AccessText>x:String</AccessText> 

(description) Specifies with an underscore the character that is used as the access key. 

[content property] Text 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) The Brush that fills the content area. 

BaselineOffset x:Double 

(description) A value that adjusts the baseline offset position of text in an AccessText 

element. 

FontFamily FontFamily 

(description) The font family to use with the AccessText element. 

FontSize x:Double 

(description) The font size to use with the AccessText element. 

[text syntax] FontSizeSyntax 

FontStretch FontStretch 

(description) A FontStretch property that selects a normal, condensed, or expanded font from 

a FontFamily. 

FontStyle FontStyle 

(description) The font style to use with the AccessText element. 

FontWeight FontWeight 

(description) The font weight to use with the AccessText element. 

Foreground Brush 

(description) The Brush that draws the text content of the element. 

LineHeight x:Double 

(description) The height of each line box. 
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(usage) <AccessText>x:String</AccessText> 

[text syntax] LengthSyntax 

LineStackingStrategy LineStackingStrategy 

(description) How the LineHeight property is enforced. 

Text x:String 

(description) The text that is displayed by the AccessText element. 

TextAlignment TextAlignment 

(description) The horizontal alignment of the content. 

TextDecorations TextDecorationCollection 

(description) The decorations that are added to the text of an AccessText element. 

TextEffects TextEffectCollection 

(description) The effects that are added to the text of an AccessText element. 

TextTrimming TextTrimming 

(description) How the textual content of an AccessText element is clipped if it overflows the 

line box. 

TextWrapping TextWrapping 

(description) Whether the textual content of an AccessText element is wrapped if it overflows 

the line box. 

4.2   AdornedElementPlaceholder 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > 
AdornedElementPlaceholder, IInputElement 

(usage) <AdornedElementPlaceholder>UIElement</AdornedElementPlaceholder> 

(description) Represents the element used in a ControlTemplate to specify where a decorated control 

is placed relative to other elements in the ControlTemplate. 

[content 

property] 

Child 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

Child UIElement 

(description) The single child object of this AdornedElementPlaceholder object. 
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4.3   AdornerDecorator 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Decorator > 
AdornerDecorator, IInputElement 

(usage) <AdornerDecorator>UIElement</AdornerDecorator> 

(description) Provides an AdornerLayer for the child elements in the visual tree. 

[content property] Child 

[name property] Name 

[xml lang property] Language 

(properties)  

Child UIElement 

(description) The single child of an AdornerDecorator. 

4.4   AffineTransform3D 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > Transform3D > 
AffineTransform3D 

RotateTransform3D ScaleTransform3D TranslateTransform3D 

(usage) None. 

(description) Base type from which all concrete affine 3-D transforms--translations, rotations, 

and scale transformations--derive. 

[is default 

constructible] 

false 

4.5   AlignmentX 

x:Object > AlignmentX 

(usage) Left| Center| Right 

(description) Describes how content is positioned horizontally in a container. 

(used by) TileBrush 

[is nullable] false 

[text syntax] AlignmentXSyntax 

4.6   AlignmentY 

x:Object > AlignmentY 

(usage) Top| Center| Bottom 
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(usage) Top| Center| Bottom 

(description) Describes how content is positioned vertically in a container. 

(used by) TileBrush 

[is nullable] false 

[text syntax] AlignmentYSyntax 

4.7   AlternationConverter 

x:Object > AlternationConverter, IValueConverter 

(usage) <AlternationConverter>x:Object*</AlternationConverter> 

(description) Converts an integer to and from an object by applying the integer as an index to a 

list of objects. 

[content 

property] 

Values 

(properties)  

Values IList 

(description) A list of objects that the AlternationConverter returns when an integer is passed to 

the CultureInfo) method. 

[read only] true 

4.8   AmbientLight 

x:Object > DependencyObject > Freezable > Animatable > Model3D > Light > AmbientLight 

(usage) <AmbientLight /> 

(description) Light object that applies light to objects uniformly, regardless of their shape. 

4.9   AnchoredBlock 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > AnchoredBlock, IInputElement 

Figure Floater 

(usage) None. 

(description) A base type that provides a base for Inline elements that are used to anchor 

Block elements to flow content. 

[is default 

constructible] 

false 

[content property] Blocks 
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Figure Floater 

[name property] Name 

[xml lang property] Language 

(properties)  

Blocks BlockCollection 

(description) A BlockCollection containing the top-level Block elements that comprise the 

contents of the element. 

[read only] true 

BorderBrush Brush 

(description) A Brush to use when painting the element's border. 

BorderThickness Thickness 

(description) The border thickness for the element. 

LineHeight x:Double 

(description) The height of each line of content. 

[text syntax] LengthSyntax 

LineStackingStrategy LineStackingStrategy 

(description) The mechanism by which a line box is determined for each line of text within 

the text element. 

Margin Thickness 

(description) The margin thickness for the element. 

Padding Thickness 

(description) The padding thickness for the element. 

TextAlignment TextAlignment 

(description) A value that indicates the horizontal alignment of text content. 

4.10   Animatable 

x:Object > DependencyObject > Freezable > Animatable 

Brush CacheMode Camera DashStyle Drawing DrawingCollection Effect GeneralTransform 

GeneralTransform3D GeneralTransform3DCollection GeneralTransformCollection Geometry 

Geometry3D GeometryCollection GradientStop GradientStopCollection GuidelineSet ImageSource 

Material MaterialCollection MediaPlayer Model3D Model3DCollection PathFigure 

PathFigureCollection PathSegment PathSegmentCollection Pen PixelShader Rotation3D 

TextDecoration TextDecorationCollection TextEffect TextEffectCollection Timeline 

TimelineCollection Transform3DCollection TransformCollection 

(usage) None. 
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Brush CacheMode Camera DashStyle Drawing DrawingCollection Effect GeneralTransform 

GeneralTransform3D GeneralTransform3DCollection GeneralTransformCollection Geometry 

Geometry3D GeometryCollection GradientStop GradientStopCollection GuidelineSet ImageSource 

Material MaterialCollection MediaPlayer Model3D Model3DCollection PathFigure 

PathFigureCollection PathSegment PathSegmentCollection Pen PixelShader Rotation3D 

TextDecoration TextDecorationCollection TextEffect TextEffectCollection Timeline 

TimelineCollection Transform3DCollection TransformCollection 

(description) A base type that provides animation support. 

[is default constructible] false 

4.11   AnimationTimeline 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline 

BooleanAnimationBase ByteAnimationBase CharAnimationBase ColorAnimationBase 

DecimalAnimationBase DoubleAnimationBase Int16AnimationBase Int32AnimationBase 

Int64AnimationBase MatrixAnimationBase ObjectAnimationBase Point3DAnimationBase 

PointAnimationBase QuaternionAnimationBase RectAnimationBase Rotation3DAnimationBase 

SingleAnimationBase SizeAnimationBase StringAnimationBase ThicknessAnimationBase 

Vector3DAnimationBase VectorAnimationBase 

(usage) None. 

(description) Defines a segment of time over which output values are produced. These 

values are used to animate a target property. 

[is default constructible] false 

[name property] Name 

4.12   Application 

x:Object > Application 

(usage) <Application /> 

(description) Encapsulates an application. 

(properties)  

MainWindow Window 

(description) The main window of the application. 

Properties IDictionary 

(description) A collection of application-scope properties. 

[read only] true 

Resources ResourceDictionary 

(description) A collection of application-scope resources, such as styles and 

brushes. 
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(usage) <Application /> 

ShutdownMode ShutdownMode 

(description) The condition that causes the Shutdown method to be called. 

StartupUri x:Uri 

(description) A UI that is automatically shown when an application starts. 

(attachable properties)  

Application.Cookie x:String 

(description)  

[target type] x:Uri 

(static properties)  

Current Application 

(description) The Application object for the current AppDomain. 

(events)  

Activated Occurs when an application becomes the foreground application. 

Deactivated Occurs when an application stops being the foreground application. 

DispatcherUnhandledException Occurs when an exception is thrown by an application but not 

handled. 

Exit Occurs just before an application shuts down, and cannot be 

canceled. 

FragmentNavigation Occurs when a navigator in the application begins navigation to a 

content fragment, Navigation occurs immediately if the desired 

fragment is in the current content, or after the source XAML content 

has been loaded if the desired fragment is in different content. 

LoadCompleted Occurs when content that was navigated to by a navigator in the 

application has been loaded, parsed, and has begun rendering. 

Navigated Occurs when the content that is being navigated to by a navigator in 

the application has been found, although it may not have completed 

loading. 

Navigating Occurs when a new navigation is requested by a navigator in the 

application. 

NavigationFailed Occurs when an error occurs while a navigator in the application is 

navigating to the requested content. 

NavigationProgress Occurs periodically during a download that is being managed by a 

navigator in the application to provide navigation progress 

information. 

NavigationStopped Occurs when the StopLoading method of a navigator in the 

application is called, or when a new navigation is requested by a 
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(usage) <Application /> 

navigator while a current navigation is in progress. 

SessionEnding Occurs when the user ends the Windows session by logging off or 

shutting down the operating system. 

Startup Occurs when the Run method of the Application object is called. 

4.13   ApplicationCommands 

x:Object > ApplicationCommands 

(usage) {x:Static ApplicationCommands.StaticPropertyName} 

(description) Provides a standard set of application related commands. 

[is default constructible] false 

(static properties)  

CancelPrint RoutedUICommand 

(description) The value that represents the Cancel Print command. 

Close RoutedUICommand 

(description) The value that represents the Close command. 

ContextMenu RoutedUICommand 

(description) The value that represents the Context Menu command. 

Copy RoutedUICommand 

(description) The value that represents the Copy command. 

CorrectionList RoutedUICommand 

(description) The value that represents the Correction List command. 

Cut RoutedUICommand 

(description) The value that represents the Cut command. 

Delete RoutedUICommand 

(description) The value that represents the Delete command. 

Find RoutedUICommand 

(description) The value that represents the Find command. 

Help RoutedUICommand 

(description) The value that represents the Help command. 

New RoutedUICommand 
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(usage) {x:Static ApplicationCommands.StaticPropertyName} 

(description) The value that represents the New command. 

NotACommand RoutedUICommand 

(description) Represents a command which is always ignored. 

Open RoutedUICommand 

(description) The value that represents the Open command. 

Paste RoutedUICommand 

(description) The value that represents the Paste command. 

Print RoutedUICommand 

(description) The value that represents the Print command. 

PrintPreview RoutedUICommand 

(description) The value that represents the Print Preview command. 

Properties RoutedUICommand 

(description) The value that represents the Properties command. 

Redo RoutedUICommand 

(description) The value that represents the Redo command. 

Replace RoutedUICommand 

(description) The value that represents the Replace command. 

Save RoutedUICommand 

(description) The value that represents the Save command. 

SaveAs RoutedUICommand 

(description) The value that represents the Save As command. 

SelectAll RoutedUICommand 

(description) The value that represents the Select All command. 

Stop RoutedUICommand 

(description) The value that represents the Stop command. 

Undo RoutedUICommand 

(description) The value that represents the Undo command. 

4.14   ApplicationGesture 

x:Object > ApplicationGesture 
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(usage) AllGestures| ArrowDown| ArrowLeft| ArrowRight| ArrowUp| Check| 

ChevronDown| ChevronLeft| ChevronRight... 

(description) Specifies the available application-specific . 

[is nullable] false 

[text 

syntax] 

ApplicationGestureSyntax 

4.15   ArcSegment 

x:Object > DependencyObject > Freezable > Animatable > PathSegment > ArcSegment 

(usage) <ArcSegment /> 

(description) Represents an elliptical arc between two points. 

(properties)  

IsLargeArc x:Boolean 

(description) A value that indicates whether the arc should be greater than 180 degrees. 

Point Point 

(description) The endpoint of the elliptical arc. 

RotationAngle x:Double 

(description) The amount (in degrees) by which the ellipse is rotated about the x-axis. 

Size Size 

(description) The x- and y-radius of the arc as a Size structure. 

SweepDirection SweepDirection 

(description) A value that specifies whether the arc is drawn in the Clockwise or Counterclockwise 

direction. 

4.16   AutomationProperties 

x:Object > AutomationProperties 

(usage) None. 

(description) Provides a way to manipulate the value of the 

associated properties of the AutomationPeer element 

instance. 

[is default constructible] false 

(attachable properties)  

AutomationProperties.AcceleratorKey x:String 
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(usage) None. 

(description) The accelerator key for the specified element. 

[target type] DependencyObject 

AutomationProperties.AccessKey x:String 

(description) The access key for the specified element. 

[target type] DependencyObject 

AutomationProperties.AutomationId x:String 

(description) The string that uniquely identifies the specified 

element. 

[target type] DependencyObject 

AutomationProperties.HelpText x:String 

(description) The help text for the specified element. The help text 

generally is the same text that is provided in the tooltip 

for the control. 

[target type] DependencyObject 

AutomationProperties.IsColumnHeader x:Boolean 

(description) A value indicating whether the specified element is a 

column header. 

[target type] DependencyObject 

AutomationProperties.IsOffscreenBehavior IsOffscreenBehavior 

(description)  

[target type] DependencyObject 

AutomationProperties.IsRequiredForForm x:Boolean 

(description) A value that indicates whether the specified element is 

required to be filled out on a form. 

[target type] DependencyObject 

AutomationProperties.IsRowHeader x:Boolean 

(description) A value indicating whether the specified element is a 

row header. 

[target type] DependencyObject 

AutomationProperties.ItemStatus x:String 

(description) A description of the status of an item within an 

element. 

[target type] DependencyObject 
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(usage) None. 

AutomationProperties.ItemType x:String 

(description) A description of the type of the specified element. 

[target type] DependencyObject 

AutomationProperties.LabeledBy UIElement 

(description) The element that contains the text label for the 

specified element. 

[target type] DependencyObject 

AutomationProperties.Name x:String 

(description) The name of the element. 

[target type] DependencyObject 

4.17   AutoToolTipPlacement 

x:Object > AutoToolTipPlacement 

(usage) None| TopLeft| BottomRight 

(description) Describes the means by which the automatic ToolTip is positioned on a Slider control. 

(used by) Slider 

[is nullable] false 

[text syntax] AutoToolTipPlacementSyntax 

4.18   AxisAngleRotation3D 

x:Object > DependencyObject > Freezable > Animatable > Rotation3D > AxisAngleRotation3D 

(usage) <AxisAngleRotation3D /> 

(description) Represents a 3-D rotation of a specified angle about a specified axis. 

(properties)  

Angle x:Double 

(description) The angle of a 3-D rotation, in degrees. 

Axis Vector3D 

(description) The axis of a 3-D rotation. 

4.19   BackEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > BackEase, IEasingFunction 
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(usage) <BackEase /> 

(description) Represents an easing function that retracts the motion of an animation slightly before it 

begins to animate in the path indicated. 

(properties)  

Amplitude x:Double 

(description) The amplitude of retraction associated with a BackEase animation. 

4.20   BaselineAlignment 

x:Object > BaselineAlignment 

(usage) Top| Center| Bottom| Baseline| TextTop| TextBottom| Subscript| Superscript 

(description) Describes how the baseline for a text-based element is positioned on the vertical axis, 

relative to the established baseline for text. 

(used by) Inline 

[is nullable] false 

[text 

syntax] 

BaselineAlignmentSyntax 

4.21   BaseValueSource 

x:Object > BaseValueSource 

(usage) Unknown| Default| Inherited| DefaultStyle| DefaultStyleTrigger| Style| 

TemplateTrigger| StyleTrigger| ImplicitStyleReference... 

(description) Identifies the property system source of a particular property value. 

[is nullable] false 

[text 

syntax] 

BaseValueSourceSyntax 

4.22   BeginStoryboard 

x:Object > DependencyObject > TriggerAction > BeginStoryboard 

(usage) <BeginStoryboard>Storyboard</BeginStoryboard> 

(description) A trigger action that begins a Storyboard and distributes its animations to their 

targeted objects and properties. 

[content 

property] 

Storyboard 

[name property] Name 

(properties)  
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(usage) <BeginStoryboard>Storyboard</BeginStoryboard> 

HandoffBehavior HandoffBehavior 

(description) The proper hand-off behavior to start an animation clock in this storyboard 

Name x:String 

(description) The name of the BeginStoryboard object. By naming the BeginStoryboard object, 

the Storyboard can be controlled after it is started. 

Storyboard Storyboard 

(description) The Storyboard that this BeginStoryboard starts. 

4.23   BezierSegment 

x:Object > DependencyObject > Freezable > Animatable > PathSegment > BezierSegment 

(usage) <BezierSegment /> 

(description) Represents a cubic Bezier curve drawn between two points. 

(properties)  

Point1 Point 

(description) The first control point of the curve. 

Point2 Point 

(description) The second control point of the curve. 

Point3 Point 

(description) The end point of the curve. 

4.24   Binding 

x:Object > x:MarkupExtension > BindingBase > Binding 

(usage) {Binding } | <Binding /> 

(description) Provides high-level access to the definition of a binding, which 

connects the properties of binding target objects, and any data 

source (for example, a database, an XML file, or any object that 

contains data). 

[return value type] x:Object 

[constructors]  

(1 parameter)  

path x:String 

(description) The initial Path for the binding. 
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(usage) {Binding } | <Binding /> 

(properties)  

AsyncState x:Object 

(description) Opaque data passed to the asynchronous data dispatcher. 

BindsDirectlyToSource x:Boolean 

(description) A value that indicates whether to evaluate the Path relative to the 

data item or the DataSourceProvider object. 

Converter IValueConverter 

(description) The converter to use. 

ConverterCulture CultureInfo 

(description) The culture in which to evaluate the converter. 

[text syntax] CultureInfoIetfLanguageTagSyntax 

ConverterParameter x:Object 

(description) The parameter to pass to the Converter. 

ElementName x:String 

(description) The name of the element to use as the binding source object. 

IsAsync x:Boolean 

(description) A value that indicates whether the Binding should get and set 

values asynchronously. 

Mode BindingMode 

(description) A value that indicates the direction of the data flow in the binding. 

NotifyOnSourceUpdated x:Boolean 

(description) A value that indicates whether to raise the SourceUpdated event 

when a value is transferred from the binding target to the binding 

source. 

NotifyOnTargetUpdated x:Boolean 

(description) A value that indicates whether to raise the TargetUpdated event 

when a value is transferred from the binding source to the binding 

target. 

NotifyOnValidationError x:Boolean 

(description) A value that indicates whether to raise the Error attached event on 

the bound object. 

Path PropertyPath 

(description) The path to the binding source property. 



 

52 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) {Binding } | <Binding /> 

RelativeSource RelativeSource 

(description) The binding source by specifying its location relative to the position 

of the binding target. 

Source x:Object 

(description) The object to use as the binding source. 

UpdateSourceTrigger UpdateSourceTrigger 

(description) A value that determines the timing of binding source updates. 

ValidatesOnDataErrors x:Boolean 

(description) A value that indicates whether to include the 

DataErrorValidationRule. 

ValidatesOnExceptions x:Boolean 

(description) A value that indicates whether to include the 

ExceptionValidationRule. 

ValidatesOnNotifyDataErrors 

(4.5) 

x:Boolean 

(description) A value that indicates whether to include the 

NotifyDataErrorValidationRule. 

ValidationRules Collection(ValidationRule) 

(description) A collection of rules that check the validity of the user input. 

[read only] true 

XPath x:String 

(description) An XPath query that returns the value on the XML binding source to 

use. 

(attachable properties)  

Binding.XmlNamespaceManager XmlNamespaceManager 

(description) The XmlNamespaceManager used to perform namespace-aware 

XPath queries in XML bindings. 

[target type] DependencyObject 

(attachable events)  

Binding.SourceUpdated Occurs when a value is transferred from the binding target to the 

binding source, but only for bindings with the 

NotifyOnSourceUpdated value set to true. 

Binding.TargetUpdated Occurs when a value is transferred from the binding source to the 

binding target, but only for bindings with the 

NotifyOnTargetUpdated value set to true. 
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4.25   BindingBase 

x:Object > x:MarkupExtension > BindingBase 

Binding MultiBinding PriorityBinding 

(usage) None. 

(description) A base type for binding types. 

(used by) Condition DataGridBoundColumn DataGridColumn DataGridComboBoxColumn 

DataGridHyperlinkColumn DataTrigger GridViewColumn 

HierarchicalDataTemplate MultiBinding PriorityBinding 

[is default 

constructible] 

false 

[return value type] x:Object 

(properties)  

BindingGroupName x:String 

(description) The name of the BindingGroup to which this binding belongs. 

Delay (4.5) x:Int32 

(description) The amount of time, in milliseconds, to wait before updating the binding source 

after the value on the target changes. 

FallbackValue x:Object 

(description) The value to use when the binding is unable to return a value. 

StringFormat x:String 

(description) A string that specifies how to format the binding if it displays the bound value 

as a string. 

TargetNullValue x:Object 

(description) The value that is used in the target when the value of the source is null. 

4.26   BindingGroup 

x:Object > DependencyObject > BindingGroup 

(usage) <BindingGroup /> 

(description) Contains a collection of bindings and ValidationRule objects that are 

used to validate an object. 

(used by) FrameworkContentElement FrameworkElement 

HierarchicalDataTemplate ItemsControl 

(properties)  

Items IList 
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(usage) <BindingGroup /> 

(description) The sources that are used by the Binding objects in the BindingGroup. 

[read only] true 

Name x:String 

(description) The name that identifies the BindingGroup, which can be used to 

include and exclude Binding objects in the BindingGroup. 

NotifyOnValidationError x:Boolean 

(description) Whether the Error event occurs when the state of a ValidationRule 

changes. 

SharesProposedValues x:Boolean 

(description) A value that indicates whether the BindingGroup reuses target values 

that have not been committed to the source. 

ValidatesOnNotifyDataError 

(4.5) 

x:Boolean 

(description) A value that indicates whether to include the 

NotifyDataErrorValidationRule. 

ValidationRules Collection(ValidationRule) 

(description) A collection of ValidationRule objects that validate the source objects 

in the BindingGroup. 

[read only] true 

4.27   BindingMode 

x:Object > BindingMode 

(usage) TwoWay| OneWay| OneTime| OneWayToSource| Default 

(description) Describes the direction of the data flow in a binding. 

(used by) Binding MultiBinding 

[is nullable] false 

[text syntax] BindingModeSyntax 

4.28   BindingOperations 

x:Object > BindingOperations 

(usage) {x:Static BindingOperations.StaticPropertyName} 

(description) Provides static methods to manipulate bindings, including Binding, 

MultiBinding, and PriorityBinding objects. 
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(usage) {x:Static BindingOperations.StaticPropertyName} 

[is default 

constructible] 

false 

(static properties)  

DisconnectedSource 

(4.5) 

x:Object 

(description) An object that replaces the DataContext when an item container is removed 

from the visual tree. 

4.29   BindingStatus 

x:Object > BindingStatus 

(usage) Unattached| Inactive| Active| Detached| AsyncRequestPending| PathError| 

UpdateTargetError| UpdateSourceError 

(description) Describes the status of a binding. 

[is nullable] false 

[text 

syntax] 

BindingStatusSyntax 

4.30   BitmapCache 

x:Object > DependencyObject > Freezable > Animatable > CacheMode > BitmapCache 

(usage) <BitmapCache> string </BitmapCache> 

(description) Creates and caches a bitmap representation of a UIElement. 

(used by) BitmapCacheBrush 

[text syntax] CacheModeSyntax 

(properties)  

EnableClearType x:Boolean 

(description) A value that indicates whether the bitmap is rendered with ClearType activated. 

RenderAtScale x:Double 

(description) A value that indicates the scale that is applied to the bitmap. 

SnapsToDevicePixels x:Boolean 

(description) A value that indicates whether the bitmap is rendered with pixel snapping. 

4.31   BitmapCacheBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > BitmapCacheBrush 
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(usage) <BitmapCacheBrush> string </BitmapCacheBrush> 

(description) Paints an area with cached content. 

[text syntax] BrushSyntax 

(properties)  

AutoLayoutContent x:Boolean 

(description) A value that indicates whether layout is applied to the contents of this brush. 

BitmapCache BitmapCache 

(description) A CacheMode that represents cached content. 

Target Visual 

(description) The target visual to cache. 

4.32   BitmapCacheOption 

x:Object > BitmapCacheOption 

(usage) Default| OnDemand| OnLoad| None 

(description) Specifies how a bitmap image takes advantage of memory caching. 

(used by) BitmapImage 

[is nullable] false 

[text syntax] BitmapCacheOptionSyntax 

4.33   BitmapCreateOptions 

x:Object > BitmapCreateOptions 

(usage) None| PreservePixelFormat| DelayCreation| IgnoreColorProfile| 

IgnoreImageCache 

(description) Specifies initialization options for bitmap images. 

(used by) BitmapImage 

[is nullable] false 

[text syntax] BitmapCreateOptionsSyntax 

4.34   BitmapEncoder 

x:Object > BitmapEncoder 

BmpBitmapEncoder GifBitmapEncoder JpegBitmapEncoder PngBitmapEncoder TiffBitmapEncoder 

WmpBitmapEncoder 
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BmpBitmapEncoder GifBitmapEncoder JpegBitmapEncoder PngBitmapEncoder TiffBitmapEncoder 

WmpBitmapEncoder 

(usage) None. 

(description) Encodes a collection of BitmapFrame objects to an image stream. 

[is default constructible] false 

(properties)  

ColorContexts ReadOnlyCollection(ColorContext) 

(description) A value that represents the color profile that is associated with this 

encoder. 

Frames IList(BitmapFrame) 

(description) The individual frames within an image. 

Preview BitmapSource 

(description) A BitmapSource that represents the global preview of a bitmap, if there is 

one. 

Thumbnail BitmapSource 

(description) A BitmapSource that represents the global embedded thumbnail. 

4.35   BitmapFrame 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 
BitmapFrame 

(usage) <BitmapFrame> string </BitmapFrame> 

(description) Represents image data returned by a decoder and accepted by encoders. 

(used by) BitmapEncoder 

[is default constructible] false 

[text syntax] x:Uri, from [MS-XAML] 

(properties)  

BaseUri x:Uri 

(description) A value that represents the base Uri of the current context. 

4.36   BitmapImage 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 
BitmapImage 

(usage) <BitmapImage> string </BitmapImage> 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) <BitmapImage> string </BitmapImage> 

(description) Provides a specialized BitmapSource that is optimized for loading images using 

XAML. 

[text syntax] x:Uri, from [MS-XAML] 

(properties)  

BaseUri x:Uri 

(description) A value that represents the base Uri of the current BitmapImage context. 

CacheOption BitmapCacheOption 

(description) The BitmapCacheOption to use for this instance of BitmapImage. 

CreateOptions BitmapCreateOptions 

(description) The BitmapCreateOptions for a BitmapImage. 

DecodePixelHeight x:Int32 

(description) The height, in pixels, that the image is decoded to. 

DecodePixelWidth x:Int32 

(description) The width, in pixels, that the image is decoded to. 

Rotation Rotation 

(description) The angle that this BitmapImage is rotated to. 

SourceRect Int32Rect 

(description) The rectangle that is used as the source of the BitmapImage. 

UriCachePolicy RequestCachePolicy 

(description) A value that represents the caching policy for images that come from an HTTP 

source. 

[text syntax] RequestCachePolicySyntax 

UriSource x:Uri 

(description) The Uri source of the BitmapImage. 

4.37   BitmapScalingMode 

x:Object > BitmapScalingMode 

(usage) Unspecified| LowQuality| HighQuality| Linear| Fant| NearestNeighbor 

(description) Specifies which technique is used to scale bitmap images. 

(used by) RenderOptions 

[is nullable] false 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) Unspecified| LowQuality| HighQuality| Linear| Fant| NearestNeighbor 

[text syntax] BitmapScalingModeSyntax 

4.38   BitmapSource 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource 

BitmapFrame BitmapImage CachedBitmap ColorConvertedBitmap CroppedBitmap 

FormatConvertedBitmap RenderTargetBitmap TransformedBitmap WriteableBitmap 

(usage) <BitmapSource> string </BitmapSource> 

(description) Represents a single, constant set of pixels at a certain size and 

resolution. 

(used by) BitmapEncoder ColorConvertedBitmap CroppedBitmap 

FormatConvertedBitmap TransformedBitmap 

[is default constructible] false 

[text syntax] x:Uri, from [MS-XAML] 

(events)  

DecodeFailed Occurs when the image fails to load, due to a corrupt image header. 

DownloadCompleted Occurs when the bitmap content has been completely downloaded. 

DownloadFailed Occurs when the bitmap content failed to download. 

DownloadProgress Occurs when the download progress of the bitmap content has changed. 

4.39   Block 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Block, IInputElement 

BlockUIContainer List Paragraph Section Table 

(usage) None. 

(description) A base type that provides a base for all block-level flow content 

elements. 

(used by) BlockCollection 

[is default constructible] false 

[name property] Name 

[xml lang property] Language 

(properties)  

BorderBrush Brush 

http://go.microsoft.com/fwlink/?LinkId=390715
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BlockUIContainer List Paragraph Section Table 

(description) A Brush to use when painting the element's border. 

BorderThickness Thickness 

(description) The border thickness for the element. 

BreakColumnBefore x:Boolean 

(description) A value that indicates whether to automatically insert a column-break 

before this element in cases where the element participates in a 

column-based presentation. 

BreakPageBefore x:Boolean 

(description) A value that indicates whether to automatically insert a page-break 

before this element. 

ClearFloaters WrapDirection 

(description) The direction in which any Floater elements contained by a Block 

element should be repositioned. 

FlowDirection FlowDirection 

(description) The relative direction for flow of content within a Block element. 

IsHyphenationEnabled x:Boolean 

(description) A value that indicates whether automatic hyphenation of words is 

enabled or disabled. 

LineHeight x:Double 

(description) The height of each line of content. 

[text syntax] LengthSyntax 

LineStackingStrategy LineStackingStrategy 

(description) How a line box is determined for each line of text within the block-level 

flow content element. 

Margin Thickness 

(description) The margin thickness for the element. 

Padding Thickness 

(description) The padding thickness for the element. 

SiblingBlocks BlockCollection 

(description) A collection of Block elements that are siblings to the current Block 

element. 

[read only] true 

TextAlignment TextAlignment 
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BlockUIContainer List Paragraph Section Table 

(description) The horizontal alignment of text content. 

(attachable properties)  

Block.IsHyphenationEnabled x:Boolean 

(description) A value that indicates whether automatic hyphenation of words is 

enabled or disabled. 

[target type] DependencyObject 

Block.LineHeight x:Double 

(description) The height of each line of content. 

[target type] DependencyObject 

[text syntax] LengthSyntax 

Block.LineStackingStrategy LineStackingStrategy 

(description) How a line box is determined for each line of text within the block-level 

flow content element. 

[target type] DependencyObject 

Block.TextAlignment TextAlignment 

(description) The horizontal alignment of text content. 

[target type] DependencyObject 

4.40   BlockCollection 

x:Object > TextElementCollection(Block) > BlockCollection 

(usage) None. 

(description) Represents a collection of Block elements. BlockCollection defines the allowable 

child content of the FlowDocument, Section, ListItem, TableCell, Floater, and 

Figure elements. 

(used by) AnchoredBlock Block FlowDocument ListItem Section TableCell 

[is default 

constructible] 

false 

[is list] true 

[allowed types] Block 

4.41   BlockUIContainer 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 

Block > BlockUIContainer, IInputElement 
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(usage) <BlockUIContainer>UIElement</BlockUIContainer> 

(description) A block-level flow content element which enables UIElement elements (i.e. a Button) 

to be embedded (hosted) in flow content. 

[content 

property] 

Child 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

Child UIElement 

(description) The UIElement hosted by the BlockUIContainer. 

4.42   BlurEffect 

x:Object > DependencyObject > Freezable > Animatable > Effect > BlurEffect 

(usage) <BlurEffect /> 

(description) A bitmap effect that blurs the target texture. 

(properties)  

KernelType KernelType 

(description) A value representing the curve that is used to calculate the blur. 

Radius x:Double 

(description) A value that indicates the radius of the blur effect's curve. 

RenderingBias RenderingBias 

(description) A value that indicates whether the system renders an effect with emphasis on speed or 

quality. 

4.43   BmpBitmapEncoder 

x:Object > BitmapEncoder > BmpBitmapEncoder 

(usage) <BmpBitmapEncoder /> 

(description) Defines an encoder that is used to encode bitmap (BMP) format images. 

4.44   Bold 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > Span > Bold, IInputElement 
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(usage) <Bold>[Inline|UIElement|x:String]*</Bold> 

(description) An inline-level flow content element which causes content to appear with a bold 

font weight. 

[content 

property] 

Inlines 

[name property] Name 

[xml lang 

property] 

Language 

4.45   BooleanAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
BooleanAnimationBase 

BooleanAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Boolean value. 

[is default constructible] false 

[name property] Name 

4.46   BooleanAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
BooleanAnimationBase > BooleanAnimationUsingKeyFrames 

(usage) <BooleanAnimationUsingKeyFrames>BooleanKeyFrame*</BooleanAnimationUsingKeyFrame

s> 

(description

) 

Animates the value of a property that takes a Boolean along a set of KeyFrames over a 

specified Duration. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

KeyFrames BooleanKeyFrameCollection 

(description

) 

The collection of BooleanKeyFrame objects that define the animation. 

4.47   BooleanKeyFrame 

x:Object > DependencyObject > Freezable > BooleanKeyFrame 
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DiscreteBooleanKeyFrame 

(usage) None. 

(description) A base type that defines a segment with its own target value and interpolation 

technique for a BooleanAnimationUsingKeyFrames. 

(used by) BooleanKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached 

Value x:Boolean 

(description) The key frame's target value. 

4.48   BooleanKeyFrameCollection 

x:Object > DependencyObject > Freezable > BooleanKeyFrameCollection 

(usage) <BooleanKeyFrameCollection>BooleanKeyFrame*</BooleanKeyFrameCollection> 

(description) Represents a collection of BooleanKeyFrame objects. 

(used by) BooleanAnimationUsingKeyFrames 

[is list] true 

[allowed types] BooleanKeyFrame 

(static properties)  

Empty BooleanKeyFrameCollection 

(description) An empty BooleanKeyFrameCollection. 

4.49   BooleanToVisibilityConverter 

x:Object > BooleanToVisibilityConverter, IValueConverter 

(usage) <BooleanToVisibilityConverter /> 

(description) Represents the converter that converts Boolean values to and from Visibility enumeration 

values. 

4.50   Border 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Decorator > Border, 
IInputElement 
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(usage) <Border>UIElement</Border> 

(description) Draws a border, background, or both around another element. 

[content property] Child 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Background Brush 

(description) The Brush that fills the area between the bounds of a Border. 

BorderBrush Brush 

(description) The Brush that draws the outer border color. 

BorderThickness Thickness 

(description) The relative Thickness of a Border. 

CornerRadius CornerRadius 

(description) A value that represents the degree to which the corners of a Border are rounded. 

Padding Thickness 

(description) A Thickness value that describes the amount of space between a Border and its 

child element. 

4.51   BorderGapMaskConverter 

x:Object > BorderGapMaskConverter, IMultiValueConverter 

(usage) <BorderGapMaskConverter /> 

(description) Represents a converter that converts the dimensions of a GroupBox control into a 

VisualBrush. 

4.52   BounceEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > BounceEase, IEasingFunction 

(usage) <BounceEase /> 

(description) Represents an easing function that creates an animated bouncing effect. 

(properties)  

Bounces x:Int32 

(description) The number of bounces. 



 

66 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <BounceEase /> 

Bounciness x:Double 

(description) A value that specifies how bouncy the bounce animation is. Low values of this property 

result in bounces with little lose of height between bounces (more bouncy) while high 

values result in dampened bounces (less bouncy). 

4.53   Brush 

x:Object > DependencyObject > Freezable > Animatable > Brush 

BitmapCacheBrush GradientBrush SolidColorBrush TileBrush 

(usage) AliceBlue | AntiqueWhite | Aqua | Aquamarine | Azure | Beige | Bisque | Black | 

BlanchedAlmond ... 

(description) Defines objects used to paint graphical objects. Types that derive from Brush 

describe how the area is painted. 

(used by) AccessText AnchoredBlock Block Border BulletDecorator ContainerVisual Control 

DataGrid DataGridColumnHeader DataGridRowHeader DataGridTextColumn 

DiffuseMaterial DrawingGroup EmissiveMaterial FixedPage FlowDocument 

FlowDocumentPageViewer FlowDocumentReader FlowDocumentScrollViewer 

GeometryDrawing GlyphRunDrawing Glyphs InkCanvas ListItem Page Panel 

PasswordBox Pen Ribbon RibbonButton RibbonCheckBox RibbonControlService 

RibbonGalleryItem RibbonGroup RibbonMenuButton RibbonMenuItem 

RibbonRadioButton RibbonSplitButton RibbonTabHeader RibbonTextBox 

RibbonToggleButton RibbonTwoLineText Shape SpecularMaterial TableCell 

TableColumn TextBlock TextBoxBase TextEffect TextElement TickBar ToolBarTray 

UIElement Viewport3DVisual 

[is default 

constructible] 

false 

[text syntax] BrushSyntax 

(properties)  

Opacity x:Double 

(description) The degree of opacity of a Brush. 

RelativeTransform Transform 

(description) The transformation that is applied to the brush using relative coordinates. 

Transform Transform 

(description) The transformation that is applied to the brush. This transformation is applied 

after the brush's output has been mapped and positioned. 

4.54   Brushes 

x:Object > Brushes 

(usage) {x:Static Brushes.StaticPropertyName} 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) Implements a set of predefined SolidColorBrush objects. 

[is default constructible] false 

(static properties)  

AliceBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF0F8FF. 

AntiqueWhite SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFAEBD7. 

Aqua SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF00FFFF. 

Aquamarine SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF7FFFD4. 

Azure SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF0FFFF. 

Beige SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF5F5DC. 

Bisque SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFE4C4. 

Black SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF000000. 

BlanchedAlmond SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFEBCD. 

Blue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF0000FF. 

BlueViolet SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF8A2BE2. 

Brown SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFA52A2A. 

BurlyWood SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFDEB887. 

CadetBlue SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #FF5F9EA0. 

Chartreuse SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF7FFF00. 

Chocolate SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFD2691E. 

Coral SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF7F50. 

CornflowerBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF6495ED. 

Cornsilk SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFF8DC. 

Crimson SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFDC143C. 

Cyan SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF00FFFF. 

DarkBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF00008B. 

DarkCyan SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF008B8B. 

DarkGoldenrod SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFB8860B. 

DarkGray SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFA9A9A9. 

DarkGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF006400. 

DarkKhaki SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFBDB76B. 

DarkMagenta SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF8B008B. 

DarkOliveGreen SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #FF556B2F. 

DarkOrange SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF8C00. 

DarkOrchid SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF9932CC. 

DarkRed SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF8B0000. 

DarkSalmon SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFE9967A. 

DarkSeaGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF8FBC8F. 

DarkSlateBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF483D8B. 

DarkSlateGray SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF2F4F4F. 

DarkTurquoise SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF00CED1. 

DarkViolet SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF9400D3. 

DeepPink SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF1493. 

DeepSkyBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF00BFFF. 

DimGray SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF696969. 

DodgerBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF1E90FF. 

Firebrick SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFB22222. 

FloralWhite SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #FFFFFAF0. 

ForestGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF228B22. 

Fuchsia SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF00FF. 

Gainsboro SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFDCDCDC. 

GhostWhite SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF8F8FF. 

Gold SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFD700. 

Goldenrod SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFDAA520. 

Gray SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF808080. 

Green SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF008000. 

GreenYellow SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFADFF2F. 

Honeydew SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF0FFF0. 

HotPink SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF69B4. 

IndianRed SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFCD5C5C. 

Indigo SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF4B0082. 

Ivory SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFFFF0. 

Khaki SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #FFF0E68C. 

Lavender SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFE6E6FA. 

LavenderBlush SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFF0F5. 

LawnGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF7CFC00. 

LemonChiffon SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFFACD. 

LightBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFADD8E6. 

LightCoral SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF08080. 

LightCyan SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFE0FFFF. 

LightGoldenrodYellow SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFAFAD2. 

LightGray SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFD3D3D3. 

LightGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF90EE90. 

LightPink SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFB6C1. 

LightSalmon SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFA07A. 

LightSeaGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF20B2AA. 

LightSkyBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF87CEFA. 

LightSlateGray SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #FF778899. 

LightSteelBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFB0C4DE. 

LightYellow SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFFFE0. 

Lime SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF00FF00. 

LimeGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF32CD32. 

Linen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFAF0E6. 

Magenta SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF00FF. 

Maroon SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF800000. 

MediumAquamarine SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF66CDAA. 

MediumBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF0000CD. 

MediumOrchid SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFBA55D3. 

MediumPurple SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF9370DB. 

MediumSeaGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF3CB371. 

MediumSlateBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF7B68EE. 

MediumSpringGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF00FA9A. 

MediumTurquoise SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #FF48D1CC. 

MediumVioletRed SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFC71585. 

MidnightBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF191970. 

MintCream SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF5FFFA. 

MistyRose SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFE4E1. 

Moccasin SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFE4B5. 

NavajoWhite SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFDEAD. 

Navy SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF000080. 

OldLace SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFDF5E6. 

Olive SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF808000. 

OliveDrab SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF6B8E23. 

Orange SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFA500. 

OrangeRed SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF4500. 

Orchid SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFDA70D6. 

PaleGoldenrod SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFEEE8AA. 

PaleGreen SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #FF98FB98. 

PaleTurquoise SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFAFEEEE. 

PaleVioletRed SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFDB7093. 

PapayaWhip SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFEFD5. 

PeachPuff SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFDAB9. 

Peru SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFCD853F. 

Pink SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFC0CB. 

Plum SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFDDA0DD. 

PowderBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFB0E0E6. 

Purple SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF800080. 

Red SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF0000. 

RosyBrown SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFBC8F8F. 

RoyalBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF4169E1. 

SaddleBrown SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF8B4513. 

Salmon SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFA8072. 

SandyBrown SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #FFF4A460. 

SeaGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF2E8B57. 

SeaShell SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFF5EE. 

Sienna SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFA0522D. 

Silver SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFC0C0C0. 

SkyBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF87CEEB. 

SlateBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF6A5ACD. 

SlateGray SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF708090. 

Snow SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFFAFA. 

SpringGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF00FF7F. 

SteelBlue SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF4682B4. 

Tan SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFD2B48C. 

Teal SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF008080. 

Thistle SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFD8BFD8. 

Tomato SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFF6347. 

Transparent SolidColorBrush 
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(usage) {x:Static Brushes.StaticPropertyName} 

(description) The solid fill color that has a hexadecimal value of #00FFFFFF. 

Turquoise SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF40E0D0. 

Violet SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFEE82EE. 

Wheat SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF5DEB3. 

White SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFFFFF. 

WhiteSmoke SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFF5F5F5. 

Yellow SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FFFFFF00. 

YellowGreen SolidColorBrush 

(description) The solid fill color that has a hexadecimal value of #FF9ACD32. 

4.55   BrushMappingMode 

x:Object > BrushMappingMode 

(usage) Absolute| RelativeToBoundingBox 

(description) Specifies the coordinate system used by a Brush. 

(used by) GradientBrush TileBrush 

[is nullable] false 

[text syntax] BrushMappingModeSyntax 

4.56   BulletDecorator 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Decorator > 
BulletDecorator, IInputElement 

(usage) <BulletDecorator>UIElement</BulletDecorator> 

(description) Represents a layout control that aligns a bullet and another visual object. 

[content property] Child 
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(usage) <BulletDecorator>UIElement</BulletDecorator> 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) The background color for a BulletDecorator control. 

Bullet UIElement 

(description) The object to use as the bullet in a BulletDecorator. 

4.57   Button 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ButtonBase > Button, IInputElement 

CalendarButton CalendarDayButton RibbonButton 

(usage) <Button>x:Object</Button> 

(description) Represents a button control, which reacts to the Click event. 

[content 

property] 

Content 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

IsCancel x:Boolean 

(description) A value that indicates whether a Button is a Cancel button. A user can activate the 

Cancel button by pressing the ESC key. 

IsDefault x:Boolean 

(description) A value that indicates whether a Button is the default button. A user invokes the 

default button by pressing the ENTER key. 

4.58   ButtonBase 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ButtonBase, IInputElement 

Button DataGridColumnHeader DataGridRowHeader GridViewColumnHeader RepeatButton 

ToggleButton 

(usage) None. 
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Button DataGridColumnHeader DataGridRowHeader GridViewColumnHeader RepeatButton 

ToggleButton 

(description) Represents the base type for all Button controls. 

[is default constructible] false 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

ClickMode ClickMode 

(description) When the Click event occurs. 

Command ICommand 

(description) The command to invoke when this button is pressed. 

CommandParameter x:Object 

(description) The parameter to pass to the Command property. 

CommandTarget IInputElement 

(description) The element on which to raise the specified command. 

IsPressed x:Boolean 

(description) A value that indicates whether a ButtonBase is currently activated. 

(events)  

Click Occurs when a Button is clicked. 

4.59   ByteAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

ByteAnimationBase > ByteAnimation 

(usage) <ByteAnimation /> 

(description) Animates the value of a Byte property between two target values using linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(x:Byte) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 
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(usage) <ByteAnimation /> 

(description) The easing function applied to this animation. 

From x:Nullable(x:Byte) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(x:Byte) 

(description) The animation's ending value. 

4.60   ByteAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

ByteAnimationBase 

ByteAnimation ByteAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Byte value. 

[is default constructible] false 

[name property] Name 

4.61   ByteAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
ByteAnimationBase > ByteAnimationUsingKeyFrames 

(usage) <ByteAnimationUsingKeyFrames>ByteKeyFrame*</ByteAnimationUsingKeyFrames> 

(description) Animates the value of a Byte property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value 

of the property being animated. 
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(usage) <ByteAnimationUsingKeyFrames>ByteKeyFrame*</ByteAnimationUsingKeyFrames> 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames ByteKeyFrameCollection 

(description) The collection of ByteKeyFrame objects that define the animation. 

4.62   ByteKeyFrame 

x:Object > DependencyObject > Freezable > ByteKeyFrame 

DiscreteByteKeyFrame EasingByteKeyFrame LinearByteKeyFrame SplineByteKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a ByteAnimationUsingKeyFrames. 

(used by) ByteKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value x:Byte 

(description) The key frame's target value. 

4.63   ByteKeyFrameCollection 

x:Object > DependencyObject > Freezable > ByteKeyFrameCollection 

(usage) <ByteKeyFrameCollection>ByteKeyFrame*</ByteKeyFrameCollection> 

(description) Represents a collection of ByteKeyFrame objects. 

(used by) ByteAnimationUsingKeyFrames 

[is list] true 

[allowed types] ByteKeyFrame 

(static properties)  

Empty ByteKeyFrameCollection 

(description) An empty ByteKeyFrameCollection. 
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4.64   CachedBitmap 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 
CachedBitmap 

(usage) <CachedBitmap> string </CachedBitmap> 

(description) Provides caching functionality for a BitmapSource. 

[is default constructible] false 

[text syntax] x:Uri, from [MS-XAML] 

4.65   CacheMode 

x:Object > DependencyObject > Freezable > Animatable > CacheMode 

BitmapCache 

(usage) <CacheMode> string </CacheMode> 

(description) Provides a base implementation for caching a UIElement. 

(used by) ContainerVisual UIElement Viewport2DVisual3D 

[is default constructible] false 

[text syntax] CacheModeSyntax 

4.66   CachingHint 

x:Object > CachingHint 

(usage) Unspecified| Cache 

(description) Specifies whether to cache tile brush objects. 

(used by) RenderOptions 

[is nullable] false 

[text syntax] CachingHintSyntax 

4.67   Calendar 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > Calendar, 
IInputElement 

(usage) <Calendar /> 

(description) Represents a control that enables a user to select a date by using a visual 

calendar display. 

[name property] Name 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) <Calendar /> 

[xml lang property] Language 

(properties)  

BlackoutDates CalendarBlackoutDatesCollection 

(description) A collection of dates that are marked as not selectable. 

[read only] true 

CalendarButtonStyle Style 

(description) The Style associated with the control's internal CalendarButton object. 

CalendarDayButtonStyle Style 

(description) The Style associated with the control's internal CalendarDayButton object. 

CalendarItemStyle Style 

(description) The Style associated with the control's internal CalendarItem object. 

DisplayDate x:DateTime 

(description) The date to display. 

DisplayDateEnd x:Nullable(x:DateTime) 

(description) The last date in the date range that is available in the calendar. 

DisplayDateStart x:Nullable(x:DateTime) 

(description) The first date that is available in the calendar. 

DisplayMode CalendarMode 

(description) A value that indicates whether the calendar displays a month, year, or 

decade. 

FirstDayOfWeek DayOfWeek 

(description) The day that is considered the beginning of the week. 

IsTodayHighlighted x:Boolean 

(description) A value that indicates whether the current date is highlighted. 

SelectedDate x:Nullable(x:DateTime) 

(description) The currently selected date. 

SelectedDates SelectedDatesCollection 

(description) A collection of selected dates. 

[read only] true 

SelectionMode CalendarSelectionMode 
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(usage) <Calendar /> 

(description) A value that indicates what kind of selections are allowed. 

(events)  

DisplayDateChanged Occurs when the DisplayDate property is changed. 

DisplayModeChanged Occurs when the DisplayMode property is changed. 

SelectedDatesChanged Occurs when the collection returned by the SelectedDates property is 

changed. 

SelectionModeChanged Occurs when the SelectionMode changes. 

4.68   CalendarBlackoutDatesCollection 

x:Object > ObservableCollection(CalendarDateRange) > CalendarBlackoutDatesCollection 

(usage) None. 

(description) Represents a collection of non-selectable dates in a Calendar. 

(used by) Calendar DatePicker 

[is default constructible] false 

[is list] true 

[allowed types] CalendarDateRange 

4.69   CalendarButton 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ButtonBase > Button > CalendarButton, IInputElement 

(usage) <CalendarButton>x:Object</CalendarButton> 

(description) Represents a month or year on a Calendar object. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.70   CalendarDateRange 

x:Object > CalendarDateRange 

(usage) <CalendarDateRange /> 

(description) Represents a range of dates in a Calendar. 

(used by) CalendarBlackoutDatesCollection 
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(usage) <CalendarDateRange /> 

(properties)  

End x:DateTime 

(description) The last date in the represented range. 

Start x:DateTime 

(description) The first date in the represented range. 

(events)  

PropertyChanged Occurs when a property value changes. 

4.71   CalendarDayButton 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ButtonBase > Button > CalendarDayButton, IInputElement 

(usage) <CalendarDayButton>x:Object</CalendarDayButton> 

(description) Represents a day on a Calendar. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.72   CalendarItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
CalendarItem, IInputElement 

(usage) <CalendarItem /> 

(description) Represents the currently displayed month or year on a Calendar. 

[name property] Name 

[xml lang property] Language 

(static properties)  

DayTitleTemplateResourceKey ComponentResourceKey 

(description) The resource key for the DataTemplate that displays the days of the 

week. 

4.73   CalendarMode 

x:Object > CalendarMode 

(usage) Month| Year| Decade 
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(usage) Month| Year| Decade 

(description) Specifies whether a Calendar displays a month, year, or decade. 

(used by) Calendar 

[is nullable] false 

[text syntax] CalendarModeSyntax 

4.74   CalendarSelectionMode 

x:Object > CalendarSelectionMode 

(usage) SingleDate| SingleRange| MultipleRange| None 

(description) Specifies whether a single or multiple dates can be selected in a Calendar. 

(used by) Calendar 

[is nullable] false 

[text syntax] CalendarSelectionModeSyntax 

4.75   Camera 

x:Object > DependencyObject > Freezable > Animatable > Camera 

MatrixCamera ProjectionCamera 

(usage) None. 

(description) Specifies what portion of the 3D scene is rendered by the Viewport3DVisual or 

Viewport3D element. 

(used by) Viewport3D Viewport3DVisual 

[is default 

constructible] 

false 

(properties)  

Transform Transform3D 

(description) The Transform3D applied to the camera. 

4.76   Canvas 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > Canvas, 

IInputElement 

(usage) <Canvas>UIElement*</Canvas> 

(description) Defines an area within which you can explicitly position child elements by using 

coordinates that are relative to the Canvas area. 



 

86 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <Canvas>UIElement*</Canvas> 

[content property] Children 

[name property] Name 

[xml lang 

property] 

Language 

(attachable 

properties) 

 

Canvas.Bottom x:Double 

(description) A value that represents the distance between the bottom of an element and the 

bottom of its parent Canvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

Canvas.Left x:Double 

(description) A value that represents the distance between the left side of an element and the 

left side of its parent Canvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

Canvas.Right x:Double 

(description) A value that represents the distance between the right side of an element and the 

right side of its parent Canvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

Canvas.Top x:Double 

(description) A value that represents the distance between the top of an element and the top of 

its parent Canvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

4.77   CaptureMode 

x:Object > CaptureMode 

(usage) None| Element| SubTree 

(description) Specifies the mouse capture policies. 

[is nullable] false 

[text syntax] CaptureModeSyntax 
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4.78   CharacterBufferRange 

x:Object > CharacterBufferRange 

(usage) <CharacterBufferRange /> 

(description) Describes a string of characters. 

[is nullable] false 

(static properties)  

Empty CharacterBufferRange 

(description) An empty character string. 

4.79   CharacterBufferReference 

x:Object > CharacterBufferReference 

(usage) <CharacterBufferReference /> 

(description) Describes a character buffer for a text run. 

[is nullable] false 

4.80   CharacterCasing 

x:Object > CharacterCasing 

(usage) Normal| Lower| Upper 

(description) Specifies the case of characters typed manually into a TextBox control. 

(used by) TextBox 

[is nullable] false 

[text syntax] CharacterCasingSyntax 

4.81   CharacterHit 

x:Object > CharacterHit 

(usage) <CharacterHit /> 

(description) Represents information about a character hit within a glyph run. 

[is nullable] false 

4.82   CharacterMetrics 

x:Object > CharacterMetrics 
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(usage) <CharacterMetrics /> 

(description) Represents the metrics used to lay out a character in a device font. 

(used by) CharacterMetricsDictionary 

(properties)  

Metrics x:String 

(description) A comma-delimited string representing metric values. 

4.83   CharacterMetricsDictionary 

x:Object > CharacterMetricsDictionary 

(usage) None. 

(description) Represents a dictionary of CharacterMetrics objects for a device font that is 

indexed by Unicode scalar values. 

(used by) FamilyTypeface 

[is default 

constructible] 

false 

[is dictionary] true 

[allowed types] CharacterMetrics 

[allowed key types] x:Int32 

(properties)  

Keys ICollection(x:Int32) 

(description) A collection of character codes from CharacterMetricsDictionary. 

[read only] true 

Values ICollection(CharacterMetrics) 

(description) The collection of CharacterMetrics values in the CharacterMetricsDictionary. 

[read only] true 

4.84   CharAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
CharAnimationBase 

CharAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Char value. 
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CharAnimationUsingKeyFrames 

[is default constructible] false 

[name property] Name 

4.85   CharAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

CharAnimationBase > CharAnimationUsingKeyFrames 

(usage) <CharAnimationUsingKeyFrames>CharKeyFrame*</CharAnimationUsingKeyFrames> 

(description) Animates the value of a Char property along a set of KeyFrames over a specified 

Duration. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

KeyFrames CharKeyFrameCollection 

(description) The collection of CharKeyFrame objects that define the animation. 

4.86   CharKeyFrame 

x:Object > DependencyObject > Freezable > CharKeyFrame 

DiscreteCharKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a CharAnimationUsingKeyFrames. 

(used by) CharKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value x:Char 

(description) The key frame's target value. 

4.87   CharKeyFrameCollection 

x:Object > DependencyObject > Freezable > CharKeyFrameCollection 
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(usage) <CharKeyFrameCollection>CharKeyFrame*</CharKeyFrameCollection> 

(description) Represents a collection of CharKeyFrame objects. 

(used by) CharAnimationUsingKeyFrames 

[is list] true 

[allowed types] CharKeyFrame 

(static properties)  

Empty CharKeyFrameCollection 

(description) An empty CharKeyFrameCollection. 

4.88   CheckBox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ButtonBase > ToggleButton > CheckBox, IInputElement 

RibbonCheckBox 

(usage) <CheckBox>x:Object</CheckBox> 

(description) Represents a control that a user can select and clear. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.89   CircleEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > CircleEase, IEasingFunction 

(usage) <CircleEase /> 

(description) Represents an easing function that creates an animation that accelerates and/or 

decelerates using a circular function. 

4.90   ClearTypeHint 

x:Object > ClearTypeHint 

(usage) Auto| Enabled 

(description) An enumeration that specifies a hint to the rendering engine that text can be rendered 

with ClearType. 

(used by) RenderOptions 

[is nullable] false 

[text ClearTypeHintSyntax 
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(usage) Auto| Enabled 

syntax] 

4.91   ClickMode 

x:Object > ClickMode 

(usage) Release| Press| Hover 

(description) Specifies when the Click event should be raised. 

(used by) ButtonBase 

[is nullable] false 

[text syntax] ClickModeSyntax 

4.92   Clock 

x:Object > Clock 

(usage) None. 

(description) Maintains run-time timing state for a Timeline. 

(used by) ClockCollection 

[is default constructible] false 

(events)  

Completed Occurs when this clock has completely finished playing. 

CurrentGlobalSpeedInvalidated Occurs when the clock's speed is updated. 

CurrentStateInvalidated Occurs when the clock's CurrentState property is updated. 

CurrentTimeInvalidated Occurs when this clock's CurrentTime becomes invalid. 

RemoveRequested Occurs when the Remove method is called on this Clock or one of its 

parent clocks. 

4.93   ClockCollection 

x:Object > ClockCollection 

(usage) None. 

(description) Represents an ordered collection of Clock objects. 

[is default constructible] false 

[is list] true 

[allowed types] Clock 
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4.94   ClockState 

x:Object > ClockState 

(usage) Active| Filling| Stopped 

(description) Describes the potential states of a timeline's Clock object. 

[is nullable] false 

[text syntax] ClockStateSyntax 

4.95   CollectionContainer 

x:Object > DependencyObject > CollectionContainer 

(usage) <CollectionContainer /> 

(description) Holds an existing collection structure, such as an ObservableCollection or a DataSet, to 

be used inside a CompositeCollection. 

4.96   CollectionView 

x:Object > CollectionView 

ItemCollection 

(usage) {x:Static CollectionView.StaticPropertyName} 

(description) Represents a view for grouping, sorting, filtering, and navigating a data 

collection. 

[is default 

constructible] 

false 

(properties)  

Culture CultureInfo 

(description) The culture information to use during sorting. 

[text syntax] CultureInfoIetfLanguageTagSyntax 

GroupDescriptions ObservableCollection(GroupDescription) 

(description) A collection of GroupDescription objects that describes how the items in the 

collection are grouped in the view. 

[read only] true 

SortDescriptions SortDescriptionCollection 

(description) A collection of SortDescription structures that describes how the items in the 

collection are sorted in the view. 

[read only] true 
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ItemCollection 

(static properties)  

NewItemPlaceholder x:Object 

(description) The object that is in the collection to represent a new item. 

(events)  

CurrentChanged Occurs after the CurrentItem has changed. 

CurrentChanging Occurs when the CurrentItem is changing. 

4.97   CollectionViewSource 

x:Object > DependencyObject > CollectionViewSource 

(usage) <CollectionViewSource /> 

(description) The XAML proxy of a CollectionView type. 

(properties)  

CollectionViewType x:XamlType 

(description) The desired view type. 

Culture CultureInfo 

(description) The culture that is used for operations such as sorting and comparisons. 

[text syntax] CultureInfoIetfLanguageTagSyntax 

GroupDescriptions ObservableCollection(GroupDescription) 

(description) A collection of GroupDescription objects that describes how the items in 

the collection are grouped in the view. 

[read only] true 

IsLiveFilteringRequested 

(4.5) 

x:Boolean 

(description) A value that indicates whether CollectionViewSource should filter the 

data in real time if it can. 

IsLiveGroupingRequested 

(4.5) 

x:Boolean 

(description) A value that indicates whether CollectionViewSource should group the 

data in real time if it can. 

IsLiveSortingRequested 

(4.5) 

x:Boolean 

(description) A value that indicates whether CollectionViewSource should sort the 

data in real time if it can. 
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(usage) <CollectionViewSource /> 

LiveFilteringProperties 

(4.5) 

ObservableCollection(x:String) 

(description) A collection of strings that specify the properties that participate in 

filtering data in real time. 

[read only] true 

LiveGroupingProperties 

(4.5) 

ObservableCollection(x:String) 

(description) A collection of strings that specify the properties that participate in 

grouping data in real time. 

[read only] true 

LiveSortingProperties (4.5) ObservableCollection(x:String) 

(description) A collection of strings that specify the properties that participate in 

sorting data in real time. 

[read only] true 

SortDescriptions SortDescriptionCollection 

(description) A collection of SortDescription objects that describes how the items in 

the collection are sorted in the view. 

[read only] true 

Source x:Object 

(description) The collection object from which to create this view. 

(events)  

Filter Provides filtering logic. 

4.98   Color 

x:Object > Color 

(usage) AliceBlue| AntiqueWhite| Aqua| Aquamarine| Azure| Beige| Bisque| Black| 

BlanchedAlmond... 

(description) Describes a color in terms of alpha, red, green, and blue channels. 

(used by) ColorKeyFrame DiffuseMaterial DrawingAttributes DropShadowEffect EmissiveMaterial 

GradientStop Light SolidColorBrush SpecularMaterial 

[is nullable] false 

[text 

syntax] 

ColorSyntax 

(properties)  
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(usage) AliceBlue| AntiqueWhite| Aqua| Aquamarine| Azure| Beige| Bisque| Black| 

BlanchedAlmond... 

A x:Byte 

(description) The sRGB alpha channel value of the color. 

B x:Byte 

(description) The sRGB blue channel value of the color. 

G x:Byte 

(description) The sRGB green channel value of the color. 

R x:Byte 

(description) The sRGB red channel value of the color. 

ScA x:Single 

(description) The ScRGB alpha channel value of the color. 

ScB x:Single 

(description) The ScRGB blue channel value of the color. 

ScG x:Single 

(description) The ScRGB green channel value of the color. 

ScR x:Single 

(description) The ScRGB red channel value of the color. 

4.99   ColorAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
ColorAnimationBase > ColorAnimation 

(usage) <ColorAnimation /> 

(description) Animates the value of a  Color property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(Color) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Color) 
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(usage) <ColorAnimation /> 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Color) 

(description) The animation's ending value. 

4.100   ColorAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
ColorAnimationBase 

ColorAnimation ColorAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Color value. 

[is default constructible] false 

[name property] Name 

4.101   ColorAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
ColorAnimationBase > ColorAnimationUsingKeyFrames 

(usage) <ColorAnimationUsingKeyFrames>ColorKeyFrame*</ColorAnimationUsingKeyFrames> 

(description) Animates the value of a Color property along a set of KeyFrames over a specified 

Duration. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value of 

the property being animated. 

IsCumulative x:Boolean 
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(usage) <ColorAnimationUsingKeyFrames>ColorKeyFrame*</ColorAnimationUsingKeyFrames> 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames ColorKeyFrameCollection 

(description) The collection of ColorKeyFrame objects that define the animation. 

4.102   ColorContext 

x:Object > ColorContext 

(usage) None. 

(description) Represents the International Color Consortium (ICC) or Image Color Management 

(ICM) color profile that is associated with a bitmap image. 

(used by) BitmapEncoder 

[is default 

constructible] 

false 

4.103   ColorConvertedBitmap 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 
ColorConvertedBitmap 

(usage) <ColorConvertedBitmap> string </ColorConvertedBitmap> 

(description) Changes the color space of a BitmapSource. 

[text syntax] x:Uri, from [MS-XAML] 

(properties)  

DestinationFormat PixelFormat 

(description) A value that represents the PixelFormat of the converted bitmap. 

Source BitmapSource 

(description) A value that identifies the source bitmap that is converted. 

4.104   ColorConvertedBitmapExtension 

x:Object > x:MarkupExtension > ColorConvertedBitmapExtension 

(usage) {ColorConvertedBitmap } | <ColorConvertedBitmap /> 

(description) Implements a markup extension that enables ColorConvertedBitmap creation. A 

ColorConvertedBitmap does not have an embedded profile, the profile instead being 

based on source and destination values. 

[return value 

type] 

ColorConvertedBitmap 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) {ColorConvertedBitmap } | <ColorConvertedBitmap /> 

[constructors]  

(1 parameter)  

image x:Object 

(description) A string that is parsed to determine three URIs: image source, source color context, 

and destination color context. 

4.105   ColorInterpolationMode 

x:Object > ColorInterpolationMode 

(usage) ScRgbLinearInterpolation| SRgbLinearInterpolation 

(description) Determines how the colors in a gradient are interpolated. 

(used by) GradientBrush 

[is nullable] false 

[text syntax] ColorInterpolationModeSyntax 

4.106   ColorKeyFrame 

x:Object > DependencyObject > Freezable > ColorKeyFrame 

DiscreteColorKeyFrame EasingColorKeyFrame LinearColorKeyFrame SplineColorKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a ColorAnimationUsingKeyFrames. 

(used by) ColorKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value Color 

(description) The key frame's target value. 

4.107   ColorKeyFrameCollection 

x:Object > DependencyObject > Freezable > ColorKeyFrameCollection 

(usage) <ColorKeyFrameCollection>ColorKeyFrame*</ColorKeyFrameCollection> 
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(usage) <ColorKeyFrameCollection>ColorKeyFrame*</ColorKeyFrameCollection> 

(description) Represents a collection of ColorKeyFrame objects. 

(used by) ColorAnimationUsingKeyFrames 

[is list] true 

[allowed types] ColorKeyFrame 

(static properties)  

Empty ColorKeyFrameCollection 

(description) An empty ColorKeyFrameCollection. 

4.108   Colors 

x:Object > Colors 

(usage) {x:Static Colors.StaticPropertyName} 

(description) Implements a set of predefined colors. 

[is default constructible] false 

(static properties)  

AliceBlue Color 

(description) The system-defined color that has an ARGB value of #FFF0F8FF. 

AntiqueWhite Color 

(description) The system-defined color that has an ARGB value of #FFFAEBD7. 

Aqua Color 

(description) The system-defined color that has an ARGB value of #FF00FFFF. 

Aquamarine Color 

(description) The system-defined color that has an ARGB value of #FF7FFFD4. 

Azure Color 

(description) The system-defined color that has an ARGB value of #FFF0FFFF. 

Beige Color 

(description) The system-defined color that has an ARGB value of #FFF5F5DC. 

Bisque Color 

(description) The system-defined color that has an ARGB value of #FFFFE4C4. 

Black Color 

(description) The system-defined color that has an ARGB value of #FF000000. 
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(usage) {x:Static Colors.StaticPropertyName} 

BlanchedAlmond Color 

(description) The system-defined color that has an ARGB value of #FFFFEBCD. 

Blue Color 

(description) The system-defined color that has an ARGB value of #FF0000FF. 

BlueViolet Color 

(description) The system-defined color that has an ARGB value of #FF8A2BE2. 

Brown Color 

(description) The system-defined color that has an ARGB value of #FFA52A2A. 

BurlyWood Color 

(description) The system-defined color that has an ARGB value of #FFDEB887. 

CadetBlue Color 

(description) The system-defined color that has an ARGB value of #FF5F9EA0. 

Chartreuse Color 

(description) The system-defined color that has an ARGB value of #FF7FFF00. 

Chocolate Color 

(description) The system-defined color that has an ARGB value of #FFD2691E. 

Coral Color 

(description) The system-defined color that has an ARGB value of #FFFF7F50. 

CornflowerBlue Color 

(description) The system-defined color that has an ARGB value of #FF6495ED. 

Cornsilk Color 

(description) The system-defined color that has an ARGB value of #FFFFF8DC. 

Crimson Color 

(description) The system-defined color that has an ARGB value of #FFDC143C. 

Cyan Color 

(description) The system-defined color that has an ARGB value of #FF00FFFF. 

DarkBlue Color 

(description) The system-defined color that has an ARGB value of #FF00008B. 

DarkCyan Color 

(description) The system-defined color that has an ARGB value of #FF008B8B. 
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(usage) {x:Static Colors.StaticPropertyName} 

DarkGoldenrod Color 

(description) The system-defined color that has an ARGB value of #FFB8860B. 

DarkGray Color 

(description) The system-defined color that has an ARGB value of #FFA9A9A9. 

DarkGreen Color 

(description) The system-defined color that has an ARGB value of #FF006400. 

DarkKhaki Color 

(description) The system-defined color that has an ARGB value of #FFBDB76B. 

DarkMagenta Color 

(description) The system-defined color that has an ARGB value of #FF8B008B. 

DarkOliveGreen Color 

(description) The system-defined color that has an ARGB value of #FF556B2F. 

DarkOrange Color 

(description) The system-defined color that has an ARGB value of #FFFF8C00. 

DarkOrchid Color 

(description) The system-defined color that has an ARGB value of #FF9932CC. 

DarkRed Color 

(description) The system-defined color that has an ARGB value of #FF8B0000. 

DarkSalmon Color 

(description) The system-defined color that has an ARGB value of #FFE9967A. 

DarkSeaGreen Color 

(description) The system-defined color that has an ARGB value of #FF8FBC8F. 

DarkSlateBlue Color 

(description) The system-defined color that has an ARGB value of #FF483D8B. 

DarkSlateGray Color 

(description) The system-defined color that has an ARGB value of #FF2F4F4F. 

DarkTurquoise Color 

(description) The system-defined color that has an ARGB value of #FF00CED1. 

DarkViolet Color 

(description) The system-defined color that has an ARGB value of #FF9400D3. 
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(usage) {x:Static Colors.StaticPropertyName} 

DeepPink Color 

(description) The system-defined color that has an ARGB value of #FFFF1493. 

DeepSkyBlue Color 

(description) The system-defined color that has an ARGB value of #FF00BFFF. 

DimGray Color 

(description) The system-defined color that has an ARGB value of #FF696969. 

DodgerBlue Color 

(description) The system-defined color that has an ARGB value of #FF1E90FF. 

Firebrick Color 

(description) The system-defined color that has an ARGB value of #FFB22222. 

FloralWhite Color 

(description) The system-defined color that has an ARGB value of #FFFFFAF0. 

ForestGreen Color 

(description) The system-defined color that has an ARGB value of #FF228B22. 

Fuchsia Color 

(description) The system-defined color that has an ARGB value of #FFFF00FF. 

Gainsboro Color 

(description) The system-defined color that has an ARGB value of #FFDCDCDC. 

GhostWhite Color 

(description) The system-defined color that has an ARGB value of #FFF8F8FF. 

Gold Color 

(description) The system-defined color that has an ARGB value of #FFFFD700. 

Goldenrod Color 

(description) The system-defined color that has an ARGB value of #FFDAA520. 

Gray Color 

(description) The system-defined color that has an ARGB value of #FF808080. 

Green Color 

(description) The system-defined color that has an ARGB value of #FF008000. 

GreenYellow Color 

(description) The system-defined color that has an ARGB value of #FFADFF2F. 
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(usage) {x:Static Colors.StaticPropertyName} 

Honeydew Color 

(description) The system-defined color that has an ARGB value of #FFF0FFF0. 

HotPink Color 

(description) The system-defined color that has an ARGB value of #FFFF69B4. 

IndianRed Color 

(description) The system-defined color that has an ARGB value of #FFCD5C5C. 

Indigo Color 

(description) The system-defined color that has an ARGB value of #FF4B0082. 

Ivory Color 

(description) The system-defined color that has an ARGB value of #FFFFFFF0. 

Khaki Color 

(description) The system-defined color that has an ARGB value of #FFF0E68C. 

Lavender Color 

(description) The system-defined color that has an ARGB value of #FFE6E6FA. 

LavenderBlush Color 

(description) The system-defined color that has an ARGB value of #FFFFF0F5. 

LawnGreen Color 

(description) The system-defined color that has an ARGB value of #FF7CFC00. 

LemonChiffon Color 

(description) The system-defined color that has an ARGB value of #FFFFFACD. 

LightBlue Color 

(description) The system-defined color that has an ARGB value of #FFADD8E6. 

LightCoral Color 

(description) The system-defined color that has an ARGB value of #FFF08080. 

LightCyan Color 

(description) The system-defined color that has an ARGB value of #FFE0FFFF. 

LightGoldenrodYellow Color 

(description) The system-defined color that has an ARGB value of #FFFAFAD2. 

LightGray Color 

(description) The system-defined color that has an ARGB value of #FFD3D3D3. 
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(usage) {x:Static Colors.StaticPropertyName} 

LightGreen Color 

(description) The system-defined color that has an ARGB value of #FF90EE90. 

LightPink Color 

(description) The system-defined color that has an ARGB value of #FFFFB6C1. 

LightSalmon Color 

(description) The system-defined color that has an ARGB value of #FFFFA07A. 

LightSeaGreen Color 

(description) The system-defined color that has an ARGB value of #FF20B2AA. 

LightSkyBlue Color 

(description) The system-defined color that has an ARGB value of #FF87CEFA. 

LightSlateGray Color 

(description) The system-defined color that has an ARGB value of #FF778899. 

LightSteelBlue Color 

(description) The system-defined color that has an ARGB value of #FFB0C4DE. 

LightYellow Color 

(description) The system-defined color that has an ARGB value of #FFFFFFE0. 

Lime Color 

(description) The system-defined color that has an ARGB value of #FF00FF00. 

LimeGreen Color 

(description) The system-defined color that has an ARGB value of #FF32CD32. 

Linen Color 

(description) The system-defined color that has an ARGB value of #FFFAF0E6. 

Magenta Color 

(description) The system-defined color that has an ARGB value of #FFFF00FF. 

Maroon Color 

(description) The system-defined color that has an ARGB value of #FF800000. 

MediumAquamarine Color 

(description) The system-defined color that has an ARGB value of #FF66CDAA. 

MediumBlue Color 

(description) The system-defined color that has an ARGB value of #FF0000CD. 
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(usage) {x:Static Colors.StaticPropertyName} 

MediumOrchid Color 

(description) The system-defined color that has an ARGB value of #FFBA55D3. 

MediumPurple Color 

(description) The system-defined color that has an ARGB value of #FF9370DB. 

MediumSeaGreen Color 

(description) The system-defined color that has an ARGB value of #FF3CB371. 

MediumSlateBlue Color 

(description) The system-defined color that has an ARGB value of #FF7B68EE. 

MediumSpringGreen Color 

(description) The system-defined color that has an ARGB value of #FF00FA9A. 

MediumTurquoise Color 

(description) The system-defined color that has an ARGB value of #FF48D1CC. 

MediumVioletRed Color 

(description) The system-defined color that has an ARGB value of #FFC71585. 

MidnightBlue Color 

(description) The system-defined color that has an ARGB value of #FF191970. 

MintCream Color 

(description) The system-defined color that has an ARGB value of #FFF5FFFA. 

MistyRose Color 

(description) The system-defined color that has an ARGB value of #FFFFE4E1. 

Moccasin Color 

(description) The system-defined color that has an ARGB value of #FFFFE4B5. 

NavajoWhite Color 

(description) The system-defined color that has an ARGB value of #FFFFDEAD. 

Navy Color 

(description) The system-defined color that has an ARGB value of #FF000080. 

OldLace Color 

(description) The system-defined color that has an ARGB value of #FFFDF5E6. 

Olive Color 

(description) The system-defined color that has an ARGB value of #FF808000. 
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(usage) {x:Static Colors.StaticPropertyName} 

OliveDrab Color 

(description) The system-defined color that has an ARGB value of #FF6B8E23. 

Orange Color 

(description) The system-defined color that has an ARGB value of #FFFFA500. 

OrangeRed Color 

(description) The system-defined color that has an ARGB value of #FFFF4500. 

Orchid Color 

(description) The system-defined color that has an ARGB value of #FFDA70D6. 

PaleGoldenrod Color 

(description) The system-defined color that has an ARGB value of #FFEEE8AA. 

PaleGreen Color 

(description) The system-defined color that has an ARGB value of #FF98FB98. 

PaleTurquoise Color 

(description) The system-defined color that has an ARGB value of #FFAFEEEE. 

PaleVioletRed Color 

(description) The system-defined color that has an ARGB value of #FFDB7093. 

PapayaWhip Color 

(description) The system-defined color that has an ARGB value of #FFFFEFD5. 

PeachPuff Color 

(description) The system-defined color that has an ARGB value of #FFFFDAB9. 

Peru Color 

(description) The system-defined color that has an ARGB value of #FFCD853F. 

Pink Color 

(description) The system-defined color that has an ARGB value of #FFFFC0CB. 

Plum Color 

(description) The system-defined color that has an ARGB value of #FFDDA0DD. 

PowderBlue Color 

(description) The system-defined color that has an ARGB value of #FFB0E0E6. 

Purple Color 

(description) The system-defined color that has an ARGB value of #FF800080. 
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(usage) {x:Static Colors.StaticPropertyName} 

Red Color 

(description) The system-defined color that has an ARGB value of #FFFF0000. 

RosyBrown Color 

(description) The system-defined color that has an ARGB value of #FFBC8F8F. 

RoyalBlue Color 

(description) The system-defined color that has an ARGB value of #FF4169E1. 

SaddleBrown Color 

(description) The system-defined color that has an ARGB value of #FF8B4513. 

Salmon Color 

(description) The system-defined color that has an ARGB value of #FFFA8072. 

SandyBrown Color 

(description) The system-defined color that has an ARGB value of #FFF4A460. 

SeaGreen Color 

(description) The system-defined color that has an ARGB value of #FF2E8B57. 

SeaShell Color 

(description) The system-defined color that has an ARGB value of #FFFFF5EE. 

Sienna Color 

(description) The system-defined color that has an ARGB value of #FFA0522D. 

Silver Color 

(description) The system-defined color that has an ARGB value of #FFC0C0C0. 

SkyBlue Color 

(description) The system-defined color that has an ARGB value of #FF87CEEB. 

SlateBlue Color 

(description) The system-defined color that has an ARGB value of #FF6A5ACD. 

SlateGray Color 

(description) The system-defined color that has an ARGB value of #FF708090. 

Snow Color 

(description) The system-defined color that has an ARGB value of #FFFFFAFA. 

SpringGreen Color 

(description) The system-defined color that has an ARGB value of #FF00FF7F. 
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(usage) {x:Static Colors.StaticPropertyName} 

SteelBlue Color 

(description) The system-defined color that has an ARGB value of #FF4682B4. 

Tan Color 

(description) The system-defined color that has an ARGB value of #FFD2B48C. 

Teal Color 

(description) The system-defined color that has an ARGB value of #FF008080. 

Thistle Color 

(description) The system-defined color that has an ARGB value of #FFD8BFD8. 

Tomato Color 

(description) The system-defined color that has an ARGB value of #FFFF6347. 

Transparent Color 

(description) The system-defined color that has an ARGB value of #00FFFFFF. 

Turquoise Color 

(description) The system-defined color that has an ARGB value of #FF40E0D0. 

Violet Color 

(description) The system-defined color that has an ARGB value of #FFEE82EE. 

Wheat Color 

(description) The system-defined color that has an ARGB value of #FFF5DEB3. 

White Color 

(description) The system-defined color that has an ARGB value of #FFFFFFFF. 

WhiteSmoke Color 

(description) The system-defined color that has an ARGB value of #FFF5F5F5. 

Yellow Color 

(description) The system-defined color that has an ARGB value of #FFFFFF00. 

YellowGreen Color 

(description) The system-defined color that has an ARGB value of #FF9ACD32. 

4.109   ColumnDefinition 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > DefinitionBase > 

ColumnDefinition, IInputElement 
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(usage) <ColumnDefinition /> 

(description) Defines column-specific properties that apply to Grid elements. 

(used by) ColumnDefinitionCollection 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

MaxWidth x:Double 

(description) A value that represents the maximum width of a ColumnDefinition. 

[text syntax] LengthSyntax 

MinWidth x:Double 

(description) A value that represents the minimum width of a ColumnDefinition. 

[text syntax] LengthSyntax 

Width GridLength 

(description) The calculated width of a ColumnDefinition element, or sets the GridLength value of 

a column that is defined by the ColumnDefinition. 

4.110   ColumnDefinitionCollection 

x:Object > ColumnDefinitionCollection 

(usage) None. 

(description) Provides access to an ordered, strongly typed collection of ColumnDefinition 

objects. 

(used by) Grid 

[is default 

constructible] 

false 

[is list] true 

[allowed types] ColumnDefinition 

4.111   ColumnSpaceDistribution 

x:Object > ColumnSpaceDistribution 

(usage) Left| Right| Between 

(description) Describes how to distribute space in columnated flow content. 

[is nullable] false 
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(usage) Left| Right| Between 

[text syntax] ColumnSpaceDistributionSyntax 

4.112   CombinedGeometry 

x:Object > DependencyObject > Freezable > Animatable > Geometry > CombinedGeometry 

(usage) <CombinedGeometry> string </CombinedGeometry> 

(description) Represents a 2-D geometric shape defined by the combination of two 

Geometry objects. 

[text syntax] GeometrySyntax 

(properties)  

Geometry1 Geometry 

(description) The first Geometry object of this CombinedGeometry object. 

Geometry2 Geometry 

(description) The second Geometry object of this CombinedGeometry object. 

GeometryCombineMode GeometryCombineMode 

(description) The way by which the two geometries (specified by the Geometry1 and 

Geometry2 properties) are combined. 

4.113   ComboBox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > Selector > ComboBox, IInputElement 

(usage) <ComboBox>x:Object*</ComboBox> 

(description) Represents a selection control with a drop-down list that can be 

shown or hidden by clicking the arrow on the control. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

IsDropDownOpen x:Boolean 

(description) A value that indicates whether the drop-down for a combo box 

is currently open. 

IsEditable x:Boolean 

(description) A value that enables or disables editing of the text in text box 

of the ComboBox. 
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(usage) <ComboBox>x:Object*</ComboBox> 

IsReadOnly x:Boolean 

(description) A value that enables selection-only mode, in which the contents 

of the combo box are selectable but not editable. 

MaxDropDownHeight x:Double 

(description) The maximum height for a combo box drop-down. 

[text syntax] LengthSyntax 

ShouldPreserveUserEnteredPrefix 

(4.5) 

x:Boolean 

(description) A value that indicates whether the ComboBox keeps the user's 

input or replaces the input with a matching item. 

StaysOpenOnEdit x:Boolean 

(description) Whether a ComboBox that is open and displays a drop-down 

control will remain open when a user clicks the TextBox. 

Text x:String 

(description) The text of the currently selected item. 

(events)  

DropDownClosed Occurs when the drop-down list of the combo box closes. 

DropDownOpened Occurs when the drop-down list of the combo box opens. 

4.114   ComboBoxItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ListBoxItem > ComboBoxItem, IInputElement 

(usage) <ComboBoxItem>x:Object</ComboBoxItem> 

(description) Implements a selectable item inside a ComboBox. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.115   CommandBinding 

x:Object > CommandBinding 

(usage) <CommandBinding /> 

(description) Binds a RoutedCommand to the event handlers that implement the command. 
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(usage) <CommandBinding /> 

(used by) CommandBindingCollection 

(properties)  

Command ICommand 

(description) The ICommand associated with this CommandBinding. 

(events)  

CanExecute Occurs when the command associated with this CommandBinding initiates a 

check to determine whether the command can be executed on the command 

target. 

Executed Occurs when the command associated with this CommandBinding executes. 

PreviewCanExecute Occurs when the command associated with this CommandBinding initiates a 

check to determine whether the command can be executed on the current 

command target. 

PreviewExecuted Occurs when the command associated with this CommandBinding executes. 

4.116   CommandBindingCollection 

x:Object > CommandBindingCollection 

(usage) <CommandBindingCollection>CommandBinding*</CommandBindingCollection> 

(description) Represents a collection of CommandBinding objects. 

(used by) ContentElement UIElement UIElement3D 

[is list] true 

[allowed types] CommandBinding 

4.117   ComponentCommands 

x:Object > ComponentCommands 

(usage) {x:Static ComponentCommands.StaticPropertyName} 

(description) Provides a standard set of component-related commands, which have 

predefined key input gestures and Text properties. 

[is default 

constructible] 

false 

(static properties)  

ExtendSelectionDown RoutedUICommand 

(description) The value that represents the Extend Selection Down command. 

ExtendSelectionLeft RoutedUICommand 
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(usage) {x:Static ComponentCommands.StaticPropertyName} 

(description) The value that represents the Extend Selection Left command. 

ExtendSelectionRight RoutedUICommand 

(description) The value that represents the Extend Selection Right command. 

ExtendSelectionUp RoutedUICommand 

(description) The value that represents the Extend Selection Up command. 

MoveDown RoutedUICommand 

(description) The value that represents the Move Down command. 

MoveFocusBack RoutedUICommand 

(description) The value that represents the Move Focus Back command. 

MoveFocusDown RoutedUICommand 

(description) The value that represents the Move Focus Down command. 

MoveFocusForward RoutedUICommand 

(description) The value that represents the Move Focus Forward command. 

MoveFocusPageDown RoutedUICommand 

(description) The value that represents the Move Focus Page Down command. 

MoveFocusPageUp RoutedUICommand 

(description) The value that represents the Move Focus Page Up command. 

MoveFocusUp RoutedUICommand 

(description) The value that represents the Move Focus Up command. 

MoveLeft RoutedUICommand 

(description) The value that represents the Move Left command. 

MoveRight RoutedUICommand 

(description) The value that represents the Move Right command. 

MoveToEnd RoutedUICommand 

(description) The value that represents the Move To End command. 

MoveToHome RoutedUICommand 

(description) The value that represents the Move To Home command. 

MoveToPageDown RoutedUICommand 

(description) The value that represents the Move To Page Down command. 

MoveToPageUp RoutedUICommand 
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(usage) {x:Static ComponentCommands.StaticPropertyName} 

(description) The value that represents the Move To Page Up command. 

MoveUp RoutedUICommand 

(description) The value that represents the Move Up command. 

ScrollByLine RoutedUICommand 

(description) The value that represents the Scroll By Line command. 

ScrollPageDown RoutedUICommand 

(description) The value that represents the Scroll Page Down command. 

ScrollPageLeft RoutedUICommand 

(description) The value that represents the Scroll Page Left command. 

ScrollPageRight RoutedUICommand 

(description) The value that represents the Scroll Page Right command. 

ScrollPageUp RoutedUICommand 

(description) The value that represents the Scroll Page Up command. 

SelectToEnd RoutedUICommand 

(description) The value that represents the Select To End command. 

SelectToHome RoutedUICommand 

(description) The value that represents the Select To Home command. 

SelectToPageDown RoutedUICommand 

(description) The value that represents the Select To Page Down command. 

SelectToPageUp RoutedUICommand 

(description) The value that represents the Select To Page Up command. 

4.118   ComponentResourceKey 

x:Object > x:MarkupExtension > ResourceKey > ComponentResourceKey 

(usage) {ComponentResourceKey } | <ComponentResourceKey /> 

(description) Defines or references resource keys based on type names in external 

assemblies, as well as an additional identifier. 

[return value type] ResourceKey 

[constructors]  

(2 parameters)  
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(usage) {ComponentResourceKey } | <ComponentResourceKey /> 

typeInTargetAssembly x:XamlType 

(description) The type that defines the resource key. 

resourceId x:Object 

(description) A unique identifier to differentiate this ComponentResourceKey from others 

associated with the  type. 

(properties)  

ResourceId x:Object 

(description) A unique identifier to differentiate this key from others associated with this 

type. 

TypeInTargetAssembly x:XamlType 

(description) The Type that defines the resource key. 

4.119   CompositeCollection 

x:Object > CompositeCollection 

(usage) <CompositeCollection>x:Object*</CompositeCollection> 

(description) Enables multiple collections and items to be displayed as a single list. 

[is list] true 

[allowed types] x:Object 

4.120   Condition 

x:Object > Condition 

(usage) <Condition /> 

(description) Represents a condition for the MultiTrigger and the MultiDataTrigger, which apply 

changes to property values based on a set of conditions. 

(used by) ConditionCollection 

(properties)  

Binding BindingBase 

(description) The binding that specifies the property of the condition. This is only applicable to 

MultiDataTrigger objects. 

Property DependencyProperty 

(description) The property of the condition. This is only applicable to MultiTrigger objects. 

SourceName x:String 
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(usage) <Condition /> 

(description) The name of the object with the property that causes the associated setters to be 

applied. This is only applicable to MultiTrigger objects. 

Value x:Object 

(description) The value of the condition. 

[text 

syntax] 

This property's text syntax is the text syntax of the Property. 

4.121   ConditionCollection 

x:Object > Collection(Condition) > ConditionCollection 

(usage) <ConditionCollection>Condition*</ConditionCollection> 

(description) Represents a collection of Condition objects. 

(used by) MultiDataTrigger MultiTrigger 

[is list] true 

[allowed types] Condition 

4.122   ContainerUIElement3D 

x:Object > DependencyObject > Visual3D > UIElement3D > ContainerUIElement3D, IInputElement 

(usage) <ContainerUIElement3D>Visual3D*</ContainerUIElement3D> 

(description) Represents a container for Visual3D objects. 

[content property] Children 

(properties)  

Children Visual3DCollection 

(description) A Visual3DCollection of child elements of this ContainerUIElement3D object. 

[read only] true 

4.123   ContainerVisual 

x:Object > DependencyObject > Visual > ContainerVisual 

DrawingVisual HostVisual 

(usage) <ContainerVisual /> 

(description) Manages a collection of Visual objects. 

(properties)  
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DrawingVisual HostVisual 

CacheMode CacheMode 

(description) A cached representation of the ContainerVisual. 

Children VisualCollection 

(description) The child collection of the ContainerVisual. 

[read only] true 

Clip Geometry 

(description) The clipping region of the ContainerVisual. 

Effect Effect 

(description) The bitmap effect to apply to the ContainerVisual. 

Offset Vector 

(description) The offset value of the ContainerVisual from its reference point. 

Opacity x:Double 

(description) The opacity of the ContainerVisual, based on 0=transparent, 1=opaque. 

OpacityMask Brush 

(description) A brush that specifies a possible opacity mask for the ContainerVisual. 

Transform Transform 

(description) The transform that is applied to the ContainerVisual. 

XSnappingGuidelines DoubleCollection 

(description) The X (horizontal) guideline for the ContainerVisual. 

YSnappingGuidelines DoubleCollection 

(description) The Y (vertical) guideline for the ContainerVisual. 

4.124   ContentControl 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl, IInputElement 

ButtonBase DataGridCell Frame GroupItem HeaderedContentControl Label ListBoxItem 

RibbonControl RibbonGalleryItem RibbonTabHeader ScrollViewer StatusBarItem ToolTip 

UserControl Window 

(usage) <ContentControl>x:Object</ContentControl> 

(description) Represents a control with a single piece of content of any type. 

[content property] Content 
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ButtonBase DataGridCell Frame GroupItem HeaderedContentControl Label ListBoxItem 

RibbonControl RibbonGalleryItem RibbonTabHeader ScrollViewer StatusBarItem ToolTip 

UserControl Window 

[name property] Name 

[xml lang property] Language 

(properties)  

Content x:Object 

(description) The content of a ContentControl. 

ContentStringFormat x:String 

(description) A composite string that specifies how to format the Content property if 

it is displayed as a string. 

ContentTemplate DataTemplate 

(description) The data template used to display the content of the ContentControl. 

ContentTemplateSelector DataTemplateSelector 

(description) A template selector that enables an application writer to provide 

custom template-selection logic. 

4.125   ContentElement 

x:Object > DependencyObject > ContentElement, IInputElement 

FrameworkContentElement 

(usage) <ContentElement /> 

(description) Provides a core-level base type for content elements. Content 

elements are designed for flow-style presentation, using an 

intuitive markup-oriented layout model and a deliberately simple 

object model. 

(properties)  

AllowDrop x:Boolean 

(description) A value that indicates whether this element can be used as the 

target of a drag-and-drop operation. 

CommandBindings CommandBindingCollection 

(description) A collection of CommandBinding objects that are associated with 

this element. 

[read only] true 

Focusable x:Boolean 

(description) A value that indicates whether the element can receive focus. 
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FrameworkContentElement 

InputBindings InputBindingCollection 

(description) The collection of input bindings that are associated with this 

element. 

[read only] true 

IsEnabled x:Boolean 

(description) A value that indicates whether this element is enabled in the user 

interface (UI). 

(events)  

DragEnter Occurs when the input system reports an underlying drag event 

with this element as the drag target. 

DragLeave Occurs when the input system reports an underlying drag event 

with this element as the drag origin. 

DragOver Occurs when the input system reports an underlying drag event 

with this element as the potential drop target. 

Drop Occurs when the input system reports an underlying drop event 

with this element as the drop target. 

FocusableChanged Occurs when the value of the Focusable property changes. 

GiveFeedback Occurs when the input system reports an underlying drag-and-drop 

event that involves this element. 

GotFocus Occurs when this element gets logical focus. 

GotKeyboardFocus Occurs when the keyboard is focused on this element. 

GotMouseCapture Occurs when this element captures the mouse. 

GotStylusCapture Occurs when this element captures the stylus. 

GotTouchCapture Occurs when a touch is captured to this element. 

IsEnabledChanged Occurs when the value of the IsEnabled property on this element 

changes. 

IsKeyboardFocusedChanged Occurs when the value of the IsKeyboardFocused property changes 

on this element. 

IsKeyboardFocusWithinChanged Occurs when the value of the IsKeyboardFocusWithinChanged 

property changes on this element. 

IsMouseCapturedChanged Occurs when the value of the IsMouseCaptured property changes 

on this element. 

IsMouseCaptureWithinChanged Occurs when the value of the IsMouseCaptureWithinProperty 

changes on this element. 

IsMouseDirectlyOverChanged Occurs when the value of the IsMouseDirectlyOver property 

changes on this element. 
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FrameworkContentElement 

IsStylusCapturedChanged Occurs when the value of the IsStylusCaptured property changes 

on this element. 

IsStylusCaptureWithinChanged Occurs when the value of the IsStylusCaptureWithin property 

changes on this element. 

IsStylusDirectlyOverChanged Occurs when the value of the IsStylusDirectlyOver property 

changes on this element. 

KeyDown Occurs when a key is pressed while focus is on this element. 

KeyUp Occurs when a key is released while focus is on this element. 

LostFocus Occurs when this element loses logical focus. 

LostKeyboardFocus Occurs when the keyboard is no longer focused on this element. 

LostMouseCapture Occurs when this element loses mouse capture. 

LostStylusCapture Occurs when this element loses stylus capture. 

LostTouchCapture Occurs when this element loses a touch capture. 

MouseDown Occurs when any mouse button is pressed while the pointer is over 

this element. 

MouseEnter Occurs when the mouse pointer enters the bounds of this element. 

MouseLeave Occurs when the mouse pointer leaves the bounds of this element. 

MouseLeftButtonDown Occurs when the left mouse button is pressed while the mouse 

pointer is over this element. 

MouseLeftButtonUp Occurs when the left mouse button is released while the mouse 

pointer is over this element. 

MouseMove Occurs when the mouse pointer moves while over this element. 

MouseRightButtonDown Occurs when the right mouse button is pressed while the mouse 

pointer is over this element. 

MouseRightButtonUp Occurs when the right mouse button is released while the mouse 

pointer is over this element. 

MouseUp Occurs when any mouse button is released over this element. 

MouseWheel Occurs when the user rotates the mouse wheel while the mouse 

pointer is over this element. 

PreviewDragEnter Occurs when the input system reports an underlying drag event 

with this element as the drag target. 

PreviewDragLeave Occurs when the input system reports an underlying drag event 

with this element as the drag origin. 

PreviewDragOver Occurs when the input system reports an underlying drag event 

with this element as the potential drop target. 
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FrameworkContentElement 

PreviewDrop Occurs when the input system reports an underlying drop event 

with this element as the drop target. 

PreviewGiveFeedback Occurs when a drag-and-drop operation is started. 

PreviewGotKeyboardFocus Occurs when the keyboard is focused on this element. 

PreviewKeyDown Occurs when a key is pressed while the keyboard is focused on this 

element. 

PreviewKeyUp Occurs when a key is released while the keyboard is focused on this 

element. 

PreviewLostKeyboardFocus Occurs when the keyboard is no longer focused on this element. 

PreviewMouseDown Occurs when any mouse button is pressed while the pointer is over 

this element. 

PreviewMouseLeftButtonDown Occurs when the left mouse button is pressed while the mouse 

pointer is over this element. 

PreviewMouseLeftButtonUp Occurs when the left mouse button is released while the mouse 

pointer is over this element. 

PreviewMouseMove Occurs when the mouse pointer moves while the mouse pointer is 

over this element. 

PreviewMouseRightButtonDown Occurs when the right mouse button is pressed while the mouse 

pointer is over this element. 

PreviewMouseRightButtonUp Occurs when the right mouse button is released while the mouse 

pointer is over this element. 

PreviewMouseUp Occurs when any mouse button is released while the mouse pointer 

is over this element. 

PreviewMouseWheel Occurs when the user rotates the mouse wheel while the mouse 

pointer is over this element. 

PreviewQueryContinueDrag Occurs when there is a change in the keyboard or mouse button 

state during a drag-and-drop operation. 

PreviewStylusButtonDown Occurs when the stylus button is pressed while the pointer is over 

this element. 

PreviewStylusButtonUp Occurs when the stylus button is released while the pointer is over 

this element. 

PreviewStylusDown Occurs when the stylus touches the digitizer while it is over this 

element. 

PreviewStylusInAirMove Occurs when the stylus moves over an element without actually 

touching the digitizer. 

PreviewStylusInRange Occurs when the stylus is close enough to the digitizer to be 

detected, while over this element. 

PreviewStylusMove Occurs when the stylus moves while over the element. The stylus 
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FrameworkContentElement 

must move while being detected by the  digitizer  to raise this 

event, otherwise, PreviewStylusInAirMove is raised instead. 

PreviewStylusOutOfRange Occurs when the stylus is too far from the digitizer to be detected. 

PreviewStylusSystemGesture Occurs when a user performs one of several stylus gestures. 

PreviewStylusUp Occurs when the user raises the stylus off the digitizer while the 

stylus is over this element. 

PreviewTextInput Occurs when this element gets text in a device-independent 

manner. 

PreviewTouchDown Occurs when a finger touches the screen while the finger is over 

this element. 

PreviewTouchMove Occurs when a finger moves on the screen while the finger is over 

this element. 

PreviewTouchUp Occurs when a finger is raised off of the screen while the finger is 

over this element. 

QueryContinueDrag Occurs when there is a change in the keyboard or mouse button 

state during a drag-and-drop operation. 

QueryCursor Occurs when the cursor is requested to display. This event is raised 

on an element each time that the mouse pointer moves to a new 

location, which means the cursor object might need to be changed 

based on its new position. 

StylusButtonDown Occurs when the stylus button is pressed while the pointer is over 

this element. 

StylusButtonUp Occurs when the stylus button is released while the pointer is over 

this element. 

StylusDown Occurs when the stylus touches the digitizer while the stylus is over 

this element. 

StylusEnter Occurs when the stylus enters the bounds of this element. 

StylusInAirMove Occurs when the stylus moves over an element without actually 

touching the digitizer. 

StylusInRange Occurs when the stylus is close enough to the digitizer to be 

detected, while over this element. 

StylusLeave Occurs when the stylus leaves the bounds of the element. 

StylusMove Occurs when the stylus moves over this element. The stylus must 

move while on the digitizer to raise this event. Otherwise, 

StylusInAirMove is raised instead. 

StylusOutOfRange Occurs when the stylus is too far from the digitizer to be detected, 

while over this element. 

StylusSystemGesture Occurs when a user performs one of several stylus gestures. 
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FrameworkContentElement 

StylusUp Occurs when the user raises the stylus off the digitizer while it is 

over this element. 

TextInput Occurs when this element gets text in a device-independent 

manner. 

TouchDown Occurs when a finger touches the screen while the finger is over 

this element. 

TouchEnter Occurs when a touch moves from outside to inside the bounds of 

this element. 

TouchLeave Occurs when a touch moves from inside to outside the bounds of 

this element. 

TouchMove Occurs when a finger moves on the screen while the finger is over 

this element. 

TouchUp Occurs when a finger is raised off of the screen while the finger is 

over this element. 

4.126   ContentOperations 

x:Object > ContentOperations 

(usage) None. 

(description) Provides ways for manipulating the position of a ContentElement in an 

element tree. 

[is default constructible] false 

(attachable properties)  

ContentOperations.Parent DependencyObject 

(description)  

[target type] ContentElement 

4.127   ContentPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > ContentPresenter, 
IInputElement 

DataGridDetailsPresenter RibbonContentPresenter ScrollContentPresenter 

(usage) <ContentPresenter /> 

(description) Displays the content of a ContentControl. 

[name property] Name 

[xml lang property] Language 
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DataGridDetailsPresenter RibbonContentPresenter ScrollContentPresenter 

(properties)  

Content x:Object 

(description) The data used to generate the child elements of a ContentPresenter. 

ContentSource x:String 

(description) The base name to use during automatic aliasing. 

ContentStringFormat x:String 

(description) A composite string that specifies how to format the Content property if it is 

displayed as a string. 

ContentTemplate DataTemplate 

(description) The template used to display the content of the control. 

ContentTemplateSelector DataTemplateSelector 

(description) The DataTemplateSelector, which allows the application writer to provide 

custom logic for choosing the template that is used to display the content 

of the control. 

RecognizesAccessKey x:Boolean 

(description) A value that indicates whether the ContentPresenter should use AccessText 

in its style. 

4.128   ContextMenu 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > MenuBase > ContextMenu, IInputElement 

RibbonContextMenu 

(usage) <ContextMenu>x:Object*</ContextMenu> 

(description) Represents a pop-up menu that enables a control to expose functionality that is 

specific to the context of the control. 

(used by) ContextMenuService FrameworkContentElement FrameworkElement GridView 

GridViewHeaderRowPresenter 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

HasDropShadow x:Boolean 

(description) A value that indicates whether the context menu appears with a dropped 

shadow. 
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RibbonContextMenu 

HorizontalOffset x:Double 

(description) Get or sets the horizontal distance between the target origin and the popup 

alignment point. 

[text syntax] LengthSyntax 

IsOpen x:Boolean 

(description) A value that indicates whether the ContextMenu is visible. 

Placement PlacementMode 

(description) The Placement property of a ContextMenu. 

PlacementRectangle Rect 

(description) The area relative to which the context menu is positioned when it opens. 

PlacementTarget UIElement 

(description) The UIElement relative to which the ContextMenu is positioned when it opens. 

StaysOpen x:Boolean 

(description) A value that indicates whether the ContextMenu should close automatically. 

VerticalOffset x:Double 

(description) Get or sets the vertical distance between the target origin and the popup 

alignment point. 

[text syntax] LengthSyntax 

(events)  

Closed Occurs when a particular instance of a ContextMenu closes. 

Opened Occurs when a particular instance of a context menu opens. 

4.129   ContextMenuService 

x:Object > ContextMenuService 

(usage) None. 

(description) Provides the system implementation for displaying a 

ContextMenu. 

[is default constructible] false 

(attachable properties)  

ContextMenuService.ContextMenu ContextMenu 

(description) The content of a ContextMenu. 
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(usage) None. 

[target type] DependencyObject 

ContextMenuService.HasDropShadow x:Boolean 

(description) A value that indicates whether the ContextMenu has the 

drop shadow effect enabled. 

[target type] DependencyObject 

ContextMenuService.HorizontalOffset x:Double 

(description) A value that indicates where along the x-direction to 

place the ContextMenu with respect to the parent 

control. 

[target type] DependencyObject 

[text syntax] LengthSyntax 

ContextMenuService.IsEnabled x:Boolean 

(description) A value that indicates whether the ContextMenu can be 

shown. 

[target type] DependencyObject 

ContextMenuService.Placement PlacementMode 

(description) A value that specifies the placement of the ContextMenu 

relative to the PlacementTarget or PlacementRectangle. 

[target type] DependencyObject 

ContextMenuService.PlacementRectangle Rect 

(description) The area relative to which the context menu is 

positioned when it opens. 

[target type] DependencyObject 

ContextMenuService.PlacementTarget UIElement 

(description) The parent control of the ContextMenu. 

[target type] DependencyObject 

ContextMenuService.ShowOnDisabled x:Boolean 

(description) A value that indicates whether the ContextMenu should 

be shown when its parent is grayed out. 

[target type] DependencyObject 

ContextMenuService.VerticalOffset x:Double 

(description) A value that indicates where along the y-direction to 

place the ContextMenu with respect to the parent 

control. 
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(usage) None. 

[target type] DependencyObject 

[text syntax] LengthSyntax 

(attachable events)  

ContextMenuService.ContextMenuClosing  

ContextMenuService.ContextMenuOpening  

4.130   Control 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control, IInputElement 

Calendar CalendarItem ContentControl DataGridRow DatePicker DocumentViewerBase 

FlowDocumentReader FlowDocumentScrollViewer ItemsControl KeyTipControl PasswordBox 

RangeBase ResizeGrip RibbonContextualTabGroup RibbonTwoLineText Separator TextBoxBase 

Thumb 

(usage) <Control /> 

(description) Represents the base type for user interface (UI) elements that 

use a ControlTemplate to define their appearance. 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) A brush that describes the background of a control. 

BorderBrush Brush 

(description) A brush that describes the border background of a control. 

BorderThickness Thickness 

(description) The border thickness of a control. 

FontFamily FontFamily 

(description) The font family of the control. 

FontSize x:Double 

(description) The font size. 

[text syntax] FontSizeSyntax 

FontStretch FontStretch 

(description) The degree to which a font is condensed or expanded on the 

screen. 
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Calendar CalendarItem ContentControl DataGridRow DatePicker DocumentViewerBase 

FlowDocumentReader FlowDocumentScrollViewer ItemsControl KeyTipControl PasswordBox 

RangeBase ResizeGrip RibbonContextualTabGroup RibbonTwoLineText Separator TextBoxBase 

Thumb 

FontStyle FontStyle 

(description) The font style. 

FontWeight FontWeight 

(description) The weight or thickness of the specified font. 

Foreground Brush 

(description) A brush that describes the foreground color. 

HorizontalContentAlignment HorizontalAlignment 

(description) The horizontal alignment of the control's content. 

IsTabStop x:Boolean 

(description) A value that indicates whether a control is included in tab 

navigation. 

Padding Thickness 

(description) The padding inside a control. 

TabIndex x:Int32 

(description) A value that determines the order in which elements receive focus 

when the user navigates through controls by using the TAB key. 

Template ControlTemplate 

(description) A control template. 

VerticalContentAlignment VerticalAlignment 

(description) The vertical alignment of the control's content. 

(events)  

MouseDoubleClick Occurs when a mouse button is clicked two or more times. 

PreviewMouseDoubleClick Occurs when a user clicks the mouse button two or more times. 

4.131   ControllableStoryboardAction 

x:Object > DependencyObject > TriggerAction > ControllableStoryboardAction 

PauseStoryboard RemoveStoryboard ResumeStoryboard SeekStoryboard 

SetStoryboardSpeedRatio SkipStoryboardToFill StopStoryboard 

(usage) None. 

(description) Manipulates a Storyboard that has been applied by a BeginStoryboard 
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PauseStoryboard RemoveStoryboard ResumeStoryboard SeekStoryboard 

SetStoryboardSpeedRatio SkipStoryboardToFill StopStoryboard 

action. 

[is default constructible] false 

(properties)  

BeginStoryboardName x:String 

(description) The Name of the BeginStoryboard that began the Storyboard you want to 

interactively control. 

4.132   ControlTemplate 

x:Object > FrameworkTemplate > ControlTemplate 

(usage) <ControlTemplate>FrameworkElement</ControlTemplate> 

(description) Specifies the visual structure and behavioral aspects of a Control that can be shared 

across multiple instances of the control. 

(used by) Control DataGrid DataGridRow Page Validation 

[content 

property] 

Template 

[dictionary key 

property] 

TargetType 

[is name scope] true 

(properties)  

TargetType x:XamlType 

(description) The type for which this ControlTemplate is intended. 

Triggers TriggerCollection 

(description) A collection of TriggerBase objects that apply property changes or perform actions 

based on specified conditions. 

[read only] true 

4.133   CoreCompatibilityPreferences 

x:Object > CoreCompatibilityPreferences 

(usage) {x:Static 

CoreCompatibilityPreferences.StaticPropertyName} 

(description)  

[is default constructible] false 

(static properties)  
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(usage) {x:Static 

CoreCompatibilityPreferences.StaticPropertyName} 

IsAltKeyRequiredInAccessKeyDefaultScope x:Boolean 

(description)  

4.134   CornerRadius 

x:Object > CornerRadius 

(usage) <CornerRadius> string </CornerRadius> 

(description) Represents the radii of a rectangle's corners. 

(used by) Border RibbonButton RibbonControlService RibbonRadioButton RibbonToggleButton 

WindowChrome 

[is nullable] false 

[text 

syntax] 

CornerRadiusSyntax 

(properties)  

BottomLeft x:Double 

(description) The radius of the bottom-left corner. 

BottomRight x:Double 

(description) The radius of the bottom-right corner. 

TopLeft x:Double 

(description) The radius of the top-left corner. 

TopRight x:Double 

(description) The radius of the top-right corner. 

4.135   CroppedBitmap 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 

CroppedBitmap 

(usage) <CroppedBitmap> string </CroppedBitmap> 

(description) Crops a BitmapSource. 

[text syntax] x:Uri, from [MS-XAML] 

(properties)  

Source BitmapSource 

(description) The source for the bitmap. 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) <CroppedBitmap> string </CroppedBitmap> 

SourceRect Int32Rect 

(description) The rectangular area that the bitmap is cropped to. 

4.136   CubicEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > CubicEase, IEasingFunction 

(usage) <CubicEase /> 

(description) Represents an easing function that creates an animation that accelerates and/or 

decelerates using the formula f(t) = t3. 

4.137   Cursor 

x:Object > Cursor 

(usage) AppStarting| Arrow| ArrowCD| Cross| Hand| Help| IBeam| No| None... 

(description) Represents the image used for the mouse pointer. 

(used by) FrameworkContentElement FrameworkElement 

[is default constructible] false 

[text syntax] CursorSyntax 

4.138   Cursors 

x:Object > Cursors 

(usage) {x:Static Cursors.StaticPropertyName} 

(description) Defines a set of default cursors. 

[is default 

constructible] 

false 

(static properties)  

AppStarting Cursor 

(description) The Cursor that appears when an application is starting. 

Arrow Cursor 

(description) The Arrow Cursor. 

ArrowCD Cursor 

(description) The arrow with a compact disk Cursor. 

Cross Cursor 



 

132 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) {x:Static Cursors.StaticPropertyName} 

(description) The crosshair Cursor. 

Hand Cursor 

(description) A hand Cursor. 

Help Cursor 

(description) A help Cursor which is a combination of an arrow and a question mark. 

IBeam Cursor 

(description) An I-beam Cursor, which is used to show where the text cursor appears when 

the mouse is clicked. 

No Cursor 

(description) A Cursor with which indicates that a particular region is invalid for a given 

operation. 

None Cursor 

(description) A special cursor that is invisible. 

Pen Cursor 

(description) A pen Cursor. 

ScrollAll Cursor 

(description) The scroll all Cursor. 

ScrollE Cursor 

(description) The scroll east Cursor. 

ScrollN Cursor 

(description) The scroll north Cursor. 

ScrollNE Cursor 

(description) The scroll northeast cursor. 

ScrollNS Cursor 

(description) The scroll north/south cursor. 

ScrollNW Cursor 

(description) A scroll northwest cursor. 

ScrollS Cursor 

(description) The scroll south Cursor. 

ScrollSE Cursor 

(description) A south/east scrolling Cursor. 
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(usage) {x:Static Cursors.StaticPropertyName} 

ScrollSW Cursor 

(description) The scroll southwest Cursor. 

ScrollW Cursor 

(description) The scroll west Cursor. 

ScrollWE Cursor 

(description) A west/east scrolling Cursor. 

SizeAll Cursor 

(description) A four-headed sizing Cursor, which consists of four joined arrows that point 

north, south, east, and west. 

SizeNESW Cursor 

(description) A two-headed northeast/southwest sizing Cursor. 

SizeNS Cursor 

(description) A two-headed north/south sizing Cursor. 

SizeNWSE Cursor 

(description) A two-headed northwest/southeast sizing Cursor. 

SizeWE Cursor 

(description) A two-headed west/east sizing Cursor. 

UpArrow Cursor 

(description) An up arrow Cursor, which is typically used to identify an insertion point. 

Wait Cursor 

(description) Specifies a wait (or hourglass) Cursor. 

4.139   CursorType 

x:Object > CursorType 

(usage) None| No| Arrow| AppStarting| Cross| Help| IBeam| SizeAll| SizeNESW... 

(description) Specifies the built in cursor types. 

[is nullable] false 

[text syntax] CursorTypeSyntax 

4.140   CustomPopupPlacement 

x:Object > CustomPopupPlacement 
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(usage) <CustomPopupPlacement /> 

(description) Defines custom placement parameters for a Popup control. 

[is nullable] false 

(properties)  

Point Point 

(description) The point that is relative to the target object where the upper-left corner of the Popup 

control is placedl. 

PrimaryAxis PopupPrimaryAxis 

(description) The direction in which to move a Popup control when the Popup is obscured by screen 

boundaries. 

4.141   DashStyle 

x:Object > DependencyObject > Freezable > Animatable > DashStyle 

(usage) Dash| DashDot| DashDotDot| Dot| Solid 

(description) Represents the sequence of dashes and gaps that will be applied by a Pen. 

(used by) Pen 

(properties)  

Dashes DoubleCollection 

(description) The collection of dashes and gaps in this DashStyle. 

Offset x:Double 

(description) How far in the dash sequence the stroke will start. 

4.142   DashStyles 

x:Object > DashStyles 

(usage) {x:Static DashStyles.StaticPropertyName} 

(description) Implements a set of predefined DashStyle objects. 

[is default constructible] false 

(static properties)  

Dash DashStyle 

(description) A DashStyle with a Dashes property equal to 2,2. 

DashDot DashStyle 

(description) A DashStyle with a Dashes property equal to 2,2,0,2. 



 

135 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) {x:Static DashStyles.StaticPropertyName} 

DashDotDot DashStyle 

(description) A DashStyle with a Dashes property equal to 2,2,0,2,0,2. 

Dot DashStyle 

(description) A DashStyle with a Dashes property equal to 0,2. 

Solid DashStyle 

(description) A DashStyle with an empty Dashes property. 

4.143   DataErrorValidationRule 

x:Object > ValidationRule > DataErrorValidationRule 

(usage) <DataErrorValidationRule /> 

(description) Represents a rule that checks for errors that are raised by the IDataErrorInfo 

implementation of the source object. 

4.144   DataGrid 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > Selector > MultiSelector > DataGrid, IInputElement 

(usage) <DataGrid>x:Object*</DataGrid> 

(description) Represents a control that displays data in a customizable grid. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

AlternatingRowBackground Brush 

(description) The background brush for use on alternating rows. 

AreRowDetailsFrozen x:Boolean 

(description) A value that indicates whether the row details can scroll horizontally. 

AutoGenerateColumns x:Boolean 

(description) A value that indicates whether the columns are created automatically. 

CanUserAddRows x:Boolean 

(description) A value that indicates whether the user can add new rows to the 

DataGrid. 
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(usage) <DataGrid>x:Object*</DataGrid> 

CanUserDeleteRows x:Boolean 

(description) A value that indicates whether the user can delete rows from the 

DataGrid. 

CanUserReorderColumns x:Boolean 

(description) A value that indicates whether the user can change the column 

display order by dragging column headers with the mouse. 

CanUserResizeColumns x:Boolean 

(description) A value that indicates whether the user can adjust the width of 

columns by using the mouse. 

CanUserResizeRows x:Boolean 

(description) A value that indicates whether the user can adjust the height of rows 

by using the mouse. 

CanUserSortColumns x:Boolean 

(description) A value that indicates whether the user can sort columns by clicking 

the column header. 

CellStyle Style 

(description) The style applied to all cells in the DataGrid. 

ClipboardCopyMode DataGridClipboardCopyMode 

(description) A value that indicates how content is copied to the clipboard. 

ColumnHeaderHeight x:Double 

(description) The height of the column headers row. 

ColumnHeaderStyle Style 

(description) The style applied to all column headers in the DataGrid. 

Columns ObservableCollection(DataGridColumn) 

(description) A collection that contains all the columns in the DataGrid. 

[read only] true 

ColumnWidth DataGridLength 

(description) The standard width and sizing mode of columns and headers in the 

DataGrid. 

CurrentCell DataGridCellInfo 

(description) The cell that has focus. 

CurrentColumn DataGridColumn 
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(usage) <DataGrid>x:Object*</DataGrid> 

(description) The column that contains the current cell. 

CurrentItem x:Object 

(description) The data item bound to the row that contains the current cell. 

DragIndicatorStyle Style 

(description) The style that is used when rendering the drag indicator that is 

displayed while dragging a column header. 

DropLocationIndicatorStyle Style 

(description) The style that is applied to indicate the drop location when dragging a 

column header. 

EnableColumnVirtualization x:Boolean 

(description) A value that indicates whether column virtualization is enabled. 

EnableRowVirtualization x:Boolean 

(description) A value that indicates whether row virtualization is enabled. 

FrozenColumnCount x:Int32 

(description) The number of non-scrolling columns. 

GridLinesVisibility DataGridGridLinesVisibility 

(description) A value that indicates which grid lines are shown. 

HeadersVisibility DataGridHeadersVisibility 

(description) The value that specifies the visibility of the row and column headers. 

HorizontalGridLinesBrush Brush 

(description) The brush that is used to draw the horizontal grid lines. 

HorizontalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates how horizontal scroll bars are displayed in the 

DataGrid. 

IsReadOnly x:Boolean 

(description) A value that indicates whether the user can edit values in the 

DataGrid. 

MaxColumnWidth x:Double 

(description) The maximum width constraint of the columns and headers in the 

DataGrid. 

MinColumnWidth x:Double 

(description) The minimum width constraint of the columns and headers in the 
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(usage) <DataGrid>x:Object*</DataGrid> 

DataGrid. 

MinRowHeight x:Double 

(description) The minimum height constraint of the rows and headers in the 

DataGrid. 

RowBackground Brush 

(description) The default brush for the row background. 

RowDetailsTemplate DataTemplate 

(description) The template that is used to display the row details. 

RowDetailsTemplateSelector DataTemplateSelector 

(description) The template selector that is used for the row details. 

RowDetailsVisibilityMode DataGridRowDetailsVisibilityMode 

(description) A value that indicates when the details section of a row is displayed. 

RowHeaderStyle Style 

(description) The style applied to all row headers. 

RowHeaderTemplate DataTemplate 

(description) The template for the row headers. 

RowHeaderTemplateSelector DataTemplateSelector 

(description) The template selector for row headers. 

RowHeaderWidth x:Double 

(description) The width of the row header column. 

RowHeight x:Double 

(description) The suggested height for all rows. 

RowStyle Style 

(description) The style applied to all rows. 

RowStyleSelector StyleSelector 

(description) The style selector for the rows. 

RowValidationErrorTemplate ControlTemplate 

(description) The template that is used to visually indicate an error in row 

validation. 

RowValidationRules ObservableCollection(ValidationRule) 

(description) The rules that are used to validate the data in each row. 
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(usage) <DataGrid>x:Object*</DataGrid> 

[read only] true 

SelectedCells IList(DataGridCellInfo) 

(description) The list of cells that are currently selected. 

[read only] true 

SelectionMode DataGridSelectionMode 

(description) A value that indicates how rows and cells are selected in the DataGrid. 

SelectionUnit DataGridSelectionUnit 

(description) A value that indicates whether rows, cells, or both can be selected in 

the DataGrid. 

VerticalGridLinesBrush Brush 

(description) The brush that is used to draw the vertical grid lines. 

VerticalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates how vertical scroll bars are displayed in the 

DataGrid. 

(static properties)  

DeleteCommand RoutedUICommand 

(description) Represents the command that indicates the intention to delete the 

current row. 

FocusBorderBrushKey ComponentResourceKey 

(description) The key that references the default border brush for a focused cell. 

HeadersVisibilityConverter IValueConverter 

(description) The converter that converts a DataGridHeadersVisibility to a Visibility. 

RowDetailsScrollingConverter IValueConverter 

(description) The converter that converts a Boolean value to a 

SelectiveScrollingOrientation. 

SelectAllCommand RoutedUICommand 

(description) Represents the command that indicates the intention to select all cells 

in the DataGrid. 

(events)  

AddingNewItem  

AutoGeneratedColumns Occurs when auto generation of all columns is completed. 

AutoGeneratingColumn Occurs when an individual column is auto-generated. 
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(usage) <DataGrid>x:Object*</DataGrid> 

BeginningEdit Occurs before a row or cell enters edit mode. 

CellEditEnding Occurs before a cell edit is committed or canceled. 

ColumnDisplayIndexChanged Occurs when the DisplayIndex property on one of the columns 

changes. 

ColumnHeaderDragCompleted Occurs when the user releases a column header after dragging it by 

using the mouse. 

ColumnHeaderDragDelta Occurs every time the mouse position changes while the user drags a 

column header. 

ColumnHeaderDragStarted Occurs when the user begins dragging a column header by using the 

mouse. 

ColumnReordered Occurs when a column moves to a new position in the display order. 

ColumnReordering Occurs before a column moves to a new position in the display order. 

CopyingRowClipboardContent Occurs after the default row content is prepared. 

CurrentCellChanged Occurs when the value of the CurrentCell property has changed. 

InitializingNewItem Occurs when a new item is created. 

LoadingRow Occurs after a DataGridRow is instantiated, so that you can customize 

it before it is used. 

LoadingRowDetails Occurs when a new row details template is applied to a row. 

PreparingCellForEdit Occurs when a cell enters edit mode. 

RowDetailsVisibilityChanged Occurs when the visibility of a row details element changes. 

RowEditEnding Occurs before a row edit is committed or canceled. 

SelectedCellsChanged Occurs when the SelectedCells collection changes. 

Sorting Occurs when a column is being sorted. 

UnloadingRow Occurs when a DataGridRow object becomes available for reuse. 

UnloadingRowDetails Occurs when a row details element becomes available for reuse. 

4.145   DataGridBoundColumn 

x:Object > DependencyObject > DataGridColumn > DataGridBoundColumn 

DataGridCheckBoxColumn DataGridHyperlinkColumn DataGridTextColumn 

(usage) None. 

(description) Serves as the base type for columns that can bind to a property in the data 

source of a DataGrid. 

[is default constructible] false 
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DataGridCheckBoxColumn DataGridHyperlinkColumn DataGridTextColumn 

(properties)  

Binding BindingBase 

(description) The binding that associates the column with a property in the data source. 

ClipboardContentBinding BindingBase 

(description) The binding object to use when getting or setting cell content for the 

clipboard. 

EditingElementStyle Style 

(description) The style that is used when rendering the element that the column displays 

for a cell in editing mode. 

ElementStyle Style 

(description) The style that is used when rendering the element that the column displays 

for a cell that is not in editing mode. 

4.146   DataGridCell 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > DataGridCell, IInputElement 

(usage) <DataGridCell>x:Object</DataGridCell> 

(description) Represents a cell of a DataGrid control. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

IsEditing x:Boolean 

(description) A value that indicates whether the cell is in edit mode. 

IsSelected x:Boolean 

(description) A value that indicates whether the cell is selected. 

(events)  

Selected Occurs when the cell is selected. 

Unselected Occurs when the cell selection is cleared. 

4.147   DataGridCellInfo 

x:Object > DataGridCellInfo 
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(usage) <DataGridCellInfo /> 

(description) Represents information about a specific cell in a DataGrid. 

(used by) DataGrid 

[is nullable] false 

4.148   DataGridCellsPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > 
VirtualizingPanel > DataGridCellsPanel, IInputElement 

(usage) <DataGridCellsPanel>UIElement*</DataGridCellsPanel> 

(description) Represents a panel that lays out cells and column headers in a data grid. 

[content property] Children 

[name property] Name 

[xml lang property] Language 

4.149   DataGridCellsPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > DataGridCellsPresenter, IInputElement 

(usage) <DataGridCellsPresenter>x:Object*</DataGridCellsPresenter> 

(description) Used within the template of a DataGrid to specify the location in the control's visual 

tree where the cells are to be added. 

[content 

property] 

Items 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

Item x:Object 

(description) The data item that the row represents. 

4.150   DataGridCheckBoxColumn 

x:Object > DependencyObject > DataGridColumn > DataGridBoundColumn > 
DataGridCheckBoxColumn 

(usage) <DataGridCheckBoxColumn /> 
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(usage) <DataGridCheckBoxColumn /> 

(description) Represents a DataGrid column that hosts CheckBox controls in its cells. 

(properties)  

IsThreeState x:Boolean 

(description) A value that indicates whether the hosted CheckBox controls enable 

three states or two. 

(static properties)  

DefaultEditingElementStyle Style 

(description) The default value of the EditingElementStyle property. 

DefaultElementStyle Style 

(description) The default value of the ElementStyle property. 

4.151   DataGridClipboardCellContent 

x:Object > DataGridClipboardCellContent 

(usage) <DataGridClipboardCellContent /> 

(description) Encapsulates the value and location of a DataGrid cell for use when copying content to 

the Clipboard. 

[is nullable] false 

4.152   DataGridClipboardCopyMode 

x:Object > DataGridClipboardCopyMode 

(usage) None| ExcludeHeader| IncludeHeader 

(description) Defines constants that specify whether users can copy data from a DataGrid control to 

the Clipboard and whether column header values are included. 

(used by) DataGrid 

[is nullable] false 

[text 

syntax] 

DataGridClipboardCopyModeSyntax 

4.153   DataGridColumn 

x:Object > DependencyObject > DataGridColumn 

DataGridBoundColumn DataGridComboBoxColumn DataGridTemplateColumn 

(usage) None. 
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DataGridBoundColumn DataGridComboBoxColumn DataGridTemplateColumn 

(description) Represents a DataGrid column. 

(used by) DataGrid 

[is default constructible] false 

(properties)  

CanUserReorder x:Boolean 

(description) A value that indicates whether the user can change the column display 

position by dragging the column header. 

CanUserResize x:Boolean 

(description) A value that indicates whether the user can adjust the column width by 

using the mouse. 

CanUserSort x:Boolean 

(description) A value that indicates whether the user can sort the column by clicking 

the column header. 

CellStyle Style 

(description) The style that is used to render cells in the column. 

ClipboardContentBinding BindingBase 

(description) The binding object to use when getting or setting cell content for the 

clipboard. 

DisplayIndex x:Int32 

(description) The display position of the column relative to the other columns in the 

DataGrid. 

DragIndicatorStyle Style 

(description) The style object to apply to the column header during a drag operation. 

Header x:Object 

(description) The content of the column header. 

HeaderStringFormat x:String 

(description) The format pattern to apply to the content of the column header. 

HeaderStyle Style 

(description) The style that is used when rendering the column header. 

HeaderTemplate DataTemplate 

(description) The template that defines the visual representation of the column 

header. 
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DataGridBoundColumn DataGridComboBoxColumn DataGridTemplateColumn 

HeaderTemplateSelector DataTemplateSelector 

(description) The object that selects which template to use for the column header. 

IsReadOnly x:Boolean 

(description) A value that indicates whether cells in the column can be edited. 

MaxWidth x:Double 

(description) The maximum width constraint of the column. 

MinWidth x:Double 

(description) The minimum width constraint of the column. 

SortDirection x:Nullable(ListSortDirection) 

(description) The sort direction (ascending or descending) of the column. 

SortMemberPath x:String 

(description) A property name, or a period-delimited hierarchy of property names, 

that indicates the member to sort by. 

Visibility Visibility 

(description) The visibility of the column. 

Width DataGridLength 

(description) The column width or automatic sizing mode. 

(events)  

CopyingCellClipboardContent Occurs after the cell clipboard content is prepared. 

PastingCellClipboardContent Occurs before the clipboard content is moved to the cell. 

4.154   DataGridColumnHeader 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ButtonBase > DataGridColumnHeader, IInputElement 

(usage) <DataGridColumnHeader>x:Object</DataGridColumnHeader> 

(description) Represents an individual DataGrid column header. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

SeparatorBrush Brush 
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(usage) <DataGridColumnHeader>x:Object</DataGridColumnHeader> 

(description) The Brush used to paint the column header separator lines. 

SeparatorVisibility Visibility 

(description) The user interface (UI) visibility of the column header 

separator lines. 

(static properties)  

ColumnFloatingHeaderStyleKey ComponentResourceKey 

(description) The key that references the style for displaying column 

headers during a header drag operation. 

ColumnHeaderDropSeparatorStyleKey ComponentResourceKey 

(description) The key that references the style for the drop location 

indicator during a header drag operation. 

4.155   DataGridColumnHeadersPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > DataGridColumnHeadersPresenter, IInputElement 

(usage) <DataGridColumnHeadersPresenter>x:Object*</DataGridColumnHeadersPresenter> 

(description) Used within the template of a DataGrid to specify the location in the control's visual tree 

where the column headers are to be added. 

[content 

property] 

Items 

[name 

property] 

Name 

[xml lang 

property] 

Language 

4.156   DataGridComboBoxColumn 

x:Object > DependencyObject > DataGridColumn > DataGridComboBoxColumn 

(usage) <DataGridComboBoxColumn /> 

(description) Represents a DataGrid column that hosts ComboBox controls in its 

cells. 

(properties)  

ClipboardContentBinding BindingBase 

(description) The binding object to use when getting or setting cell content for the 

clipboard. 

DisplayMemberPath x:String 
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(usage) <DataGridComboBoxColumn /> 

(description) A path to a value on the source object to provide the visual 

representation of the object. 

EditingElementStyle Style 

(description) The style that is used when rendering the element that the column 

displays for a cell in editing mode. 

ElementStyle Style 

(description) The style that is used when rendering the element that the column 

displays for a cell that is not in editing mode. 

ItemsSource IEnumerable 

(description) A collection that is used to generate the content of the combo box 

control. 

SelectedItemBinding BindingBase 

(description) The binding for the currently selected item. 

SelectedValueBinding BindingBase 

(description) The value of the selected item, obtained by using SelectedValuePath. 

SelectedValuePath x:String 

(description) The path that is used to get the SelectedValue from the SelectedItem. 

TextBinding BindingBase 

(description) The binding for the text in the text box portion of the ComboBox 

control. 

(static properties)  

DefaultEditingElementStyle Style 

(description) The default value of the EditingElementStyle property. 

DefaultElementStyle Style 

(description) The default value of the ElementStyle. 

TextBlockComboBoxStyleKey ComponentResourceKey 

(description) The resource key for the style to apply to a read-only combo box. 

4.157   DataGridDetailsPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > ContentPresenter > 

DataGridDetailsPresenter, IInputElement 

(usage) <DataGridDetailsPresenter /> 

(description) Used within the template of a DataGrid to specify the location in the control's visual 
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(usage) <DataGridDetailsPresenter /> 

tree where the row details are to be added. 

[name property] Name 

[xml lang 

property] 

Language 

4.158   DataGridEditAction 

x:Object > DataGridEditAction 

(usage) Cancel| Commit 

(description) Defines constants that specify whether an edit is being canceled or committed. 

[is nullable] false 

[text syntax] DataGridEditActionSyntax 

4.159   DataGridEditingUnit 

x:Object > DataGridEditingUnit 

(usage) Cell| Row 

(description) Defines constants that specify whether editing is enabled on a cell level or on a row level. 

[is nullable] false 

[text syntax] DataGridEditingUnitSyntax 

4.160   DataGridGridLinesVisibility 

x:Object > DataGridGridLinesVisibility 

(usage) All| Horizontal| None| Vertical 

(description) Defines constants that specify the visibility of the grid lines in a DataGrid. 

(used by) DataGrid 

[is nullable] false 

[text syntax] DataGridGridLinesVisibilitySyntax 

4.161   DataGridHeadersVisibility 

x:Object > DataGridHeadersVisibility 

(usage) All| Column| Row| None 

(description) Defines constants that specify the visibility of row and column headers in a DataGrid. 
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(usage) All| Column| Row| None 

(used by) DataGrid 

[is nullable] false 

[text syntax] DataGridHeadersVisibilitySyntax 

4.162   DataGridHyperlinkColumn 

x:Object > DependencyObject > DataGridColumn > DataGridBoundColumn > 
DataGridHyperlinkColumn 

(usage) <DataGridHyperlinkColumn /> 

(description) Represents a DataGrid column that hosts Uri elements in its cells. 

(properties)  

ContentBinding BindingBase 

(description) The binding to the text of the hyperlink. 

TargetName x:String 

(description) The name of a target window or frame for the hyperlink. 

(static properties)  

DefaultEditingElementStyle Style 

(description) The default value of the EditingElementStyle property. 

DefaultElementStyle Style 

(description) The default value of the ElementStyle property. 

4.163   DataGridLength 

x:Object > DataGridLength 

(usage) <DataGridLength> string </DataGridLength> 

(description) Represents the lengths of elements within the DataGrid control. 

(used by) DataGrid DataGridColumn 

[is nullable] false 

[text syntax] DataGridLengthSyntax 

(static 

properties) 

 

Auto DataGridLength 

(description) A DataGridLength structure that represents the standard automatic sizing mode. 
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(usage) <DataGridLength> string </DataGridLength> 

SizeToCells DataGridLength 

(description) A DataGridLength structure that represents the cell-based automatic sizing mode. 

SizeToHeader DataGridLength 

(description) A DataGridLength structure that represents the header-based automatic sizing 

mode. 

4.164   DataGridLengthUnitType 

x:Object > DataGridLengthUnitType 

(usage) Auto| Pixel| SizeToCells| SizeToHeader| Star 

(description) Defines constants that specify how elements in a DataGrid are sized. 

[is nullable] false 

[text syntax] DataGridLengthUnitTypeSyntax 

4.165   DataGridRow 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

DataGridRow, IInputElement 

(usage) <DataGridRow /> 

(description) Represents a DataGrid row. 

[name property] Name 

[xml lang property] Language 

(properties)  

DetailsTemplate DataTemplate 

(description) The template that is used to display the details section of the row. 

DetailsTemplateSelector DataTemplateSelector 

(description) A template selector that provides custom logic for choosing a row details 

template. 

DetailsVisibility Visibility 

(description) A value that indicates when the details section of the row is displayed. 

Header x:Object 

(description) An object that represents the row header contents. 

HeaderStyle Style 



 

151 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <DataGridRow /> 

(description) The style that is used when rendering the row header. 

HeaderTemplate DataTemplate 

(description) The template that is used to display the row header. 

HeaderTemplateSelector DataTemplateSelector 

(description) A template selector that provides custom logic for choosing a row header 

template. 

IsSelected x:Boolean 

(description) A value that indicates whether the row is selected. 

Item x:Object 

(description) The data item that the row represents. 

ItemsPanel ItemsPanelTemplate 

(description) The template that defines the panel that controls the layout of cells in the 

row. 

ValidationErrorTemplate ControlTemplate 

(description) The template that is used to visually indicate an error in row validation. 

(events)  

Selected Occurs when the row is selected. 

Unselected Occurs when the row selection is cleared. 

4.166   DataGridRowDetailsVisibilityMode 

x:Object > DataGridRowDetailsVisibilityMode 

(usage) Collapsed| Visible| VisibleWhenSelected 

(description) Defines constants that specify when DataGrid row details are displayed. 

(used by) DataGrid 

[is nullable] false 

[text syntax] DataGridRowDetailsVisibilityModeSyntax 

4.167   DataGridRowHeader 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ButtonBase > DataGridRowHeader, IInputElement 

(usage) <DataGridRowHeader>x:Object</DataGridRowHeader> 
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(usage) <DataGridRowHeader>x:Object</DataGridRowHeader> 

(description) Represents an individual DataGrid row header. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

SeparatorBrush Brush 

(description) The Brush used to paint the row header separator lines. 

SeparatorVisibility Visibility 

(description) The user interface (UI) visibility of the row header separator lines. 

4.168   DataGridRowsPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > 
VirtualizingPanel > VirtualizingStackPanel > DataGridRowsPresenter, IInputElement 

(usage) <DataGridRowsPresenter>UIElement*</DataGridRowsPresenter> 

(description) Used within the template of a DataGrid to specify the location in the control's visual 

tree where the rows are to be added. 

[content 

property] 

Children 

[name 

property] 

Name 

[xml lang 

property] 

Language 

4.169   DataGridSelectionMode 

x:Object > DataGridSelectionMode 

(usage) Single| Extended 

(description) Defines constants that specify whether single or multiple item selections are supported 

by a DataGrid control. 

(used by) DataGrid 

[is nullable] false 

[text 

syntax] 

DataGridSelectionModeSyntax 
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4.170   DataGridSelectionUnit 

x:Object > DataGridSelectionUnit 

(usage) Cell| FullRow| CellOrRowHeader 

(description) Defines constants that specify whether cells, rows, or both, are used for selection in a 

DataGrid control. 

(used by) DataGrid 

[is nullable] false 

[text 

syntax] 

DataGridSelectionUnitSyntax 

4.171   DataGridTemplateColumn 

x:Object > DependencyObject > DataGridColumn > DataGridTemplateColumn 

(usage) <DataGridTemplateColumn /> 

(description) Represents a DataGrid column that hosts template-specified content in 

its cells. 

(properties)  

CellEditingTemplate DataTemplate 

(description) The template to use to display the contents of a cell that is in editing 

mode. 

CellEditingTemplateSelector DataTemplateSelector 

(description) The object that determines which template to use to display the 

contents of a cell that is in editing mode. 

CellTemplate DataTemplate 

(description) The template to use to display the contents of a cell that is not in editing 

mode. 

CellTemplateSelector DataTemplateSelector 

(description) The object that determines which template to use to display the 

contents of a cell that is not in editing mode. 

4.172   DataGridTextColumn 

x:Object > DependencyObject > DataGridColumn > DataGridBoundColumn > DataGridTextColumn 

(usage) <DataGridTextColumn /> 

(description) Represents a DataGrid column that hosts textual content in its cells. 

(properties)  
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(usage) <DataGridTextColumn /> 

FontFamily FontFamily 

(description) The font family for the content of cells in the column. 

FontSize x:Double 

(description) The font size for the content of cells in the column. 

[text syntax] FontSizeSyntax 

FontStyle FontStyle 

(description) The font style for the content of cells in the column. 

FontWeight FontWeight 

(description) The font weight for the content of cells in the column. 

Foreground Brush 

(description) The Brush that is used to paint the text contents of cells in the column. 

(static properties)  

DefaultEditingElementStyle Style 

(description) The default value of the EditingElementStyle property. 

DefaultElementStyle Style 

(description) The default value of the ElementStyle property. 

4.173   DataObject 

x:Object > DataObject 

(usage) <DataObject /> 

(description) Provides a basic implementation of the IDataObject interface, which defines a 

format-independent mechanism for transferring data. 

(attachable events)  

DataObject.Copying Occurs when the associated dependency object has prepared appropriate 

data formats that represent the copy selection, added the copy selection 

formats to a DataObject, and is ready to either place the DataObject on the 

Clipboard or begin a drag-and-drop operation. 

DataObject.Pasting Occurs when the associated dependency object is ready to paste data. 

DataObject.SettingData Occurs when the associated dependency object attempts to add a new data 

format to a DataObject. 

4.174   DataTemplate 

x:Object > FrameworkTemplate > DataTemplate 
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HierarchicalDataTemplate ItemContainerTemplate 

(usage) <DataTemplate>FrameworkElement</DataTemplate> 

(description) Describes the visual structure of a data object. 

(used by) ContentControl ContentPresenter DataGrid DataGridColumn DataGridRow 

DataGridTemplateColumn GridView GridViewColumn GridViewHeaderRowPresenter 

GroupStyle HeaderedContentControl HeaderedItemsControl 

HierarchicalDataTemplate ItemsControl Ribbon RibbonApplicationMenu 

RibbonContextualTabGroup RibbonGallery RibbonGroupTemplateSizeDefinition 

TabControl 

[content 

property] 

Template 

[dictionary key 

property] 

DataTemplateKey 

[is name scope] true 

(properties)  

DataTemplateKey x:Object 

(description) The default key of the DataTemplate. 

[read only] true 

DataType x:Object 

(description) The type for which this DataTemplate is intended. 

Triggers TriggerCollection 

(description) A collection of triggers that apply property values or perform actions based on one 

or more conditions. 

[read only] true 

4.175   DataTemplateKey 

x:Object > x:MarkupExtension > ResourceKey > TemplateKey > DataTemplateKey 

(usage) {DataTemplateKey } | <DataTemplateKey /> 

(description) Represents the resource key for the DataTemplate type. 

[return value 

type] 

ResourceKey 

[constructors]  

(1 parameter)  

dataType x:Object 

(description) The type for which this template is designed. This is either a Type (to indicate that the 

DataTemplate is used to display items of the given type), or a string (to indicate that 
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(usage) {DataTemplateKey } | <DataTemplateKey /> 

the DataTemplate is used to display XmlNode elements with the given tag name). 

4.176   DataTemplateSelector 

x:Object > DataTemplateSelector 

(usage) <DataTemplateSelector /> 

(description) Provides a way to choose a DataTemplate based on the data object and the data-bound 

element. 

(used by) ContentControl ContentPresenter DataGrid DataGridColumn DataGridRow 

DataGridTemplateColumn GridView GridViewColumn GridViewHeaderRowPresenter 

GroupStyle HeaderedContentControl HeaderedItemsControl HierarchicalDataTemplate 

ItemsControl RibbonApplicationMenu RibbonContextualTabGroup RibbonGallery 

TabControl 

4.177   DataTrigger 

x:Object > DependencyObject > TriggerBase > DataTrigger 

(usage) <DataTrigger>SetterBase*</DataTrigger> 

(description) Represents a trigger that applies property values or performs actions when the bound 

data meets a specified condition. 

[content 

property] 

Setters 

(properties)  

Binding BindingBase 

(description) The binding that produces the property value of the data object. 

Setters SetterBaseCollection 

(description) A collection of Setter objects, which describe the property values to apply when the 

data item meets the specified condition. 

[read only] true 

Value x:Object 

(description) The value to be compared with the property value of the data object. 

4.178   DatePicker 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > DatePicker, 
IInputElement 

(usage) <DatePicker /> 

(description) Represents a control that allows the user to select a date. 
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(usage) <DatePicker /> 

[name property] Name 

[xml lang property] Language 

(properties)  

BlackoutDates CalendarBlackoutDatesCollection 

(description) A collection of dates that are marked as not selectable. 

[read only] true 

CalendarStyle Style 

(description) The style that is used when rendering the calendar. 

DisplayDate x:DateTime 

(description) The date to display. 

DisplayDateEnd x:Nullable(x:DateTime) 

(description) The last date to be displayed. 

DisplayDateStart x:Nullable(x:DateTime) 

(description) The first date to be displayed. 

FirstDayOfWeek DayOfWeek 

(description) The day that is considered the beginning of the week. 

IsDropDownOpen x:Boolean 

(description) A value that indicates whether the drop-down Calendar is open or closed. 

IsTodayHighlighted x:Boolean 

(description) A value that indicates whether the current date will be highlighted. 

SelectedDate x:Nullable(x:DateTime) 

(description) The currently selected date. 

SelectedDateFormat DatePickerFormat 

(description) The format that is used to display the selected date. 

Text x:String 

(description) The text that is displayed by the DatePicker, or sets the selected date. 

(events)  

CalendarClosed Occurs when the drop-down Calendar is closed. 

CalendarOpened Occurs when the drop-down Calendar is opened. 

DateValidationError Occurs when Text is set to a value that cannot be interpreted as a date or 
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(usage) <DatePicker /> 

when the date cannot be selected. 

SelectedDateChanged Occurs when the SelectedDate property is changed. 

4.179   DatePickerFormat 

x:Object > DatePickerFormat 

(usage) Long| Short 

(description) Specifies date formats for a DatePicker. 

(used by) DatePicker 

[is nullable] false 

[text syntax] DatePickerFormatSyntax 

4.180   DatePickerTextBox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

TextBoxBase > TextBox > DatePickerTextBox, IInputElement 

(usage) <DatePickerTextBox>x:String</DatePickerTextBox> 

(description) Represents the text input of a DatePicker. 

[content property] Text 

[name property] Name 

[xml lang property] Language 

4.181   DecimalAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

DecimalAnimationBase > DecimalAnimation 

(usage) <DecimalAnimation /> 

(description) Animates the value of a  Decimal property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(x:Decimal) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 
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(usage) <DecimalAnimation /> 

(description) The easing function applied to this animation. 

From x:Nullable(x:Decimal) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(x:Decimal) 

(description) The animation's ending value. 

4.182   DecimalAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

DecimalAnimationBase 

DecimalAnimation DecimalAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Decimal value. 

[is default constructible] false 

[name property] Name 

4.183   DecimalAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
DecimalAnimationBase > DecimalAnimationUsingKeyFrames 

(usage) <DecimalAnimationUsingKeyFrames>DecimalKeyFrame*</DecimalAnimationUsingKeyFrame

s> 

(description

) 

Animates the value of a Decimal property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 
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(usage) <DecimalAnimationUsingKeyFrames>DecimalKeyFrame*</DecimalAnimationUsingKeyFrame

s> 

(description

) 

A value that specifies whether the animation's output value is added to the base value of the 

property being animated. 

IsCumulativ

e 

x:Boolean 

(description

) 

A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames DecimalKeyFrameCollection 

(description

) 

The collection of DecimalKeyFrame objects that define the animation. 

4.184   DecimalKeyFrame 

x:Object > DependencyObject > Freezable > DecimalKeyFrame 

DiscreteDecimalKeyFrame EasingDecimalKeyFrame LinearDecimalKeyFrame 

SplineDecimalKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a DecimalAnimationUsingKeyFrames. 

(used by) DecimalKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value x:Decimal 

(description) The key frame's target value. 

4.185   DecimalKeyFrameCollection 

x:Object > DependencyObject > Freezable > DecimalKeyFrameCollection 

(usage) <DecimalKeyFrameCollection>DecimalKeyFrame*</DecimalKeyFrameCollection> 

(description) Represents a collection of DecimalKeyFrame objects. 

(used by) DecimalAnimationUsingKeyFrames 

[is list] true 

[allowed types] DecimalKeyFrame 
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(usage) <DecimalKeyFrameCollection>DecimalKeyFrame*</DecimalKeyFrameCollection> 

(static properties)  

Empty DecimalKeyFrameCollection 

(description) An empty DecimalKeyFrameCollection. 

4.186   Decorator 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Decorator, 
IInputElement 

AdornerDecorator Border BulletDecorator InkPresenter Viewbox 

(usage) <Decorator>UIElement</Decorator> 

(description) Provides a base type for elements that apply effects onto or around a single child 

element, such as Border or Viewbox. 

[content 

property] 

Child 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Child UIElement 

(description) The single child element of a Decorator. 

4.187   DeferrableContent 

x:Object > DeferrableContent 

(usage) <DeferrableContent> string </DeferrableContent> 

(description) Represents deferrable content that is held within BAML as a stream. 

(used by) ResourceDictionary 

[is default constructible] false 

4.188   DefinitionBase 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > DefinitionBase, 

IInputElement 

ColumnDefinition RowDefinition 

(usage) None. 

(description) Defines the functionality required to support a shared-size group that is used by 
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ColumnDefinition RowDefinition 

the ColumnDefinitionCollection and RowDefinitionCollection types. 

[is default 

constructible] 

false 

[name property] Name 

[xml lang property] Language 

(properties)  

SharedSizeGroup x:String 

(description) A value that identifies a ColumnDefinition or RowDefinition as a member of a 

defined group that shares sizing properties. 

4.189   DependencyObject 

x:Object > DependencyObject 

BindingGroup CollectionContainer CollectionViewSource ContentElement DataGridColumn 

Freezable GestureRecognizer GridViewColumn JournalEntry TextSearch TriggerAction TriggerBase 

ViewBase Visual Visual3D VisualState VisualStateGroup VisualStateManager VisualTransition 

(usage) <DependencyObject /> 

(description) A base type that supports visual and graphic elements. 

(used by) ContentOperations Storyboard Validation 

4.190   DependencyProperty 

x:Object > DependencyProperty 

(usage) <DependencyProperty> string </DependencyProperty> 

(description) Represents a property that can depend on other values. 

(used by) Condition Setter TemplateBindingExtension Trigger 

[is default constructible] false 

[text syntax] DependencyPropertySyntax 

4.191   DiffuseMaterial 

x:Object > DependencyObject > Freezable > Animatable > Material > DiffuseMaterial 

(usage) <DiffuseMaterial /> 

(description) Allows the application of a 2-D brush, like a SolidColorBrush or TileBrush, to a diffusely-

lit 3-D model. 

(properties)  
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(usage) <DiffuseMaterial /> 

AmbientColor Color 

(description) A color that represents how the material reflects AmbientLight. 

Brush Brush 

(description) Brush to be applied as a Material to a 3-D model. 

Color Color 

(description) The color filter for the material's texture. 

4.192   DirectionalLight 

x:Object > DependencyObject > Freezable > Animatable > Model3D > Light > DirectionalLight 

(usage) <DirectionalLight /> 

(description) Light object that projects its effect along a direction specified by a Vector3D. 

(properties)  

Direction Vector3D 

(description) Represents the vector along which the light's effect will be seen on models in a 3-D 

scene. 

4.193   DiscreteBooleanKeyFrame 

x:Object > DependencyObject > Freezable > BooleanKeyFrame > DiscreteBooleanKeyFrame 

(usage) <DiscreteBooleanKeyFrame /> 

(description) Animates from the Boolean value of the previous key frame to its own Value using 

discrete interpolation. 

4.194   DiscreteByteKeyFrame 

x:Object > DependencyObject > Freezable > ByteKeyFrame > DiscreteByteKeyFrame 

(usage) <DiscreteByteKeyFrame /> 

(description) Animates from the Byte value of the previous key frame to its own Value using discrete 

interpolation. 

4.195   DiscreteCharKeyFrame 

x:Object > DependencyObject > Freezable > CharKeyFrame > DiscreteCharKeyFrame 

(usage) <DiscreteCharKeyFrame /> 

(description) Animates from the Char value of the previous key frame to its own Value using discrete 
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(usage) <DiscreteCharKeyFrame /> 

interpolation. 

4.196   DiscreteColorKeyFrame 

x:Object > DependencyObject > Freezable > ColorKeyFrame > DiscreteColorKeyFrame 

(usage) <DiscreteColorKeyFrame /> 

(description) Animates from the Color value of the previous key frame to its own Value using discrete 

interpolation. 

4.197   DiscreteDecimalKeyFrame 

x:Object > DependencyObject > Freezable > DecimalKeyFrame > DiscreteDecimalKeyFrame 

(usage) <DiscreteDecimalKeyFrame /> 

(description) Animates from the Decimal value of the previous key frame to its own Value using 

discrete interpolation. 

4.198   DiscreteDoubleKeyFrame 

x:Object > DependencyObject > Freezable > DoubleKeyFrame > DiscreteDoubleKeyFrame 

(usage) <DiscreteDoubleKeyFrame /> 

(description) Animates from the Double value of the previous key frame to its own Value using 

discrete interpolation. 

4.199   DiscreteInt16KeyFrame 

x:Object > DependencyObject > Freezable > Int16KeyFrame > DiscreteInt16KeyFrame 

(usage) <DiscreteInt16KeyFrame /> 

(description) Animates from the Int16 value of the previous key frame to its own Value using discrete 

interpolation. 

4.200   DiscreteInt32KeyFrame 

x:Object > DependencyObject > Freezable > Int32KeyFrame > DiscreteInt32KeyFrame 

(usage) <DiscreteInt32KeyFrame /> 

(description) Animates from the Int32 value of the previous key frame to its own Value using discrete 

interpolation. 

4.201   DiscreteInt64KeyFrame 

x:Object > DependencyObject > Freezable > Int64KeyFrame > DiscreteInt64KeyFrame 
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(usage) <DiscreteInt64KeyFrame /> 

(description) Animates from the Int64 value of the previous key frame to its own Value using discrete 

interpolation. 

4.202   DiscreteMatrixKeyFrame 

x:Object > DependencyObject > Freezable > MatrixKeyFrame > DiscreteMatrixKeyFrame 

(usage) <DiscreteMatrixKeyFrame /> 

(description) Animates from the Matrix value of the previous key frame to its own Value using discrete 

interpolation. 

4.203   DiscreteObjectKeyFrame 

x:Object > DependencyObject > Freezable > ObjectKeyFrame > DiscreteObjectKeyFrame 

(usage) <DiscreteObjectKeyFrame /> 

(description) Animates from the Object value of the previous key frame to its own Value using discrete 

interpolation. 

4.204   DiscretePoint3DKeyFrame 

x:Object > DependencyObject > Freezable > Point3DKeyFrame > DiscretePoint3DKeyFrame 

(usage) <DiscretePoint3DKeyFrame /> 

(description) Animates from the Point3D value of the previous key frame to its own Value using 

discrete interpolation. 

4.205   DiscretePointKeyFrame 

x:Object > DependencyObject > Freezable > PointKeyFrame > DiscretePointKeyFrame 

(usage) <DiscretePointKeyFrame /> 

(description) Animates from the Point value of the previous key frame to its own Value using discrete 

interpolation. 

4.206   DiscreteQuaternionKeyFrame 

x:Object > DependencyObject > Freezable > QuaternionKeyFrame > DiscreteQuaternionKeyFrame 

(usage) <DiscreteQuaternionKeyFrame /> 

(description) Animates from the Quaternion value of the previous key frame to its own Value using 

discrete interpolation. 
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4.207   DiscreteRectKeyFrame 

x:Object > DependencyObject > Freezable > RectKeyFrame > DiscreteRectKeyFrame 

(usage) <DiscreteRectKeyFrame /> 

(description) Animates from the Rect value of the previous key frame to its own Value using discrete 

interpolation. 

4.208   DiscreteRotation3DKeyFrame 

x:Object > DependencyObject > Freezable > Rotation3DKeyFrame > DiscreteRotation3DKeyFrame 

(usage) <DiscreteRotation3DKeyFrame /> 

(description) Animates from the Rotation3D value of the previous key frame to its own Value using 

discrete interpolation. 

4.209   DiscreteSingleKeyFrame 

x:Object > DependencyObject > Freezable > SingleKeyFrame > DiscreteSingleKeyFrame 

(usage) <DiscreteSingleKeyFrame /> 

(description) Animates from the Single value of the previous key frame to its own Value using discrete 

interpolation. 

4.210   DiscreteSizeKeyFrame 

x:Object > DependencyObject > Freezable > SizeKeyFrame > DiscreteSizeKeyFrame 

(usage) <DiscreteSizeKeyFrame /> 

(description) Animates from the Size value of the previous key frame to its own Value using discrete 

interpolation. 

4.211   DiscreteStringKeyFrame 

x:Object > DependencyObject > Freezable > StringKeyFrame > DiscreteStringKeyFrame 

(usage) <DiscreteStringKeyFrame /> 

(description) Animates from the String value of the previous key frame to its own Value using discrete 

interpolation. 

4.212   DiscreteThicknessKeyFrame 

x:Object > DependencyObject > Freezable > ThicknessKeyFrame > DiscreteThicknessKeyFrame 

(usage) <DiscreteThicknessKeyFrame /> 

(description) Animates from the Thickness value of the previous key frame to its own Value using 

discrete interpolation. 
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4.213   DiscreteVector3DKeyFrame 

x:Object > DependencyObject > Freezable > Vector3DKeyFrame > DiscreteVector3DKeyFrame 

(usage) <DiscreteVector3DKeyFrame /> 

(description) Animates from the Vector3D value of the previous key frame to its own Value using 

discrete interpolation. 

4.214   DiscreteVectorKeyFrame 

x:Object > DependencyObject > Freezable > VectorKeyFrame > DiscreteVectorKeyFrame 

(usage) <DiscreteVectorKeyFrame /> 

(description) Animates from the Vector value of the previous key frame to its own Value using discrete 

interpolation. 

4.215   Dock 

x:Object > Dock 

(usage) Left| Top| Right| Bottom 

(description) Specifies the Dock position of a child element that is inside a DockPanel. 

(used by) DockPanel TabControl 

[is nullable] false 

[text syntax] DockSyntax 

4.216   DockPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > DockPanel, 
IInputElement 

(usage) <DockPanel>UIElement*</DockPanel> 

(description) Defines an area where you can arrange child elements either horizontally or 

vertically, relative to each other. 

[content property] Children 

[name property] Name 

[xml lang property] Language 

(properties)  

LastChildFill x:Boolean 

(description) A value that indicates whether the last child element within a DockPanel stretches 

to fill the remaining available space. 

(attachable  
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(usage) <DockPanel>UIElement*</DockPanel> 

properties) 

DockPanel.Dock Dock 

(description) A value that indicates the position of a child element within a parent DockPanel. 

[target type] UIElement 

4.217   DocumentPageView 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > DocumentPageView, 
IInputElement 

(usage) <DocumentPageView /> 

(description) Represents a viewport for a paginated DocumentPage. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

PageNumber x:Int32 

(description) The page number of the current page displayed. 

Stretch Stretch 

(description) A Stretch enumeration that specifies how content should be stretched to fill the 

display page. 

StretchDirection StretchDirection 

(description) A StretchDirection enumeration that specifies in what scaling directions Stretch 

should be applied. 

(events)  

PageConnected Occurs when a Visual element of the DocumentPage is connected. 

PageDisconnected Occurs when a Visual element of the DocumentPage is disconnected. 

4.218   DocumentReference 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > DocumentReference, 
IInputElement 

(usage) <DocumentReference /> 

(description) Provides access to reference a FixedDocument. 

(used by) DocumentReferenceCollection 
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(usage) <DocumentReference /> 

[name property] Name 

[xml lang property] Language 

(properties)  

Source x:Uri 

(description) The uniform resource identifier (URI) for this document reference. 

4.219   DocumentReferenceCollection 

x:Object > DocumentReferenceCollection 

(usage) None. 

(description) Defines an ordered list of DocumentReference elements. 

(used by) FixedDocumentSequence 

[is default constructible] false 

[is list] true 

[allowed types] DocumentReference 

(events)  

CollectionChanged Occurs when an element is added or removed. 

4.220   DocumentViewer 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

DocumentViewerBase > DocumentViewer, IInputElement 

(usage) <DocumentViewer>IDocumentPaginatorSource</DocumentViewer> 

(description) Represents a document viewing control that can host paginated 

FixedDocument content such as an XpsDocument. 

[content property] Document 

[name property] Name 

[xml lang property] Language 

(properties)  

HorizontalOffset x:Double 

(description) The horizontal scroll position. 

HorizontalPageSpacing x:Double 

(description) The horizontal space between pages. 



 

170 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <DocumentViewer>IDocumentPaginatorSource</DocumentViewer> 

MaxPagesAcross x:Int32 

(description) A value defining the maximum number of page columns to display. 

ShowPageBorders x:Boolean 

(description) A value that indicates whether drop-shadow page borders are 

displayed. 

VerticalOffset x:Double 

(description) The vertical scroll position. 

VerticalPageSpacing x:Double 

(description) The vertical spacing between displayed pages. 

Zoom x:Double 

(description) The document zoom percentage. 

(static properties)  

FitToHeightCommand RoutedUICommand 

(description) The RoutedUICommand that performs the FitToHeight operation. 

FitToMaxPagesAcrossCommand RoutedUICommand 

(description) The RoutedUICommand that performs the MaxPagesAcross operation. 

FitToWidthCommand RoutedUICommand 

(description) The RoutedUICommand that performs the FitToWidth operation. 

ViewThumbnailsCommand RoutedUICommand 

(description) The RoutedUICommand that performs the ViewThumbnails operation. 

4.221   DocumentViewerBase 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
DocumentViewerBase, IInputElement 

DocumentViewer FlowDocumentPageViewer 

(usage) None. 

(description) Provides a base type for viewers that are intended to display 

fixed or flow content (represented by a FixedDocument or 

FlowDocument, respectively). 

[is default constructible] false 

[content property] Document 

[name property] Name 
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DocumentViewer FlowDocumentPageViewer 

[xml lang property] Language 

(properties)  

Document IDocumentPaginatorSource 

(description) A IDocumentPaginatorSource to be paginated and displayed by 

the viewer. 

(attachable properties)  

DocumentViewerBase.IsMasterPage x:Boolean 

(description) A value that indicates whether or not a child element in the 

viewer should be used as a master page. 

[target type] DependencyObject 

(events)  

PageViewsChanged Occurs when the collection of DocumentPageView items 

associated with this viewer (represented by the PageViews 

property) changes. 

4.222   DoubleAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
DoubleAnimationBase > DoubleAnimation 

(usage) <DoubleAnimation /> 

(description) Animates the value of a  Double property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(x:Double) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(x:Double) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 
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(usage) <DoubleAnimation /> 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(x:Double) 

(description) The animation's ending value. 

4.223   DoubleAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
DoubleAnimationBase 

DoubleAnimation DoubleAnimationUsingKeyFrames DoubleAnimationUsingPath 

(usage) None. 

(description) A base type that animates a Double value. 

[is default constructible] false 

[name property] Name 

4.224   DoubleAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
DoubleAnimationBase > DoubleAnimationUsingKeyFrames 

(usage) <DoubleAnimationUsingKeyFrames>DoubleKeyFrame*</DoubleAnimationUsingKeyFrames> 

(description) Animates the value of a Double property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value of 

the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames DoubleKeyFrameCollection 

(description) The collection of DoubleKeyFrame objects that define the animation. 

4.225   DoubleAnimationUsingPath 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
DoubleAnimationBase > DoubleAnimationUsingPath 
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(usage) <DoubleAnimationUsingPath /> 

(description) Animates the value of a Double property between two or more target values using a 

PathGeometry to specify those values. This animation can be used to move a visual 

object along a path. 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

PathGeometry PathGeometry 

(description) Specifies the geometry used to generate this animation's output values. 

Source PathAnimationSource 

(description) The aspect of this animation's PathGeometry that determines its output value. 

4.226   DoubleCollection 

x:Object > DependencyObject > Freezable > DoubleCollection 

(usage) <DoubleCollection> string </DoubleCollection> 

(description) Represents an ordered collection of Double values. 

(used by) ContainerVisual DashStyle GuidelineSet Shape Slider TickBar VisualTreeHelper 

[text syntax] DoubleCollectionSyntax 

[is list] true 

[allowed types] x:Double 

4.227   DoubleKeyFrame 

x:Object > DependencyObject > Freezable > DoubleKeyFrame 

DiscreteDoubleKeyFrame EasingDoubleKeyFrame LinearDoubleKeyFrame SplineDoubleKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a DoubleAnimationUsingKeyFrames. 

(used by) DoubleKeyFrameCollection 
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DiscreteDoubleKeyFrame EasingDoubleKeyFrame LinearDoubleKeyFrame SplineDoubleKeyFrame 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value x:Double 

(description) The key frame's target value. 

4.228   DoubleKeyFrameCollection 

x:Object > DependencyObject > Freezable > DoubleKeyFrameCollection 

(usage) <DoubleKeyFrameCollection>DoubleKeyFrame*</DoubleKeyFrameCollection> 

(description) Represents a collection of DoubleKeyFrame objects. 

(used by) DoubleAnimationUsingKeyFrames 

[is list] true 

[allowed types] DoubleKeyFrame 

(static properties)  

Empty DoubleKeyFrameCollection 

(description) An empty DoubleKeyFrameCollection. 

4.229   DragAction 

x:Object > DragAction 

(usage) Continue| Drop| Cancel 

(description) Specifies how and if a drag-and-drop operation should continue. 

[is nullable] false 

[text syntax] DragActionSyntax 

4.230   DragDropEffects 

x:Object > DragDropEffects 

(usage) None| Copy| Move| Link| Scroll| All 

(description) Specifies the effects of a drag-and-drop operation. 

[is nullable] false 
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(usage) None| Copy| Move| Link| Scroll| All 

[text syntax] DragDropEffectsSyntax 

4.231   DragDropKeyStates 

x:Object > DragDropKeyStates 

(usage) None| LeftMouseButton| RightMouseButton| ShiftKey| ControlKey| 

MiddleMouseButton| AltKey 

(description) Specifies the current state of the modifier keys (SHIFT, CTRL, and ALT), as well as the 

state of the mouse buttons. 

[is nullable] false 

[text 

syntax] 

DragDropKeyStatesSyntax 

4.232   Drawing 

x:Object > DependencyObject > Freezable > Animatable > Drawing 

DrawingGroup GeometryDrawing GlyphRunDrawing ImageDrawing VideoDrawing 

(usage) None. 

(description) A base type that describes a 2-D drawing. 

(used by) DrawingBrush DrawingCollection DrawingImage 

[is default constructible] false 

4.233   DrawingAttributes 

x:Object > DrawingAttributes 

(usage) <DrawingAttributes /> 

(description) Specifies the appearance of a Stroke 

(used by) InkCanvas Stroke 

(properties)  

Color Color 

(description) The color of a Stroke. 

FitToCurve x:Boolean 

(description) A value that indicates whether Bezier smoothing is used to render the Stroke. 

Height x:Double 

(description) The height of the stylus used to draw the Stroke. 
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(usage) <DrawingAttributes /> 

IgnorePressure x:Boolean 

(description) A value that indicates whether the thickness of a Stroke changes according to 

the amount of pressure applied. 

IsHighlighter x:Boolean 

(description) A value that indicates whether the Stroke looks like a highlighter. 

StylusTip StylusTip 

(description) The shape of the stylus used to draw the Stroke. 

StylusTipTransform Matrix 

(description) The Matrix that specifies the transformation to perform on the stylus' tip. 

Width x:Double 

(description) The width of the stylus used to draw the Stroke. 

(events)  

AttributeChanged Occurs when a property in the DrawingAttributes object changes. 

PropertyDataChanged Occurs when property data is added or removed from the StrokeCollection. 

4.234   DrawingBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > TileBrush > DrawingBrush 

(usage) <DrawingBrush> string </DrawingBrush> 

(description) Paints an area with a Drawing, which can include shapes, text, video, images, or other 

drawings. 

[text 

syntax] 

BrushSyntax 

(properties)  

Drawing Drawing 

(description) The Drawing that describes the contents of this DrawingBrush. 

4.235   DrawingCollection 

x:Object > DependencyObject > Freezable > Animatable > DrawingCollection 

(usage) <DrawingCollection>Drawing*</DrawingCollection> 

(description) Represents an ordered collection of Drawing objects. 

(used by) DrawingGroup 
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(usage) <DrawingCollection>Drawing*</DrawingCollection> 

[is list] true 

[allowed types] Drawing 

4.236   DrawingGroup 

x:Object > DependencyObject > Freezable > Animatable > Drawing > DrawingGroup 

(usage) <DrawingGroup>Drawing*</DrawingGroup> 

(description) Represents a collection of drawings that can be operated upon as a single drawing. 

[content property] Children 

(properties)  

Children DrawingCollection 

(description) The Drawing objects that are contained in this DrawingGroup. 

ClipGeometry Geometry 

(description) The clip region of this DrawingGroup. 

GuidelineSet GuidelineSet 

(description) The GuidelineSet to apply to this DrawingGroup. 

Opacity x:Double 

(description) The opacity of this DrawingGroup. 

OpacityMask Brush 

(description) The brush used to alter the opacity of select regions of this DrawingGroup. 

Transform Transform 

(description) The Transform that is applied to this DrawingGroup. 

4.237   DrawingImage 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > DrawingImage 

(usage) <DrawingImage> string </DrawingImage> 

(description) An ImageSource that uses a Drawing for content. 

[text syntax] x:Uri, from [MS-XAML] 

(properties)  

Drawing Drawing 

(description) The drawing content for the DrawingImage. 

http://go.microsoft.com/fwlink/?LinkId=390715
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4.238   DrawingVisual 

x:Object > DependencyObject > Visual > ContainerVisual > DrawingVisual 

(usage) <DrawingVisual /> 

(description) DrawingVisual is a visual object that can be used to render vector graphics on the 

screen. The content is persisted by the system. 

4.239   DropShadowEffect 

x:Object > DependencyObject > Freezable > Animatable > Effect > DropShadowEffect 

(usage) <DropShadowEffect /> 

(description) A bitmap effect that paints a drop shadow around the target texture. 

(properties)  

BlurRadius x:Double 

(description) A value that indicates the radius of the shadow's blur effect. 

Color Color 

(description) The color of the drop shadow. 

Direction x:Double 

(description) The direction of the drop shadow. 

Opacity x:Double 

(description) The opacity of the drop shadow. 

RenderingBias RenderingBias 

(description) A value that indicates whether the system renders the drop shadow with emphasis on 

speed or quality. 

ShadowDepth x:Double 

(description) The distance of the drop shadow below the texture. 

4.240   Duration 

x:Object > Duration 

(usage) <Duration> string </Duration> 

(description) Represents the duration of time that a Timeline is active. 

(used by) Timeline VisualTransition 

[is nullable] false 

[text syntax] DurationSyntax 
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(usage) <Duration> string </Duration> 

(static properties)  

Automatic Duration 

(description) A Duration value that is automatically determined. 

Forever Duration 

(description) A Duration value that represents an infinite interval. 

4.241   DynamicResourceExtension 

x:Object > x:MarkupExtension > DynamicResourceExtension 

(usage) {DynamicResource } | <DynamicResource /> 

(description) Implements a markup extension that supports dynamic resource references made 

from XAML. 

[return value 

type] 

x:Object 

[constructors]  

(1 parameter)  

resourceKey x:Object 

(description) The key of the resource that this markup extension references. 

(properties)  

ResourceKey x:Object 

(description) The key specified by this dynamic resource reference. The key is used to lookup a 

resource in resource dictionaries, by means of an intermediate expression. 

4.242   EasingByteKeyFrame 

x:Object > DependencyObject > Freezable > ByteKeyFrame > EasingByteKeyFrame 

(usage) <EasingByteKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

ByteAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.243   EasingColorKeyFrame 

x:Object > DependencyObject > Freezable > ColorKeyFrame > EasingColorKeyFrame 
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(usage) <EasingColorKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

ColorAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.244   EasingDecimalKeyFrame 

x:Object > DependencyObject > Freezable > DecimalKeyFrame > EasingDecimalKeyFrame 

(usage) <EasingDecimalKeyFrame /> 

(description) A base type that enables you to associate easing functions with a 

DecimalAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.245   EasingDoubleKeyFrame 

x:Object > DependencyObject > Freezable > DoubleKeyFrame > EasingDoubleKeyFrame 

(usage) <EasingDoubleKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

DoubleAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.246   EasingFunctionBase 

x:Object > DependencyObject > Freezable > EasingFunctionBase, IEasingFunction 

BackEase BounceEase CircleEase CubicEase ElasticEase ExponentialEase PowerEase 

QuadraticEase QuarticEase QuinticEase SineEase 

(usage) None. 

(description) Provides the base type for all the easing functions. 

[is default constructible] false 

(properties)  
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BackEase BounceEase CircleEase CubicEase ElasticEase ExponentialEase PowerEase 

QuadraticEase QuarticEase QuinticEase SineEase 

EasingMode EasingMode 

(description) A value that specifies how the animation interpolates. 

4.247   EasingInt16KeyFrame 

x:Object > DependencyObject > Freezable > Int16KeyFrame > EasingInt16KeyFrame 

(usage) <EasingInt16KeyFrame /> 

(description) A type that enables you to associate easing functions with a 

Int16AnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.248   EasingInt32KeyFrame 

x:Object > DependencyObject > Freezable > Int32KeyFrame > EasingInt32KeyFrame 

(usage) <EasingInt32KeyFrame /> 

(description) A type that enables you to associate easing functions with a 

Int32AnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.249   EasingInt64KeyFrame 

x:Object > DependencyObject > Freezable > Int64KeyFrame > EasingInt64KeyFrame 

(usage) <EasingInt64KeyFrame /> 

(description) A type that enables you to associate easing functions with a 

Int64AnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.250   EasingMode 

x:Object > EasingMode 
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(usage) EaseIn| EaseOut| EaseInOut 

(description) Defines the modes in which types derived from EasingFunctionBase perform their easing. 

(used by) EasingFunctionBase 

[is nullable] false 

[text syntax] EasingModeSyntax 

4.251   EasingPoint3DKeyFrame 

x:Object > DependencyObject > Freezable > Point3DKeyFrame > EasingPoint3DKeyFrame 

(usage) <EasingPoint3DKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

Point3DAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.252   EasingPointKeyFrame 

x:Object > DependencyObject > Freezable > PointKeyFrame > EasingPointKeyFrame 

(usage) <EasingPointKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

PointAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.253   EasingQuaternionKeyFrame 

x:Object > DependencyObject > Freezable > QuaternionKeyFrame > EasingQuaternionKeyFrame 

(usage) <EasingQuaternionKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

QuaternionAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

UseShortestPath x:Boolean 
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(usage) <EasingQuaternionKeyFrame /> 

(description) A value that indicates whether the animation will automatically flip the sign of the 

destination quaternion to ensure the shortest path is taken. 

4.254   EasingRectKeyFrame 

x:Object > DependencyObject > Freezable > RectKeyFrame > EasingRectKeyFrame 

(usage) <EasingRectKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

RectAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.255   EasingRotation3DKeyFrame 

x:Object > DependencyObject > Freezable > Rotation3DKeyFrame > EasingRotation3DKeyFrame 

(usage) <EasingRotation3DKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

Rotation3DAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.256   EasingSingleKeyFrame 

x:Object > DependencyObject > Freezable > SingleKeyFrame > EasingSingleKeyFrame 

(usage) <EasingSingleKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

SingleAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.257   EasingSizeKeyFrame 

x:Object > DependencyObject > Freezable > SizeKeyFrame > EasingSizeKeyFrame 
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(usage) <EasingSizeKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

SizeAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.258   EasingThicknessKeyFrame 

x:Object > DependencyObject > Freezable > ThicknessKeyFrame > EasingThicknessKeyFrame 

(usage) <EasingThicknessKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

ThicknessAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.259   EasingVector3DKeyFrame 

x:Object > DependencyObject > Freezable > Vector3DKeyFrame > EasingVector3DKeyFrame 

(usage) <EasingVector3DKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

Vector3DAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 

4.260   EasingVectorKeyFrame 

x:Object > DependencyObject > Freezable > VectorKeyFrame > EasingVectorKeyFrame 

(usage) <EasingVectorKeyFrame /> 

(description) A type that enables you to associate easing functions with a 

VectorAnimationUsingKeyFrames key frame animation. 

(properties)  

EasingFunction IEasingFunction 

(description) The easing function applied to the key frame. 
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4.261   EdgeMode 

x:Object > EdgeMode 

(usage) Unspecified| Aliased 

(description) Determines how the edges of non-text drawing primitives are rendered. 

(used by) RenderOptions 

[is nullable] false 

[text syntax] EdgeModeSyntax 

4.262   EdgeProfile 

x:Object > EdgeProfile 

(usage) Linear| CurvedIn| CurvedOut| BulgedUp 

(description) Specifies the type of curve to apply to the edge of a bitmap. 

[is nullable] false 

[text syntax] EdgeProfileSyntax 

4.263   EditingCommands 

x:Object > EditingCommands 

(usage) {x:Static EditingCommands.StaticPropertyName} 

(description) Provides a standard set of editing related commands. 

[is default 

constructible] 

false 

(static properties)  

AlignCenter RoutedUICommand 

(description) Represents the AlignCenter command, which requests that the current 

paragraph or a selection of paragraphs be centered. 

AlignJustify RoutedUICommand 

(description) Represents the AlignJustify command, which requests that the current 

paragraph or a selection of paragraphs be justified. 

AlignLeft RoutedUICommand 

(description) Represents the AlignLeft command, which requests that a selection of 

content be aligned left. 

AlignRight RoutedUICommand 

(description) Represents the AlignRight command, which requests that a selection of 
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(usage) {x:Static EditingCommands.StaticPropertyName} 

content be aligned right. 

Backspace RoutedUICommand 

(description) Represents the Backspace command, which requests that a backspace be 

entered at the current position or over the current selection. 

CorrectSpellingError RoutedUICommand 

(description) Represents the CorrectSpellingError command, which requests that any 

misspelled word at the current position be corrected. 

DecreaseFontSize RoutedUICommand 

(description) Represents the DecreaseFontSize command, which requests that the font 

size for the current selection be decreased by 1 point. 

DecreaseIndentation RoutedUICommand 

(description) Represents the DecreaseIndentation command, which requests that 

indentation for the current paragraph be decreased by one tab stop. 

Delete RoutedUICommand 

(description) Represents the Delete command, which requests that the current selection 

be deleted. 

DeleteNextWord RoutedUICommand 

(description) Represents the DeleteNextWord command, which requests that the next 

word (relative to a current position) be deleted. 

DeletePreviousWord RoutedUICommand 

(description) Represents the DeletePreviousWord command, which requests that the 

previous word (relative to a current position) be deleted. 

EnterLineBreak RoutedUICommand 

(description) Represents the EnterLineBreak command, which requests that a line break 

be inserted at the current position or over the current selection. 

EnterParagraphBreak RoutedUICommand 

(description) Represents the EnterParagraphBreak command, which requests that a 

paragraph break be inserted at the current position or over the current 

selection. 

IgnoreSpellingError RoutedUICommand 

(description) Represents the IgnoreSpellingError command, which requests that any 

instances of misspelled words at the current position or in the current 

selection be ignored. 

IncreaseFontSize RoutedUICommand 

(description) Represents the IncreaseFontSize command, which requests that the font 

size for the current selection be increased by 1 point. 
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(usage) {x:Static EditingCommands.StaticPropertyName} 

IncreaseIndentation RoutedUICommand 

(description) Represents the IncreaseIndentation command, which requests that 

indentation for the current paragraph be increased by one tab stop. 

MoveDownByLine RoutedUICommand 

(description) Represents the MoveDownByLine command, which requests that the caret 

move down by one line. 

MoveDownByPage RoutedUICommand 

(description) Represents the MoveDownByPage command, which requests that the caret 

move down by one page. 

MoveDownByParagraph RoutedUICommand 

(description) Represents the MoveDownByParagraph command, which requests that the 

caret move down by one paragraph. 

MoveLeftByCharacter RoutedUICommand 

(description) Represents the MoveLeftByCharacter command, which requests that the 

caret move one character left. 

MoveLeftByWord RoutedUICommand 

(description) Represents the MoveLeftByWord command, which requests that the caret 

move one word left. 

MoveRightByCharacter RoutedUICommand 

(description) Represents the MoveRightByCharacter command, which requests that the 

caret move one character right. 

MoveRightByWord RoutedUICommand 

(description) Represents the MoveRightByWord command, which requests that the caret 

move right by one word. 

MoveToDocumentEnd RoutedUICommand 

(description) Represents the MoveToDocumentEnd command, which requests that the 

caret move to the very end of content. 

MoveToDocumentStart RoutedUICommand 

(description) Represents the MoveToDocumentStart command, which requests that the 

caret move to the very beginning of content. 

MoveToLineEnd RoutedUICommand 

(description) Represents the MoveToLineEnd command, which requests that the caret 

move to the end of the current line. 

MoveToLineStart RoutedUICommand 

(description) Represents the MoveToLineStart command, which requests that the caret 
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(usage) {x:Static EditingCommands.StaticPropertyName} 

move to the beginning of the current line. 

MoveUpByLine RoutedUICommand 

(description) Represents the MoveUpByLine command, which requests that the caret 

move up by one line. 

MoveUpByPage RoutedUICommand 

(description) Represents the MoveUpByPage command, which requests that the caret 

move up by one page. 

MoveUpByParagraph RoutedUICommand 

(description) Represents the MoveUpByParagraph command, which requests that the 

caret move up by one paragraph. 

SelectDownByLine RoutedUICommand 

(description) Represents the SelectDownByLine command, which requests that the 

current selection be expanded down by one line. 

SelectDownByPage RoutedUICommand 

(description) Represents the SelectDownByPage command, which requests that the 

current selection be expanded down by one page. 

SelectDownByParagraph RoutedUICommand 

(description) Represents the SelectDownByParagraph command, which requests that the 

current selection be expanded down by one paragraph. 

SelectLeftByCharacter RoutedUICommand 

(description) Represents the SelectLeftByCharacter command, which requests that the 

current selection be expanded left by one character. 

SelectLeftByWord RoutedUICommand 

(description) Represents the SelectLeftByWord command, which requests that the current 

selection be expanded left by one word. 

SelectRightByCharacter RoutedUICommand 

(description) Represents the SelectRightByCharacter command, which requests that the 

current selection be expanded right by one character. 

SelectRightByWord RoutedUICommand 

(description) Represents the SelectRightByWord command, which requests that the 

current selection be expanded right by one word. 

SelectToDocumentEnd RoutedUICommand 

(description) Represents the SelectToDocumentEnd command, which requests that the 

current selection be expanded to the very end of content. 

SelectToDocumentStart RoutedUICommand 
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(usage) {x:Static EditingCommands.StaticPropertyName} 

(description) Represents the SelectToDocumentStart command, which requests that the 

current selection be expanded to the very beginning of content. 

SelectToLineEnd RoutedUICommand 

(description) Represents the SelectToLineEnd command, which requests that the current 

selection be expanded to the end of the current line. 

SelectToLineStart RoutedUICommand 

(description) Represents the SelectToLineStart command, which requests that the current 

selection be expanded to the beginning of the current line. 

SelectUpByLine RoutedUICommand 

(description) Represents the SelectUpByLine command, which requests that the current 

selection be expanded up by one line. 

SelectUpByPage RoutedUICommand 

(description) Represents the SelectUpByPage command, which requests that the current 

selection be expanded  up by one page. 

SelectUpByParagraph RoutedUICommand 

(description) Represents the SelectUpByParagraph command, which requests that the 

current selection be expanded up by one paragraph. 

TabBackward RoutedUICommand 

(description) Represents the TabBackward command. 

TabForward RoutedUICommand 

(description) Represents the TabForward command. 

ToggleBold RoutedUICommand 

(description) Represents the ToggleBold command, which requests that Bold formatting 

be toggled on the current selection. 

ToggleBullets RoutedUICommand 

(description) Represents the ToggleBullets command, which requests that unordered list 

(also referred to as bulleted list) formatting be toggled on the current 

selection. 

ToggleInsert RoutedUICommand 

(description) Represents the ToggleInsert command, which toggles the typing mode 

between Insert and Overtype. 

ToggleItalic RoutedUICommand 

(description) Represents the ToggleItalic command, which requests that Italic formatting 

be toggled on the current selection. 

ToggleNumbering RoutedUICommand 
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(usage) {x:Static EditingCommands.StaticPropertyName} 

(description) Represents the ToggleNumbering command, which requests that ordered 

list (also referred to as numbered list) formatting be toggled on the current 

selection. 

ToggleSubscript RoutedUICommand 

(description) Represents the ToggleSubscript command, which requests that subscript 

formatting be toggled on the current selection. 

ToggleSuperscript RoutedUICommand 

(description) Represents the ToggleSuperscript command, which requests that 

superscript formatting be toggled on the current selection. 

ToggleUnderline RoutedUICommand 

(description) Represents the ToggleUnderline command, which requests that Underline 

formatting be toggled on the current selection. 

4.264   Effect 

x:Object > DependencyObject > Freezable > Animatable > Effect 

BlurEffect DropShadowEffect 

(usage) {x:Static Effect.StaticPropertyName} 

(description) Provides a custom bitmap effect. 

(used by) ContainerVisual UIElement 

[is default 

constructible] 

false 

(static properties)  

ImplicitInput Brush 

(description) A Brush that, when it is used as an input for an Effect, causes the bitmap of the 

UIElement that the Effect is applied to be that input. 

4.265   ElasticEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > ElasticEase, IEasingFunction 

(usage) <ElasticEase /> 

(description) Represents an easing function that creates an animation that resembles a spring 

oscillating back and forth until it comes to rest. 

(properties)  

Oscillations x:Int32 

(description) The number of times the target slides back and forth over the animation destination. 
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(usage) <ElasticEase /> 

Springiness x:Double 

(description) The stiffness of the spring. The smaller the Springiness value is, the stiffer the spring and 

the faster the elasticity decreases in intensity over each oscillation. 

4.266   Ellipse 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Shape > Ellipse, 
IInputElement 

(usage) <Ellipse /> 

(description) Draws an ellipse. 

[name property] Name 

[xml lang property] Language 

4.267   EllipseGeometry 

x:Object > DependencyObject > Freezable > Animatable > Geometry > EllipseGeometry 

(usage) <EllipseGeometry> string </EllipseGeometry> 

(description) Represents the geometry of a circle or ellipse. 

[text syntax] GeometrySyntax 

(properties)  

Center Point 

(description) The center point of the EllipseGeometry. 

RadiusX x:Double 

(description) The x-radius value of the EllipseGeometry. 

RadiusY x:Double 

(description) The y-radius value of the EllipseGeometry. 

4.268   EmissiveMaterial 

x:Object > DependencyObject > Freezable > Animatable > Material > EmissiveMaterial 

(usage) <EmissiveMaterial /> 

(description) Applies a Brush to a 3-D model so that it participates in lighting calculations as if the 

Material were emitting light equal to the color of the Brush. 

(properties)  

Brush Brush 
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(usage) <EmissiveMaterial /> 

(description) The Brush applied by the EmissiveMaterial. 

Color Color 

(description) The color filter for the material's texture. 

4.269   EventPrivateKey 

x:Object > EventPrivateKey 

(usage) <EventPrivateKey /> 

(description) Provides unique identification for events whose handlers are stored into an internal 

hashtable. 

4.270   EventSetter 

x:Object > SetterBase > EventSetter 

(usage) <EventSetter /> 

(description) Represents an event setter in a style. Event setters invoke the specified event 

handlers in response to events. 

(properties)  

Event RoutedEvent 

(description) The particular routed event that this EventSetter responds to. 

HandledEventsToo x:Boolean 

(description) A value that determines whether the handler assigned to the setter should still be 

invoked, even if the event is marked handled in its event data. 

4.271   EventTrigger 

x:Object > DependencyObject > TriggerBase > EventTrigger 

(usage) <EventTrigger>TriggerAction*</EventTrigger> 

(description) Represents a trigger that applies a set of actions in response to an event. 

[content 

property] 

Actions 

(properties)  

Actions TriggerActionCollectiont 

(description) The collection of actions to apply when the event occurs. 

[read only] true 
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(usage) <EventTrigger>TriggerAction*</EventTrigger> 

RoutedEvent RoutedEvent 

(description) The RoutedEvent that will activate this trigger. 

SourceName x:String 

(description) The name of the object with the event that activates this trigger. This is only used by 

element triggers or template triggers. 

4.272   ExceptionValidationRule 

x:Object > ValidationRule > ExceptionValidationRule 

(usage) <ExceptionValidationRule /> 

(description) Represents a rule that checks for exceptions that are thrown during the update of the 

binding source property. 

4.273   ExpandDirection 

x:Object > ExpandDirection 

(usage) Down| Up| Left| Right 

(description) Specifies the direction in which an Expander control opens. 

(used by) Expander 

[is nullable] false 

[text syntax] ExpandDirectionSyntax 

4.274   Expander 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > HeaderedContentControl > Expander, IInputElement 

(usage) <Expander>x:Object</Expander> 

(description) Represents the control that displays a header that has a collapsible window that 

displays content. 

[content property] Content 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

ExpandDirection ExpandDirection 

(description) The direction in which the Expander content window opens. 
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(usage) <Expander>x:Object</Expander> 

IsExpanded x:Boolean 

(description) Whether the Expander content window is visible. 

(events)  

Collapsed Occurs when the content window of an Expander control closes and only the 

Header is visible. 

Expanded Occurs when the content window of an Expander control opens to display both its 

header and content. 

4.275   ExponentialEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > ExponentialEase, 
IEasingFunction 

(usage) <ExponentialEase /> 

(description) Represents an easing function that creates an animation that accelerates and/or 

decelerates using an exponential formula. 

(properties)  

Exponent x:Double 

(description) The exponent used to determine the interpolation of the animation. 

4.276   FamilyTypeface 

x:Object > FamilyTypeface 

(usage) <FamilyTypeface /> 

(description) Specifies the details of a single typeface supported by a FontFamily. 

(used by) FamilyTypefaceCollection 

(properties)  

AdjustedFaceNames IDictionary(XmlLanguage,x:String) 

(description) A collection of localized face names adjusted by the font differentiator. 

[read only] true 

CapsHeight x:Double 

(description) The distance from baseline to top of an English capital, relative to em 

size. 

DeviceFontCharacterMetrics CharacterMetricsDictionary 

(description) The collection of character metrics for a device font family typeface. 
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(usage) <FamilyTypeface /> 

[read only] true 

DeviceFontName x:String 

(description) The name or unique identifier for a device font family typeface. 

Stretch FontStretch 

(description) The designed stretch of the font family typeface. 

StrikethroughPosition x:Double 

(description) The position of the strikethrough value relative to the baseline. The 

value is also relative to em size. 

StrikethroughThickness x:Double 

(description) The thickness of the strikethrough relative to em size. 

Style FontStyle 

(description) The style of the font family typeface design. 

UnderlinePosition x:Double 

(description) The position of underline value relative to the baseline. The value is also 

relative to em size. 

UnderlineThickness x:Double 

(description) The thickness of underline relative to em size. 

Weight FontWeight 

(description) The designed weight of this font family typeface. 

XHeight x:Double 

(description) The Western x-height relative to em size. 

4.277   FamilyTypefaceCollection 

x:Object > FamilyTypefaceCollection 

(usage) None. 

(description) Represents a collection of FamilyTypeface instances. 

(used by) FontFamily 

[is default constructible] false 

[is list] true 

[allowed types] FamilyTypeface 
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4.278   Figure 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > AnchoredBlock > Figure, IInputElement 

(usage) <Figure>Block*</Figure> 

(description) An inline-level flow content element used to host a figure. A figure is a portion of 

flow content with placement properties that can be customized independently 

from the primary content flow within a FlowDocument. 

[content property] Blocks 

[name property] Name 

[xml lang property] Language 

(properties)  

CanDelayPlacement x:Boolean 

(description) A value that indicates whether this figure can delay its placement in the flow of 

content. 

Height FigureLength 

(description) A value that indicates the height of a Figure element. 

HorizontalAnchor FigureHorizontalAnchor 

(description) A value that indicates the position that content is anchored to in the horizontal 

direction. 

HorizontalOffset x:Double 

(description) A value that indicates the distance that a Figure is offset from its baseline in the 

horizontal direction. 

[text syntax] LengthSyntax 

VerticalAnchor FigureVerticalAnchor 

(description) A value that indicates the position that content is anchored to in the vertical 

direction. 

VerticalOffset x:Double 

(description) A value that indicates the distance that a Figure is offset from its baseline in the 

vertical direction. 

[text syntax] LengthSyntax 

Width FigureLength 

(description) A value that indicates the width of a Figure element. 

WrapDirection WrapDirection 

(description) A value that indicates the allowable ways in which content can flow around a 

Figure. 
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4.279   FigureHorizontalAnchor 

x:Object > FigureHorizontalAnchor 

(usage) PageLeft| PageCenter| PageRight| ContentLeft| ContentCenter| ContentRight| 

ColumnLeft| ColumnCenter| ColumnRight... 

(description) Describes a position reference for a figure in a horizontal direction. 

(used by) Figure 

[is nullable] false 

[text 

syntax] 

FigureHorizontalAnchorSyntax 

4.280   FigureLength 

x:Object > FigureLength 

(usage) <FigureLength> string </FigureLength> 

(description) Describes the height or width of a Figure. 

(used by) Figure 

[is nullable] false 

[text syntax] FigureLengthSyntax 

4.281   FigureUnitType 

x:Object > FigureUnitType 

(usage) Auto| Pixel| Column| Content| Page 

(description) Describes the unit type associated with the width or height of a FigureLength. 

[is nullable] false 

[text syntax] FigureUnitTypeSyntax 

4.282   FigureVerticalAnchor 

x:Object > FigureVerticalAnchor 

(usage) PageTop| PageCenter| PageBottom| ContentTop| ContentCenter| ContentBottom| 

ParagraphTop 

(description) Describes the point of reference of a figure in the vertical direction. 

(used by) Figure 

[is nullable] false 

[text FigureVerticalAnchorSyntax 
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(usage) PageTop| PageCenter| PageBottom| ContentTop| ContentCenter| ContentBottom| 

ParagraphTop 

syntax] 

4.283   FillBehavior 

x:Object > FillBehavior 

(usage) HoldEnd| Stop 

(description) Specifies how a Timeline behaves when it is outside its active period but its parent is 

inside its active or hold period. 

(used by) Timeline 

[is nullable] false 

[text 

syntax] 

FillBehaviorSyntax 

4.284   FillRule 

x:Object > FillRule 

(usage) EvenOdd| Nonzero 

(description) Specifies how the intersecting areas of PathFigure objects contained in a Geometry are 

combined to form the area of the Geometry. 

(used by) GeometryGroup PathGeometry Polygon Polyline StreamGeometry 

[is nullable] false 

[text 

syntax] 

FillRuleSyntax 

4.285   FixedDocument 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > FixedDocument, 
IInputElement 

(usage) <FixedDocument>PageContent*</FixedDocument> 

(description) Hosts a portable, high fidelity, fixed-format document with read access for user text 

selection, keyboard navigation, and search. 

[content 

property] 

Pages 

[name 

property] 

Name 

[xml lang 

property] 

Language 
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(usage) <FixedDocument>PageContent*</FixedDocument> 

(properties)  

Pages PageContentCollection 

(description) A collection of the document's PageContent elements. 

[read only] true 

PrintTicket x:Object 

(description) The PrintTicket that is associated with this document. 

4.286   FixedDocumentSequence 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > 
FixedDocumentSequence, IInputElement 

(usage) <FixedDocumentSequence>DocumentReference*</FixedDocumentSequence> 

(description) Hosts one or more DocumentReference elements that define a sequence of fixed 

documents. 

[content 

property] 

References 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

PrintTicket x:Object 

(description) The PrintTicket that is associated with this document sequence. 

References DocumentReferenceCollection 

(description) A collection of the document sequence's DocumentReference child elements. 

[read only] true 

4.287   FixedPage 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > FixedPage, 
IInputElement 

(usage) <FixedPage>UIElement*</FixedPage> 

(description) Provides the content for a high fidelity, fixed-format page. 

(used by) PageContent 

[content property] Children 
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(usage) <FixedPage>UIElement*</FixedPage> 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) The Brush used for the page background. 

BleedBox Rect 

(description) A rectangle defining the overflow area for bleeds, registration marks, and crop 

marks. 

Children UIElementCollection 

(description) A collection of the FixedPage child elements. 

[read only] true 

ContentBox Rect 

(description) The bounding rectangle of the content area; that is, the area of the page 

within the margins, if any. 

PrintTicket x:Object 

(description) The PrintTicket that is associated with the page. 

(attachable 

properties) 

 

FixedPage.Bottom x:Double 

(description) The distance between the bottom of the page and the bottom of the parent 

Canvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

FixedPage.Left x:Double 

(description) The distance between the left edge of the page and the left edge of the parent 

Canvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

FixedPage.NavigateUri x:Uri 

(description) The URI associated with the page. 

[target type] UIElement 

FixedPage.Right x:Double 
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(usage) <FixedPage>UIElement*</FixedPage> 

(description) The distance between the right edge of the page and the right edge of the 

parent Canvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

FixedPage.Top x:Double 

(description) The distance between the top of the page and the top of the parent Canvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

4.288   Floater 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > AnchoredBlock > Floater, IInputElement 

(usage) <Floater>Block*</Floater> 

(description) Provides an inline-level flow content element used to host a floater. A floater 

displays images and other content parallel to the main content flow in a 

FlowDocument. 

[content property] Blocks 

[name property] Name 

[xml lang property] Language 

(properties)  

HorizontalAlignment HorizontalAlignment 

(description) A value that indicates the horizontal alignment for a Floater object. 

Width x:Double 

(description) A value that indicates the width of a Floater object. 

[text syntax] LengthSyntax 

4.289   FlowDirection 

x:Object > FlowDirection 

(usage) LeftToRight| RightToLeft 

(description) Defines constants that specify the content flow direction for text and user interface (UI) 

elements. 

(used by) Block FlowDocument FrameworkElement Inline ListItem TableCell 
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(usage) LeftToRight| RightToLeft 

[is nullable] false 

[text 

syntax] 

FlowDirectionSyntax 

4.290   FlowDocument 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > FlowDocument, 
IInputElement 

(usage) <FlowDocument>Block*</FlowDocument> 

(description) Hosts and formats flow content with advanced document features, such 

as pagination and columns. 

(used by) FlowDocumentReader FlowDocumentScrollViewer RichTextBox 

[content property] Blocks 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) The Brush used to fill the background of content area. 

Blocks BlockCollection 

(description) The top-level Block elements of the contents of the FlowDocument. 

[read only] true 

ColumnGap x:Double 

(description) The column gap value, which indicates the spacing between columns in 

a FlowDocument. 

[text syntax] LengthSyntax 

ColumnRuleBrush Brush 

(description) The Brush used to draw the rule between columns. 

ColumnRuleWidth x:Double 

(description) The column rule width. 

[text syntax] LengthSyntax 

ColumnWidth x:Double 

(description) The minimum desired width of the columns in a FlowDocument. 

[text syntax] LengthSyntax 
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(usage) <FlowDocument>Block*</FlowDocument> 

FlowDirection FlowDirection 

(description) The relative direction for flow of content in a FlowDocument. 

FontFamily FontFamily 

(description) The preferred top-level font family for the FlowDocument. 

FontSize x:Double 

(description) The top-level font size for the FlowDocument. 

[text syntax] FontSizeSyntax 

FontStretch FontStretch 

(description) The top-level font-stretching characteristics for the FlowDocument. 

FontStyle FontStyle 

(description) The top-level font style for the FlowDocument. 

FontWeight FontWeight 

(description) The top-level font weight for the FlowDocument. 

Foreground Brush 

(description) The Brush to apply to the text contents of the FlowDocument. 

IsColumnWidthFlexible x:Boolean 

(description) A value that indicates whether the ColumnWidth value is flexible or 

fixed. 

IsHyphenationEnabled x:Boolean 

(description) A value that indicates whether automatic hyphenation of words is 

enabled or disabled. 

IsOptimalParagraphEnabled x:Boolean 

(description) A value that indicates whether optimal paragraph layout is enabled or 

disabled. 

LineHeight x:Double 

(description) The height of each line of content. 

[text syntax] LengthSyntax 

LineStackingStrategy LineStackingStrategy 

(description) The mechanism by which a line box is determined for each line of text 

within the FlowDocument. 

MaxPageHeight x:Double 
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(usage) <FlowDocument>Block*</FlowDocument> 

(description) The maximum height for pages in a FlowDocument. 

[text syntax] LengthSyntax 

MaxPageWidth x:Double 

(description) The maximum width for pages in a FlowDocument. 

[text syntax] LengthSyntax 

MinPageHeight x:Double 

(description) The minimum height for pages in a FlowDocument. 

[text syntax] LengthSyntax 

MinPageWidth x:Double 

(description) The minimum width for pages in a FlowDocument. 

[text syntax] LengthSyntax 

PageHeight x:Double 

(description) The preferred height for pages in a FlowDocument. 

[text syntax] LengthSyntax 

PagePadding Thickness 

(description) A value that indicates the thickness of padding space between the 

boundaries of a page and the page's content. 

PageWidth x:Double 

(description) The preferred width for pages in a FlowDocument. 

[text syntax] LengthSyntax 

TextAlignment TextAlignment 

(description) A value that indicates the horizontal alignment of text content. 

TextEffects TextEffectCollection 

(description) The effects to apply to the text of a FlowDocument. 

4.291   FlowDocumentPageViewer 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

DocumentViewerBase > FlowDocumentPageViewer, IInputElement 

(usage) <FlowDocumentPageViewer>IDocumentPaginatorSource</FlowDocume

ntPageViewer> 

(description) Represents a control for viewing flow content in a fixed viewing mode 

that shows content one page at a time. 
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(usage) <FlowDocumentPageViewer>IDocumentPaginatorSource</FlowDocume

ntPageViewer> 

[content property] Document 

[name property] Name 

[xml lang property] Language 

(properties)  

IsInactiveSelectionHighlightE

nabled 

x:Boolean 

(description)  

MaxZoom x:Double 

(description) The maximum allowable Zoom level for the FlowDocumentPageViewer. 

MinZoom x:Double 

(description) The minimum allowable Zoom level for the FlowDocumentPageViewer. 

SelectionBrush Brush 

(description) The brush that highlights the selected text. 

SelectionOpacity x:Double 

(description) The opacity of the SelectionBrush. 

Zoom x:Double 

(description) The current zoom level for the FlowDocumentPageViewer. 

ZoomIncrement x:Double 

(description) The zoom increment. 

4.292   FlowDocumentReader 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
FlowDocumentReader, IInputElement 

(usage) <FlowDocumentReader>FlowDocument</FlowDocumentReader> 

(description) Provides a control for viewing flow content, with built-in support 

for multiple viewing modes. 

[content property] Document 

[name property] Name 

[xml lang property] Language 

(properties)  

Document FlowDocument 
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(usage) <FlowDocumentReader>FlowDocument</FlowDocumentReader> 

(description) A FlowDocument that hosts the content to be displayed by the 

FlowDocumentReader. 

IsFindEnabled x:Boolean 

(description) A value that indicates whether the Find routed command is 

enabled. 

IsInactiveSelectionHighlightEnabled x:Boolean 

(description)  

IsPageViewEnabled x:Boolean 

(description) A value that indicates whether Page is available as a viewing 

mode. 

IsPrintEnabled x:Boolean 

(description) A value that indicates whether the Print routed command is 

enabled. 

IsScrollViewEnabled x:Boolean 

(description) A value that indicates whether Scroll is available as a viewing 

mode. 

IsTwoPageViewEnabled x:Boolean 

(description) A value that indicates whether TwoPage is available as a viewing 

mode. 

MaxZoom x:Double 

(description) The maximum allowable Zoom level for the 

FlowDocumentReader. 

MinZoom x:Double 

(description) The minimum allowable Zoom level for the FlowDocumentReader. 

SelectionBrush Brush 

(description) The brush that highlights the selected text. 

SelectionOpacity x:Double 

(description) The opacity of the SelectionBrush. 

ViewingMode FlowDocumentReaderViewingMode 

(description) The viewing mode for the FlowDocumentReader. 

Zoom x:Double 

(description) The current zoom level. 

ZoomIncrement x:Double 
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(usage) <FlowDocumentReader>FlowDocument</FlowDocumentReader> 

(description) The zoom increment. 

4.293   FlowDocumentReaderViewingMode 

x:Object > FlowDocumentReaderViewingMode 

(usage) Page| TwoPage| Scroll 

(description) Names viewing modes for the FlowDocumentReader control. 

(used by) FlowDocumentReader 

[is nullable] false 

[text syntax] FlowDocumentReaderViewingModeSyntax 

4.294   FlowDocumentScrollViewer 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
FlowDocumentScrollViewer, IInputElement 

(usage) <FlowDocumentScrollViewer>FlowDocument</FlowDocumentScrollVi

ewer> 

(description) Provides a control for viewing flow content in a continuous scrolling 

mode. 

[content property] Document 

[name property] Name 

[xml lang property] Language 

(properties)  

Document FlowDocument 

(description) A FlowDocument that hosts the content to be displayed by the 

FlowDocumentScrollViewer. 

HorizontalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates whether a horizontal scroll bar is shown. 

IsInactiveSelectionHighlightEnab

led 

x:Boolean 

(description)  

IsSelectionEnabled x:Boolean 

(description) A value that indicates whether selection of content within the 

FlowDocumentScrollViewer is enabled. 

IsToolBarVisible x:Boolean 
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(usage) <FlowDocumentScrollViewer>FlowDocument</FlowDocumentScrollVi

ewer> 

(description) A value that indicates whether the FlowDocumentScrollViewer toolbar 

is visible. 

MaxZoom x:Double 

(description) The maximum allowable Zoom level for the 

FlowDocumentScrollViewer. 

MinZoom x:Double 

(description) The minimum allowable Zoom level for the 

FlowDocumentScrollViewer. 

SelectionBrush Brush 

(description) The brush that highlights the selected text. 

SelectionOpacity x:Double 

(description) The opacity of the SelectionBrush. 

VerticalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates whether a vertical scroll bar is shown. 

Zoom x:Double 

(description) The current zoom level. 

ZoomIncrement x:Double 

(description) The zoom increment. 

4.295   FocusManager 

x:Object > FocusManager 

(usage) None. 

(description) Provides ways for determining and setting focus scopes and for 

setting the focused element within the scope. 

[is default constructible] false 

(attachable properties)  

FocusManager.FocusedElement IInputElement 

(description) Determines whether the element this property is attached to has 

logical focus. 

[target type] DependencyObject 

FocusManager.IsFocusScope x:Boolean 

(description) Determines whether the element this property is attached to is a 
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(usage) None. 

focus scope. 

[target type] DependencyObject 

(attachable events)  

FocusManager.GotFocus  

FocusManager.LostFocus  

4.296   FocusNavigationDirection 

x:Object > FocusNavigationDirection 

(usage) Next| Previous| First| Last| Left| Right| Up| Down 

(description) Specifies the direction within a user interface (UI) in which a desired focus change 

request is attempted. The direction is either based on tab order or by relative direction in 

layout. 

[is nullable] false 

[text 

syntax] 

FocusNavigationDirectionSyntax 

4.297   FontCapitals 

x:Object > FontCapitals 

(usage) Normal| AllSmallCaps| SmallCaps| AllPetiteCaps| PetiteCaps| Unicase| Titling 

(description) Describes the capital letter style for a Typography object. 

(used by) Typography 

[is nullable] false 

[text syntax] FontCapitalsSyntax 

4.298   FontEastAsianLanguage 

x:Object > FontEastAsianLanguage 

(usage) Normal| Jis78| Jis83| Jis90| Jis04| HojoKanji| NlcKanji| Simplified| Traditional... 

(description) Provides a mechanism for the user to select font-specific versions of glyphs for a 

specified East Asian writing system or language. 

(used by) Typography 

[is nullable] false 

[text 

syntax] 

FontEastAsianLanguageSyntax 
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4.299   FontEastAsianWidths 

x:Object > FontEastAsianWidths 

(usage) Normal| Proportional| Full| Half| Third| Quarter 

(description) Provides a mechanism for the user to select glyphs of different width styles. 

(used by) Typography 

[is nullable] false 

[text syntax] FontEastAsianWidthsSyntax 

4.300   FontEmbeddingManager 

x:Object > FontEmbeddingManager 

(usage) <FontEmbeddingManager /> 

(description) Provides functionality for physical and composite font embedding. 

(properties)  

GlyphTypefaceUris ICollection(x:Uri) 

(description) Returns the collection of glyph typefaces used by the GlyphRun specified in the 

GlyphRun) method. 

[read only] true 

4.301   FontEmbeddingRight 

x:Object > FontEmbeddingRight 

(usage) Installable| InstallableButNoSubsetting| InstallableButWithBitmapsOnly| 

InstallableButNoSubsettingAndWithBitmapsOnly| RestrictedLicense| 

PreviewAndPrint| PreviewAndPrintButNoSubsetting| 

PreviewAndPrintButWithBitmapsOnly| 

PreviewAndPrintButNoSubsettingAndWithBitmapsOnly... 

(description) Describes font embedding permissions specified in an OpenType font file. 

[is nullable] false 

[text 

syntax] 

FontEmbeddingRightSyntax 

4.302   FontFamily 

x:Object > FontFamily 

(usage) <FontFamily> string </FontFamily> 

(description) Represents a family of related fonts. 
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(usage) <FontFamily> string </FontFamily> 

(used by) AccessText Control DataGridTextColumn FlowDocument Page TextBlock TextElement 

[text syntax] FontFamilySyntax 

(properties)  

Baseline x:Double 

(description) The distance between the baseline and the character cell top. 

FamilyMaps FontFamilyMapCollection 

(description) The collection of FontFamilyMap objects. 

[read only] true 

FamilyNames LanguageSpecificStringDictionary 

(description) A collection of strings and CultureInfo values that represent the font family names of 

the FontFamily object. 

[read only] true 

FamilyTypefaces FamilyTypefaceCollection 

(description) A collection of typefaces for the FontFamily object. 

[read only] true 

LineSpacing x:Double 

(description) The line spacing value for the FontFamily object. The line spacing is the 

recommended baseline-to-baseline distance for the text in this font relative to the 

em size. 

4.303   FontFamilyMap 

x:Object > FontFamilyMap 

(usage) <FontFamilyMap /> 

(description) Defines which FontFamily to use for a specified set of Unicode code points and a culture-

specific language. 

(used by) FontFamilyMapCollection 

(properties)  

Language XmlLanguage 

(description) The culture-specific language for the FontFamilyMap. 

Scale x:Double 

(description) The font scale factor for the target FontFamily. 

Target x:String 
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(usage) <FontFamilyMap /> 

(description) The target font family name for which the Unicode range applies to. 

Unicode x:String 

(description) A string value representing one or more Unicode code point ranges. 

4.304   FontFamilyMapCollection 

x:Object > FontFamilyMapCollection 

(usage) None. 

(description) Represents an ordered collection of FontFamilyMap objects. 

(used by) FontFamily 

[is default constructible] false 

[is list] true 

[allowed types] FontFamilyMap 

4.305   FontFraction 

x:Object > FontFraction 

(usage) Normal| Slashed| Stacked 

(description) Describes the fraction style for a Typography object. 

(used by) Typography 

[is nullable] false 

[text syntax] FontFractionSyntax 

4.306   FontNumeralAlignment 

x:Object > FontNumeralAlignment 

(usage) Normal| Proportional| Tabular 

(description) Describes the numeral alignment for a Typography object. 

(used by) Typography 

[is nullable] false 

[text syntax] FontNumeralAlignmentSyntax 

4.307   FontNumeralStyle 

x:Object > FontNumeralStyle 
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(usage) Normal| Lining| OldStyle 

(description) Describes the numeral style for a Typography object. 

(used by) Typography 

[is nullable] false 

[text syntax] FontNumeralStyleSyntax 

4.308   Fonts 

x:Object > Fonts 

(usage) {x:Static Fonts.StaticPropertyName} 

(description) Provides enumeration support for FontFamily and Typeface objects. 

[is default constructible] false 

(attachable properties)  

Fonts.FontFamilies ICollection(FontFamily) 

(description)  

[target type] x:String 

[read only] true 

Fonts.Typefaces ICollection(Typeface) 

(description)  

[target type] x:String 

[read only] true 

(static properties)  

4.309   FontStretch 

x:Object > FontStretch 

(usage) Condensed| Expanded| ExtraCondensed| ExtraExpanded| Medium| Normal| 

SemiCondensed| SemiExpanded| UltraCondensed... 

(description) Describes the degree to which a font has been stretched compared to the normal aspect 

ratio of that font. 

(used by) AccessText Control FamilyTypeface FlowDocument TextBlock TextElement 

[is nullable] false 

[text 

syntax] 

FontStretchSyntax 
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4.310   FontStretches 

x:Object > FontStretches 

(usage) {x:Static FontStretches.StaticPropertyName} 

(description) Provides a set of static predefined FontStretch values. 

[is default constructible] false 

(static properties)  

Condensed FontStretch 

(description) Specifies a condensed FontStretch. 

Expanded FontStretch 

(description) Specifies an expanded FontStretch. 

ExtraCondensed FontStretch 

(description) Specifies an extra-condensed FontStretch. 

ExtraExpanded FontStretch 

(description) Specifies an extra-expanded FontStretch. 

Medium FontStretch 

(description) Specifies a medium FontStretch. 

Normal FontStretch 

(description) Specifies a normal FontStretch. 

SemiCondensed FontStretch 

(description) Specifies a semi-condensed FontStretch. 

SemiExpanded FontStretch 

(description) Specifies a semi-expanded FontStretch. 

UltraCondensed FontStretch 

(description) Specifies an ultra-condensed FontStretch. 

UltraExpanded FontStretch 

(description) Specifies an ultra-expanded FontStretch. 

4.311   FontStyle 

x:Object > FontStyle 

(usage) Italic| Normal| Oblique 

(description) Defines a structure that represents the style of a font face as normal, italic, or oblique. 
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(usage) Italic| Normal| Oblique 

(used by) AccessText Control DataGridTextColumn FamilyTypeface FlowDocument TextBlock 

TextElement 

[is nullable] false 

[text 

syntax] 

FontStyleSyntax 

4.312   FontStyles 

x:Object > FontStyles 

(usage) {x:Static FontStyles.StaticPropertyName} 

(description) Provides a set of static predefined FontStyle values. 

[is default constructible] false 

(static properties)  

Italic FontStyle 

(description) Specifies an italic FontStyle. 

Normal FontStyle 

(description) Specifies a normal FontStyle. 

Oblique FontStyle 

(description) Specifies an oblique FontStyle. 

4.313   FontVariants 

x:Object > FontVariants 

(usage) Normal| Superscript| Subscript| Ordinal| Inferior| Ruby 

(description) Renders variant typographic glyph forms. 

(used by) Typography 

[is nullable] false 

[text syntax] FontVariantsSyntax 

4.314   FontWeight 

x:Object > FontWeight 

(usage) Black| Bold| DemiBold| ExtraBlack| ExtraBold| ExtraLight| Heavy| Light| 

Medium... 

(description) Refers to the density of a typeface, in terms of the lightness or heaviness of the strokes. 
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(usage) Black| Bold| DemiBold| ExtraBlack| ExtraBold| ExtraLight| Heavy| Light| 

Medium... 

(used by) AccessText Control DataGridTextColumn FamilyTypeface FlowDocument TextBlock 

TextElement 

[is nullable] false 

[text 

syntax] 

FontWeightSyntax 

4.315   FontWeights 

x:Object > FontWeights 

(usage) {x:Static FontWeights.StaticPropertyName} 

(description) Provides a set of static predefined FontWeight values. 

[is default constructible] false 

(static properties)  

Black FontWeight 

(description) Specifies a "Black" font weight. 

Bold FontWeight 

(description) Specifies a "Bold" font weight. 

DemiBold FontWeight 

(description) Specifies a "Demi-bold" font weight. 

ExtraBlack FontWeight 

(description) Specifies an "Extra-black" font weight. 

ExtraBold FontWeight 

(description) Specifies an "Extra-bold" font weight. 

ExtraLight FontWeight 

(description) Specifies an "Extra-light" font weight. 

Heavy FontWeight 

(description) Specifies a "Heavy" font weight. 

Light FontWeight 

(description) Specifies a "Light" font weight. 

Medium FontWeight 

(description) Specifies a "Medium" font weight. 
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(usage) {x:Static FontWeights.StaticPropertyName} 

Normal FontWeight 

(description) Specifies a "Normal" font weight. 

Regular FontWeight 

(description) Specifies a "Regular" font weight. 

SemiBold FontWeight 

(description) Specifies a "Semi-bold" font weight. 

Thin FontWeight 

(description) Specifies a "Thin" font weight. 

UltraBlack FontWeight 

(description) Specifies an "Ultra-black" font weight. 

UltraBold FontWeight 

(description) Specifies an "Ultra-bold" font weight. 

UltraLight FontWeight 

(description) Specifies an "Ultra-light" font weight. 

4.316   FormatConvertedBitmap 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 

FormatConvertedBitmap 

(usage) <FormatConvertedBitmap> string </FormatConvertedBitmap> 

(description) Provides pixel format conversion functionality for a BitmapSource. 

[text syntax] x:Uri, from [MS-XAML] 

(properties)  

AlphaThreshold x:Double 

(description) The alpha channel threshold of a bitmap when converting to palletized formats that 

recognizes an alpha color. 

DestinationFormat PixelFormat 

(description) The pixel format to convert the bitmap to. 

Source BitmapSource 

(description) The source for the bitmap. 

http://go.microsoft.com/fwlink/?LinkId=390715
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4.317   Frame 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > Frame, IInputElement 

(usage) <Frame /> 

(description) Frame is a content control that supports navigation. 

[name property] Name 

[xml lang property] Language 

(properties)  

JournalOwnership JournalOwnership 

(description) Whether a Frame is responsible for managing its own navigation history, or 

yields navigation history management to a parent navigator 

(NavigationWindow, Frame). 

NavigationUIVisibility NavigationUIVisibility 

(description) When the Frame can show its navigation UI. 

SandboxExternalContent x:Boolean 

(description) Whether a Frame isolates external XAML content within a partial trust 

security sandbox (with the default Internet permission set). 

Source x:Uri 

(description) The uniform resource identifier (URI) of the current content, or the URI of 

new content that is currently being navigated to. 

(events)  

ContentRendered Occurs after Frame content has been rendered. 

FragmentNavigation Occurs when navigation to a content fragment begins, which occurs 

immediately, if the desired fragment is in the current content, or after the 

source XAML content has been loaded, if the desired fragment is in different 

content. 

LoadCompleted Occurs when content that was navigated to has been loaded, parsed, and 

has begun rendering. 

Navigated Occurs when the content that is being navigated to has been found, and is 

available from the Content property, although it may not have completed 

loading. 

Navigating Occurs when a new navigation is requested. 

NavigationFailed Occurs when an error is raised while navigating to the requested content. 

NavigationProgress Occurs periodically during a download to provide navigation progress 

information. 

NavigationStopped Occurs when the StopLoading method is called, or when a new navigation is 

requested while a current navigation is in progress. 
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4.318   FrameworkCompatibilityPreferences 

x:Object > FrameworkCompatibilityPreferences 

(usage) {x:Static 

FrameworkCompatibilityPreferences.StaticPropertyNa

me} 

(description)  

[is default constructible] false 

(static properties)  

AreInactiveSelectionHighlightBrushKeysSupport

ed 

x:Boolean 

(description)  

KeepTextBoxDisplaySynchronizedWithTextPrope

rty 

x:Boolean 

(description)  

4.319   FrameworkContentElement 

x:Object > DependencyObject > ContentElement > FrameworkContentElement, IInputElement 

DefinitionBase FixedDocument FixedDocumentSequence FlowDocument TableColumn TextElement 

(usage) <FrameworkContentElement /> 

(description) Adds support for additional input (including tooltips and context menus), 

storyboards, data context for databinding, styles, and logical trees. 

FrameworkContentElement is an implementation of the ContentElement base 

type. 

[name property] Name 

[xml lang property] Language 

(properties)  

BindingGroup BindingGroup 

(description) The BindingGroup that is used for the element. 

ContextMenu ContextMenu 

(description) The context menu element that should appear whenever the context menu is 

requested via user interface (UI) from within this element. 

Cursor Cursor 

(description) The cursor that displays when the mouse pointer is over this element. 

DataContext x:Object 

(description) The data context for an element when it participates in data binding. 
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DefinitionBase FixedDocument FixedDocumentSequence FlowDocument TableColumn TextElement 

FocusVisualStyle Style 

(description) An object that enables customization of appearance, effects, or other style 

characteristics that will apply to this element when it captures keyboard focus. 

ForceCursor x:Boolean 

(description) A value indicating whether this FrameworkContentElement should force the 

user interface (UI) to render the cursor as declared by this instance's Cursor 

property. 

InputScope InputScope 

(description) The context for input used by this FrameworkContentElement. 

Language XmlLanguage 

(description) Localization/globalization language information that applies to an individual 

element. 

Name x:String 

(description) The identifying name of the element. The name provides a reference so that 

the element can be referred to after it is constructed during XAML parsing. 

OverridesDefaultStyle x:Boolean 

(description) A value indicating whether this element incorporates style properties from 

theme styles. 

Resources ResourceDictionary 

(description) The current locally-defined resource dictionary. 

Style Style 

(description) The style to be used by this element. 

Tag x:Object 

(description) An arbitrary object value that can be used to store custom information about 

this element. 

ToolTip x:Object 

(description) The tool-tip object that is displayed for this element in the user interface (UI). 

(events)  

ContextMenuClosing Occurs just before any context menu on the element is closed. 

ContextMenuOpening Occurs when any context menu on the element is opened. 

DataContextChanged Occurs when this element's data context changes. 

Initialized Occurs when this FrameworkContentElement is initialized. This coincides with 

cases where the value of the IsInitialized property changes from false (or 

undefined) to true. 
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DefinitionBase FixedDocument FixedDocumentSequence FlowDocument TableColumn TextElement 

Loaded Occurs when the element is laid out, rendered, and ready for interaction. 

SourceUpdated Occurs when any associated data source participating in a binding on this 

element changes. 

TargetUpdated Occurs when any associated target property participating in a binding on this 

element changes. 

ToolTipClosing Occurs just before any tooltip on the element is closed. 

ToolTipOpening Occurs when any tooltip on the element is opened. 

Unloaded Occurs when the element is removed from an element tree of loaded elements. 

4.320   FrameworkElement 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement, IInputElement 

AccessText AdornedElementPlaceholder ContentPresenter Control Decorator DocumentPageView 

DocumentReference FixedPage Glyphs GridViewRowPresenterBase Image InkCanvas 

ItemsPresenter MediaElement Page PageContent Panel Popup Shape TextBlock TickBar 

ToolBarTray Track Viewport3D 

(usage) <FrameworkElement /> 

(description) A base type for elements that provides advanced features, 

such as styling and advanced layout. 

[name property] Name 

[xml lang property] Language 

(properties)  

BindingGroup BindingGroup 

(description) The BindingGroup that is used for the element. 

ContextMenu ContextMenu 

(description) The context menu element that should appear whenever the 

context menu is requested through user interface (UI) from 

within this element. 

Cursor Cursor 

(description) The cursor that displays when the mouse pointer is over this 

element. 

DataContext x:Object 

(description) The data context for an element when it participates in data 

binding. 

FlowDirection FlowDirection 

(description) The direction that text and other user interface (UI) elements 
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AccessText AdornedElementPlaceholder ContentPresenter Control Decorator DocumentPageView 

DocumentReference FixedPage Glyphs GridViewRowPresenterBase Image InkCanvas 

ItemsPresenter MediaElement Page PageContent Panel Popup Shape TextBlock TickBar 

ToolBarTray Track Viewport3D 

flow within any parent element that controls their layout. 

FocusVisualStyle Style 

(description) A property that enables customization of appearance, effects, 

or other style characteristics that will apply to this element 

when it captures keyboard focus. 

ForceCursor x:Boolean 

(description) A value that indicates whether this FrameworkElement should 

force the user interface (UI) to render the cursor as declared 

by the Cursor property. 

Height x:Double 

(description) The suggested height of the element. 

[text syntax] LengthSyntax 

HorizontalAlignment HorizontalAlignment 

(description) The horizontal alignment characteristics applied to this 

element when it is composed within a parent element, such as 

a panel or items control. 

InputScope InputScope 

(description) The context for input used by this FrameworkElement. 

Language XmlLanguage 

(description) Localization/globalization language information that applies to 

an element. 

LayoutTransform Transform 

(description) A graphics transformation that should apply to this element 

when  layout is performed. 

Margin Thickness 

(description) The outer margin of an element. 

MaxHeight x:Double 

(description) The maximum height constraint of the element. 

[text syntax] LengthSyntax 

MaxWidth x:Double 

(description) The maximum width constraint of the element. 

[text syntax] LengthSyntax 
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AccessText AdornedElementPlaceholder ContentPresenter Control Decorator DocumentPageView 

DocumentReference FixedPage Glyphs GridViewRowPresenterBase Image InkCanvas 

ItemsPresenter MediaElement Page PageContent Panel Popup Shape TextBlock TickBar 

ToolBarTray Track Viewport3D 

MinHeight x:Double 

(description) The minimum height constraint of the element. 

[text syntax] LengthSyntax 

MinWidth x:Double 

(description) The minimum width constraint of the element. 

[text syntax] LengthSyntax 

Name x:String 

(description) The identifying name of the element. The name provides a 

reference so that the element can be referred to after it is 

constructed during XAML parsing. 

OverridesDefaultStyle x:Boolean 

(description) A value that indicates whether this element incorporates style 

properties from theme styles. 

Resources ResourceDictionary 

(description) The locally-defined resource dictionary. 

Style Style 

(description) The style used by this element when it is rendered. 

Tag x:Object 

(description) An arbitrary object value that can be used to store custom 

information about this element. 

ToolTip x:Object 

(description) The tool-tip object that is displayed for this element in the 

user interface (UI). 

Triggers TriggerCollection 

(description) The collection of triggers established directly on this element, 

or in child elements. 

[read only] true 

UseLayoutRounding x:Boolean 

(description) A value that indicates whether layout rounding should be 

applied to this element's size and position during layout. 

VerticalAlignment VerticalAlignment 
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AccessText AdornedElementPlaceholder ContentPresenter Control Decorator DocumentPageView 

DocumentReference FixedPage Glyphs GridViewRowPresenterBase Image InkCanvas 

ItemsPresenter MediaElement Page PageContent Panel Popup Shape TextBlock TickBar 

ToolBarTray Track Viewport3D 

(description) The vertical alignment characteristics applied to this element 

when it is composed within a parent element such as a panel 

or items control. 

Width x:Double 

(description) The width of the element. 

[text syntax] LengthSyntax 

(attachable properties)  

FrameworkElement.FlowDirection FlowDirection 

(description) The direction that text and other user interface (UI) elements 

flow within any parent element that controls their layout. 

[target type] DependencyObject 

(events)  

ContextMenuClosing Occurs just before any context menu on the element is closed. 

ContextMenuOpening Occurs when any context menu on the element is opened. 

DataContextChanged Occurs when the data context for this element changes. 

Initialized Occurs when this FrameworkElement is initialized. This event 

coincides with cases where the value of the IsInitialized 

property changes from false (or undefined) to true. 

Loaded Occurs when the element is laid out, rendered, and ready for 

interaction. 

RequestBringIntoView Occurs when an attempt is made to bring the specified 

element region into view. 

SizeChanged Occurs when either the ActualHeight or the ActualWidth 

properties change value on this element. 

SourceUpdated Occurs when the source value changes for any existing 

property binding on this element. 

TargetUpdated Occurs when the target value changes for any property 

binding on this element. 

ToolTipClosing Occurs just before any tooltip on the element is closed. 

ToolTipOpening Occurs when any tooltip on the element is opened. 

Unloaded Occurs when the element is removed from within an element 

tree of loaded elements. 
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4.321   FrameworkPropertyMetadataOptions 

x:Object > FrameworkPropertyMetadataOptions 

(usage) None| AffectsMeasure| AffectsArrange| AffectsParentMeasure| 

AffectsParentArrange| AffectsRender| Inherits| OverridesInheritanceBehavior| 

NotDataBindable... 

(description) Specifies the types of framework-level property behavior that pertain to a particular 

property in the property system. 

[is nullable] false 

[text 

syntax] 

FrameworkPropertyMetadataOptionsSyntax 

4.322   FrameworkTemplate 

x:Object > FrameworkTemplate 

ControlTemplate DataTemplate ItemsPanelTemplate 

(usage) None. 

(description) A base type that defines a tree of elements that comprise the template. 

[is default 

constructible] 

false 

[content property] Template 

[is name scope] true 

(properties)  

Resources ResourceDictionary 

(description) The collection of resources that can be used within the scope of this template. 

Template FrameworkElement 

(description) A reference to the object that records or plays the XAML nodes for the template 

when the template is defined or applied by a writer. 

4.323   Freezable 

x:Object > DependencyObject > Freezable 



 

226 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

Animatable BooleanKeyFrame BooleanKeyFrameCollection ByteKeyFrame ByteKeyFrameCollection 

CharKeyFrame CharKeyFrameCollection ColorKeyFrame ColorKeyFrameCollection 

DecimalKeyFrame DecimalKeyFrameCollection DoubleCollection DoubleKeyFrame 

DoubleKeyFrameCollection EasingFunctionBase InputBinding Int16KeyFrame 

Int16KeyFrameCollection Int32Collection Int32KeyFrame Int32KeyFrameCollection 

Int64KeyFrame Int64KeyFrameCollection KeySpline MatrixKeyFrame MatrixKeyFrameCollection 

ObjectKeyFrame ObjectKeyFrameCollection Point3DCollection Point3DKeyFrame 

Point3DKeyFrameCollection PointCollection PointKeyFrame PointKeyFrameCollection 

QuaternionKeyFrame QuaternionKeyFrameCollection RectKeyFrame RectKeyFrameCollection 

RibbonControlSizeDefinition RibbonGroupSizeDefinitionBase Rotation3DKeyFrame 

Rotation3DKeyFrameCollection SingleKeyFrame SingleKeyFrameCollection SizeKeyFrame 

SizeKeyFrameCollection StringKeyFrame StringKeyFrameCollection TaskbarItemInfo 

ThicknessKeyFrame ThicknessKeyFrameCollection ThumbButtonInfo Vector3DCollection 

Vector3DKeyFrame Vector3DKeyFrameCollection VectorCollection VectorKeyFrame 

VectorKeyFrameCollection WindowChrome 

(usage) None. 

(description) Defines an object that has a modifiable state and a read-only (frozen) state. 

Types that derive from Freezable provide detailed change notification, can be 

made immutable, and can clone themselves. 

[is default 

constructible] 

false 

(events)  

Changed Occurs when the Freezable or an object it contains is modified. 

4.324   GeneralTransform 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform 

GeneralTransformGroup Transform 

(usage) None. 

(description) Provides generalized transformation support for objects, such as points and 

rectangles. 

(used by) GeneralTransformCollection 

[is default 

constructible] 

false 

4.325   GeneralTransform3D 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D 

GeneralTransform3DGroup Transform3D 

(usage) None. 

(description) Provides generalized transformation support for 3-D objects. 

(used by) GeneralTransform3DCollection 
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GeneralTransform3DGroup Transform3D 

[is default constructible] false 

4.326   GeneralTransform3DCollection 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3DCollection 

(usage) <GeneralTransform3DCollection>GeneralTransform3D*</GeneralTransform3DCollection> 

(description) Represents an ordered collection of GeneralTransform3D objects. 

(used by) GeneralTransform3DGroup 

[is list] true 

[allowed 

types] 

GeneralTransform3D 

4.327   GeneralTransform3DGroup 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > 
GeneralTransform3DGroup 

(usage) <GeneralTransform3DGroup>GeneralTransform3D*</GeneralTransform3DGroup> 

(description) Represents a GeneralTransform3D that is a composite of the transforms in its 

GeneralTransform3DCollection. 

[content 

property] 

Children 

(properties)  

Children GeneralTransform3DCollection 

(description) The collection of GeneralTransform3DGroup objects that form this 

GeneralTransform3DGroup. 

4.328   GeneralTransformCollection 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransformCollection 

(usage) <GeneralTransformCollection>GeneralTransform*</GeneralTransformCollection> 

(description) Represents an ordered collection of GeneralTransform objects. 

(used by) GeneralTransformGroup 

[is list] true 

[allowed types] GeneralTransform 
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4.329   GeneralTransformGroup 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform > 
GeneralTransformGroup 

(usage) <GeneralTransformGroup>GeneralTransform*</GeneralTransformGroup> 

(description) Represents a GeneralTransform that is a composite of the transforms in its 

GeneralTransformCollection. 

[content 

property] 

Children 

(properties)  

Children GeneralTransformCollection 

(description) The collection of GeneralTransformGroup objects that form this 

GeneralTransformGroup. 

4.330   GeneratorDirection 

x:Object > GeneratorDirection 

(usage) Forward| Backward 

(description) Specifies the direction in which item generation will occur. GeneratorDirection is used by 

StartAt. 

[is nullable] false 

[text 

syntax] 

GeneratorDirectionSyntax 

4.331   GeneratorPosition 

x:Object > GeneratorPosition 

(usage) <GeneratorPosition /> 

(description) GeneratorPosition is used to describe the position of an item that is managed by 

ItemContainerGenerator. 

[is nullable] false 

(properties)  

Index x:Int32 

(description) The Int32 index that is relative to the generated (realized) items. 

Offset x:Int32 

(description) The Int32 offset that is relative to the ungenerated (unrealized) items near the indexed 

item. 
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4.332   GeneratorStatus 

x:Object > GeneratorStatus 

(usage) NotStarted| GeneratingContainers| ContainersGenerated| Error 

(description) Used by ItemContainerGenerator to indicate the status of its item generation. 

[is nullable] false 

[text syntax] GeneratorStatusSyntax 

4.333   Geometry 

x:Object > DependencyObject > Freezable > Animatable > Geometry 

CombinedGeometry EllipseGeometry GeometryGroup LineGeometry PathGeometry 

RectangleGeometry StreamGeometry 

(usage) <Geometry> string </Geometry> 

(description) A base type for geometric shapes. 

(used by) CombinedGeometry ContainerVisual DrawingGroup GeometryCollection 

GeometryDrawing Path RibbonTwoLineText TextEffect UIElement 

Viewport3DVisual 

[is default constructible] false 

[text syntax] GeometrySyntax 

(properties)  

Transform Transform 

(description) The Transform object applied to a Geometry. 

(static properties)  

Empty Geometry 

(description) An empty object. 

StandardFlatteningTolerance x:Double 

(description) The standard tolerance used for polygonal approximation. 

4.334   Geometry3D 

x:Object > DependencyObject > Freezable > Animatable > Geometry3D 

MeshGeometry3D 

(usage) None. 

(description) A base type for three-dimensional geometric shapes. 
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MeshGeometry3D 

(used by) GeometryModel3D Viewport2DVisual3D 

[is default constructible] false 

4.335   GeometryCollection 

x:Object > DependencyObject > Freezable > Animatable > GeometryCollection 

(usage) <GeometryCollection>Geometry*</GeometryCollection> 

(description) Represents a collection of Geometry objects. 

(used by) GeometryGroup 

[is list] true 

[allowed types] Geometry 

4.336   GeometryCombineMode 

x:Object > GeometryCombineMode 

(usage) Union| Intersect| Xor| Exclude 

(description) Specifies the different ways by which two geometries can be combined. 

(used by) CombinedGeometry 

[is nullable] false 

[text syntax] GeometryCombineModeSyntax 

4.337   GeometryDrawing 

x:Object > DependencyObject > Freezable > Animatable > Drawing > GeometryDrawing 

(usage) <GeometryDrawing /> 

(description) Draws a Geometry using the specified Brush and Pen. 

(properties)  

Brush Brush 

(description) The Brush used to fill the interior of the shape described by this GeometryDrawing. 

Geometry Geometry 

(description) The Geometry that describes the shape of this GeometryDrawing. 

Pen Pen 

(description) The Pen used to stroke this GeometryDrawing. 
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4.338   GeometryGroup 

x:Object > DependencyObject > Freezable > Animatable > Geometry > GeometryGroup 

(usage) <GeometryGroup> string |Geometry*</GeometryGroup> 

(description) Represents a composite geometry, composed of other Geometry objects. 

[text syntax] GeometrySyntax 

[content 

property] 

Children 

(properties)  

Children GeometryCollection 

(description) The GeometryCollection that contains the objects that define this GeometryGroup. 

FillRule FillRule 

(description) How the intersecting areas of the objects contained in this GeometryGroup are 

combined. 

4.339   GeometryModel3D 

x:Object > DependencyObject > Freezable > Animatable > Model3D > GeometryModel3D 

(usage) <GeometryModel3D /> 

(description) Renders a Geometry3D with the specified Material. 

(properties)  

BackMaterial Material 

(description) The Material used to render the back of this GeometryModel3D. 

Geometry Geometry3D 

(description) The Geometry3D that describes the shape of this GeometryModel3D. 

Material Material 

(description) The Material used to render the front of this GeometryModel3D. 

4.340   GestureRecognizer 

x:Object > DependencyObject > GestureRecognizer 

(usage) <GestureRecognizer /> 

(description) Recognizes ink gestures. 

4.341   GifBitmapEncoder 

x:Object > BitmapEncoder > GifBitmapEncoder 
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(usage) <GifBitmapEncoder /> 

(description) Defines an encoder that is used to encode Graphics Interchange Format (GIF) images. 

4.342   GlyphRun 

x:Object > GlyphRun 

(usage) <GlyphRun /> 

(description) Represents a sequence of glyphs from a single face of a single font at a single 

size, and with a single rendering style. 

(used by) GlyphRunDrawing 

(properties)  

AdvanceWidths IList(x:Double) 

(description) The list of Double values that represent the advance widths corresponding to 

the glyph indices. 

[text syntax] DoubleIListSyntax 

BaselineOrigin Point 

(description) The baseline origin of the GlyphRun. 

BidiLevel x:Int32 

(description) The bidirectional nesting level of the GlyphRun. 

CaretStops IList(x:Boolean) 

(description) The list of Boolean values that determine whether there are caret stops for 

every UTF16 code point in the Unicode representing the GlyphRun. 

[text syntax] BoolIListSyntax 

Characters IList(x:Char) 

(description) The list of UTF16 code points that represent the Unicode content of the 

GlyphRun. 

[text syntax] CharIListSyntax 

ClusterMap IList(UInt16) 

(description) The list of UInt16 values that maps characters in the GlyphRun to glyph 

indices. 

[text syntax] UShortIListSyntax 

DeviceFontName x:String 

(description) The specific device font for which the GlyphRun has been optimized. 

FontRenderingEmSize x:Double 
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(usage) <GlyphRun /> 

(description) The em size used for rendering the GlyphRun. 

GlyphIndices IList(UInt16) 

(description) An array of UInt16 values that represent the glyph indices in the rendering 

physical font. 

[text syntax] UShortIListSyntax 

GlyphOffsets IList(Point) 

(description) An array of Point values representing the offsets of the glyphs in the GlyphRun. 

[text syntax] PointIListSyntax 

GlyphTypeface GlyphTypeface 

(description) The GlyphTypeface for the GlyphRun. 

IsSideways x:Boolean 

(description) A value indicating whether to rotate glyphs. 

Language XmlLanguage 

(description) The XmlLanguage for the GlyphRun. 

4.343   GlyphRunDrawing 

x:Object > DependencyObject > Freezable > Animatable > Drawing > GlyphRunDrawing 

(usage) <GlyphRunDrawing /> 

(description) Represents a Drawing object that renders a GlyphRun. 

(properties)  

ForegroundBrush Brush 

(description) The foreground brush of the GlyphRunDrawing. 

GlyphRun GlyphRun 

(description) The GlyphRun that describes the text to draw. 

4.344   Glyphs 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Glyphs, IInputElement 

(usage) <Glyphs /> 

(description) Represents the set of glyphs that are used for rendering fixed text. 

[name property] Name 
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(usage) <Glyphs /> 

[xml lang property] Language 

(properties)  

BidiLevel x:Int32 

(description) The bidirectional nesting level of Glyphs. 

CaretStops x:String 

(description) The caret stops that correspond to the code points in the Unicode string 

representing the Glyphs. 

DeviceFontName x:String 

(description) The specific device font for which the Glyphs object has been optimized. 

Fill Brush 

(description) The sets the Brush that is used for the fill of the Glyphs type. 

FontRenderingEmSize x:Double 

(description) The em size used for rendering the Glyphs type. 

[text syntax] FontSizeSyntax 

FontUri x:Uri 

(description) The Uri that represents the location of the font used for rendering the Glyphs 

type. 

Indices x:String 

(description) A collection of glyph specifications that represents the Glyphs object. 

IsSideways x:Boolean 

(description) Determines whether to rotate the Glyphs object. 

OriginX x:Double 

(description) The value of the x origin for the Glyphs object. 

[text syntax] LengthSyntax 

OriginY x:Double 

(description) The value of the y origin for the Glyphs object. 

[text syntax] LengthSyntax 

StyleSimulations StyleSimulations 

(description) The StyleSimulations for the Glyphs type. 

UnicodeString x:String 

(description) The String that represents the Unicode string for the Glyphs object. 
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4.345   GlyphTypeface 

x:Object > GlyphTypeface 

(usage) <GlyphTypeface /> 

(description) Specifies a physical font face that 

corresponds to a font file on the disk. 

(used by) GlyphRun 

(properties)  

AdvanceHeights IDictionary(UInt16,x:Double) 

(description) The advance heights for the glyphs 

represented by the GlyphTypeface object. 

[read only] true 

AdvanceWidths IDictionary(UInt16,x:Double) 

(description) The advance widths for the glyphs 

represented by the GlyphTypeface object. 

[read only] true 

BottomSideBearings IDictionary(UInt16,x:Double) 

(description) The distance from bottom edge of the black 

box to the bottom end of the advance vector 

for the glyphs represented by the 

GlyphTypeface object. 

[read only] true 

CharacterToGlyphMap IDictionary(x:Int32,UInt16) 

(description) The nominal mapping of a Unicode code point 

to a glyph index as defined by the font 

'CMAP' table. 

[read only] true 

Copyrights IDictionary(CultureInfo,x:String) 

(description) The copyright information for the 

GlyphTypeface object. 

[read only] true 

Descriptions IDictionary(CultureInfo,x:String) 

(description) The description information for the 

GlyphTypeface object. 

[read only] true 

DesignerNames IDictionary(CultureInfo,x:String) 
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(usage) <GlyphTypeface /> 

(description) The designer information for the 

GlyphTypeface object. 

[read only] true 

DesignerUrls IDictionary(CultureInfo,x:String) 

(description) The designer URL information for the 

GlyphTypeface object. 

[read only] true 

DistancesFromHorizontalBaselineToBlackBoxBottom IDictionary(UInt16,x:Double) 

(description) The offset value from the horizontal Western 

baseline to the bottom of the glyph black box 

for the glyphs represented by the 

GlyphTypeface object. 

[read only] true 

FaceNames IDictionary(CultureInfo,x:String) 

(description) The face name for the GlyphTypeface object. 

[read only] true 

FamilyNames IDictionary(CultureInfo,x:String) 

(description) The family name for the GlyphTypeface 

object. 

[read only] true 

FontUri x:Uri 

(description) The URI for the GlyphTypeface object. 

LeftSideBearings IDictionary(UInt16,x:Double) 

(description) The distance from the leading end of the 

advance vector to the left edge of the black 

box for the glyphs represented by the 

GlyphTypeface object. 

[read only] true 

LicenseDescriptions IDictionary(CultureInfo,x:String) 

(description) The font license description information for 

the GlyphTypeface object. 

[read only] true 

ManufacturerNames IDictionary(CultureInfo,x:String) 

(description) The font manufacturer information for the 

GlyphTypeface object. 
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(usage) <GlyphTypeface /> 

[read only] true 

RightSideBearings IDictionary(UInt16,x:Double) 

(description) The distance from the right edge of the black 

box to the right end of the advance vector for 

the glyphs represented by the GlyphTypeface 

object. 

[read only] true 

SampleTexts IDictionary(CultureInfo,x:String) 

(description) The sample text information for the 

GlyphTypeface object. 

[read only] true 

StyleSimulations StyleSimulations 

(description) The StyleSimulations for the GlyphTypeface 

object. 

TopSideBearings IDictionary(UInt16,x:Double) 

(description) The distance from the top end of the vertical 

advance vector to the top edge of the black 

box for the glyphs represented by the 

GlyphTypeface object. 

[read only] true 

Trademarks IDictionary(CultureInfo,x:String) 

(description) The trademark notice information for the 

GlyphTypeface object. 

[read only] true 

VendorUrls IDictionary(CultureInfo,x:String) 

(description) The vendor URL information for the 

GlyphTypeface object. 

[read only] true 

VersionStrings IDictionary(CultureInfo,x:String) 

(description) The version string information for the 

GlyphTypeface object interpreted from the 

font's 'NAME' table. 

[read only] true 

Win32FaceNames IDictionary(CultureInfo,x:String) 

(description) The  face name for the font represented by 

the  GlyphTypeface object. 
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(usage) <GlyphTypeface /> 

[read only] true 

Win32FamilyNames IDictionary(CultureInfo,x:String) 

(description) The  family name for the font represented by 

the  GlyphTypeface object. 

[read only] true 

4.346   GradientBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > GradientBrush 

LinearGradientBrush RadialGradientBrush 

(usage) <GradientBrush> string</GradientBrush> 

(description) A base type that describes a gradient, composed of gradient stops. 

[is default 

constructible] 

false 

[text syntax] BrushSyntax 

[content property] GradientStops 

(properties)  

ColorInterpolationMode ColorInterpolationMode 

(description) A ColorInterpolationMode enumeration that specifies how the gradient's 

colors are interpolated. 

GradientStops GradientStopCollection 

(description) The brush's gradient stops. 

MappingMode BrushMappingMode 

(description) A BrushMappingMode enumeration that specifies whether the gradient 

brush's positioning coordinates are absolute or relative to the output area. 

SpreadMethod GradientSpreadMethod 

(description) The type of spread method that specifies how to draw a gradient that starts 

or ends inside the bounds of the object to be painted. 

4.347   GradientSpreadMethod 

x:Object > GradientSpreadMethod 

(usage) Pad| Reflect| Repeat 

(description) Specifies how to draw the gradient outside a gradient brush's gradient vector or space. 
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(usage) Pad| Reflect| Repeat 

(used by) GradientBrush 

[is nullable] false 

[text syntax] GradientSpreadMethodSyntax 

4.348   GradientStop 

x:Object > DependencyObject > Freezable > Animatable > GradientStop 

(usage) <GradientStop /> 

(description) Describes the location and color of a transition point in a gradient. 

(used by) GradientStopCollection 

(properties)  

Color Color 

(description) The color of the gradient stop. 

Offset x:Double 

(description) The location of the gradient stop within the gradient vector. 

4.349   GradientStopCollection 

x:Object > DependencyObject > Freezable > Animatable > GradientStopCollection 

(usage) <GradientStopCollection>GradientStop*</GradientStopCollection> 

(description) Represents a collection of GradientStop objects that can be individually accessed by 

index. 

(used by) GradientBrush 

[is list] true 

[allowed 

types] 

GradientStop 

4.350   Grid 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > Grid, 
IInputElement 

SelectiveScrollingGrid 

(usage) <Grid>UIElement*</Grid> 

(description) Defines a flexible grid area that consists of columns and rows. 

[content property] Children 
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SelectiveScrollingGrid 

[name property] Name 

[xml lang property] Language 

(properties)  

ColumnDefinitions ColumnDefinitionCollection 

(description) A ColumnDefinitionCollection defined on this instance of Grid. 

[read only] true 

RowDefinitions RowDefinitionCollection 

(description) A RowDefinitionCollection defined on this instance of Grid. 

[read only] true 

ShowGridLines x:Boolean 

(description) A value that indicates whether grid lines are visible within this Grid. 

(attachable properties)  

Grid.Column x:Int32 

(description) A value that indicates which column child content within a Grid should appear 

in. 

[target type] UIElement 

Grid.ColumnSpan x:Int32 

(description) A value that indicates the total number of columns that child content spans 

within a Grid. 

[target type] UIElement 

Grid.IsSharedSizeScope x:Boolean 

(description) A value that indicates that multiple Grid elements are sharing size 

information. 

[target type] UIElement 

Grid.Row x:Int32 

(description) A value that indicates which row child content within a Grid should appear in. 

[target type] UIElement 

Grid.RowSpan x:Int32 

(description) A value that indicates the total number of rows that child content spans 

within a Grid. 

[target type] UIElement 
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4.351   GridLength 

x:Object > GridLength 

(usage) <GridLength> string </GridLength> 

(description) Represents the length of elements that explicitly support Star unit types. 

(used by) ColumnDefinition RowDefinition TableColumn 

[is nullable] false 

[text syntax] GridLengthSyntax 

(static 

properties) 

 

Auto GridLength 

(description) An instance of GridLength that holds a value whose size is determined by the size 

properties of the content object. 

4.352   GridResizeBehavior 

x:Object > GridResizeBehavior 

(usage) BasedOnAlignment| CurrentAndNext| PreviousAndCurrent| PreviousAndNext 

(description) Specifies the rows or columns that are resized by a GridSplitter control. 

(used by) GridSplitter 

[is nullable] false 

[text syntax] GridResizeBehaviorSyntax 

4.353   GridResizeDirection 

x:Object > GridResizeDirection 

(usage) Auto| Columns| Rows 

(description) Specifies whether a GridSplitter control redistributes space between rows or between 

columns. 

(used by) GridSplitter 

[is nullable] false 

[text 

syntax] 

GridResizeDirectionSyntax 

4.354   GridSplitter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > Thumb > 

GridSplitter, IInputElement 



 

242 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <GridSplitter /> 

(description) Represents the control that redistributes space between columns or rows of a 

Grid control. 

[name property] Name 

[xml lang property] Language 

(properties)  

DragIncrement x:Double 

(description) The minimum distance that a user must drag a mouse to resize rows or columns 

with a GridSplitter control. 

KeyboardIncrement x:Double 

(description) The distance that each press of an arrow key moves a GridSplitter control. 

PreviewStyle Style 

(description) The style that customizes the appearance, effects, or other style characteristics 

for the GridSplitter control preview indicator that is displayed when the 

ShowsPreview property is set to true. 

ResizeBehavior GridResizeBehavior 

(description) Which columns or rows are resized relative to the column or row for which the 

GridSplitter control is defined. 

ResizeDirection GridResizeDirection 

(description) A value that indicates whether the GridSplitter control resizes rows or columns. 

ShowsPreview x:Boolean 

(description) A value that indicates whether the GridSplitter control updates the column or row 

size as the user drags the control. 

4.355   GridUnitType 

x:Object > GridUnitType 

(usage) Auto| Pixel| Star 

(description) Describes the kind of value that a GridLength object is holding. 

[is nullable] false 

[text syntax] GridUnitTypeSyntax 

4.356   GridView 

x:Object > DependencyObject > ViewBase > GridView 

(usage) <GridView>GridViewColumn*</GridView> 
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(usage) <GridView>GridViewColumn*</GridView> 

(description) Represents a view mode that displays data items in columns for a 

ListView control. 

[content property] Columns 

(properties)  

AllowsColumnReorder x:Boolean 

(description) Whether columns in a GridView can be reordered by a drag-and-

drop operation. 

ColumnHeaderContainerStyle Style 

(description) The style to apply to column headers. 

ColumnHeaderContextMenu ContextMenu 

(description) A ContextMenu for the GridView. 

ColumnHeaderStringFormat x:String 

(description) A composite string that specifies how to format the column headers 

of the GridView if they are displayed as strings. 

ColumnHeaderTemplate DataTemplate 

(description) A template to use to display the column headers. 

ColumnHeaderTemplateSelector DataTemplateSelector 

(description) The selector object that provides logic for selecting a template to 

use for each column header. 

ColumnHeaderToolTip x:Object 

(description) The content of a tooltip that appears when the mouse pointer 

pauses over one of the column headers. 

Columns GridViewColumnCollection 

(description) The collection of GridViewColumn objects that is defined for this 

GridView. 

[read only] true 

(attachable properties)  

GridView.ColumnCollection GridViewColumnCollection 

(description) The attached property that contains the GridViewColumnCollection. 

[target type] DependencyObject 

(static properties)  

GridViewItemContainerStyleKey ResourceKey 
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(usage) <GridView>GridViewColumn*</GridView> 

(description) The key that references the style that is defined for each 

ListViewItem in a GridView. 

GridViewScrollViewerStyleKey ResourceKey 

(description) The key that references the style that is defined for the 

ScrollViewer control that encloses the content that is displayed by a 

GridView. 

GridViewStyleKey ResourceKey 

(description) The key that references the style that is defined for the GridView. 

4.357   GridViewColumn 

x:Object > DependencyObject > GridViewColumn 

(usage) <GridViewColumn>x:Object</GridViewColumn> 

(description) Represents a column that displays data. 

(used by) GridViewColumnCollection 

[content property] Header 

(properties)  

ActualWidth x:Double 

(description) The actual width of a GridViewColumn. 

CellTemplate DataTemplate 

(description) The template to use to display the contents of a column cell. 

CellTemplateSelector DataTemplateSelector 

(description) A DataTemplateSelector that determines the template to use to display cells 

in a column. 

DisplayMemberBinding BindingBase 

(description) The data item to bind to for this column. 

Header x:Object 

(description) The content of the header of a GridViewColumn. 

HeaderContainerStyle Style 

(description) The style to use for the header of the GridViewColumn. 

HeaderStringFormat x:String 

(description) A composite string that specifies how to format the Header property if it is 

displayed as a string. 
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(usage) <GridViewColumn>x:Object</GridViewColumn> 

HeaderTemplate DataTemplate 

(description) The template to use to display the content of the column header. 

HeaderTemplateSelector DataTemplateSelector 

(description) The DataTemplateSelector that provides logic to select the template to use 

to display the column header. 

Width x:Double 

(description) The width of the column. 

[text syntax] LengthSyntax 

4.358   GridViewColumnCollection 

x:Object > ObservableCollection(GridViewColumn) > GridViewColumnCollection 

(usage) <GridViewColumnCollection>GridViewColumn*</GridViewColumnCollection> 

(description) Represents a collection of GridViewColumn objects. 

(used by) GridView GridViewRowPresenterBase 

[is list] true 

[allowed types] GridViewColumn 

4.359   GridViewColumnHeader 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ButtonBase > GridViewColumnHeader, IInputElement 

(usage) <GridViewColumnHeader>x:Object</GridViewColumnHeader> 

(description) Represents a column header for a GridViewColumn. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.360   GridViewColumnHeaderRole 

x:Object > GridViewColumnHeaderRole 

(usage) Normal| Floating| Padding 

(description) Defines the state or role of a GridViewColumnHeader control. 

[is nullable] false 
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(usage) Normal| Floating| Padding 

[text syntax] GridViewColumnHeaderRoleSyntax 

4.361   GridViewHeaderRowPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > 
GridViewRowPresenterBase > GridViewHeaderRowPresenter, IInputElement 

(usage) <GridViewHeaderRowPresenter /> 

(description) Represents an object that is used to define the layout of a row of 

column headers. 

[name property] Name 

[xml lang property] Language 

(properties)  

AllowsColumnReorder x:Boolean 

(description) A value that indicates whether columns can change positions. 

ColumnHeaderContainerStyle Style 

(description) The Style to use for the column headers. 

ColumnHeaderContextMenu ContextMenu 

(description) A ContextMenu for the column headers. 

ColumnHeaderStringFormat x:String 

(description) A composite string that specifies how to format the column headers 

if they are displayed as strings. 

ColumnHeaderTemplate DataTemplate 

(description) The template to use to display the column headers. 

ColumnHeaderTemplateSelector DataTemplateSelector 

(description) A DataTemplateSelector that provides logic that selects the data 

template to use to display a column header. 

ColumnHeaderToolTip x:Object 

(description) The content for a tooltip for the column header row. 

4.362   GridViewRowPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > 
GridViewRowPresenterBase > GridViewRowPresenter, IInputElement 

(usage) <GridViewRowPresenter /> 
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(usage) <GridViewRowPresenter /> 

(description) Represents an object that specifies the layout of a row of data. 

[name property] Name 

[xml lang property] Language 

(properties)  

Content x:Object 

(description) The data content to display in a row. 

4.363   GridViewRowPresenterBase 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > 
GridViewRowPresenterBase, IInputElement 

GridViewHeaderRowPresenter GridViewRowPresenter 

(usage) None. 

(description) Represents the base type for types that define the layout for a row of data where 

different data items are displayed in different columns. 

[is default 

constructible] 

false 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Columns GridViewColumnCollection 

(description) A GridViewColumnCollection. 

4.364   GroupBox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > HeaderedContentControl > GroupBox, IInputElement 

(usage) <GroupBox>x:Object</GroupBox> 

(description) Represents a control that creates a container that has a border and a header for 

user interface (UI) content. 

[content 

property] 

Content 

[name property] Name 

[xml lang 

property] 

Language 
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4.365   GroupItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > GroupItem, IInputElement 

(usage) <GroupItem>x:Object</GroupItem> 

(description) Appears as the root of the visual subtree generated for a group. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.366   GroupStyle 

x:Object > GroupStyle 

(usage) <GroupStyle /> 

(description) Defines how you want the group to look at each level. 

(used by) ItemsControl 

(properties)  

AlternationCount x:Int32 

(description) The number of alternating GroupItem objects. 

ContainerStyle Style 

(description) The style that is applied to the GroupItem generated for each item. 

ContainerStyleSelector StyleSelector 

(description) Enables the application writer to provide custom selection logic for a style to 

apply to each generated GroupItem. 

HeaderStringFormat x:String 

(description) A composite string that specifies how to format the header if it is displayed 

as a string. 

HeaderTemplate DataTemplate 

(description) The template that is used to display the group header. 

HeaderTemplateSelector DataTemplateSelector 

(description) Enables the application writer to provide custom selection logic for a 

template that is used to display the group header. 

HidesIfEmpty x:Boolean 

(description) A value that indicates whether items corresponding to empty groups should 

be displayed. 
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(usage) <GroupStyle /> 

Panel ItemsPanelTemplate 

(description) A template that creates the panel used to layout the items. 

(static properties)  

Default GroupStyle 

(description) The default style of the group. 

4.367   GuidelineSet 

x:Object > DependencyObject > Freezable > Animatable > GuidelineSet 

(usage) <GuidelineSet /> 

(description) Represents a collection of guide lines that can assist in adjusting rendered figures to a 

device pixel grid. 

(used by) DrawingGroup 

(properties)  

GuidelinesX DoubleCollection 

(description) A series of coordinate values that represent guide lines on the X-axis. 

GuidelinesY DoubleCollection 

(description) A series of coordinate values that represent guide lines on the Y-axis. 

4.368   HandoffBehavior 

x:Object > HandoffBehavior 

(usage) SnapshotAndReplace| Compose 

(description) Specifies how new animations interact with any existing ones that are already applied to 

a property. 

(used by) BeginStoryboard 

[is nullable] false 

[text 

syntax] 

HandoffBehaviorSyntax 

4.369   HeaderedContentControl 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > HeaderedContentControl, IInputElement 

Expander GroupBox TabItem 
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Expander GroupBox TabItem 

(usage) <HeaderedContentControl>x:Object</HeaderedContentControl> 

(description) Provides the base implementation for all controls that contain single content 

and have a header. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

Header x:Object 

(description) The data used for the header of each control. 

HeaderStringFormat x:String 

(description) A composite string that specifies how to format the Header property if it is 

displayed as a string. 

HeaderTemplate DataTemplate 

(description) The template used to display the content of the control's header. 

HeaderTemplateSelector DataTemplateSelector 

(description) A data template selector that provides custom logic for choosing the 

template used to display the header. 

4.370   HeaderedItemsControl 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > HeaderedItemsControl, IInputElement 

MenuItem RibbonGalleryCategory RibbonGroup RibbonTab ToolBar TreeViewItem 

(usage) <HeaderedItemsControl>x:Object*</HeaderedItemsControl> 

(description) Represents a control that contains multiple items and has a header. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

Header x:Object 

(description) The item that labels the control. 

HeaderStringFormat x:String 

(description) A composite string that specifies how to format the Header property if it is 
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MenuItem RibbonGalleryCategory RibbonGroup RibbonTab ToolBar TreeViewItem 

displayed as a string. 

HeaderTemplate DataTemplate 

(description) The template used to display the contents of the control's header. 

HeaderTemplateSelector DataTemplateSelector 

(description) The object that provides custom selection logic for a template used to 

display the header of each item. 

4.371   HierarchicalDataTemplate 

x:Object > FrameworkTemplate > DataTemplate > HierarchicalDataTemplate 

(usage) <HierarchicalDataTemplate>FrameworkElement</HierarchicalDataTemplate

> 

(description) Represents a DataTemplate that supports HeaderedItemsControl, such as 

TreeViewItem or MenuItem. 

[content property] Template 

[dictionary key property] DataTemplateKey 

[is name scope] true 

(properties)  

AlternationCount x:Int32 

(description) The number of alternating item containers for the child items. 

ItemBindingGroup BindingGroup 

(description) The BindingGroup that is copied to each child item. 

ItemContainerStyle Style 

(description) The Style that is applied to the item container for each child item. 

ItemContainerStyleSelecto

r 

StyleSelector 

(description) Custom style-selection logic for a style that can be applied to each item 

container. 

ItemsSource BindingBase 

(description) The binding for this data template, which indicates where to find the 

collection that represents the next level in the data hierarchy. 

ItemStringFormat x:String 

(description) A composite string that specifies how to format the items in the next level in 

the data hierarchy if they are displayed as strings. 
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(usage) <HierarchicalDataTemplate>FrameworkElement</HierarchicalDataTemplate

> 

ItemTemplate DataTemplate 

(description) The DataTemplate to apply to the ItemTemplate property on a generated 

HeaderedItemsControl (such as a MenuItem or a TreeViewItem), to indicate 

how to display items from the next level in the data hierarchy. 

ItemTemplateSelector DataTemplateSelector 

(description) The DataTemplateSelector to apply to the ItemTemplateSelector property on 

a generated HeaderedItemsControl (such as a MenuItem or a 

TreeViewItem), to indicate how to select a template to display items from 

the next level in the data hierarchy. 

4.372   HierarchicalVirtualizationConstraints (4.5) 

x:Object > HierarchicalVirtualizationConstraints 

(usage) <HierarchicalVirtualizationConstraints /> 

(description) Specifies the sizes of a control's viewport and cache. This structure is used by the 

IHierarchicalVirtualizationAndScrollInfo interface. 

(used by) IHierarchicalVirtualizationAndScrollInfo 

[is nullable] false 

4.373   HierarchicalVirtualizationHeaderDesiredSizes (4.5) 

x:Object > HierarchicalVirtualizationHeaderDesiredSizes 

(usage) <HierarchicalVirtualizationHeaderDesiredSizes /> 

(description) Represents the desired size of the control's header, in pixels and in logical units. This 

structure is used by the IHierarchicalVirtualizationAndScrollInfo interface. 

[is nullable] false 

4.374   HierarchicalVirtualizationItemDesiredSizes (4.5) 

x:Object > HierarchicalVirtualizationItemDesiredSizes 

(usage) <HierarchicalVirtualizationItemDesiredSizes /> 

(description) Represents the desired size of the control's items, in device-independent units (1/96th 

inch per unit) and in logical units. 

(used by) IHierarchicalVirtualizationAndScrollInfo 

[is nullable] false 
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4.375   HitTestFilterBehavior 

x:Object > HitTestFilterBehavior 

(usage) ContinueSkipChildren| ContinueSkipSelfAndChildren| ContinueSkipSelf| Continue| 

Stop 

(description) Specifies the return behavior of a hit test in a hit test filter callback method. 

[is nullable] false 

[text 

syntax] 

HitTestFilterBehaviorSyntax 

4.376   HitTestResultBehavior 

x:Object > HitTestResultBehavior 

(usage) Stop| Continue 

(description) Determines whether to continue the enumeration of any remaining visual objects during 

a hit test. 

[is nullable] false 

[text 

syntax] 

HitTestResultBehaviorSyntax 

4.377   HorizontalAlignment 

x:Object > HorizontalAlignment 

(usage) Left| Center| Right| Stretch 

(description) Indicates where an element should be displayed on the horizontal axis relative to the 

allocated layout slot of the parent element. 

(used by) Control Floater FrameworkElement 

[is nullable] false 

[text 

syntax] 

HorizontalAlignmentSyntax 

4.378   HostVisual 

x:Object > DependencyObject > Visual > ContainerVisual > HostVisual 

(usage) <HostVisual /> 

(description) Represents a Visual object that can be connected anywhere to a parent visual tree. 
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4.379   Hyperlink 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > Span > Hyperlink, IInputElement 

(usage) <Hyperlink>[Inline|UIElement|x:String]*</Hyperlink> 

(description) An inline-level flow content element that provides facilities for hosting hyperlinks 

within flow content. 

[content property] Inlines 

[name property] Name 

[xml lang property] Language 

(properties)  

Command ICommand 

(description) A command to associate with the Hyperlink. 

CommandParameter x:Object 

(description) Command parameters associated with the command specified by the Command 

property. 

CommandTarget IInputElement 

(description) A target element on which to execute the command specified by the Command 

property. 

NavigateUri x:Uri 

(description) A URI to navigate to when the Hyperlink is activated. 

TargetName x:String 

(description) The name of a target window or frame for the Hyperlink. 

(events)  

Click Occurs when the left mouse button is clicked on a Hyperlink. 

RequestNavigate Occurs when navigation events are requested. 

4.380   IAnimatable 

IAnimatable 
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AccessText AdornedElementPlaceholder AdornerDecorator AffineTransform3D AmbientLight 

AnchoredBlock Animatable AnimationTimeline ArcSegment AxisAngleRotation3D BezierSegment 

BitmapCache BitmapCacheBrush BitmapFrame BitmapImage BitmapSource Block 

BlockUIContainer BlurEffect Bold BooleanAnimationBase BooleanAnimationUsingKeyFrames 

Border Brush BulletDecorator Button ButtonBase ByteAnimation ByteAnimationBase 

ByteAnimationUsingKeyFrames CachedBitmap CacheMode Calendar CalendarButton 

CalendarDayButton CalendarItem Camera Canvas CharAnimationBase 

CharAnimationUsingKeyFrames CheckBox ColorAnimation ColorAnimationBase 

ColorAnimationUsingKeyFrames ColorConvertedBitmap ColumnDefinition CombinedGeometry 

ComboBox ComboBoxItem ContainerUIElement3D ContentControl ContentElement 

ContentPresenter ContextMenu Control CroppedBitmap DashStyle DataGrid DataGridCell 

DataGridCellsPanel DataGridCellsPresenter DataGridColumnHeader 

DataGridColumnHeadersPresenter DataGridDetailsPresenter DataGridRow DataGridRowHeader 

DataGridRowsPresenter DatePicker DatePickerTextBox DecimalAnimation DecimalAnimationBase 

DecimalAnimationUsingKeyFrames Decorator DefinitionBase DiffuseMaterial DirectionalLight 

DockPanel DocumentPageView DocumentReference DocumentViewer DocumentViewerBase 

DoubleAnimation DoubleAnimationBase DoubleAnimationUsingKeyFrames 

DoubleAnimationUsingPath Drawing DrawingBrush DrawingCollection DrawingGroup 

DrawingImage DropShadowEffect Effect Ellipse EllipseGeometry EmissiveMaterial Expander Figure 

FixedDocument FixedDocumentSequence FixedPage Floater FlowDocument 

FlowDocumentPageViewer FlowDocumentReader FlowDocumentScrollViewer 

FormatConvertedBitmap Frame FrameworkContentElement FrameworkElement GeneralTransform 

GeneralTransform3D GeneralTransform3DCollection GeneralTransform3DGroup 

GeneralTransformCollection GeneralTransformGroup Geometry Geometry3D GeometryCollection 

GeometryDrawing GeometryGroup GeometryModel3D GlyphRunDrawing Glyphs GradientBrush 

GradientStop GradientStopCollection Grid GridSplitter GridViewColumnHeader 

GridViewHeaderRowPresenter GridViewRowPresenter GridViewRowPresenterBase GroupBox 

GroupItem GuidelineSet HeaderedContentControl HeaderedItemsControl Hyperlink Image 

ImageBrush ImageDrawing ImageSource InkCanvas InkPresenter Inline InlineUIContainer 

Int16Animation Int16AnimationBase Int16AnimationUsingKeyFrames Int32Animation 

Int32AnimationBase Int32AnimationUsingKeyFrames Int64Animation Int64AnimationBase 

Int64AnimationUsingKeyFrames Italic ItemsControl ItemsPresenter KeyTipControl Label Light 

Line LinearGradientBrush LineBreak LineGeometry LineSegment List ListBox ListBoxItem ListItem 

ListView ListViewItem Material MaterialCollection MaterialGroup MatrixAnimationBase 

MatrixAnimationUsingKeyFrames MatrixAnimationUsingPath MatrixCamera MatrixTransform 

MatrixTransform3D MediaElement MediaPlayer MediaTimeline Menu MenuBase MenuItem 

MeshGeometry3D Model3D Model3DCollection Model3DGroup ModelUIElement3D ModelVisual3D 

MultiSelector NavigationWindow ObjectAnimationBase ObjectAnimationUsingKeyFrames 

OrthographicCamera Page PageContent Panel Paragraph ParallelTimeline PasswordBox Path 

PathFigure PathFigureCollection PathGeometry PathSegment PathSegmentCollection Pen 

PerspectiveCamera PixelShader Point3DAnimation Point3DAnimationBase 

Point3DAnimationUsingKeyFrames PointAnimation PointAnimationBase 

PointAnimationUsingKeyFrames PointAnimationUsingPath PointLight PointLightBase 

PolyBezierSegment Polygon Polyline PolyLineSegment PolyQuadraticBezierSegment Popup 

ProgressBar ProjectionCamera QuadraticBezierSegment QuaternionAnimation 

QuaternionAnimationBase QuaternionAnimationUsingKeyFrames QuaternionRotation3D 

RadialGradientBrush RadioButton RangeBase Rectangle RectangleGeometry RectAnimation 

RectAnimationBase RectAnimationUsingKeyFrames RenderTargetBitmap RepeatButton ResizeGrip 

Ribbon RibbonApplicationMenu RibbonApplicationMenuItem RibbonApplicationSplitMenuItem 

RibbonButton RibbonCheckBox RibbonComboBox RibbonContentPresenter RibbonContextMenu 

RibbonContextualTabGroup RibbonContextualTabGroupItemsControl RibbonControl 

RibbonControlGroup RibbonControlSizeDefinitionCollection RibbonFilterMenuButton RibbonGallery 

RibbonGalleryCategory RibbonGalleryItem RibbonGroup RibbonGroupSizeDefinitionBaseCollection 

RibbonMenuButton RibbonMenuItem RibbonQuickAccessToolBar RibbonRadioButton 

RibbonSeparator RibbonSplitButton RibbonSplitMenuItem RibbonTab RibbonTabHeader 

RibbonTabHeaderItemsControl RibbonTextBox RibbonToggleButton RibbonToolTip 

RibbonTwoLineText RibbonWindow RichTextBox RotateTransform RotateTransform3D Rotation3D 

Rotation3DAnimation Rotation3DAnimationBase Rotation3DAnimationUsingKeyFrames 

RowDefinition Run ScaleTransform ScaleTransform3D ScrollBar ScrollContentPresenter 

ScrollViewer Section SelectiveScrollingGrid Selector Separator Shape SingleAnimation 

SingleAnimationBase SingleAnimationUsingKeyFrames SizeAnimation SizeAnimationBase 

SizeAnimationUsingKeyFrames SkewTransform Slider SolidColorBrush Span SpecularMaterial 

SpotLight StackPanel StatusBar StatusBarItem Storyboard StreamGeometry StringAnimationBase 

StringAnimationUsingKeyFrames TabControl TabItem Table TableCell TableColumn TableRow 

TableRowGroup TabPanel TextBlock TextBox TextBoxBase TextDecoration 

TextDecorationCollection TextEffect TextEffectCollection TextElement ThicknessAnimation 

ThicknessAnimationBase ThicknessAnimationUsingKeyFrames Thumb ThumbButtonInfoCollection 

TickBar TileBrush Timeline TimelineCollection TimelineGroup ToggleButton ToolBar 

ToolBarOverflowPanel ToolBarPanel ToolBarTray ToolTip Track Transform Transform3D 

Transform3DCollection Transform3DGroup TransformCollection TransformedBitmap 

TransformGroup TranslateTransform TranslateTransform3D TreeView TreeViewItem UIElement 

UIElement3D Underline UniformGrid UserControl Vector3DAnimation Vector3DAnimationBase 

Vector3DAnimationUsingKeyFrames VectorAnimation VectorAnimationBase 

VectorAnimationUsingKeyFrames VideoDrawing Viewbox Viewport2DVisual3D Viewport3D 
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(usage) None. 

(description) This type supports the infrastructure. To make a type animatable, it should 

derive from UIElement, ContentElement, or Animatable. 

[is default constructible] false 

4.381   ICommandSource 

ICommandSource 

Button ButtonBase CalendarButton CalendarDayButton CheckBox DataGridColumnHeader 

DataGridRowHeader GridViewColumnHeader Hyperlink InputBinding KeyBinding MenuItem 

MouseBinding RadioButton RepeatButton RibbonApplicationMenuItem 

RibbonApplicationSplitMenuItem RibbonButton RibbonCheckBox RibbonGallery RibbonMenuItem 

RibbonRadioButton RibbonSplitButton RibbonSplitMenuItem RibbonTextBox RibbonToggleButton 

ThumbButtonInfo ToggleButton 

(usage) None. 

(description) Defines an object that knows how to invoke a command. 

[is default constructible] false 

4.382   IContainItemStorage 

IContainItemStorage 

ComboBox ContextMenu DataGrid DataGridCellsPresenter DataGridColumnHeadersPresenter 

GroupItem HeaderedItemsControl ItemsControl ListBox ListView Menu MenuBase MenuItem 

MultiSelector Ribbon RibbonApplicationMenu RibbonApplicationMenuItem 

RibbonApplicationSplitMenuItem RibbonComboBox RibbonContextMenu 

RibbonContextualTabGroupItemsControl RibbonControlGroup RibbonFilterMenuButton 

RibbonGallery RibbonGalleryCategory RibbonGroup RibbonMenuButton RibbonMenuItem 

RibbonQuickAccessToolBar RibbonSplitButton RibbonSplitMenuItem RibbonTab 

RibbonTabHeaderItemsControl Selector StatusBar TabControl ToolBar TreeView TreeViewItem 

(usage) None. 

(description)  

[is default constructible] false 

4.383   IContentHost 

IContentHost 

TextBlock 

(usage) None. 

(description) This interface is implemented by layouts which host ContentElement. 

[is default constructible] false 
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4.384   IDataObject 

IDataObject 

DataObject 

(usage) None. 

(description) Provides a format-independent mechanism for transferring data. 

[is default constructible] false 

4.385   IEasingFunction 

IEasingFunction 

BackEase BounceEase CircleEase CubicEase EasingFunctionBase ElasticEase ExponentialEase 

PowerEase QuadraticEase QuarticEase QuinticEase SineEase 

(usage) None. 

(description) Defines the basic functionality of an easing function. 

(used by) ByteAnimation ColorAnimation DecimalAnimation DoubleAnimation 

EasingByteKeyFrame EasingColorKeyFrame EasingDecimalKeyFrame 

EasingDoubleKeyFrame EasingInt16KeyFrame EasingInt32KeyFrame 

EasingInt64KeyFrame EasingPoint3DKeyFrame EasingPointKeyFrame 

EasingQuaternionKeyFrame EasingRectKeyFrame EasingRotation3DKeyFrame 

EasingSingleKeyFrame EasingSizeKeyFrame EasingThicknessKeyFrame 

EasingVector3DKeyFrame EasingVectorKeyFrame Int16Animation Int32Animation 

Int64Animation Point3DAnimation PointAnimation QuaternionAnimation RectAnimation 

Rotation3DAnimation SingleAnimation SizeAnimation ThicknessAnimation 

Vector3DAnimation VectorAnimation VisualTransition 

[is default 

constructible] 

false 

4.386   IFrameworkInputElement 

IFrameworkInputElement, IInputElement 
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AccessText AdornedElementPlaceholder AdornerDecorator AnchoredBlock Block BlockUIContainer 

Bold Border BulletDecorator Button ButtonBase Calendar CalendarButton CalendarDayButton 

CalendarItem Canvas CheckBox ColumnDefinition ComboBox ComboBoxItem ContentControl 

ContentPresenter ContextMenu Control DataGrid DataGridCell DataGridCellsPanel 

DataGridCellsPresenter DataGridColumnHeader DataGridColumnHeadersPresenter 

DataGridDetailsPresenter DataGridRow DataGridRowHeader DataGridRowsPresenter DatePicker 

DatePickerTextBox Decorator DefinitionBase DockPanel DocumentPageView DocumentReference 

DocumentViewer DocumentViewerBase Ellipse Expander Figure FixedDocument 

FixedDocumentSequence FixedPage Floater FlowDocument FlowDocumentPageViewer 

FlowDocumentReader FlowDocumentScrollViewer Frame FrameworkContentElement 

FrameworkElement Glyphs Grid GridSplitter GridViewColumnHeader 

GridViewHeaderRowPresenter GridViewRowPresenter GridViewRowPresenterBase GroupBox 

GroupItem HeaderedContentControl HeaderedItemsControl Hyperlink Image InkCanvas 

InkPresenter Inline InlineUIContainer Italic ItemsControl ItemsPresenter KeyTipControl Label 

Line LineBreak List ListBox ListBoxItem ListItem ListView ListViewItem MediaElement Menu 

MenuBase MenuItem MultiSelector NavigationWindow Page PageContent Panel Paragraph 

PasswordBox Path Polygon Polyline Popup ProgressBar RadioButton RangeBase Rectangle 

RepeatButton ResizeGrip Ribbon RibbonApplicationMenu RibbonApplicationMenuItem 

RibbonApplicationSplitMenuItem RibbonButton RibbonCheckBox RibbonComboBox 

RibbonContentPresenter RibbonContextMenu RibbonContextualTabGroup 

RibbonContextualTabGroupItemsControl RibbonControl RibbonControlGroup 

RibbonFilterMenuButton RibbonGallery RibbonGalleryCategory RibbonGalleryItem RibbonGroup 

RibbonMenuButton RibbonMenuItem RibbonQuickAccessToolBar RibbonRadioButton 

RibbonSeparator RibbonSplitButton RibbonSplitMenuItem RibbonTab RibbonTabHeader 

RibbonTabHeaderItemsControl RibbonTextBox RibbonToggleButton RibbonToolTip 

RibbonTwoLineText RibbonWindow RichTextBox RowDefinition Run ScrollBar 

ScrollContentPresenter ScrollViewer Section SelectiveScrollingGrid Selector Separator Shape 

Slider Span StackPanel StatusBar StatusBarItem TabControl TabItem Table TableCell TableColumn 

TableRow TableRowGroup TabPanel TextBlock TextBox TextBoxBase TextElement Thumb TickBar 

ToggleButton ToolBar ToolBarOverflowPanel ToolBarPanel ToolBarTray ToolTip Track TreeView 

TreeViewItem Underline UniformGrid UserControl Viewbox Viewport3D VirtualizingPanel 

VirtualizingStackPanel WebBrowser Window WrapPanel 

(usage) None. 

(description) Declares a namescope contract for framework elements. 

[is default constructible] false 

(properties)  

Name x:String 

(description) The name of an element. 

4.387   IHierarchicalVirtualizationAndScrollInfo (4.5) 

IHierarchicalVirtualizationAndScrollInfo 

GroupItem TreeViewItem 

(usage) None. 

(description) Provides properties through which a control that displays hierarchical data 

communicates with a VirtualizingPanel. 

[is default constructible] false 
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GroupItem TreeViewItem 

(properties)  

Constraints HierarchicalVirtualizationConstraints 

(description) An object that represents the sizes of the control's viewport and cache. 

InBackgroundLayout x:Boolean 

(description) A value that indicates whether the control's layout pass occurs at a lower 

priority. 

ItemDesiredSizes HierarchicalVirtualizationItemDesiredSizes 

(description) An object that represents the desired size of the control's items, in device-

independent units (1/96th inch per unit) and in logical units. 

MustDisableVirtualization x:Boolean 

(description) A value that indicates whether the owning ItemsControl should virtualize 

its items. 

4.388   IInputElement 

IInputElement 
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AccessText AdornedElementPlaceholder AdornerDecorator AnchoredBlock Block BlockUIContainer 

Bold Border BulletDecorator Button ButtonBase Calendar CalendarButton CalendarDayButton 

CalendarItem Canvas CheckBox ColumnDefinition ComboBox ComboBoxItem 

ContainerUIElement3D ContentControl ContentElement ContentPresenter ContextMenu Control 

DataGrid DataGridCell DataGridCellsPanel DataGridCellsPresenter DataGridColumnHeader 

DataGridColumnHeadersPresenter DataGridDetailsPresenter DataGridRow DataGridRowHeader 

DataGridRowsPresenter DatePicker DatePickerTextBox Decorator DefinitionBase DockPanel 

DocumentPageView DocumentReference DocumentViewer DocumentViewerBase Ellipse Expander 

Figure FixedDocument FixedDocumentSequence FixedPage Floater FlowDocument 

FlowDocumentPageViewer FlowDocumentReader FlowDocumentScrollViewer Frame 

FrameworkContentElement FrameworkElement Glyphs Grid GridSplitter GridViewColumnHeader 

GridViewHeaderRowPresenter GridViewRowPresenter GridViewRowPresenterBase GroupBox 

GroupItem HeaderedContentControl HeaderedItemsControl Hyperlink IFrameworkInputElement 

Image InkCanvas InkPresenter Inline InlineUIContainer Italic ItemsControl ItemsPresenter 

KeyTipControl Label Line LineBreak List ListBox ListBoxItem ListItem ListView ListViewItem 

MediaElement Menu MenuBase MenuItem ModelUIElement3D MultiSelector NavigationWindow 

Page PageContent Panel Paragraph PasswordBox Path Polygon Polyline Popup ProgressBar 

RadioButton RangeBase Rectangle RepeatButton ResizeGrip Ribbon RibbonApplicationMenu 

RibbonApplicationMenuItem RibbonApplicationSplitMenuItem RibbonButton RibbonCheckBox 

RibbonComboBox RibbonContentPresenter RibbonContextMenu RibbonContextualTabGroup 

RibbonContextualTabGroupItemsControl RibbonControl RibbonControlGroup 

RibbonFilterMenuButton RibbonGallery RibbonGalleryCategory RibbonGalleryItem RibbonGroup 

RibbonMenuButton RibbonMenuItem RibbonQuickAccessToolBar RibbonRadioButton 

RibbonSeparator RibbonSplitButton RibbonSplitMenuItem RibbonTab RibbonTabHeader 

RibbonTabHeaderItemsControl RibbonTextBox RibbonToggleButton RibbonToolTip 

RibbonTwoLineText RibbonWindow RichTextBox RowDefinition Run ScrollBar 

ScrollContentPresenter ScrollViewer Section SelectiveScrollingGrid Selector Separator Shape 

Slider Span StackPanel StatusBar StatusBarItem TabControl TabItem Table TableCell TableColumn 

TableRow TableRowGroup TabPanel TextBlock TextBox TextBoxBase TextElement Thumb TickBar 

ToggleButton ToolBar ToolBarOverflowPanel ToolBarPanel ToolBarTray ToolTip Track TreeView 

TreeViewItem UIElement UIElement3D Underline UniformGrid UserControl Viewbox Viewport3D 

VirtualizingPanel VirtualizingStackPanel WebBrowser Window WrapPanel 

(usage) None. 

(description) Establishes the common events and also the event-related 

properties and methods for basic input processing by 

elements. 

(used by) ButtonBase FocusManager Hyperlink InputBinding 

Manipulation MenuItem RibbonGallery RibbonSplitButton 

RibbonTextBox ThumbButtonInfo 

[is default constructible] false 

(properties)  

Focusable x:Boolean 

(description) A value that indicates whether focus can be set to this 

element. 

(events)  

GotKeyboardFocus Occurs when the keyboard is focused on this element. 

GotMouseCapture Occurs when the element captures the mouse. 

GotStylusCapture Occurs when the element captures the stylus. 
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AccessText AdornedElementPlaceholder AdornerDecorator AnchoredBlock Block BlockUIContainer 

Bold Border BulletDecorator Button ButtonBase Calendar CalendarButton CalendarDayButton 

CalendarItem Canvas CheckBox ColumnDefinition ComboBox ComboBoxItem 

ContainerUIElement3D ContentControl ContentElement ContentPresenter ContextMenu Control 

DataGrid DataGridCell DataGridCellsPanel DataGridCellsPresenter DataGridColumnHeader 

DataGridColumnHeadersPresenter DataGridDetailsPresenter DataGridRow DataGridRowHeader 

DataGridRowsPresenter DatePicker DatePickerTextBox Decorator DefinitionBase DockPanel 

DocumentPageView DocumentReference DocumentViewer DocumentViewerBase Ellipse Expander 

Figure FixedDocument FixedDocumentSequence FixedPage Floater FlowDocument 

FlowDocumentPageViewer FlowDocumentReader FlowDocumentScrollViewer Frame 

FrameworkContentElement FrameworkElement Glyphs Grid GridSplitter GridViewColumnHeader 

GridViewHeaderRowPresenter GridViewRowPresenter GridViewRowPresenterBase GroupBox 

GroupItem HeaderedContentControl HeaderedItemsControl Hyperlink IFrameworkInputElement 

Image InkCanvas InkPresenter Inline InlineUIContainer Italic ItemsControl ItemsPresenter 

KeyTipControl Label Line LineBreak List ListBox ListBoxItem ListItem ListView ListViewItem 

MediaElement Menu MenuBase MenuItem ModelUIElement3D MultiSelector NavigationWindow 

Page PageContent Panel Paragraph PasswordBox Path Polygon Polyline Popup ProgressBar 

RadioButton RangeBase Rectangle RepeatButton ResizeGrip Ribbon RibbonApplicationMenu 

RibbonApplicationMenuItem RibbonApplicationSplitMenuItem RibbonButton RibbonCheckBox 

RibbonComboBox RibbonContentPresenter RibbonContextMenu RibbonContextualTabGroup 

RibbonContextualTabGroupItemsControl RibbonControl RibbonControlGroup 

RibbonFilterMenuButton RibbonGallery RibbonGalleryCategory RibbonGalleryItem RibbonGroup 

RibbonMenuButton RibbonMenuItem RibbonQuickAccessToolBar RibbonRadioButton 

RibbonSeparator RibbonSplitButton RibbonSplitMenuItem RibbonTab RibbonTabHeader 

RibbonTabHeaderItemsControl RibbonTextBox RibbonToggleButton RibbonToolTip 

RibbonTwoLineText RibbonWindow RichTextBox RowDefinition Run ScrollBar 

ScrollContentPresenter ScrollViewer Section SelectiveScrollingGrid Selector Separator Shape 

Slider Span StackPanel StatusBar StatusBarItem TabControl TabItem Table TableCell TableColumn 

TableRow TableRowGroup TabPanel TextBlock TextBox TextBoxBase TextElement Thumb TickBar 

ToggleButton ToolBar ToolBarOverflowPanel ToolBarPanel ToolBarTray ToolTip Track TreeView 

TreeViewItem UIElement UIElement3D Underline UniformGrid UserControl Viewbox Viewport3D 

VirtualizingPanel VirtualizingStackPanel WebBrowser Window WrapPanel 

KeyDown Occurs when a key is pressed while the keyboard is focused 

on this element. 

KeyUp Occurs when a key is released while the keyboard is focused 

on this element. 

LostKeyboardFocus Occurs when the keyboard is no longer focused on this 

element. 

LostMouseCapture Occurs when this element loses mouse capture. 

LostStylusCapture Occurs when this element loses stylus capture. 

MouseEnter Occurs when the mouse pointer enters the bounds of this 

element. 

MouseLeave Occurs when the mouse pointer leaves the bounds of this 

element. 

MouseLeftButtonDown Occurs when the left mouse button is pressed while the 

mouse pointer is over the element. 

MouseLeftButtonUp Occurs when the left mouse button is released while the 

mouse pointer is over the element. 

MouseMove Occurs when the mouse pointer moves while the mouse 
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AccessText AdornedElementPlaceholder AdornerDecorator AnchoredBlock Block BlockUIContainer 

Bold Border BulletDecorator Button ButtonBase Calendar CalendarButton CalendarDayButton 

CalendarItem Canvas CheckBox ColumnDefinition ComboBox ComboBoxItem 

ContainerUIElement3D ContentControl ContentElement ContentPresenter ContextMenu Control 

DataGrid DataGridCell DataGridCellsPanel DataGridCellsPresenter DataGridColumnHeader 

DataGridColumnHeadersPresenter DataGridDetailsPresenter DataGridRow DataGridRowHeader 

DataGridRowsPresenter DatePicker DatePickerTextBox Decorator DefinitionBase DockPanel 

DocumentPageView DocumentReference DocumentViewer DocumentViewerBase Ellipse Expander 

Figure FixedDocument FixedDocumentSequence FixedPage Floater FlowDocument 

FlowDocumentPageViewer FlowDocumentReader FlowDocumentScrollViewer Frame 

FrameworkContentElement FrameworkElement Glyphs Grid GridSplitter GridViewColumnHeader 

GridViewHeaderRowPresenter GridViewRowPresenter GridViewRowPresenterBase GroupBox 

GroupItem HeaderedContentControl HeaderedItemsControl Hyperlink IFrameworkInputElement 

Image InkCanvas InkPresenter Inline InlineUIContainer Italic ItemsControl ItemsPresenter 

KeyTipControl Label Line LineBreak List ListBox ListBoxItem ListItem ListView ListViewItem 

MediaElement Menu MenuBase MenuItem ModelUIElement3D MultiSelector NavigationWindow 

Page PageContent Panel Paragraph PasswordBox Path Polygon Polyline Popup ProgressBar 

RadioButton RangeBase Rectangle RepeatButton ResizeGrip Ribbon RibbonApplicationMenu 

RibbonApplicationMenuItem RibbonApplicationSplitMenuItem RibbonButton RibbonCheckBox 

RibbonComboBox RibbonContentPresenter RibbonContextMenu RibbonContextualTabGroup 

RibbonContextualTabGroupItemsControl RibbonControl RibbonControlGroup 

RibbonFilterMenuButton RibbonGallery RibbonGalleryCategory RibbonGalleryItem RibbonGroup 

RibbonMenuButton RibbonMenuItem RibbonQuickAccessToolBar RibbonRadioButton 

RibbonSeparator RibbonSplitButton RibbonSplitMenuItem RibbonTab RibbonTabHeader 

RibbonTabHeaderItemsControl RibbonTextBox RibbonToggleButton RibbonToolTip 

RibbonTwoLineText RibbonWindow RichTextBox RowDefinition Run ScrollBar 

ScrollContentPresenter ScrollViewer Section SelectiveScrollingGrid Selector Separator Shape 

Slider Span StackPanel StatusBar StatusBarItem TabControl TabItem Table TableCell TableColumn 

TableRow TableRowGroup TabPanel TextBlock TextBox TextBoxBase TextElement Thumb TickBar 

ToggleButton ToolBar ToolBarOverflowPanel ToolBarPanel ToolBarTray ToolTip Track TreeView 

TreeViewItem UIElement UIElement3D Underline UniformGrid UserControl Viewbox Viewport3D 

VirtualizingPanel VirtualizingStackPanel WebBrowser Window WrapPanel 

pointer is over the element. 

MouseRightButtonDown Occurs when the right mouse button is pressed while the 

mouse pointer is over the element. 

MouseRightButtonUp Occurs when the right mouse button is released while the 

mouse pointer is over the element. 

MouseWheel Occurs when the mouse wheel moves while the mouse 

pointer is over this element. 

PreviewGotKeyboardFocus Occurs when the keyboard is focused on this element. 

PreviewKeyDown Occurs when a key is pressed while the keyboard is focused 

on this element. 

PreviewKeyUp Occurs when a key is released while the keyboard is focused 

on this element. 

PreviewLostKeyboardFocus Occurs when the keyboard is no longer focused on this 

element. 

PreviewMouseLeftButtonDown Occurs when the left mouse button is pressed while the 

mouse pointer is over the element. 

PreviewMouseLeftButtonUp Occurs when the left mouse button is released while the 

mouse pointer is over the element. 
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AccessText AdornedElementPlaceholder AdornerDecorator AnchoredBlock Block BlockUIContainer 

Bold Border BulletDecorator Button ButtonBase Calendar CalendarButton CalendarDayButton 

CalendarItem Canvas CheckBox ColumnDefinition ComboBox ComboBoxItem 

ContainerUIElement3D ContentControl ContentElement ContentPresenter ContextMenu Control 

DataGrid DataGridCell DataGridCellsPanel DataGridCellsPresenter DataGridColumnHeader 

DataGridColumnHeadersPresenter DataGridDetailsPresenter DataGridRow DataGridRowHeader 

DataGridRowsPresenter DatePicker DatePickerTextBox Decorator DefinitionBase DockPanel 

DocumentPageView DocumentReference DocumentViewer DocumentViewerBase Ellipse Expander 

Figure FixedDocument FixedDocumentSequence FixedPage Floater FlowDocument 

FlowDocumentPageViewer FlowDocumentReader FlowDocumentScrollViewer Frame 

FrameworkContentElement FrameworkElement Glyphs Grid GridSplitter GridViewColumnHeader 

GridViewHeaderRowPresenter GridViewRowPresenter GridViewRowPresenterBase GroupBox 

GroupItem HeaderedContentControl HeaderedItemsControl Hyperlink IFrameworkInputElement 

Image InkCanvas InkPresenter Inline InlineUIContainer Italic ItemsControl ItemsPresenter 

KeyTipControl Label Line LineBreak List ListBox ListBoxItem ListItem ListView ListViewItem 

MediaElement Menu MenuBase MenuItem ModelUIElement3D MultiSelector NavigationWindow 

Page PageContent Panel Paragraph PasswordBox Path Polygon Polyline Popup ProgressBar 

RadioButton RangeBase Rectangle RepeatButton ResizeGrip Ribbon RibbonApplicationMenu 

RibbonApplicationMenuItem RibbonApplicationSplitMenuItem RibbonButton RibbonCheckBox 

RibbonComboBox RibbonContentPresenter RibbonContextMenu RibbonContextualTabGroup 

RibbonContextualTabGroupItemsControl RibbonControl RibbonControlGroup 

RibbonFilterMenuButton RibbonGallery RibbonGalleryCategory RibbonGalleryItem RibbonGroup 

RibbonMenuButton RibbonMenuItem RibbonQuickAccessToolBar RibbonRadioButton 

RibbonSeparator RibbonSplitButton RibbonSplitMenuItem RibbonTab RibbonTabHeader 

RibbonTabHeaderItemsControl RibbonTextBox RibbonToggleButton RibbonToolTip 

RibbonTwoLineText RibbonWindow RichTextBox RowDefinition Run ScrollBar 

ScrollContentPresenter ScrollViewer Section SelectiveScrollingGrid Selector Separator Shape 

Slider Span StackPanel StatusBar StatusBarItem TabControl TabItem Table TableCell TableColumn 

TableRow TableRowGroup TabPanel TextBlock TextBox TextBoxBase TextElement Thumb TickBar 

ToggleButton ToolBar ToolBarOverflowPanel ToolBarPanel ToolBarTray ToolTip Track TreeView 

TreeViewItem UIElement UIElement3D Underline UniformGrid UserControl Viewbox Viewport3D 

VirtualizingPanel VirtualizingStackPanel WebBrowser Window WrapPanel 

PreviewMouseMove Occurs when the mouse pointer moves while the mouse 

pointer is over the element. 

PreviewMouseRightButtonDown Occurs when the right mouse button is pressed while the 

mouse pointer is over the element. 

PreviewMouseRightButtonUp Occurs when the right mouse button is released while the 

mouse pointer is over the element. 

PreviewMouseWheel Occurs when the mouse wheel moves while the mouse 

pointer is over this element. 

PreviewStylusButtonDown Occurs when the stylus button is pressed down while the 

stylus is over this element. 

PreviewStylusButtonUp Occurs when the stylus button is released while the stylus is 

over this element. 

PreviewStylusDown Occurs when the stylus touches the digitizer while over this 

element. 

PreviewStylusInAirMove Occurs when the stylus moves over an element, but without 

touching the digitizer. 

PreviewStylusInRange Occurs when the stylus is close enough to the digitizer to be 

detected. 
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AccessText AdornedElementPlaceholder AdornerDecorator AnchoredBlock Block BlockUIContainer 

Bold Border BulletDecorator Button ButtonBase Calendar CalendarButton CalendarDayButton 

CalendarItem Canvas CheckBox ColumnDefinition ComboBox ComboBoxItem 

ContainerUIElement3D ContentControl ContentElement ContentPresenter ContextMenu Control 

DataGrid DataGridCell DataGridCellsPanel DataGridCellsPresenter DataGridColumnHeader 

DataGridColumnHeadersPresenter DataGridDetailsPresenter DataGridRow DataGridRowHeader 

DataGridRowsPresenter DatePicker DatePickerTextBox Decorator DefinitionBase DockPanel 

DocumentPageView DocumentReference DocumentViewer DocumentViewerBase Ellipse Expander 

Figure FixedDocument FixedDocumentSequence FixedPage Floater FlowDocument 

FlowDocumentPageViewer FlowDocumentReader FlowDocumentScrollViewer Frame 

FrameworkContentElement FrameworkElement Glyphs Grid GridSplitter GridViewColumnHeader 

GridViewHeaderRowPresenter GridViewRowPresenter GridViewRowPresenterBase GroupBox 

GroupItem HeaderedContentControl HeaderedItemsControl Hyperlink IFrameworkInputElement 

Image InkCanvas InkPresenter Inline InlineUIContainer Italic ItemsControl ItemsPresenter 

KeyTipControl Label Line LineBreak List ListBox ListBoxItem ListItem ListView ListViewItem 

MediaElement Menu MenuBase MenuItem ModelUIElement3D MultiSelector NavigationWindow 

Page PageContent Panel Paragraph PasswordBox Path Polygon Polyline Popup ProgressBar 

RadioButton RangeBase Rectangle RepeatButton ResizeGrip Ribbon RibbonApplicationMenu 

RibbonApplicationMenuItem RibbonApplicationSplitMenuItem RibbonButton RibbonCheckBox 

RibbonComboBox RibbonContentPresenter RibbonContextMenu RibbonContextualTabGroup 

RibbonContextualTabGroupItemsControl RibbonControl RibbonControlGroup 

RibbonFilterMenuButton RibbonGallery RibbonGalleryCategory RibbonGalleryItem RibbonGroup 

RibbonMenuButton RibbonMenuItem RibbonQuickAccessToolBar RibbonRadioButton 

RibbonSeparator RibbonSplitButton RibbonSplitMenuItem RibbonTab RibbonTabHeader 

RibbonTabHeaderItemsControl RibbonTextBox RibbonToggleButton RibbonToolTip 

RibbonTwoLineText RibbonWindow RichTextBox RowDefinition Run ScrollBar 

ScrollContentPresenter ScrollViewer Section SelectiveScrollingGrid Selector Separator Shape 

Slider Span StackPanel StatusBar StatusBarItem TabControl TabItem Table TableCell TableColumn 

TableRow TableRowGroup TabPanel TextBlock TextBox TextBoxBase TextElement Thumb TickBar 

ToggleButton ToolBar ToolBarOverflowPanel ToolBarPanel ToolBarTray ToolTip Track TreeView 

TreeViewItem UIElement UIElement3D Underline UniformGrid UserControl Viewbox Viewport3D 

VirtualizingPanel VirtualizingStackPanel WebBrowser Window WrapPanel 

PreviewStylusMove Occurs when the stylus moves while the stylus is over the 

element. 

PreviewStylusOutOfRange Occurs when the stylus is too far from the digitizer to be 

detected. 

PreviewStylusSystemGesture Occurs when one of several stylus gestures are detected, for 

example, Tap or Drag. 

PreviewStylusUp Occurs when the stylus is raised off the digitizer while over 

this element. 

PreviewTextInput Occurs when this element gets text in a device-independent 

manner. 

StylusButtonDown Occurs when the stylus button is pressed while the stylus is 

over this element. 

StylusButtonUp Occurs when the stylus button is released while the stylus is 

over this element. 

StylusDown Occurs when the stylus touches the digitizer while over this 

element. 

StylusEnter Occurs when the stylus cursor enters the bounds of the 

element. 
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AccessText AdornedElementPlaceholder AdornerDecorator AnchoredBlock Block BlockUIContainer 

Bold Border BulletDecorator Button ButtonBase Calendar CalendarButton CalendarDayButton 

CalendarItem Canvas CheckBox ColumnDefinition ComboBox ComboBoxItem 

ContainerUIElement3D ContentControl ContentElement ContentPresenter ContextMenu Control 

DataGrid DataGridCell DataGridCellsPanel DataGridCellsPresenter DataGridColumnHeader 

DataGridColumnHeadersPresenter DataGridDetailsPresenter DataGridRow DataGridRowHeader 

DataGridRowsPresenter DatePicker DatePickerTextBox Decorator DefinitionBase DockPanel 

DocumentPageView DocumentReference DocumentViewer DocumentViewerBase Ellipse Expander 

Figure FixedDocument FixedDocumentSequence FixedPage Floater FlowDocument 

FlowDocumentPageViewer FlowDocumentReader FlowDocumentScrollViewer Frame 

FrameworkContentElement FrameworkElement Glyphs Grid GridSplitter GridViewColumnHeader 

GridViewHeaderRowPresenter GridViewRowPresenter GridViewRowPresenterBase GroupBox 

GroupItem HeaderedContentControl HeaderedItemsControl Hyperlink IFrameworkInputElement 

Image InkCanvas InkPresenter Inline InlineUIContainer Italic ItemsControl ItemsPresenter 

KeyTipControl Label Line LineBreak List ListBox ListBoxItem ListItem ListView ListViewItem 

MediaElement Menu MenuBase MenuItem ModelUIElement3D MultiSelector NavigationWindow 

Page PageContent Panel Paragraph PasswordBox Path Polygon Polyline Popup ProgressBar 

RadioButton RangeBase Rectangle RepeatButton ResizeGrip Ribbon RibbonApplicationMenu 

RibbonApplicationMenuItem RibbonApplicationSplitMenuItem RibbonButton RibbonCheckBox 

RibbonComboBox RibbonContentPresenter RibbonContextMenu RibbonContextualTabGroup 

RibbonContextualTabGroupItemsControl RibbonControl RibbonControlGroup 

RibbonFilterMenuButton RibbonGallery RibbonGalleryCategory RibbonGalleryItem RibbonGroup 

RibbonMenuButton RibbonMenuItem RibbonQuickAccessToolBar RibbonRadioButton 

RibbonSeparator RibbonSplitButton RibbonSplitMenuItem RibbonTab RibbonTabHeader 

RibbonTabHeaderItemsControl RibbonTextBox RibbonToggleButton RibbonToolTip 

RibbonTwoLineText RibbonWindow RichTextBox RowDefinition Run ScrollBar 

ScrollContentPresenter ScrollViewer Section SelectiveScrollingGrid Selector Separator Shape 

Slider Span StackPanel StatusBar StatusBarItem TabControl TabItem Table TableCell TableColumn 

TableRow TableRowGroup TabPanel TextBlock TextBox TextBoxBase TextElement Thumb TickBar 

ToggleButton ToolBar ToolBarOverflowPanel ToolBarPanel ToolBarTray ToolTip Track TreeView 

TreeViewItem UIElement UIElement3D Underline UniformGrid UserControl Viewbox Viewport3D 

VirtualizingPanel VirtualizingStackPanel WebBrowser Window WrapPanel 

StylusInAirMove Occurs when the stylus moves over an element, but without 

touching the digitizer. 

StylusInRange Occurs when the stylus is close enough to the digitizer to be 

detected. 

StylusLeave Occurs when the stylus cursor leaves the bounds of the 

element. 

StylusMove Occurs when the stylus cursor moves over the element. 

StylusOutOfRange Occurs when the stylus is too far from the digitizer to be 

detected. 

StylusSystemGesture Occurs when one of several stylus gestures are detected, for 

example, Tap or Drag. 

StylusUp Occurs when the stylus is raised off the digitizer while over 

this element. 

TextInput Occurs when this element gets text in a device-independent 

manner. 

4.389   IKeyFrame 

IKeyFrame 
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BooleanKeyFrame ByteKeyFrame CharKeyFrame ColorKeyFrame DecimalKeyFrame 

DiscreteBooleanKeyFrame DiscreteByteKeyFrame DiscreteCharKeyFrame DiscreteColorKeyFrame 

DiscreteDecimalKeyFrame DiscreteDoubleKeyFrame DiscreteInt16KeyFrame 

DiscreteInt32KeyFrame DiscreteInt64KeyFrame DiscreteMatrixKeyFrame 

DiscreteObjectKeyFrame DiscretePoint3DKeyFrame DiscretePointKeyFrame 

DiscreteQuaternionKeyFrame DiscreteRectKeyFrame DiscreteRotation3DKeyFrame 

DiscreteSingleKeyFrame DiscreteSizeKeyFrame DiscreteStringKeyFrame 

DiscreteThicknessKeyFrame DiscreteVector3DKeyFrame DiscreteVectorKeyFrame 

DoubleKeyFrame EasingByteKeyFrame EasingColorKeyFrame EasingDecimalKeyFrame 

EasingDoubleKeyFrame EasingInt16KeyFrame EasingInt32KeyFrame EasingInt64KeyFrame 

EasingPoint3DKeyFrame EasingPointKeyFrame EasingQuaternionKeyFrame EasingRectKeyFrame 

EasingRotation3DKeyFrame EasingSingleKeyFrame EasingSizeKeyFrame 

EasingThicknessKeyFrame EasingVector3DKeyFrame EasingVectorKeyFrame Int16KeyFrame 

Int32KeyFrame Int64KeyFrame LinearByteKeyFrame LinearColorKeyFrame 

LinearDecimalKeyFrame LinearDoubleKeyFrame LinearInt16KeyFrame LinearInt32KeyFrame 

LinearInt64KeyFrame LinearPoint3DKeyFrame LinearPointKeyFrame LinearQuaternionKeyFrame 

LinearRectKeyFrame LinearRotation3DKeyFrame LinearSingleKeyFrame LinearSizeKeyFrame 

LinearThicknessKeyFrame LinearVector3DKeyFrame LinearVectorKeyFrame MatrixKeyFrame 

ObjectKeyFrame Point3DKeyFrame PointKeyFrame QuaternionKeyFrame RectKeyFrame 

Rotation3DKeyFrame SingleKeyFrame SizeKeyFrame SplineByteKeyFrame SplineColorKeyFrame 

SplineDecimalKeyFrame SplineDoubleKeyFrame SplineInt16KeyFrame SplineInt32KeyFrame 

SplineInt64KeyFrame SplinePoint3DKeyFrame SplinePointKeyFrame SplineQuaternionKeyFrame 

SplineRectKeyFrame SplineRotation3DKeyFrame SplineSingleKeyFrame SplineSizeKeyFrame 

SplineThicknessKeyFrame SplineVector3DKeyFrame SplineVectorKeyFrame StringKeyFrame 

ThicknessKeyFrame Vector3DKeyFrame VectorKeyFrame 

(usage) None. 

(description) An IKeyFrame interface implementation provides un-typed access to 

KeyTime properties. 

[is default constructible] false 

(properties)  

KeyTime KeyTime 

(description) KeyTime values associated with a KeyFrame object. 

Value x:Object 

(description) The value associated with a KeyTime instance. 

4.390   IKeyFrameAnimation 

IKeyFrameAnimation 

BooleanAnimationUsingKeyFrames ByteAnimationUsingKeyFrames 

CharAnimationUsingKeyFrames ColorAnimationUsingKeyFrames 

DecimalAnimationUsingKeyFrames DoubleAnimationUsingKeyFrames 

Int16AnimationUsingKeyFrames Int32AnimationUsingKeyFrames Int64AnimationUsingKeyFrames 

MatrixAnimationUsingKeyFrames ObjectAnimationUsingKeyFrames 

Point3DAnimationUsingKeyFrames PointAnimationUsingKeyFrames 

QuaternionAnimationUsingKeyFrames RectAnimationUsingKeyFrames 

Rotation3DAnimationUsingKeyFrames SingleAnimationUsingKeyFrames 

SizeAnimationUsingKeyFrames StringAnimationUsingKeyFrames 

ThicknessAnimationUsingKeyFrames Vector3DAnimationUsingKeyFrames 

VectorAnimationUsingKeyFrames 
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BooleanAnimationUsingKeyFrames ByteAnimationUsingKeyFrames 

CharAnimationUsingKeyFrames ColorAnimationUsingKeyFrames 

DecimalAnimationUsingKeyFrames DoubleAnimationUsingKeyFrames 

Int16AnimationUsingKeyFrames Int32AnimationUsingKeyFrames Int64AnimationUsingKeyFrames 

MatrixAnimationUsingKeyFrames ObjectAnimationUsingKeyFrames 

Point3DAnimationUsingKeyFrames PointAnimationUsingKeyFrames 

QuaternionAnimationUsingKeyFrames RectAnimationUsingKeyFrames 

Rotation3DAnimationUsingKeyFrames SingleAnimationUsingKeyFrames 

SizeAnimationUsingKeyFrames StringAnimationUsingKeyFrames 

ThicknessAnimationUsingKeyFrames Vector3DAnimationUsingKeyFrames 

VectorAnimationUsingKeyFrames 

(usage) None. 

(description) An IKeyFrameAnimation interface implementation provides untyped access 

to key frame collection members. 

[is default constructible] false 

(properties)  

KeyFrames IList 

(description) An ordered collection KeyFrames associated with this animation sequence. 

4.391   Image 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Image, IInputElement 

(usage) <Image /> 

(description) Represents a control that displays an image. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Source ImageSource 

(description) The ImageSource for the image. 

Stretch Stretch 

(description) A value that describes how an Image should be stretched to fill the destination 

rectangle. 

StretchDirection StretchDirection 

(description) A value that indicates how the image is scaled. 

(events)  

ImageFailed Occurs when there is a failure in the image. 



 

268 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

4.392   ImageBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > TileBrush > ImageBrush 

(usage) <ImageBrush> string </ImageBrush> 

(description) Paints an area with an image. 

[text syntax] BrushSyntax 

(properties)  

ImageSource ImageSource 

(description) The image displayed by this ImageBrush. 

4.393   ImageDrawing 

x:Object > DependencyObject > Freezable > Animatable > Drawing > ImageDrawing 

(usage) <ImageDrawing /> 

(description) Draws an image within a region defined by a Rect. 

(properties)  

ImageSource ImageSource 

(description) The source of the image 

Rect Rect 

(description) The region in which the image is drawn. 

4.394   ImageSource 

x:Object > DependencyObject > Freezable > Animatable > ImageSource 

BitmapSource DrawingImage 

(usage) <ImageSource> string </ImageSource> 

(description) Represents a object type that has a width, height, and ImageMetadata such as a  

BitmapSource and a DrawingImage. 

(used by) Image ImageBrush ImageDrawing RibbonButton RibbonCheckBox 

RibbonControlService RibbonGallery RibbonGalleryItem RibbonGroup 

RibbonMenuButton RibbonMenuItem RibbonRadioButton RibbonSplitButton 

RibbonSplitMenuItem RibbonTextBox RibbonToggleButton RibbonToolTip 

TaskbarItemInfo ThumbButtonInfo Window 

[is default 

constructible] 

false 

[text syntax] x:Uri, from [MS-XAML] 

http://go.microsoft.com/fwlink/?LinkId=390715
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4.395   ImeConversionModeValues 

x:Object > ImeConversionModeValues 

(usage) Native| Katakana| FullShape| Roman| CharCode| NoConversion| Eudc| Symbol| 

Fixed... 

(description) Describes a mode of input conversion to be performed by an input method. 

(used by) InputMethod 

[is nullable] false 

[text 

syntax] 

ImeConversionModeValuesSyntax 

4.396   ImeSentenceModeValues 

x:Object > ImeSentenceModeValues 

(usage) None| PluralClause| SingleConversion| Automatic| PhrasePrediction| 

Conversation| DoNotCare 

(description) Specifies the mode of sentence conversion performed by an input method. 

(used by) InputMethod 

[is nullable] false 

[text 

syntax] 

ImeSentenceModeValuesSyntax 

4.397   IMultiValueConverter 

IMultiValueConverter 

BorderGapMaskConverter JournalEntryUnifiedViewConverter MenuScrollingVisibilityConverter 

(usage) None. 

(description) Provides a way to apply custom logic in a MultiBinding. 

(used by) MultiBinding 

[is default constructible] false 

4.398   InertiaExpansionBehavior 

x:Object > InertiaExpansionBehavior 

(usage) <InertiaExpansionBehavior /> 

(description) Controls the deceleration of a resizing manipulation during inertia. 

(properties)  
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(usage) <InertiaExpansionBehavior /> 

DesiredDeceleration x:Double 

(description) The rate that resizing slows in device-independent units (1/96th inch per unit) 

per square milliseconds. 

DesiredExpansion Vector 

(description) The amount the element resizes at the end of inertia. 

InitialRadius x:Double 

(description) The initial average radius. 

InitialVelocity Vector 

(description) The initial rate the element resizes at the start of inertia. 

4.399   InertiaRotationBehavior 

x:Object > InertiaRotationBehavior 

(usage) <InertiaRotationBehavior /> 

(description) Controls the deceleration of a rotation manipulation during inertia. 

(properties)  

DesiredDeceleration x:Double 

(description) The rate the rotation slows in degrees per squared millisecond. 

DesiredRotation x:Double 

(description) The rotation, in degrees, at the end of the inertial movement. 

InitialVelocity x:Double 

(description) The initial rate of the rotation at the start of the inertia phase. 

4.400   InertiaTranslationBehavior 

x:Object > InertiaTranslationBehavior 

(usage) <InertiaTranslationBehavior /> 

(description) Controls deceleration on a translation manipulation during inertia. 

(properties)  

DesiredDeceleration x:Double 

(description) The rate the linear movement slows in device-independent units (1/96th inch 

per unit) per squared millisecond. 

DesiredDisplacement x:Double 
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(usage) <InertiaTranslationBehavior /> 

(description) The linear movement of the manipulation at the end of inertia. 

InitialVelocity Vector 

(description) The initial rate of linear movement at the start of the inertia phase. 

4.401   InheritanceBehavior 

x:Object > InheritanceBehavior 

(usage) Default| SkipToAppNow| SkipToAppNext| SkipToThemeNow| SkipToThemeNext| 

SkipAllNow| SkipAllNext 

(description) Indicates the current mode of lookup for both property value inheritance, a resource 

lookup, and a RelativeSource FindAncestor lookup. 

[is nullable] false 

[text 

syntax] 

InheritanceBehaviorSyntax 

4.402   InkCanvas 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > InkCanvas, 

IInputElement 

(usage) <InkCanvas>UIElement*</InkCanvas> 

(description) Defines an area that receives and displays ink strokes. 

[content property] Children 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) A Brush. The brush is used to fill the border area surrounding a 

InkCanvas. 

Children UIElementCollection 

(description) Retrieves child elements of the InkCanvas. 

[read only] true 

DefaultDrawingAttributes DrawingAttributes 

(description) The drawing attributes that are applied to new ink strokes made 

on the InkCanvas. 

DefaultStylusPointDescription StylusPointDescription 
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(usage) <InkCanvas>UIElement*</InkCanvas> 

(description) The stylus point description for an InkCanvas. 

EditingMode InkCanvasEditingMode 

(description) The user editing mode used by an active pointing device. 

EditingModeInverted InkCanvasEditingMode 

(description) The user editing mode if the stylus is inverted when it interacts 

with the InkCanvas. 

MoveEnabled x:Boolean 

(description) A Boolean value which indicates whether the user is enabled to 

move selected ink strokes and/or elements on the InkCanvas. 

ResizeEnabled x:Boolean 

(description) A Boolean value that indicates whether the user can resize 

selected ink strokes and/or elements on the InkCanvas. 

Strokes StrokeCollection 

(description) The collection of ink Stroke objects collected by the InkCanvas. 

UseCustomCursor x:Boolean 

(description) A Boolean value that indicates whether to override standard 

InkCanvas cursor functionality to support a custom cursor. 

(attachable properties)  

InkCanvas.Bottom x:Double 

(description) The distance between the bottom of an element and the bottom 

of its parent InkCanvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

InkCanvas.Left x:Double 

(description) The distance between the left side of an element and the left 

side of its parent InkCanvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

InkCanvas.Right x:Double 

(description) The distance between the right side of an element and the right 

side of its parent InkCanvas. 

[target type] UIElement 

[text syntax] LengthSyntax 
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(usage) <InkCanvas>UIElement*</InkCanvas> 

InkCanvas.Top x:Double 

(description) The distance between the top of an element and the top of its 

parent InkCanvas. 

[target type] UIElement 

[text syntax] LengthSyntax 

(events)  

ActiveEditingModeChanged Occurs when the current editing mode changes. 

DefaultDrawingAttributesReplaced Occurs when the DefaultDrawingAttributes property is replaced. 

EditingModeChanged Occurs when the EditingMode property of an InkCanvas object 

has been changed. 

EditingModeInvertedChanged Occurs when the EditingModeInverted property of an InkCanvas 

object has been changed. 

Gesture Occurs when the InkCanvas detects a gesture. 

SelectionChanged Occurs when the selection on the InkCanvas changes. 

SelectionChanging Occurs when a new set of ink strokes and/or elements is being 

selected. 

SelectionMoved Occurs after the user moves a selection of strokes and/or 

elements. 

SelectionMoving Occurs before selected strokes and elements are moved. 

SelectionResized Occurs when a selection of strokes and/or elements has been 

resized by the user. 

SelectionResizing Occurs before selected strokes and elements are resized. 

StrokeCollected Occurs when a stroke drawn by the user is added to the Strokes 

property. 

StrokeErased Occurs when user erases a stroke. 

StrokeErasing Occurs just before a user erases a stroke. 

StrokesReplaced Occurs when the Strokes property is replaced. 

4.403   InkCanvasClipboardFormat 

x:Object > InkCanvasClipboardFormat 

(usage) InkSerializedFormat| Text| Xaml 

(description) Specifies the formats that an InkCanvas will accept from the Clipboard. 

[is nullable] false 
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(usage) InkSerializedFormat| Text| Xaml 

[text syntax] InkCanvasClipboardFormatSyntax 

4.404   InkCanvasEditingMode 

x:Object > InkCanvasEditingMode 

(usage) None| Ink| GestureOnly| InkAndGesture| Select| EraseByPoint| EraseByStroke 

(description) Specifies the editing mode for the InkCanvas 

(used by) InkCanvas 

[is nullable] false 

[text syntax] InkCanvasEditingModeSyntax 

4.405   InkCanvasSelectionHitResult 

x:Object > InkCanvasSelectionHitResult 

(usage) None| TopLeft| Top| TopRight| Right| BottomRight| Bottom| BottomLeft| Left... 

(description) Identifies the various parts of a selection adorner on an InkCanvas. 

[is nullable] false 

[text syntax] InkCanvasSelectionHitResultSyntax 

4.406   InkPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Decorator > 
InkPresenter, IInputElement 

(usage) <InkPresenter>UIElement</InkPresenter> 

(description) Renders ink on a surface. 

[content property] Child 

[name property] Name 

[xml lang property] Language 

(properties)  

Strokes StrokeCollection 

(description) The strokes that the InkPresenter displays. 

4.407   Inline 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline, IInputElement 
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AnchoredBlock InlineUIContainer LineBreak Run Span 

(usage) None. 

(description) A base type that provides a base for all inline flow content elements. 

(used by) InlineCollection 

[is default 

constructible] 

false 

[name property] Name 

[xml lang property] Language 

(properties)  

BaselineAlignment BaselineAlignment 

(description) The baseline alignment for the Inline element. 

FlowDirection FlowDirection 

(description) A value that specifies the relative direction for flow of content within a Inline 

element. 

SiblingInlines InlineCollection 

(description) An InlineCollection that contains the Inline elements that are siblings (peers) 

to this element. 

[read only] true 

TextDecorations TextDecorationCollection 

(description) A TextDecorationCollection that contains text decorations to apply to this 

element. 

4.408   InlineCollection 

x:Object > TextElementCollection(Inline) > InlineCollection 

(usage) None. 

(description) Represents a collection of Inline elements. InlineCollection defines the 

allowable child content of the Paragraph, Span, and TextBlock elements. 

(used by) Inline Paragraph Span TextBlock 

[is default 

constructible] 

false 

[whitespace significant 

collection] 

true 

[is list] true 

[allowed types] Inline UIElement x:String 
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4.409   InlineUIContainer 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > InlineUIContainer, IInputElement 

(usage) <InlineUIContainer>UIElement</InlineUIContainer> 

(description) An inline-level flow content element which enables UIElement elements (i.e. a Button) 

to be embedded (hosted) in flow content. 

[content 

property] 

Child 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

Child UIElement 

(description) The UIElement hosted by the InlineUIContainer. 

4.410   InputBinding 

x:Object > DependencyObject > Freezable > InputBinding 

KeyBinding MouseBinding 

(usage) None. 

(description) Represents a binding between an InputGesture and a command. The 

command is potentially a RoutedCommand. 

(used by) InputBindingCollection 

[is default 

constructible] 

false 

(properties)  

Command ICommand 

(description) The ICommand associated with this input binding. 

CommandParameter x:Object 

(description) The command-specific data for a particular command. 

CommandTarget IInputElement 

(description) The target element of the command. 

Gesture InputGesture 

(description) The InputGesture associated with this input binding. 
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4.411   InputBindingCollection 

x:Object > InputBindingCollection 

(usage) <InputBindingCollection>InputBinding*</InputBindingCollection> 

(description) Represents an ordered collection of InputBinding objects. 

(used by) ContentElement UIElement UIElement3D 

[is list] true 

[allowed types] InputBinding 

4.412   InputGesture 

x:Object > InputGesture 

KeyGesture MouseGesture 

(usage) None. 

(description) A base type that describes input device gestures. 

(used by) InputBinding InputGestureCollection KeyBinding MouseBinding 

[is default constructible] false 

4.413   InputGestureCollection 

x:Object > InputGestureCollection 

(usage) <InputGestureCollection>InputGesture*</InputGestureCollection> 

(description) Represents an ordered collection of InputGesture objects. 

(used by) RoutedCommand 

[is list] true 

[allowed types] InputGesture 

4.414   InputLanguageManager 

x:Object > InputLanguageManager 

(usage) {x:Static 

InputLanguageManager.StaticPropertyName} 

(description) Provides facilities for managing input languages in. 

[is default constructible] false 

(properties)  

CurrentInputLanguage CultureInfo 
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(usage) {x:Static 

InputLanguageManager.StaticPropertyName} 

(description) The current input language. 

[text syntax] CultureInfoIetfLanguageTagSyntax 

(attachable properties)  

InputLanguageManager.InputLanguage CultureInfo 

(description) The preferred input language for the associated 

dependency object. 

[target type] DependencyObject 

[text syntax] CultureInfoIetfLanguageTagSyntax 

InputLanguageManager.RestoreInputLanguage x:Boolean 

(description) A value that indicates whether or not the 

previously active input language should be 

restored when the associated dependency object 

looses the input focus. 

[target type] DependencyObject 

(static properties)  

Current InputLanguageManager 

(description) The input language manager associated with the 

current context. 

(events)  

InputLanguageChanged Occurs when a change of input language is 

completed. 

InputLanguageChanging Occurs when a change of input language is 

initiated. 

4.415   InputManager 

x:Object > InputManager 

(usage) {x:Static InputManager.StaticPropertyName} 

(description) Manages all the input systems in. 

[is default 

constructible] 

false 

(static properties)  

Current InputManager 

(description) The InputManager associated with the current thread. 
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(usage) {x:Static InputManager.StaticPropertyName} 

(events)  

EnterMenuMode Occurs when a control enters menu mode by calling the PresentationSource) 

method. 

HitTestInvalidatedAsync Occurs when the result of a hit-test may have changed. 

LeaveMenuMode Occurs when a control leaves menu mode by calling the PresentationSource) 

method. 

PostNotifyInput Occurs after the PreNotifyInput handlers have finished processing the input 

and the corresponding events have been raised. 

PostProcessInput Occurs after the PreNotifyInput handlers have finished processing the input. 

PreNotifyInput Occurs when the PreProcessInput handlers have finished processing the 

input, if the input was not canceled. 

PreProcessInput Occurs when the InputManager starts to process the input item. 

4.416   InputMethod 

x:Object > InputMethod 

(usage) {x:Static InputMethod.StaticPropertyName} 

(description) Provides facilities for managing and interacting with the 

Text Services Framework, which provides support for 

alternate text input methods such as speech and 

handwriting. 

[is default constructible] false 

(properties)  

HandwritingState InputMethodState 

(description) The current state of handwriting input for this input 

method. 

ImeConversionMode ImeConversionModeValues 

(description) The current conversion mode for the input method 

editor associated with this input method. 

ImeSentenceMode ImeSentenceModeValues 

(description) The current sentence mode for the input method editor 

associated with this input method. 

ImeState InputMethodState 

(description) The current state of the input method editor associated 

with this input method. 

MicrophoneState InputMethodState 
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(usage) {x:Static InputMethod.StaticPropertyName} 

(description) The current state of microphone input for this input 

method. 

SpeechMode SpeechMode 

(description) The speech mode for this input method. 

(attachable properties)  

InputMethod.InputScope InputScope 

(description) The input scope for a specified dependency object. 

[target type] DependencyObject 

InputMethod.IsInputMethodEnabled x:Boolean 

(description) A value that indicates whether this input method is 

enabled. 

[target type] DependencyObject 

InputMethod.IsInputMethodSuspended x:Boolean 

(description) A value that indicates whether this input method is 

suspended. 

[target type] DependencyObject 

InputMethod.PreferredImeConversionMode ImeConversionModeValues 

(description) A preferred ImeConversionModeValues value for a 

specified dependency object. 

[target type] DependencyObject 

InputMethod.PreferredImeSentenceMode ImeSentenceModeValues 

(description) A preferred ImeSentenceModeValues value for a 

specified dependency object. 

[target type] DependencyObject 

InputMethod.PreferredImeState InputMethodState 

(description) A preferred input method state for a specified 

dependency object. 

[target type] DependencyObject 

(static properties)  

Current InputMethod 

(description) A reference to any currently active input method 

associated with the current context. 

(events)  
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(usage) {x:Static InputMethod.StaticPropertyName} 

StateChanged Occurs when the input method state (represented by 

the ImeState property) changes. 

4.417   InputMethodState 

x:Object > InputMethodState 

(usage) Off| On| DoNotCare 

(description) Describes the state of an InputMethod. 

(used by) InputMethod 

[is nullable] false 

[text syntax] InputMethodStateSyntax 

4.418   InputMode 

x:Object > InputMode 

(usage) Foreground| Sink 

(description) Specifies the possible values for the input mode. 

[is nullable] false 

[text syntax] InputModeSyntax 

4.419   InputScope 

x:Object > InputScope 

(usage) <InputScope> string </InputScope> 

(description) Represents information related to the scope of data provided by an input method. 

(used by) FrameworkContentElement FrameworkElement InputMethod 

[text syntax] InputScopeSyntax 

(properties)  

Names IList 

(description) The input scope name. 

[read only] true 

PhraseList IList 

(description) A collection of phrases to be used as suggested input patterns by input processors. 

[read only] true 



 

282 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <InputScope> string </InputScope> 

RegularExpression x:String 

(description) A regular expression to be used as a suggested text input pattern by input 

processors. 

SrgsMarkup x:String 

(description) A string that specifies any Speech Recognition Grammar Specification (SRGS) 

markup to be used as a suggested input pattern by input processors. 

4.420   InputScopeName 

x:Object > InputScopeName 

(usage) <InputScopeName> string |InputScopeNameValue</InputScopeName> 

(description) Defines a name for text input patterns. 

[content 

property] 

NameValue 

(properties)  

NameValue InputScopeNameValue 

(description) The input scope name value which modifies how input from alternative input 

methods is interpreted. 

4.421   InputScopeNameValue 

x:Object > InputScopeNameValue 

(usage) Default| Url| FullFilePath| FileName| EmailUserName| EmailSmtpAddress| 

LogOnName| PersonalFullName| PersonalNamePrefix... 

(description) Specifies the input scope name which modifies how input from alternative input methods 

is interpreted. 

(used by) InputScopeName 

[is nullable] false 

[text 

syntax] 

InputScopeNameValueSyntax 

4.422   InputScopePhrase 

x:Object > InputScopePhrase 

(usage) <InputScopePhrase>x:String</InputScopePhrase> 

(description) Represents a suggested input text pattern. 

[content Name 
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(usage) <InputScopePhrase>x:String</InputScopePhrase> 

property] 

(properties)  

Name x:String 

(description) A descriptive name associated with the text input pattern for this 

InputScopePhrase. 

4.423   InputType 

x:Object > InputType 

(usage) Keyboard| Mouse| Stylus| Hid| Text| Command 

(description) Specifies the possible types of input being reported. 

[is nullable] false 

[text syntax] InputTypeSyntax 

4.424   Int16Animation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

Int16AnimationBase > Int16Animation 

(usage) <Int16Animation /> 

(description) Animates the value of a  Int16 property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(x:Int16) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(x:Int16) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 
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(usage) <Int16Animation /> 

To x:Nullable(x:Int16) 

(description) The animation's ending value. 

4.425   Int16AnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

Int16AnimationBase 

Int16Animation Int16AnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Int16 value. 

[is default constructible] false 

[name property] Name 

4.426   Int16AnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Int16AnimationBase > Int16AnimationUsingKeyFrames 

(usage) <Int16AnimationUsingKeyFrames>Int16KeyFrame*</Int16AnimationUsingKeyFrames> 

(description) Animates the value of a Int16 property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value of 

the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames Int16KeyFrameCollection 

(description) The collection of Int16KeyFrame objects that define the animation. 

4.427   Int16KeyFrame 

x:Object > DependencyObject > Freezable > Int16KeyFrame 

DiscreteInt16KeyFrame EasingInt16KeyFrame LinearInt16KeyFrame SplineInt16KeyFrame 
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DiscreteInt16KeyFrame EasingInt16KeyFrame LinearInt16KeyFrame SplineInt16KeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a Int16AnimationUsingKeyFrames. 

(used by) Int16KeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value x:Int16 

(description) The key frame's target value. 

4.428   Int16KeyFrameCollection 

x:Object > DependencyObject > Freezable > Int16KeyFrameCollection 

(usage) <Int16KeyFrameCollection>Int16KeyFrame*</Int16KeyFrameCollection> 

(description) Represents a collection of Int16KeyFrame objects. 

(used by) Int16AnimationUsingKeyFrames 

[is list] true 

[allowed types] Int16KeyFrame 

(static properties)  

Empty Int16KeyFrameCollection 

(description) An empty Int16KeyFrameCollection. 

4.429   Int32Animation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Int32AnimationBase > Int32Animation 

(usage) <Int32Animation /> 

(description) Animates the value of an  Int32 property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  
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(usage) <Int32Animation /> 

By x:Nullable(x:Int32) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(x:Int32) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(x:Int32) 

(description) The animation's ending value. 

4.430   Int32AnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

Int32AnimationBase 

Int32Animation Int32AnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Int32 value. 

[is default constructible] false 

[name property] Name 

4.431   Int32AnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Int32AnimationBase > Int32AnimationUsingKeyFrames 

(usage) <Int32AnimationUsingKeyFrames>Int32KeyFrame*</Int32AnimationUsingKeyFrames> 

(description) Animates the value of a Int32 property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 
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(usage) <Int32AnimationUsingKeyFrames>Int32KeyFrame*</Int32AnimationUsingKeyFrames> 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value of 

the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames Int32KeyFrameCollection 

(description) The collection of Int32KeyFrame objects that define the animation. 

4.432   Int32Collection 

x:Object > DependencyObject > Freezable > Int32Collection 

(usage) <Int32Collection> string </Int32Collection> 

(description) Represents a collection of Int32 values. 

(used by) MeshGeometry3D 

[text syntax] Int32CollectionSyntax 

[is list] true 

[allowed types] x:Int32 

4.433   Int32KeyFrame 

x:Object > DependencyObject > Freezable > Int32KeyFrame 

DiscreteInt32KeyFrame EasingInt32KeyFrame LinearInt32KeyFrame SplineInt32KeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a Int32AnimationUsingKeyFrames. 

(used by) Int32KeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value x:Int32 
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DiscreteInt32KeyFrame EasingInt32KeyFrame LinearInt32KeyFrame SplineInt32KeyFrame 

(description) The key frame's target value. 

4.434   Int32KeyFrameCollection 

x:Object > DependencyObject > Freezable > Int32KeyFrameCollection 

(usage) <Int32KeyFrameCollection>Int32KeyFrame*</Int32KeyFrameCollection> 

(description) Represents a collection of Int32KeyFrame objects. 

(used by) Int32AnimationUsingKeyFrames 

[is list] true 

[allowed types] Int32KeyFrame 

(static properties)  

Empty Int32KeyFrameCollection 

(description) An empty Int32KeyFrameCollection. 

4.435   Int32Rect 

x:Object > Int32Rect 

(usage) <Int32Rect> string </Int32Rect> 

(description) Describes the width, height, and location of an integer rectangle. 

(used by) BitmapImage CroppedBitmap 

[is nullable] false 

[text syntax] Int32RectSyntax 

(properties)  

Height x:Int32 

(description) The height of the rectangle. 

Width x:Int32 

(description) The width of the rectangle. 

X x:Int32 

(description) The x-coordinate of the top-left corner of the rectangle. 

Y x:Int32 

(description) The y-coordinate of the top-left corner of the rectangle. 

(static  
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(usage) <Int32Rect> string </Int32Rect> 

properties) 

Empty Int32Rect 

(description) The empty rectangle, a special value that represents a rectangle with no position or 

area. 

4.436   Int64Animation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

Int64AnimationBase > Int64Animation 

(usage) <Int64Animation /> 

(description) Animates the value of a  Int64 property between two target values using linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(x:Int64) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(x:Int64) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(x:Int64) 

(description) The animation's ending value. 

4.437   Int64AnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Int64AnimationBase 

Int64Animation Int64AnimationUsingKeyFrames 

(usage) None. 
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Int64Animation Int64AnimationUsingKeyFrames 

(description) A base type that animates a Int64 value. 

[is default constructible] false 

[name property] Name 

4.438   Int64AnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Int64AnimationBase > Int64AnimationUsingKeyFrames 

(usage) <Int64AnimationUsingKeyFrames>Int64KeyFrame*</Int64AnimationUsingKeyFrames> 

(description) Animates the value of a Int64 property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value of 

the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames Int64KeyFrameCollection 

(description) The collection of Int64KeyFrame objects that define the animation. 

4.439   Int64KeyFrame 

x:Object > DependencyObject > Freezable > Int64KeyFrame 

DiscreteInt64KeyFrame EasingInt64KeyFrame LinearInt64KeyFrame SplineInt64KeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a Int64AnimationUsingKeyFrames. 

(used by) Int64KeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 
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DiscreteInt64KeyFrame EasingInt64KeyFrame LinearInt64KeyFrame SplineInt64KeyFrame 

(description) The time at which the key frame's target Value should be reached. 

Value x:Int64 

(description) The key frame's target value. 

4.440   Int64KeyFrameCollection 

x:Object > DependencyObject > Freezable > Int64KeyFrameCollection 

(usage) <Int64KeyFrameCollection>Int64KeyFrame*</Int64KeyFrameCollection> 

(description) Represents a collection of Int64KeyFrame objects. 

(used by) Int64AnimationUsingKeyFrames 

[is list] true 

[allowed types] Int64KeyFrame 

(static properties)  

Empty Int64KeyFrameCollection 

(description) An empty Int64KeyFrameCollection. 

4.441   IntersectionDetail 

x:Object > IntersectionDetail 

(usage) NotCalculated| Empty| FullyInside| FullyContains| Intersects 

(description) Provides information about the intersection between the geometries in the 

GeometryHitTestParameters and the visual which was hit. 

[is nullable] false 

[text 

syntax] 

IntersectionDetailSyntax 

4.442   InvertAxes 

x:Object > InvertAxes 

(usage) None| Horizontal| Vertical| Both 

(description) Indicate the inversion of horizontal and vertical axes of the drawing surface. 

[is nullable] false 

[text syntax] InvertAxesSyntax 
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4.443   IScrollInfo 

IScrollInfo 

DataGridRowsPresenter ScrollContentPresenter StackPanel ToolBarPanel VirtualizingStackPanel 

(usage) None. 

(description) Represents the main scrollable region inside a ScrollViewer control. 

[is default constructible] false 

(properties)  

CanHorizontallyScroll x:Boolean 

(description) A value that indicates whether scrolling on the horizontal axis is possible. 

CanVerticallyScroll x:Boolean 

(description) A value that indicates whether scrolling on the vertical axis is possible. 

ScrollOwner ScrollViewer 

(description) A ScrollViewer element that controls scrolling behavior. 

4.444   IsOffscreenBehavior 

x:Object > IsOffscreenBehavior 

(usage)  

(description)  

(used by) AutomationProperties 

[is nullable] false 

[text syntax] IsOffscreenBehaviorSyntax 

4.445   Italic 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > Span > Italic, IInputElement 

(usage) <Italic>[Inline|UIElement|x:String]*</Italic> 

(description) Provides an inline-level flow content element that causes content to appear with an 

italic font style. 

[content 

property] 

Inlines 

[name property] Name 

[xml lang 

property] 

Language 



 

293 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

4.446   ItemCollection 

x:Object > CollectionView > ItemCollection 

(usage) None. 

(description) Holds the list of items that constitute the content of an ItemsControl. 

(used by) ItemsControl 

[is default constructible] false 

[is list] true 

[allowed types] x:Object 

(properties)  

GroupDescriptions ObservableCollection(GroupDescription) 

(description) A collection of GroupDescription objects that defines how to group the 

items. 

[read only] true 

IsLiveFiltering (4.5) x:Nullable(x:Boolean) 

(description) A value that indicates whether filtering data in real time is enabled. 

IsLiveGrouping (4.5) x:Nullable(x:Boolean) 

(description) A value that indicates whether grouping data in real time is enabled. 

IsLiveSorting (4.5) x:Nullable(x:Boolean) 

(description) A value that indicates whether sorting in real time is enabled. 

LiveFilteringProperties 

(4.5) 

ObservableCollection(x:String) 

(description) A collection of strings that specify the properties that participate in 

filtering data in real time. 

[read only] true 

LiveGroupingProperties 

(4.5) 

ObservableCollection(x:String) 

(description) A collection of strings that specify the properties that participate in 

grouping data in real time. 

[read only] true 

LiveSortingProperties 

(4.5) 

ObservableCollection(x:String) 

(description) A collection of strings that specify the properties that participate in sorting 

data in real time. 

[read only] true 
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(usage) None. 

SortDescriptions SortDescriptionCollection 

(description) A collection of SortDescription objects that describe how the items in the 

collection are sorted in the view. 

[read only] true 

4.447   ItemContainerTemplate (4.5) 

x:Object > FrameworkTemplate > DataTemplate > ItemContainerTemplate 

(usage) <ItemContainerTemplate>FrameworkElement</ItemContainerTemplate> 

(description) Provides the template for producing a container for an ItemsControl 

object. 

[content property] Template 

[dictionary key property] ItemContainerTemplateKey 

[is name scope] true 

(properties)  

ItemContainerTemplateKey x:Object 

(description) The default key of the ItemContainerTemplate. 

[read only] true 

4.448   ItemContainerTemplateKey (4.5) 

x:Object > x:MarkupExtension > ResourceKey > TemplateKey > ItemContainerTemplateKey 

(usage) {ItemContainerTemplateKey } | <ItemContainerTemplateKey /> 

(description) Provides a resource key for an ItemContainerTemplate object. 

[return value type] ResourceKey 

[constructors]  

(1 parameter)  

dataType x:Object 

(description) The type for which this template is designed. 

4.449   ItemsControl 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl, IInputElement 
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DataGridCellsPresenter DataGridColumnHeadersPresenter HeaderedItemsControl MenuBase 

RibbonContextualTabGroupItemsControl RibbonControlGroup RibbonGallery 

RibbonQuickAccessToolBar RibbonTabHeaderItemsControl Selector StatusBar TreeView 

(usage) <ItemsControl>x:Object*</ItemsControl> 

(description) Represents a control that can be used to present a collection of 

items. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

AlternationCount x:Int32 

(description) The number of alternating item containers in the ItemsControl, 

which enables alternating containers to have a unique 

appearance. 

DisplayMemberPath x:String 

(description) A path to a value on the source object to serve as the visual 

representation of the object. 

GroupStyle ObservableCollection(GroupStyle) 

(description) A collection of GroupStyle objects that define the appearance of 

each level of groups. 

[read only] true 

IsTextSearchCaseSensitive x:Boolean 

(description) A value that indicates whether case is a condition when searching 

for items. 

IsTextSearchEnabled x:Boolean 

(description) A value that indicates whether TextSearch is enabled on the 

ItemsControl instance. 

ItemBindingGroup BindingGroup 

(description) The BindingGroup that is copied to each item in the ItemsControl. 

ItemContainerStyle Style 

(description) The Style that is applied to the container element generated for 

each item. 

ItemContainerStyleSelector StyleSelector 

(description) Custom style-selection logic for a style that can be applied to each 

generated container element. 

Items ItemCollection 
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DataGridCellsPresenter DataGridColumnHeadersPresenter HeaderedItemsControl MenuBase 

RibbonContextualTabGroupItemsControl RibbonControlGroup RibbonGallery 

RibbonQuickAccessToolBar RibbonTabHeaderItemsControl Selector StatusBar TreeView 

(description) The collection used to generate the content of the ItemsControl. 

[read only] true 

ItemsPanel ItemsPanelTemplate 

(description) The template that defines the panel that controls the layout of 

items. 

ItemsSource IEnumerable 

(description) A collection used to generate the content of the ItemsControl. 

ItemStringFormat x:String 

(description) A composite string that specifies how to format the items in the 

ItemsControl if they are displayed as strings. 

ItemTemplate DataTemplate 

(description) The DataTemplate used to display each item. 

ItemTemplateSelector DataTemplateSelector 

(description) The custom logic for choosing a template used to display each 

item. 

(attachable properties)  

ItemsControl.AlternationIndex x:Int32 

(description) The assigned value of the item container when alternating item 

containers are used. 

[target type] DependencyObject 

4.450   ItemsPanelTemplate 

x:Object > FrameworkTemplate > ItemsPanelTemplate 

(usage) <ItemsPanelTemplate>FrameworkElement</ItemsPanelTemplate> 

(description) Specifies the panel that the ItemsPresenter creates for the layout of the items of an 

ItemsControl. 

(used by) DataGridRow GroupStyle ItemsControl 

[content 

property] 

Template 

[is name scope] true 
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4.451   ItemsPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > ItemsPresenter, 
IInputElement 

(usage) <ItemsPresenter /> 

(description) Used within the template of an item control to specify the place in the control's visual 

tree where the ItemsPanel defined by the ItemsControl is to be added. 

[name 

property] 

Name 

[xml lang 

property] 

Language 

4.452   IValueConverter 

IValueConverter 

AlternationConverter BooleanToVisibilityConverter JournalEntryListConverter 

ZoomPercentageConverter 

(usage) None. 

(description) Provides a way to apply custom logic to a binding. 

(used by) Binding PropertyGroupDescription TemplateBindingExtension 

[is default constructible] false 

4.453   IWeakEventListener 

IWeakEventListener 

CollectionContainer CollectionViewSource CompositeCollection GridViewHeaderRowPresenter 

GridViewRowPresenter GridViewRowPresenterBase ItemCollection RibbonGallery 

RibbonGalleryCategory 

(usage) None. 

(description) Provides event listening support for types that expect to receive events through 

the WeakEvent pattern and a WeakEventManager. 

[is default 

constructible] 

false 

4.454   JournalEntry 

x:Object > DependencyObject > JournalEntry 

(usage) None. 

(description) Represents an entry in either back or forward navigation history. 
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(usage) None. 

[is default 

constructible] 

false 

(properties)  

Name x:String 

(description) The name of the journal entry. 

Source x:Uri 

(description) The URI of the content that was navigated to. 

(attachable properties)  

JournalEntry.KeepAlive x:Boolean 

(description) A value that indicates whether the content of a journal entry is either 

retained or re-created when navigated to in navigation history. 

[target type] DependencyObject 

JournalEntry.Name x:String 

(description) The name of the journal entry. 

[target type] DependencyObject 

4.455   JournalEntryListConverter 

x:Object > JournalEntryListConverter, IValueConverter 

(usage) <JournalEntryListConverter /> 

(description) This type or member supports the Microsoft .NET infrastructure. 

4.456   JournalEntryPosition 

x:Object > JournalEntryPosition 

(usage) Back| Current| Forward 

(description) Specifies the position in navigation history of a piece of content with respect to current 

content. JournalEntryPosition is used by JournalEntryUnifiedViewConverter. 

(used by) JournalEntryUnifiedViewConverter 

[is nullable] false 

[text 

syntax] 

JournalEntryPositionSyntax 

4.457   JournalEntryUnifiedViewConverter 

x:Object > JournalEntryUnifiedViewConverter, IMultiValueConverter 
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(usage) <JournalEntryUnifiedViewConverter /> 

(description) Merges navigation back history and 

navigation forward history (as exposed 

by Frame or NavigationWindow) into a 

single navigation menu. 

(attachable properties)  

JournalEntryUnifiedViewConverter.JournalEntryPosition JournalEntryPosition 

(description) A value that specifies whether an entry is 

in back navigation history, forward 

navigation history, or is the current 

content of a navigator. 

[target type] DependencyObject 

4.458   JournalOwnership 

x:Object > JournalOwnership 

(usage) Automatic| OwnsJournal| UsesParentJournal 

(description) Specifies whether a Frame uses its own journal. JournalOwnership is used by the 

JournalOwnership property. 

(used by) Frame 

[is nullable] false 

[text 

syntax] 

JournalOwnershipSyntax 

4.459   JpegBitmapEncoder 

x:Object > BitmapEncoder > JpegBitmapEncoder 

(usage) <JpegBitmapEncoder /> 

(description) Defines an encoder that is used to encode Joint Photographics Experts Group (JPEG) 

format images. 

(properties)  

FlipHorizontal x:Boolean 

(description) A value that indicates whether a Joint Photographics Experts Group (JPEG) image should 

be flipped horizontally during encoding. 

FlipVertical x:Boolean 

(description) A value that indicates whether a Joint Photographics Experts Group (JPEG) image should 

be flipped vertically during encoding. 

QualityLevel x:Int32 
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(usage) <JpegBitmapEncoder /> 

(description) A value that indicates the quality level of the resulting Joint Photographics Experts 

Group (JPEG) image. 

Rotation Rotation 

(description) A value that represents the degree to which a Joint Photographics Experts Group (JPEG) 

image is rotated. 

4.460   JumpItem 

x:Object > JumpItem 

JumpPath JumpTask 

(usage) None. 

(description) Represents the base type for the JumpPath and JumpTask types. 

(used by) JumpList 

[is default 

constructible] 

false 

(properties)  

CustomCategory x:String 

(description) The name of the category the JumpItem is grouped with in the Windows 7 

taskbar Jump List. 

4.461   JumpItemRejectionReason 

x:Object > JumpItemRejectionReason 

(usage) None| InvalidItem| NoRegisteredHandler| RemovedByUser 

(description) Describes why a JumpItem could not be added to the Jump List by the Windows shell. 

[is nullable] false 

[text syntax] JumpItemRejectionReasonSyntax 

4.462   JumpList 

x:Object > JumpList 

(usage) <JumpList>JumpItem*</JumpList> 

(description) Represents a list of items and tasks displayed as a menu on a Windows 7 

taskbar button. 

(used by) JumpList 

[content property] JumpItems 
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(usage) <JumpList>JumpItem*</JumpList> 

(properties)  

JumpItems List(JumpItem) 

(description) The collection of JumpItem objects that are displayed in the Jump List. 

[read only] true 

ShowFrequentCategory x:Boolean 

(description) A value that indicates whether frequently used items are displayed in the 

Jump List. 

ShowRecentCategory x:Boolean 

(description) A value that indicates whether recently used items are displayed in the 

Jump List. 

(attachable properties)  

JumpList.JumpList JumpList 

(description)  

[target type] Application 

(events)  

JumpItemsRejected Occurs when jump items are not successfully added to the Jump List by 

the Windows shell. 

JumpItemsRemovedByUser Occurs when jump items previously in the Jump List are removed from 

the list by the user. 

4.463   JumpPath 

x:Object > JumpItem > JumpPath 

(usage) <JumpPath /> 

(description) Represents a link to a file that is displayed in a Windows 7 taskbar Jump List. 

(properties)  

Path x:String 

(description) The path to the file to be included in the Jump List. 

4.464   JumpTask 

x:Object > JumpItem > JumpTask 

(usage) <JumpTask /> 

(description) Represents a shortcut to an application in the Windows 7 taskbar Jump List. 
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(usage) <JumpTask /> 

(properties)  

ApplicationPath x:String 

(description) The path to the application. 

Arguments x:String 

(description) The arguments passed to the application on startup. 

Description x:String 

(description) The text displayed in the tooltip for the task in the Jump List. 

IconResourceIndex x:Int32 

(description) The zero-based index of an icon embedded in a resource. 

IconResourcePath x:String 

(description) The path to a resource that contains the icon to display in the Jump List. 

Title x:String 

(description) The text displayed for the task in the Jump List. 

WorkingDirectory x:String 

(description) The working directory of the application on startup. 

4.465   KernelType 

x:Object > KernelType 

(usage) Gaussian| Box 

(description) Describes the kernel used to create the effect. 

(used by) BlurEffect 

[is nullable] false 

[text syntax] KernelTypeSyntax 

4.466   Key 

x:Object > Key 

(usage) None| Cancel| Back| Tab| LineFeed| Clear| Return| Enter| Pause... 

(description) Specifies the possible key values on a keyboard. 

(used by) KeyBinding 

[is nullable] false 



 

303 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) None| Cancel| Back| Tab| LineFeed| Clear| Return| Enter| Pause... 

[text syntax] KeySyntax 

4.467   KeyBinding 

x:Object > DependencyObject > Freezable > InputBinding > KeyBinding 

(usage) <KeyBinding /> 

(description) Binds a KeyGesture to a RoutedCommand (or another  ICommand implementation). 

(properties)  

Gesture InputGesture 

(description) The gesture associated with this KeyBinding. 

[text syntax] KeyGestureSyntax 

Key Key 

(description) The Key of the KeyGesture associated with this KeyBinding. 

Modifiers ModifierKeys 

(description) The ModifierKeys of the KeyGesture associated with this KeyBinding. 

4.468   Keyboard 

x:Object > Keyboard 

(usage) {x:Static Keyboard.StaticPropertyName} 

(description) Represents the keyboard device. 

[is default constructible] false 

(static properties)  

DefaultRestoreFocusMode RestoreFocusMode 

(description) The behavior of when restoring focus. 

FocusedElement IInputElement 

(description) The element that has keyboard focus. 

Modifiers ModifierKeys 

(description) The set of ModifierKeys that are currently 

pressed. 

PrimaryDevice KeyboardDevice 

(description) The primary keyboard input device. 
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(usage) {x:Static Keyboard.StaticPropertyName} 

(attachable events)  

Keyboard.GotKeyboardFocus Occurs when an element receives 

keyboard focus. 

Keyboard.KeyboardInputProviderAcquireFocus Occurs when the keyboard input provider 

acquires focus. 

Keyboard.KeyDown Occurs when a key on the keyboard is 

pressed. 

Keyboard.KeyUp Occurs when a key on the keyboard is 

released. 

Keyboard.LostKeyboardFocus Occurs when an element loses keyboard 

focus. 

Keyboard.PreviewGotKeyboardFocus Occurs when an element is in the process 

of acquiring keyboard focus. 

Keyboard.PreviewKeyboardInputProviderAcquireFocus Occurs when the keyboard input provider 

is in the process of acquiring focus. 

Keyboard.PreviewKeyDown Occurs when a key on the keyboard is 

pressed. 

Keyboard.PreviewKeyUp Occurs when a key on the keyboard is 

released. 

Keyboard.PreviewLostKeyboardFocus Occurs when an element is in the process 

of losing keyboard focus. 

4.469   KeyboardNavigation 

x:Object > KeyboardNavigation 

(usage) None. 

(description) Provides logical and directional navigation between 

focusable objects. 

[is default constructible] false 

(attachable properties)  

KeyboardNavigation.AcceptsReturn x:Boolean 

(description) A value indicating whether the Return character is 

accepted by a control. 

[target type] DependencyObject 

KeyboardNavigation.ControlTabNavigation KeyboardNavigationMode 

(description) The logical control tab navigation behavior for the 

children of the element that this property is set on. 
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(usage) None. 

[target type] DependencyObject 

KeyboardNavigation.DirectionalNavigation KeyboardNavigationMode 

(description) The directional navigation behavior for the children of 

the element that this property is set on. 

[target type] DependencyObject 

KeyboardNavigation.IsTabStop x:Boolean 

(description) A value indicating whether the element that this 

property is set on is a tab stop. 

[target type] DependencyObject 

KeyboardNavigation.TabIndex x:Int32 

(description) The tab index for the element that this property is set 

on. 

[target type] DependencyObject 

KeyboardNavigation.TabNavigation KeyboardNavigationMode 

(description) The logical tab navigation behavior for the children of 

the element that this property is set on. 

[target type] DependencyObject 

4.470   KeyboardNavigationMode 

x:Object > KeyboardNavigationMode 

(usage) Continue| Once| Cycle| None| Contained| Local 

(description) Specifies the possible values for changes in focus when logical and directional navigation 

occurs. 

(used by) KeyboardNavigation 

[is nullable] false 

[text 

syntax] 

KeyboardNavigationModeSyntax 

4.471   KeyGesture 

x:Object > InputGesture > KeyGesture 

(usage) <KeyGesture> string </KeyGesture> 

(description) Defines a keyboard combination that can be used to invoke a command. 

[is default constructible] false 



 

306 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <KeyGesture> string </KeyGesture> 

[text syntax] KeyGestureSyntax 

4.472   KeySpline 

x:Object > DependencyObject > Freezable > KeySpline 

(usage) <KeySpline> string </KeySpline> 

(description) This type is used by a spline key frame to define animation progress. 

(used by) SplineByteKeyFrame SplineColorKeyFrame SplineDecimalKeyFrame 

SplineDoubleKeyFrame SplineInt16KeyFrame SplineInt32KeyFrame 

SplineInt64KeyFrame SplinePoint3DKeyFrame SplinePointKeyFrame 

SplineQuaternionKeyFrame SplineRectKeyFrame SplineRotation3DKeyFrame 

SplineSingleKeyFrame SplineSizeKeyFrame SplineThicknessKeyFrame 

SplineVector3DKeyFrame SplineVectorKeyFrame 

[text syntax] KeySplineSyntax 

(properties)  

ControlPoint1 Point 

(description) The first control point used to define a Bezier curve that describes a KeySpline. 

ControlPoint2 Point 

(description) The second control point used to define a Bezier curve that describes a KeySpline. 

4.473   KeyStates 

x:Object > KeyStates 

(usage) None| Down| Toggled 

(description) Specifies constants that define the state of a key. 

[is nullable] false 

[text syntax] KeyStatesSyntax 

4.474   KeyTime 

x:Object > KeyTime 

(usage) <KeyTime> string </KeyTime> 

(description) During the relative course of an animation, a KeyTime instance specifies the precise 

timing when a particular key frame should take place. 

(used by) BooleanKeyFrame ByteKeyFrame CharKeyFrame ColorKeyFrame DecimalKeyFrame 

DoubleKeyFrame IKeyFrame Int16KeyFrame Int32KeyFrame Int64KeyFrame 

MatrixKeyFrame ObjectKeyFrame Point3DKeyFrame PointKeyFrame 

QuaternionKeyFrame RectKeyFrame Rotation3DKeyFrame SingleKeyFrame 
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(usage) <KeyTime> string </KeyTime> 

SizeKeyFrame StringKeyFrame ThicknessKeyFrame Vector3DKeyFrame VectorKeyFrame 

[is nullable] false 

[text syntax] KeyTimeSyntax 

(static 

properties) 

 

Paced KeyTime 

(description) The Paced value which creates timing behavior resulting in an animation that 

interpolates at a constant rate. 

Uniform KeyTime 

(description) The Uniform value which divides the allotted time of the animation evenly between key 

frames. 

4.475   KeyTimeType 

x:Object > KeyTimeType 

(usage) Uniform| Percent| TimeSpan| Paced 

(description) Represents the different types that may represent a KeyTime instance. 

[is nullable] false 

[text syntax] KeyTimeTypeSyntax 

4.476   KeyTipControl (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
KeyTipControl, IInputElement 

(usage) <KeyTipControl /> 

(description) Represents the control used inside the KeyTip. 

[name property] Name 

[xml lang property] Language 

(properties)  

Text x:String 

(description) The text associated with this control. 

4.477   KeyTipHorizontalPlacement (4.5) 

x:Object > KeyTipHorizontalPlacement 
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(usage) KeyTipLeftAtTargetLeft| KeyTipLeftAtTargetCenter| KeyTipLeftAtTargetRight| 

KeyTipCenterAtTargetLeft| KeyTipCenterAtTargetCenter| 

KeyTipCenterAtTargetRight| KeyTipRightAtTargetLeft| 

KeyTipRightAtTargetCenter| KeyTipRightAtTargetRight... 

(description) Specifies the values for the horizontal placement of the KeyTip relative to its placement 

target. 

[is nullable] false 

[text 

syntax] 

KeyTipHorizontalPlacementSyntax 

4.478   KeyTipService (4.5) 

x:Object > KeyTipService 

(usage) None. 

(description) Represents a service that provides properties, methods, and 

events to enable and manage KeyTips in Ribbon controls. 

[is default constructible] false 

(attachable properties)  

KeyTipService.IsKeyTipScope x:Boolean 

(description) A value that indicates whether the element that this 

property is attached to is in KeyTip scope. 

[target type] DependencyObject 

KeyTipService.KeyTip x:String 

(description) The text to use for the KeyTip. 

[target type] DependencyObject 

KeyTipService.KeyTipStyle Style 

(description) The style to use with the KeyTip. 

[target type] DependencyObject 

(attachable events)  

KeyTipService.ActivatingKeyTip Occurs when the KeyTip is activated. 

KeyTipService.KeyTipAccessed Occurs when the KeyTip is accessed. 

KeyTipService.PreviewKeyTipAccessed Occurs when the KeyTip is accessed. 

4.479   KeyTipVerticalPlacement (4.5) 

x:Object > KeyTipVerticalPlacement 
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(usage) KeyTipTopAtTargetTop| KeyTipTopAtTargetCenter| KeyTipTopAtTargetBottom| 

KeyTipCenterAtTargetTop| KeyTipCenterAtTargetCenter| 

KeyTipCenterAtTargetBottom| KeyTipBottomAtTargetTop| 

KeyTipBottomAtTargetCenter| KeyTipBottomAtTargetBottom... 

(description) Specifies the values for the vertical placement of the KeyTip relative to its placement 

target. 

[is nullable] false 

[text 

syntax] 

KeyTipVerticalPlacementSyntax 

4.480   Label 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > Label, IInputElement 

(usage) <Label>x:Object</Label> 

(description) Represents the text label for a control and provides support for access keys. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

Target UIElement 

(description) The element that receives focus when the user presses the label's access key. 

[text syntax] x:NameReference, from [MS-XAML] 

4.481   LanguageSpecificStringDictionary 

x:Object > LanguageSpecificStringDictionary 

(usage) None. 

(description) Represents a dictionary of strings that are used to represent the name of an 

object in different languages. 

(used by) FontFamily 

[is default 

constructible] 

false 

[is dictionary] true 

[allowed types] x:String 

[allowed key types] XmlLanguage 

(properties)  

http://go.microsoft.com/fwlink/?LinkId=390715


 

310 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) None. 

Keys ICollection(XmlLanguage) 

(description) A collection containing the keys, or XmlLanguage objects, in the dictionary. 

[read only] true 

Values ICollection(x:String) 

(description) A collection containing the values, or strings, in the dictionary. 

[read only] true 

4.482   Light 

x:Object > DependencyObject > Freezable > Animatable > Model3D > Light 

AmbientLight DirectionalLight PointLightBase 

(usage) None. 

(description) Model3D object that represents lighting applied to a 3-D scene. 

[is default constructible] false 

(properties)  

Color Color 

(description) The color of the light. 

4.483   Line 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Shape > Line, 

IInputElement 

(usage) <Line /> 

(description) Draws a straight line between two points. 

[name property] Name 

[xml lang property] Language 

(properties)  

X1 x:Double 

(description) The x-coordinate of the Line start point. 

[text syntax] LengthSyntax 

X2 x:Double 

(description) The x-coordinate of the Line end point. 
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(usage) <Line /> 

[text syntax] LengthSyntax 

Y1 x:Double 

(description) The y-coordinate of the Line start point. 

[text syntax] LengthSyntax 

Y2 x:Double 

(description) The y-coordinate of the Line end point. 

[text syntax] LengthSyntax 

4.484   LinearByteKeyFrame 

x:Object > DependencyObject > Freezable > ByteKeyFrame > LinearByteKeyFrame 

(usage) <LinearByteKeyFrame /> 

(description) Animates from the Byte value of the previous key frame to its own Value using linear 

interpolation. 

4.485   LinearColorKeyFrame 

x:Object > DependencyObject > Freezable > ColorKeyFrame > LinearColorKeyFrame 

(usage) <LinearColorKeyFrame /> 

(description) Animates from the Color value of the previous key frame to its own Value using linear 

interpolation. 

4.486   LinearDecimalKeyFrame 

x:Object > DependencyObject > Freezable > DecimalKeyFrame > LinearDecimalKeyFrame 

(usage) <LinearDecimalKeyFrame /> 

(description) Animates from the Decimal value of the previous key frame to its own Value using linear 

interpolation. 

4.487   LinearDoubleKeyFrame 

x:Object > DependencyObject > Freezable > DoubleKeyFrame > LinearDoubleKeyFrame 

(usage) <LinearDoubleKeyFrame /> 

(description) Animates from the Double value of the previous key frame to its own Value using linear 

interpolation. 
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4.488   LinearGradientBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > GradientBrush > 
LinearGradientBrush 

(usage) <LinearGradientBrush> string |GradientStop*</LinearGradientBrush> 

(description) Paints an area with a linear gradient. 

[text syntax] BrushSyntax 

[content property] GradientStops 

(properties)  

EndPoint Point 

(description) The ending two-dimensional coordinates of the linear gradient. 

StartPoint Point 

(description) The starting two-dimensional coordinates of the linear gradient. 

4.489   LinearInt16KeyFrame 

x:Object > DependencyObject > Freezable > Int16KeyFrame > LinearInt16KeyFrame 

(usage) <LinearInt16KeyFrame /> 

(description) Animates from the Int16 value of the previous key frame to its own Value using linear 

interpolation. 

4.490   LinearInt32KeyFrame 

x:Object > DependencyObject > Freezable > Int32KeyFrame > LinearInt32KeyFrame 

(usage) <LinearInt32KeyFrame /> 

(description) Animates from the Int32 value of the previous key frame to its own Value using linear 

interpolation. 

4.491   LinearInt64KeyFrame 

x:Object > DependencyObject > Freezable > Int64KeyFrame > LinearInt64KeyFrame 

(usage) <LinearInt64KeyFrame /> 

(description) Animates from the Int64 value of the previous key frame to its own Value using linear 

interpolation. 

4.492   LinearPoint3DKeyFrame 

x:Object > DependencyObject > Freezable > Point3DKeyFrame > LinearPoint3DKeyFrame 
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(usage) <LinearPoint3DKeyFrame /> 

(description) Animates from the Point3D value of the previous key frame to its own Value using linear 

interpolation. 

4.493   LinearPointKeyFrame 

x:Object > DependencyObject > Freezable > PointKeyFrame > LinearPointKeyFrame 

(usage) <LinearPointKeyFrame /> 

(description) Animates from the Point value of the previous key frame to its own Value using linear 

interpolation. 

4.494   LinearQuaternionKeyFrame 

x:Object > DependencyObject > Freezable > QuaternionKeyFrame > LinearQuaternionKeyFrame 

(usage) <LinearQuaternionKeyFrame /> 

(description) Animates from the Quaternion value of the previous key frame to its own Value using 

linear interpolation. 

(properties)  

UseShortestPath x:Boolean 

(description) A Boolean value that indicates whether the animation uses spherical linear 

interpolation to calculate the shortest arc between positions. 

4.495   LinearRectKeyFrame 

x:Object > DependencyObject > Freezable > RectKeyFrame > LinearRectKeyFrame 

(usage) <LinearRectKeyFrame /> 

(description) Animates from the Rect value of the previous key frame to its own Value using linear 

interpolation. 

4.496   LinearRotation3DKeyFrame 

x:Object > DependencyObject > Freezable > Rotation3DKeyFrame > LinearRotation3DKeyFrame 

(usage) <LinearRotation3DKeyFrame /> 

(description) Animates from the Rotation3D value of the previous key frame to its own Value using 

linear interpolation. 

4.497   LinearSingleKeyFrame 

x:Object > DependencyObject > Freezable > SingleKeyFrame > LinearSingleKeyFrame 

(usage) <LinearSingleKeyFrame /> 
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(usage) <LinearSingleKeyFrame /> 

(description) Animates from the Single value of the previous key frame to its own Value using linear 

interpolation. 

4.498   LinearSizeKeyFrame 

x:Object > DependencyObject > Freezable > SizeKeyFrame > LinearSizeKeyFrame 

(usage) <LinearSizeKeyFrame /> 

(description) Animates from the Size value of the previous key frame to its own Value using linear 

interpolation. 

4.499   LinearThicknessKeyFrame 

x:Object > DependencyObject > Freezable > ThicknessKeyFrame > LinearThicknessKeyFrame 

(usage) <LinearThicknessKeyFrame /> 

(description) Animates from the Thickness value of the previous key frame to its own Value using 

linear interpolation. 

4.500   LinearVector3DKeyFrame 

x:Object > DependencyObject > Freezable > Vector3DKeyFrame > LinearVector3DKeyFrame 

(usage) <LinearVector3DKeyFrame /> 

(description) Animates from the Vector3D value of the previous key frame to its own Value using 

linear interpolation. 

4.501   LinearVectorKeyFrame 

x:Object > DependencyObject > Freezable > VectorKeyFrame > LinearVectorKeyFrame 

(usage) <LinearVectorKeyFrame /> 

(description) Animates from the Vector value of the previous key frame to its own Value using linear 

interpolation. 

4.502   LineBreak 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > LineBreak, IInputElement 

(usage) <LineBreak /> 

(description) An inline flow content element that causes a line break to occur in flow 

content. 

[name property] Name 
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(usage) <LineBreak /> 

[xml lang property] Language 

[trim surrounding 

whitespace] 

true 

4.503   LineBreakCondition 

x:Object > LineBreakCondition 

(usage) BreakDesired| BreakPossible| BreakRestrained| BreakAlways 

(description) Describes the breaking condition around an inline object. 

[is nullable] false 

[text syntax] LineBreakConditionSyntax 

4.504   LineGeometry 

x:Object > DependencyObject > Freezable > Animatable > Geometry > LineGeometry 

(usage) <LineGeometry> string </LineGeometry> 

(description) Represents the geometry of a line. 

[text syntax] GeometrySyntax 

(properties)  

EndPoint Point 

(description) The end point of a line. 

StartPoint Point 

(description) The start point of the line. 

4.505   LineSegment 

x:Object > DependencyObject > Freezable > Animatable > PathSegment > LineSegment 

(usage) <LineSegment /> 

(description) Creates a line between two points in a PathFigure. 

(properties)  

Point Point 

(description) The end point of the line segment. 
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4.506   LineStackingStrategy 

x:Object > LineStackingStrategy 

(usage) BlockLineHeight| MaxHeight 

(description) Describes a mechanism by which a line box is determined for each line. 

(used by) AccessText AnchoredBlock Block FlowDocument ListItem RibbonTwoLineText TableCell 

TextBlock 

[is nullable] false 

[text 

syntax] 

LineStackingStrategySyntax 

4.507   LinkTarget 

x:Object > LinkTarget 

(usage) <LinkTarget /> 

(description) Represents an element on a page that can be linked to from other documents or other 

places in the same document. 

(used by) LinkTargetCollection 

(properties)  

Name x:String 

(description) The name of the element that this LinkTarget identifies as a linkable element. 

4.508   LinkTargetCollection 

x:Object > CollectionBase > LinkTargetCollection 

(usage) <LinkTargetCollection>LinkTarget*</LinkTargetCollection> 

(description) Provides a collection of all of the LinkTarget elements in a Package. 

(used by) PageContent 

[is list] true 

[allowed types] LinkTarget 

4.509   List 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Block > List, IInputElement 

(usage) <List>ListItem*</List> 

(description) A block-level flow content element that provides facilities for presenting content in 

an ordered or unordered list. 



 

317 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <List>ListItem*</List> 

[content 

property] 

ListItems 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

ListItems ListItemCollection 

(description) A ListItemCollection containing the ListItem elements that comprise the contents of 

the List. 

[read only] true 

MarkerOffset x:Double 

(description) The desired distance between the contents of each ListItem element, and the near 

edge of the list marker. 

[text syntax] LengthSyntax 

MarkerStyle TextMarkerStyle 

(description) The marker style for the List. 

StartIndex x:Int32 

(description) The starting index for labeling the items in an ordered list. 

4.510   ListBox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > Selector > ListBox, IInputElement 

ListView 

(usage) <ListBox>x:Object*</ListBox> 

(description) Contains a list of selectable items. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

SelectedItems IList 

(description) The currently selected items. 

[read only] true 
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ListView 

SelectionMode SelectionMode 

(description) The selection behavior for a ListBox. 

4.511   ListBoxItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ListBoxItem, IInputElement 

ComboBoxItem ListViewItem 

(usage) <ListBoxItem>x:Object</ListBoxItem> 

(description) Represents a selectable item in a ListBox. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

IsSelected x:Boolean 

(description) A value that indicates whether a ListBoxItem is selected. 

(events)  

Selected Occurs when a ListBoxItem is selected. 

Unselected Occurs when a ListBoxItem is unselected. 

4.512   ListItem 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
ListItem, IInputElement 

(usage) <ListItem>Block*</ListItem> 

(description) A flow content element that represents a particular content item in an ordered 

or unordered List. 

(used by) ListItemCollection 

[content property] Blocks 

[name property] Name 

[xml lang property] Language 

(properties)  

Blocks BlockCollection 



 

319 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <ListItem>Block*</ListItem> 

(description) A block collection that contains the top-level Block elements of the ListItem. 

[read only] true 

BorderBrush Brush 

(description) A Brush to use when painting the element's border. 

BorderThickness Thickness 

(description) The border thickness for the element. 

FlowDirection FlowDirection 

(description) The relative direction for flow of content within a ListItem element. 

LineHeight x:Double 

(description) The height of each line of content. 

[text syntax] LengthSyntax 

LineStackingStrategy LineStackingStrategy 

(description) The mechanism by which a line box is determined for each line of text within 

the ListItem. 

Margin Thickness 

(description) The margin thickness for the element. 

Padding Thickness 

(description) The padding thickness for the element. 

SiblingListItems ListItemCollection 

(description) A ListItemCollection that contains the ListItem elements that are siblings of the 

current ListItem element. 

[read only] true 

TextAlignment TextAlignment 

(description) A value that indicates the horizontal alignment of text content. 

4.513   ListItemCollection 

x:Object > TextElementCollection(ListItem) > ListItemCollection 

(usage) None. 

(description) Represents a collection of ListItem elements. ListItemCollection defines the 

allowable child content of a List element. 

(used by) List ListItem 
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(usage) None. 

[is default 

constructible] 

false 

[is list] true 

[allowed types] ListItem 

4.514   ListView 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > Selector > ListBox > ListView, IInputElement 

(usage) <ListView>x:Object*</ListView> 

(description) Represents a control that displays a list of data items. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

View ViewBase 

(description) An object that defines how the data is styled and organized in a ListView control. 

4.515   ListViewItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ListBoxItem > ListViewItem, IInputElement 

(usage) <ListViewItem>x:Object</ListViewItem> 

(description) Represents an item in a ListView control. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.516   Localization 

x:Object > Localization 

(usage) None. 

(description) The Localization type defines attached properties for localization attributes 

and comments. 

[is default 

constructible] 

false 



 

321 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) None. 

(attachable properties)  

Localization.Attributes x:String 

(description) Which resources, such as FontFamily, are to be localized. 

[target type] x:Object 

Localization.Comments x:String 

(description) Comments, which are free-form text that the markup author includes. 

[target type] x:Object 

4.517   LocalizationCategory 

x:Object > LocalizationCategory 

(usage) None| Text| Title| Label| Button| CheckBox| ComboBox| ListBox| Menu... 

(description) Specifies the category value of a LocalizabilityAttribute for a type or type member. 

[is nullable] false 

[text syntax] LocalizationCategorySyntax 

4.518   LocalValueEntry 

x:Object > LocalValueEntry 

(usage) <LocalValueEntry /> 

(description) Represents a property identifier and the property value for a locally set property. 

[is nullable] false 

4.519   LocalValueEnumerator 

x:Object > LocalValueEnumerator 

(usage) <LocalValueEnumerator /> 

(description) Provides enumeration support for the local values of any properties that exist on a 

DependencyObject. 

[is nullable] false 

4.520   LogicalDirection 

x:Object > LogicalDirection 

(usage) Backward| Forward 
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(usage) Backward| Forward 

(description) Specifies a logical direction in which to perform certain text operations, such as inserting, 

retrieving, or navigating through text relative to a specified position (a TextPointer). 

[is nullable] false 

[text 

syntax] 

LogicalDirectionSyntax 

4.521   Manipulation 

x:Object > Manipulation 

(usage) None. 

(description) Contains methods to get and update information about a 

manipulation. 

[is default constructible] false 

(attachable properties)  

Manipulation.ManipulationContainer IInputElement 

(description)  

[target type] UIElement 

Manipulation.ManipulationMode ManipulationModes 

(description)  

[target type] UIElement 

Manipulation.ManipulationParameter ManipulationParameters2D 

(description)  

[target type] UIElement 

Manipulation.ManipulationPivot ManipulationPivot 

(description)  

[target type] UIElement 

4.522   ManipulationModes 

x:Object > ManipulationModes 

(usage) None| TranslateX| TranslateY| Translate| Rotate| Scale| All 

(description) Specifies how manipulation events are interpreted. 

(used by) Manipulation 
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(usage) None| TranslateX| TranslateY| Translate| Rotate| Scale| All 

[is nullable] false 

[text syntax] ManipulationModesSyntax 

4.523   ManipulationPivot 

x:Object > ManipulationPivot 

(usage) <ManipulationPivot /> 

(description) Specifies how a rotation occurs with one point of user input. 

(used by) Manipulation 

(properties)  

Center Point 

(description) The center of a single-point manipulation. 

Radius x:Double 

(description) The area around the pivot that is used to determine how much rotation and translation 

occurs when a single point of contact initiates the manipulation. 

4.524   Material 

x:Object > DependencyObject > Freezable > Animatable > Material 

DiffuseMaterial EmissiveMaterial MaterialGroup SpecularMaterial 

(usage) None. 

(description) A base type for materials. 

(used by) GeometryModel3D MaterialCollection Viewport2DVisual3D 

[is default constructible] false 

4.525   MaterialCollection 

x:Object > DependencyObject > Freezable > Animatable > MaterialCollection 

(usage) <MaterialCollection>Material*</MaterialCollection> 

(description) Collection of Material objects. 

(used by) MaterialGroup 

[is list] true 

[allowed types] Material 
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4.526   MaterialGroup 

x:Object > DependencyObject > Freezable > Animatable > Material > MaterialGroup 

(usage) <MaterialGroup>Material*</MaterialGroup> 

(description) Represents a Material that is a composite of the Materials in its collection. 

[content property] Children 

(properties)  

Children MaterialCollection 

(description) A collection of child Material objects. 

4.527   Matrix 

x:Object > Matrix 

(usage) <Matrix> string </Matrix> 

(description) Represents a 3x3 affine transformation matrix used for transformations in 2-D 

space. 

(used by) DrawingAttributes MatrixKeyFrame MatrixTransform 

[is nullable] false 

[text syntax] MatrixSyntax 

(properties)  

M11 x:Double 

(description) The value of the first row and first column of this Matrix structure. 

M12 x:Double 

(description) The value of the first row and second column of this Matrix structure. 

M21 x:Double 

(description) The value of the second row and first column of this Matrix structure. 

M22 x:Double 

(description) The value of the second row and second column of this Matrix structure. 

OffsetX x:Double 

(description) The value of the third row and first column of this Matrix structure. 

OffsetY x:Double 

(description) The value of the third row and second column of this Matrix structure. 

(static 

properties) 
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(usage) <Matrix> string </Matrix> 

Identity Matrix 

(description) An identity Matrix. 

4.528   Matrix3D 

x:Object > Matrix3D 

(usage) <Matrix3D> string </Matrix3D> 

(description) Represents a 4 x 4 matrix used for transformations in 3-D space. 

(used by) MatrixCamera MatrixTransform3D 

[is nullable] false 

[text syntax] Matrix3DSyntax 

(properties)  

M11 x:Double 

(description) The value of the first row and first column of this Matrix3D structure. 

M12 x:Double 

(description) The value of the first row and second column of this Matrix3D structure. 

M13 x:Double 

(description) The value of the first row and third column of this Matrix3D structure. 

M14 x:Double 

(description) The value of the first row and fourth column of this Matrix3D structure. 

M21 x:Double 

(description) The value of the second row and first column of this Matrix3D structure. 

M22 x:Double 

(description) The value of the second row and second column of this Matrix3D structure. 

M23 x:Double 

(description) The value of the second row and third column of this Matrix3D structure. 

M24 x:Double 

(description) The value of the second row and fourth column of this Matrix3D structure. 

M31 x:Double 

(description) The value of the third row and first column of this Matrix3D structure. 

M32 x:Double 
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(usage) <Matrix3D> string </Matrix3D> 

(description) The value of the third row and second column of this Matrix3D structure. 

M33 x:Double 

(description) The value of the third row and third column of this Matrix3D structure. 

M34 x:Double 

(description) The value of the third row and fourth column of this Matrix3D structure. 

M44 x:Double 

(description) The value of the fourth row and fourth column of this Matrix3D structure. 

OffsetX x:Double 

(description) The value of the fourth row and first column of this Matrix3D structure. 

OffsetY x:Double 

(description) The value of the fourth row and second column of this Matrix3D structure. 

OffsetZ x:Double 

(description) The value of the fourth row and third column of this Matrix3D structure. 

(static properties)  

Identity Matrix3D 

(description) Changes a Matrix3D structure into an identity Matrix3D. 

4.529   MatrixAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
MatrixAnimationBase 

MatrixAnimationUsingKeyFrames MatrixAnimationUsingPath 

(usage) None. 

(description) A base type that animates a Matrix value. 

[is default constructible] false 

[name property] Name 

4.530   MatrixAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
MatrixAnimationBase > MatrixAnimationUsingKeyFrames 

(usage) <MatrixAnimationUsingKeyFrames>MatrixKeyFrame*</MatrixAnimationUsingKeyFrames> 

(description) Animates the value of a Matrix property along a set of KeyFrames. 
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(usage) <MatrixAnimationUsingKeyFrames>MatrixKeyFrame*</MatrixAnimationUsingKeyFrames> 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

KeyFrames MatrixKeyFrameCollection 

(description) The collection of MatrixKeyFrame objects that define the animation. 

4.531   MatrixAnimationUsingPath 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
MatrixAnimationBase > MatrixAnimationUsingPath 

(usage) <MatrixAnimationUsingPath /> 

(description) Animates the value of a Matrix property by using a PathGeometry to 

generate the animated values. This animation can be used to move a visual 

object along a path. 

[name property] Name 

(properties)  

DoesRotateWithTangent x:Boolean 

(description) A value indicating whether the object rotates along the tangent of the path. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be 

added to this animation's starting value. 

IsAngleCumulative x:Boolean 

(description) A value that specifies whether the rotation angle of the animated matrix 

should accumulate over repetitions. 

IsOffsetCumulative x:Boolean 

(description) A value indicating whether the offset produced by the animated matrix will 

accumulate over repetitions. 

PathGeometry PathGeometry 

(description) The geometry used to generate this animation's output values. 

4.532   MatrixCamera 

x:Object > DependencyObject > Freezable > Animatable > Camera > MatrixCamera 

(usage) <MatrixCamera /> 
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(usage) <MatrixCamera /> 

(description) Camera which specifies the view and projection transforms as Matrix3D objects 

(properties)  

ProjectionMatrix Matrix3D 

(description) A Matrix3D as the projection transformation matrix. 

ViewMatrix Matrix3D 

(description) A Matrix3D as the view transformation matrix. 

4.533   MatrixKeyFrame 

x:Object > DependencyObject > Freezable > MatrixKeyFrame 

DiscreteMatrixKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a MatrixAnimationUsingKeyFrames. 

(used by) MatrixKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value Matrix 

(description) The key frame's target value. 

4.534   MatrixKeyFrameCollection 

x:Object > DependencyObject > Freezable > MatrixKeyFrameCollection 

(usage) <MatrixKeyFrameCollection>MatrixKeyFrame*</MatrixKeyFrameCollection> 

(description) Represents a collection of MatrixKeyFrame objects. 

(used by) MatrixAnimationUsingKeyFrames 

[is list] true 

[allowed types] MatrixKeyFrame 

(static properties)  

Empty MatrixKeyFrameCollection 
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(usage) <MatrixKeyFrameCollection>MatrixKeyFrame*</MatrixKeyFrameCollection> 

(description) An empty MatrixKeyFrameCollection. 

4.535   MatrixTransform 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform > Transform > 
MatrixTransform 

(usage) <MatrixTransform> string </MatrixTransform> 

(description) Creates an arbitrary affine matrix transformation that is used to manipulate objects or 

coordinate systems in a 2-D plane. 

[text 

syntax] 

TransformSyntax 

(properties)  

Matrix Matrix 

(description) The Matrix structure that defines this transformation. 

4.536   MatrixTransform3D 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > Transform3D > 
MatrixTransform3D 

(usage) <MatrixTransform3D /> 

(description) Creates a transformation specified by a Matrix3D, used to manipulate objects or 

coordinate systems in 3-D world space. 

(properties)  

Matrix Matrix3D 

(description) A Matrix3D that specifies a 3-D transformation. 

4.537   MediaCommands 

x:Object > MediaCommands 

(usage) {x:Static MediaCommands.StaticPropertyName} 

(description) Provides a standard set of media related commands. 

[is default constructible] false 

(static properties)  

BoostBass RoutedUICommand 

(description) The value that represents the Boost Base command. 

ChannelDown RoutedUICommand 
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(usage) {x:Static MediaCommands.StaticPropertyName} 

(description) The value that represents the Channel Down command. 

ChannelUp RoutedUICommand 

(description) The value that represents the Channel Up command. 

DecreaseBass RoutedUICommand 

(description) The value that represents the Decrease Bass command. 

DecreaseMicrophoneVolume RoutedUICommand 

(description) The value that represents the Decrease Microphone Volume command. 

DecreaseTreble RoutedUICommand 

(description) The value that represents the Decrease Treble command. 

DecreaseVolume RoutedUICommand 

(description) The value that represents the Decrease Volume command. 

FastForward RoutedUICommand 

(description) The value that represents the Fast Forward command. 

IncreaseBass RoutedUICommand 

(description) The value that represents the Increase Bass command. 

IncreaseMicrophoneVolume RoutedUICommand 

(description) The value that represents the Increase Microphone Volume command. 

IncreaseTreble RoutedUICommand 

(description) The value that represents the Increase Treble command. 

IncreaseVolume RoutedUICommand 

(description) The value that represents the Increase Volume command. 

MuteMicrophoneVolume RoutedUICommand 

(description) The value that represents the Mute Microphone Volume command. 

MuteVolume RoutedUICommand 

(description) The value that represents the Mute Volume command. 

NextTrack RoutedUICommand 

(description) The value that represents the Next Track command. 

Pause RoutedUICommand 

(description) The value that represents the Pause command. 

Play RoutedUICommand 



 

331 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) {x:Static MediaCommands.StaticPropertyName} 

(description) The value that represents the Play command. 

PreviousTrack RoutedUICommand 

(description) The value that represents the Previous Track command. 

Record RoutedUICommand 

(description) The value that represents the Record command. 

Rewind RoutedUICommand 

(description) The value that represents the Rewind command. 

Select RoutedUICommand 

(description) The value that represents the Select command. 

Stop RoutedUICommand 

(description) The value that represents the Stop command. 

ToggleMicrophoneOnOff RoutedUICommand 

(description) The value that represents the Toggle Microphone On Off command. 

TogglePlayPause RoutedUICommand 

(description) The value that represents the Toggle Play Pause command. 

4.538   MediaElement 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > MediaElement, 

IInputElement 

(usage) <MediaElement /> 

(description) Represents a control that contains audio and/or video. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Balance x:Double 

(description) A ratio of volume across speakers. 

IsMuted x:Boolean 

(description) A value indicating whether the audio is muted. 

LoadedBehavior MediaState 

(description) The load behavior MediaState for the media. 
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(usage) <MediaElement /> 

Position x:TimeSpan 

(description) The current position of progress through the media's playback time. 

ScrubbingEnabled x:Boolean 

(description) A value that indicates whether the MediaElement will update frames for seek 

operations while paused. 

Source x:Uri 

(description) A media source on the MediaElement. 

SpeedRatio x:Double 

(description) The speed ratio of the media. 

Stretch Stretch 

(description) A Stretch value that describes how a MediaElement fills the destination rectangle. 

StretchDirection StretchDirection 

(description) A value that determines the restrictions on scaling that are applied to the image. 

UnloadedBehavior MediaState 

(description) The unload behavior MediaState for the media. 

Volume x:Double 

(description) The media's volume. 

(events)  

BufferingEnded Occurs when media buffering has ended. 

BufferingStarted Occurs when media buffering has begun. 

MediaEnded Occurs when the media has ended. 

MediaFailed Occurs when an error is encountered. 

MediaOpened Occurs when media loading has finished. 

ScriptCommand Occurs when a script command is encountered in the media. 

4.539   MediaPlayer 

x:Object > DependencyObject > Freezable > Animatable > MediaPlayer 

(usage) <MediaPlayer /> 

(description) Provides media playback for drawings. 

(used by) VideoDrawing 
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(usage) <MediaPlayer /> 

(properties)  

Balance x:Double 

(description) The balance between the left and right speaker volumes. 

IsMuted x:Boolean 

(description) A value that indicates whether the media is muted. 

Position x:TimeSpan 

(description) The current position of the media. 

ScrubbingEnabled x:Boolean 

(description) A value that indicates whether scrubbing is enabled. 

SpeedRatio x:Double 

(description) The ratio of speed that media is played at. 

Volume x:Double 

(description) The media's volume. 

(events)  

BufferingEnded Occurs when buffering has finished. 

BufferingStarted Occurs when buffering has started. 

MediaEnded Occurs when the media has finished playback. 

MediaFailed Occurs when an error is encountered 

MediaOpened Occurs when the media is opened. 

ScriptCommand Occurs when a script command has been encountered within the media. 

4.540   MediaState 

x:Object > MediaState 

(usage) Manual| Play| Close| Pause| Stop 

(description) Specifies the states that can be applied to a MediaElement for the LoadedBehavior and 

UnloadedBehavior properties. 

(used by) MediaElement 

[is nullable] false 

[text 

syntax] 

MediaStateSyntax 
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4.541   MediaTimeline 

x:Object > DependencyObject > Freezable > Animatable > Timeline > MediaTimeline 

(usage) <MediaTimeline /> 

(description) Provides a Timeline for media content. 

[name property] Name 

(properties)  

Source x:Uri 

(description) The media source associated with the timeline. 

4.542   Menu 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > MenuBase > Menu, IInputElement 

RibbonMenuButton 

(usage) <Menu>x:Object*</Menu> 

(description) Represents a menu control that enables you to hierarchically organize elements 

associated with commands and event handlers. 

[content 

property] 

Items 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

IsMainMenu x:Boolean 

(description) A value that indicates whether this Menu receives a main menu activation 

notification. 

4.543   MenuBase 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > MenuBase, IInputElement 

ContextMenu Menu 

(usage) None. 

(description) Represents a control that defines choices for users to select. 

[is default constructible] false 

[content property] Items 
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ContextMenu Menu 

[name property] Name 

[xml lang property] Language 

(properties)  

UsesItemContainerTemplate 

(4.5) 

x:Boolean 

(description) A value that indicates whether the menu selects different item 

containers, depending on the type of the item in the underlying 

collection or some other heuristic. 

4.544   MenuItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > HeaderedItemsControl > MenuItem, IInputElement 

RibbonMenuItem 

(usage) <MenuItem>x:Object*</MenuItem> 

(description) Represents a selectable item inside a Menu. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

Command ICommand 

(description) The command associated with the menu item. 

CommandParameter x:Object 

(description) The parameter to pass to the Command property of a MenuItem. 

CommandTarget IInputElement 

(description) The target element on which to raise the specified command. 

Icon x:Object 

(description) The icon that appears in a MenuItem. 

InputGestureText x:String 

(description) The text describing an input gesture that will call the command tied 

to the specified item. 

IsCheckable x:Boolean 

(description) A value that indicates whether a MenuItem can be checked. 
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RibbonMenuItem 

IsChecked x:Boolean 

(description) A value that indicates whether the MenuItem is checked. 

IsSubmenuOpen x:Boolean 

(description) A value that indicates whether the submenu of the MenuItem is open. 

StaysOpenOnClick x:Boolean 

(description) A value that indicates that the submenu in which this MenuItem is 

located should not close when this item is clicked. 

UsesItemContainerTemplate 

(4.5) 

x:Boolean 

(description) A value that indicates whether the menu selects different item 

containers, depending on the type of the item in the underlying 

collection or some other heuristic. 

(static properties)  

SeparatorStyleKey ResourceKey 

(description) The resource key for a style applied to a MenuItem when the 

MenuItem is a Separator. 

SubmenuHeaderTemplateKey ResourceKey 

(description) The resource key for a style applied to a MenuItem when the 

MenuItem is a header of a submenu. 

SubmenuItemTemplateKey ResourceKey 

(description) The resource key for a style applied to a MenuItem when the 

MenuItem is a submenu. 

TopLevelHeaderTemplateKey ResourceKey 

(description) The resource key for a style applied to a MenuItem when the 

MenuItem is a header of a top-level menu. 

TopLevelItemTemplateKey ResourceKey 

(description) The resource key for a style applied to a MenuItem when it is a top-

level MenuItem that can invoke commands. 

(events)  

Checked Occurs when a menu item is checked. 

Click Occurs when a MenuItem is clicked. 

SubmenuClosed Occurs when the state of the IsSubmenuOpen property changes to 

false. 

SubmenuOpened Occurs when the state of the IsSubmenuOpen property changes to 

true. 



 

337 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

RibbonMenuItem 

Unchecked Occurs when a MenuItem is unchecked. 

4.545   MenuItemRole 

x:Object > MenuItemRole 

(usage) TopLevelItem| TopLevelHeader| SubmenuItem| SubmenuHeader 

(description) Defines the different roles that a MenuItem can have. 

[is nullable] false 

[text syntax] MenuItemRoleSyntax 

4.546   MenuScrollingVisibilityConverter 

x:Object > MenuScrollingVisibilityConverter, IMultiValueConverter 

(usage) <MenuScrollingVisibilityConverter /> 

(description) Represents a data-binding converter to handle the visibility of repeat buttons in scrolling 

menus. 

4.547   MeshGeometry3D 

x:Object > DependencyObject > Freezable > Animatable > Geometry3D > MeshGeometry3D 

(usage) <MeshGeometry3D /> 

(description) Triangle primitive for building a 3-D shape. 

(properties)  

Normals Vector3DCollection 

(description) A collection of normal vectors for the MeshGeometry3D. 

Positions Point3DCollection 

(description) A collection of vertex positions for a MeshGeometry3D. 

TextureCoordinates PointCollection 

(description) A collection of texture coordinates for the MeshGeometry3D. 

TriangleIndices Int32Collection 

(description) A collection of triangle indices for the MeshGeometry3D. 

4.548   MessageBoxButton 

x:Object > MessageBoxButton 
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(usage) OK| OKCancel| YesNoCancel| YesNo 

(description) Specifies the buttons that are displayed on a message box. Used as an argument of the 

Show method. 

[is nullable] false 

[text 

syntax] 

MessageBoxButtonSyntax 

4.549   MessageBoxImage 

x:Object > MessageBoxImage 

(usage) None| Hand| Question| Exclamation| Asterisk| Stop| Error| Warning| 

Information... 

(description) Specifies the icon that is displayed by a message box. 

[is nullable] false 

[text syntax] MessageBoxImageSyntax 

4.550   MessageBoxOptions 

x:Object > MessageBoxOptions 

(usage) None| ServiceNotification| DefaultDesktopOnly| RightAlign| RtlReading 

(description) Specifies special display options for a message box. 

[is nullable] false 

[text syntax] MessageBoxOptionsSyntax 

4.551   MessageBoxResult 

x:Object > MessageBoxResult 

(usage) None| OK| Cancel| Yes| No 

(description) Specifies which message box button that a user clicks. MessageBoxResult is returned by 

the Show method. 

[is nullable] false 

[text 

syntax] 

MessageBoxResultSyntax 

4.552   MinMaxParagraphWidth 

x:Object > MinMaxParagraphWidth 

(usage) <MinMaxParagraphWidth /> 
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(usage) <MinMaxParagraphWidth /> 

(description) Represents the smallest and largest possible paragraph width that can fully contain the 

specified text content. 

[is nullable] false 

4.553   Model3D 

x:Object > DependencyObject > Freezable > Animatable > Model3D 

GeometryModel3D Light Model3DGroup 

(usage) None. 

(description) Provides functionality for 3-D models. 

(used by) Model3DCollection ModelUIElement3D ModelVisual3D 

[is default constructible] false 

(properties)  

Transform Transform3D 

(description) The Transform3D set on the model. 

4.554   Model3DCollection 

x:Object > DependencyObject > Freezable > Animatable > Model3DCollection 

(usage) <Model3DCollection>Model3D*</Model3DCollection> 

(description) Represents an ordered collection of Model3D objects. 

(used by) Model3DGroup 

[is list] true 

[allowed types] Model3D 

4.555   Model3DGroup 

x:Object > DependencyObject > Freezable > Animatable > Model3D > Model3DGroup 

(usage) <Model3DGroup>Model3D*</Model3DGroup> 

(description) Enables using a number of 3-D models as a unit. 

[content property] Children 

(properties)  

Children Model3DCollection 

(description) A collection of Model3D objects. 
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4.556   ModelUIElement3D 

x:Object > DependencyObject > Visual3D > UIElement3D > ModelUIElement3D, IInputElement 

(usage) <ModelUIElement3D>Model3D</ModelUIElement3D> 

(description) Renders a 3-D model that supports input, focus, and events. 

[content property] Model 

(properties)  

Model Model3D 

(description) The Model3D to render. 

4.557   ModelVisual3D 

x:Object > DependencyObject > Visual3D > ModelVisual3D 

(usage) <ModelVisual3D>Visual3D*</ModelVisual3D> 

(description) Provides a Visual3D that renders Model3D objects. 

[content property] Children 

(properties)  

Children Visual3DCollection 

(description) A collection of child Visual3D objects. 

[read only] true 

Content Model3D 

(description) The model that comprises the content of the ModelVisual3D. 

Transform Transform3D 

(description) The transform set on the ModelVisual3D. 

4.558   Modifiability 

x:Object > Modifiability 

(usage) Unmodifiable| Modifiable| Inherit 

(description) Specifies the modifiability value of a LocalizabilityAttribute for a type or type member. 

[is nullable] false 

[text syntax] ModifiabilitySyntax 

4.559   ModifierKeys 

x:Object > ModifierKeys 
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(usage) None| Alt| Control| Shift| Windows 

(description) Specifies the set of modifier keys. 

(used by) KeyBinding MouseGesture 

[is nullable] false 

[text syntax] ModifierKeysSyntax 

4.560   Mouse 

x:Object > Mouse 

(usage) {x:Static Mouse.StaticPropertyName} 

(description) Represents the mouse device to a specific 

thread. 

[is default constructible] false 

(static properties)  

Captured IInputElement 

(description) The element that has captured the mouse. 

DirectlyOver IInputElement 

(description) The element the mouse pointer is directly 

over. 

LeftButton MouseButtonState 

(description) The state of the left button of the mouse. 

MiddleButton MouseButtonState 

(description) The state of the middle button of the mouse. 

OverrideCursor Cursor 

(description) The cursor for the entire application. 

PrimaryDevice MouseDevice 

(description) The primary mouse device. 

RightButton MouseButtonState 

(description) The state of the right button. 

XButton1 MouseButtonState 

(description) The state of the first extended button. 

XButton2 MouseButtonState 

(description) The state of the second extended button. 
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(usage) {x:Static Mouse.StaticPropertyName} 

(attachable events)  

Mouse.GotMouseCapture Occurs when an element captures the mouse. 

Mouse.LostMouseCapture Occurs when an element loses mouse 

capture. 

Mouse.MouseDown Occurs when any mouse button is depressed. 

Mouse.MouseEnter Occurs when the mouse pointer enters the 

boundaries of an element. 

Mouse.MouseLeave Occurs when the mouse pointer leaves the 

boundaries of an element. 

Mouse.MouseMove Occurs when the mouse pointer moves. 

Mouse.MouseUp Occurs when any mouse button is released. 

Mouse.MouseWheel Occurs when the mouse wheel is rotated. 

Mouse.PreviewMouseDown Occurs when any mouse button is depressed. 

Mouse.PreviewMouseDownOutsideCapturedElement Occurs when the primary mouse button is 

pressed outside the element that is capturing 

mouse events. 

Mouse.PreviewMouseMove Occurs when the mouse moves over an 

element. 

Mouse.PreviewMouseUp Occurs when any mouse button is released. 

Mouse.PreviewMouseUpOutsideCapturedElement Occurs when the primary mouse button is 

released outside the element that is capturing 

mouse events. 

Mouse.PreviewMouseWheel Occurs when the mouse wheel rotates. 

Mouse.QueryCursor Occurs when an element queries for the 

current mouse cursor. 

4.561   MouseAction 

x:Object > MouseAction 

(usage) None| LeftClick| RightClick| MiddleClick| WheelClick| LeftDoubleClick| 

RightDoubleClick| MiddleDoubleClick 

(description) Specifies constants that define actions performed by the mouse. 

(used by) MouseBinding MouseGesture 

[is nullable] false 

[text 

syntax] 

MouseActionSyntax 
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4.562   MouseBinding 

x:Object > DependencyObject > Freezable > InputBinding > MouseBinding 

(usage) <MouseBinding /> 

(description) Binds a MouseGesture to a RoutedCommand (or another ICommand implementation). 

(properties)  

Gesture InputGesture 

(description) The gesture associated with this MouseBinding. 

[text syntax] MouseGestureSyntax 

MouseAction MouseAction 

(description) The MouseAction associated with this MouseBinding. 

4.563   MouseButton 

x:Object > MouseButton 

(usage) Left| Middle| Right| XButton1| XButton2 

(description) Defines values that specify the buttons on a mouse device. 

[is nullable] false 

[text syntax] MouseButtonSyntax 

4.564   MouseButtonState 

x:Object > MouseButtonState 

(usage) Released| Pressed 

(description) Specifies the possible states of a mouse button. 

[is nullable] false 

[text syntax] MouseButtonStateSyntax 

4.565   MouseGesture 

x:Object > InputGesture > MouseGesture 

(usage) <MouseGesture> string </MouseGesture> 

(description) Defines a mouse input gesture that can be used to invoke a command. 

[text syntax] MouseGestureSyntax 

(properties)  
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(usage) <MouseGesture> string </MouseGesture> 

Modifiers ModifierKeys 

(description) The modifier keys associated with this MouseGesture. 

MouseAction MouseAction 

(description) The MouseAction associated with this gesture. 

4.566   MultiBinding 

x:Object > x:MarkupExtension > BindingBase > MultiBinding 

(usage) <MultiBinding>BindingBase*</MultiBinding> 

(description) Describes a collection of Binding objects attached to a single binding 

target property. 

[content property] Bindings 

[return value type] x:Object 

(properties)  

Bindings Collection(BindingBase) 

(description) The collection of Binding objects within this MultiBinding instance. 

[read only] true 

Converter IMultiValueConverter 

(description) The converter to use to convert the source values to or from the 

target value. 

ConverterCulture CultureInfo 

(description) The CultureInfo object that applies to any converter assigned to 

bindings wrapped by the MultiBinding or on the MultiBinding itself. 

[text syntax] CultureInfoIetfLanguageTagSyntax 

ConverterParameter x:Object 

(description) An optional parameter to pass to a converter as additional 

information. 

Mode BindingMode 

(description) A value that indicates the direction of the data flow of this binding. 

NotifyOnSourceUpdated x:Boolean 

(description) A value that indicates whether to raise the SourceUpdated event 

when a value is transferred from the binding target to the binding 

source. 

NotifyOnTargetUpdated x:Boolean 
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(usage) <MultiBinding>BindingBase*</MultiBinding> 

(description) A value that indicates whether to raise the TargetUpdated event when 

a value is transferred from the binding source to the binding target. 

NotifyOnValidationError x:Boolean 

(description) A value that indicates whether to raise the Error attached event on 

the bound element. 

UpdateSourceTrigger UpdateSourceTrigger 

(description) A value that determines the timing of binding source updates. 

ValidatesOnDataErrors x:Boolean 

(description) A value that indicates whether to include the DataErrorValidationRule. 

ValidatesOnExceptions x:Boolean 

(description) A value that indicates whether to include the ExceptionValidationRule. 

ValidatesOnNotifyDataErrors 

(4.5) 

x:Boolean 

(description) A value that indicates whether to include the 

NotifyDataErrorValidationRule. 

ValidationRules Collection(ValidationRule) 

(description) The collection of ValidationRule objects for this instance of 

MultiBinding. 

[read only] true 

4.567   MultiDataTrigger 

x:Object > DependencyObject > TriggerBase > MultiDataTrigger 

(usage) <MultiDataTrigger>SetterBase*</MultiDataTrigger> 

(description) Represents a trigger that applies property values or performs actions when the bound 

data meet a set of conditions. 

[content 

property] 

Setters 

(properties)  

Conditions ConditionCollection 

(description) A collection of Condition objects. Changes to property values are applied when all the 

conditions in the collection are met. 

[read only] true 

Setters SetterBaseCollection 

(description) A collection of Setter objects that describe the property values to apply when all the 
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(usage) <MultiDataTrigger>SetterBase*</MultiDataTrigger> 

conditions of the MultiDataTrigger are met. 

[read only] true 

4.568   MultiSelector 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > Selector > MultiSelector, IInputElement 

DataGrid 

(usage) None. 

(description) Provides a base type for controls that allow multiple items to be selected. 

[is default constructible] false 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

SelectedItems IList 

(description) The items in the MultiSelector that are selected. 

[read only] true 

4.569   MultiTrigger 

x:Object > DependencyObject > TriggerBase > MultiTrigger 

(usage) <MultiTrigger>SetterBase*</MultiTrigger> 

(description) Represents a trigger that applies property values or performs actions when a set of 

conditions are satisfied. 

[content 

property] 

Setters 

(properties)  

Conditions ConditionCollection 

(description) A collection of Condition objects. Changes to property values are applied when all of 

the conditions in the collection are met. 

[read only] true 

Setters SetterBaseCollection 

(description) A collection of Setter objects, which describe the property values to apply when all of 

the conditions of the MultiTrigger are met. 
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(usage) <MultiTrigger>SetterBase*</MultiTrigger> 

[read only] true 

4.570   NavigationCommands 

x:Object > NavigationCommands 

(usage) {x:Static NavigationCommands.StaticPropertyName} 

(description) Provides a standard set of navigation-related commands. 

[is default constructible] false 

(static properties)  

BrowseBack RoutedUICommand 

(description) The value that represents the Browse Back command. 

BrowseForward RoutedUICommand 

(description) The value that represents the Browse Forward command. 

BrowseHome RoutedUICommand 

(description) The value that represents the Browse Home command. 

BrowseStop RoutedUICommand 

(description) The value that represents the Browse Stop command. 

DecreaseZoom RoutedUICommand 

(description) The value that represents the Decrease Zoom command. 

Favorites RoutedUICommand 

(description) The value that represents the Favorites command. 

FirstPage RoutedUICommand 

(description) The value that represents the First Page command. 

GoToPage RoutedUICommand 

(description) The value that represents the Go To Page command. 

IncreaseZoom RoutedUICommand 

(description) The value that represents the Increase Zoom command. 

LastPage RoutedUICommand 

(description) The value that represents the Last Page command. 

NavigateJournal RoutedUICommand 

(description) The value that represents the Navigate Journal command. 
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(usage) {x:Static NavigationCommands.StaticPropertyName} 

NextPage RoutedUICommand 

(description) The value that represents the Next Page command. 

PreviousPage RoutedUICommand 

(description) The value that represents the Previous Page command. 

Refresh RoutedUICommand 

(description) The value that represents the Refresh command. 

Search RoutedUICommand 

(description) The value that represents the Search command. 

Zoom RoutedUICommand 

(description) The value that represents the Zoom command. 

4.571   NavigationMode 

x:Object > NavigationMode 

(usage) New| Back| Forward| Refresh 

(description) Specifies the type of navigation that is taking place NavigationMode is used by the 

NavigationMode property. 

[is nullable] false 

[text 

syntax] 

NavigationModeSyntax 

4.572   NavigationUIVisibility 

x:Object > NavigationUIVisibility 

(usage) Automatic| Visible| Hidden 

(description) Specifies whether a Frame displays its navigation chrome. NavigationUIVisibility is used 

by the NavigationUIVisibility property. 

(used by) Frame 

[is nullable] false 

[text 

syntax] 

NavigationUIVisibilitySyntax 

4.573   NavigationWindow 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > Window > NavigationWindow, IInputElement 
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(usage) <NavigationWindow /> 

(description) Represents a window that supports content navigation. 

[name property] Name 

[xml lang property] Language 

(properties)  

SandboxExternalContent x:Boolean 

(description) A value that indicates whether a NavigationWindow isolates external XAML 

content within a partial trust security sandbox (with default Internet zone 

permission set). 

ShowsNavigationUI x:Boolean 

(description) A value that indicates whether a NavigationWindow shows its navigation UI. 

Source x:Uri 

(description) The uniform resource identifier (URI) of the current content, or the URI of 

new content that is currently being navigated to. 

(events)  

FragmentNavigation Occurs when navigation to a content fragment begins, which occurs 

immediately, if the desired fragment is in the current content, or after the 

source XAML content has been loaded, if the desired fragment is in different 

content. 

LoadCompleted Occurs when content that was navigated to has been loaded, parsed, and 

has begun rendering. 

Navigated Occurs when the content that is being navigated to has been found, and is 

available from the Content property, although it may not have completed 

loading. 

Navigating Occurs when a new navigation is requested. 

NavigationFailed Occurs when an error is raised while navigating to the requested content. 

NavigationProgress Occurs periodically during a download to provide navigation progress 

information. 

NavigationStopped Occurs when the StopLoading method is called, or when a new navigation is 

requested while a current navigation is in progress. 

4.574   NonClientFrameEdges (4.5) 

x:Object > NonClientFrameEdges 

(usage) None| Left| Top| Right| Bottom 

(description) Specifies constants that indicate which edges of the window frame are not owned by the 

client. 

(used by) WindowChrome 
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(usage) None| Left| Top| Right| Bottom 

[is nullable] false 

[text 

syntax] 

NonClientFrameEdgesSyntax 

4.575   NotifyDataErrorValidationRule (4.5) 

x:Object > ValidationRule > NotifyDataErrorValidationRule 

(usage) <NotifyDataErrorValidationRule /> 

(description) Represents a rule that checks for errors that are raised by a data source that implements 

INotifyDataErrorInfo. 

4.576   NumberCultureSource 

x:Object > NumberCultureSource 

(usage) Text| User| Override 

(description) Specifies how the culture for numbers in a text run is determined. 

(used by) NumberSubstitution 

[is nullable] false 

[text syntax] NumberCultureSourceSyntax 

4.577   NumberSubstitution 

x:Object > NumberSubstitution 

(usage) <NumberSubstitution /> 

(description) Specifies how numbers in text are displayed in different 

cultures. 

(properties)  

CultureOverride CultureInfo 

(description) A value which identifies which culture to use when the value of 

the CultureSource property is set to Override. 

[text syntax] CultureInfoIetfLanguageTagSyntax 

CultureSource NumberCultureSource 

(description) A value which identifies the source of the culture value that is 

used to determine number substitution. 

Substitution NumberSubstitutionMethod 

(description) A value which identifies the substitution method that is used to 
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(usage) <NumberSubstitution /> 

determine number substitution. 

(attachable properties)  

NumberSubstitution.CultureOverride CultureInfo 

(description) A value which identifies which culture to use when the value of 

the CultureSource property is set to Override. 

[target type] DependencyObject 

[text syntax] CultureInfoIetfLanguageTagSyntax 

NumberSubstitution.CultureSource NumberCultureSource 

(description) A value which identifies the source of the culture value that is 

used to determine number substitution. 

[target type] DependencyObject 

NumberSubstitution.Substitution NumberSubstitutionMethod 

(description) A value which identifies the substitution method that is used to 

determine number substitution. 

[target type] DependencyObject 

4.578   NumberSubstitutionMethod 

x:Object > NumberSubstitutionMethod 

(usage) AsCulture| Context| European| NativeNational| Traditional 

(description) Defines an enumerator type that specifies the type of number substitution to perform on 

numbers in a text run. 

(used by) NumberSubstitution 

[is nullable] false 

[text 

syntax] 

NumberSubstitutionMethodSyntax 

4.579   ObjectAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
ObjectAnimationBase 

ObjectAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Object value. 

[is default constructible] false 
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ObjectAnimationUsingKeyFrames 

[name property] Name 

4.580   ObjectAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
ObjectAnimationBase > ObjectAnimationUsingKeyFrames 

(usage) <ObjectAnimationUsingKeyFrames>ObjectKeyFrame*</ObjectAnimationUsingKeyFrames> 

(description) Animates the value of an Object property along a set of KeyFrames over a specified 

Duration. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

KeyFrames ObjectKeyFrameCollection 

(description) The collection of ObjectKeyFrame objects that define the animation. 

4.581   ObjectDataProvider 

x:Object > DataSourceProvider > ObjectDataProvider 

(usage) <ObjectDataProvider /> 

(description) Wraps and creates an object that you can use as a binding source. 

(properties)  

ConstructorParameters IList 

(description) The list of parameters to pass to the constructor. 

[read only] true 

IsAsynchronous x:Boolean 

(description) A value that indicates whether to perform object creation in a worker thread 

or in the active context. 

MethodName x:String 

(description) The name of the method to call. 

MethodParameters IList 

(description) The list of parameters to pass to the method. 

[read only] true 
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(usage) <ObjectDataProvider /> 

ObjectInstance x:Object 

(description) The object used as the binding source. 

ObjectType x:XamlType 

(description) The type of object to create an instance of. 

4.582   ObjectKeyFrame 

x:Object > DependencyObject > Freezable > ObjectKeyFrame 

DiscreteObjectKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a ObjectAnimationUsingKeyFrames. 

(used by) ObjectKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value x:Object 

(description) The key frame's target value. 

4.583   ObjectKeyFrameCollection 

x:Object > DependencyObject > Freezable > ObjectKeyFrameCollection 

(usage) <ObjectKeyFrameCollection>ObjectKeyFrame*</ObjectKeyFrameCollection> 

(description) Represents a collection of ObjectKeyFrame objects. 

(used by) ObjectAnimationUsingKeyFrames 

[is list] true 

[allowed types] ObjectKeyFrame 

(static properties)  

Empty ObjectKeyFrameCollection 

(description) An empty ObjectKeyFrameCollection. 
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4.584   Orientation 

x:Object > Orientation 

(usage) Horizontal| Vertical 

(description) Defines the different orientations that a control or layout can have. 

(used by) ProgressBar ScrollBar Slider StackPanel ToolBarTray Track VirtualizingStackPanel 

WrapPanel 

[is nullable] false 

[text syntax] OrientationSyntax 

4.585   OrthographicCamera 

x:Object > DependencyObject > Freezable > Animatable > Camera > ProjectionCamera > 

OrthographicCamera 

(usage) <OrthographicCamera /> 

(description) Represents an orthographic projection camera. 

(properties)  

Width x:Double 

(description) The width of the camera's viewing box, in world units. 

4.586   OverflowMode 

x:Object > OverflowMode 

(usage) AsNeeded| Always| Never 

(description) Specifies how ToolBar items are placed in the main toolbar panel and in the overflow 

panel. 

(used by) ToolBar 

[is nullable] false 

[text syntax] OverflowModeSyntax 

4.587   Page 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Page, IInputElement 

(usage) <Page>x:Object</Page> 

(description) Represents a navigatable unit. 

[content property] Content 

[name property] Name 
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(usage) <Page>x:Object</Page> 

[xml lang property] Language 

(properties)  

Background Brush 

(description) The background for a Page. 

Content x:Object 

(description) The content of a Page. 

FontFamily FontFamily 

(description) The name of the specified font family. 

FontSize x:Double 

(description) The font size. 

[text syntax] FontSizeSyntax 

Foreground Brush 

(description) The foreground for a Page. 

KeepAlive x:Boolean 

(description) A value that indicates whether the Page instance is retained in navigation history. 

ShowsNavigationUI x:Boolean 

(description) Whether the navigation UI of a NavigationWindow is visible. 

Template ControlTemplate 

(description) The control template for a Page. 

Title x:String 

(description) The title of the Page. 

WindowHeight x:Double 

(description) The height of the host Window or NavigationWindow of a Page. 

WindowTitle x:String 

(description) The title of the host Window or NavigationWindow of a Page. 

WindowWidth x:Double 

(description) The width of the host Window or NavigationWindow of a Page. 

4.588   PageContent 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > PageContent, 
IInputElement 
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(usage) <PageContent>FixedPage</PageContent> 

(description) Provides information about the FixedPage elements within a FixedDocument. 

(used by) PageContentCollection 

[content property] Child 

[name property] Name 

[xml lang property] Language 

(properties)  

Child FixedPage 

(description) The FixedPage associated with this PageContent. 

LinkTargets LinkTargetCollection 

(description) A collection of LinkTarget elements that identify the hyperlink-addressable 

locations on the page. 

[read only] true 

Source x:Uri 

(description) The uniform resource identifier (URI) to the FixedPage content data stream. 

(events)  

GetPageRootCompleted Occurs when the asynchronous load of a fixed-format page has completed. 

4.589   PageContentCollection 

x:Object > PageContentCollection 

(usage) None. 

(description) Provides collection support for a collection of document pages. 

(used by) FixedDocument 

[is default constructible] false 

[is list] true 

[allowed types] PageContent 

4.590   PageRange 

x:Object > PageRange 

(usage) <PageRange /> 

(description) Specifies a range of pages. 
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(usage) <PageRange /> 

[is nullable] false 

(properties)  

PageFrom x:Int32 

(description) The page number of the first page in the range. 

PageTo x:Int32 

(description) The page number of the last page in the range. 

4.591   PageRangeSelection 

x:Object > PageRangeSelection 

(usage) AllPages| UserPages| CurrentPage| SelectedPages 

(description) Specifies whether all the pages or only a limited range will be processed by an operation, 

usually printing. 

[is nullable] false 

[text 

syntax] 

PageRangeSelectionSyntax 

4.592   Panel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel, IInputElement 

Canvas DockPanel Grid StackPanel TabPanel ToolBarOverflowPanel UniformGrid VirtualizingPanel 

WrapPanel 

(usage) None. 

(description) A base type for all panel elements and used to position and arrange child 

objects. 

[is default 

constructible] 

false 

[content property] Children 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) A Brush that is used to fill the area between the borders of a Panel. 

Children UIElementCollection 
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Canvas DockPanel Grid StackPanel TabPanel ToolBarOverflowPanel UniformGrid VirtualizingPanel 

WrapPanel 

(description) A UIElementCollection of child elements of this Panel. 

[read only] true 

IsItemsHost x:Boolean 

(description) A value that indicates that this Panel is a container for user interface (UI) items 

that are generated by an ItemsControl. 

(attachable 

properties) 

 

Panel.ZIndex x:Int32 

(description) A value that represents the order on the z-plane in which an element appears. 

[target type] UIElement 

4.593   PanningMode 

x:Object > PanningMode 

(usage) None| HorizontalOnly| VerticalOnly| Both| HorizontalFirst| VerticalFirst 

(description) Specifies how ScrollViewer reacts to touch manipulation. 

(used by) ScrollViewer 

[is nullable] false 

[text syntax] PanningModeSyntax 

4.594   Paragraph 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 

Block > Paragraph, IInputElement 

(usage) <Paragraph>[Inline|UIElement|x:String]*</Paragraph> 

(description) A block-level flow content element used to group content into a paragraph. 

[content 

property] 

Inlines 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Inlines InlineCollection 

(description) An InlineCollection containing the top-level Inline elements that comprise the 
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(usage) <Paragraph>[Inline|UIElement|x:String]*</Paragraph> 

contents of the Paragraph. 

[read only] true 

KeepTogether x:Boolean 

(description) A value that indicates whether the text of the paragraph may be broken by a page 

break or column break. 

KeepWithNext x:Boolean 

(description) A value that indicates whether a break may occur between this paragraph and the 

next paragraph. 

MinOrphanLines x:Int32 

(description) A value that specifies the minimum number of lines that can be left before the break 

when a Paragraph is broken by a page break or column break. 

MinWidowLines x:Int32 

(description) A value that specifies the minimum number of lines that can be placed after the 

break when a Paragraph is broken by a page break or column break. 

TextDecorations TextDecorationCollection 

(description) A TextDecorationCollection that contains text decorations to apply to this element. 

TextIndent x:Double 

(description) A value that indicates how far to indent the first line of a Paragraph. 

[text syntax] LengthSyntax 

4.595   ParallelTimeline 

x:Object > DependencyObject > Freezable > Animatable > Timeline > TimelineGroup > 

ParallelTimeline 

Storyboard 

(usage) <ParallelTimeline>Timeline*</ParallelTimeline> 

(description) Defines a segment of time that may contain child Timeline objects. These child 

timelines become active according to their respective BeginTime properties. Also, child 

timelines are able to overlap (run in parallel) with each other. 

[content 

property] 

Children 

[name 

property] 

Name 

(properties)  

SlipBehavior SlipBehavior 
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Storyboard 

(description) A value that specifies how this timeline will behave when one or more of its Timeline 

children slips. 

4.596   PasswordBox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
PasswordBox, IInputElement 

(usage) <PasswordBox /> 

(description) Represents a control designed for entering and handling 

passwords. 

[name property] Name 

[xml lang property] Language 

(properties)  

CaretBrush Brush 

(description) The brush that specifies the color of the password box's caret. 

IsInactiveSelectionHighlightEnabled x:Boolean 

(description)  

MaxLength x:Int32 

(description) The maximum length for passwords to be handled by this 

PasswordBox. 

Password x:String 

(description) The password currently held by the PasswordBox. 

PasswordChar x:Char 

(description) The masking character for the PasswordBox. 

SelectionBrush Brush 

(description) The brush that highlights selected text. 

SelectionOpacity x:Double 

(description) The opacity of the SelectionBrush. 

(events)  

PasswordChanged Occurs when the value of the Password property changes. 

4.597   Path 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Shape > Path, 
IInputElement 
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(usage) <Path /> 

(description) Draws a series of connected lines and curves. 

[name property] Name 

[xml lang property] Language 

(properties)  

Data Geometry 

(description) A Geometry that specifies the shape to be drawn. 

4.598   PathAnimationSource 

x:Object > PathAnimationSource 

(usage) X| Y| Angle 

(description) Specifies the output property value of the path that is used to drive the animation. 

(used by) DoubleAnimationUsingPath 

[is nullable] false 

[text syntax] PathAnimationSourceSyntax 

4.599   PathFigure 

x:Object > DependencyObject > Freezable > Animatable > PathFigure 

(usage) <PathFigure>PathSegment*</PathFigure> 

(description) Represents a subsection of a geometry, a single connected series of two-dimensional 

geometric segments. 

(used by) PathFigureCollection 

[content 

property] 

Segments 

(properties)  

IsClosed x:Boolean 

(description) A value that specifies whether this figures first and last segments are connected. 

IsFilled x:Boolean 

(description) Whether the contained area of this PathFigure is to be used for hit-testing, 

rendering, and clipping. 

Segments PathSegmentCollection 

(description) The collection of segments that define the shape of this PathFigure object. 
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(usage) <PathFigure>PathSegment*</PathFigure> 

StartPoint Point 

(description) The Point where the PathFigure begins. 

4.600   PathFigureCollection 

x:Object > DependencyObject > Freezable > Animatable > PathFigureCollection 

(usage) <PathFigureCollection> string </PathFigureCollection> 

(description) Represents a collection of PathFigure objects that collectively make up the geometry of 

a PathGeometry. 

(used by) PathGeometry 

[text syntax] PathFigureCollectionSyntax 

[is list] true 

[allowed 

types] 

PathFigure 

4.601   PathGeometry 

x:Object > DependencyObject > Freezable > Animatable > Geometry > PathGeometry 

(usage) <PathGeometry> string |PathFigure*</PathGeometry> 

(description) Represents a complex shape that may be composed of arcs, curves, ellipses, lines, 

and rectangles. 

(used by) DoubleAnimationUsingPath MatrixAnimationUsingPath PointAnimationUsingPath 

[text syntax] GeometrySyntax 

[content 

property] 

Figures 

(properties)  

Figures PathFigureCollection 

(description) The collection of PathFigure objects that describe the path's contents. 

FillRule FillRule 

(description) A value that determines how the intersecting areas contained in this PathGeometry 

are combined. 

4.602   PathSegment 

x:Object > DependencyObject > Freezable > Animatable > PathSegment 
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ArcSegment BezierSegment LineSegment PolyBezierSegment PolyLineSegment 

PolyQuadraticBezierSegment QuadraticBezierSegment 

(usage) None. 

(description) Represents a segment of a PathFigure object. 

(used by) PathSegmentCollection 

[is default 

constructible] 

false 

(properties)  

IsSmoothJoin x:Boolean 

(description) A value that indicates whether the join between this PathSegment and the 

previous PathSegment is treated as a corner when it is stroked with a Pen. 

IsStroked x:Boolean 

(description) A value that indicates whether the segment is stroked. 

4.603   PathSegmentCollection 

x:Object > DependencyObject > Freezable > Animatable > PathSegmentCollection 

(usage) <PathSegmentCollection>PathSegment*</PathSegmentCollection> 

(description) Represents a collection of PathSegment objects that can be individually accessed by 

index. 

(used by) PathFigure 

[is list] true 

[allowed 

types] 

PathSegment 

4.604   PauseStoryboard 

x:Object > DependencyObject > TriggerAction > ControllableStoryboardAction > PauseStoryboard 

(usage) <PauseStoryboard /> 

(description) A trigger action that pauses a Storyboard. 

4.605   Pen 

x:Object > DependencyObject > Freezable > Animatable > Pen 

(usage) <Pen /> 

(description) Describes how a shape is outlined. 

(used by) GeometryDrawing TextDecoration 
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(usage) <Pen /> 

(properties)  

Brush Brush 

(description) The fill the outline produced by this Pen. 

DashCap PenLineCap 

(description) A value that specifies how the ends of each dash are drawn. 

DashStyle DashStyle 

(description) A value that describes the pattern of dashes generated by this Pen. 

EndLineCap PenLineCap 

(description) The type of shape to use at the end of a stroke. 

LineJoin PenLineJoin 

(description) The type of joint used at the vertices of a shape's outline. 

MiterLimit x:Double 

(description) The limit on the ratio of the miter length to half this pen's Thickness. 

StartLineCap PenLineCap 

(description) The type of shape to use at the beginning of a stroke. 

Thickness x:Double 

(description) The thickness of the stroke produced by this Pen. 

4.606   PenLineCap 

x:Object > PenLineCap 

(usage) Flat| Square| Round| Triangle 

(description) Describes the shape at the end of a line or segment. 

(used by) Pen Shape 

[is nullable] false 

[text syntax] PenLineCapSyntax 

4.607   PenLineJoin 

x:Object > PenLineJoin 

(usage) Miter| Bevel| Round 

(description) Describes the shape that joins two lines or segments. 



 

365 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) Miter| Bevel| Round 

(used by) Pen Shape 

[is nullable] false 

[text syntax] PenLineJoinSyntax 

4.608   PerspectiveCamera 

x:Object > DependencyObject > Freezable > Animatable > Camera > ProjectionCamera > 
PerspectiveCamera 

(usage) <PerspectiveCamera /> 

(description) Represents a perspective projection camera. 

(properties)  

FieldOfView x:Double 

(description) A value that represents the camera's horizontal field of view. 

4.609   PixelFormat 

x:Object > PixelFormat 

(usage) Bgr101010| Bgr24| Bgr32| Bgr555| Bgr565| Bgra32| BlackWhite| Cmyk32| 

Default... 

(description) Defines a pixel format for images and pixel-based surfaces. 

(used by) ColorConvertedBitmap FormatConvertedBitmap 

[is nullable] false 

[text syntax] PixelFormatSyntax 

(properties)  

Masks IList(PixelFormatChannelMask) 

(description) A collection of bit masks associated with the PixelFormat. 

[read only] true 

4.610   PixelFormatChannelMask 

x:Object > PixelFormatChannelMask 

(usage) <PixelFormatChannelMask /> 

(description) Defines the bit mask and shift for a specific pixel formats 

(used by) PixelFormat 



 

366 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <PixelFormatChannelMask /> 

[is nullable] false 

(properties)  

Mask IList(x:Byte) 

(description) The bitmask for a color channel. The value will never be greater then 0xffffffff 

[read only] true 

4.611   PixelFormats 

x:Object > PixelFormats 

(usage) {x:Static PixelFormats.StaticPropertyName} 

(description) Represents the collection of supported pixel formats. 

[is default 

constructible] 

false 

(static 

properties) 

 

Bgr101010 PixelFormat 

(description) The Bgr101010 pixel format. Bgr101010 is a sRGB format with 32 bits per pixel 

(BPP). Each color channel (blue, green, and red) is allocated 10 bits per pixel (BPP). 

Bgr24 PixelFormat 

(description) The Bgr24 pixel format. Bgr24 is a sRGB format with 24 bits per pixel (BPP). Each 

color channel (blue, green, and red) is allocated 8 bits per pixel (BPP). 

Bgr32 PixelFormat 

(description) The Bgr32 pixel format. Bgr32 is a sRGB format with 32 bits per pixel (BPP). Each 

color channel (blue, green, and red) is allocated 8 bits per pixel (BPP). 

Bgr555 PixelFormat 

(description) The Bgr555 pixel format. Bgr555 is a sRGB format with 16 bits per pixel (BPP). Each 

color channel (blue, green, and red) is allocated 5 bits per pixel (BPP). 

Bgr565 PixelFormat 

(description) The Bgr565 pixel format. Bgr565 is a sRGB format with 16 bits per pixel (BPP). Each 

color channel (blue, green, and red) is allocated 5, 6, and 5 bits per pixel (BPP) 

respectively. 

Bgra32 PixelFormat 

(description) The Bgra32 pixel format. Bgra32 is a sRGB format with 32 bits per pixel (BPP). Each 

channel (blue, green, red, and alpha) is allocated 8 bits per pixel (BPP). 

BlackWhite PixelFormat 
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(usage) {x:Static PixelFormats.StaticPropertyName} 

(description) The black and white pixel format which displays one bit of data per pixel as either 

black or white. 

Cmyk32 PixelFormat 

(description) The Cmyk32 pixel format which displays 32 bits per pixel (BPP) with each color 

channel (cyan, magenta, yellow, and black) allocated 8 bits per pixel (BPP). 

Default PixelFormat 

(description) The pixel format that is best suited for the particular operation. 

Gray16 PixelFormat 

(description) The Gray16 pixel format which displays a 16 bits-per-pixel grayscale channel, 

allowing 65536 shades of gray. This format has a gamma of 1.0. 

Gray2 PixelFormat 

(description) The Gray2 pixel format which displays a 2 bits-per-pixel grayscale channel, allowing 

4 shades of gray. 

Gray32Float PixelFormat 

(description) The Gray32Float pixel format. Gray32Float displays a 32 bits per pixel (BPP) 

grayscale channel, allowing over 4 billion shades of gray. This format has a gamma 

of 1.0. 

Gray4 PixelFormat 

(description) The Gray4 pixel format which displays a 4 bits-per-pixel grayscale channel, allowing 

16 shades of gray. 

Gray8 PixelFormat 

(description) The Gray8 pixel format which displays an 8 bits-per-pixel grayscale channel, allowing 

256 shades of gray. 

Indexed1 PixelFormat 

(description) The pixel format specifying a paletted bitmap with 2 colors. 

Indexed2 PixelFormat 

(description) The pixel format specifying a paletted bitmap with 4 colors. 

Indexed4 PixelFormat 

(description) The pixel format specifying a paletted bitmap with 16 colors. 

Indexed8 PixelFormat 

(description) The pixel format specifying a paletted bitmap with 256 colors. 

Pbgra32 PixelFormat 

(description) The Pbgra32 pixel format. Pbgra32 is a sRGB format with 32 bits per pixel (BPP). 

Each channel (blue, green, red, and alpha) is allocated 8 bits per pixel (BPP). Each 
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(usage) {x:Static PixelFormats.StaticPropertyName} 

color channel is pre-multiplied by the alpha value. 

Prgba128Float PixelFormat 

(description) The Prgba128Float pixel format. Prgba128Float is a ScRGB format with 128 bits per 

pixel (BPP). Each channel (red, green, blue, and alpha) is allocated 32 bits per pixel 

(BPP). Each color channel is pre-multiplied by the alpha value. This format has a 

gamma of 1.0. 

Prgba64 PixelFormat 

(description) The Prgba64 pixel format. Prgba64 is a sRGB format with 64 bits per pixel (BPP). 

Each channel (blue, green, red, and alpha) is allocated 32 bits per pixel (BPP). Each 

color channel is pre-multiplied by the alpha value. This format has a gamma of 1.0. 

Rgb128Float PixelFormat 

(description) The Rgb128Float pixel format. Rgb128Float is a ScRGB format with 128 bits per pixel 

(BPP). Each color channel is allocated 32 BPP. This format has a gamma of 1.0. 

Rgb24 PixelFormat 

(description) The Rgb24 pixel format. Rgb24 is a sRGB format with 24 bits per pixel (BPP). Each 

color channel (red, green, and blue) is allocated 8 bits per pixel (BPP). 

Rgb48 PixelFormat 

(description) The Rgb48 pixel format. Rgb48 is a sRGB format with 48 bits per pixel (BPP). Each 

color channel (red, green, and blue) is allocated 16 bits per pixel (BPP). This format 

has a gamma of 1.0. 

Rgba128Float PixelFormat 

(description) The Rgba128Float pixel format. Rgba128Float is a ScRGB format with 128 bits per 

pixel (BPP). Each color channel is allocated 32 bits per pixel (BPP). This format has a 

gamma of 1.0. 

Rgba64 PixelFormat 

(description) The Rgba64 pixel format. Rgba64 is an sRGB format with 64 bits per pixel (BPP). 

Each channel (red, green, blue, and alpha) is allocated 16 bits per pixel (BPP). This 

format has a gamma of 1.0. 

4.612   PixelShader 

x:Object > DependencyObject > Freezable > Animatable > PixelShader 

(usage) <PixelShader /> 

(description) Provides a managed wrapper around a High Level Shading Language (HLSL) pixel 

shader. 

(properties)  

ShaderRenderMode ShaderRenderMode 

(description) A value indicating whether to use hardware or software rendering. 
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(usage) <PixelShader /> 

UriSource x:Uri 

(description) A Pack URI reference to HLSL bytecode in the assembly. 

4.613   PlacementMode 

x:Object > PlacementMode 

(usage) Absolute| Relative| Bottom| Center| Right| AbsolutePoint| RelativePoint| Mouse| 

MousePoint... 

(description) Describes the placement of where a Popup control appears on the screen. 

(used by) ContextMenu ContextMenuService Popup ToolTip ToolTipService 

[is nullable] false 

[text 

syntax] 

PlacementModeSyntax 

4.614   PngBitmapEncoder 

x:Object > BitmapEncoder > PngBitmapEncoder 

(usage) <PngBitmapEncoder /> 

(description) Defines an encoder that is used to encode Portable Network Graphics (PNG) format 

images. 

(properties)  

Interlace PngInterlaceOption 

(description) A value that indicates whether the Portable Network Graphics (PNG) bitmap should 

interlace. 

4.615   PngInterlaceOption 

x:Object > PngInterlaceOption 

(usage) Default| On| Off 

(description) Specifies whether a Portable Network Graphics (PNG) format image is interlaced during 

encoding. 

(used by) PngBitmapEncoder 

[is nullable] false 

[text 

syntax] 

PngInterlaceOptionSyntax 
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4.616   Point 

x:Object > Point 

(usage) <Point> string </Point> 

(description) Represents an x- and y-coordinate pair in two-dimensional space. 

(used by) ArcSegment BezierSegment CustomPopupPlacement EllipseGeometry GlyphRun 

KeySpline LinearGradientBrush LineGeometry LineSegment ManipulationPivot PathFigure 

PointCollection PointKeyFrame QuadraticBezierSegment RadialGradientBrush Rect 

TouchPoint UIElement 

[is nullable] false 

[text 

syntax] 

PointSyntax 

(properties)  

X x:Double 

(description) The X-coordinate value of this Point structure. 

Y x:Double 

(description) The Y-coordinate value of this Point. 

4.617   Point3D 

x:Object > Point3D 

(usage) <Point3D> string </Point3D> 

(description) Represents an x-, y-, and z-coordinate point in 3-D space. 

(used by) Point3DCollection Point3DKeyFrame PointLightBase ProjectionCamera Rect3D 

[is nullable] false 

[text syntax] Point3DSyntax 

(properties)  

X x:Double 

(description) The x-coordinate of this Point3D structure. 

Y x:Double 

(description) The y-coordinate of this Point3D structure. 

Z x:Double 

(description) The z-coordinate of this Point3D structure. 
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4.618   Point3DAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Point3DAnimationBase > Point3DAnimation 

(usage) <Point3DAnimation /> 

(description) Animates the value of a Point3D property using linear interpolation between two 

values. 

[name 

property] 

Name 

(properties)  

By x:Nullable(Point3D) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Point3D) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Point3D) 

(description) The animation's ending value. 

4.619   Point3DAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Point3DAnimationBase 

Point3DAnimation Point3DAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Point3D value. 

[is default constructible] false 

[name property] Name 
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4.620   Point3DAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Point3DAnimationBase > Point3DAnimationUsingKeyFrames 

(usage) <Point3DAnimationUsingKeyFrames>Point3DKeyFrame*</Point3DAnimationUsingKeyFrame

s> 

(description

) 

Animates the value of a Point3D property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description

) 

A value that specifies whether the animation's output value is added to the base value of the 

property being animated. 

IsCumulativ

e 

x:Boolean 

(description

) 

A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames Point3DKeyFrameCollection 

(description

) 

The collection of Point3DKeyFrame objects that define the animation. 

4.621   Point3DCollection 

x:Object > DependencyObject > Freezable > Point3DCollection 

(usage) <Point3DCollection> string </Point3DCollection> 

(description) Represents an ordered collection of Point3D objects. 

(used by) MeshGeometry3D 

[text syntax] Point3DCollectionSyntax 

[is list] true 

[allowed types] Point3D 

4.622   Point3DKeyFrame 

x:Object > DependencyObject > Freezable > Point3DKeyFrame 

DiscretePoint3DKeyFrame EasingPoint3DKeyFrame LinearPoint3DKeyFrame 

SplinePoint3DKeyFrame 
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DiscretePoint3DKeyFrame EasingPoint3DKeyFrame LinearPoint3DKeyFrame 

SplinePoint3DKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a Point3DAnimationUsingKeyFrames. 

(used by) Point3DKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value Point3D 

(description) The key frame's target value. 

4.623   Point3DKeyFrameCollection 

x:Object > DependencyObject > Freezable > Point3DKeyFrameCollection 

(usage) <Point3DKeyFrameCollection>Point3DKeyFrame*</Point3DKeyFrameCollection> 

(description) Represents a collection of Point3DKeyFrame objects. 

(used by) Point3DAnimationUsingKeyFrames 

[is list] true 

[allowed types] Point3DKeyFrame 

(static properties)  

Empty Point3DKeyFrameCollection 

(description) An empty Point3DKeyFrameCollection. 

4.624   Point4D 

x:Object > Point4D 

(usage) <Point4D> string </Point4D> 

(description) Represents an x-, y-, z-, and w-coordinate point in world space used in performing 

transformations with non-affine 3-D matrices. 

[is nullable] false 

[text 

syntax] 

Point4DSyntax 
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(usage) <Point4D> string </Point4D> 

(properties)  

W x:Double 

(description) The W component of this Point4D structure. 

X x:Double 

(description) The X component of this Point4D structure. 

Y x:Double 

(description) The Y component of this Point4D structure. 

Z x:Double 

(description) The Z component of this Point4D structure. 

4.625   PointAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
PointAnimationBase > PointAnimation 

(usage) <PointAnimation /> 

(description) Animates the value of a Point property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(Point) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Point) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Point) 

(description) The animation's ending value. 



 

375 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

4.626   PointAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
PointAnimationBase 

PointAnimation PointAnimationUsingKeyFrames PointAnimationUsingPath 

(usage) None. 

(description) A base type that animates a Point value. 

[is default constructible] false 

[name property] Name 

4.627   PointAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

PointAnimationBase > PointAnimationUsingKeyFrames 

(usage) <PointAnimationUsingKeyFrames>PointKeyFrame*</PointAnimationUsingKeyFrames> 

(description) Animates the value of a Point property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value of 

the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames PointKeyFrameCollection 

(description) The collection of PointKeyFrame objects that define the animation. 

4.628   PointAnimationUsingPath 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

PointAnimationBase > PointAnimationUsingPath 

(usage) <PointAnimationUsingPath /> 

(description) Animates the value of a Point property between two or more target values using a 

PathGeometry to specify those values. This animation can be used to move a visual 

object along a path. 

[name Name 
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(usage) <PointAnimationUsingPath /> 

property] 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value 

of the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

PathGeometry PathGeometry 

(description) Specifies the geometry used to generate this animation's output values. 

4.629   PointCollection 

x:Object > DependencyObject > Freezable > PointCollection 

(usage) <PointCollection> string </PointCollection> 

(description) Represents a collection of Point values that can be individually accessed by index. 

(used by) MeshGeometry3D PolyBezierSegment Polygon Polyline PolyLineSegment 

PolyQuadraticBezierSegment 

[text syntax] PointCollectionSyntax 

[is list] true 

[allowed 

types] 

Point 

4.630   PointKeyFrame 

x:Object > DependencyObject > Freezable > PointKeyFrame 

DiscretePointKeyFrame EasingPointKeyFrame LinearPointKeyFrame SplinePointKeyFrame 

(usage) None. 

(description) Defines an animation segment with its own target value and interpolation 

technique for a PointAnimationUsingKeyFrames. 

(used by) PointKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 
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DiscretePointKeyFrame EasingPointKeyFrame LinearPointKeyFrame SplinePointKeyFrame 

Value Point 

(description) The key frame's target value. 

4.631   PointKeyFrameCollection 

x:Object > DependencyObject > Freezable > PointKeyFrameCollection 

(usage) <PointKeyFrameCollection>PointKeyFrame*</PointKeyFrameCollection> 

(description) Represents a collection of PointKeyFrame objects. 

(used by) PointAnimationUsingKeyFrames 

[is list] true 

[allowed types] PointKeyFrame 

(static properties)  

Empty PointKeyFrameCollection 

(description) An empty PointKeyFrameCollection. 

4.632   PointLight 

x:Object > DependencyObject > Freezable > Animatable > Model3D > Light > PointLightBase > 

PointLight 

(usage) <PointLight /> 

(description) Represents a light source that has a specified position in space and projects its light in all 

directions. 

4.633   PointLightBase 

x:Object > DependencyObject > Freezable > Animatable > Model3D > Light > PointLightBase 

PointLight SpotLight 

(usage) None. 

(description) A base type that represents a light object that has a position in space and 

projects its light in all directions. 

[is default 

constructible] 

false 

(properties)  

ConstantAttenuation x:Double 

(description) A constant value by which the intensity of the light diminishes over distance. 
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PointLight SpotLight 

LinearAttenuation x:Double 

(description) A value that specifies the linear diminution of the light's intensity over 

distance. 

Position Point3D 

(description) A Point3D that specifies the light's position in world space. 

QuadraticAttenuation x:Double 

(description) A value that specifies the diminution of the light's effect over distance, 

calculated by a quadratic operation. 

Range x:Double 

(description) The distance beyond which the light has no effect. 

4.634   PolyBezierSegment 

x:Object > DependencyObject > Freezable > Animatable > PathSegment > PolyBezierSegment 

(usage) <PolyBezierSegment /> 

(description) Represents one or more cubic Bezier curves. 

(properties)  

Points PointCollection 

(description) The PointCollection that define this PolyBezierSegment object. 

4.635   Polygon 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Shape > Polygon, 
IInputElement 

(usage) <Polygon /> 

(description) Draws a polygon, which is a connected series of lines that form a closed shape. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

FillRule FillRule 

(description) A FillRule enumeration that specifies how the interior fill of the shape is 

determined. 

Points PointCollection 
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(usage) <Polygon /> 

(description) A collection that contains the vertex points of the polygon. 

4.636   Polyline 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Shape > Polyline, 
IInputElement 

(usage) <Polyline /> 

(description) Draws a series of connected straight lines. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

FillRule FillRule 

(description) A FillRule enumeration that specifies how the interior fill of the shape is 

determined. 

Points PointCollection 

(description) A collection that contains the vertex points of the Polyline. 

4.637   PolyLineSegment 

x:Object > DependencyObject > Freezable > Animatable > PathSegment > PolyLineSegment 

(usage) <PolyLineSegment /> 

(description) Represents a set of line segments defined by a PointCollection with each Point specifying 

the end point of a line segment. 

(properties)  

Points PointCollection 

(description) The collection of Point structures that defines this PolyLineSegment object. 

4.638   PolyQuadraticBezierSegment 

x:Object > DependencyObject > Freezable > Animatable > PathSegment > 

PolyQuadraticBezierSegment 

(usage) <PolyQuadraticBezierSegment /> 

(description) Represents a set of quadratic Bezier segments. 

(properties)  

Points PointCollection 
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(usage) <PolyQuadraticBezierSegment /> 

(description) The PointCollection that defines this PolyQuadraticBezierSegment object. 

4.639   Popup 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Popup, IInputElement 

(usage) <Popup>UIElement</Popup> 

(description) Represents a pop-up window that has content. 

[content property] Child 

[name property] Name 

[xml lang property] Language 

(properties)  

AllowsTransparency x:Boolean 

(description) A value that indicates whether a Popup control can contain transparent content. 

Child UIElement 

(description) The content of the Popup control. 

HorizontalOffset x:Double 

(description) Get or sets the horizontal distance between the target origin and the popup 

alignment point. 

[text syntax] LengthSyntax 

IsOpen x:Boolean 

(description) A value that indicates whether the Popup is visible. 

Placement PlacementMode 

(description) The orientation of the Popup control when the control opens, and specifies the 

behavior of the Popup control when it overlaps screen boundaries. 

PlacementRectangle Rect 

(description) The rectangle relative to which the Popup control is positioned when it opens. 

PlacementTarget UIElement 

(description) The element relative to which the Popup is positioned when it opens. 

PopupAnimation PopupAnimation 

(description) An animation for the opening and closing of a Popup control. 

StaysOpen x:Boolean 

(description) A value that indicates whether the Popup control closes when the control is no 
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(usage) <Popup>UIElement</Popup> 

longer in focus. 

VerticalOffset x:Double 

(description) The vertical distance between the target origin and the popup alignment point. 

[text syntax] LengthSyntax 

(events)  

Closed Occurs when the IsOpen property changes to false. 

Opened Occurs when the IsOpen property changes to true. 

4.640   PopupAnimation 

x:Object > PopupAnimation 

(usage) None| Fade| Slide| Scroll 

(description) Describes how a Popup control animates when it opens. 

(used by) Popup 

[is nullable] false 

[text syntax] PopupAnimationSyntax 

4.641   PopupPrimaryAxis 

x:Object > PopupPrimaryAxis 

(usage) None| Horizontal| Vertical 

(description) Describes the direction to move a Popup control to increase the amount of the Popup 

that is visible. 

(used by) CustomPopupPlacement 

[is nullable] false 

[text 

syntax] 

PopupPrimaryAxisSyntax 

4.642   PowerEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > PowerEase, IEasingFunction 

(usage) <PowerEase /> 

(description) Represents an easing function that creates an animation that accelerates and/or 

decelerates using the formula f(t) = tp where p is equal to the Power property. 

(properties)  
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(usage) <PowerEase /> 

Power x:Double 

(description) The exponential power of the animation interpolation. For example, a value of 7 will 

create an animation interpolation curve that follows the formula f(t) = t7. 

4.643   PowerLineStatus 

x:Object > PowerLineStatus 

(usage) Offline| Online| Unknown 

(description) Indicates whether the system power is online, or that the system power status is 

unknown. 

[is nullable] false 

[text syntax] PowerLineStatusSyntax 

4.644   PresentationTraceLevel 

x:Object > PresentationTraceLevel 

(usage) None| Low| Medium| High 

(description) Describes the level of detail to trace about a particular object. 

(used by) PresentationTraceSources 

[is nullable] false 

[text syntax] PresentationTraceLevelSyntax 

4.645   PresentationTraceSources 

x:Object > PresentationTraceSources 

(usage) None. 

(description) Provides debug tracing support that is specifically targeted for 

applications. 

[is default constructible] false 

(attachable properties)  

PresentationTraceSources.TraceLevel PresentationTraceLevel 

(description) A value that specifies the level of detail to trace about a 

particular object. 

[target type] x:Object 
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4.646   PriorityBinding 

x:Object > x:MarkupExtension > BindingBase > PriorityBinding 

(usage) <PriorityBinding>BindingBase*</PriorityBinding> 

(description) Describes a collection of Binding objects that is attached to a single binding target 

property, which receives its value from the first binding in the collection that produces 

a value successfully. 

[content 

property] 

Bindings 

[return value 

type] 

x:Object 

(properties)  

Bindings Collection(BindingBase) 

(description) The collection of Binding objects that is established for this instance of PriorityBinding. 

[read only] true 

4.647   ProgressBar 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > RangeBase 
> ProgressBar, IInputElement 

(usage) <ProgressBar /> 

(description) Indicates the progress of an operation. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

IsIndeterminate x:Boolean 

(description) Whether the ProgressBar shows actual values or generic, continuous progress 

feedback. 

Orientation Orientation 

(description) The orientation of a ProgressBar: horizontal or vertical. 

4.648   ProjectionCamera 

x:Object > DependencyObject > Freezable > Animatable > Camera > ProjectionCamera 

OrthographicCamera PerspectiveCamera 

(usage) None. 
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OrthographicCamera PerspectiveCamera 

(description) A base type for perspective and orthographic projection cameras. 

[is default 

constructible] 

false 

(properties)  

FarPlaneDistance x:Double 

(description) A value that specifies the distance from the camera of the camera's far clip 

plane. 

LookDirection Vector3D 

(description) A Vector3D which defines the direction in which the camera is looking in 

world coordinates. 

NearPlaneDistance x:Double 

(description) A value that specifies the distance from the camera of the camera's near clip 

plane. 

Position Point3D 

(description) The position of the camera in world coordinates. 

UpDirection Vector3D 

(description) A Vector3D which defines the upward direction of the camera. 

4.649   PropertyGroupDescription 

x:Object > GroupDescription > PropertyGroupDescription 

(usage) <PropertyGroupDescription /> 

(description) Describes the grouping of items using a property name as the criteria. 

(properties)  

Converter IValueConverter 

(description) A converter to apply to the property value or the item to produce the final value 

that is used to determine which group(s) an item belongs to. 

PropertyName x:String 

(description) The name of the property that is used to determine which group(s) an item belongs 

to. 

StringComparison StringComparison 

(description) A StringComparison value that specifies the comparison between the value of an 

item (as determined by PropertyName and Converter) and the name of a group. 
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4.650   PropertyPath 

x:Object > PropertyPath 

(usage) <PropertyPath> string </PropertyPath> 

(description) Implements a data structure for describing a property as a path below another 

property, or below an owning type. Property paths are used in data binding to 

objects, and in storyboards and timelines for animations. 

(used by) Binding Storyboard 

[is default 

constructible] 

false 

[text syntax] PropertyPathSyntax 

(properties)  

Path x:String 

(description) The string that describes the path. 

PathParameters Collection(x:Object) 

(description) The list of parameters to use when the path refers to indexed parameters. 

[read only] true 

4.651   QuadraticBezierSegment 

x:Object > DependencyObject > Freezable > Animatable > PathSegment > 
QuadraticBezierSegment 

(usage) <QuadraticBezierSegment /> 

(description) Creates a quadratic Bezier curve between two points in a PathFigure. 

(properties)  

Point1 Point 

(description) The control Point of the curve. 

Point2 Point 

(description) The end Point of this QuadraticBezierSegment. 

4.652   QuadraticEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > QuadraticEase, IEasingFunction 

(usage) <QuadraticEase /> 

(description) Represents an easing function that creates an animation that accelerates and/or 

decelerates using the formula f(t) = t2 
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4.653   QuarticEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > QuarticEase, IEasingFunction 

(usage) <QuarticEase /> 

(description) Represents an easing function that creates an animation that accelerates and/or 

decelerates using the formula f(t) = t4. 

4.654   Quaternion 

x:Object > Quaternion 

(usage) <Quaternion> string </Quaternion> 

(description) Structure that represents a rotation in three dimensions. 

(used by) QuaternionKeyFrame QuaternionRotation3D 

[is nullable] false 

[text syntax] QuaternionSyntax 

(properties)  

W x:Double 

(description) The W component of the quaternion. 

X x:Double 

(description) The X component of the quaternion. 

Y x:Double 

(description) The Y component of the quaternion. 

Z x:Double 

(description) The Z component of the quaternion. 

(static properties)  

Identity Quaternion 

(description) The Identity quaternion 

4.655   QuaternionAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

QuaternionAnimationBase > QuaternionAnimation 

(usage) <QuaternionAnimation /> 

(description) Animates the value of a Quaternion property between two target values using  linear 

interpolation over a specified Duration. 
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(usage) <QuaternionAnimation /> 

[name property] Name 

(properties)  

By x:Nullable(Quaternion) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Quaternion) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Quaternion) 

(description) The animation's ending value. 

UseShortestPath x:Boolean 

(description) A Boolean value that indicates whether the animation uses spherical linear 

interpolation to calculate the shortest arc between positions. 

4.656   QuaternionAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

QuaternionAnimationBase 

QuaternionAnimation QuaternionAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Quaternion value. 

[is default constructible] false 

[name property] Name 

4.657   QuaternionAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
QuaternionAnimationBase > QuaternionAnimationUsingKeyFrames 
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(usage) <QuaternionAnimationUsingKeyFrames>QuaternionKeyFrame*</QuaternionAnimationUsingK

eyFrames> 

(descriptio

n) 

Animates the value of a Quaternion property along a set of KeyFrames over a specified 

Duration. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties

) 

 

IsAdditive x:Boolean 

(descriptio

n) 

A value that specifies whether the animation's output value is added to the base value of the 

property being animated. 

IsCumulati

ve 

x:Boolean 

(descriptio

n) 

A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames QuaternionKeyFrameCollection 

(descriptio

n) 

The collection of QuaternionKeyFrame objects that define the animation. 

4.658   QuaternionKeyFrame 

x:Object > DependencyObject > Freezable > QuaternionKeyFrame 

DiscreteQuaternionKeyFrame EasingQuaternionKeyFrame LinearQuaternionKeyFrame 

SplineQuaternionKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a QuaternionAnimationUsingKeyFrames. 

(used by) QuaternionKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value Quaternion 

(description) The key frame's target value. 
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4.659   QuaternionKeyFrameCollection 

x:Object > DependencyObject > Freezable > QuaternionKeyFrameCollection 

(usage) <QuaternionKeyFrameCollection>QuaternionKeyFrame*</QuaternionKeyFrameCollection> 

(description) Represents a collection of QuaternionKeyFrame objects. 

(used by) QuaternionAnimationUsingKeyFrames 

[is list] true 

[allowed 

types] 

QuaternionKeyFrame 

(static 

properties) 

 

Empty QuaternionKeyFrameCollection 

(description) An empty QuaternionKeyFrameCollection. 

4.660   QuaternionRotation3D 

x:Object > DependencyObject > Freezable > Animatable > Rotation3D > QuaternionRotation3D 

(usage) <QuaternionRotation3D /> 

(description) Represents a rotation transformation defined as a quaternion. 

(properties)  

Quaternion Quaternion 

(description) The Quaternion that defines the destination rotation. 

4.661   QuinticEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > QuinticEase, IEasingFunction 

(usage) <QuinticEase /> 

(description) Represents an easing function that creates an animation that accelerates and/or 

decelerates using the formula f(t) = t5. 

4.662   RadialGradientBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > GradientBrush > 
RadialGradientBrush 

(usage) <RadialGradientBrush> string |GradientStop*</RadialGradientBrush> 

(description) Paints an area with a radial gradient. A focal point defines the beginning of the 

gradient, and a circle defines the end point of the gradient. 

[text syntax] BrushSyntax 
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(usage) <RadialGradientBrush> string |GradientStop*</RadialGradientBrush> 

[content 

property] 

GradientStops 

(properties)  

Center Point 

(description) The center of the outermost circle of the radial gradient. 

GradientOrigin Point 

(description) The location of the two-dimensional focal point that defines the beginning of the 

gradient. 

RadiusX x:Double 

(description) The horizontal radius of the outermost circle of the radial gradient. 

RadiusY x:Double 

(description) The vertical radius of the outermost circle of a radial gradient. 

4.663   RadioButton 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ButtonBase > ToggleButton > RadioButton, IInputElement 

RibbonRadioButton 

(usage) <RadioButton>x:Object</RadioButton> 

(description) Represents a button that can be selected, but not cleared, by a user. The IsChecked 

property of a RadioButton can be set by clicking it, but it can only be cleared 

programmatically. 

[content 

property] 

Content 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

GroupName x:String 

(description) The name that specifies which RadioButton controls are mutually exclusive. 

4.664   RangeBase 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > RangeBase, 
IInputElement 
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ProgressBar ScrollBar Slider 

(usage) None. 

(description) Represents an element that has a value within a specific range. 

[is default 

constructible] 

false 

[name property] Name 

[xml lang property] Language 

(properties)  

LargeChange x:Double 

(description) A value to be added to or subtracted from the Value of a RangeBase control. 

Maximum x:Double 

(description) The highest possible Value of the range element. 

Minimum x:Double 

(description) The Minimum possible Value of the range element. 

SmallChange x:Double 

(description) A Value to be added to or subtracted from the Value of a RangeBase 

control. 

Value x:Double 

(description) The current magnitude of the range control. 

(events)  

ValueChanged Occurs when the range value changes. 

4.665   Readability 

x:Object > Readability 

(usage) Unreadable| Readable| Inherit 

(description) Specifies the readability value of a LocalizabilityAttribute for a type or type member. 

[is nullable] false 

[text syntax] ReadabilitySyntax 

4.666   ReasonSessionEnding 

x:Object > ReasonSessionEnding 

(usage) Logoff| Shutdown 
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(usage) Logoff| Shutdown 

(description) Specifies the reason for which the user's session is ending. Used by the 

ReasonSessionEnding property. 

[is nullable] false 

[text 

syntax] 

ReasonSessionEndingSyntax 

4.667   RecognitionConfidence 

x:Object > RecognitionConfidence 

(usage) Strong| Intermediate| Poor 

(description) Specifies the confidence level that the GestureRecognizer determines for a particular ink 

gesture. 

[is nullable] false 

[text 

syntax] 

RecognitionConfidenceSyntax 

4.668   Rect 

x:Object > Rect 

(usage) <Rect> string </Rect> 

(description) Describes the width, height, and location of a rectangle. 

(used by) ContextMenu ContextMenuService FixedPage ImageDrawing Popup 

RectangleGeometry RectKeyFrame TileBrush ToolTip ToolTipService TouchPoint 

VideoDrawing Viewport3DVisual 

[is nullable] false 

[text syntax] RectSyntax 

(properties)  

Height x:Double 

(description) The height of the rectangle. 

Location Point 

(description) The position of the top-left corner of the rectangle. 

Size Size 

(description) The width and height of the rectangle. 

Width x:Double 

(description) The width of the rectangle. 
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(usage) <Rect> string </Rect> 

X x:Double 

(description) The x-axis value of the left side of the rectangle. 

Y x:Double 

(description) The y-axis value of the top side of the rectangle. 

(static 

properties) 

 

Empty Rect 

(description) A special value that represents a rectangle with no position or area. 

4.669   Rect3D 

x:Object > Rect3D 

(usage) <Rect3D> string </Rect3D> 

(description) Represents a 3-D rectangle: for example, a cube. 

[is nullable] false 

[text syntax] Rect3DSyntax 

(properties)  

Location Point3D 

(description) A Point3D that represents the origin of the Rect3D. 

Size Size3D 

(description) The area of the Rect3D. 

SizeX x:Double 

(description) The size of the Rect3D  in the X dimension. 

SizeY x:Double 

(description) The size of the Rect3D  in the Y dimension. 

SizeZ x:Double 

(description) The size of the Rect3D in the Z dimension. 

X x:Double 

(description) The value of the X coordinate of the Rect3D. 

Y x:Double 

(description) The value of the Y coordinate of the Rect3D. 
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(usage) <Rect3D> string </Rect3D> 

Z x:Double 

(description) The value of the Z coordinate of the Rect3D. 

(static properties)  

Empty Rect3D 

(description) An empty Rect3D. 

4.670   Rectangle 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Shape > Rectangle, 

IInputElement 

(usage) <Rectangle /> 

(description) Draws a rectangle. 

[name property] Name 

[xml lang property] Language 

(properties)  

RadiusX x:Double 

(description) The x-axis radius of the ellipse that is used to round the corners of the rectangle. 

[text syntax] LengthSyntax 

RadiusY x:Double 

(description) The y-axis radius of the ellipse that is used to round the corners of the rectangle. 

[text syntax] LengthSyntax 

4.671   RectangleGeometry 

x:Object > DependencyObject > Freezable > Animatable > Geometry > RectangleGeometry 

(usage) <RectangleGeometry> string </RectangleGeometry> 

(description) Describes a two-dimensional rectangle. 

[text syntax] GeometrySyntax 

(properties)  

RadiusX x:Double 

(description) The x-radius of the ellipse use to round the corners of the rectangle. 

RadiusY x:Double 
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(usage) <RectangleGeometry> string </RectangleGeometry> 

(description) The y-radius of the ellipse use to round the corners of the rectangle. 

Rect Rect 

(description) The dimensions of the rectangle. 

4.672   RectAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
RectAnimationBase > RectAnimation 

(usage) <RectAnimation /> 

(description) Animates the value of a Rect property between two target values using linear 

interpolation. 

[name 

property] 

Name 

(properties)  

By x:Nullable(Rect) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Rect) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Rect) 

(description) The animation's ending value. 

4.673   RectAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

RectAnimationBase 

RectAnimation RectAnimationUsingKeyFrames 

(usage) None. 
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RectAnimation RectAnimationUsingKeyFrames 

(description) A base type that animates a Rect value. 

[is default constructible] false 

[name property] Name 

4.674   RectAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
RectAnimationBase > RectAnimationUsingKeyFrames 

(usage) <RectAnimationUsingKeyFrames>RectKeyFrame*</RectAnimationUsingKeyFrames> 

(description) Animates the value of a property that takes a Rect along a set of key frames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that indicates whether the animation's output value is added to the base value 

of the property being animated. 

IsCumulative x:Boolean 

(description) A value that indicates whether the animation's value accumulates when it repeats. 

KeyFrames RectKeyFrameCollection 

(description) The collection of RectKeyFrame objects that define the animation. 

4.675   RectKeyFrame 

x:Object > DependencyObject > Freezable > RectKeyFrame 

DiscreteRectKeyFrame EasingRectKeyFrame LinearRectKeyFrame SplineRectKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a RectAnimationUsingKeyFrames. 

(used by) RectKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 
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DiscreteRectKeyFrame EasingRectKeyFrame LinearRectKeyFrame SplineRectKeyFrame 

(description) The time at which the key frame's target Value should be reached. 

Value Rect 

(description) The key frame's target value. 

4.676   RectKeyFrameCollection 

x:Object > DependencyObject > Freezable > RectKeyFrameCollection 

(usage) <RectKeyFrameCollection>RectKeyFrame*</RectKeyFrameCollection> 

(description) Represents a collection of RectKeyFrame objects. 

(used by) RectAnimationUsingKeyFrames 

[is list] true 

[allowed types] RectKeyFrame 

(static properties)  

Empty RectKeyFrameCollection 

(description) An empty RectKeyFrameCollection. 

4.677   RelativeSource 

x:Object > x:MarkupExtension > RelativeSource 

(usage) {RelativeSource } | <RelativeSource /> 

(description) Implements a markup extension that describes the location of the binding source 

relative to the position of the binding target. 

(used by) Binding 

[return value 

type] 

RelativeSource 

[constructors]  

(1 parameter)  

mode RelativeSourceMode 

(description) One of the RelativeSourceMode values. 

(3 parameters)  

mode RelativeSourceMode 

(description) One of the RelativeSourceMode values. For this signature to be relevant, this 

should be FindAncestor. 
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(usage) {RelativeSource } | <RelativeSource /> 

ancestorType x:XamlType 

(description) The Type of ancestor to look for. 

ancestorLevel x:Int32 

(description) The ordinal position of the desired ancestor among all ancestors of the given type. 

(properties)  

AncestorLevel x:Int32 

(description) The level of ancestor to look for, in FindAncestor mode. Use 1 to indicate the one 

nearest to the binding target element. 

AncestorType x:XamlType 

(description) The type of ancestor to look for. 

Mode RelativeSourceMode 

(description) A RelativeSourceMode value that describes the location of the binding source 

relative to the position of the binding target. 

(static properties)  

PreviousData RelativeSource 

(description) A static value that is used to return a RelativeSource constructed for the 

PreviousData mode. 

Self RelativeSource 

(description) A static value that is used to return a RelativeSource constructed for the Self 

mode. 

TemplatedParent RelativeSource 

(description) A static value that is used to return a RelativeSource constructed for the 

TemplatedParent mode. 

4.678   RelativeSourceMode 

x:Object > RelativeSourceMode 

(usage) PreviousData| TemplatedParent| Self| FindAncestor 

(description) Describes the location of the binding source relative to the position of the binding target. 

(used by) RelativeSource 

[is nullable] false 

[text syntax] RelativeSourceModeSyntax 
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4.679   RemoveStoryboard 

x:Object > DependencyObject > TriggerAction > ControllableStoryboardAction > RemoveStoryboard 

(usage) <RemoveStoryboard /> 

(description) A trigger action that removes a Storyboard. 

4.680   RenderCapability 

x:Object > RenderCapability 

(usage) {x:Static RenderCapability.StaticPropertyName} 

(description) Enables applications to query for the current rendering 

tier for their associated Dispatcher object and to 

register for notification of changes. 

[is default constructible] false 

(static properties)  

IsShaderEffectSoftwareRenderingSupported x:Boolean 

(description) A value that indicates whether the system can render 

bitmap effects in software. 

MaxHardwareTextureSize Size 

(description) The maximum width and height for bitmap creation of 

the underlying hardware device. 

Tier x:Int32 

(description) A value that indicates the rendering tier for the 

current thread. 

4.681   RenderingBias 

x:Object > RenderingBias 

(usage) Performance| Quality 

(description) Indicates whether the system renders an effect with emphasis on speed or quality. 

(used by) BlurEffect DropShadowEffect 

[is nullable] false 

[text syntax] RenderingBiasSyntax 

4.682   RenderOptions 

x:Object > RenderOptions 
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(usage) {x:Static 

RenderOptions.StaticPropertyName} 

(description) Provides options for controlling the 

rendering behavior of objects. 

[is default constructible] false 

(attachable properties)  

RenderOptions.BitmapScalingMode BitmapScalingMode 

(description) The BitmapScalingMode for a given 

DependencyObject. 

[target type] DependencyObject 

RenderOptions.CacheInvalidationThresholdMaximum x:Double 

(description) The cache invalidation threshold maximum 

value for a given DependencyObject. 

[target type] DependencyObject 

RenderOptions.CacheInvalidationThresholdMinimum x:Double 

(description) The cache invalidation threshold minimum 

value for a given DependencyObject. 

[target type] DependencyObject 

RenderOptions.CachingHint CachingHint 

(description) A value that indicates that rendered content 

should be cached when possible. 

[target type] DependencyObject 

RenderOptions.ClearTypeHint ClearTypeHint 

(description) A value that indicates to the rendering 

engine whether text can be rendered with 

ClearType. 

[target type] DependencyObject 

RenderOptions.EdgeMode EdgeMode 

(description) The EdgeMode enumeration value for a non-

text primitive that determines how its edges 

are rendered. 

[target type] DependencyObject 

(static properties)  

ProcessRenderMode RenderMode 

(description) Specifies the render mode preference for the 

current process. 
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4.683   RenderTargetBitmap 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 
RenderTargetBitmap 

(usage) <RenderTargetBitmap> string </RenderTargetBitmap> 

(description) Converts a Visual object into a bitmap. 

[is default constructible] false 

[text syntax] x:Uri, from [MS-XAML] 

4.684   RepeatBehavior 

x:Object > RepeatBehavior 

(usage) <RepeatBehavior> string </RepeatBehavior> 

(description) Describes how a Timeline repeats its simple duration. 

(used by) Timeline 

[is nullable] false 

[text syntax] RepeatBehaviorSyntax 

(static properties)  

Forever RepeatBehavior 

(description) A RepeatBehavior that specifies an infinite number of repetitions. 

4.685   RepeatButton 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ButtonBase > RepeatButton, IInputElement 

(usage) <RepeatButton>x:Object</RepeatButton> 

(description) Represents a control that raises its Click event repeatedly from the time it is pressed 

until it is released. 

(used by) Track 

[content 

property] 

Content 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

Delay x:Int32 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) <RepeatButton>x:Object</RepeatButton> 

(description) The amount of time, in milliseconds, the RepeatButton waits while it is pressed before 

it starts repeating. The value must be non-negative. 

Interval x:Int32 

(description) The amount of time, in milliseconds, between repeats once repeating starts. The 

value must be non-negative. 

4.686   ResizeGrip 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > ResizeGrip, 
IInputElement 

(usage) <ResizeGrip /> 

(description) Represents an implementation of a Thumb control that enables a Window to 

change its size. 

[name property] Name 

[xml lang 

property] 

Language 

4.687   ResizeGripDirection (4.5) 

x:Object > ResizeGripDirection 

(usage) None| TopLeft| Top| TopRight| Right| BottomRight| Bottom| BottomLeft| Left... 

(description) Specifies constants that indicate the direction of the resize grip behavior on an input 

element. 

(used by) WindowChrome 

[is nullable] false 

[text 

syntax] 

ResizeGripDirectionSyntax 

4.688   ResizeMode 

x:Object > ResizeMode 

(usage) NoResize| CanMinimize| CanResize| CanResizeWithGrip 

(description) Specifies whether a window can be resized and, if so, how it can be resized. Used by the 

ResizeMode property. 

(used by) Window 

[is nullable] false 

[text 

syntax] 

ResizeModeSyntax 
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4.689   ResourceDictionary 

x:Object > ResourceDictionary 

(usage) <ResourceDictionary>ResourceDictionary</ResourceDictionary> 

(description) Provides a hash table / dictionary implementation that contains resources used by 

components and other elements of an application. 

(used by) Application FrameworkContentElement FrameworkElement FrameworkTemplate 

ResourceDictionary Style 

[is dictionary] true 

[allowed types] x:Object 

[allowed key 

types] 

x:Object 

(properties)  

DeferrableContent DeferrableContent 

(description) The deferrable content for this resource dictionary. 

IsReadOnly x:Boolean 

(description) Whether this ResourceDictionary is read-only. 

MergedDictionaries Collection(ResourceDictionary) 

(description) A collection of the ResourceDictionary dictionaries that constitute the various 

resource dictionaries in the merged dictionaries. 

[read only] true 

Source x:Uri 

(description) The uniform resource identifier (URI) to load resources from. 

4.690   ResourceDictionaryLocation 

x:Object > ResourceDictionaryLocation 

(usage) None| SourceAssembly| ExternalAssembly 

(description) Specifies the locations where theme resource dictionaries are located. 

[is nullable] false 

[text syntax] ResourceDictionaryLocationSyntax 

4.691   ResourceKey 

x:Object > x:MarkupExtension > ResourceKey 

ComponentResourceKey TemplateKey 
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ComponentResourceKey TemplateKey 

(usage) None. 

(description) A base type for various resource keys. 

[is default constructible] false 

[return value type] ResourceKey 

4.692   RestoreFocusMode 

x:Object > RestoreFocusMode 

(usage) Auto| None 

(description) Specifies how restores focus to the window. 

[is nullable] false 

[text syntax] RestoreFocusModeSyntax 

4.693   ResumeStoryboard 

x:Object > DependencyObject > TriggerAction > ControllableStoryboardAction > ResumeStoryboard 

(usage) <ResumeStoryboard /> 

(description) Supports a trigger action that resumes a paused Storyboard. 

4.694   Ribbon (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > Selector > Ribbon, IInputElement 

(usage) <Ribbon>x:Object*</Ribbon> 

(description) Represents the root element of a ribbon user interface that 

hosts a Quick Access Toolbar, Application Menu, and tabs. 

(used by) RibbonControlService 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

ApplicationMenu RibbonApplicationMenu 

(description) The RibbonApplicationMenu that is a logical child of this Ribbon 

control. 

CheckedBackground Brush 
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(usage) <Ribbon>x:Object*</Ribbon> 

(description) The brush that is used to draw the background of Ribbon 

controls when they are in the Checked state. 

CheckedBorderBrush Brush 

(description) The brush that is used to draw the outer border of Ribbon 

controls when they are in the Checked state. 

ContextualTabGroupHeaderTemplate DataTemplate 

(description) The template that is used to display Header items in the 

RibbonContextualTabGroup. 

ContextualTabGroups Collection(RibbonContextualTabGroup) 

(description) A collection that contains all of the RibbonContextualTabGroup 

items in the Ribbon. 

[read only] true 

ContextualTabGroupStyle Style 

(description) The style that is used when rendering 

RibbonContextualTabGroup items in the Ribbon. 

FocusedBackground Brush 

(description) The brush used to draw the background of Ribbon controls in 

the Focused state. 

FocusedBorderBrush Brush 

(description) The brush used to draw the outer border of Ribbon controls in 

the Focused state. 

HelpPaneContent x:Object 

(description) The contents of the help pane. 

HelpPaneContentTemplate DataTemplate 

(description) The template that is used to display the content of the help 

pane. 

IsCollapsed x:Boolean 

(description) A value that indicates whether the Ribbon is collapsed. 

IsDropDownOpen x:Boolean 

(description) A value that indicates whether the drop-down for a RibbonTab 

is open. 

IsMinimized x:Boolean 

(description) A value that indicates whether the Ribbon is minimized. 

MouseOverBackground Brush 
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(usage) <Ribbon>x:Object*</Ribbon> 

(description) The brush that is used to draw the background of Ribbon 

controls when they are in the MouseOver state. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of Ribbon 

controls when they are in the MouseOver state. 

PressedBackground Brush 

(description) The brush that is used to draw the background of Ribbon 

controls when they are in the Pressed state. 

PressedBorderBrush Brush 

(description) The brush that is used to draw the outer border of Ribbon 

controls when they are in the Pressed state. 

QuickAccessToolBar RibbonQuickAccessToolBar 

(description) The RibbonQuickAccessToolBar that is a logical child of this 

Ribbon. 

ShowQuickAccessToolBarOnTop x:Boolean 

(description) A value that indicates whether to show the Quick Access 

Toolbar above the Ribbon. 

TabHeaderStyle Style 

(description) The style that is used when rendering tab headers. 

TabHeaderTemplate DataTemplate 

(description) The template that is used to display tab headers. 

Title x:Object 

(description) The title of this Ribbon control. 

TitleTemplate DataTemplate 

(description) The template that is used to display the Ribbon title. 

WindowIconVisibility Visibility 

(description) The Visibility for the icon of the RibbonWindow that contains 

this Ribbon. 

(events)  

Collapsed Occurs when the IsCollapsed property is changed to true and 

the Ribbon is collapsed. 

Expanded Occurs when the IsCollapsed property is changed to false and 

the Ribbon is expanded. 
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4.695   RibbonApplicationMenu (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > MenuBase > Menu > RibbonMenuButton > RibbonApplicationMenu, IInputElement 

(usage) <RibbonApplicationMenu>x:Object*</RibbonApplicationMenu> 

(description) Represents an Application Menu that is used in a Ribbon 

control. 

(used by) Ribbon 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

AuxiliaryPaneContent x:Object 

(description) The content of the Application Menu auxiliary pane. 

AuxiliaryPaneContentTemplate DataTemplate 

(description) The template that is used to display the content of the 

Application Menu auxiliary pane. 

AuxiliaryPaneContentTemplateSelector DataTemplateSelector 

(description) The custom logic for selecting a DataTemplate that is used to 

display the contents of the Application Menu auxiliary pane. 

FooterPaneContent x:Object 

(description) The content of the Application Menu footer pane. 

FooterPaneContentTemplate DataTemplate 

(description) The template that is used to display the content of the 

Application Menu footer pane. 

FooterPaneContentTemplateSelector DataTemplateSelector 

(description) The custom logic for selecting a DataTemplate that is used to 

display the contents of the Application Menu footer pane. 

4.696   RibbonApplicationMenuItem (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > MenuItem > RibbonMenuItem > 

RibbonApplicationMenuItem, IInputElement 

(usage) <RibbonApplicationMenuItem>x:Object*</RibbonApplicationMenuItem> 

(description) Represents a menu item inside a RibbonApplicationMenu control. 
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(usage) <RibbonApplicationMenuItem>x:Object*</RibbonApplicationMenuItem> 

[content property] Items 

[name property] Name 

[xml lang property] Language 

4.697   RibbonApplicationMenuItemLevel (4.5) 

x:Object > RibbonApplicationMenuItemLevel 

(usage) Top| Middle| Sub 

(description) Defines constants that specify the level that a menu item is displayed at in the ribbon 

Application Menu. 

[is nullable] false 

[text 

syntax] 

RibbonApplicationMenuItemLevelSyntax 

4.698   RibbonApplicationSplitMenuItem (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > MenuItem > RibbonMenuItem > RibbonSplitMenuItem > 
RibbonApplicationSplitMenuItem, IInputElement 

(usage) <RibbonApplicationSplitMenuItem>x:Object*</RibbonApplicationSplitMenuItem> 

(description) Represents a menu item inside a RibbonApplicationMenu control that can invoke a 

command and also display a submenu. 

[content 

property] 

Items 

[name 

property] 

Name 

[xml lang 

property] 

Language 

4.699   RibbonButton (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ButtonBase > Button > RibbonButton, IInputElement 

(usage) <RibbonButton>x:Object</RibbonButton> 

(description) Represents a button that is used in a Ribbon control. 

[content property] Content 

[name property] Name 
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(usage) <RibbonButton>x:Object</RibbonButton> 

[xml lang property] Language 

(properties)  

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

CornerRadius CornerRadius 

(description) A value that indicates the amount that the corners of a 

ribbon button are rounded. 

FocusedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it has focus. 

FocusedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it has focus. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

Label x:String 

(description) The text that is displayed next to or below the control. 

LargeImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Large. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the 

control when the mouse pointer is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when the mouse pointer is over it. 

PressedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it is pressed. 

PressedBorderBrush Brush 
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(usage) <RibbonButton>x:Object</RibbonButton> 

(description) The brush that is used to draw the outer border of the 

control when it is pressed. 

QuickAccessToolBarControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control when it is 

hosted in the Quick Access Toolbar. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

SmallImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Small. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for 

this control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip 

for this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this 

control. 

4.700   RibbonCheckBox (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ButtonBase > ToggleButton > CheckBox > RibbonCheckBox, IInputElement 

(usage) <RibbonCheckBox>x:Object</RibbonCheckBox> 

(description) Represents a check box that is used in a Ribbon control. 

[content property] Content 
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(usage) <RibbonCheckBox>x:Object</RibbonCheckBox> 

[name property] Name 

[xml lang property] Language 

(properties)  

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

CheckedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it is in the Checked state. 

CheckedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it is in the Checked state. 

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

FocusedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it has focus. 

FocusedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it has focus. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

Label x:String 

(description) The text that is displayed next to or below the control. 

LargeImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Large. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the 

control when the mouse pointer is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when the mouse pointer is over it. 
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(usage) <RibbonCheckBox>x:Object</RibbonCheckBox> 

PressedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it is pressed. 

PressedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it is pressed. 

QuickAccessToolBarControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control when it is 

hosted in the Quick Access Toolbar. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

SmallImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Small. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for 

this control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip 

for this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this 

control. 

4.701   RibbonComboBox (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > MenuBase > Menu > RibbonMenuButton > RibbonComboBox, IInputElement 
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(usage) <RibbonComboBox>x:Object*</RibbonComboBox> 

(description) Represents a combo box that is used in a Ribbon control. 

[content property] Items 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

IsEditable x:Boolean 

(description) A value that indicates whether the content of the combo box can be edited. 

IsReadOnly x:Boolean 

(description) A value that indicates whether selection-only mode is enabled, in which the 

contents of the combo box are selectable but not editable. 

SelectionBoxWidth x:Double 

(description) The width of the text box that displays the selected item in the combo box. 

StaysOpenOnEdit x:Boolean 

(description) A value that indicates whether a combo box that is open and displays a drop-down 

control will remain open when a user clicks the selection box. 

Text x:String 

(description) The text of the currently selected item. 

4.702   RibbonCommands (4.5) 

x:Object > RibbonCommands 

(usage) {x:Static RibbonCommands.StaticPropertyName} 

(description) Provides static access to standard ribbon 

commands. 

[is default constructible] false 

(static properties)  

AddToQuickAccessToolBarCommand RoutedUICommand 

(description) A reference to the AddToQuickAccessToolBar 

command. 

MaximizeRibbonCommand RoutedUICommand 

(description) A reference to the MaximizeRibbon command. 

MinimizeRibbonCommand RoutedUICommand 
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(usage) {x:Static RibbonCommands.StaticPropertyName} 

(description) A reference to the MinimizeRibbon command. 

RemoveFromQuickAccessToolBarCommand RoutedUICommand 

(description) A reference to the 

RemoveFromQuickAccessToolbar command. 

ShowQuickAccessToolBarAboveRibbonCommand RoutedUICommand 

(description) A reference to the 

ShowQuickAccessToolBarAboveRibbon command. 

ShowQuickAccessToolBarBelowRibbonCommand RoutedUICommand 

(description) A reference to the 

ShowQuickAccessToolBarBelowRibbon command. 

4.703   RibbonContentPresenter (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > ContentPresenter > 
RibbonContentPresenter, IInputElement 

(usage) <RibbonContentPresenter /> 

(description) Displays the content of a ribbon control. 

[name property] Name 

[xml lang property] Language 

(properties)  

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

4.704   RibbonContextMenu (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > MenuBase > ContextMenu > RibbonContextMenu, IInputElement 

(usage) <RibbonContextMenu>x:Object*</RibbonContextMenu> 

(description) Represents a menu that is displayed in the context of a particular control. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

4.705   RibbonContextualTabGroup (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
RibbonContextualTabGroup, IInputElement 
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(usage) <RibbonContextualTabGroup>x:Object</RibbonContextualTabGroup> 

(description) Represents a Ribbon tab group that dynamically displays controls that are 

only relevant in a particular context. 

(used by) Ribbon 

[content property] Header 

[name property] Name 

[xml lang property] Language 

(properties)  

Header x:Object 

(description) The content of the contextual tab group header. 

HeaderStringFormat x:String 

(description) The format that is used to display the header content as a string. 

HeaderTemplate DataTemplate 

(description) The DataTemplate that is used to display the contents of the header. 

HeaderTemplateSelector DataTemplateSelector 

(description) The custom logic for selecting a DataTemplate that is used to display the 

contents of the header. 

4.706   RibbonContextualTabGroupItemsControl (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > RibbonContextualTabGroupItemsControl, IInputElement 

(usage) <RibbonContextualTabGroupItemsControl>x:Object*</RibbonContextualTabGroupItemsContr

ol> 

(description

) 

Represents an items control that hosts contextual tab groups in a Ribbon. 

[content 

property] 

Items 

[name 

property] 

Name 

[xml lang 

property] 

Language 

4.707   RibbonControl (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > RibbonControl, IInputElement 
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(usage) <RibbonControl>x:Object</RibbonControl> 

(description) Represents a container for controls in a ribbon. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

4.708   RibbonControlGroup (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > RibbonControlGroup, IInputElement 

(usage) <RibbonControlGroup>x:Object*</RibbonControlGroup> 

(description) Groups a set of ribbon controls into a visual and conceptual unit. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

4.709   RibbonControlLength (4.5) 

x:Object > RibbonControlLength 

(usage) <RibbonControlLength> string </RibbonControlLength> 

(description) Represents widths in a RibbonControlSizeDefinition. 

(used by) RibbonControlSizeDefinition 

[is nullable] false 

[text syntax] RibbonControlLengthSyntax 

(static 

properties) 

 

Auto RibbonControlLength 

(description) A RibbonControlLength structure that represents the standard automatic sizing 
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(usage) <RibbonControlLength> string </RibbonControlLength> 

mode. 

4.710   RibbonControlLengthUnitType (4.5) 

x:Object > RibbonControlLengthUnitType 

(usage) Auto| Pixel| Item| Star 

(description) Defines constants that specify how elements in a Ribbon are sized. 

[is nullable] false 

[text syntax] RibbonControlLengthUnitTypeSyntax 

4.711   RibbonControlService (4.5) 

x:Object > RibbonControlService 

(usage) None. 

(description) Represents a service that 

provides properties and methods 

to control the display and 

behavior of Ribbon controls. 

[is default constructible] false 

(attachable properties)  

RibbonControlService.CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether 

this control can be added directly 

to the Quick Access Toolbar. 

[target type] DependencyObject 

RibbonControlService.CheckedBackground Brush 

(description) The brush that is used to draw 

the background of the control 

when it is in the Checked state. 

[target type] DependencyObject 

RibbonControlService.CheckedBorderBrush Brush 

(description) The brush that is used to draw 

the outer border of the control 

when it in the Checked state. 

[target type] DependencyObject 

RibbonControlService.ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition 
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(usage) None. 

for this control. 

[target type] DependencyObject 

RibbonControlService.CornerRadius CornerRadius 

(description) A value that indicates the 

amount that the corners of a 

ribbon button are rounded. 

[target type] DependencyObject 

RibbonControlService.DefaultControlSizeDefinition RibbonControlSizeDefinition 

(description) The default 

RibbonControlSizeDefinition for 

this control. 

[target type] DependencyObject 

RibbonControlService.FocusedBackground Brush 

(description) The brush that is used to draw 

the background of the control 

when it has focus. 

[target type] DependencyObject 

RibbonControlService.FocusedBorderBrush Brush 

(description) The brush that is used to draw 

the outer border of the control 

when it has focus. 

[target type] DependencyObject 

RibbonControlService.IsInControlGroup x:Boolean 

(description) A value that indicates whether 

the control is hosted in a 

RibbonControlGroup. 

[target type] DependencyObject 

RibbonControlService.IsInQuickAccessToolBar x:Boolean 

(description) A value that indicates whether 

the control is hosted in the Quick 

Access Toolbar. 

[target type] DependencyObject 

RibbonControlService.Label x:String 

(description) The text that is displayed next to 

or below the control. 

[target type] DependencyObject 
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(usage) None. 

RibbonControlService.LargeImageSource ImageSource 

(description) The image that is displayed on 

the control when the image size 

is set to Large. 

[target type] DependencyObject 

RibbonControlService.MouseOverBackground Brush 

(description) The brush that is used to draw 

the background of the control 

when the mouse pointer is over 

it. 

[target type] DependencyObject 

RibbonControlService.MouseOverBorderBrush Brush 

(description) The brush that is used to draw 

the outer border of the control 

when the mouse pointer is over 

it. 

[target type] DependencyObject 

RibbonControlService.PressedBackground Brush 

(description) The brush that is used to draw 

the background of the control 

when it is pressed. 

[target type] DependencyObject 

RibbonControlService.PressedBorderBrush Brush 

(description) The brush that is used to draw 

the outer border of the control 

when it is pressed. 

[target type] DependencyObject 

RibbonControlService.QuickAccessToolBarControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition 

for this control when it is hosted 

in the Quick Access Toolbar. 

[target type] DependencyObject 

RibbonControlService.QuickAccessToolBarId x:Object 

(description) A unique identifier that links a 

ribbon control to a corresponding 

control in the Quick Access 

Toolbar. 

[target type] DependencyObject 
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(usage) None. 

RibbonControlService.Ribbon Ribbon 

(description) A reference to the Ribbon that 

this control belongs to. 

[target type] DependencyObject 

RibbonControlService.ShowKeyboardCues x:Boolean 

(description) A value that indicates whether to 

show the keyboard focus visual 

for this control. 

[target type] DependencyObject 

RibbonControlService.SmallImageSource ImageSource 

(description) The image that is displayed on 

the control when the image size 

is set to Small. 

[target type] DependencyObject 

RibbonControlService.ToolTipDescription x:String 

(description) The descriptive text that is 

displayed in the ToolTip for this 

control. 

[target type] DependencyObject 

RibbonControlService.ToolTipFooterDescription x:String 

(description) The descriptive text that is 

displayed in the footer of the 

ToolTip for this control. 

[target type] DependencyObject 

RibbonControlService.ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in 

the footer of the ToolTip for this 

control. 

[target type] DependencyObject 

RibbonControlService.ToolTipFooterTitle x:String 

(description) The title text that is displayed in 

the footer of the ToolTip for this 

control. 

[target type] DependencyObject 

RibbonControlService.ToolTipImageSource ImageSource 

(description) The image that is displayed in 
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(usage) None. 

the ToolTip for this control. 

[target type] DependencyObject 

RibbonControlService.ToolTipTitle x:String 

(description) The title text that is displayed in 

the ToolTip for this control. 

[target type] DependencyObject 

(attachable events)  

RibbonControlService.DismissPopup Occurs when a ribbon popup is 

closed. 

4.712   RibbonControlSizeDefinition (4.5) 

x:Object > DependencyObject > Freezable > RibbonControlSizeDefinition 

(usage) <RibbonControlSizeDefinition /> 

(description) Specifies information about the size and visibility of the images and label associated 

with a Ribbon control. 

(used by) RibbonButton RibbonCheckBox RibbonContentPresenter RibbonControl 

RibbonControlGroup RibbonControlService RibbonControlSizeDefinitionCollection 

RibbonMenuButton RibbonRadioButton RibbonTextBox RibbonToggleButton 

(properties)  

ImageSize RibbonImageSize 

(description) A value that indicates how to show the image on a control. 

IsCollapsed x:Boolean 

(description) A value that indicates whether a control is collapsed. 

IsLabelVisible x:Boolean 

(description) A value that indicates whether the control's label is visible. 

MaxWidth RibbonControlLength 

(description) The maximum width constraint of a container control in a Ribbon. 

MinWidth RibbonControlLength 

(description) The minimum width constraint of a container control in a Ribbon. 

Width RibbonControlLength 

(description) The width of a container control in a Ribbon. 
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4.713   RibbonControlSizeDefinitionCollection (4.5) 

x:Object > DependencyObject > Freezable > Animatable > 
FreezableCollection(RibbonControlSizeDefinition) > RibbonControlSizeDefinitionCollection 

(usage) <RibbonControlSizeDefinitionCollection>RibbonControlSizeDefinition*</RibbonControlSizeDef

initionCollection> 

(descriptio

n) 

Represents a collection of RibbonControlSizeDefinition objects. 

(used by) RibbonGroupSizeDefinition 

[is list] true 

[allowed 

types] 

RibbonControlSizeDefinition 

4.714   RibbonDismissPopupMode (4.5) 

x:Object > RibbonDismissPopupMode 

(usage) Always| MousePhysicallyNotOver 

(description) Defines constants that specify whether the DismissPopup attached event closes all drop-

downs in a chain of drop-downs or only drop-downs that the mouse pointer is not over. 

[is nullable] false 

[text 

syntax] 

RibbonDismissPopupModeSyntax 

4.715   RibbonFilterMenuButton (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > MenuBase > Menu > RibbonMenuButton > RibbonFilterMenuButton, IInputElement 

(usage) <RibbonFilterMenuButton>x:Object*</RibbonFilterMenuButton> 

(description) Represents a button that opens a filter menu drop-down in a RibbonGallery. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

4.716   RibbonGallery (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > RibbonGallery, IInputElement 

(usage) <RibbonGallery>x:Object*</RibbonGallery> 

(description) Represents a menu that displays a set of related items or 

commands in a visually rich format that can be organized into 
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(usage) <RibbonGallery>x:Object*</RibbonGallery> 

multiple categorized subsets. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

AllFilterItemContainerStyle Style 

(description) The style that is applied to items in the filter when the "All" 

filter is selected. 

AllFilterItemTemplate DataTemplate 

(description) The DataTemplate that is used to display items in the filter 

when the "All" filter is selected. 

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

CanUserFilter x:Boolean 

(description) A value that indicates whether a user can apply a filter to 

gallery items. 

CategoryStyle Style 

(description) The style that is applied to the RibbonGalleryCategory 

element generated for each item. 

CategoryTemplate DataTemplate 

(description) The DataTemplate that is used to display each item in a 

RibbonGalleryCategory. 

ColumnsStretchToFill x:Boolean 

(description) A value that indicates that the gallery distributes all its 

available width equally between its columns. 

Command ICommand 

(description) The command that is associated with this ribbon gallery. 

CommandParameter x:Object 

(description) A user-defined data value to pass to the command. 

CommandTarget IInputElement 

(description) The element on which to invoke the specified command. 

FilterItemContainerStyle Style 
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(usage) <RibbonGallery>x:Object*</RibbonGallery> 

(description) The style that is applied to the filter items container 

generated from a RibbonGalleryCategory header. 

FilterItemContainerStyleSelector StyleSelector 

(description) The custom logic for selecting a Style that is applied to items 

in the filter when a custom filter is selected. 

FilterItemTemplate DataTemplate 

(description) The DataTemplate that is used to display items in the filter 

when a custom filter is selected. 

FilterItemTemplateSelector DataTemplateSelector 

(description) The custom logic for selecting a DataTemplate that is used to 

display items in the filter when a custom filter is selected. 

FilterMenuButtonStyle Style 

(description) The style that is applied to the filter menu button. 

FilterPaneContent x:Object 

(description) The contents of the filter pane. 

FilterPaneContentTemplate DataTemplate 

(description) The DataTemplate that is used to display the contents of the 

filter pane. 

GalleryItemStyle Style 

(description) The style that is applied to items in the RibbonGallery. 

GalleryItemTemplate DataTemplate 

(description) The DataTemplate that is used to display each item in a 

RibbonGallery. 

IsSharedColumnSizeScope x:Boolean 

(description) A value that specifies whether this gallery defines the scope 

used for uniform layout of items. 

IsSynchronizedWithCurrentItem x:Nullable(x:Boolean) 

(description) A value that indicates whether the gallery should keep the 

SelectedItem synchronized with the current item in the Items 

collection. 

MaxColumnCount x:Int32 

(description) A value that specifies the maximum number of columns used 

to layout items in a gallery ItemsPanel. 

MinColumnCount x:Int32 
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(usage) <RibbonGallery>x:Object*</RibbonGallery> 

(description) A value that specifies the minimum number of columns used 

to layout items in a gallery ItemsPanel. 

PreviewCommandParameter x:Object 

(description) A user-defined data value to pass to the command when it is 

previewed. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

SelectedItem x:Object 

(description) The currently selected item in the ribbon gallery. 

SelectedValue x:Object 

(description) The value of the property on the SelectedItem that is 

specified by the SelectedValuePath. 

SelectedValuePath x:String 

(description) The path that is used to get the SelectedValue of the 

SelectedItem in a RibbonGallery. 

SmallImageSource ImageSource 

(description) The image that is displayed on the control when the image 

size is set to Small. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for this 

control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip for 

this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 
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(usage) <RibbonGallery>x:Object*</RibbonGallery> 

(description) The title text that is displayed in the ToolTip for this control. 

(static properties)  

AllFilterItem x:Object 

(description) The filter that returns all items in a ribbon gallery. 

FilterCommand RoutedCommand 

(description) The command to invoke when the current gallery filter is 

changed by the user. 

(events)  

SelectionChanged Occurs when the SelectedItem property changes. 

4.717   RibbonGalleryCategory (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > RibbonGalleryCategory, IInputElement 

(usage) <RibbonGalleryCategory>x:Object*</RibbonGalleryCategory> 

(description) Represents a group of related items in a RibbonGallery. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

ColumnsStretchToFill x:Boolean 

(description) A value that indicates that the gallery category distributes all its available 

width equally between its columns. 

HeaderVisibility Visibility 

(description) The Visibility for the ribbon gallery header. 

IsSharedColumnSizeScope x:Boolean 

(description) A value that specifies whether this gallery category defines the scope 

used for uniform layout of items. 

MaxColumnCount x:Int32 

(description) A value that specifies the maximum number of columns used to lay out 

items in a gallery ItemsPanel. 

MinColumnCount x:Int32 

(description) A value that specifies the minimum number of columns used to lay out 

items in a gallery ItemsPanel. 



 

427 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

4.718   RibbonGalleryItem (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > RibbonGalleryItem, IInputElement 

(usage) <RibbonGalleryItem>x:Object</RibbonGalleryItem> 

(description) Represents an individual item of a RibbonGallery that is used in a Ribbon 

control. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

CheckedBackground Brush 

(description) The brush that is used to draw the background of the control when it is in 

the Checked state. 

CheckedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control when it is 

in the Checked state. 

IsSelected x:Boolean 

(description) A value that indicates whether this item is selected. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the control when the 

mouse pointer is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control when the 

mouse pointer is over it. 

PressedBackground Brush 

(description) The brush that is used to draw the background of the control when it is 

pressed. 

PressedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control when it is 

pressed. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for this control. 
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(usage) <RibbonGalleryItem>x:Object</RibbonGalleryItem> 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the ToolTip for this 

control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip for this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this control. 

(events)  

Selected Occurs when the IsSelected property of the item changes to true. 

Unselected Occurs when the IsSelected property of the item changes to false. 

4.719   RibbonGroup (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > RibbonGroup, IInputElement 

(usage) <RibbonGroup>x:Object*</RibbonGroup> 

(description) Represents a logical group of controls as they appear on a 

RibbonTab. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

GroupSizeDefinitions RibbonGroupSizeDefinitionBaseCollection 

(description) The RibbonGroupSizeDefinition collection for a ribbon group. 

IsDropDownOpen x:Boolean 

(description) A value that indicates whether the drop-down for the group is 
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(usage) <RibbonGroup>x:Object*</RibbonGroup> 

open. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

LargeImageSource ImageSource 

(description) The image that is displayed on the control when the image 

size is set to Large. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the control 

when the mouse pointer is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control 

when the mouse pointer is over it. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

SmallImageSource ImageSource 

(description) The image that is displayed on the control when the image 

size is set to Small. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for this 

control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip for 

this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this control. 
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4.720   RibbonGroupSizeDefinition (4.5) 

x:Object > DependencyObject > Freezable > RibbonGroupSizeDefinitionBase > 
RibbonGroupSizeDefinition 

(usage) <RibbonGroupSizeDefinition>RibbonControlSizeDefinition*</RibbonGroupSizeDefi

nition> 

(description) Specifies information about the size of controls in a RibbonGroup and the visual 

state of the group. 

[content property] ControlSizeDefinitions 

(properties)  

ControlSizeDefinitio

ns 

RibbonControlSizeDefinitionCollection 

(description) A collection of RibbonControlSizeDefinition items that specify the size of controls in 

the group. 

4.721   RibbonGroupSizeDefinitionBase (4.5) 

x:Object > DependencyObject > Freezable > RibbonGroupSizeDefinitionBase 

RibbonGroupSizeDefinition RibbonGroupTemplateSizeDefinition 

(usage) None. 

(description) Provides a base type for ribbon group definition types. 

(used by) RibbonGroupSizeDefinitionBaseCollection 

[is default constructible] false 

(properties)  

IsCollapsed x:Boolean 

(description) A value that indicates whether the control group is collapsed. 

4.722   RibbonGroupSizeDefinitionBaseCollection (4.5) 

x:Object > DependencyObject > Freezable > Animatable > 
FreezableCollection(RibbonGroupSizeDefinitionBase) > RibbonGroupSizeDefinitionBaseCollection 

(usage) <RibbonGroupSizeDefinitionBaseCollection>RibbonGroupSizeDefinitionBase*</RibbonGroupSi

zeDefinitionBaseCollection> 

(descripti

on) 

Provides a friendly name for XAML usage of a RibbonGroupSizeDefinition collection. 

(used by) RibbonGroup 

[is list] true 

[allowed RibbonGroupSizeDefinitionBase 
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(usage) <RibbonGroupSizeDefinitionBaseCollection>RibbonGroupSizeDefinitionBase*</RibbonGroupSi

zeDefinitionBaseCollection> 

types] 

4.723   RibbonGroupTemplateSizeDefinition (4.5) 

x:Object > DependencyObject > Freezable > RibbonGroupSizeDefinitionBase > 
RibbonGroupTemplateSizeDefinition 

(usage) <RibbonGroupTemplateSizeDefinition>DataTemplate</RibbonGroupTemplateSizeDefiniti

on> 

(description) Provides a default content template for a RibbonGroup. 

[content 

property] 

ContentTemplate 

(properties)  

ContentTemplat

e 

DataTemplate 

(description) The DataTemplate that is used to display a RibbonGroup. 

4.724   RibbonImageSize (4.5) 

x:Object > RibbonImageSize 

(usage) Collapsed| Small| Large 

(description) Defines constants that specify how images are shown on Ribbon controls. 

(used by) RibbonControlSizeDefinition 

[is nullable] false 

[text syntax] RibbonImageSizeSyntax 

4.725   RibbonMenuButton (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > MenuBase > Menu > RibbonMenuButton, IInputElement 

RibbonApplicationMenu RibbonComboBox RibbonFilterMenuButton RibbonSplitButton 

(usage) <RibbonMenuButton>x:Object*</RibbonMenuButton> 

(description) Represents a button on the ribbon that displays a drop-

down menu when clicked. 

(used by) RibbonQuickAccessToolBar 

[content property] Items 

[name property] Name 
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RibbonApplicationMenu RibbonComboBox RibbonFilterMenuButton RibbonSplitButton 

[xml lang property] Language 

(properties)  

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

CanUserResizeHorizontally x:Boolean 

(description) A value that indicates whether the user can resize the 

drop-down horizontally. 

CanUserResizeVertically x:Boolean 

(description) A value that indicates whether the user can resize the 

drop-down vertically. 

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

DropDownHeight x:Double 

(description) The height of the drop-down. 

FocusedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it has focus. 

FocusedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it has focus. 

IsDropDownOpen x:Boolean 

(description) A value that indicates whether the drop-down is open. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

Label x:String 

(description) The text that is displayed next to or below the control. 

LargeImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Large. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the 

control when the mouse pointer is over it. 
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RibbonApplicationMenu RibbonComboBox RibbonFilterMenuButton RibbonSplitButton 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when the mouse pointer is over it. 

PressedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it is pressed. 

PressedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it is pressed. 

QuickAccessToolBarControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control when it is 

hosted in the Quick Access Toolbar. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

SmallImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Small. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for 

this control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip 

for this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this 

control. 
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RibbonApplicationMenu RibbonComboBox RibbonFilterMenuButton RibbonSplitButton 

(events)  

DropDownClosed Occurs when the drop-down is closed. 

DropDownOpened Occurs when the drop-down is opened. 

4.726   RibbonMenuItem (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > MenuItem > RibbonMenuItem, IInputElement 

RibbonApplicationMenuItem RibbonSplitMenuItem 

(usage) <RibbonMenuItem>x:Object*</RibbonMenuItem> 

(description) Represents a menu item inside a Ribbon menu control. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

CanUserResizeHorizontally x:Boolean 

(description) A value that indicates whether the user can resize the drop-

down horizontally. 

CanUserResizeVertically x:Boolean 

(description) A value that indicates whether the user can resize the drop-

down vertically. 

CheckedBackground Brush 

(description) The brush that is used to draw the background of the control 

when it is in the Checked state. 

CheckedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control 

when it is in the Checked state. 

DropDownHeight x:Double 

(description) The height of the drop-down. 

ImageSource ImageSource 

(description) The image that is displayed on the control. 
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RibbonApplicationMenuItem RibbonSplitMenuItem 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the control 

when the mouse pointer is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control 

when the mouse pointer is over it. 

PressedBackground Brush 

(description) The brush that is used to draw the background of the control 

when it is pressed. 

PressedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control 

when it is pressed. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

QuickAccessToolBarImageSource ImageSource 

(description) The image that is displayed on the control when it is hosted 

in the Quick Access Toolbar. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for this 

control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip for 

this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 
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RibbonApplicationMenuItem RibbonSplitMenuItem 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this control. 

4.727   RibbonQuickAccessToolBar (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > RibbonQuickAccessToolBar, IInputElement 

(usage) <RibbonQuickAccessToolBar>x:Object*</RibbonQuickAccessToolBar> 

(description) Represents a ribbon toolbar that is always visible in the window 

frame to provide access to common commands. 

(used by) Ribbon 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

CustomizeMenuButton RibbonMenuButton 

(description) A RibbonMenuButton that is used to show the Quick Access Toolbar 

customization menu. 

IsOverflowOpen x:Boolean 

(description) A value that indicates whether the Quick Access Toolbar overflow 

menu is open. 

(attachable events)  

RibbonQuickAccessToolBar.Clone Occurs when an element in the Quick Access Toolbar is cloned. 

4.728   RibbonRadioButton (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ButtonBase > ToggleButton > RadioButton > RibbonRadioButton, IInputElement 

(usage) <RibbonRadioButton>x:Object</RibbonRadioButton> 

(description) Represents a radio button that is used in a Ribbon 

control. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  
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(usage) <RibbonRadioButton>x:Object</RibbonRadioButton> 

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

CheckedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it is in the Checked state. 

CheckedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it is in the Checked state. 

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

CornerRadius CornerRadius 

(description) A value that indicates the amount that the corners of a 

ribbon button are rounded. 

FocusedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it has focus. 

FocusedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it has focus. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

Label x:String 

(description) The text that is displayed next to or below the control. 

LargeImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Large. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the 

control when the mouse pointer is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when the mouse pointer is over it. 

PressedBackground Brush 
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(usage) <RibbonRadioButton>x:Object</RibbonRadioButton> 

(description) The brush that is used to draw the background of the 

control when it is pressed. 

PressedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it is pressed. 

QuickAccessToolBarControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control when it is 

hosted in the Quick Access Toolbar. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

SmallImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Small. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for 

this control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip 

for this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this 

control. 

4.729   RibbonSeparator (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > Separator > 

RibbonSeparator, IInputElement 
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(usage) <RibbonSeparator /> 

(description) Represents a control that provides a divider and optional label between elements in 

a Ribbon menu or RibbonGallery. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Label x:String 

(description) The text that is displayed with the visual separator line. 

4.730   RibbonSplitButton (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > MenuBase > Menu > RibbonMenuButton > RibbonSplitButton, IInputElement 

(usage) <RibbonSplitButton>x:Object*</RibbonSplitButton> 

(description) Represents a composite control that has a primary button 

that responds to a Click event and a secondary button that 

displays a drop-down list of mutually exclusive values. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

CheckedBackground Brush 

(description) The brush that is used to draw the background of the control 

when it is in the Checked state. 

CheckedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control 

when it is in the Checked state. 

Command ICommand 

(description) The command that is associated with this control. 

CommandParameter x:Object 

(description) A user-defined data value to pass to the command. 

CommandTarget IInputElement 

(description) The element on which to raise the specified command. 

DropDownToolTipDescription x:String 
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(usage) <RibbonSplitButton>x:Object*</RibbonSplitButton> 

(description) The descriptive text that is displayed in the ToolTip for the 

drop-down area of this control. 

DropDownToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for the drop-down area of this control. 

DropDownToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for the 

drop-down area of this control. 

DropDownToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip for 

the drop-down area of this control. 

DropDownToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for the drop-down 

area of this control. 

DropDownToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for the drop-

down area of this control. 

HeaderKeyTip x:String 

(description) The keyboard shortcut for the header area of this control. 

HeaderQuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

IsCheckable x:Boolean 

(description) A value that indicates whether a user can check and uncheck 

the button. 

IsChecked x:Boolean 

(description) A value that indicates whether the button is checked. 

LabelPosition RibbonSplitButtonLabelPosition 

(description) A value that indicates the relative position of the label for this 

control. 

(events)  

Click Occurs when the button is clicked. 

4.731   RibbonSplitButtonLabelPosition (4.5) 

x:Object > RibbonSplitButtonLabelPosition 
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(usage) Header| DropDown 

(description) Provides values that indicate the position of the label of a RibbonSplitButton. 

(used by) RibbonSplitButton 

[is nullable] false 

[text syntax] RibbonSplitButtonLabelPositionSyntax 

4.732   RibbonSplitMenuItem (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > MenuItem > RibbonMenuItem > RibbonSplitMenuItem, 
IInputElement 

RibbonApplicationSplitMenuItem 

(usage) <RibbonSplitMenuItem>x:Object*</RibbonSplitMenuItem> 

(description) Represents a menu item inside a Ribbon menu that can 

invoke a command and also display a submenu. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

DropDownToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for the 

drop-down area of this control. 

DropDownToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for the drop-down area of this control. 

DropDownToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for the 

drop-down area of this control. 

DropDownToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip for 

the drop-down area of this control. 

DropDownToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for the drop-down 

area of this control. 

DropDownToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for the drop-
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RibbonApplicationSplitMenuItem 

down area of this control. 

HeaderKeyTip x:String 

(description) The keyboard shortcut for the header area of this control. 

HeaderQuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

4.733   RibbonTab (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > RibbonTab, IInputElement 

(usage) <RibbonTab>x:Object*</RibbonTab> 

(description) Represents a tab in a Ribbon. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

ContextualTabGroupHeader x:Object 

(description) The header content of the RibbonContextualTabGroup that this tab is in. 

GroupSizeReductionOrder StringCollection 

(description) A collection of RibbonGroup names that specify the order in which group 

size definitions are applied as the ribbon is reduced in size. 

[text syntax] StringCollectionSyntax 

HeaderStyle Style 

(description) The style that is applied to the header of the ribbon tab. 

IsSelected x:Boolean 

(description) A value that indicates whether the ribbon tab is selected. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

4.734   RibbonTabHeader (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > RibbonTabHeader, IInputElement 
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(usage) <RibbonTabHeader>x:Object</RibbonTabHeader> 

(description) Represents the header of a RibbonTab control. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

CheckedBackground Brush 

(description) The brush that is used to draw the background of the control when it is in the 

Checked state. 

CheckedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control when it is in 

the Checked state. 

FocusedBackground Brush 

(description) The brush that is used to draw the background of the control when it has 

focus. 

FocusedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control when it has 

focus. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the control when the 

mouse is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the control when the 

mouse is over it. 

4.735   RibbonTabHeaderItemsControl (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > RibbonTabHeaderItemsControl, IInputElement 

(usage) <RibbonTabHeaderItemsControl>x:Object*</RibbonTabHeaderItemsControl> 

(description) Represents an items control that hosts RibbonTabHeader items. 

[content property] Items 

[name property] Name 

[xml lang property] Language 
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4.736   RibbonTextBox (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
TextBoxBase > TextBox > RibbonTextBox, IInputElement 

(usage) <RibbonTextBox>x:String</RibbonTextBox> 

(description) Represents a text box that is used in a Ribbon control. 

[content property] Text 

[name property] Name 

[xml lang property] Language 

(properties)  

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

Command ICommand 

(description) The command that is associated with this control. 

CommandParameter x:Object 

(description) A user defined data value to pass to the command. 

CommandTarget IInputElement 

(description) The element on which to raise the specified command. 

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

FocusedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it has focus. 

FocusedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it has focus. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

Label x:String 

(description) The text that is displayed next to or below the control. 

LargeImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Large. 
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(usage) <RibbonTextBox>x:String</RibbonTextBox> 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the 

control when the mouse pointer is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when the mouse pointer is over it. 

QuickAccessToolBarControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control when it is 

hosted in the Quick Access Toolbar. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

SmallImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Small. 

TextBoxWidth x:Double 

(description) The width of the control. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for 

this control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip 

for this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this 

control. 
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4.737   RibbonToggleButton (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ButtonBase > ToggleButton > RibbonToggleButton, IInputElement 

(usage) <RibbonToggleButton>x:Object</RibbonToggleButton> 

(description) Represents a toggle button that is used in a Ribbon 

control. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

CanAddToQuickAccessToolBarDirectly x:Boolean 

(description) A value that indicates whether this control can be added 

directly to the Quick Access Toolbar. 

CheckedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it is in the Checked state. 

CheckedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it is in the Checked state. 

ControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control. 

CornerRadius CornerRadius 

(description) A value that indicates the amount that the corners of a 

ribbon button are rounded. 

FocusedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it has focus. 

FocusedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it has focus. 

KeyTip x:String 

(description) The keyboard shortcut for the control. 

Label x:String 

(description) The text that is displayed next to or below the control. 
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(usage) <RibbonToggleButton>x:Object</RibbonToggleButton> 

LargeImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Large. 

MouseOverBackground Brush 

(description) The brush that is used to draw the background of the 

control when the mouse pointer is over it. 

MouseOverBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when the mouse pointer is over it. 

PressedBackground Brush 

(description) The brush that is used to draw the background of the 

control when it is pressed. 

PressedBorderBrush Brush 

(description) The brush that is used to draw the outer border of the 

control when it is pressed. 

QuickAccessToolBarControlSizeDefinition RibbonControlSizeDefinition 

(description) The RibbonControlSizeDefinition for this control when it is 

hosted in the Quick Access Toolbar. 

QuickAccessToolBarId x:Object 

(description) A unique identifier that links a ribbon control to a 

corresponding control in the Quick Access Toolbar. 

SmallImageSource ImageSource 

(description) The image that is displayed on the control when the 

image size is set to Small. 

ToolTipDescription x:String 

(description) The descriptive text that is displayed in the ToolTip for 

this control. 

ToolTipFooterDescription x:String 

(description) The descriptive text that is displayed in the footer of the 

ToolTip for this control. 

ToolTipFooterImageSource ImageSource 

(description) The image that is displayed in the footer of the ToolTip for 

this control. 

ToolTipFooterTitle x:String 

(description) The title text that is displayed in the footer of the ToolTip 
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(usage) <RibbonToggleButton>x:Object</RibbonToggleButton> 

for this control. 

ToolTipImageSource ImageSource 

(description) The image that is displayed in the ToolTip for this control. 

ToolTipTitle x:String 

(description) The title text that is displayed in the ToolTip for this 

control. 

4.738   RibbonToolTip (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ToolTip > RibbonToolTip, IInputElement 

(usage) <RibbonToolTip>x:Object</RibbonToolTip> 

(description) Represents a control that creates a pop-up window to display information about 

an element in the Ribbon. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

Description x:String 

(description) The descriptive text that is displayed for the control that is associated with this 

ToolTip. 

FooterDescription x:String 

(description) The descriptive text that is displayed in the ToolTip footer for the control that is 

associated with this ToolTip. 

FooterImageSource ImageSource 

(description) The image that is displayed in the ToolTip footer for the control that is associated 

with this ToolTip. 

FooterTitle x:String 

(description) The title text that is displayed in the ToolTip footer for the control that is 

associated with this ToolTip. 

ImageSource ImageSource 

(description) The image that is displayed for the control that is associated with this ToolTip. 

Title x:String 

(description) The title text that is displayed for the control that is associated with this ToolTip. 
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4.739   RibbonTwoLineText (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
RibbonTwoLineText, IInputElement 

(usage) <RibbonTwoLineText /> 

(description) Represents a specialized label that can display its contents on one 

or two lines, with an optional shape displayed inline with the text. 

[name property] Name 

[xml lang property] Language 

(properties)  

BaselineOffset x:Double 

(description) The amount by which each line of text is offset from the baseline. 

LineHeight x:Double 

(description) The height of each line of content. 

[text syntax] LengthSyntax 

LineStackingStrategy LineStackingStrategy 

(description) The mechanism by which the line box is determined for each line 

of content. 

Padding Thickness 

(description) The thickness of the space between the boundaries of the content 

area and the displayed content. 

PathFill Brush 

(description) The brush that is used to draw the inside of the shape that is 

displayed with the label. 

PathStroke Brush 

(description) The brush that is used to draw the outline of the shape that is 

displayed with the label. 

Text x:String 

(description) The text content in this element. 

TextAlignment TextAlignment 

(description) A value that indicates the horizontal alignment of text content in 

this element. 

TextDecorations TextDecorationCollection 

(description) A TextDecorationCollection that contains the effects to apply to 

the text content in this element. 
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(usage) <RibbonTwoLineText /> 

TextEffects TextEffectCollection 

(description) The effects to apply to the text content in this element. 

TextTrimming TextTrimming 

(description) The text trimming behavior to use when content overflows the 

content area. 

(attachable properties)  

RibbonTwoLineText.HasTwoLines x:Boolean 

(description) A value that indicates whether this control layout can extend to 

two lines or if it is restricted to one line. 

[target type] DependencyObject 

RibbonTwoLineText.PathData Geometry 

(description) The geometry data that defines the shape that is displayed with 

the label. 

[target type] DependencyObject 

4.740   RibbonWindow (4.5) 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > Window > RibbonWindow, IInputElement 

(usage) <RibbonWindow>x:Object</RibbonWindow> 

(description) Represents a window that can draw a Ribbon Quick Access Toolbar and contextual 

tab groups in its border. 

[content 

property] 

Content 

[name property] Name 

[xml lang 

property] 

Language 

4.741   RichTextBox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
TextBoxBase > RichTextBox, IInputElement 

(usage) <RichTextBox>FlowDocument</RichTextBox> 

(description) Represents a rich editing control which operates on FlowDocument objects. 

[content property] Document 

[name property] Name 
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(usage) <RichTextBox>FlowDocument</RichTextBox> 

[xml lang property] Language 

(properties)  

Document FlowDocument 

(description) The FlowDocument that represents the contents of the RichTextBox. 

IsDocumentEnabled x:Boolean 

(description) A value that indicates whether the user can interact with UIElement and 

ContentElement objects within the RichTextBox. 

4.742   RotateTransform 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform > Transform > 

RotateTransform 

(usage) <RotateTransform> string </RotateTransform> 

(description) Rotates an object clockwise about a specified point in a 2-D x-y coordinate system. 

[text syntax] TransformSyntax 

(properties)  

Angle x:Double 

(description) The angle, in degrees, of clockwise rotation. 

CenterX x:Double 

(description) The x-coordinate of the rotation center point. 

CenterY x:Double 

(description) The y-coordinate of the rotation center point. 

4.743   RotateTransform3D 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > Transform3D > 
AffineTransform3D > RotateTransform3D 

(usage) <RotateTransform3D /> 

(description) Specifies a rotation transformation. 

(properties)  

CenterX x:Double 

(description) The X coordinate of the Point3D about which to rotate. 

CenterY x:Double 
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(usage) <RotateTransform3D /> 

(description) The Y coordinate of the Point3D about which to rotate. 

CenterZ x:Double 

(description) The Z coordinate of the Point3D about which to rotate. 

Rotation Rotation3D 

(description) A Rotation3D that specifies the rotation. 

4.744   Rotation 

x:Object > Rotation 

(usage) Rotate0| Rotate90| Rotate180| Rotate270 

(description) Specifies the rotation to apply to a bitmap image. 

(used by) BitmapImage JpegBitmapEncoder WmpBitmapEncoder 

[is nullable] false 

[text syntax] RotationSyntax 

4.745   Rotation3D 

x:Object > DependencyObject > Freezable > Animatable > Rotation3D 

AxisAngleRotation3D QuaternionRotation3D 

(usage) {x:Static Rotation3D.StaticPropertyName} 

(description) Specifies the 3-D rotation to be used in a transformation. 

(used by) RotateTransform3D Rotation3DAnimation Rotation3DKeyFrame 

[is default constructible] false 

(static properties)  

Identity Rotation3D 

(description) Singleton identity Rotation3D. 

4.746   Rotation3DAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

Rotation3DAnimationBase > Rotation3DAnimation 

(usage) <Rotation3DAnimation /> 

(description) Animates the value of a Rotation3D property using linear interpolation between two 

values determined by the combination of From, To, or By properties that are set for 

the animation. 
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(usage) <Rotation3DAnimation /> 

[name 

property] 

Name 

(properties)  

By Rotation3D 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From Rotation3D 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To Rotation3D 

(description) The animation's ending value. 

4.747   Rotation3DAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

Rotation3DAnimationBase 

Rotation3DAnimation Rotation3DAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Rotation3D value. 

[is default constructible] false 

[name property] Name 

4.748   Rotation3DAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Rotation3DAnimationBase > Rotation3DAnimationUsingKeyFrames 

(usage) <Rotation3DAnimationUsingKeyFrames>Rotation3DKeyFrame*</Rotation3DAnimationUsingK

eyFrames> 

(descriptio

n) 

Animates the value of a Rotation3D property along a set of KeyFrames. 
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(usage) <Rotation3DAnimationUsingKeyFrames>Rotation3DKeyFrame*</Rotation3DAnimationUsingK

eyFrames> 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties

) 

 

IsAdditive x:Boolean 

(descriptio

n) 

A value that specifies whether the animation's output value is added to the base value of the 

property being animated. 

IsCumulati

ve 

x:Boolean 

(descriptio

n) 

A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames Rotation3DKeyFrameCollection 

(descriptio

n) 

The collection of Rotation3DKeyFrame objects that define the animation. 

4.749   Rotation3DKeyFrame 

x:Object > DependencyObject > Freezable > Rotation3DKeyFrame 

DiscreteRotation3DKeyFrame EasingRotation3DKeyFrame LinearRotation3DKeyFrame 

SplineRotation3DKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a Rotation3DAnimationUsingKeyFrames. 

(used by) Rotation3DKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value Rotation3D 

(description) The key frame's target value. 

4.750   Rotation3DKeyFrameCollection 

x:Object > DependencyObject > Freezable > Rotation3DKeyFrameCollection 
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(usage) <Rotation3DKeyFrameCollection>Rotation3DKeyFrame*</Rotation3DKeyFrameCollection> 

(description) Represents a collection of Rotation3DKeyFrame objects. 

(used by) Rotation3DAnimationUsingKeyFrames 

[is list] true 

[allowed 

types] 

Rotation3DKeyFrame 

(static 

properties) 

 

Empty Rotation3DKeyFrameCollection 

(description) An empty Rotation3DKeyFrameCollection. 

4.751   RoutedCommand 

x:Object > RoutedCommand 

RoutedUICommand 

(usage) <RoutedCommand> string </RoutedCommand> 

(description) Defines a command that implements ICommand and is routed through the 

element tree. 

[text syntax] CommandSyntax 

(properties)  

InputGestures InputGestureCollection 

(description) The collection of InputGesture objects that are associated with this command. 

[read only] true 

(events)  

CanExecuteChanged Occurs when changes to the command source are detected by the command 

manager. These changes often affect whether the command should execute on 

the current command target. 

4.752   RoutedEvent 

x:Object > RoutedEvent 

(usage) <RoutedEvent> string </RoutedEvent> 

(description) Represents and identifies a routed event and declares its characteristics. 

(used by) EventSetter EventTrigger 

[is default constructible] false 
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(usage) <RoutedEvent> string </RoutedEvent> 

[text syntax] RoutedEventSyntax 

4.753   RoutedEventHandlerInfo 

x:Object > RoutedEventHandlerInfo 

(usage) <RoutedEventHandlerInfo /> 

(description) Provides special handling information to inform event listeners whether specific handlers 

should be invoked. 

[is nullable] false 

4.754   RoutedUICommand 

x:Object > RoutedCommand > RoutedUICommand 

(usage) <RoutedUICommand> string </RoutedUICommand> 

(description) Defines an ICommand that is routed through the element tree and contains a text 

property. 

[text syntax] CommandSyntax 

(properties)  

Text x:String 

(description) The text that describes this command. 

4.755   RoutingStrategy 

x:Object > RoutingStrategy 

(usage) Tunnel| Bubble| Direct 

(description) Indicates the routing strategy of a routed event. 

[is nullable] false 

[text syntax] RoutingStrategySyntax 

4.756   RowDefinition 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > DefinitionBase > 
RowDefinition, IInputElement 

(usage) <RowDefinition /> 

(description) Defines row-specific properties that apply to Grid elements. 

(used by) RowDefinitionCollection 



 

457 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <RowDefinition /> 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Height GridLength 

(description) The calculated height of a RowDefinition element, or sets the GridLength value of a 

row that is defined by the RowDefinition. 

MaxHeight x:Double 

(description) A value that represents the maximum height of a RowDefinition. 

[text syntax] LengthSyntax 

MinHeight x:Double 

(description) A value that represents the minimum allowable height of a RowDefinition. 

[text syntax] LengthSyntax 

4.757   RowDefinitionCollection 

x:Object > RowDefinitionCollection 

(usage) None. 

(description) Provides access to an ordered, strongly typed collection of RowDefinition 

objects. 

(used by) Grid 

[is default 

constructible] 

false 

[is list] true 

[allowed types] RowDefinition 

4.758   Run 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 

Inline > Run, IInputElement 

(usage) <Run>x:String</Run> 

(description) An inline-level flow content element intended to contain a run of formatted or 

unformatted text. 

[content 

property] 

Text 
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(usage) <Run>x:String</Run> 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Text x:String 

(description) The unformatted text contents of this text Run. 

4.759   SamplingMode 

x:Object > SamplingMode 

(usage) NearestNeighbor| Bilinear| Auto 

(description) Indicates the way Brush-valued properties are sampled in a custom shader effect. 

[is nullable] false 

[text syntax] SamplingModeSyntax 

4.760   ScaleTransform 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform > Transform > 
ScaleTransform 

(usage) <ScaleTransform> string </ScaleTransform> 

(description) Scales an object in the 2-D x-y coordinate system. 

[text syntax] TransformSyntax 

(properties)  

CenterX x:Double 

(description) The x-coordinate of the center point of this ScaleTransform. 

CenterY x:Double 

(description) The y-coordinate of the center point of this ScaleTransform. 

ScaleX x:Double 

(description) The x-axis scale factor. 

ScaleY x:Double 

(description) The y-axis scale factor. 
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4.761   ScaleTransform3D 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > Transform3D > 
AffineTransform3D > ScaleTransform3D 

(usage) <ScaleTransform3D /> 

(description) Scales an object in the three-dimensional x-y-z plane, starting from a defined center 

point. Scale factors are defined in x-, y-, and z- directions from this center point. 

(properties)  

CenterX x:Double 

(description) The x-coordinate of the transform's center point. 

CenterY x:Double 

(description) The z-coordinate of the transform's center point. 

CenterZ x:Double 

(description) The z-coordinate of the transform's center point. 

ScaleX x:Double 

(description) The scale factor in the x-direction. 

ScaleY x:Double 

(description) The scale factor in the y-direction. 

ScaleZ x:Double 

(description) The scale factor in the z-direction. 

4.762   ScrollBar 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > RangeBase 
> ScrollBar, IInputElement 

(usage) <ScrollBar /> 

(description) Represents a control that provides a scroll bar that has a sliding Thumb whose 

position corresponds to a value. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Orientation Orientation 

(description) Whether the ScrollBar is displayed horizontally or vertically. 

ViewportSize x:Double 
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(usage) <ScrollBar /> 

(description) The amount of the scrollable content that is currently visible. 

(events)  

Scroll Occurs one or more times as content scrolls in a ScrollBar when the user moves the 

Thumb by using the mouse. 

4.763   ScrollBarVisibility 

x:Object > ScrollBarVisibility 

(usage) Disabled| Auto| Hidden| Visible 

(description) Specifies the visibility of a ScrollBar for scrollable content. 

(used by) DataGrid FlowDocumentScrollViewer ScrollViewer TextBoxBase 

[is nullable] false 

[text syntax] ScrollBarVisibilitySyntax 

4.764   ScrollContentPresenter 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > ContentPresenter > 

ScrollContentPresenter, IInputElement 

(usage) <ScrollContentPresenter /> 

(description) Displays the content of a ScrollViewer control. 

[name property] Name 

[xml lang property] Language 

(properties)  

CanContentScroll x:Boolean 

(description) Indicates whether the content, if it supports IScrollInfo, should be allowed to 

control scrolling. 

CanHorizontallyScroll x:Boolean 

(description) A value that indicates whether scrolling on the horizontal axis is possible. 

CanVerticallyScroll x:Boolean 

(description) A value that indicates whether scrolling on the vertical axis is possible. 

ScrollOwner ScrollViewer 

(description) A ScrollViewer element that controls scrolling behavior. 
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4.765   ScrollEventType 

x:Object > ScrollEventType 

(usage) EndScroll| First| LargeDecrement| LargeIncrement| Last| SmallDecrement| 

SmallIncrement| ThumbPosition| ThumbTrack... 

(description) Describes the behavior that caused a Scroll event for a ScrollBar control. 

[is nullable] false 

[text 

syntax] 

ScrollEventTypeSyntax 

4.766   ScrollUnit (4.5) 

x:Object > ScrollUnit 

(usage) Pixel| Item 

(description) Specifies the type of unit that is used by the ScrollUnit attached property. 

(used by) VirtualizingPanel 

[is nullable] false 

[text syntax] ScrollUnitSyntax 

4.767   ScrollViewer 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > ScrollViewer, IInputElement 

(usage) <ScrollViewer>x:Object</ScrollViewer> 

(description) Represents a scrollable area that can contain other visible 

elements. 

(used by) IScrollInfo ScrollContentPresenter StackPanel 

VirtualizingStackPanel 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

CanContentScroll x:Boolean 

(description) A value that indicates whether elements that support the 

IScrollInfo interface are allowed to scroll. 

HorizontalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates whether a horizontal ScrollBar 
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(usage) <ScrollViewer>x:Object</ScrollViewer> 

should be displayed. 

IsDeferredScrollingEnabled x:Boolean 

(description) A value that indicates whether the content is stationary 

when the user drags the Thumb of a ScrollBar. 

PanningDeceleration x:Double 

(description) The rate ScrollViewer slows in device-independent units 

(1/96th inch per unit) per squared millisecond when in 

inertia. 

PanningMode PanningMode 

(description) The way ScrollViewer reacts to touch manipulation. 

PanningRatio x:Double 

(description) The ratio of scrolling offset to translate manipulation 

offset. 

VerticalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates whether a vertical ScrollBar should 

be displayed. 

(attachable properties)  

ScrollViewer.CanContentScroll x:Boolean 

(description) A value that indicates whether elements that support the 

IScrollInfo interface are allowed to scroll. 

[target type] DependencyObject 

ScrollViewer.HorizontalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates whether a horizontal ScrollBar 

should be displayed. 

[target type] DependencyObject 

ScrollViewer.IsDeferredScrollingEnabled x:Boolean 

(description) A value that indicates whether the content is stationary 

when the user drags the Thumb of a ScrollBar. 

[target type] DependencyObject 

ScrollViewer.PanningDeceleration x:Double 

(description) The rate ScrollViewer slows in device-independent units 

(1/96th inch per unit) per squared millisecond when in 

inertia. 

[target type] DependencyObject 

ScrollViewer.PanningMode PanningMode 
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(usage) <ScrollViewer>x:Object</ScrollViewer> 

(description) The way ScrollViewer reacts to touch manipulation. 

[target type] DependencyObject 

ScrollViewer.PanningRatio x:Double 

(description) The ratio of scrolling offset to translate manipulation 

offset. 

[target type] DependencyObject 

ScrollViewer.VerticalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates whether a vertical ScrollBar should 

be displayed. 

[target type] DependencyObject 

(events)  

ScrollChanged Occurs when changes are detected to the scroll position, 

extent, or viewport size. 

4.768   Section 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Block > Section, IInputElement 

(usage) <Section>Block*</Section> 

(description) A block-level flow content element used for grouping other 

Block elements. 

[content property] Blocks 

[name property] Name 

[xml lang property] Language 

(properties)  

Blocks BlockCollection 

(description) A BlockCollection containing the top-level Block elements that 

comprise the contents of the Section. 

[read only] true 

HasTrailingParagraphBreakOnPaste x:Boolean 

(description) A value that indicates whether or not a trailing paragraph break 

should be inserted after the last paragraph when placing the 

contents of a root Section element on the clipboard. 
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4.769   SeekStoryboard 

x:Object > DependencyObject > TriggerAction > ControllableStoryboardAction > SeekStoryboard 

(usage) <SeekStoryboard /> 

(description) A trigger action that provides functionality for seeking (skipping) to a specified time 

within the active period of a Storyboard. 

(properties)  

Offset x:TimeSpan 

(description) The amount by which the storyboard should move forward or backward from the seek 

origin Origin. 

Origin TimeSeekOrigin 

(description) The position from which this seek operation's Offset is applied. 

4.770   SelectedDatesCollection 

x:Object > ObservableCollection(x:DateTime) > SelectedDatesCollection 

(usage) None. 

(description) Represents a set of selected dates in a Calendar. 

(used by) Calendar 

[is default constructible] false 

[is list] true 

[allowed types] x:DateTime 

4.771   SelectionMode 

x:Object > SelectionMode 

(usage) Single| Multiple| Extended 

(description) Defines the selection behavior for a ListBox. 

(used by) ListBox 

[is nullable] false 

[text syntax] SelectionModeSyntax 

4.772   SelectiveScrollingGrid 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > Grid > 
SelectiveScrollingGrid, IInputElement 
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(usage) <SelectiveScrollingGrid>UIElement*</SelectiveScrollin

gGrid> 

(description) A panel that can hold specified cells in place when the 

view is scrolled. 

[content property] Children 

[name property] Name 

[xml lang property] Language 

(attachable properties)  

SelectiveScrollingGrid.SelectiveScrollingOrien

tation 

SelectiveScrollingOrientation 

(description) The direction that cells can scroll. 

[target type] DependencyObject 

4.773   SelectiveScrollingOrientation 

x:Object > SelectiveScrollingOrientation 

(usage) None| Horizontal| Vertical| Both 

(description) Specifies the direction that SelectiveScrollingGrid panels can scroll. 

(used by) SelectiveScrollingGrid 

[is nullable] false 

[text syntax] SelectiveScrollingOrientationSyntax 

4.774   Selector 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ItemsControl > Selector, IInputElement 

ComboBox ListBox MultiSelector Ribbon TabControl 

(usage) None. 

(description) Represents a control that allows a user to select items from among 

its child elements. 

[is default constructible] false 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  
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ComboBox ListBox MultiSelector Ribbon TabControl 

IsSynchronizedWithCurrentItem x:Nullable(x:Boolean) 

(description) A value that indicates whether a Selector should keep the 

SelectedItem synchronized with the current item in the Items 

property. 

SelectedIndex x:Int32 

(description) The index of the first item in the current selection or returns 

negative one (-1) if the selection is empty. 

SelectedItem x:Object 

(description) The first item in the current selection or returns null if the selection 

is empty 

SelectedValue x:Object 

(description) The value of the SelectedItem, obtained by using 

SelectedValuePath. 

SelectedValuePath x:String 

(description) The path that is used to get the SelectedValue from the 

SelectedItem. 

(attachable properties)  

Selector.IsSelected x:Boolean 

(description) A value that indicates whether an item is selected. 

[target type] DependencyObject 

(events)  

SelectionChanged Occurs when the selection of a Selector changes. 

(attachable events)  

Selector.Selected Occurs when an item is selected. 

Selector.Unselected Occurs when an item is unselected. 

4.775   Separator 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > Separator, 
IInputElement 

RibbonSeparator 

(usage) <Separator /> 

(description) Control that is used to separate items in items controls. 

[name property] Name 
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RibbonSeparator 

[xml lang property] Language 

4.776   SetStoryboardSpeedRatio 

x:Object > DependencyObject > TriggerAction > ControllableStoryboardAction > 
SetStoryboardSpeedRatio 

(usage) <SetStoryboardSpeedRatio /> 

(description) A trigger action that changes the speed of a Storyboard. 

(properties)  

SpeedRatio x:Double 

(description) A new Storyboard animation speed as a ratio of the old animation speed. 

4.777   Setter 

x:Object > SetterBase > Setter 

(usage) <Setter /> 

(description) Represents a setter that applies a property value. 

(properties)  

Property DependencyProperty 

(description) The property to which the Value will be applied. 

TargetName x:String 

(description) The name of the object this Setter is intended for. 

Value x:Object 

(description) The value to apply to the property that is specified by this Setter. 

[text syntax] This property's text syntax is the text syntax of the Property. 

4.778   SetterBase 

x:Object > SetterBase 

EventSetter Setter 

(usage) None. 

(description) Represents the base type for value setters. 

(used by) SetterBaseCollection 

[is default constructible] false 
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4.779   SetterBaseCollection 

x:Object > Collection(SetterBase) > SetterBaseCollection 

(usage) <SetterBaseCollection>SetterBase*</SetterBaseCollection> 

(description) Represents a collection of SetterBase objects. 

(used by) DataTrigger MultiDataTrigger MultiTrigger Style Trigger 

[is list] true 

[allowed types] SetterBase 

4.780   ShaderRenderMode 

x:Object > ShaderRenderMode 

(usage) Auto| SoftwareOnly| HardwareOnly 

(description) Indicates the policy for rendering a ShaderEffect in software. 

(used by) PixelShader 

[is nullable] false 

[text syntax] ShaderRenderModeSyntax 

4.781   Shape 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Shape, IInputElement 

Ellipse Line Path Polygon Polyline Rectangle 

(usage) None. 

(description) A base type for vector shapes. 

[is default 

constructible] 

false 

[name property] Name 

[xml lang property] Language 

(properties)  

Fill Brush 

(description) The Brush that specifies how the shape's interior is painted. 

Stretch Stretch 

(description) A Stretch enumeration value that describes how the shape fills its allocated 

space. 

Stroke Brush 
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Ellipse Line Path Polygon Polyline Rectangle 

(description) The Brush that specifies how the Shape outline is painted. 

StrokeDashArray DoubleCollection 

(description) A collection of Double values that indicate the pattern of dashes and gaps that 

is used to outline shapes. 

StrokeDashCap PenLineCap 

(description) A PenLineCap enumeration value that specifies how the ends of a dash are 

drawn. 

StrokeDashOffset x:Double 

(description) A Double that specifies the distance within the dash pattern where a dash 

begins. 

StrokeEndLineCap PenLineCap 

(description) A PenLineCap enumeration value that describes the Shape at the end of a 

line. 

StrokeLineJoin PenLineJoin 

(description) A PenLineJoin enumeration value that specifies the type of join that is used at 

the vertices of a Shape. 

StrokeMiterLimit x:Double 

(description) A limit on the ratio of the miter length to half the StrokeThickness of a Shape 

element. 

StrokeStartLineCap PenLineCap 

(description) A PenLineCap enumeration value that describes the Shape at the start of a 

Stroke. 

StrokeThickness x:Double 

(description) The width of the Shape outline. 

[text syntax] LengthSyntax 

4.782   ShutdownMode 

x:Object > ShutdownMode 

(usage) OnLastWindowClose| OnMainWindowClose| OnExplicitShutdown 

(description) Specifies how an application will shutdown. Used by the ShutdownMode property. 

(used by) Application 

[is nullable] false 

[text syntax] ShutdownModeSyntax 
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4.783   SineEase 

x:Object > DependencyObject > Freezable > EasingFunctionBase > SineEase, IEasingFunction 

(usage) <SineEase /> 

(description) Represents an easing function that creates an animation that accelerates and/or 

decelerates using a sine formula (see remarks below). 

4.784   SingleAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
SingleAnimationBase > SingleAnimation 

(usage) <SingleAnimation /> 

(description) Animates the value of a  Single property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(x:Single) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(x:Single) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(x:Single) 

(description) The animation's ending value. 

4.785   SingleAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
SingleAnimationBase 

SingleAnimation SingleAnimationUsingKeyFrames 

(usage) None. 
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SingleAnimation SingleAnimationUsingKeyFrames 

(description) A base type that animates a Single value. 

[is default constructible] false 

[name property] Name 

4.786   SingleAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
SingleAnimationBase > SingleAnimationUsingKeyFrames 

(usage) <SingleAnimationUsingKeyFrames>SingleKeyFrame*</SingleAnimationUsingKeyFrames> 

(description) Animates the value of a Single property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value of 

the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames SingleKeyFrameCollection 

(description) The collection of SingleKeyFrame objects that define the animation. 

4.787   SingleKeyFrame 

x:Object > DependencyObject > Freezable > SingleKeyFrame 

DiscreteSingleKeyFrame EasingSingleKeyFrame LinearSingleKeyFrame SplineSingleKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a SingleAnimationUsingKeyFrames. 

(used by) SingleKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 
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DiscreteSingleKeyFrame EasingSingleKeyFrame LinearSingleKeyFrame SplineSingleKeyFrame 

(description) The time at which the key frame's target Value should be reached. 

Value x:Single 

(description) The key frame's target value. 

4.788   SingleKeyFrameCollection 

x:Object > DependencyObject > Freezable > SingleKeyFrameCollection 

(usage) <SingleKeyFrameCollection>SingleKeyFrame*</SingleKeyFrameCollection> 

(description) Represents a collection of SingleKeyFrame objects. 

(used by) SingleAnimationUsingKeyFrames 

[is list] true 

[allowed types] SingleKeyFrame 

(static properties)  

Empty SingleKeyFrameCollection 

(description) An empty SingleKeyFrameCollection. 

4.789   Size 

x:Object > Size 

(usage) <Size> string </Size> 

(description) Implements a structure that is used to describe the Size of an object. 

(used by) ArcSegment Rect SizeKeyFrame UIElement 

[is nullable] false 

[text syntax] SizeSyntax 

(properties)  

Height x:Double 

(description) The Height of this instance of Size. 

Width x:Double 

(description) The Width of this instance of Size. 

(static properties)  

Empty Size 

(description) A value that represents a static empty Size. 
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4.790   Size3D 

x:Object > Size3D 

(usage) <Size3D> string </Size3D> 

(description) Data structure that describes the size of a three-dimensional object. 

(used by) Rect3D 

[is nullable] false 

[text syntax] Size3DSyntax 

(properties)  

X x:Double 

(description) The X value of this Size3D structure. 

Y x:Double 

(description) The Y value of this Size3D structure. 

Z x:Double 

(description) The Z value of this Size3D structure. 

(static properties)  

Empty Size3D 

(description) A value that represents an empty Size3D structure. 

4.791   SizeAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
SizeAnimationBase > SizeAnimation 

(usage) <SizeAnimation /> 

(description) Animates the value of a  Size property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(Size) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Size) 



 

474 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <SizeAnimation /> 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Size) 

(description) The animation's ending value. 

4.792   SizeAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
SizeAnimationBase 

SizeAnimation SizeAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Size value. 

[is default constructible] false 

[name property] Name 

4.793   SizeAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
SizeAnimationBase > SizeAnimationUsingKeyFrames 

(usage) <SizeAnimationUsingKeyFrames>SizeKeyFrame*</SizeAnimationUsingKeyFrames> 

(description) Animates the value of a Size property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value 

of the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 
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(usage) <SizeAnimationUsingKeyFrames>SizeKeyFrame*</SizeAnimationUsingKeyFrames> 

KeyFrames SizeKeyFrameCollection 

(description) The collection of SizeKeyFrame objects that define the animation. 

4.794   SizeKeyFrame 

x:Object > DependencyObject > Freezable > SizeKeyFrame 

DiscreteSizeKeyFrame EasingSizeKeyFrame LinearSizeKeyFrame SplineSizeKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a SizeAnimationUsingKeyFrames. 

(used by) SizeKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value Size 

(description) The key frame's target value. 

4.795   SizeKeyFrameCollection 

x:Object > DependencyObject > Freezable > SizeKeyFrameCollection 

(usage) <SizeKeyFrameCollection>SizeKeyFrame*</SizeKeyFrameCollection> 

(description) Represents a collection of SizeKeyFrame objects. 

(used by) SizeAnimationUsingKeyFrames 

[is list] true 

[allowed types] SizeKeyFrame 

(static properties)  

Empty SizeKeyFrameCollection 

(description) An empty SizeKeyFrameCollection. 

4.796   SizeToContent 

x:Object > SizeToContent 
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(usage) Manual| Width| Height| WidthAndHeight 

(description) Specifies how a window will automatically size itself to fit the size of its content. Used by 

the SizeToContent property. 

(used by) Window 

[is nullable] false 

[text 

syntax] 

SizeToContentSyntax 

4.797   SkewTransform 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform > Transform > 

SkewTransform 

(usage) <SkewTransform> string </SkewTransform> 

(description) Represents a 2-D skew. 

[text syntax] TransformSyntax 

(properties)  

AngleX x:Double 

(description) The x-axis skew angle, which is measured in degrees counterclockwise from the y-axis. 

AngleY x:Double 

(description) The y-axis skew angle, which is measured in degrees counterclockwise from the x-axis. 

CenterX x:Double 

(description) The x-coordinate of the transform center. 

CenterY x:Double 

(description) The y-coordinate of the transform center. 

4.798   SkipStoryboardToFill 

x:Object > DependencyObject > TriggerAction > ControllableStoryboardAction > 
SkipStoryboardToFill 

(usage) <SkipStoryboardToFill /> 

(description) A trigger action that advances a Storyboard to the end of its fill period. 

4.799   Slider 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > RangeBase 
> Slider, IInputElement 

(usage) <Slider /> 
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(usage) <Slider /> 

(description) Represents a control that lets the user select from a range of values by 

moving a Thumb control along a Track. 

[name property] Name 

[xml lang property] Language 

(properties)  

AutoToolTipPlacement AutoToolTipPlacement 

(description) Whether a tooltip that contains the current value of the Slider displays 

when the Thumb is pressed. If a tooltip is displayed, this property also 

specifies the placement of the tooltip. 

AutoToolTipPrecision x:Int32 

(description) The number of digits that are displayed to the right side of the decimal 

point for the Value of the Slider in a tooltip. 

Delay x:Int32 

(description) The amount of time in milliseconds that a RepeatButton waits, while it is 

pressed, before a command to move the Thumb executes, such as a 

DecreaseLarge command. 

Interval x:Int32 

(description) The amount of time in milliseconds between increase or decrease 

commands when a user clicks the RepeatButton of a Slider. 

IsDirectionReversed x:Boolean 

(description) The direction of increasing value. 

IsMoveToPointEnabled x:Boolean 

(description) A value that indicates whether the Thumb of a Slider moves immediately to 

the location of the mouse click that occurs while the mouse pointer pauses 

on the Slider track. 

IsSelectionRangeEnabled x:Boolean 

(description) A value that indicates whether the Slider displays a selection range along 

the Slider. 

IsSnapToTickEnabled x:Boolean 

(description) A value that indicates whether the Slider automatically moves the Thumb 

to the closest tick mark. 

Orientation Orientation 

(description) The orientation of a Slider. 

SelectionEnd x:Double 

(description) The largest value of a specified selection for a Slider. 
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(usage) <Slider /> 

SelectionStart x:Double 

(description) The smallest value of a specified selection for a Slider. 

TickFrequency x:Double 

(description) The interval between tick marks. 

TickPlacement TickPlacement 

(description) The position of tick marks with respect to the Track of the Slider. 

Ticks DoubleCollection 

(description) The positions of the tick marks to display for a Slider. 

(static properties)  

DecreaseLarge RoutedCommand 

(description) A command that decreases the value of the Slider by the same amount as 

the LargeChange property. 

DecreaseSmall RoutedCommand 

(description) A command that decreases the value of the Slider by the same amount as 

the SmallChange property. 

IncreaseLarge RoutedCommand 

(description) A command that increases the value of the slider by the same amount as 

the LargeChange property. 

IncreaseSmall RoutedCommand 

(description) A command that increases the value of the slider by the same amount as 

the SmallChange property. 

MaximizeValue RoutedCommand 

(description) A command that sets the Slider Value to the Maximum value. 

MinimizeValue RoutedCommand 

(description) A command that sets the Slider Value to the Minimum value. 

4.800   SlipBehavior 

x:Object > SlipBehavior 

(usage) Grow| Slip 

(description) Indicates how a ParallelTimeline will behave when one or more of its Timeline children 

slips. 

(used by) ParallelTimeline 
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(usage) Grow| Slip 

[is nullable] false 

[text syntax] SlipBehaviorSyntax 

4.801   SolidColorBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > SolidColorBrush 

(usage) <SolidColorBrush> string </SolidColorBrush> 

(description) Paints an area with a solid color. 

[text syntax] BrushSyntax 

(properties)  

Color Color 

(description) The color of this SolidColorBrush. 

4.802   SoundPlayerAction 

x:Object > DependencyObject > TriggerAction > SoundPlayerAction 

(usage) <SoundPlayerAction /> 

(description) Represents a lightweight audio playback TriggerAction used to play .wav files. 

(properties)  

Source x:Uri 

(description) The audio source location. 

4.803   Span 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Inline > Span, IInputElement 

Bold Hyperlink Italic Underline 

(usage) <Span>[Inline|UIElement|x:String]*</Span> 

(description) Groups other Inline flow content elements. 

[content 

property] 

Inlines 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  
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Bold Hyperlink Italic Underline 

Inlines InlineCollection 

(description) An InlineCollection containing the top-level Inline elements that comprise the 

contents of the Span. 

[read only] true 

4.804   SpecularMaterial 

x:Object > DependencyObject > Freezable > Animatable > Material > SpecularMaterial 

(usage) <SpecularMaterial /> 

(description) Allows a 2-D brush, like a SolidColorBrush or TileBrush, to be applied to a specularly-lit 

3-D model. 

(properties)  

Brush Brush 

(description) The 2-D brush to apply to a specularly-lit 3-D model. 

Color Color 

(description) A value that filters the color properties of the material applied to the model. 

SpecularPower x:Double 

(description) A value that specifies the degree to which a material applied to a 3-D model reflects 

the lighting model as shine. 

4.805   SpeechMode 

x:Object > SpeechMode 

(usage) Dictation| Command| Indeterminate 

(description) Specifies the mode of interpretation for speech input. 

(used by) InputMethod 

[is nullable] false 

[text syntax] SpeechModeSyntax 

4.806   SpellCheck 

x:Object > SpellCheck 

(usage) None. 

(description) Provides real-time spell-checking functionality to text-editing 

controls, such as TextBox and RichTextBox. 
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(usage) None. 

[is default constructible] false 

(properties)  

CustomDictionaries IList 

(description) The collection of lexicon file locations that are used for custom spell 

checking. 

[read only] true 

IsEnabled x:Boolean 

(description) A value that determines whether the spelling checker is enabled on 

this text-editing control, such as TextBox or RichTextBox. 

SpellingReform SpellingReform 

(description) The spelling reform rules that are used by the spelling checker. 

(attachable properties)  

SpellCheck.CustomDictionaries IList 

(description) The collection of lexicon file locations that are used for custom spell 

checking. 

[target type] TextBoxBase 

[read only] true 

SpellCheck.IsEnabled x:Boolean 

(description) A value that determines whether the spelling checker is enabled on 

this text-editing control, such as TextBox or RichTextBox. 

[target type] TextBoxBase 

SpellCheck.SpellingReform SpellingReform 

(description) The spelling reform rules that are used by the spelling checker. 

[target type] TextBoxBase 

4.807   SpellingReform 

x:Object > SpellingReform 

(usage) PreAndPostreform| Prereform| Postreform 

(description) Specifies the spelling reform rules used by the spellchecker of the text editing control 

(i.e. TextBox or RichTextBox). 

(used by) SpellCheck 

[is nullable] false 
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(usage) PreAndPostreform| Prereform| Postreform 

[text 

syntax] 

SpellingReformSyntax 

4.808   SplineByteKeyFrame 

x:Object > DependencyObject > Freezable > ByteKeyFrame > SplineByteKeyFrame 

(usage) <SplineByteKeyFrame /> 

(description) Animates from the Byte value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.809   SplineColorKeyFrame 

x:Object > DependencyObject > Freezable > ColorKeyFrame > SplineColorKeyFrame 

(usage) <SplineColorKeyFrame /> 

(description) Animates from the Color value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.810   SplineDecimalKeyFrame 

x:Object > DependencyObject > Freezable > DecimalKeyFrame > SplineDecimalKeyFrame 

(usage) <SplineDecimalKeyFrame /> 

(description) Animates from the Decimal value of the previous key frame to its own Value using 

splined interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.811   SplineDoubleKeyFrame 

x:Object > DependencyObject > Freezable > DoubleKeyFrame > SplineDoubleKeyFrame 
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(usage) <SplineDoubleKeyFrame /> 

(description) Animates from the Double value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.812   SplineInt16KeyFrame 

x:Object > DependencyObject > Freezable > Int16KeyFrame > SplineInt16KeyFrame 

(usage) <SplineInt16KeyFrame /> 

(description) Animates from the Int16 value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.813   SplineInt32KeyFrame 

x:Object > DependencyObject > Freezable > Int32KeyFrame > SplineInt32KeyFrame 

(usage) <SplineInt32KeyFrame /> 

(description) Animates from the Int32 value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.814   SplineInt64KeyFrame 

x:Object > DependencyObject > Freezable > Int64KeyFrame > SplineInt64KeyFrame 

(usage) <SplineInt64KeyFrame /> 

(description) Animates from the Int64 value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 
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4.815   SplinePoint3DKeyFrame 

x:Object > DependencyObject > Freezable > Point3DKeyFrame > SplinePoint3DKeyFrame 

(usage) <SplinePoint3DKeyFrame /> 

(description) Animates from the Point3D value of the previous key frame to its own Value using 

splined interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.816   SplinePointKeyFrame 

x:Object > DependencyObject > Freezable > PointKeyFrame > SplinePointKeyFrame 

(usage) <SplinePointKeyFrame /> 

(description) Animates from the Point value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.817   SplineQuaternionKeyFrame 

x:Object > DependencyObject > Freezable > QuaternionKeyFrame > SplineQuaternionKeyFrame 

(usage) <SplineQuaternionKeyFrame /> 

(description) Animates from the Quaternion value of the previous key frame to its own Value using 

splined interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

UseShortestPath x:Boolean 

(description) A value that indicates whether the animation uses spherical linear interpolation to 

calculate the shortest arc between positions. 

4.818   SplineRectKeyFrame 

x:Object > DependencyObject > Freezable > RectKeyFrame > SplineRectKeyFrame 

(usage) <SplineRectKeyFrame /> 
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(usage) <SplineRectKeyFrame /> 

(description) Animates from the Rect value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.819   SplineRotation3DKeyFrame 

x:Object > DependencyObject > Freezable > Rotation3DKeyFrame > SplineRotation3DKeyFrame 

(usage) <SplineRotation3DKeyFrame /> 

(description) Animates from the Rotation3D value of the previous key frame to its own Value using 

splined interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.820   SplineSingleKeyFrame 

x:Object > DependencyObject > Freezable > SingleKeyFrame > SplineSingleKeyFrame 

(usage) <SplineSingleKeyFrame /> 

(description) Animates from the Single value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.821   SplineSizeKeyFrame 

x:Object > DependencyObject > Freezable > SizeKeyFrame > SplineSizeKeyFrame 

(usage) <SplineSizeKeyFrame /> 

(description) Animates from the Size value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 
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4.822   SplineThicknessKeyFrame 

x:Object > DependencyObject > Freezable > ThicknessKeyFrame > SplineThicknessKeyFrame 

(usage) <SplineThicknessKeyFrame /> 

(description) Animates from the Thickness value of the previous key frame to its own Value using 

splined interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.823   SplineVector3DKeyFrame 

x:Object > DependencyObject > Freezable > Vector3DKeyFrame > SplineVector3DKeyFrame 

(usage) <SplineVector3DKeyFrame /> 

(description) Animates from the Vector3D value of the previous key frame to its own Value using 

splined interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.824   SplineVectorKeyFrame 

x:Object > DependencyObject > Freezable > VectorKeyFrame > SplineVectorKeyFrame 

(usage) <SplineVectorKeyFrame /> 

(description) Animates from the Vector value of the previous key frame to its own Value using splined 

interpolation. 

(properties)  

KeySpline KeySpline 

(description) The two control points that define animation progress for this key frame. 

4.825   SpotLight 

x:Object > DependencyObject > Freezable > Animatable > Model3D > Light > PointLightBase > 
SpotLight 

(usage) <SpotLight /> 

(description) Light object that projects its effect in a cone-shaped area along a specified direction. 

(properties)  
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(usage) <SpotLight /> 

Direction Vector3D 

(description) A Vector3D that specifies the direction in which the SpotLight projects its light. 

InnerConeAngle x:Double 

(description) An angle that specifies the proportion of a SpotLight's cone-shaped projection in 

which the light fully illuminates objects in the scene. 

OuterConeAngle x:Double 

(description) An angle that specifies the proportion of a SpotLight's cone-shaped projection outside 

which the light does not illuminate objects in the scene. 

4.826   StackPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > StackPanel, 
IInputElement 

ToolBarPanel 

(usage) <StackPanel>UIElement*</StackPanel> 

(description) Arranges child elements into a single line that can be oriented horizontally or 

vertically. 

[content property] Children 

[name property] Name 

[xml lang property] Language 

(properties)  

CanHorizontallyScroll x:Boolean 

(description) A value that indicates whether a StackPanel can scroll in the horizontal 

dimension. 

CanVerticallyScroll x:Boolean 

(description) A value that indicates whether content can scroll in the vertical dimension. 

Orientation Orientation 

(description) A value that indicates the dimension by which child elements are stacked. 

ScrollOwner ScrollViewer 

(description) A value that identifies the container that controls scrolling behavior in this 

StackPanel. 

4.827   StaticResourceExtension 

x:Object > x:MarkupExtension > StaticResourceExtension 
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(usage) {StaticResource } | <StaticResource /> 

(description) Implements a markup extension that supports static (XAML load time) resource 

references made from XAML. 

[return value 

type] 

x:Object 

[constructors]  

(1 parameter)  

resourceKey x:Object 

(description) The key of the resource that this markup extension references. 

(properties)  

ResourceKey x:Object 

(description) The key value passed by this static resource reference. They key is used  to return 

the object matching that key in resource dictionaries. 

4.828   StatusBar 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > StatusBar, IInputElement 

(usage) <StatusBar>x:Object*</StatusBar> 

(description) Represents a control that displays items and information in a 

horizontal bar in an application window. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

UsesItemContainerTemplate 

(4.5) 

x:Boolean 

(description) A value that indicates whether the menu selects different item 

containers, depending on the type of the item in the underlying 

collection or some other heuristic. 

(static properties)  

SeparatorStyleKey ResourceKey 

(description) The key that represents the style to use for Separator objects in the 

StatusBar. 
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4.829   StatusBarItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > StatusBarItem, IInputElement 

(usage) <StatusBarItem>x:Object</StatusBarItem> 

(description) Represents an item of a StatusBar control. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.830   StickyNoteType 

x:Object > StickyNoteType 

(usage) Text| Ink 

(description) Specifies whether a StickyNoteControl accepts text or ink. 

[is nullable] false 

[text syntax] StickyNoteTypeSyntax 

4.831   StopStoryboard 

x:Object > DependencyObject > TriggerAction > ControllableStoryboardAction > StopStoryboard 

(usage) <StopStoryboard /> 

(description) A trigger action that stops a Storyboard. 

4.832   Storyboard 

x:Object > DependencyObject > Freezable > Animatable > Timeline > TimelineGroup > 
ParallelTimeline > Storyboard 

(usage) <Storyboard>Timeline*</Storyboard> 

(description) A container timeline that provides object and property targeting 

information for its child animations. 

(used by) BeginStoryboard VisualState VisualTransition 

[content property] Children 

[name property] Name 

(attachable properties)  

Storyboard.Target DependencyObject 
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(usage) <Storyboard>Timeline*</Storyboard> 

(description) The object that should be animated. 

[target type] DependencyObject 

Storyboard.TargetName x:String 

(description) The name of the object to animate. The object must be a 

DependencyObject. 

[target type] DependencyObject 

Storyboard.TargetProperty PropertyPath 

(description) The property that should be animated. 

[target type] DependencyObject 

4.833   StreamGeometry 

x:Object > DependencyObject > Freezable > Animatable > Geometry > StreamGeometry 

(usage) <StreamGeometry> string </StreamGeometry> 

(description) Defines a geometric shape, described using a StreamGeometryContext. This geometry is 

light-weight alternative to PathGeometry: it does not support data binding, animation, or 

modification. 

[text 

syntax] 

GeometrySyntax 

(properties)  

FillRule FillRule 

(description) A value that determines how the intersecting areas contained in this StreamGeometry 

are combined. 

4.834   Stretch 

x:Object > Stretch 

(usage) None| Fill| Uniform| UniformToFill 

(description) Describes how content is resized to fill its allocated space. 

(used by) DocumentPageView Image MediaElement Shape TileBrush Viewbox 

[is nullable] false 

[text syntax] StretchSyntax 

4.835   StretchDirection 

x:Object > StretchDirection 
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(usage) UpOnly| DownOnly| Both 

(description) Describes how scaling applies to content and restricts scaling to named axis types. 

(used by) DocumentPageView Image MediaElement Viewbox 

[is nullable] false 

[text syntax] StretchDirectionSyntax 

4.836   StringAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
StringAnimationBase 

StringAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a String value. 

[is default constructible] false 

[name property] Name 

4.837   StringAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
StringAnimationBase > StringAnimationUsingKeyFrames 

(usage) <StringAnimationUsingKeyFrames>StringKeyFrame*</StringAnimationUsingKeyFrames> 

(description) Animates the value of a String property along a set of KeyFrames over a specified 

Duration. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

KeyFrames StringKeyFrameCollection 

(description) The collection of StringKeyFrame objects that define the animation. 

4.838   StringKeyFrame 

x:Object > DependencyObject > Freezable > StringKeyFrame 

DiscreteStringKeyFrame 

(usage) None. 

(description) Defines an animation segment with its own target value and interpolation 
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DiscreteStringKeyFrame 

technique for a StringAnimationUsingKeyFrames. 

(used by) StringKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value x:String 

(description) The key frame's target value. 

4.839   StringKeyFrameCollection 

x:Object > DependencyObject > Freezable > StringKeyFrameCollection 

(usage) <StringKeyFrameCollection>StringKeyFrame*</StringKeyFrameCollection> 

(description) Represents a collection of StringKeyFrame objects. 

(used by) StringAnimationUsingKeyFrames 

[is list] true 

[allowed types] StringKeyFrame 

(static properties)  

Empty StringKeyFrameCollection 

(description) An empty StringKeyFrameCollection. 

4.840   Stroke 

x:Object > Stroke 

(usage) None. 

(description) Represents a single ink stroke. 

(used by) StrokeCollection 

[is default constructible] false 

(properties)  

DrawingAttributes DrawingAttributes 

(description) The DrawingAttributes for the Stroke object. 

StylusPoints StylusPointCollection 
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(usage) None. 

(description) Returns the stylus points of the Stroke. 

(events)  

DrawingAttributesChanged Occurs when the DrawingAttributes associated with the Stroke object 

change. 

DrawingAttributesReplaced Occurs when the drawing attributes of a Stroke object are replaced. 

Invalidated Occurs when the appearance of the Stroke changes. 

PropertyDataChanged Occurs when the custom properties on a Stroke object changes. 

StylusPointsChanged Occurs when the StylusPoints property changes. 

StylusPointsReplaced Occurs when the StylusPoints property is assigned a new 

StylusPointCollection. 

4.841   StrokeCollection 

x:Object > Collection(Stroke) > StrokeCollection 

(usage) <StrokeCollection> string </StrokeCollection> 

(description) Represents a collection of Stroke objects. 

(used by) InkCanvas InkPresenter 

[text syntax] StrokeCollectionSyntax 

[is list] true 

[allowed types] Stroke 

(events)  

PropertyDataChanged Occurs when custom property is added or removed from the StrokeCollection. 

StrokesChanged Occurs when a Stroke in the collection changes. 

4.842   Style 

x:Object > Style 

(usage) <Style>SetterBase*</Style> 

(description) Enables the sharing of properties, resources, and event handlers between instances of 

a type. 

(used by) Calendar DataGrid DataGridBoundColumn DataGridColumn DataGridComboBoxColumn 

DataGridRow DatePicker FrameworkContentElement FrameworkElement GridSplitter 

GridView GridViewColumn GridViewHeaderRowPresenter GroupStyle 

HierarchicalDataTemplate ItemsControl KeyTipService Ribbon RibbonGallery 

RibbonTab Style 
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(usage) <Style>SetterBase*</Style> 

[content 

property] 

Setters 

[dictionary key 

property] 

TargetType 

[is name 

scope] 

true 

(properties)  

BasedOn Style 

(description) A defined style that is the basis of the current style. 

Resources ResourceDictionary 

(description) The collection of resources that can be used within the scope of this style. 

Setters SetterBaseCollection 

(description) A collection of Setter and EventSetter objects. 

[read only] true 

TargetType x:XamlType 

(description) The type for which this style is intended. 

Triggers TriggerCollection 

(description) A collection of TriggerBase objects that apply property values based on specified 

conditions. 

[read only] true 

4.843   StyleSelector 

x:Object > StyleSelector 

(usage) <StyleSelector /> 

(description) Provides a way to apply styles based on custom logic. 

(used by) DataGrid GroupStyle HierarchicalDataTemplate ItemsControl RibbonGallery 

4.844   StyleSimulations 

x:Object > StyleSimulations 

(usage) None| BoldSimulation| ItalicSimulation| BoldItalicSimulation 

(description) Defines an enumerator type that describes the simulation style of a font. 

(used by) Glyphs GlyphTypeface 
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(usage) None| BoldSimulation| ItalicSimulation| BoldItalicSimulation 

[is nullable] false 

[text syntax] StyleSimulationsSyntax 

4.845   Stylus 

x:Object > Stylus 

(usage) {x:Static Stylus.StaticPropertyName} 

(description) Provides access to general information about a tablet pen. 

[is default constructible] false 

(attachable properties)  

Stylus.IsFlicksEnabled x:Boolean 

(description) A value indicating whether flicks are enabled. 

[target type] DependencyObject 

Stylus.IsPressAndHoldEnabled x:Boolean 

(description) A values indicating whether press and hold is enabled. 

[target type] DependencyObject 

Stylus.IsTapFeedbackEnabled x:Boolean 

(description) Whether a value indicating whether tap feedback is enabled. 

[target type] DependencyObject 

Stylus.IsTouchFeedbackEnabled x:Boolean 

(description) Whether a value indicating whether touch feedback is enabled. 

[target type] DependencyObject 

(static properties)  

Captured IInputElement 

(description) The element to which the stylus is bound. 

CurrentStylusDevice StylusDevice 

(description) The stylus that represents the stylus currently in use. 

DirectlyOver IInputElement 

(description) The element that is directly beneath the stylus. 

(attachable events)  

Stylus.GotStylusCapture Occurs when an element captures the stylus events. 
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(usage) {x:Static Stylus.StaticPropertyName} 

Stylus.LostStylusCapture Occurs when an element releases stylus events. 

Stylus.PreviewStylusButtonDown Occurs when the user presses one of the buttons on the stylus. 

Stylus.PreviewStylusButtonUp Occurs when the user releases one of the buttons on the stylus. 

Stylus.PreviewStylusDown Occurs when user touches the tip of the stylus to the tablet. 

Stylus.PreviewStylusInAirMove Occurs if the stylus moves while it is within range of (but not 

touching) the tablet. 

Stylus.PreviewStylusInRange Occurs when the stylus comes within range of the tablet. 

Stylus.PreviewStylusMove Occurs when the stylus moves while it is touching the tablet. 

Stylus.PreviewStylusOutOfRange Occurs when the stylus goes out of range of the tablet. 

Stylus.PreviewStylusSystemGesture Occurs when the user makes a system gesture with this stylus. 

Stylus.PreviewStylusUp Occurs when the user lifts the stylus from the tablet. 

Stylus.StylusButtonDown Occurs when the user presses one of the buttons on the stylus. 

Stylus.StylusButtonUp Occurs when the user releases one of the buttons on the stylus. 

Stylus.StylusDown Occurs when the user touches the tip of the stylus to the 

tablet. 

Stylus.StylusEnter Occurs when the stylus cursor enters the bounds of an 

element. 

Stylus.StylusInAirMove Occurs when the stylus moves while it is in range of, but not 

touching, the tablet. 

Stylus.StylusInRange Occurs when the stylus comes within range of the tablet. 

Stylus.StylusLeave Occurs when the stylus cursor leaves the bounds of an 

element. 

Stylus.StylusMove Occurs when the stylus moves while it is touching the tablet. 

Stylus.StylusOutOfRange Occurs when the stylus goes out of range of the tablet. 

Stylus.StylusSystemGesture Occurs when the user makes a system gesture with this stylus. 

Stylus.StylusUp Occurs when the user raises the stylus from the Tablet PC. 

4.846   StylusButton 

x:Object > StylusButton 

(usage) None. 

(description) Represents a button on a stylus. 

(used by) StylusButtonCollection 
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(usage) None. 

[is default constructible] false 

4.847   StylusButtonCollection 

x:Object > ReadOnlyCollection(StylusButton) > StylusButtonCollection 

(usage) None. 

(description) Contains a collection of StylusButton objects. 

[is default constructible] false 

[is list] true 

[allowed types] StylusButton 

4.848   StylusButtonState 

x:Object > StylusButtonState 

(usage) Up| Down 

(description) Represents the state of a StylusButton. 

[is nullable] false 

[text syntax] StylusButtonStateSyntax 

4.849   StylusDeviceCollection 

x:Object > ReadOnlyCollection(StylusDevice) > StylusDeviceCollection 

(usage) None. 

(description) Contains the StylusDevice objects that represent a Tablet PC's stylus 

devices. 

[is default 

constructible] 

false 

[is list] true 

[allowed types] StylusDevice 

4.850   StylusPoint 

x:Object > StylusPoint 

(usage) <StylusPoint /> 

(description) Represents a single data point collected from the digitizer and stylus. 
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(usage) <StylusPoint /> 

(used by) StylusPointCollection 

[is nullable] false 

(properties)  

Description StylusPointDescription 

(description) The StylusPointDescription that specifies the properties stored in the StylusPoint. 

PressureFactor x:Single 

(description) A value between 0 and 1 that reflects the amount of pressure the stylus applies to the 

digitizer's surface when the StylusPoint is created. 

X x:Double 

(description) The value for the x-coordinate of the StylusPoint. 

Y x:Double 

(description) The y-coordinate of the StylusPoint. 

4.851   StylusPointCollection 

x:Object > Collection(StylusPoint) > StylusPointCollection 

(usage) <StylusPointCollection>StylusPoint*</StylusPointCollection> 

(description) Contains a collection of StylusPoint objects. 

(used by) Stroke 

[is list] true 

[allowed types] StylusPoint 

(events)  

Changed Occurs when the StylusPointCollection changes. 

4.852   StylusPointDescription 

x:Object > StylusPointDescription 

(usage) <StylusPointDescription /> 

(description) Specifies the properties that are in a StylusPoint. 

(used by) InkCanvas StylusPoint 

4.853   StylusPointPropertyUnit 

x:Object > StylusPointPropertyUnit 
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(usage) None| Inches| Centimeters| Degrees| Radians| Seconds| Pounds| Grams 

(description) Specifies the unit of measurement for a StylusPoint property. 

[is nullable] false 

[text syntax] StylusPointPropertyUnitSyntax 

4.854   StylusTip 

x:Object > StylusTip 

(usage) Rectangle| Ellipse 

(description) Specifies the tip to be used to draw a Stroke. 

(used by) DrawingAttributes 

[is nullable] false 

[text syntax] StylusTipSyntax 

4.855   SweepDirection 

x:Object > SweepDirection 

(usage) Counterclockwise| Clockwise 

(description) Defines the direction an elliptical arc is drawn. 

(used by) ArcSegment 

[is nullable] false 

[text syntax] SweepDirectionSyntax 

4.856   SystemColors 

x:Object > SystemColors 

(usage) {x:Static SystemColors.StaticPropertyName} 

(description) Contains system colors, system brushes, and system 

resource keys that correspond to system display elements. 

[is default constructible] false 

(static properties)  

ActiveBorderBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of the active window's 

border. 

ActiveBorderBrushKey ResourceKey 
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(usage) {x:Static SystemColors.StaticPropertyName} 

(description) The ResourceKey for the SolidColorBrush used to paint the 

active window's border. 

ActiveBorderColor Color 

(description) A Color structure that is the color of the active window's 

border. 

ActiveBorderColorKey ResourceKey 

(description) The ResourceKey for the Color of the active window's 

border. 

ActiveCaptionBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of the background of 

the active window's title bar. 

ActiveCaptionBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush used to paint the 

background of the active window's title bar. 

ActiveCaptionColor Color 

(description) A Color structure that is the background color of the active 

window's title bar. 

ActiveCaptionColorKey ResourceKey 

(description) The ResourceKey for the background Color of the active 

window's title bar. 

ActiveCaptionTextBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of the text in the active 

window's title bar. 

ActiveCaptionTextBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

text in the active window's title bar. 

ActiveCaptionTextColor Color 

(description) A Color structure that is the color of the text in the active 

window's title bar. 

ActiveCaptionTextColorKey ResourceKey 

(description) The ResourceKey for the Color of the text in the active 

window's title bar. 

AppWorkspaceBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of the application 

workspace. 
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(usage) {x:Static SystemColors.StaticPropertyName} 

AppWorkspaceBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

application workspace. 

AppWorkspaceColor Color 

(description) A Color structure that is the color of the application 

workspace. 

AppWorkspaceColorKey ResourceKey 

(description) The ResourceKey for the Color of the application 

workspace. 

ControlBrush SolidColorBrush 

(description) A SolidColorBrush that is the face color of a three-

dimensional display element. 

ControlBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

face of a three-dimensional display element. 

ControlColor Color 

(description) A Color structure that is the face color of a three-

dimensional display element. 

ControlColorKey ResourceKey 

(description) The ResourceKey for the face Color of a three-dimensional 

display element. 

ControlDarkBrush SolidColorBrush 

(description) A SolidColorBrush that is the shadow color of a three-

dimensional display element. 

ControlDarkBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

shadow of a three-dimensional display element. 

ControlDarkColor Color 

(description) A Color structure that is the shadow color of a three-

dimensional display element. 

ControlDarkColorKey ResourceKey 

(description) The ResourceKey for the shadow Color of a three-

dimensional display element. 

ControlDarkDarkBrush SolidColorBrush 

(description) A SolidColorBrush that is the dark shadow color of a three-
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(usage) {x:Static SystemColors.StaticPropertyName} 

dimensional display element. 

ControlDarkDarkBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

dark shadow of a three-dimensional display element. 

ControlDarkDarkColor Color 

(description) A Color structure that is the dark shadow color of a three-

dimensional display element. 

ControlDarkDarkColorKey ResourceKey 

(description) The ResourceKey for the dark shadow Color of the 

highlight color of a three-dimensional display element. 

ControlLightBrush SolidColorBrush 

(description) A SolidColorBrush that is the light color of a three-

dimensional display element. 

ControlLightBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

light area of a three-dimensional display element. 

ControlLightColor Color 

(description) A Color structure that is the light color of a three-

dimensional display element. 

ControlLightColorKey ResourceKey 

(description) The ResourceKey for the highlight Color of a three-

dimensional display element. 

ControlLightLightBrush SolidColorBrush 

(description) A SolidColorBrush that is the highlight color of a three-

dimensional display element. 

ControlLightLightBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

highlight of a three-dimensional display element. 

ControlLightLightColor Color 

(description) A Color structure that is the highlight color of a three-

dimensional display element. 

ControlLightLightColorKey ResourceKey 

(description) The ResourceKey for the highlight Color of a three-

dimensional display element. 

ControlTextBrush SolidColorBrush 
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(usage) {x:Static SystemColors.StaticPropertyName} 

(description) A SolidColorBrush that is the color of text in a three-

dimensional display element. 

ControlTextBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints text 

in a three-dimensional display element. 

ControlTextColor Color 

(description) A Color structure that is the color of text in a three-

dimensional display element. 

ControlTextColorKey ResourceKey 

(description) The ResourceKey for the Color of text in a three-

dimensional display element. 

DesktopBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of the desktop. 

DesktopBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

desktop. 

DesktopColor Color 

(description) A Color structure that is the color of the desktop. 

DesktopColorKey ResourceKey 

(description) The ResourceKey for the Color of the desktop. 

GradientActiveCaptionBrush SolidColorBrush 

(description) A SolidColorBrush that is the right side color in the 

gradient of an active window's title bar. 

GradientActiveCaptionBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that is the color 

of the right side of the gradient of an active window's title 

bar. 

GradientActiveCaptionColor Color 

(description) A Color structure that is the right side color in the gradient 

of an active window's title bar. 

GradientActiveCaptionColorKey ResourceKey 

(description) The ResourceKey for the right-side Color in the gradient of 

an active window's title bar. 

GradientInactiveCaptionBrush SolidColorBrush 
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(usage) {x:Static SystemColors.StaticPropertyName} 

(description) A SolidColorBrush that is the right side color in the 

gradient of an inactive window's title bar. 

GradientInactiveCaptionBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that is the color 

of the right side of the gradient of an inactive window's 

title bar. 

GradientInactiveCaptionColor Color 

(description) A Color structure that is the right side color in the gradient 

of an inactive window's title bar. 

GradientInactiveCaptionColorKey ResourceKey 

(description) The ResourceKey for the right-side Color in the gradient of 

an inactive window's title bar. 

GrayTextBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of disabled text. 

GrayTextBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints 

disabled text. 

GrayTextColor Color 

(description) A Color structure that is the color of disabled text. 

GrayTextColorKey ResourceKey 

(description) The ResourceKey for the Color of disabled text. 

HighlightBrush SolidColorBrush 

(description) A SolidColorBrush that paints the background of selected 

items. 

HighlightBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

background of selected items. 

HighlightColor Color 

(description) A Color structure that is the background color of selected 

items. 

HighlightColorKey ResourceKey 

(description) The ResourceKey for the background Color of selected 

items. 

HighlightTextBrush SolidColorBrush 
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(description) A SolidColorBrush that is the color of the text of selected 

items. 

HighlightTextBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

text of selected items. 

HighlightTextColor Color 

(description) A Color structure that is the color of the text of selected 

items. 

HighlightTextColorKey ResourceKey 

(description) The ResourceKey for the Color of a selected item's text. 

HotTrackBrush SolidColorBrush 

(description) A SolidColorBrush that is the color used to designate a 

hot-tracked item. 

HotTrackBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints hot-

tracked items. 

HotTrackColor Color 

(description) A Color structure that is the color used to designate a hot-

tracked item. 

HotTrackColorKey ResourceKey 

(description) The ResourceKey for the Color that designates a hot-

tracked item. 

InactiveBorderBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of an inactive window's 

border. 

InactiveBorderBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

border of an inactive window. 

InactiveBorderColor Color 

(description) A Color structure that is the color of an inactive window's 

border. 

InactiveBorderColorKey ResourceKey 

(description) The ResourceKey for the Color of an inactive window's 

border. 

InactiveCaptionBrush SolidColorBrush 
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(usage) {x:Static SystemColors.StaticPropertyName} 

(description) A SolidColorBrush that is the background color of an 

inactive window's title bar. 

InactiveCaptionBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

background of an inactive window's title bar. 

InactiveCaptionColor Color 

(description) A Color structure that is the background color of an 

inactive window's title bar. 

InactiveCaptionColorKey ResourceKey 

(description) The ResourceKey for the background Color of an inactive 

window's title bar. 

InactiveCaptionTextBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of the text of an 

inactive window's title bar. 

InactiveCaptionTextBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

text of an inactive window's title bar. 

InactiveCaptionTextColor Color 

(description) A Color structure that is the color of the text of an inactive 

window's title bar. 

InactiveCaptionTextColorKey ResourceKey 

(description) The ResourceKey for the Color of the text of an inactive 

window's title bar. 

InactiveSelectionHighlightBrush SolidColorBrush 

(description)  

InactiveSelectionHighlightBrushKey ResourceKey 

(description)  

InactiveSelectionHighlightTextBrush SolidColorBrush 

(description)  

InactiveSelectionHighlightTextBrushKey ResourceKey 

(description)  

InfoBrush SolidColorBrush 

(description) A SolidColorBrush that is the background color for the 

ToolTip control. 
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(usage) {x:Static SystemColors.StaticPropertyName} 

InfoBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

background of the ToolTip control. 

InfoColor Color 

(description) A Color structure that is the background color for the 

ToolTip control. 

InfoColorKey ResourceKey 

(description) The ResourceKey for the background Color of the ToolTip 

control. 

InfoTextBrush SolidColorBrush 

(description) A SolidColorBrush that is the text color for the ToolTip 

control. 

InfoTextBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

text in a ToolTip control. 

InfoTextColor Color 

(description) A Color structure that is the text color for the ToolTip 

control. 

InfoTextColorKey ResourceKey 

(description) The ResourceKey for the Color of the text in a ToolTip 

control. 

MenuBarBrush SolidColorBrush 

(description) A SolidColorBrush that is the background color for a menu 

bar. 

MenuBarBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

background of a menu bar. 

MenuBarColor Color 

(description) A Color structure that is the background color for a menu 

bar. 

MenuBarColorKey ResourceKey 

(description) The ResourceKey for the background Color of a menu bar. 

MenuBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of a menu's 

background. 
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(usage) {x:Static SystemColors.StaticPropertyName} 

MenuBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

background of a menu. 

MenuColor Color 

(description) A Color structure that is the color of a menu's background. 

MenuColorKey ResourceKey 

(description) The ResourceKey for the background Color of a menu. 

MenuHighlightBrush SolidColorBrush 

(description) A SolidColorBrush that is the color used to highlight a 

menu item. 

MenuHighlightBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints a 

highlighted menu item. 

MenuHighlightColor Color 

(description) A Color structure that is the color used to highlight a menu 

item. 

MenuHighlightColorKey ResourceKey 

(description) The ResourceKey for the background Color of a highlighted 

menu item. 

MenuTextBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of a menu's text. 

MenuTextBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints a 

menu's text. 

MenuTextColor Color 

(description) A Color structure that is the color of a menu's text. 

MenuTextColorKey ResourceKey 

(description) The ResourceKey for the Color of a menu's text. 

ScrollBarBrush SolidColorBrush 

(description) A SolidColorBrush that is the background color of a scroll 

bar. 

ScrollBarBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 
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background of a scroll bar. 

ScrollBarColor Color 

(description) A Color structure that is the background color of a scroll 

bar. 

ScrollBarColorKey ResourceKey 

(description) The ResourceKey for the background Color of a scroll bar. 

WindowBrush SolidColorBrush 

(description) A SolidColorBrush that is the background color in the client 

area of a window. 

WindowBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

background of a window's client area. 

WindowColor Color 

(description) A Color structure that is the background color in the client 

area of a window. 

WindowColorKey ResourceKey 

(description) The ResourceKey for the background Color of a window's 

client area. 

WindowFrameBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of a window frame. 

WindowFrameBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints a 

window frame. 

WindowFrameColor Color 

(description) A Color structure that is the color of a window frame. 

WindowFrameColorKey ResourceKey 

(description) The ResourceKey for the Color of a window frame. 

WindowTextBrush SolidColorBrush 

(description) A SolidColorBrush that is the color of the text in the client 

area of a window. 

WindowTextBrushKey ResourceKey 

(description) The ResourceKey for the SolidColorBrush that paints the 

text in the client area of a window. 

WindowTextColor Color 
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(usage) {x:Static SystemColors.StaticPropertyName} 

(description) A Color structure that is the color of the text in the client 

area of a window. 

WindowTextColorKey ResourceKey 

(description) The ResourceKey for the Color of text in a window's client 

area. 

4.857   SystemCommands (4.5) 

x:Object > SystemCommands 

(usage) {x:Static SystemCommands.StaticPropertyName} 

(description) Defines routed commands that are common to window management. 

[is default constructible] false 

(static properties)  

CloseWindowCommand RoutedCommand 

(description) A command that closes a window. 

MaximizeWindowCommand RoutedCommand 

(description) A command that maximizes a window. 

MinimizeWindowCommand RoutedCommand 

(description) A command that maximizes a window. 

RestoreWindowCommand RoutedCommand 

(description) A command that restores a window. 

ShowSystemMenuCommand RoutedCommand 

(description) A command that displays the system menu. 

4.858   SystemFonts 

x:Object > SystemFonts 

(usage) {x:Static SystemFonts.StaticPropertyName} 

(description) Contains properties that expose the system resources that 

concern fonts. 

[is default constructible] false 

(static properties)  

CaptionFontFamily FontFamily 
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(usage) {x:Static SystemFonts.StaticPropertyName} 

(description) The metric that determines the font family of the caption of 

the nonclient area of a nonminimized window. 

CaptionFontFamilyKey ResourceKey 

(description) The ResourceKey for the CaptionFontFamily property. 

CaptionFontSize x:Double 

(description) The metric that determines the caption font-size for the 

nonclient area of a nonminimized window. 

CaptionFontSizeKey ResourceKey 

(description) The ResourceKey for the CaptionFontSize property. 

CaptionFontStyle FontStyle 

(description) The metric that determines the caption font-style for the 

nonclient area of a nonminimized window. 

CaptionFontStyleKey ResourceKey 

(description) The ResourceKey for the CaptionFontStyle property. 

CaptionFontTextDecorations TextDecorationCollection 

(description) The metric that determines the caption text-decorations for 

the nonclient area of a nonminimized window. 

CaptionFontTextDecorationsKey ResourceKey 

(description) The ResourceKey for the CaptionFontTextDecorations 

property. 

CaptionFontWeight FontWeight 

(description) The metric that determines the caption font-weight for the 

nonclient area of a nonminimized window. 

CaptionFontWeightKey ResourceKey 

(description) The ResourceKey for the CaptionFontWeight property. 

IconFontFamily FontFamily 

(description) The font family from the logical font information for the 

current icon-title font. 

IconFontFamilyKey ResourceKey 

(description) The ResourceKey for the IconFontFamily property. 

IconFontSize x:Double 

(description) The font size from the logical font information for the current 

icon-title font. 
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IconFontSizeKey ResourceKey 

(description) The ResourceKey for the IconFontSize property. 

IconFontStyle FontStyle 

(description) The font style from the logical font information for the current 

icon-title font. 

IconFontStyleKey ResourceKey 

(description) The ResourceKey for the IconFontStyle property. 

IconFontTextDecorations TextDecorationCollection 

(description) The text decorations from the logical font information for the 

current icon-title font. 

IconFontTextDecorationsKey ResourceKey 

(description) The ResourceKey for the IconFontTextDecorations property. 

IconFontWeight FontWeight 

(description) The font weight from the logical font information for the 

current icon-title font. 

IconFontWeightKey ResourceKey 

(description) The ResourceKey for the IconFontWeight property. 

MenuFontFamily FontFamily 

(description) The metric that determines the font family for menu text. 

MenuFontFamilyKey ResourceKey 

(description) The ResourceKey for the MenuFontFamily property. 

MenuFontSize x:Double 

(description) The metric that determines the font size of menu text. 

MenuFontSizeKey ResourceKey 

(description) The ResourceKey for the MenuFontSize property. 

MenuFontStyle FontStyle 

(description) The metric that determines the font style for menu text. 

MenuFontStyleKey ResourceKey 

(description) The ResourceKey for the MenuFontStyle property. 

MenuFontTextDecorations TextDecorationCollection 

(description) The metric that determines the text decorations for menu 
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text. 

MenuFontTextDecorationsKey ResourceKey 

(description) The ResourceKey for the MenuFontTextDecorations property. 

MenuFontWeight FontWeight 

(description) The metric that determines the font weight for menu text. 

MenuFontWeightKey ResourceKey 

(description) The ResourceKey for the MenuFontWeight property. 

MessageFontFamily FontFamily 

(description) The metric that determines the font family for message box 

text. 

MessageFontFamilyKey ResourceKey 

(description) The ResourceKey for the MessageFontFamily property. 

MessageFontSize x:Double 

(description) The metric that determines the font size of message box text. 

MessageFontSizeKey ResourceKey 

(description) The ResourceKey for the MessageFontSize property. 

MessageFontStyle FontStyle 

(description) The metric that determines the font style for message box 

text. 

MessageFontStyleKey ResourceKey 

(description) The ResourceKey for the MessageFontStyle property. 

MessageFontTextDecorations TextDecorationCollection 

(description) The metric that determines the decorations for message box 

text. 

MessageFontTextDecorationsKey ResourceKey 

(description) The ResourceKey for the MessageFontTextDecorations 

property. 

MessageFontWeight FontWeight 

(description) The metric that determines the font weight for message box 

text. 

MessageFontWeightKey ResourceKey 

(description) The ResourceKey for the MessageFontWeight property. 
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SmallCaptionFontFamily FontFamily 

(description) The metric that determines the font family of the small-

caption text for the nonclient area of a nonminimized window. 

SmallCaptionFontFamilyKey ResourceKey 

(description) The ResourceKey for the SmallCaptionFontFamily property. 

SmallCaptionFontSize x:Double 

(description) The metric that determines the font size of the small-caption 

text for the nonclient area of a nonminimized window. 

SmallCaptionFontSizeKey ResourceKey 

(description) The ResourceKey for the SmallCaptionFontSize property. 

SmallCaptionFontStyle FontStyle 

(description) The metric that determines the font style of the small-caption 

text for the nonclient area of a nonminimized window. 

SmallCaptionFontStyleKey ResourceKey 

(description) The ResourceKey for the SmallCaptionFontStyle property. 

SmallCaptionFontTextDecorations TextDecorationCollection 

(description) The metric that determines the decorations of the small-

caption text for the nonclient area of a nonminimized window. 

SmallCaptionFontTextDecorationsKey ResourceKey 

(description) The ResourceKey for the SmallCaptionFontTextDecorations 

property. 

SmallCaptionFontWeight FontWeight 

(description) The metric that determines the font weight of the small-

caption text for the nonclient area of a nonminimized window. 

SmallCaptionFontWeightKey ResourceKey 

(description) The ResourceKey for the SmallCaptionFontWeight property. 

StatusFontFamily FontFamily 

(description) The metric that determines the font family of the text used in 

status bars and ToolTips for the nonclient area of a 

nonminimized window. 

StatusFontFamilyKey ResourceKey 

(description) The ResourceKey for the StatusFontFamily property. 

StatusFontSize x:Double 
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(description) The metric that determines the font size of the text used in 

status bars and ToolTips for the nonclient area of a 

nonminimized window. 

StatusFontSizeKey ResourceKey 

(description) The ResourceKey for the StatusFontSize property. 

StatusFontStyle FontStyle 

(description) The metric that determines the font style of the text used in 

status bars and ToolTips for the nonclient area of a 

nonminimized window. 

StatusFontStyleKey ResourceKey 

(description) The ResourceKey for the StatusFontStyle property. 

StatusFontTextDecorations TextDecorationCollection 

(description) The metric that determines the decorations of the text used 

in status bars and ToolTips for the nonclient area of a 

nonminimized window. 

StatusFontTextDecorationsKey ResourceKey 

(description) The ResourceKey for the StatusFontTextDecorations property. 

StatusFontWeight FontWeight 

(description) The metric that determines the font weight of the text used in 

status bars and ToolTips for the nonclient area of a 

nonminimized window. 

StatusFontWeightKey ResourceKey 

(description) The ResourceKey for the StatusFontWeight property. 

4.859   SystemGesture 

x:Object > SystemGesture 

(usage) None| Tap| RightTap| Drag| RightDrag| HoldEnter| HoverEnter| HoverLeave| 

Flick... 

(description) Defines the available system gestures. 

[is nullable] false 

[text syntax] SystemGestureSyntax 

4.860   SystemParameters 

x:Object > SystemParameters 
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(description) Contains properties that you can use to query system 

settings. 

[is default constructible] false 

(static properties)  

Border x:Int32 

(description) The border multiplier factor that determines the width of a 

window's sizing border. 

BorderKey ResourceKey 

(description) The ResourceKey for the Border property. 

BorderWidth x:Double 

(description) The metric that determines the border width of the 

nonclient area of a nonminimized window. 

BorderWidthKey ResourceKey 

(description) The ResourceKey for the BorderWidth property. 

CaptionHeight x:Double 

(description) The metric that determines the caption height for the 

nonclient area of a nonminimized window. 

CaptionHeightKey ResourceKey 

(description) The ResourceKey for the CaptionHeight property. 

CaptionWidth x:Double 

(description) The metric that determines the caption width for the 

nonclient area of a nonminimized window. 

CaptionWidthKey ResourceKey 

(description) The ResourceKey for the CaptionWidth property. 

CaretWidth x:Double 

(description) The caret width, in pixels, for edit controls. 

CaretWidthKey ResourceKey 

(description) The ResourceKey for the CaretWidth property. 

ClientAreaAnimation x:Boolean 

(description) A value indicating whether the client area animation 

feature is enabled. 

ClientAreaAnimationKey ResourceKey 
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(description) A ResourceKey for the ClientAreaAnimation property. 

ComboBoxAnimation x:Boolean 

(description) A value indicating whether the slide-open effect for combo 

boxes is enabled. 

ComboBoxAnimationKey ResourceKey 

(description) The ResourceKey for the ComboBoxAnimation property. 

ComboBoxPopupAnimation PopupAnimation 

(description) The system value of the PopupAnimation property for 

combo boxes. 

ComboBoxPopupAnimationKey ResourceKey 

(description) The ResourceKey for the ComboBoxPopupAnimation 

property. 

CursorHeight x:Double 

(description) The height, in pixels, of a cursor. 

CursorHeightKey ResourceKey 

(description) The ResourceKey for the CursorHeight property. 

CursorShadow x:Boolean 

(description) A value indicating whether the cursor has a shadow around 

it. 

CursorShadowKey ResourceKey 

(description) The ResourceKey for the CursorShadow property. 

CursorWidth x:Double 

(description) The width, in pixels, of a cursor. 

CursorWidthKey ResourceKey 

(description) The ResourceKey for the CursorWidth property. 

DragFullWindows x:Boolean 

(description) A value indicating whether dragging of full windows is 

enabled. 

DragFullWindowsKey ResourceKey 

(description) The ResourceKey for the DragFullWindows property. 

DropShadow x:Boolean 

(description) A value indicating whether the drop shadow effect is 
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enabled. 

DropShadowKey ResourceKey 

(description) The ResourceKey for the DropShadow property. 

FixedFrameHorizontalBorderHeight x:Double 

(description) The height of the horizontal border of the frame around a 

window. 

FixedFrameHorizontalBorderHeightKey ResourceKey 

(description) The ResourceKey for the 

FixedFrameHorizontalBorderHeight property. 

FixedFrameVerticalBorderWidth x:Double 

(description) The width of the vertical border of the frame around a 

window. 

FixedFrameVerticalBorderWidthKey ResourceKey 

(description) The ResourceKey for the FixedFrameVerticalBorderWidth 

property. 

FlatMenu x:Boolean 

(description) A value indicating whether native menus appear as a flat 

menu. 

FlatMenuKey ResourceKey 

(description) The ResourceKey for the FlatMenu property. 

FocusBorderHeight x:Double 

(description) The height, in pixels, of the upper and lower edges of the 

focus rectangle. 

FocusBorderHeightKey ResourceKey 

(description) The ResourceKey for the FocusBorderHeight property. 

FocusBorderWidth x:Double 

(description) The width, in pixels, of the left and right edges of the focus 

rectangle. 

FocusBorderWidthKey ResourceKey 

(description) The ResourceKey for the FocusBorderWidth property. 

FocusHorizontalBorderHeight x:Double 

(description) The height of the upper and lower edges of the focus 

rectangle. 

FocusHorizontalBorderHeightKey ResourceKey 
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(description) The ResourceKey for the FocusHorizontalBorderHeight 

property. 

FocusVerticalBorderWidth x:Double 

(description) The width of the left and right edges of the focus 

rectangle. 

FocusVerticalBorderWidthKey ResourceKey 

(description) The ResourceKey for the FocusVerticalBorderWidth 

property. 

FocusVisualStyleKey ResourceKey 

(description) The ResourceKey for the FocusVisualStyle property. 

ForegroundFlashCount x:Int32 

(description) The number of times the Set Foreground Window flashes 

the taskbar button when rejecting a foreground switch 

request. 

ForegroundFlashCountKey ResourceKey 

(description) The ResourceKey for the ForegroundFlashCount property. 

FullPrimaryScreenHeight x:Double 

(description) The height, in pixels, of the client area for a full-screen 

window on the primary display monitor. 

FullPrimaryScreenHeightKey ResourceKey 

(description) The ResourceKey for the FullPrimaryScreenHeight 

property. 

FullPrimaryScreenWidth x:Double 

(description) The width, in pixels, of the client area for a full-screen 

window on the primary display monitor. 

FullPrimaryScreenWidthKey ResourceKey 

(description) The ResourceKey for the FullPrimaryScreenWidth property. 

GradientCaptions x:Boolean 

(description) A value indicating whether the gradient effect for window 

title bars is enabled. 

GradientCaptionsKey ResourceKey 

(description) The ResourceKey for the GradientCaptions property. 

HighContrast x:Boolean 

(description) Information about the High Contrast accessibility feature. 
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HighContrastKey ResourceKey 

(description) The ResourceKey for the HighContrast property. 

HorizontalScrollBarButtonWidth x:Double 

(description) The width, in pixels, of the arrow bitmap on a horizontal 

scroll bar. 

HorizontalScrollBarButtonWidthKey ResourceKey 

(description) The ResourceKey for the HorizontalScrollBarButtonWidth 

property. 

HorizontalScrollBarHeight x:Double 

(description) The height of a horizontal scroll bar, in pixels. 

HorizontalScrollBarHeightKey ResourceKey 

(description) The ResourceKey for the HorizontalScrollBarHeight 

property. 

HorizontalScrollBarThumbWidth x:Double 

(description) The width, in pixels, of the Thumb in a horizontal scroll 

bar. 

HorizontalScrollBarThumbWidthKey ResourceKey 

(description) The ResourceKey for the HorizontalScrollBarThumbWidth 

property. 

HotTracking x:Boolean 

(description) A value indicating whether hot tracking of user-interface 

elements, such as menu names on menu bars, is enabled. 

HotTrackingKey ResourceKey 

(description) The ResourceKey for the HotTracking property. 

IconGridHeight x:Double 

(description) The height of a grid in which a large icon will fit. 

IconGridHeightKey ResourceKey 

(description) The ResourceKey for the IconGridHeight property. 

IconGridWidth x:Double 

(description) The width of a grid that a large icon will fit into. 

IconGridWidthKey ResourceKey 

(description) The ResourceKey for the IconGridWidth property. 
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IconHeight x:Double 

(description) The default height of an icon. 

IconHeightKey ResourceKey 

(description) The ResourceKey for the IconHeight property. 

IconHorizontalSpacing x:Double 

(description) The width, in pixels, of an icon cell. The system uses this 

rectangle to arrange icons in large icon view. 

IconHorizontalSpacingKey ResourceKey 

(description) The ResourceKey for the IconHorizontalSpacing property. 

IconTitleWrap x:Boolean 

(description) A value indicating whether icon-title wrapping is enabled. 

IconTitleWrapKey ResourceKey 

(description) The ResourceKey for the IconTitleWrap property. 

IconVerticalSpacing x:Double 

(description) The height, in pixels, of an icon cell. The system uses this 

rectangle to arrange icons in large icon view. 

IconVerticalSpacingKey ResourceKey 

(description) The ResourceKey for the IconVerticalSpacing property. 

IconWidth x:Double 

(description) The default width of an icon. 

IconWidthKey ResourceKey 

(description) The ResourceKey for the IconWidth property. 

IsGlassEnabled (4.5) x:Boolean 

(description) A value that indicates whether glass window frames are 

being used. 

IsImmEnabled x:Boolean 

(description) A value that indicates whether the system is ready to use a 

Unicode-based Input Method Editor (IME) on a Unicode 

application. 

IsImmEnabledKey ResourceKey 

(description) The ResourceKey for the IsImmEnabled property. 

IsMediaCenter x:Boolean 
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(description) A value that indicates whether the current system is a 

media center. 

IsMediaCenterKey ResourceKey 

(description) The ResourceKey for the IsMediaCenter property. 

IsMenuDropRightAligned x:Boolean 

(description) A value that indicates whether drop-down menus are right-

aligned with the corresponding menu item. 

IsMenuDropRightAlignedKey ResourceKey 

(description) The ResourceKey for the IsMenuDropRightAligned 

property. 

IsMiddleEastEnabled x:Boolean 

(description) A value that indicates whether the system is enabled for 

Hebrew and Arabic languages. 

IsMiddleEastEnabledKey ResourceKey 

(description) The ResourceKey for the IsMiddleEastEnabled property. 

IsMousePresent x:Boolean 

(description) A value that indicates whether a mouse is installed. 

IsMousePresentKey ResourceKey 

(description) The ResourceKey for the IsMousePresent property. 

IsMouseWheelPresent x:Boolean 

(description) A value that indicates whether the installed mouse has a 

vertical scroll wheel. 

IsMouseWheelPresentKey ResourceKey 

(description) The ResourceKey for the IsMouseWheelPresent property. 

IsPenWindows x:Boolean 

(description) A value that indicates whether a pen system is installed. 

IsPenWindowsKey ResourceKey 

(description) The ResourceKey for the IsPenWindows property. 

IsRemotelyControlled x:Boolean 

(description) A value that indicates whether the current session is 

remotely controlled. 

IsRemotelyControlledKey ResourceKey 
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(description) The ResourceKey for the IsRemotelyControlled property. 

IsRemoteSession x:Boolean 

(description) A value that indicates whether the calling process is 

associated with a Terminal Services client session. 

IsRemoteSessionKey ResourceKey 

(description) The ResourceKey for the IsRemoteSession property. 

IsSlowMachine x:Boolean 

(description) A value that indicates whether the computer has a low-end 

(slow) processor. 

IsSlowMachineKey ResourceKey 

(description) The ResourceKey for the IsSlowMachine property. 

IsTabletPC x:Boolean 

(description) A value that indicates whether the current system is a 

tablet. 

IsTabletPCKey ResourceKey 

(description) The ResourceKey for the IsTabletPC property. 

KanjiWindowHeight x:Double 

(description) A value that indicates the height, in pixels, of the kanji 

window at the bottom of the screen for systems that use 

double-byte characters. 

KanjiWindowHeightKey ResourceKey 

(description) The ResourceKey for the KanjiWindowHeight property. 

KeyboardCues x:Boolean 

(description) A value indicating whether menu access keys are always 

underlined. 

KeyboardCuesKey ResourceKey 

(description) The ResourceKey for the KeyboardCues property. 

KeyboardDelay x:Int32 

(description) The keyboard repeat-delay setting, which is a value in the 

range from 0 (approximately 250 milliseconds delay) 

through 3 (approximately 1 second delay). 

KeyboardDelayKey ResourceKey 

(description) The ResourceKey for the KeyboardDelay property. 
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KeyboardPreference x:Boolean 

(description) A value indicating whether the user relies on the keyboard 

instead of the mouse, and whether the user wants 

applications to display keyboard interfaces that are 

typically hidden. 

KeyboardPreferenceKey ResourceKey 

(description) The ResourceKey for the KeyboardPreference property. 

KeyboardSpeed x:Int32 

(description) The keyboard repeat-speed setting, which is a value in the 

range from 0 (approximately 2.5 repetitions per second) 

through 31 (approximately 30 repetitions per second). 

KeyboardSpeedKey ResourceKey 

(description) The ResourceKey for the KeyboardSpeed property. 

ListBoxSmoothScrolling x:Boolean 

(description) A value indicating whether the smooth-scrolling effect for 

list boxes is enabled. 

ListBoxSmoothScrollingKey ResourceKey 

(description) The ResourceKey for the ListBoxSmoothScrolling property. 

MaximizedPrimaryScreenHeight x:Double 

(description) A value that indicates the height, in pixels, of a maximized 

top-level window on the primary display monitor. 

MaximizedPrimaryScreenHeightKey ResourceKey 

(description) The ResourceKey for the MaximizedPrimaryScreenHeight 

property. 

MaximizedPrimaryScreenWidth x:Double 

(description) A value that indicates the width, in pixels, of a maximized 

top-level window on the primary display monitor. 

MaximizedPrimaryScreenWidthKey ResourceKey 

(description) The ResourceKey for the MaximizedPrimaryScreenWidth 

property. 

MaximumWindowTrackHeight x:Double 

(description) A value that indicates the maximum height, in pixels, of a 

window that has a caption and sizing borders. 

MaximumWindowTrackHeightKey ResourceKey 

(description) The ResourceKey for the MaximumWindowTrackHeight 
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property. 

MaximumWindowTrackWidth x:Double 

(description) A value that indicates the maximum width, in pixels, of a 

window that has a caption and sizing borders. 

MaximumWindowTrackWidthKey ResourceKey 

(description) The ResourceKey for the MaximumWindowTrackWidth 

property. 

MenuAnimation x:Boolean 

(description) A value indicating whether the menu animation feature is 

enabled. 

MenuAnimationKey ResourceKey 

(description) The ResourceKey for the MenuAnimation property. 

MenuBarHeight x:Double 

(description) A value that indicates the height, in pixels, of a single-line 

menu bar. 

MenuBarHeightKey ResourceKey 

(description) The ResourceKey for the MenuBarHeight property. 

MenuButtonHeight x:Double 

(description) A value that indicates the height, in pixels, of a menu bar 

button. 

MenuButtonHeightKey ResourceKey 

(description) The ResourceKey for the MenuButtonHeight property. 

MenuButtonWidth x:Double 

(description) A value that indicates the width, in pixels, of a menu bar 

button. 

MenuButtonWidthKey ResourceKey 

(description) The ResourceKey for the MenuButtonWidth property. 

MenuCheckmarkHeight x:Double 

(description) A value that indicates the height, in pixels, of the default 

menu check-mark bitmap. 

MenuCheckmarkHeightKey ResourceKey 

(description) The ResourceKey for the MenuCheckmarkHeight property. 

MenuCheckmarkWidth x:Double 
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(description) A value that indicates the width, in pixels, of the default 

menu check-mark bitmap. 

MenuCheckmarkWidthKey ResourceKey 

(description) The ResourceKey for the MenuCheckmarkWidth property. 

MenuDropAlignment x:Boolean 

(description) A value indicating whether pop-up menus are left-aligned 

or right-aligned, relative to the corresponding menu item. 

MenuDropAlignmentKey ResourceKey 

(description) The ResourceKey for the MenuDropAlignment property. 

MenuFade x:Boolean 

(description) A value indicating whether menu fade animation is 

enabled. 

MenuFadeKey ResourceKey 

(description) The ResourceKey for the MenuFade property. 

MenuHeight x:Double 

(description) The metric that determines the height of the menu. 

MenuHeightKey ResourceKey 

(description) The ResourceKey for the MenuHeight property. 

MenuPopupAnimation PopupAnimation 

(description) The system value of the PopupAnimation property for 

menus. 

MenuPopupAnimationKey ResourceKey 

(description) The ResourceKey for the MenuPopupAnimation property. 

MenuShowDelay x:Int32 

(description) The time, in milliseconds, that the system waits before 

displaying a shortcut menu when the mouse cursor is over 

a submenu item. 

MenuShowDelayKey ResourceKey 

(description) The ResourceKey for the MenuShowDelay property. 

MenuWidth x:Double 

(description) The metric that determines the width of the menu. 

MenuWidthKey ResourceKey 
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(description) The ResourceKey for the MenuWidth property. 

MinimizeAnimation x:Boolean 

(description) The animation effects associated with user actions. 

MinimizeAnimationKey ResourceKey 

(description) The ResourceKey for the MinimizeAnimation property. 

MinimizedGridHeight x:Double 

(description) A value that indicates the height, in pixels, of a grid cell for 

a minimized window. 

MinimizedGridHeightKey ResourceKey 

(description) The ResourceKey for the MinimizedGridHeight property. 

MinimizedGridWidth x:Double 

(description) A value that indicates the width, in pixels, of a grid cell for 

a minimized window. 

MinimizedGridWidthKey ResourceKey 

(description) The ResourceKey for the MinimizedGridWidth property. 

MinimizedWindowHeight x:Double 

(description) A value that indicates the height, in pixels, of a minimized 

window. 

MinimizedWindowHeightKey ResourceKey 

(description) The ResourceKey for the MinimizedWindowHeight property. 

MinimizedWindowWidth x:Double 

(description) A value that indicates the width, in pixels, of a minimized 

window. 

MinimizedWindowWidthKey ResourceKey 

(description) The ResourceKey for the MinimizedWindowWidth property. 

MinimumHorizontalDragDistance x:Double 

(description) The width of a rectangle centered on a drag point to allow 

for limited movement of the mouse pointer before a drag 

operation begins. 

MinimumVerticalDragDistance x:Double 

(description) The height of a rectangle centered on a drag point to allow 

for limited movement of the mouse pointer before a drag 

operation begins. 
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MinimumWindowHeight x:Double 

(description) A value that indicates the minimum height, in pixels, of a 

window. 

MinimumWindowHeightKey ResourceKey 

(description) The ResourceKey for the MinimumWindowHeight property. 

MinimumWindowTrackHeight x:Double 

(description) A value that indicates the minimum tracking height of a 

window, in pixels. 

MinimumWindowTrackHeightKey ResourceKey 

(description) The ResourceKey for the MinimumWindowTrackHeight 

property. 

MinimumWindowTrackWidth x:Double 

(description) A value that indicates the minimum tracking width of a 

window, in pixels. 

MinimumWindowTrackWidthKey ResourceKey 

(description) The ResourceKey for the MinimumWindowTrackWidth 

property. 

MinimumWindowWidth x:Double 

(description) A value that indicates the minimum width, in pixels, of a 

window. 

MinimumWindowWidthKey ResourceKey 

(description) The ResourceKey for the MinimumWindowWidth property. 

MouseHoverHeight x:Double 

(description) The height, in pixels, of the rectangle within which the 

mouse pointer has to stay to generate a mouse-hover 

event. 

MouseHoverHeightKey ResourceKey 

(description) The ResourceKey for the MouseHoverHeight property. 

MouseHoverTime x:TimeSpan 

(description) The time, in milliseconds, that the mouse pointer must 

remain in the hover rectangle to generate a mouse-hover 

event. 

MouseHoverTimeKey ResourceKey 

(description) The ResourceKey for the MouseHoverTime property. 
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MouseHoverWidth x:Double 

(description) The width, in pixels, of the rectangle within which the 

mouse pointer has to stay to generate a mouse-hover 

event. 

MouseHoverWidthKey ResourceKey 

(description) The ResourceKey for the MouseHoverWidth property. 

NavigationChromeDownLevelStyleKey ResourceKey 

(description) The ResourceKey for the 

NavigationChromeDownLevelStyleKey property. 

NavigationChromeStyleKey ResourceKey 

(description) The ResourceKey for the NavigationChromeStyleKey 

property. 

PowerLineStatus PowerLineStatus 

(description) A value indicating whether the system power is online, or 

that the system power status is unknown. 

PowerLineStatusKey ResourceKey 

(description) A ResourceKey for the PowerLineStatus property. 

PrimaryScreenHeight x:Double 

(description) A value that indicates the screen height, in pixels, of the 

primary display monitor. 

PrimaryScreenHeightKey ResourceKey 

(description) The ResourceKey for the PrimaryScreenHeight property. 

PrimaryScreenWidth x:Double 

(description) A value that indicates the screen width, in pixels, of the 

primary display monitor. 

PrimaryScreenWidthKey ResourceKey 

(description) The ResourceKey for the PrimaryScreenWidth property. 

ResizeFrameHorizontalBorderHeight x:Double 

(description) A value that indicates the height (thickness), in pixels, of 

the horizontal sizing border around the perimeter of a 

window that can be resized. 

ResizeFrameHorizontalBorderHeightKey ResourceKey 

(description) The ResourceKey for the 

ResizeFrameHorizontalBorderHeight property. 
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ResizeFrameVerticalBorderWidth x:Double 

(description) A value that indicates the width (thickness), in pixels, of 

the vertical sizing border around the perimeter of a window 

that can be resized. 

ResizeFrameVerticalBorderWidthKey ResourceKey 

(description) The ResourceKey for the ResizeFrameVerticalBorderWidth 

property. 

ScrollHeight x:Double 

(description) The metric that determines the scroll height of the 

nonclient area of a nonminimized window. 

ScrollHeightKey ResourceKey 

(description) The ResourceKey for the ScrollHeight property. 

ScrollWidth x:Double 

(description) The metric that determines the scroll width of the nonclient 

area of a nonminimized window. 

ScrollWidthKey ResourceKey 

(description) The ResourceKey for the ScrollWidth property. 

SelectionFade x:Boolean 

(description) A value indicating whether the selection fade effect is 

enabled. 

SelectionFadeKey ResourceKey 

(description) The ResourceKey for the SelectionFade property. 

ShowSounds x:Boolean 

(description) A value that indicates whether the user requires 

information in visual format. 

ShowSoundsKey ResourceKey 

(description) The ResourceKey for the ShowSounds property. 

SmallCaptionHeight x:Double 

(description) The metric that determines the height of the small caption 

of the nonclient area of a nonminimized window. 

SmallCaptionHeightKey ResourceKey 

(description) The ResourceKey for the SmallCaptionHeight property. 

SmallCaptionWidth x:Double 
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(description) The metric that determines the width of the small caption 

of the nonclient area of a nonminimized window. 

SmallCaptionWidthKey ResourceKey 

(description) The ResourceKey for the SmallCaptionWidth property. 

SmallIconHeight x:Double 

(description) A value that indicates the recommended height, in pixels, 

of a small icon. 

SmallIconHeightKey ResourceKey 

(description) The ResourceKey for the SmallIconHeight property. 

SmallIconWidth x:Double 

(description) A value that indicates the recommended width, in pixels, of 

a small icon. 

SmallIconWidthKey ResourceKey 

(description) The ResourceKey for the SmallIconWidth property. 

SmallWindowCaptionButtonHeight x:Double 

(description) A value that indicates the height, in pixels, of small caption 

buttons. 

SmallWindowCaptionButtonHeightKey ResourceKey 

(description) The ResourceKey for the SmallWindowCaptionButtonHeight 

property. 

SmallWindowCaptionButtonWidth x:Double 

(description) A value that indicates the width, in pixels, of small caption 

buttons. 

SmallWindowCaptionButtonWidthKey ResourceKey 

(description) The ResourceKey for the SmallWindowCaptionButtonWidth 

property. 

SnapToDefaultButton x:Boolean 

(description) A value indicating whether the snap-to-default button is 

enabled. If enabled, the mouse cursor automatically moves 

to the default button of a dialog box, such as OK or Apply. 

SnapToDefaultButtonKey ResourceKey 

(description) The ResourceKey for the SnapToDefaultButton property. 

StylusHotTracking x:Boolean 

(description) A value indicating whether hot tracking of a stylus is 
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enabled. 

StylusHotTrackingKey ResourceKey 

(description) The ResourceKey for the StylusHotTracking property. 

SwapButtons x:Boolean 

(description) A value that indicates whether the functionality of the left 

and right mouse buttons are swapped. 

SwapButtonsKey ResourceKey 

(description) The ResourceKey for the SwapButtons property. 

ThickHorizontalBorderHeight x:Double 

(description) A value that indicates the height, in pixels, of a 3-D 

border. 

ThickHorizontalBorderHeightKey ResourceKey 

(description) The ResourceKey for the ThickHorizontalBorderHeight 

property. 

ThickVerticalBorderWidth x:Double 

(description) A value that indicates the width, in pixels, of a 3-D border. 

ThickVerticalBorderWidthKey ResourceKey 

(description) The ResourceKey for the ThickVerticalBorderWidth 

property. 

ThinHorizontalBorderHeight x:Double 

(description) A value that indicates the height, in pixels, of a horizontal 

window border. 

ThinHorizontalBorderHeightKey ResourceKey 

(description) The ResourceKey for the ThinHorizontalBorderHeight 

property. 

ThinVerticalBorderWidth x:Double 

(description) A value that indicates the width, in pixels, of a vertical 

window border. 

ThinVerticalBorderWidthKey ResourceKey 

(description) The ResourceKey for the ThinVerticalBorderWidth property. 

ToolTipAnimation x:Boolean 

(description) A value indicating whether ToolTip animation is enabled. 

ToolTipAnimationKey ResourceKey 



 

533 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) {x:Static SystemParameters.StaticPropertyName} 

(description) The ResourceKey for the ToolTipAnimation property. 

ToolTipFade x:Boolean 

(description) A value indicating whether ToolTip animation uses a fade 

effect or a slide effect. 

ToolTipFadeKey ResourceKey 

(description) The ResourceKey for the ToolTipFade property. 

ToolTipPopupAnimation PopupAnimation 

(description) The system value of the PopupAnimation property for 

ToolTips. 

ToolTipPopupAnimationKey ResourceKey 

(description) The ResourceKey for the ToolTipPopupAnimation property. 

UIEffects x:Boolean 

(description) A value that indicates whether all user interface (UI) 

effects are enabled. 

UIEffectsKey ResourceKey 

(description) The ResourceKey for the UIEffects property. 

UxThemeColor (4.5) x:String 

(description) The color theme name. 

UxThemeName (4.5) x:String 

(description) The theme name. 

VerticalScrollBarButtonHeight x:Double 

(description) A value that indicates the height, in pixels, of the arrow 

bitmap on a vertical scroll bar. 

VerticalScrollBarButtonHeightKey ResourceKey 

(description) The ResourceKey for the VerticalScrollBarButtonHeight 

property. 

VerticalScrollBarThumbHeight x:Double 

(description) A value that indicates the height, in pixels, of the thumb in 

a vertical scroll bar. 

VerticalScrollBarThumbHeightKey ResourceKey 

(description) The ResourceKey for the VerticalScrollBarThumbHeight 

property. 

VerticalScrollBarWidth x:Double 
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(usage) {x:Static SystemParameters.StaticPropertyName} 

(description) A value that indicates the width, in pixels, of a vertical 

scroll bar. 

VerticalScrollBarWidthKey ResourceKey 

(description) The ResourceKey for the VerticalScrollBarWidth property. 

VirtualScreenHeight x:Double 

(description) A value that indicates the height, in pixels, of the virtual 

screen. 

VirtualScreenHeightKey ResourceKey 

(description) The ResourceKey for the VirtualScreenHeight property. 

VirtualScreenLeft x:Double 

(description) A value that indicates the coordinate for the left side of the 

virtual screen. 

VirtualScreenLeftKey ResourceKey 

(description) The ResourceKey for the VirtualScreenLeft property. 

VirtualScreenTop x:Double 

(description) A value that indicates the upper coordinate of the virtual 

screen. 

VirtualScreenTopKey ResourceKey 

(description) The ResourceKey for the VirtualScreenTop property. 

VirtualScreenWidth x:Double 

(description) A value that indicates the width, in pixels, of the virtual 

screen. 

VirtualScreenWidthKey ResourceKey 

(description) The ResourceKey for the VirtualScreenWidth property. 

WheelScrollLines x:Int32 

(description) A value that indicates the number of lines to scroll when 

the mouse wheel is rotated. 

WheelScrollLinesKey ResourceKey 

(description) The ResourceKey for the WheelScrollLines property. 

WindowCaptionButtonHeight x:Double 

(description) A value that indicates the height, in pixels, of a button in 

the title bar of a window. 

WindowCaptionButtonHeightKey ResourceKey 
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(usage) {x:Static SystemParameters.StaticPropertyName} 

(description) The ResourceKey for the WindowCaptionButtonHeight 

property. 

WindowCaptionButtonWidth x:Double 

(description) A value that indicates the width, in pixels, of a button in 

the title bar of a window. 

WindowCaptionButtonWidthKey ResourceKey 

(description) The ResourceKey for the WindowCaptionButtonWidth 

property. 

WindowCaptionHeight x:Double 

(description) A value that indicates the height, in pixels, of a caption 

area. 

WindowCaptionHeightKey ResourceKey 

(description) The ResourceKey for the WindowCaptionHeight property. 

WindowCornerRadius (4.5) CornerRadius 

(description) The radius of the corners for a window. 

WindowGlassBrush (4.5) Brush 

(description) The brush that paints the glass window frame. 

WindowGlassColor (4.5) Color 

(description) The color that is used to paint the glass window frame. 

WindowNonClientFrameThickness (4.5) Thickness 

(description) The size of the non-client area of the window. 

WindowResizeBorderThickness (4.5) Thickness 

(description) The size of the resizing border around the window. 

WorkArea Rect 

(description) The size of the work area on the primary display monitor. 

WorkAreaKey ResourceKey 

(description) The ResourceKey for the WorkArea property. 

4.861   TabControl 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > Selector > TabControl, IInputElement 

(usage) <TabControl>x:Object*</TabControl> 
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(usage) <TabControl>x:Object*</TabControl> 

(description) Represents a control that contains multiple items that share the same 

space on the screen. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

ContentStringFormat x:String 

(description) A composite string that specifies how to format the contents of the TabItem 

objects if they are displayed as strings. 

ContentTemplate DataTemplate 

(description) The DataTemplate to apply to any TabItem that does not have a 

ContentTemplate or ContentTemplateSelector property defined. 

ContentTemplateSelector DataTemplateSelector 

(description) A DataTemplateSelector that provides custom logic for choosing the 

template that is used to display the content of the control. 

TabStripPlacement Dock 

(description) How tab headers align relative to the tab content. 

4.862   TabItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > HeaderedContentControl > TabItem, IInputElement 

(usage) <TabItem>x:Object</TabItem> 

(description) Represents a selectable item inside a TabControl. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

IsSelected x:Boolean 

(description) A value that indicates whether the TabItem is selected. 

4.863   Table 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
Block > Table, IInputElement 
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(usage) <Table>TableRowGroup*</Table> 

(description) A block-level flow content element that provides a grid-based presentation 

organized by rows and columns. 

[content 

property] 

RowGroups 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

CellSpacing x:Double 

(description) The amount of spacing between cells in a table. 

[text syntax] LengthSyntax 

Columns TableColumnCollection 

(description) A TableColumnCollection object that contains the columns hosted by the table. 

[read only] true 

RowGroups TableRowGroupCollection 

(description) A TableRowGroupCollection collection object that contains the row groups hosted by 

the table. 

[read only] true 

4.864   TableCell 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
TableCell, IInputElement 

(usage) <TableCell>Block*</TableCell> 

(description) A flow content element that defines a cell of content within a Table. 

(used by) TableCellCollection 

[content property] Blocks 

[name property] Name 

[xml lang property] Language 

(properties)  

Blocks BlockCollection 

(description) A BlockCollection containing the top-level Block elements that comprise the 

contents of the TableCell. 

[read only] true 
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(usage) <TableCell>Block*</TableCell> 

BorderBrush Brush 

(description) A Brush to use when painting the element's border. 

BorderThickness Thickness 

(description) The border thickness for the element. 

ColumnSpan x:Int32 

(description) The number of columns that the TableCell should span. 

FlowDirection FlowDirection 

(description) A value that specifies the relative direction for flow of content within a TableCell 

element. 

LineHeight x:Double 

(description) The height of each line of content. 

[text syntax] LengthSyntax 

LineStackingStrategy LineStackingStrategy 

(description) The mechanism by which a line box is determined for each line of text within 

the TableCell. 

Padding Thickness 

(description) The padding thickness for the element. 

RowSpan x:Int32 

(description) The number of rows that the TableCell should span. 

TextAlignment TextAlignment 

(description) A value that indicates the horizontal alignment of text content. 

4.865   TableCellCollection 

x:Object > TableCellCollection 

(usage) None. 

(description) Provides standard facilities for creating and managing a type-safe, ordered 

collection of TableCell objects. 

(used by) TableRow 

[is default 

constructible] 

false 

[is list] true 

[allowed types] TableCell 
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(usage) None. 

(properties)  

Capacity x:Int32 

(description) The preallocated collection item capacity for this collection. 

4.866   TableColumn 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TableColumn, 
IInputElement 

(usage) <TableColumn /> 

(description) A flow content element that defines a column within a Table. 

(used by) TableColumnCollection 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

Background Brush 

(description) The background Brush used to fill the content of the TableColumn. 

Width GridLength 

(description) The width of a TableColumn element. The Width property measures the sum of the 

TableColumn content, padding, and border from side to side. 

4.867   TableColumnCollection 

x:Object > TableColumnCollection 

(usage) None. 

(description) Provides standard facilities for creating and managing a type-safe, ordered 

collection of TableColumn objects. 

(used by) Table 

[is default 

constructible] 

false 

[is list] true 

[allowed types] TableColumn 

(properties)  

Capacity x:Int32 
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(usage) None. 

(description) The pre-allocated collection item capacity for this collection. 

4.868   TableRow 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 
TableRow, IInputElement 

(usage) <TableRow>TableCell*</TableRow> 

(description) A flow content element that defines a row within a Table. 

(used by) TableRowCollection 

[content property] Cells 

[name property] Name 

[xml lang property] Language 

(properties)  

Cells TableCellCollection 

(description) A TableCellCollection that contains cells of a TableRow. 

[read only] true 

4.869   TableRowCollection 

x:Object > TableRowCollection 

(usage) None. 

(description) Provides standard facilities for creating and managing a type-safe, ordered 

collection of TableRow objects. 

(used by) TableRowGroup 

[is default 

constructible] 

false 

[is list] true 

[allowed types] TableRow 

(properties)  

Capacity x:Int32 

(description) The pre-allocated collection item capacity for this collection. 

4.870   TableRowGroup 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 

TableRowGroup, IInputElement 
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(usage) <TableRowGroup>TableRow*</TableRowGroup> 

(description) Represents a flow content element used to group TableRow elements within a Table. 

(used by) TableRowGroupCollection 

[content 

property] 

Rows 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Rows TableRowCollection 

(description) A TableRowCollection that contains the TableRow objects that comprise the contents 

of the TableRowGroup. 

[read only] true 

4.871   TableRowGroupCollection 

x:Object > TableRowGroupCollection 

(usage) None. 

(description) Provides standard facilities for creating and managing a type-safe, ordered 

collection of TableRowGroup objects. 

(used by) Table 

[is default 

constructible] 

false 

[is list] true 

[allowed types] TableRowGroup 

(properties)  

Capacity x:Int32 

(description) The pre-allocated collection item capacity for this collection. 

4.872   TabletDeviceType 

x:Object > TabletDeviceType 

(usage) Stylus| Touch 

(description) Defines values for the type of devices the tablet device uses. 

[is nullable] false 
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(usage) Stylus| Touch 

[text syntax] TabletDeviceTypeSyntax 

4.873   TabletHardwareCapabilities 

x:Object > TabletHardwareCapabilities 

(usage) None| Integrated| StylusMustTouch| HardProximity| StylusHasPhysicalIds| 

SupportsPressure 

(description) Defines values that specify the hardware capabilities of a tablet device, including desktop 

digitizers and mice. 

[is nullable] false 

[text 

syntax] 

TabletHardwareCapabilitiesSyntax 

4.874   TabPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > TabPanel, 
IInputElement 

(usage) <TabPanel>UIElement*</TabPanel> 

(description) Handles the layout of the TabItem objects on a TabControl. 

[content property] Children 

[name property] Name 

[xml lang property] Language 

4.875   TaskbarItemInfo 

x:Object > DependencyObject > Freezable > TaskbarItemInfo 

(usage) <TaskbarItemInfo /> 

(description) Represents information about how the taskbar thumbnail is displayed. 

(used by) Window 

(properties)  

Description x:String 

(description) The text for the taskbar item tooltip. 

Overlay ImageSource 

(description) The image that is displayed over the program icon in the taskbar button. 

ProgressState TaskbarItemProgressState 
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(usage) <TaskbarItemInfo /> 

(description) A value that indicates how the progress indicator is displayed in the taskbar 

button. 

ProgressValue x:Double 

(description) A value that indicates the fullness of the progress indicator in the taskbar 

button. 

ThumbButtonInfos ThumbButtonInfoCollection 

(description) The collection of ThumbButtonInfo objects that are associated with the Window. 

ThumbnailClipMargin Thickness 

(description) A value that specifies the part of the application window's client area that is 

displayed in the taskbar thumbnail. 

4.876   TaskbarItemProgressState 

x:Object > TaskbarItemProgressState 

(usage) None| Indeterminate| Normal| Error| Paused 

(description) Specifies the state of the progress indicator in the Windows taskbar. 

(used by) TaskbarItemInfo 

[is nullable] false 

[text syntax] TaskbarItemProgressStateSyntax 

4.877   TemplateBindingExtension 

x:Object > x:MarkupExtension > TemplateBindingExtension 

(usage) {TemplateBinding } | <TemplateBinding /> 

(description) Implements a markup extension that supports the binding between the value of 

a property in a template and the value of some other exposed property on the 

templated control. 

[return value type] x:Object 

[constructors]  

(1 parameter)  

property DependencyProperty 

(description) The identifier of the property being bound. 

(properties)  

Converter IValueConverter 
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(usage) {TemplateBinding } | <TemplateBinding /> 

(description) The converter that interprets between source and target of a binding. 

ConverterParameter x:Object 

(description) The parameter to pass to the converter. 

Property DependencyProperty 

(description) The property being bound to. 

4.878   TemplateKey 

x:Object > x:MarkupExtension > ResourceKey > TemplateKey 

DataTemplateKey ItemContainerTemplateKey 

(usage) None. 

(description) When used as a resource key for a data template, allows the data template to 

participate in the lookup process. 

[is default 

constructible] 

false 

[return value type] ResourceKey 

(properties)  

DataType x:Object 

(description) The type for which the template is designed. 

4.879   TextAlignment 

x:Object > TextAlignment 

(usage) Left| Right| Center| Justify 

(description) Specifies whether the text in the object is left-aligned, right-aligned, centered, or 

justified. 

(used by) AccessText AnchoredBlock Block FlowDocument ListItem RibbonTwoLineText TableCell 

TextBlock TextBox 

[is nullable] false 

[text 

syntax] 

TextAlignmentSyntax 

4.880   TextBlock 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > TextBlock, 
IInputElement 
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(usage) <TextBlock>[Inline|UIElement|x:String]*</TextBlock> 

(description) Provides a lightweight control for displaying small amounts of flow 

content. 

[content property] Inlines 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) The Brush used to fill the background of content area. 

BaselineOffset x:Double 

(description) The amount by which each line of text is offset from the baseline. 

FontFamily FontFamily 

(description) The preferred top-level font family for the TextBlock. 

FontSize x:Double 

(description) The top-level font size for the TextBlock. 

[text syntax] FontSizeSyntax 

FontStretch FontStretch 

(description) The top-level font-stretching characteristics for the TextBlock. 

FontStyle FontStyle 

(description) The top-level font style for the TextBlock. 

FontWeight FontWeight 

(description) The top-level font weight for the TextBlock. 

Foreground Brush 

(description) The Brush to apply to the text contents of the TextBlock. 

Inlines InlineCollection 

(description) An InlineCollection containing the top-level Inline elements that 

comprise the contents of the TextBlock. 

[read only] true 

IsHyphenationEnabled x:Boolean 

(description) A value that indicates whether automatic hyphenation of words is 

enabled or disabled. 

LineHeight x:Double 
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(usage) <TextBlock>[Inline|UIElement|x:String]*</TextBlock> 

(description) The height of each line of content. 

[text syntax] LengthSyntax 

LineStackingStrategy LineStackingStrategy 

(description) The mechanism by which a line box is determined for each line of 

text within the TextBlock. 

Padding Thickness 

(description) A value that indicates the thickness of padding space between the 

boundaries of the content area, and the content displayed by a 

TextBlock. 

Text x:String 

(description) The text contents of a TextBlock. 

TextAlignment TextAlignment 

(description) A value that indicates the horizontal alignment of text content. 

TextDecorations TextDecorationCollection 

(description) A TextDecorationCollection that contains the effects to apply to the 

text of a TextBlock. 

TextEffects TextEffectCollection 

(description) The effects to apply to the text content in this element. 

TextTrimming TextTrimming 

(description) The text trimming behavior to employ when content overflows the 

content area. 

TextWrapping TextWrapping 

(description) How the TextBlock should wrap text. 

(attachable properties)  

TextBlock.BaselineOffset x:Double 

(description) The amount by which each line of text is offset from the baseline. 

[target type] DependencyObject 

TextBlock.FontFamily FontFamily 

(description) The preferred top-level font family for the TextBlock. 

[target type] DependencyObject 

TextBlock.FontSize x:Double 

(description) The top-level font size for the TextBlock. 
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(usage) <TextBlock>[Inline|UIElement|x:String]*</TextBlock> 

[target type] DependencyObject 

[text syntax] FontSizeSyntax 

TextBlock.FontStretch FontStretch 

(description) The top-level font-stretching characteristics for the TextBlock. 

[target type] DependencyObject 

TextBlock.FontStyle FontStyle 

(description) The top-level font style for the TextBlock. 

[target type] DependencyObject 

TextBlock.FontWeight FontWeight 

(description) The top-level font weight for the TextBlock. 

[target type] DependencyObject 

TextBlock.Foreground Brush 

(description) The Brush to apply to the text contents of the TextBlock. 

[target type] DependencyObject 

TextBlock.LineHeight x:Double 

(description) The height of each line of content. 

[target type] DependencyObject 

[text syntax] LengthSyntax 

TextBlock.LineStackingStrategy LineStackingStrategy 

(description) The mechanism by which a line box is determined for each line of 

text within the TextBlock. 

[target type] DependencyObject 

TextBlock.TextAlignment TextAlignment 

(description) A value that indicates the horizontal alignment of text content. 

[target type] DependencyObject 

4.881   TextBox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

TextBoxBase > TextBox, IInputElement 

DatePickerTextBox RibbonTextBox 

(usage) <TextBox>x:String</TextBox> 
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DatePickerTextBox RibbonTextBox 

(description) Represents a control that can be used to display or edit unformatted text. 

[content property] Text 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

CaretIndex x:Int32 

(description) The insertion position index of the caret. 

CharacterCasing CharacterCasing 

(description) How characters are cased when they are manually entered into the text box. 

MaxLength x:Int32 

(description) The maximum number of characters that can be manually entered into the text 

box. 

MaxLines x:Int32 

(description) The maximum number of visible lines. 

MinLines x:Int32 

(description) The minimum number of visible lines. 

SelectedText x:String 

(description) The content of the current selection in the text box. 

SelectionLength x:Int32 

(description) A value indicating the number of characters in the current selection in the text 

box. 

SelectionStart x:Int32 

(description) A character index for the beginning of the current selection. 

Text x:String 

(description) The text contents of the text box. 

TextAlignment TextAlignment 

(description) The horizontal alignment of the contents of the text box. 

TextDecorations TextDecorationCollection 

(description) The text decorations to apply to the text box. 

TextWrapping TextWrapping 
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DatePickerTextBox RibbonTextBox 

(description) How the text box should wrap text. 

4.882   TextBoxBase 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
TextBoxBase, IInputElement 

RichTextBox TextBox 

(usage) None. 

(description) A base type that provides functionality for text editing controls. 

[is default constructible] false 

[name property] Name 

[xml lang property] Language 

(properties)  

AcceptsReturn x:Boolean 

(description) A value that indicates how the text editing control responds 

when the user presses the ENTER key. 

AcceptsTab x:Boolean 

(description) A value that indicates how the text editing control responds 

when the user presses the TAB key. 

AutoWordSelection x:Boolean 

(description) A value that determines whether when a user selects part of a 

word by dragging across it with the mouse, the rest of the 

word is selected. 

CaretBrush Brush 

(description) The brush that is used to paint the caret of the text box. 

HorizontalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates whether a horizontal scroll bar is shown. 

IsInactiveSelectionHighlightEnabled x:Boolean 

(description)  

IsReadOnly x:Boolean 

(description) A value that indicates whether the text editing control is read-

only to a user interacting with the control. 

IsReadOnlyCaretVisible x:Boolean 

(description) A value that indicates whether a read-only text box displays a 
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RichTextBox TextBox 

caret. 

IsUndoEnabled x:Boolean 

(description) A value that indicates whether undo support is enabled for the 

text-editing control. 

SelectionBrush Brush 

(description) The brush that highlights selected text. 

SelectionOpacity x:Double 

(description) The opacity of the SelectionBrush. 

UndoLimit x:Int32 

(description) The number of actions stored in the undo queue. 

VerticalScrollBarVisibility ScrollBarVisibility 

(description) A value that indicates whether a vertical scroll bar is shown. 

(events)  

SelectionChanged Occurs when the text selection has changed. 

TextChanged Occurs when content changes in the text element. 

4.883   TextCollapsingStyle 

x:Object > TextCollapsingStyle 

(usage) TrailingCharacter| TrailingWord 

(description) Specifies the style of collapsed text. 

[is nullable] false 

[text syntax] TextCollapsingStyleSyntax 

4.884   TextCompositionAutoComplete 

x:Object > TextCompositionAutoComplete 

(usage) Off| On 

(description) Defines a set of states for the handling of automatic completion of a text composition. 

[is nullable] false 

[text syntax] TextCompositionAutoCompleteSyntax 
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4.885   TextDataFormat 

x:Object > TextDataFormat 

(usage) Text| UnicodeText| Rtf| Html| CommaSeparatedValue| Xaml 

(description) Specifies the data format of the text data. 

[is nullable] false 

[text syntax] TextDataFormatSyntax 

4.886   TextDecoration 

x:Object > DependencyObject > Freezable > Animatable > TextDecoration 

(usage) Baseline| OverLine| Strikethrough| Underline 

(description) Represents a text decoration, which a visual ornamentation that is added to text 

(such as an underline). 

(used by) TextDecorationCollection 

(properties)  

Location TextDecorationLocation 

(description) The vertical location at which the text decoration is drawn. 

Pen Pen 

(description) The Pen used to draw the text decoration. 

PenOffset x:Double 

(description) The text decoration's offset from its Location. 

PenOffsetUnit TextDecorationUnit 

(description) The units in which the PenOffset value is expressed. 

PenThicknessUnit TextDecorationUnit 

(description) The units in which the Thickness of the text decoration's Pen is expressed. 

4.887   TextDecorationCollection 

x:Object > DependencyObject > Freezable > Animatable > TextDecorationCollection 

(usage) <TextDecorationCollection> string </TextDecorationCollection> 

(description) Represents a collection of TextDecoration instances. 

(used by) AccessText Inline Paragraph RibbonTwoLineText TextBlock TextBox 

[text syntax] TextDecorationCollectionSyntax 
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(usage) <TextDecorationCollection> string </TextDecorationCollection> 

[is list] true 

[allowed types] TextDecoration 

4.888   TextDecorationLocation 

x:Object > TextDecorationLocation 

(usage) Underline| OverLine| Strikethrough| Baseline 

(description) Specifies the vertical position of a TextDecoration object. 

(used by) TextDecoration 

[is nullable] false 

[text syntax] TextDecorationLocationSyntax 

4.889   TextDecorations 

x:Object > TextDecorations 

(usage) {x:Static TextDecorations.StaticPropertyName} 

(description) Provides a set of static predefined text decorations. 

[is default constructible] false 

(static properties)  

Baseline TextDecorationCollection 

(description) Specifies a baseline TextDecoration. 

OverLine TextDecorationCollection 

(description) Specifies an overline TextDecoration. 

Strikethrough TextDecorationCollection 

(description) Specifies a strikethrough TextDecoration. 

Underline TextDecorationCollection 

(description) Specifies an underline TextDecoration. 

4.890   TextDecorationUnit 

x:Object > TextDecorationUnit 

(usage) FontRecommended| FontRenderingEmSize| Pixel 

(description) Specifies the unit type of either a TextDecoration PenOffset or a Pen thickness value. 
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(usage) FontRecommended| FontRenderingEmSize| Pixel 

(used by) TextDecoration 

[is nullable] false 

[text syntax] TextDecorationUnitSyntax 

4.891   TextEffect 

x:Object > DependencyObject > Freezable > Animatable > TextEffect 

(usage) <TextEffect /> 

(description) Represents a text effect that can be applied to text objects. 

(used by) TextEffectCollection 

(properties)  

Clip Geometry 

(description) The clipping region of the TextEffect. 

Foreground Brush 

(description) The Brush to apply to the content of the TextEffect. 

PositionCount x:Int32 

(description) The position in the text that the TextEffect applies to. 

PositionStart x:Int32 

(description) The starting position in the text that the TextEffect applies to. 

Transform Transform 

(description) The Transform that is applied to the TextEffect. 

4.892   TextEffectCollection 

x:Object > DependencyObject > Freezable > Animatable > TextEffectCollection 

(usage) <TextEffectCollection>TextEffect*</TextEffectCollection> 

(description) Provides collection support for a collection of TextEffect objects. 

(used by) AccessText FlowDocument RibbonTwoLineText TextBlock TextElement 

[is list] true 

[allowed types] TextEffect 
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4.893   TextElement 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement, 
IInputElement 

Block Inline ListItem TableCell TableRow TableRowGroup 

(usage) None. 

(description) A base type for elements that contain text. 

[is default constructible] false 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) The Brush used to fill the background of the content area. 

FontFamily FontFamily 

(description) The preferred top-level font family for the content of the element. 

FontSize x:Double 

(description) The font size for the content of the element. 

[text syntax] FontSizeSyntax 

FontStretch FontStretch 

(description) The font-stretching characteristics for the content of the element. 

FontStyle FontStyle 

(description) The font style for the content of the element. 

FontWeight FontWeight 

(description) The top-level font weight for the content of the element. 

Foreground Brush 

(description) The Brush to apply to the content of the element. 

TextEffects TextEffectCollection 

(description) A collection of text effects to apply to the content of the element. 

(attachable properties)  

TextElement.FontFamily FontFamily 

(description) The preferred top-level font family for the content of the element. 

[target type] DependencyObject 
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Block Inline ListItem TableCell TableRow TableRowGroup 

TextElement.FontSize x:Double 

(description) The font size for the content of the element. 

[target type] DependencyObject 

[text syntax] FontSizeSyntax 

TextElement.FontStretch FontStretch 

(description) The font-stretching characteristics for the content of the element. 

[target type] DependencyObject 

TextElement.FontStyle FontStyle 

(description) The font style for the content of the element. 

[target type] DependencyObject 

TextElement.FontWeight FontWeight 

(description) The top-level font weight for the content of the element. 

[target type] DependencyObject 

TextElement.Foreground Brush 

(description) The Brush to apply to the content of the element. 

[target type] DependencyObject 

4.894   TextElementCollection(T) 

x:Object > TextElementCollection(T) 

(usage) None. 

(description) Provides standard facilities for creating and managing a type-safe, ordered 

collection of TextElement objects. This is a generic collection for working with 

objects of a specified type that derives from TextElement. 

[is default 

constructible] 

false 

[is list] true 

[allowed types] T 

4.895   TextFormattingMode 

x:Object > TextFormattingMode 

(usage) Display| Ideal 
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(usage) Display| Ideal 

(description) Defines the formatting methods supported by the TextFormatter type. 

(used by) TextOptions 

[is nullable] false 

[text syntax] TextFormattingModeSyntax 

4.896   TextHintingMode 

x:Object > TextHintingMode 

(usage) Auto| Fixed| Animated 

(description) Defines the rendering behavior of static or animated text. 

(used by) TextOptions 

[is nullable] false 

[text syntax] TextHintingModeSyntax 

4.897   TextMarkerStyle 

x:Object > TextMarkerStyle 

(usage) None| Disc| Circle| Square| Box| LowerRoman| UpperRoman| LowerLatin| 

UpperLatin... 

(description) Describes the appearance of a list item's bullet style. 

(used by) List 

[is nullable] false 

[text 

syntax] 

TextMarkerStyleSyntax 

4.898   TextOptions 

x:Object > TextOptions 

(usage) None. 

(description) Defines a set of attached properties that affect the way text is 

displayed in an element. 

[is default constructible] false 

(attachable properties)  

TextOptions.TextFormattingMode TextFormattingMode 

(description) The TextFormattingMode for the element. This is an attached 
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(usage) None. 

property. 

[target type] DependencyObject 

TextOptions.TextHintingMode TextHintingMode 

(description) The TextHintingMode for the element. This is an attached 

property. 

[target type] DependencyObject 

TextOptions.TextRenderingMode TextRenderingMode 

(description) The TextRenderingMode for the element. This is an attached 

property. 

[target type] DependencyObject 

4.899   TextPointerContext 

x:Object > TextPointerContext 

(usage) None| Text| EmbeddedElement| ElementStart| ElementEnd 

(description) Determines the category of content that is adjacent to a TextPointer in a specified 

LogicalDirection. 

[is nullable] false 

[text 

syntax] 

TextPointerContextSyntax 

4.900   TextRenderingMode 

x:Object > TextRenderingMode 

(usage) Auto| Aliased| Grayscale| ClearType 

(description) Defines the supported rendering modes for text. 

(used by) TextOptions 

[is nullable] false 

[text syntax] TextRenderingModeSyntax 

4.901   TextRunCache 

x:Object > TextRunCache 

(usage) <TextRunCache /> 

(description) Provides caching services to the TextFormatter object in order to improve performance. 
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4.902   TextSearch 

x:Object > DependencyObject > TextSearch 

(usage) None. 

(description) Enables a user to quickly access items in a set by typing prefixes of strings. 

[is default 

constructible] 

false 

(attachable properties)  

TextSearch.Text x:String 

(description) The string that identifies an item in a control's collection. 

[target type] DependencyObject 

TextSearch.TextPath x:String 

(description) The name of the items' property that identifies each item in a control's 

collection. 

[target type] DependencyObject 

4.903   TextTabAlignment 

x:Object > TextTabAlignment 

(usage) Left| Center| Right| Character 

(description) Describes how text is aligned at a tab location. 

[is nullable] false 

[text syntax] TextTabAlignmentSyntax 

4.904   TextTrimming 

x:Object > TextTrimming 

(usage) None| CharacterEllipsis| WordEllipsis 

(description) Describes how text is trimmed when it overflows the edge of its containing box. 

(used by) AccessText RibbonTwoLineText TextBlock 

[is nullable] false 

[text syntax] TextTrimmingSyntax 

4.905   TextWrapping 

x:Object > TextWrapping 
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(usage) WrapWithOverflow| NoWrap| Wrap 

(description) Specifies whether text wraps when it reaches the edge of the containing box 

(used by) AccessText TextBlock TextBox 

[is nullable] false 

[text syntax] TextWrappingSyntax 

4.906   ThemeDictionaryExtension 

x:Object > x:MarkupExtension > ThemeDictionaryExtension 

(usage) {ThemeDictionary } | <ThemeDictionary /> 

(description) Implements a markup extension that enables application authors to customize 

control styles based on the current system theme. 

[return value 

type] 

x:Uri 

[constructors]  

(1 parameter)  

assemblyName x:String 

(description) The assembly name string. 

(properties)  

AssemblyName x:String 

(description) A particular naming convention to identify which dictionary applies for a particular 

theme. 

4.907   Thickness 

x:Object > Thickness 

(usage) <Thickness> string </Thickness> 

(description) Describes the thickness of a frame around a rectangle. Four Double values describe the 

Left, Top, Right, and Bottom sides of the rectangle, respectively. 

(used by) AnchoredBlock Block Border Control FlowDocument FrameworkElement ListItem 

RibbonTwoLineText TableCell TaskbarItemInfo TextBlock ThicknessKeyFrame 

WindowChrome 

[is nullable] false 

[text 

syntax] 

ThicknessSyntax 

(properties)  
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(usage) <Thickness> string </Thickness> 

Bottom x:Double 

(description) The width, in pixels, of the lower side of the bounding rectangle. 

Left x:Double 

(description) The width, in pixels, of the left side of the bounding rectangle. 

Right x:Double 

(description) The width, in pixels, of the right side of the bounding rectangle. 

Top x:Double 

(description) The width, in pixels, of the upper side of the bounding rectangle. 

4.908   ThicknessAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

ThicknessAnimationBase > ThicknessAnimation 

(usage) <ThicknessAnimation /> 

(description) Animates the value of a  Thickness property between two target values using  linear 

interpolation over a specified Duration. 

[name 

property] 

Name 

(properties)  

By x:Nullable(Thickness) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Thickness) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Thickness) 

(description) The animation's ending value. 
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4.909   ThicknessAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
ThicknessAnimationBase 

ThicknessAnimation ThicknessAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Thickness value. 

[is default constructible] false 

[name property] Name 

4.910   ThicknessAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

ThicknessAnimationBase > ThicknessAnimationUsingKeyFrames 

(usage) <ThicknessAnimationUsingKeyFrames>ThicknessKeyFrame*</ThicknessAnimationUsingKeyF

rames> 

(description

) 

Animates the value of a Thickness property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description

) 

A value that specifies whether the animation's output value is added to the base value of the 

property being animated. 

IsCumulativ

e 

x:Boolean 

(description

) 

A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames ThicknessKeyFrameCollection 

(description

) 

The collection of ThicknessKeyFrame objects that define the animation. 

4.911   ThicknessKeyFrame 

x:Object > DependencyObject > Freezable > ThicknessKeyFrame 

DiscreteThicknessKeyFrame EasingThicknessKeyFrame LinearThicknessKeyFrame 

SplineThicknessKeyFrame 
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DiscreteThicknessKeyFrame EasingThicknessKeyFrame LinearThicknessKeyFrame 

SplineThicknessKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a ThicknessAnimationUsingKeyFrames. 

(used by) ThicknessKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value Thickness 

(description) The key frame's target value. 

4.912   ThicknessKeyFrameCollection 

x:Object > DependencyObject > Freezable > ThicknessKeyFrameCollection 

(usage) <ThicknessKeyFrameCollection>ThicknessKeyFrame*</ThicknessKeyFrameCollection> 

(description) Represents a collection of ThicknessKeyFrame objects. 

(used by) ThicknessAnimationUsingKeyFrames 

[is list] true 

[allowed 

types] 

ThicknessKeyFrame 

(static 

properties) 

 

Empty ThicknessKeyFrameCollection 

(description) An empty ThicknessKeyFrameCollection. 

4.913   Thumb 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > Thumb, 
IInputElement 

GridSplitter 

(usage) <Thumb /> 

(description) Represents a control that can be dragged by the user. 

(used by) Track 



 

563 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

GridSplitter 

[name property] Name 

[xml lang 

property] 

Language 

(events)  

DragCompleted Occurs when the Thumb control loses mouse capture. 

DragDelta Occurs one or more times as the mouse changes position when a Thumb control 

has logical focus and mouse capture. 

DragStarted Occurs when a Thumb control receives logical focus and mouse capture. 

4.914   ThumbButtonInfo 

x:Object > DependencyObject > Freezable > ThumbButtonInfo 

(usage) <ThumbButtonInfo /> 

(description) Represents information about how to display a button in the Windows 7 taskbar 

thumbnail. 

(used by) ThumbButtonInfoCollection 

(properties)  

Command ICommand 

(description) The command to invoke when this thumbnail button is clicked. 

CommandParameter x:Object 

(description) The parameter to pass to the Command property. 

CommandTarget IInputElement 

(description) The element on which to raise the specified command. 

Description x:String 

(description) The text to display for the thumbnail button tooltip. 

DismissWhenClicked x:Boolean 

(description) A value that indicates whether the taskbar thumbnail closes when the thumbnail 

button is clicked. 

ImageSource ImageSource 

(description) The image that is displayed on the thumbnail button. 

IsBackgroundVisible x:Boolean 

(description) A value that indicates whether a border and highlight is displayed around the 

thumbnail button. 
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(usage) <ThumbButtonInfo /> 

IsEnabled x:Boolean 

(description) A value that indicates whether the thumbnail button is enabled. 

IsInteractive x:Boolean 

(description) A value that indicates whether the user can interact with the thumbnail button. 

Visibility Visibility 

(description) A value that specifies the display state of the thumbnail button. 

(events)  

Click Occurs when the thumbnail button is clicked. 

4.915   ThumbButtonInfoCollection 

x:Object > DependencyObject > Freezable > Animatable > FreezableCollection(ThumbButtonInfo) > 

ThumbButtonInfoCollection 

(usage) <ThumbButtonInfoCollection>ThumbButtonInfo*</ThumbButtonInfoCollection> 

(description) Represents a collection of ThumbButtonInfo objects that are associated with a 

Window. 

(used by) TaskbarItemInfo 

[is list] true 

[allowed 

types] 

ThumbButtonInfo 

4.916   TickBar 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > TickBar, 
IInputElement 

(usage) <TickBar /> 

(description) Represents a control that draws a set of tick marks for a Slider control. 

[name property] Name 

[xml lang property] Language 

(properties)  

Fill Brush 

(description) The Brush that is used to draw the tick marks. 

IsDirectionReversed x:Boolean 

(description) The direction of increasing value of the tick marks. 
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(usage) <TickBar /> 

IsSelectionRangeEnabled x:Boolean 

(description) Whether the TickBar displays a selection range. 

Maximum x:Double 

(description) The maximum value that is possible for a tick mark. 

Minimum x:Double 

(description) The minimum value that is possible for a tick mark. 

Placement TickBarPlacement 

(description) Where tick marks appear  relative to a Track of a Slider control. 

ReservedSpace x:Double 

(description) A space buffer for the area that contains the tick marks that are specified 

for a TickBar. 

SelectionEnd x:Double 

(description) The end point of a selection. 

SelectionStart x:Double 

(description) The start point of a selection. 

TickFrequency x:Double 

(description) The interval between tick marks. 

Ticks DoubleCollection 

(description) The positions of the tick marks. 

4.917   TickBarPlacement 

x:Object > TickBarPlacement 

(usage) Left| Top| Right| Bottom 

(description) Specifies the placement of a TickBar with respect to the Track of a Slider control. 

(used by) TickBar 

[is nullable] false 

[text syntax] TickBarPlacementSyntax 

4.918   TickPlacement 

x:Object > TickPlacement 
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(usage) None| TopLeft| BottomRight| Both 

(description) Specifies the position of tick marks in a Slider control with respect to the Track that the 

control implements. 

(used by) Slider 

[is nullable] false 

[text 

syntax] 

TickPlacementSyntax 

4.919   TiffBitmapEncoder 

x:Object > BitmapEncoder > TiffBitmapEncoder 

(usage) <TiffBitmapEncoder /> 

(description) Defines an encoder that is used to encode Tagged Image File Format (TIFF) format 

images. 

(properties)  

Compression TiffCompressOption 

(description) A value that indicates the type of compression that is used by this Tagged Image File 

Format (TIFF) image. 

4.920   TiffCompressOption 

x:Object > TiffCompressOption 

(usage) Default| None| Ccitt3| Ccitt4| Lzw| Rle| Zip 

(description) Specifies the possible compression schemes for Tagged Image File Format (TIFF) bitmap 

images. 

(used by) TiffBitmapEncoder 

[is nullable] false 

[text 

syntax] 

TiffCompressOptionSyntax 

4.921   TileBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > TileBrush 

DrawingBrush ImageBrush VisualBrush 

(usage) <TileBrush> string </TileBrush> 

(description) Describes a way to paint a region by using one or more tiles. 

[is default 

constructible] 

false 
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DrawingBrush ImageBrush VisualBrush 

[text syntax] BrushSyntax 

(properties)  

AlignmentX AlignmentX 

(description) The horizontal alignment of content in the TileBrush base tile. 

AlignmentY AlignmentY 

(description) The vertical alignment of content in the TileBrush base tile. 

Stretch Stretch 

(description) A value that specifies how the content of this TileBrush stretches to fit its tiles. 

TileMode TileMode 

(description) A value that specifies how a TileBrush fills the area that you are painting if the base 

tile is smaller than the output area. 

Viewbox Rect 

(description) The position and dimensions of the content in a TileBrush tile. 

ViewboxUnits BrushMappingMode 

(description) A value that specifies whether the Viewbox value is relative to the bounding box of 

the TileBrush contents or whether the value is absolute. 

Viewport Rect 

(description) The position and dimensions of the base tile for a TileBrush. 

ViewportUnits BrushMappingMode 

(description) A BrushMappingMode enumeration that specifies whether the value of the 

Viewport, which indicates the size and position of the TileBrush base tile, is relative 

to the size of the output area. 

4.922   TileMode 

x:Object > TileMode 

(usage) None| Tile| FlipX| FlipY| FlipXY 

(description) Describes how a TileBrush paints tiles onto an output area. 

(used by) TileBrush 

[is nullable] false 

[text syntax] TileModeSyntax 
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4.923   Timeline 

x:Object > DependencyObject > Freezable > Animatable > Timeline 

AnimationTimeline MediaTimeline TimelineGroup 

(usage) None. 

(description) Defines a segment of time. 

(used by) TimelineCollection 

[is default constructible] false 

[name property] Name 

(properties)  

AccelerationRatio x:Double 

(description) A value specifying the percentage of the timeline's Duration spent 

accelerating the passage of time from zero to its maximum rate. 

AutoReverse x:Boolean 

(description) A value that indicates whether the timeline plays in reverse after it 

completes a forward iteration. 

BeginTime x:Nullable(x:TimeSpan) 

(description) The time at which this Timeline should begin. 

DecelerationRatio x:Double 

(description) A value specifying the percentage of the timeline's Duration spent 

decelerating the passage of time from its maximum rate to zero. 

Duration Duration 

(description) The length of time for which this timeline plays, not counting 

repetitions. 

FillBehavior FillBehavior 

(description) A value that specifies how the Timeline behaves after it reaches the 

end of its active period. 

Name x:String 

(description) The name of this Timeline. 

RepeatBehavior RepeatBehavior 

(description) The repeating behavior of this timeline. 

SpeedRatio x:Double 

(description) The rate, relative to its parent, at which time progresses for this 

Timeline. 



 

569 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

AnimationTimeline MediaTimeline TimelineGroup 

(attachable properties)  

Timeline.DesiredFrameRate x:Nullable(x:Int32) 

(description) The desired frame rate for this timeline and its child timelines. 

[target type] Timeline 

(events)  

Completed Occurs when this timeline has completely finished playing: it will no 

longer enter its active period. 

CurrentGlobalSpeedInvalidated Occurs when the rate at which time progresses for the timeline's 

clock changes. 

CurrentStateInvalidated Occurs when the CurrentState property of the timeline's Clock is 

updated. 

CurrentTimeInvalidated Occurs when the CurrentTime property of the timeline's Clock is 

updated. 

RemoveRequested Occurs when the clock created for this timeline or one of its parent 

timelines is removed. 

4.924   TimelineCollection 

x:Object > DependencyObject > Freezable > Animatable > TimelineCollection 

(usage) <TimelineCollection>Timeline*</TimelineCollection> 

(description) Represents a collection of Timeline objects. 

(used by) TimelineGroup 

[is list] true 

[allowed types] Timeline 

4.925   TimelineGroup 

x:Object > DependencyObject > Freezable > Animatable > Timeline > TimelineGroup 

ParallelTimeline 

(usage) None. 

(description) A base type that represents a Timeline that may contain a collection of child 

Timeline objects. 

[is default 

constructible] 

false 

[content property] Children 
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ParallelTimeline 

[name property] Name 

(properties)  

Children TimelineCollection 

(description) The collection of direct child Timeline objects of the TimelineGroup. 

4.926   TimeSeekOrigin 

x:Object > TimeSeekOrigin 

(usage) BeginTime| Duration 

(description) Indicates the origin of a seek operation. The offset of the seek operation is relative to 

this origin. 

(used by) SeekStoryboard 

[is nullable] false 

[text 

syntax] 

TimeSeekOriginSyntax 

4.927   ToggleButton 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ButtonBase > ToggleButton, IInputElement 

CheckBox RadioButton RibbonToggleButton 

(usage) <ToggleButton>x:Object</ToggleButton> 

(description) Base type for controls that can switch states, such as CheckBox. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

IsChecked x:Nullable(x:Boolean) 

(description) Whether the ToggleButton is checked. 

IsThreeState x:Boolean 

(description) Determines whether the control supports two or three states. 

(events)  

Checked Occurs when a ToggleButton is checked. 
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CheckBox RadioButton RibbonToggleButton 

Indeterminate Occurs when the state of a ToggleButton is neither on nor off. 

Unchecked Occurs when a ToggleButton is unchecked. 

4.928   ToleranceType 

x:Object > ToleranceType 

(usage) Absolute| Relative 

(description) Determines the means by which an error tolerance value is interpreted. 

[is nullable] false 

[text syntax] ToleranceTypeSyntax 

4.929   ToolBar 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > ToolBar, IInputElement 

(usage) <ToolBar>x:Object*</ToolBar> 

(description) Provides a container for a group of commands or controls. 

(used by) ToolBarTray 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

Band x:Int32 

(description) A value that indicates where the toolbar should be located in the ToolBarTray. 

BandIndex x:Int32 

(description) The band index number that indicates the position of the toolbar on the band. 

IsOverflowOpen x:Boolean 

(description) A value that indicates whether the ToolBar overflow area is currently visible. 

(attachable 

properties) 

 

ToolBar.OverflowMode OverflowMode 

(description) A value that indicates when an item should be placed in the overflow panel 

instead of in the main panel. 
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(usage) <ToolBar>x:Object*</ToolBar> 

[target type] DependencyObject 

(static properties)  

ButtonStyleKey ResourceKey 

(description) The Style applied to buttons on a toolbar. 

CheckBoxStyleKey ResourceKey 

(description) The Style applied to check boxes on a ToolBar. 

ComboBoxStyleKey ResourceKey 

(description) The Style applied to combo boxes on a ToolBar. 

MenuStyleKey ResourceKey 

(description) The Style applied to menus on a ToolBar. 

RadioButtonStyleKey ResourceKey 

(description) The Style applied to radio buttons on a toolbar. 

SeparatorStyleKey ResourceKey 

(description) The Style applied to separators on a ToolBar. 

TextBoxStyleKey ResourceKey 

(description) The Style applied to text boxes on a ToolBar. 

ToggleButtonStyleKey ResourceKey 

(description) The Style applied to ToggleButton controls on a ToolBar. 

4.930   ToolBarOverflowPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > 
ToolBarOverflowPanel, IInputElement 

(usage) <ToolBarOverflowPanel>UIElement*</ToolBarOverflowPanel> 

(description) Used to arrange overflow ToolBar items. 

[content property] Children 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

WrapWidth x:Double 

(description) The recommended width for an overflow ToolBar before items flow to the next 
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(usage) <ToolBarOverflowPanel>UIElement*</ToolBarOverflowPanel> 

line. 

4.931   ToolBarPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > StackPanel > 
ToolBarPanel, IInputElement 

(usage) <ToolBarPanel>UIElement*</ToolBarPanel> 

(description) Arranges ToolBar items inside a ToolBar. 

[content property] Children 

[name property] Name 

[xml lang property] Language 

4.932   ToolBarTray 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > ToolBarTray, 
IInputElement 

(usage) <ToolBarTray>ToolBar*</ToolBarTray> 

(description) Represents the container that handles the layout of a ToolBar. 

[content property] ToolBars 

[name property] Name 

[xml lang property] Language 

(properties)  

Background Brush 

(description) A brush to use for the background color of the ToolBarTray. 

IsLocked x:Boolean 

(description) A value that indicates whether a ToolBar can be moved inside a ToolBarTray. 

Orientation Orientation 

(description) Specifies the orientation of a ToolBarTray. 

ToolBars Collection(ToolBar) 

(description) The collection of ToolBar elements in the ToolBarTray. 

[read only] true 

(attachable properties)  

ToolBarTray.IsLocked x:Boolean 
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(usage) <ToolBarTray>ToolBar*</ToolBarTray> 

(description) A value that indicates whether a ToolBar can be moved inside a ToolBarTray. 

[target type] DependencyObject 

4.933   ToolTip 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 

ContentControl > ToolTip, IInputElement 

RibbonToolTip 

(usage) <ToolTip>x:Object</ToolTip> 

(description) Represents a control that creates a pop-up window that displays information for 

an element in the interface. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

HasDropShadow x:Boolean 

(description) A value that indicates whether the control has a drop shadow. 

HorizontalOffset x:Double 

(description) Get or sets the horizontal distance between the target origin and the popup 

alignment point. 

[text syntax] LengthSyntax 

IsOpen x:Boolean 

(description) A value that indicates whether a ToolTip is visible. 

Placement PlacementMode 

(description) The orientation of the ToolTip control when it opens, and specifies how the 

ToolTip control behaves when it overlaps screen boundaries. 

PlacementRectangle Rect 

(description) The rectangular area relative to which the ToolTip control is positioned when it 

opens. 

PlacementTarget UIElement 

(description) The UIElement relative to which the ToolTip is positioned when it opens. 

StaysOpen x:Boolean 

(description) A value that indicates whether an open ToolTip remains open until the user clicks 

the mouse when the mouse is not over the ToolTip. 
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RibbonToolTip 

VerticalOffset x:Double 

(description) Get or sets the vertical distance between the target origin and the popup 

alignment point. 

[text syntax] LengthSyntax 

(events)  

Closed Occurs when a ToolTip is closed and is no longer visible. 

Opened Occurs when a ToolTip becomes visible. 

4.934   ToolTipService 

x:Object > ToolTipService 

(usage) None. 

(description) Represents a service that provides properties and events to 

control the display and behavior of tooltips. 

[is default constructible] false 

(attachable properties)  

ToolTipService.BetweenShowDelay x:Int32 

(description) The maximum time between the display of two tooltips where 

the second tooltip appears without a delay. 

[target type] DependencyObject 

ToolTipService.HasDropShadow x:Boolean 

(description) Whether the tooltip displays a drop shadow effect. 

[target type] DependencyObject 

ToolTipService.HorizontalOffset x:Double 

(description) The offset from the left of the area that is specified for the 

tooltip by the PlacementRectangle and PlacementTarget 

properties. 

[target type] DependencyObject 

[text syntax] LengthSyntax 

ToolTipService.InitialShowDelay x:Int32 

(description) The length of time before a tooltip opens. 

[target type] DependencyObject 

ToolTipService.IsEnabled x:Boolean 
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(usage) None. 

(description) Whether a tooltip appears. 

[target type] DependencyObject 

ToolTipService.Placement PlacementMode 

(description) The orientation of the tooltip when it opens, and specifies how 

the tooltip behaves when it overlaps screen boundaries. 

[target type] DependencyObject 

ToolTipService.PlacementRectangle Rect 

(description) The rectangular area relative to which the tooltip is positioned. 

[target type] DependencyObject 

ToolTipService.PlacementTarget UIElement 

(description) The object relative to which the tooltip is positioned. 

[target type] DependencyObject 

ToolTipService.ShowDuration x:Int32 

(description) The amount of time that a tooltip remains visible. 

[target type] DependencyObject 

ToolTipService.ShowOnDisabled x:Boolean 

(description) Whether a tooltip appears for an object that is not enabled. 

[target type] DependencyObject 

ToolTipService.ToolTip x:Object 

(description) The content of a tooltip. 

[target type] DependencyObject 

ToolTipService.VerticalOffset x:Double 

(description) The distance from the top of the area that is specified for the 

tooltip by the PlacementRectangle and PlacementTarget 

properties. 

[target type] DependencyObject 

[text syntax] LengthSyntax 

(attachable events)  

ToolTipService.ToolTipClosing  

ToolTipService.ToolTipOpening  
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4.935   TouchAction 

x:Object > TouchAction 

(usage) Down| Move| Up 

(description) Describes the action of a specific touch point. 

(used by) TouchPoint 

[is nullable] false 

[text syntax] TouchActionSyntax 

4.936   TouchPoint 

x:Object > TouchPoint 

(usage) None. 

(description) Represents a single touch point from a multitouch message source. 

(used by) TouchPointCollection 

[is default constructible] false 

(properties)  

Action TouchAction 

(description) The last action that occurred at this location. 

Bounds Rect 

(description) The bounds of the area that the finger has in contact with the screen. 

Position Point 

(description) The location of the touch point. 

4.937   TouchPointCollection 

x:Object > Collection(TouchPoint) > TouchPointCollection 

(usage) <TouchPointCollection>TouchPoint*</TouchPointCollection> 

(description) Contains a collection of TouchPoint objects. 

[is list] true 

[allowed types] TouchPoint 

4.938   Track 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Track, IInputElement 
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(usage) <Track /> 

(description) Represents a control primitive that handles the positioning and sizing of a 

Thumb control and two RepeatButton controls that are used to set a Value. 

[name property] Name 

[xml lang property] Language 

(properties)  

DecreaseRepeatButton RepeatButton 

(description) The RepeatButton that decreases the Value property of the Track. 

IncreaseRepeatButton RepeatButton 

(description) The RepeatButton that increases the Value property of the Track type. 

IsDirectionReversed x:Boolean 

(description) Whether the direction of increasing Value is reversed from the default 

direction. 

Maximum x:Double 

(description) The maximum possible Value of the Track. 

Minimum x:Double 

(description) The minimum possible Value of the Track. 

Orientation Orientation 

(description) A value that indicates whether the Track is displayed horizontally or vertically. 

Thumb Thumb 

(description) The Thumb control that is used to change the Value of a Track. 

Value x:Double 

(description) The current value of the Track as determined by the position of the Thumb 

control. 

ViewportSize x:Double 

(description) The size of the part of the scrollable content that is visible. 

4.939   Transform 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform > Transform 

MatrixTransform RotateTransform ScaleTransform SkewTransform TransformGroup 

TranslateTransform 

(usage) <Transform> string </Transform> 

(description) A base type for transformations in a two-dimensional plane. 
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MatrixTransform RotateTransform ScaleTransform SkewTransform TransformGroup 

TranslateTransform 

(used by) Brush ContainerVisual DrawingGroup FrameworkElement Geometry TextEffect 

TransformCollection TransformedBitmap UIElement Viewport3DVisual 

[is default 

constructible] 

false 

[text syntax] TransformSyntax 

(static properties)  

Identity Transform 

(description) An identity transform. 

4.940   Transform3D 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > Transform3D 

AffineTransform3D MatrixTransform3D Transform3DGroup 

(usage) {x:Static Transform3D.StaticPropertyName} 

(description) A base type for transformations in a three-dimensional plane. 

(used by) Camera Model3D ModelVisual3D Transform3DCollection Visual3D 

[is default constructible] false 

(static properties)  

Identity Transform3D 

(description) The identity transformation. 

4.941   Transform3DCollection 

x:Object > DependencyObject > Freezable > Animatable > Transform3DCollection 

(usage) <Transform3DCollection>Transform3D*</Transform3DCollection> 

(description) Represents an ordered collection of Transform3D objects. 

(used by) Transform3DGroup 

[is list] true 

[allowed types] Transform3D 

4.942   Transform3DGroup 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > Transform3D > 
Transform3DGroup 
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(usage) <Transform3DGroup>Transform3D*</Transform3DGroup> 

(description) Represents a transformation that is a composite of the Transform3D children in its 

Transform3DCollection. 

[content 

property] 

Children 

(properties)  

Children Transform3DCollection 

(description) A collection of Transform3D objects. 

4.943   TransformCollection 

x:Object > DependencyObject > Freezable > Animatable > TransformCollection 

(usage) <TransformCollection>Transform*</TransformCollection> 

(description) Represents a collection of Transform objects that can be individually accessed by 

index. 

(used by) TransformGroup 

[is list] true 

[allowed 

types] 

Transform 

4.944   TransformedBitmap 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 

TransformedBitmap 

(usage) <TransformedBitmap> string </TransformedBitmap> 

(description) Scales and rotates a BitmapSource. 

[text syntax] x:Uri, from [MS-XAML] 

(properties)  

Source BitmapSource 

(description) The source for the bitmap. 

Transform Transform 

(description) The Transform, which specifies the scale or rotation of the bitmap. 

4.945   TransformGroup 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform > Transform > 
TransformGroup 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) <TransformGroup> string |Transform*</TransformGroup> 

(description) Represents a composite Transform composed of other Transform objects. 

[text syntax] TransformSyntax 

[content property] Children 

(properties)  

Children TransformCollection 

(description) The TransformCollection that defines this TransformGroup. 

4.946   TranslateTransform 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform > Transform > 
TranslateTransform 

(usage) <TranslateTransform> string </TranslateTransform> 

(description) Translates (moves) an object in the 2-D x-y coordinate system. 

[text syntax] TransformSyntax 

(properties)  

X x:Double 

(description) The distance to translate along the x-axis. 

Y x:Double 

(description) The distance to translate (move) an object along the y-axis. 

4.947   TranslateTransform3D 

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > Transform3D > 
AffineTransform3D > TranslateTransform3D 

(usage) <TranslateTransform3D /> 

(description) Translates an object in the three-dimensional x-y-z plane. 

(properties)  

OffsetX x:Double 

(description) The X-axis value of the translation's offset. 

OffsetY x:Double 

(description) The Y-axis value of the translation's offset. 

OffsetZ x:Double 

(description) The Z-axis value of the translation's offset. 
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4.948   TreeView 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > TreeView, IInputElement 

(usage) <TreeView>x:Object*</TreeView> 

(description) Represents a control that displays hierarchical data in a tree structure that has 

items that can expand and collapse. 

[content property] Items 

[name property] Name 

[xml lang property] Language 

(properties)  

SelectedValuePath x:String 

(description) The path that is used to get the SelectedValue of the SelectedItem in a 

TreeView. 

(events)  

SelectedItemChanged Occurs when the SelectedItem changes. 

4.949   TreeViewItem 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ItemsControl > HeaderedItemsControl > TreeViewItem, IInputElement 

(usage) <TreeViewItem>x:Object*</TreeViewItem> 

(description) Implements a selectable item in a TreeView control. 

[content property] Items 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

IsExpanded x:Boolean 

(description) Whether the nested items in a TreeViewItem are expanded or collapsed. 

IsSelected x:Boolean 

(description) Whether a TreeViewItem control is selected. 

(events)  

Collapsed Occurs when the IsExpanded property changes from true to false. 

Expanded Occurs when the IsExpanded property changes from false to true. 
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(usage) <TreeViewItem>x:Object*</TreeViewItem> 

Selected Occurs when the IsSelected property of a TreeViewItem changes from false to 

true. 

Unselected Occurs when the IsSelected property of a TreeViewItem changes from true to 

false. 

4.950   Trigger 

x:Object > DependencyObject > TriggerBase > Trigger 

(usage) <Trigger>SetterBase*</Trigger> 

(description) Represents a trigger that applies property values or performs actions conditionally. 

[content 

property] 

Setters 

(properties)  

Property DependencyProperty 

(description) The property that returns the value that is compared with the Value property of the 

trigger. The comparison is a reference equality check. 

Setters SetterBaseCollection 

(description) A collection of Setter objects, which describe the property values to apply when the 

specified condition has been met. 

[read only] true 

SourceName x:String 

(description) The name of the object with the property that causes the associated setters to be 

applied. 

Value x:Object 

(description) The value to be compared with the property value of the element. The comparison is 

a reference equality check. 

[text syntax] This property's text syntax is the text syntax of the Property. 

4.951   TriggerAction 

x:Object > DependencyObject > TriggerAction 

BeginStoryboard ControllableStoryboardAction SoundPlayerAction 

(usage) None. 

(description) Describes an action to perform for a trigger. 

(used by) TriggerActionCollectiont 
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BeginStoryboard ControllableStoryboardAction SoundPlayerAction 

[is default constructible] false 

4.952   TriggerActionCollection 

x:Object > TriggerActionCollectiont 

(usage) <TriggerActionCollection>TriggerAction*</TriggerActionCollection> 

(description) Represents a collection of TriggerAction objects. 

(used by) EventTrigger TriggerBase 

[is list] true 

[allowed types] TriggerAction 

4.953   TriggerBase 

x:Object > DependencyObject > TriggerBase 

DataTrigger EventTrigger MultiDataTrigger MultiTrigger Trigger 

(usage) None. 

(description) Represents the base type for specifying a conditional value within a Style object. 

(used by) TriggerCollection 

[is default 

constructible] 

false 

(properties)  

EnterActions TriggerActionCollectiont 

(description) A collection of TriggerAction objects to apply when the trigger object becomes 

active. This property does not apply to the EventTrigger type. 

[read only] true 

ExitActions TriggerActionCollectiont 

(description) A collection of TriggerAction objects to apply when the trigger object becomes 

inactive. This property does not apply to the EventTrigger type. 

[read only] true 

4.954   TriggerCollection 

x:Object > Collection(TriggerBase) > TriggerCollection 

(usage) None. 

(description) Represents a collection of TriggerBase objects. 
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(usage) None. 

(used by) ControlTemplate DataTemplate FrameworkElement Style 

[is default constructible] false 

[is list] true 

[allowed types] TriggerBase 

4.955   Typography 

x:Object > Typography 

(usage) None. 

(description) Provides access to a rich set of OpenType typography properties. 

[is default constructible] false 

(properties)  

AnnotationAlternates x:Int32 

(description) A value that specifies the index of an alternate annotation form. 

Capitals FontCapitals 

(description) A FontCapitals enumerated value that indicates the capital form 

of the selected font. 

CapitalSpacing x:Boolean 

(description) A value that determines whether inter-glyph spacing for all-

capital text is globally adjusted to improve readability. 

CaseSensitiveForms x:Boolean 

(description) A value that determines whether glyphs adjust their vertical 

position to better align with uppercase glyphs. 

ContextualAlternates x:Boolean 

(description) A value that determines whether custom glyph forms can be 

used based upon the context of the text being rendered. 

ContextualLigatures x:Boolean 

(description) A value that determines whether contextual ligatures are 

enabled. 

ContextualSwashes x:Int32 

(description) A value that specifies the index of a contextual swashes form. 

DiscretionaryLigatures x:Boolean 

(description) A value that determines whether discretionary ligatures are 

enabled. 
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(usage) None. 

EastAsianExpertForms x:Boolean 

(description) A value that determines whether the standard Japanese font 

forms have been replaced with the corresponding preferred 

typographic forms. 

EastAsianLanguage FontEastAsianLanguage 

(description) A FontEastAsianLanguage enumerated value that indicates the 

version of glyphs to be used for a specific writing system or 

language. 

EastAsianWidths FontEastAsianWidths 

(description) A FontEastAsianWidths enumerated value that indicates the 

proportional width to be used for Latin characters in an East 

Asian font. 

Fraction FontFraction 

(description) A FontFraction enumerated value that indicates the fraction 

style. 

HistoricalForms x:Boolean 

(description) A value that determines whether historical forms are enabled. 

HistoricalLigatures x:Boolean 

(description) A value that indicates whether historical ligatures are enabled. 

Kerning x:Boolean 

(description) A value that indicates whether kerning is enabled. 

MathematicalGreek x:Boolean 

(description) A value that indicates whether standard typographic font forms 

of Greek glyphs have been replaced with corresponding font 

forms commonly used in mathematical notation. 

NumeralAlignment FontNumeralAlignment 

(description) A FontNumeralAlignment enumerated value that indicates the 

alighnment of widths when using numerals. 

NumeralStyle FontNumeralStyle 

(description) A FontNumeralStyle enumerated value that determines the set 

of glyphs that are used to render numeric alternate font forms. 

SlashedZero x:Boolean 

(description) A value that indicates whether a nominal zero font form should 

be replaced with a slashed zero. 

StandardLigatures x:Boolean 
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(usage) None. 

(description) A value that indicates whether standard ligatures are enabled. 

StandardSwashes x:Int32 

(description) A value that specifies the index of a standard swashes form. 

StylisticAlternates x:Int32 

(description) A value that specifies the index of a stylistic alternates form. 

StylisticSet1 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet10 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet11 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet12 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet13 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet14 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet15 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet16 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet17 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet18 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 
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(usage) None. 

enabled. 

StylisticSet19 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet2 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet20 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet3 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet4 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet5 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet6 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet7 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet8 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

StylisticSet9 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

Variants FontVariants 

(description) A FontVariants enumerated value that indicates a variation of 

the standard typographic form to be used. 

(attachable properties)  
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(usage) None. 

Typography.AnnotationAlternates x:Int32 

(description) A value that specifies the index of an alternate annotation form. 

[target type] DependencyObject 

Typography.Capitals FontCapitals 

(description) A FontCapitals enumerated value that indicates the capital form 

of the selected font. 

[target type] DependencyObject 

Typography.CapitalSpacing x:Boolean 

(description) A value that determines whether inter-glyph spacing for all-

capital text is globally adjusted to improve readability. 

[target type] DependencyObject 

Typography.CaseSensitiveForms x:Boolean 

(description) A value that determines whether glyphs adjust their vertical 

position to better align with uppercase glyphs. 

[target type] DependencyObject 

Typography.ContextualAlternates x:Boolean 

(description) A value that determines whether custom glyph forms can be 

used based upon the context of the text being rendered. 

[target type] DependencyObject 

Typography.ContextualLigatures x:Boolean 

(description) A value that determines whether contextual ligatures are 

enabled. 

[target type] DependencyObject 

Typography.ContextualSwashes x:Int32 

(description) A value that specifies the index of a contextual swashes form. 

[target type] DependencyObject 

Typography.DiscretionaryLigatures x:Boolean 

(description) A value that determines whether discretionary ligatures are 

enabled. 

[target type] DependencyObject 

Typography.EastAsianExpertForms x:Boolean 

(description) A value that determines whether the standard Japanese font 

forms have been replaced with the corresponding preferred 
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(usage) None. 

typographic forms. 

[target type] DependencyObject 

Typography.EastAsianLanguage FontEastAsianLanguage 

(description) A FontEastAsianLanguage enumerated value that indicates the 

version of glyphs to be used for a specific writing system or 

language. 

[target type] DependencyObject 

Typography.EastAsianWidths FontEastAsianWidths 

(description) A FontEastAsianWidths enumerated value that indicates the 

proportional width to be used for Latin characters in an East 

Asian font. 

[target type] DependencyObject 

Typography.Fraction FontFraction 

(description) A FontFraction enumerated value that indicates the fraction 

style. 

[target type] DependencyObject 

Typography.HistoricalForms x:Boolean 

(description) A value that determines whether historical forms are enabled. 

[target type] DependencyObject 

Typography.HistoricalLigatures x:Boolean 

(description) A value that indicates whether historical ligatures are enabled. 

[target type] DependencyObject 

Typography.Kerning x:Boolean 

(description) A value that indicates whether kerning is enabled. 

[target type] DependencyObject 

Typography.MathematicalGreek x:Boolean 

(description) A value that indicates whether standard typographic font forms 

of Greek glyphs have been replaced with corresponding font 

forms commonly used in mathematical notation. 

[target type] DependencyObject 

Typography.NumeralAlignment FontNumeralAlignment 

(description) A FontNumeralAlignment enumerated value that indicates the 

alighnment of widths when using numerals. 

[target type] DependencyObject 
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(usage) None. 

Typography.NumeralStyle FontNumeralStyle 

(description) A FontNumeralStyle enumerated value that determines the set 

of glyphs that are used to render numeric alternate font forms. 

[target type] DependencyObject 

Typography.SlashedZero x:Boolean 

(description) A value that indicates whether a nominal zero font form should 

be replaced with a slashed zero. 

[target type] DependencyObject 

Typography.StandardLigatures x:Boolean 

(description) A value that indicates whether standard ligatures are enabled. 

[target type] DependencyObject 

Typography.StandardSwashes x:Int32 

(description) A value that specifies the index of a standard swashes form. 

[target type] DependencyObject 

Typography.StylisticAlternates x:Int32 

(description) A value that specifies the index of a stylistic alternates form. 

[target type] DependencyObject 

Typography.StylisticSet1 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet10 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet11 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet12 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 
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(usage) None. 

[target type] DependencyObject 

Typography.StylisticSet13 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet14 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet15 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet16 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet17 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet18 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet19 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet2 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 
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(usage) None. 

Typography.StylisticSet20 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet3 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet4 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet5 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet6 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet7 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet8 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.StylisticSet9 x:Boolean 

(description) A value that indicates whether a stylistic set of a font form is 

enabled. 

[target type] DependencyObject 

Typography.Variants FontVariants 
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(usage) None. 

(description) A FontVariants enumerated value that indicates a variation of 

the standard typographic form to be used. 

[target type] DependencyObject 

4.956   UIElement 

x:Object > DependencyObject > Visual > UIElement, IInputElement 

FrameworkElement 

(usage) <UIElement /> 

(description) A base type for core elements and basic presentation 

characteristics. 

(used by) AdornedElementPlaceholder AdornerDecorator 

AutomationProperties BlockUIContainer BulletDecorator 

ContextMenu ContextMenuService Decorator InlineCollection 

InlineUIContainer Label Popup ToolTip ToolTipService 

UIElementCollection Viewbox 

(properties)  

AllowDrop x:Boolean 

(description) A value indicating whether this element can be used as the target 

of a drag-and-drop operation. 

CacheMode CacheMode 

(description) A cached representation of the UIElement. 

Clip Geometry 

(description) The geometry used to define the outline of the contents of an 

element. 

ClipToBounds x:Boolean 

(description) A value indicating whether to clip the content of this element (or 

content coming from the child elements of this element) to fit into 

the size of the containing element. 

CommandBindings CommandBindingCollection 

(description) A collection of CommandBinding objects associated with this 

element. A CommandBinding enables command handling for this 

element, and declares the linkage between a command, its events, 

and the handlers attached by this element. 

[read only] true 

Effect Effect 

(description) The bitmap effect to apply to the UIElement. 
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FrameworkElement 

Focusable x:Boolean 

(description) A value that indicates whether the element can receive focus. 

InputBindings InputBindingCollection 

(description) The collection of input bindings associated with this element. 

[read only] true 

IsEnabled x:Boolean 

(description) A value indicating whether this element is enabled in the user 

interface (UI). 

IsHitTestVisible x:Boolean 

(description) A value that declares whether this element can possibly be 

returned as a hit test result from some portion of its rendered 

content. 

IsManipulationEnabled x:Boolean 

(description) A value that indicates whether manipulation events are enabled on 

this UIElement. 

Opacity x:Double 

(description) The opacity factor applied to the entire UIElement when it is 

rendered in the user interface (UI). 

OpacityMask Brush 

(description) An opacity mask, as a Brush implementation that is applied to any 

alpha-channel masking for the rendered content of this element. 

RenderSize Size 

(description) The final render size of this element. 

RenderTransform Transform 

(description) Transform information that affects the rendering position of this 

element. 

RenderTransformOrigin Point 

(description) The center point of any possible render transform declared by 

RenderTransform, relative to the bounds of the element. 

SnapsToDevicePixels x:Boolean 

(description) A value that determines whether rendering for this element should 

use device-specific pixel settings during rendering. 

Uid x:String 

(description) The unique identifier (for localization) for this element. 
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FrameworkElement 

Visibility Visibility 

(description) The user interface (UI) visibility of this element. 

(events)  

DragEnter Occurs when the input system reports an underlying drag event 

with this element as the drag target. 

DragLeave Occurs when the input system reports an underlying drag event 

with this element as the drag origin. 

DragOver Occurs when the input system reports an underlying drag event 

with this element as the potential drop target. 

Drop Occurs when the input system reports an underlying drop event 

with this element as the drop target. 

FocusableChanged Occurs when the value of the Focusable property changes. 

GiveFeedback Occurs when the input system reports an underlying drag-and-drop 

event that involves this element. 

GotFocus Occurs when this element gets logical focus. 

GotKeyboardFocus Occurs when the keyboard is focused on this element. 

GotMouseCapture Occurs when this element captures the mouse. 

GotStylusCapture Occurs when this element captures the stylus. 

GotTouchCapture Occurs when a touch is captured to this element. 

IsEnabledChanged Occurs when the value of the IsEnabled property on this element 

changes. 

IsHitTestVisibleChanged Occurs when the value of the IsHitTestVisible property changes on 

this element. 

IsKeyboardFocusedChanged Occurs when the value of the IsKeyboardFocused property changes 

on this element. 

IsKeyboardFocusWithinChanged Occurs when the value of the IsKeyboardFocusWithinChanged 

property changes on this element. 

IsMouseCapturedChanged Occurs when the value of the IsMouseCaptured property changes 

on this element. 

IsMouseCaptureWithinChanged Occurs when the value of the IsMouseCaptureWithinProperty 

changes on this element. 

IsMouseDirectlyOverChanged Occurs when the value of the IsMouseDirectlyOver property 

changes on this element. 

IsStylusCapturedChanged Occurs when the value of the IsStylusCaptured property changes 

on this element. 

IsStylusCaptureWithinChanged Occurs when the value of the IsStylusCaptureWithin property 
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FrameworkElement 

changes on this element. 

IsStylusDirectlyOverChanged Occurs when the value of the IsStylusDirectlyOver property 

changes on this element. 

IsVisibleChanged Occurs when the value of the IsVisible property changes on this 

element. 

KeyDown Occurs when a key is pressed while focus is on this element. 

KeyUp Occurs when a key is released while focus is on this element. 

LayoutUpdated Occurs when the layout of the various visual elements associated 

with the current Dispatcher changes. 

LostFocus Occurs when this element loses logical focus. 

LostKeyboardFocus Occurs when the keyboard is no longer focused on this element,. 

LostMouseCapture Occurs when this element loses mouse capture. 

LostStylusCapture Occurs when this element loses stylus capture. 

LostTouchCapture Occurs when this element loses a touch capture. 

ManipulationBoundaryFeedback Occurs when the manipulation encounters a boundary. 

ManipulationCompleted Occurs when a manipulation and inertia on the UIElement object is 

complete. 

ManipulationDelta Occurs when the input device changes position during a 

manipulation. 

ManipulationInertiaStarting Occurs when the input device loses contact with the UIElement 

object during a manipulation and inertia begins. 

ManipulationStarted Occurs when an input device begins a manipulation on the 

UIElement object. 

ManipulationStarting Occurs when the manipulation processor is first created. 

MouseDown Occurs when any mouse button is pressed while the pointer is over 

this element. 

MouseEnter Occurs when the mouse pointer enters the bounds of this element. 

MouseLeave Occurs when the mouse pointer leaves the bounds of this element. 

MouseLeftButtonDown Occurs when the left mouse button is pressed while the mouse 

pointer is over this element. 

MouseLeftButtonUp Occurs when the left mouse button is released while the mouse 

pointer is over this element. 

MouseMove Occurs when the mouse pointer moves while over this element. 

MouseRightButtonDown Occurs when the right mouse button is pressed while the mouse 

pointer is over this element. 
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FrameworkElement 

MouseRightButtonUp Occurs when the right mouse button is released while the mouse 

pointer is over this element. 

MouseUp Occurs when any mouse button is released over this element. 

MouseWheel Occurs when the user rotates the mouse wheel while the mouse 

pointer is over this element. 

PreviewDragEnter Occurs when the input system reports an underlying drag event 

with this element as the drag target. 

PreviewDragLeave Occurs when the input system reports an underlying drag event 

with this element as the drag origin. 

PreviewDragOver Occurs when the input system reports an underlying drag event 

with this element as the potential drop target. 

PreviewDrop Occurs when the input system reports an underlying drop event 

with this element as the drop target. 

PreviewGiveFeedback Occurs when a drag-and-drop operation is started. 

PreviewGotKeyboardFocus Occurs when the keyboard is focused on this element. 

PreviewKeyDown Occurs when a key is pressed while focus is on this element. 

PreviewKeyUp Occurs when a key is released while focus is on this element. 

PreviewLostKeyboardFocus Occurs when the keyboard is no longer focused on this element. 

PreviewMouseDown Occurs when any mouse button is pressed while the pointer is over 

this element. 

PreviewMouseLeftButtonDown Occurs when the left mouse button is pressed while the mouse 

pointer is over this element. 

PreviewMouseLeftButtonUp Occurs when the left mouse button is released while the mouse 

pointer is over this element. 

PreviewMouseMove Occurs when the mouse pointer moves while the mouse pointer is 

over this element. 

PreviewMouseRightButtonDown Occurs when the right mouse button is pressed while the mouse 

pointer is over this element. 

PreviewMouseRightButtonUp Occurs when the right mouse button is released while the mouse 

pointer is over this element. 

PreviewMouseUp Occurs when any mouse button is released while the mouse pointer 

is over this element. 

PreviewMouseWheel Occurs when the user rotates the mouse wheel while the mouse 

pointer is over this element. 

PreviewQueryContinueDrag Occurs when there is a change in the keyboard or mouse button 

state during a drag-and-drop operation. 

PreviewStylusButtonDown Occurs when the stylus button is pressed while the pointer is over 
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FrameworkElement 

this element. 

PreviewStylusButtonUp Occurs when the stylus button is released while the pointer is over 

this element. 

PreviewStylusDown Occurs when the stylus touches the digitizer while it is over this 

element. 

PreviewStylusInAirMove Occurs when the stylus moves over an element without actually 

touching the digitizer. 

PreviewStylusInRange Occurs when the stylus is close enough to the digitizer to be 

detected, while over this element. 

PreviewStylusMove Occurs when the stylus moves while over the element. The stylus 

must move while being detected by the digitizer to raise this event, 

otherwise, PreviewStylusInAirMove is raised instead. 

PreviewStylusOutOfRange Occurs when the stylus is too far from the digitizer to be detected. 

PreviewStylusSystemGesture Occurs when a user performs one of several stylus gestures. 

PreviewStylusUp Occurs when the user raises the stylus off the digitizer while the 

stylus is over this element. 

PreviewTextInput Occurs when this element gets text in a device-independent 

manner. 

PreviewTouchDown Occurs when a finger touches the screen while the finger is over 

this element. 

PreviewTouchMove Occurs when a finger moves on the screen while the finger is over 

this element. 

PreviewTouchUp Occurs when a finger is raised off of the screen while the finger is 

over this element. 

QueryContinueDrag Occurs when there is a change in the keyboard or mouse button 

state during a drag-and-drop operation. 

QueryCursor Occurs when the cursor is requested to display. This event is raised 

on an element each time that the mouse pointer moves to a new 

location, which means the cursor object might need to be changed 

based on its new position. 

StylusButtonDown Occurs when the stylus button is pressed while the pointer is over 

this element. 

StylusButtonUp Occurs when the stylus button is released while the pointer is over 

this element. 

StylusDown Occurs when the stylus touches the digitizer while the stylus is over 

this element. 

StylusEnter Occurs when the stylus enters the bounds of this element. 

StylusInAirMove Occurs when the stylus moves over an element without actually 

touching the digitizer. 
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FrameworkElement 

StylusInRange Occurs when the stylus is close enough to the digitizer to be 

detected, while over this element. 

StylusLeave Occurs when the stylus leaves the bounds of the element. 

StylusMove Occurs when the stylus moves over this element. The stylus must 

move while on the digitizer to raise this event. Otherwise, 

StylusInAirMove is raised instead. 

StylusOutOfRange Occurs when the stylus is too far from the digitizer to be detected, 

while over this element. 

StylusSystemGesture Occurs when a user performs one of several stylus gestures. 

StylusUp Occurs when the user raises the stylus off the digitizer while it is 

over this element. 

TextInput Occurs when this element gets text in a device-independent 

manner. 

TouchDown Occurs when a finger touches the screen while the finger is over 

this element. 

TouchEnter Occurs when a touch moves from outside to inside the bounds of 

this element. 

TouchLeave Occurs when a touch moves from inside to outside the bounds of 

this element. 

TouchMove Occurs when a finger moves on the screen while the finger is over 

this element. 

TouchUp Occurs when a finger is raised off of the screen while the finger is 

over this element. 

4.957   UIElement3D 

x:Object > DependencyObject > Visual3D > UIElement3D, IInputElement 

ContainerUIElement3D ModelUIElement3D 

(usage) None. 

(description) UIElement3D is a base type for core level implementations building 

on elements and basic presentation characteristics. 

[is default constructible] false 

(properties)  

AllowDrop x:Boolean 

(description) A value indicating whether this element can be used as the target 

of a drag-and-drop operation. 

CommandBindings CommandBindingCollection 



 

601 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

ContainerUIElement3D ModelUIElement3D 

(description) A collection of CommandBinding objects associated with this 

element. 

[read only] true 

Focusable x:Boolean 

(description) A value that indicates whether the element can receive focus. 

InputBindings InputBindingCollection 

(description) The collection of input bindings associated with this element. 

[read only] true 

IsEnabled x:Boolean 

(description) A value indicating whether this element is enabled in the user 

interface (UI). 

IsHitTestVisible x:Boolean 

(description) A value that declares whether this element can possibly be 

returned as a hit test result from some portion of its rendered 

content. 

Visibility Visibility 

(description) The user interface (UI) visibility of this element. 

(events)  

DragEnter Occurs when the input system reports an underlying drag event 

with this element as the drag target. 

DragLeave Occurs when the input system reports an underlying drag event 

with this element as the drag origin. 

DragOver Occurs when the input system reports an underlying drag event 

with this element as the potential drop target. 

Drop Occurs when the input system reports an underlying drop event 

with this element as the drop target. 

FocusableChanged Occurs when the value of the Focusable property changes. 

GiveFeedback Occurs when the input system reports an underlying drag-and-drop 

event that involves this element. 

GotFocus Occurs when this element gets logical focus. 

GotKeyboardFocus Occurs when the keyboard is focused on this element. 

GotMouseCapture Occurs when this element captures the mouse. 

GotStylusCapture Occurs when this element captures the stylus. 

GotTouchCapture Occurs when a touch is captured to this element. 
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ContainerUIElement3D ModelUIElement3D 

IsEnabledChanged Occurs when the value of the IsEnabled property on this element 

changes. 

IsHitTestVisibleChanged Occurs when the value of the IsHitTestVisible property changes on 

this element. 

IsKeyboardFocusedChanged Occurs when the value of the IsKeyboardFocused property changes 

on this element. 

IsKeyboardFocusWithinChanged Occurs when the value of the IsKeyboardFocusWithin property 

changes on this element. 

IsMouseCapturedChanged Occurs when the value of the IsMouseCaptured property changes 

on this element. 

IsMouseCaptureWithinChanged Occurs when the value of the IsMouseCaptureWithin property 

changes on this element. 

IsMouseDirectlyOverChanged Occurs when the value of the IsMouseDirectlyOver property 

changes on this element. 

IsStylusCapturedChanged Occurs when the value of the IsStylusCaptured property changes 

on this element. 

IsStylusCaptureWithinChanged Occurs when the value of the IsStylusCaptureWithin property 

changes on this element. 

IsStylusDirectlyOverChanged Occurs when the value of the IsStylusDirectlyOver property 

changes on this element. 

IsVisibleChanged Occurs when the value of the IsVisible property changes on this 

element. 

KeyDown Occurs when a key is pressed while the keyboard is focused on this 

element. 

KeyUp Occurs when a key is released while the keyboard is focused on this 

element. 

LostFocus Occurs when this element loses logical focus. 

LostKeyboardFocus Occurs when the keyboard is no longer focused on this element. 

LostMouseCapture Occurs when this element loses mouse capture. 

LostStylusCapture Occurs when this element loses stylus capture. 

LostTouchCapture Occurs when this element loses a touch capture. 

MouseDown Occurs when any mouse button is pressed while the pointer is over 

this element. 

MouseEnter Occurs when the mouse pointer enters the bounds of this element. 

MouseLeave Occurs when the mouse pointer leaves the bounds of this element. 

MouseLeftButtonDown Occurs when the left mouse button is pressed while the mouse 

pointer is over this element. 
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ContainerUIElement3D ModelUIElement3D 

MouseLeftButtonUp Occurs when the left mouse button is released while the mouse 

pointer is over this element. 

MouseMove Occurs when the mouse pointer moves while over this element. 

MouseRightButtonDown Occurs when the right mouse button is pressed while the mouse 

pointer is over this element. 

MouseRightButtonUp Occurs when the right mouse button is released while the mouse 

pointer is over this element. 

MouseUp Occurs when any mouse button is released over this element. 

MouseWheel Occurs when the user rotates the mouse wheel while the mouse 

pointer is over this element. 

PreviewDragEnter Occurs when the input system reports an underlying drag event 

with this element as the drag target. 

PreviewDragLeave Occurs when the input system reports an underlying drag event 

with this element as the drag origin. 

PreviewDragOver Occurs when the input system reports an underlying drag event 

with this element as the potential drop target. 

PreviewDrop Occurs when the input system reports an underlying drop event 

with this element as the drop target. 

PreviewGiveFeedback Occurs when a drag-and-drop operation is started. 

PreviewGotKeyboardFocus Occurs when the keyboard is focused on this element. 

PreviewKeyDown Occurs when a key is pressed while the keyboard is focused on this 

element. 

PreviewKeyUp Occurs when a key is released while the keyboard is focused on this 

element. 

PreviewLostKeyboardFocus Occurs when the keyboard is no longer focused on this element. 

PreviewMouseDown Occurs when any mouse button is pressed while the pointer is over 

this element. 

PreviewMouseLeftButtonDown Occurs when the left mouse button is pressed while the mouse 

pointer is over this element. 

PreviewMouseLeftButtonUp Occurs when the left mouse button is released while the mouse 

pointer is over this element. 

PreviewMouseMove Occurs when the mouse pointer moves while the mouse pointer is 

over this element. 

PreviewMouseRightButtonDown Occurs when the right mouse button is pressed while the mouse 

pointer is over this element. 

PreviewMouseRightButtonUp Occurs when the right mouse button is released while the mouse 

pointer is over this element. 
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ContainerUIElement3D ModelUIElement3D 

PreviewMouseUp Occurs when any mouse button is released while the mouse pointer 

is over this element. 

PreviewMouseWheel Occurs when the user rotates the mouse wheel while the mouse 

pointer is over this element. 

PreviewQueryContinueDrag Occurs when there is a change in the keyboard or mouse button 

state during a drag-and-drop operation. 

PreviewStylusButtonDown Occurs when the stylus button is pressed while the pointer is over 

this element. 

PreviewStylusButtonUp Occurs when the stylus button is released while the pointer is over 

this element. 

PreviewStylusDown Occurs when the stylus touches the digitizer while it is over this 

element. 

PreviewStylusInAirMove Occurs when the stylus moves over an element without actually 

touching the digitizer. 

PreviewStylusInRange Occurs when the stylus is close enough to the digitizer to be 

detected, while over this element. 

PreviewStylusMove Occurs when the stylus moves while over the element. The stylus 

must move while being detected by the digitizer to raise this event, 

otherwise, PreviewStylusInAirMove is raised instead. 

PreviewStylusOutOfRange Occurs when the stylus is too far from the digitizer to be detected. 

PreviewStylusSystemGesture Occurs when a user performs one of several stylus gestures. 

PreviewStylusUp Occurs when the user raises the stylus off the digitizer while the 

stylus is over this element. 

PreviewTextInput Occurs when this element gets text in a device-independent 

manner. 

PreviewTouchDown Occurs when a finger touches the screen while the finger is over 

this element. 

PreviewTouchMove Occurs when a finger moves on the screen while the finger is over 

this element. 

PreviewTouchUp Occurs when a finger is raised off of the screen while the finger is 

over this element. 

QueryContinueDrag Occurs when there is a change in the keyboard or mouse button 

state during a drag-and-drop operation. 

QueryCursor Occurs when the cursor is requested to display. This event is raised 

on an element each time that the mouse pointer moves to a new 

location, which means the cursor object might need to be changed 

based on its new position. 

StylusButtonDown Occurs when the stylus button is pressed while the pointer is over 

this element. 
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ContainerUIElement3D ModelUIElement3D 

StylusButtonUp Occurs when the stylus button is released while the pointer is over 

this element. 

StylusDown Occurs when the stylus touches the digitizer while the stylus is over 

this element. 

StylusEnter Occurs when the stylus enters the bounds of this element. 

StylusInAirMove Occurs when the stylus moves over an element without actually 

touching the digitizer. 

StylusInRange Occurs when the stylus is close enough to the digitizer to be 

detected, while over this element. 

StylusLeave Occurs when the stylus leaves the bounds of the element. 

StylusMove Occurs when the stylus moves over this element. The stylus must 

move while on the digitizer to raise this event. Otherwise, 

StylusInAirMove is raised instead. 

StylusOutOfRange Occurs when the stylus is too far from the digitizer to be detected, 

while over this element. 

StylusSystemGesture Occurs when a user performs one of several stylus gestures. 

StylusUp Occurs when the user raises the stylus off the digitizer while it is 

over this element. 

TextInput Occurs when this element gets text in a device-independent 

manner. 

TouchDown Occurs when a finger touches the screen while the finger is over 

this element. 

TouchEnter Occurs when a touch moves from outside to inside the bounds of 

this element. 

TouchLeave Occurs when a touch moves from inside to outside the bounds of 

this element. 

TouchMove Occurs when a finger moves on the screen while the finger is over 

this element. 

TouchUp Occurs when a finger is raised off of the screen while the finger is 

over this element. 

4.958   UIElementCollection 

x:Object > UIElementCollection 

(usage) None. 

(description) Represents an ordered collection of UIElement child elements. 

(used by) FixedPage InkCanvas Panel 

[is default constructible] false 
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(usage) None. 

[is list] true 

[allowed types] UIElement 

(properties)  

Capacity x:Int32 

(description) The number of elements that the UIElementCollection can contain. 

4.959   Underline 

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement > 

Inline > Span > Underline, IInputElement 

(usage) <Underline>[Inline|UIElement|x:String]*</Underline> 

(description) An inline-level flow content element which causes content to appear with an 

underlined text decoration. 

[content 

property] 

Inlines 

[name property] Name 

[xml lang 

property] 

Language 

4.960   UndoAction 

x:Object > UndoAction 

(usage) None| Merge| Undo| Redo| Clear| Create 

(description) How the undo stack caused or is affected by a text change. 

[is nullable] false 

[text syntax] UndoActionSyntax 

4.961   UniformGrid 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > UniformGrid, 
IInputElement 

(usage) <UniformGrid>UIElement*</UniformGrid> 

(description) Provides a way to arrange content in a grid where all the cells in the grid have the 

same size. 

[content 

property] 

Children 

[name property] Name 
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(usage) <UniformGrid>UIElement*</UniformGrid> 

[xml lang 

property] 

Language 

(properties)  

Columns x:Int32 

(description) The number of columns that are in the grid. 

FirstColumn x:Int32 

(description) The number of leading blank cells in the first row of the grid. 

Rows x:Int32 

(description) The number of rows that are in the grid. 

4.962   UpdateSourceTrigger 

x:Object > UpdateSourceTrigger 

(usage) Default| PropertyChanged| LostFocus| Explicit 

(description) Describes the timing of binding source updates. 

(used by) Binding MultiBinding 

[is nullable] false 

[text syntax] UpdateSourceTriggerSyntax 

4.963   UserControl 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > UserControl, IInputElement 

(usage) <UserControl>x:Object</UserControl> 

(description) Provides a simple way to create a control. 

[content property] Content 

[name property] Name 

[xml lang property] Language 

4.964   Validation 

x:Object > Validation 

(usage) None. 

(description) Provides support for data validation. 
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(usage) None. 

[is default constructible] false 

(attachable properties)  

Validation.ErrorTemplate ControlTemplate 

(description) The ControlTemplate used to generate validation error feedback 

on the adorner layer. 

[target type] DependencyObject 

Validation.ValidationAdornerSite DependencyObject 

(description) The element that appears to indicate that a validation error 

occurred on the bound element where this property is set. 

[target type] DependencyObject 

Validation.ValidationAdornerSiteFor DependencyObject 

(description) The element for which this element appears to indicate that an 

error occurred. 

[target type] DependencyObject 

(attachable events)  

Validation.Error Occurs when the bound element runs into a validation error, 

but only for bindings with the NotifyOnValidationError value set 

to true. 

4.965   ValidationErrorEventAction 

x:Object > ValidationErrorEventAction 

(usage) Added| Removed 

(description) Describes whether a ValidationError object has been added or cleared. 

[is nullable] false 

[text syntax] ValidationErrorEventActionSyntax 

4.966   ValidationResult 

x:Object > ValidationResult 

(usage) {x:Static ValidationResult.StaticPropertyName} 

(description) Represents the result returned by the validation rule that indicates whether the 

checked value passed. 

[is default 

constructible] 

false 
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(usage) {x:Static ValidationResult.StaticPropertyName} 

(static properties)  

ValidResult ValidationResult 

(description) A valid instance of ValidationResult. 

4.967   ValidationRule 

x:Object > ValidationRule 

DataErrorValidationRule ExceptionValidationRule NotifyDataErrorValidationRule 

(usage) None. 

(description) Provides a way to create a custom rule in order to check the validity of 

user input. 

(used by) Binding BindingGroup DataGrid MultiBinding 

[is default constructible] false 

(properties)  

ValidatesOnTargetUpdated x:Boolean 

(description) A value that indicates whether the validation rule runs when the target of 

the Binding is updated. 

ValidationStep ValidationStep 

(description) When the validation rule runs. 

4.968   ValidationStep 

x:Object > ValidationStep 

(usage) RawProposedValue| ConvertedProposedValue| UpdatedValue| CommittedValue 

(description) Specifies when a ValidationRule runs. 

(used by) ValidationRule 

[is nullable] false 

[text syntax] ValidationStepSyntax 

4.969   ValueSource 

x:Object > ValueSource 

(usage) <ValueSource /> 

(description) Reports the information returned from DependencyProperty). 
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(usage) <ValueSource /> 

[is nullable] false 

4.970   Vector 

x:Object > Vector 

(usage) <Vector> string </Vector> 

(description) Represents a displacement in 2-D space. 

(used by) ContainerVisual InertiaExpansionBehavior InertiaTranslationBehavior VectorCollection 

VectorKeyFrame Viewport3DVisual 

[is nullable] false 

[text 

syntax] 

VectorSyntax 

(properties)  

X x:Double 

(description) The X component of this vector. 

Y x:Double 

(description) The Y component of this vector. 

4.971   Vector3D 

x:Object > Vector3D 

(usage) <Vector3D> string </Vector3D> 

(description) Represents a displacement in 3-D space. 

(used by) AxisAngleRotation3D DirectionalLight ProjectionCamera SpotLight Vector3DCollection 

Vector3DKeyFrame 

[is nullable] false 

[text 

syntax] 

Vector3DSyntax 

(properties)  

X x:Double 

(description) The X component of this Vector3D structure. 

Y x:Double 

(description) The Y component of this Vector3D structure. 

Z x:Double 
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(usage) <Vector3D> string </Vector3D> 

(description) The Z component of this Vector3D structure. 

4.972   Vector3DAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Vector3DAnimationBase > Vector3DAnimation 

(usage) <Vector3DAnimation /> 

(description) Animates the value of a Vector3D property using linear interpolation between two 

values. 

[name 

property] 

Name 

(properties)  

By x:Nullable(Vector3D) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Vector3D) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Vector3D) 

(description) The animation's ending value. 

4.973   Vector3DAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Vector3DAnimationBase 

Vector3DAnimation Vector3DAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that represents an animated Vector3D value. 

[is default constructible] false 
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Vector3DAnimation Vector3DAnimationUsingKeyFrames 

[name property] Name 

4.974   Vector3DAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
Vector3DAnimationBase > Vector3DAnimationUsingKeyFrames 

(usage) <Vector3DAnimationUsingKeyFrames>Vector3DKeyFrame*</Vector3DAnimationUsingKeyFra

mes> 

(description

) 

Animates the value of a Vector3D property along a set of KeyFrames. 

[content 

property] 

KeyFrames 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description

) 

A value that specifies whether the animation's output value is added to the base value of the 

property being animated. 

IsCumulativ

e 

x:Boolean 

(description

) 

A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames Vector3DKeyFrameCollection 

(description

) 

The collection of Vector3DKeyFrame objects that define the animation. 

4.975   Vector3DCollection 

x:Object > DependencyObject > Freezable > Vector3DCollection 

(usage) <Vector3DCollection> string </Vector3DCollection> 

(description) Collection of Vector3D objects. 

(used by) MeshGeometry3D 

[text syntax] Vector3DCollectionSyntax 

[is list] true 

[allowed types] Vector3D 
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4.976   Vector3DKeyFrame 

x:Object > DependencyObject > Freezable > Vector3DKeyFrame 

DiscreteVector3DKeyFrame EasingVector3DKeyFrame LinearVector3DKeyFrame 

SplineVector3DKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a Vector3DAnimationUsingKeyFrames. 

(used by) Vector3DKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 

Value Vector3D 

(description) The key frame's target value. 

4.977   Vector3DKeyFrameCollection 

x:Object > DependencyObject > Freezable > Vector3DKeyFrameCollection 

(usage) <Vector3DKeyFrameCollection>Vector3DKeyFrame*</Vector3DKeyFrameCollection> 

(description) Represents a collection of Vector3DKeyFrame objects. 

(used by) Vector3DAnimationUsingKeyFrames 

[is list] true 

[allowed types] Vector3DKeyFrame 

(static 

properties) 

 

Empty Vector3DKeyFrameCollection 

(description) An empty Vector3DKeyFrameCollection. 

4.978   VectorAnimation 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
VectorAnimationBase > VectorAnimation 

(usage) <VectorAnimation /> 

(description) Animates the value of a Vector property between two target values using linear 

interpolation over a specified Duration. 
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(usage) <VectorAnimation /> 

[name 

property] 

Name 

(properties)  

By x:Nullable(Vector) 

(description) The total amount by which the animation changes its starting value. 

EasingFunction IEasingFunction 

(description) The easing function applied to this animation. 

From x:Nullable(Vector) 

(description) The animation's starting value. 

IsAdditive x:Boolean 

(description) A value that indicates whether the target property's current value should be added to 

this animation's starting value. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

To x:Nullable(Vector) 

(description) The animation's ending value. 

4.979   VectorAnimationBase 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 

VectorAnimationBase 

VectorAnimation VectorAnimationUsingKeyFrames 

(usage) None. 

(description) A base type that animates a Vector value. 

[is default constructible] false 

[name property] Name 

4.980   VectorAnimationUsingKeyFrames 

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline > 
VectorAnimationBase > VectorAnimationUsingKeyFrames 

(usage) <VectorAnimationUsingKeyFrames>VectorKeyFrame*</VectorAnimationUsingKeyFrames> 

(description) Animates the value of a Vector property along a set of KeyFrames. 

[content KeyFrames 
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(usage) <VectorAnimationUsingKeyFrames>VectorKeyFrame*</VectorAnimationUsingKeyFrames> 

property] 

[name 

property] 

Name 

(properties)  

IsAdditive x:Boolean 

(description) A value that specifies whether the animation's output value is added to the base value of 

the property being animated. 

IsCumulative x:Boolean 

(description) A value that specifies whether the animation's value accumulates when it repeats. 

KeyFrames VectorKeyFrameCollection 

(description) The collection of VectorKeyFrame objects that define the animation. 

4.981   VectorCollection 

x:Object > DependencyObject > Freezable > VectorCollection 

(usage) <VectorCollection> string </VectorCollection> 

(description) Represents an ordered collection of Vector values. 

[text syntax] VectorCollectionSyntax 

[is list] true 

[allowed types] Vector 

4.982   VectorKeyFrame 

x:Object > DependencyObject > Freezable > VectorKeyFrame 

DiscreteVectorKeyFrame EasingVectorKeyFrame LinearVectorKeyFrame SplineVectorKeyFrame 

(usage) None. 

(description) A base type that defines an animation segment with its own target value and 

interpolation technique for a VectorAnimationUsingKeyFrames. 

(used by) VectorKeyFrameCollection 

[is default 

constructible] 

false 

(properties)  

KeyTime KeyTime 

(description) The time at which the key frame's target Value should be reached. 
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DiscreteVectorKeyFrame EasingVectorKeyFrame LinearVectorKeyFrame SplineVectorKeyFrame 

Value Vector 

(description) The key frame's target value. 

4.983   VectorKeyFrameCollection 

x:Object > DependencyObject > Freezable > VectorKeyFrameCollection 

(usage) <VectorKeyFrameCollection>VectorKeyFrame*</VectorKeyFrameCollection> 

(description) Represents a collection of VectorKeyFrame objects. 

(used by) VectorAnimationUsingKeyFrames 

[is list] true 

[allowed types] VectorKeyFrame 

(static properties)  

Empty VectorKeyFrameCollection 

(description) An empty VectorKeyFrameCollection. 

4.984   VerticalAlignment 

x:Object > VerticalAlignment 

(usage) Top| Center| Bottom| Stretch 

(description) Describes how a child element is vertically positioned or stretched within a parent's 

layout slot. 

(used by) Control FrameworkElement 

[is nullable] false 

[text 

syntax] 

VerticalAlignmentSyntax 

4.985   VideoDrawing 

x:Object > DependencyObject > Freezable > Animatable > Drawing > VideoDrawing 

(usage) <VideoDrawing /> 

(description) Plays a media file. If the media is a video file, the VideoDrawing draws it to the specified 

rectangle. 

(properties)  

Player MediaPlayer 

(description) The media player associated with the drawing. 
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(usage) <VideoDrawing /> 

Rect Rect 

(description) The rectangular area in which the video is drawn. 

4.986   ViewBase 

x:Object > DependencyObject > ViewBase 

GridView 

(usage) None. 

(description) Represents the base type for views that define the appearance of data in a 

ListView control. 

(used by) ListView 

[is default 

constructible] 

false 

4.987   Viewbox 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Decorator > Viewbox, 
IInputElement 

(usage) <Viewbox>UIElement</Viewbox> 

(description) Defines a content decorator that can stretch and scale a single child to fill the 

available space. 

[content property] Child 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  

Child UIElement 

(description) The single child of a Viewbox element. 

Stretch Stretch 

(description) The Viewbox Stretch mode, which determines how content fits into the available 

space. 

StretchDirection StretchDirection 

(description) The StretchDirection, which determines how scaling is applied to the contents of a 

Viewbox. 
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4.988   Viewport2DVisual3D 

x:Object > DependencyObject > Visual3D > Viewport2DVisual3D 

(usage) <Viewport2DVisual3D>Visual</Viewport2DVisual3D> 

(description) Renders the 2-D children within the specified 3-D 

viewport bounds. 

[content property] Visual 

(properties)  

CacheMode CacheMode 

(description) A cached representation of the Viewport2DVisual3D. 

Geometry Geometry3D 

(description) The 3-D geometry for this Viewport2DVisual3D. 

Material Material 

(description) The material that describes the appearance of the 3-D 

object. 

Visual Visual 

(description) The 2-D visual to be placed on the 3-D object. 

(attachable properties)  

Viewport2DVisual3D.IsVisualHostMaterial x:Boolean 

(description) A value that specifies whether a material should be 

interactive. 

[target type] Material 

4.989   Viewport3D 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Viewport3D, 
IInputElement 

(usage) <Viewport3D>Visual3D*</Viewport3D> 

(description) Renders the contained 3-D content within the 2-D layout bounds of the Viewport3D 

element. 

[content 

property] 

Children 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  
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(usage) <Viewport3D>Visual3D*</Viewport3D> 

Camera Camera 

(description) A camera object that projects the 3-D contents of the Viewport3D to the 2-D 

surface of the Viewport3D. 

Children Visual3DCollection 

(description) A collection of the Visual3D children of the Viewport3D. 

[read only] true 

4.990   Viewport3DVisual 

x:Object > DependencyObject > Visual > Viewport3DVisual 

(usage) <Viewport3DVisual>Visual3D*</Viewport3DVisual> 

(description) Renders the Visual3D children within the specified 2D viewport bounds. 

[content property] Children 

(properties)  

Camera Camera 

(description) The Camera used by the Viewport3DVisual. 

Children Visual3DCollection 

(description) A collection of Visual3D objects contained by Viewport3DVisual. 

[read only] true 

Clip Geometry 

(description) The clipping region of the Viewport3DVisual. 

Offset Vector 

(description) The offset value of the Viewport3DVisual. 

Opacity x:Double 

(description) The opacity of the Viewport3DVisual. 

OpacityMask Brush 

(description) The opacity mask value of the Viewport3DVisual. 

Transform Transform 

(description) The transform value of the Viewport3DVisual. 

Viewport Rect 

(description) The rectangle in which the Viewport3DVisual will be rendered. 
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4.991   VirtualizationCacheLength (4.5) 

x:Object > VirtualizationCacheLength 

(usage) <VirtualizationCacheLength> string </VirtualizationCacheLength> 

(description) Represents the measurements for the CacheLength attached property. 

(used by) VirtualizingPanel 

[is nullable] false 

[text syntax] VirtualizationCacheLengthSyntax 

4.992   VirtualizationCacheLengthUnit (4.5) 

x:Object > VirtualizationCacheLengthUnit 

(usage) Pixel| Item| Page 

(description) Specifies the type of unit that is used by the CacheLength attached property. 

(used by) VirtualizingPanel 

[is nullable] false 

[text syntax] VirtualizationCacheLengthUnitSyntax 

4.993   VirtualizationMode 

x:Object > VirtualizationMode 

(usage) Standard| Recycling 

(description) Specifies the method the VirtualizingStackPanel uses to manage virtualizing its child 

items. 

(used by) VirtualizingPanel 

[is nullable] false 

[text syntax] VirtualizationModeSyntax 

4.994   VirtualizingPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > 

VirtualizingPanel, IInputElement 

DataGridCellsPanel VirtualizingStackPanel 

(usage) None. 

(description) A base type for panels that virtualize their child 

data collection. 

[is default constructible] false 
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DataGridCellsPanel VirtualizingStackPanel 

[content property] Children 

[name property] Name 

[xml lang property] Language 

(attachable properties)  

VirtualizingPanel.CacheLength (4.5) VirtualizationCacheLength 

(description) The size of the cache before and after the viewport 

when the VirtualizingPanel is virtualizing. 

[target type] DependencyObject 

VirtualizingPanel.CacheLengthUnit (4.5) VirtualizationCacheLengthUnit 

(description) The type of unit that is used by the CacheLength 

property. 

[target type] DependencyObject 

VirtualizingPanel.IsContainerVirtualizable 

(4.5) 

x:Boolean 

(description) Get or sets a value that indicates whether this 

VirtualizingPanel should virtualize an item. 

[target type] DependencyObject 

VirtualizingPanel.IsVirtualizing (4.5) x:Boolean 

(description) A value that indicates that this VirtualizingPanel is 

virtualizing its child collection. 

[target type] DependencyObject 

VirtualizingPanel.IsVirtualizingWhenGrouping 

(4.5) 

x:Boolean 

(description) A value that indicates whether this 

VirtualizingPanel virtualizes the items in its 

collection when it displays groups. 

[target type] DependencyObject 

VirtualizingPanel.ScrollUnit (4.5) ScrollUnit 

(description) A value that indicates whether scrolling is 

measured as items in the collection or as pixels. 

[target type] DependencyObject 

VirtualizingPanel.VirtualizationMode (4.5) VirtualizationMode 

(description) How a panel in an ItemsControl virtualizes its child 

items. 
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DataGridCellsPanel VirtualizingStackPanel 

[target type] DependencyObject 

4.995   VirtualizingStackPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > 
VirtualizingPanel > VirtualizingStackPanel, IInputElement 

DataGridRowsPresenter 

(usage) <VirtualizingStackPanel>UIElement*</VirtualizingStackPa

nel> 

(description) Arranges and virtualizes content on a single line that is 

oriented either horizontally or vertically. 

[content property] Children 

[name property] Name 

[xml lang property] Language 

(properties)  

CanHorizontallyScroll x:Boolean 

(description) A value that indicates whether a VirtualizingStackPanel 

can scroll in the horizontal dimension. 

CanVerticallyScroll x:Boolean 

(description) A value that indicates whether content can scroll in the 

vertical dimension. 

Orientation Orientation 

(description) A value that describes the horizontal or vertical orientation 

of stacked content. 

ScrollOwner ScrollViewer 

(description) A value that identifies the container that controls scrolling 

behavior in this VirtualizingStackPanel. 

(attachable events)  

VirtualizingStackPanel.CleanUpVirtualizedI

tem 

Occurs when an item is being re-virtualized by the 

ItemsControl that is associated with this instance of 

VirtualizingStackPanel. 

4.996   Visibility 

x:Object > Visibility 

(usage) Visible| Hidden| Collapsed 
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(usage) Visible| Hidden| Collapsed 

(description) Specifies the display state of an element. 

(used by) DataGridColumn DataGridColumnHeader DataGridRow DataGridRowHeader Ribbon 

RibbonGalleryCategory ThumbButtonInfo UIElement UIElement3D 

[is nullable] false 

[text 

syntax] 

VisibilitySyntax 

4.997   Visual 

x:Object > DependencyObject > Visual 

ContainerVisual UIElement Viewport3DVisual 

(usage) None. 

(description) Represents a visual object. 

(used by) BitmapCacheBrush Viewport2DVisual3D VisualBrush VisualCollection 

[is default constructible] false 

4.998   Visual3D 

x:Object > DependencyObject > Visual3D 

ModelVisual3D UIElement3D Viewport2DVisual3D 

(usage) None. 

(description) Provides services and properties that are common to visual 3-D objects, including 

hit-testing, coordinate transformation, and bounding box calculations. 

(used by) Visual3DCollection 

[is default 

constructible] 

false 

(properties)  

Transform Transform3D 

(description) The transformation that is applied to the 3-D object. 

4.999   Visual3DCollection 

x:Object > Visual3DCollection 

(usage) None. 

(description) Represents an ordered collection of Visual3D objects. 
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(usage) None. 

(used by) ContainerUIElement3D ModelVisual3D Viewport3D Viewport3DVisual 

[is default constructible] false 

[is list] true 

[allowed types] Visual3D 

4.1000   VisualBrush 

x:Object > DependencyObject > Freezable > Animatable > Brush > TileBrush > VisualBrush 

(usage) <VisualBrush> string </VisualBrush> 

(description) Paints an area with a Visual. 

[text syntax] BrushSyntax 

(properties)  

AutoLayoutContent x:Boolean 

(description) A value that specifies whether this VisualBrush will run layout its Visual. 

Visual Visual 

(description) The brush's content. 

4.1001   VisualCollection 

x:Object > VisualCollection 

(usage) None. 

(description) Represents an ordered collection of Visual objects. 

(used by) ContainerVisual 

[is default constructible] false 

[is list] true 

[allowed types] Visual 

(properties)  

Capacity x:Int32 

(description) The number of elements that the VisualCollection can contain. 

4.1002   VisualState 

x:Object > DependencyObject > VisualState 
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(usage)  

(description) Represents the visual appearance of the control when it is in a specific state. 

(used by) VisualStateGroup 

[content 

property] 

Storyboard 

[name property] Name 

(properties)  

Name x:String 

(description) The name of the VisualState. 

Storyboard Storyboard 

(description) A Storyboard that defines the appearance of the control when it is in the state that is 

represented by the VisualState. 

4.1003   VisualStateGroup 

x:Object > DependencyObject > VisualStateGroup 

(usage) <VisualStateGroup>x:Object*</VisualStateGroup> 

(description) Contains mutually exclusive VisualState objects and VisualTransition objects 

that are used to move from one state to another. 

[content property] States 

[name property] Name 

(properties)  

CurrentState VisualState 

(description) The VisualState that is currently applied to the control. 

Name x:String 

(description) The name of the VisualStateGroup. 

States IList 

(description) The collection of mutually exclusive VisualState objects. 

[read only] true 

Transitions IList 

(description) The collection of VisualTransition objects. 

[read only] true 

(events)  
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(usage) <VisualStateGroup>x:Object*</VisualStateGroup> 

CurrentStateChanged Occurs after a control transitions to a different state. 

CurrentStateChanging Occurs when a control starts transitioning to a different state. 

4.1004   VisualStateManager 

x:Object > DependencyObject > VisualStateManager 

(usage) <VisualStateManager /> 

(description) Manages states and the logic for transitioning 

between states for controls. 

(used by) VisualStateManager 

(attachable properties)  

VisualStateManager.CustomVisualStateManager VisualStateManager 

(description) The VisualStateManager object that transitions 

between the states of a control. 

[target type] FrameworkElement 

VisualStateManager.VisualStateGroups IList 

(description) A collection of VisualStateGroup objects. 

[target type] FrameworkElement 

[read only] true 

4.1005   VisualTransition 

x:Object > DependencyObject > VisualTransition 

(usage) <VisualTransition>Storyboard</VisualTransition> 

(description) Represents the visual behavior that occurs when a control transitions from 

one state to another. 

[content property] Storyboard 

(properties)  

From x:String 

(description) The name of the VisualState to transition from. 

GeneratedDuration Duration 

(description) The time that it takes to move from one state to another. 

GeneratedEasingFunction IEasingFunction 
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(usage) <VisualTransition>Storyboard</VisualTransition> 

(description) A custom mathematical formula that is used to transition between states. 

Storyboard Storyboard 

(description) The Storyboard that occurs when the transition occurs. 

To x:String 

(description) The name of the VisualState to transition to. 

4.1006   VisualTreeHelper 

x:Object > VisualTreeHelper 

(usage) None. 

(description) Provides support for performing common tasks that involve 

nodes in a visual tree. 

[is default constructible] false 

(attachable properties)  

VisualTreeHelper.XSnappingGuidelines DoubleCollection 

(description)  

[target type] Visual 

[read only] true 

VisualTreeHelper.YSnappingGuidelines DoubleCollection 

(description)  

[target type] Visual 

[read only] true 

4.1007   WebBrowser 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > ActiveXHost > 

WebBrowser, IInputElement 

(usage) <WebBrowser /> 

(description) Hosts and navigates between HTML documents. Enables interoperability between 

managed code and HTML script. 

[name property] Name 

[xml lang 

property] 

Language 

(properties)  
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(usage) <WebBrowser /> 

ObjectForScripting x:Object 

(description) An instance of a public type, implemented by the host application, that can be 

accessed by script from a hosted document. 

Source x:Uri 

(description) The Uri of the current document hosted in the WebBrowser. 

(events)  

LoadCompleted Occurs when the document being navigated to has finished downloading. 

Navigated Occurs when the document being navigated to is located and has started 

downloading. 

Navigating Occurs just before navigation to a document. 

4.1008   Window 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control > 
ContentControl > Window, IInputElement 

NavigationWindow RibbonWindow 

(usage) <Window>x:Object</Window> 

(description) Provides the ability to create, configure, show, and manage the lifetime of 

windows and dialog boxes. 

(used by) Application Window 

[content property] Content 

[name property] Name 

[xml lang property] Language 

(properties)  

AllowsTransparency x:Boolean 

(description) A value that indicates whether a window's client area supports transparency. 

DialogResult x:Nullable(x:Boolean) 

(description) The dialog result value, which is the value that is returned from the 

ShowDialog method. 

[text syntax] DialogResultSyntax 

Icon ImageSource 

(description) A window's icon. 

Left x:Double 
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NavigationWindow RibbonWindow 

(description) The position of the window's left edge, in relation to the desktop. 

[text syntax] LengthSyntax 

Owner Window 

(description) The Window that owns this Window. 

ResizeMode ResizeMode 

(description) The resize mode. 

ShowActivated x:Boolean 

(description) A value that indicates whether a window is activated when first shown. 

ShowInTaskbar x:Boolean 

(description) A value that indicates whether the window has a task bar button. 

SizeToContent SizeToContent 

(description) A value that indicates whether a window will automatically size itself to fit 

the size of its content. 

TaskbarItemInfo TaskbarItemInfo 

(description) The Windows 7 taskbar thumbnail for the Window. 

Title x:String 

(description) A window's title. 

Top x:Double 

(description) The position of the window's top edge, in relation to the desktop. 

[text syntax] LengthSyntax 

Topmost x:Boolean 

(description) A value that indicates whether a window appears in the topmost z-order. 

WindowStartupLocation WindowStartupLocation 

(description) The position of the window when first shown. 

WindowState WindowState 

(description) A value that indicates whether a window is restored, minimized, or 

maximized. 

WindowStyle WindowStyle 

(description) A window's border style. 

(events)  

Activated Occurs when a window becomes the foreground window. 
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NavigationWindow RibbonWindow 

Closed Occurs when the window is about to close. 

Closing Occurs directly after Close is called, and can be handled to cancel window 

closure. 

ContentRendered Occurs after a window's content has been rendered. 

Deactivated Occurs when a window becomes a background window. 

LocationChanged Occurs when the window's location changes. 

SourceInitialized This event is raised to support interoperation. 

StateChanged Occurs when the window's WindowState property changes. 

4.1009   WindowChrome (4.5) 

x:Object > DependencyObject > Freezable > WindowChrome 

(usage) <WindowChrome /> 

(description) Represents an object that describes the customizations 

to the non-client area of a window. 

(used by) WindowChrome 

(properties)  

CaptionHeight x:Double 

(description) The height of the caption area at the top of a window. 

CornerRadius CornerRadius 

(description) A value that indicates the amount that the corners of a 

window are rounded. 

GlassFrameThickness Thickness 

(description) A value that indicates the width of the glass border 

around a window. 

NonClientFrameEdges NonClientFrameEdges 

(description) A value that indicates which edges of the window frame 

are not owned by the client. 

ResizeBorderThickness Thickness 

(description) A value that indicates the width of the border that is 

used to resize a window. 

UseAeroCaptionButtons x:Boolean 

(description) A value that indicates whether hit-testing is enabled on 

the Windows Aero caption buttons. 
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(usage) <WindowChrome /> 

(attachable properties)  

WindowChrome.IsHitTestVisibleInChrome x:Boolean 

(description) A value that indicates whether hit-testing is enabled on 

the part of an element that is in the non-client area of a 

window. 

[target type] IInputElement 

WindowChrome.ResizeGripDirection ResizeGripDirection 

(description) A value that indicates the direction of the resize grip 

behavior on an input element. 

[target type] IInputElement 

WindowChrome.WindowChrome WindowChrome 

(description) The instance of WindowChrome that is attached to a 

window. 

[target type] Window 

(static properties)  

GlassFrameCompleteThickness Thickness 

(description) A uniform thickness of -1. 

4.1010   WindowCollection 

x:Object > WindowCollection 

(usage) <WindowCollection /> 

(description) Represents a collection of Window objects. 

4.1011   WindowStartupLocation 

x:Object > WindowStartupLocation 

(usage) Manual| CenterScreen| CenterOwner 

(description) Specifies the position that a Window will be shown in when it is first opened. Used by the 

WindowStartupLocation property. 

(used by) Window 

[is nullable] false 

[text 

syntax] 

WindowStartupLocationSyntax 
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4.1012   WindowState 

x:Object > WindowState 

(usage) Normal| Minimized| Maximized 

(description) Specifies whether a window is minimized, maximized, or restored. Used by the 

WindowState property. 

(used by) Window 

[is nullable] false 

[text 

syntax] 

WindowStateSyntax 

4.1013   WindowStyle 

x:Object > WindowStyle 

(usage) None| SingleBorderWindow| ThreeDBorderWindow| ToolWindow 

(description) Specifies the type of border that a Window has. Used by the WindowStyle property. 

(used by) Window 

[is nullable] false 

[text syntax] WindowStyleSyntax 

4.1014   WmpBitmapEncoder 

x:Object > BitmapEncoder > WmpBitmapEncoder 

(usage) <WmpBitmapEncoder /> 

(description) Defines an encoder that is used to encode Microsoft Windows Media 

Photo images. 

(properties)  

AlphaDataDiscardLevel x:Byte 

(description) The level of alpha frequency data to discard during a compressed 

domain transcode. 

AlphaQualityLevel x:Byte 

(description) The compression quality for a planar alpha channel. 

CompressedDomainTranscode x:Boolean 

(description) A value that indicates whether compressed domain operations can be 

used. Compressed domain operations are transformation operations 

that are done without decoding the image data. 

FlipHorizontal x:Boolean 
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(usage) <WmpBitmapEncoder /> 

(description) A value indicating whether to flip the image horizontally. 

FlipVertical x:Boolean 

(description) A value that indicates whether to flip the image vertically. 

FrequencyOrder x:Boolean 

(description) A value that indicates whether to encoding in frequency order. 

HorizontalTileSlices x:Int16 

(description) The number of horizontal divisions to use during compression 

encoding. A single division creates two horizontal regions. 

IgnoreOverlap x:Boolean 

(description) A value that indicates whether to ignore region overlap pixels in 

subregion compressed domain encoding. 

ImageDataDiscardLevel x:Byte 

(description) The level of image data to discard during a compressed domain 

transcode. 

ImageQualityLevel x:Single 

(description) The image quality level. 

InterleavedAlpha x:Boolean 

(description) A value that indicates whether to encode the alpha channel data as an 

additional interleaved channel. 

Lossless x:Boolean 

(description) A value that indicates whether to encode using lossless compression. 

OverlapLevel x:Byte 

(description) The overlap processing level. 

QualityLevel x:Byte 

(description) The compression quality for the main image. 

Rotation Rotation 

(description) The Rotation of the image. 

SubsamplingLevel x:Byte 

(description) The sub-sampling level for RGB image encoding. 

UseCodecOptions x:Boolean 

(description) A value that indicates codec options are to be used. 
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(usage) <WmpBitmapEncoder /> 

VerticalTileSlices x:Int16 

(description) The number of vertical divisions to use during compression encoding. 

A single division creates two vertical regions. 

4.1015   WrapDirection 

x:Object > WrapDirection 

(usage) None| Left| Right| Both 

(description) Specifies the allowable directions that content can wrap around an object. 

(used by) Block Figure 

[is nullable] false 

[text syntax] WrapDirectionSyntax 

4.1016   WrapPanel 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Panel > WrapPanel, 
IInputElement 

(usage) <WrapPanel>UIElement*</WrapPanel> 

(description) Positions child elements in sequential position from left to right, breaking content to the 

next line at the edge of the containing box. Subsequent ordering happens sequentially 

from top to bottom or from right to left, depending on the value of the Orientation 

property. 

[content 

property] 

Children 

[name 

property] 

Name 

[xml lang 

property] 

Language 

(properties)  

ItemHeight x:Double 

(description) A value that specifies the height of all items that are contained within a WrapPanel. 

[text syntax] LengthSyntax 

ItemWidth x:Double 

(description) A value that specifies the width of all items that are contained within a WrapPanel. 

[text syntax] LengthSyntax 

Orientation Orientation 
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(usage) <WrapPanel>UIElement*</WrapPanel> 

(description) A value that specifies the dimension in which child content is arranged. 

4.1017   WriteableBitmap 

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource > 
WriteableBitmap 

(usage) <WriteableBitmap> string </WriteableBitmap> 

(description) Provides a BitmapSource that can be written to and updated. 

[is default constructible] false 

[text syntax] x:Uri, from [MS-XAML] 

(properties)  

BackBuffer IntPtr 

(description) A pointer to the back buffer. 

4.1018   XmlDataProvider 

x:Object > DataSourceProvider > XmlDataProvider 

(usage) <XmlDataProvider><XData/></XmlDataProvider> 

(description) Enables declarative access to XML data for data binding. 

[content property] XmlSerializer 

(properties)  

IsAsynchronous x:Boolean 

(description) A value that indicates whether node collection creation will be performed in a 

worker thread or in the active context. 

Source x:Uri 

(description) The Uri of the XML data file to use as the binding source. 

XmlNamespaceManager XmlNamespaceManager 

(description) The XmlNamespaceManager used to run XPath queries. 

XmlSerializer IXmlSerializable 

(description) The inline XML content. 

[read only] true 

[is xdata] true 

XPath x:String 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) <XmlDataProvider><XData/></XmlDataProvider> 

(description) The XPath query used to generate the data collection. 

4.1019   XmlNamespaceMapping 

x:Object > XmlNamespaceMapping 

(usage) <XmlNamespaceMapping /> 

(description) Declares a mapping between a uniform resource identifier (URI) and a prefix. 

(used by) XmlNamespaceMappingCollection 

(properties)  

Prefix x:String 

(description) The prefix to use in XAML. 

Uri x:Uri 

(description) The Uri of the namespace for which to create a mapping. 

4.1020   XmlNamespaceMappingCollection 

x:Object > XmlNamespaceManager > XmlNamespaceMappingCollection 

(usage) <XmlNamespaceMappingCollection>XmlNamespaceMapping*</XmlNamespaceMappingColle

ction> 

(description

) 

Represents a collection of XmlNamespaceMapping objects. 

[is list] true 

[allowed 

types] 

XmlNamespaceMapping 

4.1021   ZoomPercentageConverter 

x:Object > ZoomPercentageConverter, IValueConverter 

(usage) <ZoomPercentageConverter /> 

(description) Implements a type converter for converting Double (used as the value of Zoom) to and 

from other types. 
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5   WPF XamlType Information Items for Assignable Types 

5.1   ActiveXHost 

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > ActiveXHost, 
IInputElement 

WebBrowser 

(usage) None. 

(description) Hosts an ActiveX control as an element within content. 

[is default constructible] false 

[name property] Name 

[xml lang property] Language 

5.2   x:Boolean 

x:Object > x:Boolean 

link to externally defined type x:Boolean, from [MS-XAML] 

5.3   x:Byte 

x:Object > x:Byte 

link to externally defined type x:Byte, from [MS-XAML] 

5.4   x:Char 

x:Object > x:Char 

link to externally defined type x:Char, from [MS-XAML] 

5.5   Collection(T) 

x:Object > Collection(T) 

ConditionCollection SetterBaseCollection StrokeCollection StylusPointCollection 

TouchPointCollection TriggerCollection 

(usage) <Collection x:TypeArguments="T">T*</Collection> 

(description)  

(used by) Binding BindingGroup MultiBinding PriorityBinding PropertyPath ResourceDictionary 

Ribbon ToolBarTray 

[is list] true 

http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
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ConditionCollection SetterBaseCollection StrokeCollection StylusPointCollection 

TouchPointCollection TriggerCollection 

[allowed 

types] 

T 

5.6   CollectionBase 

x:Object > CollectionBase 

LinkTargetCollection 

(usage) None. 

(description) Provides the base type for a strongly typed collection. 

[is default constructible] false 

[is list] true 

[allowed types] x:Object 

5.7   CultureInfo 

x:Object > CultureInfo 

(usage) <CultureInfo> string </CultureInfo> 

(description) Provides information about a specific culture. The information includes the names 

for the culture, the writing system, the calendar used, and formatting for dates and 

sort strings. 

(used by) Binding CollectionView CollectionViewSource InputLanguageManager MultiBinding 

NumberSubstitution 

[is default 

constructible] 

false 

[text syntax] CultureInfoSyntax 

5.8   DataSourceProvider 

x:Object > DataSourceProvider 

ObjectDataProvider XmlDataProvider 

(usage) None. 

(description) Common base type and contract for DataSourceProvider objects, which are 

factories that execute some queries to produce a single object or a list of objects 

that you can use as binding source objects. 

[is default 

constructible] 

false 
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5.9   x:DateTime 

x:Object > x:DateTime 

link to externally defined type x:DateTime, from [MS-XAML] 

5.10   DayOfWeek 

x:Object > DayOfWeek 

(usage) Sunday| Monday| Tuesday| Wednesday| Thursday| Friday| Saturday 

(description) Specifies the day of the week. 

(used by) Calendar DatePicker 

[is nullable] false 

[text syntax] DayOfWeekSyntax 

5.11   x:Decimal 

x:Object > x:Decimal 

link to externally defined type x:Decimal, from [MS-XAML] 

5.12   Delegate 

x:Object > Delegate 

(usage) <Delegate> string </Delegate> 

(description) Represents a delegate, which is a data structure that refers to a static method or 

to a type instance and an instance method of that type. 

(used by) EventSetter 

[is default 

constructible] 

false 

[text syntax] x:XamlEvent, from [MS-XAML] 

5.13   x:Double 

x:Object > x:Double 

link to externally defined type x:Double, from [MS-XAML] 

5.14   FreezableCollection(T) 

x:Object > DependencyObject > Freezable > Animatable > FreezableCollection(T) 

http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
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RibbonControlSizeDefinitionCollection RibbonGroupSizeDefinitionBaseCollection 

ThumbButtonInfoCollection 

(usage) <FreezableCollection x:TypeArguments="T">T*</FreezableCollection> 

(description)  

[is list] true 

[allowed types] T 

5.15   GroupDescription 

x:Object > GroupDescription 

PropertyGroupDescription 

(usage) None. 

(description) A base type that describes how to divide the items in a collection into 

groups. 

(used by) CollectionView CollectionViewSource ItemCollection 

[is default 

constructible] 

false 

5.16   ICollection(T) 

ICollection(T) 

BlockCollection CalendarBlackoutDatesCollection CharacterMetricsDictionary ClockCollection 

ColumnDefinitionCollection ConditionCollection DoubleCollection DrawingCollection 

FamilyTypefaceCollection FontFamilyMapCollection GeneralTransform3DCollection 

GeneralTransformCollection GeometryCollection GradientStopCollection GridViewColumnCollection 

InlineCollection Int32Collection LanguageSpecificStringDictionary ListItemCollection 

MaterialCollection Model3DCollection PathFigureCollection PathSegmentCollection 

Point3DCollection PointCollection RibbonControlSizeDefinitionCollection 

RibbonGroupSizeDefinitionBaseCollection RowDefinitionCollection SelectedDatesCollection 

SetterBaseCollection StrokeCollection StylusButtonCollection StylusDeviceCollection 

StylusPointCollection TableCellCollection TableColumnCollection TableRowCollection 

TableRowGroupCollection TextDecorationCollection TextEffectCollection 

TextElementCollection(TextElementCollection+TextElementType) ThumbButtonInfoCollection 

TimelineCollection TouchPointCollection Transform3DCollection TransformCollection 

TriggerActionCollectiont TriggerCollection Vector3DCollection VectorCollection Visual3DCollection 

XmlNamespaceMappingCollection 

(usage) None. 

(description)  

(used by) CharacterMetricsDictionary FontEmbeddingManager Fonts 

LanguageSpecificStringDictionary 

[is default constructible] false 

[is list] true 
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BlockCollection CalendarBlackoutDatesCollection CharacterMetricsDictionary ClockCollection 

ColumnDefinitionCollection ConditionCollection DoubleCollection DrawingCollection 

FamilyTypefaceCollection FontFamilyMapCollection GeneralTransform3DCollection 

GeneralTransformCollection GeometryCollection GradientStopCollection GridViewColumnCollection 

InlineCollection Int32Collection LanguageSpecificStringDictionary ListItemCollection 

MaterialCollection Model3DCollection PathFigureCollection PathSegmentCollection 

Point3DCollection PointCollection RibbonControlSizeDefinitionCollection 

RibbonGroupSizeDefinitionBaseCollection RowDefinitionCollection SelectedDatesCollection 

SetterBaseCollection StrokeCollection StylusButtonCollection StylusDeviceCollection 

StylusPointCollection TableCellCollection TableColumnCollection TableRowCollection 

TableRowGroupCollection TextDecorationCollection TextEffectCollection 

TextElementCollection(TextElementCollection+TextElementType) ThumbButtonInfoCollection 

TimelineCollection TouchPointCollection Transform3DCollection TransformCollection 

TriggerActionCollectiont TriggerCollection Vector3DCollection VectorCollection Visual3DCollection 

XmlNamespaceMappingCollection 

[allowed types] T 

5.17   ICommand (4.5) 

ICommand 

RoutedCommand RoutedUICommand 

(usage) <ICommand> string </ICommand> 

(description) Defines a command. 

(used by) ButtonBase CommandBinding Hyperlink InputBinding MenuItem RibbonGallery 

RibbonSplitButton RibbonTextBox ThumbButtonInfo 

[is default 

constructible] 

false 

[text syntax] CommandSyntax 

5.18   IDictionary 

IDictionary 

CharacterMetricsDictionary LanguageSpecificStringDictionary ResourceDictionary 

(usage) None. 

(description) Represents a nongeneric collection of key/value pairs. 

(used by) Application 

[is default constructible] false 

[is dictionary] true 

[allowed types] x:Object 

[allowed key types] x:Object 



 

642 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

5.19   IDictionary(T,U) 

IDictionary(T,U) 

CharacterMetricsDictionary LanguageSpecificStringDictionary 

(usage) None. 

(description) Represents a nongeneric collection of key/value pairs. 

(used by) FamilyTypeface GlyphTypeface 

[is default constructible] false 

[is dictionary] true 

[allowed types] x:String 

[allowed key types] CultureInfo 

5.20   IDocumentPaginatorSource 

IDocumentPaginatorSource 

FixedDocument FixedDocumentSequence FlowDocument 

(usage) None. 

(description) Defines the source object that performs actual content pagination. 

(used by) DocumentViewerBase 

[is default constructible] false 

5.21   IEnumerable 

IEnumerable 

(usage) None. 

(description) Exposes the enumerator, which supports a simple iteration over a non-generic 

collection. 

(used by) DataGridComboBoxColumn ItemsControl 

[is default 

constructible] 

false 

5.22   IList 

IList 

(usage) None. 

(description) Represents a non-generic collection of objects that can be individually accessed by 

index. 
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(usage) None. 

(used by) AlternationConverter BindingGroup IKeyFrameAnimation InputScope ListBox 

MultiSelector ObjectDataProvider SpellCheck VisualStateGroup VisualStateManager 

[is default 

constructible] 

false 

[is list] true 

[allowed types] x:Object 

5.23   IList(T) 

IList(T) 

CalendarBlackoutDatesCollection ColumnDefinitionCollection ConditionCollection DoubleCollection 

DrawingCollection FamilyTypefaceCollection FontFamilyMapCollection 

GeneralTransform3DCollection GeneralTransformCollection GeometryCollection 

GradientStopCollection GridViewColumnCollection Int32Collection MaterialCollection 

Model3DCollection PathFigureCollection PathSegmentCollection Point3DCollection PointCollection 

RibbonControlSizeDefinitionCollection RibbonGroupSizeDefinitionBaseCollection 

RowDefinitionCollection SelectedDatesCollection SetterBaseCollection StrokeCollection 

StylusButtonCollection StylusDeviceCollection StylusPointCollection TableCellCollection 

TableColumnCollection TableRowCollection TableRowGroupCollection TextDecorationCollection 

TextEffectCollection ThumbButtonInfoCollection TimelineCollection TouchPointCollection 

Transform3DCollection TransformCollection TriggerActionCollectiont TriggerCollection 

Vector3DCollection VectorCollection Visual3DCollection 

(usage) None. 

(description)  

(used by) BitmapEncoder DataGrid GlyphRun PixelFormat 

PixelFormatChannelMask 

[is default constructible] false 

[is list] true 

[allowed types] T 

5.24   x:Int16 

x:Object > x:Int16 

link to externally defined type x:Int16, from [MS-XAML] 

5.25   x:Int32 

x:Object > x:Int32 

link to externally defined type x:Int32, from [MS-XAML] 

http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715


 

644 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

5.26   x:Int64 

x:Object > x:Int64 

link to externally defined type x:Int64, from [MS-XAML] 

5.27   IntPtr 

x:Object > IntPtr 

(usage) <IntPtr /> 

(description) A platform-specific type that is used to represent a pointer or a handle. 

(used by) WriteableBitmap 

[is nullable] false 

5.28   IXmlSerializable 

IXmlSerializable 

(usage) None. 

(description) Provides custom formatting for XML serialization and deserialization. 

(used by) XmlDataProvider 

[is default constructible] false 

[is xdata] true 

5.29   List(T) 

x:Object > List(T) 

(usage) <List x:TypeArguments="T">T*</List> 

(description)  

(used by) JumpList 

[is list] true 

[allowed types] T 

5.30   ManipulationParameters2D (4.5) 

x:Object > ManipulationParameters2D 

(usage) None. 

(description) Base type from which all manipulation parameter types are derived. 

http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) None. 

(used by) Manipulation 

[is default constructible] false 

5.31   x:MarkupExtension 

x:Object > x:MarkupExtension 

BindingBase ColorConvertedBitmapExtension DynamicResourceExtension RelativeSource 

ResourceKey StaticResourceExtension TemplateBindingExtension ThemeDictionaryExtension 

link to externally defined type x:MarkupExtension, from [MS-XAML] 

5.32   x:Nullable(T) 

x:Object > x:Nullable(T) 

link to externally defined type x:Nullable(T), from [MS-XAML] 

5.33   x:Object 

x:Object 

AlternationConverter ApplicationCommands AutomationProperties BindingOperations 

BooleanToVisibilityConverter BorderGapMaskConverter Brushes CalendarDateRange 

CharacterMetrics CharacterMetricsDictionary ClockCollection ColorContext Colors 

ColumnDefinitionCollection CommandBinding CommandBindingCollection ComponentCommands 

CompositeCollection Condition ContentOperations ContextMenuService 

CoreCompatibilityPreferences Cursor Cursors DashStyles DataObject DataTemplateSelector 

DeferrableContent DependencyProperty DocumentReferenceCollection DrawingAttributes 

EditingCommands EventPrivateKey FamilyTypeface FamilyTypefaceCollection FocusManager 

FontEmbeddingManager FontFamily FontFamilyMap FontFamilyMapCollection Fonts FontStretches 

FontStyles FontWeights FrameworkCompatibilityPreferences GlyphRun GlyphTypeface GroupStyle 

InertiaExpansionBehavior InertiaRotationBehavior InertiaTranslationBehavior 

InputBindingCollection InputGesture InputGestureCollection InputScope InputScopeName 

InputScopePhrase JournalEntryListConverter JournalEntryUnifiedViewConverter JumpItem 

JumpList Keyboard KeyboardNavigation KeyTipService LanguageSpecificStringDictionary 

LinkTarget Localization Manipulation ManipulationPivot MediaCommands 

MenuScrollingVisibilityConverter Mouse NavigationCommands NumberSubstitution 

PageContentCollection PixelFormats PresentationTraceSources PropertyPath RenderCapability 

RenderOptions ResourceDictionary RibbonCommands RibbonControlService RoutedCommand 

RoutedEvent RowDefinitionCollection SetterBase SpellCheck Stroke StyleSelector Stylus 

StylusButton StylusPointDescription SystemColors SystemCommands SystemFonts 

SystemParameters TableCellCollection TableColumnCollection TableRowCollection 

TableRowGroupCollection FrameworkElement TextDecorations 

TextElementCollection(TextElementCollection+TextElementType) TextOptions TextRunCache 

ToolTipService TouchPoint TriggerActionCollectiont Typography UIElementCollection Validation 

ValidationResult ValidationRule Visual3DCollection VisualCollection VisualTreeHelper 

WindowCollection XmlNamespaceMapping ZoomPercentageConverter 

link to externally defined type x:Object, from [MS-XAML] 

http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
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5.34   ObservableCollection(T) 

x:Object > ObservableCollection(T) 

CalendarBlackoutDatesCollection GridViewColumnCollection SelectedDatesCollection 

(usage) <ObservableCollection x:TypeArguments="T">T*</ObservableCollection> 

(description)  

(used by) CollectionView CollectionViewSource DataGrid ItemCollection ItemsControl 

[is list] true 

[allowed types] T 

5.35   Predicate(T) 

x:Object > Delegate > Predicate(T) 

(usage) <Predicate x:TypeArguments="T"> string </Predicate> 

(description)  

(used by) CollectionView ItemCollection 

[is default constructible] false 

[text syntax] x:XamlEvent, from [MS-XAML] 

5.36   ReadOnlyCollection(T) 

x:Object > ReadOnlyCollection(T) 

StylusButtonCollection StylusDeviceCollection 

(usage) None. 

(description)  

(used by) BitmapEncoder 

[is default constructible] false 

[is list] true 

[allowed types] T 

5.37   RequestCachePolicy 

x:Object > RequestCachePolicy 

(usage) <RequestCachePolicy /> 

(description) Defines an application's caching requirements for resources obtained by using 

WebRequest objects. 

http://go.microsoft.com/fwlink/?LinkId=390715


 

647 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

(usage) <RequestCachePolicy /> 

(used by) BitmapImage 

5.38   x:Single 

x:Object > x:Single 

link to externally defined type x:Single, from [MS-XAML] 

5.39   SortDescriptionCollection 

x:Object > SortDescriptionCollection 

(usage) <SortDescriptionCollection>SortDescription*</SortDescriptionCollection> 

(description) Represents a collection of SortDescription objects. 

(used by) CollectionView CollectionViewSource ItemCollection 

[is list] true 

[allowed types] SortDescription 

5.40   x:String 

x:Object > x:String 

link to externally defined type x:String, from [MS-XAML] 

5.41   StringCollection 

x:Object > StringCollection 

(usage) <StringCollection>x:String*</StringCollection> 

(description) Represents a collection of strings. 

(used by) RibbonTab 

[is list] true 

[allowed types] x:String 

5.42   StringComparison 

x:Object > StringComparison 

(usage) CurrentCulture| CurrentCultureIgnoreCase| InvariantCulture| 

InvariantCultureIgnoreCase| Ordinal| OrdinalIgnoreCase 

(description) Specifies the culture, case, and sort rules to be used by certain overloads of the String) 

and Object) methods. 

http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
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(usage) CurrentCulture| CurrentCultureIgnoreCase| InvariantCulture| 

InvariantCultureIgnoreCase| Ordinal| OrdinalIgnoreCase 

(used by) PropertyGroupDescription 

[is nullable] false 

[text 

syntax] 

StringComparisonSyntax 

5.43   x:TimeSpan 

x:Object > x:TimeSpan 

link to externally defined type x:TimeSpan, from [MS-XAML] 

5.44   x:XamlType 

x:Object > x:XamlType 

link to externally defined type x:XamlType, from [MS-XAML] 

5.45   UInt16 

x:Object > UInt16 

(usage) <UInt16> string </UInt16> 

(description) Represents a 16-bit unsigned integer. 

(used by) GlyphRun GlyphTypeface 

[is nullable] false 

[text syntax] UInt16Syntax 

5.46   x:Uri 

x:Object > x:Uri 

link to externally defined type x:Uri, from [MS-XAML] 

5.47   XmlDocument 

x:Object > XmlDocument 

(usage) <XmlDocument /> 

(description) Represents an XML document. 

(used by) XmlDataProvider 

http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
http://go.microsoft.com/fwlink/?LinkId=390715
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5.48   XmlLanguage 

x:Object > XmlLanguage 

(usage) <XmlLanguage> string </XmlLanguage> 

(description) Represents a language tag for use in XAML markup. 

(used by) FontFamilyMap FrameworkContentElement FrameworkElement GlyphRun 

LanguageSpecificStringDictionary 

[is default 

constructible] 

false 

[text syntax] XmlLanguageSyntax 

5.49   XmlNamespaceManager 

x:Object > XmlNamespaceManager 

XmlNamespaceMappingCollection 

(usage) None. 

(description) Resolves, adds, and removes namespaces to a collection and provides scope 

management for these namespaces. 

(used by) Binding XmlDataProvider 

[is default 

constructible] 

false 
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6   WPF Xaml Text Syntax Information Sets 

6.1   AlignmentXSyntax 

[values]  

Center The contents align toward the center of the container. 

Left The contents align toward the left of the container. 

Right The contents align toward the right of the container. 

6.2   AlignmentYSyntax 

[values]  

Bottom The contents align toward the lower edge of the container. 

Center The contents align toward the center of the container. 

Top The contents align toward the upper edge of the container. 

6.3   ApplicationGestureSyntax 

[values]  

AllGestures Recognizes all application-specific gestures. 

ArrowDown Has no suggested semantic behavior or action. The arrow can be drawn in single 

stroke or in two strokes where one stroke is the line and the other is the arrow head. 

Do not use more than two strokes to draw the arrow. 

ArrowLeft Has no suggested semantic behavior or action. The arrow can be drawn in single 

stroke or in two strokes where one stroke is the line and the other is the arrow head. 

Do not use more than two strokes to draw the arrow. 

ArrowRight Has no suggested semantic behavior or action. The arrow can be drawn in single 

stroke or in two strokes where one stroke is the line and the other is the arrow head. 

Do not use more than two strokes to draw the arrow. 

ArrowUp Has no suggested semantic behavior or action. The arrow can be drawn in single 

stroke or in two strokes where one stroke is the line and the other is the arrow head. 

Do not use more than two strokes to draw the arrow. 

Check Has no suggested semantic behavior or action. The upward stroke must be twice as 

long as the smaller downward stroke. 

ChevronDown Has no suggested semantic behavior or action. Both sides of the chevron must be 

drawn as equal as possible. The angle must be sharp and end in a point. 

ChevronLeft Has no suggested semantic behavior or action. Both sides of the chevron must be 

drawn as equal as possible. The angle must be sharp and end in a point. 

ChevronRight Has no suggested semantic behavior or action. Both sides of the chevron must be 

drawn as equal as possible. The angle must be sharp and end in a point. 
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[values]  

ChevronUp Has no suggested semantic behavior or action. Both sides of the chevron must be 

drawn as equal as possible. The angle must be sharp and end in a point. 

Circle Has no suggested semantic behavior or action. The circle must be drawn in a single 

stroke without lifting the pen. 

Curlicue Has no suggested semantic behavior or action. Start the curlicue on the word you 

intend to cut. 

DoubleCircle Has no suggested semantic behavior or action. The two circles must overlap each 

other and be drawn in a single stroke without lifting the pen. 

DoubleCurlicue Has no suggested semantic behavior or action. Start the double-curlicue on the word 

you intend to copy. 

DoubleTap Signifies a mouse double-click. The two taps must be made quickly to result in the 

least amount of slippage and the least duration between taps. In addition, the taps 

must be as close to each other as possible. 

Down Has no suggested semantic behavior or action. This gesture must be drawn as a 

single fast flick in the downward direction. 

DownLeft Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the down stroke. The two sides must be as equal in length as 

possible and at a right angle. 

DownLeftLong Signifies pressing an ENTER key. This gesture must be drawn in a single stroke 

starting with the down stroke. The left stroke is about twice as long as the up stroke, 

and the two strokes must be at a right angle. 

DownRight Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the down stroke. The two sides must be as equal in length as 

possible and at a right angle. 

DownRightLong Signifies pressing the spacebar. This gesture must be drawn in a single stroke starting 

with the down stroke. The right stroke must be about twice as long as the up stroke, 

and the two strokes must be at a right angle. 

DownUp Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the down stroke. The two strokes must be as close to each other 

as possible. 

Exclamation Has no suggested semantic behavior or action. The line must be drawn first and then 

the dot drawn quickly and as close to the line as possible. 

Left Specifies a backspace. This gesture must be drawn as a single fast flick to the left. 

LeftDown Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the left stroke. The two sides are as equal in length as possible 

and at a right angle. 

LeftRight Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the left stroke. The two sides are as equal in length as possible 

and at a right angle. 

LeftUp Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the left stroke. The two sides must be as equal in length as 

possible and at a right angle. 



 

652 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

[values]  

NoGesture Recognizes no application-specific gestures. 

Right Signifies a space. This gesture must be drawn as a single fast flick to the right. 

RightDown Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the right stroke. The two sides must be as equal in length as 

possible and at a right angle. 

RightLeft Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the right stroke. The two strokes must be as close to each other 

as possible. 

RightUp Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the right stroke. The two sides must be as equal in length as 

possible and at a right angle. 

ScratchOut Erases content. This gesture must be drawn as a single stroke that has at least three 

back-and-forth motions. 

SemicircleLeft Has no suggested semantic behavior or action. The semicircle must be drawn from 

left to right. The two ends of the semicircle should be as horizontally even as possible. 

SemicircleRight Has no suggested semantic behavior or action. The semicircle must be drawn from 

right to left. The two ends of the semicircle should be as horizontally even as possible. 

Square Has no suggested semantic behavior or action. The square can be drawn in one or 

two strokes. In one stroke, draw the entire square without lifting the pen. In two 

strokes, draw three sides of the square and use another stroke to draw the remaining 

side. Do not use more than two strokes to draw the square. 

Star Has no suggested semantic behavior or action. The star must have exactly five points 

and be drawn in a single stroke without lifting the pen. 

Tap Signifies a mouse click. For the least amount of slippage, the tap must be made 

quickly. 

Triangle Has no suggested semantic behavior or action. The triangle must be drawn in a single 

stroke, without lifting the pen. 

Up Has no suggested semantic behavior or action. This gesture must be drawn as a 

single fast flick in the upward direction. 

UpDown Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the up stroke. The two strokes must be as close to each other as 

possible. 

UpLeft Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the up stroke. The two sides must be as equal in length as 

possible and at a right angle. 

UpLeftLong Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the up stroke. The left stroke must be about twice as long as the 

up stroke, and the two strokes must be at a right angle. 

UpRight Has no suggested semantic behavior or action. This gesture must be drawn in a single 

stroke starting with the up stroke. The two sides must be as equal in length as 

possible and at a right angle. 
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[values]  

UpRightLong Signifies pressing a TAB key. This gesture must be drawn in a single stroke starting 

with the up stroke. The right stroke must be about twice as long as the up stroke, and 

the two strokes must be at a right angle. 

6.4   AutoToolTipPlacementSyntax 

[values]  

BottomRight For a horizontal Slider show the automatic ToolTip at the bottom edge of the Thumb. For 

a vertical Slider show the automatic ToolTip at the right edge of the Thumb. 

None No automatic ToolTip 

TopLeft For a horizontal Slider show the automatic ToolTip at the top edge of the Thumb. For a 

vertical Slider show the automatic ToolTip at the left edge of the Thumb. 

6.5   BaselineAlignmentSyntax 

[values]  

Baseline A baseline that is aligned at the actual baseline of the containing box. 

Bottom A baseline that is aligned at the lower edge of the containing box. 

Center A baseline that is aligned to the center of the containing box. 

Subscript A baseline that is aligned at the subscript position of the containing box. 

Superscript A baseline that is aligned at the superscript position of the containing box. 

TextBottom A baseline that is aligned at the lower edge of the text baseline. 

TextTop A baseline that is aligned at the upper edge of the text baseline. 

Top A baseline that is aligned to the upper edge of the containing box. 

6.6   BaseValueSourceSyntax 

[values]  

Default Source is the default value, as defined by property metadata. 

DefaultStyle Source is from a setter in the default style. The default style comes from the 

current theme. 

DefaultStyleTrigger Source is from a trigger in the default style. The default style comes from the 

current theme. 

ImplicitStyleReference Source is an implicit style reference (style was based on detected type or 

based type). This value is only returned for the Style property itself, not for 

properties that are set through setters or triggers of such a style. 

Inherited Source is a value through property value inheritance. 

Local Source is a locally set value. 
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[values]  

ParentTemplate Source is based on a parent template being used by an element. 

ParentTemplateTrigger Source is a trigger-based value from a parent template that created the 

element. 

Style Source is from a style setter of a non-theme style. 

StyleTrigger Source is a trigger-based value of a non-theme style. 

TemplateTrigger Source is a trigger-based value in a template that is from a non-theme style. 

Unknown Source is not known. This is the default value. 

6.7   BindingModeSyntax 

[values]  

Default Uses the default Mode value of the binding target. The default value varies for each 

property. In general, user-editable control properties, such as those of text boxes 

and check boxes, default to two-way bindings, whereas most other properties 

default to one-way bindings. 

OneTime Updates the binding target when the application starts or when the data context 

changes. This type of binding is appropriate if you are using data where either a 

snapshot of the current state is appropriate to use or the data is truly static. This 

type of binding is also useful if you want to initialize your target property with some 

value from a source property and the data context is not known in advance. 

OneWay Updates the binding target property when the binding source changes. This type of 

binding is appropriate if the control being bound is implicitly read-only, such as a 

stock ticker. Or perhaps the target property has no control interface for making 

changes, such as a data-bound background color of a table. If there is no need to 

monitor the changes of the target property, the OneWay binding mode can be used 

instead of the TwoWay binding mode. 

OneWayToSource Updates the source property when the target property changes. 

TwoWay Causes changes to either the source property or the target property to 

automatically update the other. This type of binding is appropriate for editable 

forms or other fully-interactive UI scenarios. 

6.8   BindingStatusSyntax 

[values]  

Active The binding has been successfully activated. This means that the binding has 

been attached to its binding target (target) property and has located the 

binding source (source), resolved the Path and/or XPath, and begun 

transferring values. 

AsyncRequestPending The binding is waiting for an asynchronous operation to complete. 

Detached The binding has been detached from its target property. 

Inactive The binding has not been activated. 
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[values]  

PathError The binding was unable to resolve the source path. 

Unattached The binding has not yet been attached to its target property. 

UpdateSourceError The binding was unable to send the value to the source property. 

UpdateTargetError The binding could not successfully return a source value to update the target 

value. For more information, see the remarks on FallbackValue. 

6.9   BitmapCacheOptionSyntax 

[values]  

Default Caches the entire image into memory. This is the default value. 

None Do not create a memory store. All requests for the image are filled directly by the image 

file. 

OnDemand Creates a memory store for requested data only. The first request loads the image directly; 

subsequent requests are filled from the cache. 

OnLoad Caches the entire image into memory at load time. All requests for image data are filled 

from the memory store. 

6.10   BitmapCreateOptionsSyntax 

[values]  

DelayCreation Causes a BitmapSource object to delay initialization until it is necessary. This is 

useful when dealing with collections of images. 

IgnoreColorProfile Causes a BitmapSource to ignore an embedded color profile. 

IgnoreImageCache Loads images without using an existing image cache. This option should only be 

selected when images in a cache need to be refreshed. 

None No BitmapCreateOptions are specified. This is the default value. 

PreservePixelFormat Ensures that the PixelFormat a file is stored in is the same as it is loaded to. 

6.11   BitmapScalingModeSyntax 

[values]  

Fant Use very high quality Fant bitmap scaling, which is slower than all other bitmap 

scaling modes, but produces higher quality output. 

HighQuality Use high quality bitmap scaling, which is slower than LowQuality mode, but produces 

higher quality output. The HighQuality mode is the same as the Fant mode. 

Linear Use linear bitmap scaling, which is faster than HighQuality mode, but produces lower 

quality output. 

LowQuality Use bilinear bitmap scaling, which is faster than HighQuality mode, but produces 

lower quality output. The LowQuality mode is the same as the Linear mode. 
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[values]  

NearestNeighbor Use nearest-neighbor bitmap scaling, which provides performance benefits over 

LowQuality mode when the software rasterizer is used. This mode is often used to 

magnify a bitmap. 

Unspecified Use the default bitmap scaling mode, which is Linear. 

6.12   BrushMappingModeSyntax 

[values]  

Absolute The coordinate system is not relative to a bounding box. Values are 

interpreted directly in local space. 

RelativeToBoundingBox The coordinate system is relative to a bounding box: 0 indicates 0 percent of 

the bounding box, and 1 indicates 100 percent of the bounding box. For 

example, (0.5, 0.5) describes a point in the middle of the bounding box, and 

(1, 1) describes a point at the bottom right of the bounding box. 

6.13   BrushSyntax 

[values]  

AliceBlue The solid fill color that has a hexadecimal value 

of #FFF0F8FF. 

AntiqueWhite The solid fill color that has a hexadecimal value 

of #FFFAEBD7. 

Aqua The solid fill color that has a hexadecimal value 

of #FF00FFFF. 

Aquamarine The solid fill color that has a hexadecimal value 

of #FF7FFFD4. 

Azure The solid fill color that has a hexadecimal value 

of #FFF0FFFF. 

Beige The solid fill color that has a hexadecimal value 

of #FFF5F5DC. 

Bisque The solid fill color that has a hexadecimal value 

of #FFFFE4C4. 

Black The solid fill color that has a hexadecimal value 

of #FF000000. 

BlanchedAlmond The solid fill color that has a hexadecimal value 

of #FFFFEBCD. 

Blue The solid fill color that has a hexadecimal value 

of #FF0000FF. 

BlueViolet The solid fill color that has a hexadecimal value 

of #FF8A2BE2. 

Brown The solid fill color that has a hexadecimal value 
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[values]  

of #FFA52A2A. 

BurlyWood The solid fill color that has a hexadecimal value 

of #FFDEB887. 

CadetBlue The solid fill color that has a hexadecimal value 

of #FF5F9EA0. 

Chartreuse The solid fill color that has a hexadecimal value 

of #FF7FFF00. 

Chocolate The solid fill color that has a hexadecimal value 

of #FFD2691E. 

Coral The solid fill color that has a hexadecimal value 

of #FFFF7F50. 

CornflowerBlue The solid fill color that has a hexadecimal value 

of #FF6495ED. 

Cornsilk The solid fill color that has a hexadecimal value 

of #FFFFF8DC. 

Crimson The solid fill color that has a hexadecimal value 

of #FFDC143C. 

Cyan The solid fill color that has a hexadecimal value 

of #FF00FFFF. 

DarkBlue The solid fill color that has a hexadecimal value 

of #FF00008B. 

DarkCyan The solid fill color that has a hexadecimal value 

of #FF008B8B. 

DarkGoldenrod The solid fill color that has a hexadecimal value 

of #FFB8860B. 

DarkGray The solid fill color that has a hexadecimal value 

of #FFA9A9A9. 

DarkGreen The solid fill color that has a hexadecimal value 

of #FF006400. 

DarkKhaki The solid fill color that has a hexadecimal value 

of #FFBDB76B. 

DarkMagenta The solid fill color that has a hexadecimal value 

of #FF8B008B. 

DarkOliveGreen The solid fill color that has a hexadecimal value 

of #FF556B2F. 

DarkOrange The solid fill color that has a hexadecimal value 

of #FFFF8C00. 

DarkOrchid The solid fill color that has a hexadecimal value 

of #FF9932CC. 
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[values]  

DarkRed The solid fill color that has a hexadecimal value 

of #FF8B0000. 

DarkSalmon The solid fill color that has a hexadecimal value 

of #FFE9967A. 

DarkSeaGreen The solid fill color that has a hexadecimal value 

of #FF8FBC8F. 

DarkSlateBlue The solid fill color that has a hexadecimal value 

of #FF483D8B. 

DarkSlateGray The solid fill color that has a hexadecimal value 

of #FF2F4F4F. 

DarkTurquoise The solid fill color that has a hexadecimal value 

of #FF00CED1. 

DarkViolet The solid fill color that has a hexadecimal value 

of #FF9400D3. 

DeepPink The solid fill color that has a hexadecimal value 

of #FFFF1493. 

DeepSkyBlue The solid fill color that has a hexadecimal value 

of #FF00BFFF. 

DimGray The solid fill color that has a hexadecimal value 

of #FF696969. 

DodgerBlue The solid fill color that has a hexadecimal value 

of #FF1E90FF. 

Firebrick The solid fill color that has a hexadecimal value 

of #FFB22222. 

FloralWhite The solid fill color that has a hexadecimal value 

of #FFFFFAF0. 

ForestGreen The solid fill color that has a hexadecimal value 

of #FF228B22. 

Fuchsia The solid fill color that has a hexadecimal value 

of #FFFF00FF. 

Gainsboro The solid fill color that has a hexadecimal value 

of #FFDCDCDC. 

GhostWhite The solid fill color that has a hexadecimal value 

of #FFF8F8FF. 

Gold The solid fill color that has a hexadecimal value 

of #FFFFD700. 

Goldenrod The solid fill color that has a hexadecimal value 

of #FFDAA520. 

Gray The solid fill color that has a hexadecimal value 
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[values]  

of #FF808080. 

Green The solid fill color that has a hexadecimal value 

of #FF008000. 

GreenYellow The solid fill color that has a hexadecimal value 

of #FFADFF2F. 

Honeydew The solid fill color that has a hexadecimal value 

of #FFF0FFF0. 

HotPink The solid fill color that has a hexadecimal value 

of #FFFF69B4. 

IndianRed The solid fill color that has a hexadecimal value 

of #FFCD5C5C. 

Indigo The solid fill color that has a hexadecimal value 

of #FF4B0082. 

Ivory The solid fill color that has a hexadecimal value 

of #FFFFFFF0. 

Khaki The solid fill color that has a hexadecimal value 

of #FFF0E68C. 

Lavender The solid fill color that has a hexadecimal value 

of #FFE6E6FA. 

LavenderBlush The solid fill color that has a hexadecimal value 

of #FFFFF0F5. 

LawnGreen The solid fill color that has a hexadecimal value 

of #FF7CFC00. 

LemonChiffon The solid fill color that has a hexadecimal value 

of #FFFFFACD. 

LightBlue The solid fill color that has a hexadecimal value 

of #FFADD8E6. 

LightCoral The solid fill color that has a hexadecimal value 

of #FFF08080. 

LightCyan The solid fill color that has a hexadecimal value 

of #FFE0FFFF. 

LightGoldenrodYellow The solid fill color that has a hexadecimal value 

of #FFFAFAD2. 

LightGray The solid fill color that has a hexadecimal value 

of #FFD3D3D3. 

LightGreen The solid fill color that has a hexadecimal value 

of #FF90EE90. 

LightPink The solid fill color that has a hexadecimal value 

of #FFFFB6C1. 
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[values]  

LightSalmon The solid fill color that has a hexadecimal value 

of #FFFFA07A. 

LightSeaGreen The solid fill color that has a hexadecimal value 

of #FF20B2AA. 

LightSkyBlue The solid fill color that has a hexadecimal value 

of #FF87CEFA. 

LightSlateGray The solid fill color that has a hexadecimal value 

of #FF778899. 

LightSteelBlue The solid fill color that has a hexadecimal value 

of #FFB0C4DE. 

LightYellow The solid fill color that has a hexadecimal value 

of #FFFFFFE0. 

Lime The solid fill color that has a hexadecimal value 

of #FF00FF00. 

LimeGreen The solid fill color that has a hexadecimal value 

of #FF32CD32. 

Linen The solid fill color that has a hexadecimal value 

of #FFFAF0E6. 

Magenta The solid fill color that has a hexadecimal value 

of #FFFF00FF. 

Maroon The solid fill color that has a hexadecimal value 

of #FF800000. 

MediumAquamarine The solid fill color that has a hexadecimal value 

of #FF66CDAA. 

MediumBlue The solid fill color that has a hexadecimal value 

of #FF0000CD. 

MediumOrchid The solid fill color that has a hexadecimal value 

of #FFBA55D3. 

MediumPurple The solid fill color that has a hexadecimal value 

of #FF9370DB. 

MediumSeaGreen The solid fill color that has a hexadecimal value 

of #FF3CB371. 

MediumSlateBlue The solid fill color that has a hexadecimal value 

of #FF7B68EE. 

MediumSpringGreen The solid fill color that has a hexadecimal value 

of #FF00FA9A. 

MediumTurquoise The solid fill color that has a hexadecimal value 

of #FF48D1CC. 

MediumVioletRed The solid fill color that has a hexadecimal value 
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[values]  

of #FFC71585. 

MidnightBlue The solid fill color that has a hexadecimal value 

of #FF191970. 

MintCream The solid fill color that has a hexadecimal value 

of #FFF5FFFA. 

MistyRose The solid fill color that has a hexadecimal value 

of #FFFFE4E1. 

Moccasin The solid fill color that has a hexadecimal value 

of #FFFFE4B5. 

NavajoWhite The solid fill color that has a hexadecimal value 

of #FFFFDEAD. 

Navy The solid fill color that has a hexadecimal value 

of #FF000080. 

OldLace The solid fill color that has a hexadecimal value 

of #FFFDF5E6. 

Olive The solid fill color that has a hexadecimal value 

of #FF808000. 

OliveDrab The solid fill color that has a hexadecimal value 

of #FF6B8E23. 

Orange The solid fill color that has a hexadecimal value 

of #FFFFA500. 

OrangeRed The solid fill color that has a hexadecimal value 

of #FFFF4500. 

Orchid The solid fill color that has a hexadecimal value 

of #FFDA70D6. 

PaleGoldenrod The solid fill color that has a hexadecimal value 

of #FFEEE8AA. 

PaleGreen The solid fill color that has a hexadecimal value 

of #FF98FB98. 

PaleTurquoise The solid fill color that has a hexadecimal value 

of #FFAFEEEE. 

PaleVioletRed The solid fill color that has a hexadecimal value 

of #FFDB7093. 

PapayaWhip The solid fill color that has a hexadecimal value 

of #FFFFEFD5. 

PeachPuff The solid fill color that has a hexadecimal value 

of #FFFFDAB9. 

Peru The solid fill color that has a hexadecimal value 

of #FFCD853F. 
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[values]  

Pink The solid fill color that has a hexadecimal value 

of #FFFFC0CB. 

Plum The solid fill color that has a hexadecimal value 

of #FFDDA0DD. 

PowderBlue The solid fill color that has a hexadecimal value 

of #FFB0E0E6. 

Purple The solid fill color that has a hexadecimal value 

of #FF800080. 

Red The solid fill color that has a hexadecimal value 

of #FFFF0000. 

RosyBrown The solid fill color that has a hexadecimal value 

of #FFBC8F8F. 

RoyalBlue The solid fill color that has a hexadecimal value 

of #FF4169E1. 

SaddleBrown The solid fill color that has a hexadecimal value 

of #FF8B4513. 

Salmon The solid fill color that has a hexadecimal value 

of #FFFA8072. 

SandyBrown The solid fill color that has a hexadecimal value 

of #FFF4A460. 

SeaGreen The solid fill color that has a hexadecimal value 

of #FF2E8B57. 

SeaShell The solid fill color that has a hexadecimal value 

of #FFFFF5EE. 

Sienna The solid fill color that has a hexadecimal value 

of #FFA0522D. 

Silver The solid fill color that has a hexadecimal value 

of #FFC0C0C0. 

SkyBlue The solid fill color that has a hexadecimal value 

of #FF87CEEB. 

SlateBlue The solid fill color that has a hexadecimal value 

of #FF6A5ACD. 

SlateGray The solid fill color that has a hexadecimal value 

of #FF708090. 

Snow The solid fill color that has a hexadecimal value 

of #FFFFFAFA. 

SpringGreen The solid fill color that has a hexadecimal value 

of #FF00FF7F. 

SteelBlue The solid fill color that has a hexadecimal value 
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[values]  

of #FF4682B4. 

Tan The solid fill color that has a hexadecimal value 

of #FFD2B48C. 

Teal The solid fill color that has a hexadecimal value 

of #FF008080. 

Thistle The solid fill color that has a hexadecimal value 

of #FFD8BFD8. 

Tomato The solid fill color that has a hexadecimal value 

of #FFFF6347. 

Transparent The solid fill color that has a hexadecimal value 

of #00FFFFFF. 

Turquoise The solid fill color that has a hexadecimal value 

of #FF40E0D0. 

Violet The solid fill color that has a hexadecimal value 

of #FFEE82EE. 

Wheat The solid fill color that has a hexadecimal value 

of #FFF5DEB3. 

White The solid fill color that has a hexadecimal value 

of #FFFFFFFF. 

WhiteSmoke The solid fill color that has a hexadecimal value 

of #FFF5F5F5. 

Yellow The solid fill color that has a hexadecimal value 

of #FFFFFF00. 

YellowGreen The solid fill color that has a hexadecimal value 

of #FF9ACD32. 

[patterns]  

#[\dA-F]{3} An RGB value in the sRGB color space with one 

hexadecimal digit per channel. Examples: #F00 

Red: 100%, Green 0%, Blue 0% #fb0 Red: 

100%, Green 73%, Blue 0% #FFF Red: 100%, 

Green 100%, Blue 100% 

#[\dA-F]{4} An ARGB value in the sRGB color space with one 

hexadecimal digit per channel. Examples: 

#FF00 Alpha: 100% Red: 100%, Green 0%, 

Blue 0% #8fb0 Alpha: 53% Red: 100%, Green 

73%, Blue 0% #4FFF Alpha 27% Red: 100%, 

Green 100%, Blue 100% 

#[\dA-F]{6} An RGB value in the sRGB color space with two 

hexadecimal digits per channel. Examples: 

#FF0000 Red: 100%, Green 0%, Blue 0% 

#ff3300 Red: 100%, Green 20%, Blue 0% 

#FFFFFF Red: 100%, Green 100%, Blue 100% 
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[values]  

#[\dA-F]{8} An ARGB value in the sRGB color space with two 

hexadecimal digits per channel. Examples: 

#FFFF0000 Alpha: 100% Red: 100%, Green 

0%, Blue 0% #80ffbf00 Alpha: 50% Red: 

100%, Green 75%, Blue 0% #40FFFFFF Alpha 

25% Red: 100%, Green 100%, Blue 100% 

sc#\s*(([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){2,3}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

An RGB or ARGB value in the scRGB color 

space, with each channel specified as a decimal 

floating point number, separated by either 

commas or whitespace. Examples: sc# 1 0 0 

Red: 100%, Green 0%, Blue 0% sc# 1 0.75, 0 

Red: 100%, Green 75%, Blue 0% sc# 2.5E-1 1 

0 0 Alpha: 25%, Red: 100%, Green 0%, Blue 

0% sc# 1.5,0,-0.5 Red: 150%, Green 0%, Blue 

-50% 

[is case sensitive] true 

ContextColor\s+[^\s]*\s*(([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){3,8}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

A color in a color space identified by a URI; the 

color space URI is followed by a sequence of 

decimal floating point values separated by 

whitespace and/or commas. The first is an alpha 

value, and it is followed by the color-space-

specific channel values (of which there may be 

from 3 to 8 inclusive). Examples: ContextColor 

../color/sRGB.icm 1 1 0 0 

[is case sensitive] true 

6.14   CacheModeSyntax 

[values]  

BitmapCache Caches the visual content as a bitmap. 

6.15   CachingHintSyntax 

[values]  

Cache Cache the tiled brush objects in an off-screen buffer, using the caching hints specified by 

the RenderOptions settings. 

Unspecified No caching hints are specified. 

6.16   CalendarModeSyntax 

[values]  

Decade The Calendar displays a decade at a time. 

Month The Calendar displays a month at a time. 

Year The Calendar displays a year at a time. 
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6.17   CalendarSelectionModeSyntax 

[values]  

MultipleRange Multiple non-contiguous ranges of dates can be selected. Use the SelectedDates 

property to retrieve the selected dates. 

None No selections are allowed. 

SingleDate A single date can be selected. Use the SelectedDate property to retrieve the selected 

date. 

SingleRange A single range of dates can be selected. Use the SelectedDates property to retrieve the 

selected dates. 

6.18   CaptureModeSyntax 

[values]  

Element Mouse capture is applied to a single element. Mouse input goes to the captured element. 

None No mouse capture. Mouse input goes to the element under the mouse. 

SubTree Mouse capture is applied to a subtree of elements. If the mouse is over a child of the element 

with capture, mouse input is sent to the child element. Otherwise, mouse input is sent to the 

element with mouse capture. 

6.19   CharacterCasingSyntax 

[values]  

Lower Characters typed into a TextBox are converted to lowercase. 

Normal Characters typed into a TextBox are not converted. 

Upper Characters typed into a TextBox are converted to uppercase. 

6.20   ClearTypeHintSyntax 

[values]  

Auto The rendering engine uses ClearType when it is possible. If opacity is introduced, ClearType is 

disabled for that subtree. 

Enabled The rendering engine re-enables ClearType for the current subtree. Where opacity is 

introduced in this subtree, ClearType is disabled. 

6.21   ClickModeSyntax 

[values]  

Hover Specifies that the Click event should be raised when the mouse hovers over a control. 

Press Specifies that the Click event should be raised as soon as a button is pressed. 

Release Specifies that the Click event should be raised when a button is pressed and released. 
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6.22   ClockStateSyntax 

[values]  

Active The current Clock time changes in direct relation to that of its parent. If the timeline is an 

animation, it is actively affecting targeted properties, so their value may change from tick (a 

sampling point in time) to tick. If the timeline has children, they may be Active, Filling, or 

Stopped. 

Filling The Clock timing continues, but does not change in relation to that of its parent. If the timeline 

is an animation, it is actively affecting targeted properties, but its values don't change from 

tick to tick. If the timeline has children, they may be Active, Filling, or Stopped. 

Stopped The Clock timing is halted, making the clock's current time and progress values undefined. If 

this timeline is an animation, it no longer affects targeted properties. If this timeline has 

children, they are also Stopped. 

6.23   ColorInterpolationModeSyntax 

[values]  

ScRgbLinearInterpolation Colors are interpolated in the scRGB color space 

SRgbLinearInterpolation Colors are interpolated in the sRGB color space 

6.24   ColorSyntax 

[values]  

AliceBlue The solid fill color that has a hexadecimal value 

of #FFF0F8FF. 

AntiqueWhite The solid fill color that has a hexadecimal value 

of #FFFAEBD7. 

Aqua The solid fill color that has a hexadecimal value 

of #FF00FFFF. 

Aquamarine The solid fill color that has a hexadecimal value 

of #FF7FFFD4. 

Azure The solid fill color that has a hexadecimal value 

of #FFF0FFFF. 

Beige The solid fill color that has a hexadecimal value 

of #FFF5F5DC. 

Bisque The solid fill color that has a hexadecimal value 

of #FFFFE4C4. 

Black The solid fill color that has a hexadecimal value 

of #FF000000. 

BlanchedAlmond The solid fill color that has a hexadecimal value 

of #FFFFEBCD. 

Blue The solid fill color that has a hexadecimal value 

of #FF0000FF. 
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[values]  

BlueViolet The solid fill color that has a hexadecimal value 

of #FF8A2BE2. 

Brown The solid fill color that has a hexadecimal value 

of #FFA52A2A. 

BurlyWood The solid fill color that has a hexadecimal value 

of #FFDEB887. 

CadetBlue The solid fill color that has a hexadecimal value 

of #FF5F9EA0. 

Chartreuse The solid fill color that has a hexadecimal value 

of #FF7FFF00. 

Chocolate The solid fill color that has a hexadecimal value 

of #FFD2691E. 

Coral The solid fill color that has a hexadecimal value 

of #FFFF7F50. 

CornflowerBlue The solid fill color that has a hexadecimal value 

of #FF6495ED. 

Cornsilk The solid fill color that has a hexadecimal value 

of #FFFFF8DC. 

Crimson The solid fill color that has a hexadecimal value 

of #FFDC143C. 

Cyan The solid fill color that has a hexadecimal value 

of #FF00FFFF. 

DarkBlue The solid fill color that has a hexadecimal value 

of #FF00008B. 

DarkCyan The solid fill color that has a hexadecimal value 

of #FF008B8B. 

DarkGoldenrod The solid fill color that has a hexadecimal value 

of #FFB8860B. 

DarkGray The solid fill color that has a hexadecimal value 

of #FFA9A9A9. 

DarkGreen The solid fill color that has a hexadecimal value 

of #FF006400. 

DarkKhaki The solid fill color that has a hexadecimal value 

of #FFBDB76B. 

DarkMagenta The solid fill color that has a hexadecimal value 

of #FF8B008B. 

DarkOliveGreen The solid fill color that has a hexadecimal value 

of #FF556B2F. 

DarkOrange The solid fill color that has a hexadecimal value 
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[values]  

of #FFFF8C00. 

DarkOrchid The solid fill color that has a hexadecimal value 

of #FF9932CC. 

DarkRed The solid fill color that has a hexadecimal value 

of #FF8B0000. 

DarkSalmon The solid fill color that has a hexadecimal value 

of #FFE9967A. 

DarkSeaGreen The solid fill color that has a hexadecimal value 

of #FF8FBC8F. 

DarkSlateBlue The solid fill color that has a hexadecimal value 

of #FF483D8B. 

DarkSlateGray The solid fill color that has a hexadecimal value 

of #FF2F4F4F. 

DarkTurquoise The solid fill color that has a hexadecimal value 

of #FF00CED1. 

DarkViolet The solid fill color that has a hexadecimal value 

of #FF9400D3. 

DeepPink The solid fill color that has a hexadecimal value 

of #FFFF1493. 

DeepSkyBlue The solid fill color that has a hexadecimal value 

of #FF00BFFF. 

DimGray The solid fill color that has a hexadecimal value 

of #FF696969. 

DodgerBlue The solid fill color that has a hexadecimal value 

of #FF1E90FF. 

Firebrick The solid fill color that has a hexadecimal value 

of #FFB22222. 

FloralWhite The solid fill color that has a hexadecimal value 

of #FFFFFAF0. 

ForestGreen The solid fill color that has a hexadecimal value 

of #FF228B22. 

Fuchsia The solid fill color that has a hexadecimal value 

of #FFFF00FF. 

Gainsboro The solid fill color that has a hexadecimal value 

of #FFDCDCDC. 

GhostWhite The solid fill color that has a hexadecimal value 

of #FFF8F8FF. 

Gold The solid fill color that has a hexadecimal value 

of #FFFFD700. 
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[values]  

Goldenrod The solid fill color that has a hexadecimal value 

of #FFDAA520. 

Gray The solid fill color that has a hexadecimal value 

of #FF808080. 

Green The solid fill color that has a hexadecimal value 

of #FF008000. 

GreenYellow The solid fill color that has a hexadecimal value 

of #FFADFF2F. 

Honeydew The solid fill color that has a hexadecimal value 

of #FFF0FFF0. 

HotPink The solid fill color that has a hexadecimal value 

of #FFFF69B4. 

IndianRed The solid fill color that has a hexadecimal value 

of #FFCD5C5C. 

Indigo The solid fill color that has a hexadecimal value 

of #FF4B0082. 

Ivory The solid fill color that has a hexadecimal value 

of #FFFFFFF0. 

Khaki The solid fill color that has a hexadecimal value 

of #FFF0E68C. 

Lavender The solid fill color that has a hexadecimal value 

of #FFE6E6FA. 

LavenderBlush The solid fill color that has a hexadecimal value 

of #FFFFF0F5. 

LawnGreen The solid fill color that has a hexadecimal value 

of #FF7CFC00. 

LemonChiffon The solid fill color that has a hexadecimal value 

of #FFFFFACD. 

LightBlue The solid fill color that has a hexadecimal value 

of #FFADD8E6. 

LightCoral The solid fill color that has a hexadecimal value 

of #FFF08080. 

LightCyan The solid fill color that has a hexadecimal value 

of #FFE0FFFF. 

LightGoldenrodYellow The solid fill color that has a hexadecimal value 

of #FFFAFAD2. 

LightGray The solid fill color that has a hexadecimal value 

of #FFD3D3D3. 

LightGreen The solid fill color that has a hexadecimal value 
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[values]  

of #FF90EE90. 

LightPink The solid fill color that has a hexadecimal value 

of #FFFFB6C1. 

LightSalmon The solid fill color that has a hexadecimal value 

of #FFFFA07A. 

LightSeaGreen The solid fill color that has a hexadecimal value 

of #FF20B2AA. 

LightSkyBlue The solid fill color that has a hexadecimal value 

of #FF87CEFA. 

LightSlateGray The solid fill color that has a hexadecimal value 

of #FF778899. 

LightSteelBlue The solid fill color that has a hexadecimal value 

of #FFB0C4DE. 

LightYellow The solid fill color that has a hexadecimal value 

of #FFFFFFE0. 

Lime The solid fill color that has a hexadecimal value 

of #FF00FF00. 

LimeGreen The solid fill color that has a hexadecimal value 

of #FF32CD32. 

Linen The solid fill color that has a hexadecimal value 

of #FFFAF0E6. 

Magenta The solid fill color that has a hexadecimal value 

of #FFFF00FF. 

Maroon The solid fill color that has a hexadecimal value 

of #FF800000. 

MediumAquamarine The solid fill color that has a hexadecimal value 

of #FF66CDAA. 

MediumBlue The solid fill color that has a hexadecimal value 

of #FF0000CD. 

MediumOrchid The solid fill color that has a hexadecimal value 

of #FFBA55D3. 

MediumPurple The solid fill color that has a hexadecimal value 

of #FF9370DB. 

MediumSeaGreen The solid fill color that has a hexadecimal value 

of #FF3CB371. 

MediumSlateBlue The solid fill color that has a hexadecimal value 

of #FF7B68EE. 

MediumSpringGreen The solid fill color that has a hexadecimal value 

of #FF00FA9A. 
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[values]  

MediumTurquoise The solid fill color that has a hexadecimal value 

of #FF48D1CC. 

MediumVioletRed The solid fill color that has a hexadecimal value 

of #FFC71585. 

MidnightBlue The solid fill color that has a hexadecimal value 

of #FF191970. 

MintCream The solid fill color that has a hexadecimal value 

of #FFF5FFFA. 

MistyRose The solid fill color that has a hexadecimal value 

of #FFFFE4E1. 

Moccasin The solid fill color that has a hexadecimal value 

of #FFFFE4B5. 

NavajoWhite The solid fill color that has a hexadecimal value 

of #FFFFDEAD. 

Navy The solid fill color that has a hexadecimal value 

of #FF000080. 

OldLace The solid fill color that has a hexadecimal value 

of #FFFDF5E6. 

Olive The solid fill color that has a hexadecimal value 

of #FF808000. 

OliveDrab The solid fill color that has a hexadecimal value 

of #FF6B8E23. 

Orange The solid fill color that has a hexadecimal value 

of #FFFFA500. 

OrangeRed The solid fill color that has a hexadecimal value 

of #FFFF4500. 

Orchid The solid fill color that has a hexadecimal value 

of #FFDA70D6. 

PaleGoldenrod The solid fill color that has a hexadecimal value 

of #FFEEE8AA. 

PaleGreen The solid fill color that has a hexadecimal value 

of #FF98FB98. 

PaleTurquoise The solid fill color that has a hexadecimal value 

of #FFAFEEEE. 

PaleVioletRed The solid fill color that has a hexadecimal value 

of #FFDB7093. 

PapayaWhip The solid fill color that has a hexadecimal value 

of #FFFFEFD5. 

PeachPuff The solid fill color that has a hexadecimal value 
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[values]  

of #FFFFDAB9. 

Peru The solid fill color that has a hexadecimal value 

of #FFCD853F. 

Pink The solid fill color that has a hexadecimal value 

of #FFFFC0CB. 

Plum The solid fill color that has a hexadecimal value 

of #FFDDA0DD. 

PowderBlue The solid fill color that has a hexadecimal value 

of #FFB0E0E6. 

Purple The solid fill color that has a hexadecimal value 

of #FF800080. 

Red The solid fill color that has a hexadecimal value 

of #FFFF0000. 

RosyBrown The solid fill color that has a hexadecimal value 

of #FFBC8F8F. 

RoyalBlue The solid fill color that has a hexadecimal value 

of #FF4169E1. 

SaddleBrown The solid fill color that has a hexadecimal value 

of #FF8B4513. 

Salmon The solid fill color that has a hexadecimal value 

of #FFFA8072. 

SandyBrown The solid fill color that has a hexadecimal value 

of #FFF4A460. 

SeaGreen The solid fill color that has a hexadecimal value 

of #FF2E8B57. 

SeaShell The solid fill color that has a hexadecimal value 

of #FFFFF5EE. 

Sienna The solid fill color that has a hexadecimal value 

of #FFA0522D. 

Silver The solid fill color that has a hexadecimal value 

of #FFC0C0C0. 

SkyBlue The solid fill color that has a hexadecimal value 

of #FF87CEEB. 

SlateBlue The solid fill color that has a hexadecimal value 

of #FF6A5ACD. 

SlateGray The solid fill color that has a hexadecimal value 

of #FF708090. 

Snow The solid fill color that has a hexadecimal value 

of #FFFFFAFA. 
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[values]  

SpringGreen The solid fill color that has a hexadecimal value 

of #FF00FF7F. 

SteelBlue The solid fill color that has a hexadecimal value 

of #FF4682B4. 

Tan The solid fill color that has a hexadecimal value 

of #FFD2B48C. 

Teal The solid fill color that has a hexadecimal value 

of #FF008080. 

Thistle The solid fill color that has a hexadecimal value 

of #FFD8BFD8. 

Tomato The solid fill color that has a hexadecimal value 

of #FFFF6347. 

Transparent The solid fill color that has a hexadecimal value 

of #00FFFFFF. 

Turquoise The solid fill color that has a hexadecimal value 

of #FF40E0D0. 

Violet The solid fill color that has a hexadecimal value 

of #FFEE82EE. 

Wheat The solid fill color that has a hexadecimal value 

of #FFF5DEB3. 

White The solid fill color that has a hexadecimal value 

of #FFFFFFFF. 

WhiteSmoke The solid fill color that has a hexadecimal value 

of #FFF5F5F5. 

Yellow The solid fill color that has a hexadecimal value 

of #FFFFFF00. 

YellowGreen The solid fill color that has a hexadecimal value 

of #FF9ACD32. 

[patterns]  

#[\dA-F]{3} An RGB value in the sRGB color space with one 

hexadecimal digit per channel. Examples: #F00 

Red: 100%, Green 0%, Blue 0% #fb0 Red: 

100%, Green 73%, Blue 0% #FFF Red: 100%, 

Green 100%, Blue 100% 

#[\dA-F]{4} An ARGB value in the sRGB color space with one 

hexadecimal digit per channel. Examples: 

#FF00 Alpha: 100% Red: 100%, Green 0%, 

Blue 0% #8fb0 Alpha: 53% Red: 100%, Green 

73%, Blue 0% #4FFF Alpha 27% Red: 100%, 

Green 100%, Blue 100% 

#[\dA-F]{6} An RGB value in the sRGB color space with two 
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[values]  

hexadecimal digits per channel. Examples: 

#FF0000 Red: 100%, Green 0%, Blue 0% 

#ff3300 Red: 100%, Green 20%, Blue 0% 

#FFFFFF Red: 100%, Green 100%, Blue 100% 

#[\dA-F]{8} An ARGB value in the sRGB color space with two 

hexadecimal digits per channel. Examples: 

#FFFF0000 Alpha: 100% Red: 100%, Green 

0%, Blue 0% #80ffbf00 Alpha: 50% Red: 

100%, Green 75%, Blue 0% #40FFFFFF Alpha 

25% Red: 100%, Green 100%, Blue 100% 

sc#\s*(([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){2,3}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

An RGB or ARGB value in the scRGB color 

space, with each channel specified as a decimal 

floating point number, separated by either 

commas or whitespace. Examples: sc# 1 0 0 

Red: 100%, Green 0%, Blue 0% sc# 1 0.75, 0 

Red: 100%, Green 75%, Blue 0% sc# 2.5E-1 1 

0 0 Alpha: 25%, Red: 100%, Green 0%, Blue 

0% sc# 1.5,0,-0.5 Red: 150%, Green 0%, Blue 

-50% 

[is case sensitive] true 

ContextColor\s+[^\s]*\s*(([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){3,8}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

A color in a color space identified by a URI; the 

color space URI is followed by a sequence of 

decimal floating point values separated by 

whitespace and/or commas. The first is an alpha 

value, and it is followed by the color-space-

specific channel values (of which there may be 

from 3 to 8 inclusive). Examples: ContextColor 

../color/sRGB.icm 1 1 0 0 

[is case sensitive] true 

6.25   ColumnSpaceDistributionSyntax 

[values]  

Between Space is distributed evenly between all columns. 

Left Space is distributed before the first column. 

Right Space is distributed after the last column. 

6.26   CommandSyntax 

[values]  

BrowseBack The Browse Back 

command 

[is case sensitive] true 

BrowseForward The Browse Forward 

command 
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[values]  

[is case sensitive] true 

BrowseHome The Browse Home 

command 

[is case sensitive] true 

BrowseStop The Browse Stop 

command 

[is case sensitive] true 

Refresh The Refresh 

command 

[is case sensitive] true 

Favorites The Favorites 

command 

[is case sensitive] true 

Search The Search 

command 

[is case sensitive] true 

IncreaseZoom The Increase Zoom 

command 

[is case sensitive] true 

DecreaseZoom The Decrease Zoom 

command 

[is case sensitive] true 

Zoom The Zoom command 

[is case sensitive] true 

NextPage The Next Page 

command 

[is case sensitive] true 

PreviousPage The Previous Page 

command 

[is case sensitive] true 

FirstPage The First Page 

command 

[is case sensitive] true 

LastPage The Last Page 

command 
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[values]  

[is case sensitive] true 

GoToPage The Go To Page 

command 

[is case sensitive] true 

NavigateJournal The Navigate 

Journal command 

[is case sensitive] true 

Cut The Cut command 

[is case sensitive] true 

Copy The Copy command 

[is case sensitive] true 

Paste The Paste command 

[is case sensitive] true 

Undo The Undo command 

[is case sensitive] true 

Redo The Redo command 

[is case sensitive] true 

Find The Find command 

[is case sensitive] true 

Replace The Replace 

command 

[is case sensitive] true 

Help The Help command 

[is case sensitive] true 

New The New command 

[is case sensitive] true 

Open The Open command 

[is case sensitive] true 

Save The Save command 

[is case sensitive] true 

SaveAs The Save As 
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[values]  

command 

[is case sensitive] true 

Close The Close command 

[is case sensitive] true 

Print The Print command 

[is case sensitive] true 

PrintPreview The Print Preview 

command 

[is case sensitive] true 

Properties The Properties 

command 

[is case sensitive] true 

ContextMenu The Context Menu 

command 

[is case sensitive] true 

CorrectionList The Correction List 

command 

[is case sensitive] true 

SelectAll The Select All 

command 

[is case sensitive] true 

NotACommand Indicates the 

absence of a 

command. 

[is case sensitive] true 

ScrollPageLeft The Scroll Page Left 

command 

[is case sensitive] true 

ScrollPageRight The Scroll Page 

Right command 

[is case sensitive] true 

ScrollPageUp The Scroll Page Up 

command 

[is case sensitive] true 

ScrollPageDown The Scroll Page 
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[values]  

Down command 

[is case sensitive] true 

ScrollByLine The Scroll By Line 

command 

[is case sensitive] true 

MoveLeft The Move Left 

command 

[is case sensitive] true 

MoveRight The Move Right 

command 

[is case sensitive] true 

MoveUp The Move Up 

command 

[is case sensitive] true 

MoveDown The Move Down 

command 

[is case sensitive] true 

ExtendSelectionUp The Extend 

Selection Up 

command 

[is case sensitive] true 

ExtendSelectionDown The Extend 

Selection Down 

command 

[is case sensitive] true 

ExtendSelectionLeft The Extend 

Selection Left 

command 

[is case sensitive] true 

ExtendSelectionRight The Extend 

Selection Right 

command 

[is case sensitive] true 

MoveToHome The Move To Home 

command 

[is case sensitive] true 
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[values]  

MoveToEnd The Move To End 

command 

[is case sensitive] true 

MoveToPageUp The Move To Page 

Up command 

[is case sensitive] true 

MoveToPageDown The Move To Page 

Down command 

[is case sensitive] true 

SelectToHome The Select To Home 

command 

[is case sensitive] true 

SelectToEnd The Select To End 

command 

[is case sensitive] true 

SelectToPageDown The Select To Page 

Down command 

[is case sensitive] true 

SelectToPageUp The Select To Page 

Up command 

[is case sensitive] true 

MoveFocusUp The Move Focus Up 

command 

[is case sensitive] true 

MoveFocusDown The Move Focus 

Down command 

[is case sensitive] true 

MoveFocusBack The Move Focus 

Back command 

[is case sensitive] true 

MoveFocusForward The Move Focus 

Forward command 

[is case sensitive] true 

MoveFocusPageUp The Move Focus 

Page Up command 
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[values]  

[is case sensitive] true 

MoveFocusPageDown The Move Focus 

Page Down 

command 

[is case sensitive] true 

ToggleInsert The Toggle Insert 

command 

[is case sensitive] true 

Delete The Delete 

command 

[is case sensitive] true 

Backspace The Backspace 

command 

[is case sensitive] true 

DeleteNextWord The Delete Next 

Word command 

[is case sensitive] true 

DeletePreviousWord The Delete Previous 

Word command 

[is case sensitive] true 

EnterParagraphBreak The Enter Paragraph 

Break command 

[is case sensitive] true 

EnterLineBreak The Enter Line 

Break command 

[is case sensitive] true 

TabForward The Tab Forward 

command 

[is case sensitive] true 

TabBackward The Tab Backward 

command 

[is case sensitive] true 

MoveRightByCharacter The Move Right By 

Character command 

[is case sensitive] true 
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[values]  

MoveLeftByCharacter The Move Left By 

Character command 

[is case sensitive] true 

MoveRightByWord The Move Right By 

Word command 

[is case sensitive] true 

MoveLeftByWord The Move Left By 

Word command 

[is case sensitive] true 

MoveDownByLine The Move Down By 

Line command 

[is case sensitive] true 

MoveUpByLine The Move Up By 

Line command 

[is case sensitive] true 

MoveDownByParagraph The Move Down By 

Paragraph command 

[is case sensitive] true 

MoveUpByParagraph The Move Up By 

Paragraph command 

[is case sensitive] true 

MoveDownByPage The Move Down By 

Page command 

[is case sensitive] true 

MoveUpByPage The Move Up By 

Page command 

[is case sensitive] true 

MoveToLineStart The Move To Line 

Start command 

[is case sensitive] true 

MoveToLineEnd The Move To Line 

End command 

[is case sensitive] true 

MoveToDocumentStart The Move To 

Document Start 

command 
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[values]  

[is case sensitive] true 

MoveToDocumentEnd The Move To 

Document End 

command 

[is case sensitive] true 

SelectRightByCharacter The Select Right By 

Character command 

[is case sensitive] true 

SelectLeftByCharacter The Select Left By 

Character command 

[is case sensitive] true 

SelectRightByWord The Select Right By 

Word command 

[is case sensitive] true 

SelectLeftByWord The Select Left By 

Word command 

[is case sensitive] true 

SelectDownByLine The Select Down By 

Line command 

[is case sensitive] true 

SelectUpByLine The Select Up By 

Line command 

[is case sensitive] true 

SelectDownByParagraph The Select Down By 

Paragraph command 

[is case sensitive] true 

SelectUpByParagraph The Select Up By 

Paragraph command 

[is case sensitive] true 

SelectDownByPage The Select Down By 

Page command 

[is case sensitive] true 

SelectUpByPage The Select Up By 

Page command 

[is case sensitive] true 
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[values]  

SelectToLineStart The Select To Line 

Start command 

[is case sensitive] true 

SelectToLineEnd The Select To Line 

End command 

[is case sensitive] true 

SelectToDocumentStart The Select To 

Document Start 

command 

[is case sensitive] true 

SelectToDocumentEnd The Select To 

Document End 

command 

[is case sensitive] true 

ToggleBold The Toggle Bold 

command 

[is case sensitive] true 

ToggleItalic The Toggle Italic 

command 

[is case sensitive] true 

ToggleUnderline The Toggle 

Underline command 

[is case sensitive] true 

ToggleSubscript The Toggle 

Subscript command 

[is case sensitive] true 

ToggleSuperscript The Toggle 

Superscript 

command 

[is case sensitive] true 

IncreaseFontSize The Increase Font 

Size command 

[is case sensitive] true 

DecreaseFontSize The Decrease Font 

Size command 

[is case sensitive] true 
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[values]  

ApplyFontSize The Apply Font Size 

command 

[is case sensitive] true 

ApplyFontFamily The Apply Font 

Family command 

[is case sensitive] true 

ApplyForeground The Apply 

Foreground 

command 

[is case sensitive] true 

ApplyBackground The Apply 

Background 

command 

[is case sensitive] true 

AlignLeft The Align Left 

command 

[is case sensitive] true 

AlignCenter The Align Center 

command 

[is case sensitive] true 

AlignRight The Align Right 

command 

[is case sensitive] true 

AlignJustify The Align Justify 

command 

[is case sensitive] true 

ToggleBullets The Toggle Bullets 

command 

[is case sensitive] true 

ToggleNumbering The Toggle 

Numbering 

command 

[is case sensitive] true 

IncreaseIndentation The Increase 

Indentation 

command 

[is case sensitive] true 
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[values]  

DecreaseIndentation The Decrease 

Indentation 

command 

[is case sensitive] true 

Play The Play command 

[is case sensitive] true 

Pause The Pause 

command 

[is case sensitive] true 

Stop The Stop command 

[is case sensitive] true 

Record The Record 

command 

[is case sensitive] true 

NextTrack The Next Track 

command 

[is case sensitive] true 

PreviousTrack The Previous Track 

command 

[is case sensitive] true 

FastForward The Fast Forward 

command 

[is case sensitive] true 

Rewind The Rewind 

command 

[is case sensitive] true 

ChannelUp The Channel Up 

command 

[is case sensitive] true 

ChannelDown The  Channel Down 

command 

[is case sensitive] true 

TogglePlayPause The Toggle Play 

Pause command 

[is case sensitive] true 
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[values]  

IncreaseVolume The Increase 

Volume command 

[is case sensitive] true 

DecreaseVolume The  Decrease 

Volume command 

[is case sensitive] true 

MuteVolume The Mute Volume 

command 

[is case sensitive] true 

IncreaseTreble The Increase Treble 

command 

[is case sensitive] true 

DecreaseTreble The Decrease Treble 

command 

[is case sensitive] true 

IncreaseBass The Increase Bass 

command 

[is case sensitive] true 

DecreaseBass The Decrease Bass 

command 

[is case sensitive] true 

BoostBass The Boost Bass 

command 

[is case sensitive] true 

IncreaseMicrophoneVolume The  Increase 

Microphone Volume 

command 

[is case sensitive] true 

DecreaseMicrophoneVolume The Decrease 

Microphone Volume 

command 

[is case sensitive] true 

MuteMicrophoneVolume The Mute 

Microphone Volume 

command 

[is case sensitive] true 
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[values]  

ToggleMicrophoneOnOff The Toggle 

Microphone On Off 

command 

[is case sensitive] true 

Select The  Select 

command 

[is case sensitive] true 

[patterns]  

([_\p{L}][-

.\w]*:?([_\p{Lu}\p{Ll}\p{Lo}\p{Lt}\p{Nl}][_\p{L}\p{Mn}\p{Mc}\p{Nd

}\p{Nl}]*\.))?[_\p{Lu}\p{Ll}\p{Lo}\p{Lt}\p{Nl}][_\p{L}\p{Mn}\p{Mc}

\p{Nd}\p{Nl}]* 

Either just a 

command name, or 

a string of the form 

TypeName.Comman

dName, or a string 

of the form 

namespacePrefix:Ty

peName.CommandN

ame. 

[is case sensitive] true 

6.27   CornerRadiusSyntax 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){3}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Four whitespace and/or comma 

separated decimal floating point values 

specifying the radius of curvature for the 

top left, top right, bottom right, and 

bottom left corners of a shape. 

[is case sensitive] true 

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) A single decimal floating point value 

indicating the radius of curvature for a 

corner or some corners. 

[is case sensitive] true 

6.28   CultureInfoIetfLanguageTagSyntax 

[patterns]  

[A-Z]{2}(-[0-9A-

Z]{2}) 

A two letter language code identifier optionally followed by a dash then a two-

letter country or region code. 

6.29   CultureInfoSyntax 

[values]  

CurrentCulture The CultureInfo object that represents the culture used by the 
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[values]  

current thread. 

CurrentUICulture The CultureInfo object that represents the current user interface 

culture used by the Resource Manager to look up culture-specific 

resources at run time. 

DefaultThreadCurrentCulture The default culture for threads in the current application domain. 

DefaultThreadCurrentUICulture The default UI culture for threads in the current application domain. 

InstalledUICulture The CultureInfo that represents the culture installed with the 

operating system. 

InvariantCulture The CultureInfo that is culture-independent (invariant). 

6.30   CursorSyntax 

[values]  

AppStarting The Cursor that appears when an application is starting. 

[is case sensitive] true 

Arrow The Arrow Cursor. 

[is case sensitive] true 

ArrowCD The arrow with a compact disk Cursor. 

[is case sensitive] true 

Cross The crosshair Cursor. 

[is case sensitive] true 

Hand A hand Cursor. 

[is case sensitive] true 

Help A help Cursor which is a combination of an arrow and a question mark. 

[is case sensitive] true 

IBeam An I-beam Cursor, which is used to show where the text cursor appears when the 

mouse is clicked. 

[is case sensitive] true 

No A Cursor with which indicates that a particular region is invalid for a given 

operation. 

[is case sensitive] true 

None A special cursor that is invisible. 

[is case sensitive] true 

Pen A pen Cursor. 
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[values]  

[is case sensitive] true 

ScrollAll The scroll all Cursor. 

[is case sensitive] true 

ScrollE The scroll east Cursor. 

[is case sensitive] true 

ScrollN The scroll north Cursor. 

[is case sensitive] true 

ScrollNE The scroll northeast cursor. 

[is case sensitive] true 

ScrollNS The scroll north/south cursor. 

[is case sensitive] true 

ScrollNW A scroll northwest cursor. 

[is case sensitive] true 

ScrollS The scroll south Cursor. 

[is case sensitive] true 

ScrollSE A south/east scrolling Cursor. 

[is case sensitive] true 

ScrollSW The scroll southwest Cursor. 

[is case sensitive] true 

ScrollW The scroll west Cursor. 

[is case sensitive] true 

ScrollWE A west/east scrolling Cursor. 

[is case sensitive] true 

SizeAll A four-headed sizing Cursor, which consists of four joined arrows that point north, 

south, east, and west. 

[is case sensitive] true 

SizeNESW A two-headed northeast/southwest sizing Cursor. 

[is case sensitive] true 

SizeNS A two-headed north/south sizing Cursor. 

[is case sensitive] true 
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[values]  

SizeNWSE A two-headed northwest/southeast sizing Cursor. 

[is case sensitive] true 

SizeWE A two-headed west/east sizing Cursor. 

[is case sensitive] true 

UpArrow An up arrow Cursor, which is typically used to identify an insertion point. 

[is case sensitive] true 

Wait Specifies a wait (or hourglass) Cursor. 

[is case sensitive] true 

[patterns]  

.*\.((CUR)|(ANI)) Any string ending in either ".cur" or ".ani" 

6.31   CursorTypeSyntax 

[values]  

AppStarting A standard arrow with small hourglass cursor. 

Arrow A standard arrow cursor. 

ArrowCD An arrow cd cursor. 

Cross A crosshair cursor. 

Hand A hand cursor. 

Help A help cursor. 

IBeam A text I-Beam cursor. 

No No cursor. 

None A value indicating that no cursor should be displayed. 

Pen A pen cursor. 

ScrollAll A scrolling cursor with arrows pointing north, south, east, and west. 

ScrollE A scrolling cursor with an arrow pointing east. 

ScrollN A scrolling cursor with an arrow pointing north. 

ScrollNE A scrolling cursor with arrows pointing north and east. 

ScrollNS A scrolling cursor with arrows pointing north and south. 

ScrollNW A scrolling cursor with arrows pointing north and west. 

ScrollS A scrolling cursor with an arrow pointing south. 
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[values]  

ScrollSE A scrolling cursor with arrows pointing south and east. 

ScrollSW A scrolling cursor with arrows pointing south and west. 

ScrollW A scrolling cursor with an arrow pointing west. 

ScrollWE A scrolling cursor with arrows pointing west and east. 

SizeAll A cursor with arrows pointing north, south, east, and west. 

SizeNESW A cursor with arrows pointing northeast and southwest. 

SizeNS A cursor with arrows pointing north and south. 

SizeNWSE A cursor with arrows pointing northwest and southeast. 

SizeWE A cursor with arrows pointing west and east. 

UpArrow A vertical arrow cursor. 

Wait An hourglass cursor. 

6.32   DataGridClipboardCopyModeSyntax 

[values]  

ExcludeHeader Users can copy the text values of selected cells to the Clipboard, and column header 

values are not included. 

IncludeHeader Users can copy the text values of selected cells to the Clipboard, and column header 

values are included. 

None Clipboard support is disabled. 

6.33   DataGridEditActionSyntax 

[values]  

Cancel The edit is being canceled. 

Commit The edit is being committed. 

6.34   DataGridEditingUnitSyntax 

[values]  

Cell Cell editing is enabled. 

Row Row editing is enabled. 

6.35   DataGridGridLinesVisibilitySyntax 

[values]  
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[values]  

All Both horizontal and vertical grid lines are visible. 

Horizontal Only horizontal grid lines are visible. 

None No grid lines are visible. 

Vertical Only vertical grid lines are visible. 

6.36   DataGridHeadersVisibilitySyntax 

[values]  

All Both row and column headers are visible. 

Column Only column headers are visible. 

None No headers are visible. 

Row Only row headers are visible. 

6.37   DataGridLengthSyntax 

[values]  

Auto A DataGridLength structure that represents the standard automatic sizing mode. 

SizeToCells A DataGridLength structure that represents the cell-based automatic sizing mode. 

SizeToHeader A DataGridLength structure that represents the header-based automatic sizing mode. 

6.38   DataGridLengthUnitTypeSyntax 

[values]  

Auto The size is based on the contents of both the cells and the column header. 

Pixel The size is a fixed value expressed in pixels. 

SizeToCells The size is based on the contents of the cells. 

SizeToHeader The size is based on the contents of the column header. 

Star The size is a weighted proportion of available space. 

6.39   DataGridRowDetailsVisibilityModeSyntax 

[values]  

Collapsed The row details section is not displayed for any rows. 

Visible The row details section is displayed for all rows. 

VisibleWhenSelected The row details section is displayed only for selected rows. 
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6.40   DataGridSelectionModeSyntax 

[values]  

Extended Multiple items in the DataGrid can be selected at the same time. 

Single Only one item in the DataGrid can be selected at a time. 

6.41   DataGridSelectionUnitSyntax 

[values]  

Cell Only cells are selectable. Clicking a cell selects the cell. Clicking a row or column 

header does nothing. 

CellOrRowHeader Cells and rows are selectable. Clicking a cell selects only the cell. Clicking a row 

header selects the full row. 

FullRow Only full rows are selectable. Clicking a cell or a row header selects the full row. 

6.42   DatePickerFormatSyntax 

[values]  

Long Specifies that the date should be displayed by using unabbreviated days of the week and month 

names. This value displays a string that is equal to the string that is returned by the 

ToLongDateString method. 

Short Specifies that the date should be displayed by using abbreviated days of the week and month 

names. This value displays a string that is equal to the string that is returned by the 

ToShortDateString method. 

6.43   DayOfWeekSyntax 

[values]  

Friday Indicates Friday. 

Monday Indicates Monday. 

Saturday Indicates Saturday. 

Sunday Indicates Sunday. 

Thursday Indicates Thursday. 

Tuesday Indicates Tuesday. 

Wednesday Indicates Wednesday. 

6.44   DependencyPropertySyntax 

[patterns]  

([_\p{L}][-

.\w]*:)?([_\p{Lu}\p{Ll}\p{Lo}\p{Lt}\p{Nl}][_\p{L}\p{Mn}\p{Mc}\p{N

Either just a 

property name, or 
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[patterns]  

d}\p{Nl}]*\.)?[_\p{Lu}\p{Ll}\p{Lo}\p{Lt}\p{Nl}][_\p{L}\p{Mn}\p{Mc}

\p{Nd}\p{Nl}]* 

a string of the form 

TypeName.Property

Name, or a string 

of the form 

namespacePrefix:T

ypeName.PropertyN

ame, or a string of 

the form 

namespacePrefix:Pr

opertyName. 

[is case sensitive] true 

6.45   DockSyntax 

[values]  

Bottom A child element that is positioned at the bottom of the DockPanel. 

Left A child element that is positioned on the left side of the DockPanel. 

Right A child element that is positioned on the right side of the DockPanel. 

Top A child element that is positioned at the top of the DockPanel. 

6.46   DoubleCollectionSyntax 

[patterns]  

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)(((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?))* 

One or more whitespace 

and/or comma separated 

decimal floating point values. 

[is case sensitive] true 

6.47   DragActionSyntax 

[values]  

Cancel The operation is canceled with no drop message. 

Continue The operation will continue. 

Drop The operation will stop with a drop. 

6.48   DragDropEffectsSyntax 

[values]  

All The data is copied, removed from the drag source, and scrolled in the drop target. 

Copy The data is copied to the drop target. 

Link The data from the drag source is linked to the drop target. 
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[values]  

Move The data from the drag source is moved to the drop target. 

None The drop target does not accept the data. 

Scroll Scrolling is about to start or is currently occurring in the drop target. 

6.49   DragDropKeyStatesSyntax 

[values]  

AltKey The ALT key is pressed. 

ControlKey The control (CTRL) key is pressed. 

LeftMouseButton The left mouse button is pressed. 

MiddleMouseButton The middle mouse button is pressed. 

None No modifier keys or mouse buttons are pressed. 

RightMouseButton The right mouse button is pressed. 

ShiftKey The shift (SHIFT) key is pressed. 

6.50   DurationSyntax 

[values]  

Automatic  

[is case sensitive] true 

Forever  

[is case sensitive] true 

[patterns]  

(\d+\.)?\d\d?:\d\d?:((\d\d?)|(\d?\d?\.\d*)) The string may optionally begin with a decimal 

number and a dot. When present, this optional 

part indicates the number of days. The string 

always contains three parts separated by colons. 

The first two of these are one or two digit 

numbers specifying hours and minutes. The third 

part indicates the number of seconds and  can be 

a two-digit integer, or a floating point number 

with 0, 1, or 2 digits before the point, and any 

number of digits after the point. Examples:  0:0:1 

One second 1.0:0:0 One day 0:0:0.5 Half a 

second 0:0:.5 Half a second 2.5:2:22 Two days, 

five hours, two minutes, 22 seconds 

[is case sensitive] true 

\d+ A decimal number specifying the number of days. 

Examples:  1 One day 10 Ten days 
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[values]  

[is case sensitive] true 

6.51   EasingModeSyntax 

[values]  

EaseIn Interpolation follows the mathematical formula associated with the easing function. 

EaseInOut Interpolation uses EaseIn for the first half of the animation and EaseOut for the second half. 

EaseOut Interpolation follows 100% interpolation minus the output of the formula associated with 

the easing function. 

6.52   EdgeModeSyntax 

[values]  

Aliased Render the edges of non-text drawing primitives as aliased edges. 

Unspecified No edge mode is specified. Do not alter the current edge mode of non-text drawing 

primitives. This is the default value. 

6.53   EdgeProfileSyntax 

[values]  

BulgedUp An edge that curves up and then down, like a ridge. 

CurvedIn A concave edge that curves in. 

CurvedOut A convex edge that curves out. 

Linear An edge that is a straight line. 

6.54   ExpandDirectionSyntax 

[values]  

Down The Expander control opens down. 

Left The Expander control opens left. 

Right The Expander control opens right. 

Up The Expander control opens up. 

6.55   FigureHorizontalAnchorSyntax 

[values]  

ColumnCenter Anchor the figure in the center of the column content area. 

ColumnLeft Anchor the figure to the left of the column content area. 
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[values]  

ColumnRight Anchor the figure to the right of the column content area. 

ContentCenter Anchor the figure in the center of the page content area. 

ContentLeft Anchor the figure to the left of the page content area. 

ContentRight Anchor the figure to the right of the page content area. 

PageCenter Anchor the figure in the center of the page area. 

PageLeft Anchor the figure to the left of the page area. 

PageRight Anchor the figure to the right of the page area. 

6.56   FigureLengthSyntax 

[values]  

Auto Indicates that automatic sizing 

should be used 

[patterns]  

([+-]?((\d[\d,]*(\.\d*)?)|((\d[\d,]*)?\.\d+))([eE][+-

]?\d+)?)?\s*((COLUMN(S)?)|CONTENT|PAGE) 

An optional decimal floating 

point number, followed by 

either 'column', 'columns', 

'content' or 'page' 

[+-]?((\d[\d,]*(\.\d*)?)|((\d[\d,]*)?\.\d+))([eE][+-]?\d+)? 

(\s*(px|in|cm|pt))? 

A decimal floating point 

number, optionally followed by 

either 'in', 'cm', 'pt', or 'px' 

6.57   FigureUnitTypeSyntax 

[values]  

Auto Default value when the FigureLength is not specified which creates a value for the width or 

height of the Figure that is calculated without constraints. Note: When FigureUnitType is set to 

Auto, the Value property of FigureLength is set to 1. 

Column The value of the width or height of the Figure is expressed as a fraction (including fractions 

greater then 1) of the width of the column the Figure is in. 

Content The value of the width or height of the Figure is expressed as a fraction (including fractions 

greater then 1) of the content width of the Figure. Note: Note: When FigureUnitType is set to 

Content, the Value property of FigureLength must be set to a value between 0 and 1. 

Page The value of the width or height of the Figure is expressed as a fraction (including fractions 

greater then 1) of the page width of that the Figure is in. Note: Note: When FigureUnitType is 

set to Page, the Value property of FigureLength must be set to a value between 0 and 1. 

Pixel The value of the width or height of the Figure is expressed in pixels (96 pixels-per-inch). 
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6.58   FigureVerticalAnchorSyntax 

[values]  

ContentBottom Anchor the figure to the bottom of the page content area. 

ContentCenter Anchor the figure to the center of the page content area. 

ContentTop Anchor the figure to the top of the page content area. 

PageBottom Anchor the figure to the bottom of the page area. 

PageCenter Anchor the figure to the center of the page area. 

PageTop Anchor the figure to the top of the page area. 

ParagraphTop Anchor the figure to the top of the current paragraph. 

6.59   FillBehaviorSyntax 

[values]  

HoldEnd After it reaches the end of its active period, the timeline holds its progress until the end of its 

parent's active and hold periods. 

Stop The timeline stops if it is outside its active period while its parent is inside its active period. 

6.60   FillRuleSyntax 

[values]  

EvenOdd Rule that determines whether a point is in the fill region by drawing a ray from that point to 

infinity in any direction and counting the number of path segments within the given shape 

that the ray crosses. If this number is odd, the point is inside; if even, the point is outside. 

Nonzero Rule that determines whether a point is in the fill region of the path by drawing a ray from 

that point to infinity in any direction and then examining the places where a segment of the 

shape crosses the ray. Starting with a count of zero, add one each time a segment crosses 

the ray from left to right and subtract one each time a path segment crosses the ray from 

right to left. After counting the crossings, if the result is zero then the point is outside the 

path. Otherwise, it is inside. 

6.61   FlowDirectionSyntax 

[values]  

LeftToRight Indicates that content should flow from left to right. 

RightToLeft Indicates that content should flow from right to left. 

6.62   FlowDocumentReaderViewingModeSyntax 

[values]  

Page Indicates that the FlowDocumentReader should show content one page at a time. 



 

699 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

[values]  

Scroll Indicates that the FlowDocumentReader should show content in continuous scrolling mode. 

TwoPage Indicates that the FlowDocumentReader should show content two pages at a time, similar to 

an open book. 

6.63   FocusNavigationDirectionSyntax 

[values]  

Down Move focus to another focusable element downwards from the currently focused element. 

First Move focus to the first focusable element in tab order. Not supported for 

FocusNavigationDirection). 

Last Move focus to the last focusable element in tab order. Not supported for 

FocusNavigationDirection). 

Left Move focus to another focusable element to the left of the currently focused element. 

Next Move focus to the next focusable element in tab order. Not supported for 

FocusNavigationDirection). 

Previous Move focus to the previous focusable element in tab order. Not supported for 

FocusNavigationDirection). 

Right Move focus to another focusable element to the right of the currently focused element. 

Up Move focus to another focusable element upwards from the currently focused element. 

6.64   FontCapitalsSyntax 

[values]  

AllPetiteCaps Both capital and lowercase letters are replaced with a glyph form of an uppercase letter 

with the same approximate height. Petite capitals are smaller than small capitals. 

AllSmallCaps Both capital and lowercase letters are replaced with a glyph form of an uppercase letter 

with the same approximate height. 

Normal Capital letters render normally. 

PetiteCaps Lowercase letters are replaced with a glyph form of an uppercase letter with the same 

approximate height. Petite capitals are smaller than small capitals. 

SmallCaps Lowercase letters are replaced with a glyph form of an uppercase letter with the same 

approximate height. 

Titling Glyph forms are substituted with a typographic form specifically designed for titles. 

Unicase Capital letters display in unicase. Unicase fonts render both upper and lowercase letters 

in a mixture of upper and lowercase glyphs determined by the type designer. 

6.65   FontEastAsianLanguageSyntax 

[values]  
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[values]  

HojoKanji Replaces default glyphs with the corresponding forms from the Hojo Kanji 

specification. 

Jis04 Replaces default Japanese glyphs with the corresponding forms from the JIS04 

specification. 

Jis78 Replaces default Japanese glyphs with the corresponding forms from the JIS78 

specification. 

Jis83 Replaces default Japanese glyphs with the corresponding forms from the JIS83 

specification. 

Jis90 Replaces default Japanese glyphs with the corresponding forms from the JIS90 

specification. 

NlcKanji Replaces default glyphs with the corresponding forms from the NLC Kanji 

specification. 

Normal No font-specific glyph versions are applied. 

Simplified Replaces traditional Chinese or Japanese forms with their corresponding simplified 

forms. 

Traditional Replaces simplified Chinese or Japanese forms with their corresponding traditional 

forms. 

TraditionalNames Replaces simplified Kanji forms with their corresponding traditional forms. This 

glyph set is explicitly limited to the traditional forms considered proper for use in 

personal names. 

6.66   FontEastAsianWidthsSyntax 

[values]  

Full Replaces uniform width glyphs with full width (usually em) glyphs. 

Half Replaces uniform width glyphs with half width (half em) glyphs. 

Normal Default width style. 

Proportional Replaces uniform width glyphs with proportionally spaced glyphs. 

Quarter Replaces uniform width glyphs with one-quarter width (one-quarter em) glyphs. 

Third Replaces uniform width glyphs with one-third width (one-third em) glyphs. 

6.67   FontEmbeddingRightSyntax 

[values]  

Editable The font may be embedded but must only 

be installed temporarily on other systems. 

In contrast to the PreviewAndPrint setting, 

documents containing Editable fonts may 

be opened, edited, or saved. 
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[values]  

EditableButNoSubsetting The font may be embedded but must only 

be installed temporarily on other systems. 

Documents containing the font may be 

opened, edited, or saved. The font may 

not be subsetted prior to embedding. 

EditableButNoSubsettingAndWithBitmapsOnly The font may be embedded but must only 

be installed temporarily on other systems. 

Documents containing the font may be 

opened, edited, or saved. The font may 

not be subsetted prior to embedding. Only 

bitmaps contained in the font may be 

embedded. No outline data may be 

embedded. 

EditableButWithBitmapsOnly The font may be embedded but must only 

be installed temporarily on other systems. 

Documents containing the font may be 

opened, edited, or saved. Only bitmaps 

contained in the font may be embedded. 

No outline data may be embedded. 

Installable Fonts with this setting indicate that they 

may be embedded and permanently 

installed on the remote system by an 

application. The user of the remote system 

acquires the identical rights, obligations 

and licenses for that font as the original 

purchaser of the font, and is subject to the 

same end-user license agreement, 

copyright, design patent, and/or 

trademark as was the original purchaser. 

InstallableButNoSubsetting Fonts with this setting indicate that they 

may be embedded and permanently 

installed on the remote system by an 

application. They may not be subsetted 

prior to embedding. 

InstallableButNoSubsettingAndWithBitmapsOnly Fonts with this setting indicate that they 

may be embedded and permanently 

installed on the remote system by an 

application. They may not be subsetted 

prior to embedding. Only bitmaps 

contained in the fonts may be embedded. 

No outline data may be embedded. 

InstallableButWithBitmapsOnly Fonts with this setting indicate that they 

may be embedded and permanently 

installed on the remote system by an 

application. Only bitmaps contained in the 

fonts may be embedded. No outline data 

may be embedded. 

PreviewAndPrint The font may be embedded and 

temporarily loaded on the remote system. 

Documents containing the font must be 
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[values]  

opened in a read-only mode. 

PreviewAndPrintButNoSubsetting The font may be embedded and 

temporarily loaded on the remote system. 

Documents containing the font must be 

opened in a read-only mode. The font may 

not be subsetted prior to embedding. 

PreviewAndPrintButNoSubsettingAndWithBitmapsOnly The font may be embedded and 

temporarily loaded on the remote system. 

Documents containing the font must be 

opened in a read-only mode. The font may 

not be subsetted prior to embedding. Only 

bitmaps contained in the font may be 

embedded. No outline data may be 

embedded. 

PreviewAndPrintButWithBitmapsOnly The font may be embedded and 

temporarily loaded on the remote system. 

Documents containing the font must be 

opened in a read-only mode. Only bitmaps 

contained in the font may be embedded. 

No outline data may be embedded. 

RestrictedLicense Fonts with this setting must not be 

modified, embedded or exchanged in any 

manner without first obtaining permission 

of the legal owner. 

6.68   FontFamilySyntax 

[patterns]  

.* A sequence of comma-separated font family names. Each name can optionally start with a 

string indicating the location of the font file. This optional location specifier is indicated by 

a # symbol - the part before the hash is the location and the part after the hash is the 

family name. The absence of a # indicates that only the family name is specified. (The 

regular expression does not reflect this, because there are no restrictions on what text 

appears as the font name other than that it must not contain a '#' or a ',' and since those 

are both allowed as delimiters, there are no syntactic limits on the string. Of course 

whether the string is meaningful in practice depends on whether the specified font is 

available.) 

[is case 

sensitive] 

true 

6.69   FontFractionSyntax 

[values]  

Normal Default style is used. 

Slashed Slashed fraction style is used. 

Stacked Stacked fraction style is used. 
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6.70   FontNumeralAlignmentSyntax 

[values]  

Normal Default numeral alignment is used. 

Proportional Proportional width alignment is used. 

Tabular Tabular alignment is used. 

6.71   FontNumeralStyleSyntax 

[values]  

Lining Lining numeral style is used. Replaces default glyphs with numeric forms of even height. 

Normal Default numeral style is used. 

OldStyle Old style numeral style is used. Replaces default glyphs with a figure style that matches 

lowercase letters in height and color. 

6.72   FontSizeSyntax 

[patterns]  

[+-]?((\d[\d,]*(\.\d*)?)|((\d[\d,]*)?\.\d+))([eE][+-

]?\d+)? (\s*(PX|IN|CM|PT))? 

A decimal floating point number, 

optionally followed by either 'in', 

'cm', 'pt', or 'px' 

6.73   FontStretchSyntax 

[values]  

Condensed Specifies a condensed FontStretch. 

[trim 

whitespace] 

false 

Expanded Specifies an expanded FontStretch. 

[trim 

whitespace] 

false 

ExtraCondensed Specifies an extra-condensed FontStretch. 

[trim 

whitespace] 

false 

ExtraExpanded Specifies an extra-expanded FontStretch. 

[trim 

whitespace] 

false 

Medium Specifies a medium FontStretch. 

[trim 

whitespace] 

false 
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[values]  

Normal Specifies a normal FontStretch. 

[trim 

whitespace] 

false 

SemiCondensed Specifies a semi-condensed FontStretch. 

[trim 

whitespace] 

false 

SemiExpanded Specifies a semi-expanded FontStretch. 

[trim 

whitespace] 

false 

UltraCondensed Specifies an ultra-condensed FontStretch. 

[trim 

whitespace] 

false 

UltraExpanded Specifies an ultra-expanded FontStretch. 

[trim 

whitespace] 

false 

[patterns]  

\+?0*[1-9] A single digit in the range 1-9, optionally preceded by a + sign and/or any number 

of leading zeros. 

[is case 

sensitive] 

true 

6.74   FontStyleSyntax 

[values]  

Italic Specifies an italic FontStyle. 

Normal Specifies a normal FontStyle. 

Oblique Specifies an oblique FontStyle. 

6.75   FontVariantsSyntax 

[values]  

Inferior Replaces a default glyph with an inferior glyph, or it may combine glyph substitution with 

positioning adjustments for proper placement. Inferior forms are typically used in chemical 

formulas or mathematical notation. 

Normal Default font behavior. Font scaling and positioning is normal. 

Ordinal Replaces a default glyph with an ordinal glyph, or it may combine glyph substitution with 

positioning adjustments for proper placement. Ordinal forms are normally associated with 

numeric notation of an ordinal word, such as "1st" for "first." 
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[values]  

Ruby Replaces a default glyph with a smaller Japanese Kana glyph. This is used to clarify the 

meaning of Kanji, which may be unfamiliar to the reader. 

Subscript Replaces a default glyph with a subscript glyph. 

Superscript Replaces a default glyph with a superscript glyph. Superscript is commonly used for 

footnotes. 

6.76   FontWeightSyntax 

[values]  

Black Specifies a "Black" font weight. 

[trim whitespace] false 

Bold Specifies a "Bold" font weight. 

[trim whitespace] false 

DemiBold Specifies a "Demi-bold" font weight. 

[trim whitespace] false 

ExtraBlack Specifies an "Extra-black" font weight. 

[trim whitespace] false 

ExtraBold Specifies an "Extra-bold" font weight. 

[trim whitespace] false 

ExtraLight Specifies an "Extra-light" font weight. 

[trim whitespace] false 

Heavy Specifies a "Heavy" font weight. 

[trim whitespace] false 

Light Specifies a "Light" font weight. 

[trim whitespace] false 

Medium Specifies a "Medium" font weight. 

[trim whitespace] false 

Normal Specifies a "Normal" font weight. 

[trim whitespace] false 

Regular Specifies a "Regular" font weight. 

[trim whitespace] false 

SemiBold Specifies a "Semi-bold" font weight. 
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[values]  

[trim whitespace] false 

Thin Specifies a "Thin" font weight. 

[trim whitespace] false 

UltraBlack Specifies an "Ultra-black" font weight. 

[trim whitespace] false 

UltraBold Specifies an "Ultra-bold" font weight. 

[trim whitespace] false 

UltraLight Specifies an "Ultra-light" font weight. 

[trim whitespace] false 

[patterns]  

\+?\d* An integer numeric value. (This should be in the range 1-999.) 

[is case sensitive] true 

6.77   FrameworkPropertyMetadataOptionsSyntax 

[values]  

AffectsArrange The arrange pass of layout composition is affected by value 

changes to this property. 

AffectsMeasure The measure pass of layout compositions is affected by value 

changes to this property. 

AffectsParentArrange The arrange pass on the parent element is affected by value 

changes to this property. 

AffectsParentMeasure The measure pass on the parent element is affected by value 

changes to this property. 

AffectsRender Some aspect of rendering or layout composition (other than 

measure or arrange) is affected by value changes to this property. 

BindsTwoWayByDefault The BindingMode for data bindings on this property defaults to 

TwoWay. 

Inherits The values of this property are inherited by child elements. 

Journal The values of this property should be saved or restored by 

journaling processes, or when navigating by Uniform resource 

identifiers (URIs). 

None No options are specified; the property uses the default behavior of 

the property system. 

NotDataBindable Data binding to this property is not allowed. 
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[values]  

OverridesInheritanceBehavior The values of this property span separated trees for purposes of 

property value inheritance. 

SubPropertiesDoNotAffectRender The subproperties on the value of this property do not affect any 

aspect of rendering. 

6.78   GeneratorDirectionSyntax 

[values]  

Backward Specifies to generate items in a backward direction. 

Forward Specifies to generate items in a forward direction. 

6.79   GeneratorStatusSyntax 

[values]  

ContainersGenerated The generator has finished generating containers. 

Error The generator has finished generating containers, but encountered one or more 

errors. 

GeneratingContainers The generator is generating containers. 

NotStarted The generator has not tried to generate content. 

6.80   GeometryCombineModeSyntax 

[values]  

Exclude The second region is excluded from the first. 

Intersect The two regions are combined by taking their intersection. The new area consists of the 

overlapping region between the two geometries. 

Union The two regions are combined by taking the union. 

Xor The two regions are combined by taking the area that exists in the first region but not the 

second and the area that exists in the second region but not the first. 

6.81   GeometrySyntax 

[patterns]  

(F\s*[01])?(\s*[mMlLhHvVcCsSqQtTaAzZ]\s*((([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+))*([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?))?)* 

Optionally begins with a fill rule 

specifier: an uppercase F followed 

by a 0 or a 1, with optional 

whitespace between the  F and 

the digit. Remainder of string 

consists of a sequence of single 

letter commands, each followed 

by a sequence of comma and/or 

whitespace-separated floating 
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[patterns]  

point decimal values. 

[is case sensitive] true 

6.82   GradientSpreadMethodSyntax 

[values]  

Pad Default value. The color values at the ends of the gradient vector fill the remaining space. 

Reflect The gradient is repeated in the reverse direction until the space is filled. 

Repeat The gradient is repeated in the original direction until the space is filled. 

6.83   GridLengthSyntax 

[values]  

auto Indicates that automatic sizing 

should be used 

* Equivalent to a value of "1*" 

[patterns]  

[+-]?((\d[\d,]*(\.\d*)?)|((\d[\d,]*)?\.\d+))([eE][+-

]?\d+)? (\s*(\*|PX|IN|CM|PT))? 

A decimal floating point number, 

optionally followed by either '*', 

'in', 'cm', 'pt', or 'px' 

6.84   GridResizeBehaviorSyntax 

[values]  

BasedOnAlignment Space is redistributed based on the value of the HorizontalAlignment and 

VerticalAlignment properties. 

CurrentAndNext For a horizontal GridSplitter, space is redistributed between the row that is 

specified for the GridSplitter and the next row that is below it. For a vertical 

GridSplitter, space is redistributed between the column that is specified for the 

GridSplitter and the next column that is to the right. 

PreviousAndCurrent For a horizontal GridSplitter, space is redistributed between the row that is 

specified for the GridSplitter and the next row that is above it. For a vertical 

GridSplitter, space is redistributed between the column that is specified for the 

GridSplitter and the next column that is to the left. 

PreviousAndNext For a horizontal GridSplitter, space is redistributed between the rows that are 

above and below the row that is specified for the GridSplitter. For a vertical 

GridSplitter, space is redistributed between the columns that are to the left and 

right of the column that is specified for the GridSplitter. 

6.85   GridResizeDirectionSyntax 

[values]  
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[values]  

Auto Space is redistributed based on the values of the HorizontalAlignment, VerticalAlignment, 

ActualWidth, and ActualHeight properties of the GridSplitter. 

Columns Space is redistributed between columns. 

Rows Space is redistributed between rows. 

6.86   GridUnitTypeSyntax 

[values]  

Auto The size is determined by the size properties of the content object. 

Pixel The value is expressed as a pixel. 

Star The value is expressed as a weighted proportion of available space. 

6.87   GridViewColumnHeaderRoleSyntax 

[values]  

Floating The column header is the object of a drag-and-drop operation to move a column. 

Normal The column header displays above its associated column. 

Padding The column header is the last header in the row of column headers and is used for padding. 

6.88   HandoffBehaviorSyntax 

[values]  

Compose New animations are combined with existing animations by appending the new 

animations to the end of the composition chain. 

SnapshotAndReplace New animations replace any existing animations on the properties to which they 

are applied. 

6.89   HitTestFilterBehaviorSyntax 

[values]  

Continue Hit test against the current Visual and its descendants. 

ContinueSkipChildren Hit test against the current Visual, but not its descendants. 

ContinueSkipSelf Do not hit test against the current Visual, but hit test against its 

descendants. 

ContinueSkipSelfAndChildren Do not hit test against the current Visual or its descendants. 

Stop Stop hit testing at the current Visual. 
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6.90   HitTestResultBehaviorSyntax 

[values]  

Continue Continue hit testing against the next visual in the visual tree hierarchy. 

Stop Stop any further hit testing and return from the callback. 

6.91   HorizontalAlignmentSyntax 

[values]  

Center An element aligned to the center of the layout slot for the parent element. 

Left An element aligned to the left of the layout slot for the parent element. 

Right An element aligned to the right of the layout slot for the parent element. 

Stretch An element stretched to fill the entire layout slot of the parent element. 

6.92   ImeConversionModeValuesSyntax 

[values]  

Alphanumeric The input method uses alphanumeric conversion mode. 

CharCode The input method uses character code conversion mode. 

DoNotCare The input method does not care what input conversion method is used; the actual 

conversion method is indeterminate. 

Eudc The input method uses EUDC (end user defined character) conversion mode. 

Fixed The input method uses fixed conversion mode. 

FullShape The input method uses full-shape conversion mode. 

Katakana The input method uses Katakana conversion mode. 

Native The input method uses a native character (Hiragana, Hangul, Chinese) conversion 

mode. 

NoConversion The input method will not perform any input conversion. 

Roman The input method uses Roman character conversion mode. 

Symbol The input method uses symbol conversion mode. 

6.93   ImeSentenceModeValuesSyntax 

[values]  

Automatic The input method uses the sentence conversion method automatically. 

Conversation The input method uses conversation-style sentence conversion. 

DoNotCare The input method does not care what sentence conversion method is used; the 
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[values]  

actual sentence conversion mode is indeterminate. 

None The input method does not perform any sentence conversion. 

PhrasePrediction The input method uses phrase prediction sentence conversion. 

PluralClause The input method uses plural clause sentence conversion. 

SingleConversion The input method uses single Kanji/Hanja sentence conversion. 

6.94   InheritanceBehaviorSyntax 

[values]  

Default Property value inheritance lookup will query the current element and continue 

walking up the element tree to the page root. 

SkipAllNext Property value inheritance lookup will query the current element but not any 

further. 

SkipAllNow Property value inheritance lookup will not query the current element or any further. 

SkipToAppNext Property value inheritance lookup will query the current element but not any 

further. 

SkipToAppNow Property value inheritance lookup will not query the current element or any further. 

SkipToThemeNext Property value inheritance lookup will query the current element but not any 

further. 

SkipToThemeNow Property value inheritance lookup will not query the current element or any further. 

6.95   InkCanvasClipboardFormatSyntax 

[values]  

InkSerializedFormat Indicates that the InkCanvas accepts Ink Serialized Format (ISF). 

Text Indicates that the InkCanvas accepts text. 

Xaml Indicates that the InkCanvas accepts "Extensible Application Markup Language" 

(XAML) format. 

6.96   InkCanvasEditingModeSyntax 

[values]  

EraseByPoint Indicates that the pen erases part of a stroke when the pen intersects the stroke. 

EraseByStroke Indicates that the pen erases an entire stroke when the pen intersects the stroke. 

GestureOnly Indicates that the InkCanvas responds to gestures, and does not receive ink. 

Ink Indicates that ink appears on the InkCanvas when the pen sends data to it. 
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[values]  

InkAndGesture Indicates that the InkCanvas responds to gestures, and receives ink. 

None Indicates that no action is taken when the pen sends data to the InkCanvas. 

Select Indicates that the pen selects strokes and elements on the InkCanvas. 

6.97   InkCanvasSelectionHitResultSyntax 

[values]  

Bottom The lower middle handle of the selection adorner. 

BottomLeft The lower left handle of the selection adorner. 

BottomRight The lower right handle of the selection adorner. 

Left The middle handle on the left edge of the selection adorner. 

None No part of the selection adorner. 

Right The middle handle on the right edge of the selection adorner. 

Selection The area within the bounds of the selection adorner. 

Top The upper middle handle of the selection adorner. 

TopLeft The upper left handle of the selection adorner. 

TopRight The upper right handle of the selection adorner. 

6.98   InputMethodStateSyntax 

[values]  

DoNotCare The input method is in an indeterminate state. 

Off The input method is off. 

On The input method is on. 

6.99   InputModeSyntax 

[values]  

Foreground The input was provided when the application was in the foreground. 

Sink The input was provided when the application was not in the foreground. 

6.100   InputScopeNameValueSyntax 

[values]  

AddressCity The text input pattern for a city address. 
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[values]  

AddressCountryName The text input pattern for the name of a country. 

AddressCountryShortName The text input pattern for the abbreviated name of a country. 

AddressStateOrProvince The text input pattern for a state or province. 

AddressStreet The text input pattern for a street address. 

AlphanumericFullWidth The text input pattern for alphanumeric full-width characters. 

AlphanumericHalfWidth The text input pattern for alphanumeric half-width characters. 

Bopomofo The text input pattern for the Bopomofo Mandarin Chinese phonetic 

transcription system. 

CurrencyAmount The text input pattern for amount of currency. 

CurrencyAmountAndSymbol The text input pattern for amount and symbol of currency. 

CurrencyChinese The text input pattern for Chinese currency. 

Date The text input pattern for a calendar date. 

DateDay The text input pattern for the numeric day in a calendar date. 

DateDayName The text input pattern for the name of the day in a calendar date. 

DateMonth The text input pattern for the numeric month in a calendar date. 

DateMonthName The text input pattern for the name of the month in a calendar date. 

DateYear The text input pattern for the year in a calendar date. 

Default The default handling of input commands. 

Digits The text input pattern for digits. 

EmailSmtpAddress The text input pattern for a Simple Mail Transfer Protocol (SMTP) email 

address. 

EmailUserName The text input pattern for an email user name. 

FileName The text input pattern for a file name. 

FullFilePath The text input pattern for the full path of a file. 

Hanja The text input pattern for Hanja characters. 

Hiragana The text input pattern for the Hiragana writing system. 

KatakanaFullWidth The text input pattern for full-width Katakana characters. 

KatakanaHalfWidth The text input pattern for half-width Katakana characters. 

LogOnName The text input pattern for a log on name. 

Number The text input pattern for a number. 

NumberFullWidth The text input pattern for a full-width number. 
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[values]  

OneChar The text input pattern for one character. 

Password The text input pattern for a password. 

PersonalFullName The text input pattern for a person's full name. 

PersonalGivenName The text input pattern for a person's given name. 

PersonalMiddleName The text input pattern for a person's middle name. 

PersonalNamePrefix The text input pattern for the prefix of a person's name. 

PersonalNameSuffix The text input pattern for the suffix of a person's name. 

PersonalSurname The text input pattern for a person's surname. 

PhraseList The text input pattern for a phrase list. 

PostalAddress The text input pattern for a postal address. 

PostalCode The text input pattern for a postal code. 

RegularExpression The text input pattern for a regular expression. 

Srgs The text input pattern for the Speech Recognition Grammar Specification 

(SRGS). 

TelephoneAreaCode The text input pattern for a telephone area code. 

TelephoneCountryCode The text input pattern for a telephone country code. 

TelephoneLocalNumber The text input pattern for a telephone local number. 

TelephoneNumber The text input pattern for a telephone number. 

Time The text input pattern for the time. 

TimeHour The text input pattern for the hour of the time. 

TimeMinorSec The text input pattern for the minutes or seconds of time. 

Url The text input pattern for a Uniform Resource Locator (URL). 

Xml The text input pattern for XML. 

6.101   InputScopeSyntax 

[patterns]  

(([_\p{Lu}\p{Ll}\p{Lo}\p{Lt}\p{Nl}][_\p{L}\p{Mn}\p{Mc}\p{Nd}\p{Nl}]*\.))

?[_\p{Lu}\p{Ll}\p{Lo}\p{Lt}\p{Nl}][_\p{L}\p{Mn}\p{Mc}\p{Nd}\p{Nl}]* 

Either a 

string of the 

form 

TypeName.

ScopeName

, or a string 

of the form 

ScopeName



 

715 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

[patterns]  

. 

[is case sensitive] true 

6.102   InputTypeSyntax 

[values]  

Command Input was provided by a command. 

Hid Input was provided a Human Interface Device that was not a keyboard, a mouse, or a 

stylus. 

Keyboard Input was provided by a keyboard. 

Mouse Input was provided by a mouse. 

Stylus Input was provided by a stylus. 

Text Input was provided by text. 

6.103   Int32CollectionSyntax 

[patterns]  

\d+(((\s*,\s*)|\s+)\d+)* A sequence of decimal integers separated by either a comma or 

whitespace 

[is case sensitive] true 

6.104   Int32RectSyntax 

[values]  

Empty Equivalent to a value of "0,0,0,0" 

[is case sensitive] true 

[patterns]  

(\d+((\s*,\s*)|\s+)){3}\d+ Four decimal integers separated by either a comma or whitespace. 

[is case sensitive] true 

6.105   IntersectionDetailSyntax 

[values]  

Empty The Geometry hit test parameter and the target visual, or geometry, do not intersect. 

FullyContains The Geometry hit test parameter is fully contained within the boundary of the target 

visual or geometry. 

FullyInside The target visual, or geometry, is fully inside the Geometry hit test parameter. 
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[values]  

Intersects The Geometry hit test parameter and the target visual, or geometry, intersect. This 

means that the two elements overlap, but neither element contains the other. 

NotCalculated The IntersectionDetail value is not calculated. 

6.106   InvertAxesSyntax 

[values]  

Both Drawing surface is inverted in both axes. 

Horizontal Drawing surface is inverted in the horizontal axis. 

None Drawing surface is not inverted in either axis. 

Vertical Drawing surface is inverted in the vertical axis. 

6.107   IsOffscreenBehaviorSyntax 

[values]  

Default (4.5)  

FromClip (4.5)  

Offscreen (4.5)  

Onscreen (4.5)  

6.108   JournalEntryPositionSyntax 

[values]  

Back Content is in back navigation history relative to current content. 

Current Content is the current content. 

Forward Content is in forward navigation history with respect to current content. 

6.109   JournalOwnershipSyntax 

[values]  

Automatic Whether or not this Frame will create and use its own journal depends on its 

parent. 

OwnsJournal The Frame maintains its own journal. 

UsesParentJournal The Frame uses the journal of the next available navigation host up the content 

tree, if available. Otherwise, navigation history is not maintained for the Frame. 
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6.110   JumpItemRejectionReasonSyntax 

[values]  

InvalidItem The JumpItem references an invalid file path, or the operating system does not 

support Jump Lists. 

None The reason is not specified. 

NoRegisteredHandler The application is not registered to handle the file name extension of the 

JumpItem. 

RemovedByUser The item was previously in the Jump List but was removed by the user. 

6.111   KernelTypeSyntax 

[values]  

Box A simple blur created with a square distribution curve. 

Gaussian A distributed curve that creates a smooth distribution for a blur. 

6.112   KeyboardNavigationModeSyntax 

[values]  

Contained Depending on the direction of the navigation, focus returns to the first or the last item when 

the end or the beginning of the container is reached, but does not move past the beginning 

or end of the container. 

Continue Each element receives keyboard focus, as long as it is a navigation stop. Navigation leaves 

the containing element when an edge is reached. 

Cycle Depending on the direction of the navigation, the focus returns to the first or the last item 

when the end or the beginning of the container is reached. Focus cannot leave the container 

using logical navigation. 

Local Tab Indexes are considered on local subtree only inside this container and behave like 

Continue after that. 

None No keyboard navigation is allowed inside this container. 

Once The container and all of its child elements as a whole receive focus only once. Either the first 

tree child or the or the last focused element in the group receives focus 

6.113   KeyGestureSyntax 

[patterns]  

((CONTROL|CTRL|SHIFT|ALT|WINDOWS|WIN)\s*\+\s*)+\w+(,.+)? A sequence of one or 

more key modifiers 

delimited by '+', followed 

by a key name (which 

follows the final '+' in the 

list of modifiers). This 

may be followed by a 

comma which, if present, 
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[patterns]  

must be followed by a 

string representing the 

display text for the key 

gesture. Note that 

although this regular 

expression does not 

enforce it, the key name 

should be a valid 

KeySyntax. 

6.114   KeySplineSyntax 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){3}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Four decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.115   KeyStatesSyntax 

[values]  

Down The key is pressed. 

None The key is not pressed. 

Toggled The key is toggled. 

6.116   KeySyntax 

[values]  

A The A key. 

AbntC1 The ABNT_C1 (Brazilian) key. 

AbntC2 The ABNT_C2 (Brazilian) key. 

Add The Add key. 

Apps The Application key (Microsoft Natural Keyboard). 

Attn The ATTN key. 

B The B key. 

Back The Backspace key. 

BrowserBack The Browser Back key. 

BrowserFavorites The Browser Favorites key. 

BrowserForward The Browser Forward key. 
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[values]  

BrowserHome The Browser Home key. 

BrowserRefresh The Browser Refresh key. 

BrowserSearch The Browser Search key. 

BrowserStop The Browser Stop key. 

C The C key. 

Cancel The Cancel key. 

Capital The Caps Lock key. 

CapsLock The Caps Lock key. 

Clear The Clear key. 

CrSel The CRSEL key. 

D The D key. 

D0 The 0 (zero) key. 

D1 The 1 (one) key. 

D2 The 2 key. 

D3 The 3 key. 

D4 The 4 key. 

D5 The 5 key. 

D6 The 6 key. 

D7 The 7 key. 

D8 The 8 key. 

D9 The 9 key. 

DbeAlphanumeric The DBE_ALPHANUMERIC key. 

DbeCodeInput The DBE_CODEINPUT key. 

DbeDbcsChar The DBE_DBCSCHAR key. 

DbeDetermineString The DBE_DETERMINESTRING key. 

DbeEnterDialogConversionMode The DBE_ENTERDLGCONVERSIONMODE key. 

DbeEnterImeConfigureMode The DBE_ENTERIMECONFIGMODE key. 

DbeEnterWordRegisterMode The DBE_ENTERWORDREGISTERMODE key. 

DbeFlushString The DBE_FLUSHSTRING key. 

DbeHiragana The DBE_HIRAGANA key. 
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[values]  

DbeKatakana The DBE_KATAKANA key. 

DbeNoCodeInput The DBE_NOCODEINPUT key. 

DbeNoRoman The DBE_NOROMAN key. 

DbeRoman The DBE_ROMAN key. 

DbeSbcsChar The DBE_SBCSCHAR key. 

DeadCharProcessed The key is used with another key to create a single combined 

character. 

Decimal The Decimal key. 

Delete The Delete key. 

Divide The Divide key. 

Down The Down Arrow key. 

E The E key. 

End The End key. 

Enter The Enter key. 

EraseEof The ERASE EOF key. 

Escape The ESC key. 

Execute The Execute key. 

ExSel The EXSEL key. 

F The F key. 

F1 The F1 key. 

F10 The F10 key. 

F11 The F11 key. 

F12 The F12 key. 

F13 The F13 key. 

F14 The F14 key. 

F15 The F15 key. 

F16 The F16 key. 

F17 The F17 key. 

F18 The F18 key. 

F19 The F19 key. 
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[values]  

F2 The F2 key. 

F20 The F20 key. 

F21 The F21 key. 

F22 The F22 key. 

F23 The F23 key. 

F24 The F24 key. 

F3 The F3 key. 

F4 The F4 key. 

F5 The F5 key. 

F6 The F6 key. 

F7 The F7 key. 

F8 The F8 key. 

F9 The F9 key. 

FinalMode The IME Final mode key. 

G The G key. 

H The H key. 

HangulMode The IME Hangul mode key. 

HanjaMode The IME Hanja mode key. 

Help The Help key. 

Home The Home key. 

I The I key. 

ImeAccept The IME Accept key. 

ImeConvert The IME Convert key. 

ImeModeChange The IME Mode change request. 

ImeNonConvert The IME NonConvert key. 

ImeProcessed A special key masking the real key being processed by an IME. 

Insert The Insert key. 

J The J key. 

JunjaMode The IME Junja mode key. 

K The K key. 



 

722 / 779 

[MS-WPFXV-2012] — v20141223   
 WPF Xaml Vocabulary Specification 2012  
 
 Copyright © 2014 Microsoft Corporation.  
 
 Release: Tuesday, December 23, 2014  

[values]  

KanaMode The IME Kana mode key. 

KanjiMode The IME Kanji mode key. 

L The L key. 

LaunchApplication1 The Launch Application1 key. 

LaunchApplication2 The Launch Application2 key. 

LaunchMail The Launch Mail key. 

Left The Left Arrow key. 

LeftAlt The left ALT key. 

LeftCtrl The left CTRL key. 

LeftShift The left Shift key. 

LineFeed The Linefeed key. 

LWin The left Windows logo key (Microsoft Natural Keyboard). 

M The M key. 

MediaNextTrack The Media Next Track key. 

MediaPlayPause The Media Play Pause key. 

MediaPreviousTrack The Media Previous Track key. 

MediaStop The Media Stop key. 

Multiply The Multiply key. 

N The N key. 

Next The Page Down key. 

NoName A constant reserved for future use. 

None No key pressed. 

NumLock The Num Lock key. 

NumPad0 The 0 key on the numeric keypad. 

NumPad1 The 1 key on the numeric keypad. 

NumPad2 The 2 key on the numeric keypad. 

NumPad3 The 3 key on the numeric keypad. 

NumPad4 The 4 key on the numeric keypad. 

NumPad5 The 5 key on the numeric keypad. 

NumPad6 The 6 key on the numeric keypad. 
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[values]  

NumPad7 The 7 key on the numeric keypad. 

NumPad8 The 8 key on the numeric keypad. 

NumPad9 The 9 key on the numeric keypad. 

O The O key. 

Oem1 The OEM 1 key. 

Oem102 The OEM 102 key. 

Oem2 The OEM 2 key. 

Oem3 The OEM 3 key. 

Oem4 The OEM 4 key. 

Oem5 The OEM 5 key. 

Oem6 The OEM 6 key. 

Oem7 The OEM 7 key. 

Oem8 The OEM 8 key. 

OemAttn The OEM ATTN key. 

OemAuto The OEM AUTO key. 

OemBackslash The OEM Backslash key. 

OemBackTab The OEM BACKTAB key. 

OemClear The OEM Clear key. 

OemCloseBrackets The OEM Close Brackets key. 

OemComma The OEM Comma key. 

OemCopy The OEM COPY key. 

OemEnlw The OEM ENLW key. 

OemFinish The OEM FINISH key. 

OemMinus The OEM Minus key. 

OemOpenBrackets The OEM Open Brackets key. 

OemPeriod The OEM Period key. 

OemPipe The OEM Pipe key. 

OemPlus The OEM Addition key. 

OemQuestion The OEM Question key. 

OemQuotes The OEM Quotes key. 
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[values]  

OemSemicolon The OEM Semicolon key. 

OemTilde The OEM Tilde key. 

P The P key. 

Pa1 The PA1 key. 

PageDown The Page Down key. 

PageUp The Page Up key. 

Pause The Pause key. 

Play The PLAY key. 

Print The Print key. 

PrintScreen The Print Screen key. 

Prior The Page Up key. 

Q The Q key. 

R The R key. 

Return The Return key. 

Right The Right Arrow key. 

RightAlt The right ALT key. 

RightCtrl The right CTRL key. 

RightShift The right Shift key. 

RWin The right Windows logo key (Microsoft Natural Keyboard). 

S The S key. 

Scroll The Scroll Lock key. 

Select The Select key. 

SelectMedia The Select Media key. 

Separator The Separator key. 

Sleep The Computer Sleep key. 

Snapshot The Print Screen key. 

Space The Spacebar key. 

Subtract The Subtract key. 

System A special key masking the real key being processed as a system 

key. 
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[values]  

T The T key. 

Tab The Tab key. 

U The U key. 

Up The Up Arrow key. 

V The V key. 

VolumeDown The Volume Down key. 

VolumeMute The Volume Mute key. 

VolumeUp The Volume Up key. 

W The W key. 

X The X key. 

Y The Y key. 

Z The Z key. 

Zoom The ZOOM key. 

6.117   KeyTimeSyntax 

[values]  

Uniform Key frames will be uniformly spaced throughout 

the animation if they are all set to a key time of 

Uniform 

[is case sensitive] true 

Paced Indicates that a key frame's duration should be 

calculated so as to keep a constant rate of 

change over the entire animation's duration. 

[is case sensitive] true 

[patterns]  

(\d+\.)?\d\d?:\d\d?:((\d\d?)|(\d?\d?\.\d*)) The string may optionally begin with a decimal 

number and a dot. When present, this optional 

part indicates the number of days. The string 

always contains three parts separated by colons. 

The first two of these are one or two digit 

numbers specifying hours and minutes. The third 

part indicates the number of seconds and  can be 

a two-digit integer, or a floating point number 

with 0, 1, or 2 digits before the point, and any 

number of digits after the point. Examples:  

0:0:1 One second 1.0:0:0 One day 0:0:0.5 Half a 

second 0:0:.5 Half a second 2.5:2:22 Two days, 

five hours, two minutes, 22 seconds 
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[values]  

[is case sensitive] true 

\d+ A decimal number specifying the number of days. 

Examples:  1 One day 10 Ten days 

[is case sensitive] true 

\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?\s*% 

Decimal floating point number followed by a '%' 

symbol. (This is a percentage representing a 

proportion of the total duration of the animation, 

so it should have a value in the range from 0 to 

100.) 

[is case sensitive] true 

6.118   KeyTimeTypeSyntax 

[values]  

Paced Specifies that adjacent KeyFrames are each allotted a slice of time proportional to their 

length, respectively. The overall goal is to produce a length value that keeps the pace of the 

animation sequence constant. 

Percent Specifies that each KeyTime value is expressed as a percentage of the total time allotted for 

a given animation sequence. 

TimeSpan Specifies that each KeyTime is expressed as a TimeSpan value relative to the BeginTime of 

an animation sequence. 

Uniform Specifies that the allotted total time for an animation sequence is divided evenly amongst 

each of the key frames. 

6.119   KeyTipHorizontalPlacementSyntax (4.5) 

[values]  

KeyTipCenterAtTargetCenter The center of the KeyTip is aligned with the center of the target 

element. 

KeyTipCenterAtTargetLeft The center of the KeyTip is aligned with the left of the target element. 

KeyTipCenterAtTargetRight The center of the KeyTip is aligned with the right of the target element. 

KeyTipLeftAtTargetCenter The left of the KeyTip is aligned with the center of the target element. 

KeyTipLeftAtTargetLeft The left of the KeyTip is aligned with the left of the target element. 

KeyTipLeftAtTargetRight The left of the KeyTip is aligned with the right of the target element. 

KeyTipRightAtTargetCenter The right of the KeyTip is aligned with the center of the target element. 

KeyTipRightAtTargetLeft The right of the KeyTip is aligned with the left of the target element. 

KeyTipRightAtTargetRight The right of the KeyTip is aligned with the right of the target element. 
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6.120   KeyTipVerticalPlacementSyntax (4.5) 

[values]  

KeyTipBottomAtTargetBottom The bottom of the KeyTip is aligned with the bottom of the target 

element. 

KeyTipBottomAtTargetCenter The bottom of the KeyTip is aligned with the center of the target 

element. 

KeyTipBottomAtTargetTop The bottom of the KeyTip is aligned with the top of the target 

element. 

KeyTipCenterAtTargetBottom The center of the KeyTip is aligned with the bottom of the target 

element. 

KeyTipCenterAtTargetCenter The center of the KeyTip is aligned with the center of the target 

element. 

KeyTipCenterAtTargetTop The center of the KeyTip is aligned with the top of the target element. 

KeyTipTopAtTargetBottom The top of the KeyTip is aligned with the bottom of the target 

element. 

KeyTipTopAtTargetCenter The top of the KeyTip is aligned with the center of the target element. 

KeyTipTopAtTargetTop The top of the KeyTip is aligned with the top of the target element. 

6.121   LengthSyntax 

[values]  

Auto Indicates that automatic sizing 

should be used 

[patterns]  

[+-]?((\d[\d,]*(\.\d*)?)|((\d[\d,]*)?\.\d+))([eE][+-

]?\d+)? (\s*(PX|IN|CM|PT))? 

A decimal floating point number, 

optionally followed by either 'in', 

'cm', 'pt', or 'px' 

6.122   LineBreakConditionSyntax 

[values]  

BreakAlways Break is always allowed. 

BreakDesired Break if not prohibited by another object. 

BreakPossible Break if allowed by another object. 

BreakRestrained Break always prohibited unless the other object is set to BreakAlways. 

6.123   LineStackingStrategySyntax 

[values]  
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[values]  

BlockLineHeight The stack height is determined by the block element line-height property value. 

MaxHeight The stack height is the smallest value that containing all the inline elements on that 

line when those elements are properly aligned. 

6.124   LocalizationCategorySyntax 

[values]  

Button A Button or related control. 

CheckBox A CheckBox or related control. 

ComboBox A ComboBox or related control such as ComboBoxItem. 

Font Font-related data such as font name, style, or size. 

Hyperlink A Hyperlink or related control. 

Ignore Do not localize this resource. This does not apply to any child nodes that might exist. 

Inherit Inherits its category from a parent node. 

Label A Label or related control. 

ListBox A ListBox or related control such as ListBoxItem. 

Menu A Menu or related control such as MenuItem. 

NeverLocalize Do not localize this resource, or any child nodes whose category is set to Inherit. 

None Resource does not belong to a standard category. 

RadioButton A RadioButton or related control. 

Text For a lengthy piece of text. 

TextFlow For panels that can contain text. 

Title For a single line of text, such as text used for a title. 

ToolTip A ToolTip or related control. 

XmlData XML data. 

6.125   LogicalDirectionSyntax 

[values]  

Backward Backward, or from right to left. 

Forward Forward, or from left to right. 
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6.126   ManipulationModesSyntax 

[values]  

All A manipulation can scale, translate, or rotate an object and can occur with one point of 

input. 

None Manipulation events do not occur. 

Rotate A manipulation can rotate an object. 

Scale A manipulation can scale an object. 

Translate A manipulation can translate an object. 

TranslateX A manipulation can translate an object horizontally. 

TranslateY A manipulation can translate an object vertically. 

6.127   Matrix3DSyntax 

[values]  

Identity The identity matrix. 

[is case sensitive] true 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){15}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Sixteen decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.128   MatrixSyntax 

[values]  

Identity The identity matrix. 

[is case sensitive] true 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){5}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Six decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.129   MediaStateSyntax 

[values]  

Close The state used to close the media. All media resources are released (including video memory). 
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[values]  

Manual The state used to control a MediaElement manually. Interactive methods like Play and Pause 

can be used. Media will preroll but not play when the MediaElement is assigned a valid media 

source. 

Pause The state used to pause the media. Media will preroll but remains paused when the 

MediaElement is assigned a valid media source. 

Play The state used to play the media. Media will preroll automatically when the MediaElement is 

assigned a valid media source. 

Stop The state used to stop the media. Media will preroll but not play when the MediaElement is 

assigned a valid media source. Media resources are not released. 

6.130   MenuItemRoleSyntax 

[values]  

SubmenuHeader Header for a submenu. 

SubmenuItem Menu item in a submenu that can invoke commands. 

TopLevelHeader Header for top-level menus. 

TopLevelItem Top-level menu item that can invoke commands. 

6.131   MessageBoxButtonSyntax 

[values]  

OK The message box displays an OK button. 

OKCancel The message box displays OK and Cancel buttons. 

YesNo The message box displays Yes and No buttons. 

YesNoCancel The message box displays Yes, No, and Cancel buttons. 

6.132   MessageBoxImageSyntax 

[values]  

Asterisk The message box contains a symbol consisting of a lowercase letter i in a circle. 

Error The message box contains a symbol consisting of white X in a circle with a red 

background. 

Exclamation The message box contains a symbol consisting of an exclamation point in a triangle with a 

yellow background. 

Hand The message box contains a symbol consisting of a white X in a circle with a red 

background. 

Information The message box contains a symbol consisting of a lowercase letter i in a circle. 

None No icon is displayed. 
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[values]  

Question The message box contains a symbol consisting of a question mark in a circle. 

Stop The message box contains a symbol consisting of white X in a circle with a red 

background. 

Warning The message box contains a symbol consisting of an exclamation point in a triangle with a 

yellow background. 

6.133   MessageBoxOptionsSyntax 

[values]  

DefaultDesktopOnly The message box is displayed on the default desktop of the interactive window 

station. Specifies that the message box is displayed from a windows service 

application in order to notify the user of an event. 

None No options are set. 

RightAlign The message box text and title bar caption are right-aligned. 

RtlReading All text, buttons, icons, and title bars are displayed right-to-left. 

ServiceNotification The message box is displayed on the currently active desktop even if a user is 

not logged on to the computer. Specifies that the message box is displayed from 

a windows service application in order to notify the user of an event. 

6.134   MessageBoxResultSyntax 

[values]  

Cancel The result value of the message box is Cancel. 

No The result value of the message box is No. 

None The message box returns no result. 

OK The result value of the message box is OK. 

Yes The result value of the message box is Yes. 

6.135   ModifiabilitySyntax 

[values]  

Inherit Targeted value modifiability is inherited from its parent node. 

Modifiable Targeted value is modifiable by localizers. 

Unmodifiable Targeted value is not modifiable by localizers. 

6.136   ModifierKeysSyntax 

[values]  
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[values]  

Alt The ALT key. 

Control The CTRL key. 

None No modifiers are pressed. 

Shift The SHIFT key. 

Windows The Windows logo key. 

6.137   MouseActionSyntax 

[values]  

LeftClick A left mouse button click. 

LeftDoubleClick A left mouse button double-click. 

MiddleClick A middle mouse button click. 

MiddleDoubleClick A middle mouse button double-click. 

None No action. 

RightClick A right mouse button click. 

RightDoubleClick A right mouse button double-click. 

WheelClick A mouse wheel rotation. 

6.138   MouseButtonStateSyntax 

[values]  

Pressed The button is pressed. 

Released The button is released. 

6.139   MouseButtonSyntax 

[values]  

Left The left mouse button. 

Middle The middle mouse button. 

Right The right mouse button. 

XButton1 The first extended mouse button. 

XButton2 The second extended mouse button. 
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6.140   MouseGestureSyntax 

[patterns]  

((CONTROL|CTRL|SHIFT|ALT|WINDOWS|WIN)\s*\+\s*)*(LEFTCLICK|RIGHTCLICK|M

IDDLECLICK|WHEELCLICK|LEFTDOUBLECLICK|RIGHTDOUBLECLICK|MIDDLEDOUBLECL

ICK) 

One of 

the 

MouseAct

ionSyntax 

values, 

optionally 

preceded 

by a '+'-

delimited 

sequence 

from the 

ModifierK

eysSynta

x. 

6.141   NavigationModeSyntax 

[values]  

Back Navigating back to the most recent content in back navigation history. This occurs when the 

GoBack method is called. 

Forward Navigating to the most recent content on forward navigation history. This occurs when the 

GoForward method is called. 

New Navigating to new content. This occurs when the Navigate method is called, or when Source 

property is set. 

Refresh Reloading the current content. This occurs when the Refresh method is called. 

6.142   NavigationUIVisibilitySyntax 

[values]  

Automatic The navigation chrome is visible when a Frame uses its own journal (see JournalOwnership). 

Hidden The navigation chrome is not visible. 

Visible The navigation chrome is visible. 

6.143   NonClientFrameEdgesSyntax (4.5) 

[values]  

Bottom The bottom edge is not owned by the client (value = 8). 

Left The left edge is not owned by the client (value = 1). 

None All edges are owned by the client (value = 0). 

Right The right edge is not owned by the client (value = 4). 

Top The top edge is not owned by the client (value = 2). 
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6.144   NumberCultureSourceSyntax 

[values]  

Override Number culture is derived from the CultureOverride property. 

Text Default. Number culture is derived from the value of the CultureInfo property, which is the 

culture of the text run. In markup, this is represented by the xml:lang attribute. 

User Number culture is derived from the culture value of the current thread, which by default is the 

user default culture. 

6.145   NumberSubstitutionMethodSyntax 

[values]  

AsCulture Default. Specifies that the substitution method should be determined based on the 

number culture's DigitSubstitution property value. 

Context If the number culture is an Arabic or Farsi culture, specifies that the digits depend on 

the context. Either traditional or Latin digits are used depending on the nearest 

preceding strong character, or, if there is none, the text direction of the paragraph. 

European Specifies that code points 0x30-0x39 are always rendered as European digits, in which 

case, no number substitution is performed. 

NativeNational Specifies that numbers are rendered using the national digits for the number culture, 

as specified by the culture's NativeDigits property value. 

Traditional Specifies that numbers are rendered using the traditional digits for the number culture. 

For most cultures, this is the same as the NativeNational enumeration value. However, 

using NativeNational can result in Latin digits for some Arabic cultures, whereas using 

Traditional results in Arabic digits for all Arabic cultures. 

6.146   OrientationSyntax 

[values]  

Horizontal Control or layout should be horizontally oriented. 

Vertical Control or layout should be vertically oriented. 

6.147   OverflowModeSyntax 

[values]  

Always Item is permanently placed in the overflow panel. 

AsNeeded Item moves between the main panel and overflow panel, depending on the available space. 

Never Item is never allowed to overflow. 

6.148   PageRangeSelectionSyntax 

[values]  
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[values]  

AllPages All pages. 

CurrentPage (4.5) The current page. 

SelectedPages (4.5) The selected pages. 

UserPages A user-specified range of pages. 

6.149   PanningModeSyntax 

[values]  

Both The ScrollViewer scrolls horizontally and vertically. 

HorizontalFirst The ScrollViewer scrolls when the user moves a finger horizontally first. If the user 

moves the vertically first, the movement is treated as mouse events. After the 

ScrollViewer begins to scroll, it will scroll horizontally and vertically. 

HorizontalOnly The ScrollViewer scrolls horizontally only. 

None The ScrollViewer does not respond to touch input. 

VerticalFirst The ScrollViewer scrolls when the user moves a finger vertically first. If the user moves 

the horizontally first, the movement is treated as mouse events. After the ScrollViewer 

begins to scroll, it will scroll horizontally and vertically. 

VerticalOnly The ScrollViewer scrolls vertically only. 

6.150   PathAnimationSourceSyntax 

[values]  

Angle Specifies the tangent angle of rotation during the progression along an animation sequence 

path. 

X Specifies the x-coordinate offset during the progression along an animation sequence path. 

Y Specifies the y-coordinate offset during the progression along an animation sequence path. 

6.151   PathFigureCollectionSyntax 

[patterns]  

(\s*[mMlLhHvVcCsSqQtTaAzZ]\s*((([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+))*([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?))?)* 

A sequence of single letter 

commands, each followed by a 

sequence of comma and/or 

whitespace-separated floating 

point decimal values. 

[is case sensitive] true 

6.152   PenLineCapSyntax 

[values]  
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[values]  

Flat A cap that does not extend past the last point of the line. Comparable to no line cap. 

Round A semicircle that has a diameter equal to the line thickness. 

Square A rectangle that has a height equal to the line thickness and a length equal to half the line 

thickness. 

Triangle An isosceles right triangle whose base length is equal to the thickness of the line. 

6.153   PenLineJoinSyntax 

[values]  

Bevel Beveled vertices. 

Miter Regular angular vertices. 

Round Rounded vertices. 

6.154   PixelFormatSyntax 

[values]  

Default The default pixel format. (The meaning of this is context-specific.) 

[trim 

whitespace] 

false 

Extended No specific meaning is defined for this value, but individual properties may define a 

meaning for it. 

[trim 

whitespace] 

false 

Indexed1 A color-indexed format with 2 entries in the index. 

[trim 

whitespace] 

false 

Indexed2 A color-indexed format with 4 entries in the index. 

[trim 

whitespace] 

false 

Indexed4 A color-indexed format with 16 entries in the index. 

[trim 

whitespace] 

false 

Indexed8 A color-indexed format with 256 entries in the index. 

[trim 

whitespace] 

false 

BlackWhite A 1bpp black and white image. 
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[values]  

[trim 

whitespace] 

false 

Gray2 A monochrome image with 4 levels of brightness. 

[trim 

whitespace] 

false 

Gray4 A monochrome image with 16 levels of brightness. 

[trim 

whitespace] 

false 

Gray8 A monochrome image with 256 levels of brightness. 

[trim 

whitespace] 

false 

Gray16 A monochrome image with 65536 levels of brightness. 

[trim 

whitespace] 

false 

Gray32Float A monochrome image with brightness represented as a 32-bit floating point value. 

[trim 

whitespace] 

false 

Bgr555 An image in which each pixel is represented by a 16-bit value containing 5 bits of 

blue, 5 bits of green, then 5 bits of red channel data for each pixel (with one unused 

bit) 

[trim 

whitespace] 

false 

Bgr565 An image in which each pixel is represented by a 16-bit value containing 5 bits of 

blue, 6 bits of green, then 5 bits of red channel data for each pixel 

[trim 

whitespace] 

false 

Bgr24 An image where each pixel is represented by a 24-bit value comprising a blue, then a 

green, then a red octet (8-bit byte) 

[trim 

whitespace] 

false 

Rgb24 An image where each pixel is represented by a red, then a green, then a blue octet 

(8-bit byte) 

[trim 

whitespace] 

false 

Bgr101010 An image with 10 bits each for the blue, green, and red channels. 

[trim 

whitespace] 

false 
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[values]  

Bgr32 An image where each pixel is represented by a 32-bit value comprising a blue, then a 

green, then a red octet (8-bit byte), with one unused octet per pixel 

[trim 

whitespace] 

false 

Bgra32 An image where each pixel is represented by a 32-bit value comprising a blue, then a 

green, then a red, then an alpha octet (8-bit byte) 

[trim 

whitespace] 

false 

Pbgra32 An image where each pixel is represented by a 32-bit value comprising a blue, then a 

green, then a red, then an alpha octet (8-bit byte), where the red, green, and blue 

channels are pre-multiplied by the alpha channel. 

[trim 

whitespace] 

false 

Rgb48 An image with 16 bits each for the red, green, and blue channels. 

[trim 

whitespace] 

false 

Rgba64 An image with 16 bits each for the red, green, blue, and alpha channels. 

[trim 

whitespace] 

false 

Prgba64 An image with 16 bits each for the red, green, blue, and alpha channels, where the 

red, green, and blue channels are pre-multiplied by the alpha channel. 

[trim 

whitespace] 

false 

Rgb128Float An image where the red, green, and blue channels are each represented by a 32-bit 

floating point value, and the pixel size is padded to be 128 bits wide. 

[trim 

whitespace] 

false 

Rgba128Float An image where the red, green, blue, and alpha channels are each represented by a 

32-bit floating point value. 

[trim 

whitespace] 

false 

Prgba128Float An image where the red, green, blue, and alpha channels are each represented by a 

32-bit floating point value, and the red, green, and blue channels are pre-multiplied 

by the alpha channel. 

[trim 

whitespace] 

false 

Cmyk32 An image where each pixel is represented by a 32-bit value comprising a cyan, then a 

magenta, then a yellow, then a black octet. 

[trim false 
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[values]  

whitespace] 

6.155   PlacementModeSyntax 

[values]  

Absolute A position of the Popup control relative to the upper-left corner of the screen and at an 

offset that is defined by the HorizontalOffset and VerticalOffset property values. If the 

screen edge obscures the Popup, the control then repositions itself to align with the 

edge. 

AbsolutePoint A position of the Popup control relative to the upper-left corner of the screen and at an 

offset that is defined by the HorizontalOffset and VerticalOffset property values. If the 

screen edge obscures the Popup, the control extends in the opposite direction from the 

axis defined by the HorizontalOffset or VerticalOffset. 

Bottom A position of the Popup control where the control  aligns its upper edge with the lower 

edge of the PlacementTarget and aligns its left edge with the left edge of the 

PlacementTarget. If the lower screen-edge obscures the Popup, the control repositions 

itself so that its lower edge aligns with the upper edge of the PlacementTarget. If the 

upper screen-edge obscures the Popup, the control then repositions itself so that its 

upper edge aligns with the upper screen-edge. 

Center A position of the Popup control where it is centered over the PlacementTarget. If a 

screen edge obscures the Popup, the control repositions itself to align with the screen 

edge. 

Left A Popup control that aligns its right edge with the left edge of the PlacementTarget and 

aligns its upper edge with the upper edge of the PlacementTarget. If the left screen-

edge obscures the Popup, the Popup repositions itself so that its left edge aligns with 

the right edge of the PlacementTarget. If the right screen-edge obscures the Popup, the 

right edge of the control aligns with the right screen-edge. If the upper or lower screen-

edge obscures the Popup, the control repositions itself to align with the obscuring 

screen edge. 

Mouse A position of the Popup control that aligns its upper edge with the lower edge of the 

bounding box of the mouse and aligns its left edge with the left edge of the bounding 

box of the mouse. If the lower screen-edge obscures the Popup, it repositions itself to 

align with the upper edge of the bounding box of the mouse. If the upper screen-edge 

obscures the Popup, the control repositions itself to align with the upper screen-edge. 

MousePoint A position of the Popup control relative to the tip of the mouse cursor and at an offset 

that is defined by the HorizontalOffset and VerticalOffset property values. If a horizontal 

or vertical screen edge obscures the Popup, it opens in the opposite direction from the 

obscuring edge. If the opposite screen edge also obscures the Popup, it then aligns with 

the obscuring screen edge. 

Relative A position of the Popup control relative to the upper-left corner of the PlacementTarget 

and at an offset that is defined by the HorizontalOffset and VerticalOffset property 

values. If the screen edge obscures the Popup, the control repositions itself to align with 

the screen edge. 

RelativePoint A position of the Popup control relative to the upper-left corner of the PlacementTarget 

and at an offset that is defined by the HorizontalOffset and VerticalOffset property 

values. If a screen edge obscures the Popup, the Popup extends in the opposite 

direction from the direction from the axis defined by the HorizontalOffset or 

VerticalOffset. If the opposite screen edge also obscures the Popup, the control then 
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[values]  

aligns with this screen edge. 

Right A position of the Popup control that aligns its left edge with the right edge of the 

PlacementTarget and aligns its upper edge with the upper edge of the PlacementTarget. 

If the right screen-edge obscures the Popup, the control repositions itself so that its left 

edge aligns with the left edge of the PlacementTarget. If the left screen-edge obscures 

the Popup, the control repositions itself so that its left edge aligns with the left screen-

edge. If the upper or lower screen-edge obscures the Popup, the control then 

repositions itself to align with the obscuring screen edge. 

Top A position of the Popup control that aligns its lower edge with the upper edge of the 

PlacementTarget and aligns its left edge with the left edge of the PlacementTarget. If 

the upper screen-edge obscures the Popup, the control repositions itself so that its 

upper edge aligns with the lower edge of the PlacementTarget. If the lower screen-edge 

obscures the Popup, the lower edge of the control aligns with the lower screen-edge. If 

the left or right screen-edge obscures the Popup, it then repositions itself to align with 

the obscuring screen. 

6.156   PngInterlaceOptionSyntax 

[values]  

Default The PngBitmapEncoder determines whether the image should be interlaced. 

Off The resulting bitmap image is not interlaced. 

On The resulting bitmap image is interlaced. 

6.157   Point3DCollectionSyntax 

[patterns]  

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)(((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)){2}((((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?)){3})* 

Sequence of decimal floating 

point values, separated by 

either a comma or whitespace. 

The number of values in the 

sequence is a multiple of three. 

[is case sensitive] true 

6.158   Point3DSyntax 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){2}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Three decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.159   Point4DSyntax 

[patterns]  
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[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){3}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Four decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.160   PointCollectionSyntax 

[patterns]  

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?)){2})* 

Sequence of decimal floating 

point values, separated by 

either a comma or whitespace. 

The number of values in the 

sequence is a multiple of two. 

[is case sensitive] true 

6.161   PointSyntax 

[patterns]  

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Two decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.162   PopupAnimationSyntax 

[values]  

Fade The Popup control gradually appears, or fades in. This effect is created by increasing the 

opacity of the Popup window over time. 

None The Popup control appears without animation. 

Scroll The Popup control scrolls from the upper-left corner of its parent. If the screen does not provide 

enough room to allow the Popup default behavior, the Popup scrolls from the lower-right corner 

instead. 

Slide The Popup control slides down or up into place. By default, a Popup slides down. However, if 

the screen does not provide enough room for the Popup to slide down, it slides up instead. 

6.163   PopupPrimaryAxisSyntax 

[values]  

Horizontal A Popup control changes position by moving along the horizontal axis of the screen before 

moving along the vertical axis. 

None A Popup control changes position according to default Popup behavior. 

Vertical A Popup control changes position by moving along the vertical axis of the screen before 
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[values]  

moving along the horizontal axis. 

6.164   PowerLineStatusSyntax 

[values]  

Offline The system power is not on. 

Online The system power is on. 

Unknown The status of the system power cannot be determined. 

6.165   PresentationTraceLevelSyntax 

[values]  

High Traces all additional information. 

Low Traces some additional information. 

Medium Traces a medium amount of additional information. 

None Traces no available additional information. 

6.166   PropertyPathSyntax 

[patterns]  

.* Property paths have a syntax that involves balanced parentheses and balanced square 

brackets, and so it cannot be represented as a regular expression. The syntax takes the 

form of a list of property identifiers each separated by either a . or a /. Each property 

identifier is either an alphanumeric string of characters, or a sequence of characters 

enclosed in parentheses. Each property may optionally be followed by one or more square-

bracket-enclosed alphanumeric strings. Examples:  Property Property.More.Properties 

MyCollection[100] MyHashTable[foo].Bar Multi[10][20] Prop.Coll/Foo[10] 

[is case 

sensitive] 

true 

6.167   QuaternionSyntax 

[values]  

Identity The Identity quaternion 

6.168   ReadabilitySyntax 

[values]  

Inherit Targeted value readability is inherited from its parent node. 

Readable Targeted value is readable text. 
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[values]  

Unreadable Targeted value is not readable. 

6.169   ReasonSessionEndingSyntax 

[values]  

Logoff The session is ending because the user is logging off. 

Shutdown The session is ending because the user is shutting down Windows. 

6.170   RecognitionConfidenceSyntax 

[values]  

Intermediate Indicates intermediate confidence in the recognition result. 

Poor Indicates poor confidence in the recognition result. 

Strong Indicates strong confidence in the recognition result. 

6.171   Rect3DSyntax 

[values]  

Empty Equivalent to a 

value of 

"0,0,0,0,0,0" 

[is case sensitive] true 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){3}((\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){2}(\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?) 

Six decimal 

floating point 

values, 

separated by 

either a comma 

or whitespace. 

The last three 

digits must not 

be negative. 

[is case sensitive] true 

6.172   RectSyntax 

[values]  

Empty Equivalent to a 

value of 

"0,0,0,0" 

[is case sensitive] true 
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[values]  

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){2}((\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+))(\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Four decimal 

floating point 

values, 

separated by 

either a comma 

or whitespace. 

The last two 

digits must not 

be negative. 

[is case sensitive] true 

6.173   RelativeSourceModeSyntax 

[values]  

FindAncestor Refers to the ancestor in the parent chain of the data-bound element. You can use 

this to bind to an ancestor of a specific type or its subtypes. This is the mode you 

use if you want to specify AncestorType and/or AncestorLevel. 

PreviousData Allows you to bind the previous data item (not that control that contains the data 

item) in the list of data items being displayed. 

Self Refers to the element on which you are setting the binding and allows you to bind 

one property of that element to another property on the same element. 

TemplatedParent Refers to the element to which the template (in which the data-bound element 

exists) is applied. This is similar to setting a TemplateBindingExtension and is only 

applicable if the Binding is within a template. 

6.174   RenderingBiasSyntax 

[values]  

Performance The rendering system emphasizes performance. 

Quality The rendering system emphasizes quality. 

6.175   RepeatBehaviorSyntax 

[values]  

Forever Indicates that an animation should repeat 

indefinitely. 

[is case sensitive] true 

[patterns]  

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)x 

A decimal floating point number followed by an 

'x'. Indicates that the animation should repeat 

the specified number of times. Example:  2x 

Repeat twice 4.5x Repeat four and a half times 
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[values]  

[is case sensitive] true 

(\d+\.)?\d\d?:\d\d?:((\d\d?)|(\d?\d?\.\d*)) The string may optionally begin with a decimal 

number and a dot. When present, this optional 

part indicates the number of days. The string 

always contains three parts separated by colons. 

The first two of these are one or two digit 

numbers specifying hours and minutes. The third 

part indicates the number of seconds and  can be 

a two-digit integer, or a floating point number 

with 0, 1, or 2 digits before the point, and any 

number of digits after the point. Examples:  

0:0:1 Repeat for one second 1.0:0:0 Repeat for 

one day 0:0:0.5 Repeat for half a second 0:0:.5 

Repeat for half a second 2.5:2:22 Repeat for two 

days, five hours, two minutes, 22 seconds 

[is case sensitive] true 

\d+ A decimal number specifying the number of days. 

Examples:  1 Repeat for one day 10 Repeat for 

ten days 

[is case sensitive] true 

6.176   RequestCachePolicySyntax 

[values]  

BypassCache Satisfies a request by using the server. No entries are taken from caches, 

added to caches, or removed from caches between the client and server. No 

entries are taken from caches, added to caches, or removed from caches 

between the client and server. This is the default cache behavior specified in 

the machine configuration file that ships with the. 

CacheIfAvailable Satisfies a request for a resource from the cache if the resource is available; 

otherwise, sends a request for a resource to the server. If the requested item 

is available in any cache between the client and the server, the request might 

be satisfied by the intermediate cache. 

CacheOnly Satisfies a request using the locally cached resource; does not send a request 

for an item that is not in the cache. When this cache policy level is specified, 

a WebException exception is thrown if the item is not in the client cache. 

CacheOrNextCacheOnly Satisfies a request for a resource either from the local computer's cache or a 

remote cache on the local area network. If the request cannot be satisfied, a 

WebException exception is thrown. In the HTTP caching protocol, this is 

achieved using the only-if-cached cache control directive. 

Default Satisfies a request for a resource either by using the cached copy of the 

resource or by sending a request for the resource to the server. The action 

taken is determined by the current cache policy and the age of the content in 

the cache. This is the cache level that should be used by most applications. 

NoCacheNoStore Never satisfies a request by using resources from the cache and does not 

cache resources. If the resource is present in the local cache, it is removed. 

This policy level indicates to intermediate caches that they should remove the 
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[values]  

resource. In the HTTP caching protocol, this is achieved using the no-cache 

cache control directive. 

Refresh Satisfies a request by using the server or a cache other than the local cache. 

Before the request can be satisfied by an intermediate cache, that cache 

must revalidate its cached entry with the server. In the HTTP caching 

protocol, this is achieved using the max-age = 0 cache control directive and 

the no-cache Pragma header. 

Reload Satisfies a request by using the server. The response might be saved in the 

cache. In the HTTP caching protocol, this is achieved using the no-cache 

cache control directive and the no-cache Pragma header. 

Revalidate Compares the copy of the resource in the cache with the copy on the server. 

If the copy on the server is newer, it is used to satisfy the request and 

replaces the copy in the cache. If the copy in the cache is the same as the 

server copy, the cached copy is used. In the HTTP caching protocol, this is 

achieved using a conditional request. 

6.177   ResizeGripDirectionSyntax (4.5) 

[values]  

Bottom The window resizes from its bottom edge. 

BottomLeft The window resizes from its bottom-left corner. 

BottomRight The window resizes from its bottom-right corner. 

Left The windows resizes from its left edge. 

None No resize behavior is specified. 

Right The window resizes from its right edge. 

Top The window resizes from its top edge. 

TopLeft The window resizes from its top-left corner. 

TopRight The window resizes from its top-right corner. 

6.178   ResizeModeSyntax 

[values]  

CanMinimize A window can only be minimized and restored. The Minimize and Maximize buttons 

are both shown, but only the Minimize button is enabled. 

CanResize A window can be resized. The Minimize and Maximize buttons are both shown and 

enabled. 

CanResizeWithGrip A window can be resized. The Minimize and Maximize buttons are both shown and 

enabled. A resize grip appears in the bottom-right corner of the window. 

NoResize A window cannot be resized. The Minimize and Maximize buttons are not displayed 

in the title bar. 
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6.179   ResourceDictionaryLocationSyntax 

[values]  

ExternalAssembly Theme dictionaries exist in assemblies external to the one defining the types being 

themed. 

None No theme dictionaries exist. 

SourceAssembly Theme dictionaries exist in the assembly that defines the types being themed. 

6.180   RestoreFocusModeSyntax 

[values]  

Auto WPF automatically tries to restore focus to the element that last had focus. 

None WPF does not restore focus. 

6.181   RibbonApplicationMenuItemLevelSyntax (4.5) 

[values]  

Middle The menu item is displayed in the middle level. 

Sub The menu item is displayed in the lowest level. 

Top The menu item is displayed in the top level. 

6.182   RibbonControlLengthSyntax (4.5) 

[values]  

Auto A RibbonControlLength structure that represents the standard automatic sizing mode. 

6.183   RibbonControlLengthUnitTypeSyntax (4.5) 

[values]  

Auto The sizing method is not specified. 

Item The size is a fixed value expressed in the number of child elements. 

Pixel The size is a fixed value expressed in pixels. 

Star The size is a weighted proportion of the available space. 

6.184   RibbonDismissPopupModeSyntax (4.5) 

[values]  

Always All drop-downs in a chain are closed. 

MousePhysicallyNotOver Drop-downs in a chain are closed up to the one that the mouse pointer is 

over. 
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6.185   RibbonImageSizeSyntax (4.5) 

[values]  

Collapsed The image is collapsed. 

Large The large image is shown. 

Small The small image is shown. 

6.186   RibbonSplitButtonLabelPositionSyntax (4.5) 

[values]  

DropDown Indicates that the label should be positioned in the drop-down section of the 

RibbonSplitButton. 

Header Indicates that the label should be positioned in the header section of the RibbonSplitButton. 

6.187   RotationSyntax 

[values]  

Rotate0 The bitmap is not rotated. This is the default value. 

Rotate180 Rotate the bitmap clockwise by 180 degrees. 

Rotate270 Rotate the bitmap clockwise by 270 degrees. 

Rotate90 Rotate the bitmap clockwise by 90 degrees. 

6.188   RoutedEventSyntax 

[patterns]  

([_\p{L}][-

.\w]*:)?([_\p{Lu}\p{Ll}\p{Lo}\p{Lt}\p{Nl}][_\p{L}\p{Mn}\p{Mc}\p{Nd

}\p{Nl}]*\.)[_\p{Lu}\p{Ll}\p{Lo}\p{Lt}\p{Nl}][_\p{L}\p{Mn}\p{Mc}\p

{Nd}\p{Nl}]* 

Either a string of 

the form 

namespacePrefix:T

ypeName.EventNa

me, or a string of 

the form 

TypeName.Propert

yName. 

[is case sensitive] true 

6.189   RoutingStrategySyntax 

[values]  

Bubble The routed event uses a bubbling strategy, where the event instance routes upwards through 

the tree, from event source to root. 

Direct The routed event does not route through an element tree, but does support other routed event 

capabilities such as type handling, EventTrigger or EventSetter. 
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[values]  

Tunnel The routed event uses a tunneling strategy, where the event instance routes downwards 

through the tree, from root to source element. 

6.190   SamplingModeSyntax 

[values]  

Auto The system selects the most appropriate sampling mode. 

Bilinear Use bilinear sampling. 

NearestNeighbor Use nearest neighbor sampling. 

6.191   ScrollBarVisibilitySyntax 

[values]  

Auto A ScrollBar appears and the dimension of the ScrollViewer is applied to the content when the 

viewport cannot display all of the content. For a horizontal ScrollBar, the width of the content 

is set to the ViewportWidth of the ScrollViewer. For a vertical ScrollBar, the height of the 

content is set to the ViewportHeight of the ScrollViewer. 

Disabled A ScrollBar does not appear even when the viewport cannot display all of the content. The 

dimension of the content is set to the corresponding dimension of the ScrollViewer parent. For 

a horizontal ScrollBar, the width of the content is set to the ViewportWidth of the 

ScrollViewer. For a vertical ScrollBar, the height of the content is set to the ViewportHeight of 

the ScrollViewer. 

Hidden A ScrollBar does not appear even when the viewport cannot display all of the content. The 

dimension of the ScrollViewer is not applied to the content. 

Visible A ScrollBar always appears. The dimension of the ScrollViewer is applied to the content. For a 

horizontal ScrollBar, the width of the content is set to the ViewportWidth of the ScrollViewer. 

For a vertical ScrollBar, the height of the content is set to the ViewportHeight of the 

ScrollViewer. 

6.192   ScrollEventTypeSyntax 

[values]  

EndScroll The Thumb was dragged to a new position and is now no longer being dragged by 

the user. 

First The Thumb moved to the Minimum position of the ScrollBar. For a vertical ScrollBar, 

this movement occurs when the CTRL+HOME keys are pressed. This movement 

corresponds to a ScrollToTopCommand in a vertical ScrollBar and a 

ScrollToLeftEndCommand in a horizontal ScrollBar. 

LargeDecrement The Thumb moved a specified distance, as determined by the value of LargeChange, 

to the left for a horizontal ScrollBar or upward for a vertical ScrollBar. For a vertical 

ScrollBar, this movement occurs when the page button that is above the Thumb is 

pressed, or when the PAGE UP key is pressed, and corresponds to a 

PageUpCommand. For a horizontal ScrollBar, this movement occurs when the page 

button to the left of the Thumb is pressed, and corresponds to a PageLeftCommand. 
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[values]  

LargeIncrement The Thumb moved a specified distance, as determined by the value of LargeChange, 

to the right for a horizontal ScrollBar or downward for a vertical ScrollBar. For a 

vertical ScrollBar, this movement occurs when the page button that is below the 

Thumb is pressed, or when the PAGE DOWN key is pressed, and corresponds to a 

PageDownCommand. For a horizontal ScrollBar, this movement occurs when the 

page button to the right of the Thumb is pressed, and corresponds to a 

PageRightCommand. 

Last The Thumb moved to the Maximum position of the ScrollBar. For a vertical ScrollBar, 

this movement occurs when the CTRL+END keys are pressed. This movement 

corresponds to a ScrollToEndCommand in a vertical ScrollBar and a 

ScrollToRightEndCommand in a horizontal ScrollBar. 

SmallDecrement The Thumb moved a small distance, as determined by the value of SmallChange, to 

the left for a horizontal ScrollBar or upward for a vertical ScrollBar. For a vertical 

ScrollBar, this movement occurs when the upper RepeatButton is pressed or when 

the UP ARROW key is pressed, and corresponds to a LineUpCommand. For a 

horizontal ScrollBar, this movement occurs when the left RepeatButton is pressed, 

and corresponds to a LineLeftCommand. 

SmallIncrement The Thumb moved a small distance, as determined by the value of SmallChange, to 

the right for a horizontal ScrollBar or downward for a vertical ScrollBar. For a vertical 

ScrollBar, this movement occurs when the lower RepeatButton is pressed or when 

the DOWN ARROW key is pressed, and corresponds to a LineDownCommand. For a 

horizontal ScrollBar, this movement occurs when the right RepeatButton is pressed, 

and corresponds to a LineRightCommand. 

ThumbPosition The Thumb moved to a new position because the user selected Scroll Here in the 

shortcut menu of the ScrollBar. This movement corresponds to the 

ScrollHereCommand. To view the shortcut menu, right-click the mouse when the 

pointer is over the ScrollBar. 

ThumbTrack The Thumb was dragged and caused a MouseMove event. A Scroll event of this 

ScrollEventType may occur more than one time when the Thumb is dragged in the 

ScrollBar. 

6.193   ScrollUnitSyntax (4.5) 

[values]  

Item The ScrollUnit is measured in terms of the items that are displayed in the panel. 

Pixel The ScrollUnit is measured in terms of device-independent units (1/96th inch per unit). 

6.194   SelectionModeSyntax 

[values]  

Extended The user can select multiple consecutive items while holding down the SHIFT key. 

Multiple The user can select multiple items without holding down a modifier key. 

Single The user can select only one item at a time. 
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6.195   SelectiveScrollingOrientationSyntax 

[values]  

Both The panel scrolls in both the horizontal and vertical direction. 

Horizontal The panel scrolls in the horizontal direction only. 

None The panel does not scroll. 

Vertical The panel scrolls in the vertical direction only. 

6.196   ShaderRenderModeSyntax 

[values]  

Auto Allow hardware and software rendering. 

HardwareOnly Require hardware rendering, ignore if unavailable. 

SoftwareOnly Force software rendering. 

6.197   ShutdownModeSyntax 

[values]  

OnExplicitShutdown An application shuts down only when Shutdown is called. 

OnLastWindowClose An application shuts down when either the last window closes, or Shutdown is 

called. 

OnMainWindowClose An application shuts down when either the main window closes, or Shutdown is 

called. 

6.198   Size3DSyntax 

[values]  

Empty Equivalent to a 

value of "0,0,0" 

[is case sensitive] true 

[patterns]  

((\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){2}(\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?) 

Three decimal 

floating point 

values, separated 

by either a 

comma or 

whitespace. 

[is case sensitive] true 
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6.199   SizeSyntax 

[values]  

Empty Equivalent to a 

value of "0,0" 

[is case sensitive] true 

[patterns]  

(\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)(\+?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?) 

Two decimal floating 

point values, 

separated by either 

a comma or 

whitespace. 

[is case sensitive] true 

6.200   SizeToContentSyntax 

[values]  

Height Specifies that a window will automatically set its height to fit the height of its 

content, but not the width. 

Manual Specifies that a window will not automatically set its size to fit the size of its content. 

Instead, the size of a window is determined by other properties, including Width, 

Height, MaxWidth, MaxHeight, MinWidth, and MinHeight. 

Width Specifies that a window will automatically set its width to fit the width of its content, 

but not the height. 

WidthAndHeight Specifies that a window will automatically set both its width and height to fit the 

width and height of its content. 

6.201   SlipBehaviorSyntax 

[values]  

Grow Indicates that a ParallelTimeline will not slip with the child Timeline, but will expand to fit all 

slipping Timeline children. NOTE: This is only effective when the Duration of the ParallelTimeline 

is not explicitly specified. 

Slip Indicates that a ParallelTimeline will slip along with its first child Timeline that can slip 

whenever that child is delayed or accelerated.. 

6.202   SpeechModeSyntax 

[values]  

Command Speech input is interpreted as commands. 

Dictation Speech input is interpreted as dictation. 

Indeterminate Speech input mode is indeterminate. 
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6.203   SpellingReformSyntax 

[values]  

Postreform Use spelling rules from after the spelling reform. 

PreAndPostreform Use spelling rules from both before and after the spelling reform. 

Prereform Use spelling rules from before the spelling reform. 

6.204   StickyNoteTypeSyntax 

[values]  

Ink An ink sticky note. 

Text A text sticky note. 

6.205   StretchDirectionSyntax 

[values]  

Both The content stretches to fit the parent according to the Stretch mode. 

DownOnly The content scales downward only when it is larger than the parent. If the content is 

smaller, no scaling upward is performed. 

UpOnly The content scales upward only when it is smaller than the parent. If the content is larger, 

no scaling downward is performed. 

6.206   StretchSyntax 

[values]  

Fill The content is resized to fill the destination dimensions. The aspect ratio is not 

preserved. 

None The content preserves its original size. 

Uniform The content is resized to fit in the destination dimensions while it preserves its native 

aspect ratio. 

UniformToFill The content is resized to fill the destination dimensions while it preserves its native 

aspect ratio. If the aspect ratio of the destination rectangle differs from the source, the 

source content is clipped to fit in the destination dimensions. 

6.207   StringCollectionSyntax 

StringComparisonSyntax 

[values]  

CurrentCulture Compare strings using culture-sensitive sort rules and the current 

culture. 

CurrentCultureIgnoreCase Compare strings using culture-sensitive sort rules, the current culture, 
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StringComparisonSyntax 

and ignoring the case of the strings being compared. 

InvariantCulture Compare strings using culture-sensitive sort rules and the invariant 

culture. 

InvariantCultureIgnoreCase Compare strings using culture-sensitive sort rules, the invariant culture, 

and ignoring the case of the strings being compared. 

Ordinal Compare strings using ordinal sort rules. 

OrdinalIgnoreCase Compare strings using ordinal sort rules and ignoring the case of the 

strings being compared. 

6.208   StrokeCollectionSyntax 

[patterns]  

[A-Za-z0-9+/]* A base64 string. 

[is case sensitive] true 

6.209   StyleSimulationsSyntax 

[values]  

BoldItalicSimulation Bold and Italic style simulation. 

BoldSimulation Bold style simulation. 

ItalicSimulation Italic style simulation. 

None No font style simulation. 

6.210   StylusButtonStateSyntax 

[values]  

Down The button is pressed down. 

Up The button is up. 

6.211   StylusPointPropertyUnitSyntax 

[values]  

Centimeters Indicates that a StylusPoint property is measured in centimeters. 

Degrees Indicates that a StylusPoint property is measured in degrees. 

Grams Indicates that a StylusPoint property is measured in grams. 

Inches Indicates that a StylusPoint property is measured in inches. 

None Indicates that a StylusPoint property's measurement is not specified. 
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[values]  

Pounds Indicates that a StylusPoint property is measured in pounds. 

Radians Indicates that a StylusPoint property is measured in radians. 

Seconds Indicates that a StylusPoint property is measured in seconds. 

6.212   StylusTipSyntax 

[values]  

Ellipse Represents an ellipse-shaped tip. 

Rectangle Represents a rectangle-shaped tip. 

6.213   SweepDirectionSyntax 

[values]  

Clockwise Specifies that arcs are drawn in a clockwise (positive-angle) direction. 

Counterclockwise Specifies that arcs are drawn in a counter clockwise (negative-angle) direction. 

6.214   SystemGestureSyntax 

[values]  

Drag Maps to a left drag on a mouse. 

Flick Occurs with a short, quick stroke that translates into a specific command. The action 

taken by a flick is set system-wide. An application can listen for a Flick and prevent it 

from becoming one of the standard ApplicationCommands by setting the Handled 

property to true in the StylusSystemGesture event. 

HoldEnter Indicates that press and hold has occurred. 

HoldLeave  

HoverEnter Maps to a mouse hover. This can be used to show ToolTip rollover effects, or other 

mouse hover behaviors. 

HoverLeave Maps to a mouse leaving a hover. This can be used to end ToolTip rollover effects or 

other mouse hover behaviors. 

None No system gesture. 

RightDrag Maps to a right drag on a mouse. This can be used to drag an object or selection to a 

different area and is followed by the appearance of the shortcut menu which provides 

options for moving the object. 

RightTap Maps to a right-click on a mouse. This can be used to show a shortcut menu. 

Tap Maps to a left-click on a mouse. This can be used to choose a command from the menu 

or toolbar, take action if a command is chosen, set an insertion point, or show selection 

feedback. 
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[values]  

TwoFingerTap Maps to a double-click of a mouse. 

6.215   TabletDeviceTypeSyntax 

[values]  

Stylus Indicates the tablet device is a stylus. 

Touch Indicates the tablet device is a touch screen. 

6.216   TabletHardwareCapabilitiesSyntax 

[values]  

HardProximity Indicates the tablet device can generate in-air packets when the stylus is in the 

physical detection range (proximity) of the tablet device. 

Integrated Indicates the digitizer is integrated with the display. 

None Indicates the tablet device cannot provide this information. 

StylusHasPhysicalIds Indicates the tablet device can uniquely identify the active stylus. 

StylusMustTouch Indicates the stylus must be in physical contact with the tablet device to report 

its position. 

SupportsPressure Indicates that the tablet device can detect the amount of pressure the user 

applies when using the stylus. 

6.217   TaskbarItemProgressStateSyntax 

[values]  

Error A red progress indicator is displayed in the taskbar button. 

Indeterminate A pulsing green indicator is displayed in the taskbar button. 

None No progress indicator is displayed in the taskbar button. 

Normal A green progress indicator is displayed in the taskbar button. 

Paused A yellow progress indicator is displayed in the taskbar button. 

6.218   TextAlignmentSyntax 

[values]  

Center Text is centered. 

Justify Text is justified. 

Left Default. Text is aligned to the left. 

Right Text is aligned to the right. 
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6.219   TextCollapsingStyleSyntax 

[values]  

TrailingCharacter Collapse trailing characters. 

TrailingWord Collapse trailing words. 

6.220   TextCompositionAutoCompleteSyntax 

[values]  

Off Auto-complete is off. 

On Auto-complete is on. A TextInput event will be raised automatically by the 

TextCompositionManager after a TextInputStart event is handled. 

6.221   TextDataFormatSyntax 

[values]  

CommaSeparatedValue Specifies that the text data is in the CommaSeparatedValue data format. 

Html Specifies that the text data is in the Html data format. 

Rtf Specifies that the text data is in the Rtf data format. 

Text Specifies that the text data is in the Text data format. 

UnicodeText Specifies that the text data is in the UnicodeText data format. 

Xaml Specifies that the text data is in the Xaml data format. 

6.222   TextDecorationCollectionSyntax 

[patterns]  

(NONE)|(OVERLINE|BASELINE|UNDERLINE|STRIKETHROUGH)?((\s*,\s*)(OVERLINE|

BASELINE|UNDERLINE|STRIKETHROUGH))* 

Either 

'none', or 

a 

comma-

separate

d list of 

any 

combinat

ion of 

overline, 

baseline, 

underline

, and 

strikethr

ough. 

6.223   TextDecorationLocationSyntax 

[values]  
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[values]  

Baseline The vertical position of a baseline. 

OverLine The vertical position of an overline. 

Strikethrough The vertical position of a strikethrough. 

Underline The vertical position of an underline. This is the default value. 

6.224   TextDecorationUnitSyntax 

[values]  

FontRecommended A unit value that is relative to the font used for the TextDecoration. If the 

decoration spans multiple fonts, an average recommended value is calculated. 

This is the default value. 

FontRenderingEmSize A unit value that is relative to the em size of the font. The value of the offset or 

thickness is equal to the offset or thickness value multiplied by the font em 

size. 

Pixel A unit value that is expressed in pixels. 

6.225   TextFormattingModeSyntax 

[values]  

Display Indicates that the TextFormatter lays out text by using GDI-compatible font metrics. 

Ideal Indicates that the TextFormatter lays out text by using ideal font metrics. 

6.226   TextHintingModeSyntax 

[values]  

Animated The rendering engine renders text with the highest animated quality. 

Auto The rendering engine automatically determines whether to draw text with quality settings 

appropriate for animated or static text. 

Fixed The rendering engine renders text with the highest static quality. 

6.227   TextMarkerStyleSyntax 

[values]  

Box A solid square box is displayed. 

Circle A hollow disc circle is displayed. 

Decimal A decimal is displayed, starting with the number one, for example, 1, 2, and 3. The 

TextMarkerStyle is automatically incremented for each item added to the list. 

Disc A solid disc circle is displayed. 
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[values]  

LowerLatin A lowercase ASCII character is displayed, starting with the letter a, for example, a, b, 

and c. The TextMarkerStyle is automatically incremented for each item added to the list. 

LowerRoman A lowercase Roman numeral is displayed, starting with the numeral i, for example, i, ii, 

iii, and iv. The TextMarkerStyle is automatically incremented for each item added to the 

list. 

None No marker is displayed. 

Square A hollow square shape is displayed. 

UpperLatin An uppercase ASCII character is displayed, starting with the letter A, for example, A, B, 

and C. The TextMarkerStyle is automatically incremented for each item added to the list. 

UpperRoman An uppercase Roman numeral is displayed, starting with the numeral I, for example, I, 

II, III, and IV. The TextMarkerStyle is automatically incremented for each item added to 

the list. 

6.228   TextPointerContextSyntax 

[values]  

ElementEnd The TextPointer is adjacent to the closing tag of a TextElement. 

ElementStart The TextPointer is adjacent to the opening tag of a TextElement. 

EmbeddedElement The TextPointer is adjacent to an embedded UIElement or ContentElement. 

None The TextPointer is adjacent to the beginning or end of content. 

Text The TextPointer is adjacent to text. 

6.229   TextRenderingModeSyntax 

[values]  

Aliased Text is rendered with bilevel anti-aliasing. 

Auto Text is rendered with the most appropriate rendering algorithm based on the layout mode 

that was used to format the text. 

ClearType Text is rendered with the most appropriate ClearType rendering algorithm based on the 

layout mode that was used to format the text. 

Grayscale Text is rendered with grayscale anti-aliasing. 

6.230   TextTabAlignmentSyntax 

[values]  

Center Text is center-aligned at the tab location. 

Character Text is aligned at the tab location at a specified character. 

Left Text is left-aligned at the tab location. 
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[values]  

Right Text is right-aligned at the tab location. 

6.231   TextTrimmingSyntax 

[values]  

CharacterEllipsis Text is trimmed at a character boundary. An ellipsis (...) is drawn in place of 

remaining text. 

None Text is not trimmed. 

WordEllipsis Text is trimmed at a word boundary. An ellipsis (...) is drawn in place of remaining 

text. 

6.232   TextWrappingSyntax 

[values]  

NoWrap No line wrapping is performed. 

Wrap Line breaking occurs if the line overflows beyond the available block width, even if 

a line-breaking opportunity cannot be determined, as in the case of a very long 

word constrained in a fixed-width container with no scrolling allowed. 

WrapWithOverflow Line breaking occurs if the line overflows beyond the available block width. 

However, a line may overflow beyond the block width if a line-break opportunity 

cannot be determined, as in the case of a very long word constrained in a fixed-

width container with no scrolling allowed. 

6.233   ThicknessSyntax 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+))?([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

One decimal floating point value, 

or two values separated by 

either a comma or whitespace. 

[is case sensitive] true 

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){3}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Four decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.234   TickBarPlacementSyntax 

[values]  

Bottom The tick bar is positioned below the Track of the Slider. 

Left The tick bar is positioned to the left of the Track of the Slider. 

Right The tick bar is positioned to the right of the Track of the Slider. 
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[values]  

Top The tick bar is positioned above the Track of the Slider. 

6.235   TickPlacementSyntax 

[values]  

Both Tick marks appear above and below the Track bar for a horizontal Slider, or to the left 

and right of the Track for a vertical Slider. 

BottomRight Tick marks appear below the Track for a horizontal Slider, or to the right of the Track for 

a vertical Slider. 

None No tick marks appear. 

TopLeft Tick marks appear above the Track for a horizontal Slider, or to the left of the Track for a 

vertical Slider. 

6.236   TiffCompressOptionSyntax 

[values]  

Ccitt3 The CCITT3 compression schema is used. 

Ccitt4 The CCITT4 compression schema is used. 

Default The TiffBitmapEncoder encoder attempts to save the bitmap with the best possible compression 

schema. 

Lzw The LZW compression schema is used. 

None The Tagged Image File Format (TIFF) image is not compressed. 

Rle The RLE compression schema is used. 

Zip Zip compression schema is used. 

6.237   TileModeSyntax 

[values]  

FlipX The same as Tile except that alternate columns of tiles are flipped horizontally. The base tile 

itself is not flipped. 

FlipXY The combination of FlipX and FlipY. The base tile itself is not flipped. 

FlipY The same as Tile except that alternate rows of tiles are flipped vertically. The base tile itself is 

not flipped. 

None The base tile is drawn but not repeated. The remaining area is transparent 

Tile The base tile is drawn and the remaining area is filled by repeating the base tile. The right edge 

of one tile meets the left edge of the next, and similarly for the bottom and top edges. 
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6.238   TimeSeekOriginSyntax 

[values]  

BeginTime The offset is relative to the beginning of the activation period of the Timeline. 

Duration The offset is relative to the Duration of the Timeline, the length of a single iteration. This 

value has no meaning if the Duration of the Timeline is not resolved. 

6.239   ToleranceTypeSyntax 

[values]  

Absolute Error tolerance is treated as an absolute value. 

Relative Error tolerance is treated as a relative value. 

6.240   TouchActionSyntax 

[values]  

Down The act of putting a finger onto the screen. 

Move The act of dragging a finger across the screen. 

Up The act of lifting a finger off of the screen. 

6.241   TransformSyntax 

[values]  

Identity The identity matrix. 

[is case sensitive] true 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){5}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Six decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.242   UndoActionSyntax 

[values]  

Clear This change will clear the undo stack 

Create This change will create a new undo unit 

Merge This change will merge into the previous undo unit 

None This change will not affect the undo stack at all 

Redo This change is the result of a call to Redo() 
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[values]  

Undo This change is the result of a call to Undo() 

6.243   UpdateSourceTriggerSyntax 

[values]  

Default The default UpdateSourceTrigger value of the binding target property. The default 

value for most properties is PropertyChanged, while the Text property has a default 

value of LostFocus. 

Explicit Updates the binding source only when you call the UpdateSource method. 

LostFocus Updates the binding source whenever the binding target element loses focus. 

PropertyChanged Updates the binding source immediately whenever the binding target property 

changes. 

6.244   ValidationErrorEventActionSyntax 

[values]  

Added A new ValidationError object has been detected. 

Removed An existing ValidationError object has been cleared. 

6.245   ValidationStepSyntax 

[values]  

CommittedValue Runs the ValidationRule after the value has been committed to the source. 

ConvertedProposedValue Runs the ValidationRule after the value is converted. 

RawProposedValue Runs the ValidationRule before any conversion occurs. 

UpdatedValue Runs the ValidationRule after the source is updated. 

6.246   Vector3DCollectionSyntax 

[patterns]  

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)(((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)){2}((((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?)){3})* 

Sequence of decimal floating 

point values, separated by 

either a comma or whitespace. 

The number of values in the 

sequence is a multiple of three. 

[is case sensitive] true 

6.247   Vector3DSyntax 

[patterns]  
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[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)){2}([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Three decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.248   VectorCollectionSyntax 

[patterns]  

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?)){2})* 

Sequence of decimal floating 

point values, separated by 

either a comma or whitespace. 

The number of values in the 

sequence is a multiple of two. 

[is case sensitive] true 

6.249   VectorSyntax 

[patterns]  

([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+)([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

Two decimal floating point 

values, separated by either a 

comma or whitespace. 

[is case sensitive] true 

6.250   VerticalAlignmentSyntax 

[values]  

Bottom The child element is aligned to the bottom of the parent's layout slot. 

Center The child element is aligned to the center of the parent's layout slot. 

Stretch The child element stretches to fill the parent's layout slot. 

Top The child element is aligned to the top of the parent's layout slot. 

6.251   VirtualizationCacheLengthSyntax (4.5) 

[patterns]  

(([+-]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-

]?\d+)?)((\s*,\s*)|\s+))?([+-

]?((\d+(\.\d*)?)|(\d*\.\d+))([eE][+-]?\d+)?) 

One decimal floating point value, 

or two values separated by either 

a comma or whitespace. 

[is case sensitive] true 
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6.252   VirtualizationCacheLengthUnitSyntax (4.5) 

[values]  

Item The CacheLength is measured in terms of the items that are displayed in the panel. 

Page The CacheLength is measured in terms of a page, which is equal to the size of the panel's 

viewport. 

Pixel The CacheLength is measured in terms of device-independent units (1/96th inch per unit). 

6.253   VirtualizationModeSyntax 

[values]  

Recycling Reuse the item containers. 

Standard Create and discard the item containers. 

6.254   VisibilitySyntax 

[values]  

Collapsed Do not display the element, and do not reserve space for it in layout. 

Hidden Do not display the element, but reserve space for the element in layout. 

Visible Display the element. 

6.255   WindowStartupLocationSyntax 

[values]  

CenterOwner The startup location of a Window is the center of the Window that owns it, as specified 

by the Owner property. 

CenterScreen The startup location of a Window is the center of the screen that contains the mouse 

cursor. 

Manual The startup location of a Window is set manually, or defers to the default Windows 

location. 

6.256   WindowStateSyntax 

[values]  

Maximized The window is maximized. 

Minimized The window is minimized. 

Normal The window is restored. 

6.257   WindowStyleSyntax 

[values]  
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[values]  

None Only the client area is visible - the title bar and border are not shown. A 

NavigationWindow with a WindowStyle of None will still display the navigation 

user interface (UI). 

SingleBorderWindow A window with a single border. This is the default value. 

ThreeDBorderWindow A window with a 3-D border. 

ToolWindow A fixed tool window. 

6.258   WrapDirectionSyntax 

[values]  

Both Content that flows around both sides of the object. 

Left Content that only flows around the left side of the object. 

None Content that does not flow around the object. 

Right Content that only flows around the right side of the object. 

6.259   XmlLanguageSyntax 

[patterns]  

[A-Z]{1,8}(-[0-

9A-Z]{1,8})* 

A series of tags, each from 1-8 characters long, separated by hyphens. The first 

tag can use upper and lowercase ASCII letters. The remaining tags can use the 

same and may also contain digits. 

[trim whitespace] false 
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IList 642 
IList(T) 643 
Image 267 
ImageBrush 268 
ImageDrawing 268 
ImageSource 268 
ImeConversionModeValues 269 
ImeConversionModeValuesSyntax 710 
ImeSentenceModeValues 269 
ImeSentenceModeValuesSyntax 710 
IMultiValueConverter 269 
InertiaExpansionBehavior 269 
InertiaRotationBehavior 270 
InertiaTranslationBehavior 270 
InheritanceBehavior 271 
InheritanceBehaviorSyntax 711 
InkCanvas 271 
InkCanvasClipboardFormat 273 
InkCanvasClipboardFormatSyntax 711 
InkCanvasEditingMode 274 
InkCanvasEditingModeSyntax 711 
InkCanvasSelectionHitResult 274 
InkCanvasSelectionHitResultSyntax 712 
InkPresenter 274 

Inline 274 
InlineCollection 275 
InlineUIContainer 276 
InputBinding 276 
InputBindingCollection 277 
InputGesture 277 
InputGestureCollection 277 
InputLanguageManager 277 
InputManager 278 
InputMethod 279 
InputMethodState 281 
InputMethodStateSyntax 712 
InputMode 281 
InputModeSyntax 712 
InputScope 281 
InputScopeName 282 
InputScopeNameValue 282 
InputScopeNameValueSyntax 712 
InputScopePhrase 282 
InputScopeSyntax 714 
InputType 283 
InputTypeSyntax 715 
Int16Animation 283 

Int16AnimationBase 284 
Int16AnimationUsingKeyFrames 284 
Int16KeyFrame 284 
Int16KeyFrameCollection 285 
Int32Animation 285 
Int32AnimationBase 286 
Int32AnimationUsingKeyFrames 286 
Int32Collection 287 
Int32CollectionSyntax 715 
Int32KeyFrame 287 
Int32KeyFrameCollection 288 
Int32Rect 288 
Int32RectSyntax 715 
Int64Animation 289 
Int64AnimationBase 289 
Int64AnimationUsingKeyFrames 290 
Int64KeyFrame 290 
Int64KeyFrameCollection 291 
IntersectionDetail 291 
IntersectionDetailSyntax 715 
IntPtr 644 
Introduction 28 
InvertAxes 291 
InvertAxesSyntax 716 
IScrollInfo 292 
IsOffscreenBehavior 292 
IsOffscreenBehaviorSyntax 716 
Italic 292 
ItemCollection 293 
ItemContainerTemplate (4.5) 294 
ItemContainerTemplateKey (4.5) 294 
ItemsControl 294 
ItemsPanelTemplate 296 
ItemsPresenter 297 
IValueConverter 297 
IWeakEventListener 297 
IXmlSerializable 644 
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J 

JournalEntry 297 
JournalEntryListConverter 298 
JournalEntryPosition 298 
JournalEntryPositionSyntax 716 
JournalEntryUnifiedViewConverter 298 
JournalOwnership 299 
JournalOwnershipSyntax 716 
JpegBitmapEncoder 299 
JumpItem 300 
JumpItemRejectionReason 300 
JumpItemRejectionReasonSyntax 717 
JumpList 300 
JumpPath 301 
JumpTask 301 

K 

KernelType 302 
KernelTypeSyntax 717 
Key 302 
KeyBinding 303 
Keyboard 303 
KeyboardNavigation 304 
KeyboardNavigationMode 305 
KeyboardNavigationModeSyntax 717 
KeyGesture 305 
KeyGestureSyntax 717 
KeySpline 306 
KeySplineSyntax 718 
KeyStates 306 
KeyStatesSyntax 718 
KeySyntax 718 
KeyTime 306 
KeyTimeSyntax 725 
KeyTimeType 307 
KeyTimeTypeSyntax 726 
KeyTipControl (4.5) 307 
KeyTipHorizontalPlacement (4.5) 307 
KeyTipHorizontalPlacementSyntax (4.5) 726 
KeyTipService (4.5) 308 
KeyTipVerticalPlacement (4.5) 308 
KeyTipVerticalPlacementSyntax (4.5) 727 

L 

Label 309 
LanguageSpecificStringDictionary 309 
LengthSyntax 727 
Light 310 
Line 310 
LinearByteKeyFrame 311 
LinearColorKeyFrame 311 
LinearDecimalKeyFrame 311 
LinearDoubleKeyFrame 311 

LinearGradientBrush 312 
LinearInt16KeyFrame 312 
LinearInt32KeyFrame 312 
LinearInt64KeyFrame 312 
LinearPoint3DKeyFrame 312 

LinearPointKeyFrame 313 
LinearQuaternionKeyFrame 313 
LinearRectKeyFrame 313 
LinearRotation3DKeyFrame 313 
LinearSingleKeyFrame 313 
LinearSizeKeyFrame 314 
LinearThicknessKeyFrame 314 
LinearVector3DKeyFrame 314 
LinearVectorKeyFrame 314 
LineBreak 314 
LineBreakCondition 315 
LineBreakConditionSyntax 727 
LineGeometry 315 
LineSegment 315 
LineStackingStrategy 316 
LineStackingStrategySyntax 727 
LinkTarget 316 
LinkTargetCollection 316 
List 316 
List(T) 644 
ListBox 317 
ListBoxItem 318 
ListItem 318 

ListItemCollection 319 
ListView 320 
ListViewItem 320 
Localization 320 
LocalizationCategory 321 
LocalizationCategorySyntax 728 
LocalValueEntry 321 
LocalValueEnumerator 321 
LogicalDirection 321 
LogicalDirectionSyntax 728 

M 

Manipulation 322 
ManipulationModes 322 
ManipulationModesSyntax 729 
ManipulationParameters2D (4.5) 644 
ManipulationPivot 323 
Material 323 
MaterialCollection 323 
MaterialGroup 324 
Matrix 324 
Matrix3D 325 
Matrix3DSyntax 729 
MatrixAnimationBase 326 
MatrixAnimationUsingKeyFrames 326 
MatrixAnimationUsingPath 327 
MatrixCamera 327 
MatrixKeyFrame 328 
MatrixKeyFrameCollection 328 
MatrixSyntax 729 
MatrixTransform 329 
MatrixTransform3D 329 
MediaCommands 329 
MediaElement 331 
MediaPlayer 332 
MediaState 333 
MediaStateSyntax 729 
MediaTimeline 334 
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Menu 334 
MenuBase 334 
MenuItem 335 
MenuItemRole 337 
MenuItemRoleSyntax 730 
MenuScrollingVisibilityConverter 337 
MeshGeometry3D 337 
MessageBoxButton 337 
MessageBoxButtonSyntax 730 
MessageBoxImage 338 
MessageBoxImageSyntax 730 
MessageBoxOptions 338 
MessageBoxOptionsSyntax 731 
MessageBoxResult 338 
MessageBoxResultSyntax 731 
MinMaxParagraphWidth 338 
Model3D 339 
Model3DCollection 339 
Model3DGroup 339 
ModelUIElement3D 340 
ModelVisual3D 340 
Modifiability 340 
ModifiabilitySyntax 731 

ModifierKeys 340 
ModifierKeysSyntax 731 
Mouse 341 
MouseAction 342 
MouseActionSyntax 732 
MouseBinding 343 
MouseButton 343 
MouseButtonState 343 
MouseButtonStateSyntax 732 
MouseButtonSyntax 732 
MouseGesture 343 
MouseGestureSyntax 733 
MultiBinding 344 
MultiDataTrigger 345 
MultiSelector 346 
MultiTrigger 346 

N 

NavigationCommands 347 
NavigationMode 348 
NavigationModeSyntax 733 
NavigationUIVisibility 348 
NavigationUIVisibilitySyntax 733 
NavigationWindow 348 
NonClientFrameEdges (4.5) 349 
NonClientFrameEdgesSyntax (4.5) 733 
NotifyDataErrorValidationRule (4.5) 350 
NumberCultureSource 350 
NumberCultureSourceSyntax 734 
NumberSubstitution 350 
NumberSubstitutionMethod 351 
NumberSubstitutionMethodSyntax 734 

O 

ObjectAnimationBase 351 
ObjectAnimationUsingKeyFrames 352 

ObjectDataProvider 352 

ObjectKeyFrame 353 
ObjectKeyFrameCollection 353 
ObservableCollection(T) 646 
Orientation 354 
OrientationSyntax 734 
OrthographicCamera 354 
OverflowMode 354 
OverflowModeSyntax 734 

P 

Page 354 
PageContent 355 
PageContentCollection 356 
PageRange 356 
PageRangeSelection 357 
PageRangeSelectionSyntax 734 
Panel 357 
PanningMode 358 

PanningModeSyntax 735 
Paragraph 358 
ParallelTimeline 359 
PasswordBox 360 
Path 360 
PathAnimationSource 361 
PathAnimationSourceSyntax 735 
PathFigure 361 
PathFigureCollection 362 
PathFigureCollectionSyntax 735 
PathGeometry 362 
PathSegment 362 
PathSegmentCollection 363 
PauseStoryboard 363 
Pen 363 
PenLineCap 364 
PenLineCapSyntax 735 
PenLineJoin 364 
PenLineJoinSyntax 736 
PerspectiveCamera 365 
PixelFormat 365 
PixelFormatChannelMask 365 
PixelFormats 366 
PixelFormatSyntax 736 
PixelShader 368 
PlacementMode 369 
PlacementModeSyntax 739 
PngBitmapEncoder 369 
PngInterlaceOption 369 
PngInterlaceOptionSyntax 740 
Point 370 
Point3D 370 
Point3DAnimation 371 
Point3DAnimationBase 371 
Point3DAnimationUsingKeyFrames 372 
Point3DCollection 372 
Point3DCollectionSyntax 740 
Point3DKeyFrame 372 
Point3DKeyFrameCollection 373 
Point3DSyntax 740 
Point4D 373 
Point4DSyntax 740 
PointAnimation 374 
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PointAnimationBase 375 
PointAnimationUsingKeyFrames 375 
PointAnimationUsingPath 375 
PointCollection 376 
PointCollectionSyntax 741 
PointKeyFrame 376 
PointKeyFrameCollection 377 
PointLight 377 
PointLightBase 377 
PointSyntax 741 
PolyBezierSegment 378 
Polygon 378 
Polyline 379 
PolyLineSegment 379 
PolyQuadraticBezierSegment 379 
Popup 380 
PopupAnimation 381 
PopupAnimationSyntax 741 
PopupPrimaryAxis 381 
PopupPrimaryAxisSyntax 741 
PowerEase 381 
PowerLineStatus 382 
PowerLineStatusSyntax 742 

Predicate(T) 646 
PresentationTraceLevel 382 
PresentationTraceLevelSyntax 742 
PresentationTraceSources 382 
PriorityBinding 383 
ProgressBar 383 
ProjectionCamera 383 
PropertyGroupDescription 384 
PropertyPath 385 
PropertyPathSyntax 742 

Q 

QuadraticBezierSegment 385 
QuadraticEase 385 
QuarticEase 386 
Quaternion 386 
QuaternionAnimation 386 
QuaternionAnimationBase 387 
QuaternionAnimationUsingKeyFrames 387 
QuaternionKeyFrame 388 
QuaternionKeyFrameCollection 389 
QuaternionRotation3D 389 
QuaternionSyntax 742 
QuinticEase 389 

R 

RadialGradientBrush 389 
RadioButton 390 
RangeBase 390 
Readability 391 
ReadabilitySyntax 742 
ReadOnlyCollection(T) 646 
ReasonSessionEnding 391 
ReasonSessionEndingSyntax 743 
RecognitionConfidence 392 
RecognitionConfidenceSyntax 743 

Rect 392 

Rect3D 393 
Rect3DSyntax 743 
Rectangle 394 
RectangleGeometry 394 
RectAnimation 395 
RectAnimationBase 395 
RectAnimationUsingKeyFrames 396 
RectKeyFrame 396 
RectKeyFrameCollection 397 
RectSyntax 743 
References 767 
RelativeSource 397 
RelativeSourceMode 398 
RelativeSourceModeSyntax 744 
RemoveStoryboard 399 
RenderCapability 399 
RenderingBias 399 
RenderingBiasSyntax 744 
RenderOptions 399 
RenderTargetBitmap 401 
RepeatBehavior 401 
RepeatBehaviorSyntax 744 
RepeatButton 401 

RequestCachePolicy 646 
RequestCachePolicySyntax 745 
ResizeGrip 402 
ResizeGripDirection (4.5) 402 
ResizeGripDirectionSyntax (4.5) 746 
ResizeMode 402 
ResizeModeSyntax 746 
ResourceDictionary 403 
ResourceDictionaryLocation 403 
ResourceDictionaryLocationSyntax 747 
ResourceKey 403 
RestoreFocusMode 404 
RestoreFocusModeSyntax 747 
ResumeStoryboard 404 
Ribbon (4.5) 404 
RibbonApplicationMenu (4.5) 407 
RibbonApplicationMenuItem (4.5) 407 
RibbonApplicationMenuItemLevel (4.5) 408 
RibbonApplicationMenuItemLevelSyntax (4.5) 747 
RibbonApplicationSplitMenuItem (4.5) 408 
RibbonButton (4.5) 408 
RibbonCheckBox (4.5) 410 
RibbonComboBox (4.5) 412 
RibbonCommands (4.5) 413 
RibbonContentPresenter (4.5) 414 
RibbonContextMenu (4.5) 414 
RibbonContextualTabGroup (4.5) 414 
RibbonContextualTabGroupItemsControl (4.5) 415 
RibbonControl (4.5) 415 
RibbonControlGroup (4.5) 416 
RibbonControlLength (4.5) 416 
RibbonControlLengthSyntax (4.5) 747 
RibbonControlLengthUnitType (4.5) 417 
RibbonControlLengthUnitTypeSyntax (4.5) 747 
RibbonControlService (4.5) 417 
RibbonControlSizeDefinition (4.5) 421 
RibbonControlSizeDefinitionCollection (4.5) 422 
RibbonDismissPopupMode (4.5) 422 
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RibbonDismissPopupModeSyntax (4.5) 747 
RibbonFilterMenuButton (4.5) 422 
RibbonGallery (4.5) 422 
RibbonGalleryCategory (4.5) 426 
RibbonGalleryItem (4.5) 427 
RibbonGroup (4.5) 428 
RibbonGroupSizeDefinition (4.5) 430 
RibbonGroupSizeDefinitionBase (4.5) 430 
RibbonGroupSizeDefinitionBaseCollection (4.5) 430 
RibbonGroupTemplateSizeDefinition (4.5) 431 
RibbonImageSize (4.5) 431 
RibbonImageSizeSyntax (4.5) 748 
RibbonMenuButton (4.5) 431 
RibbonMenuItem (4.5) 434 
RibbonQuickAccessToolBar (4.5) 436 
RibbonRadioButton (4.5) 436 
RibbonSeparator (4.5) 438 
RibbonSplitButton (4.5) 439 
RibbonSplitButtonLabelPosition (4.5) 440 
RibbonSplitButtonLabelPositionSyntax (4.5) 748 
RibbonSplitMenuItem (4.5) 441 
RibbonTab (4.5) 442 
RibbonTabHeader (4.5) 442 

RibbonTabHeaderItemsControl (4.5) 443 
RibbonTextBox (4.5) 444 
RibbonToggleButton (4.5) 446 
RibbonToolTip (4.5) 448 
RibbonTwoLineText (4.5) 449 
RibbonWindow (4.5) 450 
RichTextBox 450 
RotateTransform 451 
RotateTransform3D 451 
Rotation 452 
Rotation3D 452 
Rotation3DAnimation 452 
Rotation3DAnimationBase 453 
Rotation3DAnimationUsingKeyFrames 453 
Rotation3DKeyFrame 454 
Rotation3DKeyFrameCollection 454 
RotationSyntax 748 
RoutedCommand 455 
RoutedEvent 455 
RoutedEventHandlerInfo 456 
RoutedEventSyntax 748 
RoutedUICommand 456 
RoutingStrategy 456 
RoutingStrategySyntax 748 
RowDefinition 456 
RowDefinitionCollection 457 
Run 457 

S 

SamplingMode 458 
SamplingModeSyntax 749 
ScaleTransform 458 
ScaleTransform3D 459 
ScrollBar 459 
ScrollBarVisibility 460 
ScrollBarVisibilitySyntax 749 
ScrollContentPresenter 460 
ScrollEventType 461 

ScrollEventTypeSyntax 749 
ScrollUnit (4.5) 461 
ScrollUnitSyntax (4.5) 750 
ScrollViewer 461 
Section 463 
SeekStoryboard 464 
SelectedDatesCollection 464 
SelectionMode 464 
SelectionModeSyntax 750 
SelectiveScrollingGrid 464 
SelectiveScrollingOrientation 465 
SelectiveScrollingOrientationSyntax 751 
Selector 465 
Separator 466 
SetStoryboardSpeedRatio 467 
Setter 467 
SetterBase 467 
SetterBaseCollection 468 
ShaderRenderMode 468 
ShaderRenderModeSyntax 751 
Shape 468 
ShutdownMode 469 
ShutdownModeSyntax 751 

SineEase 470 
SingleAnimation 470 
SingleAnimationBase 470 
SingleAnimationUsingKeyFrames 471 
SingleKeyFrame 471 
SingleKeyFrameCollection 472 
Size 472 
Size3D 473 
Size3DSyntax 751 
SizeAnimation 473 
SizeAnimationBase 474 
SizeAnimationUsingKeyFrames 474 
SizeKeyFrame 475 
SizeKeyFrameCollection 475 
SizeSyntax 752 
SizeToContent 475 
SizeToContentSyntax 752 
SkewTransform 476 
SkipStoryboardToFill 476 
Slider 476 
SlipBehavior 478 
SlipBehaviorSyntax 752 
SolidColorBrush 479 
SortDescriptionCollection 647 
SoundPlayerAction 479 
Span 479 
Specification Conventions 29 
SpecularMaterial 480 
SpeechMode 480 
SpeechModeSyntax 752 
SpellCheck 480 
SpellingReform 481 
SpellingReformSyntax 753 
SplineByteKeyFrame 482 
SplineColorKeyFrame 482 
SplineDecimalKeyFrame 482 
SplineDoubleKeyFrame 482 
SplineInt16KeyFrame 483 
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SplineInt32KeyFrame 483 
SplineInt64KeyFrame 483 
SplinePoint3DKeyFrame 484 
SplinePointKeyFrame 484 
SplineQuaternionKeyFrame 484 
SplineRectKeyFrame 484 
SplineRotation3DKeyFrame 485 
SplineSingleKeyFrame 485 
SplineSizeKeyFrame 485 
SplineThicknessKeyFrame 486 
SplineVector3DKeyFrame 486 
SplineVectorKeyFrame 486 
SpotLight 486 
StackPanel 487 
StaticResourceExtension 487 
StatusBar 488 
StatusBarItem 489 
StickyNoteType 489 
StickyNoteTypeSyntax 753 
StopStoryboard 489 
Storyboard 489 
StreamGeometry 490 
Stretch 490 

StretchDirection 490 
StretchDirectionSyntax 753 
StretchSyntax 753 
StringAnimationBase 491 
StringAnimationUsingKeyFrames 491 
StringCollection 647 
StringCollectionSyntax 753 
StringComparison 647 
StringKeyFrame 491 
StringKeyFrameCollection 492 
Stroke 492 
StrokeCollection 493 
StrokeCollectionSyntax 754 
Style 493 
StyleSelector 494 
StyleSimulations 494 
StyleSimulationsSyntax 754 
Stylus 495 
StylusButton 496 
StylusButtonCollection 497 
StylusButtonState 497 
StylusButtonStateSyntax 754 
StylusDeviceCollection 497 
StylusPoint 497 
StylusPointCollection 498 
StylusPointDescription 498 
StylusPointPropertyUnit 498 
StylusPointPropertyUnitSyntax 754 
StylusTip 499 
StylusTipSyntax 755 
SweepDirection 499 
SweepDirectionSyntax 755 
SystemColors 499 
SystemCommands (4.5) 510 
SystemFonts 510 
SystemGesture 515 
SystemGestureSyntax 755 
SystemParameters 515 

T 

TabControl 535 
TabItem 536 
Table 536 
TableCell 537 
TableCellCollection 538 
TableColumn 539 
TableColumnCollection 539 
TableRow 540 
TableRowCollection 540 
TableRowGroup 540 
TableRowGroupCollection 541 
TabletDeviceType 541 
TabletDeviceTypeSyntax 756 
TabletHardwareCapabilities 542 
TabletHardwareCapabilitiesSyntax 756 
TabPanel 542 

TaskbarItemInfo 542 
TaskbarItemProgressState 543 
TaskbarItemProgressStateSyntax 756 
TemplateBindingExtension 543 
TemplateKey 544 
TextAlignment 544 
TextAlignmentSyntax 756 
TextBlock 544 
TextBox 547 
TextBoxBase 549 
TextCollapsingStyle 550 
TextCollapsingStyleSyntax 757 
TextCompositionAutoComplete 550 
TextCompositionAutoCompleteSyntax 757 
TextDataFormat 551 
TextDataFormatSyntax 757 
TextDecoration 551 
TextDecorationCollection 551 
TextDecorationCollectionSyntax 757 
TextDecorationLocation 552 
TextDecorationLocationSyntax 757 
TextDecorations 552 
TextDecorationUnit 552 
TextDecorationUnitSyntax 758 
TextEffect 553 
TextEffectCollection 553 
TextElement 554 
TextElementCollection(T) 555 
TextFormattingMode 555 
TextFormattingModeSyntax 758 
TextHintingMode 556 
TextHintingModeSyntax 758 
TextMarkerStyle 556 
TextMarkerStyleSyntax 758 
TextOptions 556 
TextPointerContext 557 
TextPointerContextSyntax 759 
TextRenderingMode 557 
TextRenderingModeSyntax 759 
TextRunCache 557 
TextSearch 558 
TextTabAlignment 558 
TextTabAlignmentSyntax 759 
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TextTrimming 558 
TextTrimmingSyntax 760 
TextWrapping 558 
TextWrappingSyntax 760 
The WPF Xaml Schema Information Set 36 
ThemeDictionaryExtension 559 
Thickness 559 
ThicknessAnimation 560 
ThicknessAnimationBase 561 
ThicknessAnimationUsingKeyFrames 561 
ThicknessKeyFrame 561 
ThicknessKeyFrameCollection 562 
ThicknessSyntax 760 
Thumb 562 
ThumbButtonInfo 563 
ThumbButtonInfoCollection 564 
TickBar 564 
TickBarPlacement 565 
TickBarPlacementSyntax 760 
TickPlacement 565 
TickPlacementSyntax 761 
TiffBitmapEncoder 566 
TiffCompressOption 566 

TiffCompressOptionSyntax 761 
TileBrush 566 
TileMode 567 
TileModeSyntax 761 
Timeline 568 
TimelineCollection 569 
TimelineGroup 569 
TimeSeekOrigin 570 
TimeSeekOriginSyntax 762 
ToggleButton 570 
ToleranceType 571 
ToleranceTypeSyntax 762 
ToolBar 571 
ToolBarOverflowPanel 572 
ToolBarPanel 573 
ToolBarTray 573 
ToolTip 574 
ToolTipService 575 
TouchAction 577 
TouchActionSyntax 762 
TouchPoint 577 
TouchPointCollection 577 
Track 577 
Transform 578 
Transform3D 579 
Transform3DCollection 579 
Transform3DGroup 579 
TransformCollection 580 
TransformedBitmap 580 
TransformGroup 580 
TransformSyntax 762 
TranslateTransform 581 
TranslateTransform3D 581 
TreeView 582 
TreeViewItem 582 
Trigger 583 
TriggerAction 583 
TriggerActionCollection 584 

TriggerBase 584 
TriggerCollection 584 
Typography 585 

U 

UIElement 594 
UIElement3D 600 
UIElementCollection 605 
UInt16 648 
Underline 606 
UndoAction 606 
UndoActionSyntax 762 
UniformGrid 606 
UpdateSourceTrigger 607 
UpdateSourceTriggerSyntax 763 
UserControl 607 

V 

Validation 607 
ValidationErrorEventAction 608 
ValidationErrorEventActionSyntax 763 
ValidationResult 608 
ValidationRule 609 
ValidationStep 609 
ValidationStepSyntax 763 
ValueSource 609 
Vector 610 
Vector3D 610 
Vector3DAnimation 611 
Vector3DAnimationBase 611 
Vector3DAnimationUsingKeyFrames 612 
Vector3DCollection 612 
Vector3DCollectionSyntax 763 
Vector3DKeyFrame 613 
Vector3DKeyFrameCollection 613 
Vector3DSyntax 763 
VectorAnimation 613 
VectorAnimationBase 614 
VectorAnimationUsingKeyFrames 614 
VectorCollection 615 
VectorCollectionSyntax 764 
VectorKeyFrame 615 
VectorKeyFrameCollection 616 
VectorSyntax 764 
VerticalAlignment 616 
VerticalAlignmentSyntax 764 
VideoDrawing 616 
ViewBase 617 
Viewbox 617 
Viewport2DVisual3D 618 
Viewport3D 618 
Viewport3DVisual 619 
VirtualizationCacheLength (4.5) 620 
VirtualizationCacheLengthSyntax (4.5) 764 
VirtualizationCacheLengthUnit (4.5) 620 
VirtualizationCacheLengthUnitSyntax (4.5) 765 
VirtualizationMode 620 
VirtualizationModeSyntax 765 
VirtualizingPanel 620 

VirtualizingStackPanel 622 
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Visibility 622 
VisibilitySyntax 765 
Visual 623 
Visual3D 623 
Visual3DCollection 623 
VisualBrush 624 
VisualCollection 624 
VisualState 624 
VisualStateGroup 625 
VisualStateManager 626 
VisualTransition 626 
VisualTreeHelper 627 

W 

WebBrowser 627 
Window 628 
WindowChrome (4.5) 630 
WindowCollection 631 

WindowStartupLocation 631 
WindowStartupLocationSyntax 765 
WindowState 632 
WindowStateSyntax 765 
WindowStyle 632 
WindowStyleSyntax 765 
WmpBitmapEncoder 632 
WPF Xaml Text Syntax Information Sets 650 
WPF XamlType Information Items 37 
WPF XamlType Information Items for Assignable 

Types 637 
WrapDirection 634 
WrapDirectionSyntax 766 
WrapPanel 634 
WriteableBitmap 635 

X 

x:Boolean 637 
x:Byte 637 
x:Char 637 
x:DateTime 639 
x:Decimal 639 
x:Double 639 
x:Int16 643 
x:Int32 643 
x:Int64 644 
x:MarkupExtension 645 
x:Nullable(T) 645 
x:Object 645 
x:Single 647 
x:String 647 
x:TimeSpan 648 
x:Uri 648 
x:XamlType 648 
Xaml Members where [is attachable] is True 33 
Xaml Members where [is event] is True 34 
Xaml Members where [is static] is True 34 
Xaml Type Order 31 
Xaml Types 29 
Xaml Types where [is generic] is True 34 
XmlDataProvider 635 

XmlDocument 648 

XmlLanguage 649 
XmlLanguageSyntax 766 
XmlNamespaceManager 649 
XmlNamespaceMapping 636 
XmlNamespaceMappingCollection 636 

Z 

ZoomPercentageConverter 636 


	Table of Contents
	1   Introduction
	2   Specification Conventions
	2.1   Xaml Types
	2.2   Xaml Type Order
	2.3   Xaml Members where [is attachable] is True
	2.4   Xaml Types where [is generic] is True
	2.5   Xaml Members where [is event] is True
	2.6   Xaml Members where [is static] is True
	2.7   Constructors

	3   The WPF Xaml Schema Information Set
	4   WPF XamlType Information Items
	4.1   AccessText
	4.2   AdornedElementPlaceholder
	4.3   AdornerDecorator
	4.4   AffineTransform3D
	4.5   AlignmentX
	4.6   AlignmentY
	4.7   AlternationConverter
	4.8   AmbientLight
	4.9   AnchoredBlock
	4.10   Animatable
	4.11   AnimationTimeline
	4.12   Application
	4.13   ApplicationCommands
	4.14   ApplicationGesture
	4.15   ArcSegment
	4.16   AutomationProperties
	4.17   AutoToolTipPlacement
	4.18   AxisAngleRotation3D
	4.19   BackEase
	4.20   BaselineAlignment
	4.21   BaseValueSource
	4.22   BeginStoryboard
	4.23   BezierSegment
	4.24   Binding
	4.25   BindingBase
	4.26   BindingGroup
	4.27   BindingMode
	4.28   BindingOperations
	4.29   BindingStatus
	4.30   BitmapCache
	4.31   BitmapCacheBrush
	4.32   BitmapCacheOption
	4.33   BitmapCreateOptions
	4.34   BitmapEncoder
	4.35   BitmapFrame
	4.36   BitmapImage
	4.37   BitmapScalingMode
	4.38   BitmapSource
	4.39   Block
	4.40   BlockCollection
	4.41   BlockUIContainer
	4.42   BlurEffect
	4.43   BmpBitmapEncoder
	4.44   Bold
	4.45   BooleanAnimationBase
	4.46   BooleanAnimationUsingKeyFrames
	4.47   BooleanKeyFrame
	4.48   BooleanKeyFrameCollection
	4.49   BooleanToVisibilityConverter
	4.50   Border
	4.51   BorderGapMaskConverter
	4.52   BounceEase
	4.53   Brush
	4.54   Brushes
	4.55   BrushMappingMode
	4.56   BulletDecorator
	4.57   Button
	4.58   ButtonBase
	4.59   ByteAnimation
	4.60   ByteAnimationBase
	4.61   ByteAnimationUsingKeyFrames
	4.62   ByteKeyFrame
	4.63   ByteKeyFrameCollection
	4.64   CachedBitmap
	4.65   CacheMode
	4.66   CachingHint
	4.67   Calendar
	4.68   CalendarBlackoutDatesCollection
	4.69   CalendarButton
	4.70   CalendarDateRange
	4.71   CalendarDayButton
	4.72   CalendarItem
	4.73   CalendarMode
	4.74   CalendarSelectionMode
	4.75   Camera
	4.76   Canvas
	4.77   CaptureMode
	4.78   CharacterBufferRange
	4.79   CharacterBufferReference
	4.80   CharacterCasing
	4.81   CharacterHit
	4.82   CharacterMetrics
	4.83   CharacterMetricsDictionary
	4.84   CharAnimationBase
	4.85   CharAnimationUsingKeyFrames
	4.86   CharKeyFrame
	4.87   CharKeyFrameCollection
	4.88   CheckBox
	4.89   CircleEase
	4.90   ClearTypeHint
	4.91   ClickMode
	4.92   Clock
	4.93   ClockCollection
	4.94   ClockState
	4.95   CollectionContainer
	4.96   CollectionView
	4.97   CollectionViewSource
	4.98   Color
	4.99   ColorAnimation
	4.100   ColorAnimationBase
	4.101   ColorAnimationUsingKeyFrames
	4.102   ColorContext
	4.103   ColorConvertedBitmap
	4.104   ColorConvertedBitmapExtension
	4.105   ColorInterpolationMode
	4.106   ColorKeyFrame
	4.107   ColorKeyFrameCollection
	4.108   Colors
	4.109   ColumnDefinition
	4.110   ColumnDefinitionCollection
	4.111   ColumnSpaceDistribution
	4.112   CombinedGeometry
	4.113   ComboBox
	4.114   ComboBoxItem
	4.115   CommandBinding
	4.116   CommandBindingCollection
	4.117   ComponentCommands
	4.118   ComponentResourceKey
	4.119   CompositeCollection
	4.120   Condition
	4.121   ConditionCollection
	4.122   ContainerUIElement3D
	4.123   ContainerVisual
	4.124   ContentControl
	4.125   ContentElement
	4.126   ContentOperations
	4.127   ContentPresenter
	4.128   ContextMenu
	4.129   ContextMenuService
	4.130   Control
	4.131   ControllableStoryboardAction
	4.132   ControlTemplate
	4.133   CoreCompatibilityPreferences
	4.134   CornerRadius
	4.135   CroppedBitmap
	4.136   CubicEase
	4.137   Cursor
	4.138   Cursors
	4.139   CursorType
	4.140   CustomPopupPlacement
	4.141   DashStyle
	4.142   DashStyles
	4.143   DataErrorValidationRule
	4.144   DataGrid
	4.145   DataGridBoundColumn
	4.146   DataGridCell
	4.147   DataGridCellInfo
	4.148   DataGridCellsPanel
	4.149   DataGridCellsPresenter
	4.150   DataGridCheckBoxColumn
	4.151   DataGridClipboardCellContent
	4.152   DataGridClipboardCopyMode
	4.153   DataGridColumn
	4.154   DataGridColumnHeader
	4.155   DataGridColumnHeadersPresenter
	4.156   DataGridComboBoxColumn
	4.157   DataGridDetailsPresenter
	4.158   DataGridEditAction
	4.159   DataGridEditingUnit
	4.160   DataGridGridLinesVisibility
	4.161   DataGridHeadersVisibility
	4.162   DataGridHyperlinkColumn
	4.163   DataGridLength
	4.164   DataGridLengthUnitType
	4.165   DataGridRow
	4.166   DataGridRowDetailsVisibilityMode
	4.167   DataGridRowHeader
	4.168   DataGridRowsPresenter
	4.169   DataGridSelectionMode
	4.170   DataGridSelectionUnit
	4.171   DataGridTemplateColumn
	4.172   DataGridTextColumn
	4.173   DataObject
	4.174   DataTemplate
	4.175   DataTemplateKey
	4.176   DataTemplateSelector
	4.177   DataTrigger
	4.178   DatePicker
	4.179   DatePickerFormat
	4.180   DatePickerTextBox
	4.181   DecimalAnimation
	4.182   DecimalAnimationBase
	4.183   DecimalAnimationUsingKeyFrames
	4.184   DecimalKeyFrame
	4.185   DecimalKeyFrameCollection
	4.186   Decorator
	4.187   DeferrableContent
	4.188   DefinitionBase
	4.189   DependencyObject
	4.190   DependencyProperty
	4.191   DiffuseMaterial
	4.192   DirectionalLight
	4.193   DiscreteBooleanKeyFrame
	4.194   DiscreteByteKeyFrame
	4.195   DiscreteCharKeyFrame
	4.196   DiscreteColorKeyFrame
	4.197   DiscreteDecimalKeyFrame
	4.198   DiscreteDoubleKeyFrame
	4.199   DiscreteInt16KeyFrame
	4.200   DiscreteInt32KeyFrame
	4.201   DiscreteInt64KeyFrame
	4.202   DiscreteMatrixKeyFrame
	4.203   DiscreteObjectKeyFrame
	4.204   DiscretePoint3DKeyFrame
	4.205   DiscretePointKeyFrame
	4.206   DiscreteQuaternionKeyFrame
	4.207   DiscreteRectKeyFrame
	4.208   DiscreteRotation3DKeyFrame
	4.209   DiscreteSingleKeyFrame
	4.210   DiscreteSizeKeyFrame
	4.211   DiscreteStringKeyFrame
	4.212   DiscreteThicknessKeyFrame
	4.213   DiscreteVector3DKeyFrame
	4.214   DiscreteVectorKeyFrame
	4.215   Dock
	4.216   DockPanel
	4.217   DocumentPageView
	4.218   DocumentReference
	4.219   DocumentReferenceCollection
	4.220   DocumentViewer
	4.221   DocumentViewerBase
	4.222   DoubleAnimation
	4.223   DoubleAnimationBase
	4.224   DoubleAnimationUsingKeyFrames
	4.225   DoubleAnimationUsingPath
	4.226   DoubleCollection
	4.227   DoubleKeyFrame
	4.228   DoubleKeyFrameCollection
	4.229   DragAction
	4.230   DragDropEffects
	4.231   DragDropKeyStates
	4.232   Drawing
	4.233   DrawingAttributes
	4.234   DrawingBrush
	4.235   DrawingCollection
	4.236   DrawingGroup
	4.237   DrawingImage
	4.238   DrawingVisual
	4.239   DropShadowEffect
	4.240   Duration
	4.241   DynamicResourceExtension
	4.242   EasingByteKeyFrame
	4.243   EasingColorKeyFrame
	4.244   EasingDecimalKeyFrame
	4.245   EasingDoubleKeyFrame
	4.246   EasingFunctionBase
	4.247   EasingInt16KeyFrame
	4.248   EasingInt32KeyFrame
	4.249   EasingInt64KeyFrame
	4.250   EasingMode
	4.251   EasingPoint3DKeyFrame
	4.252   EasingPointKeyFrame
	4.253   EasingQuaternionKeyFrame
	4.254   EasingRectKeyFrame
	4.255   EasingRotation3DKeyFrame
	4.256   EasingSingleKeyFrame
	4.257   EasingSizeKeyFrame
	4.258   EasingThicknessKeyFrame
	4.259   EasingVector3DKeyFrame
	4.260   EasingVectorKeyFrame
	4.261   EdgeMode
	4.262   EdgeProfile
	4.263   EditingCommands
	4.264   Effect
	4.265   ElasticEase
	4.266   Ellipse
	4.267   EllipseGeometry
	4.268   EmissiveMaterial
	4.269   EventPrivateKey
	4.270   EventSetter
	4.271   EventTrigger
	4.272   ExceptionValidationRule
	4.273   ExpandDirection
	4.274   Expander
	4.275   ExponentialEase
	4.276   FamilyTypeface
	4.277   FamilyTypefaceCollection
	4.278   Figure
	4.279   FigureHorizontalAnchor
	4.280   FigureLength
	4.281   FigureUnitType
	4.282   FigureVerticalAnchor
	4.283   FillBehavior
	4.284   FillRule
	4.285   FixedDocument
	4.286   FixedDocumentSequence
	4.287   FixedPage
	4.288   Floater
	4.289   FlowDirection
	4.290   FlowDocument
	4.291   FlowDocumentPageViewer
	4.292   FlowDocumentReader
	4.293   FlowDocumentReaderViewingMode
	4.294   FlowDocumentScrollViewer
	4.295   FocusManager
	4.296   FocusNavigationDirection
	4.297   FontCapitals
	4.298   FontEastAsianLanguage
	4.299   FontEastAsianWidths
	4.300   FontEmbeddingManager
	4.301   FontEmbeddingRight
	4.302   FontFamily
	4.303   FontFamilyMap
	4.304   FontFamilyMapCollection
	4.305   FontFraction
	4.306   FontNumeralAlignment
	4.307   FontNumeralStyle
	4.308   Fonts
	4.309   FontStretch
	4.310   FontStretches
	4.311   FontStyle
	4.312   FontStyles
	4.313   FontVariants
	4.314   FontWeight
	4.315   FontWeights
	4.316   FormatConvertedBitmap
	4.317   Frame
	4.318   FrameworkCompatibilityPreferences
	4.319   FrameworkContentElement
	4.320   FrameworkElement
	4.321   FrameworkPropertyMetadataOptions
	4.322   FrameworkTemplate
	4.323   Freezable
	4.324   GeneralTransform
	4.325   GeneralTransform3D
	4.326   GeneralTransform3DCollection
	4.327   GeneralTransform3DGroup
	4.328   GeneralTransformCollection
	4.329   GeneralTransformGroup
	4.330   GeneratorDirection
	4.331   GeneratorPosition
	4.332   GeneratorStatus
	4.333   Geometry
	4.334   Geometry3D
	4.335   GeometryCollection
	4.336   GeometryCombineMode
	4.337   GeometryDrawing
	4.338   GeometryGroup
	4.339   GeometryModel3D
	4.340   GestureRecognizer
	4.341   GifBitmapEncoder
	4.342   GlyphRun
	4.343   GlyphRunDrawing
	4.344   Glyphs
	4.345   GlyphTypeface
	4.346   GradientBrush
	4.347   GradientSpreadMethod
	4.348   GradientStop
	4.349   GradientStopCollection
	4.350   Grid
	4.351   GridLength
	4.352   GridResizeBehavior
	4.353   GridResizeDirection
	4.354   GridSplitter
	4.355   GridUnitType
	4.356   GridView
	4.357   GridViewColumn
	4.358   GridViewColumnCollection
	4.359   GridViewColumnHeader
	4.360   GridViewColumnHeaderRole
	4.361   GridViewHeaderRowPresenter
	4.362   GridViewRowPresenter
	4.363   GridViewRowPresenterBase
	4.364   GroupBox
	4.365   GroupItem
	4.366   GroupStyle
	4.367   GuidelineSet
	4.368   HandoffBehavior
	4.369   HeaderedContentControl
	4.370   HeaderedItemsControl
	4.371   HierarchicalDataTemplate
	4.372   HierarchicalVirtualizationConstraints (4.5)
	4.373   HierarchicalVirtualizationHeaderDesiredSizes (4.5)
	4.374   HierarchicalVirtualizationItemDesiredSizes (4.5)
	4.375   HitTestFilterBehavior
	4.376   HitTestResultBehavior
	4.377   HorizontalAlignment
	4.378   HostVisual
	4.379   Hyperlink
	4.380   IAnimatable
	4.381   ICommandSource
	4.382   IContainItemStorage
	4.383   IContentHost
	4.384   IDataObject
	4.385   IEasingFunction
	4.386   IFrameworkInputElement
	4.387   IHierarchicalVirtualizationAndScrollInfo (4.5)
	4.388   IInputElement
	4.389   IKeyFrame
	4.390   IKeyFrameAnimation
	4.391   Image
	4.392   ImageBrush
	4.393   ImageDrawing
	4.394   ImageSource
	4.395   ImeConversionModeValues
	4.396   ImeSentenceModeValues
	4.397   IMultiValueConverter
	4.398   InertiaExpansionBehavior
	4.399   InertiaRotationBehavior
	4.400   InertiaTranslationBehavior
	4.401   InheritanceBehavior
	4.402   InkCanvas
	4.403   InkCanvasClipboardFormat
	4.404   InkCanvasEditingMode
	4.405   InkCanvasSelectionHitResult
	4.406   InkPresenter
	4.407   Inline
	4.408   InlineCollection
	4.409   InlineUIContainer
	4.410   InputBinding
	4.411   InputBindingCollection
	4.412   InputGesture
	4.413   InputGestureCollection
	4.414   InputLanguageManager
	4.415   InputManager
	4.416   InputMethod
	4.417   InputMethodState
	4.418   InputMode
	4.419   InputScope
	4.420   InputScopeName
	4.421   InputScopeNameValue
	4.422   InputScopePhrase
	4.423   InputType
	4.424   Int16Animation
	4.425   Int16AnimationBase
	4.426   Int16AnimationUsingKeyFrames
	4.427   Int16KeyFrame
	4.428   Int16KeyFrameCollection
	4.429   Int32Animation
	4.430   Int32AnimationBase
	4.431   Int32AnimationUsingKeyFrames
	4.432   Int32Collection
	4.433   Int32KeyFrame
	4.434   Int32KeyFrameCollection
	4.435   Int32Rect
	4.436   Int64Animation
	4.437   Int64AnimationBase
	4.438   Int64AnimationUsingKeyFrames
	4.439   Int64KeyFrame
	4.440   Int64KeyFrameCollection
	4.441   IntersectionDetail
	4.442   InvertAxes
	4.443   IScrollInfo
	4.444   IsOffscreenBehavior
	4.445   Italic
	4.446   ItemCollection
	4.447   ItemContainerTemplate (4.5)
	4.448   ItemContainerTemplateKey (4.5)
	4.449   ItemsControl
	4.450   ItemsPanelTemplate
	4.451   ItemsPresenter
	4.452   IValueConverter
	4.453   IWeakEventListener
	4.454   JournalEntry
	4.455   JournalEntryListConverter
	4.456   JournalEntryPosition
	4.457   JournalEntryUnifiedViewConverter
	4.458   JournalOwnership
	4.459   JpegBitmapEncoder
	4.460   JumpItem
	4.461   JumpItemRejectionReason
	4.462   JumpList
	4.463   JumpPath
	4.464   JumpTask
	4.465   KernelType
	4.466   Key
	4.467   KeyBinding
	4.468   Keyboard
	4.469   KeyboardNavigation
	4.470   KeyboardNavigationMode
	4.471   KeyGesture
	4.472   KeySpline
	4.473   KeyStates
	4.474   KeyTime
	4.475   KeyTimeType
	4.476   KeyTipControl (4.5)
	4.477   KeyTipHorizontalPlacement (4.5)
	4.478   KeyTipService (4.5)
	4.479   KeyTipVerticalPlacement (4.5)
	4.480   Label
	4.481   LanguageSpecificStringDictionary
	4.482   Light
	4.483   Line
	4.484   LinearByteKeyFrame
	4.485   LinearColorKeyFrame
	4.486   LinearDecimalKeyFrame
	4.487   LinearDoubleKeyFrame
	4.488   LinearGradientBrush
	4.489   LinearInt16KeyFrame
	4.490   LinearInt32KeyFrame
	4.491   LinearInt64KeyFrame
	4.492   LinearPoint3DKeyFrame
	4.493   LinearPointKeyFrame
	4.494   LinearQuaternionKeyFrame
	4.495   LinearRectKeyFrame
	4.496   LinearRotation3DKeyFrame
	4.497   LinearSingleKeyFrame
	4.498   LinearSizeKeyFrame
	4.499   LinearThicknessKeyFrame
	4.500   LinearVector3DKeyFrame
	4.501   LinearVectorKeyFrame
	4.502   LineBreak
	4.503   LineBreakCondition
	4.504   LineGeometry
	4.505   LineSegment
	4.506   LineStackingStrategy
	4.507   LinkTarget
	4.508   LinkTargetCollection
	4.509   List
	4.510   ListBox
	4.511   ListBoxItem
	4.512   ListItem
	4.513   ListItemCollection
	4.514   ListView
	4.515   ListViewItem
	4.516   Localization
	4.517   LocalizationCategory
	4.518   LocalValueEntry
	4.519   LocalValueEnumerator
	4.520   LogicalDirection
	4.521   Manipulation
	4.522   ManipulationModes
	4.523   ManipulationPivot
	4.524   Material
	4.525   MaterialCollection
	4.526   MaterialGroup
	4.527   Matrix
	4.528   Matrix3D
	4.529   MatrixAnimationBase
	4.530   MatrixAnimationUsingKeyFrames
	4.531   MatrixAnimationUsingPath
	4.532   MatrixCamera
	4.533   MatrixKeyFrame
	4.534   MatrixKeyFrameCollection
	4.535   MatrixTransform
	4.536   MatrixTransform3D
	4.537   MediaCommands
	4.538   MediaElement
	4.539   MediaPlayer
	4.540   MediaState
	4.541   MediaTimeline
	4.542   Menu
	4.543   MenuBase
	4.544   MenuItem
	4.545   MenuItemRole
	4.546   MenuScrollingVisibilityConverter
	4.547   MeshGeometry3D
	4.548   MessageBoxButton
	4.549   MessageBoxImage
	4.550   MessageBoxOptions
	4.551   MessageBoxResult
	4.552   MinMaxParagraphWidth
	4.553   Model3D
	4.554   Model3DCollection
	4.555   Model3DGroup
	4.556   ModelUIElement3D
	4.557   ModelVisual3D
	4.558   Modifiability
	4.559   ModifierKeys
	4.560   Mouse
	4.561   MouseAction
	4.562   MouseBinding
	4.563   MouseButton
	4.564   MouseButtonState
	4.565   MouseGesture
	4.566   MultiBinding
	4.567   MultiDataTrigger
	4.568   MultiSelector
	4.569   MultiTrigger
	4.570   NavigationCommands
	4.571   NavigationMode
	4.572   NavigationUIVisibility
	4.573   NavigationWindow
	4.574   NonClientFrameEdges (4.5)
	4.575   NotifyDataErrorValidationRule (4.5)
	4.576   NumberCultureSource
	4.577   NumberSubstitution
	4.578   NumberSubstitutionMethod
	4.579   ObjectAnimationBase
	4.580   ObjectAnimationUsingKeyFrames
	4.581   ObjectDataProvider
	4.582   ObjectKeyFrame
	4.583   ObjectKeyFrameCollection
	4.584   Orientation
	4.585   OrthographicCamera
	4.586   OverflowMode
	4.587   Page
	4.588   PageContent
	4.589   PageContentCollection
	4.590   PageRange
	4.591   PageRangeSelection
	4.592   Panel
	4.593   PanningMode
	4.594   Paragraph
	4.595   ParallelTimeline
	4.596   PasswordBox
	4.597   Path
	4.598   PathAnimationSource
	4.599   PathFigure
	4.600   PathFigureCollection
	4.601   PathGeometry
	4.602   PathSegment
	4.603   PathSegmentCollection
	4.604   PauseStoryboard
	4.605   Pen
	4.606   PenLineCap
	4.607   PenLineJoin
	4.608   PerspectiveCamera
	4.609   PixelFormat
	4.610   PixelFormatChannelMask
	4.611   PixelFormats
	4.612   PixelShader
	4.613   PlacementMode
	4.614   PngBitmapEncoder
	4.615   PngInterlaceOption
	4.616   Point
	4.617   Point3D
	4.618   Point3DAnimation
	4.619   Point3DAnimationBase
	4.620   Point3DAnimationUsingKeyFrames
	4.621   Point3DCollection
	4.622   Point3DKeyFrame
	4.623   Point3DKeyFrameCollection
	4.624   Point4D
	4.625   PointAnimation
	4.626   PointAnimationBase
	4.627   PointAnimationUsingKeyFrames
	4.628   PointAnimationUsingPath
	4.629   PointCollection
	4.630   PointKeyFrame
	4.631   PointKeyFrameCollection
	4.632   PointLight
	4.633   PointLightBase
	4.634   PolyBezierSegment
	4.635   Polygon
	4.636   Polyline
	4.637   PolyLineSegment
	4.638   PolyQuadraticBezierSegment
	4.639   Popup
	4.640   PopupAnimation
	4.641   PopupPrimaryAxis
	4.642   PowerEase
	4.643   PowerLineStatus
	4.644   PresentationTraceLevel
	4.645   PresentationTraceSources
	4.646   PriorityBinding
	4.647   ProgressBar
	4.648   ProjectionCamera
	4.649   PropertyGroupDescription
	4.650   PropertyPath
	4.651   QuadraticBezierSegment
	4.652   QuadraticEase
	4.653   QuarticEase
	4.654   Quaternion
	4.655   QuaternionAnimation
	4.656   QuaternionAnimationBase
	4.657   QuaternionAnimationUsingKeyFrames
	4.658   QuaternionKeyFrame
	4.659   QuaternionKeyFrameCollection
	4.660   QuaternionRotation3D
	4.661   QuinticEase
	4.662   RadialGradientBrush
	4.663   RadioButton
	4.664   RangeBase
	4.665   Readability
	4.666   ReasonSessionEnding
	4.667   RecognitionConfidence
	4.668   Rect
	4.669   Rect3D
	4.670   Rectangle
	4.671   RectangleGeometry
	4.672   RectAnimation
	4.673   RectAnimationBase
	4.674   RectAnimationUsingKeyFrames
	4.675   RectKeyFrame
	4.676   RectKeyFrameCollection
	4.677   RelativeSource
	4.678   RelativeSourceMode
	4.679   RemoveStoryboard
	4.680   RenderCapability
	4.681   RenderingBias
	4.682   RenderOptions
	4.683   RenderTargetBitmap
	4.684   RepeatBehavior
	4.685   RepeatButton
	4.686   ResizeGrip
	4.687   ResizeGripDirection (4.5)
	4.688   ResizeMode
	4.689   ResourceDictionary
	4.690   ResourceDictionaryLocation
	4.691   ResourceKey
	4.692   RestoreFocusMode
	4.693   ResumeStoryboard
	4.694   Ribbon (4.5)
	4.695   RibbonApplicationMenu (4.5)
	4.696   RibbonApplicationMenuItem (4.5)
	4.697   RibbonApplicationMenuItemLevel (4.5)
	4.698   RibbonApplicationSplitMenuItem (4.5)
	4.699   RibbonButton (4.5)
	4.700   RibbonCheckBox (4.5)
	4.701   RibbonComboBox (4.5)
	4.702   RibbonCommands (4.5)
	4.703   RibbonContentPresenter (4.5)
	4.704   RibbonContextMenu (4.5)
	4.705   RibbonContextualTabGroup (4.5)
	4.706   RibbonContextualTabGroupItemsControl (4.5)
	4.707   RibbonControl (4.5)
	4.708   RibbonControlGroup (4.5)
	4.709   RibbonControlLength (4.5)
	4.710   RibbonControlLengthUnitType (4.5)
	4.711   RibbonControlService (4.5)
	4.712   RibbonControlSizeDefinition (4.5)
	4.713   RibbonControlSizeDefinitionCollection (4.5)
	4.714   RibbonDismissPopupMode (4.5)
	4.715   RibbonFilterMenuButton (4.5)
	4.716   RibbonGallery (4.5)
	4.717   RibbonGalleryCategory (4.5)
	4.718   RibbonGalleryItem (4.5)
	4.719   RibbonGroup (4.5)
	4.720   RibbonGroupSizeDefinition (4.5)
	4.721   RibbonGroupSizeDefinitionBase (4.5)
	4.722   RibbonGroupSizeDefinitionBaseCollection (4.5)
	4.723   RibbonGroupTemplateSizeDefinition (4.5)
	4.724   RibbonImageSize (4.5)
	4.725   RibbonMenuButton (4.5)
	4.726   RibbonMenuItem (4.5)
	4.727   RibbonQuickAccessToolBar (4.5)
	4.728   RibbonRadioButton (4.5)
	4.729   RibbonSeparator (4.5)
	4.730   RibbonSplitButton (4.5)
	4.731   RibbonSplitButtonLabelPosition (4.5)
	4.732   RibbonSplitMenuItem (4.5)
	4.733   RibbonTab (4.5)
	4.734   RibbonTabHeader (4.5)
	4.735   RibbonTabHeaderItemsControl (4.5)
	4.736   RibbonTextBox (4.5)
	4.737   RibbonToggleButton (4.5)
	4.738   RibbonToolTip (4.5)
	4.739   RibbonTwoLineText (4.5)
	4.740   RibbonWindow (4.5)
	4.741   RichTextBox
	4.742   RotateTransform
	4.743   RotateTransform3D
	4.744   Rotation
	4.745   Rotation3D
	4.746   Rotation3DAnimation
	4.747   Rotation3DAnimationBase
	4.748   Rotation3DAnimationUsingKeyFrames
	4.749   Rotation3DKeyFrame
	4.750   Rotation3DKeyFrameCollection
	4.751   RoutedCommand
	4.752   RoutedEvent
	4.753   RoutedEventHandlerInfo
	4.754   RoutedUICommand
	4.755   RoutingStrategy
	4.756   RowDefinition
	4.757   RowDefinitionCollection
	4.758   Run
	4.759   SamplingMode
	4.760   ScaleTransform
	4.761   ScaleTransform3D
	4.762   ScrollBar
	4.763   ScrollBarVisibility
	4.764   ScrollContentPresenter
	4.765   ScrollEventType
	4.766   ScrollUnit (4.5)
	4.767   ScrollViewer
	4.768   Section
	4.769   SeekStoryboard
	4.770   SelectedDatesCollection
	4.771   SelectionMode
	4.772   SelectiveScrollingGrid
	4.773   SelectiveScrollingOrientation
	4.774   Selector
	4.775   Separator
	4.776   SetStoryboardSpeedRatio
	4.777   Setter
	4.778   SetterBase
	4.779   SetterBaseCollection
	4.780   ShaderRenderMode
	4.781   Shape
	4.782   ShutdownMode
	4.783   SineEase
	4.784   SingleAnimation
	4.785   SingleAnimationBase
	4.786   SingleAnimationUsingKeyFrames
	4.787   SingleKeyFrame
	4.788   SingleKeyFrameCollection
	4.789   Size
	4.790   Size3D
	4.791   SizeAnimation
	4.792   SizeAnimationBase
	4.793   SizeAnimationUsingKeyFrames
	4.794   SizeKeyFrame
	4.795   SizeKeyFrameCollection
	4.796   SizeToContent
	4.797   SkewTransform
	4.798   SkipStoryboardToFill
	4.799   Slider
	4.800   SlipBehavior
	4.801   SolidColorBrush
	4.802   SoundPlayerAction
	4.803   Span
	4.804   SpecularMaterial
	4.805   SpeechMode
	4.806   SpellCheck
	4.807   SpellingReform
	4.808   SplineByteKeyFrame
	4.809   SplineColorKeyFrame
	4.810   SplineDecimalKeyFrame
	4.811   SplineDoubleKeyFrame
	4.812   SplineInt16KeyFrame
	4.813   SplineInt32KeyFrame
	4.814   SplineInt64KeyFrame
	4.815   SplinePoint3DKeyFrame
	4.816   SplinePointKeyFrame
	4.817   SplineQuaternionKeyFrame
	4.818   SplineRectKeyFrame
	4.819   SplineRotation3DKeyFrame
	4.820   SplineSingleKeyFrame
	4.821   SplineSizeKeyFrame
	4.822   SplineThicknessKeyFrame
	4.823   SplineVector3DKeyFrame
	4.824   SplineVectorKeyFrame
	4.825   SpotLight
	4.826   StackPanel
	4.827   StaticResourceExtension
	4.828   StatusBar
	4.829   StatusBarItem
	4.830   StickyNoteType
	4.831   StopStoryboard
	4.832   Storyboard
	4.833   StreamGeometry
	4.834   Stretch
	4.835   StretchDirection
	4.836   StringAnimationBase
	4.837   StringAnimationUsingKeyFrames
	4.838   StringKeyFrame
	4.839   StringKeyFrameCollection
	4.840   Stroke
	4.841   StrokeCollection
	4.842   Style
	4.843   StyleSelector
	4.844   StyleSimulations
	4.845   Stylus
	4.846   StylusButton
	4.847   StylusButtonCollection
	4.848   StylusButtonState
	4.849   StylusDeviceCollection
	4.850   StylusPoint
	4.851   StylusPointCollection
	4.852   StylusPointDescription
	4.853   StylusPointPropertyUnit
	4.854   StylusTip
	4.855   SweepDirection
	4.856   SystemColors
	4.857   SystemCommands (4.5)
	4.858   SystemFonts
	4.859   SystemGesture
	4.860   SystemParameters
	4.861   TabControl
	4.862   TabItem
	4.863   Table
	4.864   TableCell
	4.865   TableCellCollection
	4.866   TableColumn
	4.867   TableColumnCollection
	4.868   TableRow
	4.869   TableRowCollection
	4.870   TableRowGroup
	4.871   TableRowGroupCollection
	4.872   TabletDeviceType
	4.873   TabletHardwareCapabilities
	4.874   TabPanel
	4.875   TaskbarItemInfo
	4.876   TaskbarItemProgressState
	4.877   TemplateBindingExtension
	4.878   TemplateKey
	4.879   TextAlignment
	4.880   TextBlock
	4.881   TextBox
	4.882   TextBoxBase
	4.883   TextCollapsingStyle
	4.884   TextCompositionAutoComplete
	4.885   TextDataFormat
	4.886   TextDecoration
	4.887   TextDecorationCollection
	4.888   TextDecorationLocation
	4.889   TextDecorations
	4.890   TextDecorationUnit
	4.891   TextEffect
	4.892   TextEffectCollection
	4.893   TextElement
	4.894   TextElementCollection(T)
	4.895   TextFormattingMode
	4.896   TextHintingMode
	4.897   TextMarkerStyle
	4.898   TextOptions
	4.899   TextPointerContext
	4.900   TextRenderingMode
	4.901   TextRunCache
	4.902   TextSearch
	4.903   TextTabAlignment
	4.904   TextTrimming
	4.905   TextWrapping
	4.906   ThemeDictionaryExtension
	4.907   Thickness
	4.908   ThicknessAnimation
	4.909   ThicknessAnimationBase
	4.910   ThicknessAnimationUsingKeyFrames
	4.911   ThicknessKeyFrame
	4.912   ThicknessKeyFrameCollection
	4.913   Thumb
	4.914   ThumbButtonInfo
	4.915   ThumbButtonInfoCollection
	4.916   TickBar
	4.917   TickBarPlacement
	4.918   TickPlacement
	4.919   TiffBitmapEncoder
	4.920   TiffCompressOption
	4.921   TileBrush
	4.922   TileMode
	4.923   Timeline
	4.924   TimelineCollection
	4.925   TimelineGroup
	4.926   TimeSeekOrigin
	4.927   ToggleButton
	4.928   ToleranceType
	4.929   ToolBar
	4.930   ToolBarOverflowPanel
	4.931   ToolBarPanel
	4.932   ToolBarTray
	4.933   ToolTip
	4.934   ToolTipService
	4.935   TouchAction
	4.936   TouchPoint
	4.937   TouchPointCollection
	4.938   Track
	4.939   Transform
	4.940   Transform3D
	4.941   Transform3DCollection
	4.942   Transform3DGroup
	4.943   TransformCollection
	4.944   TransformedBitmap
	4.945   TransformGroup
	4.946   TranslateTransform
	4.947   TranslateTransform3D
	4.948   TreeView
	4.949   TreeViewItem
	4.950   Trigger
	4.951   TriggerAction
	4.952   TriggerActionCollection
	4.953   TriggerBase
	4.954   TriggerCollection
	4.955   Typography
	4.956   UIElement
	4.957   UIElement3D
	4.958   UIElementCollection
	4.959   Underline
	4.960   UndoAction
	4.961   UniformGrid
	4.962   UpdateSourceTrigger
	4.963   UserControl
	4.964   Validation
	4.965   ValidationErrorEventAction
	4.966   ValidationResult
	4.967   ValidationRule
	4.968   ValidationStep
	4.969   ValueSource
	4.970   Vector
	4.971   Vector3D
	4.972   Vector3DAnimation
	4.973   Vector3DAnimationBase
	4.974   Vector3DAnimationUsingKeyFrames
	4.975   Vector3DCollection
	4.976   Vector3DKeyFrame
	4.977   Vector3DKeyFrameCollection
	4.978   VectorAnimation
	4.979   VectorAnimationBase
	4.980   VectorAnimationUsingKeyFrames
	4.981   VectorCollection
	4.982   VectorKeyFrame
	4.983   VectorKeyFrameCollection
	4.984   VerticalAlignment
	4.985   VideoDrawing
	4.986   ViewBase
	4.987   Viewbox
	4.988   Viewport2DVisual3D
	4.989   Viewport3D
	4.990   Viewport3DVisual
	4.991   VirtualizationCacheLength (4.5)
	4.992   VirtualizationCacheLengthUnit (4.5)
	4.993   VirtualizationMode
	4.994   VirtualizingPanel
	4.995   VirtualizingStackPanel
	4.996   Visibility
	4.997   Visual
	4.998   Visual3D
	4.999   Visual3DCollection
	4.1000   VisualBrush
	4.1001   VisualCollection
	4.1002   VisualState
	4.1003   VisualStateGroup
	4.1004   VisualStateManager
	4.1005   VisualTransition
	4.1006   VisualTreeHelper
	4.1007   WebBrowser
	4.1008   Window
	4.1009   WindowChrome (4.5)
	4.1010   WindowCollection
	4.1011   WindowStartupLocation
	4.1012   WindowState
	4.1013   WindowStyle
	4.1014   WmpBitmapEncoder
	4.1015   WrapDirection
	4.1016   WrapPanel
	4.1017   WriteableBitmap
	4.1018   XmlDataProvider
	4.1019   XmlNamespaceMapping
	4.1020   XmlNamespaceMappingCollection
	4.1021   ZoomPercentageConverter

	5   WPF XamlType Information Items for Assignable Types
	5.1   ActiveXHost
	5.2   x:Boolean
	5.3   x:Byte
	5.4   x:Char
	5.5   Collection(T)
	5.6   CollectionBase
	5.7   CultureInfo
	5.8   DataSourceProvider
	5.9   x:DateTime
	5.10   DayOfWeek
	5.11   x:Decimal
	5.12   Delegate
	5.13   x:Double
	5.14   FreezableCollection(T)
	5.15   GroupDescription
	5.16   ICollection(T)
	5.17   ICommand (4.5)
	5.18   IDictionary
	5.19   IDictionary(T,U)
	5.20   IDocumentPaginatorSource
	5.21   IEnumerable
	5.22   IList
	5.23   IList(T)
	5.24   x:Int16
	5.25   x:Int32
	5.26   x:Int64
	5.27   IntPtr
	5.28   IXmlSerializable
	5.29   List(T)
	5.30   ManipulationParameters2D (4.5)
	5.31   x:MarkupExtension
	5.32   x:Nullable(T)
	5.33   x:Object
	5.34   ObservableCollection(T)
	5.35   Predicate(T)
	5.36   ReadOnlyCollection(T)
	5.37   RequestCachePolicy
	5.38   x:Single
	5.39   SortDescriptionCollection
	5.40   x:String
	5.41   StringCollection
	5.42   StringComparison
	5.43   x:TimeSpan
	5.44   x:XamlType
	5.45   UInt16
	5.46   x:Uri
	5.47   XmlDocument
	5.48   XmlLanguage
	5.49   XmlNamespaceManager

	6   WPF Xaml Text Syntax Information Sets
	6.1   AlignmentXSyntax
	6.2   AlignmentYSyntax
	6.3   ApplicationGestureSyntax
	6.4   AutoToolTipPlacementSyntax
	6.5   BaselineAlignmentSyntax
	6.6   BaseValueSourceSyntax
	6.7   BindingModeSyntax
	6.8   BindingStatusSyntax
	6.9   BitmapCacheOptionSyntax
	6.10   BitmapCreateOptionsSyntax
	6.11   BitmapScalingModeSyntax
	6.12   BrushMappingModeSyntax
	6.13   BrushSyntax
	6.14   CacheModeSyntax
	6.15   CachingHintSyntax
	6.16   CalendarModeSyntax
	6.17   CalendarSelectionModeSyntax
	6.18   CaptureModeSyntax
	6.19   CharacterCasingSyntax
	6.20   ClearTypeHintSyntax
	6.21   ClickModeSyntax
	6.22   ClockStateSyntax
	6.23   ColorInterpolationModeSyntax
	6.24   ColorSyntax
	6.25   ColumnSpaceDistributionSyntax
	6.26   CommandSyntax
	6.27   CornerRadiusSyntax
	6.28   CultureInfoIetfLanguageTagSyntax
	6.29   CultureInfoSyntax
	6.30   CursorSyntax
	6.31   CursorTypeSyntax
	6.32   DataGridClipboardCopyModeSyntax
	6.33   DataGridEditActionSyntax
	6.34   DataGridEditingUnitSyntax
	6.35   DataGridGridLinesVisibilitySyntax
	6.36   DataGridHeadersVisibilitySyntax
	6.37   DataGridLengthSyntax
	6.38   DataGridLengthUnitTypeSyntax
	6.39   DataGridRowDetailsVisibilityModeSyntax
	6.40   DataGridSelectionModeSyntax
	6.41   DataGridSelectionUnitSyntax
	6.42   DatePickerFormatSyntax
	6.43   DayOfWeekSyntax
	6.44   DependencyPropertySyntax
	6.45   DockSyntax
	6.46   DoubleCollectionSyntax
	6.47   DragActionSyntax
	6.48   DragDropEffectsSyntax
	6.49   DragDropKeyStatesSyntax
	6.50   DurationSyntax
	6.51   EasingModeSyntax
	6.52   EdgeModeSyntax
	6.53   EdgeProfileSyntax
	6.54   ExpandDirectionSyntax
	6.55   FigureHorizontalAnchorSyntax
	6.56   FigureLengthSyntax
	6.57   FigureUnitTypeSyntax
	6.58   FigureVerticalAnchorSyntax
	6.59   FillBehaviorSyntax
	6.60   FillRuleSyntax
	6.61   FlowDirectionSyntax
	6.62   FlowDocumentReaderViewingModeSyntax
	6.63   FocusNavigationDirectionSyntax
	6.64   FontCapitalsSyntax
	6.65   FontEastAsianLanguageSyntax
	6.66   FontEastAsianWidthsSyntax
	6.67   FontEmbeddingRightSyntax
	6.68   FontFamilySyntax
	6.69   FontFractionSyntax
	6.70   FontNumeralAlignmentSyntax
	6.71   FontNumeralStyleSyntax
	6.72   FontSizeSyntax
	6.73   FontStretchSyntax
	6.74   FontStyleSyntax
	6.75   FontVariantsSyntax
	6.76   FontWeightSyntax
	6.77   FrameworkPropertyMetadataOptionsSyntax
	6.78   GeneratorDirectionSyntax
	6.79   GeneratorStatusSyntax
	6.80   GeometryCombineModeSyntax
	6.81   GeometrySyntax
	6.82   GradientSpreadMethodSyntax
	6.83   GridLengthSyntax
	6.84   GridResizeBehaviorSyntax
	6.85   GridResizeDirectionSyntax
	6.86   GridUnitTypeSyntax
	6.87   GridViewColumnHeaderRoleSyntax
	6.88   HandoffBehaviorSyntax
	6.89   HitTestFilterBehaviorSyntax
	6.90   HitTestResultBehaviorSyntax
	6.91   HorizontalAlignmentSyntax
	6.92   ImeConversionModeValuesSyntax
	6.93   ImeSentenceModeValuesSyntax
	6.94   InheritanceBehaviorSyntax
	6.95   InkCanvasClipboardFormatSyntax
	6.96   InkCanvasEditingModeSyntax
	6.97   InkCanvasSelectionHitResultSyntax
	6.98   InputMethodStateSyntax
	6.99   InputModeSyntax
	6.100   InputScopeNameValueSyntax
	6.101   InputScopeSyntax
	6.102   InputTypeSyntax
	6.103   Int32CollectionSyntax
	6.104   Int32RectSyntax
	6.105   IntersectionDetailSyntax
	6.106   InvertAxesSyntax
	6.107   IsOffscreenBehaviorSyntax
	6.108   JournalEntryPositionSyntax
	6.109   JournalOwnershipSyntax
	6.110   JumpItemRejectionReasonSyntax
	6.111   KernelTypeSyntax
	6.112   KeyboardNavigationModeSyntax
	6.113   KeyGestureSyntax
	6.114   KeySplineSyntax
	6.115   KeyStatesSyntax
	6.116   KeySyntax
	6.117   KeyTimeSyntax
	6.118   KeyTimeTypeSyntax
	6.119   KeyTipHorizontalPlacementSyntax (4.5)
	6.120   KeyTipVerticalPlacementSyntax (4.5)
	6.121   LengthSyntax
	6.122   LineBreakConditionSyntax
	6.123   LineStackingStrategySyntax
	6.124   LocalizationCategorySyntax
	6.125   LogicalDirectionSyntax
	6.126   ManipulationModesSyntax
	6.127   Matrix3DSyntax
	6.128   MatrixSyntax
	6.129   MediaStateSyntax
	6.130   MenuItemRoleSyntax
	6.131   MessageBoxButtonSyntax
	6.132   MessageBoxImageSyntax
	6.133   MessageBoxOptionsSyntax
	6.134   MessageBoxResultSyntax
	6.135   ModifiabilitySyntax
	6.136   ModifierKeysSyntax
	6.137   MouseActionSyntax
	6.138   MouseButtonStateSyntax
	6.139   MouseButtonSyntax
	6.140   MouseGestureSyntax
	6.141   NavigationModeSyntax
	6.142   NavigationUIVisibilitySyntax
	6.143   NonClientFrameEdgesSyntax (4.5)
	6.144   NumberCultureSourceSyntax
	6.145   NumberSubstitutionMethodSyntax
	6.146   OrientationSyntax
	6.147   OverflowModeSyntax
	6.148   PageRangeSelectionSyntax
	6.149   PanningModeSyntax
	6.150   PathAnimationSourceSyntax
	6.151   PathFigureCollectionSyntax
	6.152   PenLineCapSyntax
	6.153   PenLineJoinSyntax
	6.154   PixelFormatSyntax
	6.155   PlacementModeSyntax
	6.156   PngInterlaceOptionSyntax
	6.157   Point3DCollectionSyntax
	6.158   Point3DSyntax
	6.159   Point4DSyntax
	6.160   PointCollectionSyntax
	6.161   PointSyntax
	6.162   PopupAnimationSyntax
	6.163   PopupPrimaryAxisSyntax
	6.164   PowerLineStatusSyntax
	6.165   PresentationTraceLevelSyntax
	6.166   PropertyPathSyntax
	6.167   QuaternionSyntax
	6.168   ReadabilitySyntax
	6.169   ReasonSessionEndingSyntax
	6.170   RecognitionConfidenceSyntax
	6.171   Rect3DSyntax
	6.172   RectSyntax
	6.173   RelativeSourceModeSyntax
	6.174   RenderingBiasSyntax
	6.175   RepeatBehaviorSyntax
	6.176   RequestCachePolicySyntax
	6.177   ResizeGripDirectionSyntax (4.5)
	6.178   ResizeModeSyntax
	6.179   ResourceDictionaryLocationSyntax
	6.180   RestoreFocusModeSyntax
	6.181   RibbonApplicationMenuItemLevelSyntax (4.5)
	6.182   RibbonControlLengthSyntax (4.5)
	6.183   RibbonControlLengthUnitTypeSyntax (4.5)
	6.184   RibbonDismissPopupModeSyntax (4.5)
	6.185   RibbonImageSizeSyntax (4.5)
	6.186   RibbonSplitButtonLabelPositionSyntax (4.5)
	6.187   RotationSyntax
	6.188   RoutedEventSyntax
	6.189   RoutingStrategySyntax
	6.190   SamplingModeSyntax
	6.191   ScrollBarVisibilitySyntax
	6.192   ScrollEventTypeSyntax
	6.193   ScrollUnitSyntax (4.5)
	6.194   SelectionModeSyntax
	6.195   SelectiveScrollingOrientationSyntax
	6.196   ShaderRenderModeSyntax
	6.197   ShutdownModeSyntax
	6.198   Size3DSyntax
	6.199   SizeSyntax
	6.200   SizeToContentSyntax
	6.201   SlipBehaviorSyntax
	6.202   SpeechModeSyntax
	6.203   SpellingReformSyntax
	6.204   StickyNoteTypeSyntax
	6.205   StretchDirectionSyntax
	6.206   StretchSyntax
	6.207   StringCollectionSyntax
	6.208   StrokeCollectionSyntax
	6.209   StyleSimulationsSyntax
	6.210   StylusButtonStateSyntax
	6.211   StylusPointPropertyUnitSyntax
	6.212   StylusTipSyntax
	6.213   SweepDirectionSyntax
	6.214   SystemGestureSyntax
	6.215   TabletDeviceTypeSyntax
	6.216   TabletHardwareCapabilitiesSyntax
	6.217   TaskbarItemProgressStateSyntax
	6.218   TextAlignmentSyntax
	6.219   TextCollapsingStyleSyntax
	6.220   TextCompositionAutoCompleteSyntax
	6.221   TextDataFormatSyntax
	6.222   TextDecorationCollectionSyntax
	6.223   TextDecorationLocationSyntax
	6.224   TextDecorationUnitSyntax
	6.225   TextFormattingModeSyntax
	6.226   TextHintingModeSyntax
	6.227   TextMarkerStyleSyntax
	6.228   TextPointerContextSyntax
	6.229   TextRenderingModeSyntax
	6.230   TextTabAlignmentSyntax
	6.231   TextTrimmingSyntax
	6.232   TextWrappingSyntax
	6.233   ThicknessSyntax
	6.234   TickBarPlacementSyntax
	6.235   TickPlacementSyntax
	6.236   TiffCompressOptionSyntax
	6.237   TileModeSyntax
	6.238   TimeSeekOriginSyntax
	6.239   ToleranceTypeSyntax
	6.240   TouchActionSyntax
	6.241   TransformSyntax
	6.242   UndoActionSyntax
	6.243   UpdateSourceTriggerSyntax
	6.244   ValidationErrorEventActionSyntax
	6.245   ValidationStepSyntax
	6.246   Vector3DCollectionSyntax
	6.247   Vector3DSyntax
	6.248   VectorCollectionSyntax
	6.249   VectorSyntax
	6.250   VerticalAlignmentSyntax
	6.251   VirtualizationCacheLengthSyntax (4.5)
	6.252   VirtualizationCacheLengthUnitSyntax (4.5)
	6.253   VirtualizationModeSyntax
	6.254   VisibilitySyntax
	6.255   WindowStartupLocationSyntax
	6.256   WindowStateSyntax
	6.257   WindowStyleSyntax
	6.258   WrapDirectionSyntax
	6.259   XmlLanguageSyntax

	7   References
	8   Index

