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This month we’ve partnered
with Microsoft to bring you a
free, 28-page supplement on
Expression Studio 3. Whether
you’re new to Microsoft’s web
design and development suite
or an old hand, we’ll reveal the most jawdropping new features in version 3 and how
you can use them to enhance your websites,
speed up your workflow and more. Enjoy!
editor
www.twitter.com/danoliver
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2

in association with Microsoft

MS_expression 2

6/11/09 12:40:12

expression – 3 contents

Build sites 12

content
Expression Studio 3

Create a prototype 16

features >
4

Three is the
magic number
Gary Marshall examines the
new features in Microsoft
Expression Studio 3

10

Profile:
Specialmoves
The agency explains why
it’s an enthusiastic user
of Microsoft technologies

Opinion 26

20

Best of Silverlight

27

technique >
12

16

26

Blend/Create a
prototype in
SketchFlow

Kristie Weatherford of Lab49
demonstrates how to use
SketchFlow to build a currency
trade prototype

Competition
Win a copy of Microsoft
Expression Studio 3!

Expression Web 3/
Start building sites
Paul Dawson of EMC
Conchango gives a guided
tour of the software

Dan Oliver checks out some
of the coolest uses of Silverlight
technology on the web today

25

Glossary
Your handy guide to all the
terms and techniques

22

Below the Surface
Rich Wand explores the
exciting possibilities offered
by Microsoft Surface

Silverlight/Design
with Deep Zoom
Costas Brammer of
Specialmoves explains how to
make best use of Silverlight’s
powerful new feature

WIN!

Your own copy of
Expression Studio 3
Turn to page 25 for full
details of our fantastic
competition!

Best of Silverlight 20

in association with Microsoft

MS_expression 3

3

6/11/09 12:40:17

expression –3 introduction

3 is the
magic number
As the Expression suite reaches version 3, Microsoft isn’t sitting on its
laurels. As Gary Marshall discovers, the new versions include powerful
new tools and some jaw-dropping new features
Words Gary Marshall has been
writing for .net since 1998, when
members of the HTML Writer’s
Guild, sitting in silence in far-away
monasteries, painfully drew each
web page by hand before nailing
the results to wooden servers. At
least, that’s how he remembers it.
www.bigmouthstrikesagain.com
Image Simon Middleweek is a
designer and illustrator with
more than 10 years’ experience
working in editorial design.
www.twitter.com/
simonmiddleweek
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The latest version of Microsoft’s Expression suite is
a very big deal. Expression Web has a brand new
user interface, some extremely useful new features
and a vastly improved publishing system, while Blend
introduces SketchFlow, a way of prototyping online and
desktop applications that’s likely to save you a great deal of
time, effort and expense.
Graphics package Expression Design has been beefed
up too, while Expression Encoder offers improved video
encoding. As before, the applications are designed
to work seamlessly with one another (and with Visual
Studio) – so for example, you might create assets in Design,
use them in Blend to build an online application in Silverlight
and then stick that into a bigger site that you’ve built in
Expression Web.

an upgrade + VAT) adds
Expression Blend with
SketchFlow. Then there’s
Expression Professional
Subscription (around £780 +
VAT), which takes Expression
Studio and adds Visual Studio
Standard, Office Standard, Office
Visio Professional, Windows XP,
Windows Vista Business and a free
horse. We’re lying about the horse. As well
as existing Expression users, the upgrade prices are available
to users of any Adobe Creative Suite products. Plus in the case
of Expression Web, you’re eligible for the upgrade price if
you’re a Microsoft Office user.

How much?

Preview power

Before we get stuck into the detail, it’s worth pointing out
that this isn’t particularly pricey software. As there’s no UK
RRP, we checked out prices from local resellers and Microsoft
offers the Expression applications in three different bundles.
Expression Web (around £100/£57 as an upgrade + VAT) gives
you Expression Web 3, Expression Design 3 and Expression
Encoder 3, while Expression Studio (around £400/£236 as

The headline new feature in Expression Web is SuperPreview,
which is designed to take the drudgery out of cross-browser
compatibility testing. It’s the result of extensive consultation
with web designers, and it provides an easy way for you to
test layouts in the various browsers you need to support
without running multiple programs or using online browser
testing services such as WebShots.
You can view different browsers side by side, clicking on
any weird bits to display the relevant bit of the DOM, and we
particularly like the overlay view. This enables you to layer one
browser on top of another, making even minor layout issues
immediately obvious. It isn’t limited to different versions of IE
either: you can use it to check your designs in Firefox
or compare them with your PSD compositions.
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Case study i2Q Education
Fresh from the ambitious Attollo project, which
used Silverlight 2 to deliver a platform for online
education, i2Q Education (www.i2q.co.uk) is
using Blend 3 and Silverlight 3 to deliver school
data in such a way that parents can understand it
– and we’re talking about a lot of parents. Where
Attollo was designed for 150,000 users, i2Q’s
latest project is for half a million. The project is
called OpenSchool, and as user interface lead
Nick Harewood explains, “Schools are required
to have an online parental reporting solution in
place by 2010, and OpenSchool will deliver the
same rich UX that helped differentiate Attollo.”
Attollo offered users a full-screen desktop
with a customisable look and feel, with LINQ to
SQL taking care of data access behind the scenes.
OpenSchool picks up where Attollo left off and
takes advantage of some of the new features in
Silverlight 3 and the Silverlight 3 Toolkit.
OpenSchool is an in-browser application
that will also offer a slimmed-down ‘out of
browser’ application and a Silverlight Mobile
version. It makes extensive use of Silverlight 3’s

Expression Web also has a second kind
of page preview, which Microsoft calls
Snapshot Preview. This is a live rendering of your
page, and it changes as you add or adjust the
underlying code.
As with SuperPreview it’s not an Internet
Explorer-only job: it supports Firefox, and displays
ASP.NET and PHP pages as well as HTML ones
courtesy of the included ASP.NET and PHP
development server, which saves you the effort
of installing a local web server.
The graphics side of things has been boosted,
too. Version 3 of Expression Web supports
Photoshop import and gives you the ability to
embed Deep Zoom images via Silverlight
or Seadragon. And while we’re on the subject of
Silverlight, the bundled Encoder makes it easy to

new controls, as well as its charting toolkits and
extensions for visualising data. “OpenSchool
will leverage the student data held in schools
and present it to parents through a rich and
highly functional UI,” Harewood says. “Using
the built-in Charting controls, raw attendance,
assessment, behaviour and other data types will
be presented as highly interactive visuals. The
key driver is to make this rich data set accessible
to parents so they can become more involved in
their children’s education.” The project began in
June, and will be completed in October.
For i2Q, SketchFlow has replaced the familiar,
time-consuming and often frustrating model of
iterating design ideas: whiteboard to wireframe
to static HTML and the odd Visio diagram
that “makes great wallpaper” but doesn’t
do a brilliant job of communicating what an
application will actually be like. So what does
Harewood think of Expression Blend 3? “First
impressions overall are that it’s a much better
tool for the job,” he says. “There are fewer
hiccups in the workflow, and everything just

convert video clips to Silverlight, stick them
into your web project and skin the video player.
Plus you can encode video into Silverlight without
leaving Expression Web if Expression Encoder
is installed.
Deep Zoom isn’t new to Silverlight 3 – it’s
in Silverlight 2 – but it’s a welcome addition to
Expression Web. The technology takes giant,
high-resolution images and cleverly carves them
up, downloading data on a just-in-time basis as
the user pans and zooms.
One of the best demonstrations of Deep
Zoom is the Hard Rock Café’s memorabilia website
(www.memorabilia.hardrock.com), and there’s a
fascinating demo at Deep Earth (www.codeplex.
com/deepearth). You can’t create Deep Zoom
images from inside Expression Web, but the

seems more robust and fit for purpose. Another
telltale sign of its maturity is the number of
choices now available in the Options menu. It
seems a much more malleable application, easier
to fit to the users’ needs and preferences.”

Touch of class The OpenSchool system takes advantage
of Silverlight 3’s controls and data visualisations to
create a UI that’s simple for parents to understand

necessary software – Deep Zoom Composer – is
a free download from Microsoft.com.
To find out more about using Deep Zoom, turn
to page 22 for our in-depth tutorial.

Better Blend
Version 3 of Expression Blend is very interesting
indeed. In addition to a number of worthwhile
new features – the ability to import PSD and AI
files while retaining layers and shapes; better font
embedding and management; more control over
animation; smooth layout transitions; support for
WPF and Silverlight graphic effects; a redesigned
Asset Library; and the ability to use sample data
for prototyping and testing data-enabled
applications when the data source is unavailable
– Microsoft has added Behaviors, which are
reusable components that you can drag onto
your project to add interactivity.
In addition to Blend’s own Behaviors, coders can
create their own using the Blend 3 SDK. But the key
thing about Behaviors is that you don’t need to be
a coder to take advantage of them.
For example, you might have a Behavior for
a video playback slider that displays the time
when the user hovers their mouse over the
slider; to use it, you’d just drag and drop it onto
your slider control (if you’d like to know how to
create that one, Jobi Joy has posted a tutorial at
jobijoy.blogspot.com/2009/07/slider-preview-asexpression-blend-3.html).

Template creator

Panel precision Expression Web’s panels can be set to auto-hide or detached altogether to create a custom workspace

6

Another welcome change is the modified Make
Into Control command, which enables you to
turn artwork into templates for UI controls. For
example, you might create a text box with specific
formatting, which Blend will store for re-use, or
you might create a slider control in a Photoshop
mock-up, bring it into Blend and turn the slider
control into a reusable skin that you can drag and
drop throughout your application.
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SketchFlow What inspired Blend’s most jaw-dropping feature?

Movable feast Expression Blend’s interface has been given
number of visual and functional tweaks, with the Assets
Library now in the form of a dockable panel

As you’d expect, Blend’s Silverlight support has
been boosted to make it play nice with Silverlight
3. There’s a new project type, Silverlight Application
+ Web Site, which publishes your Silverlight
application along with an HTML page to launch
it, and you can configure your applications to run
in their own windows outside the web browser
(although the new Library caching feature, which
can speed up performance, isn’t supported in outof-browser applications).
We’ve left the best new feature until last,
though: version 3 of Blend now comes with
SketchFlow, an extraordinarily clever – and
exceptionally handy – way of turning prototypes
and bright ideas into finished applications.
The path from an initial idea to a finished
application can be a rocky one. Initial designs are
refined or replaced entirely, interactive elements
are suggested, tried and tested, and everyone from
the client’s marketing director to the CEO’s dog has
an input. Wouldn’t it be great if you could start
with a sketch, make it work like an application,
tweak it as you go along and let interested parties
play with mock-ups before you nail down the final
design – without having to build version after
version after version?
With SketchFlow you can do exactly that. It
supports both WPF and Silverlight applications
and works in essentially the same way for each,
although the available libraries differ slightly
according to whether you’re planning to create a
desktop application or an in-browser one.

Go with the Flow
You really need to see SketchFlow in action
to appreciate how simple and useful it is, but
to give you an example let’s think about a login
system or an ecommerce application. You’ll
need a login screen for people to enter their
credentials, a failure screen if they get it wrong,
a logged-in screen if they enter the right
information, and you’ll probably want a
common header across each one.

Christian Schormann is the man behind
SketchFlow, and he’s been working on the
idea for a long time. “I’ve been designing user
interfaces for complex authoring applications
for years, and I got more and more frustrated
with the tools I had to actually come up with a
design and iterate on it,” he recalls. “This was
particularly cumbersome, with dynamic UIs that
would reformat or change state, or resize – all
these dynamic aspects of user interaction just
can’t be easily mocked up in a normal static
drawing program. And the more dynamic user
interfaces get, the less satisfying static mock-ups
are as your primary mental evaluation device.”
Schormann began sketching out a solution
in Windows Forms. “I wanted to be able to
create a mind-map of the structure of a user
experience, think about that in an abstract
fashion even before, potentially, ever creating
any concrete UI. I wanted a tool that would
allow me to be as fuzzy or vague as I liked, but
that would let me become concrete whenever
I wanted to. So I started playing with the ideas
you see in the prototype screenshot (below),
and found that they worked pretty well, even in
my shaky and incomplete prototype.
“You have a very different mindset during
prototyping than during production – it’s all
about exploration, tentativeness, expanding

your mind space. I wanted a tool that better
reflected that mindset,” he adds. When he
joined Microsoft, he found a number of people
who had been thinking along similar lines.
“We designed the whole feature set for Blend
3 with SketchFlow in mind. The different bits
and pieces of Blend 3 really have been designed
to re-enforce and support each other – for
example, behaviors and sample data stand
well on their own, but they add incredible
expressive power to the prototyping story.
The Photoshop import works beautifully on its
own, but combined with the data binding story
it’s quite amazing what you can do with it, to
quickly convert a static comp into a living and
breathing application.”

Early days Christian Schormann sketched out his
ideas for a prototyping system in Windows Forms

Integrated “We designed the whole feature set for
Blend 3 with SketchFlow in mind,” Schormann says

If you’re building an ecommerce site, there’s
going to be a product page with buy buttons,
a shopping basket and the various components
of a checkout system. To start prototyping
these systems in SketchFlow, you’d map out the
relationship between the different components
in the Map panel, which creates a series of
underlying XAML files for each screen.
You can bind these files so, for example, if
there’s a common interface element such as a
header that will appear on each screen, you can
create it once and then bind it to the screens on
which it needs to appear. Then it’s just a matter of
bashing together a rough UI, which you can do by
dragging and dropping standard components such

SketchFlow is an extraordinarily clever
way of turning prototypes and bright
ideas into finished applications

Easy does it The Sketch Editor was designed to make
it simple to bash out drafts of user interface ideas

as buttons and boxes, by importing a Photoshop
mock-up or scanning in the biro drawing you did
on the back of a napkin.

Sketching it out
Even if you didn’t design your UI on the back
of a napkin, SketchFlow includes a Sketch visual
style that you can use to make it look as if you
did. It’s not a gimmick, though: the dashed-off
appearance of a sketch can make users more likely
to offer feedback, because they may assume that
a polished, high quality interface involves so much
work that the merest suggestion of a change might
make you blow a gasket.
More importantly, by making everything look
sketched you can avoid wasting time on issues of
the “I’m really not sure about that shade of green”
variety and get your users to concentrate on more
important elements of your application.
It’s what happens next that makes SketchFlow
brilliant. You can now start adding features inside
Blend: so, for example, you could right-click
on a button, select Navigate To and
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User interface

A guided tour of the new UI

Expression Web 3 looks a bit different from its
predecessors, but there’s more to its new user
interface than a fashionable black makeover.
The toolbars and menus have been tweaked,
information gets out of your way when you
don’t need it and Snapshot and SuperPreview
make it easy to spot potential problems.

1

New Site menu

2

Revised toolbars and new
Code View bar

Site management and settings have been relocated
from the File menu to the new Site menu. The
program now transfers multiple files simultaneously,
you can transfer to multiple destinations and the FTP
service supports both FTPS and SFTP.

In addition to the eye-friendly dark user interface,
Expression Web’s toolbars have been reorganised
and there’s a new Code View toolbar for code
navigation and formatting.

3

Snapshot

Snapshot provides a real-time view of your page
as it will appear in the browser, and you can set it
to render as various versions of IE and Firefox.
Thanks to the built-in ASP.NET and PHP development
server, Snapshot can preview data-driven pages as
well as static ones.

make it call up another screen; you could
experiment with transition effects between
screens; you could bring in sample data to show
how list boxes would work; or you could drag and
drop Behaviors to add interactivity.
You can then publish your project in one of
two ways. Option one is to bash it out as a Word
document, but the second option – publishing it

4

Auto Hide Panels

If you like panels to get out of the way when
you don’t need them, you’ll like the Auto Hide
feature in version 3. As the name suggests, this
feature makes panels hide themselves when you
move the mouse away.

for viewing in SketchFlow Player – is much more
fun and much more useful.
SketchFlow Player is a Silverlight-based
application that runs in a web browser and that
enables users – clients – to see your ideas in
action. This isn’t a slideshow or a screencast,
though: it’s an interactive application, and
everything you’ve added in Blend will work in

Zoom zoom Expression Web 3 enables you to insert Deep Zoom images, as showcased to excellent effect by the Hard
Rock Café memorabilia site. For more on the Deep Zoom feature, turn to page 22 for Costas Brammer’s tutorial

8

5

SuperPreview

Expression Web 3’s headline feature is exceptionally
handy. The blurring you see here is because we’ve
overlaid the same page in Firefox and in Internet
Explorer 8 to see whether there are any layout
differences. You can display the relevant bit of the
DOM to see where a particular problem lives.

their browser. Scrolly bits scroll, list boxes list,
data is displayed and animations animate in a
classic case of ‘show, don’t tell’ where even the
crudest biro sketch works like a real application
– which, of course, it is.
You can provide multiple versions in the same
publication, so you might offer different interface
ideas, alternative input methods or anything else
you fancy getting feedback on, and the client can
then add their comments about what they like
or don’t like. That data can then be brought back
into Blend, where the annotations will appear in
context on the design surface, and you can start
refining your prototype into something more solid.
Because you’ve been building the application
as you go along, you’re not rebuilding or recoding
your application every time there’s a change. If you
import your UI design from Photoshop, Illustrator
or Expression Design you can apply it to your
application in much the same way you’d apply a
CSS design to change a web page.

Versatile video You can invoke Expression Encoder from
within Expression Web, or use it as a stand-alone
application for creating Silverlight video
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Smooth operator IIS Smooth Streaming is Microsoft’s implementation of adaptive streaming technology, with bit rates
changing to match users’ bandwidth availability – which drastically reduces the amount of stuttering and buffering

Our first thought on seeing SketchFlow in
action was “Agencies are going to love this”,
and that’s what Microsoft says it’s hearing too.
As SketchFlow’s creator Christian Schormann told
us: “We’ve had a lot of feedback from agencystyle customers, who’ve told us that SketchFlow
really helps them – not just in their core design
processes, but that it really makes a difference
when bidding for contracts, because they can
answer more rapidly, more effectively and at much
lower cost to RFPs. That provides a direct benefit
to their bottom line, and that is always a good
result for any design tool to achieve.”

Further features
There are several new features in Expression
Design 3 and Expression Encoder 3 that we
think are worth highlighting. As before, Design
enables you to import vector and bitmap images
or create new images for reuse in Web or Blend,

source), and the Timeline now enables you to build
a single clip from multiple media files.
Silverlight 3 pops up again in the form of
support for offline video, H.264 media and
playing embedded video in a separate browser,
and there’s a collection of new templates for
easy encoding and export.

Superior streaming
Encoder 3 also adds more support for IIS
Smooth Streaming, Microsoft’s version of
adaptive streaming technology. This enables
you to encode clips at various bit rates, which
are then broken up into small chunks and
delivered according to the amount of bandwidth
available to the user – so if their connection starts
to clog, the bit rate drops, and if it improves, the
bit rate does too.
When running in tandem with Silverlight 3’s
graphics acceleration support, Smooth Streaming

Since day one, there’s been a constant
dialogue between Microsoft and the
design/development community
and you can output your finished assets as an
HTML composition, PSD, PDF, Silverlight/Windows
Presentation Foundation canvas or, if you’re
creating assets for Web or Blend, XAML. Version
3 adds Photoshop import, enabling you to open
PSDs while retaining the original layers.
The interface has been given a tweak, and as
you’d expect the application has been updated to
support Silverlight 3, so for example Drop Shadow
and Gaussian Blur effects can now be exported as
WPF and Silverlight 3-compatible effects.
Expression Encoder has been freshened up, too.
The new Screen Capture utility makes it easy to
create video documentation: you can capture still
and video images of the on-screen action as well
as your webcam (or any external audio or video

is capable of reliably streaming 1080p ‘true HD’
high definition video. According to Microsoft,
testing by firms such as NBC “has shown that
engagement times far exceed those using
other non-adaptive streaming platforms, so
the upside for content monetisation is very
encouraging”. We suspect that’s marketing
speak for “if people have to wait for video they
bugger off” – a situation adaptive streaming is
designed specifically to address. Microsoft has
already inked deals with the big content delivery
networks to support IIS Smooth Streaming, with
Akamai, Level3 and Limelight already supporting
the technology. If you’d like to see it in action
there’s a compelling demo at www.iis.net/media/
experiencesmoothstreaming.

Top Expression Design 3 now boasts Photoshop import
and the same flexible workspace system as Expression
Web Middle SketchFlow’s hand-drawn styles ensure users
pay attention to the important bits, not the colour of the
logo Above The Expression apps work together, so for
example you might create a UI in Expression Design and
then bring it into Expression Web

We’ve been very impressed with Microsoft’s
Expression applications since day one – not
just because of the software itself, but also with
Microsoft’s approach to it. There’s been a
constant dialogue between the company and
the design/development community in the
form of betas, technical previews, conferences,
webcasts and blogs, and it’s clear that Microsoft
has been listening.
From banishing everyday irritations to reducing
the hassle of prototyping online applications,
version 3 of the suite is a significant upgrade that
should make existing Expression users very happy
– and that could well tempt users of other web
building applications to switch. l
Do you find the new features in Expression 3 useful?
Share your experiences at forum.netmag.co.uk
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Specialmoves
Members of high-end interactive production company
Specialmoves explain their distinct approach to design and
why they’re enthusiastic users of Microsoft technologies

Specialmoves
Agency location Shoreditch, London
Team 19
Expertise Interaction design, visual design,
3D, Flash, Silverlight, Flex, Unity, HTML/CSS,
back end (.NET, PHP, Django, Perl)
Established 2000
Clients TBWA, MTV, Glue, Work Club, Poke,
BBC, Agency Republic, Adam & Eve, Publicis,
Mydeco, BBH, Dare, Isobel, Albion, Tribal DDB,
Iris, Euro RSCG, GT

choose us. They know we can deliver work our
competitors can’t.
Seb Bicais, developer and technical project
manager: Utility and relevance lie at the very
core of what we do. We use our knowledge and
experience to create outstanding interaction design
resulting in brilliant interactive experiences.
Specialmoves is driven by finding creative solutions
to technical problems – we’re really good at it.
Coming from diverse backgrounds, we’ve built up
a shared technical knowledge and skill set that’s
second to none. This, combined with a platformneutral stance, means we can apply the same
exacting standards to every single project.

Q&A
.net: When did Specialmoves form and what do
you specialise in?
Katy Morgan, office manager: Specialmoves
was founded in 2000 by Darrell Wilkins, Pascal
Auberson and James Norwood. We’re a high-end
interactive consultancy and production company
that works with creative agencies and media
owners building remarkable websites, online
advertising and games.

.net: Which projects have you employed Microsoft
technologies to deliver?
Matthew Harney, senior interactive developer:
Most of our projects that have involved complex,
back-end architecture have been built around
Microsoft technologies.

.net: What sets you apart from other agencies?
Darrell Wilkins, executive creative director:
Specialmoves offers much more than just beautiful
work. Brilliant interaction design, superior technical
know-how and a meticulous production process
are the reasons why leading creative agencies

.net: Why did you choose Microsoft technologies?
SB: We find Microsoft technologies very well
adapted for the web, and using the same editor for
every aspect of the architecture makes things easier
to integrate. Being able to build web services, DLLs,
console applications and simple server scripts with
the same tool is also a big plus. The latest versions
of IIS, ASP.NET and SQL Server are very satisfying in
terms of robustness, speed and scalability. Also, we
develop in C#, which makes developing Silverlight
applications really easy.
.net: What other key tools do you use?
MH: Photoshop and Illustrator often start the design
process, then we add flourish with 3DSMax, Mental
Ray and RealFlow as needed. Video comes in and
out of Final Cut and we employ an in-house audio
specialist who writes his own tools as needed.
On the coding side, we use everything from GCC
cross-compilers for ARM mobile development,
Visual Studio with Expression and Eclipse for web
development, and good old Notepad for Unity3D.
Our most-used tool is a big blackboard and chalk.

Top row, l-r: Darrell Wilkins, Pascal Auberson, Seb Bicais, Alex Gounaropoulos, Anthony Hughes, James Norwood
Bottom row, l-r: Sylvie Brandl, Chi Li, Val Rabot, Ciaran Park, Katy Morgan, Matt Bilson, Nicola Borradaile, Matthew Harney

10

8

.net: Which part of the design process do you see
as the most valuable?
DW: When creating an interactive piece that’s fun
and really easy to use, it’s essential to plan as much
of the user experience design before going ahead
with any of the visuals.
Costas Brammer, visual effects designer: We start
with sketches, which develop into fully fledged
skeleton designs and act as a solid foundation for
our visual designers to work from. The end results
not only look great but are
9 a pleasure to use.
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“Expression 3
allows designers
and coders to work
together more
quickly”
Darrell Wilkins

6

7

5

.net: Where do you find inspiration for the
online games you produce?
Chi Li, visual web designer: Arcade games from
the 80s/90s are a great source of inspiration for web
game ideas. Their stripped-down nature and focused
gameplay translates very well on to the web.

8

.net: How do you secure repeat business?
DW: Make sure you have the best people in every
position, from office manager and producers
through to technical architects and visual designers.
KM: Getting out of the way and letting people’s
talents shine through is really important.

9

.net: Which new feature in the Microsoft
Expression suite are you most excited about?
CB: There are so many features available ‘for free’
in Microsoft Expression it’s hard to really consider
them all, but the visual design tool combined with
the integration of Behaviors is a great feature.
MH: It allows designers and coders to work
together through source control much more
quickly than we’re used to with other current tools.
.net: Which project are you most proud of?
DW: The Virtual FA Cup. In an industry being swept
away by often pointless, irrelevant AR projects, we
created something simple, effective and relevant.
.net: What advice would you have for someone
who wants a job at Specialmoves?
DW: Look at what we do and how we go about
it. If you have similar motivations, and are keen to
learn, then just apply! l
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(1-2) Robin Hood
Showdown is a 3D action
game based on the
BBC1 drama. Utilising
the Unity plug-in, we
were able to deliver rich
3D environments, fluid
character animations
and dynamic gameplay
rarely seen in a browser.
(3-4) Built to support the
BBC’s Baby Borrowers,
the Baby Challenge 3D
game (specialmoves.com/
our-work/content/bbcbaby-challenge/game.html)
tests your ability to look
after very young children.
(5) Launched on the eve
of the FA Cup semi-finals,
this site (specialmoves.
com/our-work/content/
fa-cup-demo) harnesses
Augmented Reality
technology to enable

football fans to see
themselves holding The
Virtual FA Cup. They can
then send a photo or
video on to their mates.
(6-7) The MyDeco 3D
Room Planner (mydeco.
com/rooms/planner) is a
unique take on planning
and decorating rooms. One
of the easiest and most
intuitive planning tools to
use, this online application
enables you to create 3D
renders of your own room
designs. It’s a unique, easy
to use and powerful online
app that’s been extremely
well received by users and
garnered several accolades
including an FWA
award, the E-consultancy
Innovation Award 2008
in User Experience,
plus IMA and BIMA

nominations. (8-9) Pimp
My Ride (specialmoves.
com/our-work/content/
pimp-my-ride/game.html)
involved a big update to
one of MTV UK’s most
popular games. With a
brand new level, great
handling and a high score
table, the game is now up
there with the best online
driving games. (10) We
helped Tribal DDB bring
its Cornetto Love Message
Generator (cornetto.com)
to life. Users can write a
love note, send a plane to
fly the message over a city
of choice and then send a
realistic video of the flight
via web or phone. Two
months into the campaign,
over 45,000 love messages
have been sent across Italy,
France and Portugal.
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Expression Web 3
start building sites
The latest version of Microsoft’s web design and development software makes web building
easier than ever. EMC Conchango’s Paul Dawson gives you a guided tour of its possibilities
It’s not often that a new tool comes around that’s a new and serious
player in a particular field, but with the launch of version 3,
Expression Web is now a real contender in the world of visual
web page design.
The focus we all have now is on standards compliance, cross-browser
compatibility, accessibility and the integration of rich media components,
so it’s no surprise that Expression Web has a lot to offer in these areas.
Expression Web is as far from Frontpage as you can possibly get, and
much closer to ‘proper’ development tools like Visual Studio, paying close
attention to the quality of code.
In short, the first time I saw Expression Web 3, I was surprised. Surprised at
where Microsoft had taken it, and how it seemed to be much more open and
ready to integrate with the other tools that we all us, like Photoshop. It even
has a setting for you to work more effectively with PHP-coded sites!
It’s clear that Expression Web is a tool for professionals and doesn’t try to
automate everything. So there’s plenty of scope for a visual-only designer to
find it a challenge – but there are plenty of tools to help them become more
knowledgeable and gently coax them down the right paths while allowing the
‘pro’ to do it in their own way if they wish.
I won’t ‘review’ Expression Web here, or compare it to its rivals, but
rather take you through a few of its key features so you get a feel for what
it’s all about …

Getting started
The first step in using Expression Web, unless you’re planning on just tweaking
a single web page, is defining a site.
A site is literally a folder that contains all the necessary files for a site. It’s
pretty straightforward: just select File > Open and pick the folder within which
your site sits. This can be an empty folder for a new project, or an existing
folder. Expression Web doesn’t really care where it is, so long as it’s local and it
has all the access it needs to it.

Expert tip Intellisense: a brief history
IntelliSense works by accessing an automatically generated in-memory
database of classes, variable names and other constructs defined in or
referenced by the application being edited.
The idea is to speed up development by reducing the amount of
memorisation required or the need to refer to external documentation.
Intellisense first debuted as a mainstream product in 1996 in Visual
Basic, and was a significant part of why that particular language
brought so many new people to programming. IntelliSense is now also
supported by the Visual Studio editors for C++, C#, J#, Visual Basic, XML,
HTML and XSLT among others.

Helping write standards-compliant code is the next key feature. In the Page
Editor options, you’ll see that you can set the document declaration that you’re
targeting. Not only does this drive the doctype declaration in the meta data,
but more importantly it will drive the way in which the editor helps with
keeping the code you write compliant to that standard.
The first big weapon in the arsenal to help you adhere to these standards is
Intellisense, Microsoft’s auto-completion tool, which is well tested in products
like Visual Studio. What Intellisense does is a little like predictive text input,
only more intelligent. Although it allows you to type anything you want, the
‘intelli’ bit of the functionality will retrieve lists of things that are possible,

What Intellisense does is a
little like predictive text input,
only more intelligent
based on the standards compliance you’re looking for. So, if you set XHTML 1.0
as your primary document type, it will never suggest any tags or markup that
aren’t part of the XHTML 1.0 standard.

Keeping it relevant

First steps The first time you create a template in Expression Web 3, you need
to check the box that says Maintain the site using hidden metadata file

12

As you type < to open a piece of markup, Intellisense pops up with the list of
markup that’s possible in the context you’re in.
Either keep typing and the focus in the list will go to the relevant tag, or
scroll up and down the list. When the markup you want is highlighted in the
list, hit the [Tab] key or [Enter] and it will auto complete and move you on to
the next Intellisense list.
When you type > to close the tag, for example, the corresponding </ form>
is also created, and the cursor placed between them so you can start writing
the contents of the form.
Intellisense is also aware of the classes, ids and styles in use in the site, and
makes them available as a list for selection at appropriate points.
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Checkers

No, not Gordon Brown’s holiday home …

Crumb of comfort Clicking on welcome_block selects the entire div: this
breadcrumb is pretty useful for helping you work out where you are on the site
The other use of the doctype setting is to check your code for compliance to
the standard. So if you write markup in such a way that’s not compliant to the
standard, Expression Web will warn you as you type it. It uses similar visual
cues to the spellchecking functionality in Word, underlining the tags that don’t
conform with a hover-over message that tells you what error it has picked up.
All the way through editing you’ll see the bottom bar updating various
things from the size of the file you’re editing to some compatibility and error
checking tools. The first is checking compliance to the selected Doctype
Schema, enabling you to jump straight to any detected incompatibilities and
rectify them. The second is looking for more fundamental code errors such as
unclosed or incomplete tags. So as well as highlighting it in the code with a
red wavy underline, all errors are consolidated here.

Checkers are tools for checking that what you’ve created is compliant
to the published Doctype Schemas, works in your target browsers
and is accessible. Expression Web has all of these, and first up is the
accessibility checker.
Seeing as UK legislation is a bit hazy on what constitutes ‘accessible’,
and seeing as many of us work on sites that have to be compliant to
the laws of the country in which they’re being used, it’s handy that the
settings for the accessibility checker are pretty flexible. And anyone
who’s done any accessibility testing of any worth also knows that an
automated checker will only clearly define a relatively small number of
things that are known for certain to be accessibility issues, in that they
specifically contravene one of the WCAGs. So it’s also handy to be able
to turn on warnings and the manual checklist so we can look for things
that aren’t so easily measurable by an automated tool.
The accessibility report is viewable ‘in situ’ alongside the code and
design view, and can be re-run over and over as you trawl through and
fix up issues it has highlighted – or extend its remit to the entire site.
The compatibility checker works in a similar way and is equally
comprehensive in the options available and how it takes you directly to
the errors so you can fix them up there and then.

Templating
The first thing we’re going to do is create some new pages, and we’re going to
use a feature in Expression Web called Dynamic Site Templates. This pretty
much does what it says on the tin, and users of DreamWeaver will be familiar
with the concept – it allows dynamic web pages to be created from a template.
But first, if you’ve not used a template in Expression Web before, you’ll need to
make a change to the site settings.
From the Site menu, select Site Settings. The dialogue shown in the
bottom-left screengrab will pop up and you’ll need to check the box that
says: Maintain the site using hidden metadata files. These are files that
Expression Web uses that it doesn’t publish as part of the finished site, to keep
things like references to external files, and links and references between files in
the site intact, no matter what you do to them.
Pretty much every WYSIWYG HTML editor does this, either in a database or
some other kind of config file, but for once it’s nice to see an application make
this option specific. I know I’ve been confused by .dat files and the like in other
packages, not sure which ones are required to make the site work and which
ones are only needed to do the editing.
Once this is checked, we can define a template from which all new pages on
the site can be generated. Doing this is pretty trivial, as all you do is save the
file from which you want to start any new pages as a .dwt (dynamic web

Options open Different countries demand different accessibility standards, so
the settings for the accessibility checker are reassuringly flexible

template) file. We’ll call ours default.dwt. The process of saving it also opens it
for editing, which we need, because we need to define which aspects of the
page are to be different (ie editable for each new page) and which are to be
common and updated from the template (ie non-editable).
By default, the whole of the template is deemed to be non-editable, so we’ll
add in a few regions that we’ll change on the subsequent pages. Click inside
the area that you want to make editable, and in the very handy breadcrumb
trail at the top you’ll see clearly where in the page structure you are.
We want the whole area called welcome_block to be editable, so click on it.
This also selects the entire div: this breadcrumb is also pretty useful for
helping you work out where you are in the structure of any page.

Right To make complex
changes to an image, rightclick on it to pull up the
picture properties dialogue

Left Click Manage
Editable Regions and
you’re invited to name
the selected region
and make it editable
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SuperPreview

A great new way to test in different browsers
SuperPreview is a superb new tool that enables you to configure
the comparison between a range of different browsers, including
the dreaded IE6 SP1. There is a variety of views that allow side-byside comparison, and as you scroll and click around the pages, the
containers and other non-visible elements are highlighted for you for
ease of debugging.
In the case below I’ve got it configured to look at IE8 running in
IE6 compatibility mode, and Firefox 3.5.2. There is a variety of views
that allow
side-by-side
comparison
and as you
scroll and
click around
the pages,
the containers
and other
non-visible
elements are
highlighted
for you
for ease of debugging. However, my favourite view is the overlay
view. The code we wrote here was very standards compliant, and not
too complex, so it wasn’t surprising that the pages didn’t render that
differently, and in the side-by-side view they look pretty identical.
But when I turned on overlay, look what happened:

Ring the changes After you save the .dwt file, you’re prompted to push the changes
made in the template through to the other files that are attached to it

When you want to make changes to the common (non-editable) areas on
all your pages, just open default.dwt again and make the change.
In the design view, you can use the View menu to define which ‘visual aids’
are turned on. This is useful in templates, as one of them is Template Region
Labels. Turning these on displays clearly where the editable regions are and
what they’re called.
If you’re working in a scenario where others have to edit these pages you
can use the name we defined above as a note to content editors eg ‘Put main
page content here’.

Conflict resolution
Okay, now save the .dwt file before we move on. Expression Web
will prompt you before closing it to push the changes made in the template
through to the other files that are attached to the template (as shown in
the above screenshot).
The process that follows is pretty good, as it deals with any conflicts
between templates and pages that already exist. Once some editable regions
are set up in the DWT, you can start creating new files from the template.
Doing this is also pretty straightforward: just Choose File > New > Create from

No, the printers haven’t got that image wrong. The blurring of the
text is the result of very tiny differences in layout and sizing, overlaid
on top of each other.
In this case, you can easily pick out the differences in how they
render the blockquote, the H1 formatted text and the form. The
designers who work with me – who consider themselves to be pixel
perfect – have never been so happy!

Make it editable
Now from the Format menu, select Dynamic Web Templates and then
Manage Editable Regions. The dialogue that opens up invites you to name the
region that you’ve just selected and to make it editable. We’ll use a friendly
name, Main Content Area, which doesn’t affect the div name in the HTML, and
click add to make it an editable region.
Note there’s a new tag up in the breadcrumb called <DWT:Editable> that
marks the beginning of the section. As we’ve already added the region, the
dialogue box in the screenshot has the rename button where the add button
used to be.
This means that if you forget to give it a friendly name, or want to make a
reference to the name of the actual div in the friendly name, you can rename it
without any trouble. Close the dialogue and you’re ready to go.

14

Expression Web makes every
attempt to help you write
clean, light, efficient code
Dynamic Web Template. In the Attach Dynamic Web Template window, click
the default document representing your .dwt file, then click Open.
This opens up a new file called Untitled_1.html, which you can then rename
to become the page you want to create.
Let’s do some basic editing in this page to show how you add content and
styling. By editing the existing containers in the editable content area, we can
change copy, and apply existing styles using entirely the design view.

Clean code
Expression Web makes every attempt to help you write clean, light,
efficient code. Sure, it’s quite possible to format text in the design or code
view without creating a CSS style, but if you select New Style from the
Manage Styles tab at the bottom-right, you get a dialogue box. You’ll notice
that it gives you the option to create this new style in an external style sheet,
be it a new one or an existing one. You can also bodge it into the current page
if you need to, of course, but you can’t say that the software doesn’t make it
pretty easy to do it right.
Let’s put some more content in. An image, for example, is as you’d expect:
Insert > Picture, and select a file from your disk. In the WYSIWYG view you can
resize the image of course, but also adjust its positioning and padding by
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Simple form Using the toolbox on the top right, I put in some simple form fields,
including a login button that I can then type into to change the wording, and resize

Further options More advanced properties enable you to choose the script type and
even wire it up correctly to the appropriate post action

dragging the margins and resizing them in the design view. The design
view shows the padding as a grey column for ease of reference, and backs
up any visual changes you make by showing you the pixel value as you make
the change.
If you want to get complex, though, pull up the picture properties by
right-clicking the image, and you’ll see pretty much everything you need. That
includes the wrapping style, which no matter how much I tried VALIGNing or
HALIGNing, I just couldn’t remember how to do in code, but it was all here.
Once resized, another right-click option is to re-sample the image. So if it
started as a 1MB image and you’re only using it at just under 300 pixels, it will
resample it and resave the image in the resolution at which you’ll be using it,
thereby saving valuable bandwidth.

move it into the site directory and I kept making mental notes to move it
manually before deploying the site.
But Expression Web was way ahead of me. The moment I wanted to close
the file it spotted all the things that I’d done that needed tidying up. As well as
offering to save the image in the right place, it also offered to save changes to
the style sheet we made and move a piece of script I used. In short, anything
that you do during the editing process that isn’t saved somewhere in the site

The trickier bits
Although typically I’ll call on a developer to do things like make forms work,
I always need to show them what I need. In many cases, when they’re
commonly used forms, or where I’m using an open source script, I’ll wire the
thing in and make it work properly.
Let’s put in a simple form to see how it’s done in Expression Web. The main
feature we’ll be using here is the toolbox. It’s the box on the top right and it
contains a whole bunch of ‘stuff’ you might want to insert into a web page in
terms of tags and markup.
Select an item, right-click, hit Insert, and it appears in the design view. In the
screengrabs above, I’m putting in some simple form fields, including a login
button that I can then type into to change the wording, and resize, before
going on to the more advanced properties where I can choose the script type,
and even wire it up correctly to the appropriate post action.
The other thing that was bugging me as I was working with this image is
that when I had the code view open I could see clearly that it was referencing
the original location of the file on my hard disk, which I had got from the
Sample Pictures folder in Windows 7. I was upset that it hadn’t asked me to

Import > PSD enables you to
bring in all the elements you
need from a single PSD
folder, it will handle and ask you to tidy up. There are a few other tidying up
tools available as well, like the code optimiser that will even remove white
space, as well as tidy up your code formatting.

Layering it on thick
“But,” I hear you cry, “I get all my images from a designer who just gives me a
PSD file from Photoshop. I’ve still got to chop up those files into the images I
need.” Well, thankfully Expression Web has an answer to that, too. You can
either insert an image straight from a PSD file or you can import an entire PSD
file using the import function.
Now, I have a confession. I don’t have Photoshop installed on my machine.
It’s a new machine running Windows 7, so I have an excuse, but it’s also a
good way to test this. So, I downloaded one of Chris Anderton’s Deluxive PSDs
from deluxive.deviantart.com and tried it out.
When you select the Insert > Picture option you get the ability to see all of
the layers, and to select and deselect any you choose, and to select the image
format and quality in which the image is then saved.
Selecting Import > PSD will just do this process without inserting the image
into a specific part of the page. It enables you to bring in all the elements you
need from a single PSD and get them in the right place and format in your site
folder before setting about building anything.
Seeing as all many of our UI developers do with Photoshop is import slices
of PSDs into web projects, this may save us a Photoshop licence or two! l

About the author
Name Paul Dawson
Job Experience director
Company EMC Conchango
Blog blogs.conchango.com/pauldawson
Client DHL, Virgin Atlantic, Tesco & others
Favourite ice cream Ben & Jerry’s Chocolate fudge brownie

Switching to manual Automated tools can be a blunt instrument when it comes to
accessibility, so the manual checklist is a big help in staying on top of potential issues
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Blend build a
SketchFlow prototype
Kristie Weatherford of technology consulting firm Lab49 explains how to use
the SketchFlow feature in Expression Blend to build a currency trade prototype
Expert tip Properties panel
The Properties panel is contextual: it changes
depending on what’s selected in the Design
view. The Search field will help locate the
properties in this tutorial. But beware! When
you want rounded corners, the property on
a Border is CornerRadius, but on a Rectangle
you have to use the RadiusX and RadiusY
properties. This is an example for Silverlight
projects: round corners are not available on
sketchy style controls in SketchFlow projects.
Searching helps you find properties, but some
effects are applied differently from one control
to another and may not have the same name.

What you’ll learn In this tutorial, I’ll build a Silverlight F/X currency trade prototype to demonstrate some of the
functionality available in SketchFlow and Microsoft Expression Blend 3 while implementing a real-world example from
the financial services domain

Knowledge needed None
Requires Microsoft Expression Blend 3
Project time 1-2 hours
SketchFlow is a compelling new tool for
creating interactive prototypes. It incorporates
the review, commenting and collaboration that
comes with the process of designing apps and
interactive content. Using ‘sketchy’ styled controls
adds interactivity to your mock-ups: that means
textboxes that work like real textboxes, combo
boxes that really drop down, radio buttons and
checkboxes that work. Controls used in mock-ups
can load sample data, or you can go one step
further and consume services. Data validation
during the prototyping design phase – can it be
true?
The SketchFlow map of your application flow
quickly creates click-through prototypes and the
SketchFlow Player enables clients and users to

16

comment and mark up their feedback directly on
the designs. Importing feedback keeps it in one
place and creates a trail from review to revision.
These features and ease of use have given many
of us at Lab49 ‘SketchFlow fever’, and our positive
client reviews have proved it communicates the
message of our designs in a whole new way. Even
the directors and developers at Lab49 have created
mock-ups using SketchFlow on their own to
communicate functionality on their projects. Here,
I’ll use it to create a currency trade prototype.

START

New project Choose File > New Project…
> Silverlight 3 SketchFlow Application. Name the project
FXTraderDemo. Click OK. The SketchFlow Map should
appear in the bottom pane. On the top left we’ll be
working with the Assets tab to use Sketch-styled controls.

About the author
Name Kristie Weatherford
Job User experience consultant
Company Lab49
Areas of expertise Silverlight &
WPF, animation, interaction
Favourite ice cream
Dove Chocolate & Brownie Affair

2

Default page A default file, Screen1, will open. This
is the name that will display in the SketchFlow Player, so first
we should change this to FXTraderView by clicking the blue
screen in the map area. This will be the default page and
you can right-click and select Visual Tag > Red for emphasis.
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FXPart Layout Select Assets (top left). Expand
SketchFlow, expand Styles and select SketchFlowStyles.
Choose Rectangle-Sketch from the list. Draw a rectangle the
size of the UserControl. Go back to FXTraderView. From the
application menu, select Project > Build project.

6

Content Drag some ComboBoxItems from the Assets
panel to the ComboBox in the Objects and Timeline panel.
Name these with currency values to give interactivity to the
mock-up. Select button and change Content value to Done.
Click the Hide icon on the Front grid to go to the normal state.

Add screen In the SketchFlow Map, hover over
the FXTraderView screen. Select icon for Create and insert a
Component screen. A green screen appears; drag it out and
rename it FXPart. Select UserControl in Objects and Timeline.
In Properties panel, change Width to 300 and Height to 150.

Set up Back Return to FXPart component screen. Select
Rectangle; right-click. Select Group Into > Grid. Rename the grid
Back. Make a copy, rename it Front. Click Hide icon on Front grid
in Objects and Timeline. Ensuring Front is selected in Objects and
Timeline, add a SketchStyle Button and ComboBox to Back grid.

4

FXTraderView Layout From Assets, select
Project and Screen_1_1 our FXPart. Copy the component five
times. Arrange evenly in two columns and three rows. The
alignment guides added in Blend 3 should make this easier for
beginners; advanced users can use a Grid or a Uniform Grid.

5

7

Front Select the Front grid in Objects and Timeline.
Start adding TextBlocks, icons, TextBox and ComboBox using
the SketchFlow-styled controls from the Assets panel. Add
two rectangles and add TextBlocks to display the currency
and the rate of change. Add a red and green arrow.

8

9

Storyboard In Objects and Timeline, click the + icon
to create a new Storyboard. Name it Flip. With the yellow
slider at the 0 position on the timeline, select the Front grid
and create a keyframe (see Expert Tip, page 18). Move the
slider to the 0:00.100 position and create another keyframe.

10

Animations With the slider still at the second
keyframe and the Front grid selected, expand Transform in
the Properties panel. Select Scale. Change the X value to 0.
Select the Back grid in the Objects & Timeline panel. Create a
keyframe at the 0 mark. Set the Scale transform X value to 0.

11

Create Flip Create keyframes at 0:00.1.00 and 0:00.2.00 on the Back grid timeline. Change the Scale transform X
value to 1 at the third keyframe. Close the Storyboard (click the X next to its name top-left in Objects and Timeline) to
return to the default view. Select Grid in Objects and Timeline. Change Cursor value in Common Properties to Hand.
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More animation Click the New icon. Name the
new Storyboard FlipBack and select the Front grid. Create a
keyframe at the 0 position on the Front grid’s timeline and
set the Scale transform value to 0. Create another keyframe
at the 0:00.100 position and another at 0:00.2.00.

13

Flip back On the third keyframe on the Front grid
timeline, set the Scale transform value to 1. This makes the
front show again. Select Back grid. Create a keyframe at the
0 position. Set the Scale transform value to 1. Create another
keyframe at 0:00.1.00. Set the Scale transform value to 0.

14

Hook up the flip back Close the Storyboard.
Select the Front grid and Hide it to show the Back grid
content. Select the Done button. Switch the Properties
panel to Events. Double-click the Click value. FXPart’s code
behind the file will open with the event handler added.

15

Begin storyboard Remove placeholder code.
Write this.FlipBack.Begin(); to register the click event.
Return to FXPart’s design. Unhide Front grid. Select Settings
icon. Switch to Events in the Properties panel. Double-click
MouseLeftButtonDown. Remove comment placeholder code.

16

Run project Write this.Flip.Begin(); to register
the click event starting the Flip animation Storyboard. In the
Menu, select Project > Run Project. The SketchFlow Player
will launch. Click Settings icon. The Flip animation will hide
the Front grid and show the Back, creating a flipping effect.

17

Feedback & comments When reviewing your interactive SketchFlow mock-up with a client or team, feedback
can be captured directly in the SketchFlow Player. In the Feedback tab on the bottom left, type some comments and click the
+ icon. Select the pencil or highlighter to draw directly on the designs; use the eraser to remove your markings.

Expert tip Keyframes

18

More feedback Add feedback to the design
and click the folder icon for Feedback options. Select Export
Feedback. Enter author information. Click OK. Pick a place
to save the Feedback file and name it. Click Save to create
an XML feedback file that will be imported into the project.

18

19

Import feedback Close the browser. Select
Window > Feedback. Click the + icon. Browse to the saved
feedback file to import it to the project. Click the Lightbulb
icon to show and hide the ink markup notes. Feedback,
review and collaboration directly in the project!

Create keyframes on a storyboard timeline
by selecting the object you want to animate
in the Objects and Timeline panel and move
the yellow slider to the time position you
want to place your keyframe. Select the
Record keyframe icon located above the 0
position on the timeline to place a keyframe.
You can also position the yellow slider
where you want to animate an object, and
instead of recording a keyframe you can just
move the object or change a property and
Blend will record a keyframe automatically.
Advanced users can choose to apply Easing
functions to keyframes with Silverlight 3.
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Silverlight
the best of

A selection of sublime design and cutting-edge features
1-5 Wimbledon 2009
URL www.net5.nl/web/show/id=488596/langid=43
Built by SBS Broadcasting
Created by the SBS Broadcasting network in
Hollasnd, this 2009 Wimbledon site was a great
example of what can be done with Silverlight’s
streaming video (which now boasts H.264 and
AAC support). You can still watch the majority of
this year’s matches from the tennis tournament,
and relive those moments of Murray-mania that
had us all hooked (it’s also a nice reminder of
what British sunshine looks like, lest we forget).

3

1

2

1

4

6-10 Hard Rock Memorabilia
URL memorabilia.hardrock.com
Designed by Duncan/Channon
Built by Vertigo
4

One of the most high profile exponents of
Silverlight’s Deep Zoom technology has been
the Hard Rock Memorabilia site. You can view
thousands of items from the annals of rock history,
and seamlessly zoom in on extreme detail (to the
point where you can even make out individual
fingerprints!). There’s no need to wait for huge
downloads, because images are updated as you
close in on specific detail. The site, designed by
Duncan/Channon (www.duncanchannon.com) and
built by Vertigo (www.vertigo.com) in 2008, still
stands out as a shining example of Deep Zoom.
(Turn to page 22 to find out how to start using this
technology on your own websites.)
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1-5 Microsoft
Centre des Usages
URL www.microsoft.com/france/entreprises/
centre-des-usages/
Built by www.mrmworldwide.com
1

The Centre des Usages website was built for
Microsoft by MRM Worldwide. The aim of the site is
to educate French businesses on how Microsoft can
help them in different walks of life (whether in the
home, office or on the road). The site’s navigation
takes the form of a series of books that, as you
select them, pop open in the main content area of
the site. You can then interact with each pop-up
scenario. It’s a fantastic way to illustrate Microsoft
technologies working in a variety of scenarios.

4

6-10 Microsoft
Worldwide Telescope

URL www.worldwidetelescope.org/webclient/
Built by In house

5

4

6

8

10

3

Space is cool. And in the shape of the Microsoft
WorldWide Telescope, Microsoft Research has
produced a truly stunning piece of technology that
enables you to navigate your way around the great
beyond. Made up of a combination of satellite and
telescope images, this application uses Microsoft’s
Visual Experience Engine to provide you with the
ability to pan and zoom across the night sky. You’ll
need to hand over an extra chunk of your hard
drive to the app, but it’s well worth it. To infinity
and beyond ... No. You’re right. We should be
sensible about this. ENGAGE WARP DRIVE!

7
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Silverlight design
with Deep Zoom
Costas Brammer of high-end interactive production company Specialmoves
explains how to make best use of Silverlight’s powerful new feature

l CD
Your essentd ia
for this
The PDF file use
found on
tutorial can be
.
this issue’s CD

Expert tip Get creative
Deep Zoom has been used on some great
sites, such as Hard Rock Memorabilia (bit.
ly/ZUCGD) and Microsoft’s photosynth.net.
Both use layers of images, set at different Z
depths. If you need to do advanced zooming
to layers like this, you can either set this
up in Deep Zoom Composer or arrange the
layers programmatically. Unless you’re doing
something based on information retrieval,
try to be creative: many examples on the web
are just simple mosaics (though some are still
fun, such as bit.ly/p1VMJ).

What you’ll learn I’ll explain how import a high-res PDF into Deep Zoom Composer, an application dedicated to
the preparation of Deep Zoom content. We’ll then take this into Microsoft Expression Blend, where we’ll place it into an
empty Silverlight project and ready it for web export
Knowledge needed Basic understanding of
Photoshop and Microsoft Expression Blend
Requires Adobe Photoshop, Microsoft Blend,
Deep Zoom Composer
Project time 30 minutes
Deep Zoom is a great feature of Silverlight
(available as a free download at silverlight.net/
GetStarted), which is really so simple that you’ll
wonder why anyone else hasn’t released such a
tool until now.
Rather like the step up from the older, linearbased computer tapes to the quicker ‘random access
memory’ of hard drives, a Deep Zoom component
lets you see the overview of a data element (be it
a magazine article, picture or a map of the Earth)
then quickly home in on the detail you want. It’s like
browsing the index of a book then jumping straight
to the desired page, but with the smoothness of
Deep Zoom it becomes so much more.
In this tutorial, we’re going to run through the

22

process of taking pages from a magazine (ready for
print) and preparing those to use as a Deep Zoom
experience on the web. We’ll start in Photoshop
and then import the image into Deep Zoom
Composer. We’ll then take this into Expression
Blend, where we’ll place it into an empty Silverlight
project and ready it for web export.
The PDF used here is on the CD, but if you don’t
have Photoshop, find a folder of images (JPEG,
PNG, TIFF or BMP) and jump straight to Step 4. l

START

Photoshop Import the PDF you’re going
to use for your Deep Zoom experience into Photoshop.
Choose File > Open. Select NET192.pdf from the CD. When
the import dialog appears, select both page thumbnails,
and under Page Options, choose Trim Box.

About the author
Name Costas Brammer
Company Specialmoves
Site specialmoves.com
Areas of expertise Motion
visual effects, UXD design
Favourite ice cream Ben and
Jerry’s Chunky Monkey

2

Quality We want to keep the quality as high as
possible at this stage of the process, as the nature of Deep
Zoom is to allow high-res images to load quickly even on a
web connection. As this PDF was made for print, keep the
default setting of 300dpi. When you’re done, press OK.
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New Project With the images ready, open Deep
Zoom Composer (available as a free download). Select New
Project in the splash window. If the splash window doesn’t
appear on load, choose File > New Project. Name the
project Netzoom and save it to a directory of your choice.

6

Click and drag Click and drag the images so that
they sit next to each other – the auto-snapping in Deep
Zoom Composer is very accurate and in this case it should
work well enough that you don’t need to use any of the
other alignment buttons in the left-hand toolbar.

Flatten Flatten the images (Layer > Flatten Image)
and save them as a PNG. Deep Zoom supports a number of
popular image formats, but it’s always good to keep things
simple. Choose File > Save As, choose PNG as the format,
and name the files NET192A.png and NET192B.png.

Composer View Click on the Compose tab and
you’ll be presented with the Composer View. Drag both
images from the image gallery at the bottom onto the
artboard. You can use the Selection (arrow), Pan (hand) and
Zoom (magnifying glass) tools to navigate around.

4

Import A blank project will open and you’ll see
three tabs near the top of the window: Import, Compose
and Export. If the Import tab isn’t selected, click on it. Using
the Add Image button on the right, import the two PNGs
you saved from Photoshop (NET192A.png, NET192B.png).

5

7

Export Once you’re happy with the positioning,
you’re all ready to export. Click on the Export tab at the
top. You’ll now see two tabs on the right-hand panel:
DeepZoomPix and Custom. Click on the Custom tab and
you’ll be presented with a number of export options.

8

9

Output type Ensure the Output type is Silverlight
Deep Zoom, and type Net192 in the Name box. For export
location, select the directory in which you’d like the Deep
Zoom assets to be saved. Ideally, this will be the same folder
that contains the rest of your Silverlight project files.

10

Pre-generated template As this will be a
Blend project, we’ll choose Export as collection for image
type. This enables us to select a pre-generated template for
export from the drop-down list. Select Blend 3 Behaviors +
Source from the list.

11

Choose compression settings Keep the default image format settings. You’ll notice you have a choice of
JPEG or PNG compression – Blend treats both in the same manner, so it’s primarily a matter of personal preference.
Once you’re done, press the Export button.
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Preview After the export process, a menu bar
will pop up asking what you’d like to do next. You can now
select Preview in Browser to check how things are looking.
If this is all you need to do then you can finish the tutorial
here and load the generated files up to your website.

13

Edit If you want to edit the Deep Zoom Silverlight
application, select View Project Folder from the post-export
menu. You’ll see the DeepZoomProject files Composer has
created. Double-click on the DeepZoomProject.sln file, or
right-click and Open with…, to open the project in Blend.

14

Open in Blend When the project opens
in Blend, you’ll see the same layout as in Deep Zoom
Composer. Things get a little confusing here, as Blend calls
the Deep Zoom Component a MultiScaleImage component.
Run the project from Blend by pressing the F5 key.

15

Extreme pixellation Once the browser
has opened, zoom in as far as you can and take note of
the extreme pixellation. The screengrab shown above
demonstrates clearly how we can zoom in so far that we
lose the crispness of the image.

16

Set limits To fix the limits of how far the
zoom-in is premitted to go, we need to alter the default
code files generated for us from Deep Zoom Composer. In
the Projects view, find the file DeepZoomInitializer.cs and
double-click to open it.

17

Add code Scroll down to find the private function named Zoom. There’s already a snippet of logic to control how
far we can zoom out. Just add another bit of code directly under it to say if ( newzoom > 20.0 ) newzoom = 20.0;. This
locks the maximum zoom at 20x. Run the project again with F5 and test the zoom-in.

Expert tip Complex comps

18

And again The mouse wheel is now limited, but if
you use the button interface in the Silverlight control you’re
still able to zoom further than we’d like. Open DeepZoom_
ZoomIn.cs. Add if ( newzoom > 20.0 ) newzoom = 20.0;
into the zoom function as before, then test it with F5.

24

FINISH

Go further So there we have it – a Deep
Zoom-enabled magazine article with a quick look at how
to customise the zoom behaviour. Deep Zoom Composer is
much more advanced than this, however, and you can get
great effects by linking different layers of zooming images.

Be mindful of the final hosting solution
when working with complex Deep Zoom
compositions. For standard mosaic, you’ll
need around 12,000 images, stitched using
a free tool such as AndreaMosiac (www.
andreaplanet.com/andreamosaic) before
being processed with Deep Zoom Composer.
You can then export this into Blend or Visual
Studio to produce the Silverlight application
to host on the web. If you’re hosting the
Deep Zoom from your own website you
might need to change the mime type to
serve .xaml files.
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Win

expression –3 competition

a copy of

Microsoft Expression
Studio 3!
The release of Microsoft Expression Studio 3 is
great news for the web design and development
community. Its rich array of purpose-built tools
and technologies offer amazing possibilities to bring your
creative ideas to life.
First up, there’s website designer and HTML/CSS editor
Expression Web, which makes creating standards-based
websites faster and easier than ever. Its range of powerful
features includes SuperPreview – a visual tool for testing
websites in different browsers; Snapshot Preview – a
live rendering of your page that changes as you add or
adjust code; the ability to embed Deep Zoom images via
Silverlight; and much more.
Expression Studio 3 also comes with
Expression Blend, the latest version of
Microsoft’s interface builder for Silverlight
and Windows Presentation Foundation
applications. Exciting new features include
Behaviors – reusable components you can
drag onto your project to add interactivity
– and SketchFlow, a quick and easy way of
creating prototypes that demonstrate UI flow,
screen layout and application state transitions.
The suite also features Expression Design, a
professional design tool for creating graphics
content, with a wide range of powerful
importing, slicing and exporting capabilities.
Finally, there’s Expression Encoder 3, which
makes it easy to prepare video for use in a
variety of ways, including Silverlight on the web.
It’s the design suite your toolkit won’t be
complete without – and we’ve got 10 copies
to give away! For a chance to win, just go to
www.futurecomps.co.uk/expression2009 and
answer the following question. Good luck!

Question What’s the name of the new
prototyping tool in Microsoft
Expression Blend 3?

Terms and conditions Competition rules

Employees at Future
Publishing and Microsoft and their immediate families
and agents are not eligible to enter. No purchase of
.net magazine is necessary to enter the competition.
The editor’s decision is final and no correspondence
will be entered into. Microsoft has the right to
substitute the prize for a similar prize of equal or
higher value if the stated prize is not available.
There are no cash alternatives. The competition
closes on 30 November 2009.
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Rich Wand on…

Below the
Surface
Microsoft Surface is opening up a new world of gesture-based interactions – and designing
for it requires a whole new range of skills, explains Rich Wand of EMC Conchango
With a wave of gestural mobile devices
and gaming systems flooding the
market, more and more people are
interacting directly with digital content – click
is fast being replaced by tap, flick and pinch.
Microsoft recently announced Natal, a sensorbased interface that responds to contact-free
gestures such as a wave and a nod. And while we
eagerly await this technology to come to market,
there’s plenty to be excited about already with
the launch of Microsoft Surface.
Surface incorporates the naturalness of handgesture recognition but also blends reality and
virtual reality by enabling users to interact with
digital content using ‘real’ physical objects. From a
design perspective there are a lot of new principles
to master. Designing a Surface experience is not
the same as designing for traditional websites.

“Designing for
Surface is not the
same as designing
for traditional
websites”
Rich Wand

26

The key is to avoid retrofitting existing
experiences and introduce new ways of thinking
that enable new interaction models. For those
looking to get involved in this new era of
interaction design, here are some pointers:
Make it finger-friendly: Fingers don’t have
the same level of precision as a mouse, so make
sure all interactive elements are sized and spaced
to optimise gestural interactions.
Encourage active exploration: Don’t make
users memorise how to do things. Make the
experience discoverable and reward the user for
exploring. Nudge and entice users to do more.
Enhance the user’s sensory experience:
Don’t just focus on visual experiences. Surface
doesn’t just encourage but mandates a fuller
sensory experience. Use sound to reinforce user
interactions and create fuller sensory experiences.
Encourage social participation: Surface
moves beyond solitary desktop experiences.
Design your application to invite people to join
in and encourage person-to-person interactions.
Consider the challenges of multi-stranger versus
multi-friends scenarios and different levels of task
coupling. For example, how do the actions of one
user affect the other? What happens when new
people approach the table from a different side?
Make it alive: Ensure every action has an
immediate response, regardless of how subtle this
feedback is. Even if no one is interacting, don’t let
the Surface device sit there lifeless.

Make it magical: Add a certain amount
of realism but then augment it further with
something that doesn’t exist in the real world.
For example, use real-world behaviour such as
acceleration but then disrupt the physics in a way
that only a digital experience can.
Make the interface invisible: In a Surface
experience, the interface shouldn’t be visible as
the content becomes the interface. Design an
interface-free application that enables users to
directly manipulate the digital content.
Remember the enjoyment factor: Playfulness
can manifest itself in many forms, such as
through copy or interaction design, not to forget
playfulness through interaction with other people.
Don’t ignore this important dimension in designing
engaging and immersive experiences.

Where do we go from here?
Different gestural interfaces will bring different
design philosophies and with this fresh and
exciting challenges. Erase your mind to a world
without GUIs and design with no preconceptions
of interactions models that have been. Don’t
underestimate what seem to be simple applications
– often the simplicity masks the complexity.
Rich Wand is a senior user experience consultant at
EMC Conchango. He works on digital experiences
for the web and beyond. He’s at his happiest
working when there is no mouse in sight.

in association with Microsoft

MS_expression 26

6/11/09 12:41:07

expression–3 glossary

Expression– 3
Useful design and development terms

Deep Zoom
Cool Silverlight
feature in Expression
Web 3 and Deep
Zoom Composer that
enables users to
pan around and
zoom in a large, high
resolution image or
a large collection
of images.

Expression
Blend 3
The latest version
of Microsoft’s
user interface
builder for Silverlight
and Windows
Presentation
Foundation
applications.

Expression
Design 3
The latest version
of Microsoft’s
illustration and
vector graphics
design tool.
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Expression
Encoder 3
The latest version
of Microsoft’s video
encoding tool.

Expression
Studio 3
The latest version
of Microsoft’s
Expression Suite,
which includes
Expression Web 3,
Expression Blend 3,
Expression Design
3, and Expression
Encoder.

Expression
Web 3
The latest version of
Microsoft’s website
designer and
HTML/CSS editor.

IIS Smooth
Streaming
Technology that
enables adaptive
streaming of
media, providing a
stutter free viewing
experience for
viewing true
HD media
(720p+) online.

Silverlight 3
The latest version
of Microsoft’s
plug-in for the
creation of rich web
applications that
run on Mac OS,
Windows and Linux.

SketchFlow
A tool in Expression
Blend that enables
you to quickly create
prototypes that
demonstrate UI flow,
screen layout and
application state
transitions.

Snapshot
Preview
Page preview feature
in Expression Web 3.
It provides a live
rendering of web
pages that changes
as you add or adjust
the underlying code.

Surface
A revolutionary
multi-touch
computer with a
large, horizontal
user interface.
Surface responds
to natural hand
gestures and
real-world objects,
helping people
interact with digital
content in a simple
and intuitive way.

Visual Studio
An Integrated
Development
Environment (IDE)
that can be used
to develop console
and graphical
user interface
applications,
Windows Forms
applications,
websites, web apps,
and web services.

SuperPreview
Visual tool in
Expression Web 3 for
testing websites in
different browsers.
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