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Chapter 10

Create Effective Marketing Materials 
with Publisher 2010

In this chapter:

n	 Starting Out with Publisher 2010

n	 Creating and Using Templates and Building Blocks

n	 Creating Precise Layouts

n	 Enhancing Typography with OpenType Features

n	 Working with the Improved Color Palette

n	 Previewing and Printing Publications

n	 Preparing for Commercial Printing

n	 Sharing Publisher Files

How do you create your marketing materials today? If you are spending a big portion of your 
budget outsourcing four-color postcards, brochures, newsletters, and more, you can do the 
job closer to home with Publisher 2010 and save money, time, and effort. What’s more, you 
can create and save reusable content—called building blocks—that you can insert in future 
materials, which helps you ensure that your messaging stays consistent no matter what kinds 
of materials you create.

Improvements in Publisher 2010 make it easier than ever to create new files using both 
built-in and community-submitted templates. New layout tools help you align objects, place 
captions, and position elements on the page in accurate and aesthetically pleasing ways. You 
can also spruce up your photos with artistic effects, improved editing tools, and support for 
OpenType features such as ligatures and stylistic sets.

Starting Out with Publisher 2010
The Microsoft Publisher 2010 window gives you plenty of room to work on screen, while 
keeping the tools you need within reach. (See Figure 10-1.) The Ribbon includes seven tabs—
File, Home, Insert, Page Design, Mailings, Review, and View—and each tab contains groups 
of tools related to the tab topic. On the Insert tab, for example, you’ll find Picture in the 
Illustrations group, enabling you to add pictures to the current page with just a few clicks of 
the mouse. 
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Page Navigation Pane

Ribbon Work area

Scratch area View controls

FIGURE 10-1 The Publisher 2010 window includes the Ribbon and the Page Navigation pane.

The Publisher window also includes a scratch area surrounding the entire publication. The 
scratch area enables you to place objects partially off the page so that you can create bleeds 
(photos, backgrounds, or other graphical elements that print all the way to the edge of the 
page). In Publisher 2010, you can choose to hide or display the scratch area so that you can 
see the overall design, including bleeds, as well as the page as it will appear when printed.

Collapse and Expand Page Navigation Pane
The Page Navigation pane along the left side of the window displays thumbnails of the pages 
in the current document, which enables you to get a sense of the document flow and over-
all layout at a glance. You can use the Page Navigation pane to scroll through the different 
pages in your document, checking text flow, placement of illustrations, format of headings, 
and other parts of the design.
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If you want to increase the amount of space available for the current page, you can collapse 
the Page Navigation pane, which reduces the size of the displayed thumbnails. To expand the 
pane, simply click the Expand button at its upper-right corner.

Use the Mini Toolbar
Now Publisher 2010 also includes the Mini Toolbar, a set of text-formatting tools that appears 
when you select text in your document. When the Mini Toolbar first appears, it is transparent; 
when you point to the toolbar it becomes solid, as Figure 10-2 shows. If you move the mouse 
pointer away from the toolbar, it disappears altogether. In this way, the tools are within reach 
if you need them, but they fade away if you don’t.

FIGURE 10-2 The Mini Toolbar displays formatting tools when you select text.

Tip If the Mini Toolbar doesn’t appear automatically when you select text in your document, 
you can turn the feature on by clicking File and choosing Options. On the General tab, click the 
Enable The Mini Toolbar option.

Creating and Using Templates and Building Blocks
Publisher 2010 offers dozens of built-in templates you can use to create letters, newsletters, 
brochures, business cards, calendars, labels, and much more. When you choose to create a 
new publication based on a template, you can use one of the templates installed with the 
software or access templates available online in the Publisher community. (See Figure 10-3.)

In addition to using templates to start your publication, you can add predesigned elements 
to your pages by choosing from a gallery of page parts, known as building blocks. Building 
blocks are available in the Page Parts tool in the Building Blocks group of the Insert tab. 
(See Figure 10-4.)
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FIGURE 10-3 You can choose to begin a new publication based on an installed or online template or create 
your own design on a blank page.

Tip A building block is a part of a page that you might want to use regularly in your publications. 

By default, Publisher includes headings, pull quotes, sidebars, and stories in the Page Parts 
gallery of the Building Blocks group on the Insert tab. You can insert the building blocks as 
they are and then customize them to fit your publication, or you can create your own Page 
Part and then save it as a building block. Either way, the building blocks feature can save 
you time and effort and help you provide a consistent look and feel among the various 
publications you create.



	 Chapter 10  Create Effective Marketing Materials with Publisher 2010	 133

FIGURE 10-4 Page Parts can save you time and add a professional touch to your page design.

Step by Step: Creating a Building Block
Here’s how to create a new building block in Publisher 2010:

	 1.	 Open the Publisher document you want to use.

	 2.	 Create and select the element you want to save as a building block. Hint: You 
might want to save a page heading, report title, pull quote, table, or other 
often-used element.

	 3.	 Right-click the element you selected and choose Save As Building Block.
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	 4.	 In the Create New Building Block dialog box, shown here, enter a title and 
description.

	 5.	 Click the Category arrow, and choose the category that best applies to the type 
of element you’ve created.

	 6.	 Click OK to save the building block.
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Creating Precise Layouts
Publisher 2010 also includes dynamic layout guides to help you position elements precisely 
on the page. Guides appear automatically as you drag an object—text, picture, or shape—on 
the page. Turn on the display of guides by clicking Guides in the Show group of the View tab.

Vertical and horizontal guides help you ensure you’re positioning elements so that they 
align with other objects on the page. Guides appear and disappear as you drag the ob-
ject so that they take up space on-screen only in the areas where you need to use them. 
(See Figure 10-5.)

Horizontal
guide

Center
guide

FIGURE 10-5 Publisher 2010 provides dynamic guides that help you place objects on the page.

Enhancing Typography with OpenType Features
Both Publisher 2010 and Word 2010 are now able to make use of OpenType features such 
as ligatures and stylistic sets in the fonts that offer them. Ligatures are a combination of two 
letters shown typographically as a single character in some fonts. For example, the letters 



136	 Part II  Hit the Ground Running

fi in some typefaces are placed close together and shown as a single character. This type of 
text control is used most often in high-quality typography work.

Similarly, stylistic sets offer a variety of appearances in the selected font. The Typography 
tools are found on the Text Box Tools Format tab, which appears when a text box is selected 
in your Publisher document. Figure 10-6 shows some of the stylistic sets available for the 
Gabriola font. 

FIGURE 10-6 Publisher 2010 enables you to take advantage of professional typography features available 
with some OpenType fonts.

In addition to ligatures and stylistic sets, Publisher 2010 also supports number styles, 
stylistic alternates, and swash features. Figure 10-7 shows the primary Typography tools, and 
Table 10-1 provides a description of each one.

FIGURE 10-7 Publisher 2010 offers different OpenType features you can apply to fonts that support them.
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TABLE 10-1  Typography features in Publisher 2010

Tool Description

Ligatures Enables you to choose whether to use ligatures in the document (and, 
if so, what kind)

Number Style Sets the appearance of numerals in the selected font in the current 
document

Stylistic Alternates Offers alternate characters you can use in the text in your document

Stylistic Sets Displays a gallery so that you can choose the format style of the 
selected font

Swash Works as a toggle, and turns on or off decorative text elements 

Tip Publisher 2010 also includes Paste with Live Preview, which enables you to preview the way 
an object will look before you paste it in your Publisher document.

Working with the Improved Color Palette
Publisher 2010 updated its color palette to include elements that help you keep a consis-
tent look and feel throughout the materials you create. Now you can stay true to the color 
scheme you selected and apply a variety of tints, shades, and gradients to the text and 
shapes on your pages. You’ll find the new palette on all border and fill tools—for example, 
Figure 10-8 shows the color palette that appears when you click the Shape Fill tool in the 
Shape Styles group of the Drawing Tools Format tab. 

FIGURE 10-8  The improved color palette now displays color scheme selections and expanded color choices.
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Previewing and Printing Publications
The Print feature in Publisher 2010 now enables you to preview, adjust, and print all in the 
same screen in Backstage view. (See Figure 10-9.) When you click the File tab and click Print, 
you see the current page of your open publication, complete with the page margins, headers 
and footers, and more. You can easily choose the print options you need—for example, se-
lect the printer you want to use, choose the print layout and paper style, and select whether 
you want to print as an RGB color publication or a composite black and white.

FIGURE 10-9 The Preview And Print interface in Publisher 2010 enables you to make last-minute changes and 
print, all from the same screen.

Have you ever printed a double-sided report only to find out that the image on the back of 
the page made the text on the front hard to read? Publisher 2010 includes a backlight fea-
ture that enables you to see through the page on double-sided publications so that you can 
avoid that kind of situation in the future. When you choose two-sided printing in the print 
options, the Decrease Transparent View and Increase Transparent View tools appear at the 
upper-right corner of the preview window. (See Figure 10-10.) To change the transparency 
and display the back of the page while you’re looking at the front, drag the Transparency 
slider to the right. You can also turn the page and view the transparency from another 
perspective using the Front and Back tools at the bottom of the preview area.
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FIGURE 10-10 The Transparency tools become available when you choose two-sided printing.

Tip  Before you finalize your design, be sure to run the Design Checker to identify and correct 
design problems in the publication. You’ll find the Design Checker on the Info tab of Backstage 
view.

Preparing for Commercial Printing
Publisher 2010 includes expanded support for the four-color process and spot color printing, 
including CMYK composite postscript and Pantone colors (both PMS and the new Pantone 
GOE color system). You’ll find the tools you need to prepare a file for commercial printing by 
clicking the File tab to display Backstage view. Click Info, and click Commercial Print Settings. 

Commercial Print Settings enables you to choose the color model you want to use, work 
with the embedded fonts in your publication, and manage the registration of the document. 
(See Figure 10-11.) When you’re ready to finalize the file, click File and in Backstage view, click 
Share and choose Save For A Commercial Printer.
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FIGURE 10-11  Commercial Print Settings enable you to prepare your publication for professional printing.

Sharing Publisher Files
You can share the files you create in Publisher 2010 in various ways. You can e-mail pages 
from within Publisher, create a PDF/XPS document, publish the document as HTML, save the 
piece for a commercial printer, or save the publication for another computer. You’ll find these 
options in the Share tab of Backstage view.

Tip Before you send your Publisher document by e-mail, you can preview it by clicking File 
to display Backstage view and choosing Share. Click E-mail Preview to display a version of the 
document as it will appear to the recipient. 
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