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Automate tasks with Visual Basic macros

If you're not familiar with macros, don't let the term frighten you. A macro is simply a recorded set of
keystrokes and instructions that you can use to automate a task that you don't want to do from scratch
each time. For example, you might record a macro to apply specific page margins, insert a customized
bulleted list, or insert a complex table. Take this tutorial to learn how.
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Before you begin

What you'll learn
After completing this tutorial, you'll be able to:
* Show the Developer tab on the ribbon.
* Record a macro to insert a stylized table.
* Assign a keyboard shortcut to a macro.
* Run arecorded macro.

e Edit a macro.

Requirements
*  Word for Mac 2011

* Basic Word skills, including how to open a document, cut and paste, and format text.

Estimated time to complete: % 25 minutes
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1. Show the Developer tab

The Developer tab is a specialized ribbon tab that contains commands for working with macros. By
default, the Developer tab does not appear on the ribbon.

Let's show the Developer tab on the Word ribbon.

Important This tutorial uses Word to demonstrate how to work with macros. However, the principles
are similar in Excel.

é/ In Word, click File > New Blank Document.

New Blank Document [ #N
New from iempiate... 1irasP

Open... #0
Open URL... 4 ¥#0
Open Recent >

2

“=7  On the ribbon, click Ribbon Options, and then click Ribbon Preferences.

)

.Qv ( Search in Document I

| A

Insert : Theme

B . TextBox Shape Picture . Themes :

Ribbon Preferences... R
Customize Ribbon Tab Order
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\3/ In the Tab or Group Title box, select the Developer check box, and then click OK.

Ceneral
™ Turn on the ribbon
g Expand ribbon when document opens
() Hide group titles

Customize

e

Appearance: | Word Blue
Show or hide tabs, or drag them into the order you prefer:
Tab or Group Title

M Tables

gCham

™ Smartart

PulTisiig cayout view

M tiome

o

Description of preference

OK
Closes this dialog box and saves any changes you have made.

(o (E)

& Notice that the Developer tab now appears on the ribbon.

. Document1
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; Form Controls
& [Aa] TextBox (v Combogox [=] insent Frame

e (V] CheckBox | Options  HAYF

Hints

* To rearrange or remove ribbon tabs from the ribbon, click Ribbon Options, and then click

Customize Ribbon Tab Order.

Before you move on
Make sure that you can do the following:

* Show the Developer tab on the ribbon.
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2. Assign a keyboard shortcut to a macro

Before you begin recording a macro, you have the option to assign it a keyboard shortcut. By assigning a
keyboard shortcut to a macro, you will be able to run the macro at any time by pressing the shortcut keys.

Let's assign a keyboard shortcut to the macro that we will record in the next lesson.

\1/ On the Developer tab, under Visual Basic, click Record.

Layout l Docum

B B2 e

Editor Macros | Record | Pause

Visual Basic

2 In the Macro name box, type MySpecialTable, and then click Keyboard.

Macro name:

[MySpeciaITabIe l

Assign macro to

P

Toolbars | Keyboard

LJ Note Macro names cannot contain spaces or special characters, such as @ or !.

3 Make sure that the cursor is in the Press new keyboard shortcut box, and then press

$8+OPTION+T.
|

Press new keyboard shortcut: [Command+0ption+T

Currently assigned to:

' Description

Save changes in: | Normal.dotm )
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L Note If the keyboard shortcut is assigned to another command, the command will appear next to
Currently assigned to. If you assign a different keyboard shortcut, make a note of the shortcut since you

will use it in a later lesson.

4 Click Assign. The shortcut appears in the Current keys box. Then click OK.

Commands:

' Normal NewMacros MySpecialTable

Categories:

Current keys:
[ Remove

[] Command +Option+T ]
)

Press new keyboard shortcut: [

Description

Save changes in: [ Normal.dotm  8) ( Reset All... ) @

“=“ Notice that the Record button on the Developer tab now appears as Stop. Word is now in macro

recording mode.

Layout | Docum

* =[O @

Editor  Macros Stop Pause

Hints
* By default, a macro is saved so that it can be used in all documents that are based on the Normal
template (Normal.dotx). To restrict a macro to the current document, in the Record Macro dialog
box (shown in step 2), on the Store macro in pop-up menu, click Document1 (document), where

Document] is the name of the current document.

Before you move on
Make sure that you can do the following:

Assign a keyboard shortcut to a macro.
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3. Record a macro

To record a macro, you simply step through the task as you would normally. As you perform the task,
Word records each click, keystroke, and any text that you type as VBA code that you can edit later.

Let's record a macro that will insert a stylized, two-column "Question and Answer" table.

Important You must follow the steps in lesson 2 before you complete this lesson.

\!'/ On the Tables tab, under Table Options, click New, then drag to create a 2 x 6 table.

® 00

A Home Layout Document Elements Tables

J Table Options

¥ mm Header Row First Column

=== Total Row Last Column

New _ Randed Rows  Randed Columnsg
2 x 6 Table E

{0 [ O [ |
I O I |
O I I [ O
{0
{0 [ |
O I I [ O |
OCnEEoo
(1 syt 1 1]

L
IHTRIRIRI]
L
IHTRIRTAI
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2 Hold down SHIFT and OPTION, and press the right arrow key on your keyboard until the table is

selected as shown below.

LJ Note When recording a macro, you cannot use the mouse to select, copy, or drag content in the
document. To record these actions, you must use the keyboard.
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@J Under Table Styles, click Light Shading - Accent 1.

S

K‘) On the Tables tab, under Draw Borders, click Borders, and then click All.

> [ Search in Document

Outside
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P

Type Question, press TAB, and then type Answer.

Question

Answer

On the Developer tab, click Stop. The macro is now recorded and saved

\ A Home ‘ Layout | Docum

Visual Basic

= &

Editor  Macros

Hints

When you record your own macros, it is important to carefully plan what you want to record. The

macro recorder records every keystroke and click, which can lead to inefficient macros if you
record a lot of unnecessary keystrokes.

To pause while recording a macro, on the Developer tab, click Pause.

Before you move on

Make sure that you can do the following:

Record a macro to insert a two-column table.
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4. Run the macro
When you run a macro, Word performs the sequence of tasks that you recorded.

Let's run the macro by using the assigned keyboard shortcut and by using a command on the Developer
tab.

\}/ Click File > New Blank Document.

New Blank Document [ #N ]
New from iempiate... &P

Open... #0
Open URL... 430
Open Recent >

Z Press 38+OPTION+T.

L Note If you assigned a different keyboard shortcut in the earlier lesson, press that shortcut instead.

é/ Click below the inserted table, and then press RETURN to insert a blank line.

Question Answer

““  On the Developer tab, under Visual Basic, under Visual Basic, click Macros.

l A Home l Layout | Docum

Visual Basic

OXO,

Editor | Macros | Record Pause
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> Click MySpecialTable, and then click Run.

Macro name:
[ MySpecialTable ]

pecialTable Cancel

Jihll

Create
Delete
Organizer...
Macros in: [ All active templates and documents I-ﬂ

Description:

LJ Note If you don't see your macro in the list, on the Macros in pop-up menu, click All active
templates and documents.

O Notice that Word inserts a table each time that you run the macro.

Question Answer

Question Answer
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Hints

* To change the keyboard shortcut assigned to a macro, click View > Toolbars > Customize
Toolbars and Menus. Then, on the Commands tab, under Categories, click Macros. Click the
macro that you want to change the shortcut for, and then click Keyboard.

* To change macro security warnings, click Word > Preferences. Then, under Personal Settings,
click Security. The option is listed under Macro Security.

Before you move on
Make sure that you can do the following:

* Run a macro by using the assigned keyboard shortcut and by using the Macros command on the
Developer tab.

5. Edit the macro

When you record a macro, Word automatically translates each keystroke and click into VBA code. For the
macro that you just recorded, the code specifies that the macro will insert a 2 x 6 table, plus all of the
placeholder text that you typed. You can modify the code, and thus the actions that the macro performs,
by using the built-in Visual Basic Editor.

Let's edit the macro so that the inserted table includes three columns instead of the original two.

- Note Advanced macro editing is beyond the scope of this tutorial. For additional information about
editing macros and the Visual Basic Editor, see Visual Basic Documentation.

1 On the Developer tab, under Visual Basic, click Editor.
®00
Pl = oo L
1 A Home | lLayout = Docum
Visual Basic

AEz © W

Editor | Macros Record Pause
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2 Notice that the window contains code for the table that you created .

000 Project

D=
+ 38 Normal (Normal.dotm)
¥ [17 Microsoft Word Objects
# ThisDocument

v D Nkrown w«a Objects

(General) B MySpecialTable

2, DefaultTableBehavior: «wdWord9TableBehavior, AutoFitBehavior = _
wdAutoFitFixed

Sub MySpecialTable( s
[' MySpecialTable Macro ]
ActiveDocument.Tables Add Range: =Selection.Range, NumRows =6, NumColumns:= _

™ ThisDocument Selection. MoveRight Unit:«wdWord, Count:«13, Extend: «wdExtend
V[ References Selection.Tables(1).Style = "Light Shading - Accent 1°
B8 reference to Normal With Selection.Borders(wdBorderTop)
¥ e oAk o L
v n ons.Default n
- e e aerd Oblects ‘Color = Options.DefaultBorderColor
ument End With
¥ References With Selection.8orders(wdBorderLeft)
& Reference 1o Normal .LineStyle = Options.DefaultBorderLineStyle
LineWidth = Options.DefaultBorderLineWidth
.Color = Options.DefaultBorderColor
End With
With Selection.Borders(wdBorderBottom)
& .LineStyle = Options.DefaultBorderLineStyle
; .LineWidth = Options.DefaultBorderLineWidth
.Color = Options.DefaultBorderColor
End With

With Selection.Borders(wdBorderRight)
.LineStyle = Options.DefaultBorderLineStyle
LineWidth = Options.DefaultBorderLineWidth
.Color = Options.DefaultBorderColor -

End With |4

v
4

D Note If the code doesn't appear, in the Project window, under Modules, double-click NewMacros.

\3/ In the code, after NumColumns:=_, replace the 2 with a 3.

(General) B MySpecialTable B

Sub MySpecialTable()

' MySpecialTable Macro

ActiveDocument.Tables.Add Range:=Selection.Range, NumRows:=6, NumColumns:=
DefaultTableBehavior:=wdWord9TableBehavior, AutoFitBehavior:= _
wdAutoFitFixed
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At the bottom of the window, select the lines of code shown below, and then click Edit > Copy.

End With

With Selection.Borders(wdBorderVertical)
.LineStyle = Options.DefaultBorderLineStyle
.LineWidth = Options.DefaultBorderLineWidth
.Color = Options.DefaultBorderColor

End With

election.
Selection.MoveRight Unit:=wdCell
Selection.TypeText Text:="Answer"

end Sub

\5/ In the code, click after the quotation mark that follows Answer, press RETURN, and then click Edit >
Paste.
End With
Selection.TypeText Text:="Question"
Selection.MoveRight Unit:=wdCell
Selection.TypeText Text:="Answer"
Selection.MoveRight Unit:=wdCell
Selection.TypeText Text:="Answer"
End Sub
=S

L Replace the second instance of Answer with Comments.

End With
Selection.TypeText Text:="Question"

Selection.MoveRight Unit:=wdCell
Selection.TypeText Text:="Answer"
Selection.MoveRight Unit:=wdCell

Selection.TypeText Text::

End Sub

S

'H'é

Microsoft Office for Mac 2011 tutorial: Automate tasks with Visual Basic macros

13



z/ Click Word > Close and Return to Microsoft Word.

About Microsoft Visual Basic...

Preferences...
Services

Hide Word
Hide Others
Show All

3,

>

#EH
X #H

[ Close and Return to Microsoft Word [ $Q ]

) Below the existing table, press RETURN, and then press 38+OPTION+T (or the keyboard shortcut that

you assigned in the earlier lesson).

3 Notice that the macro now inserts a three-column table that is based on the edited code.

Question Answer

Question Answer

Question Answer Comments
Hints

* To edit a macro other than the one just recorded, on the Developer tab, under Visual Basic, click

Macros. Select the macro that you want to edit, and then click Edit.

* To delete a macro, on the Developer tab, under Visual Basic, click Macros. Select the macro that
you want to delete, and then click Delete.

Before you move on
Make sure that you can do the following:

* Edit a macro by using the built-in Visual Basic Editor.
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Quick Reference Card

To

Do this

Show the Developer tab
on the ribbon

Begin recording a macro

Assign a keyboard
shortcut to a macro

Restrict a macro to the
document in which it is
recorded

Pause while recording a
macro

Run a macro

Edit a macro

Delete a macro

Change the keyboard
shortcut for a macro

Click the Ribbon Preferences gear, then click Ribbon Preferences. Select the
Developer check box.

Plan the sequence of steps for the task that you want to perform (for example,
inserting a stylized table). Then, on the Developer tab, under Visual Basic,
click Record.

Begin recording a macro. Then, under Assignh macro to, click Keyboard, and
then press the keyboard shortcut that you want (for example, 38+OPTION+T).

Begin recording a macro. Then, on the Store macro in pop-up menu, click
Documentl (document), where Document1 (document) is the document in
which the macro is being recorded.

On the Developer tab, under Visual Basic, click Pause.

Press the keyboard shortcut that you assigned to the macro. Or, on the
Developer tab, under Visual Basic, click Macros, click the macro, and then
click Run.

On the Developer tab, under Visual Basic, click Macros. Click a macro in the
list, and then click Edit.

On the Developer tab, under Visual Basic, click Macros. Click a macro in the
list, and then click Delete

Click View > Toolbars > Customize Toolbars and Menus. Then, on the
Commands tab, under Categories, click Macros. Click the macro that you
want to change the shortcut for, and then click Keyboard.

More Hints

* The Developer tab is a specialized ribbon tab that contains commands for working with macros.
By default, the Developer tab does not appear on the ribbon.

* You can use commands on the Developer tab to record and edit macros in Word, Excel, and

PowerPoint.

*  When you record your own macros, it is important to carefully plan what you want to record. The
macro recorder records every keystroke and click, which can lead to inefficient macros if you
record a lot of unnecessary keystrokes.

* Macro names cannot contain spaces or special characters, such as @ or !.

e By default, a macro is saved so that it can be used in all documents. You can however restrict the
macro to the document in which it is recorded.

*  When you record a macro, Word automatically translates each keystroke and click into VBA code.
You can modify the code, and thus the actions that the macro performs, by using the built-in

Visual Basic Editor.
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