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Infroduction

You can use Microsoft Visual SourceSafe (VSS), Microsoft Visual Studio Team Foundation
Server (TFS), or MorphX VCS for version control in Microsoft Dynamics AX 2009. This document
describes how 1o set up the Version Control System (VCS) for Microsoft Dynamics AX 2009 by
using VSS as your VCS. The steps involved in setfting up version control by using VSS are:

e Set up Microsoft Visual SourceSafe on the version control server.
o Setup Team Server (the ID server) on the Team Server computer.

e Set up Microsoft Dynamics AX 2009 and the Microsoft Visual SourceSafe client on the
administrator computer.

o Configure version control settings in Microsoft Dynamics AX 2009.

Version Control System Considerations

Before you configure Microsoft Dynamics AX 2009 to utilize VSS for version confrol, review the
requirements and features of each of the VCS options. For more information about VCS
opftions, see the version control documentation in Microsoft Dynamics AX 2009.

Setup overview

Source Control Team Server computer | Administrator and
Server developer computer

Computer Windows Server Supported Operating o  Supported Operating
configuration 2003, Windows XP, System (See Set up the System (See Set up the
Windows 2000, or Developer and Developer and
Windows NT 4.0 with Administrator Administrator
SPé or later, Computers later in this Computers later in this
e Microsoft Visual document) document)
SourceSafe e Team Server e Microsoft SQL Server or
database on Oracle
Microsoft SQL Server o Microsoft Dynamics AX
or Oracle 2009 application, AOS,
and client

e Visual SourceSafe client

Tasks e Install and set up e Install and set up e Installon each
(Admin) (Admin) computer (Admin and
developers)

Install and Set Up the Team Server (ID Server)

Note: Team Server should not be confused with Team Foundation Server. Team Server is
an ID server that handles the task of issuing unique IDs to objects and labels when they
are created.

See the Team Server (ID Server) Setup Whitepaper to set up Team Server at
http://go.microsoft.com/fwlink/2Linkld=120292.
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Install and set up the Microsoft Visual SourceSafe Server

Install Microsoft Visual SourceSafe on the VSS server computer.

1.
2.

Start Setup.exe.

Enter your VSS product key, read the Microsoft Software License Terms, select | accept
the terms of the License Agreement, and then click Next.

Select Default to install the default features.

Click Finish when the setup is complete.

Create a New VSS Database on the VSS Server

1.

6.

Click Start > All Programs > Microsoft Visual SourceSafe > Microsoft Visual SourceSafe
Administration.

Click File > New Database, and then click Next.

In the Location fext box, type the path and folder name of the database, and then click
Next.

Type a name for the new VSS database, and then click Next.

Select the Lock-Modify-Unlock Model check box for the pessimistic concurrency model,
or select the Copy-Modify-Merge Model check box to allow for concurrent
development; and then click Next.

Click Finish.

Create a New VSS Database on the VSS Server

On the VSS server computer, open Microsoft Visual SourceSafe.
In the VSS database, right-click the root node ($/), and then select Create project.

Type a name for the project that will hold the Microsoft Dynamics AX 2009 objects. For
example, Ax2009.

Share the VSS Database Folder on the Server

o > 0N

Right-click the VSS database folder, and then select Sharing and Security.
Click Share this folder.

Click the Permissions button.

In the Group or User names pane, select a user group, a user, or Everyone.

Select the check box to Allow Full Control, and then click OK twice.

Protect the Global Version Control Settings

We recommend that you grant write access to the vesdef.xml file on the VSS server only to
the administrator.

1.

Click Start > All Programs > Microsoft Visual SourceSafe > Microsoft Visual SourceSafe
Administration.

Click Tools > Options.

On the Project rights tab, select Enable Rights and Assignments commands, and then
click OK.

Click Tools > Rights by project.
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5. Expand the project nodes, and then select the Definition node.

6. Select all of the developers in the users’ list, and clear the Check Out/Check In check
box. This enables read-only access to all developers, and the administrator keeps alll
rights.

Set up the Developer and Administrator Computers

Install the Operating System
See http://go.microsoft.com/fwlink/2Linkld=113164&clcid=0x409 for system requirements.

Install MS SQL Server or Oracle

See http://go.microsoft.com/fwlink/2Linkld=113164&clcid=0x409 for system requirements.

Install Microsoft Dynamics AX 2009

See http://go.microsoft.com/fwlink/2Linkld=117123 for access to the Microsoft Dynamics AX
Implementation Guide.

Install the Microsoft Visual SourceSafe Client on Each Developer Computer
1. Start Setup.exe.

2. Enter your VSS product key, read the Microsoft Software License Terms, select | accept
the terms of the License Agreement, and then click Next.

Select Custom, and then click Next.
4. Select Visual SourceSafe and Documentation (optional), and then click Next.

5. Click Finish when installation is complete.

Connect the VSS Client to the VSS Server Database

This optional step verifies that the installation succeeded and that you can see the VSS
server.
1. Click Start > All programs > Microsoft Visual SourceSafe > Microsoft Visual SourceSafe.

2. Click File > Open SourceSafe database.

3. Click Add, and then click Next.

4. Select the Connect to an existing database option, and then click Next.
5

Type the path of the VSS database folder on the server, click Next twice, and then click
Finish.

6. Click Open.

Set Up Local Version Control Parameters (Developer and
Administrator)

Create a Local Repository Folder

1. Open Windows Explorer.

2. Create a new folder to use as the local repository folder. For example,
C:\VCS_Repository.
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Note: Consider the folder you choose for the local repository folder. If a VSS client that
runs against the VSS server shares a local repository folder with a Microsoft Dynamics AX
2009 client and a change is checked in by using the VSS client, the Microsoft Dynamics
AX client will not reflect those changes when you synchronize the Microsoft Dynamics AX
client unless you select Force when you synchronize.

Set Up the Version Control Parameters

1. Click Microsoft Dynamics AX > Tools > Development tools > Version control > Setup >
Parameters.
B8 version control parameters =]

General | Yisual Sourcesafe I

\ersion control settings

Source conkrol stakus: IEnahIe - I

Mersion conkral syskem: I'u'isual SourceSafe j

Repository Folder: I WS Repository| |

Environment setkings

Color checked-out objects in the A0T: W

Warn when reverting objecks; v

(0] 4 Cancel

In Source control status, select Enable.
In Version control system, select Visual SourceSafe.
In Repository folder, type the path of the repository folder.

Choose environment settings, or use the default environment settings.

S T o

Click the Visual SourceSafe tab.
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BBl Yersion control parameters !EI

Gereral  Misual Sourcesafe |

‘Wisual SourceSafe Settings

Yisual SourceSafe rook project: I 1 axz009]

Wisual SourceSafe database | ini File: I CSourcesafeDB\srosafe, ini |

(] Cancel

7. Inthe Visual SourceSafe root project field, type the name of the project in VSS.
Remember to include the ROOT name, such as $/Ax2009.

8. Inthe Visual SourceSafe database .ini field, type the path and file name for the srcsafe.ini
file in the SourceSafe database folder.

Configure Global Version Control System Settings (Administrator)

1. Click Microsoft Dynamics AX > Tools > Development tools > Version control > Setup >
System settings.
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BBl System settings =]

General |OI:-jeu:I: rules I Additional subfolders I

version conkrol settings

Skatus line: I My Project

Team Server name: I.ﬁ.xTeamSEwer "l

Team Server Database name: I,.:.,xT5| j

Compiler warnings: I,.:.,.;.;Ept vI Compiler to-dos: I,.:.,.;.;Ept vI
Compiler errors: I":'":':Ept vI Besk practice errors: I":'":':Ept vI

Fur title case update: I Test project: I j

(0] 4 | Cancel |

In Microsoft SQL Server or Oracle, select the type of database that the Team Server uses.

If you selected Microsoft SQL Server in step 2, type the name of the Team Server in Team
Server name. If you selected Oracle in step 2, type or select the TNS Service name in
Team Server TNS Service Name.

If you selected Microsoft SQL Server in step 2, type or select the name of the Team Server
database, such as AXTS, in Team Server Database name. If you selected Oracle in step 2,
type or select the Team Server schema, such as AXTS, in Team Server Schema.

Specify best practice seftings.

Create Repository

You must add all objects from your master copy of Microsoft Dynamics AX 2009 to the VCS
server. When you add the objects to the server that runs the VCS, they are automatically
registered in the Team Server so that IDs are assigned to them. Assigning IDs to all existing
objects ensures that the Team Server can issue unique IDs for new objects when they are
created.

Create a Local Repository Folder

Create arepository folder on your computer. When you add the Application Object Tree

(AQOT) objects to the server, a copy of each object is also added to your repository folder.

Note: Consider the folder you choose for the local repository folder. If a VSS client that
runs against the VSS server shares a local repository folder with a Microsoft Dynamics AX
2009 client and a change is checked in by using the VSS client, the Microsoft Dynamics
AX 2009 client will not reflect those changes when you synchronize the Microsoft
Dynamics AX 2009 client unless you select Force when you synchronize.

Open Windows Explorer.
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2. Create a new folder to use as your local repository folder, such as C:\VCS_Repository.

Create Repository

1. Click Microsoft Dynamics AX > Tools > Development tools > Version control > Create
repository.

PEl Create repository I =]

Check-in description: | Creation of repository|

IQ—KI Cancel

2. In Check-in description, type a description of the check-in, such as “Creation of
repository.”

3. Click OK.

Synchronize Objects

At first, the local version of Microsoft Dynamics AX 2009 may not be synchronized with the
master version that is deployed by the version control administrator. To access the latest
version of all AOT objects, synchronize the local version with the version that is on the server
that is running the version control system.

1. Click Microsoft Dynamics AX > Tools > Development tools > Version control > Synchronize.

BB Synchronization M= E3 |

ir) Synchronizes the A0T with the latest changes of all objects,
"\-\

Seleck Force to stark an update regardless of whether a change has been made.,

Select Delete local objects ta delete local objects, files, and Folders that do not exist in the global repaositorsy.

Type: ILatest Yersion ™ I

Label: I

Force: I

Delete local objecks: [

IQ—KI Cancel
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2. Indicate whether you want to force the synchronization and whether you want to delete
local objects that have been deleted on the source control server (optional).

3. Click OK to start synchronization.

Optional Task

Add Ax32Serv.exe as an Exception on the Win2K3 Database Server Firewall
1. Click Start > Control panel > Windows Firewall.

2. Select On to turn on the firewall.

3. On the Exceptions fab, click the Add program button.

4

In the Add a program dialog box, browse to locate the Ax32Serv.exe file on your
computer, and then click OK fo add it o the list of exceptions.
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Microsoft Dynamics is a line of integrated, adaptable business management solutions that enables
you and your people to make business decisions with greater confidence. Microsoft Dynamics works
like and with familiar Microsoft software, automating and streamlining financial, customer relationship
and supply chain processes in a way that helps you drive business success.

U.S. and Canada Toll Free 1-888-477-7989
Worldwide +1-701-281-6500
www.microsoft.com/dynamics

The information contained in this document represents the current view of Microsoft Corporation on the issues discussed as of the
date of publication. Because Microsoft must respond to changing market conditions, this document should not be interpreted to be
a commitment on the part of Microsoft, and Microsoft cannot guarantee the accuracy of any information presented after the date
of publication.

This document is for informational purposes only. MICROSOFT MAKES NO WARRANTIES, EXPRESS, IMPLIED, OR STATUTORY, AS TO THE
INFORMATION IN THIS DOCUMENT.

Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this
document may be reproduced, stored in or infroduced into a retrieval system, or fransmitted in any form or by any means
(electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of
Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter
in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does
not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2008 Microsoft Corporation. All rights reserved.

Microsoft, the Microsoft Dynamics Logo, BizTalk, Dexterity, FRx, Microsoft Dynamics, SharePoint, Visual Basic, Visual C++, Visual
SourceSafe, Visual Studio, Windows, and Windows Server are either registered trademarks or frademarks of Microsoft Corporation, FRx
Software Corporation, or Microsoft Business Solutions ApS in the United States and/or other countries. Microsoft Business Solutions ApS
and FRx Software Corporation are subsidiaries of Microsoft Corporation.
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