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4.394 IMAGESOUICE  coiiiiciiiiiiieieeiiiiiiiees eeree e s e aeaaereee e e .. 268
4.395 ImeConversionModeValUES ..o iviiiiies vt eeeeeeea——. 269
4,396 ImMeSentenceModeValUES ...ooooiiiiiiiiiiiiiiiiiiiee rrr——— —eeaeeeaa e 269
4.397 IMUIIVAlUBCONVEIEN  oeieiiiiiiies eeeeeeeeeeeeeee e e ——— 269
4.398 InertiaEXpansionBehavior = .oooiiiiiiiiiis e e 269
4,399 InertiaRotatioNnBENaVIOr .iiiies e 270
4.400 InertiaTranslationBehavior s e 270
4.401 InheritanCeBehaVvIOr —  ...ciciciciciiiiiiiiies s e ———— 271
4,402 INKCANVAS  cooviiiiiiiiiieeiieiiiiiieiiiie et e e 271
4.403 InkCanvasClipboardFormat ... e aeereeee s 273
4.404 InkCanvasEditingMOde ..o e 274
4.405 InkCanvasSelectionHitResult 274
4.406 InkPresen ter .......ccccccccoviveiieiinnnns .. 274
4,407 InliN€  .vvvveeeiiee 274
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4.408 InlineCollection 275
4.409 InlineUlContainer 276
4.410 InputBinding  .ccoeeeieeiie. ... 276
4411 InputBindingCollECtiON oot e e 277
4412 INPUIGESIUME oot rreee e s isrrrrr e eeeeeeereere e e s . 277
4.413 InputGestureCollECtION oo e e 277
4.414 InputLanguageManager ... e e 277
4.415 INPUIMANAGET oo eiiiitiee s e areeeeeeea e e e aae e .278
4416 INPUIMELhOO oot e e e .. 279
4.417 INPUIMELNOASTIAIE oo e e 281
4418 INPUIMOOE oo e e e aeas 281
44109 INPUISCOPE  iiieiiiiiiiiiiiiiiiiieeeiiiiee eevvvviiinren e e snninnnneees eeeee e e aaen 281
4.420 INPUESCOPENGAME s e e 282
4.421 InputScopeNameValue . e e 282
4.422 INPULSCOPEPNIASE oo e eerree e 282
0y T 1 o o U1 5/ o1 PN 283
4424 INtLBANIMALION i riiiieiie e s areeeeaaea e e naaeaean 283
4.425 INtIBANIMALIONBASE oot e eeeaneeee e e 284
4.426 Intl6AnIMationUsingKeYFrames —  iiiiiiiiiiviieies e eeaeeas 284
4427 INLIBKEYFIame it s e e 284
4.428 Intl6KeyFrameColleCtion oo e e 285
4.429 Int32Animation ... 285
4.430 Int32AnimationBase 286
4.431 Int32AnimationUsing 286
4.432 Int32Collection  ....ooieiiieen 287
4433 Int32KeyFrame  ......ccccceviiiieiniiieeenns 287
4.434 Int32KeyFrameColleCtion oo s e 288
4.435 INB2RECE oo s e e 288
4436  INtBAANIMALION  coiiiiiiie i eriieiie e areeeeaeaee e e e e aaaeaaan 289
4.437 IntB4AnimationBase  ....cccceiienieieneene 289
4.438 Int64AnimationUsingKeyFrames 290
4.439 Int64KeyFrame  .......ccccoiiiiiiiiiiiiens 290
4.440 Int64KeyFrameColleCtion .o e e 291
4.441 IntersectionDetail oo e 291
4442 INVEIMAXES oo e eeeee e aaa 291
4443 ISCrollinfO oo e e e aeaees 292
4.444 |SOffscreenBehavior s e e 292
4445 RAIC oo e s aeeeseeneens 292
4446 IemMCOIIECHION it e aeereee e 293
4447 ItemContainerTemplate (4.5) s e eeeeae 294
4.448 ItemContainerTemplateKey (4.5) i e e 294
4449 NeMSCONIIOl it e e e .. 294
4.450 ItemsPanelTemplate s e e 296
4.451 HEMSPIESENIEI s ettt e e 297
4,452 IValUBCONVEITEI oo ciiieiiiis et erire e sieee s eeee s 297
4.453 IWeakKEVENtLISIENEr oo e eeeeee e 297
4454 JOUMNAIENIIY s e eeeee s e e aaaee e .. 297
4.455 JournalEntryLiStCONVEIEr i e e 298
4.456 JournalEntryPoSItioN .o e e 298
4.457 JournalEntryUnifi  edVIeWCONVEIEr ..o et e 298

4.458 JournalOwnership 299
4.459 JpegBitmapEncoder 299
4460 Jumpltem 300
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4.461 JumpltemReEJeCtiONREASON oo e e 300
4,462 JumpList ...
4.463 JumpPath
4.464 JumpTask
4.465 KernelType ..ocovvevvieeiciieeee,
4466 KeY .o,
4.467 KeyBinding ....coocevviieeiiieeeee,
4.468 Keyboard .......ccccciiiiiiiiiiiieenns
4.469 KeyboardNavigation — ........ccceeeeeviieeeeinnnn.
4.470 KeyboardNavigationMode
4471 KeyGesture
4.472 KeySpline

4473 KeyStates  ......ccccvvviieiiiieeee
4474 KeyTime oo,
4475 KeyTimeType .oooveeeiiiieeeeieeeee
4.476 KeyTipControl (4.5) .o,
4.477 KeyTipHorizontalPlacement (4.5) i e e 307
4.478 KeyTIPServiCe (4.5) i e e 308
4.479 KeyTipVerticalPlacement (4.5) i e e 308
4480 Label oot s e aeeeanees 309
4.4 81 LanguageSpecificStringDIClioNary .o e e 309
4482 LIGNE oo e e aneeesnees 310
4483 LINE oo e e aareeneeneans 310
4.484 LinearByteKeYFrame ..o e e 311
4.485 LinearColorKeYFrame ..o e e 311
4.486 LinearDecimalKeYFrame ..o e eeaiee s 311
4.487 LinearDoUblEKEYFrame .o e e 311
4.488 LinearGradientBrush ... e e 312
4.489 Linearintl6KEYFrame i e eenree e 312
4.490 LinearInt32KeyFrame 312
4.491 LinearInt64KeyFrame 312
4.492 LinearPoint3DKeyFrame 312
4.493 LinearPointKeyFrame 313
4.494 LinearQuaternionKeYFrame s s ereesneee 313
4.495 LinearRecCtKeYFrame .. e e 313
4.496 LinearRotation3DKeYFrame .o s ereenneee 313
4.497 LinearSingleKeYFrame it e e 313
4.498 LinearSizeKeyFrame s e e 314
4.499 LinearThickneSSKEYFrame . e e 314
4500 LinearVector3DKeYFrame . e e 314
4.501 LinearVectorKey — Frame ...ccociiiiiiiiicis et e 314
4.502 LINEBreak ...occcocciiiiiiiiiiiiiiies s e e 314
4.503 LineBreakCondition ... e e 315
4504 LINEGEOMELIY oot e eeearee e .315
4505 LINESEOMENT oot e eeeeaee e a e ..315
4.506  LIineStackingStrategy  ....cccccveviiiiiiiiiiiiiiee e areese e 316
4507 LINKTArgeL oo et ens eeeereee e aenees 316
4.508 LinkTargetColleCtion ..ot v e 316
4509 LISt oo s v eeseereane 316
4510 LIStBOX oo e eeeesee et aareeees 317
4511 L iStBOXIEEM oo e e s ... 318
4512 LIStHEM (oo s e ereens 318
4.513 ListitemCOIIECHON oo e e 319
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4514
4515
4516
4517
4.518
4519
4.520
4.521
4.522
4.523
4.524
4.525
4.526
4.527
4528
4.529
4.530
4.531
4.532
4.533
4.534
4.535
4.536
4.537
4.538
4.539
4.540
4.541
4.542
4.543
4.544
4.545
4.546
4.547
4.548
4.549
4.550
4551
4.552
4.553
4.554
4.555
4.556
4.557
4.558
4.559
4.560
4.561
4.562
4.563
4.564
4.565
4.566

ListView
ListViewltem
Localization
LocalizationCategory
LocalValueEntry
LocalValueEnumerator
LogicalDirection
Manipulation
ManipulationModes
ManipulationPivot
Material
MaterialCollection
MaterialGroup
Matrix
Matrix3D
MatrixAnimationBase

MatrixAnimationUsingKeyFrames

MatrixAnimationUsingPath
MatrixCamera
MatrixKeyFrame
MatrixKeyFrameCollection
MatrixTransform
MatrixTransform3D
MediaCommands
MediaElement
MediaPlayer
MediaState
MediaTimeline
Menu
MenuBase
Menultem
MenultemRole

MenuScrollingVisibilityConverter

MeshGeometry3D
MessageBoxButton
MessageBoxIimage
MessageBoxOptions
MessageBoxResult
MinMaxParagraphWidth
Model3D
Model3DCollection
Model3DGroup
ModelUIElement3D
ModelVisual3D
Modifiability
Modifierkeys
Mouse
MouseAction
MouseBinding
MouseButton
MouseButtonState
MouseGesture
MultiBinding

..320
.. 320

321
321
321
321

.. 322

322
323
323
323

.324

324
325
326
326
327

.327

328
328
329
329
329

.331
.. 332

333

.334

334
334
335
337
337
337
337
338
338
338
338
339
339
339
340
340

... 340
.. 340

341

.. 342
.343
.. 343

343

.343
.. 344
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4567 MUltiDAtATIIQUEr oo iiiieerriiies eeee e erre e e e eeeeaeeeeeaeeeaeaaaeee e 345

4.568 MUILISEIECIOr  oiiiiiiiicicririiis e eeeree e .. 346
4.569 MUIITIQOEr oot e sriee e s eeerieee e e e e aneeas ... 346
4,570 NavigationCommandsS  .cocociiiiiiiiieciiiiiiie e arree e 347
4571 NavigatioNMOOE .o ciiiiiis e e e 348
4.572 NavigationUIVISiDility oot e e 348
4,573 NavigationWindow 348
4.574 NonClientFrameEdges (4.5) 349
4575 NotifyDataErrorValidationRule (4.5) i e ... 350
4576 NUmMbDErCUlUrESOUICE  iiiiiiiiciiciiiieiie et nes areeeaeaeeeee s e 350
4.577 NumberSUDSHtULION oo e e 350
4.578 NumberSubstitutionMethod it e 351
4.579 ODbjectANIMAtiONBASE  .ccciiiiiiiiiciiic it e eereeee e 351
4580 ObjectAnimationUsingKeyFrames . e e 352
4581 ObjectD ataProvider .....ccccciiiiiiiiiiiiies e e 352
4582 ODbjectKeYFrame i e e 353
4.583 ObjectKeyFrameColleCtion ..o e e 353
4584 Orientation .o e eeesree e ies aaes 354
4.585 OrthographiCCamera  ..cccccceiiieiiiiiiiieiis e eeree s 354
4586 OVErflOWMOAE oot e eeeerer e .354
A = - Vo 1 R 354
4.588 PageCoNnent  ...ococciciiiiiiiiiiiiieiiiis e eeee e ... 355
4.589 PageContentCollection 356
4590 PageRange ........cccccerviieinnnnn. 356
4591 PageRangeSelection 357
e A = o1 357
4.593 PanningMOdE ..ot e e .. 358
e A o =T |- o o 358
4595 ParallelTimeline 359
4.596 PaSSWOIOBOX  ccccccieiiiiiiiiiiieiiiess eeeieesiee e e e e eeeseeeseeeneeeneeenee e ..360
4597 Path .o, 360
4.598 PathAnimationSource 361
4599 PathFigure .iiiiis e e e aeane 361
4.600 PathFigureColleCtion ..o e e 362
4.601 PathGEOMELIY oot e eeeeree e .362
4.602 PathSegment .o e e .. 362
4.603 PathSegmentColleCtion ..o e e 363
4.604 PauseStorybhoard ... e eeeereee e 363
0L T == o O 363
4.606 PenLineCap .....cccccccevvvieeenniinienns ... 364
4.607 PenLinedoin  ......ccccceeiiiiiieniiineene ... 364
4.608 PerspectiveCamera 365
4.609 PiXEIFOrMAt oot e eeeree e ... 365
4.610 PixelFormatChannelMask ...t s e 365
4611 PiXElIFOIMALS  .oooiiiiiiiiiiiiiiiriiiiiiis e e e ... 366
4.612 PiXelShAUer i e ... 368
4.613 PlacementMOOE  ...coooiciiiiiiiiiiiiiiieiiis s e 369
4.614 PngBitmapEncoder 369
4.615 PnglinterlaceOption 369
4616 Point ...cccceiviiieeeee 370
4.617 Point3D  ..ocovevieeeee 370
4.618 Point3DANIMation  ......ccccoeieiiiiieeeen. 371
4.619 Point3DAnimationBase 371
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4.620 Point3DANIMAationUsiNgKEYFrames .o e e 372

4.621 PoINt3D  COlECHON .oviciiiiiiiiiiiiiiiiiiis et e 372
4.622 Point3DKeyFrame 372
4.623 Point3DKeyFrameColleCtion .oooiiiiiiiiiiiiiviiieiie s erree e 373
4.624 POINAD oot e e e 373
4.625 PointAnimation ... 374
4.6 26 PointAnimationBase 375
4.627 PointAnimationUsingKeyFrames s e e 375
4,628 PointAnimationUsingPath ...t e e 375
4.629 PointCollection  .....ccccoceviviiiieiiiee 376
4.630 PointKeyFrame ........cccccevviieeiiineenn, 376
4.631 PointKeyFrameColleCtion .ot e rree e 377
4.632 POINtLIGt oot e e e 377
4,633 POINLIGhtBASE it e eeerree e 377
4.634 POlyBeZIErSEgMENL oot e e 378
4,635 POIYGON oo e e, aareaa 378
4.636 POIYIINE oot s e e 379
4.637 POIYLINESEIMENT i et e 379
4.638 PolyQuadraticBezierSegment .. e eeeeee 379
4.639 POPUD  coiiiiciiiiiiiiie i et eeeeenne e eeaneeeens 380
4.640 POPUPANIMALION  iiiviiiiiiiiieiieiiieiis eeveeree e see s eeaeeaaeeseeesaee e 381
4.641 POPUPPHMAIYAXIS oot e eenree e s 381
4.642 POWEIEASE ..ccoociviiiiiiiiiiiiiiies e e e 381
4.643 PowerLineStatus  .......ccccceieiiieeieeene 382
4.644 PresentationTracelLevel 382
4.645 PresentationTraCeSOUICES coccvciiieiiiniirieiiienis eeveereee e eesreesreanens 382
4.646 PriorityBindiNg oo e e 383
4647 ProgreSSBar ..o e e ... 383
4.648 ProjeCtioNnCamera  .ccocceviieiiiiiiieniiens e eeree e 383
4.649 PropertyGroupDesCrPtiON oo e e 384
4.650 PropertyPath ..o .. 385
4.651 QuadraticBezierSegment 385
4.652 QUAdratiCEASE .o e e 385
4.653 QUANICEASE  .ccciiiiiiiiiiciiieiiiiees e aeeeeee e ... 386
1 A @ 11 = 1 (=] ¢ 1o ) o O 386
4.655 QuaternionAnimation s e aareee s 386
4.656 QuaternionAnimati ONBASE ..ooiiciiiiiie s e eeeean———— 387
4.657 QuaternionAnimationUsingKeYFrames s e 387
4.658 QuaternionKeyFrame s e e 388
4.659 QuaternionKeyFrameColleCtion s s e 389
4.660 QuaternionROtatioN3D oo e eeeeaeee e 389
4,661 QUINLCEASE  viiiiiiiciiiiiicciiiiiiis svvcriree e eeaeeee e ... 389
4.662 RadialGradientBrush ..o e eeeeeee e 389
4.663 RaAdiOBULION  oiiiiiiiiiiiis s e ... 390
4.664 RANGEBASE ..ot e e e 390
4.665 Readability ..o e reeree e aaes 391
4.666 ReasonSesSIONENAING  coiiiiiiiiiiiiiiis s e 391
4.667 RecognitioNCONfIdENCE oo e e 392
4668 RECL oo e s aeeeseeneens 392
4,669 RECI3D oo e e v 393
4670 RECIANGIE oot s e aeeeaa 394
4.671 RectangleGeometry 394
4.672 RectAnimation 395
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4.673 ReCtANIMAtiONBASE ..o e e 395
4.674 RectAnimationUsingKeyFrames 396
4.675 RectKeyFrame ..., 396
4,676 RectKeyFrameCollection ........ccccceviiveeiinnennn. 397
4.677 RelativeSource ........cccvvveniieiiiiinene 397
4.678 RelativeSourceMOode ..o e e 398
4.679 RemoveStoryboard s e e 399
4.680 RenderCapability ..o e eeeereee e 399
4.681 RenderingBias ... e e .399
4.682 ReNderOPONS oot e aeereee e eeaaeeas 399
4.683 RenderTargetBitmap 401
4.684 RepeatBehavior ........cccccceeeiiiiiieenns 401
4.685 RepeatBUMON i e e e a e .401
4,686 RESIZEGHD oot e eeerree e aeas 402
4.687 ResSizeGripDirection (4.5) s e eea e 402
4.688 RESIZEMOUE ..ot e e .. 402
4.689 RESOUICEDICHONAIY  oociiiiiiiiic it et aee e e 403
4.690 ResourceDIctionaryLoCation ..o e ereenneee 403
4.691 RESOUICEKEY  oiiiiiiiiiiiiiiiiiiiiiiiiiis ettt ees eeeee s .. 403
4.692 ReSIOrEFOCUSMOOE ..o e e 404
4.693 ResumeSIOryboard ..o e e 404
4.694 RIDDON (4.5) oot e e .. 404
4.695 RibbonApplicationMenu (4.5) 407
4.696 RibbonApplicationMenultem (4.5) 407
4.697 RibbonApplicationMenultemLevel (4.5) . 408
4.698 RibbonApplicationSplitMenultem (4.5) oo e 408
4.699 RIbDONBULION (4.5) oo e e 408
4.700 RIibboNCheCkBOX (4.5) oo e aereee e 410
4.701 RibbonCombOBOX (4 .5) oo s e 412
4.702 RibbonCommands (4.5) oo e e 413
4.703 RibbonContentPresenter (4.5) i s e 414
4.704 RibbonContextMenu (4.5) .o 414
4.705 RibbonContextualTabGroup (4.5) 414
4.706 RibbonContextualTabGroupltemsControl (4.5) s e 415
4,707 RIbboNCONLIol (4.5) oot e e 415
4.708 RiIbbonControlGroup (4.5) oo e e 416
4.709 RibbonControlLength (4.5) i aeereeee 416
4.710 RibbonControlLengthUnItType (4.5) i et .. 417
4.711 Rib bonControlService (4.5) s e e 417
4712 RibbonControlSizeDefinition (4.5) i e e 421
4.713 RibbonControlSizeDefinitionCollection (4.5) s e 422
4.714 RibbonDismissPopupMode (4.5) s e e 422
4.715 RibbonFilterMenuBuUttoN (4.5) s s e 422
4716 RibbonGallery (4.5) it e e 422
4.717 RibbonGalleryCategory (4.5) 426
4.718 RibbonGal leryltem (4.5) 427
4.719 RIbDONGIOUP (4.5)  ceiiiiviis s e 428
4.720 RibbonGroupSizeDefinition (4.5) s e e 430
4.721 Ribbo nGroupSizeDefinitionBase (4.5) i e .430
4.722 RibbonGroupSizeDefinitionBaseCollection (4.5) s e 430
4.723 RibbonGroupTemplateSizeDefinition (4.5) s e 431
4724 RibbonimMageSize (4.5) s e e 431
4.725 RIbbonNMenuBUHON (4.5) oo e e 431
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4.726 RibbonMenultem (4.5) it s e 434

4,727 RibbonQuUICKACCESSTOOIBAr (4.5) oo e eeea 436
4.728 RibbonRadioBULON (4.5) i e e 436
4,729 RiIbbonSeparator (4.5) s e e 438
4,730 RibbonSPlitBUttON (4.5) oo e v 439
4.731 RibbonSplitButtonLabelPosition (4.5) s e .440
4,732 RibbonSplitMenultem (4.5) s e e 441
4.733 RIbbONTAb (4.5) coocciiis e eeeree s 442
4,734 RibbonTabHeader (4.5) i e e 442
4.735 RibbonTabHeaderltemsControl (4.5) .. 443
4736 Rib bonTextBox (4.5) ..ccocevviiveeviieeeene. 444
4,737 RibbonToggleButton (4.5) s v eeeeser e 446
4.738 RIbbONTOOITIP (4.5) oo e e 448
4,739 RiIbbonTWOLINETEXt (4.5) oo vt e e e 449
4.740 RIibbONWINAOW (4.5) oo e eeeeeee e 450
4741 RIChTEXIBOX  cooiiiiiiiiiiiiiiiiiiiiiis et ss teeeiee et ... 450
4,742 RotateTransform i e eeeeree e 451
4743 RotateTransform3D oot e eee e 451
g o Lo ] = Lo o PR 452
T = (o ] = 1T 1] I PP 452
4.746 Rotation3DANIMALION oo e aaree e 452
4.747 Rotation3DAnimati ONBASE ... e 453
4.748 Rotation3DAnimationUsingKeyFrames 453
4.749 Rotation3DKeyFrame  ......cccccvieiiieeneeenne 454
4.750 Rotation3DKeyFrameColleCtion .o e e 454
4.751 RoutedCOm  MANG .ccoiiiiiiiiiiiiiiiieiiiens e e eeseee e e 455
4752 ROULEAEVENT  ooiiiiiiiiiiiieiiciiiiiiis eevriee st e e srineesiees teeeeanieeeesseeeeestaeeeanns ... 455
4.753 RoutedEventHandlerInfo s e 456
4754 RoutedUICOMMANA oo e eeeenee e 456
4.755 ROULNGSITAtEOY  oivviiiiiiiiiiiiieiiieiis eevee s e siee s eerreeaeeesaee e 456
4.756 ROWDESINIION oo e .456
4.757 RowDEefinitioNCOIIECION oo e eeeeree e 457
4.758 RUN ..,

4.759 SamplingMode ...

4760 ScaleTransform

4.7 61 ScaleTransform3D

4762 ScrollBar ....cccccciiiiiiieeee

4.763 ScrollBarVisibility

4.764 ScrollContentPreSENIEr oo e eeeereea e 460
4765 SCrollEVENITYPE oot ettt rieee s e 461
4.766 SCrollUnit (4.5) oot v eeeree s e 461
4767 SCrollVIEWET oo iiiiiiiiiiiis et eee e ... 461
S Y= Tt 1 o ST 463
4,769 SeekStoryboard ..o e e 464
4770 SelectedDatesSCollECtioN i e e 464
4771 SeleCtioNMOOE it e eeeree e 464
4772 SelectiveScrollingGrid oo s e 464
4.773 SelectiveScrollingOrientation .o e e 465
ATT74 SEIECIOI it e e ees anaeeeas 465
4775 SEPAMALON  .ooiiiiciiiiiiiic it e aeeee s eeena 466
4776 SetStoryboardSpeedRati0 .o s eeee e 467
AT7T7 Setter .veiviiiiieieeeeeees

4,778 SetterBase
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4,779 SetterBaseCollECHON ..cccciiiiiiiies e e ———— 468

4,780 ShaderRenderMode ... e e 468
4781 Shape ....ccccoceverieiienien 468
4,782 ShutdownMode 469
4783 SINEEASE ..ot e s e 470
4.784 SINgIEANIMALION oo e eereese e 470
4,785 SingleAnimationBase ..ot e e 470
4.786 SingleAnimationUsiNgKeYFrames ..o e e 471
4787 SINGIEKEYFIAME oo cciiiciiiis et ereee e 471
4.788 SingleKeyFrameColleCtion ..o e 472
4789 SIZE oo e e 472
4790 SiZE3D oo s e e 473
4.791 SiZeANIMALION oot e eree e 473
4,792 SizeAnNIMAtioNBase ..o s e 474
4.793 SizeAnimationUsingKeyFrames s e e 474
4794 SizeKeYFIame .ot e e 475
4.795 SizeKeyFrameColleCion ..o e e 475
4.796 SiZETOCONIENT oo vt areesre e 475
4797 SKeWTTansfOrM .o e e 476
4.798 SKipStoryboardTOFIll  ooiiiiies e e 476
4799 SHAEE oo e s e 476
4.800 SIPBENAVIOr oo e e ... 478
4.801 SolidColorBrush 479
4.802 SoundPlayerAction 479
4.803 Span .o 479
4.804 SpecularMaterial 480
4.805 SPEECNMOUE oo e e ... 480
4.806 SPEIICRECK oot e e 480
4.807 SpellingREfOrM it e e 481
4.808 SplineBytEKEYFIrame  ..ooccciiiiiiiiiiiiciiieiis et eeree s 482
4.809 SplineColorKeyFrame — ......ccccoooevviieeinennne 482
4.810 SplineDecimalKeyFrame  ......ccccceevieenieeninnn, 482
4.811 SplineDoubleKey — Frame .......cccccciiiiiiiiiiiiies e e 482
4.812 SplineIntI6KEYFrame i e e 483
4.813 SplineInt32KeyFrame 483
4.814 Splinelnt64KeyFrame 483
4.815 SplinePoint3DKeYFrame .. e e 484
4.816 SplinePointKEYFrame .. e e 484
4.817 SplineQuaternionKeYFrame . e ereennees 484
4.818 SplineReCtKEYFrame ..o e e 484
4.819 SplineRotation3DKEYFrame .o s ereennees 485
4.820 SplineSingleKeyFrame ..t e e 485
4.821 SplineSizeKeYFrame .. e e 485
4.822 SplineThickneSSKeYFrame ..o et eeeanieeeeas 486
4.823 SplineVector3DKEYFrame .iiiiiiiiiiiiiies e e 486
4.824 SplineVectorKeYFrame  .oiiiiiiiiviiis e e 486
4.825 SPOLLIGNt oo e e e 486
4.826 StackPanel ...t e e 487
4.827 StatiCReSOUICEEXIENSION i e eerree s 487
4.828 StAtUSBAr  .ooooicciiiiiiiiiiiiiiis s e eeeaa 488
4.829 StatusBarltem 489
4.830 StickyNoteType 489
4.831 StopStoryboard 489
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4.832
4.833
4.834
4.835
4.836
4.837
4.838
4.839
4.840
4.841
4.842
4.843
4.844
4.845
4.846
4.847
4.848
4.849
4.850
4.851
4.852
4.853
4.854
4.855
4.856
4.857
4.858
4.859
4.860
4.861
4.862
4.863
4.864
4.865
4.866
4.867
4.868
4.869
4.870
4871
4.872
4.873
4.874
4.875
4.876
4.877
4.878
4.879
4.880
4.881
4.882
4.883
4.884

Storyboard
StreamGeometry
Stretch
StretchDirection
StringAnimationBase

StringAnimationUsingKeyFrames

StringKeyFrame
StringKeyFrameCollection
Stroke
StrokeCollection
Style
StyleSelector
StyleSimulations
Stylus
StylusButton
StylusButtonCollection
StylusButtonState
StylusDeviceCollection
StylusPoint
StylusPointCollection
StylusPointDescription
StylusPointPropertyUnit
StylusTip
SweepDirection
SystemColors
SystemCommands (4.5)
SystemFonts
SystemGesture
SystemParameters
TabControl
Tabltem
Table
TableCell
TableCellCollection
TableColumn
TableColumnCollection
TableRow
TableRowCollection
TableRowGroup
TableRowGroupCollection
TabletDeviceType
TabletHardwareCapabilities
TabPanel
Taskbarlteminfo
TaskbarltemProgressState
TemplateBindingExtension
TemplateKey
TextAlignment
TextBlock
TextBox
TextBoxBase
TextCollapsingStyle
TextCompositionAutoComplete

490
490
490
491
491
491
492
492
493
493

..494

494
495

.. 496

497
497
497
497
498
498
498
499
499

.499

510

..510

515
515
535
536
536
537
538

..539

539
540
540
540
541
541
542
542
542
543
543

..544

544
544
547

.. 549

550
550
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4.885 TextDataFormat ..o s e 551

4.886 TextDecoration — .....cccccevviieeiiiiieeenns 551
4.887 TextDecorationCollection 551
4.888 TextDecorationLOCatiON ..o e eeeerre e 552
4.889 TeXIDECOratiONS  .iiiiciiiiiiiiieciiiiieiiiis v eee s 552
4.890 TextDecoratioNUNIt  .ccciiiiiiciiiicicceiiceeieies e e ———— 552
4891 TeXIEMECL it e reea 553
4.892 TextEffeCtCOIECHON oo e e ————— 553
4.893 TeEXIEIEMENT it e e e ... 554
4.894 TextElementCollection(T) e riiieiiies e eeee e 555
4.895 TextFormattingMOde ..o e eeeeree e 555
4.896 TextHINtiNGMOAE .o e e 556
4.897 TeXIMArkerStyle s e e 556
4,898 TEXIOPLONS it et eerrree e ... 556
4.899 TeXtPOINtEICONIEXE  occcciiiiccciccicceciiiiieies e v —————— 557
4,900 TextRenderingMOdE ..o e eerr— e 557
4,901 TextRUNCAChE oo e e ——————— 557
4,902 TEXISEAICN  cooiiiiiiiiiiiieeiiiiie e . e 558
4.903 TextTabAlGNMEeNt s e eeeree e 558
4.904 TextTAMMING oo e .558
4.905 TextWrapping  .occccvceviinniiiiiieeiee e .558
4.906 ThemeDictionaryEXIENSION oot e e 559
4,907 ThiCKNESS  ooiiiciiiccicriiis et vt eeea 559
4,908 ThicknessAnimation  .......ccccccevviviiieeneeennn. 560
4,909 ThicknessAnimationBase 561
4.910 ThicknessAnimationUsingKeyFrames —  .iiiiiiiiiiiiiie e ..561
4.911 ThickneSSKeYFrame ..o e e 561
4.912 ThicknessKeyFrameColleCtion .o s e 562
4913 ThUMD it e e eeeaaas 562
4914 ThumbBULtONINfO i e e 563
4,915 ThumbButtonInfoColleCtion .t ———— e 564
4,916 TICKBAI  ooiciiiciciiii it e e aereeeas 564
4,917 TickBarPlaCemMeNt .o e eereree 565
4,918 TICKPIACEMEN oot ———— e .565
4919 TiffBItMAPENCOUEr oo iiiis e areee e 566
4.920 TiffCOMPreSSOPLON oo e e 566
4,921 THEBIUSN  cooeieeeeeeeeeeeitiies ettt e ——————— aeeeea 566
4,922 THEMOUE oot e e ————— eaaaa 567
4,923 TIMEINE  cooeeeeeeeeeeeeiiiee ettt e rvrrea 568
4,924 TIimelineCollECHON i s rrr————— 569
4.925 TIMENNEGIOUP oot et e e 569
4,926 TIMESEEKOIIGIN it et e 570
4.927 TOQIEBULION oot e eeeee e ..570
4928 ToleranceType 571
4,929 ToolBar .....cccccevvvvvvevverrnnninnnns 571
4.930 ToolBarOVErflOWPANE!  ..ooveeiiiiiiiiies ettt e 572
4,931 TooIBarPanel ...t e e ..573
4.932 TOOIBAITIAY  .iovciieiiiiiiieiiieiiiieiiie etrreesiee e eereeeae e ... 573
e 1 1 T I To I o T 574
4.934 TOOITIPSEIVICE oot e riees e 575
4,935 TouchAction ..........cccceeeiiiiiinenn.. . D77
4,936 TouchPoint ......cccccevviiviiiieeiieens 577

4.937 TouchPointCollection 577

19 / 779

[MS -WPFXV-2012] 0 v20141223
WPF Xaml Vocabulary Specification 2012

Copyright © 2014 Microsoft Corporation.

Release: Tuesday, December 23, 2014



4.938 TraCK oocoiiciiiciiiiiiiis s e aeeeaneeas 577

4.939 TransformM i e e e 578
4,940 Transform3D oo e e ————— ..579
4.941 Transform3DCOIECHON oiiiiiiircviiis e e 579
4,942 Transform3DGIOUD  oviivciiiiiiiiiccciiieiiis eeerrr e aereee s e 579
4,943 TransformCollECtiON i e ———— 580
4,944 TransformedBitMap .ot e e 580
4.945 TransfOrMGIOUD oo e eereeane e 580
4.946 TranslateTransSform i e e 581
4,947 TranslateTransform3D oot e aeeerr————————— 581
4.948 TreeView ...
4.949 TreeViewltem
4950 TrHQQer .eicecceeeiiiieeeiieeeene
4,951 TriggerAction .
4.952 TriggerActionCollECHION oo e e 584
4,953 TrHQQErBase .o e e ... 584
4.954 TriggerColleCtion oo e e 584
4.955 TYPOGraphy oo e eereen e s ... 585
4.956 UIEIEMENT oo et e ees 594
4.957 UIEIEMENI3D  coiicciiviieciieivieiiiese eevrvesieesiee e siie s eeeseeeseeeneeeneeenae e ..600
4.958 UIEIEMENtCOIIECHION iiiiiiiccicriviiieiis e eeree s 605
4,959 UNErNE oo e vt ————————— areaes 606
4.960 UNAOACHON  iiiiiiiiiiciiieiiiiiiiene everieese e e se e e e s eeerreesee e nne e nee aeeas 606
4961 UniformGrid . 606
4,962 UpdateSourceTrigger 607
4.963 UserControl ......ccccceveeeviiennnne .... 607
4,964 Validation oo e vt aeeaes 607
4.965 ValidationErrorEVENTACHON coieiiiiiiicviicriieiiiens e eeereeeaaees 608
4966 ValidationR = ©SUIt ..oooiiiiiiiiicciiiis e e 608
4.967 ValidatioNRUIE ..ot e earee e .609
4,968 ValidationStep 609
4.969 ValueSource ... 609
4,970 VEeCtOr ...ccoccvvvvvnniiiiiiinnnn, 610
e T V= T o (0] £ | 610
4,972 VectorBDANIMALION .o ereee e eeeeeeeeeee e e e 611
4,973 Vector3DANIMALIONBASE .cccciiiiiiiciiiieviiiiees e aeereeee e 611
4974 Vector3DAnimationUsSINgKEYFrames s et ..612
4.975 Vector3DCOIIECHION oo e eeereeree e 612
4976 VecCtor3DKEYFIrame  .iiiiiiiiiiiiieiiis e e e 613
4977 Vector3DKeyFrameColleCtion .o e e 613
4,978 VeCtorAniMation i iiiiiis vt eeeeeeeai———— e 613
4.979 VectorAnimationBase  .ccciiiiiiiiiies e eeee e ————— 614
4.980 VectorAnimationUsingKeYyFrames i e e 614
4,981 VectorColleCtion  .vviiiiiicciiiiee e 615
4.982 VecCtorKeyFrame . e 615
4.983 VectorKeyFrameColleCtion .o e e 616
4,984 VerticalAIGNMENE oo e e 616
4.985 VIideODIaWiNg oo e aaee e .616
4,986 VIEWBASE  cccciiiiiiiiciciiiiiiiieee e avvrrrreeree e areaes 617
4,987 VIEBWDOX oot e eeeeenirre e eeees 617
4,988 Viewport2DVISUAI3D oo e eeeeaeee e 618
4,989 VIEWPOI3D i e aeeaeee e ... 618
4.990 Viewport3DVIsual oot e e 619
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4.991 VirtualizationCacheLength (4.5) s e e 620
4,992 VirtualizationCachelLengthUnit ( A5) s e .. 620
4,993 VirtualizatioNnMode oot e e 620
4,994 VirtualizingPanel ..o e e 620
4,995 VirtualizingStackPanel ..ot e e 622
4.996 VIiSIDIlIY oo e eesee e eenees 622
4.997 VISUBl i e e eeseeenan 623
4.998 ViSUAIBD oo e eenreeesee e nne aeanees 623
4.999 Visual3DCOIIECHON  .iooviiiiiiiiiieiiieviieies e eeree e 623
41000 VisUAIBIrUSN it e eeeeee e ..624
4.1001 VisualCollection 624
4.1002 VisualState ......cccoceeeviieniiennnen, .. 624
4.1003 VisSUAISTAtEGIOUD  .eooviieiiiiriieiiieiiieiee s eenree e 625
4.1004 VisualStateManager oot e aarreee s 626
41005 VisualTransSition  ..oocccioiiiiiiiiiiiiiiiiiis e rree e eeeeneeeeeaeeeaeaaee e 626
4.1006 VisUaITreEHEIPEr  ooiiiiii it et erree e e 627
4.1007 WEDBIOWSEr i e eeeeree e .627
0 010 S VLY T [ S 628
4.1009 WiIindowChrome (4.5) oo e aeree e 630
41010 WiINdoWCOHECHON iiiiiiciiiriivies e aeeeee e ea e 631
4.1011 WindowStartupLoCation .o e e 631
41012 WINAOWSEALE i ciiiieeiiiiees eeeeriee e snee e aeeneeeesaaee e eaaaeeas 632
4.1013 WindowStyle  ....cccoviiiiiiiee .632
4.1014 WmpBitmapEncoder 632
4.1015 WrapDir€CtiON  cciiiiiiiiiiieiiiciiins e eeree e 634
4.1016 WrapPan€l ...occcviiiiiiiiiiiiiiiiiis e eereese e .. 634
4.1017 WriteableBitmap .ot e e 635
4.1018 XMIDAtaPIOVIAEr  oiiiiiiiiiiiciiieviieies e eeereee s 635
4.1019 XmINamespaceMapPiNg  cccccceviieriieiiieniiens e e 636
4.1020 XmINamespaceMappingColleCtion ..o e .. 636
41021 ZoomPercentageCoONVEITEr it v e e 636
5 WPF XamlIType Information Items for Assignable Types e s 637
5.1 ACHVEXHOSE oot et eeenee e aeeeees 637
5.2 XBOOIEAN i e e e eeeae 637
5.3 XIBYIE s e e 637
5.4 XICRAr oo e e s areee e 637
5.5 ColleCtion(T) oo e e eenes 637
5.6 COllECHONBASE  ..oooiiciiiiiciiiiiiciiiiiiis et areeee e e e areee s .. 638
5.7 CURUIEINfO oot e e aeaees 638
5.8 DataSOUrCEPIOVIAEI oot ciiiiiie et srire e aeeeeee e e e 638
5.9 XDAETIME oot et eeeere e aeaees 639
5.10 DayOfWEEK  ooooiiiiiiiiiiciiiiiieis e e e 639
5.11 XIDECIMAl oot e e aeaees 639
5.12 DEIEALE ..o e e eenees 639
5.13 XIDOUDIE i e e e eeeeaees 639
5.14 FreezableColleCtion(T)  .oiiiiiiiiiiiiiiiiieiiies et eeee e 639
5.15 GroupDesCriplion oo e e 640
5.16 1COIECHON(T)  coiiiiiiiiiiiie i et eeeea e e e e araeeeeans .. 640
5.17 1ComMANd (4.5) oo e e s 641
5.18 IDictionary  ......ccccoceeieinnen. 641
5.19 IDictionary(T,U) 642
5.20 IDocUmMeNtPaginatorSOUICE oo e eeeneeennes 642
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5.21 [IENUMErADIE s e e .. 642
5.22 ILiSt i 642
5.23 IList(T) .coecereeiienn, 643
524 xiIntle ... 643
525 xiInt32 .., 643
B5.26  XINIBA oot s e e 644
B5.27 INPI i s e e 644
5.28 IXmMISerializable ... e 644
5.29 LISHT) oo e e eaeeean 644
5.30 ManipulationParameters2D (4.5) s e e 644
5.31 x:MarkupExtension 645
5.32 x:Nullable(T) oo, ... 645
5.33 XIODJECE i e e rea e eeeeaaes 645
5.34 Ob servableCollection(T) .o et eeerrea e 646
5.35 PrediCate(T) oo iiiiiiieiis s e e 646
5.36 ReadOnlyColleCtion(T)  iiiiiiiiiciiiciiiieiiiis eevrree e eeeeene e 646
5.37 RequestCaChePOliCY ..o e e 646
5.38 XiSINGIE oot e s aaeenn 647
5.39 SortDescriptionCOIlECtiON iviiiiiiiiririiis e eeeee e 647
540 XISHING oot e e s aareenns 647
5.41 StringCollECtiON it e eeeree e 647
5.42 StringCOMPAIISON i et eeeree e 647
LI T el I 11415 o - o U 648
5.44 x:XamlIType 648
545 UINt16 ..coooooviiiiiiiieieeeenn 648
546 XU oo e e e 648
547 XMIDOCUMENT oot et eeeriee e nnee e e ... 648
5.48 XMILANQUAGE  cooviiiiiiiiiieriieiiiieie e eeeneeesee e sree e .. 649
5.49 XmINamespaceManager ... e e 649
6 WPF Xaml Text Syntax Information Sets i e 650
6.1 AlIGNMENIXSYNIAX oo e eeeeaeeee e 650
6.2 AlIGNMENIYSYNIAX  oiiiiiiiiiiiiii i et eeeeaaee e 650
6.3 ApplicatioNGESIUrESYNIAX v e e 650
6.4 AUtoTOOITIPPIACEMENISYNIAX coiiiiiiiiiiiiiiieiis s areee e 653
6.5 BaselineAlIgnNMmentSYNtaX .o e e 653
6.6 BaseValueSourceSyntax 653
6.7 BindingModeSyntax 654
6.8 BiNdiNgStatUSSYNAX oo e e 654
6.9 BitmapCacheOptioNSYNIAX — .ccoiiviiiiiiiiiiiiiiieiies e iees e e aeeee e 655
6.10 BitmapCreateOptioNSSYNIAX iooccviiiiiiiiiiiiiiieeis e ee aeneeeneeees 655
6.11 BitmapScalingModeSyntax 655

6.12 BrushMappingModeSyntax 656
6.13 BrushSyntax .......ccccccvieennineen. 656
6.14 CacCheMOdeSYNIAX oo e e 664
6.15 CachingHINISYNIAX oot e e 664
6.16 CalendarMOdeSYNIaX .o e aereee e 664
6.17 CalendarSelectionMOdeSYNtaX .o s eeeeeane 665
6.18 CaptureModeSYNtAX oo e eeeeree e 665
6.19 CharacterCasingSyntax 665
6.20 ClearTypeHintSyntax 665
6.21 ClickModeSyntax .......cccccevveeriieenineenns 665
6.22 ClOCKSIAtESYNIAX  ovciviiiiiiiiiiiiiiiniis e e 666
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6.23 ColorinterpolationModeSyntax

6.24 ColorSynta X ..ccccccceevveeviieeeeiinneenn.
6.25 ColumnSpaceDistributionSyntax

6.26 CommandSyntax  .....ccccceeeeeeiiiieeeennnnn.

6.27 CornerRadiusSyntax  ......cccccceeeeevviieeeennnnn.
6.28 CulturelnfoletfLanguageTagSyntax
6.29 CulturelnfoSyntax  ....ccccocevveeiiiieeiiien,
6.30 CursorSyntax  ......cccceceeeeininiiineennn.
6.31 CursorTypeSyntax  ......cccccceeeveeeiiiivevnnnnns
6.32 DataGridClipboardCopyModeSyntax
6.33 DataGridEditActionSyntax  ......cccceeveiieeniiiee e
6.34 DataGridEditingUnitSyntax — .....cccccoveeeivcieeeee,
6.35 DataGridGridLinesVisibilitySyntax
6.36 DataGridHeadersVisibilitySyntax

6.37 DataGridLengthSyntaXx — ......cccccovivieeiiiiienenns

6.38 DataGridLengthUnitTypeSyntax

6.39 DataGridRo wDetailsVisibilityModeSyntax ..o e 692
6.40 DataGridSelectionMOAeSYNIAX —  .occvvvviiiiiieiiieriiiiee e ereeeane 693
6.41 DataGridSelectionUnitSYNtaX .o e e 693
6.42 DatePickerFOrmatSyNtaX ..o e e 693
6.43 DayOfWEEKSYNIAX  covcciviiiiiiiiiiiiviiiiis eveie e ree e enee eereee e e 693
6.44 DependencCyPropertySYNtaX oo e eeeneeennees 693
L I T Yo 15} ] - OO 694
6.46 DoubleColleCtioONSYNAX oo e e 694
6.47 DragACtONSYNIAX i e eeeree e 694
6.48 DragDropEffeCtSSYNIaX oot e eee e 694
6.49 DragDropKeyStateSS — YNIAX ..occccciiviiiiiiiiieiiiiis e eeerreee e 695
6.50 DUratioNSYNIAX  coocciviiiiiiiiiiiieniieiiis eereeeree e enes eaeeeseee e e e seeennaeas .695
6.51 EaSINgMOUESYNIAX  .ooovciiiiiiiiiciiiiiiieies e eeree e 696
6.52 EdQEMOUESYNIAX  civvcviiiiiiiiiiiieiiiieiiis eereeeee s aeeeenee e e e e 696
6.53 EdgeProfileSyntax — .....cccccoiiiiieniieennnn, 696
6.54 ExpandDirectionSyntax  ........c.ccoeee. 696
6.55 FigureHorizontalAnchorSyntax 696
6.56 FigureLengthSYNtaX .. e e 697
6.57 FigureUnItTYyPeSYNIaX oo et aereeee e 697
6.58 FigureVerticalANChOrSYNtaX oo v eeeneeeanes 698
6.59 FillBENAVIOISYNIAX  coiiiiiiiiiiiiiiiiiiiiiis et e 698
6.60 FilIRUIESYNIAX  .iiiiciiiiiiiiiiiiiiiiies e e e ... 698
6.61 FIOWDIFrECHONSYNIAX i e see e eees eeesiee e 698
6.62 FlowDocumentReaderViewingModeSyntaX .o e 698
6.63 FocusNavigationDIireCioNSYNIaX oo v eeneeas 699
6.64 FontCapi talSSYNAX .ccccccciiiiiiiiiiiiiiiiies e e 699
6.65 FONtEastASIanLanguageSyntaX .o s v 699
6.66 FontEastAsianWidthsSyntax 700
6.67 FontEmbeddingRightSyntax 700
6.68 FontFamilySyntax — ....cccccvieviieniieennn, 702
6.69 FONtFraClioNSYNIAX oo et rieee e eeee e 702
6.70 FontNumeralAlignmeNntSYNtaX v s e 703
6.71 FontNumeralStyleSyntaxX ..o e e 703
6.72 FONISIZESYNIAX  covciiviiiiiiiiiiiiiiiiiis et areeenee e .703
6.73 FONISIretChSYNtAX —  ccoiiiiiiiiiiiiiiiis e erreea e 703
6.74 FONISLYIESYNIAX oo e eeeeeaaee e 704
6.75 FONtVariantSSYNIAX oo e areeeee e 704
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6.76
6.77
6.78
6.79
6.80
6.81
6.82
6.83
6.84
6.85
6.86
6.87
6.88
6.89
6.90
6.91
6.92
6.93
6.94
6.95
6.96
6.97
6.98
6.99
6.100
6.101
6.102
6.103
6.104
6.105
6.106
6.107
6.108
6.109
6.110
6.111
6.112
6.113
6.114
6.115
6.116
6.117
6.118
6.119
6.120
6.121
6.122
6.123
6.124
6.125
6.126
6.127
6.128

FontWeightSyntax — ......ccccoeeviiiieiiiieeens
FrameworkPropertyMetadataOptionsSyntax
GeneratorDirectionSyntax
GeneratorStatusSyntax

GeometryCombineModeSyntax ~ ............

GeometrySyntax — .......cccoocieeeniieeennne.
GradientSpreadMethodSyntax ~ ............
GridLengthSyntax — ......cccccoevieeiieenienns

GridResizeBehaviorSynt  aX........ccccoeeeee..

GridResizeDirectionSyntax
GridUnitTypeSyntax
GridViewColumnHeaderRoleSyntax ...

HandoffBehaviorSyntax — .......ccccceevieennnen.

HitTestFilterBehaviorSyntax — .......c.......

HitTestResultBehaviorSyntax — ................

HorizontalAlignmentSyntax — ......ccceeee

ImeConversionModeValuesSyntax ...
ImeSentenceModeValuesSyntax — ...........

InheritanceBehaviorSyntax ~ ........c....c...
InkCanvasCli pboardFormatSyntax
InkCanvasEditingModeSyntax ~— .............

InkCanvasSelectionHitResultSyntax

InputMethodStateSyntax — ....cccceevceenen.
InputModeSyntax — .....cccovverieiieeeee

InputScopeNameValueSyntax ~ ............

InputScopeSyntax  .....ccceiiiiiinnieeee,
InputTypeSyntax  .....cccocoveericienineene
Int32CollectionSyntax
INt32RectSyntax ..o
IntersectionDetailSyntax
InvertAxesSyntax  .......ccccevveeennineeennns
IsOffscreenBehaviorSyntax
JournalEntryPositionSyntax
JournalOwnershipSyntax
JumpltemRejecti  onReasonSyntax .....
KernelTypeSyntax  ....ccccevvieviveneeeninens

KeyboardNavigationModeSyntax ...

KeyGestureSyntax  .....ccccoeeevviiiiiiieeeennnn.
KeySplineSyntax  .....cccccvevivenieenineens
KeyStatesSyntax  .......ccccceeveeiiiiiiniennn.
KeySyntax .cccccocvvvviiiiiiieeee e
KeyTimeSyntaXx  .......ccccoceeeiiiienennnn.

KeyTimeTypeSyntax  ..cccccoceeveeviveeeennnnn.
KeyTipHorizontalPla  cementSyntax (4.5)

KeyTipVerticalPlacementSyntax (4.5)
LengthSyntax — ..cccoveviieniienieee,
LineBreakConditionSyntax — ..........c.c...
LineStackingStrategySyntax — ..............

LocalizationCategorySyntax — .......c........
LogicalDirectionSyntax — .....ccccovcveerneenne

ManipulationModesSyntax — .......cccceeeue
Matrix3DSyntax — ...cccceeeviiieeeeeeeen
MatrixSyntax  .....cccceieeinieeeenn,

705
706
707
707
707
707
708
708
708
708
709
709
709
709
710
710
710
710
711
711
711
712
712
712
712
714
715
715
715
715
716
716
716
716
717
717
717
717
718
718
718
725
726
726
727

727

727
727
728
728
729
729
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6.129 MediaStateSYNtaX .o e e 729
6.130 MenultemRoleSyntax  ......cccceevviieeiiiiieeens 730
6.131 MessageBoxButtonSyntax 730
6.132 MessageBoxXImageSyNtaX s v eereeeaeeaen 730
6.133 MessageBoXOPtONSSYNIAX covciviiiieiiiiiiccciieiis e s arreee e s 731
6.134 MessageBOoXRESUISYNIAX .o v eeeee s 731
6.135 ModifiabilitySyNtax .ot e e 731
6.136 MOdIfIerKeYSSYNIAX oo e e 731
6.137 MOUSEACHONSYNIAX  coociiiiciiicciiiic e eeeere e s e aeereee e e 732
6.138 MouseBULtONSTAtESYNIAX .o e eeeeeere e 732
6.139 MOUSEBULIONSYNLAX  rivviiiiiiiiiiiiiiiieniiiiis eevvviriee e sinrrerneees veeeeesssnsrrereeae e 732
6.140 MOUSEGESIUIESYNIAX  tiiiiiiiiiciiiiiie s cvrveee e e e irrrrrn e aeeeeniereeee e 733
6.141 NavigatioNMOAESYNIAX  cocccciiiiiiieiciiieiriies e eeeeeeeeeaeeeae e 733
6.142 NavigationUIVisibilitySyntax s e e 733
6.143 NonClientFrameEdgesSyntax (4.5) i e .. 733
6.144 NumberCultureSoUrCeSYNIaX .occcciiciiiiiiciieciciiiies e eeeeraeeas 734
6.145 Num berSubstitutionMethodSyntax — ....cccccciiiiiiiiiiies 734
6.146 OrientatioNSYNIAX oo e e e 734
6.147 OVverflowMOdeSYNIAX  cooccevciiiiiiiiieiriiiiies e aeeeseee e e 734
6.148 PageRangeSeleCtionSYNIAX oot e aereeenees 734
6.149 PanningModeSY  NEAX .ccccccvvcviiiiiiiiiiiiiiies eereeenee e nees aeeeeneeeanneeaniee e 735
6.150 PathAnimationSOUrCESYNIAX —  ccccvciviiiiiiieiiieiiiens e eeeneeens 735
6.151 PathFigureCollectionSyntax 735
6.152 PenLineCapSyntax 735
6.153 PenLineJoinSyntax 736
6.154 PixelFormatSyntax 736
6.155 PlacementMOodeSYNtaX .o e e 739
6.156 PngInterlaceOptioNSYNtaX —  .ccvcciviiiiiiiiiiiiiiies e eeeneeeneeens 740
6.157 PoINt3DCOIIECHONSYNIAX ovviiiiiiiiicriie e e e 740
6.158 Point3DSyntax 740
6.159 Point4DSyntax 740
6.160 PointCollectionSyntax 741
6.161 POINISYNIAX  eoviiiiiiiiiiiii s e aeeee e .. 741
6.162 POPUPANIMALIONSYNIAX oo e eeeree e 741
6.163 POPUPPriMaryAXISSYNIAX —  .ociiciiiiiiiieiiiiiieiiiee e eeeeaeeee e 741
6.164 POWErLINESIAtUS  SYNAX occvviieiiiiiiiiiiieiiis e eeeree e 742
6.165 PresentationTracelLevelSyntax .iiiiiiiies e e 742
6.166 PropertyPathSyntaX ..o e e 742
6.167 QUALEINIONSYNIAX oo et aeeeeee e 742
6.168 ReadabilitySyNtax  .iiiiiiis e e 742
6.169 ReasonSessioNENdING  SYNAX oo e e 743
6.170 RecognitionConfiIdenceSyntaX .o e e 743
6.171 RECIBDSYNAX  cccoviiiiiiiiiciice s e e .743
6.172 RECISYNAX  civiiiiiiiiiiiiiiiiiiiiiies it eeeeeee s e 743
6.173 RelativeSourceModeSyNtaX —  ..cccccccciiiiiiiiiiiiiiis s areee e 744
6.174 RenderingBiaSSYNIaX .o e e 744
6.175 RepeatBehaviorSYNtaX ... e aeereeee e 744
6.176 RequestCachePoliCySYNtaXx .o e e 745
6.177 ResizeGripDirectionSyntax (4.5) o e e 746
6.178 RESIZEMOAESYNIAX i e e 746
6.179 ResourceDictionaryLocationSYNtaxX .o e . 147
6.180 RestoreFocU SMOAESYNAX ...cccceiiciiiiiiiiiieiiiiies et eeeereee e 747
6.181 RibbonApplicationMenultemLevelSyntax (4.5) e e 747
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6.182 RibbonControlLengthSyntax (4.5) oo e e 747
6.183 RibbonControlLengthUnitTypeSyntax (4.5) i e e et 747
6.184 RibbonDismissPopupModeSyntax (4.5) i e 747
6.185 RibbonimageSizeSyntax (4.5) s e reeaa 748
6.186 RibbonSplitButtonLabelPositionSyntax (4.5) e e 748
6.187 ROLAUONSYNIAX  ooiviiiiiiiiiiiiiriieiiis e nee areee s 748
6.188 ROUtEAEVENISYNIAX  cooviiiiiiiicciiiciiiiiies et e e aeereee e e 748
6.189 ROULINGSIrAtegYSYNIAX oo e eesree e 748
6.190 SamplingMOdeSYNIAX oo e eeeeaee e 749
6.191 ScrollBarVisibilitySYyNtaX oo e eeeree e 749
6.192 SCrollEVENITYPESYNIAX cocciiiiciiieiicieeeviiiiees eeeviee e esie e e e eerreeeenee e 749
6.193 ScrollUnitSyntax (4.5) i e eeerrea e 750
6.194 SelectioNMOAESY  NEAX ..ccccvcvvvriiiiiieiiiiriis e aeeeeeee e 750
6.195 SelectiveScrollingOrientatioNSYNtaxX .o e .. 751
6.196 ShaderRenderModeSYNtaX .o e e 751
6.197 ShutdownMOdESYNIAX —  cocccciiiiiie v et eeerree e e 751
6.198 SIZE3DSYNIAX  covciiriiiiiieiiicniieiiis s aaee e .751
6.199 SIZESYNIAX  iovciiriieiiiciiieiiieiits e e s 752
6.200 SizE€TOCONENISYNIAX  coccvvviiiiiiiiiiieriiieriies eveeereeesee e seeeniees ateeeseeeseeeseeenes 752
6.201 SIHPBEhaVIOrSYNtaX — oociiiiiiiiiiiiiiiiis et e 752
6.202 SPEEChMOESYNIAX  ccivcciiiiiiiiiiiiiiieriieiee eeeree e eeeseeenee e 752
6.203 SpellingReformSYNIaXx oo e e 753
6.204 StiCKYNOtETYPESYNAX iivcciiiiiiiii i eevreeerie e enes aereee e 753
6.205 StretchDIreCtiONSYNIAX oo e e 753
6.206 SIretChSYNIAX oo e e .753
6.207 StringColleCtioNSYNTAX oo e e 753
6.208 StrokeColleCtionSYNtaX .o e e 754
6.209 StyleSimulation  SSYNIAX .cccccviiiiiiiiiiiiiiiiie e eeenee e 754
6.210 StylusBULIONSIAESYNIAX coociviiiiciciicriiriies e eeaeeeeeas 754
6.211 StylusPointPropertyUnitSYNtaXx —  cocccciiieiiiiiiiiniiies e enee e eeeneeeas 754
6.212 StylusTipSyntax  ...cccccceverveeriveenneennne 755
6.213 SweepDirectionSyntax 755
6.214 SystemGestureSyntax 755
6.215 TabletDeviceTypeSyntax 756
6.216 TabletHardwareCapabilitieSSyntax .o e e 756
6.217 TaskbarltemProgressStateSyNtaX oo e e 756
6.218 TextAlIgNMENISYNIAX  oiiiiiiiiiiiiiiiiiieiiies et siiees eeee e 756
6.219 TextCollapsSingStyleSYNtaX —  .iiiiiiiiiiiiieiis s e 757
6.220 TextCompositi  ONAUIOCOMPIEIESYNIAX  oviiiiiiiiiiiiiicires e 757
6.221 TextDataFormatSYyNntax . e rrreeeeee s 757
6.222 TextDecorationColleCtiONSYNIAX oocviiiiiiivieviieiiis e aaeeeas 757
6.223 TextDecorationLoCatioNSYNtAX —  .coicciciiiiiiiiiiiieeiiies et e eeeeeene 757
6.224 TextDecorationUNItSYNtaX .o v eeeneeennes 758
6.225 TextFormattingModeSyNtaXx —  .cccciiiiiiiiieiies s eeee e 758
6.226 TextHINtiNgMOdESYNIAX .coiiiiiiiiiiiiiies e eeee e 758
6.227 TextMarkerStyleSyntaX .o e e 758
6.228 TextPointerCoNEXISYNIAX —  cocccciiiiiiiiiiiieeriees e eeeeeeee e 759
6.229 TextRenderingModeSyNtaX —  .oocccciiviiiiiiiiiiiis e eeneeeneeee 759
6.230 TextTabAlignmentSynta X tteitiiee et enree s anneeeesniee e ree e eeeeeaaeeeeeae 759
6.231 TextTrimmINGSYNAX oo e aeeeneee e 760
6.232 TextWrappingSYNIaX —  .occcciiiiiiiiiiiiieiiies e eeee e 760
6.233 ThIiCKNESSSYNIAX oot et eeeeeeee e 760
6.234 TickBarPlacementSyNta X .cccccciiiiiiiiiiiiiee e e 760
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6.235 TIiCkPlacementSYNIaX .o e e 761

6.236 TIffCOMPressOPtONSYNIAX oo ciciiiccciieies e eies arreeeeaaa 761
6.237 TileModeSyntaxX  ......ccccceiiieeiiiieeenns 761
6.238 TimeSeekOriginSyntax 762
6.239 ToleranCeTYPESYNIAX  iivviiiiciiiicciiieeiiiis eeevee e rees rreeeene e 762
6.240 TOUChACLIONSYNIAX  iiiiciiiiiiiiie i eeeee e eriee e rree e e eeeereeeaeateeeeeaneeas 762
6.241 TransfOrMSYNIAX cooiiiiiiiiiciiiciiiiiis et eerea e s 762
6.242 UNOACLONSYNIAX  oiiiiiiiiiiiiieiiiiiieiiies eeiee e e snee e snieees eeeeaaeeeeaaneeeeaneeas 762
6.243 UpdateSourceTriggerSYNaX —  .ocivceviiiieeiiiiieeiiiiis ceeeevsinr e e s e enine e eeeaneeeeas 763
6.244 ValidationErrorEVENtACHONSYNIAX oo e s 763
6.245 ValidationStepSyntax  ...ccccccceevviiieeiiiiieeenns 763
6.246 Vector3DCollectionSyntax 763
6.247 VeCtor3DSYNIAX oo e eeeeeeee e 763
6.248 VectorColleCtionSyNtaX .o vt eerree e e 764
6.249 VECIOISYNIAX  oociieiiiiiie e e nrree e eeeeee e .. 764
6.250 VerticalAlIgnmentSYNtaX i icieeviies v reeanee e 764
6.251 VirtualizationCacheLengthSyntax (4.5) i e 764
6.252 VirtualizationCacheLengthUnitSyntax (4.5) e e 765
6.253 VirtualizatioNMOdeSYNIaX .o e eeeneeeneens 765
6.254 ViSIDIlItySYNIAX oot s e s 765
6.255 WindowStartupLoCatioNSYNtAX —  ccccvccvviieiiiiniieiiiees e eeeneeeas 765
6.256 WiINdOWSIAESYNIAX ioccviiiiiiiiiiiciiieiiis e aeeeeree e 765
6.257 WINdOWSLYIESYNIAX  ccooicciiiiiiiciiiiiiiiiiiis v nree e eeeneeeeneee e 765
6.258 WrapDireCONSYNIAX — coccvciiiiiiiiiciiiiiiies et enees aeeeaeee e 766
6.259 XMILAGNQUAGESYNIAX oo iiieiiis e s aaeeeneee e 766
7 REfEIENCES oot et e aaeeaee 767
S T 0 To = RS 768
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1 Introduction

Xaml is defined in the Xaml Object Mapping Specification (referred to as ' MS - XAML] ' for short). The
MS - XAML] specification enables each application that uses Xaml to define its own vocabulary.
Vocabularies are formally specified using the Xaml Schema Information Set, a data model defined

by [MS -XAML] .

This specification defines the Xaml Schema Information Set information items for the Windows
Presentation Foundation (WPF) Xaml Vocabulary. The information items in the Xaml Schema

Information Set presented in this specification can be used in conjunctio nwith [MS-XAML] to
determine whether any particular Xaml instance or XML document is valid WPF Xaml.
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2 Specification Conventions

The [MS -XAML] specification only defines a data model for the Xaml Schema Information Set. It
does not prescribe the representation of the information items that constitute a schema. While
XAML] does in troduce a notation with which it defines its intrinsic information items, this
specification does not use that notation. Instead, a more compact representation is used to

minimize redundancy.

The WPF Xaml Vocabulary contains several thousand information it

make it easier to see each i

2.1 Xaml Types

tem's distinguishing features.

MS -

ems, many of which share much
in common. The following sections describe the conventions used in this specification, which exploit
this commonality to reduce the volume of text required to describe each information item, and to

The [MS -XAML] specification defines a XamlType Information Item. Throughout this specification,
when a XamIType Information Item is presented, only those values that do not match the default

value are listed. The following table defines the default values for a XamITyp

e Information Item.

Property Default Value
[is default constructible] True

[is nullable] True

[text syntax] Null
[dictionary key property] Null
[name property] Null

[xml lang property] Null

[trim surrounding whitespace] False
[whitespace significant collection] False

[is list] False

[is dictionary] False
[members] Empty set
[content property] Null
[allowed types] Empty set
[allowed key types] Empty set
[is xdata] False

[is name scope] False
[constructors] Empty set
[return value type] Null
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This specification denotes non  -default values for the information set items with rows that begin with
the relevant property name in square brackets. Each Xaml Type definition in this specification

includes some non -normative info rmation, in order to aid understanding of the type. In order to
distinguish them, these rows begin with a name in parentheses.

There is a (usage) row that illustrates the way in which the type is used in XML. If the type cannot
contain content, a self  -closing tag will be displayed, as the following example shows:

(usage) <DependencyObiject />

Some types offer a choice of content. The following example indicates that the three fixed string
values shown are acceptable as content:

(usage) OnLastWindowClose | OnMainWindowClose | OnExplicitShutdown

Elements that may contain string content look like the following example. Note that there are
typically constraints on which strings are valid. The purpose of the (usage) row is only to provide an
approximate indication of content, rather than a formal description.

(usage) <PropertyPath> string </PropertyPath>

Types that can contain an instance of some other type show the name of the type in the usage, as
shown in the following example:

(usage) < BeginStoryboard> Storyboard </BeginStoryboard>

Types that can contain multiple instances of some other type indicate this with an asterisk, as
shown in the following example:

(usage) <XmINamespaceMappingCollection> XmINamespaceMapping*
</XmINamespaceMappi ngCollection>

Some types cannot be used directly in a Xaml document. For example, a type might be used as the
[value type] of a member, but may be marked as [is default constructible] False, and have no [text
syntax]. A Xaml document might contain types t hat list such a type in their [types assignable to]
property, but the type itself cannot be used directly. (This corresponds to the idea of an abstract

type in some object -oriented programming systems.) Such types have "None" in their Usage row.

Type defin itions also include (description) rows, both for the type and also for the members of that
type. Thisis also non  -normative.

The (used by) row is also non -normative. Each (used by) row provides a list of types that use this
type in some way. For example, i t lists types that use this type as the [value type] of a member.
The (used by) row is provided to make it easier to see how a type is used, and it does not translate
into a property in the Xaml Schema Information Set.

Some types that are used as the [valu e type] of a member, but which are not typically used directly

as objects have a (types assignable from) row. This is non -normative, and is provided as a guide to
the role of the type. Note that this list is necessarily not complete, because the set of typ es from
which a type is assignable is not closed: anyone is free to define a new Xaml vocabulary which

defines types that are assignable to types in this specification.
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2.2 Xaml Type Order

Xaml types in this specification are ordered in an alphabetical way. The WPF Xaml Vocabulary uses

the [types assignable to] property in a way that corresponds to inheritance in object -oriented
programming. On the row above each type name is a list of '‘Base ' types. On the row below each
type name are types which directly 'inherit' from that type.

The following example shows the XamIType Information Items for the Fruit, Apple, and Banana
types.

Fruit

Fruit

Apple Banana

(usage) Value

é é

property N Value

Fruit> Apple

Apple

(usage) Value

é é

property N Value

Fruit> Banana

Banana (4.5)

(usage) Value

é é

property N Value

Since this specification models typical object -oriented inheritance, a 'derived' type inherits all

members from a 'base’ type. This is not made explicit. For each type, only additional members are

listed. The [MS-XAML] specification does not require this inheritance -like style. In the Xaml Schema
Information Set data model, each type lists its members exhaustively. Therefore, the correct

interpretation of a type definition in this specification i s that the corresponding XamIType

Information Item's [members] property should include not just the listed members, but also all of

the [members] of each type listed in its [types assignable to] property.

The "Banana" type, in the example above, has "(4.5) " listed after it to indicate that this type was
introduced in this XAML Vocabulary's version 4.5 release. All types or members without a version
number after it were released in versions previous to that.
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XamIMember Information Items have numerous propert ies, and in this specification, members are
more similar than they are different. So a notation is used to minimize redundancy. Some

XamlMember Information Item properties may be omitted. Unless specified otherwise, the default

values described in the foll  owing table apply.

Property Default Value
[text syntax] Null

[is read only] False

[is static] False

[is attachable] False

[target type] Null

[allowed location] Any

[is event] False

[is directive] False

Members are not defined in distinct sections of this specification - they are listed inside their

defining type following a row named (properties). This means that the [owner type] member defined

by [MS -XAML] is never specified explicitly in this specification. The [owner type] is always the type

in which the member definition appears. Likewise, the [members] property of the defining type is

never explicitly defined - it always contains all of th e members listed for that type. The [name] and
[value type] are specified on the first line of the property description. This line may be followed by

non -default values for other properties. The following example shows the XamIType Information

Item for the  Satsuma type, which defines a member named SegmentCount of type Int32.

Fruit > Satsuma

Satsuma

(usage) <Satsuma />

(description) Specifies a small, orange citrus fruit.
(properties)

SegmentCount Int32

(description) The number of segments in this satsuma.

If all of the XamIMember Information Item properties had been listed in full for this property, it
would look like the following table.

Property Value

[name] SegmentCount
[owner type] Satsuma
[value type] Int32
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Property Value
[text syntax] Null
[is read only] False
[is static] False
[is attachable] False
[target type] Null
[allowed location] Any
[is event] False
As with the type -level (description), the per -member (description) entries in this specification are

non - normative.

XamlIType Information Item descriptions in this document may contain up to three additional

member categories: attachable members, event members, and static members. These three

member categories have slightly different defaults, and are grouped separately in the type
definitions for clarity. The conventions for these member categories are defined in the following
sections.

2.3 Xaml Members where [is attachable] is True

A type that defines members whose [is attachable] property is True will list them in a section that

begins with "(attachable properties)". The following FruitBowl! type example defines a Children

member for which the normal defaults apply. This FruitBow! ty pe also defines an attachable member
named ZIndex for which [is attachable] is True. (The other member defaults still apply for ZIndex.)

Object > Bowl(T) > FruitBowl

FruitBowl

(usage) <FruitBowl>Fruit*</FruitBow!>
(description) A container of fruit.

[c ontent property] Children

(properties)

Children FruitCollection

(description) The items of fruit

(attachable properties)

FruitBowl.ZIndex Int32
(description) Indicates how deeply buried within the fruit bowl a piece of fruit is.
[target type] Fruit
The name for an attachable member is specified as TypeName .MemberName . This is a syntactical

convention to make it clear that this is an attachable property, and to illustrate how the property will
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look in a Xaml document. The [name] property of the XamIMember Information Item will only
contain the MemberName part (the part after the period).

2.4 Xaml Types where [is generic] is True

A type whose [is generic] property is Truue will be represented with a (T) notation following the
[type name]. "Bowl(Fruit)" would be describing a generic Bowl type, with Fruit as the type
argument.

Object > Bowl(T)

Bowl(T)

FruitBowl

(usage) <Bowl x:TypeArguments="T" >
(description) A container for different types of objects.
[is collection] True

2.5 Xaml Members where [is event] is True

A type that defines members whose [is event] property is True will list them in a section that begins
with "(events)". For members in this section, the default value for [value type] is the x:XamIEvent
type defined in Section 5" Intrinsic Schema Information Items "of [MS-XAML]. (The other defaults

still apply.)

2.6 Xaml Members where [is static] is True

A type that defines members whose [is static] property is True will list them in a section that begins
with "(static properties)".

2.7 Constructors

Types with a non -empty [constructors] property use a convention similar to that for members. This
example includes a constructor:

4.97.4 BruleeToppingExtension
(usage) {BruleeToppingExtension}
(description) Defines the way in which the topping on a brulée -style dessert is
prepared.
[types assignable to] Brulee MarkupExtension Object
(used by) FruitBrulee CremeBrulee
[return value type] BruleeTopping
[constructors]
(2 parameters)
thickness Double
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4.97.4 BruleeToppingExtension
(description) The thickness of the topping in 1/96th of an inch.
burnFactor Double
(description) The extent to which  the sugar is burnt: O for raw sugar, 1 for
carbon.

Unlike members, which are identified by names, a constructor for a type is distinguished only by the

number of parameters it has. This type has a single constructor that takes two parameters. This is

int erpreted as a Constructor Information Iltem, whose [arguments] contains one entry per

parameter. The [arguments] list contains just XamlIType Information Items - both the Double type in
this case. Note that the type is the only formal part of the constructor argument - the name and
description are only provided for informational purposes.
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3 The WPF Xaml Schema Information Set

The WPF Xaml Schema Information Item is a Xaml Schema Information Item (as defined in Section

3 " Xaml Schema Information Set "of [MS-XAML]). Its properties are defined in the following table.
Property Value
[target "http://schemas.microsoft.com/winfx/2006/xaml/presentation”
namespace]
[types] All of the XamIType Informat ion Items defined in the " WPF XamlIType Information

Iltems " section of this specification.

[assignable All of the XamIType Information Items defined in the " WPF XamlIType Information
types] Iltems for Assignable Types " section of this specification.

[directives]

The XamIMember Information Items defined in this specification for which the [is
directive] property is True.

[compatible Empty
with schemas]
A WPF Xaml instance MUST be well  -formed and valid with respect to this schema, using the rules for

‘well -formed' and 'valid' defined in MS - XAML] .

An XML document that is a WPF Xaml document MU ST yield a WPF Xaml instance when the
processing rules in Section 6 " Creating a Xaml Information Set from XML " are applied using this
schema.
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4 WPF XamlIType Information Items

4.1 AccessText

X:Object > DependencyObject > Visual > UlElement > FrameworkElement > AccessText,
IInputElement

(usage) <AccessText> x:String </AccessText>

(description) Specifies with an underscore the character that is used as the access key.
[content property] Text

[name property] Name

[xml lang property] Language

(properties)

Background Brush

(description)

The Brush that fills the content area.

BaselineOffset

x:Double

(description) A value that adjusts the baseline offset position of text in an AccessText
element.
FontFamily FontFamily

(description)

The font family to use with the AccessText element.

FontSize

x:Double

(description)

The font size to use with the AccessText element.

[text syntax]

FontSizeSyntax

FontStretch

FontStretch

(description)

A FontStretch property that selects a normal, condensed, or expanded font from
a FontFamily.

FontStyle

FontStyle

(descripti  on)

The font style to use with the AccessText element.

FontWeight

FontWeight

(description)

The font weight to use with the AccessText element.

Foreground

Brush

(description)

The Brush that draws the text content of the element.

LineHeight

x:Double

(description)

The height of each line box.
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(usage) <AccessText> x:String </AccessText>

[text syntax] LengthSyntax

LineStackingStrategy LineStackingStrategy

(description) How the LineHeight property is enforced.

Text x:String

(description) The text that is displayed by the AccessText element.

TextAlignment TextAlignment

(description) The horizontal alignment of the content.

TextDecorations TextDecorationCollection

(description) The decorations that are added to the text of an AccessText element.

TextEffects TextEffectCollection

(description) The effects that are added to the text of an AccessText element.

TextTrimming TextTrimming

(description) How the textual content of an AccessText element is clipped if it overflows the
line box.

TextWrapping TextWrapping

(description) Whether the textual content of an AccessText element is wrapped if it overflows
the line box.

4.2 AdornedElementPlaceholder

x:Object > DependencyObject > Visual > UlElement > FrameworkElement >
AdornedElementPlaceholder, lInputElement

(usage) <AdornedElementPlac eholder> UlElement </AdornedElementPlaceholder>

(description) Represents the element used in a ControlTemplate to specify where a decorated control
is placed relative to other elements in the ControlTempl ate.

[content Child

property]

[name Name

property]

[xml lang Language

property]

(properties)

Child UlElement

(description) The single child object of this AdornedElementPlaceholder object.
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4.3 AdornerDecorator

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Decorator >
AdornerDecorator, lInputElement

(usage) <AdornerDecorator>  UlElement </AdornerDecorator>
(description) Provides an AdornerLayer for the child elements in the visual tree.
[content property] Child

[name pro  perty] Name

[xml lang property] Language

(properties)

Child UlElement

(description) The single child of an AdornerDecorator.

4.4 AffineTransform3D

x:Object > DependencyObject > Freezable > Animatable > GeneralTransform3D > Transform3D >
AffineTransform3D

RotateTransform3D ScaleTransform3D TranslateTransform3D

(usage) None.

(description) Base type from which all concrete affine 3 -D transforms -- translations, rotations,
and scale transformations - derive.

[is default false

constructible]

4.5 AlignmentX

x:Object > AlignmentX

(usage) Left | Center | Right

(description) Describes how content is positioned horizontally in a container.
(used by) TileBrush

[is nullable] false

[text syntax] AlignmentXSyntax

4.6 AlignmentY

x:Object > AlignmentY

(usage) Top | Center | Bottom
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(usage)

Top | Center | Bottom

(description) Describes how content is positioned vertically in a container.
(used by) TileBrush
[is nullable] false

[text syntax]

AlignmentY Syntax

4.7 AlternationConverter

x:Object > AlternationConverter,

IValueConverter

(usage) <AlternationConverter>  x:Object _*</AlternationConverter>

(description) Converts an integer to and from an object by applying the integer as an index to a
list of objects.

[content Values

property]

(properties)

Values IList

(description) A list of objects that the AlternationConverter returns when an integer is passed to
the Culturelnfo) method.

[read only] true

4.8 AmbientLight

x:Object > DependencyObject > Freezable > Animatable > Model3D > Light > AmbientLight
(usage) <AmbientLight />
(description) Light object th at applies light to objects uniformly, regardless of their shape.

4.9 AnchoredBlock

x:Object

> DependencyObiject

> ContentElement > FrameworkContentElement > TextElement >

Inline > AnchoredBlock,

IInputElement

Figure _ Floater

(usage)

None.

(description)

A base type that provides a base for Inline elements that are used to anc hor
Block elements to flow content.

[is default false
constructible]
[content property] Blocks
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Figure Floater

[name property] Name

[xml lang property] Language
(properties)

Blocks BlockCollection

(description)

A BlockCollection containing the top
contents of the element.

-level Block elements that comprise the

[read only]

true

BorderBrush

Brush

(description)

A Brush to use when painting the element's border.

BorderThickness

Thickness

(description)

The border thickness for the element.

LineHeight

x:Double

(description)

The height of each line of content.

[text syntax]

LengthSyntax

LineStackingStrategy LineStackingStrategy

(description) The mechanism by which alin e box is determined for each line of text within
the text element.

Margin Thickness

(description) The margin thickness for the element.

Padding Thickness

(description) The padding thickness for the element.

TextAlignment

TextAlignment

(description)

A value that indicates the horizontal alignment of text content.

4.10 Animatable

x:Object > DependencyObject > Freezable > Animatable

GeneralTransform
Geometry
ImageSource

Brush CacheMode
GeneralTransform3D

DrawingCollection Effect
GeneralTransform3DCollection GeneralTransformCollection
Geometry3D GeometryCollection GradientStop GradientStopCollection GuidelineSet
Material _ MaterialCollection MediaPlayer  Model3D  Model3DCollection PathFigure
PathFigureCollection PathSegment PathSegmentCollection Pen PixelShader _ Rotation3D
TextDecoration TextDecorationCollection TextEffect  TextEffectCollection Timeline
TimelineCollection Transform3DCollection TransformCollection

Camera DashStyle  Drawing

(usage) None.
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Brush CacheMode

Camera DashStyle

Drawing  DrawingCollection Effect GeneralTransform

GeneralTransform3D

GeneralTransform3DCollection GeneralTransformCollection Geometry

Geometry3D

GeometryCollection

GradientStop GradientStopCollection GuidelineSet ImageSource

Material

MaterialCollection

MediaPlayer  Model3D _ Model3DCollection PathFigure

PathFigureCollection

PathSegment PathSegmentCollection Pen PixelShader _ Rotation3D

TextDecoration

TextDecorationCollection

TextEffect  TextEffectCollection Timeline

TimelineCollection

Transform3DCollection

TransformCollection

(description)

A base type that provides animation support.

[is default constructible]

false

4.11 AnimationTimeline

x:Object

> DependencyObiject

> Freezable > Animatable > Timeline > AnimationTimeline

BooleanAnimationBase

ByteAnimationBase CharAnimationBase ColorAnimationBase

DecimalAnimationBase

DoubleAnimationBase Int16AnimationBase Int32AnimationBase

Int64AnimationBase

MatrixAnimationBase ObjectAnimationBase Point3DAnimationBase

PointAnimationBase

QuaternionAnimationBase RectAnimationBase Rotation3DAnimationBase

SingleAnimationBase

SizeAnimationBase StringAnimationBase ThicknessAnimationBase

Vector3DAnimationBase

VectorAnimationB ase

(usage)

None.

(description)

Defines a segment of time over which output values are produced. These
values are used to animate a target property.

[is default constructible]

false

[name property]

Name

4.12 Application

x:Object > Application

(usage)

<Application />

(description)

Encapsulates an application.

(properties)

MainWindow Window

(description) The main window of the application.

Properties IDictionary

(description) A collection of application  -scope properties.
[read only] true

Resources ResourceDictionary

(description)

A collection of application  -scope resources, such as styles and

brushes.
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(usage)

<Application />

ShutdownMode ShutdownMode

(description) The condition that causes the Shutdown method to be called.
StartupUri x:Uri

(description) A Ul that is automatically shown when an application starts.

(attachable properties)

Application.Cookie x:String

(description)

[target type] x:Uri

(static properties)

Current Application

(description) The Application object for the current AppDomain.

(events)

Activated Occurs when an application becomes the foreground application.
Deactivated Occurs when an application stops being the foreground application.

DispatcherUnhandledException

Occurs when an exception is thrown by an application but not
handled.

Exit

Occurs just before an application shuts down, and cannot be
canceled.

FragmentNavigation

Occurs when a navigator in the application begins navigation to a
content fragment, Naviga  tion occurs immediately if the desired
fragment is in the current content, or after the source XAML content
has been loaded if the desired fragment is in different content.

LoadCompleted Occurs when content that was navigated to by a navigator in the
appl ication has been loaded, parsed, and has begun rendering.

Navigated Occurs when the content that is being navigated to by a navigator in
the application has been found, although it may not have completed
loading.

Navigating Occurs when a new navigation i s requested by a navigator in the

application.

NavigationFailed

Occurs when an error occurs while a navigator in the application is
navigating to the requested content.

NavigationProgress Occurs periodically during a download that is being managed by a
navigator in the application to provide navigation progress
information.

NavigationStopped Occurs when the StopLoading method of a navigator in the

application is called, or when a new navig ation is requested by a
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(usage)

<Application />

navigator while a current navigation is in progress.

SessionEnding

Occurs when the user ends the Windows session by logging off or
shutting down the operating system.

Startup

Occurs when the Run method of the Application object is called.

4.13 ApplicationCommands

x:Object > ApplicationCommands

(usage)

{x:Static ApplicationCommands.StaticPropertyName}

(description)

Provides a standard set of application related commands.

[is default constructible]

false

(static properties)

CancelPrint

RoutedUICommand

(description)

The value that represents the Cancel Print command.

Close

RoutedUICommand

(description)

The value that represents the Close command.

ContextMenu RoutedUICommand
(description) The value that represents the Context Menu command.
Copy RoutedUICommand

(description)

The value that represents the Copy command.

CorrectionList RoutedUICommand

(description) The value that represents the Correction List command.
Cut RoutedUICommand

(description) The value that represents the Cut command.

Delete RoutedUICommand

(description)

The value that represents the Delete command.

Find RoutedUICommand
(description) The value that represents the Find command.
Help RoutedUICommand
(description) The value that represents the Help command.
New RoutedUICommand
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(usage)

{x:Static ApplicationCommands.StaticPropertyName}

(description) The value that represents the New command.
NotACommand RoutedUICommand

(description) Represents a command which is always ignored.
Open RoutedUICommand

(description) The value that represents the Open command.
Paste RoutedUICommand

(description) The value that represents the Paste command.
Print RoutedUICommand

(description) The value that represents the Print command.

PrintPreview

RoutedUICommand

(description)

The value that represents the Print Preview command.

Properties

RoutedUICommand

(description)

The value that represents the Properties command.

Redo RoutedUICommand

(description) The value that represents the Redo command.
Replace RoutedUICo _mmand

(description) The value that represents the Replace command.
Save RoutedUICommand

(description)

The value that represents the Save command.

SaveAs RoutedUICommand

(description) The value that represents the Save As command.
SelectAll RoutedUICommand

(description) The value that represents the Se lect All command.
Stop RoutedUICommand

(description)

The value that represents the Stop command.

Undo

RoutedUICommand

(description)

The value that represents the Undo command.

4.14 ApplicationGesture

x:Object > ApplicationGesture
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(usage) AllGestures | ArrowDown | ArrowLeft | ArrowRight | ArrowUp | Check |
ChevronDown | ChevronLeft | ChevronRight

(description) Specifies the available application - specific .

[is nullable] false

[text ApplicationGestureSyntax

syntax]

4.15 ArcSegment

x:Object > DependencyObject > Freezable > Animatable > PathSegment > ArcSegment

(usage) <ArcSegment />

(description) Represents an elliptical arc between two points.

(properties)

IsLargeArc x:Boolean

(description) A value that indicates whether the arc should be greater than 180 degrees.

Point Point

(description) The endpoint of the el liptical arc.

RotationAngle x:Double

(description) The amount (in degrees) by which the ellipse is rotated about the x - axis.

Size Size

(description) The x - and y -radius of the arc as a Size structure.

SweepDirection SweepDirection

(description) A value that specifies whether the arc is drawn in the Clockwise or Counterclockwise
direction.

4.16 AutomationProperties

x:Object > AutomationProperties

(usage)

None.

(description)

Provides a way to manipulate the value of the
associated properties of the AutomationPeer element
instance.

[is default constructible] false
(attachable properties)
AutomationProperties.Acceleratorkey x:String
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(usage)

None.

(description)

The accelerator key for the specified element.

[target type]

DependencyObject

AutomationProperties.AccessKey

x:String

(description) The access key for the specified element.
[target type] DependencyObject
AutomationProperties.Automationld x:String

(description)

The string that uniquely identifies the specified
element.

[target type] DependencyObject
AutomationProperties.HelpText x:String

(description) The help text for the specified element. The help text
generally is the same tex  tthat is provided in the tooltip
for the control.

[target type] DependencyObject

AutomationProperties.IsColumnHeader x:Boolean

(description) A value indicating whether the specified element is a
column header.
[target type] DependencyObject

AutomationProperties.|sOffscreenBehavior

IsOffsc reenBehavior

(description)

[target type]

DependencyObject

AutomationProperties.IsRequiredForForm

x:Boolean

(description)

A value that indicates whether the specified element is
required to be filled out on a form.

[target type]

DependencyObject

AutomationProperties.IsRowHeader

x:Boolean

(description) A value indicating whether the specified element is a
row header.

[target type] DependencyObject

AutomationProperties.ltemStatus x:String

(description) A description of the status of an item within an
element.
[target type] DependencyObiject
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(usage) None.

AutomationProperties.ltemType x:String

(description) A description of the type of the specified element.
[target type] DependencyObject
AutomationProperties.LabeledBy UlElement

(description) The element that contains the text label for the

specified element.

[target type] DependencyObject
AutomationProperties.Name x:String

(description) The name of the element.
[target type] DependencyObiject

4.17 AutoToolTipPlacement

x:Object > AutoToolTipPlacement

(usage) None | TopLeft | BottomRight

(description) Describes the means by which the automatic ToolTip is positioned on a Slider control.
(used by) Slider

[is nullable] false

[text syntax] AutoToolTipPlacementSyntax

4.18 AxisAngleRotation3D

x:Object > DependencyObject > Freezable > Animatable > Rotation3D > AxisAngleRotation3D

(usage) <AxisAngleRotation3D />

(description) Represents a 3 -D rotation of a specified angle about a spec ified axis.
(properties)

Angle x:Double

(description) The angle of a3 -D rotation, in degrees.

Axis Vector3D

(description) The axis of a3 -D rot ation.

4.19 BackEase

x:Object > DependencyObject > Freezable > EasingFunctionBase > BackEase, |EasingFunction
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(usage) <BackEase />

(description) Represents an easing function that retracts the motion of an animatio n slightly before it
begins to animate in the path indicated.

(properties)
Amplitude x:Double
(description) The amplitude of retraction associated with a BackEase animation.

4.20 BaselineAlignment

x:Object > BaselineAlignment

(usage) Top | Center | Bottom | Baseline | TextTop | TextBottom | Subscript | Superscript

(description) Describes how the baseline for a text -based element is positioned on the vertical axis,
relative to the established baseline for text.

(used by) Inline

[is nullable] false

[text BaselineAlignmentSyntax
syntax]

4.21 BaseValueSource

x:Object > BaseValueSource

(usage) Unknown | Default | Inherited | DefaultStyle | DefaultStyleTrigger | Style |
TemplateTrigger | StyleTrigger | ImplicitStyleReference

(description) Identifies the property system source of a particular property value.

[is nullable] false

[text BaseValueSourceSyntax

syntax]

4.22 BeginStoryboard

x:Object > DependencyObject > TriggerAction > BeginStoryboard

(usage) < BeginStoryboard> Storyboard _</BeginStoryboard>
(description) A trigger action that begins a Storyboard and distributes its animations to their

targeted objects and properties.

[content Storyboard
property]

[name property] Name
(properties)
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(usage) < BeginStoryboard> Storyboard </BeginStoryboard>

HandoffBehavior HandoffBehavior

(description) The proper hand - off behavior to start an animation clock in th is storyboard
Name x:String

(description) The name of the BeginStoryboard object. By naming the BeginStoryboard object,

the Storyboard can be controlled after it is started.

Storyboard Storyboard
(description) The Storyboard that this BeginStoryboard starts.

4.23 BezierSegment

x:Object > DependencyObject > Freezable > Animatable > PathSegment

> BezierSegment

(usage) <BezierSegment />
(description) Represents a cubic Bezier curve drawn between two points.
(properties )
Pointl Point
(description) The first control point of the curve.
Point2 Point
(description) The second control point of the curve.
Point3 Point
(description) The end point of the curve.
4.24 Binding

x:Object > x:MarkupExtension > BindingBase > Binding

(usage)

{Binding }| <  Binding />

(description)

Provides high -level access to the definition of a binding, which
connects the properties of binding target objects, and any data
source (for example, a database, an XML file, or any object that
contains data).

[return value type] x:Object

[constructors]

(1 parameter)

path x:String

(description) The initial Path for the binding.
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(usage) {Binding } | <  Binding />

(properties)

AsyncState x:Object

(description) Opagque data passed to the asynchronous data dispatcher.

BindsDirectlyToSource

x:Boolean

(description) A value that indicates w  hether to evaluate the Path relative to the
data item or the DataSourceProvider object.

Converter 1ValueConverter

(description) The converter to use.

ConverterCulture

Culturelnfo

(description)

The culture in which to evaluate the converter.

[text syntax]

CulturelnfoletfLanguageTagSyntax

ConverterParameter

x:Object

(description)

The parameter to pass to the Converter.

ElementName x:String
(description) The name of the element to use as the binding sourc e object.
IsAsync x:Boolean

(description)

A value that indicates whether the Binding should get and set
values asynchronously.

Mode BindingMode
(description) A value that indicates the direction of the data flow in the binding.
NotifyOnSourceUpdated x:Boolean

(description)

A value that indicates whether to raise the SourceUpdated event
when a value is transferred from the binding target to the binding
source.

NotifyOnTargetUpdated

x:Boolean

(description)

A value that indicates whether to raise the TargetUpdated event
when a value is transfe  rred from the binding source to the binding
target.

NotifyOnValidationError

x:Boolean

(description)

A value that indicates whether to raise the Error attached event on
the bound object.

Path PropertyPath
(description) The path to the binding source property.
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(usage)

{Binding } | <  Binding />

RelativeSource

RelativeSource

(description) The binding source by specifying its location relative to the position
of the binding target.

Source x:Object

(description) The object to use as the binding source.

UpdateSourceTrigger UpdateSourceTrigger

(description) A value that determines the timing of binding source updates.

ValidatesOnDataErrors

x:Boolean

(description)

A value that indicates whether to include the
DataErrorValidationRule.

ValidatesOnExceptions

x:Boolean

(description)

A value that indicates whether to include the
ExceptionValidationRule.

ValidatesOnN  otifyDataErrors
(4.5)

x:Boolean

(description)

A value that indicates whether to include the
NotifyDataErrorValidationRule.

ValidationRules

Collectio n(ValidationRule )

(description)

A collection of rules that check the validity of the user input.

[read only] true
XPath x:String
(description) An XPath query that returns the value on the XML binding source to

use.

(attachable properties)

Binding.XmINamespaceManager

XmINamespaceManager

(description)

The XmINamespaceManager used to perform n amespace -aware
XPath queries in XML bindings.

[target type]

DependencyObject

(attachable events)

Binding.SourceUpdated

Occurs when a value is transferred from the binding target to the
binding source, but only for bindings with the
NotifyOnSourceUpdated value set to true.

Binding.TargetUpdated

Occurs when a value is transferred from the binding source to the
binding targe t, but only for bindings with the
NotifyOnTargetUpdated value set to true.
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4.25 BindingBase

x:Object > x:MarkupExtension _ > BindingBase

Binding _ MultiBinding PriorityBinding

(usage) None.
(description) A base type for binding types.
(used by) Condition DataGridBoundColumn _ DataGridColumn  DataGridComboBoxColumn

DataGridHyperlinkColumn DataTrigger  GridViewColumn
HierarchicalDataTemp late MultiBinding  PriorityBinding

[is default false
constructible]

[return value type] x:Object

(properties)

BindingGroupName X:String

(description) The name of the BindingGroup to which this binding belongs.

Delay (4.5) x:Int32

(description) The amount of time, in milliseconds, to wait before updating the binding source

after the value on the target changes.

FallbackValue x:Object

(description) The value to use when the bindi ng is unable to return a value.

StringFormat x:String

(description) A string that specifies how to format the binding if it displays the bound value
as a string.

TargetNullValue x:Object

(description) The value that is used in the target when the value of the source is null.

4.26 BindingGroup

x:Object > DependencyObject > BindingGroup

(usage) <BindingGroup />

(description) Contains a collection of bindings and ValidationRule objects that are
used to validate an object.

(used by) FrameworkContentElement FrameworkElement
HierarchicalDataTemplate ItemsControl

(properties)

Items IList
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(usage)

<BindingGroup />

(description) The sources that  are used by the Binding objects in the BindingGroup.
[read only] true

Name x:String

(description) The name that identifies the BindingGroup, which can be used to

include and exclude Binding objects in the BindingGroup.

NotifyOnValidationError

x:Boolean

(description) Whether the Error event occurs w hen the state of a ValidationRule
changes.
SharesProposedValues x:Boolean

(description)

A value that indicates whether the BindingGroup reuses target values
that have not been committed to the source.

ValidatesOnNotifyDataError
(4.5)

x:Boolean

(description)

A value that indicates whether to include the
NotifyDataErrorValidationRule.

ValidationRules

Collection (ValidationRule )

(description) A collection of ValidationRule objects that validate the source objects
in the BindingGroup.
[read only] true

4.27 BindingMode

x:Object > BindingMode

(usage)

TwoWay | OneWay | OneTime | OneWayToSource | Default

(description)

Describes the direction of the data flow in a binding.

(used by)

Binding MultiBinding

[is nullable]

false

[text syntax]

BindingModeSyntax

4.28 BindingOperations

x:Object > BindingOperations

(usage)

{x:Static BindingOperations.StaticPropertyName}

(description)

Provides static methods to manipulate bindings, including Binding,
MultiBinding, and PriorityBinding objects.
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(4.5)

(usage) {x:Static BindingOperations.StaticPropertyName}
[is default false

constructible]

(static properties)

DisconnectedSource x:Object

(description)

An object that replaces the DataContext when an item container is removed
from the visual tree.

4.29 BindingStatus

x:Object > BindingStatus

(usage) Unattached | Inactive | Active | Detached | AsyncRequestPending | PathError |
UpdateTargetError | UpdateSourceError

(description) Describes the status of a binding.

[is nullable] false

[text BindingStatusSyntax

syntax]

4.30 BitmapCache

x:Object > DependencyObject > Freezable > Animatable > CacheMode > BitmapCache

(usage) <BitmapCache> string </BitmapCache>

(description) Creates and caches a bitmap representation of a UIElemen t.

(used by) BitmapCacheBrush

[text syntax] CacheModeSyntax

(properties)

EnableClearType x:B oolean

(description) A value that indicates whether the bitmap is rendered with ClearType activated.
RenderAtScale x:Double

(description)

A value that indicates the scale that is applied to the bitmap.

SnapsToDevicePixels

x:Boolean

(description)

A value that indicates whether the bitmap is rendered with pixel snapping.

4.31 BitmapCacheBrush

x:Object > DependencyObject > Freezable > Animatable > Brush > BitmapCacheBrush
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(usage) <BitmapCacheBrush> string </BitmapCacheBrush>

(description) Paints an area with cached content.

[text sy ntax] BrushSyntax

(properties)

AutoLayoutContent x:Boolean

(description) A value that indicates whether layout is applied to the contents of this brush.
BitmapCache BitmapCache

(description) A CacheMode that represents cached content.

Target Visual

(description) The target visual to cache.

4.32 BitmapCacheOption

x:Object > BitmapCacheOption

(usage) Default | OnDemand | OnLoad | None

(description) Specifies how a bitmap image takes advantage of memory caching.
(used by) Bitmaplmage

[is nullable] false

[text syntax] BitmapCacheOptionSyntax

4.33 BitmapCreateOptions

x:Object > BitmapCreateOptions

(usage) None | PreservePixelFormat | DelayCreation | IgnoreColorProfile |
IgnorelmageCache

(description) Specifies initialization options for bitmap images.

(used by) Bitmaplmage

[is nullable] false

[text syntax] BitmapCreateOptionsSyntax

4.34 BitmapEncoder

x:Object > BitmapEncoder

BmpBitmapEncoder

GifBitmapEncoder JpegBitmapEncoder PngBitmapEncoder TiffBitmapEncoder

WmpBitmapEncoder
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BmpBitmapEncoder GifBitmapEncoder JpegBitmapEncoder PngBitmapEncoder TiffBitmapEncoder
WmpBitmapEncoder
(usage) None.

(description)

Encodes a collection of BitmapFrame objects to an image stream.

[is default constructible]

false

(properties)

ColorContexts

ReadOnlyCollection (ColorContext )

(description) A value that represents the color profile that is associated with this
encoder.

Frames IList (BitmapFrame )

(description) The individual frames within an image.

Preview BitmapSource

(description)

A BitmapSource that represents the global preview of a bitmap, if there is
one.

Thumbnail

BitmapSource

(description)

A BitmapSource that represents the global embedded thumbnail.

4.35 BitmapFrame

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource >

BitmapFrame

(usage) <BitmapFrame> string </BitmapFrame>
(description) Represents image data returned by a decoder and accepted by encoders.
(used by) BitmapEncoder

[is default constructible]

false

[text syntax]

x:Uri, from [MS -XAML

(properties)
BaseUri x:Uri
(description) A value that represents the base Uri of the current context.

4.36 Bitmaplmage

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource >

Bitmaplmage

(usage)

<Bitmaplmage> string </Bitmaplmage>
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(usage)

<Bitmaplmage> string </Bitmaplmage>

(description)

Provides a specialized BitmapSource that is optimized for loading images using
XAML.

[text syntax]

X:Uri, from [MS-XAML

(properties)

BaseUri x:Uri

(description) A value that represents the base Uri of the current Bitmaplmage context.
CacheOption BitmapCacheOption

(description) The BitmapCacheOption to use for this instance of Bitmaplmage.
CreateOptions BitmapCreateOptions

(description) The BitmapCreateOptions for a Bitmaplmage.

DecodePixelHeight x:Int32

(description)

The height, in pixels, that the image is decoded to.

DecodePixelWidth x:Int32

(description) The width, in pixels, that the image is decoded to.
Rotation Rotation

(description) The angle that this Bitmaplmage is rotated to.
SourceRect Int32Rect

(description)

The rectangle that is used as the source of the Bitmaplmage.

UriCachePolicy

RequestCachePolicy

(description)

A value that represents the caching policy for images that come from an HTTP
source.

[text syntax]

RequestCachePolicySyntax

UriSource

x:Uri

(description)

The Uri source of the Bitmaplmage.

4.37 BitmapScalingMode

x:Object > BitmapScalingMode

(usage) Unspecified | LowQuality | HighQuality | Linear | Fant | NearestNeighbor
(description) Specifies which technique is used to scale bitmap images.

(used by) RenderOptions

[is nullable] false
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(usage)

Unspecified | LowQuality | HighQuality | Linear | Fant | NearestNeighbor

[text syntax]

BitmapScalingModeSyntax

4.38 BitmapSource

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource

BitmapFrame Bitmaplmage CachedBitmap ColorConvertedBitmap CroppedBitmap

FormatConvertedBitmap RenderTargetBitmap TransformedBitmap WriteableBitmap

(usage) <BitmapSource> string </BitmapSource>

(description) Represents a single, constant set of pixels at a certain size and
resolution.

(used by) BitmapEncoder ColorConvertedBitmap  CroppedBitmap
FormatConvertedBitmap _ TransformedBitmap

[is default constructible] false

[text syntax] x:Uri, from  [MS - XAML

(events)

DecodeFailed

Occurs when the image fails to load, due to a corrupt image header.

DownloadCompleted

Occurs when the bitmap content has been completely downloaded.

DownloadFailed

Occurs when the bitmap content failed to download.

DownloadProgress

Occurs when the download progress of the bitmap content has changed.

4.39 Block

x:Object > Dependen

cyObject > ContentElement > FrameworkContentElement

> TextElement >

Block, linputElement

BlockUIContainer

List Paragraph

Section _ Table

(usage)

None.

(description)

A base type that provides a base for all block -level flow content

elements.
(used by) BlockCollection
[is default constructible] false
[name property] Name
[xml lang property] Language
(properties)
BorderBrush Brush
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BlockUIContainer List Paragraph  Section Table

(description) A Brush to use when painting the element's border.

BorderThickness Thickness

(description) The border thickness for the element.

BreakColumnBefore x:Boolean

(description) A value that indicates whether to automatically insert a column -break

before this elementin cas  es where the element participates in a
column -based presentation.

BreakPageBefore x:Boolean

(description) A value that indicates whether to automatically insert a page -break
before this element.

ClearFloaters WrapDirection
(description) The direction in which any Floater elements contained by a Block

element should be repositioned.

FlowDirection FlowDirection

(description) The relative direction for flow of content within a Block element.
IsHyphenationEnabled x:Boolean

(description) A value that indicates whether automatic hyphenation of words is

enabled or disabled.

LineHeight x:Double

(description) The height of each line of content.

[text syntax] LengthSyntax

LineStackingStrategy LineStackingStrategy

(description) How a line box is determined for each line of text within the block -level

flow content element.

Margin Thickness

(description) The margin thickness for the element.

Padding Thickness

(description) The padding thickness for the element.

SiblingBlocks BlockCollection

(description) A collection of Block elements that are siblings to the current Block
element.

[read only] true

TextAlignment TextAlig nment
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BlockUIContainer List Paragraph  Section Table

(description) The horizontal alignment of text content.

(attachable properties)

Block.IsHyphenationEnabled x:Boolean

(description) A value that indicates whether automatic hyphenation of words is
enabled or disabled.

[target type] DependencyObiject

Block.LineHeight x:Double

(des cription) The height of each line of content.

[target type] DependencyObject

[text syntax] LengthSyntax

Block.LineStackingStrategy LineStackingStrategy

(description) How a line box is determined for each line of text within the block -level

flow content element.

[target type] DependencyObiject
Block.TextAlignment TextAlignment

(description) The horizontal alignment of text content.
[target type] DependencyObiject

4.40 BlockCollection

x:Object > TextElementCollection _(Block ) > BlockCollection

(usage) None.

(description) Represents a collection of Block elements. BlockCollection defines the allowable
child content of the FlowDocument, Section, Listltem, TableCell, Floater, and
Figure elements.

(used by) AnchoredBlock Block FlowDocument Listltem Section TableCell

[is default false
constructible]

[is list] true

[allowed types] Block

4.41 BlockUIContainer

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement >
Block > BlockUIContainer, IInputElement
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(usage) <BlockUIContainer>  UlElement </BlockUIContainer>

(description) A block -level flow content element which enables UIElement elements (i.e. a Button)
to be embedded (hosted) in flow content.

[content Child

property]

[name Name

property]

[xml lang Language

property]

(properties)

Child UlElement

(description) The UlElement hosted by the BlockUIContainer.

4.42 BlurEffect

x:Object > DependencyObject > Freezable > Animatable > Effect > BlurEffect

(usage) <BlurEffect />

(description) A bitmap effect that blurs the target texture.
(properties)

KernelType KernelType

(description)

A value representing the curve that is used to calculate the blur.

Radius

x:Double

(description)

A value that indicates the radiu s of the blur effect's curve.

RenderingBias

RenderingBias

(description)

A value that indicates whether the system renders an effect with emphasis on speed or
quality.

4.43 BmpBitmapEncoder

x:Object > BitmapEncoder > BmpBitmapEncoder

(usage)

<BmpBitmapEncoder />

(description)

Defines an encoder that is used to encode bitmap (BMP) format images.

4.44 Bold

x:Object > DependencyObject > ContentElement > FrameworkContentElement > TextElement >

Inline_ > Span > Bold, linputElement
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(usage) <Bold>[ [nline |UlElement |x:String ]*</Bold>

(description) An inline -level flow content element which causes content to appear with a bold
font weight.

[content Inlines

property]

[name property] Name

[xml lang Language

property]

4.45 BooleanAnimationBase

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline >
BooleanAnimationBase

BooleanAnimationUsingKeyFrames

(usage) None.

(description) A base type that animates a Boolean value.
[is default constructible] false

[name property] Name

4.46 BooleanAnimationUsingKeyFrames

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline >
BooleanAnimationBase > BooleanAnimationUsingKeyFrames

(usage) <BooleanAnimationUsingKeyFrames> BooleanKeyFrame *</BooleanAnimationUsingKeyFrame
s>

(description Animates the value of a property that takes a Boolean along a set of KeyFrames over a

) specified Duration.

[content KeyFrames

property]

[name Name

property]

(properties)

KeyFrames BooleanKeyFrameCollection

(description The collection of Boolea nKeyFrame objects that define the animation.

)

4.47 BooleanKeyFrame

x:Object > DependencyObject > Freezable > BooleanKeyFrame
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DiscreteBooleanKeyFrame

(usage) None.

(description) A base type that defines a segment with its own target value and interpolation
technique for a BooleanAnimationUsingKeyFrames.

(used by) BooleanKeyFrameCollection

[is default false
constructible]

(properties)

KeyTime KeyTime

(description) The time at which the key frame's target Value should be reached
Value x:Boolean

(description) The key frame's target value.

4.48 BooleanKeyFrameCollection

x:Object > DependencyObject > Freezable > BooleanKeyFrameCollection

(usage) <BooleanKeyFrameCollection> BooleanKeyFrame *</BooleanKeyFrameCollection>
(description) Represents a collection of BooleanKeyFrame objects.

(used by) BooleanAnimationUsingKeyFrames

[is list] true

[allowed types] BooleanKeyFrame

(static properties)

Empty BooleanKeyFrameCollection

(description) An empty BooleanKeyFrameCollection.

4.49 BooleanToVisibilityConverter

x:Object > BooleanToVisibilityConverter, [ValueConverter
(usage) <BooleanToVisibilityConverter />
(description) Represents the converter that converts Boolean values to and from Visibility enumeration
values.
4,50 Border

x:Object > DependencyObject > Visual > UlElement > FrameworkElement > Decorator > Border,
lInputElement
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(usage)

<Border> UlElement _</Border>

(description) Draws a border, background, or both around another element.
[content property] Child

[name property] Name

[xml lang Langu age

property]

(properties)

Background Brush

(description) The Brush that fills the area between the bounds of a Border.
BorderBrush Brush

(description) The Brush that draws the outer border color.

BorderThickness

Thickness

(description)

The relative Thickness of a Border.

CornerRadius

CornerRadius

(description) A value that represents the degree to which the corners of a Border are rounded.
Padding Thickness
(description) A Thickness value that describes the amount of space between a Border and its

child element.

451 BorderGapMaskConverter

x:Object > BorderGapMaskConverter, IMultiValueConverter

(usage) <BorderGapMaskConverter />

(description) Represents a converter that converts the dimensions of a GroupBox control into a

VisualBrush.

4.52 BounceEase

x:Object > DependencyObject > Freezable > EasingFunctionBase > BounceEase, |EasingFunction

(usage) <BounceEase />

(description) Represents an easing function that creates an animated bouncing e ffect.
(properties)

Bounces x:Int32

(description) The number of bounces.
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(usage) <BounceEase />

Bounciness x:Double

(description) A value that specifies how bouncy the bounce animation is. Low values of this property
result in bounces with little lose of height between bounces (more bouncy) while high
values result in dampened bounces (less bouncy).

4.53 Brush

x:Object > DependencyObject > Freezable > Animatable > Brush

BitmapCacheBrush

GradientBrush SolidColorBrush TileBrush

(usage)

AliceBlue | AntiqueWhite | Aqua | Aquamarine | Azure | Beige | Bisque | Black |
BlanchedAlmond ...

(description)

Defines objects used to paint graphical objects. T ypes that derive from Brush
describe how the area is painted.

(used by)

AccessText AnchoredBlock Block Border BulletDecorator ContainerVisual —Control
DataGrid DataGridColumnHeader  DataGridRowHeader DataGridTextColumn
DiffuseMaterial  DrawingGroup EmissiveMaterial = FixedPage FlowDocument
FlowDocumentPageViewer  FlowDocumentReader  FlowDocumentScrollViewer
GeometryDrawing  GlyphRunDrawing  Glyphs InkCanvas Listitem Page Panel
PasswordBox Pen Ribbon RibbonButton RibbonCheckBox RibbonControlService
RibbonGalleryltem  RibbonGroup RibbonMenuButton  RibbonMenultem
RibbonRadioButton  RibbonSplitButton  RibbonTabHeader RibbonTextBox
RibbonToggleButton  RibbonTwolLineText Shape SpecularMat erial TableCell
TableColumn TextBlock TextBoxBase TextEffect TextElement TickBar ToolBarTray

UlElement Viewport3DVisual

[is default
constructible]

false

[text syntax]

BrushSynta x

(properties)

Opacity

x:Double

(description)

The degree of opacity of a Brush.

RelativeTransform

Transform

(description)

The transformation that is applied to the brush using relative coordinates.

Transform

Transform

(description)

The transformation that is applied to the brush. This transformation is applied
after the b rush's output has been mapped and positioned.

4.54 Brushes

x:Object > Brushes

(usage)

{x:Static Brushes.StaticPropertyName}
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(usage) {x:Static Brushes.StaticPropertyName}

(description) Implements a set of predefined SolidColorBrush objects.

[is default constructible] false

(static properties)

AliceBlue SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFOF8FF.
AntiqueWhite SolidColo rBrush

(description) The solid fill color that has a hexadecimal value of #FFFAEBD?7.
Aqua SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFOO0FFFF.
Aquamarine SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF7FFFDA4.
Azure SolidColorBrush

(description) The solid fill colo r that has a hexadecimal value of #FFFOFFFF.
Beige SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFF5F5DC.
Bisque SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFE4C4.
Black SolidColorBrush

(description) The solid fill colo r that has a hexadecimal value of #FF000000.
BlanchedAlmond SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFEBCD.
Blue SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFO000FF.
BlueViolet SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF8A2BE2.
Brown SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFA52A2A.
BurlyWood SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFDEB887.
CadetBlue SolidColorBrush
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(usage)

{x:Static Brushes.StaticPropertyName}

(description) The solid fill color that has a hexadecimal value of #FF5F9EAOQ.
Chartreuse SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF7FFF00.
Chocolate SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFD2691E.
Coral SolidColorBrush

(description) The solid fill colo r that has a hexadecimal value of #FFFF7F50.

CornflowerBlue

SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF6495ED.
Cornsilk SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFFF8DC.
Crimson SolidColorBrush

(description)

The solid fill co lor that has a hexadecimal value of #FFDC143C.

Cyan SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFO0FFFF.
DarkBlue SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF00008B.
DarkCyan SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF008B8B.

DarkGoldenrod SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFB8860B.
DarkGray SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFA9A9A9.
DarkGreen SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF006400.

DarkKhaki SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFBDB76B.
DarkMagenta SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF8B008B.

DarkOliveGreen

SolidColorBrush
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(usage)

{x:Static Brushes.StaticPropertyName}

(description) The solid fill color that ha s a hexadecimal value of #FF556B2F.
DarkOrange SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFF8CO00.
DarkOrchid SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF9932CC.
DarkRed SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF8B0000.
DarkSalmon SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFE9967A.
DarkSeaGreen SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF8FBC8F.
DarkSlateBlue SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF483D8B.

DarkSlateGray

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF2F4F4F.

DarkTurquoise

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFO0CED1.

DarkViolet

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF9400D3.

DeepPink SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFF1493.
DeepSkyBlue SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFO0BFFF.
DimGray SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF696969.

DodgerBlue SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF1E90FF.
Firebrick SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFB22222.
FloralWhite SolidColorBrush
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(usage)

{x:Static Brushes.StaticPropertyName}

(description) The solid fil | color that has a hexadecimal value of #FFFFFAFO.
ForestGreen SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF228B22.
Fuchsia SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFOOFF.
Gainsboro SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #~FDCDCDC.
GhostWhite SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFF8F8FF.
Gold SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFD700.
Goldenrod SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFDAA520.

Gray SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF808080.
Green SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF008000.
GreenYellow SolidColorBrush

(description)

The solid fill color that has a hexadecima | value of #FFADFF2F.

Honeydew SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFOFFFO.
HotPink SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFF69B4.
IndianRed SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFCD5C5C.

I ndigo SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF4B0082.
Ivory SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFFFFFO.
Khaki SolidColorBrush
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(usage)

{x:Static Brushes.StaticPropertyName}

(description) The solid fill color that has a hexadecimal value of #FFFOE68C.
Lavender SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFE6EGFA.

LavenderBlush

SolidColorBrush

(description) The solid fill color that has a hexa decimal value of #FFFFFOF5.
LawnGreen SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF7CFCO00.

LemonChiffon

SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFFACD.
LightBlue SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFADD8ES6.
LightCoral SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFF08080.

LightCyan

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFEOFFFF.

LightGoldenrodYellow

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFFAFAD?2.

LightGray

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFD3D3D3.

LightGreen SolidColorBrush

(description) The solid fill  color that has a hexadecimal value of #FF90EE90.
LightPink SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFB6C1.
LightSalmon SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFFFAQ7A.

LightSeaGreen SolidColorBrush

(description) The solid f ill color that has a hexadecimal value of #FF20B2AA.
LightSkyBlue SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF87CEFA.
LightSlateGray SolidColorBrush
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(usage)

{x:Static Brushes.StaticPropertyName}

(description) The solid fill color that has a hexadecimal value of #FF778899.
LightSteelBlue SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFBOC4DE.
LightYellow SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFFFEO.
Lime SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFO0FFOO.
LimeGreen SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF32CD32.
Linen SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFAFOE6.
Magenta SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFFFO0FF.

Maroon

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF800000.

MediumAquamarine

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF66CDAA.

MediumBlue

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFO0000CD.

MediumOrchid SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFBA55D3.
MediumPurple SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF9370DB.

MediumSeaGreen

SolidColorBrush

(descri  ption)

The solid fill color that has a hexadecimal value of #FF3CB371.

MediumSilateBlue

SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF7B68EE.
MediumSpringGreen SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFO0FA9A.

MediumTurquoise

SolidColorBrush
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(usage)

{x:Static Brushes.StaticPropertyName}

(description) The soli d fill color that has a hexadecimal value of #FF48D1CC.
MediumVioletRed SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFC71585.
MidnightBlue SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF191970.
MintCream SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFF5FFFA.
MistyRose SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFE4EL1.
Moccasin SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFE4B5.
NavajoWhite SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFFFDEAD.

Navy SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF000080.
OldLace SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFDF5E6.
Olive SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF808000.

OliveDrab SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF6B8E23.
Orange SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFFA500.
OrangeRed SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFFF4500.

Orchid

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFDA70D6.

PaleGoldenrod

SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFEEE8AA.

PaleGreen

SolidColorBrush
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(usage)

{x:Static Brushes.StaticPropertyName}

(description)

The solid fill  color that has a hexadecimal value of #FF98FB98.

PaleTurquoise

SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFAFEEEE.
PaleVioletRed SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFDB7093.
PapayaWhip SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFFEFD5.
PeachPuff SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFFDAB9.
Peru SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFCD853F.
Pink SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFFFCOCB.

Plum SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFDDAODD.
PowderBlue SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFBOEOES.
Purple SolidColorBrush

(description)

The solid fill color that has a hexadecima | value of #FF800080.

Red SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFF0000.
RosyBrown SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFBC8F8F.
RoyalBlue SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FF4169E1.

SaddleBrown

SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF8B4513.
Salmon SolidColorBrush
(description) The solid fill color that has a hexadecimal value of #FFFA8072.
SandyBrown SolidColorBrush
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(usage)

{x:Static Brushes.StaticPropertyName}

(description) The solid fill color that has a hexadecimal value of #FFF4A460.
SeaGreen SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF2E8B57.
SeaShell SolidColorBrush

(description) The solid fill color that has a hexa decimal value of #FFFFF5EE.
Sienna SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFA0522D.
Silver SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFC0OCO0CO.
SkyBlue SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF87CEEB.
Sla teBlue SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF6A5ACD.

SlateGray SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF708090.
Snow SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFFAFA.
SpringGreen SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FFO0FF7F.

SteelBlue SolidColorBrush

(description) The solid fill color that has a hexade cimal value of #FF4682B4.
Tan SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFD2B48C.
Teal SolidColorBrush

(description)

The solid fill color that has a hexadecimal value of #FF008080.

Thistle SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFD8BFDS8.
Tomato SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFF6347.
Transparent SolidColorBrush
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(usage) {x:Static Brushes.StaticPropertyName}

(description) The solid fill color that has a hexadecimal value of #00FFFFFF.
Turquoise SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF40E0DO.
Violet SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFEE82EE.
Wheat SolidColorBrush

(description) The solid fill colo r that has a hexadecimal value of #FFF5DEBS3.
White SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFFFFFFF.
WhiteSmoke SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FFF5F5F5.
Yellow SolidColorBrush

(description) The solid fill col or that has a hexadecimal value of #FFFFFFOO.
YellowGreen SolidColorBrush

(description) The solid fill color that has a hexadecimal value of #FF9ACD32.

4.55 BrushMappingMode

x:Object > BrushMappingMode

(usage) Absolute | RelativeToBoundingBox
(description) Specifies the coordinate system used by a Brush.
(used by) GradientBrush _ TileBrush

[is nullable] false

[text syntax] BrushMappingModeSyntax

456 BulletDecorator

X:Object > DependencyObject > Visual > UlElement > FrameworkElement > Decorator

BulletDecorator,

IInputElement

>

(usage)

<BulletDecorator>  UlElement _</BulletDecorator>

(description)

Represents a layout control that aligns a bullet and another visual object.

[content property]

Child
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(usage) <BulletDecorator>  UlElement _</BulletDecorator>
[nam e property] Name

[xml lang property] Language

(properties)

Background Brush

(description) The background color for a BulletDecorator control.
Bullet UlElement

(description)

The object to use as the bullet in a BulletDecorator.

4.57 Button

x:Object > DependencyObject > Visual > UIElement > FrameworkElement > Control >

Conte ntControl > ButtonBase > Button, lInputElement

CalendarButton CalendarDayButton RibbonButton

(usage) <Button> x:Object </Button>

(description) Represents a button control, which reacts to the CI ick event.

[content Content

property]

[name property] Name

[xml lang Language

property]

(properties)

IsCancel x:Boolean

(description) A value that indicates whether a Button is a Cancel button. A user can activate the
Cancel button by pressing the ESC key.

IsDefault x:Boolean

(description) A value that indicates whether a Button is t he default button. A user invokes the

default button by pressing the ENTER key.

4.58 ButtonBase

x:Object > DependencyObject > Visual > UlElement > FrameworkElement > Control >

Conte ntControl > ButtonBase, lInputElement

Button  DataGridColumnHeader DataGridRowHeader GridViewColumnHeader RepeatButton

ToqggleButton

(usage)

None.
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Button _ DataGridColumnHeader DataGridRowHeader GridViewColumnHeader RepeatButton
ToqgleButton

(description) Represents the base type for all Button controls.

[is default constructible] false

[content property] Content

[name property] Name

[xml lang property] Language

(properties)

ClickMode ClickMode

(description) When the Click event occurs.

Command ICommand

(description) The command to invoke when this button is pressed.
CommandParame  ter x:Object

(description) The parameter to pass to the Command property.
CommandTarget IInputElement

(description) The element on which to raise the specified command.

IsPressed x:Boolean

(description) A value that indicates whether a ButtonBase is currently activated.
(events)

Click Occurs when a Buttonis clic ~ ked.

4.59 ByteAnimation

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline >
ByteAnimationBase > ByteAnimation

(usage) <ByteAnimation />

(description) Animates the value of a Byte property between two target values using linear
interpolation over a specified Duration.

[name Name

property]

(properties)

By x:Nullable (x:Byte )

(description) The total amount by which the animation changes its starting value.

EasingFunction IEa singFunction
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(usage) <ByteAnimation />

(description) The easing function applied to this animation.

From x:Nullable (x:Byte )

(description) The animation's starting value.

IsAdditive x:Boolean

(description) A value that indicates whether the target property's current value should be added to
this animation's starting value.

IsCumulative x:Boolean

(description) A value that specifies whether the animation's value accumulates when it repeats.

To x:Nullable (x:Byte )

(description) The animation's ending value.

4.60 ByteAnimationBase

x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline >
ByteAnimationBase
ByteAnimation ByteAnimationUsingKeyFrames
(usage) None.
(description) A base type that animates a Byte value.
[is default constructible] false
[name property] Name
4.61 ByteAnimationUsingKeyFrames
x:Object > DependencyObject > Freezable > Animatable > Timeline > AnimationTimeline >

ByteAnimationBase

> ByteAnimationUsingKeyFrames

(usage) <ByteAnimationUsingKeyFrames> ByteKeyFrame __*</ByteAnimationUsingKeyFrames>
(description) Animates the value of a Byte property along a set of KeyFrame S.

[content KeyFrames

property]

[name Name

property]

(properties)

IsAdditive x:Boolean

(description)

A value that specifies whether the animation's output value is added to the base value
of the pr operty being animated.
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(usage) <ByteAnimationUsingKeyFrames> ByteKeyFrame _ *</ByteAnimationUsingKeyFrames>
IsCumulative x:Boolean

(description) A value that specifies whether the animation's value accumulates when it repeats.
KeyFrames ByteKeyFrameCollection

(description) The collection of ByteKeyFrame objects that define the animation.

4.62 ByteKeyFrame

x:Object > DependencyObject > Freezable > ByteKeyFrame

DiscreteByteKeyFrame EasingByteKeyFrame LinearByteKeyFrame SplineByteKeyFrame
(usage) None.
(description) A base type that defines an animation segment with its own target value and

interpolation technique for a ByteAnimationUsingKeyFrames.

(used by) ByteKeyFrameCollection
[is default false

constructible]

(properties)

KeyTime KeyTime

(description)

The time at which the key frame's target Value should be reached.

Value x:Byte
(description) The key frame's target value.

4.63 ByteKeyFrameCollection

x:Object > DependencyObject > Freezable > ByteKeyFrameCollection

(usage)

<ByteKeyFrameCollection>  ByteKeyFrame  *</ByteKeyFrameCollection>

(description)

Represents a collection of ByteKeyFrame objects.

(used by)

Byte AnimationUsingKeyFrames

lis list]

true

[allowed types]

ByteKeyFrame

(static properties)

Empty

ByteKeyFrameCollection

(description)

An empty ByteKeyFrameCollection.
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4.64 CachedBitmap

x:Object > DependencyObject > Freezable > Animatable > ImageSource > BitmapSource >
CachedBitmap

(usage) <CachedBitmap> string </CachedBitmap >
(description) Provides caching functionality for a BitmapSource.
[is default constructible] false

[text syntax] x:Uri, from  [MS - XAML

4.65 CacheMode

x:Object > DependencyObject > Freezable > Animatable > CacheMode

BitmapCache

(usage) <CacheMode> string </CacheMode>

(description) Provides a base implementation for caching a UIElement.
(use d by) ContainerVisual _ UlElement Viewport2DVisual3D

[is default constructible] false

[textsynta  X] CacheModeSyntax

4.66 CachingHint

x:Object > CachingHint

(usage) Unspecified | Cache

(description) Specifies whether to cache tile brush objects.
(used by) RenderOptions

[is nullable] false

[text syntax] CachingHintSyntax

4.67 Calendar

x:Object > DependencyObject > Visual > UlElement > FrameworkElement > Control > Calendar,
IInputElement

(usage) <Calendar />

(description) Represents a control that enables a user to select a date by using a visual
calendar display.

[name property] Name
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