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Creating a Transacted Resource Using 
System.Transactions (Lab 2) 

(Visual C#, Visual Basic) 
For the Visual Basic lab, go to page 17. 

 

Objectives 
After completing this lab, you will be able to: 

a. Create a transacted resource with System.Transactions 
b. Serialize Transactions 
c. Use System.Transactions events such as 

DistributedTransactionStarted event and 
TransactionCompleted event 

 

Prerequisites 
Before working on this lab, you must have the 
following installed on your machine (installed by 
default on the Virtual PC image): 

a. .NET Framework  v2.0 
b. Visual Studio .NET 2005 

 
* It is highly recommended that you complete Lab 1 (Using 
System.Transactions to write reliable applications) before 
starting this lab. 

 

Scenario 
This demo introduces you to some of the more 
advanced features of System.Transactions.  It starts by 
having you create your own transacted resource.  It then 
has you create a client that creates a transaction and 
serializes it to the transacted resource.  It ends by 
showing you how to use the 
DistributedTransactionStarted event and the 
TransactionCompleted event.  
 
Estimated time to complete this lab: 60 minutes 

 

Note: 
The code for all these exercises is on your lab machine 
at C:\Microsoft Hands On 
Labs\HOL205\TxLab2\CS\CompletedExercises. If 
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you wish, you can open these files and cut and paste the 
code into your project instead of typing it. 

Exercise 1 
Creating a Transacted Resource 
In this exercise, you will create a console test application in Visual C# .NET.  The 
application will include a transacted resource (in this case a transacted integer) that 
enlists in the transaction.  The integer will commit or abort the changes made to it based 
on the outcome of the Transaction. This lab will teach you how to enlist and participate in 
Transactions using the IEnlistmentNotification interface. You will use the Microsoft 
Visual Studio .NET Development Environment to create, compile, and run this lab. 
 

Tasks Detailed steps 

1.  Open project for 
Lab2 in Visual Studio 

a. Click Start->Programs->Microsoft Visual Studio 2005 Beta 2-
>Microsoft Visual Studio 2005 Beta 2. 

b. Click File->Open->Project/Solution. 
c. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\CS\Exercises\Exercise1 and select the file 
Lab2.sln. 

d. Click Open. 

2.  Add a reference to 
System.Transactions 

a. Click View->Solution Explorer. 
b. In Solution Explorer, right-click on References and click Add 

Reference… 
c. With the .NET tab selected, select the component name 

System.Transactions.dll. 
d. Click OK 

3.  Add a using 
statement for 
System.Transactions 

a. Open TxInt.cs by double clicking it in the Solution Explorer 
b. At the top of TxInt.cs add the following: 
using System.Transactions; 

4.  Build your 
application 

a. Select Build->Build Solution. 
b. If the build is successful, you will see the following in the output 

window: 
Build: 1 succeeded or up-to-date, 0 failed, 0 skipped 

 
5.  Code a class for the 
transacted integer 

a. Open TxInt.cs and add the following to the TxInt class in the 
ResourceManager namespace.  The TxInt class will be the transacted 
integer.  We are just defining two constructors and a property called val 
that you can Get and Set. 

 
    public class TxInt 
    { 
 
        private int livevalue; 
        private Hashtable enlistmentTable = new Hashtable(); 
    
        public TxInt() 
        { 
 

Formatted: Bullets and Numbering
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        } 
        public TxInt(int value) 
        { 
            livevalue = value; 
        } 
 
        public int val 
        { 
            get 
            { 
                return GetValue(); 
            } 
 
            set 
            { 
                SetValue(value); 
            } 
        } 
    } 
The livevalue integer represents the current value for the 
integer when it is accessed outside of a Transaction.  The 
enlistmentTable is a standard hash table that will hold the 
integer values that are Set under Transactions. 

 

6.  Add an internal 
class that will be used 
to enlist in the 
transaction 

a. Next we will create a class that derives from IEnlistmentNotification 
that can be used to enlist in a transaction.  This class will be an 
enlistment in the transaction that stores the temporary value of the 
integer for a given transaction.  So when a user tries to set the value of a 
TxInt object within a transaction, a TxTmpValue object will be created 
to store the value of the integer temporarily until the transaction 
completes. 

 
    internal class TxTmpValue : IEnlistmentNotification 
    { 
        internal int val;  // Holds the temporary value 
         
  TxInt parent;     //Pointer to the 'real' value 
        Transaction tx;    //Transaction it is enlisted in 
 
        public TxTmpValue (TxInt p, Transaction t) 
        { 
            parent = p; 
            tx = t; 
        } 
 
        #region IEnlistmentNotification Members 
 
        void IEnlistmentNotification.Commit(Enlistment 
enlistment) 
        { 
            Console.WriteLine("\n ****** "); 
            Console.WriteLine("Enlistment received Commit"); 
            Console.WriteLine(" ****** \n"); 
            parent.CommitTransaction(val, tx); 
 
            enlistment.Done(); 
        } 
 
        void IEnlistmentNotification.InDoubt(Enlistment 
enlistment) 
        { 
            enlistment.Done(); 
        } 
 
        void IEnlistmentNotification.Prepare(PreparingEnlistment 
preparingEnlistment) 
        { 
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            preparingEnlistment.Prepared(); 
        } 
 
        void IEnlistmentNotification.Rollback(Enlistment 
enlistment) 
        { 
            Console.WriteLine("\n ****** "); 
            Console.WriteLine("Enlistment received Rollback"); 
            Console.WriteLine(" ****** \n"); 
 
            parent.AbortTransaction(tx); 
            enlistment.Done(); 
        } 
 
        #endregion 
    } 
IEnlistmentNotification contains four methods (Prepare, Commit, 
Rollback, and InDoubt).  When you enlist in a Transaction, you 
pass in an object that implements this interface.  When Commit() 
is called on the CommittableTransaction, all enlistments will be 
asked to prepare.  This is done by the TransactionManager 
calling Prepare one all of the enlistments. When an enlistment 
is done preparing, it calls back Prepared() or ForceRollback().  
Since our example does not do any work in Prepare, we always 
return Prepared.  Once the Transaction has completed, it will 
notify the enlistments by calling either Commit, Rollback or 
InDoubt, depending on the outcome of the Transaction.  In our 
example, we call AbortTransaction or CommitTransaction methods 
on the TxInt depending on the Transaction outcome. 

 

7.  Implement the 
GetValue and 
SetValue methods in 
the TxInt class 

a. Add SetValue() to the TxInt class 
 

        private void SetValue(int value) 
        { 
            Transaction tx; 
            TxTmpValue enlistment; 
 
            // Get current transaction 
            tx = Transaction.Current; 
 
            // If none -- set the real value 
            if(tx == null) 
            { 
                livevalue = value; 
                return; 
            } 
 
            // Check if already enlisted for that transaction 
            enlistment = (TxTmpValue)enlistmentTable[tx]; 
            if(enlistment == null) 
            { 
                // If not -- create an enlistment structure 
                enlistment = new TxTmpValue(this, tx); 
                enlistmentTable.Add(tx, enlistment); 
 
                // Enlist with TM 
                tx.EnlistVolatile(enlistment, 
EnlistmentOptions.None); 
            } 
 
            enlistment.val = value; 
        } 
 
SetValue() takes an integer and sets it as the current 
transacted integer value.  If SetValue is not called under a 
Transaction, it simply sets livevalue to the value passed in 
where it becomes the immediate value of the transacted integer.  
If there is a Transaction in Transaction.Current, it will 
associate the value passed in with an enlistment, so that when 
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the Transaction is Committed or Aborted, the enlistment can 
update livevalue appropriately.  SetValue checks the enlistment 
hash table to see if it has already created an enlistment for 
this Transaction.  If it has, it resets enlistment.val to the 
new value passed in.  If not, it will create a new enlistment 
object (TxTmpValue), add it to the enlistment table, and then 
enlist in the transaction with this new enlistment object. 
 
To enlist it uses  
tx.EnlistVolatile(enlistment, EnlistmentOptions.None); 

 
b. Add GetValue() to the TxInt class. 

 
        private int GetValue() 
        { 
 
            Transaction tx; 
            TxTmpValue enlistment; 
 
            // Get current transaction 
            tx = Transaction.Current; 
 
            // If none -- return live value 
            if (tx == null) 
                return livevalue; 
 
            // Running under a transaction context 
            enlistment = (TxTmpValue)enlistmentTable[tx]; 
            if (enlistment == null) 
                return livevalue; 
 
            return enlistment.val; 
        } 
 
GetValue() returns the current value of the transacted integer.  
If there is no ambient transaction when Get is called, it 
returns the livevalue.  Otherwise, it checks to see if there are 
any enlistments associated with the Transaction.  If there is an 
enlistment, it returns the value associated with the enlistment 
because that is the current value until the Transaction commits 
or aborts. 
 
 

8.  Implement the 
CommitTransaction 
and AbortTransaction 
methods in the TxInt 
class 

a. Add CommitTransaction and AbortTransaction methods to TxInt class.  
These methods are called by the TxTmpValue enlistment class when 
the Transaction commits or aborts.   

 
        // Called when the transaction is committed 
        internal void CommitTransaction(int val, Transaction tx) 
        { 
            // Set the live value 
            livevalue = val; 
 
            // Remove the state associated with the transaction 
            enlistmentTable.Remove(tx); 
        } 
 
        // Called when the transaction is aborted 
        internal void AbortTransaction(Transaction tx) 
        { 
            // Remove the state associated with the transaction 
            enlistmentTable.Remove(tx); 
        } 
 
CommitTransaction takes the value that was stored by the 
enlistment and sets it as the livevalue.  It then removes the 
enlistment from the hash table because the Transaction is 
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completed and will not be used again. returns the current value 
of the transacted integer.  If there is no ambient transaction 
when Get is called, it returns the livevalue.  Otherwise, it 
checks to see if there are any enlistments associated with the 
Transaction.  If there is an enlistment 

 

9.  Add a Main method 
to the RemoteRM class 
that uses the transacted 
integer 

a. Open the RemoteRM.cs file by clicking RemoteRM.cs in the Solution 
Explorer. 

b. Add a Main method that creates a TransactionScope and uses the 
transacted integer within the scope of a Transaction. 
 

        static void Main(string[] args) 
        { 
            string Msg1 = "Would you like to complete the 
TransactionScope? Saying no will cause an exception to be 
thrown."; 
            DialogResult completeScope1 = MessageBox.Show(Msg1, 
"Complete Scope", MessageBoxButtons.YesNo); 
 
 
            TxInt txInt = new TxInt(3); 
         
            Console.WriteLine("RM Creating Scope");             
            Console.WriteLine("TxInt value before scope: " + 
txInt.val); 
 
            try 
            { 
                using (TransactionScope ts = new 
TransactionScope()) 
                { 
                    txInt.val = 5; 
                    Console.WriteLine("TxInt value inside scope: 
" + txInt.val); 
 
                    if (completeScope1 == DialogResult.No) 
                    { 
                        Console.WriteLine("Throwing new 
exception from TransactionScope."); 
                        throw new 
ApplicationException("Exception from TransactionScope."); 
                    } 
 
                    ts.Complete(); 
                } 
 
            } 
            catch (TransactionAbortedException e) 
            { 
                Console.WriteLine(e); 
            } 
            catch (ApplicationException e) 
            { 
                Console.WriteLine(e); 
            } 
 
            Console.WriteLine("TxInt value after scope: " + 
txInt.val); 
 
            PauseForExit();  
        } 
 

10.  Add a using 
statement for 
System.Transactions 

a. At the top of RemoteRM.cs add the following: 
using System.Transactions; 
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11.  Build your 
application 

a. Select Build->Build Solution. 
b. If the build is successful, you will see the following in the output 

window: 
Build: 1 succeeded or up-to-date, 0 failed, 0 skipped 

 
12.  Run the application a. Click Debug->Start Debugging 

A dialog box will appear and if Yes is selected, Complete() 
will be called on the TransactionScope and the transaction 
will Commit.  Since the transaction commits, the changes made 
to the transacted integer will be reflected in the last print 
out of the integer value.  If No is selected, an exception 
will be thrown and the TransactionScope will not be 
completed.  This will cause the transaction to abort and the 
changes made to the integer will automatically be rolled 
back.  

 
 

Conclusion 
 

In this exercise we created a transacted resource using 
transaction enlistments.  The resource enlists in a 
transaction and it receives notifications regarding the 
outcome of the transaction through its 
IEnlistmentNotification implementation.  The resource 
we created a volatile resource because it does not log 
state and therefore cannot perform recovery.   
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Exercise 2 
Serialize a Transaction from a client to a resource 
manager (RM) 
In this exercise, you will see how easy it is to pass transactions. We will use remoting to 
set up a client and a resource manager (RM).  The client will serialize a transaction to the 
RM we created in Exercise 1 and the RM will modify its transacted integer under the 
transaction that it receives. 
 

Tasks Detailed steps 

1.  Open project for 
Lab 2 in Visual 
Studio 

a. Click Start->Programs->Microsoft Visual Studio 2005 Beta 2-
>Microsoft Visual Studio 2005 Beta 2. 

b. Click File->Open->Project/Solution. 
c. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\CS\Exercises\Exercise2 and select the file 
Lab2.sln. 

d. Click Open. 

2.  Add the client 
project that 
contains the client 
application 

a. Click View->Solution Explorer. 
b. In Solution Explorer, right-click on Solution ‘Lab2’ solution and click 

Add -> Existing Project… 
c. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\CS\Exercises\Exercise2\Client and select the file 
Client.csproj. 

d. Click Open 

3.  Add a using 
statement for 
System.Transaction
s 

a. Open Client.cs by double clicking it in the Solution Explorer 
b. At the top of Client.cs add the following: 
using System.Transactions; 

4.  Add a 
TransactionScope 
to the client 

a. Add a TransactionScope to the Main method in the client.  The 
TransactionScope will create the Transaction that we will pass the resource 
manager.  Note:  the code that is already in place in this Main method is to 
set up the remoting. 

try 
{ 
   // Code to set up remoting 
   TcpChannel channel = new TcpChannel(); 
   ChannelServices.RegisterChannel(channel); 
 
   Console.WriteLine("Channel Registered"); 
   rm1 = (IRemoteRM)Activator.GetObject(typeof(IRemoteRM), 
"tcp://localhost:12345/RM1.rem"); 
   Console.WriteLine("RM retrieved:" + rm1.ToString()); 
 
   using (TransactionScope ts = new TransactionScope()) 
   { 
 
      Console.WriteLine("Calling RMCreateScope on the remote RM."); 
 
      if (completeScope1 == DialogResult.No) 
      { 
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         Console.WriteLine("Throwing new exception from 
TransactionScope."); 
         throw new ApplicationException("Exception from 
TransactionScope."); 
      } 
 
      ts.Complete(); 
   } 
 
} 
catch (TransactionAbortedException e) 
{ 
   Console.WriteLine(e); 
} 
catch (ApplicationException e) 
{ 
   Console.WriteLine(e); 
} 
finally 
{ 
   Console.WriteLine("Client finished.  Press Enter to exit."); 
   Console.ReadLine(); 
} 
   

5.  Add calls to the 
resource manager 

a. Inside the TransactionScope, make a remoting call to the Resource 
Manager and pass it the Transaction that the TransactionScope has placed 
inside Transaction.Current.  The Transaction will automatically be 
serialized to the resource managers app domain for you!  Also add a call to 
to the Resource Manager to print the current value of its transacted integer. 

using (TransactionScope ts = new TransactionScope()) 
{ 
 
   Console.WriteLine("Calling RMCreateScope on the remote RM."); 
    
   rm1.RMCreateScope(Transaction.Current); 
 
   rm1.RMPrintTxIntValue(); 
 
   if (completeScope1 == DialogResult.No) 
   { 
      Console.WriteLine("Throwing new exception from 
TransactionScope."); 
      throw new ApplicationException("Exception from 
TransactionScope."); 
   } 
 
   ts.Complete(); 
} 

 
 
b. Add another remote call to the Resource Manager to print the transacted 

integer value after the TransactionScope ends.   We will add this in the 
finally block. 

 
            finally 
            { 
                rm1.RMPrintTxIntValue(); 
 
                Console.WriteLine("Client finished.  Press Enter to 
exit."); 
                Console.ReadLine(); 
            } 
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6.  Enable the 
remote server 

a. We want to create a remote server that will be running so that the client can 
connect to the RM and use remoting to make method calls on the RM.  
Since this is all remoting code that does not have anything specific to do 
with Transactions, we have placed the code inside RMServer.cs and all you 
have to do is uncomment all of the code inside this file. 

b. Open RMServer.cs by double clicking it in the Solution Explorer. 
c. Delete the comments from around the code (/* and */) 

7.  Add the 
RemoteInterface 
project  

a. Another thing we need in order to enable remoting is an interface that the 
client and resource manager can share.  We have defined an interface in a 
project called RemoteInterface, and we need to include this project in our 
solution. 

b. Click View->Solution Explorer. 
c. In Solution Explorer, right-click on Solution ‘Lab2’ solution and click 

Add -> Existing Project… 
d. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\CS\Exercises\Exercise2\RemotingInterface and 
select the file RemotingInterface.csproj. 

e. Click Open 

8.  Build the 
RemoteInterface 
project 

a. Build the RemoteInterface project to create a class library that we can add 
references to in our client and resource manager projects.  This will allow 
us to access the IRemoteRM interface contained in the RemoteInterface 
project. 

b. Right click on the RemoteInterface project in the Solution Explorer and 
select Build. 

c. If the build is successful, you will see the following in the output window: 
Build: 1 succeeded or up-to-date, 0 failed, 0 skipped 

 
9.  Add references 
to RemoteInterface 

a. In Solution Explorer under Client, right-click on References and click 
Add Reference… 

b. Choose the Browse tab and navigate to  C:\Microsoft Hands On 
Labs\HOL205\TxLab2\CS\Exercises\Exercise2\RemotingInterface\Bin
\Debug and select RemotingInterface.dll. 

c. Click OK 
d. Repeat steps a-c for the References under ResourceManager 

10.  Add using 
statement for 
RemoteInterface 

a. Open RemoteRM.cs by double clicking it in the Solution Explorer 
b. At the top of RemoteRM.cs add the following: 
using RemotingInterface; 

11.  Modify the 
RemoteRM class so 
it can be used for 
remoting 

a. In order for the RemoteRM to work with remoting, we need to add 
MarshalByRefObject and have it derive from an interface that is 
recognized by both the client and the resource manager. 

b. Open RemoteRM.cs by double clicking it in the Solution Explorer 
c. Add the following to the RemoteRM 
public class RemoteRM : MarshalByRefObject, IRemoteRM 

 
d. We then need to delete the Main method in RemoteRM.cs since the Main 

method for this project is now in RMServer.cs.  Open RemoteRM.cs by 
double clicking RemoteRM.cs in the Solution Explorer.  Delete the entire 
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Main method (Not just the contexts of the method). 
 

        public static void Main(string[] args) 
        { 
           … 
        } 

 
e. After removing Main, we want to add the following methods that we need 

for the IRemoteRM interface.  The RMCreateScope method is the method 
the client will call to pass the Transaction to the RM.  Inside, we create a 
TransactionScope and pass in the transaction we received from the client as 
a parameter.  The RMPrintTxIntValue prints out the current value of the 
TxInt. 

        public RemoteRM() 
        { 
        } 
 
        public override string ToString() 
        { 
            return "This is a remote Resource Manager"; 
        } 
 
 
        #region IRemoteRM Members 
 
        public void RMCreateScope(Transaction tx) 
        { 
            Console.WriteLine("RM Creating Scope with Transaction 
from Client"); 
             
             
            try 
            { 
                using (TransactionScope ts = new 
TransactionScope(tx)) 
                { 
                    ts.Complete(); 
                } 
            } 
            catch (TransactionException e) 
            { 
                Console.WriteLine(e); 
            }   
             
            Console.WriteLine("Scope finished");           
        } 
 
        public void RMPrintTxIntValue() 
        { 
            Console.WriteLine("TxInt value from remote call: " + 
txInt.val); 
        } 
 
        #endregion 

 

12.  Add a 
transacted integer 
to the RemoteRM 
TransactionScope 

a. Add a transacted integer to the RemoteRM class so we can modify the 
integer inside the TransactionScope. 

 
    public class RemoteRM : MarshalByRefObject, IRemoteRM 
    { 
        TxInt txInt = new TxInt(3); 

 
b. Add the following update to the transacted integer in the TransactionScope 
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        #region IRemoteRM Members 
 
        public void RMCreateScope(Transaction tx) 
        { 
            Console.WriteLine("RM Creating Scope with Transaction 
from Client "); 
             
            Console.WriteLine("TxInt value before scope: " + 
txInt.val); 
 
            try 
            { 
                using (TransactionScope ts = new 
TransactionScope(tx)) 
                { 
                    txInt.val = 5; 
                    Console.WriteLine("TxInt value inside scope: " 
+ txInt.val); 
 
                    ts.Complete(); 
                } 
            } 
            catch (TransactionException e) 
            { 
                Console.WriteLine(e); 
            }  
             
            Console.WriteLine("Scope finished");                    
        } 
 
        #endregion 

 
The update made the transacted integer is done under the 
Transaction that was created by the client.  This means that the 
update of the transacted integer is dependent on whether or not the 
client’s TransactionScope commits or aborts the Transaction. 

13.  Build your 
application 

a. Select Build->Build Solution. 
b. If the build is successful, you will see the following in the output window: 
Build: 3 succeeded or up-to-date, 0 failed, 0 skipped 

 
14.  Run the 
applications 

a. To start the RM, right click on the ResourceManager project in Solution 
Explorer and choose Debug->Start new instance.   A window should start 
up that says: 

“Resource Manager Server Online.   Press Enter to exit.” 
 
b. After the RM has started, right click on the Client project in Solution 

Explorer and choose Start Debugging.   This should cause a dialog box to 
appear that will ask if you would like to Complete the TransactionScope.  
Choose Yes or No. 

 
If you chose Yes, the output of the Client should look something like: 

Channel Registered 
RM retrieved:This is a Resource Manager 
Calling RMCreateScope on the remote RM. 
Client finished.  Press Enter to exit. 
 

If you chose Yes, the output of the Resource Manager should look something 
like: 
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Resource Manager Server Online.  Press Enter to exit. 
RM Creating Scope with Transaction from Client 
TxInt value before scope: 3 
TxInt value inside scope: 5 
Scope finished 
TxInt value from remote call: 3 
 ****** 
Enlistment received Commit 
 ****** 
TxInt value from remote call: 5 
 
 
 

The TxInt is set to 3 before the scope and inside the scope it is 
updated to 5.  When the client’s scope ends and the transaction is 
committed, the live value of the TxInt is updated to 5.  Before the 
commit, the live value continues to be 3, but if you get the value 
under the transaction, the new temporary value of 5 is printed.  
This is why the print “TxInt value inside scope” returns a 5 but 
the first “TxInt value from remote call” returns a 3.  It is 
because the former is called within the context of the transactions 
and the latter is not. 

  

 
Conclusion 
 

This exercise shows how easy it is to serialize a 
transaction from one location to another.  We modified 
a transacted integer on the resource manager to show 
that the transaction received by the RM is the same as 
the one passed by the client.  You could see how the 
transacted work that is done on the transaction in the 
resource manager is committed or rolled back 
depending on whether or not the client commits or 
aborts the transaction.   
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Exercise 3 
Using DistributedTransactionStarted and 
TransactionCompleted events 
In this exercise, you will learn how to use the DistributedTransactionStarted and the 
TransactionCompleted events to monitor transactions.  We will use the same remoting 
example from Exercise 2 and add the events to the remote location. 
 
 DistributedTransactionStarted event – This event sends notifications when new 
distributed transactions are created.  Note: This event only monitors distributed 
transactions because monitoring local transactions degrades performance. 
 TransactionCompleted event –This is an event that you can subscribe to in order 
to receive a notification that a given Transaction has completed.  You can use this event 
instead of a volatile enlistment to get outcome notification for Transactions. 
 
 

Tasks Detailed steps 

1.  Open project for 
Lab 2 in Visual Studio 

a. Click Start->Programs->Microsoft Visual Studio 2005 Beta 2-
>Microsoft Visual Studio 2005 Beta 2. 

b. Click File->Open->Project/Solution. 
c. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\CS\Exercises\Exercise3 and select the file 
Lab2.sln. 

d. Click OK. 

2.  Add the Distributed 
TransactionStarted 
event to the 
RemoteRM class  

a. Open the RemoteRM.cs file by double clicking RemoteRM.cs in 
Solution Explorer 

b. Subscribe to the DistributedTransactionStarted event in the RM 
constructor.  This will allow you to get the started event for every 
distributed transaction that is started in that process.  When a new 
Transaction is started, it will call the callback method specified (in this 
case TransactionStartedEvent). 

 
public RemoteRM() 
{ 
   Console.WriteLine("Creating RM and subscribing to tx started 
event."); 
   TransactionManager.DistributedTransactionStarted += new 
TransactionStartedEventHandler(TransactionStartedEvent); 
} 

 
c. Create the callback method TransactionStartedEvent that will be called 

whenever new distributed transactions are started.  In this method we 
are printing a trace and then subscribing to the 
TransactionCompletedEvent so we can get the outcome of the 
transaction. 

 
void TransactionStartedEvent(object sender, TransactionEventArgs 
e) 
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{ 
   Console.WriteLine("A distributed transaction has started.  
Subscribing to tx completed event."); 
   e.Transaction.TransactionCompleted += new 
TransactionCompletedEventHandler(TransactionCompletedEvent); 
} 

 
d. Create the callback method TransactionCompletedEvent that will be 

called whenever the Transaction completes.  The 
TransactionCompletedEvent will print out the status of the transaction, 
and the value of a transacted integer that we will create in the next step. 

 
void TransactionCompletedEvent(object sender, 
TransactionEventArgs e) 
{ 
   Console.WriteLine("A distributed transaction has completed.  
Status: " + e.Transaction.TransactionInformation.Status); 
   Console.WriteLine("TxInt value after tx completes: " + 
txInt.val); 
} 
 

4.  Build your 
application 

a. Select Build->Build Solution. 
b. If the build is successful, you will see the following in the output 

window: 
Build: 3 succeeded or up-to-date, 0 failed, 0 skipped 

 
5.  Run the applications a. To start the RM, right click on the ResourceManager project in 

Solution Explorer and choose Debug->Start new instance.   A window 
should start up that says: 

“Resource Manager Server Online.   Press Enter to exit.” 
 
b. After the RM has started, right click on the Client project in Solution 

Explorer and choose Start Debugging.   This should cause a dialog box 
to appear that will ask if you would like to Complete the 
TransactionScope.  Choose Yes or No. 

 
If you chose Yes, the output of the Client should look something like: 

Channel Registered 
RM retrieved:This is a Resource Manager 
Calling RMCreateScope on the remote RM. 
Client finished.  Press Enter to exit. 
 

If you chose Yes, the output of the Resource Manager should look 
something like: 
Resource Manager Server Online.  Press Enter to exit. 
Creating RM and subscribing to the tx started event. 
A distributed transaction has started.  Subscribing to tx completed event. 
RM Creating Scope with Transaction from Client 
TxInt value before scope: 3 
TxInt value inside scope: 5 
Scope finished 
TxInt value from remote call: 3 
 ****** 
Enlistment received Commit 
 ****** 
A distributed transaction has completed.  Status: Committed 
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TxInt value after tx completes: 5 
TxInt value from remote call: 5 
 

If you chose No on the dialog box, you can see that the client’s 
TransactionScope will roll back the Transaction.  This will also 
roll back the change you made to the transacted integer within 
the Transaction (on the Resource Manager). 

  

 

Conclusion 
 

This exercise demonstrates how you can use the 
DistributedTransactionStarted and the 
TransactionCompleted events to monitor transactions.  
The DistributedTransactionStarted event will notify you 
when transactions are created, and the 
TransactionCompleted event lets you know when they 
are finished.  The TransactionCompleted event can also 
be used in place of enlistments to get transaction 
outcomes.  Once you receive the completed event, you 
can get the transaction status from the transaction’s 
TransactionInformation.     
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Creating a Transacted Resource Using 
System.Transactions (Lab 2) 

(Visual Basic) 
For the Visual C# lab, go to page 1. 
Objectives 
After completing this lab, you will be able to: 

a. Create a transacted resource with System.Transactions 
b. Serialize Transactions 
c. Use System.Transactions events such as 

DistributedTransactionStarted event and 
TransactionCompleted event 

 

Prerequisites 
Before working on this lab, you must have the 
following installed on your machine (installed by 
default on the Virtual PC image): 

a. .NET Framework  v2.0 
b. Visual Studio .NET 2005 

 
* It is highly recommended that you complete Lab 1 (Using 
System.Transactions to write reliable applications) before 
starting this lab. 

 

Scenario 
This demo introduces you to some of the more 
advanced features of System.Transactions.  It starts by 
having you create your own transacted resource.  It then 
has you create a client that creates a transaction and 
serializes it to the transacted resource.  It ends by 
showing you how to use the 
DistributedTransactionStarted event and the 
TransactionCompleted event.  
 
Estimated time to complete this lab: 60 minutes 
Note: 
The code for all these exercises is on your lab machine 
at C:\Microsoft Hands On 
Labs\HOL205\TxLab2\VB\CompletedExercises. If 
you wish, you can open these files and cut and paste the 
code into your project instead of typing it. 
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Exercise 1 
Creating a Transacted Resource 
In this exercise, you will create a console test application in Visual Basic .NET.  The 
application will include a transacted resource (in this case a transacted integer) that 
enlists in the transaction.  The integer will commit or abort the changes made to it based 
on the outcome of the Transaction. This lab will teach you how to enlist and participate in 
Transactions using the IEnlistmentNotification interface. You will use the Microsoft 
Visual Studio .NET Development Environment to create, compile, and run this lab. 
 

Tasks Detailed steps 

1.  Open project for 
Lab2 in Visual Studio 

a. Click Start->Programs->Microsoft Visual Studio 2005 Beta 2-
>Microsoft Visual Studio 2005 Beta 2. 

b. Click File->Open->Project/Solution. 
c. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\VB\Exercises\Exercise1 and select the file 
Lab2.sln. 

d. Click Open. 

2.  Add a reference to 
System.Transactions 

a. Click View->Solution Explorer. 
b. In Solution Explorer, double-click on MyProject to open. 
c. In the main window, click on the References tab on the left. 
d. Click the Add… button 
e. With the .NET tab selected, select the component name 

System.Transactions.dll. 
f. Click OK 

3.  Add a using 
statement for 
System.Transactions 

a. Open TxInt.cs by double clicking it in the Solution Explorer 
b. At the top of TxInt.vb add the following: 
Imports System.Transactions 

4.  Build your 
application 

a. Select Build->Build Solution. 
b. If the build is successful, you will see the following in the output 

window: 
Build: 1 succeeded or up-to-date, 0 failed, 0 skipped 

 
5.  Code a class for the 
transacted integer 

a. Open TxInt.vb and add the following to the TxInt class in the 
ResourceManager namespace.  The TxInt class will be the transacted 
integer.  We are just defining two constructors and a property called val 
that you can Get and Set. 

 
    Public Class TxInt 
        Private livevalue As Integer 
 
        Private enlistmentTable As Hashtable = New Hashtable 
 
        Public Sub New() 
            MyBase.New() 
        End Sub 
 
        Public Sub New(ByVal value As Integer) 

Formatted: Bullets and Numbering
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            MyBase.New() 
            livevalue = value 
        End Sub 
 
        Public Property val() As Integer 
            Get 
                Return GetValue 
            End Get 
            Set(ByVal value As Integer) 
                SetValue(value) 
            End Set 
        End Property   
 
        End Sub 
    End Class 
The livevalue integer represents the current value for the 
integer when it is accessed outside of a Transaction.  The 
enlistmentTable is a standard hash table that will hold the 
integer values that are Set under Transactions. 

 

6.  Add an internal 
class that will be used 
to enlist in the 
transaction 

a. Next we will create a class that derives from IEnlistmentNotification 
that can be used to enlist in a transaction.  This class will be an 
enlistment in the transaction that stores the temporary value of the 
integer for a given transaction.  So when a user tries to set the value of a 
TxInt object within a transaction, a TxTmpValue object will be created 
to store the value of the integer temporarily until the transaction 
completes. 

 
    Class TxTmpValue 
        Implements IEnlistmentNotification 
 
        Friend val As Integer 
 
        Private parent As TxInt 
 
        Private tx As Transaction 
 
        Public Sub New(ByVal p As TxInt, ByVal t As Transaction) 
            MyBase.New() 
            parent = p 
            tx = t 
        End Sub 
 
        Sub IEnlistmentNotification_Commit(ByVal enlistment As 
Enlistment) Implements IEnlistmentNotification.Commit 
            Console.WriteLine("") 
            Console.WriteLine(" ****** ") 
            Console.WriteLine("Enlistment received Commit") 
            Console.WriteLine(" ****** ") 
            Console.WriteLine("") 
            parent.CommitTransaction(val, tx) 
            enlistment.Done() 
        End Sub 
 
        Sub IEnlistmentNotification_InDoubt(ByVal enlistment As 
Enlistment) Implements IEnlistmentNotification.InDoubt 
            enlistment.Done() 
        End Sub 
 
        Sub IEnlistmentNotification_Prepare(ByVal 
preparingEnlistment As PreparingEnlistment) Implements 
IEnlistmentNotification.Prepare 
            preparingEnlistment.Prepared() 
        End Sub 
 
        Sub IEnlistmentNotification_Rollback(ByVal enlistment As 
Enlistment) Implements IEnlistmentNotification.Rollback 
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            Console.WriteLine("") 
            Console.WriteLine(" ****** ") 
            Console.WriteLine("Enlistment received Rollback") 
            Console.WriteLine(" ****** ") 
            Console.WriteLine("") 
            parent.AbortTransaction(tx) 
            enlistment.Done() 
        End Sub 
    End Class 
 
IEnlistmentNotification contains four methods (Prepare, Commit, 
Rollback, and InDoubt).  When you enlist in a Transaction, you 
pass in an object that implements this interface.  When Commit() 
is called on the CommittableTransaction, all enlistments will be 
asked to prepare.  This is done by the TransactionManager 
calling Prepare one all of the enlistments. When an enlistment 
is done preparing, it calls back Prepared() or ForceRollback().  
Since our example does not do any work in Prepare, we always 
return Prepared.  Once the Transaction has completed, it will 
notify the enlistments by calling either Commit, Rollback or 
InDoubt, depending on the outcome of the Transaction.  In our 
example, we call AbortTransaction or CommitTransaction methods 
on the TxInt depending on the Transaction outcome. 

 

7.  Implement the 
GetValue and 
SetValue methods in 
the TxInt class 

a. Add SetValue() to the TxInt class 
 

        Private Sub SetValue(ByVal value As Integer) 
            Dim tx As Transaction 
            Dim enlistment As TxTmpValue 
            ' Get current transaction 
            tx = Transaction.Current 
            ' If none -- set the real value 
            If (tx = Nothing) Then 
                livevalue = value 
                Return 
            End If 
            ' Check if already enlisted for that transaction 
            enlistment = CType(enlistmentTable(tx), TxTmpValue) 
            If (enlistment Is Nothing) Then 
                ' If not -- create an enlistment structure 
                enlistment = New TxTmpValue(Me, tx) 
                enlistmentTable.Add(tx, enlistment) 
                ' Enlist with TM 
                tx.EnlistVolatile(enlistment, 
EnlistmentOptions.None) 
            End If 
            enlistment.val = value 
        End Sub 
 
SetValue() takes an integer and sets it as the current 
transacted integer value.  If SetValue is not called under a 
Transaction, it simply sets livevalue to the value passed in 
where it becomes the immediate value of the transacted integer.  
If there is a Transaction in Transaction.Current, it will 
associate the value passed in with an enlistment, so that when 
the Transaction is Committed or Aborted, the enlistment can 
update livevalue appropriately.  SetValue checks the enlistment 
hash table to see if it has already created an enlistment for 
this Transaction.  If it has, it resets enlistment.val to the 
new value passed in.  If not, it will create a new enlistment 
object (TxTmpValue), add it to the enlistment table, and then 
enlist in the transaction with this new enlistment object. 
 
To enlist it uses  
tx.EnlistVolatile(enlistment, EnlistmentOptions.None); 

 
b. Add GetValue() to the TxInt class. 



21     System.Transactions in Whidbey_______________________________________________ 

 

 
        Private Function GetValue() As Integer 
            Dim tx As Transaction 
            Dim enlistment As TxTmpValue 
            ' Get current transaction 
            tx = Transaction.Current 
            ' If none -- return live value 
            If (tx = Nothing) Then 
                Return livevalue 
            End If 
            enlistment = CType(enlistmentTable(tx), TxTmpValue) 
            If (enlistment Is Nothing) Then 
                Return livevalue 
            End If 
            Return enlistment.val 
        End Function 
 
GetValue() returns the current value of the transacted integer.  
If there is no ambient transaction when Get is called, it 
returns the livevalue.  Otherwise, it checks to see if there are 
any enlistments associated with the Transaction.  If there is an 
enlistment, it returns the value associated with the enlistment 
because that is the current value until the Transaction commits 
or aborts. 
 
 

8.  Implement the 
CommitTransaction 
and AbortTransaction 
methods in the TxInt 
class 

a. Add CommitTransaction and AbortTransaction methods to TxInt class.  
These methods are called by the TxTmpValue enlistment class when 
the Transaction commits or aborts.   

 
        ' Called when the transaction is committed 
        Friend Sub CommitTransaction(ByVal val As Integer, ByVal 
tx As Transaction) 
            ' Set the live value 
            livevalue = val 
            ' Remove the state associated with the transaction 
            enlistmentTable.Remove(tx) 
        End Sub 
 
        ' Called when the transaction is aborted 
        Friend Sub AbortTransaction(ByVal tx As Transaction) 
            ' Remove the state associated with the transaction 
            enlistmentTable.Remove(tx) 
        End Sub 
 
 
CommitTransaction takes the value that was stored by the 
enlistment and sets it as the livevalue.  It then removes the 
enlistment from the hash table because the Transaction is 
completed and will not be used again. returns the current value 
of the transacted integer.  If there is no ambient transaction 
when Get is called, it returns the livevalue.  Otherwise, it 
checks to see if there are any enlistments associated with the 
Transaction.  If there is an enlistment 

 

9.  Add a Main method 
to the RemoteRM class 
that uses the transacted 
integer 

a. Open the RemoteRM.vb file by clicking RemoteRM.vb in the Solution 
Explorer. 

b. Add a Main method that creates a TransactionScope and uses the 
transacted integer within the scope of a Transaction. 
 

    Class RemoteRM 
        Shared Sub Main(ByVal args() As String) 
            Dim Msg1 As String = "Would you like to complete the 
TransactionScope? Saying no will cause an exceptio" & _ 
"n to be thrown." 
            Dim completeScope1 As DialogResult = 
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MessageBox.Show(Msg1, "Complete Scope", MessageBoxButtons.YesNo) 
            Dim txInt As TxInt = New TxInt(3) 
 
            Console.WriteLine("RM Creating Scope") 
            Console.WriteLine("TxInt value before scope: {0}", 
txInt.val) 
 
            Try 
 
                Using ts As New TransactionScope 
                    txInt.val = 5 
                    Console.WriteLine("TxInt value inside scope: 
{0}", txInt.val) 
 
                    If (completeScope1 = DialogResult.No) Then 
                        Console.WriteLine("Throwing new 
exception from TransactionScope.") 
                        Throw New 
ApplicationException("Exception from TransactionScope.") 
                    End If 
 
                    ts.Complete() 
                End Using 
 
            Catch ex As TransactionAbortedException 
                Console.WriteLine(ex) 
            Catch appe As ApplicationException 
                Console.WriteLine(appe) 
            End Try 
 
            Console.WriteLine("TxInt value after scope: {0}", 
txInt.val) 
            PauseForExit() 
        End Sub 

 

10.  Add a using 
statement for 
System.Transactions 

a. At the top of RemoteRM.vb add the following: 
Imports System.Transactions 

11.  Build your 
application 

a. Select Build->Build Solution. 
b. If the build is successful, you will see the following in the output 

window: 
Build: 1 succeeded or up-to-date, 0 failed, 0 skipped 

 
12.  Run the application a. Click Debug->Start Debugging 

A dialog box will appear and if Yes is selected, Complete() 
will be called on the TransactionScope and the transaction 
will Commit.  Since the transaction commits, the changes made 
to the transacted integer will be reflected in the last print 
out of the integer value.  If No is selected, an exception 
will be thrown and the TransactionScope will not be 
completed.  This will cause the transaction to abort and the 
changes made to the integer will automatically be rolled 
back.  

 
 

Conclusion 
 

In this exercise we created a transacted resource using 
transaction enlistments.  The resource enlists in a 
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transaction and it receives notifications regarding the 
outcome of the transaction through its 
IEnlistmentNotification implementation.  The resource 
we created a volatile resource because it does not log 
state and therefore cannot perform recovery.   
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Exercise 2 
Serialize a Transaction from a client to a resource 
manager (RM) 
In this exercise, you will see how easy it is to pass transactions. We will use remoting to 
set up a client and a resource manager (RM).  The client will serialize a transaction to the 
RM we created in Exercise 1 and the RM will modify its transacted integer under the 
transaction that it receives. 
 

Tasks Detailed steps 

1.  Open 
project for Lab 
2 in Visual 
Studio 

a. Click Start->Programs->Microsoft Visual Studio 2005 Beta 2->Microsoft 
Visual Studio 2005 Beta 2. 

b. Click File->Open->Project/Solution. 
c. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\VB\Exercises\Exercise2 and select the file Lab2.sln. 
d. Click Open. 

2.  Add the 
client project 
that contains 
the client 
application 

a. Click View->Solution Explorer. 
b. In Solution Explorer, right-click on Solution ‘Lab2’ solution and click Add -> 

Existing Project… 
c. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\VB\Exercises\Exercise2\Client and select the file 
Client.csproj. 

d. Click Open 

3.  Add a 
Imports 
statement for 
System.Transa
ctions 

a. Open Client.vb by double clicking it in the Solution Explorer 
b. At the top of Client.vb add the following: 
Imports System.Transactions 

4.  Add a 
TransactionSc
ope to the 
client 

a. Add a TransactionScope to the Main method in the client.  The 
TransactionScope will create the Transaction that we will pass the resource 
manager.  Note:  the code that is already in place in this Main method is to set 
up the remoting. 

 
            Try 
                ' Code to set up remoting 
                Dim channel As TcpChannel = New TcpChannel 
                ChannelServices.RegisterChannel(channel) 
                Console.WriteLine("Channel Registered") 
                rm1 = 
CType(Activator.GetObject(GetType(RemotingInterface.RemotingInterface.I
RemoteRM), "tcp://localhost:12345/RM1.rem"), 
RemotingInterface.RemotingInterface.IRemoteRM) 
 
                Using ts As New TransactionScope 
                    Console.WriteLine("Calling RMCreateScope on the 
remote RM.") 
 
                    If (completeScope1 = DialogResult.No) Then 
                        Console.WriteLine("Throwing new exception from 
TransactionScope.") 
                        Throw New ApplicationException("Exception from 
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TransactionScope.") 
                    End If 
 
                    ts.Complete() 
                End Using 
 
            Catch e As TransactionAbortedException 
                Console.WriteLine(e) 
            Catch e As ApplicationException 
                Console.WriteLine(e) 
            Finally   

5.  Add calls to 
the resource 
manager 

a. Inside the TransactionScope, make a remoting call to the Resource Manager and 
pass it the Transaction that the TransactionScope has placed inside 
Transaction.Current.  The Transaction will automatically be serialized to the 
resource managers app domain for you!  Also add a call to to the Resource 
Manager to print the current value of its transacted integer. 

 
                Using ts As New TransactionScope 
                    Console.WriteLine("Calling RMCreateScope on the 
remote RM.") 
                    rm1.RMCreateScope(Transaction.Current) 
                    rm1.RMPrintTxIntValue() 
                    If (completeScope1 = DialogResult.No) Then 
                        Console.WriteLine("Throwing new exception from 
TransactionScope.") 
                        Throw New ApplicationException("Exception from 
TransactionScope.") 
                    End If 

 
 
b. Add another remote call to the Resource Manager to print the transacted integer 

value after the TransactionScope ends.   We will add this in the finally block. 
 
            Catch e As TransactionAbortedException 
                Console.WriteLine(e) 
            Catch e As ApplicationException 
                Console.WriteLine(e) 
            Finally 
                rm1.RMPrintTxIntValue() 
                Console.WriteLine("Client finished.  Press Enter to 
exit.") 
                Console.ReadLine() 
            End Try 

6.  Enable the 
remote server 

a. We want to create a remote server that will be running so that the client can 
connect to the RM and use remoting to make method calls on the RM.  Since 
this is all remoting code that does not have anything specific to do with 
Transactions, we have placed the code inside RMServer.vb and all you have to 
do is uncomment all of the code inside this file. 

b. Open RMServer.vb by double clicking it in the Solution Explorer. 
c. Delete the comments from around the code 

7.  Add the 
RemoteInterfa
ce project  

a. Another thing we need in order to enable remoting is an interface that the client 
and resource manager can share.  We have defined an interface in a project 
called RemoteInterface, and we need to include this project in our solution. 

b. Click View->Solution Explorer. 
c. In Solution Explorer, right-click on Solution ‘Lab2’ solution and click Add -> 

Existing Project… 
d. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\VB\Exercises\Exercise2\RemotingInterface and 
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select the file RemotingInterface.csproj. 
e. Click Open 

8.  Build the 
RemoteInterfa
ce project 

a. Build the RemoteInterface project to create a class library that we can add 
references to in our client and resource manager projects.  This will allow us to 
access the IRemoteRM interface contained in the RemoteInterface project. 

b. Right click on the RemoteInterface project in the Solution Explorer and select 
Build. 

c. If the build is successful, you will see the following in the output window: 
Build: 1 succeeded or up-to-date, 0 failed, 0 skipped 

 
9.  Add 
references to 
RemoteInterfa
ce 

a. Click View->Solution Explorer. 
b. In Solution Explorer under RemoteInterface, double-click on MyProject to 

open. 
c. In the main window, click on the References tab on the left. 
d. Click the Add… button 
e. Choose the Browse tab and navigate to  C:\Microsoft Hands On 

Labs\HOL205\TxLab2\VB\Exercises\Exercise2\RemotingInterface\Bin\Deb
ug and select RemotingInterface. 

f. Click OK 
g. Repeat steps a-c for the References under ResourceManager 

10.  Add 
Imports 
statement for 
RemoteInterfa
ce 

a. Open RemoteRM.vb by double clicking it in the Solution Explorer 
b. At the top of RemoteRM.vb add the following: 
Imports RemotingInterface 

11.  Modify the 
RemoteRM 
class so it can 
be used for 
remoting 

a. In order for the RemoteRM to work with remoting, we need to add 
MarshalByRefObject and have it derive from an interface that is recognized by 
both the client and the resource manager. 

b. Open RemoteRM.vb by double clicking it in the Solution Explorer 
c. Add the following to the RemoteRM 
 

    Public Class RemoteRM 

        Inherits MarshalByRefObject 

        Implements IRemoteRM 

 
d. We then need to delete the Main method in RemoteRM.vb since the Main 

method for this project is now in RMServer.vb.  Open RemoteRM.vb by double 
clicking RemoteRM.vb in the Solution Explorer.  Delete the entire Main method 
(Not just the contexts of the method) 

 
        Public Shared Sub Main() 

        End Sub 

 

e. After removing Main, we want to add the following methods that we need for 
the IRemoteRM interface.  The RMCreateScope method is the method the client 
will call to pass the Transaction to the RM.  Inside, we create a 
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TransactionScope and pass in the transaction we received from the client as a 
parameter.  The RMPrintTxIntValue prints out the current value of the TxInt. 

 
 
        Public Sub New() 
            MyBase.New() 
        End Sub 
 
 
        Public Overrides Function ToString() As String 
            Return "This is a remote Resource Manager" 
        End Function 
 
 
        Overridable Sub RMCreateScope(ByRef tx As Transaction) 
Implements IRemoteRM.RMCreateScope 
 
            Console.WriteLine("RM Creating Scope with Transaction from 
Client") 
 
            Try 
                Using ts As New TransactionScope(tx) 
 
                    ts.Complete() 
                End Using 
 
            Catch ex As TransactionException 
                Console.WriteLine(ex) 
            End Try 
 
            Console.WriteLine("Scope finished.") 
        End Sub 
 
        Overridable Sub RMPrintTxIntValue() Implements 
IRemoteRM.RMPrintTxIntValue 
            Console.WriteLine("TxInt value from remote call: {0}", 
txInt.val) 
        End Sub 
 

12.  Add a 
transacted 
integer to the 
RemoteRM 
TransactionSc
ope 

Add a transacted integer to the RemoteRM class so we can modify the integer inside 
the TransactionScope. 

 
   Public Class RemoteRM 
        Inherits MarshalByRefObject 
        Implements IRemoteRM 
 
        Private txInt As TxInt = New TxInt(3) 
 
 

Add the following update to the transacted integer in the TransactionScope 
 

        Overridable Sub RMCreateScope(ByRef tx As Transaction) 
Implements IRemoteRM.RMCreateScope 
 
            Console.WriteLine("RM Creating Scope with Transaction from 
Client") 
            Console.WriteLine("TxInt value before scope: {0}", 
txInt.val) 
            Try 
                Using ts As New TransactionScope(tx) 
                    txInt.val = 5 
                    Console.WriteLine("TxInt value inside scope: {0}", 
txInt.val) 
                    ts.Complete() 
                End Using 
            Catch ex As TransactionException 
                Console.WriteLine(ex) 
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            End Try 
            Console.WriteLine("Scope finished.") 
        End Sub 

 
The update made the transacted integer is done under the Transaction 
that was created by the client.  This means that the update of the 
transacted integer is dependent on whether or not the client’s 
TransactionScope commits or aborts the Transaction. 

13.  Build your 
application 

Select Build->Build Solution. 
If the build is successful, you will see the following in the output window: 
Build: 3 succeeded or up-to-date, 0 failed, 0 skipped 

 
14.  Run the 
applications 

a. To start the RM, right click on the ResourceManager project in Solution 
Explorer and choose Debug->Start new instance.   A window should start up 
that says: 

“Resource Manager Server Online.   Press Enter to exit.” 
 
b. After the RM has started, right click on the Client project in Solution Explorer 

and choose Start Debugging.   This should cause a dialog box to appear that 
will ask if you would like to Complete the TransactionScope.  Choose Yes or 
No. 

 
If you chose Yes, the output of the Client should look something like: 

Channel Registered 
Calling RMCreateScope on the remote RM. 
Client finished.  Press Enter to exit. 
 

If you chose Yes, the output of the Resource Manager should look something like: 
Resource Manager Server Online.  Press Enter to exit. 
RM Creating Scope with Transaction from Client 
TxInt value before scope: 3 
TxInt value inside scope: 5 
Scope finished 
TxInt value from remote call: 3 
 ****** 
Enlistment received Commit 
 ****** 
TxInt value from remote call: 5 
 
 
 

The TxInt is set to 3 before the scope and inside the scope it is 
updated to 5.  When the client’s scope ends and the transaction is 
committed, the live value of the TxInt is updated to 5.  Before the 
commit, the live value continues to be 3, but if you get the value 
under the transaction, the new temporary value of 5 is printed.  This 
is why the print “TxInt value inside scope” returns a 5 but the first 
“TxInt value from remote call” returns a 3.  It is because the former 
is called within the context of the transactions and the latter is not. 

  

 
Conclusion 
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This exercise shows how easy it is to serialize a 
transaction from one location to another.  We modified 
a transacted integer on the resource manager to show 
that the transaction received by the RM is the same as 
the one passed by the client.  You could see how the 
transacted work that is done on the transaction in the 
resource manager is committed or rolled back 
depending on whether or not the client commits or 
aborts the transaction.   
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Exercise 3 
Using DistributedTransactionStarted and 
TransactionCompleted events 
In this exercise, you will learn how to use the DistributedTransactionStarted and the 
TransactionCompleted events to monitor transactions.  We will use the same remoting 
example from Exercise 2 and add the events to the remote location. 
 
 DistributedTransactionStarted event – This event sends notifications when new 
distributed transactions are created.  Note: This event only monitors distributed 
transactions because monitoring local transactions degrades performance. 
 TransactionCompleted event –This is an event that you can subscribe to in order 
to receive a notification that a given Transaction has completed.  You can use this event 
instead of a volatile enlistment to get outcome notification for Transactions. 
 
 

Tasks Detailed steps 

1.  Open project for 
Lab 2 in Visual Studio 

a. Click Start->Programs->Microsoft Visual Studio 2005 Beta 2-
>Microsoft Visual Studio 2005 Beta 2. 

b. Click File->Open->Project/Solution. 
c. Navigate to C:\Microsoft Hands On 

Labs\HOL205\TxLab2\VB\Exercises\Exercise3 and select the file 
Lab2.sln. 

d. Click OK. 

2.  Add the Distributed 
TransactionStarted 
event to the 
RemoteRM class  

a. Open the RemoteRM.vb file by double clicking RemoteRM.vb in 
Solution Explorer 

b. Subscribe to the DistributedTransactionStarted event in the RM 
constructor.  This will allow you to get the started event for every 
distributed transaction that is started in that process.  When a new 
Transaction is started, it will call the callback method specified (in this 
case TransactionStartedEvent). 

 
    Public Class RemoteRM 
        Inherits MarshalByRefObject 
        Implements IRemoteRM 
 
        Private txInt As TxInt = New TxInt(3) 
 
        Public Sub New() 
            MyBase.New() 
            Console.WriteLine("Creating RM and subscribing to tx 
started event.") 
            AddHandler 
TransactionManager.DistributedTransactionStarted, AddressOf 
Me.TransactionStartedEvent 
        End Sub  

 
c. Create the callback method TransactionStartedEvent that will be called 

whenever new distributed transactions are started.  In this method we 
are printing a trace and then subscribing to the 
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TransactionCompletedEvent so we can get the outcome of the 
transaction. 

 
Sub TransactionStartedEvent(ByVal sender As Object, ByVal e As 
TransactionEventArgs) 
 
   Console.WriteLine("A distributed transaction has started.  
Subscribing to tx completed event.") 
   AddHandler e.Transaction.TransactionCompleted, AddressOf 
Me.TransactionCompletedEvent 
 
End Sub 
 

d. Create the callback method TransactionCompletedEvent that will be 
called whenever the Transaction completes.  The 
TransactionCompletedEvent will print out the status of the transaction, 
and the value of a transacted integer that we will create in the next step. 

 
Sub TransactionCompletedEvent(ByVal sender As Object, ByVal e As 
TransactionEventArgs) 
 
   Console.WriteLine("A distributed transaction has completed.  
Status: {0}", e.Transaction.TransactionInformation.Status) 
   Console.WriteLine("TxInt value after tx completes: {0}", 
txInt.val) 
 
End Sub 

4.  Build your 
application 

a. Select Build->Build Solution. 
b. If the build is successful, you will see the following in the output 

window: 
Build: 3 succeeded or up-to-date, 0 failed, 0 skipped 

 
5.  Run the applications a. To start the RM, right click on the ResourceManager project in 

Solution Explorer and choose Debug->Start new instance.   A window 
should start up that says: 

“Resource Manager Server Online.   Press Enter to exit.” 
 
b. After the RM has started, right click on the Client project in Solution 

Explorer and choose Start Debugging.   This should cause a dialog box 
to appear that will ask if you would like to Complete the 
TransactionScope.  Choose Yes or No. 

 
If you chose Yes, the output of the Client should look something like: 

Channel Registered 
Calling RMCreateScope on the remote RM. 
Client finished.  Press Enter to exit. 
 

If you chose Yes, the output of the Resource Manager should look 
something like: 
Resource Manager Server Online.  Press Enter to exit. 
Creating RM and subscribing to the tx started event. 
A distributed transaction has started.  Subscribing to tx completed event. 
RM Creating Scope with Transaction from Client 
TxInt value before scope: 3 
TxInt value inside scope: 5 
Scope finished 
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TxInt value from remote call: 3 
 ****** 
Enlistment received Commit 
 ****** 
A distributed transaction has completed.  Status: Committed 
TxInt value after tx completes: 5 
TxInt value from remote call: 5 
 

If you chose No on the dialog box, you can see that the client’s 
TransactionScope will roll back the Transaction.  This will also 
roll back the change you made to the transacted integer within 
the Transaction (on the Resource Manager). 

  

 

Conclusion 
 

This exercise demonstrates how you can use the 
DistributedTransactionStarted and the 
TransactionCompleted events to monitor transactions.  
The DistributedTransactionStarted event will notify you 
when transactions are created, and the 
TransactionCompleted event lets you know when they 
are finished.  The TransactionCompleted event can also 
be used in place of enlistments to get transaction 
outcomes.  Once you receive the completed event, you 
can get the transaction status from the transaction’s 
TransactionInformation.     
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