
Lab 3:  ASP.NET 2.0 User Interface 
Enhancements: Master Pages, Themes, and 
Controls 

Estimated time to 
complete this lab:  
60 minutes 

ASP.NET 2.0 provides a wide range of new features to simplify the development of 
user interfaces, from master pages, themes, and skins to more than 50 new controls 
designed to make short work of implementing common user interface elements. 
In this lab, you’ll get first-hand experience using these new features by giving the 
MyComics application you started in Lab 2 a face-lift. First, you’ll add a master 
page to the site. Next, you’ll theme the site using a custom theme. Finally, you’ll 
use a MultiView control to offers users a choice of ways to view comic book data, 
and you’ll combine DataList controls and custom HTTP handlers to implement a 
new view of the comic database. 
Here’s how the application will look in Internet Explorer at the conclusion of this 
lab: 

 
 
 
 

 
 
 
 
 
If you have not completed a lab greater than Lab 1 previous to this lab, run the cmd 
file C:\HOL\Web\LabFiles\Database\CacheSetup.cmd 

Lab Setup 
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Exercise 1 
Create a master page 
In this exercise, you’ll create a master page to serve Default.aspx, Details.aspx, Admin.aspx, and other pages 
that will be added later. Then you’ll modify the existing pages by turning them into content pages.. 

Tasks Detailed Steps 
1. Open the Web 

site 
a. Start Microsoft Visual Studio and use the “File->Open Web Site” command to open the 

C:\HOL\Web\Starter\VB\Lab3 site. 
a. Right-click C:\..\Lab3 in the Solution Explorer window and select “Add Folder -

>Regular Folder.”  Name the folder Images. 
b. Right-click the Images folder in Solution Explorer and use the “Add Existing Item” 

command to add MyComics.gif to the Images folder. You’ll find MyComics.gif in 
C:\HOL\Web\LabFiles\Images. 

 

2. Add a master 
page to the 
site 
 
 

a. Right-click C:\..\Lab3 in Solution Explorer and select “Add New Item.” 
b. Choose “Master Page” as the template type and name the master page Site.master. Be 

sure C# or Visual Basic is selected in the Language box and that “Place code in separate 
file” is checked before clicking OK. 

 

 Click the designer’s Design button to switch to Design view. You’re now 
ready to begin designing the master page. 

3. Define the 
layout of the 
master page 

a. Select “Insert Table” from Visual Studio’s Layout menu. 
b. Click the Template button and select “Header, footer, and side” from the drop-down list 

as shown below. Then click OK to add a table to the master page. 
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c. Grab the ContentPlaceHolder by the title bar and move it into the right-hand cell of the 

table’s second row. 
d. Place the cursor in that cell (not in the ContentPlaceHolder). Then go to the Properties 

window and set the cell’s VAlign property to “top”. The ContentPlaceHolder control 
should snap to the top of the cell  

e. Right-click the table’s top row and select “Insert->Row Below” from the context menu. 
f. Select the new row. Then set its Height to 1 and BgColor to gray. 
g. Right-click the table’s bottom row and select “Insert->Row Above” from the context 

menu. 
h. Select the new row. Then set its Height to 1 and BgColor to gray. 
i. Right-click the cell to the left of the one that contains the ContentPlaceHolder control 

and select “Insert->Column to the Right.” 
j. Put the cursor in the new cell. Then set the cell’s Width to 1 and BgColor to gray. 
k. Select the table’s top row. Set BgColor to “#105070”. 
l. Put the cursor in the leftmost cell in the table’s middle row. Set BgColor to “#ececec.” 
m. Select the table’s bottom row. Set BgColor to “#ececec”. 
n. Switch to Source view and manually modify the <body> tag to look like this: 
<body topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0"> 
o. Click the Design button to view the master page in Design view. It  
should look something like this: 
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4. Add content to 
the master 
page 

a. Drag a HyperLink control from the Toolbox and drop it into the top row of the table. 
a. Set the HyperLink’s ImageUrl property to “~/Images/MyComics.gif” and its 

NavigateUrl property to “~/Default.aspx”. 
b. Select the table’s top row. Set its Height property to 1 so the height will adjust to fit the 

image. 
c. Put the cursor in the leftmost cell in the table’s middle row. Set the cell’s Width 

property to 128. 
d. Select the table’s bottom row. Set its Height property to 16. 
e. With the cursor still in the bottom row, set the font to 8-point Verdana and type “If this 

page works, I built it. If it doesn’t work, I don’t know who built it.” The master page 
should now look like this in the designer: 
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5. Convert 
existing pages 
into content 
pages 

a. Double-click Default.aspx in Solution Explorer to open it in the designer. 
b. Switch to Source view and add a MasterPageFile=“~/Site.master” attribute to the @ 

Page directive at the top of the page. 
c. Also in Source view, remove the <!DOCTYPE>, <html>, <head>, <body>, <form>, 

and <div> elements from the page. Then add an <asp:Content> element that 
encapsulates all of the page’s remaining content: 

<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" Runat="server"> 
  
  
  
</asp:Content> 
d. Add a Title=“MyComics” attribute to Default.aspx’s @ Page directive. 
e. Repeat steps 1 through 4 for Details.aspx so that it, too, becomes a content page. 
f. Repeat steps 1 through 4 for Admin.aspx so that it, too, becomes a content page. 
g. Select Default.aspx in the Solution Explorer window. Then press Ctrl+F5 to launch it. 
h. Verify that Default.aspx was successfully converted into a content page: 
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i. Click one of the GridView’s Select buttons to display Details.aspx. Verify that it, too, 

was successfully converted into a content page. 
j. Change the URL in browser’s address bar to point to Admin.aspx and verify that it, too, 

is now a content page. 
k. Close the browser and return to Visual Studio. 
 

6. Refine 
Default.aspx 

a. Open Default.aspx in the designer and switch to Design view. 
b. Position the cursor underneath the GridView control and use the “Layout->Insert Table” 

command to insert a table. In the Insert Table dialog, select the Header template shown 
below. 
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c. Drag the existing SqlDataSource and DropDownList controls into the table’s top row. 
d. Drag the existing ObjectDataSource and GridView controls into the table’s bottom row. 
e. Delete any whitespace between the table’s top row and the top of the page so the top of 

the table lines up with the top of the page. 
f. Right-click the top row of the table and select “Insert->Row Below.” 
g. Set the new row’s height to 1 and background color (BgColor) to gray. 
h. Set the top row’s height to 32 and background color to “#ececec”. 
i. Insert a space or two to the left of the DropDownList to move it away from the left 

border of the table cell. 
j. Select the DropDownList. Then go to the Properties window and set the font to 10-point 

Verdana. 
k. Set the GridView control’s to 10-point Verdana also. 
l. Press Ctrl+F5 to launch Default.aspx in your browser and verify that it resembles the 

page pictured below: 
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m. Close the browser and return to Visual Studio. 
 

7. Refine 
Details.aspx 

a. Open Details.aspx in Design view. 
b. Set the DetailsView control’s font to 10-point Verdana. 
 

8. Refine 
Admin.aspx 

c. Open Admin.aspx in Design view. 
d. Repeat the steps you performed on Default.aspx in Task 6 for Admin.aspx. As an 

alternative, you can cut-and-paste the HTML added to Default.aspx in Task 6 into 
Admin.aspx. 

e. Set the DetailsView control’s font to 10-point Verdana. 
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Exercise 2 
Theme the Web site’s pages  
Theming is an easy-to-use mechanism for applying visual attributes en masse to controls. 
You can apply themes to individual pages or to an entire site. In this exercise, you’ll apply a 
supplied theme to see the effect it has on the site’s pages. Then you’ll customize the theme 
and use it to standardize MyComics’ look and feel.. 

Tasks Detailed Steps 
9. Remove 

formatting 
from the 
GridView.  
 
 

a. Open Default.aspx in Design view. Select the GridView control and click the small arrow in 
its upper right corner to display the “GridView Tasks” menu. 

b. Click “Auto Format” and use the “Remove Formatting” option to remove the formatting you 
applied in Lab 2. 

c. Run Default.aspx in your browser. What does the GridView look like now? 
d. Close the browser and return to Visual Studio. 

 

10. Theme the 
page 
“BasicBlue” 
 

a. Add an “App_Themes” folder to the Web site. 
b. Add a folder named “BasicBlue” to the Themes folder. 
c. Right-click the App_Themes\BasicBlue folder in Solution Explorer and select “Add Existing 

Item.” 
d. Select C:\HOL\Web\LabFiles\Themes\BasicBlue\ BasicBlue.skin to create a local copy of 

that file in your site’s App_Themes\BasicBlue folder. 
e. Add a folder named “Images” to the App_Themes \BasicBlue folder. 
f. Right-click the App_Themes\BasicBlue\Images folder in Solution Explorer and select “Add 

Existing Item.” 
g. Select all the files in C:\HOL\Web\LabFiles\Themes\BasicBlue\Images folder to create local 

copies of those files in your site’s App_Themes \BasicBlue\Images folder 
h. Open Default.aspx in Source view and add a Theme=”BasicBlue” attribute to the @ Page 

directive. 
i. Run Default.aspx in your browser. The page should look like this: 
 

 
j. Close the browser and return to Visual Studio. 

11. Develop a 
theme of your 
own 

a. Add a folder named MyComics to the App_Themes folder 
b. Right-click the App_Themes \MyComics folder in Solution Explorer and select “Add 

Existing Item.” 
c. Select BasicBlue.skin from your site’s own Themes\BasicBlue folder to create a local copy 

of that file in Themes\MyComics. 
d. Rename the file “MyComics.skin”. 
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e. Double-click MyComics.skin in the Solution Explorer window. 
f. Use Visual Studio’s “Edit->Find and Replace->Quick Replace” command to replace all 

occurrences of “#000066” with “#105070”. 
g. Use Visual Studio’s “Edit->Find and Replace->Quick Replace” command to replace all 

occurrences of “#eeeeee” with “lightyellow”. 
h. Save the modified file and close the Quick Replace window. 
i. Add a folder named “Images” to the Themes\MyComics folder. 
j. Right-click the Themes\MyComics\Images folder in Solution Explorer and select “Add 

Existing Item.” 
k. Select all the files in your own site’s Themes\BasicBlue\Images folder to create local copies 

of those files in Themes\MyComics\Images. 
l. Change the Theme attribute in Default.aspx’s @ Page directive to Theme=“MyComics.” 
m. Launch Default.aspx in your browser and note the changes in the controls. 
n. Close the browser and return to Visual Studio. 
 

12. Theme all the 
site’s pages 

a. Open Default.aspx in Source view and remove the Theme attribute from the @ Page 
directive. 

b. Open Details.aspx in Design view. 
c. Select the DetailsView control and use the “Auto Format” command in the “DetailsView 

Tasks” menu to remove formatting from the DetailsView. 
d. Open Admin.aspx in Design view. 
e. Remove formatting from Admin.aspx’s GridView and DetailsView controls. 
f. Double-click Web.config in Solution Explorer to open it for editing. 
g. Add the following statement to the <system.web> section of Web.config: 

<pages theme="MyComics" /> 

h. Launch Default.aspx in your browser and verify that it’s still themed “MyComics.” 
i. Click one of the Select buttons to display Details.aspx. Verify that Details.aspx is themed to 

match Default.aspx. 
j. Change the URL in browser’s address bar to point to Admin.aspx and verify that 

Admin.aspx is themed as well. 
k. Close the browser and return to Visual Studio. 
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Exercise 3 
Add multiple views 
In this exercise, you’ll add a MultiView control to Default.aspx and populate the MultiView with two views: 
one that presents page content the way it’s presented now, and another that uses DataList controls to present 
page content in a completely different way. The DataList will use a custom HTTP handler named 
ImageGrabber.ashx to retrieve cover images from the database and render them to the page. You’ll also add 
buttons for switching between the views.. 

Tasks Detailed Steps 
1. Add a custom 

HTTP handler 
 
<cannot test 
until 
objectdatadapte
r does> 

a. Right-click the c:\..\Lab3 folder in Solution Explorer and use the “Add Existing Item” 
command to make a local copy of the file 
C:\HOL\Web\LabFiles\Components\ImageGrabber.ashx. 

b. Open ImageGrabber.ashx and inspect the code contained therein. It contains a 
dynamically compiled HTTP handler that reads a comic book ID from a query string 
and uses it to query the MyComics database for a comic book cover image. To improve 
performance, it caches cover images in the ASP.NET application cache, and it uses 
SqlCacheDependency objects to refresh cached cover images if the images in the 
database change. In a moment, you’ll use ImageGrabber.ashx as the target of ASP.NET 
Image controls to retrieve comic book cover images from the database and display them. 

 

2. Add a 
MultiView 
control to 
Default.aspx. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

a. Open Default.aspx in Design view. 
b. Grab a MultiView control from the Toolbox and drop it onto the page immediately 

below the GridView1. 
c. Drag a View control from the Toolbox and drop it into the MultiView. That view 

becomes View1. 
d. Drag the GridView1 control on the page into View1. 
e. Drag another View control from the Toolbox and drop it into the MultiView. That view 

becomes View2. 
f. Set the MultiView’s ActiveViewIndex property to 0. 
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Continued 

Tasks Detailed Steps 
3. Add a 

DataList 
control to the 
MultiView 
 

a. Drag a DataList control from the Toolbox and drop it into View2. 
b. Use the “DataList Tasks” menu to assign ObjectDataSource1 as the DataLists’s data 

source. Upon completion, the page appears this way in the designer: 

 
c. Switch to Source view and add the following <ItemTemplate> to the DataList. Note the 

use of Image controls whose ImageUrl attributes point to ImageGrabber.ashx to render 
images from the database, and the simplified data-binding expressions that make HTML 
templates more readable: 

C# 
<ItemTemplate> 
<table cellpadding="4"> 
<tr> 
<td width="100"> 
<asp:Image ID="CoverImage" 
ImageUrl='<%# "~/ImageGrabber.ashx?ComicID=" + Eval 
("ComicID") %>' 
Runat="server" /> 
</td> 
<td valign="top" style="font-family: Verdana; font-size: 
10pt"> 
<asp:Label ID="ComicID" Text='<%# Eval ("ComicID") %>' 
Visible="false" Runat="server" /> 
<asp:LinkButton Text='<%# Eval ("Title") + "&nbsp;"  
+ Eval ("Number") %>' Runat="server" /><br /> 
<%# (bool) Eval ("CGC") ? "CGC " : "" %> 
<%# Eval ("Grade", "{0:f1}") %> 
</td> 
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</tr> 
</table> 
</ItemTemplate> 

Visual Basic 
<ItemTemplate> 
<table cellpadding="4"> 
<tr> 
<td width="100"> 
<asp:Image ID="CoverImage" 
ImageUrl='<%# "~/ImageGrabber.ashx?ComicID=" & 
Eval("ComicID") %>' 
Runat="server" /> 
</td> 
<td valign="top" style="font-family: Verdana; font-size: 
10pt"> 
<asp:Label ID="ComicID" Text='<%# Eval("ComicID") %>' 
Visible="false" Runat="server" /> 
<asp:LinkButton Text='<%# Eval("Title") & "&nbsp;" & 
Eval("Number") %>' 
Runat="server" /><br /> 
<%#IIf(Eval("CGC"), "CGC ", "")%> 
<%#Eval("Grade", "{0:f1}") %> 
</td> 
</tr> 
</table> 
</ItemTemplate> 

d. Switch back to Design view and set the DataList’s RepeatColumns property to 3 to 
divide the output into 3 columns. 

e. Set the DataList’s RepeatDirection property to “Horizontal” to organize items in row-
first (rather than column-first) order. 

f. Set the DataList’s CellPadding property to 8. 
g. Set the DataList’s EnableTheming property to false. 
h. With the DataList selected in Design view, click the lightning bolt icon in the Properties 

window to display a list a DataList events. Double-click “ItemCommand” to add an 
ItemCommand event handler to Default.aspx.cs or Default.aspx.vb. 

i. Add the following statements to the body of the handler: 
C# 

Label label = (Label) e.Item.FindControl ("ComicID"); 
Response.Redirect ("Details.aspx?ComicID=" + label.Text); 

Visual Basic 
Dim lbl As Label = _ 
   CType(e.Item.FindControl("ComicID"), Label) 
Response.Redirect("Details.aspx?ComicID=" & lbl.Text) 

j. Press Ctrl+F5 to launch Default.aspx. The page looks the same as it did before. In other 
words, the GridView is displayed, not the DataList. Why? 

k. Close the browser and return to Visual Studio. Change the MultiView control’s 
ActiveViewIndex property to 1. 

l. Press Ctrl+F5 again. Verify that the resulting page looks like this: 
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m. Click one of the comic book titles and verify that Details.aspx appears showing details 

for that comic. 
n. Close the browser and return to Visual Studio. 
 

4. Add buttons 
for switching 
views 

a. The next task is to add a pair of buttons for switching views interactively. Begin by 
setting the MultiView’s ActiveViewIndex property back to 0. 

b. Add a Button control to Default.aspx, positioning it just right of the DropDownList. 
Add a few spaces to separate the DropDownList and the Button. Then assign the Button 
control the following property values: 

Text = “GridView” 
EnableTheming = false 
Width = 100 

c. Add another Button control to the page, positioning it just right of the button added in 
the previous step. Insert a few spaces between buttons to separate them. Then assign the 
new Button control the following property values: 

Text = “DataList” 
EnableTheming = false 
Width = 100 

d. Double-click the “GridView” button to add a click handler. Add the following statement 
to the body of the handler: 

C# 
MultiView1.ActiveViewIndex = 0; 

Visual Basic 
MultiView1.ActiveViewIndex = 0 

e. Go back to Default.aspx and double-click the “DataList” button to add a click handler. 
Add the following statement to the body of the handler: 

C# 
MultiView1.ActiveViewIndex = 1; 
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Visual Basic 
MultiView1.ActiveViewIndex = 1; 

 
If the buttons were defined inside the MultiView, you could implement view switching 
declaratively by setting the buttons’ CommandName properties to 
“SwitchViewByIndex” or “SwitchViewByID” and setting each button’s 
CommandArgument property to the corresponding view ID or view index. However, 
since the layout of this page calls for the buttons to be defined outside the MultiView, 
you have to write two lines of code—one per button—to perform view switching. 
 

f. Run Default.aspx in your browser and verify that you can switch views by clicking 
buttons. Here’s what the page looks like when “DataList” view is selected: 

 
 

You might have to select a title from the drop-down list after clicking the 
“DataList” button for the first time to get the comics to appear. Also, you 
may find that the title selected in the drop-down list gets out of sync with the 
titles shown on the page as you switch back and forth between views. 
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 Summary 
 
Here’s a recap of what you learned in this lab: 
 

• How to build a master page 
• How to convert existing pages into content pages 
• How to apply themes to a site 
• How to use MultiView controls to implement multiple views 
• How to interactively switch between views in MultiView controls 
• How to use custom HTTP handlers to render images retrieved from a 

database 
 
Take a moment to review the application in its current form. As you do, here are 
some questions to ponder: 
 

• How many lines of code do you count in the .aspx.cs files? How many 
lines of code would have been required to build the same UI in ASP.NET 
1.x.? 

 
• How would you go about adding a third view to the MultiView? 

 
• How would you rate the user experience when using the Visual Studio IDE 

to build and apply master pages? 
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