
Lab 1: Create a Web Site 

ASP.NET is loaded with new features designed to make building sophisticated 
Web sites easier than ever before. In this lab, you’ll build a Web site which is 
designed to acquaint you with some of the ASP.Net 2.0 features and provide a taste 
of what’s to come. 

Estimated time to 
complete this lab:  
60 minutes 
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Exercise 1 
Create a Web site 
In this exercise, you’ll use Visual Studio to create a new Web site. You’ll also add a pair of 
folders to it: one for holding images, and another for holding components. 

Tasks Detailed Steps 
1. Create a new 

Web site 
a. Start Microsoft Visual Studio. 
b. Select “New Web Site” from Visual Studio’s File menu. 
c. In the New Web Site dialog, choose “Visual C#” or “Visual Basic” as the project type 

and “Empty Web Site” as the template type. Type 
“C:\HOL\Web\Starter\<language>\Lab1” into the Location box and click OK to 
create the Lab1 Web site. 

 

2. Add an 
Images folder 

a. Right-click C:\..\Lab1 in the Solution Explorer window and select “Add Folder -
>Regular Folder.”  

 If Solution Explorer isn’t visible, select “Solution Explorer” from the 
View menu to display it, or press Ctrl+Alt+L.) 

b. Name the folder “Images.” 
c. Right-click the Images folder in Solution Explorer and select “Add Existing Item.” 
d. Navigate to the C:\HOL\Web\LabFiles\Images folder and select MSN.gif to add a 

local copy of MSN.gif to your Web site’s Images folder. You’ll use the GIF in Exercise 
2. 

 

3. Add an 
App_Code 
folder 

a. Right-click C:\..\Lab1 in the Solution Explorer window and select “Add Folder -
>App_Code Folder.” 

! Note that this folder named “App_Code” allows classes to be auto compiled 
and generally consumable within in your ASP.Net project 
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Exercise 2 
Create a master page 
In this exercise, you’ll create a master page to serve as a template for the Web site’s pages. 

Tasks Detailed Steps 

1. Add a master 
page 
 
 

a. In the Solution Explorer window, right-click C:\..\Lab1and select “Add New Item.” 
b. In the Add New Item dialog, select “Master Page” and type “Site.master” into the 

Name box. Be sure “Place code in separate file” is checked and the appropriate 
language is selected in the Language box before clicking Add.  

 

2. Add a table to 
the master 
page 

a. Click the Design button in the lower left corner of the designer window to switch to 
Design view. 

b. Go to the Layout menu and select “Insert Table.” 
c. In the Insert Table dialog, set Rows and Columns to 2. Check the Width box and enter 

100%. Also check the “Cell padding” and “Cell spacing” boxes and set both to 0, as 
shown below. Then click OK to add the table to the master page. The table should 
appear above the ContentPlaceHolder control. 

 

3. Create a 
banner 

a. Drag an ASP.NET Image control from the the Toolbox and drop it into the upper left 
cell of the table.  

 If the Toolbox window isn’t visible, select Toolbox from the View menu or 
press Ctrl+Alt+X. 

b. Go to the Properties window and set the Image control’s ImageUrl property to 
“~/Images/MSN.gif”.  

 If the Properties window isn’t visible, select “Properties Window” from 
the View menu or press F4. 

c. Also in the Properties window, set the Image control’s ImageAlign property to Middle. 
d. Position the cursor just outside the left border of the table’s upper-left cell and click the 

grab handle to select the entire table row. 
e. Go to the Properties window and set the row’s BgColor property to “#10527B”. 
f. Select the next table row. Set its BgColor property to gray and Height property to 1. 
g. Select the table’s left column. Set its Width property to 100. 
h. Select the table’s right column. Set its Width property to 100%. (Note the percent 

sign!) 
i. Put the cursor in the table’s upper-right cell and type “Bookstore.” 
j. Select the text you just typed. Use the Formatting toolbar to change the text to 48-point 

bold italic Verdana and set the font color to White.  

 If the Formatting toolbar isn’t visible, select View -> Toolbars -> 
Formatting to make it visible. 

Afterwards, you should see this in the designer: 
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Exercise 3 
Build the main content page  
Now that the master page is complete, it’s time to build a content page. The first one you’ll build demonstrates 
how quickly—and with how little code—you can create a data-driven Web page with ASP.NET 2.0. 

Tasks Detailed Steps 
1. Add a content 

page 
 
 

a. First delete the Default.apsx page in Solution Explorer and then Right-click C:\..\Lab1 
in Solution Explorer and select “Add New Item.” 

b. Select “Web Form” and name it Default.aspx. Check the “Place code in separate 
file” and “Select master page” boxes and make sure the appropriate language is 
selected in the Language box before clicking Add. 

c. In the ensuing “Select a Master Page” window, select Site.master—the master page 
you built in the previous exercise—and click OK. 

d. Examine the @Page directive at the top of Default.aspx.  

 Notice the MasterPageFile  attribute.  
e. Click the Design button to switch to Design view. Notice that designer shows the 

content inherited from the master page, but shades it to indicate that it’s not defined in 
the content page itself. 

 

2. Add a 
SqlDataSource 
control 

a. Press the Smart Tag on upper right of content area and select “Default to Master 
Content” option on the menu.  Content on the page can be Custom (default) or come 
from the Master.  Now press the Smart Tag on upper right of content area and select 
“Create Custom Content” 

b. Drag a SqlDataSource control (you’ll find it in the Toolbox’s Data section) onto the 
page and drop it over the Content control. 

c. Click “Configure Data Source” in the “Common SqlDataSource Tasks” menu (see 
below). 

 
d. When the Configure Data Source dialog pops up, click the New button next to “Choose 

your data connection” to create a new database connection. 
e. In the Connection Properties dialog, type “localhost” into the “Select or enter a server 

name” box and select “Use Windows NT Integrated Security.” Then select “pubs” 
under “Select or enter a database name” and click OK. 

f. Make sure the new connection is selected in the “Choose your data connection” box. 
Then click Next. 

g. Make sure “Yes, save this connection as” is checked and click Next to proceed. 
h. In the ensuing dialog, select “titles” in the drop-down list labeled “Name.” In the 

Columns box, check “title,” “price,” and “notes” as shown below. Then click Next to 
proceed. 

i. Click Finish to finish configuring the SqlDataSource 
 

3. Add a 
GridView 
control 

a. Drag a GridView control onto the page and drop it underneath the SqlDataSource 
control. 

b. In the “GridView Tasks” menu, select SqlDataSource1 from the “Choose Data Source” 
list to bind the GridView to the SqlDataSource. 
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c. Use the “Auto Format” command in “GridView Tasks” to apply the “Rainy Day” 
format to the GridView. 

d. Click “Edit Columns” in the “GridView Tasks” Smart Tag. 
e. Select the column named “price.” Set its DataFormatString property to “{0:c}” and 

its ItemStyle-HorizontalAlign property to Right.  
f. Click “Add New Column” in the “GridView Tasks” Smart Tag. 
g. Select “CheckBoxField” in the Choose a field type list and fill in the remaining fields 

of the Add Field dialog as pictured below. Then click OK. 

 
h. Click “Edit Columns” in the “Common GridView Tasks” menu. 
i. Select the “add to cart” column that you just added and click “Convert this field into 

a Template Field.” Then set the column’s ItemStyle-HorizontalAlign property to 
Center and click OK. 

j. Check the “Enable sorting” box in the “Common GridView Tasks” menu. 
k. Select the GridView in the designer and use the Properties window to set its Width 

property to 100%. 
l. Select “Start Without Debugging” from the Debug menu (or press Ctrl+F5) to launch 

Default.aspx in a browser window. Verify that the output looks something like this: 
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m. Sort the GridView by clicking one of the sortable column headers. Also verify that 

clicking the same header several times in succession performs alternating ascending 
and descending sorts. 

n. Close the browser and return to Visual Studio 
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Exercise 4 
Build the check-out page 
In this exercise, you’ll build a check-out page that lists the items selected in the GridView on the previous 
page and asks for a credit card number. You’ll see first-hand how cross-page postbacks work and how a page 
that’s the target of a cross-page postback can communicate with the page that posted to it. You’ll also build a 
simple component that validates credit card numbers and allow ASP.NET to autocompile it. 

Tasks Detailed Steps 

1. Add a 
content page 
 
 

a. Right-click C:\..\Lab1 in Solution Explorer and select “Add New Item.” 
b. Select “Web Form” and name it CheckOut.aspx. Make sure the “Place code in 

separate file” and “Select master page” boxes are checked before clicking Add. 
c. Select Site.master as the master page. 
d. Add the following directive below the Page Directive. 

<%@ PreviousPageType VirtualPath="~/Default.aspx"  %> 

e. Click the Design button to switch to Design view. 
 

2. Add content 
to the page 

a. Add a pair of text strings, a BulletedList control, a TextBox control, and a Button control to 
the page’s Content control, approximating the layout shown below.  

 The layout pictured here uses 14-point bold Verdana for the text strings and 
12-point bold Verdana for the BulletedList control. Use the Formatting toolbar 
to set the font on the text strings, and the Properties window to set the font on 
the BulletedList. To set the font size to 12-point on the latter, you’ll need to 
type “12pt” into the Size box under Font. 

 
b. Double-click the page in the designer to add a Page_Load method. 
c. Add the following code to Page_Load to bind the BulletedList to an ArrayList 

containing the titles of the books selected on the previous page. Note the use of the 
PreviousPage property to call a public method on the page that posted to this one: 

C# 
if (PreviousPage != null && PreviousPage.IsCrossPagePostBack) { 
BulletedList1.DataSource = ((_Default) PreviousPage).GetTitles (); BulletedList1.DataBind (); }
VB 
If Not (PreviousPage Is Nothing) AndAlso PreviousPage.IsCrossPagePostBack Then 

BulletedList1.DataSource = CType(PreviousPage, _Default).GetTitles 
      BulletedList1.DataBind() 
End If 
 

d. Add the following statement to the using or Imports statements at the top of 
CheckOut.aspx.cs or CheckOut.aspx.vb: 
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C# 
using System.Collections; 

VB 
Imports System.Collections 

 
e. Double-click Default.aspx.cs or Default.aspx.vb in Solution Explorer to open it for 

editing and add the following statement to the using or Imports statements at the top: 
C# 

using System.Collections; 

VB 
Imports System.Collections 

f. Add the following method to the Default_aspx class: 
C# 

public ArrayList GetTitles () 
{ 
 A ist list = new ArrayL rrayList (); 
 foreach (GridViewRow row in GridView1.Rows) { 
  CheckBox box =  
            (CheckBox) row.Cells[3].Controls[1]; 
   if (box.Checked) 
    list.Add (row.Cells[0].Text); 
  } 
  return list; 
 } 

VB 
Public Function GetTitles() As ArrayList 
   Dim list As ArrayList = New ArrayList() 
   For Each row As GridViewRow In GridView1.Rows 
      Dim box As CheckBox = _ 
       CType(row.Cells(3).Controls(1), CheckBox) 
            If (box.Checked) Then 
                list.Add(row.Cells(0).Text) 
            End If 
        Next 
        Return list 
    End Function 

 
g. Double-click Default.aspx.  in Solution Explorer to open it and select design. 
h. he  properties of Text to “Checkout >>” and Add a button below the GridView and set t

PostBackURL to Checkout.aspx: 
i. Click Default.aspx in the Solution Explorer window and press Ctrl+F5 to launch it. 
j. ttom Check a few of the boxes in the GridView and click the Check Out button at the bo

of the page. Verify that CheckOut.aspx appears and accurately lists the items you 
selected: 

k. Close the browser and return to Visual Studio. 
 

3. Add a 
CreditCard 
component 

 

a. lution Explorer window, right click the App_Code folder and select “Add New In the So
Item.” 

b. cause Select “Class” as the template type and type “CreditCard” into the Name box. Be
this source code file is located in the App_Code folder, it will be autocompiled by 
ASP.NET. 

c. itCard class. It “validates” a credit card number by Add the following method to the Cred



Lab 1: Create a Web Site          9  
 

ensuring that it’s 16 characters long: 
C# 

public static bool IsValid (string number){ 
    return (number.Length == 16); 
} 

VB 
    Public Shared Function IsValid(ByVal number As String) As Boolean 
        Return (number.Length = 16) 
    End Function 

d.  Design view. Double-click the Go back to the designer and open CheckOut.aspx in
“Place Order” button to write a click handler for it. 

e. Add the following code to the Button1_Click method 
C# 

if (CreditCard.IsValid(TextBox1.Text)) 
   Response.Redirect("ThankYou.aspx");  
else  
   ClientScript.RegisterStartupScript(script.GetType(),"Error", script); 

VB 
If CreditCard.IsValid(TextBox1.Text) Then 
   Response.Redirect("ThankYou.aspx") 
Else 
   ClientScript.RegisterStartupScript(script.GetType(),"Error", script) 
End If 

f. Add the following field to the CheckOut_aspx class: 
C# 

static readonly string script ="<script language=\"javascript\">\n" + 
"alert (\"Sorry, but we couldn't validate your credit card\");\n" +"</script>"; 

VB 
Private Shared ReadOnly script As String = "<script language=""javascript"">" & 
vbCrLf & _ 
"alert (""Sorry, but we couldn't validate your credit card"");" & vbCrLf & _ 
"</script>" 

g.  Run Default.aspx. Select a few items in the GridView and click the Check Out button.
Type “12345” into the credit card box and click “Place Order.” The following error 
message should appear in a popup message box. 

 
h. Dismiss the message box. Then close the browser and return to Visual Studio. 
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Exercise 5 
Build the thank-you page 
All that remains now is to build the content page that the Place Order button redirects to following a successful 
credit card validation. In this exercise, you’ll build that page and then test the finished application.. 

Tasks Detailed Steps 
1. Add a content page 
 

a. Right-click C:\..\Lab1 in Solution Explorer and select “Add New Item.” 
b. Select “Web Form” and name it ThankYou.aspx. Check the “Place code in 

separate file” and “Select master page” boxes before clicking Add. 
c. Select Site.master as the master page. 
d. Click the Design button to switch to Design view. 
e. Position the cursor in the page’s Content control and type “Thank you for using 

MSN Bookstore!” 
f. Modify the text you just typed to use a bold italic 14-point Verdana font. 
 

2. Test the finished 
application 

a. Select Default.aspx in the Solution Explorer window and press Ctrl+F5 to launch 
it. 

b. Check a few of the boxes in the GridView and click the “Check Out” button. 
c. Type “1234567812345678” into the credit card box and click the “Place Order” 

button. 
d. Verify that ThankYou.aspx appears and displays the message shown below: 

 
e. Close the browser and return to Visual Studio. 
 

 



Lab 1: Create a Web Site          11  
 

Exercise 6 
Use the Web Site Administration Tool 
Another of the new features in ASP.NET is the Web Site Administration Tool. In ASP.NET 1.x, you change 
configuration settings by hand-modifying CONFIG files. In ASP.NET 2.0, most configuration changes can be 
made through the Web Site Administration Tool. The tool is built on top of the new configuration API, which 
we’ll explore in detail in a subsequent course module. 
In this exercise, you’ll use the Web Site Administration Tool to make a simple configuration change to your 
Web site. 

Tasks Detailed Steps 
1. Start the Web 

Site 
Administration 
Tool 
 
 

a. Select “ASP.NET Configuration” from Visual Studio’s Website menu. After a brief 
pause, the following page appears in the IDE: 

 NOTE: 

The “Website->ASP.NET Configuration” command launches the Web Site 
Administration Tool inside the Visual Studio IDE. Outside Visual Studio, you can 
launch the Web Site Administration Tool by pointing your browser to 
http://.../webadmin.axd, where “...” targets a virtual directory containing an 
ASP.NET application. Webadmin.axd isn’t a file; it’s a phantom resource 
mapped to an HTTP handler that redirects to the Web Site Administration Tool 
on the Web server. 

 
 

2. Toggle the 
debug setting 

a. Click the Application tab at the top of the page, or the “Application Configuration” 
link in the body of the page. 

b. Click “Configure debugging and tracing.” 
c. Double-click Web.config in Solution Explorer to open the file. Read the 

<compilation> element and make a mental note of what it says. 
d. Return to the Web Site Administration Tool without closing Web.config and click 

the “Enable debugging” box. 
e. Visual Studio displays a message informing you that Web.config has been modified 

outside the source editor and asks if you want to reload it. Click the “Yes” button. 
f. Go back to Web.config. How has the <compilation> element changed? 
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