
LAB PRT04: Developing Solutions on 
Microsoft® SharePoint® Products and 
Technologies 

Objectives 
 

Module 1: Using the Microsoft Windows SharePoint Services Object 
Model. Make use of the managed code object model provided by Windows 
SharePoint Services to perform a variety of tasks.  Estimated time to complete 
this module: 60 minutes  

Module 2: Creating a Web Part for Microsoft SharePoint Products and 
Technologies.  Learn to create a data-driven Web Part, including enhancing the 
Web Part with custom properties.  Deploy it to a Microsoft Windows 
SharePoint Services server and add it to the Virtual Server Gallery.  Add the 
web part to the home page of a SharePoint site.  Estimated time to complete 
this module: 60 minutes 

Module 3: Creating Connectible Web Parts for Microsoft SharePoint 
Products and Technologies.  Learn to create Web Parts that can provide and 
consume information to/from each other using Web Part Connections.  
Estimated time to complete this module: 60 minutes 

Estimated time to complete this lab: 3 hours 
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Module 1 
For your convenience, the code needed for this module has been stored in Visual Studio in the Toolbox 
under the “Object Model HOL” tab. You may just drag-and-drop the appropriate code snippet in lieu of 
typing. Each snippet label is included in the manual text. 

Exercise 1  
Creating an ASP.NET page application for use within a SharePoint 
site 

In this exercise, you will learn how to create an ASPX application on a 
Windows SharePoint Services (or, for that matter, a Microsoft® Office 
SharePoint® Portal Server 2003) host. You will also learn how to identify 
specific user and SharePoint site context within an ASPX application.  

Any ASPX page place inside the IIS virtual server's /_layouts directory will be 
handled by Windows SharePoint Services (and, by definition, SharePoint Portal 
Server) as if it were a subdirectory of each and every SharePoint site.  In other 
words, anything under: 

 http://server/_layouts 

can be called with (for example) any of the following URLs: 

 http://server/sites/thissite/_layouts 
 http://server/sites/thatsite/_layouts 
 http://server/sites/thatsite/thatsubsite/_layouts 

In each case, the ASPX will be presented with a context object that provides it 
with information about the site to the left of "/_layouts/". 

 Create a Visual Studio ASP.NET Web Application project  

1. Login as the “Jeff Teper” user (username “jeff”, password “P@ssw0rd”) 
2. Start Visual Studio.Net 2003 
3. On the File menu, select New, and then click Project 
4. In the New Project dialog, click “Visual C# Projects”, then select the 

“ASP.NET Web Application” template 
5. Change the location of the project to 

http://server/_layouts/MySharePointApp 
6. Click “OK” 

 Set a reference to the Windows SharePoint Services assembly 

1. Add a reference to the Windows SharePoint Services assembly to your 
project by clicking on the “Project” menu and selecting “Add 
Reference…” 

2. On the .NET tab, select “Windows SharePoint Services” and click 
“Select” 

3. Click “OK” 

 Add server controls to the ASPX page 
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1. Open WebForm1.aspx in Design view. 
2. To the form, add 

• a textbox 

• a button (put it below the textbox) 

• a label (put it below the button) 

3. Double-click the button to open the code-behind file for the form 
4. Add the following code within the Page_Load procedure (Visual Studio 

Snippet 1): 
if ( !IsPostBack ) 
{ 
 // If this is the first time loading the page, 
 // populate the textbox with the current  
 // user’s name 
 string sUser = Context.User.Identity.Name.ToString().Trim(); 
 TextBox1.Text = sUser; 
} 

 

 Establish the SharePoint site context 

1. At the top of the code-behind file, add the following using directives (Visual 
Studio Snippet 2): 
using Microsoft.SharePoint; 
using Microsoft.SharePoint.Utilities; 
using Microsoft.SharePoint.WebControls; 

 
2. Within the Button1_Click handler that Visual Studio .NET created, add the 

following lines of code (Visual Studio Snippet 3): 
// Establish Site and Web context 
SPSite oThisSite = SPControl.GetContextSite( Context); 
SPWeb oThisWeb = SPControl.GetContextWeb( Context ); 

 Identify the current user and their role in the SharePoint site 

1. Next, add the following code block below the code you just added (Visual 
Studio Snippet 4): 
// Get the entered user's name 
string sUser = TextBox1.Text; 
 
string sUserInfo = sUser  
 + " belongs to the following roles ("  
 + oThisWeb.Url + "):<BR>"; 
 
// Get the users for this web 
SPUserCollection oUsers = oThisWeb.Users; 
foreach ( SPUser oUser in oUsers )  
{ 
 // Locate the current user and get his/her roles 
 if ( oUser.LoginName.ToLower() == sUser.ToLower() )  
 { 
  SPRoleCollection oRoles = oUser.Roles; 
  foreach ( SPRole oRole in oRoles )  
  { 
   sUserInfo +=  
    SPEncode.HtmlEncode( oRole.Name ) 
    + "<BR>"; 
  } 
  break; 
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 } 
} 
 
// Populate the label with the User's info 
Label1.Text = sUserInfo; 

 Build the solution and test the new site 

1. From the Visual Studio Build menu, choose Build MySharePointApp 
2. Open Internet Explorer and navigate to  

http://server/sites/VitaminSalesTeam/_layouts/MySharePointApp/WebForm
1.aspx 

 Note that your user account has been identified and placed in the textbox. 
3. Click the form's Button control. 
4. Note that your user account's privileges within this site have been 

enumerated in this form's label control.  Now let's try the same form from 
within another site – your My Site, in this case. 

5. From the same Internet Explorer window, navigate to  
 
http://server/personal/jeff/_layouts/MySharePointApp/WebForm1.aspx 
 

 Note that your user account has been identified and placed in the textbox. 
6. Click the form's Button control. 
7. Note that your user account's privileges within your My Site have been 

enumerated in this form's label control. 
8. If you wished to do so, you could append 

 
 /_layouts/MySharePointApp/WebForm1.aspx 
 
to any Windows SharePoint Services site URL within http://server and this 
page would report user and privilege information for this user at that site. 
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Exercise 2 
Extracting data from a SharePoint list 

In this exercise, you will learn how to access SharePoint list data using the 
provided API.  You will learn how identify lists and extract data and list 
schema information. You will also learn how to add and change content in a 
SharePoint list. 

NOTE:  The page you will be building is dependent on the site from which it is 
being executed containing a list named "Customer Issues".  As such, unlike the 
previous example, it will not successfully execute in every site. 

 Return to the Visual Studio ASP.NET Web Application project 

1. If you closed it, reopen the Web Application you created in Exercise 1.  
Otherwise, simply switch to its already-open application window. 

 Add a new Web Form to the application 

1. Click on the “Project” menu and select “Add Web Form…” 
2. In the “Add New Item” dialog that opens, ensure that Web Form is 

selected. 
3. Change the Name to “ListExample.aspx” 
4. Click “Open” 

 Update the form definition with SharePoint directives 

1. Open ListExample.aspx in HTML view. 
2. Add the following page directives to the top of the page (Visual Studio 

Snippet 5): 
<%@ Register Tagprefix="SharePoint" 
Namespace="Microsoft.SharePoint.WebControls" 
Assembly="Microsoft.SharePoint, Version=11.0.0.0, 
Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> 
<%@ Register Tagprefix="Utilities" 
Namespace="Microsoft.SharePoint.Utilities" 
Assembly="Microsoft.SharePoint, Version=11.0.0.0, 
Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> 
<%@ Import Namespace="Microsoft.SharePoint" %> 
<%@ Register Tagprefix="WebPartPages" 
Namespace="Microsoft.SharePoint.WebPartPages" 
Assembly="Microsoft.SharePoint, Version=11.0.0.0, 
Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> 
 

3. Add the SharePoint FormDigest control to the form by adding the following 
line inside the <form> tags (Visual Studio Snippet 6): 
<SharePoint:FormDigest runat="server"/> 

 Add server controls to the ASPX page 

1. Switch to Design view. 
2. To the form, add 

• a textbox 

• a button (put it below the textbox) 

• a listbox (put it below the button) 
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3. Change the text of the button to “Add”. 
4. Double-click the button to open the code-behind file for the form. 

 Establish the SharePoint site context 

1. At the top of the code-behind file, add the following using directives (Visual 
Studio Snippet 2): 
using Microsoft.SharePoint; 
using Microsoft.SharePoint.Utilities; 
using Microsoft.SharePoint.WebControls; 

 
2. Add the following modular declarations to the top of your ListExample 

class (Visual Studio Snippet 7): 
private SPSite m_oThisSite; 
private SPWeb m_oThisWeb; 

 
3. Within the Page_Load procedure that Visual Studio .NET created, add the 

following  lines of code (Visual Studio Snippet 8): 
// Establish Site and Web context 
m_oThisSite = SPControl.GetContextSite( Context ); 
m_oThisWeb = SPControl.GetContextWeb( Context ); 
 

 Display the items in the site list 

1. Below the Button1_Click function, add the following LoadList procedure to 
your class (Visual Studio Snippet 9): 
private void LoadList( string sList )  
{ 
 SPList oList = m_oThisWeb.Lists[ sList ]; 
 SPListItemCollection oListItems = oList.Items; 
 
 ListBox1.Items.Clear(); 
 foreach ( SPListItem oItem in oListItems )  
 { 
  ListBox1.Items.Add(oItem["Title"].ToString()); 
 } 
} 
 

2. Call the LoadList procedure from the Page_Load event by adding the 
following lines of code to the end of the Page_Load procedure (Visual 
Studio Snippet 10): 
if ( !IsPostBack ) 
{ 
 LoadList( "Customer Issues" ); 
} 
 

 Add the add item code and build the project 

1. Within the Button1_Click handler that Visual Studio .NET created, add the 
following lines of code (Visual Studio Snippet 11): 
SPList oList = m_oThisWeb.Lists[ "Customer Issues" ]; 
SPListItemCollection oListItems = oList.Items; 
 
SPListItem oNewItem = oList.Items.Add(); 
oNewItem[ "Title" ] = TextBox1.Text; 
oNewItem.Update(); 
 
LoadList( "Customer Issues" ); 
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2. Build the project. 

 Run the application and add an item to the list 

1. Browse to your application by entering the following URL in Internet 
Explorer:   

http://server/sites/vitaminsalesteam/_layouts/MySharePointApp/ListExample.aspx 

2. Type the title of your new list item in the text box and click the “Add” 
button. 

3. Browse to the Customer Issues list to see your newly added item by 
entering the following URL in Internet Explorer: 

http://server/sites/VitaminSalesTeam/Lists/Customer%20Issue/AllItems.aspx 
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Exercise 3 
Creating a SharePoint site using API calls 

In this exercise, you will learn how to create a new SharePoint site using the 
Windows SharePoint Services API.  

 Return to the Visual Studio ASP.NET Web Application project 

1. If you closed it, reopen the Web Application you created in Exercise 1.  
Otherwise, simply switch to its already-open application window. 

 Add a new Web Form to the application 

1. Click on the “Project” menu and select “Add Web Form…” 
2. In the “Add New Item” dialog that opens, ensure that Web Form is selected. 
3. Change the Name to “SiteCreationExample.aspx” 
4. Click “Open” 

 Update the form definition with SharePoint directives 

1. Open SiteCreationExample.aspx in HTML view. 
2. Add the following page directives to the top of the page (Visual Studio 

Snippet 5): 
<%@ Register Tagprefix="SharePoint" 
Namespace="Microsoft.SharePoint.WebControls" 
Assembly="Microsoft.SharePoint, Version=11.0.0.0, 
Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> 
<%@ Register Tagprefix="Utilities" 
Namespace="Microsoft.SharePoint.Utilities" 
Assembly="Microsoft.SharePoint, Version=11.0.0.0, 
Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> 
<%@ Import Namespace="Microsoft.SharePoint" %> 
<%@ Register Tagprefix="WebPartPages" 
Namespace="Microsoft.SharePoint.WebPartPages" 
Assembly="Microsoft.SharePoint, Version=11.0.0.0, 
Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> 

 
3. Add the SharePoint FormDigest control to the form by adding the following 

line inside the <form> tags (Visual Studio Snippet 6): 
<SharePoint:FormDigest runat="server"/> 

 Add server controls to the ASPX page 

1. Switch to Design view. 
2. Add three labels, three textboxes, and a button to the page, much like this: 

Label1 TextBox1 

Label2 TextBox2 

Label3 TextBox3 

Button1  

 

3. Double-click the button to open the code-behind file for the form. 
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4. Add the following code to the Page_Load handler (Visual Studio Snippet 

12): 
Label1.Text = "Name:"; 
Label2.Text = "Title:"; 
Label3.Text = "Description:"; 
Button1.Text = "Create Site"; 

 
 Establish the SharePoint site context 

1. At the top of the code-behind file, add the following using directives (Visual 
Studio Snippet 2): 
using Microsoft.SharePoint; 
using Microsoft.SharePoint.Utilities; 
using Microsoft.SharePoint.WebControls; 

 
2. Add the following modular declarations to the top of your 

SiteCreationExample class (Visual Studio Snippet 13): 
private SPSite m_oThisSite; 
private SPWeb m_oThisWeb; 
 

3. Within the Page_Load procedure that Visual Studio .NET created, add the 
following  lines of code to the beginning (Visual Studio Snippet 14): 
// Establish Site and Web context 
m_oThisSite = SPControl.GetContextSite( Context ); 
m_oThisWeb = SPControl.GetContextWeb( Context ); 
 
 Add code for creating the site and build the project 

1. Within the Button1_Click handler that Visual Studio .NET created, add the 
following lines of code (Visual Studio Snippet 15): 
// Get current web's web collection 
SPWebCollection oWebs = m_oThisWeb.Webs; 
 
// Get current web's template 
string sTemplate = m_oThisWeb.WebTemplate; 
 
string sName = TextBox1.Text.ToString(); 
string sTitle = TextBox2.Text.ToString(); 
string sDescription = TextBox3.Text.ToString(); 
 
// Add the new site 
SPWeb oNewWeb = oWebs.Add( sName, sTitle,  
 sDescription, 1033, sTemplate, true, false ); 
 
// Redirect to the new site 
Response.Redirect( oNewWeb.Url ); 
 

2. Build the project 

 Create a new site beneath the current site 

1. Browse to your application by entering the following URL in Internet 
Explorer: 

http://server/sites/vitaminsalesteam/_layouts/MySharePointApp/SiteCreationExam
ple.aspx 

2. Type the name, title, and description of your new site into the text boxes and 
click the “Create Site” button. 
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 Test the new site 

1. You should be redirected to your new site. 
 
Congratulations! You have now completed this module. 
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Module 2 
For your convenience, the code needed for this lab has been stored in Visual Studio in the Toolbox under 
the “Web Part HOL1” tab. You may just drag-and-drop the appropriate code snippet in lieu of typing. 
Each snippet label is included in the manual text. 

Exercise 1  
Creating the NorthwindOrders Web Part Class 

In this exercise, you will use the Web Part Templates for Microsoft® Visual 
Studio .NET 2003 to create a custom SharePoint Web Part Library project.   

 To start a Web Part Library project  

1. From the Start Menu open Microsoft Visual Studio .NET 2003 
2. From the File menu choose “New  Project…” 
3. In the “Add New Project” dialog box, select “Web Part Library” from 

“Visual C# Projects” with the following properties: 
a. Name: Northwind 
b. Location: "C:\Documents and Settings\Jeff\My Documents\Visual 

Studio Projects" 
4. The template automatically inserts the code for a standard Web Part.  It has 

the default name of WebPart1, which we will want to change to our own 
class name. 

 To adjust the class name for our Web Part 

1. In the Solution Explorer window, right-click WebPart1.cs, choose Rename, 
and change this file's name to NorthwindOrders.cs. 

2. Open NorthwindOrders.cs by double-clicking on it. 
Replace the text: 

 /// <summary> 
 /// Summary description for WebPart1. 
 /// </summary> 
 [DefaultProperty("Text"), 
 ToolboxData("<{0}:WebPart1  
 runat=server></{0}:WebPart1>"), 
 XmlRoot(Namespace="Northwind")] 
 public class WebPart1 :  
  Microsoft.SharePoint.WebPartPages.WebPart 
 

with (Visual Studio Snippet 1)… 
 
 /// <summary> 
 /// Summary description for NorthwindOrders. 
 /// </summary> 
 [DefaultProperty("Text"), 
 ToolboxData("<{0}: NorthwindOrders  
 runat=server></{0}: NorthwindOrders >"), 
 XmlRoot(Namespace="Northwind")] 
 public class NorthwindOrders :  
  Microsoft.SharePoint.WebPartPages.WebPart 
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Exercise 2  
Creating the Child Controls 

In this exercise, you will start to add functionality to your web part by building 
up the control collection.  In a Web Part, as in any custom control, all property 
settings must be specified in the code. This is similar to the pattern used in 
Visual Studio.NET Windows Forms, where all control property settings appear 
in the code and all controls are explicitly added to the form’s "Controls" 
collection. 

 Task 1 – To add reference to System.Data namespace  

1. Add a directive to the end of the list of already-added "using" directives 
(Visual Studio Snippet 2): 
using System.Data; 
using System.Data.SqlClient; 

 
2. Add a reference to the System.Data namespace 

a. Right-click on the Solution Explorer -> References 
b. Select “Add Reference” 
c. Select the .Net tab 
d. Double-click on the System.Data.dll entry 
e. Select OK 

 Task 2 – To add child controls to the Web Part 

1. Add a label and a DataGrid to the declarations section inside the 
NorthwindOrders class (Visual Studio Snippet 3):  
protected Label ErrorLabel; 
protected DataGrid OrdersGrid; 

 
 Task 3 – To override the CreateChildControls method  

In this procedure, you will override the CreateChildControls method.  In this 
method, you instantiate the controls, set their properties, and hook up any 
event handler. You also must add the controls to the part’s Controls 
collection, which is inherited from System.Web.UI.Control. The code 
begins by instantiating the ErrorLabel control, which is invisible by default.  

This control is used to display an error message if an exception occurs while 
attempting to load the Web Part’s data.  Next, the code instantiates the 
DataGrid control, hooks up its event handlers, and, as was done for 
ErrorLabel, the code adds this control to the Web Part’s Controls collection. 

1. Directly below the variables you have declared in the previous procedure, 
type the following code to override the CreateChildControls() method 
(Visual Studio Snippet 4):  
protected override void CreateChildControls() 
{ 
 // This label is used to display a 
 // security error if file I/O 
 // permissions aren't available. 
 ErrorLabel = new Label(); 
 ErrorLabel.Visible = false; 
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 Controls.Add(ErrorLabel); 
 
 // Create the data grid 
 OrdersGrid = new DataGrid(); 
 OrdersGrid.Load += new EventHandler(OrdersLoad); 
 OrdersGrid.AllowPaging = false; 
 Controls.Add(OrdersGrid); 
} 

 
 From the File menu, click Save All 

 Task 4 - To handle events for the Orders DataGrid 

The NorthwindOrders code contains one event handler for the DataGrid to 
load the grid.  In the Load event handler, you will use ADO.NET to query 
information from the sample Northwind database supplied with every copy 
of Microsoft SQL Server 2000.  

We will put the code that actually binds the DataGrid to an ADO.NET 
DataSet into a standalone private method named BindGrid.  This allows us 
to force the grid to repopulate under a variety of conditions, primarily in this 
case when we receive a new CustomerID via a connection. 

1. Directly below the CreateChildControls() method you have already written, 
type the following code to load the Orders DataGrid (Visual Studio Snippet 
5). 
public void OrdersLoad(object sender, EventArgs e) 
{ 

if (CustomerId == null) 
{ 

CustomerId = ""; 
} 
else 
{ 
 BindGrid(); 
} 

} 
 
2. Directly below the OrdersLoad() method you have already written, type the 

following code for the BindGrid method (Visual Studio Snippet 6). 
private void BindGrid() 
{ 
 String sqlQuery = "SELECT OrderID, CustomerID" 
   + ", OrderDate, RequiredDate" 
   + ", ShippedDate, Freight" 
   + " FROM Orders WHERE CustomerID = " 

   + "'" + CustomerId + "'"; 
 
 String sqlConn = "Persist Security Info=False" 
  + ";Integrated Security=SSPI" 
  + ";Initial Catalog=Northwind" 
  + ";Data Source=server"; 
 
 SqlConnection cnx = null; 
 SqlCommand cmd = null; 
 SqlDataReader rdr = null; 
 
 try 
 { 
  cnx = new SqlConnection(sqlConn); 
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  cmd = new SqlCommand(sqlQuery, cnx); 
  rdr = null; 
  cnx.Open(); 
  rdr = cmd.ExecuteReader(); 
 
  OrdersGrid.Enabled = true; 
  OrdersGrid.DataSource = rdr; 
  OrdersGrid.DataBind(); 
 } 
 catch (Exception ex) 

{ 
 ErrorLabel.Text.Insert(ErrorLabel.Text.Length, 

   "Exception occurred: " + ex.ToString()); 
  ErrorLabel.Visible = true; 
 } 
 finally 
 { 
  if (rdr != null) 
   rdr.Close(); 
   
  if (cnx != null) 
   cnx.Close(); 
 } 
} 

 
From the File menu, click Save All. 
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Exercise 3  
Rendering the Web Part’s HTML 

Use of child controls in a Web Part is optional. But every Web Part that 
displays anything to the user must override the RenderWebPart method. This is 
where your Web Part generates the HTML that gets rendered inside the Web 
Part frame. 

The NorthwindOrders Web Part contains a label, named ErrorLabel, which is 
hidden by default. It is made visible only if an exception occurs when 
attempting to read the XML data file in the OrdersLoad event handler. 

After insuring that any child controls have been created, the RenderWebPart 
code checks whether ErrorLabel is still invisible, indicating that the data was 
successfully loaded.  If the ErrorLabel control is visible, then the only rendering 
code that runs is the code to display the error message in that was assigned to 
the text property of this control.  The code then checks to see if there is a 
connection: if not connected, display instructions for creating a connection, if 
connected, display based on presence of CustomerID.  The remaining code in 
the RenderWebPart method calls the RenderControl method of the DataGrid 
control.   

 Task 1 - To override the RenderWebPart method 

1. In the RenderWebPart method that was created for you,  
replace… 

  
output.Write(SPEncode.HtmlEncode(Text)); 

 
with (Visual Studio Snippet 7)… 
 

// The EnsureChildControls method of 
// System.Web.UI.Control calls the 
// CreateChildControls method only if the 
// ChildControlsCreated property is false. 
EnsureChildControls(); 
 
// In case of an error, 
// ErrorLabel is made visible in BindGrid(). 
if (ErrorLabel.Visible == true) 
{ 
 ErrorLabel.RenderControl(output); 
 return; 
} 
 
// If we haven’t been given a CustomerID,  
// display instructions.  Otherwise, 
// display a heading and the grid. 
if (CustomerId == "" || CustomerId == null) 
{ 
 String toolPaneUrl = ToolPane.GetShowToolPaneEvent( 
  this, ToolPane.ToolPaneView.Properties); 
 
 output.Write("<P>Please <A HREF=\"" + toolPaneUrl 
  + "\">click here</A> to provide" 
  + " a valid Customer ID. </P>"); 
} 
else 
{    
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 output.RenderBeginTag("div"); 
 output.AddStyleAttribute( 
  HtmlTextWriterStyle.FontWeight, "bold"); 
  
 output.RenderBeginTag(HtmlTextWriterTag.Span); 
 output.Write("<nobr> Orders for Customer ID: "  
  + SPEncode.HtmlEncode(CustomerId)  
  + "</nobr>"); 
 output.RenderEndTag(); //span 
  
 OrdersGrid.RenderControl(output); 
 output.RenderEndTag(); //div 
} 

 

From the File menu, click Save All. 
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Exercise 4  
Creating and Displaying Custom Properties 

Any custom properties that you create for your Web Part class can easily be 
exposed to users in the browser task pane when they choose to modify the Web 
Part. 

There are several attributes that you can add to the property definition in your 
code to refine how the property will be presented to the user. The 
NorthwindOrders Web Part has a property named CustomerID that determines 
how much data is displayed. The section of the RenderWebPart method that 
renders the DataGrid control checks this property and renders the grid only if 
this property is present. 

The attributes added to the DetailViewEnabled property in following code 
specify a description, a custom category, a default value and a friendly name for 
the property. In addition, setting the WebPartStorage attribute to 
Storage.Personal specifies that different values of the property can be stored for 
different users. 

 Task 1 - To create a custom property 

1. In the class declarations section 
replace… 
const string _defaulttext = ""; 
private string text=_defaulttext; 

 

with (Visual Studio Snippet 8)… 
private string _customerID; 

 
2. Directly below the BindGrid method, update the code to insert the 

CustomerID property. 
replace… 
 [Browsable(true), Category("Miscellaneous"),  
DefaultValue(_defaulttext), 
Description(""), 
FriendlyName("Text"), 
WebPartStorageAttribute(Storage.Personal)]  
public string Text  
{ 
 get 
 { 
  return text; 
 } 
 
 set 
 { 
  text = value; 
 } 
}  

With (Visual Studio Snippet 9)… 
// Use attributes to specify property UI and storage. 
// Create a custom category for display 
// in the tool pane property browser. 
[Category("Customer"), 
DefaultValue(""), 
WebPartStorage(Storage.Personal), 
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FriendlyNameAttribute("Customer ID"), 
Description("Enter Customer ID for order list.")] 
public string CustomerId 
{ 
 get 
 { 
  return _customerID; 
 } 
 set 
 { 
  _customerID = value; 
 } 
} 

 

From the File menu, click Save All. 

 Task 2 - To create a Custom Tool Part 

Defining the property, as above, is all that you must do to ensure that it is 
displayed in the task pane. You can, however, override the GetToolParts 
method to customize the display of your properties. This method returns an 
array of ToolPart objects to be displayed in the task pane. 

The following code first adds a CustomToolPart object to the tool Web Part 
array that the method returns. Even without this code the custom View category 
containing the custom property would be displayed, but by default it would be 
displayed after the standard properties. Putting it first in the array moves it to 
the top of the task pane. The CustomToolPart object automatically displays any 
custom properties, and the WebToolPart object automatically displays the 
standard properties. The code also specifies that the custom View category 
should be expanded. The other categories are collapsed by default when the task 
pane opens. 

1. Override the GetToolParts() method. 
replace… 
 
//public override ToolPart[] GetToolParts() 
//{ 
// ToolPart[] toolparts = new ToolPart[2]; 
// WebPartToolPart wptp = new WebPartToolPart(); 
// CustomPropertyToolPart custom = new 
CustomPropertyToolPart(); 
// toolparts[0] = wptp; 
// toolparts[1] = custom; 
 
// return toolparts; 
//} 
 

 with (Visual Studio Snippet 10)… 
 
public override ToolPart[] GetToolParts() 
{ 
 // This method returns an array of ToolParts. 
 ToolPart[] toolparts; 
 
 // Add a CustomPropertyToolPart, which will  
 // automatically display the custom  
 // CustomerID property. 
 
 // Expand the custom Customer category, 
 // which was created in an attribute of  
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 // the property. 
  
 toolparts = new ToolPart[2]; 
 CustomPropertyToolPart cptp =  
  new CustomPropertyToolPart(); 
 WebPartToolPart wptp = new WebPartToolPart(); 
 cptp.Expand("Customer"); 
 toolparts[0] = cptp; 
 toolparts[1] = wptp; 
 
 return toolparts; 
} 

 
From the File menu, click Save All. 
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Exercise 5 
Building a Web Part Package 

In this exercise, you will create a Web Part Package to deploy your custom web 
parts. A Web Part package is a CAB file that contains the following items: 

1. Manifest.xml 
2. Web Part assemblies 
3. Class resource files (optional) 
4. DWP files 

 Task 1- Modifying the DWP file for a Web Part 

1. In the Solution Explorer window, right-click WebPart1.dwp, choose 
Rename, and change this file's name to NorthwindOrders.dwp. 

2. Open NorthwindOrders.dwp by double-clicking on it. 
3. Replace the contents of this file with the following (Visual Studio Snippet 

11)… 
<?xml version="1.0" encoding="utf-8"?> 
<WebPart xmlns="http://schemas.microsoft.com/WebPart/v2" > 
 <Title>Northwind Orders</Title> 
 <Description>Northwind Customer Orders.</Description> 
 <Assembly>Northwind</Assembly> 
 <TypeName>Northwind.NorthwindOrders</TypeName> 
</WebPart> 

 

 Task 2- Modifying the Manifest file for a CAB 

1. In the Solution Explorer window, open Manifest.xml by double-clicking on 
it. 

2. Replace the contents of this file with the following (Visual Studio Snippet 
12)… 
<?xml version="1.0"?> 
<WebPartManifest 
xmlns="http://schemas.microsoft.com/WebPart/v2/Manifest"> 
  <Assemblies> 
    <Assembly FileName="Northwind.dll"> 
      <ClassResources> 
      </ClassResources> 
      <SafeControls> 
        <SafeControl 
          Namespace="Northwind" 
          TypeName="*" 
        /> 
      </SafeControls> 
    </Assembly> 
  </Assemblies> 
  <DwpFiles> 
    <DwpFile FileName="NorthwindOrders.dwp"/> 
  </DwpFiles> 
</WebPartManifest> 

  
 Task 2 - Create a CAB file using Visual Studio .NET 

1. In the Solution Explorer window, select the Northwind Solution. 
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2. From the File menu, click Add Project, New Project 
3. In the Add New Project dialog box, under Project Types, click Setup and 

Deployment Projects and select Cab Project. 
a. Name: NorthwindCab 
b. Location: C:\Documents and Settings\Jeff\My Documents\Visual 

Studio Projects\Northwind 
c. Click OK. 

4. Add the Web Part project output to the CAB project. 
a. In the Solution Explorer, right-click on the CAB project. 
b. In the shortcut menu that appears, point to Add and then click Project 

Output. 
c. In the Add Project Output Group dialog box, ensure that you to select 

the correct project. 
d. Select “Primary Output” and “Content Files” and then click OK. 

5. Build the solution and the CAB is created. 
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Exercise 6  
Deploying and Testing your Web Part 

In this exercise, you will deploy and test your Web Part.  Administrators can 
deploy CAB packages created by developers by using stsadm.exe. This tool is 
the command-line alternative to managing a Windows SharePoint Services 
computer. Three commands in the tool deal with Web Part package 
deployment: 

• AddWPPack 
• DeleteWPPack 
• EnumWPPacks 

 
To learn about a command in stsadm.exe, at the command prompt, type the 
following: 

stsadm –help command 

 Task 1 - Adding a Web Part Package 

1. Open a command prompt.   
2. Navigate to the “C:\Documents and Settings\Jeff\My Documents\Visual 

Studio Projects\Northwind\NorthwindCab\Debug” directory 
3. We have already added the C:\Program Files\Common Files\Microsoft 

Shared\web server extensions\60\BIN directory to this computer's path, so 
you only need to type the following command (all on one line – do not cut 
and paste the command from this document) : 
stsadm –o addwppack –filename NorthwindCab.cab 
 

 Task 2 - Testing Web Part deployment 

1. Open an Internet Explorer browser session and navigate to http://server/ 
2. Click My Site 
3. Near the top-right corner of the page, click “Modify My Page” and select 

“Add Web Parts  Browse” from the drop-down 
4. In the right pane, click the Virtual Server gallery and locate the “Northwind 

Orders” Web Part you created (you may have to click “next” a few times in 
the list of Web Parts) 

5. Drag and drop the Northwind Orders Web Part onto to a zone on the page. 
6. When the page refreshes, the newly-added Web Part should display a 

message asking you to provide a Customer ID.  Click on the error message's 
"click here" link to open the tool pane that configures this Web Part. 

7. In the tool pane, enter "ANTON" in the Customer ID textbox, and click on 
the OK button at the bottom of the tool pane. 

8. Note that the Web Part now displays all orders for the customer with ID 
"ANTON". 

 
Congratulations! You have now completed this module. 
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Module 3 
For your convenience, the code needed for this lab has been stored in Visual Studio in the Toolbox under 
the “Web Part HOL2” tab. You may just drag-and-drop the appropriate code snippet in lieu of typing. 
Each snippet label is included in the manual text. 

Exercise 1  
Creating the ConnTest Project 

In this exercise, you will use the Web Part Templates for Microsoft® Visual 
Studio .NET 2003 to create a custom SharePoint Web Part Library project.   

 To start a Web Part Library project  

1. From the Start Menu open Microsoft Visual Studio .NET 2003 
2. From the File menu choose “New  Project…” 
3. In the “Add New Project” dialog box, select “Web Part Library” from 

“Visual Basic Projects” with the following properties: 
a. Name: ConnTest 
b. Location: "C:\Documents and Settings\Jeff\My 

Documents\Visual Studio Projects" 
4. The template automatically inserts the code for a standard Web Part, which 

we will want to remove and replace with specific items. 

 To remove the default Web Part code from the project 

1. In the Solution Explorer window, right-click WebPart1.vb, choose Delete, 
and when asked, choose "OK" to confirm the deletion. 

2. In the Solution Explorer window, right-click WebPart1.dwp, choose 
Delete, and when asked, choose "OK" to confirm the deletion. 

At this point, the project contains References, a module named 
AssemblyInfo.vb, and a Manifest.xml file.  We need to add code and DWP files 
for both a provider Web Part and a consumer Web Part.  We'll also need to add 
and configure a CAB file setup project to this solution.  For the moment, let's 
begin with just the code modules. 

 To add and configure a Provider Web Part 

1. In the Solution Explorer window, right-click the ConnTest project, choose 
Add, and choose Add New Item… 

2. In the “Add New Item - ConnTest” dialog box, select “Provider Web Part 
Library” from “Local Project Items” with the following properties, then 
click OK.: 
a. Name: ProviderWebPart1 

3. A file named ProviderWebPart1.vb is created, added to your project, and 
opened in the Visual Studio editor. 

4. Change the namespace for this to "ConnTest".  Locate the attribute line 
above Public Class ProviderWebPart1, which begins with: 
<DefaultProperty( 
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and replace… 

XmlRoot(Namespace:="ProviderWebPart1") 
 

with (Visual Studio Snippet 1)… 

XmlRoot(Namespace:="ConnTest") 
 

 To add and configure a Consumer Web Part 

1. In the Solution Explorer window, right-click the ConnTest project, choose 
Add, then choose Add New Item… 

2. In the “Add New Item - ConnTest” dialog box, select “Consumer Web Part 
Library” from “Local Project Items” with the following properties, then 
click OK.: 
a. Name: ConsumerWebPart1 

3. A file named ConsumerWebPart1.vb is created, added to your project, and 
opened in the Visual Studio editor. 

4. Change the namespace for this to "ConnTest".  Locate the attribute line 
above Public Class ConsumerWebPart1, which begins with: 
<DefaultProperty( 
 

and replace… 

XmlRoot(Namespace:="ConsumerWebPart1") 
 

with (Visual Studio Snippet 1)… 

XmlRoot(Namespace:="ConnTest") 
 

5. From the File menu, click Save All. 
 

 



26  LAB PRT04: Developing Solutions on Microsoft® SharePoint® Products and Technologies 
 

 

Exercise 2  
Creating and Configuring Control Creation and Custom Rendering 
for the Provider Web Part 

We're going to keep the provider Web Part very simple.  It will consist of a 
single checkbox that will not fetch any data.  The state of this checkbox will be 
what we provide to any consumer Web Parts that wish to connect to this 
provider. 

 To add child controls to the Provider Web Part 

1. Open the code window for ProviderWebPart1.vb. 
2. Add a CheckBox to the declarations section inside the ProviderWebPart1 

class, immediately underneath the top of the class definition.  In other 
words, underneath: 
Implements ICellProvider 
 

 …insert the line (Visual Studio Snippet 2): 
Protected statusCheckBox As CheckBox 
 

 
 Remove the default Text custom property 

1. Delete the property procedure for the [Text] property, along with the 
attribute defined on the line above it.  Also delete the member variables 
meant to be used with the [Text] property.  In other words, delete the 
following: 
Private Const _defaultText As String = "" 
Dim _text As String = _defaultText 
 
<Browsable(True), Category("Miscellaneous"), 
DefaultValue(_defaultText), 
WebPartStorage(Storage.Personal), FriendlyName("Text"), 
Description("Text Property")> _ 
Property [Text]() As String 

Get 
Return _text 

End Get 
 

Set(ByVal Value As String) 
_text = Value 

End Set 
End Property 
 

 To override the CreateChildControls method  

In this procedure, you will override the CreateChildControls method to add 
a checkbox control to this Web Part's Controls collection.  You'll also define 
an event handler for the checkbox's Load event. 

1. Near the bottom of the module, directly above the RenderWebPart method, 
insert the following (Visual Studio Snippet 3):  
    Protected Overrides Sub CreateChildControls() 
        statusCheckBox = New CheckBox 
        AddHandler statusCheckBox.Load, _ 
         AddressOf statusCheckBox_Load 
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        Me.Controls.Add(Me.statusCheckBox) 
    End Sub 
 
    Protected Sub statusCheckBox_Load( _ 
    ByVal sender As Object, ByVal e As EventArgs) 
        statusCheckBox.Text = "Click me!" 
        statusCheckBox.AutoPostBack = True 
    End Sub 
 

The only part of this that's out of the ordinary is setting AutoPostBack to 
True for our checkbox control.  Since we're constructing a server-side 
connection, a postback is necessary, and setting AutoPostBack to True 
means that they will happen automatically when the user makes a change to 
the control.  Otherwise, we would have to intercept specific events and 
handle the postback manually. 

 To change the provider Web Part's RenderWebPart method: 

There's very little to do here other than ensure that our checkbox renders 
itself. 

1. Directly below the statusCheckBox_Load() method you have already 
written, type the following code to load the Orders DataGrid.  Replace the 
current RenderWebPart member function with the following (Visual Studio 
Snippet 4): 
    Protected Overrides Sub RenderWebPart( _ 
    ByVal output As System.Web.UI.HtmlTextWriter) 
        EnsureChildControls() 
        statusCheckBox.RenderControl(output) 
    End Sub 

 
From the File menu, click Save All. 

 



28  LAB PRT04: Developing Solutions on Microsoft® SharePoint® Products and Technologies 
 

 

Exercise 3 
Reviewing and Modifying the Provider Web Part 

The project template's default ProviderWebPart1 code already contains pretty 
much everything you need to provide one cell of data.  This is most of the 
heavy lifting that is required, so this exercise will primarily review the steps 
necessary to implement connections.  You will be making a few changes to the 
existing code, so do not skip this exercise.   

The Web Part-to-Web Part infrastructure calls methods of the Web Parts to 
discover the connectable Web Parts that are available on each page. It makes 
these connection options available to the user by populating menu items that are 
added to each connectable part.  

Most of the connection interfaces require you to declare event delegates. The 
Web Part infrastructure hooks these events to handlers in other Web Parts when 
a user creates a connection. The infrastructure calls a series of methods for each 
connectable Web Part while the page is being constructed, enabling provider 
Web Parts to communicate by firing events that get handled by the consumer 
Web Parts to which they are connected. To create an ICellProvider Web Part, 
you must override six methods. The sections below explain these tasks and 
show you where to make the one adjustment that sends the status of our custom 
checkbox to any registered consumer Web Parts. 

 Declare Cell Interface member variables 

1. Update the member variables to better describe the data we'll provide. 
replace… 

Dim Private _cellName As string = "Cell Data" 
 

With (Visual Studio Snippet 5)… 
Private cbxStatus As String = "CheckboxStatus" 
Private cbxStatDesc As String = "Checkbox Status" 

 

 Override the EnsureInterfaces method 

The EnsureInterfaces method provides notification to the Web Part that it 
should ensure that all its interfaces are registered using RegisterInterface. 

 Override CanRunAt method 

The CanRunAt method is called by the framework to determine whether a part 
thinks that it can be run on the client or server based on the current 
configuration.  In our case, we will be supporting only server-side connections.  
While this does involve a server round-trip, more often than not, if the 
consumer Web Part needs to call a Web service or perform a database query 
based on information provided to it from a connection, the server round trip 
would have been needed anyway. 

 Override the PartCommunicationConnect method 

The PartCommunicationConnect method provides notification to the Web Part 
that it has been connected. The framework uses this to inform a part that it is 
connected as soon as it connects up the appropriate events for the connection. 

 Override PartCommunicationInit method 
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At this time, a part should fire any events that end with 'Init' if they can. 

1. Update the PartCommunicationInit implementation to use our custom 
property. 

replace…. 
 

cellProviderInitArgs.FieldName = _cellName 
 
with (Visual Studio Snippet 6)… 
 

cellProviderInitArgs.FieldName = cbxStatus 
cellProviderInitArgs.FieldDisplayName = cbxStatDesc 

 
 Override PartCommunicationMain method 

At this time, a part can fire any events that it wants to.  Example: fire 
"CellReady" 

In our case, rather than sending along the value of a custom property, we want 
to provide specific text depending on whether our checkbox is checked.   

1. Change the data being sent through the cell we're providing. 
Replace… 

cellReadyArgs.Cell = Text 
 

with (Visual Studio Snippet 7)… 

cellReadyArgs.Cell = _ 
 IIf(statusCheckBox.Checked, "Checked", "Unchecked") 

 

 Save 

1. From the File menu, click Save All. 
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Exercise 4 
Reviewing and Modifying the Consumer Web Part 

Since the template-generated Consumer Web Part's code does most of the work 
you'll need for this lab, this exercise will primarily review the steps necessary to 
implement connections.  Some still require code, so don’t skip this exercise.   

To create an ICellConsumer Web Part, you must declare two events and 
override six methods. The sections below explain these tasks and present the 
sample code from ConsumerWebPart1. 

NOTE:  The consumer Web Part already renders the value of its Text property 
by default.  As such, its user interface needs no modification.  We simply need 
to make sure that data we receive via a connection is used to change our Text 
property. 

 Declare Cell Interface member variables 

1. Open the code window for ConsumerWebPart1.vb  
2. Update the member variables to better describe the data we want to 

consume. 
replace… 

    Private _cellName As String = "Cell Data"      'cell 
information 
 

With (Visual Studio Snippet 8)… 
    Private cbxStatus As String = "CheckboxStatus" 
    Private cbxStatDesc As String = "Checkbox Status" 

 

 Declare ICellConsumer Events 

The OrdersCellConsumer code declares two events that are required to 
implement the ICellConsumer interface – CellProviderInit and CellReady.   

For this particular Web Part, we will accept any data from any provider.  One 
could, however, add code to the CellProviderInit event to learn about the 
provider and the data it is prepared to provide, and take action accordingly. 

For the CellReady event, the default code already takes the string representation 
of the Cell being consumed and using it to set the value of the Text property. 

 Override the EnsureInterfaces method 

This is a notification to the Web Part that it should ensure that all its interfaces 
are registered using RegisterInterface.  It is here that we indicate that we are a 
Web Part connection consumer, and that we are ready to consume a Cell. 

 Override CanRunAt method 

This is called by the framework to determine whether a part thinks that it can be 
run on the client or server based on the current configuration.   This Web Part 
will use the default method of server-side communication only. 

 Override the PartCommunicationConnect method 
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This is a notification to the Web Part that it has been connected. The framework 
uses this to inform a part that it is connected as soon as it connects up the 
appropriate events for the connection. 

In this Web Part's case, we'll keep track of how many connections we are 
receiving.  In a real-world scenario, it would allow us to have the Web Part 
behave differently depending on whether it was being configured manually or 
whether it was receiving configuration data over a connection. 

 Override PartCommunicationInit method 

At this time, a part should fire any events that end with 'Init' if they can. 

1. Update the PartCommunicationInit implementation to use our custom 
information. 

replace…. 
 

'Set the FieldName 
cellConsumerInitArgs.FieldName = _cellName 

 
with… 
 

'Set the FieldName and FieldDisplayName 
'properties of the EventArgs object. 
'These values could be used by the provider part. 
cellConsumerInitArgs.FieldName = cbxStatus 
cellConsumerInitArgs.FieldDisplayName = cbxStatDesc 

 
 Override GetInitEventArgs method 

The GetInitArgs method is called by the Authoring environment for all the 
initial data required for creating a connection.  It is a virtual method on the 
WebPart base class which needs to be overridden by the developer.  The 
method returns the InitArgs object and takes in the interface name. 

1. Update the GetInitEventArgs implementation to use our custom 
information. 

replace…. 
 

'Set the FieldName 
cellConsumerInitArgs.FieldName = _cellName 

 
with (Visual Studio Snippet 9)… 
 

'Set the FieldName and FieldDisplayName 
'properties of the EventArgs object. 
'These values could be used by the provider part. 
cellConsumerInitArgs.FieldName = cbxStatus 
cellConsumerInitArgs.FieldDisplayName = cbxStatDesc 
 
 Create Event Handlers 

PartCommunicationNeedData, BeginDataRetrieval, and EndDataRetrieval 
are not needed for this Web Part because it doesn't have to do any 
Asynchronous data fetching.  The RowConsumerInit event handler will fire  
during its PartCommunicationInit phase.  If the connection was between a 
row provider and a cell consumer, this is where the provider Web Part could 
see what type of "row" the consumer was expecting and/or requesting.  
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 Save 

1. From the File menu, click Save All. 
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Exercise 5 
Building a Web Part Package 

In this exercise, you will create a Web Part Package to deploy your custom web 
parts. A Web Part package is a CAB file that contains the following items: 

• Manifest.xml 
• Web Part assemblies 
• Class resource files (optional) 
• DWP files 
 

 Adding and editing the DWP file for the Provider Web Part 

1. In the Solution Explorer window, right-click the ConnTest project, choose 
Add, then choose Add New Item… 

2. In the “Add New Item - ConnTest” dialog box, select “Web Part DWP” 
from “Local Project Items” with the following properties, then click OK.: 

• Name: ProviderWebPart1.dwp 
A file named ProviderWebPart1.dwp is created, added to your project, and 
opened in the Visual Studio editor. 
3. Replace the contents of this file with the following (Visual Studio Snippet 

10)… 
<?xml version="1.0" encoding="utf-8"?> 
<WebPart xmlns="http://schemas.microsoft.com/WebPart/v2" > 
 <Title>ConnTest Provider</Title> 
 <Description>Connection Test Provider.</Description> 
 <Assembly>ConnTest</Assembly> 
 <TypeName>ConnTest.ProviderWebPart1</TypeName> 
</WebPart> 

 

 Adding and editing the DWP file for the Consumer Web Part 

1. In the Solution Explorer window, right-click the ConnTest project, choose 
Add, then choose Add New Item… 

2. In the “Add New Item - ConnTest” dialog box, select “Web Part DWP” 
from “Local Project Items” with the following properties, then click OK.: 

• Name: ConsumerWebPart1.dwp 
A file named ConsumerWebPart1.dwp is created, added to your project, and 
opened in the Visual Studio editor. 
3. Replace the contents of this file with the following (Visual Studio Snippet 

11)… 
<?xml version="1.0" encoding="utf-8"?> 
<WebPart xmlns="http://schemas.microsoft.com/WebPart/v2" > 
 <Title>ConnTest Consumer</Title> 
 <Description>Connection Test Consumer.</Description> 
 <Assembly>ConnTest</Assembly> 
 <TypeName>ConnTest.ConsumerWebPart1</TypeName> 
</WebPart> 

 

 Modifying the Manifest file for a CAB 
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1. In the Solution Explorer window, open Manifest.xml by double-clicking on 

it. 
2. Replace the contents of this file with the following (Visual Studio Snippet 

12)… 
<?xml version="1.0"?> 
<WebPartManifest 
xmlns="http://schemas.microsoft.com/WebPart/v2/Manifest"> 
  <Assemblies> 
    <Assembly FileName="ConnTest.dll"> 
      <ClassResources> 
      </ClassResources> 
      <SafeControls> 
        <SafeControl 
          Namespace="ConnTest" 
          TypeName="*" 
        /> 
      </SafeControls> 
    </Assembly> 
  </Assemblies> 
  <DwpFiles> 
    <DwpFile FileName="ProviderWebPart1.dwp"/> 
    <DwpFile FileName="ConsumerWebPart1.dwp"/> 
  </DwpFiles> 
</WebPartManifest> 

  
 Create a CAB file using Visual Studio .NET 

1.  In the Solution Explorer window, open Manifest.xml by double-clicking on 
it. 

2.  Replace the contents of this file with the following (Visual Studio Snippet 
12)… 

3.  In the Solution Explorer window, select the ConnTest Solution (the top-
most item). 

4.  From the File menu, click Add Project, New Project 
5.  In the Add New Project dialog box, under Project Types, click Setup and 

Deployment Projects and select Cab Project. 

a. Name: ConnTestCab 

b. Location: C:\Documents and Settings\Jeff\My 
Documents\Visual Studio Projects\ConnTest 

c. Click OK. 
6. Replace the contents of this file with the following (Visual Studio Snippet 

12)… 
7. In the Solution Explorer window, select the ConnTest Solution (the top-

most item). 
8. From the File menu, click Add Project, New Project 
9. Add the Web Part project output to the CAB project. 

a. In the Solution Explorer, right-click on the CAB project. 
b. In the shortcut menu that appears, point to Add and then click Project 

Output. 
c. In the Add Project Output Group dialog box, ensure that you to 

select the correct project. 
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d. Select “Primary Output” and “Content Files” and then click OK. 

10. Build the solution.  The assembly is created and added to the CAB file 
along with the manifest and DWP file. 
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Exercise 6  
Deploying and Testing your Web Part 

In this exercise, you will deploy and test your Web Part.  Administrators can 
deploy CAB packages created by developers by using stssadm.exe. This tool is 
the command-line alternative to managing a Windows SharePoint Services 
computer. Three commands in the tool deal with Web Part package 
deployment: 

• AddWPPack 
• DeleteWPPack 
• EnumWPPacks 
 

To learn about a command in stsadm.exe, at the command prompt, type the 
following: 

stsadm –help command 

 Adding a Web Part Package 

1. Open a command prompt.   
2. Navigate to the “C:\Documents and Settings\Jeff\My Documents\Visual 

Studio Projects\ConnTest\ConnTestCab\Debug” directory 
3. We have already added the C:\Program Files\Common Files\Microsoft 

Shared\web server extensions\60\BIN directory to this computer's path, so 
you only need to type the following command (all on one line – do not cut 
and paste this command from this file) : 
stsadm –o addwppack –filename ConnTest.cab 
 

 Testing Web Part deployment 

1. Open an Internet Explorer browser session. 
2. Click My Site 
3. Near the top-right corner of the page, click “Modify My Page” and select 

“Add Web Parts  Browse” from the drop-down 
4. In the right pane, click the Virtual Server gallery and locate the “ConnTest 

Consumer” Web Part you created (you may have to click “next” a few times 
in the list of Web Parts) 

5. Drag and drop the ConnTest Provider Web Part onto to a zone on the page. 
6. Drag and drop the ConnTest Consumer Web Part onto to a zone on the 

page. 
7. Click on the down arrow in the title bar for the ConnTest Consumer web 

part and select Connections  Cell Consumer  ConnTest Provider.  The 
page refreshes and the ConnTest Consumer Web Part's text reads 
"Unchecked". 

8. Click the checkbox named "Click me!" in the ConnTest Provider Web Part.  
The page will refresh and the ConnTest Consumer Web Part's text changes 
from "Unchecked" to "Checked".  

 
Congratulations! You have now completed this lab. 
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