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Setting Up the Labs 
To work through the lab exercises, you must install: 

• Microsoft® Windows® 2000 or later 

• Microsoft Visual Studio® 2005 Beta 2 

• Microsoft Visual Studio 2005 Tools for the Microsoft Office System Beta 2 (included 
with Visual Studio 2005 Beta 2) 

• Microsoft Office Professional Edition 2003 

• Microsoft SQL Server™ 2000 (or higher) or MSDE with the Northwind database 

Note When applicable, instructions in the lab manuals refer to files by a full path; it 
is assumed that the download files are extracted to the root of C: drive. The files 
needed to complete the labs are in a folder named C:\VSTO2005\Files\Word. 



 

Lab 1 - Word Actions Pane 
The objective of this lab is to introduce you to creating a new Microsoft Word project 
with Visual Studio Tools for Office and to demonstrate working with an actions pane in 
Word. In this lab, you will create an actions pane for your Word solution and manage 
layout of controls contained in the actions pane.   

Estimated time to complete:  

o Exercise 1: Create an Actions Pane - 10 minutes  

Exercise 1: Create an Actions Pane 

Create a new Word Document project 

1. On the File menu, click New Project. 

2. In the list of Project Types, expand Visual Basic and click Office. 

3. Select Word Document in the Templates list. 

4. Type CustomerSurvey in the Name box. If you have a directory box, type 
“C:\VSTO2005\Labs” as the save to: directory. The New Project dialog box looks like 
Figure 1. 

 

Figure 1. Create a new Word Document project. 

5. Click OK. The Visual Studio Tools for Office Project Wizard appears. 

6. In the wizard, select Copy an existing document. 
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7. Click the Browse button. 

8. Navigate to C:\VSTO2005\Files\Word\Customer Satisfaction Survey.doc and 
click Open. 

9. In the Project wizard, click OK. You may receive the warning shown in Figure 2. 

 

Figure 2. Access to the VBA project system is disabled by default. 

 If you do receive the security message, click OK to allow access to the Microsoft 
Visual Basic® for Applications project system. You will only need to do this once. 

10. On the File menu, click Save All.  

11. If you didn’t have a directory box on step 4, then a save dialog will pop up. In the 
project Location box, type C:\VSTO2005\Labs and click Save. 

Add a user control to the Word actions pane 

1. In Solution Explorer, right-click the CustomerSurvey project, select Add on the 
context menu and then click Existing Item. The Add Existing Item dialog box 
appears. 

2. Navigate to select C:\VSTO2005\Files\Word\SubmitPane.vb and click Add. 

3. In Solution Explorer, right-click SubmitPane.vb and select View Designer on the 
context menu.  
The user control SubmitPane appears as shown in Figure 3. It is a simple user 
control with only a GroupBox, a Label and a Button. 

 

Figure 3. SubmitPane is ready to be added to the actions pane. 

4. In Solution Explorer, right-click SubmitPane.vb and click View Code on the 
context menu. 
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5. Add code to the SubmitPane class that will raise an event named OnSubmit when 
the Button is clicked and that exposes public write-only properties for setting the 
text of the Label and Button controls. Start by adding an Event statement to the 
SubmitPane class: 

Public Class SubmitPane 

 

    Public Event OnSubmit() 

 

End Class 

6. In the Class Name list at the top of the Code window, select btnSubmit. 

7. In the Method Name list at the top of the Code window, select Click. Visual Studio 
creates the procedure stub for the button’s Click event.  

8. Add code to raise the OnSubmit event: 

    Private Sub btnSubmit_Click(ByVal sender As Object, _ 

      ByVal e As System.EventArgs) Handles btnSubmit.Click 

        RaiseEvent OnSubmit() 

    End Sub 

9. Add code to define the Message and ButtonText properties: 

    Public WriteOnly Property Message() As String 

        Set(ByVal value As String) 

            Me.lblStatus.Text = value 

        End Set 

    End Property 

 

    Public WriteOnly Property ButtonText() As String 

        Set(ByVal value As String) 

            Me.btnSubmit.Text = value 

        End Set 

    End Property 

10. In Solution Explorer, right-click ThisDocument.vb and select View Code on the 
context menu. 

11. Add a private member variable to the ThisDocument class for an instance of the 
SubmitPane user control: 

Private WithEvents ucSubmitPane As SubmitPane 

12. In Solution Explorer, right-click ThisDocument.vb and select View Code. The 
code module for the document appears; observe that the document code-behind is 
encapsulated in a class named ThisDocument. 

13. Add a new private method named CreateActionsPane to the ThisDocument class 
that will add the SubmitPane control to the Word actions pane: 

Private Sub CreateActionsPane() 
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    Me.SmartDocument.SolutionID = "" 

 

    'Add a User Control to the actions pane 

    ucSubmitPane = New SubmitPane 

    Me.ActionsPane.Controls.Add(ucSubmitPane) 

 

End Sub 

14. Add a call to CreateActionsPane in the Startup event of the ThisDocument class: 

Private Sub ThisDocument_Startup(ByVal sender As Object, ByVal e As 

System.EventArgs) Handles Me.Startup 

    Me.CreateActionsPane() 

End Sub 

15. Add code to handle the OnSubmit event that is raised by the SubmitPane control 
when the button is clicked. To add the procedure stub automatically, select 
ucSubmitPane from the Class Name list, and select OnSubmit from the Method 
Name list.  

16. Add the following code to the procedure stub: 

Private Sub ucSubmitPane_OnSubmit() Handles ucSubmitPane.OnSubmit 

    MessageBox.Show("TO DO: Submit") 

End Sub 

Checkpoint 

1. On the File menu, click Save All. 

2. On the Debug menu, click Start to build and run the project. The document 
Customer Satisfaction Survey.doc opens in Microsoft Word. 

3. The actions pane now contains a SubmitPane user control, as shown in Figure 4. 

 

Figure 4. The actions pane with the SubmitPane user control. 
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4. Click the Submit button. You receive the message TO DO: Submit. 

5. Close the document without saving changes and exit Word. 
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Lab 2 - Controls in a Word Document 
The objective of this lab is to demonstrate the types of controls that you can use on a 
Word document surface and how you can handle document and control events.  

Estimated Time to Complete: 

o Exercise 1: Use a Bookmark Control and Handle Events – 15 minutes 

o Exercise 2: Use Windows Forms Controls – 15 minutes 

This lab uses the CustomerSurvey project you created in Lab 1.  

Exercise 1: Use a Bookmark Control and Handle Events 

Handle an event for a bookmark control in your document 

1. In Solution Explorer, right-click ThisDocument.vb and select View Designer on 
the context menu. 

2. On the View menu, click Properties Window. 

3. Click the drop-down arrow next to the list at the top of the Properties window (the 
Control list) to see the list of controls on the document; notice that several bookmark 
controls already exist (because the designer automatically created bookmark controls 
for bookmarks that existed in the original Customer Satisfaction Survey.doc when 
you created the project). 

4. Select bkMenu in the Control list of the Properties window to select the bookmark 
bkMenu. 

5. Double-click inside the bookmark bkMenu. The Code window for ThisDocument.vb 
is opened and the bkMenu_SelectionChange event is automatically created for 
you. 

6. Add the following code to bkMenu_SelectionChange to change the Word status 
bar text when the bookmark is selected: 

Private Sub bkMenu_SelectionChange(ByVal sender As System.Object, _ 

  ByVal e As Microsoft.Office.Tools.Word.SelectionEventArgs) _ 

  Handles bkMenu.SelectionChange 

    Me.Application.StatusBar = "Right-click for more options" 

End Sub 

 

Create a command bar during document initialization  

1. Add private member variables for CommandBar and CommandBar button references 
to the ThisDocument class: 

'Commandbar popup and commandbar controls 

Private cbPopup As Office.CommandBar 

Private cbctlPrevious As Office.CommandBarButton 

Private cbctlNext As Office.CommandBarButton 
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Private cbctlShowByCustID As Office.CommandBarButton 

Private cbctlShowAll As Office.CommandBarButton 

Private cbctlShowCompleted As Office.CommandBarButton 

2. Add a private method to the ThisDocument class named cbctlClick that will be 
called when any one of the command bar buttons on the custom popup is clicked: 

Private Sub cbctlClick(ByVal Ctrl As Office.CommandBarButton, _ 

  ByRef CancelDefault As Boolean) 

    MessageBox.Show("To do: " & Ctrl.Tag) 

End Sub 

3. Add a private method to the ThisDocument class named AddPopupButton that 
will be called to create command bar buttons and set up the event delegates for the 
buttons. 

Private Sub AddPopupButton(ByVal Caption As String, _ 

  ByVal Tag As String, ByRef Btn As Office.CommandBarButton) 

 

    'Add the button with the given Caption and Tag properties 

    Btn = cbPopup.Controls.Add(Office.MsoControlType.msoControlButton) 

    Btn.Caption = Caption 

    Btn.Tag = Tag 

 

    'Set up the event handler for the button when it is clicked 

    AddHandler Btn.Click, AddressOf Me.cbctlClick 

 

End Sub 

4. Add a private method to the ThisDocumentClass named AddPopupMenu that will 
create a popup command bar named “Survey Filter Popup”: 

Private Sub AddPopupMenu() 

 

    Try 

        'Set the customization context to the this document so that 

        'command bar changes are reflected in this document and not stored 

        'in Normal.dot (which is the default) 

        Me.Application.CustomizationContext = _ 

            Me.Application.ActiveDocument 

 

        'Add the commandbar to the document 

        cbPopup = Me.CommandBars.Add("Survey Filter Popup", _ 

            Office.MsoBarPosition.msoBarPopup, , True) 

 

        'Add commandbar buttons to the popup 

        Me.AddPopupButton("Previous Order", "MOVE_PREVIOUS", _ 

            cbctlPrevious) 
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        Me.AddPopupButton("Next Order", "MOVE_NEXT", cbctlNext) 

        Me.AddPopupButton("", "SHOW_BY_CUSTID", cbctlShowByCustID) 

        cbctlShowByCustID.BeginGroup = True 

        Me.AddPopupButton("Show Only Completed Surveys Ready to Submit", _ 

            "SHOW_COMPLETED", cbctlShowCompleted) 

        Me.AddPopupButton("Show All Orders", "SHOW_ALL", cbctlShowAll) 

 

    Catch ex As Exception 

        MessageBox.Show(ex.Message, "Error adding Survey Filter Popup") 

    End Try 

End Sub 

5. Append the following line of code to ThisDocument_Startup to call the 
AddPopupMenu method: 

Me.AddPopupMenu() 

Show a command bar popup when a bookmark is right-clicked 

1. In the Code window, select bkMenu in the Class Name list and click 
BeforeRightClick in the Method Name list. Notice that the corresponding event 
handler, bkMenu_BeforeRightClick, appears in the Code window. 

2. Add code to bkMenu_BeforeRightClick that will show the Survey Filter Popup 
CommandBar when the bookmark bkMenu is right-clicked: 

Private Sub bkMenu_BeforeRightClick(ByVal sender As Object, _ 

  ByVal e As Microsoft.Office.Tools.Word.ClickEventArgs) _ 

  Handles bkMenu.BeforeRightClick 

 

    'Update commandbar button properties based on the text of the 

    'current Customer ID 

    cbctlShowByCustID.Caption = "Show Only Orders for [TO DO]" 

 

    'Show the popup and then cancel the default action  

    cbPopup.ShowPopup() 

    e.Cancel = True 

 

End Sub 

Checkpoint 

1. On the File menu, click Save All. 

2. On the Debug menu, click Start to build and run the project. The document 
Customer Satisfaction Survey.doc opens in Microsoft Word. 

3. Click the document to place the insertion mark inside the bookmark bkMenu.  Note 
that the status bar text changes to Right-click for more options as shown in 
Figure 5. 



 

 

Figure 5. Click the bookmark to see the 
status message; right-click to see the popup menu. 

4. Right-click the bookmark bkMenu to display the Survey Filter Popup command 
bar. 

5. Click any one of the controls on the popup to display a message. 

6. Close the document without saving changes and exit Word. 

Exercise 2: Use Windows Forms Controls 

Add Windows Forms controls to your document 

Throughout this portion of the exercise, refer to Figure 6 for an illustration of how the 
controls should be positioned on the document. 
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Figure 6. The document looks like this when the controls have all been placed. 

1. In Solution Explorer, right-click ThisDocument.vb and select View Designer on 
the context menu. 

2. If the Toolbox window is not visible, then click Toolbox on the View menu. 

3. Select a NumericUpDown control and drag it to the last cell of the first row in the 
survey table.  

4. Select a CheckBox control and drag it to the last cell of the second row in the 
survey table. 

5. Select a CheckBox control and drag it to the last cell of the third row in the survey 
table. 

6. Select a NumericUpDown control and drag it to the last cell of the fourth row in the 
survey table.  

7. Select a CheckBox control and drag it to the last cell of the fifth row in the survey 
table. 

8. Set the properties for the Windows Forms controls on the document according to 
Table 1. 

Control Property Value 

NumericUpDown1 (Name) nupdnSalesRep 

 Maximum 5 

 Minimum 1 

 Value 5 

 Width 140 

CheckBox1 (Name) chkCourteous 

 Text No 

 14



 

 15

Control Property Value 

 Width 140 

CheckBox2 (Name) chkEfficiency 

 Text No 

 Width 140 

NumericUpDown2 (Name) nupdnOverall 

 Maximum 5 

 Minimum 1 

 Value 5 

 Width 140 

CheckBox3 (Name) chkSurveyed 

 Text Completed 

 Width 140 

Table 1. Use this table to set property values for each control. 

Initialize the Windows Forms controls on your document 

1. In Solution Explorer, right-click ThisDocument.vb and click View Code from the 
context menu. 

2. Add a private read-only property named NormalFont to the ThisDocument class 
that returns a Font similar to the Normal font in the document. You will use 
NormalFont to set the Font properties of the Windows Forms controls so that it 
resembles the Normal style font in the document. 

Private ReadOnly Property NormalFont() As System.Drawing.Font 

     Get 

         Dim ftNormal As Word.Font = Me.Styles("Normal").Font 

         Dim ft As System.Drawing.Font 

         ft = New Font(ftNormal.Name, ftNormal.Size, FontStyle.Regular) 

         Return ft 

     End Get 

End Property 

3. Append the following code to ThisDocument_Startup to initialize the controls 
fonts: 

'Format the controls fonts to match the Normal style 

Dim ft As System.Drawing.Font = Me.NormalFont 

Me.nupdnSalesRep.Font = ft 

Me.chkCourteous.Font = ft 

Me.chkEfficiency.Font = ft 

Me.nupdnOverall.Font = ft 

Me.chkSurveyed.Font = ft 
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4. In the Code window, select chkCourteous in the Class Name list and select 
CheckedChanged in the Method Name list.  

5. Add code to the chkCourteous_CheckedChanged event handler that will change 
the text of the control to Yes or No based on the current value: 

Private Sub chkCourteous_CheckedChanged(ByVal sender As Object, _ 

  ByVal e As System.EventArgs) Handles chkCourteous.CheckedChanged 

    If chkCourteous.Checked Then 

        chkCourteous.Text = "Yes" 

    Else 

        chkCourteous.Text = "No" 

    End If 

End Sub 

6. Use the same technique to create a similar event handler for the CheckChanged 
event of the chkEfficiency check box control: 

Private Sub chkEfficiency_CheckedChanged(ByVal sender As Object, _ 

  ByVal e As System.EventArgs) Handles chkEfficiency.CheckedChanged 

    If chkEfficiency.Checked Then 

        chkEfficiency.Text = "Yes" 

    Else 

        chkEfficiency.Text = "No" 

    End If 

End Sub 

Checkpoint 

1. On the File menu, click Save All. 

2. On the Debug menu, click Start to build and run the project. The document 
Customer Satisfaction Survey.doc opens in Word. 

3. The Windows Forms controls appear on the document as illustrated in Figure 7. 



 

 

Figure 7. The Word document now includes Windows Form controls. 

4. Click one of the check boxes and note that the text changes to match the state of 
the check box. 

5. Make different choices in one of the drop-down lists. 

6. Close the document without saving changes and exit Word. 
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Lab 3 - Data in a Word Document 
The objective of this lab is to illustrate how you can work with data in a Word document. 
In this lab, you will connect to a SQL Server data source, bind bookmarks and Windows 
Forms controls to database objects and navigate records in the data source. 

Estimated time to complete: 

o Exercise 1: Set Up a Connection and Add a Data Source – 10 minutes 

o Exercise 2: Connect, Bind and Navigate Data – 30 minutes 

o Exercise 3: Filter Data – 10 minutes 

o Exercise 4: Insert and Update Data – 10 minutes 

This lab uses the CustomerSurvey project you created in Lab 2. 

Exercise 1: Set Up a Connection and Add a Data Source 
This lab uses data in the Northwind sample database included with SQL Server 2000.   

You will use a SQL batch procedure to a new table named Surveys to the Northwind 
sample database and create a new row in each table with an OrderID and CustomerID 
that matches the first 100 records in the Orders table. The design of the Surveys table 
is as follows: 

Field SQL Data 
Type 

Description 

OrderID Int OrderID corresponding to an OrderID in the Orders table 

CustomerID Nchar(5) CustomerID corresponding to the order in the Orders table 

RateSalesRep smallint Satisfaction rating from 0-5 for the sales representative 

RateCourteous Bit Rating 0 (no) or (1) yes for courtesy 

RateEfficiency Bit Rating 0 (no) or (1) yes for efficiency 

RateOverall smallint Satisfaction rating from 0-5 for overall service 

RateFrequency smallint Rating from 0-5 regarding frequency of service 

Survey Bit 1 if the survey is complete, otherwise 0 

Run the SQL batch procedure 

1. On the Windows Start menu, click Run. Type cmd and click OK. A Command 
Window opens. 

2. Change to the folder where the lab files reside: 

cd C:\VSTO2005\Files\Word 

3. Execute the batch procedure: 

osql.exe –n -E -i survey.sql 

You will receive the message 100 row(s) affected. 

4. Close the Command window. 



 

Add a data source to your project 

1. On the Data menu, click Show Data Sources. The Data Source window appears. 

2. Click Add New Data Source in the Data Source window.  The Data Source 
Configuration window appears. 

3. Select Database for the data source type and click Next. 

4. Click New Connection. If you have not created a data connection before, the 
Choose Data Source dialog box appears. If you have created a data connection, 
you see the Add Connection dialog box shown in Figure 10 instead and you can 
skip to step 8. 

5. The Choose Data Source dialog box appears. 

6. In the Choose Data Source dialog box, select Microsoft SQL Server, as shown in 
Figure 8. 

 

Figure 8. The Microsoft SQL Server data source 
is used for Microsoft SQL Server 7.0 and up. 

7. Click Continue. You see the Add Connection dialog box shown in Figure 9. 
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Figure 9. Use the Add Connection dialog box 
to build and test the data source connection. 

8. Type (local) in the Server name dropdown list, or select the name of your server 
from the list. Once you have made this selection, the Connect to a database 
section will become active. 

9. In the Log on to the server section, select the Use Windows Authentication 
option button.  

10. In the Select or enter a database name dropdown list, choose Northwind. 

11. Click Test Connection. If you do not receive the confirmation message shown in 
Figure 10, return to the Add Connection dialog box and verify that the selections 
you made are appropriate for your server. 
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Figure 10. Once appropriate selections are made, 
the test connection will succeed. 

12. Click OK to close the message box, and click OK to close the Add Connection 
dialog box. The Data Source Configuration Wizard now includes the connection you 
just created, as shown in Figure 11. 

 

Figure 11. The name of your server (holbpr in the example) 
precedes the name of the database. 

13. Click Next. You see the next step of the Wizard as shown in Figure 12. 
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Figure 12. Save the connection using the 
default name, NorthwindConnectionString. 

14. Leave the Yes, save the connection as checkbox selected and click Next. You see 
the Choose your database objects page of the Wizard, as shown in Figure 13. 

 

Figure 13. You can use this page to select 
which objects you need for your application. 
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15. Expand Tables in the list of database objects.  

16. Select the Customers and Surveys tables. 

17. Click Finish.  

Configure the data source 

1. In the Data Sources window, select NorthwindDataSet and click the Edit 
DataSet with Designer button at the top of the Data Sources window. 

2. Right-click the Surveys table in the designer window and select Configure from the 
context menu. The Data Component Configuration Wizard appears. 

3. Append a WHERE clause to the SQL statement so that newly filled DataSets will 
contain only records where the Surveyed field is 0. 

SELECT OrderID, CustomerID, RateSalesRep, RateCourteous, RateEfficiency,  

       RateOverall, RateFrequency, Surveyed  

FROM   dbo.Surveys 

WHERE  Surveyed=0 

 The completed dialog box looks like Figure 14. 

 

Figure 14. You only need to add the WHERE clause to the SQL statement. 

4. Click Finish. 

Add a relation to the data source 

1. On the Data menu, select Add and choose Relation. The Relation dialog box 
appears. 
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2. Specify the following for the new relation: 

• Name is FK_Survey_Customers 

• Parent Table is Surveys 

• Child Table is Customers 

• PK Fields is CustomerID 

• FK Fields is CustomerID 

When complete, the Relation dialog box looks like Figure 15. 

 

Figure 15. The Relation dialog box is used 
to create a link between Customers and Surveys. 

3. Click OK to add the new relation.  

4. The Data Source window appears as illustrated in Figure 16 below. 
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Figure 16. The relation between the two tables is now 
defined and shown visually in the Data Source window. 

5. On the File menu, select Save All to save your changes. 

Exercise 2: Connect, Bind and Navigate to Data 

Bind a bookmark to a field in the Orders table (the parent table) 

1. In Solution Explorer, right-click ThisDocument.vb and select View Designer on 
the context menu. 

2. In the Data Sources window, expand Surveys. 

3. Select OrderID under Surveys and drag it onto the bookmark bkOrderID in the 
table.  
 
Note: The bookmark bkOrderID is now bound to the SurveysBindingSource.  The 
SurveysBindingSource control is automatically added to the component tray by 
the designer when the OrderID field is dragged to the bookmark. 

Bind the Windows Forms controls on the document to fields in 
SurveysBindingSource 

1. Select the nupdnSalesRep control in the document. 

2. In the Properties window, expand the DataBindings property and select the 
(Advanced) property. 

3. Click the ellipsis (…) next to the (Advanced) property. You see the Formatting 
and Advanced Binding dialog box shown in Figure 17. 
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Figure 17. Use the Formatting and Advanced Binding 
dialog box to bind the controls to the fields in the data source. 

4. In the Property list, select Value. 

5. Drop down the Binding list.  

6. Expand SurveysBindingSource and select RateSalesRep. 

7.  Click OK. 

8. Repeat steps 1 through 7 for the other controls in the document. Use Table 2 to see 
which property and field to bind for each control. 

Control Property to Bind Field to Bind  

nupdnSalesRep Value SurveysBindingSource - RateSalesRep 

chkCourteous Checked SurveysBindingSource - RateCourteous 

chkEfficiency Checked SurveysBindingSource - RateEfficiency 

nupdnOverall Value SurveysBindingSource - RateOverall 

chkSurveyed Checked SurveysBindingSource - Surveyed 

Table 2. Binding instructions for each control. 

Bind controls to fields in the Customers table (the child table) using the foreign 
key 

1. In the Data Sources window, expand Customers. 

2. Select CustomerID under Customers and drag it onto the bookmark 
bkCustomerID in the document.  

 26



 

 27

 
Note: The bookmark bkCustomerID is now bound to the 
CustomersBindingSource. The CustomersBindingSource control is automatically 
added to the component tray by the designer when you drag the CustomerID field 
from the Data Sources window. 

3. Select CompanyName under Customers and drag it onto the bookmark 
bkCompanyName in the document. 

4. Select ContactName under Customers and drag it onto the bookmark 
bkContactName in the document. 

5. Select Phone under Customers and drag it onto the bookmark bkPhone in the 
document. 

6. Select CustomersBindingSource in the component tray.  

7. Change the DataSource property to SurveysBindingSource. 

8. Change the DataMember property to FK_Survey_Customers. 

9. In Solution Explorer, right-click ThisDocument.vb and select View Code on the 
context menu. 

10. Delete the lines of code that the designer added to ThisDocument_Startup to 
automatically fill the table adapters: 

'TODO: Delete this line of code to remove the default AutoFill for  

'NorthwindDataSet.Customers'. 

If Me.NeedsFill("NorthwindDataSet") Then 

    Me.CustomersTableAdapter.Fill(Me.NorthwindDataSet.Customers) 

End If 

'TODO: Delete this line of code to remove the default AutoFill for 

'NorthwindDataSet.Surveys'. 

If Me.NeedsFill("NorthwindDataSet") Then 

     Me.SurveysTableAdapter.Fill(Me.NorthwindDataSet.Surveys) 

End If 

And add a new private member to the ThisDocument class named GetSurveys: 

Private Sub GetSurveys() 

     Me.CustomersTableAdapter.Fill(Me.NorthwindDataSet.Customers) 

     Me.SurveysTableAdapter.Fill(Me.NorthwindDataSet.Surveys) 

End Sub 

11. Append a call to GetSurveys to ThisDocument_Startup: 

Private Sub ThisDocument_Startup(ByVal sender As Object, _ 

 ByVal e As System.EventArgs) Handles Me.Startup 

    Me.CreateActionsPane() 

    Me.AddPopupMenu() 

    'Format the controls fonts to match the Normal style 

    Dim ft As System.Drawing.Font = Me.NormalFont 

    Me.nupdnSalesRep.Font = ft 
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    Me.chkCourteous.Font = ft 

    Me.chkEfficiency.Font = ft 

    Me.nupdnOverall.Font = ft 

    Me.chkSurveyed.Font = ft 

 

    Me.GetSurveys() 

End Sub 

Checkpoint 

1. On the File menu, click Save All. 

2. On the Debug menu, click Start to build and run the project. The document 
Customer Satisfaction Survey.doc opens in Microsoft Word. 

3. Notice that the values in the first record of the data source (Order 10248 for VINET) 
appear in the bookmark controls and Windows Forms controls as illustrated in 
Figure 18. 

 

Figure 18. The document now includes data bound controls. 

4. Close the document without saving changes and exit Word. 

Navigate records in the view 

1. Replace the code in cbctlClick with the following code which will execute 
MovePrevious or MoveNext on the DataConnector based on the command bar 
button that triggered the event: 

Private Sub cbctlClick(ByVal Ctrl As Office.CommandBarButton, _ 

    ByRef CancelDefault As Boolean) 
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    Me.Application.ScreenUpdating = False 

 

    Try 

        'Perform action based on the tag of the button  

        'that was clicked.  

        Select Case Ctrl.Tag 

            Case "MOVE_PREVIOUS" 

                Me.SurveysBindingSource.MovePrevious() 

            Case "MOVE_NEXT" 

                Me.SurveysBindingSource.MoveNext() 

        End Select 

    Catch ex As Exception 

        MessageBox.Show(ex.Message) 

    Finally 

        Me.Application.ScreenUpdating = True 

    End Try 

 

End Sub 

2. Modify bkMenu_BeforeRightClick to enable/disable the navigation command bar 
buttons based on the current position in the view: 

Private Sub bkMenu_BeforeRightClick(ByVal sender As Object, _ 

    ByVal e As Microsoft.Office.Tools.Word.ClickEventArgs) _ 

    Handles bkMenu.BeforeRightClick 

 

    'Update commandbar button properties based on the text of the 

    'current Customer ID and the current position in the data source 

    cbctlShowByCustID.Caption = _ 

        "Show Only Orders for " & Me.bkCustomerID.Text 

    Dim nPos As Int16 = Me.SurveysBindingSource.Position 

    cbctlPrevious.Enabled = (nPos > 0) 

    cbctlNext.Enabled = ( _ 

        nPos + 1 < Me.SurveysBindingSource.Count) 

 

    'Show the popup and then cancel the default action  

    cbPopup.ShowPopup() 

    e.Cancel = True 

 

End Sub 
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Display the current position and record count in the view 

1. Add a private method to the ThisDocument class named UpdatePane that will 
update the label in the SubmitPane control (in the actions pane) to display the 
current position and record count in the view: 

Private Sub UpdatePane() 

 

    'Update the SubmitPane control to display the current position in 

    'the data source and the count of records in the data source 

    If Not (Me.ucSubmitPane Is Nothing) Then 

        Dim sCaption As String 

        Dim nCurrentRecord As Int16 = Me.SurveysBindingSource.Position + 1 

        Dim nRecords As Int16 = Me.SurveysBindingSource.Count 

        sCaption = nCurrentRecord & " of " & nRecords 

        Me.ucSubmitPane.Message = sCaption 

    End If 

 

End Sub 

2. In the Class Name list, select SurveysBindingSource.  

3. In the Method Name list, select ListChanged.  

4. Add code to SurveysBindingSource_ListChanged that will update the window 
caption when the list changes: 

Private Sub SurveysBindingSource_ListChanged(ByVal sender As Object, _ 

 ByVal e As System.ComponentModel.ListChangedEventArgs) _ 

 Handles SurveysBindingSource.ListChanged 

    Me.UpdatePane() 

End Sub 

5. In the Method Name list, select PositionChanged. 

6. Add code to SurveysBindingSource_PositionChanged that will update the 
window caption when the position within the existing list changes: 

Private Sub SurveysBindingSource_PositionChanged(ByVal sender As Object, _ 

 ByVal e As System.EventArgs) _ 

 Handles SurveysBindingSource.PositionChanged 

    Me.UpdatePane() 

End Sub 

Checkpoint 

1. On the File menu, click Save All. 

2. On the Debug menu, click Start to build and run the project. The document 
Customer Satisfaction Survey.doc opens in Word. Notice that the actions pane 
displays the current position in the data source (1 of 100) and that the first order in 
the view is for Order 10248.  
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3. Fill out the controls in the survey. 

Note: In the following steps, you may see a redraw problem (for the Beta 2 build), if 
the controls in the table seem to overlap or duplicate, you can fix this problem by 
moving the page slider down and then back up to force a window redraw. 

4. Right-click the bookmark bkMenu.  

5. Select Next Order on the popup menu to move to the next record in the data 
source. Notice that the actions pane changes to reflect the current position in the 
data source (2 of 100) and that the Order 10249 now appears in the view. 

6. Right-click the bookmark bkMenu.  

7. Select Previous Order on the popup menu to move back to the first record in the 
data source. 

8. Notice that your survey selections (stored in the in-memory dataset, not in the 
actual data source) are restored in the view for Order 10248. 

9. Close the document without saving changes and exit Microsoft Word. 

Exercise 3: Filter Data  

Filter data in your data source 

1. In Solution Explorer, right-click ThisDocument.vb and select View Code from 
the context menu. 

2. Insert three additional cases to the Select Case in cbctlClick that will filter the data 
source to show all data, show data only for a given customer or show data only for 
completed surveys: 

Private Sub cbctlClick(ByVal Ctrl As Office.CommandBarButton, _ 

    ByRef CancelDefault As Boolean) 

 

    Me.Application.ScreenUpdating = False 

 

    Try 

        'Perform action based on the tag of the button  

        'that was clicked.  

        Select Case Ctrl.Tag 

            Case "MOVE_PREVIOUS" 

                Me.SurveysBindingSource.MovePrevious() 

            Case "MOVE_NEXT" 

                Me.SurveysBindingSource.MoveNext() 

            Case "SHOW_ALL" 

                Me.SurveysBindingSource.EndEdit() 

                Me.SurveysBindingSource.RemoveFilter() 

            Case "SHOW_BY_CUSTID" 

                Me.SurveysBindingSource.EndEdit() 

                Me.SurveysBindingSource.Filter = _ 
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                    String.Format(" CustomerID = '{0}' ", Me.bkCustomerID.Text) 

            Case "SHOW_COMPLETED" 

                Me.SurveysBindingSource.EndEdit() 

                Me.SurveysBindingSource.Filter = "Surveyed=1" 

        End Select 

    Catch ex As Exception 

        MessageBox.Show(ex.Message) 

    Finally 

        Me.Application.ScreenUpdating = True 

    End Try 

 

End Sub 

Checkpoint 

1. On the File menu, click Save All. 

2. On the Debug menu, click Start to build and run the project. The document 
Customer Satisfaction Survey.doc opens in Word. 

3. Observe the actions pane; currently, the view contains 100 records in the table and 
you are viewing record 1. 

4. Right-click the bookmark bkMenu and select Show Only Orders for VINET on the 
context menu. 

5. Observe the actions pane message which indicates that the view now represents only 
the 3 records in the Surveys table associated with the Customer ID VINET. 

6. Right-click the bookmark bkMenu and select Previous Order or Next Order to 
navigate the records for VINET. 

7. Right-click the bookmark bkMenu and select Show All Orders to show all records. 

8. Complete questionnaires for one or more records. Once you have completed a 
survey for a record, check Completed. 

9. Right-click the bookmark bkMenu and select Show Only Completed Surveys 
Ready to Submit to display only those surveys that you have marked as completed. 

10. Close the document without saving changes and exit Word. 

Exercise 4: Insert and Update Data 

Update data 

1. In Solution Explorer, right-click ThisDocument.vb and select View Code on the 
context menu. 

2. Replace the code in the OnSubmit event that is raised by the SubmitPane control 
when the button is clicked that will update the survey data in the database: 

Private Sub ucSubmitPane_OnSubmit() Handles ucSubmitPane.OnSubmit 

 

    'End the current edit 
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    Me.SurveysBindingSource.EndEdit() 

 

    'Select those rows that have the Surveyed field set to 1 

    Dim rows() As CustomerSurvey.NorthwindDataSet.SurveysRow 

    rows = Me.northwindDataSet.Surveys.Select("Surveyed=1") 

 

    'If there is at least one row selected, then proceed to update 

    'the database; otherwise, display a message 

    If rows.Length > 0 Then 

        Try 

            Dim nCount As Int16 

 

            'Perform the update and display a message about the 

            'rows affected 

            nCount = Me.surveysTableAdapter.Update(rows) 

            MessageBox.Show(nCount & " survey(s) have been submitted.") 

            GetSurveys() 

        Catch ex As Exception 

            MessageBox.Show(ex.Message, "Error updating records") 

        End Try 

    Else 

        MessageBox.Show("None of the records have been marked as " & _ 

            "complete. No updates to the database have been made.") 

    End If 

 

End Sub 

Checkpoint 

1. On the File menu, click Save All. 

2. On the Debug menu, click Start to build and run the project. The document 
Customer Satisfaction Survey.doc opens in Word. 

3. Complete the survey for Order 10248 (VINET). 

4. Click Submit in the actions pane.  You receive a message that 1 survey(s) have 
been submitted and the next record appears. 

5. Complete the survey for Order 10249 (TOMSP) but do not submit the survey yet.  

6. Right-click the bookmark bkMenu and select Next Order on the context menu to 
show the next record. 

7. Complete the survey for Order 10250 (HANAR). 

8. Click Submit. You receive a message that 2 survey(s) have been submitted. 

9. Close the document without saving changes and exit Word. 
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Lab 4 - Data Caching in a Word Document 
This lab illustrates how you can cache data in a Word document for offline use. Once 
data is cached in a document, you will read and write to the document’s data cache. 

Estimated time to complete: 

o Exercise 1: Cache Data in a Word Document – 20 minutes 

 

This lab uses the CustomerSurvey project you created in Lab 3.  

Exercise 1: Cache Data in a Word Document 

Add a cached dataset to the document 

1. In Solution Explorer, right-click ThisDocument.vb and select View Code on the 
context menu. 

2. Add a public variable to the ThisDocument class to store the DataSet in the 
document cache: 

<Cached()> Public dsCached As CustomerSurvey.NorthwindDataSet 

3. Add a private member variable to the ThisDocument class that you will use to 
indicate whether or not you are using a cached dataset: 

Private bCached As Boolean 

4. Add code to ThisDocument_BeforeSave that will cache the data when the 
document is saved: 

Private Sub ThisDocument_BeforeSave(ByVal sender As Object, _ 

  ByVal e As Microsoft.Office.Tools.Word.Document.SaveEventArgs) _ 

  Handles Me.BeforeSave 

    Me.SurveysBindingSource.EndEdit() 

    Me.NorthwindDataSet.AcceptChanges() 

    dsCached = Me.NorthwindDataSet 

End Sub 

5. Replace the code in the GetSurveys member so that it will use data from the cache 
when it is present in the document: 

Private Sub GetSurveys() 

    bCached = Not (dsCached Is Nothing) 

 

    Try 

        Me.Application.ScreenUpdating = False 

        If Not bCached Then 

            'If there is no data cached in this document, then fill  

            'the dataset from the live data source. 

            Me.CustomersTableAdapter.Fill(Me.NorthwindDataSet.Customers) 

            Me.SurveysTableAdapter.Fill(Me.NorthwindDataSet.Surveys) 
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        Else 

            'Load the dataset from the cache             

            Me.NorthwindDataSet = dsCached 

            Me.NorthwindDataSet.AcceptChanges() 

        End If 

        'Set up the data connectors. 

        Me.SurveysBindingSource.DataMember = "Surveys" 

        Me.SurveysBindingSource.DataSource = Me.NorthwindDataSet 

        Me.CustomersBindingSource.DataMember = "FK_Survey_Customers" 

        Me.CustomersBindingSource.DataSource = Me.SurveysBindingSource 

        Me.Application.ScreenUpdating = True 

    Catch ex As Exception 

        Me.Application.ScreenUpdating = True 

        MessageBox.Show(ex.Message, "Error retrieving data") 

    End Try 

 

End Sub 

6. Modify the UpdatePane member so that, when the view represents cached data, 
the SubmitPane will have a message containing the text “[Cached]” and the button 
will display the text “Connect and Submit”: 

Private Sub UpdatePane() 

 

    'Update the SubmitPane control to display the current position in 

    'the data source and the count of records in the data source 

    If Not (Me.ucSubmitPane Is Nothing) Then 

        Dim sCaption As String 

        Dim nCurrentRecord As Int16 = Me.SurveysBindingSource.Position + 1 

        Dim nRecords As Int16 = Me.SurveysBindingSource.Count 

        sCaption = nCurrentRecord & " of " & nRecords 

        If bCached Then sCaption &= vbCrLf & "[Cached]" 

        Me.ucSubmitPane.Message = sCaption 

        If bCached Then  

           Me.ucSubmitPane.ButtonText = "Connect and Submit" 

        Else 

           Me.ucSubmitPane.ButtonText = " Submit" 

        End If 

    End If 

 

End Sub 

7. Add a new private member named UpdateCachedData to the ThisDocument class 
that will handle updating data from the cached dataset: 

    Private Function UpdateCachedData( _ 
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      ByVal rows() As CustomerSurvey.NorthwindDataSet.SurveysRow) As Int16 

 

        'Connect to the data source 

        Dim cn As New _ 

         SqlClient.SqlConnection(My.Settings.NorthwindConnectionString) 

 

        ' Create the UpdateCommand and parameters 

        Dim cmd As SqlClient.SqlCommand = New SqlClient.SqlCommand( _ 

          "UPDATE [Surveys] " & _ 

          "SET    [RateSalesRep]=@RateSalesRep, [RateCourteous]=" & _ 

          "@RateCourteous, [RateEfficiency]=@RateEfficiency, " & _ 

          "[RateOverall]=@RateOverall, " & _ 

          "[Surveyed]=1 WHERE  OrderID=@OrderID and CustomerID=@CustomerID", _ 

          cn) 

        cmd.Parameters.Add("@OrderID", SqlDbType.Int, 0, "OrderID") 

        cmd.Parameters.Add("@CustomerID", SqlDbType.NChar, 5, "CustomerID") 

        cmd.Parameters.Add("@RateSalesRep", SqlDbType.Int, 0, "RateSalesRep") 

        cmd.Parameters.Add("@RateCourteous", SqlDbType.Bit, 0, "RateCourteous") 

        cmd.Parameters.Add("@RateEfficiency", SqlDbType.Bit, 0, _ 

          "RateEfficiency") 

        cmd.Parameters.Add("@RateOverall", SqlDbType.Int, 0, "RateOverall") 

        cmd.Parameters.Add("@Surveyed", SqlDbType.Bit, 0, "Surveyed") 

        Dim da As SqlClient.SqlDataAdapter = New SqlClient.SqlDataAdapter(cmd) 

        da.UpdateCommand = cmd 

 

        'Execute the update  

        Dim nCount As Int16 

        ncount = da.Update(rows) 

 

        'Close the connection 

        cn.Close() 

 

        'Return the rows affected 

        Return nCount 

 

    End Function 

8. Modify the OnSubmit event of the SubmitPane control to handle updates 
originating from the cached dataset: 

Private Sub ucSubmitPane_OnSubmit() Handles ucSubmitPane.OnSubmit 

 

    'End the current edit 

    Me.SurveysBindingSource.EndEdit() 
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    'Select those rows that have the Surveyed field set to 1 

    Dim rows() As CustomerSurvey.NorthwindDataSet.SurveysRow 

    rows = Me.northwindDataSet.Surveys.Select("Surveyed=1") 

 

    'If there is at least one row selected, then proceed to update 

    'the database; otherwise, throw a message 

    If rows.Length > 0 Then 

        Try 

            Dim nCount As Int16 

            If Not bCached Then 

                'Perform the update and display a message about the 

                'rows affected 

                nCount = Me.surveysTableAdapter.Update(rows) 

                MessageBox.Show(nCount & " survey(s) have been submitted.") 

                GetSurveys() 

            Else 

                nCount = Me.UpdateCachedData(rows) 

                MessageBox.Show(nCount & " survey(s) have been submitted.") 

                dsCached.Clear() 

                dsCached = Nothing 

                GetSurveys() 

            End If 

        Catch ex As Exception 

            MessageBox.Show(ex.Message, "Error updating records") 

        End Try 

    Else 

        MessageBox.Show("None of the records have been marked as " & _ 

            "complete. No updates to the database have been made.") 

    End If 

 

End Sub 

Checkpoint 

1. On the File menu, click Save All. 

2. On the Debug menu, click Start to build and run the project. The document 
Customer Satisfaction Survey.doc opens in Word. 

3. Currently the data source represents 97 survey records and the current record is 
Order 10251 for VICTE. 

4. Complete the surveys for Orders 10251 and 10252 (but do not submit them). 

5. On the File menu, click Save As. The Save As dialog box appears. 



 

6. Type C:\VSTO2005\Labs\CustomerSurvey\CustomerSurvey\bin\Cached.doc 
in the File Name box and click Save. 

7. Close Cached.doc. 

8. Open Cached.doc. 

9. Observe that the actions pane indicates that you are viewing cached data as 
illustrated in Figure 19. Also notice that the survey selections you made for Orders 
10251 and 10252 have been restored. 

 

Figure 19. The actions pane shows that you are working with cached data. 

10. Move to Order 10253 and complete the survey. 

11. Click Connect and Submit in the actions pane. You receive a message that 3 
survey(s) have been submitted.  Once the surveys are submitted, the actions 
pane indicates that you are now working with the live data and not the cached data. 
There are now 94 uncompleted surveys in the view. 

12. In preparation for the next exercise, select Save from the File menu to save 
Cached.doc. 

13. Close the document and exit Word. 

 38


	Setting Up the Labs
	Lab 1 - Word Actions Pane
	Exercise 1: Create an Actions Pane
	Create a new Word Document project
	Add a user control to the Word actions pane
	Checkpoint




	Lab 2 - Controls in a Word Document
	Exercise 1: Use a Bookmark Control and Handle Events
	Handle an event for a bookmark control in your document
	Create a command bar during document initialization
	Show a command bar popup when a bookmark is right-clicked
	Checkpoint

	Exercise 2: Use Windows Forms Controls
	Add Windows Forms controls to your document
	Initialize the Windows Forms controls on your document
	Checkpoint





	Lab 3 - Data in a Word Document
	Exercise 1: Set Up a Connection and Add a Data Source
	Run the SQL batch procedure
	Add a data source to your project
	Configure the data source
	Add a relation to the data source

	Exercise 2: Connect, Bind and Navigate to Data
	Bind a bookmark to a field in the Orders table (the parent t
	Bind the Windows Forms controls on the document to fields in
	Bind controls to fields in the Customers table (the child ta
	Checkpoint
	Display the current position and record count in the view
	Checkpoint

	Exercise 3: Filter Data
	Filter data in your data source
	Checkpoint

	Exercise 4: Insert and Update Data
	Update data
	Checkpoint





	Lab 4 - Data Caching in a Word Document
	Exercise 1: Cache Data in a Word Document
	Add a cached dataset to the document
	Checkpoint




