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ARC04: Build a Domain Specific Language Designer Using the 
DSL Tools for Microsoft Visual Studio 2005 

Requirements 
 
In order to complete this walkthrough you will need an installation of  

• Microsoft® Visual Studio® 2005 Beta 2 
• Visual Studio 2005 SDK 2005 Beta 2 
• DSL Tools Version “May 2005” for Visual Studio 2005 Beta 2 

Microsoft Word is also recommended so that you can view this document electronically while carrying 
out the lab.  
 
Instructor Notes:  
• As the product is still in the beta stage of production, many features of the product have been 

partially implemented or not implemented at all.  While this lab has been designed to address the 
features that are currently implemented, minor glitches may arise due to the pre-production nature 
of the software.  Be prepared to inform students that this lab is simply a technology preview and is 
not reflective of the final product in terms of feature-set or stability. 

Lab Objective     

Estimated time to complete this lab: 45 minutes 
 

For the purpose of this walkthrough, you will use the Domain Specific Language Tools for Visual Studio 
2005 to build a graphical designer integrated into Visual Studio for your own domain specific language. 
The Domain Specific Language Tools ship as a separate download for Visual Studio. The DSL Tools 
are an SDK that allows you to use Microsoft’s generic modeling platform to build visual modeling tools 
that run inside of Visual Studio. The SDK contains code generation tools that will generate a running 
designer based on an XML description.  
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Exercise – Build a Domain Specific Language Designer Using the DSL 
Tools for Microsoft Visual Studio 2005 
 
This hands-on lab explores how the Microsoft DSL Tools for Visual Studio 2005 can be used to build a 
visual designer with code generation. In this lab, you will learn more about the files that are used to 
define the concepts and notation for a Domain Specific Language, and the process that takes these 
files and generates a complete Visual Studio designer for that language.  You will learn some of the 
options for defining different aspects of the concepts and notation, and how the notation is mapped to 
the concepts.   You will see the various components that make up a complete Visual Studio designer, 
how these components are generated from the definition files, and understand how the designer 
solution is built.  Finally, you will run the generated designer, and learn how to generate code and 
reports from the models that you create with it. 

The Sample Domain Specific Language: A Business Entity Language (BEL) 
Visual domain specific languages can be used to specify business requirements. A common diagram 
type used in this area is Business Entity Diagrams. These diagram show the entities involved in a 
business process. Let’s assume we define a small domain specific language to capture the information 
we get from a conversation with a subject expert of a banking application.  
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We define a shape called “Business Entity”. Each entity has a set of attributes. For example, the 
business entity “bank account” might have attributes like “amount” and “credit line”. Business entities 
are related to each other, and we represent these relationships by lines between the business entity 
shapes.  For example, the business entity “bank account” will be related to the business entity 
“customer”. 
 
In addition to the structure of the business entities we define another shape called “business rule”, 
which captures parts of the business logic. We use the rules to describe how business entities are used 
together. For example, we have a business entity called “account” and we have a business entity called 
“transaction”, and we describe the business rules about how a transaction, which involves two 
accounts, gets approved. 
 
For the hands-on lab we define a very simple version of the Business Entity language.  A real 
production version would of course be much more fully-featured and integrated into the overall 
development lifecycle.  Different artifacts might be generated from the completed language, including 
database definitions, message formats, and user interfaces for the business entities, and skeletons for 
business logic from the rules.  In the lab you’ll see how to use the business entity model to generate a 
simple HTML report and a WinForms-based user interface. 

Task 0 – Create a DSL Extensibility Project 

• Open Visual Studio 2005 Beta 2 by clicking on the Visual Studio 2005 Beta 2 shortcut on the 
desktop.  

• Visual Studio 2005 Beta 2 opens. 

• On the File menu, point to “New …” and click Project.  

• Browse to “Other Project Types” and open the folder. 

• Select “Extensibility” in the folder “Other Project Types”. 

• Select “Domain Specific Language Designer”. 
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• Type in the name of our domain-specific language: “BizEntity”. 

• Type in the path for  the new project: “c:\dslhol”. 

• Press Enter to dismiss the “New Project” dialog box. 

• The DSL Tools wizard appears 

• Click “Next”. 

 



Page 5 

 

• On the next page select the “Blank Language” template. 

 

• On the next page, type in our desired file extension for business entity files: “biz”. 

 

• Leave the rest of the settings on this page alone. 

• You can ignore the rest of the wizard for now and just press “Finish”. 

• The DSL Tools for Visual Studio will generate the designer solution.  Be patient, this takes a little 
while. 
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Task 1 – Build an Initial Designer for Business Entities 

Building a designer requires three different steps: 

• Describe the elements of your domain in a domain model 

• Specify the notational elements for business entities  

• Define how the notation maps to your elements  

Task 1.1 – Build a Domain Model for Business Entities 

The domain model that the DSL tools wizard has put into your solution is a nearly empty one and looks 
like this: 
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The shapes in the domain model describe classes, and the lines between them describe relationships. 

In order to allow you to finish the lab in the allotted time, we are going to load in a prepared domain 
model for the business entity designer.  

• Close the domain model designer by clicking on “File | Close” 

• In the Solution Explorer, right-click on the DomainModel project, and choose “Add->Existing 
Item”. 

• Set the “Files of Type:” filter to “All Files”. 

• In the “File Name:” box, type “c:\dsl\BizEntity.dmd”.  Click the “Add” button. 

 

• Confirm you want to replace the existing file. 

• In the Solution Explorer, double-click on the “BizEntity.dmd” file you just added, which will be 
located in the DomainModel project.  The domain model will look like this: 
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This diagram defines the structure of the domain model, which is made up of classes (rounded 
rectangles) and relationships between classes (lines).  To get a better idea of what this notation 
means, let’s take a closer look at the Entity class: 

• Open up the “Entity” shape by clicking on the little “+” sign.  Note: three “Entity” shapes appear 
in the diagram because the “Entity” class is referenced by other classes; the shape you should 
click on is in the lower portion of the diagram, indicated by the red arrow in the image above. 

 

• Here we see that classes may contain value properties.  The “Entity” class has two value 
properties, “Kind” and Description”. You can click on the value properties to see details about 
them in the “Properties” window in the lower right corner of Visual Studio. 

• An entity may reference another entity. This is indicated by the dotted line labeled 
“ReferencedEntity”.  You can select the relationship in the diagram by clicking on the dotted line 
to see its details in the “Properties” window again.  Notice that the name of this relationship is 
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“Association”; the names of its two roles (ends) are ReferencedEntity and ReferringEntities.  
The roles are represented in the diagram by the small triangular and rectangular shapes 
appearing on the line.  You can also click on these to view properties about them. 

• An Entity contains Attributes. This containment is indicated by the solid line between the “Entity” 
class and the “Attribute” class, labeled “Attributes”.  You can open up the “Attribute” shape and 
have a look at its value properties. 

Task 1.2 – Describe the Notation for Business Entities  

The notation which will be used in the designer for our domain specific language is described in a XML 
file. As with the domain model the blank solution contains a default description, and for this lab we will 
load a prepared file to save time. 

• To have a look at the default XML file that was generated from the blank language template, click 
on the “BizEntity.dsldd” tab on the main window of Visual Studio. You’ll notice that it refers to the 
classes from the original domain model, such as “ConceptA”. 

 

• Close this file by clicking on “File | Close” 

• In the Solution Explorer, right-click on the “Designer” project, and choose “Add->Existing Item” from 
the context menu. 
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• Set the “Files of Type:” filter to “All Files”. 

• In the “File Name:” box, type “c:\dsl\BizEntity.dsldd”.  Click the “Add” button. 

• Confirm you want to replace the existing file. 

• Double-click on the “BizEntity.dsldd” file you just added, to open it in the XML editor.  The file will be 
located in the Designer project in the Solution Explorer.  

• The first function of the dsldd file is to define the notation for our designer.  This notation can 
include shapes which appear in the toolbox and can be dragged onto the design surface, connector 
lines which connect shapes, and more.  To make this a little more concrete, let’s look at an example 
from our “BizEntity” domain.  In the XML editor, browse down until you see a section marked with 
the <shapes> tag (line 185, about three quarters of the way through the file). 

 

• We won’t go into too much of the detail of this format in the lab, but notice that we define two 
shapes, a “BusinessRulesShape”, and an “EntityShape”.  Note that the second shape is defined 
using the <compartmentShape> tag, because we want it to have a sub-compartment for displaying 
the attributes defined on the entity. 

Task 1.3 – Map the Notation to the Domain Model 

• The second function of the dsldd file is to map the designer notation onto the domain.  In general, 
this involves mapping shapes to classes and connector lines to relationships, so that as a user 
creates shapes and connectors in the designer, they are also creating the corresponding classes 
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and relationships in the domain.  Again, let’s look at the “BizEntity” example.  Navigate to the 
<shapeMaps> tag in the XML editor, line 74, about one-third of the way through the file.  

 
 
• Notice the <class> element defined as a child the <shapeMap> element.  This specifies the class in 

the domain model which the shape maps to.  In this case it is the “Entity” class. 
• Skip the <compartmentMaps> and <iconMaps> sections for the moment. 
• Notice the <melCollectionExpression> element defined beneath the <iconMaps> element.  This 

specifies a role in the domain model that an entity must play in order to have a shape created for it.  
Another way to think of this is that it is specifying the location in the domain model we can find the 
“Entity” classes we want to map to.  In our case, we specify the “ER/Entities” role, which indicates 
that we want to create an “EntityShape” for all “Entity” instances in the model which are connected 
to the root element of our domain, which is named “ER”.  

• Notice the <shape> element defined beneath the <class> element.  This specifies the shape in this 
mapping, in this case the “EntityShape”. 

• Finally, the <textMaps>, <comparmentMaps>, and <iconMaps> sections map parts of the domain 
model to text, compartments, and icons which appear on a shape.  Notice the use of <expression> 
elements within these sections to define the mappings. 

Task 2 – Generate the Code for the Designer and Build the Solution 

Because we have modified the domain model and notation, we must now regenerate code and build 
the solution in order to update the designer.   First, there is one more file that needs to be added to the 
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solution, which contains some required strings and icon resources used by the designer. 
 
• In the Solution Explorer, right-click on the Diagram folder in the Designer project, and choose “Add-

>Existing Item”. 

 

• In the “File Name:” box, type “c:\dsl\BizEntityDesigner.Resource.resx”.  Click the “Add” button. 

• Confirm that you want to replace the existing file. 

Now we are ready to generate code and build. 

• Click on the “Transform All Templates” button in the toolbar (shown below circled in red).  Note that 
this command may take a little while to complete. 
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• Now build the updated solution, by selecting the “Build Solution” command from the Build menu.  

Note that this command may take a little while to complete the first time. 

 

• Issue:  There is a known issue which causes code generation to fail every so often.  If you see 
failures in either the code generation step or the build step, try repeating these steps again. 

Task 3 – Run the Business Entity Designer 

Now that the designer is generated and built, let’s take a quick look at some of its features.   

• Press Ctrl-F5 to run the designer.  This will bring up a second instance of Visual Studio with a 
project open named “BizEntityDebugging”. 

• Notice that there is a file named “Empty.biz” included in this project.  Double-click to open that file in 
your designer.  Your designer will look like this: 
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• To get a feel for how the designer works, drag two “Entity” shapes from the toolbox onto the blank 

diagram surface.  To do this, left-click on the “Entity” tool, hold the mouse button down and drag to 
the document area, and release. 

• Click on the “Association” tool in the toolbox.  Click on the first entity shape you added, then on the 
second shape to draw an association line between them.  The result should look something like 
this: 
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• Notice that our notation defines a shape which correspond to an Entity in the domain model, and a 
connector line which corresponds to an association between entities. 

• Feel free to explore the target designer a little more at this point.  Some things to try: 

• Double-click on the “NewEntity” text in the shape header to rename it using in-place editing. 
• Right-click on the shape header and select “Add->Attribute” from the context menu to add a new 

attribute to the shape.  Note that according to our notation, attributes on entities are placed in a 
compartment within the entity shape. 

• Click on the association line, and set the “SourceMultiplicity” and/or “TargetMultiplicity” 
properties from the property grid.  Note that the labels on the diagram lines are updated to 
match. 

• When you’re finished, close the designer by selecting “File->Close” from the main menu.  When 
prompted, do NOT save changes to the “Empty.biz” file, because we are going to modify the 
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domain model in the next task, which will result in a change to the format of this file. 

• Close the second IDE by selecting “File->Exit” from the main menu. 

Task 4 – Add a new property 

Suppose we decide that the current model of the BizEntity domain is inadequate.  In this task we will 
extend the model add a new property to a class in the domain model.  In fact, we are going to add a 
new property to the “Association” relationship. The domain model designer provides the facility to show 
relationships as though they were themselves classes, in order to be able to add properties to them. 
You can also create relationships to relationships and inherit from relationships, although we won’t do 
either in this lab. 

• Click on the “BizEntity.dmd” tab to take you back to the domain model designer.  At the top of the 
diagram you should see a brown class called “Association”.  It is brown because this is a 
relationship, not a normal class.  Open up the “Association” shape by clicking on the little “+” sign. 

• Invoke the “View->Toolbox” command from the main menu to bring the Toolbox window back into 
view. 

 

Notice that the “Association” class defines two properties, “SourceMultiplicity” and 
“TargetMultiplicity”, which you have already seen show up at the ends of association lines in the 
Business Entity designer.   

• Left-mouse on the value property tool in the toolbox, drag to the main body of the Association class 
(the brown part), and release the mouse button.  A new property called “Property1” should appear 
in the flap. 
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• Click on “Property1” to select it.  You should see that it is selected in the property browser at the 
lower right of Visual Studio.  In this browser, find the “Name” property under the “Misc” category, 
and edit it to read “RelationshipType”. 

 

• Press Enter to commit the change.  The new name should be shown on the diagram. 

 

• Save the “BizEntity.dmd” file. 

Task 5 – Introduce notation for the new property 

• Now we need to modify the notation file so that the new property shows up on the diagram.  
Double-click on the BizEntity.dsldd file in the Solution Explorer to bring the XML file to the front. 
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Scroll down in the file to find the definition of the connector called “AssociationLink” (line 152). 

• Note that you may want to close the Visual Studio Toolbox at this point to give the XML editor more 
room.  You can do this by clicking the “X” in the upper right corner of the Toolbox window, located 
on the left side of the screen. 

• In this section you will see that within the <decorators> section there are two <connectorText> 
elements defined. Each of these represents a textual decorator on the connector that is mapped to 
the Association relationship.  You will introduce a new one of these for the new property. 

• Using copy and paste, duplicate the second <connectorText> element.  In the new element, change 
the name from “SourceLabel” to “TypeLabel” and the position from “SourceBottom” to “TargetTop”. 
Leave the defaultTextId as it is.  

<decorators> 
<connectorText name="TargetLabel" position="TargetBottom" defaultTextId="DefaultLabelText"/> 
<connectorText name="SourceLabel" position="SourceBottom"  defaultTextId="DefaultLabelText"/> 
<connectorText name="TypeLabel" position="TargetTop" defaultTextId="DefaultLabelText"/> 

</decorators> 

• The previous step defined a textual decorator in the notation, connected to the target end of the 
AssociationLink connector, and positioned at the top.  Now we must define a mapping from this 
decorator to our new property. Scroll up the file until you find the connectorMap for the 
AssociationLink connector (line 18).  This has several parts: a <class>, a <connector>, a 
<sourceMap>, a <targetMap>, and some <textMaps>. 

• Using copy and paste, duplicate the complete second <textMap> element (8 lines).  In the new 
element, change “TargetLabel” to “TypeLabel”, and “TargetMultiplicity” to “RelationshipType”. Leave 
everything else as it is. The changes you should make are indicated in bold red in the XML 
fragment below.  By doing this, you have associated the new decorator with the new property. 

<connectorTextMap> 
 <textDecorator>…Diagram/Connectors/AssociationLink/Decorators/TypeLabel</textDecorator> 
 <valueExpression> 
  <valuePropertyExpression> 
   <valueProperty>…BizEntity/Association/RelationshipType</valueProperty> 
  </valuePropertyExpression> 
 </valueExpression> 
</connectorTextMap> 

• Save the “BizEntity.dsldd” file. 

• Because you have changed the domain model and notation, you must regenerate the code to build 
the designer.  Just as you did earlier, find the “Transform All Templates” button in the Solution 
Explorer toolbar, and click it.  As before, this command may take a little time to complete.  If you get 
any errors at this point, it may mean that you made a mistake with the instructions for modifying the 
notation file. 
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• Now build the updated solution, by selecting the “Build Solution” option from the Build menu. 

 

Task 6 – Build a Business Entity Model with your new Designer 

Now that we’ve modified the domain and the notation, let’s use the updated designer to build a portion 
of the Business Entity Diagram shown in the introduction to this lab. 

• Press Ctrl-F5 to run the designer.  As before, this will bring up the BizEntityDebugging project in a 
second instance of Visual Studio. 

• Double-click on the file named “Empty.biz” in the Solution Explorer to open it.  This will bring up the 
empty design surface as before.  We want to build the diagram shown below: 
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• To start, drag an “Entity” shape from the toolbox onto the design surface.  Double-click on the 

“NewEntity” header text on the shape and rename it to “Customer”.  Press Enter to commit the 
change. 

• To indicate that this is a persistent entity, double-click on the text “MyType” and enter the text 
“Persistent”.  Press Enter to commit the change. 

• Right-click on the shape header area and choose “Add->Attribute” from the context menu. 
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• Type in “Name” as the name of the new attribute, and press Enter to commit the change. 

• Use steps similar to the above to create the “Account” Entity, with “Credit Line” and “Amount” 
attributes. 

• In the toolbox, click on the “Association” tool.  Click first on the “Customer” entity, and then on the 
“Account” entity to create the association between “Customer” and “Account.” 

• Make sure the connector you just added is selected, and press F4 to bring up the property grid.  Set 
the value of the “SourceMultiplicity” property to “1”, to indicate that in our example, each account is 
associated with a single customer. 

 

• Also notice the “RelationshipType” property that now appears in the property grid.  This is a result of 
adding the new property to the domain model in task 4.  Type some text into this property, and 
notice that it appears on the diagram.  This is a result of modifying the designer notation in task 5. 

• Press Ctrl-S to save the business entity diagram. 

Task 7 – Generate a HTML report of your Model with your new Designer 

Now that we have built a sample business entity diagram, you may be wondering what you can do with 
it.  In this task we’ll demonstrate how to use the text generation functionality included with the DSL 
toolkit to generate artifacts from our model.  Text generation works via template files, which contain 
both templatized text to be generated, and logic which controls how that generation happens.  Let’s 
look at an example which takes a .biz file as input, and generates an HTML report over the domain 
defined in that file. 

• Right-click on the “BizEntityDebugging” project in the Solution Explorer, and choose “Add->Existing 
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Item…” from the context menu. 

 

• Set the “Files of Type:” filter to “All Files”. 

• Type “c:\dsl\BizEntity.ReportTemplate” into the “File name:” box, and press “Add”. 

• Double-click on the newly added “BizEntity.ReportTemplate” file in the Solution Explorer to open it 
in the text editor (you may want to close the Toolbox window at this point to give the text editor 
more room).  We will examine the details of this file to see how code generation works. 

• The first three lines, shown below, set up some parameters for the code generator, we won’t 
concern ourselves with the details of those here: 

<#@ template 
inherits="Microsoft.VisualStudio.TextTemplating.VSHost.ModelingTextTransformation"#> 
<#@ output extension=".htm" #> 
<#@ er processor="BizEntityDirectiveProcessor" requires="fileName='Empty.biz'" #> 
 

• The next five lines are standard HTML, these will be generated to the output file as static header 
text: 

<html> 
<body> 
<h1>A report on the contents of Empty.biz</h1>  
<p>For this report to work…</p> 
<h2>Entities:</h2> 
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• Now things get interesting.  Notice the <# and #> tags which delimit sections of the file.  Logic which 
controls text generation in placed within these tags (if you are familiar with ASP pages, this is a 
similar idea).  In this case, the logic is written in C#, but it may be written in Microsoft Visual Basic® 
.NET as well.  To make clearer what’s going on, we’ve grayed out the text to be generated below so 
you can just focus on the control flow; if you are familiar with C#, you will notice that what’s left are 
two nested foreach loops, the outer one over a collection called “Entities” and the inner one over a 
collection called “Attributes”.  As you may have guessed, these collections contain elements 
instances from the domain model. 

<# 

        foreach ( Entity e in this.ER.Entities )  
        {  
#>  
        <h3><#=e.Name#></h3> 
        <p>Kind: <#=e.Kind#></p> 
<# 
            foreach ( Attribute a in e.Attributes )  
            {  
#> 
        <p>Attribute: <#=a.Name#> 
<#  
            }  
#> 
<#  
        }  

#>  

• Now let’s look at the same section of the file, but focus on the generated text.  As in the static 
header, these lines are HTML, except for the <#= #> tags, which indicate parameters that will be 
filled in by values from the domain model during generation.  Note the use of the properties “Name” 
and “Kind” to indicate which values from the domain model will be used.  Also note the use of the 
foreach loop iteration variables “e” and “a” to indicate which Entity and Attribute instances are used 
in the parameterization (these have been bolded for emphasis).   

<# 
        foreach ( Entity e in this.ER.Entities )  
        {  
#>  
        <h3><#=e.Name#></h3> 
        <p>Kind: <#=e.Kind#></p> 
<# 
            foreach ( Attribute a in e.Attributes )  
            {  
#> 
        <p>Attribute: <#=a.Name#> 
<#  
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            }  
#> 
<#  
        }  

#>  

• Next, let’s run the template.  Click on the “BizEntity.ReportTemplate” file in the Solution Explorer. 

• In the Properties window, enter the value “TextTemplatingFileGenerator” for the “Custom Tool” 
property, and press Enter. 

 

• Notice that a “+” appears next to the “BizEntity.ReportTemplate” file in the Solution Explorer.  Click 
on this to reveal the generated file, “BizEntity.htm”.  Right-click on this file and choose “View in 
Browser” from the context menu to see it rendered in Internet Explorer. 
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• Notice that the Entities and Attributes defined in the business entity diagram appear in this report.  
Due to the interaction logic in the template, if we were to add additional Entities or Attributes, and 
re-run text generation, those additional items would appear in the report.  

• Close the “BizEntity.htm” file. 

Task 8 – Generate Code for Dialog Boxes from your Model 

HTML artifacts are not the only type that can be generated.  In this task we will see how to generate 
source code artifacts as well (as you may have guessed, the source code for business entity designer 
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was generated from the .dsldd and .dmd files in this manner).  As an example, we will generate some 
simple Microsoft Windows® Forms-based classes that might be used in the UI of an application 
supporting the business process defined in a business entity diagram. 

• Right-click on the “BizEntityDebugging” project in the Solution Explorer, and choose “Add->Existing 
Item…” from the context menu. 

• Type “c:\dsl\EntityForm.cstemplate” into the “File name:” box, and press “Add”. 

• Add the file “c:\dsl\Program.cstemplate” to the project in the same manner 

• Click on the “EntityForm.cstemplate” file in the Solution Explorer. 

• In the Properties window, enter the value “TextTemplatingFileGenerator” for the “Custom Tool“ 
property, and press Enter. 

 

• Click on the “Program.cstemplate” file in the Solution Explorer. 

• In the Properties window, enter the value “TextTemplatingFileGenerator” for the “Custom Tool” 
property, and press Enter. 

• Code should be generated for both templates when the “Custom Tool” property is set.  To 
regenerate the code, you can click on the “Transform All Templates” button in the Solution Explorer 
toolbar (circled in red below). 
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• Set up the “BizEntityDebugging” solution to launch the “BizEntityDebugging” project.  Right-click on 
the solution node in the Solution Explorer, and choose the “Properties” command. 

 

• Expand the “Configuration Properties” node in the Property Pages dialog box, and select the 
“Configuration” node.  Check the “Build” checkbox. 
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• Press “OK” on the Property Pages dialog box. 

• Press F5 to build and run the “BizEntityDebugging” project.  You should see two forms pop up.  
Note that the title of each form corresponds to an entity defined in the business entity diagram, and 
there are editable text boxes corresponding to the attributes defined on each entity. 

• By now you may be running out of time for this lab, but if you still have a few extra minutes, there 
are a couple things you can do: 

o Examine the .cstemplate files and the resulting generated code.  Note that the template files 
look similar to the .ReportTemplate file we examined in Task 7, except that the text to be 
generated is C# code rather than HTML. 

o Open the “Entity.biz” file and modify the diagram by adding more entities or attributes.  Save 
the diagram and invoke “Transform All Templates” to see the effects of these changes on 
the generated artifacts. 

 


